ＡＰＩリスト

クッキーライブラリ

概要

クッキーに対するアクセス関数群

ソースファイル

imart/csjs/im_cookie.js

(URLの関係で呼び出し時のソースパスは変わります。ページベース開発モデルの場合は、csjs/im_cookie.js でリンクできます。)

構造図

      getCookie()
      removeCookie()
      setCookie()

      使用例

使用例

プレゼンテーション・ページで
<SCRIPT src="csjs/im_cookie.js"></SCRIPT>

<SCRIPT language="JavaScript1.2">
// クッキーに "ABC" というキーで "XYZ" というデータを保存
setCookie("ABC", "XYZ");
// クッキーから "ABC" というキーに該当するデータを取得
var sABC = getCookie("ABC");
// クッキーから "ABC" というキーに該当するデータを削除
removeCookie("ABC");
</SCRIPT>

詳細

getCookie()

  • 型

    文字列型関数
    (String) getCookie((String) sName) ;

  • 概要

    クッキーの値を取得する関数

  • 入力値

    sName：参照名称(文字列)

  • 返却値

    参照名称に対応した値

  • 詳細

    指定参照名称に該当するクッキー内に保存された値を返却します。
    指定参照名称で値を取得できなかった場合には、null 値が返されます。

removeCookie()

  • 型

    void 型関数
    (void) removeCookie( (String) sName) ;

  • 概要

    クッキーの値を消去する関数

  • 入力値

    sName：参照名称(文字列)

  • 返却値

    なし

  • 詳細

    クッキー内に保存されているデータのうち、指定の参照名に該当するデータを消去します。
    実際には、クッキーの有効期限を過去に設定し直す事によって、その値自体を無効とし、表面上見えない状態にしているだけです。

setCookie()

  • 型

    void 型関数
    (void) setCookie((String)sName, (String)sValue, [(Date)dExpires[, (String)sDomain[, (String)sPath[, (boolean)bSecure]]]]) ;

  • 概要

    クッキーに値を保存するメソッド

  • 入力値

    sName : 参照名称(必須)
    sValue : 値(必須)
    dExpires: 利用期限(任意)
    sDomain : 有効ドメイン(任意)
    sPath : 設定可能階層(任意)
    bSecure : セキュリティの有無(任意)

  • 返却値

    なし

  • 詳細

    指定のデータをクッキーに保存します。


ＡＰＩリスト

DATE ライブラリ

概要

日付（時間）データ操作関数群

ソースファイル

imart/csjs/im_date.js

(URLの関係で呼び出し時のソースパスは変わります。ページベース開発モデルの場合は、csjs/im_date.js でリンクできます。)

構造図

      isDateData()
      isLeapYear()

      使用例

使用例

プレゼンテーション・ページで
<SCRIPT src="csjs/im_window.js"></SCRIPT>

<!-- ボタンを押すと、2002年02年29日が日付として正しいかどうか判定します -->
<INPUT type="button" onClick="alert(isDateData(2002, 02, 02));">>

詳細

isDateData()

  • 型

    真偽値型関数
    (boolean) isDateData((Number) nYear, (Number)nMonth, (Number)nDay, (Number)nHour, (Number)nMinutes, (Number)nSecond) ;

  • 概要

    日付として正しいかどうか判定します。

  • 入力値

    (number) nYear : 年(必須) (number) nMonth : 月(必須) (number) nDay : 日(必須) (number) nHour : 時間(任意) (number) nMinutes: 分(任意) (number) nSecond : 秒(任意)

  • 返却値

    指定の数値データが日付として正しい場合 true、そうでない場合false。

  • 詳細

    与えられた数値の組合わせが日付（および時間）を表す情報として正しいかどうかを判定します。この関数は、閏年の判定も行っているので、２月２９日に関しても正しく判定することができます。

isLeapYear()

  • 型

    真偽値型関数
    (boolean) isLeapYear((Number) nYear) ;

  • 概要

    指定の年が閏年かどうか判定します。

  • 入力値

    (number) nYear : 年(必須)

  • 返却値

    指定の年が閏年の場合 true、そうでない場合false。

  • 詳細

    与えられた数値を西暦年として閏年計算をします。


ＡＰＩリスト

イベントライブラリ

概要

イベントに関する関数群

ソースファイル

imart/csjs/im_event.js

(URLの関係で呼び出し時のソースパスは変わります。ページベース開発モデルの場合は、csjs/im_event.js でリンクできます。)

構造図

      isDoubleClick()

      使用例

使用例

プレゼンテーション・ページで
    <HTML>

        <HEAD>

            <SCRIPT src="csjs/im_window.js"></SCRIPT>

            <SCRIPT language="JavaScript1.2">

                function chkClick(){

                    if(isDoubleClick()){

                        window.alert("WARNING: Double-click !!");

                    }

                }

            </SCRIPT>

        </HEAD>

        <BODY>

            <FORM>

                <INPUT type="button" onClick="chkClick();">

            </FORM>

        </BODY>

    </HTML>

詳細

isDoubleClick()

  • 型

    真偽値型関数
    (boolean) isDoubleClick() ;

  • 概要

    ダブルクリックされたかどうか判定します。

  • 入力値

    なし

  • 返却値

    ダブルクリックされたと判断された場合 true、そうでない場合 false。

  • 詳細

    直前に関数実行されてから一定時間（1/2秒）以内に再び関数呼び出しされた場合、ダブルクリックされたと判断して真値を返します。

    この関数は、JavaScript のタイマー機能を利用しています。まだ一度も関数実行されていない状態で関数呼び出しされた場合、タイマーにより時間計測します。時間計測している間に関数呼び出しされた場合、その呼び出し回数に関係なく必ず true を返します。

    タイマーによる時間計測を開始してから十分な時間（およそ1/2秒）経過するとフラグが解除されます。
    フラグが解除された状態で関数呼び出しされると、再びタイマーにより時間計測を開始して true を返します。時間計測中に関数呼び出しされた場合、false を返します。時間計測を開始して十分な時間（およそ1/2秒）が経過するとフラグが解除されます。

    以降、上記プロセスが関数呼び出しのたびに繰り替えされます。


ＡＰＩリスト

実数計算ライブラリ

概要

小数演算を可能にするオブジェクト。

ソースファイル

imart/csjs/im_realnumber.js

(URLの関係で呼び出し時のソースパスは変わります。ページベース開発モデルの場合は、csjs/im_realnumber.js でリンクできます。)

構造図

    RealNumber
      ├ getAdd()
      ├ getDiv()
      ├ getMlt()
      ├ getSub()
      ├ get()
      └ toString()

      使用例

使用例

プレゼンテーション・ページで
<SCRIPT src="csjs/im_realnumber.js"></SCRIPT>

<SCRIPT language="JavaScript1.2">
//変数 oRN を 2.1 で初期化
var oRN = new RealNumber( 2.1 );
//加算 oRN + 0.9 を実行し、その数字データ(String)を取得する。
var nAns = oRN.getAdd(0.9).toString();
</SCRIPT>

詳細

RealNumber(nTarget)

  • 型

    コンストラクター・メソッド
    (Object) RealNumber( (number) nTarget) ;

  • 概要

    指定の数値を表すインスタンスを生成

  • 入力値

    第1引数：数値

  • 詳細

    引数に指定した数値を表す実数オブジェクトのインスタンスを生成する。

getAdd(nTarget)

  • 型

    Object型メソッド
    (Object) getAdd( (number) nTarget) ;

  • 概要

    オブジェクトの持つ数値データと加法演算するメソッド

  • 入力値

    第1引数：演算数値

  • 返却値

    RealNumber

  • 詳細

    このオブジェクトのもつ数値と足し算をしする。
    返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しない。

getDiv(nTarget)

  • 型

    Object型メソッド
    (Object) getDiv( (number) nTarget) ;

  • 概要

    オブジェクトの持つ数値データと除法演算するメソッド

  • 入力値

    第1引数：演算数値

  • 返却値

    RealNumber

  • 詳細

    このオブジェクトのもつ数値と割り算する。
    返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しない。

getMlt(nTarget)

  • 型

    Object型メソッド
    (Object) getMlt(nTarget) ;

  • 概要

    オブジェクトの持つ数値データと乗法演算するメソッド

  • 入力値

    第1引数：演算数値

  • 返却値

    RealNumber

  • 詳細

    このオブジェクトのもつ数値と掛け算をしする。
    返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しない。

getSub(nTarget)

  • 型

    Object型メソッド
    (Object) getSub(nTarget) ;

  • 概要

    オブジェクトの持つ数値データと減法演算するメソッド

  • 入力値

    第1引数：演算数値

  • 返却値

    RealNumber

  • 詳細

    このオブジェクトのもつ数値と引き算をする。
    返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しない。

toString()

  • 型

    String型メソッド
    (String) toString() ;

  • 概要

    オブジェクトの持つ数値データを文字列として取得するメソッド

  • 入力値

    第1引数：なし

  • 返却値

    数値データ（文字列）

  • 詳細

    このオブジェクトのもつ数値情報を文字列で返す。

get()

  • 型

    Number型メソッド
    (Number) get() ;

  • 概要

    オブジェクトの持つ数値データを取得するメソッド

  • 入力値

    第1引数：なし

  • 返却値

    数値データ

  • 詳細

    このオブジェクトのもつ数値情報を返す。


ＡＰＩリスト

ウィンドウライブラリ

概要

ウィンドウ操作関数群

ソースファイル

imart/csjs/im_window.js

(URLの関係で呼び出し時のソースパスは変わります。ページベース開発モデルの場合は、csjs/im_window.js でリンクできます。)

構造図

      openNewWindow()

      使用例

使用例

プレゼンテーション・ページで
<SCRIPT src="csjs/im_window.js"></SCRIPT>

<SCRIPT language="JavaScript1.2">
// 名称が "MY_WIN" というウィンドウを新規に立ちあげる
openNewWindow("MY_WIN", "status=yes,resizable=yes");
</SCRIPT>

詳細

openNewWindow()

  • 型

    オブジェクト型関数
    (Object) openNewWindow((String) name, (String) status) ;

  • 概要

    新しいウィンドウを開く関数

  • 入力値

    name：ウィンドウ参照名称(必須)
    status：ウィンドウ・ステータス(必須)

  • 返却値

    新規に開いたウィンドウのハンドル(Window オブジェクト)

  • 詳細

    指定された条件で新しいウィンドウを開きます。
    この関数は、window.open() と同等の振る舞いをします。引数 status には、window.open() ＡＰＩの第３引数に与える引数と同様の文字列データ(詳細は、JavaScript のリファレンスを参照して下さい)を渡して下さい。
    この関数は、JavaScript の window.open() と等しい値を返します。

    指定された参照名で、すでにウィンドウが開かれている場合、新規ウィンドウが開かれない場合があります。

    この関数を利用して開いたウィンドウには、『Please wait...』という画面が表示されます。


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし
Copyright © 2000-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream の使用

ExtendedInputStream を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedInputStream の使用

ExtendedInputStream を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 ExtendedInputStream ExtendedSocket.getInputStream()
入力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の使用

ExtendedOutputStream を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedOutputStream の使用

ExtendedOutputStream を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 ExtendedOutputStream ExtendedSocket.getOutputStream()
出力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter の使用

jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader の使用

jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter の使用

jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.Directory の使用

Directory を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file での Directory の使用

jp.co.intra_mart.common.aid.jdk.java.io.file での Directory のサブクラス
 class ExtendedDirectory
File インスタンスを作成するためのファクトリクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory の使用

ExtendedDirectory を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file での ExtendedDirectory の使用

ExtendedDirectory を返す jp.co.intra_mart.common.aid.jdk.java.io.file のメソッド
ExtendedDirectory | ExtendedDirectory.childDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedDirectory | ExtendedDirectory.findDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile の使用

ExtendedFile を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file での ExtendedFile の使用

ExtendedFile を返す jp.co.intra_mart.common.aid.jdk.java.io.file のメソッド
ExtendedFile | ExtendedDirectory.childFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected ExtendedFile | ExtendedDirectory.findFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Directory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス Directory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
ExtendedDirectory
public class Directory
extends File

このクラスは、ディレクトリを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ディレクトリである場合に利用することができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
Directory(File parent, String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(String parent, String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
Collection | childDirectories() この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
Collection | childFiles() この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
boolean | deleteAll() このディレクトリパスを削除します。
void | deleteChilds() このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。
Collection | files(int depth) この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | paths(int depth) この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Directory

public Directory(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(File parent,
                 String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(String parent,
                 String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

childDirectories

public Collection childDirectories()
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ディレクトリを表す java.io.File クラスのインスタンスです。

戻り値:
ディレクトリパスを繰り返し処理する反復子

childFiles

public Collection childFiles()
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

戻り値:
ファイルパスを繰り返し処理する反復子

deleteAll

public boolean deleteAll()
                  throws IOException
このディレクトリパスを削除します。 このディレクトリがファイルまたはサブディレクトリを持つ場合、 それらもすべて削除します。

このメソッドは複数のパスを削除しますが、すべてのパスを削除したか、 またはしないことを保証するものではありません。 このディレクトリパスの削除に失敗した場合でも、 このディレクトリに含まれるいくつかのパスが削除される場合があります。

戻り値:
このディレクトリパスの削除に成功した場合 true。それ以外の場合 false。
例外:
IOException - このディレクトリパスに含まれるいずれかのパスの削除に失敗した場合。

deleteChilds

public void deleteChilds()
                  throws IOException
このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。 このサブディレクトリに含まれるファイルやサブディレクトリも 再帰的に検索し、すべて削除します。

このメソッドが false を返した場合でも、 いくつかのパスが削除される場合があります。

例外:
IOException - このディレクトリパスに含まれるいずれかのパスの削除に失敗した場合。

paths

public Collection paths(int depth)
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルまたはディレクトリを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合

files

public Collection files(int depth)
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス ExtendedDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
すべての実装インタフェース:
Comparable, Serializable
public class ExtendedDirectory
extends Directory

File インスタンスを作成するためのファクトリクラスです。

このクラスは、指定のディレクトリを親とすして、相対パスにより解決される 抽象パスを表す File インスタンスを生成する機能を提供します。 生成された File インスタンスは、オブジェクト内にプールされるため、 同じパスを繰り返し利用ようなプログラムで利用することにより、 メモリリソースを節約することができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedDirectory(File parent, String path, int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(String pathname, int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
メソッドの概要
void | archive(File f) このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(File f, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(OutputStream out) このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(OutputStream out, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out) このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
ExtendedDirectory | childDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
ExtendedFile | childFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
File | childPath(String path) このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
protected ExtendedDirectory | findDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedFile | findFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected File | findPath(String path) このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
void | reset() キャッシュ領域をクリアします。
クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory から継承したメソッド
childDirectories, childFiles, deleteAll, deleteChilds, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedDirectory

public ExtendedDirectory(String pathname,
                         int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
pathname - ディレクトリパス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合

ExtendedDirectory

public ExtendedDirectory(File parent,
                         String path,
                         int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 このオブジェクトのパスは、parent を親ディレクトリとした 子抽象パス path により解決されます。
引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
parent - 親ディレクトリ
path - パス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合
メソッドの詳細

childFile

public ExtendedFile childFile(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

findFile

protected ExtendedFile findFile(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

このメソッドは、childFile メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

childDirectory

public ExtendedDirectory childDirectory(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。 このメソッドは、このオブジェクトのプール許容値と等しい プール許容値を持つ ExtendedDirectory のインスタンスを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

findDirectory

protected ExtendedDirectory findDirectory(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

このメソッドは、childDirectory メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

childPath

public File childPath(String path)
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

findPath

protected File findPath(String path)
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

このメソッドは、childPath メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

reset

public void reset()
キャッシュ領域をクリアします。

archive

public void archive(File f)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(File f,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。 ファイルに出力されるファイルは、フィルタの基準を満たす必要があります。 圧縮されるファイルは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
filter - ファイル名フィルタ
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス ExtendedFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile
すべての実装インタフェース:
Comparable, Serializable
public class ExtendedFile
extends File

このクラスは、ファイルを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ファイルである場合に利用することができます。

導入されたバージョン:
version 5.0
関連項目:
File, ExtendedDirectory, 直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedFile(File parent, String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(String parent, String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
void | append(byte[] b) 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | append(String str) デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | append(String str, String enc) 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
byte[] | getBytes() この抽象パスが表すファイルからデータを読み込みます。
Iterator | readLines() ファイルの行を繰り返し処理する反復子を作成します。
Iterator | readLines(String enc) ファイルの行を繰り返し処理する反復子を作成します。
String | readString() このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
String | readString(String enc) このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
void | write(byte[] b) 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | write(String str) デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | write(String str, String enc) 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedFile

public ExtendedFile(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(File parent,
                    String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(String parent,
                    String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

getBytes

public byte[] getBytes()
                throws FileNotFoundException,
                       IOException
この抽象パスが表すファイルからデータを読み込みます。

戻り値:
ファイルの内容
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString()
                  throws FileNotFoundException,
                         IOException
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、デフォルトの文字エンコーディングから Unicode に変換して返します。

戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString(String enc)
                  throws FileNotFoundException,
                         UnsupportedEncodingException,
                         IOException
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、指定の文字エンコーディングから Unicode に変換して返します。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines()
                   throws FileNotFoundException,
                          IOException
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、デフォルトの文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines(String enc)
                   throws FileNotFoundException,
                          UnsupportedEncodingException,
                          IOException
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、指定の文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

write

public void write(String str)
           throws IOException
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  String enc)
           throws UnsupportedEncodingException,
                  IOException
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(String str)
            throws IOException
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

append

public void append(String str,
                   String enc)
            throws UnsupportedEncodingException,
                   IOException
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(byte[] b)
            throws IOException
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

バイトは、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対してバイトを追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成してバイトをファイルの先頭に書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合

write

public void write(byte[] b)
           throws IOException
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.io.file (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.java.io.file
クラス
Directory
ExtendedDirectory
ExtendedFile


jp.co.intra_mart.common.aid.jdk.java.io.file (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

参照:
説明

クラスの概要
Directory | このクラスは、ディレクトリを扱う時に便利な機能を提供します。
ExtendedDirectory | File インスタンスを作成するためのファクトリクラスです。
ExtendedFile | このクラスは、ファイルを扱う時に便利な機能を提供します。

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.java.io.file クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file の使用

jp.co.intra_mart.common.aid.jdk.java.io.file を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file により使用される jp.co.intra_mart.common.aid.jdk.java.io.file のクラス
Directory
このクラスは、ディレクトリを扱う時に便利な機能を提供します。
ExtendedDirectory
File インスタンスを作成するためのファクトリクラスです。
ExtendedFile
このクラスは、ファイルを扱う時に便利な機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


BASE64DecodeInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64DecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
public class BASE64DecodeInputStream
extends FilterInputStream

このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、BASE64 デコードされ read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
BASE64DecodeInputStream(InputStream in)
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeInputStream

public BASE64DecodeInputStream(InputStream in)
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BASE64DecodeOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64DecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
public class BASE64DecodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 デコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64DecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeOutputStream

public BASE64DecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が ASCII 文字の範囲に含まれない場合（ASCII のコントロールコードの場合も含む）や不正なコードが指定された場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BASE64EncodeOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64EncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
public class BASE64EncodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 エンコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64EncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
メソッドの概要
void | close() ストリームを閉じます。
void | finish() 出力ストリームへのエンコードデータの書き込みを終了します。
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、3 バイトのデータを受け取るとエンコードされたバイトを 出力ストリームに書き込みます。入力されたバイトが 3 バイトに満たない 場合は、入力されたバイトが合計で 3 バイトになるまでバッファに 溜め込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

finish

public void finish()
            throws IOException
出力ストリームへのエンコードデータの書き込みを終了します。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。 もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。
このメソッドは、finish メソッドを呼び出した後、 スーパークラス(java.io.FilterOutputStream)の close メソッドを呼び出します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ExtendedInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
public class ExtendedInputStream
extends InputStream

このクラスは、標準の入力ストリームを拡張した機能を提供します。

このクラスは、jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream により 書き出されたストリームを読み込むための実装を提供します。
このクラスの各メソッドは、データをストリームから読み込むときに、 java.io.DataInputStream または java.io.ObjectInputStream の 適切なメソッドを使います。

データをストリームに書き出したときに使ったメソッドに対応した 適切なメソッドを利用することにより、データを読み込むことができます。

このクラスを jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream と対で使うことにより、 データをファイルに保存したり、ネットワークにより他のプロセスへ データを転送することができます。

jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の writeObject メソッドにより 書き出されたオブジェクトは、readObject メソッドにより インスタンス化することができます。 この時、インスタンスに必要なクラスが存在している必要があります。

導入されたバージョン:
version 5.0

コンストラクタの概要
ExtendedInputStream(InputStream in)
入力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
入力ストリームを構築します。
メソッドの概要
void | close() 入出力ストリームおよびソケットを閉じます。
boolean | isClosed() この入出力ストリームが閉じられているかチェックします。
int | read() データ取得。
int | read(byte[] b, int off, int len) データ取得。
boolean | readBoolean() boolean 型データ取得。
int | readInt() int 型データ取得。
long | readLong() long 型データ取得。
Object | readObject() Object の取得。
String | readString() 文字列の取得。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedInputStream

public ExtendedInputStream(InputStream in)
                    throws IOException
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedInputStream

public ExtendedInputStream(InputStream in,
                           ErrorEventListener listener)
                    throws IOException
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

read

public int read()
         throws IOException
データ取得。

入力ストリームから次のバイトのデータを取得します。

戻り値:
取得したバイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(), ExtendedOutputStream.write(int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
データ取得。

入力ストリームから len バイトまでのデータをバイト配列に 読み込みます。

パラメータ:
b - バイト配列
off - データの開始オフセット
len - 読み込むバイト数
戻り値:
取得したバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(byte[], int, int), ExtendedOutputStream.write(int)

readInt

public int readInt()
            throws IOException
int 型データ取得。

基本データ型の整数データを読み込みます。

戻り値:
int 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readInt(), ExtendedOutputStream.writeInt(int)

readLong

public long readLong()
              throws IOException
long 型データ取得。

基本データ型の長整数データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readLong(), ExtendedOutputStream.writeLong(long)

readBoolean

public boolean readBoolean()
                    throws IOException
boolean 型データ取得。

基本データ型の真偽値データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readBoolean(), ExtendedOutputStream.writeBoolean(boolean)

readObject

public Object readObject()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
Object の取得。

戻り値:
入力して復元したオブジェクト
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ObjectInputStream.readObject(), ExtendedOutputStream.writeObject(Object)

readString

public String readString()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
文字列の取得。

このメソッドは、jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスの writeString メソッドを使って書き込んだデータを読み込むための メソッドです。他の方法で書き込んだデータを読み込むことはできません。

戻り値:
入力した文字列
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ExtendedOutputStream.writeString(String)

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ExtendedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
public class ExtendedOutputStream
extends OutputStream

このクラスは、標準の出力ストリームを拡張した機能を提供します。

このクラスの各メソッドは、データをストリームに書き出すときに、 java.io.DataOutputStream または java.io.ObjectOutputStream の 適切なメソッドを使います。
writeObject メソッドを使ってオブジェクトをストリームに書き出す 場合、ストリームに書き込めるのは java.io.Serializable インタフェースを サポートするオブジェクトに限ります。それ以外のオブジェクトを ストリームに書き込もうとした場合、例外がスローされます。

この出力ストリームに書き込んだデータを入力する場合、 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream を利用する必要があります。 他の入力ストリームから読み込んだ場合例外がスローされることがあります。

導入されたバージョン:
version 5.0
関連項目:
ExtendedInputStream

コンストラクタの概要
ExtendedOutputStream(OutputStream out)
出力ストリームを構築します。
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
出力ストリームを構築します。
メソッドの概要
void | close() 入出力ストリームおよびソケットを閉じます。
void | flush() 書き出しストリーム内のデータをすべて出力。
boolean | isClosed() この入出力ストリームが閉じられているかチェックします。
void | write(byte[] b, int off, int len) オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
void | write(int data) 指定されたバイトを書き込みます。
void | writeBoolean(boolean data) boolean 型データの送信。
void | writeInt(int data) int 型データの送信。
void | writeLong(long data) long 型データの送信。
void | writeObject(Object data) オブジェクトの送信。
void | writeString(String data) 文字列の送信。
クラス java.io.OutputStream から継承したメソッド
write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out)
                     throws IOException
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out,
                            ErrorEventListener listener)
                     throws IOException
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

write

public void write(int data)
           throws IOException
指定されたバイトを書き込みます。

パラメータ:
data - バイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(int), ExtendedInputStream.read()

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(byte[],int,int), ExtendedInputStream.read()

writeInt

public void writeInt(int data)
              throws IOException
int 型データの送信。
基本データ型の整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeInt(int), ExtendedInputStream.readInt()

writeLong

public void writeLong(long data)
               throws IOException
long 型データの送信。
基本データ型の長整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeLong(long), ExtendedInputStream.readLong()

writeBoolean

public void writeBoolean(boolean data)
                  throws IOException
boolean 型データの送信。
基本データ型の真偽値データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeBoolean(boolean), ExtendedInputStream.readBoolean()

writeObject

public void writeObject(Object data)
                 throws IOException
オブジェクトの送信。

java.io.Serializable インタフェースを実装している オブジェクトを基礎出力ストリームに書き込みます。
このメソッドはオブジェクトをストリームに書き込む際に、 java.io.ObjectOutputStream の writeObject メソッドを使います。

パラメータ:
data - オブジェクト
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
ObjectOutputStream.writeObject(Object), Serializable, ExtendedInputStream.readObject()

writeString

public void writeString(String data)
                 throws IOException
文字列の送信。
このメソッドは、writeObject() メソッドを使い文字列をストリームに 書き込みます。 java.io.DataOutputStream や java.io.ObjectOutputStream の writeUTF メソッドとの違いは、ストリームに書き込める文字列の 長さに制約がないことです。

パラメータ:
data - ストリームに書き込む文字列
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
DataOutputStream.writeUTF(String),
ObjectOutputStream.writeUTF(String),
ExtendedInputStream.readString()

flush

public void flush()
           throws IOException
書き出しストリーム内のデータをすべて出力。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス HexInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
public class HexInputStream
extends InputStream

このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、16進数表現からバイトに変換され read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
protected  InputStream in
フィルタ処理される入力ストリームです。
コンストラクタの概要
HexInputStream(InputStream in)
指定された InputStream から読み込む HexInputStream を作成します。
メソッドの概要
void | close() ストリームを閉じます。
int | read() デコードデータのバイトを読み込みます。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

in

protected InputStream in
フィルタ処理される入力ストリームです。

コンストラクタの詳細

HexInputStream

public HexInputStream(InputStream in)
指定された InputStream から読み込む HexInputStream を作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

close

public void close()
           throws IOException
ストリームを閉じます。

入力ストリームを閉じ、これに関連するすべての システムリソースを解放します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス HexOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
public class HexOutputStream
extends OutputStream

このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、16進数表現され 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 [0-9a-f] の範囲のキャラクタで構成されます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
protected  OutputStream out
フィルタ処理される基礎出力ストリームです。
コンストラクタの概要
HexOutputStream(OutputStream out)
指定された OutputStream に書き込む HexOutputStream を作成します。
メソッドの概要
void | close() ストリームを閉じます。
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.OutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected OutputStream out
フィルタ処理される基礎出力ストリームです。

コンストラクタの詳細

HexOutputStream

public HexOutputStream(OutputStream out)
指定された OutputStream に書き込む HexOutputStream を作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、バイトを上位４ビットと下位ビットに分け、 それぞれ16進数表現されたキャラクターコードに置き換えて、 計２バイトのデータを基礎ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

close

public void close()
           throws IOException
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。
もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipleOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス MultipleOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
public class MultipleOutputStream
extends OutputStream

複数の出力ストリームにバイトを書き出すためのフィルタ実装です。

このフィルタを利用する事によって、 同じバイト情報を全く異なる複数の出力先へ、同時に書き出すことができます。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultipleOutputStream()
唯一のコンストラクタ
メソッドの概要
void | addOutputStream(OutputStream output) メッセージの出力先を追加します。
void | close() このストリームを閉じます。
protected void | finalize() このオブジェクトをクリーンアップします。
void | flush() この出力ストリームをフラッシュします。
boolean | removeOutputStream(OutputStream output) メッセージの出力先を削除します。
void | write(byte[] b) 指定のバイトを 設定されている各出力先へ書き出します。
void | write(byte[] b, int off, int len) 指定のバイトを 設定されている各出力先へ書き出します。
void | write(int b) 指定のバイトを 設定されている各出力先へ書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultipleOutputStream

public MultipleOutputStream()
唯一のコンストラクタ

メソッドの詳細

addOutputStream

public void addOutputStream(OutputStream output)
メッセージの出力先を追加します。

パラメータ:
output - 出力ストリーム

removeOutputStream

public boolean removeOutputStream(OutputStream output)
メッセージの出力先を削除します。

パラメータ:
output - 出力ストリーム
戻り値:
削除に成功した場合は true。

write

public void write(int b)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
この出力ストリームをフラッシュします。

まず、この出力ストリーム内のデータをフラッシュします。 その後、設定されている各出力先の OutputStream.flush() メソッドを 順に呼び出します。

例外:
IOException - 入出力エラー

close

public void close()
           throws IOException
このストリームを閉じます。

このメソッドは、自分をクローズ処理すると同時に基礎ストリームも閉じます。 設定されている各出力先の OutputStream.close() メソッドを 順に呼び出します。

例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
このオブジェクトをクリーンアップします。 このオブジェクトへの参照はもうないとガベージコレクションによって 判断されたときに、ガベージコレクタによって呼び出されます。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.io (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.java.io
クラス
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
ExtendedInputStream
ExtendedOutputStream
HexInputStream
HexOutputStream
MultipleOutputStream
ReplaceWriter
TrimmedFilterReader
TrimmedFilterWriter
UnlimitedBufferedOutputStream
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
XORInputStream
XOROutputStream


jp.co.intra_mart.common.aid.jdk.java.io (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

参照:
説明

クラスの概要
BASE64DecodeInputStream | このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
BASE64DecodeOutputStream | このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64EncodeOutputStream | このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
ExtendedInputStream | このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedOutputStream | このクラスは、標準の出力ストリームを拡張した機能を提供します。
HexInputStream | このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
HexOutputStream | このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
MultipleOutputStream | 複数の出力ストリームにバイトを書き出すためのフィルタ実装です。
ReplaceWriter | このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
TrimmedFilterReader | このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。
TrimmedFilterWriter | このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。
UnlimitedBufferedOutputStream | 出力データを一時的にバッファリングする出力ストリームの実装です。
URLDecodeInputStream | このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
URLDecodeOutputStream | このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
URLEncodeOutputStream | このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
XORInputStream | このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
XOROutputStream | このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。

パッケージ jp.co.intra_mart.common.aid.jdk.java.io の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
このパッケージには、java.io パッケージに含まれるクラスを拡張したものが多く含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.jdk.java.io クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
    • class java.io.OutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
    • class java.io.Reader
      • class java.io.FilterReader
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
      • class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.aid.jdk.java.io の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io の使用

jp.co.intra_mart.common.aid.jdk.java.io を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net により使用される jp.co.intra_mart.common.aid.jdk.java.io のクラス
ExtendedInputStream
このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedOutputStream
このクラスは、標準の出力ストリームを拡張した機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ReplaceWriter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ReplaceWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
public class ReplaceWriter
extends Writer

このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
置換対象となる部分文字列と置換する文字列の長さは同じ必要はありません。 置換対象となる文字データと異なる長さの文字データを置換後のデータとして 指定することも可能です。この場合、 このクラスによって基礎ストリームに書き込まれるデータ量は、 元のデータ量と変化します。

   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("abc");
   String result = sw.toString();
文字データ "abc" は、"xyz" に変化します。この場合、以下のように 記述しても同様の結果が得られます。
   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("a");
   rw.write("b");
   rw.write("c");
   String result = sw.toString();

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReplaceWriter(Writer out, char[] oldChars)
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, char[] oldChars, char[] newChars)
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString)
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString, String newString)
文字列置換のためのストリームフィルタを作成します。
メソッドの概要
void | close() ストリームを閉じてフラッシュします。
void | finish() バッファに保存してあるデータを書き出します。
void | flush() ストリームをフラッシュします。
void | write(char[] cbuf, int off, int len) 文字列の一部を基礎ストリームに書き込みます。
void | write(int c) 単一文字を書き込みます。
クラス java.io.Writer から継承したメソッド
write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars)
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 削除対象となる文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString)
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldString - 削除対象となる文字列

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars,
                     char[] newChars)
文字列置換のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは適切な置換を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 置換対象となる文字の配列
newChars - 置換する文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString,
                     String newString)
文字列置換のためのストリームフィルタを作成します。

パラメータ:
out - 基礎ストリーム
oldString - 置換対象となる文字列
newString - 置換する文字列
メソッドの詳細

write

public void write(int c)
           throws IOException
単一文字を書き込みます。 書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字列の一部を基礎ストリームに書き込みます。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

finish

public void finish()
            throws IOException
バッファに保存してあるデータを書き出します。

ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字を基礎ストリームへただちに 書き込みます。
このメソッドは、このストリームの持つ置換対象データと比較中の 文字データを含むすべてのバッファを基礎ストリームに書き込みます。 このメソッドを呼び出し後は、write() メソッドによって与えられる データを改めて検索し直します。この機能のより、このストリームフィルタの 複数のストリームでの再利用が可能となります。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrimmedFilterReader (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス TrimmedFilterReader

java.lang.Object
    拡張 java.io.Reader
        拡張 java.io.FilterReader
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
public class TrimmedFilterReader
extends FilterReader

このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。

フィルタ処理として、 文字入力ストリームから Java の基準に従った空白文字ではない文字を読み込みます。

導入されたバージョン:
Version 5.0

フィールドの概要
クラス java.io.FilterReader から継承したフィールド
in
クラス java.io.Reader から継承したフィールド
lock
コンストラクタの概要
TrimmedFilterReader(Reader in)
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。
メソッドの概要
int | read() 単一の文字を読み込みます。
int | read(char[] cbuf, int off, int len) 配列の一部に文字を読み込みます。
クラス java.io.FilterReader から継承したメソッド
close, mark, markSupported, ready, reset, skip
クラス java.io.Reader から継承したメソッド
read
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TrimmedFilterReader

public TrimmedFilterReader(Reader in)
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。

パラメータ:
in - 基本となるストリームを提供する Reader オブジェクト
メソッドの詳細

read

public int read()
         throws IOException
単一の文字を読み込みます。

文字入力ストリームから読み込んだ文字が Java の基準に従った空白文字である場合に、 次の文字を読み込みを行います。

文字の値は 0 ～ 65535 (0x00-0xffff) の範囲の値をとる int として返されます。 ストリームの終わりに達して読み込むデータがない場合は -1 を返します。

このメソッドは、入力データが読み込めるようになるか、 ストリームの終わりが検出されるか、 または例外がスローされるまでブロックします。

戻り値:
0 ～ 65535 (0x00-0xffff) の範囲の整数としての、読み込まれた文字。ストリームの終わりに達した場合は -1
例外:
IOException - 入出力エラーが発生した場合
関連項目:
java.io.Reader#read()

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException,
                NullPointerException
配列の一部に文字を読み込みます。

入力ストリームから len 文字数分の文字を指定された文字の配列に格納します。 実際に読み込まれた文字数は整数として返されます。

このメソッドは、入力データが読み込めるようになるか、 ファイルの終わりが検出されるか、 あるいは例外がスローされるまでブロックします。

文字の配列 cbuf が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 cbuf の長さより大きい場合は、 IndexOutOfBoundsException がスローされます。

len が 0 の場合は、文字が読み込まれず、0 が返されます。 そうでない場合は、Java の基準に従った空白文字でない 1 文字以上の読み込み処理が行われます。 ストリームがファイルの終わりに達しているために読み込む文字がない場合は、 値 -1 が返されます。 そうでない場合は、Java の基準に従った空白文字でない len 文字数分の文字が読み込まれ、 文字の配列 cbuf に格納されます。

すべての場合において、文字 cbuf[0] ～ cbuf[off] および文字 cbuf[off+len] ～ cbuf[b.length-1] は影響を受けません。

ファイルの終わりに達している以外の理由で最初のバイトが読み込めない場合は、 IOException がスローされます。 特に、入力ストリームが閉じている場合には IOException がスローされます。

このメソッドは、単純に read() メソッドを繰り返し呼び出します。 最初の呼び出しが IOException になる場合、 その例外は呼び出し側から read(cbuf, off, len) メソッドに返されます。 read() の以降の呼び出しが IOException になった場合、 その例外はファイルの終わりが検出された場合と同じようにキャッチおよび処理されます。 つまり、その時点までに読み込まれた文字は cbuf に格納され、 例外が発生するまでに読み込まれた文字数が返されます。

パラメータ:
cbuf - 転送先バッファ
off - 文字の格納開始オフセット
len - 読み込む文字の最大数
戻り値:
読み込まれた文字数。
例外:
IOException
NullPointerException
関連項目:
Reader.read(char[], int, int)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrimmedFilterWriter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス TrimmedFilterWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
public class TrimmedFilterWriter
extends FilterWriter

このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。

フィルタ処理として、 Java の基準に従った空白ではない文字を文字出力ストリームに書き込みます。

導入されたバージョン:
Version 5.0

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
TrimmedFilterWriter(Writer writer)
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。
メソッドの概要
void | write(char[] cbuf, int off, int len) 文字の配列の一部を書き込みます。
void | write(int c) 指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。
void | write(String str, int off, int len) 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TrimmedFilterWriter

public TrimmedFilterWriter(Writer writer)
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。

パラメータ:
writer - 基本となる文字出力ストリームを提供する java.io.Writer オブジェクト
メソッドの詳細

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
文字列の一部を書き込みます。 オフセット off から始まる指定の文字列 str から、 len 文字分を文字出力ストリームに書き込みます。
この処理は、

char[] strToCharArray = str.toCharArray(); 上の式のように文字列 str を新しい文字の配列 strToCharArray に変換して write(strToCharArray, off, len) を呼び出す場合とまったく同じです。

指定した文字の配列 str が null の場合は、NullPointerException がスローされます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字の配列の一部を書き込みます。

オフセット off から始まる指定の文字の配列 cbuf から、 len 文字分を文字出力ストリームに書き込みます。
この処理で最初に書き込まれる文字は要素 b[off] で、 最後に書き込まれる文字は要素 cbuf[off+len-1] です。

この処理では、書き込む文字ごとに write(int) のメソッドを呼び出します。 指定した文字の配列 cbuf が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 cbuf の長さより大きい場合は、 IndexOutOfBoundsException がスローされます。

パラメータ:
cbuf - 書き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。

書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnlimitedBufferedOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス UnlimitedBufferedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
public class UnlimitedBufferedOutputStream
extends FilterOutputStream

出力データを一時的にバッファリングする出力ストリームの実装です。

このクラスは、 BufferedOutputStream と異なり、 flush() メソッドが呼び出されるまで、 すべてのバイトをメモリ中にバッファリングします。 したがって、明示的にフラッシュしなければ、データが出力される事は ありません。 逆に言うと、明示的にフラッシュするまですべてのデータをメモリ中に 保存する事になるため、大きなデータを扱う場合には十分な注意が必要です。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
UnlimitedBufferedOutputStream(OutputStream out)
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。
メソッドの概要
void | flush() この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。
void | write(byte[] b) b.length バイトのデータを出力ストリームに書き込みます。
void | write(byte[] b, int off, int len) 指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。
void | write(int b) 指定のバイトを出力します。
クラス java.io.FilterOutputStream から継承したメソッド
close
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UnlimitedBufferedOutputStream

public UnlimitedBufferedOutputStream(OutputStream out)
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。

パラメータ:
out - 出力先ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
指定のバイトを出力します。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラー

write

public void write(byte[] b)
           throws IOException
b.length バイトのデータを出力ストリームに書き込みます。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - データ
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLDecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
public class URLDecodeInputStream
extends FilterInputStream

このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
この入力ストリームに読み込まれたバイトは、URL デコードされ 基礎入力ストリームに読み込まれます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
URLDecodeInputStream(InputStream in)
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeInputStream

public URLDecodeInputStream(InputStream in)
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLDecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
public class URLDecodeOutputStream
extends FilterOutputStream

このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL デコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLDecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む URLデコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeOutputStream

public URLDecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む URLデコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLEncodeOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLEncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
public class URLEncodeOutputStream
extends FilterOutputStream

このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL エンコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLEncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLEncodeOutputStream

public URLEncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XORInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス XORInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
public class XORInputStream
extends FilterInputStream

このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、 指定されたバイトデータとの排他論理和を計算した結果として read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
XORInputStream(InputStream in, int b)
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XORInputStream

public XORInputStream(InputStream in,
                      int b)
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。

パラメータ:
in - 入力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。このメソッドは、入力が可能になるまでブロックします。

パラメータ:
b - データの読み込み先のバッファ
off - データの開始オフセット
len - 読み込まれる最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XOROutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス XOROutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
public class XOROutputStream
extends FilterOutputStream

このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、指定のバイトデータとの 排他論理和を計算して、その結果のバイトデータが 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 同じバイトデータによって排他論理和を取ることにより、 もとのバイトデータに戻すことができます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
XOROutputStream(OutputStream out, int b)
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XOROutputStream

public XOROutputStream(OutputStream out,
                       int b)
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。

パラメータ:
out - 出力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread の使用

jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader の使用

ResourceLoader を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ResourceLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang での ResourceLoader のサブクラス
 class ExtendedClassLoader
このクラスは、拡張されたクラスローダーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の使用

jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener の使用

ShutdownListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ShutdownListener の使用

ShutdownListener を返す jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static ShutdownListener[] ShutdownEventController.getShutdownListeners()
現在登録されているリスナを返します。

ShutdownListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static void | ShutdownEventController.addListener(ShutdownListener listener) シャットダウンリスナーを登録します。
static boolean | ShutdownEventController.removeListener(ShutdownListener listener) シャットダウンリスナーを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の使用

jp.co.intra_mart.common.aid.jdk.java.lang.StdErr はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の使用

jp.co.intra_mart.common.aid.jdk.java.lang.StdOut はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener の使用

ThreadStopListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ThreadStopListener の使用

ThreadStopListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
 void ExtendedThread.addThreadStopListener(ThreadStopListener listener)
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener の使用

ThrowablePrintListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ThrowablePrintListener の使用

ThrowablePrintListener を返す jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static ThrowablePrintListener StdErr.getThrowablePrintListener()
現在の例外出力リスナを返します。

ThrowablePrintListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static void StdErr.setThrowablePrintListener(ThrowablePrintListener listener)
指定の例外出力リスナを割り当て直します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ExtendedClassLoader (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ExtendedClassLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
            拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
public class ExtendedClassLoader
extends ResourceLoader

このクラスは、拡張されたクラスローダーです。

このクラスローダーは、リソースを検索するパスを任意に追加することが できます。

導入されたバージョン:
version 5.0

コンストラクタの概要
ExtendedClassLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ExtendedClassLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
メソッドの概要
void | addNativePath(File path) クラスパスを追加します。
protected Class | findClass(String name) 指定されたクラスを探します。
protected String | findLibrary(String libname) ネイティブライブラリの絶対パス名を返します。
File[] | getNativePaths() このクラスローダーに設定されているネイティブライブラリパスを返します。
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader から継承したメソッド
addClassArchive, addClassArchiveLibrary, addClassPath, findResource, findResources, getClassArchives, getClassPaths
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedClassLoader

public ExtendedClassLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。

ExtendedClassLoader

public ExtendedClassLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。

パラメータ:
parent - 親クラスローダー
メソッドの詳細

addNativePath

public void addNativePath(File path)
クラスパスを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に ネイティブリソースを検索していきます。 path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

getNativePaths

public File[] getNativePaths()
このクラスローダーに設定されているネイティブライブラリパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からネイティブライブラリを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addNativePath(File), File

findLibrary

protected String findLibrary(String libname)
ネイティブライブラリの絶対パス名を返します。
VM はこのメソッドを呼び出して、このクラスローダでロードされたクラスに 属するネイティブライブラリを見つけます。 このメソッドが null を返す場合、VM は java.library.path プロパティで 指定されたパスにしたがってライブラリを検索します。

パラメータ:
libname - ライブラリ名
戻り値:
ネイティブライブラリの絶対パス

findClass

protected Class findClass(String name)
                   throws ClassNotFoundException
指定されたクラスを探します。
このメソッドは、クラスをロードするための新しい委譲モデルに準拠する クラスローダ実装によってオーバーライドされ、必要なクラスの 親クラスローダのチェック後に loadClass メソッドによって呼び出されます。 デフォルトの実装は ClassNotFoundException をスローします。

パラメータ:
name - クラス名
戻り値:
結果の Class オブジェクト
例外:
ClassNotFoundException - クラスが見つからなかった場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedThread (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ExtendedThread

java.lang.Object
    拡張 java.lang.Thread
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread
すべての実装インタフェース:
Runnable
public class ExtendedThread
extends Thread

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.lang.Thread から継承したフィールド
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
コンストラクタの概要
ExtendedThread()
Constructor for ExtendedThread.
ExtendedThread(Runnable target)
Constructor for ExtendedThread.
ExtendedThread(Runnable target, String name)
Constructor for ExtendedThread.
ExtendedThread(String name)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target, String name)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, String name)
Constructor for ExtendedThread.
メソッドの概要
void | addThreadStopListener(ThreadStopListener listener) このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
void | fire() スレッド実行されるロジック。
void | run() このオブジェクトのスレッド実行ロジックです。
クラス java.lang.Thread から継承したメソッド
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getContextClassLoader, getName, getPriority, getThreadGroup, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setName, setPriority, sleep, sleep, start, stop, stop, suspend, toString, yield
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedThread

public ExtendedThread()
Constructor for ExtendedThread.

ExtendedThread

public ExtendedThread(Runnable target)
Constructor for ExtendedThread.

パラメータ:
target -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target)
Constructor for ExtendedThread.

パラメータ:
group -
target -

ExtendedThread

public ExtendedThread(String name)
Constructor for ExtendedThread.

パラメータ:
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      String name)
Constructor for ExtendedThread.

パラメータ:
group -
name -

ExtendedThread

public ExtendedThread(Runnable target,
                      String name)
Constructor for ExtendedThread.

パラメータ:
target -
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target,
                      String name)
Constructor for ExtendedThread.

パラメータ:
group -
target -
name -
メソッドの詳細

run

public final void run()
このオブジェクトのスレッド実行ロジックです。 このメソッドをサブクラスがオーバーライドすることはできません。 サブクラスがスレッド実行ロジックを定義するためには、fireメソッドを オーバーライドしてください。

fire

public void fire()
スレッド実行されるロジック。 Thread クラスを継承したサブクラスにおいて、通常 run メソッドに 記述する内容をこのメソッドに定義してください。

addThreadStopListener

public void addThreadStopListener(ThreadStopListener listener)
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

パラメータ:
listener - スレッド終了イベントリスナー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.lang (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース
ShutdownListener
ThreadStopListener
ThrowablePrintListener
クラス
ExtendedClassLoader
ExtendedThread
ResourceLoader
ShutdownEventController
StdErr
StdOut


jp.co.intra_mart.common.aid.jdk.java.lang (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang

このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ShutdownListener | シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
ThreadStopListener | To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThrowablePrintListener | このインタフェースは、例外情報を出力するためのものです。

クラスの概要
ExtendedClassLoader | このクラスは、拡張されたクラスローダーです。
ExtendedThread | To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ResourceLoader | このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
ShutdownEventController | このクラスは、サーバプロセスの基礎ロジック。
StdErr | このクラスは、エラーメッセージ出力用です。
StdOut | このクラスは、システムメッセージ出力用です。

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.java.lang クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.ClassLoader
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
        • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
    • class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.lang の使用

jp.co.intra_mart.common.aid.jdk.java.lang を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang により使用される jp.co.intra_mart.common.aid.jdk.java.lang のクラス
ResourceLoader
このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
ShutdownListener
シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
ThreadStopListener
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThrowablePrintListener
このインタフェースは、例外情報を出力するためのものです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ResourceLoader (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ResourceLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
直系の既知のサブクラス:
ExtendedClassLoader
public class ResourceLoader
extends ClassLoader

このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。

このクラスローダーは、リソースを検索するパスを任意に追加することが できます。

導入されたバージョン:
version 5.0

コンストラクタの概要
ResourceLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ResourceLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
メソッドの概要
void | addClassArchive(File path) クラスパスに指定のアーカイブファイルを追加します。
void | addClassArchiveLibrary(File path) クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。
void | addClassPath(File path) クラスパスを追加します。
protected URL | findResource(String name) 指定された名前を持つリソースを探します。
protected Enumeration | findResources(String name) 指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。
File[] | getClassArchives() このクラスローダーに設定されているクラスアーカイブパスを返します。
File[] | getClassPaths() このクラスローダーに設定されているクラスパスを返します。
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findClass, findLibrary, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResourceLoader

public ResourceLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。

ResourceLoader

public ResourceLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。

パラメータ:
parent - 親クラスローダー
メソッドの詳細

addClassPath

public void addClassPath(File path)
クラスパスを追加します。

ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に クラスを検索していきます。
path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

addClassArchive

public void addClassArchive(File path)
クラスパスに指定のアーカイブファイルを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に クラスを検索していきます。 path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

addClassArchiveLibrary

public void addClassArchiveLibrary(File path)
クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
このメソッドは、path に含まれる jar または zip ファイルを検索し、 addClassArchive(File) を呼び出して このクラスローダの検索パスに追加します。

パラメータ:
path - 追加するパス

getClassPaths

public File[] getClassPaths()
このクラスローダーに設定されているクラスパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からクラスを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addClassPath(File), File

getClassArchives

public File[] getClassArchives()
このクラスローダーに設定されているクラスアーカイブパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からクラスを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addClassArchive(File), File

findResources

protected Enumeration findResources(String name)
                             throws IOException
指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。

パラメータ:
name - リソース名
戻り値:
リソースの URL の Enumeration
例外:
IOException

findResource

protected URL findResource(String name)
指定された名前を持つリソースを探します。

パラメータ:
name - リソース名
戻り値:
リソースを読み込むための URL。リソースが見つからなかった場合は null
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ShutdownEventController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ShutdownEventController

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
public class ShutdownEventController
extends Object

このクラスは、サーバプロセスの基礎ロジック。

導入されたバージョン:
version 4.0
関連項目:
ShutdownListener

メソッドの概要
static void | addListener(ShutdownListener listener) シャットダウンリスナーを登録します。
static ShutdownListener[] | getShutdownListeners() 現在登録されているリスナを返します。
static boolean | isShutdown() シャットダウン中（またはシャットダウン処理終了）かどうかを判定。
static boolean | removeListener(ShutdownListener listener) シャットダウンリスナーを削除します。
static void | shutdown() このプロセスを終了します。
static void | shutdown(int status) このプロセスを終了します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

addListener

public static void addListener(ShutdownListener listener)
シャットダウンリスナーを登録します。

パラメータ:
listener - イベントリスナーオブジェクト
例外:
IllegalStateException - すでにシャットダウン処理中
関連項目:
ShutdownListener

removeListener

public static boolean removeListener(ShutdownListener listener)
シャットダウンリスナーを削除します。

ただし、すでにシャットダウンフェーズに入ってしまっている場合は、 リスナーの削除に成功しても削除したリスナが実行されてしまう 可能性があります。

パラメータ:
listener - イベントリスナーオブジェクト
戻り値:
リストに、指定された要素が格納されている場合は true
関連項目:
ShutdownListener

getShutdownListeners

public static ShutdownListener[] getShutdownListeners()
現在登録されているリスナを返します。

戻り値:
登録されているリスナ

shutdown

public static void shutdown()
このプロセスを終了します。 このメソッドは、System.exit(0) と同様です。

導入されたバージョン:
version 4.0.1

shutdown

public static void shutdown(int status)
このプロセスを終了します。 引数はステータスコードとして作用します。 通例、ゼロ以外のステータスコードは異常終了を示します。 このメソッドは、正常に復帰することはありません。

パラメータ:
status - 終了のステータス
導入されたバージョン:
version 4.0.1

isShutdown

public static boolean isShutdown()
シャットダウン中（またはシャットダウン処理終了）かどうかを判定。

戻り値:
シャットダウン中（またはシャットダウン処理を終了したとみなされる）場合は、true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ShutdownListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ShutdownListener

public interface ShutdownListener

シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。

このインターフェースを実装して ShutdownEventController クラスに登録する ことで、任意のロジックをシャットダウン直前に実行することができます。

導入されたバージョン:
version 5.0
関連項目:
ShutdownEventController

メソッドの概要
 void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。

メソッドの詳細

handleShutdown

public void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。 このメソッドを実装することで、 シャットダウン直前に任意のロジックを実行することができます。 このメソッドは、プロセスのシャットダウン直前に実行されるため、 必ずスレッドセーフであり、かつデッドロックしないように プログラムする必要があります。 このメソッド実行中の ShutdownEventController に対するリスナー登録は、 デッドロックの原因となるので、絶対にやってはいけません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StdErr (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス StdErr

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
public class StdErr
extends Object

このクラスは、エラーメッセージ出力用です。

導入されたバージョン:
version 5.0

メソッドの概要
static void | addOutputStream(OutputStream out) メッセージの出力先を追加します。
static PrintStream | getDefaultPrintStream() このクラスがロードされた時点の、System.err を 返します。
static PrintStream | getPrintStream() メッセージを出力する出力ストリームを返します。
static ThrowablePrintListener | getThrowablePrintListener() 現在の例外出力リスナを返します。
static boolean | removeOutputStream(OutputStream out) メッセージの出力先を削除します。
static void | setThrowablePrintListener(ThrowablePrintListener listener) 指定の例外出力リスナを割り当て直します。
static void | write(String msg) 指定のメッセージを標準エラー出力および指定の出力先に書き出します。
static void | write(String msg, Throwable exception) 指定のメッセージを標準エラー出力および指定の出力先に書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getDefaultPrintStream

public static PrintStream getDefaultPrintStream()
このクラスがロードされた時点の、System.err を 返します。

このメソッドのリターン値を引数にして、 removeOutputStream(OutputStream) を実行すると、 標準エラー出力（コンソール）にメッセージが表示されなくなります。

戻り値:
標準エラー出力にメッセージを書き出す出力ストリーム

getPrintStream

public static PrintStream getPrintStream()
メッセージを出力する出力ストリームを返します。

返された出力ストリームの PrintStream.close() メソッドを 実行してストリームを閉じてしまうと、以後メッセージを出力できなく なります。

戻り値:
出力ストリーム

addOutputStream

public static void addOutputStream(OutputStream out)
メッセージの出力先を追加します。

パラメータ:
out - 出力ストリーム

removeOutputStream

public static boolean removeOutputStream(OutputStream out)
メッセージの出力先を削除します。

パラメータ:
out - 出力ストリーム
戻り値:
削除に成功した場合は true。

setThrowablePrintListener

public static void setThrowablePrintListener(ThrowablePrintListener listener)
指定の例外出力リスナを割り当て直します。

パラメータ:
listener - 新しい例外出力リスナ

getThrowablePrintListener

public static ThrowablePrintListener getThrowablePrintListener()
現在の例外出力リスナを返します。

戻り値:
現在有効な例外出力リスナ

write

public static void write(String msg)
指定のメッセージを標準エラー出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ

write

public static void write(String msg,
                         Throwable exception)
指定のメッセージを標準エラー出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ
exception - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StdOut (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス StdOut

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
public class StdOut
extends Object

このクラスは、システムメッセージ出力用です。

導入されたバージョン:
version 5.0

メソッドの概要
static void | addOutputStream(OutputStream out) メッセージの出力先を追加します。
static PrintStream | getDefaultPrintStream() このクラスがロードされた時点の、System.out を 返します。
static PrintStream | getPrintStream() メッセージを出力する出力ストリームを返します。
static boolean | removeOutputStream(OutputStream out) メッセージの出力先を削除します。
static void | write(String msg) 指定のメッセージを標準出力および指定の出力先に書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getDefaultPrintStream

public static PrintStream getDefaultPrintStream()
このクラスがロードされた時点の、System.out を 返します。

このメソッドのリターン値を引数にして、 removeOutputStream(OutputStream) を実行すると、 標準出力（コンソール）にメッセージが表示されなくなります。

戻り値:
標準出力にメッセージを書き出す出力ストリーム

getPrintStream

public static PrintStream getPrintStream()
メッセージを出力する出力ストリームを返します。

返された出力ストリームの PrintStream.close() メソッドを 実行してストリームを閉じてしまうと、以後メッセージを出力できなく なります。

戻り値:
出力ストリーム

addOutputStream

public static void addOutputStream(OutputStream out)
メッセージの出力先を追加します。

パラメータ:
out - 出力ストリーム

removeOutputStream

public static boolean removeOutputStream(OutputStream out)
メッセージの出力先を削除します。

パラメータ:
out - 出力ストリーム
戻り値:
削除に成功した場合は true。

write

public static void write(String msg)
指定のメッセージを標準出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ThreadStopListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ThreadStopListener

public interface ThreadStopListener

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0

メソッドの概要
 void handleThreadStop()
監視していたスレッドが終了したときに実行されるメソッドです。

メソッドの詳細

handleThreadStop

public void handleThreadStop()
監視していたスレッドが終了したときに実行されるメソッドです。 このメソッドをサブクラスが実行することで、特定のスレッド終了時に プログラムを実行することができます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ThrowablePrintListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ThrowablePrintListener

public interface ThrowablePrintListener

このインタフェースは、例外情報を出力するためのものです。

StdErr クラスと合わせて利用します。

導入されたバージョン:
version 5.0

メソッドの概要
void | printMessage(Throwable t) 例外のメッセージを出力します。
void | printStackTrace(Throwable t) 例外のスタックトレースを出力します。

メソッドの詳細

printMessage

public void printMessage(Throwable t)
例外のメッセージを出力します。

パラメータ:
t - 例外

printStackTrace

public void printStackTrace(Throwable t)
例外のスタックトレースを出力します。

パラメータ:
t - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor の使用

AbstractSocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での AbstractSocketConnectionDistributor の使用

jp.co.intra_mart.common.aid.jdk.java.net での AbstractSocketConnectionDistributor のサブクラス
 class SocketPool
このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket の使用

ExtendedSocket を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedSocket の使用

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedSocket のサブクラス
 class SocketConnection
ソケットプール用のスケルトン実装を提供します。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 void SocketEventListener.handleSocketEvent(ExtendedSocket socket)
ソケットに関するイベント発生時に呼び出されるメソッド。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のコンストラクタ
SocketConnection(ExtendedSocket socket)
ソケット入出力インスタンスを構築します。
ExtendedSocket(ExtendedSocket socket)
ソケットを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.Localhost の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.Localhost の使用

Localhost を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での Localhost の使用

Localhost を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
static Localhost Localhost.instance()
このクラスから生成される唯一のインスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection の使用

SocketConnection を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
SocketConnection | SocketPool.connection() コネクションの取得。
SocketConnection | SocketConnectionDistributor.connection() コネクションの取得。

SocketConnection 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 boolean SocketPool.eject(SocketConnection connection)
指定コネクションをこのプールの管理から切り離します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor の使用

SocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionDistributor の使用

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionDistributor のサブインタフェース
 interface SocketConnectionManager
通信ソケットをプールする機能のインターフェースです。

SocketConnectionDistributor を実装している jp.co.intra_mart.common.aid.jdk.java.net のクラス
class | AbstractSocketConnectionDistributor このクラスは、通信ソケットを作成する機能を提供します。
class | SocketPool このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager の使用

SocketConnectionManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionManager の使用

SocketConnectionManager を実装している jp.co.intra_mart.common.aid.jdk.java.net のクラス
 class SocketPool
このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener の使用

SocketEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketEventListener の使用

SocketEventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
void | SocketPool.addCreateSocketEventListener(SocketEventListener listener) ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | SocketPool.addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | ExtendedSocket.addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.SocketPool の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.SocketPool の使用

jp.co.intra_mart.common.aid.jdk.java.net.SocketPool はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException の使用

jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractSocketConnectionDistributor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス AbstractSocketConnectionDistributor

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor
すべての実装インタフェース:
SocketConnectionDistributor
直系の既知のサブクラス:
SocketPool
public abstract class AbstractSocketConnectionDistributor
extends Object
implements SocketConnectionDistributor

このクラスは、通信ソケットを作成する機能を提供します。

このクラスを継承してソケットプールを作成することができます。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractSocketConnectionDistributor(String address, int port)
ソケット作成オブジェクトを構築します。
メソッドの概要
protected Socket | createSocket() 新しいソケットを作成します。
String | getAddress() アドレスを返します。
int | getPort() ポートを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

コンストラクタの詳細

AbstractSocketConnectionDistributor

protected AbstractSocketConnectionDistributor(String address,
                                              int port)
ソケット作成オブジェクトを構築します。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
メソッドの詳細

createSocket

protected Socket createSocket()
                       throws UnknownHostException,
                              IOException
新しいソケットを作成します。

戻り値:
ソケット
例外:
UnknownHostException - ホストの IP アドレスを判定できなかった場合
IOException - ソケットの生成中に入出力エラーが発生した場合

getAddress

public String getAddress()
アドレスを返します。

戻り値:
このプールのネットワーク接続先サーバアドレス

getPort

public int getPort()
ポートを返します。

戻り値:
このプールのネットワーク接続先サーバポート
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedSocket (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス ExtendedSocket

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
直系の既知のサブクラス:
SocketConnection
public class ExtendedSocket
extends Object

このクラスは、ソケット通信用の入出力機能を提供します。

このクラスの提供している独自機能や、このクラスの持つメソッドから 取得したオブジェクトを使っている最中に例外がスローされた場合、 このクラスのインスタンスは発生した例外を保存します。 保存された例外は、lastError メソッドにより知ることができます。
ただし、このクラスが継承しているスーパークラスのメソッドの 呼び出し時にスローされた例外に関しては感知することはできません。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected | ExtendedSocket(ExtendedSocket socket) ソケットを構築します。
 | ExtendedSocket(Socket socket) ソケットを構築します。
 | ExtendedSocket(String address, int port) ソケットを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | clearError() このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
void | close() 入出力ストリームおよびソケットを閉じます。
Iterator | errorIterator() このインスタンスのメソッド実行中に発生した例外を返します。
Collection | getCloseSocketEventListeners() このソケットに登録されているクローズ・イベント・リスナーを返します。
ExtendedInputStream | getInputStream() 入力ストリームの取得。
ExtendedOutputStream | getOutputStream() 出力ストリームの取得。
Socket | getSocket() このオブジェクトの持つソケットオブジェクトを返します。
boolean | isClosed() このソケットが閉じられているかどうかをチェックします。
Throwable | lastError() このインスタンスのメソッド中で最後に発生した例外を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedSocket

public ExtendedSocket(String address,
                      int port)
               throws UnknownHostException,
                      IOException
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
UnknownHostException - ホストの IP アドレスが判定できなかった場合にスローされます。
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

public ExtendedSocket(Socket socket)
               throws IOException
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

protected ExtendedSocket(ExtendedSocket socket)
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
メソッドの詳細

getSocket

public Socket getSocket()
このオブジェクトの持つソケットオブジェクトを返します。 このメソッドから取得したソケットオブジェクトの入出力ストリームと このオブジェクト自身から取得した入出力ストリームを 同時に利用した場合、データ送受信の整合性が失われてしまう可能性が あります。

戻り値:
ソケットオブジェクト

getInputStream

public ExtendedInputStream getInputStream()
入力ストリームの取得。

戻り値:
入力ストリーム

getOutputStream

public ExtendedOutputStream getOutputStream()
出力ストリームの取得。

戻り値:
出力ストリーム

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー
導入されたバージョン:
version 4.2

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
このソケットに登録されているクローズ・イベント・リスナーを返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection
導入されたバージョン:
version 4.2

lastError

public Throwable lastError()
このインスタンスのメソッド中で最後に発生した例外を返します。

戻り値:
最後に発生した例外

clearError

public void clearError()
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。

このメソッドを実行すると、次に例外が発生するまで lastError()メソッドは null を返し、 errorIterator()メソッドは空の反復子を返します。

導入されたバージョン:
version 4.0

errorIterator

public Iterator errorIterator()
このインスタンスのメソッド実行中に発生した例外を返します。 このメソッドの返す反復子は発生時間順に例外オブジェクトを返します。 反復子の返すオブジェクトは、Throwable クラスと代入互換のある オブジェクトになります。

戻り値:
例外の反復子

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
このソケットが閉じられているかどうかをチェックします。

戻り値:
ソケットが閉じられている場合は true
導入されたバージョン:
version4.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Localhost (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス Localhost

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.Localhost
すべての実装インタフェース:
Serializable
public class Localhost
extends Object
implements Serializable

このクラスは、サーバプロセスの基礎情報を管理します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

メソッドの概要
byte[] | getAddress() このコンピュータのＩＰアドレスを返します。
String | getHostAddress() このコンピュータのアドレスを返します。
String | getHostName() このコンピュータのホスト名を返します。
static Localhost | instance() このクラスから生成される唯一のインスタンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

instance

public static Localhost instance()
                          throws UnknownHostException
このクラスから生成される唯一のインスタンスを返します。 このメソッドが返すインスタンスは、常に一定で、 VM 内で共有されます。

戻り値:
このクラスのインスタンス
例外:
UnknownHostException - このコンピュータのＩＰアドレスが判定できなかった場合

getAddress

public byte[] getAddress()
このコンピュータのＩＰアドレスを返します。

戻り値:
IPアドレス

getHostAddress

public String getHostAddress()
このコンピュータのアドレスを返します。

戻り値:
アドレス

getHostName

public String getHostName()
このコンピュータのホスト名を返します。

戻り値:
ホスト名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.net (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.java.net
インタフェース
SocketConnectionDistributor
SocketConnectionManager
SocketEventListener
クラス
AbstractSocketConnectionDistributor
ExtendedSocket
Localhost
SocketConnection
SocketPool
例外
UnsupportedNetworkConnectException


jp.co.intra_mart.common.aid.jdk.java.net (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.net

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

参照:
説明

インタフェースの概要
SocketConnectionDistributor | このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionManager | 通信ソケットをプールする機能のインターフェースです。
SocketEventListener | 通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

クラスの概要
AbstractSocketConnectionDistributor | このクラスは、通信ソケットを作成する機能を提供します。
ExtendedSocket | このクラスは、ソケット通信用の入出力機能を提供します。
Localhost | このクラスは、サーバプロセスの基礎情報を管理します。
SocketConnection | ソケットプール用のスケルトン実装を提供します。
SocketPool | このクラスは、通信ソケットをプールする機能を提供します。

例外の概要
UnsupportedNetworkConnectException To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.

パッケージ jp.co.intra_mart.common.aid.jdk.java.net の説明

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.java.net クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager)
    • class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
    • class jp.co.intra_mart.common.aid.jdk.java.net.Localhost (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.java.net の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.net の使用

jp.co.intra_mart.common.aid.jdk.java.net を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net により使用される jp.co.intra_mart.common.aid.jdk.java.net のクラス
AbstractSocketConnectionDistributor
このクラスは、通信ソケットを作成する機能を提供します。
ExtendedSocket
このクラスは、ソケット通信用の入出力機能を提供します。
Localhost
このクラスは、サーバプロセスの基礎情報を管理します。
SocketConnection
ソケットプール用のスケルトン実装を提供します。
SocketConnectionDistributor
このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionManager
通信ソケットをプールする機能のインターフェースです。
SocketEventListener
通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SocketConnection (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス SocketConnection

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
        拡張 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
public abstract class SocketConnection
extends ExtendedSocket

ソケットプール用のスケルトン実装を提供します。

導入されたバージョン:
version 5.0
関連項目:
SocketPool

コンストラクタの概要
protected | SocketConnection(ExtendedSocket socket) ソケット入出力インスタンスを構築します。
protected | SocketConnection(Socket socket) ソケット入出力インスタンスを構築します。
protected | SocketConnection(String address, int port) ソケット入出力インスタンスを構築します。
メソッドの概要
abstract  void release()
ソケットおよび入出力ストリームの利用を中止します。
クラス jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket から継承したメソッド
addCloseSocketEventListener, clearError, close, errorIterator, getCloseSocketEventListeners, getInputStream, getOutputStream, getSocket, isClosed, lastError
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnection

protected SocketConnection(String address,
                           int port)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(Socket socket)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(ExtendedSocket socket)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

release

public abstract void release()
                      throws IOException
ソケットおよび入出力ストリームの利用を中止します。

このインスタンスの利用が終了したら、必ず呼び出して下さい。
このメソッドを呼び出さないと、プール領域中のリソースが完全には 開放されません。
また、スーパークラス ExtendedSocket の close メソッドを呼び出した場合も プール中のリソースが完全に開放されない可能性があります。

リソースの開放は、プールオブジェクトが必要に応じて行います。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketConnectionDistributor

既知のサブインタフェースの一覧:
SocketConnectionManager
既知の実装クラスの一覧:
AbstractSocketConnectionDistributor, SocketPool
public interface SocketConnectionDistributor

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

導入されたバージョン:
version 5.0

メソッドの概要
void | clean() プール中のコネクションをすべて破棄します。
SocketConnection | connection() コネクションの取得。
void | destroy() このプールを破棄します。

メソッドの詳細

connection

public SocketConnection connection()
                            throws IOException
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

destroy

public void destroy()
このプールを破棄します。

clean

public void clean()
プール中のコネクションをすべて破棄します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketConnectionManager

すべてのスーパーインタフェース:
SocketConnectionDistributor
既知の実装クラスの一覧:
SocketPool
public interface SocketConnectionManager
extends SocketConnectionDistributor

通信ソケットをプールする機能のインターフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
int | getCapacity() コネクション作成最大数の取得。
int | getSize() このプールが現在管理しているコネクション数です。
int | usableConnection() 現在待機中のコネクションをです。
インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

メソッドの詳細

getCapacity

public int getCapacity()
コネクション作成最大数の取得。

戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
現在待機中のコネクションをです。

戻り値:
待機中のコネクション数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketEventListener

public interface SocketEventListener

通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

ソケットに関するイベント通知側と組み合わせて利用することにより、 ソケットに関する特定のイベント発生時に独自の処理を実行することができます。

導入されたバージョン:
version 5.0

メソッドの概要
 void handleSocketEvent(ExtendedSocket socket)
ソケットに関するイベント発生時に呼び出されるメソッド。

メソッドの詳細

handleSocketEvent

public void handleSocketEvent(ExtendedSocket socket)
                       throws IOException
ソケットに関するイベント発生時に呼び出されるメソッド。 サブクラスは、このメソッドを実装することにより、特定のソケットに関する イベントの発生を知ることができます。

パラメータ:
socket - イベントの発生したソケット
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketPool (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス SocketPool

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor
        拡張 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool
すべての実装インタフェース:
SocketConnectionDistributor, SocketConnectionManager
public class SocketPool
extends AbstractSocketConnectionDistributor
implements SocketConnectionManager

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

導入されたバージョン:
version 5.0

コンストラクタの概要
SocketPool(String address, int port)
ソケットプールを構築します。
SocketPool(String address, int port, int capacity)
ソケットプールを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | addCreateSocketEventListener(SocketEventListener listener) ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | clean() プール中のコネクションをすべて破棄します。
SocketConnection | connection() コネクションの取得。
void | destroy() このプールを破棄します。
boolean | eject(SocketConnection connection) 指定コネクションをこのプールの管理から切り離します。
protected void | finalize() このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
int | getCapacity() コネクション作成最大数の取得。
Collection | getCloseSocketEventListeners() このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
Collection | getCreateSocketEventListeners() このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
int | getSize() このプールが現在管理しているコネクション数です。
int | usableConnection() 現在待機中のコネクションをです。
クラス jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor から継承したメソッド
createSocket, getAddress, getPort
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketPool

public SocketPool(String address,
                  int port)
ソケットプールを構築します。

このプールで管理できるソケットコネクションは 1 個になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート

SocketPool

public SocketPool(String address,
                  int port,
                  int capacity)
ソケットプールを構築します。

コネクションは動的に生成されます。 capacity 個よりも多くのコネクション要求があった場合、 コネクションが開放されるまで待ち状態になります。
capacity にはプールの性質上、 1 以上の値を指定して下さい。 capacity に 1 より小さな値を指定した場合、プール数は 1 になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
capacity - 接続コネクションの最大数
メソッドの詳細

addCreateSocketEventListener

public void addCreateSocketEventListener(SocketEventListener listener)
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールで新規にソケットが 作成されたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCreateSocketEventListeners

public Collection getCreateSocketEventListeners()
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールのソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

getCapacity

public int getCapacity()
コネクション作成最大数の取得。

定義:
インタフェース SocketConnectionManager 内の getCapacity
戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

定義:
インタフェース SocketConnectionManager 内の getSize
戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
現在待機中のコネクションをです。

定義:
インタフェース SocketConnectionManager 内の usableConnection
戻り値:
待機中のコネクション数

connection

public SocketConnection connection()
                            throws IOException
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

定義:
インタフェース SocketConnectionDistributor 内の connection
戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

eject

public boolean eject(SocketConnection connection)
指定コネクションをこのプールの管理から切り離します。

指定コネクションがこのプールに管理されていたものなら、 このメソッド実行後はこのプールの管理するコネクションが１つ減少するので、 新たにコネクションを作成することができるようになります。

指定のコネクションをこのプールが管理していて他のスレッドによって 使用（connection() メソッドにより取得）されていない場合 true を 返します。指定のコネクションがこのプールにより管理されているもの であった場合でも、他のスレッドにより使用中の場合は false を返します。

パラメータ:
connection - 管理から切り離すコネクション
戻り値:
コネクションの切り離しに成功した場合 true

destroy

public void destroy()
このプールを破棄します。

定義:
インタフェース SocketConnectionDistributor 内の destroy

clean

public void clean()
プール中のコネクションをすべて破棄します。

定義:
インタフェース SocketConnectionDistributor 内の clean

finalize

protected void finalize()
                 throws Throwable
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。 SocketPool クラスは、このメソッドによりオブジェクトの破棄前に リソースのクリーンアップをします。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UnsupportedNetworkConnectException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス UnsupportedNetworkConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.io.IOException
                拡張 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException
すべての実装インタフェース:
Serializable
public class UnsupportedNetworkConnectException
extends IOException

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnsupportedNetworkConnectException()
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String arg0)
Constructor for UnsupportedNetworkConnectException.
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException()
Constructor for UnsupportedNetworkConnectException.

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException(String arg0)
Constructor for UnsupportedNetworkConnectException.

パラメータ:
arg0 -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator の使用

AbstractDualComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での AbstractDualComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util での AbstractDualComparator のサブクラス
 class MultiComparator
複数のコンパレータを使用してソートを行うためにクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.util.DualComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.util.DualComparator の使用

DualComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での DualComparator の使用

DualComparator を実装している jp.co.intra_mart.common.aid.jdk.java.util のクラス
class | AbstractDualComparator ２つのコンパレータを使用してソートを行うクラスです。
class | MultiComparator 複数のコンパレータを使用してソートを行うためにクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties の使用

ExtendedProperties を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml での ExtendedProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml での ExtendedProperties のサブクラス
 class XMLProperties
XML をベースとした不変のプロパティセットを表します。

jp.co.intra_mart.common.aid.jdk.org.w3c.dom での ExtendedProperties の使用

jp.co.intra_mart.common.aid.jdk.org.w3c.dom での ExtendedProperties のサブクラス
 class ElementProperties
DOM をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator の使用

FilterComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での FilterComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util での FilterComparator のサブクラス
 class ReverseComparator
コンパレータのフィルタとして機能します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap の使用

jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties の使用

jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractDualComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス AbstractDualComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
直系の既知のサブクラス:
MultiComparator
public abstract class AbstractDualComparator
extends Object
implements DualComparator

２つのコンパレータを使用してソートを行うクラスです。
比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 もし、その比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
AbstractDualComparator()
新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jdk.java.util.DualComparator から継承したメソッド
getPrimaryComparator, getSecondaryComparator
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

AbstractDualComparator

public AbstractDualComparator()
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は ０、最初の引数が ２ 番目の引 数より大きい場合は正の整数を返します。
このメソッドは ２ つのコンパレータを使用して比較を行いその結果を返します。 比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 比較の結果が０でないときは、その比較した結果を返します。もし比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DualComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
インタフェース DualComparator

すべてのスーパーインタフェース:
Comparator, Serializable
既知の実装クラスの一覧:
AbstractDualComparator
public interface DualComparator
extends Serializable, Comparator

２つのコンパレータを使用してソートを行うためのインターフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
Comparator | getPrimaryComparator() １番目コンパレータを取得します。
Comparator | getSecondaryComparator() ２番目コンパレータを取得します。
インタフェース java.util.Comparator から継承したメソッド
compare, equals

メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
１番目コンパレータを取得します。

戻り値:
１番目のコンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
２番目コンパレータを取得します。

戻り値:
２番目のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedProperties (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ExtendedProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
直系の既知のサブクラス:
ElementProperties
public class ExtendedProperties
extends Properties

java.util.Properties を、より便利に利用するためのインタフェースを提供します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ExtendedProperties()
デフォルト値を持たない空のプロパティリストを作成します。
ExtendedProperties(Properties defaults)
指定されたデフォルト値を持つ空のプロパティリストを作成します。
メソッドの概要
double | doubleValue(String key) 指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
double | doubleValue(String key, double defaultValue) 指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
float | floatValue(String key) 指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
float | floatValue(String key, float defaultValue) 指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
int | intValue(String key) 指定されたキーによって示されるプロパティ値を 数値として取得します。
int | intValue(String key, int defaultValue) 指定されたキーによって示されるプロパティ値を 数値として取得します。
boolean | isFalse(String key) 指定されたキーによって示されるプロパティ値を真偽判定します。
boolean | isTrue(String key) 指定されたキーによって示されるプロパティ値を真偽判定します。
long | longValue(String key) 指定されたキーによって示されるプロパティ値を 長整数として取得します。
long | longValue(String key, long defaultValue) 指定されたキーによって示されるプロパティ値を 長整数として取得します。
int | parseInt(String key, int radix) 2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。
long | parseLong(String key, int radix) 2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedProperties

public ExtendedProperties()
デフォルト値を持たない空のプロパティリストを作成します。

ExtendedProperties

public ExtendedProperties(Properties defaults)
指定されたデフォルト値を持つ空のプロパティリストを作成します。

パラメータ:
defaults - デフォルト値
メソッドの詳細

isTrue

public boolean isTrue(String key)
指定されたキーによって示されるプロパティ値を真偽判定します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値が "true" の場合(大文字と小文字は区別しない) true、そうでない場合 false。

isFalse

public boolean isFalse(String key)
指定されたキーによって示されるプロパティ値を真偽判定します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値が "false" の場合(大文字と小文字は区別しない) true、そうでない場合 false。

intValue

public int intValue(String key)
指定されたキーによって示されるプロパティ値を 数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は 0。

intValue

public int intValue(String key,
                    int defaultValue)
指定されたキーによって示されるプロパティ値を 数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

parseInt

public int parseInt(String key,
                    int radix)
             throws NumberFormatException
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。 このメソッドは、java.lang.Integer.parseInt(String s, int radix) メソッドの仕様に準じます。

パラメータ:
key - プロパティの名前
radix - 使用される基数
戻り値:
プロパティの文字列値を数値として表現した値。
例外:
NumberFormatException - 文字列が解析可能な整数を含まない場合

longValue

public long longValue(String key)
指定されたキーによって示されるプロパティ値を 長整数として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は 0。

longValue

public long longValue(String key,
                      long defaultValue)
指定されたキーによって示されるプロパティ値を 長整数として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

parseLong

public long parseLong(String key,
                      int radix)
               throws NumberFormatException
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。 このメソッドは、java.lang.Long.parseLong(String s, int radix) メソッドの仕様に準じます。

パラメータ:
key - プロパティの名前
radix - 使用される基数
戻り値:
プロパティの文字列値を数値として表現した値。
例外:
NumberFormatException - 文字列が解析可能な整数を含まない場合

floatValue

public float floatValue(String key)
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は float 型の非数 (NaN) 値。

floatValue

public float floatValue(String key,
                        float defaultValue)
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

doubleValue

public double doubleValue(String key)
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は double 型の非数 (NaN) 値。

doubleValue

public double doubleValue(String key,
                          double defaultValue)
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス FilterComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator
すべての実装インタフェース:
Comparator, Serializable
直系の既知のサブクラス:
ReverseComparator
public abstract class FilterComparator
extends Object
implements Comparator, Serializable

コンパレータのフィルターとして機能する抽象クラスです。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
FilterComparator(Comparator comparator)
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
int | compare(Object arg0, Object arg1) 順序付けのために 2 つの引数を比較するメソッドです。
Comparator | getParentComparator() フィルター対象のコンパレータを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

FilterComparator

public FilterComparator(Comparator comparator)
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果

getParentComparator

public Comparator getParentComparator()
フィルター対象のコンパレータを返します。

戻り値:
フィルター対象のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FixedSizeMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス FixedSizeMap

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
すべての実装インタフェース:
Map
public class FixedSizeMap
extends AbstractMap

LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。

このクラスのマップは、決められたサイズの領域持ちます。 キーはコンストラクタで指定された マップのサイズに等しい個数しか、このマップに関連付けることはできません。 すでにマップのサイズに等しい個数のキーが関連付けられている状態で、 別の新しいキーを関連付けようとした場合、LRU アルゴリズムに従い 最も古くに使われたキーが削除され、全体のキー数がマップのサイズに 等しくなるように調整されます。
このオブジェクトは、Thread safe となっています。
このマップは LRU アルゴリズムにより動作するため、 マッピングの追加や更新をしたり、キーにマッピングされている値の取得を した時に、キーのアクセス順をチェックします。 したがって、マップのサイズが大きさに比例して put() や get() メソッドの レスポンス時間が長くなります。 このハッシュテーブルは、適度な大きさで利用することを推奨します。

導入されたバージョン:
version 5.0
関連項目:
Hashtable

入れ子クラスの概要
クラス java.util.Map から継承した入れ子クラス
Map.Entry
コンストラクタの概要
FixedSizeMap(int size)
指定されたサイズの領域を持つマップを構築します。
メソッドの概要
int | capacity() このマップに対してマップできるキーの最大個数を返します。
void | clear() マップからマッピングをすべて削除します。
boolean | containsKey(Object key) 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
Set | entrySet() このマップに格納されているマッピングのセットビューを返します。
Object | get(Object key) マップが、指定されたキーにマッピングしている値を返します。
Object | put(Object key, Object value) 指定された値を、マップ内の指定されたキーに関連付けます 。
Object | remove(Object key) このキーにマッピングがある場合に、そのマッピングをマップから削除します。
クラス java.util.AbstractMap から継承したメソッド
clone, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FixedSizeMap

public FixedSizeMap(int size)
             throws IllegalArgumentException
指定されたサイズの領域を持つマップを構築します。

パラメータ:
size - ハッシュテーブルの容量
例外:
IllegalArgumentException - 容量が 1 より小さい場合
メソッドの詳細

capacity

public int capacity()
このマップに対してマップできるキーの最大個数を返します。 このメソッドの返す値は、コンストラクタで指定されたハッシュテーブルの 容量値をそのまま返すものです。

戻り値:
このマップにエントリできるキーの最大個数

clear

public void clear()
マップからマッピングをすべて削除します。

containsKey

public boolean containsKey(Object key)
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。

パラメータ:
key - このマップにあるかどうかを判定するキー
戻り値:
指定されたキーへのマッピングをこのマップが含む場合は true

entrySet

public Set entrySet()
このマップに格納されているマッピングのセットビューを返します。 このセットの各要素は Map.Entry です。セットはこのマップを 基にしているので、マップへの変更、およびセットへの変更は、 互いに反映されます。 セットでの繰り返し処理が進行中にマップが変更された場合、 反復の結果は保証されません。セットは要素の削除をサポートしており、 対応するエントリをマップから削除することができます。 削除には、Iterator.remove、Set.remove、removeAll、retainAll、 および clear オペレーションが使えます。 add または addAll オペレーションはサポートされません。

戻り値:
このマップに格納されているマッピングのセットビュー

get

public Object get(Object key)
マップが、指定されたキーにマッピングしている値を返します。 マップに、このキーに対するマッピングがない場合は null を返します。

パラメータ:
key - 関連付けられている値が返されるキー
戻り値:
マップが、指定されたキーにマッピングしている値。このキーに対するマッピングがマップにない場合は null
関連項目:
containsKey(Object)

put

public Object put(Object key,
                  Object value)
指定された値を、マップ内の指定されたキーに関連付けます 。 マップにすでにこのキーに対するマッピングがある場合、 古い値は置き換えられます。

パラメータ:
key - 指定された値が関連付けられるキー
value - 指定されたキーに関連付けられる値
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
例外:
NullPointerException - キーまたは値が null の場合

remove

public Object remove(Object key)
このキーにマッピングがある場合に、そのマッピングをマップから削除します。

パラメータ:
key - マッピングがマップから削除されるキー
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultiComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス MultiComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
public class MultiComparator
extends AbstractDualComparator

複数のコンパレータを使用してソートを行うためにクラスです。
実行したコンパレータの compare() メソッドの戻り値が０でなくなるか、全てのコンパレータの実行が完了するまで下記の順番でコンパレータの実行が行われます。

・コンストラクタで指定された第１コンパレータ
・コンストラクタで指定された第２コンパレータ
・addComparator()で追加されたコンパレータ

このクラスは同じインスタンスのコンパレータを２つ以上持つことを想定されていません。 そのような操作を行うと、正しい結果が得られない可能性があります。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
MultiComparator(Comparator primaryComparator, Comparator secondaryComparator)
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
メソッドの概要
void | addComparator(Comparator comparator) 指定されたコンパレータ comparator を追加します。
Collection | getComparators() 設定されている全てのコンパレータを取得します。
Comparator | getPrimaryComparator() 第１コンパレータを返します。
Comparator | getSecondaryComparator() 第２コンパレータを返します。
boolean | removeComparator(Comparator comparator) 指定されたコンパレータ comparatorを削除します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

MultiComparator

public MultiComparator(Comparator primaryComparator,
                       Comparator secondaryComparator)
                throws NullPointerException
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
もし primaryComparator がnullで、 secondaryComparator がnullでない時は、secondaryComparator が第１コンパレータとして扱われます。
primaryComparator 、secondaryComparator がともにnullの時は例外を発生させます。

パラメータ:
primaryComparator - 第１コンパレータ
secondaryComparator - 第２コンパレータ
例外:
NullPointerException - primaryComparator 、 secondaryComparator がともにnullの時発生します。
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
第１コンパレータを返します。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
第２コンパレータを返します。 このメソッドの戻り値は、設定された第２コンパレータをラップしたMultiComparatorのオブジェクトになります。 もし、第２コンパレータが設定されていないときはnullを返します。

戻り値:
第２コンパレータ

addComparator

public void addComparator(Comparator comparator)
                   throws NullPointerException
指定されたコンパレータ comparator を追加します。 指定されたコンパレータ comparatorがnullの時は例外を発生させます。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 指定されたcomparatorがnullの時に発生します。

removeComparator

public boolean removeComparator(Comparator comparator)
                         throws IllegalArgumentException
指定されたコンパレータ comparatorを削除します。 指定されたコンパレータの削除に成功したときはtrue、失敗したときはfalseを返します。 このクラスのオブジェクトが持つ全てのコンパレータを削除しようとすると例外が発生します。

パラメータ:
comparator - 削除対象のコンパレータ
戻り値:
削除に成功したときはtrue、失敗したときはfalseを返す。
例外:
IllegalArgumentException - 全てのコンパレータを削除しようとした時に発生します。

getComparators

public Collection getComparators()
設定されている全てのコンパレータを取得します。

戻り値:
設定されている全てのコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.util (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.java.util
インタフェース
DualComparator
クラス
AbstractDualComparator
ExtendedProperties
FilterComparator
FixedSizeMap
MultiComparator
ResourceBundleProperties
ReverseComparator
SequenceComparator


jp.co.intra_mart.common.aid.jdk.java.util (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.util

このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

参照:
説明

インタフェースの概要
DualComparator ２つのコンパレータを使用してソートを行うためのインターフェースです。

クラスの概要
AbstractDualComparator | ２つのコンパレータを使用してソートを行うクラスです。
ExtendedProperties | java.util.Properties を、より便利に利用するためのインタフェースを提供します。
FilterComparator | コンパレータのフィルターとして機能する抽象クラスです。
FixedSizeMap | LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。
MultiComparator | 複数のコンパレータを使用してソートを行うためにクラスです。
ResourceBundleProperties | このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。
ReverseComparator | コンパレータのフィルタとして機能します。
SequenceComparator | 挿入順にソートするためのコンパレータです。

パッケージ jp.co.intra_mart.common.aid.jdk.java.util の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.java.util クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator (implements jp.co.intra_mart.common.aid.jdk.java.util.DualComparator)
      • class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
    • class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
    • class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator (implements java.util.Comparator, java.io.Serializable)

インタフェース階層

  • interface java.util.Comparator
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.io.Serializable)
  • interface java.io.Serializable
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.util.Comparator)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.java.util の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.util の使用

jp.co.intra_mart.common.aid.jdk.java.util を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util | このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
AbstractDualComparator
２つのコンパレータを使用してソートを行うクラスです。
DualComparator
２つのコンパレータを使用してソートを行うためのインターフェースです。
FilterComparator
コンパレータのフィルターとして機能する抽象クラスです。

jp.co.intra_mart.common.aid.jdk.javax.xml により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
ExtendedProperties
java.util.Properties を、より便利に利用するためのインタフェースを提供します。

jp.co.intra_mart.common.aid.jdk.org.w3c.dom により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
ExtendedProperties
java.util.Properties を、より便利に利用するためのインタフェースを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ResourceBundleProperties (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ResourceBundleProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
public class ResourceBundleProperties
extends Properties

このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。プロパティデータは、java.util.ResourceBundle により取得されます。
ロードできるリソースに関しては、java.util.ResourceBundle の 説明を参照して下さい。
このクラスのコンストラクタが、java.util.ResourceBundle クラスの getBundle() メソッドと同様の機能を提供しています。 各コンストラクタは、引数の同じ getBundle() メソッドに対応しています。

導入されたバージョン:
version 5.0
関連項目:
Properties, ResourceBundle, 直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ResourceBundleProperties(String baseName)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale, ClassLoader loader)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
メソッドの概要
 Locale getLocale()
ResourceBundle の Locale を返します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceBundleProperties

public ResourceBundleProperties(String baseName)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale,
                                ClassLoader loader)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
loader - リソースをロードする ClassLoader
例外:
MissingResourceException - リソースの照合に失敗した場合
メソッドの詳細

getLocale

public Locale getLocale()
ResourceBundle の Locale を返します。
この関数は、このオブジェクトが本当に要求されたロケールに対応しているか、 またはフォールバックであるかを判定するために、このオブジェクトが 構築されたあとで使用できます。

この関数は、java.util.ResourceBundle クラスの getLocale() と 同じであり、java.util.ResourceBundle クラスとインターフェースを 合わせるために提供されています。 java.util.ResourceBundle クラスの getLocale() の説明を参照して下さい。

戻り値:
ロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReverseComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ReverseComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
すべての実装インタフェース:
Comparator, Serializable
public class ReverseComparator
extends FilterComparator

コンパレータのフィルタとして機能します。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ReverseComparator(Comparator comparator)
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator から継承したメソッド
getParentComparator
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

ReverseComparator

public ReverseComparator(Comparator comparator)
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

定義:
インタフェース Comparator 内の compare
オーバーライド:
クラス FilterComparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
フィルタ対象のコンパレータの compare() メソッドの結果を反転させた値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SequenceComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス SequenceComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator
すべての実装インタフェース:
Comparator, Serializable
public class SequenceComparator
extends Object
implements Comparator, Serializable

挿入順にソートするためのコンパレータです。
このコンパレータは挿入が早い物から遅い物の順に並べます。
このコンパレータは、挿入されたオブジェクトの順番をインスタンス変数として持っています。 そのため、複数のオブジェクトでこのコンパレータを共有使用すると正しく動作しない可能性があります。
またこのクラスは、java.lang.TreeSet、java.lang.TreeMapで使用されることを想定して作られています。 そのため、他のクラスのコンパレータとして使用すると正しく動作しない可能性があります。 クラスで管理できるオブジェクトの数は、２の３１乗-１までのみ管理できます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
SequenceComparator()
新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

SequenceComparator

public SequenceComparator()
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドの目的は、挿入順にソートすることです。 引数１と引数２を比較したとき、引数１の方が挿入が遅いときは正の数、早い時は負の数を返します。
引数１と引数２が同じインスタンスの時は０を返します

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引き数１
arg1 - 引き数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.common.aid.jdk.javax.xml (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.javax.xml
クラス
XMLProperties


jp.co.intra_mart.common.aid.jdk.javax.xml (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml

このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

参照:
説明

クラスの概要
XMLProperties XML をベースとした不変のプロパティセットを表します。

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の説明

このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.javax.xml クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
              • class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml の使用

jp.co.intra_mart.common.aid.jdk.javax.xml はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


XMLProperties (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.javax.xml
クラス XMLProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
                    拡張 jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
                        拡張 jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
public class XMLProperties
extends ElementProperties

XML をベースとした不変のプロパティセットを表します。 このクラスは、XML を元データとして、Properties として 利用できるインタフェースを提供します。

読み込んだ XML ソースは、DocumentBuilderFactory が 返すパーサを利用して解析します。 XML で記述された各情報に対しては、XPath 形式の文字列をプロパティ名として Properties.getProperty(java.lang.String) により アクセスできます。

プロパティ名の例

  • /root/elm1 ・・・タグに挟まれた文字列情報
  • /root/elm1/@attr ・・・タグの属性
  • /root/elm1/text() ・・・タグに挟まれた文字列情報を連結したもの
  • /root/elm1/comment() ・・・コメントを連結したもの

上記以外の XPath 構文は、解釈できません。 また、.. や // 等を用いた相対指定もできません。

取得できる値は、テキストノードおよび属性(attribute)ノードの値のみです。 コメントノード等の値は取得できません。

バージョン:
Version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
XMLProperties(File f)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource in)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource in, Properties parent)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream in)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream in, Properties parent)
指定データを持つ新しいプロパティセットを作成します。
メソッドの概要
 Document getDocument()
設定ファイルのドキュメントノードを返します。
クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties から継承したメソッド
getElement, getProperties
クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties から継承したメソッド
doubleValue, doubleValue, floatValue, floatValue, intValue, intValue, isFalse, isTrue, longValue, longValue, parseInt, parseLong
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

XMLProperties

public XMLProperties(File f)
              throws FileNotFoundException,
                     ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
f - 設定ファイル（xml）のパス
例外:
FileNotFoundException - ファイルがな場合。またはファイルにアクセスできない場合。
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputStream in)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputSource in)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputStream in,
                     Properties parent)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
parent - 基礎データ
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputSource in,
                     Properties parent)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
parent - 基礎データ
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー
メソッドの詳細

getDocument

public Document getDocument()
設定ファイルのドキュメントノードを返します。

戻り値:
ドキュメントノード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties の使用

ElementProperties を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml での ElementProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml での ElementProperties のサブクラス
 class XMLProperties
XML をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ElementProperties (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.org.w3c.dom
クラス ElementProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
                    拡張 jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
直系の既知のサブクラス:
XMLProperties
public class ElementProperties
extends ExtendedProperties

DOM をベースとした不変のプロパティセットを表します。 このクラスは、DOM を元データとして、Properties として 利用できるインタフェースを提供します。

DOM の各情報に対しては、XPath 形式の文字列をプロパティ名として Properties.getProperty(java.lang.String) により アクセスできます。

プロパティ名の例

  • /root/elm1 ・・・タグに挟まれた文字列情報
  • /root/elm1/@attr ・・・タグの属性
  • /root/elm1/text() ・・・タグに挟まれた文字列情報を連結したもの
  • /root/elm1/comment() ・・・コメントを連結したもの

上記以外の XPath 構文は、解釈できません。 また、.. や // 等を用いた相対指定もできません。

取得できる値は、テキストノードおよび属性(attribute)ノードの値のみです。 コメントノード等の値は取得できません。

バージョン:
Version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ElementProperties(Element element)
指定のエレメントの情報をプロパティズ化します。
ElementProperties(Element element, Properties parent)
指定のエレメントの情報をプロパティズ化します。
メソッドの概要
Element | getElement() 現在のプロパティズの元となったエレメントノードを返します。
String[] | getProperties(String key) 指定のキーにマップされた値のリストを返します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties から継承したメソッド
doubleValue, doubleValue, floatValue, floatValue, intValue, intValue, isFalse, isTrue, longValue, longValue, parseInt, parseLong
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ElementProperties

public ElementProperties(Element element)
指定のエレメントの情報をプロパティズ化します。

パラメータ:
element - プロパティズ化するエレメントノード

ElementProperties

public ElementProperties(Element element,
                         Properties parent)
指定のエレメントの情報をプロパティズ化します。

パラメータ:
element - プロパティズ化するエレメントノード
parent - 基礎データ
メソッドの詳細

getElement

public Element getElement()
現在のプロパティズの元となったエレメントノードを返します。

戻り値:
エレメントノード

getProperties

public String[] getProperties(String key)
指定のキーにマップされた値のリストを返します。
XML 中で同名のタグが連続している場合など、タグや属性から生成された キー名称が同一のもののすべてを返します。

パラメータ:
key - キー
戻り値:
キーにマップされた値の配列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.org.w3c.dom (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.org.w3c.dom
クラス
ElementProperties


jp.co.intra_mart.common.aid.jdk.org.w3c.dom (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom

このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

参照:
説明

クラスの概要
ElementProperties DOM をベースとした不変のプロパティセットを表します。

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の説明

このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.org.w3c.dom クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.org.w3c.dom の使用

jp.co.intra_mart.common.aid.jdk.org.w3c.dom を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml により使用される jp.co.intra_mart.common.aid.jdk.org.w3c.dom のクラス
ElementProperties
DOM をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter の使用

AdvancedOutputStreamWriter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset での AdvancedOutputStreamWriter の使用

AdvancedOutputStreamWriter を返す jp.co.intra_mart.foundation.utility.charset のメソッド
static AdvancedOutputStreamWriter AdvancedOutputStreamWriter.createWriter(OutputStreamWriter writer)
推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder の使用

jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の使用

jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException の使用

ResourceFormatException を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での ResourceFormatException の使用

ResourceFormatException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
protected  void CharacterEncoder.setCharacterEncoding(String enc)
このオブジェクトが対象とする文字エンコーディングを設定します。

ResourceFormatException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のコンストラクタ
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

jp.co.intra_mart.foundation.utility.charset での ResourceFormatException の使用

jp.co.intra_mart.foundation.utility.charset での ResourceFormatException のサブクラス
 class ResourceFormatException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException の使用

ResourceNotFoundException を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での ResourceNotFoundException の使用

ResourceNotFoundException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
protected  void CharacterEncoder.setCharacterEncoding(String enc)
このオブジェクトが対象とする文字エンコーディングを設定します。

ResourceNotFoundException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のコンストラクタ
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

jp.co.intra_mart.foundation.utility.charset での ResourceNotFoundException の使用

jp.co.intra_mart.foundation.utility.charset での ResourceNotFoundException のサブクラス
 class ResourceNotFoundException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AdvancedOutputStreamWriter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス AdvancedOutputStreamWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
public class AdvancedOutputStreamWriter
extends FilterWriter

このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。

通常、ASCII の範囲に含まれない文字は、java.io.OutputStreamWriter を 利用して相互に文字コード変換した場合、各文字エンコーディングの Unicode に対するマッピングの相違により、本来その文字エンコーディングにおいて 存在する文字であってもコード不明を意味する「?」に置き換えられてしまう ことがあります。 いわゆる、この文字化けに対して、文字コード変換前に、 対象となる文字エンコーディングに対する Unicode の正しい文字に 置換することで、いくつかの文字については正しく文字コード変換することが できます。
このクラスでは、この方式により文字化けを回避します。

文字化けに対する文字のマッピングおよび対応する文字エンコーディングに 関しては、jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスの仕様に準じます。

導入されたバージョン:
version 5.0
関連項目:
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
メソッドの概要
String | getCharacterEncoding() このオブジェクトが対象としている文字エンコーディング名を返します。
OutputStreamWriter | getOutputStreamWriter() このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
void | write(char[] cbuf, int off, int len) 文字の配列の一部を書き込みます。
void | write(int c) 単一の文字を書き込みます。
void | write(String str, int off, int len) 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  String charsetName)
                           throws UnsupportedEncodingException,
                                  ResourceNotFoundException,
                                  ResourceFormatException,
                                  IOException
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
charsetName - サポートされる charset の名前
例外:
UnsupportedEncodingException - 指定された文字エンコーディングがサポートされていない場合
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out)
                           throws ResourceFormatException,
                                  ResourceNotFoundException,
                                  IOException
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  Charset cs)
                           throws IOException,
                                  ResourceFormatException,
                                  ResourceNotFoundException
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
cs - サポートされる Charset
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 入出力エラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  CharsetEncoder enc)
                           throws ResourceFormatException,
                                  IOException,
                                  ResourceNotFoundException
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
enc - 文字エンコーディングエンコーダ
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStreamWriter writer)
                           throws ResourceNotFoundException,
                                  IOException,
                                  ResourceFormatException
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

なお、このオブジェクトが対応する文字エンコーディングは、 java.io.OutputStreamWriter#getEncoding() の返す値によって 決定します。 java.io.OutputStreamWriter#getEncoding() が null を返す場合、 このコンストラクタは NUllPointerException をスローして オブジェクトの作成に失敗します。

パラメータ:
writer - 基本となるストリームを提供する java.io.OutputStreamWriter オブジェクト
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
ResourceFormatException - 設定に不整合がある場合
IOException - 設定の読み込みエラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字の配列の一部を書き込みます。

パラメータ:
cbuf - 書き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
単一の文字を書き込みます。

パラメータ:
c - 書き込む文字を指定する int
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
文字列の一部を書き込みます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

getOutputStreamWriter

public OutputStreamWriter getOutputStreamWriter()
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。

戻り値:
基礎となっている java.io.OutputStreamWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CharacterEncoder (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス CharacterEncoder

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
public class CharacterEncoder
extends Object

このクラスは、文字エンコードの機能を提供します。

このクラスは、Java runtime が提供する通常の文字コード変換において 文字のマッピング定義の相違に起因して文字化けしてしまう現象を解決するための 一つの方法となります。 実際には、定義ファイルに設定されている文字をネイティブコードへ変換する前に 他の文字へ変更する事により、文字化けを防ぎます。

例えば、EUC_JP における文字「～」は、 Unicode へ変換した際 0x301C(Wave Dash) にマッピングされます。 これに対して、SJIS では文字「～」は、 Unicode の 0xFF5E(Fullwidth Tilde) にマッピングされています。 このため、相互に文字コード変換をすると、 文字「?」に置き換わると言う現象(いわゆる文字化け)が発生します。
このクラスでは、Unicode から SJIS へ変換する際に Unicode の文字 0x301C(Wave Dash) を 0xFF5E(Fullwidth Tilde) へ変更してから 文字コード変換を行います。

定義ファイルは、クラスローダを利用して検索および読み込まれます。 したがって、定義ファイルはクラスパスに設定されているディレクトリまたは アーカイブファイル内に配置する必要があります。
各文字エンコーディングと文字の変換テーブルの関連については、 定義ファイル jp/co/intra_mart/resources/charset/encoding/mapping.xml に記載されています。

導入されたバージョン:
version 5.0

コンストラクタの概要
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
メソッドの概要
byte[] | encode(char c) 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(char[] c) 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(String str) 指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。
String | getCharacterEncoding() このオブジェクトが対象としている文字エンコーディング名を返します。
String | newString(char[] c) getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
String | newString(String str) getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
protected void | setCharacterEncoding(String enc) このオブジェクトが対象とする文字エンコーディングを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterEncoder

public CharacterEncoder(String enc)
                 throws ResourceNotFoundException,
                        ResourceFormatException,
                        IOException
文字コード変換のためのエンコーダを作成します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

protected void setCharacterEncoding(String enc)
                             throws ResourceFormatException,
                                    ResourceNotFoundException,
                                    IOException
このオブジェクトが対象とする文字エンコーディングを設定します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー

encode

public byte[] encode(char c)
              throws UnsupportedEncodingException,
                     IOException
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(char[] c)
              throws UnsupportedEncodingException,
                     IOException
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字配列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(String str)
              throws UnsupportedEncodingException,
                     IOException
指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
str - 文字列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

newString

public String newString(String str)
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 str のマッピングを修正した 新しい文字列です。

パラメータ:
str - 文字列
戻り値:
マッピングを修正された新しい文字列

newString

public String newString(char[] c)
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 c のマッピングを修正した 新しい文字列です。
引数の配列 c は変化しません。

パラメータ:
c - 文字配列
戻り値:
新しい文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CharacterSetManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス CharacterSetManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
public class CharacterSetManager
extends Object

このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。

J2SE,v1.4でサポートされているエンコーディングセット名から IANAに登録されているキャラクタセット名へのマッピングについては、 定義ファイル jp/co/intra_mart/common/aid/jdk/util/charset/jdk2iana.properties に記載されています。

IANAに登録されているキャラクタセット名と J2SE,v1.4 でサポートされているエンコーディングセット名へのマッピングについては、 定義ファイル jp/co/intra_mart/common/aid/jdk/util/charset/jdk2iana.properties に記載されています。

導入されたバージョン:
version 5.0

コンストラクタの概要
CharacterSetManager()
メソッドの概要
static String | toIANAName(String jdkEncodingSetName) 指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
static String | toJDKName(String ianaCharacterSetName) 指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterSetManager

public CharacterSetManager()
メソッドの詳細

toJDKName

public static String toJDKName(String ianaCharacterSetName)
指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
対応するエンコーディングセット名が見つからない場合には 指定されたキャラクタセット名をそのまま返却します。

パラメータ:
ianaCharacterSetName - IANAに登録されている キャラクタセット名
戻り値:
J2SEでサポートされているエンコーディングセット名

toIANAName

public static String toIANAName(String jdkEncodingSetName)
指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
対応するキャラクタセット名が見つからない場合には 指定されたエンコーディングセット名をそのまま返却します。

パラメータ:
jdkEncodingSetName - J2SEでサポートされているエンコーディングセット名
戻り値:
IANAに登録されているキャラクタセット名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util.charset (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.util.charset
クラス
AdvancedOutputStreamWriter
CharacterEncoder
CharacterSetManager
例外
ResourceFormatException
ResourceNotFoundException


jp.co.intra_mart.common.aid.jdk.util.charset (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
AdvancedOutputStreamWriter | このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
CharacterEncoder | このクラスは、文字エンコードの機能を提供します。
CharacterSetManager | このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。

例外の概要
ResourceFormatException | リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException | リソースがないことを通知する例外です。

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の説明

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.util.charset クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util.charset の使用

jp.co.intra_mart.common.aid.jdk.util.charset を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset により使用される jp.co.intra_mart.common.aid.jdk.util.charset のクラス
ResourceFormatException
リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException
リソースがないことを通知する例外です。

jp.co.intra_mart.foundation.utility.charset により使用される jp.co.intra_mart.common.aid.jdk.util.charset のクラス
AdvancedOutputStreamWriter
このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
ResourceFormatException
リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException
リソースがないことを通知する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ResourceFormatException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス ResourceFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ResourceFormatException
public class ResourceFormatException
extends Exception

リソースの内容が不適切であることを通知する例外です。

設定の内容に誤りがあるか、または定義の書式が正しくない場合にスローされます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ResourceFormatException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceFormatException

public ResourceFormatException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceFormatException

public ResourceFormatException(String msg,
                               Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResourceNotFoundException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス ResourceNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ResourceNotFoundException
public class ResourceNotFoundException
extends Exception

リソースがないことを通知する例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ResourceNotFoundException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceNotFoundException

public ResourceNotFoundException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceNotFoundException

public ResourceNotFoundException(String msg,
                                 Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.util.Counter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.Counter の使用

jp.co.intra_mart.common.aid.jdk.util.Counter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.ErrorEvent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.ErrorEvent の使用

ErrorEvent を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util での ErrorEvent の使用

ErrorEvent 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util のメソッド
 void ErrorEventListener.handleError(ErrorEvent err)
発生した例外を通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener の使用

ErrorEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io での ErrorEventListener の使用

ErrorEventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.io のコンストラクタ
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
出力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
入力ストリームを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.EventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util のメソッド
 void EventQueueController.entry(EventListener listener)
イベントリスナーの登録。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.EventQueueController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.EventQueueController の使用

EventQueueController を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での EventQueueController の使用

EventQueueController 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.LockMonitor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.LockMonitor の使用

jp.co.intra_mart.common.aid.jdk.util.LockMonitor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions の使用

jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter の使用

AbstractMessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での AbstractMessageReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report での AbstractMessageReporter のサブクラス
class | FileReporter メッセージのファイル出力機能を提供します。
class | MultiCastReporter メッセージを複数のストリームに出力するためのフィルタークラスです。
class | PrintStreamReporter メッセージ出力用クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.FileReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の使用

FilterMessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での FilterMessageReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report での FilterMessageReporter のサブクラス
class | LineReportFilter メッセージを行出力するためのフィルタークラスです。
class | ReportLevelFilter メッセージの出力制御を行うためのフィルタークラスです。
class | RepresentativeReporter メッセージ出力をイベント処理するためのフィルタークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter の使用

jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter の使用

MessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での MessageReporter の使用

MessageReporter を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
class | AbstractMessageReporter メッセージ出力用のスケルトンクラスです。
class | FileReporter メッセージのファイル出力機能を提供します。
class | FilterMessageReporter メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
class | LineReportFilter メッセージを行出力するためのフィルタークラスです。
class | MultiCastReporter メッセージを複数のストリームに出力するためのフィルタークラスです。
class | PrintStreamReporter メッセージ出力用クラスです。
class | ReportLevelFilter メッセージの出力制御を行うためのフィルタークラスです。
class | RepresentativeReporter メッセージ出力をイベント処理するためのフィルタークラスです。

MessageReporter として宣言されている jp.co.intra_mart.common.aid.jdk.util.report のフィールド
protected  MessageReporter FilterMessageReporter.out
基礎出力ストリームです。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
void | MultiCastReporter.addReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
boolean | MultiCastReporter.hasReporter(MessageReporter reporter) 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | MultiCastReporter.removeReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
ReportLevelFilter(MessageReporter out, int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner の使用

ReportFileConditioner を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportFileConditioner の使用

ReportFileConditioner を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
class | EverydayConditioner このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | FileSizeConditioner このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | OutputSizeConditioner このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | PeriodicConditioner このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。

ReportFileConditioner 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
void | FileReporter.addConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
boolean | FileReporter.removeConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter の使用

ReportFileWriter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportFileWriter の使用

ReportFileWriter として宣言されている jp.co.intra_mart.common.aid.jdk.util.report のフィールド
protected  ReportFileWriter FileReporter.out
基礎出力ストリームです。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
boolean | ReportFileConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | PeriodicConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | OutputSizeConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | FileSizeConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | EverydayConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の使用

ReportLevel を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportLevel の使用

ReportLevel を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
 class ReportLevelFilter
メッセージの出力制御を行うためのフィルタークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の使用

jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractMessageReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス AbstractMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
FileReporter, MultiCastReporter, PrintStreamReporter
public abstract class AbstractMessageReporter
extends Object
implements MessageReporter

メッセージ出力用のスケルトンクラスです。

サブクラスでは、report メソッドをオーバーライドして、 任意の出力先にメッセージを出力する機能を実装する必要があります。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractMessageReporter()
唯一のコンストラクタ。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) data をメッセージとして出力します。
abstract void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractMessageReporter

protected AbstractMessageReporter()
唯一のコンストラクタ。

メソッドの詳細

report

public abstract void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(String.valueOf(data))

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EverydayConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス EverydayConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner
すべての実装インタフェース:
ReportFileConditioner
public class EverydayConditioner
extends Object
implements ReportFileConditioner

このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 指定時間になった(指定時間を経過した)ときに、 メッセージファイルのローテイト機能イベントを発生させることができます。 時間のチェックは時および分によるものなので、FileReporter の中で リフレッシュイベントは毎日発生することになります。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
EverydayConditioner(int hours, int minutes)
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes)
                    throws IllegalArgumentException
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
例外:
IllegalArgumentException - 引数が有効範囲外の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
このオブジェクトの作成時に指定された時刻を経過して最初の呼び出し時 の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FileReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
すべての実装インタフェース:
MessageReporter
public class FileReporter
extends AbstractMessageReporter

メッセージのファイル出力機能を提供します。

このクラスは、report メソッドで渡されたメッセージを指定のファイルに 出力します。

導入されたバージョン:
version 5.0

フィールドの概要
protected  ReportFileWriter out
基礎出力ストリームです。
コンストラクタの概要
FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | addConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
void | close() このオブジェクトを閉じます。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
boolean | removeConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected ReportFileWriter out
基礎出力ストリームです。

コンストラクタの詳細

FileReporter

public FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

addConditioner

public void addConditioner(ReportFileConditioner conditioner)
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
引数が null の場合は、何の効果もありません。 また、conditioner が既に登録済みのインスタンスである場合、 追加登録はされません。

パラメータ:
conditioner - 追加する ReportFileConditioner のインスタンス

removeConditioner

public boolean removeConditioner(ReportFileConditioner conditioner)
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
引数が null の場合は、何の効果もありません。

パラメータ:
conditioner - 削除する ReportFileConditioner のインスタンス
戻り値:
指定のオブジェクトを削除できた場合 true。

report

public void report(String message)
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileSizeConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FileSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
public class FileSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
FileSizeConditioner(long max)
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSizeConditioner

public FileSizeConditioner(long max)
                    throws IllegalArgumentException
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、メッセージファイルが指定の大きさ(max)以上に なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルサイズが、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterMessageReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FilterMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
LineReportFilter, ReportLevelFilter, RepresentativeReporter
public class FilterMessageReporter
extends Object
implements MessageReporter

メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。

基礎出力ストリームにメッセージを出力する前にメッセージを加工したりする 追加機能を提供するクラスを作成するために利用することができます。

このクラスは、単に MessageReporter の全てのメソッドを オーバーライドし、各要求を基礎出力ストリームに渡す機能を提供しています。 サブクラスでは、メソッドを追加したり、必要に応じてメソッドをオーバーライド することがあります。

導入されたバージョン:
version 5.0

フィールドの概要
protected  MessageReporter out
基礎出力ストリームです。
コンストラクタの概要
FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 基礎出力ストリームに対してメッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected MessageReporter out
基礎出力ストリームです。

コンストラクタの詳細

FilterMessageReporter

public FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に message を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドでは、基礎出力リポートオブジェクトも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineReportFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス LineReportFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
すべての実装インタフェース:
MessageReporter
public class LineReportFilter
extends FilterMessageReporter

メッセージを行出力するためのフィルタークラスです。

このクラスを利用すると、report メソッドに渡されたメッセージ文字列に 改行コードを付加して、行出力することができます。
以下のようなプログラムにより、ログファイルをログファイルを作成することが できます。

FIle logFile = new File("test.log");
ReportFileWriter writer = new ReportFileWriter(logFile);
FileReporter writer = new FileReporter(writer);
MessageReporter reporter = new LineReportFilter(writer);
これで、変数 reporter の report メソッドを呼び出す毎に、 ファイル test.log に report メソッド指定したメッセージが １行として出力されます。

導入されたバージョン:
version 5.0
関連項目:
ReportLevel

フィールドの概要
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
メソッドの概要
void | report(Object data) 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LineReportFilter

public LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
メッセージを出力します。
このメソッドは、基礎出力ストリームに対して、message に 改行コードを付加してメッセージを１行出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース MessageReporter

既知の実装クラスの一覧:
AbstractMessageReporter, FilterMessageReporter
public interface MessageReporter

メッセージ出力のためのインターフェースです。

このインターフェースを実装したクラスでは、report メソッドで 指定されたメッセージを任意の出力先に対して出力する機能を提供します。

導入されたバージョン:
version 5.0

メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。

メソッドの詳細

report

public void report(String message)
メッセージを出力します。

パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultiCastReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス MultiCastReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
すべての実装インタフェース:
MessageReporter
public class MultiCastReporter
extends AbstractMessageReporter

メッセージを複数のストリームに出力するためのフィルタークラスです。

このクラスは、MessageReporter インターフェースを実装したクラスに対する フィルタークラスとして働きます。 report メソッドに渡されたメッセージデータは、指定された複数の MessageReporter インターフェースすべてに渡されます。
このフィルタークラスを利用することにより、複数の MessageReporter に 対して同じメッセージを渡すことができるため、メッセージ出力プログラムを 効率的に記述することができます。

メッセージの出力先となる MessageReporter は、addReporter メソッドで 定義します。addReporter メソッドでの定義順と、実際の実行順は 保証されません。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultiCastReporter()
唯一のコンストラクタ。
メソッドの概要
void | addReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
Iterator | getReporters() セット内の要素についての反復子を返します。
boolean | hasReporter(MessageReporter reporter) 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | removeReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultiCastReporter

public MultiCastReporter()
唯一のコンストラクタ。

メソッドの詳細

addReporter

public void addReporter(MessageReporter reporter)
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。 すでに指定のオブジェクトを要素としてもっていた場合、 このメソッドは何も行いません。

パラメータ:
reporter - セットに追加される要素

hasReporter

public boolean hasReporter(MessageReporter reporter)
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。

パラメータ:
reporter - セットに含まれているかチェックする要素
戻り値:
セット内に指定された要素がある場合は true

removeReporter

public boolean removeReporter(MessageReporter reporter)
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

パラメータ:
reporter - セットにあった場合に削除されるオブジェクト
戻り値:
指定された要素がセット内にあった場合は true

getReporters

public Iterator getReporters()
セット内の要素についての反復子を返します。 反復子から取得される各要素は、addReporter メソッドにより追加された リポーターオブジェクトになります。 各要素の取得順は保証されません。 このオブジェクトが閉じられている場合 null を返します。

戻り値:
セット内の要素についての反復子

report

public void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス AbstractMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このオブジェクトの持つすべての Reporter オブジェクトを閉じて、 リソースを開放します。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 このオブジェクトの持つすべての Reporter オブジェクトをフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OutputSizeConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス OutputSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
public class OutputSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
OutputSizeConditioner(long max)
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

OutputSizeConditioner

public OutputSizeConditioner(long max)
                      throws IllegalArgumentException
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
このオブジェクトは、ログファイルへ書き出したメッセージの量が 一定(max)以上の大きさに なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルへの出力文字数が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util.report (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.util.report
インタフェース
MessageReporter
ReportFileConditioner
ReportLevel
クラス
AbstractMessageReporter
EverydayConditioner
FileReporter
FileSizeConditioner
FilterMessageReporter
LineReportFilter
MultiCastReporter
OutputSizeConditioner
PeriodicConditioner
PrintStreamReporter
ReportFileWriter
ReportLevelFilter
RepresentativeReporter


jp.co.intra_mart.common.aid.jdk.util.report (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.report

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MessageReporter | メッセージ出力のためのインターフェースです。
ReportFileConditioner | このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportLevel | メッセージレベルのインターフェースです。

クラスの概要
AbstractMessageReporter | メッセージ出力用のスケルトンクラスです。
EverydayConditioner | このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
FileReporter | メッセージのファイル出力機能を提供します。
FileSizeConditioner | このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
FilterMessageReporter | メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
LineReportFilter | メッセージを行出力するためのフィルタークラスです。
MultiCastReporter | メッセージを複数のストリームに出力するためのフィルタークラスです。
OutputSizeConditioner | このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PeriodicConditioner | このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PrintStreamReporter | メッセージ出力用クラスです。
ReportFileWriter | メッセージをファイルに出力するストリームクラスです。
ReportLevelFilter | メッセージの出力制御を行うためのフィルタークラスです。
RepresentativeReporter | メッセージ出力をイベント処理するためのフィルタークラスです。

パッケージ jp.co.intra_mart.common.aid.jdk.util.report の説明

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.util.report クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.report の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
    • class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel)
      • class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
    • class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class java.io.Writer
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.util.report の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util.report の使用

jp.co.intra_mart.common.aid.jdk.util.report を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report により使用される jp.co.intra_mart.common.aid.jdk.util.report のクラス
AbstractMessageReporter
メッセージ出力用のスケルトンクラスです。
FilterMessageReporter
メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
MessageReporter
メッセージ出力のためのインターフェースです。
ReportFileConditioner
このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportFileWriter
メッセージをファイルに出力するストリームクラスです。
ReportLevel
メッセージレベルのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PeriodicConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス PeriodicConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner
すべての実装インタフェース:
ReportFileConditioner
public class PeriodicConditioner
extends Object
implements ReportFileConditioner

このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 一定期間の経過に合わせてに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
PeriodicConditioner(long millis)
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PeriodicConditioner

public PeriodicConditioner(long millis)
                    throws IllegalArgumentException
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、指定の時間が経過した時に リフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - millis がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
引数 outputSize の値が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrintStreamReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス PrintStreamReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
すべての実装インタフェース:
MessageReporter
public class PrintStreamReporter
extends AbstractMessageReporter

メッセージ出力用クラスです。

このクラスは、指定の PrintStream に対してメッセージを出力するための 機能を実装しています。 例えば、このクラスのコンストラクタの引数に java.lang.System.out を指定した 場合、標準出力に対してメッセージを出力することができます。
このクラスの特徴は、report メソッドに渡されたメッセージを PrintStream の println メソッドに渡します。 これにより、report メソッドの呼び出し毎にメッセージを改行付きで 指定の PrintStream に出力することができます（１行毎に出力）。

導入されたバージョン:
version 5.0

コンストラクタの概要
PrintStreamReporter(PrintStream out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrintStreamReporter

public PrintStreamReporter(PrintStream out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース ReportFileConditioner

既知の実装クラスの一覧:
EverydayConditioner, FileSizeConditioner, OutputSizeConditioner, PeriodicConditioner
public interface ReportFileConditioner

このクラスは、ReportFileWriter の初期化チェックのインターフェースです。

このクラスは FileReporter クラスにより ReportFileWriter へのメッセージ 書き出し前に呼び出されます。
このクラスは、FileReporter および ReportFileWriter オブジェクトと 組み合わせて使います。 これらのクラスと連携することにより、メッセージファイルの ローテイト機能などを実装することができます。

導入されたバージョン:
version 5.0

メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。

メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
このメソッドは、FileReporter クラスにより呼び出されます。 真値(true)を返すと、ReportFileWriter は現在のログファイルに対して 初期化処理を行います。 メッセージファイルの初期化処理に関しては、 ReportFileWriter クラス(または、そのサブクラス)により行われます。

パラメータ:
writer - メッセージファイルへの出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileWriter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス ReportFileWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter
public class ReportFileWriter
extends Writer

メッセージをファイルに出力するストリームクラスです。

このクラスは、メッセージを指定のファイルに対して出力するための スケルトンです。 また、このクラスは reset メソッドをオーバーライドすることにより、 ファイルのローテイト機能などを実装することができます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReportFileWriter(File f)
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
メソッドの概要
void | close() ストリームを閉じてフラッシュします。
protected Writer | createWriter() メッセージをファイルへ書き出すための出力ストリームを作成します。
Writer | currentWriter() このオブジェクトが文字を書き出している基礎 Writer を返します。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() ストリームをフラッシュします。
File | getFile() このオブジェクトが文字を書き出すファイルを取得します。
void | handleShutdown() シャットダウンイベントが発生したときに実行されるメソッドです。
long | length() このライターの出力文字数を取得します。
protected void | reconstruction() 現在使用中の Writer をリセットします。
protected Writer | reset(Writer writer) 文字の出力ストリームをリセットします。
void | write(char[] cbuf, int off, int len) 基礎ストリームに文字を出力します。
クラス java.io.Writer から継承したメソッド
write, write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReportFileWriter

public ReportFileWriter(File f)
                 throws IOException
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。

パラメータ:
f - このライターで書き出すファイル
例外:
IOException - 入出力エラー
メソッドの詳細

getFile

public File getFile()
このオブジェクトが文字を書き出すファイルを取得します。
このメソッドは、このオブジェクトの作成時にコンストラクタの引数として 与えられた File オブジェクトへの参照を返します。

戻り値:
このライターで書き出すファイル

createWriter

protected Writer createWriter()
                       throws IOException
メッセージをファイルへ書き出すための出力ストリームを作成します。

このメソッドは、単に getFile メソッドが返すファイルに対して 文字を書き出すための出力ストリームを作成して返します。 このメソッドの返す出力ストリームを使うことで、 getFile メソッドの返す ファイルに対してメッセージを追記していくことができます。
メッセージを任意の文字コードに変換したり、出力バッファを備えた Writer オブジェクトを作成する必要がある場合には、サブクラスで このメソッドをオーバーライドして実装して下さい。

戻り値:
出力ストリーム
例外:
IOException

length

public long length()
このライターの出力文字数を取得します。
このメソッドで返される文字数は、このファイルに対して 現在までに出力した文字数です。 文字数カウンタは、reset メソッドを実行することにより 0 (ゼロ)にリセットされます。

戻り値:
出力文字数

currentWriter

public Writer currentWriter()
このオブジェクトが文字を書き出している基礎 Writer を返します。

戻り値:
基礎 Writer オブジェクト

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
基礎ストリームに文字を出力します。
このメソッドをサブクラスがオーバーライドすることにより、 バッファ機能などを実装することができます。 ただし、このメソッドをオーバーライドしたサブクラスは、 同時に length メソッドもオーバーライドする必要があります。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException

reconstruction

protected void reconstruction()
                       throws IOException
現在使用中の Writer をリセットします。
このメソッドは、FileReporter クラスにより呼び出されます。 FileReporter オブジェクトでは、ReportFileConditioner オブジェクトが ファイルの初期化を必要と判断した場合に、このメソッドを呼び出して、 Writer の初期化を求めてきます。 これにより、リポートファイルのローテイト機能などを 実装することができます。

例外:
IOException

reset

protected Writer reset(Writer writer)
                throws IOException
文字の出力ストリームをリセットします。

このメソッドは reset メソッドに呼び出されます。
このメソッドは、単に引数のストリーム(writer)をそのまま リターンします。ファイルのローテイト機能などを実装する場合、 サブクラスでこのメソッドをオーバーライドして下さい。

パラメータ:
writer - 現在のストリーム
戻り値:
新しいストリーム
例外:
IOException

close

public void close()
           throws IOException
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。
ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字の目的の宛先にただちに文字を書き込みます。 宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。 つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream の すべてのバッファをフラッシュします。

サブクラスで、文字のバッファリング機能を実装している場合、 このメソッドをオーバーライドしてバッファに保存している 文字をフラッシュするように実装しなければいけません。

例外:
IOException - 入出力エラーが発生した場合

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable

handleShutdown

public void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。 このメソッドは、シャットダウンイベント発生時に、 バッファされているバイトをすべて出力するために flush() メソッドを呼び出します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportLevel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース ReportLevel

既知の実装クラスの一覧:
ReportLevelFilter
public interface ReportLevel

メッセージレベルのインターフェースです。

このインターフェースは、定数値化したメッセージレベルを示します。 すべてのメッセージに関して、必ずしもこのインターフェースで定義されている レベル値を使う必要はありませんが、このインターフェースを利用することにより プログラム全体でレベル値を統一することができます。

導入されたバージョン:
version 5.0

フィールドの概要
static int | MAX_VALUE レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
static int | MIN_VALUE レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
static int | TYPE_DEBUG デバッグレベル。
static int | TYPE_ERROR エラーレベル。
static int | TYPE_REPORT 通常の情報レベル。
static int | TYPE_WARNING 警告レベル。

フィールドの詳細

MIN_VALUE

public static final int MIN_VALUE
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。

関連項目:
定数フィールド値

MAX_VALUE

public static final int MAX_VALUE
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。

関連項目:
定数フィールド値

TYPE_DEBUG

public static final int TYPE_DEBUG
デバッグレベル。 デバッグ情報を出力する場合に利用します。

関連項目:
定数フィールド値

TYPE_REPORT

public static final int TYPE_REPORT
通常の情報レベル。
常に以下の関係が成り立ちます。

TYPE_DEBUG < TYPE_REPORT

関連項目:
定数フィールド値

TYPE_WARNING

public static final int TYPE_WARNING
警告レベル。 警告メッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_REPORT < TYPE_WARNING

関連項目:
定数フィールド値

TYPE_ERROR

public static final int TYPE_ERROR
エラーレベル。 エラーメッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_WARNING < TYPE_ERROR

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ReportLevelFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス ReportLevelFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter
すべての実装インタフェース:
MessageReporter, ReportLevel
public class ReportLevelFilter
extends FilterMessageReporter
implements ReportLevel

メッセージの出力制御を行うためのフィルタークラスです。

このクラスを利用することにより、メッセージをメッセージレベルにより、 出力制御を行うことができます。

導入されたバージョン:
version 5.0
関連項目:
ReportLevel

フィールドの概要
protected  int datumpoint
このリポーターがフィルタリングする基準レベル値
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel から継承したフィールド
MAX_VALUE, MIN_VALUE, TYPE_DEBUG, TYPE_ERROR, TYPE_REPORT, TYPE_WARNING
コンストラクタの概要
ReportLevelFilter(MessageReporter out, int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | report(Object data) data をメッセージとして出力します。
void | report(Object data, int level) 指定のメッセージレベルが基準値以上のメッセージを出力します。
void | report(String message) メッセージを出力します。
void | report(String message, int level) 指定のメッセージレベルが基準値以上のメッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

datumpoint

protected int datumpoint
このリポーターがフィルタリングする基準レベル値

コンストラクタの詳細

ReportLevelFilter

public ReportLevelFilter(MessageReporter out,
                         int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
メッセージを出力します。
このメソッドは、以下の呼出と同じです。

report(message, ReportLevel.MAX_VALUE)

つまり、メッセージ message は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(String message,
                   int level)
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
message - メッセージ
level - メッセージレベル

report

public void report(Object data)
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(data, ReportLevel.MAX_VALUE)

つまり、メッセージデータ data は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

report

public void report(Object data,
                   int level)
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
data - データ
level - メッセージレベル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RepresentativeReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス RepresentativeReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
すべての実装インタフェース:
MessageReporter
public class RepresentativeReporter
extends FilterMessageReporter

メッセージ出力をイベント処理するためのフィルタークラスです。

このクラスを利用することにより、メッセージの MessageReporter における 処理を現在のスレッドと並列実行させることができます。 これにより、このクラスの report メソッドと、出力先となる MessageReporter の report メソッドの実行は非同期に処理されます。

このクラスを利用することのメリットは、メッセージの出力処理を 待たなくても、現在のスレッドの実行を継続できることにあります。 逆に、このクラスを利用することにより、メッセージ出力処理と現在のスレッド処理 がスレッドセーフであることが保証されなければなりません。
report メソッドで指定されたメッセージはキューに蓄積され、 現在のスレッドと異なるメッセージ処理専用のスレッドで 基礎出力ストリームに渡されます。 メッセージの出力処理は、現在のスレッドと非同期ですが、 report メソッドの実行順とメッセージの出力順は保証されます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
メソッドの概要
boolean | canReport() このストリームが書き込み可能かどうかをチェックします。
void | close() ストリームを閉じます。
void | flush() ストリームをフラッシュします。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RepresentativeReporter

public RepresentativeReporter(MessageReporter out,
                              EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

canReport

public boolean canReport()
このストリームが書き込み可能かどうかをチェックします。

戻り値:
ストリームの書き込みが可能な場合 true、そうでない場合 false。

report

public void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
ストリームを閉じます。
このメソッドは、ストリームを閉じる前に flush メソッドを実行します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス FilterMessageReporter 内の close
例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

ストリームに蓄積されているすべてのメッセージイベントを処理します。 このメソッドを実行した場合、現在のスレッドで メッセージが処理されます。また、このメソッドはすべてのメッセージ出力 処理が完了するまでブロックします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス FilterMessageReporter 内の flush
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Counter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス Counter

java.lang.Object
    拡張 java.lang.Number
        拡張 jp.co.intra_mart.common.aid.jdk.util.Counter
すべての実装インタフェース:
Serializable
public class Counter
extends Number
implements Serializable

このクラスは、カウンター機能を提供します。

ある数値を基準として１ずつ増やしたり１ずつ減らしたりすることができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
Counter()
カウンターオブジェクトを作成します。
Counter(long initValue)
指定の初期値でカウンターオブジェクトを作成します。
メソッドの概要
long | decrement() カウンターの値を１だけ減少させます。
double | doubleValue() カウンターの現在の値を double 型として返します。
float | floatValue() カウンターの現在の値を float 型として返します。
long | increment() カウンターの値を１だけ増加させます。
int | intValue() カウンターの現在の値を int 型として返します。
long | longValue() カウンターの現在の値を long 型として返します。
クラス java.lang.Number から継承したメソッド
byteValue, shortValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Counter

public Counter()
カウンターオブジェクトを作成します。

初期値は０です。したがって、このコンストラクタの呼び出しは、 以下の呼び出しと同義です。
new Counter(0)

Counter

public Counter(long initValue)
指定の初期値でカウンターオブジェクトを作成します。

パラメータ:
initValue - カウンターの初期値
メソッドの詳細

increment

public long increment()
カウンターの値を１だけ増加させます。

戻り値:
変化後のカウンターの値

decrement

public long decrement()
カウンターの値を１だけ減少させます。

戻り値:
変化後のカウンターの値

intValue

public int intValue()
カウンターの現在の値を int 型として返します。 値を丸めたり切り捨てたりすることもあります。

戻り値:
このオブジェクトが表す数値を int 型に変換した値;

longValue

public long longValue()
カウンターの現在の値を long 型として返します。

戻り値:
このオブジェクトが表す数値を long 型に変換した値

floatValue

public float floatValue()
カウンターの現在の値を float 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を float 型に変換した値

doubleValue

public double doubleValue()
カウンターの現在の値を double 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を double 型に変換した値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ErrorEvent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス ErrorEvent

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
public class ErrorEvent
extends Object

例外をイベントとして扱うためのプロトコルです。

イベントリスナー(インターフェース ErrorEventListener を実装したクラス) のオーナーオブジェクトは、例外の発生時にこのクラスのインスタンスを 生成して各リスナーに通知する義務があります。

導入されたバージョン:
version 5.0
関連項目:
ErrorEventListener

コンストラクタの概要
ErrorEvent(Throwable t, Object obj)
エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable t, String msg, Object obj)
エラーを通知するためのイベントを構築します。
メソッドの概要
Throwable | getException() 通知されたエラーまたは例外を取得します。
String | getMessage() 通知されたエラーメッセージを取得します。
Object | getObject() 通知されたエラー発生オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorEvent

public ErrorEvent(Throwable t,
                  Object obj)
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
obj - エラーの発生したオブジェクト

ErrorEvent

public ErrorEvent(Throwable t,
                  String msg,
                  Object obj)
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
msg - エラーメッセージ
obj - エラーの発生したオブジェクト
メソッドの詳細

getObject

public Object getObject()
通知されたエラー発生オブジェクトを取得します。

戻り値:
通知されたエラーオブジェクト

getMessage

public String getMessage()
通知されたエラーメッセージを取得します。 メッセージが通知されていない場合、通知されたエラーのメッセージを 返します。

戻り値:
通知されたエラーメッセージ
関連項目:
Throwable.getMessage()

getException

public Throwable getException()
通知されたエラーまたは例外を取得します。

戻り値:
通知されたエラーまたは例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ErrorEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
インタフェース ErrorEventListener

public interface ErrorEventListener

例外をイベントとして扱うためのスケルトン実装を提供します。

このインターフェースを実装したクラスのインスタンスは例外の発生に伴い その例外をイベントとして受け取ることができます。 このインターフェースを実装しているクラスから生成されたインスタンスの オーナーオブジェクトは、 例外発生をイベントとしてインスタンスに対して通知する義務があります。

導入されたバージョン:
version 5.0

メソッドの概要
 void handleError(ErrorEvent err)
発生した例外を通知します。

メソッドの詳細

handleError

public void handleError(ErrorEvent err)
発生した例外を通知します。

パラメータ:
err - 発生したエラーイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
インタフェース EventListener

public interface EventListener

このクラスは、イベントリスナーのインターフェースです。

イベントコントローラと組み合わせて使うことにより、 様々なイベント機能を実装することができます。

導入されたバージョン:
version 5.0
関連項目:
EventQueueController

メソッドの概要
 void handleEvent()
イベントが発生した時にコントローラから呼び出されます。

メソッドの詳細

handleEvent

public void handleEvent()
イベントが発生した時にコントローラから呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventQueueController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス EventQueueController

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.EventQueueController
public class EventQueueController
extends Object

このクラスは、イベントリスナーを実行するイベント機能を実装します。

イベントコントローラは、指定された時間間隔に従ってリスナー登録状況を確認し、 リスナーの登録が１つ以上あった場合、これらを専用スレッドで実行します。 このとき、イベントリスナーの実行順と実行の直列化が保証されます。
これらの機能により、通常の関数実行や java.lang.Thread クラスを利用した 並列処理などと異なった機能を実装することができます。

このクラスを利用することにより、現在の処理とイベント処理を並列化することが できます。また、一つのコントローラは同時に一つのイベントリスナーしか 実行しないため、それぞれのリスナーの処理が並列処理されることはありません。 従って、リスナーはマルチスレッドを意識したプログラムにする必要がありますが、 リスナー間でマルチスレッドを意識する必要はありません。

導入されたバージョン:
version 5.0
関連項目:
EventListener

コンストラクタの概要
EventQueueController()
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long millis)
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
メソッドの概要
void | entry(EventListener listener) イベントリスナーの登録。
void | eventGenerating() キューに登録されているイベントリスナーを一つ実行します。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() キューに溜まっているすべてのイベントリスナーを実行します。
void | setCapacity(int max) キューの容量を変更します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventQueueController

public EventQueueController()
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 コントローラがリスナー登録状況を監視する時間間隔はデフォルト値(60秒)が 適用されます。

EventQueueController

public EventQueueController(long millis)
                     throws IllegalArgumentException
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 millis は、リスナーの登録状況を監視する時間間隔です。 コントローラは、リスナーが一つも登録されていない状態になると、 millis ミリ秒間隔でリスナー登録の有無を確認します。

パラメータ:
millis - イベントの監視間隔(ミリ秒)
例外:
IllegalArgumentException - millis が 0 以下の場合
メソッドの詳細

setCapacity

public void setCapacity(int max)
                 throws IllegalStateException,
                        IllegalArgumentException
キューの容量を変更します。

パラメータ:
max - イベントをプールできる最大量
例外:
IllegalStateException - max 個以上のリスナーが登録されている場合
IllegalArgumentException - max が 0 以下の場合

entry

public void entry(EventListener listener)
           throws NullPointerException,
                  IndexOutOfBoundsException,
                  IllegalStateException
イベントリスナーの登録。
イベントリスナーは、一旦キューに溜められます。 キューに保管されたリスナーは、 このコントローラにより現在実行中のスレッドとは 別のスレッドで登録順に呼び出されます。

実行されたリスナーは、処理が終了すると破棄されます。

通常のスレッドクラスを利用した並列処理との違いは、 イベントリスナーが登録順に実行される点と、 イベントリスナーの実行が直列化される点にあります。

パラメータ:
listener - イベントリスナー
例外:
NullPointerException - listener が null の場合
IndexOutOfBoundsException - キューが飽和状態の場合
IllegalStateException - コントローラが破棄処理済の場合

flush

public void flush()
キューに溜まっているすべてのイベントリスナーを実行します。

このメソッドは、現在実行中のスレッドで すべてのイベント処理を行います。

eventGenerating

public void eventGenerating()
                     throws NoSuchElementException
キューに登録されているイベントリスナーを一つ実行します。 実行されるリスナーは、現在キューに保管されているリスナーの中で 最も過去に登録されたリスナーです。 このメソッドは、現在実行中のスレッドで 登録順で最も過去のイベントを１つ実行します。

例外:
NoSuchElementException - 登録リスナーがない場合

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LockMonitor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス LockMonitor

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.LockMonitor
public class LockMonitor
extends Object

このクラスはモニター機能を提供します。
このクラスでは、複数個のモニターを管理することができます。 アプリケーションでは、entry() メソッドによりモニターを取得し、 release() メソッドでモニターを開放します。

導入されたバージョン:
version 5.0

コンストラクタの概要
LockMonitor(int max)
モニターを構築します。
メソッドの概要
int | activeCount() 現在取得済みモニターの数を取得します。
void | entry() モニターの取得。
int | queue() モニターを取得するための待ち行列に入っているスレッドの数です。
void | release() モニターの開放。
int | size() このオブジェクトの管理するモニターの数を取得します。
int | total() モニターを利用中、または利用しようとしているスレッドの数です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LockMonitor

public LockMonitor(int max)
モニターを構築します。

パラメータ:
max - 管理するモニターの個数
メソッドの詳細

entry

public void entry()
モニターの取得。

モニターを取得できるまでブロックします。 モニターの取得＝動作の権利を取得

size

public int size()
このオブジェクトの管理するモニターの数を取得します。

戻り値:
モニターの数

activeCount

public int activeCount()
現在取得済みモニターの数を取得します。

戻り値:
取得済みモニターの数

total

public int total()
モニターを利用中、または利用しようとしているスレッドの数です。

戻り値:
entry() メソッドを実行して release() メソッドを実行していないスレッドの数
導入されたバージョン:
version 4.2

queue

public int queue()
モニターを取得するための待ち行列に入っているスレッドの数です。

戻り値:
entry() メソッドを実行して、ブロック状態になっているスレッドの数
導入されたバージョン:
version 4.2

release

public void release()
モニターの開放。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipurposeInternetMailExtensions (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス MultipurposeInternetMailExtensions

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
public class MultipurposeInternetMailExtensions
extends Object

MIME タイプを持つオブジェクトです。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultipurposeInternetMailExtensions(File path)
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String filename)
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String mediaType, String subType)
指定のMIMEタイプを表すオブジェクトを構築します。
メソッドの概要
String | getMediaType() このオブジェクトが表す MIME タイプの Media Type を返します。
String | getSubType() このオブジェクトが表す MIME タイプの subtype を返します。
String | getType() このオブジェクトが表す MIME タイプを返します。
String | toString() このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String filename)
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 filename の拡張子により解決されます。
引数 filename に拡張子がない場合や、拡張子から MIME タイプを解決 出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
filename - ファイル名

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(File path)
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 path の表すファイル名の拡張子により解決されます。
引数 path の表すファイル名に拡張子がない場合や、拡張子から MIME タイプを 解決出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
path - ファイル名を表す File クラスのインスタンス

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String mediaType,
                                          String subType)
指定のMIMEタイプを表すオブジェクトを構築します。

このコンストラクタにより構築されたオブジェクトの表す MIME タイプは、 mediaType "/" subType となります。

パラメータ:
mediaType - メディアタイプを表すキーワード
subType - サブタイプを表すキーワード
メソッドの詳細

getMediaType

public String getMediaType()
このオブジェクトが表す MIME タイプの Media Type を返します。

戻り値:
Media Type を表す文字列

getSubType

public String getSubType()
このオブジェクトが表す MIME タイプの subtype を返します。

戻り値:
subtype を表す文字列

getType

public String getType()
このオブジェクトが表す MIME タイプを返します。

戻り値:
MIME タイプを表す文字列

toString

public String toString()
このオブジェクトの文字列表現を返します。

戻り値:
MIME タイプを表す文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jdk.util
インタフェース
ErrorEventListener
EventListener
クラス
Counter
ErrorEvent
EventQueueController
LockMonitor
MultipurposeInternetMailExtensions


jp.co.intra_mart.common.aid.jdk.util (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ErrorEventListener | 例外をイベントとして扱うためのスケルトン実装を提供します。
EventListener | このクラスは、イベントリスナーのインターフェースです。

クラスの概要
Counter | このクラスは、カウンター機能を提供します。
ErrorEvent | 例外をイベントとして扱うためのプロトコルです。
EventQueueController | このクラスは、イベントリスナーを実行するイベント機能を実装します。
LockMonitor | このクラスはモニター機能を提供します。
MultipurposeInternetMailExtensions | MIME タイプを持つオブジェクトです。

パッケージ jp.co.intra_mart.common.aid.jdk.util の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jdk.util クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
    • class jp.co.intra_mart.common.aid.jdk.util.EventQueueController
    • class jp.co.intra_mart.common.aid.jdk.util.LockMonitor
    • class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.util.Counter (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener
  • interface jp.co.intra_mart.common.aid.jdk.util.EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jdk.util の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util の使用

jp.co.intra_mart.common.aid.jdk.util を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
ErrorEventListener
例外をイベントとして扱うためのスケルトン実装を提供します。

jp.co.intra_mart.common.aid.jdk.util により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
ErrorEvent
例外をイベントとして扱うためのプロトコルです。
EventListener
このクラスは、イベントリスナーのインターフェースです。

jp.co.intra_mart.common.aid.jdk.util.report により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
EventQueueController
このクラスは、イベントリスナーを実行するイベント機能を実装します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException の使用

BadRequestException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での BadRequestException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での BadRequestException のサブクラス
class | EmptyQueryException クエリがない場合にスローされる例外です。
class | ExcessiveQueryException クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
class | LengthRequiredException Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
class | UnripeQueryException クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException の使用

ExtendedServletException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での ExtendedServletException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での ExtendedServletException のサブクラス
class | BadRequestException 不正なリクエストを受け付けたことを通知するための例外です。
class | EmptyQueryException クエリがない場合にスローされる例外です。
class | ExcessiveQueryException クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
class | ForbiddenException アクセス権限がないことを通知する例外です。
class | LengthRequiredException Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
class | NotFoundException 指定されたコンテンツが見つからないことを通知するための例外です。
class | RequestEntityTooLargeException 処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
class | ServiceUnavailableException サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
class | UnauthorizedException リクエストを受け付けるためには認証が必要であることを通知するための例外です。
class | UnripeQueryException クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException の使用

UnripeQueryException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での UnripeQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での UnripeQueryException のサブクラス
 class EmptyQueryException
クエリがない場合にスローされる例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


BadRequestException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス BadRequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExcessiveQueryException, LengthRequiredException, UnripeQueryException
public class BadRequestException
extends ExtendedServletException

不正なリクエストを受け付けたことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
BadRequestException()
例外を作成します。
BadRequestException(String message)
指定のメッセージを持つ例外を作成します。
BadRequestException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BadRequestException

public BadRequestException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

BadRequestException

public BadRequestException(String message,
                           Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

BadRequestException

public BadRequestException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EmptyQueryException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス EmptyQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
すべての実装インタフェース:
Serializable
public class EmptyQueryException
extends UnripeQueryException

クエリがない場合にスローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyQueryException()
例外を作成します。
EmptyQueryException(String message)
指定のメッセージを持つ例外を作成します。
EmptyQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EmptyQueryException

public EmptyQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

EmptyQueryException

public EmptyQueryException(String message,
                           Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

EmptyQueryException

public EmptyQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExcessiveQueryException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ExcessiveQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
すべての実装インタフェース:
Serializable
public class ExcessiveQueryException
extends BadRequestException

クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ExcessiveQueryException()
例外を作成します。
ExcessiveQueryException(String message)
指定のメッセージを持つ例外を作成します。
ExcessiveQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExcessiveQueryException

public ExcessiveQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ExcessiveQueryException

public ExcessiveQueryException(String message,
                               Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ExcessiveQueryException

public ExcessiveQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedServletException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ExtendedServletException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BadRequestException, ForbiddenException, NotFoundException, RequestEntityTooLargeException, ServiceUnavailableException, UnauthorizedException
public class ExtendedServletException
extends ServletException

Servlet 例外の拡張モデルです。 JRE 1.4 から、Throwable に #getCause() が実装されました。 これと、ServletException が従来から持つ #getRootCause() が 同義となるようにしてあります。

導入されたバージョン:
version 5.0
関連項目:
ServletException, 直列化された形式

コンストラクタの概要
ExtendedServletException()
例外オブジェクトを作成します。
ExtendedServletException(String message)
指定されたメッセージを持つ例外を作成します。
ExtendedServletException(String message, Throwable rootCause)
指定されたメッセージと根本原因となった例外を持つ例外を作成します。
ExtendedServletException(Throwable rootCause)
根本原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedServletException

public ExtendedServletException()
例外オブジェクトを作成します。

ExtendedServletException

public ExtendedServletException(String message)
指定されたメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ExtendedServletException

public ExtendedServletException(String message,
                                Throwable rootCause)
指定されたメッセージと根本原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ExtendedServletException

public ExtendedServletException(Throwable rootCause)
根本原因となった例外を持つ例外を作成します。

パラメータ:
rootCause - 原因となった例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForbiddenException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ForbiddenException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
すべての実装インタフェース:
Serializable
public class ForbiddenException
extends ExtendedServletException

アクセス権限がないことを通知する例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ForbiddenException()
例外を作成します。
ForbiddenException(String message)
指定のメッセージを持つ例外を作成します。
ForbiddenException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForbiddenException

public ForbiddenException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ForbiddenException

public ForbiddenException(String message,
                          Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ForbiddenException

public ForbiddenException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LengthRequiredException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス LengthRequiredException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
すべての実装インタフェース:
Serializable
public class LengthRequiredException
extends BadRequestException

Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
LengthRequiredException()
例外を作成します。
LengthRequiredException(String message)
指定のメッセージを持つ例外を作成します。
LengthRequiredException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LengthRequiredException

public LengthRequiredException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

LengthRequiredException

public LengthRequiredException(String message,
                               Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

LengthRequiredException

public LengthRequiredException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotFoundException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス NotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
すべての実装インタフェース:
Serializable
public class NotFoundException
extends ExtendedServletException

指定されたコンテンツが見つからないことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
NotFoundException()
例外を作成します。
NotFoundException(String message)
指定のメッセージを持つ例外を作成します。
NotFoundException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotFoundException

public NotFoundException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

NotFoundException

public NotFoundException(String message,
                         Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

NotFoundException

public NotFoundException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
例外
BadRequestException
EmptyQueryException
ExcessiveQueryException
ExtendedServletException
ForbiddenException
LengthRequiredException
NotFoundException
RequestEntityTooLargeException
ServiceUnavailableException
UnauthorizedException
UnripeQueryException


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception

このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

例外の概要
BadRequestException | 不正なリクエストを受け付けたことを通知するための例外です。
EmptyQueryException | クエリがない場合にスローされる例外です。
ExcessiveQueryException | クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
ExtendedServletException | Servlet 例外の拡張モデルです。
ForbiddenException | アクセス権限がないことを通知する例外です。
LengthRequiredException | Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
NotFoundException | 指定されたコンテンツが見つからないことを通知するための例外です。
RequestEntityTooLargeException | 処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
ServiceUnavailableException | サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
UnauthorizedException | リクエストを受け付けるためには認証が必要であることを通知するための例外です。
UnripeQueryException | クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の説明

このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception のクラス
BadRequestException
不正なリクエストを受け付けたことを通知するための例外です。
ExtendedServletException
Servlet 例外の拡張モデルです。
UnripeQueryException
クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RequestEntityTooLargeException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス RequestEntityTooLargeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
すべての実装インタフェース:
Serializable
public class RequestEntityTooLargeException
extends ExtendedServletException

処理可能量より大きいリクエストを受け付けたことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
RequestEntityTooLargeException()
例外を作成します。
RequestEntityTooLargeException(String message)
指定のメッセージを持つ例外を作成します。
RequestEntityTooLargeException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestEntityTooLargeException

public RequestEntityTooLargeException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

RequestEntityTooLargeException

public RequestEntityTooLargeException(String message,
                                      Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

RequestEntityTooLargeException

public RequestEntityTooLargeException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceUnavailableException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ServiceUnavailableException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
すべての実装インタフェース:
Serializable
public class ServiceUnavailableException
extends ExtendedServletException

サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceUnavailableException()
例外を作成します。
ServiceUnavailableException(String message)
指定のメッセージを持つ例外を作成します。
ServiceUnavailableException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceUnavailableException

public ServiceUnavailableException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ServiceUnavailableException

public ServiceUnavailableException(String message,
                                   Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ServiceUnavailableException

public ServiceUnavailableException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnauthorizedException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス UnauthorizedException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException
すべての実装インタフェース:
Serializable
public class UnauthorizedException
extends ExtendedServletException

リクエストを受け付けるためには認証が必要であることを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnauthorizedException()
例外を作成します。
UnauthorizedException(String message)
指定のメッセージを持つ例外を作成します。
UnauthorizedException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnauthorizedException

public UnauthorizedException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

UnauthorizedException

public UnauthorizedException(String message,
                             Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

UnauthorizedException

public UnauthorizedException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnripeQueryException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス UnripeQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EmptyQueryException
public class UnripeQueryException
extends BadRequestException

クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnripeQueryException()
例外を作成します。
UnripeQueryException(String message)
指定のメッセージを持つ例外を作成します。
UnripeQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnripeQueryException

public UnripeQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

UnripeQueryException

public UnripeQueryException(String message,
                            Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

UnripeQueryException

public UnripeQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter の使用

AbstractFilter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.security.filter | アクセスセキュリティのフィルタに関連するクラスを提供します。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractFilter のサブクラス
class | AbsoluteLinkFilter 絶対表現のＵＲＬをレスポンスするためのフィルタ。
class | ExceptionHandlingFilter サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
class | HTTPContextHandlingFilter このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
class | LuxuryResponseWriterFilter
class | NoCacheFilter ブラウザのキャッシュを無効にするフィルタ。
class | RequestMessageBodyFilter リクエストをラップするフィルタです。
class | ResponseContentTypeManagementFilter レスポンスの Content-Type を自動解決するフィルタです。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での AbstractFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での AbstractFilter のサブクラス
 class HttpSessionMonitoringFilter
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。

jp.co.intra_mart.foundation.security.filter での AbstractFilter の使用

jp.co.intra_mart.foundation.security.filter での AbstractFilter のサブクラス
class | RequestCharacterEncodingFilter リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
class | ResponseCharacterEncodingFilter レスポンスの文字エンコーディングを自動解決するフィルタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper の使用

HttpServletRequestMessageBodyWrapper を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletRequestMessageBodyWrapper の使用

HttpServletRequestMessageBodyWrapper を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
static HttpServletRequestMessageBodyWrapper | RequestMessageBodyFilter.getCurrentRequest() 現在処理中のリクエストを返します。
HttpServletRequestMessageBodyWrapper | HttpServletRequestMessageBodyWrapperBuilder.buildExtendedHttpServletRequest(HttpServletRequest request, HttpServletResponse response) ExtendedHttpServletRequest を作成して返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter の使用

RequestParameter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での RequestParameter の使用

RequestParameter を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
static RequestParameter[] | RequestMessageBodyFilter.getRequestParameters() 現在のリクエストのパラメータを返します。
RequestParameter[] | HttpServletRequestMessageBodyWrapper.getRequestParameters() パラメータ情報を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbsoluteLinkFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbsoluteLinkFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
すべての実装インタフェース:
Filter
public class AbsoluteLinkFilter
extends AbstractFilter

絶対表現のＵＲＬをレスポンスするためのフィルタ。

このフィルタの目的は、ServletResponse#encodeURL() の実行結果として、 単にセッションＩＤ情報を付加するだけではなく、必ず絶対形式のＵＲＬを 作成することです。 したがって、このフィルタは、チェーンの次サーブレットまたはフィルタに対して、 ラップしたレスポンスを渡します。

このフィルタがレスポンスをラップするのは、事前に指定されたセッションに 関連したリクエストのみです。 #entry(ServletRequest) または entry(HttpSession) で 登録していないセッションに関するリクエストについては、 レスポンスをラップすることなくチェーンの次のサーブレットまたはフィルタを 実行します。

コンストラクタの概要
AbsoluteLinkFilter()
フィルタを新しく作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタ処理します。
static void | entry(HttpServletRequest request) このフィルタによってＵＲＬの制御を行うことを定義します。
static void | entry(HttpSession session) このフィルタによってＵＲＬの制御を行うことを定義します。
static void | leave(HttpServletRequest request) 指定のセッションに関する、このフィルタの処理を停止します。
static void | leave(HttpSession session) 指定のセッションに関する、このフィルタの処理を停止します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbsoluteLinkFilter

public AbsoluteLinkFilter()
フィルタを新しく作成します。

メソッドの詳細

entry

public static void entry(HttpServletRequest request)
このフィルタによってＵＲＬの制御を行うことを定義します。

この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
request - リクエスト
例外:
NullPointerException - 引数が null の場合
IllegalStateException - セッションを取得できなかった場合

entry

public static void entry(HttpSession session)
このフィルタによってＵＲＬの制御を行うことを定義します。

この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
session - セッション
例外:
NullPointerException - 引数が null の場合

leave

public static void leave(HttpServletRequest request)
指定のセッションに関する、このフィルタの処理を停止します。 この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

既にセッションが有効でない場合、このメソッドは何も行いません。

パラメータ:
request - リクエスト
例外:
NullPointerException - 引数が null の場合

leave

public static void leave(HttpSession session)
指定のセッションに関する、このフィルタの処理を停止します。 この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
session - セッション
例外:
NullPointerException - 引数が null の場合

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタ処理します。

現在のリクエストに関連付けられているセッションが、 このクラスの entry(HttpSession) で定義済みのセッションの場合、 レスポンスをラップします。 ラップされたレスポンスは、javax.servlet.http.HttpServletResponse#encodeURL(java.lang.String) の 返り値として、必ず絶対形式のＵＲＬを返すようになります。

レスポンスをラップするかどうかに関わらず、 このメソッドは、フィルタチェーン内の次のチェーンを呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - フィルタチェーンの次のビュー
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
すべての実装インタフェース:
Filter
直系の既知のサブクラス:
AbsoluteLinkFilter, ExceptionHandlingFilter, HTTPContextHandlingFilter, HttpSessionMonitoringFilter, LuxuryResponseWriterFilter, NoCacheFilter, RequestCharacterEncodingFilter, RequestMessageBodyFilter, ResponseCharacterEncodingFilter, ResponseContentTypeManagementFilter
public abstract class AbstractFilter
extends Object
implements Filter

フィルタを実装するための抽象クラスです。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractFilter()
フィルタオブジェクトを作成します。
メソッドの概要
void | destroy() フィルタの終了処理。
abstract void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
FilterConfig | getFilterConfig() このフィルタの設定オブジェクトを返します。
ServletContext | getServletContext() この Filter を実行している ServletContext への参照を返します。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
void | init(FilterConfig config) フィルタを初期化します。
protected void | log(String msg) Servlet ログファイルに指定されたメッセージを出力します。
protected void | log(String msg, Throwable throwable) 与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractFilter

protected AbstractFilter()
フィルタオブジェクトを作成します。

メソッドの詳細

init

public final void init(FilterConfig config)
                throws ServletException
フィルタを初期化します。

このメソッドは、この抽象クラスの初期化を実行後に、 handleInit() を実行します。 サブクラスが独自の初期化処理を必要とする場合は、 handleInit() をオーバーライドして初期化処理を実装してください。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタ設定オブジェクト
例外:
ServletException - 初期化エラー
関連項目:
Filter.init(FilterConfig)

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

例外:
ServletException - 初期化エラー
関連項目:
init(FilterConfig)

getFilterConfig

public FilterConfig getFilterConfig()
このフィルタの設定オブジェクトを返します。

このメソッドは、コンストラクタでは利用できません。

戻り値:
フィルタ設定オブジェクト。コンストラクタで呼び出した場合は null を返します。

getServletContext

public ServletContext getServletContext()
この Filter を実行している ServletContext への参照を返します。

このメソッドは、コンストラクタでは利用できません。

戻り値:
このフィルタが Servlet コンテナとの対話に使っている ServletContext オブジェクト
例外:
NullPointerException - コンストラクタで呼び出した場合

log

protected void log(String msg)
Servlet ログファイルに指定されたメッセージを出力します。
通常は event ログです。 Servlet ログファイルの名前やタイプは Servlet コンテナによって違います。

このメソッドの呼び出しは、下記と同等です。
this.getFilterConfig().getServletContext().log(msg);

このメソッドは、コンストラクタでは利用できません。

パラメータ:
msg - ログファイルに出力するメッセージ
例外:
NullPointerException - コンストラクタで呼び出した場合
関連項目:
ServletContext.log(String)

log

protected void log(String msg,
                   Throwable throwable)
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
Servlet ログファイルは通常は event ログですが、 名前やタイプは Servlet コンテナによって違います。

このメソッドの呼び出しは、下記と同等です。
this.getFilterConfig().getServletContext().log(msg, throwable);

このメソッドは、コンストラクタでは利用できません。

パラメータ:
msg - ログファイルに出力するメッセージ
throwable - エラーや例外
例外:
NullPointerException - コンストラクタで呼び出した場合
関連項目:
ServletContext.log(String, Throwable)

doFilter

public abstract void doFilter(ServletRequest request,
                              ServletResponse response,
                              FilterChain chain)
                       throws ServletException,
                              IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

destroy

public final void destroy()
フィルタの終了処理。

このメソッドは、handleDestroy() を呼び出します。
handleDestroy() から正常に制御が返ってきた場合も、
また handleDestroy() が例外をスローした場合も、
このメソッドが終了する直前に、この抽象クラスの破棄処理が行われます。

サブクラスが独自の初期化処理を必要とする場合は、 handleDestroy() をオーバーライドして 初期化処理を実装してください。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

関連項目:
destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExceptionHandlingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス ExceptionHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
すべての実装インタフェース:
Filter
public class ExceptionHandlingFilter
extends AbstractFilter

サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。

このフィルタを利用すると、例外の種類によって表示するエラーページを 切り替える事ができます。また、フォワード先ＵＲＬを JSP や Servlet にすると、 エラーログを出力するなどの例外処理をすることもできます。

フィルタの設定値は、以下のとおりです。

id.attribute.exception | フォワード先へ、発生した例外を通知するためのキー名です。 この指定値をキー名として、発生した例外を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.url | フォワード先へ、リクエストＵＲＬを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getRequestURL() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.uri | フォワード先へ、リクエストＵＲＩを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getRequestURI() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.servlet | フォワード先へ、サーブレットパスを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getServletPath() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
path.mapping マッピングに関して定義した定義ファイルです。 定義ファイルはＸＭＬ形式で、以下のフォーマットになります。

   <error-page>
     <mapping>
       <exception-type>例外のクラス名</exception-type>
       <location>例外発生時にフォワードするパス</location>
     </mapping>
   </error-page>
<mapping> は任意の個数だけ定義できます。

フィルタは、指定されたパスをクラスパスから検索します。 定義ファイルは、必ずクラスパスに設定されているディレクトリに 保存してください。

exception.cause.enable 例外がスローされた直接原因となった例外 （Throwable.getCause() が返す値） もチェック対象とするかどうかの設定です。

文字列 'true' を設定した場合、ネストされた例外もチェックします。 ただし、パフォーマンスが悪化する可能性があります。
文字列 'false' を設定した場合、スローされた例外のみをチェック対象とします。 パフォーマンス面では有利ですが、パターンによっては 適切なエラーページを表示できない恐れがあります。

コンストラクタの概要
ExceptionHandlingFilter()
新しくフィルタオブジェクトを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExceptionHandlingFilter

public ExceptionHandlingFilter()
新しくフィルタオブジェクトを作成します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPContextHandlingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HTTPContextHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
すべての実装インタフェース:
Filter
public class HTTPContextHandlingFilter
extends AbstractFilter

このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。

導入されたバージョン:
version 5.0

コンストラクタの概要
HTTPContextHandlingFilter()
デフォルト・コンストラクタ
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPContextHandlingFilter

public HTTPContextHandlingFilter()
デフォルト・コンストラクタ

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
クラス AbstractFilter の記述:
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws IOException,
                     ServletException
クラス AbstractFilter の記述:
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
クラス AbstractFilter の記述:
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletRequestMessageBodyWrapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletRequestMessageBodyWrapper

すべてのスーパーインタフェース:
HttpServletRequest, ServletRequest
public interface HttpServletRequestMessageBodyWrapper
extends HttpServletRequest

HttpServletRequest を拡張したインタフェースです。

導入されたバージョン:
version 5.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletRequest から継承したフィールド
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
メソッドの概要
InputStream | getMessageBody() リクエストのメッセージボディを返します。
RequestParameter[] | getRequestParameters() パラメータ情報を返します。
インタフェース javax.servlet.http.HttpServletRequest から継承したメソッド
getAuthType, getContextPath, getCookies, getDateHeader, getHeader, getHeaderNames, getHeaders, getIntHeader, getMethod, getPathInfo, getPathTranslated, getQueryString, getRemoteUser, getRequestedSessionId, getRequestURI, getRequestURL, getServletPath, getSession, getSession, getUserPrincipal, isRequestedSessionIdFromCookie, isRequestedSessionIdFromUrl, isRequestedSessionIdFromURL, isRequestedSessionIdValid, isUserInRole
インタフェース javax.servlet.ServletRequest から継承したメソッド
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocale, getLocales, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

メソッドの詳細

getMessageBody

public InputStream getMessageBody()
                           throws IOException
リクエストのメッセージボディを返します。

このメソッドは、ServletRequest.getInputStream() または ServletRequest.getReader() を 実行した後でも、メッセージボディを含む入力ストリームを返します。
また同様に、 ServletRequest.getParameter(String name) を実行した後でも、メッセージボディを含む入力ストリームを返します。

戻り値:
メッセージボディを含む入力ストリーム
例外:
IOException - 入出力の例外が発生した場合

getRequestParameters

public RequestParameter[] getRequestParameters()
                                        throws IOException
パラメータ情報を返します。

戻り値:
パラメータ
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpServletRequestMessageBodyWrapperBuilder (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletRequestMessageBodyWrapperBuilder

public interface HttpServletRequestMessageBodyWrapperBuilder

HttpServletRequest を拡張したインタフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
HttpServletRequestMessageBodyWrapper | buildExtendedHttpServletRequest(HttpServletRequest request, HttpServletResponse response) ExtendedHttpServletRequest を作成して返します。
void | destroy() このオブジェクトの破棄処理をします。
void | init(FilterConfig config) このオブジェクトを初期化します。

メソッドの詳細

init

public void init(FilterConfig config)
このオブジェクトを初期化します。

buildExtendedHttpServletRequest

public HttpServletRequestMessageBodyWrapper buildExtendedHttpServletRequest(HttpServletRequest request,
                                                                            HttpServletResponse response)
                                                                     throws IOException,
                                                                            ServletException
ExtendedHttpServletRequest を作成して返します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
IOException - 入出力エラー
ServletException - その他の実行時エラー

destroy

public void destroy()
このオブジェクトの破棄処理をします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LuxuryResponseWriterFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス LuxuryResponseWriterFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
すべての実装インタフェース:
Filter
public class LuxuryResponseWriterFilter
extends AbstractFilter

導入されたバージョン:
version5.0
関連項目:
AbstractFilter

コンストラクタの概要
LuxuryResponseWriterFilter()
デフォルトコンストラクタ
メソッドの概要
 void doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
フィルタとして動作するロジック。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LuxuryResponseWriterFilter

public LuxuryResponseWriterFilter()
デフォルトコンストラクタ

メソッドの詳細

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
クラス AbstractFilter の記述:
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoCacheFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス NoCacheFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
すべての実装インタフェース:
Filter
public class NoCacheFilter
extends AbstractFilter

ブラウザのキャッシュを無効にするフィルタ。

このフィルタは、レスポンスヘッダに以下を追加します。

 Pragma: no-cache
 Cache-Control: no-cache
 Expires: Tue, 22 Feb 2000 12:00:00 GMT

レスポンスヘッダ Expires の値については、 フィルタの初期化パラメータ expires で任意に設定する事もできます。

設定可能な初期化パラメータは以下のとおりです。

expires コンテンツの有効期限日時

導入されたバージョン:
version 5.0

コンストラクタの概要
NoCacheFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NoCacheFilter

public NoCacheFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース
HttpServletRequestMessageBodyWrapper
HttpServletRequestMessageBodyWrapperBuilder
RequestParameter
クラス
AbsoluteLinkFilter
AbstractFilter
ExceptionHandlingFilter
HTTPContextHandlingFilter
LuxuryResponseWriterFilter
NoCacheFilter
RequestMessageBodyFilter
ResponseContentTypeManagementFilter


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter

このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
HttpServletRequestMessageBodyWrapper | HttpServletRequest を拡張したインタフェースです。
HttpServletRequestMessageBodyWrapperBuilder | HttpServletRequest を拡張したインタフェースです。
RequestParameter | １つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

クラスの概要
AbsoluteLinkFilter | 絶対表現のＵＲＬをレスポンスするためのフィルタ。
AbstractFilter | フィルタを実装するための抽象クラスです。
ExceptionHandlingFilter | サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
HTTPContextHandlingFilter | このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
LuxuryResponseWriterFilter |
NoCacheFilter | ブラウザのキャッシュを無効にするフィルタ。
RequestMessageBodyFilter | リクエストをラップするフィルタです。
ResponseContentTypeManagementFilter | レスポンスの Content-Type を自動解決するフィルタです。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の説明

このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.security.filter | アクセスセキュリティのフィルタに関連するクラスを提供します。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。
HttpServletRequestMessageBodyWrapper
HttpServletRequest を拡張したインタフェースです。
RequestParameter
１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。

jp.co.intra_mart.foundation.security.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RequestMessageBodyFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス RequestMessageBodyFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
すべての実装インタフェース:
Filter
public class RequestMessageBodyFilter
extends AbstractFilter

リクエストをラップするフィルタです。 このフィルタを利用する事により、リクエストの情報を、 いつでも取得できるようになります。

このフィルタを利用する場合は、実装を指定する必要があります。 フィルタの初期化パラメータ名 config に、 MIME タイプと インタフェース HttpServletRequestMessageBodyWrapperBuilder の 実装クラス名を指定したプロパティズファイルのパスを設定してください。

導入されたバージョン:
version 5.0

コンストラクタの概要
RequestMessageBodyFilter()
フィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
static HttpServletRequestMessageBodyWrapper | getCurrentRequest() 現在処理中のリクエストを返します。
static InputStream | getInputStream() 現在のリクエストのメッセージボディを返します。
static RequestParameter[] | getRequestParameters() 現在のリクエストのパラメータを返します。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RequestMessageBodyFilter

public RequestMessageBodyFilter()
フィルタを作成します。

メソッドの詳細

getInputStream

public static InputStream getInputStream()
                                  throws IOException
現在のリクエストのメッセージボディを返します。

リクエストまたはメッセージボディが不明の場合は、null を返します。

戻り値:
メッセージボディを含む入力ストリーム
例外:
IOException - 入出力の例外が発生した場合

getRequestParameters

public static RequestParameter[] getRequestParameters()
                                               throws IOException
現在のリクエストのパラメータを返します。

リクエストが不明な場合は null を返します。

戻り値:
パラメータ情報オブジェクトの配列
例外:
IOException - 入出力の例外が発生した場合

getCurrentRequest

public static HttpServletRequestMessageBodyWrapper getCurrentRequest()
現在処理中のリクエストを返します。

リクエストが不明、 またはHttpServletRequestMessageBodyWrapperに ラップされていない場合は、null を返します。

戻り値:
リクエスト

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RequestParameter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース RequestParameter

public interface RequestParameter

１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

導入されたバージョン:
Version 5.0

メソッドの概要
String | getHeader(String name) 指定のヘッダの値を返します。
String[] | getHeaderNames() ヘッダ名称一覧を返します。
String | getName() パラメータ名を返します。
InputStream | getNameAsStream() パラメータの名称を返します。
String | getValue() データ部を文字列表現として返します。
Reader | getValueAsReader() データ部を Reader として取得します。
InputStream | getValueAsStream() データ部を入力ストリームとして取得します。
long | getValueLength() データ部のバイト長を返します。
boolean | hasHeader(String name) 指定された文字列がヘッダの名称かどうかを判定します。
boolean | hasHeaders() このオブジェクトがヘッダ情報を持つかどうかを判定します。

メソッドの詳細

getName

public String getName()
パラメータ名を返します。

GET の場合、各パラメータのパラメータ名を返します。
POST の場合、 フォームから送信された情報のうち、このエンティティが表す情報の もととなったフォーム中に定義されたコントロールの名称を返します。

戻り値:
パラメータ名

getNameAsStream

public InputStream getNameAsStream()
                            throws IOException
パラメータの名称を返します。

戻り値:
パラメータ名を含む入力ストリーム
例外:
IOException - 入出力エラー

getValue

public String getValue()
データ部を文字列表現として返します。

入力されたバイトデータから文字列への変換には、 リクエストの文字エンコーディング(javax.servlet.ServletRequest#getCharacterEncoding())を使います。

戻り値:
データ

getValueAsReader

public Reader getValueAsReader()
                        throws UnsupportedEncodingException,
                               IOException
データ部を Reader として取得します。

文字コード変換には、 リクエストの文字エンコーディング(javax.servlet.ServletRequest#getCharacterEncoding())を使います。

戻り値:
データ
例外:
UnsupportedEncodingException
IOException

getValueAsStream

public InputStream getValueAsStream()
                             throws IOException
データ部を入力ストリームとして取得します。

戻り値:
データ
例外:
IOException

getValueLength

public long getValueLength()
データ部のバイト長を返します。

戻り値:
データのサイズ

hasHeaders

public boolean hasHeaders()
このオブジェクトがヘッダ情報を持つかどうかを判定します。

戻り値:
ヘッダ情報を持つ場合 true

getHeaderNames

public String[] getHeaderNames()
ヘッダ名称一覧を返します。

このエンティティのもつヘッダ情報の名称一覧を返します。
ヘッダ情報がない場合、このメソッドは null を返します。

戻り値:
ヘッダ名称

getHeader

public String getHeader(String name)
指定のヘッダの値を返します。

指定のヘッダ名がない場合や、ヘッダ自体がない場合は、 null を返します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称にマップされている値

hasHeader

public boolean hasHeader(String name)
指定された文字列がヘッダの名称かどうかを判定します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称が値にマップされている場合 true
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResponseContentTypeManagementFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス ResponseContentTypeManagementFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
すべての実装インタフェース:
Filter
public class ResponseContentTypeManagementFilter
extends AbstractFilter

レスポンスの Content-Type を自動解決するフィルタです。
このフィルタの次のチェーン以降でレスポンス(ServletResponse)に対して、 #setCopntentType() を呼び出さなかった場合、 #getWriter() または #getOutputStream() 呼び出し時に Content-Type を自動的に設定します。

設定する Content-Type は、このフィルタの初期化パラメータ Content-Type で 指定された値です。 初期化パラメータ Content-Type が未定義の場合、text/html が設定されます。

バージョン:
1.0

コンストラクタの概要
ResponseContentTypeManagementFilter()
新しくフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
void | handleInit() このフィルタを初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResponseContentTypeManagementFilter

public ResponseContentTypeManagementFilter()
新しくフィルタを作成します。

メソッドの詳細

handleInit

public void handleInit()
このフィルタを初期化します。

オーバーライド:
クラス AbstractFilter 内の handleInit
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。

このメソッドが作る HttpServletResponse は、引数 response をラップし、 #getWriter() または #getOutputStream() メソッドが実行された時に #setContentType() を一度も呼び出されていない場合、 フィルタの初期化パラメータで設定されている Content-Type をセットしてから、 引数 response の #getWriter() または #getOutputStream() メソッドを 呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext の使用

HTTPContext を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での HTTPContext の使用

HTTPContext を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のメソッド
abstract HTTPContext | HTTPContextManager.getCurrentContext() 現在のスレッドに関連付けられた HTTP コンテキストを返します。
abstract HTTPContext[] | HTTPContextManager.getAllContext() マネージャーが保持するすべての HTTP コンテキストを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の使用

HTTPContextManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での HTTPContextManager の使用

HTTPContextManager を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のメソッド
static HTTPContextManager HTTPContextManager.getInstance()
HTTP コンテキスト・マネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager の使用

HttpSessionManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での HttpSessionManager の使用

HttpSessionManager を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のクラス
 class AbstractHttpSessionManager
インタフェース HttpSessionManager の抽象実装です。

HttpSessionManager を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
abstract  HttpSessionManager HttpSessionManagerFactory.getManager()
マネージャを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の使用

HttpSessionManagerFactory を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での HttpSessionManagerFactory の使用

HttpSessionManagerFactory を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
static HttpSessionManagerFactory HttpSessionManagerFactory.getInstance()
インスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException の使用

NoSuchSessionException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での NoSuchSessionException の使用

NoSuchSessionException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
long | HttpSessionManager.getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
long | HttpSessionManager.getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | HttpSessionManager.getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
abstract long | AbstractHttpSessionManager.getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
abstract long | AbstractHttpSessionManager.getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
abstract int | AbstractHttpSessionManager.getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractHttpSessionManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス AbstractHttpSessionManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager
すべての実装インタフェース:
HttpSessionManager
public abstract class AbstractHttpSessionManager
extends Object
implements HttpSessionManager

インタフェース HttpSessionManager の抽象実装です。 インタフェースを実装するクラスは、この抽象実装を継承すると便利です。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractHttpSessionManager()
HttpSessionManager の抽象実装を構築します。
メソッドの概要
abstract String[] | getAllIds() 現在有効なすべての HttpSession のセッションＩＤを返します。
abstract long | getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
abstract long | getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | getLength() 現在有効な HttpSession の数を返します。
abstract int | getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager から継承したメソッド
getCount

コンストラクタの詳細

AbstractHttpSessionManager

protected AbstractHttpSessionManager()
HttpSessionManager の抽象実装を構築します。

メソッドの詳細

getLength

public int getLength()
現在有効な HttpSession の数を返します。

戻り値:
有効な HttpSession の個数

getAllIds

public abstract String[] getAllIds()
現在有効なすべての HttpSession のセッションＩＤを返します。 セッションＩＤは、HttpSession.getId() が 返す値です。

定義:
インタフェース HttpSessionManager 内の getAllIds
戻り値:
セッションＩＤの配列

getCreationTime

public abstract long getCreationTime(String id)
                              throws NoSuchSessionException,
                                     UnsupportedOperationException
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getCreationTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getCreationTime
パラメータ:
id - セッションＩＤ
戻り値:
セッションが作成された時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getLastAccessedTime

public abstract long getLastAccessedTime(String id)
                                  throws NoSuchSessionException,
                                         UnsupportedOperationException
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getLastAccessedTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getLastAccessedTime
パラメータ:
id - セッションＩＤ
戻り値:
セッションに対して最後にアクセスした時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getMaxInactiveInterval

public abstract int getMaxInactiveInterval(String id)
                                    throws NoSuchSessionException,
                                           UnsupportedOperationException
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getMaxInactiveInterval() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getMaxInactiveInterval
パラメータ:
id - セッションＩＤ
戻り値:
クライアントからのリクエストの間に何秒間セッションを持続するかを表す数値
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
インタフェース HttpSessionManager

既知の実装クラスの一覧:
AbstractHttpSessionManager
public interface HttpSessionManager

HttpSession に関する情報を提供するクラスの共通インタフェース定義です。

導入されたバージョン:
version 5.0

メソッドの概要
String[] | getAllIds() 現在有効なすべての HttpSession のセッションＩＤを返します。
int | getCount() 現在有効な HttpSession の数を返します。
long | getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
long | getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。

メソッドの詳細

getCount

public int getCount()
現在有効な HttpSession の数を返します。

戻り値:
有効な HttpSession の個数

getAllIds

public String[] getAllIds()
現在有効なすべての HttpSession のセッションＩＤを返します。 セッションＩＤは、HttpSession.getId() が 返す値です。

戻り値:
セッションＩＤの配列

getCreationTime

public long getCreationTime(String id)
                     throws NoSuchSessionException,
                            UnsupportedOperationException
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getCreationTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
セッションが作成された時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getLastAccessedTime

public long getLastAccessedTime(String id)
                         throws NoSuchSessionException,
                                UnsupportedOperationException
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getLastAccessedTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
セッションに対して最後にアクセスした時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getMaxInactiveInterval

public int getMaxInactiveInterval(String id)
                           throws NoSuchSessionException,
                                  UnsupportedOperationException
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getMaxInactiveInterval() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
クライアントからのリクエストの間に何秒間セッションを持続するかを表す数値
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionManagerFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionManagerFactory

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
public abstract class HttpSessionManagerFactory
extends Object

HttpSessionManager を作成するファクトリクラスの抽象実装です。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected HttpSessionManagerFactory()
新しい HttpSessionManagerFactory を構築します。
メソッドの概要
static HttpSessionManagerFactory | getInstance() インスタンスを返します。
abstract HttpSessionManager | getManager() マネージャを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionManagerFactory

protected HttpSessionManagerFactory()
新しい HttpSessionManagerFactory を構築します。

メソッドの詳細

getInstance

public static HttpSessionManagerFactory getInstance()
インスタンスを返します。
このメソッドが返すファクトリは、システムに標準実装されているものです。 独自実装を利用する場合は、このクラスを継承して新しいサブクラスを 作成してください。

戻り値:
ファクトリオブジェクトを返します。

getManager

public abstract HttpSessionManager getManager()
マネージャを返します。

戻り値:
マネージャ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionMonitoringFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionMonitoringFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
すべての実装インタフェース:
Filter
public class HttpSessionMonitoringFilter
extends AbstractFilter

HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。 このフィルタを設定し動作させる事で、HttpSessionManager の標準実装が 正しい値を返します。

導入されたバージョン:
version 5.0

コンストラクタの概要
HttpSessionMonitoringFilter()
新しい HttpSessionMonitoringFilter を構築します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionMonitoringFilter

public HttpSessionMonitoringFilter()
新しい HttpSessionMonitoringFilter を構築します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionMonitoringListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionMonitoringListener

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener
すべての実装インタフェース:
EventListener, HttpSessionListener
public class HttpSessionMonitoringListener
extends Object
implements HttpSessionListener

HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。 このリスナを設定し動作させる事で、HttpSessionManager の標準実装が 正しい値を返します。

導入されたバージョン:
version 5.0

コンストラクタの概要
HttpSessionMonitoringListener()
新しいセッションリスナを構築します。
メソッドの概要
void | sessionCreated(HttpSessionEvent se) セッションが作成されたことを通知します。
void | sessionDestroyed(HttpSessionEvent se) セッションが無効になったことを通知します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionMonitoringListener

public HttpSessionMonitoringListener()
新しいセッションリスナを構築します。

メソッドの詳細

sessionCreated

public void sessionCreated(HttpSessionEvent se)
セッションが作成されたことを通知します。

定義:
インタフェース HttpSessionListener 内の sessionCreated
パラメータ:
se - 通知するイベント

sessionDestroyed

public void sessionDestroyed(HttpSessionEvent se)
セッションが無効になったことを通知します。

定義:
インタフェース HttpSessionListener 内の sessionDestroyed
パラメータ:
se - 通知するイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NoSuchSessionException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス NoSuchSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException
すべての実装インタフェース:
Serializable
public class NoSuchSessionException
extends Exception

特定のＨＴＴＰセッションが見つからない場合にスローされます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
NoSuchSessionException()
詳細メッセージを持たない NoSuchSessionException を構築します。
NoSuchSessionException(String message)
詳細メッセージを持つ NoSuchSessionException を構築します。
NoSuchSessionException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。
NoSuchSessionException(Throwable cause)
指定された原因を使用して新しい NoSuchSessionException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSuchSessionException

public NoSuchSessionException()
詳細メッセージを持たない NoSuchSessionException を構築します。

NoSuchSessionException

public NoSuchSessionException(String message)
詳細メッセージを持つ NoSuchSessionException を構築します。

パラメータ:
message - 詳細メッセージ

NoSuchSessionException

public NoSuchSessionException(String message,
                              Throwable cause)
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

NoSuchSessionException

public NoSuchSessionException(Throwable cause)
指定された原因を使用して新しい NoSuchSessionException を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
インタフェース
HttpSessionManager
クラス
AbstractHttpSessionManager
HttpSessionManagerFactory
HttpSessionMonitoringFilter
HttpSessionMonitoringListener
例外
NoSuchSessionException


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session

このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
HttpSessionManager HttpSession に関する情報を提供するクラスの共通インタフェース定義です。

クラスの概要
AbstractHttpSessionManager | インタフェース HttpSessionManager の抽象実装です。
HttpSessionManagerFactory | HttpSessionManager を作成するファクトリクラスの抽象実装です。
HttpSessionMonitoringFilter | HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。
HttpSessionMonitoringListener | HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。

例外の概要
NoSuchSessionException 特定のＨＴＴＰセッションが見つからない場合にスローされます。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の説明

このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener (implements javax.servlet.http.HttpSessionListener)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のクラス
HttpSessionManager
HttpSession に関する情報を提供するクラスの共通インタフェース定義です。
HttpSessionManagerFactory
HttpSessionManager を作成するファクトリクラスの抽象実装です。
NoSuchSessionException
特定のＨＴＴＰセッションが見つからない場合にスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


HTTPContext (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
インタフェース HTTPContext

public interface HTTPContext

リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。

メソッドの概要
HttpSession | getCurrentSession() このリクエストに関連づけられている現在のセッションを返します。
HttpServletRequest | getRequest() リクエストを返します。
HttpServletResponse | getResponse() レスポンスを返します。
ServletContext | getServletContext() サーブレットコンテキストを返します。
HttpSession | getSession() このリクエストに関連づけられている現在のセッションを返します。
void | log(String message) Servlet ログファイルに指定されたメッセージを出力します。
void | log(String message, Throwable throwable) 与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。

メソッドの詳細

getServletContext

public ServletContext getServletContext()
サーブレットコンテキストを返します。

戻り値:
サーブレットコンテキスト

getRequest

public HttpServletRequest getRequest()
リクエストを返します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
レスポンスを返します。

戻り値:
レスポンス

getSession

public HttpSession getSession()
このリクエストに関連づけられている現在のセッションを返します。 リクエストがセッションを持たない場合はセッションを生成します。

戻り値:
このリクエストに関連づけられているHttpSession

getCurrentSession

public HttpSession getCurrentSession()
このリクエストに関連づけられている現在のセッションを返します。 リクエストが有効なHttpSessionを持たない場合は nullを返します。

戻り値:
このリクエストに関連づけられているHttpSession。リクエストが有効なセッションを持っていなければ null。

log

public void log(String message)
Servlet ログファイルに指定されたメッセージを出力します。

このメソッドは、現在の ServletContext の #log(String) を呼び出します。

パラメータ:
message - ログファイルに出力するメッセージを指定する String
関連項目:
ServletContext.log(String msg)

log

public void log(String message,
                Throwable throwable)
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。

このメソッドは、現在の ServletContext の #log(String, Throwable) を呼び出します。

パラメータ:
message - エラーや例外を解説する String
throwable - Throwable エラーや例外
関連項目:
ServletContext.log(String message, Throwable throwable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPContextManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス HTTPContextManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
public abstract class HTTPContextManager
extends Object

HTTP コンテキスト・マネージャ

導入されたバージョン:
version 5.0

コンストラクタの概要
protected HTTPContextManager()
デフォルトコンストラクタ getInstance()を利用してください。
メソッドの概要
abstract HTTPContext[] | getAllContext() マネージャーが保持するすべての HTTP コンテキストを返します。
abstract HTTPContext | getCurrentContext() 現在のスレッドに関連付けられた HTTP コンテキストを返します。
static HTTPContextManager | getInstance() HTTP コンテキスト・マネージャのインスタンスを取得します。
abstract int | getLength() マネージャーが保持する HTTP コンテキストの数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPContextManager

protected HTTPContextManager()
デフォルトコンストラクタ getInstance()を利用してください。

メソッドの詳細

getInstance

public static HTTPContextManager getInstance()
HTTP コンテキスト・マネージャのインスタンスを取得します。

戻り値:
HTTP コンテキスト・マネージャ

getCurrentContext

public abstract HTTPContext getCurrentContext()
現在のスレッドに関連付けられた HTTP コンテキストを返します。

戻り値:
現在のスレッドに関連付けられた HTTP コンテキスト

getAllContext

public abstract HTTPContext[] getAllContext()
                                     throws UnsupportedOperationException
マネージャーが保持するすべての HTTP コンテキストを返します。

戻り値:
マネージャーが保持するすべての HTTP コンテキストの配列
例外:
UnsupportedOperationException - サブクラスが本メソッドをサポートしていない場合

getLength

public abstract int getLength()
                       throws UnsupportedOperationException
マネージャーが保持する HTTP コンテキストの数を返します。

戻り値:
マネージャーが保持する HTTP コンテキストの数
例外:
UnsupportedOperationException - サブクラスが本メソッドをサポートしていない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
インタフェース
HTTPContext
クラス
HTTPContextManager


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http

このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
HTTPContext リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。

クラスの概要
HTTPContextManager HTTP コンテキスト・マネージャ

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の説明

このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
HTTPContext
リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。
HTTPContextManager
HTTP コンテキスト・マネージャ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


FilterServletInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet
クラス FilterServletInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 javax.servlet.ServletInputStream
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
public class FilterServletInputStream
extends ServletInputStream

InputStream を ServletInputStream に変換するためのラッパです。

このクラスは、基礎ストリームの対応するメソッドを呼び出すだけです。 各メソッドをオーバーライドして再定義することにより、 入力をフィルタリングする事ができます。

導入されたバージョン:
Version 5.0

コンストラクタの概要
FilterServletInputStream(InputStream in)
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。
メソッドの概要
int | available() この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。
void | close() 入力を閉じます。
protected InputStream | getInputStream() このオブジェクトがラップしている入力ストリームを返します。
void | mark(int readlimit) 入力ストリームの現在位置にマークを設定します。
boolean | markSupported() 入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。
int | read() 基礎入力から１バイト読み込みます。
int | read(byte[] b) 基礎入力から指定のバイト配列にデータを読み込みます。
int | read(byte[] b, int off, int len) 基礎入力から指定のバイト配列にデータを読み込みます。
void | reset() このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。
long | skip(long n) 指定のバイト数だけ入力をスキップします。
クラス javax.servlet.ServletInputStream から継承したメソッド
readLine
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FilterServletInputStream

public FilterServletInputStream(InputStream in)
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

getInputStream

protected InputStream getInputStream()
このオブジェクトがラップしている入力ストリームを返します。

戻り値:
入力ストリーム

read

public int read()
         throws IOException
基礎入力から１バイト読み込みます。

このメソッドは、以下と同じです。
getInputStream().read()

戻り値:
データの次のバイト。ストリームの終わりに達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b)
         throws IOException
基礎入力から指定のバイト配列にデータを読み込みます。

このメソッドは、以下と同じです。
getInputStream().read(b)

パラメータ:
b - データの読み込み先のバッファ
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
基礎入力から指定のバイト配列にデータを読み込みます。

このメソッドは、以下と同じです。
getInputStream().read(b, off, len)

パラメータ:
b - データの読み込み先のバッファ
off - データが書き込まれる配列 b の開始オフセット
len - 読み込む最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合

skip

public long skip(long n)
          throws IOException
指定のバイト数だけ入力をスキップします。

このメソッドは、以下と同じです。
getInputStream().skip(n)

パラメータ:
n - スキップするバイト数
戻り値:
実際にスキップされたバイト数
例外:
IOException - 入出力エラーが発生した場合

available

public int available()
              throws IOException
この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。

このメソッドは、以下と同じです。
getInputStream().available()

戻り値:
ブロックしないで入力ストリームから読み込むことができるバイト数
例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
入力を閉じます。

このメソッドは、以下と同じです。
getInputStream().close()

例外:
IOException - 入出力エラーが発生した場合

mark

public void mark(int readlimit)
入力ストリームの現在位置にマークを設定します。

このメソッドは、以下と同じです。
getInputStream().mark(readlimit)

パラメータ:
readlimit - マーク位置が無効になる前に読み込み可能なバイトの最大リミット

reset

public void reset()
           throws IOException
このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。

このメソッドは、以下と同じです。
getInputStream().reset()

例外:
IOException - ストリームにマークが設定されていなかった場合、またはマークが無効になっていた場合

markSupported

public boolean markSupported()
入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。

このメソッドは、以下と同じです。
getInputStream().markSupported()

戻り値:
このストリームインスタンスが mark および reset メソッドをサポートしている場合は true、サポートしていない場合は false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet
クラス
FilterServletInputStream


jp.co.intra_mart.common.aid.jsdk.javax.servlet (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet

このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
FilterServletInputStream InputStream を ServletInputStream に変換するためのラッパです。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の説明

このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jsdk.javax.servlet クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class javax.servlet.ServletInputStream
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の使用

jp.co.intra_mart.common.aid.jsdk.utility.BrowseString はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の使用

jp.co.intra_mart.common.aid.jsdk.utility.URLUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


BrowseString (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.utility
クラス BrowseString

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
public class BrowseString
extends Object

HTML表示用文字列変換ユーティリティクラス。

HTML表示用に文字列の変換を行うクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static String convert(String string)
HTML表示可能な文字列に変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

convert

public static String convert(String string)
HTML表示可能な文字列に変換します。

「>」、「<」、「"」、「&」、「半角スペース」、「改行コード」をHTML表示可能な文字に変換します。
改行コードは「<BR>」に変換します。

パラメータ:
string - 変換元文字列
戻り値:
変換された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.utility (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.aid.jsdk.utility
クラス
BrowseString
URLUtil


jp.co.intra_mart.common.aid.jsdk.utility (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.utility

このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
BrowseString | HTML表示用文字列変換ユーティリティクラス。
URLUtil | URL関連のユーティリティクラス。

パッケージ jp.co.intra_mart.common.aid.jsdk.utility の説明

このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.aid.jsdk.utility クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.utility の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
    • class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.aid.jsdk.utility の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.utility の使用

jp.co.intra_mart.common.aid.jsdk.utility はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


URLUtil (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.utility
クラス URLUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
public class URLUtil
extends Object

URL関連のユーティリティクラス。

HttpServletRequestが保持している情報を元に、URLを生成するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
URLUtil()
メソッドの概要
static String | encodeUrl(String src) 文字列をURLエンコードします。
static URL | getContextURL(HttpServletRequest request) 引数で与えられたリクエストのコンテキストを示すURLを生成します。
static URL | getContextURL(HttpServletRequest request, boolean appendSlash) 引数で与えられたリクエストのコンテキストを示すURLを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLUtil

public URLUtil()
メソッドの詳細

getContextURL

public static URL getContextURL(HttpServletRequest request)
                         throws MalformedURLException
引数で与えられたリクエストのコンテキストを示すURLを生成します。
このメソッドで生成されたURLの末尾は、常にスラッシュとなります。

パラメータ:
request - リクエスト
戻り値:
要求のコンテキストを示すURL
例外:
MalformedURLException - 引数で与えられたリクエストに使用されるスキーマが未知である場合

getContextURL

public static URL getContextURL(HttpServletRequest request,
                                boolean appendSlash)
                         throws MalformedURLException
引数で与えられたリクエストのコンテキストを示すURLを生成します。
このメソッドで生成されたURLの末尾は、引数 appendSlash によって変化します。

パラメータ:
request - リクエスト
appendSlash - このメソッドで生成されたURLの末尾にスラッシュを付加する場合は、true、　それ以外はfalse
戻り値:
要求のコンテキストを示すURL
例外:
MalformedURLException - 引数で与えられたリクエストに使用されるスキーマが未知である場合

encodeUrl

public static String encodeUrl(String src)
文字列をURLエンコードします。

パラメータ:
src - URLエンコード元文字列
戻り値:
URLエンコード後の文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.platform.util.DateUtil の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.platform.util.DateUtil の使用

jp.co.intra_mart.common.platform.util.DateUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DateUtil (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.platform.util
クラス DateUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.platform.util.DateUtil
public class DateUtil
extends Object

日付操作ユーティリティクラスです。

日付に関する操作をするためのユーティリティクラスです。
このクラスのメソッドはすべてstaticメソッドとなっています。
このクラスのインスタンスを生成することはできません。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static Date | convertOnlyDate(Date date) 日付のみのjava.util.Dateに変換します。
static Date | convertOnlyDate(long date) 日付のみのjava.util.Dateに変換します。
static Date | convertOnlyDateTime(Date date) 日付と時刻のみのjava.util.Dateに変換します。
static Date | convertOnlyDateTime(long date) 日付と時刻のみのjava.util.Dateに変換します。
static String | dateToString(Date date) データベース登録用文字列を取得します。
static Date | getMaxDate() システムで許可されている最大日時を取得します。
static Date | getMinDate() システムで許可されている最小日時を取得します。
static Date | stringToDate(String dateString) データベース登録用文字列からjava.util.Dateを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

dateToString

public static String dateToString(Date date)
データベース登録用文字列を取得します。

パラメータ:
date - 変換元のDateオブジェクト
戻り値:
データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)

stringToDate

public static Date stringToDate(String dateString)
データベース登録用文字列からjava.util.Dateを取得します。

パラメータ:
dateString - 変換元のデータベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
戻り値:
Dateオブジェクト

convertOnlyDate

public static Date convertOnlyDate(long date)
日付のみのjava.util.Dateに変換します。

時刻は、00:00:00.000に設定されます。

パラメータ:
date - 1970 年 1 月 1 日 00:00:00 GMT からのミリ秒数
戻り値:
日付のみのjava.util.Date

convertOnlyDate

public static Date convertOnlyDate(Date date)
日付のみのjava.util.Dateに変換します。

時刻は、00:00:00.000に設定されます。

パラメータ:
date - 日付
戻り値:
日付のみのjava.util.Date

convertOnlyDateTime

public static Date convertOnlyDateTime(long date)
日付と時刻のみのjava.util.Dateに変換します。

ミリ秒の単位は 0 に設定されます。

パラメータ:
date - 1970 年 1 月 1 日 00:00:00 GMT からのミリ秒数
戻り値:
日付と時刻のみのjava.util.Date

convertOnlyDateTime

public static Date convertOnlyDateTime(Date date)
日付と時刻のみのjava.util.Dateに変換します。

ミリ秒の単位は 0 に設定されます。

パラメータ:
date - 日付
戻り値:
日付と時刻のみのjava.util.Date

getMinDate

public static Date getMinDate()
システムで許可されている最小日時を取得します。

戻り値:
システムで許可されている最小日時

getMaxDate

public static Date getMaxDate()
システムで許可されている最大日時を取得します。

戻り値:
システムで許可されている最大日時
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.platform.util (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.platform.util
クラス
DateUtil


jp.co.intra_mart.common.platform.util (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.util

このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。

参照:
説明

クラスの概要
DateUtil 日付操作ユーティリティクラスです。

パッケージ jp.co.intra_mart.common.platform.util の説明

このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.platform.util クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.util.DateUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.platform.util の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.platform.util の使用

jp.co.intra_mart.common.platform.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.platform.vm.CommandLineArgument の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.platform.vm.CommandLineArgument の使用

jp.co.intra_mart.common.platform.vm.CommandLineArgument はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CommandLineArgument (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.platform.vm
クラス CommandLineArgument

java.lang.Object
    拡張 jp.co.intra_mart.common.platform.vm.CommandLineArgument
public class CommandLineArgument
extends Object

このクラスはコマンド実引数を解釈するための共通実装です。

このクラスは、インスタンス生成時にコマンドライン引数を解析し、 オプションと引数に選別します。 コマンド [-オプション名 [値]] [引数] オプションは "-" から始まる名称文字列と値から成り立ちます。 最後尾のオプション指定以降のトークンを引数として解釈します。 オプションはオプション名("-" から始まるトークン)をキーとして 値がマッピングされます。

コンストラクタの概要
CommandLineArgument(String[] args)
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。
メソッドの概要
String | getArgument(int index) 指定されたすべてのコマンドライン引数の引数を返します。
String[] | getArguments() 指定されたすべてのコマンドライン引数の引数を返します。
String | getOption(String name) オプションの値を返します。
String | getOption(String name, String def) オプションの値を返します。
Set | getOptionNames() 指定されたすべてのオプションの名前を返します。
String[] | getOptions(String name) オプションの値を返します。
String[] | getQuery() 引数情報を取得します。
boolean | hasArguments() コマンドライン引数があるかどうか判定します。
boolean | hasOption(String name) オプションが指定されているかどうか判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CommandLineArgument

public CommandLineArgument(String[] args)
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。

実引数(command-line-arguments)の格納されている配列の構造は変化しません。
コマンド [-オプション名 [値]] [引数] オプションと引数を分割します。 オプションは、値のない単独指定も可能です。

パラメータ:
args - コマンド実行時のコマンドライン引数(main メソッドの引数)
例外:
IllegalArgumentException - 引数が null の場合
メソッドの詳細

getQuery

public String[] getQuery()
引数情報を取得します。 このメソッドは、このインスタンス生成時にコンストラクタに指定した 値を返します。

戻り値:
引数情報

hasOption

public boolean hasOption(String name)
オプションが指定されているかどうか判定します。

パラメータ:
name - オプション名
戻り値:
オプションが指定されている場合 true、そうでない場合 false。

getOption

public String getOption(String name)
                 throws IllegalArgumentException
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。

パラメータ:
name - オプション名
戻り値:
オプションの値
例外:
IllegalArgumentException - 指定のオプション名が定義されていない場合

getOption

public String getOption(String name,
                        String def)
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。 また、指定のオプション名が未定義だった場合、デフォルト値 def を 返します。

パラメータ:
name - オプション名
def - オプションが未指定だった場合のデフォルト値
戻り値:
オプションの値

getOptions

public String[] getOptions(String name)
                    throws IllegalArgumentException
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。

パラメータ:
name - オプション名
戻り値:
オプションの値
例外:
IllegalArgumentException - 指定のオプション名が定義されていない場合

getOptionNames

public Set getOptionNames()
指定されたすべてのオプションの名前を返します。 返却値のセットの各要素は String インスタンスです。

戻り値:
オプション名一覧のセット

getArguments

public String[] getArguments()
指定されたすべてのコマンドライン引数の引数を返します。 ここで返される引数は、コマンドライン引数のうちの オプション指定ではない引数です。 返却値のセットの各要素は String インスタンスです。

戻り値:
引数のセット

getArgument

public String getArgument(int index)
                   throws ArrayIndexOutOfBoundsException
指定されたすべてのコマンドライン引数の引数を返します。 ここで返される引数は、コマンドライン引数のうちの オプション指定ではない引数です。 返却値のセットの各要素は String インスタンスです。

戻り値:
引数のセット
例外:
ArrayIndexOutOfBoundsException - インデックスが範囲外の場合（引数の個数以上、または負数）

hasArguments

public boolean hasArguments()
コマンドライン引数があるかどうか判定します。 ここでチェックされる引数は、コマンドライン引数のうちの オプション指定ではない引数です。

戻り値:
オプションではない引数がある場合 true、そうでない場合 false。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.platform.vm (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.common.platform.vm
クラス
CommandLineArgument


jp.co.intra_mart.common.platform.vm (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.vm

このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

参照:
説明

クラスの概要
CommandLineArgument このクラスはコマンド実引数を解釈するための共通実装です。

パッケージ jp.co.intra_mart.common.platform.vm の説明

このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.common.platform.vm クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.vm の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.vm.CommandLineArgument
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.common.platform.vm の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.platform.vm の使用

jp.co.intra_mart.common.platform.vm はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.AccountManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AccountManager の使用

jp.co.intra_mart.foundation.acssecurity.AccountManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.AcsData の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AcsData の使用

jp.co.intra_mart.foundation.acssecurity.AcsData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.AcssecurityException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.AcssecurityException の使用

AcssecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.acssecurity アクセスセキュリティモジュールを利用するためのクラスを提供します。

jp.co.intra_mart.foundation.acssecurity での AcssecurityException の使用

AcssecurityException をスローする jp.co.intra_mart.foundation.acssecurity のメソッド
 void RoleManager.setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 void RoleManager.setData(Map datas, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 boolean RoleManager.contains(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
 int RoleManager.count()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
 Vector RoleManager.getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
 Map RoleManager.getData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
 void RoleManager.delData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 void RoleManager.delData(String roleId, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 String RoleManager.getIdByName(String roleName)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
 String[] RoleManager.getListData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
 String[] RoleManager.getParentData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
 void AccountManager.setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
 void AccountManager.setData(Map datas, boolean isTransaction)
推奨されていません。
 boolean AccountManager.contains(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
 int AccountManager.count()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
 Vector AccountManager.getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
 Map AccountManager.getData(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
 void AccountManager.delData(String uid)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 void AccountManager.delData(String uid, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.Logingp の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.Logingp の使用

jp.co.intra_mart.foundation.acssecurity.Logingp はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.acssecurity.RoleManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.acssecurity.RoleManager の使用

jp.co.intra_mart.foundation.acssecurity.RoleManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AccountManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AccountManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.AccountManager
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。

public class AccountManager
extends Object

ログインユーザ情報を操作します。

コンストラクタの概要
AccountManager(String login_grp)
推奨されていません。
メソッドの概要
 boolean contains(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
 int count()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
 void delData(String uid)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 void delData(String uid, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
 Map getData(String userId)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
 Vector getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
 void setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
 void setData(Map datas, boolean isTransaction)
推奨されていません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountManager

public AccountManager(String login_grp)
推奨されていません。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

setData

public void setData(Map datas)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。

ユーザデータを登録する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
datas - ユーザデータ

例外:
AcssecurityException -

引数 datas(Map)の内容
      (key == value)

         以下、IMISに登録されるデータ。
         DBを使用する場合,（＊）印のデータはIMISとDBの同期をとる。

         id      = ユーザID(String)[必須]（＊）
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]（＊）
         madrs   = メールアドレス(String)（＊）
         mbladrs = モバイル用メールアドレス(String)（＊）
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）

         以下、DBにのみ登録されるデータ。
                    (get()メソッドでは取得できない)
         kana    = ユーザ名カナ(String)
         eng     = ユーザ名英字(String)
         tel     = 電話番号(String)
         hndy    = 携帯電話番号(String)
         fax     = FAX番号(String)
         extens  = 内線電話番号(String)
         exFax   = 内線FAX(String)
         cntry_cd =  国コード(String)
         zip     = 郵便番号(String)
         adrs    = 住所(String)
         madrs2  = メールアドレス２(String)
         url     = URL(String)
         note    = 備考(String)
         mainGp  = 主所属グループCD(String)
         groups  = 所属グループCDの配列(String[])
         その他 各アプリに依存(String or Double or Boolean)

        引数に指定したユーザIDが既に存在していた場合、上書き(前のデータはなくなり、引数データを追加)する。

setData

public void setData(Map datas,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。

ユーザデータを登録する

パラメータ:
datas - ユーザデータ

isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException -

     引数 datas(Map)の内容

      (key == value)

         以下、IMISに登録されるデータ。
         DBを使用する場合,（＊）印のデータはIMISとDBの同期をとる。

         id      = ユーザID(String)[必須]（＊）
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]（＊）
         madrs   = メールアドレス(String)（＊）
         mbladrs = モバイル用メールアドレス(String)（＊）
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）

         以下、DBにのみ登録されるデータ。
                    (get()メソッドでは取得できない)
         kana    = ユーザ名カナ(String)
         eng     = ユーザ名英字(String)
         tel     = 電話番号(String)
         hndy    = 携帯電話番号(String)
         fax     = FAX番号(String)
         extens  = 内線電話番号(String)
         exFax   = 内線FAX(String)
         cntry_cd =  国コード(String)
         zip     = 郵便番号(String)
         adrs    = 住所(String)
         madrs2  = メールアドレス２(String)
         url     = URL(String)
         note    = 備考(String)
         mainGp  = 主所属グループCD(String)
         groups  = 所属グループCDの配列(String[])
         その他 各アプリに依存(String or Double or Boolean)

        引数に指定したユーザIDが既に存在していた場合、上書きする。

contains

public boolean contains(String userId)
                 throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。

ユーザデータの存在チェック

パラメータ:
userId - ユーザID
戻り値:
ある true / ない false
例外:
AcssecurityException

count

public int count()
          throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。

ユーザデータの登録数を取得

戻り値:
登録ユーザ数
例外:
AcssecurityException

getIDs

public Vector getIDs()
              throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。

ユーザIDをすべて取得する

戻り値:
ユーザIDの配列(データがない場合は空の配列)
例外:
AcssecurityException

getData

public Map getData(String userId)
            throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。

ユーザデータの取得

パラメータ:
userId - ユーザID
戻り値:
ユーザ情報（ユーザ情報がなければnull）

     戻り値 (Map)の内容

      (key == value)

         id      = ユーザID(String)
         pwd     = パスワード(String)
         mpwd    = モバイル用パスワード(String)
         name    = ユーザ名(String)[必須]
         madrs   = メールアドレス(String)
         mbladrs = モバイル用メールアドレス(String)
         explan  = 説明(String)
         vldDate = 有効期限(Double(ミリ秒))
         roles   = ロールIDの配列(String[])
         license = ライセンス(Boolean あり true/なし false)
         apps    = アプリケーションロール(String[]) （V4.0.0以上）
例外:
AcssecurityException

delData

public void delData(String uid)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

ユーザデータを削除する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

例外:
AcssecurityException

delData

public void delData(String uid,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。

ユーザデータを削除する

パラメータ:
isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AcsData (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AcsData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.AcsData

public class AcsData
extends Object

ロール、メニュー、メッセージ、アカウント、バッチ、リンク データをインポート／エクスポートします。

※インポート／エクスポート のフォーマットは、system/config/data/format_readme.txtを参照して下さい。

コンストラクタの概要
AcsData()
推奨されていません。
メソッドの概要
static Number acntFromDBToIS(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number acntFromISToDB(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number dbConsistChk(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllAccount(String login_grp)
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。
static Number delAllLink(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllMenu(String login_grp)
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。
static Number delAllMessage(String login_grp)
推奨されていません。 代替えメソッドはありません。
static Number delAllRole(String login_grp)
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。
static Number delAllSchedule(String login_grp)
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。
static Number getAccount(String login_grp, String path)
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getLink(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number getMenu(String login_grp, String path)
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getMessage(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number getRole(String login_grp, String path)
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number getSchedule(String login_grp, String path)
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
static Number setAccount(String login_grp, String path)
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setLink(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number setMenu(String login_grp, String path)
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setMessage(String login_grp, String path)
推奨されていません。 代替えメソッドはありません。
static Number setRole(String login_grp, String path)
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
static Number setSchedule(String login_grp, String path)
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AcsData

public AcsData()
推奨されていません。
メソッドの詳細

setRole

public static Number setRole(String login_grp,
                             String path)
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。

ロールデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3： システムエラー
6： パスがディレクトリである

setMenu

public static Number setMenu(String login_grp,
                             String path)
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。

メニューデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setMessage

public static Number setMessage(String login_grp,
                                String path)
推奨されていません。 代替えメソッドはありません。

メッセージデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正

setAccount

public static Number setAccount(String login_grp,
                                String path)
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。

アカウントデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setSchedule

public static Number setSchedule(String login_grp,
                                 String path)
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。

バッチデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：システムエラー
6：パスがディレクトリである

setLink

public static Number setLink(String login_grp,
                             String path)
推奨されていません。 代替えメソッドはありません。

リンクデータをインポートする

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 指定のファイル内のロールデータを Infomation Server へ登録します。 データは第1引数で指定したログイングループに登録されます。 ファイルは File Server 上にある必要があります。 第2引数のデータファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（imart_error.log）に出力されます。 (指定のフォーマットにそぐわないデータがある場合、処理が遅くなります。) 既に同一のロールIDがシステムに登録されている場合、上書きされます。

パラメータ:
login_grp - ログイングループID
path - データファイルパス
戻り値:
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正

getRole

public static Number getRole(String login_grp,
                             String path)
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。

ロール情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getMenu

public static Number getMenu(String login_grp,
                             String path)
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。

メニュー情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getMessage

public static Number getMessage(String login_grp,
                                String path)
推奨されていません。 代替えメソッドはありません。

メッセージ情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getAccount

public static Number getAccount(String login_grp,
                                String path)
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。

アカウント情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getSchedule

public static Number getSchedule(String login_grp,
                                 String path)
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。

バッチ情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正
6：パスがディレクトリである。

getLink

public static Number getLink(String login_grp,
                             String path)
推奨されていません。 代替えメソッドはありません。

リンク情報をエクスポートする

指定のログイングループ内のロールデータを ファイルへ出力します。 ファイルは File Server 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはFile Serverインストールフォルダからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。

パラメータ:
login_grp - ログイングループID
path - 出力ファイルパス
戻り値:
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
3：エクスポートするデータがない
4：ファイルへの書き込みに失敗
5：引数が不正

delAllRole

public static Number delAllRole(String login_grp)
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。

ロール情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正
3: システムエラー

delAllMenu

public static Number delAllMenu(String login_grp)
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。

メニュー情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正
3: システムエラー

delAllMessage

public static Number delAllMessage(String login_grp)
推奨されていません。 代替えメソッドはありません。

メッセージ情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllAccount

public static Number delAllAccount(String login_grp)
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。

アカウント情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllSchedule

public static Number delAllSchedule(String login_grp)
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。

バッチ情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

delAllLink

public static Number delAllLink(String login_grp)
推奨されていません。 代替えメソッドはありません。

リンク情報を全て削除する

指定のログイングループ内のロールデータを 全て削除します。

パラメータ:
login_grp - ログイングループID
戻り値:
0：削除成功
2：引数が不正

dbConsistChk

public static Number dbConsistChk(String login_grp)
推奨されていません。 代替えメソッドはありません。

DBとInfomationサーバとのアカウント情報整合性チェック

DBとInfomationサーバのアカウントデータの数があっているかチェックします。

パラメータ:
login_grp - ログイングループID
戻り値:
0：不整合なし
1：ＤＢにデータが不足している
2：ＤＢのデータが多い
3：DBに接続できない。またはDBにテーブル(b_m_user)がない。
4：引数が不正

acntFromISToDB

public static Number acntFromISToDB(String login_grp)
推奨されていません。 代替えメソッドはありません。

Infomationサーバのアカウント情報をDBへ入れる

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 このメソッドは内部でDBトランザクションを発行しています。このメソッドを トランザクション内で使用しないで下さい。 このメソッドは登録しているユーザ数に処理時間が依存します。サーバ環境にも よりますが、数分から数十分処理時間がかかる場合があります。 Infomationサーバのアカウント情報をDBのユーザ管理テーブルへ入れます。 既にDBに登録してあるユーザは処理しません。 （Infomationサーバに存在し、DBにないユーザだけをDBに 追加します。DBの既存データの更新は行いません。）

パラメータ:
login_grp - ログイングループID
戻り値:
0：登録成功
1：DBに接続できない。またはDBにテーブル(b_m_user)がない。
2：引数が不正

acntFromDBToIS

public static Number acntFromDBToIS(String login_grp)
推奨されていません。 代替えメソッドはありません。

DBのアカウント情報をInfomationサーバへ入れる

このメソッドは同期をとりません。複数のリクエストから同時に 実行されるような場所には使用しないで下さい。 このメソッドは登録しているユーザ数に処理時間が依存します。サーバ環境にも よりますが、数分から数十分処理時間がかかる場合があります。 DBのユーザ管理テーブルのアカウント情報をInfomationサーバへ入れます。 既にInfomationサーバに登録してあるユーザは処理しません。 （DBに存在し、InfomationサーバにないユーザだけをInfomationサーバに 追加します。Infomationサーバの既存データの更新は行いません。） ユーザIDをパスワードとして登録します。 そのとき、ユーザIDが14桁を越えている場合は15桁目以降をカットします。 i-modeパスワードは登録しません。 ライセンスなしで登録します。 有効期限は無期限で登録します。 ロール情報は登録しません。

パラメータ:
login_grp - ログイングループID
戻り値:
0：登録成功
1：DBに接続できない。またはDBにテーブル(b_m_user)がない。
2：引数が不正
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AcssecurityException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス AcssecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.acssecurity.AcssecurityException
すべての実装インタフェース:
Serializable
public class AcssecurityException
extends Exception

アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

関連項目:
直列化された形式

メソッドの概要
int | getCode()
String | getMessage()
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

メソッドの詳細

getMessage

public String getMessage()

getCode

public int getCode()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Logingp (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス Logingp

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.Logingp

public class Logingp
extends Object

ログイングループ情報を操作します。

コンストラクタの概要
Logingp(String login_grp)
推奨されていません。 LoginGroupManagerに置き換えられました。
メソッドの概要
static Number count()
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。
 Boolean del(String key)
推奨されていません。 代替えメソッドはありません。
static List entries()
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。
 Object get(String key)
推奨されていません。 代替えメソッドはありません。
static Boolean isGroup(String login_grp)
推奨されていません。 代替えメソッドはありません。
 Boolean set(String key, Number value)
推奨されていません。 代替えメソッドはありません。
 Boolean set(String key, String value)
推奨されていません。 代替えメソッドはありません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Logingp

public Logingp(String login_grp)
推奨されていません。 LoginGroupManagerに置き換えられました。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

count

public static Number count()
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。

登録されているログイングループ数を返す

戻り値:
ログイングループ数

entries

public static List entries()
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。

登録されているログイングループIDの配列を取得する。

戻り値:
ログイングループIDの配列
(データがないときnull)

isGroup

public static Boolean isGroup(String login_grp)
推奨されていません。 代替えメソッドはありません。

指定のログイングループの存在チェック

パラメータ:
login_grp - ログイングループID
戻り値:
ある true/ない false

del

public Boolean del(String key)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報を削除する。

set()メソッドで登録した値を削除する。

パラメータ:
key - データのキー

戻り値:
成功 true/失敗 false

get

public Object get(String key)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報を取得する。

set()メソッドで登録した値を取得する。

パラメータ:
key - データのキー

戻り値:
set()メソッドで登録した値(String、Number)

set

public Boolean set(String key,
                   Number value)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報をセットする。

パラメータ:
key - データのキー
value - データ
戻り値:
成功 true/失敗 false

set

public Boolean set(String key,
                   String value)
推奨されていません。 代替えメソッドはありません。

ログイングループ付随情報をセットする。

パラメータ:
key - データのキー
value - データ
戻り値:
成功 true/失敗 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.acssecurity (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.acssecurity
クラス
AccountManager
AcsData
Logingp
RoleManager
例外
AcssecurityException


jp.co.intra_mart.foundation.acssecurity (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.acssecurity

アクセスセキュリティモジュールを利用するためのクラスを提供します。

参照:
説明

クラスの概要
AccountManager | 推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
AcsData | 推奨されていません。
Logingp | 推奨されていません。
RoleManager | 推奨されていません。

例外の概要
AcssecurityException アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

パッケージ jp.co.intra_mart.foundation.acssecurity の説明

アクセスセキュリティモジュールを利用するためのクラスを提供します。 このパッケージのクラスを利用することで、アクセスセキュリティ機能の持つ 以下の情報に対してアクセスすることができます。

  • アカウント
  • ログイングループ
  • ロール
  • メニュー
  • メッセージ
  • バッチ
  • リンク

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.acssecurity クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.acssecurity の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.acssecurity.AccountManager
    • class jp.co.intra_mart.foundation.acssecurity.AcsData
    • class jp.co.intra_mart.foundation.acssecurity.Logingp
    • class jp.co.intra_mart.foundation.acssecurity.RoleManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.acssecurity.AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.acssecurity の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.acssecurity の使用

jp.co.intra_mart.foundation.acssecurity を使用しているパッケージ
jp.co.intra_mart.foundation.acssecurity アクセスセキュリティモジュールを利用するためのクラスを提供します。

jp.co.intra_mart.foundation.acssecurity により使用される jp.co.intra_mart.foundation.acssecurity のクラス
AcssecurityException
アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RoleManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.acssecurity
クラス RoleManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.acssecurity.RoleManager

public class RoleManager
extends Object

ロール情報を操作します。

コンストラクタの概要
RoleManager(String login_grp)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
メソッドの概要
 boolean contains(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
 int count()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
 void delData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 void delData(String roleId, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
 Map getData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
 String getIdByName(String roleName)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
 Vector getIDs()
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
 String[] getListData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
 String[] getParentData(String roleId)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
 void setData(Map datas)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
 void setData(Map datas, boolean isTransaction)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleManager

public RoleManager(String login_grp)
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。

コンストラクタ

パラメータ:
login_grp - ログイングループID
メソッドの詳細

setData

public void setData(Map datas)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。

ロールデータを登録する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
datas - ロールデータ

例外:
AcssecurityException -

引数 datas(Map)の内容
(key == value)
id      = ロールID(String)[必須]
         name    = ロール名(String)[必須]
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)

        引数に指定したロールIDが既に存在していた場合、上書きする。

setData

public void setData(Map datas,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。

ロールデータを登録する

パラメータ:
datas - ロールデータ

isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException -

引数 datas(Map)の内容
(key == value)
id      = ロールID(String)[必須]
         name    = ロール名(String)[必須]
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)

        引数に指定したロールIDが既に存在していた場合、上書きする。

contains

public boolean contains(String roleId)
                 throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。

ロールデータの存在チェック

パラメータ:
roleId - ロールID
戻り値:
ある true / ない false
例外:
AcssecurityException

count

public int count()
          throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。

ロールデータの登録数を取得

戻り値:
登録ロール数
例外:
AcssecurityException

getIDs

public Vector getIDs()
              throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。

ロールIDをすべて取得する

戻り値:
ロールIDの配列(データがない場合は空の配列)
例外:
AcssecurityException

getData

public Map getData(String roleId)
            throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。

ロールデータの取得

パラメータ:
roleId - ロールID
戻り値:
ユーザ情報（ユーザ情報がなければnull）

戻り値 (Map)の内容
(key == value)
id      = ロールID(String)
         name    = ロール名(String)
         explan  = 説明(String)
         detail  = 詳細(String)
         roles   = ロールIDの配列(String[])
         search_key = 検索キー(String)
例外:
AcssecurityException

delData

public void delData(String roleId)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。

ロールデータを削除する

DBを使用する場合,このメソッドは内部でDBトランザクションを発行します。 このメソッドをDBトランザクション内で使用しないで下さい。

パラメータ:
roleId - ロールID
例外:
AcssecurityException

delData

public void delData(String roleId,
                    boolean isTransaction)
             throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。

ロールデータを削除する

パラメータ:
roleId - ロールID
isTransaction - DBトランザクションフラグ（true このメソッドの中でDBトランザクションを張る。／false このメソッドの中でDBトランザクションを張らない。）

例外:
AcssecurityException

getIdByName

public String getIdByName(String roleName)
                   throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。

ロール名からロールIDを取得する

パラメータ:
roleName - ロール名
戻り値:
ロールID(データがない場合はnull)
２つ以上あった場合は先に見つかったほうを返す。
例外:
AcssecurityException

getListData

public String[] getListData(String roleId)
                     throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。

サブロールデータの取得(子ロールも含めたロールデータをすべて取得する)

パラメータ:
roleId - ロールID
戻り値:
ロールID配列
例外:
AcssecurityException

getParentData

public String[] getParentData(String roleId)
                       throws AcssecurityException
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。

直接の親（一階層上）ロールIDを取得する

パラメータ:
roleId - ロールID
戻り値:
ロールID配列
例外:
AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.appcomn.AppcomnException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.appcomn.AppcomnException の使用

AppcomnException を使用しているパッケージ
jp.co.intra_mart.foundation.appcomn アプリケーション共通モジュール。

jp.co.intra_mart.foundation.appcomn での AppcomnException の使用

AppcomnException をスローする jp.co.intra_mart.foundation.appcomn のメソッド
 void Profile.addProfile(Map data)
推奨されていません。 UserManager.addUser(User user) に置き換えられました。
 void Profile.updateProfile(Map data)
推奨されていません。 UserManager.updateUser(User user) に置き換えられました。
 void Profile.deleteProfile(String userCode)
推奨されていません。 UserManager.deleteUser(User user) に置き換えられました。
 void Grouping.insertData(Map datas)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.insertData(Map datas, String[] jsTriggers)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.updateData(Map datas)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.updateData(Map datas, String[] jsTriggers)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.deleteData(String grouping_cd)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.deleteData(String grouping_cd, String[] jsTriggers)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.setAttachInfo(Map setParam)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.delAttachInfo(Map delParam)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.insertPostData(Map datas)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.updatePostData(Map datas)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Grouping.deletePostData(String grouping_cd, String post_cd)
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
 void Category.addCategoryDetail(Map data)
推奨されていません。 CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
 void Category.updateCategoryDetail(Map data)
推奨されていません。 CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
 void Category.deleteCategoryDetail(String categoryClassCode, String categoryCode)
推奨されていません。 CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.appcomn.Category の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.appcomn.Category の使用

jp.co.intra_mart.foundation.appcomn.Category はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.appcomn.Grouping の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.appcomn.Grouping の使用

jp.co.intra_mart.foundation.appcomn.Grouping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.appcomn.Profile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.appcomn.Profile の使用

jp.co.intra_mart.foundation.appcomn.Profile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AppcomnException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.appcomn
クラス AppcomnException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.appcomn.AppcomnException
すべての実装インタフェース:
Serializable
public class AppcomnException
extends Exception

アプリケーション共通マスタの情報操作時にエラーが発生した場合にスローされます。

関連項目:
直列化された形式

メソッドの概要
int | getCode() 推奨されていません。
String | getMessage() 推奨されていません。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

メソッドの詳細

getMessage

public String getMessage()
推奨されていません。

getCode

public int getCode()
推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Category (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.appcomn
クラス Category

java.lang.Object
    拡張 jp.co.intra_mart.foundation.appcomn.Category

public class Category
extends Object

互換モードでアプリケーション共通マスタの分類マスタの更新を行います。

導入されたバージョン:
5.0

コンストラクタの概要
Category(String loginGroup)
推奨されていません。 コンストラクタ
メソッドの概要
 void addCategoryDetail(Map data)
推奨されていません。 CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
 void deleteCategoryDetail(String categoryClassCode, String categoryCode)
推奨されていません。 CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
 void updateCategoryDetail(Map data)
推奨されていません。 CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Category

public Category(String loginGroup)
推奨されていません。
コンストラクタ

パラメータ:
loginGroup - ログイングループID
メソッドの詳細

addCategoryDetail

public void addCategoryDetail(Map data)
                       throws AppcomnException
推奨されていません。 CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。

分類情報を追加します。
このメソッドは内部でDBトランザクションを発行しています。

パラメータ:
data - 登録データ

引数 data(Map)の内容
(key == value)
category_cls_cd = 分類区分コード (String)[必須]
category_cd = 分類コード (String)[必須]
category_name = 分類名 (String)[必須]
notes = 備考 (String)
例外:
AppcomnException

updateCategoryDetail

public void updateCategoryDetail(Map data)
                          throws AppcomnException
推奨されていません。 CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。

分類情報を更新します。
このメソッドは内部でDBトランザクションを発行しています。

パラメータ:
data - 更新データ

引数 data(Map)の内容
(key == value)
category_cls_cd = 分類区分コード (String)[必須]
category_cd = 分類コード (String)[必須]
category_name = 分類名 (String)[必須]
notes = 備考 (String)
例外:
AppcomnException

deleteCategoryDetail

public void deleteCategoryDetail(String categoryClassCode,
                                 String categoryCode)
                          throws AppcomnException
推奨されていません。 CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。

分類情報を削除します。
このメソッドは内部でDBトランザクションを発行しています。

パラメータ:
categoryClassCode - カテゴリ区分コード
categoryCode - カテゴリコード
例外:
AppcomnException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Grouping (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.appcomn
クラス Grouping

java.lang.Object
    拡張 jp.co.intra_mart.foundation.appcomn.Grouping

public class Grouping
extends Object

アプリケーション共通マスタの組織情報(グルーピング情報)を操作します。

コンストラクタの概要
Grouping(String login_grp)
推奨されていません。 グルーピング情報操作オブジェクトの作成。
メソッドの概要
void | delAttachInfo(Map delParam) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | deleteData(String grouping_cd) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | deleteData(String grouping_cd, String[] jsTriggers) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | deletePostData(String grouping_cd, String post_cd) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
List | getStruct(String grouping_cd) 推奨されていません。 CompnanyManager,PublicGroupManagerの各メソッドに置き換えられました。
void | insertData(Map datas) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | insertData(Map datas, String[] jsTriggers) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | insertPostData(Map datas) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | setAttachInfo(Map setParam) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | updateData(Map datas) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | updateData(Map datas, String[] jsTriggers) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
void | updatePostData(Map datas) 推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Grouping

public Grouping(String login_grp)
推奨されていません。
グルーピング情報操作オブジェクトの作成。

パラメータ:
login_grp - ログイングループID
メソッドの詳細

insertData

public void insertData(Map datas)
                throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

グルーピングデータを登録する。

このメソッドの中でDBトランザクションを張ります。

パラメータ:
datas - 登録データ

引数 datas(Map)の内容
(key == value)
grouping_cd = グルーピング(String)[必須]
grouping_cls_cd = グルーピング種別CD(String)[必須]
//プライベートG（"private"）、オフィシャルG（"official"）、
//会社（"comp"）、組織（"orgn"）
grouping_type = グルーピングタイプ(String) 互換されていません
grouping_name = グルーピング名(String)[必須]
parent_grouping_cd = 親グルーピングCD(String)
//グルーピング種別CD(grouping_cls_cd)を会社("comp")にした場合は指定できません。
grouping_name_kana = グルーピング名カナ(String)
grouping_name_eng = グルーピング名英字(String)
telephone_number = 電話番号(String)
fax_number = FAX番号(String)
extension_number = 内線番号(String)
extension_fax_number = 内線FAX番号(String)
country_cd = 国コード(String)
zip_code = 郵便番号(String)
address = 住所(String)
address2 = 住所２(String)
email_address1 = メールアドレス1(String)
email_address2 = メールアドレス2(String)
url = URL(String)
notes = 備考(String)
sort_key = ソート番号(Number)
owner_cd = 所有者CD(String)
//プライベートGのみ必須
zone = 公開ゾーンCD(Array)
attribute = 検索属性CD(Array)
channel = 販売チャネル(Array)
calc_type_flag = 税率計算方法(String、文字で０～２を指定) 互換されていません
//以下、BM以外のパッケージ（スタートパックなど）が使用するキー（予約項目）
reserve01 互換されていません
reserve02 互換されていません
reserve03 互換されていません
reserve04 互換されていません
reserve05 互換されていません
reserve06 互換されていません
reserve07 互換されていません
reserve08 互換されていません
reserve09 互換されていません
reserve10 互換されていません
reserve11 互換されていません
reserve12 互換されていません
reserve13 互換されていません
reserve14 互換されていません
reserve15 互換されていません
例外:
AppcomnExceptin - グルーピングの登録に失敗した場合
AppcomnException

insertData

public void insertData(Map datas,
                       String[] jsTriggers)
                throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

グルーピングデータを登録する。

このメソッドの中でDBトランザクションを張ります。

パラメータ:
datas - 登録データ
jsTriggers - JavaScriptトリガー
引数 datas(Map)の内容
(key == value)
grouping_cd = グルーピング(String)[必須]
grouping_cls_cd = グルーピング種別CD(String)[必須]
//プライベートG（"private"）、オフィシャルG（"official"）、
//会社（"comp"）、組織（"orgn"）
grouping_type = グルーピングタイプ(String) 互換されていません
grouping_name = グルーピング名(String)[必須]
parent_grouping_cd = 親グルーピングCD(String)
//グルーピング種別CD(grouping_cls_cd)を会社("comp")にした場合は指定できません。
grouping_name_kana = グルーピング名カナ(String)
grouping_name_eng = グルーピング名英字(String)
telephone_number = 電話番号(String)
fax_number = FAX番号(String)
extension_number = 内線番号(String)
extension_fax_number = 内線FAX番号(String)
country_cd = 国コード(String)
zip_code = 郵便番号(String)
address = 住所(String)
address2 = 住所２(String)
email_address1 = メールアドレス1(String)
email_address2 = メールアドレス2(String)
url = URL(String)
notes = 備考(String)
sort_key = ソート番号(Number)
owner_cd = 所有者CD(String)
//プライベートGのみ必須
zone = 公開ゾーンCD(Array)
attribute = 検索属性CD(Array)
channel = 販売チャネル(Array)
calc_type_flag = 税率計算方法(String、文字で０～２を指定) 互換されていません
//以下、BM以外のパッケージ（スタートパックなど）が使用するキー（予約項目）
reserve01 互換されていません
reserve02 互換されていません
reserve03 互換されていません
reserve04 互換されていません
reserve05 互換されていません
reserve06 互換されていません
reserve07 互換されていません
reserve08 互換されていません
reserve09 互換されていません
reserve10 互換されていません
reserve11 互換されていません
reserve12 互換されていません
reserve13 互換されていません
reserve14 互換されていません
reserve15 互換されていません
例外:
AppcomnExceptin - グルーピングの登録に失敗した場合
AppcomnException

updateData

public void updateData(Map datas)
                throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

グルーピングデータを更新する。

このメソッドの中でDBトランザクションを張ります。

パラメータ:
datas - 更新データ

引数 datas(Map)の内容
(key == value)
grouping_cd = グルーピング(String)[必須]
grouping_cls_cd = グルーピング種別CD(String)[必須]
//プライベートG（"private"）、オフィシャルG（"official"）、
//会社（"comp"）、組織（"orgn"）
grouping_type = グルーピングタイプ(String) 互換されていません
grouping_name = グルーピング名(String)[必須]
parent_grouping_cd = 親グルーピングCD(String)
//グルーピング種別CD(grouping_cls_cd)を会社("comp")にした場合は指定できません。
grouping_name_kana = グルーピング名カナ(String)
grouping_name_eng = グルーピング名英字(String)
telephone_number = 電話番号(String)
fax_number = FAX番号(String)
extension_number = 内線番号(String)
extension_fax_number = 内線FAX番号(String)
country_cd = 国コード(String)
zip_code = 郵便番号(String)
address = 住所(String)
address2 = 住所２(String)
email_address1 = メールアドレス1(String)
email_address2 = メールアドレス2(String)
url = URL(String)
notes = 備考(String)
sort_key = ソート番号(Number)
owner_cd = 所有者CD(String)
//プライベートGのみ必須
zone = 公開ゾーンCD(Array)
attribute = 検索属性CD(Array)
channel = 販売チャネル(Array)
calc_type_flag = 税率計算方法(String、文字で０～２を指定) 互換されていません
//以下、BM以外のパッケージ（スタートパックなど）が使用するキー（予約項目）
reserve01 互換されていません
reserve02 互換されていません
reserve03 互換されていません
reserve04 互換されていません
reserve05 互換されていません
reserve06 互換されていません
reserve07 互換されていません
reserve08 互換されていません
reserve09 互換されていません
reserve10 互換されていません
reserve11 互換されていません
reserve12 互換されていません
reserve13 互換されていません
reserve14 互換されていません
reserve15 互換されていません
例外:
AppcomnExceptin - グルーピングの更新に失敗した場合
AppcomnException

updateData

public void updateData(Map datas,
                       String[] jsTriggers)
                throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

グルーピングデータを更新する。

このメソッドの中でDBトランザクションを張ります。

パラメータ:
datas - 更新データ
jsTriggers - JavaScriptトリガー

引数 datas(Map)の内容
(key == value)
grouping_cd = グルーピング(String)[必須]
grouping_cls_cd = グルーピング種別CD(String)[必須]
//プライベートG（"private"）、オフィシャルG（"official"）、
//会社（"comp"）、組織（"orgn"）
grouping_type = グルーピングタイプ(String) 互換されていません
grouping_name = グルーピング名(String)[必須]
parent_grouping_cd = 親グルーピングCD(String)
//グルーピング種別CD(grouping_cls_cd)を会社("comp")にした場合は指定できません。
grouping_name_kana = グルーピング名カナ(String)
grouping_name_eng = グルーピング名英字(String)
telephone_number = 電話番号(String)
fax_number = FAX番号(String)
extension_number = 内線番号(String)
extension_fax_number = 内線FAX番号(String)
country_cd = 国コード(String)
zip_code = 郵便番号(String)
address = 住所(String)
address2 = 住所２(String)
email_address1 = メールアドレス1(String)
email_address2 = メールアドレス2(String)
url = URL(String)
notes = 備考(String)
sort_key = ソート番号(Number)
owner_cd = 所有者CD(String)
//プライベートGのみ必須
zone = 公開ゾーンCD(Array)
attribute = 検索属性CD(Array)
channel = 販売チャネル(Array)
calc_type_flag = 税率計算方法(String、文字で０～２を指定) 互換されていません
//以下、BM以外のパッケージ（スタートパックなど）が使用するキー（予約項目）
reserve01 互換されていません
reserve02 互換されていません
reserve03 互換されていません
reserve04 互換されていません
reserve05 互換されていません
reserve06 互換されていません
reserve07 互換されていません
reserve08 互換されていません
reserve09 互換されていません
reserve10 互換されていません
reserve11 互換されていません
reserve12 互換されていません
reserve13 互換されていません
reserve14 互換されていません
reserve15 互換されていません
例外:
AppcomnExceptin - グルーピングの更新に失敗した場合
AppcomnException

deleteData

public void deleteData(String grouping_cd)
                throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

グルーピングデータを削除する。

このメソッドの中でDBトランザクションを張ります。

パラメータ:
grouping_cd - グルーピングCD

例外:
AppcomnException

deleteData

public void deleteData(String grouping_cd,
                       String[] jsTriggers)
                throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

グルーピングデータを削除する。

このメソッドの中でDBトランザクションを張ります。

パラメータ:
grouping_cd - グルーピングCD
jsTriggers - JavaScriptトリガー

例外:
AppcomnException

setAttachInfo

public void setAttachInfo(Map setParam)
                   throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

所属情報を登録する。

既に存在するレコードは更新します。 このメソッドの中でDBトランザクションを張ります。

パラメータ:
setParam - 削除パラメータ
引数 datas(Map)の内容

 (key == value)

 user_cd = ユーザコード(String)

 grouping_cd = グルーピング(String)

 main_flag = 主所属フラグ(Number)(副所属とする 0/主所属とする 1
 主所属を指定できるのはグルーピングコードが会社・組織のときのみ。)

 post_cd = 役職コード(String)(グルーピングコードが会社・組織のときのみ)

 sort_key = ソート番号(Number)(グルーピングコードがプライベートグループのときのみ)
例外:
AppcomnExceptin - 所属情報の登録に失敗した場合
AppcomnException

delAttachInfo

public void delAttachInfo(Map delParam)
                   throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

所属情報を削除する。

引数に該当する所属情報レコードを削除。 引数を一つも指定しない場合はエラーとする。 このメソッドの中でDBトランザクションを張ります。

パラメータ:
delParam - 削除パラメータ
引数 datas(Map)の内容

 (key == value)

 user_cd = ユーザコード(String)[任意]

 grouping_cd = グルーピング(String)[任意]

 main_flag = 主所属フラグ(Number 副所属 0/主所属 1)[任意]

 post_cd = 役職コード(String)[任意]

 sort_key = ソート番号(Number)[任意]
例外:
AppcomnExceptin - 所属の削除に失敗した場合
AppcomnException

getStruct

public List getStruct(String grouping_cd)
推奨されていません。 CompnanyManager,PublicGroupManagerの各メソッドに置き換えられました。

第一引数グループの階層構造を取得する。

パラメータ:
grouping_cd - グルーピングコード
戻り値:
組織情報Object配列 (上位階層から順番に入る)
戻り値の要素(Map)の内容

 (key == value)

 cd = グルーピングコード(String)

 name = グルーピング名(String)

 エラー時 null

insertPostData

public void insertPostData(Map datas)
                    throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

役職データの登録を行う。

パラメータ:
datas - 役職データ

引数datasの内容
(key == value)
grouping_cd = グルーピング(String)[必須]
post_cd = 役職コード(String)[必須]
post_name = 役職名(String)[必須]
sort_key = ソート番号(Number)
notes = 備考(String)
例外:
AppcomnException - 役職の登録に失敗した場合

updatePostData

public void updatePostData(Map datas)
                    throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

役職データの更新を行う。

パラメータ:
datas - 役職データ

引数 datasの内容
(key == value)
grouping_cd = グルーピング(String)[必須]
post_cd = 役職コード(String)[必須]
post_name = 役職名(String)[必須]
sort_key = ソート番号(Number)
notes = 備考(String)
例外:
AppcomnException - 役職の更新に失敗した場合

deletePostData

public void deletePostData(String grouping_cd,
                           String post_cd)
                    throws AppcomnException
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。

役職データの削除を行う。

パラメータ:
grouping_cd - グルーピングコード
post_cd - 役職コード
例外:
AppcomnException - 役職の削除に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.appcomn (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.appcomn
クラス
Category
Grouping
Profile
例外
AppcomnException


jp.co.intra_mart.foundation.appcomn (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.appcomn

アプリケーション共通モジュール。

参照:
説明

クラスの概要
Category | 推奨されていません。
Grouping | 推奨されていません。
Profile | 推奨されていません。

例外の概要
AppcomnException アプリケーション共通マスタの情報操作時にエラーが発生した場合にスローされます。

パッケージ jp.co.intra_mart.foundation.appcomn の説明

アプリケーション共通モジュール。 組織情報などアプリケーション共通情報操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.appcomn クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.appcomn の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.appcomn.Category
    • class jp.co.intra_mart.foundation.appcomn.Grouping
    • class jp.co.intra_mart.foundation.appcomn.Profile
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.appcomn.AppcomnException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.appcomn の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.appcomn の使用

jp.co.intra_mart.foundation.appcomn を使用しているパッケージ
jp.co.intra_mart.foundation.appcomn アプリケーション共通モジュール。

jp.co.intra_mart.foundation.appcomn により使用される jp.co.intra_mart.foundation.appcomn のクラス
AppcomnException
アプリケーション共通マスタの情報操作時にエラーが発生した場合にスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Profile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.appcomn
クラス Profile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.appcomn.Profile

public class Profile
extends Object

互換モードでアプリケーション共通マスタのユーザマスタの更新を行います。

導入されたバージョン:
5.0

コンストラクタの概要
Profile(String loginGroup)
推奨されていません。 コンストラクタ
メソッドの概要
void | addProfile(Map data) 推奨されていません。 UserManager.addUser(User user) に置き換えられました。
void | deleteProfile(String userCode) 推奨されていません。 UserManager.deleteUser(User user) に置き換えられました。
void | updateProfile(Map data) 推奨されていません。 UserManager.updateUser(User user) に置き換えられました。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Profile

public Profile(String loginGroup)
推奨されていません。
コンストラクタ

パラメータ:
loginGroup - ログイングループID
メソッドの詳細

addProfile

public void addProfile(Map data)
                throws AppcomnException
推奨されていません。 UserManager.addUser(User user) に置き換えられました。

プロファイル情報を新規登録します。
このメソッドは内部でDBトランザクションを発行しています。

パラメータ:
data - 登録データ
例外:
AppcomnException - プロファイルの登録に失敗した場合

引数 data(Map)の内容
(key == value)

user_cd = ユーザコード (String)[必須]
user_name = ユーザ名 (String)[必須]
user_name_kana = ユーザ名カナ (String)
user_name_eng = ユーザ名英字 (String)
telephone_number = 電話番号 (String)
mobile_number = 携帯電話番号 (String)
fax_number = FAX番号 (String)
extension_number = 内線番号 (String)
extension_fax_number = 内線FAX番号 (String)
country_cd = 国コード (String)
zip_code = 郵便番号 (String)
address = 住所 (String)
email_address1 = メールアドレス１ (String)
email_address2 = メールアドレス２ (String)
mobile_email_address = 携帯用メール (String)
url = URL (String)
notes = 備考 (String)
user_name_kana = ソートキー (Number) 省略された場合は0が設定されます。

updateProfile

public void updateProfile(Map data)
                   throws AppcomnException
推奨されていません。 UserManager.updateUser(User user) に置き換えられました。

プロファイル情報を更新します。
更新データに設定されない項目には、null が設定されます。
このメソッドは内部でDBトランザクションを発行しています。

パラメータ:
data - 更新データ
例外:
AppcomnException - プロファイルの更新に失敗した場合

引数 data(Map)の内容
(key == value)

user_cd = ユーザコード (String)[必須]
user_name = ユーザ名 (String)[必須]
user_name_kana = ユーザ名カナ (String)
user_name_eng = ユーザ名英字 (String)
telephone_number = 電話番号 (String)
mobile_number = 携帯電話番号 (String)
fax_number = FAX番号 (String)
extension_number = 内線番号 (String)
extension_fax_number = 内線FAX番号 (String)
country_cd = 国コード (String)
zip_code = 郵便番号 (String)
address = 住所 (String)
email_address1 = メールアドレス１ (String)
email_address2 = メールアドレス２ (String)
mobile_email_address = 携帯用メール (String)
url = URL (String)
notes = 備考 (String)
user_name_kana = ソートキー (Number) 省略された場合は0が設定されます。

deleteProfile

public void deleteProfile(String userCode)
                   throws AppcomnException
推奨されていません。 UserManager.deleteUser(User user) に置き換えられました。

プロファイル情報を削除します。
削除の対象となるユーザ情報が存在しない場合は何もしません。
このメソッドは内部でDBトランザクションを発行しています。

パラメータ:
userCode - ユーザコード
例外:
AppcomnException - プロファイルの削除に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.commons.validation.InputCheck の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.commons.validation.InputCheck の使用

jp.co.intra_mart.foundation.commons.validation.InputCheck はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


InputCheck (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.commons.validation
クラス InputCheck

java.lang.Object
    拡張 jp.co.intra_mart.foundation.commons.validation.InputCheck
public class InputCheck
extends Object

入力チェック関数ライブラリ

導入されたバージョン:
4.2

コンストラクタの概要
InputCheck()
メソッドの概要
static int | checkDigitOfNumber(Number value, Integer integerDigit, Integer floatDigit) 数値の整数部、小数部の桁数チェック（引数がクラス版）。
static int | checkDigitOfNumber(Number value, int integerDigit, int floatDigit) 数値の整数部、小数部の桁数チェック。
static int | checkDigitOfNumberString(String value, Integer integerDigit, Integer floatDigit) 数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）
static int | checkDigitOfNumberString(String value, int integerDigit, int floatDigit) 数値（文字型）の整数部、小数部の桁数チェック ※数値かどうかのチェックも行う。
static boolean | isDateString(String dateString) 日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。
static boolean | isDateTimeString(String dateTimeString) 日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。
static boolean | isDateTimeString(String dateTimeString, SimpleDateFormat df) 日時文字列が指定フォーマットにそっているかどうかをチェックする。
static boolean | isEMailAddress(String str) 入力文字列がメールアドレスの形式をとっているかのチェック。
static boolean | isEmpty(Number value) 数値のNULLチェック。
static boolean | isEmpty(String str) 渡された文字列が、空文字列かまたはNULLかチェック。
static boolean | isExistString(String[] strAry, String str) 配列内に指定した文字列が含まれているかどうかをチェックする。
static boolean | isInput(Number column) カラムの空値チェック。
static boolean | isInput(String column) カラムの空値チェック。
static boolean | isKatakanaString(String str) 文字列が半角カナ文字列かチェックする。
static boolean | isKessaiDateString(String kessaiDateString) 決済年月日(YYYYMMDD)として有効かをチェックする。
static boolean | isLenEqual(Number column, int length) カラムの入力桁数チェック。
static boolean | isLenEqual(Number column, Integer length) カラムの入力桁数チェック（引数がクラス版）。
static boolean | isLenEqual(String column, int byteLength) カラムの入力バイト数チェック。
static boolean | isLenEqual(String column, Integer byteLength) カラムの入力バイト数チェック（引数がクラス版）。
static boolean | isLenLessThan(Number column, int length) カラムの桁数が指定桁数より小さいか(等号を含まない)。
static boolean | isLenLessThan(Number column, Integer length) カラムの桁数が指定桁数より小さいか(等号を含まない)（引数がクラス版）。
static boolean | isLenLessThan(String column, int byteLength) カラムのバイト数が指定バイト数より小さいか(等号を含まない)。
static boolean | isLenLessThan(String column, Integer byteLength) カラムのバイト数が指定バイト数より小さいか(等号を含まない)（引数がクラス版）。
static boolean | isLenMoreThan(Number column, int length) カラムの桁数が指定桁数より大きいか(等号を含まない)。
static boolean | isLenMoreThan(Number column, Integer length) カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。
static boolean | isLenMoreThan(String column, int byteLength) カラムのバイト数が指定バイト数より大きいか(等号を含まない)。
static boolean | isLenMoreThan(String column, Integer byteLength) カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。
static boolean | isNengetsuString(String nengetsuString) 年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。
static boolean | isNotNull(Object obj) not nullチェック not nullのとき true nullのとき false
static boolean | isNumberString(String value) 文字列が数値かどうかをチェックする。
static boolean | isNumeralRange(String column, Number min, Number max) 指定した数値カラムが指定した数値の範囲なのかチェック 範囲最大値、または最小値と同じ値は範囲内に含まれる。
static boolean | isShimebiString(String shimebiString) 締め日(YYYYMMDD)として有効かをチェックする。
static boolean | isValidDate(String year, String month, String day) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
static boolean | isValueEqual(Number column1, Number column2) カラム１の値とカラム２の値が同一かのチェック。
static boolean | isValueEqual(String column1, String column2) カラム１の値とカラム２の値が同一かのチェック。
static boolean | isValueLessThan(Number column1, Number column2) カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
static boolean | isValueLessThan(String column1, String column2) カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
static boolean | isValueMoreThan(Number column1, Number column2) カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
static boolean | isValueMoreThan(String column1, String column2) カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
static boolean | isWeekDate(String dateColumn, int dateFlag) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
static boolean | isWeekDate(String dateColumn, Integer dateFlag) 推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InputCheck

public InputCheck()
メソッドの詳細

isInput

public static boolean isInput(String column)
カラムの空値チェック。

nullのとき空値
空文字列のときは空値
値が入っているときは空値ではありません
（参照）isEmpty(java.lang.String)

パラメータ:
column - カラム入力文字列
戻り値:
true:空値ではない false:空値

isInput

public static boolean isInput(Number column)
カラムの空値チェック。

nullのとき空値
0のときは空値ではない
NaN,無限大が入っているときは空値ではありません
値が入っているときは空値ではありません
（参照）isEmpty(java.lang.Number)

パラメータ:
column - カラム入力数値
戻り値:
true:空値ではない false:空値

isLenEqual

public static boolean isLenEqual(String column,
                                 int byteLength)
カラムの入力バイト数チェック。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が一致 false:バイト数が一致しない

isLenEqual

public static boolean isLenEqual(String column,
                                 Integer byteLength)
カラムの入力バイト数チェック（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が一致 false:バイト数が一致しない

isLenEqual

public static boolean isLenEqual(Number column,
                                 int length)
カラムの入力桁数チェック。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が一致 false:桁数が一致しない

isLenEqual

public static boolean isLenEqual(Number column,
                                 Integer length)
カラムの入力桁数チェック（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が一致 false:桁数が一致しない

isLenLessThan

public static boolean isLenLessThan(String column,
                                    int byteLength)
カラムのバイト数が指定バイト数より小さいか(等号を含まない)。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより短い false:バイト数が指定のものと同じか長い

isLenLessThan

public static boolean isLenLessThan(String column,
                                    Integer byteLength)
カラムのバイト数が指定バイト数より小さいか(等号を含まない)（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより短い false:バイト数が指定のものと同じか長い

isLenLessThan

public static boolean isLenLessThan(Number column,
                                    int length)
カラムの桁数が指定桁数より小さいか(等号を含まない)。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより短い false:桁数が指定のものと同じか長い

isLenLessThan

public static boolean isLenLessThan(Number column,
                                    Integer length)
カラムの桁数が指定桁数より小さいか(等号を含まない)（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより短い false:桁数が指定のものと同じか長い

isLenMoreThan

public static boolean isLenMoreThan(String column,
                                    int byteLength)
カラムのバイト数が指定バイト数より大きいか(等号を含まない)。

カラムがnullまたは空文字列のときは常にFalseを返す
0バイト指定はFalseを返す

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより長い false:バイト数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(String column,
                                    Integer byteLength)
カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。

パラメータ:
column - カラム入力文字列
byteLength - カラムのバイト数
戻り値:
true:バイト数が指定のものより長い false:バイト数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(Number column,
                                    int length)
カラムの桁数が指定桁数より大きいか(等号を含まない)。

カラムがnullのときは常にFalseを返す
カラムに入力された数値を文字列に変換して桁数を比較する
NaN、無限大などの問題は考慮していません
0桁指定はfalseを返す

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより長い false:桁数が指定のものと同じか短い

isLenMoreThan

public static boolean isLenMoreThan(Number column,
                                    Integer length)
カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。

パラメータ:
column - カラム入力数値
length - 桁数
戻り値:
true:桁数が指定のものより長い false:桁数が指定のものと同じか短い

isValueEqual

public static boolean isValueEqual(String column1,
                                   String column2)
カラム１の値とカラム２の値が同一かのチェック。

大文字、小文字および半角、全角の違う文字は違う文字として扱う
両方null値、または空文字列の場合はtrueを返す
一方がnull値、または空文字列でもう一方が一般の文字列の場合はfalseを返す
nullと空値を比較した場合はtrueを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:同一文字列 false:異なる文字列

isValueEqual

public static boolean isValueEqual(Number column1,
                                   Number column2)
カラム１の値とカラム２の値が同一かのチェック。

型が違うものが渡された場合はfalseを返す
両方null値の場合はtrueを返す
一方がnull値の場合はfalseを返す

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:同一値 false:異なる値

isValueLessThan

public static boolean isValueLessThan(String column1,
                                      String column2)
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。

半角、全角などが混ざってもUnicode順で判断する
一方がnull値、または空文字列の場合は無条件でfalseを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:カラム１の値がカラム２の値よりも小さい
false:カラム１の値がカラム２の値よりも大きい、または同一値

isValueLessThan

public static boolean isValueLessThan(Number column1,
                                      Number column2)
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。

型が違うものが渡された場合はfalseを返す
どちらか一方でもnull値だった場合はfalseを返す
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:カラム１の値がカラム２の値よりも小さい
false:カラム１の値がカラム２の値よりも大きい、または同一値

isValueMoreThan

public static boolean isValueMoreThan(String column1,
                                      String column2)
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。

半角、全角などが混ざってもUnicode順で判断する
一方がnull値、または空文字列の場合は無条件でfalseを返す

パラメータ:
column1 - 対象文字列１
column2 - 対象文字列２
戻り値:
true:カラム１の値がカラム２の値よりも大きい
false:カラム１の値がカラム２の値より小さい、または同一値

isValueMoreThan

public static boolean isValueMoreThan(Number column1,
                                      Number column2)
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。

型が違うものが渡された場合はfalseを返す
どちらか一方でもnull値だった場合はfalseを返す
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column1 - 対象値１
column2 - 対象値２
戻り値:
true:カラム１の値がカラム２の値よりも大きい
false:カラム１の値がカラム２の値よりも小さい、または同一値

isValidDate

public static boolean isValidDate(String year,
                                  String month,
                                  String day)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが有効な範囲なのかチェック

パラメータ:
year - 年
month - 月
day - 日
戻り値:
true:正当な日付 false:不正な日付

isWeekDate

public static boolean isWeekDate(String dateColumn,
                                 int dateFlag)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが銀行営業日なのかチェック。

パラメータ:
dateColumn - 日付文字列
dateFlag - 判定する日付のタイプを示すフラグ 0:営業日判定 1:休日判定
戻り値:
判定条件を満たせばtrue,条件に合わなかったらfalse

isWeekDate

public static boolean isWeekDate(String dateColumn,
                                 Integer dateFlag)
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。

日付カラムが銀行営業日なのかチェック（引数がクラス版）。

パラメータ:
dateColumn - 日付文字列
dateFlag - 判定する日付のタイプを示すフラグ 0:営業日判定 1:休日判定
戻り値:
判定条件を満たせばtrue,条件に合わなかったらfalse

isNumeralRange

public static boolean isNumeralRange(String column,
                                     Number min,
                                     Number max)
指定した数値カラムが指定した数値の範囲なのかチェック
範囲最大値、または最小値と同じ値は範囲内に含まれる。

数値カラムがnullまたは空文字列の場合はfalseを返す
範囲値の指定のどちらか一方がnullの場合はfalseを返す
範囲値の指定の型が異なる場合はfalseを返す
数値カラムの値を範囲指定のクラスの型に変更して判断を行う
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)

パラメータ:
column - 数値を示す文字列
min - 範囲最小値
max - 範囲最大値
戻り値:
true:範囲内 false:範囲外

checkDigitOfNumber

public static int checkDigitOfNumber(Number value,
                                     int integerDigit,
                                     int floatDigit)
数値の整数部、小数部の桁数チェック。

Double型の値は有効桁数１６桁
Float型の値は有効桁数７桁
(使用できる型を限定: Integer,Byte,Short,Long,Float,Double)
数値を文字列に変換してcheckDigitOfNumberStringを使用して判断する
（参照）checkDigitOfNumberString(java.lang.String, int, int)

パラメータ:
value - 数値
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された数値が不正 -2:渡された桁数情報が不正 -3:有効桁数を超えて桁数判断を行おうとしている -4:この関数では扱えない型

checkDigitOfNumber

public static int checkDigitOfNumber(Number value,
                                     Integer integerDigit,
                                     Integer floatDigit)
数値の整数部、小数部の桁数チェック（引数がクラス版）。

パラメータ:
value - 数値
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された数値が不正 -2:渡された桁数情報が不正 -3:有効桁数を超えて桁数判断を行おうとしている -4:この関数では扱えない型

checkDigitOfNumberString

public static int checkDigitOfNumberString(String value,
                                           int integerDigit,
                                           int floatDigit)
数値（文字型）の整数部、小数部の桁数チェック
※数値かどうかのチェックも行う。

扱える数値文字列は指数表現の入らないものだけとする
(例) 1234567890.0987654321は扱える
12345.67E89といった表現は扱えない
符号も１桁としてカウントする

パラメータ:
value - 数値文字列
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された文字列が数値ではない -2:渡された桁数情報が不正

checkDigitOfNumberString

public static int checkDigitOfNumberString(String value,
                                           Integer integerDigit,
                                           Integer floatDigit)
数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）

パラメータ:
value - 数値文字列
integerDigit - 整数部桁数
floatDigit - 小数部桁数
戻り値:
0:チェック成功 1:整数部桁数オーバー 2:小数部桁数オーバー 3:整数部、小数部ともに桁数オーバー -1:渡された文字列が数値ではない -2:渡された桁数情報が不正

isEmpty

public static boolean isEmpty(String str)
渡された文字列が、空文字列かまたはNULLかチェック。

nullのときtrue
空文字列のときtrue
値が入っているときはfalse
（参照）isInput(java.lang.String)

パラメータ:
str - 文字列
戻り値:
true:空文字列またはNULL false:空値

isEmpty

public static boolean isEmpty(Number value)
数値のNULLチェック。

nullのときtrueを返す
0のときはfalseを返す
NaN,無限大が入っているときはfalseを返す
値が入っているときはfalseを返す
（参照）isInput(java.lang.Number)

パラメータ:
value - 数値
戻り値:
true:null false:nullではない

isNumberString

public static boolean isNumberString(String value)
文字列が数値かどうかをチェックする。

パラメータ:
value - 数値文字列
戻り値:
true:数値文字列である false:数値文字列ではない

isDateString

public static boolean isDateString(String dateString)
日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。

パラメータ:
dateString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isShimebiString

public static boolean isShimebiString(String shimebiString)
締め日(YYYYMMDD)として有効かをチェックする。

（日付として有効かどうかだけをチェックする）

パラメータ:
shimebiString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isKessaiDateString

public static boolean isKessaiDateString(String kessaiDateString)
決済年月日(YYYYMMDD)として有効かをチェックする。

（営業日として有効かどうかだけをチェックする）

パラメータ:
kessaiDateString - 日付文字列
戻り値:
true:フォーマットに従っている false:従っていない

isNengetsuString

public static boolean isNengetsuString(String nengetsuString)
年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。

パラメータ:
nengetsuString - 年月指定文字列
戻り値:
true:フォーマットに従っている false:従っていない

isDateTimeString

public static boolean isDateTimeString(String dateTimeString)
日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。

パラメータ:
dateTimeString - 日時文字列
戻り値:
true:フォーマットに従っている false:従っていない

isDateTimeString

public static boolean isDateTimeString(String dateTimeString,
                                       SimpleDateFormat df)
日時文字列が指定フォーマットにそっているかどうかをチェックする。

パラメータ:
dateTimeString - 日時文字列
df - 指定フォーマット
戻り値:
true:フォーマットに従っている false:従っていない

isKatakanaString

public static boolean isKatakanaString(String str)
文字列が半角カナ文字列かチェックする。

半角カナ文字と半角スペースだけを許可する

パラメータ:
str - 半角カナ文字列
戻り値:
true:半角カナ文字だけで構成 false:違う種類の文字が含まれる

isExistString

public static boolean isExistString(String[] strAry,
                                    String str)
配列内に指定した文字列が含まれているかどうかをチェックする。

配列の要素のうち、どれか一つの要素が対象文字列を含むならばtrueを返す
対象文字列にnullか空文字列を指定された場合にはfalseを返す

パラメータ:
strAry - 文字列が含まれる配列
str - 対象文字列
戻り値:
true:対象文字列が含まれる false:対象文字列が含まれない

isEMailAddress

public static boolean isEMailAddress(String str)
入力文字列がメールアドレスの形式をとっているかのチェック。

（以下の形式の文字列をエラーとして判定します
☆@がない場合
☆.で始まるユーザ名・ドメイン名
☆.で終わるユーザ名・ドメイン名
☆ドメインに.が無い場合
☆ユーザ名の文字数が3文字未満の場合
☆ユーザ名に.が2文字以上含まれている場合
☆.を含んだドメイン名の文字数が4文字未満の場合
☆ユーザ名に含まれる文字に . _ - 以外の記号が入っている場合
☆ドメイン名に含まれる文字に . - 以外の記号が入っている場合
☆ドメインのピリオドが出現した後に続けてピリオドが出現する
☆最後の.の後、アルファベットが２文字未満しかない
（ＲＦＣ８２２で許可されている記号は!#$%&'*+-/=?^_`{|}~であるがより制限を厳しくする）

パラメータ:
str - メールアドレス
戻り値:
true:メールアドレス形式に合致 false:メールアドレス形式に適合しない

isNotNull

public static boolean isNotNull(Object obj)
not nullチェック not nullのとき true nullのとき false

パラメータ:
obj - チェック対象オブジェクト
戻り値:
true:null以外のとき false:nullのとき
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.commons.validation (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.commons.validation
クラス
InputCheck


jp.co.intra_mart.foundation.commons.validation (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons.validation

このパッケージは、入力チェック関数ライブラリを提供します。

参照:
説明

クラスの概要
InputCheck 入力チェック関数ライブラリ

パッケージ jp.co.intra_mart.foundation.commons.validation の説明

このパッケージは、入力チェック関数ライブラリを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.commons.validation クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.commons.validation の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.commons.validation.InputCheck
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.commons.validation の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.commons.validation の使用

jp.co.intra_mart.foundation.commons.validation はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.ConInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.ConInfo の使用

ConInfo を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での ConInfo の使用

ConInfo を返す jp.co.intra_mart.foundation.database のメソッド
ConInfo | DbsConnection.getConnectionInfo() 推奨されていません。 データベース設定情報を取得します。
ConInfo | DbManager.getConnectInfo() 推奨されていません。 代替えメソッドはありません。

ConInfo 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static boolean | DbManager.contact(ConInfo dio) 推奨されていません。 代替えメソッドはありません。
Connection | DatabaseAccessor.getConnection(ConInfo conInfo) Connectionオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DatabaseAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DatabaseAccessor の使用

DatabaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseAccessor の使用

DatabaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static void DatabaseManager.setDatabaseAccessor(DatabaseAccessor databaseAccessor)
データベースアクセッサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DatabaseManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DatabaseManager の使用

DatabaseManager を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DatabaseManager の使用

DatabaseManager を返す jp.co.intra_mart.foundation.database のメソッド
static DatabaseManager DatabaseManager.getInstance()
データべースマネージャインスタンスを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DataSourceProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DataSourceProvider の使用

DataSourceProvider を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DataSourceProvider の使用

DataSourceProvider 型のパラメータを持つ jp.co.intra_mart.foundation.database のメソッド
static void DatabaseManager.setSourceProvider(DataSourceProvider provider)
ソースプロバイダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DbManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DbManager の使用

jp.co.intra_mart.foundation.database.DbManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DbsConnection の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DbsConnection の使用

DbsConnection を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.database での DbsConnection の使用

DbsConnection を返す jp.co.intra_mart.foundation.database のメソッド
 DbsConnection DbManager.getConnection()
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。

jp.co.intra_mart.framework.base.data での DbsConnection の使用

DbsConnection を返す jp.co.intra_mart.framework.base.data のメソッド
DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.exception.DatabaseSQLException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.exception.DatabaseSQLException の使用

jp.co.intra_mart.foundation.database.exception.DatabaseSQLException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DatabaseSQLException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database.exception
クラス DatabaseSQLException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.sql.SQLException
                拡張 jp.co.intra_mart.foundation.database.exception.DatabaseSQLException
すべての実装インタフェース:
Serializable
public class DatabaseSQLException
extends SQLException

データベースSQL例外拡張クラス。

SQL例外に原因となる例外を渡せるようにした拡張版例外クラス。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DatabaseSQLException(String reason)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, int vendorCode)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, int vendorCode, Throwable cause)
コンストラクタ。
DatabaseSQLException(String reason, String SQLState, Throwable cause)
コンストラクタ。
DatabaseSQLException(String reason, Throwable cause)
コンストラクタ。
クラス java.sql.SQLException から継承したメソッド
getErrorCode, getNextException, getSQLState, setNextException
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DatabaseSQLException

public DatabaseSQLException(String reason)
コンストラクタ。

パラメータ:
reason - 理由

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            int vendorCode)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
vendorCode - ベンダーコード

DatabaseSQLException

public DatabaseSQLException(String reason,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
cause - 原因となる例外

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
cause - 原因となる例外

DatabaseSQLException

public DatabaseSQLException(String reason,
                            String SQLState,
                            int vendorCode,
                            Throwable cause)
コンストラクタ。

パラメータ:
reason - 理由
SQLState - SQLステータス
vendorCode - ベンダーコード
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.database.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.database.exception
例外
DatabaseSQLException


jp.co.intra_mart.foundation.database.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database.exception

データベースＳＱＬ例外クラスを提供します。

参照:
説明

例外の概要
DatabaseSQLException データベースSQL例外拡張クラス。

パッケージ jp.co.intra_mart.foundation.database.exception の説明

データベースＳＱＬ例外クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.database.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.sql.SQLException
          • class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.database.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.database.exception の使用

jp.co.intra_mart.foundation.database.exception はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ConInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース ConInfo

public interface ConInfo

フィールドの概要
static String | TYPE_DATA_SOURCE
static String | TYPE_GROUP
static String | TYPE_JDBC
static String | TYPE_SYSTEM
メソッドの概要
String | getConId() 接続参照名を取得します。
String | getConnectionType() 接続の種別を取得します。
String | getDataSourceRefName() DataSourceへの参照名を取得します。
String | getIdentifier() コネクションの識別子を取得します。
void | setDataSourceRefName(String dsRefName) DataSourceへの参照名を設定します。

フィールドの詳細

TYPE_SYSTEM

public static final String TYPE_SYSTEM
関連項目:
定数フィールド値

TYPE_GROUP

public static final String TYPE_GROUP
関連項目:
定数フィールド値

TYPE_DATA_SOURCE

public static final String TYPE_DATA_SOURCE
関連項目:
定数フィールド値

TYPE_JDBC

public static final String TYPE_JDBC
関連項目:
定数フィールド値
メソッドの詳細

setDataSourceRefName

public void setDataSourceRefName(String dsRefName)
DataSourceへの参照名を設定します。

パラメータ:
dsRefName - DataSourceへの参照名

getDataSourceRefName

public String getDataSourceRefName()
DataSourceへの参照名を取得します。

戻り値:
DataSourceへの参照名

getConId

public String getConId()
接続参照名を取得します。

戻り値:
接続参照名

getConnectionType

public String getConnectionType()
接続の種別を取得します。

戻り値:
接続の種別

getIdentifier

public String getIdentifier()
コネクションの識別子を取得します。

戻り値:
コネクションの識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DatabaseAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DatabaseAccessor

public interface DatabaseAccessor

データベース接続オブジェクト取得インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
DatabaseAccessorImpl

メソッドの概要
void | beginTransaction() データベースアクセスのトランザクションを開始します。
void | commit() データベースのトランザクションをコミットします。
Connection | getConnection(ConInfo conInfo) Connectionオブジェクトを取得します。
boolean | isTransaction() データベースアクセスのトランザクション状態を取得します。
void | rollback() データベースのトランザクションをロールバックします。

メソッドの詳細

getConnection

public Connection getConnection(ConInfo conInfo)
                         throws SQLException,
                                NamingException
Connectionオブジェクトを取得します。

パラメータ:
conInfo - データベース接続情報
戻り値:
データベース接続オブジェクト
例外:
SQLException
NamingException

beginTransaction

public void beginTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクションを開始します。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

isTransaction

public boolean isTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクション状態を取得します。

戻り値:
true : トランザクション中 / false : トランザクション外
例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

commit

public void commit()
            throws NamingException,
                   IllegalStateException,
                   SecurityException,
                   RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SystemException
データベースのトランザクションをコミットします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
HeuristicRollbackException - この例外は、コミット操作によってスローされ、ヒューリスティックな決定が行われて、それに関連するすべての更新がロールバックされたことを報告します。
HeuristicMixedException - この例外は、ヒューリスティックな決定が行われて、それに関連する一部の更新がコミットされ、残りの更新がロールバックされたことを報告するためにスローされます。
RollbackException - RollbackException 例外は、トランザクションがロールバック専用としてマークされたか、コミットの代わりにロールバックされた場合にスローされます。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

rollback

public void rollback()
              throws NamingException,
                     IllegalStateException,
                     SecurityException,
                     SystemException
データベースのトランザクションをロールバックします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DatabaseManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DatabaseManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DatabaseManager
public class DatabaseManager
extends Object

データベースマネージャクラス。

コネクションオブジェクトを管理するマネージャです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | beginTransaction() データベースアクセスのトランザクションを開始します。
void | commit() データベースのトランザクションをコミットします。
String | dateToString(Date date) データベース登録用文字列を取得します。
String[] | getConnectIdsBySystem() システムに紐付くシステム接続名の一覧を取得します。
String | getDataSourceNameByLoginGroup(String groupId) ログイングループIDからデータソース参照名を取得します。
String | getDataSourceNameBySystem(String connectId) システム接続名からデータソース参照名を取得します。
static DatabaseManager | getInstance() データべースマネージャインスタンスを生成します。
Connection | getJdbcConnection(String driver, String connectURL, String user, String password) JDBCからコネクションオブジェクトを取得します。
Connection | getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | getResourceConnection(String resourceRef) リソース参照名からコネクションオブジェクト取得を取得します。
Connection | getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。
boolean | isTransaction() データベースアクセスのトランザクション状態を取得します。
void | rollback() データベースのトランザクションをロールバックします。
static void | setDatabaseAccessor(DatabaseAccessor databaseAccessor) データベースアクセッサを設定します。
static void | setSourceProvider(DataSourceProvider provider) ソースプロバイダを設定します。
Date | stringToDate(String dateString) データベース登録用文字列からjava.util.Dateを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static DatabaseManager getInstance()
データべースマネージャインスタンスを生成します。

戻り値:
データべースマネージャインスタンス

setDatabaseAccessor

public static void setDatabaseAccessor(DatabaseAccessor databaseAccessor)
データベースアクセッサを設定します。

実際にデータベースコネクションを取得するアクセッサを設定します。

通常、このメソッドを使用する必要はありません。

パラメータ:
databaseAccessor - データベースアクセッサ

setSourceProvider

public static void setSourceProvider(DataSourceProvider provider)
ソースプロバイダを設定します。

データソース設定ファイルを提供するプロバイダを設定します。

通常、このメソッドを使用する必要はありません。

パラメータ:
provider - ソースプロバイダ

beginTransaction

public void beginTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクションを開始します。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

isTransaction

public boolean isTransaction()
                      throws NamingException,
                             NotSupportedException,
                             SystemException
データベースアクセスのトランザクション状態を取得します。

戻り値:
true : トランザクション中 / false : トランザクション外
例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
NotSupportedException - NotSupportedException 例外は、操作がサポートされていない機能であるために、要求が実行できないことを示します。

commit

public void commit()
            throws NamingException,
                   IllegalStateException,
                   SecurityException,
                   RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SystemException
データベースのトランザクションをコミットします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
HeuristicRollbackException - この例外は、コミット操作によってスローされ、ヒューリスティックな決定が行われて、それに関連するすべての更新がロールバックされたことを報告します。
HeuristicMixedException - この例外は、ヒューリスティックな決定が行われて、それに関連する一部の更新がコミットされ、残りの更新がロールバックされたことを報告するためにスローされます。
RollbackException - RollbackException 例外は、トランザクションがロールバック専用としてマークされたか、コミットの代わりにロールバックされた場合にスローされます。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

dateToString

public String dateToString(Date date)
データベース登録用文字列を取得します。

パラメータ:
date - 変換元のDateオブジェクト
戻り値:
データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)

getConnectIdsBySystem

public String[] getConnectIdsBySystem()
システムに紐付くシステム接続名の一覧を取得します。

戻り値:
接続名の配列

getDataSourceNameByLoginGroup

public String getDataSourceNameByLoginGroup(String groupId)
ログイングループIDからデータソース参照名を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
データソース参照名

getDataSourceNameBySystem

public String getDataSourceNameBySystem(String connectId)
システム接続名からデータソース参照名を取得します。

パラメータ:
connectId - システム接続名
戻り値:
データソース参照名

getJdbcConnection

public Connection getJdbcConnection(String driver,
                                    String connectURL,
                                    String user,
                                    String password)
                             throws SQLException
JDBCからコネクションオブジェクトを取得します。

パラメータ:
driver - ドライバ名
connectURL - 接続URL
user - DBユーザ
password - DBパスワード
戻り値:
コネクションオブジェクト
例外:
SQLException - データベースの例外が発生した場合にスローされます。

getLoginGroupConnection

public Connection getLoginGroupConnection(String groupId)
                                   throws NamingException,
                                          SQLException,
                                          NotExistException,
                                          AccessSecurityException
ログイングループIDからコネクションオブジェクトを取得します。
ログイングループに紐付いたコネクションオブジェクトを取得します。

パラメータ:
groupId - ログイングループID
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。
NotFoundDataSourceException - システム接続名に対応するデータベース設定情報が存在しなかった場合にスローされます。
AccessSecurityException - データベース設定情報が取得できなかった場合にスローされます。
NotExistException

getResourceConnection

public Connection getResourceConnection(String resourceRef)
                                 throws NamingException,
                                        SQLException
リソース参照名からコネクションオブジェクト取得を取得します。

パラメータ:
resourceRef - リソース参照名
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。

getSystemConnection

public Connection getSystemConnection(String connectId)
                               throws NamingException,
                                      SQLException,
                                      NotExistException,
                                      AccessSecurityException
システム接続名からコネクションオブジェクトを取得します。
システムに紐付いたコネクションオブジェクトを取得します。

パラメータ:
connectId - システム接続名
戻り値:
コネクションオブジェクト
例外:
NamingException - データベースリソース参照名が解決できなかった場合にスローされます。
SQLException - データベースの例外が発生した場合にスローされます。
NotFoundDataSourceException - システム接続名に対応するデータベース設定情報が存在しなかった場合にスローされます。
AccessSecurityException - データベース設定情報が取得できなかった場合にスローされます。
NotExistException

rollback

public void rollback()
              throws NamingException,
                     IllegalStateException,
                     SecurityException,
                     SystemException
データベースのトランザクションをロールバックします。

例外:
NamingException - Context および DirContext インタフェースでの操作によってスローされるすべての例外のスーパークラスです。
SystemException - SystemException は、トランザクションマネージャによってスローされ、トランザクションサービスの処理をこれ以上続行できないような予想外のエラー状態が検出されたことを示します。
SecurityException - セキュリティマネージャによってスローされ、セキュリティ違反を示します。
IllegalStateException - 不正または不適切なときにメソッドが呼び出されたことを示します。

stringToDate

public Date stringToDate(String dateString)
データベース登録用文字列からjava.util.Dateを取得します。

パラメータ:
dateString - 変換元のデータベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
戻り値:
Dateオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataSourceProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DataSourceProvider

public interface DataSourceProvider

データソース設定情報取得プロバイダインタフェース。

データソース設定情報を取得するためのプロバイダインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 InputStream getInputStream()
データソース設定ファイルのストリームを取得します。

メソッドの詳細

getInputStream

public InputStream getInputStream()
データソース設定ファイルのストリームを取得します。

戻り値:
データソース設定ファイルのストリーム
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DbManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DbManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DbManager
推奨されていません。 DatabaseManagerを使用してください。

public class DbManager
extends Object

データベース操作APIです。

データベース操作を行います。

導入されたバージョン:
3.0
バージョン:
2.0

コンストラクタの概要
DbManager(String connectID)
推奨されていません。 DatabaseManagerを使用してください。
メソッドの概要
 boolean contact()
推奨されていません。 代替えメソッドはありません。
static boolean contact(ConInfo dio)
推奨されていません。 代替えメソッドはありません。
static String dateToString(Date date)
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。
static String[] getConnectIDs()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
 ConInfo getConnectInfo()
推奨されていません。 代替えメソッドはありません。
 DbsConnection getConnection()
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
static String[] getReference()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
 boolean isConnect()
推奨されていません。 代替えメソッドはありません。
static Date stringToDate(String dateString)
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DbManager

public DbManager(String connectID)
推奨されていません。 DatabaseManagerを使用してください。

コンストラクタ

パラメータ:
connectID - 接続参照名
メソッドの詳細

contact

public static boolean contact(ConInfo dio)
推奨されていません。 代替えメソッドはありません。

データベース接続を試みます。

パラメータ:
dio - データベース接続情報オブジェクト
戻り値:
成功 ture／失敗 false

dateToString

public static String dateToString(Date date)
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。

データベース登録用文字列を取得します。

パラメータ:
date - java.util.Date
戻り値:
データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
導入されたバージョン:
Version 4.0

getConnectIDs

public static String[] getConnectIDs()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。

データベース接続参照名一覧を取得する。

戻り値:
データベース接続参照名配列

getReference

public static String[] getReference()
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。

データベース接続設定参照名を取得する。

戻り値:
データベース接続設定参照名配列

stringToDate

public static Date stringToDate(String dateString)
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。

データベース登録用文字列からjava.util.Date取得します。

パラメータ:
dateString - データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
戻り値:
java.util.Date
導入されたバージョン:
Version 4.0

contact

public boolean contact()
推奨されていません。 代替えメソッドはありません。

データベース接続を試みます。

戻り値:
成功 ture／失敗 false

getConnectInfo

public ConInfo getConnectInfo()
推奨されていません。 代替えメソッドはありません。

データベース接続情報を取得します。

指定の接続参照名のデータベース接続情報を取得します。

戻り値:
ConInfo データベース接続情報オブジェクト

getConnection

public DbsConnection getConnection()
                            throws SQLException
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。

データベースコネクションを取得します。

このメソッドで取得したコネクションを使用後は、そのコネクションの releaseメソッドを必ず 呼び出すこと。
releaseメソッドを呼び出さずにこのメソッドを実行した場合、 コネクションの取得に失敗し、nullが 返ります。

戻り値:
データベースコネクションオブジェクト
例外:
SQLException

isConnect

public boolean isConnect()
推奨されていません。 代替えメソッドはありません。

データベース接続の状態を確認します。

戻り値:
接続されている ture／接続されていない false
一度接続されると、途中、何らかの理由でデータベースとの接続が切断されてもtrueを返し続ける。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DbsConnection (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DbsConnection

すべてのスーパーインタフェース:
Connection
推奨されていません。 DatabaseManagerから取得したコネクションを使用してください。

public interface DbsConnection
extends Connection

特定のデータベースとの接続 (セッション) を表現します。
Connection のコンテキスト内で SQL 文が実行され結果が返されます。

このコネクションを使用後は必ずreleaseメソッドを呼び出し、解放して下さい。

フィールドの概要
インタフェース java.sql.Connection から継承したフィールド
TRANSACTION_NONE, TRANSACTION_READ_COMMITTED, TRANSACTION_READ_UNCOMMITTED, TRANSACTION_REPEATABLE_READ, TRANSACTION_SERIALIZABLE
メソッドの概要
void | clearWarnings() 推奨されていません。 この Connection オブジェクトに関して通知されたすべての警告をクリアします。
void | close() 推奨されていません。 releaseメソッドと同等です。
void | commit() 推奨されていません。 データベースアクセスの確定処理を行います。
Statement | createStatement() 推奨されていません。 SQL 文をデータベースに送るための Statement オブジェクトを生成します。
Statement | createStatement(int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
Statement | createStatement(int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
int | execute(String sql) 推奨されていません。 任意のＳＱＬ文をデータベースに対してリクエストする insert/update/delete文を実行する。
List | fetch(String sql, int startRow, int endRow) 推奨されていません。 SELECT文を発行してデータベースから指定範囲のデータを取得する
boolean | getAutoCommit() 推奨されていません。 現在の自動コミットの状態を取得します。
String | getCatalog() 推奨されていません。 Connection の現在のカタログ名を返します。
ConInfo | getConnectionInfo() 推奨されていません。 データベース設定情報を取得します。
int | getCount(String tablename, String where) 推奨されていません。 指定条件に該当する表内のデータ件数を取得する
String | getDbName() 推奨されていません。 このデータベース製品の名前を取得します。
String | getDbVersion() 推奨されていません。 このデータベース製品のバージョンを取得します。
String | getEscape() 推奨されていません。 ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
int | getHoldability() 推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。
DatabaseMetaData | getMetaData() 推奨されていません。 この接続のデータベースに関するメタデータを取得します。
int | getTransactionIsolation() 推奨されていません。 この Connection の現在のトランザクション遮断レベルを取得します。
Map | getTypeMap() 推奨されていません。 この接続に関連した型マップオブジェクトを取得します。
SQLWarning | getWarnings() 推奨されていません。 この Connection に関する呼び出しによって通知された最初の警告を返します。
int | insert(String table, Map datas) 推奨されていません。 データベースにデータを追加挿入するメソッド データベースにインサート処理をする。
boolean | isClosed() 推奨されていません。 Connection がクローズされているかどうかを判定します。
boolean | isColumn(String clmnname, String tblname) 推奨されていません。 データベースの表内に指定カラムが存在するか調べる
boolean | isDataSource() 推奨されていません。 このコネクションがDataSourceかを返します。
boolean | isReadOnly() 推奨されていません。 Connection が読み込み専用モードかどうかを判定します。
String | nativeSQL(String sql) 推奨されていません。 指定された SQL 文をシステムの本来の SQL 文法に変換します。
CallableStatement | prepareCall(String sql) 推奨されていません。 データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。
CallableStatement | prepareCall(String sql, int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
CallableStatement | prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql) 推奨されていません。 パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。
PreparedStatement | prepareStatement(String sql, int autoGeneratedKeys) 推奨されていません。 自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int[] columnIndexes) 推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int resultSetType, int resultSetConcurrency) 推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 推奨されていません。 指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。
PreparedStatement | prepareStatement(String sql, String[] columnNames) 推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
void | release() 推奨されていません。 データベースコネクションを解放します。
void | releaseSavepoint(Savepoint savepoint) 推奨されていません。 現在のトランザクションから指定された Savepoint オブジェクトを削除します。
int | remove(String table, String where) 推奨されていません。 データベースにデータを削除するメソッド データベースのデータを削除(デリート)する。
void | rollback() 推奨されていません。 データベースアクセスの取り消し処理をする トランザクションを終了(rollback)させる。
void | rollback(Savepoint savepoint) 推奨されていません。 指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。
List | select(String sql) 推奨されていません。 SELECT文を発行してデータベースからデータを取得する
void | setAutoCommit(boolean autoCommit) 推奨されていません。
void | setCatalog(String catalog) 推奨されていません。 この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。
void | setHoldability(int holdability) 推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。
void | setReadOnly(boolean readOnly) 推奨されていません。 この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。
Savepoint | setSavepoint() 推奨されていません。 現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
Savepoint | setSavepoint(String name) 推奨されていません。 現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
void | setTimer(boolean autoRelease) 推奨されていません。 トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）
void | setTransactionIsolation(int level) 推奨されていません。 トランザクション遮断レベルを指定されたものに変更することを試みます。
void | setTypeMap(Map map) 推奨されていません。 この接続の型マップとして指定された型マップをインストールします。
void | transaction() 推奨されていません。 データベースアクセスのトランザクションを開始する トランザクションを開始させる。
int | update(String table, String where, Map datas) 推奨されていません。 データベースにデータを更新するメソッド データベースのデータを更新(アップデート)する。

メソッドの詳細

clearWarnings

public void clearWarnings()
                   throws SQLException
推奨されていません。
この Connection オブジェクトに関して通知されたすべての警告をクリアします。

このメソッドを呼び出したあと、Connection に対する新しい警告が通知されるまで、getWarnings は null を返します。

定義:
インタフェース Connection 内の clearWarnings
例外:
SQLException - データベースアクセスエラーが発生した場合

close

public void close()
           throws SQLException
推奨されていません。
releaseメソッドと同等です。

定義:
インタフェース Connection 内の close
例外:
SQLException - データベースアクセスエラーが発生した場合

commit

public void commit()
            throws SQLException
推奨されていません。
データベースアクセスの確定処理を行います。

トランザクションを終了(commit)させる。

定義:
インタフェース Connection 内の commit
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement()
                          throws SQLException
推奨されていません。
SQL 文をデータベースに送るための Statement オブジェクトを生成します。

パラメータなしの SQL 文は通常、Statement オブジェクトを使用して実行されます。同じ SQL 文が多 数回実行される場合は、PreparedStatement オブジェクトを使用する方が効率的です。 返される Statement オブジェクトを使って作成された結果セットは、デフォルトでは、順方 向専用タイプで、読み取り専用の並行処理ができます。

定義:
インタフェース Connection 内の createStatement
戻り値:
新しい Statement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement(int resultSetType,
                                 int resultSetConcurrency)
                          throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。

このメソッドは上記の createStatement メソッドと同じですが、デフォルト の結果セットのタイプおよび結果セットの並行処理の種類をオーバーライドできます。

定義:
インタフェース Connection 内の createStatement
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
新しい Statement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

createStatement

public Statement createStatement(int resultSetType,
                                 int resultSetConcurrency,
                                 int resultSetHoldability)
                          throws SQLException
推奨されていません。
指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。 このメソッドは上記の createStatement メソッドと同じですが、デフォルトの結果セットの型、並行処理、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の createStatement
パラメータ:
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する新しい Statement オブジェクト
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す - ResultSet 定数でない場合
SQLException

execute

public int execute(String sql)
            throws SQLException
推奨されていません。
任意のＳＱＬ文をデータベースに対してリクエストする

insert/update/delete文を実行する。

パラメータ:
sql - insert/update/delete文（引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。）
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

fetch

public List fetch(String sql,
                  int startRow,
                  int endRow)
           throws SQLException
推奨されていません。
SELECT文を発行してデータベースから指定範囲のデータを取得する

パラメータ:
sql - SQL文（SELECT文）
引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。
startRow - 取得するデータの開始レコード位置 (1以上を指定)
endRow - 取得するデータの総件数 (1以上を指定)
戻り値:
Listの各要素はHashtable。カラム名(全て小文字に変換)＝値 で格納される。

取得できるデータはjp.co.intra_mart.foundation.database.DbsConnection.selectメソッドの戻り値と同様に変換されます。

例外:
SQLException - データベースアクセスエラーが発生した場合

getAutoCommit

public boolean getAutoCommit()
                      throws SQLException
推奨されていません。
現在の自動コミットの状態を取得します。

定義:
インタフェース Connection 内の getAutoCommit
戻り値:
現在の自動コミットモードの状態
例外:
SQLException - データベースアクセスエラーが発生した場合

getCatalog

public String getCatalog()
                  throws SQLException
推奨されていません。
Connection の現在のカタログ名を返します。

定義:
インタフェース Connection 内の getCatalog
戻り値:
現在のカタログ名または null
例外:
SQLException - データベースアクセスエラーが発生した場合

getConnectionInfo

public ConInfo getConnectionInfo()
推奨されていません。
データベース設定情報を取得します。

戻り値:
データベース設定情報

getCount

public int getCount(String tablename,
                    String where)
             throws SQLException
推奨されていません。
指定条件に該当する表内のデータ件数を取得する

パラメータ:
tablename - テーブル名
戻り値:
件数。
例外:
SQLException - データベースアクセスエラーが発生した場合

getDbName

public String getDbName()
                 throws SQLException
推奨されていません。
このデータベース製品の名前を取得します。

戻り値:
データベース製品の名前
例外:
SQLException - データベースアクセスエラーが発生した場合

getDbVersion

public String getDbVersion()
                    throws SQLException
推奨されていません。
このデータベース製品のバージョンを取得します。

戻り値:
データベースのバージョン
例外:
SQLException - データベースアクセスエラーが発生した場合

getEscape

public String getEscape()
                 throws SQLException
推奨されていません。
ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

これは、文字列パターンスタイルカタログ検索パラメータで '_' や '%' をエスケープするのに使用できる 文字列です。 '_' 文字は任意の 1 文字を表します。 '%' 文字は 0 文字以上のシーケンスを表します。

戻り値:
データベースのバージョン
例外:
SQLException - データベースアクセスエラーが発生した場合

getHoldability

public int getHoldability()
                   throws SQLException
推奨されていません。
この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。

定義:
インタフェース Connection 内の getHoldability
戻り値:
保持機能。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
例外:
データベースアクセスエラーが発生した場合
SQLException

getMetaData

public DatabaseMetaData getMetaData()
                             throws SQLException
推奨されていません。
この接続のデータベースに関するメタデータを取得します。

Connection のデータベースは、テーブル、サポートしている SQL 文法、ストアドプロシージャ、 およびこの接続の能力などを記述する情報を提供します。この情報は、DatabaseMetaData オブジェクトから 取得します。

定義:
インタフェース Connection 内の getMetaData
戻り値:
この Connection に対する DatabaseMetaData オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

getTransactionIsolation

public int getTransactionIsolation()
                            throws SQLException
推奨されていません。
この Connection の現在のトランザクション遮断レベルを取得します。

定義:
インタフェース Connection 内の getTransactionIsolation
戻り値:
現在の TRANSACTION_* モード値
例外:
SQLException - データベースアクセスエラーが発生した場合

getTypeMap

public Map getTypeMap()
               throws SQLException
推奨されていません。
この接続に関連した型マップオブジェクトを取得します。

アプリケーションが型マップにエントリを追加していない限り、空のマップが返されます。

定義:
インタフェース Connection 内の getTypeMap
戻り値:
この Connection オブジェクトに関連した java.util.Map オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

getWarnings

public SQLWarning getWarnings()
                       throws SQLException
推奨されていません。
この Connection に関する呼び出しによって通知された最初の警告を返します。

注: 引き続く警告は、この SQLWarning にチェーンされます。

定義:
インタフェース Connection 内の getWarnings
戻り値:
最初の SQLWarning または null
例外:
SQLException - データベースアクセスエラーが発生した場合

insert

public int insert(String table,
                  Map datas)
           throws SQLException
推奨されていません。
データベースにデータを追加挿入するメソッド

データベースにインサート処理をする。 挿入データはオブジェクト(Map)形式のデータをセット。 なお、オブジェクトのプロパティ名称は、挿入したい データベースのカラム名称に等しく作成し、そのプロパティに 対して挿入したいデータをセットする。

パラメータ:
table - 処理対象のデータベース表名
datas - 挿入データ 引数 datas(Map)の内容
(key == value)
カラム名 = 値 ここでセットできるデータ型（値）は、String,Numberのみです。
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

isClosed

public boolean isClosed()
                 throws SQLException
推奨されていません。
Connection がクローズされているかどうかを判定します。

定義:
インタフェース Connection 内の isClosed
戻り値:
Connection がクローズされている場合は true、まだオープンの状態の場合は false
例外:
SQLException - データベースアクセスエラーが発生した場合

isColumn

public boolean isColumn(String clmnname,
                        String tblname)
                 throws SQLException
推奨されていません。
データベースの表内に指定カラムが存在するか調べる

パラメータ:
clmnname - 存在の有無をチェックしたいカラム名称 （カラム名の大文字小文字は区別しない）
tblname - 定義情報をチェックしたい表名
戻り値:
指定のカラムは存在する ture／指定のカラムは存在しない false
例外:
SQLException - データベースアクセスエラーが発生した場合

isDataSource

public boolean isDataSource()
推奨されていません。
このコネクションがDataSourceかを返します。

戻り値:
DataSourceの場合 true／DataSourceではないの場合 false
例外:
SQLException - データベースアクセスエラーが発生した場合

isReadOnly

public boolean isReadOnly()
                   throws SQLException
推奨されていません。
Connection が読み込み専用モードかどうかを判定します。

定義:
インタフェース Connection 内の isReadOnly
戻り値:
Connection が読み込み専用モードの場合は true、そうでない場合は false
例外:
SQLException - データベースアクセスエラーが発生した場合

nativeSQL

public String nativeSQL(String sql)
                 throws SQLException
推奨されていません。
指定された SQL 文をシステムの本来の SQL 文法に変換します。

ドライバは、送信前にJDBC SQL 文法をシステムの本来の SQL 文法に変換できます。 このメソッドは、ドライバが送る文のシステム本来の形のフォームを返します。

定義:
インタフェース Connection 内の nativeSQL
パラメータ:
sql - 1 つ以上の '?' パラメータプレースホルダーを含めることができる SQL 文
戻り値:
この文の元のフォーム
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql)
                              throws SQLException
推奨されていません。
データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。

CallableStatement オブジェクトは、その IN と OUT パラメータを設定するメ ソッドとストアドプロシージャの呼び出しを実行するメソッドを提供します。
注: このメソッドは、ストアドプロシージャ呼び出し文を処理するために最適化されていま す。ドライバによっては、prepareCall メソッドが実行されるときにデータベースに呼び出し 文を送るものがあります。その他のドライバは、CallableStatement オブジェクトが実行さ れるまで待ちます。これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。 返される CallableStatement を 使って作成された結果セットは、デフォルトでは、順方向専用タイプで、読み取り専用の 並行処理ができます。

ストアドプロシジャーの実行例

 以下のようなストアドプロシジャーを実行する場合。
  // ストアドプロシジャー CREATE OR REPLACE PROCEDURE spTest ( retNo IN OUT
 NUMBER,errMsg IN OUT VARCHAR2 ) IS BEGIN retNo := retNo + 1; errMsg :=
 errMsg || 'A'; END; /

 public void execStoredProc(){ DbManager dbmgr = new DbManager("DEFAULT");
 DbsConnection dbsc = dbmgr.getConnection();

 String stmt = new String("{call spTest (?,?)}"); CallableStatement
 clblstmt = dbsc.prepareCall(stmt);
  // パラメータセット clblstmt.setInt(1,2);
 clblstmt.registerOutParameter(1,java.sql.Types.DECIMAL);
 clblstmt.setString(2,"TEST");
 clblstmt.registerOutParameter(2,java.sql.Types.VARCHAR);

 //実行 clblstmt.execute();

 System.out.println(clblstmt.getInt(1));
 System.out.println(clblstmt.getString(2));

 //終了処理 clblstmt.close(); dbsc.release(); }
  <<結果>>3 TESTA

 ストアドファンクションの実行例

 以下のようなストアドファンクションを実行する場合。
  // ストアドファンクション CREATE OR REPLACE FUNCTION fcTest ( retNo IN OUT
 NUMBER,errMsg IN OUT VARCHAR2 ) RETURN number IS retValue number(2);
 BEGIN retNo := retNo + 1; errMsg := errMsg || 'A';

 retValue := 19; return retValue; END; /

 public void execStoredFunc(){ DbManager dbmgr = new DbManager("DEFAULT");
 DbsConnection dbsc = dbmgr.getConnection();

 String stmt = new String("{? = call fcTest (?,?)}");
 CallableStatement clblstmt = dbsc.prepareCall(stmt);
  // 戻り値セット clblstmt.registerOutParameter(1,java.sql.Types.DECIMAL); //
 パラメータセット clblstmt.setInt(1,2);
 clblstmt.registerOutParameter(2,java.sql.Types.DECIMAL);
 clblstmt.setString(2,"TEST");
 clblstmt.registerOutParameter(3,java.sql.Types.VARCHAR);

 //実行 clblstmt.execute();

 System.out.println(clblstmt.getInt(1));
 System.out.println(clblstmt.getInt(2));
 System.out.println(clblstmt.getString(3));

 //終了処理 clblstmt.close(); dbsc.release(); }
  <<結果>>19 3 TESTA

 詳しくはjava.sql.CallableStatementの説明をご覧ください。

定義:
インタフェース Connection 内の prepareCall

パラメータ:
sql - 1 つ以上の '?' パラメータプレースホルダーを含めることができる SQL 文。通 常この文は、JBDC
            関数呼び出しのエスケープ文字列である

戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト

例外:

SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql,
                                     int resultSetType,
                                     int resultSetConcurrency)
                              throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。

このメソッドは上記の prepareCall メソッドと同じ様ですが、デフ ォルトの結果セットのタイプおよび結果セットの並行処理の種類をオーバーライドできま す。

定義:
インタフェース Connection 内の prepareCall
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareCall

public CallableStatement prepareCall(String sql,
                                     int resultSetType,
                                     int resultSetConcurrency,
                                     int resultSetHoldability)
                              throws SQLException
推奨されていません。
指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。 このメソッドは上記の prepareCall メソッドと同じですが、デフォルトの結果セットの型、結果セットの並行処理の種類、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の prepareCall
パラメータ:
sql - SQL 文がデータベースへ送られる String オブジェクト。1 つ以上の ? パラメータを含めることができる
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
プリコンパイルされた SQL 文を含む新しい CallableStatement オブジェクト。指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す - ResultSet 定数でない場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql)
                                   throws SQLException
推奨されていません。
パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルし て、PreparedStatement オブジェクトに格納できます。したがって、このオブジェクトは、こ の文を複数回、効率的に実行するのに使用できます。 注: このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するた めに最適化されています。ドライバが、プリコンパイルをサポートしている場合、 prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。この場合、 PreparedStatement が実行されるまで、文はデータベースに送られません。これはユー ザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたか に関して影響があります。 返される PreparedStatement を使って生成された結果セット は、デフォルトでは、順方向専用タイプで、読み取り専用の並行処理ができます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int autoGeneratedKeys)
                                   throws SQLException
推奨されていません。
自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。 指定された定数によって、ドライバが自動生成キーを取得可能にするかどうかが指定されます。 SQL 文が INSERT 文でない場合、このパラメータは無視されます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。 この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
autoGeneratedKeys - 自動生成キーを返すかどうかを示すフラグ。次の Statement 定数のうちの 1 つ
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト。自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合、または指定されたパラメータが自動生成キーを返すかどうかを示す - Statement 定数でない場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int resultSetType,
                                          int resultSetConcurrency)
                                   throws SQLException
推奨されていません。
指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。

このメソッドは上記の prepareStatement メソッドと同じです が、デフォルトの結果セットのタイプおよび結果セットの並行処理の種類をオーバーライド できます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
resultSetType - 結果セットのタイプ。ResultSet.TYPE_XXX を参照
resultSetConcurrency - 並行処理の種類。ResultSet.CONCUR_XXX を参照
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int resultSetType,
                                          int resultSetConcurrency,
                                          int resultSetHoldability)
                                   throws SQLException
推奨されていません。
指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。

このメソッドは上記の prepareStatement メソッドと同じですが、デフォルトの結果セットの型、並行処理、および保持機能をオーバーライドできます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - SQL 文がデータベースへ送られる String オブジェクト。1 つ以上の ? IN パラメータを含めることができる
resultSetType - ResultSet 定数。ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE、または ResultSet.TYPE_SCROLL_SENSITIVE のうちの 1 つ
resultSetConcurrency - ResultSet 定数。ResultSet.CONCUR_READ_ONLY または ResultSet.CONCUR_UPDATABLE
resultSetHoldability - ResultSet 定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
戻り値:
プリコンパイルされた SQL 文を含む新しい PreparedStatement オブジェクト。指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する
例外:
SQLException - データベースアクセスエラーが発生した場合、または指定されたパラメータが型、並行処理、および保持機能を示す ResultSet 定数でない場合

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          int[] columnIndexes)
                                   throws SQLException
推奨されていません。
指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。この配列は、 使用可能にされる自動生成キーを含むターゲットテーブルの列のインデックスを含みます。 SQL 文が INSERT 文でない場合、この配列は無視されます。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルして、PreparedStatement オブジェクトに格納できます。 したがって、このオブジェクトは、この文を複数回、効率的に実行するのに使用できます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
columnIndexes - 挿入された行から返される列を示す列インデックスの配列
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト。指定された列インデックスの配列によって指定される自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合
SQLException

prepareStatement

public PreparedStatement prepareStatement(String sql,
                                          String[] columnNames)
                                   throws SQLException
推奨されていません。
指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。 この配列は、返される自動生成キーを含むターゲットテーブルの列の名前を含みます。 SQL 文が INSERT 文でない場合、この配列は無視されます。

IN パラメータ付きまたは IN パラメータなしの SQL 文は、プリコンパイルして、PreparedStatement オブジェクトに格納できます。 したがって、このオブジェクトは、この文を複数回、効率的に実行するのに使用できます。

注 : このメソッドは、プリコンパイルが効果のある、パラメータ付き SQL 文を処理するために最適化されています。 ドライバが、プリコンパイルをサポートしている場合、prepareStatement メソッドは、その文をプリコンパイル用としてデータベースに送ります。 ドライバによっては、プリコンパイルをサポートしていないものがあります。 この場合、PreparedStatement が実行されるまで、文はデータベースに送られません。 これはユーザに直接的な影響はありませんが、どのメソッドが、どの SQLException をスローしたかに関して影響があります。

返される PreparedStatement オブジェクトを使って作成された結果セットは、デフォルトでは、TYPE_FORWARD_ONLY の型で、CONCUR_READ_ONLY の並行処理レベルを持ちます。

定義:
インタフェース Connection 内の prepareStatement
パラメータ:
sql - 1 つ以上の '?' IN パラメータプレースホルダーを含めることができる SQL 文
columnNames - 挿入された行から返される列を示す列名の配列
戻り値:
プリコンパイルされた文を含む新しい PreparedStatement オブジェクト。指定された列名の配列によって指定される自動生成キーを返す機能を持つ
例外:
データベースアクセスエラーが発生した場合
SQLException

release

public void release()
             throws SQLException
推奨されていません。
データベースコネクションを解放します。

現在使用しているデータベースコネクションをシステムに返します。 このコネクションを使用後、必ず一回呼び出して下さい。

例外:
SQLException - データベースアクセスエラーが発生した場合

releaseSavepoint

public void releaseSavepoint(Savepoint savepoint)
                      throws SQLException
推奨されていません。
現在のトランザクションから指定された Savepoint オブジェクトを削除します。削除されたあとでセーブポイントを参照すると SQLException がスローされます。

定義:
インタフェース Connection 内の releaseSavepoint
パラメータ:
savepoint - 削除される Savepoint オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合、または指定された Savepoint オブジェクトが現在のトランザクションで有効なセーブポイントでない場合

remove

public int remove(String table,
                  String where)
           throws SQLException
推奨されていません。
データベースにデータを削除するメソッド

データベースのデータを削除(デリート)する。 条件を設定すると、条件に合致したすべてのレコードを削除する。

パラメータ:
table - 処理対象のデータベース表名
where - 更新部分検索条件(WHERE 句)
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合

rollback

public void rollback()
              throws SQLException
推奨されていません。
データベースアクセスの取り消し処理をする

トランザクションを終了(rollback)させる。

定義:
インタフェース Connection 内の rollback
例外:
SQLException - データベースアクセスエラーが発生した場合

rollback

public void rollback(Savepoint savepoint)
              throws SQLException
推奨されていません。
指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。

定義:
インタフェース Connection 内の rollback
パラメータ:
savepoint - ロールバックする Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、Savepoint - オブジェクトが有効でなくなった場合、または現在この Connection オブジェクトが自動コミットモードである場合
SQLException

select

public List select(String sql)
            throws SQLException
推奨されていません。
SELECT文を発行してデータベースからデータを取得する

パラメータ:
sql - SQL文（SELECT文）
引数のSQL文にはステートメント末判定文字(";"や"/"など)は付けない。
戻り値:
Listの各要素はHashtable。カラム名(全て小文字に変換)＝値 で格納される。 取得できるデータは以下のように変換されます。

JDBCドライバによっては以下の表の通りに取得できない場合もあります。
java.sql.Types.CHAR | java.lang.String
java.sql.Types.CLOB(※１)
java.sql.Types.LONGVARCHAR
java.sql.Types.VARCHAR
java.sql.Types.TIMESTAMP
java.sql.Types.OTHER(※１)
java.sql.Types.BIT | java.lang.Double
java.sql.Types.BIGINT
java.sql.Types.DECIMAL
java.sql.Types.DOUBLE
java.sql.Types.FLOAT
java.sql.Types.INTEGER
java.sql.Types.NUMERIC
java.sql.Types.REAL
java.sql.Types.SMALLINT
java.sql.Types.TINYINT
java.sql.Types.DATE | java.util.Date
java.sql.Types.TIME
java.sql.Types.BINARY(※１) | java.lang.String（エンコードしないString(バイナリ形式)）
java.sql.Types.LONGVARBINARY(※１)
java.sql.Types.VARBINARY(※１)
java.sql.Types.NULL | 取得しない
java.sql.Types.REF(※１) | java.lang.Object(java.sql.ResultSet.getObject()で取得した値)
java.sql.Types.JAVA_OBJECT(※１)
java.sql.Types.STRUCT(※１)
java.sql.Types.ARRAY(※１)
java.sql.Types.DISTINCT(※１)
(※１)推奨されません。動作未検証です。
例外:
SQLException - データベースアクセスエラーが発生した場合

setAutoCommit

public void setAutoCommit(boolean autoCommit)
                   throws SQLException
推奨されていません。

定義:
インタフェース Connection 内の setAutoCommit
例外:
SQLException

setCatalog

public void setCatalog(String catalog)
                throws SQLException
推奨されていません。
この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。

ドライバがカタログをサポートしていない場合は、この要求を無視しま す。

定義:
インタフェース Connection 内の setCatalog
例外:
SQLException - データベースアクセスエラーが発生した場合

setHoldability

public void setHoldability(int holdability)
                    throws SQLException
推奨されていません。
この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。

定義:
インタフェース Connection 内の setHoldability
パラメータ:
holdability - ResultSet の保持機能定数。ResultSet.HOLD_CURSORS_OVER_COMMIT または ResultSet.CLOSE_CURSORS_AT_COMMIT
例外:
データベースアクセスエラーが発生した場合、指定されたパラメータが保持機能を示す - ResultSet 定数でない場合、または指定された保持機能がサポートされていない場合
SQLException

setReadOnly

public void setReadOnly(boolean readOnly)
                 throws SQLException
推奨されていません。
この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。

注: トランザクションの途中では、このメソッドを呼び出すことはできません。

定義:
インタフェース Connection 内の setReadOnly
パラメータ:
readOnly - true の場合は読み込み専用モードが有効、false の場合は読み込み専用モードが無効
例外:
SQLException - データベースアクセスエラーが発生した場合

setSavepoint

public Savepoint setSavepoint()
                       throws SQLException
推奨されていません。
現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。

定義:
インタフェース Connection 内の setSavepoint
戻り値:
新しい Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、または現在この - Connection オブジェクトが自動コミットモードである場合
SQLException

setSavepoint

public Savepoint setSavepoint(String name)
                       throws SQLException
推奨されていません。
現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。

定義:
インタフェース Connection 内の setSavepoint
パラメータ:
name - セーブポイントの名前を格納する String
戻り値:
新しい Savepoint オブジェクト
例外:
データベースアクセスエラーが発生した場合、または現在この - Connection オブジェクトが自動コミットモードである場合
SQLException

setTimer

public void setTimer(boolean autoRelease)
              throws SQLException
推奨されていません。
トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）

パラメータ:
autoRelease - タイマーストップ false ／スタート true
例外:
SQLException

setTransactionIsolation

public void setTransactionIsolation(int level)
                             throws SQLException
推奨されていません。
トランザクション遮断レベルを指定されたものに変更することを試みます。

指定できるトランザクション遮断レベルの定数は、Connection インタフェースで定義されています。
注: トランザクションの途中では、このメソッドを呼び出すことはできません。

定義:
インタフェース Connection 内の setTransactionIsolation
パラメータ:
level - TRANSACTION_NONE を除く TRANSACTION_* 遮断値の 1 つ。データベースによっては、ほかの値をサポートしないものがある
例外:
SQLException - データベースアクセスエラーが発生した場合

setTypeMap

public void setTypeMap(Map map)
                throws SQLException
推奨されていません。
この接続の型マップとして指定された型マップをインストールします。

型マップは、SQL 構造化型および個別の型のカスタムマッピングに使用されます。

定義:
インタフェース Connection 内の setTypeMap
パラメータ:
map - この Connection オブジェクトのデフォルトの型マップの代わりとしてインスト ールする java.util.Map オブジェクト
例外:
SQLException - データベースアクセスエラーが発生した場合

transaction

public void transaction()
                 throws SQLException
推奨されていません。
データベースアクセスのトランザクションを開始する

トランザクションを開始させる。

例外:
SQLException - データベースアクセスエラーが発生した場合

update

public int update(String table,
                  String where,
                  Map datas)
           throws SQLException
推奨されていません。
データベースにデータを更新するメソッド

データベースのデータを更新(アップデート)する。 更新データはオブジェクト(Map)形式のデータをセット。 なお、オブジェクトのプロパティ名称は、更新したい データベースのカラム名称に等しく作成し、そのプロパティに 対して挿入したいデータをセットする。

パラメータ:
table - 処理対象のデータベース表名
where - 更新部分検索条件(WHERE 句)
datas - 更新データ 引数 datas(Map)の内容
(key == value)
カラム名 = 値 ここでセットできるデータ型（値）は、String,Numberのみです。
戻り値:
処理行数
例外:
SQLException - データベースアクセスエラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.database (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.database
インタフェース
ConInfo
DatabaseAccessor
DataSourceProvider
DbsConnection
クラス
DatabaseManager
DbManager


jp.co.intra_mart.foundation.database (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database

データベースへアクセスするためのクラスを提供します。

参照:
説明

インタフェースの概要
ConInfo |
DatabaseAccessor | データベース接続オブジェクト取得インターフェースを定義します。
DataSourceProvider | データソース設定情報取得プロバイダインタフェース。
DbsConnection | 推奨されていません。 DatabaseManagerから取得したコネクションを使用してください。

クラスの概要
DatabaseManager | データベースマネージャクラス。
DbManager | 推奨されていません。 DatabaseManagerを使用してください。

パッケージ jp.co.intra_mart.foundation.database の説明

データベースへアクセスするためのクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.database クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.database の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.database.DatabaseManager
    • class jp.co.intra_mart.foundation.database.DbManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.database.ConInfo
  • interface java.sql.Connection
    • interface jp.co.intra_mart.foundation.database.DbsConnection
  • interface jp.co.intra_mart.foundation.database.DatabaseAccessor
  • interface jp.co.intra_mart.foundation.database.DataSourceProvider
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.database の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.database の使用

jp.co.intra_mart.foundation.database を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.database のクラス
ConInfo
DatabaseAccessor
データベース接続オブジェクト取得インターフェースを定義します。
DatabaseManager
データベースマネージャクラス。
DataSourceProvider
データソース設定情報取得プロバイダインタフェース。
DbsConnection
推奨されていません。 DatabaseManagerから取得したコネクションを使用してください。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.foundation.database のクラス
DbsConnection
推奨されていません。 DatabaseManagerから取得したコネクションを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational の使用

CateogryClassInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class 分類区分情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class での CateogryClassInternational の使用

CateogryClassInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のメソッド
 CateogryClassInternational CateogryClass.getCateogryClassInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

CateogryClassInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のメソッド
 void CateogryClass.putInternational(Locale locale, CateogryClassInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CateogryClass (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス CateogryClass

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass
すべての実装インタフェース:
Serializable
public class CateogryClass
extends Object
implements Serializable

分類区分の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CateogryClass()
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
CateogryClassInternational | getCateogryClassInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
Locale[] | getLocales() この分類区分で管理している言語（ロケール）をすべて取得します。
String | getNotes() 備考を取得します。
void | putInternational(Locale locale, CateogryClassInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setNotes(String notes) 備考を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CateogryClass

public CateogryClass()
メソッドの詳細

getLocales

public Locale[] getLocales()
この分類区分で管理している言語（ロケール）をすべて取得します。

戻り値:
この分類区分で管理している言語（ロケール）

getCateogryClassInternational

public CateogryClassInternational getCateogryClassInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             CateogryClassInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CateogryClassInternational (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス CateogryClassInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational
すべての実装インタフェース:
Serializable
public class CateogryClassInternational
extends Object
implements Serializable

分類区分の国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CateogryClassInternational()
メソッドの概要
String | getName() 分類区分名を取得します。
void | setName(String name) 分類区分名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CateogryClassInternational

public CateogryClassInternational()
メソッドの詳細

getName

public String getName()
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
分類区分名を設定します。

パラメータ:
name - 分類区分名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
クラス
CateogryClass
CateogryClassInternational


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class

分類区分情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CateogryClass | 分類区分の基本属性のデータを取り扱います。
CateogryClassInternational | 分類区分の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の説明

分類区分情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.category.category_class クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class 分類区分情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.category_class により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.category_class のクラス
CateogryClassInternational
分類区分の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の使用

CategoryManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での CategoryManager の使用

CategoryManager を返す jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
static CategoryManager CategoryManager.getCategoryManager(String user, String group)
CategoryManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail の使用

CategoryDetail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での CategoryDetail の使用

CategoryDetail 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
abstract void | CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
abstract void | CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational の使用

CategoryDetailInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.detail 分類詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category.detail での CategoryDetailInternational の使用

CategoryDetailInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.category.detail のメソッド
 CategoryDetailInternational CategoryDetail.getCategoryDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。

CategoryDetailInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.category.detail のメソッド
 void CategoryDetail.putInternational(Locale locale, CategoryDetailInternational data)
指定された言語に対する国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CategoryDetail (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス CategoryDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail
すべての実装インタフェース:
Serializable
public class CategoryDetail
extends Object
implements Serializable

分類区分詳細の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CategoryDetail()
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
CategoryDetailInternational | getCategoryDetailInternational(Locale locale) 指定された言語に対する国際化情報を取得します。
Locale[] | getLocales() この分類区分詳細で管理している言語（ロケール）をすべて取得します。
String | getNotes() 備考を取得します。
void | putInternational(Locale locale, CategoryDetailInternational data) 指定された言語に対する国際化情報を設定します。
void | removeInternational(Locale locale) 指定された言語に対する国際化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setNotes(String notes) 備考を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryDetail

public CategoryDetail()
メソッドの詳細

getLocales

public Locale[] getLocales()
この分類区分詳細で管理している言語（ロケール）をすべて取得します。

戻り値:
この分類区分詳細で管理している言語（ロケール）

getCategoryDetailInternational

public CategoryDetailInternational getCategoryDetailInternational(Locale locale)
指定された言語に対する国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
国際化情報

putInternational

public void putInternational(Locale locale,
                             CategoryDetailInternational data)
指定された言語に対する国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 国際化情報

removeInternational

public void removeInternational(Locale locale)
指定された言語に対する国際化情報を削除します。

パラメータ:
locale - 言語（ロケール）

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailInternational (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス CategoryDetailInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational
すべての実装インタフェース:
Serializable
public class CategoryDetailInternational
extends Object
implements Serializable

分類区分詳細の国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CategoryDetailInternational()
メソッドの概要
String | getName() 分類名を取得します。
void | setName(String name) 分類名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryDetailInternational

public CategoryDetailInternational()
メソッドの詳細

getName

public String getName()
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
分類名を設定します。

パラメータ:
name - 分類名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category.detail (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.category.detail
クラス
CategoryDetail
CategoryDetailInternational


jp.co.intra_mart.foundation.datastore.application.domain.category.detail (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail

分類詳細情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CategoryDetail | 分類区分詳細の基本属性のデータを取り扱います。
CategoryDetailInternational | 分類区分詳細の国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の説明

分類詳細情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.category.detail クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category.detail の使用

jp.co.intra_mart.foundation.datastore.application.domain.category.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail | 分類詳細情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.detail のクラス
CategoryDetail
分類区分詳細の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.category.detail により使用される jp.co.intra_mart.foundation.datastore.application.domain.category.detail のクラス
CategoryDetailInternational
分類区分詳細の国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CategoryManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.category
クラス CategoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager
public abstract class CategoryManager
extends Object

分類に関連する情報を管理します。 このクラスのインスタンスは必ず getCategoryManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
CategoryManager()
メソッドの概要
abstract void | addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。
static CategoryManager | getCategoryManager(String user, String group) CategoryManagerを取得します。
protected abstract void | init(String user, String group) CategoryManagerを初期化します。
abstract void | updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CategoryManager

public CategoryManager()
メソッドの詳細

getCategoryManager

public static CategoryManager getCategoryManager(String user,
                                                 String group)
                                          throws ManagerException
CategoryManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCategoryManager
例外:
ManagerException - CategoryManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
CategoryManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - CategoryManagerの初期化に失敗

addCategoryDetail

public abstract void addCategoryDetail(CategoryDetail categoryDetail)
                                throws ManagerException
分類区分詳細を登録します。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の登録に失敗

updateCategoryDetail

public abstract void updateCategoryDetail(CategoryDetail categoryDetail)
                                   throws ManagerException
登録済の分類区分詳細を更新します。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の更新に失敗

deleteCategoryDetail

public abstract void deleteCategoryDetail(CategoryDetail categoryDetail)
                                   throws ManagerException
登録済の分類区分詳細を削除します。
指定された分類区分詳細の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
categoryDetail - 分類区分詳細情報
例外:
ManagerException - 分類区分詳細の削除に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.category (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.category
クラス
CategoryManager


jp.co.intra_mart.foundation.datastore.application.domain.category (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category

分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CategoryManager 分類に関連する情報を管理します。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の説明

分類情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.category クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category 分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.category のクラス
CategoryManager
分類に関連する情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach の使用

DepartmentAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentAttach の使用

DepartmentAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | CompanyManager.deleteMember(DepartmentAttach attach) 組織から人員をはずします。
void | CompanyChangedListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での DepartmentAttach の使用

DepartmentAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable の使用

DepartmentAttachTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.attach 組織所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach での DepartmentAttachTerminable の使用

DepartmentAttachTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentAttachTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
 void DepartmentAttach.putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DepartmentAttach (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス DepartmentAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach
すべての実装インタフェース:
Serializable
public class DepartmentAttach
extends Object
implements Serializable

組織所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentAttach()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
DepartmentAttachTerminable | getDepartmentAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentAttachTerminable | getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getDepartmentCode() 組織コードを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() この組織所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentAttach

public DepartmentAttach()
メソッドの詳細

getTerms

public Term[] getTerms()
この組織所属で管理している期間をすべて取得します。

戻り値:
この組織所属で管理している期間

getDepartmentAttachTerminable

public DepartmentAttachTerminable getDepartmentAttachTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentAttachTerminable

public DepartmentAttachTerminable getDepartmentAttachTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentAttachTerminable

public void putDepartmentAttachTerminable(Term term,
                                          DepartmentAttachTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentAttachTerminable

public void removeDepartmentAttachTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス DepartmentAttachTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable
すべての実装インタフェース:
Serializable
public class DepartmentAttachTerminable
extends Object
implements Serializable

組織所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentAttachTerminable()
メソッドの概要
String | getPostCode() 役職CDを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentAttachTerminable

public DepartmentAttachTerminable()
メソッドの詳細

getPostCode

public String getPostCode()
役職CDを取得します。

戻り値:
役職CD

setPostCode

public void setPostCode(String postCode)
役職CDを設定します。

パラメータ:
postCode - 役職CD
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.attach (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.company.attach
クラス
DepartmentAttach
DepartmentAttachTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.attach (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach

組織所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DepartmentAttach | 組織所属の基本属性のデータを取り扱います。
DepartmentAttachTerminable | 組織所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の説明

組織所属情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.company.attach クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttach
組織所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttachTerminable
組織所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.attach のクラス
DepartmentAttach
組織所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory の使用

CompanyCategory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyCategory の使用

CompanyCategory 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | CompanyManager.removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
void | CompanyChangedListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyCategory の使用

CompanyCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable の使用

CompanyCategoryTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.category 会社分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category での CompanyCategoryTerminable の使用

CompanyCategoryTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyCategoryTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
 void CompanyCategory.putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CompanyCategory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス CompanyCategory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory
すべての実装インタフェース:
Serializable
public class CompanyCategory
extends Object
implements Serializable

会社組織分類の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyCategory()
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
CompanyCategoryTerminable | getCompanyCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyCategoryTerminable | getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
Term[] | getTerms() この会社組織分類で管理している期間をすべて取得します。
void | putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyCategory

public CompanyCategory()
メソッドの詳細

getTerms

public Term[] getTerms()
この会社組織分類で管理している期間をすべて取得します。

戻り値:
この会社組織分類で管理している期間

getCompanyCategoryTerminable

public CompanyCategoryTerminable getCompanyCategoryTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyCategoryTerminable

public CompanyCategoryTerminable getCompanyCategoryTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyCategoryTerminable

public void putCompanyCategoryTerminable(Term term,
                                         CompanyCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyCategoryTerminable

public void removeCompanyCategoryTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス CompanyCategoryTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable
すべての実装インタフェース:
Serializable
public class CompanyCategoryTerminable
extends Object
implements Serializable

会社組織分類の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyCategoryTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyCategoryTerminable

public CompanyCategoryTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.category (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.company.category
クラス
CompanyCategory
CompanyCategoryTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.category (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category

会社分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CompanyCategory | 会社組織分類の基本属性のデータを取り扱います。
CompanyCategoryTerminable | 会社組織分類の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の説明

会社分類情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.company.category クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategory
会社組織分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategoryTerminable
会社組織分類の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.category のクラス
CompanyCategory
会社組織分類の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener の使用

CompanyChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での CompanyChangedListener の使用

CompanyChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class CompanyChangedMenuListener
会社・組織に関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter の使用

CompanyImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyImporter の使用

CompanyImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
 class StandardCompanyImporter
会社のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の使用

CompanyManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyManager の使用

CompanyManager を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
static CompanyManager CompanyManager.getCompanyManager(String user, String group)
CompanyManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter の使用

CompanyPostImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyPostImporter の使用

CompanyPostImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
 class StandardCompanyPostImporter
役職のインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct の使用

DepartmentStruct を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentStruct の使用

DepartmentStruct を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract  DepartmentStruct[] CompanyManager.getDepartmentStructs(String company, String department, Date date, Locale locale)
組織の階層構造を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company の使用

Company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Company の使用

Company 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addCompany(Company company) 会社を登録します。
abstract void | CompanyManager.deleteCompany(Company company) 登録済の会社を削除します。
void | CompanyChangedListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での Company の使用

Company 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable の使用

CompanyTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での CompanyTerminable の使用

CompanyTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
CompanyTerminable | Company.getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyTerminable | Company.getCompanyTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 void Company.putCompanyTerminable(Term term, CompanyTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational の使用

CompanyTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での CompanyTerminableInternational の使用

CompanyTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 CompanyTerminableInternational CompanyTerminable.getCompanyTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

CompanyTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 void CompanyTerminable.putCompanyTerminableInternational(Locale locale, CompanyTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Company (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス Company

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company
すべての実装インタフェース:
Serializable
public class Company
extends Object
implements Serializable

会社の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Company()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
CompanyTerminable | getCompanyTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyTerminable | getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() この会社で管理している期間をすべて取得します。
void | putCompanyTerminable(Term term, CompanyTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Company

public Company()
メソッドの詳細

getTerms

public Term[] getTerms()
この会社で管理している期間をすべて取得します。

戻り値:
この会社で管理している期間

getCompanyTerminable

public CompanyTerminable getCompanyTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyTerminable

public CompanyTerminable getCompanyTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyTerminable

public void putCompanyTerminable(Term term,
                                 CompanyTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyTerminable

public void removeCompanyTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス CompanyTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable
すべての実装インタフェース:
Serializable
public class CompanyTerminable
extends Object
implements Serializable

会社の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyTerminable()
メソッドの概要
CompanyTerminableInternational | getCompanyTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() この会社で管理している言語（ロケール）をすべて取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
void | putCompanyTerminableInternational(Locale locale, CompanyTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyTerminable

public CompanyTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この会社で管理している言語（ロケール）をすべて取得します。

戻り値:
この会社で管理している言語（ロケール）

getCompanyTerminableInternational

public CompanyTerminableInternational getCompanyTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putCompanyTerminableInternational

public void putCompanyTerminableInternational(Locale locale,
                                              CompanyTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyTerminableInternational (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス CompanyTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational
すべての実装インタフェース:
Serializable
public class CompanyTerminableInternational
extends Object
implements Serializable

会社の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyTerminableInternational()
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyTerminableInternational

public CompanyTerminableInternational()
メソッドの詳細

getName

public String getName()
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
組織名を設定します。

パラメータ:
name - 組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
住所1を設定します。

パラメータ:
address1 - 住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
住所2を設定します。

パラメータ:
address2 - 住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.company (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.company.company
クラス
Company
CompanyTerminable
CompanyTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.company (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company

会社情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Company | 会社の基本属性のデータを取り扱います。
CompanyTerminable | 会社の期間化属性のデータを取り扱います。
CompanyTerminableInternational | 会社の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の説明

会社情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.company.company クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.company の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
Company
会社の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
CompanyTerminable
会社の期間化属性のデータを取り扱います。
CompanyTerminableInternational
会社の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.company のクラス
Company
会社の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department の使用

Department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Department の使用

Department 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addDepartment(Department department) 組織を登録します。
abstract void | CompanyManager.updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | CompanyManager.deleteDepartment(Department department) 登録済の組織情報を削除します。
void | CompanyChangedListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での Department の使用

Department 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable の使用

DepartmentTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department 組織情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での DepartmentTerminable の使用

DepartmentTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
DepartmentTerminable | Department.getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentTerminable | Department.getDepartmentTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 void Department.putDepartmentTerminable(Term term, DepartmentTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational の使用

DepartmentTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department 組織情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での DepartmentTerminableInternational の使用

DepartmentTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 DepartmentTerminableInternational DepartmentTerminable.getDepartmentTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

DepartmentTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 void DepartmentTerminable.putDepartmentTerminableInternational(Locale locale, DepartmentTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Department (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス Department

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department
すべての実装インタフェース:
Serializable
public class Department
extends Object
implements Serializable

組織の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Department()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
DepartmentTerminable | getDepartmentTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentTerminable | getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() この組織で管理している期間をすべて取得します。
void | putDepartmentTerminable(Term term, DepartmentTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDepartmentTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Department

public Department()
メソッドの詳細

getTerms

public Term[] getTerms()
この組織で管理している期間をすべて取得します。

戻り値:
この組織で管理している期間

getDepartmentTerminable

public DepartmentTerminable getDepartmentTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentTerminable

public DepartmentTerminable getDepartmentTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentTerminable

public void putDepartmentTerminable(Term term,
                                    DepartmentTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentTerminable

public void removeDepartmentTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス DepartmentTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable
すべての実装インタフェース:
Serializable
public class DepartmentTerminable
extends Object
implements Serializable

組織の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentTerminable()
メソッドの概要
String | getCountryCode() 国コードを取得します。
DepartmentTerminableInternational | getDepartmentTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() この組織で管理している言語（ロケール）をすべて取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
void | putDepartmentTerminableInternational(Locale locale, DepartmentTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentTerminable

public DepartmentTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この組織で管理している言語（ロケール）をすべて取得します。

戻り値:
この組織で管理している言語（ロケール）

getDepartmentTerminableInternational

public DepartmentTerminableInternational getDepartmentTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putDepartmentTerminableInternational

public void putDepartmentTerminableInternational(Locale locale,
                                                 DepartmentTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス1を取得します。

戻り値:
メールアドレス1

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1

getEmailAddress2

public String getEmailAddress2()
メールアドレス2を取得します。

戻り値:
メールアドレス2

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableInternational (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス DepartmentTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational
すべての実装インタフェース:
Serializable
public class DepartmentTerminableInternational
extends Object
implements Serializable

組織の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentTerminableInternational()
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentTerminableInternational

public DepartmentTerminableInternational()
メソッドの詳細

getName

public String getName()
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
組織名を設定します。

パラメータ:
name - 組織名

getNameSyllabary

public String getNameSyllabary()
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ

getNameEnglish

public String getNameEnglish()
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字

getAddress1

public String getAddress1()
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
住所1を設定します。

パラメータ:
address1 - 住所1

getAddress2

public String getAddress2()
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
住所2を設定します。

パラメータ:
address2 - 住所2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.department (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.company.department
クラス
Department
DepartmentTerminable
DepartmentTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.department (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department

組織情報を操作するクラスを提供します。

参照:
説明

クラスの概要
Department | 組織の基本属性のデータを取り扱います。
DepartmentTerminable | 組織の期間化属性のデータを取り扱います。
DepartmentTerminableInternational | 組織の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の説明

組織情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.company.department クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.department の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.department により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
DepartmentTerminable
組織の期間化属性のデータを取り扱います。
DepartmentTerminableInternational
組織の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.department のクラス
Department
組織の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain の使用

DepartmentMain を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での DepartmentMain の使用

DepartmentMain 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | CompanyManager.removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
void | CompanyChangedListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での DepartmentMain の使用

DepartmentMain 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable の使用

DepartmentMainTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.main 主所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main での DepartmentMainTerminable の使用

DepartmentMainTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Date date) 指定された日時に対する期間化情報を取得します。

DepartmentMainTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
 void DepartmentMain.putDepartmentMainTerminable(Term term, DepartmentMainTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DepartmentMain (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス DepartmentMain

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain
すべての実装インタフェース:
Serializable
public class DepartmentMain
extends Object
implements Serializable

主所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentMain()
メソッドの概要
DepartmentMainTerminable | getDepartmentMainTerminable(Date date) 指定された日時に対する期間化情報を取得します。
DepartmentMainTerminable | getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
Term[] | getTerms() この主所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putDepartmentMainTerminable(Term term, DepartmentMainTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentMain

public DepartmentMain()
メソッドの詳細

getTerms

public Term[] getTerms()
この主所属で管理している期間をすべて取得します。

戻り値:
この主所属で管理している期間

getDepartmentMainTerminable

public DepartmentMainTerminable getDepartmentMainTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getDepartmentMainTerminable

public DepartmentMainTerminable getDepartmentMainTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putDepartmentMainTerminable

public void putDepartmentMainTerminable(Term term,
                                        DepartmentMainTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeDepartmentMainTerminable

public void removeDepartmentMainTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス DepartmentMainTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable
すべての実装インタフェース:
Serializable
public class DepartmentMainTerminable
extends Object
implements Serializable

主所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentMainTerminable()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentMainTerminable

public DepartmentMainTerminable()
メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
組織コード

setDepartmentCode

public void setDepartmentCode(String departmentCode)
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.main (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.company.main
クラス
DepartmentMain
DepartmentMainTerminable


jp.co.intra_mart.foundation.datastore.application.domain.company.main (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main

主所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
DepartmentMain | 主所属の基本属性のデータを取り扱います。
DepartmentMainTerminable | 主所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の説明

主所属情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.company.main クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.main の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.main を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMain
主所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.main により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMainTerminable
主所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.main のクラス
DepartmentMain
主所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost の使用

CompanyPost を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyPost の使用

CompanyPost 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addPost(CompanyPost post) 役職を登録します。
abstract void | CompanyManager.updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | CompanyManager.deletePost(CompanyPost post) 登録済の役職情報を削除します。
void | CompanyChangedListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyPost の使用

CompanyPost 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable の使用

CompanyPostTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post 役職情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での CompanyPostTerminable の使用

CompanyPostTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Date date) 指定された日時に対する期間化情報を取得します。

CompanyPostTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 void CompanyPost.putCompanyPostTerminable(Term term, CompanyPostTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational の使用

CompanyPostTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post 役職情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での CompanyPostTerminableInternational の使用

CompanyPostTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 CompanyPostTerminableInternational CompanyPostTerminable.getCompanyPostTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

CompanyPostTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 void CompanyPostTerminable.putCompanyPostTerminableInternational(Locale locale, CompanyPostTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost の使用

PlainCompanyPost を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company 会社情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での PlainCompanyPost の使用

PlainCompanyPost を返す jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Date date) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsInCompany(String company, Date date, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Date date) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Locale locale) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | CompanyManager.getPostsOfUser(String company, String user, Date date, Locale locale) ユーザに設定された役職をすべて取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CompanyPost (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost
すべての実装インタフェース:
Serializable
public class CompanyPost
extends Object
implements Serializable

役職の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPost()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
CompanyPostTerminable | getCompanyPostTerminable(Date date) 指定された日時に対する期間化情報を取得します。
CompanyPostTerminable | getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() この役職で管理している期間をすべて取得します。
void | putCompanyPostTerminable(Term term, CompanyPostTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setNotes(String notes) 備考を設定します。
void | setPostCode(String postCode) 役職コードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPost

public CompanyPost()
メソッドの詳細

getTerms

public Term[] getTerms()
この役職で管理している期間をすべて取得します。

戻り値:
この役職で管理している期間

getCompanyPostTerminable

public CompanyPostTerminable getCompanyPostTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getCompanyPostTerminable

public CompanyPostTerminable getCompanyPostTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putCompanyPostTerminable

public void putCompanyPostTerminable(Term term,
                                     CompanyPostTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeCompanyPostTerminable

public void removeCompanyPostTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
役職コード

setPostCode

public void setPostCode(String postCode)
役職コードを設定します。

パラメータ:
postCode - 役職コード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPostTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable
すべての実装インタフェース:
Serializable
public class CompanyPostTerminable
extends Object
implements Serializable

役職の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPostTerminable()
メソッドの概要
CompanyPostTerminableInternational | getCompanyPostTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
Locale[] | getLocales() この役職で管理している言語（ロケール）をすべて取得します。
void | putCompanyPostTerminableInternational(Locale locale, CompanyPostTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostTerminable

public CompanyPostTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
この役職で管理している言語（ロケール）をすべて取得します。

戻り値:
この役職で管理している言語（ロケール）

getCompanyPostTerminableInternational

public CompanyPostTerminableInternational getCompanyPostTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putCompanyPostTerminableInternational

public void putCompanyPostTerminableInternational(Locale locale,
                                                  CompanyPostTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableInternational (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
クラス CompanyPostTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational
すべての実装インタフェース:
Serializable
public class CompanyPostTerminableInternational
extends Object
implements Serializable

役職の期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyPostTerminableInternational()
メソッドの概要
String | getName() 役職名を取得します。
void | setName(String name) 役職名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyPostTerminableInternational

public CompanyPostTerminableInternational()
メソッドの詳細

getName

public String getName()
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
役職名を設定します。

パラメータ:
name - 役職名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.post (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.company.post
インタフェース
PlainCompanyPost
クラス
CompanyPost
CompanyPostTerminable
CompanyPostTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.company.post (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post

役職情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PlainCompanyPost 役職データを扱います。

クラスの概要
CompanyPost | 役職の基本属性のデータを取り扱います。
CompanyPostTerminable | 役職の期間化属性のデータを取り扱います。
CompanyPostTerminableInternational | 役職の期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の説明

役職情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.company.post クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational (implements java.io.Serializable)

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.post の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.post を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPost
役職の基本属性のデータを取り扱います。
PlainCompanyPost
役職データを扱います。

jp.co.intra_mart.foundation.datastore.application.domain.company.post により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPostTerminable
役職の期間化属性のデータを取り扱います。
CompanyPostTerminableInternational
役職の期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.post のクラス
CompanyPost
役職の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PlainCompanyPost (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.post
インタフェース PlainCompanyPost

すべてのスーパーインタフェース:
Serializable
public interface PlainCompanyPost
extends Serializable

役職データを扱います。

導入されたバージョン:
5.0

メソッドの概要
Date | getActivationDate() 役職情報の有効開始日を取得します。
String | getCompanyCode() 会社コードを取得します。
Date | getExpirationDate() 役職情報の有効終了日を取得します。
Locale | getLocale() 役職名の言語を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
String | getPostName() 役職名を取得します。
int | getSortKey() ソートキーを取得します。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
役職コード

getPostName

public String getPostName()
役職名を取得します。

戻り値:
役職名

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

getActivationDate

public Date getActivationDate()
役職情報の有効開始日を取得します。

戻り値:
有効開始日

getExpirationDate

public Date getExpirationDate()
役職情報の有効終了日を取得します。

戻り値:
有効終了日

getLocale

public Locale getLocale()
役職名の言語を取得します。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion の使用

CompanyVersion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での CompanyVersion の使用

CompanyVersion 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | CompanyManager.updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
abstract void | CompanyManager.deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
void | CompanyChangedListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での CompanyVersion の使用

CompanyVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | CompanyChangedMenuListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CompanyVersion (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company.version
クラス CompanyVersion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion
すべての実装インタフェース:
Serializable
public class CompanyVersion
extends Object
implements Serializable

会社構成バージョンの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
CompanyVersion()
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
void | setVersionCode(String versionCode) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyVersion

public CompanyVersion()
メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
会社コード

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します。

パラメータ:
companyCode - 会社コード

getVersionCode

public String getVersionCode()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCode

public void setVersionCode(String versionCode)
バージョンコードを設定します。

パラメータ:
versionCode - バージョンコード

getStartDate

public Date getStartDate()
開始日を取得します。

戻り値:
開始日

setStartDate

public void setStartDate(Date startDate)
開始日を設定します。

パラメータ:
startDate - 開始日

getEndDate

public Date getEndDate()
終了日を取得します。

戻り値:
終了日

setEndDate

public void setEndDate(Date endDate)
終了日を設定します。

パラメータ:
endDate - 終了日

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company.version (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.company.version
クラス
CompanyVersion


jp.co.intra_mart.foundation.datastore.application.domain.company.version (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version

バーション情報を操作するクラスを提供します。

参照:
説明

クラスの概要
CompanyVersion 会社構成バージョンの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の説明

バーション情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.company.version クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company.version の使用

jp.co.intra_mart.foundation.datastore.application.domain.company.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.version のクラス
CompanyVersion
会社構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company.version のクラス
CompanyVersion
会社構成バージョンの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CompanyChangedListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyChangedListener

既知の実装クラスの一覧:
CompanyChangedMenuListener
public interface CompanyChangedListener

会社・組織に関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。
void | postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         Company company)
                  throws ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           Company company)
                    throws ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            Department department)
                     throws ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              CompanyCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  CompanyCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      DepartmentAttach attach)
               throws ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          DepartmentAttach attach)
                   throws ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    DepartmentMain main)
             throws ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        DepartmentMain main)
                 throws ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         CompanyVersion version)
                  throws ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      CompanyPost post)
               throws ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyImporter

既知の実装クラスの一覧:
StandardCompanyImporter
public interface CompanyImporter

会社のインポートのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス CompanyManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
public abstract class CompanyManager
extends Object

会社や組織に関連する情報を管理します。 このクラスのインスタンスは必ず getCompanyManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
CompanyManager()
メソッドの概要
abstract void | addCompany(Company company) 会社を登録します。
abstract void | addDepartment(Department department) 組織を登録します。
abstract void | addPost(CompanyPost post) 役職を登録します。
abstract void | addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
abstract void | deleteCompany(Company company) 登録済の会社を削除します。
abstract void | deleteDepartment(Department department) 登録済の組織情報を削除します。
abstract void | deleteMember(DepartmentAttach attach) 組織から人員をはずします。
abstract void | deletePost(CompanyPost post) 登録済の役職情報を削除します。
abstract void | deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
static CompanyManager | getCompanyManager(String user, String group) CompanyManagerを取得します。
abstract DepartmentStruct[] | getDepartmentStructs(String company, String department, Date date, Locale locale) 組織の階層構造を取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Date date) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Date date, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsInCompany(String company, Locale locale) 会社に登録済の役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Date date) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Date date, Locale locale) ユーザに設定された役職をすべて取得します。
abstract PlainCompanyPost[] | getPostsOfUser(String company, String user, Locale locale) ユーザに設定された役職をすべて取得します。
protected abstract void | init(String user, String group) CompanyManagerを初期化します。
abstract void | joinDepartment(String company, String parentDepartment, String department, String version) 組織構成に組織を登録します。
abstract void | leaveDepartment(String company, String department, String version) 組織構成から組織情報を離脱させます。
abstract void | moveDepartment(String company, String parentDepartment, String department, String version) 組織構成に登録済の組織情報を移動します。
abstract void | removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
abstract void | removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
abstract void | setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyManager

public CompanyManager()
メソッドの詳細

getCompanyManager

public static CompanyManager getCompanyManager(String user,
                                               String group)
                                        throws ManagerException
CompanyManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCompanyManager
例外:
ManagerException - CompanyManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
CompanyManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addCompany

public abstract void addCompany(Company company)
                         throws ManagerException
会社を登録します。 このメソッドを実行すると下記のような動作が行われます。
  1. 会社を新規登録する。
  2. 会社に対応する組織を新規登録する。

パラメータ:
company - 会社情報
例外:
ManagerException - 会社の新規登録に失敗

deleteCompany

public abstract void deleteCompany(Company company)
                            throws ManagerException
登録済の会社を削除します。 このメソッドを実行すると指定された会社に関連する全ての情報が削除されます。
指定された会社の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
company - 会社
例外:
ManagerException - 会社の削除に失敗

addDepartment

public abstract void addDepartment(Department department)
                            throws ManagerException
組織を登録します。
このメソッドを実行しただけではまだ会社の組織構成には追加されていません。
組織構成に追加したい場合は joinDepartment(String, String, String, String) を使用してください。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織の登録に失敗

updateDepartment

public abstract void updateDepartment(Department department)
                               throws ManagerException
登録済の組織情報を更新します。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織情報の更新に失敗

deleteDepartment

public abstract void deleteDepartment(Department department)
                               throws ManagerException
登録済の組織情報を削除します。
指定された組織情報が存在しない場合は ManagerException がスローされます。

パラメータ:
department - 組織情報
例外:
ManagerException - 組織情報の削除に失敗

joinDepartment

public abstract void joinDepartment(String company,
                                    String parentDepartment,
                                    String department,
                                    String version)
                             throws ManagerException
組織構成に組織を登録します。
新しく親となる組織と登録対象の組織は同一の会社に所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。
選択された組織が対象のバージョンにおいて既に登録されているときはこのメソッドは使用できません。

パラメータ:
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 新規登録する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織構成に組織の登録の失敗

moveDepartment

public abstract void moveDepartment(String company,
                                    String parentDepartment,
                                    String department,
                                    String version)
                             throws ManagerException
組織構成に登録済の組織情報を移動します。
新しく上位となる組織と移動対象の組織は同一の会社に所属している必要があります。

また、組織構成が循環するような移動はできません。
バージョンコードは登録済みのものを指定する必要があります。

パラメータ:
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織の移動の失敗

leaveDepartment

public abstract void leaveDepartment(String company,
                                     String department,
                                     String version)
                              throws ManagerException
組織構成から組織情報を離脱させます。
このメソッドを実行すると、組織を対象バージョンから離脱させることができます。
指定された組織が子組織を持っていた場合、それらの組織も再帰的にこのバージョンから削除されます。
このメソッドを実行しても組織情報そのものは残ります。
指定された組織が組織構成に登録されていない場合は ManagerException がスローされます。

パラメータ:
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ManagerException - 組織構成から組織情報の離脱の失敗

setCategoryDetail

public abstract void setCategoryDetail(CompanyCategory category)
                                throws ManagerException
組織に対して指定された分類区分情報を設定します。

パラメータ:
category - 設定する分類区分詳細詳細情報
例外:
ManagerException - 分類区分情報の設定に失敗

removeCategoryDetail

public abstract void removeCategoryDetail(CompanyCategory category)
                                   throws ManagerException
組織に対して指定された分類区分情報を削除します。
指定された分類区分情報が存在しない場合は ManagerException がスローされます。

パラメータ:
category - 削除する分類区分詳細詳細情報
例外:
ManagerException - 分類区分情報の削除に失敗

setMember

public abstract void setMember(DepartmentAttach attach)
                        throws ManagerException
組織に人員を割り当てます。
人員の割当情報はパラメータで渡された情報で完全に上書きされます。

パラメータ:
attach - 割当人員の情報
例外:
ManagerException - 人員の割当に失敗

deleteMember

public abstract void deleteMember(DepartmentAttach attach)
                           throws ManagerException
組織から人員をはずします。
指定された人員が組織に割り当てられていない場合は ManagerException がスローされます。

パラメータ:
attach - 組織から外す人員の情報
例外:
ManagerException - 人員の削除に失敗

setMain

public abstract void setMain(DepartmentMain main)
                      throws ManagerException
ユーザが主所属する組織を設定します。
既存の主所属情報は新しい情報で上書きされます。

パラメータ:
main - 主所属情報
例外:
ManagerException - 主所属する組織の設定に失敗

removeMain

public abstract void removeMain(DepartmentMain main)
                         throws ManagerException
指定されたユーザの主所属を削除します。
指定されたユーザの主所属の情報が存在しない場合は ManagerException がスローされます。

パラメータ:
main - 主所属情報
例外:
ManagerException - 主所属の削除の失敗

addVersion

public abstract void addVersion(CompanyVersion version)
                         throws ManagerException
会社構成バージョンを新規に登録します。
追加された構成バージョンのトップレベルには、会社に該当する組織が追加されます。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの新規登録に失敗

updateVersion

public abstract void updateVersion(CompanyVersion version)
                            throws ManagerException
登録済の会社構成バージョンを更新します。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの更新に失敗

deleteVersion

public abstract void deleteVersion(CompanyVersion version)
                            throws ManagerException
登録済の会社構成バージョンを削除します。
指定された会社構成バージョンの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
version - バージョン情報
例外:
ManagerException - 会社構成バージョンの削除に失敗

copyVersion

public abstract void copyVersion(String company,
                                 String srcVersion,
                                 String destVersion,
                                 Term term)
                          throws ManagerException
登録済の会社構成バージョンの内容をコピーします。
コピー元の会社構成バージョンに関連する、全ての組織内包がコピー先の会社構成バージョンに関連づくようにコピーされます。
コピー元のバージョンコードは登録済みのものを選択してください
コピー先のバージョンコードは登録されていないものを選択してください

パラメータ:
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ManagerException - 会社構成バージョンのコピーに失敗

getDepartmentStructs

public abstract DepartmentStruct[] getDepartmentStructs(String company,
                                                        String department,
                                                        Date date,
                                                        Locale locale)
                                                 throws ManagerException
組織の階層構造を取得します。
指定された日付に該当する会社構成バージョンが存在しない場合は、ManagerException がスローされます。
また、会社構成バージョンは存在するが該当する組織情報が存在しない場合は空の配列を返します。

パラメータ:
company - 会社コード
department - 組織コード
date - 日付
locale - 言語(ロケール)
戻り値:
組織の階層構造
例外:
ManagerException - 組織の階層構造の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company)
会社に登録済の役職をすべて取得します。
役職を特定するためにシステム日付、ログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Date date)
会社に登録済の役職をすべて取得します。
役職を特定するためにログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
date - 役職情報を特定するための日付
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Locale locale)
会社に登録済の役職をすべて取得します。
役職を特定するためにシステム日付を使用します。

パラメータ:
company - 会社コード
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsInCompany

public abstract PlainCompanyPost[] getPostsInCompany(String company,
                                                     Date date,
                                                     Locale locale)
会社に登録済の役職をすべて取得します。

パラメータ:
company - 会社コード
date - 役職情報を特定するための日付
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user)
ユーザに設定された役職をすべて取得します。
役職を特定するためにシステム日付、ログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Date date)
ユーザに設定された役職をすべて取得します。
役職を特定するためにログインユーザのデフォルト言語を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
date - 役職情報を特定するための日付
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Locale locale)
ユーザに設定された役職をすべて取得します。
役職を特定するためにシステム日付を使用します。

パラメータ:
company - 会社コード
user - ユーザコード
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

getPostsOfUser

public abstract PlainCompanyPost[] getPostsOfUser(String company,
                                                  String user,
                                                  Date date,
                                                  Locale locale)
ユーザに設定された役職をすべて取得します。

パラメータ:
company - 会社コード
user - ユーザコード
date - 役職情報を特定するための日付
locale - 役職情報を特定するための言語
戻り値:
会社に登録済の役職
例外:
ManagerException - 役職情報の取得に失敗

addPost

public abstract void addPost(CompanyPost post)
                      throws ManagerException
役職を登録します。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の登録に失敗

updatePost

public abstract void updatePost(CompanyPost post)
                         throws ManagerException
登録済の役職情報を更新します。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の更新に失敗

deletePost

public abstract void deletePost(CompanyPost post)
                         throws ManagerException
登録済の役職情報を削除します。
指定された役職情報が存在しない場合は ManagerException がスローされます。

パラメータ:
post - 役職情報
例外:
ManagerException - 役職の削除に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース CompanyPostImporter

既知の実装クラスの一覧:
StandardCompanyPostImporter
public interface CompanyPostImporter

役職のインポートのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException - インポート時に例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentStruct (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース DepartmentStruct

public interface DepartmentStruct

組織の階層です。

導入されたバージョン:
5.0

メソッドの概要
String | getCompanyCode() 会社コードを取得する。
String | getDepartmentCode() 組織コードを取得する。
String | getName() 会社名または組織名を取得する。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得する。

戻り値:
会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得する。

戻り値:
組織コード

getName

public String getName()
会社名または組織名を取得する。

戻り値:
会社名または組織名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.company (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.company
インタフェース
CompanyChangedListener
CompanyImporter
CompanyPostImporter
DepartmentStruct
クラス
CompanyManager
StandardCompanyImporter
StandardCompanyPostImporter


jp.co.intra_mart.foundation.datastore.application.domain.company (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company

会社情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
CompanyChangedListener | 会社・組織に関する情報の変更時のリスナーです。
CompanyImporter | 会社のインポートのインターフェースです。
CompanyPostImporter | 役職のインポートのインターフェースです。
DepartmentStruct | 組織の階層です。

クラスの概要
CompanyManager | 会社や組織に関連する情報を管理します。
StandardCompanyImporter | 会社のインポートを行います。
StandardCompanyPostImporter | 役職のインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の説明

会社情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.company クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company の使用

jp.co.intra_mart.foundation.datastore.application.domain.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
CompanyImporter
会社のインポートのインターフェースです。
CompanyManager
会社や組織に関連する情報を管理します。
CompanyPostImporter
役職のインポートのインターフェースです。
DepartmentStruct
組織の階層です。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.company のクラス
CompanyChangedListener
会社・組織に関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StandardCompanyImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス StandardCompanyImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter
すべての実装インタフェース:
CompanyImporter
public class StandardCompanyImporter
extends Object
implements CompanyImporter

会社のインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardCompanyImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCompanyImporter

public StandardCompanyImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース CompanyImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardCompanyPostImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.company
クラス StandardCompanyPostImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter
すべての実装インタフェース:
CompanyPostImporter
public class StandardCompanyPostImporter
extends Object
implements CompanyPostImporter

役職のインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardCompanyPostImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCompanyPostImporter

public StandardCompanyPostImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース CompanyPostImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach の使用

PrivateGroupAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroupAttach の使用

PrivateGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract void | PrivateGroupManager.setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | PrivateGroupManager.deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。
void | PrivateGroupChangedListener.memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
クラス
PrivateGroupAttach


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach

プライベートグループ所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PrivateGroupAttach プライベートグループ所属の基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の説明

プライベートグループ所属情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach のクラス
PrivateGroupAttach
プライベートグループ所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PrivateGroupAttach (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
クラス PrivateGroupAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach
すべての実装インタフェース:
Serializable
public class PrivateGroupAttach
extends Object
implements Serializable

プライベートグループ所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PrivateGroupAttach()
メソッドの概要
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setOwnerCode(String ownerCode) 所有者コードを設定します。
void | setPrivateGroupCode(String privateGroupCode) グループコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroupAttach

public PrivateGroupAttach()
メソッドの詳細

getOwnerCode

public String getOwnerCode()
所有者コードを取得します。

戻り値:
所有者コード

setOwnerCode

public void setOwnerCode(String ownerCode)
所有者コードを設定します。

パラメータ:
ownerCode - 所有者コード

getPrivateGroupCode

public String getPrivateGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPrivateGroupCode

public void setPrivateGroupCode(String privateGroupCode)
グループコードを設定します。

パラメータ:
privateGroupCode - グループコード

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の使用

PrivateGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroupManager の使用

PrivateGroupManager を返す jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
static PrivateGroupManager PrivateGroupManager.getPrivateGroupManager(String user, String group)
PrivateGroupManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup の使用

PrivateGroup を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での PrivateGroup の使用

PrivateGroup 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
abstract void | PrivateGroupManager.addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | PrivateGroupManager.updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
abstract void | PrivateGroupManager.deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
void | PrivateGroupChangedListener.privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
クラス
PrivateGroup


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group

プライベートグループ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PrivateGroup プライベートグループの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の説明

プライベートグループ情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.private_group.group クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group.group のクラス
PrivateGroup
プライベートグループの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PrivateGroup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
クラス PrivateGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup
すべての実装インタフェース:
Serializable
public class PrivateGroup
extends Object
implements Serializable

プライベートグループの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PrivateGroup()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
int | getSortKey() ソートキーを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setOwnerCode(String ownerCode) 所有者コードを設定します。
void | setPrivateGroupCode(String privateGroupCode) グループコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroup

public PrivateGroup()
メソッドの詳細

getOwnerCode

public String getOwnerCode()
所有者コードを取得します。

戻り値:
所有者コード

setOwnerCode

public void setOwnerCode(String ownerCode)
所有者コードを設定します。

パラメータ:
ownerCode - 所有者コード

getPrivateGroupCode

public String getPrivateGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPrivateGroupCode

public void setPrivateGroupCode(String privateGroupCode)
グループコードを設定します。

パラメータ:
privateGroupCode - グループコード

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.private_group (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.private_group
インタフェース
PrivateGroupChangedListener
クラス
PrivateGroupManager


jp.co.intra_mart.foundation.datastore.application.domain.private_group (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group

プライベートグループ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PrivateGroupChangedListener プライベートグループに関する情報の更新時のリスナーです。

クラスの概要
PrivateGroupManager プライベートグループに関連する情報を管理します。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の説明

プライベートグループ情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.private_group クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group の使用

jp.co.intra_mart.foundation.datastore.application.domain.private_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.private_group プライベートグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.private_group のクラス
PrivateGroupManager
プライベートグループに関連する情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PrivateGroupChangedListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group
インタフェース PrivateGroupChangedListener

public interface PrivateGroupChangedListener

プライベートグループに関する情報の更新時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | init(Map params) プライベートグループリスナーの初期化を行います。
void | memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。
void | privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。

メソッドの詳細

init

public void init(Map params)
プライベートグループリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

privateGroupAdded

public void privateGroupAdded(String groupId,
                              PrivateGroup group)
                       throws ChangedListenerException
プライベートグループがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

privateGroupUpdated

public void privateGroupUpdated(String groupId,
                                PrivateGroup group)
                         throws ChangedListenerException
プライベートグループがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

privateGroupDeleted

public void privateGroupDeleted(String groupId,
                                PrivateGroup group)
                         throws ChangedListenerException
プライベートグループがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
group - プライベートグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PrivateGroupAttach member)
               throws ChangedListenerException
プライベートグループ所属情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
member - プライベートグループ所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PrivateGroupAttach member)
                   throws ChangedListenerException
プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
member - プライベート所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.private_group
クラス PrivateGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager
public abstract class PrivateGroupManager
extends Object

プライベートグループに関連する情報を管理します。 このクラスのインスタンスは必ず getPrivateGroupManager(String, String) で取得してください。コンストラクタによる明示的な生成はできません。

導入されたバージョン:
5.0

コンストラクタの概要
PrivateGroupManager()
メソッドの概要
abstract void | addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。
abstract void | deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
static PrivateGroupManager | getPrivateGroupManager(String user, String group) PrivateGroupManagerを取得します。
protected abstract void | init(String user, String group) PrivateGroupManagerを初期化します。
abstract void | setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrivateGroupManager

public PrivateGroupManager()
メソッドの詳細

getPrivateGroupManager

public static PrivateGroupManager getPrivateGroupManager(String user,
                                                         String group)
                                                  throws ManagerException
PrivateGroupManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するPrivateGroupManager
例外:
ManagerException - PrivateGroupManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
PrivateGroupManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addPrivateGroup

public abstract void addPrivateGroup(PrivateGroup group)
                              throws ManagerException
プライベートグループを登録します。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの登録に失敗

updatePrivateGroup

public abstract void updatePrivateGroup(PrivateGroup group)
                                 throws ManagerException
登録済のプライベートグループ情報を更新します。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの更新に失敗

deletePrivateGroup

public abstract void deletePrivateGroup(PrivateGroup group)
                                 throws ManagerException
登録済のプライベートグループ情報を削除します。
指定されたプライベートグループ情報が存在しない場合は ManagerException がスローされます。

パラメータ:
group - プライベートグループ情報
例外:
ManagerException - プライベートグループの削除に失敗

setMember

public abstract void setMember(PrivateGroupAttach member)
                        throws ManagerException
プライベートグループに人員を割り当てます。

パラメータ:
member - プライベートグループに割り当てる人員の情報
例外:
ManagerException - プライベートグループへの人員の割り当てに失敗

deleteMember

public abstract void deleteMember(PrivateGroupAttach member)
                           throws ManagerException
プライベートグループから人員をはずします。
指定された人員がプライベートグループに割り当てられていない場合は ManagerException がスローされます。

パラメータ:
member - プライベートグループから削除する人員の情報
例外:
ManagerException - プライベートグループからの人員の削除に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach の使用

PublicGroupAttach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupAttach の使用

PublicGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | PublicGroupManager.deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
void | PublicGroupChangedListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupAttach の使用

PublicGroupAttach 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable の使用

PublicGroupAttachTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach パブリックグループ所属情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach での PublicGroupAttachTerminable の使用

PublicGroupAttachTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupAttachTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
 void PublicGroupAttach.putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス
PublicGroupAttach
PublicGroupAttachTerminable


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach

パブリックグループ所属情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupAttach | パブリックグループ所属の基本属性のデータを取り扱います。
PublicGroupAttachTerminable | パブリックグループ所属の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の説明

パブリックグループ所属情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttach
パブリックグループ所属の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttachTerminable
パブリックグループ所属の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のクラス
PublicGroupAttach
パブリックグループ所属の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupAttach (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス PublicGroupAttach

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach
すべての実装インタフェース:
Serializable
public class PublicGroupAttach
extends Object
implements Serializable

パブリックグループ所属の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupAttach()
メソッドの概要
PublicGroupAttachTerminable | getPublicGroupAttachTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupAttachTerminable | getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループ所属で管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
void | putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupAttach

public PublicGroupAttach()
メソッドの詳細

getTerms

public Term[] getTerms()
このパブリックグループ所属で管理している期間をすべて取得します。

戻り値:
このパブリックグループ所属で管理している期間

getPublicGroupAttachTerminable

public PublicGroupAttachTerminable getPublicGroupAttachTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupAttachTerminable

public PublicGroupAttachTerminable getPublicGroupAttachTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupAttachTerminable

public void putPublicGroupAttachTerminable(Term term,
                                           PublicGroupAttachTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupAttachTerminable

public void removePublicGroupAttachTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
クラス PublicGroupAttachTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupAttachTerminable
extends Object
implements Serializable

パブリックグループ所属の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupAttachTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupAttachTerminable

public PublicGroupAttachTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory の使用

PublicGroupCategory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupCategory の使用

PublicGroupCategory 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | PublicGroupManager.removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
void | PublicGroupChangedListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupCategory の使用

PublicGroupCategory 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable の使用

PublicGroupCategoryTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category パブリックグループ分類情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category での PublicGroupCategoryTerminable の使用

PublicGroupCategoryTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupCategoryTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
 void PublicGroupCategory.putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス
PublicGroupCategory
PublicGroupCategoryTerminable


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category

パブリックグループ分類情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupCategory | パブリックグループ分類の基本属性のデータを取り扱います。
PublicGroupCategoryTerminable | パブリックグループ分類の期間化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の説明

パブリックグループ分類情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.public_group.category クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategory
パブリックグループ分類の基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategoryTerminable
パブリックグループ分類の期間化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のクラス
PublicGroupCategory
パブリックグループ分類の基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupCategory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス PublicGroupCategory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory
すべての実装インタフェース:
Serializable
public class PublicGroupCategory
extends Object
implements Serializable

パブリックグループ分類の基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupCategory()
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
PublicGroupCategoryTerminable | getPublicGroupCategoryTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupCategoryTerminable | getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Term[] | getTerms() このパブリックグループ分類で管理している期間をすべて取得します。
void | putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setCategoryClassCode(String categoryClassCode) 分類区分コードを設定します。
void | setCategoryCode(String categoryCode) 分類コードを設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupCategory

public PublicGroupCategory()
メソッドの詳細

getTerms

public Term[] getTerms()
このパブリックグループ分類で管理している期間をすべて取得します。

戻り値:
このパブリックグループ分類で管理している期間

getPublicGroupCategoryTerminable

public PublicGroupCategoryTerminable getPublicGroupCategoryTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupCategoryTerminable

public PublicGroupCategoryTerminable getPublicGroupCategoryTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupCategoryTerminable

public void putPublicGroupCategoryTerminable(Term term,
                                             PublicGroupCategoryTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupCategoryTerminable

public void removePublicGroupCategoryTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getCategoryClassCode

public String getCategoryClassCode()
分類区分コードを取得します。

戻り値:
分類区分コード

setCategoryClassCode

public void setCategoryClassCode(String categoryClassCode)
分類区分コードを設定します。

パラメータ:
categoryClassCode - 分類区分コード

getCategoryCode

public String getCategoryCode()
分類コードを取得します。

戻り値:
分類コード

setCategoryCode

public void setCategoryCode(String categoryCode)
分類コードを設定します。

パラメータ:
categoryCode - 分類コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
クラス PublicGroupCategoryTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupCategoryTerminable
extends Object
implements Serializable

パブリックグループ分類の期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupCategoryTerminable()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupCategoryTerminable

public PublicGroupCategoryTerminable()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener の使用

PublicGroupChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での PublicGroupChangedListener の使用

PublicGroupChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class PublicGroupChangedMenuListener
パブリックグループに関する情報の変更時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter の使用

PublicGroupImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupImporter の使用

PublicGroupImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
 class StandardPublicGroupImporter
パブリックグループのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の使用

PublicGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupManager の使用

PublicGroupManager を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
static PublicGroupManager PublicGroupManager.getPublicGroupManager(String user, String group)
PublicGroupManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct の使用

PublicGroupStruct を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupStruct の使用

PublicGroupStruct を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract  PublicGroupStruct[] PublicGroupManager.getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale)
パブリックグループの階層構造を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup の使用

PublicGroup を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroup の使用

PublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | PublicGroupManager.updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | PublicGroupManager.deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
void | PublicGroupChangedListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroup の使用

PublicGroup 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable の使用

PublicGroupTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での PublicGroupTerminable の使用

PublicGroupTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 void PublicGroup.putPublicGroupTerminable(Term term, PublicGroupTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational の使用

PublicGroupTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group パブリックグループ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での PublicGroupTerminableInternational の使用

PublicGroupTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 PublicGroupTerminableInternational PublicGroupTerminable.getPublicGroupTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

PublicGroupTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 void PublicGroupTerminable.putPublicGroupTerminableInternational(Locale locale, PublicGroupTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス
PublicGroup
PublicGroupTerminable
PublicGroupTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group

パブリックグループ情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroup | パブリックグループの基本属性のデータを取り扱います。
PublicGroupTerminable | パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminableInternational | パブリックグループの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の説明

パブリックグループ情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.public_group.group クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroupTerminable
パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminableInternational
パブリックグループの期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のクラス
PublicGroup
パブリックグループの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup
すべての実装インタフェース:
Serializable
public class PublicGroup
extends Object
implements Serializable

パブリックグループの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroup()
メソッドの概要
String | getNotes() 備考を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
PublicGroupTerminable | getPublicGroupTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupTerminable | getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループで管理している期間をすべて取得します。
void | putPublicGroupTerminable(Term term, PublicGroupTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupCode(String publicGroupCode) グループコードを設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroup

public PublicGroup()
メソッドの詳細

getTerms

public Term[] getTerms()
このパブリックグループで管理している期間をすべて取得します。

戻り値:
このパブリックグループで管理している期間

getPublicGroupTerminable

public PublicGroupTerminable getPublicGroupTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupTerminable

public PublicGroupTerminable getPublicGroupTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupTerminable

public void putPublicGroupTerminable(Term term,
                                     PublicGroupTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupTerminable

public void removePublicGroupTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

setPublicGroupCode

public void setPublicGroupCode(String publicGroupCode)
グループコードを設定します。

パラメータ:
publicGroupCode - グループコード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroupTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupTerminable
extends Object
implements Serializable

パブリックグループの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupTerminable()
メソッドの概要
Locale[] | getLocales() このパブリックグループで管理している言語（ロケール）をすべて取得します。
PublicGroupTerminableInternational | getPublicGroupTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
void | putPublicGroupTerminableInternational(Locale locale, PublicGroupTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupTerminable

public PublicGroupTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このパブリックグループで管理している言語（ロケール）をすべて取得します。

戻り値:
このパブリックグループで管理している言語（ロケール）

getPublicGroupTerminableInternational

public PublicGroupTerminableInternational getPublicGroupTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putPublicGroupTerminableInternational

public void putPublicGroupTerminableInternational(Locale locale,
                                                  PublicGroupTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableInternational (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
クラス PublicGroupTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational
すべての実装インタフェース:
Serializable
public class PublicGroupTerminableInternational
extends Object
implements Serializable

パブリックグループの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupTerminableInternational()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupTerminableInternational

public PublicGroupTerminableInternational()
メソッドの詳細

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet の使用

PublicGroupSet を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupSet の使用

PublicGroupSet 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | PublicGroupManager.deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
void | PublicGroupChangedListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupSet の使用

PublicGroupSet 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable の使用

PublicGroupSetTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set パブリックグループセット情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での PublicGroupSetTerminable の使用

PublicGroupSetTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Date date) 指定された日時に対する期間化情報を取得します。

PublicGroupSetTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 void PublicGroupSet.putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational の使用

PublicGroupSetTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set パブリックグループセット情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での PublicGroupSetTerminableInternational の使用

PublicGroupSetTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 PublicGroupSetTerminableInternational PublicGroupSetTerminable.getPublicGroupSetTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

PublicGroupSetTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 void PublicGroupSetTerminable.putPublicGroupSetTerminableInternational(Locale locale, PublicGroupSetTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス
PublicGroupSet
PublicGroupSetTerminable
PublicGroupSetTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set

パブリックグループセット情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupSet | パブリックグループセットの基本属性のデータを取り扱います。
PublicGroupSetTerminable | パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminableInternational | パブリックグループセットの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の説明

パブリックグループセット情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.public_group.set クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSet
パブリックグループセットの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSetTerminable
パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminableInternational
パブリックグループセットの期間国際化属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のクラス
PublicGroupSet
パブリックグループセットの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupSet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSet

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet
すべての実装インタフェース:
Serializable
public class PublicGroupSet
extends Object
implements Serializable

パブリックグループセットの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSet()
メソッドの概要
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
PublicGroupSetTerminable | getPublicGroupSetTerminable(Date date) 指定された日時に対する期間化情報を取得します。
PublicGroupSetTerminable | getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このパブリックグループセットで管理している期間をすべて取得します。
void | putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data) 指定された期間に対する期間化情報を設定します。
void | removePublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSet

public PublicGroupSet()
メソッドの詳細

getTerms

public Term[] getTerms()
このパブリックグループセットで管理している期間をすべて取得します。

戻り値:
このパブリックグループセットで管理している期間

getPublicGroupSetTerminable

public PublicGroupSetTerminable getPublicGroupSetTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getPublicGroupSetTerminable

public PublicGroupSetTerminable getPublicGroupSetTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putPublicGroupSetTerminable

public void putPublicGroupSetTerminable(Term term,
                                        PublicGroupSetTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removePublicGroupSetTerminable

public void removePublicGroupSetTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSetTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable
すべての実装インタフェース:
Serializable
public class PublicGroupSetTerminable
extends Object
implements Serializable

パブリックグループセットの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSetTerminable()
メソッドの概要
Locale[] | getLocales() このパブリックグループセットで管理している言語（ロケール）をすべて取得します。
PublicGroupSetTerminableInternational | getPublicGroupSetTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
void | putPublicGroupSetTerminableInternational(Locale locale, PublicGroupSetTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSetTerminable

public PublicGroupSetTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このパブリックグループセットで管理している言語（ロケール）をすべて取得します。

戻り値:
このパブリックグループセットで管理している言語（ロケール）

getPublicGroupSetTerminableInternational

public PublicGroupSetTerminableInternational getPublicGroupSetTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putPublicGroupSetTerminableInternational

public void putPublicGroupSetTerminableInternational(Locale locale,
                                                     PublicGroupSetTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetTerminableInternational (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
クラス PublicGroupSetTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational
すべての実装インタフェース:
Serializable
public class PublicGroupSetTerminableInternational
extends Object
implements Serializable

パブリックグループセットの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupSetTerminableInternational()
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupSetTerminableInternational

public PublicGroupSetTerminableInternational()
メソッドの詳細

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
グループ名を設定します。

パラメータ:
name - グループ名

getNameSyllabary

public String getNameSyllabary()
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ

getNameEnglish

public String getNameEnglish()
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion の使用

PublicGroupVersion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での PublicGroupVersion の使用

PublicGroupVersion 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | PublicGroupManager.updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
abstract void | PublicGroupManager.deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
void | PublicGroupChangedListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.menu での PublicGroupVersion の使用

PublicGroupVersion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
クラス
PublicGroupVersion


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version

パブリックグループバージョン情報を操作するクラスを提供します。

参照:
説明

クラスの概要
PublicGroupVersion パブリックグループ構成バージョンの基本属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の説明

パブリックグループバージョン情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.public_group.version クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.version のクラス
PublicGroupVersion
パブリックグループ構成バージョンの基本属性のデータを取り扱います。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group.version のクラス
PublicGroupVersion
パブリックグループ構成バージョンの基本属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupVersion (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
クラス PublicGroupVersion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion
すべての実装インタフェース:
Serializable
public class PublicGroupVersion
extends Object
implements Serializable

パブリックグループ構成バージョンの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupVersion()
メソッドの概要
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setPublicGroupSetCode(String publicGroupSetCode) グループセットコードを設定します。
void | setStartDate(Date startDate) 開始日を設定します。
void | setVersionCode(String versionCode) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupVersion

public PublicGroupVersion()
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

setPublicGroupSetCode

public void setPublicGroupSetCode(String publicGroupSetCode)
グループセットコードを設定します。

パラメータ:
publicGroupSetCode - グループセットコード

getVersionCode

public String getVersionCode()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCode

public void setVersionCode(String versionCode)
バージョンコードを設定します。

パラメータ:
versionCode - バージョンコード

getStartDate

public Date getStartDate()
開始日を取得します。

戻り値:
開始日

setStartDate

public void setStartDate(Date startDate)
開始日を設定します。

パラメータ:
startDate - 開始日

getEndDate

public Date getEndDate()
終了日を取得します。

戻り値:
終了日

setEndDate

public void setEndDate(Date endDate)
終了日を設定します。

パラメータ:
endDate - 終了日

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.domain.public_group (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース
PublicGroupChangedListener
PublicGroupImporter
PublicGroupStruct
クラス
PublicGroupManager
StandardPublicGroupImporter


jp.co.intra_mart.foundation.datastore.application.domain.public_group (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group

パブリックグループ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
PublicGroupChangedListener | パブリックグループに関する情報の更新時のリスナーです。
PublicGroupImporter | パブリックグループのインポートのインターフェースです
PublicGroupStruct | 組織の階層です。

クラスの概要
PublicGroupManager | パブリックグループに関連する情報を管理します。
StandardPublicGroupImporter | パブリックグループのインポートを行います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の説明

パブリックグループ情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.public_group クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group の使用

jp.co.intra_mart.foundation.datastore.application.domain.public_group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
PublicGroupImporter
パブリックグループのインポートのインターフェースです
PublicGroupManager
パブリックグループに関連する情報を管理します。
PublicGroupStruct
組織の階層です。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.application.domain.public_group のクラス
PublicGroupChangedListener
パブリックグループに関する情報の更新時のリスナーです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupChangedListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupChangedListener

既知の実装クラスの一覧:
PublicGroupChangedMenuListener
public interface PublicGroupChangedListener

パブリックグループに関する情報の更新時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          PublicGroupSet groupSet)
                   throws ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

groupSetDeleted

public void groupSetDeleted(String groupId,
                            PublicGroupSet groupSet)
                     throws ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupAdded

public void publicGroupAdded(String groupId,
                             PublicGroup publicGroup)
                      throws ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              PublicGroupCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  PublicGroupCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PublicGroupAttach attach)
               throws ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PublicGroupAttach attach)
                   throws ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         PublicGroupVersion version)
                  throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupImporter

既知の実装クラスの一覧:
StandardPublicGroupImporter
public interface PublicGroupImporter

パブリックグループのインポートのインターフェースです

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
クラス PublicGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
public abstract class PublicGroupManager
extends Object

パブリックグループに関連する情報を管理します。 このクラスのインスタンスは必ず getPublicGroupManager(String, String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
PublicGroupManager()
メソッドの概要
abstract void | addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
abstract void | deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
abstract void | deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
abstract void | deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
abstract void | deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
static PublicGroupManager | getPublicGroupManager(String user, String group) PublicGroupManagerを取得します。
abstract PublicGroupStruct[] | getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale) パブリックグループの階層構造を取得します。
protected abstract void | init(String user, String group) PublicGroupManagerを初期化します。
abstract void | joinPublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成にパブリックグループを登録します。
abstract void | leavePublicGroup(String groupSet, String publicGroup, String version) パブリックグループ構成からパブリックグループ情報を離脱させます。
abstract void | movePublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成に登録済のパブリックグループ情報を移動します。
abstract void | removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
abstract void | setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupManager

public PublicGroupManager()
メソッドの詳細

getPublicGroupManager

public static PublicGroupManager getPublicGroupManager(String user,
                                                       String group)
                                                throws ManagerException
PublicGroupManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するCompanyManager
例外:
ManagerException - PublicGroupManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
PublicGroupManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - 初期化に失敗

addGroupSet

public abstract void addGroupSet(PublicGroupSet groupSet)
                          throws ManagerException
パブリックグループセットを登録します。 このメソッドを実行すると下記のような動作が行われます。
  1. パブリックグループセットを新規登録する。
  2. パブリックグループセットに対応するパブリックグループを新規登録する。

パラメータ:
groupSet - パブリックグループセット情報
例外:
MapperException - パブリックグループセットの登録に失敗
ManagerException

deleteGroupSet

public abstract void deleteGroupSet(PublicGroupSet groupSet)
                             throws ManagerException
登録済のパブリックグループセットを削除します。 このメソッドを実行すると指定されたパブリックグループセットに関連する全ての情報が削除されます。
指定されたパブリックグループセットの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
groupSet - パブリックグループセット情報
例外:
ManagerException - パブリックグループセットの削除に失敗

addPublicGroup

public abstract void addPublicGroup(PublicGroup publicGroup)
                             throws ManagerException
パブリックグループを登録します。 このメソッドを実行しただけではまだパブリックグループセットのパブリックグループ構成には追加されていません。 パブリックグループ構成に追加したい場合は joinPublicGroup(String, String, String, String)を使用してください。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの登録に失敗

updatePublicGroup

public abstract void updatePublicGroup(PublicGroup publicGroup)
                                throws ManagerException
登録済のパブリックグループ情報を更新します。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの更新に失敗

deletePublicGroup

public abstract void deletePublicGroup(PublicGroup publicGroup)
                                throws ManagerException
登録済のパブリックグループ情報を削除します。
指定されたパブリックグループの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
publicGroup - パブリックグループ情報
例外:
ManagerException - パブリックグループの削除に失敗

joinPublicGroup

public abstract void joinPublicGroup(String groupSet,
                                     String parentGroup,
                                     String publicGroup,
                                     String version)
                              throws ManagerException
パブリックグループ構成にパブリックグループを登録します。 新しく親となるパブリックグループと登録対象のパブリックグループは同一のパブリックグループセットに所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。 親となるパブリックグループは、パブリックグループ内包に登録済みのものを指定する必要があります
指定されたパブリックグループが対象のバージョンにおいて既に登録されているときはこのメソッドは使用できません。

パラメータ:
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 新規登録するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループ構成にパブリックグループの登録に失敗

movePublicGroup

public abstract void movePublicGroup(String groupSet,
                                     String parentGroup,
                                     String publicGroup,
                                     String version)
                              throws ManagerException
パブリックグループ構成に登録済のパブリックグループ情報を移動します。 新しく上位となるパブリックグループと移動対象のパブリックグループは同一のパブリックグループセットに所属している必要があります。
また、パブリックグループ構成が循環するような移動はできません。 バージョンコードは登録済みのものを指定する必要があります

パラメータ:
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループの移動に失敗

leavePublicGroup

public abstract void leavePublicGroup(String groupSet,
                                      String publicGroup,
                                      String version)
                               throws ManagerException
パブリックグループ構成からパブリックグループ情報を離脱させます。 このメソッドを実行すると、指定されたパブリックグループを指定されたバージョンから削除します。 指定されたパブリックグループが子パブリックグループを持っていた場合、それらのパブリックグループも再帰的にこのバージョンから削除されます。 このメソッドを実行してもパブリックグループ情報そのものは残ります。
指定されたパブリックグループがグループ構成に登録されていない場合は ManagerException がスローされます。

パラメータ:
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ManagerException - パブリックグループ構成からパブリックグループの離脱の失敗

setCategoryDetail

public abstract void setCategoryDetail(PublicGroupCategory category)
                                throws ManagerException
パブリックグループに対して指定された分類区分情報を設定します。

パラメータ:
category - 設定する分類区分詳細情報
例外:
ManagerException - 分類区分情報の設定に失敗

removeCategoryDetail

public abstract void removeCategoryDetail(PublicGroupCategory category)
                                   throws ManagerException
パブリックグループに対して指定された分類区分情報を削除します。 指定された分類区分情報が存在しない場合は ManagerException がスローされます。

パラメータ:
category - 削除する分類区分詳細詳細情報
例外:
ManagerException - パブリックグループに対して指定された分類区分情報の削除に失敗

setMember

public abstract void setMember(PublicGroupAttach attach)
                        throws ManagerException
パブリックグループに人員を割り当てます。 人員の割当情報はパラメータで渡された情報で完全に上書きされます。

パラメータ:
attach - 割当人員の情報
例外:
ManagerException - 人員の割当に失敗

deleteMember

public abstract void deleteMember(PublicGroupAttach attach)
                           throws ManagerException
パブリックグループから人員をはずします。 削除対象となる期間は無限の過去から無限の未来となります。
指定された人員がパブリックグループに割り当てられていない場合は ManagerException がスローされます。

パラメータ:
attach - パブリックグループから外す人員の情報
例外:
ManagerException - パブリックグループから人員を外すことに失敗

addVersion

public abstract void addVersion(PublicGroupVersion version)
                         throws ManagerException
パブリックグループセット構成バージョンを新規に登録します。 追加された構成バージョンのトップレベルには、パブリックグループセットが自動的に追加されます。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの登録に失敗

updateVersion

public abstract void updateVersion(PublicGroupVersion version)
                            throws ManagerException
登録済のパブリックグループセット構成バージョンを更新します。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの更新に失敗

deleteVersion

public abstract void deleteVersion(PublicGroupVersion version)
                            throws ManagerException
登録済のパブリックグループセット構成バージョンを削除します。
指定されたパブリックグループセット構成バージョンが存在しない場合は ManagerException がスローされます。

パラメータ:
version - バージョン情報
例外:
ManagerException - パブリックグループセット構成バージョンの削除に失敗

copyVersion

public abstract void copyVersion(String groupSet,
                                 String srcVersion,
                                 String destVersion,
                                 Term term)
                          throws ManagerException
登録済のパブリックグループセット構成バージョンの内容をコピーします。 コピー元のバージョンコードは登録済みのものを選択してください コピー先のバージョンコードは登録されていないものを選択してください

パラメータ:
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのグループセットコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ManagerException - パブリックグループセット構成バージョンのコピーに失敗

getPublicGroupStructs

public abstract PublicGroupStruct[] getPublicGroupStructs(String groupSet,
                                                          String publicGroup,
                                                          Date date,
                                                          Locale locale)
                                                   throws ManagerException
パブリックグループの階層構造を取得します。 指定された日付に該当する、パブリックグループ構成バージョンがない時はエラーとなります。

パラメータ:
groupSet - グループセットコード
publicGroup - グループコード
date - 日付
locale - 言語(ロケール)
戻り値:
パブリックグループの階層構造
例外:
ManagerException - パブリックグループの階層構造の取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupStruct (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
インタフェース PublicGroupStruct

public interface PublicGroupStruct

組織の階層です。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。

メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
グループセットコードを取得します。

戻り値:
グループセットコード

getPublicGroupCode

public String getPublicGroupCode()
グループコードを取得します。

戻り値:
グループコード

getName

public String getName()
グループ名を取得します。

戻り値:
グループ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardPublicGroupImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.public_group
クラス StandardPublicGroupImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter
すべての実装インタフェース:
PublicGroupImporter
public class StandardPublicGroupImporter
extends Object
implements PublicGroupImporter

パブリックグループのインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardPublicGroupImporter()
メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardPublicGroupImporter

public StandardPublicGroupImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース PublicGroupImporter 内の doImport
パラメータ:
inputstream - 入力ストリーム
user - ログインユーザコード
group - ログイングループコード
例外:
ImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter の使用

jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.User の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.User の使用

User を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での User の使用

User 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
abstract void | UserManager.addUser(User user) ユーザを登録します。
abstract void | UserManager.updateUser(User user) 登録済のユーザを更新します。
abstract void | UserManager.deleteUser(User user) 登録済のユーザを削除します。
void | UserChangedListener.userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | UserChangedListener.userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。
void | UserChangedListener.userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener の使用

jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter の使用

UserImporter を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserImporter の使用

UserImporter を実装している jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
 class StandardUserImporter
ユーザプロファイルのインポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の使用

UserManager を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserManager の使用

UserManager を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
static UserManager UserManager.getUserManager(String user, String group)
UserManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable の使用

UserTerminable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserTerminable の使用

UserTerminable を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
UserTerminable | User.getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
UserTerminable | User.getUserTerminable(Date date) 指定された日時に対する期間化情報を取得します。

UserTerminable 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 void User.putUserTerminable(Term term, UserTerminable data)
指定された期間に対する期間化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational の使用

UserTerminableInternational を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user での UserTerminableInternational の使用

UserTerminableInternational を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 UserTerminableInternational UserTerminable.getUserTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。

UserTerminableInternational 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 void UserTerminable.putUserTerminableInternational(Locale locale, UserTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.domain.user (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース
UserChangedListener
UserImporter
クラス
StandardUserImporter
User
UserManager
UserTerminable
UserTerminableInternational


jp.co.intra_mart.foundation.datastore.application.domain.user (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user

ユーザ情報を操作するクラスを提供します。

参照:
説明

インタフェースの概要
UserChangedListener | ユーザに関する情報の変更時のリスナーです。
UserImporter | ユーザインポーターのインタフェースです。

クラスの概要
StandardUserImporter | ユーザプロファイルのインポートを行います。
User | ユーザの基本属性のデータを取り扱います。
UserManager | ユーザに関連する情報を管理します。
UserTerminable | ユーザの期間化属性のデータを取り扱います。
UserTerminableInternational | ユーザの期間国際化属性のデータを取り扱います。

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の説明

ユーザ情報を操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.domain.user クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.User (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user の使用

jp.co.intra_mart.foundation.datastore.application.domain.user を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.user ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.application.domain.user のクラス
User
ユーザの基本属性のデータを取り扱います。
UserImporter
ユーザインポーターのインタフェースです。
UserManager
ユーザに関連する情報を管理します。
UserTerminable
ユーザの期間化属性のデータを取り扱います。
UserTerminableInternational
ユーザの期間国際化属性のデータを取り扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StandardUserImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス StandardUserImporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter
すべての実装インタフェース:
UserImporter
public class StandardUserImporter
extends Object
implements UserImporter

ユーザプロファイルのインポートを行います。

導入されたバージョン:
5.0

コンストラクタの概要
StandardUserImporter()
メソッドの概要
 void doImport(InputStream inputStream, String user, String group)
インポートを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserImporter

public StandardUserImporter()
メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

定義:
インタフェース UserImporter 内の doImport
パラメータ:
inputStream - 入力ストリーム
user - ログインユーザ
group - ログイングループ
例外:
ImportException - インポートに失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


User (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス User

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.User
すべての実装インタフェース:
Serializable
public class User
extends Object
implements Serializable

ユーザの基本属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
User()
メソッドの概要
String | getAccountFlag() アカウントフラグを取得します。
String | getNotes() 備考を取得します。
int | getSortKey() ソートキーを取得します。
Term[] | getTerms() このユーザで管理している期間をすべて取得します。
String | getUserCode() ユーザコードを取得します。
UserTerminable | getUserTerminable(Date date) 指定された日時に対する期間化情報を取得します。
UserTerminable | getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | putUserTerminable(Term term, UserTerminable data) 指定された期間に対する期間化情報を設定します。
void | removeUserTerminable(Term term) 指定された期間に対する期間化情報を削除します。
void | setAccountFlag(String accountFlag) このメソッドはシステム内で使用されます。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setUserCode(String userCode) ユーザコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

User

public User()
メソッドの詳細

getTerms

public Term[] getTerms()
このユーザで管理している期間をすべて取得します。

戻り値:
このユーザで管理している期間

getUserTerminable

public UserTerminable getUserTerminable(Term term)
指定された期間に対する期間化情報を取得します。 指定された期間の有効開始日、有効終了日と完全に期間が一致するデータがない時は null が返されます。

パラメータ:
term - 期間
戻り値:
期間化情報

getUserTerminable

public UserTerminable getUserTerminable(Date date)
指定された日時に対する期間化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
date - 日時
戻り値:
期間化情報

putUserTerminable

public void putUserTerminable(Term term,
                              UserTerminable data)
指定された期間に対する期間化情報を設定します。

パラメータ:
term - 期間
data - 期間化情報

removeUserTerminable

public void removeUserTerminable(Term term)
指定された期間に対する期間化情報を削除します。

パラメータ:
term - 期間

getUserCode

public String getUserCode()
ユーザコードを取得します。

戻り値:
ユーザコード

setUserCode

public void setUserCode(String userCode)
ユーザコードを設定します。

パラメータ:
userCode - ユーザコード

getAccountFlag

public String getAccountFlag()
アカウントフラグを取得します。

戻り値:
アカウントフラグ

setAccountFlag

public void setAccountFlag(String accountFlag)
このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
accountFlag - アカウントフラグ

getNotes

public String getNotes()
備考を取得します。

戻り値:
備考

setNotes

public void setNotes(String notes)
備考を設定します。

パラメータ:
notes - 備考

getSortKey

public int getSortKey()
ソートキーを取得します。

戻り値:
ソートキー

setSortKey

public void setSortKey(int sortKey)
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserChangedListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース UserChangedListener

public interface UserChangedListener

ユーザに関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

メソッドの概要
void | init(Map params) ユーザリスナーの初期化を行います。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。
void | userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。

メソッドの詳細

init

public void init(Map params)
ユーザリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

パラメータ:
userid - ログインユーザID

userAdded

public void userAdded(String groupId,
                      User user)
               throws ChangedListenerException
ユーザ情報がデータストアに登録された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

userUpdated

public void userUpdated(String groupId,
                        User user)
                 throws ChangedListenerException
ユーザ情報がデータストアに対して更新された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

userDeleted

public void userDeleted(String groupId,
                        User user)
                 throws ChangedListenerException
ユーザ情報がデータストアから削除された後に呼び出されます。

パラメータ:
groupId - ログイングループID
user - ユーザ情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
インタフェース UserImporter

既知の実装クラスの一覧:
StandardUserImporter
public interface UserImporter

ユーザインポーターのインタフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void doImport(InputStream inputstream, String user, String group)
インポートを行います。

メソッドの詳細

doImport

public void doImport(InputStream inputstream,
                     String user,
                     String group)
              throws ImportException
インポートを行います。

パラメータ:
inputstream - 入力ストリーム
user - ログインユーザ
group - ログイングループ
例外:
ImportException - インポートに失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
public abstract class UserManager
extends Object

ユーザに関連する情報を管理します。 このクラスのインスタンスは必ず getUserManager(String,String) で取得してください。

導入されたバージョン:
5.0

コンストラクタの概要
UserManager()
メソッドの概要
abstract void | addUser(User user) ユーザを登録します。
abstract void | deleteUser(User user) 登録済のユーザを削除します。
static UserManager | getUserManager(String user, String group) UserManagerを取得します。
protected abstract void | init(String user, String group) UserManagerを初期化します。
abstract void | updateUser(User user) 登録済のユーザを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserManager

public UserManager()
メソッドの詳細

getUserManager

public static UserManager getUserManager(String user,
                                         String group)
                                  throws ManagerException
UserManagerを取得します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
戻り値:
ログイングループコードに該当するUserManager
例外:
ManagerException - UserManagerの取得に失敗

init

protected abstract void init(String user,
                             String group)
                      throws ManagerException
UserManagerを初期化します。

パラメータ:
user - ログインユーザコード
group - ログイングループコード
例外:
ManagerException - UserManagerの初期化に失敗

addUser

public abstract void addUser(User user)
                      throws ManagerException
ユーザを登録します。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の登録に失敗

updateUser

public abstract void updateUser(User user)
                         throws ManagerException
登録済のユーザを更新します。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の更新に失敗

deleteUser

public abstract void deleteUser(User user)
                         throws ManagerException
登録済のユーザを削除します。
指定されたユーザの情報が存在しない場合は ManagerException がスローされます。

パラメータ:
user - ユーザ情報
例外:
ManagerException - UserManagerのユーザ情報の削除に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserTerminable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable
すべての実装インタフェース:
Serializable
public class UserTerminable
extends Object
implements Serializable

ユーザの期間化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
UserTerminable()
メソッドの概要
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
Locale[] | getLocales() このユーザで管理している言語（ロケール）をすべて取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
UserTerminableInternational | getUserTerminableInternational(Locale locale) 指定された言語に対する期間国際化情報を取得します。
String | getZipCode() 郵便番号を取得します。
void | putUserTerminableInternational(Locale locale, UserTerminableInternational data) 指定された言語に対する期間国際化情報を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserTerminable

public UserTerminable()
メソッドの詳細

getLocales

public Locale[] getLocales()
このユーザで管理している言語（ロケール）をすべて取得します。

戻り値:
このユーザで管理している言語（ロケール）

getUserTerminableInternational

public UserTerminableInternational getUserTerminableInternational(Locale locale)
指定された言語に対する期間国際化情報を取得します。 該当するデータがなかった場合 null が返されます。

パラメータ:
locale - 言語（ロケール）
戻り値:
期間国際化情報

putUserTerminableInternational

public void putUserTerminableInternational(Locale locale,
                                           UserTerminableInternational data)
指定された言語に対する期間国際化情報を設定します。

パラメータ:
locale - 言語（ロケール）
data - 期間国際化情報

getTelephoneNumber

public String getTelephoneNumber()
電話番号を取得します。

戻り値:
電話番号

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号

getMobileNumber

public String getMobileNumber()
携帯電話番号を取得します。

戻り値:
携帯電話番号

setMobileNumber

public void setMobileNumber(String mobileNumber)
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号

getFaxNumber

public String getFaxNumber()
FAX番号を取得します。

戻り値:
FAX番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号

getExtensionNumber

public String getExtensionNumber()
内線番号を取得します。

戻り値:
内線番号

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号

getExtensionFaxNumber

public String getExtensionFaxNumber()
内線FAX番号を取得します。

戻り値:
内線FAX番号

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号

getCountryCode

public String getCountryCode()
国コードを取得します。

戻り値:
国コード

setCountryCode

public void setCountryCode(String countryCode)
国コードを設定します。

パラメータ:
countryCode - 国コード

getZipCode

public String getZipCode()
郵便番号を取得します。

戻り値:
郵便番号

setZipCode

public void setZipCode(String zipCode)
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号

getEmailAddress1

public String getEmailAddress1()
メールアドレス１を取得します。

戻り値:
メールアドレス１

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１

getEmailAddress2

public String getEmailAddress2()
メールアドレス２を取得します。

戻り値:
メールアドレス２

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２

getMobileEmailAddress

public String getMobileEmailAddress()
携帯用メールを取得します。

戻り値:
携帯用メール

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableInternational (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.domain.user
クラス UserTerminableInternational

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational
すべての実装インタフェース:
Serializable
public class UserTerminableInternational
extends Object
implements Serializable

ユーザの期間国際化属性のデータを取り扱います。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
UserTerminableInternational()
メソッドの概要
String | getAddress() 住所を取得します。
String | getName() ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
void | setAddress(String address) 住所を設定します。
void | setName(String name) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserTerminableInternational

public UserTerminableInternational()
メソッドの詳細

getName

public String getName()
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
ユーザ名を設定します。

パラメータ:
name - ユーザ名

getNameSyllabary

public String getNameSyllabary()
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ

getNameEnglish

public String getNameEnglish()
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字

getAddress

public String getAddress()
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の使用

CateogryClassBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での CateogryClassBaseModel の使用

CateogryClassBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
CateogryClassBaseModel | CateogryClassMapper.create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
CateogryClassBaseModel | CateogryClassMapper.select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。

CateogryClassBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
void | CateogryClassMapper.insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | CateogryClassMapper.update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | CateogryClassMapper.delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel の使用

CateogryClassInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での CateogryClassInternationalModel の使用

CateogryClassInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
 CateogryClassInternationalModel CateogryClassBaseModel.selectCateogryClassInternationalModel(Locale locale)
指定された言語に該当する分類区分の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CateogryClassBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CateogryClassBaseModel
extends BaseModel

分類区分の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | NAME 分類区分名
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getName() 分類区分名を取得します。
String | getName(Locale locale) 分類区分名を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
CateogryClassInternationalModel | selectCateogryClassInternationalModel(Locale locale) 指定された言語に該当する分類区分の国際化モデルを取得します。
void | setName(String name) 分類区分名を設定します。
void | setName(String name, Locale locale) 分類区分名を設定します。
void | setNotes(String notes) 備考を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
分類区分名

関連項目:
定数フィールド値
メソッドの詳細

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
分類区分名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCateogryClassInternationalModel

public CateogryClassInternationalModel selectCateogryClassInternationalModel(Locale locale)
                                                                      throws IllegalLocaleException
指定された言語に該当する分類区分の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CateogryClassInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface CateogryClassInternationalModel
extends InternationalModel

分類区分の国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 分類区分名を取得します。
void | setName(String name) 分類区分名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
分類区分名を取得します。

戻り値:
分類区分名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類区分名を設定します。

パラメータ:
name - 分類区分名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CateogryClassMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース CateogryClassMapper

すべてのスーパーインタフェース:
Mapper
public interface CateogryClassMapper
extends Mapper

分類区分に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CateogryClassBaseModel | create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
void | delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。
void | delete(Collection models) 分類区分の基本モデルを複数削除します。
void | insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | insert(Collection models) 分類区分の基本モデルを複数挿入します。
CateogryClassBaseModel | select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。
void | update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | update(Collection models) 分類区分の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CateogryClassBaseModel create(String categoryClassCode)
                              throws MapperException
プライマリキーに該当する分類区分を生成します。

パラメータ:
categoryClassCode - 分類区分コード
戻り値:
プライマリキーに該当する分類区分の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CateogryClassBaseModel select(String categoryClassCode)
                              throws MapperException
プライマリーキーで特定される分類区分の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
categoryClassCode - 分類区分コード
戻り値:
分類区分の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ挿入します。 引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する分類区分の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
分類区分の基本モデルを複数挿入します。 引数に指定するものは同一の CateogryClassMapperの create(String) で生成された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する分類区分の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ更新します。 引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する分類区分の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
分類区分の基本モデルを複数更新します。 引数に指定するものは同一の CateogryClassMapperの select 系メソッド から取得されたものかで生成された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 更新する分類区分の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CateogryClassBaseModel model)
            throws MapperException
分類区分の基本モデルを1つだけ削除します。 引数で指定された分類区分の基本モデルに該当するデータのすべての情報を削除します。引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する分類区分の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
分類区分の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する分類区分の基本モデルは同一の CateogryClassMapperの select 系メソッド から取得された分類区分の基本モデルの集合である必要があります。

パラメータ:
models - 削除する分類区分の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.category.category_class (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.category.category_class
インタフェース
CateogryClassBaseModel
CateogryClassInternationalModel
CateogryClassMapper


jp.co.intra_mart.foundation.datastore.application.model.category.category_class (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class

分類区分情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CateogryClassBaseModel | 分類区分の基本モデルです。
CateogryClassInternationalModel | 分類区分の国際化モデルです。
CateogryClassMapper | 分類区分に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の説明

分類区分情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.category.category_class クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.category_class の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class 分類区分情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.application.model.category.category_class のクラス
CateogryClassBaseModel
分類区分の基本モデルです。
CateogryClassInternationalModel
分類区分の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の使用

CategoryDetailBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での CategoryDetailBaseModel の使用

CategoryDetailBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
CategoryDetailBaseModel | CategoryDetailMapper.create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
CategoryDetailBaseModel | CategoryDetailMapper.select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。

CategoryDetailBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
void | CategoryDetailMapper.insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | CategoryDetailMapper.update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | CategoryDetailMapper.delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel の使用

CategoryDetailInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での CategoryDetailInternationalModel の使用

CategoryDetailInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
 CategoryDetailInternationalModel CategoryDetailBaseModel.selectCategoryDetailInternationalModel(Locale locale)
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CategoryDetailBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CategoryDetailBaseModel
extends BaseModel

分類区分詳細の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | NAME 分類名
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getName() 分類名を取得します。
String | getName(Locale locale) 分類名を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
CategoryDetailInternationalModel | selectCategoryDetailInternationalModel(Locale locale) 指定された言語に該当する分類区分詳細の国際化モデルを取得します。
void | setName(String name) 分類名を設定します。
void | setName(String name, Locale locale) 分類名を設定します。
void | setNotes(String notes) 備考を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
分類名

関連項目:
定数フィールド値
メソッドの詳細

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
分類名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCategoryDetailInternationalModel

public CategoryDetailInternationalModel selectCategoryDetailInternationalModel(Locale locale)
                                                                        throws IllegalLocaleException
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
分類区分詳細の国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailInternationalModel

すべてのスーパーインタフェース:
InternationalModel, Serializable
public interface CategoryDetailInternationalModel
extends InternationalModel

分類区分詳細の国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 分類名を取得します。
void | setName(String name) 分類名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel から継承したメソッド
getExtendedInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
分類名を取得します。

戻り値:
分類名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
分類名を設定します。

パラメータ:
name - 分類名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CategoryDetailMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース CategoryDetailMapper

すべてのスーパーインタフェース:
Mapper
public interface CategoryDetailMapper
extends Mapper

分類区分詳細に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CategoryDetailBaseModel | create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
void | delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。
void | delete(Collection models) 分類区分詳細の基本モデルを複数削除します。
void | insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | insert(Collection models) 分類区分詳細の基本モデルを複数挿入します。
CategoryDetailBaseModel | select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
void | update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | update(Collection models) 分類区分詳細の基本モデルを複数更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CategoryDetailBaseModel create(String categoryClassCode,
                                      String categoryCode)
                               throws MapperException
プライマリキーに該当する分類区分詳細を生成します。

パラメータ:
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当する分類区分詳細の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CategoryDetailBaseModel select(String categoryClassCode,
                                      String categoryCode)
                               throws MapperException
プライマリーキーで特定される分類区分詳細の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
分類区分詳細の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ挿入します。 引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する分類区分詳細の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数挿入します。 引数に指定するものは同一の CategoryDetailMapperの create(String,String) で生成された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する分類区分詳細の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ更新します。 引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する分類区分詳細の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数更新します。 引数に指定するものは同一の CategoryDetailMapperの select 系メソッド から取得されたものかで生成された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 更新する分類区分詳細の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CategoryDetailBaseModel model)
            throws MapperException
分類区分詳細の基本モデルを1つだけ削除します。 引数で指定された分類区分詳細の基本モデルに該当するデータのすべての情報を削除します。引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する分類区分詳細の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
分類区分詳細の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する分類区分詳細の基本モデルは同一の CategoryDetailMapperの select 系メソッド から取得された分類区分詳細の基本モデルの集合である必要があります。

パラメータ:
models - 削除する分類区分詳細の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.category.detail (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.category.detail
インタフェース
CategoryDetailBaseModel
CategoryDetailInternationalModel
CategoryDetailMapper


jp.co.intra_mart.foundation.datastore.application.model.category.detail (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail

分類詳細情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CategoryDetailBaseModel | 分類区分詳細の基本モデルです。
CategoryDetailInternationalModel | 分類区分詳細の国際化モデルです。
CategoryDetailMapper | 分類区分詳細に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の説明

分類詳細情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.category.detail クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.category.detail の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.detail 分類詳細情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.application.model.category.detail のクラス
CategoryDetailBaseModel
分類区分詳細の基本モデルです。
CategoryDetailInternationalModel
分類区分詳細の国際化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の使用

DepartmentAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での DepartmentAttachBaseModel の使用

DepartmentAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
DepartmentAttachBaseModel | DepartmentAttachMapper.create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
DepartmentAttachBaseModel | DepartmentAttachMapper.select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。

DepartmentAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
void | DepartmentAttachMapper.insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
void | DepartmentAttachMapper.update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
void | DepartmentAttachMapper.delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel の使用

DepartmentAttachTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での DepartmentAttachTerminableModel の使用

DepartmentAttachTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
 DepartmentAttachTerminableModel DepartmentAttachBaseModel.selectDepartmentAttachTerminableModel(Date date)
指定された日付に該当する組織所属の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DepartmentAttachBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentAttachBaseModel
extends BaseModel

組織所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | POST_CODE 役職CD
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getPostCode() 役職CDを取得します。
String | getPostCode(Date date) 役職CDを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
DepartmentAttachTerminableModel | selectDepartmentAttachTerminableModel(Date date) 指定された日付に該当する組織所属の期間化モデルを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
void | setPostCode(String postCode, Date date) 役職CDを設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

POST_CODE

public static final String POST_CODE
役職CD

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode()
                   throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode(Date date)
                   throws AccessorException
役職CDを取得します。

パラメータ:
date - 日時
戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

setPostCode

public void setPostCode(String postCode)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
例外:
AccessorException - データの設定に失敗した場合

setPostCode

public void setPostCode(String postCode,
                        Date date)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentAttachTerminableModel

public DepartmentAttachTerminableModel selectDepartmentAttachTerminableModel(Date date)
                                                                      throws IllegalTermException
指定された日付に該当する組織所属の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
組織所属の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentAttachMapper
extends Mapper

組織所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentAttachBaseModel | create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
void | delete(Collection models) 組織所属の基本モデルを複数削除します。
void | delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織所属の基本モデルを複数挿入します。
void | insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
DepartmentAttachBaseModel | select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。
void | update(Collection models) 組織所属の基本モデルを複数更新します。
void | update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentAttachBaseModel create(String userCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリキーに該当する組織所属を生成します。

パラメータ:
userCode - ユーザコード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentAttachBaseModel select(String userCode,
                                        String companyCode,
                                        String departmentCode)
                                 throws MapperException
プライマリーキーで特定される組織所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
組織所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ挿入します。 引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織所属の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentAttachMapperの create(String,String,String) で生成された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ更新します。 引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織所属の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentAttachMapperの select 系メソッド から取得されたものかで生成された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentAttachBaseModel model)
            throws MapperException
組織所属の基本モデルを1つだけ削除します。 引数で指定された組織所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織所属の基本モデルは同一の DepartmentAttachMapperの select 系メソッド から取得された組織所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentAttachTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース DepartmentAttachTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentAttachTerminableModel
extends TerminableModel

組織所属の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getPostCode() 役職CDを取得します。
void | setPostCode(String postCode) 役職CDを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getPostCode

public String getPostCode()
                   throws AccessorException
役職CDを取得します。

戻り値:
役職CD
例外:
AccessorException - データの取得に失敗した場合

setPostCode

public void setPostCode(String postCode)
                 throws AccessorException
役職CDを設定します。

パラメータ:
postCode - 役職CD
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.attach (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.company.attach
インタフェース
DepartmentAttachBaseModel
DepartmentAttachMapper
DepartmentAttachTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.attach (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach

組織所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentAttachBaseModel | 組織所属の基本モデルです。
DepartmentAttachMapper | 組織所属に関連するマッパです。
DepartmentAttachTerminableModel | 組織所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の説明

組織所属情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.company.attach クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.attach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach 組織所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.company.attach のクラス
DepartmentAttachBaseModel
組織所属の基本モデルです。
DepartmentAttachTerminableModel
組織所属の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の使用

CompanyCategoryBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category 会社分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での CompanyCategoryBaseModel の使用

CompanyCategoryBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
CompanyCategoryBaseModel | CompanyCategoryMapper.create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
CompanyCategoryBaseModel | CompanyCategoryMapper.select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。

CompanyCategoryBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
void | CompanyCategoryMapper.insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
void | CompanyCategoryMapper.update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
void | CompanyCategoryMapper.delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CompanyCategoryBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyCategoryBaseModel
extends BaseModel

会社組織分類の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyCategoryMapper
extends Mapper

会社組織分類に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyCategoryBaseModel | create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
void | delete(Collection models) 会社組織分類の基本モデルを複数削除します。
void | delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。
void | insert(Collection models) 会社組織分類の基本モデルを複数挿入します。
void | insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
CompanyCategoryBaseModel | select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。
void | update(Collection models) 会社組織分類の基本モデルを複数更新します。
void | update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyCategoryBaseModel create(String companyCode,
                                       String departmentCode,
                                       String categoryClassCode,
                                       String categoryCode)
                                throws MapperException
プライマリキーに該当する会社組織分類を生成します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当する会社組織分類の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyCategoryBaseModel select(String companyCode,
                                       String departmentCode,
                                       String categoryClassCode,
                                       String categoryCode)
                                throws MapperException
プライマリーキーで特定される会社組織分類の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
会社組織分類の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ挿入します。 引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社組織分類の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyCategoryMapperの create(String,String,String,String) で生成された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社組織分類の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ更新します。 引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社組織分類の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数更新します。 引数に指定するものは同一の CompanyCategoryMapperの select 系メソッド から取得されたものかで生成された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社組織分類の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyCategoryBaseModel model)
            throws MapperException
会社組織分類の基本モデルを1つだけ削除します。 引数で指定された会社組織分類の基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社組織分類の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社組織分類の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社組織分類の基本モデルは同一の CompanyCategoryMapperの select 系メソッド から取得された会社組織分類の基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社組織分類の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyCategoryTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース CompanyCategoryTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface CompanyCategoryTerminableModel
extends TerminableModel

会社組織分類の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.category (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.company.category
インタフェース
CompanyCategoryBaseModel
CompanyCategoryMapper
CompanyCategoryTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.category (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category

会社分類情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyCategoryBaseModel | 会社組織分類の基本モデルです。
CompanyCategoryMapper | 会社組織分類に関連するマッパです。
CompanyCategoryTerminableModel | 会社組織分類の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の説明

会社分類情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.company.category クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.category の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.category 会社分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.application.model.company.category のクラス
CompanyCategoryBaseModel
会社組織分類の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の使用

CompanyBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company 会社情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での CompanyBaseModel の使用

CompanyBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
CompanyBaseModel | CompanyMapper.create(String companyCode) プライマリキーに該当する会社を生成します。
CompanyBaseModel | CompanyMapper.select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。

CompanyBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
void | CompanyMapper.insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
void | CompanyMapper.update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
void | CompanyMapper.delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CompanyBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース CompanyBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyBaseModel
extends BaseModel

会社の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース CompanyMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyMapper
extends Mapper

会社に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyBaseModel | create(String companyCode) プライマリキーに該当する会社を生成します。
void | delete(Collection models) 会社の基本モデルを複数削除します。
void | delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。
void | insert(Collection models) 会社の基本モデルを複数挿入します。
void | insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
CompanyBaseModel | select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。
void | update(Collection models) 会社の基本モデルを複数更新します。
void | update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyBaseModel create(String companyCode)
                        throws MapperException
プライマリキーに該当する会社を生成します。

パラメータ:
companyCode - 会社コード
戻り値:
プライマリキーに該当する会社の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyBaseModel select(String companyCode)
                        throws MapperException
プライマリーキーで特定される会社の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
戻り値:
会社の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ挿入します。 引数に指定する会社の基本モデルは同一の CompanyMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyMapperの create(String) で生成された会社の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ更新します。 引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社の基本モデルを複数更新します。 引数に指定するものは同一の CompanyMapperの select 系メソッド から取得されたものかで生成された会社の基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyBaseModel model)
            throws MapperException
会社の基本モデルを1つだけ削除します。 引数で指定された会社の基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社の基本モデルは同一の CompanyMapperの select 系メソッド から取得された会社の基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.company (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.company.company
インタフェース
CompanyBaseModel
CompanyMapper


jp.co.intra_mart.foundation.datastore.application.model.company.company (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company

会社情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyBaseModel | 会社の基本モデルです。
CompanyMapper | 会社に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の説明

会社情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.company.company クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.company の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.company 会社情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.application.model.company.company のクラス
CompanyBaseModel
会社の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の使用

DepartmentBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentBaseModel の使用

DepartmentBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
DepartmentBaseModel | DepartmentMapper.create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
DepartmentBaseModel | DepartmentMapper.select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。

DepartmentBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
void | DepartmentMapper.insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
void | DepartmentMapper.update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
void | DepartmentMapper.delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel の使用

DepartmentTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentTerminableInternationalModel の使用

DepartmentTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableInternationalModel DepartmentTerminableModel.selectDepartmentTerminableInternationalModel(Locale locale)
指定された言語に該当する組織の期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel の使用

DepartmentTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での DepartmentTerminableModel の使用

DepartmentTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableModel DepartmentBaseModel.selectDepartmentTerminableModel(Date date)
指定された日付に該当する組織の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DepartmentBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentBaseModel
extends BaseModel

組織の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ADDRESS1 住所1
static String | ADDRESS2 住所2
static String | COMPANY_CODE 会社コード
static String | COUNTRY_CODE 国コード
static String | DEPARTMENT_CODE 組織コード
static String | EMAIL_ADDRESS1 メールアドレス1
static String | EMAIL_ADDRESS2 メールアドレス2
static String | EXTENSION_FAX_NUMBER 内線FAX番号
static String | EXTENSION_NUMBER 内線番号
static String | FAX_NUMBER FAX番号
static String | NAME 組織名
static String | NAME_ENGLISH 組織名英字
static String | NAME_SYLLABARY 組織名カナ
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | TELEPHONE_NUMBER 電話番号
static String | URL URL
static String | ZIP_CODE 郵便番号
メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Date date) 住所1を取得します。
String | getAddress1(Date date, Locale locale) 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Date date) 住所2を取得します。
String | getAddress2(Date date, Locale locale) 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCompanyCode() 会社コードを取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress1(Date date) メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getEmailAddress2(Date date) メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Date date) 組織名を取得します。
String | getName(Date date, Locale locale) 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Date date) 組織名英字を取得します。
String | getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Date date) 組織名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
DepartmentTerminableModel | selectDepartmentTerminableModel(Date date) 指定された日付に該当する組織の期間化モデルを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress1(String address1, Date date) 住所1を設定します。
void | setAddress1(String address1, Date date, Locale locale) 住所1を設定します。
void | setAddress1(String address1, Locale locale) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setAddress2(String address2, Date date) 住所2を設定します。
void | setAddress2(String address2, Date date, Locale locale) 住所2を設定します。
void | setAddress2(String address2, Locale locale) 住所2を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setCountryCode(String countryCode, Date date) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress1(String emailAddress1, Date date) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setEmailAddress2(String emailAddress2, Date date) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
void | setName(String name) 組織名を設定します。
void | setName(String name, Date date) 組織名を設定します。
void | setName(String name, Date date, Locale locale) 組織名を設定します。
void | setName(String name, Locale locale) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setUrl(String url, Date date) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
void | setZipCode(String zipCode, Date date) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

TELEPHONE_NUMBER

public static final String TELEPHONE_NUMBER
電話番号

関連項目:
定数フィールド値

FAX_NUMBER

public static final String FAX_NUMBER
FAX番号

関連項目:
定数フィールド値

EXTENSION_NUMBER

public static final String EXTENSION_NUMBER
内線番号

関連項目:
定数フィールド値

EXTENSION_FAX_NUMBER

public static final String EXTENSION_FAX_NUMBER
内線FAX番号

関連項目:
定数フィールド値

COUNTRY_CODE

public static final String COUNTRY_CODE
国コード

関連項目:
定数フィールド値

ZIP_CODE

public static final String ZIP_CODE
郵便番号

関連項目:
定数フィールド値

EMAIL_ADDRESS1

public static final String EMAIL_ADDRESS1
メールアドレス1

関連項目:
定数フィールド値

EMAIL_ADDRESS2

public static final String EMAIL_ADDRESS2
メールアドレス2

関連項目:
定数フィールド値

URL

public static final String URL
URL

関連項目:
定数フィールド値

NAME

public static final String NAME
組織名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
組織名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
組織名英字

関連項目:
定数フィールド値

ADDRESS1

public static final String ADDRESS1
住所1

関連項目:
定数フィールド値

ADDRESS2

public static final String ADDRESS2
住所2

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber(Date date)
                          throws AccessorException
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber,
                               Date date)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

getFaxNumber

public String getFaxNumber(Date date)
                    throws AccessorException
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber,
                         Date date)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionNumber

public String getExtensionNumber(Date date)
                          throws AccessorException
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber,
                               Date date)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
                             throws AccessorException
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber,
                                  Date date)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

getCountryCode

public String getCountryCode(Date date)
                      throws AccessorException
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

setCountryCode

public void setCountryCode(String countryCode,
                           Date date)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

getZipCode

public String getZipCode(Date date)
                  throws AccessorException
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

setZipCode

public void setZipCode(String zipCode,
                       Date date)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス1を取得します。

戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress1

public String getEmailAddress1(Date date)
                        throws AccessorException
メールアドレス1を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1,
                             Date date)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス2を取得します。

戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress2

public String getEmailAddress2(Date date)
                        throws AccessorException
メールアドレス2を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2,
                             Date date)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

getUrl

public String getUrl(Date date)
              throws AccessorException
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

setUrl

public void setUrl(String url,
                   Date date)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
組織名を取得します。

パラメータ:
date - 日時
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
date - 日時
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
date - 日時
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Date date)
                   throws AccessorException
住所1を取得します。

パラメータ:
date - 日時
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Date date,
                          Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Date date)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Date date,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Date date)
                   throws AccessorException
住所2を取得します。

パラメータ:
date - 日時
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Date date,
                          Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Date date)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Date date,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentTerminableModel

public DepartmentTerminableModel selectDepartmentTerminableModel(Date date)
                                                          throws IllegalTermException
指定された日付に該当する組織の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
組織の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentMapper
extends Mapper

組織に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentBaseModel | create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
void | delete(Collection models) 組織の基本モデルを複数削除します。
void | delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織の基本モデルを複数挿入します。
void | insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
DepartmentBaseModel | select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。
void | update(Collection models) 組織の基本モデルを複数更新します。
void | update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentBaseModel create(String companyCode,
                                  String departmentCode)
                           throws MapperException
プライマリキーに該当する組織を生成します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentBaseModel select(String companyCode,
                                  String departmentCode)
                           throws MapperException
プライマリーキーで特定される組織の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
departmentCode - 組織コード
戻り値:
組織の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ挿入します。 引数に指定する組織の基本モデルは同一の DepartmentMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentMapperの create(String,String) で生成された組織の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ更新します。 引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentMapperの select 系メソッド から取得されたものかで生成された組織の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentBaseModel model)
            throws MapperException
組織の基本モデルを1つだけ削除します。 引数で指定された組織の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織の基本モデルは同一の DepartmentMapperの select 系メソッド から取得された組織の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface DepartmentTerminableInternationalModel
extends TerminableInternationalModel

組織の期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getName() 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setName(String name) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース DepartmentTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentTerminableModel
extends TerminableModel

組織の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress1() 住所1を取得します。
String | getAddress1(Locale locale) 住所1を取得します。
String | getAddress2() 住所2を取得します。
String | getAddress2(Locale locale) 住所2を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス1を取得します。
String | getEmailAddress2() メールアドレス2を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getName() 組織名を取得します。
String | getName(Locale locale) 組織名を取得します。
String | getNameEnglish() 組織名英字を取得します。
String | getNameEnglish(Locale locale) 組織名英字を取得します。
String | getNameSyllabary() 組織名カナを取得します。
String | getNameSyllabary(Locale locale) 組織名カナを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
DepartmentTerminableInternationalModel | selectDepartmentTerminableInternationalModel(Locale locale) 指定された言語に該当する組織の期間国際化モデルを取得します。
void | setAddress1(String address1) 住所1を設定します。
void | setAddress1(String address1, Locale locale) 住所1を設定します。
void | setAddress2(String address2) 住所2を設定します。
void | setAddress2(String address2, Locale locale) 住所2を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setName(String name) 組織名を設定します。
void | setName(String name, Locale locale) 組織名を設定します。
void | setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス1を取得します。

戻り値:
メールアドレス1
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス1を設定します。

パラメータ:
emailAddress1 - メールアドレス1
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス2を取得します。

戻り値:
メールアドレス2
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス2を設定します。

パラメータ:
emailAddress2 - メールアドレス2
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
組織名を取得します。

戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
組織名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
組織名を設定します。

パラメータ:
name - 組織名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
組織名カナを取得します。

戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
組織名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
組織名カナを設定します。

パラメータ:
nameSyllabary - 組織名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
組織名英字を取得します。

戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
組織名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
組織名英字を設定します。

パラメータ:
nameEnglish - 組織名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress1

public String getAddress1()
                   throws AccessorException
住所1を取得します。

戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

getAddress1

public String getAddress1(Locale locale)
                   throws AccessorException
住所1を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所1
例外:
AccessorException - データの取得に失敗した場合

setAddress1

public void setAddress1(String address1)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
例外:
AccessorException - データの設定に失敗した場合

setAddress1

public void setAddress1(String address1,
                        Locale locale)
                 throws AccessorException
住所1を設定します。

パラメータ:
address1 - 住所1
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress2

public String getAddress2()
                   throws AccessorException
住所2を取得します。

戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

getAddress2

public String getAddress2(Locale locale)
                   throws AccessorException
住所2を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所2
例外:
AccessorException - データの取得に失敗した場合

setAddress2

public void setAddress2(String address2)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
例外:
AccessorException - データの設定に失敗した場合

setAddress2

public void setAddress2(String address2,
                        Locale locale)
                 throws AccessorException
住所2を設定します。

パラメータ:
address2 - 住所2
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentTerminableInternationalModel

public DepartmentTerminableInternationalModel selectDepartmentTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当する組織の期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
組織の期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.department (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.company.department
インタフェース
DepartmentBaseModel
DepartmentMapper
DepartmentTerminableInternationalModel
DepartmentTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.department (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department

組織情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentBaseModel | 組織の基本モデルです。
DepartmentMapper | 組織に関連するマッパです。
DepartmentTerminableInternationalModel | 組織の期間国際化モデルです。
DepartmentTerminableModel | 組織の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の説明

組織情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.company.department クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.department の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department 組織情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.application.model.company.department のクラス
DepartmentBaseModel
組織の基本モデルです。
DepartmentTerminableInternationalModel
組織の期間国際化モデルです。
DepartmentTerminableModel
組織の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の使用

DepartmentInclusionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion 組織内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での DepartmentInclusionBaseModel の使用

DepartmentInclusionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
DepartmentInclusionBaseModel | DepartmentInclusionMapper.create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
DepartmentInclusionBaseModel | DepartmentInclusionMapper.select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。

DepartmentInclusionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
void | DepartmentInclusionMapper.insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
void | DepartmentInclusionMapper.update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
void | DepartmentInclusionMapper.delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DepartmentInclusionBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース DepartmentInclusionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentInclusionBaseModel
extends BaseModel

組織内包の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | DEPTH 階層レベル
static String | PARENT_DEPARTMENT_CODE 親組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | VERSION_CODE バージョンコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
int | getDepth() 階層レベルを取得します。
String | getParentDepartmentCode() 親組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setDepth(int depth) 階層レベルを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

PARENT_DEPARTMENT_CODE

public static final String PARENT_DEPARTMENT_CODE
親組織コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値

DEPTH

public static final String DEPTH
階層レベル

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getParentDepartmentCode

public String getParentDepartmentCode()
                               throws AccessorException
親組織コードを取得します。

戻り値:
親組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepth

public int getDepth()
             throws AccessorException
階層レベルを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
階層レベル
例外:
AccessorException - データの取得に失敗した場合

setDepth

public void setDepth(int depth)
              throws AccessorException
階層レベルを設定します。

パラメータ:
depth - 階層レベル
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentInclusionMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース DepartmentInclusionMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentInclusionMapper
extends Mapper

組織内包に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentInclusionBaseModel | create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
void | delete(Collection models) 組織内包の基本モデルを複数削除します。
void | delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。
void | insert(Collection models) 組織内包の基本モデルを複数挿入します。
void | insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
DepartmentInclusionBaseModel | select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。
void | update(Collection models) 組織内包の基本モデルを複数更新します。
void | update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentInclusionBaseModel create(String companyCode,
                                           String versionCode,
                                           String parentDepartmentCode,
                                           String departmentCode)
                                    throws MapperException
プライマリキーに該当する組織内包を生成します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
parentDepartmentCode - 親組織コード
departmentCode - 組織コード
戻り値:
プライマリキーに該当する組織内包の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentInclusionBaseModel select(String companyCode,
                                           String versionCode,
                                           String parentDepartmentCode,
                                           String departmentCode)
                                    throws MapperException
プライマリーキーで特定される組織内包の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
parentDepartmentCode - 親組織コード
departmentCode - 組織コード
戻り値:
組織内包の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ挿入します。 引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する組織内包の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
組織内包の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentInclusionMapperの create(String,String,String,String) で生成された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する組織内包の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ更新します。 引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する組織内包の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
組織内包の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentInclusionMapperの select 系メソッド から取得されたものかで生成された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 更新する組織内包の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentInclusionBaseModel model)
            throws MapperException
組織内包の基本モデルを1つだけ削除します。 引数で指定された組織内包の基本モデルに該当するデータのすべての情報を削除します。引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する組織内包の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
組織内包の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する組織内包の基本モデルは同一の DepartmentInclusionMapperの select 系メソッド から取得された組織内包の基本モデルの集合である必要があります。

パラメータ:
models - 削除する組織内包の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
インタフェース
DepartmentInclusionBaseModel
DepartmentInclusionMapper


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion

組織内包情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentInclusionBaseModel | 組織内包の基本モデルです。
DepartmentInclusionMapper | 組織内包に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の説明

組織内包情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.company.inclusion クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion 組織内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のクラス
DepartmentInclusionBaseModel
組織内包の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の使用

DepartmentMainBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での DepartmentMainBaseModel の使用

DepartmentMainBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
DepartmentMainBaseModel | DepartmentMainMapper.create(String userCode) プライマリキーに該当する主所属を生成します。
DepartmentMainBaseModel | DepartmentMainMapper.select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。

DepartmentMainBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
void | DepartmentMainMapper.insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
void | DepartmentMainMapper.update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
void | DepartmentMainMapper.delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel の使用

DepartmentMainTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での DepartmentMainTerminableModel の使用

DepartmentMainTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
 DepartmentMainTerminableModel DepartmentMainBaseModel.selectDepartmentMainTerminableModel(Date date)
指定された日付に該当する主所属の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DepartmentMainBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface DepartmentMainBaseModel
extends BaseModel

主所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | DEPARTMENT_CODE 組織コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | USER_CODE ユーザコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getCompanyCode(Date date) 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getDepartmentCode(Date date) 組織コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getUserCode() ユーザコードを取得します。
DepartmentMainTerminableModel | selectDepartmentMainTerminableModel(Date date) 指定された日付に該当する主所属の期間化モデルを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setCompanyCode(String companyCode, Date date) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
void | setDepartmentCode(String departmentCode, Date date) 組織コードを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

DEPARTMENT_CODE

public static final String DEPARTMENT_CODE
組織コード

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getCompanyCode

public String getCompanyCode(Date date)
                      throws AccessorException
会社コードを取得します。

パラメータ:
date - 日時
戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
例外:
AccessorException - データの設定に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode,
                           Date date)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

getDepartmentCode

public String getDepartmentCode(Date date)
                         throws AccessorException
組織コードを取得します。

パラメータ:
date - 日時
戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
例外:
AccessorException - データの設定に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode,
                              Date date)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

selectDepartmentMainTerminableModel

public DepartmentMainTerminableModel selectDepartmentMainTerminableModel(Date date)
                                                                  throws IllegalTermException
指定された日付に該当する主所属の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
主所属の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainMapper

すべてのスーパーインタフェース:
Mapper
public interface DepartmentMainMapper
extends Mapper

主所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
DepartmentMainBaseModel | create(String userCode) プライマリキーに該当する主所属を生成します。
void | delete(Collection models) 主所属の基本モデルを複数削除します。
void | delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。
void | insert(Collection models) 主所属の基本モデルを複数挿入します。
void | insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
DepartmentMainBaseModel | select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。
void | update(Collection models) 主所属の基本モデルを複数更新します。
void | update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public DepartmentMainBaseModel create(String userCode)
                               throws MapperException
プライマリキーに該当する主所属を生成します。

パラメータ:
userCode - ユーザコード
戻り値:
プライマリキーに該当する主所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public DepartmentMainBaseModel select(String userCode)
                               throws MapperException
プライマリーキーで特定される主所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
戻り値:
主所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ挿入します。 引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入する主所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
主所属の基本モデルを複数挿入します。 引数に指定するものは同一の DepartmentMainMapperの create(String) で生成された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する主所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ更新します。 引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する主所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
主所属の基本モデルを複数更新します。 引数に指定するものは同一の DepartmentMainMapperの select 系メソッド から取得されたものかで生成された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新する主所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(DepartmentMainBaseModel model)
            throws MapperException
主所属の基本モデルを1つだけ削除します。 引数で指定された主所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する主所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
主所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する主所属の基本モデルは同一の DepartmentMainMapperの select 系メソッド から取得された主所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除する主所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentMainTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース DepartmentMainTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface DepartmentMainTerminableModel
extends TerminableModel

主所属の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
void | setCompanyCode(String companyCode) 会社コードを設定します。
void | setDepartmentCode(String departmentCode) 組織コードを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

setCompanyCode

public void setCompanyCode(String companyCode)
                    throws AccessorException
会社コードを設定します。

パラメータ:
companyCode - 会社コード
例外:
AccessorException - データの設定に失敗した場合

getDepartmentCode

public String getDepartmentCode()
                         throws AccessorException
組織コードを取得します。

戻り値:
組織コード
例外:
AccessorException - データの取得に失敗した場合

setDepartmentCode

public void setDepartmentCode(String departmentCode)
                       throws AccessorException
組織コードを設定します。

パラメータ:
departmentCode - 組織コード
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.main (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.company.main
インタフェース
DepartmentMainBaseModel
DepartmentMainMapper
DepartmentMainTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.main (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main

組織主所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
DepartmentMainBaseModel | 主所属の基本モデルです。
DepartmentMainMapper | 主所属に関連するマッパです。
DepartmentMainTerminableModel | 主所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の説明

組織主所属情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.company.main クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.main の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.main 組織主所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.application.model.company.main のクラス
DepartmentMainBaseModel
主所属の基本モデルです。
DepartmentMainTerminableModel
主所属の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の使用

CompanyPostBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostBaseModel の使用

CompanyPostBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
CompanyPostBaseModel | CompanyPostMapper.create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
CompanyPostBaseModel | CompanyPostMapper.select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。

CompanyPostBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
void | CompanyPostMapper.insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
void | CompanyPostMapper.update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
void | CompanyPostMapper.delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel の使用

CompanyPostTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostTerminableInternationalModel の使用

CompanyPostTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableInternationalModel CompanyPostTerminableModel.selectCompanyPostTerminableInternationalModel(Locale locale)
指定された言語に該当する役職の期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel の使用

CompanyPostTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での CompanyPostTerminableModel の使用

CompanyPostTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableModel CompanyPostBaseModel.selectCompanyPostTerminableModel(Date date)
指定された日付に該当する役職の期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CompanyPostBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyPostBaseModel
extends BaseModel

役職の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | NAME 役職名
static String | NOTES 備考
static String | POST_CODE 役職コード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getName() 役職名を取得します。
String | getName(Date date) 役職名を取得します。
String | getName(Date date, Locale locale) 役職名を取得します。
String | getName(Locale locale) 役職名を取得します。
String | getNotes() 備考を取得します。
String | getPostCode() 役職コードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
CompanyPostTerminableModel | selectCompanyPostTerminableModel(Date date) 指定された日付に該当する役職の期間化モデルを取得します。
void | setName(String name) 役職名を設定します。
void | setName(String name, Date date) 役職名を設定します。
void | setName(String name, Date date, Locale locale) 役職名を設定します。
void | setName(String name, Locale locale) 役職名を設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

POST_CODE

public static final String POST_CODE
役職コード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
役職名

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getPostCode

public String getPostCode()
                   throws AccessorException
役職コードを取得します。

戻り値:
役職コード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
役職名を取得します。

パラメータ:
date - 日時
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCompanyPostTerminableModel

public CompanyPostTerminableModel selectCompanyPostTerminableModel(Date date)
                                                            throws IllegalTermException
指定された日付に該当する役職の期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
役職の期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyPostMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyPostMapper
extends Mapper

役職に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyPostBaseModel | create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
void | delete(Collection models) 役職の基本モデルを複数削除します。
void | delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。
void | insert(Collection models) 役職の基本モデルを複数挿入します。
void | insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
CompanyPostBaseModel | select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。
void | update(Collection models) 役職の基本モデルを複数更新します。
void | update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyPostBaseModel create(String companyCode,
                                   String postCode)
                            throws MapperException
プライマリキーに該当する役職を生成します。

パラメータ:
companyCode - 会社コード
postCode - 役職コード
戻り値:
プライマリキーに該当する役職の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyPostBaseModel select(String companyCode,
                                   String postCode)
                            throws MapperException
プライマリーキーで特定される役職の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
postCode - 役職コード
戻り値:
役職の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ挿入します。 引数に指定する役職の基本モデルは同一の CompanyPostMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する役職の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
役職の基本モデルを複数挿入します。 引数に指定するものは同一の CompanyPostMapperの create(String,String) で生成された役職の基本モデルの集合である必要があります。

パラメータ:
models - 挿入する役職の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ更新します。 引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する役職の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
役職の基本モデルを複数更新します。 引数に指定するものは同一の CompanyPostMapperの select 系メソッド から取得されたものかで生成された役職の基本モデルの集合である必要があります。

パラメータ:
models - 更新する役職の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyPostBaseModel model)
            throws MapperException
役職の基本モデルを1つだけ削除します。 引数で指定された役職の基本モデルに該当するデータのすべての情報を削除します。引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する役職の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
役職の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する役職の基本モデルは同一の CompanyPostMapperの select 系メソッド から取得された役職の基本モデルの集合である必要があります。

パラメータ:
models - 削除する役職の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface CompanyPostTerminableInternationalModel
extends TerminableInternationalModel

役職の期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 役職名を取得します。
void | setName(String name) 役職名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyPostTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース CompanyPostTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface CompanyPostTerminableModel
extends TerminableModel

役職の期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() 役職名を取得します。
String | getName(Locale locale) 役職名を取得します。
CompanyPostTerminableInternationalModel | selectCompanyPostTerminableInternationalModel(Locale locale) 指定された言語に該当する役職の期間国際化モデルを取得します。
void | setName(String name) 役職名を設定します。
void | setName(String name, Locale locale) 役職名を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
役職名を取得します。

戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
役職名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
役職名を設定します。

パラメータ:
name - 役職名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectCompanyPostTerminableInternationalModel

public CompanyPostTerminableInternationalModel selectCompanyPostTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当する役職の期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
役職の期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.post (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.company.post
インタフェース
CompanyPostBaseModel
CompanyPostMapper
CompanyPostTerminableInternationalModel
CompanyPostTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.company.post (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post

会社役職情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyPostBaseModel | 役職の基本モデルです。
CompanyPostMapper | 役職に関連するマッパです。
CompanyPostTerminableInternationalModel | 役職の期間国際化モデルです。
CompanyPostTerminableModel | 役職の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の説明

会社役職情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.company.post クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.post の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.post 会社役職情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.application.model.company.post のクラス
CompanyPostBaseModel
役職の基本モデルです。
CompanyPostTerminableInternationalModel
役職の期間国際化モデルです。
CompanyPostTerminableModel
役職の期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の使用

CompanyVersionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version 会社バージョン情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での CompanyVersionBaseModel の使用

CompanyVersionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
CompanyVersionBaseModel | CompanyVersionMapper.create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
CompanyVersionBaseModel | CompanyVersionMapper.select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。

CompanyVersionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
void | CompanyVersionMapper.insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
void | CompanyVersionMapper.update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
void | CompanyVersionMapper.delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CompanyVersionBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース CompanyVersionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface CompanyVersionBaseModel
extends BaseModel

会社構成バージョンの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | COMPANY_CODE 会社コード
static String | END_DATE 終了日
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | START_DATE 開始日
static String | VERSION_CODE バージョンコード
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

COMPANY_CODE

public static final String COMPANY_CODE
会社コード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

START_DATE

public static final String START_DATE
開始日

関連項目:
定数フィールド値

END_DATE

public static final String END_DATE
終了日

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getCompanyCode

public String getCompanyCode()
                      throws AccessorException
会社コードを取得します。

戻り値:
会社コード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getStartDate

public Date getStartDate()
                  throws AccessorException
開始日を取得します。

戻り値:
開始日
例外:
AccessorException - データの取得に失敗した場合

setStartDate

public void setStartDate(Date startDate)
                  throws AccessorException
開始日を設定します。

パラメータ:
startDate - 開始日
例外:
AccessorException - データの設定に失敗した場合

getEndDate

public Date getEndDate()
                throws AccessorException
終了日を取得します。

戻り値:
終了日
例外:
AccessorException - データの取得に失敗した場合

setEndDate

public void setEndDate(Date endDate)
                throws AccessorException
終了日を設定します。

パラメータ:
endDate - 終了日
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyVersionMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース CompanyVersionMapper

すべてのスーパーインタフェース:
Mapper
public interface CompanyVersionMapper
extends Mapper

会社構成バージョンに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
CompanyVersionBaseModel | create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
void | delete(Collection models) 会社構成バージョンの基本モデルを複数削除します。
void | delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。
void | insert(Collection models) 会社構成バージョンの基本モデルを複数挿入します。
void | insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
CompanyVersionBaseModel | select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
void | update(Collection models) 会社構成バージョンの基本モデルを複数更新します。
void | update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public CompanyVersionBaseModel create(String companyCode,
                                      String versionCode)
                               throws MapperException
プライマリキーに該当する会社構成バージョンを生成します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
戻り値:
プライマリキーに該当する会社構成バージョンの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public CompanyVersionBaseModel select(String companyCode,
                                      String versionCode)
                               throws MapperException
プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
companyCode - 会社コード
versionCode - バージョンコード
戻り値:
会社構成バージョンの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ挿入します。 引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入する会社構成バージョンの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数挿入します。 引数に指定するものは同一の CompanyVersionMapperの create(String,String) で生成された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 挿入する会社構成バージョンの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ更新します。 引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新する会社構成バージョンの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数更新します。 引数に指定するものは同一の CompanyVersionMapperの select 系メソッド から取得されたものかで生成された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 更新する会社構成バージョンの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(CompanyVersionBaseModel model)
            throws MapperException
会社構成バージョンの基本モデルを1つだけ削除します。 引数で指定された会社構成バージョンの基本モデルに該当するデータのすべての情報を削除します。引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除する会社構成バージョンの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
会社構成バージョンの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定する会社構成バージョンの基本モデルは同一の CompanyVersionMapperの select 系メソッド から取得された会社構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 削除する会社構成バージョンの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.application.model.company.version (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.company.version
インタフェース
CompanyVersionBaseModel
CompanyVersionMapper


jp.co.intra_mart.foundation.datastore.application.model.company.version (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version

会社バージョン情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
CompanyVersionBaseModel | 会社構成バージョンの基本モデルです。
CompanyVersionMapper | 会社構成バージョンに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の説明

会社バージョン情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.company.version クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.company.version の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.version 会社バージョン情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.application.model.company.version のクラス
CompanyVersionBaseModel
会社構成バージョンの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の使用

PrivateGroupAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach プライベートグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での PrivateGroupAttachBaseModel の使用

PrivateGroupAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。

PrivateGroupAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
void | PrivateGroupAttachMapper.insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
void | PrivateGroupAttachMapper.update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
void | PrivateGroupAttachMapper.delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース
PrivateGroupAttachBaseModel
PrivateGroupAttachMapper


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach

プライベートグループ所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PrivateGroupAttachBaseModel | プライベートグループ所属の基本モデルです。
PrivateGroupAttachMapper | プライベートグループ所属に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の説明

プライベートグループ所属情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.private_group.attach クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach プライベートグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のクラス
PrivateGroupAttachBaseModel
プライベートグループ所属の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PrivateGroupAttachBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース PrivateGroupAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PrivateGroupAttachBaseModel
extends BaseModel

プライベートグループ所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | OWNER_CODE 所有者コード
static String | PRIVATE_GROUP_CODE グループコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

OWNER_CODE

public static final String OWNER_CODE
所有者コード

関連項目:
定数フィールド値

PRIVATE_GROUP_CODE

public static final String PRIVATE_GROUP_CODE
グループコード

関連項目:
定数フィールド値

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getOwnerCode

public String getOwnerCode()
                    throws AccessorException
所有者コードを取得します。

戻り値:
所有者コード
例外:
AccessorException - データの取得に失敗した場合

getPrivateGroupCode

public String getPrivateGroupCode()
                           throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupAttachMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
インタフェース PrivateGroupAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface PrivateGroupAttachMapper
extends Mapper

プライベートグループ所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PrivateGroupAttachBaseModel | create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
void | delete(Collection models) プライベートグループ所属の基本モデルを複数削除します。
void | delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。
void | insert(Collection models) プライベートグループ所属の基本モデルを複数挿入します。
void | insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
PrivateGroupAttachBaseModel | select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
void | update(Collection models) プライベートグループ所属の基本モデルを複数更新します。
void | update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PrivateGroupAttachBaseModel create(String ownerCode,
                                          String privateGroupCode,
                                          String userCode)
                                   throws MapperException
プライマリキーに該当するプライベートグループ所属を生成します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
userCode - ユーザコード
戻り値:
プライマリキーに該当するプライベートグループ所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PrivateGroupAttachBaseModel select(String ownerCode,
                                          String privateGroupCode,
                                          String userCode)
                                   throws MapperException
プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
userCode - ユーザコード
戻り値:
プライベートグループ所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ挿入します。 引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するプライベートグループ所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数挿入します。 引数に指定するものは同一の PrivateGroupAttachMapperの create(String,String,String) で生成されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ更新します。 引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するプライベートグループ所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数更新します。 引数に指定するものは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたものかで生成されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PrivateGroupAttachBaseModel model)
            throws MapperException
プライベートグループ所属の基本モデルを1つだけ削除します。 引数で指定されたプライベートグループ所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するプライベートグループ所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
プライベートグループ所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するプライベートグループ所属の基本モデルは同一の PrivateGroupAttachMapperの select 系メソッド から取得されたプライベートグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除するプライベートグループ所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の使用

PrivateGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group プライベートグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での PrivateGroupBaseModel の使用

PrivateGroupBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
PrivateGroupBaseModel | PrivateGroupMapper.create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
PrivateGroupBaseModel | PrivateGroupMapper.select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。

PrivateGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
void | PrivateGroupMapper.insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
void | PrivateGroupMapper.update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
void | PrivateGroupMapper.delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.private_group.group (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース
PrivateGroupBaseModel
PrivateGroupMapper


jp.co.intra_mart.foundation.datastore.application.model.private_group.group (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group

プライベートグループ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PrivateGroupBaseModel | プライベートグループの基本モデルです。
PrivateGroupMapper | プライベートグループに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の説明

プライベートグループ情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.private_group.group クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.private_group.group の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.private_group.group プライベートグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.application.model.private_group.group のクラス
PrivateGroupBaseModel
プライベートグループの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PrivateGroupBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース PrivateGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PrivateGroupBaseModel
extends BaseModel

プライベートグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | NAME グループ名
static String | NAME_ENGLISH グループ名英字
static String | NAME_SYLLABARY グループ名カナ
static String | NOTES 備考
static String | OWNER_CODE 所有者コード
static String | PRIVATE_GROUP_CODE グループコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getOwnerCode() 所有者コードを取得します。
String | getPrivateGroupCode() グループコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

OWNER_CODE

public static final String OWNER_CODE
所有者コード

関連項目:
定数フィールド値

PRIVATE_GROUP_CODE

public static final String PRIVATE_GROUP_CODE
グループコード

関連項目:
定数フィールド値

NAME

public static final String NAME
グループ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
グループ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
グループ名英字

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getOwnerCode

public String getOwnerCode()
                    throws AccessorException
所有者コードを取得します。

戻り値:
所有者コード
例外:
AccessorException - データの取得に失敗した場合

getPrivateGroupCode

public String getPrivateGroupCode()
                           throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PrivateGroupMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.private_group.group
インタフェース PrivateGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface PrivateGroupMapper
extends Mapper

プライベートグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PrivateGroupBaseModel | create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
void | delete(Collection models) プライベートグループの基本モデルを複数削除します。
void | delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。
void | insert(Collection models) プライベートグループの基本モデルを複数挿入します。
void | insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
PrivateGroupBaseModel | select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
void | update(Collection models) プライベートグループの基本モデルを複数更新します。
void | update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PrivateGroupBaseModel create(String ownerCode,
                                    String privateGroupCode)
                             throws MapperException
プライマリキーに該当するプライベートグループを生成します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
戻り値:
プライマリキーに該当するプライベートグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PrivateGroupBaseModel select(String ownerCode,
                                    String privateGroupCode)
                             throws MapperException
プライマリーキーで特定されるプライベートグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
ownerCode - 所有者コード
privateGroupCode - グループコード
戻り値:
プライベートグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ挿入します。 引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するプライベートグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数挿入します。 引数に指定するものは同一の PrivateGroupMapperの create(String,String) で生成されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するプライベートグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ更新します。 引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するプライベートグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数更新します。 引数に指定するものは同一の PrivateGroupMapperの select 系メソッド から取得されたものかで生成されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するプライベートグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PrivateGroupBaseModel model)
            throws MapperException
プライベートグループの基本モデルを1つだけ削除します。 引数で指定されたプライベートグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するプライベートグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
プライベートグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するプライベートグループの基本モデルは同一の PrivateGroupMapperの select 系メソッド から取得されたプライベートグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するプライベートグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の使用

PublicGroupAttachBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach パブリックグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での PublicGroupAttachBaseModel の使用

PublicGroupAttachBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
PublicGroupAttachBaseModel | PublicGroupAttachMapper.create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
PublicGroupAttachBaseModel | PublicGroupAttachMapper.select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。

PublicGroupAttachBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
void | PublicGroupAttachMapper.insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
void | PublicGroupAttachMapper.update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
void | PublicGroupAttachMapper.delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース
PublicGroupAttachBaseModel
PublicGroupAttachMapper
PublicGroupAttachTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach

パブリックグループ所属情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupAttachBaseModel | パブリックグループ所属の基本モデルです。
PublicGroupAttachMapper | パブリックグループ所属に関連するマッパです。
PublicGroupAttachTerminableModel | パブリックグループ所属の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の説明

パブリックグループ所属情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.public_group.attach クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach パブリックグループ所属情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のクラス
PublicGroupAttachBaseModel
パブリックグループ所属の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupAttachBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupAttachBaseModel
extends BaseModel

パブリックグループ所属の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | USER_CODE ユーザコード
メソッドの概要
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getUserCode() ユーザコードを取得します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupAttachMapper
extends Mapper

パブリックグループ所属に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupAttachBaseModel | create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
void | delete(Collection models) パブリックグループ所属の基本モデルを複数削除します。
void | delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ所属の基本モデルを複数挿入します。
void | insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
PublicGroupAttachBaseModel | select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
void | update(Collection models) パブリックグループ所属の基本モデルを複数更新します。
void | update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupAttachBaseModel create(String userCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリキーに該当するパブリックグループ所属を生成します。

パラメータ:
userCode - ユーザコード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループ所属の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupAttachBaseModel select(String userCode,
                                         String publicGroupSetCode,
                                         String publicGroupCode)
                                  throws MapperException
プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
パブリックグループ所属の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの create(String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ所属の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupAttachMapperの create(String,String,String) で生成されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ所属の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupAttachMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupAttachBaseModel model)
            throws MapperException
パブリックグループ所属の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ所属の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ所属の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ所属の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ所属の基本モデルは同一の PublicGroupAttachMapperの select 系メソッド から取得されたパブリックグループ所属の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ所属の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupAttachTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
インタフェース PublicGroupAttachTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupAttachTerminableModel
extends TerminableModel

パブリックグループ所属の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の使用

PublicGroupCategoryBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category パブリックグループ分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での PublicGroupCategoryBaseModel の使用

PublicGroupCategoryBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。

PublicGroupCategoryBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
void | PublicGroupCategoryMapper.insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
void | PublicGroupCategoryMapper.update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
void | PublicGroupCategoryMapper.delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.category (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース
PublicGroupCategoryBaseModel
PublicGroupCategoryMapper
PublicGroupCategoryTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.category (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category

パブリックグループ分類情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupCategoryBaseModel | パブリックグループ分類の基本モデルです。
PublicGroupCategoryMapper | パブリックグループ分類に関連するマッパです。
PublicGroupCategoryTerminableModel | パブリックグループ分類の期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の説明

パブリックグループ分類情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.public_group.category クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.category の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.category パブリックグループ分類情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.category のクラス
PublicGroupCategoryBaseModel
パブリックグループ分類の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupCategoryBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupCategoryBaseModel
extends BaseModel

パブリックグループ分類の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | CATEGORY_CLASS_CODE 分類区分コード
static String | CATEGORY_CODE 分類コード
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getCategoryClassCode() 分類区分コードを取得します。
String | getCategoryCode() 分類コードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

CATEGORY_CLASS_CODE

public static final String CATEGORY_CLASS_CODE
分類区分コード

関連項目:
定数フィールド値

CATEGORY_CODE

public static final String CATEGORY_CODE
分類コード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getCategoryClassCode

public String getCategoryClassCode()
                            throws AccessorException
分類区分コードを取得します。

戻り値:
分類区分コード
例外:
AccessorException - データの取得に失敗した場合

getCategoryCode

public String getCategoryCode()
                       throws AccessorException
分類コードを取得します。

戻り値:
分類コード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupCategoryMapper
extends Mapper

パブリックグループ分類に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupCategoryBaseModel | create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
void | delete(Collection models) パブリックグループ分類の基本モデルを複数削除します。
void | delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ分類の基本モデルを複数挿入します。
void | insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
PublicGroupCategoryBaseModel | select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
void | update(Collection models) パブリックグループ分類の基本モデルを複数更新します。
void | update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupCategoryBaseModel create(String publicGroupSetCode,
                                           String publicGroupCode,
                                           String categoryClassCode,
                                           String categoryCode)
                                    throws MapperException
プライマリキーに該当するパブリックグループ分類を生成します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
プライマリキーに該当するパブリックグループ分類の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupCategoryBaseModel select(String publicGroupSetCode,
                                           String publicGroupCode,
                                           String categoryClassCode,
                                           String categoryCode)
                                    throws MapperException
プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
categoryClassCode - 分類区分コード
categoryCode - 分類コード
戻り値:
パブリックグループ分類の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ分類の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupCategoryMapperの create(String,String,String,String) で生成されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ分類の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupCategoryBaseModel model)
            throws MapperException
パブリックグループ分類の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ分類の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ分類の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ分類の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ分類の基本モデルは同一の PublicGroupCategoryMapperの select 系メソッド から取得されたパブリックグループ分類の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ分類の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupCategoryTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.category
インタフェース PublicGroupCategoryTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupCategoryTerminableModel
extends TerminableModel

パブリックグループ分類の期間化モデルです。

導入されたバージョン:
5.0

インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の使用

PublicGroupBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupBaseModel の使用

PublicGroupBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
PublicGroupBaseModel | PublicGroupMapper.create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
PublicGroupBaseModel | PublicGroupMapper.select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。

PublicGroupBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
void | PublicGroupMapper.insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
void | PublicGroupMapper.update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
void | PublicGroupMapper.delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel の使用

PublicGroupTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupTerminableInternationalModel の使用

PublicGroupTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableInternationalModel PublicGroupTerminableModel.selectPublicGroupTerminableInternationalModel(Locale locale)
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel の使用

PublicGroupTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での PublicGroupTerminableModel の使用

PublicGroupTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableModel PublicGroupBaseModel.selectPublicGroupTerminableModel(Date date)
指定された日付に該当するパブリックグループの期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.group (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース
PublicGroupBaseModel
PublicGroupMapper
PublicGroupTerminableInternationalModel
PublicGroupTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.public_group.group (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group

パブリックグループ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupBaseModel | パブリックグループの基本モデルです。
PublicGroupMapper | パブリックグループに関連するマッパです。
PublicGroupTerminableInternationalModel | パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel | パブリックグループの期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の説明

パブリックグループ情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.public_group.group クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.group の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.group パブリックグループ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.group のクラス
PublicGroupBaseModel
パブリックグループの基本モデルです。
PublicGroupTerminableInternationalModel
パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel
パブリックグループの期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupBaseModel
extends BaseModel

パブリックグループの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | NAME グループ名
static String | NAME_ENGLISH グループ名英字
static String | NAME_SYLLABARY グループ名カナ
static String | NOTES 備考
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
メソッドの概要
String | getName() グループ名を取得します。
String | getName(Date date) グループ名を取得します。
String | getName(Date date, Locale locale) グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Date date) グループ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Date date) グループ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
PublicGroupTerminableModel | selectPublicGroupTerminableModel(Date date) 指定された日付に該当するパブリックグループの期間化モデルを取得します。
void | setName(String name) グループ名を設定します。
void | setName(String name, Date date) グループ名を設定します。
void | setName(String name, Date date, Locale locale) グループ名を設定します。
void | setName(String name, Locale locale) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

NAME

public static final String NAME
グループ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
グループ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
グループ名英字

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
グループ名を取得します。

パラメータ:
date - 日時
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
date - 日時
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
date - 日時
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectPublicGroupTerminableModel

public PublicGroupTerminableModel selectPublicGroupTerminableModel(Date date)
                                                            throws IllegalTermException
指定された日付に該当するパブリックグループの期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
パブリックグループの期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupMapper
extends Mapper

パブリックグループに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupBaseModel | create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
void | delete(Collection models) パブリックグループの基本モデルを複数削除します。
void | delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループの基本モデルを複数挿入します。
void | insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
PublicGroupBaseModel | select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
void | update(Collection models) パブリックグループの基本モデルを複数更新します。
void | update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupBaseModel create(String publicGroupSetCode,
                                   String publicGroupCode)
                            throws MapperException
プライマリキーに該当するパブリックグループを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupBaseModel select(String publicGroupSetCode,
                                   String publicGroupCode)
                            throws MapperException
プライマリーキーで特定されるパブリックグループの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
publicGroupCode - グループコード
戻り値:
パブリックグループの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupMapperの create(String,String) で生成されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ更新します。 引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupMapperの select 系メソッド から取得されたものかで生成されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupBaseModel model)
            throws MapperException
パブリックグループの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループの基本モデルは同一の PublicGroupMapperの select 系メソッド から取得されたパブリックグループの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface PublicGroupTerminableInternationalModel
extends TerminableInternationalModel

パブリックグループの期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
void | setName(String name) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.group
インタフェース PublicGroupTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface PublicGroupTerminableModel
extends TerminableModel

パブリックグループの期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getName() グループ名を取得します。
String | getName(Locale locale) グループ名を取得します。
String | getNameEnglish() グループ名英字を取得します。
String | getNameEnglish(Locale locale) グループ名英字を取得します。
String | getNameSyllabary() グループ名カナを取得します。
String | getNameSyllabary(Locale locale) グループ名カナを取得します。
PublicGroupTerminableInternationalModel | selectPublicGroupTerminableInternationalModel(Locale locale) 指定された言語に該当するパブリックグループの期間国際化モデルを取得します。
void | setName(String name) グループ名を設定します。
void | setName(String name, Locale locale) グループ名を設定します。
void | setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
グループ名を取得します。

戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
グループ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
グループ名を設定します。

パラメータ:
name - グループ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
グループ名カナを取得します。

戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
グループ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
グループ名カナを設定します。

パラメータ:
nameSyllabary - グループ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
グループ名英字を取得します。

戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
グループ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
グループ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
グループ名英字を設定します。

パラメータ:
nameEnglish - グループ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectPublicGroupTerminableInternationalModel

public PublicGroupTerminableInternationalModel selectPublicGroupTerminableInternationalModel(Locale locale)
                                                                                throws IllegalLocaleException
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
パブリックグループの期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の使用

PublicGroupInclusionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion パブリックグループ内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での PublicGroupInclusionBaseModel の使用

PublicGroupInclusionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。

PublicGroupInclusionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
void | PublicGroupInclusionMapper.insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
void | PublicGroupInclusionMapper.update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
void | PublicGroupInclusionMapper.delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース
PublicGroupInclusionBaseModel
PublicGroupInclusionMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion

パブリックグループ内包情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupInclusionBaseModel | パブリックグループ内包の基本モデルです。
PublicGroupInclusionMapper | パブリックグループ内包に関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の説明

パブリックグループ内包情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion パブリックグループ内包情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のクラス
PublicGroupInclusionBaseModel
パブリックグループ内包の基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupInclusionBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース PublicGroupInclusionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupInclusionBaseModel
extends BaseModel

パブリックグループ内包の基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | DEPTH 階層レベル
static String | PARENT_PUBLIC_GROUP_CODE 親グループコード
static String | PUBLIC_GROUP_CODE グループコード
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | VERSION_CODE バージョンコード
メソッドの概要
int | getDepth() 階層レベルを取得します。
String | getParentPublicGroupCode() 親グループコードを取得します。
String | getPublicGroupCode() グループコードを取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setDepth(int depth) 階層レベルを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

PARENT_PUBLIC_GROUP_CODE

public static final String PARENT_PUBLIC_GROUP_CODE
親グループコード

関連項目:
定数フィールド値

PUBLIC_GROUP_CODE

public static final String PUBLIC_GROUP_CODE
グループコード

関連項目:
定数フィールド値

DEPTH

public static final String DEPTH
階層レベル

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getParentPublicGroupCode

public String getParentPublicGroupCode()
                                throws AccessorException
親グループコードを取得します。

戻り値:
親グループコード
例外:
AccessorException - データの取得に失敗した場合

getPublicGroupCode

public String getPublicGroupCode()
                          throws AccessorException
グループコードを取得します。

戻り値:
グループコード
例外:
AccessorException - データの取得に失敗した場合

getDepth

public int getDepth()
             throws AccessorException
階層レベルを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
階層レベル
例外:
AccessorException - データの取得に失敗した場合

setDepth

public void setDepth(int depth)
              throws AccessorException
階層レベルを設定します。

パラメータ:
depth - 階層レベル
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupInclusionMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
インタフェース PublicGroupInclusionMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupInclusionMapper
extends Mapper

パブリックグループ内包に関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupInclusionBaseModel | create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
void | delete(Collection models) パブリックグループ内包の基本モデルを複数削除します。
void | delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ内包の基本モデルを複数挿入します。
void | insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
PublicGroupInclusionBaseModel | select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
void | update(Collection models) パブリックグループ内包の基本モデルを複数更新します。
void | update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupInclusionBaseModel create(String publicGroupSetCode,
                                            String versionCode,
                                            String parentPublicGroupCode,
                                            String publicGroupCode)
                                     throws MapperException
プライマリキーに該当するパブリックグループ内包を生成します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
parentPublicGroupCode - 親グループコード
publicGroupCode - グループコード
戻り値:
プライマリキーに該当するパブリックグループ内包の基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupInclusionBaseModel select(String publicGroupSetCode,
                                            String versionCode,
                                            String parentPublicGroupCode,
                                            String publicGroupCode)
                                     throws MapperException
プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
parentPublicGroupCode - 親グループコード
publicGroupCode - グループコード
戻り値:
パブリックグループ内包の基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの create(String,String,String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ内包の基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupInclusionMapperの create(String,String,String,String) で生成されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ更新します。 引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ内包の基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupInclusionBaseModel model)
            throws MapperException
パブリックグループ内包の基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ内包の基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ内包の基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ内包の基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ内包の基本モデルは同一の PublicGroupInclusionMapperの select 系メソッド から取得されたパブリックグループ内包の基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ内包の基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の使用

PublicGroupSetBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set パブリックグループセット情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での PublicGroupSetBaseModel の使用

PublicGroupSetBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
PublicGroupSetBaseModel | PublicGroupSetMapper.create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
PublicGroupSetBaseModel | PublicGroupSetMapper.select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。

PublicGroupSetBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
void | PublicGroupSetMapper.insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
void | PublicGroupSetMapper.update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
void | PublicGroupSetMapper.delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.set (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース
PublicGroupSetBaseModel
PublicGroupSetMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.set (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set

パブリックグループセット情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupSetBaseModel | パブリックグループセットの基本モデルです。
PublicGroupSetMapper | パブリックグループセットに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の説明

パブリックグループセット情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.public_group.set クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.set の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.set パブリックグループセット情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.set のクラス
PublicGroupSetBaseModel
パブリックグループセットの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupSetBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース PublicGroupSetBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupSetBaseModel
extends BaseModel

パブリックグループセットの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
メソッドの概要
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupSetMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.set
インタフェース PublicGroupSetMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupSetMapper
extends Mapper

パブリックグループセットに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupSetBaseModel | create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
void | delete(Collection models) パブリックグループセットの基本モデルを複数削除します。
void | delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループセットの基本モデルを複数挿入します。
void | insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
PublicGroupSetBaseModel | select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
void | update(Collection models) パブリックグループセットの基本モデルを複数更新します。
void | update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupSetBaseModel create(String publicGroupSetCode)
                               throws MapperException
プライマリキーに該当するパブリックグループセットを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
戻り値:
プライマリキーに該当するパブリックグループセットの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupSetBaseModel select(String publicGroupSetCode)
                               throws MapperException
プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
戻り値:
パブリックグループセットの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループセットの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupSetMapperの create(String) で生成されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループセットの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ更新します。 引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループセットの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupSetMapperの select 系メソッド から取得されたものかで生成されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループセットの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupSetBaseModel model)
            throws MapperException
パブリックグループセットの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループセットの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループセットの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループセットの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループセットの基本モデルは同一の PublicGroupSetMapperの select 系メソッド から取得されたパブリックグループセットの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループセットの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の使用

PublicGroupVersionBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version パブリックグループバーション情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での PublicGroupVersionBaseModel の使用

PublicGroupVersionBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
PublicGroupVersionBaseModel | PublicGroupVersionMapper.create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
PublicGroupVersionBaseModel | PublicGroupVersionMapper.select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。

PublicGroupVersionBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
void | PublicGroupVersionMapper.insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
void | PublicGroupVersionMapper.update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
void | PublicGroupVersionMapper.delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.public_group.version (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース
PublicGroupVersionBaseModel
PublicGroupVersionMapper


jp.co.intra_mart.foundation.datastore.application.model.public_group.version (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version

パブリックグループバーション情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
PublicGroupVersionBaseModel | パブリックグループ構成バージョンの基本モデルです。
PublicGroupVersionMapper | パブリックグループ構成バージョンに関連するマッパです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の説明

パブリックグループバーション情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.public_group.version クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.public_group.version の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.public_group.version パブリックグループバーション情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.application.model.public_group.version のクラス
PublicGroupVersionBaseModel
パブリックグループ構成バージョンの基本モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupVersionBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース PublicGroupVersionBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface PublicGroupVersionBaseModel
extends BaseModel

パブリックグループ構成バージョンの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | END_DATE 終了日
static String | NOTES 備考
static String | PUBLIC_GROUP_SET_CODE グループセットコード
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | START_DATE 開始日
static String | VERSION_CODE バージョンコード
メソッドの概要
Date | getEndDate() 終了日を取得します。
String | getNotes() 備考を取得します。
String | getPublicGroupSetCode() グループセットコードを取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
Date | getStartDate() 開始日を取得します。
String | getVersionCode() バージョンコードを取得します。
void | setEndDate(Date endDate) 終了日を設定します。
void | setNotes(String notes) 備考を設定します。
void | setStartDate(Date startDate) 開始日を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

PUBLIC_GROUP_SET_CODE

public static final String PUBLIC_GROUP_SET_CODE
グループセットコード

関連項目:
定数フィールド値

VERSION_CODE

public static final String VERSION_CODE
バージョンコード

関連項目:
定数フィールド値

START_DATE

public static final String START_DATE
開始日

関連項目:
定数フィールド値

END_DATE

public static final String END_DATE
終了日

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値
メソッドの詳細

getPublicGroupSetCode

public String getPublicGroupSetCode()
                             throws AccessorException
グループセットコードを取得します。

戻り値:
グループセットコード
例外:
AccessorException - データの取得に失敗した場合

getVersionCode

public String getVersionCode()
                      throws AccessorException
バージョンコードを取得します。

戻り値:
バージョンコード
例外:
AccessorException - データの取得に失敗した場合

getStartDate

public Date getStartDate()
                  throws AccessorException
開始日を取得します。

戻り値:
開始日
例外:
AccessorException - データの取得に失敗した場合

setStartDate

public void setStartDate(Date startDate)
                  throws AccessorException
開始日を設定します。

パラメータ:
startDate - 開始日
例外:
AccessorException - データの設定に失敗した場合

getEndDate

public Date getEndDate()
                throws AccessorException
終了日を取得します。

戻り値:
終了日
例外:
AccessorException - データの取得に失敗した場合

setEndDate

public void setEndDate(Date endDate)
                throws AccessorException
終了日を設定します。

パラメータ:
endDate - 終了日
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PublicGroupVersionMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.public_group.version
インタフェース PublicGroupVersionMapper

すべてのスーパーインタフェース:
Mapper
public interface PublicGroupVersionMapper
extends Mapper

パブリックグループ構成バージョンに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
PublicGroupVersionBaseModel | create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
void | delete(Collection models) パブリックグループ構成バージョンの基本モデルを複数削除します。
void | delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
void | insert(Collection models) パブリックグループ構成バージョンの基本モデルを複数挿入します。
void | insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
PublicGroupVersionBaseModel | select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
void | update(Collection models) パブリックグループ構成バージョンの基本モデルを複数更新します。
void | update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public PublicGroupVersionBaseModel create(String publicGroupSetCode,
                                          String versionCode)
                                   throws MapperException
プライマリキーに該当するパブリックグループ構成バージョンを生成します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
戻り値:
プライマリキーに該当するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public PublicGroupVersionBaseModel select(String publicGroupSetCode,
                                          String versionCode)
                                   throws MapperException
プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
publicGroupSetCode - グループセットコード
versionCode - バージョンコード
戻り値:
パブリックグループ構成バージョンの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。 引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの create(String,String) で生成されたものである必要があります。

パラメータ:
model - 挿入するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数挿入します。 引数に指定するものは同一の PublicGroupVersionMapperの create(String,String) で生成されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ更新します。 引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数更新します。 引数に指定するものは同一の PublicGroupVersionMapperの select 系メソッド から取得されたものかで生成されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 更新するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(PublicGroupVersionBaseModel model)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを1つだけ削除します。 引数で指定されたパブリックグループ構成バージョンの基本モデルに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するパブリックグループ構成バージョンの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
パブリックグループ構成バージョンの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するパブリックグループ構成バージョンの基本モデルは同一の PublicGroupVersionMapperの select 系メソッド から取得されたパブリックグループ構成バージョンの基本モデルの集合である必要があります。

パラメータ:
models - 削除するパブリックグループ構成バージョンの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の使用

UserBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserBaseModel の使用

UserBaseModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
UserBaseModel | UserMapper.create(String userCode) プライマリキーに該当するユーザを生成します。
UserBaseModel | UserMapper.select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。

UserBaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
void | UserMapper.insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
void | UserMapper.update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
void | UserMapper.delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper の使用

jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel の使用

UserTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserTerminableInternationalModel の使用

UserTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableInternationalModel UserTerminableModel.selectUserTerminableInternationalModel(Locale locale)
指定された言語に該当するユーザの期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel の使用

UserTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user での UserTerminableModel の使用

UserTerminableModel を返す jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableModel UserBaseModel.selectUserTerminableModel(Date date)
指定された日付に該当するユーザの期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.application.model.user (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース
UserBaseModel
UserMapper
UserTerminableInternationalModel
UserTerminableModel


jp.co.intra_mart.foundation.datastore.application.model.user (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user

ユーザ情報を操作するマッパーとモデルを提供します。

参照:
説明

インタフェースの概要
UserBaseModel | ユーザの基本モデルです。
UserMapper | ユーザに関連するマッパです。
UserTerminableInternationalModel | ユーザの期間国際化モデルです。
UserTerminableModel | ユーザの期間化モデルです。

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の説明

ユーザ情報を操作するマッパーとモデルを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.application.model.user クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.application.model.user の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.application.model.user の使用

jp.co.intra_mart.foundation.datastore.application.model.user を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.user ユーザ情報を操作するマッパーとモデルを提供します。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.application.model.user のクラス
UserBaseModel
ユーザの基本モデルです。
UserTerminableInternationalModel
ユーザの期間国際化モデルです。
UserTerminableModel
ユーザの期間化モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


UserBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserBaseModel

すべてのスーパーインタフェース:
BaseModel, Serializable
public interface UserBaseModel
extends BaseModel

ユーザの基本モデルです。

導入されたバージョン:
5.0

フィールドの概要
static String | ACCOUNT_FLAG アカウントフラグ
static String | ADDRESS 住所
static String | AVALIABLE_LOGIN_USER ログインできるアカウントを表す定数
static String | COUNTRY_CODE 国コード
static String | EMAIL_ADDRESS1 メールアドレス１
static String | EMAIL_ADDRESS2 メールアドレス２
static String | EXTENSION_FAX_NUMBER 内線FAX番号
static String | EXTENSION_NUMBER 内線番号
static String | FAX_NUMBER FAX番号
static String | MOBILE_EMAIL_ADDRESS 携帯用メール
static String | MOBILE_NUMBER 携帯電話番号
static String | NAME ユーザ名
static String | NAME_ENGLISH ユーザ名英字
static String | NAME_SYLLABARY ユーザ名カナ
static String | NOTES 備考
static String | RECORD_DATE 最終更新日
static String | RECORD_USER_CODE 最終更新者
static String | SORT_KEY ソートキー
static String | TELEPHONE_NUMBER 電話番号
static String | UNAVALIABLE_LOGIN_USER ログイン出来ないアカウントを表す定数
static String | URL URL
static String | USER_CODE ユーザコード
static String | ZIP_CODE 郵便番号
メソッドの概要
String | getAccountFlag() アカウントフラグを取得します。
String | getAddress() 住所を取得します。
String | getAddress(Date date) 住所を取得します。
String | getAddress(Date date, Locale locale) 住所を取得します。
String | getAddress(Locale locale) 住所を取得します。
String | getCountryCode() 国コードを取得します。
String | getCountryCode(Date date) 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress1(Date date) メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getEmailAddress2(Date date) メールアドレス２を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getExtensionNumber(Date date) 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getFaxNumber(Date date) FAX番号を取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileEmailAddress(Date date) 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getMobileNumber(Date date) 携帯電話番号を取得します。
String | getName() ユーザ名を取得します。
String | getName(Date date) ユーザ名を取得します。
String | getName(Date date, Locale locale) ユーザ名を取得します。
String | getName(Locale locale) ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameEnglish(Date date) ユーザ名英字を取得します。
String | getNameEnglish(Date date, Locale locale) ユーザ名英字を取得します。
String | getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
String | getNameSyllabary(Date date) ユーザ名カナを取得します。
String | getNameSyllabary(Date date, Locale locale) ユーザ名カナを取得します。
String | getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | getNotes() 備考を取得します。
Date | getRecordDate() 最終更新日を取得します。
String | getRecordUserCode() 最終更新者を取得します。
int | getSortKey() ソートキーを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getTelephoneNumber(Date date) 電話番号を取得します。
String | getUrl() URLを取得します。
String | getUrl(Date date) URLを取得します。
String | getUserCode() ユーザコードを取得します。
String | getZipCode() 郵便番号を取得します。
String | getZipCode(Date date) 郵便番号を取得します。
UserTerminableModel | selectUserTerminableModel(Date date) 指定された日付に該当するユーザの期間化モデルを取得します。
void | setAccountFlag(String accountFlag) アカウントフラグを設定します。
void | setAddress(String address) 住所を設定します。
void | setAddress(String address, Date date) 住所を設定します。
void | setAddress(String address, Date date, Locale locale) 住所を設定します。
void | setAddress(String address, Locale locale) 住所を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setCountryCode(String countryCode, Date date) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress1(String emailAddress1, Date date) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setEmailAddress2(String emailAddress2, Date date) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileEmailAddress(String mobileEmailAddress, Date date) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setMobileNumber(String mobileNumber, Date date) 携帯電話番号を設定します。
void | setName(String name) ユーザ名を設定します。
void | setName(String name, Date date) ユーザ名を設定します。
void | setName(String name, Date date, Locale locale) ユーザ名を設定します。
void | setName(String name, Locale locale) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Date date, Locale locale) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Date date, Locale locale) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | setNotes(String notes) 備考を設定します。
void | setSortKey(int sortKey) ソートキーを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setUrl(String url, Date date) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
void | setZipCode(String zipCode, Date date) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel から継承したメソッド
getBaseAccessor, getExtendedBaseModelMap, getInternationalModelMap, getTerminableModelMap, init

フィールドの詳細

USER_CODE

public static final String USER_CODE
ユーザコード

関連項目:
定数フィールド値

ACCOUNT_FLAG

public static final String ACCOUNT_FLAG
アカウントフラグ

関連項目:
定数フィールド値

NOTES

public static final String NOTES
備考

関連項目:
定数フィールド値

SORT_KEY

public static final String SORT_KEY
ソートキー

関連項目:
定数フィールド値

RECORD_USER_CODE

public static final String RECORD_USER_CODE
最終更新者

関連項目:
定数フィールド値

RECORD_DATE

public static final String RECORD_DATE
最終更新日

関連項目:
定数フィールド値

TELEPHONE_NUMBER

public static final String TELEPHONE_NUMBER
電話番号

関連項目:
定数フィールド値

MOBILE_NUMBER

public static final String MOBILE_NUMBER
携帯電話番号

関連項目:
定数フィールド値

FAX_NUMBER

public static final String FAX_NUMBER
FAX番号

関連項目:
定数フィールド値

EXTENSION_NUMBER

public static final String EXTENSION_NUMBER
内線番号

関連項目:
定数フィールド値

EXTENSION_FAX_NUMBER

public static final String EXTENSION_FAX_NUMBER
内線FAX番号

関連項目:
定数フィールド値

COUNTRY_CODE

public static final String COUNTRY_CODE
国コード

関連項目:
定数フィールド値

ZIP_CODE

public static final String ZIP_CODE
郵便番号

関連項目:
定数フィールド値

EMAIL_ADDRESS1

public static final String EMAIL_ADDRESS1
メールアドレス１

関連項目:
定数フィールド値

EMAIL_ADDRESS2

public static final String EMAIL_ADDRESS2
メールアドレス２

関連項目:
定数フィールド値

MOBILE_EMAIL_ADDRESS

public static final String MOBILE_EMAIL_ADDRESS
携帯用メール

関連項目:
定数フィールド値

URL

public static final String URL
URL

関連項目:
定数フィールド値

NAME

public static final String NAME
ユーザ名

関連項目:
定数フィールド値

NAME_SYLLABARY

public static final String NAME_SYLLABARY
ユーザ名カナ

関連項目:
定数フィールド値

NAME_ENGLISH

public static final String NAME_ENGLISH
ユーザ名英字

関連項目:
定数フィールド値

ADDRESS

public static final String ADDRESS
住所

関連項目:
定数フィールド値

UNAVALIABLE_LOGIN_USER

public static final String UNAVALIABLE_LOGIN_USER
ログイン出来ないアカウントを表す定数

関連項目:
定数フィールド値

AVALIABLE_LOGIN_USER

public static final String AVALIABLE_LOGIN_USER
ログインできるアカウントを表す定数

関連項目:
定数フィールド値
メソッドの詳細

getUserCode

public String getUserCode()
                   throws AccessorException
ユーザコードを取得します。

戻り値:
ユーザコード
例外:
AccessorException - データの取得に失敗した場合

getAccountFlag

public String getAccountFlag()
                      throws AccessorException
アカウントフラグを取得します。

戻り値:
アカウントフラグ
例外:
AccessorException - データの取得に失敗した場合

setAccountFlag

public void setAccountFlag(String accountFlag)
                    throws AccessorException
アカウントフラグを設定します。

パラメータ:
accountFlag - アカウントフラグ
例外:
AccessorException - データの設定に失敗した場合

getNotes

public String getNotes()
                throws AccessorException
備考を取得します。

戻り値:
備考
例外:
AccessorException - データの取得に失敗した場合

setNotes

public void setNotes(String notes)
              throws AccessorException
備考を設定します。

パラメータ:
notes - 備考
例外:
AccessorException - データの設定に失敗した場合

getSortKey

public int getSortKey()
               throws AccessorException
ソートキーを取得します。 値が設定されてない場合に、このメソッドを呼び出すとNullPointerExceptionが発生します。

戻り値:
ソートキー
例外:
AccessorException - データの取得に失敗した場合

setSortKey

public void setSortKey(int sortKey)
                throws AccessorException
ソートキーを設定します。

パラメータ:
sortKey - ソートキー
例外:
AccessorException - データの設定に失敗した場合

getRecordUserCode

public String getRecordUserCode()
                         throws AccessorException
最終更新者を取得します。

戻り値:
最終更新者
例外:
AccessorException - データの取得に失敗した場合

getRecordDate

public Date getRecordDate()
                   throws AccessorException
最終更新日を取得します。

戻り値:
最終更新日
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

getTelephoneNumber

public String getTelephoneNumber(Date date)
                          throws AccessorException
電話番号を取得します。

パラメータ:
date - 日時
戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber,
                               Date date)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getMobileNumber

public String getMobileNumber()
                       throws AccessorException
携帯電話番号を取得します。

戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

getMobileNumber

public String getMobileNumber(Date date)
                       throws AccessorException
携帯電話番号を取得します。

パラメータ:
date - 日時
戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
例外:
AccessorException - データの設定に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber,
                            Date date)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

getFaxNumber

public String getFaxNumber(Date date)
                    throws AccessorException
FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber,
                         Date date)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionNumber

public String getExtensionNumber(Date date)
                          throws AccessorException
内線番号を取得します。

パラメータ:
date - 日時
戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber,
                               Date date)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber(Date date)
                             throws AccessorException
内線FAX番号を取得します。

パラメータ:
date - 日時
戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber,
                                  Date date)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

getCountryCode

public String getCountryCode(Date date)
                      throws AccessorException
国コードを取得します。

パラメータ:
date - 日時
戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

setCountryCode

public void setCountryCode(String countryCode,
                           Date date)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

getZipCode

public String getZipCode(Date date)
                  throws AccessorException
郵便番号を取得します。

パラメータ:
date - 日時
戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

setZipCode

public void setZipCode(String zipCode,
                       Date date)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス１を取得します。

戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress1

public String getEmailAddress1(Date date)
                        throws AccessorException
メールアドレス１を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1,
                             Date date)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス２を取得します。

戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

getEmailAddress2

public String getEmailAddress2(Date date)
                        throws AccessorException
メールアドレス２を取得します。

パラメータ:
date - 日時
戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
例外:
AccessorException - データの設定に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2,
                             Date date)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress()
                             throws AccessorException
携帯用メールを取得します。

戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress(Date date)
                             throws AccessorException
携帯用メールを取得します。

パラメータ:
date - 日時
戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
例外:
AccessorException - データの設定に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress,
                                  Date date)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

getUrl

public String getUrl(Date date)
              throws AccessorException
URLを取得します。

パラメータ:
date - 日時
戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

setUrl

public void setUrl(String url,
                   Date date)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
date - 日時
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Date date,
                      Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Date date,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Date date,
                               Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Date date,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
date - 日時
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Date date,
                             Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Date date,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Date date)
                  throws AccessorException
住所を取得します。

パラメータ:
date - 日時
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Date date,
                         Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
date - 日時
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Date date)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
date - 日時
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Date date,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
date - 日時
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectUserTerminableModel

public UserTerminableModel selectUserTerminableModel(Date date)
                                              throws IllegalTermException
指定された日付に該当するユーザの期間化モデルを取得します。

パラメータ:
date - 指定日付
戻り値:
ユーザの期間化モデル
例外:
IllegalTermException - 指定された日付に該当する期間が定義されていない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserMapper

すべてのスーパーインタフェース:
Mapper
public interface UserMapper
extends Mapper

ユーザに関連するマッパです。

導入されたバージョン:
5.0

メソッドの概要
UserBaseModel | create(String userCode) プライマリキーに該当するユーザを生成します。
void | delete(Collection models) ユーザの基本モデルを複数削除します。
void | delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。
void | insert(Collection models) ユーザの基本モデルを複数挿入します。
void | insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
UserBaseModel | select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。
void | update(Collection models) ユーザの基本モデルを複数更新します。
void | update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper から継承したメソッド
checkByBaseProperty, close, createBaseModel, init, isClosed, notifyDelete, notifyUpdate, select

メソッドの詳細

create

public UserBaseModel create(String userCode)
                     throws MapperException
プライマリキーに該当するユーザを生成します。

パラメータ:
userCode - ユーザコード
戻り値:
プライマリキーに該当するユーザの基本モデル
例外:
MapperException - モデルの生成に失敗した場合

select

public UserBaseModel select(String userCode)
                     throws MapperException
プライマリーキーで特定されるユーザの基本モデルを取得します。 取得されるモデルにはすべてのプロパティの値が設定されています。
検索条件に一致するデータがないときはnullを返します。

パラメータ:
userCode - ユーザコード
戻り値:
ユーザの基本モデル
例外:
MapperException - 検索で例外が発生した場合

insert

public void insert(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ挿入します。 引数に指定するユーザの基本モデルは同一の UserMapperの create(String) で生成されたものである必要があります。

パラメータ:
model - 挿入するユーザの基本モデル
例外:
MapperException - 挿入で何らかの例外が発生した場合

insert

public void insert(Collection models)
            throws MapperException
ユーザの基本モデルを複数挿入します。 引数に指定するものは同一の UserMapperの create(String) で生成されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 挿入するユーザの基本モデルの集合
例外:
MapperException - 挿入で何らかの例外が発生した場合

update

public void update(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ更新します。 引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたもので生成されたものである必要があります。

パラメータ:
model - 更新するユーザの基本モデル
例外:
MapperException - 更新で何らかの例外が発生した場合

update

public void update(Collection models)
            throws MapperException
ユーザの基本モデルを複数更新します。 引数に指定するものは同一の UserMapperの select 系メソッド から取得されたものかで生成されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 更新するユーザの基本モデルの集合
例外:
MapperException - 更新で何らかの例外が発生した場合

delete

public void delete(UserBaseModel model)
            throws MapperException
ユーザの基本モデルを1つだけ削除します。 引数で指定されたユーザの基本モデルに該当するデータのすべての情報を削除します。引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するユーザの基本モデル
例外:
MapperException - 削除で何らかの例外が発生した場合

delete

public void delete(Collection models)
            throws MapperException
ユーザの基本モデルを複数削除します。 引数で指定されたものに該当するデータのすべての情報を削除します。引数に指定するユーザの基本モデルは同一の UserMapperの select 系メソッド から取得されたユーザの基本モデルの集合である必要があります。

パラメータ:
models - 削除するユーザの基本モデルの集合
例外:
MapperException - 削除で何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable, TerminableInternationalModel
public interface UserTerminableInternationalModel
extends TerminableInternationalModel

ユーザの期間国際化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress() 住所を取得します。
String | getName() ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
void | setAddress(String address) 住所を設定します。
void | setName(String name) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel から継承したメソッド
getExtendedTerminableInternationalModelMap, getLocale, init

メソッドの詳細

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.application.model.user
インタフェース UserTerminableModel

すべてのスーパーインタフェース:
Serializable, TerminableModel
public interface UserTerminableModel
extends TerminableModel

ユーザの期間化モデルです。

導入されたバージョン:
5.0

メソッドの概要
String | getAddress() 住所を取得します。
String | getAddress(Locale locale) 住所を取得します。
String | getCountryCode() 国コードを取得します。
String | getEmailAddress1() メールアドレス１を取得します。
String | getEmailAddress2() メールアドレス２を取得します。
String | getExtensionFaxNumber() 内線FAX番号を取得します。
String | getExtensionNumber() 内線番号を取得します。
String | getFaxNumber() FAX番号を取得します。
String | getMobileEmailAddress() 携帯用メールを取得します。
String | getMobileNumber() 携帯電話番号を取得します。
String | getName() ユーザ名を取得します。
String | getName(Locale locale) ユーザ名を取得します。
String | getNameEnglish() ユーザ名英字を取得します。
String | getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | getNameSyllabary() ユーザ名カナを取得します。
String | getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | getTelephoneNumber() 電話番号を取得します。
String | getUrl() URLを取得します。
String | getZipCode() 郵便番号を取得します。
UserTerminableInternationalModel | selectUserTerminableInternationalModel(Locale locale) 指定された言語に該当するユーザの期間国際化モデルを取得します。
void | setAddress(String address) 住所を設定します。
void | setAddress(String address, Locale locale) 住所を設定します。
void | setCountryCode(String countryCode) 国コードを設定します。
void | setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | setFaxNumber(String faxNumber) FAX番号を設定します。
void | setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | setName(String name) ユーザ名を設定します。
void | setName(String name, Locale locale) ユーザ名を設定します。
void | setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | setUrl(String url) URLを設定します。
void | setZipCode(String zipCode) 郵便番号を設定します。
インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel から継承したメソッド
getExtendedTerminableModelMap, getTerm, getTerminableInternationalModelMap, init

メソッドの詳細

getTelephoneNumber

public String getTelephoneNumber()
                          throws AccessorException
電話番号を取得します。

戻り値:
電話番号
例外:
AccessorException - データの取得に失敗した場合

setTelephoneNumber

public void setTelephoneNumber(String telephoneNumber)
                        throws AccessorException
電話番号を設定します。

パラメータ:
telephoneNumber - 電話番号
例外:
AccessorException - データの設定に失敗した場合

getMobileNumber

public String getMobileNumber()
                       throws AccessorException
携帯電話番号を取得します。

戻り値:
携帯電話番号
例外:
AccessorException - データの取得に失敗した場合

setMobileNumber

public void setMobileNumber(String mobileNumber)
                     throws AccessorException
携帯電話番号を設定します。

パラメータ:
mobileNumber - 携帯電話番号
例外:
AccessorException - データの設定に失敗した場合

getFaxNumber

public String getFaxNumber()
                    throws AccessorException
FAX番号を取得します。

戻り値:
FAX番号
例外:
AccessorException - データの取得に失敗した場合

setFaxNumber

public void setFaxNumber(String faxNumber)
                  throws AccessorException
FAX番号を設定します。

パラメータ:
faxNumber - FAX番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionNumber

public String getExtensionNumber()
                          throws AccessorException
内線番号を取得します。

戻り値:
内線番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionNumber

public void setExtensionNumber(String extensionNumber)
                        throws AccessorException
内線番号を設定します。

パラメータ:
extensionNumber - 内線番号
例外:
AccessorException - データの設定に失敗した場合

getExtensionFaxNumber

public String getExtensionFaxNumber()
                             throws AccessorException
内線FAX番号を取得します。

戻り値:
内線FAX番号
例外:
AccessorException - データの取得に失敗した場合

setExtensionFaxNumber

public void setExtensionFaxNumber(String extensionFaxNumber)
                           throws AccessorException
内線FAX番号を設定します。

パラメータ:
extensionFaxNumber - 内線FAX番号
例外:
AccessorException - データの設定に失敗した場合

getCountryCode

public String getCountryCode()
                      throws AccessorException
国コードを取得します。

戻り値:
国コード
例外:
AccessorException - データの取得に失敗した場合

setCountryCode

public void setCountryCode(String countryCode)
                    throws AccessorException
国コードを設定します。

パラメータ:
countryCode - 国コード
例外:
AccessorException - データの設定に失敗した場合

getZipCode

public String getZipCode()
                  throws AccessorException
郵便番号を取得します。

戻り値:
郵便番号
例外:
AccessorException - データの取得に失敗した場合

setZipCode

public void setZipCode(String zipCode)
                throws AccessorException
郵便番号を設定します。

パラメータ:
zipCode - 郵便番号
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress1

public String getEmailAddress1()
                        throws AccessorException
メールアドレス１を取得します。

戻り値:
メールアドレス１
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress1

public void setEmailAddress1(String emailAddress1)
                      throws AccessorException
メールアドレス１を設定します。

パラメータ:
emailAddress1 - メールアドレス１
例外:
AccessorException - データの設定に失敗した場合

getEmailAddress2

public String getEmailAddress2()
                        throws AccessorException
メールアドレス２を取得します。

戻り値:
メールアドレス２
例外:
AccessorException - データの取得に失敗した場合

setEmailAddress2

public void setEmailAddress2(String emailAddress2)
                      throws AccessorException
メールアドレス２を設定します。

パラメータ:
emailAddress2 - メールアドレス２
例外:
AccessorException - データの設定に失敗した場合

getMobileEmailAddress

public String getMobileEmailAddress()
                             throws AccessorException
携帯用メールを取得します。

戻り値:
携帯用メール
例外:
AccessorException - データの取得に失敗した場合

setMobileEmailAddress

public void setMobileEmailAddress(String mobileEmailAddress)
                           throws AccessorException
携帯用メールを設定します。

パラメータ:
mobileEmailAddress - 携帯用メール
例外:
AccessorException - データの設定に失敗した場合

getUrl

public String getUrl()
              throws AccessorException
URLを取得します。

戻り値:
URL
例外:
AccessorException - データの取得に失敗した場合

setUrl

public void setUrl(String url)
            throws AccessorException
URLを設定します。

パラメータ:
url - URL
例外:
AccessorException - データの設定に失敗した場合

getName

public String getName()
               throws AccessorException
ユーザ名を取得します。

戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

getName

public String getName(Locale locale)
               throws AccessorException
ユーザ名を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名
例外:
AccessorException - データの取得に失敗した場合

setName

public void setName(String name)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
例外:
AccessorException - データの設定に失敗した場合

setName

public void setName(String name,
                    Locale locale)
             throws AccessorException
ユーザ名を設定します。

パラメータ:
name - ユーザ名
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameSyllabary

public String getNameSyllabary()
                        throws AccessorException
ユーザ名カナを取得します。

戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

getNameSyllabary

public String getNameSyllabary(Locale locale)
                        throws AccessorException
ユーザ名カナを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名カナ
例外:
AccessorException - データの取得に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
例外:
AccessorException - データの設定に失敗した場合

setNameSyllabary

public void setNameSyllabary(String nameSyllabary,
                             Locale locale)
                      throws AccessorException
ユーザ名カナを設定します。

パラメータ:
nameSyllabary - ユーザ名カナ
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getNameEnglish

public String getNameEnglish()
                      throws AccessorException
ユーザ名英字を取得します。

戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

getNameEnglish

public String getNameEnglish(Locale locale)
                      throws AccessorException
ユーザ名英字を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザ名英字
例外:
AccessorException - データの取得に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
例外:
AccessorException - データの設定に失敗した場合

setNameEnglish

public void setNameEnglish(String nameEnglish,
                           Locale locale)
                    throws AccessorException
ユーザ名英字を設定します。

パラメータ:
nameEnglish - ユーザ名英字
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

getAddress

public String getAddress()
                  throws AccessorException
住所を取得します。

戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

getAddress

public String getAddress(Locale locale)
                  throws AccessorException
住所を取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
住所
例外:
AccessorException - データの取得に失敗した場合

setAddress

public void setAddress(String address)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
例外:
AccessorException - データの設定に失敗した場合

setAddress

public void setAddress(String address,
                       Locale locale)
                throws AccessorException
住所を設定します。

パラメータ:
address - 住所
locale - 言語（ロケール）
例外:
AccessorException - データの設定に失敗した場合

selectUserTerminableInternationalModel

public UserTerminableInternationalModel selectUserTerminableInternationalModel(Locale locale)
                                                                        throws IllegalLocaleException
指定された言語に該当するユーザの期間国際化モデルを取得します。

パラメータ:
locale - 言語（ロケール）
戻り値:
ユーザの期間国際化モデル
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor の使用

BaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での BaseAccessor の使用

BaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
BaseAccessor | TerminableAccessor.getBaseAccessor() この期間化アクセサが所属する基本アクセサを取得します。
BaseAccessor | InternationalAccessor.getBaseAccessor() この国際化アクセサが所属する基本アクセサを取得します。
BaseAccessor | ExtendedBaseAccessor.getBaseAccessor() 拡張元となる基本エンティティの基本アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での BaseAccessor の使用

BaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
protected BaseAccessor | IntramartDBMapper.createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseAccessor | GenericBaseModel.getBaseAccessor() この基本モデルに割り当てられた基本アクセサを取得します。
BaseAccessor | BaseModelContext.getBaseAccessor() 基本アクセサを取得します。
BaseAccessor | BaseModel.getBaseAccessor() 基本アクセサ BaseAccessor を取得します。

BaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setBaseAccessor(BaseAccessor accessor)
基本アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor の使用

ExtendedBaseAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedBaseAccessor の使用

ExtendedBaseAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseAccessor の使用

ExtendedBaseAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedGenericBaseModel.init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。
void | ExtendedBaseModel.init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedBaseAccessorMap BaseAccessor.getExtendedBaseAccessorMap()
基本アクセサに関連する拡張基本アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseAccessorMap の使用

ExtendedBaseAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericBaseModelMap.init(ExtendedBaseAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalAccessor の使用

ExtendedInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedInternationalModel.init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。
void | ExtendedGenericInternationalModel.init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedInternationalAccessorMap InternationalAccessor.getExtendedInternationalAccessorMap()
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalAccessorMap の使用

ExtendedInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericInternationalModelMap.init(ExtendedInternationalAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableAccessor の使用

ExtendedTerminableAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedTerminableModel.init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。
void | ExtendedGenericTerminableModel.init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedTerminableAccessorMap TerminableAccessor.getExtendedTerminableAccessorMap()
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableAccessorMap の使用

ExtendedTerminableAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericTerminableModelMap.init(ExtendedTerminableAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalAccessor の使用

ExtendedTerminableInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | ExtendedTerminableInternationalModel.init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。
void | ExtendedGenericTerminableInternationalModel.init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 ExtendedTerminableInternationalAccessorMap TerminableInternationalAccessor.getExtendedTerminableInternationalAccessorMap()
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalAccessorMap の使用

ExtendedTerminableInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void ExtendedGenericTerminableInternationalModelMap.init(ExtendedTerminableInternationalAccessorMap accessorMap)
初期化を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor の使用

InternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での InternationalAccessor の使用

InternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | InternationalAccessorMap.findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
InternationalAccessor | ExtendedInternationalAccessor.getInternationalAccessor() 拡張もととなる国際化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalAccessor の使用

InternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalAccessor | InternationalModelContext.getInternationalAccessor() 国際化アクセサを取得します。
protected InternationalAccessor | GenericInternationalModel.getInternationalAccessor() この国際化モデルに割り当てられた国際化アクセサを取得します。

InternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void InternationalModelContext.setInternationalAccessor(InternationalAccessor accessor)
国際化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap の使用

InternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での InternationalAccessorMap の使用

InternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 InternationalAccessorMap BaseAccessor.getInternationalAccessorMap()
基本アクセサに関連する国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalAccessorMap の使用

InternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericInternationalModelMap.init(String modelName, InternationalAccessorMap accessorMap)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor の使用

TerminableAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableAccessor の使用

TerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableAccessor | TerminableInternationalAccessor.getTerminableAccessor() この期間国際化アクセサが所属する期間化アクセサを取得します。
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
TerminableAccessor | TerminableAccessorMap.findTerminableAccessor(Date date) 指定された日付に該当する期間化アクセサを取得します。
TerminableAccessor | ExtendedTerminableAccessor.getTerminableAccessor() 拡張もととなる期間化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableAccessor の使用

TerminableAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableAccessor | TerminableModelContext.getTerminableAccessor() 期間化アクセサを取得します。
protected TerminableAccessor | GenericTerminableModel.getTerminableAccessor() この期間化モデルに割り当てられた期間化アクセサを取得します。

TerminableAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setTerminableAccessor(TerminableAccessor accessor)
期間化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap の使用

TerminableAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableAccessorMap の使用

TerminableAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableAccessorMap BaseAccessor.getTerminableAccessorMap()
基本アクセサに関連する期間化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableAccessorMap の使用

TerminableAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericTerminableModelMap.init(String terminableName, String terminableInternationalName, TerminableAccessorMap accessorMap, Locale defaultLocale)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor の使用

TerminableInternationalAccessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableInternationalAccessor の使用

TerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | TerminableInternationalAccessorMap.findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
TerminableInternationalAccessor | ExtendedTerminableInternationalAccessor.getTerminableInternationalAccessor() 拡張もととなる期間国際化アクセサを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalAccessor の使用

TerminableInternationalAccessor を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalAccessor | TerminableInternationalModelContext.getTerminableInternationalAccessor() 期間国際化アクセサを取得します。
protected TerminableInternationalAccessor | GenericTerminableInternationalModel.getTerminableInternationalAccessor() この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。

TerminableInternationalAccessor 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableInternationalModelContext.setTerminableInternationalAccessor(TerminableInternationalAccessor accessor)
期間国際化アクセサを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableInternationalAccessorMap TerminableAccessor.getTerminableInternationalAccessorMap()
この期間化アクセサに対する期間国際化アクセサのマップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalAccessorMap の使用

TerminableInternationalAccessorMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void GenericTerminableInternationalModelMap.init(String modelName, TerminableInternationalAccessorMap accessorMap)
初期化処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


BaseAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース BaseAccessor

すべてのスーパーインタフェース:
Serializable
public interface BaseAccessor
extends Serializable

基本エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の基本エンティティに反映されます。

クローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0

メソッドの概要
Entity | getEntity() アクセサの基となるエンティティを取得します。
ExtendedBaseAccessorMap | getExtendedBaseAccessorMap() 基本アクセサに関連する拡張基本アクセサのマップを取得します。
InternationalAccessorMap | getInternationalAccessorMap() 基本アクセサに関連する国際化アクセサのマップを取得します。
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessorMap | getTerminableAccessorMap() 基本アクセサに関連する期間化アクセサのマップを取得します。
boolean | isClosed() このアクセサがクローズされた状態かどうかを確認します。
void | setClosed() このアクセサをクローズします。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getEntity

public Entity getEntity()
アクセサの基となるエンティティを取得します。

戻り値:
アクセサの基となるエンティティ

getInternationalAccessorMap

public InternationalAccessorMap getInternationalAccessorMap()
基本アクセサに関連する国際化アクセサのマップを取得します。

戻り値:
国際化アクセサのマップ

getTerminableAccessorMap

public TerminableAccessorMap getTerminableAccessorMap()
基本アクセサに関連する期間化アクセサのマップを取得します。

戻り値:
期間化アクセサのマップ

getExtendedBaseAccessorMap

public ExtendedBaseAccessorMap getExtendedBaseAccessorMap()
基本アクセサに関連する拡張基本アクセサのマップを取得します。

戻り値:
拡張基本アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合

isClosed

public boolean isClosed()
このアクセサがクローズされた状態かどうかを確認します。 アクセサが一度クローズされている場合、以下のメソッドを使用してデータを設定することはできません。
  • setProperty(String, Object)

戻り値:
クローズされている場合 true 、そうでなければ false
関連項目:
setClosed()

setClosed

public void setClosed()
このアクセサをクローズします。

関連項目:
isClosed()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedBaseAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedBaseAccessor
extends Serializable

拡張基本エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張基本エンティティに反映されます。

拡張元となる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() 拡張元となる基本エンティティの基本アクセサを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
拡張元となる基本エンティティの基本アクセサを取得します。

戻り値:
基本アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseAccessorMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedBaseAccessorMap

public interface ExtendedBaseAccessorMap

拡張基本アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedBaseAccessor | createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。

メソッドの詳細

createExtendedBaseAccessor

public ExtendedBaseAccessor createExtendedBaseAccessor(String name)
                                                throws IllegalExtensionException,
                                                       AccessorClosedException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedBaseAccessor

public ExtendedBaseAccessor findExtendedBaseAccessor(String name)
                                              throws IllegalExtensionException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException - 基本アクセサがクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedInternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedInternationalAccessor
extends Serializable

拡張国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張国際化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
InternationalAccessor | getInternationalAccessor() 拡張もととなる国際化アクセサを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getInternationalAccessor

public InternationalAccessor getInternationalAccessor()
拡張もととなる国際化アクセサを取得します。

戻り値:
国際化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalAccessorMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedInternationalAccessorMap

public interface ExtendedInternationalAccessorMap

拡張国際アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalAccessor | createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。

メソッドの詳細

createExtendedInternationalAccessor

public ExtendedInternationalAccessor createExtendedInternationalAccessor(String name)
                                                                  throws IllegalExtensionException,
                                                                         AccessorClosedException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、国際化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedInternationalAccessor

public ExtendedInternationalAccessor findExtendedInternationalAccessor(String name)
                                                                throws IllegalExtensionException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、国際化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException - 基本アクセサがクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableAccessor

すべてのスーパーインタフェース:
Serializable
public interface ExtendedTerminableAccessor
extends Serializable

拡張期間化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張期間化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessor | getTerminableAccessor() 拡張もととなる期間化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
拡張もととなる期間化アクセサを取得します。

戻り値:
期間化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableAccessorMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableAccessorMap

public interface ExtendedTerminableAccessorMap

拡張期間化アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableAccessor | createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。

メソッドの詳細

createExtendedTerminableAccessor

public ExtendedTerminableAccessor createExtendedTerminableAccessor(String name)
                                                            throws IllegalExtensionException,
                                                                   AccessorClosedException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedTerminableAccessor

public ExtendedTerminableAccessor findExtendedTerminableAccessor(String name)
                                                          throws IllegalExtensionException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableInternationalAccessor

public interface ExtendedTerminableInternationalAccessor

拡張期間国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の拡張期間国際化エンティティに反映されます。

拡張もととなる基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
Object | getProperty(String prop) プロパティを取得します。
TerminableInternationalAccessor | getTerminableInternationalAccessor() 拡張もととなる期間国際化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getTerminableInternationalAccessor

public TerminableInternationalAccessor getTerminableInternationalAccessor()
拡張もととなる期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ情報
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ情報
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalAccessorMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース ExtendedTerminableInternationalAccessorMap

public interface ExtendedTerminableInternationalAccessorMap

拡張期間国際化アクセサのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalAccessor | createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。

メソッドの詳細

createExtendedTerminableInternationalAccessor

public ExtendedTerminableInternationalAccessor createExtendedTerminableInternationalAccessor(String name)
                                                                                throws IllegalExtensionException,
                                                                                AccessorClosedException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。 拡張アクセサを指定するための拡張名には、「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、期間国際化属性を持たない拡張名が指定された場合
AccessorClosedException - 基本アクセサがクローズされている場合

findExtendedTerminableInternationalAccessor

public ExtendedTerminableInternationalAccessor findExtendedTerminableInternationalAccessor(String name)
                                                                                throws IllegalExtensionException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。 拡張アクセサを指定するための拡張名には、「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化アクセサ
例外:
IllegalExtensionException - 存在しない拡張名、期間国際化属性を持たない拡張名が指定された場合

remove

public void remove(String name)
            throws AccessorClosedException
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。 拡張名には「拡張アクセサが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張アクセサが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorClosedException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース InternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface InternationalAccessor
extends Serializable

国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の国際化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() この国際化アクセサが所属する基本アクセサを取得します。
ExtendedInternationalAccessorMap | getExtendedInternationalAccessorMap() この国際化アクセサに対する拡張国際化アクセサのマップを取得します。
Locale | getLocale() ロケールを取得します。
Object | getProperty(String prop) プロパティを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
この国際化アクセサが所属する基本アクセサを取得します。

戻り値:
基本アクセサ

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getExtendedInternationalAccessorMap

public ExtendedInternationalAccessorMap getExtendedInternationalAccessorMap()
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。

戻り値:
拡張国際化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalAccessorMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース InternationalAccessorMap

public interface InternationalAccessorMap

国際化アクセサのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createInternationalAccessor(Locale)
  • remove(Locale)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
InternationalAccessor | createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
Locale[] | getLocales() 現在管理している言語の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createInternationalAccessor

public InternationalAccessor createInternationalAccessor(Locale locale)
                                                  throws IllegalLocaleException,
                                                         AccessorClosedException
国際化アクセサを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
国際化アクセサ
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findInternationalAccessor

public InternationalAccessor findInternationalAccessor(Locale locale)
                                                throws IllegalLocaleException
指定された言語に該当する国際化アクセサを取得します。 引数 locale で指定された言語に該当する InternationalAccessor を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間化アクセサ（存在しない場合は null）
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合

remove

public void remove(Locale locale)
            throws IllegalLocaleException,
                   AccessorClosedException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getLocales

public Locale[] getLocales()
現在管理している言語の一覧を取得します。 もし、管理している言語がない時は空の配列を返します。

戻り値:
管理している言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.accessor (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース
BaseAccessor
ExtendedBaseAccessor
ExtendedBaseAccessorMap
ExtendedInternationalAccessor
ExtendedInternationalAccessorMap
ExtendedTerminableAccessor
ExtendedTerminableAccessorMap
ExtendedTerminableInternationalAccessor
ExtendedTerminableInternationalAccessorMap
InternationalAccessor
InternationalAccessorMap
TerminableAccessor
TerminableAccessorMap
TerminableInternationalAccessor
TerminableInternationalAccessorMap


jp.co.intra_mart.foundation.datastore.common.accessor (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor

情報を扱うためのアクセサを提供します。

参照:
説明

インタフェースの概要
BaseAccessor | 基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor | 拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap | 拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor | 拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap | 拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor | 拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap | 拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor | 拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap | 拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor | 国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap | 国際化アクセサのマッピング情報を持ちます。
TerminableAccessor | 期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap | 期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor | 期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap | 期間国際化アクセサのマッピング情報を持ちます。

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の説明

情報を扱うためのアクセサを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.common.accessor クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.common.accessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.accessor の使用

jp.co.intra_mart.foundation.datastore.common.accessor を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.accessor のクラス
BaseAccessor
基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap
拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap
拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap
拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap
国際化アクセサのマッピング情報を持ちます。
TerminableAccessor
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap
期間国際化アクセサのマッピング情報を持ちます。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.accessor のクラス
BaseAccessor
基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessor
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap
拡張基本アクセサのマッピング情報を持ちます。
ExtendedInternationalAccessor
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap
拡張国際アクセサのマッピング情報を持ちます。
ExtendedTerminableAccessor
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap
拡張期間国際化アクセサのマッピング情報を持ちます。
InternationalAccessor
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap
国際化アクセサのマッピング情報を持ちます。
TerminableAccessor
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap
期間国際化アクセサのマッピング情報を持ちます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


TerminableAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableAccessor

すべてのスーパーインタフェース:
Serializable
public interface TerminableAccessor
extends Serializable

期間化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の期間化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
BaseAccessor | getBaseAccessor() この期間化アクセサが所属する基本アクセサを取得します。
ExtendedTerminableAccessorMap | getExtendedTerminableAccessorMap() この期間化アクセサに対する拡張期間化アクセサのマップを取得します。
Object | getProperty(String prop) プロパティを取得します。
Term | getTerm() 期間を取得します。
String | getTermCode() 期間CDを取得します。
TerminableInternationalAccessorMap | getTerminableInternationalAccessorMap() この期間化アクセサに対する期間国際化アクセサのマップを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getBaseAccessor

public BaseAccessor getBaseAccessor()
この期間化アクセサが所属する基本アクセサを取得します。

戻り値:
基本アクセサ

getTerm

public Term getTerm()
期間を取得します。

戻り値:
期間

getTermCode

public String getTermCode()
期間CDを取得します。

戻り値:
期間CD

getTerminableInternationalAccessorMap

public TerminableInternationalAccessorMap getTerminableInternationalAccessorMap()
この期間化アクセサに対する期間国際化アクセサのマップを取得します。

戻り値:
期間国際化アクセサのマップ

getExtendedTerminableAccessorMap

public ExtendedTerminableAccessorMap getExtendedTerminableAccessorMap()
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。

戻り値:
拡張期間化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableAccessorMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableAccessorMap

public interface TerminableAccessorMap

期間化アクセサのマッピング情報を持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createTerminableAccessor(Term)
  • remove(Term)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
TerminableAccessor | createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
TerminableAccessor | findTerminableAccessor(Date date) 指定された日付に該当する期間化アクセサを取得します。
Term[] | getTerms() 現在管理している期間の一覧を取得します。
Map | remove(Term term) 指定された期間に該当するデータを削除します。

メソッドの詳細

createTerminableAccessor

public TerminableAccessor createTerminableAccessor(Term term)
                                            throws IllegalTermException,
                                                   AccessorClosedException
指定した期間に期間化アクセサを生成します。 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す

パラメータ:
term - 期間
戻り値:
期間アクセサ
例外:
IllegalTermException - 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findTerminableAccessor

public TerminableAccessor findTerminableAccessor(Date date)
指定された日付に該当する期間化アクセサを取得します。 引数 date で指定された日付を期間内に含む TerminableAccessor を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
date - 対象となる日付
戻り値:
対象となる期間化アクセサ（存在しない場合は null）

remove

public Map remove(Term term)
           throws AccessorClosedException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。
削除対象の期間に該当するデータを持つ TerminableAccessorがキー、 削除に伴い新たに作成された期間に該当するデータを持つ TerminableAccessorの Collection が値のマップを返します。 （新規に作成された TerminableAccessorがない時は、値には 空の Collection）

パラメータ:
term - 削除対象の期間
戻り値:
map 削除された TerminableAccessorをキー、削除に伴って新規に作成された TerminableAccessorを値とするマップを返す
例外:
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getTerms

public Term[] getTerms()
現在管理している期間の一覧を取得します。 返される期間は期間の早い物から遅い物の順位並んでいる必要があります。 もし、管理している期間の管理がない時は空の配列を返します。

戻り値:
現在管理している期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableInternationalAccessor

すべてのスーパーインタフェース:
Serializable
public interface TerminableInternationalAccessor
extends Serializable

期間国際化エンティティに対する情報操作用のインタフェースです。 このクラスを通じて実際の期間国際化エンティティに反映されます。

基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
ExtendedTerminableInternationalAccessorMap | getExtendedTerminableInternationalAccessorMap() この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。
Locale | getLocale() ロケールを取得します。
Object | getProperty(String prop) プロパティを取得します。
TerminableAccessor | getTerminableAccessor() この期間国際化アクセサが所属する期間化アクセサを取得します。
void | setProperty(String prop, Object value) プロパティを設定します。

メソッドの詳細

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
この期間国際化アクセサが所属する期間化アクセサを取得します。

戻り値:
期間化アクセサ

getExtendedTerminableInternationalAccessorMap

public ExtendedTerminableInternationalAccessorMap getExtendedTerminableInternationalAccessorMap()
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。

戻り値:
拡張期間化アクセサのマップ

getProperty

public Object getProperty(String prop)
                   throws DataNotFoundException
プロパティを取得します。

パラメータ:
prop - プロパティ名
戻り値:
プロパティの値
例外:
DataNotFoundException - 検索時に取得していないプロパティが指定された場合

setProperty

public void setProperty(String prop,
                        Object value)
                 throws AccessorClosedException,
                        AccessorIllegalPropertyValueException
プロパティを設定します。

パラメータ:
prop - プロパティ名
value - プロパティの値
例外:
AccessorIllegalPropertyValueException - プロパティの値が不正な場合
AccessorClosedException - アクセサがすでにクローズされている場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalAccessorMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.accessor
インタフェース TerminableInternationalAccessorMap

public interface TerminableInternationalAccessorMap

期間国際化アクセサのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。 所属する基本アクセサがクローズされている場合、以下のメソッドを使用してデータを設定することはできません。

  • createTerminableInternationalAccessor(Locale)
  • remove(Locale)

導入されたバージョン:
5.0
関連項目:
BaseAccessor.isClosed(), BaseAccessor.setClosed()

メソッドの概要
TerminableInternationalAccessor | createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
Locale[] | getLocales() 現在管理している言語の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createTerminableInternationalAccessor

public TerminableInternationalAccessor createTerminableInternationalAccessor(Locale locale)
                                                                      throws IllegalLocaleException,
                                                                             AccessorClosedException
期間国際化アクセサを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
期間国際化アクセサ
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

findTerminableInternationalAccessor

public TerminableInternationalAccessor findTerminableInternationalAccessor(Locale locale)
                                                                    throws IllegalLocaleException
指定された言語に該当する期間国際化アクセサを取得します。 引数 locale で指定された言語に該当する TerminableInternationalAccessorを取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化アクセサ（存在しない場合は null）
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合

remove

public void remove(Locale locale)
            throws IllegalLocaleException,
                   AccessorClosedException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
IllegalLocaleException - ロケールに関する例外が発生した場合
AccessorClosedException - 基本アクセサがクローズされている場合、例外を返す

getLocales

public Locale[] getLocales()
現在管理している言語の一覧を取得します。 管理している言語がない時は、空の配列を返します。

戻り値:
現在管理している言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ActivationKey の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ActivationKey の使用

ActivationKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ActivationKey の使用

ActivationKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ActivationKey Relationship.getActivationKey()
ソースエンティティのライフタイム期間の有効開始日時を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Application の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Application の使用

Application を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Application の使用

Application を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Application | Table.getApplication() テーブルを定義しているアプリケーションを取得します。
Application | Relationship.getApplication() リレーションシップが定義されているアプリケーションを取得します。
Application | Model.getApplication() モデルを定義しているアプリケーションを取得します。
Application | ExtendedTable.getApplication() 拡張テーブルを定義しているアプリケーションを取得します。
Application | ExtendedModel.getApplication() 拡張モデルを定義しているアプリケーションを取得します。
Application | ExtendedEntity.getApplication() 拡張エンティティを定義しているアプリケーションを取得します。
Application | Entity.getApplication() エンティティを定義しているアプリケーションを取得します。
Application | Configuration.getApplication(String name) 指定された名前に該当するアプリケーションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Attribute の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Attribute の使用

Attribute を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Attribute の使用

Attribute を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Attribute | UpdateInfo.getUpdateUser() エンティティの更新ユーザとなる属性を取得します。
Attribute | UpdateInfo.getUpdateTimestamp() エンティティの更新日付となる属性を取得します。
Attribute | TerminableKey.getAttribute() 期間化基準項目となる属性を取得します。
Attribute[] | Relationship.getForeignKeys() ソースエンティティの外部キーの集合を取得します。
Attribute | Property.getAttribute() プロパティに対応付ける属性を取得します。
Attribute | PrimaryKeyMapping.getAttribute() プライマリーキーとなる属性を取得します。
Attribute[] | Lifetime.getNullKeys() ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
Attribute | InternationalKey.getAttribute() 国際化基準項目となる属性を取得します。
Attribute | ExpirationKey.getAttribute() ライフタイム期間の有効終了日時となる属性を取得します。
Attribute[] | Entity.getPrimaryKeys() エンティティのプライマリキーとなる属性をすべて取得します。
Attribute[] | Delete.getNullKeys() ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
Attribute | ColumnMapping.getAttribute() カラムに割り当てる属性を取得します。
Attribute | Column.getAttribute() カラムに対応付ける属性を取得します。
Attribute | ActivationKey.getAttribute() ライフタイム期間の有効開始日時となる属性を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.AttributeType の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.AttributeType の使用

AttributeType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での AttributeType の使用

AttributeType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static AttributeType | AttributeType.STRING 文字列型
static AttributeType | AttributeType.DECIMAL 整数型
static AttributeType | AttributeType.DATE 日時型
static AttributeType | AttributeType.FLOAT 浮動少数型
static AttributeType | AttributeType.LOCALE ロケール

AttributeType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 AttributeType Attribute.getType()
属性の型を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.BaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.BaseModel の使用

BaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での BaseModel の使用

BaseModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 BaseModel Model.getBaseModel()
基本モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.BaseTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.BaseTable の使用

BaseTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での BaseTable の使用

BaseTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 BaseTable Table.getBaseTable()
基本テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Column の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Column の使用

jp.co.intra_mart.foundation.datastore.common.config.Column はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping の使用

jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Configuration の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Configuration の使用

Configuration を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Configuration の使用

Configuration を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
abstract  Configuration ConfigurationFactory.createConfiguration()
Configurationを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の使用

ConfigurationFactory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ConfigurationFactory の使用

ConfigurationFactory を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
static ConfigurationFactory ConfigurationFactory.getInstance()
ConfigurationFactoryのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Delete の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Delete の使用

Delete を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Delete の使用

Delete を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 Delete Relationship.getDelete()
ターゲットエンティティのデータ削除時の整合性制約を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.DeleteType の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.DeleteType の使用

DeleteType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での DeleteType の使用

DeleteType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static DeleteType | DeleteType.CASCADE 削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
static DeleteType | DeleteType.NULL Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
static DeleteType | DeleteType.EXCEPTION 例外 例外を発生させます。

DeleteType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 DeleteType Delete.getDeleteType()
ターゲットエンティティの削除時の整合性制約のタイプを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Entity の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Entity の使用

Entity を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での Entity の使用

Entity を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 Entity BaseAccessor.getEntity()
アクセサの基となるエンティティを取得します。

jp.co.intra_mart.foundation.datastore.common.config での Entity の使用

Entity を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Entity | TerminableKey.getSourceEntity() 期間化基準項目の基点となるソースエンティティの情報を取得します。
Entity | Table.getEntity() テーブル定義の基となるエンティティを取得します。
Entity | Relationship.getSourceEntity() ソースエンティティの情報を取得します。
Entity | Relationship.getTargetEntity() ターゲットエンティティの情報を取得します。
Entity | Model.getEntity() モデル定義の基となるエンティティを取得します。
Entity | InternationalKey.getSourceEntity() 国際化基準項目の基点となるソースエンティティの情報を取得します。
Entity | ExtendedEntity.getEntity() 拡張対象となるエンティティを取得します。
Entity | ExpirationKey.getSourceEntity() ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。
Entity | Attribute.getEntity() 属性が定義されているエンティティを取得します。
Entity | ActivationKey.getSourceEntity() ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey の使用

ExpirationKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExpirationKey の使用

ExpirationKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExpirationKey Relationship.getExpirationKey()
ソースエンティティのライフタイム期間の有効終了日時を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel の使用

ExtendedBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedBaseModel の使用

ExtendedBaseModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedBaseModel ExtendedModel.getExtendedBaseModel()
拡張基本モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable の使用

ExtendedBaseTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedBaseTable の使用

ExtendedBaseTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedBaseTable ExtendedTable.getExtendedBaseTable()
拡張基本テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity の使用

ExtendedEntity を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedEntity の使用

ExtendedEntity を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedEntity | ExtendedTable.getExtendedEntity() 拡張テーブル定義の基となる拡張エンティティを取得します。
ExtendedEntity | ExtendedModel.getExtendedEntity() 拡張モデル定義の基となる拡張エンティティを取得します。
ExtendedEntity | Attribute.getExtendedEntity() 属性が定義されている拡張エンティティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel の使用

ExtendedInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedInternationalModel の使用

ExtendedInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedInternationalModel ExtendedModel.getExtendedInternationalModel()
拡張国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable の使用

ExtendedInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedInternationalTable の使用

ExtendedInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedInternationalTable ExtendedTable.getExtendedInternationalTable()
拡張国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel の使用

ExtendedModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedModel の使用

ExtendedModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedModel | ExtendedTerminableModel.getExtendedModel() 拡張期間化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedTerminableInternationalModel.getExtendedModel() 拡張期間国際化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedInternationalModel.getExtendedModel() 拡張国際化モデルが定義されている拡張モデル定義を取得します。
ExtendedModel | ExtendedEntity.getExtendedModel() この拡張エンティティを参照している拡張モデルを取得します。
ExtendedModel | ExtendedBaseModel.getExtendedModel() 拡張基本モデルが定義されている拡張モデル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable の使用

ExtendedTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTable の使用

ExtendedTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
ExtendedTable | ExtendedTerminableTable.getExtendedTable() 拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedTerminableInternationalTable.getExtendedTable() 拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedInternationalTable.getExtendedTable() 拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
ExtendedTable | ExtendedEntity.getExtendedTable() この拡張エンティティを参照している拡張テーブルを取得します。
ExtendedTable | ExtendedBaseTable.getExtendedTable() 拡張基本テーブルが定義されている拡張テーブル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableInternationalModel ExtendedModel.getExtendedTerminableInternationalModel()
拡張期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable の使用

ExtendedTerminableInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableInternationalTable の使用

ExtendedTerminableInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableInternationalTable ExtendedTable.getExtendedTerminableInternationalTable()
拡張期間国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel の使用

ExtendedTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableModel の使用

ExtendedTerminableModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableModel ExtendedModel.getExtendedTerminableModel()
拡張期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable の使用

ExtendedTerminableTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での ExtendedTerminableTable の使用

ExtendedTerminableTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 ExtendedTerminableTable ExtendedTable.getExtendedTerminableTable()
拡張期間化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalKey の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalKey の使用

InternationalKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalKey の使用

InternationalKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalKey Relationship.getInternationalKey()
ソースエンティティの国際化基準項目を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalModel の使用

InternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalModel の使用

InternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalModel Model.getInternationalModel()
国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.InternationalTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.InternationalTable の使用

InternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での InternationalTable の使用

InternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 InternationalTable Table.getInternationalTable()
国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Lifetime の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Lifetime の使用

Lifetime を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Lifetime の使用

Lifetime を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 Lifetime Relationship.getLifetime()
ターゲットエンティティの期間削除時の整合性制約を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の使用

LifetimeType を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での LifetimeType の使用

LifetimeType として宣言されている jp.co.intra_mart.foundation.datastore.common.config のフィールド
static LifetimeType | LifetimeType.CASCADE 削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
static LifetimeType | LifetimeType.NULL Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
static LifetimeType | LifetimeType.EXCEPTION 例外 例外を発生させます。

LifetimeType を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 LifetimeType Lifetime.getLifetimeType()
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Model の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Model の使用

Model を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Model の使用

Model を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Model | TerminableModel.getModel() 期間化モデルが定義されているモデル定義を取得します。
Model | TerminableInternationalModel.getModel() 期間国際化モデルが定義されているモデル定義を取得します。
Model | InternationalModel.getModel() 国際化モデルが定義されているモデル定義を取得します。
Model | Entity.getModel() このエンティティを参照しているモデルを取得します。
Model | BaseModel.getModel() 基本モデルが定義されているモデル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping の使用

jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Property の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Property の使用

jp.co.intra_mart.foundation.datastore.common.config.Property はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Relationship の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Relationship の使用

Relationship を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Relationship の使用

Relationship を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Relationship[] | TerminableKey.getRefereRelationships() ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
Relationship[] | InternationalKey.getRefereRelationships() ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
Relationship[] | ExpirationKey.getRefereRelationships() ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
Relationship[] | ActivationKey.getRefereRelationships() ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。

jp.co.intra_mart.foundation.datastore.common.model での Relationship の使用

Relationship 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
protected Collection | IntramartDBMapper.select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.Table の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.Table の使用

Table を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での Table の使用

Table を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
Table | TerminableTable.getTable() 期間化テーブルが定義されているテーブル定義を取得します。
Table | TerminableInternationalTable.getTable() 期間国際化テーブルが定義されているテーブル定義を取得します。
Table | InternationalTable.getTable() 国際化テーブルが定義されているテーブル定義を取得します。
Table | Entity.getTable() このエンティティを参照しているテーブルを取得します。
Table | BaseTable.getTable() 基本テーブルが定義されているテーブル定義を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel の使用

TerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableInternationalModel の使用

TerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableInternationalModel Model.getTerminableInternationalModel()
期間国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable の使用

TerminableInternationalTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableInternationalTable の使用

TerminableInternationalTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableInternationalTable Table.getTerminableInternationalTable()
期間国際化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableKey の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableKey の使用

TerminableKey を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableKey の使用

TerminableKey を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableKey Relationship.getTerminableKey()
ソースエンティティの期間化基準項目を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableModel の使用

TerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableModel の使用

TerminableModel を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableModel Model.getTerminableModel()
期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.TerminableTable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.TerminableTable の使用

TerminableTable を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での TerminableTable の使用

TerminableTable を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 TerminableTable Table.getTerminableTable()
期間化テーブルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo の使用

UpdateInfo を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.config アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.config での UpdateInfo の使用

UpdateInfo を返す jp.co.intra_mart.foundation.datastore.common.config のメソッド
 UpdateInfo Entity.getUpdateInfo()
エンティティの更新情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ActivationKey (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ActivationKey

public interface ActivationKey

ライフタイム期間の有効開始日時を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() ライフタイム期間の有効開始日時となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
ライフタイム期間の有効開始日時となる属性を取得します。

戻り値:
ライフタイム期間の有効開始日時となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Application (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Application

public interface Application

アプリケーションを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getEntities() アプリケーションで定義しているエンティティの一覧を取得します。
Map | getExtendedEntities() アプリケーションで定義している拡張エンティティの一覧を取得します。
Map | getExtendedModels() アプリケーションで定義している拡張モデル定義の一覧を取得します。
Map | getExtendedTables() アプリケーションで定義している拡張テーブル定義の一覧を取得します。
Map | getModels() アプリケーションで定義しているモデル定義の一覧を取得します。
String | getName() アプリケーション名を取得します。
Map | getRelationships() アプリケーションで定義しているリレーションシップの一覧を取得します。
Map | getTables() アプリケーションで定義しているテーブル定義の一覧を取得します。

メソッドの詳細

getName

public String getName()
アプリケーション名を取得します。

戻り値:
アプリケーション名

getEntities

public Map getEntities()
アプリケーションで定義しているエンティティの一覧を取得します。 エンティティ名をキー、 Entityを値としたマップを返します。

戻り値:
エンティティの一覧

getExtendedEntities

public Map getExtendedEntities()
アプリケーションで定義している拡張エンティティの一覧を取得します。 拡張名をキー、 ExtendedEntityを値としたマップを返します。

戻り値:
拡張エンティティの一覧

getRelationships

public Map getRelationships()
アプリケーションで定義しているリレーションシップの一覧を取得します。 リレーションシップ名をキー、 Relationshipを値としたマップを返します。

戻り値:
リレーションシップの一覧

getTables

public Map getTables()
アプリケーションで定義しているテーブル定義の一覧を取得します。 「テーブルの定義基となるエンティティが定義されているアプリケーション名　+ . + エンティティ名」 をキー、 Tableを値としたマップを返します。

例
エンティティが定義されているアプリケーション名：jp.co.intra_mart
エンティティ名：Entity
上記のようなときは「jp.co.intra_mart.Entity」がキーとなります。

戻り値:
テーブル定義の一覧

getExtendedTables

public Map getExtendedTables()
アプリケーションで定義している拡張テーブル定義の一覧を取得します。 「拡張テーブルの定義基となる拡張エンティティが定義されているアプリケーション名　+ . + 拡張名」 をキー、 ExtendedTableを値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張テーブル定義の一覧

getModels

public Map getModels()
アプリケーションで定義しているモデル定義の一覧を取得します。 「モデルの定義基となるエンティティが定義されているアプリケーション名　+ . + エンティティ名」、 Modelを値としたマップを返します。

例
エンティティが定義されているアプリケーション名：jp.co.intra_mart
エンティティ名：Entity
上記のようなときは「jp.co.intra_mart.Entity」がキーとなります。

戻り値:
拡張テーブル定義の一覧

getExtendedModels

public Map getExtendedModels()
アプリケーションで定義している拡張モデル定義の一覧を取得します。 「拡張モデルの定義基となる拡張エンティティが定義されているアプリケーション名　+ . + 拡張名」 をキー、 ExtendedModelを値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張モデル定義の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Attribute (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Attribute

public interface Attribute

属性を定義します。

導入されたバージョン:
5.0

メソッドの概要
Entity | getEntity() 属性が定義されているエンティティを取得します。
ExtendedEntity | getExtendedEntity() 属性が定義されている拡張エンティティを取得します。
String | getName() 属性名を取得します。
AttributeType | getType() 属性の型を取得します。
boolean | isInternational() 属性が国際化の対象であるかどうかを取得します。
boolean | isNullAcceptable() 属性にnullが設定可能であるかどうかを取得します。
boolean | isTerminable() 属性が期間化の対象であるかどうかを取得します。

メソッドの詳細

getName

public String getName()
属性名を取得します。

戻り値:
属性名

getType

public AttributeType getType()
属性の型を取得します。

戻り値:
属性の型

isTerminable

public boolean isTerminable()
属性が期間化の対象であるかどうかを取得します。

戻り値:
属性が期間化の対象である場合 true 、そうでない場合 false

isInternational

public boolean isInternational()
属性が国際化の対象であるかどうかを取得します。

戻り値:
属性が国際化の対象である場合 true 、そうでない場合 false

isNullAcceptable

public boolean isNullAcceptable()
属性にnullが設定可能であるかどうかを取得します。

戻り値:
属性にnullが設定が可能である場合 true 、そうでない場合 false

getEntity

public Entity getEntity()
属性が定義されているエンティティを取得します。

戻り値:
属性が定義されているエンティティ

getExtendedEntity

public ExtendedEntity getExtendedEntity()
属性が定義されている拡張エンティティを取得します。 属性が拡張エンティティに定義されていないとき null を返します。

戻り値:
属性が定義されている拡張エンティティ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AttributeType (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス AttributeType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.AttributeType
すべての実装インタフェース:
Serializable
public class AttributeType
extends Object
implements Serializable

属性で指定できる型です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

フィールドの概要
static AttributeType | DATE 日時型
static AttributeType | DECIMAL 整数型
static AttributeType | FLOAT 浮動少数型
static AttributeType | LOCALE ロケール
static AttributeType | STRING 文字列型
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

STRING

public static final AttributeType STRING
文字列型

DECIMAL

public static final AttributeType DECIMAL
整数型

DATE

public static final AttributeType DATE
日時型

FLOAT

public static final AttributeType FLOAT
浮動少数型

LOCALE

public static final AttributeType LOCALE
ロケール

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース BaseModel

public interface BaseModel

基本モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 基本モデルのクラス名を取得します。
Model | getModel() 基本モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
基本モデルが定義されているモデル定義を取得します。

戻り値:
基本モデルが定義されているモデル定義

getClassName

public String getClassName()
基本モデルのクラス名を取得します。

戻り値:
基本モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BaseTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース BaseTable

public interface BaseTable

基本テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getName() 基本テーブルのテーブル名を取得します。
Table | getTable() 基本テーブルが定義されているテーブル定義を取得します。

メソッドの詳細

getTable

public Table getTable()
基本テーブルが定義されているテーブル定義を取得します。

戻り値:
基本テーブルが定義されているテーブル定義

getName

public String getName()
基本テーブルのテーブル名を取得します。

戻り値:
基本テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
基本テーブルに含まれるカラムマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Column (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Column

public interface Column

属性に対応するカラムの型を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() カラムに対応付ける属性を取得します。
String | getType() カラムの型を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
カラムに対応付ける属性を取得します。

戻り値:
カラムに対応付ける属性

getType

public String getType()
カラムの型を取得します。

戻り値:
カラムの型
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ColumnMapping (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ColumnMapping

public interface ColumnMapping

分割されたテーブルに割り当てられるカラムを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() カラムに割り当てる属性を取得します。
String | getName() カラム名を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
カラムに割り当てる属性を取得します。

戻り値:
カラムに割り当てる属性

getName

public String getName()
カラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Configuration (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Configuration

public interface Configuration

設定内容を取得します。

導入されたバージョン:
5.0

メソッドの概要
 Application getApplication(String name)
指定された名前に該当するアプリケーションを取得します。

メソッドの詳細

getApplication

public Application getApplication(String name)
指定された名前に該当するアプリケーションを取得します。

パラメータ:
name - アプリケーション名
戻り値:
指定された名前に該当するアプリケーション
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConfigurationFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス ConfigurationFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
public abstract class ConfigurationFactory
extends Object

Configurationを生成します。

導入されたバージョン:
5.0

コンストラクタの概要
ConfigurationFactory()
メソッドの概要
abstract Configuration | createConfiguration() Configurationを生成します。
static ConfigurationFactory | getInstance() ConfigurationFactoryのインスタンスを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConfigurationFactory

public ConfigurationFactory()
メソッドの詳細

getInstance

public static ConfigurationFactory getInstance()
ConfigurationFactoryのインスタンスを取得します。

戻り値:
ConfigurationFactory

createConfiguration

public abstract Configuration createConfiguration()
Configurationを生成します。

戻り値:
Configuration
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Delete (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Delete

public interface Delete

削除時の整合性制約です。 ターゲットエンティティの情報変更による整合性制約の内容です。

導入されたバージョン:
5.0

メソッドの概要
DeleteType | getDeleteType() ターゲットエンティティの削除時の整合性制約のタイプを取得します。
Attribute[] | getNullKeys() ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

メソッドの詳細

getDeleteType

public DeleteType getDeleteType()
ターゲットエンティティの削除時の整合性制約のタイプを取得します。

戻り値:
削除時の整合性制約のタイプ

getNullKeys

public Attribute[] getNullKeys()
ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

戻り値:
データ削除時の整合性制約の対象となる外部キー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DeleteType (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス DeleteType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.DeleteType
すべての実装インタフェース:
Serializable
public class DeleteType
extends Object
implements Serializable

削除時の整合性制約のタイプです。 ターゲットエンティティの情報変更による整合性制約のタイプです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

フィールドの概要
static DeleteType | CASCADE 削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
static DeleteType | EXCEPTION 例外 例外を発生させます。
static DeleteType | NULL Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CASCADE

public static final DeleteType CASCADE
削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。

NULL

public static final DeleteType NULL
Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。

EXCEPTION

public static final DeleteType EXCEPTION
例外 例外を発生させます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Entity (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Entity

public interface Entity

エンティティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() エンティティを定義しているアプリケーションを取得します。
Map | getAttributes() エンティティに含まれる属性をすべて取得します。
Map | getExtendedEntities() このエンティティを拡張している拡張エンティティをすべて取得します。
Model | getModel() このエンティティを参照しているモデルを取得します。
String | getName() エンティティ名を取得します。
Attribute[] | getPrimaryKeys() エンティティのプライマリキーとなる属性をすべて取得します。
Map | getReferedRelationships() このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
Map | getSourceRelationships() このエンティティをソースとしているリレーションシップをすべて取得します。
Table | getTable() このエンティティを参照しているテーブルを取得します。
Map | getTargetRelationships() このエンティティをターゲットとしているリレーションシップをすべて取得します。
UpdateInfo | getUpdateInfo() エンティティの更新情報を取得します。
boolean | isInternational() エンティティが国際化の対象であるかどうかを取得します。
boolean | isTerminable() エンティティが期間化の対象であるかどうかを取得します。
boolean | isTerminableInternational() エンティティが期間国際化の対象であるかどうかを取得します。

メソッドの詳細

getApplication

public Application getApplication()
エンティティを定義しているアプリケーションを取得します。

戻り値:
エンティティを定義しているアプリケーション

getAttributes

public Map getAttributes()
エンティティに含まれる属性をすべて取得します。 属性名をキー、 Attributeを値としたマップを返します。

戻り値:
エンティティに含まれる属性

getName

public String getName()
エンティティ名を取得します。

戻り値:
エンティティ名

getPrimaryKeys

public Attribute[] getPrimaryKeys()
エンティティのプライマリキーとなる属性をすべて取得します。 ここで取得される属性は、 getAttributes()で取得される配列の部分集合になります。 また、配列の順番はプライマリキーとして定義された順番になります。

戻り値:
プライマリキーとなる属性

getUpdateInfo

public UpdateInfo getUpdateInfo()
エンティティの更新情報を取得します。 存在しない場合はnullを返します。

戻り値:
エンティティの更新情報

isTerminable

public boolean isTerminable()
エンティティが期間化の対象であるかどうかを取得します。

戻り値:
属性が期間化の対象である場合 true 、そうでない場合 false

isInternational

public boolean isInternational()
エンティティが国際化の対象であるかどうかを取得します。

戻り値:
属性が国際化の対象である場合 true 、そうでない場合 false

isTerminableInternational

public boolean isTerminableInternational()
エンティティが期間国際化の対象であるかどうかを取得します。

戻り値:
エンティティが期間国際化の対象である場合 true 、そうでない場合 false

getExtendedEntities

public Map getExtendedEntities()
このエンティティを拡張している拡張エンティティをすべて取得します。 「拡張エンティティが定義されているアプリケーション名 + . + 拡張名」 をキー、 ExtendedEntity を値としたマップを返します。

例
拡張エンティティが定義されているアプリケーション名：jp.co.intra_mart
拡張名：ExtendedEntity
上記のようなときは「jp.co.intra_mart.ExtendedEntity」がキーとなります。

戻り値:
拡張エンティティ一覧

getTable

public Table getTable()
このエンティティを参照しているテーブルを取得します。
このエンティティを参照しているテーブルが存在しないときは null を返します。

戻り値:
このエンティティを参照しているテーブル

getModel

public Model getModel()
このエンティティを参照しているモデルを取得します。

戻り値:
このエンティティを参照しているモデル

getSourceRelationships

public Map getSourceRelationships()
このエンティティをソースとしているリレーションシップをすべて取得します。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティをソースとしているリレーションシップ

getTargetRelationships

public Map getTargetRelationships()
このエンティティをターゲットとしているリレーションシップをすべて取得します。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティをターゲットとしているリレーションシップをすべて取得します。

getReferedRelationships

public Map getReferedRelationships()
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
ただし、このエンティティがソースとなるリレーションシップは取得対象となりません。 「リレーションシップが定義されているアプリケーション名 + . + リレーションシップ名」 をキー、 Relationship を値としたマップを返します。

例
リレーションシップが定義されているアプリケーション名：jp.co.intra_mart
リレーションシップ名：Relationship1
上記のようなときは「jp.co.intra_mart.Relationship1」がキーとなります。

戻り値:
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpirationKey (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExpirationKey

public interface ExpirationKey

ライフタイム期間の有効終了日時を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() ライフタイム期間の有効終了日時となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
ライフタイム期間の有効終了日時となる属性を取得します。

戻り値:
ライフタイム期間の有効終了日時となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedBaseModel

public interface ExtendedBaseModel

拡張基本モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張基本モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張基本モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張基本モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張基本モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張基本モデルのクラス名を取得します。

戻り値:
拡張基本モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedBaseTable

public interface ExtendedBaseTable

拡張基本テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張基本テーブルが定義されている拡張テーブル定義を取得します。
String | getName() 拡張基本テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張基本テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張基本テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張基本テーブルのテーブル名を取得します。

戻り値:
拡張基本テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張基本テーブルに含まれるカラムマッピング

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張基本テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedEntity (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedEntity

public interface ExtendedEntity

拡張エンティティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張エンティティを定義しているアプリケーションを取得します。
Map | getAttributes() 拡張エンティティに含まれる属性をすべて取得します。
Entity | getEntity() 拡張対象となるエンティティを取得します。
ExtendedModel | getExtendedModel() この拡張エンティティを参照している拡張モデルを取得します。
ExtendedTable | getExtendedTable() この拡張エンティティを参照している拡張テーブルを取得します。
String | getName() 拡張名を取得します。
boolean | hasBaseAttributes() 拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。
boolean | hasInternationalAttributes() 拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。
boolean | hasTerminableAttributes() 拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。
boolean | hasTerminableInternationalAttributes() 拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。

メソッドの詳細

getApplication

public Application getApplication()
拡張エンティティを定義しているアプリケーションを取得します。

戻り値:
拡張エンティティを定義しているアプリケーション

getAttributes

public Map getAttributes()
拡張エンティティに含まれる属性をすべて取得します。 属性名をキー、 Attributeを値としたマップを返します。

戻り値:
拡張エンティティに含まれる属性

getName

public String getName()
拡張名を取得します。

戻り値:
拡張名

getEntity

public Entity getEntity()
拡張対象となるエンティティを取得します。

戻り値:
拡張対象となるエンティティ

getExtendedTable

public ExtendedTable getExtendedTable()
この拡張エンティティを参照している拡張テーブルを取得します。
この拡張エンティティを参照している拡張テーブルが存在しないときは null を返します。

戻り値:
この拡張エンティティを参照している拡張テーブル

getExtendedModel

public ExtendedModel getExtendedModel()
この拡張エンティティを参照している拡張モデルを取得します。
この拡張エンティティを参照している拡張モデルが存在しないときは null を返します。

戻り値:
この拡張エンティティを参照している拡張モデル

hasBaseAttributes

public boolean hasBaseAttributes()
拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。

戻り値:
期間化も国際化もされていない従属属性を持つときは、 true 、そうでない場合 false

hasTerminableAttributes

public boolean hasTerminableAttributes()
拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。

戻り値:
期間化のみされている従属属性を持つ場合は true 、そうでない場合 false

hasInternationalAttributes

public boolean hasInternationalAttributes()
拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。

戻り値:
国際化のみされている従属属性を持つ場合は true 、そうでない場合 false

hasTerminableInternationalAttributes

public boolean hasTerminableInternationalAttributes()
拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。

戻り値:
期間国際化されている従属属性を持つ場合は true 、そうでない場合 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedInternationalModel

public interface ExtendedInternationalModel

拡張国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張国際化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張国際化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張国際化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張国際化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張国際化モデルのクラス名を取得します。

戻り値:
拡張国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedInternationalTable

public interface ExtendedInternationalTable

拡張国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 拡張国際化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張国際化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張国際化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張国際化テーブルのテーブル名を取得します。

戻り値:
拡張国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張国際化テーブルに含まれるカラムマッピング

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張国際化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedModel

public interface ExtendedModel

拡張モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張モデルを定義しているアプリケーションを取得します。
ExtendedBaseModel | getExtendedBaseModel() 拡張基本モデルを取得します。
ExtendedEntity | getExtendedEntity() 拡張モデル定義の基となる拡張エンティティを取得します。
ExtendedInternationalModel | getExtendedInternationalModel() 拡張国際化モデルを取得します。
ExtendedTerminableInternationalModel | getExtendedTerminableInternationalModel() 拡張期間国際化モデルを取得します。
ExtendedTerminableModel | getExtendedTerminableModel() 拡張期間化モデルを取得します。
Map | getProperties() 拡張モデルに含まれるプロパティをすべて取得します。

メソッドの詳細

getApplication

public Application getApplication()
拡張モデルを定義しているアプリケーションを取得します。

戻り値:
拡張モデルを定義しているアプリケーション

getExtendedEntity

public ExtendedEntity getExtendedEntity()
拡張モデル定義の基となる拡張エンティティを取得します。

戻り値:
拡張モデル定義の基となる拡張エンティティ

getProperties

public Map getProperties()
拡張モデルに含まれるプロパティをすべて取得します。 属性名をキー、 Propertyを値としたマップを返します。

戻り値:
拡張モデルに含まれるプロパティ

getExtendedBaseModel

public ExtendedBaseModel getExtendedBaseModel()
拡張基本モデルを取得します。 拡張基本モデルが使用されない場合、 null が返されます。

戻り値:
拡張基本モデル

getExtendedInternationalModel

public ExtendedInternationalModel getExtendedInternationalModel()
拡張国際化モデルを取得します。 拡張国際化モデルが使用されない場合、 null が返されます。

戻り値:
拡張国際化モデル

getExtendedTerminableModel

public ExtendedTerminableModel getExtendedTerminableModel()
拡張期間化モデルを取得します。 拡張期間化モデルが使用されない場合、 null が返されます。

戻り値:
拡張期間化モデル

getExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel getExtendedTerminableInternationalModel()
拡張期間国際化モデルを取得します。 拡張期間国際化モデルが使用されない場合、 null が返されます。

戻り値:
拡張期間国際化モデル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTable

public interface ExtendedTable

拡張テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() 拡張テーブルを定義しているアプリケーションを取得します。
Map | getColumns() 拡張テーブルに含まれるカラムをすべて取得します。
ExtendedBaseTable | getExtendedBaseTable() 拡張基本テーブルを取得します。
ExtendedEntity | getExtendedEntity() 拡張テーブル定義の基となる拡張エンティティを取得します。
ExtendedInternationalTable | getExtendedInternationalTable() 拡張国際化テーブルを取得します。
ExtendedTerminableInternationalTable | getExtendedTerminableInternationalTable() 拡張期間国際化テーブルを取得します。
ExtendedTerminableTable | getExtendedTerminableTable() 拡張期間化テーブルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
拡張テーブルを定義しているアプリケーションを取得します。

戻り値:
拡張テーブルを定義しているアプリケーション

getExtendedEntity

public ExtendedEntity getExtendedEntity()
拡張テーブル定義の基となる拡張エンティティを取得します。

戻り値:
拡張テーブル定義の基となる拡張エンティティ

getColumns

public Map getColumns()
拡張テーブルに含まれるカラムをすべて取得します。 属性名をキー、 Columnを値としたマップを返します。

戻り値:
拡張テーブルに含まれるカラム

getExtendedBaseTable

public ExtendedBaseTable getExtendedBaseTable()
拡張基本テーブルを取得します。 拡張基本テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張基本テーブル

getExtendedInternationalTable

public ExtendedInternationalTable getExtendedInternationalTable()
拡張国際化テーブルを取得します。 拡張国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張国際化テーブル

getExtendedTerminableTable

public ExtendedTerminableTable getExtendedTerminableTable()
拡張期間化テーブルを取得します。 拡張期間化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張期間化テーブル

getExtendedTerminableInternationalTable

public ExtendedTerminableInternationalTable getExtendedTerminableInternationalTable()
拡張期間国際化テーブルを取得します。 拡張期間国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
拡張期間国際化テーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableInternationalModel

public interface ExtendedTerminableInternationalModel

拡張期間国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張期間国際化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張期間国際化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張期間国際化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張期間国際化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張期間国際化モデルのクラス名を取得します。

戻り値:
拡張期間国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableInternationalTable

public interface ExtendedTerminableInternationalTable

拡張期間国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 拡張期間国際化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張期間国際化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張期間国際化テーブルのテーブル名を取得します。

戻り値:
拡張期間国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張期間国際化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張期間国際化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableModel

public interface ExtendedTerminableModel

拡張期間化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 拡張期間化モデルのクラス名を取得します。
ExtendedModel | getExtendedModel() 拡張期間化モデルが定義されている拡張モデル定義を取得します。

メソッドの詳細

getExtendedModel

public ExtendedModel getExtendedModel()
拡張期間化モデルが定義されている拡張モデル定義を取得します。

戻り値:
拡張期間化モデルが定義されている拡張モデル定義

getClassName

public String getClassName()
拡張期間化モデルのクラス名を取得します。

戻り値:
拡張期間化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース ExtendedTerminableTable

public interface ExtendedTerminableTable

拡張期間化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
ExtendedTable | getExtendedTable() 拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
String | getName() 拡張期間化テーブルのテーブル名を取得します。
Map | getPrimaryKeyMappings() 拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getExtendedTable

public ExtendedTable getExtendedTable()
拡張期間化テーブルが定義されている拡張テーブル定義を取得します。

戻り値:
拡張期間化テーブルが定義されている拡張テーブル定義

getName

public String getName()
拡張期間化テーブルのテーブル名を取得します。

戻り値:
拡張期間化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
拡張期間化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getPrimaryKeyMappings

public Map getPrimaryKeyMappings()
拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。 属性名をキー、 PrimaryKeyMappingを値としたマップを返します。

戻り値:
拡張期間化テーブルに含まれるプライマリキーマッピング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalKey (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalKey

public interface InternationalKey

国際化基準項目を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() 国際化基準項目となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() 国際化基準項目の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
国際化基準項目の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
国際化基準項目となる属性を取得します。

戻り値:
国際化基準項目となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalModel

public interface InternationalModel

国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 国際化モデルのクラス名を取得します。
Model | getModel() 国際化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
国際化モデルが定義されているモデル定義を取得します。

戻り値:
国際化モデルが定義されているモデル定義

getClassName

public String getClassName()
国際化モデルのクラス名を取得します。

戻り値:
国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース InternationalTable

public interface InternationalTable

国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 国際化テーブルのテーブル名を取得します。
Table | getTable() 国際化テーブルが定義されているテーブル定義を取得します。

メソッドの詳細

getTable

public Table getTable()
国際化テーブルが定義されているテーブル定義を取得します。

戻り値:
国際化テーブルが定義されているテーブル定義

getName

public String getName()
国際化テーブルのテーブル名を取得します。

戻り値:
国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
国際化テーブルに含まれるカラムマッピング

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Lifetime (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Lifetime

public interface Lifetime

期間削除時の整合性制約です。 ターゲットエンティティの期間（またはその一部）が削除された場合の整合性制約です。

導入されたバージョン:
5.0

メソッドの概要
LifetimeType | getLifetimeType() ターゲットエンティティの期間削除時の整合性制約のタイプを取得します
Attribute[] | getNullKeys() ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

メソッドの詳細

getLifetimeType

public LifetimeType getLifetimeType()
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します

戻り値:
期間削除時の整合性制約のタイプ

getNullKeys

public Attribute[] getNullKeys()
ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。

戻り値:
期間削除時の整合性制約の対象となる外部キー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LifetimeType (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
クラス LifetimeType

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.config.LifetimeType
public class LifetimeType
extends Object

期間削除時の整合性制約のタイプです。 ターゲットエンティティの期間（またはその一部）が削除された場合の整合性制約のタイプです。

導入されたバージョン:
5.0

フィールドの概要
static LifetimeType | CASCADE 削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
static LifetimeType | EXCEPTION 例外 例外を発生させます。
static LifetimeType | NULL Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CASCADE

public static final LifetimeType CASCADE
削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。

NULL

public static final LifetimeType NULL
Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。

EXCEPTION

public static final LifetimeType EXCEPTION
例外 例外を発生させます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Model (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Model

public interface Model

モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() モデルを定義しているアプリケーションを取得します。
BaseModel | getBaseModel() 基本モデルを取得します。
Entity | getEntity() モデル定義の基となるエンティティを取得します。
InternationalModel | getInternationalModel() 国際化モデルを取得します。
String | getMapperClassName() マッパのクラス名を取得します。
Map | getProperties() モデルに含まれるプロパティをすべて取得します。
TerminableInternationalModel | getTerminableInternationalModel() 期間国際化モデルを取得します。
TerminableModel | getTerminableModel() 期間化モデルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
モデルを定義しているアプリケーションを取得します。

戻り値:
モデルを定義しているアプリケーション

getEntity

public Entity getEntity()
モデル定義の基となるエンティティを取得します。

戻り値:
モデル定義の基となるエンティティ

getProperties

public Map getProperties()
モデルに含まれるプロパティをすべて取得します。 属性名をキー、 Propertyを値としたマップを返します。

戻り値:
モデルに含まれるプロパティ

getMapperClassName

public String getMapperClassName()
マッパのクラス名を取得します。

戻り値:
マッパのクラス名

getBaseModel

public BaseModel getBaseModel()
基本モデルを取得します。

戻り値:
基本モデル

getInternationalModel

public InternationalModel getInternationalModel()
国際化モデルを取得します。 国際化モデルが使用されない場合、 null が返されます。

戻り値:
国際化モデル

getTerminableModel

public TerminableModel getTerminableModel()
期間化モデルを取得します。 期間化モデルが使用されない場合、 null が返されます。

戻り値:
期間化モデル

getTerminableInternationalModel

public TerminableInternationalModel getTerminableInternationalModel()
期間国際化モデルを取得します。 期間国際化モデルが使用されない場合、 null が返されます。

戻り値:
期間国際化モデル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.config (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.common.config
インタフェース
ActivationKey
Application
Attribute
BaseModel
BaseTable
Column
ColumnMapping
Configuration
Delete
Entity
ExpirationKey
ExtendedBaseModel
ExtendedBaseTable
ExtendedEntity
ExtendedInternationalModel
ExtendedInternationalTable
ExtendedModel
ExtendedTable
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalTable
ExtendedTerminableModel
ExtendedTerminableTable
InternationalKey
InternationalModel
InternationalTable
Lifetime
Model
PrimaryKeyMapping
Property
Relationship
Table
TerminableInternationalModel
TerminableInternationalTable
TerminableKey
TerminableModel
TerminableTable
UpdateInfo
クラス
AttributeType
ConfigurationFactory
DeleteType
LifetimeType


jp.co.intra_mart.foundation.datastore.common.config (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.config

アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

参照:
説明

インタフェースの概要
ActivationKey | ライフタイム期間の有効開始日時を定義します。
Application | アプリケーションを定義します。
Attribute | 属性を定義します。
BaseModel | 基本モデルを定義します。
BaseTable | 基本テーブルを定義します。
Column | 属性に対応するカラムの型を定義します。
ColumnMapping | 分割されたテーブルに割り当てられるカラムを定義します。
Configuration | 設定内容を取得します。
Delete | 削除時の整合性制約です。
Entity | エンティティを定義します。
ExpirationKey | ライフタイム期間の有効終了日時を定義します。
ExtendedBaseModel | 拡張基本モデルを定義します。
ExtendedBaseTable | 拡張基本テーブルを定義します。
ExtendedEntity | 拡張エンティティを定義します。
ExtendedInternationalModel | 拡張国際化モデルを定義します。
ExtendedInternationalTable | 拡張国際化テーブルを定義します。
ExtendedModel | 拡張モデルを定義します。
ExtendedTable | 拡張テーブルを定義します。
ExtendedTerminableInternationalModel | 拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalTable | 拡張期間国際化テーブルを定義します。
ExtendedTerminableModel | 拡張期間化モデルを定義します。
ExtendedTerminableTable | 拡張期間化テーブルを定義します。
InternationalKey | 国際化基準項目を定義します。
InternationalModel | 国際化モデルを定義します。
InternationalTable | 国際化テーブルを定義します。
Lifetime | 期間削除時の整合性制約です。
Model | モデルを定義します。
PrimaryKeyMapping | 分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。
Property | プロパティを定義します。
Relationship | リレーションシップを定義します。
Table | テーブルを定義します。
TerminableInternationalModel | 期間国際化モデルを定義します。
TerminableInternationalTable | 期間国際化テーブルを定義します。
TerminableKey | 期間化基準項目を定義します。
TerminableModel | 期間化モデルを定義します。
TerminableTable | 期間化テーブルを定義します。
UpdateInfo | エンティティの更新情報です。

クラスの概要
AttributeType | 属性で指定できる型です。
ConfigurationFactory | Configurationを生成します。
DeleteType | 削除時の整合性制約のタイプです。
LifetimeType | 期間削除時の整合性制約のタイプです。

パッケージ jp.co.intra_mart.foundation.datastore.common.config の説明

アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.common.config クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.config の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.config.AttributeType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
    • class jp.co.intra_mart.foundation.datastore.common.config.DeleteType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.Application
  • interface jp.co.intra_mart.foundation.datastore.common.config.Attribute
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.Column
  • interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping
  • interface jp.co.intra_mart.foundation.datastore.common.config.Configuration
  • interface jp.co.intra_mart.foundation.datastore.common.config.Delete
  • interface jp.co.intra_mart.foundation.datastore.common.config.Entity
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime
  • interface jp.co.intra_mart.foundation.datastore.common.config.Model
  • interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping
  • interface jp.co.intra_mart.foundation.datastore.common.config.Property
  • interface jp.co.intra_mart.foundation.datastore.common.config.Relationship
  • interface jp.co.intra_mart.foundation.datastore.common.config.Table
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.common.config の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.config の使用

jp.co.intra_mart.foundation.datastore.common.config を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
Entity
エンティティを定義します。

jp.co.intra_mart.foundation.datastore.common.config により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
ActivationKey
ライフタイム期間の有効開始日時を定義します。
Application
アプリケーションを定義します。
Attribute
属性を定義します。
AttributeType
属性で指定できる型です。
BaseModel
基本モデルを定義します。
BaseTable
基本テーブルを定義します。
Configuration
設定内容を取得します。
ConfigurationFactory
Configurationを生成します。
Delete
削除時の整合性制約です。
DeleteType
削除時の整合性制約のタイプです。
Entity
エンティティを定義します。
ExpirationKey
ライフタイム期間の有効終了日時を定義します。
ExtendedBaseModel
拡張基本モデルを定義します。
ExtendedBaseTable
拡張基本テーブルを定義します。
ExtendedEntity
拡張エンティティを定義します。
ExtendedInternationalModel
拡張国際化モデルを定義します。
ExtendedInternationalTable
拡張国際化テーブルを定義します。
ExtendedModel
拡張モデルを定義します。
ExtendedTable
拡張テーブルを定義します。
ExtendedTerminableInternationalModel
拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalTable
拡張期間国際化テーブルを定義します。
ExtendedTerminableModel
拡張期間化モデルを定義します。
ExtendedTerminableTable
拡張期間化テーブルを定義します。
InternationalKey
国際化基準項目を定義します。
InternationalModel
国際化モデルを定義します。
InternationalTable
国際化テーブルを定義します。
Lifetime
期間削除時の整合性制約です。
LifetimeType
期間削除時の整合性制約のタイプです。
Model
モデルを定義します。
Relationship
リレーションシップを定義します。
Table
テーブルを定義します。
TerminableInternationalModel
期間国際化モデルを定義します。
TerminableInternationalTable
期間国際化テーブルを定義します。
TerminableKey
期間化基準項目を定義します。
TerminableModel
期間化モデルを定義します。
TerminableTable
期間化テーブルを定義します。
UpdateInfo
エンティティの更新情報です。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.config のクラス
Relationship
リレーションシップを定義します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PrimaryKeyMapping (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース PrimaryKeyMapping

public interface PrimaryKeyMapping

分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() プライマリーキーとなる属性を取得します。
String | getName() プライマリーキーとなるカラム名を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
プライマリーキーとなる属性を取得します。

戻り値:
カラムに割り当てる属性

getName

public String getName()
プライマリーキーとなるカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Property (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Property

public interface Property

プロパティを定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() プロパティに対応付ける属性を取得します。
String | getType() プロパティの型を取得します。

メソッドの詳細

getAttribute

public Attribute getAttribute()
プロパティに対応付ける属性を取得します。

戻り値:
プロパティに対応付ける属性

getType

public String getType()
プロパティの型を取得します。

戻り値:
プロパティの型
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Relationship (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Relationship

public interface Relationship

リレーションシップを定義します。

導入されたバージョン:
5.0

メソッドの概要
ActivationKey | getActivationKey() ソースエンティティのライフタイム期間の有効開始日時を取得します。
Application | getApplication() リレーションシップが定義されているアプリケーションを取得します。
Delete | getDelete() ターゲットエンティティのデータ削除時の整合性制約を取得します。
ExpirationKey | getExpirationKey() ソースエンティティのライフタイム期間の有効終了日時を取得します。
Attribute[] | getForeignKeys() ソースエンティティの外部キーの集合を取得します。
InternationalKey | getInternationalKey() ソースエンティティの国際化基準項目を取得します。
Lifetime | getLifetime() ターゲットエンティティの期間削除時の整合性制約を取得します。
String | getName() リレーションシップ名を取得します。
Entity | getSourceEntity() ソースエンティティの情報を取得します。
Entity | getTargetEntity() ターゲットエンティティの情報を取得します。
TerminableKey | getTerminableKey() ソースエンティティの期間化基準項目を取得します。

メソッドの詳細

getApplication

public Application getApplication()
リレーションシップが定義されているアプリケーションを取得します。

戻り値:
リレーションシップが定義されているアプリケーション

getName

public String getName()
リレーションシップ名を取得します。

戻り値:
リレーションシップ名

getSourceEntity

public Entity getSourceEntity()
ソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getTargetEntity

public Entity getTargetEntity()
ターゲットエンティティの情報を取得します。

戻り値:
ターゲットエンティティの情報

getForeignKeys

public Attribute[] getForeignKeys()
ソースエンティティの外部キーの集合を取得します。 ターゲットエンティティのプライマリキーの順番と一致している必要があります。

戻り値:
ソースエンティティの外部キーの集合

getTerminableKey

public TerminableKey getTerminableKey()
ソースエンティティの期間化基準項目を取得します。

戻り値:
期間化基準項目となる属性

getInternationalKey

public InternationalKey getInternationalKey()
ソースエンティティの国際化基準項目を取得します。

戻り値:
国際化基準項目となる属性

getActivationKey

public ActivationKey getActivationKey()
ソースエンティティのライフタイム期間の有効開始日時を取得します。

戻り値:
ライフタイム期間の有効開始日時となる属性

getExpirationKey

public ExpirationKey getExpirationKey()
ソースエンティティのライフタイム期間の有効終了日時を取得します。

戻り値:
ライフタイム期間の有効終了日時となる属性

getDelete

public Delete getDelete()
ターゲットエンティティのデータ削除時の整合性制約を取得します。

戻り値:
データ削除時の整合性制約

getLifetime

public Lifetime getLifetime()
ターゲットエンティティの期間削除時の整合性制約を取得します。

戻り値:
期間削除時の整合性制約
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Table (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース Table

public interface Table

テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Application | getApplication() テーブルを定義しているアプリケーションを取得します。
BaseTable | getBaseTable() 基本テーブルを取得します。
Map | getColumns() テーブルに含まれるカラムをすべて取得します。
Entity | getEntity() テーブル定義の基となるエンティティを取得します。
InternationalTable | getInternationalTable() 国際化テーブルを取得します。
TerminableInternationalTable | getTerminableInternationalTable() 期間国際化テーブルを取得します。
TerminableTable | getTerminableTable() 期間化テーブルを取得します。

メソッドの詳細

getApplication

public Application getApplication()
テーブルを定義しているアプリケーションを取得します。

戻り値:
テーブルを定義しているアプリケーション

getEntity

public Entity getEntity()
テーブル定義の基となるエンティティを取得します。

戻り値:
テーブル定義の基となるエンティティ

getColumns

public Map getColumns()
テーブルに含まれるカラムをすべて取得します。 属性名をキー、 Columnを値としたマップを返します。

戻り値:
テーブルに含まれるカラム

getBaseTable

public BaseTable getBaseTable()
基本テーブルを取得します。

戻り値:
基本テーブル

getInternationalTable

public InternationalTable getInternationalTable()
国際化テーブルを取得します。 国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
国際化テーブル

getTerminableTable

public TerminableTable getTerminableTable()
期間化テーブルを取得します。 期間化テーブルが定義されていない場合、 null が返されます。

戻り値:
期間化テーブル

getTerminableInternationalTable

public TerminableInternationalTable getTerminableInternationalTable()
期間国際化テーブルを取得します。 期間国際化テーブルが定義されていない場合、 null が返されます。

戻り値:
期間国際化テーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableInternationalModel

public interface TerminableInternationalModel

期間国際化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 期間国際化モデルのクラス名を取得します。
Model | getModel() 期間国際化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
期間国際化モデルが定義されているモデル定義を取得します。

戻り値:
期間国際化モデルが定義されているモデル定義

getClassName

public String getClassName()
期間国際化モデルのクラス名を取得します。

戻り値:
期間国際化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableInternationalTable

public interface TerminableInternationalTable

期間国際化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getLocaleColumnName() ロケールに該当するカラムのカラム名を取得します。
String | getName() 期間国際化テーブルのテーブル名を取得します。
Table | getTable() 期間国際化テーブルが定義されているテーブル定義を取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getTable

public Table getTable()
期間国際化テーブルが定義されているテーブル定義を取得します。

戻り値:
期間国際化テーブルが定義されているテーブル定義

getName

public String getName()
期間国際化テーブルのテーブル名を取得します。

戻り値:
期間国際化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
期間国際化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getLocaleColumnName

public String getLocaleColumnName()
ロケールに該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableKey (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableKey

public interface TerminableKey

期間化基準項目を定義します。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getAttribute() 期間化基準項目となる属性を取得します。
Relationship[] | getRefereRelationships() ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
Entity | getSourceEntity() 期間化基準項目の基点となるソースエンティティの情報を取得します。

メソッドの詳細

getSourceEntity

public Entity getSourceEntity()
期間化基準項目の基点となるソースエンティティの情報を取得します。

戻り値:
ソースエンティティの情報

getRefereRelationships

public Relationship[] getRefereRelationships()
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。

戻り値:
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップ

getAttribute

public Attribute getAttribute()
期間化基準項目となる属性を取得します。

戻り値:
期間化基準項目となる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableModel

public interface TerminableModel

期間化モデルを定義します。

導入されたバージョン:
5.0

メソッドの概要
String | getClassName() 期間化モデルのクラス名を取得します。
Model | getModel() 期間化モデルが定義されているモデル定義を取得します。

メソッドの詳細

getModel

public Model getModel()
期間化モデルが定義されているモデル定義を取得します。

戻り値:
期間化モデルが定義されているモデル定義

getClassName

public String getClassName()
期間化モデルのクラス名を取得します。

戻り値:
期間化モデルのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableTable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース TerminableTable

public interface TerminableTable

期間化テーブルを定義します。

導入されたバージョン:
5.0

メソッドの概要
Map | getColumnMappings() 期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
String | getEndDateColumnName() 期間の日時に該当するカラムのカラム名を取得します。
String | getName() 期間化テーブルのテーブル名を取得します。
String | getStartDateColumnName() 期間の開始日時に該当するカラムのカラム名を取得します。
Table | getTable() 期間化テーブルが定義されているテーブル定義を取得します。
String | getTermColumnName() 期間CDに該当するカラムのカラム名を取得します。

メソッドの詳細

getTable

public Table getTable()
期間化テーブルが定義されているテーブル定義を取得します。

戻り値:
期間化テーブルが定義されているテーブル定義

getName

public String getName()
期間化テーブルのテーブル名を取得します。

戻り値:
期間化テーブルのテーブル名

getColumnMappings

public Map getColumnMappings()
期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。 属性名をキー、 ColumnMappingを値としたマップを返します。

戻り値:
期間化テーブルに含まれるカラムマッピング

getTermColumnName

public String getTermColumnName()
期間CDに該当するカラムのカラム名を取得します。

戻り値:
カラム名

getStartDateColumnName

public String getStartDateColumnName()
期間の開始日時に該当するカラムのカラム名を取得します。

戻り値:
カラム名

getEndDateColumnName

public String getEndDateColumnName()
期間の日時に該当するカラムのカラム名を取得します。

戻り値:
カラム名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UpdateInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.config
インタフェース UpdateInfo

public interface UpdateInfo

エンティティの更新情報です。 エンティティの更新ユーザ、更新日時となる属性を持ちます。

導入されたバージョン:
5.0

メソッドの概要
Attribute | getUpdateTimestamp() エンティティの更新日付となる属性を取得します。
Attribute | getUpdateUser() エンティティの更新ユーザとなる属性を取得します。

メソッドの詳細

getUpdateUser

public Attribute getUpdateUser()
エンティティの更新ユーザとなる属性を取得します。

戻り値:
エンティティの更新ユーザとなる属性

getUpdateTimestamp

public Attribute getUpdateTimestamp()
エンティティの更新日付となる属性を取得します。

戻り値:
エンティティの更新ユーザとなる属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.BaseModel の使用

BaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での BaseModel のサブインタフェース
 interface CateogryClassBaseModel
分類区分の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での BaseModel のサブインタフェース
 interface CategoryDetailBaseModel
分類区分詳細の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での BaseModel のサブインタフェース
 interface DepartmentAttachBaseModel
組織所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での BaseModel のサブインタフェース
 interface CompanyCategoryBaseModel
会社組織分類の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.company での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company での BaseModel のサブインタフェース
 interface CompanyBaseModel
会社の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での BaseModel のサブインタフェース
 interface DepartmentBaseModel
組織の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での BaseModel のサブインタフェース
 interface DepartmentInclusionBaseModel
組織内包の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での BaseModel のサブインタフェース
 interface DepartmentMainBaseModel
主所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での BaseModel のサブインタフェース
 interface CompanyPostBaseModel
役職の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.version での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version での BaseModel のサブインタフェース
 interface CompanyVersionBaseModel
会社構成バージョンの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での BaseModel のサブインタフェース
 interface PrivateGroupAttachBaseModel
プライベートグループ所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での BaseModel のサブインタフェース
 interface PrivateGroupBaseModel
プライベートグループの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での BaseModel のサブインタフェース
 interface PublicGroupAttachBaseModel
パブリックグループ所属の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での BaseModel のサブインタフェース
 interface PublicGroupCategoryBaseModel
パブリックグループ分類の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での BaseModel のサブインタフェース
 interface PublicGroupBaseModel
パブリックグループの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での BaseModel のサブインタフェース
 interface PublicGroupInclusionBaseModel
パブリックグループ内包の基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での BaseModel のサブインタフェース
 interface PublicGroupSetBaseModel
パブリックグループセットの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での BaseModel のサブインタフェース
 interface PublicGroupVersionBaseModel
パブリックグループ構成バージョンの基本モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での BaseModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での BaseModel のサブインタフェース
 interface UserBaseModel
ユーザの基本モデルです。

jp.co.intra_mart.foundation.datastore.common.model での BaseModel の使用

BaseModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericBaseModel
基本モデルの汎用的な抽象クラスです。

BaseModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
BaseModel | Mapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | Mapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
BaseModel | IntramartDBMapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | IntramartDBMapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。

BaseModel 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
protected void | IntramartDBMapper.insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | IntramartDBMapper.update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | IntramartDBMapper.delete(BaseModel model) 基本モデルを1つだけ削除します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext の使用

BaseModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での BaseModelContext の使用

BaseModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | GenericBaseModel.init(BaseModelContext context) 基本モデルを初期化します。
void | BaseModel.init(BaseModelContext context) 基本モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel の使用

ExtendedBaseModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseModel の使用

ExtendedBaseModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericBaseModel
拡張基本モデルの汎用的な抽象クラスです。

ExtendedBaseModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedBaseModel | ExtendedGenericBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。
ExtendedBaseModel | ExtendedBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap の使用

ExtendedBaseModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedBaseModelMap の使用

ExtendedBaseModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericBaseModelMap
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedBaseModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedBaseModelMap | GenericBaseModel.getExtendedBaseModelMap() 拡張基本モデルのマップを取得します。
ExtendedBaseModelMap | BaseModelContext.getExtendedBaseModelMap() 拡張基本モデルマップを取得します。
ExtendedBaseModelMap | BaseModel.getExtendedBaseModelMap() 拡張基本エンティティに対応する拡張基本モデルのマップを取得します。

ExtendedBaseModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap)
拡張基本モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel の使用

ExtendedInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalModel の使用

ExtendedInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericInternationalModel
拡張国際化モデルの汎用的な抽象クラスです。

ExtendedInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedInternationalModel | ExtendedInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.newExtendedInternationalModel(String name) 初期化されていない拡張国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap の使用

ExtendedInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedInternationalModelMap の使用

ExtendedInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericInternationalModelMap
拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedInternationalModelMap | InternationalModelContext.getExtendedInternationalModelMap() 拡張国際化モデルマップを取得します。
ExtendedInternationalModelMap | InternationalModel.getExtendedInternationalModelMap() 拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
ExtendedInternationalModelMap | GenericInternationalModel.getExtendedInternationalModelMap() 拡張国際化モデルのマップを取得します。

ExtendedInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void InternationalModelContext.setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap)
拡張国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalModel の使用

ExtendedTerminableInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableInternationalModel
拡張期間国際化モデルの汎用的な抽象クラスです。

ExtendedTerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap の使用

ExtendedTerminableInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableInternationalModelMap の使用

ExtendedTerminableInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableInternationalModelMap
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedTerminableInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableInternationalModelMap | TerminableInternationalModelContext.getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルマップを取得します。
ExtendedTerminableInternationalModelMap | TerminableInternationalModel.getExtendedTerminableInternationalModelMap() 拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
ExtendedTerminableInternationalModelMap | GenericTerminableInternationalModel.getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルのマップを取得します。

ExtendedTerminableInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableInternationalModelContext.setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap)
拡張期間国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel の使用

ExtendedTerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableModel の使用

ExtendedTerminableModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableModel
拡張期間化モデルの汎用的な抽象クラスです。

ExtendedTerminableModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModel | ExtendedTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap の使用

ExtendedTerminableModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での ExtendedTerminableModelMap の使用

ExtendedTerminableModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class ExtendedGenericTerminableModelMap
拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。

ExtendedTerminableModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModelMap | TerminableModelContext.getExtendedTerminableModelMap() 拡張期間化モデルマップを取得します。
ExtendedTerminableModelMap | TerminableModel.getExtendedTerminableModelMap() 拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
ExtendedTerminableModelMap | GenericTerminableModel.getExtendedTerminableModelMap() 拡張期間化モデルのマップを取得します。

ExtendedTerminableModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap)
拡張期間化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap の使用

jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModel の使用

InternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での InternationalModel のサブインタフェース
 interface CateogryClassInternationalModel
分類区分の国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での InternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での InternationalModel のサブインタフェース
 interface CategoryDetailInternationalModel
分類区分詳細の国際化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModel の使用

InternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericInternationalModel
国際化モデルの汎用的な抽象クラスです。

InternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalModel | InternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
InternationalModel | InternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
InternationalModel | GenericInternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
protected InternationalModel | GenericBaseModel.selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext の使用

InternationalModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModelContext の使用

InternationalModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | InternationalModel.init(InternationalModelContext context) 国際化モデルを初期化します。
void | GenericInternationalModel.init(InternationalModelContext context) 国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap の使用

InternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での InternationalModelMap の使用

InternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericInternationalModelMap
国際化モデルマッピングの汎用的な抽象クラスです。

InternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
InternationalModelMap | GenericBaseModel.getInternationalModelMap() 国際化モデルのマップを取得します。
InternationalModelMap | BaseModelContext.getInternationalModelMap() 国際化モデルマップを取得します。
InternationalModelMap | BaseModel.getInternationalModelMap() 国際化モデルのマップを取得します。

InternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setInternationalModelMap(InternationalModelMap internationalMap)
国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper の使用

jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.Mapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.Mapper の使用

Mapper を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での Mapper のサブインタフェース
 interface CateogryClassMapper
分類区分に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.category.detail での Mapper のサブインタフェース
 interface CategoryDetailMapper
分類区分詳細に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での Mapper のサブインタフェース
 interface DepartmentAttachMapper
組織所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での Mapper のサブインタフェース
 interface CompanyCategoryMapper
会社組織分類に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.company での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.company での Mapper のサブインタフェース
 interface CompanyMapper
会社に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での Mapper のサブインタフェース
 interface DepartmentMapper
組織に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での Mapper のサブインタフェース
 interface DepartmentInclusionMapper
組織内包に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での Mapper のサブインタフェース
 interface DepartmentMainMapper
主所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での Mapper のサブインタフェース
 interface CompanyPostMapper
役職に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.company.version での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.company.version での Mapper のサブインタフェース
 interface CompanyVersionMapper
会社構成バージョンに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での Mapper のサブインタフェース
 interface PrivateGroupAttachMapper
プライベートグループ所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での Mapper のサブインタフェース
 interface PrivateGroupMapper
プライベートグループに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での Mapper のサブインタフェース
 interface PublicGroupAttachMapper
パブリックグループ所属に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での Mapper のサブインタフェース
 interface PublicGroupCategoryMapper
パブリックグループ分類に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での Mapper のサブインタフェース
 interface PublicGroupMapper
パブリックグループに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での Mapper のサブインタフェース
 interface PublicGroupInclusionMapper
パブリックグループ内包に関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での Mapper のサブインタフェース
 interface PublicGroupSetMapper
パブリックグループセットに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での Mapper のサブインタフェース
 interface PublicGroupVersionMapper
パブリックグループ構成バージョンに関連するマッパです。

jp.co.intra_mart.foundation.datastore.application.model.user での Mapper の使用

jp.co.intra_mart.foundation.datastore.application.model.user での Mapper のサブインタフェース
 interface UserMapper
ユーザに関連するマッパです。

jp.co.intra_mart.foundation.datastore.common.model での Mapper の使用

Mapper を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class IntramartDBMapper
intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。

Mapper を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
abstract  Mapper MapperFactory.createMapper(String application, String entity, String group, String user)
マッパーを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の使用

MapperFactory を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での MapperFactory の使用

MapperFactory を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
static MapperFactory MapperFactory.newInstance()
マッパーファクトリを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel の使用

TerminableInternationalModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableInternationalModel のサブインタフェース
 interface DepartmentTerminableInternationalModel
組織の期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableInternationalModel のサブインタフェース
 interface CompanyPostTerminableInternationalModel
役職の期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableInternationalModel のサブインタフェース
 interface PublicGroupTerminableInternationalModel
パブリックグループの期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableInternationalModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableInternationalModel のサブインタフェース
 interface UserTerminableInternationalModel
ユーザの期間国際化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModel の使用

TerminableInternationalModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableInternationalModel
期間国際化モデルの汎用的な抽象クラスです。

TerminableInternationalModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModel | TerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
TerminableInternationalModel | TerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
protected TerminableInternationalModel | GenericTerminableModel.selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext の使用

TerminableInternationalModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModelContext の使用

TerminableInternationalModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | TerminableInternationalModel.init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。
void | GenericTerminableInternationalModel.init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap の使用

TerminableInternationalModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableInternationalModelMap の使用

TerminableInternationalModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableInternationalModelMap
期間国際化モデルマッピングの汎用的な抽象クラスです。

TerminableInternationalModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModelMap | TerminableModelContext.getTerminableInternationalModelMap() 期間国際化モデルマップを取得します。
TerminableInternationalModelMap | TerminableModel.getTerminableInternationalModelMap() 期間国際化モデルを取得します。
TerminableInternationalModelMap | GenericTerminableModel.getTerminableInternationalModelMap() 期間国際化モデルのマップを取得します。

TerminableInternationalModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void TerminableModelContext.setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap)
期間国際化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModel の使用

TerminableModel を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.attach での TerminableModel のサブインタフェース
 interface DepartmentAttachTerminableModel
組織所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.category での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.category での TerminableModel のサブインタフェース
 interface CompanyCategoryTerminableModel
会社組織分類の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.department での TerminableModel のサブインタフェース
 interface DepartmentTerminableModel
組織の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.main での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.main での TerminableModel のサブインタフェース
 interface DepartmentMainTerminableModel
主所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.company.post での TerminableModel のサブインタフェース
 interface CompanyPostTerminableModel
役職の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での TerminableModel のサブインタフェース
 interface PublicGroupAttachTerminableModel
パブリックグループ所属の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での TerminableModel のサブインタフェース
 interface PublicGroupCategoryTerminableModel
パブリックグループ分類の期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での TerminableModel のサブインタフェース
 interface PublicGroupTerminableModel
パブリックグループの期間化モデルです。

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableModel の使用

jp.co.intra_mart.foundation.datastore.application.model.user での TerminableModel のサブインタフェース
 interface UserTerminableModel
ユーザの期間化モデルです。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModel の使用

TerminableModel を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableModel
期間化モデルの汎用的な抽象クラスです。

TerminableModel を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
TerminableModel | TerminableModelMap.findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
TerminableModel | GenericTerminableModelMap.findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。
protected TerminableModel | GenericBaseModel.selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext の使用

TerminableModelContext を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModelContext の使用

TerminableModelContext 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
void | TerminableModel.init(TerminableModelContext context) 期間化モデルを初期化します。
void | GenericTerminableModel.init(TerminableModelContext context) 期間化モデルを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap の使用

TerminableModelMap を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.model での TerminableModelMap の使用

TerminableModelMap を実装している jp.co.intra_mart.foundation.datastore.common.model のクラス
 class GenericTerminableModelMap
期間化モデルマッピングの汎用的な抽象クラスです。

TerminableModelMap を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModelMap | GenericBaseModel.getTerminableModelMap() 期間化モデルのマップを取得します。
TerminableModelMap | BaseModelContext.getTerminableModelMap() 期間化モデルマップを取得します。
TerminableModelMap | BaseModel.getTerminableModelMap() 期間化モデルのマップを取得します。

TerminableModelMap 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
 void BaseModelContext.setTerminableModelMap(TerminableModelMap terminableMap)
期間化モデルマップを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


BaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース BaseModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CategoryDetailBaseModel, CateogryClassBaseModel, CompanyBaseModel, CompanyCategoryBaseModel, CompanyPostBaseModel, CompanyVersionBaseModel, DepartmentAttachBaseModel, DepartmentBaseModel, DepartmentInclusionBaseModel, DepartmentMainBaseModel, PrivateGroupAttachBaseModel, PrivateGroupBaseModel, PublicGroupAttachBaseModel, PublicGroupBaseModel, PublicGroupCategoryBaseModel, PublicGroupInclusionBaseModel, PublicGroupSetBaseModel, PublicGroupVersionBaseModel, UserBaseModel
既知の実装クラスの一覧:
GenericBaseModel
public interface BaseModel
extends Serializable

基本モデルの情報です。 基本エンティティの1データが基本モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
BaseAccessor | getBaseAccessor() 基本アクセサ BaseAccessor を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本エンティティに対応する拡張基本モデルのマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルのマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルのマップを取得します。
void | init(BaseModelContext context) 基本モデルを初期化します。

メソッドの詳細

init

public void init(BaseModelContext context)
基本モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 基本モデルコンテキスト

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルのマップを取得します。 この基本モデルに関連する国際化モデルのマップを取得します。

戻り値:
国際化モデルのマップ

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルのマップを取得します。 この基本モデルに関連する期間化モデルのマップを取得します。

戻り値:
期間化モデルのマップ

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本エンティティに対応する拡張基本モデルのマップを取得します。

戻り値:
拡張基本モデルマップ

getBaseAccessor

public BaseAccessor getBaseAccessor()
基本アクセサ BaseAccessor を取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

戻り値:
基本アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BaseModelContext (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース BaseModelContext

public interface BaseModelContext

基本モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
BaseAccessor | getBaseAccessor() 基本アクセサを取得します。
Date | getDefaultDate() デフォルト日時を取得します。
Locale | getDefaultLocale() デフォルト言語を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本モデルマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルマップを取得します。
void | setBaseAccessor(BaseAccessor accessor) 基本アクセサを設定します。
void | setDefaultDate(Date date) デフォルト日時を設定します。
void | setDefaultLocale(Locale locale) デフォルト言語を設定します。
void | setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap) 拡張基本モデルマップを設定します。
void | setInternationalModelMap(InternationalModelMap internationalMap) 国際化モデルマップを設定します。
void | setTerminableModelMap(TerminableModelMap terminableMap) 期間化モデルマップを設定します。

メソッドの詳細

setBaseAccessor

public void setBaseAccessor(BaseAccessor accessor)
基本アクセサを設定します。

パラメータ:
accessor - 基本アクセサ

getBaseAccessor

public BaseAccessor getBaseAccessor()
基本アクセサを取得します。

戻り値:
基本アクセサ

setDefaultDate

public void setDefaultDate(Date date)
デフォルト日時を設定します。

パラメータ:
date - 日時

getDefaultDate

public Date getDefaultDate()
デフォルト日時を取得します。

戻り値:
日時

setDefaultLocale

public void setDefaultLocale(Locale locale)
デフォルト言語を設定します。

パラメータ:
locale - 言語

getDefaultLocale

public Locale getDefaultLocale()
デフォルト言語を取得します。

戻り値:
言語

setInternationalModelMap

public void setInternationalModelMap(InternationalModelMap internationalMap)
国際化モデルマップを設定します。

パラメータ:
internationalMap - 国際化モデルマップ

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルマップを取得します。

戻り値:
国際化モデルマップ

setTerminableModelMap

public void setTerminableModelMap(TerminableModelMap terminableMap)
期間化モデルマップを設定します。

パラメータ:
terminableMap - 期間化モデルマップ

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルマップを取得します。

戻り値:
期間化モデルマップ

setExtendedBaseModelMap

public void setExtendedBaseModelMap(ExtendedBaseModelMap extendedMap)
拡張基本モデルマップを設定します。

パラメータ:
extendedMap - 拡張基本モデルマップ

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本モデルマップを取得します。

戻り値:
拡張基本モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedBaseModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericBaseModel
public interface ExtendedBaseModel
extends Serializable

拡張基本モデルの情報です。 基本エンティティの拡張部分に対応するモデル情報です。拡張基本エンティティの1データが拡張基本モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

パラメータ:
accessor - 拡張基本アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedBaseModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedBaseModelMap

既知の実装クラスの一覧:
ExtendedGenericBaseModelMap
public interface ExtendedBaseModelMap

拡張基本モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedBaseModel | createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。

メソッドの詳細

createExtendedBaseModel

public ExtendedBaseModel createExtendedBaseModel(String name)
                                          throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedBaseModel

public ExtendedBaseModel findExtendedBaseModel(String name)
                                        throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericBaseModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel
すべての実装インタフェース:
ExtendedBaseModel, Serializable
public abstract class ExtendedGenericBaseModel
extends Object
implements ExtendedBaseModel

拡張基本モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericBaseModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedBaseAccessor accessor) 拡張基本モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericBaseModel

public ExtendedGenericBaseModel()
メソッドの詳細

init

public void init(ExtendedBaseAccessor accessor)
拡張基本モデルを初期化します。

定義:
インタフェース ExtendedBaseModel 内の init
パラメータ:
accessor - 拡張基本アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericBaseModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericBaseModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap
すべての実装インタフェース:
ExtendedBaseModelMap
public abstract class ExtendedGenericBaseModelMap
extends Object
implements ExtendedBaseModelMap

拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericBaseModelMap()
メソッドの概要
ExtendedBaseModel | createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | init(ExtendedBaseAccessorMap accessorMap) 初期化を行います。
ExtendedBaseModel | newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericBaseModelMap

public ExtendedGenericBaseModelMap()
メソッドの詳細

init

public void init(ExtendedBaseAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張基本アクセサマップ

createExtendedBaseModel

public ExtendedBaseModel createExtendedBaseModel(String name)
                                          throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedBaseModelMap 内の createExtendedBaseModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedBaseModel

public ExtendedBaseModel findExtendedBaseModel(String name)
                                        throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedBaseModelMap 内の findExtendedBaseModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedBaseModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedBaseModel

public ExtendedBaseModel newExtendedBaseModel(String name)
                                       throws IllegalExtensionException
初期化されていない拡張基本モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または基本属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel
すべての実装インタフェース:
ExtendedInternationalModel, Serializable
public abstract class ExtendedGenericInternationalModel
extends Object
implements ExtendedInternationalModel

拡張国際化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedInternationalAccessor accessor) 拡張国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericInternationalModel

public ExtendedGenericInternationalModel()
メソッドの詳細

init

public void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

定義:
インタフェース ExtendedInternationalModel 内の init
パラメータ:
accessor - 拡張国際化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericInternationalModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap
すべての実装インタフェース:
ExtendedInternationalModelMap
public abstract class ExtendedGenericInternationalModelMap
extends Object
implements ExtendedInternationalModelMap

拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericInternationalModelMap()
メソッドの概要
ExtendedInternationalModel | createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | init(ExtendedInternationalAccessorMap accessorMap) 初期化を行います。
ExtendedInternationalModel | newExtendedInternationalModel(String name) 初期化されていない拡張国際化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericInternationalModelMap

public ExtendedGenericInternationalModelMap()
メソッドの詳細

init

public void init(ExtendedInternationalAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張国際化アクセサマップ

createExtendedInternationalModel

public ExtendedInternationalModel createExtendedInternationalModel(String name)
                                                            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedInternationalModelMap 内の createExtendedInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedInternationalModel

public ExtendedInternationalModel findExtendedInternationalModel(String name)
                                                          throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedInternationalModelMap 内の findExtendedInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedInternationalModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedInternationalModel

public ExtendedInternationalModel newExtendedInternationalModel(String name)
初期化されていない拡張国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張国際化モデルのインスタンス
例外:
ModelCreateException - 拡張モデルのインスタンスの生成に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel
すべての実装インタフェース:
ExtendedTerminableInternationalModel, Serializable
public abstract class ExtendedGenericTerminableInternationalModel
extends Object
implements ExtendedTerminableInternationalModel

拡張期間国際化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericTerminableInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedTerminableInternationalAccessor accessor) 拡張期間国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableInternationalModel

public ExtendedGenericTerminableInternationalModel()
メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

定義:
インタフェース ExtendedTerminableInternationalModel 内の init
パラメータ:
accessor - 拡張期間国際化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableInternationalModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap
すべての実装インタフェース:
ExtendedTerminableInternationalModelMap
public abstract class ExtendedGenericTerminableInternationalModelMap
extends Object
implements ExtendedTerminableInternationalModelMap

拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericTerminableInternationalModelMap()
メソッドの概要
ExtendedTerminableInternationalModel | createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | init(ExtendedTerminableInternationalAccessorMap accessorMap) 初期化を行います。
ExtendedTerminableInternationalModel | newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableInternationalModelMap

public ExtendedGenericTerminableInternationalModelMap()
メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張期間国際化アクセサマップ

createExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel createExtendedTerminableInternationalModel(String name)
                                                                                throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の createExtendedTerminableInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel findExtendedTerminableInternationalModel(String name)
                                                                              throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の findExtendedTerminableInternationalModel
パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedTerminableInternationalModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel newExtendedTerminableInternationalModel(String name)
                                                                             throws IllegalExtensionException
初期化されていない拡張期間国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または期間国際化属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel
すべての実装インタフェース:
ExtendedTerminableModel, Serializable
public abstract class ExtendedGenericTerminableModel
extends Object
implements ExtendedTerminableModel

拡張期間化モデルの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ExtendedGenericTerminableModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
void | init(ExtendedTerminableAccessor accessor) 拡張期間化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableModel

public ExtendedGenericTerminableModel()
メソッドの詳細

init

public void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

定義:
インタフェース ExtendedTerminableModel 内の init
パラメータ:
accessor - 拡張期間化アクセサ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedGenericTerminableModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス ExtendedGenericTerminableModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap
すべての実装インタフェース:
ExtendedTerminableModelMap
public abstract class ExtendedGenericTerminableModelMap
extends Object
implements ExtendedTerminableModelMap

拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
ExtendedGenericTerminableModelMap()
メソッドの概要
ExtendedTerminableModel | createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | init(ExtendedTerminableAccessorMap accessorMap) 初期化を行います。
ExtendedTerminableModel | newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。
void | remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedGenericTerminableModelMap

public ExtendedGenericTerminableModelMap()
メソッドの詳細

init

public void init(ExtendedTerminableAccessorMap accessorMap)
初期化を行います。

パラメータ:
accessorMap - 拡張期間化アクセサマップ

createExtendedTerminableModel

public ExtendedTerminableModel createExtendedTerminableModel(String name)
                                                      throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

定義:
インタフェース ExtendedTerminableModelMap 内の createExtendedTerminableModel
パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableModel

public ExtendedTerminableModel findExtendedTerminableModel(String name)
                                                    throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

定義:
インタフェース ExtendedTerminableModelMap 内の findExtendedTerminableModel
パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

定義:
インタフェース ExtendedTerminableModelMap 内の remove
パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合

newExtendedTerminableModel

public ExtendedTerminableModel newExtendedTerminableModel(String name)
                                                   throws IllegalExtensionException
初期化されてていない拡張期間化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデルのインスタンス
例外:
IllegalExtensionException - 存在しない拡張名、または期間化属性を持たない拡張名が指定された場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedInternationalModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericInternationalModel
public interface ExtendedInternationalModel
extends Serializable

拡張国際化モデルの情報です。 国際化エンティティの拡張部分に対応するモデル情報です。拡張国際化エンティティの1データが拡張国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedInternationalAccessor accessor)
拡張国際化モデルを初期化します。

パラメータ:
accessor - 拡張国際化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInternationalModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedInternationalModelMap

既知の実装クラスの一覧:
ExtendedGenericInternationalModelMap
public interface ExtendedInternationalModelMap

拡張国際化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModel | createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。

メソッドの詳細

createExtendedInternationalModel

public ExtendedInternationalModel createExtendedInternationalModel(String name)
                                                            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedInternationalModel

public ExtendedInternationalModel findExtendedInternationalModel(String name)
                                                          throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張基本モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableInternationalModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericTerminableInternationalModel
public interface ExtendedTerminableInternationalModel
extends Serializable

拡張期間国際化モデルの情報です。 期間国際化エンティティの拡張部分に対応するモデル情報です。拡張期間国際化エンティティの1データが拡張期間国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedTerminableInternationalAccessor accessor)
拡張期間国際化モデルを初期化します。

パラメータ:
accessor - 拡張期間国際化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableInternationalModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableInternationalModelMap

既知の実装クラスの一覧:
ExtendedGenericTerminableInternationalModelMap
public interface ExtendedTerminableInternationalModelMap

拡張期間国際化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModel | createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。

メソッドの詳細

createExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel createExtendedTerminableInternationalModel(String name)
                                                                                throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableInternationalModel

public ExtendedTerminableInternationalModel findExtendedTerminableInternationalModel(String name)
                                                                              throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間国際化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableModel

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ExtendedGenericTerminableModel
public interface ExtendedTerminableModel
extends Serializable

拡張期間化モデルの情報です。 期間化エンティティの拡張部分に対応するモデル情報です。拡張期間化エンティティの1データが拡張期間化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
 void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

メソッドの詳細

init

public void init(ExtendedTerminableAccessor accessor)
拡張期間化モデルを初期化します。

パラメータ:
accessor - 拡張期間化アクセサ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedTerminableModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース ExtendedTerminableModelMap

既知の実装クラスの一覧:
ExtendedGenericTerminableModelMap
public interface ExtendedTerminableModelMap

拡張期間化モデルのマッピング情報を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableModel | createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。

メソッドの詳細

createExtendedTerminableModel

public ExtendedTerminableModel createExtendedTerminableModel(String name)
                                                      throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

findExtendedTerminableModel

public ExtendedTerminableModel findExtendedTerminableModel(String name)
                                                    throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は null を返します。

パラメータ:
name - 拡張名
戻り値:
拡張期間化モデル
例外:
AccessorException - アクセサで例外が何らかの発生した場合

remove

public void remove(String name)
            throws AccessorException
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。 拡張名には「拡張モデルが定義されているアプリケーション名 + . + 拡張名」を設定して下さい。 拡張名で指定される拡張モデルが生成されていない場合は何もしません。

パラメータ:
name - 拡張名
例外:
AccessorException - アクセサで例外が何らかの発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericBaseModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericBaseModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel
すべての実装インタフェース:
BaseModel, Serializable
public abstract class GenericBaseModel
extends Object
implements BaseModel

基本モデルの汎用的な抽象クラスです。 このクラスでは、 init(BaseModelContext)で設定された基本アクセサを getBaseAccessor() で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericBaseModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
protected Object | get(String name, Date date) 指定の属性が、指定の日時に保持している値を取得します。
protected Object | get(String name, Date date, Locale locale) 指定の属性が、指定の日時、言語で保持している値を取得します。
protected Object | get(String name, Locale locale) 指定の属性が、指定の言語で保持している値を取得します。
BaseAccessor | getBaseAccessor() この基本モデルに割り当てられた基本アクセサを取得します。
protected Date | getDefaultDate() モデル生成時に設定されたデフォルト日時を取得します。
protected Locale | getDefaultLocale() モデル生成時に設定されたデフォルト言語を取得します。
ExtendedBaseModelMap | getExtendedBaseModelMap() 拡張基本モデルのマップを取得します。
InternationalModelMap | getInternationalModelMap() 国際化モデルのマップを取得します。
TerminableModelMap | getTerminableModelMap() 期間化モデルのマップを取得します。
void | init(BaseModelContext context) 基本モデルを初期化します。
protected InternationalModel | selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
protected TerminableModel | selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
protected void | set(String name, Object value, Date date) 指定の属性に、指定の日時で値を設定します。
protected void | set(String name, Object value, Date date, Locale locale) 指定の属性に、指定の日時、言語で値を設定します。
protected void | set(String name, Object value, Locale locale) 指定の属性に、指定の言語で値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericBaseModel

public GenericBaseModel()
メソッドの詳細

init

public void init(BaseModelContext context)
基本モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース BaseModel 内の init
パラメータ:
context - 基本モデルコンテキスト

getBaseAccessor

public BaseAccessor getBaseAccessor()
この基本モデルに割り当てられた基本アクセサを取得します。

定義:
インタフェース BaseModel 内の getBaseAccessor
戻り値:
基本アクセサ

getInternationalModelMap

public InternationalModelMap getInternationalModelMap()
国際化モデルのマップを取得します。 この基本モデルに関連する国際化モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getInternationalModelMap
戻り値:
国際化モデルマップ

selectInternationalModel

protected InternationalModel selectInternationalModel(Locale locale)
                                               throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。

パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getTerminableModelMap

public TerminableModelMap getTerminableModelMap()
期間化モデルのマップを取得します。 この基本モデルに関連する期間化モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getTerminableModelMap
戻り値:
期間化モデルマップ

selectTerminableModel

protected TerminableModel selectTerminableModel(Date date)
                                         throws IllegalTermException
指定された日時に該当する期間化モデルを取得します。

パラメータ:
date - 日時
戻り値:
期間化モデル
例外:
IllegalTermException - 期間に関する例外が発生した場合

getExtendedBaseModelMap

public ExtendedBaseModelMap getExtendedBaseModelMap()
拡張基本モデルのマップを取得します。 この基本モデルに関連する拡張基本モデルのマップを取得します。

定義:
インタフェース BaseModel 内の getExtendedBaseModelMap
戻り値:
拡張基本モデルマップ

getDefaultDate

protected Date getDefaultDate()
モデル生成時に設定されたデフォルト日時を取得します。

戻り値:
デフォルト日時

getDefaultLocale

protected Locale getDefaultLocale()
モデル生成時に設定されたデフォルト言語を取得します。

戻り値:
デフォルト言語

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Date date)
              throws AccessorException
指定の属性が、指定の日時に保持している値を取得します。

パラメータ:
name - 属性名
date - 日時
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Locale locale)
              throws AccessorException
指定の属性が、指定の言語で保持している値を取得します。

パラメータ:
name - 属性名
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Date date,
                     Locale locale)
              throws AccessorException
指定の属性が、指定の日時、言語で保持している値を取得します。

パラメータ:
name - 属性名
date - 日時
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Date date)
            throws AccessorException
指定の属性に、指定の日時で値を設定します。

パラメータ:
name - 属性名
value - 値
date - 日時
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Locale locale)
            throws AccessorException
指定の属性に、指定の言語で値を設定します。

パラメータ:
name - 属性名
value - 値
locale - 言語
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Date date,
                   Locale locale)
            throws AccessorException
指定の属性に、指定の日時、言語で値を設定します。

パラメータ:
name - 属性名
value - 値
date - 日時
locale - 言語
例外:
AccessorException - アクセサで例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel
すべての実装インタフェース:
InternationalModel, Serializable
public abstract class GenericInternationalModel
extends Object
implements InternationalModel

国際化モデルの汎用的な抽象クラスです。 このクラスでは、 init(InternationalModelContext)で設定された国際化アクセサを getInternationalAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化モデルのマップを取得します。
protected InternationalAccessor | getInternationalAccessor() この国際化モデルに割り当てられた国際化アクセサを取得します。
Locale | getLocale() 国際化モデルが保持する言語 Locale を取得します。
void | init(InternationalModelContext context) 国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericInternationalModel

public GenericInternationalModel()
メソッドの詳細

init

public void init(InternationalModelContext context)
国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース InternationalModel 内の init
パラメータ:
context - 国際化モデルコンテキスト

getInternationalAccessor

protected InternationalAccessor getInternationalAccessor()
この国際化モデルに割り当てられた国際化アクセサを取得します。

戻り値:
国際化アクセサ

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化モデルのマップを取得します。 この国際化モデルに関連する拡張国際化モデルのマップを取得します。

定義:
インタフェース InternationalModel 内の getExtendedInternationalModelMap
戻り値:
拡張国際化モデルマップ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

getLocale

public Locale getLocale()
国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

定義:
インタフェース InternationalModel 内の getLocale
戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericInternationalModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap
すべての実装インタフェース:
InternationalModelMap, Serializable
public abstract class GenericInternationalModelMap
extends Object
implements InternationalModelMap

国際化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericInternationalModelMap()
メソッドの概要
InternationalModel | createInternationalModel(Locale locale) 国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する国際化モデルが存在するどうか判定します。
InternationalModel | findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | init(String modelName, InternationalAccessorMap accessorMap) 初期化処理を行います。
InternationalModel | newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericInternationalModelMap

public GenericInternationalModelMap()
メソッドの詳細

init

public void init(String modelName,
                 InternationalAccessorMap accessorMap)
初期化処理を行います。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
modelName - モデル名
accessorMap - 国際化アクセサマップ

createInternationalModel

public InternationalModel createInternationalModel(Locale locale)
                                            throws AccessorException
国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

定義:
インタフェース InternationalModelMap 内の createInternationalModel
パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する国際化モデルが存在するどうか判定します。

定義:
インタフェース InternationalModelMap 内の exists
パラメータ:
locale - 言語
戻り値:
指定された言語に該当する国際化モデルが存在する場合は true、それ以外は false

findInternationalModel

public InternationalModel findInternationalModel(Locale locale)
                                          throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。 引数 locale で指定された言語に該当する　TerminableModel を取得します。該当するものが存在しない場合、 null が返されます。

定義:
インタフェース InternationalModelMap 内の findInternationalModel
パラメータ:
locale - 対象となる言語
戻り値:
対象となる国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 対象のlocale が見つからない場合

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

定義:
インタフェース InternationalModelMap 内の remove
パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで例外が発生した場合

newInternationalModel

public InternationalModel newInternationalModel(Locale locale)
                                         throws IllegalLocaleException
初期化されていない国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
locale - 言語
戻り値:
国際化モデルのインスタンス
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

定義:
インタフェース InternationalModelMap 内の getLocales
戻り値:
言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableInternationalModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel
すべての実装インタフェース:
Serializable, TerminableInternationalModel
public abstract class GenericTerminableInternationalModel
extends Object
implements TerminableInternationalModel

期間国際化モデルの汎用的な抽象クラスです。 このクラスでは、 init(TerminableInternationalModelContext)で設定された期間国際化アクセサを getTerminableInternationalAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableInternationalModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルのマップを取得します。
Locale | getLocale() 期間国際化モデルが保持する言語 Locale を取得します。
protected TerminableInternationalAccessor | getTerminableInternationalAccessor() この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。
void | init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableInternationalModel

public GenericTerminableInternationalModel()
メソッドの詳細

init

public void init(TerminableInternationalModelContext context)
期間国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース TerminableInternationalModel 内の init
パラメータ:
context - 期間国際化モデルコンテキスト

getTerminableInternationalAccessor

protected TerminableInternationalAccessor getTerminableInternationalAccessor()
この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化モデルのマップを取得します。 この期間国際化モデルに関連する拡張期間国際化モデルのマップを取得します。

定義:
インタフェース TerminableInternationalModel 内の getExtendedTerminableInternationalModelMap
戻り値:
拡張期間国際化モデルマップ

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

getLocale

public Locale getLocale()
期間国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

定義:
インタフェース TerminableInternationalModel 内の getLocale
戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableInternationalModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableInternationalModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap
すべての実装インタフェース:
Serializable, TerminableInternationalModelMap
public abstract class GenericTerminableInternationalModelMap
extends Object
implements TerminableInternationalModelMap

期間国際化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableInternationalModelMap()
メソッドの概要
TerminableInternationalModel | createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
TerminableInternationalModel | findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | init(String modelName, TerminableInternationalAccessorMap accessorMap) 初期化処理を行います。
TerminableInternationalModel | newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableInternationalModelMap

public GenericTerminableInternationalModelMap()
メソッドの詳細

init

public void init(String modelName,
                 TerminableInternationalAccessorMap accessorMap)
初期化処理を行います。

パラメータ:
modelName - 期間国際化モデルのクラス名
accessorMap - 期間国際化アクセサマップ

createTerminableInternationalModel

public TerminableInternationalModel createTerminableInternationalModel(Locale locale)
                                                                throws AccessorException
期間国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

定義:
インタフェース TerminableInternationalModelMap 内の createTerminableInternationalModel
パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。

定義:
インタフェース TerminableInternationalModelMap 内の exists
パラメータ:
locale - 言語
戻り値:
対象となる期間国際化モデルが存在する場合 true、それ以外は false

findTerminableInternationalModel

public TerminableInternationalModel findTerminableInternationalModel(Locale locale)
                                                              throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。 引数 locale で指定された言語に該当する TerminableInternationalModelを取得します。該当するものが存在しない場合、 null が返されます。

定義:
インタフェース TerminableInternationalModelMap 内の findTerminableInternationalModel
パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 対象の言語が見つからない場合

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

定義:
インタフェース TerminableInternationalModelMap 内の remove
パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで例外が発生した場合

newTerminableInternationalModel

public TerminableInternationalModel newTerminableInternationalModel(Locale locale)
                                                             throws IllegalLocaleException
初期化されていない期間国際化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
locale - 言語
戻り値:
期間国際化モデルのインスタンス
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

定義:
インタフェース TerminableInternationalModelMap 内の getLocales
戻り値:
言語の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel
すべての実装インタフェース:
Serializable, TerminableModel
public abstract class GenericTerminableModel
extends Object
implements TerminableModel

期間化モデルの汎用的な抽象クラスです。 このクラスでは、 init(TerminableModelContext)で設定された期間化アクセサを getTerminableAccessor()で取得することができます。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableModel()
メソッドの概要
protected Object | get(String name) 指定の属性が保持する値を取得します。
protected Object | get(String name, Locale locale) 指定の属性が指定の言語で保持する値を取得します。
protected Locale | getDefaultLocale() モデル生成時に指定された言語を取得します。
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化モデルのマップを取得します。
Term | getTerm() 期間化モデルが保持する期間 Term を取得します。
protected TerminableAccessor | getTerminableAccessor() この期間化モデルに割り当てられた期間化アクセサを取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルのマップを取得します。
void | init(TerminableModelContext context) 期間化モデルを初期化します。
protected TerminableInternationalModel | selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
protected void | set(String name, Object value) 指定の属性に値を設定します。
protected void | set(String name, Object value, Locale locale) 指定の属性に値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableModel

public GenericTerminableModel()
メソッドの詳細

init

public void init(TerminableModelContext context)
期間化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

定義:
インタフェース TerminableModel 内の init
パラメータ:
context - 期間化モデルコンテキスト

getTerminableAccessor

protected TerminableAccessor getTerminableAccessor()
この期間化モデルに割り当てられた期間化アクセサを取得します。

戻り値:
期間化アクセサ

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルのマップを取得します。 この期間化モデルに関連する期間国際化モデルのマップを取得します。

定義:
インタフェース TerminableModel 内の getTerminableInternationalModelMap
戻り値:
期間国際化モデルマップ

selectTerminableInternationalModel

protected TerminableInternationalModel selectTerminableInternationalModel(Locale locale)
                                                                   throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。

パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
IllegalLocaleException - 言語に関する問題が発生した場合

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化モデルのマップを取得します。 この期間化モデルに関連する拡張期間化モデルのマップを取得します。

定義:
インタフェース TerminableModel 内の getExtendedTerminableModelMap
戻り値:
拡張期間化モデルマップ

getDefaultLocale

protected Locale getDefaultLocale()
モデル生成時に指定された言語を取得します。

戻り値:
モデル生成時のlocale

get

protected Object get(String name)
              throws AccessorException
指定の属性が保持する値を取得します。

パラメータ:
name - 属性名
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

get

protected Object get(String name,
                     Locale locale)
              throws AccessorException
指定の属性が指定の言語で保持する値を取得します。

パラメータ:
name - 属性名
locale - 言語
戻り値:
属性値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
AccessorException - アクセサで例外が発生した場合

set

protected void set(String name,
                   Object value,
                   Locale locale)
            throws AccessorException
指定の属性に値を設定します。

パラメータ:
name - 属性名
value - 値
例外:
IllegalLocaleException - 言語に関する例外が発生した場合
AccessorException - アクセサで例外が発生した場合

getTerm

public Term getTerm()
期間化モデルが保持する期間 Term を取得します。 このメソッドをオーバーライドすると期間を取得できなくなります。

定義:
インタフェース TerminableModel 内の getTerm
戻り値:
期間
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericTerminableModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス GenericTerminableModelMap

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap
すべての実装インタフェース:
Serializable, TerminableModelMap
public abstract class GenericTerminableModelMap
extends Object
implements TerminableModelMap

期間化モデルマッピングの汎用的な抽象クラスです。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
GenericTerminableModelMap()
メソッドの概要
TerminableModel | createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
boolean | exists(Date date) 指定された日時を含む期間化モデルが存在するかどうか判定します。
TerminableModel | findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
Term[] | getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
void | init(String terminableName, String terminableInternationalName, TerminableAccessorMap accessorMap, Locale defaultLocale) 初期化処理を行います。
TerminableModel | newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。
void | remove(Term term) 指定された期間に該当するデータを削除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericTerminableModelMap

public GenericTerminableModelMap()
メソッドの詳細

init

public void init(String terminableName,
                 String terminableInternationalName,
                 TerminableAccessorMap accessorMap,
                 Locale defaultLocale)
初期化処理を行います。

パラメータ:
terminableName - 期間化モデルのクラス名
terminableInternationalName - 期間国際化モデルのクラス名
accessorMap - 期間化アクセサマップ
defaultLocale - デフォルト言語

createTerminableModel

public TerminableModel createTerminableModel(Term term)
                                      throws AccessorException
指定した期間を満たす期間化モデルを生成します。 設定した期間化モデルによって重複する期間が発生する場合、例外が発生します。

定義:
インタフェース TerminableModelMap 内の createTerminableModel
パラメータ:
term - 期間 　　 *
戻り値:
期間化モデル
例外:
AccessorException - アクセサで何らかの例外が発生した場合

exists

public boolean exists(Date date)
指定された日時を含む期間化モデルが存在するかどうか判定します。

定義:
インタフェース TerminableModelMap 内の exists
パラメータ:
date - 日時
戻り値:
指定された日時を含む期間化モデルが存在する場合は true、それ以外は false

findTerminableModel

public TerminableModel findTerminableModel(Date date)
                                    throws IllegalTermException
指定された日時に該当する期間化モデルを取得します。 引数 date で指定された日時を期間内に含む TerminableModelを取得します。
指定された日時に該当する期間化モデルが存在しない場合は例外を返します。

定義:
インタフェース TerminableModelMap 内の findTerminableModel
パラメータ:
date - 対象となる日時
戻り値:
対象となる期間化モデル
例外:
IllegalTermException - 該当するものが存在しない場合

remove

public void remove(Term term)
            throws AccessorException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。

定義:
インタフェース TerminableModelMap 内の remove
パラメータ:
term - 削除対象の期間
例外:
AccessorException - アクセサで何らかの例外が発生した場合

newTerminableModel

public TerminableModel newTerminableModel(Term term)
                                   throws DataStoreSystemException
初期化されていない期間化モデルのインスタンスを取得します。 このメソッドはシステム内で使用されます。明示的に使用しないでください。

パラメータ:
term - 期間
戻り値:
期間化モデルのインスタンス
例外:
DataStoreSystemException

getTerms

public Term[] getTerms()
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。 取得される期間は時系列でソートされています。

定義:
インタフェース TerminableModelMap 内の getTerms
戻り値:
期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CategoryDetailInternationalModel, CateogryClassInternationalModel
既知の実装クラスの一覧:
GenericInternationalModel
public interface InternationalModel
extends Serializable

国際化モデルの情報です。 国際化エンティティの1データが国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
Locale | getLocale() 国際化モデルが保持する言語 Locale を取得します。
void | init(InternationalModelContext context) 国際化モデルを初期化します。

メソッドの詳細

init

public void init(InternationalModelContext context)
国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 国際化モデルコンテキスト

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。

戻り値:
拡張国際化モデルマップ

getLocale

public Locale getLocale()
国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModelContext (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModelContext

public interface InternationalModelContext

国際化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedInternationalModelMap | getExtendedInternationalModelMap() 拡張国際化モデルマップを取得します。
InternationalAccessor | getInternationalAccessor() 国際化アクセサを取得します。
void | setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap) 拡張国際化モデルマップを設定します。
void | setInternationalAccessor(InternationalAccessor accessor) 国際化アクセサを設定します。

メソッドの詳細

setInternationalAccessor

public void setInternationalAccessor(InternationalAccessor accessor)
国際化アクセサを設定します。

パラメータ:
accessor - 国際化アクセサ

getInternationalAccessor

public InternationalAccessor getInternationalAccessor()
国際化アクセサを取得します。

戻り値:
国際化アクセサ

setExtendedInternationalModelMap

public void setExtendedInternationalModelMap(ExtendedInternationalModelMap extendedMap)
拡張国際化モデルマップを設定します。

パラメータ:
extendedMap - 拡張国際化モデルマップ

getExtendedInternationalModelMap

public ExtendedInternationalModelMap getExtendedInternationalModelMap()
拡張国際化モデルマップを取得します。

戻り値:
拡張国際化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース InternationalModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericInternationalModelMap
public interface InternationalModelMap
extends Serializable

国際化モデルのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。

導入されたバージョン:
5.0

メソッドの概要
InternationalModel | createInternationalModel(Locale locale) 国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する国際化モデルが存在するどうか判定します。
InternationalModel | findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
Locale[] | getLocales() マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createInternationalModel

public InternationalModel createInternationalModel(Locale locale)
                                            throws AccessorException
国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する国際化モデルが存在するどうか判定します。

パラメータ:
locale - 言語
戻り値:
指定された言語に該当する国際化モデルが存在する場合は true、それ以外は false

findInternationalModel

public InternationalModel findInternationalModel(Locale locale)
                                          throws IllegalLocaleException
指定された言語に該当する国際化モデルを取得します。 引数 locale で指定された言語に該当する InternationalModel を取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。

戻り値:
言語の一覧

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
AccessorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBMapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス IntramartDBMapper

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper
すべての実装インタフェース:
Mapper
public abstract class IntramartDBMapper
extends Object
implements Mapper

intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。

導入されたバージョン:
5.0

コンストラクタの概要
IntramartDBMapper()
メソッドの概要
void | checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | close() マッパーをクローズします。
protected BaseAccessor | createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseModel | createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
protected void | delete(BaseModel model) 基本モデルを1つだけ削除します。
protected void | delete(Collection models) アクセサを複数削除します。
protected abstract String | getApplicationName() マッパーが定義されているアプリケーション名を取得します。
protected abstract String | getEntityName() マッパーがアクセスするエンティティ名を取得します。
void | init(String user, String group) マッパーを初期化します。
protected void | insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | insert(Collection models) 基本モデルを複数挿入します。
boolean | isClosed() マッパーがクローズされているかどうか確認します。
void | notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
BaseModel | select(Map keys) プライマリーキーで特定される基本モデルを取得します。
protected Collection | select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
protected void | update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | update(Collection models) 基本モデルを複数更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartDBMapper

public IntramartDBMapper()
メソッドの詳細

init

public void init(String user,
                 String group)
          throws MapperException
マッパーを初期化します。 マッパーを生成する場合は、このメソッドを必ず呼び出して下さい。

定義:
インタフェース Mapper 内の init
パラメータ:
user - ログインユーザID
group - ログイングループID
例外:
MapperException - マッパーの初期化に失敗した場合

createBaseAccessor

protected BaseAccessor createBaseAccessor(Map primary)
                                   throws MapperException
このマッパーに該当する基本アクセサを新規に生成します。 アクセサはコンストラクタではなくこの新規生成系メソッドでのみ生成します。このメソッドで生成されたアクセサは次の状態です。
  • 指定された（または自動的に割り当てられた）プライマリキーが設定済
  • 国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 期間化アクセサが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
  • 期間国際化アクセサが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)

パラメータ:
primary - 基本アクセサのプライマリキー
戻り値:
基本アクセサ
例外:
MapperException

createBaseModel

public BaseModel createBaseModel(Map keys)
                          throws MapperException
このマッパーに該当する基本モデルを新規に生成します。 モデルを新規に生成することができるのはこのメソッドだけです。このメソッドで生成されたモデルは次の状態になります。
  • 指定されたプライマリキーが設定済
  • 該当するエンティティが国際化されている場合は、国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 該当するエンティティが期間化されている場合は、期間化モデルが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
  • 該当するエンティティが期間国際化されている場合は、期間国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15|00:00:00)
    • 有効終了日は期間の最大日時 (9999/12/31|23:59:59)
    このメソッドで生成されたモデルはまだデータベースには反映されていません。データベースに反映するためには以下のデータ更新系のAPIを使用します。
    • insert(BaseModel)
    • insert(Collection)
    • update(BaseModel)
    • update(Collection)
    • delete(BaseModel)
    • delete(Collection)

    定義:
    インタフェース Mapper 内の createBaseModel
    パラメータ:
    keys - 項目名とその値を持つプライマリキーのマップ
    戻り値:
    プライマリキーが設定された基本モデル
    例外:
    MapperException - モデルの生成に失敗した場合

select

public BaseModel select(Map keys)
                 throws MapperException
プライマリーキーで特定される基本モデルを取得します。 取得される基本モデルには、国際化されている場合にはすべての言語情報、期間化されている場合にはすべての期間情報が設定されます。 また、基本モデル BaseModel、国際化モデル InternationalModel、期間化モデル TerminableModel、 期間国際化モデル TerminableInternationalModel にはすべてのプロパティが設定されます。
プライマリーキーに一致するデータが存在しない場合は、null を返します。

定義:
インタフェース Mapper 内の select
パラメータ:
keys - 項目名とその値を持つプライマリキーのマップ
戻り値:
基本モデル
例外:
MapperException - モデルの取得に失敗した場合

select

protected Collection select(Relationship relationship,
                            Map keys)
                     throws MapperException
外部キーで特定される基本モデルをすべて取得します。 外部キーによる検索条件に一致する基本モデル BaseModel のコレクション Collection が取得されます。
検索条件に一致するデータが存在しない場合は、空のコレクションを返します。

パラメータ:
relationship - 検索する基本モデルの外部キー項目を定義したリレーションシップ
keys - 検索条件
戻り値:
基本モデルのコレクション
例外:
MapperException - 基本モデルの取得に失敗した場合

insert

protected void insert(BaseModel model)
               throws MapperException
基本モデルを1つだけ挿入します。 引数に指定する基本モデルは同一の Mapperの createBaseAccessor(Map) で生成されたものである必要があります。

パラメータ:
model - 挿入するモデル
例外:
MapperException - 基本モデルの挿入に失敗した場合

insert

protected void insert(Collection models)
               throws MapperException
基本モデルを複数挿入します。 引数に指定するものは同一の Mapperの createBaseAccessor(Map) で生成されたアクセサの集合である必要があります。

パラメータ:
models - 挿入する基本モデルの集合
例外:
MapperException - 基本モデルの挿入に失敗した場合

update

protected void update(BaseModel model)
               throws MapperException
基本モデルを1つだけ更新します。 引数に指定するアクセサは同一の Mapperの select 系メソッドから取得されたものか createBaseAccessor(Map) で生成されたものである必要があります。期間が重複するデータが存在する場合、指定したアクセサが最優先されるように期間が調節された上で上書きします。

パラメータ:
model - 更新する基本モデル
例外:
MapperException - 基本モデルの更新に失敗した場合

update

protected void update(Collection models)
               throws MapperException
基本モデルを複数更新します。 引数に指定するものは同一の Mapperの select 系メソッドから取得されたものか createBaseAccessor(Map) で生成された基本モデルの集合である必要があります。

パラメータ:
models - 更新する基本モデルの集合
例外:
MapperException - 基本モデルの更新に失敗した場合

delete

protected void delete(BaseModel model)
               throws MapperException
基本モデルを1つだけ削除します。 引数で指定された基本モデルに該当するデータのすべての期間の情報を削除します。引数に指定する基本モデルは同一の Mapperの select 系メソッド から取得されたものである必要があります。

パラメータ:
model - 削除するアクセサ
例外:
MapperException - 基本モデルの削除に失敗した場合

delete

protected void delete(Collection models)
               throws MapperException
アクセサを複数削除します。 引数で指定されたものに該当するデータのすべての期間の情報を削除します。引数に指定するアクセサは同一の Mapperの select 系メソッド から取得されたアクセサの集合である必要があります。

パラメータ:
models - 削除するアクセサ
例外:
MapperException - 基本モデルの削除に失敗した場合

notifyUpdate

public void notifyUpdate(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が更新された場合に、このメソッドを呼び出してその内容を通知します。 マッパー Mapper は参照先モデルの更新内容と整合性をとるために、それを参照する基本モデルの内容を更新します。

定義:
インタフェース Mapper 内の notifyUpdate
パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

notifyDelete

public void notifyDelete(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が削除された場合にその内容を通知します。 マッパー Mapper は削除されたモデルを参照する基本モデルに対して、整合性を守るための更新を行います。

定義:
インタフェース Mapper 内の notifyDelete
パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

checkByBaseProperty

public void checkByBaseProperty(Relationship[] relationships,
                                BaseModel target,
                                BaseModel base)
                         throws MapperException
基準項目によるリレーションシップの整合性制約をチェックします。 整合性制約違反が存在する場合は、MapperException をスローします。 リレーションシップ Relationship には、基準項目を参照するリレーションシップを参照元とするエンティティ Entity まで たどるためのリレーションシップの集合を設定します。

定義:
インタフェース Mapper 内の checkByBaseProperty
パラメータ:
relationships - リレーションシップの集合
target - 参照先基本モデル
base - 基準項目をもつ基本モデル
例外:
MapperException - 基準項目によるチェックで制約違反があった場合

close

public void close()
           throws MapperException
マッパーをクローズします。 このメソッドはトランザクションが終了される前に必ず呼び出される必要があります。 このメソッドが呼ばれると、マッパーは再利用できなくなります。 また、このマッパーから取得されたモデルの更新もできなくなります。

定義:
インタフェース Mapper 内の close
例外:
MapperException - マッパーがすでにクローズされている場合

getApplicationName

protected abstract String getApplicationName()
マッパーが定義されているアプリケーション名を取得します。

戻り値:
アプリケーション名

getEntityName

protected abstract String getEntityName()
マッパーがアクセスするエンティティ名を取得します。

戻り値:
エンティティ名

isClosed

public boolean isClosed()
マッパーがクローズされているかどうか確認します。

定義:
インタフェース Mapper 内の isClosed
戻り値:
クローズされている場合 true 、そうでなければ false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Mapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース Mapper

既知のサブインタフェースの一覧:
CategoryDetailMapper, CateogryClassMapper, CompanyCategoryMapper, CompanyMapper, CompanyPostMapper, CompanyVersionMapper, DepartmentAttachMapper, DepartmentInclusionMapper, DepartmentMainMapper, DepartmentMapper, PrivateGroupAttachMapper, PrivateGroupMapper, PublicGroupAttachMapper, PublicGroupCategoryMapper, PublicGroupInclusionMapper, PublicGroupMapper, PublicGroupSetMapper, PublicGroupVersionMapper, UserMapper
既知の実装クラスの一覧:
IntramartDBMapper
public interface Mapper

エンティティの情報のマッパーです。 実際に永続化されるデータとJavaのクラスを対応付けます。 一度close()メソッドが呼ばれると、isClosed()以外のメソッドはすべて例外をthrowします。

導入されたバージョン:
5.0

メソッドの概要
void | checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | close() マッパーをクローズします。
BaseModel | createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
void | init(String user, String group) マッパーを初期化します。
boolean | isClosed() マッパーがクローズされているかどうか確認します。
void | notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
BaseModel | select(Map keys) プライマリーキーで特定される基本モデルを取得します。

メソッドの詳細

init

public void init(String user,
                 String group)
          throws MapperException
マッパーを初期化します。 マッパーを生成する場合は、このメソッドを必ず呼び出して下さい。

パラメータ:
user - ログインユーザ
group - ログイングループ名
例外:
MapperException - マッパーの初期化に失敗した場合

createBaseModel

public BaseModel createBaseModel(Map keys)
                          throws MapperException
このマッパーに該当する基本モデルを新規に生成します。 モデルを新規に生成することができるのはこのメソッドだけです。このメソッドで生成されたモデルは次の状態になります。
  • 指定されたプライマリキーが設定済
  • 該当するエンティティが国際化されている場合は、国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
  • 該当するエンティティが期間化されている場合は、期間化モデルが1つだけ存在
    • 有効開始日は期間の最小日時 (1582/10/15)
    • 有効終了日は期間の最大日時 (9999/12/31)
  • 該当するエンティティが期間国際化されている場合は、期間国際化モデルが1つだけ存在
    • ロケールはデフォルトロケール
    • 有効開始日は期間の最小日時 (1582/10/15)
    • 有効終了日は期間の最大日時 (9999/12/31)

    パラメータ:
    keys - 項目名とその値を持つプライマリキーのマップ
    戻り値:
    プライマリキーが設定された基本モデル
    例外:
    MapperException - モデルの生成に失敗した場合

select

public BaseModel select(Map keys)
                 throws MapperException
プライマリーキーで特定される基本モデルを取得します。 取得される基本モデルには、国際化されている場合にはすべての言語情報、期間化されている場合にはすべての期間情報が設定されます。 また、基本モデル BaseModel、国際化モデル InternationalModel、期間化モデル TerminableModel、 期間国際化モデル TerminableInternationalModel にはすべてのプロパティが設定されます。

パラメータ:
keys - 項目名とその値を持つプライマリキーのマップ
戻り値:
基本モデル
例外:
MapperException - 検索で例外が発生した場合

notifyUpdate

public void notifyUpdate(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が更新された場合に、このメソッドを呼び出してその内容を通知します。 マッパー Mapper は参照先モデルの更新内容と整合性をとるために、それを参照する基本モデルの内容を更新します。

パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

notifyDelete

public void notifyDelete(Relationship relationship,
                         BaseModel model)
                  throws MapperException
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。 引数で指定されたリレーションシップ Relationship の参照先基本モデル BaseModel が削除された場合にその内容を通知します。 マッパー Mapper は削除されたモデルを参照する基本モデルに対して、整合性を守るための更新を行います。

パラメータ:
relationship - リレーションシップ
model - 参照先基本モデル
例外:
MapperException - 更新通知先で何らかの例外が発生した場合

checkByBaseProperty

public void checkByBaseProperty(Relationship[] relationships,
                                BaseModel target,
                                BaseModel base)
                         throws MapperException
基準項目によるリレーションシップの整合性制約をチェックします。 リレーションシップ Relationship には、基準項目を参照するリレーションシップを参照元とするエンティティ Entity まで たどるためのリレーションシップの集合を設定します。 基本モデル BaseModel は、基準項目をプロパティにもつ基本モデルを設定します。

パラメータ:
relationships - リレーションシップの集合
target - 参照先基本モデル
base - 基準項目をもつ基本モデル
例外:
MapperException - 基準項目によるチェックで何らかの例外が発生した場合

close

public void close()
           throws MapperException
マッパーをクローズします。 このメソッドはトランザクションが終了される前に必ず呼び出される必要があります。 このメソッドが呼ばれると、マッパーは再利用できなくなります。 また、このマッパーから取得されたモデルの更新もできなくなります。

例外:
MapperException - マッパーがすでにクローズされている場合

isClosed

public boolean isClosed()
マッパーがクローズされているかどうか確認します。

戻り値:
クローズされている場合 true 、そうでなければ false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
クラス MapperFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.model.MapperFactory
public abstract class MapperFactory
extends Object

マッパーを生成します。

導入されたバージョン:
5.0

コンストラクタの概要
MapperFactory()
メソッドの概要
abstract Mapper | createMapper(String application, String entity, String group, String user) マッパーを生成します。
static MapperFactory | newInstance() マッパーファクトリを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MapperFactory

public MapperFactory()
メソッドの詳細

newInstance

public static MapperFactory newInstance()
                                 throws MapperException
マッパーファクトリを取得します。

戻り値:
マッパーファクトリ
例外:
MapperException

createMapper

public abstract Mapper createMapper(String application,
                                    String entity,
                                    String group,
                                    String user)
                             throws MapperException
マッパーを生成します。

パラメータ:
application - マッパーを定義するアプリケーション名
entity - マッパーを定義するエンティティ名
group - ログイングループ名
user - ログインユーザコード
戻り値:
マッパー
例外:
MapperException - マッパーの生成に失敗した時
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.common.model (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.common.model
インタフェース
BaseModel
BaseModelContext
ExtendedBaseModel
ExtendedBaseModelMap
ExtendedInternationalModel
ExtendedInternationalModelMap
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModelMap
ExtendedTerminableModel
ExtendedTerminableModelMap
InternationalModel
InternationalModelContext
InternationalModelMap
Mapper
TerminableInternationalModel
TerminableInternationalModelContext
TerminableInternationalModelMap
TerminableModel
TerminableModelContext
TerminableModelMap
クラス
ExtendedGenericBaseModel
ExtendedGenericBaseModelMap
ExtendedGenericInternationalModel
ExtendedGenericInternationalModelMap
ExtendedGenericTerminableInternationalModel
ExtendedGenericTerminableInternationalModelMap
ExtendedGenericTerminableModel
ExtendedGenericTerminableModelMap
GenericBaseModel
GenericInternationalModel
GenericInternationalModelMap
GenericTerminableInternationalModel
GenericTerminableInternationalModelMap
GenericTerminableModel
GenericTerminableModelMap
IntramartDBMapper
MapperFactory


jp.co.intra_mart.foundation.datastore.common.model (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.model

情報を扱うための、モデルやマッパーを提供します。

参照:
説明

インタフェースの概要
BaseModel | 基本モデルの情報です。
BaseModelContext | 基本モデルの初期化に必要な設定を持ちます。
ExtendedBaseModel | 拡張基本モデルの情報です。
ExtendedBaseModelMap | 拡張基本モデルのマッピング情報を持ちます。
ExtendedInternationalModel | 拡張国際化モデルの情報です。
ExtendedInternationalModelMap | 拡張国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalModel | 拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap | 拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableModel | 拡張期間化モデルの情報です。
ExtendedTerminableModelMap | 拡張期間化モデルのマッピング情報を持ちます。
InternationalModel | 国際化モデルの情報です。
InternationalModelContext | 国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap | 国際化モデルのマッピング情報を持ちます。
Mapper | エンティティの情報のマッパーです。
TerminableInternationalModel | 期間国際化モデルの情報です。
TerminableInternationalModelContext | 期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap | 期間国際化モデルのマッピング情報を持ちます。
TerminableModel | 期間化モデルの情報です。
TerminableModelContext | 期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap | 期間化モデルのマッピング情報を持ちます。

クラスの概要
ExtendedGenericBaseModel | 拡張基本モデルの汎用的な抽象クラスです。
ExtendedGenericBaseModelMap | 拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericInternationalModel | 拡張国際化モデルの汎用的な抽象クラスです。
ExtendedGenericInternationalModelMap | 拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModel | 拡張期間国際化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModelMap | 拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableModel | 拡張期間化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableModelMap | 拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。
GenericBaseModel | 基本モデルの汎用的な抽象クラスです。
GenericInternationalModel | 国際化モデルの汎用的な抽象クラスです。
GenericInternationalModelMap | 国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableInternationalModel | 期間国際化モデルの汎用的な抽象クラスです。
GenericTerminableInternationalModelMap | 期間国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableModel | 期間化モデルの汎用的な抽象クラスです。
GenericTerminableModelMap | 期間化モデルマッピングの汎用的な抽象クラスです。
IntramartDBMapper | intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。
MapperFactory | マッパーを生成します。

パッケージ jp.co.intra_mart.foundation.datastore.common.model の説明

情報を扱うための、モデルやマッパーを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.common.model クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.BaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper (implements jp.co.intra_mart.foundation.datastore.common.model.Mapper)
    • class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory

インタフェース階層

  • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.common.model の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.model の使用

jp.co.intra_mart.foundation.datastore.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
InternationalModel
国際化モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
Mapper
エンティティの情報のマッパーです。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableModel
期間化モデルの情報です。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.model のクラス
BaseModel
基本モデルの情報です。
BaseModelContext
基本モデルの初期化に必要な設定を持ちます。
ExtendedBaseModel
拡張基本モデルの情報です。
ExtendedBaseModelMap
拡張基本モデルのマッピング情報を持ちます。
ExtendedInternationalModel
拡張国際化モデルの情報です。
ExtendedInternationalModelMap
拡張国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalModel
拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap
拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableModel
拡張期間化モデルの情報です。
ExtendedTerminableModelMap
拡張期間化モデルのマッピング情報を持ちます。
InternationalModel
国際化モデルの情報です。
InternationalModelContext
国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap
国際化モデルのマッピング情報を持ちます。
Mapper
エンティティの情報のマッパーです。
MapperFactory
マッパーを生成します。
TerminableInternationalModel
期間国際化モデルの情報です。
TerminableInternationalModelContext
期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap
期間国際化モデルのマッピング情報を持ちます。
TerminableModel
期間化モデルの情報です。
TerminableModelContext
期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap
期間化モデルのマッピング情報を持ちます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


TerminableInternationalModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CompanyPostTerminableInternationalModel, DepartmentTerminableInternationalModel, PublicGroupTerminableInternationalModel, UserTerminableInternationalModel
既知の実装クラスの一覧:
GenericTerminableInternationalModel
public interface TerminableInternationalModel
extends Serializable

期間国際化モデルの情報です。 期間国際化エンティティの1データが期間国際化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
Locale | getLocale() 期間国際化モデルが保持する言語 Locale を取得します。
void | init(TerminableInternationalModelContext context) 期間国際化モデルを初期化します。

メソッドの詳細

init

public void init(TerminableInternationalModelContext context)
期間国際化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 期間国際化モデルコンテキスト

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。

戻り値:
拡張期間国際化モデルマップ

getLocale

public Locale getLocale()
期間国際化モデルが保持する言語 Locale を取得します。 このメソッドをオーバーライドすると言語を取得することが出来なくなります。

戻り値:
言語
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModelContext (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModelContext

public interface TerminableInternationalModelContext

期間国際化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableInternationalModelMap | getExtendedTerminableInternationalModelMap() 拡張期間国際化モデルマップを取得します。
TerminableInternationalAccessor | getTerminableInternationalAccessor() 期間国際化アクセサを取得します。
void | setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap) 拡張期間国際化モデルマップを設定します。
void | setTerminableInternationalAccessor(TerminableInternationalAccessor accessor) 期間国際化アクセサを設定します。

メソッドの詳細

setTerminableInternationalAccessor

public void setTerminableInternationalAccessor(TerminableInternationalAccessor accessor)
期間国際化アクセサを設定します。

パラメータ:
accessor - 期間国際化アクセサ

getTerminableInternationalAccessor

public TerminableInternationalAccessor getTerminableInternationalAccessor()
期間国際化アクセサを取得します。

戻り値:
期間国際化アクセサ

setExtendedTerminableInternationalModelMap

public void setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap extendedMap)
拡張期間国際化モデルマップを設定します。

パラメータ:
extendedMap - 拡張期間国際化モデルマップ

getExtendedTerminableInternationalModelMap

public ExtendedTerminableInternationalModelMap getExtendedTerminableInternationalModelMap()
拡張期間国際化モデルマップを取得します。

戻り値:
拡張期間国際化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableInternationalModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableInternationalModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericTerminableInternationalModelMap
public interface TerminableInternationalModelMap
extends Serializable

期間国際化モデルのマッピング情報を持ちます。 システムで定義された言語に対応する情報のみを持ちます。

導入されたバージョン:
5.0

メソッドの概要
TerminableInternationalModel | createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
boolean | exists(Locale locale) 指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
TerminableInternationalModel | findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
Locale[] | getLocales() マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。
void | remove(Locale locale) 指定された言語に該当するデータを削除します。

メソッドの詳細

createTerminableInternationalModel

public TerminableInternationalModel createTerminableInternationalModel(Locale locale)
                                                                throws AccessorException
期間国際化モデルを生成します。 引数で指定された言語に該当する既存の情報は新しい情報で上書きされます。 システムで取り扱う言語のみが対象となります。

パラメータ:
locale - 言語
戻り値:
期間国際化モデル
例外:
AccessorException - システムで使用することができない言語が指定された場合

exists

public boolean exists(Locale locale)
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。

パラメータ:
locale - 言語
戻り値:
対象となる期間国際化モデルが存在する場合 true、それ以外は false

findTerminableInternationalModel

public TerminableInternationalModel findTerminableInternationalModel(Locale locale)
                                                              throws IllegalLocaleException
指定された言語に該当する期間国際化モデルを取得します。 引数 locale で指定された言語に該当する TerminableInternationalModelを取得します。該当するものが存在しない場合、 null が返されます。

パラメータ:
locale - 対象となる言語
戻り値:
対象となる期間国際化モデル（存在しない場合は null）
例外:
IllegalLocaleException - 言語に関する例外が発生した場合

getLocales

public Locale[] getLocales()
マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。

戻り値:
言語の一覧

remove

public void remove(Locale locale)
            throws AccessorException
指定された言語に該当するデータを削除します。

パラメータ:
locale - 削除対象の言語
例外:
AccessorException - アクセサで何らかの例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModel

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
CompanyCategoryTerminableModel, CompanyPostTerminableModel, DepartmentAttachTerminableModel, DepartmentMainTerminableModel, DepartmentTerminableModel, PublicGroupAttachTerminableModel, PublicGroupCategoryTerminableModel, PublicGroupTerminableModel, UserTerminableModel
既知の実装クラスの一覧:
GenericTerminableModel
public interface TerminableModel
extends Serializable

期間化モデルの情報です。 期間化エンティティの1データが期間化モデルの1インスタンスに対応します。

導入されたバージョン:
5.0

メソッドの概要
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
Term | getTerm() 期間化モデルが保持する期間 Term を取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルを取得します。
void | init(TerminableModelContext context) 期間化モデルを初期化します。

メソッドの詳細

init

public void init(TerminableModelContext context)
期間化モデルを初期化します。 このメソッドはシステム内でマッパから使用されます。明示的に使用しないでください。

パラメータ:
context - 期間化モデルコンテキスト

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルを取得します。 この期間モデルに関連する期間国際化モデルの集合を取得します。

戻り値:
期間国際化モデルの集合

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。

戻り値:
拡張期間化モデルマップ

getTerm

public Term getTerm()
期間化モデルが保持する期間 Term を取得します。 このメソッドをオーバーライドすると期間を取得できなくなります。

戻り値:
期間
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModelContext (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModelContext

public interface TerminableModelContext

期間化化モデルの初期化に必要な設定を持ちます。

導入されたバージョン:
5.0

メソッドの概要
Locale | getDefaultLocale() デフォルト言語を取得します。
ExtendedTerminableModelMap | getExtendedTerminableModelMap() 拡張期間化モデルマップを取得します。
TerminableAccessor | getTerminableAccessor() 期間化アクセサを取得します。
TerminableInternationalModelMap | getTerminableInternationalModelMap() 期間国際化モデルマップを取得します。
void | setDefaultLocale(Locale locale) デフォルト言語を設定します。
void | setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap) 拡張期間化モデルマップを設定します。
void | setTerminableAccessor(TerminableAccessor accessor) 期間化アクセサを設定します。
void | setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap) 期間国際化モデルマップを設定します。

メソッドの詳細

setTerminableAccessor

public void setTerminableAccessor(TerminableAccessor accessor)
期間化アクセサを設定します。

パラメータ:
accessor - 期間化アクセサ

getTerminableAccessor

public TerminableAccessor getTerminableAccessor()
期間化アクセサを取得します。

戻り値:
期間化アクセサ

setDefaultLocale

public void setDefaultLocale(Locale locale)
デフォルト言語を設定します。

パラメータ:
locale - 言語

getDefaultLocale

public Locale getDefaultLocale()
デフォルト言語を取得します。

戻り値:
言語

setTerminableInternationalModelMap

public void setTerminableInternationalModelMap(TerminableInternationalModelMap terminableInternationalMap)
期間国際化モデルマップを設定します。

パラメータ:
terminableInternationalMap - 期間国際化モデルマップ

getTerminableInternationalModelMap

public TerminableInternationalModelMap getTerminableInternationalModelMap()
期間国際化モデルマップを取得します。

戻り値:
期間国際化モデルマップ

setExtendedTerminableModelMap

public void setExtendedTerminableModelMap(ExtendedTerminableModelMap extendedMap)
拡張期間化モデルマップを設定します。

パラメータ:
extendedMap - 拡張期間化モデルマップ

getExtendedTerminableModelMap

public ExtendedTerminableModelMap getExtendedTerminableModelMap()
拡張期間化モデルマップを取得します。

戻り値:
拡張期間化モデルマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TerminableModelMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.model
インタフェース TerminableModelMap

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
GenericTerminableModelMap
public interface TerminableModelMap
extends Serializable

期間化モデルのマッピング情報を持ちます。 期間が変更された場合などは自動的に期間情報が重複しないように調整されます。

導入されたバージョン:
5.0

メソッドの概要
TerminableModel | createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
boolean | exists(Date date) 指定された日付を含む期間化モデルが存在するかどうか判定します。
TerminableModel | findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
Term[] | getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
void | remove(Term term) 指定された期間に該当するデータを削除します。

メソッドの詳細

createTerminableModel

public TerminableModel createTerminableModel(Term term)
                                      throws AccessorException
指定した期間を満たす期間化モデルを生成します。 指定した期間に期間化アクセサを生成します。 生成した期間化アクセサによって重複する期間が発生する場合、例外を返す

パラメータ:
term - 期間
戻り値:
期間化モデル
例外:
AccessorException - アクセサで何らかの例外が発生した場合

exists

public boolean exists(Date date)
指定された日付を含む期間化モデルが存在するかどうか判定します。

パラメータ:
date - 日付
戻り値:
指定された日付を含む期間化モデルが存在する場合は true、それ以外は false

findTerminableModel

public TerminableModel findTerminableModel(Date date)
                                    throws IllegalTermException
指定された日付に該当する期間化モデルを取得します。 引数 date で指定された日付を期間内に含む TerminableModel を取得します。該当するものが存在しない場合、例外を返します

パラメータ:
date - 対象となる日付
戻り値:
対象となる期間化モデル
例外:
IllegalTermException - 指定された日時に該当するモデルが存在しない場合

remove

public void remove(Term term)
            throws AccessorException
指定された期間に該当するデータを削除します。 削除対象の期間に該当するデータがなくなるよう、既存のデータの有効開始日時や有効終了日時は調整されます。

パラメータ:
term - 削除対象の期間
例外:
AccessorException - アクセサで何らかの例外が発生した場合

getTerms

public Term[] getTerms()
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。 取得される期間は時系列でソートされています。

戻り値:
期間の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.common.structure.Term の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.structure.Term の使用

Term を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
abstract void | CompanyManager.copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
void | CompanyChangedListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
 Term[] DepartmentAttach.getTerms()
この組織所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.attach のメソッド
DepartmentAttachTerminable | DepartmentAttach.getDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | DepartmentAttach.putDepartmentAttachTerminable(Term term, DepartmentAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | DepartmentAttach.removeDepartmentAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
 Term[] CompanyCategory.getTerms()
この会社組織分類で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.category のメソッド
CompanyCategoryTerminable | CompanyCategory.getCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | CompanyCategory.putCompanyCategoryTerminable(Term term, CompanyCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | CompanyCategory.removeCompanyCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
 Term[] Company.getTerms()
この会社で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.company のメソッド
CompanyTerminable | Company.getCompanyTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Company.putCompanyTerminable(Term term, CompanyTerminable data) 指定された期間に対する期間化情報を設定します。
void | Company.removeCompanyTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
 Term[] Department.getTerms()
この組織で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.department のメソッド
DepartmentTerminable | Department.getDepartmentTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | Department.putDepartmentTerminable(Term term, DepartmentTerminable data) 指定された期間に対する期間化情報を設定します。
void | Department.removeDepartmentTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
 Term[] DepartmentMain.getTerms()
この主所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.main のメソッド
DepartmentMainTerminable | DepartmentMain.getDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | DepartmentMain.putDepartmentMainTerminable(Term term, DepartmentMainTerminable data) 指定された期間に対する期間化情報を設定します。
void | DepartmentMain.removeDepartmentMainTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
 Term[] CompanyPost.getTerms()
この役職で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.company.post のメソッド
CompanyPostTerminable | CompanyPost.getCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | CompanyPost.putCompanyPostTerminable(Term term, CompanyPostTerminable data) 指定された期間に対する期間化情報を設定します。
void | CompanyPost.removeCompanyPostTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
abstract void | PublicGroupManager.copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
void | PublicGroupChangedListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
 Term[] PublicGroupAttach.getTerms()
このパブリックグループ所属で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach のメソッド
PublicGroupAttachTerminable | PublicGroupAttach.getPublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupAttach.putPublicGroupAttachTerminable(Term term, PublicGroupAttachTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupAttach.removePublicGroupAttachTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
 Term[] PublicGroupCategory.getTerms()
このパブリックグループ分類で管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category のメソッド
PublicGroupCategoryTerminable | PublicGroupCategory.getPublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupCategory.putPublicGroupCategoryTerminable(Term term, PublicGroupCategoryTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupCategory.removePublicGroupCategoryTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
 Term[] PublicGroup.getTerms()
このパブリックグループで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group のメソッド
PublicGroupTerminable | PublicGroup.getPublicGroupTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroup.putPublicGroupTerminable(Term term, PublicGroupTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroup.removePublicGroupTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
 Term[] PublicGroupSet.getTerms()
このパブリックグループセットで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set のメソッド
PublicGroupSetTerminable | PublicGroupSet.getPublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | PublicGroupSet.putPublicGroupSetTerminable(Term term, PublicGroupSetTerminable data) 指定された期間に対する期間化情報を設定します。
void | PublicGroupSet.removePublicGroupSetTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.user での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
 Term[] User.getTerms()
このユーザで管理している期間をすべて取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
UserTerminable | User.getUserTerminable(Term term) 指定された期間に対する期間化情報を取得します。
void | User.putUserTerminable(Term term, UserTerminable data) 指定された期間に対する期間化情報を設定します。
void | User.removeUserTerminable(Term term) 指定された期間に対する期間化情報を削除します。

jp.co.intra_mart.foundation.datastore.common.accessor での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
Term[] | TerminableAccessorMap.getTerms() 現在管理している期間の一覧を取得します。
Term | TerminableAccessor.getTerm() 期間を取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
Map | TerminableAccessorMap.remove(Term term) 指定された期間に該当するデータを削除します。

jp.co.intra_mart.foundation.datastore.common.model での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.model のメソッド
Term[] | TerminableModelMap.getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
Term | TerminableModel.getTerm() 期間化モデルが保持する期間 Term を取得します。
Term[] | GenericTerminableModelMap.getTerms() マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
Term | GenericTerminableModel.getTerm() 期間化モデルが保持する期間 Term を取得します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | TerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | GenericTerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.newTerminableModel(Term term) 初期化されていない期間化モデルのインスタンスを取得します。

jp.co.intra_mart.foundation.datastore.common.structure での Term の使用

Term を返す jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

Term 型のパラメータを持つ jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static void | TermManager.validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

jp.co.intra_mart.foundation.security.menu での Term の使用

Term 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | PublicGroupChangedMenuListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.common.structure.TermManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.common.structure.TermManager の使用

jp.co.intra_mart.foundation.datastore.common.structure.TermManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.datastore.common.structure (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.common.structure
クラス
Term
TermManager


jp.co.intra_mart.foundation.datastore.common.structure (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.structure

期間情報などを扱うクラスを提供します。

参照:
説明

クラスの概要
Term | 有効期間を表します。
TermManager | 期間 Term を取り扱うマネージャクラスです。

パッケージ jp.co.intra_mart.foundation.datastore.common.structure の説明

期間情報などを扱うクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.common.structure クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.common.structure の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.datastore.common.structure.Term (implements java.lang.Comparable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.structure.TermManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.common.structure の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.common.structure の使用

jp.co.intra_mart.foundation.datastore.common.structure を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.attach により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.category により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.company により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.department により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.main により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.company.post により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.category により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.group により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.public_group.set により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.datastore.common.structure により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.datastore.common.structure のクラス
Term
有効期間を表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Term (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.structure
クラス Term

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.structure.Term
すべての実装インタフェース:
Comparable, Serializable
public class Term
extends Object
implements Comparable, Serializable

有効期間を表します。 有効期間は開始時間と終了時間から構成されます。次の式を満たす範囲が有効期間として認められます。

開始時間 ≤ 有効期間 < 終了時間

また、開始時間と終了時間は常に次の関係である必要があります。

開始時間 < 終了時間

設定された開始時間および終了時間の時刻は、00:00:00 に切り捨てられます。
ただし、終了時刻に有効最大日時 (9999/12/31|23:59:59) が設定された場合は切り捨ては行いません。

なお、システムで有効な最小日時は以下のAPIで取得することができます。
  • getMinDate()
  • DateUtil.getMinDate()
システムで有効な最大日時は以下のAPIで取得することができます。
  • getMaxDate()
  • DateUtil.getMaxDate()

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
Term()
開始時間、終了時間とも指定されていない有効期間を生成します。
Term(Date activation)
開始時間のみが指定された有効期間を生成します。
Term(Date activation, Date expiration)
開始時間と終了時間がともに指定された有効期間を生成します。
メソッドの概要
int | compareTo(Object o) この期間と指定された期間を比較します。
boolean | containsDate(Date date) 指定された日時が期間内に入っているかどうかを指定します。
boolean | equals(Object obj) この有効期間と他の有効期間が等しいかどうかを示します。
Date | getActivationDate() 開始時間を取得します。
Date | getExpirationDate() 終了時間を取得します。
static Date | getMaxDate() システムで設定できる期間の最大日時を取得します。
static Date | getMinDate() システムで設定できる期間の最小日時を取得します。
int | hashCode() 有効期間のハッシュコード値を返します。
String | toString() オブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Term

public Term()
開始時間、終了時間とも指定されていない有効期間を生成します。 このコンストラクタで指定された有効期間は常に有効であることを意味します。

Term

public Term(Date activation)
開始時間のみが指定された有効期間を生成します。 終了時間が定義されていないため、終了日時には期間の最大日付が設定されます

パラメータ:
activation - 有効開始時間
例外:
IllegalArgumentException - 指定された開始時間が期間の最小日時、最大日時に含まれる日付でないとき発生する
NullPointerException - 有効開始時間が null

Term

public Term(Date activation,
            Date expiration)
     throws IllegalArgumentException
開始時間と終了時間がともに指定された有効期間を生成します。 開始時間と終了時間をともに設定する場合、以下の式を満たす必要があります。

開始時間 ≤ 終了時間

パラメータ:
activation - 有効期間の開始時間
expiration - 有効期間の終了時間
例外:
IllegalArgumentException - 開始時間が終了時間よりも後
NullPointerException - 有効開始時間または有効終了時間が null
メソッドの詳細

getActivationDate

public Date getActivationDate()
開始時間を取得します。

戻り値:
開始時間

getExpirationDate

public Date getExpirationDate()
終了時間を取得します。

戻り値:
終了時間

getMinDate

public static Date getMinDate()
システムで設定できる期間の最小日時を取得します。

戻り値:
期間の最小日時

getMaxDate

public static Date getMaxDate()
システムで設定できる期間の最大日時を取得します。

戻り値:
期間の最大日時

containsDate

public boolean containsDate(Date date)
                     throws NullPointerException,
                            IllegalArgumentException
指定された日時が期間内に入っているかどうかを指定します。

パラメータ:
date - 日時
戻り値:
指定された日時が期間内に入っている場合は true 、そうでなければ false
例外:
NullPointerException - 指定された日付が null
IllegalArgumentException - 不正な日付が設定された場合

compareTo

public int compareTo(Object o)
              throws ClassCastException,
                     IllegalArgumentException
この期間と指定された期間を比較します。 比較する期間どうしは完全に一致するか、少しも重なっていないかのいずれかである必要があります。期間の一部のみが重なっていたり、一方が他方の期間を包含している場合は例外が発生します。

定義:
インタフェース Comparable 内の compareTo
パラメータ:
o - 比較対照の期間（ Term）
戻り値:
この期間が引数で指定された期間より過去である場合は負の整数、等しい場合はゼロ、この期間が引数で指定された期間より未来である場合は正の整数
例外:
ClassCastException - 指定された期間が Termではない
IllegalArgumentException - 指定された期間の一部が重なっている、または一方が他方を包含している

equals

public boolean equals(Object obj)
この有効期間と他の有効期間が等しいかどうかを示します。 開始時間と終了時間がそれぞれの有効期間において完全に一致している場合、有効期間が等しいとみなされます。

パラメータ:
obj - 比較対象の有効期間
戻り値:
obj 引数に指定された有効期間とこの有効期間が等しい場合は true 、そうでない場合は false

hashCode

public int hashCode()
有効期間のハッシュコード値を返します。

戻り値:
有効期間のハッシュコード値

toString

public String toString()
オブジェクトの文字列表現を返します。
有効開始時間と有効終了時間をそれぞれ DateUtil.dateToString(Date) で変換した String を、半角ハイフン(-)で連結した文字列を返します。 つまり、このメソッドは次の値と等しい文字列を返します。

DateUtil.dateToString(getActivationDate()) + " - " + DateUtil.dateToString(getExpirationDate())

戻り値:
このオブジェクトの文字列表現
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TermManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.common.structure
クラス TermManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.datastore.common.structure.TermManager
public class TermManager
extends Object

期間 Term を取り扱うマネージャクラスです。

導入されたバージョン:
5.0

メソッドの概要
static Date | getMaxDate() システムで設定できる期間の最大日時を取得します。
static Date | getMinDate() システムで設定できる期間の最小日時を取得します。
static Term[] | getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。
static Term[] | subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static void | validateTerm(Date activation, Date expiration) 指定された2つの日時が有効な期間を構成するかどうか調べます。
static void | validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

validateTerm

public static void validateTerm(Date activation,
                                Date expiration)
                         throws TermManagerException
指定された2つの日時が有効な期間を構成するかどうか調べます。
指定された日時が有効な期間を構成しない場合は TermManagerException 例外をスローします。

パラメータ:
activation - 有効開始日時
expiration - 有効終了日時
例外:
TermManagerException - 指定された日時が有効な期間を構成しない場合

validateTerms

public static void validateTerms(Term[] terms)
                          throws TermManagerException
指定された期間配列が有効かどうかを調べます。
指定された期間配列が有効ではない場合はTermManagerException 例外をスローします。
期間配列は以下の場合に有効でないと判定されます。
  • 期間配列にnullの要素が含まれている場合
  • 期間が互いに重なる要素が含まれている場合

パラメータ:
terms - 期間の配列
例外:
TermManagerException - 指定された期間配列が有効でない場合

getMinDate

public static Date getMinDate()
システムで設定できる期間の最小日時を取得します。 取得される値は Term.getMinDate() で取得される値と同じです。

戻り値:
期間の最小日時

getMaxDate

public static Date getMaxDate()
システムで設定できる期間の最大日時を取得します。 取得される値は Term.getMaxDate() で取得される値と同じです。

戻り値:
期間の最大日時

subtract

public static Term[] subtract(Term[] term1,
                              Term[] term2)
                       throws TermManagerException
期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
差し引かれる期間が存在しない場合は空の配列を返します。
期間配列 term1 または term2 が null の場合も、空の配列を返します。

パラメータ:
term1 - 期間
term2 - 期間
戻り値:
term1 と term2 の差分となる期間
例外:
TermManagerException - 指定された期間配列内に期間に重複が存在する場合

getOverlap

public static Term[] getOverlap(Term[] term1,
                                Term[] term2)
                         throws TermManagerException
2つの期間配列 term1 と term2 で重なっている期間を返します。
期間に重なりが存在しない場合は空の配列を返します。
期間配列 term1 または term2 が null の場合も、空の配列を返します。

パラメータ:
term1 - 期間
term2 - 期間
戻り値:
互いに重なっている期間
例外:
TermManagerException - 指定された期間配列内に期間に重複が存在する場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException の使用

AccessorClosedException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor 情報を扱うためのアクセサを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での AccessorClosedException の使用

AccessorClosedException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
void | TerminableInternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
void | TerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
TerminableAccessor | TerminableAccessorMap.createTerminableAccessor(Term term) 指定した期間に期間化アクセサを生成します。
Map | TerminableAccessorMap.remove(Term term) 指定された期間に該当するデータを削除します。
void | TerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
void | InternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
void | InternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
void | ExtendedTerminableInternationalAccessorMap.remove(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。
void | ExtendedTerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
void | ExtendedTerminableAccessorMap.remove(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。
void | ExtendedTerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
void | ExtendedInternationalAccessorMap.remove(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。
void | ExtendedInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
void | ExtendedBaseAccessorMap.remove(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。
void | ExtendedBaseAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | BaseAccessor.setProperty(String prop, Object value) プロパティを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorException の使用

AccessorException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
String | CateogryClassInternationalModel.getName() 分類区分名を取得します。
void | CateogryClassInternationalModel.setName(String name) 分類区分名を設定します。
String | CateogryClassBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CateogryClassBaseModel.getNotes() 備考を取得します。
void | CateogryClassBaseModel.setNotes(String notes) 備考を設定します。
String | CateogryClassBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CateogryClassBaseModel.getRecordDate() 最終更新日を取得します。
String | CateogryClassBaseModel.getName() 分類区分名を取得します。
String | CateogryClassBaseModel.getName(Locale locale) 分類区分名を取得します。
void | CateogryClassBaseModel.setName(String name) 分類区分名を設定します。
void | CateogryClassBaseModel.setName(String name, Locale locale) 分類区分名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
String | CategoryDetailInternationalModel.getName() 分類名を取得します。
void | CategoryDetailInternationalModel.setName(String name) 分類名を設定します。
String | CategoryDetailBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CategoryDetailBaseModel.getCategoryCode() 分類コードを取得します。
String | CategoryDetailBaseModel.getNotes() 備考を取得します。
void | CategoryDetailBaseModel.setNotes(String notes) 備考を設定します。
String | CategoryDetailBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CategoryDetailBaseModel.getRecordDate() 最終更新日を取得します。
String | CategoryDetailBaseModel.getName() 分類名を取得します。
String | CategoryDetailBaseModel.getName(Locale locale) 分類名を取得します。
void | CategoryDetailBaseModel.setName(String name) 分類名を設定します。
void | CategoryDetailBaseModel.setName(String name, Locale locale) 分類名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
String | DepartmentAttachTerminableModel.getPostCode() 役職CDを取得します。
void | DepartmentAttachTerminableModel.setPostCode(String postCode) 役職CDを設定します。
String | DepartmentAttachBaseModel.getUserCode() ユーザコードを取得します。
String | DepartmentAttachBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentAttachBaseModel.getDepartmentCode() 組織コードを取得します。
int | DepartmentAttachBaseModel.getSortKey() ソートキーを取得します。
void | DepartmentAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | DepartmentAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentAttachBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentAttachBaseModel.getPostCode() 役職CDを取得します。
String | DepartmentAttachBaseModel.getPostCode(Date date) 役職CDを取得します。
void | DepartmentAttachBaseModel.setPostCode(String postCode) 役職CDを設定します。
void | DepartmentAttachBaseModel.setPostCode(String postCode, Date date) 役職CDを設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
String | CompanyCategoryBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyCategoryBaseModel.getDepartmentCode() 組織コードを取得します。
String | CompanyCategoryBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | CompanyCategoryBaseModel.getCategoryCode() 分類コードを取得します。
String | CompanyCategoryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyCategoryBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
String | CompanyBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
String | DepartmentTerminableModel.getTelephoneNumber() 電話番号を取得します。
void | DepartmentTerminableModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
String | DepartmentTerminableModel.getFaxNumber() FAX番号を取得します。
void | DepartmentTerminableModel.setFaxNumber(String faxNumber) FAX番号を設定します。
String | DepartmentTerminableModel.getExtensionNumber() 内線番号を取得します。
void | DepartmentTerminableModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
String | DepartmentTerminableModel.getExtensionFaxNumber() 内線FAX番号を取得します。
void | DepartmentTerminableModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
String | DepartmentTerminableModel.getCountryCode() 国コードを取得します。
void | DepartmentTerminableModel.setCountryCode(String countryCode) 国コードを設定します。
String | DepartmentTerminableModel.getZipCode() 郵便番号を取得します。
void | DepartmentTerminableModel.setZipCode(String zipCode) 郵便番号を設定します。
String | DepartmentTerminableModel.getEmailAddress1() メールアドレス1を取得します。
void | DepartmentTerminableModel.setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
String | DepartmentTerminableModel.getEmailAddress2() メールアドレス2を取得します。
void | DepartmentTerminableModel.setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
String | DepartmentTerminableModel.getUrl() URLを取得します。
void | DepartmentTerminableModel.setUrl(String url) URLを設定します。
String | DepartmentTerminableModel.getName() 組織名を取得します。
String | DepartmentTerminableModel.getName(Locale locale) 組織名を取得します。
void | DepartmentTerminableModel.setName(String name) 組織名を設定します。
void | DepartmentTerminableModel.setName(String name, Locale locale) 組織名を設定します。
String | DepartmentTerminableModel.getNameSyllabary() 組織名カナを取得します。
String | DepartmentTerminableModel.getNameSyllabary(Locale locale) 組織名カナを取得します。
void | DepartmentTerminableModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | DepartmentTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
String | DepartmentTerminableModel.getNameEnglish() 組織名英字を取得します。
String | DepartmentTerminableModel.getNameEnglish(Locale locale) 組織名英字を取得します。
void | DepartmentTerminableModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | DepartmentTerminableModel.setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
String | DepartmentTerminableModel.getAddress1() 住所1を取得します。
String | DepartmentTerminableModel.getAddress1(Locale locale) 住所1を取得します。
void | DepartmentTerminableModel.setAddress1(String address1) 住所1を設定します。
void | DepartmentTerminableModel.setAddress1(String address1, Locale locale) 住所1を設定します。
String | DepartmentTerminableModel.getAddress2() 住所2を取得します。
String | DepartmentTerminableModel.getAddress2(Locale locale) 住所2を取得します。
void | DepartmentTerminableModel.setAddress2(String address2) 住所2を設定します。
void | DepartmentTerminableModel.setAddress2(String address2, Locale locale) 住所2を設定します。
String | DepartmentTerminableInternationalModel.getName() 組織名を取得します。
void | DepartmentTerminableInternationalModel.setName(String name) 組織名を設定します。
String | DepartmentTerminableInternationalModel.getNameSyllabary() 組織名カナを取得します。
void | DepartmentTerminableInternationalModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
String | DepartmentTerminableInternationalModel.getNameEnglish() 組織名英字を取得します。
void | DepartmentTerminableInternationalModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
String | DepartmentTerminableInternationalModel.getAddress1() 住所1を取得します。
void | DepartmentTerminableInternationalModel.setAddress1(String address1) 住所1を設定します。
String | DepartmentTerminableInternationalModel.getAddress2() 住所2を取得します。
void | DepartmentTerminableInternationalModel.setAddress2(String address2) 住所2を設定します。
String | DepartmentBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentBaseModel.getDepartmentCode() 組織コードを取得します。
String | DepartmentBaseModel.getNotes() 備考を取得します。
void | DepartmentBaseModel.setNotes(String notes) 備考を設定します。
int | DepartmentBaseModel.getSortKey() ソートキーを取得します。
void | DepartmentBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | DepartmentBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentBaseModel.getTelephoneNumber() 電話番号を取得します。
String | DepartmentBaseModel.getTelephoneNumber(Date date) 電話番号を取得します。
void | DepartmentBaseModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | DepartmentBaseModel.setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
String | DepartmentBaseModel.getFaxNumber() FAX番号を取得します。
String | DepartmentBaseModel.getFaxNumber(Date date) FAX番号を取得します。
void | DepartmentBaseModel.setFaxNumber(String faxNumber) FAX番号を設定します。
void | DepartmentBaseModel.setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
String | DepartmentBaseModel.getExtensionNumber() 内線番号を取得します。
String | DepartmentBaseModel.getExtensionNumber(Date date) 内線番号を取得します。
void | DepartmentBaseModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | DepartmentBaseModel.setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
String | DepartmentBaseModel.getExtensionFaxNumber() 内線FAX番号を取得します。
String | DepartmentBaseModel.getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
void | DepartmentBaseModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | DepartmentBaseModel.setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
String | DepartmentBaseModel.getCountryCode() 国コードを取得します。
String | DepartmentBaseModel.getCountryCode(Date date) 国コードを取得します。
void | DepartmentBaseModel.setCountryCode(String countryCode) 国コードを設定します。
void | DepartmentBaseModel.setCountryCode(String countryCode, Date date) 国コードを設定します。
String | DepartmentBaseModel.getZipCode() 郵便番号を取得します。
String | DepartmentBaseModel.getZipCode(Date date) 郵便番号を取得します。
void | DepartmentBaseModel.setZipCode(String zipCode) 郵便番号を設定します。
void | DepartmentBaseModel.setZipCode(String zipCode, Date date) 郵便番号を設定します。
String | DepartmentBaseModel.getEmailAddress1() メールアドレス1を取得します。
String | DepartmentBaseModel.getEmailAddress1(Date date) メールアドレス1を取得します。
void | DepartmentBaseModel.setEmailAddress1(String emailAddress1) メールアドレス1を設定します。
void | DepartmentBaseModel.setEmailAddress1(String emailAddress1, Date date) メールアドレス1を設定します。
String | DepartmentBaseModel.getEmailAddress2() メールアドレス2を取得します。
String | DepartmentBaseModel.getEmailAddress2(Date date) メールアドレス2を取得します。
void | DepartmentBaseModel.setEmailAddress2(String emailAddress2) メールアドレス2を設定します。
void | DepartmentBaseModel.setEmailAddress2(String emailAddress2, Date date) メールアドレス2を設定します。
String | DepartmentBaseModel.getUrl() URLを取得します。
String | DepartmentBaseModel.getUrl(Date date) URLを取得します。
void | DepartmentBaseModel.setUrl(String url) URLを設定します。
void | DepartmentBaseModel.setUrl(String url, Date date) URLを設定します。
String | DepartmentBaseModel.getName() 組織名を取得します。
String | DepartmentBaseModel.getName(Date date) 組織名を取得します。
String | DepartmentBaseModel.getName(Locale locale) 組織名を取得します。
String | DepartmentBaseModel.getName(Date date, Locale locale) 組織名を取得します。
void | DepartmentBaseModel.setName(String name) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Date date) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Locale locale) 組織名を設定します。
void | DepartmentBaseModel.setName(String name, Date date, Locale locale) 組織名を設定します。
String | DepartmentBaseModel.getNameSyllabary() 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Date date) 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Locale locale) 組織名カナを取得します。
String | DepartmentBaseModel.getNameSyllabary(Date date, Locale locale) 組織名カナを取得します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Date date) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) 組織名カナを設定します。
void | DepartmentBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) 組織名カナを設定します。
String | DepartmentBaseModel.getNameEnglish() 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Date date) 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Locale locale) 組織名英字を取得します。
String | DepartmentBaseModel.getNameEnglish(Date date, Locale locale) 組織名英字を取得します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Date date) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Locale locale) 組織名英字を設定します。
void | DepartmentBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) 組織名英字を設定します。
String | DepartmentBaseModel.getAddress1() 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Date date) 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Locale locale) 住所1を取得します。
String | DepartmentBaseModel.getAddress1(Date date, Locale locale) 住所1を取得します。
void | DepartmentBaseModel.setAddress1(String address1) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Date date) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Locale locale) 住所1を設定します。
void | DepartmentBaseModel.setAddress1(String address1, Date date, Locale locale) 住所1を設定します。
String | DepartmentBaseModel.getAddress2() 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Date date) 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Locale locale) 住所2を取得します。
String | DepartmentBaseModel.getAddress2(Date date, Locale locale) 住所2を取得します。
void | DepartmentBaseModel.setAddress2(String address2) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Date date) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Locale locale) 住所2を設定します。
void | DepartmentBaseModel.setAddress2(String address2, Date date, Locale locale) 住所2を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
String | DepartmentInclusionBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentInclusionBaseModel.getVersionCode() バージョンコードを取得します。
String | DepartmentInclusionBaseModel.getParentDepartmentCode() 親組織コードを取得します。
String | DepartmentInclusionBaseModel.getDepartmentCode() 組織コードを取得します。
int | DepartmentInclusionBaseModel.getDepth() 階層レベルを取得します。
void | DepartmentInclusionBaseModel.setDepth(int depth) 階層レベルを設定します。
String | DepartmentInclusionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentInclusionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
String | DepartmentMainTerminableModel.getCompanyCode() 会社コードを取得します。
void | DepartmentMainTerminableModel.setCompanyCode(String companyCode) 会社コードを設定します。
String | DepartmentMainTerminableModel.getDepartmentCode() 組織コードを取得します。
void | DepartmentMainTerminableModel.setDepartmentCode(String departmentCode) 組織コードを設定します。
String | DepartmentMainBaseModel.getUserCode() ユーザコードを取得します。
String | DepartmentMainBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | DepartmentMainBaseModel.getRecordDate() 最終更新日を取得します。
String | DepartmentMainBaseModel.getCompanyCode() 会社コードを取得します。
String | DepartmentMainBaseModel.getCompanyCode(Date date) 会社コードを取得します。
void | DepartmentMainBaseModel.setCompanyCode(String companyCode) 会社コードを設定します。
void | DepartmentMainBaseModel.setCompanyCode(String companyCode, Date date) 会社コードを設定します。
String | DepartmentMainBaseModel.getDepartmentCode() 組織コードを取得します。
String | DepartmentMainBaseModel.getDepartmentCode(Date date) 組織コードを取得します。
void | DepartmentMainBaseModel.setDepartmentCode(String departmentCode) 組織コードを設定します。
void | DepartmentMainBaseModel.setDepartmentCode(String departmentCode, Date date) 組織コードを設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
String | CompanyPostTerminableModel.getName() 役職名を取得します。
String | CompanyPostTerminableModel.getName(Locale locale) 役職名を取得します。
void | CompanyPostTerminableModel.setName(String name) 役職名を設定します。
void | CompanyPostTerminableModel.setName(String name, Locale locale) 役職名を設定します。
String | CompanyPostTerminableInternationalModel.getName() 役職名を取得します。
void | CompanyPostTerminableInternationalModel.setName(String name) 役職名を設定します。
String | CompanyPostBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyPostBaseModel.getPostCode() 役職コードを取得します。
String | CompanyPostBaseModel.getNotes() 備考を取得します。
void | CompanyPostBaseModel.setNotes(String notes) 備考を設定します。
int | CompanyPostBaseModel.getSortKey() ソートキーを取得します。
void | CompanyPostBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | CompanyPostBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyPostBaseModel.getRecordDate() 最終更新日を取得します。
String | CompanyPostBaseModel.getName() 役職名を取得します。
String | CompanyPostBaseModel.getName(Date date) 役職名を取得します。
String | CompanyPostBaseModel.getName(Locale locale) 役職名を取得します。
String | CompanyPostBaseModel.getName(Date date, Locale locale) 役職名を取得します。
void | CompanyPostBaseModel.setName(String name) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Date date) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Locale locale) 役職名を設定します。
void | CompanyPostBaseModel.setName(String name, Date date, Locale locale) 役職名を設定します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
String | CompanyVersionBaseModel.getCompanyCode() 会社コードを取得します。
String | CompanyVersionBaseModel.getVersionCode() バージョンコードを取得します。
Date | CompanyVersionBaseModel.getStartDate() 開始日を取得します。
void | CompanyVersionBaseModel.setStartDate(Date startDate) 開始日を設定します。
Date | CompanyVersionBaseModel.getEndDate() 終了日を取得します。
void | CompanyVersionBaseModel.setEndDate(Date endDate) 終了日を設定します。
String | CompanyVersionBaseModel.getNotes() 備考を取得します。
void | CompanyVersionBaseModel.setNotes(String notes) 備考を設定します。
String | CompanyVersionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | CompanyVersionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
String | PrivateGroupAttachBaseModel.getOwnerCode() 所有者コードを取得します。
String | PrivateGroupAttachBaseModel.getPrivateGroupCode() グループコードを取得します。
String | PrivateGroupAttachBaseModel.getUserCode() ユーザコードを取得します。
int | PrivateGroupAttachBaseModel.getSortKey() ソートキーを取得します。
void | PrivateGroupAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PrivateGroupAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PrivateGroupAttachBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
String | PrivateGroupBaseModel.getOwnerCode() 所有者コードを取得します。
String | PrivateGroupBaseModel.getPrivateGroupCode() グループコードを取得します。
String | PrivateGroupBaseModel.getName() グループ名を取得します。
void | PrivateGroupBaseModel.setName(String name) グループ名を設定します。
String | PrivateGroupBaseModel.getNameSyllabary() グループ名カナを取得します。
void | PrivateGroupBaseModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
String | PrivateGroupBaseModel.getNameEnglish() グループ名英字を取得します。
void | PrivateGroupBaseModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
String | PrivateGroupBaseModel.getNotes() 備考を取得します。
void | PrivateGroupBaseModel.setNotes(String notes) 備考を設定します。
int | PrivateGroupBaseModel.getSortKey() ソートキーを取得します。
void | PrivateGroupBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PrivateGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PrivateGroupBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
String | PublicGroupAttachBaseModel.getUserCode() ユーザコードを取得します。
String | PublicGroupAttachBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupAttachBaseModel.getPublicGroupCode() グループコードを取得します。
int | PublicGroupAttachBaseModel.getSortKey() ソートキーを取得します。
void | PublicGroupAttachBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PublicGroupAttachBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupAttachBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
String | PublicGroupCategoryBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupCategoryBaseModel.getPublicGroupCode() グループコードを取得します。
String | PublicGroupCategoryBaseModel.getCategoryClassCode() 分類区分コードを取得します。
String | PublicGroupCategoryBaseModel.getCategoryCode() 分類コードを取得します。
String | PublicGroupCategoryBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupCategoryBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
String | PublicGroupTerminableModel.getName() グループ名を取得します。
String | PublicGroupTerminableModel.getName(Locale locale) グループ名を取得します。
void | PublicGroupTerminableModel.setName(String name) グループ名を設定します。
void | PublicGroupTerminableModel.setName(String name, Locale locale) グループ名を設定します。
String | PublicGroupTerminableModel.getNameSyllabary() グループ名カナを取得します。
String | PublicGroupTerminableModel.getNameSyllabary(Locale locale) グループ名カナを取得します。
void | PublicGroupTerminableModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | PublicGroupTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
String | PublicGroupTerminableModel.getNameEnglish() グループ名英字を取得します。
String | PublicGroupTerminableModel.getNameEnglish(Locale locale) グループ名英字を取得します。
void | PublicGroupTerminableModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | PublicGroupTerminableModel.setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
String | PublicGroupTerminableInternationalModel.getName() グループ名を取得します。
void | PublicGroupTerminableInternationalModel.setName(String name) グループ名を設定します。
String | PublicGroupTerminableInternationalModel.getNameSyllabary() グループ名カナを取得します。
void | PublicGroupTerminableInternationalModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
String | PublicGroupTerminableInternationalModel.getNameEnglish() グループ名英字を取得します。
void | PublicGroupTerminableInternationalModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
String | PublicGroupBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupBaseModel.getPublicGroupCode() グループコードを取得します。
String | PublicGroupBaseModel.getNotes() 備考を取得します。
void | PublicGroupBaseModel.setNotes(String notes) 備考を設定します。
int | PublicGroupBaseModel.getSortKey() ソートキーを取得します。
void | PublicGroupBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | PublicGroupBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupBaseModel.getRecordDate() 最終更新日を取得します。
String | PublicGroupBaseModel.getName() グループ名を取得します。
String | PublicGroupBaseModel.getName(Date date) グループ名を取得します。
String | PublicGroupBaseModel.getName(Locale locale) グループ名を取得します。
String | PublicGroupBaseModel.getName(Date date, Locale locale) グループ名を取得します。
void | PublicGroupBaseModel.setName(String name) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Date date) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Locale locale) グループ名を設定します。
void | PublicGroupBaseModel.setName(String name, Date date, Locale locale) グループ名を設定します。
String | PublicGroupBaseModel.getNameSyllabary() グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Date date) グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Locale locale) グループ名カナを取得します。
String | PublicGroupBaseModel.getNameSyllabary(Date date, Locale locale) グループ名カナを取得します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Date date) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) グループ名カナを設定します。
void | PublicGroupBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) グループ名カナを設定します。
String | PublicGroupBaseModel.getNameEnglish() グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Date date) グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Locale locale) グループ名英字を取得します。
String | PublicGroupBaseModel.getNameEnglish(Date date, Locale locale) グループ名英字を取得します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Date date) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Locale locale) グループ名英字を設定します。
void | PublicGroupBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) グループ名英字を設定します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
String | PublicGroupInclusionBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupInclusionBaseModel.getVersionCode() バージョンコードを取得します。
String | PublicGroupInclusionBaseModel.getParentPublicGroupCode() 親グループコードを取得します。
String | PublicGroupInclusionBaseModel.getPublicGroupCode() グループコードを取得します。
int | PublicGroupInclusionBaseModel.getDepth() 階層レベルを取得します。
void | PublicGroupInclusionBaseModel.setDepth(int depth) 階層レベルを設定します。
String | PublicGroupInclusionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupInclusionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
String | PublicGroupSetBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupSetBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupSetBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
String | PublicGroupVersionBaseModel.getPublicGroupSetCode() グループセットコードを取得します。
String | PublicGroupVersionBaseModel.getVersionCode() バージョンコードを取得します。
Date | PublicGroupVersionBaseModel.getStartDate() 開始日を取得します。
void | PublicGroupVersionBaseModel.setStartDate(Date startDate) 開始日を設定します。
Date | PublicGroupVersionBaseModel.getEndDate() 終了日を取得します。
void | PublicGroupVersionBaseModel.setEndDate(Date endDate) 終了日を設定します。
String | PublicGroupVersionBaseModel.getNotes() 備考を取得します。
void | PublicGroupVersionBaseModel.setNotes(String notes) 備考を設定します。
String | PublicGroupVersionBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | PublicGroupVersionBaseModel.getRecordDate() 最終更新日を取得します。

jp.co.intra_mart.foundation.datastore.application.model.user での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
String | UserTerminableModel.getTelephoneNumber() 電話番号を取得します。
void | UserTerminableModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
String | UserTerminableModel.getMobileNumber() 携帯電話番号を取得します。
void | UserTerminableModel.setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
String | UserTerminableModel.getFaxNumber() FAX番号を取得します。
void | UserTerminableModel.setFaxNumber(String faxNumber) FAX番号を設定します。
String | UserTerminableModel.getExtensionNumber() 内線番号を取得します。
void | UserTerminableModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
String | UserTerminableModel.getExtensionFaxNumber() 内線FAX番号を取得します。
void | UserTerminableModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
String | UserTerminableModel.getCountryCode() 国コードを取得します。
void | UserTerminableModel.setCountryCode(String countryCode) 国コードを設定します。
String | UserTerminableModel.getZipCode() 郵便番号を取得します。
void | UserTerminableModel.setZipCode(String zipCode) 郵便番号を設定します。
String | UserTerminableModel.getEmailAddress1() メールアドレス１を取得します。
void | UserTerminableModel.setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
String | UserTerminableModel.getEmailAddress2() メールアドレス２を取得します。
void | UserTerminableModel.setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
String | UserTerminableModel.getMobileEmailAddress() 携帯用メールを取得します。
void | UserTerminableModel.setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
String | UserTerminableModel.getUrl() URLを取得します。
void | UserTerminableModel.setUrl(String url) URLを設定します。
String | UserTerminableModel.getName() ユーザ名を取得します。
String | UserTerminableModel.getName(Locale locale) ユーザ名を取得します。
void | UserTerminableModel.setName(String name) ユーザ名を設定します。
void | UserTerminableModel.setName(String name, Locale locale) ユーザ名を設定します。
String | UserTerminableModel.getNameSyllabary() ユーザ名カナを取得します。
String | UserTerminableModel.getNameSyllabary(Locale locale) ユーザ名カナを取得します。
void | UserTerminableModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | UserTerminableModel.setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
String | UserTerminableModel.getNameEnglish() ユーザ名英字を取得します。
String | UserTerminableModel.getNameEnglish(Locale locale) ユーザ名英字を取得します。
void | UserTerminableModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | UserTerminableModel.setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
String | UserTerminableModel.getAddress() 住所を取得します。
String | UserTerminableModel.getAddress(Locale locale) 住所を取得します。
void | UserTerminableModel.setAddress(String address) 住所を設定します。
void | UserTerminableModel.setAddress(String address, Locale locale) 住所を設定します。
String | UserTerminableInternationalModel.getName() ユーザ名を取得します。
void | UserTerminableInternationalModel.setName(String name) ユーザ名を設定します。
String | UserTerminableInternationalModel.getNameSyllabary() ユーザ名カナを取得します。
void | UserTerminableInternationalModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
String | UserTerminableInternationalModel.getNameEnglish() ユーザ名英字を取得します。
void | UserTerminableInternationalModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
String | UserTerminableInternationalModel.getAddress() 住所を取得します。
void | UserTerminableInternationalModel.setAddress(String address) 住所を設定します。
String | UserBaseModel.getUserCode() ユーザコードを取得します。
String | UserBaseModel.getAccountFlag() アカウントフラグを取得します。
void | UserBaseModel.setAccountFlag(String accountFlag) アカウントフラグを設定します。
String | UserBaseModel.getNotes() 備考を取得します。
void | UserBaseModel.setNotes(String notes) 備考を設定します。
int | UserBaseModel.getSortKey() ソートキーを取得します。
void | UserBaseModel.setSortKey(int sortKey) ソートキーを設定します。
String | UserBaseModel.getRecordUserCode() 最終更新者を取得します。
Date | UserBaseModel.getRecordDate() 最終更新日を取得します。
String | UserBaseModel.getTelephoneNumber() 電話番号を取得します。
String | UserBaseModel.getTelephoneNumber(Date date) 電話番号を取得します。
void | UserBaseModel.setTelephoneNumber(String telephoneNumber) 電話番号を設定します。
void | UserBaseModel.setTelephoneNumber(String telephoneNumber, Date date) 電話番号を設定します。
String | UserBaseModel.getMobileNumber() 携帯電話番号を取得します。
String | UserBaseModel.getMobileNumber(Date date) 携帯電話番号を取得します。
void | UserBaseModel.setMobileNumber(String mobileNumber) 携帯電話番号を設定します。
void | UserBaseModel.setMobileNumber(String mobileNumber, Date date) 携帯電話番号を設定します。
String | UserBaseModel.getFaxNumber() FAX番号を取得します。
String | UserBaseModel.getFaxNumber(Date date) FAX番号を取得します。
void | UserBaseModel.setFaxNumber(String faxNumber) FAX番号を設定します。
void | UserBaseModel.setFaxNumber(String faxNumber, Date date) FAX番号を設定します。
String | UserBaseModel.getExtensionNumber() 内線番号を取得します。
String | UserBaseModel.getExtensionNumber(Date date) 内線番号を取得します。
void | UserBaseModel.setExtensionNumber(String extensionNumber) 内線番号を設定します。
void | UserBaseModel.setExtensionNumber(String extensionNumber, Date date) 内線番号を設定します。
String | UserBaseModel.getExtensionFaxNumber() 内線FAX番号を取得します。
String | UserBaseModel.getExtensionFaxNumber(Date date) 内線FAX番号を取得します。
void | UserBaseModel.setExtensionFaxNumber(String extensionFaxNumber) 内線FAX番号を設定します。
void | UserBaseModel.setExtensionFaxNumber(String extensionFaxNumber, Date date) 内線FAX番号を設定します。
String | UserBaseModel.getCountryCode() 国コードを取得します。
String | UserBaseModel.getCountryCode(Date date) 国コードを取得します。
void | UserBaseModel.setCountryCode(String countryCode) 国コードを設定します。
void | UserBaseModel.setCountryCode(String countryCode, Date date) 国コードを設定します。
String | UserBaseModel.getZipCode() 郵便番号を取得します。
String | UserBaseModel.getZipCode(Date date) 郵便番号を取得します。
void | UserBaseModel.setZipCode(String zipCode) 郵便番号を設定します。
void | UserBaseModel.setZipCode(String zipCode, Date date) 郵便番号を設定します。
String | UserBaseModel.getEmailAddress1() メールアドレス１を取得します。
String | UserBaseModel.getEmailAddress1(Date date) メールアドレス１を取得します。
void | UserBaseModel.setEmailAddress1(String emailAddress1) メールアドレス１を設定します。
void | UserBaseModel.setEmailAddress1(String emailAddress1, Date date) メールアドレス１を設定します。
String | UserBaseModel.getEmailAddress2() メールアドレス２を取得します。
String | UserBaseModel.getEmailAddress2(Date date) メールアドレス２を取得します。
void | UserBaseModel.setEmailAddress2(String emailAddress2) メールアドレス２を設定します。
void | UserBaseModel.setEmailAddress2(String emailAddress2, Date date) メールアドレス２を設定します。
String | UserBaseModel.getMobileEmailAddress() 携帯用メールを取得します。
String | UserBaseModel.getMobileEmailAddress(Date date) 携帯用メールを取得します。
void | UserBaseModel.setMobileEmailAddress(String mobileEmailAddress) 携帯用メールを設定します。
void | UserBaseModel.setMobileEmailAddress(String mobileEmailAddress, Date date) 携帯用メールを設定します。
String | UserBaseModel.getUrl() URLを取得します。
String | UserBaseModel.getUrl(Date date) URLを取得します。
void | UserBaseModel.setUrl(String url) URLを設定します。
void | UserBaseModel.setUrl(String url, Date date) URLを設定します。
String | UserBaseModel.getName() ユーザ名を取得します。
String | UserBaseModel.getName(Date date) ユーザ名を取得します。
String | UserBaseModel.getName(Locale locale) ユーザ名を取得します。
String | UserBaseModel.getName(Date date, Locale locale) ユーザ名を取得します。
void | UserBaseModel.setName(String name) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Date date) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Locale locale) ユーザ名を設定します。
void | UserBaseModel.setName(String name, Date date, Locale locale) ユーザ名を設定します。
String | UserBaseModel.getNameSyllabary() ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Date date) ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Locale locale) ユーザ名カナを取得します。
String | UserBaseModel.getNameSyllabary(Date date, Locale locale) ユーザ名カナを取得します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Date date) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Locale locale) ユーザ名カナを設定します。
void | UserBaseModel.setNameSyllabary(String nameSyllabary, Date date, Locale locale) ユーザ名カナを設定します。
String | UserBaseModel.getNameEnglish() ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Date date) ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Locale locale) ユーザ名英字を取得します。
String | UserBaseModel.getNameEnglish(Date date, Locale locale) ユーザ名英字を取得します。
void | UserBaseModel.setNameEnglish(String nameEnglish) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Date date) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Locale locale) ユーザ名英字を設定します。
void | UserBaseModel.setNameEnglish(String nameEnglish, Date date, Locale locale) ユーザ名英字を設定します。
String | UserBaseModel.getAddress() 住所を取得します。
String | UserBaseModel.getAddress(Date date) 住所を取得します。
String | UserBaseModel.getAddress(Locale locale) 住所を取得します。
String | UserBaseModel.getAddress(Date date, Locale locale) 住所を取得します。
void | UserBaseModel.setAddress(String address) 住所を設定します。
void | UserBaseModel.setAddress(String address, Date date) 住所を設定します。
void | UserBaseModel.setAddress(String address, Locale locale) 住所を設定します。
void | UserBaseModel.setAddress(String address, Date date, Locale locale) 住所を設定します。

jp.co.intra_mart.foundation.datastore.common.model での AccessorException の使用

AccessorException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | TerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
TerminableInternationalModel | TerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
void | TerminableInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
InternationalModel | InternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
void | InternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
TerminableModel | GenericTerminableModelMap.createTerminableModel(Term term) 指定した期間を満たす期間化モデルを生成します。
void | GenericTerminableModelMap.remove(Term term) 指定された期間に該当するデータを削除します。
protected Object | GenericTerminableModel.get(String name) 指定の属性が保持する値を取得します。
protected Object | GenericTerminableModel.get(String name, Locale locale) 指定の属性が指定の言語で保持する値を取得します。
protected void | GenericTerminableModel.set(String name, Object value) 指定の属性に値を設定します。
protected void | GenericTerminableModel.set(String name, Object value, Locale locale) 指定の属性に値を設定します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.createTerminableInternationalModel(Locale locale) 期間国際化モデルを生成します。
void | GenericTerminableInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
protected Object | GenericTerminableInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | GenericTerminableInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
InternationalModel | GenericInternationalModelMap.createInternationalModel(Locale locale) 国際化モデルを生成します。
void | GenericInternationalModelMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
protected Object | GenericInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | GenericInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
protected Object | GenericBaseModel.get(String name) 指定の属性が保持する値を取得します。
protected Object | GenericBaseModel.get(String name, Date date) 指定の属性が、指定の日時に保持している値を取得します。
protected Object | GenericBaseModel.get(String name, Locale locale) 指定の属性が、指定の言語で保持している値を取得します。
protected Object | GenericBaseModel.get(String name, Date date, Locale locale) 指定の属性が、指定の日時、言語で保持している値を取得します。
protected void | GenericBaseModel.set(String name, Object value) 指定の属性に値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Date date) 指定の属性に、指定の日時で値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Locale locale) 指定の属性に、指定の言語で値を設定します。
protected void | GenericBaseModel.set(String name, Object value, Date date, Locale locale) 指定の属性に、指定の日時、言語で値を設定します。
ExtendedTerminableModel | ExtendedTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | ExtendedTerminableModelMap.remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | ExtendedTerminableInternationalModelMap.remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
ExtendedInternationalModel | ExtendedInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | ExtendedInternationalModelMap.remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.createExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.findExtendedTerminableModel(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
void | ExtendedGenericTerminableModelMap.remove(String name) 拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
protected Object | ExtendedGenericTerminableModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericTerminableModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.createExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.findExtendedTerminableInternationalModel(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
void | ExtendedGenericTerminableInternationalModelMap.remove(String name) 拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
protected Object | ExtendedGenericTerminableInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericTerminableInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.createExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
ExtendedInternationalModel | ExtendedGenericInternationalModelMap.findExtendedInternationalModel(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
void | ExtendedGenericInternationalModelMap.remove(String name) 拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
protected Object | ExtendedGenericInternationalModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericInternationalModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | ExtendedGenericBaseModelMap.remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
protected Object | ExtendedGenericBaseModel.get(String name) 指定の属性が保持する値を取得します。
protected void | ExtendedGenericBaseModel.set(String name, Object value) 指定の属性に値を設定します。
ExtendedBaseModel | ExtendedBaseModelMap.createExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
ExtendedBaseModel | ExtendedBaseModelMap.findExtendedBaseModel(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
void | ExtendedBaseModelMap.remove(String name) 拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。

jp.co.intra_mart.foundation.datastore.exception での AccessorException の使用

jp.co.intra_mart.foundation.datastore.exception での AccessorException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException の使用

AccessorIllegalPropertyValueException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor 情報を扱うためのアクセサを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での AccessorIllegalPropertyValueException の使用

AccessorIllegalPropertyValueException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
void | TerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | TerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | InternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedTerminableInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedTerminableAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedInternationalAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | ExtendedBaseAccessor.setProperty(String prop, Object value) プロパティを設定します。
void | BaseAccessor.setProperty(String prop, Object value) プロパティを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException の使用

jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException の使用

DataNotFoundException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での DataNotFoundException の使用

DataNotFoundException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
Object | TerminableInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | TerminableAccessor.getProperty(String prop) プロパティを取得します。
Object | InternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedTerminableInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedTerminableAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedInternationalAccessor.getProperty(String prop) プロパティを取得します。
Object | ExtendedBaseAccessor.getProperty(String prop) プロパティを取得します。
Object | BaseAccessor.getProperty(String prop) プロパティを取得します。

jp.co.intra_mart.foundation.datastore.exception での DataNotFoundException の使用

jp.co.intra_mart.foundation.datastore.exception での DataNotFoundException のサブクラス
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException の使用

DataStoreApplicationException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.exception での DataStoreApplicationException の使用

jp.co.intra_mart.foundation.datastore.exception での DataStoreApplicationException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorException アクセサで発生する例外の基底クラス
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalRelationshipException リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
class | ManagerException マネージャに関する例外クラス
class | MapperException マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
class | TermManagerException 期間に関する例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException の使用

jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException の使用

DataStoreSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.common.model での DataStoreSystemException の使用

DataStoreSystemException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
 TerminableModel GenericTerminableModelMap.newTerminableModel(Term term)
初期化されていない期間化モデルのインスタンスを取得します。

jp.co.intra_mart.foundation.datastore.exception での DataStoreSystemException の使用

jp.co.intra_mart.foundation.datastore.exception での DataStoreSystemException のサブクラス
class | AccessorSystemException アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
class | DataStoreConfigException アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
class | MapperDAOException マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException の使用

IllegalExtensionException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalExtensionException の使用

IllegalExtensionException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.createExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
ExtendedTerminableInternationalAccessor | ExtendedTerminableInternationalAccessorMap.findExtendedTerminableInternationalAccessor(String name) 拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.createExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
ExtendedTerminableAccessor | ExtendedTerminableAccessorMap.findExtendedTerminableAccessor(String name) 拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.createExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
ExtendedInternationalAccessor | ExtendedInternationalAccessorMap.findExtendedInternationalAccessor(String name) 拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.createExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
ExtendedBaseAccessor | ExtendedBaseAccessorMap.findExtendedBaseAccessor(String name) 拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalExtensionException の使用

IllegalExtensionException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
ExtendedTerminableModel | ExtendedGenericTerminableModelMap.newExtendedTerminableModel(String name) 初期化されてていない拡張期間化モデルのインスタンスを取得します。
ExtendedTerminableInternationalModel | ExtendedGenericTerminableInternationalModelMap.newExtendedTerminableInternationalModel(String name) 初期化されていない拡張期間国際化モデルのインスタンスを取得します。
ExtendedBaseModel | ExtendedGenericBaseModelMap.newExtendedBaseModel(String name) 初期化されていない拡張基本モデルのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException の使用

IllegalLocaleException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
 CateogryClassInternationalModel CateogryClassBaseModel.selectCateogryClassInternationalModel(Locale locale)
指定された言語に該当する分類区分の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
 CategoryDetailInternationalModel CategoryDetailBaseModel.selectCategoryDetailInternationalModel(Locale locale)
指定された言語に該当する分類区分詳細の国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableInternationalModel DepartmentTerminableModel.selectDepartmentTerminableInternationalModel(Locale locale)
指定された言語に該当する組織の期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableInternationalModel CompanyPostTerminableModel.selectCompanyPostTerminableInternationalModel(Locale locale)
指定された言語に該当する役職の期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableInternationalModel PublicGroupTerminableModel.selectPublicGroupTerminableInternationalModel(Locale locale)
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.user での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableInternationalModel UserTerminableModel.selectUserTerminableInternationalModel(Locale locale)
指定された言語に該当するユーザの期間国際化モデルを取得します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
TerminableInternationalAccessor | TerminableInternationalAccessorMap.createTerminableInternationalAccessor(Locale locale) 期間国際化アクセサを生成します。
TerminableInternationalAccessor | TerminableInternationalAccessorMap.findTerminableInternationalAccessor(Locale locale) 指定された言語に該当する期間国際化アクセサを取得します。
void | TerminableInternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。
InternationalAccessor | InternationalAccessorMap.createInternationalAccessor(Locale locale) 国際化アクセサを生成します。
InternationalAccessor | InternationalAccessorMap.findInternationalAccessor(Locale locale) 指定された言語に該当する国際化アクセサを取得します。
void | InternationalAccessorMap.remove(Locale locale) 指定された言語に該当するデータを削除します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalLocaleException の使用

IllegalLocaleException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableInternationalModel | TerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
InternationalModel | InternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
protected TerminableInternationalModel | GenericTerminableModel.selectTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.findTerminableInternationalModel(Locale locale) 指定された言語に該当する期間国際化モデルを取得します。
TerminableInternationalModel | GenericTerminableInternationalModelMap.newTerminableInternationalModel(Locale locale) 初期化されていない期間国際化モデルのインスタンスを取得します。
InternationalModel | GenericInternationalModelMap.findInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。
InternationalModel | GenericInternationalModelMap.newInternationalModel(Locale locale) 初期化されていない国際化モデルのインスタンスを取得します。
protected InternationalModel | GenericBaseModel.selectInternationalModel(Locale locale) 指定された言語に該当する国際化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException の使用

jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.IllegalTermException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.IllegalTermException の使用

IllegalTermException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
 DepartmentAttachTerminableModel DepartmentAttachBaseModel.selectDepartmentAttachTerminableModel(Date date)
指定された日付に該当する組織所属の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
 DepartmentTerminableModel DepartmentBaseModel.selectDepartmentTerminableModel(Date date)
指定された日付に該当する組織の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
 DepartmentMainTerminableModel DepartmentMainBaseModel.selectDepartmentMainTerminableModel(Date date)
指定された日付に該当する主所属の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
 CompanyPostTerminableModel CompanyPostBaseModel.selectCompanyPostTerminableModel(Date date)
指定された日付に該当する役職の期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
 PublicGroupTerminableModel PublicGroupBaseModel.selectPublicGroupTerminableModel(Date date)
指定された日付に該当するパブリックグループの期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.application.model.user での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
 UserTerminableModel UserBaseModel.selectUserTerminableModel(Date date)
指定された日付に該当するユーザの期間化モデルを取得します。

jp.co.intra_mart.foundation.datastore.common.accessor での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.common.accessor のメソッド
 TerminableAccessor TerminableAccessorMap.createTerminableAccessor(Term term)
指定した期間に期間化アクセサを生成します。

jp.co.intra_mart.foundation.datastore.common.model での IllegalTermException の使用

IllegalTermException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
TerminableModel | TerminableModelMap.findTerminableModel(Date date) 指定された日付に該当する期間化モデルを取得します。
TerminableModel | GenericTerminableModelMap.findTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。
protected TerminableModel | GenericBaseModel.selectTerminableModel(Date date) 指定された日時に該当する期間化モデルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.ImportException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.ImportException の使用

ImportException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
void | StandardCompanyPostImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | StandardCompanyImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | CompanyPostImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | CompanyImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
void | StandardPublicGroupImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | PublicGroupImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。

jp.co.intra_mart.foundation.datastore.application.domain.user での ImportException の使用

ImportException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
void | UserImporter.doImport(InputStream inputstream, String user, String group) インポートを行います。
void | StandardUserImporter.doImport(InputStream inputStream, String user, String group) インポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.ManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.ManagerException の使用

ManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.category のメソッド
static CategoryManager | CategoryManager.getCategoryManager(String user, String group) CategoryManagerを取得します。
protected abstract void | CategoryManager.init(String user, String group) CategoryManagerを初期化します。
abstract void | CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) 分類区分詳細を登録します。
abstract void | CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を更新します。
abstract void | CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) 登録済の分類区分詳細を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
static CompanyManager | CompanyManager.getCompanyManager(String user, String group) CompanyManagerを取得します。
protected abstract void | CompanyManager.init(String user, String group) CompanyManagerを初期化します。
abstract void | CompanyManager.addCompany(Company company) 会社を登録します。
abstract void | CompanyManager.deleteCompany(Company company) 登録済の会社を削除します。
abstract void | CompanyManager.addDepartment(Department department) 組織を登録します。
abstract void | CompanyManager.updateDepartment(Department department) 登録済の組織情報を更新します。
abstract void | CompanyManager.deleteDepartment(Department department) 登録済の組織情報を削除します。
abstract void | CompanyManager.joinDepartment(String company, String parentDepartment, String department, String version) 組織構成に組織を登録します。
abstract void | CompanyManager.moveDepartment(String company, String parentDepartment, String department, String version) 組織構成に登録済の組織情報を移動します。
abstract void | CompanyManager.leaveDepartment(String company, String department, String version) 組織構成から組織情報を離脱させます。
abstract void | CompanyManager.setCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を設定します。
abstract void | CompanyManager.removeCategoryDetail(CompanyCategory category) 組織に対して指定された分類区分情報を削除します。
abstract void | CompanyManager.setMember(DepartmentAttach attach) 組織に人員を割り当てます。
abstract void | CompanyManager.deleteMember(DepartmentAttach attach) 組織から人員をはずします。
abstract void | CompanyManager.setMain(DepartmentMain main) ユーザが主所属する組織を設定します。
abstract void | CompanyManager.removeMain(DepartmentMain main) 指定されたユーザの主所属を削除します。
abstract void | CompanyManager.addVersion(CompanyVersion version) 会社構成バージョンを新規に登録します。
abstract void | CompanyManager.updateVersion(CompanyVersion version) 登録済の会社構成バージョンを更新します。
abstract void | CompanyManager.deleteVersion(CompanyVersion version) 登録済の会社構成バージョンを削除します。
abstract void | CompanyManager.copyVersion(String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンの内容をコピーします。
abstract DepartmentStruct[] | CompanyManager.getDepartmentStructs(String company, String department, Date date, Locale locale) 組織の階層構造を取得します。
abstract void | CompanyManager.addPost(CompanyPost post) 役職を登録します。
abstract void | CompanyManager.updatePost(CompanyPost post) 登録済の役職情報を更新します。
abstract void | CompanyManager.deletePost(CompanyPost post) 登録済の役職情報を削除します。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
static PrivateGroupManager | PrivateGroupManager.getPrivateGroupManager(String user, String group) PrivateGroupManagerを取得します。
protected abstract void | PrivateGroupManager.init(String user, String group) PrivateGroupManagerを初期化します。
abstract void | PrivateGroupManager.addPrivateGroup(PrivateGroup group) プライベートグループを登録します。
abstract void | PrivateGroupManager.updatePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を更新します。
abstract void | PrivateGroupManager.deletePrivateGroup(PrivateGroup group) 登録済のプライベートグループ情報を削除します。
abstract void | PrivateGroupManager.setMember(PrivateGroupAttach member) プライベートグループに人員を割り当てます。
abstract void | PrivateGroupManager.deleteMember(PrivateGroupAttach member) プライベートグループから人員をはずします。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
static PublicGroupManager | PublicGroupManager.getPublicGroupManager(String user, String group) PublicGroupManagerを取得します。
protected abstract void | PublicGroupManager.init(String user, String group) PublicGroupManagerを初期化します。
abstract void | PublicGroupManager.addGroupSet(PublicGroupSet groupSet) パブリックグループセットを登録します。
abstract void | PublicGroupManager.deleteGroupSet(PublicGroupSet groupSet) 登録済のパブリックグループセットを削除します。
abstract void | PublicGroupManager.addPublicGroup(PublicGroup publicGroup) パブリックグループを登録します。
abstract void | PublicGroupManager.updatePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を更新します。
abstract void | PublicGroupManager.deletePublicGroup(PublicGroup publicGroup) 登録済のパブリックグループ情報を削除します。
abstract void | PublicGroupManager.joinPublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成にパブリックグループを登録します。
abstract void | PublicGroupManager.movePublicGroup(String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成に登録済のパブリックグループ情報を移動します。
abstract void | PublicGroupManager.leavePublicGroup(String groupSet, String publicGroup, String version) パブリックグループ構成からパブリックグループ情報を離脱させます。
abstract void | PublicGroupManager.setCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を設定します。
abstract void | PublicGroupManager.removeCategoryDetail(PublicGroupCategory category) パブリックグループに対して指定された分類区分情報を削除します。
abstract void | PublicGroupManager.setMember(PublicGroupAttach attach) パブリックグループに人員を割り当てます。
abstract void | PublicGroupManager.deleteMember(PublicGroupAttach attach) パブリックグループから人員をはずします。
abstract void | PublicGroupManager.addVersion(PublicGroupVersion version) パブリックグループセット構成バージョンを新規に登録します。
abstract void | PublicGroupManager.updateVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを更新します。
abstract void | PublicGroupManager.deleteVersion(PublicGroupVersion version) 登録済のパブリックグループセット構成バージョンを削除します。
abstract void | PublicGroupManager.copyVersion(String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
abstract PublicGroupStruct[] | PublicGroupManager.getPublicGroupStructs(String groupSet, String publicGroup, Date date, Locale locale) パブリックグループの階層構造を取得します。

jp.co.intra_mart.foundation.datastore.application.domain.user での ManagerException の使用

ManagerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
static UserManager | UserManager.getUserManager(String user, String group) UserManagerを取得します。
protected abstract void | UserManager.init(String user, String group) UserManagerを初期化します。
abstract void | UserManager.addUser(User user) ユーザを登録します。
abstract void | UserManager.updateUser(User user) 登録済のユーザを更新します。
abstract void | UserManager.deleteUser(User user) 登録済のユーザを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.MapperDAOException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.MapperDAOException の使用

jp.co.intra_mart.foundation.datastore.exception.MapperDAOException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.MapperException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.MapperException の使用

MapperException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。

jp.co.intra_mart.foundation.datastore.application.model.category.category_class での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.category_class のメソッド
CateogryClassBaseModel | CateogryClassMapper.create(String categoryClassCode) プライマリキーに該当する分類区分を生成します。
CateogryClassBaseModel | CateogryClassMapper.select(String categoryClassCode) プライマリーキーで特定される分類区分の基本モデルを取得します。
void | CateogryClassMapper.insert(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ挿入します。
void | CateogryClassMapper.insert(Collection models) 分類区分の基本モデルを複数挿入します。
void | CateogryClassMapper.update(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ更新します。
void | CateogryClassMapper.update(Collection models) 分類区分の基本モデルを複数更新します。
void | CateogryClassMapper.delete(CateogryClassBaseModel model) 分類区分の基本モデルを1つだけ削除します。
void | CateogryClassMapper.delete(Collection models) 分類区分の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.category.detail での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.category.detail のメソッド
CategoryDetailBaseModel | CategoryDetailMapper.create(String categoryClassCode, String categoryCode) プライマリキーに該当する分類区分詳細を生成します。
CategoryDetailBaseModel | CategoryDetailMapper.select(String categoryClassCode, String categoryCode) プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
void | CategoryDetailMapper.insert(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ挿入します。
void | CategoryDetailMapper.insert(Collection models) 分類区分詳細の基本モデルを複数挿入します。
void | CategoryDetailMapper.update(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ更新します。
void | CategoryDetailMapper.update(Collection models) 分類区分詳細の基本モデルを複数更新します。
void | CategoryDetailMapper.delete(CategoryDetailBaseModel model) 分類区分詳細の基本モデルを1つだけ削除します。
void | CategoryDetailMapper.delete(Collection models) 分類区分詳細の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.attach のメソッド
DepartmentAttachBaseModel | DepartmentAttachMapper.create(String userCode, String companyCode, String departmentCode) プライマリキーに該当する組織所属を生成します。
DepartmentAttachBaseModel | DepartmentAttachMapper.select(String userCode, String companyCode, String departmentCode) プライマリーキーで特定される組織所属の基本モデルを取得します。
void | DepartmentAttachMapper.insert(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ挿入します。
void | DepartmentAttachMapper.insert(Collection models) 組織所属の基本モデルを複数挿入します。
void | DepartmentAttachMapper.update(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ更新します。
void | DepartmentAttachMapper.update(Collection models) 組織所属の基本モデルを複数更新します。
void | DepartmentAttachMapper.delete(DepartmentAttachBaseModel model) 組織所属の基本モデルを1つだけ削除します。
void | DepartmentAttachMapper.delete(Collection models) 組織所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.category での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.category のメソッド
CompanyCategoryBaseModel | CompanyCategoryMapper.create(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリキーに該当する会社組織分類を生成します。
CompanyCategoryBaseModel | CompanyCategoryMapper.select(String companyCode, String departmentCode, String categoryClassCode, String categoryCode) プライマリーキーで特定される会社組織分類の基本モデルを取得します。
void | CompanyCategoryMapper.insert(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ挿入します。
void | CompanyCategoryMapper.insert(Collection models) 会社組織分類の基本モデルを複数挿入します。
void | CompanyCategoryMapper.update(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ更新します。
void | CompanyCategoryMapper.update(Collection models) 会社組織分類の基本モデルを複数更新します。
void | CompanyCategoryMapper.delete(CompanyCategoryBaseModel model) 会社組織分類の基本モデルを1つだけ削除します。
void | CompanyCategoryMapper.delete(Collection models) 会社組織分類の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.company での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.company のメソッド
CompanyBaseModel | CompanyMapper.create(String companyCode) プライマリキーに該当する会社を生成します。
CompanyBaseModel | CompanyMapper.select(String companyCode) プライマリーキーで特定される会社の基本モデルを取得します。
void | CompanyMapper.insert(CompanyBaseModel model) 会社の基本モデルを1つだけ挿入します。
void | CompanyMapper.insert(Collection models) 会社の基本モデルを複数挿入します。
void | CompanyMapper.update(CompanyBaseModel model) 会社の基本モデルを1つだけ更新します。
void | CompanyMapper.update(Collection models) 会社の基本モデルを複数更新します。
void | CompanyMapper.delete(CompanyBaseModel model) 会社の基本モデルを1つだけ削除します。
void | CompanyMapper.delete(Collection models) 会社の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.department での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.department のメソッド
DepartmentBaseModel | DepartmentMapper.create(String companyCode, String departmentCode) プライマリキーに該当する組織を生成します。
DepartmentBaseModel | DepartmentMapper.select(String companyCode, String departmentCode) プライマリーキーで特定される組織の基本モデルを取得します。
void | DepartmentMapper.insert(DepartmentBaseModel model) 組織の基本モデルを1つだけ挿入します。
void | DepartmentMapper.insert(Collection models) 組織の基本モデルを複数挿入します。
void | DepartmentMapper.update(DepartmentBaseModel model) 組織の基本モデルを1つだけ更新します。
void | DepartmentMapper.update(Collection models) 組織の基本モデルを複数更新します。
void | DepartmentMapper.delete(DepartmentBaseModel model) 組織の基本モデルを1つだけ削除します。
void | DepartmentMapper.delete(Collection models) 組織の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.inclusion のメソッド
DepartmentInclusionBaseModel | DepartmentInclusionMapper.create(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリキーに該当する組織内包を生成します。
DepartmentInclusionBaseModel | DepartmentInclusionMapper.select(String companyCode, String versionCode, String parentDepartmentCode, String departmentCode) プライマリーキーで特定される組織内包の基本モデルを取得します。
void | DepartmentInclusionMapper.insert(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ挿入します。
void | DepartmentInclusionMapper.insert(Collection models) 組織内包の基本モデルを複数挿入します。
void | DepartmentInclusionMapper.update(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ更新します。
void | DepartmentInclusionMapper.update(Collection models) 組織内包の基本モデルを複数更新します。
void | DepartmentInclusionMapper.delete(DepartmentInclusionBaseModel model) 組織内包の基本モデルを1つだけ削除します。
void | DepartmentInclusionMapper.delete(Collection models) 組織内包の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.main での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.main のメソッド
DepartmentMainBaseModel | DepartmentMainMapper.create(String userCode) プライマリキーに該当する主所属を生成します。
DepartmentMainBaseModel | DepartmentMainMapper.select(String userCode) プライマリーキーで特定される主所属の基本モデルを取得します。
void | DepartmentMainMapper.insert(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ挿入します。
void | DepartmentMainMapper.insert(Collection models) 主所属の基本モデルを複数挿入します。
void | DepartmentMainMapper.update(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ更新します。
void | DepartmentMainMapper.update(Collection models) 主所属の基本モデルを複数更新します。
void | DepartmentMainMapper.delete(DepartmentMainBaseModel model) 主所属の基本モデルを1つだけ削除します。
void | DepartmentMainMapper.delete(Collection models) 主所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.post での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.post のメソッド
CompanyPostBaseModel | CompanyPostMapper.create(String companyCode, String postCode) プライマリキーに該当する役職を生成します。
CompanyPostBaseModel | CompanyPostMapper.select(String companyCode, String postCode) プライマリーキーで特定される役職の基本モデルを取得します。
void | CompanyPostMapper.insert(CompanyPostBaseModel model) 役職の基本モデルを1つだけ挿入します。
void | CompanyPostMapper.insert(Collection models) 役職の基本モデルを複数挿入します。
void | CompanyPostMapper.update(CompanyPostBaseModel model) 役職の基本モデルを1つだけ更新します。
void | CompanyPostMapper.update(Collection models) 役職の基本モデルを複数更新します。
void | CompanyPostMapper.delete(CompanyPostBaseModel model) 役職の基本モデルを1つだけ削除します。
void | CompanyPostMapper.delete(Collection models) 役職の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.company.version での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.company.version のメソッド
CompanyVersionBaseModel | CompanyVersionMapper.create(String companyCode, String versionCode) プライマリキーに該当する会社構成バージョンを生成します。
CompanyVersionBaseModel | CompanyVersionMapper.select(String companyCode, String versionCode) プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
void | CompanyVersionMapper.insert(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ挿入します。
void | CompanyVersionMapper.insert(Collection models) 会社構成バージョンの基本モデルを複数挿入します。
void | CompanyVersionMapper.update(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ更新します。
void | CompanyVersionMapper.update(Collection models) 会社構成バージョンの基本モデルを複数更新します。
void | CompanyVersionMapper.delete(CompanyVersionBaseModel model) 会社構成バージョンの基本モデルを1つだけ削除します。
void | CompanyVersionMapper.delete(Collection models) 会社構成バージョンの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.attach のメソッド
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.create(String ownerCode, String privateGroupCode, String userCode) プライマリキーに該当するプライベートグループ所属を生成します。
PrivateGroupAttachBaseModel | PrivateGroupAttachMapper.select(String ownerCode, String privateGroupCode, String userCode) プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
void | PrivateGroupAttachMapper.insert(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ挿入します。
void | PrivateGroupAttachMapper.insert(Collection models) プライベートグループ所属の基本モデルを複数挿入します。
void | PrivateGroupAttachMapper.update(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ更新します。
void | PrivateGroupAttachMapper.update(Collection models) プライベートグループ所属の基本モデルを複数更新します。
void | PrivateGroupAttachMapper.delete(PrivateGroupAttachBaseModel model) プライベートグループ所属の基本モデルを1つだけ削除します。
void | PrivateGroupAttachMapper.delete(Collection models) プライベートグループ所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.private_group.group のメソッド
PrivateGroupBaseModel | PrivateGroupMapper.create(String ownerCode, String privateGroupCode) プライマリキーに該当するプライベートグループを生成します。
PrivateGroupBaseModel | PrivateGroupMapper.select(String ownerCode, String privateGroupCode) プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
void | PrivateGroupMapper.insert(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ挿入します。
void | PrivateGroupMapper.insert(Collection models) プライベートグループの基本モデルを複数挿入します。
void | PrivateGroupMapper.update(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ更新します。
void | PrivateGroupMapper.update(Collection models) プライベートグループの基本モデルを複数更新します。
void | PrivateGroupMapper.delete(PrivateGroupBaseModel model) プライベートグループの基本モデルを1つだけ削除します。
void | PrivateGroupMapper.delete(Collection models) プライベートグループの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.attach のメソッド
PublicGroupAttachBaseModel | PublicGroupAttachMapper.create(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループ所属を生成します。
PublicGroupAttachBaseModel | PublicGroupAttachMapper.select(String userCode, String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
void | PublicGroupAttachMapper.insert(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ挿入します。
void | PublicGroupAttachMapper.insert(Collection models) パブリックグループ所属の基本モデルを複数挿入します。
void | PublicGroupAttachMapper.update(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ更新します。
void | PublicGroupAttachMapper.update(Collection models) パブリックグループ所属の基本モデルを複数更新します。
void | PublicGroupAttachMapper.delete(PublicGroupAttachBaseModel model) パブリックグループ所属の基本モデルを1つだけ削除します。
void | PublicGroupAttachMapper.delete(Collection models) パブリックグループ所属の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.category のメソッド
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.create(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリキーに該当するパブリックグループ分類を生成します。
PublicGroupCategoryBaseModel | PublicGroupCategoryMapper.select(String publicGroupSetCode, String publicGroupCode, String categoryClassCode, String categoryCode) プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
void | PublicGroupCategoryMapper.insert(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ挿入します。
void | PublicGroupCategoryMapper.insert(Collection models) パブリックグループ分類の基本モデルを複数挿入します。
void | PublicGroupCategoryMapper.update(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ更新します。
void | PublicGroupCategoryMapper.update(Collection models) パブリックグループ分類の基本モデルを複数更新します。
void | PublicGroupCategoryMapper.delete(PublicGroupCategoryBaseModel model) パブリックグループ分類の基本モデルを1つだけ削除します。
void | PublicGroupCategoryMapper.delete(Collection models) パブリックグループ分類の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.group のメソッド
PublicGroupBaseModel | PublicGroupMapper.create(String publicGroupSetCode, String publicGroupCode) プライマリキーに該当するパブリックグループを生成します。
PublicGroupBaseModel | PublicGroupMapper.select(String publicGroupSetCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
void | PublicGroupMapper.insert(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ挿入します。
void | PublicGroupMapper.insert(Collection models) パブリックグループの基本モデルを複数挿入します。
void | PublicGroupMapper.update(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ更新します。
void | PublicGroupMapper.update(Collection models) パブリックグループの基本モデルを複数更新します。
void | PublicGroupMapper.delete(PublicGroupBaseModel model) パブリックグループの基本モデルを1つだけ削除します。
void | PublicGroupMapper.delete(Collection models) パブリックグループの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion のメソッド
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.create(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリキーに該当するパブリックグループ内包を生成します。
PublicGroupInclusionBaseModel | PublicGroupInclusionMapper.select(String publicGroupSetCode, String versionCode, String parentPublicGroupCode, String publicGroupCode) プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
void | PublicGroupInclusionMapper.insert(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ挿入します。
void | PublicGroupInclusionMapper.insert(Collection models) パブリックグループ内包の基本モデルを複数挿入します。
void | PublicGroupInclusionMapper.update(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ更新します。
void | PublicGroupInclusionMapper.update(Collection models) パブリックグループ内包の基本モデルを複数更新します。
void | PublicGroupInclusionMapper.delete(PublicGroupInclusionBaseModel model) パブリックグループ内包の基本モデルを1つだけ削除します。
void | PublicGroupInclusionMapper.delete(Collection models) パブリックグループ内包の基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.set のメソッド
PublicGroupSetBaseModel | PublicGroupSetMapper.create(String publicGroupSetCode) プライマリキーに該当するパブリックグループセットを生成します。
PublicGroupSetBaseModel | PublicGroupSetMapper.select(String publicGroupSetCode) プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
void | PublicGroupSetMapper.insert(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ挿入します。
void | PublicGroupSetMapper.insert(Collection models) パブリックグループセットの基本モデルを複数挿入します。
void | PublicGroupSetMapper.update(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ更新します。
void | PublicGroupSetMapper.update(Collection models) パブリックグループセットの基本モデルを複数更新します。
void | PublicGroupSetMapper.delete(PublicGroupSetBaseModel model) パブリックグループセットの基本モデルを1つだけ削除します。
void | PublicGroupSetMapper.delete(Collection models) パブリックグループセットの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.public_group.version のメソッド
PublicGroupVersionBaseModel | PublicGroupVersionMapper.create(String publicGroupSetCode, String versionCode) プライマリキーに該当するパブリックグループ構成バージョンを生成します。
PublicGroupVersionBaseModel | PublicGroupVersionMapper.select(String publicGroupSetCode, String versionCode) プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
void | PublicGroupVersionMapper.insert(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
void | PublicGroupVersionMapper.insert(Collection models) パブリックグループ構成バージョンの基本モデルを複数挿入します。
void | PublicGroupVersionMapper.update(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
void | PublicGroupVersionMapper.update(Collection models) パブリックグループ構成バージョンの基本モデルを複数更新します。
void | PublicGroupVersionMapper.delete(PublicGroupVersionBaseModel model) パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
void | PublicGroupVersionMapper.delete(Collection models) パブリックグループ構成バージョンの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.application.model.user での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.application.model.user のメソッド
UserBaseModel | UserMapper.create(String userCode) プライマリキーに該当するユーザを生成します。
UserBaseModel | UserMapper.select(String userCode) プライマリーキーで特定されるユーザの基本モデルを取得します。
void | UserMapper.insert(UserBaseModel model) ユーザの基本モデルを1つだけ挿入します。
void | UserMapper.insert(Collection models) ユーザの基本モデルを複数挿入します。
void | UserMapper.update(UserBaseModel model) ユーザの基本モデルを1つだけ更新します。
void | UserMapper.update(Collection models) ユーザの基本モデルを複数更新します。
void | UserMapper.delete(UserBaseModel model) ユーザの基本モデルを1つだけ削除します。
void | UserMapper.delete(Collection models) ユーザの基本モデルを複数削除します。

jp.co.intra_mart.foundation.datastore.common.model での MapperException の使用

MapperException をスローする jp.co.intra_mart.foundation.datastore.common.model のメソッド
static MapperFactory | MapperFactory.newInstance() マッパーファクトリを取得します。
abstract Mapper | MapperFactory.createMapper(String application, String entity, String group, String user) マッパーを生成します。
void | Mapper.init(String user, String group) マッパーを初期化します。
BaseModel | Mapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | Mapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
void | Mapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | Mapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | Mapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | Mapper.close() マッパーをクローズします。
void | IntramartDBMapper.init(String user, String group) マッパーを初期化します。
protected BaseAccessor | IntramartDBMapper.createBaseAccessor(Map primary) このマッパーに該当する基本アクセサを新規に生成します。
BaseModel | IntramartDBMapper.createBaseModel(Map keys) このマッパーに該当する基本モデルを新規に生成します。
BaseModel | IntramartDBMapper.select(Map keys) プライマリーキーで特定される基本モデルを取得します。
protected Collection | IntramartDBMapper.select(Relationship relationship, Map keys) 外部キーで特定される基本モデルをすべて取得します。
protected void | IntramartDBMapper.insert(BaseModel model) 基本モデルを1つだけ挿入します。
protected void | IntramartDBMapper.insert(Collection models) 基本モデルを複数挿入します。
protected void | IntramartDBMapper.update(BaseModel model) 基本モデルを1つだけ更新します。
protected void | IntramartDBMapper.update(Collection models) 基本モデルを複数更新します。
protected void | IntramartDBMapper.delete(BaseModel model) 基本モデルを1つだけ削除します。
protected void | IntramartDBMapper.delete(Collection models) アクセサを複数削除します。
void | IntramartDBMapper.notifyUpdate(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
void | IntramartDBMapper.notifyDelete(Relationship relationship, BaseModel model) リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
void | IntramartDBMapper.checkByBaseProperty(Relationship[] relationships, BaseModel target, BaseModel base) 基準項目によるリレーションシップの整合性制約をチェックします。
void | IntramartDBMapper.close() マッパーをクローズします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.datastore.exception.TermManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.datastore.exception.TermManagerException の使用

TermManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.common.structure 期間情報などを扱うクラスを提供します。

jp.co.intra_mart.foundation.datastore.common.structure での TermManagerException の使用

TermManagerException をスローする jp.co.intra_mart.foundation.datastore.common.structure のメソッド
static void | TermManager.validateTerm(Date activation, Date expiration) 指定された2つの日時が有効な期間を構成するかどうか調べます。
static void | TermManager.validateTerms(Term[] terms) 指定された期間配列が有効かどうかを調べます。
static Term[] | TermManager.subtract(Term[] term1, Term[] term2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Term[] | TermManager.getOverlap(Term[] term1, Term[] term2) 2つの期間配列 term1 と term2 で重なっている期間を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AccessorClosedException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorClosedException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
すべての実装インタフェース:
Serializable
public class AccessorClosedException
extends AccessorException

アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。

  • setProperty(String, Object)

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorClosedException()
コンストラクタ
AccessorClosedException(String message)
コンストラクタ
AccessorClosedException(String message, Throwable cause)
コンストラクタ
AccessorClosedException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorClosedException

public AccessorClosedException()
コンストラクタ

AccessorClosedException

public AccessorClosedException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorClosedException

public AccessorClosedException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorClosedException

public AccessorClosedException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessorException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorClosedException, AccessorIllegalPropertyValueException, DataNotFoundException, IllegalExtensionException
public class AccessorException
extends DataStoreApplicationException

アクセサで発生する例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorException()
コンストラクタ
AccessorException(String message)
コンストラクタ
AccessorException(String message, Throwable cause)
コンストラクタ
AccessorException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorException

public AccessorException()
コンストラクタ

AccessorException

public AccessorException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorException

public AccessorException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorException

public AccessorException(String message,
                         Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessorIllegalPropertyValueException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorIllegalPropertyValueException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
すべての実装インタフェース:
Serializable
public class AccessorIllegalPropertyValueException
extends AccessorException

アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorIllegalPropertyValueException()
コンストラクタ
AccessorIllegalPropertyValueException(String message)
コンストラクタ
AccessorIllegalPropertyValueException(String message, Throwable cause)
コンストラクタ
AccessorIllegalPropertyValueException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException()
コンストラクタ

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorIllegalPropertyValueException

public AccessorIllegalPropertyValueException(String message,
                                             Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessorSystemException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス AccessorSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
すべての実装インタフェース:
Serializable
public class AccessorSystemException
extends DataStoreSystemException

アクセサのプロパティに関する例外クラス

指定されたプロパティがアクセサに存在しない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
AccessorSystemException()
コンストラクタ
AccessorSystemException(String message)
コンストラクタ
AccessorSystemException(String message, Throwable cause)
コンストラクタ
AccessorSystemException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessorSystemException

public AccessorSystemException()
コンストラクタ

AccessorSystemException

public AccessorSystemException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

AccessorSystemException

public AccessorSystemException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

AccessorSystemException

public AccessorSystemException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataNotFoundException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
IllegalLocaleException, IllegalTermException
public class DataNotFoundException
extends AccessorException

アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataNotFoundException()
コンストラクタ
DataNotFoundException(String message)
コンストラクタ
DataNotFoundException(String message, Throwable cause)
コンストラクタ
DataNotFoundException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataNotFoundException

public DataNotFoundException()
コンストラクタ

DataNotFoundException

public DataNotFoundException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataNotFoundException

public DataNotFoundException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataNotFoundException

public DataNotFoundException(String message,
                             Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreApplicationException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorException, IllegalRelationshipException, ManagerException, MapperException, TermManagerException
public class DataStoreApplicationException
extends FoundationException

アプリケーション共通マスタで発生するアプリケーション例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataStoreApplicationException()
コンストラクタ
DataStoreApplicationException(String message)
コンストラクタ
DataStoreApplicationException(String message, Throwable cause)
コンストラクタ
DataStoreApplicationException(Throwable cause)
コンストラクタ
メソッドの概要
String | getKey() エラーメッセージを作成するための識別子を取得します。
String[] | getValues() エラーメッセージで使用する置換用の文字列を取得します。
void | setKey(String key) エラーメッセージを作成するためのキーを取得します。
void | setValues(String[] values) エラーメッセージで使用する置換用の文字列を設定します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreApplicationException

public DataStoreApplicationException()
コンストラクタ

DataStoreApplicationException

public DataStoreApplicationException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataStoreApplicationException

public DataStoreApplicationException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataStoreApplicationException

public DataStoreApplicationException(String message,
                                     Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
メソッドの詳細

setKey

public void setKey(String key)
エラーメッセージを作成するためのキーを取得します。

パラメータ:
key - メッセージキー

setValues

public void setValues(String[] values)
エラーメッセージで使用する置換用の文字列を設定します。

パラメータ:
values - 置換用文字列

getKey

public String getKey()
エラーメッセージを作成するための識別子を取得します。

戻り値:
メッセージキー

getValues

public String[] getValues()
エラーメッセージで使用する置換用の文字列を取得します。

戻り値:
置換用文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreConfigException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
すべての実装インタフェース:
Serializable
public class DataStoreConfigException
extends DataStoreSystemException

アプリケーション共通マスタの設定に関する例外クラス

アプリケーション共通マスタの設定に不整合がある場合にスローする。

関連項目:
直列化された形式

コンストラクタの概要
DataStoreConfigException()
詳細メッセージを指定しないで DataStoreConfigException を構築します。
DataStoreConfigException(String msg)
指定された詳細メッセージを持つ DataStoreConfigException を構築します。
DataStoreConfigException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConfigException(Throwable throwable)
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreConfigException

public DataStoreConfigException()
詳細メッセージを指定しないで DataStoreConfigException を構築します。

DataStoreConfigException

public DataStoreConfigException(String msg)
指定された詳細メッセージを持つ DataStoreConfigException を構築します。

パラメータ:
msg - 詳細メッセージ

DataStoreConfigException

public DataStoreConfigException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外

DataStoreConfigException

public DataStoreConfigException(Throwable throwable)
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataStoreSystemException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス DataStoreSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessorSystemException, DataStoreConfigException, MapperDAOException
public class DataStoreSystemException
extends FoundationRuntimeException

アプリケーション共通マスタで発生するシステム例外の基底クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
DataStoreSystemException()
コンストラクタ
DataStoreSystemException(String message)
コンストラクタ
DataStoreSystemException(String message, Throwable cause)
コンストラクタ
DataStoreSystemException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataStoreSystemException

public DataStoreSystemException()
コンストラクタ

DataStoreSystemException

public DataStoreSystemException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

DataStoreSystemException

public DataStoreSystemException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

DataStoreSystemException

public DataStoreSystemException(String message,
                                Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalExtensionException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalExtensionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
すべての実装インタフェース:
Serializable
public class IllegalExtensionException
extends AccessorException

拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalExtensionException()
コンストラクタ
IllegalExtensionException(String message)
コンストラクタ
IllegalExtensionException(String message, Throwable cause)
コンストラクタ
IllegalExtensionException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalExtensionException

public IllegalExtensionException()
コンストラクタ

IllegalExtensionException

public IllegalExtensionException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalExtensionException

public IllegalExtensionException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalExtensionException

public IllegalExtensionException(String message,
                                 Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalLocaleException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalLocaleException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                            拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
すべての実装インタフェース:
Serializable
public class IllegalLocaleException
extends DataNotFoundException

アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalLocaleException()
コンストラクタ
IllegalLocaleException(String message)
コンストラクタ
IllegalLocaleException(String message, Throwable cause)
コンストラクタ
IllegalLocaleException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalLocaleException

public IllegalLocaleException()
コンストラクタ

IllegalLocaleException

public IllegalLocaleException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalLocaleException

public IllegalLocaleException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalLocaleException

public IllegalLocaleException(String message,
                              Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalRelationshipException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalRelationshipException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
すべての実装インタフェース:
Serializable
public class IllegalRelationshipException
extends DataStoreApplicationException

リレーションシップに関する例外クラス

リレーションシップの整合性が正しくない場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalRelationshipException()
コンストラクタ
IllegalRelationshipException(String message)
コンストラクタ
IllegalRelationshipException(String message, Throwable cause)
コンストラクタ
IllegalRelationshipException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalRelationshipException

public IllegalRelationshipException()
コンストラクタ

IllegalRelationshipException

public IllegalRelationshipException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalRelationshipException

public IllegalRelationshipException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalRelationshipException

public IllegalRelationshipException(String message,
                                    Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalTermException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス IllegalTermException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.AccessorException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                            拡張 jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
すべての実装インタフェース:
Serializable
public class IllegalTermException
extends DataNotFoundException

アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalTermException()
コンストラクタ
IllegalTermException(String message)
コンストラクタ
IllegalTermException(String message, Throwable cause)
コンストラクタ
IllegalTermException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalTermException

public IllegalTermException()
コンストラクタ

IllegalTermException

public IllegalTermException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

IllegalTermException

public IllegalTermException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

IllegalTermException

public IllegalTermException(String message,
                            Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImportException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス ImportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.datastore.exception.ImportException
すべての実装インタフェース:
Serializable
public class ImportException
extends Exception

アプリケーション共通マスタのインポートに関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ImportException()
コンストラクタ
ImportException(String message)
コンストラクタ
ImportException(String message, Throwable cause)
コンストラクタ
ImportException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImportException

public ImportException()
コンストラクタ

ImportException

public ImportException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ImportException

public ImportException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ImportException

public ImportException(String message,
                       Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス ManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.ManagerException
すべての実装インタフェース:
Serializable
public class ManagerException
extends DataStoreApplicationException

マネージャに関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
ManagerException()
コンストラクタ
ManagerException(String message)
コンストラクタ
ManagerException(String message, Throwable cause)
コンストラクタ
ManagerException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ManagerException

public ManagerException()
コンストラクタ

ManagerException

public ManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

ManagerException

public ManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

ManagerException

public ManagerException(String message,
                        Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperDAOException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス MapperDAOException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
                        拡張 jp.co.intra_mart.foundation.datastore.exception.MapperDAOException
すべての実装インタフェース:
Serializable
public class MapperDAOException
extends DataStoreSystemException

マッパーのデータベース接続に関する例外クラス

マッパーがデータベース接続で問題が発生した場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MapperDAOException()
コンストラクタ
MapperDAOException(String message)
コンストラクタ
MapperDAOException(String message, Throwable cause)
コンストラクタ
MapperDAOException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MapperDAOException

public MapperDAOException()
コンストラクタ

MapperDAOException

public MapperDAOException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

MapperDAOException

public MapperDAOException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

MapperDAOException

public MapperDAOException(String message,
                          Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MapperException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス MapperException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.MapperException
すべての実装インタフェース:
Serializable
public class MapperException
extends DataStoreApplicationException

マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MapperException()
コンストラクタ
MapperException(String message)
コンストラクタ
MapperException(String message, Throwable cause)
コンストラクタ
MapperException(Throwable cause)
コンストラクタ
メソッドの概要
protected String | getBaseName() メッセージを取得するためのリソースバンドルの基底名を返します。
static void | setBaseName(String baseName) リソースバンドルの基底名を設定します。
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MapperException

public MapperException()
コンストラクタ

MapperException

public MapperException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

MapperException

public MapperException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

MapperException

public MapperException(String message,
                       Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
メソッドの詳細

getBaseName

protected String getBaseName()
メッセージを取得するためのリソースバンドルの基底名を返します。

戻り値:
基底名

setBaseName

public static void setBaseName(String baseName)
リソースバンドルの基底名を設定します。

パラメータ:
baseName - 基底名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.datastore.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.datastore.exception
例外
AccessorClosedException
AccessorException
AccessorIllegalPropertyValueException
AccessorSystemException
DataNotFoundException
DataStoreApplicationException
DataStoreConfigException
DataStoreSystemException
IllegalExtensionException
IllegalLocaleException
IllegalRelationshipException
IllegalTermException
ImportException
ManagerException
MapperDAOException
MapperException
TermManagerException


jp.co.intra_mart.foundation.datastore.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exception

アプリケーション共通マスタで発生する例外クラスを提供します。

参照:
説明

例外の概要
AccessorClosedException | アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorException | アクセサで発生する例外の基底クラス
AccessorIllegalPropertyValueException | アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
AccessorSystemException | アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
DataNotFoundException | アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
DataStoreApplicationException | アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreConfigException | アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
DataStoreSystemException | アプリケーション共通マスタで発生するシステム例外の基底クラス
IllegalExtensionException | 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException | アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
IllegalRelationshipException | リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
IllegalTermException | アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
ImportException | アプリケーション共通マスタのインポートに関する例外クラス
ManagerException | マネージャに関する例外クラス
MapperDAOException | マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。
MapperException | マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
TermManagerException | 期間に関する例外クラス

パッケージ jp.co.intra_mart.foundation.datastore.exception の説明

アプリケーション共通マスタで発生する例外クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.datastore.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.datastore.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.datastore.exception.AccessorException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
              • class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
              • class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
            • class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
            • class jp.co.intra_mart.foundation.datastore.exception.ManagerException
            • class jp.co.intra_mart.foundation.datastore.exception.MapperException
            • class jp.co.intra_mart.foundation.datastore.exception.TermManagerException
        • class jp.co.intra_mart.foundation.datastore.exception.ImportException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
              • class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.datastore.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.datastore.exception の使用

jp.co.intra_mart.foundation.datastore.exception を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
ImportException
アプリケーション共通マスタのインポートに関する例外クラス
ManagerException
マネージャに関する例外クラス

jp.co.intra_mart.foundation.datastore.application.model.category.category_class により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.category.detail により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.company により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.department により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.main により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.post により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.company.version により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.private_group.group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.category により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.group により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.set により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.public_group.version により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.application.model.user により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.common.accessor により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorClosedException
アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorIllegalPropertyValueException
アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。
DataNotFoundException
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
IllegalExtensionException
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。

jp.co.intra_mart.foundation.datastore.common.model により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
DataStoreSystemException
アプリケーション共通マスタで発生するシステム例外の基底クラス
IllegalExtensionException
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalLocaleException
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalTermException
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
MapperException
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。

jp.co.intra_mart.foundation.datastore.common.structure により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
TermManagerException
期間に関する例外クラス

jp.co.intra_mart.foundation.datastore.exception により使用される jp.co.intra_mart.foundation.datastore.exception のクラス
AccessorException
アクセサで発生する例外の基底クラス
DataNotFoundException
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
DataStoreApplicationException
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreSystemException
アプリケーション共通マスタで発生するシステム例外の基底クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


TermManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.datastore.exception
クラス TermManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
                    拡張 jp.co.intra_mart.foundation.datastore.exception.TermManagerException
すべての実装インタフェース:
Serializable
public class TermManagerException
extends DataStoreApplicationException

期間に関する例外クラス

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
TermManagerException()
コンストラクタ
TermManagerException(String message)
コンストラクタ
TermManagerException(String message, Throwable cause)
コンストラクタ
TermManagerException(Throwable cause)
コンストラクタ
クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException から継承したメソッド
getKey, getValues, setKey, setValues
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TermManagerException

public TermManagerException()
コンストラクタ

TermManagerException

public TermManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

TermManagerException

public TermManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

TermManagerException

public TermManagerException(String message,
                            Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.drawer.AbstractDrawer の使用

AbstractDrawer を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での AbstractDrawer の使用

jp.co.intra_mart.foundation.graph での AbstractDrawer のサブクラス
class | BarGraphDrawer 棒グラフを描画します。
class | CircleGraphDrawer 円グラフを描画します。
class | LineGraphDrawer 折れ線グラフを描画します。
class | PortFolioDrawer ポートフォリオを描画します。
class | RadarChartDrawer レーダーチャートを描画します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractDrawer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.drawer
クラス AbstractDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BarGraphDrawer, CircleGraphDrawer, LineGraphDrawer, PortFolioDrawer, RadarChartDrawer
public abstract class AbstractDrawer
extends Object
implements Serializable

画像ファイル出力用のスケルトンクラスです。

サブクラスでは、createImage メソッドをオーバーライドして、 画像を描画する機能を実装する必要があります。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
protected AbstractDrawer()
唯一のコンストラクタ。
メソッドの概要
protected abstract void | createImage(Graphics g) 画像ファイルを描画します。
String | getContentType() 画像ファイルのフォーマットを返却します。
int | getHeight() 画像ファイルの高さを返却します。
int | getWidth() 画像ファイルの幅を返却します。
void | putImage(OutputStream out) 指定のストリームにファイルを出力します。
void | setContentType(String type) 画像ファイルのフォーマットを設定します。
void | setHeight(int height) 画像ファイルの高さを設定します。
void | setWidth(int width) 画像ファイルの幅を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractDrawer

protected AbstractDrawer()
唯一のコンストラクタ。

メソッドの詳細

createImage

protected abstract void createImage(Graphics g)
画像ファイルを描画します。
サブクラスでは、このメソッドをオーバーライドする必要があります。

パラメータ:
g - グラフィックコンテキスト

setContentType

public void setContentType(String type)
画像ファイルのフォーマットを設定します。

パラメータ:
type - コンテントタイプ
"png" または "jpeg" かを指定。
初期のコンテントタイプはpngです。

setWidth

public void setWidth(int width)
画像ファイルの幅を設定します。

パラメータ:
width - 幅

setHeight

public void setHeight(int height)
画像ファイルの高さを設定します。

getContentType

public String getContentType()
画像ファイルのフォーマットを返却します。 初期のコンテントタイプはpngです。

戻り値:
コンテントタイプ

getWidth

public int getWidth()
画像ファイルの幅を返却します。

戻り値:
幅

getHeight

public int getHeight()
画像ファイルの高さを返却します。

戻り値:
高さ

putImage

public void putImage(OutputStream out)
              throws IOException
指定のストリームにファイルを出力します。
画像フォーマットは#setContentType()によって決定されます。

パラメータ:
out - 出力先ストリーム
例外:
IOException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.drawer (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.drawer
クラス
AbstractDrawer


jp.co.intra_mart.foundation.drawer (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.drawer

画像ファイル出力用クラスを提供します。

参照:
説明

クラスの概要
AbstractDrawer 画像ファイル出力用のスケルトンクラスです。

パッケージ jp.co.intra_mart.foundation.drawer の説明

画像ファイル出力用クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.drawer クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.drawer の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.drawer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.drawer の使用

jp.co.intra_mart.foundation.drawer を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph により使用される jp.co.intra_mart.foundation.drawer のクラス
AbstractDrawer
画像ファイル出力用のスケルトンクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.ChangedListenerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.ChangedListenerException の使用

ChangedListenerException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.company のメソッド
void | CompanyChangedListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | CompanyChangedListener.departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | CompanyChangedListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | CompanyChangedListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.private_group での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.private_group のメソッド
void | PrivateGroupChangedListener.privateGroupAdded(String groupId, PrivateGroup group) プライベートグループがデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupUpdated(String groupId, PrivateGroup group) プライベートグループがデータストアに更新された後に呼び出されます。
void | PrivateGroupChangedListener.privateGroupDeleted(String groupId, PrivateGroup group) プライベートグループがデータストアから削除された後に呼び出されます。
void | PrivateGroupChangedListener.memberSet(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
void | PrivateGroupChangedListener.memberDeleted(String groupId, PrivateGroupAttach member) プライベートグループ所属情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.public_group での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.public_group のメソッド
void | PublicGroupChangedListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | PublicGroupChangedListener.publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

jp.co.intra_mart.foundation.datastore.application.domain.user での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.datastore.application.domain.user のメソッド
void | UserChangedListener.userAdded(String groupId, User user) ユーザ情報がデータストアに登録された後に呼び出されます。
void | UserChangedListener.userUpdated(String groupId, User user) ユーザ情報がデータストアに対して更新された後に呼び出されます。
void | UserChangedListener.userDeleted(String groupId, User user) ユーザ情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.account での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | RoleChangedAccountListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedAccountListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedAccountListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedAccountListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedAccountListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | AccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | AccountChangedListener.accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountChangedListener.accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | AccountChangedListener.accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | RoleChangedMenuListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedMenuListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedMenuListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedMenuListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedMenuListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | PublicGroupChangedMenuListener.groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | PublicGroupChangedMenuListener.publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | PublicGroupChangedMenuListener.versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | CompanyChangedMenuListener.departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | CompanyChangedMenuListener.versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | CompanyChangedMenuListener.postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | CompanyChangedMenuListener.postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。

jp.co.intra_mart.foundation.security.role での ChangedListenerException の使用

ChangedListenerException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleChangedListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedListener.roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RoleChangedListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleChangedListener.subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RoleChangedListener.subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.FoundationException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.FoundationException の使用

FoundationException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.exception での FoundationException の使用

jp.co.intra_mart.foundation.datastore.exception での FoundationException のサブクラス
class | AccessorClosedException アクセサのクローズ時に発生する例外クラス アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
class | AccessorException アクセサで発生する例外の基底クラス
class | AccessorIllegalPropertyValueException アクセサのプロパティ設定に関する例外クラス アクセサに不正な値が設定された場合にスローする。
class | DataNotFoundException アクセサのプロパティ値の取得に関する例外クラス 指定されたプロパティに対する値が設定されていない場合にスローする。
class | DataStoreApplicationException アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
class | IllegalExtensionException 拡張アクセサに関する例外クラス 拡張アクセサに対して不正な操作が行われた場合にスローする。
class | IllegalLocaleException アクセサが保持する言語に関する例外クラス アクセサが保持していない言語を要求された場合にスローする。
class | IllegalRelationshipException リレーションシップに関する例外クラス リレーションシップの整合性が正しくない場合にスローする。
class | IllegalTermException アクセサが保持する期間に関する例外クラス アクセサが保持しない日時または期間が指定されたときにスローする。
class | ManagerException マネージャに関する例外クラス
class | MapperException マッパーに関する例外クラス マッパーの処理中に問題が発生した場合にスローする。
class | TermManagerException 期間に関する例外クラス

jp.co.intra_mart.foundation.exception での FoundationException の使用

jp.co.intra_mart.foundation.exception での FoundationException のサブクラス
 class ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.exception での FoundationException の使用

jp.co.intra_mart.foundation.security.exception での FoundationException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityException アクセスセキュリティの基本となる例外クラス。
class | AccessSecurityExportException エクスポート時例外クラス。
class | AccessSecurityImportException インポート時例外クラス。
class | AccessSecurityListenerExcpetion アクセスセキュリティリスナーの例外クラス。
class | AccessSecurityReadException アクセスセキュリティ情報の取得例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | AccessSecurityWriteException アクセスセキュリティ情報の更新例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | IllegalArgumentException 引数が不正の例外クラス。
class | NoFilterException HTTPリクエスト・レスポンス取得例外クラス。
class | NoSessionCookieException セッション情報クッキー取得例外クラス。
class | NoSessionException セッション取得例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotFoundDataSourceException データソースの参照名未解決例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.exception.FoundationRuntimeException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.exception.FoundationRuntimeException の使用

FoundationRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.exception での FoundationRuntimeException の使用

jp.co.intra_mart.foundation.datastore.exception での FoundationRuntimeException のサブクラス
class | AccessorSystemException アクセサのプロパティに関する例外クラス 指定されたプロパティがアクセサに存在しない場合にスローする。
class | DataStoreConfigException アプリケーション共通マスタの設定に関する例外クラス アプリケーション共通マスタの設定に不整合がある場合にスローする。
class | DataStoreSystemException アプリケーション共通マスタで発生するシステム例外の基底クラス
class | MapperDAOException マッパーのデータベース接続に関する例外クラス マッパーがデータベース接続で問題が発生した場合にスローする。

jp.co.intra_mart.foundation.security.exception での FoundationRuntimeException の使用

jp.co.intra_mart.foundation.security.exception での FoundationRuntimeException のサブクラス
class | AccessSecurityConfigException アクセスセキュリティ設定に関する例外クラス。
class | AccessSecurityRuntimeException アクセスセキュリティランタイム例外クラス。
class | SystemConfigException システム設定に関する例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ChangedListenerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス ChangedListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.exception.ChangedListenerException
すべての実装インタフェース:
Serializable
public class ChangedListenerException
extends FoundationException

更新リスナーの例外クラス。

更新リスナー内で例外が発せした場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ChangedListenerException()
コンストラクタ。
ChangedListenerException(String message)
コンストラクタ。
ChangedListenerException(String message, Throwable cause)
コンストラクタ。
ChangedListenerException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ChangedListenerException

public ChangedListenerException()
コンストラクタ。

ChangedListenerException

public ChangedListenerException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

ChangedListenerException

public ChangedListenerException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

ChangedListenerException

public ChangedListenerException(String message,
                                Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FoundationException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス FoundationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityException, ChangedListenerException, DataStoreApplicationException
public class FoundationException
extends Exception

システム基盤共通例外クラス。

システムでスローされる例外のスーパークラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FoundationException()
コンストラクタ。
FoundationException(String message)
コンストラクタ。
FoundationException(String message, Throwable cause)
コンストラクタ。
FoundationException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FoundationException

public FoundationException()
コンストラクタ。

FoundationException

public FoundationException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

FoundationException

public FoundationException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

FoundationException

public FoundationException(String message,
                           Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FoundationRuntimeException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.exception
クラス FoundationRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityRuntimeException, DataStoreSystemException
public class FoundationRuntimeException
extends RuntimeException

システム基盤共通ランタイム例外クラス。

システムでスローされるランタイム例外のスーパークラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FoundationRuntimeException()
コンストラクタ。
FoundationRuntimeException(String message)
コンストラクタ。
FoundationRuntimeException(String message, Throwable cause)
コンストラクタ。
FoundationRuntimeException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FoundationRuntimeException

public FoundationRuntimeException()
コンストラクタ。

FoundationRuntimeException

public FoundationRuntimeException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

FoundationRuntimeException

public FoundationRuntimeException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

FoundationRuntimeException

public FoundationRuntimeException(String message,
                                  Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.exception
例外
ChangedListenerException
FoundationException
FoundationRuntimeException


jp.co.intra_mart.foundation.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.exception

システムでスローされる例外クラスを提供します。

参照:
説明

例外の概要
ChangedListenerException | 更新リスナーの例外クラス。
FoundationException | システム基盤共通例外クラス。
FoundationRuntimeException | システム基盤共通ランタイム例外クラス。

パッケージ jp.co.intra_mart.foundation.exception の説明

システムでスローされる例外クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.exception.ChangedListenerException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.exception の使用

jp.co.intra_mart.foundation.exception を使用しているパッケージ
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.datastore.application.domain.company により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.private_group により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.public_group により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.application.domain.user により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.datastore.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。
FoundationRuntimeException
システム基盤共通ランタイム例外クラス。

jp.co.intra_mart.foundation.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.exception により使用される jp.co.intra_mart.foundation.exception のクラス
FoundationException
システム基盤共通例外クラス。
FoundationRuntimeException
システム基盤共通ランタイム例外クラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.exception のクラス
ChangedListenerException
更新リスナーの例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.BarGraphDrawer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.BarGraphDrawer の使用

jp.co.intra_mart.foundation.graph.BarGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.BarGraphObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.BarGraphObject の使用

BarGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での BarGraphObject の使用

BarGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 BarGraphObject BarGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

BarGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | BarGraphDrawer.addData(BarGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | BarGraphDrawer.addData(int index, BarGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.CircleGraphDrawer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.CircleGraphDrawer の使用

jp.co.intra_mart.foundation.graph.CircleGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.CircleGraphObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.CircleGraphObject の使用

CircleGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での CircleGraphObject の使用

CircleGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 CircleGraphObject CircleGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

CircleGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | CircleGraphDrawer.addData(CircleGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | CircleGraphDrawer.addData(int index, CircleGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.LineGraphDrawer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.LineGraphDrawer の使用

jp.co.intra_mart.foundation.graph.LineGraphDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.LineGraphObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.LineGraphObject の使用

LineGraphObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での LineGraphObject の使用

LineGraphObject を返す jp.co.intra_mart.foundation.graph のメソッド
 LineGraphObject LineGraphDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

LineGraphObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | LineGraphDrawer.addData(LineGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | LineGraphDrawer.addData(int index, LineGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.PortFolioDrawer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.PortFolioDrawer の使用

jp.co.intra_mart.foundation.graph.PortFolioDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.PortFolioObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.PortFolioObject の使用

PortFolioObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での PortFolioObject の使用

PortFolioObject を返す jp.co.intra_mart.foundation.graph のメソッド
 PortFolioObject PortFolioDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

PortFolioObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | PortFolioDrawer.addData(PortFolioObject obj) 描画オブジェクトに新しいデータを追加します。
void | PortFolioDrawer.addData(int index, PortFolioObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.RadarChartDrawer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.RadarChartDrawer の使用

jp.co.intra_mart.foundation.graph.RadarChartDrawer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.graph.RadarChartObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.graph.RadarChartObject の使用

RadarChartObject を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph での RadarChartObject の使用

RadarChartObject を返す jp.co.intra_mart.foundation.graph のメソッド
 RadarChartObject RadarChartDrawer.getData(int index)
リスト内の指定された位置にあるデータを返します。

RadarChartObject 型のパラメータを持つ jp.co.intra_mart.foundation.graph のメソッド
void | RadarChartDrawer.addData(RadarChartObject obj) 描画オブジェクトに新しいデータを追加します。
void | RadarChartDrawer.addData(int index, RadarChartObject obj) 指定された位置に、指定された描画オブジェクトを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


BarGraphDrawer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス BarGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.BarGraphDrawer
すべての実装インタフェース:
Serializable
public class BarGraphDrawer
extends AbstractDrawer

棒グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
BarGraphDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現で棒グラフを作成します。
BarGraphDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現で棒グラフを作成します。
メソッドの概要
void | addData(BarGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | addData(int index, BarGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 棒グラフを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
BarGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

コンストラクタの詳細

BarGraphDrawer

public BarGraphDrawer(int min,
                      int max,
                      int count)
ｙ軸の目盛値をint表現で棒グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

BarGraphDrawer

public BarGraphDrawer(double min,
                      double max,
                      double count)
ｙ軸の目盛値をdouble表現で棒グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(BarGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    BarGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public BarGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
棒グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BarGraphObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス BarGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.BarGraphObject
すべての実装インタフェース:
Serializable
public class BarGraphObject
extends Object
implements Serializable

BarGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
BarGraphObject()
デフォルトのデータオブジェクトを作成します。
BarGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() 棒の色を返します。
double | getData(int index) 指定された位置にある値を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) 棒の色を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BarGraphObject

public BarGraphObject()
デフォルトのデータオブジェクトを作成します。

BarGraphObject

public BarGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
棒の色を返します。

戻り値:
color 描画される棒の色

setColor

public void setColor(Color color)
棒の色を設定します。

パラメータ:
color - 描画される棒の色
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CircleGraphDrawer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス CircleGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.CircleGraphDrawer
すべての実装インタフェース:
Serializable
public class CircleGraphDrawer
extends AbstractDrawer

円グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static int | DEFAULT_CAPTION_MARGIN 標準のキャプション表示位置のマージン
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
CircleGraphDrawer()
ｙ軸の目盛値をint表現で円グラフを作成します。
メソッドの概要
void | addData(CircleGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | addData(int index, CircleGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 円グラフを描画します。
int | getCaptionMargin() キャプション表示位置のマージンを返します。
CircleGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaptionMargin(int margin) キャプション表示位置のマージンを設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_CAPTION_MARGIN

public static int DEFAULT_CAPTION_MARGIN
標準のキャプション表示位置のマージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

コンストラクタの詳細

CircleGraphDrawer

public CircleGraphDrawer()
ｙ軸の目盛値をint表現で円グラフを作成します。

例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

addData

public void addData(CircleGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

addData

public void addData(int index,
                    CircleGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

getData

public CircleGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
戻り値:
jp.co.intra_mart.foundation.graph.RadarChartObject
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

setCaptionMargin

public void setCaptionMargin(int margin)
キャプション表示位置のマージンを設定します。

パラメータ:
margin - キャプション表示位置のマージン

getCaptionMargin

public int getCaptionMargin()
キャプション表示位置のマージンを返します。

戻り値:
int キャプション表示位置のマージン

createImage

protected void createImage(Graphics g)
円グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CircleGraphObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス CircleGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.CircleGraphObject
すべての実装インタフェース:
Serializable
public class CircleGraphObject
extends Object
implements Serializable

CircleGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
CircleGraphObject(double number, Color color)
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(double number, Color color, String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
CircleGraphObject(int number, Color color)
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(int number, Color color, String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
メソッドの概要
String | getCaption() キャプション文字列を返します。
Color | getColor() グラフの色を返します。
double | getData() グラフ値を返します。
Color | getFontColor() キャプションの文字色を返します。
int | getFontSize() キャプションの文字サイズを返します。
boolean | isDouble() グラフ値がdouble表現かどうかを判定します。
void | setCaption(String caption) キャプション文字列を返します。
void | setFontColor(Color font_color) キャプションの文字色を設定します。
void | setFontSize(int font_size) キャプションの文字サイズを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CircleGraphObject

public CircleGraphObject(double number,
                         Color color)
グラフ値と色を指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
number - グラフの値
color - 描画されるグラフの色

CircleGraphObject

public CircleGraphObject(int number,
                         Color color)
グラフ値と色を指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
number - グラフの値
color - 描画されるグラフの色

CircleGraphObject

public CircleGraphObject(double number,
                         Color color,
                         String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
number - グラフの値
color - 描画されるグラフの色
caption - キャプションの文字列

CircleGraphObject

public CircleGraphObject(int number,
                         Color color,
                         String caption)
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
number - グラフの値
color - 描画されるグラフの色
caption - キャプションの文字列
メソッドの詳細

getData

public double getData()
グラフ値を返します。

戻り値:
double 値

getColor

public Color getColor()
グラフの色を返します。

戻り値:
color 描画されるグラフの色

getCaption

public String getCaption()
キャプション文字列を返します。

戻り値:
String キャプション文字列

setCaption

public void setCaption(String caption)
キャプション文字列を返します。

戻り値:
String キャプション文字列

getFontColor

public Color getFontColor()
キャプションの文字色を返します。

戻り値:
Color キャプションの文字色

setFontColor

public void setFontColor(Color font_color)
キャプションの文字色を設定します。

パラメータ:
font_color - キャプションの文字色

getFontSize

public int getFontSize()
キャプションの文字サイズを返します。

戻り値:
int キャプションの文字サイズ

setFontSize

public void setFontSize(int font_size)
キャプションの文字サイズを設定します。

パラメータ:
font_size - キャプションの文字サイズ

isDouble

public boolean isDouble()
グラフ値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineGraphDrawer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス LineGraphDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.LineGraphDrawer
すべての実装インタフェース:
Serializable
public class LineGraphDrawer
extends AbstractDrawer

折れ線グラフを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
LineGraphDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。
LineGraphDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現で折れ線グラフを作成します。
メソッドの概要
void | addData(int index, LineGraphObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(LineGraphObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) 折れ線グラフを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
LineGraphObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

コンストラクタの詳細

LineGraphDrawer

public LineGraphDrawer(int min,
                       int max,
                       int count)
ｙ軸の目盛値をint表現で折れ線グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

LineGraphDrawer

public LineGraphDrawer(double min,
                       double max,
                       double count)
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(LineGraphObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    LineGraphObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public LineGraphObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
折れ線グラフを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineGraphObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス LineGraphObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.LineGraphObject
すべての実装インタフェース:
Serializable
public class LineGraphObject
extends Object
implements Serializable

LineGraphDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static Stroke DEFAULT_STROKE
コンストラクタの概要
LineGraphObject()
デフォルトのデータオブジェクトを作成します。
LineGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。
LineGraphObject(Color color, Stroke stroke)
線の色と描画属性を指定して、データオブジェクトを作成します。
LineGraphObject(Stroke stroke)
線の描画属性を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() 線の色を返します。
double | getData(int index) 指定された位置にある値を返します。
Stroke | getStroke() 描画される線の描画属性を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) 線の色を設定します。
void | setStroke(Stroke stroke) 描画される線の描画属性を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_STROKE

public static Stroke DEFAULT_STROKE
コンストラクタの詳細

LineGraphObject

public LineGraphObject()
デフォルトのデータオブジェクトを作成します。

LineGraphObject

public LineGraphObject(Color color)
線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色

LineGraphObject

public LineGraphObject(Stroke stroke)
線の描画属性を指定して、データオブジェクトを作成します。

パラメータ:
stroke - 描画される線の描画属性

LineGraphObject

public LineGraphObject(Color color,
                       Stroke stroke)
線の色と描画属性を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
stroke - 描画される線の描画属性
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
線の色を返します。

戻り値:
color 描画される線の色

getStroke

public Stroke getStroke()
描画される線の描画属性を返します。

戻り値:
描画される線の描画属性

setColor

public void setColor(Color color)
線の色を設定します。

パラメータ:
color - 描画される線の色

setStroke

public void setStroke(Stroke stroke)
描画される線の描画属性を設定します。

パラメータ:
stroke - 描画される線の描画属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.graph (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.graph
クラス
BarGraphDrawer
BarGraphObject
CircleGraphDrawer
CircleGraphObject
LineGraphDrawer
LineGraphObject
PortFolioDrawer
PortFolioObject
RadarChartDrawer
RadarChartObject


jp.co.intra_mart.foundation.graph (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.graph

グラフ描画に関するクラスを提供します。

参照:
説明

クラスの概要
BarGraphDrawer | 棒グラフを描画します。
BarGraphObject | BarGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphDrawer | 円グラフを描画します。
CircleGraphObject | CircleGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphDrawer | 折れ線グラフを描画します。
LineGraphObject | LineGraphDrawerクラスのデータを保存するオブジェクトです。
PortFolioDrawer | ポートフォリオを描画します。
PortFolioObject | PortFolioDrawerクラスのデータを保存するオブジェクトです。
RadarChartDrawer | レーダーチャートを描画します。
RadarChartObject | RadarChartDrawerクラスのデータを保存するオブジェクトです。

パッケージ jp.co.intra_mart.foundation.graph の説明

グラフ描画に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.graph クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.graph の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.graph.BarGraphDrawer
      • class jp.co.intra_mart.foundation.graph.CircleGraphDrawer
      • class jp.co.intra_mart.foundation.graph.LineGraphDrawer
      • class jp.co.intra_mart.foundation.graph.PortFolioDrawer
      • class jp.co.intra_mart.foundation.graph.RadarChartDrawer
    • class jp.co.intra_mart.foundation.graph.BarGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.CircleGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.LineGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.PortFolioObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.RadarChartObject (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.graph の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.graph の使用

jp.co.intra_mart.foundation.graph を使用しているパッケージ
jp.co.intra_mart.foundation.graph グラフ描画に関するクラスを提供します。

jp.co.intra_mart.foundation.graph により使用される jp.co.intra_mart.foundation.graph のクラス
BarGraphObject
BarGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphObject
CircleGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphObject
LineGraphDrawerクラスのデータを保存するオブジェクトです。
PortFolioObject
PortFolioDrawerクラスのデータを保存するオブジェクトです。
RadarChartObject
RadarChartDrawerクラスのデータを保存するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PortFolioDrawer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス PortFolioDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.PortFolioDrawer
すべての実装インタフェース:
Serializable
public class PortFolioDrawer
extends AbstractDrawer

ポートフォリオを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static Color | DEFAULT_GRAPH_BACKGROUND_COLOR 標準のグラフ領域の背景色
static Color | DEFAULT_GRAPH_BORDER_COLOR 標準のグラフ領域のボーダー色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
static String | SCALE_POSITION_CENTER ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定
static String | SCALE_POSITION_SIDE ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定
コンストラクタの概要
PortFolioDrawer(double x_center, double x_size, double x_count, double y_center, double y_size, double y_count)
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。
PortFolioDrawer(int x_center, int x_size, int x_count, int y_center, int y_size, int y_count)
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。
メソッドの概要
void | addData(int index, PortFolioObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(PortFolioObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) ポートフォリオを描画します。
Color | getCaptionColor() キャプションの文字色を返します。
double | getCenterPointX() ｘ軸の中心値を返します。
double | getCenterPointY() ｙ軸の中心値を返します。
PortFolioObject | getData(int index) リスト内の指定された位置にあるデータを返します。
double | getDataSizeX() ｘ軸の中心値からのデータサイズを返します。
double | getDataSizeY() ｙ軸の中心値からのデータサイズを返します。
Color | getGraphBackgroundColor() グラフ領域の背景色を返します。
Color | getGraphBorderColor() グラフ領域のボーダーの色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getScaleCountX() ｘ軸の目盛間隔を返します。
double | getScaleCountY() ｙ軸の目盛間隔を返します。
String | getScalePosition() ｘ軸、ｙ軸の目盛りの表示位置を返します。
boolean | isDouble() ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setGraphBackgroundColor(Color color) グラフ領域の背景色を設定します。
void | setGraphBorderColor(Color color) グラフ領域のボーダーの色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
void | setScalePosition(String scale_position) ｘ軸、ｙ軸の目盛りの表示位置を設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_BACKGROUND_COLOR

public static Color DEFAULT_GRAPH_BACKGROUND_COLOR
標準のグラフ領域の背景色

DEFAULT_GRAPH_BORDER_COLOR

public static Color DEFAULT_GRAPH_BORDER_COLOR
標準のグラフ領域のボーダー色

SCALE_POSITION_SIDE

public static String SCALE_POSITION_SIDE
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定

SCALE_POSITION_CENTER

public static String SCALE_POSITION_CENTER
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定

コンストラクタの詳細

PortFolioDrawer

public PortFolioDrawer(int x_center,
                       int x_size,
                       int x_count,
                       int y_center,
                       int y_size,
                       int y_count)
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。

パラメータ:
x_center - ｘ軸の中心値
x_size - ｘ軸の中心値からのデータサイズ
x_count - ｘ軸の目盛り間隔
y_center - ｙ軸の中心値
y_size - ｙ軸の中心値からのデータサイズ
y_count - ｙ軸の目盛り間隔
例外:
IllegalArgumentException - x_count <= 0 または y_count <= 0

PortFolioDrawer

public PortFolioDrawer(double x_center,
                       double x_size,
                       double x_count,
                       double y_center,
                       double y_size,
                       double y_count)
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。

パラメータ:
x_center - ｘ軸の中心値
x_size - ｘ軸の中心値からのデータサイズ
x_count - ｘ軸の目盛り間隔
y_center - ｙ軸の中心値
y_size - ｙ軸の中心値からのデータサイズ
y_count - ｙ軸の目盛り間隔
例外:
IllegalArgumentException - x_count <= 0 または y_count <= 0
メソッドの詳細

getCenterPointX

public double getCenterPointX()
ｘ軸の中心値を返します。

戻り値:
double ｘ軸の中心値

getDataSizeX

public double getDataSizeX()
ｘ軸の中心値からのデータサイズを返します。

戻り値:
double ｘ軸の中心値からのデータサイズ

getScaleCountX

public double getScaleCountX()
ｘ軸の目盛間隔を返します。

戻り値:
double ｘ軸の目盛り間隔

getCenterPointY

public double getCenterPointY()
ｙ軸の中心値を返します。

戻り値:
double ｙ軸の中心値

getDataSizeY

public double getDataSizeY()
ｙ軸の中心値からのデータサイズを返します。

戻り値:
double ｙ軸の中心値からのデータサイズ

getScaleCountY

public double getScaleCountY()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛り間隔

setScalePosition

public void setScalePosition(String scale_position)
ｘ軸、ｙ軸の目盛りの表示位置を設定します。 デフォルト値はSCALE_POSITION_CENTER（グラフの中心）になります

パラメータ:
scale_position - 目盛りの表示位置 SCALE_POSITION_CENTER：グラフの中心 SCALE_POSITION_SIDE：グラフの枠

getScalePosition

public String getScalePosition()
ｘ軸、ｙ軸の目盛りの表示位置を返します。

戻り値:
String 目盛りの表示位置 SCALE_POSITION_CENTER：グラフの中心 SCALE_POSITION_SIDE：グラフの枠

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphBackgroundColor

public Color getGraphBackgroundColor()
グラフ領域の背景色を返します。

戻り値:
Color グラフ領域の背景色

setGraphBackgroundColor

public void setGraphBackgroundColor(Color color)
グラフ領域の背景色を設定します。

パラメータ:
color - グラフ領域の背景色

getGraphBorderColor

public Color getGraphBorderColor()
グラフ領域のボーダーの色を返します。

戻り値:
グラフ領域のボーダーの色

setGraphBorderColor

public void setGraphBorderColor(Color color)
グラフ領域のボーダーの色を設定します。

パラメータ:
color - グラフ領域のボーダーの色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(PortFolioObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

addData

public void addData(int index,
                    PortFolioObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public PortFolioObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

createImage

protected void createImage(Graphics g)
ポートフォリオを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PortFolioObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス PortFolioObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.PortFolioObject
すべての実装インタフェース:
Serializable
public class PortFolioObject
extends Object
implements Serializable

PortFolioDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
PortFolioObject(double x_data, double y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(double x_data, double y_data, Color color, int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortFolioObject(int x_data, int y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(int x_data, int y_data, Color color, int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
メソッドの概要
Color | getColor() 描画する点の色を返します。
double | getDataX() グラフのｘ値を返します。
double | getDataY() グラフのｙ値を返します。
int | getSize() 描画する点のサイズを返します。
boolean | isDouble() グラフ値がdouble表現かどうかを判定します。
void | setColor(Color color) 描画する点の色を設定します。
void | setSize(int size) 描画する点のサイズを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortFolioObject

public PortFolioObject(double x_data,
                       double y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値

PortFolioObject

public PortFolioObject(int x_data,
                       int y_data)
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値

PortFolioObject

public PortFolioObject(double x_data,
                       double y_data,
                       Color color,
                       int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。 グラフ値は doubleです。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値
color - 描画する点の色
size - 描画する点のサイズ

PortFolioObject

public PortFolioObject(int x_data,
                       int y_data,
                       Color color,
                       int size)
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。 グラフ値は intで与えますが、値はdoubleで扱われます。

パラメータ:
x_data - グラフのｘ値
y_data - グラフのｙ値
color - 描画する点の色
size - 描画する点のサイズ
メソッドの詳細

getDataX

public double getDataX()
グラフのｘ値を返します。

戻り値:
double ｘ値

getDataY

public double getDataY()
グラフのｙ値を返します。

戻り値:
double ｙ値

getColor

public Color getColor()
描画する点の色を返します。

戻り値:
color 描画する点の色

setColor

public void setColor(Color color)
描画する点の色を設定します。

パラメータ:
color - 描画する点の色

getSize

public int getSize()
描画する点のサイズを返します。

戻り値:
int 描画する点のサイズ

setSize

public void setSize(int size)
描画する点のサイズを設定します。

パラメータ:
size - 描画する点のサイズ

isDouble

public boolean isDouble()
グラフ値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RadarChartDrawer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス RadarChartDrawer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.drawer.AbstractDrawer
        拡張 jp.co.intra_mart.foundation.graph.RadarChartDrawer
すべての実装インタフェース:
Serializable
public class RadarChartDrawer
extends AbstractDrawer

レーダーチャートを描画します。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

フィールドの概要
static int | DEFAULT_BOTTOM_MARGIN 標準のグラフ領域の下部マージン
static int | DEFAULT_CAPTION_MARGIN 標準のキャプション表示位置のマージン
static Color | DEFAULT_GRAPH_FRAME_COLOR 標準のグラフ枠の線色
static Color | DEFAULT_IMAGE_BACKGROUND_COLOR 標準の画像ファイル背景色
static Color | DEFAULT_IMAGE_BORDER_COLOR 標準の画像ファイルのボーダ色
static int | DEFAULT_LEFT_MARGIN 標準のグラフ領域の左側マージン
static int | DEFAULT_RIGHT_MARGIN 標準のグラフ領域の右側マージン
static int | DEFAULT_TOP_MARGIN 標準のグラフ領域の上部マージン
コンストラクタの概要
RadarChartDrawer(double min, double max, double count)
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。
RadarChartDrawer(int min, int max, int count)
ｙ軸の目盛値をint表現でレーダーチャートを作成します。
メソッドの概要
void | addData(int index, RadarChartObject obj) 指定された位置に、指定された描画オブジェクトを追加します。
void | addData(RadarChartObject obj) 描画オブジェクトに新しいデータを追加します。
void | clear() すべてのデータを削除します。
protected void | createImage(Graphics g) レーダーチャートを描画します。
String[] | getCaption() ｘ軸のキャプションを返します。
Color | getCaptionColor() キャプションの文字色を返します。
int | getCaptionMargin() キャプション表示位置のマージンを返します。
RadarChartObject | getData(int index) リスト内の指定された位置にあるデータを返します。
Color | getGraphFrameColor() グラフ枠の線色を返します。
Color | getImageBackgroundColor() 画像ファイルの背景色を返します。
Color | getImageBorderColor() 画像ファイルのボーダ色を返します。
Color | getImgaeBackgroundColor() 推奨されていません。
Color | getImgaeBorderColor() 推奨されていません。
double | getMax() ｙ軸の最大値を返します。
double | getMin() ｙ軸の最小値を返します。
double | getScaleCount() ｙ軸の目盛間隔を返します。
boolean | isDouble() ｙ軸の目盛値がdouble表現かどうかを判定します。
void | remove(int index) 指定された位置のデータを削除します。
void | setCaption(String[] caption) ｘ軸のキャプションを設定します。
void | setCaptionColor(Color color) キャプションの文字色を設定します。
void | setCaptionMargin(int margin) キャプション表示位置のマージンを設定します。
void | setGraphFrameColor(Color color) グラフ枠の線色を設定します。
void | setImageBackgroundColor(Color color) 画像ファイルの背景色を設定します。
void | setImageBorderColor(Color color) 画像ファイルのボーダ色を設定します。
void | setImgaeBackgroundColor(Color color) 推奨されていません。
void | setImgaeBorderColor(Color color) 推奨されていません。
void | setMargin(int top, int right, int bottom, int left) グラフ領域のマージンを設定します。
int | size() データの数を返します。
クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer から継承したメソッド
getContentType, getHeight, getWidth, putImage, setContentType, setHeight, setWidth
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_TOP_MARGIN

public static int DEFAULT_TOP_MARGIN
標準のグラフ領域の上部マージン

DEFAULT_RIGHT_MARGIN

public static int DEFAULT_RIGHT_MARGIN
標準のグラフ領域の右側マージン

DEFAULT_BOTTOM_MARGIN

public static int DEFAULT_BOTTOM_MARGIN
標準のグラフ領域の下部マージン

DEFAULT_LEFT_MARGIN

public static int DEFAULT_LEFT_MARGIN
標準のグラフ領域の左側マージン

DEFAULT_CAPTION_MARGIN

public static int DEFAULT_CAPTION_MARGIN
標準のキャプション表示位置のマージン

DEFAULT_IMAGE_BACKGROUND_COLOR

public static Color DEFAULT_IMAGE_BACKGROUND_COLOR
標準の画像ファイル背景色

DEFAULT_IMAGE_BORDER_COLOR

public static Color DEFAULT_IMAGE_BORDER_COLOR
標準の画像ファイルのボーダ色

DEFAULT_GRAPH_FRAME_COLOR

public static Color DEFAULT_GRAPH_FRAME_COLOR
標準のグラフ枠の線色

コンストラクタの詳細

RadarChartDrawer

public RadarChartDrawer(int min,
                        int max,
                        int count)
ｙ軸の目盛値をint表現でレーダーチャートを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0

RadarChartDrawer

public RadarChartDrawer(double min,
                        double max,
                        double count)
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。

パラメータ:
min - ｙ軸の最小値
max - ｙ軸の最大値
count - ｙ軸の目盛間隔
例外:
IllegalArgumentException - max <= min または count <= 0
メソッドの詳細

getMax

public double getMax()
ｙ軸の最大値を返します。

戻り値:
double ｙ軸の最大値

getMin

public double getMin()
ｙ軸の最小値を返します。

戻り値:
double ｙ軸の最小値

getScaleCount

public double getScaleCount()
ｙ軸の目盛間隔を返します。

戻り値:
double ｙ軸の目盛間隔

setCaption

public void setCaption(String[] caption)
ｘ軸のキャプションを設定します。

パラメータ:
caption - キャプション

getCaption

public String[] getCaption()
ｘ軸のキャプションを返します。

戻り値:
キャプション

addData

public void addData(RadarChartObject obj)
描画オブジェクトに新しいデータを追加します。

パラメータ:
obj - データ

setImageBackgroundColor

public void setImageBackgroundColor(Color color)
画像ファイルの背景色を設定します。

パラメータ:
color -

setImgaeBackgroundColor

public void setImgaeBackgroundColor(Color color)
推奨されていません。

画像ファイルの背景色を設定します。

パラメータ:
color -

getImageBackgroundColor

public Color getImageBackgroundColor()
画像ファイルの背景色を返します。

戻り値:
color

getImgaeBackgroundColor

public Color getImgaeBackgroundColor()
推奨されていません。

画像ファイルの背景色を返します。

戻り値:
color

setImageBorderColor

public void setImageBorderColor(Color color)
画像ファイルのボーダ色を設定します。

パラメータ:
color -

setImgaeBorderColor

public void setImgaeBorderColor(Color color)
推奨されていません。

画像ファイルのボーダ色を設定します。

パラメータ:
color -

getImageBorderColor

public Color getImageBorderColor()
画像ファイルのボーダ色を返します。

戻り値:
color

getImgaeBorderColor

public Color getImgaeBorderColor()
推奨されていません。

画像ファイルのボーダ色を返します。

戻り値:
color

getGraphFrameColor

public Color getGraphFrameColor()
グラフ枠の線色を返します。

戻り値:
Color グラフ枠の線色

setGraphFrameColor

public void setGraphFrameColor(Color color)
グラフ枠の線色を設定します。

パラメータ:
color - グラフ枠の線色

getCaptionColor

public Color getCaptionColor()
キャプションの文字色を返します。

戻り値:
キャプションの文字色

setCaptionColor

public void setCaptionColor(Color color)
キャプションの文字色を設定します。

パラメータ:
color - キャプションの文字色

addData

public void addData(int index,
                    RadarChartObject obj)
指定された位置に、指定された描画オブジェクトを追加します。 現在その位置にあるデータはindex値に１追加されます。

パラメータ:
obj - データ
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index > size())

isDouble

public boolean isDouble()
ｙ軸の目盛値がdouble表現かどうかを判定します。

戻り値:
doubleで表現する場合はtrue

getData

public RadarChartObject getData(int index)
リスト内の指定された位置にあるデータを返します。

パラメータ:
index - インデックス
戻り値:
jp.co.intra_mart.foundation.graph.RadarChartObject
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置のデータを削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
データの数を返します。

戻り値:
int 値の数

clear

public void clear()
すべてのデータを削除します。

setMargin

public void setMargin(int top,
                      int right,
                      int bottom,
                      int left)
グラフ領域のマージンを設定します。

パラメータ:
top - 上部のマージン
right - 右側のマ－ジン
bottom - 下部のマージン
left - 左側のマージン

setCaptionMargin

public void setCaptionMargin(int margin)
キャプション表示位置のマージンを設定します。

パラメータ:
margin - キャプション表示位置のマージン

getCaptionMargin

public int getCaptionMargin()
キャプション表示位置のマージンを返します。

戻り値:
int キャプション表示位置のマージン

createImage

protected void createImage(Graphics g)
レーダーチャートを描画します。

定義:
クラス AbstractDrawer 内の createImage
パラメータ:
g - グラフィックコンテキスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RadarChartObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.graph
クラス RadarChartObject

java.lang.Object
    拡張 jp.co.intra_mart.foundation.graph.RadarChartObject
すべての実装インタフェース:
Serializable
public class RadarChartObject
extends Object
implements Serializable

RadarChartDrawerクラスのデータを保存するオブジェクトです。

導入されたバージョン:
version 4.1
関連項目:
直列化された形式

コンストラクタの概要
RadarChartObject()
デフォルトのデータオブジェクトを作成します。
RadarChartObject(boolean fill)
塗りつぶしの可否を指定して、データオブジェクトを作成します。
RadarChartObject(Color color)
グラフ線の色を指定して、データオブジェクトを作成します。
RadarChartObject(Color color, boolean fill)
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。
メソッドの概要
void | addData(double number) 値を追加します。
void | addData(int number) 値を追加します。
void | clear() すべての値を削除します。
Color | getColor() グラフ線の色を返します。
double | getData(int index) 指定された位置にある値を返します。
boolean | getFill() 描画されるグラフの塗りつぶし可否を返します。
void | remove(int index) 指定された位置の値を削除します。
void | setColor(Color color) グラフ線の色を設定します。
void | setFill(boolean fill) 描画されるグラフの塗りつぶし可否を設定します。
int | size() 値の数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RadarChartObject

public RadarChartObject()
デフォルトのデータオブジェクトを作成します。

RadarChartObject

public RadarChartObject(Color color)
グラフ線の色を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画されるグラフの色

RadarChartObject

public RadarChartObject(boolean fill)
塗りつぶしの可否を指定して、データオブジェクトを作成します。

パラメータ:
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）

RadarChartObject

public RadarChartObject(Color color,
                        boolean fill)
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。

パラメータ:
color - 描画される線の色
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）
メソッドの詳細

addData

public void addData(double number)
値を追加します。

パラメータ:
number - 値

addData

public void addData(int number)
値を追加します。 intを与えますが、値はdoubleで扱われます。

パラメータ:
number - 値

getData

public double getData(int index)
指定された位置にある値を返します。

パラメータ:
index - 返される値のインデックス
戻り値:
double 値
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

remove

public void remove(int index)
指定された位置の値を削除します。 削除後は後続の要素を左側に移動します。

パラメータ:
index - 削除されるデータ値のインデックス
例外:
IndexOutOfBoundsException - インデックスが範囲外の場合 (index < 0 || index >= size())

size

public int size()
値の数を返します。

戻り値:
int 値の数

clear

public void clear()
すべての値を削除します。

getColor

public Color getColor()
グラフ線の色を返します。

戻り値:
color 描画されるグラフ線の色

getFill

public boolean getFill()
描画されるグラフの塗りつぶし可否を返します。

戻り値:
描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）

setColor

public void setColor(Color color)
グラフ線の色を設定します。

パラメータ:
color - 描画されるグラフ線の色

setFill

public void setFill(boolean fill)
描画されるグラフの塗りつぶし可否を設定します。

パラメータ:
fill - 描画されるグラフの塗りつぶし可否（true：塗りつぶす／false：塗りつぶさない）
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.http.CGIEnvironment の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.CGIEnvironment の使用

jp.co.intra_mart.foundation.http.CGIEnvironment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.FileSender の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.FileSender の使用

jp.co.intra_mart.foundation.http.FileSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.http.MultipartFormData.Entity の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.http.MultipartFormData.Entity の使用

MultipartFormData.Entity を使用しているパッケージ
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.http での MultipartFormData.Entity の使用

MultipartFormData.Entity を返す jp.co.intra_mart.foundation.http のメソッド
MultipartFormData.Entity | MultipartFormData.getEntity(int index) 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | MultipartFormData.getEntity(String name) 指定の名前を持つエンティティを取得します。
MultipartFormData.Entity[] | MultipartFormData.getEntities(String name) 指定の名前を持つエンティティをすべて取得します。

jp.co.intra_mart.framework.base.service での MultipartFormData.Entity の使用

MultipartFormData.Entity を返す jp.co.intra_mart.framework.base.service のメソッド
MultipartFormData.Entity | Transition.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
MultipartFormData.Entity | ServiceControllerAdapter.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.MultipartFormData の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.MultipartFormData の使用

jp.co.intra_mart.foundation.http.MultipartFormData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.http.SessionQuery の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.http.SessionQuery の使用

jp.co.intra_mart.foundation.http.SessionQuery はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CGIEnvironment (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス CGIEnvironment

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 java.util.HashMap
            拡張 jp.co.intra_mart.foundation.http.CGIEnvironment
すべての実装インタフェース:
Cloneable, Map, Serializable
public class CGIEnvironment
extends HashMap

このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
ユーザー・プログラムでは、このクラスを利用する事でサーブレット環境で CGI 環境変数インターフェースを実装する事が出来ます。

関連項目:
HttpServletRequest, HashMap, 直列化された形式

コンストラクタの概要
CGIEnvironment(HttpServletRequest httpRequest)
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。
メソッドの概要
 String getenv(String key)
値の取得。
クラス java.util.HashMap から継承したメソッド
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
クラス java.util.AbstractMap から継承したメソッド
equals, hashCode, toString
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait
インタフェース java.util.Map から継承したメソッド
equals, hashCode

コンストラクタの詳細

CGIEnvironment

public CGIEnvironment(HttpServletRequest httpRequest)
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。

パラメータ:
httpRequest - サーブレット実行時に受け取るリクエストオブジェクト
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getenv

public String getenv(String key)
値の取得。

キーにマップされている値を返します。
引数 key には、ＣＧＩ環境変数の変数名を指定して下さい。 引数に指定されたＣＧＩ環境変数にマップされている値がない場合 null を 返します。

パラメータ:
key - 値にマップされているキー
戻り値:
キーにマップされている値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FileSender (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス FileSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.http.FileSender
public class FileSender
extends Object

このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。

関連項目:
HttpServletResponse

コンストラクタの概要
FileSender(HttpServletResponse httpResponse)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
メソッドの概要
void | write(byte b) バイトの出力。
void | write(byte[] src) バイトの出力。
void | write(byte[] src, int off, int len) バイトの出力。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSender

public FileSender(HttpServletResponse httpResponse)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして application/octet-stream を指定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment

例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  MultipurposeInternetMailExtensions mimeType)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 引数 mimeType の表す MIME タイプを設定します。

パラメータ:
mimeType - MIME タイプ
例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  String filename)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 指定のファイル名にマップされている MIME を表す文字列か、または、 指定のファイル名にマップされている MIME タイプを解決できなかった 場合には application/octet-stream を指定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment; filename=ファイル名
“ファイル名”の部分には、引数 filename が設定されます。

パラメータ:
filename - ファイル名
例外:
IOException - 入出力エラー

FileSender

public FileSender(HttpServletResponse httpResponse,
                  MultipurposeInternetMailExtensions mimeType,
                  String filename)
           throws IOException
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

このコンストラクタでは、HTTP レスポンスヘッダの Content-Type および Content-Disposition の設定を自動的に行います。 その他のヘッダへの設定は httpResponse に対して 直接設定をしてください。
HTTP レスポンスヘッダの Content-Type には、MIME タイプとして 引数 mimeType の表す MIME タイプを設定します。
HTTP レスポンスヘッダの Content-Disposition は、以下のように定義します。
Content-Disposition: attachment; filename=ファイル名
“ファイル名”の部分には、引数 filename が設定されます。

パラメータ:
mimeType - MIME タイプ
filename - ファイル名
例外:
IOException - 入出力エラー
メソッドの詳細

write

public void write(byte b)
           throws IOException
バイトの出力。

指定のバイトを HTTP レスポンスの出力ストリームに書き出します。

パラメータ:
b - ストリームに書き出すバイト
例外:
IOException - 入出力エラー

write

public void write(byte[] src)
           throws IOException
バイトの出力。

指定のバイトを HTTP レスポンスの出力ストリームに書き出します。

パラメータ:
src - ストリームに書き出すバイト列
例外:
IOException - 入出力エラー

write

public void write(byte[] src,
                  int off,
                  int len)
           throws IOException
バイトの出力。

オフセット off から始まる指定のバイト配列から HTTP レスポンスの 出力ストリームに len バイトを書き込みます。

パラメータ:
src - ストリームに書き出すバイト列
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipartFormData.Entity (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
インタフェース MultipartFormData.Entity

含まれているインタフェース:
MultipartFormData
public static interface MultipartFormData.Entity

フォームデータのエンティティです。

フォームから送信された情報を解析した結果の各エンティティは、 ヘッダ情報とデータで構成されます。

メソッドの概要
boolean | containsHeader(String name) 指定された文字列がヘッダの名称かどうかを判定します。
byte[] | getBytes() データ部をバイト配列として取得します。
String | getContent() データ部を文字列表現として取得します。
String | getContent(String enc) データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
int | getContentLength() データ部をバイト長を取得します。
String | getFileName() アップロードされたファイルのファイル名を取得します。
String | getHeader(String name) ヘッダの取得。
String[] | getHeaderNames() ヘッダ名称一覧の取得。
InputStream | getInputStream() データ部を入力ストリームとして取得します。
String | getName() フォームのコントロール名称の取得。
Reader | getReader() データ部を Reader として取得します。

メソッドの詳細

getName

public String getName()
フォームのコントロール名称の取得。

フォームから送信された情報のうち、このエンティティが表す情報の もととなったフォーム中に定義されたコントロールの名称を返します。

戻り値:
コントロール名称

getFileName

public String getFileName()
アップロードされたファイルのファイル名を取得します。

ファイルアップロードをしたリクエストではない場合は、null を返します。
Content-Disposition: form-data; name="ctrl_name"; filename="file_path"
ヘッダは、上記のような形式で受け取れる
ctrl_name: <INPUT type="file"> の name 属性
file_path: クライアントでのファイル名
ヘッダ情報は他にもあるが、上記の行のみを対象に解析を行う

戻り値:
String ファイル名

getHeaderNames

public String[] getHeaderNames()
ヘッダ名称一覧の取得。

このエンティティのもつヘッダ情報の名称一覧を返します。

戻り値:
ヘッダ名称の取得

getHeader

public String getHeader(String name)
ヘッダの取得。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称にマップされている値

containsHeader

public boolean containsHeader(String name)
指定された文字列がヘッダの名称かどうかを判定します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称が値にマップされている場合 true

getContentLength

public int getContentLength()
データ部をバイト長を取得します。

戻り値:
データのサイズ

getContent

public String getContent()
データ部を文字列表現として取得します。

入力されたバイトデータから文字列への変換には、プラットフォームの デフォルトエンコーディングを使います。

戻り値:
データ

getContent

public String getContent(String enc)
                  throws UnsupportedEncodingException
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。

指定のエンコード名がサポートされていない場合 UnsupportedEncodingException がスローされます。

パラメータ:
enc - エンコード名
戻り値:
データ
例外:
UnsupportedEncodingException
関連項目:
UnsupportedEncodingException

getBytes

public byte[] getBytes()
データ部をバイト配列として取得します。

戻り値:
データ

getReader

public Reader getReader()
データ部を Reader として取得します。

戻り値:
データ

getInputStream

public InputStream getInputStream()
データ部を入力ストリームとして取得します。

戻り値:
データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultipartFormData (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス MultipartFormData

java.lang.Object
    拡張 java.util.AbstractCollection
        拡張 java.util.AbstractList
            拡張 java.util.ArrayList
                拡張 jp.co.intra_mart.foundation.http.MultipartFormData
すべての実装インタフェース:
Cloneable, Collection, List, RandomAccess, Serializable
public class MultipartFormData
extends ArrayList

フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。

このオブジェクトは、ブラウザから multipart/form-data 形式でリクエストされた データを解析し、boundary で区切られた各情報(エンティティ)をとしてリストに 保管します。

このクラスを利用する事により、ブラウザからサーバに対するファイルの アップロードなどが簡単に実装する事ができます。

関連項目:
直列化された形式

入れ子クラスの概要
static interface MultipartFormData.Entity
フォームデータのエンティティです。
フィールドの概要
クラス java.util.AbstractList から継承したフィールド
modCount
コンストラクタの概要
MultipartFormData(ServletRequest req)
リクエストされた情報を解析して、新しいオブジェクトを構築します。
メソッドの概要
MultipartFormData.Entity[] | getEntities(String name) 指定の名前を持つエンティティをすべて取得します。
MultipartFormData.Entity | getEntity(int index) 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | getEntity(String name) 指定の名前を持つエンティティを取得します。
クラス java.util.ArrayList から継承したメソッド
add, add, addAll, addAll, clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, removeRange, set, size, toArray, toArray, trimToSize
クラス java.util.AbstractList から継承したメソッド
equals, hashCode, iterator, listIterator, listIterator, subList
クラス java.util.AbstractCollection から継承したメソッド
containsAll, remove, removeAll, retainAll, toString
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait
インタフェース java.util.List から継承したメソッド
containsAll, equals, hashCode, iterator, listIterator, listIterator, remove, removeAll, retainAll, subList

コンストラクタの詳細

MultipartFormData

public MultipartFormData(ServletRequest req)
                  throws IOException,
                         IllegalArgumentException
リクエストされた情報を解析して、新しいオブジェクトを構築します。
multipart/form-data 形式のリクエストを解析します。

req が multipart/form-data で受信したリクエストではない場合、 IllegalArgumentException をスローします。

パラメータ:
req - サーブレットエンジンから渡されるリクエスト情報オブジェクト
例外:
IOException - リクエストデータ解析時の入出力エラー
IllegalArgumentException - 引数が不正の場合
メソッドの詳細

getEntity

public MultipartFormData.Entity getEntity(int index)
指定のインデックスに該当するエンティティを取得します。

インデックスが範囲外の場合(インデックスが負または size() よりも大きい) IndexOutOfBoundsException をスローします。

パラメータ:
index - 返すエンティティのインデックス
戻り値:
リスト内の指定された位置にあるエンティティ

getEntity

public MultipartFormData.Entity getEntity(String name)
指定の名前を持つエンティティを取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 指定の名前を持つエンティティが複数存在する場合、その中のいずれか一つが 返されます。 該当するエンティティが存在しない場合 null を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

getEntities

public MultipartFormData.Entity[] getEntities(String name)
指定の名前を持つエンティティをすべて取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 該当するエンティティが存在しない場合、空の配列を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.http (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.http
インタフェース
MultipartFormData.Entity
クラス
CGIEnvironment
FileSender
MultipartFormData
SessionQuery


jp.co.intra_mart.foundation.http (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

参照:
説明

インタフェースの概要
MultipartFormData.Entity フォームデータのエンティティです。

クラスの概要
CGIEnvironment | このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
FileSender | このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。
MultipartFormData | フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。
SessionQuery | 推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

パッケージ jp.co.intra_mart.foundation.http の説明

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.http クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.http の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.foundation.http.MultipartFormData
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.http.CGIEnvironment
    • class jp.co.intra_mart.foundation.http.FileSender
    • class jp.co.intra_mart.foundation.http.SessionQuery

インタフェース階層

  • interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.http の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.http の使用

jp.co.intra_mart.foundation.http を使用しているパッケージ
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.http により使用される jp.co.intra_mart.foundation.http のクラス
MultipartFormData.Entity
フォームデータのエンティティです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.foundation.http のクラス
MultipartFormData.Entity
フォームデータのエンティティです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SessionQuery (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.http
クラス SessionQuery

java.lang.Object
    拡張 jp.co.intra_mart.foundation.http.SessionQuery
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

public class SessionQuery
extends Object

このクラスは、intra-mart のセッションを維持したまま プレゼンテーション・ページ＆ファンクション・コンテナを HTTP を利用して 呼び出すためのセッション引数を提供します。
このクラスを利用することにより、ＪＳＰおよびサーブレットにより作成された ページからページベース開発モデルのページに対してリンクすることができます。

なお、ＪＳＰおよびサーブレット間でのセッション維持には利用できません。

関連項目:
GenericURLBuilder, URLBuilder

コンストラクタの概要
SessionQuery(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
メソッドの概要
 String addURL(String url)
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
protected  String getQuery()
推奨されていません。 代替えメソッドはありません。
 String getQueryName()
推奨されていません。 代替えメソッドはありません。
 String getQueryValue()
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。
 String setTo(String path)
推奨されていません。 代替えメソッドはありません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionQuery

public SessionQuery(HttpServletRequest request,
                    HttpServletResponse response)
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。

セッションを維持するためのリクエスト引数を作成するインスタンスを 構築します。

指定のセッションＩＤにより遷移先のページで セッションを共有することができます。

例外:
NullPointerException - 引数が null
メソッドの詳細

setTo

public String setTo(String path)
推奨されていません。 代替えメソッドはありません。

遷移先ページの指定。

遷移先のプレゼンテーション・ページのパスを指定します。
パスは、InformationServer からの相対形式で拡張子(.html)を 省略したものを指定して下さい。

sample/tutorial/beginner/index.html へ遷移する場合、 sample/tutorial/beginner/index という文字列を引数 path に指定します。

パラメータ:
path - ファイル名
戻り値:
このメソッドで設定済みだった値
例外:
NullPointerException - 引数が null

getQueryName

public String getQueryName()
推奨されていません。 代替えメソッドはありません。

クエリー引数名称の取得。

クエリー引数の名称を返します。
このメソッドの値を <INPUT> の name 属性値として指定する事で、 セッションを維持したまま intra-mart のプレゼンテーション・ページへ 遷移するフォームを作成する事が出来ます。

戻り値:
クエリー引数名称

getQueryValue

public String getQueryValue()
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。

クエリー引数値の取得。

クエリー引数の値を返します。
このメソッドの値を <INPUT> の value 属性値として指定する事で、 セッションを維持したまま intra-mart のプレゼンテーション・ページへ 遷移するフォームを作成する事が出来ます。

戻り値:
クエリー引数値

getQuery

protected String getQuery()
推奨されていません。 代替えメソッドはありません。

クエリー引数の取得。

クエリー引数を返します。

戻り値:
クエリー引数

addURL

public String addURL(String url)
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。

ＵＲＬへのクエリーの追加。

セッションを維持したまま intra-mart へアクセスするＵＲＬを返します。

パラメータ:
url - intra-mart にアクセスするためのＵＲＬ
戻り値:
セッション維持の為のクエリー引数を付加したＵＲＬ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.im_curl.CurlFieldBean の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlFieldBean の使用

CurlFieldBean を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

jp.co.intra_mart.foundation.im_curl での CurlFieldBean の使用

CurlFieldBean 型のパラメータを持つ jp.co.intra_mart.foundation.im_curl のメソッド
 void CurlXMLComposer.addField(CurlFieldBean field)
フィールド一覧リストにフィールドを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF の使用

CurlRecordBeanIF を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

jp.co.intra_mart.foundation.im_curl での CurlRecordBeanIF の使用

CurlRecordBeanIF 型のパラメータを持つ jp.co.intra_mart.foundation.im_curl のメソッド
 void CurlXMLComposer.addRecord(CurlRecordBeanIF record)
レコード一覧リストにレコードを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlXMLComposer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlXMLComposer の使用

jp.co.intra_mart.foundation.im_curl.CurlXMLComposer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlXMLParser の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlXMLParser の使用

jp.co.intra_mart.foundation.im_curl.CurlXMLParser はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CurlFieldBean (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlFieldBean

java.lang.Object
    拡張 jp.co.intra_mart.foundation.im_curl.CurlFieldBean
public class CurlFieldBean
extends Object

CurlフィールドBeanクラス
機能は以下の通り

  • CurlのRecordFieldクラスの属性情報を格納するBean

コンストラクタの概要
CurlFieldBean()
メソッドの概要
String | getCaption() キャプションを返します。
String | getDefault_value() デフォルト値を返します。
String | getDomain() ドメインを返します。
String | getIndex_type() インデックスタイプを返します。
String | getModifiable() 変更可能の可否を返します。
String | getName() 名前を返します。
String | getNullable() Null受付の可否を返します。
String | getRequired() フォーカスの要求の有無を返します。
void | setCaption(String string) キャプションを格納します。
void | setDefault_value(String string) デフォルト値を格納します。
void | setDomain(String string) ドメインを格納します。
void | setIndex_type(String string) インデックスタイプを格納します。
void | setModifiable(String string) 変更可能の可否を格納します。
void | setName(String string) 名前を格納します。
void | setNullable(String string) Null受付の可否を格納します。
void | setRequired(String string) フォーカスの要求の有無を格納します。
String | toString() オブジェクトを文字列に変換します。
String | toXMLNode() このインスタンスのXMLノードとしての文字列を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurlFieldBean

public CurlFieldBean()
メソッドの詳細

getCaption

public String getCaption()
キャプションを返します。

戻り値:
キャプション

getDefault_value

public String getDefault_value()
デフォルト値を返します。

戻り値:
デフォルト値

getDomain

public String getDomain()
ドメインを返します。

戻り値:
ドメイン

getIndex_type

public String getIndex_type()
インデックスタイプを返します。

戻り値:
インデックスタイプ

getModifiable

public String getModifiable()
変更可能の可否を返します。

戻り値:
変更可能の可否

getName

public String getName()
名前を返します。

戻り値:
名前

getNullable

public String getNullable()
Null受付の可否を返します。

戻り値:
Null受付の可否

getRequired

public String getRequired()
フォーカスの要求の有無を返します。

戻り値:
フォーカスの要求の有無

setCaption

public void setCaption(String string)
キャプションを格納します。

パラメータ:
string - キャプション

setDefault_value

public void setDefault_value(String string)
デフォルト値を格納します。

パラメータ:
string - デフォルト値

setDomain

public void setDomain(String string)
ドメインを格納します。

パラメータ:
string - ドメイン

setIndex_type

public void setIndex_type(String string)
インデックスタイプを格納します。

パラメータ:
string - インデックスタイプ

setModifiable

public void setModifiable(String string)
変更可能の可否を格納します。

パラメータ:
string - 変更可能の可否

setName

public void setName(String string)
名前を格納します。

パラメータ:
string - 名前

setNullable

public void setNullable(String string)
Null受付の可否を格納します。

パラメータ:
string - Null受付の可否

setRequired

public void setRequired(String string)
フォーカスの要求の有無を格納します。

パラメータ:
string - フォーカスの要求の有無

toString

public String toString()
オブジェクトを文字列に変換します。

戻り値:
このオブジェクトの文字列表現

toXMLNode

public String toXMLNode()
このインスタンスのXMLノードとしての文字列を返します。

戻り値:
XMLノードへ変換した文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlRecordBeanIF (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
インタフェース CurlRecordBeanIF

public interface CurlRecordBeanIF

CurlレコードBeanインタフェース
機能は以下の通り

  • CurlのRecordクラスの属性を格納するBean用のインタフェース

メソッドの概要
 String toXMLNode()
保持しているデータをXMLノードの文字列に変換します。

メソッドの詳細

toXMLNode

public String toXMLNode()
保持しているデータをXMLノードの文字列に変換します。

戻り値:
XMLノード文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlXMLComposer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlXMLComposer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
public class CurlXMLComposer
extends Object

CurlXML生成クラス
機能は以下の通り

  • Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。

コンストラクタの概要
CurlXMLComposer()
メソッドの概要
void | addField(CurlFieldBean field) フィールド一覧リストにフィールドを追加します。
void | addRecord(CurlRecordBeanIF record) レコード一覧リストにレコードを追加します。
void | setFieldList(ArrayList fieldList) フィールド一覧リストをセットします。
void | setRecordList(ArrayList recordList) レコード一覧リストをセットします。
String | toXML() 指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CurlXMLComposer

public CurlXMLComposer()
メソッドの詳細

addField

public void addField(CurlFieldBean field)
フィールド一覧リストにフィールドを追加します。

パラメータ:
field - フィールド定義クラスのインスタンス

setFieldList

public void setFieldList(ArrayList fieldList)
フィールド一覧リストをセットします。

パラメータ:
fieldList - フィールド一覧リスト

addRecord

public void addRecord(CurlRecordBeanIF record)
レコード一覧リストにレコードを追加します。

パラメータ:
record - レコードクラスのインスタンス

setRecordList

public void setRecordList(ArrayList recordList)
レコード一覧リストをセットします。

パラメータ:
recordList - レコード一覧リスト

toXML

public String toXML()
             throws Exception
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。

戻り値:
Curlで入力可能なXMLの文字列
例外:
Exception
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurlXMLParser (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlXMLParser

java.lang.Object
    拡張 org.xml.sax.helpers.DefaultHandler
        拡張 jp.co.intra_mart.foundation.im_curl.CurlXMLParser
すべての実装インタフェース:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler
public class CurlXMLParser
extends DefaultHandler

CurlXMLパーサクラス
機能は以下の通り

  • Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。

フィールドの概要
protected Object | field に対応するCurlFieldBean
protected ArrayList | fieldsList に対応するCurlFieldBeanクラスのインスタンス格納用リスト
protected Object | instance に対応するJavaBeans
protected ArrayList | recordList に対応するクラスのインスタンス格納用リスト
コンストラクタの概要
CurlXMLParser(InputStream stream, String beanClassName)
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。
CurlXMLParser(String path, String beanClassName)
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。
メソッドの概要
protected void | createField(Attributes atts) qNameがFieldの場合のパーサの動作を定義します。
protected void | createRecord(Attributes atts) qNameがRecordの場合のパーサの動作を定義します。
void | endElement(String uri, String localName, String qName) DefaultHandlerのabstractメソッドをオーバーライドします。
ArrayList | getFieldsList() パースした結果のフィールド一覧リストを返します。
ArrayList | getRecordList() パースした結果のレコード一覧リストを返します。
void | startElement(String uri, String localName, String qName, Attributes atts) DefaultHandlerのabstractメソッドをオーバーライドします。
クラス org.xml.sax.helpers.DefaultHandler から継承したメソッド
characters, endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

fieldsList

protected ArrayList fieldsList
に対応するCurlFieldBeanクラスのインスタンス格納用リスト

recordList

protected ArrayList recordList
に対応するクラスのインスタンス格納用リスト

field

protected Object field
に対応するCurlFieldBean

instance

protected Object instance
に対応するJavaBeans

コンストラクタの詳細

CurlXMLParser

public CurlXMLParser(String path,
                     String beanClassName)
              throws SAXException
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。

パラメータ:
path - パース対象のXMLファイルのパス
beanClassName - パース対象のXMLのRecordタグに対応するJavaBeansクラス名
例外:
SAXException

CurlXMLParser

public CurlXMLParser(InputStream stream,
                     String beanClassName)
              throws SAXException
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。

パラメータ:
stream - パース対象のXMLを読み込むストリーム
beanClassName - パース対象のXMLのRecordタグに対応するJavaBeansクラス名
例外:
SAXException
メソッドの詳細

getRecordList

public ArrayList getRecordList()
パースした結果のレコード一覧リストを返します。

戻り値:
レコード一覧

getFieldsList

public ArrayList getFieldsList()
パースした結果のフィールド一覧リストを返します。

戻り値:
フィールド一覧

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
DefaultHandlerのabstractメソッドをオーバーライドします。
Curlで出力されたXML(elaborate-recordsetでの出力)をパースし、 FieldタグをCurlFieldBeanクラスのリストに、Recordタグを指定したJavaBeans クラスのリストに変換します。処理の詳細は次の通りです。
  1. Fieldタグをパースし、フィールド一覧リストに格納する。
  2. Recordタグのパース
    1. 指定されたJavaBeansクラスのインスタンス生成
    2. Recordタグの属性名、属性値を取得
    3. フィールド一覧リスト内のフィールド名を取得
    4. 指定されたJavaBeansクラスのメソッド一覧を検索しRecordタグの 属性のセッターが存在すればセッターを呼び出し属性値をセットする。 存在の有無は"set"+属性値をすべて小文字に変換した文字列がJavaBeans クラスのメソッド一覧内に存在するかで判断する。

例外:
SAXException

createField

protected void createField(Attributes atts)
qNameがFieldの場合のパーサの動作を定義します。 RecordSetのフィールドを解析する部分になります。

パラメータ:
atts -

createRecord

protected void createRecord(Attributes atts)
                     throws SAXException
qNameがRecordの場合のパーサの動作を定義します。 RecordSetのレコードを解析する部分になります。

パラメータ:
atts -
例外:
SAXException

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
DefaultHandlerのabstractメソッドをオーバーライドします。

例外:
SAXException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.im_curl (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.im_curl
インタフェース
CurlRecordBeanIF
クラス
CurlFieldBean
CurlXMLComposer
CurlXMLParser


jp.co.intra_mart.foundation.im_curl (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.im_curl

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

参照:
説明

インタフェースの概要
CurlRecordBeanIF CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース

クラスの概要
CurlFieldBean | CurlフィールドBeanクラス 機能は以下の通り CurlのRecordFieldクラスの属性情報を格納するBean
CurlXMLComposer | CurlXML生成クラス 機能は以下の通り Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。
CurlXMLParser | CurlXMLパーサクラス 機能は以下の通り Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。

パッケージ jp.co.intra_mart.foundation.im_curl の説明

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.im_curl クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.im_curl の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.im_curl.CurlFieldBean
    • class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class jp.co.intra_mart.foundation.im_curl.CurlXMLParser

インタフェース階層

  • interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.im_curl の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.im_curl の使用

jp.co.intra_mart.foundation.im_curl を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

jp.co.intra_mart.foundation.im_curl により使用される jp.co.intra_mart.foundation.im_curl のクラス
CurlFieldBean
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlRecordBeanIF
CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.MailSender の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.MailSender の使用

MailSender を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail での MailSender の使用

MailSender を実装している jp.co.intra_mart.foundation.mail.javamail のクラス
 class JavaMailSender
JavaMailをラップしたメール送信オブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.MailSenderException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.MailSenderException の使用

MailSenderException を使用しているパッケージ
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail のメソッド
 void MailSender.send()
メールを送信します。

jp.co.intra_mart.foundation.mail.javamail での MailSenderException の使用

MailSenderException をスローする jp.co.intra_mart.foundation.mail.javamail のメソッド
protected void | StandardMail.init() StandardMailオブジェクトを初期化します。
protected Properties | StandardMail.getProperties() JavaMailのSMTPセッションに渡す属性を初期化します。
protected void | StandardMail.prepareSession(Session session) SMTPセッションに対して操作を行います。
protected void | StandardMail.prepareMimeMessage(MimeMessage message) MIMEメッセージに対して操作を行います。
void | JavaMailSender.send() メールを送信します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.JavaMailSender の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.JavaMailSender の使用

jp.co.intra_mart.foundation.mail.javamail.JavaMailSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.StandardMail の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.StandardMail の使用

StandardMail を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail での StandardMail の使用

StandardMail 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail のコンストラクタ
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException の使用

JavaMailPropertyException を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property での JavaMailPropertyException の使用

JavaMailPropertyException をスローする jp.co.intra_mart.foundation.mail.javamail.property のメソッド
static JavaMailPropertyHandler JavaMailPropertyHandler.getInstance()
JavaMailPropertyHandlerのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の使用

JavaMailPropertyHandler を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property での JavaMailPropertyHandler の使用

JavaMailPropertyHandler を返す jp.co.intra_mart.foundation.mail.javamail.property のメソッド
static JavaMailPropertyHandler JavaMailPropertyHandler.getInstance()
JavaMailPropertyHandlerのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


JavaMailPropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
すべての実装インタフェース:
Serializable
public class JavaMailPropertyException
extends Exception

JavaMailSenderの設定に関する情報を提供する例外です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
JavaMailPropertyException()
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String message)
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable cause)
指定された原因を使用してJavaMailPropertyExceptionを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

JavaMailPropertyException

public JavaMailPropertyException()
JavaMailPropertyExceptionを構築します。

JavaMailPropertyException

public JavaMailPropertyException(String message)
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。

パラメータ:
message -

JavaMailPropertyException

public JavaMailPropertyException(String message,
                                 Throwable cause)
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。

パラメータ:
message -
cause -

JavaMailPropertyException

public JavaMailPropertyException(Throwable cause)
指定された原因を使用してJavaMailPropertyExceptionを構築します。

パラメータ:
cause -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


JavaMailPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
public class JavaMailPropertyHandler
extends Object

JavaMailSenderの設定を保持します。

導入されたバージョン:
5.0.2

メソッドの概要
String | getCharset(Locale locale) キャラクターセットを取得します。
String | getContentTransferEncoding(Locale locale) Content-Transfer-Encodingを取得します。
String | getContentType(String ext) コンテントタイプを取得します。
boolean | getDebugOption() JavaMailに設定するデバック設定の有無を取得します。
static JavaMailPropertyHandler | getInstance() JavaMailPropertyHandlerのインスタンスを取得します。
String | getMimeEncoding(Locale locale) MIMEエンコードを取得します。
String | getXMailerHeader() 送信メールに付加するX-Mailerヘッダを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static JavaMailPropertyHandler getInstance()
                                           throws JavaMailPropertyException
JavaMailPropertyHandlerのインスタンスを取得します。

戻り値:
JavaMailPropertyHandlerのインスタンス
例外:
JavaMailPropertyException

getContentType

public String getContentType(String ext)
コンテントタイプを取得します。

パラメータ:
ext - ドットを含む拡張子
戻り値:
コンテントタイプ

getXMailerHeader

public String getXMailerHeader()
送信メールに付加するX-Mailerヘッダを取得します。

戻り値:
X-Mailerヘッダ

getDebugOption

public boolean getDebugOption()
JavaMailに設定するデバック設定の有無を取得します。

戻り値:
デバック設定

getCharset

public String getCharset(Locale locale)
キャラクターセットを取得します。

パラメータ:
locale - ロケール
戻り値:
キャラクターセット

getMimeEncoding

public String getMimeEncoding(Locale locale)
MIMEエンコードを取得します。

パラメータ:
locale - ロケール
戻り値:
エンコード

getContentTransferEncoding

public String getContentTransferEncoding(Locale locale)
Content-Transfer-Encodingを取得します。

パラメータ:
locale - ロケール
戻り値:
Content-Transfer-Encoding
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.property (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.mail.javamail.property
クラス
JavaMailPropertyHandler
例外
JavaMailPropertyException


jp.co.intra_mart.foundation.mail.javamail.property (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラスの概要
JavaMailPropertyHandler JavaMailSenderの設定を保持します。

例外の概要
JavaMailPropertyException JavaMailSenderの設定に関する情報を提供する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.mail.javamail.property クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.mail.javamail.property の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.property の使用

jp.co.intra_mart.foundation.mail.javamail.property を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property により使用される jp.co.intra_mart.foundation.mail.javamail.property のクラス
JavaMailPropertyException
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyHandler
JavaMailSenderの設定を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


JavaMailSender (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス JavaMailSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.JavaMailSender
すべての実装インタフェース:
MailSender
public class JavaMailSender
extends Object
implements MailSender

JavaMailをラップしたメール送信オブジェクトです。
メールの送信情報はStandardMailのインスタンスにより 決定されます。

導入されたバージョン:
5.0
関連項目:
StandardMail

コンストラクタの概要
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。
メソッドの概要
 void send()
メールを送信します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

JavaMailSender

public JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

パラメータ:
mail - 送信メール
メソッドの詳細

send

public void send()
          throws MailSenderException
メールを送信します。

定義:
インタフェース MailSender 内の send
例外:
MailSenderException - メール送信時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.mail.javamail
クラス
JavaMailSender
StandardMail


jp.co.intra_mart.foundation.mail.javamail (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail

メール送信クラスを提供します。

参照:
説明

クラスの概要
JavaMailSender | JavaMailをラップしたメール送信オブジェクトです。
StandardMail | 送信するメールの属性を保管します。

パッケージ jp.co.intra_mart.foundation.mail.javamail の説明

メール送信クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.mail.javamail クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.mail.javamail の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail の使用

jp.co.intra_mart.foundation.mail.javamail を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail.javamail のクラス
StandardMail
送信するメールの属性を保管します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StandardMail (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス StandardMail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.StandardMail
public class StandardMail
extends Object

送信するメールの属性を保管します。
このオブジェクトが保持するメールのキャラクターセット、エンコディングの設定は ロケールに依存します。

ロケール毎の設定は定義ファイルをにより決定されます。
ServerManager上に /conf/mail/encode.properties として、定義ファイルを配置してください。
指定可能なキーの一覧

charset | キャラクターセット
mimeEncoding | MIMEエンコード (B or Q)
contentTransferEncoding | ボディのエンコード

導入されたバージョン:
5.0
関連項目:
JavaMailSender

コンストラクタの概要
StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。
メソッドの概要
void | addAttachment(String filename, String file) 添付ファイルを追加します。
void | addBcc(String address) Bccを追加します。
void | addBcc(String address, String personal) Bccを追加します。
void | addCc(String address) Ccを追加します。
void | addCc(String address, String personal) Ccを追加します。
void | addHeader(String name, String value) ヘッダーを追加します。
void | addReplyTo(String replyto) ReplyToを追加します。
void | addTo(String address) Toを追加します。
void | addTo(String address, String personal) Toを追加します。
Locale | getLocale() ロケールを取得します。
protected Properties | getProperties() JavaMailのSMTPセッションに渡す属性を初期化します。
protected void | init() StandardMailオブジェクトを初期化します。
protected void | prepareMimeMessage(MimeMessage message) MIMEメッセージに対して操作を行います。
protected void | prepareSession(Session session) SMTPセッションに対して操作を行います。
void | setFrom(String address) Fromを設定します。
void | setFrom(String address, String personal) Fromを設定します。
void | setSubject(String subject) Subjectを設定します。
void | setText(String text) 本文を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardMail

public StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。

StandardMail

public StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。

パラメータ:
locale - 送信先ロケール
メソッドの詳細

init

protected void init()
             throws MailSenderException
StandardMailオブジェクトを初期化します。 このメソッドはJavaMailSender.send()から呼ばれます。

例外:
MailSenderException - StandardMailオブジェクトを初期化時に例外が発生。

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getProperties

protected Properties getProperties()
                            throws MailSenderException
JavaMailのSMTPセッションに渡す属性を初期化します。

ここではSMTPサーバのホスト及びポートを設定します。
このメソッドはJavaMailSender.send()から呼ばれます。

戻り値:
属性
例外:
MailSenderException - 属性設定時に例外が発生。

prepareSession

protected void prepareSession(Session session)
                       throws MailSenderException
SMTPセッションに対して操作を行います。

ここでは、JavaMailにデバックオプションを設定します。 設定値は"conf/mail/javaMail.properties"の設定値が有効となります。
このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
session - SMTPセッション
例外:
MailSenderException - セッション操作中に例外が発生。

prepareMimeMessage

protected void prepareMimeMessage(MimeMessage message)
                           throws MailSenderException
MIMEメッセージに対して操作を行います。 このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
message - メッセージ
例外:
MailSenderException - メッセージ操作中に例外が発生。

addHeader

public void addHeader(String name,
                      String value)
ヘッダーを追加します。

パラメータ:
name - ヘッダーの名前
value - ヘッダーの値

addReplyTo

public void addReplyTo(String replyto)
ReplyToを追加します。

パラメータ:
replyto - ReplyToに追加するメールアドレス

setFrom

public void setFrom(String address)
Fromを設定します。

パラメータ:
address - メールアドレス

setFrom

public void setFrom(String address,
                    String personal)
Fromを設定します。

パラメータ:
address - メールアドレス
personal - 名前

setSubject

public void setSubject(String subject)
Subjectを設定します。

パラメータ:
subject - Subject

addTo

public void addTo(String address)
Toを追加します。

パラメータ:
address - メールアドレス

addTo

public void addTo(String address,
                  String personal)
Toを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addCc

public void addCc(String address)
Ccを追加します。

パラメータ:
address - メールアドレス

addCc

public void addCc(String address,
                  String personal)
Ccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addBcc

public void addBcc(String address)
Bccを追加します。

パラメータ:
address - メールアドレス

addBcc

public void addBcc(String address,
                   String personal)
Bccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

setText

public void setText(String text)
本文を設定します。

パラメータ:
text - 本文

addAttachment

public void addAttachment(String filename,
                          String file)
添付ファイルを追加します。

パラメータ:
filename - 添付ファイル名
file - ファイル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSender (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail
インタフェース MailSender

既知の実装クラスの一覧:
JavaMailSender
public interface MailSender

メールを送信するためのインターフェースです。

導入されたバージョン:
5.0

メソッドの概要
 void send()
メールを送信します。

メソッドの詳細

send

public void send()
          throws MailSenderException
メールを送信します。

例外:
MailSenderException - メール送信時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSenderException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail
クラス MailSenderException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.mail.MailSenderException
すべての実装インタフェース:
Serializable
public class MailSenderException
extends Exception

メール送信時またはその他の不正な処理に関する情報を提供する例外です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
MailSenderException()
MailSenderExceptionを構築します。
MailSenderException(String message)
指定された詳細メッセージを使用してMailSenderExceptionを構築します。
MailSenderException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。
MailSenderException(Throwable cause)
指定された原因を使用してMailSenderExceptionを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MailSenderException

public MailSenderException()
MailSenderExceptionを構築します。

MailSenderException

public MailSenderException(String message)
指定された詳細メッセージを使用してMailSenderExceptionを構築します。

パラメータ:
message -

MailSenderException

public MailSenderException(String message,
                           Throwable cause)
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。

パラメータ:
message -
cause -

MailSenderException

public MailSenderException(Throwable cause)
指定された原因を使用してMailSenderExceptionを構築します。

パラメータ:
cause -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.mail
インタフェース
MailSender
例外
MailSenderException


jp.co.intra_mart.foundation.mail (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail

メール送信に関するクラスを提供します。

参照:
説明

インタフェースの概要
MailSender メールを送信するためのインターフェースです。

例外の概要
MailSenderException メール送信時またはその他の不正な処理に関する情報を提供する例外です。

パッケージ jp.co.intra_mart.foundation.mail の説明

メール送信に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.mail クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.MailSenderException

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.MailSender
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.mail の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail の使用

jp.co.intra_mart.foundation.mail を使用しているパッケージ
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail により使用される jp.co.intra_mart.foundation.mail のクラス
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail のクラス
MailSender
メールを送信するためのインターフェースです。
MailSenderException
メール送信時またはその他の不正な処理に関する情報を提供する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer の使用

AbstractTreeNodeContainer を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での AbstractTreeNodeContainer の使用

jp.co.intra_mart.foundation.page での AbstractTreeNodeContainer のサブクラス
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeRoot ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.EventScript の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.EventScript の使用

jp.co.intra_mart.foundation.page.EventScript はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.NodeNameComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.NodeNameComparator の使用

jp.co.intra_mart.foundation.page.NodeNameComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.NodeTypeComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.NodeTypeComparator の使用

jp.co.intra_mart.foundation.page.NodeTypeComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeBranch の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeBranch の使用

TreeBranch を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeBranch の使用

TreeBranch 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
void | TreeBranch.setAll(TreeBranch branch) 指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
void | AbstractTreeNodeContainer.addChildBranch(TreeBranch branch) 指定されたブランチ branchを子ノードとして追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeLeaf の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeLeaf の使用

TreeLeaf を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeLeaf の使用

TreeLeaf 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
 void AbstractTreeNodeContainer.addChildLeaf(TreeLeaf leaf)
指定されたリーフ leafを子ノードとして追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNode の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNode の使用

TreeNode を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNode の使用

TreeNode を実装している jp.co.intra_mart.foundation.page のクラス
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeLeaf ツリービュー内の「ページ」をあらわすクラスです。

TreeNode 型のパラメータを持つ jp.co.intra_mart.foundation.page のメソッド
void | AbstractTreeNodeContainer.addChildNode(TreeNode node) 指定されたノード node を子ノードとして追加します。
boolean | AbstractTreeNodeContainer.hasChildNode(TreeNode node) 指定されたノード node を持っているか調べます。
boolean | AbstractTreeNodeContainer.removeChildNode(TreeNode node) 指定されたノード node をこのノードの子から削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNodeContainer の使用

TreeNodeContainer を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNodeContainer の使用

jp.co.intra_mart.foundation.page での TreeNodeContainer のサブインタフェース
 interface TreeNodeProvider
ツリービューの「ホーム」をあらわすインターフェースです。

TreeNodeContainer を実装している jp.co.intra_mart.foundation.page のクラス
class | AbstractTreeNodeContainer ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
class | TreeBranch ツリービュー内の「フォルダ」をあらわすクラスです。
class | TreeRoot ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.page.TreeNodeProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.page.TreeNodeProvider の使用

TreeNodeProvider を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page での TreeNodeProvider の使用

TreeNodeProvider を実装している jp.co.intra_mart.foundation.page のクラス
 class TreeRoot
ツリービュー内の「ホーム」をあらわすクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.page.TreeRoot の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.page.TreeRoot の使用

jp.co.intra_mart.foundation.page.TreeRoot はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractTreeNodeContainer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス AbstractTreeNodeContainer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
すべての実装インタフェース:
TreeNodeContainer
直系の既知のサブクラス:
TreeBranch, TreeRoot
public abstract class AbstractTreeNodeContainer
extends Object
implements TreeNodeContainer

ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
この抽象クラスを使用して、ツリービューの「ホーム」と「フォルダ」は子ノードの追加、削除などの処理を行います。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
AbstractTreeNodeContainer()
子ノードを追加順に並べる、新しいオブジェクトを生成します。
AbstractTreeNodeContainer(Comparator comparator)
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。
メソッドの概要
void | addChildBranch(TreeBranch branch) 指定されたブランチ branchを子ノードとして追加します。
void | addChildLeaf(TreeLeaf leaf) 指定されたリーフ leafを子ノードとして追加します。
void | addChildNode(TreeNode node) 指定されたノード node を子ノードとして追加します。
Collection | getChildNodes() このノードの子ノードをすべて含む Collectionを返します。
boolean | hasChildNode(TreeNode node) 指定されたノード node を持っているか調べます。
boolean | hasChildNodes() このノードが子ノードを持っているかどうかを判断します。
boolean | isEmpty() このノードの下に子ノードがないか調べます。
boolean | removeChildNode(TreeNode node) 指定されたノード node をこのノードの子から削除します。
void | removeChildNodes() 子ノードを全て削除します。
int | size() このノードが持つ子ノードの数を返します。
void | sort(Comparator comparator) 指定されたコンパレータに従って、子ノードをソートします。
void | sortAll(Comparator comparator) このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractTreeNodeContainer

public AbstractTreeNodeContainer()
子ノードを追加順に並べる、新しいオブジェクトを生成します。

AbstractTreeNodeContainer

public AbstractTreeNodeContainer(Comparator comparator)
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。

パラメータ:
comparator - コンパレータ
メソッドの詳細

addChildNode

public void addChildNode(TreeNode node)
                  throws NullPointerException
指定されたノード node を子ノードとして追加します。

パラメータ:
node - ツリーノード
例外:
NullPoiterException - 引数がnullだった場合
NullPointerException

addChildBranch

public void addChildBranch(TreeBranch branch)
                    throws NullPointerException
指定されたブランチ branchを子ノードとして追加します。

パラメータ:
branch - ブランチ
例外:
NullPointerException - 引数がnullだった場合

addChildLeaf

public void addChildLeaf(TreeLeaf leaf)
指定されたリーフ leafを子ノードとして追加します。

パラメータ:
leaf - リーフ
例外:
NullPointerException - 引数がnullだった場合

hasChildNode

public boolean hasChildNode(TreeNode node)
指定されたノード node を持っているか調べます。 持っているときはtrueを返します。

パラメータ:
node - 子として持っているかどうか調べるノード
戻り値:
指定されたノードを持つときはtrue、持っていないときはfalseを返します。

removeChildNode

public boolean removeChildNode(TreeNode node)
指定されたノード　node をこのノードの子から削除します。

パラメータ:
node - 削除指定されたノード
戻り値:
削除に成功したときはtrue、削除に失敗したときはfalseを返します。

removeChildNodes

public void removeChildNodes()
子ノードを全て削除します。

sort

public void sort(Comparator comparator)
          throws NullPointerException
指定されたコンパレータに従って、子ノードをソートします。 このメソッド呼出後、子ノードの追加は指定されたコンパレータに従ってソートされます。

パラメータ:
comparator - コンパレータ
例外:
NullPoiterException - 引数がnullだったとき
NullPointerException

sortAll

public void sortAll(Comparator comparator)
             throws NullPointerException
このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 引数がnullだったとき

getChildNodes

public Collection getChildNodes()
このノードの子ノードをすべて含む Collectionを返します。 もし、一つも子ノードがない時は空のCollectionが返されます。

定義:
インタフェース TreeNodeContainer 内の getChildNodes
戻り値:
子ノードを含むCollection

hasChildNodes

public boolean hasChildNodes()
このノードが子ノードを持っているかどうかを判断します。 持っているときは、trueを返します。

定義:
インタフェース TreeNodeContainer 内の hasChildNodes
戻り値:
持ってるときは、trueを返します。

isEmpty

public boolean isEmpty()
このノードの下に子ノードがないか調べます。 このノードが一つも子を持っていないときにtrueを返します。

定義:
インタフェース TreeNodeContainer 内の isEmpty
戻り値:
子を持っていないときにtrueを返します。

size

public int size()
このノードが持つ子ノードの数を返します。

定義:
インタフェース TreeNodeContainer 内の size
戻り値:
子ノードの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventScript (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス EventScript

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.EventScript
public class EventScript
extends Object

ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。

このオブジェクトが作成するスクリプトは JavaScript 1.2 に準拠します。

このオブジェクトが作成するスクリプトの動作にはクッキーを利用しています。 クッキーの容量制限を越える量の値をやり取り(監視や受取)はできません。 また、クッキーを保存する際、クッキーの path 属性は 「/」で値を保存 していますので、この機能で扱うデータは、セキュリティ的に問題のない 範囲にとどめるか、またはセキュリティ的に問題となる場合には、 他の方法を利用するようにして下さい。

イベント同士でやり取りできる値の変数型は、クッキーの制約により 文字列型のみとなります。他の変数型の値に関しては、イベントでの入出力に おいて、データの整合性が保証されません。

このオブジェクトは、新しいインスタンスが構築されるたびに内部のシーケンサに より各々のインスタンスに対してＩＤが割り振られています。このＩＤは、 ブラウザでイベントが実行された時にイベントのスクリプトが誤動作をしない ように各変数や関数名称に利用されています。
従って、１つのインスタンスから複数回にわたりスクリプトを生成して １つのページで動作させた場合、それらのスクリプトは誤動作をします。
またＩＤは、0 から始まり 255 までカウントされ、256 に達した時点で 再び 0 からインクリメントされるように実装されています。つまり、初めて 構築されたインスタンスと 257 回目に構築されたインスタンスにより 生成されたイベントのためのスクリプトを同じページで実行した場合、 誤動作を起こします。

JSP でこのクラスを利用する場合の例

<% EventScript es = new EventScript("my_event"); %>
<% es.setOnChange("window.alert(\"Change!!\");"); %>
<SCRIPT> <%= es.getScript(); %> </SCRIPT>

フィールドの概要
protected static int counter
このクラスからインスタンスが生成された回数。
コンストラクタの概要
EventScript(String name)
イベントスクリプトを作成するためのインスタンスを構築します。
メソッドの概要
String | getLanguage() 言語名を返します。
String | getLanguageVersion() 言語のバージョンを返します。
String | getScript() 設定された情報からイベントのためのスクリプトを作成します。
void | setFocus(String valName) イベントとして監視する変数名を指定します。
void | setInitialize(String value) イベントの初期値を指定します。
void | setOnChange(String src) 監視している値に変更があった場合に実行するスクリプトを指定します。
void | setReceive(String valName) イベントから値を受け取る変数名を指定します。
int | setTimer(int millis) イベントの監視間隔を設定します。
String | toString() このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

counter

protected static volatile int counter
このクラスからインスタンスが生成された回数。

この値は、0 から 255 の範囲で加算されていき、256 に達した時 0 にリセットされて再び加算されていきます。

コンストラクタの詳細

EventScript

public EventScript(String name)
イベントスクリプトを作成するためのインスタンスを構築します。

引数 name は、このイベントのＩＤになります。 同じＩＤを持つ EventScript のインスタンスから生成されたイベントは ブラウザで実行された時に、それぞれ連携しあうことができます。

パラメータ:
name - このイベントのＩＤ
例外:
NullPointerException - 引数が null
メソッドの詳細

getLanguage

public String getLanguage()
言語名を返します。

このオブジェクトの生成するスクリプトは、このメソッドの返す言語に準拠 しています。 ブラウザが、この言語に対応していない場合、イベントのスクリプトは 正常に動作しません。

戻り値:
生成されるスクリプトの言語名

getLanguageVersion

public String getLanguageVersion()
言語のバージョンを返します。

このオブジェクトの生成するスクリプトは、メソッド getLanguage() の返す 言語のこのメソッドの返すバージョンに準拠しています。 ブラウザが、この言語のバージョンに対応していない場合、 イベントのスクリプトは正常に動作しません。

戻り値:
生成されるスクリプトの言語のバージョン
関連項目:
getLanguage()

setTimer

public int setTimer(int millis)
イベントの監視間隔を設定します。

指定のミリ秒間隔で変数を監視します。
インスタンス構築時の初期値は 250 ミリ秒に設定されています。この値を 小さくする事で EventScript 同士の連携のタイミングをよりリアルタイムに することができますが、クライアント・コンピュータに大きな負荷が かかってしまいます。
戻り値は、前に設定されていた値です。

パラメータ:
millis - 監視間隔（ミリ秒）
戻り値:
前に設定されていた値

setReceive

public void setReceive(String valName)
イベントから値を受け取る変数名を指定します。

ここでは、イベントから値を受け取るための変数名称を指定します。
変数は、ブラウザ上で動作するスクリプトで扱える変数に限ります。

パラメータ:
valName - 変数名称

setFocus

public void setFocus(String valName)
イベントとして監視する変数名を指定します。

ここでは、イベントで値を監視する変数名称を指定します。
変数は、ブラウザ上で動作するスクリプトで扱える変数に限ります。

パラメータ:
valName - 変数名称

setInitialize

public void setInitialize(String value)
イベントの初期値を指定します。

イベント内部の監視変数の初期値を設定します。
初期値を監視対象変数の現在値と同じ値に設定する事により イベント動作開始時の setOnChange() の誤動作を 未然に防ぐ事が出来ます。

パラメータ:
value - 初期値
関連項目:
setOnChange(java.lang.String)

setOnChange

public void setOnChange(String src)
監視している値に変更があった場合に実行するスクリプトを指定します。

スクリプトは、ブラウザ上で動作するスクリプトに限ります。

パラメータ:
src - 変更イベント発生時に実行するスクリプト

getScript

public String getScript()
設定された情報からイベントのためのスクリプトを作成します。

このメソッドの返すスクリプトがブラウザ上で実行された時 イベントとして動作します。

戻り値:
スクリプトのソース

toString

public String toString()
このオブジェクトの文字列表現を返します。

実際には、このメソッドの結果は getScript() と同じです。

戻り値:
このオブジェクトの文字列表現
関連項目:
getScript()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NodeNameComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス NodeNameComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.NodeNameComparator
すべての実装インタフェース:
Comparator, Serializable
public class NodeNameComparator
extends Object
implements Comparator, Serializable

ツリービューのノードを名前順にソートするためのコンパレータです。 並びは名前の昇順になります。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NodeNameComparator()
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

NodeNameComparator

public NodeNameComparator()
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドはツリービューのノードを名前で昇順にソートすることを目的としています。 もし、arg0とarg1が同じ名前でarg0.equals(arg1) == falseの時は正の整数を返します。arg0.equals(arg1)==trueの時は0を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NodeTypeComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス NodeTypeComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
        拡張 jp.co.intra_mart.foundation.page.NodeTypeComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
public class NodeTypeComparator
extends AbstractDualComparator

ツリービューのノードを種類順にソートするためのコンパレータです。
並び順は「フォルダ」、「ページ」の順になります。 比較対象の２つノードの種類が同じときは、コンストラクタで与えられた、 第２コンパレータで比較を行い、その結果を返します。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NodeTypeComparator(Comparator secondaryComparator)
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。
メソッドの概要
Comparator | getPrimaryComparator() 第１コンパレータを取得します。
Comparator | getSecondaryComparator() 第２コンパレータを取得します。
クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

NodeTypeComparator

public NodeTypeComparator(Comparator secondaryComparator)
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。

パラメータ:
secondaryComparator - 第２コンパレータ
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
第１コンパレータを取得します。
このクラスの第１コンパレータは、ツリービューのノードを種類順にソートするコンパレータです。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
第２コンパレータを取得します。
このクラスの第２コンパレータは、コンストラクタで指定されたコンパレータです。

戻り値:
第２コンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.page (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.page
インタフェース
TreeNode
TreeNodeContainer
TreeNodeProvider
クラス
AbstractTreeNodeContainer
EventScript
NodeNameComparator
NodeTypeComparator
TreeBranch
TreeLeaf
TreeRoot


jp.co.intra_mart.foundation.page (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.page

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

参照:
説明

インタフェースの概要
TreeNode | ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer | 子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider | ツリービューの「ホーム」をあらわすインターフェースです。

クラスの概要
AbstractTreeNodeContainer | ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
EventScript | ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。
NodeNameComparator | ツリービューのノードを名前順にソートするためのコンパレータです。
NodeTypeComparator | ツリービューのノードを種類順にソートするためのコンパレータです。
TreeBranch | ツリービュー内の「フォルダ」をあらわすクラスです。
TreeLeaf | ツリービュー内の「ページ」をあらわすクラスです。
TreeRoot | ツリービュー内の「ホーム」をあらわすクラスです。

パッケージ jp.co.intra_mart.foundation.page の説明

ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.page クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.page の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.page.NodeTypeComparator
    • class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer (implements jp.co.intra_mart.foundation.page.TreeNodeContainer)
      • class jp.co.intra_mart.foundation.page.TreeBranch (implements jp.co.intra_mart.foundation.page.TreeNode)
      • class jp.co.intra_mart.foundation.page.TreeRoot (implements jp.co.intra_mart.foundation.page.TreeNodeProvider)
    • class jp.co.intra_mart.foundation.page.EventScript
    • class jp.co.intra_mart.foundation.page.NodeNameComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.foundation.page.TreeLeaf (implements jp.co.intra_mart.foundation.page.TreeNode)

インタフェース階層

  • interface jp.co.intra_mart.foundation.page.TreeNode
  • interface jp.co.intra_mart.foundation.page.TreeNodeContainer
    • interface jp.co.intra_mart.foundation.page.TreeNodeProvider
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.page の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.page の使用

jp.co.intra_mart.foundation.page を使用しているパッケージ
jp.co.intra_mart.foundation.page ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.page により使用される jp.co.intra_mart.foundation.page のクラス
AbstractTreeNodeContainer
ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
TreeBranch
ツリービュー内の「フォルダ」をあらわすクラスです。
TreeLeaf
ツリービュー内の「ページ」をあらわすクラスです。
TreeNode
ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer
子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider
ツリービューの「ホーム」をあらわすインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


TreeBranch (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeBranch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
        拡張 jp.co.intra_mart.foundation.page.TreeBranch
すべての実装インタフェース:
TreeNode, TreeNodeContainer
public class TreeBranch
extends AbstractTreeNodeContainer
implements TreeNode

ツリービュー内の「フォルダ」をあらわすクラスです。
TreeNodeインターフェースの実装クラスのインスタンスを子ノードとして持つことが出来ます。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeBranch()
新しいTreeBranchオブジェクトを生成します。
TreeBranch(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。
メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。
void | setAll(TreeBranch branch) 指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
void | setArgument(String argument) 引数文字列を設定します。
void | setName(String name) 項目の表示名称のを設定します。
void | setNote(String note) マウスポイント時に表示されるポップアップ文字列を設定します。
クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer から継承したメソッド
addChildBranch, addChildLeaf, addChildNode, getChildNodes, hasChildNode, hasChildNodes, isEmpty, removeChildNode, removeChildNodes, size, sort, sortAll
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TreeBranch

public TreeBranch()
新しいTreeBranchオブジェクトを生成します。

TreeBranch

public TreeBranch(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。

パラメータ:
comparator - コンパレータ
メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

定義:
インタフェース TreeNode 内の getName
戻り値:
項目の表示名称

setName

public void setName(String name)
項目の表示名称のを設定します。

パラメータ:
name - 項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

定義:
インタフェース TreeNode 内の getNote
戻り値:
ポップアップ文字列

setNote

public void setNote(String note)
マウスポイント時に表示されるポップアップ文字列を設定します。

パラメータ:
note - ポップアップ文字列

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

定義:
インタフェース TreeNode 内の getArgument
戻り値:
引数文字列

setArgument

public void setArgument(String argument)
引数文字列を設定します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

パラメータ:
argument - 引数文字列

setAll

public void setAll(TreeBranch branch)
指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。

パラメータ:
branch - 指定されたブランチ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeLeaf (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeLeaf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.TreeLeaf
すべての実装インタフェース:
TreeNode
public class TreeLeaf
extends Object
implements TreeNode

ツリービュー内の「ページ」をあらわすクラスです。 このクラスは子ノードを持つことが出来ません。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeLeaf()
新しくTreeLeafオブジェクトを生成します。
TreeLeaf(String name)
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。
TreeLeaf(String name, String note)
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。
メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。
void | setArgument(String argument) マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。
void | setName(String name) 項目の表示名称を設定します。
void | setNote(String note) マウスポイント時に表示されるポップアップ文字列を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TreeLeaf

public TreeLeaf()
新しくTreeLeafオブジェクトを生成します。

TreeLeaf

public TreeLeaf(String name)
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。

パラメータ:
name - 表示名称

TreeLeaf

public TreeLeaf(String name,
                String note)
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。

パラメータ:
name - 表示名称
note - ポップアップ文字列
メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

定義:
インタフェース TreeNode 内の getName
戻り値:
項目の表示名称

setName

public void setName(String name)
項目の表示名称を設定します。

パラメータ:
name - 項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

定義:
インタフェース TreeNode 内の getNote
戻り値:
note ポップアップ文字列

setNote

public void setNote(String note)
マウスポイント時に表示されるポップアップ文字列を設定します。

パラメータ:
note -

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

定義:
インタフェース TreeNode 内の getArgument
戻り値:
JavaScript JavaScript関数に渡される引数文字列

setArgument

public void setArgument(String argument)
マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。

パラメータ:
argument - 引数文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeNode (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNode

既知の実装クラスの一覧:
TreeBranch, TreeLeaf
public interface TreeNode

ツリービュー内の単一のノードを表すインターフェースです。 ツリービュー表示時の表示名称、ポップアップ文字列、JavaScript 関数に渡される引数文字列を取得するメソッドを持ちます。

導入されたバージョン:
version 4.3
バージョン:
1.0

メソッドの概要
String | getArgument() 引数文字列を取得します。
String | getName() 項目の表示名称のを取得します。
String | getNote() マウスポイント時に表示されるポップアップ文字列を取得します。

メソッドの詳細

getName

public String getName()
項目の表示名称のを取得します。

戻り値:
項目の表示名称

getNote

public String getNote()
マウスポイント時に表示されるポップアップ文字列を取得します。

戻り値:
ポップアップ文字列

getArgument

public String getArgument()
引数文字列を取得します。引数文字列はマウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡されます。

戻り値:
引数文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreeNodeContainer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNodeContainer

既知のサブインタフェースの一覧:
TreeNodeProvider
既知の実装クラスの一覧:
AbstractTreeNodeContainer, TreeRoot
public interface TreeNodeContainer

子ノードを参照するためのメソッドが定義されたインターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Collection | getChildNodes() このノードの子をすべて含む Collectionを返します。
boolean | hasChildNodes() このノードが子ノードを持っているかどうかを判断します。
boolean | isEmpty() このノードが一つも子を持っていないときにtrueを返します。
int | size() このノードが持つ子ノードの数を返します。

メソッドの詳細

getChildNodes

public Collection getChildNodes()
このノードの子をすべて含む Collectionを返します。 もし、一つも子ノードがない時は空のCollectionが返されます。

戻り値:
子ノードを含むCollection

hasChildNodes

public boolean hasChildNodes()
このノードが子ノードを持っているかどうかを判断します。 持っているときは、trueを返します。

戻り値:
持ってるときは、trueを返します。

isEmpty

public boolean isEmpty()
このノードが一つも子を持っていないときにtrueを返します。

戻り値:
子を持っていないときにtrueを返します。

size

public int size()
このノードが持つ子ノードの数を返します。

戻り値:
子ノードの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TreeNodeProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
インタフェース TreeNodeProvider

すべてのスーパーインタフェース:
TreeNodeContainer
既知の実装クラスの一覧:
TreeRoot
public interface TreeNodeProvider
extends TreeNodeContainer

ツリービューの「ホーム」をあらわすインターフェースです。 ツリービューの「ホーム」をあらわすクラスを作成するときは必ずこのインターフェースを実装する必要があります。

導入されたバージョン:
version 4.3
バージョン:
1.0

メソッドの概要
 Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer から継承したメソッド
getChildNodes, hasChildNodes, isEmpty, size

メソッドの詳細

getNodeSet

public Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。

戻り値:
ルート以外の全てのノードが含まれるSet
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreeRoot (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.page
クラス TreeRoot

java.lang.Object
    拡張 jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer
        拡張 jp.co.intra_mart.foundation.page.TreeRoot
すべての実装インタフェース:
TreeNodeContainer, TreeNodeProvider
public class TreeRoot
extends AbstractTreeNodeContainer
implements TreeNodeProvider

ツリービュー内の「ホーム」をあらわすクラスです。 子のクラスのオブジェクトは、ツリービュー内に一つだけ存在し、ツリーの原点となるノードです。

導入されたバージョン:
version 4.3
バージョン:
1.0

コンストラクタの概要
TreeRoot()
新しいTreeRootオブジェクトを生成します。
TreeRoot(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。
メソッドの概要
 Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
クラス jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer から継承したメソッド
addChildBranch, addChildLeaf, addChildNode, getChildNodes, hasChildNode, hasChildNodes, isEmpty, removeChildNode, removeChildNodes, size, sort, sortAll
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.page.TreeNodeContainer から継承したメソッド
getChildNodes, hasChildNodes, isEmpty, size

コンストラクタの詳細

TreeRoot

public TreeRoot()
新しいTreeRootオブジェクトを生成します。

TreeRoot

public TreeRoot(Comparator comparator)
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。

パラメータ:
comparator - 指定されたコンパレータ
メソッドの詳細

getNodeSet

public Set getNodeSet()
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。

定義:
インタフェース TreeNodeProvider 内の getNodeSet
戻り値:
ルート以外の全てのノードが含まれるSet
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.auth.SapConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapConnector の使用

SapConnector を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SapConnector の使用

SapConnector 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.auth のメソッド
static com.sap.mw.jco.JCO.Repository SapRepositoryManager.getJCORepository(SapConnector sapConnector)
Repository情報を生成もしくは、取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException の使用

SAPAuthAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.common.auth のコンストラクタ
SapConnector(String serverType)
プロパティファイルを読込み属性に値をセットします。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void BapiController.executeBapi()
BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException の使用

SAPAuthSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.auth のメソッド
static com.sap.mw.jco.JCO.Repository | SapRepositoryManager.getJCORepository(SapConnector sapConnector) Repository情報を生成もしくは、取得します。
com.sap.mw.jco.JCO.Client | SapConnector.useConnection() コネクションを生成します。
static void | SapConnector.releaseConnection(com.sap.mw.jco.JCO.Client connection) コネクションをリリースします。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.auth のコンストラクタ
SapConnector()
プロパティファイルを読込み属性に値をセットします。
SapConnector(String serverType)
プロパティファイルを読込み属性に値をセットします。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void BapiController.executeBapi()
BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

jp.co.intra_mart.foundation.sap.common.util.file での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.file のコンストラクタ
PropertiesFile(String fileName)
ファイル名を指定してプロパティファイルを取得します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.auth.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.common.auth.exception
例外
SAPAuthAppException
SAPAuthSystemException


jp.co.intra_mart.foundation.sap.common.auth.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception

ＳＡＰ連携に関する例外クラスを提供します。

参照:
説明

例外の概要
SAPAuthAppException | 認証系APIアプリケーション例外クラス
SAPAuthSystemException | 認証系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の説明

ＳＡＰ連携に関する例外クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.common.auth.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
        • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.auth.exception の使用

jp.co.intra_mart.foundation.sap.common.auth.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.file により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SAPAuthAppException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth.exception
クラス SAPAuthAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
すべての実装インタフェース:
Serializable
public class SAPAuthAppException
extends Exception

認証系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAuthAppException(String message)
認証系APIアプリケーション例外
SAPAuthAppException(String message, Throwable ex)
認証系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAuthAppException

public SAPAuthAppException(String message,
                           Throwable ex)
認証系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAuthAppException

public SAPAuthAppException(String message)
認証系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAuthSystemException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth.exception
クラス SAPAuthSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
すべての実装インタフェース:
Serializable
public class SAPAuthSystemException
extends Exception

認証系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAuthSystemException(String message, Throwable ex)
認証系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAuthSystemException

public SAPAuthSystemException(String message,
                              Throwable ex)
認証系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.auth (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.common.auth
クラス
SapConnector
SapRepositoryManager


jp.co.intra_mart.foundation.sap.common.auth (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

クラスの概要
SapConnector | SAPコネクタークラス 機能は以下の通り 単一ユーザIDで任意のコネクションプールを作成し、R/3にログインします。
SapRepositoryManager | JCO.Repository を管理クラス。

パッケージ jp.co.intra_mart.foundation.sap.common.auth の説明

ＳＡＰ連携に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.common.auth クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.auth.SapConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.common.auth の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.auth の使用

jp.co.intra_mart.foundation.sap.common.auth を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapConnector
SAPコネクタークラス
機能は以下の通り
単一ユーザIDで任意のコネクションプールを作成し、R/3にログインします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SapConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapConnector
すべての実装インタフェース:
Serializable
public class SapConnector
extends Object
implements Serializable

SAPコネクタークラス
機能は以下の通り

  • 単一ユーザIDで任意のコネクションプールを作成し、R/3にログインします。
  • 接続先のR/3サーバが複数存在する場合でも、任意のR/3サーバに接続可能です。

関連項目:
直列化された形式

コンストラクタの概要
SapConnector()
プロパティファイルを読込み属性に値をセットします。
SapConnector(String serverType)
プロパティファイルを読込み属性に値をセットします。
メソッドの概要
String | getAshost() 接続先サーバIPアドレスを取得します｡
String | getClient() クライアントを取得します｡
long | getConnectionTimeout() コネクションのタイムアウトを取得します｡
String | getLang() 言語を取得します｡
String | getPasswd() パスワードを取得します｡
String | getPoolName() プール名称を取得します｡
int | getPoolSize() プール内のコネクション数を取得します｡
String | getServerType() サーバタイプを取得します｡
String | getSysnr() システム番号を取得します｡
long | getTimeoutCheckPeriod() コネクションのタイムアウトのチェック間隔を取得します｡
String | getUser() ユーザを取得します｡
long | getWaitTime() コネクション取得の待機時間を取得します｡
static void | releaseConnection(com.sap.mw.jco.JCO.Client connection) コネクションをリリースします。
void | setAshost(String ashost) 接続先サーバIPアドレスを設定します｡
void | setClient(String client) クライアントを設定します｡
void | setConnectionTimeout(long connectionTimeout) コネクションのタイムアウトを設定します｡
void | setLang(String lang) 言語を設定します｡
void | setPasswd(String passwd) パスワードを設定します｡
void | setPoolName(String poolName) プール名称を設定します｡
void | setPoolSize(int poolSize) プール内のコネクション数を設定します｡
void | setServerType(String serverType) サーバタイプを設定します｡
void | setSysnr(String sysnr) システム番号を設定します｡
void | setTimeoutCheckPeriod(long timeoutCheckPeriod) コネクションのタイムアウトのチェック間隔を設定します｡
void | setUser(String user) ユーザを設定します｡
void | setWaitTime(long waitTime) コネクション取得の待機時間を設定します｡
String | toString() デバッグ用のメソッドです。
com.sap.mw.jco.JCO.Client | useConnection() コネクションを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapConnector

public SapConnector()
             throws SAPAuthSystemException
プロパティファイルを読込み属性に値をセットします。 接続先が１つの場合に使用します。

例外:
SAPAuthSystemException - 認証系システム例外

SapConnector

public SapConnector(String serverType)
             throws SAPAuthAppException,
                    SAPAuthSystemException
プロパティファイルを読込み属性に値をセットします。 接続先が複数の場合に使用します。

パラメータ:
serverType - サーバタイプ
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
メソッドの詳細

setServerType

public void setServerType(String serverType)
サーバタイプを設定します｡

パラメータ:
serverType - サーバタイプ

setClient

public void setClient(String client)
クライアントを設定します｡

パラメータ:
client - クライアント

setUser

public void setUser(String user)
ユーザを設定します｡

パラメータ:
user - ユーザ

setPasswd

public void setPasswd(String passwd)
パスワードを設定します｡

パラメータ:
passwd - パスワード

setLang

public void setLang(String lang)
言語を設定します｡

パラメータ:
lang - 言語

setSysnr

public void setSysnr(String sysnr)
システム番号を設定します｡

パラメータ:
sysnr - システム番号

setAshost

public void setAshost(String ashost)
接続先サーバIPアドレスを設定します｡

パラメータ:
ashost - 接続先サーバIPアドレス

setPoolName

public void setPoolName(String poolName)
プール名称を設定します｡

パラメータ:
poolName - プール名称

setPoolSize

public void setPoolSize(int poolSize)
プール内のコネクション数を設定します｡

パラメータ:
poolSize - プール内のコネクション数

setWaitTime

public void setWaitTime(long waitTime)
コネクション取得の待機時間を設定します｡

パラメータ:
waitTime - コネクション取得の待機時間

setConnectionTimeout

public void setConnectionTimeout(long connectionTimeout)
コネクションのタイムアウトを設定します｡

パラメータ:
connectionTimeout - コネクションのタイムアウト

setTimeoutCheckPeriod

public void setTimeoutCheckPeriod(long timeoutCheckPeriod)
コネクションのタイムアウトのチェック間隔を設定します｡

パラメータ:
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔

getServerType

public String getServerType()
サーバタイプを取得します｡

戻り値:
serverType

getClient

public String getClient()
クライアントを取得します｡

戻り値:
client

getUser

public String getUser()
ユーザを取得します｡

戻り値:
user

getPasswd

public String getPasswd()
パスワードを取得します｡

戻り値:
passwd

getLang

public String getLang()
言語を取得します｡

戻り値:
lang

getSysnr

public String getSysnr()
システム番号を取得します｡

戻り値:
sysnr

getAshost

public String getAshost()
接続先サーバIPアドレスを取得します｡

戻り値:
ashost

getPoolName

public String getPoolName()
プール名称を取得します｡

戻り値:
poolName

getPoolSize

public int getPoolSize()
プール内のコネクション数を取得します｡

戻り値:
poolSize

getWaitTime

public long getWaitTime()
コネクション取得の待機時間を取得します｡

戻り値:
waitTime

getConnectionTimeout

public long getConnectionTimeout()
コネクションのタイムアウトを取得します｡

戻り値:
connectionTimeout

getTimeoutCheckPeriod

public long getTimeoutCheckPeriod()
コネクションのタイムアウトのチェック間隔を取得します｡

戻り値:
timeoutCheckPeriod

useConnection

public com.sap.mw.jco.JCO.Client useConnection()
                                        throws SAPAuthSystemException
コネクションを生成します。

戻り値:
connection
例外:
SAPAuthSystemException - 認証系システム例外

releaseConnection

public static void releaseConnection(com.sap.mw.jco.JCO.Client connection)
                              throws SAPAuthSystemException
コネクションをリリースします。

パラメータ:
connection - コネクション
例外:
SAPAuthSystemException - 認証系システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn の使用

BapiReturn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での BapiReturn の使用

BapiReturn を返す jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 BapiReturn BapiController.getReturn()
ＢＡＰＩ実行結果を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager の使用

ConnectionManager を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException の使用

SAPGeneralAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
String | LineProperty.getSeparateKey(int partIndex) 指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
void | BapiController.putImportParam(String key, String val) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
void | BapiController.putStructParam(String key, String val, String structName) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
void | BapiController.putTableParam(String key, String val, String tableName, int recordNo) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
void | BapiController.executeBapi() BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡ なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

jp.co.intra_mart.foundation.sap.module.accounting での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException の使用

SAPGeneralSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
void | ConnectionManager.commit() ＢＡＰＩ実行結果のCOMMIT処理を行います｡
void | ConnectionManager.rollback() ＢＡＰＩ実行結果のROLLBACK処理を行います｡
void | BapiController.putImportParam(String key, String val) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
void | BapiController.putStructParam(String key, String val, String structName) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
void | BapiController.putTableParam(String key, String val, String tableName, int recordNo) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
void | BapiController.executeBapi() BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡ なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。
boolean | BapiController.isSuccess() ＢＡＰＩ実行が正常に行われたか判定します｡ＢＡＰＩ実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡
String | BapiController.getErrMessage() ＢＡＰＩの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。
String | BapiController.getExportParam(String propKey) export(Export)情報を返します。
HashMap | BapiController.getStructureParam(String paramName) structure(Export)情報を返します。
Iterator | BapiController.getTableParam(String paramName) table(Export)情報を返します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
LineProperty(String propertyKey, String propertyValue)
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
BapiReturn(com.sap.mw.jco.JCO.Structure str)
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(com.sap.mw.jco.JCO.Table tbl)
指定されたJCO.Table情報でBapiReturnを作成します。
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

jp.co.intra_mart.foundation.sap.common.util.data での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.data のメソッド
static String Convertor.convJCOdata(int typ, int len, Object val)
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.general_purpose.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.common.general_purpose.exception
例外
SAPGeneralAppException
SAPGeneralSystemException


jp.co.intra_mart.foundation.sap.common.general_purpose.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

例外の概要
SAPGeneralAppException | 共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException | 共通API/汎用データ取得・追加・更新APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の説明

ＳＡＰ連携に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.common.general_purpose.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose.exception の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.data により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SAPGeneralAppException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose.exception
クラス SAPGeneralAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
すべての実装インタフェース:
Serializable
public class SAPGeneralAppException
extends Exception

共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPGeneralAppException(String message)
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralAppException(String message, Throwable ex)
共通API/汎用データ取得・追加・更新APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPGeneralAppException

public SAPGeneralAppException(String message,
                              Throwable ex)
共通API/汎用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPGeneralAppException

public SAPGeneralAppException(String message)
共通API/汎用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPGeneralSystemException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose.exception
クラス SAPGeneralSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
すべての実装インタフェース:
Serializable
public class SAPGeneralSystemException
extends Exception

共通API/汎用データ取得・追加・更新APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPGeneralSystemException(String message, Throwable ex)
共通API/汎用データ取得・追加・更新APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPGeneralSystemException

public SAPGeneralSystemException(String message,
                                 Throwable ex)
共通API/汎用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BapiController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController
すべての実装インタフェース:
Serializable
public class BapiController
extends Object
implements Serializable

BAPIコントローラクラス
機能は以下の通り

  • ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡
  • 展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開メソッドを使用して取得します｡

関連項目:
直列化された形式

コンストラクタの概要
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
メソッドの概要
void | clear() セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
void | executeBapi() BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡ なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。
ArrayList | getBapiHashList() BapiHashの一覧を取得します。
ArrayList | getBapiReturnList() BapiReturnの一覧を取得します｡
String | getErrMessage() ＢＡＰＩの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。
ArrayList | getExpExpList() プロパティ情報(export(Export))の一覧を取得します｡
String | getExportParam(String propKey) export(Export)情報を返します。
ArrayList | getExpStrList() プロパティ情報(structure(Export))の一覧を取得します｡
ArrayList | getExpTblList() プロパティ情報(table(Export))の一覧を取得します｡
ArrayList | getImpImpList() プロパティ情報(import(Import))の一覧を取得します。
ArrayList | getImpStrList() プロパティ情報(structure(Import))一覧を取得します。
ArrayList | getImpTblList() プロパティ情報(table(Import))の一覧を取得します｡
Properties | getProperty() プロパティファイル情報を取得します。
String | getPropertyName() プロパティファイル名を取得します。
BapiReturn | getReturn() ＢＡＰＩ実行結果を取得します。
Iterator | getReturnList() ＢＡＰＩ実行結果の一覧を取得します。
HashMap | getStructureParam(String paramName) structure(Export)情報を返します。
Iterator | getTableParam(String paramName) table(Export)情報を返します。
boolean | isSuccess() ＢＡＰＩ実行が正常に行われたか判定します｡ＢＡＰＩ実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡
void | putImportParam(String key, String val) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
void | putStructParam(String key, String val, String structName) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
void | putTableParam(String key, String val, String tableName, int recordNo) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
void | setBapiHashList(ArrayList bapiHashList) BapiHashの一覧を設定します｡
void | setBapiReturnList(ArrayList bapiReturnList) BapiReturnの一覧を設定します｡
void | setExpExpList(ArrayList expExpList) プロパティ情報(export(Export))の一覧を設定します｡
void | setExpStrList(ArrayList expStrList) プロパティ情報(structure(Export))の一覧を設定します｡
void | setExpTblList(ArrayList expTblList) プロパティ情報(table(Export))の一覧を設定します｡
void | setImpImpList(ArrayList impImpList) プロパティ情報(import(Import))の一覧を設定します｡
void | setImpStrList(ArrayList impStrList) プロパティ情報(structure(Import))の一覧を設定します｡
void | setImpTblList(ArrayList impTblList) プロパティ情報(table(Import))の一覧を設定します｡
void | setProperty(Properties property) プロパティファイル情報を設定します｡
void | setPropertyName(String propertyName) プロパティファイル名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BapiController

public BapiController(String propertyName,
                      ConnectionManager connectionManager)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
connectionManager - コネクション管理オブジェクト
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

BapiController

public BapiController(String propertyName)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
メソッドの詳細

putImportParam

public void putImportParam(String key,
                           String val)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

putStructParam

public void putStructParam(String key,
                           String val,
                           String structName)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
structName - BapiHashに設定するparamTypeの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

putTableParam

public void putTableParam(String key,
                          String val,
                          String tableName,
                          int recordNo)
                   throws SAPGeneralSystemException,
                          SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
tableName - BapiHashに設定するparamTypeの値
recordNo - BapiHashに設定するrecordNoの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

executeBapi

public void executeBapi()
                 throws SAPGeneralSystemException,
                        SAPGeneralAppException,
                        SAPAuthSystemException,
                        SAPAuthAppException
BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。呼び出し側で明示的にConnectionManager#commit またはConnectionManager#rollbackを実行する必要があります。また、R/3とのコネクションも 上記2メソッド内で行われますので、確実に呼び出すように実装しなくてはなりません。

例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理
SAPAuthAppException - 認証系アプリケーション例外処理

isSuccess

public boolean isSuccess()
                  throws SAPGeneralSystemException
ＢＡＰＩ実行が正常に行われたか判定します｡ＢＡＰＩ実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡

戻り値:
bapiSuccess BAPI実行結果
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getErrMessage

public String getErrMessage()
                     throws SAPGeneralSystemException
ＢＡＰＩの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。全て正常("S" / "")の場合は nullが返却されます｡

戻り値:
buffer BAPI実行結果エラーとなった全てのメッセージ情報
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getExportParam

public String getExportParam(String propKey)
                      throws SAPGeneralSystemException
export(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名、 プロパティファイルのキー情報で一覧から該当するBapiHashオブジェクト を検索して、値を返します｡

パラメータ:
propKey - 検索条件となるPropertyKey
戻り値:
rtnVal 引数のキーに対応する値
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getStructureParam

public HashMap getStructureParam(String paramName)
                          throws SAPGeneralSystemException
structure(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索して返します｡

パラメータ:
paramName - 検索条件となるParamName
戻り値:
retMap 検索結果となるBapiHash
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getTableParam

public Iterator getTableParam(String paramName)
                       throws SAPGeneralSystemException
table(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索し、一覧に格納して返します｡

パラメータ:
paramName - 検索条件となるParamName
戻り値:
retMap 検索結果となるBapiHash
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getReturnList

public Iterator getReturnList()
ＢＡＰＩ実行結果の一覧を取得します。(Table用)

戻り値:
bapiReturnList

getReturn

public BapiReturn getReturn()
ＢＡＰＩ実行結果を取得します。(Structure用)

戻り値:
bapiRet

getBapiHashList

public ArrayList getBapiHashList()
BapiHashの一覧を取得します。

戻り値:
bapiHashList

getProperty

public Properties getProperty()
プロパティファイル情報を取得します。

戻り値:
property

getPropertyName

public String getPropertyName()
プロパティファイル名を取得します。

戻り値:
propertyName

getImpImpList

public ArrayList getImpImpList()
プロパティ情報(import(Import))の一覧を取得します。

戻り値:
impImpList

getImpStrList

public ArrayList getImpStrList()
プロパティ情報(structure(Import))一覧を取得します。

戻り値:
impStrList

getImpTblList

public ArrayList getImpTblList()
プロパティ情報(table(Import))の一覧を取得します｡

戻り値:
impTblList

getExpExpList

public ArrayList getExpExpList()
プロパティ情報(export(Export))の一覧を取得します｡

戻り値:
expExpList

getExpStrList

public ArrayList getExpStrList()
プロパティ情報(structure(Export))の一覧を取得します｡

戻り値:
expStrList

getExpTblList

public ArrayList getExpTblList()
プロパティ情報(table(Export))の一覧を取得します｡

戻り値:
expTblList

getBapiReturnList

public ArrayList getBapiReturnList()
BapiReturnの一覧を取得します｡

戻り値:
bapiReturnList

setBapiHashList

public void setBapiHashList(ArrayList bapiHashList)
BapiHashの一覧を設定します｡

パラメータ:
bapiHashList - BapiHashList

setProperty

public void setProperty(Properties property)
プロパティファイル情報を設定します｡

パラメータ:
property - Property

setPropertyName

public void setPropertyName(String propertyName)
プロパティファイル名を設定します｡

パラメータ:
propertyName - propertyName

setImpImpList

public void setImpImpList(ArrayList impImpList)
プロパティ情報(import(Import))の一覧を設定します｡

パラメータ:
impImpList - impImpList

setImpStrList

public void setImpStrList(ArrayList impStrList)
プロパティ情報(structure(Import))の一覧を設定します｡

パラメータ:
impStrList - impStrList

setImpTblList

public void setImpTblList(ArrayList impTblList)
プロパティ情報(table(Import))の一覧を設定します｡

パラメータ:
impTblList - impTblList

setExpExpList

public void setExpExpList(ArrayList expExpList)
プロパティ情報(export(Export))の一覧を設定します｡

パラメータ:
expExpList - expExpList

setExpStrList

public void setExpStrList(ArrayList expStrList)
プロパティ情報(structure(Export))の一覧を設定します｡

パラメータ:
expStrList - expStrList

setExpTblList

public void setExpTblList(ArrayList expTblList)
プロパティ情報(table(Export))の一覧を設定します｡

パラメータ:
expTblList - expTblList

setBapiReturnList

public void setBapiReturnList(ArrayList bapiReturnList)
BapiReturnの一覧を設定します｡

パラメータ:
bapiReturnList - bapiReturnList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値

clear

public void clear()

セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。

BapiControllerを複数回使用する場合、一度putImportParam()などを実行した後に 同じパラメータをセットする前に実行する必要があります。

実行例は次のようになります。

 BapiController bapiController = new BapiController(...);
 bapiController.putImportParam(...);
 bapiController.putStructParam(...);
 ...
 executeBapi();

 //クリア
 bapiController.clear();

 //BapiControllerを再利用する
 bapiController.putImportParam(...);
 bapiController.putStructParam(...);
 ...
 executeBapi();

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BapiHash (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiHash

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 java.util.HashMap
            拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash
すべての実装インタフェース:
Cloneable, Map, Serializable
public class BapiHash
extends HashMap
implements Serializable

BapiHashクラス
機能は以下の通り

  • 汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡
  • R/3のBAPI処理にて使用されるパラメータの値を保持します。
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
BapiHash(String impExpType, String paramType)
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡
BapiHash(String impExpType, String paramType, String paramName)
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。
BapiHash(String impExpType, String paramType, String paramName, int recordNo)
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。
メソッドの概要
String | getImpExpType() 入力／出力区分を取得します｡
String | getParamName() パラメタ名を取得します｡
String | getParamType() パラメタ属性を取得します｡
int | getRecordNo() レコード番号を取得します｡
void | setImpExpType(String impExpType) 入力／出力区分を設定します｡
void | setParamName(String paramName) パラメタ名を設定します｡
void | setParamType(String paramType) パラメタ属性を設定します｡
void | setRecordNo(int recordNo) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.util.HashMap から継承したメソッド
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
クラス java.util.AbstractMap から継承したメソッド
equals, hashCode
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait
インタフェース java.util.Map から継承したメソッド
equals, hashCode

コンストラクタの詳細

BapiHash

public BapiHash(String impExpType,
                String paramType)
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性

BapiHash

public BapiHash(String impExpType,
                String paramType,
                String paramName)
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性
paramName - BapiHashのパラメタ名

BapiHash

public BapiHash(String impExpType,
                String paramType,
                String paramName,
                int recordNo)
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性
paramName - BapiHashのパラメタ名
recordNo - BapiHashのレコード番号
メソッドの詳細

getImpExpType

public String getImpExpType()
入力／出力区分を取得します｡

戻り値:
impExpType

getParamName

public String getParamName()
パラメタ名を取得します｡

戻り値:
paramName

getParamType

public String getParamType()
パラメタ属性を取得します｡

戻り値:
paramType

getRecordNo

public int getRecordNo()
レコード番号を取得します｡

戻り値:
recordNo

setImpExpType

public void setImpExpType(String impExpType)
入力／出力区分を設定します｡

パラメータ:
impExpType - BapiHashの入出力区分

setParamName

public void setParamName(String paramName)
パラメタ名を設定します｡

パラメータ:
paramName - Importのパラメタ名

setParamType

public void setParamType(String paramType)
パラメタ属性を設定します｡

パラメータ:
paramType - Importのパラメタ属性

setRecordNo

public void setRecordNo(int recordNo)
レコード番号を設定します｡

パラメータ:
recordNo - Importのレコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BapiReturn (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiReturn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn
すべての実装インタフェース:
Serializable
public class BapiReturn
extends Object
implements Serializable

BapiReturnクラス
機能は以下の通り

  • R/3のBAPI処理の実行結果に関する値を保持します。
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
BapiReturn(com.sap.mw.jco.JCO.Structure str)
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(com.sap.mw.jco.JCO.Table tbl)
指定されたJCO.Table情報でBapiReturnを作成します。
メソッドの概要
String | getCode() コードを取得します｡
String | getField() フィールドを取得します｡
String | getId() ＩＤを取得します｡
String | getLogMsgNo() ログメッセージナンバーを取得します｡
String | getLogNo() ログナンバーを取得します｡
String | getMessage() メッセージを取得します｡
String | getMessageV1() メッセージＶ１を取得します｡
String | getMessageV2() メッセージＶ２を取得します｡
String | getMessageV3() メッセージＶ３を取得します｡
String | getMessageV4() メッセージＶ４を取得します｡
String | getNumber() ナンバーを取得します｡
String | getParameter() パラメーターを取得します｡
String | getRow() 行番号を取得します｡
String | getSystem() ＩＤを取得します｡
String | getType() タイプを取得します｡
void | setCode(String code) コードを設定します｡
void | setField(String field) フィールドを設定します｡
void | setId(String id) ＩＤを設定します｡
void | setLogMsgNo(String logMsgNo) ログメッセージナンバーを設定します｡
void | setLogNo(String logNo) ログナンバーを設定します｡
void | setMessage(String message) メッセージを設定します｡
void | setMessageV1(String messageV1) メッセージＶ１を設定します｡
void | setMessageV2(String messageV2) メッセージＶ２を設定します｡
void | setMessageV3(String messageV3) メッセージＶ３を設定します｡
void | setMessageV4(String messageV4) メッセージＶ４を設定します｡
void | setNumber(String number) ナンバーを設定します｡
void | setParameter(String parameter) パラメーターを設定します｡
void | setRow(String row) 行番号を設定します｡
void | setSystem(String system) システムを設定します｡
void | setType(String type) タイプを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BapiReturn

public BapiReturn(com.sap.mw.jco.JCO.Structure str)
           throws SAPGeneralSystemException
指定されたJCO.Structure情報でBapiReturnを作成します。 引数のBAPI RETURN(Structure)情報から属性に値をセットします｡

パラメータ:
str - JCO.Structure
例外:
SAPGeneralSystemException - システム例外処理

BapiReturn

public BapiReturn(com.sap.mw.jco.JCO.Table tbl)
           throws SAPGeneralSystemException
指定されたJCO.Table情報でBapiReturnを作成します。 引数のBAPI RETURN(Table)情報から属性に値をセットします｡

パラメータ:
tbl - JCO.Table
例外:
SAPGeneralSystemException - システム例外処理
メソッドの詳細

getField

public String getField()
フィールドを取得します｡

戻り値:
field

getId

public String getId()
ＩＤを取得します｡

戻り値:
id

getCode

public String getCode()
コードを取得します｡

戻り値:
code

getLogMsgNo

public String getLogMsgNo()
ログメッセージナンバーを取得します｡

戻り値:
logMsgNo

getLogNo

public String getLogNo()
ログナンバーを取得します｡

戻り値:
logNo

getMessage

public String getMessage()
メッセージを取得します｡

戻り値:
message

getMessageV1

public String getMessageV1()
メッセージＶ１を取得します｡

戻り値:
messageV1

getMessageV2

public String getMessageV2()
メッセージＶ２を取得します｡

戻り値:
messageV2

getMessageV3

public String getMessageV3()
メッセージＶ３を取得します｡

戻り値:
messageV3

getMessageV4

public String getMessageV4()
メッセージＶ４を取得します｡

戻り値:
messageV4

getNumber

public String getNumber()
ナンバーを取得します｡

戻り値:
number

getParameter

public String getParameter()
パラメーターを取得します｡

戻り値:
parameter

getRow

public String getRow()
行番号を取得します｡

戻り値:
row

getSystem

public String getSystem()
ＩＤを取得します｡

戻り値:
tableList

getType

public String getType()
タイプを取得します｡

戻り値:
type

setField

public void setField(String field)
フィールドを設定します｡

パラメータ:
field - BapiReturnのfieldの値

setId

public void setId(String id)
ＩＤを設定します｡

パラメータ:
id - BapiReturnのidの値

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
ログメッセージナンバーを設定します｡

パラメータ:
logMsgNo - BapiReturnのlogMsgNoの値

setLogNo

public void setLogNo(String logNo)
ログナンバーを設定します｡

パラメータ:
logNo - BapiReturnのlogNoの値

setMessage

public void setMessage(String message)
メッセージを設定します｡

パラメータ:
message - BapiReturnのmessageの値

setMessageV1

public void setMessageV1(String messageV1)
メッセージＶ１を設定します｡

パラメータ:
messageV1 - BapiReturnのmessageV1の値

setMessageV2

public void setMessageV2(String messageV2)
メッセージＶ２を設定します｡

パラメータ:
messageV2 - BapiReturnのmessageV2の値

setMessageV3

public void setMessageV3(String messageV3)
メッセージＶ３を設定します｡

パラメータ:
messageV3 - BapiReturnのmessageV3の値

setMessageV4

public void setMessageV4(String messageV4)
メッセージＶ４を設定します｡

パラメータ:
messageV4 - BapiReturnのmessageV4の値

setNumber

public void setNumber(String number)
ナンバーを設定します｡

パラメータ:
number - BapiReturnのnumberの値

setParameter

public void setParameter(String parameter)
パラメーターを設定します｡

パラメータ:
parameter - BapiReturnのparameterの値

setRow

public void setRow(String row)
行番号を設定します｡

パラメータ:
row - BapiReturnのrowの値

setSystem

public void setSystem(String system)
システムを設定します｡

パラメータ:
system - BapiReturnのsystemの値

setType

public void setType(String type)
タイプを設定します｡

パラメータ:
type - BapiReturnのtypeの値

setCode

public void setCode(String code)
コードを設定します｡

パラメータ:
code - BapiReturnのcodeの値

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConnectionManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス ConnectionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager
すべての実装インタフェース:
Serializable
public class ConnectionManager
extends Object
implements Serializable

ConnectionManagerクラス

R/3へのコネクション(トランザクション)を管理するクラスです。 commitとrollbackの2つのパブリックメソッドを持ち、業務ロジックの最後に実行することで R/3への変更を確定/取り消しすることができます。 なお、R/3へのコネクションの開放も上記2メソッド内で実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

関連項目:
直列化された形式

コンストラクタの概要
ConnectionManager()
メソッドの概要
void | commit() ＢＡＰＩ実行結果のCOMMIT処理を行います｡
void | rollback() ＢＡＰＩ実行結果のROLLBACK処理を行います｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConnectionManager

public ConnectionManager()
メソッドの詳細

commit

public void commit()
            throws SAPGeneralSystemException
ＢＡＰＩ実行結果のCOMMIT処理を行います｡

例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

rollback

public void rollback()
              throws SAPGeneralSystemException
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineProperty (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス LineProperty

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty
すべての実装インタフェース:
Serializable
public class LineProperty
extends Object
implements Serializable

LinePropertyクラス
機能は以下の通り

  • Propertyファイル１行ごとの情報を保持します｡
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
LineProperty(String propertyKey, String propertyValue)
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
メソッドの概要
String[] | getPropertyKeyPart() プロパティのキーを取得します｡
String | getPropertyValue() プロパティの値を取得します｡
String | getSeparateKey(int partIndex) 指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
void | setPropertyKeyPart(String[] propertyKeyPart) プロパティのキーを設定します｡
void | setPropertyValue(String propertyValue) プロパティの値を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LineProperty

public LineProperty(String propertyKey,
                    String propertyValue)
             throws SAPGeneralSystemException
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。

パラメータ:
propertyKey - PropertyKey
propertyValue - PropertyValue
例外:
SAPGeneralSystemException - システム例外処理
メソッドの詳細

getSeparateKey

public String getSeparateKey(int partIndex)
                      throws SAPGeneralAppException
指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
引数 = 0 の場合：入力／出力区分("import"/"export")
引数 = 1 の場合：パラメータ属性("import(export)"/"structure"/"table")
引数 = 2 の場合：パラメータ名
引数 = 3 の場合：コンポーネント名

パラメータ:
partIndex - propertyKeyPart（分割値の格納用配列）の要素を指定する添字
戻り値:
propertyKeyPart[]
例外:
SAPGeneralAppException - アプリケーション例外処理

getPropertyValue

public String getPropertyValue()
プロパティの値を取得します｡

戻り値:
propertyValue

getPropertyKeyPart

public String[] getPropertyKeyPart()
プロパティのキーを取得します｡

戻り値:
propertyKeyPart

setPropertyValue

public void setPropertyValue(String propertyValue)
プロパティの値を設定します｡

パラメータ:
propertyValue - PropertyValue

setPropertyKeyPart

public void setPropertyKeyPart(String[] propertyKeyPart)
プロパティのキーを設定します｡

パラメータ:
propertyKeyPart - propertyKeyPart

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.general_purpose (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.common.general_purpose
クラス
BapiController
BapiHash
BapiReturn
ConnectionManager
LineProperty


jp.co.intra_mart.foundation.sap.common.general_purpose (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

クラスの概要
BapiController | BAPIコントローラクラス 機能は以下の通り ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡ 展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開メソッドを使用して取得します｡
BapiHash | BapiHashクラス 機能は以下の通り 汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡ R/3のBAPI処理にて使用されるパラメータの値を保持します。
BapiReturn | BapiReturnクラス 機能は以下の通り R/3のBAPI処理の実行結果に関する値を保持します。
ConnectionManager | ConnectionManagerクラス R/3へのコネクション(トランザクション)を管理するクラスです。
LineProperty | LinePropertyクラス 機能は以下の通り Propertyファイル１行ごとの情報を保持します｡ 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の説明

ＳＡＰ連携に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.common.general_purpose クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose の使用

jp.co.intra_mart.foundation.sap.common.general_purpose を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiReturn
BapiReturnクラス
機能は以下の通り
R/3のBAPI処理の実行結果に関する値を保持します。
ConnectionManager
ConnectionManagerクラス
R/3へのコネクション(トランザクション)を管理するクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.data.Convertor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.data.Convertor の使用

jp.co.intra_mart.foundation.sap.common.util.data.Convertor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Convertor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.data
クラス Convertor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.data.Convertor
すべての実装インタフェース:
Serializable
public final class Convertor
extends Object
implements Serializable

Converterクラス
機能は以下の通り

  • SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。

関連項目:
直列化された形式

メソッドの概要
static String convJCOdata(int typ, int len, Object val)
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

convJCOdata

public static String convJCOdata(int typ,
                                 int len,
                                 Object val)
                          throws SAPGeneralSystemException
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。それ以外のパラメータ属性の場合は無変換で 文字列を返します｡

パラメータ:
typ - 設定する項目の属性
len - 設定する項目の項目長
val - 変換対象オブジェクト
戻り値:
retVal 変換後文字列
例外:
SAPGeneralSystemException - システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util.data (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.common.util.data
クラス
Convertor


jp.co.intra_mart.foundation.sap.common.util.data (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.data

ＳＡＰ連携にて使用するデータ変換クラスを提供します。

参照:
説明

クラスの概要
Convertor Converterクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.data の説明

ＳＡＰ連携にて使用するデータ変換クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.common.util.data クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.data.Convertor (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.common.util.data の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.data の使用

jp.co.intra_mart.foundation.sap.common.util.data はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の使用

jp.co.intra_mart.foundation.sap.common.util.date.DateHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DateHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.date
クラス DateHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.date.DateHandler
すべての実装インタフェース:
Serializable
public final class DateHandler
extends Object
implements Serializable

DateHandlerクラス
機能は以下の通り

  • SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

関連項目:
直列化された形式

メソッドの概要
static Date | getDateValue(String strValue) 日付書式[YYYYMMDD]の文字列をDate型に変換します。
static String | getStringDate(Date date) Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。
static String | getSysdate() システム日付を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getSysdate

public static String getSysdate()
システム日付を取得します。

戻り値:
nowDate システム日付[YYYYMMDD]

getStringDate

public static String getStringDate(Date date)
Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。

パラメータ:
date - 日付書式変換前Date型オブジェクト
戻り値:
date 日付書式変換後文字列[YYYYMMDD]

getDateValue

public static Date getDateValue(String strValue)
                         throws ParseException
日付書式[YYYYMMDD]の文字列をDate型に変換します。

パラメータ:
strValue - 日付書式[YYYYMMDD]の文字列
戻り値:
dateValue Date型に変換後の値
例外:
ParseException - 日付変換システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util.date (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.common.util.date
クラス
DateHandler


jp.co.intra_mart.foundation.sap.common.util.date (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.date

ＳＡＰ連携にて使用する日付操作クラスを提供します。

参照:
説明

クラスの概要
DateHandler DateHandlerクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.date の説明

ＳＡＰ連携にて使用する日付操作クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.common.util.date クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.date の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.common.util.date の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.date の使用

jp.co.intra_mart.foundation.sap.common.util.date はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile の使用

jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.util.file (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.common.util.file
クラス
PropertiesFile


jp.co.intra_mart.foundation.sap.common.util.file (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.file

ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。

参照:
説明

クラスの概要
PropertiesFile プロパティファイルクラス
機能は以下の通り
ファイル名を指定してプロパティファイルを呼び出します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.file の説明

ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.common.util.file クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.common.util.file の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.file の使用

jp.co.intra_mart.foundation.sap.common.util.file はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PropertiesFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.file
クラス PropertiesFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile
すべての実装インタフェース:
Serializable
public class PropertiesFile
extends Object
implements Serializable

プロパティファイルクラス
機能は以下の通り

  • ファイル名を指定してプロパティファイルを呼び出します。

関連項目:
直列化された形式

コンストラクタの概要
PropertiesFile(String fileName)
ファイル名を指定してプロパティファイルを取得します。
メソッドの概要
Properties | getProperties() プロパティを取得します｡
void | setPropeties(Properties properties) プロパティを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertiesFile

public PropertiesFile(String fileName)
               throws SAPAuthSystemException
ファイル名を指定してプロパティファイルを取得します。

パラメータ:
fileName - ファイル名
例外:
SAPAuthSystemException - 認証系システム例外
メソッドの詳細

setPropeties

public void setPropeties(Properties properties)
プロパティを設定します｡

パラメータ:
properties - プロパティ

getProperties

public Properties getProperties()
プロパティを取得します｡

戻り値:
properties

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountGl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountTax はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用

jp.co.intra_mart.foundation.sap.module.accounting.Bank はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BankController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用

BankList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BankList の使用

BankList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BankList BankController.getBaList()
銀行一覧を取得します｡

BankList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BankController.setBaList(BankList baList)
銀行一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用

BusinessAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BusinessAreaList の使用

BusinessAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BusinessAreaList BusinessAreaController.getBusAreaList()
事業領域一覧を取得します｡

BusinessAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BusinessAreaController.setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Company の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Company の使用

jp.co.intra_mart.foundation.sap.module.accounting.Company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CompanyController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用

CompanyList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CompanyList の使用

CompanyList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CompanyList CompanyController.getCompList()
会社一覧を取得します｡

CompanyList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CompanyController.setCompList(CompanyList compList)
会社一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用

ControllingAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ControllingAreaList の使用

ControllingAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ControllingAreaList ControllingAreaController.getControllAreaList()
管理領域一覧を取得します｡

ControllingAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ControllingAreaController.setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用

CostCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CostCenterList の使用

CostCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CostCenterList CostCenterController.getCostCentList()
原価センタ一覧を取得します｡

CostCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CostCenterController.setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用

jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用

DocumentHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での DocumentHeader の使用

DocumentHeader を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 DocumentHeader AccEmployeePayPostController.getDocumentHeader()
伝票ヘッダを取得します｡

DocumentHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAcc はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAccController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用

GlAccList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での GlAccList の使用

GlAccList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 GlAccList GlAccController.getGlList()
勘定科目一覧を取得します｡

GlAccList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void GlAccController.setGlList(GlAccList glList)
勘定科目一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用

ProfitCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ProfitCenterList の使用

ProfitCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ProfitCenterList ProfitCenterController.getProfitCentList()
利益センタ一覧を取得します｡

ProfitCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ProfitCenterController.setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用

SAPAccountingAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingAppException の使用

SAPAccountingAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用

SAPAccountingSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingSystemException の使用

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
String | ProfitCenterController.getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
String | ProfitCenterController.getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
String | ProfitCenterController.getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | GlAccController.getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
String | GlAccController.getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | CostCenterController.getName(String costCenter) 原価センタを指定して一般名称を取得します。
String | CostCenterController.getDescript(String costCenter) 原価センタを指定してテキストを取得します。
String | ControllingAreaController.getName(String coArea) 管理領域を指定して管理領域名を取得します。
String | CompanyController.getCompName(String compCode) 会社コードを指定して会社名を取得します。
String | BusinessAreaController.getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
String | BankController.getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | BankController.getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | AccEmployeePayPostController.executeBapi() BapiControllerにより会計伝票を登録します。

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.accounting.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.module.accounting.exception
例外
SAPAccountingAppException
SAPAccountingSystemException


jp.co.intra_mart.foundation.sap.module.accounting.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

ＳＡＰ連携会計系例外クラスを提供します。

参照:
説明

例外の概要
SAPAccountingAppException | 会計系APIアプリケーション例外クラス
SAPAccountingSystemException | 会計系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の説明

ＳＡＰ連携会計系例外クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.module.accounting.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
        • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting.exception のクラス
SAPAccountingAppException
会計系APIアプリケーション例外クラス
SAPAccountingSystemException
会計系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SAPAccountingAppException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
すべての実装インタフェース:
Serializable
public class SAPAccountingAppException
extends Exception

会計系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingAppException(String message)
会計系APIアプリケーション例外
SAPAccountingAppException(String message, Throwable ex)
会計系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingAppException

public SAPAccountingAppException(String message,
                                 Throwable ex)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAccountingAppException

public SAPAccountingAppException(String message)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAccountingSystemException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
すべての実装インタフェース:
Serializable
public class SAPAccountingSystemException
extends Exception

会計系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingSystemException(String message, Throwable ex)
会計系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingSystemException

public SAPAccountingSystemException(String message,
                                    Throwable ex)
会計系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccEmployeePayPostController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccEmployeePayPostController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController
すべての実装インタフェース:
Serializable
public class AccEmployeePayPostController
extends Object
implements Serializable

伝票登録コントローラクラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

コンストラクタの概要
AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
メソッドの概要
void | executeBapi() BapiControllerにより会計伝票を登録します。
ArrayList | getAccountGlList() G/L 勘定明細一覧を取得します｡
ArrayList | getAccountPayableList() 仕入先明細一覧を取得します｡
ArrayList | getAccountTaxList() 税明細一覧を取得します｡
ArrayList | getCurrencyAmountList() 明細通貨項目一覧を取得します｡
DocumentHeader | getDocumentHeader() 伝票ヘッダを取得します｡
void | setAccountGlList(ArrayList accountGlList) G/L 勘定明細一覧を設定します｡
void | setAccountPayableList(ArrayList accountPayableList) 仕入先明細一覧を設定します｡
void | setAccountTaxList(ArrayList accountTaxList) 税明細一覧を設定します｡
void | setCuAmtBase(String cuAmtBase, int index) 明細通貨項目の課税基準額に値を設定します。
void | setCuAmtDoccur(String cuAmtDoccur, int index) 明細通貨項目の伝票通貨額に値を設定します。
void | setCuCurrency(String cuCurrency, int index) 明細通貨項目の通貨コードに値を設定します。
void | setCuItemnoAcc(String cuItemnoAcc, int index) 明細通貨項目の会計伝票明細番号に値を設定します。
void | setCurrencyAmountList(ArrayList currencyAmountList) 明細通貨項目一覧を設定します｡
void | setDocAcDocNo(String docAcDocNo) 伝票ヘッダの会計伝票番号に値を設定します。
void | setDocCompCode(String docCompCode) 伝票ヘッダの会社コードに値を設定します。
void | setDocDocDate(String docDocDate) 伝票ヘッダの伝票の伝票日付に値を設定します。
void | setDocDocType(String docDocType) 伝票ヘッダの伝票タイプに値を設定します。
void | setDocFiscYear(String docFiscYear) 伝票ヘッダの会計年度に値を設定します。
void | setDocFisPeriod(String docFisPeriod) 伝票ヘッダの会計期間に値を設定します。
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダの伝票ヘッダテキストに値を設定します。
void | setDocObjKey(String docObjKey) 伝票ヘッダのオブジェクトキーに値を設定します。
void | setDocObjType(String docObjType) 伝票ヘッダの参照処理に値を設定します。
void | setDocPstngDate(String docPstngDate) 伝票ヘッダの伝票の転記日付に値を設定します。
void | setDocRefDocNo(String docRefDocNo) 伝票ヘッダの参照伝票番号に値を設定します。
void | setDocumentHeader(DocumentHeader documentHeader) 伝票ヘッダを設定します｡
void | setDocUsername(String docUsername) 伝票ヘッダのユーザ名に値を設定します。
void | setGlAllocNmbr(String glAllocNmbr, int index) G/L 勘定明細のソートキーに値を設定します。
void | setGlBusArea(String glBusArea, int index) G/L 勘定明細の事業領域に値を設定します。
void | setGlCompCode(String glCompCode, int index) G/L 勘定明細の会社コードに値を設定します。
void | setGlCostcenter(String glCostcenter, int index) G/L 勘定明細の原価センタに値を設定します。
void | setGlDocType(String glDocType, int index) G/L 勘定明細の伝票タイプに値を設定します。
void | setGlFiscYear(String glFiscYear, int index) G/L 勘定明細の会計年度に値を設定します。
void | setGlGlAccount(String glGlAccount, int index) G/L 勘定明細の総勘定元帳勘定に値を設定します。
void | setGlItemnoAcc(String glItemnoAcc, int index) G/L 勘定明細の会計伝票明細番号に値を設定します。
void | setGlItemText(String glItemText, int index) G/L 勘定明細の明細テキストに値を設定します。
void | setGlOrderid(String glOrderid, int index) G/L 勘定明細の指図番号に値を設定します。
void | setGlPstngDate(String glPstngDate, int index) G/L 勘定明細の伝票の転記日付に値を設定します。
void | setGlRefKey1(String glRefKey1, int index) G/L 勘定明細の取引先参照キーに値を設定します。
void | setGlTaxCode(String glTaxCode, int index) G/L 勘定明細の消費税コードに値を設定します。
void | setGlWbsElement(String glWbsElement, int index) G/L 勘定明細のWBS 要素に値を設定します。
void | setPaAllocNmbr(String paAllocNmbr, int index) 仕入先明細のソートキーに値を設定します。
void | setPaBlineDate(String paBlineDate, int index) 仕入先明細の期日計算の支払基準日に値を設定します。
void | setPaGlAccount(String paGlAccount, int index) 仕入先明細の総勘定元帳勘定に値を設定します。
void | setPaItemnoAcc(String paItemnoAcc, int index) 仕入先明細の会計伝票明細番号に値を設定します。
void | setPaItemText(String paItemText, int index) 仕入先明細の明細テキストに値を設定します。
void | setPaPymtMeth(String paPymtMeth, int index) 仕入先明細の支払方法に値を設定します。
void | setPaVendorNo(String paVendorNo, int index) 仕入先明細の仕入先または債権者の勘定コードに値を設定します。
void | setTaGlAccount(String taGlAccount, int index) 税明細の総勘定元帳勘定に値を設定します。
void | setTaItemnoAcc(String taItemnoAcc, int index) 税明細の会計伝票明細番号に値を設定します。
void | setTaTaxCode(String taTaxCode, int index) 税明細の消費税コードに値を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccEmployeePayPostController

public AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡

メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingAppException,
                        SAPAccountingSystemException
BapiControllerにより会計伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingAppException - 会計業務アプリケーション例外
SAPAccountingSystemException - 会計業務システム例外

setDocObjType

public void setDocObjType(String docObjType)
伝票ヘッダの参照処理に値を設定します。

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
伝票ヘッダのオブジェクトキーに値を設定します。

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
伝票ヘッダのユーザ名に値を設定します。

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダの伝票ヘッダテキストに値を設定します。

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
伝票ヘッダの会社コードに値を設定します。

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
伝票ヘッダの会計伝票番号に値を設定します。

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
伝票ヘッダの会計年度に値を設定します。

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票ヘッダの伝票の伝票日付に値を設定します。

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票ヘッダの伝票の転記日付に値を設定します。

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
伝票ヘッダの会計期間に値を設定します。

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票ヘッダの伝票タイプに値を設定します。

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
伝票ヘッダの参照伝票番号に値を設定します。

パラメータ:
docRefDocNo - 参照伝票番号

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc,
                           int index)
仕入先明細の会計伝票明細番号に値を設定します。

パラメータ:
paItemnoAcc - 会計伝票明細番号
index - レコード番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo,
                          int index)
仕入先明細の仕入先または債権者の勘定コードに値を設定します。

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード
index - レコード番号

setPaGlAccount

public void setPaGlAccount(String paGlAccount,
                           int index)
仕入先明細の総勘定元帳勘定に値を設定します。

パラメータ:
paGlAccount - 総勘定元帳勘定
index - レコード番号

setPaBlineDate

public void setPaBlineDate(String paBlineDate,
                           int index)
仕入先明細の期日計算の支払基準日に値を設定します。

パラメータ:
paBlineDate - 期日計算の支払基準日
index - レコード番号

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth,
                          int index)
仕入先明細の支払方法に値を設定します。

パラメータ:
paPymtMeth - 支払方法
index - レコード番号

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr,
                           int index)
仕入先明細のソートキーに値を設定します。

パラメータ:
paAllocNmbr - ソートキー
index - レコード番号

setPaItemText

public void setPaItemText(String paItemText,
                          int index)
仕入先明細の明細テキストに値を設定します。

パラメータ:
paItemText - 明細テキスト
index - レコード番号

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc,
                           int index)
G/L 勘定明細の会計伝票明細番号に値を設定します。

パラメータ:
glItemnoAcc - 会計伝票明細番号
index - レコード番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount,
                           int index)
G/L 勘定明細の総勘定元帳勘定に値を設定します。

パラメータ:
glGlAccount - 総勘定元帳勘定
index - レコード番号

setGlCompCode

public void setGlCompCode(String glCompCode,
                          int index)
G/L 勘定明細の会社コードに値を設定します。

パラメータ:
glCompCode - 会社コード
index - レコード番号

setGlPstngDate

public void setGlPstngDate(String glPstngDate,
                           int index)
G/L 勘定明細の伝票の転記日付に値を設定します。

パラメータ:
glPstngDate - 伝票の転記日付
index - レコード番号

setGlDocType

public void setGlDocType(String glDocType,
                         int index)
G/L 勘定明細の伝票タイプに値を設定します。

パラメータ:
glDocType - 伝票タイプ
index - レコード番号

setGlFiscYear

public void setGlFiscYear(String glFiscYear,
                          int index)
G/L 勘定明細の会計年度に値を設定します。

パラメータ:
glFiscYear - 会計年度
index - レコード番号

setGlRefKey1

public void setGlRefKey1(String glRefKey1,
                         int index)
G/L 勘定明細の取引先参照キーに値を設定します。

パラメータ:
glRefKey1 - 取引先参照キー
index - レコード番号

setGlItemText

public void setGlItemText(String glItemText,
                          int index)
G/L 勘定明細の明細テキストに値を設定します。

パラメータ:
glItemText - 明細テキスト
index - レコード番号

setGlTaxCode

public void setGlTaxCode(String glTaxCode,
                         int index)
G/L 勘定明細の消費税コードに値を設定します。

パラメータ:
glTaxCode - 消費税コード
index - レコード番号

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr,
                           int index)
G/L 勘定明細のソートキーに値を設定します。

パラメータ:
glAllocNmbr - ソートキー
index - レコード番号

setGlBusArea

public void setGlBusArea(String glBusArea,
                         int index)
G/L 勘定明細の事業領域に値を設定します。

パラメータ:
glBusArea - 事業領域
index - レコード番号

setGlCostcenter

public void setGlCostcenter(String glCostcenter,
                            int index)
G/L 勘定明細の原価センタに値を設定します。

パラメータ:
glCostcenter - 原価センタ
index - レコード番号

setGlOrderid

public void setGlOrderid(String glOrderid,
                         int index)
G/L 勘定明細の指図番号に値を設定します。

パラメータ:
glOrderid - 指図番号
index - レコード番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement,
                            int index)
G/L 勘定明細のWBS 要素に値を設定します。

パラメータ:
glWbsElement - WBS 要素
index - レコード番号

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc,
                           int index)
税明細の会計伝票明細番号に値を設定します。

パラメータ:
taItemnoAcc - 会計伝票明細番号
index - レコード番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount,
                           int index)
税明細の総勘定元帳勘定に値を設定します。

パラメータ:
taGlAccount - 総勘定元帳勘定
index - レコード番号

setTaTaxCode

public void setTaTaxCode(String taTaxCode,
                         int index)
税明細の消費税コードに値を設定します。

パラメータ:
taTaxCode - 消費税コード
index - レコード番号

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc,
                           int index)
明細通貨項目の会計伝票明細番号に値を設定します。

パラメータ:
cuItemnoAcc - 会計伝票明細番号
index - レコード番号

setCuCurrency

public void setCuCurrency(String cuCurrency,
                          int index)
明細通貨項目の通貨コードに値を設定します。

パラメータ:
cuCurrency - 通貨コード
index - レコード番号

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur,
                           int index)
明細通貨項目の伝票通貨額に値を設定します。

パラメータ:
cuAmtDoccur - 伝票通貨額
index - レコード番号

setCuAmtBase

public void setCuAmtBase(String cuAmtBase,
                         int index)
明細通貨項目の課税基準額に値を設定します。

パラメータ:
cuAmtBase - 課税基準額
index - レコード番号

setDocumentHeader

public void setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

パラメータ:
documentHeader - 伝票ヘッダ

setAccountPayableList

public void setAccountPayableList(ArrayList accountPayableList)
仕入先明細一覧を設定します｡

パラメータ:
accountPayableList - 仕入先明細一覧

setAccountGlList

public void setAccountGlList(ArrayList accountGlList)
G/L 勘定明細一覧を設定します｡

パラメータ:
accountGlList - G/L 勘定明細一覧

setAccountTaxList

public void setAccountTaxList(ArrayList accountTaxList)
税明細一覧を設定します｡

パラメータ:
accountTaxList - 税明細一覧

setCurrencyAmountList

public void setCurrencyAmountList(ArrayList currencyAmountList)
明細通貨項目一覧を設定します｡

パラメータ:
currencyAmountList - 明細通貨項目一覧

getDocumentHeader

public DocumentHeader getDocumentHeader()
伝票ヘッダを取得します｡

戻り値:
documentHeader

getAccountPayableList

public ArrayList getAccountPayableList()
仕入先明細一覧を取得します｡

戻り値:
accountPayableList

getAccountGlList

public ArrayList getAccountGlList()
G/L 勘定明細一覧を取得します｡

戻り値:
accountGlList

getAccountTaxList

public ArrayList getAccountTaxList()
税明細一覧を取得します｡

戻り値:
accountTaxList

getCurrencyAmountList

public ArrayList getCurrencyAmountList()
明細通貨項目一覧を取得します｡

戻り値:
accountTaxList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountGl (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountGl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountGl
すべての実装インタフェース:
Serializable
public class AccountGl
extends Object
implements Serializable

G/L 勘定明細クラス
機能は以下の通り

  • G/L 勘定明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountGl(int index)
G/L 勘定明細情報を作成します。
メソッドの概要
String | getGlAllocNmbr() ソートキーを取得します｡
String | getGlBusArea() 事業領域を取得します｡
String | getGlCompCode() 会社コードを取得します｡
String | getGlCostcenter() 原価センタを取得します｡
String | getGlDocType() 伝票タイプを取得します｡
String | getGlFiscYear() 会計年度を取得します｡
String | getGlGlAccount() 総勘定元帳勘定を取得します｡
int | getGlIndex() レコード番号を取得します｡
String | getGlItemnoAcc() 会計伝票明細番号を取得します｡
String | getGlItemText() 明細テキストを取得します｡
String | getGlOrderid() 指図番号を取得します｡
String | getGlPstngDate() 伝票の転記日付を取得します｡
String | getGlRefKey1() 取引先参照キーを取得します｡
String | getGlTaxCode() 消費税コードを取得します｡
String | getGlWbsElement() WBS 要素を取得します｡
void | setGlAllocNmbr(String glAllocNmbr) ソートキーコードを設定します｡
void | setGlBusArea(String glBusArea) 事業領域コードを設定します｡
void | setGlCompCode(String glCompCode) 会社コードコードを設定します｡
void | setGlCostcenter(String glCostcenter) 原価センタコードを設定します｡
void | setGlDocType(String glDocType) 伝票タイプコードを設定します｡
void | setGlFiscYear(String glFiscYear) 会計年度コードを設定します｡
void | setGlGlAccount(String glGlAccount) 総勘定元帳勘定コードを設定します｡
void | setGlIndex(int glIndex) レコード番号を設定します｡
void | setGlItemnoAcc(String glItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setGlItemText(String glItemText) 明細テキストコードを設定します｡
void | setGlOrderid(String glOrderid) 指図番号コードを設定します｡
void | setGlPstngDate(String glPstngDate) 伝票の転記日付コードを設定します｡
void | setGlRefKey1(String glRefKey1) 取引先参照キーコードを設定します｡
void | setGlTaxCode(String glTaxCode) 消費税コードコードを設定します｡
void | setGlWbsElement(String glWbsElement) WBS 要素コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountGl

public AccountGl(int index)
G/L 勘定明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
glItemnoAcc - 会計伝票明細番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
glGlAccount - 総勘定元帳勘定

setGlCompCode

public void setGlCompCode(String glCompCode)
会社コードコードを設定します｡

パラメータ:
glCompCode - 会社コード

setGlPstngDate

public void setGlPstngDate(String glPstngDate)
伝票の転記日付コードを設定します｡

パラメータ:
glPstngDate - 伝票の転記日付

setGlDocType

public void setGlDocType(String glDocType)
伝票タイプコードを設定します｡

パラメータ:
glDocType - 伝票タイプ

setGlFiscYear

public void setGlFiscYear(String glFiscYear)
会計年度コードを設定します｡

パラメータ:
glFiscYear - 会計年度

setGlRefKey1

public void setGlRefKey1(String glRefKey1)
取引先参照キーコードを設定します｡

パラメータ:
glRefKey1 - 取引先参照キー

setGlItemText

public void setGlItemText(String glItemText)
明細テキストコードを設定します｡

パラメータ:
glItemText - 明細テキスト

setGlTaxCode

public void setGlTaxCode(String glTaxCode)
消費税コードコードを設定します｡

パラメータ:
glTaxCode - 消費税コード

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr)
ソートキーコードを設定します｡

パラメータ:
glAllocNmbr - ソートキー

setGlBusArea

public void setGlBusArea(String glBusArea)
事業領域コードを設定します｡

パラメータ:
glBusArea - 事業領域

setGlCostcenter

public void setGlCostcenter(String glCostcenter)
原価センタコードを設定します｡

パラメータ:
glCostcenter - 原価センタ

setGlOrderid

public void setGlOrderid(String glOrderid)
指図番号コードを設定します｡

パラメータ:
glOrderid - 指図番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement)
WBS 要素コードを設定します｡

パラメータ:
glWbsElement - WBS 要素

setGlIndex

public void setGlIndex(int glIndex)
レコード番号を設定します｡

パラメータ:
glIndex - レコード番号

getGlItemnoAcc

public String getGlItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
glItemnoAcc

getGlGlAccount

public String getGlGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
glGlAccount

getGlCompCode

public String getGlCompCode()
会社コードを取得します｡

戻り値:
glCompCode

getGlPstngDate

public String getGlPstngDate()
伝票の転記日付を取得します｡

戻り値:
glPstngDate

getGlDocType

public String getGlDocType()
伝票タイプを取得します｡

戻り値:
glDocType

getGlFiscYear

public String getGlFiscYear()
会計年度を取得します｡

戻り値:
glFiscYear

getGlRefKey1

public String getGlRefKey1()
取引先参照キーを取得します｡

戻り値:
glRefKey1

getGlItemText

public String getGlItemText()
明細テキストを取得します｡

戻り値:
glItemText

getGlTaxCode

public String getGlTaxCode()
消費税コードを取得します｡

戻り値:
glTaxCode

getGlAllocNmbr

public String getGlAllocNmbr()
ソートキーを取得します｡

戻り値:
glAllocNmbr

getGlBusArea

public String getGlBusArea()
事業領域を取得します｡

戻り値:
glBusArea

getGlCostcenter

public String getGlCostcenter()
原価センタを取得します｡

戻り値:
glCostcenter

getGlOrderid

public String getGlOrderid()
指図番号を取得します｡

戻り値:
glOrderid

getGlWbsElement

public String getGlWbsElement()
WBS 要素を取得します｡

戻り値:
glWbsElement

getGlIndex

public int getGlIndex()
レコード番号を取得します｡

戻り値:
giIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountPayable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountPayable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable
すべての実装インタフェース:
Serializable
public class AccountPayable
extends Object
implements Serializable

仕入先明細クラス
機能は以下の通り

  • 仕入先明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountPayable(int index)
仕入先明細情報を作成します。
メソッドの概要
String | getPaAllocNmbr() ソートキーを取得します｡
String | getPaBlineDate() 期日計算の支払基準日を取得します｡
String | getPaGlAccount() 総勘定元帳勘定を取得します｡
int | getPaIndex() レコード番号を取得します｡
String | getPaItemnoAcc() 会計伝票明細番号を取得します｡
String | getPaItemText() 明細テキストを取得します｡
String | getPaPymtMeth() 支払方法を取得します｡
String | getPaVendorNo() 仕入先または債権者の勘定コードを取得します｡
void | setPaAllocNmbr(String paAllocNmbr) ソートキーコードを設定します｡
void | setPaBlineDate(String paBlineDate) 期日計算の支払基準日コードを設定します｡
void | setPaGlAccount(String paGlAccount) 総勘定元帳勘定コードを設定します｡
void | setPaIndex(int paIndex) レコード番号を設定します｡
void | setPaItemnoAcc(String paItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setPaItemText(String paItemText) 明細テキストコードを設定します｡
void | setPaPymtMeth(String paPymtMeth) 支払方法を設定します｡
void | setPaVendorNo(String paVendorNo) 仕入先または債権者の勘定コードコードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountPayable

public AccountPayable(int index)
仕入先明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
paItemnoAcc - 会計伝票明細番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo)
仕入先または債権者の勘定コードコードを設定します｡

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード

setPaGlAccount

public void setPaGlAccount(String paGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
paGlAccount - 総勘定元帳勘定

setPaBlineDate

public void setPaBlineDate(String paBlineDate)
期日計算の支払基準日コードを設定します｡

パラメータ:
paBlineDate - 期日計算の支払基準日

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth)
支払方法を設定します｡

パラメータ:
paPymtMeth - 支払方法

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr)
ソートキーコードを設定します｡

パラメータ:
paAllocNmbr - ソートキー

setPaItemText

public void setPaItemText(String paItemText)
明細テキストコードを設定します｡

パラメータ:
paItemText - 明細テキスト

setPaIndex

public void setPaIndex(int paIndex)
レコード番号を設定します｡

パラメータ:
paIndex - レコード番号

getPaItemnoAcc

public String getPaItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
paItemnoAcc

getPaVendorNo

public String getPaVendorNo()
仕入先または債権者の勘定コードを取得します｡

戻り値:
paVendorNo

getPaGlAccount

public String getPaGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
paGlAccount

getPaBlineDate

public String getPaBlineDate()
期日計算の支払基準日を取得します｡

戻り値:
paBlineDate

getPaPymtMeth

public String getPaPymtMeth()
支払方法を取得します｡

戻り値:
paPymtMeth

getPaAllocNmbr

public String getPaAllocNmbr()
ソートキーを取得します｡

戻り値:
paAllocNmbr

getPaItemText

public String getPaItemText()
明細テキストを取得します｡

戻り値:
paItemText

getPaIndex

public int getPaIndex()
レコード番号を取得します｡

戻り値:
paIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountTax (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountTax

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountTax
すべての実装インタフェース:
Serializable
public class AccountTax
extends Object
implements Serializable

税明細クラス
機能は以下の通り

  • 税明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountTax(int index)
指定されたレコード番号でAccountTaxを作成します｡
メソッドの概要
String | getTaGlAccount() 総勘定元帳勘定を取得します｡
int | getTaIndex() レコード番号を取得します｡
String | getTaItemnoAcc() 会計伝票明細番号を取得します｡
String | getTaTaxCode() 消費税コードを取得します｡
void | setTaGlAccount(String taGlAccount) 総勘定元帳勘定コードを設定します｡
void | setTaIndex(int taIndex) レコード番号を設定します｡
void | setTaItemnoAcc(String taItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setTaTaxCode(String taTaxCode) 消費税コードコードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountTax

public AccountTax(int index)
指定されたレコード番号でAccountTaxを作成します｡

パラメータ:
index - レコード番号
メソッドの詳細

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
taItemnoAcc - 会計伝票明細番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
taGlAccount - 総勘定元帳勘定

setTaTaxCode

public void setTaTaxCode(String taTaxCode)
消費税コードコードを設定します｡

パラメータ:
taTaxCode - 消費税コード

setTaIndex

public void setTaIndex(int taIndex)
レコード番号を設定します｡

パラメータ:
taIndex - レコード番号

getTaItemnoAcc

public String getTaItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
taItemnoAcc

getTaGlAccount

public String getTaGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
taGlAccount

getTaTaxCode

public String getTaTaxCode()
消費税コードを取得します｡

戻り値:
taTaxCode

getTaIndex

public int getTaIndex()
レコード番号を取得します｡

戻り値:
tadex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Bank (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Bank

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Bank
すべての実装インタフェース:
Serializable
public class Bank
extends Object
implements Serializable

銀行情報クラス
機能は以下の通り

  • 銀行の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Bank()
銀行情報を作成します。
メソッドの概要
String | getBankKey() 銀行コードを取得します｡
String | getBankName() 銀行名を取得します｡
String | getCity() 市区町村名を取得します｡
void | setBankKey(String bankKey) 銀行コードを設定します｡
void | setBankName(String bankName) 銀行名を設定します｡
void | setCity(String city) 市区町村名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Bank

public Bank()
銀行情報を作成します。

メソッドの詳細

setBankKey

public void setBankKey(String bankKey)
銀行コードを設定します｡

パラメータ:
bankKey - 銀行コード

setBankName

public void setBankName(String bankName)
銀行名を設定します｡

パラメータ:
bankName - 銀行名

setCity

public void setCity(String city)
市区町村名を設定します｡

パラメータ:
city - 市区町村名

getBankKey

public String getBankKey()
銀行コードを取得します｡

戻り値:
bankKey

getBankName

public String getBankName()
銀行名を取得します｡

戻り値:
bankName

getCity

public String getCity()
市区町村名を取得します｡

戻り値:
city

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankController
すべての実装インタフェース:
Serializable
public class BankController
extends Object
implements Serializable

銀行コントローラクラス
機能は以下の通り

  • 銀行の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
メソッドの概要
BankList | getBaList() 銀行一覧を取得します｡
ArrayList | getBankList() 銀行一覧を取得します。
String | getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | setBaList(BankList baList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankController

public BankController()
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBankList

public ArrayList getBankList()
銀行一覧を取得します。

戻り値:
bankList 銀行一覧

getBankName

public String getBankName(String bankKey)
                   throws SAPAccountingSystemException
銀行コードを指定して銀行名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
bankName 銀行名
例外:
SAPAccountingSystemException - 会計業務システム例外

getCity

public String getCity(String bankKey)
               throws SAPAccountingSystemException
銀行コードを指定して市区町村名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
city 市区町村名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBaList

public void setBaList(BankList baList)
銀行一覧を設定します｡

パラメータ:
baList - 銀行一覧

getBaList

public BankList getBaList()
銀行一覧を取得します｡

戻り値:
baList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankList (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankList
すべての実装インタフェース:
Serializable
public class BankList
extends Object
implements Serializable

銀行一覧クラス
機能は以下の通り

  • 銀行の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
BankList()
executeBapiを呼び出し銀行一覧を作成します。
メソッドの概要
ArrayList | getBankList() 銀行一覧を取得します｡
void | setBankList(ArrayList bankList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankList

public BankList()
         throws SAPAuthAppException,
                SAPAuthSystemException,
                SAPGeneralAppException,
                SAPGeneralSystemException,
                SAPAccountingSystemException
executeBapiを呼び出し銀行一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBankList

public void setBankList(ArrayList bankList)
銀行一覧を設定します｡

パラメータ:
bankList - 銀行一覧

getBankList

public ArrayList getBankList()
銀行一覧を取得します｡

戻り値:
bankList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessArea (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea
すべての実装インタフェース:
Serializable
public class BusinessArea
extends Object
implements Serializable

事業領域情報クラス
機能は以下の通り

  • 事業領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessArea()
事業領域情報を作成します。
メソッドの概要
String | getBusArDes() 事業領域名を取得します｡
String | getBusArea() 事業領域を取得します｡
void | setBusArDes(String busArDes) 事業領域名を設定します｡
void | setBusArea(String busArea) 事業領域を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessArea

public BusinessArea()
事業領域情報を作成します。

メソッドの詳細

setBusArea

public void setBusArea(String busArea)
事業領域を設定します｡

パラメータ:
busArea - 事業領域

setBusArDes

public void setBusArDes(String busArDes)
事業領域名を設定します｡

パラメータ:
busArDes - 事業領域名

getBusArea

public String getBusArea()
事業領域を取得します｡

戻り値:
businessAreaCode

getBusArDes

public String getBusArDes()
事業領域名を取得します｡

戻り値:
busArDes

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController
すべての実装インタフェース:
Serializable
public class BusinessAreaController
extends Object
implements Serializable

事業領域コントローラクラス
機能は以下の通り

  • 事業領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
メソッドの概要
String | getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
BusinessAreaList | getBusAreaList() 事業領域一覧を取得します｡
ArrayList | getBusinessAreaList() 事業領域一覧を取得します。
void | setBusAreaList(BusinessAreaList busAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaController

public BusinessAreaController()
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧を取得します。

戻り値:
businessAreaList 事業領域一覧

getBusArDes

public String getBusArDes(String busArea)
                   throws SAPAccountingSystemException
事業領域を指定して事業領域名を取得します。

パラメータ:
busArea - 事業領域
戻り値:
busArDes 事業領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBusAreaList

public void setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

パラメータ:
busAreaList - 事業領域一覧

getBusAreaList

public BusinessAreaList getBusAreaList()
事業領域一覧を取得します｡

戻り値:
busAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaList (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList
すべての実装インタフェース:
Serializable
public class BusinessAreaList
extends Object
implements Serializable

事業領域一覧クラス
機能は以下の通り

  • 事業領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
メソッドの概要
ArrayList | getBusinessAreaList() 事業領域一覧を取得します｡
void | setBusinessAreaList(ArrayList businessAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaList

public BusinessAreaList()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し事業領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBusinessAreaList

public void setBusinessAreaList(ArrayList businessAreaList)
事業領域一覧を設定します｡

パラメータ:
businessAreaList - 事業領域一覧

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧を取得します｡

戻り値:
businessAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Company (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Company

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Company
すべての実装インタフェース:
Serializable
public class Company
extends Object
implements Serializable

会社情報クラス
機能は以下の通り

  • 会社の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Company()
会社情報を作成します。
メソッドの概要
String | getCompCode() 会社コードを取得します｡
String | getCompName() 会社名を取得します｡
void | setCompCode(String compCode) 会社コードを設定します｡
void | setCompName(String compName) 会社名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Company

public Company()
会社情報を作成します。

メソッドの詳細

setCompCode

public void setCompCode(String compCode)
会社コードを設定します｡

パラメータ:
compCode - 会社コード

setCompName

public void setCompName(String compName)
会社名を設定します｡

パラメータ:
compName - 会社名

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

getCompName

public String getCompName()
会社名を取得します｡

戻り値:
compName

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyController
すべての実装インタフェース:
Serializable
public class CompanyController
extends Object
implements Serializable

会社コントローラクラス
機能は以下の通り

  • 会社の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します。
CompanyList | getCompList() 会社一覧を取得します｡
String | getCompName(String compCode) 会社コードを指定して会社名を取得します。
void | setCompList(CompanyList compList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyController

public CompanyController()
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPAccountingSystemException
CompanyListのコンストラクタを呼び出し会社一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します。

戻り値:
companyList 会社一覧

getCompName

public String getCompName(String compCode)
                   throws SAPAccountingSystemException
会社コードを指定して会社名を取得します。

パラメータ:
compCode - 会社コード
戻り値:
compName 会社名
例外:
SAPAccountingSystemException - 会計業務システム例外

setCompList

public void setCompList(CompanyList compList)
会社一覧を設定します｡

パラメータ:
compList - 会社一覧

getCompList

public CompanyList getCompList()
会社一覧を取得します｡

戻り値:
compList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyList (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyList
すべての実装インタフェース:
Serializable
public class CompanyList
extends Object
implements Serializable

会社一覧クラス
機能は以下の通り

  • 会社の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します｡
void | setCompanyList(ArrayList companyList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyList

public CompanyList()
            throws SAPAuthAppException,
                   SAPAuthSystemException,
                   SAPGeneralAppException,
                   SAPGeneralSystemException,
                   SAPAccountingSystemException
executeBapiを呼び出し会社一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCompanyList

public void setCompanyList(ArrayList companyList)
会社一覧を設定します｡

パラメータ:
companyList - 会社一覧

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します｡

戻り値:
companyList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingArea (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea
すべての実装インタフェース:
Serializable
public class ControllingArea
extends Object
implements Serializable

管理領域情報クラス
機能は以下の通り

  • 管理領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingArea()
管理領域情報を作成します。
メソッドの概要
String | getCoArea() 管理領域を取得します｡
String | getName() 管理領域名を取得します｡
void | setCoArea(String coArea) 管理領域を設定します｡
void | setName(String name) 管理領域名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingArea

public ControllingArea()
管理領域情報を作成します。

メソッドの詳細

setCoArea

public void setCoArea(String coArea)
管理領域を設定します｡

パラメータ:
coArea - 管理領域

setName

public void setName(String name)
管理領域名を設定します｡

パラメータ:
name - 管理領域名

getCoArea

public String getCoArea()
管理領域を取得します｡

戻り値:
coArea

getName

public String getName()
管理領域名を取得します｡

戻り値:
name

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController
すべての実装インタフェース:
Serializable
public class ControllingAreaController
extends Object
implements Serializable

管理領域コントローラクラス
機能は以下の通り

  • 管理領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
メソッドの概要
ControllingAreaList | getControllAreaList() 管理領域一覧を取得します｡
ArrayList | getControllingAreaList() 管理領域一覧を取得します。
String | getName(String coArea) 管理領域を指定して管理領域名を取得します。
void | setControllAreaList(ControllingAreaList controllAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaController

public ControllingAreaController()
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPAccountingSystemException
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します。

戻り値:
controllingAreaList 管理領域一覧

getName

public String getName(String coArea)
               throws SAPAccountingSystemException
管理領域を指定して管理領域名を取得します。

パラメータ:
coArea - 管理領域
戻り値:
name 管理領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setControllAreaList

public void setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

パラメータ:
controllAreaList - 管理領域一覧

getControllAreaList

public ControllingAreaList getControllAreaList()
管理領域一覧を取得します｡

戻り値:
controllAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaList (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList
すべての実装インタフェース:
Serializable
public class ControllingAreaList
extends Object
implements Serializable

管理領域一覧クラス
機能は以下の通り

  • 管理領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
メソッドの概要
ArrayList | getControllingAreaList() 管理領域一覧を取得します｡
void | setControllingAreaList(ArrayList controllingAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaList

public ControllingAreaList()
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPAccountingSystemException
executeBapiを呼び出し管理領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setControllingAreaList

public void setControllingAreaList(ArrayList controllingAreaList)
管理領域一覧を設定します｡

パラメータ:
controllingAreaList - 管理領域一覧

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します｡

戻り値:
controllingAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenter
すべての実装インタフェース:
Serializable
public class CostCenter
extends Object
implements Serializable

原価センタ情報クラス
機能は以下の通り

  • 原価センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenter()
原価センタ情報を取得します。
メソッドの概要
String | getControllingArea() 管理領域を取得します｡
String | getCostCenter() 原価センタを取得します｡
String | getDescript() テキストを取得します｡
String | getName() 一般名称を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setCostCenter(String costCenter) 原価センタを設定します｡
void | setDescript(String descript) テキストを設定します｡
void | setName(String name) 一般名称を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenter

public CostCenter()
原価センタ情報を取得します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setCostCenter

public void setCostCenter(String costCenter)
原価センタを設定します｡

パラメータ:
costCenter - 原価センタ

setName

public void setName(String name)
一般名称を設定します｡

パラメータ:
name - 一般名称

setDescript

public void setDescript(String descript)
テキストを設定します｡

パラメータ:
descript - テキスト

getControllingArea

public String getControllingArea()
管理領域を取得します｡

戻り値:
controllingArea

getCostCenter

public String getCostCenter()
原価センタを取得します｡

戻り値:
costCenter

getName

public String getName()
一般名称を取得します｡

戻り値:
name

getDescript

public String getDescript()
テキストを取得します｡

戻り値:
descript

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController
すべての実装インタフェース:
Serializable
public class CostCenterController
extends Object
implements Serializable

原価センタコントローラクラス
機能は以下の通り

  • 原価センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
メソッドの概要
ArrayList | getCostCenterList() 原価センタ一覧を取得します。
CostCenterList | getCostCentList() 原価センタ一覧を取得します｡
String | getDescript(String costCenter) 原価センタを指定してテキストを取得します。
String | getName(String costCenter) 原価センタを指定して一般名称を取得します。
void | setCostCentList(CostCenterList costCentList) 原価センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterController

public CostCenterController(String controllingArea)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea,
                            Date date)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧を取得します。

戻り値:
costCenterList 原価センタ一覧

getName

public String getName(String costCenter)
               throws SAPAccountingSystemException
原価センタを指定して一般名称を取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
name 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getDescript

public String getDescript(String costCenter)
                   throws SAPAccountingSystemException
原価センタを指定してテキストを取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
descript テキスト
例外:
SAPAccountingSystemException - 会計業務システム例外

setCostCentList

public void setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

パラメータ:
costCentList - 原価センタ一覧

getCostCentList

public CostCenterList getCostCentList()
原価センタ一覧を取得します｡

戻り値:
costCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterList (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList
すべての実装インタフェース:
Serializable
public class CostCenterList
extends Object
implements Serializable

原価センタ一覧クラス
機能は以下の通り

  • 原価センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
メソッドの概要
ArrayList | getCostCenterList() 原価センタ一覧を取得します｡
void | setCostCenterList(ArrayList costCenterList) 原価センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterList

public CostCenterList(String controllingArea,
                      String date)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
executeBapiを呼び出し原価センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCostCenterList

public void setCostCenterList(ArrayList costCenterList)
原価センタ一覧を設定します｡

パラメータ:
costCenterList - 原価センタ一覧

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧を取得します｡

戻り値:
costCenterList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurrencyAmount (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CurrencyAmount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount
すべての実装インタフェース:
Serializable
public class CurrencyAmount
extends Object
implements Serializable

明細通貨項目クラス
機能は以下の通り

  • 明細通貨項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CurrencyAmount(int index)
指定されたレコード番号でCurrencyAmountを作成します。
メソッドの概要
String | getCuAmtBase() 課税基準額を取得します｡
String | getCuAmtDoccur() 伝票通貨額を取得します｡
String | getCuCurrency() 通貨コードを取得します｡
int | getCuIndex() レコード番号を取得します｡
String | getCuItemnoAcc() 会計伝票明細番号を取得します｡
void | setCuAmtBase(String cuAmtBase) 課税基準額を設定します｡
void | setCuAmtDoccur(String cuAmtDoccur) 伝票通貨額設定します｡
void | setCuCurrency(String cuCurrency) 通貨コードを設定します｡
void | setCuIndex(int cuIndex) レコード番号を設定します｡
void | setCuItemnoAcc(String cuItemnoAcc) 会計伝票明細番号コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurrencyAmount

public CurrencyAmount(int index)
指定されたレコード番号でCurrencyAmountを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
cuItemnoAcc - 会計伝票明細番号

setCuCurrency

public void setCuCurrency(String cuCurrency)
通貨コードを設定します｡

パラメータ:
cuCurrency - 通貨コード

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur)
伝票通貨額設定します｡

パラメータ:
cuAmtDoccur - 伝票通貨額

setCuAmtBase

public void setCuAmtBase(String cuAmtBase)
課税基準額を設定します｡

パラメータ:
cuAmtBase - 課税基準額

setCuIndex

public void setCuIndex(int cuIndex)
レコード番号を設定します｡

パラメータ:
cuIndex - レコード番号

getCuItemnoAcc

public String getCuItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
cuItemnoAcc

getCuCurrency

public String getCuCurrency()
通貨コードを取得します｡

戻り値:
cuCurrency

getCuAmtDoccur

public String getCuAmtDoccur()
伝票通貨額を取得します｡

戻り値:
cuAmtDoccur

getCuAmtBase

public String getCuAmtBase()
課税基準額を取得します｡

戻り値:
cuAmtBase

getCuIndex

public int getCuIndex()
レコード番号を取得します｡

戻り値:
cuindex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DocumentHeader (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス DocumentHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader
すべての実装インタフェース:
Serializable
public class DocumentHeader
extends Object
implements Serializable

伝票ヘッダクラス
機能は以下の通り

  • 伝票ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DocumentHeader()
伝票ヘッダ情報を作成します。
メソッドの概要
String | getDocAcDocNo() 会計伝票番号を取得します｡
String | getDocCompCode() 会社コードを取得します｡
String | getDocDocDate() 伝票の伝票日付を取得します｡
String | getDocDocType() 伝票タイプを取得します｡
String | getDocFiscYear() 会計年度を取得します｡
String | getDocFisPeriod() 会計期間を取得します｡
String | getDocHeaderTxt() 伝票ヘッダテキストを取得します｡
String | getDocObjKey() オブジェクトキーを取得します｡
String | getDocObjType() 参照処理を取得します｡
String | getDocPstngDate() 伝票の転記日付を取得します｡
String | getDocRefDocNo() 参照伝票番号を取得します｡
String | getDocUsername() ユーザ名を取得します｡
void | setDocAcDocNo(String docAcDocNo) 会計伝票番号コードを設定します｡
void | setDocCompCode(String docCompCode) 会社コードコードを設定します｡
void | setDocDocDate(String docDocDate) 伝票の伝票日付コードを設定します｡
void | setDocDocType(String docDocType) 伝票タイプコードを設定します｡
void | setDocFiscYear(String docFiscYear) 会計年度コードを設定します｡
void | setDocFisPeriod(String docFisPeriod) 会計期間コードを設定します｡
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダテキストコードを設定します｡
void | setDocObjKey(String docObjKey) オブジェクトキーコードを設定します｡
void | setDocObjType(String docObjType) 参照処理コードを設定します｡
void | setDocPstngDate(String docPstngDate) 伝票の転記日付コードを設定します｡
void | setDocRefDocNo(String docRefDocNo) 参照伝票番号コードを設定します｡
void | setDocUsername(String docUsername) ユーザ名コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DocumentHeader

public DocumentHeader()
伝票ヘッダ情報を作成します。

メソッドの詳細

setDocObjType

public void setDocObjType(String docObjType)
参照処理コードを設定します｡

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
オブジェクトキーコードを設定します｡

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
ユーザ名コードを設定します｡

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダテキストコードを設定します｡

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
会社コードコードを設定します｡

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
会計伝票番号コードを設定します｡

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
会計年度コードを設定します｡

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票の伝票日付コードを設定します｡

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票の転記日付コードを設定します｡

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
会計期間コードを設定します｡

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票タイプコードを設定します｡

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
参照伝票番号コードを設定します｡

パラメータ:
docRefDocNo - 参照伝票番号

getDocObjType

public String getDocObjType()
参照処理を取得します｡

戻り値:
docObjType

getDocObjKey

public String getDocObjKey()
オブジェクトキーを取得します｡

戻り値:
docObjKey

getDocUsername

public String getDocUsername()
ユーザ名を取得します｡

戻り値:
docUsername

getDocHeaderTxt

public String getDocHeaderTxt()
伝票ヘッダテキストを取得します｡

戻り値:
docHeaderTxt

getDocCompCode

public String getDocCompCode()
会社コードを取得します｡

戻り値:
docCompCode

getDocAcDocNo

public String getDocAcDocNo()
会計伝票番号を取得します｡

戻り値:
docAcDocNo

getDocFiscYear

public String getDocFiscYear()
会計年度を取得します｡

戻り値:
docFiscYear

getDocDocDate

public String getDocDocDate()
伝票の伝票日付を取得します｡

戻り値:
docDocDate

getDocPstngDate

public String getDocPstngDate()
伝票の転記日付を取得します｡

戻り値:
docPstngDate

getDocFisPeriod

public String getDocFisPeriod()
会計期間を取得します｡

戻り値:
docFisPeriod

getDocDocType

public String getDocDocType()
伝票タイプを取得します｡

戻り値:
docDocType

getDocRefDocNo

public String getDocRefDocNo()
参照伝票番号を取得します｡

戻り値:
docRefDocNo

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAcc (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAcc

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAcc
すべての実装インタフェース:
Serializable
public class GlAcc
extends Object
implements Serializable

勘定項目情報クラス
機能は以下の通り

  • 勘定項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GlAcc()
勘定項目情報を作成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します｡
String | getGlAccount() G/L勘定コードを取得します｡
String | getLongText() 総勘定元帳勘定テキスト(長)を取得します｡
String | getShortText() G/L勘定コードテキスト(短)を取得します｡
void | setCompanyCode(String companyCode) 会社コードを設定します｡
void | setGlAccount(String glAccount) G/L勘定コードを設定します｡
void | setLongText(String longText) 総勘定元帳勘定テキスト(長)を設定します｡
void | setShortText(String shortText) G/L勘定コードテキスト(短)を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAcc

public GlAcc()
勘定項目情報を作成します。

メソッドの詳細

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します｡

パラメータ:
companyCode - 会社コード

setGlAccount

public void setGlAccount(String glAccount)
G/L勘定コードを設定します｡

パラメータ:
glAccount - G/L勘定コード

setShortText

public void setShortText(String shortText)
G/L勘定コードテキスト(短)を設定します｡

パラメータ:
shortText - G/L勘定コードテキスト(短)

setLongText

public void setLongText(String longText)
総勘定元帳勘定テキスト(長)を設定します｡

パラメータ:
longText - 総勘定元帳勘定テキスト(長)

getCompanyCode

public String getCompanyCode()
会社コードを取得します｡

戻り値:
companyCode

getGlAccount

public String getGlAccount()
G/L勘定コードを取得します｡

戻り値:
glAccount

getShortText

public String getShortText()
G/L勘定コードテキスト(短)を取得します｡

戻り値:
shortText

getLongText

public String getLongText()
総勘定元帳勘定テキスト(長)を取得します｡

戻り値:
longText

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccController
すべての実装インタフェース:
Serializable
public class GlAccController
extends Object
implements Serializable

勘定科目コントローラクラス
機能は以下の通り

  • 勘定科目の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定科目一覧を取得します。
GlAccList | getGlList() 勘定科目一覧を取得します｡
String | getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
void | setGlList(GlAccList glList) 勘定科目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccController

public GlAccController(String companyCode)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。

パラメータ:
companyCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getGlAccList

public ArrayList getGlAccList()
勘定科目一覧を取得します。

戻り値:
glAccList 勘定科目一覧

getShortText

public String getShortText(String glAccount)
                    throws SAPAccountingSystemException
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
shortText G/L勘定コードテキスト(短)
例外:
SAPAccountingSystemException - 会計業務システム例外

getLongText

public String getLongText(String glAccount)
                   throws SAPAccountingSystemException
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
longText 総勘定元帳勘定テキスト(長)
例外:
SAPAccountingSystemException - 会計業務システム例外

setGlList

public void setGlList(GlAccList glList)
勘定科目一覧を設定します｡

パラメータ:
glList - 勘定科目一覧

getGlList

public GlAccList getGlList()
勘定科目一覧を取得します｡

戻り値:
glList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccList (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccList
すべての実装インタフェース:
Serializable
public class GlAccList
extends Object
implements Serializable

勘定項目一覧クラス
機能は以下の通り

  • 勘定項目の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定項目一覧を取得します｡
void | setGlAccList(ArrayList glAccList) 勘定項目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccList

public GlAccList(String companyCode)
          throws SAPAuthAppException,
                 SAPAuthSystemException,
                 SAPGeneralAppException,
                 SAPGeneralSystemException,
                 SAPAccountingSystemException
executeBapiを呼び出し勘定項目一覧を作成します。

パラメータ:
companyCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setGlAccList

public void setGlAccList(ArrayList glAccList)
勘定項目一覧を設定します｡

パラメータ:
glAccList - 勘定項目一覧

getGlAccList

public ArrayList getGlAccList()
勘定項目一覧を取得します｡

戻り値:
glAccList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.accounting (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.sap.module.accounting
クラス
AccEmployeePayPostController
AccountGl
AccountPayable
AccountTax
Bank
BankController
BankList
BusinessArea
BusinessAreaController
BusinessAreaList
Company
CompanyController
CompanyList
ControllingArea
ControllingAreaController
ControllingAreaList
CostCenter
CostCenterController
CostCenterList
CurrencyAmount
DocumentHeader
GlAcc
GlAccController
GlAccList
ProfitCenter
ProfitCenterController
ProfitCenterList


jp.co.intra_mart.foundation.sap.module.accounting (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

ＳＡＰ連携会計系に関するクラスを提供します。

参照:
説明

クラスの概要
AccEmployeePayPostController | 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
AccountGl | G/L 勘定明細クラス 機能は以下の通り G/L 勘定明細の情報を保持します。
AccountPayable | 仕入先明細クラス 機能は以下の通り 仕入先明細の情報を保持します。
AccountTax | 税明細クラス 機能は以下の通り 税明細の情報を保持します。
Bank | 銀行情報クラス 機能は以下の通り 銀行の情報を保持します。
BankController | 銀行コントローラクラス 機能は以下の通り 銀行の情報を取得します。
BankList | 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
BusinessArea | 事業領域情報クラス 機能は以下の通り 事業領域の情報を保持します。
BusinessAreaController | 事業領域コントローラクラス 機能は以下の通り 事業領域の情報を取得します。
BusinessAreaList | 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
Company | 会社情報クラス 機能は以下の通り 会社の情報を保持します。
CompanyController | 会社コントローラクラス 機能は以下の通り 会社の情報を取得します。
CompanyList | 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
ControllingArea | 管理領域情報クラス 機能は以下の通り 管理領域の情報を保持します。
ControllingAreaController | 管理領域コントローラクラス 機能は以下の通り 管理領域の情報を取得します。
ControllingAreaList | 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
CostCenter | 原価センタ情報クラス 機能は以下の通り 原価センタの情報を保持します。
CostCenterController | 原価センタコントローラクラス 機能は以下の通り 原価センタの情報を取得します。
CostCenterList | 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
CurrencyAmount | 明細通貨項目クラス 機能は以下の通り 明細通貨項目の情報を保持します。
DocumentHeader | 伝票ヘッダクラス 機能は以下の通り 伝票ヘッダの情報を保持します。
GlAcc | 勘定項目情報クラス 機能は以下の通り 勘定項目の情報を保持します。
GlAccController | 勘定科目コントローラクラス 機能は以下の通り 勘定科目の情報を取得します。
GlAccList | 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
ProfitCenter | 利益センタ情報クラス 機能は以下の通り 利益センタの情報を保持します。
ProfitCenterController | 利益センタコントローラクラス 機能は以下の通り 利益センタの情報を取得します。
ProfitCenterList | 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の説明

ＳＡＰ連携会計系に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.sap.module.accounting クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.sap.module.accounting の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting の使用

jp.co.intra_mart.foundation.sap.module.accounting を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting のクラス
BankList
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BusinessAreaList
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
CompanyList
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
ControllingAreaList
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
CostCenterList
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
DocumentHeader
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
GlAccList
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
ProfitCenterList
利益センタ一覧クラス
機能は以下の通り
利益センタの情報を一覧形式で取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ProfitCenter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter
すべての実装インタフェース:
Serializable
public class ProfitCenter
extends Object
implements Serializable

利益センタ情報クラス
機能は以下の通り

  • 利益センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenter()
利益センタ情報を作成します。
メソッドの概要
String | getControllingArea() 管理領域コードを取得します｡
String | getInCharge() 利益センタ責任者を取得します｡
String | getPctrName() 一般名称を取得します｡
String | getProfitCtr() 利益センタを取得します｡
String | getValidTo() 有効終了日を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setInCharge(String inCharge) 利益センタ責任者を設定します｡
void | setPctrName(String pctrName) 一般名称を設定します｡
void | setProfitCtr(String profitCtr) 利益センタを設定します｡
void | setValidTo(String validTo) 有効終了日を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenter

public ProfitCenter()
利益センタ情報を作成します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します｡

パラメータ:
profitCtr - 利益センタ

setValidTo

public void setValidTo(String validTo)
有効終了日を設定します｡

パラメータ:
validTo - 有効終了日

setPctrName

public void setPctrName(String pctrName)
一般名称を設定します｡

パラメータ:
pctrName - 一般名称

setInCharge

public void setInCharge(String inCharge)
利益センタ責任者を設定します｡

パラメータ:
inCharge - 利益センタ責任者

getControllingArea

public String getControllingArea()
管理領域コードを取得します｡

戻り値:
controllingArea

getProfitCtr

public String getProfitCtr()
利益センタを取得します｡

戻り値:
profitCtr

getValidTo

public String getValidTo()
有効終了日を取得します｡

戻り値:
validTo

getPctrName

public String getPctrName()
一般名称を取得します｡

戻り値:
pctrName

getInCharge

public String getInCharge()
利益センタ責任者を取得します｡

戻り値:
inCharge

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController
すべての実装インタフェース:
Serializable
public class ProfitCenterController
extends Object
implements Serializable

利益センタコントローラクラス
機能は以下の通り

  • 利益センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
メソッドの概要
String | getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
ArrayList | getProfitCenterList() 利益センタ一覧を取得します。
ProfitCenterList | getProfitCentList() 利益センタ一覧を取得します｡
String | getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
void | setProfitCentList(ProfitCenterList profitCentList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterController

public ProfitCenterController(String controllingArea)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              Date date)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 日付
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧を取得します。

戻り値:
profitCenterList 管理領域一覧

getValidTo

public String getValidTo(String profitCtr)
                  throws SAPAccountingSystemException
利益センタを指定して有効終了日を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
validTo 有効終了日
例外:
SAPAccountingSystemException - 会計業務システム例外

getPctrName

public String getPctrName(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して一般名称を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
pctrName 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getInCharge

public String getInCharge(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して利益センタ責任者を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
inCharge 利益センタ責任者
例外:
SAPAccountingSystemException - 会計業務システム例外

setProfitCentList

public void setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

パラメータ:
profitCentList - 利益センタ一覧

getProfitCentList

public ProfitCenterList getProfitCentList()
利益センタ一覧を取得します｡

戻り値:
profitCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterList (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList
すべての実装インタフェース:
Serializable
public class ProfitCenterList
extends Object
implements Serializable

利益センタ一覧クラス
機能は以下の通り

  • 利益センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
メソッドの概要
ArrayList | getProfitCenterList() 利益センタ一覧を取得します｡
void | setProfitCenterList(ArrayList profitCenterList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterList

public ProfitCenterList(String controllingArea,
                        String date)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し利益センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
date - 日付
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setProfitCenterList

public void setProfitCenterList(ArrayList profitCenterList)
利益センタ一覧を設定します｡

パラメータ:
profitCenterList - 利益センタ一覧

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧を取得します｡

戻り値:
profitCenterList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.scenario.FunctionContainer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.FunctionContainer の使用

FunctionContainer を使用しているパッケージ
jp.co.intra_mart.foundation.scenario ページベース開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での FunctionContainer の使用

jp.co.intra_mart.foundation.scenario での FunctionContainer のサブクラス
 class FunctionContainerFile
FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.FunctionContainerFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.FunctionContainerFile の使用

jp.co.intra_mart.foundation.scenario.FunctionContainerFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.NoSuchPropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.NoSuchPropertyException の使用

NoSuchPropertyException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario ページベース開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での NoSuchPropertyException の使用

NoSuchPropertyException をスローする jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | VariableScope.getProperty(String name) プロパティ値を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.PresentationPage の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.PresentationPage の使用

jp.co.intra_mart.foundation.scenario.PresentationPage はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.ScriptCompileException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.ScriptCompileException の使用

ScriptCompileException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario ページベース開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptCompileException の使用

ScriptCompileException をスローする jp.co.intra_mart.foundation.scenario のメソッド
protected void | FunctionContainer.compileString(String src) スクリプトのソースをコンパイルします。
protected void | FunctionContainer.compileReader(Reader in) スクリプトのソースをコンパイルします。

ScriptCompileException をスローする jp.co.intra_mart.foundation.scenario のコンストラクタ
FunctionContainerFile(String path, Locale locale)
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String path)
ファンクション・コンテナをコンパイルします。
FunctionContainer(Reader in)
新しいインスタンスを構築します。
FunctionContainer(String src)
新しいインスタンスを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.scenario.ScriptRuntimeException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.scenario.ScriptRuntimeException の使用

ScriptRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.scenario ページベース開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptRuntimeException の使用

ScriptRuntimeException をスローする jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
String | PresentationPage.execute(String path) プログラム実行。
String | PresentationPage.execute(String path, Object[] args) プログラム実行。
VariableScope | FunctionContainer.execute() スクリプトの実行。
VariableScope | FunctionContainer.execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.scenario.ScriptValue の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.scenario.ScriptValue の使用

ScriptValue を使用しているパッケージ
jp.co.intra_mart.foundation.scenario ページベース開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での ScriptValue の使用

jp.co.intra_mart.foundation.scenario での ScriptValue のサブインタフェース
 interface VariableScope
スクリプトのスコープを表すオブジェクトです。

ScriptValue を返す jp.co.intra_mart.foundation.scenario のメソッド
ScriptValue | VariableScope.invoke(String name, String arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | VariableScope.invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | VariableScope.getProperty(String name) プロパティ値を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.scenario.VariableScope の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.scenario.VariableScope の使用

VariableScope を使用しているパッケージ
jp.co.intra_mart.foundation.scenario ページベース開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario での VariableScope の使用

VariableScope を返す jp.co.intra_mart.foundation.scenario のメソッド
VariableScope | FunctionContainer.execute() スクリプトの実行。
VariableScope | FunctionContainer.execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


FunctionContainer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス FunctionContainer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.FunctionContainer
直系の既知のサブクラス:
FunctionContainerFile
public abstract class FunctionContainer
extends Object

FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。

関連項目:
Object

コンストラクタの概要
protected | FunctionContainer() 新しいインスタンスを構築します。
 | FunctionContainer(Reader in) 新しいインスタンスを構築します。
 | FunctionContainer(String src) 新しいインスタンスを構築します。
メソッドの概要
protected void | compileReader(Reader in) スクリプトのソースをコンパイルします。
protected void | compileString(String src) スクリプトのソースをコンパイルします。
VariableScope | execute() スクリプトの実行。
VariableScope | execute(HttpServletRequest request, HttpServletResponse response) スクリプトの実行。
abstract String | sourceName() ソース名称の取得。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FunctionContainer

protected FunctionContainer()
新しいインスタンスを構築します。

このコンストラクタでは、このクラスを継承したサブクラス側で compileReader() メソッド等を利用してソースをコンパイルすることを 保証しなければなりません。

FunctionContainer

public FunctionContainer(Reader in)
                  throws IOException,
                         ScriptCompileException
新しいインスタンスを構築します。

指定のファンクション・コンテナをコンパイルします。

パラメータ:
in - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

FunctionContainer

public FunctionContainer(String src)
                  throws IOException,
                         ScriptCompileException
新しいインスタンスを構築します。

指定のファンクション・コンテナをコンパイルします。

パラメータ:
src - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
メソッドの詳細

compileString

protected void compileString(String src)
                      throws IOException,
                             ScriptCompileException
スクリプトのソースをコンパイルします。

パラメータ:
src - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

compileReader

protected void compileReader(Reader in)
                      throws IOException,
                             ScriptCompileException
スクリプトのソースをコンパイルします。

パラメータ:
in - ファンクションコンテナのソース
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー

sourceName

public abstract String sourceName()
ソース名称の取得。

スクリプトのソース名称を返します。
このクラスの汎用規約では、スクリプトがファイルの場合は ファイルのパス名を返します。

戻り値:
ソースの名前

execute

public VariableScope execute()
                      throws ScriptRuntimeException
スクリプトの実行。

スクリプトを実行します。
このメソッドによる実行時は、セッションが不明となるため、 セッションに関連したAPIを利用したスクリプトを実行することはできません。

戻り値は、このスクリプトのスコープです。

戻り値:
ソースの名前
例外:
ScriptRuntimeException - スクリプトの実行時エラー

execute

public VariableScope execute(HttpServletRequest request,
                             HttpServletResponse response)
                      throws ScriptRuntimeException
スクリプトの実行。

セッションを伴ってスクリプトを実行します。
指定のサーブレットにより管理されているセッションを維持したまま スクリプトを実行します。 また、このメソッドを利用する事により、セッション関連の ＡＰＩをスクリプト中で利用する事ができます。
戻り値は、このスクリプトのスコープです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ソースの名前
例外:
ScriptRuntimeException - スクリプトの実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FunctionContainerFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス FunctionContainerFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.FunctionContainer
        拡張 jp.co.intra_mart.foundation.scenario.FunctionContainerFile
public class FunctionContainerFile
extends FunctionContainer

FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
ファイルは Resource Service によって管理されているものに限ります。

関連項目:
FunctionContainer

コンストラクタの概要
FunctionContainerFile(String path)
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String path, Locale locale)
ファンクション・コンテナをコンパイルします。
メソッドの概要
 String sourceName()
スクリプトのファイルパス名を返します。
クラス jp.co.intra_mart.foundation.scenario.FunctionContainer から継承したメソッド
compileReader, compileString, execute, execute
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FunctionContainerFile

public FunctionContainerFile(String path,
                             Locale locale)
                      throws IOException,
                             ScriptCompileException
ファンクション・コンテナをコンパイルします。

このコンストラクタの呼び出しは、以下と同様です。 new FunctionContainerFile(path, java.util.Locale.getDefault())

パラメータ:
path - ソースファイルのパス名
locale - ソースのロケール
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
導入されたバージョン:
version 5.0

FunctionContainerFile

public FunctionContainerFile(String path)
                      throws IOException,
                             ScriptCompileException
ファンクション・コンテナをコンパイルします。

ファンクション・コンテナのファイルパスは、Resource Service が 管理しているリソースルートディレクトリ(標準では pages/)からの 相対形式で指定して下さい。
例） new FunctionContainerFile("my/container/library.js")

パラメータ:
path - ソースファイルのパス名
例外:
IOException - Reader の入出力エラー
ScriptCompileException - コンパイルエラー
メソッドの詳細

sourceName

public String sourceName()
スクリプトのファイルパス名を返します。

定義:
クラス FunctionContainer 内の sourceName
戻り値:
ファイルパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSuchPropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス NoSuchPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
すべての実装インタフェース:
Serializable
public class NoSuchPropertyException
extends Exception

NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
NoSuchPropertyException(String message)
詳細メッセージを指定して NoSuchPropertyException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSuchPropertyException

public NoSuchPropertyException(String message)
詳細メッセージを指定して NoSuchPropertyException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.scenario (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.scenario
インタフェース
ScriptValue
VariableScope
クラス
FunctionContainer
FunctionContainerFile
PresentationPage
例外
NoSuchPropertyException
ScriptCompileException
ScriptRuntimeException


jp.co.intra_mart.foundation.scenario (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.scenario

ページベース開発モデルのプログラムと連携するＡＰＩ。

参照:
説明

インタフェースの概要
ScriptValue | スクリプトの値を保持するオブジェクトです。
VariableScope | スクリプトのスコープを表すオブジェクトです。

クラスの概要
FunctionContainer | FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
FunctionContainerFile | FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
PresentationPage | PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。

例外の概要
NoSuchPropertyException | NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
ScriptCompileException | ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException | ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。

パッケージ jp.co.intra_mart.foundation.scenario の説明

ページベース開発モデルのプログラムと連携するＡＰＩ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.scenario クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.scenario の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.scenario.FunctionContainer
      • class jp.co.intra_mart.foundation.scenario.FunctionContainerFile
    • class jp.co.intra_mart.foundation.scenario.PresentationPage
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
        • class jp.co.intra_mart.foundation.scenario.ScriptCompileException
        • class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException

インタフェース階層

  • interface jp.co.intra_mart.foundation.scenario.ScriptValue
    • interface jp.co.intra_mart.foundation.scenario.VariableScope
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.scenario の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.scenario の使用

jp.co.intra_mart.foundation.scenario を使用しているパッケージ
jp.co.intra_mart.foundation.scenario ページベース開発モデルのプログラムと連携するＡＰＩ。

jp.co.intra_mart.foundation.scenario により使用される jp.co.intra_mart.foundation.scenario のクラス
FunctionContainer
FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
NoSuchPropertyException
NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
ScriptCompileException
ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException
ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。
ScriptValue
スクリプトの値を保持するオブジェクトです。
VariableScope
スクリプトのスコープを表すオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PresentationPage (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス PresentationPage

java.lang.Object
    拡張 jp.co.intra_mart.foundation.scenario.PresentationPage
public abstract class PresentationPage
extends Object

PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。

プレゼンテーションページを実行するには、リンク先 URL を プログラマが意識する必要があります。

リンク先 URL とは、プレゼンテーションページ内のリンクやフォームを 表現する <IMART> タグ内で使われるもので、そのリンクをクリックした 場合や、そのフォームをサブミットした場合にリクエストを送信するアドレス になります。したがって、その URL は intra-mart に接続できて ページベース開発モデルのページをリクエストできるという条件を 満たす必要があります。 この条件を満たす URL は、通常はログイン画面をリクエストするための URL と等しくなります。intra-mart を標準的にインストールした状態では、

http://サーバアドレス:ポート番号/imart/intramart
になります。

セッションを持つページを作成する場合は、 ログイン画面からログインした時に割り当てられた セッションを維持するように実行することが必要になります。 セッションを維持したページを作成する場合、Servlet の リクエストおよびレスポンスが必要になります。 これは、Servlet の HTTP セッションを利用してセッションを 確立しているためであり、他の方法ではセッションを維持したページを 作成することはできません。
セッションを指定しなかった場合、ユーザー情報を決定することができないため、 ユーザおよびログイングループに関わるすべての API の利用が不可能となります。

導入されたバージョン:
version 3.2
関連項目:
Object

コンストラクタの概要
PresentationPage()
セッションを持たないページ作成用オブジェクトを作成します。
PresentationPage(HttpServletRequest request, HttpServletResponse response)
任意のセッションを持つページ作成オブジェクトを構築します。
メソッドの概要
String | execute(String path) プログラム実行。
String | execute(String path, Object[] args) プログラム実行。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationPage

public PresentationPage()
セッションを持たないページ作成用オブジェクトを作成します。

PresentationPage

public PresentationPage(HttpServletRequest request,
                        HttpServletResponse response)
                 throws IllegalArgumentException
任意のセッションを持つページ作成オブジェクトを構築します。

パラメータ:
request - サーブレットの引数オブジェクト
response - サーブレットのレスポンスオブジェクト
例外:
IllegalArgumentException - 引数のいずれかが NULL である場合に スローされます
メソッドの詳細

execute

public String execute(String path)
               throws ScriptRuntimeException,
                      FileNotFoundException
プログラム実行。

指定のプログラムを実行します。

プログラムは HTML および JavaScript ファイルで、引数 path には、Information Server のプログラムパスからの相対形式で拡張子を省略 した形式で指定します。実行エンジンは、自動的に path.html および path.js を探して実行します。

パラメータ:
path - 実行するプログラムのパス
戻り値:
HTML ソース
例外:
ScriptRuntimeException - ページプログラム実行時エラー
FileNotFoundException

execute

public String execute(String path,
                      Object[] args)
               throws ScriptRuntimeException,
                      FileNotFoundException
プログラム実行。

指定のプログラムを実行します。

プログラムは HTML および JavaScript ファイルで、引数 path には、Resource-Service のプログラムパスからの相対形式で拡張子を省略 した形式で指定します。実行エンジンは、自動的に path.html および path.js を探して実行します。

引数 args は、path.js に定義されている init() メソッドの 実行時引数として渡されます。 args が持つ要素の個数は、init() 関数に渡される引数の個数と 等しくなります。

パラメータ:
path - 実行するプログラムのパス
args - プログラム実行時の任意引数
戻り値:
HTML ソース
例外:
ScriptRuntimeException - ページプログラム実行時エラー
FileNotFoundException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ScriptCompileException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス ScriptCompileException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.ScriptCompileException
すべての実装インタフェース:
Serializable
public class ScriptCompileException
extends Exception

ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
コンパイルエラーとは、主に構文エラーになります。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
ScriptCompileException(String message)
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptCompileException(String message, Throwable cause)
詳細メッセージを指定して ScriptCompileException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ScriptCompileException

public ScriptCompileException(String message)
詳細メッセージを指定して ScriptCompileException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()

ScriptCompileException

public ScriptCompileException(String message,
                              Throwable cause)
詳細メッセージを指定して ScriptCompileException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
導入されたバージョン:
version 4.3
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ScriptRuntimeException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
クラス ScriptRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.scenario.ScriptRuntimeException
すべての実装インタフェース:
Serializable
public class ScriptRuntimeException
extends Exception

ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。

関連項目:
Object, Exception, 直列化された形式

コンストラクタの概要
ScriptRuntimeException(String message)
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptRuntimeException(String message, Throwable cause)
詳細メッセージを指定して ScriptRuntimeException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ScriptRuntimeException

public ScriptRuntimeException(String message)
詳細メッセージを指定して ScriptRuntimeException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
関連項目:
Throwable.getMessage()

ScriptRuntimeException

public ScriptRuntimeException(String message,
                              Throwable cause)
詳細メッセージを指定して ScriptRuntimeException を構築します。

文字列 message は、 java.lang.Throwable クラスの Throwable.getMessage() メソッドを使って あとで取り出すことができます。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
導入されたバージョン:
version 4.3
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ScriptValue (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
インタフェース ScriptValue

既知のサブインタフェースの一覧:
VariableScope
public interface ScriptValue

スクリプトの値を保持するオブジェクトです。

メソッドの概要
boolean | booleanValue() このオブジェクトの示す値の真偽値表現を取得します。
double | doubleValue() このオブジェクトの示す値の数値表現を取得します。
Object | getValue() このオブジェクトの示す値を取得します。
boolean | isFunction() このオブジェクトの示す値が関数かどうか判定します。
boolean | isInstance(Class c) このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。
boolean | isNull() このオブジェクトの示す値が null かどうか判定します。
boolean | isObject() このオブジェクトの示す値がオブジェクトかどうか判定します。
boolean | isUndefined() このオブジェクトの示す値が undefined かどうか判定します。
String | toString() このオブジェクトの示す値の文字列表現を取得します。

メソッドの詳細

isObject

public boolean isObject()
このオブジェクトの示す値がオブジェクトかどうか判定します。

戻り値:
オブジェクトの場合 true、そうでない場合 false

isFunction

public boolean isFunction()
このオブジェクトの示す値が関数かどうか判定します。

戻り値:
関数の場合 true、そうでない場合 false

isUndefined

public boolean isUndefined()
このオブジェクトの示す値が undefined かどうか判定します。

戻り値:
Undefined の場合 true、そうでない場合 false

isNull

public boolean isNull()
このオブジェクトの示す値が null かどうか判定します。

戻り値:
null の場合 true、そうでない場合 false

isInstance

public boolean isInstance(Class c)
このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。

このメソッドは、c の isInstance() メソッドにより判定を行います。

戻り値:
代入互換の関係にある場合 true、そうでない場合 false
関連項目:
Class.isInstance(java.lang.Object)

getValue

public Object getValue()
このオブジェクトの示す値を取得します。

戻り値:
値

toString

public String toString()
このオブジェクトの示す値の文字列表現を取得します。

戻り値:
値の文字列表現

doubleValue

public double doubleValue()
このオブジェクトの示す値の数値表現を取得します。

戻り値:
値の数値表現

booleanValue

public boolean booleanValue()
このオブジェクトの示す値の真偽値表現を取得します。

戻り値:
値の真偽値表現
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


VariableScope (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.scenario
インタフェース VariableScope

すべてのスーパーインタフェース:
ScriptValue
public interface VariableScope
extends ScriptValue

スクリプトのスコープを表すオブジェクトです。

メソッドの概要
ScriptValue | getProperty(String name) プロパティ値を取得します。
boolean | hasProperty(String name) プロパティが存在しているかをチェックします。
ScriptValue | invoke(String name, Number arg) 指定関数を実行します。
ScriptValue | invoke(String name, Object[] args) 指定関数を実行します。
ScriptValue | invoke(String name, String arg) 指定関数を実行します。
Object[] | keys() プロパティの名称一覧を取得します。
インタフェース jp.co.intra_mart.foundation.scenario.ScriptValue から継承したメソッド
booleanValue, doubleValue, getValue, isFunction, isInstance, isNull, isObject, isUndefined, toString

メソッドの詳細

invoke

public ScriptValue invoke(String name,
                          String arg)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
返却値は、呼び出した関数の戻り値になりますが、 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
arg - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

invoke

public ScriptValue invoke(String name,
                          Number arg)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
返却値は、呼び出した関数の戻り値になりますが、 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
arg - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

invoke

public ScriptValue invoke(String name,
                          Object[] args)
                   throws ScriptRuntimeException,
                          NoSuchPropertyException
指定関数を実行します。

指定の関数を指定の引数を伴って実行します。
引数は配列形式で複数の値を指定できます。また、引数に指定できる データ型は、スクリプトで解釈できる型(String, Number, Boolean)に 限られます。
返却値は、呼び出した関数の戻り値になりますが、引数同様 スクリプトおよび JAVA の双方で解釈できる型 (String, Number, Boolean)に限られます。

パラメータ:
name - 関数名
args - 引数
戻り値:
関数の戻り値
例外:
ScriptRuntimeException - スクリプト実行時エラー
NoSuchPropertyException - 指定のプロパティが存在しない場合

getProperty

public ScriptValue getProperty(String name)
                        throws NoSuchPropertyException
プロパティ値を取得します。 このスコープにおいて指定のプロパティ名にマップされている 値を取得します。

パラメータ:
name - プロパティ名
戻り値:
プロパティにマップされている値
例外:
NoSuchPropertyException - 指定のプロパティが存在しない場合

hasProperty

public boolean hasProperty(String name)
プロパティが存在しているかをチェックします。 このスコープにおいて指定のプロパティが値にマップされている場合 真値(true)を返します。

パラメータ:
name - プロパティ名
戻り値:
プロパティがマップされている場合 true

keys

public Object[] keys()
プロパティの名称一覧を取得します。 このスコープが保持しているプロパティのプロパティ名を配列形式で 取得します。

戻り値:
このスコープが保持しているプロパティの名称一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.account.Account の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.Account の使用

Account を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での Account の使用

Account を返す jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountReaderDecorator.doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
Account | AccountManager.getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
Account[] | AccountManager.getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | AccountManager.getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
Account[] | AccountManager.searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
Account | AccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
Account[] | AccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
Account[] | AccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountReaderDecorator.doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
void | AccountQueryWriterListener.queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountManager.addAccount(Account account) アカウントを新規追加します。
void | AccountManager.updateAccount(Account account) アカウントを更新します。
void | AccountChangedListener.accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。

jp.co.intra_mart.foundation.security.certification での Account の使用

Account 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
int | UserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
int | StandardUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
int | LDAPUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountAccessor の使用

jp.co.intra_mart.foundation.security.account.AccountAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountChangedListener の使用

jp.co.intra_mart.foundation.security.account.AccountChangedListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountExporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountExporter の使用

AccountExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountExporter の使用

AccountExporter を実装している jp.co.intra_mart.foundation.security.account のクラス
 class StandardAccountBackup
アカウントバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountImporter の使用

AccountImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountImporter の使用

AccountImporter を実装している jp.co.intra_mart.foundation.security.account のクラス
 class StandardAccountBackup
アカウントバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.AccountManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.AccountManager の使用

AccountManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountManager の使用

AccountManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | StandardAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | StandardAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | AccountImporter.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | AccountExporter.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountPostWriterListener の使用

jp.co.intra_mart.foundation.security.account.AccountPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener の使用

jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.account.AccountReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.account.AccountReaderDecorator の使用

jp.co.intra_mart.foundation.security.account.AccountReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.AccountRole の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.AccountRole の使用

AccountRole を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccountRole の使用

AccountRole を返す jp.co.intra_mart.foundation.security.account のメソッド
AccountRole[] | AccountManager.getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
AccountRole | AccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
AccountRole[] | AccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。

AccountRole 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountQueryWriterListener.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountManager.addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | AccountManager.updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | AccountChangedListener.accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountChangedListener.accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.FavoriteMenu の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.FavoriteMenu の使用

FavoriteMenu を使用しているパッケージ
jp.co.intra_mart.foundation.security.account アカウントに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での FavoriteMenu の使用

FavoriteMenu を返す jp.co.intra_mart.foundation.security.account のメソッド
FavoriteMenu[] | AccountManager.getFavoriteMenus(String userId) マイメニューをすべて取得します。
FavoriteMenu | AccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
FavoriteMenu[] | AccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。

FavoriteMenu 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。
void | AccountManager.addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
void | AccountManager.updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener の使用

jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.account.StandardAccountBackup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.account.StandardAccountBackup の使用

jp.co.intra_mart.foundation.security.account.StandardAccountBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Account (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス Account

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.Account
すべての実装インタフェース:
LocaleProvider, Serializable
public class Account
extends Object
implements LocaleProvider, Serializable

アカウントモデル。

このアカウントにが有効になる条件（ログインできる条件）は、
有効開始日 <= 日付 < 有効終了日の範囲でかつ、アカウントがライセンス登録してある場合です。
アカウントのライセンス登録については、ライセンスマネージャ( LicenseManager)を参照してください。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager, 直列化された形式

コンストラクタの概要
Account(String userID)
コンストラクタ。
メソッドの概要
boolean | equals(Object account) オブジェクトを比較します。
String | getColorPatternId() カラーパターンIDを取得します。
String | getDescription() 説明を取得します。
String | getEncoding() エンコーディング情報を取得します。
Locale | getLocale() ロケールを取得します。
Date | getLockDate() アカウントロック日付を取得します。
int | getLoginFailureCount() ログイン失敗回数を取得します。
String | getMainPagePatternId() メインページパターンIDを取得します。
String | getMobilePassword() モバイル用パスワードを取得します。
String | getPassword() パスワードを取得します。
String | getUserId() ユーザIDを取得します。
Date | getValidEndDate() 有効終了日を取得します。
Date | getValidStartDate() 有効開始日取得。
int | hashCode() ハッシュコードを取得します。
void | increaseLoginFailureCount() ログイン失敗回数をカウントアップします。
boolean | isGoOut() 外出状態を取得します。
boolean | isLock() アカウントロック状態を取得します。
void | resetLock() アカウントロックをリセットします。
void | setColorPatternId(String colorPattrenId) カラーパターンIDを設定します。
void | setDescription(String description) 説明を設定します。
void | setEncoding(String encoding) エンコーディング情報を設定します。
void | setGoOut(boolean goOut) 外出状態を設定します。
void | setLocale(Locale locale) ロケールを設定します。
void | setLockDate(Date lockDate) アカウントロック日付を設定します。
void | setLoginFailureCount(int loginFailureCount) ログイン失敗回数を設定します。
void | setMainPagePatternId(String mainPagePatternId) メインページパターンIDを設定する。
void | setMobilePassword(String mobilePassword) モバイル用パスワードを設定します。
void | setPassword(String password) パスワードを設定します。
protected void | setUserId(String userId) ユーザIDを設定します。
void | setValidEndDate(Date endDate) 有効終了日を設定します。
void | setValidStartDate(Date startDate) 有効開始日を設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Account

public Account(String userID)
コンストラクタ。

パラメータ:
userID - ユーザID
メソッドの詳細

equals

public boolean equals(Object account)
オブジェクトを比較します。

指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
account - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディング情報を取得します。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング情報
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールを取得します。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getLockDate

public Date getLockDate()
アカウントロック日付を取得します。

戻り値:
ロックされている場合は、このアカウントがロックされた日付を返却します。
ロックされていない場合はnullを返却します。

getLoginFailureCount

public int getLoginFailureCount()
ログイン失敗回数を取得します。

このアカウントがログインに失敗している回数を返却します。

戻り値:
ログイン失敗回数

getMainPagePatternId

public String getMainPagePatternId()
メインページパターンIDを取得します。

戻り値:
メインページパターンID

getMobilePassword

public String getMobilePassword()
モバイル用パスワードを取得します。

戻り値:
モバイル用パスワード

getDescription

public String getDescription()
説明を取得します。

戻り値:
説明

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

getPassword

public String getPassword()
パスワードを取得します。

戻り値:
パスワード

getUserId

public String getUserId()
ユーザIDを取得します。

戻り値:
ユーザID

getValidEndDate

public Date getValidEndDate()
有効終了日を取得します。

アカウントは有効終了日の前日まで有効となります。

戻り値:
有効終了日

getValidStartDate

public Date getValidStartDate()
有効開始日取得。

アカウントは有効開始日から有効となります。

戻り値:
有効開始日

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード

increaseLoginFailureCount

public void increaseLoginFailureCount()
ログイン失敗回数をカウントアップします。

isGoOut

public boolean isGoOut()
外出状態を取得します。

戻り値:
外出している場合は、true

isLock

public boolean isLock()
アカウントロック状態を取得します。

戻り値:
ロックされている場合は、true

resetLock

public void resetLock()
アカウントロックをリセットします。

アカウントロックを解除し、ログイン失敗回数を０にリセットします。

setEncoding

public void setEncoding(String encoding)
エンコーディング情報を設定します。

パラメータ:
encoding - エンコーディング情報

setGoOut

public void setGoOut(boolean goOut)
外出状態を設定します。

パラメータ:
goOut - 外出している場合はtrue

setLocale

public void setLocale(Locale locale)
ロケールを設定します。

パラメータ:
locale - ロケール

setLockDate

public void setLockDate(Date lockDate)
アカウントロック日付を設定します。

パラメータ:
lockDate - 日付を設定した場合、アカウントはロックされる。 nullを設定した場合、アカウントのロックは解除される。

setLoginFailureCount

public void setLoginFailureCount(int loginFailureCount)
ログイン失敗回数を設定します。

設定できる値は0以上です。

パラメータ:
loginFailureCount - ログイン失敗回数

setMainPagePatternId

public void setMainPagePatternId(String mainPagePatternId)
メインページパターンIDを設定する。

パラメータ:
mainPagePatternId - メインページパターンID

setMobilePassword

public void setMobilePassword(String mobilePassword)
モバイル用パスワードを設定します。

パラメータ:
mobilePassword - モバイル用パスワード

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - 説明

setColorPatternId

public void setColorPatternId(String colorPattrenId)
カラーパターンIDを設定します。

パラメータ:
colorPattrenId - カラーパターンID

setPassword

public void setPassword(String password)
パスワードを設定します。

パラメータ:
password - パスワード

setUserId

protected void setUserId(String userId)
ユーザIDを設定します。

パラメータ:
userId - ユーザID

setValidEndDate

public void setValidEndDate(Date endDate)
有効終了日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付の前日までです。
nullを設定した場合は、最大未来日に設定されます。

パラメータ:
endDate - 有効終了日

setValidStartDate

public void setValidStartDate(Date startDate)
有効開始日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付からです。
nullを設定した場合は、最大過去日に設定されます。

パラメータ:
startDate - 有効開始日
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountAccessor

public interface AccountAccessor

アカウントアクセッサインタフェース。

アカウント情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
Account | getAccount(String groupId, String userId) アカウント情報を取得する。
int | getAccountCount(String groupId) アカウント数を取得する。
AccountRole | getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
Account[] | getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
FavoriteMenu | getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
String[] | getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
void | init(Map params) アカウントアクセッサの初期化。
void | insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
Account[] | searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
void | updateAccount(String groupId, Account account) アカウント情報を更新する。
void | updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

メソッドの詳細

deleteAccount

public void deleteAccount(String groupId,
                          String userId)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を削除する。

パラメータ:
groupId - ログイングループID
userId - 削除するユーザコード
例外:
AccessSecurityWriteException - アカウント情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウント情報が存在しない場合にスローされます。

deleteAccountRole

public void deleteAccountRole(String groupId,
                              String userId,
                              String roleId)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を削除する。

アカウントに紐付くアカウントロール情報を削除します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
例外:
AccessSecurityWriteException - アカウントロール情報の削除に失敗した場合スローされます。
NotExistException - 削除するアカウントロール情報が存在しない場合にスローされます。

deleteFavoriteMenu

public void deleteFavoriteMenu(String groupId,
                               String userId,
                               String menuId)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を削除する。

アカウントに紐付くマイメニュー情報を削除します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
例外:
AccessSecurityWriteException - マイメニュー情報の削除に失敗した場合スローされます。
NotExistException - 削除するマイメニュー情報が存在しない場合にスローされます。

getAccount

public Account getAccount(String groupId,
                          String userId)
                   throws AccessSecurityReadException
アカウント情報を取得する。

パラメータ:
groupId - ログイングループID
userId - ユーザIDの完全一致名
戻り値:
ユーザアカウントオブジェクト
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountsByUserIds

public Account[] getAccountsByUserIds(String groupId,
                                      String[] userIds)
                               throws AccessSecurityReadException
指定されたユーザIDのアカウント情報をすべて取得する。

パラメータ:
groupId - ログイングループID
userIds - ユーザIDの配列
戻り値:
ユーザアカウントオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountCount

public int getAccountCount(String groupId)
                    throws AccessSecurityReadException
アカウント数を取得する。

パラメータ:
groupId - ログイングループID
戻り値:
ユーザアカウント数
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getAccountRole

public AccountRole getAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityReadException
アカウントロール情報を取得する。

アカウントに紐付くアカウントロール情報を取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
roleId - ロールID
戻り値:
ユーザアカウントロール情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoleIds

public String[] getAccountRoleIds(String groupId,
                                  String userId)
                           throws AccessSecurityReadException
アカウントロールIDをすべて取得する。

アカウントに紐付くアカウントロールIDをすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String groupId,
                                     String userId)
                              throws AccessSecurityReadException
アカウントロール情報をすべて取得する。

アカウントに紐付くアカウントロール情報をすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
ユーザアカウントロール情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - アカウントロール情報取得に失敗した場合スローされます。

getFavoriteMenu

public FavoriteMenu getFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityReadException
マイメニュー情報を取得する。

アカウントに紐付くマイメニュー情報を取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
menuId - メニューID
戻り値:
マイメニュー情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenuIds

public String[] getFavoriteMenuIds(String groupId,
                                   String userId)
                            throws AccessSecurityReadException
マイメニューIDをすべて取得する。

アカウントに紐付くマイメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getFavoriteMenus

public FavoriteMenu[] getFavoriteMenus(String groupId,
                                       String userId)
                                throws AccessSecurityReadException
マイメニュー情報をすべて取得する。

アカウントに紐付くマイメニュー情報をすべて取得します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
マイメニュー情報の配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - マイメニュー情報取得に失敗した場合スローされます。

getUserIds

public String[] getUserIds(String groupId)
                    throws AccessSecurityReadException
ユーザIDの一覧を取得する。

パラメータ:
groupId - ログイングループID
戻り値:
ユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

getUserIdsByRoles

public String[] getUserIdsByRoles(String groupId,
                                  String[] roleIds,
                                  Date date)
                           throws AccessSecurityReadException
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。

パラメータ:
groupId - ログイングループID
roleIds - 検証用ロールIDの一覧
date - 有効期間判定用の日付
戻り値:
有効なアカウントロールを持つアカウントのユーザIDの配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

init

public void init(Map params)
アカウントアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertAccount

public void insertAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          DuplicateException
アカウント情報を新規追加する。

パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウント情報が既に存在した場合スローされます。

insertAccountRole

public void insertAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              DuplicateException
アカウントロール情報を新規追加する。

アカウントに紐付くアカウントロール情報を新規に追加します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の作成に失敗した場合スローされます。
DuplicateException - 追加するアカウントロール情報が既に存在した場合スローされます。

insertFavoriteMenu

public void insertFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               DuplicateException
マイメニュー情報を新規追加する。

アカウントに紐付くマイメニュー情報を新規に追加します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の作成に失敗した場合スローされます。
DuplicateException - 追加するマイメニュー情報が既に存在した場合スローされます。

searchAccounts

public Account[] searchAccounts(String groupId,
                                String userId)
                         throws AccessSecurityReadException
アカウント情報の読み込みます。 ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウント情報を返します。
ただし、以下の文字列を特殊文字列として扱う。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

パラメータ:
groupId - ログイングループID
userId - ユーザID（検索キー）
戻り値:
アカウント情報配列
例外:
AccessSecurityReadException - アカウント情報取得に失敗した場合スローされます。

updateAccount

public void updateAccount(String groupId,
                          Account account)
                   throws AccessSecurityWriteException,
                          NotExistException
アカウント情報を更新する。

パラメータ:
groupId - ログイングループID
account - アカウント情報
例外:
AccessSecurityWriteException - アカウント情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウント情報が存在しない場合にスローされます。

updateAccountRole

public void updateAccountRole(String groupId,
                              String userId,
                              AccountRole accountRole)
                       throws AccessSecurityWriteException,
                              NotExistException
アカウントロール情報を更新する。

アカウントに紐付くアカウントロール情報を更新します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityWriteException - アカウントロール情報の更新に失敗した場合スローされます。
NotExistException - 更新するアカウントロール情報が存在しない場合にスローされます。

updateFavoriteMenu

public void updateFavoriteMenu(String groupId,
                               String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityWriteException,
                               NotExistException
マイメニュー情報を更新する。

アカウントに紐付くマイメニュー情報を更新します。

パラメータ:
groupId - ログイングループID
userId - ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityWriteException - マイメニュー情報の更新に失敗した場合スローされます。
NotExistException - 更新するマイメニュー情報が存在しない場合にスローされます。

getUserIdsByAccountRole

public String[] getUserIdsByAccountRole(String groupId,
                                        String roleId)
                                 throws AccessSecurityReadException
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。 引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。

パラメータ:
groupId - ログイングループID
roleId - String アカウントロールのロールID
戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityReadException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountChangedListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountChangedListener

public interface AccountChangedListener

アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | accountAdded(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | accountRoleAdded(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | accountRoleUpdated(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | accountUpdated(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | init(Map params) アカウントリスナーの初期化。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

accountAdded

public void accountAdded(String groupId,
                         Account account)
                  throws ChangedListenerException
アカウント情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountDeleted

public void accountDeleted(String groupId,
                           String userId)
                    throws ChangedListenerException
アカウント情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountUpdated

public void accountUpdated(String groupId,
                           Account account)
                    throws ChangedListenerException
アカウント情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleAdded

public void accountRoleAdded(String groupId,
                             String userId,
                             AccountRole accountRole)
                      throws ChangedListenerException
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleDeleted

public void accountRoleDeleted(String groupId,
                               String userId,
                               String roleId)
                        throws ChangedListenerException
アカウントロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleUpdated

public void accountRoleUpdated(String groupId,
                               String userId,
                               AccountRole accountRole)
                        throws ChangedListenerException
アカウントロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountExporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountExporter

既知の実装クラスの一覧:
StandardAccountBackup
public interface AccountExporter

アカウントエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(AccountManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

アカウント情報をバックアップファイルに出力します。

パラメータ:
manager - アカウントマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountImporter

既知の実装クラスの一覧:
StandardAccountBackup
public interface AccountImporter

アカウントインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     AccountManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からアカウント情報を取得し、生成します。

パラメータ:
manager - アカウントマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス AccountManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.AccountManager
public final class AccountManager
extends Object

アカウントマネージャクラス。
アカウント情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
Account

コンストラクタの概要
AccountManager(String groupId)
コンストラクタ。
メソッドの概要
void | addAccount(Account account) アカウントを新規追加します。
void | addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
static void | clearInstance() アカウントマネージャのインスタンスを初期化します。
boolean | contains(String userId) アカウントの存在チェックを行います。
int | count() アカウントの登録数を取得します。
void | deleteAccount(String userId) アカウントを削除します。
void | deleteAccountRole(String userId, String roleId) アカウントロールを削除します。
void | deleteAccountRoles(String userId) アカウントロールをすべて削除します。
void | deleteAccounts() アカウントをすべて削除します。
void | deleteFavoriteMenu(String userId, String menuId) マイメニューを削除します。
void | deleteFavoriteMenus(String userId) マイメニューをすべて削除します。
void | exportData(String category, OutputStream outputStream) アカウント情報をエクスポートします。
Account | getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
String[] | getAccountRoleIds(String userId) アカウントロールIDをすべて取得します。
AccountRole[] | getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
Account[] | getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
String[] | getExportCategories() アカウントエクスポート用のカテゴリの一覧を取得します。
String[] | getFavoriteMenuIds(String userId) マイメニューIDをすべて取得します。
FavoriteMenu[] | getFavoriteMenus(String userId) マイメニューをすべて取得します。
String[] | getImportCategories() アカウントインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
String[] | getRoleIds(String userId, Date date) アカウントに紐付く有効なロールIDをすべて取得します。
String[] | getUserIds() すべてのユーザIDを取得します。
String[] | getUserIdsByAccountRole(String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | getUserIdsByRole(String roleId, Date date) 有効なロールIDを持つすべてのユーザIDを取得します。
void | importData(String category, InputStream inputStream) アカウント情報をインポートします。
Account[] | searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
void | updateAccount(Account account) アカウントを更新します。
void | updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountManager

public AccountManager(String groupId)
               throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
アカウントマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addAccount

public void addAccount(Account account)
                throws AccessSecurityException
アカウントを新規追加します。

パラメータ:
account - アカウント情報
例外:
AccessSecurityException - アカウント情報の作成に失敗した場合、または引数が不正な場合にスローされます。

addAccountRole

public void addAccountRole(String userId,
                           AccountRole accountRole)
                    throws AccessSecurityException
アカウントロールを新規追加します。

アカウントに紐付くアカウントロールを新規追加します。

パラメータ:
userId - 対象ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityException - アカウントロール情報の作成に失敗した場合、または引数が不正な場合にスローされます。

addFavoriteMenu

public void addFavoriteMenu(String userId,
                            FavoriteMenu favoriteMenu)
                     throws AccessSecurityException
マイメニューを新規追加します。

アカウントに紐付くマイメニューを新規追加します。

パラメータ:
userId - 対象ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityException - マイメニュー情報の作成に失敗した場合、または引数が不正な場合にスローされます。

contains

public boolean contains(String userId)
                 throws AccessSecurityException
アカウントの存在チェックを行います。

パラメータ:
userId - ユーザID
戻り値:
true:存在する false:存在しない
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

count

public int count()
          throws AccessSecurityException
アカウントの登録数を取得します。

戻り値:
アカウント登録数
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合に、スローされます。

deleteAccount

public void deleteAccount(String userId)
                   throws AccessSecurityException
アカウントを削除します。

パラメータ:
userId - ユーザID
例外:
AccessSecurityException - アカウント情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccountRole

public void deleteAccountRole(String userId,
                              String roleId)
                       throws AccessSecurityException
アカウントロールを削除します。

アカウントに紐付くアカウントロールを削除します。

パラメータ:
userId - 対象ユーザID
roleId - ロールID
例外:
AccessSecurityException - アカウントロール情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccountRoles

public void deleteAccountRoles(String userId)
                        throws AccessSecurityException
アカウントロールをすべて削除します。

アカウントに紐付くアカウントロールをすべて削除します。

パラメータ:
userId - 対象ユーザID
例外:
AccessSecurityException - アカウントロール情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteAccounts

public void deleteAccounts()
                    throws AccessSecurityException
アカウントをすべて削除します。

例外:
AccessSecurityException - アカウントの削除に失敗した場合にスローされます。

deleteFavoriteMenu

public void deleteFavoriteMenu(String userId,
                               String menuId)
                        throws AccessSecurityException
マイメニューを削除します。

アカウントに紐付くマイメニューを削除します。

パラメータ:
userId - 対象ユーザID
menuId - メニューID
例外:
AccessSecurityException - マイメニュー情報の削除に失敗した場合、または引数が不正な場合にスローされます。

deleteFavoriteMenus

public void deleteFavoriteMenus(String userId)
                         throws AccessSecurityException
マイメニューをすべて削除します。

アカウントに紐付くマイメニューをすべて削除します。

パラメータ:
userId - 対象ユーザID
例外:
AccessSecurityException - マイメニュー情報の削除に失敗した場合、または引数が不正な場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
アカウント情報をエクスポートします。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正な場合にスローされます。

getAccount

public Account getAccount(String userId)
                   throws AccessSecurityException
ユーザIDにマッチしたユーザデータを１件取得します。
※一度、取得したデータはキャッシュに保管します。

パラメータ:
userId -
戻り値:
ユーザデータ
例外:
AccessSecurityException - アカウントの取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoleIds

public String[] getAccountRoleIds(String userId)
                           throws AccessSecurityException
アカウントロールIDをすべて取得します。

アカウントに紐付くアカウントロールIDをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
アカウントロールIDの配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String userId)
                              throws AccessSecurityException
アカウントロールをすべて取得します。

アカウントに紐付くアカウントロールをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
アカウントロール情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccountRoles

public AccountRole[] getAccountRoles(String userId,
                                     Date date)
                              throws AccessSecurityException
有効期間内のアカウントロールをすべて取得します。

指定日付でアカウントに紐付く有効なアカウントロールをすべて取得します。

パラメータ:
userId - 対象ユーザID
date - 有効期間判定用の日付
戻り値:
アカウントロール情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getAccounts

public Account[] getAccounts()
                      throws AccessSecurityException
ログイングループ内のすべてのユーザアカウントを取得します。

戻り値:
アカウント情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合にスローされます。

getAccountsByUserIds

public Account[] getAccountsByUserIds(String[] userIds)
                               throws AccessSecurityException
ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。

パラメータ:
userIds - ユーザIDの配列
戻り値:
アカウント情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
アカウントエクスポート用のカテゴリの一覧を取得します。

戻り値:
アカウントエクスポート用カテゴリの一覧
例外:
AccessSecurityException - アカウントエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getFavoriteMenuIds

public String[] getFavoriteMenuIds(String userId)
                            throws AccessSecurityException
マイメニューIDをすべて取得します。

アカウントに紐付くマイメニューIDをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
マイメニューIDの配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - マイメニュー情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getFavoriteMenus

public FavoriteMenu[] getFavoriteMenus(String userId)
                                throws AccessSecurityException
マイメニューをすべて取得します。

アカウントに紐付くマイメニューをすべて取得します。

パラメータ:
userId - 対象ユーザID
戻り値:
マイメニュー情報の配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - マイメニュー情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
アカウントインポート用のカテゴリの一覧を取得します。

戻り値:
アカウントインポート用カテゴリの一覧
例外:
AccessSecurityException - アカウントインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getRoleIds

public String[] getRoleIds(String userId,
                           Date date)
                    throws AccessSecurityException
アカウントに紐付く有効なロールIDをすべて取得します。

指定日付でアカウントに紐付く有効なアカウントロールをすべて取得し、
有効なアカウントロールが持つすべてのサブロールを取得して、ロールIDの一覧を返却します。

パラメータ:
userId - 対象ユーザID
date - 有効期間判定用の日付
戻り値:
ロールIDの配列
該当するロールがない場合は空の配列を返します。
例外:
AccessSecurityException - ロール情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getUserIds

public String[] getUserIds()
                    throws AccessSecurityException
すべてのユーザIDを取得します。

戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityException - ユーザIDの取得に失敗した場合にスローされます。

getUserIdsByAccountRole

public String[] getUserIdsByAccountRole(String roleId)
                                 throws AccessSecurityException
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。 引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。

パラメータ:
roleId - String アカウントロールのロールID
戻り値:
ユーザIDの配列（データがない場合は空の配列を返します）
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

getUserIdsByRole

public String[] getUserIdsByRole(String roleId,
                                 Date date)
                          throws AccessSecurityException
有効なロールIDを持つすべてのユーザIDを取得します。

指定したロールIDからすべての親ロールを取得し、
指定日付で有効なアカウントロールを持つアカウントのユーザIDの一覧を返却します。

パラメータ:
roleId - ロールID
date - 有効期間判定用の日付
戻り値:
ユーザIDの配列
該当するユーザがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウント情報の取得に失敗した場合、または引数が不正な場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
アカウント情報をインポートします。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正な場合にスローされます。

searchAccounts

public Account[] searchAccounts(String userId)
                         throws AccessSecurityException
ユーザIDを検索してマッチしたアカウントを配列で返します。
ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウント情報を返します。
ただし、以下の文字列を特殊文字列として扱います。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

パラメータ:
userId - 検索キー
戻り値:
ユーザアカウント配列
データがない場合は空の配列を返します。
例外:
AccessSecurityException - アカウントの取得に失敗した場合、または引数が不正な場合にスローされます。

updateAccount

public void updateAccount(Account account)
                   throws AccessSecurityException
アカウントを更新します。

パラメータ:
account - アカウント情報
例外:
AccessSecurityException - アカウントの更新に失敗した場合、または引数が不正な場合にスローされます。

updateAccountRole

public void updateAccountRole(String userId,
                              AccountRole accountRole)
                       throws AccessSecurityException
アカウントロールを更新します。

アカウントに紐付くアカウントロールを更新します。

パラメータ:
userId - 対象ユーザID
accountRole - アカウントロール情報
例外:
AccessSecurityException - アカウントロール情報の更新に失敗した場合、または引数が不正な場合にスローされます。

updateFavoriteMenu

public void updateFavoriteMenu(String userId,
                               FavoriteMenu favoriteMenu)
                        throws AccessSecurityException
マイメニューを更新します。

アカウントに紐付くマイメニューを更新します。

パラメータ:
userId - 対象ユーザID
favoriteMenu - マイメニュー情報
例外:
AccessSecurityException - マイメニュー情報の更新に失敗した場合、または引数が不正な場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountPostWriterListener

public interface AccountPostWriterListener

アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | init(Map params) アカウントリスナーの初期化。
void | postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | postDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | postDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | postDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除した直後にコールされます。
void | postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateAccount

public void postCreateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccount

public void postDeleteAccount(String groupId,
                              String userId)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccount

public void postUpdateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateAccountRole

public void postCreateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccountRole

public void postDeleteAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccountRole

public void postUpdateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateFavoriteMenu

public void postCreateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteFavoriteMenu

public void postDeleteFavoriteMenu(String groupId,
                                   String userId,
                                   String menuId)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されたマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateFavoriteMenu

public void postUpdateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountQueryWriterListener

public interface AccountQueryWriterListener

アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
AccountManager

メソッドの概要
void | init(Map params) アカウントリスナーの初期化。
void | queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | queryDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除する直前にコールされます。
void | queryDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除する直前にコールされます。
void | queryDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除する直前にコールされます。
void | queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateAccount

public void queryCreateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
account - 作成されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccount

public void queryDeleteAccount(String groupId,
                               String userId)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 削除されるユーザコード
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateAccount

public void queryUpdateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
アカウント情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
account - 更新されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateAccountRole

public void queryCreateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccountRole

public void queryDeleteAccountRole(String groupId,
                                   String userId,
                                   String roleId)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されるロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateAccountRole

public void queryUpdateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
アカウントロール情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateFavoriteMenu

public void queryCreateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteFavoriteMenu

public void queryDeleteFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されるマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateFavoriteMenu

public void queryUpdateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
マイメニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
インタフェース AccountReaderDecorator

public interface AccountReaderDecorator

アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Account | doDecoration(String groupId, Account account) アカウントをデータストアからの読み込み直後にコールされます。
void | init(Map params) アカウントデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
アカウントデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public Account doDecoration(String groupId,
                            Account account)
アカウントをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
account - 読み込みが行われたアカウント情報
戻り値:
拡張されたアカウント情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountRole (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス AccountRole

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.AccountRole
すべての実装インタフェース:
Serializable
public class AccountRole
extends Object
implements Serializable

アカウント用ロールモデル。

アカウントに対してこのロールが有効になる範囲は、有効開始日 <= 日付 < 有効終了日の範囲です。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccountRole(String roleId)
コンストラクタ。
メソッドの概要
String | getRoleId() ロールIDを取得します。
Date | getRoleValidEndDate() ロール有効終了日を取得します。
Date | getRoleValidStartDate() ロール有効開始日を取得します。
protected void | setRoleId(String roleId) ロールIDを設定します。
void | setRoleValidEndDate(Date roleValidEndDate) ロール有効終了日を設定します。
void | setRoleValidStartDate(Date roleValidStartDate) ロール有効開始日を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountRole

public AccountRole(String roleId)
コンストラクタ。

パラメータ:
roleId - ロールID
メソッドの詳細

getRoleId

public String getRoleId()
ロールIDを取得します。

戻り値:
ロールID

getRoleValidEndDate

public Date getRoleValidEndDate()
ロール有効終了日を取得します。

戻り値:
ロール有効終了日
設定されていない場合は、日付の最大過去日を返却します。

getRoleValidStartDate

public Date getRoleValidStartDate()
ロール有効開始日を取得します。

戻り値:
ロール有効開始日
設定されていない場合は、日付の最大未来日を返却します。

setRoleId

protected void setRoleId(String roleId)
ロールIDを設定します。

パラメータ:
roleId - ロールID

setRoleValidEndDate

public void setRoleValidEndDate(Date roleValidEndDate)
ロール有効終了日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付の前日までです。
nullを設定した場合は、最大未来日に設定されます。

パラメータ:
roleValidEndDate - ロール有効終了日

setRoleValidStartDate

public void setRoleValidStartDate(Date roleValidStartDate)
ロール有効開始日を設定します。

設定されるのは、日付のみで、時間は00:00:00に設定されます。
有効になるのは設定された日付からです。
nullを設定した場合は、最大過去日に設定されます。

パラメータ:
roleValidStartDate - ロール有効開始日
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FavoriteMenu (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス FavoriteMenu

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.FavoriteMenu
すべての実装インタフェース:
Serializable
public class FavoriteMenu
extends Object
implements Serializable

マイメニューモデル。

マイメニューの情報を保管するモデルクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FavoriteMenu(String menuId)
コンストラクタ。
FavoriteMenu(String menuId, String displayName, int sortNumber)
コンストラクタ。
メソッドの概要
String | getDisplayName() マイメニュー表示名を取得します。
String | getMenuId() メニューIDを取得します。
int | getSortNumber() ソート番号を取得します。
void | setDisplayName(String displayName) マイメニュー表示名を設定する。
protected void | setMenuId(String menuId) メニューIDを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FavoriteMenu

public FavoriteMenu(String menuId,
                    String displayName,
                    int sortNumber)
コンストラクタ。

パラメータ:
displayName - マイメニュー表示名
menuId - メニューID
sortNumber - ソート番号

FavoriteMenu

public FavoriteMenu(String menuId)
コンストラクタ。

パラメータ:
menuId - メニューID
メソッドの詳細

getDisplayName

public String getDisplayName()
マイメニュー表示名を取得します。

戻り値:
マイメニュー表示名

getMenuId

public String getMenuId()
メニューIDを取得します。

戻り値:
メニューID

getSortNumber

public int getSortNumber()
ソート番号を取得します。

戻り値:
ソート番号

setDisplayName

public void setDisplayName(String displayName)
マイメニュー表示名を設定する。

パラメータ:
displayName - マイメニュー表示名

setMenuId

protected void setMenuId(String menuId)
メニューIDを設定します。

パラメータ:
menuId - メニューID

setSortNumber

public void setSortNumber(int sortNumber)
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.account (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.account
インタフェース
AccountAccessor
AccountChangedListener
AccountExporter
AccountImporter
AccountPostWriterListener
AccountQueryWriterListener
AccountReaderDecorator
クラス
Account
AccountManager
AccountRole
FavoriteMenu
RoleChangedAccountListener
StandardAccountBackup


jp.co.intra_mart.foundation.security.account (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.account

アカウントに関連するクラスを提供します。

参照:
説明

インタフェースの概要
AccountAccessor | アカウントアクセッサインタフェース。
AccountChangedListener | アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountExporter | アカウントエクスポートインタフェースです。
AccountImporter | アカウントインポートインタフェースです。
AccountPostWriterListener | アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener | アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountReaderDecorator | アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
Account | アカウントモデル。
AccountManager | アカウントマネージャクラス。
AccountRole | アカウント用ロールモデル。
FavoriteMenu | マイメニューモデル。
RoleChangedAccountListener | ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。
StandardAccountBackup | アカウントバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.account の説明

アカウントに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.account クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.account の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.account.Account (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.FavoriteMenu (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.account.StandardAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.account.AccountAccessor
  • interface jp.co.intra_mart.foundation.security.account.AccountChangedListener
  • interface jp.co.intra_mart.foundation.security.account.AccountExporter
  • interface jp.co.intra_mart.foundation.security.account.AccountImporter
  • interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.account の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.account の使用

jp.co.intra_mart.foundation.security.account を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。
AccountExporter
アカウントエクスポートインタフェースです。
AccountImporter
アカウントインポートインタフェースです。
AccountManager
アカウントマネージャクラス。
AccountRole
アカウント用ロールモデル。
FavoriteMenu
マイメニューモデル。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.account のクラス
Account
アカウントモデル。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RoleChangedAccountListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス RoleChangedAccountListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener
すべての実装インタフェース:
RoleChangedListener
public class RoleChangedAccountListener
extends Object
implements RoleChangedListener

ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleChangedAccountListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedAccountListener

public RoleChangedAccountListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAccountBackup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.account
クラス StandardAccountBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.account.StandardAccountBackup
すべての実装インタフェース:
AccountExporter, AccountImporter
public class StandardAccountBackup
extends Object
implements AccountImporter, AccountExporter

アカウントバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardAccountBackup()
メソッドの概要
void | doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardAccountBackup

public StandardAccountBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化する。

定義:
インタフェース AccountImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     AccountManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からアカウント情報を生成します。

定義:
インタフェース AccountImporter 内の doImport
パラメータ:
manager - アカウントマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(AccountManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

アカウントバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース AccountExporter 内の doExport
パラメータ:
manager - アカウントマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.admin.SuperUser の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.admin.SuperUser の使用

SuperUser を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security のメソッド
 SuperUser SystemManager.getSuperUser()
システム管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
void | SystemManager.addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
void | SystemManager.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.admin での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security.admin のメソッド
SuperUser | SuperUserReaderDecorator.doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
SuperUser | SuperUserAccessor.getSuperUser() システム管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.admin のメソッド
SuperUser | SuperUserReaderDecorator.doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
void | SuperUserQueryWriterListener.queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | SuperUserQueryWriterListener.queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。
void | SuperUserPostWriterListener.postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | SuperUserPostWriterListener.postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。
void | SuperUserAccessor.insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | SuperUserAccessor.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.certification での SuperUser の使用

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
int | SuperUserNoCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
int | SuperCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
int | StandardSuperUserCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。

jp.co.intra_mart.foundation.security.group での SuperUser の使用

SuperUser を返す jp.co.intra_mart.foundation.security.group のメソッド
SuperUser | LoginGroupManager.getSuperUser(String groupId) グループ管理者情報を取得します。
SuperUser | GroupSuperUserReaderDecorator.doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
SuperUser | GroupSuperUserAccessor.getSuperUser(String groupId) グループ管理者情報を取得します。

SuperUser 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupManager.addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
void | LoginGroupManager.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。
SuperUser | GroupSuperUserReaderDecorator.doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
void | GroupSuperUserQueryWriterListener.queryCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成する直前にコールされます。
void | GroupSuperUserQueryWriterListener.queryUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新する直前にコールされます。
void | GroupSuperUserPostWriterListener.postCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成した直後にコールされます。
void | GroupSuperUserPostWriterListener.postUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新した直後にコールされます。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserAccessor の使用

jp.co.intra_mart.foundation.security.admin.SuperUserAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener の使用

jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener の使用

jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator の使用

jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.admin (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.admin
インタフェース
SuperUserAccessor
SuperUserPostWriterListener
SuperUserQueryWriterListener
SuperUserReaderDecorator
クラス
SuperUser


jp.co.intra_mart.foundation.security.admin (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.admin

システム管理者に関連するクラスを提供します。

参照:
説明

インタフェースの概要
SuperUserAccessor | システム管理者アクセッサインタフェース。
SuperUserPostWriterListener | システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
SuperUserQueryWriterListener | システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
SuperUserReaderDecorator | システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
SuperUser スーパーユーザ・モデルインタフェース。

パッケージ jp.co.intra_mart.foundation.security.admin の説明

システム管理者に関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.admin クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.admin の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.admin.SuperUser (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.admin の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.admin の使用

jp.co.intra_mart.foundation.security.admin を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.admin のクラス
SuperUser
スーパーユーザ・モデルインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SuperUser (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
クラス SuperUser

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.admin.SuperUser
すべての実装インタフェース:
LocaleProvider, Serializable
public class SuperUser
extends Object
implements LocaleProvider, Serializable

スーパーユーザ・モデルインタフェース。 スーパーユーザのデータモデルインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
SystemManager, 直列化された形式

コンストラクタの概要
protected | SuperUser() コンストラクタ。
 | SuperUser(String userId) コンストラクタ。
メソッドの概要
boolean | equals(Object superUser) オブジェクトの比較。
String | getEncoding() エンコーディングの取得。
Locale | getLocale() ロケールの取得。
String | getMailAddress() メールアドレス取得。
String | getPassword() パスワード取得。
String | getTelNo() 電話番号取得。
String | getUserId() ユーザID取得。
int | hashCode() ハッシュコード値取得。
void | setEncoding(String encoding) エンコーディングの設定。
void | setLocale(Locale locale) ロケールの設定。
void | setMailAddress(String mailAddress) メールアドレス設定。
void | setPassword(String password) パスワード設定。
void | setTelNo(String telNo) 電話番号設定。
void | setUserId(String id) ユーザID設定。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUser

protected SuperUser()
コンストラクタ。

SuperUser

public SuperUser(String userId)
コンストラクタ。

パラメータ:
userId - スーパーユーザのユーザID
メソッドの詳細

equals

public boolean equals(Object superUser)
オブジェクトの比較。

指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
superUser - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディングの取得。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコード
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールの取得。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getMailAddress

public String getMailAddress()
メールアドレス取得。

スーパーユーザのメールアドレスを取得します

戻り値:
メールアドレス
関連項目:
getMailAddress()

getPassword

public String getPassword()
パスワード取得。

スーパーユーザのパスワードを取得します

戻り値:
パスワード
関連項目:
getPassword()

getTelNo

public String getTelNo()
電話番号取得。

スーパーユーザの電話番号を取得します

戻り値:
電話番号
関連項目:
getTelNo()

getUserId

public String getUserId()
ユーザID取得。

スーパーユーザのユーザIDを取得します

戻り値:
ユーザID
関連項目:
getUserId()

hashCode

public int hashCode()
ハッシュコード値取得。

このモデルのハッシュコード値を返します

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setEncoding

public void setEncoding(String encoding)
エンコーディングの設定。

パラメータ:
encoding - エンコーディング
関連項目:
setEncoding(String)

setLocale

public void setLocale(Locale locale)
ロケールの設定。

パラメータ:
locale - ロケール
関連項目:
setLocale(Locale)

setMailAddress

public void setMailAddress(String mailAddress)
メールアドレス設定。

スーパーユーザのメールアドレスを設定します

パラメータ:
mailAddress - メールアドレス
関連項目:
setMailAddress(String)

setPassword

public void setPassword(String password)
パスワード設定。

スーパーユーザのパスワードを設定します

パラメータ:
password - パスワード
関連項目:
setPassword(String)

setTelNo

public void setTelNo(String telNo)
電話番号設定。

スーパーユーザの電話番号を設定します

パラメータ:
telNo - 電話番号
関連項目:
setTelNo(String)

setUserId

public void setUserId(String id)
ユーザID設定。

スーパーユーザのユーザIDを設定します

パラメータ:
id - ユーザID
関連項目:
setUserId(String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SuperUserAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserAccessor

public interface SuperUserAccessor

システム管理者アクセッサインタフェース。

システム管理者情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | getSuperUser() システム管理者情報を取得します。
void | init(Map params) システム管理者アクセッサを初期化します。
void | insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

メソッドの詳細

getSuperUser

public SuperUser getSuperUser()
                       throws AccessSecurityReadException
システム管理者情報を取得します。

戻り値:
システム管理者情報
例外:
AccessSecurityReadException - システム管理者情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
システム管理者アクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertSuperUser

public void insertSuperUser(SuperUser superUser)
                     throws AccessSecurityWriteException,
                            DuplicateException
システム管理者情報を新規追加します。

パラメータ:
superUser - システム管理者情報
例外:
AccessSecurityWriteException - システム管理者情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するシステム管理者が既に存在した場合にスローされます。

updateSuperUser

public void updateSuperUser(SuperUser superUser)
                     throws AccessSecurityWriteException,
                            NotExistException
システム管理者情報を更新します。

パラメータ:
superUser - システム管理者情報
例外:
AccessSecurityWriteException - システム管理者情報の更新に失敗した場合にスローされます。
NotExistException - 更新するシステム管理者が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SuperUserPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserPostWriterListener

public interface SuperUserPostWriterListener

システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) システム管理者リスナーの初期化。
void | postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
システム管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(SuperUser superUser)
                throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに作成した直後にコールされます。

パラメータ:
superUser - 作成されたシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(SuperUser superUser)
                throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに更新した直後にコールされます。

パラメータ:
superUser - 更新されたシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserQueryWriterListener

public interface SuperUserQueryWriterListener

システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) システム管理者リスナーの初期化。
void | queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
システム管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(SuperUser superUser)
                 throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに作成する直前にコールされます。

パラメータ:
superUser - 作成されるシステム管理者情報
戻り値:
システム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(SuperUser superUser)
                 throws AccessSecurityListenerExcpetion
システム管理者情報をデータストアに更新する直前にコールされます。

パラメータ:
superUser - 更新されるシステム管理者情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.admin
インタフェース SuperUserReaderDecorator

public interface SuperUserReaderDecorator

システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | doDecoration(SuperUser superUser) システム管理者情報をデータストアからの読み込み直後にコールされます。
void | init(Map params) システム管理者デコレータの初期化。

メソッドの詳細

init

public void init(Map params)
システム管理者デコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public SuperUser doDecoration(SuperUser superUser)
システム管理者情報をデータストアからの読み込み直後にコールされます。

パラメータ:
superUser - 読み込みが行われた管理者情報
戻り値:
拡張された管理者情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.batch.Batch の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.Batch の使用

Batch を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での Batch の使用

Batch を返す jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchReaderDecorator.doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
Batch | BatchManager.getBatch(String batchId) バッチ情報を取得します。
Batch[] | BatchManager.getBatches() すべてのバッチ情報を取得します。
Batch[] | BatchManager.getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
Batch | BatchAccessor.getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | BatchAccessor.getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | BatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。

Batch 型のパラメータを持つ jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchReaderDecorator.doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
void | BatchQueryWriterListener.queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | BatchQueryWriterListener.queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。
void | BatchPostWriterListener.postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | BatchPostWriterListener.postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。
void | BatchManager.addBatch(Batch batch) バッチ情報を新規登録します。
void | BatchManager.updateBatch(Batch batch) バッチ情報を更新します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。
void | BatchAccessor.insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchAccessor の使用

jp.co.intra_mart.foundation.security.batch.BatchAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchExporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchExporter の使用

BatchExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchExporter の使用

BatchExporter を実装している jp.co.intra_mart.foundation.security.batch のクラス
 class StandardBatchBackup
バッチバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchImporter の使用

BatchImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchImporter の使用

BatchImporter を実装している jp.co.intra_mart.foundation.security.batch のクラス
 class StandardBatchBackup
バッチバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.batch.BatchManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.BatchManager の使用

BatchManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch での BatchManager の使用

BatchManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.batch のメソッド
void | StandardBatchBackup.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | StandardBatchBackup.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | BatchImporter.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | BatchExporter.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener の使用

jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener の使用

jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator の使用

jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.batch.StandardBatchBackup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.batch.StandardBatchBackup の使用

jp.co.intra_mart.foundation.security.batch.StandardBatchBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Batch (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス Batch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.Batch
すべての実装インタフェース:
Serializable
public class Batch
extends Object
implements Serializable

バッチ・モデルクラス

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
BatchManager, 直列化された形式

フィールドの概要
static String | LANG_JAVA プログラム言語(JAVA)。
static String | LANG_JAVA_SCRIPT プログラム言語(JavaScript)。
コンストラクタの概要
Batch()
コンストラクタ。
Batch(String batchId)
コンストラクタ。
メソッドの概要
String | getBatchId() バッチＩＤを取得します。
String | getDescription() バッチ内容を取得します。
String | getName() バッチ名を取得します。
String | getProgramLanguage() 実行プログラム言語を取得します。
String | getProgramPath() 実行プログラムパスを取得します。
int | getRunDay() 実行日を取得します。
int | getRunDayWeek() 実行曜日を取得します。
int | getRunHour() 実行時を取得します。
int | getRunMinute() 実行分を取得します。
int | getRunMonth() 実行月を取得します。
int | getRunSecond() 実行秒を取得します。
int | getRunYear() 実行年を取得します。
boolean | isValidate() 有効・無効フラグを取得します。
protected void | setBatchId(String batchId) バッチＩＤを設定します。
void | setDescription(String description) バッチ内容を設定します。
void | setName(String name) バッチ名を設定します。
void | setProgramLanguage(String programLanguage) 実行プログラム言語の種類を設定します。
void | setProgramPath(String programPath) 実行プログラムパスを設定します。
void | setRunDay(int runDay) 実行日を設定します。
void | setRunDayWeek(int runDayWeek) 実行曜日を設定します。
void | setRunHour(int runHour) 実行時を設定します。
void | setRunMinute(int runMinute) 実行分を設定します。
void | setRunMonth(int runMonth) 実行月を設定します。
void | setRunSecond(int runSecond) 実行秒を設定します。
void | setRunYear(int runYear) 実行年を設定します。
void | setValidate(boolean validFlg) バッチの有効・無効を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LANG_JAVA

public static final String LANG_JAVA
プログラム言語(JAVA)。
バッチを実行するプログラム言語の種類。

関連項目:
setProgramLanguage(String), 定数フィールド値

LANG_JAVA_SCRIPT

public static final String LANG_JAVA_SCRIPT
プログラム言語(JavaScript)。
バッチを実行するプログラム言語の種類。

関連項目:
setProgramLanguage(String), 定数フィールド値
コンストラクタの詳細

Batch

public Batch()
コンストラクタ。

バッチIDは自動採番されます。

Batch

public Batch(String batchId)
コンストラクタ。

パラメータ:
batchId - バッチID
メソッドの詳細

getBatchId

public String getBatchId()
バッチＩＤを取得します。

戻り値:
バッチＩＤ

getDescription

public String getDescription()
バッチ内容を取得します。

戻り値:
バッチ内容

getName

public String getName()
バッチ名を取得します。

戻り値:
バッチ名

getProgramLanguage

public String getProgramLanguage()
実行プログラム言語を取得します。
(java/js)

戻り値:
実行プログラム言語

getProgramPath

public String getProgramPath()
実行プログラムパスを取得します。

戻り値:
実行プログラムパス

getRunDay

public int getRunDay()
実行日を取得します。

戻り値:
実行日

getRunDayWeek

public int getRunDayWeek()
実行曜日を取得します。

戻り値:
曜日

getRunHour

public int getRunHour()
実行時を取得します。

戻り値:
実行時

getRunMinute

public int getRunMinute()
実行分を取得します。

戻り値:
実行分

getRunMonth

public int getRunMonth()
実行月を取得します。

戻り値:
実行月

getRunSecond

public int getRunSecond()
実行秒を取得します。

戻り値:
実行秒

getRunYear

public int getRunYear()
実行年を取得します。

戻り値:
実行年

isValidate

public boolean isValidate()
有効・無効フラグを取得します。

戻り値:
有効/無効

setBatchId

protected void setBatchId(String batchId)
バッチＩＤを設定します。

パラメータ:
batchId - バッチＩＤ

setDescription

public void setDescription(String description)
バッチ内容を設定します。

パラメータ:
description - バッチ内容

setName

public void setName(String name)
バッチ名を設定します。

パラメータ:
name - バッチ名

setProgramLanguage

public void setProgramLanguage(String programLanguage)
実行プログラム言語の種類を設定します。

設定できる値は、JavaScript( LANG_JAVA_SCRIPT)または、java( LANG_JAVA)のいずれかです。
デフォルトは、JavaScriptです。

パラメータ:
programLanguage - 実行プログラム言語

setProgramPath

public void setProgramPath(String programPath)
実行プログラムパスを設定します。 実行プログラム言語がJavaScriptである場合は、pages以下のパスを設定してください。 実行プログラム言語がjavaである場合は、クラスのフルパッケージ名を設定してください。

パラメータ:
programPath - 実行プログラムパス
関連項目:
getProgramLanguage()

setRunDay

public void setRunDay(int runDay)
実行日を設定します。

設定できる値は、-1,１～３１です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎日実行されます。

パラメータ:
runDay - 実行日

setRunDayWeek

public void setRunDayWeek(int runDayWeek)
実行曜日を設定します。

設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
実行日が設定されいる場合は、この設定は無視されます。

パラメータ:
runDayWeek - 曜日

setRunHour

public void setRunHour(int runHour)
実行時を設定します。

設定できる値は、-1,０～２３です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎時実行されます。

パラメータ:
runHour - 実行時

setRunMinute

public void setRunMinute(int runMinute)
実行分を設定します。

設定できる値は、-1,０～５９です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎分実行されます。

パラメータ:
runMinute - 実行分

setRunMonth

public void setRunMonth(int runMonth)
実行月を設定します。

設定できる値は、-1,１～１２です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎月実行されます。

パラメータ:
runMonth - 実行月

setRunSecond

public void setRunSecond(int runSecond)
実行秒を設定します。

設定できる値は、-1,０～５９です。
範囲外の値を設定した場合は、-1に設定されます。
-1を設定した場合は、毎秒実行されます。

パラメータ:
runSecond - 実行秒

setRunYear

public void setRunYear(int runYear)
実行年を設定します。

設定できる値は、-1,０～です。
-1以下を設定した場合は、-1に設定されます。
-1を設定した場合は、毎年実行されます。

パラメータ:
runYear - 実行年

setValidate

public void setValidate(boolean validFlg)
バッチの有効・無効を設定します。

パラメータ:
validFlg - 有効/無効
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BatchAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchAccessor

public interface BatchAccessor

メソッドの概要
void | deleteBatch(String groupId, String batchId) バッチ情報を削除します。
Batch | getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | getBatchIds(String groupId) すべてのバッチIDを取得します。
void | init(Map params) アクセッサの初期化。
void | insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。
void | updateBatch(String groupId, Batch batch) バッチ情報を更新します。

メソッドの詳細

deleteBatch

public void deleteBatch(String groupId,
                        String batchId)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチ情報を削除します。

パラメータ:
groupId - ログイングループID
batchId - 削除するバッチID
例外:
AccessSecurityWriteException - バッチ情報の削除に失敗した場合スローされます。
NotExistException - 削除するバッチ情報が存在しない場合スローされます。

updateBatch

public void updateBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        NotExistException
バッチ情報を更新します。

パラメータ:
groupId - ログイングループID
batch - 更新するバッチ
例外:
AccessSecurityWriteException - バッチ情報の更新に失敗した場合スローされます。
NotExistException - 削除するバッチ情報が存在しない場合スローされます。

insertBatch

public void insertBatch(String groupId,
                        Batch batch)
                 throws AccessSecurityWriteException,
                        DuplicateException
バッチ情報を新規に追加します。

パラメータ:
groupId - ログイングループID
batch - 新規登録するバッチ
例外:
AccessSecurityWriteException - バッチ情報の新規登録に失敗した場合スローされます。
DuplicateException - 追加するバッチ情報が既に存在した場合スローされます。

getBatch

public Batch getBatch(String groupId,
                      String batchId)
               throws AccessSecurityReadException
バッチ情報を取得します。

パラメータ:
groupId - ログイングループID
batchId - バッチＩＤ
戻り値:
取得されたバッチ
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatches

public Batch[] getBatches(String groupId)
                   throws AccessSecurityReadException
すべてのバッチ情報を取得します。 一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
取得されたバッチ
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatchesByIds

public Batch[] getBatchesByIds(String groupId,
                               String[] batchIds)
                        throws AccessSecurityReadException
引数に指定したバッチIDのバッチ情報をすべて取得します。
一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
batchIds - バッチＩＤの配列
戻り値:
取得されたバッチの配列
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

getBatchIds

public String[] getBatchIds(String groupId)
                     throws AccessSecurityReadException
すべてのバッチIDを取得します。
一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
バッチIDの配列
例外:
AccessSecurityReadException - バッチ情報の取得に失敗した場合スローされます。

init

public void init(Map params)
アクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BatchExporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchExporter

既知の実装クラスの一覧:
StandardBatchBackup
public interface BatchExporter

バッチバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) バッチバックアップエクスポータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doExport

public void doExport(BatchManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

バッチ情報をバックアップファイルに出力します。

パラメータ:
manager - バッチマネージャ バッチモデルクラスの配列
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchImporter

既知の実装クラスの一覧:
StandardBatchBackup
public interface BatchImporter

バッチバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | init(Map params) バッチバックアップインポータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチバックアップインポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     BatchManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からバッチ情報を取得し、生成します。

パラメータ:
manager - バッチマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス BatchManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.BatchManager
public class BatchManager
extends Object

バッチマネージャクラス。

バッチ情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
Batch

コンストラクタの概要
BatchManager(String groupId)
コンストラクタ。
メソッドの概要
void | addBatch(Batch batch) バッチ情報を新規登録します。
static void | clearInstance() バッチマネージャのインスタンスを初期化します。
void | deleteBatch(String batchId) バッチ情報を削除します。
void | deleteBatches() すべてのバッチ情報を削除します。
void | exportData(String category, OutputStream outputStream) エクスポートを行います。
Batch | getBatch(String batchId) バッチ情報を取得します。
Batch[] | getBatches() すべてのバッチ情報を取得します。
Batch[] | getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
String[] | getBatchIds() バッチIDの一覧を取得します。
String[] | getExportCategories() バッチエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() バッチインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
void | importData(String category, InputStream inputStream) インポートを行います。
void | updateBatch(Batch batch) バッチ情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BatchManager

public BatchManager(String groupId)
             throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
導入されたバージョン:
5.0
メソッドの詳細

clearInstance

public static void clearInstance()
バッチマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addBatch

public void addBatch(Batch batch)
              throws AccessSecurityException
バッチ情報を新規登録します。

パラメータ:
batch - 新規登録するバッチ
例外:
AccessSecurityException - バッチ情報の新規登録に失敗した場合、または引数が不正だった場合にスローされます。

deleteBatch

public void deleteBatch(String batchId)
                 throws AccessSecurityException
バッチ情報を削除します。

パラメータ:
batchId - 削除するバッチID
例外:
AccessSecurityException - バッチ情報の削除に失敗した場合、または引数が不正だった場合にスローされます。

deleteBatches

public void deleteBatches()
                   throws AccessSecurityException
すべてのバッチ情報を削除します。

例外:
AccessSecurityException - バッチ情報の削除に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
エクスポートを行います。

パラメータ:
category - カテゴリ名
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getBatch

public Batch getBatch(String batchId)
               throws AccessSecurityException
バッチ情報を取得します。

パラメータ:
batchId - バッチＩＤ
戻り値:
取得されたバッチ
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合、または引数が不正だった場合にスローされます。

getBatches

public Batch[] getBatches()
                   throws AccessSecurityException
すべてのバッチ情報を取得します。

戻り値:
取得されたバッチ
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getBatchesByIds

public Batch[] getBatchesByIds(String[] batchIds)
                        throws AccessSecurityException
ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。

パラメータ:
batchIds - バッチIDの配列
戻り値:
バッチ情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getBatchIds

public String[] getBatchIds()
                     throws AccessSecurityException
バッチIDの一覧を取得します。

戻り値:
バッチIDの配列
例外:
AccessSecurityException - バッチ情報の取得に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
バッチエクスポート用のカテゴリの一覧を取得します。

戻り値:
バッチエクスポート用カテゴリの一覧
例外:
AccessSecurityException - バッチエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
バッチインポート用のカテゴリの一覧を取得します。

戻り値:
バッチインポート用カテゴリの一覧
例外:
AccessSecurityException - バッチインポート用のカテゴリの取得に失敗した場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
インポートを行います。

パラメータ:
category - カテゴリ名
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

updateBatch

public void updateBatch(Batch batch)
                 throws AccessSecurityException
バッチ情報を更新します。

パラメータ:
batch - 更新するバッチ
例外:
AccessSecurityException - バッチ情報の更新に失敗した場合、または引数が不正だった場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchPostWriterListener

public interface BatchPostWriterListener

メソッドの概要
void | init(Map params) バッチリスナーの初期化。
void | postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId, String batchId) バッチ情報をデータストアから削除した直後にコールされます。
void | postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
バッチリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       Batch batch)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 作成されたバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String groupId,
                       String batchId)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
batchId - 削除されたバッチId
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(String groupId,
                       Batch batch)
                throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 更新されたバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchQueryWriterListener

public interface BatchQueryWriterListener

メソッドの概要
void | init(Map params) バッチリスナーの初期化。
void | queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId, String batchId) バッチ情報をデータストアから削除する直前にコールされます。
void | queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
バッチリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        Batch batch)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
batch - 作成されるバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String groupId,
                        String batchId)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
batchId - 削除されるバッチID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(String groupId,
                        Batch batch)
                 throws AccessSecurityListenerExcpetion
バッチ情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
batch - 更新されるバッチ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BatchReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
インタフェース BatchReaderDecorator

public interface BatchReaderDecorator

メソッドの概要
Batch | doDecoration(String groupId, Batch batch) バッチをデータストアからの読み込み直後にコールされます。
void | init(Map params) バッチデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
バッチデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public Batch doDecoration(String groupId,
                          Batch batch)
バッチをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
batch - 読み込みが行われたバッチ情報
戻り値:
拡張されたバッチ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.batch (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.batch
インタフェース
BatchAccessor
BatchExporter
BatchImporter
BatchPostWriterListener
BatchQueryWriterListener
BatchReaderDecorator
クラス
Batch
BatchManager
StandardBatchBackup


jp.co.intra_mart.foundation.security.batch (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.batch

バッチに関連するクラスを提供します。

参照:
説明

インタフェースの概要
BatchAccessor |
BatchExporter | バッチバックアップインタフェースです。
BatchImporter | バッチバックアップインタフェースです。
BatchPostWriterListener |
BatchQueryWriterListener |
BatchReaderDecorator |

クラスの概要
Batch | バッチ・モデルクラス
BatchManager | バッチマネージャクラス。
StandardBatchBackup | バッチバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.batch の説明

バッチに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.batch クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.batch.Batch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.BatchManager
    • class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup (implements jp.co.intra_mart.foundation.security.batch.BatchExporter, jp.co.intra_mart.foundation.security.batch.BatchImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.batch.BatchAccessor
  • interface jp.co.intra_mart.foundation.security.batch.BatchExporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchImporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.batch の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.batch の使用

jp.co.intra_mart.foundation.security.batch を使用しているパッケージ
jp.co.intra_mart.foundation.security.batch バッチに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.batch により使用される jp.co.intra_mart.foundation.security.batch のクラス
Batch
バッチ・モデルクラス
BatchExporter
バッチバックアップインタフェースです。
BatchImporter
バッチバックアップインタフェースです。
BatchManager
バッチマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StandardBatchBackup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.batch
クラス StandardBatchBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.batch.StandardBatchBackup
すべての実装インタフェース:
BatchExporter, BatchImporter
public class StandardBatchBackup
extends Object
implements BatchImporter, BatchExporter

バッチバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardBatchBackup()
メソッドの概要
void | doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | init(Map params) バッチバックアップの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardBatchBackup

public StandardBatchBackup()
メソッドの詳細

init

public void init(Map params)
バッチバックアップの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース BatchImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     BatchManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からバッチ情報を生成します。

定義:
インタフェース BatchImporter 内の doImport
パラメータ:
manager - バッチマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(BatchManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

バッチバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース BatchExporter 内の doExport
パラメータ:
manager - バッチマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarAccessor の使用

jp.co.intra_mart.foundation.security.calendar.CalendarAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarExporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarExporter の使用

CalendarExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarExporter の使用

CalendarExporter を実装している jp.co.intra_mart.foundation.security.calendar のクラス
 class StandardCalendarBackup
カレンダーバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarImporter の使用

CalendarImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarImporter の使用

CalendarImporter を実装している jp.co.intra_mart.foundation.security.calendar のクラス
 class StandardCalendarBackup
カレンダーバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarInfo の使用

CalendarInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarInfo の使用

CalendarInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
CalendarInfo[] | DayInfo.getCalendarInfo() マッチしたカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getConfigDayInfos() データタイプが名称であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getHodildayInfos() データタイプが休日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getNationalHodildayInfos() データタイプが祝祭日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | CategorizedCalendarInfo.getWeekdayInfos() データタイプが非休日であるカレンダーデータの一覧を取得します。
CalendarInfo | CalendarReaderDecorator.doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
CalendarInfo | CalendarManager.getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CalendarInfo | CalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。

CalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
CalendarInfo | CalendarReaderDecorator.doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
void | CalendarQueryWriterListener.queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | CalendarQueryWriterListener.queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。
void | CalendarPostWriterListener.postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | CalendarPostWriterListener.postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
void | CalendarManager.addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
void | CalendarManager.updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
void | CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

CalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のコンストラクタ
CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarManager の使用

CalendarManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarManager の使用

CalendarManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
void | StandardCalendarBackup.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | StandardCalendarBackup.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
void | CalendarImporter.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | CalendarExporter.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPlugin の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPlugin の使用

CalendarPlugin を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CalendarPlugin の使用

CalendarPlugin を実装している jp.co.intra_mart.foundation.security.calendar のクラス
class | CalendarPluginAutumnalEquinox カレンダデータプラグインクラス。
class | CalendarPluginEndOfTheMonth カレンダデータプラグインクラス。
class | CalendarPluginLastDayInTheMonth カレンダデータプラグインクラス。
class | CalendarPluginMondayMakeupHoliday カレンダデータプラグインクラス。
class | CalendarPluginVernalEquinox カレンダデータプラグインクラス。

CalendarPlugin を返す jp.co.intra_mart.foundation.security.calendar のメソッド
 CalendarPlugin CalendarManager.getPlugin(String pluginId)
カレンダーデータプラグインを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener の使用

jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener の使用

jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator の使用

jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo の使用

CategorizedCalendarInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での CategorizedCalendarInfo の使用

CategorizedCalendarInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
 CategorizedCalendarInfo CalendarManager.getCategorizedCalendarInfos(String calendarId)
すべてのカレンダーデータをデータタイプ別に分類して取得します。

CategorizedCalendarInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.calendar のメソッド
boolean | CalendarPluginVernalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginMondayMakeupHoliday.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginLastDayInTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginEndOfTheMonth.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPluginAutumnalEquinox.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
boolean | CalendarPlugin.validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date) カレンダーデータが有効かどうか検証します。
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
boolean | CalendarManager.isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | CalendarManager.isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | CalendarManager.isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.calendar.DayInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.calendar.DayInfo の使用

DayInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar での DayInfo の使用

DayInfo を返す jp.co.intra_mart.foundation.security.calendar のメソッド
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup の使用

jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CalendarAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarAccessor

public interface CalendarAccessor

カレンダーアクセッサインタフェース。

カレンダー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
String[] | getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。
void | init(Map params) カレンダーアクセッサの初期化。
void | insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
boolean | isUpdate(String groupId, String calendarId, Date date) カレンダーデータが指定された日付よりも新しいかチェックします。
void | updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

メソッドの詳細

deleteCalendar

public void deleteCalendar(String groupId,
                           String calendarId)
                    throws AccessSecurityWriteException,
                           NotExistException
カレンダーを削除します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
例外:
AccessSecurityWriteException
NotExistException

deleteCalendarInfo

public void deleteCalendarInfo(String groupId,
                               String calendarId,
                               String dataId)
                        throws AccessSecurityWriteException,
                               NotExistException
指定されたカレンダーデータを削除します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
例外:
AccessSecurityWriteException
NotExistException

getCalendarIds

public String[] getCalendarIds(String groupId)
                        throws AccessSecurityReadException
すべてのカレンダーIDを取得します。
カレンダーIDが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
戻り値:
カレンダーIDの配列
例外:
AccessSecurityReadException

getCalendarInfo

public CalendarInfo getCalendarInfo(String groupId,
                                    String calendarId,
                                    String dataId)
                             throws AccessSecurityReadException
カレンダーデータを取得します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - カレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityReadException

getCalendarInfoIds

public String[] getCalendarInfoIds(String groupId,
                                   String calendarId)
                            throws AccessSecurityReadException
すべてのカレンダーデータIDを取得します。
カレンダーデータIDが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータIDの配列
例外:
AccessSecurityReadException

getCalendarInfos

public CalendarInfo[] getCalendarInfos(String groupId,
                                       String calendarId)
                                throws AccessSecurityReadException
すべてのカレンダーデータを取得します。

カレンダーデータが存在しない場合は空の配列を返却します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
戻り値:
カレンダーデータの配列
例外:
AccessSecurityReadException

getCalendarInfosByIds

public CalendarInfo[] getCalendarInfosByIds(String groupId,
                                            String calendarId,
                                            String[] calendarInfoIds)
                                     throws AccessSecurityReadException
指定されたカレンダIDのカレンダ情報をすべて取得する。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfoIds - カレンダーデータIDの配列
戻り値:
カレンダオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - カレンダ情報取得に失敗した場合スローされます。

init

public void init(Map params)
カレンダーアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertCalendarInfo

public void insertCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               DuplicateException
カレンダーデータを新規に作成します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
DuplicateException

updateCalendarInfo

public void updateCalendarInfo(String groupId,
                               String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityWriteException,
                               NotExistException
カレンダーデータを更新します。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityWriteException
NotExistException

isUpdate

public boolean isUpdate(String groupId,
                        String calendarId,
                        Date date)
                 throws AccessSecurityReadException
カレンダーデータが指定された日付よりも新しいかチェックします。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
date - チェック対象日付
例外:
AccessSecurityReadException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CalendarExporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarExporter

既知の実装クラスの一覧:
StandardCalendarBackup
public interface CalendarExporter

カレンダーバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) カレンダーバックアップエクスポータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーバックアップエクスポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doExport

public void doExport(CalendarManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

カレンダーとカレンダー情報を
バックアップファイルに出力します。

パラメータ:
manager - カレンダーマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarImporter

既知の実装クラスの一覧:
StandardCalendarBackup
public interface CalendarImporter

カレンダーバックアップインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | init(Map params) カレンダーバックアップインポータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーバックアップインポータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     CalendarManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からカレンダーと
付随するカレンダー情報を取得し、生成します。

パラメータ:
manager - カレンダーマネージャクラス
inputStream - 入力ストリーム
戻り値:
バッチモデルクラスの配列
例外:
AccessSecurityImportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarInfo
すべての実装インタフェース:
Serializable
public class CalendarInfo
extends Object
implements Serializable

カレンダーデータ・モデルクラス

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager, 直列化された形式

フィールドの概要
static String | TYPE_CONFIG 名称（データタイプの定数）。
static String | TYPE_HOLIDAY 休日（データタイプの定数）。
static String | TYPE_NATIONAL_HOLDAY 祝祭日（データタイプの定数）。
static String | TYPE_WEEKDAY 非休日（データタイプの定数）。
コンストラクタの概要
CalendarInfo()
コンストラクタ。
CalendarInfo(String dataId)
コンストラクタ。
メソッドの概要
String | getColor() 色を取得します。
String | getDataId() データＩＤを取得します。
String | getDataType() データタイプを取得します。
int | getDay() 日を取得します。
int | getDayWeek() 曜日を取得します。
String | getDescription() データの説明を取得します。
String | getDisplayName(Locale locale) 表示名を取得します。
Locale[] | getLocales() 表示名として保管されているロケールの一覧を取得します。
int | getMonth() 月を取得します。
String | getPlugin() プラグインIDを取得します。
int | getPriority() 優先度を取得します。
int | getTimes() 次を取得します。
int | getValidEndYear() 有効終了年を取得します。
int | getValidStartYear() 有効開始年を取得します。
int | getWeek() 週を取得します。
int | getYear() 年を取得します。
void | removeDisplayName(Locale locale) ロケールに対応した表示名を削除します。
void | setColor(String color) 色を設定します。
protected void | setDataId(String dataId) データIDを設定します。
void | setDataType(String dataType) データタイプを設定します。
void | setDay(int day) 日を設定します。
void | setDayWeek(int dayWeek) 曜日を設定します。
void | setDescription(String description) データの説明を設定します。
void | setDisplayName(Locale locale, String displayName) 表示名を設定します。
void | setMonth(int month) 月を設定します。
void | setPlugin(String plugin) プラグインIDを設定します。
void | setTimes(int times) 第ｎ～曜日を設定します。
void | setValidEndYear(int validEndYear) 有効終了年を設定します。
void | setValidStartYear(int validStartYear) 有効開始年を設定します。
void | setWeek(int week) 第ｎ週目を設定します。
void | setYear(int year) 年を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_CONFIG

public static final String TYPE_CONFIG
名称（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_HOLIDAY

public static final String TYPE_HOLIDAY
休日（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_WEEKDAY

public static final String TYPE_WEEKDAY
非休日（データタイプの定数）。

関連項目:
定数フィールド値

TYPE_NATIONAL_HOLDAY

public static final String TYPE_NATIONAL_HOLDAY
祝祭日（データタイプの定数）。

関連項目:
定数フィールド値
コンストラクタの詳細

CalendarInfo

public CalendarInfo()
コンストラクタ。

データIDは自動採番されます。

CalendarInfo

public CalendarInfo(String dataId)
コンストラクタ。

パラメータ:
dataId - カレンダーデータID
メソッドの詳細

getColor

public String getColor()
色を取得します。

戻り値:
色

getDataId

public String getDataId()
データＩＤを取得します。

戻り値:
データＩＤ

getDataType

public String getDataType()
データタイプを取得します。

戻り値:
データタイプ

getDay

public int getDay()
日を取得します。

戻り値:
日

getDayWeek

public int getDayWeek()
曜日を取得します。

戻り値:
曜日

getDescription

public String getDescription()
データの説明を取得します。

戻り値:
データの説明

getDisplayName

public String getDisplayName(Locale locale)
表示名を取得します。

引数のロケールに対応した表示名を取得します。

パラメータ:
locale - ロケール
戻り値:
ロケールに対応した表示名

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応した表示名を削除します。

ロケールに対応した表示名を削除します。

パラメータ:
locale - ロケール

getLocales

public Locale[] getLocales()
表示名として保管されているロケールの一覧を取得します。

戻り値:
表示名として保管されているロケールの配列

getMonth

public int getMonth()
月を取得します。

戻り値:
月

getPlugin

public String getPlugin()
プラグインIDを取得します。

戻り値:
プラグインID

getTimes

public int getTimes()
次を取得します。
第ｎ～曜日

戻り値:
次

getValidEndYear

public int getValidEndYear()
有効終了年を取得します。

戻り値:
有効終了年

getValidStartYear

public int getValidStartYear()
有効開始年を取得します。

戻り値:
有効開始年

getWeek

public int getWeek()
週を取得します。
第ｎ週目

戻り値:
週

getYear

public int getYear()
年を取得します。

戻り値:
年

setColor

public void setColor(String color)
色を設定します。

パラメータ:
color - 色

setDataId

protected void setDataId(String dataId)
データIDを設定します。

パラメータ:
dataId - データID

setDataType

public void setDataType(String dataType)
データタイプを設定します。

設定できる値は、 TYPE_CONFIG(名称)、 TYPE_HOLIDAY(休日)、 TYPE_WEEKDAY (非休日)、 TYPE_NATIONAL_HOLDAY(祝祭日)のいずれかです。
上記以外の値が設定された場合は、 TYPE_CONFIG(名称)に設定されます。

パラメータ:
dataType - データタイプ

setDay

public void setDay(int day)
日を設定します。

設定できる値は、1から31までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

パラメータ:
day - 日

setDayWeek

public void setDayWeek(int dayWeek)
曜日を設定します。

設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

設定した曜日(日)を特定したい場合は、第ｎ～曜日の設定( getTimes())
または第ｎ週の設定( getWeek())と共に設定が可能です。
第ｎ～曜日の設定、第ｎ週の設定共に設定を行わなかった場合は、すべての指定曜日の設定となります。

パラメータ:
dayWeek - 曜日

setDescription

public void setDescription(String description)
データの説明を設定します。

パラメータ:
description - データの説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
表示名を設定します。

ロケールに対応する表示名を設定します。

パラメータ:
locale - ロケール
displayName - 表示名

setMonth

public void setMonth(int month)
月を設定します。

設定できる値は、1から12までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

パラメータ:
month - 月

setPlugin

public void setPlugin(String plugin)
プラグインIDを設定します。

この設定を無効にするにはnullまたは空文字列を設定します。

パラメータ:
plugin - プラグインID

setTimes

public void setTimes(int times)
第ｎ～曜日を設定します。

設定できる値は、1から5までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定( setDayWeek(int)) と共に設定すると、日を特定できます。

パラメータ:
times - 第ｎ～曜日

setValidEndYear

public void setValidEndYear(int validEndYear)
有効終了年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
validEndYear - 有効終了年

setValidStartYear

public void setValidStartYear(int validStartYear)
有効開始年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
validStartYear - 有効開始年

setWeek

public void setWeek(int week)
第ｎ週目を設定します。

設定できる値は、1から6までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定( setDayWeek(int)) と共に設定すると、日が特定できます。

パラメータ:
week - 週

setYear

public void setYear(int year)
年を設定します。

この設定を無効にするには-1を設定します。

パラメータ:
year - 年

getPriority

public int getPriority()
優先度を取得します。

戻り値:
優先度
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CalendarManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarManager
public class CalendarManager
extends Object

カレンダーマネージャクラス

カレンダー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarInfo

コンストラクタの概要
CalendarManager(String groupId)
コンストラクタ。
メソッドの概要
void | addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
static void | clearInstance() カレンダーマネージャのインスタンスを初期化します。
void | deleteCalendar(String calendarId) カレンダーを削除します。
void | deleteCalendarInfo(String calendarId, String dataId) カレンダーデータを削除します。
void | deleteCalendarInfos(String calendarId) すべてのカレンダーデータを削除します。
void | deleteCalendars() すべてのカレンダーを削除します。
void | exportData(String category, OutputStream outputStream) エクスポートを行います。
String[] | getCalendarIds() すべてのカレンダーIDを取得します。
CalendarInfo | getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
String[] | getCalendarInfoIds(String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CategorizedCalendarInfo | getCategorizedCalendarInfos(String calendarId) すべてのカレンダーデータをデータタイプ別に分類して取得します。
DayInfo | getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
String | getDefaultCalendarId() デフォルトカレンダーIDを取得します。
String[] | getExportCategories() カレンダーエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() カレンダーインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
DayInfo[] | getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
CalendarPlugin | getPlugin(String pluginId) カレンダーデータプラグインを取得します。
String[] | getPluginIds() カレンダーデータプラグインIDの一覧を取得します。
void | importData(String category, InputStream inputStream) インポートを行います。
boolean | isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | isUpdate(String calendarId, Date date) カレンダーデータが指定された日付よりも新しいかチェックします。
boolean | isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。
void | updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarManager

public CalendarManager(String groupId)
                throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
カレンダーマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addCalendarInfo

public void addCalendarInfo(String calendarId,
                            CalendarInfo calendarInfo)
                     throws AccessSecurityException
カレンダーデータを新規に追加します。

パラメータ:
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendar

public void deleteCalendar(String calendarId)
                    throws AccessSecurityException
カレンダーを削除します。

パラメータ:
calendarId - カレンダーID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendarInfo

public void deleteCalendarInfo(String calendarId,
                               String dataId)
                        throws AccessSecurityException
カレンダーデータを削除します。

パラメータ:
calendarId - カレンダーID
dataId - 削除するカレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendarInfos

public void deleteCalendarInfos(String calendarId)
                         throws AccessSecurityException
すべてのカレンダーデータを削除します。

パラメータ:
calendarId - カレンダーID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

deleteCalendars

public void deleteCalendars()
                     throws AccessSecurityException
すべてのカレンダーを削除します。

例外:
AccessSecurityException - 書き込みに失敗した場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
エクスポートを行います。

パラメータ:
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正な場合にスローされます。

getCalendarIds

public String[] getCalendarIds()
                        throws AccessSecurityException
すべてのカレンダーIDを取得します。

戻り値:
カレンダーIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getCalendarInfo

public CalendarInfo getCalendarInfo(String calendarId,
                                    String dataId)
                             throws AccessSecurityException
カレンダーデータを取得します。

パラメータ:
calendarId - カレンダーID
dataId - カレンダーデータID
戻り値:
カレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfoIds

public String[] getCalendarInfoIds(String calendarId)
                            throws AccessSecurityException
すべてのカレンダーデータIDを取得します。

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーデータIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfos

public CalendarInfo[] getCalendarInfos(String calendarId)
                                throws AccessSecurityException
すべてのカレンダーデータを取得します。

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーに属するすべてのカレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正な場合にスローされます。

getCalendarInfosByIds

public CalendarInfo[] getCalendarInfosByIds(String calendarId,
                                            String[] calendarInfoIds)
                                     throws AccessSecurityException
ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。

パラメータ:
calendarId - カレンダーID
calendarInfoIds - カレンダーデータIDの配列
戻り値:
カレンダー情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - カレンダー情報の取得に失敗した場合にスローされます。

getCategorizedCalendarInfos

public CategorizedCalendarInfo getCategorizedCalendarInfos(String calendarId)
                                                    throws AccessSecurityException
すべてのカレンダーデータをデータタイプ別に分類して取得します。

パラメータ:
calendarId - カレンダーID
戻り値:
カレンダーに属するデータタイプ別に分類されたべてのカレンダーデータ
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getDayInfo

public DayInfo getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo,
                          Date date)
                   throws AccessSecurityException
日付情報を取得します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付
戻り値:
カレンダーに属するデータタイプ別に分類されたすべてのカレンダーデータ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getDefaultCalendarId

public String getDefaultCalendarId()
デフォルトカレンダーIDを取得します。

戻り値:
デフォルトカレンダーID

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
カレンダーエクスポート用のカテゴリの一覧を取得します。

戻り値:
カレンダーエクスポート用カテゴリの一覧
例外:
AccessSecurityException - カレンダーエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
カレンダーインポート用のカテゴリの一覧を取得します。

戻り値:
カレンダーインポート用カテゴリの一覧
例外:
AccessSecurityException - カレンダーインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getMonthInfos

public DayInfo[] getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo,
                               int year,
                               int month)
                        throws AccessSecurityException
月情報を取得します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
year - 年
month - 月
戻り値:
カレンダーに属するデータタイプ別に分類されたすべてのカレンダーデータ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getPlugin

public CalendarPlugin getPlugin(String pluginId)
                         throws AccessSecurityException
カレンダーデータプラグインを取得します。

存在しない場合は、nullを返却します。

パラメータ:
pluginId - 取得するカレンダーデータプラグインID
戻り値:
カレンダーデータプラグイン 引数が不正な場合にスローされます。
例外:
AccessSecurityException

getPluginIds

public String[] getPluginIds()
カレンダーデータプラグインIDの一覧を取得します。

戻り値:
カレンダーデータプラグインIDの配列

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
インポートを行います。

パラメータ:
category - カテゴリ名
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正な場合にスローされます。

isHoliday

public boolean isHoliday(String calendarId,
                         CategorizedCalendarInfo categorizedCalendarInfo,
                         Date date)
                  throws AccessSecurityException
休日かどうか判定します。

パラメータ:
calendarId - カレンダーId
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:休日 false:平日
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

isNationalHoliday

public boolean isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo,
                                 Date date)
                          throws AccessSecurityException
祝日かどうか判定します。

パラメータ:
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:祝日 false:祝日以外の日
例外:
AccessSecurityExceptionc - 引数が不正な場合にスローされます。
AccessSecurityException

isWeekday

public boolean isWeekday(String calendarId,
                         CategorizedCalendarInfo categorizedCalendarInfo,
                         Date date)
                  throws AccessSecurityException
平日かどうか判定します。

パラメータ:
calendarId - カレンダーId
categorizedCalendarInfo - カテゴライズカレンダーデータ
date - 日付情報
戻り値:
判定結果 true:平日 false:休日
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

updateCalendarInfo

public void updateCalendarInfo(String calendarId,
                               CalendarInfo calendarInfo)
                        throws AccessSecurityException
カレンダーデータを更新します。

パラメータ:
calendarId - カレンダーID
calendarInfo - カレンダーデータ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正な場合にスローされます。

isUpdate

public boolean isUpdate(String calendarId,
                        Date date)
                 throws AccessSecurityException
カレンダーデータが指定された日付よりも新しいかチェックします。

パラメータ:
calendarId - カレンダーID
date - チェック日付
例外:
AccessSecurityReadException - カレンダー情報取得に失敗した場合スローされます。
AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPlugin (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPlugin

既知の実装クラスの一覧:
CalendarPluginAutumnalEquinox, CalendarPluginEndOfTheMonth, CalendarPluginLastDayInTheMonth, CalendarPluginMondayMakeupHoliday, CalendarPluginVernalEquinox
public interface CalendarPlugin

カレンダデータプラグインインターフェース。

カレンダデータの有効無効を判定するプラグインのインターフェース

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。

メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。

パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginAutumnalEquinox (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginAutumnalEquinox

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginAutumnalEquinox
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
利用方法：設定画面において、休日設定・9 月・22, 23 および 24 日
プラグイン設定で『秋分の日』を選択して利用します。
(２種類の同時設定が必要です)
判定基準：グレゴリオ歴をもとにして天文学の黄道起動計算に基づいて
定義された簡易計算式を用いて決定します。
指定の日付が秋分の日である場合に真値を、秋分の日ではない
場合に偽値を返却します。
注意事項：簡易計算式を用いて計算しているため、このロジックの有効
期間は、1900 年 3 月以降 2099 年までとなります。
(この期間外では、正しい結果を返さないことがあります)
このロジックは計算式による予測値にすぎず、日本の法律で
定められている秋分の日と完全に一致しないことがあります。
日本の祝日として定められた秋分の日の正式な日付は、前年の
2 月 1 日に国立天文台より官報として公示される文書を
参照するようにして下さい。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginAutumnalEquinox()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginAutumnalEquinox

public CalendarPluginAutumnalEquinox()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が秋分の日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginEndOfTheMonth (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginEndOfTheMonth

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginEndOfTheMonth
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインクラスです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『月末』を選択して利用します。
判定基準：日付がその月の最終日である状態を
真値(月末)として判定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginEndOfTheMonth()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginEndOfTheMonth

public CalendarPluginEndOfTheMonth()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が月末かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPluginInfo

public interface CalendarPluginInfo

カレンダーデータプラグイン情報のインターフェース。

カレンダーデータプラグイン情報のインターフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getPluginClass() カレンダーデータプラグインクラス名を取得します。
String | getPluginId() カレンダーデータプラグインIDを取得します。

メソッドの詳細

getPluginClass

public String getPluginClass()
カレンダーデータプラグインクラス名を取得します。

カレンダーデータプラグインクラスのフルパッケージ名を返却します。
CalendarPluginを実装したクラスでなければなりません。

戻り値:
カレンダーデータプラグインクラス名

getPluginId

public String getPluginId()
カレンダーデータプラグインIDを取得します。

戻り値:
カレンダーデータプラグインID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginLastDayInTheMonth (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginLastDayInTheMonth

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginLastDayInTheMonth
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインクラスです。
月内の最終曜日を定義するためのプラグインクラスです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『最終曜日』を選択して利用します。
判定基準：日付がその月の最終曜日である状態を
真値(最終曜日)として判定します。
これにより、月曜日設定と組み合わせた場合、
最終月曜日という設定が可能になります。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginLastDayInTheMonth()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginLastDayInTheMonth

public CalendarPluginLastDayInTheMonth()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が最終曜日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginMondayMakeupHoliday (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginMondayMakeupHoliday

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginMondayMakeupHoliday
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
振替休日を定義するためのプラグインです。
利用方法：設定画面において、休日設定・月曜日・プラグイン設定で
『振替休日』を選択して利用します。
判定基準：前日が休日設定であり、２種類以上の休日設定が重なっている
状態を真値(振替休日)とし１種類の休日設定のみの判定である
状態を偽値(休日ではない)と判定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginMondayMakeupHoliday()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginMondayMakeupHoliday

public CalendarPluginMondayMakeupHoliday()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が振替休日扱いかどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPluginVernalEquinox (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CalendarPluginVernalEquinox

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox
すべての実装インタフェース:
CalendarPlugin
public class CalendarPluginVernalEquinox
extends Object
implements CalendarPlugin

カレンダデータプラグインクラス。

カレンダデータの有効無効を判定するプラグインのクラスです。
利用方法：設定画面において、休日設定・3 月・19, 20, 21 および 22 日
プラグイン設定で『春分の日』を選択して利用します。
(２種類の同時設定が必要です)
判定基準：グレゴリオ歴をもとにして天文学の黄道起動計算に基づいて
定義された簡易計算式を用いて決定します。
指定の日付が春分の日である場合に真値を、春分の日ではない
場合に偽値を返却します。
注意事項：簡易計算式を用いて計算しているため、このロジックの有効
期間は、1960 年 3 月以降 2099 年までとなります。
(この期間外では、正しい結果を返さないことがあります)
このロジックは計算式による予測値にすぎず、日本の法律で
定められている春分の日と完全に一致しないことがあります。
日本の祝日として定められた春分の日の正式な日付は、前年の
2 月 1 日に国立天文台より官報として公示される文書を
参照するようにして下さい。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
CalendarPluginVernalEquinox()
メソッドの概要
 boolean validate(CalendarManager calendarManager, CategorizedCalendarInfo categorizedCalendarInfo, CalendarInfo calendarInfo, Date date)
カレンダーデータが有効かどうか検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CalendarPluginVernalEquinox

public CalendarPluginVernalEquinox()
メソッドの詳細

validate

public boolean validate(CalendarManager calendarManager,
                        CategorizedCalendarInfo categorizedCalendarInfo,
                        CalendarInfo calendarInfo,
                        Date date)
カレンダーデータが有効かどうか検証します。

指定した日付に対して、カレンダーデータが有効かどうか検証します。
指定日付が春分の日かどうかをチェックします。

定義:
インタフェース CalendarPlugin 内の validate
パラメータ:
categorizedCalendarInfo - 対象カレンダーのカテゴライズされたカレンダーデータ
calendarInfo - 対象カレンダーデータ
date - 対象の日付
戻り値:
対象のカレンダーデータが有効な場合は、trueを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarPostWriterListener

public interface CalendarPostWriterListener

カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager

メソッドの概要
void | init(Map params) カレンダーリスナーの初期化。
void | postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | postDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除した直後にコールされます。
void | postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
カレンダーリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateCalendarInfo

public void postCreateCalendarInfo(String groupId,
                                   String calendarId,
                                   CalendarInfo calendarInfo)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 作成されたカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteCalendarInfo

public void postDeleteCalendarInfo(String groupId,
                                   String calendarId,
                                   String dataId)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - 削除されたカレンダーデータID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateCalendarInfo

public void postUpdateCalendarInfo(String groupId,
                                   String calendarId,
                                   CalendarInfo calendarInfo)
                            throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 更新されたカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarQueryWriterListener

public interface CalendarQueryWriterListener

カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
CalendarManager

メソッドの概要
void | init(Map params) カレンダーリスナーの初期化。
void | queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | queryDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除する直前にコールされます。
void | queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
カレンダーリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateCalendarInfo

public void queryCreateCalendarInfo(String groupId,
                                    String calendarId,
                                    CalendarInfo calendarInfo)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 作成されるカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteCalendarInfo

public void queryDeleteCalendarInfo(String groupId,
                                    String calendarId,
                                    String dataId)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
dataId - 削除されるカレンダーデータID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateCalendarInfo

public void queryUpdateCalendarInfo(String groupId,
                                    String calendarId,
                                    CalendarInfo calendarInfo)
                             throws AccessSecurityListenerExcpetion
カレンダーデータをデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 更新されるカレンダーデータ
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CalendarReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース CalendarReaderDecorator

public interface CalendarReaderDecorator

アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
CalendarInfo | doDecoration(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアからの読み込み直後にコールされます。
void | init(Map params) カレンダーデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
カレンダーデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public CalendarInfo doDecoration(String groupId,
                                 String calendarId,
                                 CalendarInfo calendarInfo)
カレンダーデータをデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
calendarId - カレンダーID
calendarInfo - 読み込みが行われたカレンダーデータ
戻り値:
拡張されたカレンダーデータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CategorizedCalendarInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス CategorizedCalendarInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
public class CategorizedCalendarInfo
extends Object

カテゴライズカレンダーデータクラス。

データタイプで分類されたされたカレンダーデータの情報を保持するクラス。

分類されるデータタイプの種類は、以下の通りです。

  • 名称（ CalendarInfo.TYPE_CONFIG） getConfigDayInfos()
  • 休日（ CalendarInfo.TYPE_HOLIDAY） getHodildayInfos()
  • 非休日（ CalendarInfo.TYPE_WEEKDAY） getWeekdayInfos()
  • 祝祭日（ CalendarInfo.TYPE_NATIONAL_HOLDAY） getNationalHodildayInfos()

    • 導入されたバージョン:
    5.0
    バージョン:
    1.0

    コンストラクタの概要
    protected CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
    コンストラクタ。
    メソッドの概要
CalendarInfo[] | getConfigDayInfos() データタイプが名称であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getHodildayInfos() データタイプが休日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getNationalHodildayInfos() データタイプが祝祭日であるカレンダーデータの一覧を取得します。
CalendarInfo[] | getWeekdayInfos() データタイプが非休日であるカレンダーデータの一覧を取得します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    コンストラクタの詳細

    CategorizedCalendarInfo

    protected CategorizedCalendarInfo(CalendarInfo[] calendarInfos)
    コンストラクタ。

    パラメータ:
    calendarInfos - カレンダデータの配列
    メソッドの詳細

    getConfigDayInfos

    public CalendarInfo[] getConfigDayInfos()
    データタイプが名称であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが名称であるカレンダーデータの配列

    getHodildayInfos

    public CalendarInfo[] getHodildayInfos()
    データタイプが休日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが休日であるカレンダーデータの配列

    getNationalHodildayInfos

    public CalendarInfo[] getNationalHodildayInfos()
    データタイプが祝祭日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが祝祭日であるカレンダーデータの配列

    getWeekdayInfos

    public CalendarInfo[] getWeekdayInfos()
    データタイプが非休日であるカレンダーデータの一覧を取得します。

    戻り値:
    データタイプが非休日であるカレンダーデータの配列
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart(R)
    5.0
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DayInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
インタフェース DayInfo

public interface DayInfo

日付に対するカレンダーデータ情報の取得インターフェース。

日付に対するカレンダーデータの情報にアクセスするインターフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
CalendarInfo[] | getCalendarInfo() マッチしたカレンダーデータの一覧を取得します。
String | getColor() 背景色を取得します。
Date | getDate() 対象の日付を取得します。
int | getMatchCount() 名称設定以外でマッチしたカレンダーデータの数を取得します。
boolean | isHoliday() 休日設定にマッチしているかどうかを取得します。
boolean | isNationalHoliday() 祝祭日設定にマッチしているかどうかを取得します。。
boolean | isWeekday() 非休日設定にマッチしているかどうかを取得します。

メソッドの詳細

getColor

public String getColor()
背景色を取得します。

戻り値:
背景色

getDate

public Date getDate()
対象の日付を取得します。

戻り値:
date

getCalendarInfo

public CalendarInfo[] getCalendarInfo()
マッチしたカレンダーデータの一覧を取得します。

戻り値:
マッチしたカレンダーデータの配列

isHoliday

public boolean isHoliday()
休日設定にマッチしているかどうかを取得します。

戻り値:
休日設定にマッチしている場合はtrue

isNationalHoliday

public boolean isNationalHoliday()
祝祭日設定にマッチしているかどうかを取得します。。

戻り値:
祝祭日設定にマッチしている場合はtrue

isWeekday

public boolean isWeekday()
非休日設定にマッチしているかどうかを取得します。

戻り値:
非休日設定にマッチしている場合はtrue

getMatchCount

public int getMatchCount()
名称設定以外でマッチしたカレンダーデータの数を取得します。

戻り値:
名称設定以外でマッチしたカレンダーデータの数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.calendar (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.calendar
インタフェース
CalendarAccessor
CalendarExporter
CalendarImporter
CalendarPlugin
CalendarPluginInfo
CalendarPostWriterListener
CalendarQueryWriterListener
CalendarReaderDecorator
DayInfo
クラス
CalendarInfo
CalendarManager
CalendarPluginAutumnalEquinox
CalendarPluginEndOfTheMonth
CalendarPluginLastDayInTheMonth
CalendarPluginMondayMakeupHoliday
CalendarPluginVernalEquinox
CategorizedCalendarInfo
StandardCalendarBackup


jp.co.intra_mart.foundation.security.calendar (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.calendar

カレンダーに関連するクラスを提供します。

参照:
説明

インタフェースの概要
CalendarAccessor | カレンダーアクセッサインタフェース。
CalendarExporter | カレンダーバックアップインタフェースです。
CalendarImporter | カレンダーバックアップインタフェースです。
CalendarPlugin | カレンダデータプラグインインターフェース。
CalendarPluginInfo | カレンダーデータプラグイン情報のインターフェース。
CalendarPostWriterListener | カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
CalendarQueryWriterListener | カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
CalendarReaderDecorator | アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
DayInfo | 日付に対するカレンダーデータ情報の取得インターフェース。

クラスの概要
CalendarInfo | カレンダーデータ・モデルクラス
CalendarManager | カレンダーマネージャクラス カレンダー情報の操作を行います。
CalendarPluginAutumnalEquinox | カレンダデータプラグインクラス。
CalendarPluginEndOfTheMonth | カレンダデータプラグインクラス。
CalendarPluginLastDayInTheMonth | カレンダデータプラグインクラス。
CalendarPluginMondayMakeupHoliday | カレンダデータプラグインクラス。
CalendarPluginVernalEquinox | カレンダデータプラグインクラス。
CategorizedCalendarInfo | カテゴライズカレンダーデータクラス。
StandardCalendarBackup | カレンダーバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.calendar の説明

カレンダーに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.calendar クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.calendar の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.calendar.CalendarInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
    • class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup (implements jp.co.intra_mart.foundation.security.calendar.CalendarExporter, jp.co.intra_mart.foundation.security.calendar.CalendarImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator
  • interface jp.co.intra_mart.foundation.security.calendar.DayInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.calendar の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.calendar の使用

jp.co.intra_mart.foundation.security.calendar を使用しているパッケージ
jp.co.intra_mart.foundation.security.calendar カレンダーに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.calendar により使用される jp.co.intra_mart.foundation.security.calendar のクラス
CalendarExporter
カレンダーバックアップインタフェースです。
CalendarImporter
カレンダーバックアップインタフェースです。
CalendarInfo
カレンダーデータ・モデルクラス
CalendarManager
カレンダーマネージャクラス

カレンダー情報の操作を行います。
CalendarPlugin
カレンダデータプラグインインターフェース。
CategorizedCalendarInfo
カテゴライズカレンダーデータクラス。
DayInfo
日付に対するカレンダーデータ情報の取得インターフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StandardCalendarBackup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.calendar
クラス StandardCalendarBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup
すべての実装インタフェース:
CalendarExporter, CalendarImporter
public class StandardCalendarBackup
extends Object
implements CalendarImporter, CalendarExporter

カレンダーバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardCalendarBackup()
メソッドの概要
void | doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | init(Map params) カレンダーバックアップの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCalendarBackup

public StandardCalendarBackup()
メソッドの詳細

init

public void init(Map params)
カレンダーバックアップの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース CalendarImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     CalendarManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリームからカレンダーと
付随するカレンダーデータを取得し、生成します。

定義:
インタフェース CalendarImporter 内の doImport
パラメータ:
manager - カレンダーマネージャクラス
inputStream - 入力ストリーム
戻り値:
バッチモデルクラスの配列
例外:
AccessSecurityImportException

doExport

public void doExport(CalendarManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

カレンダーとカレンダーデータを
バックアップファイルに出力します。

定義:
インタフェース CalendarExporter 内の doExport
パラメータ:
manager - カレンダーマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.certification.ErrorPageProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.ErrorPageProvider の使用

ErrorPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での ErrorPageProvider の使用

ErrorPageProvider を実装している jp.co.intra_mart.foundation.security.certification のクラス
 class StandardErrorPageProvider
標準のエラーページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.LDAPUserCertification の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.LDAPUserCertification の使用

jp.co.intra_mart.foundation.security.certification.LDAPUserCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.LoginInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.LoginInfo の使用

LoginInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LoginInfo の使用

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
 int AccessSecurityManager.getLicense(LoginInfo loginInfo)
アカウントライセンスチェックを行います。

jp.co.intra_mart.foundation.security.certification での LoginInfo の使用

jp.co.intra_mart.foundation.security.certification での LoginInfo のサブインタフェース
 interface LoginRequestInfo
intra-martログイン情報操作インタフェース。

LoginInfo を返す jp.co.intra_mart.foundation.security.certification のメソッド
LoginInfo | StandardRequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | SSORequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | RequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

LoginInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
int | UserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
int | SuperUserNoCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
int | SuperCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
int | StandardUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
int | StandardSuperUserCertification.certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
int | LDAPUserCertification.certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.LoginRequestInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.LoginRequestInfo の使用

LoginRequestInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LoginRequestInfo の使用

LoginRequestInfo を返す jp.co.intra_mart.foundation.security のメソッド
 LoginRequestInfo AccessSecurityManager.createLoginRequestInfo(String loginType)
ログイン情報を作成します。

LoginRequestInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。

jp.co.intra_mart.foundation.security.certification での LoginRequestInfo の使用

LoginRequestInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
LoginInfo | StandardRequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | SSORequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
LoginInfo | RequestAnalyzer.parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.RequestAnalyzer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.RequestAnalyzer の使用

RequestAnalyzer を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での RequestAnalyzer の使用

RequestAnalyzer を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | SSORequestAnalyzer SSOのログインリクエスト解析クラス。
class | StandardRequestAnalyzer 標準のログインリクエスト解析クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の使用

jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer の使用

StandardRequestAnalyzer を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での StandardRequestAnalyzer の使用

jp.co.intra_mart.foundation.security.certification での StandardRequestAnalyzer のサブクラス
 class SSORequestAnalyzer
SSOのログインリクエスト解析クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification の使用

jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardUserCertification の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardUserCertification の使用

StandardUserCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での StandardUserCertification の使用

jp.co.intra_mart.foundation.security.certification での StandardUserCertification のサブクラス
 class LDAPUserCertification
ユーザログインLDAP認証クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider の使用

jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.SuperCertification の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.SuperCertification の使用

SuperCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での SuperCertification の使用

SuperCertification を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | StandardSuperUserCertification 管理者ログイン認証の実装クラス。
class | SuperUserNoCertification システム管理者ログイン時に強制認証を行う実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification の使用

jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.UserCertification の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.UserCertification の使用

UserCertification を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での UserCertification の使用

UserCertification を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | LDAPUserCertification ユーザログインLDAP認証クラス。
class | StandardUserCertification ユーザログイン認証クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.certification.UserPageProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.certification.UserPageProvider の使用

UserPageProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security.certification 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.certification での UserPageProvider の使用

UserPageProvider を実装している jp.co.intra_mart.foundation.security.certification のクラス
class | StandardGroupSuperUserPageProvider 標準のログイングループ管理者用ページプロバイダクラス。
class | StandardSuperUserPageProvider 標準のシステム管理者用のユーザページプロバイダクラス。
class | StandardUserPageProvider 標準のユーザページプロバイダクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ErrorPageProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース ErrorPageProvider

既知の実装クラスの一覧:
StandardErrorPageProvider
public interface ErrorPageProvider

エラーページプロバイダインタフェース。

ユーザ用の各種エラーページを取得するためのインタフェース
エラーページプロバイダを実装する場合は必ずこのインタフェースを実装します。
アクセスセキュリティAPIはこのインタフェースを通じて必要なエラーページを取得します。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml

 <access-security>
   <security-config>
     <error-page-provider>
       <page-provider-class>エラーページプロバイダインタフェース実装クラス名（フルパッケージ名）</page-provider-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </error-page-provider>
   </security-config>
 </access-security>
<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得する。
String | getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得する。
String | getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得する。
String | getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得する。
String | getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | getSessionTimeoutErrorPage(HttpServletRequest request, HttpServletResponse response) セッションタイムアウトエラーページURLを取得する。
String | getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

getCertificationErrorPage

public String getCertificationErrorPage(SessionInfo sessionInfo,
                                        HttpServletRequest request,
                                        HttpServletResponse response)
認証失敗エラーページURLを取得する。

認証に失敗した場合( SecurityConstraint.CR_NG)に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証失敗エラーページURL

getLockedErrorPage

public String getLockedErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
ユーザロックエラーページURLを取得する。

各ログインタイプ別のページプロバイダからユーザロックエラーページが取得できなかった場合に利用される。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ユーザロックエラーページURL

getLicenceErrorPage

public String getLicenceErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
ライセンスエラーページURLを取得する。

認証するユーザにライセンスがないか、または有効期間内でない場合( SecurityConstraint.CR_NO_LICENSE )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ライセンスエラーページURL

getGroupErrorPage

public String getGroupErrorPage(SessionInfo sessionInfo,
                                HttpServletRequest request,
                                HttpServletResponse response)
ログイングループエラーページURLを取得する。

認証するログイングループが存在しない場合( SecurityConstraint.CR_NO_GROUP )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログイングループエラーページURL

getSessionErrorPage

public String getSessionErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
セッションエラーページURLを取得する。

セッション情報に不整合が出た場合( SecurityConstraint.CR_SESSION_UNMATCH )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションエラーページURL

getSessionTimeoutErrorPage

public String getSessionTimeoutErrorPage(HttpServletRequest request,
                                         HttpServletResponse response)
セッションタイムアウトエラーページURLを取得する。

セッションがタイムアウトになった場合( SecurityConstraint.CR_SESSION_TIMEOUT )に表示するページを取得する。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションタイムアウトエラーページURL

getNoPermissionErrorPage

public String getNoPermissionErrorPage(SessionInfo sessionInfo,
                                       HttpServletRequest request,
                                       HttpServletResponse response)
無許可アクセスエラーページURLを取得する。

無許可のURLにアクセスした場合( SecurityConstraint.CR_NO_PERMISSION )に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
無許可アクセスエラーページURL

getSystemErrorPage

public String getSystemErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
認証処理エラーページURLを取得する。

認証処理中にエラーが発生した場合( SecurityConstraint.CR_ERROR)に表示するページを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証処理エラーページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LDAPUserCertification (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス LDAPUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserCertification
        拡張 jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
すべての実装インタフェース:
UserCertification
public class LDAPUserCertification
extends StandardUserCertification

ユーザログインLDAP認証クラス。

一般ユーザのLDAPログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。
ログイングループごとに3つのパラメータが必要です。

パラメータ名 | 説明
ログイングループID.provider-url | プロバイダURLを設定します。(Ex : ldap://localhost:389/)
ログイングループID.dn | 識別情報を設定します。（Ex : uid=?,ou=People, o=ldaps.intra-mart.jp）
ログイングループID.context-factory | コンテキストファクトリを設定します。（Ex : com.sun.jndi.ldap.LdapCtxFactory）

ログイングループID.dn に設定する'?'の部分をユーザIDに置換して、認証を行います。
このdnの記述方法は、LDAPサーバによって異なります。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
LDAPUserCertification()
メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
void | init(Map params) ユーザログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LDAPUserCertification

public LDAPUserCertification()
メソッドの詳細

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証する。

定義:
インタフェース UserCertification 内の certification
オーバーライド:
クラス StandardUserCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserCertification 内の init
オーバーライド:
クラス StandardUserCertification 内の init
パラメータ:
params - 初期化パラメータのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LoginInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース LoginInfo

すべてのスーパーインタフェース:
LocaleProvider
既知のサブインタフェースの一覧:
LoginRequestInfo
public interface LoginInfo
extends LocaleProvider

intra-martログイン情報操作インタフェース。

intra-martログイン情報を操作するためのインタフェース
intra-martログイン情報を操作する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getEncoding() エンコーディングを取得する。
String | getInitialUrl() 初期アクセスURLを取得する。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
String | getLoginType() ログインタイプを取得する。
String | getPassword() ログインパスワードを取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

戻り値:
クライアントタイプ

getEncoding

public String getEncoding()
エンコーディングを取得する。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ロケールを取得する。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。

戻り値:
ログイングループID

getLoginType

public String getLoginType()
ログインタイプを取得する。

戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getPassword

public String getPassword()
ログインパスワードを取得する。

戻り値:
パスワード

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。

戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。

戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。

戻り値:
ログインユーザID

getInitialUrl

public String getInitialUrl()
初期アクセスURLを取得する。

戻り値:
初期アクセスURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginRequestInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース LoginRequestInfo

すべてのスーパーインタフェース:
LocaleProvider, LoginInfo
public interface LoginRequestInfo
extends LoginInfo

intra-martログイン情報操作インタフェース。

intra-martログイン情報を操作するためのインタフェース
intra-martログイン情報を操作する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
String | getLoginType() ログインタイプを取得する。
String | getPassword() ログインパスワードを取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。
void | setClientType(String clientType) クライアントタイプを設定する。
void | setEncoding(String encoding) ログインエンコーディングを設定する。
void | setInitialUrl(String url) 初期アクセスURLを設定する。
void | setLocale(Locale locale) ログインロケールを設定する。
void | setLoginGroup(String groupId) ログイングループIDを設定する。
void | setPassword(String password) ログインパスワードを設定する。
void | setUrl(String url) ダイレクトＵＲＬを設定する。
void | setUrlSignature(String signature) ダイレクトＵＲＬ署名を設定する。
void | setUser(String user) ログインユーザIDを設定する。
インタフェース jp.co.intra_mart.foundation.security.certification.LoginInfo から継承したメソッド
getInitialUrl

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

定義:
インタフェース LoginInfo 内の getClientType
戻り値:
クライアントタイプ

getEncoding

public String getEncoding()
エンコーディングを取得する。

定義:
インタフェース LoginInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ロケールを取得する。

定義:
インタフェース LoginInfo 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。

定義:
インタフェース LoginInfo 内の getLoginGroup
戻り値:
ログイングループID

getLoginType

public String getLoginType()
ログインタイプを取得する。

定義:
インタフェース LoginInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getPassword

public String getPassword()
ログインパスワードを取得する。

定義:
インタフェース LoginInfo 内の getPassword
戻り値:
パスワード

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。

定義:
インタフェース LoginInfo 内の getUrl
戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。

定義:
インタフェース LoginInfo 内の getUrlSignature
戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。

定義:
インタフェース LoginInfo 内の getUser
戻り値:
ログインユーザID

setClientType

public void setClientType(String clientType)
クライアントタイプを設定する。

パラメータ:
clientType - クライアントタイプ

setEncoding

public void setEncoding(String encoding)
ログインエンコーディングを設定する。

パラメータ:
encoding - ログインエンコーディング

setLocale

public void setLocale(Locale locale)
ログインロケールを設定する。

導入されたバージョン:
5.0

setLoginGroup

public void setLoginGroup(String groupId)
ログイングループIDを設定する。

パラメータ:
groupId - ログイングループID

setPassword

public void setPassword(String password)
ログインパスワードを設定する。

パラメータ:
password - パスワード

setUrl

public void setUrl(String url)
ダイレクトＵＲＬを設定する。

パラメータ:
url - ダイレクトＵＲＬ

setUrlSignature

public void setUrlSignature(String signature)
ダイレクトＵＲＬ署名を設定する。

パラメータ:
signature - ダイレクトＵＲＬ署名

setUser

public void setUser(String user)
ログインユーザIDを設定する。

パラメータ:
user - ログインユーザID

setInitialUrl

public void setInitialUrl(String url)
初期アクセスURLを設定する。

戻り値:
初期アクセスURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.certification (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.certification
インタフェース
ErrorPageProvider
LoginInfo
LoginRequestInfo
RequestAnalyzer
SuperCertification
UserCertification
UserPageProvider
クラス
LDAPUserCertification
SSORequestAnalyzer
StandardErrorPageProvider
StandardGroupSuperUserPageProvider
StandardRequestAnalyzer
StandardSuperUserCertification
StandardSuperUserPageProvider
StandardUserCertification
StandardUserPageProvider
SuperUserNoCertification


jp.co.intra_mart.foundation.security.certification (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification

認証に関連するクラスを提供します。

参照:
説明

インタフェースの概要
ErrorPageProvider | エラーページプロバイダインタフェース。
LoginInfo | intra-martログイン情報操作インタフェース。
LoginRequestInfo | intra-martログイン情報操作インタフェース。
RequestAnalyzer | リクエストアナライザインタフェース。
SuperCertification | 管理者ログイン認証インタフェース。
UserCertification | ユーザログイン認証インタフェース。
UserPageProvider | ユーザページプロバイダインタフェース。

クラスの概要
LDAPUserCertification | ユーザログインLDAP認証クラス。
SSORequestAnalyzer | SSOのログインリクエスト解析クラス。
StandardErrorPageProvider | 標準のエラーページプロバイダクラス。
StandardGroupSuperUserPageProvider | 標準のログイングループ管理者用ページプロバイダクラス。
StandardRequestAnalyzer | 標準のログインリクエスト解析クラス。
StandardSuperUserCertification | 管理者ログイン認証の実装クラス。
StandardSuperUserPageProvider | 標準のシステム管理者用のユーザページプロバイダクラス。
StandardUserCertification | ユーザログイン認証クラス。
StandardUserPageProvider | 標準のユーザページプロバイダクラス。
SuperUserNoCertification | システム管理者ログイン時に強制認証を行う実装クラスです。

パッケージ jp.co.intra_mart.foundation.security.certification の説明

認証に関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.certification クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.certification の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider (implements jp.co.intra_mart.foundation.security.certification.ErrorPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer (implements jp.co.intra_mart.foundation.security.certification.RequestAnalyzer)
      • class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.certification.LoginInfo
      • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
  • interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertification
  • interface jp.co.intra_mart.foundation.security.certification.UserCertification
  • interface jp.co.intra_mart.foundation.security.certification.UserPageProvider
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.certification の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.certification の使用

jp.co.intra_mart.foundation.security.certification を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.certification のクラス
LoginInfo
intra-martログイン情報操作インタフェース。
LoginRequestInfo
intra-martログイン情報操作インタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security.certification のクラス
ErrorPageProvider
エラーページプロバイダインタフェース。
LoginInfo
intra-martログイン情報操作インタフェース。
LoginRequestInfo
intra-martログイン情報操作インタフェース。
RequestAnalyzer
リクエストアナライザインタフェース。
StandardRequestAnalyzer
標準のログインリクエスト解析クラス。
StandardUserCertification
ユーザログイン認証クラス。
SuperCertification
管理者ログイン認証インタフェース。
UserCertification
ユーザログイン認証インタフェース。
UserPageProvider
ユーザページプロバイダインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RequestAnalyzer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース RequestAnalyzer

既知の実装クラスの一覧:
StandardRequestAnalyzer
public interface RequestAnalyzer

リクエストアナライザインタフェース。

サーブレットリクエストからログインに必要な情報を取得して返却するするインタフェース。
アクセスセキュリティAPIはこのインタフェースを通じて必要なログイン情報を取得します。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security>,<user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。
<user-security>は、一般ユーザに対する設定です。

     <initial-request-analyzer>
       <request-analyzer-class>クエストアナライザインタフェース実装クラス名（フルパッケージ名）</request-analyzer-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </initial-request-analyzer>
     <login-request-analyzer>
       <request-analyzer-class>クエストアナライザインタフェース実装クラス名（フルパッケージ名）</request-analyzer-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </login-request-analyzer>
<initial-request-analyzer>タグには、ログイン画面表示前のリクエストを解析するクエストアナライザインタフェース実装クラスを設定します。

<login-request-analyzer>タグには、ログイン画面からのリクエストを解析するクエストアナライザインタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getLoginGroupParameterName() ログイングループＩＤリクエストパラメータ名を取得する。
String | getUrlParameterName() ダイレクトＵＲＬリクエストパラメータ名を取得する。
String | getUrlSignParameterName() ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
String | getUserParameterName() ユーザＩＤリクエストパラメータ名を取得する。
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。

メソッドの詳細

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報

getLoginGroupParameterName

public String getLoginGroupParameterName()
ログイングループＩＤリクエストパラメータ名を取得する。

戻り値:
ログイングループＩＤリクエストパラメータ名

getUserParameterName

public String getUserParameterName()
ユーザＩＤリクエストパラメータ名を取得する。

戻り値:
ユーザＩＤリクエストパラメータ名

getUrlParameterName

public String getUrlParameterName()
ダイレクトＵＲＬリクエストパラメータ名を取得する。

戻り値:
ダイレクトＵＲＬリクエストパラメータ名

getUrlSignParameterName

public String getUrlSignParameterName()
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。

戻り値:
ダイレクトＵＲＬ署名リクエストパラメータ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SSORequestAnalyzer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス SSORequestAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer
        拡張 jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
すべての実装インタフェース:
RequestAnalyzer
public class SSORequestAnalyzer
extends StandardRequestAnalyzer

SSOのログインリクエスト解析クラス。

im-SecureSignOnと連動するSSOログインリクエスト解析クラスです。

各リクエストパラメータから情報を取得してLoginInfoに設定します。
各リクエストパラメータから情報が取得されなかったものはLoginInfoに設定しません。
解析では、im-SecureSignOnののクッキー情報からログイングループ、ユーザ情報を取得します。

ログアウト時に特定のURLへのリクエストを行う場合は初期化パラメータで設定します。

パラメータ名 | 説明
sso-logout-url | ログアウト時にリクエストを行うURLを設定します。(Ex : http://server:8080/sso/logout.do)

設定方法：
このクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml

   <user-security>
     <initial-request-analyzer>
       <request-analyzer-class>jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer</request-analyzer-class>
       <init-param>
         <param-name>sso-logout-url</param-name>
         <param-value>http://server:8080/sso/logout.do</param-value>
       </init-param>
     </initial-request-analyzer>
     .....
     <auto-certification>
       <certification-class>jp.co.intra_mart.foundation.security.certification.StandardUserCertification</certification-class>
       <init-param>
         <param-name>mobile-client-type</param-name>
         <param-value>mobile</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>jp.co.intra_mart.foundation.security.certification.StandardUserCertification</certification-class>
       <init-param>
       <param-name>mobile-client-type</param-name>
       <param-value>mobile</param-value>
     </init-param>
   </user-security>

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | DEFAULT_AUTH_COOKIE_NAME
static String | DEFAULT_LOGIN_KEY
static String | KEY_AUTH_COOKIE_NAME
static String | KEY_LOGIN_KEY
static String | SSO_LOGOUT_URL
コンストラクタの概要
SSORequestAnalyzer()
メソッドの概要
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
クラス jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer から継承したメソッド
getLoginGroupParameterName, getUrlParameterName, getUrlSignParameterName, getUserParameterName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_LOGIN_KEY

public static final String KEY_LOGIN_KEY
関連項目:
定数フィールド値

KEY_AUTH_COOKIE_NAME

public static final String KEY_AUTH_COOKIE_NAME
関連項目:
定数フィールド値

DEFAULT_LOGIN_KEY

public static final String DEFAULT_LOGIN_KEY
関連項目:
定数フィールド値

DEFAULT_AUTH_COOKIE_NAME

public static final String DEFAULT_AUTH_COOKIE_NAME
関連項目:
定数フィールド値

SSO_LOGOUT_URL

public static final String SSO_LOGOUT_URL
関連項目:
定数フィールド値
コンストラクタの詳細

SSORequestAnalyzer

public SSORequestAnalyzer()
メソッドの詳細

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RequestAnalyzer 内の init
オーバーライド:
クラス StandardRequestAnalyzer 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

定義:
インタフェース RequestAnalyzer 内の parseRequest
オーバーライド:
クラス StandardRequestAnalyzer 内の parseRequest
パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardErrorPageProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardErrorPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider
すべての実装インタフェース:
ErrorPageProvider
public class StandardErrorPageProvider
extends Object
implements ErrorPageProvider

標準のエラーページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
certification-error-page | デフォルトの認証失敗画面URLを設定します。
locked-error-page | ユーザがロック状態の場合のデフォルト画面URLを設定します。
license-error-page | ログインライセンスがないの場合のデフォルト画面URLを設定します。
group-error-page | ログイングループが存在しない場合のデフォルト画面URLを設定します。
permission-error-page | 無許可アクセスページにアクセスした場合の画面のURLを設定します。
session-error-page | セッション情報不整合の場合のデフォルト画面URLを設定します。
session-timeout-page | セッションタイムアウトの場合のデフォルト画面URLを設定します。
system-error-page | デフォルトの認証処理失敗時のデフォルト画面URLを設定します。
certification-error-page.クライアントタイプ | クライアントタイプ別に認証失敗画面のURLを設定します。
locked-error-page.クライアントタイプ | クライアントタイプ別にユーザがロック状態の場合の画面URLを設定します。
license-error-page.クライアントタイプ | クライアントタイプ別にログインライセンスがない場合の画面URLを設定します。
group-error-page.クライアントタイプ | クライアントタイプ別にログイングループが存在しない場合の画面URLを設定します。
permission-error-page.クライアントタイプ | クライアントタイプ別に無許可アクセスページにアクセスした場合の画面のURLを設定します。
session-error-page.クライアントタイプ | クライアントタイプ別セッション情報不整合の場合の画面URLを設定します。
session-timeout-page.クライアントタイプ | クライアントタイプ別セッションタイムアウトの場合の画面URLを設定します。
system-error-page.クライアントタイプ | クライアントタイプ別認証処理失敗時の画面URLを設定します。

ページ決定のルール
certification-error-page.クライアントタイプ を例に取った場合
クライアントタイプ（large）の場合は

① certification-error-page.largeのＵＲＬ
② certification-error-pageのＵＲＬ

の順序でＵＲＬを決定します。
なお、設定するURLはコンテキストパスからの相対パスで記述します。
取得されるURLの先頭には、'/'をつけたものを返却します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardErrorPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得します。
String | getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得します。
String | getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得します。
String | getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得します。
String | getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | getSessionTimeoutErrorPage(HttpServletRequest request, HttpServletResponse response) セッションタイムアウトエラーページURLを取得する。
String | getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardErrorPageProvider

public StandardErrorPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース ErrorPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getCertificationErrorPage

public String getCertificationErrorPage(SessionInfo sessionInfo,
                                        HttpServletRequest request,
                                        HttpServletResponse response)
認証失敗エラーページURLを取得します。

認証に失敗した場合( SecurityConstraint.CR_NG)に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getCertificationErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証失敗エラーページURL

getGroupErrorPage

public String getGroupErrorPage(SessionInfo sessionInfo,
                                HttpServletRequest request,
                                HttpServletResponse response)
ログイングループエラーページURLを取得します。

認証するログイングループが存在しない場合( SecurityConstraint.CR_NO_GROUP )に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getGroupErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログイングループエラーページURL

getLicenceErrorPage

public String getLicenceErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
ライセンスエラーページURLを取得します。

認証するユーザにライセンスがないか、または有効期間内でない場合( SecurityConstraint.CR_NO_LICENSE )に表示するページを取得します。

定義:
インタフェース ErrorPageProvider 内の getLicenceErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ライセンスエラーページURL

getLockedErrorPage

public String getLockedErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
ユーザロックエラーページURLを取得します。

各ログインタイプ別のページプロバイダからユーザロックエラーページが取得できなかった場合に利用される。

定義:
インタフェース ErrorPageProvider 内の getLockedErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ユーザロックエラーページURL

getNoPermissionErrorPage

public String getNoPermissionErrorPage(SessionInfo sessionInfo,
                                       HttpServletRequest request,
                                       HttpServletResponse response)
無許可アクセスエラーページURLを取得する。

無許可のURLにアクセスした場合( SecurityConstraint.CR_NO_PERMISSION )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getNoPermissionErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
無許可アクセスエラーページURL

getSessionErrorPage

public String getSessionErrorPage(SessionInfo sessionInfo,
                                  HttpServletRequest request,
                                  HttpServletResponse response)
セッションエラーページURLを取得する。

セッション情報に不整合が出た場合( SecurityConstraint.CR_SESSION_UNMATCH )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSessionErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションエラーページURL

getSessionTimeoutErrorPage

public String getSessionTimeoutErrorPage(HttpServletRequest request,
                                         HttpServletResponse response)
セッションタイムアウトエラーページURLを取得する。

セッションがタイムアウトになった場合( SecurityConstraint.CR_SESSION_TIMEOUT )に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSessionTimeoutErrorPage
パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
セッションタイムアウトエラーページURL

getSystemErrorPage

public String getSystemErrorPage(SessionInfo sessionInfo,
                                 HttpServletRequest request,
                                 HttpServletResponse response)
認証処理エラーページURLを取得する。

認証処理中にエラーが発生した場合( SecurityConstraint.CR_ERROR)に表示するページを取得する。

定義:
インタフェース ErrorPageProvider 内の getSystemErrorPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証処理エラーページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardGroupSuperUserPageProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardGroupSuperUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class StandardGroupSuperUserPageProvider
extends Object
implements UserPageProvider

標準のログイングループ管理者用ページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | 初期画面のURLを設定します。
main-page | メイン画面のURLを設定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardGroupSuperUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardGroupSuperUserPageProvider

public StandardGroupSuperUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardRequestAnalyzer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardRequestAnalyzer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer
すべての実装インタフェース:
RequestAnalyzer
直系の既知のサブクラス:
SSORequestAnalyzer
public class StandardRequestAnalyzer
extends Object
implements RequestAnalyzer

標準のログインリクエスト解析クラス。

各リクエストパラメータから情報を取得してLoginInfoに設定します。
各リクエストパラメータから情報が取得されなかったものはLoginInfoに設定しません。
解析では、デフォルトのリクエストパラメータを使用して各情報を取得します。

初期化パラメータは以下のものを必要とします。
初期化パラメータは、すべて省略可能です。省略した場合は、各デフォルトのリクエストパラメータ名から情報を取得します。

パラメータ名 | 説明 | デフォルト値
login-type | ログインタイプが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOGIN_TYPE
client-type | クライアントタイプが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_CLIENT_TYPE
locale | ロケールが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOCALE
encoding | エンコーディングが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_ENCODING
login-group | ログイングループが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_LOGIN_GROUP
user | ユーザIDが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_USER
passward | パスワードが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_PASSWORD
url | ダイレクトＵＲＬが設定されるパラメータ名を設定します。 | SecurityConstraint.RP_URL
url-sign | ダイレクトＵＲＬ署名が設定されるパラメータ名を設定します。 | SecurityConstraint.RP_URL_SIGN

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardRequestAnalyzer()
デフォルトコンストラクタ。
メソッドの概要
String | getLoginGroupParameterName() ログイングループＩＤリクエストパラメータ名を取得する。
String | getUrlParameterName() ダイレクトＵＲＬリクエストパラメータ名を取得する。
String | getUrlSignParameterName() ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
String | getUserParameterName() ユーザＩＤリクエストパラメータ名を取得する。
void | init(Map params) ログインリクエストアナライザの初期化。
LoginInfo | parseRequest(LoginRequestInfo loginInfo, HttpServletRequest request) リクエストパラメータの解析。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardRequestAnalyzer

public StandardRequestAnalyzer()
デフォルトコンストラクタ。

メソッドの詳細

getLoginGroupParameterName

public String getLoginGroupParameterName()
ログイングループＩＤリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getLoginGroupParameterName
戻り値:
ログイングループＩＤリクエストパラメータ名

getUrlParameterName

public String getUrlParameterName()
ダイレクトＵＲＬリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUrlParameterName
戻り値:
ダイレクトＵＲＬリクエストパラメータ名

getUrlSignParameterName

public String getUrlSignParameterName()
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUrlSignParameterName
戻り値:
ダイレクトＵＲＬ署名リクエストパラメータ名

getUserParameterName

public String getUserParameterName()
ユーザＩＤリクエストパラメータ名を取得する。

定義:
インタフェース RequestAnalyzer 内の getUserParameterName
戻り値:
ユーザＩＤリクエストパラメータ名

init

public void init(Map params)
ログインリクエストアナライザの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RequestAnalyzer 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

parseRequest

public LoginInfo parseRequest(LoginRequestInfo loginInfo,
                              HttpServletRequest request)
リクエストパラメータの解析。

リクエストを解析してログイン情報を返却します。

定義:
インタフェース RequestAnalyzer 内の parseRequest
パラメータ:
loginInfo - ベースとなるログインリクエスト情報
サーブレットリクエスト(request)から取得した情報をこのパラメータ(loginRequestInfo)のプロパティに設定して返却する。
request - HTTPサーブレットリクエスト
戻り値:
ログイン情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardSuperUserCertification (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardSuperUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification
すべての実装インタフェース:
SuperCertification
public class StandardSuperUserCertification
extends Object
implements SuperCertification

管理者ログイン認証の実装クラス。

管理者ログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
address-filter | クライアントのIPアドレスでフィルタリングします。 IPアドレスの正規表現を設定設定します。 必要ない場合は省略可能です。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardSuperUserCertification()
デフォルトコンストラクタ
メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | init(Map params) 管理者ログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardSuperUserCertification

public StandardSuperUserCertification()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース SuperCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証します。

定義:
インタフェース SuperCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardSuperUserPageProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardSuperUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class StandardSuperUserPageProvider
extends Object
implements UserPageProvider

標準のシステム管理者用のユーザページプロバイダクラス。

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | 初期画面のURLを設定します。
main-page | メイン画面のURLを設定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardSuperUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardSuperUserPageProvider

public StandardSuperUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardUserCertification (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardUserCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserCertification
すべての実装インタフェース:
UserCertification
直系の既知のサブクラス:
LDAPUserCertification
public class StandardUserCertification
extends Object
implements UserCertification

ユーザログイン認証クラス。

標準のユーザログイン認証を行うためのクラス

初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
mobile-client-type | モバイルパスワードで認証を行うクライアントタイプを設定します。 (複数設定する場合は、カンマ区切りで設定します。) 例）small,medium

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardUserCertification()
デフォルトコンストラクタ。
メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証します。
void | init(Map params) ユーザログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserCertification

public StandardUserCertification()
デフォルトコンストラクタ。

メソッドの詳細

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証します。

定義:
インタフェース UserCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardUserPageProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス StandardUserPageProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider
すべての実装インタフェース:
UserPageProvider
public class StandardUserPageProvider
extends Object
implements UserPageProvider

標準のユーザページプロバイダクラス。
初期化パラメータは以下のものを必要とします。

パラメータ名 | 説明
initial-page | デフォルトの初期画面のURLを設定します。
initial-page.クライアントタイプ | クライアント別にデフォルトの初期画面のURLを設定します。
initial-page.クライアントタイプ.ログイングループID | ログイングループ別にデフォルトの初期画面のURLを設定します。
main-page | デフォルトのメイン画面のURLを設定します。
main-page.クライアントタイプ | クライアント別にデフォルトのメイン画面のURLを設定します。
main-page.クライアントタイプ.ログイングループID | ログイングループ別にデフォルトのメイン画面のURLを設定します。

ページ決定のルール
main-page.クライアントタイプ.[ログイングループID]を例に取った場合
ユーザがログイングループID（group_01）、クライアントタイプ（large）の場合は

① ユーザに設定されているメインパターンIDのURL
② main-page.large.group_01のURL
③ main-page.largeのURL
④ main-pageのURL

の順序でURLを決定します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardUserPageProvider()
デフォルトコンストラクタ
メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
void | init(Map params) ページプロバイダの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardUserPageProvider

public StandardUserPageProvider()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース UserPageProvider 内の init
パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得します。

初期アクセス時に表示するURLを取得します。

定義:
インタフェース UserPageProvider 内の getInitalPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得します。

ログイン後のメイン画面を表示するURLを取得する。

定義:
インタフェース UserPageProvider 内の getMainPage
パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperCertification (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース SuperCertification

既知の実装クラスの一覧:
StandardSuperUserCertification, SuperUserNoCertification
public interface SuperCertification

管理者ログイン認証インタフェース。

管理者ログイン認証を行うためのインタフェース
管理者ログイン認証を実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じて認証処理を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。

     <auto-certification>
       <certification-class>管理者ログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>管理者ログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification>
<auto-certification>タグには、ログイン画面表示前のリクエストから認証処理を行う管理者ログイン認証インタフェース実装クラスを設定します。
また、このタグは省略可能です。省略した場合は、自動ログインができなくなります。（ログイン画面を出さずにログイン）

<certification>タグには、ログイン画面からのリクエストから認証処理を行う管理者ログイン認証インタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証する。
void | init(Map params) 管理者ログイン認証の初期化を行います。

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証する。

パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
ユーザ不一致 | SecurityConstraint.CR_NO_USER
認証失敗(パスワード不一致) | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SuperUserNoCertification (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
クラス SuperUserNoCertification

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification
すべての実装インタフェース:
SuperCertification
public class SuperUserNoCertification
extends Object
implements SuperCertification

システム管理者ログイン時に強制認証を行う実装クラスです。

このクラスは、システム管理者ログインの認証を必ず成功させるクラスです。

システム管理者のパスワードを忘れた場合などの緊急事態にこのクラスを設定することで、必ずログインできるようになります。
事態を回避できた後は、セキュリティ上、必ず設定を元の状態に戻してください。
サーバ/conf/access-security.xmlのsecurity-configにこのクラスを利用するように設定することでクラスが利用されるようになります。

<security-config>
.....
<super-user-security>
.....
<certification>
<certification-class>jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification</certification-class>
 </certification>
.....
</super-user-security>
.....
</security-config>

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
SuperUserNoCertification()
デフォルトコンストラクタ
メソッドの概要
int | certification(LoginInfo loginInfo, SuperUser user, HttpServletRequest request, HttpServletResponse response) 管理者を認証します。
void | init(Map params) 管理者ログイン認証の初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUserNoCertification

public SuperUserNoCertification()
デフォルトコンストラクタ

メソッドの詳細

init

public void init(Map params)
管理者ログイン認証の初期化を行います。

管理者ログイン認証のインスタンス生成時に一度だけ呼び出されます。

定義:
インタフェース SuperCertification 内の init
パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         SuperUser user,
                         HttpServletRequest request,
                         HttpServletResponse response)
管理者を認証します。

定義:
インタフェース SuperCertification 内の certification
パラメータ:
loginInfo - ログイン情報
user - 管理者情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserCertification (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース UserCertification

既知の実装クラスの一覧:
StandardUserCertification
public interface UserCertification

ユーザログイン認証インタフェース。

ユーザログイン認証を行うためのインタフェース
ユーザログイン認証を実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じて認証処理を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>/<user-security>のタグに記述します。

     <auto-certification>
       <certification-class>ユーザログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </auto-certification>
     <certification>
       <certification-class>ユーザログイン認証インタフェース実装クラス名（フルパッケージ名）</certification-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </certification>
<auto-certification>タグには、ログイン画面表示前のリクエストから認証処理を行ユーザログイン認証インタフェース実装クラスを設定します。
また、このタグは省略可能です。省略した場合は、自動ログインができなくなります。（ログイン画面を出さずにログイン）

<certification>タグには、ログイン画面からのリクエストから認証処理を行うユーザログイン認証インタフェース実装クラスを設定します。

<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
int | certification(LoginInfo loginInfo, Account user, HttpServletRequest request, HttpServletResponse response) ユーザを認証する。
void | init(Map params) ユーザログイン認証の初期化を行います。

メソッドの詳細

init

public void init(Map params)
ユーザログイン認証の初期化を行います。

ユーザログイン認証のインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

certification

public int certification(LoginInfo loginInfo,
                         Account user,
                         HttpServletRequest request,
                         HttpServletResponse response)
ユーザを認証する。

パラメータ:
loginInfo - ログイン情報
user - ユーザ情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
認証結果
認証成功 | SecurityConstraint.CR_OK
認証失敗 | SecurityConstraint.CR_NG
認証処理エラー | SecurityConstraint.CR_ERROR
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserPageProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.certification
インタフェース UserPageProvider

既知の実装クラスの一覧:
StandardGroupSuperUserPageProvider, StandardSuperUserPageProvider, StandardUserPageProvider
public interface UserPageProvider

ユーザページプロバイダインタフェース。

ユーザ用の各種ページを取得するためのインタフェース
ユーザページプロバイダを実装する場合は必ずこのインターフェースを実装する。
アクセスセキュリティAPIはこのインタフェースを通じてログイン画面およびログイン後のメイン画面を行います。

このインターフェースを実装したクラスを以下の設定ファイルに記述します。
サーバーマネージャインストールディレクトリ/conf/access-security.xml
<access-security>/<security-config>以下の<super-user-security>,<group-super-user-security><user-security>の各タグに記述します。

<super-user-security>は、システム管理者に対する設定です。
<group-super-user-security>は、ログイングループ管理者に対する設定です。
<user-security>は、一般ユーザに対する設定です。

     <page-provider>
       <page-provider-class>ユーザページプロバイダ実装クラス名（フルパッケージ名）</page-provider-class>
       <init-param>
         <param-name>初期化パラメータ名</param-name>
         <param-value>初期化パラメータ値</param-value>
       </init-param>
     </page-provider>
<init-param>タグは複数設定可能です。
このタグに設定された値は、クラス初期化時に、init関数の引数として渡されます。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
void | init(Map params) ページプロバイダの初期化を行います。

メソッドの詳細

init

public void init(Map params)
ページプロバイダの初期化を行います。

ページプロバイダのインスタンス生成時に一度だけ呼び出されます。

パラメータ:
params - 初期化パラメータのマップ

getInitalPage

public String getInitalPage(SessionInfo sessionInfo,
                            HttpServletRequest request,
                            HttpServletResponse response)
初期ページURLを取得する。

初期アクセス時に表示するURLを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
メインページURLを取得する。

ログイン後のメイン画面を表示するURLを取得する。

パラメータ:
sessionInfo - セッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
初期ページURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.AccessSecurityManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.AccessSecurityManager の使用

AccessSecurityManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での AccessSecurityManager の使用

AccessSecurityManager を返す jp.co.intra_mart.foundation.security のメソッド
static AccessSecurityManager AccessSecurityManager.getInstance()
セキュリティマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ClientTypeInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ClientTypeInfo の使用

ClientTypeInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ClientTypeInfo の使用

ClientTypeInfo を返す jp.co.intra_mart.foundation.security のメソッド
ClientTypeInfo | SystemManager.getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | SystemManager.getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ColorPatternInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ColorPatternInfo の使用

ColorPatternInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ColorPatternInfo の使用

ColorPatternInfo を返す jp.co.intra_mart.foundation.security のメソッド
ColorPatternInfo | SystemManager.getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | SystemManager.getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.DepartmentInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.DepartmentInfo の使用

DepartmentInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での DepartmentInfo の使用

DepartmentInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
DepartmentInfo[] | MenuManager.getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
DepartmentInfo[] | MenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。

DepartmentInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | MenuManager.deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
String[] | MenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.ExtendsImport の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.ExtendsImport の使用

jp.co.intra_mart.foundation.security.ExtendsImport はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.ExtendsImportManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.ExtendsImportManager の使用

ExtendsImportManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での ExtendsImportManager の使用

ExtendsImportManager を返す jp.co.intra_mart.foundation.security のメソッド
static ExtendsImportManager ExtendsImportManager.getInstance()

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.INonTransaction の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.INonTransaction の使用

jp.co.intra_mart.foundation.security.INonTransaction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.LocaleInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.LocaleInfo の使用

LocaleInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LocaleInfo の使用

LocaleInfo を返す jp.co.intra_mart.foundation.security のメソッド
LocaleInfo | SystemManager.getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | SystemManager.getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.LocaleProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.LocaleProvider の使用

LocaleProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での LocaleProvider の使用

jp.co.intra_mart.foundation.security での LocaleProvider のサブインタフェース
interface | LocaleInfo ロケｰル情報・モデルインタフェース。
interface | SessionInfo intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.account での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.account のクラス
 class Account
アカウントモデル。

jp.co.intra_mart.foundation.security.admin での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.admin のクラス
 class SuperUser
スーパーユーザ・モデルインタフェース。

jp.co.intra_mart.foundation.security.certification での LocaleProvider の使用

jp.co.intra_mart.foundation.security.certification での LocaleProvider のサブインタフェース
interface | LoginInfo intra-martログイン情報操作インタフェース。
interface | LoginRequestInfo intra-martログイン情報操作インタフェース。

jp.co.intra_mart.foundation.security.group での LocaleProvider の使用

LocaleProvider を実装している jp.co.intra_mart.foundation.security.group のクラス
 class LoginGroup
ログイングループ・モデル。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.PostInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.PostInfo の使用

PostInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での PostInfo の使用

PostInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
PostInfo[] | MenuManager.getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PostInfo[] | MenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。

PostInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | MenuManager.deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
String[] | MenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.PublicGroupInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.PublicGroupInfo の使用

PublicGroupInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での PublicGroupInfo の使用

PublicGroupInfo を返す jp.co.intra_mart.foundation.security.menu のメソッド
PublicGroupInfo[] | MenuManager.getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
PublicGroupInfo[] | MenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。

PublicGroupInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | MenuManager.deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
String[] | MenuManager.getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
void | MenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
String[] | MenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
void | MenuAccessor.insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SecurityConstraint の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SecurityConstraint の使用

jp.co.intra_mart.foundation.security.SecurityConstraint はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SessionConfig の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SessionConfig の使用

SessionConfig を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SessionConfig の使用

SessionConfig を返す jp.co.intra_mart.foundation.security のメソッド
 SessionConfig AccessSecurityManager.getSessionConfig()
セッション情報保管パラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SessionInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SessionInfo の使用

SessionInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SessionInfo の使用

SessionInfo を返す jp.co.intra_mart.foundation.security のメソッド
SessionInfo | AccessSecurityManager.getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getCookieSessionInfo(HttpServletRequest request) クッキーからintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
int | AccessSecurityManager.getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。

jp.co.intra_mart.foundation.security.certification での SessionInfo の使用

SessionInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.certification のメソッド
String | UserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | UserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | StandardUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得します。
String | StandardUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
String | StandardSuperUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | StandardSuperUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | StandardGroupSuperUserPageProvider.getInitalPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期ページURLを取得する。
String | StandardGroupSuperUserPageProvider.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得する。
String | StandardErrorPageProvider.getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得します。
String | StandardErrorPageProvider.getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得します。
String | StandardErrorPageProvider.getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得します。
String | StandardErrorPageProvider.getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得します。
String | StandardErrorPageProvider.getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | StandardErrorPageProvider.getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | StandardErrorPageProvider.getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。
String | ErrorPageProvider.getCertificationErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証失敗エラーページURLを取得する。
String | ErrorPageProvider.getLockedErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ユーザロックエラーページURLを取得する。
String | ErrorPageProvider.getLicenceErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ライセンスエラーページURLを取得する。
String | ErrorPageProvider.getGroupErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) ログイングループエラーページURLを取得する。
String | ErrorPageProvider.getSessionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) セッションエラーページURLを取得する。
String | ErrorPageProvider.getNoPermissionErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 無許可アクセスエラーページURLを取得する。
String | ErrorPageProvider.getSystemErrorPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 認証処理エラーページURLを取得する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.SystemManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.SystemManager の使用

SystemManager を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SystemManager の使用

SystemManager を返す jp.co.intra_mart.foundation.security のメソッド
static SystemManager SystemManager.getInstance()
システムマネージャインスタンスを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.SystemSourceProvider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.SystemSourceProvider の使用

SystemSourceProvider を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での SystemSourceProvider の使用

SystemSourceProvider 型のパラメータを持つ jp.co.intra_mart.foundation.security のメソッド
static void SystemManager.setSorucePovider(SystemSourceProvider provider)
ソースプロバイダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.cryption.Cryption の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.cryption.Cryption の使用

Cryption を使用しているパッケージ
jp.co.intra_mart.foundation.security.cryption 暗号化に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.cryption での Cryption の使用

Cryption を実装している jp.co.intra_mart.foundation.security.cryption のクラス
class | NoCryption 暗号化処理を行わない実装クラス。
class | StandardCryption 文字列の暗号化・復号化を行う標準の実装クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.cryption.NoCryption の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.cryption.NoCryption の使用

jp.co.intra_mart.foundation.security.cryption.NoCryption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.cryption.StandardCryption の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.cryption.StandardCryption の使用

jp.co.intra_mart.foundation.security.cryption.StandardCryption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Cryption (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
インタフェース Cryption

既知の実装クラスの一覧:
NoCryption, StandardCryption
public interface Cryption

文字列の暗号化・復号化インタフェース。

文字列の暗号化・復号化を行うインタフェース

jp.co.intra_mart.foundation.security.StandardAccountAccessorを用いている場合は、
サーバ/conf/access-security.xmlのaccess-configにこのクラスを実装したクラスを利用するように設定することでこのクラスが利用されるようになります。

jp.co.intra_mart.foundation.security.StandardAccountAccessorでは、パスワードおよびモバイルパスワードを
このクラスを実装したクラスの暗号化処理を使って暗号化・復号化を行っています。
<access-config>
.....
<account>
<accessor>
<accessor-class>jp.co.intra_mart.foundation.security.StandardAccountAccessor</accessor-class>
<init-param>
<param-name>cryption-class</param-name>
<param-value>jp.co.intra_mart.foundation.security.cryption.Cryptionを実装したクラス</param-value>
</init-param>
 </accessor>
</account>
.....
</access-config>

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String plane)
文字列を暗号化する。

パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NoCryption (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
クラス NoCryption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.cryption.NoCryption
すべての実装インタフェース:
Cryption
public class NoCryption
extends Object
implements Cryption

暗号化処理を行わない実装クラス。

暗号化処理を行わないクラスです。
標準では、アカウントのパスワード、モバイルパスワードを暗号化するためにStandardCryption が利用されますが、
このクラスを用いることにより、データストアに暗号化を行わないで、保管することができます。
サーバ/conf/access-security.xmlのaccess-configにこのクラスを利用するように設定することでこのクラスが利用されるようになります。

<access-config>
.....
<account>
<accessor>
<accessor-class>jp.co.intra_mart.foundation.security.StandardAccountAccessor</accessor-class>
<init-param>
<param-name>cryption-class</param-name>
<param-value>jp.co.intra_mart.foundation.security.cryption.NoCryption</param-value>
</init-param>
 </accessor>
</account>
.....
</access-config>

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
NoCryption()
コンストラクタ。
メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NoCryption

public NoCryption()
コンストラクタ。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

このメソッドでは、引数に渡された値をそのまま返却します。

定義:
インタフェース Cryption 内の decrypt
パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列

encrypt

public String encrypt(String plane)
文字列を暗号化する。

このメソッドでは、引数に渡された値をそのまま返却します。

定義:
インタフェース Cryption 内の encrypt
パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.cryption (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.cryption
インタフェース
Cryption
クラス
NoCryption
StandardCryption


jp.co.intra_mart.foundation.security.cryption (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.cryption

暗号化に関連するクラスを提供します。

参照:
説明

インタフェースの概要
Cryption 文字列の暗号化・復号化インタフェース。

クラスの概要
NoCryption | 暗号化処理を行わない実装クラス。
StandardCryption | 文字列の暗号化・復号化を行う標準の実装クラスです。

パッケージ jp.co.intra_mart.foundation.security.cryption の説明

暗号化に関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.cryption クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.cryption の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.cryption.NoCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.security.cryption.StandardCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.cryption.Cryption
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.cryption の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.cryption の使用

jp.co.intra_mart.foundation.security.cryption を使用しているパッケージ
jp.co.intra_mart.foundation.security.cryption 暗号化に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.cryption により使用される jp.co.intra_mart.foundation.security.cryption のクラス
Cryption
文字列の暗号化・復号化インタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StandardCryption (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.cryption
クラス StandardCryption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.cryption.StandardCryption
すべての実装インタフェース:
Cryption
public class StandardCryption
extends Object
implements Cryption

文字列の暗号化・復号化を行う標準の実装クラスです。

jp.co.intra_mart.foundation.security.StandardAccountAccessorでパスワードとモバイルパスワードを
暗号化して保存、復号化して取得するための標準のクラスとして利用しています。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
StandardCryption()
コンストラクタ。
メソッドの概要
String | decrypt(String secret) 暗号化された文字列を復号するe。
String | encrypt(String plane) 文字列を暗号化する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardCryption

public StandardCryption()
コンストラクタ。

メソッドの詳細

decrypt

public String decrypt(String secret)
暗号化された文字列を復号するe。

定義:
インタフェース Cryption 内の decrypt
パラメータ:
secret - 暗号化された文字列
戻り値:
復号化された文字列 暗号にに失敗した場合はnullを返却します。
関連項目:
Cryption.decrypt(java.lang.String)

encrypt

public String encrypt(String plane)
文字列を暗号化する。

定義:
インタフェース Cryption 内の encrypt
パラメータ:
plane - 暗号化する文字列
戻り値:
暗号化された文字列 暗号化に失敗した場合はnullを返却します。
関連項目:
Cryption.encrypt(java.lang.String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityException の使用

AccessSecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.database での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.database のメソッド
Connection | DatabaseManager.getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | DatabaseManager.getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。

jp.co.intra_mart.foundation.security での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security のメソッド
static void | SystemManager.setSorucePovider(SystemSourceProvider provider) ソースプロバイダを設定します。
void | SystemManager.addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
ClientTypeInfo | SystemManager.getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | SystemManager.getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。
ColorPatternInfo | SystemManager.getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | SystemManager.getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。
String | SystemManager.getDefaultEncoding(Locale reqLocale) ロケールに対応するデフォルトエンコーディングを取得します。
LocaleInfo | SystemManager.getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | SystemManager.getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。
SuperUser | SystemManager.getSuperUser() システム管理者情報を取得します。
void | SystemManager.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。
void | ExtendsImportManager.doImport(String groupId, String module) 拡張インポート処理を実行します。
static AccessSecurityManager | AccessSecurityManager.getInstance() セキュリティマネージャのインスタンスを取得します。
String | AccessSecurityManager.createUrlSignature(String url, String groupId, String userId) ダイレクトＵＲＬ署名を作成します。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
void | AccessSecurityManager.forward(HttpServletRequest request, HttpServletResponse response, String url) 指定したURLにフォワードします。
void | AccessSecurityManager.forward(String url) 指定したURLにフォワードします。
String | AccessSecurityManager.getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
String | AccessSecurityManager.getErrorPage(int errorCode, HttpServletRequest request, HttpServletResponse response) エラーページＵＲＬを取得します。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
String | AccessSecurityManager.getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
int | AccessSecurityManager.getLicense(LoginInfo loginInfo) アカウントライセンスチェックを行います。
int | AccessSecurityManager.getLoginCertification() カレントスレッド情報からログイン処理を行います。
int | AccessSecurityManager.getLoginCertification(HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
String | AccessSecurityManager.getMainPage() カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
SessionConfig | AccessSecurityManager.getSessionConfig() セッション情報保管パラメータを取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | AccessSecurityManager.getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。
int | AccessSecurityManager.getSessionMode() intra-martセッションの状態を取得します。
int | AccessSecurityManager.getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
void | AccessSecurityManager.logout() ログアウト処理を行います。
void | AccessSecurityManager.logout(HttpServletRequest request, HttpServletResponse response) ログアウト処理を行います。

jp.co.intra_mart.foundation.security.account での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountManager.addAccount(Account account) アカウントを新規追加します。
void | AccountManager.addAccountRole(String userId, AccountRole accountRole) アカウントロールを新規追加します。
void | AccountManager.addFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを新規追加します。
boolean | AccountManager.contains(String userId) アカウントの存在チェックを行います。
int | AccountManager.count() アカウントの登録数を取得します。
void | AccountManager.deleteAccount(String userId) アカウントを削除します。
void | AccountManager.deleteAccountRole(String userId, String roleId) アカウントロールを削除します。
void | AccountManager.deleteAccountRoles(String userId) アカウントロールをすべて削除します。
void | AccountManager.deleteAccounts() アカウントをすべて削除します。
void | AccountManager.deleteFavoriteMenu(String userId, String menuId) マイメニューを削除します。
void | AccountManager.deleteFavoriteMenus(String userId) マイメニューをすべて削除します。
void | AccountManager.exportData(String category, OutputStream outputStream) アカウント情報をエクスポートします。
Account | AccountManager.getAccount(String userId) ユーザIDにマッチしたユーザデータを１件取得します。
String[] | AccountManager.getAccountRoleIds(String userId) アカウントロールIDをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId) アカウントロールをすべて取得します。
AccountRole[] | AccountManager.getAccountRoles(String userId, Date date) 有効期間内のアカウントロールをすべて取得します。
Account[] | AccountManager.getAccounts() ログイングループ内のすべてのユーザアカウントを取得します。
Account[] | AccountManager.getAccountsByUserIds(String[] userIds) ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
String[] | AccountManager.getExportCategories() アカウントエクスポート用のカテゴリの一覧を取得します。
String[] | AccountManager.getFavoriteMenuIds(String userId) マイメニューIDをすべて取得します。
FavoriteMenu[] | AccountManager.getFavoriteMenus(String userId) マイメニューをすべて取得します。
String[] | AccountManager.getImportCategories() アカウントインポート用のカテゴリの一覧を取得します。
String[] | AccountManager.getRoleIds(String userId, Date date) アカウントに紐付く有効なロールIDをすべて取得します。
String[] | AccountManager.getUserIds() すべてのユーザIDを取得します。
String[] | AccountManager.getUserIdsByAccountRole(String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
String[] | AccountManager.getUserIdsByRole(String roleId, Date date) 有効なロールIDを持つすべてのユーザIDを取得します。
void | AccountManager.importData(String category, InputStream inputStream) アカウント情報をインポートします。
Account[] | AccountManager.searchAccounts(String userId) ユーザIDを検索してマッチしたアカウントを配列で返します。
void | AccountManager.updateAccount(Account account) アカウントを更新します。
void | AccountManager.updateAccountRole(String userId, AccountRole accountRole) アカウントロールを更新します。
void | AccountManager.updateFavoriteMenu(String userId, FavoriteMenu favoriteMenu) マイメニューを更新します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.account のコンストラクタ
AccountManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.batch での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchManager.addBatch(Batch batch) バッチ情報を新規登録します。
void | BatchManager.deleteBatch(String batchId) バッチ情報を削除します。
void | BatchManager.deleteBatches() すべてのバッチ情報を削除します。
void | BatchManager.exportData(String category, OutputStream outputStream) エクスポートを行います。
Batch | BatchManager.getBatch(String batchId) バッチ情報を取得します。
Batch[] | BatchManager.getBatches() すべてのバッチ情報を取得します。
Batch[] | BatchManager.getBatchesByIds(String[] batchIds) ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
String[] | BatchManager.getBatchIds() バッチIDの一覧を取得します。
String[] | BatchManager.getExportCategories() バッチエクスポート用のカテゴリの一覧を取得します。
String[] | BatchManager.getImportCategories() バッチインポート用のカテゴリの一覧を取得します。
void | BatchManager.importData(String category, InputStream inputStream) インポートを行います。
void | BatchManager.updateBatch(Batch batch) バッチ情報を更新します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.batch のコンストラクタ
BatchManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarManager.addCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に追加します。
void | CalendarManager.deleteCalendar(String calendarId) カレンダーを削除します。
void | CalendarManager.deleteCalendarInfo(String calendarId, String dataId) カレンダーデータを削除します。
void | CalendarManager.deleteCalendarInfos(String calendarId) すべてのカレンダーデータを削除します。
void | CalendarManager.deleteCalendars() すべてのカレンダーを削除します。
void | CalendarManager.exportData(String category, OutputStream outputStream) エクスポートを行います。
String[] | CalendarManager.getCalendarIds() すべてのカレンダーIDを取得します。
CalendarInfo | CalendarManager.getCalendarInfo(String calendarId, String dataId) カレンダーデータを取得します。
String[] | CalendarManager.getCalendarInfoIds(String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarManager.getCalendarInfosByIds(String calendarId, String[] calendarInfoIds) ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
CategorizedCalendarInfo | CalendarManager.getCategorizedCalendarInfos(String calendarId) すべてのカレンダーデータをデータタイプ別に分類して取得します。
DayInfo | CalendarManager.getDayInfo(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 日付情報を取得します。
String[] | CalendarManager.getExportCategories() カレンダーエクスポート用のカテゴリの一覧を取得します。
String[] | CalendarManager.getImportCategories() カレンダーインポート用のカテゴリの一覧を取得します。
DayInfo[] | CalendarManager.getMonthInfos(CategorizedCalendarInfo categorizedCalendarInfo, int year, int month) 月情報を取得します。
CalendarPlugin | CalendarManager.getPlugin(String pluginId) カレンダーデータプラグインを取得します。
void | CalendarManager.importData(String category, InputStream inputStream) インポートを行います。
boolean | CalendarManager.isHoliday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 休日かどうか判定します。
boolean | CalendarManager.isNationalHoliday(CategorizedCalendarInfo categorizedCalendarInfo, Date date) 祝日かどうか判定します。
boolean | CalendarManager.isWeekday(String calendarId, CategorizedCalendarInfo categorizedCalendarInfo, Date date) 平日かどうか判定します。
void | CalendarManager.updateCalendarInfo(String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。
boolean | CalendarManager.isUpdate(String calendarId, Date date) カレンダーデータが指定された日付よりも新しいかチェックします。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.calendar のコンストラクタ
CalendarManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.exception での AccessSecurityException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityExportException エクスポート時例外クラス。
class | AccessSecurityImportException インポート時例外クラス。
class | AccessSecurityListenerExcpetion アクセスセキュリティリスナーの例外クラス。
class | AccessSecurityReadException アクセスセキュリティ情報の取得例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | AccessSecurityWriteException アクセスセキュリティ情報の更新例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | IllegalArgumentException 引数が不正の例外クラス。
class | NoFilterException HTTPリクエスト・レスポンス取得例外クラス。
class | NoSessionCookieException セッション情報クッキー取得例外クラス。
class | NoSessionException セッション取得例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotFoundDataSourceException データソースの参照名未解決例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

jp.co.intra_mart.foundation.security.group での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupManager.addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupManager.addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupManager.addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
int | LoginGroupManager.countLoginGroups() ログイングループ数を取得します。
void | LoginGroupManager.deleteMainPagePatterns(String groupId) メインページパターンをすべて削除します。
void | LoginGroupManager.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupManager.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupManager.deleteSuperUser(String groupId) グループ管理者情報を削除します。
LoginGroup | LoginGroupManager.getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | LoginGroupManager.getLoginGroupIds() ログイングループIDの一覧を取得します。
LoginGroup[] | LoginGroupManager.getLoginGroups() ログイングループの一覧を取得します。
MainPagePatternInfo | LoginGroupManager.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | LoginGroupManager.getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
MainPagePatternInfo[] | LoginGroupManager.getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
SuperUser | LoginGroupManager.getSuperUser(String groupId) グループ管理者情報を取得します。
void | LoginGroupManager.updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | LoginGroupManager.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | LoginGroupManager.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

jp.co.intra_mart.foundation.security.license での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.license のメソッド
static ApplicationInfo | LicenseManager.getApplication(String applicaionId) アプリケーション情報を取得します。
static double | LicenseManager.getApplicationLicense(String applicaionId) アプリケーションの登録ユーザ数を取得します。
static ApplicationInfo[] | LicenseManager.getApplications() アプリケーション情報の一覧を取得します。
static ApplicationInfo | LicenseManager.getProduct() システム情報を取得します。
static double | LicenseManager.getSystemLicense() システム全体の登録ライセンス数。
static double | LicenseManager.getSystemMaxLicense() システム全体のライセンス数。
void | LicenseManager.deleteAccountLicense(String userId) 指定されたユーザのライセンスを削除します。
void | LicenseManager.deleteApplicationLicenseFromAccount(String userId, String applicationId) アプリケーションライセンスをアカウントから削除します。
double | LicenseManager.getLicense() グループ内で登録されているライセンス数を取得します。
double | LicenseManager.getMaxLicense() ログイングループ内の最大登録可能ライセンス数を取得します。
String[] | LicenseManager.getRegisteredAccountLicenses() ログイングループにライセンス登録されているすべてのユーザIDを返します。
String[] | LicenseManager.getRegisteredApplicationLicensesToAccount(String userId) アカウントに登録されているアプリケーションライセンスの一覧を取得します。
boolean | LicenseManager.isRegisteredAccountLicense(String userId) 指定されたユーザがライセンスに登録されているかどうかをチェックします。
boolean | LicenseManager.isRegisteredApplicationLicenseToAccount(String userId, String applicationId) アカウントにアプリケーションライセンスが登録されてるか検証します。
boolean | LicenseManager.registerAccountLicense(String userId) ライセンス登録します。
boolean | LicenseManager.registerApplicationLicenseToAccount(String userId, String applicationId) アプリケーションライセンスをアカウントに登録します。
boolean | LicenseManager.setMaxLicense(double maxLicense) ログイングループ内の最大登録可能ライセンス数を設定します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.license のコンストラクタ
LicenseManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.menu での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | MenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | MenuManager.addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | MenuManager.addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | MenuManager.addMenuRole(String menuId, String roleId) ロールをメニューに紐付けます。
void | MenuManager.deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
void | MenuManager.deleteMenuDepartments(String menuId) 組織の紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuItem(String menuId) メニューを削除します。
void | MenuManager.deleteMenuItems() すべてのメニューを削除します。
void | MenuManager.deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
void | MenuManager.deleteMenuPosts(String menuId) 役織の紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
void | MenuManager.deleteMenuPublicGroups(String menuId) パブリックグループの紐付けをメニューからすべて削除します。
void | MenuManager.deleteMenuRole(String menuId, String roleId) ロールの紐付けをメニューから削除します。
void | MenuManager.deleteMenuRoles(String menuId) ロールの紐付けをメニューから削除します。
void | MenuManager.exportData(String category, OutputStream outputStream) メニュー情報をエクスポートします。
MenuTree[] | MenuManager.getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
String[] | MenuManager.getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | MenuManager.getExportCategories() メニューエクスポート用のカテゴリの一覧を取得します。
String[] | MenuManager.getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | MenuManager.getImportCategories() メニューインポート用のカテゴリの一覧を取得します。
DepartmentInfo[] | MenuManager.getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
String[] | MenuManager.getMenuIds() すべてのメニューIDを取得します。
String[] | MenuManager.getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | MenuManager.getMenuIdsByRole(String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuItem | MenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | MenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem[] | MenuManager.getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
PostInfo[] | MenuManager.getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PublicGroupInfo[] | MenuManager.getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
String[] | MenuManager.getMenuRoles(String menuId) メニューに紐付いたロールの一覧を取得します。
MenuTree[] | MenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
String | MenuManager.getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | MenuManager.importData(String category, InputStream inputStream) メニュー情報をインポートします。
void | MenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | MenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
void | AdminMenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | AdminMenuManager.deleteMenuItem(String menuId) メニューを削除します。
void | AdminMenuManager.deleteMenuItems() すべてのメニューを削除します。
void | AdminMenuManager.exportData(String category, OutputStream outputStream) メニュー情報・エクスポート。
String[] | AdminMenuManager.getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | AdminMenuManager.getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | AdminMenuManager.getMenuIds() すべてのメニューIDを取得します。
MenuItem | AdminMenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | AdminMenuManager.getMenuItems() すべてのメニューを取得します。
MenuTree[] | AdminMenuManager.getMenuTree() メニュー構成を取得します。
String | AdminMenuManager.getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | AdminMenuManager.importData(String category, InputStream inputStream) メニュー情報・インポート。
void | AdminMenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | AdminMenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.menu のコンストラクタ
MenuManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.message での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.message のメソッド
String | MessageManager.getMessage(Locale locale, String key) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg1, String arg2) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | MessageManager.getMessage(Locale locale, String key, String[] args) メッセージを取得します。
String | MessageManager.getMessage(String key) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg1, String arg2) メッセージを取得します。
String | MessageManager.getMessage(String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | MessageManager.getMessage(String key, String[] args) メッセージを取得します。

jp.co.intra_mart.foundation.security.permission での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.permission のメソッド
Collection | PermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
PermissionSelector | PermissionManager.getPermissionSelector(String category) 指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
Collection | PermissionManager.doSelection(String category, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | PermissionManager.doSelection(String category, String info) 選択用情報を利用して選別された情報のリストを返却します。
Collection | MenuPermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
Collection | AccountRolePermissionSelector.doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.permission のコンストラクタ
PermissionManager(String groupId)
コンストラクタ。

jp.co.intra_mart.foundation.security.role での AccessSecurityException の使用

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleManager.addRole(Role role) ロール情報を新規登録します。
void | RoleManager.addSubRole(String roleId, String subRoleId) サブロールIDを追加します。
boolean | RoleManager.certify(String[] users, String[] roles) ロール内包を認証します。
boolean | RoleManager.contains(String roleId) ロールの存在チェックを行います。
boolean | RoleManager.containsCategory(String category) カテゴリーの存在チェックをします。
int | RoleManager.countByCategory(String category) カテゴリーに属するロール数を取得します。
void | RoleManager.deleteCategory(String category) カテゴリーを削除します。
void | RoleManager.deleteRole(String roleId) ロールを削除します。
void | RoleManager.deleteRoles() すべてのロールを削除します。
void | RoleManager.deleteSubRole(String roleId, String subRoleId) 指定したサブロールIDを削除します。
void | RoleManager.deleteSubRoles(String roleId) 全てのサブロールIDを削除します。
void | RoleManager.exportData(String category, OutputStream outputStream) ロール情報・エクスポート。
String[] | RoleManager.getAllParentRoleIds(String roleId) 全ての親ロールIDを取得します。
String[] | RoleManager.getAllSubRoleIds(String roleId) 全てのサブロールサマリを取得します。
String[] | RoleManager.getExportCategories() ロールエクスポート用のカテゴリの一覧を取得します。
String[] | RoleManager.getImportCategories() ロールインポート用のカテゴリの一覧を取得します。
String[] | RoleManager.getParentRoleIds(String roleId) 親ロールIDを取得します。
Role | RoleManager.getRole(String roleId) ロール情報を取得します。
Role[] | RoleManager.getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | RoleManager.getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
String[] | RoleManager.getSubRole(String roleId) サブロール(一階層のみ)を取得します。
void | RoleManager.importData(String category, InputStream inputStream) ロール情報・インポート。
void | RoleManager.moveCategory(String oldCategory, String newCategory) カテゴリーを更新します。
Role[] | RoleManager.searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | RoleManager.searchRolesByName(String name) ロール名称検索によりロールを取得します。
void | RoleManager.updateRole(Role role) ロール情報を更新します。

AccessSecurityException をスローする jp.co.intra_mart.foundation.security.role のコンストラクタ
RoleManager(String gid)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException の使用

AccessSecurityExportException を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | StandardAccountBackup.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。
void | AccountExporter.doExport(AccountManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.batch での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | StandardBatchBackup.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。
void | BatchExporter.doExport(BatchManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | StandardCalendarBackup.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。
void | CalendarExporter.doExport(CalendarManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.menu での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | StandardMenuBackup.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | StandardAdminMenuBackup.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | MenuExporter.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | AdminMenuExporter.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。

jp.co.intra_mart.foundation.security.role での AccessSecurityExportException の使用

AccessSecurityExportException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | StandardRoleBackup.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | RoleExporter.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException の使用

AccessSecurityImportException を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | StandardAccountBackup.doImport(InputStream inputStream, AccountManager manager) インポートを行います。
void | AccountImporter.doImport(InputStream inputStream, AccountManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.batch での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | StandardBatchBackup.doImport(InputStream inputStream, BatchManager manager) インポートを行います。
void | BatchImporter.doImport(InputStream inputStream, BatchManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | StandardCalendarBackup.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。
void | CalendarImporter.doImport(InputStream inputStream, CalendarManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.menu での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | StandardMenuBackup.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | StandardAdminMenuBackup.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | MenuImporter.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | AdminMenuImporter.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。

jp.co.intra_mart.foundation.security.role での AccessSecurityImportException の使用

AccessSecurityImportException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | StandardRoleBackup.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | RoleImporter.doImport(InputStream inputStream, RoleManager manager) インポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountQueryWriterListener.queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | AccountQueryWriterListener.queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountQueryWriterListener.queryDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | AccountQueryWriterListener.queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | AccountQueryWriterListener.queryDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除する直前にコールされます。
void | AccountQueryWriterListener.queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。
void | AccountPostWriterListener.postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | AccountPostWriterListener.postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | AccountPostWriterListener.postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | AccountPostWriterListener.postDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除した直後にコールされます。
void | AccountPostWriterListener.postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.admin での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.admin のメソッド
void | SuperUserQueryWriterListener.queryCreate(SuperUser superUser) システム管理者情報をデータストアに作成する直前にコールされます。
void | SuperUserQueryWriterListener.queryUpdate(SuperUser superUser) システム管理者情報をデータストアに更新する直前にコールされます。
void | SuperUserPostWriterListener.postCreate(SuperUser superUser) システム管理者情報をデータストアに作成した直後にコールされます。
void | SuperUserPostWriterListener.postUpdate(SuperUser superUser) システム管理者情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.batch での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchQueryWriterListener.queryCreate(String groupId, Batch batch) バッチ情報をデータストアに作成する直前にコールされます。
void | BatchQueryWriterListener.queryDelete(String groupId, String batchId) バッチ情報をデータストアから削除する直前にコールされます。
void | BatchQueryWriterListener.queryUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新する直前にコールされます。
void | BatchPostWriterListener.postCreate(String groupId, Batch batch) バッチ情報をデータストアに作成した直後にコールされます。
void | BatchPostWriterListener.postDelete(String groupId, String batchId) バッチ情報をデータストアから削除した直後にコールされます。
void | BatchPostWriterListener.postUpdate(String groupId, Batch batch) バッチ情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarQueryWriterListener.queryCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成する直前にコールされます。
void | CalendarQueryWriterListener.queryDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除する直前にコールされます。
void | CalendarQueryWriterListener.queryUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新する直前にコールされます。
void | CalendarPostWriterListener.postCreateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに作成した直後にコールされます。
void | CalendarPostWriterListener.postDeleteCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータをデータストアから削除した直後にコールされます。
void | CalendarPostWriterListener.postUpdateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータをデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.group での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | LoginGroupQueryWriterListener.queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | LoginGroupQueryWriterListener.queryDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除する直前にコールされます。
void | LoginGroupQueryWriterListener.queryDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除する前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。
void | LoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | LoginGroupPostWriterListener.postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuQueryWriterListener.queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | MenuQueryWriterListener.queryDelete(String groupId, String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | MenuQueryWriterListener.queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | MenuQueryWriterListener.queryMove(String groupId, String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | MenuPostWriterListener.postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | MenuPostWriterListener.postDelete(String groupId, String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | MenuPostWriterListener.postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | MenuPostWriterListener.postMove(String groupId, String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | AdminMenuQueryWriterListener.queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | AdminMenuQueryWriterListener.queryDelete(String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | AdminMenuQueryWriterListener.queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | AdminMenuQueryWriterListener.queryMove(String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | AdminMenuPostWriterListener.postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | AdminMenuPostWriterListener.postDelete(String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | AdminMenuPostWriterListener.postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | AdminMenuPostWriterListener.postMove(String parentId, String childId) メニューの親子関係を更新した直後にコールされます。

jp.co.intra_mart.foundation.security.role での AccessSecurityListenerExcpetion の使用

AccessSecurityListenerExcpetion をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleQueryWriterListener.queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | RoleQueryWriterListener.queryDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除する直前にコールされます。
void | RoleQueryWriterListener.queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。
void | RoleQueryWriterListener.postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加する直前にコールされます。
void | RoleQueryWriterListener.postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除する直前にコールされます。
void | RolePostWriterListener.postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RolePostWriterListener.postDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | RolePostWriterListener.postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RolePostWriterListener.postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | RolePostWriterListener.postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException の使用

AccessSecurityReadException を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.account のメソッド
Account | AccountAccessor.getAccount(String groupId, String userId) アカウント情報を取得する。
Account[] | AccountAccessor.getAccountsByUserIds(String groupId, String[] userIds) 指定されたユーザIDのアカウント情報をすべて取得する。
int | AccountAccessor.getAccountCount(String groupId) アカウント数を取得する。
AccountRole | AccountAccessor.getAccountRole(String groupId, String userId, String roleId) アカウントロール情報を取得する。
String[] | AccountAccessor.getAccountRoleIds(String groupId, String userId) アカウントロールIDをすべて取得する。
AccountRole[] | AccountAccessor.getAccountRoles(String groupId, String userId) アカウントロール情報をすべて取得する。
FavoriteMenu | AccountAccessor.getFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を取得する。
String[] | AccountAccessor.getFavoriteMenuIds(String groupId, String userId) マイメニューIDをすべて取得する。
FavoriteMenu[] | AccountAccessor.getFavoriteMenus(String groupId, String userId) マイメニュー情報をすべて取得する。
String[] | AccountAccessor.getUserIds(String groupId) ユーザIDの一覧を取得する。
String[] | AccountAccessor.getUserIdsByRoles(String groupId, String[] roleIds, Date date) 指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
Account[] | AccountAccessor.searchAccounts(String groupId, String userId) アカウント情報の読み込みます。
String[] | AccountAccessor.getUserIdsByAccountRole(String groupId, String roleId) 引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。

jp.co.intra_mart.foundation.security.admin での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 SuperUser SuperUserAccessor.getSuperUser()
システム管理者情報を取得します。

jp.co.intra_mart.foundation.security.batch での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
Batch | BatchAccessor.getBatch(String groupId, String batchId) バッチ情報を取得します。
Batch[] | BatchAccessor.getBatches(String groupId) すべてのバッチ情報を取得します。
Batch[] | BatchAccessor.getBatchesByIds(String groupId, String[] batchIds) 引数に指定したバッチIDのバッチ情報をすべて取得します。
String[] | BatchAccessor.getBatchIds(String groupId) すべてのバッチIDを取得します。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
String[] | CalendarAccessor.getCalendarIds(String groupId) すべてのカレンダーIDを取得します。
CalendarInfo | CalendarAccessor.getCalendarInfo(String groupId, String calendarId, String dataId) カレンダーデータを取得します。
String[] | CalendarAccessor.getCalendarInfoIds(String groupId, String calendarId) すべてのカレンダーデータIDを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfos(String groupId, String calendarId) すべてのカレンダーデータを取得します。
CalendarInfo[] | CalendarAccessor.getCalendarInfosByIds(String groupId, String calendarId, String[] calendarInfoIds) 指定されたカレンダIDのカレンダ情報をすべて取得する。
boolean | CalendarAccessor.isUpdate(String groupId, String calendarId, Date date) カレンダーデータが指定された日付よりも新しいかチェックします。

jp.co.intra_mart.foundation.security.group での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.group のメソッド
LoginGroup | LoginGroupAccessor.getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | LoginGroupAccessor.getLoginGroupIds() ログイングループIDの一覧を取得します。
MainPagePatternInfo | LoginGroupAccessor.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | LoginGroupAccessor.getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
SuperUser | GroupSuperUserAccessor.getSuperUser(String groupId) グループ管理者情報を取得します。

jp.co.intra_mart.foundation.security.menu での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
String[] | MenuAccessor.getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | MenuAccessor.getFirstMenuIds(String groupId) 第一階層に属するノードを配列で取得します。
DepartmentInfo[] | MenuAccessor.getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | MenuAccessor.getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | MenuAccessor.getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | MenuAccessor.getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | MenuAccessor.getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | MenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | MenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | MenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
PostInfo[] | MenuAccessor.getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | MenuAccessor.getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | MenuAccessor.getMenuRoles(String groupId, String id) すべてのメニューロールを取得します。
String | MenuAccessor.getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
String[] | AdminMenuAccessor.getChildMenuIds(String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | AdminMenuAccessor.getFirstMenuIds() 第一階層に属するノードを配列で取得します。
String[] | AdminMenuAccessor.getMenuIds() すべてのメニューIDを取得します。
MenuInclusion[] | AdminMenuAccessor.getMenuInclusions() すべてのメニュー構成を取得します。
MenuItem | AdminMenuAccessor.getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | AdminMenuAccessor.getMenuItems() すべてのノードを取得します。
String | AdminMenuAccessor.getParentMenuId(String menuId) 引数で指定されたノードの親ノードを取得します。

jp.co.intra_mart.foundation.security.role での AccessSecurityReadException の使用

AccessSecurityReadException をスローする jp.co.intra_mart.foundation.security.role のメソッド
int | RoleManager.count() ロール数を取得します。
String[] | RoleManager.getCategories() カテゴリーの一覧を取得します。
String[] | RoleManager.getRoleIds() すべてのロールIDを取得します。
Role[] | RoleManager.getRoles() すべてのロール情報を取得します。
String[] | RoleAccessor.getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得する。
String[] | RoleAccessor.getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得する。
String[] | RoleAccessor.getCategories(String groupId) カテゴリの一覧を取得する。
String[] | RoleAccessor.getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得する。
Role[] | RoleAccessor.getRoleData(String groupId) ロール情報を全件取得する。
Role | RoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | RoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | RoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。
String[] | RoleAccessor.getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException の使用

AccessSecurityRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.security.exception アクセスセキュリティ例外に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.exception での AccessSecurityRuntimeException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityRuntimeException のサブクラス
class | AccessSecurityConfigException アクセスセキュリティ設定に関する例外クラス。
class | SystemConfigException システム設定に関する例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException の使用

jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException の使用

AccessSecurityWriteException を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | AccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | AccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

jp.co.intra_mart.foundation.security.admin での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
void | SuperUserAccessor.insertSuperUser(SuperUser superUser) システム管理者情報を新規追加します。
void | SuperUserAccessor.updateSuperUser(SuperUser superUser) システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.batch での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchAccessor.deleteBatch(String groupId, String batchId) バッチ情報を削除します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。
void | BatchAccessor.insertBatch(String groupId, Batch batch) バッチ情報を新規に追加します。

jp.co.intra_mart.foundation.security.calendar での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | CalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを新規に作成します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

jp.co.intra_mart.foundation.security.exception での AccessSecurityWriteException の使用

jp.co.intra_mart.foundation.security.exception での AccessSecurityWriteException のサブクラス
class | AccessSecurityCreateException アクセスセキュリティ情報作成例外クラス。
class | AccessSecurityDeleteException アクセスセキュリティ情報削除例外クラス。
class | AccessSecurityUpdateException アクセスセキュリティ情報更新例外クラス。
class | DuplicateException 作成時重複例外クラス。
class | NotExistException アクセスセキュリティ情報が存在しなかった場合の例外クラス。
class | NotSupportMethodException アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

jp.co.intra_mart.foundation.security.group での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupAccessor.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | GroupSuperUserAccessor.deleteSuperUser(String groupId) グループ管理者情報を削除します。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

jp.co.intra_mart.foundation.security.menu での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuAccessor.deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | MenuAccessor.deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | MenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | MenuAccessor.deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | MenuAccessor.deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | MenuAccessor.deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | MenuAccessor.deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | MenuAccessor.deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | MenuAccessor.deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | MenuAccessor.deleteMenuRoles(String groupId, String id) すべてのメニューロールを削除します。
void | MenuAccessor.insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | MenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | MenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | MenuAccessor.insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。
void | MenuAccessor.insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | MenuAccessor.insertMenuRole(String groupId, String id, String roleId) メニューロールを新規に作成します。
void | MenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
void | AdminMenuAccessor.deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | AdminMenuAccessor.deleteMenuItem(String menuId) 引数で渡されたノードを削除します。
void | AdminMenuAccessor.insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | AdminMenuAccessor.insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | AdminMenuAccessor.updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。

jp.co.intra_mart.foundation.security.role での AccessSecurityWriteException の使用

AccessSecurityWriteException をスローする jp.co.intra_mart.foundation.security.role のメソッド
void | RoleManager.deleteCategories() すべてのカテゴリーを削除します。
void | RoleAccessor.createRole(String groupId, Role role) ロール情報を新規に追加する。
void | RoleAccessor.deleteCategory(String groupId) すべてのカテゴリを削除する。
void | RoleAccessor.deleteCategory(String groupId, String category) カテゴリを削除する。
void | RoleAccessor.deleteRole(String groupId) すべてのロール情報を削除する。
void | RoleAccessor.deleteRole(String groupId, String roleId) ロール情報を削除する。
void | RoleAccessor.updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新する。
void | RoleAccessor.updateRole(String groupId, Role role) ロール情報を更新する。
void | RoleAccessor.insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成する。
void | RoleAccessor.deleteSubRole(String groupId, String roleId, String subRoleId) サブロールIDサマリを削除する。
void | RoleAccessor.deleteSubRole(String groupId, String roleId) 指定したロールのサブロールIDサマリを全削除する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.DuplicateException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.DuplicateException の使用

DuplicateException を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.insertAccount(String groupId, Account account) アカウント情報を新規追加する。
void | AccountAccessor.insertAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を新規追加する。
void | AccountAccessor.insertFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を新規追加する。

jp.co.intra_mart.foundation.security.admin での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 void SuperUserAccessor.insertSuperUser(SuperUser superUser)
システム管理者情報を新規追加します。

jp.co.intra_mart.foundation.security.batch での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
 void BatchAccessor.insertBatch(String groupId, Batch batch)
バッチ情報を新規に追加します。

jp.co.intra_mart.foundation.security.calendar での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
 void CalendarAccessor.insertCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo)
カレンダーデータを新規に作成します。

jp.co.intra_mart.foundation.security.group での DuplicateException の使用

DuplicateException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | GroupSuperUserAccessor.insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.IllegalArgumentException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.IllegalArgumentException の使用

jp.co.intra_mart.foundation.security.exception.IllegalArgumentException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoFilterException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoFilterException の使用

NoFilterException を使用しているパッケージ
jp.co.intra_mart.foundation.security アクセスセキュリティに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での NoFilterException の使用

NoFilterException をスローする jp.co.intra_mart.foundation.security のメソッド
int | AccessSecurityManager.forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
void | AccessSecurityManager.forward(String url) 指定したURLにフォワードします。
SessionInfo | AccessSecurityManager.getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
String | AccessSecurityManager.getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
int | AccessSecurityManager.getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
String | AccessSecurityManager.getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | AccessSecurityManager.getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
int | AccessSecurityManager.getLoginCertification() カレントスレッド情報からログイン処理を行います。
String | AccessSecurityManager.getMainPage() カレントスレッド情報からメインページURLを取得します。
String | AccessSecurityManager.getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
SessionInfo | AccessSecurityManager.getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
int | AccessSecurityManager.getSessionMode() intra-martセッションの状態を取得します。
int | AccessSecurityManager.login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
void | AccessSecurityManager.logout() ログアウト処理を行います。
void | AccessSecurityManager.secureRedirect(String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoSessionCookieException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoSessionCookieException の使用

jp.co.intra_mart.foundation.security.exception.NoSessionCookieException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NoSessionException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NoSessionException の使用

jp.co.intra_mart.foundation.security.exception.NoSessionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotExistException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotExistException の使用

NotExistException を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.database での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.database のメソッド
Connection | DatabaseManager.getLoginGroupConnection(String groupId) ログイングループIDからコネクションオブジェクトを取得します。
Connection | DatabaseManager.getSystemConnection(String connectId) システム接続名からコネクションオブジェクトを取得します。

jp.co.intra_mart.foundation.security.account での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.account のメソッド
void | AccountAccessor.deleteAccount(String groupId, String userId) アカウント情報を削除する。
void | AccountAccessor.deleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報を削除する。
void | AccountAccessor.deleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報を削除する。
void | AccountAccessor.updateAccount(String groupId, Account account) アカウント情報を更新する。
void | AccountAccessor.updateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報を更新する。
void | AccountAccessor.updateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報を更新する。

jp.co.intra_mart.foundation.security.admin での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.admin のメソッド
 void SuperUserAccessor.updateSuperUser(SuperUser superUser)
システム管理者情報を更新します。

jp.co.intra_mart.foundation.security.batch での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.batch のメソッド
void | BatchAccessor.deleteBatch(String groupId, String batchId) バッチ情報を削除します。
void | BatchAccessor.updateBatch(String groupId, Batch batch) バッチ情報を更新します。

jp.co.intra_mart.foundation.security.calendar での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.calendar のメソッド
void | CalendarAccessor.deleteCalendar(String groupId, String calendarId) カレンダーを削除します。
void | CalendarAccessor.deleteCalendarInfo(String groupId, String calendarId, String dataId) 指定されたカレンダーデータを削除します。
void | CalendarAccessor.updateCalendarInfo(String groupId, String calendarId, CalendarInfo calendarInfo) カレンダーデータを更新します。

jp.co.intra_mart.foundation.security.group での NotExistException の使用

NotExistException をスローする jp.co.intra_mart.foundation.security.group のメソッド
void | LoginGroupAccessor.deleteLoginGroup(String groupId) ログイングループを削除します。
void | LoginGroupAccessor.deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | GroupSuperUserAccessor.deleteSuperUser(String groupId) グループ管理者情報を削除します。
void | GroupSuperUserAccessor.updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException の使用

jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.NotSupportMethodException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.NotSupportMethodException の使用

jp.co.intra_mart.foundation.security.exception.NotSupportMethodException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.exception.SystemConfigException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.exception.SystemConfigException の使用

jp.co.intra_mart.foundation.security.exception.SystemConfigException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AccessSecurityConfigException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
すべての実装インタフェース:
Serializable
public class AccessSecurityConfigException
extends AccessSecurityRuntimeException

アクセスセキュリティ設定に関する例外クラス。

アクセスセキュリティ設定が正しく設定されていない場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccessSecurityConfigException()
コンストラクタ。
AccessSecurityConfigException(String message)
コンストラクタ。
AccessSecurityConfigException(String message, Throwable cause)
コンストラクタ。
AccessSecurityConfigException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityConfigException

public AccessSecurityConfigException()
コンストラクタ。

AccessSecurityConfigException

public AccessSecurityConfigException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityConfigException

public AccessSecurityConfigException(String message,
                                     Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityConfigException

public AccessSecurityConfigException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityCreateException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityCreateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
すべての実装インタフェース:
Serializable
public class AccessSecurityCreateException
extends AccessSecurityWriteException

アクセスセキュリティ情報作成例外クラス。

アクセスセキュリティ情報の作成に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityCreateException(String key, String kind)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, String group)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityCreateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityCreateException

public AccessSecurityCreateException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityDeleteException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityDeleteException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
すべての実装インタフェース:
Serializable
public class AccessSecurityDeleteException
extends AccessSecurityWriteException

アクセスセキュリティ情報削除例外クラス。

アクセスセキュリティ情報の削除に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityDeleteException(String key, String kind)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, String group)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityDeleteException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityDeleteException

public AccessSecurityDeleteException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityExportException, AccessSecurityImportException, AccessSecurityListenerExcpetion, AccessSecurityReadException, AccessSecurityWriteException, IllegalArgumentException, NoFilterException, NoSessionCookieException, NoSessionException, NotFoundDataSourceException
public class AccessSecurityException
extends FoundationException

アクセスセキュリティの基本となる例外クラス。

アクセスセキュリティで例外が発生した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | KIND_ROLE 種別 ロール。
static String | KIND_ROLE_SUB 種別 サブロール(ロール)。
コンストラクタの概要
AccessSecurityException()
コンストラクタ。
AccessSecurityException(String message)
コンストラクタ。
AccessSecurityException(String message, Throwable cause)
コンストラクタ。
AccessSecurityException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

KIND_ROLE

public static final String KIND_ROLE
種別 ロール。

関連項目:
定数フィールド値

KIND_ROLE_SUB

public static final String KIND_ROLE_SUB
種別 サブロール(ロール)。

関連項目:
定数フィールド値
コンストラクタの詳細

AccessSecurityException

public AccessSecurityException()
コンストラクタ。

AccessSecurityException

public AccessSecurityException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityException

public AccessSecurityException(String message,
                               Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityException

public AccessSecurityException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityExportException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityExportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
すべての実装インタフェース:
Serializable
public class AccessSecurityExportException
extends AccessSecurityException

エクスポート時例外クラス。

エクスポート時に例外が発生した場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityExportException(String name)
コンストラクタ。
AccessSecurityExportException(String name, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityExportException

public AccessSecurityExportException(String name)
コンストラクタ。

パラメータ:
name - 重複している名称

AccessSecurityExportException

public AccessSecurityExportException(String name,
                                     Throwable cause)
コンストラクタ。

パラメータ:
name - 重複している名称
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityImportException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityImportException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
すべての実装インタフェース:
Serializable
public class AccessSecurityImportException
extends AccessSecurityException

インポート時例外クラス。

インポート時に例外が発生した場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityImportException(String name)
コンストラクタ。
AccessSecurityImportException(String name, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityImportException

public AccessSecurityImportException(String name)
コンストラクタ。

パラメータ:
name - 重複している名称

AccessSecurityImportException

public AccessSecurityImportException(String name,
                                     Throwable cause)
コンストラクタ。

パラメータ:
name - 重複している名称
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityListenerExcpetion (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityListenerExcpetion

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
すべての実装インタフェース:
Serializable
public class AccessSecurityListenerExcpetion
extends AccessSecurityException

アクセスセキュリティリスナーの例外クラス。

アクセスセキュリティリスナー内で例外が発せした場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityListenerExcpetion()
コンストラクタ。
AccessSecurityListenerExcpetion(String message)
コンストラクタ。
AccessSecurityListenerExcpetion(String message, Throwable cause)
コンストラクタ。
AccessSecurityListenerExcpetion(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion()
コンストラクタ。

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

AccessSecurityListenerExcpetion

public AccessSecurityListenerExcpetion(String message,
                                       Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityReadException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityReadException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
すべての実装インタフェース:
Serializable
public class AccessSecurityReadException
extends AccessSecurityException

アクセスセキュリティ情報の取得例外クラス。

アクセスセキュリティ情報の取得に失敗した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityReadException(String message)
コンストラクタ。
AccessSecurityReadException(String key, String kind)
コンストラクタ。
AccessSecurityReadException(String key, String kind, String group)
コンストラクタ。
AccessSecurityReadException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityReadException(String key, String kind, Throwable cause)
コンストラクタ。
AccessSecurityReadException(String message, Throwable cause)
コンストラクタ。
AccessSecurityReadException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityReadException

public AccessSecurityReadException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   String group,
                                   Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(String key,
                                   String kind,
                                   Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(String message,
                                   Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityReadException

public AccessSecurityReadException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityRuntimeException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityConfigException, SystemConfigException
public class AccessSecurityRuntimeException
extends FoundationRuntimeException

アクセスセキュリティランタイム例外クラス。

アクセスセキュリティ設定ファイル群の不備などでシステム運用が続行不可な場合のランタイム例外クラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AccessSecurityRuntimeException()
コンストラクタ。
AccessSecurityRuntimeException(String message)
コンストラクタ。
AccessSecurityRuntimeException(String message, Throwable cause)
コンストラクタ。
AccessSecurityRuntimeException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityRuntimeException

public AccessSecurityRuntimeException()
コンストラクタ。

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(String message)
コンストラクタ。

パラメータ:
message - メッセージ

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

AccessSecurityRuntimeException

public AccessSecurityRuntimeException(String message,
                                      Throwable cause)
コンストラクタ。

パラメータ:
message - メッセージ
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityUpdateException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityUpdateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
すべての実装インタフェース:
Serializable
public class AccessSecurityUpdateException
extends AccessSecurityWriteException

アクセスセキュリティ情報更新例外クラス。

アクセスセキュリティ情報の更新に失敗した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityUpdateException(String key, String kind)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, String group)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
AccessSecurityUpdateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     String group,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

AccessSecurityUpdateException

public AccessSecurityUpdateException(String key,
                                     String kind,
                                     Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityWriteException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス AccessSecurityWriteException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccessSecurityCreateException, AccessSecurityDeleteException, AccessSecurityUpdateException, DuplicateException, NotExistException, NotSupportMethodException
public class AccessSecurityWriteException
extends AccessSecurityException

アクセスセキュリティ情報の更新例外クラス。

アクセスセキュリティ情報の更新に失敗した場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
AccessSecurityWriteException()
コンストラクタ。
AccessSecurityWriteException(String message)
コンストラクタ。
AccessSecurityWriteException(String message, Throwable cause)
コンストラクタ。
AccessSecurityWriteException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccessSecurityWriteException

public AccessSecurityWriteException()
コンストラクタ。

AccessSecurityWriteException

public AccessSecurityWriteException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

AccessSecurityWriteException

public AccessSecurityWriteException(String message,
                                    Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

AccessSecurityWriteException

public AccessSecurityWriteException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DuplicateException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス DuplicateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.DuplicateException
すべての実装インタフェース:
Serializable
public class DuplicateException
extends AccessSecurityWriteException

作成時重複例外クラス。

アクセスセキュリティ情報を新規作成する場合に重複が起こった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
DuplicateException(String key, String kind)
コンストラクタ。
DuplicateException(String key, String kind, String group)
コンストラクタ。
DuplicateException(String key, String kind, String group, Throwable cause)
コンストラクタ。
DuplicateException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateException

public DuplicateException(String key,
                          String kind,
                          String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

DuplicateException

public DuplicateException(String key,
                          String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

DuplicateException

public DuplicateException(String key,
                          String kind,
                          String group,
                          Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

DuplicateException

public DuplicateException(String key,
                          String kind,
                          Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalArgumentException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス IllegalArgumentException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
すべての実装インタフェース:
Serializable
public class IllegalArgumentException
extends AccessSecurityException

引数が不正の例外クラス。

引数が不正であった場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
IllegalArgumentException(String argName, String function)
コンストラクタ。
IllegalArgumentException(String argName, String function, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalArgumentException

public IllegalArgumentException(String argName,
                                String function)
コンストラクタ。

パラメータ:
argName - 不正な引数名

IllegalArgumentException

public IllegalArgumentException(String argName,
                                String function,
                                Throwable cause)
コンストラクタ。

パラメータ:
argName - 不正な引数名
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoFilterException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoFilterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoFilterException
すべての実装インタフェース:
Serializable
public class NoFilterException
extends AccessSecurityException

HTTPリクエスト・レスポンス取得例外クラス。

HTTPリクエスト・レスポンス情報が取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoFilterException()
コンストラクタ。
NoFilterException(String message)
コンストラクタ。
NoFilterException(String message, Throwable cause)
コンストラクタ。
NoFilterException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoFilterException

public NoFilterException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

NoFilterException

public NoFilterException(String message,
                         Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

NoFilterException

public NoFilterException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NoFilterException

public NoFilterException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSessionCookieException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoSessionCookieException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
すべての実装インタフェース:
Serializable
public class NoSessionCookieException
extends AccessSecurityException

セッション情報クッキー取得例外クラス。

セッション情報クッキーが取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoSessionCookieException(String cookieName)
コンストラクタ。
NoSessionCookieException(String cookieName, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSessionCookieException

public NoSessionCookieException(String cookieName,
                                Throwable cause)
コンストラクタ。

パラメータ:
cookieName - 存在しなかったクッキー名
cause - 原因となる例外

NoSessionCookieException

public NoSessionCookieException(String cookieName)
コンストラクタ。

パラメータ:
cookieName - 存在しなかったクッキー名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoSessionException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NoSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NoSessionException
すべての実装インタフェース:
Serializable
public class NoSessionException
extends AccessSecurityException

セッション取得例外クラス。

セッション情報が取得できなかった場合の例外。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NoSessionException()
コンストラクタ。
NoSessionException(String message)
コンストラクタ。
NoSessionException(String message, Throwable cause)
コンストラクタ。
NoSessionException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSessionException

public NoSessionException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

NoSessionException

public NoSessionException(String message,
                          Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

NoSessionException

public NoSessionException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NoSessionException

public NoSessionException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotExistException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotExistException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.NotExistException
すべての実装インタフェース:
Serializable
public class NotExistException
extends AccessSecurityWriteException

アクセスセキュリティ情報が存在しなかった場合の例外クラス。

アクセスセキュリティ情報が存在しなかった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotExistException(String key, String kind)
コンストラクタ。
NotExistException(String key, String kind, String group)
コンストラクタ。
NotExistException(String key, String kind, String group, Throwable cause)
コンストラクタ。
NotExistException(String key, String kind, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotExistException

public NotExistException(String key,
                         String kind,
                         String group)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ

NotExistException

public NotExistException(String key,
                         String kind)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別

NotExistException

public NotExistException(String key,
                         String kind,
                         String group,
                         Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
group - ログイングループ
cause - 原因となる例外

NotExistException

public NotExistException(String key,
                         String kind,
                         Throwable cause)
コンストラクタ。

パラメータ:
key - 識別情報
kind - アクセスセキュリティ種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotFoundDataSourceException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotFoundDataSourceException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
すべての実装インタフェース:
Serializable
public class NotFoundDataSourceException
extends AccessSecurityException

データソースの参照名未解決例外クラス。

ログイングループおよび接続名に紐付いたデータソース参照名が見つからなかった場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotFoundDataSourceException(String name, String type)
コンストラクタ。
NotFoundDataSourceException(String name, String type, Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotFoundDataSourceException

public NotFoundDataSourceException(String name,
                                   String type)
コンストラクタ。

パラメータ:
name - 見つからなかったログイングループまたは接続名
type - 接続種別

NotFoundDataSourceException

public NotFoundDataSourceException(String name,
                                   String type,
                                   Throwable cause)
コンストラクタ。

パラメータ:
name - 見つからなかったログイングループまたは接続名
type - 接続種別
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotSupportMethodException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス NotSupportMethodException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.exception.FoundationException
                拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
                        拡張 jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
すべての実装インタフェース:
Serializable
public class NotSupportMethodException
extends AccessSecurityWriteException

アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。

アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合にスローする。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException から継承したフィールド
KIND_ROLE, KIND_ROLE_SUB
コンストラクタの概要
NotSupportMethodException()
コンストラクタ。
NotSupportMethodException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotSupportMethodException

public NotSupportMethodException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外

NotSupportMethodException

public NotSupportMethodException()
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.exception
例外
AccessSecurityConfigException
AccessSecurityCreateException
AccessSecurityDeleteException
AccessSecurityException
AccessSecurityExportException
AccessSecurityImportException
AccessSecurityListenerExcpetion
AccessSecurityReadException
AccessSecurityRuntimeException
AccessSecurityUpdateException
AccessSecurityWriteException
DuplicateException
IllegalArgumentException
NoFilterException
NoSessionCookieException
NoSessionException
NotExistException
NotFoundDataSourceException
NotSupportMethodException
SystemConfigException


jp.co.intra_mart.foundation.security.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.exception

アクセスセキュリティ例外に関連するクラスを提供します。

参照:
説明

例外の概要
AccessSecurityConfigException | アクセスセキュリティ設定に関する例外クラス。
AccessSecurityCreateException | アクセスセキュリティ情報作成例外クラス。
AccessSecurityDeleteException | アクセスセキュリティ情報削除例外クラス。
AccessSecurityException | アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException | エクスポート時例外クラス。
AccessSecurityImportException | インポート時例外クラス。
AccessSecurityListenerExcpetion | アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException | アクセスセキュリティ情報の取得例外クラス。
AccessSecurityRuntimeException | アクセスセキュリティランタイム例外クラス。
AccessSecurityUpdateException | アクセスセキュリティ情報更新例外クラス。
AccessSecurityWriteException | アクセスセキュリティ情報の更新例外クラス。
DuplicateException | 作成時重複例外クラス。
IllegalArgumentException | 引数が不正の例外クラス。
NoFilterException | HTTPリクエスト・レスポンス取得例外クラス。
NoSessionCookieException | セッション情報クッキー取得例外クラス。
NoSessionException | セッション取得例外クラス。
NotExistException | アクセスセキュリティ情報が存在しなかった場合の例外クラス。
NotFoundDataSourceException | データソースの参照名未解決例外クラス。
NotSupportMethodException | アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。
SystemConfigException | システム設定に関する例外クラス。

パッケージ jp.co.intra_mart.foundation.security.exception の説明

アクセスセキュリティ例外に関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.exception.AccessSecurityException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateException
              • class jp.co.intra_mart.foundation.security.exception.NotExistException
              • class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
            • class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
            • class jp.co.intra_mart.foundation.security.exception.NoFilterException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionException
            • class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
              • class jp.co.intra_mart.foundation.security.exception.SystemConfigException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.exception の使用

jp.co.intra_mart.foundation.security.exception を使用しているパッケージ
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
NoFilterException
HTTPリクエスト・レスポンス取得例外クラス。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.batch により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.calendar により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.exception により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityRuntimeException
アクセスセキュリティランタイム例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。
DuplicateException
作成時重複例外クラス。
NotExistException
アクセスセキュリティ情報が存在しなかった場合の例外クラス。

jp.co.intra_mart.foundation.security.license により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

jp.co.intra_mart.foundation.security.message により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.permission により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.security.exception のクラス
AccessSecurityException
アクセスセキュリティの基本となる例外クラス。
AccessSecurityExportException
エクスポート時例外クラス。
AccessSecurityImportException
インポート時例外クラス。
AccessSecurityListenerExcpetion
アクセスセキュリティリスナーの例外クラス。
AccessSecurityReadException
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityWriteException
アクセスセキュリティ情報の更新例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SystemConfigException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.exception
クラス SystemConfigException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.exception.FoundationRuntimeException
                    拡張 jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
                        拡張 jp.co.intra_mart.foundation.security.exception.SystemConfigException
すべての実装インタフェース:
Serializable
public class SystemConfigException
extends AccessSecurityRuntimeException

システム設定に関する例外クラス。

システム設定が正しく設定されていない場合にスローされる。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SystemConfigException()
コンストラクタ。
SystemConfigException(String message)
コンストラクタ。
SystemConfigException(String message, Throwable cause)
コンストラクタ。
SystemConfigException(Throwable cause)
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemConfigException

public SystemConfigException()
コンストラクタ。

SystemConfigException

public SystemConfigException(String message)
コンストラクタ。

パラメータ:
message - 例外メッセージ

SystemConfigException

public SystemConfigException(String message,
                             Throwable cause)
コンストラクタ。

パラメータ:
message - 例外メッセージ
cause - 原因となる例外

SystemConfigException

public SystemConfigException(Throwable cause)
コンストラクタ。

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter の使用

jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter の使用

jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.SessionFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.SessionFilter の使用

jp.co.intra_mart.foundation.security.filter.SessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.filter.URLAccessFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.filter.URLAccessFilter の使用

jp.co.intra_mart.foundation.security.filter.URLAccessFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.filter (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.filter
クラス
RequestCharacterEncodingFilter
ResponseCharacterEncodingFilter
SessionFilter
URLAccessFilter


jp.co.intra_mart.foundation.security.filter (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.filter

アクセスセキュリティのフィルタに関連するクラスを提供します。

参照:
説明

クラスの概要
RequestCharacterEncodingFilter | リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
ResponseCharacterEncodingFilter | レスポンスの文字エンコーディングを自動解決するフィルタです。
SessionFilter | セッションフィルタ。
URLAccessFilter | URLアクセスフィルタ。

パッケージ jp.co.intra_mart.foundation.security.filter の説明

アクセスセキュリティのフィルタに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.filter クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.filter の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
      • class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
    • class jp.co.intra_mart.foundation.security.filter.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.security.filter.URLAccessFilter (implements javax.servlet.Filter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.filter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.filter の使用

jp.co.intra_mart.foundation.security.filter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RequestCharacterEncodingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス RequestCharacterEncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
すべての実装インタフェース:
Filter
public class RequestCharacterEncodingFilter
extends AbstractFilter

リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。 リクエストの文字エンコーディングは、 ServletRequest.setCharacterEncoding(java.lang.String) によってセットされます。
ここでSessionInfo.getEncoding() を取得できなかった場合エンコードの設定はしないで次の処理に遷移します。

バージョン:
1.0

コンストラクタの概要
RequestCharacterEncodingFilter()
メソッドの概要
 void doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain)
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RequestCharacterEncodingFilter

public RequestCharacterEncodingFilter()
メソッドの詳細

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResponseCharacterEncodingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス ResponseCharacterEncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
すべての実装インタフェース:
Filter
public class ResponseCharacterEncodingFilter
extends AbstractFilter

レスポンスの文字エンコーディングを自動解決するフィルタです。

レスポンスに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。 レスポンスの文字エンコーディングは、Content-Type 設定と共に ServletResponse.setContentType(java.lang.String) によってセットされます。

このフィルタでは、ServletResponse をラップします。 ラップされた ServletResponse に対して #setContentType(String) を 明示的に実行した場合、自動的に Content-Type を書き換えません。 このフィルタ動作によって Content-Type が自動的にセットされるのは、 ラップされた ServletResponse の #setContentType(String) が実行されていない 状態で、ServletResponse の #getOutputStream() または #getWriter() が 呼び出された場合に限られます。

このフィルタに設定可能な初期化パラメータは以下のとおりです。

mime このフィルタがContent-Typeを自動的にセットする時の MIME タイプ。標準は text/html です。

バージョン:
1.0

コンストラクタの概要
ResponseCharacterEncodingFilter()
新しくフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
void | handleInit() このフィルタを初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResponseCharacterEncodingFilter

public ResponseCharacterEncodingFilter()
新しくフィルタを作成します。

メソッドの詳細

handleInit

public void handleInit()
このフィルタを初期化します。

オーバーライド:
クラス AbstractFilter 内の handleInit
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。

このメソッドが作る HttpServletResponse は、引数 response をラップし、 #getWriter() メソッドが実行された時に #setContentType() を一度も 呼び出されていない場合、アクセスセキュリティＡＰＩを通して、 現在のセッションで有効な文字エンコーディングを自動解決し、 Content-Type をセットしてから、引数 response の #getWriter() メソッドを 呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス SessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.filter.SessionFilter
すべての実装インタフェース:
Filter
public class SessionFilter
extends Object
implements Filter

セッションフィルタ。

セッション情報の状況をチェックします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
SessionFilter()
メソッドの概要
void | destroy() 破棄します。
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
void | init(FilterConfig config) 初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionFilter

public SessionFilter()
メソッドの詳細

init

public void init(FilterConfig config)
          throws ServletException
初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタコンフィグ
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)

destroy

public void destroy()
破棄します。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLAccessFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス URLAccessFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.filter.URLAccessFilter
すべての実装インタフェース:
Filter
public class URLAccessFilter
extends Object
implements Filter

URLアクセスフィルタ。

初期パラメータで設定されたＵＲＬでフィルタを行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
URLAccessFilter()
メソッドの概要
void | destroy() 破棄します。
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタを実行します。
void | init(FilterConfig config) 初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLAccessFilter

public URLAccessFilter()
メソッドの詳細

init

public void init(FilterConfig config)
          throws ServletException
初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタコンフィグ
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
関連項目:
Filter.init(javax.servlet.FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタを実行します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
chain - フィルタチェーン
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)

destroy

public void destroy()
破棄します。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator の使用

jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.LoginGroup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.LoginGroup の使用

LoginGroup を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroup の使用

LoginGroup を返す jp.co.intra_mart.foundation.security.group のメソッド
LoginGroup | LoginGroupReaderDecorator.doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
LoginGroup | LoginGroupManager.getLoginGroup(String groupId) ログイングループ情報を取得します。
LoginGroup[] | LoginGroupManager.getLoginGroups() ログイングループの一覧を取得します。
LoginGroup | LoginGroupAccessor.getLoginGroup(String groupId) ログイングループ情報を取得します。

LoginGroup 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
LoginGroup | LoginGroupReaderDecorator.doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | LoginGroupPostWriterListener.postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | LoginGroupManager.addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupManager.updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | LoginGroupAccessor.insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | LoginGroupAccessor.updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupAccessor の使用

jp.co.intra_mart.foundation.security.group.LoginGroupAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.LoginGroupManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.LoginGroupManager の使用

LoginGroupManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroupManager の使用

LoginGroupManager を返す jp.co.intra_mart.foundation.security.group のメソッド
static LoginGroupManager LoginGroupManager.getInstance()
ログイングループマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener の使用

LoginGroupPostWriterListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での LoginGroupPostWriterListener の使用

LoginGroupPostWriterListener を実装している jp.co.intra_mart.foundation.security.group のクラス
 class MainPageImportLoginGroupPostWriterListener
ログイングループ作成時にメインページパターンを設定するリスナークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener の使用

jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator の使用

jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener の使用

jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.group.MainPagePatternInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.group.MainPagePatternInfo の使用

MainPagePatternInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group での MainPagePatternInfo の使用

MainPagePatternInfo を返す jp.co.intra_mart.foundation.security.group のメソッド
MainPagePatternInfo | LoginGroupManager.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
MainPagePatternInfo[] | LoginGroupManager.getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
MainPagePatternInfo | LoginGroupAccessor.getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。

MainPagePatternInfo 型のパラメータを持つ jp.co.intra_mart.foundation.security.group のメソッド
void | MainPageImportLoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | MainPageImportLoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupQueryWriterListener.queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | LoginGroupQueryWriterListener.queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。
void | LoginGroupPostWriterListener.postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | LoginGroupPostWriterListener.postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
void | LoginGroupManager.addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupManager.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | LoginGroupAccessor.insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | LoginGroupAccessor.updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


GroupSuperUserAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserAccessor

public interface GroupSuperUserAccessor

グループ管理者アクセッサインタフェース。

グループ管理者情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteSuperUser(String groupId) グループ管理者情報を削除します。
SuperUser | getSuperUser(String groupId) グループ管理者情報を取得します。
void | init(Map params) グループ管理者アクセッサを初期化します。
void | insertSuperUser(String groupId, SuperUser superUser) グループ管理者情報を新規追加します。
void | updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。

メソッドの詳細

deleteSuperUser

public void deleteSuperUser(String groupId)
                     throws AccessSecurityWriteException,
                            NotExistException
グループ管理者情報を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - グループ管理者情報の削除に失敗した場合にスローされます。
NotExistException - 削除するグループ管理者が存在しない場合にスローされます。

getSuperUser

public SuperUser getSuperUser(String groupId)
                       throws AccessSecurityReadException
グループ管理者情報を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
グループ管理者情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - グループ管理者情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
グループ管理者アクセッサを初期化します。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertSuperUser

public void insertSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityWriteException,
                            DuplicateException
グループ管理者情報を新規追加します。

パラメータ:
groupId - ログイングループID
superUser - グループ管理者情報
例外:
AccessSecurityWriteException - グループ管理者情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するグループ管理者が既に存在した場合にスローされます。

updateSuperUser

public void updateSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityWriteException,
                            NotExistException
グループ管理者情報を更新します。

パラメータ:
groupId - ログイングループID
superUser - グループ管理者情報
例外:
AccessSecurityWriteException - グループ管理者情報の更新に失敗した場合にスローされます。
NotExistException - 更新するグループ管理者が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserPostWriterListener

public interface GroupSuperUserPostWriterListener

グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) グループ管理者リスナーの初期化。
void | postCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId) グループ管理者情報をデータストアから削除した直後にコールされます。
void | postUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
グループ管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       SuperUser superUser)
グループ管理者情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 作成されたグループ管理者情報

postUpdate

public void postUpdate(String groupId,
                       SuperUser superUser)
グループ管理者情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 更新されたグループ管理者情報

postDelete

public void postDelete(String groupId)
グループ管理者情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserQueryWriterListener

public interface GroupSuperUserQueryWriterListener

グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) グループ管理者リスナーの初期化。
void | queryCreate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId) グループ管理者情報をデータストアから削除する直前にコールされます。
void | queryUpdate(String groupId, SuperUser superUser) グループ管理者情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
グループ管理者リスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        SuperUser superUser)
グループ管理者情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 作成されるグループ管理者情報
戻り値:
グループ管理者情報

queryUpdate

public void queryUpdate(String groupId,
                        SuperUser superUser)
グループ管理者情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
superUser - 更新されるグループ管理者情報

queryDelete

public void queryDelete(String groupId)
グループ管理者情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSuperUserReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース GroupSuperUserReaderDecorator

public interface GroupSuperUserReaderDecorator

管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
SuperUser | doDecoration(String groupId, SuperUser superUser) アカウントをデータストアからの読み込み直後にコールされます。
void | init(Map params) 管理者デコレータの初期化。

メソッドの詳細

init

public void init(Map params)
管理者デコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public SuperUser doDecoration(String groupId,
                              SuperUser superUser)
アカウントをデータストアからの読み込み直後にコールされます。

引数のgroupIdがnullの場合はシステム管理者の管理者情報を拡張して返却します。
引数のgroupIdがnullのでない場合はグループ管理者の管理者情報を拡張して返却します。

パラメータ:
groupId - ログイングループID
superUser - 読み込みが行われた管理者情報
戻り値:
拡張された管理者情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス LoginGroup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.LoginGroup
すべての実装インタフェース:
LocaleProvider, Serializable
public class LoginGroup
extends Object
implements LocaleProvider, Serializable

ログイングループ・モデル。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager, 直列化された形式

コンストラクタの概要
protected | LoginGroup() コンストラクタ。
 | LoginGroup(String groupId) コンストラクタ。
メソッドの概要
boolean | equals(Object loginGroup) オブジェクトの比較。
String | getColorPatternId() カラーパターンIDを取得します。
String | getEncoding() エンコーディングを取得します。
Locale | getLocale() ロケールを取得します。
int | getLockCount() アカウントをロックするログイン失敗回数を取得します。
int | getLockTerm() アカウントをロックする期間を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
int | hashCode() ハッシュコードを取得します。
void | setColorPatternId(String colorPattrenId) カラーパターンIDを設定します。
void | setEncoding(String encoding) エンコーディングを設定します。
void | setLocale(Locale locale) ロケールを設定します。
void | setLockCount(int count) アカウントをロックするログイン失敗回数を設定します。
void | setLockTerm(int term) アカウントをロックする期間を設定します。
protected void | setLoginGroupId(String groupId) ログイングループIDを設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroup

protected LoginGroup()
コンストラクタ。

LoginGroup

public LoginGroup(String groupId)
コンストラクタ。

パラメータ:
groupId - ログイングループID
メソッドの詳細

equals

public boolean equals(Object loginGroup)
オブジェクトの比較。 指定されたオブジェクトとこのモデルが等しいかどうかを比較します。

パラメータ:
loginGroup - モデルと等しいかどうかを比較するオブジェクト
戻り値:
指定されたオブジェクトがこのモデルと等しい場合は true
関連項目:
Object.equals(Object)

getEncoding

public String getEncoding()
エンコーディングを取得します。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング
関連項目:
LocaleProvider.getEncoding()

getLocale

public Locale getLocale()
ロケールを取得します。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール
関連項目:
LocaleProvider.getLocale()

getLockCount

public int getLockCount()
アカウントをロックするログイン失敗回数を取得します。

戻り値:
アカウントをロックするログイン失敗回数
アカウントロックを行わない場合は0を返却します。

getLockTerm

public int getLockTerm()
アカウントをロックする期間を取得します。

戻り値:
アカウントをロックする期間（分）
ロックする期間が設定されていない場合は0が返却されます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setEncoding

public void setEncoding(String encoding)
エンコーディングを設定します。

パラメータ:
encoding - エンコーディング

setLocale

public void setLocale(Locale locale)
ロケールを設定します。

パラメータ:
locale - ロケール名
関連項目:
setLocale(Locale)

setLockCount

public void setLockCount(int count)
アカウントをロックするログイン失敗回数を設定します。

設定できる値は、0以上です。
0が設定された場合はアカウントロックを行ないません。

パラメータ:
count - アカウントをロックするログイン失敗回数

setLockTerm

public void setLockTerm(int term)
アカウントをロックする期間を設定します。

設定できる値は、0以上です。
アカウントがロックされた場合の、ロック解除までの時間を分単位で設定します。
0が設定された場合は、自動的にアカウントロックは解除されません。

パラメータ:
term - アカウントをロックする期間

setLoginGroupId

protected void setLoginGroupId(String groupId)
ログイングループIDを設定します。

パラメータ:
groupId - ログイングループID

setColorPatternId

public void setColorPatternId(String colorPattrenId)
カラーパターンIDを設定します。

パラメータ:
colorPattrenId - カラーパターンID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LoginGroupAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupAccessor

public interface LoginGroupAccessor

ログイングループアクセッサインタフェース。

ログイングループ情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteLoginGroup(String groupId) ログイングループを削除します。
void | deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
LoginGroup | getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | getLoginGroupIds() ログイングループIDの一覧を取得します。
MainPagePatternInfo | getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
void | init(Map params) ログイングアクセッサの初期化。
void | insertLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | insertMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | updateLoginGroup(LoginGroup loginGroup) ログイングループを更新します。
void | updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。

メソッドの詳細

deleteLoginGroup

public void deleteLoginGroup(String groupId)
                      throws AccessSecurityWriteException,
                             NotExistException
ログイングループを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - ログイングループ情報の削除に失敗した場合にスローされます。
NotExistException - 削除するログイングループ情報が存在しない場合にスローされます。

deleteMainPagePattern

public void deleteMainPagePattern(String groupId,
                                  String mainPagePatternId)
                           throws AccessSecurityWriteException,
                                  NotExistException
メインページパターンを削除します。

ログイングループに紐付くメインページパターンを削除します。

パラメータ:
groupId - ログイングループID
mainPagePatternId - メインページパターンID
例外:
AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
NotExistException - 削除するメインページパターン情報が存在しない場合にスローされます。

getLoginGroup

public LoginGroup getLoginGroup(String groupId)
                         throws AccessSecurityReadException
ログイングループ情報を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
ログイングループ情報
存在しない場合は、nullを返却します。
例外:
AccessSecurityReadException - ログイングループ情報の取得に失敗した場合にスローされます。

getLoginGroupIds

public String[] getLoginGroupIds()
                          throws AccessSecurityReadException
ログイングループIDの一覧を取得します。

戻り値:
ログイングループIDの配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - ログイングループ情報の取得に失敗した場合にスローされます。

getMainPagePattern

public MainPagePatternInfo getMainPagePattern(String groupId,
                                              String mainPagePatternId)
                                       throws AccessSecurityReadException
メインページパターンを取得します。

パラメータ:
groupId - ログイングループID
mainPagePatternId - メインページパターンID
戻り値:
メインパターン情報
例外:
AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。

getMainPagePatternIds

public String[] getMainPagePatternIds(String groupId)
                               throws AccessSecurityReadException
メインページパターンIDの一覧を取得します。

ログイングループに紐付くメインページパターンIDの一覧を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メインページパターンIDの配列
存在しない場合は、空の配列を返却します。
例外:
AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。

init

public void init(Map params)
ログイングアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertLoginGroup

public void insertLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityWriteException,
                             DuplicateException
ログイングループを新規追加します。

パラメータ:
loginGroup - ログイングループ情報
例外:
AccessSecurityWriteException - ログイングループ情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するログイングループ情報が既に存在した場合にスローされます。

insertMainPagePattern

public void insertMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityWriteException,
                                  DuplicateException
メインページパターンを新規追加します。

ログイングループに紐付くメインページパターンを新規追加します。

パラメータ:
groupId - ログイングループID
mainPagePatternInfo -
例外:
AccessSecurityWriteException - メインページパターン情報の作成に失敗した場合にスローされます。
DuplicateException - 追加するメインページパターン情報が既に存在した場合にスローされます。

updateLoginGroup

public void updateLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityWriteException,
                             NotExistException
ログイングループを更新します。

パラメータ:
loginGroup - ログイングループ情報
例外:
AccessSecurityWriteException - ログイングループ情報の更新に失敗した場合にスローされます。
NotExistException - 更新するログイングループ情報が存在しない場合にスローされます。

updateMainPagePattern

public void updateMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityWriteException,
                                  NotExistException
メインページパターンを更新します。

ログイングループに紐付くメインページパターンを更新します。

パラメータ:
groupId - ログイングループID
mainPagePatternInfo -
例外:
AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
NotExistException - 更新するメインページパターン情報が存在しない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス LoginGroupManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.LoginGroupManager
public class LoginGroupManager
extends Object

ログイングループマネージャクラス。

ログイングループ情報を操作を行います。
ログイングループマネージャでは、以下の操作が可能です。

  • ログイングループの追加、更新、削除。
  • ログイングループへのグループ管理者の追加、更新、削除。
  • ログイングループへのメインページパターンの追加、更新、削除。

    • 導入されたバージョン:
    5.0
    バージョン:
    1.0
    関連項目:
    LoginGroup, SuperUser, MainPagePatternInfo

    メソッドの概要
void | addLoginGroup(LoginGroup loginGroup) ログイングループを新規追加します。
void | addMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを新規追加します。
void | addSuperUser(String groupId, SuperUser superUser) グループ管理者を新規追加します。
static void | clearInstance() ログイングループマネージャのインスタンスを初期化します。
int | countLoginGroups() ログイングループ数を取得します。
void | deleteLoginGroup(String groupId) ログイングループを削除します。
void | deleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを削除します。
void | deleteMainPagePatterns(String groupId) メインページパターンをすべて削除します。
void | deleteSuperUser(String groupId) グループ管理者情報を削除します。
static LoginGroupManager | getInstance() ログイングループマネージャのインスタンスを取得します。
LoginGroup | getLoginGroup(String groupId) ログイングループ情報を取得します。
String[] | getLoginGroupIds() ログイングループIDの一覧を取得します。
LoginGroup[] | getLoginGroups() ログイングループの一覧を取得します。
MainPagePatternInfo | getMainPagePattern(String groupId, String mainPagePatternId) メインページパターンを取得します。
String[] | getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
MainPagePatternInfo[] | getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
SuperUser | getSuperUser(String groupId) グループ管理者情報を取得します。
void | updateLoginGroup(LoginGroup loginGroup) ログイングループ情報を更新します。
void | updateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターンを更新します。
void | updateSuperUser(String groupId, SuperUser superUser) グループ管理者情報を更新します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    メソッドの詳細

    clearInstance

    public static void clearInstance()
    ログイングループマネージャのインスタンスを初期化します。

    アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

    アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
    通常、このメソッドを使用する必要はありません。

    getInstance

    public static LoginGroupManager getInstance()
    ログイングループマネージャのインスタンスを取得します。

    戻り値:
    ログイングループマネージャのインスタンス

    addLoginGroup

    public void addLoginGroup(LoginGroup loginGroup)
                   throws AccessSecurityException
    ログイングループを新規追加します。

    ログイングループを新規に追加します。
    ログイングループIDはユニークなものを設定してください。

    パラメータ:
    loginGroup - ログイングループ情報
    例外:
    AccessSecurityException - ログイングループ情報の追加に失敗した場合にスローされます。

    addMainPagePattern

    public void addMainPagePattern(String groupId,
                               MainPagePatternInfo mainPagePatternInfo)
                        throws AccessSecurityException
    メインページパターンを新規追加します。

    ログイングループに対してメインページパターンを新規に追加します。
    メインページパターンIDはログイングループ単位でユニークなものを設定してください。
    存在しないログイングループに対して、メインページパターンは追加できません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternInfo - メインページパターン情報
    例外:
    AccessSecurityWriteException - メインページパターン情報の追加に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    addSuperUser

    public void addSuperUser(String groupId,
                         SuperUser superUser)
                  throws AccessSecurityException
    グループ管理者を新規追加します。

    ログイングループに対してグループ管理者を新規に追加します。
    存在しないログイングループに対して、グループ管理者は追加できません。

    パラメータ:
    groupId - ログイングループID
    superUser - グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の追加に失敗した場合、または引数が不正だった場合にスローされます。

    countLoginGroups

    public int countLoginGroups()
                     throws AccessSecurityException
    ログイングループ数を取得します。

    現在登録されているログイングループの数を返却します。

    戻り値:
    ログイングループ数
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    deleteMainPagePatterns

    public void deleteMainPagePatterns(String groupId)
                            throws AccessSecurityException
    メインページパターンをすべて削除します。

    ログイングループに属するすべてのメインページパターンを削除します。
    存在しないログイングループに対して、メインページパターンの削除はできません。

    パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合にスローされます。
    AccessSecurityException

    deleteLoginGroup

    public void deleteLoginGroup(String groupId)
                      throws AccessSecurityException
    ログイングループを削除します。 ログイングループに属するすべてのアクセスセキュリティ情報も同時に削除されます。

    削除対象情報：
  • メインページパターン
  • グループ管理者
  • ロール
  • アカウント
  • メニュー
  • カレンダ
  • アクセスコントローラ
  • バッチ

    • パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityException - ログイングループ情報の削除に失敗した場合にスローされます。

    deleteMainPagePattern

    public void deleteMainPagePattern(String groupId,
                                  String mainPagePatternId)
                           throws AccessSecurityException
    メインページパターンを削除します。

    ログイングループに属するメインページパターンを削除します。
    存在しないログイングループに対して、メインページパターンの削除はできません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternId - メインページパターンID
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合に、または引数が不正だった場合にスローされます。
    AccessSecurityException

    deleteSuperUser

    public void deleteSuperUser(String groupId)
                     throws AccessSecurityException
    グループ管理者情報を削除します。

    ログイングループに属するグループ管理者を削除します。
    存在しないログイングループに対して、グループ管理者の削除はできません。

    パラメータ:
    groupId - ログイングループID
    例外:
    AccessSecurityException - グループ管理者情報の削除に失敗した場合にスローされます。

    getLoginGroup

    public LoginGroup getLoginGroup(String groupId)
                         throws AccessSecurityException
    ログイングループ情報を取得します。

    引数で指定したログイングループIDのログイングループ情報を取得します。
    指定したログイングループIDのログイングループが存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングルーID
    戻り値:
    ログイングループ情報
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getLoginGroupIds

    public String[] getLoginGroupIds()
                          throws AccessSecurityException
    ログイングループIDの一覧を取得します。

    現在登録されているログイングループのログイングループIDの一覧を取得します。
    ログイングループが一件も存在しない場合は、空の配列を返却します。

    戻り値:
    ログイングループIDの配列
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getLoginGroups

    public LoginGroup[] getLoginGroups()
                            throws AccessSecurityException
    ログイングループの一覧を取得します。

    現在登録されているログイングループの一覧を取得します。
    ログイングループが一件も存在しない場合は、空の配列を返却します。

    戻り値:
    ログイングループ情報の配列
    例外:
    AccessSecurityException - ログイングループ情報の取得に失敗した場合にスローされます。

    getMainPagePattern

    public MainPagePatternInfo getMainPagePattern(String groupId,
                                              String mainPagePatternId)
                                       throws AccessSecurityException
    メインページパターンを取得します。

    ログイングループに属するメインページパターンを取得します。
    ログイングループに属するメインページパターンIDが存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternId - メインページパターンID
    戻り値:
    メインページパターン情報
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    getMainPagePatternIds

    public String[] getMainPagePatternIds(String groupId)
                               throws AccessSecurityException
    メインページパターンIDの一覧を取得します。

    ログイングループに属するメインパターンIDの一覧を取得します。
    ログイングループに属するメインパターンが一件も存在しない場合は、空の配列を返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    メインページパターンIDの配列
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。
    AccessSecurityException

    getMainPagePatterns

    public MainPagePatternInfo[] getMainPagePatterns(String groupId)
                                          throws AccessSecurityException
    メインページパターンの一覧を取得します。

    ログイングループに属するメインパターンの一覧を取得します。
    ログイングループに属するメインパターンが一件も存在しない場合は、空の配列を返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    メインページパターン情報の配列
    例外:
    AccessSecurityReadException - メインページパターン情報の取得に失敗した場合にスローされます。
    AccessSecurityException

    getSuperUser

    public SuperUser getSuperUser(String groupId)
                       throws AccessSecurityException
    グループ管理者情報を取得します。

    ログイングループに属するグループ管理者を取得します。
    ログイングループに属するグループ管理者が存在しない場合は、nullを返却します。

    パラメータ:
    groupId - ログイングループID
    戻り値:
    グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の取得に失敗した場合にスローされます。

    updateLoginGroup

    public void updateLoginGroup(LoginGroup loginGroup)
                      throws AccessSecurityException
    ログイングループ情報を更新します。

    既に登録されているログイングループを更新します。
    存在しないログイングループに対して、ログイングループの更新はできません。

    パラメータ:
    loginGroup - ログイングループID
    例外:
    AccessSecurityException - ログイングループ情報の更新に失敗した場合にスローされます。

    updateMainPagePattern

    public void updateMainPagePattern(String groupId,
                                  MainPagePatternInfo mainPagePatternInfo)
                           throws AccessSecurityException
    メインページパターンを更新します。

    既に登録されているログイングループに属するメインページパターンを更新します。
    存在しないログイングループに対して、メインページパターンの更新はできません。

    パラメータ:
    groupId - ログイングループID
    mainPagePatternInfo -
    例外:
    AccessSecurityWriteException - メインページパターン情報の更新に失敗した場合、または引数が不正だった場合にスローされます。
    AccessSecurityException

    updateSuperUser

    public void updateSuperUser(String groupId,
                            SuperUser superUser)
                     throws AccessSecurityException
    グループ管理者情報を更新します。

    既に登録されているログイングループに属するグループ管理者を更新します。
    存在しないログイングループに対して、グループ管理者の更新はできません。

    パラメータ:
    groupId - ログイングループID
    superUser - グループ管理者情報
    例外:
    AccessSecurityException - グループ管理者情報の更新に失敗した場合、または引数が不正だった場合にスローされます。
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart(R)
    5.0
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupPostWriterListener

既知の実装クラスの一覧:
MainPageImportLoginGroupPostWriterListener
public interface LoginGroupPostWriterListener

ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager

メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateLoginGroup

public void postCreateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成した直後にコールされます。

パラメータ:
loginGroup - 作成されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateMainPagePattern

public void postCreateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteLoginGroup

public void postDeleteLoginGroup(String groupId)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - 削除されたログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteMainPagePattern

public void postDeleteMainPagePattern(String groupId,
                                      String mainPagePatternId)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されたメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateLoginGroup

public void postUpdateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新した直後にコールされます。

パラメータ:
loginGroup - 更新されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateMainPagePattern

public void postUpdateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupQueryWriterListener

public interface LoginGroupQueryWriterListener

ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
LoginGroupManager

メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | queryCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成する直前にコールされます。
void | queryCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成する前にコールされます。
void | queryDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除する直前にコールされます。
void | queryDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除する前にコールされます。
void | queryUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新する直前にコールされます。
void | queryUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新する前にコールされます。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateLoginGroup

public void queryCreateLoginGroup(LoginGroup loginGroup)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成する直前にコールされます。

パラメータ:
loginGroup - 作成されるログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateMainPagePattern

public void queryCreateMainPagePattern(String groupId,
                                       MainPagePatternInfo mainPagePatternInfo)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されるメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteLoginGroup

public void queryDeleteLoginGroup(String groupId)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - 削除されるログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteMainPagePattern

public void queryDeleteMainPagePattern(String groupId,
                                       String mainPagePatternId)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されるメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateLoginGroup

public void queryUpdateLoginGroup(LoginGroup loginGroup)
                           throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新する直前にコールされます。

パラメータ:
loginGroup - 更新されるログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateMainPagePattern

public void queryUpdateMainPagePattern(String groupId,
                                       MainPagePatternInfo mainPagePatternInfo)
                                throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新する前にコールされます。

パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されるメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
インタフェース LoginGroupReaderDecorator

public interface LoginGroupReaderDecorator

ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
LoginGroup | doDecoration(LoginGroup loginGroup) ログイングループをデータストアからの読み込み直後にコールされます。
void | init(Map params) ログイングループデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
ログイングループデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public LoginGroup doDecoration(LoginGroup loginGroup)
ログイングループをデータストアからの読み込み直後にコールされます。

パラメータ:
loginGroup - 読み込みが行われたログイングループ情報
戻り値:
拡張されたログイングループ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MainPageImportLoginGroupPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス MainPageImportLoginGroupPostWriterListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener
すべての実装インタフェース:
LoginGroupPostWriterListener
public class MainPageImportLoginGroupPostWriterListener
extends Object
implements LoginGroupPostWriterListener

ログイングループ作成時にメインページパターンを設定するリスナークラス。

ログイングループ作成時に設定されたメインページパターン情報を追加します。
デフォルトの設定ファイルはストレージサーバ/system/basic/init-main-page.xmlです。
初期化パラメータ(main-page-file)で見込む設定ファイルを変更できます。
初期化パラメータには、ストレージサーバからの相対パスで指定してください。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MainPageImportLoginGroupPostWriterListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ログイングループ書き込み時（書き込み直前）のリスナの初期化。
void | postCreateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに作成した直後にコールされます。
void | postCreateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに作成した直後にコールされます。
void | postDeleteLoginGroup(String groupId) ログイングループ情報をデータストアから削除した直後にコールされます。
void | postDeleteMainPagePattern(String groupId, String mainPagePatternId) メインページパターン情報をデータストアから削除した直後にコールされます。
void | postUpdateLoginGroup(LoginGroup loginGroup) ログイングループ情報をデータストアに更新した直後にコールされます。
void | postUpdateMainPagePattern(String groupId, MainPagePatternInfo mainPagePatternInfo) メインページパターン情報をデータストアに更新した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MainPageImportLoginGroupPostWriterListener

public MainPageImportLoginGroupPostWriterListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ログイングループ書き込み時（書き込み直前）のリスナの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース LoginGroupPostWriterListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateLoginGroup

public void postCreateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに作成した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postCreateLoginGroup
パラメータ:
loginGroup - 作成されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateMainPagePattern

public void postCreateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに作成した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postCreateMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 作成されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteLoginGroup

public void postDeleteLoginGroup(String groupId)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアから削除した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postDeleteLoginGroup
パラメータ:
groupId - 削除されたログイングループID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteMainPagePattern

public void postDeleteMainPagePattern(String groupId,
                                      String mainPagePatternId)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアから削除した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postDeleteMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternId - 削除されたメインページパターンID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateLoginGroup

public void postUpdateLoginGroup(LoginGroup loginGroup)
                          throws AccessSecurityListenerExcpetion
ログイングループ情報をデータストアに更新した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postUpdateLoginGroup
パラメータ:
loginGroup - 更新されたログイングループ情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateMainPagePattern

public void postUpdateMainPagePattern(String groupId,
                                      MainPagePatternInfo mainPagePatternInfo)
                               throws AccessSecurityListenerExcpetion
メインページパターン情報をデータストアに更新した直後にコールされます。

定義:
インタフェース LoginGroupPostWriterListener 内の postUpdateMainPagePattern
パラメータ:
groupId - 対象ログイングループID
mainPagePatternInfo - 更新されたメインページパターン情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MainPagePatternInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.group
クラス MainPagePatternInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.group.MainPagePatternInfo
すべての実装インタフェース:
Serializable
public class MainPagePatternInfo
extends Object
implements Serializable

メインページパターン情報クラス。

メインページパターン情報を保管するクラス。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MainPagePatternInfo(String mainPagePatternId)
コンストラクタ。
メソッドの概要
String | getMainPagePatternId() メインページパターンIDを取得する。
String | getMainPagePatternImageUrl() メインページパターンイメージURLを取得する。
String | getMainPagePatternUrl() メインページパターンURLを取得する。
void | setMainPagePatternImageUrl(String mainPagePatternImageUrl) メインページパターンイメージURLを設定する。
void | setMainPagePatternUrl(String mainPagePatternUrl) メインページパターンURLを設定する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MainPagePatternInfo

public MainPagePatternInfo(String mainPagePatternId)
コンストラクタ。

パラメータ:
mainPagePatternId - メインページパターンID
メソッドの詳細

getMainPagePatternId

public String getMainPagePatternId()
メインページパターンIDを取得する。

戻り値:
メインページパターンID

getMainPagePatternImageUrl

public String getMainPagePatternImageUrl()
メインページパターンイメージURLを取得する。

戻り値:
メインページパターンイメージURL。

getMainPagePatternUrl

public String getMainPagePatternUrl()
メインページパターンURLを取得する。

戻り値:
メインページパターンURL。

setMainPagePatternImageUrl

public void setMainPagePatternImageUrl(String mainPagePatternImageUrl)
メインページパターンイメージURLを設定する。

パラメータ:
mainPagePatternImageUrl - メインページパターンイメージURL。

setMainPagePatternUrl

public void setMainPagePatternUrl(String mainPagePatternUrl)
メインページパターンURLを設定する。

パラメータ:
mainPagePatternUrl - メインページパターンURL。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.group (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.group
インタフェース
GroupSuperUserAccessor
GroupSuperUserPostWriterListener
GroupSuperUserQueryWriterListener
GroupSuperUserReaderDecorator
LoginGroupAccessor
LoginGroupPostWriterListener
LoginGroupQueryWriterListener
LoginGroupReaderDecorator
クラス
LoginGroup
LoginGroupManager
MainPageImportLoginGroupPostWriterListener
MainPagePatternInfo


jp.co.intra_mart.foundation.security.group (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.group

グループ管理者に関連するクラスを提供します。

参照:
説明

インタフェースの概要
GroupSuperUserAccessor | グループ管理者アクセッサインタフェース。
GroupSuperUserPostWriterListener | グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
GroupSuperUserQueryWriterListener | グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
GroupSuperUserReaderDecorator | 管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
LoginGroupAccessor | ログイングループアクセッサインタフェース。
LoginGroupPostWriterListener | ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
LoginGroupQueryWriterListener | ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
LoginGroupReaderDecorator | ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
LoginGroup | ログイングループ・モデル。
LoginGroupManager | ログイングループマネージャクラス。
MainPageImportLoginGroupPostWriterListener | ログイングループ作成時にメインページパターンを設定するリスナークラス。
MainPagePatternInfo | メインページパターン情報クラス。

パッケージ jp.co.intra_mart.foundation.security.group の説明

グループ管理者に関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.group クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.group の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.group.LoginGroup (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.group.LoginGroupManager
    • class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener (implements jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener)
    • class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.group の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.group の使用

jp.co.intra_mart.foundation.security.group を使用しているパッケージ
jp.co.intra_mart.foundation.security.group グループ管理者に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security.group のクラス
LoginGroup
ログイングループ・モデル。
LoginGroupManager
ログイングループマネージャクラス。
LoginGroupPostWriterListener
ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MainPagePatternInfo
メインページパターン情報クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.license.ApplicationInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.license.ApplicationInfo の使用

ApplicationInfo を使用しているパッケージ
jp.co.intra_mart.foundation.security.license ライセンスに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.license での ApplicationInfo の使用

ApplicationInfo を返す jp.co.intra_mart.foundation.security.license のメソッド
static ApplicationInfo | LicenseManager.getApplication(String applicaionId) アプリケーション情報を取得します。
static ApplicationInfo[] | LicenseManager.getApplications() アプリケーション情報の一覧を取得します。
static ApplicationInfo | LicenseManager.getProduct() システム情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.license.LicenseManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.license.LicenseManager の使用

jp.co.intra_mart.foundation.security.license.LicenseManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ApplicationInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.license
インタフェース ApplicationInfo

public interface ApplicationInfo

アプリケーション情報のインタフェース。

インストールされているアプリケーションの情報を提供するインタフェース

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
long | getExpiredDate() 試用期限の日付を取得します。
String | getId() アプリケーションIDを取得します。
long | getInstallDate() インストールされた日付を取得します。
double | getLicense() アプリケーションライセンスが登録されているアカウント数を取得する。
long | getLimitedDate() 使用期限の日付を取得します。
double | getMaxLicense() アプリケーションの最大登録可能なラインセンス数を取得します。
double | getMaxProcess() アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
String | getName() アプリケーション名を取得します。
String | getPackageVersion() パッケージバージョンを取得します。
String[] | getProperties(String key) インストール情報を取得します。
String | getProperty(String key) インストール情報を取得します。
int | getSerialNo() シリアルナンバーを取得します。
String | getType() アプリケーションタイプを取得します。
String | getVersion() バージョンを取得します。
boolean | isExpired() 試用期限が切れているかどうかを判定します。
boolean | isFree() ライセンスフリーであるかどうかを判定します。
boolean | isLimited() 期限付きライセンスであるかどうかを判定します。
boolean | isOpenSource() オープンソースであるかどうかを判定します。
boolean | isRuntime() ランタイムライセンスであるかどうかを判定します。
boolean | isTrial() 試用版であるかどうかを判定します。

メソッドの詳細

getId

public String getId()
アプリケーションIDを取得します。

戻り値:
アプリケーションID

getName

public String getName()
アプリケーション名を取得します。

戻り値:
アプリケーション名

getType

public String getType()
アプリケーションタイプを取得します。

戻り値:
アプリケーションタイプ

getVersion

public String getVersion()
バージョンを取得します。

戻り値:
バージョン

getPackageVersion

public String getPackageVersion()
パッケージバージョンを取得します。

戻り値:
パッケージバージョン

getSerialNo

public int getSerialNo()
シリアルナンバーを取得します。

戻り値:
シリアルナンバー

getMaxProcess

public double getMaxProcess()
アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
アプリケーションランタイムの最大使用可能なラインセンス数

getMaxLicense

public double getMaxLicense()
アプリケーションの最大登録可能なラインセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
アプリケーションの最大登録可能なライセンス数

isTrial

public boolean isTrial()
試用版であるかどうかを判定します。

戻り値:
true : 試用版 / false : 製品版

isFree

public boolean isFree()
ライセンスフリーであるかどうかを判定します。

戻り値:
true : ライセンスフリー / false : ライセンス必須

isExpired

public boolean isExpired()
試用期限が切れているかどうかを判定します。

戻り値:
true : 試用期限が切れている / false : 試用期限内

isLimited

public boolean isLimited()
期限付きライセンスであるかどうかを判定します。

戻り値:
true : 期限付きライセンス / false : 通常ライセンス

isRuntime

public boolean isRuntime()
ランタイムライセンスであるかどうかを判定します。

戻り値:
true : ランタイムライセンス / false : 通常ライセンス

isOpenSource

public boolean isOpenSource()
オープンソースであるかどうかを判定します。

戻り値:
true : オープンソース / false : オープンソースではない

getInstallDate

public long getInstallDate()
インストールされた日付を取得します。
単位はミリ秒で返却します。

戻り値:
インストールされた日付（ミリ秒）

getExpiredDate

public long getExpiredDate()
試用期限の日付を取得します。
単位はミリ秒で返却します。

戻り値:
試用期限の日付（ミリ秒）

getLimitedDate

public long getLimitedDate()
使用期限の日付を取得します。
単位はミリ秒で返却します。

戻り値:
使用期限の日付（ミリ秒）

getProperty

public String getProperty(String key)
インストール情報を取得します。

パラメータ:
key - インストール情報のキー
戻り値:
キーに対応するインストール情報

getProperties

public String[] getProperties(String key)
インストール情報を取得します。

パラメータ:
key - インストール情報のキー
戻り値:
キーに対応するインストール情報の配列

getLicense

public double getLicense()
アプリケーションライセンスが登録されているアカウント数を取得する。

戻り値:
登録されているアカウント数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LicenseManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.license
クラス LicenseManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.license.LicenseManager
public final class LicenseManager
extends Object

ライセンス・マネージャクラス。 イントラマートのライセンスを管理するマネージャクラスを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
ApplicationInfo

コンストラクタの概要
LicenseManager(String groupId)
コンストラクタ。
メソッドの概要
void | deleteAccountLicense(String userId) 指定されたユーザのライセンスを削除します。
void | deleteApplicationLicenseFromAccount(String userId, String applicationId) アプリケーションライセンスをアカウントから削除します。
static ApplicationInfo | getApplication(String applicaionId) アプリケーション情報を取得します。
static double | getApplicationLicense(String applicaionId) アプリケーションの登録ユーザ数を取得します。
static ApplicationInfo[] | getApplications() アプリケーション情報の一覧を取得します。
double | getLicense() グループ内で登録されているライセンス数を取得します。
double | getMaxLicense() ログイングループ内の最大登録可能ライセンス数を取得します。
static ApplicationInfo | getProduct() システム情報を取得します。
String[] | getRegisteredAccountLicenses() ログイングループにライセンス登録されているすべてのユーザIDを返します。
String[] | getRegisteredApplicationLicensesToAccount(String userId) アカウントに登録されているアプリケーションライセンスの一覧を取得します。
static double | getSystemLicense() システム全体の登録ライセンス数。
static double | getSystemMaxLicense() システム全体のライセンス数。
boolean | isRegisteredAccountLicense(String userId) 指定されたユーザがライセンスに登録されているかどうかをチェックします。
boolean | isRegisteredApplicationLicenseToAccount(String userId, String applicationId) アカウントにアプリケーションライセンスが登録されてるか検証します。
boolean | registerAccountLicense(String userId) ライセンス登録します。
boolean | registerApplicationLicenseToAccount(String userId, String applicationId) アプリケーションライセンスをアカウントに登録します。
boolean | setMaxLicense(double maxLicense) ログイングループ内の最大登録可能ライセンス数を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LicenseManager

public LicenseManager(String groupId)
               throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。
メソッドの詳細

getApplication

public static ApplicationInfo getApplication(String applicaionId)
                                      throws AccessSecurityException
アプリケーション情報を取得します。
引数に指定されたアプリケーションの情報を取得します。

パラメータ:
applicaionId - アプリケーションID
戻り値:
アプリケーション情報
指定したアプリケーションが存在しない場合はnullを返します。
例外:
AccessSecurityException - アプリケーション情報の取得に失敗した場合にスローされます。

getApplicationLicense

public static double getApplicationLicense(String applicaionId)
                                    throws AccessSecurityException
アプリケーションの登録ユーザ数を取得します。

引数に指定されたアプリケーションIDを持つユーザの数を取得します。

パラメータ:
applicaionId - アプリケーションID
戻り値:
アプリケーションIDを持つユーザの数
指定したアプリケーションが存在しない場合は0
例外:
AccessSecurityException

getApplications

public static ApplicationInfo[] getApplications()
                                         throws AccessSecurityException
アプリケーション情報の一覧を取得します。

戻り値:
アプリケーション情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getProduct

public static ApplicationInfo getProduct()
                                  throws AccessSecurityException
システム情報を取得します。

戻り値:
ApplicationInfo システム情報
システム情報の取得に失敗した場合はnull システム情報の取得に失敗した場合にスローされます。
例外:
AccessSecurityException

getSystemLicense

public static double getSystemLicense()
                               throws AccessSecurityException
システム全体の登録ライセンス数。

戻り値:
システム全体の登録ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getSystemMaxLicense

public static double getSystemMaxLicense()
                                  throws AccessSecurityException
システム全体のライセンス数。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
システム全体のライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

deleteAccountLicense

public void deleteAccountLicense(String userId)
                          throws AccessSecurityException
指定されたユーザのライセンスを削除します。

パラメータ:
userId - ユーザID
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

deleteApplicationLicenseFromAccount

public void deleteApplicationLicenseFromAccount(String userId,
                                                String applicationId)
                                         throws AccessSecurityException
アプリケーションライセンスをアカウントから削除します。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

getLicense

public double getLicense()
                  throws AccessSecurityException
グループ内で登録されているライセンス数を取得します。

戻り値:
登録ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMaxLicense

public double getMaxLicense()
                     throws AccessSecurityException
ログイングループ内の最大登録可能ライセンス数を取得します。
無制限の場合は Double.POSITIVE_INFINITYを返します。

戻り値:
最大登録可能ライセンス数
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getRegisteredAccountLicenses

public String[] getRegisteredAccountLicenses()
                                      throws AccessSecurityException
ログイングループにライセンス登録されているすべてのユーザIDを返します。

戻り値:
ユーザID配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getRegisteredApplicationLicensesToAccount

public String[] getRegisteredApplicationLicensesToAccount(String userId)
                                                   throws AccessSecurityException
アカウントに登録されているアプリケーションライセンスの一覧を取得します。

パラメータ:
userId - ユーザID
戻り値:
アカウントに登録されているアプリケーションライセンスの一覧
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

isRegisteredAccountLicense

public boolean isRegisteredAccountLicense(String userId)
                                   throws AccessSecurityException
指定されたユーザがライセンスに登録されているかどうかをチェックします。

パラメータ:
userId - ユーザID
戻り値:
true:登録されている場合 false:登録されていない場合
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

isRegisteredApplicationLicenseToAccount

public boolean isRegisteredApplicationLicenseToAccount(String userId,
                                                       String applicationId)
                                                throws AccessSecurityException
アカウントにアプリケーションライセンスが登録されてるか検証します。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
戻り値:
true:登録されている場合 false:登録されていない場合
例外:
AccessSecurityException - 引数が不正だった場合、または読み込み処理に失敗した場合にスローされます。

registerAccountLicense

public boolean registerAccountLicense(String userId)
                               throws AccessSecurityException
ライセンス登録します。
指定されたユーザIDとコンストラクタで指定したログイングループIDでライセンス登録をします。
最大登録可能ライセンス数とログイングループ内最大登録可能ライセンス数を調査して これを超えた場合はエラーとします。

パラメータ:
userId - ユーザID
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

registerApplicationLicenseToAccount

public boolean registerApplicationLicenseToAccount(String userId,
                                                   String applicationId)
                                            throws AccessSecurityException
アプリケーションライセンスをアカウントに登録します。

すでに登録されているアプリケーション最大登録可能ライセンス数と合わせて
最大登録可能ライセンス数を超えた場合はエラーとします。

パラメータ:
userId - ユーザID
applicationId - アプリケーションID
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 引数が不正だった場合、または書き込み処理に失敗した場合にスローされます。

setMaxLicense

public boolean setMaxLicense(double maxLicense)
                      throws AccessSecurityException
ログイングループ内の最大登録可能ライセンス数を設定します。

すでに登録されているログイングループ内最大登録可能ライセンス数の合計と合わせて
最大登録可能ライセンス数を超えた場合はエラーとします。

パラメータ:
maxLicense - 最大登録可能ライセンス数
戻り値:
true：処理成功 false：処理失敗
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.license (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.license
インタフェース
ApplicationInfo
クラス
LicenseManager


jp.co.intra_mart.foundation.security.license (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.license

ライセンスに関連するクラスを提供します。

参照:
説明

インタフェースの概要
ApplicationInfo アプリケーション情報のインタフェース。

クラスの概要
LicenseManager ライセンス・マネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.license の説明

ライセンスに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.license クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.license の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.license.LicenseManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.license.ApplicationInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.license の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.license の使用

jp.co.intra_mart.foundation.security.license を使用しているパッケージ
jp.co.intra_mart.foundation.security.license ライセンスに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.license により使用される jp.co.intra_mart.foundation.security.license のクラス
ApplicationInfo
アプリケーション情報のインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuExporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuExporter の使用

AdminMenuExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuExporter の使用

AdminMenuExporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardAdminMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuImporter の使用

AdminMenuImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuImporter の使用

AdminMenuImporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardAdminMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.AdminMenuManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.AdminMenuManager の使用

AdminMenuManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での AdminMenuManager の使用

AdminMenuManager を返す jp.co.intra_mart.foundation.security.menu のメソッド
static AdminMenuManager AdminMenuManager.getInstance()
ログイングループマネージャのインスタンスを取得します。

AdminMenuManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | StandardAdminMenuBackup.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | StandardAdminMenuBackup.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | AdminMenuImporter.doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | AdminMenuExporter.doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator の使用

jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuAccessor の使用

jp.co.intra_mart.foundation.security.menu.MenuAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuExporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuExporter の使用

MenuExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuExporter の使用

MenuExporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuImporter の使用

MenuImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuImporter の使用

MenuImporter を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class StandardMenuBackup
メニューバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuInclusion の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuInclusion の使用

MenuInclusion を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuInclusion の使用

MenuInclusion を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuInclusion[] | MenuAccessor.getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuInclusion[] | AdminMenuAccessor.getMenuInclusions() すべてのメニュー構成を取得します。

MenuInclusion 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | MenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | MenuAccessor.deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | MenuAccessor.insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | AdminMenuManager.moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | AdminMenuAccessor.deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | AdminMenuAccessor.insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuItem の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuItem の使用

MenuItem を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security での MenuItem の使用

MenuItem を返す jp.co.intra_mart.foundation.security のメソッド
 MenuItem[] SystemManager.getSystemMenu()
システムメニューを取得します。

jp.co.intra_mart.foundation.security.menu での MenuItem の使用

MenuItem を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuItem | MenuTree.getMenuItem() メニューを取得します。
MenuItem | MenuReaderDecorator.doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
MenuItem | MenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | MenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem[] | MenuManager.getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
MenuItem | MenuAccessor.getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | MenuAccessor.getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | MenuAccessor.getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
MenuItem | AdminMenuReaderDecorator.doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
MenuItem | AdminMenuManager.getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | AdminMenuManager.getMenuItems() すべてのメニューを取得します。
MenuItem | AdminMenuAccessor.getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | AdminMenuAccessor.getMenuItems() すべてのノードを取得します。

MenuItem 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
MenuItem | MenuReaderDecorator.doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | MenuQueryWriterListener.queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | MenuQueryWriterListener.queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | MenuPostWriterListener.postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | MenuPostWriterListener.postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | MenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | MenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
void | MenuAccessor.insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | MenuAccessor.updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。
MenuItem | AdminMenuReaderDecorator.doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | AdminMenuQueryWriterListener.queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | AdminMenuQueryWriterListener.queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。
void | AdminMenuPostWriterListener.postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | AdminMenuPostWriterListener.postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。
void | AdminMenuManager.addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | AdminMenuManager.updateMenuItem(MenuItem menuItem) メニューを更新します。
void | AdminMenuAccessor.insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | AdminMenuAccessor.updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。

MenuItem 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のコンストラクタ
MenuTree(MenuItem menuItem)
コンストラクタ。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuManager の使用

MenuManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuManager の使用

MenuManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | StandardMenuBackup.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | StandardMenuBackup.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | MenuImporter.doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | MenuExporter.doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener の使用

jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener の使用

jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator の使用

jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.MenuTree の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.MenuTree の使用

MenuTree を使用しているパッケージ
jp.co.intra_mart.foundation.security.menu メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.menu での MenuTree の使用

MenuTree を返す jp.co.intra_mart.foundation.security.menu のメソッド
MenuTree[] | MenuTree.getChildren() 子メニューの一覧を取得します。
MenuTree[] | MenuManager.getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree() メニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | MenuManager.getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
MenuTree[] | AdminMenuManager.getMenuTree() メニュー構成を取得します。

MenuTree 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
 void MenuTree.addChild(MenuTree menuTree)
子メニューを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener の使用

jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup の使用

jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.menu.StandardMenuBackup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.menu.StandardMenuBackup の使用

jp.co.intra_mart.foundation.security.menu.StandardMenuBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AdminMenuAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuAccessor

public interface AdminMenuAccessor

メニューアクセッサインタフェース。

メニュー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteMenuInclusion(MenuInclusion menuInclusion) メニュー構成を削除します。
void | deleteMenuItem(String menuId) 引数で渡されたノードを削除します。
String[] | getChildMenuIds(String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | getFirstMenuIds() 第一階層に属するノードを配列で取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
MenuInclusion[] | getMenuInclusions() すべてのメニュー構成を取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | getMenuItems() すべてのノードを取得します。
String | getParentMenuId(String menuId) 引数で指定されたノードの親ノードを取得します。
void | init(Map params) メニューアクセッサの初期化。
void | insertMenuInclusion(MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | insertMenuItem(MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | updateMenuItem(MenuItem menuItem) 引数で渡されたノードを更新します。

メソッドの詳細

deleteMenuInclusion

public void deleteMenuInclusion(MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を削除します。

パラメータ:
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityWriteException
引数で渡されたノードを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityWriteException

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityReadException
引数で指定されたノードの直下の子ノードを配列で取得します。

パラメータ:
menuId - メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityReadException

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityReadException
第一階層に属するノードを配列で取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityReadException

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityReadException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityReadException

getMenuInclusions

public MenuInclusion[] getMenuInclusions()
                                  throws AccessSecurityReadException
すべてのメニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityReadException

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityReadException
指定されたメニューIDに対するノードを取得します。

パラメータ:
menuId - メニューID
戻り値:
ノード
例外:
AccessSecurityReadException

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityReadException
すべてのノードを取得します。

戻り値:
ノード配列
例外:
AccessSecurityReadException

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityReadException
引数で指定されたノードの親ノードを取得します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityReadException

init

public void init(Map params)
メニューアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertMenuInclusion

public void insertMenuInclusion(MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を新規に作成します。

パラメータ:
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

insertMenuItem

public void insertMenuItem(MenuItem menuItem,
                           String parentId)
                    throws AccessSecurityWriteException
引数で渡されたノードを新規追加します。

パラメータ:
menuItem - メニューID
parentId -
例外:
AccessSecurityWriteException

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityWriteException
引数で渡されたノードを更新します。

パラメータ:
menuItem - メニュー
例外:
AccessSecurityWriteException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AdminMenuExporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuExporter

既知の実装クラスの一覧:
StandardAdminMenuBackup
public interface AdminMenuExporter

メニューエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(AdminMenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニュー情報をバックアップファイルに出力します。

パラメータ:
manager - メニューマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuImporter

既知の実装クラスの一覧:
StandardAdminMenuBackup
public interface AdminMenuImporter

メニューインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     AdminMenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を取得し、生成します。

パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuInclusion (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス AdminMenuInclusion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion
すべての実装インタフェース:
Serializable
public class AdminMenuInclusion
extends Object
implements Serializable

メニュー内包情報クラス。

メニューの親子関係を保持するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
AdminMenuInclusion(String parentMenuId, String childMenuId)
コンストラクタ。
メソッドの概要
String | getChildMenuId() 子メニューIDを取得します。
String | getParentMenuId() 親メニューIDを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdminMenuInclusion

public AdminMenuInclusion(String parentMenuId,
                          String childMenuId)
コンストラクタ。

メソッドの詳細

getChildMenuId

public String getChildMenuId()
子メニューIDを取得します。

戻り値:
子メニューID

getParentMenuId

public String getParentMenuId()
親メニューIDを取得します。

戻り値:
親メニューID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AdminMenuManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス AdminMenuManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.AdminMenuManager
public final class AdminMenuManager
extends Object

管理メニューマネージャクラス。

グループ管理者が利用する管理メニュー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
static void | clearInstance() ログイングループマネージャのインスタンスを初期化します。
void | deleteMenuItem(String menuId) メニューを削除します。
void | deleteMenuItems() すべてのメニューを削除します。
void | exportData(String category, OutputStream outputStream) メニュー情報・エクスポート。
String[] | getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | getExportCategories() 管理メニューエクスポート用のカテゴリの一覧を取得します。
String[] | getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | getImportCategories() 管理メニューインポート用のカテゴリの一覧を取得します。
static AdminMenuManager | getInstance() ログイングループマネージャのインスタンスを取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | getMenuItems() すべてのメニューを取得します。
MenuTree[] | getMenuTree() メニュー構成を取得します。
String | getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | importData(String category, InputStream inputStream) メニュー情報・インポート。
void | moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | updateMenuItem(MenuItem menuItem) メニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

clearInstance

public static void clearInstance()
ログイングループマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

getInstance

public static AdminMenuManager getInstance()
ログイングループマネージャのインスタンスを取得します。

戻り値:
ログイングループマネージャのインスタンス

addMenuItem

public void addMenuItem(String parentMenuId,
                        MenuItem menuItem)
                 throws AccessSecurityException
メニューを追加します。

パラメータ:
parentMenuId - 親メニューID
nullの場合は、第一階層へ追加される。
例外:
AccessSecurityException - メニューの追加に失敗した場合にスローされます。

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityException
メニューを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException

deleteMenuItems

public void deleteMenuItems()
                     throws AccessSecurityException
すべてのメニューを削除します。

例外:
AccessSecurityException

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
メニュー情報・エクスポート。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityException
子メニューIDを取得します。

パラメータ:
menuId - 親メニューID
戻り値:
子メニューの配列
例外:
AccessSecurityException

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityException
第一階層のメニューIDをすべて取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityException

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityException

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityException
指定されたメニューIDに対応するメニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
メニュー
例外:
AccessSecurityException

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityException
すべてのメニューを取得します。

戻り値:
メニューの配列
例外:
AccessSecurityException

getMenuTree

public MenuTree[] getMenuTree()
                       throws AccessSecurityException
メニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityException
指定されたメニューの親メニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityException

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
メニュー情報・インポート。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException

moveMenuItem

public void moveMenuItem(MenuInclusion menuInclusion)
                  throws AccessSecurityException
メニューを移動します。

パラメータ:
menuInclusion - 新しいメニュー構成
例外:
AccessSecurityException - メニューの更新に失敗した場合にスローされます。

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityException
メニューを更新します。

パラメータ:
menuItem -
例外:
AccessSecurityException

getExportCategories

public String[] getExportCategories()
管理メニューエクスポート用のカテゴリの一覧を取得します。

戻り値:
管理メニューエクスポート用カテゴリの一覧

getImportCategories

public String[] getImportCategories()
管理メニューインポート用のカテゴリの一覧を取得します。

戻り値:
管理メニューインポート用カテゴリの一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuPostWriterListener

public interface AdminMenuPostWriterListener

メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | postCreate(MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | postDelete(String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | postMove(String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | postUpdate(MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
item - 作成されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String menuId)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
menuId - 削除されたメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
item - 更新されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postMove

public void postMove(String parentId,
                     String childId)
              throws AccessSecurityListenerExcpetion
メニューの親子関係を更新した直後にコールされます。

パラメータ:
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuQueryWriterListener

public interface AdminMenuQueryWriterListener

メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | queryCreate(MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | queryDelete(String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | queryMove(String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | queryUpdate(MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
item - 作成されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String menuId)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
menuId - 削除されるメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
item - 更新されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryMove

public void queryMove(String parentId,
                      String childId)
               throws AccessSecurityListenerExcpetion
メニューの親子関係を更新する直前にコールされます。

パラメータ:
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AdminMenuReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース AdminMenuReaderDecorator

public interface AdminMenuReaderDecorator

メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
MenuItem | doDecoration(MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | init(Map params) メニューデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
メニューデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public MenuItem doDecoration(MenuItem item)
メニューデータストアからの読み込み直後にコールされます。

パラメータ:
item - 読み込みが行われたメニュー情報
戻り値:
拡張されたメニュー情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyChangedMenuListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス CompanyChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener
すべての実装インタフェース:
CompanyChangedListener
public class CompanyChangedMenuListener
extends Object
implements CompanyChangedListener

会社・組織に関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

コンストラクタの概要
CompanyChangedMenuListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, Company company) 会社情報がデータストアに登録された後に呼び出されます。
void | companyDeleted(String groupId, Company company) 会社情報がデータストアから削除された後に呼び出されます。
void | departmentAdded(String groupId, Department department) 組織情報がデータストアに登録された後に呼び出されます。
void | departmentDeleted(String groupId, Department department) 組織情報がデータストアに更新された後に呼び出されます。
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます。
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
void | departmentUpdated(String groupId, Department department) 組織情報がデータストアから削除された後に呼び出されます。
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます。
void | postDeleted(String groupId, CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます。
void | postUpdated(String groupId, CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyChangedMenuListener

public CompanyChangedMenuListener()
メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース CompanyChangedListener 内の setUserId
パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         Company company)
                  throws ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyAdded
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           Company company)
                    throws ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の companyDeleted
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            Department department)
                     throws ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentAdded
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentUpdated
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              Department department)
                       throws ChangedListenerException
組織情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentDeleted
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentJoined
パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentMoved
パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の departmentLeft
パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              CompanyCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  CompanyCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      DepartmentAttach attach)
               throws ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          DepartmentAttach attach)
                   throws ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    DepartmentMain main)
             throws ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainSet
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        DepartmentMain main)
                 throws ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の mainRemoved
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         CompanyVersion version)
                  throws ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           CompanyVersion version)
                    throws ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      CompanyPost post)
               throws ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postAdded
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postUpdated
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        CompanyPost post)
                 throws ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース CompanyChangedListener 内の postDeleted
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuAccessor

public interface MenuAccessor

メニューアクセッサインタフェース。

メニュー情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | deleteMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を削除します。
void | deleteMenuDepartments(String groupId, String id) すべてのメニュー組織を削除します。
void | deleteMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を削除します。
void | deleteMenuItem(String groupId, String id) 引数で渡されたノードを削除します。
void | deleteMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を削除します。
void | deleteMenuPosts(String groupId, String id) すべてのメニュー役職を削除します。
void | deleteMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを削除します。
void | deleteMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを削除します。
void | deleteMenuRole(String groupId, String id, String roleId) メニューロールを削除します。
void | deleteMenuRoles(String groupId, String id) すべてのメニューロールを削除します。
String[] | getChildMenuIds(String groupId, String menuId) 引数で指定されたノードの直下の子ノードを配列で取得します。
String[] | getFirstMenuIds(String groupId) 第一階層に属するノードを配列で取得します。
DepartmentInfo[] | getMenuDepartments(String groupId, String id) すべてのメニュー組織を取得します。
String[] | getMenuIds(String groupId) すべてのメニューIDを取得します。
String[] | getMenuIdsByDepartment(String groupId, DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPost(String groupId, PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPublicGroup(String groupId, PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | getMenuIdsByRole(String groupId, String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInclusion[] | getMenuInclusions(String groupId) すべてのメニュー構成を取得します。
MenuItem | getMenuItem(String groupId, String menuId) 指定されたメニューIDに対するノードを取得します。
MenuItem[] | getMenuItems(String groupId) すべてのノードを取得します。
MenuItem[] | getMenuItemsByIds(String groupId, String[] menuIds) 指定されたユーザIDのメニュー情報をすべて取得します。
PostInfo[] | getMenuPosts(String groupId, String id) すべてのメニュー役職を取得します。
PublicGroupInfo[] | getMenuPublicGroups(String groupId, String id) すべてのメニューパブリックグループを取得します。
String[] | getMenuRoles(String groupId, String id) すべてのメニューロールを取得します。
String | getParentMenuId(String groupId, String menuId) 引数で指定されたノードの親ノードを取得します。
void | init(Map params) メニューアクセッサの初期化。
void | insertMenuDepartment(String groupId, String id, DepartmentInfo departmentInfo) メニュー組織を新規に作成します。
void | insertMenuInclusion(String groupId, MenuInclusion menuInclusion) メニュー構成を新規に作成します。
void | insertMenuItem(String groupId, MenuItem menuItem, String parentId) 引数で渡されたノードを新規追加します。
void | insertMenuPost(String groupId, String id, PostInfo postInfo) メニュー役職を新規に作成します。
void | insertMenuPublicGroup(String groupId, String id, PublicGroupInfo publicGroupInfo) メニューパブリックグループを新規に作成します。
void | insertMenuRole(String groupId, String id, String roleId) メニューロールを新規に作成します。
void | updateMenuItem(String groupId, MenuItem menuItem) 引数で渡されたノードを更新します。

メソッドの詳細

deleteMenuDepartment

public void deleteMenuDepartment(String groupId,
                                 String id,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException
メニュー組織を削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

deleteMenuDepartments

public void deleteMenuDepartments(String groupId,
                                  String id)
                           throws AccessSecurityWriteException
すべてのメニュー組織を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuInclusion

public void deleteMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を削除します。

パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

deleteMenuItem

public void deleteMenuItem(String groupId,
                           String id)
                    throws AccessSecurityWriteException
引数で渡されたノードを削除します。

パラメータ:
groupId -
id -
例外:
AccessSecurityWriteException

deleteMenuPost

public void deleteMenuPost(String groupId,
                           String id,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException

deleteMenuPosts

public void deleteMenuPosts(String groupId,
                            String id)
                     throws AccessSecurityWriteException
すべてのメニュー役職を削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuPublicGroup

public void deleteMenuPublicGroup(String groupId,
                                  String id,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

deleteMenuPublicGroups

public void deleteMenuPublicGroups(String groupId,
                                   String id)
                            throws AccessSecurityWriteException
すべてのメニューパブリックグループを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

deleteMenuRole

public void deleteMenuRole(String groupId,
                           String id,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを削除します。

パラメータ:
groupId - ログイングループID
id - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException

deleteMenuRoles

public void deleteMenuRoles(String groupId,
                            String id)
                     throws AccessSecurityWriteException
すべてのメニューロールを削除します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException

getChildMenuIds

public String[] getChildMenuIds(String groupId,
                                String menuId)
                         throws AccessSecurityReadException
引数で指定されたノードの直下の子ノードを配列で取得します。

パラメータ:
groupId - ログイングループID
menuId - メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityReadException

getFirstMenuIds

public String[] getFirstMenuIds(String groupId)
                         throws AccessSecurityReadException
第一階層に属するノードを配列で取得します。

パラメータ:
groupId - ログイングループID
戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityReadException

getMenuDepartments

public DepartmentInfo[] getMenuDepartments(String groupId,
                                           String id)
                                    throws AccessSecurityReadException
すべてのメニュー組織を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
組織情報の配列
例外:
AccessSecurityReadException

getMenuIds

public String[] getMenuIds(String groupId)
                    throws AccessSecurityReadException
すべてのメニューIDを取得します。

パラメータ:
groupId -
戻り値:
メニューIDの配列
例外:
AccessSecurityReadException

getMenuIdsByDepartment

public String[] getMenuIdsByDepartment(String groupId,
                                       DepartmentInfo[] departments)
                                throws AccessSecurityReadException
指定された組織を持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
departments - 組織情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPost

public String[] getMenuIdsByPost(String groupId,
                                 PostInfo[] posts)
                          throws AccessSecurityReadException
指定された役職を持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
posts - 役職情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPublicGroup

public String[] getMenuIdsByPublicGroup(String groupId,
                                        PublicGroupInfo[] publicGroups)
                                 throws AccessSecurityReadException
指定されたパブリックグループを持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
publicGroups - パブリックグループの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByRole

public String[] getMenuIdsByRole(String groupId,
                                 String[] roleIds)
                          throws AccessSecurityReadException
指定されたロールIDを持つメニューIDをすべて取得します。

パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuInclusions

public MenuInclusion[] getMenuInclusions(String groupId)
                                  throws AccessSecurityReadException
すべてのメニュー構成を取得します。

パラメータ:
groupId - ログイングループID
戻り値:
メニュー構成の配列
例外:
AccessSecurityReadException

getMenuItem

public MenuItem getMenuItem(String groupId,
                            String menuId)
                     throws AccessSecurityReadException
指定されたメニューIDに対するノードを取得します。

パラメータ:
groupId - グループID
menuId - メニューID
戻り値:
ノード
例外:
AccessSecurityReadException

getMenuItems

public MenuItem[] getMenuItems(String groupId)
                        throws AccessSecurityReadException
すべてのノードを取得します。

パラメータ:
groupId -
戻り値:
ノード配列
例外:
AccessSecurityReadException

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String groupId,
                                    String[] menuIds)
                             throws AccessSecurityReadException
指定されたユーザIDのメニュー情報をすべて取得します。

パラメータ:
groupId - ログイングループID
menuIds - メニューIDの配列
戻り値:
メニューオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - メニュー情報取得に失敗した場合スローされます。

getMenuPosts

public PostInfo[] getMenuPosts(String groupId,
                               String id)
                        throws AccessSecurityReadException
すべてのメニュー役職を取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
役職情報の配列
例外:
AccessSecurityReadException

getMenuPublicGroups

public PublicGroupInfo[] getMenuPublicGroups(String groupId,
                                             String id)
                                      throws AccessSecurityReadException
すべてのメニューパブリックグループを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
パブリックグループ情報の配列
例外:
AccessSecurityReadException

getMenuRoles

public String[] getMenuRoles(String groupId,
                             String id)
                      throws AccessSecurityReadException
すべてのメニューロールを取得します。

一件も存在しない場合は、空の配列を返却します。

パラメータ:
groupId - ログイングループID
id - メニューID
戻り値:
メニューロールIDの配列
例外:
AccessSecurityReadException

getParentMenuId

public String getParentMenuId(String groupId,
                              String menuId)
                       throws AccessSecurityReadException
引数で指定されたノードの親ノードを取得します。

パラメータ:
groupId - ログイングループID
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityReadException

init

public void init(Map params)
メニューアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

insertMenuDepartment

public void insertMenuDepartment(String groupId,
                                 String id,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityWriteException
メニュー組織を新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityWriteException

insertMenuInclusion

public void insertMenuInclusion(String groupId,
                                MenuInclusion menuInclusion)
                         throws AccessSecurityWriteException
メニュー構成を新規に作成します。

パラメータ:
groupId - ログイングループID
menuInclusion - メニュー構成
例外:
AccessSecurityWriteException

insertMenuItem

public void insertMenuItem(String groupId,
                           MenuItem menuItem,
                           String parentId)
                    throws AccessSecurityWriteException
引数で渡されたノードを新規追加します。

パラメータ:
groupId -
menuItem -
parentId -
例外:
AccessSecurityWriteException

insertMenuPost

public void insertMenuPost(String groupId,
                           String id,
                           PostInfo postInfo)
                    throws AccessSecurityWriteException
メニュー役職を新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
postInfo - 役職情報
例外:
AccessSecurityWriteException

insertMenuPublicGroup

public void insertMenuPublicGroup(String groupId,
                                  String id,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityWriteException
メニューパブリックグループを新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
publicGroupInfo - パブリックグループ情報
例外:
AccessSecurityWriteException

insertMenuRole

public void insertMenuRole(String groupId,
                           String id,
                           String roleId)
                    throws AccessSecurityWriteException
メニューロールを新規に作成します。

パラメータ:
groupId - ログイングループID
id - メニューID
roleId - ロールID
例外:
AccessSecurityWriteException

updateMenuItem

public void updateMenuItem(String groupId,
                           MenuItem menuItem)
                    throws AccessSecurityWriteException
引数で渡されたノードを更新します。

パラメータ:
groupId - ログイングループID
menuItem - メニュー
例外:
AccessSecurityWriteException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuExporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuExporter

既知の実装クラスの一覧:
StandardMenuBackup
public interface MenuExporter

メニューエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(MenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニュー情報をバックアップファイルに出力します。

パラメータ:
manager - メニューマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuImporter

既知の実装クラスの一覧:
StandardMenuBackup
public interface MenuImporter

メニューインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     MenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を取得し、生成します。

パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuInclusion (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuInclusion

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuInclusion
すべての実装インタフェース:
Serializable
public class MenuInclusion
extends Object
implements Serializable

メニュー内包情報クラス。

メニューの親子関係を保持するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MenuInclusion(String parentMenuId, String childMenuId)
コンストラクタ。
メソッドの概要
String | getChildMenuId() 子メニューIDを取得します。
String | getKeyString() メニュー内包情報の識別子を取得します。
String | getParentMenuId() 親メニューIDを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuInclusion

public MenuInclusion(String parentMenuId,
                     String childMenuId)
コンストラクタ。

メソッドの詳細

getChildMenuId

public String getChildMenuId()
子メニューIDを取得します。

戻り値:
子メニューID

getParentMenuId

public String getParentMenuId()
親メニューIDを取得します。

戻り値:
親メニューID

getKeyString

public String getKeyString()
メニュー内包情報の識別子を取得します。

戻り値:
メニュー内包情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuItem (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuItem
すべての実装インタフェース:
Serializable
public class MenuItem
extends Object
implements Serializable

メニュー・モデルクラス。 メニューのデータモデルを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager, 直列化された形式

フィールドの概要
static String | CONTENT_TYPE_IN メニューコンテンツの種類（内部URL）。
static String | CONTENT_TYPE_OUT メニューコンテンツの種類（外部URL）。
static String | MENU_TYPE_FOLDER メニュータイプ（フォルダ）。
static String | MENU_TYPE_ITEM メニュータイプ（アイテム）。
コンストラクタの概要
MenuItem()
コンストラクタ。
MenuItem(String id)
コンストラクタ。
メソッドの概要
boolean | equals(Object obj) このオブジェクトと他のオブジェクトが等しいかどうかを示します。
String | getArgument(String key) 引数を取得します。
String[] | getArgumentKeys() 引数キーの一覧を取得します。
String | getClientType() クライアントタイプを取します。
String | getContents() コンテンツの種類を取得します。
String | getDescription() 説明を取得します。
String | getDisplayName(Locale locale) メニュー名を取得します。
String | getId() メニューIDを取得します。
String | getImagePath() メニューイメージパスを取得します。
Locale[] | getLocales() メニュー名として保管されているロケールの一覧を取得します。
int | getSortNumber() ソート番号を取得します。
String | getType() ノードのタイプを取得します。
String | getUrl() URLを取得します。
int | hashCode() ハッシュコードを取得します。
void | removeArgument(String key) 引数を削除します。
void | removeDisplayName(Locale locale) ロケールに対応したメニュー名を削除します。
void | setArgument(String key, String value) 引数を設定します。
void | setClientType(String clientType) クライアントタイプを設定します。
void | setContents(String contents) コンテンツの種類を設定します。
void | setDescription(String description) 説明を設定します。
void | setDisplayName(Locale locale, String displayName) メニュー名を設定します。
void | setId(String id) メニューIDを設定します。
void | setImagePath(String imagePath) メニューイメージパスを設定します。
void | setSortNumber(int sortNumber) ソート番号を設定します。
void | setType(String type) ノードのタイプを設定します。
void | setUrl(String url) URLを設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONTENT_TYPE_IN

public static final String CONTENT_TYPE_IN
メニューコンテンツの種類（内部URL）。

関連項目:
定数フィールド値

CONTENT_TYPE_OUT

public static final String CONTENT_TYPE_OUT
メニューコンテンツの種類（外部URL）。

関連項目:
定数フィールド値

MENU_TYPE_FOLDER

public static final String MENU_TYPE_FOLDER
メニュータイプ（フォルダ）。

関連項目:
定数フィールド値

MENU_TYPE_ITEM

public static final String MENU_TYPE_ITEM
メニュータイプ（アイテム）。

関連項目:
定数フィールド値
コンストラクタの詳細

MenuItem

public MenuItem()
コンストラクタ。

メニューIDは自動採番されます。

MenuItem

public MenuItem(String id)
コンストラクタ。

パラメータ:
id - メニューID
メソッドの詳細

equals

public boolean equals(Object obj)
このオブジェクトと他のオブジェクトが等しいかどうかを示します。

パラメータ:
obj - 比較対象の参照オブジェクト
戻り値:
引数に指定されたオブジェクトとこのオブジェクトが等しい場合は true、そうでない場合は false
関連項目:
Object.equals(java.lang.Object)

getArgument

public String getArgument(String key)
引数を取得します。

パラメータ:
key - 属性のキー
戻り値:
属性値

getArgumentKeys

public String[] getArgumentKeys()
引数キーの一覧を取得します。

戻り値:
引数キーの配列

getClientType

public String getClientType()
クライアントタイプを取します。

戻り値:
クライアントタイプ

getContents

public String getContents()
コンテンツの種類を取得します。

戻り値:
コンテンツの種類

getDescription

public String getDescription()
説明を取得します。

戻り値:
説明

getDisplayName

public String getDisplayName(Locale locale)
メニュー名を取得します。

パラメータ:
locale - ロケール名
戻り値:
メニュー名

getId

public String getId()
メニューIDを取得します。

戻り値:
メニューID

getLocales

public Locale[] getLocales()
メニュー名として保管されているロケールの一覧を取得します。

戻り値:
メニュー名として保管されているロケールの配列

getSortNumber

public int getSortNumber()
ソート番号を取得します。

戻り値:
ソート番号

getType

public String getType()
ノードのタイプを取得します。

返却される値は、フォルダ( MENU_TYPE_FOLDER)、またはアイテム(MENU_TYPE_ITEM)です。

戻り値:
ノードのタイプ

getUrl

public String getUrl()
URLを取得します。

戻り値:
URL

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

removeArgument

public void removeArgument(String key)
引数を削除します。

パラメータ:
key - 引数キー

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応したメニュー名を削除します。

パラメータ:
locale - ロケール

setArgument

public void setArgument(String key,
                        String value)
引数を設定します。

パラメータ:
key - 引数キー
value - 引数値

setClientType

public void setClientType(String clientType)
クライアントタイプを設定します。

パラメータ:
clientType - クライアントタイプ

setContents

public void setContents(String contents)
コンテンツの種類を設定します。

パラメータ:
contents - コンテンツの種類

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - 説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
メニュー名を設定します。

パラメータ:
locale - ロケール名
displayName - メニュー名

setId

public void setId(String id)
メニューIDを設定します。

パラメータ:
id - メニューID

setSortNumber

public void setSortNumber(int sortNumber)
ソート番号を設定します。

パラメータ:
sortNumber - ソート番号

setType

public void setType(String type)
ノードのタイプを設定します。

設定できる値は、フォルダ( MENU_TYPE_FOLDER)、またはアイテム(MENU_TYPE_ITEM)です。
上記の値以外を設定した場合は、アイテム( MENU_TYPE_ITEM)に設定されます。

パラメータ:
type - メニュータイプ

setUrl

public void setUrl(String url)
URLを設定します。

パラメータ:
url - URL

getImagePath

public String getImagePath()
メニューイメージパスを取得します。

戻り値:
イメージパス

setImagePath

public void setImagePath(String imagePath)
メニューイメージパスを設定します。

パラメータ:
imagePath - イメージパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuManager
public final class MenuManager
extends Object

メニューマネージャクラス。

メニュー情報の操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuManager(String groupId)
コンストラクタ。
メソッドの概要
void | addMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織をメニューに紐付けます。
void | addMenuItem(String parentMenuId, MenuItem menuItem) メニューを追加します。
void | addMenuPost(String menuId, PostInfo postInfo) 役職をメニューに紐付けます。
void | addMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループをメニューに紐付けます。
void | addMenuRole(String menuId, String roleId) ロールをメニューに紐付けます。
static void | clearInstance() メニューマネージャのインスタンスを初期化します。
void | deleteMenuDepartment(String menuId, DepartmentInfo departmentInfo) 組織の紐付けをメニューから削除します。
void | deleteMenuDepartments(String menuId) 組織の紐付けをメニューからすべて削除します。
void | deleteMenuItem(String menuId) メニューを削除します。
void | deleteMenuItems() すべてのメニューを削除します。
void | deleteMenuPost(String menuId, PostInfo postInfo) 役織の紐付けをメニューから削除します。
void | deleteMenuPosts(String menuId) 役織の紐付けをメニューからすべて削除します。
void | deleteMenuPublicGroup(String menuId, PublicGroupInfo publicGroupInfo) パブリックグループの紐付けをメニューから削除します。
void | deleteMenuPublicGroups(String menuId) パブリックグループの紐付けをメニューからすべて削除します。
void | deleteMenuRole(String menuId, String roleId) ロールの紐付けをメニューから削除します。
void | deleteMenuRoles(String menuId) ロールの紐付けをメニューから削除します。
void | exportData(String category, OutputStream outputStream) メニュー情報をエクスポートします。
MenuTree[] | getAccountMenuTree(String userId, String clientType) 指定したアカウントのメニュー構成を取得します。
String[] | getChildMenuIds(String menuId) 子メニューIDを取得します。
String[] | getExportCategories() メニューエクスポート用のカテゴリの一覧を取得します。
String[] | getFirstMenuIds() 第一階層のメニューIDをすべて取得します。
String[] | getImportCategories() メニューインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
DepartmentInfo[] | getMenuDepartments(String menuId) メニューに紐付いた組織の一覧を取得します。
String[] | getMenuIds() すべてのメニューIDを取得します。
String[] | getMenuIdsByDepartment(DepartmentInfo[] departments) 指定された組織を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPost(PostInfo[] posts) 指定された役職を持つメニューIDをすべて取得します。
String[] | getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
String[] | getMenuIdsByRole(String[] roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuItem | getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
MenuItem[] | getMenuItems() すべてのメニューを取得します。
MenuItem[] | getMenuItemsByIds(String[] menuIds) ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
PostInfo[] | getMenuPosts(String menuId) メニューに紐付いた役職の一覧を取得します。
PublicGroupInfo[] | getMenuPublicGroups(String menuId) メニューに紐付いたパブリックグループの一覧を取得します。
String[] | getMenuRoles(String menuId) メニューに紐付いたロールの一覧を取得します。
MenuTree[] | getMenuTree() メニュー構成を取得します。
MenuTree[] | getMenuTree(String clientType) 指定されたクライアントタイプのみのメニュー構成を取得します。
MenuTree[] | getMenuTree(String clientType, String[] menuIds, boolean showNoChildFolder) 指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
String | getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
void | importData(String category, InputStream inputStream) メニュー情報をインポートします。
void | moveMenuItem(MenuInclusion menuInclusion) メニューを移動します。
void | updateMenuItem(MenuItem menuItem) メニューを更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuManager

public MenuManager(String groupId)
            throws AccessSecurityException
コンストラクタ。

ログイングループ単位のメニューを操作するマネージャーを作成します。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

clearInstance

public static void clearInstance()
メニューマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

addMenuDepartment

public void addMenuDepartment(String menuId,
                              DepartmentInfo departmentInfo)
                       throws AccessSecurityException
組織をメニューに紐付けます。

パラメータ:
menuId - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuItem

public void addMenuItem(String parentMenuId,
                        MenuItem menuItem)
                 throws AccessSecurityException
メニューを追加します。

パラメータ:
parentMenuId - 親メニューID
nullの場合は、第一階層へ追加されます。
menuItem - メニュー
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuPost

public void addMenuPost(String menuId,
                        PostInfo postInfo)
                 throws AccessSecurityException
役職をメニューに紐付けます。

パラメータ:
menuId - メニューID
postInfo - 役職情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuPublicGroup

public void addMenuPublicGroup(String menuId,
                               PublicGroupInfo publicGroupInfo)
                        throws AccessSecurityException
パブリックグループをメニューに紐付けます。

パラメータ:
menuId - メニューID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addMenuRole

public void addMenuRole(String menuId,
                        String roleId)
                 throws AccessSecurityException
ロールをメニューに紐付けます。

パラメータ:
menuId - メニューID
roleId - ロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuDepartment

public void deleteMenuDepartment(String menuId,
                                 DepartmentInfo departmentInfo)
                          throws AccessSecurityException
組織の紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
departmentInfo - 組織情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuDepartments

public void deleteMenuDepartments(String menuId)
                           throws AccessSecurityException
組織の紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuItem

public void deleteMenuItem(String menuId)
                    throws AccessSecurityException
メニューを削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuItems

public void deleteMenuItems()
                     throws AccessSecurityException
すべてのメニューを削除します。

例外:
AccessSecurityException - 削除処理に失敗した場合にスローされます。

deleteMenuPost

public void deleteMenuPost(String menuId,
                           PostInfo postInfo)
                    throws AccessSecurityException
役織の紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
postInfo - 役織情報
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPosts

public void deleteMenuPosts(String menuId)
                     throws AccessSecurityException
役織の紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPublicGroup

public void deleteMenuPublicGroup(String menuId,
                                  PublicGroupInfo publicGroupInfo)
                           throws AccessSecurityException
パブリックグループの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
publicGroupInfo - パブリックグループ
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuPublicGroups

public void deleteMenuPublicGroups(String menuId)
                            throws AccessSecurityException
パブリックグループの紐付けをメニューからすべて削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuRole

public void deleteMenuRole(String menuId,
                           String roleId)
                    throws AccessSecurityException
ロールの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
roleId - ロールID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteMenuRoles

public void deleteMenuRoles(String menuId)
                     throws AccessSecurityException
ロールの紐付けをメニューから削除します。

パラメータ:
menuId - メニューID
例外:
AccessSecurityException - 削除処理に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
メニュー情報をエクスポートします。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getAccountMenuTree

public MenuTree[] getAccountMenuTree(String userId,
                                     String clientType)
                              throws AccessSecurityException
指定したアカウントのメニュー構成を取得します。

このメソッドはメニューの絞り込みにPermissionManagerを利用しています。
PermissionManagerでメニューの絞り込みに利用されるカテゴリは、'account-menu'です。

パラメータ:
userId - ユーザID
clientType - クライアントタイプ
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getChildMenuIds

public String[] getChildMenuIds(String menuId)
                         throws AccessSecurityException
子メニューIDを取得します。

パラメータ:
menuId - 親メニューID
戻り値:
子メニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
メニューエクスポート用のカテゴリの一覧を取得します。

戻り値:
メニューエクスポート用カテゴリの一覧
例外:
AccessSecurityException - メニューエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getFirstMenuIds

public String[] getFirstMenuIds()
                         throws AccessSecurityException
第一階層のメニューIDをすべて取得します。

戻り値:
第一階層のメニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
メニューインポート用のカテゴリの一覧を取得します。

戻り値:
メニューインポート用カテゴリの一覧
例外:
AccessSecurityException - メニューインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getMenuDepartments

public DepartmentInfo[] getMenuDepartments(String menuId)
                                    throws AccessSecurityException
メニューに紐付いた組織の一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
組織情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuIds

public String[] getMenuIds()
                    throws AccessSecurityException
すべてのメニューIDを取得します。

戻り値:
メニューIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuIdsByDepartment

public String[] getMenuIdsByDepartment(DepartmentInfo[] departments)
                                throws AccessSecurityException
指定された組織を持つメニューIDをすべて取得します。

パラメータ:
departments - 組織情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPost

public String[] getMenuIdsByPost(PostInfo[] posts)
                          throws AccessSecurityException
指定された役職を持つメニューIDをすべて取得します。

パラメータ:
posts - 役職情報の配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByPublicGroup

public String[] getMenuIdsByPublicGroup(PublicGroupInfo[] publicGroups)
                                 throws AccessSecurityException
指定されたパブリックグループを持つメニューIDをすべて取得します。

パラメータ:
publicGroups - パブリックグループの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuIdsByRole

public String[] getMenuIdsByRole(String[] roleIds)
                          throws AccessSecurityException
指定されたロールIDを持つメニューIDをすべて取得します。

パラメータ:
roleIds - ロールIDの配列
戻り値:
メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityException - メニュー情報取得に失敗した場合スローされます。

getMenuItem

public MenuItem getMenuItem(String menuId)
                     throws AccessSecurityException
指定されたメニューIDに対応するメニューを取得します。

パラメータ:
menuId - メニューID
戻り値:
メニュー
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuItems

public MenuItem[] getMenuItems()
                        throws AccessSecurityException
すべてのメニューを取得します。

戻り値:
メニュー情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMenuItemsByIds

public MenuItem[] getMenuItemsByIds(String[] menuIds)
                             throws AccessSecurityException
ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。

パラメータ:
menuIds - メニューIDの配列
戻り値:
メニュー情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - メニュー情報の取得に失敗した場合にスローされます。

getMenuPosts

public PostInfo[] getMenuPosts(String menuId)
                        throws AccessSecurityException
メニューに紐付いた役職の一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
役職情報の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuPublicGroups

public PublicGroupInfo[] getMenuPublicGroups(String menuId)
                                      throws AccessSecurityException
メニューに紐付いたパブリックグループの一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
パブリックグループの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuRoles

public String[] getMenuRoles(String menuId)
                      throws AccessSecurityException
メニューに紐付いたロールの一覧を取得します。

パラメータ:
menuId - メニューID
戻り値:
ロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree()
                       throws AccessSecurityException
メニュー構成を取得します。

戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree(String clientType)
                       throws AccessSecurityException
指定されたクライアントタイプのみのメニュー構成を取得します。

パラメータ:
clientType - クライアントタイプ この値がnullの場合は、すべてのクライアントタイプが対象となります。
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getMenuTree

public MenuTree[] getMenuTree(String clientType,
                              String[] menuIds,
                              boolean showNoChildFolder)
                       throws AccessSecurityException
指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。

パラメータ:
clientType - クライアントタイプ
この値がnullの場合は、すべてのクライアントタイプが対象となります。
menuIds - 作成対象のメニューIDの配列
この値がnullの場合は、すべてのメニューIDが対象となります。
showNoChildFolder - 子メニューを持た持たないフォルダーを表示するかどうか
戻り値:
メニュー構成の配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getParentMenuId

public String getParentMenuId(String menuId)
                       throws AccessSecurityException
指定されたメニューの親メニューを取得します。

メニューIDがトップメニューであった場合は、nullを返却します。

パラメータ:
menuId - メニューID
戻り値:
親メニューID
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
メニュー情報をインポートします。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

moveMenuItem

public void moveMenuItem(MenuInclusion menuInclusion)
                  throws AccessSecurityException
メニューを移動します。

パラメータ:
menuInclusion - 新しいメニュー構成
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または書き込み処理に失敗した場合にスローされます。

updateMenuItem

public void updateMenuItem(MenuItem menuItem)
                    throws AccessSecurityException
メニューを更新します。

パラメータ:
menuItem - メニュー情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuPostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuPostWriterListener

public interface MenuPostWriterListener

メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | postCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成した直後にコールされます。
void | postDelete(String groupId, String menuId) メニュー情報をデータストアから削除した直後にコールされます。
void | postMove(String groupId, String parentId, String childId) メニューの親子関係を更新した直後にコールされます。
void | postUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreate

public void postCreate(String groupId,
                       MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 作成されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDelete

public void postDelete(String groupId,
                       String menuId)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
menuId - 削除されたメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdate

public void postUpdate(String groupId,
                       MenuItem item)
                throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 更新されたメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postMove

public void postMove(String groupId,
                     String parentId,
                     String childId)
              throws AccessSecurityListenerExcpetion
メニューの親子関係を更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuQueryWriterListener

public interface MenuQueryWriterListener

メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
MenuManager

メソッドの概要
void | init(Map params) メニューリスナーの初期化。
void | queryCreate(String groupId, MenuItem item) メニュー情報をデータストアに作成する直前にコールされます。
void | queryDelete(String groupId, String menuId) メニュー情報をデータストアから削除する直前にコールされます。
void | queryMove(String groupId, String parentId, String childId) メニューの親子関係を更新する直前にコールされます。
void | queryUpdate(String groupId, MenuItem item) メニュー情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
メニューリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreate

public void queryCreate(String groupId,
                        MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
item - 作成されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDelete

public void queryDelete(String groupId,
                        String menuId)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
menuId - 削除されるメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdate

public void queryUpdate(String groupId,
                        MenuItem item)
                 throws AccessSecurityListenerExcpetion
メニュー情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
item - 更新されるメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryMove

public void queryMove(String groupId,
                      String parentId,
                      String childId)
               throws AccessSecurityListenerExcpetion
メニューの親子関係を更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
parentId - 新しい親メニューID
childId - 新しい子メニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MenuReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
インタフェース MenuReaderDecorator

public interface MenuReaderDecorator

メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
MenuItem | doDecoration(String groupId, MenuItem item) メニューデータストアからの読み込み直後にコールされます。
void | init(Map params) メニューデコレータの初期化。

メソッドの詳細

init

public void init(Map params)
メニューデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

doDecoration

public MenuItem doDecoration(String groupId,
                             MenuItem item)
メニューデータストアからの読み込み直後にコールされます。

パラメータ:
groupId - ログイングループID
item - 読み込みが行われたメニュー情報
戻り値:
拡張されたメニュー情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MenuTree (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス MenuTree

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.MenuTree
すべての実装インタフェース:
Comparator
public class MenuTree
extends Object
implements Comparator

メニューツリークラス。

メニューをツリー形式で保管するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuTree(MenuItem menuItem)
コンストラクタ。
メソッドの概要
void | addChild(MenuTree menuTree) 子メニューを追加します。
int | compare(Object o1, Object o2) 順序付けのために 2 つの引数を比較します。
void | deleteChild(String menuId) 子メニューを削除します。
boolean | equals(Object obj) このオブジェクトと他のオブジェクトが等しいかどうかを示します。
MenuTree[] | getChildren() 子メニューの一覧を取得します。
MenuItem | getMenuItem() メニューを取得します。
boolean | hasChildren() 子メニューが存在するかどうかを取得します。
int | hashCode() ハッシュコードを取得します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuTree

public MenuTree(MenuItem menuItem)
コンストラクタ。

パラメータ:
menuItem - メニュー
メソッドの詳細

addChild

public void addChild(MenuTree menuTree)
子メニューを追加します。

パラメータ:
menuTree - 子メニューのMenuTree

compare

public int compare(Object o1,
                   Object o2)
順序付けのために 2 つの引数を比較します。

定義:
インタフェース Comparator 内の compare
パラメータ:
o1 - 比較対象の最初のオブジェクト
o2 - 比較対象の 2 番目のオブジェクト
戻り値:
最初の引数が 2 番目の引数より小さい場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引数より大きい場合は正の整数
関連項目:
Comparator.compare(java.lang.Object, java.lang.Object)

deleteChild

public void deleteChild(String menuId)
子メニューを削除します。

パラメータ:
menuId - メニューID

equals

public boolean equals(Object obj)
このオブジェクトと他のオブジェクトが等しいかどうかを示します。

定義:
インタフェース Comparator 内の equals
パラメータ:
obj - 比較対象の参照オブジェクト
戻り値:
引数に指定されたオブジェクトとこのオブジェクトが等しい場合は true、そうでない場合は false
関連項目:
Object.equals(java.lang.Object)

getChildren

public MenuTree[] getChildren()
子メニューの一覧を取得します。

戻り値:
子メニュー(MenuTree)の配列

hasChildren

public boolean hasChildren()
子メニューが存在するかどうかを取得します。

戻り値:
true : 子メニューあり / false : 子メニューなし

getMenuItem

public MenuItem getMenuItem()
メニューを取得します。

戻り値:
メニュー

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.menu (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.menu
インタフェース
AdminMenuAccessor
AdminMenuExporter
AdminMenuImporter
AdminMenuPostWriterListener
AdminMenuQueryWriterListener
AdminMenuReaderDecorator
MenuAccessor
MenuExporter
MenuImporter
MenuPostWriterListener
MenuQueryWriterListener
MenuReaderDecorator
クラス
AdminMenuInclusion
AdminMenuManager
CompanyChangedMenuListener
MenuInclusion
MenuItem
MenuManager
MenuTree
PublicGroupChangedMenuListener
RoleChangedMenuListener
StandardAdminMenuBackup
StandardMenuBackup


jp.co.intra_mart.foundation.security.menu (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.menu

メニューに関連するクラスを提供します。

参照:
説明

インタフェースの概要
AdminMenuAccessor | メニューアクセッサインタフェース。
AdminMenuExporter | メニューエクスポートインタフェースです。
AdminMenuImporter | メニューインポートインタフェースです。
AdminMenuPostWriterListener | メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AdminMenuQueryWriterListener | メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AdminMenuReaderDecorator | メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
MenuAccessor | メニューアクセッサインタフェース。
MenuExporter | メニューエクスポートインタフェースです。
MenuImporter | メニューインポートインタフェースです。
MenuPostWriterListener | メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MenuQueryWriterListener | メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
MenuReaderDecorator | メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
AdminMenuInclusion | メニュー内包情報クラス。
AdminMenuManager | 管理メニューマネージャクラス。
CompanyChangedMenuListener | 会社・組織に関する情報の変更時のリスナーです。
MenuInclusion | メニュー内包情報クラス。
MenuItem | メニュー・モデルクラス。
MenuManager | メニューマネージャクラス。
MenuTree | メニューツリークラス。
PublicGroupChangedMenuListener | パブリックグループに関する情報の変更時のリスナーです。
RoleChangedMenuListener | ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。
StandardAdminMenuBackup | メニューバックアップクラスです。
StandardMenuBackup | メニューバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.menu の説明

メニューに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.menu クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.menu の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuManager
    • class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.MenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuManager
    • class jp.co.intra_mart.foundation.security.menu.MenuTree (implements java.util.Comparator)
    • class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup (implements jp.co.intra_mart.foundation.security.menu.AdminMenuExporter, jp.co.intra_mart.foundation.security.menu.AdminMenuImporter)
    • class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup (implements jp.co.intra_mart.foundation.security.menu.MenuExporter, jp.co.intra_mart.foundation.security.menu.MenuImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator
  • interface jp.co.intra_mart.foundation.security.menu.MenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.MenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.menu の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.menu の使用

jp.co.intra_mart.foundation.security.menu を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security.menu のクラス
MenuItem
メニュー・モデルクラス。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.menu のクラス
AdminMenuExporter
メニューエクスポートインタフェースです。
AdminMenuImporter
メニューインポートインタフェースです。
AdminMenuManager
管理メニューマネージャクラス。
MenuExporter
メニューエクスポートインタフェースです。
MenuImporter
メニューインポートインタフェースです。
MenuInclusion
メニュー内包情報クラス。
MenuItem
メニュー・モデルクラス。
MenuManager
メニューマネージャクラス。
MenuTree
メニューツリークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PublicGroupChangedMenuListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス PublicGroupChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener
すべての実装インタフェース:
PublicGroupChangedListener
public class PublicGroupChangedMenuListener
extends Object
implements PublicGroupChangedListener

パブリックグループに関する情報の変更時のリスナーです。

導入されたバージョン:
5.0

コンストラクタの概要
PublicGroupChangedMenuListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | groupSetAdded(String groupId, PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます。
void | groupSetDeleted(String groupId, PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます。
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
void | publicGroupAdded(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます。
void | publicGroupDeleted(String groupId, PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます。
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
void | publicGroupUpdated(String groupId, PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます。
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupChangedMenuListener

public PublicGroupChangedMenuListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の setUesrId
パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          PublicGroupSet groupSet)
                   throws ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetAdded
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

groupSetDeleted

public void groupSetDeleted(String groupId,
                            PublicGroupSet groupSet)
                     throws ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の groupSetDeleted
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupAdded

public void publicGroupAdded(String groupId,
                             PublicGroup publicGroup)
                      throws ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupAdded
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupUpdated
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               PublicGroup publicGroup)
                        throws ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupDeleted
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupJoined
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - パブリックグループ情報（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupMoved
パラメータ:
groupId - ログイングループID
groupSet - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
publicGroup - 移動するパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の publicGroupLeft
パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              PublicGroupCategory category)
                       throws ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  PublicGroupCategory category)
                           throws ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      PublicGroupAttach attach)
               throws ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          PublicGroupAttach attach)
                   throws ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         PublicGroupVersion version)
                  throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           PublicGroupVersion version)
                    throws ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - パブリックグループセット構成バージョン
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          Term term)
                   throws ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース PublicGroupChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleChangedMenuListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス RoleChangedMenuListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener
すべての実装インタフェース:
RoleChangedListener
public class RoleChangedMenuListener
extends Object
implements RoleChangedListener

ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleChangedMenuListener()
コンストラクタ。
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedMenuListener

public RoleChangedMenuListener()
コンストラクタ。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

定義:
インタフェース RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardAdminMenuBackup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス StandardAdminMenuBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup
すべての実装インタフェース:
AdminMenuExporter, AdminMenuImporter
public class StandardAdminMenuBackup
extends Object
implements AdminMenuImporter, AdminMenuExporter

メニューバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardAdminMenuBackup()
メソッドの概要
void | doExport(AdminMenuManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, AdminMenuManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardAdminMenuBackup

public StandardAdminMenuBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化します。

定義:
インタフェース AdminMenuImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     AdminMenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を生成します。

定義:
インタフェース AdminMenuImporter 内の doImport
パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(AdminMenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニューバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース AdminMenuExporter 内の doExport
パラメータ:
manager - メニューマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardMenuBackup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.menu
クラス StandardMenuBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.menu.StandardMenuBackup
すべての実装インタフェース:
MenuExporter, MenuImporter
public class StandardMenuBackup
extends Object
implements MenuImporter, MenuExporter

メニューバックアップクラスです。

バージョン:
1.0

コンストラクタの概要
StandardMenuBackup()
メソッドの概要
void | doExport(MenuManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, MenuManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardMenuBackup

public StandardMenuBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化します。

定義:
インタフェース MenuImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     MenuManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からメニュー情報を生成します。

定義:
インタフェース MenuImporter 内の doImport
パラメータ:
manager - メニューマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(MenuManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

メニューバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース MenuExporter 内の doExport
パラメータ:
manager - メニューマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.message.MessageManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.message メッセージに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.foundation.security.message のメソッド
static MessageManager MessageManager.getInstance()
メッセージマネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


MessageManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.message.MessageManager
public class MessageManager
extends Object

メッセージマネージャクラス。

メッセージを取得するクラス。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static MessageManager | getInstance() メッセージマネージャのインスタンスを取得します。
String | getMessage(Locale locale, String key) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg) メッセージを取得します。
String | getMessage(Locale locale, String key, String[] args) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg1, String arg2) メッセージを取得します。
String | getMessage(Locale locale, String key, String arg1, String arg2, String arg3) メッセージを取得します。
String | getMessage(String key) メッセージを取得します。
String | getMessage(String key, String arg) メッセージを取得します。
String | getMessage(String key, String[] args) メッセージを取得します。
String | getMessage(String key, String arg1, String arg2) メッセージを取得します。
String | getMessage(String key, String arg1, String arg2, String arg3) メッセージを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static MessageManager getInstance()
メッセージマネージャのインスタンスを取得します。

戻り値:
メッセージマネージャのインスタンス

getMessage

public String getMessage(Locale locale,
                         String key)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
戻り値:
アクセスセキュリティメッセージ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を１つ取ります。
置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg - 置換文字列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg1,
                         String arg2)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を２つ取ります。
置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String arg1,
                         String arg2,
                         String arg3)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列を３つ取ります。
置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(Locale locale,
                         String key,
                         String[] args)
                  throws AccessSecurityException
メッセージを取得します。

指定ロケールでメッセージを取得します。
引数に置換文字列の配列を取ります。
置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - 指定ロケール
key - メッセージキー名
args - 置換文字列の配列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。

パラメータ:
key - メッセージキー名
戻り値:
メッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を１つ取ります。
置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージキー名
arg - 置換文字列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg1,
                         String arg2)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を２つ取ります。
置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String arg1,
                         String arg2,
                         String arg3)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列を３つ取ります。
置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージキー名
arg1 - 置換文字列１
arg2 - 置換文字列２
arg3 - 置換文字列３
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - 引数が不正な場合にスローされます。

getMessage

public String getMessage(String key,
                         String[] args)
                  throws AccessSecurityException
メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に置換文字列の配列を取ります。
置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージキー名
args - 置換文字列の配列
戻り値:
置換文字列をを挿入したメッセージ
例外:
AccessSecurityException - メッセージを取得に失敗した場合、または引数が不正な場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.message (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.message
クラス
MessageManager


jp.co.intra_mart.foundation.security.message (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.message

メッセージに関連するクラスを提供します。

参照:
説明

クラスの概要
MessageManager メッセージマネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.message の説明

メッセージに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.message クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.message.MessageManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.message の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.message の使用

jp.co.intra_mart.foundation.security.message を使用しているパッケージ
jp.co.intra_mart.foundation.security.message メッセージに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.message により使用される jp.co.intra_mart.foundation.security.message のクラス
MessageManager
メッセージマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.permission.PermissionManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.PermissionManager の使用

jp.co.intra_mart.foundation.security.permission.PermissionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.permission.PermissionSelector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.permission.PermissionSelector の使用

PermissionSelector を使用しているパッケージ
jp.co.intra_mart.foundation.security.permission 権限に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.permission での PermissionSelector の使用

PermissionSelector を実装している jp.co.intra_mart.foundation.security.permission のクラス
class | AccountRolePermissionSelector ユーザIDから有効なすべてのロールを取得するセレクタ。
class | MenuPermissionSelector ユーザIDから有効なメニューのID一覧を取得するセレクタ。

PermissionSelector を返す jp.co.intra_mart.foundation.security.permission のメソッド
 PermissionSelector PermissionManager.getPermissionSelector(String category)
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


MenuPermissionSelector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス MenuPermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector
すべての実装インタフェース:
PermissionSelector
public class MenuPermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なメニューのID一覧を取得するセレクタ。

選択条件としてのユーザIDからアクセス可能なメニューのメニューIDを選択します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
MenuPermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuPermissionSelector

public MenuPermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.permission (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.permission
インタフェース
PermissionSelector
クラス
AccountRolePermissionSelector
MenuPermissionSelector
PermissionManager


jp.co.intra_mart.foundation.security.permission (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.permission

権限に関連するクラスを提供します。

参照:
説明

インタフェースの概要
PermissionSelector パーミッション・作成クラスインタフェース。

クラスの概要
AccountRolePermissionSelector | ユーザIDから有効なすべてのロールを取得するセレクタ。
MenuPermissionSelector | ユーザIDから有効なメニューのID一覧を取得するセレクタ。
PermissionManager | パーミッション・マネージャクラス。

パッケージ jp.co.intra_mart.foundation.security.permission の説明

権限に関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.permission クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.permission の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.permission.PermissionManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.permission.PermissionSelector
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.permission の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.permission の使用

jp.co.intra_mart.foundation.security.permission を使用しているパッケージ
jp.co.intra_mart.foundation.security.permission 権限に関連するクラスを提供します。

jp.co.intra_mart.foundation.security.permission により使用される jp.co.intra_mart.foundation.security.permission のクラス
PermissionSelector
パーミッション・作成クラスインタフェース。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PermissionManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス PermissionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.PermissionManager
public class PermissionManager
extends Object

パーミッション・マネージャクラス。

パーミッションを生成するマネージャクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
PermissionManager(String groupId)
コンストラクタ。
メソッドの概要
Collection | doSelection(String category, String info) 選択用情報を利用して選別された情報のリストを返却します。
Collection | doSelection(String category, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
String[] | getCategories() 設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
PermissionSelector | getPermissionSelector(String category) 指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermissionManager

public PermissionManager(String groupId)
                  throws AccessSecurityException
コンストラクタ。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityException - ログイングループIDが不正な場合にスローされます。
メソッドの詳細

getCategories

public String[] getCategories()
設定XMLファイルで定義されているすべてのカテゴリ名を返却します。

戻り値:
カテゴリ名配列
導入されたバージョン:
5.0

getPermissionSelector

public PermissionSelector getPermissionSelector(String category)
                                         throws AccessSecurityException
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
カテゴリに一致する情報がない場合は、nullが返却されます。

パラメータ:
category - 設定ファイル内のカテゴリ名
戻り値:
カテゴリに対応するPermissionSelectorインスタンス
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

doSelection

public Collection doSelection(String category,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトです。

パラメータ:
category - カテゴリ
設定XMLファイルで定義されています。
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報リスト
カテゴリが存在しなかった場合は、nullを返却します。
例外:
AccessSecurityException - パーミッション作成に失敗した場合、または引数が不正だった場合にスローされます。

doSelection

public Collection doSelection(String category,
                              String info)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトです。

パラメータ:
category - カテゴリ
設定XMLファイルで定義されています。
info - 選択用情報
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報リスト
カテゴリが存在しなかった場合は、nullを返却します。
例外:
AccessSecurityException - パーミッション作成に失敗した場合、または引数が不正だった場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PermissionSelector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
インタフェース PermissionSelector

既知の実装クラスの一覧:
AccountRolePermissionSelector, MenuPermissionSelector
public interface PermissionSelector

パーミッション・作成クラスインタフェース。 パーミッションの作成クラスが実装するメソッドを定義します。
各種PermissionFactoryクラスは必ずこのインタフェースを実装し、設定XMLファイルに登録します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.role.Role の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.Role の使用

Role を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での Role の使用

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.account のメソッド
void | RoleChangedAccountListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedAccountListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.menu での Role の使用

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.menu のメソッド
void | RoleChangedMenuListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedMenuListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

jp.co.intra_mart.foundation.security.role での Role の使用

Role を返す jp.co.intra_mart.foundation.security.role のメソッド
Role | RoleReaderDecorator.doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
Role | RoleManager.getRole(String roleId) ロール情報を取得します。
Role[] | RoleManager.getRoles() すべてのロール情報を取得します。
Role[] | RoleManager.getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | RoleManager.getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
Role[] | RoleManager.searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | RoleManager.searchRolesByName(String name) ロール名称検索によりロールを取得します。
Role[] | RoleAccessor.getRoleData(String groupId) ロール情報を全件取得する。
Role | RoleAccessor.getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | RoleAccessor.getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | RoleAccessor.getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。

Role 型のパラメータを持つ jp.co.intra_mart.foundation.security.role のメソッド
Role | RoleReaderDecorator.doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
void | RoleQueryWriterListener.queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | RoleQueryWriterListener.queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。
void | RolePostWriterListener.postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RolePostWriterListener.postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleManager.addRole(Role role) ロール情報を新規登録します。
void | RoleManager.updateRole(Role role) ロール情報を更新します。
void | RoleChangedListener.roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | RoleChangedListener.roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | RoleAccessor.createRole(String groupId, Role role) ロール情報を新規に追加する。
void | RoleAccessor.updateRole(String groupId, Role role) ロール情報を更新する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleAccessor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleAccessor の使用

jp.co.intra_mart.foundation.security.role.RoleAccessor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleChangedListener の使用

RoleChangedListener を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account での RoleChangedListener の使用

RoleChangedListener を実装している jp.co.intra_mart.foundation.security.account のクラス
 class RoleChangedAccountListener
ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。

jp.co.intra_mart.foundation.security.menu での RoleChangedListener の使用

RoleChangedListener を実装している jp.co.intra_mart.foundation.security.menu のクラス
 class RoleChangedMenuListener
ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleExporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleExporter の使用

RoleExporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleExporter の使用

RoleExporter を実装している jp.co.intra_mart.foundation.security.role のクラス
 class StandardRoleBackup
ロールバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleImporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleImporter の使用

RoleImporter を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleImporter の使用

RoleImporter を実装している jp.co.intra_mart.foundation.security.role のクラス
 class StandardRoleBackup
ロールバックアップクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.role.RoleManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.RoleManager の使用

RoleManager を使用しているパッケージ
jp.co.intra_mart.foundation.security.role ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.role での RoleManager の使用

RoleManager 型のパラメータを持つ jp.co.intra_mart.foundation.security.role のメソッド
void | StandardRoleBackup.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | StandardRoleBackup.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | RoleImporter.doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | RoleExporter.doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RolePostWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RolePostWriterListener の使用

jp.co.intra_mart.foundation.security.role.RolePostWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener の使用

jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.security.role.RoleReaderDecorator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.security.role.RoleReaderDecorator の使用

jp.co.intra_mart.foundation.security.role.RoleReaderDecorator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.role.StandardRoleBackup の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.role.StandardRoleBackup の使用

jp.co.intra_mart.foundation.security.role.StandardRoleBackup はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.security.role (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.role
インタフェース
RoleAccessor
RoleChangedListener
RoleExporter
RoleImporter
RolePostWriterListener
RoleQueryWriterListener
RoleReaderDecorator
クラス
Role
RoleManager
StandardRoleBackup


jp.co.intra_mart.foundation.security.role (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.role

ロールに関連するクラスを提供します。

参照:
説明

インタフェースの概要
RoleAccessor | ロールアクセッサインタフェース。
RoleChangedListener | ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleExporter | ロールエクスポートインタフェースです。
RoleImporter | ロールインポートインタフェースです。
RolePostWriterListener | ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleQueryWriterListener | ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
RoleReaderDecorator | ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

クラスの概要
Role | ロール・モデルインタフェース。
RoleManager | ロールマネージャクラス。
StandardRoleBackup | ロールバックアップクラスです。

パッケージ jp.co.intra_mart.foundation.security.role の説明

ロールに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.role クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.role の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.role.Role (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.role.RoleManager
    • class jp.co.intra_mart.foundation.security.role.StandardRoleBackup (implements jp.co.intra_mart.foundation.security.role.RoleExporter, jp.co.intra_mart.foundation.security.role.RoleImporter)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.role.RoleAccessor
  • interface jp.co.intra_mart.foundation.security.role.RoleChangedListener
  • interface jp.co.intra_mart.foundation.security.role.RoleExporter
  • interface jp.co.intra_mart.foundation.security.role.RoleImporter
  • interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.role の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.role の使用

jp.co.intra_mart.foundation.security.role を使用しているパッケージ
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleChangedListener
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleChangedListener
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

jp.co.intra_mart.foundation.security.role により使用される jp.co.intra_mart.foundation.security.role のクラス
Role
ロール・モデルインタフェース。
RoleExporter
ロールエクスポートインタフェースです。
RoleImporter
ロールインポートインタフェースです。
RoleManager
ロールマネージャクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Role (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス Role

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.Role
すべての実装インタフェース:
Serializable
public class Role
extends Object
implements Serializable

ロール・モデルインタフェース。

ロールのデータモデルインタフェースを定義する。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
Role()
コンストラクタ。
Role(String roleId)
コンストラクタ。
Role(String roleId, String roleName)
コンストラクタ。
メソッドの概要
boolean | equals(Object role) データモデルのチェック。
String | getCategory() ロールカテゴリを取得します。
String | getDescription() 説明を取得します。
String | getDisplayName(Locale locale) ロール表示名を取得します。
Locale[] | getLocales() ロケールの一覧を取得します。
String | getRoleId() ロールIDを取得します。
String | getRoleName() ロール名を取得します。
int | hashCode() ハッシュコードを取得します。
void | removeDisplayName(Locale locale) ロケールに対応したロール表示名を削除します。
void | setCategory(String category) ロールカテゴリを設定します。
void | setDescription(String description) 説明を設定します。
void | setDisplayName(Locale locale, String displayName) ロール表示名を設定します。
void | setRoleId(String roleId) ロールIDを設定します。
void | setRoleName(String name) ロール名を設定します。
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Role

public Role()
コンストラクタ。

ロールIDは自動採番されます。

Role

public Role(String roleId)
コンストラクタ。

パラメータ:
roleId - ロールID

Role

public Role(String roleId,
            String roleName)
     throws IOException
コンストラクタ。

パラメータ:
roleId - ロールID
roleName - ロール名
メソッドの詳細

equals

public boolean equals(Object role)
データモデルのチェック。

指定されたオブジェクトがモデルと一致するかをチェックする

パラメータ:
role - :チェック対象のオブジェクト
戻り値:
true :オブジェクトがモデルと一致 false :オブジェクトがモデルと不一致
関連項目:
Object.equals(Object)

getCategory

public String getCategory()
ロールカテゴリを取得します。

戻り値:
ロールカテゴリ

getDescription

public String getDescription()
説明を取得します。

戻り値:
ロールの説明

getDisplayName

public String getDisplayName(Locale locale)
ロール表示名を取得します。

ロケールに対応したロール表示名を取得します。
存在しないロケールの場合は空文字を返します 。

パラメータ:
locale - ロケール
戻り値:
ロール表示名

getLocales

public Locale[] getLocales()
ロケールの一覧を取得します。

表示名として登録されているロケールの一覧を取得します。

戻り値:
登録されているロケールの一覧。

getRoleId

public String getRoleId()
ロールIDを取得します。

戻り値:
ロールID

getRoleName

public String getRoleName()
ロール名を取得します。

戻り値:
ロール名

hashCode

public int hashCode()
ハッシュコードを取得します。

戻り値:
ハッシュコード
関連項目:
Object.hashCode()

setCategory

public void setCategory(String category)
ロールカテゴリを設定します。

パラメータ:
category - ロールカテゴリ

setDescription

public void setDescription(String description)
説明を設定します。

パラメータ:
description - ロールの説明

setDisplayName

public void setDisplayName(Locale locale,
                           String displayName)
ロール表示名を設定します。

ロケールに対応したロール表示名を設定します。

パラメータ:
locale - ロケール
displayName - ロール表示名

removeDisplayName

public void removeDisplayName(Locale locale)
ロケールに対応したロール表示名を削除します。

ロケールに対応したロール表示名を削除します。

パラメータ:
locale - ロケール

setRoleId

public void setRoleId(String roleId)
ロールIDを設定します。

パラメータ:
roleId - ロールID

setRoleName

public void setRoleName(String name)
ロール名を設定します。

パラメータ:
name - ロール名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RoleAccessor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleAccessor

public interface RoleAccessor

ロールアクセッサインタフェース。

ロール情報の読み込みおよび書き込みのインタフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | createRole(String groupId, Role role) ロール情報を新規に追加する。
void | deleteCategory(String groupId) すべてのカテゴリを削除する。
void | deleteCategory(String groupId, String category) カテゴリを削除する。
void | deleteRole(String groupId) すべてのロール情報を削除する。
void | deleteRole(String groupId, String roleId) ロール情報を削除する。
void | deleteSubRole(String groupId, String roleId) 指定したロールのサブロールIDサマリを全削除する。
void | deleteSubRole(String groupId, String roleId, String subRoleId) サブロールIDサマリを削除する。
String[] | getAllParentRoleIds(String groupId, String roleId) すべての親ロールの一覧を取得する。
String[] | getAllSubRoleIds(String groupId, String roleId) すべてのサブロールの一覧を取得する。
String[] | getCategories(String groupId) カテゴリの一覧を取得する。
String[] | getParentRoleIds(String groupId, String roleId) 親ロールの一覧を取得する。
Role[] | getRoleData(String groupId) ロール情報を全件取得する。
Role | getRoleData(String groupId, String roleId) ロール情報を取得する。
Role[] | getRoleDataByCategory(String groupId, String category) カテゴリからロール情報を取得する。
Role[] | getRolesByIds(String groupId, String[] roleIds) 指定されたロールIDのロール情報をすべて取得する。
String[] | getSubRoleIds(String groupId, String roleId) サブロールIDサマリを取得する。
void | init(Map params) ロールアクセッサの初期化。
void | insertSubRole(String groupId, String roleId, String subRoleId) サブロールを作成する。
void | updateCategory(String groupId, String oldCategory, String newCategory) カテゴリを更新する。
void | updateRole(String groupId, Role role) ロール情報を更新する。

メソッドの詳細

createRole

public void createRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を新規に追加する。

パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の作成に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId)
                    throws AccessSecurityWriteException
すべてのカテゴリを削除する。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String groupId,
                           String category)
                    throws AccessSecurityWriteException
カテゴリを削除する。

パラメータ:
groupId - ログイングループID
category - カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId)
                throws AccessSecurityWriteException
すべてのロール情報を削除する。

パラメータ:
groupId - ログイングループID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

deleteRole

public void deleteRole(String groupId,
                       String roleId)
                throws AccessSecurityWriteException
ロール情報を削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
例外:
AccessSecurityWriteException - ロール情報の削除に失敗した場合にスローされます。

getAllParentRoleIds

public String[] getAllParentRoleIds(String groupId,
                                    String roleId)
                             throws AccessSecurityReadException
すべての親ロールの一覧を取得する。

引数に指定したロールの上位階層にあるすべての親ロールを取得する。
親ロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべての親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getAllSubRoleIds

public String[] getAllSubRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
すべてのサブロールの一覧を取得する。

引数に指定したロールの下位階層にあるすべてのサブロールを取得する。
サブロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
すべてのサブロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getCategories

public String[] getCategories(String groupId)
                       throws AccessSecurityReadException
カテゴリの一覧を取得する。

指定したログイングループに属するカテゴリが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
戻り値:
カテゴリ名の配列
例外:
AccessSecurityReadException - カテゴリの取得に失敗した場合にスローされます。

getParentRoleIds

public String[] getParentRoleIds(String groupId,
                                 String roleId)
                          throws AccessSecurityReadException
親ロールの一覧を取得する。

引数に指定したロールの１階層上位にあるすべての親ロールを取得する。
親ロールが一件も存在しない場合空の配列を返却する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
親ロールIDの配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role[] getRoleData(String groupId)
                   throws AccessSecurityReadException
ロール情報を全件取得する。

指定されたログイングループに属するロールが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleData

public Role getRoleData(String groupId,
                        String roleId)
                 throws AccessSecurityReadException
ロール情報を取得する。

指定されたロールIDをもつロールが存在しない場合はnullを返す

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
ロールデータ
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRoleDataByCategory

public Role[] getRoleDataByCategory(String groupId,
                                    String category)
                             throws AccessSecurityReadException
カテゴリからロール情報を取得する。

指定されたカテゴリに属するロール情報を取得する
指定したカテゴリーに属するロールが存在しない場合は空の配列を返却する。

パラメータ:
groupId - ログイングループID
category - カテゴリ名
戻り値:
ロール情報の配列
例外:
AccessSecurityReadException - ロール情報の取得に失敗した場合にスローされます。

getRolesByIds

public Role[] getRolesByIds(String groupId,
                            String[] roleIds)
                     throws AccessSecurityReadException
指定されたロールIDのロール情報をすべて取得する。

パラメータ:
groupId - ログイングループID
roleIds - ロールIDの配列
戻り値:
ロールオブジェクトの配列
すべて存在しない場合は、空文字列を返却します。
例外:
AccessSecurityReadException - ロール情報取得に失敗した場合スローされます。

init

public void init(Map params)
ロールアクセッサの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

updateCategory

public void updateCategory(String groupId,
                           String oldCategory,
                           String newCategory)
                    throws AccessSecurityWriteException
カテゴリを更新する。

旧カテゴリ名を新カテゴリ名に更新する。

パラメータ:
groupId - ログイングループID
oldCategory - 旧カテゴリ名
newCategory - 新カテゴリ名
例外:
AccessSecurityWriteException - カテゴリの更新に失敗した場合にスローされます。

updateRole

public void updateRole(String groupId,
                       Role role)
                throws AccessSecurityWriteException
ロール情報を更新する。

パラメータ:
groupId - ログイングループID
role - ロール情報
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

insertSubRole

public void insertSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
サブロールを作成する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId,
                          String subRoleId)
                   throws AccessSecurityWriteException
サブロールIDサマリを削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除するサブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String groupId,
                          String roleId)
                   throws AccessSecurityWriteException
指定したロールのサブロールIDサマリを全削除する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。

getSubRoleIds

public String[] getSubRoleIds(String groupId,
                              String roleId)
                       throws AccessSecurityReadException
サブロールIDサマリを取得する。

パラメータ:
groupId - ログイングループID
roleId - ロールID
戻り値:
String[] サブロールID
例外:
AccessSecurityWriteException - ロール情報の更新に失敗した場合にスローされます。
AccessSecurityReadException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RoleChangedListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleChangedListener

既知の実装クラスの一覧:
RoleChangedAccountListener, RoleChangedMenuListener
public interface RoleChangedListener

ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | roleUpdated(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      Role role)
               throws ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        Role role)
                 throws ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws ChangedListenerException
ロールにサブロールを追加した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws ChangedListenerException
ロールからサブロールを削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleExporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleExporter

既知の実装クラスの一覧:
StandardRoleBackup
public interface RoleExporter

ロールエクスポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doExport

public void doExport(RoleManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

ロール情報をバックアップファイルに出力します。

パラメータ:
manager - ロールマネージャ
outputStream - 出力ストリーム
例外:
AccessSecurityExportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleImporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleImporter

既知の実装クラスの一覧:
StandardRoleBackup
public interface RoleImporter

ロールインポートインタフェースです。

バージョン:
1.0

メソッドの概要
void | doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | init(Map params) 初期化。

メソッドの詳細

doImport

public void doImport(InputStream inputStream,
                     RoleManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からロール情報を取得し、生成します。

パラメータ:
manager - ロールマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

init

public void init(Map params)
初期化。

初期化する。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス RoleManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.RoleManager
public class RoleManager
extends Object

ロールマネージャクラス。

ロール情報に関連する操作を行います。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
RoleManager(String gid)
コンストラクタ。
メソッドの概要
void | addRole(Role role) ロール情報を新規登録します。
void | addSubRole(String roleId, String subRoleId) サブロールIDを追加します。
boolean | certify(String[] users, String[] roles) ロール内包を認証します。
boolean | contains(String roleId) ロールの存在チェックを行います。
boolean | containsCategory(String category) カテゴリーの存在チェックをします。
int | count() ロール数を取得します。
int | countByCategory(String category) カテゴリーに属するロール数を取得します。
void | deleteCategories() すべてのカテゴリーを削除します。
void | deleteCategory(String category) カテゴリーを削除します。
void | deleteRole(String roleId) ロールを削除します。
void | deleteRoles() すべてのロールを削除します。
void | deleteSubRole(String roleId, String subRoleId) 指定したサブロールIDを削除します。
void | deleteSubRoles(String roleId) 全てのサブロールIDを削除します。
void | exportData(String category, OutputStream outputStream) ロール情報・エクスポート。
String[] | getAllParentRoleIds(String roleId) 全ての親ロールIDを取得します。
String[] | getAllSubRoleIds(String roleId) 全てのサブロールサマリを取得します。
String[] | getCategories() カテゴリーの一覧を取得します。
String[] | getExportCategories() ロールエクスポート用のカテゴリの一覧を取得します。
String[] | getImportCategories() ロールインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
String[] | getParentRoleIds(String roleId) 親ロールIDを取得します。
Role | getRole(String roleId) ロール情報を取得します。
String[] | getRoleIds() すべてのロールIDを取得します。
Role[] | getRoles() すべてのロール情報を取得します。
Role[] | getRolesByCategory(String category) カテゴリー検索によりロールを取得します。
Role[] | getRolesByIds(String[] roleIds) ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
String[] | getSubRole(String roleId) サブロール(一階層のみ)を取得します。
void | importData(String category, InputStream inputStream) ロール情報・インポート。
void | moveCategory(String oldCategory, String newCategory) カテゴリーを更新します。
Role[] | searchRolesById(String key) ロールID検索によりロールを取得します。
Role[] | searchRolesByName(String name) ロール名称検索によりロールを取得します。
void | updateRole(Role role) ロール情報を更新します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleManager

public RoleManager(String gid)
            throws AccessSecurityException
コンストラクタ。

パラメータ:
gid - ログイングループID
例外:
AccessSecurityException - 指定のログイングループIDが不正の場合にスローされます。
メソッドの詳細

addRole

public void addRole(Role role)
             throws AccessSecurityException
ロール情報を新規登録します。

ロール情報をデータソースに新規登録します。

パラメータ:
role - ロール情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

addSubRole

public void addSubRole(String roleId,
                       String subRoleId)
                throws AccessSecurityException
サブロールIDを追加します。

パラメータ:
roleId - ロールID
subRoleId - サブロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

certify

public boolean certify(String[] users,
                       String[] roles)
                throws AccessSecurityException
ロール内包を認証します。

第1引数で指定されたロール配列と第2引数で指定されたロールの配列で同一のものがあるかをチェックします。
第1引数のロールのみ、ネストしたロールも含めてチェックします。

パラメータ:
users - ロールIDの配列
roles - ロールIDの配列
戻り値:
同じロールがある場合:true ない場合:false
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

contains

public boolean contains(String roleId)
                 throws AccessSecurityException
ロールの存在チェックを行います。

指定のロールが存在するかをチェックします。

パラメータ:
roleId - ロールID
戻り値:
true: 指定のロールが存在します。
false: 指定のロールが存在しません。
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

containsCategory

public boolean containsCategory(String category)
                         throws AccessSecurityException
カテゴリーの存在チェックをします。

指定のカテゴリーが該当するログイングループ内で登録されているかをチェックします。

パラメータ:
category - カテゴリー
戻り値:
true:登録済み false:未登録
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

count

public int count()
          throws AccessSecurityReadException
ロール数を取得します。

ログイングループ内のロール数を取得します。

戻り値:
ロール数
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

countByCategory

public int countByCategory(String category)
                    throws AccessSecurityException
カテゴリーに属するロール数を取得します。

ログイングループ内の指定カテゴリーに属するロールの数を取得します。

戻り値:
ロール数
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteCategories

public void deleteCategories()
                      throws AccessSecurityWriteException
すべてのカテゴリーを削除します。

ログイングループに属するカテゴリーを全件削除します

例外:
AccessSecurityWriteException - 読み込み処理に失敗した場合にスローされます。

deleteCategory

public void deleteCategory(String category)
                    throws AccessSecurityException
カテゴリーを削除します。

ログイングループ内のカテゴリーを削除します。

パラメータ:
category - カテゴリー
例外:
AccessSecurityReadException - 読み込み処理、または書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。
AccessSecurityException

deleteRole

public void deleteRole(String roleId)
                throws AccessSecurityException
ロールを削除します。

指定のロール情報を削除します。

パラメータ:
roleId - ロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteRoles

public void deleteRoles()
                 throws AccessSecurityException
すべてのロールを削除します。

すべてのロール情報を削除します 。

例外:
AccessSecurityException - 書き込み処理、または読み込み処理に失敗した場合にスローされます。

deleteSubRole

public void deleteSubRole(String roleId,
                          String subRoleId)
                   throws AccessSecurityException
指定したサブロールIDを削除します。

パラメータ:
roleId - ロールID
subRoleId - サブロールID
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

deleteSubRoles

public void deleteSubRoles(String roleId)
                    throws AccessSecurityException
全てのサブロールIDを削除します。

パラメータ:
roleId -
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

exportData

public void exportData(String category,
                       OutputStream outputStream)
                throws AccessSecurityException
ロール情報・エクスポート。

パラメータ:
category - カテゴリ
outputStream - 出力ストリーム
例外:
AccessSecurityException - エクスポートに失敗した場合、または引数が不正だった場合にスローされます。

getAllParentRoleIds

public String[] getAllParentRoleIds(String roleId)
                             throws AccessSecurityException
全ての親ロールIDを取得します。

指定したロールに属する親ロールのロールIDをすべて取得します。
ネストした親ロールについても全て取得します。
存在しない場合は空の文字列を返却します。

パラメータ:
roleId - ロールID
戻り値:
親ロールのロールID配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getAllSubRoleIds

public String[] getAllSubRoleIds(String roleId)
                          throws AccessSecurityException
全てのサブロールサマリを取得します。

パラメータ:
roleId - ロールID
戻り値:
サブロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getCategories

public String[] getCategories()
                       throws AccessSecurityReadException
カテゴリーの一覧を取得します。

ログイングループに属するカテゴリーの一覧を取得します。

戻り値:
カテゴリー一覧
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getExportCategories

public String[] getExportCategories()
                             throws AccessSecurityException
ロールエクスポート用のカテゴリの一覧を取得します。

戻り値:
ロールエクスポート用カテゴリの一覧
例外:
AccessSecurityException - ロールエクスポート用のカテゴリの取得に失敗した場合にスローされます。

getImportCategories

public String[] getImportCategories()
                             throws AccessSecurityException
ロールインポート用のカテゴリの一覧を取得します。

戻り値:
ロールインポート用カテゴリの一覧
例外:
AccessSecurityException - ロールインポート用のカテゴリの取得に失敗した場合にスローされます。

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID

getParentRoleIds

public String[] getParentRoleIds(String roleId)
                          throws AccessSecurityException
親ロールIDを取得します。

指定のロールの一階層上のロールを取得します。
存在しない場合は空の配列を返却します。

パラメータ:
roleId - ロールID
戻り値:
親ロールIDの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRole

public Role getRole(String roleId)
             throws AccessSecurityException
ロール情報を取得します。

指定されたロールの情報を取得します。
存在しない場合はnullを返却します。

パラメータ:
roleId - ロールID
戻り値:
ロール情報
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRoleIds

public String[] getRoleIds()
                    throws AccessSecurityReadException
すべてのロールIDを取得します。

ログイングループ内で登録されている全てのロールのIDを取得します。
存在しない場合は空の配列を返却します。

戻り値:
ロールIDの配列
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getRoles

public Role[] getRoles()
                throws AccessSecurityReadException
すべてのロール情報を取得します。

ログイングループ内のロール情報を全て取得します。

戻り値:
ロール情報の配列(存在しない場合は空のモデルを返却します。)
例外:
AccessSecurityReadException - 読み込み処理に失敗した場合にスローされます。

getRolesByCategory

public Role[] getRolesByCategory(String category)
                          throws AccessSecurityException
カテゴリー検索によりロールを取得します。

指定したカテゴリーに属するロール情報を全て取得します。

パラメータ:
category - カテゴリー
戻り値:
ロールの配列(検索にヒットしない場合は空のロール)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

getRolesByIds

public Role[] getRolesByIds(String[] roleIds)
                     throws AccessSecurityException
ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。

パラメータ:
roleIds - ロールIDの配列
戻り値:
ロール情報の配列（データがない場合は空の配列を返します。）
例外:
AccessSecurityException - ロール情報の取得に失敗した場合にスローされます。

getSubRole

public String[] getSubRole(String roleId)
                    throws AccessSecurityException
サブロール(一階層のみ)を取得します。

パラメータ:
roleId -
戻り値:
ロールの配列
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

importData

public void importData(String category,
                       InputStream inputStream)
                throws AccessSecurityException
ロール情報・インポート。

パラメータ:
category - カテゴリ
inputStream - 入力ストリーム
例外:
AccessSecurityException - インポートに失敗した場合、または引数が不正だった場合にスローされます。

moveCategory

public void moveCategory(String oldCategory,
                         String newCategory)
                  throws AccessSecurityException
カテゴリーを更新します。

ログイングループ内のカテゴリーを更新します。

パラメータ:
oldCategory - 旧カテゴリー
newCategory - 新カテゴリー
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。

searchRolesById

public Role[] searchRolesById(String key)
                       throws AccessSecurityException
ロールID検索によりロールを取得します。

引数に類似(前方後方一致)するロールIDを持つロール情報を全て取得します。

パラメータ:
key - 検索ロールID
戻り値:
ロールの配列(検索にヒットしない場合は空のロール)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

searchRolesByName

public Role[] searchRolesByName(String name)
                         throws AccessSecurityException
ロール名称検索によりロールを取得します。

引数に類似(前方後方一致)する名称を持つロール情報を全て取得します。

パラメータ:
name - 検索ロール名称
戻り値:
ロールの配列(検索にヒットしない場合は空の配列)
例外:
AccessSecurityException - 読み込み処理に失敗した場合、または引数が不正だった場合にスローされます。

updateRole

public void updateRole(Role role)
                throws AccessSecurityException
ロール情報を更新します。

データソース上の指定のロール情報を更新します。

パラメータ:
role - ロール情報
例外:
AccessSecurityException - 書き込み処理に失敗した場合、または引数が不正だった場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RolePostWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RolePostWriterListener

public interface RolePostWriterListener

ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | postCreateRole(String groupId, Role role) ロール情報をデータストアに作成した直後にコールされます。
void | postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます。
void | postDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます。
void | postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます。
void | postUpdateRole(String groupId, Role role) ロール情報をデータストアに更新した直後にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

postCreateRole

public void postCreateRole(String groupId,
                           Role role)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアに作成した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteRole

public void postDeleteRole(String groupId,
                           String roleId)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアから削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されたロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateRole

public void postUpdateRole(String groupId,
                           Role role)
                    throws AccessSecurityListenerExcpetion
ロール情報をデータストアに更新した直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateSubRole

public void postCreateSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールにサブロールを追加した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteSubRole

public void postDeleteSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールからサブロールを削除した直後にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleQueryWriterListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleQueryWriterListener

public interface RoleQueryWriterListener

ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | postCreateSubRole(String groupId, String roleId, String subRoleId) ロールにサブロールを追加する直前にコールされます。
void | postDeleteSubRole(String groupId, String roleId, String subRoleId) ロールからサブロールを削除する直前にコールされます。
void | queryCreateRole(String groupId, Role role) ロール情報をデータストアに作成する直前にコールされます。
void | queryDeleteRole(String groupId, String roleId) ロール情報をデータストアから削除する直前にコールされます。
void | queryUpdateRole(String groupId, Role role) ロール情報をデータストアに更新する直前にコールされます。

メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateRole

public void queryCreateRole(String groupId,
                            Role role)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアに作成する直前にコールされます。

パラメータ:
groupId - ログイングループID
role - 作成されるロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteRole

public void queryDeleteRole(String groupId,
                            String roleId)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアから削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - 削除されるロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateRole

public void queryUpdateRole(String groupId,
                            Role role)
                     throws AccessSecurityListenerExcpetion
ロール情報をデータストアに更新する直前にコールされます。

パラメータ:
groupId - ログイングループID
role - 更新されるロール
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateSubRole

public void postCreateSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールにサブロールを追加する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されるサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteSubRole

public void postDeleteSubRole(String groupId,
                              String roleId,
                              String subRoleId)
                       throws AccessSecurityListenerExcpetion
ロールからサブロールを削除する直前にコールされます。

パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されるサブロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleReaderDecorator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
インタフェース RoleReaderDecorator

public interface RoleReaderDecorator

ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Role | doDecoration(String groupId, Role role) ロール情報をデータストアから読み込んだ直後にコールされます。
void | init(Map params) ロールデコレータの初期化。

メソッドの詳細

doDecoration

public Role doDecoration(String groupId,
                         Role role)
ロール情報をデータストアから読み込んだ直後にコールされます。

パラメータ:
groupId - ログイングループID
role - 読み込みが行われたロール情報
戻り値:
拡張されたロール情報

init

public void init(Map params)
ロールデコレータの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

パラメータ:
params - 初期化パラメータのマップ(Map)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardRoleBackup (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.role
クラス StandardRoleBackup

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.role.StandardRoleBackup
すべての実装インタフェース:
RoleExporter, RoleImporter
public class StandardRoleBackup
extends Object
implements RoleImporter, RoleExporter

ロールバックアップクラスです。

バージョン:
1.0

フィールドの概要
static String KIND_ROLE
種別 ロール。
コンストラクタの概要
StandardRoleBackup()
メソッドの概要
void | doExport(RoleManager manager, OutputStream outputStream) エクスポートを行います。
void | doImport(InputStream inputStream, RoleManager manager) インポートを行います。
void | init(Map params) 初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KIND_ROLE

public static final String KIND_ROLE
種別 ロール。

関連項目:
定数フィールド値
コンストラクタの詳細

StandardRoleBackup

public StandardRoleBackup()
メソッドの詳細

init

public void init(Map params)
初期化。

初期化する。

定義:
インタフェース RoleImporter 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

doImport

public void doImport(InputStream inputStream,
                     RoleManager manager)
              throws AccessSecurityImportException
インポートを行います。

ストリーム内の情報からロール情報を生成します。

定義:
インタフェース RoleImporter 内の doImport
パラメータ:
manager - ロールマネージャクラス
inputStream - 入力ストリーム
例外:
AccessSecurityImportException

doExport

public void doExport(RoleManager manager,
                     OutputStream outputStream)
              throws AccessSecurityExportException
エクスポートを行います。

ロールバックアップ情報を生成し、ストリームに返却します。

定義:
インタフェース RoleExporter 内の doExport
パラメータ:
manager - ロールマネージャクラス
outputStream - 出力ストリーム
例外:
AccessSecurityExportException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.MenuServlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.MenuServlet の使用

jp.co.intra_mart.foundation.security.servlet.MenuServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet の使用

jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.servlet.UserInitialServlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.servlet.UserInitialServlet の使用

jp.co.intra_mart.foundation.security.servlet.UserInitialServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


GroupSuperUserInitialServlet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス GroupSuperUserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class GroupSuperUserInitialServlet
extends HttpServlet

グループ管理者初期アクセスサーブレット。

システム管理者での初期アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
GroupSuperUserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GroupSuperUserInitialServlet

public GroupSuperUserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MenuServlet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス MenuServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.MenuServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class MenuServlet
extends HttpServlet

メニュー連携サーブレットクラス。

メニューIDから画面に遷移を行うサーブレットです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MenuServlet()
コンストラクタ。
メソッドの概要
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドです。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドです。
void | init() メニューサーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MenuServlet

public MenuServlet()
コンストラクタ。

メソッドの詳細

init

public void init()
          throws ServletException
メニューサーブレットの初期化を行います。

例外:
ServletException
関連項目:
Servlet.init(javax.servlet.ServletConfig)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
例外:
ServletException
IOException
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドです。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
例外:
ServletException
IOException
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security.servlet (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security.servlet
クラス
GroupSuperUserInitialServlet
MenuServlet
SuperUserInitialServlet
UserCertificationServlet
UserInitialServlet


jp.co.intra_mart.foundation.security.servlet (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.servlet

サーブレットに関連するクラスを提供します。

参照:
説明

クラスの概要
GroupSuperUserInitialServlet | グループ管理者初期アクセスサーブレット。
MenuServlet | メニュー連携サーブレットクラス。
SuperUserInitialServlet | システム管理者初期アクセスサーブレット。
UserCertificationServlet | ユーザ認証サーブレット。
UserInitialServlet | ユーザ初期アクセスサーブレット。

パッケージ jp.co.intra_mart.foundation.security.servlet の説明

サーブレットに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security.servlet クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security.servlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.MenuServlet
        • class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security.servlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security.servlet の使用

jp.co.intra_mart.foundation.security.servlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SuperUserInitialServlet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス SuperUserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class SuperUserInitialServlet
extends HttpServlet

システム管理者初期アクセスサーブレット。

システム管理者での初期アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SuperUserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SuperUserInitialServlet

public SuperUserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserCertificationServlet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス UserCertificationServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class UserCertificationServlet
extends HttpServlet

ユーザ認証サーブレット。

ユーザでの認証アクセスを処理するサーブレット。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserCertificationServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserCertificationServlet

public UserCertificationServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserInitialServlet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.servlet
クラス UserInitialServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.foundation.security.servlet.UserInitialServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class UserInitialServlet
extends HttpServlet

ユーザ初期アクセスサーブレット。

ユーザでの初期アクセスを処理するサーブレット。

利用するクライアントタイプ別にサーブレットおよびサーブレットマッピングを定義します。(web.xml)
サーブレットを定義する場合に必以下の初期化パラメータが必要です。

パラメータ名 | 説明
client-type | このサーブレットが処理するクライアントタイプです。
group-regexp | URLからログイングループIDを抜き出すための正規表現です。 正規表現の()内にマッチしたものをログイングループIDと見なします。 省略した場合のデフォルトは(.+)\.です。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserInitialServlet()
メソッドの概要
void | destroy() サーブレットの放棄を行います。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init() サーブレットの初期化を行います。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UserInitialServlet

public UserInitialServlet()
メソッドの詳細

destroy

public void destroy()
サーブレットの放棄を行います。

導入されたバージョン:
5.0
関連項目:
Servlet.destroy()

init

public void init()
          throws ServletException
サーブレットの初期化を行います。

例外:
ServletException - サーブレットでエラーが発生した場合スローします。
導入されたバージョン:
5.0
関連項目:
GenericServlet.init()

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doGet(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。

パラメータ:
request - HTTPサーブレットリクエスト
response - HTTPサーブレットレスポンス
例外:
ServletException - サーブレットでエラーが発生した場合スローします。
IOException - 入出力エラーが発生した場合スローします。
関連項目:
HttpServlet.doPost(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccessSecurityManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス AccessSecurityManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.AccessSecurityManager
public class AccessSecurityManager
extends Object

アクセスセキュリティマネージャクラス。

アクセスセキュリティの認証処理をするためのクラスです。
アクセスセキュリティの認証処理を行う場合は、必ずこのクラスを利用します。
また、システムセッション情報を取得する場合は、このクラスを利用して取得します。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static void | clearInstance() アクセスセキュリティマネージャのインスタンスを初期化します。
LoginRequestInfo | createLoginRequestInfo(String loginType) ログイン情報を作成します。
String | createUrlSignature(String url, String groupId, String userId) ダイレクトＵＲＬ署名を作成します。
int | forceLogin(LoginRequestInfo loginRequestInfo) 強制ログイン処理を行います。
int | forceLogin(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) 強制ログイン処理を行います。
void | forward(HttpServletRequest request, HttpServletResponse response, String url) 指定したURLにフォワードします。
void | forward(String url) 指定したURLにフォワードします。
SessionInfo | getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
SessionInfo | getCookieSessionInfo(HttpServletRequest request) クッキーからintra-martセッション情報を取得します。
String | getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
String | getErrorPage(int errorCode, HttpServletRequest request, HttpServletResponse response) エラーページＵＲＬを取得します。
int | getInitialCertification(LoginRequestInfo loginInfo) カレントスレッドの情報から初期アクセス処理を行います。
int | getInitialCertification(LoginRequestInfo loginInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセス処理を行います。
String | getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
String | getInitialPage(SessionInfo sessionInfo) カレントスレッド情報から初期アクセスページURLを取得します。
String | getInitialPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) 初期アクセスページURLを取得します。
static AccessSecurityManager | getInstance() セキュリティマネージャのインスタンスを取得します。
int | getLicense(LoginInfo loginInfo) アカウントライセンスチェックを行います。
int | getLoginCertification() カレントスレッド情報からログイン処理を行います。
int | getLoginCertification(HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
String | getMainPage() カレントスレッド情報からメインページURLを取得します。
String | getMainPage(SessionInfo sessionInfo) カレントスレッド情報からメインページURLを取得します。
String | getMainPage(SessionInfo sessionInfo, HttpServletRequest request, HttpServletResponse response) メインページURLを取得します。
SessionConfig | getSessionConfig() セッション情報保管パラメータを取得します。
SessionInfo | getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
SessionInfo | getSessionInfo(HttpServletRequest request, HttpServletResponse response) intra-martセッション情報を取得します。
int | getSessionMode() intra-martセッションの状態を取得します。
int | getSessionMode(SessionInfo sessionInfo) intra-martセッションの状態を取得します。
int | login(LoginRequestInfo loginRequestInfo) ログイン処理を行います。
int | login(LoginRequestInfo loginRequestInfo, HttpServletRequest request, HttpServletResponse response) ログイン処理を行います。
void | logout() ログアウト処理を行います。
void | logout(HttpServletRequest request, HttpServletResponse response) ログアウト処理を行います。
void | secureRedirect(HttpServletRequest request, HttpServletResponse response, String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
void | secureRedirect(String url, Map args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

clearInstance

public static void clearInstance()
アクセスセキュリティマネージャのインスタンスを初期化します。

アクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。
通常、このメソッドを使用する必要はありません。

getInstance

public static AccessSecurityManager getInstance()
                                         throws AccessSecurityException
セキュリティマネージャのインスタンスを取得します。

戻り値:
セキュリティマネージャインスタンス
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

createLoginRequestInfo

public LoginRequestInfo createLoginRequestInfo(String loginType)
ログイン情報を作成します。

パラメータ:
loginType - ログインタイプ
システム管理者 | SecurityConstraint.LT_SUPER
グループ管理者 | SecurityConstraint.LT_GROUP
ユーザ | SecurityConstraint.LT_USER
戻り値:
ログイン情報

createUrlSignature

public String createUrlSignature(String url,
                                 String groupId,
                                 String userId)
                          throws AccessSecurityException
ダイレクトＵＲＬ署名を作成します。

パラメータ:
url - ダイレクトＵＲＬ
groupId - ログイングループＩＤ
userId - ユーザＩＤ
戻り値:
ダイレクトURL署名
例外:
AccessSecurityException - 引数が不正だった場合に例外がスローされます。

forceLogin

public int forceLogin(LoginRequestInfo loginRequestInfo)
               throws NoFilterException,
                      AccessSecurityException
強制ログイン処理を行います。

パスワード認証を行わずに強制的にログインします。
ただし、引数のログイン情報に存在しないログイングループを設定した場合は、ログインできません。

パラメータ:
loginRequestInfo - ログイン情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

forceLogin

public int forceLogin(LoginRequestInfo loginRequestInfo,
                      HttpServletRequest request,
                      HttpServletResponse response)
               throws AccessSecurityException
強制ログイン処理を行います。

パスワード認証を行わずに強制的にログインします。
ただし、引数のログイン情報に存在しないログイングループを設定した場合は、ログインできません。

パラメータ:
loginRequestInfo - ログイン情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

forward

public void forward(HttpServletRequest request,
                    HttpServletResponse response,
                    String url)
             throws ServletException,
                    IOException,
                    AccessSecurityException
指定したURLにフォワードします。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
url - ＵＲＬ
例外:
IOException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
ServletException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

forward

public void forward(String url)
             throws NoFilterException,
                    ServletException,
                    IOException,
                    AccessSecurityException
指定したURLにフォワードします。

パラメータ:
url - ＵＲＬ
例外:
IOException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
ServletException - 最終的なフォワード先となるリソースがこの例外をスローした場合にスローします。
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

getCookieSessionInfo

public SessionInfo getCookieSessionInfo()
                                 throws NoFilterException
カレントスレッド情報のクッキーからintra-martセッション情報を取得します。

このメソッドを利用するためには、jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestManagementFilterを
web.xmlにフィルタとして設定する必要があります。

戻り値:
クッキーに保管されているintra-martセッション情報
セッション情報保管用のクッキーが存在しない場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエストが取得できなかった場合にスローします。

getCookieSessionInfo

public SessionInfo getCookieSessionInfo(HttpServletRequest request)
クッキーからintra-martセッション情報を取得します。

パラメータ:
request - サーブレットリクエスト
戻り値:
クッキーに保管されているintra-martセッション情報
セッション情報保管用のクッキーが存在しない場合はnullを返します。

getErrorPage

public String getErrorPage(int errorCode)
                    throws NoFilterException,
                           AccessSecurityException
カレントスレッド情報からエラーページＵＲＬを取得します。

引数で指定したエラーページＵＲＬを返却します。

パラメータ:
errorCode - ログインエラーコード (SecurityConstraint.CR_* を参照)
戻り値:
エラーページのＵＲＬ
ページが存在しなかった場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getErrorPage

public String getErrorPage(int errorCode,
                           HttpServletRequest request,
                           HttpServletResponse response)
                    throws AccessSecurityException
エラーページＵＲＬを取得します。

引数で指定したエラーページＵＲＬを返却します。

パラメータ:
errorCode - ログインエラーコード (SecurityConstraint.CR_* を参照)
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
エラーページのURL
ページが存在しなかった場合はnullを返します。
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getInitialCertification

public int getInitialCertification(LoginRequestInfo loginInfo)
                            throws NoFilterException,
                                   AccessSecurityException
カレントスレッドの情報から初期アクセス処理を行います。

パラメータ:
loginInfo - ログインリクエスト情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialCertification

public int getInitialCertification(LoginRequestInfo loginInfo,
                                   HttpServletRequest request,
                                   HttpServletResponse response)
                            throws AccessSecurityException
初期アクセス処理を行います。

パラメータ:
loginInfo - ログインリクエスト情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage()
                      throws NoFilterException,
                             AccessSecurityException
カレントスレッド情報から初期アクセスページURLを取得します。

現在のセッション情報から初期アクセスページURLを取得します。

戻り値:
初期アクセスページURL
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage(SessionInfo sessionInfo)
                      throws NoFilterException,
                             AccessSecurityException
カレントスレッド情報から初期アクセスページURLを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
初期アクセスページURL
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getInitialPage

public String getInitialPage(SessionInfo sessionInfo,
                             HttpServletRequest request,
                             HttpServletResponse response)
                      throws AccessSecurityException
初期アクセスページURLを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLicense

public int getLicense(LoginInfo loginInfo)
               throws AccessSecurityException
アカウントライセンスチェックを行います。

パラメータ:
loginInfo - ログインリクエスト情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLoginCertification

public int getLoginCertification()
                          throws NoFilterException,
                                 AccessSecurityException
カレントスレッド情報からログイン処理を行います。

ログイン処理後のページを取得します。

戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getLoginCertification

public int getLoginCertification(HttpServletRequest request,
                                 HttpServletResponse response)
                          throws AccessSecurityException
ログイン処理を行います。

ログイン処理後のページを取得します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage()
                   throws NoFilterException,
                          AccessSecurityException
カレントスレッド情報からメインページURLを取得します。

現在のセッション情報からログイン後のメインページを取得します。

戻り値:
メインページURL
ページが存在しなかった場合は、nullを返却します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage(SessionInfo sessionInfo)
                   throws NoFilterException,
                          AccessSecurityException
カレントスレッド情報からメインページURLを取得します。

ログイン後のメインページを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
メインページURL
ページが存在しなかった場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getMainPage

public String getMainPage(SessionInfo sessionInfo,
                          HttpServletRequest request,
                          HttpServletResponse response)
                   throws AccessSecurityException
メインページURLを取得します。

ログイン後のメインページを取得します。

パラメータ:
sessionInfo - intra-martセッション情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
メインページURL
ページが存在しなかった場合は、nullを返します。
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

getSessionConfig

public SessionConfig getSessionConfig()
                               throws AccessSecurityException
セッション情報保管パラメータを取得します。

戻り値:
セッション情報保管パラメータ情報
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

getSessionInfo

public SessionInfo getSessionInfo()
                           throws NoFilterException,
                                  AccessSecurityException
カレントスレッド情報からintra-martセッション情報を取得します。

このメソッドを利用するためには、jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilterを
web.xmlにフィルタとして設定する必要があります。

戻り値:
intra-martセッション情報
セッションが存在しない場合はnullを返します。
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 引数が不正だった場合にスローされます。

getSessionInfo

public SessionInfo getSessionInfo(HttpServletRequest request,
                                  HttpServletResponse response)
                           throws AccessSecurityException
intra-martセッション情報を取得します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
intra-martセッション情報
セッションが存在しない場合はnullを返します。
例外:
AccessSecurityException - 引数が不正だった場合にスローされます。

getSessionMode

public int getSessionMode()
                   throws AccessSecurityException,
                          NoFilterException
intra-martセッションの状態を取得します。

戻り値:
セッション状態
初期状態 | SecurityConstraint.CR_SESSION_INITIAL
ログオン状態 | SecurityConstraint.CR_SESSION_LOGON
セッション不整合状態 | SecurityConstraint.CR_SESSION_UNMATCH
セッションタイムアウト状態 | SecurityConstraint.CR_SESSION_TIMEOUT
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。

getSessionMode

public int getSessionMode(SessionInfo sessionInfo)
                   throws AccessSecurityException
intra-martセッションの状態を取得します。

パラメータ:
sessionInfo - intra-martセッション情報
戻り値:
セッション状態
初期状態 | SecurityConstraint.CR_SESSION_INITIAL
ログオン状態 | SecurityConstraint.CR_SESSION_LOGON
セッション不整合状態 | SecurityConstraint.CR_SESSION_UNMATCH
セッションタイムアウト状態 | SecurityConstraint.CR_SESSION_TIMEOUT
例外:
AccessSecurityException - アクセスセキュリティ設定またはシステム設定に誤りがあった場合にスローします。

login

public int login(LoginRequestInfo loginRequestInfo)
          throws NoFilterException,
                 AccessSecurityException
ログイン処理を行います。

引数のログイン情報を使用して通常のログイン処理を行います。

パラメータ:
loginRequestInfo - ログイン情報
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

login

public int login(LoginRequestInfo loginRequestInfo,
                 HttpServletRequest request,
                 HttpServletResponse response)
          throws AccessSecurityException
ログイン処理を行います。

引数のログイン情報を使用して通常のログイン処理を行います。

パラメータ:
loginRequestInfo - ログイン情報
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード (SecurityConstraint.CR_* を参照)
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

logout

public void logout()
            throws NoFilterException,
                   AccessSecurityException
ログアウト処理を行います。

セッション情報を初期化します。

例外:
NoFilterException - カレントスレッドからサーブレットリクエスト・レスポンスが取得できなかった場合にスローします。
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

logout

public void logout(HttpServletRequest request,
                   HttpServletResponse response)
            throws AccessSecurityException
ログアウト処理を行います。

セッション情報を初期化します。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
戻り値:
ログインエラーコード
例外:
AccessSecurityException - 以下の条件の場合、エラーをスローします。 アクセスセキュリティ設定に誤りがあった場合。
システム設定に誤りがあった場合。
引数が不正だった場合。

secureRedirect

public void secureRedirect(HttpServletRequest request,
                           HttpServletResponse response,
                           String url,
                           Map args)
                    throws ServletException,
                           IOException
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

外部のURLの場合は、プロトコルから指定します。

内部のURLの場合は以下の通りです。
ページベースのパスにリダイレクトする場合は、最後に拡張子".jssp"が必要です。
その他のパスにダイレクトする場合は、コンテキストパスからの相対URLとなります。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
url - リダイレクトURL
args - リダイレクトURLの引数(マップ形式)
例外:
IOException
ServletException

secureRedirect

public void secureRedirect(String url,
                           Map args)
                    throws NoFilterException,
                           ServletException,
                           IOException
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

外部のURLの場合は、プロトコルから指定します。

内部のURLの場合は以下の通りです。
ページベースのパスにリダイレクトする場合は、最後に拡張子".jssp"が必要です。
その他のパスにダイレクトする場合は、コンテキストパスからの相対URLとなります。

パラメータ:
url - リダイレクトURL（コンテキストパスからの相対URL）
args - リダイレクトURLの引数(マップ形式)
例外:
ServletException
IOException
NoFilterException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ClientTypeInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ClientTypeInfo

public interface ClientTypeInfo

クライアントタイプ情報インタフェース。

クライアントタイプの情報を参照するインタフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getDisplayName() クライアントタイプ表示名を取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。

戻り値:
クライアントタイプ

getDisplayName

public String getDisplayName()
クライアントタイプ表示名を取得する。

戻り値:
クライアントタイプの表示名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ColorPatternInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ColorPatternInfo

public interface ColorPatternInfo

カラーパターン情報を取得するインタフェース。

カラーパターン情報を参照する場合はこのインタフェースを利用して取得する。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getColorCode() カラーパターンコードを取得します。
String | getColorPatternId() カラーパターンIDを取得します。
String | getCssFile() カラーパターンのCSSファイルパスを取得します。
String | getDisplayName() カラーパターン表示名を取得します。
String | getImageFolder() カラーパターンのイメージファイルのフォルダを取得します。
String | getProperty(String key) カラーパターンのプロパティ情報を取得します。
String[] | getPropertyKeys() カラーパターンのプロパティ情報のキー一覧を取得します。

メソッドの詳細

getColorCode

public String getColorCode()
カラーパターンコードを取得します。

カラーパターンをイメージするカラーコード
#rrggbb形式で返却する。

戻り値:
カラーパターンコード

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得します。

戻り値:
カラーパターンID

getCssFile

public String getCssFile()
カラーパターンのCSSファイルパスを取得します。

コンテキストパスからの相対パス。（'/'から始まります。）

戻り値:
cssPath CSSファイルパス

getDisplayName

public String getDisplayName()
カラーパターン表示名を取得します。

戻り値:
カラーパターンの表示名

getImageFolder

public String getImageFolder()
カラーパターンのイメージファイルのフォルダを取得します。

コンテキストパスからの相対パス。（'/'から始まります。）

戻り値:
imagePath イメージファイルのフォルダ

getProperty

public String getProperty(String key)
カラーパターンのプロパティ情報を取得します。

パラメータ:
key - プロパティキー
戻り値:
プロパティ情報

getPropertyKeys

public String[] getPropertyKeys()
カラーパターンのプロパティ情報のキー一覧を取得します。

戻り値:
カラーパターンのプロパティ情報のキー一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DepartmentInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス DepartmentInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.DepartmentInfo
すべての実装インタフェース:
Serializable
public class DepartmentInfo
extends Object
implements Serializable

組織情報クラス。

組織情報を保管するクラスです。
メニュー、アクセスコントロールの組織設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DepartmentInfo(String companyCode, String departmentCode)
コンストラクタ。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getDepartmentCode() 組織コードを取得します。
String | getKeyString() 組織情報の識別子を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DepartmentInfo

public DepartmentInfo(String companyCode,
                      String departmentCode)
コンストラクタ。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
companyCode 会社コード

getDepartmentCode

public String getDepartmentCode()
組織コードを取得します。

戻り値:
departmentCode 組織コード

getKeyString

public String getKeyString()
組織情報の識別子を取得します。

戻り値:
組織情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendsImport (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース ExtendsImport

public interface ExtendsImport

拡張インポート処理インターフェース。

拡張インポート処理を行うためのインターフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 void doImport(String groupId)
拡張インポート処理を行います。

メソッドの詳細

doImport

public void doImport(String groupId)
拡張インポート処理を行います。

トランザクションが必要な場合は、内部でトランザクション処理を行ってください。

パラメータ:
groupId - 対象のログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendsImportManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス ExtendsImportManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.ExtendsImportManager
public class ExtendsImportManager
extends Object

拡張インポートマネージャクラス。

拡張インポート処理を実行するマネージャクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
void | doImport(String groupId, String module) 拡張インポート処理を実行します。
static ExtendsImportManager | getInstance()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static ExtendsImportManager getInstance()

doImport

public void doImport(String groupId,
                     String module)
              throws AccessSecurityException
拡張インポート処理を実行します。

引数moduleには、クラスまたはJSのパスを指定できます。
クラスを指定する場合は、ExtendsImportを継承したクラスのフルパッケージ名を指定してください。

JSのパスを指定する場合は、指定するJSファイルに記述されている"doImport""関数をコールします。
"doImport""関数の第一引数にログイングループIDを引き渡します。
パスの指定は、pagesからの相対パスで、最後に".js"を含んだものである必要があります。
例：
function doImport(group){
......

}

パラメータ:
groupId - ログイングループID
module - 拡張インポート処理を行うクラス名またはJSのパス
例外:
AccessSecurityException - クラス名のインスタンスの生成に失敗した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


INonTransaction (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース INonTransaction

public interface INonTransaction

分散トランザクション未対応のアクセッサに実装するインターフェース。

分散トランザクション未対応のアクセッサに実装する。

導入されたバージョン:
5.0
バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース LocaleInfo

すべてのスーパーインタフェース:
LocaleProvider
public interface LocaleInfo
extends LocaleProvider

ロケｰル情報・モデルインタフェース。

ロケールのデータモデルのインタフェースを定義

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getDisplayName() ロケ－ル表示名取得。
String | getEncoding() デフォルトエンコーディングの取得。
String[] | getEncodings() ロケ－ルに対応しているエンコーディングの一覧の取得。
Locale | getLocale() ロケ－ル取得。

メソッドの詳細

getDisplayName

public String getDisplayName()
ロケ－ル表示名取得。

ロケ－ル表示名を取得する

戻り値:
ロケｰル表示名

getEncoding

public String getEncoding()
デフォルトエンコーディングの取得。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
デフォルトエンコーディング

getEncodings

public String[] getEncodings()
ロケ－ルに対応しているエンコーディングの一覧の取得。

ロケ－ルに対応しているエンコーディングの一覧の取得

戻り値:
対応しているエンコーディングの一覧

getLocale

public Locale getLocale()
ロケ－ル取得。

ロケ－ルを取得する

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケｰル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース LocaleProvider

既知のサブインタフェースの一覧:
LocaleInfo, LoginInfo, LoginRequestInfo, SessionInfo
既知の実装クラスの一覧:
Account, LoginGroup, SuperUser
public interface LocaleProvider

ロケール取得プロバイダーインタフェース。 ロケール情報を取得するためのインタフェース。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ロケールを取得する。

メソッドの詳細

getLocale

public Locale getLocale()
ロケールを取得する。

戻り値:
ロケール

getEncoding

public String getEncoding()
エンコーディングを取得する。

戻り値:
エンコーディング
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.security (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.security
インタフェース
ClientTypeInfo
ColorPatternInfo
ExtendsImport
INonTransaction
LocaleInfo
LocaleProvider
SecurityConstraint
SessionConfig
SessionInfo
SystemSourceProvider
クラス
AccessSecurityManager
DepartmentInfo
ExtendsImportManager
PostInfo
PublicGroupInfo
SystemManager


jp.co.intra_mart.foundation.security (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security

アクセスセキュリティに関連するクラスを提供します。

参照:
説明

インタフェースの概要
ClientTypeInfo | クライアントタイプ情報インタフェース。
ColorPatternInfo | カラーパターン情報を取得するインタフェース。
ExtendsImport | 拡張インポート処理インターフェース。
INonTransaction | 分散トランザクション未対応のアクセッサに実装するインターフェース。
LocaleInfo | ロケｰル情報・モデルインタフェース。
LocaleProvider | ロケール取得プロバイダーインタフェース。
SecurityConstraint | アクセスセキュリティ定数インタフェース。
SessionConfig | セッションに関する設定情報を取得するインタフェース。
SessionInfo | intra-martセッション情報参照インタフェース。
SystemSourceProvider | ロケール情報取得インターフェース。

クラスの概要
AccessSecurityManager | アクセスセキュリティマネージャクラス。
DepartmentInfo | 組織情報クラス。
ExtendsImportManager | 拡張インポートマネージャクラス。
PostInfo | 役職情報クラス。
PublicGroupInfo | パブリックグループ情報クラス。
SystemManager | システムマネージャクラス。

パッケージ jp.co.intra_mart.foundation.security の説明

アクセスセキュリティに関連するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.security クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.security の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.security.AccessSecurityManager
    • class jp.co.intra_mart.foundation.security.DepartmentInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.ExtendsImportManager
    • class jp.co.intra_mart.foundation.security.PostInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.PublicGroupInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.SystemManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.ClientTypeInfo
  • interface jp.co.intra_mart.foundation.security.ColorPatternInfo
  • interface jp.co.intra_mart.foundation.security.ExtendsImport
  • interface jp.co.intra_mart.foundation.security.INonTransaction
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.LocaleInfo
    • interface jp.co.intra_mart.foundation.security.SessionInfo
  • interface jp.co.intra_mart.foundation.security.SecurityConstraint
  • interface jp.co.intra_mart.foundation.security.SessionConfig
  • interface jp.co.intra_mart.foundation.security.SystemSourceProvider
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.security の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.security の使用

jp.co.intra_mart.foundation.security を使用しているパッケージ
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。

jp.co.intra_mart.foundation.security により使用される jp.co.intra_mart.foundation.security のクラス
AccessSecurityManager
アクセスセキュリティマネージャクラス。
ClientTypeInfo
クライアントタイプ情報インタフェース。
ColorPatternInfo
カラーパターン情報を取得するインタフェース。
ExtendsImportManager
拡張インポートマネージャクラス。
LocaleInfo
ロケｰル情報・モデルインタフェース。
LocaleProvider
ロケール取得プロバイダーインタフェース。
SessionConfig
セッションに関する設定情報を取得するインタフェース。
SessionInfo
intra-martセッション情報参照インタフェース。
SystemManager
システムマネージャクラス。
SystemSourceProvider
ロケール情報取得インターフェース。

jp.co.intra_mart.foundation.security.account により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.admin により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.certification により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。
SessionInfo
intra-martセッション情報参照インタフェース。

jp.co.intra_mart.foundation.security.group により使用される jp.co.intra_mart.foundation.security のクラス
LocaleProvider
ロケール取得プロバイダーインタフェース。

jp.co.intra_mart.foundation.security.menu により使用される jp.co.intra_mart.foundation.security のクラス
DepartmentInfo
組織情報クラス。
PostInfo
役職情報クラス。
PublicGroupInfo
パブリックグループ情報クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PostInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス PostInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.PostInfo
すべての実装インタフェース:
Serializable
public class PostInfo
extends Object
implements Serializable

役職情報クラス。

役職情報を保管するクラスです。
メニュー、アクセスコントロールの役職設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PostInfo(String companyCode, String postCode)
コンストラクタ。
メソッドの概要
String | getCompanyCode() 会社コードを取得します。
String | getKeyString() 役職情報の識別子を取得します。
String | getPostCode() 役職コードを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PostInfo

public PostInfo(String companyCode,
                String postCode)
コンストラクタ。

メソッドの詳細

getCompanyCode

public String getCompanyCode()
会社コードを取得します。

戻り値:
companyCode 会社コード

getPostCode

public String getPostCode()
役職コードを取得します。

戻り値:
postCode 役職コード

getKeyString

public String getKeyString()
役職情報の識別子を取得します。

戻り値:
役職情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PublicGroupInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス PublicGroupInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.PublicGroupInfo
すべての実装インタフェース:
Serializable
public class PublicGroupInfo
extends Object
implements Serializable

パブリックグループ情報クラス。

パブリックグループ情報を保管するクラスです。
メニュー、アクセスコントロールのパブリックグループ設定情報として利用します。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PublicGroupInfo(String groupSetCode, String groupCode)
コンストラクタ。
メソッドの概要
String | getGroupCode() グループコードを取得します。
String | getGroupSetCode() グループセットコードを取得します。
String | getKeyString() パブリックグループ情報の識別子を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupInfo

public PublicGroupInfo(String groupSetCode,
                       String groupCode)
コンストラクタ。

メソッドの詳細

getGroupSetCode

public String getGroupSetCode()
グループセットコードを取得します。

戻り値:
groupSetCode グループセットコード

getGroupCode

public String getGroupCode()
グループコードを取得します。

戻り値:
groupCode グループコード

getKeyString

public String getKeyString()
パブリックグループ情報の識別子を取得します。

戻り値:
パブリックグループ情報の識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SecurityConstraint (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SecurityConstraint

public interface SecurityConstraint

アクセスセキュリティ定数インタフェース。 アクセスセキュリティで使用する定数値を定義したインターフェース。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | ATTR_DO_FILTER セッションフィルター制御パラメータ名。
static String | CP_COOKIE セッション情報をクッキーに保管するパラメータ名。
static int | CR_ERROR 認証処理エラーの返却値。
static int | CR_LOCKED アカウントロック状態の返却値。
static int | CR_NG ログインエラーの返却値。
static int | CR_NO_GROUP ログイングループ未登録状態の返却値。
static int | CR_NO_LICENSE ライセンスなし、または有効期間外状態の返却値。
static int | CR_NO_PERMISSION 無許可ページへのアクセスの返却値。
static int | CR_NO_USER ユーザ未登録状態の返却値。
static int | CR_OK 認証成功の返却値。
static int | CR_SESSION_INITIAL セッション初期状態の返却値。
static int | CR_SESSION_LOGON セッションログオン状態の返却値。
static int | CR_SESSION_TIMEOUT セッションタイムアウト状態の返却値。
static int | CR_SESSION_UNMATCH セッション不整合状態の返却値。
static String | LT_GROUP グループマネージャー（ログインタイプ）。
static String | LT_SUPER スーパーユーザ（ログインタイプ）。
static String | LT_USER ユーザ（ログインタイプ）。
static String | RP_CLIENT_TYPE クライアントタイプのデフォルトＵＲＬ引数名。
static String | RP_ENCODING ログインエンコーディングのデフォルトＵＲＬ引数名。
static String | RP_INITIAL_URL 初期ＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_LOCALE ログインロケールのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_GROUP ログイングループIDのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_TYPE ログインタイプのデフォルトＵＲＬ引数名。
static String | RP_PASSWORD パスワードのデフォルトＵＲＬ引数名。
static String | RP_URL ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_URL_SIGN ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
static String | RP_USER ログインユーザＩＤのデフォルトＵＲＬ引数名。
static String | SP_CLIENT_TYPE クライアントタイプをセッションに保管するパラメータ名。
static String | SP_COLOR_PATTERN_ID カラーパターンIDをセッションに保管するパラメータ名。
static String | SP_ENCODING ログインエンコーディングをセッションに保管するパラメータ名。
static String | SP_INITIAL_URL 初期ページURLを属性に保管するパラメータ名。
static String | SP_LOCALE ログインロケールをセッションに保管するパラメータ名。
static String | SP_LOGIN_GROUP ログイングループIDをセッションに保管するパラメータ名。
static String | SP_LOGIN_TIME ログインした時間をセッションに保管するパラメータ名。
static String | SP_LOGIN_TYPE ログインタイプをセッションに保管するパラメータ名。
static String | SP_SIGNATURE ログイン署名をセッションに保管するパラメータ名。
static String | SP_URL 認証後表示するメインページをセッションに保管するパラメータ名。
static String | SP_URL_SIGN ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
static String | SP_USER ログインユーザＩＤをセッションに保管するパラメータ名。

フィールドの詳細

SP_LOGIN_TYPE

public static final String SP_LOGIN_TYPE
ログインタイプをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_CLIENT_TYPE

public static final String SP_CLIENT_TYPE
クライアントタイプをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_COLOR_PATTERN_ID

public static final String SP_COLOR_PATTERN_ID
カラーパターンIDをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOCALE

public static final String SP_LOCALE
ログインロケールをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_ENCODING

public static final String SP_ENCODING
ログインエンコーディングをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOGIN_GROUP

public static final String SP_LOGIN_GROUP
ログイングループIDをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_USER

public static final String SP_USER
ログインユーザＩＤをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_SIGNATURE

public static final String SP_SIGNATURE
ログイン署名をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_LOGIN_TIME

public static final String SP_LOGIN_TIME
ログインした時間をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_URL

public static final String SP_URL
認証後表示するメインページをセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_URL_SIGN

public static final String SP_URL_SIGN
ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。

関連項目:
定数フィールド値

SP_INITIAL_URL

public static final String SP_INITIAL_URL
初期ページURLを属性に保管するパラメータ名。

関連項目:
定数フィールド値

CP_COOKIE

public static final String CP_COOKIE
セッション情報をクッキーに保管するパラメータ名。

関連項目:
定数フィールド値

RP_LOGIN_TYPE

public static final String RP_LOGIN_TYPE
ログインタイプのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_CLIENT_TYPE

public static final String RP_CLIENT_TYPE
クライアントタイプのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_LOCALE

public static final String RP_LOCALE
ログインロケールのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_ENCODING

public static final String RP_ENCODING
ログインエンコーディングのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_LOGIN_GROUP

public static final String RP_LOGIN_GROUP
ログイングループIDのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_USER

public static final String RP_USER
ログインユーザＩＤのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_PASSWORD

public static final String RP_PASSWORD
パスワードのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_URL

public static final String RP_URL
ダイレクトＵＲＬのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_URL_SIGN

public static final String RP_URL_SIGN
ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

RP_INITIAL_URL

public static final String RP_INITIAL_URL
初期ＵＲＬのデフォルトＵＲＬ引数名。

関連項目:
定数フィールド値

LT_SUPER

public static final String LT_SUPER
スーパーユーザ（ログインタイプ）。

関連項目:
定数フィールド値

LT_GROUP

public static final String LT_GROUP
グループマネージャー（ログインタイプ）。

関連項目:
定数フィールド値

LT_USER

public static final String LT_USER
ユーザ（ログインタイプ）。

関連項目:
定数フィールド値

CR_OK

public static final int CR_OK
認証成功の返却値。

関連項目:
定数フィールド値

CR_NG

public static final int CR_NG
ログインエラーの返却値。

関連項目:
定数フィールド値

CR_NO_LICENSE

public static final int CR_NO_LICENSE
ライセンスなし、または有効期間外状態の返却値。

関連項目:
定数フィールド値

CR_NO_GROUP

public static final int CR_NO_GROUP
ログイングループ未登録状態の返却値。

関連項目:
定数フィールド値

CR_LOCKED

public static final int CR_LOCKED
アカウントロック状態の返却値。

関連項目:
定数フィールド値

CR_NO_USER

public static final int CR_NO_USER
ユーザ未登録状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_INITIAL

public static final int CR_SESSION_INITIAL
セッション初期状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_LOGON

public static final int CR_SESSION_LOGON
セッションログオン状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_UNMATCH

public static final int CR_SESSION_UNMATCH
セッション不整合状態の返却値。

関連項目:
定数フィールド値

CR_SESSION_TIMEOUT

public static final int CR_SESSION_TIMEOUT
セッションタイムアウト状態の返却値。

関連項目:
定数フィールド値

CR_NO_PERMISSION

public static final int CR_NO_PERMISSION
無許可ページへのアクセスの返却値。

関連項目:
定数フィールド値

CR_ERROR

public static final int CR_ERROR
認証処理エラーの返却値。

関連項目:
定数フィールド値

ATTR_DO_FILTER

public static final String ATTR_DO_FILTER
セッションフィルター制御パラメータ名。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionConfig (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SessionConfig

public interface SessionConfig

セッションに関する設定情報を取得するインタフェース。

セッションに関する設定情報を取得するためのインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getClientTypeName() クライアントタイプをセッションに保管するためのパラメータ名を取得する。
String | getColorPatternIdName() カラーパターンIDをセッションに保管するためのパラメータ名を取得する。
String | getEncodingName() エンコーディングをセッションに保管するためのパラメータ名を取得する。
String | getInitialUrlName() 初期ページURLをセッションに保管するためパラメータ名を取得する。
String | getLocaleName() ロケールをセッションに保管するためのパラメータ名を取得する。
String | getLoginGroupName() ログイングループをセッションに保管するためのパラメータ名を取得する。
String | getLoginTimeName() ログイン時間をセッションに保管するためのパラメータ名を取得する。
String | getLoginTypeName() ログインタイプをセッションに保管するためのパラメータ名を取得する。
String | getSessionCookieName() クッキーにセッション情報を保管するためパラメータ名を取得する。
String | getSignatureName() ログイン署名をセッションに保管するためのパラメータ名を取得する。
String | getUrlName() ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。
String | getUrlSignatureName() ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。
String | getUserName() ユーザＩＤをセッションに保管するためのパラメータ名を取得する。

メソッドの詳細

getClientTypeName

public String getClientTypeName()
クライアントタイプをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログインタイプをセッションに保管するためのパラメータ名

getColorPatternIdName

public String getColorPatternIdName()
カラーパターンIDをセッションに保管するためのパラメータ名を取得する。

戻り値:
カラーパターンIDをセッションに保管するためのパラメータ名

getEncodingName

public String getEncodingName()
エンコーディングをセッションに保管するためのパラメータ名を取得する。

戻り値:
エンコーディングをセッションに保管するためのパラメータ名

getInitialUrlName

public String getInitialUrlName()
初期ページURLをセッションに保管するためパラメータ名を取得する。

戻り値:
初期ページURLをセッションに保管するためパラメータ名

getLocaleName

public String getLocaleName()
ロケールをセッションに保管するためのパラメータ名を取得する。

戻り値:
ロケールをセッションに保管するためのパラメータ名

getLoginGroupName

public String getLoginGroupName()
ログイングループをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイングループをセッションに保管するためのパラメータ名

getLoginTimeName

public String getLoginTimeName()
ログイン時間をセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイン時間をセッションに保管するためのパラメータ名

getLoginTypeName

public String getLoginTypeName()
ログインタイプをセッションに保管するためのパラメータ名を取得する。

戻り値:
ログインタイプをセッションに保管するためのパラメータ名

getSessionCookieName

public String getSessionCookieName()
クッキーにセッション情報を保管するためパラメータ名を取得する。

戻り値:
クッキーにセッション情報を保管するためパラメータ名

getSignatureName

public String getSignatureName()
ログイン署名をセッションに保管するためのパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUrlName

public String getUrlName()
ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUrlSignatureName

public String getUrlSignatureName()
ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。

戻り値:
ログイン署名をセッションに保管するためのパラメータ名

getUserName

public String getUserName()
ユーザＩＤをセッションに保管するためのパラメータ名を取得する。

戻り値:
ユーザＩＤをセッションに保管するためのパラメータ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SessionInfo

すべてのスーパーインタフェース:
LocaleProvider
public interface SessionInfo
extends LocaleProvider

intra-martセッション情報参照インタフェース。

intra-martセッション情報を参照するためのインタフェース
intra-martセッション情報を参照する場合は、必ずこのインターフェースを利用して行う。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String COOKIE_SEPARATOR
セッション情報をクッキーに保管する際のセパレータ。
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternId() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
String | getInitialUrl() 初期ページURLを取得します。
Locale | getLocale() ロケールを取得する。
String | getLoginGroup() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getSignature() ログイン署名を取得する。
String | getUrl() ダイレクトＵＲＬを取得する。
String | getUrlSignature() ダイレクトＵＲＬ署名を取得する。
String | getUser() ログインユーザIDを取得する。

フィールドの詳細

COOKIE_SEPARATOR

public static final String COOKIE_SEPARATOR
セッション情報をクッキーに保管する際のセパレータ。

同じパッケージ内のみ使用可能。

関連項目:
定数フィールド値
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
セッション情報にクライアントタイプが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
クライアントタイプ

getColorPatternId

public String getColorPatternId()
カラーパターンIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合はデフォルトのカラーパターンIDを返却する。

戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
セッション情報にエンコーディングが存在しない場合、および空文字列の場合は空文字列を返却する。

定義:
インタフェース LocaleProvider 内の getEncoding
戻り値:
エンコーディング

getInitialUrl

public String getInitialUrl()
初期ページURLを取得します。
セッション情報に初期ページURLが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
初期ページURL

getLocale

public Locale getLocale()
ロケールを取得する。
セッション情報にロケールが存在しない場合、および空文字列の場合はnullを返却する。

定義:
インタフェース LocaleProvider 内の getLocale
戻り値:
ロケール

getLoginGroup

public String getLoginGroup()
ログイングループIDを取得する。
セッション情報にログイングループIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
セッション情報にログイン時間が存在しない場合、nullを返却する。

戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
セッション情報にログインタイプが存在しない場合、および空文字列の場合は SecurityConstraint.LT_USER を返却する。

戻り値:
ログインタイプ
関連項目:
SecurityConstraint.LT_SUPER, SecurityConstraint.LT_GROUP, SecurityConstraint.LT_USER

getSignature

public String getSignature()
ログイン署名を取得する。
セッション情報にログイン署名が存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイン署名

getUrl

public String getUrl()
ダイレクトＵＲＬを取得する。
セッション情報にダイレクトURLが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ダイレクトＵＲＬ

getUrlSignature

public String getUrlSignature()
ダイレクトＵＲＬ署名を取得する。
セッション情報にダイレクトURL署名が存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ダイレクトＵＲＬ署名

getUser

public String getUser()
ログインユーザIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
クラス SystemManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.SystemManager
public class SystemManager
extends Object

システムマネージャクラス。 システムで共通に使用する以下の情報を取得します。

  • システムで対応しているロケール情報
  • システムで対応しているクライアント情報
  • システムで対応しているカラーパターン情報

    • また、システム管理者情報の操作を行います。

    導入されたバージョン:
    5.0
    バージョン:
    1.0

    メソッドの概要
void | addSuperUser(SuperUser superUser) システム管理者情報を新規に作成します。
static void | clearInstance() システムマネージャのインスタンスを初期化を行います。
ClientTypeInfo | getClientType(Locale reqLocale, String clientType) 指定ロケールでクライアントタイプ情報を取得します。
ClientTypeInfo[] | getClientTypes(Locale reqLocale) 指定ロケールでクライアントタイプ情報の一覧を取得します。
ColorPatternInfo | getColorPattern(Locale reqLocale, String colorPatternId) 指定ロケールでカラーパターン情報を取得します。
ColorPatternInfo[] | getColorPatterns(Locale reqLocale) 指定ロケールでカラーパターン情報の一覧を取得します。
String | getDefaultClientType() システムのデフォルトクライアントタイプを取得します。
String | getDefaultColorPatternId() デフォルトカラーパターンIDを取得します。
String | getDefaultEncoding(Locale reqLocale) ロケールに対応するデフォルトエンコーディングを取得します。
Locale | getDefaultLocale() デフォルトロケールを取得します。
static SystemManager | getInstance() システムマネージャインスタンスを生成します。
LocaleInfo | getLocale(Locale reqLocale, Locale locale) 指定ロケールでロケール情報を取得します。
LocaleInfo[] | getLocales(Locale reqLocale) 指定ロケールでロケール情報の一覧を取得します。
SuperUser | getSuperUser() システム管理者情報を取得します。
Date | getSystemMaxDate() 最大の未来日を取得します。
MenuItem[] | getSystemMenu() システムメニューを取得します。
Date | getSystemMinDate() 最大の過去日を取得します。
static void | setSorucePovider(SystemSourceProvider provider) ソースプロバイダを設定します。
void | updateSuperUser(SuperUser superUser) システム管理者情報を更新します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    メソッドの詳細

    clearInstance

    public static void clearInstance()
    システムマネージャのインスタンスを初期化を行います。

    システム設定ファイルおよびアクセスセキュリティ設定ファイルを再取得し、インスタンスを初期化します。

    システム設定ファイルは(system.xml)は、サーバマネージャルート/confに存在します。 アクセスセキュリティ設定ファイル(access-security.xml)は、サーバマネージャルート/confに存在します。 通常、このメソッドを使用する必要はありません。

    setSorucePovider

    public static void setSorucePovider(SystemSourceProvider provider)
                             throws AccessSecurityException
    ソースプロバイダを設定します。

    システム設定ファイルを提供するプロバイダを設定します。

    通常、このメソッドを使用する必要はありません。

    パラメータ:
    provider - ソースプロバイダ
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getInstance

    public static SystemManager getInstance()
    システムマネージャインスタンスを生成します。

    戻り値:
    システムマネージャインスタンス

    addSuperUser

    public void addSuperUser(SuperUser superUser)
                  throws AccessSecurityException
    システム管理者情報を新規に作成します。

    パラメータ:
    superUser - システム管理者情報
    例外:
    AccessSecurityException - システム管理者情報が作成できなかった場合、または引数が不正だった場合にスローされます。

    getClientType

    public ClientTypeInfo getClientType(Locale reqLocale,
                                    String clientType)
                             throws AccessSecurityException
    指定ロケールでクライアントタイプ情報を取得します。

    存在しない指定ロケールおよびクライアントタイプが指定された場合はデフォルトのクライアントタイプ情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    clientType - クライアントタイプ
    戻り値:
    クライアントタイプ情報
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getClientTypes

    public ClientTypeInfo[] getClientTypes(Locale reqLocale)
                                throws AccessSecurityException
    指定ロケールでクライアントタイプ情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのクライアントタイプ情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    クライアントタイプ情報の配列
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getColorPattern

    public ColorPatternInfo getColorPattern(Locale reqLocale,
                                        String colorPatternId)
                                 throws AccessSecurityException
    指定ロケールでカラーパターン情報を取得します。

    存在しない指定ロケールおよびカラーパターンIDが指定された場合はデフォルトのカラーパターン情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    colorPatternId - カラーパターンID
    戻り値:
    カラーパターン情報。
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getColorPatterns

    public ColorPatternInfo[] getColorPatterns(Locale reqLocale)
                                    throws AccessSecurityException
    指定ロケールでカラーパターン情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのカラーパターン情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    カラーパターン情報の配列。
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getDefaultClientType

    public String getDefaultClientType()
    システムのデフォルトクライアントタイプを取得します。

    戻り値:
    デフォルトクライアントタイプ

    getDefaultColorPatternId

    public String getDefaultColorPatternId()
    デフォルトカラーパターンIDを取得します。

    戻り値:
    デフォルトカラーパターンID。

    getDefaultEncoding

    public String getDefaultEncoding(Locale reqLocale)
                          throws AccessSecurityException
    ロケールに対応するデフォルトエンコーディングを取得します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    デフォルトエンコーディング
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getDefaultLocale

    public Locale getDefaultLocale()
    デフォルトロケールを取得します。

    戻り値:
    デフォルトロケール

    getLocale

    public LocaleInfo getLocale(Locale reqLocale,
                            Locale locale)
                     throws AccessSecurityException
    指定ロケールでロケール情報を取得します。

    存在しない指定ロケールおよび取得ロケールが指定された場合はデフォルトのロケール情報を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    locale - 取得ロケール
    戻り値:
    ロケール情報
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getLocales

    public LocaleInfo[] getLocales(Locale reqLocale)
                        throws AccessSecurityException
    指定ロケールでロケール情報の一覧を取得します。

    存在しない指定ロケールが指定された場合はデフォルトのロケール情報の配列を返却します。

    パラメータ:
    reqLocale - 指定ロケール
    戻り値:
    ロケール情報の配列
    例外:
    AccessSecurityException - 引数が不正だった場合にスローされます。

    getSuperUser

    public SuperUser getSuperUser()
                       throws AccessSecurityException
    システム管理者情報を取得します。

    システム管理者の情報モデルを取得します。

    戻り値:
    システム管理者の情報モデル
    例外:
    AccessSecurityReadException - システム管理者情報が取得できなかった場合にスローされます。
    AccessSecurityException

    updateSuperUser

    public void updateSuperUser(SuperUser superUser)
                     throws AccessSecurityException
    システム管理者情報を更新します。

    パラメータ:
    superUser - システム管理者の情報モデル
    例外:
    AccessSecurityException - システム管理者情報が更新できなかった場合にスローされます。

    getSystemMenu

    public MenuItem[] getSystemMenu()
    システムメニューを取得します。

    戻り値:
    システムメニューの配列

    getSystemMinDate

    public Date getSystemMinDate()
    最大の過去日を取得します。

    システムで取り扱う最大過去日を返却します。

    戻り値:
    システムで取り扱う最大過去日

    getSystemMaxDate

    public Date getSystemMaxDate()
    最大の未来日を取得します。

    システムで取り扱う最大未来日を返却します。

    戻り値:
    システムで取り扱う最大未来日
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart(R)
    5.0
    前のクラス 次のクラス | フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SystemSourceProvider (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security
インタフェース SystemSourceProvider

public interface SystemSourceProvider

ロケール情報取得インターフェース。

設定ファイルからロケール情報を取得するためのインターフェースを定義します

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
SystemManager

メソッドの概要
InputStream | getPropertyStreamAsClientType(Locale locale) プロパティファイル(クライアントタイプ)の内容取得。
InputStream | getPropertyStreamAsColor(Locale locale) プロパティファイル(カラーパターン)の内容取得。
InputStream | getPropertyStreamAsColorProperty(String colorId, Locale locale) プロパティファイル(カラーパターン)の内容取得。
InputStream | getPropertyStreamAsLocale(Locale locale) プロパティファイル(ロケール)の内容取得。
InputStream | getStream() システム設定ファイルの内容取得。

メソッドの詳細

getPropertyStreamAsClientType

public InputStream getPropertyStreamAsClientType(Locale locale)
プロパティファイル(クライアントタイプ)の内容取得。
与えられた引数(ロケール)からプロパティファイルのストリームを返却する。
引数がnullの場合はデフォルトのプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getPropertyStreamAsColorProperty

public InputStream getPropertyStreamAsColorProperty(String colorId,
                                                    Locale locale)
プロパティファイル(カラーパターン)の内容取得。
与えられた引数(カラーパターンID、ロケール)からプロパティファイルのストリームを返却する 。
引数のロケールがnullの場合はデフォルトのカラーパターンIDのプロパティファイルのストリームを返却する。

パラメータ:
colorId - カラーパターンID
locale - ロケール

getPropertyStreamAsColor

public InputStream getPropertyStreamAsColor(Locale locale)
プロパティファイル(カラーパターン)の内容取得。
与えられた引数(ロケール)からカラーパターンプロパティファイルのストリームを返却する 。
引数のロケールがnullの場合はデフォルトのカラーパターンプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getPropertyStreamAsLocale

public InputStream getPropertyStreamAsLocale(Locale locale)
プロパティファイル(ロケール)の内容取得。
与えられた引数(ロケール)からプロパティファイルのストリームを返却する 。
引数がnullの場合はデフォルトのプロパティファイルのストリームを返却する。

パラメータ:
locale - ロケール

getStream

public InputStream getStream()
システム設定ファイルの内容取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の使用

AccountSecurityHTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での AccountSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での AccountSecurityHTTPActionEventFilterHandler のサブクラス
 class PasswordSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の使用

GroupSecurityHTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での GroupSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での GroupSecurityHTTPActionEventFilterHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent の使用

HTTPActionEventContent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventContent の使用

HTTPActionEventContent を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventContent HTTPActionEventURL.getContent()
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler の使用

HTTPActionEventEntityHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventEntityHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventEntityHandler のサブクラス
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventEntityHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventEntityHandler のサブクラス
class | PresentationFrameworkHTTPActionEventHandler im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
class | PresentationPageHTTPActionEventHandler ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler の使用

HTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventFilterHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventFilterHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用

HTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | HTTPActionEventEntityHandler HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
class | HTTPActionEventFilterHandler HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

HTTPActionEventHandler を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventHandler HTTPActionEventFilterHandler.getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
class | PresentationFrameworkHTTPActionEventHandler im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
class | PresentationPageHTTPActionEventHandler ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application.content のコンストラクタ
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException の使用

HTTPActionEventHandlerException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerException の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerException のサブクラス
 class HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

HTTPActionEventHandlerException をスローする jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventResult | HTTPActionEventHandler.execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException をスローする jp.co.intra_mart.foundation.service.client.application のメソッド
protected abstract Properties | WebApplicationHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | ServletHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected abstract Properties | HTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | HTTPActionEventFilterHandler.getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
protected Properties | HTTPActionEventFilterHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | HTTPActionEventEntityHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | ActivityHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException をスローする jp.co.intra_mart.foundation.service.client.application.content のメソッド
protected Properties | ServiceFrameworkHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | PresentationPageHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | PresentationFrameworkHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult の使用

HTTPActionEventResult を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventResult の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventResult のサブインタフェース
interface | HTTPActionEventContent Web コンテンツを取得するための共通インターフェースです。
interface | HTTPActionEventURL Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

HTTPActionEventResult を実装している jp.co.intra_mart.foundation.service.client.application のクラス
 class HTTPActionEventResultWrapper
HTTPActionEventResult のラッパーオブジェクトです。

HTTPActionEventResult を返す jp.co.intra_mart.foundation.service.client.application のメソッド
protected HTTPActionEventResult | HTTPActionEventResultWrapper.getParent() ラップしている親オブジェクトを返します。
HTTPActionEventResult | HTTPActionEventHandler.execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

HTTPActionEventResult 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper の使用

jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL の使用

HTTPActionEventURL を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventURL の使用

HTTPActionEventURL を返す jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler の使用

ServletHTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での ServletHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での ServletHTTPActionEventHandler のサブクラス
 class ActivityHTTPActionEventHandler
持続したセッションを確立するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の使用

WebApplicationHTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での WebApplicationHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での WebApplicationHTTPActionEventHandler のサブクラス
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。

jp.co.intra_mart.foundation.service.client.application.content での WebApplicationHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での WebApplicationHTTPActionEventHandler のサブクラス
class | PresentationFrameworkHTTPActionEventHandler im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
class | PresentationPageHTTPActionEventHandler ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AccessibleLinkHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス AccessibleLinkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
public class AccessibleLinkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

再接続の為のＵＲＬを制御するフィルタ実装です。

このフィルタを利用する事で、同じセッション内でのその他のリクエストにおいて、 AbsoluteLinkFilter を経由した場合、全ての再接続リクエストのためのＵＲＬが 絶対形式の表現となります。
つまり、返される画面ソース(HTML)内の、 <FORM> の action 属性や、<A> の href 属性に指定する URL が、プロトコルおよびサーバアドレス等を含む絶対形式となります (javax.servlet.HttpServletResponse#encodeURL(java.lang.String) を利用して URL をエンコードしなかった場合は除く)。

これにより、例えばポータルサーバが別サイトとして運用されている場合においても、 各ポートレット内に配置されたリンクやフォームからシステムに直接アクセス できるようになります。

このフィルタは、サーバでの処理実行時に HttpSession が開始されていなかった場合、 HttpSession を新しく開始するように働きます。 それでもセッションを取得できなかった場合、将来の予期せぬエラーを防ぐため、 例外をスローしてサーバ処理をエラー終了します。 結果として、ハンドラの #execute() メソッドは、エラーを示す結果オブジェクトを 返す事になります。

導入されたバージョン:
version 4.3

コンストラクタの概要
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessibleLinkHTTPActionEventFilterHandler

public AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityFrameworkHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ActivityFrameworkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

public class ActivityFrameworkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

サービスフレームワークおよびプレゼンテーションフレームワークの実行環境を作成するためのフィルタ実装です。

このフィルタを利用する場合、事前にログイン環境を作成しておく必要があります。 したがって、AccountSecurityHTTPActionEventFilterHandler も 併用するようにしてください。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
推奨されていません。 フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityFrameworkHTTPActionEventFilterHandler

public ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。
フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
推奨されていません。
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application.content (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.client.application.content
クラス
AccessibleLinkHTTPActionEventFilterHandler
ActivityFrameworkHTTPActionEventFilterHandler
PresentationFrameworkHTTPActionEventHandler
PresentationPageHTTPActionEventHandler
ServiceFrameworkHTTPActionEventHandler


jp.co.intra_mart.foundation.service.client.application.content (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

参照:
説明

クラスの概要
AccessibleLinkHTTPActionEventFilterHandler | 再接続の為のＵＲＬを制御するフィルタ実装です。
ActivityFrameworkHTTPActionEventFilterHandler | 推奨されていません。 このフィルタは、何もしません。
PresentationFrameworkHTTPActionEventHandler | im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
PresentationPageHTTPActionEventHandler | ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler | im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

パッケージ jp.co.intra_mart.foundation.service.client.application.content の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

導入されたバージョン:
version 4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.client.application.content クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.client.application.content の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application.content の使用

jp.co.intra_mart.foundation.service.client.application.content はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PresentationFrameworkHTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス PresentationFrameworkHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler
public class PresentationFrameworkHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。

このハンドラを利用する事により、指定のフローコンポーネントを実行して、 指定のスタートポイントに指定されているコンテンツコンポーネントの 画面ソースを取得する事ができます。
主にポータルサーバなどと連携してサービスフレームワークによる画面を １つのポートレットとして表示する場合に利用できます。 なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

このクラスは、プレゼンテーションフレームワークに必要な各引数値に関する 共通インターフェースを提供しているだけの抽象実装です。 したがって、このクラスを単独で使用しても正しい結果を得る事はできません。 サブクラスを作成して、適切な実装を追加しなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | PresentationFrameworkHTTPActionEventHandler() プレゼンテーションフレームワークを実行するためのハンドラを作成します。
 | PresentationFrameworkHTTPActionEventHandler(String application, String flowComponent, String startPoint) プレゼンテーションフレームワークを実行するためのハンドラを作成します。
メソッドの概要
String | getApplication() 設定されているアプリケーション名を返します。
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getFlowComponent() 設定されているフローコンポーネント名を返します。
String | getName() イベント名を返します。
String | getStartPoint() 設定されているスタートポイント名を返します。
protected void | setApplication(String name) 実行するフレームワークのアプリケーション名を設定します。
protected void | setFlowComponent(String name) 実行するフレームワークのフローコンポーネント名を設定します。
protected void | setStartPoint(String name) 実行するフローのスタートポイント名を設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationFrameworkHTTPActionEventHandler

protected PresentationFrameworkHTTPActionEventHandler()
プレゼンテーションフレームワークを実行するためのハンドラを作成します。
このコンストラクタでは、必要な情報を設定しないため、 インスタンス作成後に各設定を行う必要があります。

PresentationFrameworkHTTPActionEventHandler

public PresentationFrameworkHTTPActionEventHandler(String application,
                                                   String flowComponent,
                                                   String startPoint)
プレゼンテーションフレームワークを実行するためのハンドラを作成します。

パラメータ:
application - アプリケーション名
flowComponent - フローコンポーネント名
startPoint - スタートポイント名
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setApplication

protected void setApplication(String name)
実行するフレームワークのアプリケーション名を設定します。

パラメータ:
name - アプリケーション名
例外:
NullPointerException - 引数が null の場合

getApplication

public String getApplication()
設定されているアプリケーション名を返します。

戻り値:
アプリケーション名

setFlowComponent

protected void setFlowComponent(String name)
実行するフレームワークのフローコンポーネント名を設定します。

例外:
NullPointerException - 引数が null の場合

getFlowComponent

public String getFlowComponent()
設定されているフローコンポーネント名を返します。

戻り値:
フローコンポーネント名

setStartPoint

protected void setStartPoint(String name)
実行するフローのスタートポイント名を設定します。

例外:
NullPointerException - 引数が null の場合

getStartPoint

public String getStartPoint()
設定されているスタートポイント名を返します。

戻り値:
スタートポイント名

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PresentationPageHTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス PresentationPageHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
public class PresentationPageHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。

このハンドラを利用する事により、指定のプレゼンテーションページを実行して、 画面ソースを取得する事ができます。
主にポータルサーバなどと連携してページベース開発モデルによる画面を １つのポートレットとして表示する場合に利用できます。 なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | PresentationPageHTTPActionEventHandler() ハンドラを作成します。
 | PresentationPageHTTPActionEventHandler(String path) ハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
String | getPagePath() 設定されているページパスを返します。
protected void | setPagePath(String url) 実行するページベース開発モデルのページパスを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationPageHTTPActionEventHandler

protected PresentationPageHTTPActionEventHandler()
ハンドラを作成します。
このコンストラクタでは、必要な情報が設定されません。

実行するプレゼンテーションページのパスは、 setPagePath(String) で設定してください。

PresentationPageHTTPActionEventHandler

public PresentationPageHTTPActionEventHandler(String path)
ハンドラを作成します。
引数 path には、実行するプレゼンテーションページのパスを設定してください。

パラメータ:
path - ページベース開発モデルのプログラムパス
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setPagePath

protected void setPagePath(String url)
実行するページベース開発モデルのページパスを設定します。

ページパスは、Resource Service のページベース開発モデルの プログラムルート（標準では pages/）からの相対パス指定になります。

パラメータ:
url - 接続ＵＲＬ

getPagePath

public String getPagePath()
設定されているページパスを返します。

戻り値:
ページパス

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceFrameworkHTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ServiceFrameworkHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
public class ServiceFrameworkHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

このハンドラを利用する事により、指定のサービスフレームワークを実行して、 画面のソースを取得する事ができます。
主にポータルサーバなどと連携してサービスフレームワークによる画面を １つのポートレットとして表示する場合に利用できます。

なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

このクラスは、プレゼンテーションフレームワークに必要な各引数値に関する 共通インターフェースを提供しているだけの抽象実装です。 したがって、このクラスを単独で使用しても正しい結果を得る事はできません。 サブクラスを作成して、適切な実装を追加しなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | ServiceFrameworkHTTPActionEventHandler() サービスフレームワークを実行するためのハンドラを作成します。
 | ServiceFrameworkHTTPActionEventHandler(String application, String service) サービスフレームワークを実行するためのハンドラを作成します。
メソッドの概要
String | getApplication() 設定されているアプリケーションＩＤを返します。
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
String | getService() 設定されているサービスＩＤを返します。
protected void | setApplication(String id) 実行するフレームワークのアプリケーションＩＤを設定します。
protected void | setService(String id) 実行するフレームワークのサービスＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceFrameworkHTTPActionEventHandler

protected ServiceFrameworkHTTPActionEventHandler()
サービスフレームワークを実行するためのハンドラを作成します。

このコンストラクタでは、特に設定を行いません。 イベント実行要求前に、必要な情報の設定を行ってください。

ServiceFrameworkHTTPActionEventHandler

public ServiceFrameworkHTTPActionEventHandler(String application,
                                              String service)
サービスフレームワークを実行するためのハンドラを作成します。

このコンストラクタでは、特に設定を行いません。 イベント実行要求前に、必要な情報の設定を行ってください。

パラメータ:
application - アプリケーションＩＤ
service - サービスＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setApplication

protected void setApplication(String id)
実行するフレームワークのアプリケーションＩＤを設定します。

パラメータ:
id - アプリケーションＩＤ
例外:
NullPointerException - 引数が null の場合

getApplication

public String getApplication()
設定されているアプリケーションＩＤを返します。

戻り値:
アプリケーションＩＤ

setService

protected void setService(String id)
実行するフレームワークのサービスＩＤを設定します。

パラメータ:
id - サービスＩＤ
例外:
NullPointerException - 引数が null の場合

getService

public String getService()
設定されているサービスＩＤを返します。

戻り値:
サービスＩＤ

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountSecurityHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス AccountSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
PasswordSecurityHTTPActionEventFilterHandler
public class AccountSecurityHTTPActionEventFilterHandler
extends GroupSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getAccount() 設定されているアカウントＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setAccount(String accountId) アカウントＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_ACCOUNT

protected static final String ID_SECURITY_ACCOUNT
関連項目:
定数フィールド値
コンストラクタの詳細

AccountSecurityHTTPActionEventFilterHandler

public AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                   String groupId,
                                                   String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス GroupSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setAccount

protected void setAccount(String accountId)
アカウントＩＤを設定します。

パラメータ:
accountId - アカウントＩＤ

getAccount

public String getAccount()
設定されているアカウントＩＤを返します。

戻り値:
アカウントＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityHTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ActivityHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
public class ActivityHTTPActionEventHandler
extends ServletHTTPActionEventHandler

持続したセッションを確立するためのハンドラです。

このハンドラを利用すると、結果として同一のセッションを維持したまま 他のハンドラでサーバに再接続するためのＵＲＬを取得する事ができます。
セッションとは、HTTP セッションであり、 セッションを維持する事によりイベントは javax.servlet.http.HttpSession を 通してセッションデータを共有する事ができます。

複数のハンドラを利用して、同一のセッションでいくつかのイベントを 実行する必要がある場合、まずこのハンドラを利用して セッションを維持しながらイベント実行を要求できるＵＲＬを 取得してください。

このハンドラは、セッションを維持する事を目的としているため、 LimitedSessionHTTPActionEventFilterHandler と併用しても 意味がありません。
また、取得されたＵＲＬを利用する事により維持されたセッションに アクセスする事になるため、毎回ログインセッション環境を作る事も 意味を持ちません。ログインセッション環境を利用する場合は、 このハンドラを実行するときに AccountSecurityHTTPActionEventFilterHandler と併用して環境を作成してしまう方法が最も効率的です。 一度ログインセッション環境を作成してしまえば、以後の呼び出しでは ログイン環境を作成するためのフィルタを利用する必要はありません。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityHTTPActionEventHandler()
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String url)
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler から継承したメソッド
getLocation, setLocation
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityHTTPActionEventHandler

public ActivityHTTPActionEventHandler()
新しいイベントハンドラを作成します。

このコンストラクタを利用して作成されたハンドラでは、 再接続ＵＲＬはサーバ内で自動解決されます。 明示的にＵＲＬを指定したい場合は、 ServletHTTPActionEventHandler.setLocation(java.lang.String) メソッドを利用して 再接続 URL を設定してください。

ActivityHTTPActionEventHandler

public ActivityHTTPActionEventHandler(String url)
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。

引数 url には、HTTPActionEvent のリスナーとなっている サーブレットへアクセスするためのＵＲＬを指定してください。

パラメータ:
url - URL
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.client.application.HTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス ServletHTTPActionEventHandler 内の getName
戻り値:
イベント名

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

オーバーライド:
クラス ServletHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConcreteHTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ConcreteHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
public class ConcreteHTTPActionEventHandler
extends HTTPActionEventEntityHandler

任意の HTTPActionEvent を実行するためのハンドラです。

このハンドラを利用する事により、作成したイベントに 対応するハンドラを特別に作成することなく、 任意のイベントを実行する事ができます。
このハンドラは、HTTPActionEvent の汎用ハンドラのため、 HTTPActionEvent 呼び出し時のパラメータを隠蔽化したい場合などは、 独自のハンドラを定義する必要がありますが、通常はこのハンドラで ほとんどの要件を満たせると思われます。

導入されたバージョン:
version 4.3

コンストラクタの概要
ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
メソッドの概要
 String getName()
イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getEventRequestParameterMap, getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConcreteHTTPActionEventHandler

public ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。

パラメータ:
name - イベント名
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSecurityHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス GroupSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
AccountSecurityHTTPActionEventFilterHandler
public class GroupSecurityHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループによる ログインセッション環境を作る事ができます。 このフィルタを利用する事により、 イベントプログラム中でログイングループを自動解決するＡＰＩを 利用可能になります。

実在しないグループを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_GROUP
コンストラクタの概要
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getGroup() 設定されているグループＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setGroup(String groupId) グループＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_GROUP

protected static final String ID_SECURITY_GROUP
関連項目:
定数フィールド値
コンストラクタの詳細

GroupSecurityHTTPActionEventFilterHandler

public GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                 String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setGroup

protected void setGroup(String groupId)
グループＩＤを設定します。

パラメータ:
groupId - グループＩＤ

getGroup

public String getGroup()
設定されているグループＩＤを返します。

戻り値:
グループＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventContent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventContent

すべてのスーパーインタフェース:
HTTPActionEventResult
public interface HTTPActionEventContent
extends HTTPActionEventResult

Web コンテンツを取得するための共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
byte[] | getBytes() サーバからレスポンスされたコンテンツのソースをバイト列として返します。
URL | getRequestURL() このコンテンツを取得するために使用した URL を返します。
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

メソッドの詳細

getRequestURL

public URL getRequestURL()
このコンテンツを取得するために使用した URL を返します。

戻り値:
URL

getBytes

public byte[] getBytes()
                throws IOException
サーバからレスポンスされたコンテンツのソースをバイト列として返します。

何らかのエラーによりソースを受信できなかった場合、 このメソッドは null を返します。

戻り値:
コンテンツソースのバイト列。または null。
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventEntityHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventEntityHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
直系の既知のサブクラス:
ConcreteHTTPActionEventHandler, WebApplicationHTTPActionEventHandler
public abstract class HTTPActionEventEntityHandler
extends HTTPActionEventHandler

HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
void | removeParameter(String key) 指定のキーのマップを削除します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventEntityHandler

protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
直系の既知のサブクラス:
AccessibleLinkHTTPActionEventFilterHandler, ActivityFrameworkHTTPActionEventFilterHandler, GroupSecurityHTTPActionEventFilterHandler, LimitedSessionHTTPActionEventFilterHandler
public abstract class HTTPActionEventFilterHandler
extends HTTPActionEventHandler

HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。

HTTPActionEventHandler をフィルタリングする HTTPActionEventHandler は、 このクラスをスーパークラスとして実装する事を推奨します。

ユーザプログラムでは、フィルタリングしたいハンドラを基礎ハンドラとして フィルタハンドラを作成し、フィルタハンドラの HTTPActionEventHandler.execute(java.net.HttpURLConnection) を呼び出すことで、 Application Runtime でフィルタされた効果を得ながら 基礎ハンドラが指定するイベントを実行する事ができます。
なお、このハンドラを利用して呼び出すフィルターイベントは、 FilterHTTPActionEvent を実装しているクラスでなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected String | getFilterParameter(String key) このフィルタのパラメータを返します。
protected Properties | getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
abstract String | getName() フィルタイベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
HTTPActionEventHandler | getParent() このオブジェクトがフィルタリングしているハンドラを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
protected String | removeFilterParameter(String key) このフィルタのパラメータを削除します。
void | removeParameter(String key) 指定のキーのマップを削除します。
protected void | setFilterParameter(String key, String value) このフィルタのパラメータを設定します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventFilterHandler

protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getParent

public HTTPActionEventHandler getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

戻り値:
ハンドラ

getName

public abstract String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String, String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

このメソッドは、単純のラップしている親ハンドラの #hasParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterKeySet() を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

このメソッドは、単純のラップしている親ハンドラの #removeParameter(String) を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterMap() を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

setFilterParameter

protected void setFilterParameter(String key,
                                  String value)
このフィルタのパラメータを設定します。

パラメータ:
key - パラメータ名
value - パラメータの値

getFilterParameter

protected String getFilterParameter(String key)
このフィルタのパラメータを返します。

パラメータ:
key - パラメータ名
戻り値:
パラメータの値

removeFilterParameter

protected String removeFilterParameter(String key)
このフィルタのパラメータを削除します。

パラメータ:
key - パラメータ名
戻り値:
設定されていたパラメータの値

getFilterParameterMap

protected Properties getFilterParameterMap()
                                    throws HTTPActionEventHandlerParameterException
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected final Properties getEventRequestParameterMap()
                                                throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
直系の既知のサブクラス:
HTTPActionEventEntityHandler, HTTPActionEventFilterHandler
public abstract class HTTPActionEventHandler
extends Object

HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

ハンドラを作成してイベント実行を要求する場合、execute(String) または execute(java.net.URL) を利用します。 execute(java.net.HttpURLConnection) も利用できますが、 通常はこの方法を使わない方が良いと思われます。

イベント実行を要求するＵＲＬは、 HTTPActionEventListener へ接続できるものを指定します。 標準では、下記のようになります。
http://<サーバアドレス>[:<ポート番号>]/imart/HTTPActionEventListener

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。
メソッドの概要
HTTPActionEventResult | execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
HTTPActionEventResult | execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
String | getCharacterEncoding() パラメータを符号化するためのエンコーディング名を返します。
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
abstract String | getParameter(String key) 設定したパラメータ値を取得します。
abstract Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
abstract Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
abstract boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
abstract void | removeParameter(String key) 指定のキーのマップを削除します。
void | setCharacterEncoding(String enc) パラメータを符号化するためのエンコーディング名を指定します。
abstract void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandler

protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

戻り値:
イベント名

setParameter

public abstract void setParameter(String key,
                                  String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

パラメータ:
key - キー
value - 値

getParameter

public abstract String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public abstract boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public abstract Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

戻り値:
キーのセット

removeParameter

public abstract void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

パラメータ:
key - キー

getParameterMap

public abstract Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getCharacterEncoding

public String getCharacterEncoding()
パラメータを符号化するためのエンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

public void setCharacterEncoding(String enc)
                          throws UnsupportedEncodingException
パラメータを符号化するためのエンコーディング名を指定します。

デフォルトでは UTF-8 を用いてパラメータを符号化します。 また、イベントへの各パラメータ値は Unicode のまま扱われますので、 通常は文字エンコーディングを変更する必要はありません。

パラメータ:
enc - 文字エンコーディング名
例外:
UnsupportedEncodingException - 指定のエンコーディング名がサポートされない場合

execute

public HTTPActionEventResult execute(String url)
                              throws MalformedURLException,
                                     IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の URL 文字列から java.net.URL のインスタンスを 作成して execute(java.net.URL) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
MalformedURLException
IOException

execute

public HTTPActionEventResult execute(URL url)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の java.net.URL から java.net.HttpURLConnection を取得して execute(java.net.HttpURLConnection) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
IOException

execute

public HTTPActionEventResult execute(HttpURLConnection connection)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

このメソッドは、 getParameterMap() の返り値をイベントの引数として サーバに対して getName() が表すイベントの 実行を要求します。

パラメータ:
connection - コネクション
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandlerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandlerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
HTTPActionEventHandlerParameterException
public class HTTPActionEventHandlerException
extends Exception

HTTPActionEventHandler 内で発生したエラーを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventHandlerException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandlerException

public HTTPActionEventHandlerException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventHandlerException

public HTTPActionEventHandlerException(String msg,
                                       Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandlerParameterException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandlerParameterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
                拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException
すべての実装インタフェース:
Serializable
public class HTTPActionEventHandlerParameterException
extends HTTPActionEventHandlerException

HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventHandlerParameterException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandlerParameterException

public HTTPActionEventHandlerParameterException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventHandlerParameterException

public HTTPActionEventHandlerParameterException(String msg,
                                                Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResult (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventResult

既知のサブインタフェースの一覧:
HTTPActionEventContent, HTTPActionEventURL
既知の実装クラスの一覧:
HTTPActionEventResultWrapper
public interface HTTPActionEventResult

HTTPActionEvent 実行要求の結果に関する共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。

メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 HttpURLConnection の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

このメソッドでは、HTTP のレスポンスコードが 200 かどうかで、 判定しています。

戻り値:
エラーなく処理終了しなかった場合 true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResultWrapper (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventResultWrapper

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper
すべての実装インタフェース:
HTTPActionEventResult
public class HTTPActionEventResultWrapper
extends Object
implements HTTPActionEventResult

HTTPActionEventResult のラッパーオブジェクトです。
このクラスでは、基本的にラップしているオブジェクトからの 返り値をそのままリターンします。 必要に応じてサブクラスを作成し、サブクラス側で必要な処理を メソッドをオーバーライドすることにより実装してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
protected HTTPActionEventResult | getParent() ラップしている親オブジェクトを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventResultWrapper

public HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。

パラメータ:
parent - ラップする結果オブジェクト
メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

定義:
インタフェース HTTPActionEventResult 内の getConnection
戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 javax.servlet.http.HttpURLConnection#getResponseCode() の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

定義:
インタフェース HTTPActionEventResult 内の getResponseCode
戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

定義:
インタフェース HTTPActionEventResult 内の getResponseMessage
戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

定義:
インタフェース HTTPActionEventResult 内の getInputStream
戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

定義:
インタフェース HTTPActionEventResult 内の isError
戻り値:
エラーなく処理終了した場合 false。

getParent

protected HTTPActionEventResult getParent()
ラップしている親オブジェクトを返します。

戻り値:
ラップしている結果オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventURL (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventURL

すべてのスーパーインタフェース:
HTTPActionEventResult
public interface HTTPActionEventURL
extends HTTPActionEventResult

Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
 HTTPActionEventContent getContent()
getURL() によって表されるコンテンツのソースを取得します。
 String getURL()
サーバから返されたＵＲＬを返します。
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

メソッドの詳細

getURL

public String getURL()
              throws IOException
サーバから返されたＵＲＬを返します。

戻り値:
ＵＲＬ
例外:
IOException - 入出力エラー

getContent

public HTTPActionEventContent getContent()
                                  throws MalformedURLException,
                                         IOException
getURL() によって表されるコンテンツのソースを取得します。

戻り値:
サーバからの応答オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LimitedSessionHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス LimitedSessionHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
public class LimitedSessionHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

セッションを一時利用のみに限定するためのフィルタです。

イベント HTTPActionEvent では、セッション情報を扱う場合 javax.servlet.http.HttpSession を利用します。 したがって、明示的にセッション(javax.servlet.http.HttpSession)を破棄しない場合、 セッションのタイムアウトが発生するまで、サーバのメモリリソースを 消費したままの状態が維持されてしまいます。
このフィルタは、イベント処理終了時に javax.servlet.http.HttpSession#invalidate() を 実行してセッションを明示的に破棄します。 セッションを維持する必要のないイベント実行では、 このフィルタを利用することにより、サーバリソースの無駄な利用を 回避する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LimitedSessionHTTPActionEventFilterHandler

public LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.client.application
インタフェース
HTTPActionEventContent
HTTPActionEventResult
HTTPActionEventURL
クラス
AccountSecurityHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
ConcreteHTTPActionEventHandler
GroupSecurityHTTPActionEventFilterHandler
HTTPActionEventEntityHandler
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventResultWrapper
LimitedSessionHTTPActionEventFilterHandler
PasswordSecurityHTTPActionEventFilterHandler
ServletHTTPActionEventHandler
WebApplicationHTTPActionEventHandler
例外
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException


jp.co.intra_mart.foundation.service.client.application (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

参照:
説明

インタフェースの概要
HTTPActionEventContent | Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventResult | HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL | Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

クラスの概要
AccountSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ActivityHTTPActionEventHandler | 持続したセッションを確立するためのハンドラです。
ConcreteHTTPActionEventHandler | 任意の HTTPActionEvent を実行するためのハンドラです。
GroupSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventEntityHandler | HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler | HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler | HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventResultWrapper | HTTPActionEventResult のラッパーオブジェクトです。
LimitedSessionHTTPActionEventFilterHandler | セッションを一時利用のみに限定するためのフィルタです。
PasswordSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ServletHTTPActionEventHandler | Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler | フレームワークを実行するためのイベントハンドラの抽象実装です。

例外の概要
HTTPActionEventHandlerException | HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException | HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.client.application の説明

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
このパッケージを利用することにより、intra-mart ではない環境から intra-mart 内のプログラム実行を行うことができるようになりますので、例えばユーザ情報の同期など、様々なことを実現することができます。

導入されたバージョン:
version 4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.client.application クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.client.application の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application の使用

jp.co.intra_mart.foundation.service.client.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application により使用される jp.co.intra_mart.foundation.service.client.application のクラス
AccountSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventContent
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventEntityHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerException
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventResult
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
ServletHTTPActionEventHandler
Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content により使用される jp.co.intra_mart.foundation.service.client.application のクラス
HTTPActionEventEntityHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PasswordSecurityHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス PasswordSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
public class PasswordSecurityHTTPActionEventFilterHandler
extends AccountSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタは、AccountSecurityHTTPActionEventFilterHandler の機能に加えて パスワード認証も行います。したがって、AccountSecurityHTTPActionEventFilterHandler よりも 高度なセキュリティを実現しながらイベントを実行する事が可能となります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定したりパスワードが正しくない場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_PASSWORD
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getName() フィルタイベント名を返します。
String | getPassword() 設定されているパスワードを返します。
protected void | setPassword(String password) パスワードを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したメソッド
getAccount, setAccount
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_PASSWORD

protected static final String ID_SECURITY_PASSWORD
関連項目:
定数フィールド値
コンストラクタの詳細

PasswordSecurityHTTPActionEventFilterHandler

public PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                    String groupId,
                                                    String accountId,
                                                    String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
password - パスワード
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス AccountSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setPassword

protected void setPassword(String password)
パスワードを設定します。

パラメータ:
password - パスワード

getPassword

public String getPassword()
設定されているパスワードを返します。

戻り値:
パスワード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServletHTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ServletHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
直系の既知のサブクラス:
ActivityHTTPActionEventHandler
public class ServletHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

Web-Application を実行するためのイベントハンドラです。

このハンドラは、指定の Web-Application を実行するための URL を作成して 返します。 ユーザプログラムでは、このハンドラを利用して取得した URL を用いて、 サーバにリクエストすることにより目的のコンテンツのソースを 取得する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | ServletHTTPActionEventHandler() Web-Application をイベント実行するためのハンドラを作成します。
 | ServletHTTPActionEventHandler(String location) 指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getLocation() 設定されている遷移先パスを返します。
String | getName() イベント名を返します。
protected void | setLocation(String location) 遷移先のページパスを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServletHTTPActionEventHandler

protected ServletHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
このコンストラクタでは表示する画面のパスが設定されません。 サブクラスで setLocation(String) を利用して 画面パスを設定しなければいけません。

ServletHTTPActionEventHandler

public ServletHTTPActionEventHandler(String location)
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。

パラメータ:
location - Web-Application のパス
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setLocation

protected void setLocation(String location)
遷移先のページパスを設定します。

パラメータ:
location - ページパス
例外:
NullPointerException - 引数が null の場合

getLocation

public String getLocation()
設定されている遷移先パスを返します。

戻り値:
遷移先を表すパス

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

このメソッドが返す値は、イベントに対するパラメータであって、 getLocation() によって表される画面プログラムに対する リクエストパラメータではない点に注意してください。 getLocation() によって表される画面プログラムに対する リクエストパラメータに関しては、HTTPActionEventEntityHandler.getParameterMap() によって 取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WebApplicationHTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス WebApplicationHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
直系の既知のサブクラス:
PresentationFrameworkHTTPActionEventHandler, PresentationPageHTTPActionEventHandler, ServiceFrameworkHTTPActionEventHandler, ServletHTTPActionEventHandler
public abstract class WebApplicationHTTPActionEventHandler
extends HTTPActionEventEntityHandler

フレームワークを実行するためのイベントハンドラの抽象実装です。

このハンドラは、指定のフレームワークを実行するための URL を作成して 返します。 ユーザプログラムでは、このハンドラを利用して取得した URL を用いて、 サーバにリクエストすることにより目的のコンテンツのソースを 取得する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected WebApplicationHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
メソッドの概要
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
protected String | getQueryString() 設定されているパラメータ情報からクエリ文字列を作成して返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

WebApplicationHTTPActionEventHandler

protected WebApplicationHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
このコンストラクタでは表示する画面のパスが設定されません。 サブクラスで #setLocation(String) を利用して 画面パスを設定しなければいけません。

メソッドの詳細

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        String url)
                                 throws MalformedURLException,
                                        IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(String) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        URL url)
                                 throws IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(URL) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        HttpURLConnection connection)
                                 throws IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(HttpURLConnection) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

オーバーライド:
クラス HTTPActionEventEntityHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getQueryString

protected String getQueryString()
                         throws UnsupportedEncodingException
設定されているパラメータ情報からクエリ文字列を作成して返します。

戻り値:
クエリ。パラメータが設定されていない場合は null。
例外:
UnsupportedEncodingException - 設定されている文字エンコーディング名がサポート外

getURL

public HTTPActionEventURL getURL(String url)
                          throws MalformedURLException,
                                 IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(String) の結果を HTTPActionEventURL インターフェースでラップして返します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public HTTPActionEventURL getURL(URL url)
                          throws IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(URL) の結果を HTTPActionEventURL インターフェースでラップして返します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public HTTPActionEventURL getURL(HttpURLConnection connection)
                          throws IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(HttpURLConnection) の結果を HTTPActionEventURL インターフェースでラップして返します。

戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.batch.Scheduler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.batch.Scheduler の使用

jp.co.intra_mart.foundation.service.client.batch.Scheduler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.client.batch (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.client.batch
クラス
Scheduler


jp.co.intra_mart.foundation.service.client.batch (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.batch

Schedule Service を利用するためのクラスを提供します。

参照:
説明

クラスの概要
Scheduler Schedule Service の制御をするオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.batch の説明

Schedule Service を利用するためのクラスを提供します。

Schedule Service の情報を取得したり、Schedule Service でプログラムを実行することの できるクラスが用意されています。

導入されたバージョン:
version 3.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.client.batch クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.batch.Scheduler (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.client.batch の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.batch の使用

jp.co.intra_mart.foundation.service.client.batch はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Scheduler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.batch
クラス Scheduler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.batch.Scheduler
すべての実装インタフェース:
ActionListener, Serializable
public class Scheduler
extends NetworkAgent
implements Serializable

Schedule Service の制御をするオブジェクトです。

このオブジェクトのすべてのメソッドは、Schedule Service に対する オペレーションになります。
このオブジェクトの各メソッド実行時は、Schedule Service と通信を行います。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
Scheduler()
新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object args) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
boolean | defineInitializeTime(int hour, int minute, int second) バッチ初期化時間の設定。
String | initializeTime() バッチ初期化時間の取得。
boolean | isAlive() スケジューラが動作しているかどうかをチェックします。
boolean | restart() スケジューラの再開通知。
boolean | start() スケジューラの開始通知。
boolean | stop() スケジューラの停止通知。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Scheduler

public Scheduler()
新しいオブジェクトを構築します。

メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラー

start

public boolean start()
              throws IOException
スケジューラの開始通知。

スケジューラが動作を開始すると、バッチ設定に基づいて、 指定時刻に指定されたバッチプログラムを実行します。
Schedule Service は開始通知を受けると、バッチ初期化時間まで待機状態となり、 バッチプログラムの実行は現在に最も近い未来のバッチ初期化時間以降と なります。

restart() メソッドとの違いは、start() メソッドの場合、 現在から現在に最も近い未来のバッチ初期化時間までのバッチ設定を 無視します。

戻り値:
スケジューラが動作を開始した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
restart()

restart

public boolean restart()
                throws IOException
スケジューラの再開通知。

スケジューラが動作を開始すると、バッチ設定に基づいて、 指定時刻に指定されたバッチプログラムを実行します。
Schedule Service は再開通知を受けると、即時に スケジューラとして動作を開始します。

start() メソッドとの違いは、restart() メソッドの場合、 現在から現在に最も近い未来のバッチ初期化時間までのバッチ設定を 読み込んで即時に実行可能状態になる点にあります。

戻り値:
スケジューラが動作を開始した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start()

stop

public boolean stop()
             throws IOException
スケジューラの停止通知。

Schedule Serviceは停止通知を受けると、 スケジューラとして動作を停止します。

通知前に実行状態に入ったバッチプログラムは、そのバッチプログラムが 終了するまで実行を継続します。

戻り値:
スケジューラが動作を停止した場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start(), restart()

isAlive

public boolean isAlive()
                throws IOException
スケジューラが動作しているかどうかをチェックします。

戻り値:
スケジューラが動作している場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー
関連項目:
start(),
restart(),
stop()

defineInitializeTime

public boolean defineInitializeTime(int hour,
                                    int minute,
                                    int second)
                             throws IOException
バッチ初期化時間の設定。

パラメータ:
hour - 初期化時間（時間）
minute - 初期化時間（分）
second - 初期化時間（秒）
戻り値:
設定が正しく行われた場合 true、そうでない場合 false。
例外:
IOException - 入出力エラー

initializeTime

public String initializeTime()
                      throws IOException
バッチ初期化時間の取得。

バッチ初期化時間は『00:00:00』というフォーマットされた文字列で 返されます。 初期化時間設定の文字列化に失敗した場合 null が返されます。

戻り値:
バッチ初期化時間
例外:
IOException - 入出力エラー

action

public final Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
任意の実行結果
例外:
IllegalArgumentException - 想定外の通信（プロトコル違反）
関連項目:
NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.service.client.ActionListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.ActionListener の使用

ActionListener を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client のクラス
 class NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

ActionListener 型のパラメータを持つ jp.co.intra_mart.foundation.service.client のメソッド
 Object NetworkConnector.execute(ActionListener target, Object arg)
サーバに対して実行要求をします。

jp.co.intra_mart.foundation.service.client.batch での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.batch のクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.file のクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での ActionListener の使用

ActionListener を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.NetworkAgent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.NetworkAgent の使用

NetworkAgent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.batch での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.batch での NetworkAgent のサブクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.file での NetworkAgent のサブクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での NetworkAgent の使用

jp.co.intra_mart.foundation.service.client.information での NetworkAgent のサブクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.NetworkConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.NetworkConnector の使用

NetworkConnector を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client での NetworkConnector のサブクラス
 class NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.batch での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.batch での NetworkConnector のサブクラス
 class Scheduler
Schedule Service の制御をするオブジェクトです。

jp.co.intra_mart.foundation.service.client.file での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.file での NetworkConnector のサブクラス
class | AbstractComponent このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
class | NetworkFile Storage Service のファイルを扱う事の出来るオブジェクトです。

jp.co.intra_mart.foundation.service.client.information での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.information での NetworkConnector のサブクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | ExternalMemory 共有データを管理するオブジェクトです。
class | Lock アプリケーションロックをするための機能を提供します。
class | PermanentDirectory ファイルベースでデータを保存します。
class | PermanentFile ファイルベースでデータを保存します。

jp.co.intra_mart.foundation.service.client.manager での NetworkConnector の使用

jp.co.intra_mart.foundation.service.client.manager での NetworkConnector のサブクラス
 class ServerConnector
このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.file.AbstractComponent の使用

AbstractComponent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.file Storage Service を利用するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client.file での AbstractComponent の使用

jp.co.intra_mart.foundation.service.client.file での AbstractComponent のサブクラス
 class NetworkFile
Storage Service のファイルを扱う事の出来るオブジェクトです。

AbstractComponent を返す jp.co.intra_mart.foundation.service.client.file のメソッド
static AbstractComponent AbstractComponent.getInstance()
このクラスの新しいインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.file.NetworkFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.file.NetworkFile の使用

NetworkFile を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での NetworkFile の使用

NetworkFile を返す jp.co.intra_mart.framework.base.data のメソッド
protected NetworkFile | IntramartFileServerDAO.getNetworkFile(String path) パスに該当するNetworkFileを取得します。
NetworkFile | IntramartFileServerConnector.getNetworkFile(String path) Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractComponent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.file
クラス AbstractComponent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.file.AbstractComponent
すべての実装インタフェース:
ActionListener, Serializable
直系の既知のサブクラス:
NetworkFile
public abstract class AbstractComponent
extends NetworkAgent
implements Serializable

このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための メソッドと実際にサーバで実行されるロジックを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

関連項目:
NetworkAgent, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected AbstractComponent()
唯一のコンストラクタ。
メソッドの概要
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
static AbstractComponent | getInstance() このクラスの新しいインスタンスを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
action, execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractComponent

protected AbstractComponent()
唯一のコンストラクタ。

メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getInstance

public static AbstractComponent getInstance()
このクラスの新しいインスタンスを取得します。

戻り値:
このクラスから生成されるインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.file
クラス NetworkFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.file.AbstractComponent
                拡張 jp.co.intra_mart.foundation.service.client.file.NetworkFile
すべての実装インタフェース:
ActionListener, Serializable
public class NetworkFile
extends AbstractComponent
implements Serializable

Storage Service のファイルを扱う事の出来るオブジェクトです。

このオブジェクトのすべてのメソッドは、Storage Service に対する オペレーションになります。
分散サーバ形態で運用している場合、他のコンピュータに 保管されているファイルを扱う事が出来ます。 このオブジェクトの各メソッド実行時は、Storage Service と通信を行います。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
NetworkFile(String path)
新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object args) 推奨されていません。
boolean | append(String src) ファイルにテキストを追記します。
Collection | directories() ディレクトリ中のサブディレクトリの一覧を取得します。
boolean | exists() このパス名が示すファイルが存在するかどうかを判定します。
Collection | files() ディレクトリ中のファイルの一覧を取得します。
String | getPath() このオブジェクトが表すパスを返します。
boolean | isDirectory() このパス名が示すファイルがディレクトリであるかどうかを判定します。
boolean | isFile() このパス名が示すファイルが普通のファイルかどうかを判定します。
long | lastModified() このパス名が示すファイルが最後に変更された時刻を返します。
long | length() このパス名が示すファイルの長さを返します。
Collection | lists() ディレクトリ中の一覧を取得します。
byte[] | load() ファイルの内容を取得します。
boolean | makeDirectories() このパス名が示すディレクトリを生成します。
boolean | move(String newPath) このパス名が示すファイルの名前を変更します。
String | read() ファイルの内容を取得します。
boolean | remove() このパス名が示すファイルまたはディレクトリを削除します。
boolean | save(byte[] byteStream) ファイルにバイトを出力します。
boolean | write(String src) ファイルにテキストを出力します。
クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent から継承したメソッド
connection, getInstance
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NetworkFile

public NetworkFile(String path)
新しいオブジェクトを構築します。

このインスタンスは、Storage Service のファイル管理ディレクトリ(標準では storage/)以下の path で アクセスできるファイルまたはディレクトリを扱う事が出来ます。

パラメータ:
path - パス名
例外:
NullPointerException - 引数が null
メソッドの詳細

getPath

public String getPath()
このオブジェクトが表すパスを返します。 このメソッドは、コンストラクタで指定されたパスをそのまま返します。

戻り値:
パス

files

public Collection files()
                 throws IOException
ディレクトリ中のファイルの一覧を取得します。

コレクションの各要素は String です。

戻り値:
ファイル名一覧
例外:
IOException - 入出力エラー

directories

public Collection directories()
                       throws IOException
ディレクトリ中のサブディレクトリの一覧を取得します。

コレクションの各要素は String です。

戻り値:
サブディレクトリ名一覧
例外:
IOException - 入出力エラー

lists

public Collection lists()
                 throws IOException
ディレクトリ中の一覧を取得します。

ディレクトリに含まれるすべてのファイルを検索します。 ファイル名の取得対象は、サブディレクトリも含まれます。
コレクションの各要素は String です。

戻り値:
ファイルおよびサブディレクトリ名一覧
例外:
IOException - 入出力エラー

read

public String read()
            throws IOException
ファイルの内容を取得します。

ファイル内のテキストを Unicode に変換して返します。
テキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードで あるものとして読み込みます。

戻り値:
ファイルの内容
例外:
IOException - 入出力エラー

write

public boolean write(String src)
              throws IOException
ファイルにテキストを出力します。

指定の内容のテキストファイルを作成します。 すでにファイルが存在している場合は、上書きされます。
ファイルに書き出されたテキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードに 変換されています。

このメソッドは、ファイルに出力する文字を文字コード変換する際に、 AdvancedOutputStreamWriter を利用しています。 これにより、Java-VM が持つ文字コード間のマッピングに起因した文字化けに 対して、いくつかの文字の文字化けを回避しています。 文字化けを回避できる文字については、 CharacterEncoder の仕様を参照してください。

パラメータ:
src - ファイルに書き出すテキスト
戻り値:
ファイルへのテキストの書き出しに成功した場合 true
例外:
IOException - 入出力エラー

append

public boolean append(String src)
               throws IOException
ファイルにテキストを追記します。

指定の内容をテキストファイルに追記します。 すでにファイルが存在している場合は、追記されます。 ファイルが存在していない場合、新しいファイルを作成します。
ファイルに書き出されたテキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードに 変換されています。

このメソッドは、ファイルに出力する文字を文字コード変換する際に、 AdvancedOutputStreamWriter を利用しています。 これにより、Java-VM が持つ文字コード間のマッピングに起因した文字化けに 対して、いくつかの文字の文字化けを回避しています。 文字化けを回避できる文字については、 CharacterEncoder の仕様を参照してください。

パラメータ:
src - ファイルに書き出すテキスト
戻り値:
ファイルへのテキストの書き出しに成功した場合 true
例外:
IOException - 入出力エラー

load

public byte[] load()
            throws IOException
ファイルの内容を取得します。

戻り値:
バイト列
例外:
IOException - 入出力エラー

save

public boolean save(byte[] byteStream)
             throws IOException
ファイルにバイトを出力します。

指定の内容のファイルを作成します。 すでにファイルが存在している場合は、上書きされます。 ファイルが存在していない場合、新しいファイルを作成します。

パラメータ:
byteStream - ファイルに書き出すバイト
戻り値:
ファイルへのバイト列の書き出しに成功した場合 true
例外:
IOException - 入出力エラー

makeDirectories

public boolean makeDirectories()
                        throws IOException
このパス名が示すディレクトリを生成します。

存在していないが必要な親ディレクトリも一緒に作成されます。 このオペレーションが失敗した場合でも、いくつかの必要な 親ディレクトリの生成には成功した場合があります。 すでにファイルが存在している場合は、上書きされます。 ファイルが存在していない場合、新しいファイルを作成します。

戻り値:
必要なすべての親ディレクトリを含めてディレクトリが作成された場合 は true、そうでない場合は false
例外:
IOException - 入出力エラー

remove

public boolean remove()
               throws IOException
このパス名が示すファイルまたはディレクトリを削除します。

このパス名がディレクトリを示す場合、 そのディレクトリが削除されるためには空である必要があります。

戻り値:
ファイルまたはディレクトリが正常に削除された場合は true、そうでない場合は false
例外:
IOException - 入出力エラー

move

public boolean move(String newPath)
             throws IOException
このパス名が示すファイルの名前を変更します。

パラメータ:
newPath - 示されたファイルの新しいパス名
戻り値:
名前の変更が成功した場合は true、そうでない場合は false
例外:
IOException - 入出力エラー

exists

public boolean exists()
               throws IOException
このパス名が示すファイルが存在するかどうかを判定します。

戻り値:
このパス名が示すファイルが存在する場合は true、 そうでない場合は false
例外:
IOException - 入出力エラー

isFile

public boolean isFile()
               throws IOException
このパス名が示すファイルが普通のファイルかどうかを判定します。

ファイルは、それがディレクトリではなく、システムに依存するほかの 基準を満たす場合に「普通」のファイルと見なされます。 このオブジェクトにより生成されたディレクトリ以外のファイルは、 必ず普通のファイルです。

戻り値:
このパス名が示すファイルが存在し、 それが普通のファイルである場合は true、 そうでない場合は false
例外:
IOException - 入出力エラー

isDirectory

public boolean isDirectory()
                    throws IOException
このパス名が示すファイルがディレクトリであるかどうかを判定します。

戻り値:
このパス名が示すファイルが存在し、 それがディレクトリである場合は true、 そうでない場合は false
例外:
IOException - 入出力エラー

lastModified

public long lastModified()
                  throws IOException
このパス名が示すファイルが最後に変更された時刻を返します。

戻り値:
ファイルが最後に変更された時刻を表す long 値。 エポック (00:00:00 GMT, January 1, 1970) からミリ秒単位で測定。 ファイルが存在しないか、入出力エラーが発生した場合は 0L
例外:
IOException - 入出力エラー

length

public long length()
            throws IOException
このパス名が示すファイルの長さを返します。

戻り値:
このパス名が示すファイルの長さ (バイト単位)、 ファイルが存在しない場合は 0L
例外:
IOException - 入出力エラー

action

public Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
実行結果
関連項目:
NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.file (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.client.file
クラス
AbstractComponent
NetworkFile


jp.co.intra_mart.foundation.service.client.file (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.file

Storage Service を利用するためのクラスを提供します。

参照:
説明

クラスの概要
AbstractComponent | このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
NetworkFile | Storage Service のファイルを扱う事の出来るオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.file の説明

Storage Service を利用するためのクラスを提供します。

Storage Service の情報を取得したり、Storage Service でプログラムを実行することの できるクラスが用意されています。
Storage Service が別なプロセスとしてサービスを提供している場合、 このパッケージのクラスは、ネットワークにより Storage Service に対して アクセスを試みます。 これにより、intra-mart サーバの運用形態が変更されても、 プログラマはまったく意識することなく、 Storage Service を利用することができます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.client.file クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.file.AbstractComponent (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.service.client.file.NetworkFile (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.client.file の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.file の使用

jp.co.intra_mart.foundation.service.client.file を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.service.client.file のクラス
AbstractComponent
このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.foundation.service.client.file のクラス
NetworkFile
Storage Service のファイルを扱う事の出来るオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の使用

ExternalDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での ExternalDirectory の使用

ExternalDirectory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
static ExternalDirectory ExternalDirectory.getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

ExternalDirectory 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.information のコンストラクタ
ExternalMemory(ExternalDirectory parent, String id)
共有データを扱うための新しいオブジェクトを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.ExternalMemory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.ExternalMemory の使用

jp.co.intra_mart.foundation.service.client.information.ExternalMemory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.Identifier の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.Identifier の使用

jp.co.intra_mart.foundation.service.client.information.Identifier はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.InitialFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.InitialFile の使用

jp.co.intra_mart.foundation.service.client.information.InitialFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.Lock の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.Lock の使用

jp.co.intra_mart.foundation.service.client.information.Lock はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の使用

PermanentDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での PermanentDirectory の使用

PermanentDirectory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
static PermanentDirectory PermanentDirectory.getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

PermanentDirectory 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.information のコンストラクタ
PermanentFile(PermanentDirectory parent, String id)
共有データを扱うための新しいオブジェクトを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.PermanentFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.PermanentFile の使用

jp.co.intra_mart.foundation.service.client.information.PermanentFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.SessionFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.SessionFactory の使用

jp.co.intra_mart.foundation.service.client.information.SessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.SessionMemory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.SessionMemory の使用

SessionMemory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.service.client.information での SessionMemory の使用

SessionMemory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
SessionMemory | SessionFactory.getFile() 現在有効なセッションを扱う SessionMemory インスタンスを取得します。
SessionMemory | SessionFactory.entry() 新しい空のセッションを作成します。

jp.co.intra_mart.framework.base.session での SessionMemory の使用

SessionMemory 型のパラメータを持つ jp.co.intra_mart.framework.base.session のコンストラクタ
IntramartSessionObject(SessionMemory session)
推奨されていません。 IntramartSessionObjectを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.information.TreasureDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.information.TreasureDirectory の使用

TreasureDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での TreasureDirectory の使用

TreasureDirectory を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalDirectory 共有データグループを管理するオブジェクトです。
class | PermanentDirectory ファイルベースでデータを保存します。
class | SessionFactory 共有データグループを管理するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.information.TreasureFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.information.TreasureFile の使用

TreasureFile を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での TreasureFile の使用

TreasureFile を実装している jp.co.intra_mart.foundation.service.client.information のクラス
class | ExternalMemory 共有データを管理するオブジェクトです。
class | PermanentFile ファイルベースでデータを保存します。
class | SessionMemory 共有データを管理するオブジェクトです。

TreasureFile を返す jp.co.intra_mart.foundation.service.client.information のメソッド
TreasureFile | TreasureDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
TreasureFile | TreasureDirectory.entry(String id) 空のグループを作成します。
TreasureFile | SessionFactory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
TreasureFile | SessionFactory.entry(String id) 新しい空のセッションを作成します。
TreasureFile | PermanentDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
TreasureFile | PermanentDirectory.entry(String id) 空のグループを作成します。
TreasureFile | ExternalDirectory.getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
TreasureFile | ExternalDirectory.entry(String id) 空のグループを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ExternalDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス ExternalDirectory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.ExternalDirectory
すべての実装インタフェース:
ActionListener, Serializable, TreasureDirectory
public class ExternalDirectory
extends NetworkAgent
implements Serializable, TreasureDirectory

共有データグループを管理するオブジェクトです。

グループ化された共有データのグループに関する情報を操作します。 各グループに保存されているデータの取得や各グループへのデータの保存には、 ExternalMemory クラスを利用します。
このオブジェクトにより扱うデータは、Shared Memory Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散は位置している場合、 このオブジェクトの各メソッド実行時は、Shared Memory Service と通信を行います。

このオブジェクトで保管されるデータは、Shared Memory Service のメモリ中で 管理され、Shared Memory Service が動作している間、その存在が保証されます。

導入されたバージョン:
version 3.1
関連項目:
ExternalMemory, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected ExternalDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
static ExternalDirectory | getInstance(String dir) 共有データを扱うためのオブジェクトを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExternalDirectory

protected ExternalDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

メソッドの詳細

getInstance

public static ExternalDirectory getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
ExternalMemory インスタンス

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExternalMemory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス ExternalMemory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.ExternalMemory
すべての実装インタフェース:
ActionListener, Serializable, TreasureFile
public class ExternalMemory
extends NetworkAgent
implements Serializable, TreasureFile

共有データを管理するオブジェクトです。

共有データはグループ化させて保存することができます。 グループ化にはグループＩＤを用い、このグループＩＤがそれぞれの グループ間でユニークである必要があります。 グループ化された共有データのグループ情報に関しては、 ExternalDirectory クラスを利用することによりアクセスすることができます。
このオブジェクトにより扱うデータは、Shared Memory Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Shared Memory Service と通信を行います。

このオブジェクトで保管されるデータは、Shared Memory Service のメモリ中で 管理され、Shared Memory Service が動作している間、その存在が保証されます。

導入されたバージョン:
version 3.1
関連項目:
ExternalDirectory, 直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected | ExternalMemory(ExternalDirectory parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
protected | ExternalMemory(String parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
void | clear() データを削除します。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すグループＩＤを取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExternalMemory

protected ExternalMemory(String parent,
                         String id)
                  throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ名称
id - グループ
例外:
NullPointerException - 引数が null

ExternalMemory

protected ExternalMemory(ExternalDirectory parent,
                         String id)
                  throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ
id - グループ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このインスタンスが表すグループＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

id に属する共有データとして key と value をマップします。 id が存在していない場合、新しいグループが作成されます。
返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

id に属する共有データとして list をマップに追加します。 id が存在していない場合、新しいグループが作成されます。
list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から key にマップされているデータを 取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

clear

public void clear()
           throws IOException
データを削除します。

id に属する共有データをすべて削除します。

定義:
インタフェース TreasureFile 内の clear
例外:
IOException - 入出力エラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

id に属するデータの中から key にマップされているデータを 削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

id に属するデータとしてマップされている key のリストを 取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Identifier (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス Identifier

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.Identifier
public final class Identifier
extends Object

ユニークなＩＤを生成する機能を提供します。

このオブジェクトは、システム全体で一意性が保証されるＩＤを生成します。 そのため、intra-mart の各サーバモジュールを分散は位置している場合、 このオブジェクトのget() メソッド実行時は、 共通の Server Manager に管理されているすべてのプロセスで一意性を保証 されたＩＤを扱うことができます。

コンストラクタの概要
Identifier()
唯一のコンストラクタ。
メソッドの概要
String | get() 一意性を保証されたＩＤを取得します。
static String | make()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Identifier

public Identifier()
唯一のコンストラクタ。

メソッドの詳細

get

public String get()
           throws IOException
一意性を保証されたＩＤを取得します。 生成される文字列の長さは 15 バイトです。

戻り値:
ＩＤ
例外:
IOException - Server Manager との通信エラー

make

public static String make()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InitialFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス InitialFile

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.foundation.service.client.information.InitialFile
すべての実装インタフェース:
Cloneable, Map, Serializable
public final class InitialFile
extends Properties

設定ファイル(*.ini)の内容を読み込むためのクラスです。

このクラスは、Resource Service のリソースディレクトリ(標準では pages/)に 保存されている設定ファイル(*.ini)を読み込んで Properties インターフェースで 値へのアクセスを可能にします。
このクラスを利用することにより、ページベース開発モデルで作成された プログラムと設定ファイルを共有することが可能となり、 異なるモデル間において共通的な設定内容に基づいたアプリケーションを 作成できます。

関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
InitialFile(String path)
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InitialFile

public InitialFile(String path)
            throws IOException
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。

パラメータ:
path - ini ファイルのパス
例外:
FileNotFoundException - 指定ファイルが存在しないか、指定ファイルの読み込みに失敗した場合
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Lock (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス Lock

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.Lock
すべての実装インタフェース:
ActionListener, Serializable
public class Lock
extends NetworkAgent
implements Serializable

アプリケーションロックをするための機能を提供します。

このクラスでは、ロックのフラグ情報を Serialization Servive において 一元的に管理するため、異なる Application Runtime プロセス間における プログラム実行の直列化を実現することができます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
Lock(String id)
ロックをするためのインスタンスを作ります。
メソッドの概要
Object | action(Object args) 推奨されていません。
void | begin() ロックフラグを立てます。
boolean | begin(long timeout) ロックフラグを立てます。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
boolean | end() ロックを解除します。
String | getName() このインスタンスの表すロックＩＤを返します。
boolean | isLocked() ロックの状態を確認します。
static List | releaseCurrentThread() 現在のスレッドに紐付いたロックを全て解除します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Lock

public Lock(String id)
     throws NullPointerException
ロックをするためのインスタンスを作ります。 コンストラクタの引数に指定したキーに対するロック機構を提供します。 ロックの機能は Serialization Servive 上に実装されているので このＡＰＩが分散の環境において実行された場合においても同一のキーに マッピングされたロックとして排他制御を行う事が出来ます。

パラメータ:
id - ロックＩＤ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このインスタンスの表すロックＩＤを返します。

戻り値:
ロックＩＤ

begin

public void begin()
           throws IOException
ロックフラグを立てます。 このオブジェクトが表すキーに対してロックフラグを立てます。 既にロックフラグが設定されている場合には、ロックフラグが解除されるまで 待機します。このＡＰＩによりロックフラグが設定された場合、ロックフラグを 解除するまで他の begin() 要求は待機状態となります。

例外:
IOException - 入出力エラー

begin

public boolean begin(long timeout)
              throws IOException
ロックフラグを立てます。 このオブジェクトが表すキーに対してロックフラグを立てます。 既にロックフラグが設定されている場合には、ロックフラグが解除されるまで 待機します。このＡＰＩによりロックフラグが設定された場合、ロックフラグを 解除するまで他の begin() 要求は待機状態となります。 既にロック状態であり、引数 timeout 秒経過してもロックが解除されなかった 場合、このメソッドは false を返します。

パラメータ:
timeout - ロック開始要求の待ち時間（秒）
戻り値:
ロックの設定に成功した場合 true
例外:
IOException - 入出力エラー

end

public boolean end()
            throws IOException
ロックを解除します。 このオブジェクトが表すキーに対してロックを解除します。

戻り値:
ロック解除に成功した場合 true
例外:
IOException - 入出力エラー

isLocked

public boolean isLocked()
                 throws IOException
ロックの状態を確認します。 このオブジェクトが表すキーに対するロックの状態を確認します。 このオブジェクトが表すキーに対して begin() メソッドが実行されていて また、ロックセッション時間内であって end() メソッドが実行されていない場合、このメソッドは true を 返します。

戻り値:
すでにロック状態である場合 true
例外:
IOException - 入出力エラー

action

public Object action(Object args)
推奨されていません。

処理ロジックの実行。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
args - 実行時引数
戻り値:
処理結果
関連項目:
NetworkAgent.execute(Object)

releaseCurrentThread

public static List releaseCurrentThread()
現在のスレッドに紐付いたロックを全て解除します。

戻り値:
現在のスレッドに紐づいたロックが存在しない場合は null を返却します。
上記以外の場合、ロックの解除に失敗したロックID(String)を格納したListを返却します。
（ロック解除に全て成功した際には、要素が空のListが返却されます）
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.information (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.client.information
インタフェース
TreasureDirectory
TreasureFile
クラス
ExternalDirectory
ExternalMemory
Identifier
InitialFile
Lock
PermanentDirectory
PermanentFile
SessionFactory
SessionMemory


jp.co.intra_mart.foundation.service.client.information (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.information

このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

参照:
説明

インタフェースの概要
TreasureDirectory | 情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile | 情報データベースのファイルを操作するためのインターフェースを定義します。

クラスの概要
ExternalDirectory | 共有データグループを管理するオブジェクトです。
ExternalMemory | 共有データを管理するオブジェクトです。
Identifier | ユニークなＩＤを生成する機能を提供します。
InitialFile | 設定ファイル(*.ini)の内容を読み込むためのクラスです。
Lock | アプリケーションロックをするための機能を提供します。
PermanentDirectory | ファイルベースでデータを保存します。
PermanentFile | ファイルベースでデータを保存します。
SessionFactory | 共有データグループを管理するオブジェクトです。
SessionMemory | 共有データを管理するオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.client.information の説明

このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

このパッケージに含まれるクラスにより利用可能なサービスは、以下のとおりです。

  • Permanent Data Service
  • Resource Service
  • Serialization Service
  • Sharead Memory Service

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.client.information クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.information の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.foundation.service.client.information.InitialFile
    • class jp.co.intra_mart.foundation.service.client.information.Identifier
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalMemory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.information.Lock (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentFile (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
    • class jp.co.intra_mart.foundation.service.client.information.SessionFactory (implements jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
    • class jp.co.intra_mart.foundation.service.client.information.SessionMemory (implements jp.co.intra_mart.foundation.service.client.information.TreasureFile)

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureFile
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.client.information の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.information の使用

jp.co.intra_mart.foundation.service.client.information を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.service.client.information のクラス
ExternalDirectory
共有データグループを管理するオブジェクトです。
PermanentDirectory
ファイルベースでデータを保存します。
SessionMemory
共有データを管理するオブジェクトです。
TreasureDirectory
情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile
情報データベースのファイルを操作するためのインターフェースを定義します。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.foundation.service.client.information のクラス
SessionMemory
共有データを管理するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PermanentDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス PermanentDirectory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.PermanentDirectory
すべての実装インタフェース:
ActionListener, Serializable, TreasureDirectory
public class PermanentDirectory
extends NetworkAgent
implements Serializable, TreasureDirectory

ファイルベースでデータを保存します。

データをそのままファイルに保存して、サーバの再起動後も保存したデータを 扱うためのＡＰＩを提供します。
保存するデータは、直列化可能なオブジェクトに限ります。 また、保存した時の環境と取り出した時の環境において、そのデータに関連する クラスの構造が異なっている場合、正常に値をやりとりできません。

このオブジェクトにより扱うデータは、Permanent Data Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Permanent Data Service と通信を行います。 また、データファイルが保存されるディレクトリは、 treasure/ 以下の getDomain() メソッドで示されるディレクトリになります。
サブディレクトリを任意に指定する事が可能で、そのサブディレクトリ内に グループが存在し、そのグループ内にデータがキーにマップされる形で 保存されます。

getDomain() メソッドで表される情報保存ディレクトリには、 すでに用法が定められているものがあります。
ベースモジュールの各機能が利用する情報は vault/ ディレクトリに保存され、またページベース開発モデルからの情報は、 articles/ ディレクトリ内に保存されます。 これらのディレクトリに情報を保存(また更新や削除)した場合、関係機能への 情報の干渉を引き起こしシステムを不安定にしてしまう危険性があります。

このオブジェクトで保管されるデータは、Permanent Data Service のファイルで 管理され、Permanent Data Service の再起動後も、その存在が保証されます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected PermanentDirectory(String dir)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
static PermanentDirectory | getInstance(String dir) 共有データを扱うためのオブジェクトを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentDirectory

protected PermanentDirectory(String dir)
                      throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null
メソッドの詳細

getInstance

public static PermanentDirectory getInstance(String dir)
共有データを扱うためのオブジェクトを取得します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
dir - 保存ディレクトリ
例外:
NullPointerException - 引数が null

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
PermanentFile インスタンス

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PermanentFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス PermanentFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
            拡張 jp.co.intra_mart.foundation.service.client.information.PermanentFile
すべての実装インタフェース:
ActionListener, Serializable, TreasureFile
public class PermanentFile
extends NetworkAgent
implements Serializable, TreasureFile

ファイルベースでデータを保存します。

データをそのままファイルに保存して、サーバの再起動後も保存したデータを 扱うためのＡＰＩを提供します。
保存するデータは、直列化可能なオブジェクトに限ります。 また、保存した時の環境と取り出した時の環境において、そのデータに関連する クラスの構造が異なっている場合、正常に値をやりとりできません。

このオブジェクトにより扱うデータは、Permanent Data Service で一元管理されます。 そのため、intra-mart の各サーバモジュールを分散配置している場合、 このオブジェクトの各メソッド実行時は、Permanent Data Service と通信を行います。 また、データファイルが保存されるディレクトリは、 treasure/ 以下の getParentName() メソッドで示されるディレクトリになります。 サブディレクトリを任意に指定する事が可能で、そのサブディレクトリ内に グループが存在し、そのグループ内にデータがキーにマップされる形で 保存されます。

このオブジェクトで保管されるデータは、Permanent Data Service のファイルで 管理され、Permanent Data Service の再起動後も、その存在が保証されます。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したフィールド
NULL_DATA
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected | PermanentFile(PermanentDirectory parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
protected | PermanentFile(String parent, String id) 共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
Object | action(Object argV) 推奨されていません。
void | clear() データを削除します。
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すグループＩＤを取得します。
String | getParentName() 保存ディレクトリを取得します。
List | keyList() キー一覧を取得します。
boolean | move(String new_id) グループキーを変更します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス jp.co.intra_mart.foundation.service.client.NetworkAgent から継承したメソッド
execute
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentFile

protected PermanentFile(String parent,
                        String id)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ名称
id - グループ
例外:
NullPointerException - 引数が null

PermanentFile

protected PermanentFile(PermanentDirectory parent,
                        String id)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、parent に保存されている共有データの中の id に属するデータを扱えます。 domain に保存されているデータや、他の id に属するデータを扱う事は できません。

パラメータ:
parent - 親ディレクトリ
id - グループ
例外:
NullPointerException - 引数が null
メソッドの詳細

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合

getParentName

public String getParentName()
保存ディレクトリを取得します。

実際には、Permanent Data Service のルート直下 tresure/ ディレクトリに サブディレクトリとして、このメソッドが表すディレクトリを作成して データを保存します。

戻り値:
保存ディレクトリ名称

getName

public String getName()
このインスタンスが表すグループＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

id に属する共有データとして key と value をマップします。 id が存在していない場合、新しいグループが作成されます。
返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

id に属する共有データとして list をマップに追加します。 id が存在していない場合、新しいグループが作成されます。
list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から key にマップされているデータを 取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

id に属する共有データの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

clear

public void clear()
           throws IOException
データを削除します。

id に属する共有データをすべて削除します。

定義:
インタフェース TreasureFile 内の clear
例外:
IOException - 入出力エラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

id に属するデータの中から key にマップされているデータを 削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

move

public boolean move(String new_id)
             throws IOException
グループキーを変更します。

現在のグループのキー(id)を新しいキー(new_id)に変更します。
new_id が、domain 内にすでに存在する場合は、変更に失敗します。

パラメータ:
new_id - 新しいグループ名
戻り値:
グループの変更ができた場合 true、失敗した場合 false
例外:
IOException - 入出力エラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

id に属するデータとしてマップされている key のリストを 取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

action

public Object action(Object argV)
推奨されていません。

処理ロジック。

定義:
インタフェース ActionListener 内の action
定義:
クラス NetworkAgent 内の action
パラメータ:
argV - 引数
戻り値:
実行結果
関連項目:
NetworkAgent.action(Object), NetworkAgent.execute(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス SessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.SessionFactory
すべての実装インタフェース:
TreasureDirectory
public class SessionFactory
extends Object
implements TreasureDirectory

共有データグループを管理するオブジェクトです。

グループ化された共有データのグループに関する情報を操作します。 各グループに保存されているデータの取得や各グループへのデータの保存には、 SessionMemory クラスを利用します。
このオブジェクトにより扱うデータは、HTTP セッションにて管理されます。 情報の入出力に関する仕様は、実行環境における HTTP セッションの仕様に 準拠します。

導入されたバージョン:
version 3.1
関連項目:
SessionMemory

コンストラクタの概要
SessionFactory(HttpServletRequest request, HttpServletResponse response)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
void | destroy() このメソッドは、現在のセッションを破棄してしまいます。
Map | destroy(String id) id によりアクセスできるセッションデータを破棄します。
List | entries() セッションＩＤ一覧を取得します。
SessionMemory | entry() 新しい空のセッションを作成します。
TreasureFile | entry(String id) 新しい空のセッションを作成します。
Number | expiration() セッションの維持時間を取得します。
SessionMemory | getFile() 現在有効なセッションを扱う SessionMemory インスタンスを取得します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
String | getName() このオブジェクトの表すディレクトリ名称を取得します。
String | newIdentifier() 新しいセッションＩＤを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionFactory

public SessionFactory(HttpServletRequest request,
                      HttpServletResponse response)
共有データを扱うための新しいオブジェクトを構築します。

このインスタンスは、dir に保存されている共有データ に関する情報を扱えます。

パラメータ:
request - サーブレットリクエスト
response - サーブレットレスポンス
メソッドの詳細

getName

public String getName()
このオブジェクトの表すディレクトリ名称を取得します。

このメソッドは常に null を返します。

定義:
インタフェース TreasureDirectory 内の getName
戻り値:
このオブジェクトの表すディレクトリ名称

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。

ただし、id は現在有効なセッションＩＤを渡さなければなりません。 指定された id が、現在のセッションを表すものとして不適切と判断した場合、 このメソッドは null を返します。

定義:
インタフェース TreasureDirectory 内の getFile
戻り値:
SessionMemory インスタンス

getFile

public SessionMemory getFile()
現在有効なセッションを扱う SessionMemory インスタンスを取得します。

戻り値:
SessionMemory インスタンス

entries

public List entries()
セッションＩＤ一覧を取得します。

コレクションに含まれるセッションＩＤは、現在のセッションに関わるもの のみです。 したがって、コレクションに含まれる要素は常に１つだけです。 ただし、セッションを作成していない状態では、 要素を一つも持たないコレクションを返します。

コレクションの各要素は String です。

定義:
インタフェース TreasureDirectory 内の entries
戻り値:
セッションＩＤのリスト

entry

public TreasureFile entry(String id)
新しい空のセッションを作成します。

このメソッドで作成されたセッションにはデータが存在しません。 ただし、すでにセッションが作成済みの場合には、 現在のセッションが返されます。
返却値として新しいセッションのデータを扱うためのオブジェクトを 返します。

定義:
インタフェース TreasureDirectory 内の entry
パラメータ:
id - グループ
戻り値:
SessionMemory インスタンス
例外:
IllegalArgumentException - id が現在のセッションのIDとして有効ではない場合
関連項目:
TreasureDirectory.entries()

entry

public SessionMemory entry()
新しい空のセッションを作成します。

このメソッドで作成されたセッションにはデータが存在しません。 ただし、すでにセッションが作成済みの場合には、 現在のセッションが返されます。
返却値として新しいセッションのデータを扱うためのオブジェクトを 返します。

戻り値:
SessionMemory インスタンス

destroy

public Map destroy(String id)
id によりアクセスできるセッションデータを破棄します。

定義:
インタフェース TreasureDirectory 内の destroy
戻り値:
セッションの破棄に成功した場合は空の Map が返され、セッションの破棄が出来なかった場合は null が返されます。

destroy

public void destroy()
このメソッドは、現在のセッションを破棄してしまいます。 したがって、メソッド実行後はセッションが無効となり、 セッション維持が出来なくなってしまいます。

expiration

public Number expiration()
セッションの維持時間を取得します。

戻り値:
セッション時間

newIdentifier

public String newIdentifier()
新しいセッションＩＤを生成します。

このメソッドは、単純に現在の環境のセッションＩＤを返します。 HTTP セッションが未作成の場合は、新しく作成してＩＤを返します。

戻り値:
新しく作成されたセッションＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionMemory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
クラス SessionMemory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.information.SessionMemory
すべての実装インタフェース:
TreasureFile
public class SessionMemory
extends Object
implements TreasureFile

共有データを管理するオブジェクトです。

このオブジェクトにより扱うデータは、HTTPセッションにより管理されます。

導入されたバージョン:
version 3.1
関連項目:
SessionFactory

コンストラクタの概要
protected SessionMemory(HttpSession session)
共有データを扱うための新しいオブジェクトを構築します。
メソッドの概要
void | clear() すべてのデータを削除します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このインスタンスが表すセッションＩＤを取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionMemory

protected SessionMemory(HttpSession session)
                 throws NullPointerException
共有データを扱うための新しいオブジェクトを構築します。

パラメータ:
session - ＨＴＴＰセッションオブジェクト
例外:
NullPointerException - 引数が null
メソッドの詳細

getName

public String getName()
このインスタンスが表すセッションＩＤを取得します。

定義:
インタフェース TreasureFile 内の getName
戻り値:
グループＩＤ
関連項目:
SessionFactory.entry(),
SessionFactory.entry(String),
SessionFactory.getFile(String)

put

public Object put(String key,
                  Object value)
データを保存します。

共有データとして key と value をマップします。 返却値は、key にマップされていたデータになります。返却データに関して、

定義:
インタフェース TreasureFile 内の put
パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値

putAll

public void putAll(Map list)
データを保存します。

共有データとして list をマップに追加します。 list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

定義:
インタフェース TreasureFile 内の putAll
パラメータ:
list - データ

get

public Object get(String key)
データを取得します。

共有データの中から key にマップされているデータを 取得します。

定義:
インタフェース TreasureFile 内の get
パラメータ:
key - キー
戻り値:
key にマップされている値

subMap

public Map subMap(String[] keys)
データを取得します。

セッションの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、

定義:
インタフェース TreasureFile 内の subMap
パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
NullPointerException - 引数が null の場合
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、

定義:
インタフェース TreasureFile 内の entryMap
戻り値:
このマップの全データ

clear

public void clear()
すべてのデータを削除します。

定義:
インタフェース TreasureFile 内の clear

remove

public Object remove(String key)
データを削除します。

共有データの中から key にマップされているデータを 削除します。

定義:
インタフェース TreasureFile 内の remove
パラメータ:
key - キー
戻り値:
key にマップされている値

keyList

public List keyList()
キー一覧を取得します。

コレクションの各要素は String です。

定義:
インタフェース TreasureFile 内の keyList
戻り値:
マップされているキーのリスト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreasureDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
インタフェース TreasureDirectory

既知の実装クラスの一覧:
ExternalDirectory, PermanentDirectory, SessionFactory
public interface TreasureDirectory

情報データベースのディレクトリを操作するためのインターフェースを定義します。

このインターフェースを継承するクラスでは、情報データベースの ディレクトリ情報へのアクセスを実装して下さい。

メソッドの概要
Map | destroy(String id) グループデータを削除します。
List | entries() このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
TreasureFile | entry(String id) 空のグループを作成します。
TreasureFile | getFile(String id) このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
String | getName() このオブジェクトの表す名称を取得します。

メソッドの詳細

getFile

public TreasureFile getFile(String id)
このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。

戻り値:
TreasureFile インスタンス

getName

public String getName()
このオブジェクトの表す名称を取得します。

戻り値:
このオブジェクトの名称

entries

public List entries()
             throws IOException,
                    ClassNotFoundException
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。

コレクションの各要素は String です。

戻り値:
グループＩＤのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー

entry

public TreasureFile entry(String id)
                   throws IOException
空のグループを作成します。

すでにグループが存在していた場合、このメソッドは何もしません。
このメソッドで作成されたグループにはデータが存在しません。
グループを作成する事により、entries() で取得できるグループリストに このオブジェクトが表すグループが含まれます。
返却値としてグループ id のデータを扱うためのオブジェクトを返します。

パラメータ:
id - グループ
戻り値:
TreasureFile インスタンス
例外:
NullPointerException - 引数が null
IOException - 入出力エラー
関連項目:
entries()

destroy

public Map destroy(String id)
            throws IOException,
                   ClassNotFoundException
グループデータを削除します。

id に属する共有データをすべて削除し、 共有データ領域から id に属するデータを保管する領域も削除します。 このメソッドが実行されると entries() で取得できるグループリストに このオブジェクトが示すグループが含まれなくなります。

返却値は、id に属していたデータ一覧になります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

戻り値:
id に属するデータ一覧
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TreasureFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.information
インタフェース TreasureFile

既知の実装クラスの一覧:
ExternalMemory, PermanentFile, SessionMemory
public interface TreasureFile

情報データベースのファイルを操作するためのインターフェースを定義します。

このインターフェースを継承するクラスでは、情報データベースの ファイル情報へのアクセスを実装して下さい。

メソッドの概要
void | clear() このオブジェクトのマップからマッピングをすべて削除します。
Map | entryMap() グループデータを取得します。
Object | get(String key) データを取得します。
String | getName() このオブジェクトの表す名称を取得します。
List | keyList() キー一覧を取得します。
Object | put(String key, Object value) データを保存します。
void | putAll(Map list) データを保存します。
Object | remove(String key) データを削除します。
Map | subMap(String[] keys) データを取得します。

メソッドの詳細

getName

public String getName()
このオブジェクトの表す名称を取得します。

戻り値:
このオブジェクトの名称

clear

public void clear()
           throws IOException
このオブジェクトのマップからマッピングをすべて削除します。

例外:
IOException

put

public Object put(String key,
                  Object value)
           throws IOException,
                  ClassNotFoundException,
                  OptionalDataException
データを保存します。

このオブジェクトに key と value をマップします。 返却値は、key にマップされていたデータになります。返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - データを保存するキー
value - 保存するデータ
戻り値:
key にマップされていた値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

putAll

public void putAll(Map list)
            throws IOException
データを保存します。

このオブジェクトに list をマップに追加します。 list 内のキーがすでにマップに存在している場合、list のマップ情報で 上書きされます。

パラメータ:
list - データ
例外:
IOException - 入出力エラー

get

public Object get(String key)
           throws IOException,
                  ClassNotFoundException
データを取得します。

このマップの中から key にマップされているデータを取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

subMap

public Map subMap(String[] keys)
           throws IOException,
                  ClassNotFoundException
データを取得します。

このマップの中から keys の各要素にマップされているデータ群を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
keys - キーの配列
戻り値:
指定されたキーとそのキーにマップされている値を持つマップ。指定したキーが存在しなかった場合、マップはそのキーを持ちません。
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー
導入されたバージョン:
version 5.0

entryMap

public Map entryMap()
             throws IOException,
                    ClassNotFoundException
グループデータを取得します。

このマップのデータ一覧を取得します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

戻り値:
このマップの全データ
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

remove

public Object remove(String key)
              throws IOException,
                     ClassNotFoundException
データを削除します。

マップの中から key にマップされているデータを削除します。
返却データに関して、 データを保存した時の環境とデータに関連するクラスの構造が異なる場合 例外がスローされます。

パラメータ:
key - キー
戻り値:
key にマップされている値
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
OptionalDataException - データ復元時のエラー

keyList

public List keyList()
             throws IOException,
                    ClassNotFoundException
キー一覧を取得します。

マップされている key のリストを取得します。

実行環境のバージョン等が異なると ClassNotFoundException がスロー される事があります。
コレクションの各要素は String です。

戻り値:
マップされているキーのリスト
例外:
IOException - 入出力エラー
ClassNotFoundException - データ復元時のエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException の使用

IllegalPasswordException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client.manager での IllegalPasswordException の使用

IllegalPasswordException をスローする jp.co.intra_mart.foundation.service.client.manager のメソッド
 SocketConnectionDistributor SocketConnectionDistributorFactory.createSocketConnectionDistributor(String passwd)
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.manager.ServerConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.ServerConnector の使用

jp.co.intra_mart.foundation.service.client.manager.ServerConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory の使用

jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


IllegalPasswordException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス IllegalPasswordException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException
すべての実装インタフェース:
Serializable
public class IllegalPasswordException
extends Exception

パスワードが認証されなかったことを通知するための例外です。

パスワードが間違っている場合にスローされます。

導入されたバージョン:
intra-mart Version 4.1
関連項目:
直列化された形式

コンストラクタの概要
IllegalPasswordException(String message)
指定のメッセージで例外を作成します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalPasswordException

public IllegalPasswordException(String message)
指定のメッセージで例外を作成します。

メッセージは、java.lang.Throwable クラスの getMessage メソッドから取得することができます。

パラメータ:
message - メッセージ
関連項目:
Throwable.getMessage()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.manager (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.client.manager
クラス
ServerConnector
SocketConnectionDistributorFactory
例外
IllegalPasswordException


jp.co.intra_mart.foundation.service.client.manager (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.manager

このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

参照:
説明

クラスの概要
ServerConnector | このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。
SocketConnectionDistributorFactory | このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。

例外の概要
IllegalPasswordException パスワードが認証されなかったことを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.client.manager の説明

このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
それぞれのサーバの持つ機能を利用するための具体的なＡＰＩに関しては、 サブパッケージを参照してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.client.manager クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.manager の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.manager.ServerConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.client.manager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.manager の使用

jp.co.intra_mart.foundation.service.client.manager を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.service.client.manager のクラス
IllegalPasswordException
パスワードが認証されなかったことを通知するための例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ServerConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス ServerConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.manager.ServerConnector
すべての実装インタフェース:
Serializable
public class ServerConnector
extends NetworkConnector
implements Serializable

このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。

導入されたバージョン:
intra-mart Version 4.1
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。
メソッドの概要
protected SocketConnection | connection() サーバに接続するためのコネクションを取得します。
SocketConnectionDistributor | getSocketConnectionDistributor() このオブジェクトが保持しているネットワークのコネクションプールを 返します。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServerConnector

public ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。

socketConnectionDistributor には、SocketConnectionDistributorFactory クラスから 作成されたオブジェクトを渡してください。

パラメータ:
socketConnectionDistributor - ネットワークコネクション管理オブジェクト
関連項目:
SocketConnectionDistributorFactory.createSocketConnectionDistributor(String)
メソッドの詳細

getSocketConnectionDistributor

public SocketConnectionDistributor getSocketConnectionDistributor()
このオブジェクトが保持しているネットワークのコネクションプールを 返します。

connection

protected SocketConnection connection()
                               throws IOException
サーバに接続するためのコネクションを取得します。

定義:
クラス NetworkConnector 内の connection
戻り値:
コネクション
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributorFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.manager
クラス SocketConnectionDistributorFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
public class SocketConnectionDistributorFactory
extends Object

このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。

導入されたバージョン:
intra-mart Version 4.1

コンストラクタの概要
SocketConnectionDistributorFactory(String address, int port)
オブジェクトを作成します。
SocketConnectionDistributorFactory(String address, int port, int timeout)
オブジェクトを作成します。
メソッドの概要
 SocketConnectionDistributor createSocketConnectionDistributor(String passwd)
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnectionDistributorFactory

public SocketConnectionDistributorFactory(String address,
                                          int port)
オブジェクトを作成します。

パラメータ:
address - Server-Manager が動作しているコンピュータのアドレス
port - Server-Manager がサービスを提供しているネットワークポート番号

SocketConnectionDistributorFactory

public SocketConnectionDistributorFactory(String address,
                                          int port,
                                          int timeout)
オブジェクトを作成します。

timeout には、リクエストに対する Server-Manager からの応答 タイムアウトをミリ秒で指定します。 タイムアウトを設定することにより、Server-Manager から応答がない場合に、 デットロックしてしまう可能性を回避することができます。 逆に、タイムアウトを設定することによって、 正常に動作している場合に置いてもタイムアウトが発生してしまうと、 リクエストはエラー終了扱いとなってしまいます。

パラメータ:
address - Server-Manager が動作しているコンピュータのアドレス
port - Server-Manager がサービスを提供しているネットワークポート番号
timeout - リクエストのタイムアウト時間
メソッドの詳細

createSocketConnectionDistributor

public SocketConnectionDistributor createSocketConnectionDistributor(String passwd)
                                                              throws IllegalPasswordException,
                                                                     IOException
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。 引数のパスワードには、Administrator を利用するためのパスワードとして 設定されている文字列を指定してください。

パラメータ:
passwd - パスワード
戻り値:
ネットワークコネクション管理オブジェクト
例外:
IllegalPasswordException - パスワード違反
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActionListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
インタフェース ActionListener

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
NetworkAgent
public interface ActionListener
extends Serializable

このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。

導入されたバージョン:
version 4.0

メソッドの概要
 Object action(Object arg)
このメソッドは、特定のイベント発生時に実行されます。

メソッドの詳細

action

public Object action(Object arg)
              throws RuntimeException,
                     Error
このメソッドは、特定のイベント発生時に実行されます。

どのイベントに対してのリスナーになるかということは、 このインターフェースを扱うオブジェクトに依存します。 したがって、このインターフェースは様々な種類のリスナーとして動作する 可能性があり、サブクラスは目的と動作を十分に認識した上で 実装する必要があります。

パラメータ:
arg - 引数オブジェクト
戻り値:
実行結果
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkAgent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
クラス NetworkAgent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
        拡張 jp.co.intra_mart.foundation.service.client.NetworkAgent
すべての実装インタフェース:
ActionListener, Serializable
直系の既知のサブクラス:
AbstractComponent, ExternalDirectory, ExternalMemory, Lock, PermanentDirectory, PermanentFile, Scheduler
public abstract class NetworkAgent
extends NetworkConnector
implements ActionListener

このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。

サーバがネットワーク型構成で動作している場合は、ネットワーク通信を行い 目的のサーバでロジックを実行します。サーバがスタンドアロン型構成で動作 している場合は、そのサーバ内で直接ロジックを実行します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための メソッドと実際にサーバで実行されるロジックを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

関連項目:
直列化された形式

フィールドの概要
protected static Object NULL_DATA
NULL を表します。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したフィールド
GET, GET_ENTIRETY, GET_ENTIRETY_KEY, GET_ITEM, GET_ITEM_KEY, GET_SUBSET, MOVE, MOVE_ENTIRETY, MOVE_ITEM, REMOVE, REMOVE_ENTIRETY, REMOVE_ITEM, SET, SET_ENTIRETY, SET_ITEM
コンストラクタの概要
protected NetworkAgent()
唯一のコンストラクタ。
メソッドの概要
abstract Object | action(Object arg) このオブジェクトの実行ロジック。
protected Object | execute(Object arg) サーバに対して実行要求をします。
クラス jp.co.intra_mart.foundation.service.client.NetworkConnector から継承したメソッド
close, connection, execute, freeMemory, isConnected, serverTime, totalMemory
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

NULL_DATA

protected static final Object NULL_DATA
NULL を表します。 値は null です。

コンストラクタの詳細

NetworkAgent

protected NetworkAgent()
唯一のコンストラクタ。

メソッドの詳細

action

public abstract Object action(Object arg)
                       throws RuntimeException,
                              Error
このオブジェクトの実行ロジック。

このメソッドは、execute(Object) を実行すると リスナーを実行する対象となっているサーバにより呼び出されます。 このメソッドの引数 arg は execute(Object) に渡された引数が そのまま渡されます。
このメソッドは、サブクラスでオーバーライドする必要があります。

サーバがスタンドアロン型で運用されている場合、現在動作しているサーバ内で 実行されます。 また、サーバがネットワーク型で運用されている場合、 NetworkConnector.connection() から取得したコネクションにより 接続されたサーバで実行されます。
サーバがネットワーク型で運用されている場合、このメソッドの実行結果は 直列化されてサーバ間を転送されるため、このメソッドの返却値は 直列化可能なオブジェクトである必要があります。
このメソッドの返却値が直列化ができなくて、サーバがネットワーク型で 運用されていた場合、実行要求をしたサーバ側で例外がスローされます。

定義:
インタフェース ActionListener 内の action
パラメータ:
arg - 引数オブジェクト
戻り値:
実行結果
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
execute(Object)

execute

protected final Object execute(Object arg)
                        throws IOException,
                               RuntimeException,
                               Error
サーバに対して実行要求をします。

サーバがスタンドアロン型で運用されている場合、現在動作しているサーバ内で サブクラスによりオーバーライドされた action(Object) を 実行し、その結果を返します。
サーバがネットワーク型で運用されている場合、 NetworkConnector.connection() から取得したコネクションにより 接続されたサーバにこのインスタンスを転送して実行を依頼します。 接続先サーバでは、このオブジェクトを復元して サブクラスによりオーバーライドされた action(Object) を 実行します。実行結果はネットワークにより転送され、復元した後に、 このメソッドの実行結果として返します。

このメソッドに渡す引数は、直列化可能なオブジェクトに限ります。 引数を直列化できない場合、このメソッドは例外をスローします。

パラメータ:
arg - action() に渡す引数
戻り値:
action() の実行結果
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 入出力エラーが発生した場合
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
action(Object)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NetworkConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client
クラス NetworkConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.NetworkConnector
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
NetworkAgent, ServerConnector
public abstract class NetworkConnector
extends Object
implements Serializable

このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

サーバがネットワーク型構成で動作している場合は、ネットワーク通信を行い 目的のサーバにロジックを転送します。サーバがスタンドアロン型構成で動作 している場合は、そのサーバ内で直接ロジックを実行します。
このクラスを継承したサブクラスでは、他のサーバでロジックを実行するための ネットワークコネクションを定義する必要があります。
また、サブクラスは直列化可能なクラスである必要があります。 サブクラスが直列化できない場合、ロジックの呼び出し時に例外がスローされます。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
protected static int | GET
protected static int | GET_ENTIRETY
protected static int | GET_ENTIRETY_KEY
protected static int | GET_ITEM
protected static int | GET_ITEM_KEY
protected static int | GET_SUBSET
protected static int | MOVE
protected static int | MOVE_ENTIRETY
protected static int | MOVE_ITEM
protected static int | REMOVE
protected static int | REMOVE_ENTIRETY
protected static int | REMOVE_ITEM
protected static int | SET
protected static int | SET_ENTIRETY
protected static int | SET_ITEM
コンストラクタの概要
protected NetworkConnector()
唯一のコンストラクタ。
メソッドの概要
void | close() ネットワークを切断します。
protected abstract SocketConnection | connection() サーバに接続するためのコネクションを取得します。
Object | execute(ActionListener target, Object arg) サーバに対して実行要求をします。
long | freeMemory() サーバシステムの空きメモリの量を返します。
boolean | isConnected() サーバとの接続状態をチェックします。
long | serverTime() サーバのミリ秒で表される現在の時間を返します。
long | totalMemory() サーバプロセスの Java Virtual Machine のメモリの総容量を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SET

protected static final int SET
関連項目:
定数フィールド値

SET_ITEM

protected static final int SET_ITEM
関連項目:
定数フィールド値

SET_ENTIRETY

protected static final int SET_ENTIRETY
関連項目:
定数フィールド値

GET

protected static final int GET
関連項目:
定数フィールド値

GET_ITEM

protected static final int GET_ITEM
関連項目:
定数フィールド値

GET_ENTIRETY

protected static final int GET_ENTIRETY
関連項目:
定数フィールド値

GET_SUBSET

protected static final int GET_SUBSET
導入されたバージョン:
version 5.0
関連項目:
定数フィールド値

GET_ITEM_KEY

protected static final int GET_ITEM_KEY
関連項目:
定数フィールド値

GET_ENTIRETY_KEY

protected static final int GET_ENTIRETY_KEY
関連項目:
定数フィールド値

REMOVE

protected static final int REMOVE
関連項目:
定数フィールド値

REMOVE_ITEM

protected static final int REMOVE_ITEM
関連項目:
定数フィールド値

REMOVE_ENTIRETY

protected static final int REMOVE_ENTIRETY
関連項目:
定数フィールド値

MOVE

protected static final int MOVE
関連項目:
定数フィールド値

MOVE_ITEM

protected static final int MOVE_ITEM
関連項目:
定数フィールド値

MOVE_ENTIRETY

protected static final int MOVE_ENTIRETY
関連項目:
定数フィールド値
コンストラクタの詳細

NetworkConnector

protected NetworkConnector()
唯一のコンストラクタ。

メソッドの詳細

connection

protected abstract SocketConnection connection()
                                        throws UnsupportedNetworkConnectException,
                                               IOException
サーバに接続するためのコネクションを取得します。
ネットワーク接続が必要ではない場合は、 UnsupportedNetworkConnectException をスローします。

このメソッドは、サブクラスでオーバーライドする必要があります。

戻り値:
コネクション
例外:
UnsupportedNetworkConnectException - ネットワーク接続が許可されていない場合
IOException - 入出力エラーが発生した場合

execute

public Object execute(ActionListener target,
                      Object arg)
               throws IOException,
                      RuntimeException,
                      Error
サーバに対して実行要求をします。

サーバがスタンドアロン型で運用されている場合、 現在動作しているサーバ内で リスナー ActionListener.action(Object) を 実行し、その結果を返します。
サーバがネットワーク型で運用されている場合、connection() メソッドにより取得したコネクションを利用してサーバに接続し、 リスナーオブジェクトを直列化して転送します。 接続先サーバでは、転送したリスナーオブジェクトを復元して リスナーオブジェクトの ActionListener.action(Object) を 実行します。実行結果はネットワークにより転送され、復元した後に、 このメソッドの実行結果として返します。

このメソッドに渡す引数は、直列化可能なオブジェクトに限ります。 引数を直列化できない場合、このメソッドは例外をスローします。

パラメータ:
target - サーバで実行するリスナーオブジェクト
arg - action() に渡す引数
戻り値:
action() の実行結果
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 入出力エラーが発生した場合
RuntimeException - 実行時エラー
Error - 致命的なエラー
関連項目:
NetworkAgent.action(Object)

isConnected

public boolean isConnected()
サーバとの接続状態をチェックします。

このメソッド実行時に取得したネットワークコネクションについて接続確認を します。他のコネクションに関してはチェックしないため、このメソッドの 結果接続を確認できたとしても次のリクエストで取得したコネクションで 接続エラーが発生する場合があります。

戻り値:
接続に成功した場合は true、そうでない場合は false。

serverTime

public long serverTime()
                throws IOException
サーバのミリ秒で表される現在の時間を返します。

戻り値:
ミリ秒で測定した、現在時刻と UTC 1970 年 1 月 1 日午前 0 時との差
例外:
IOException - 入出力エラーが発生した場合
関連項目:
System.currentTimeMillis()

totalMemory

public long totalMemory()
                 throws IOException
サーバプロセスの Java Virtual Machine のメモリの総容量を返します。

戻り値:
現在および将来のオブジェクトに利用可能なメモリの総容量 (バイト単位)
例外:
IOException - 入出力エラーが発生した場合
関連項目:
Runtime.totalMemory()

freeMemory

public long freeMemory()
                throws IOException
サーバシステムの空きメモリの量を返します。

戻り値:
将来のオブジェクトに利用可能なメモリの推定総容量 (バイト単位)
例外:
IOException - 入出力エラーが発生した場合
関連項目:
Runtime.freeMemory()

close

public void close()
           throws IOException
ネットワークを切断します。

切断されるネットワークコネクションは、このメソッドを実行した時に、 このメソッド内でこのオブジェクトの connection() メソッドから 取得したコネクションに関してのみです。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.client
インタフェース
ActionListener
クラス
NetworkAgent
NetworkConnector


jp.co.intra_mart.foundation.service.client (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client

このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。

参照:
説明

インタフェースの概要
ActionListener このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。

クラスの概要
NetworkAgent | このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector | このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

パッケージ jp.co.intra_mart.foundation.service.client の説明

このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
それぞれのサーバの持つ機能を利用するための具体的なＡＰＩに関しては、 サブパッケージを参照してください。

関連項目:
jp.co.intra_mart.foundation.service.client.batch, jp.co.intra_mart.foundation.service.client.file, jp.co.intra_mart.foundation.service.client.information
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.client クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.service.client.ActionListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.client の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client の使用

jp.co.intra_mart.foundation.service.client を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.batch により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.service.client のクラス
ActionListener
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
NetworkAgent
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.service.client のクラス
NetworkConnector
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
protected abstract  void FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain)
イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用

HTTPActionEvent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEvent の使用

HTTPActionEvent を実装している jp.co.intra_mart.foundation.service.provider.application のクラス
 class FilterHTTPActionEvent
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用

HTTPActionEventClientContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventClientContext の使用

HTTPActionEventClientContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventClientContext HTTPActionEventContext.getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用

HTTPActionEventContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventContext の使用

HTTPActionEventContext 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
void | HTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
void | FilterHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用

HTTPActionEventException を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventException の使用

HTTPActionEventException をスローする jp.co.intra_mart.foundation.service.provider.application のメソッド
 long HTTPActionEventContext.getRequestTime()
イベントの実行を要求した時刻を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventListenerContext HTTPActionEventContext.getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


FilterHTTPActionEvent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
クラス FilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public abstract class FilterHTTPActionEvent
extends Object
implements HTTPActionEvent

Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
実際のイベントをフィルタリングしてラップする場合に利用します。

フィルターイベントを作成する場合は、この抽象実装をスーパークラスとして サブクラスを作成します。 その際、引数を１つも持たない public なコンストラクタを持つ必要があります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected FilterHTTPActionEvent()
指定のイベントをラップするためのフィルターを作成します。
メソッドの概要
void | action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FilterHTTPActionEvent

protected FilterHTTPActionEvent()
指定のイベントをラップするためのフィルターを作成します。

メソッドの詳細

action

public final void action(HTTPActionEventContext context,
                         HttpServletRequest request,
                         HttpServletResponse response)
                  throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

このメソッドは、リクエストを適切に処理した後に、 doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) を呼び出します。 サブクラスは、doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) をオーバーライドして、 フィルタとして処理したい内容を実装してください。

定義:
インタフェース HTTPActionEvent 内の action
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー

doFilter

protected abstract void doFilter(HTTPActionEventContext context,
                                 HttpServletRequest request,
                                 HttpServletResponse response,
                                 FilterHTTPActionEventChain chain)
                          throws ServletException
イベントのフィルタ処理です。

パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
chain - チェーン内の次のエンティティ
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FilterHTTPActionEventChain (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース FilterHTTPActionEventChain

public interface FilterHTTPActionEventChain

FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
FilterHTTPActionEvent は、チェーン内の次のフィルタを呼び出す時、 あるいは FilterHTTPActionEvent がチェーン内の最後のフィルタの場合は イベント(HTTPActionEvent)を呼び出す時に、 FilterHTTPActionEventChain を利用します。

導入されたバージョン:
version 4.3

メソッドの概要
void | doChain() チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
void | doChain(HttpServletRequest request, HttpServletResponse response) チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
HttpServletRequest | getRequest() チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
HttpServletResponse | getResponse() チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。

メソッドの詳細

getRequest

public HttpServletRequest getRequest()
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。

戻り値:
リクエスト

doChain

public void doChain()
             throws ServletException
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
このメソッドの呼び出しは、以下の呼び出しと同様です。

doChain(getRequest(), getResponse())

例外:
ServletException - 実行時エラー

doChain

public void doChain(HttpServletRequest request,
                    HttpServletResponse response)
             throws ServletException
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。

パラメータ:
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEvent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEvent

既知の実装クラスの一覧:
FilterHTTPActionEvent
public interface HTTPActionEvent

Application Runtime で実行されるイベントのためのインターフェースです。
このインターフェースを実装したクラスは、 Application Runtime でインスタンス化されます。 したがって、通常は WEB-INF 内にクラスを配置する事になります。

また、イベントはイベントリスナーにより引数を持たないコンストラクタを 利用してインスタンス化されます。 したがって、このインターフェースを実装するクラスは、 引数を持たない public なコンストラクタが必要になります。

導入されたバージョン:
version 4.3

メソッドの概要
 void action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response)
イベント処理メソッドです。

メソッドの詳細

action

public void action(HTTPActionEventContext context,
                   HttpServletRequest request,
                   HttpServletResponse response)
            throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventClientContext (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventClientContext

public interface HTTPActionEventClientContext

Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
String | getRemoteHostAddress() イベント実行要求をしたクライアントのアドレスを返します。
String | getRemoteHostName() イベント実行要求をしたクライアントのホスト名を返します。
String | getSystemProperty(String name) クライアントの Java 実行環境のシステムプロパティの値を返します。
Set | getSystemPropertyNameSet() クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。

メソッドの詳細

getRemoteHostAddress

public String getRemoteHostAddress()
イベント実行要求をしたクライアントのアドレスを返します。

戻り値:
アドレスを表す文字列

getRemoteHostName

public String getRemoteHostName()
イベント実行要求をしたクライアントのホスト名を返します。

戻り値:
ホスト名

getSystemProperty

public String getSystemProperty(String name)
クライアントの Java 実行環境のシステムプロパティの値を返します。

パラメータ:
name - プロパティ名
戻り値:
プロパティ名に対する値。指定のプロパティ名に関する定義値が見つからない場合は null。

getSystemPropertyNameSet

public Set getSystemPropertyNameSet()
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。 セットの各要素はプロパティ名を表す java.lang.String 型の値です。

戻り値:
プロパティ名のセット
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventContext (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventContext

public interface HTTPActionEventContext

Application Runtime で実行されるイベントに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
long | getAcceptTime() イベント実行要求を受け付けたおよその時刻を返します。
String | getCharacterEncoding() リクエストパラメータの文字エンコーディングを返します。
HTTPActionEventClientContext | getClientContext() イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
HttpServletRequest | getHttpServletRequest() 現在のイベントを要求したリクエストを返します。
HTTPActionEventListenerContext | getListenerContext() イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
long | getRequestTime() イベントの実行を要求した時刻を返します。

メソッドの詳細

getAcceptTime

public long getAcceptTime()
イベント実行要求を受け付けたおよその時刻を返します。
Servlet コンテナによって、リスナーとなっている Servlet が実行される 以前に javax.servlet.Filter 等が実行されたりします。 したがって、このメソッドの返す値はサーバがリクエストを受け付けた時刻と 一致するとは限りません。

返す時刻の単位はミリ秒で、java.lang.System#currentTimeMillis() の仕様に 準じます。

戻り値:
時刻を表すミリ秒

getCharacterEncoding

public String getCharacterEncoding()
リクエストパラメータの文字エンコーディングを返します。

戻り値:
文字エンコーディング名

getRequestTime

public long getRequestTime()
                    throws HTTPActionEventException
イベントの実行を要求した時刻を返します。 このメソッドの返す時刻は、 1970/1/1 を基準から現在までのミリ秒です。

戻り値:
1970/1/1 を基準から現在までのミリ秒
例外:
HTTPActionEventException - 要求時刻が不明な場合

getHttpServletRequest

public HttpServletRequest getHttpServletRequest()
現在のイベントを要求したリクエストを返します。

戻り値:
リクエスト

getClientContext

public HTTPActionEventClientContext getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

戻り値:
クライアント情報オブジェクト

getListenerContext

public HTTPActionEventListenerContext getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

戻り値:
リスナー情報オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
クラス HTTPActionEventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
すべての実装インタフェース:
Serializable
public class HTTPActionEventException
extends Exception

HTTPActionEvent に関するエラーを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventException

public HTTPActionEventException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventException

public HTTPActionEventException(String msg,
                                Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventListenerContext (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventListenerContext

public interface HTTPActionEventListenerContext

Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Class | getListenerClass() リスナーとなっている Servlet の実行時クラスを返します。
ServletConfig | getServletConfig() イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。

メソッドの詳細

getServletConfig

public ServletConfig getServletConfig()
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。

戻り値:
Servlet 設定情報を含んでいる ServletConfig オブジェクト

getListenerClass

public Class getListenerClass()
リスナーとなっている Servlet の実行時クラスを返します。

戻り値:
java.lang.Class 型オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.provider.application (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.provider.application
インタフェース
FilterHTTPActionEventChain
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContext
HTTPActionEventListenerContext
クラス
FilterHTTPActionEvent
例外
HTTPActionEventException


jp.co.intra_mart.foundation.service.provider.application (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

参照:
説明

インタフェースの概要
FilterHTTPActionEventChain | FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent | Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext | Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext | Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventListenerContext | Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

クラスの概要
FilterHTTPActionEvent Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

例外の概要
HTTPActionEventException HTTPActionEvent に関するエラーを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.provider.application の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

導入されたバージョン:
version 4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.provider.application クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.provider.application の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.application の使用

jp.co.intra_mart.foundation.service.provider.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application により使用される jp.co.intra_mart.foundation.service.provider.application のクラス
FilterHTTPActionEventChain
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventException
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventListenerContext
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory の使用

jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent の使用

ProcedureComponent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.batch このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.provider.batch での ProcedureComponent の使用

ProcedureComponent を実装している jp.co.intra_mart.foundation.service.provider.batch のクラス
 class PermanentDataArchiveFactory
推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.batch (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.provider.batch
インタフェース
ProcedureComponent
クラス
PermanentDataArchiveFactory


jp.co.intra_mart.foundation.service.provider.batch (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.batch

このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

参照:
説明

インタフェースの概要
ProcedureComponent スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

クラスの概要
PermanentDataArchiveFactory 推奨されていません。

パッケージ jp.co.intra_mart.foundation.service.provider.batch の説明

このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
このパッケージに含まれるクラスは、現在動作しているApplication Runtimeプロセス環境において実行されます。また、バッチプログラムを作成する場合に必要なインターフェースを提供しています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.provider.batch クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.batch の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory (implements jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent)

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.provider.batch の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.batch の使用

jp.co.intra_mart.foundation.service.provider.batch を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.batch このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.provider.batch により使用される jp.co.intra_mart.foundation.service.provider.batch のクラス
ProcedureComponent
スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PermanentDataArchiveFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.batch
クラス PermanentDataArchiveFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory
すべての実装インタフェース:
ProcedureComponent

public class PermanentDataArchiveFactory
extends Object
implements ProcedureComponent

Permanent-data Service に保存されている永続データをバックアップするための バッチプログラムです。
このクラスをバッチプログラムとして登録することで、 定期的にデータをバックアップすることができます。

なお、このバッチプログラムは、マルチログイングループ環境を サポートしておりません。 バッチとして実行されると、すべてのデータをバックアップします。 したがって、複数のログイングループでバッチ設定をしても ログイングループ単位でのデータバックアップ等を行うことはできません。

導入されたバージョン:
Version 4.2

コンストラクタの概要
PermanentDataArchiveFactory()
推奨されていません。 バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。
メソッドの概要
 void execute(Properties arg)
推奨されていません。 インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 action() メソッドをバッチプログラムとして実行します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentDataArchiveFactory

public PermanentDataArchiveFactory()
推奨されていません。
バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。

メソッドの詳細

execute

public void execute(Properties arg)
             throws RuntimeException,
                    Error
推奨されていません。
インタフェース ProcedureComponent の記述:
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 action() メソッドをバッチプログラムとして実行します。

バッチとして動作するロジック。

バッチ起動引数は、バッチの設定がバッチ設定画面で登録されている場合、 以下のような項目を持ちます。

group | バッチ設定グループ名（通常はログイングループＩＤ） | String
name | バッチ名称 | String

定義:
インタフェース ProcedureComponent 内の execute
パラメータ:
arg - バッチ起動引数
例外:
Error - 致命的なエラー
RuntimeException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ProcedureComponent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.batch
インタフェース ProcedureComponent

既知の実装クラスの一覧:
PermanentDataArchiveFactory
public interface ProcedureComponent

スケジュール実行されるバッチプログラムのためのインターフェースを定義します。

このインターフェースを継承するクラスでは、Application Runtime により呼び出された際のバッチ処理を実装して下さい。 また、実装クラスはパラメータを持たない public 宣言されたコンストラクタを 定義しておく必要があります。 バッチサーバは、このゼロパラメータ・コンストラクタを 利用して実装クラスをインスタンス化して action() メソッドを実行します。

    public class MyBatch implements ProcedureComponent{

        // バッチサーバにインスタンス化されるためのコンストラクタ

        public MyBatch(){

            super();

        }

        public void execute(Properties arg) throws java.lang.RuntimeException, java.lang.Error{

            // バッチのロジック

            System.out.println("Hello. my batch program !");
        }

    }

バッチプログラムを作成したら、コンパイルをしてクラスファイルを作成します。
できあがったクラスファイルをApplication Runtimeが実行可能な環境（ クラスパスの設定されているディレクトリ内）に保存して下さい。 なお、Application Runtime は Webアプリケーションとして動作していますので、 クラスファイルの保存場所には十分注意してください。

バッチ設定画面で MyBatch クラスを登録することで設定した時刻に execute() メソッドがApplication Runtimeにより実行されます。
上記プログラムでは、コンソール画面に「Hello. my batch program !」と 表示されます。

メソッドの概要
 void execute(Properties arg)
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 action() メソッドをバッチプログラムとして実行します。

メソッドの詳細

execute

public void execute(Properties arg)
             throws RuntimeException,
                    Error
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 action() メソッドをバッチプログラムとして実行します。

バッチとして動作するロジック。

バッチ起動引数は、バッチの設定がバッチ設定画面で登録されている場合、 以下のような項目を持ちます。

group | バッチ設定グループ名（通常はログイングループＩＤ） | String
name | バッチ名称 | String

パラメータ:
arg - バッチ起動引数
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.service.provider.Environment の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.Environment の使用

Environment を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での Environment の使用

Environment を返す jp.co.intra_mart.foundation.service.provider のメソッド
static Environment Platform.getEnvironment()
システムの設定値を持つオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.GarbageController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.GarbageController の使用

jp.co.intra_mart.foundation.service.provider.GarbageController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.GCConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.GCConditioner の使用

GCConditioner を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での GCConditioner の使用

GCConditioner 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider のメソッド
static void | GarbageController.addConditioner(GCConditioner conditioner) 推奨されていません。
static void | GarbageController.removeConditioner(GCConditioner conditioner) 推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.HomeDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.HomeDirectory の使用

HomeDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での HomeDirectory の使用

HomeDirectory を返す jp.co.intra_mart.foundation.service.provider のメソッド
static HomeDirectory HomeDirectory.instance()
ホームディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.Platform の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.Platform の使用

jp.co.intra_mart.foundation.service.provider.Platform はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.SystemErrorReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.SystemErrorReporter の使用

SystemErrorReporter を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での SystemErrorReporter の使用

SystemErrorReporter として宣言されている jp.co.intra_mart.foundation.service.provider のフィールド
static SystemErrorReporter Platform.err
エラーログに対するメッセージ出力ストリームです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.SystemReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.SystemReporter の使用

SystemReporter を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での SystemReporter の使用

jp.co.intra_mart.foundation.service.provider での SystemReporter のサブインタフェース
 interface SystemErrorReporter
エラーログ出力用のインターフェースです。

SystemReporter として宣言されている jp.co.intra_mart.foundation.service.provider のフィールド
static SystemReporter Platform.out
システムログに対するメッセージ出力ストリームです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の使用

TemporaryDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider での TemporaryDirectory の使用

TemporaryDirectory を返す jp.co.intra_mart.foundation.service.provider のメソッド
static TemporaryDirectory TemporaryDirectory.instance()
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.TemporaryFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.TemporaryFile の使用

jp.co.intra_mart.foundation.service.provider.TemporaryFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の使用

StorageDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.file このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

jp.co.intra_mart.foundation.service.provider.file での StorageDirectory の使用

StorageDirectory を返す jp.co.intra_mart.foundation.service.provider.file のメソッド
static StorageDirectory StorageDirectory.instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.file (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.provider.file
クラス
StorageDirectory


jp.co.intra_mart.foundation.service.provider.file (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.file

このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

参照:
説明

クラスの概要
StorageDirectory Storage Service の基準ディレクトリを表すクラスです。

パッケージ jp.co.intra_mart.foundation.service.provider.file の説明

このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.provider.file クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.provider.file の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.file の使用

jp.co.intra_mart.foundation.service.provider.file を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.file このパッケージには、Storage Service 環境内で利用可能な機能を提供します。

jp.co.intra_mart.foundation.service.provider.file により使用される jp.co.intra_mart.foundation.service.provider.file のクラス
StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StorageDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.file
クラス StorageDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.file.StorageDirectory
すべての実装インタフェース:
Comparable, Serializable
public class StorageDirectory
extends ExtendedDirectory

Storage Service の基準ディレクトリを表すクラスです。

Storage Service は、このクラスが表すパスを基準ディレクトリとして、 各コンテンツのファイルパスを解決します。 標準では、サーバインストールディレクトリの storage ディレクトリが 基準ディレクトリとなります。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static StorageDirectory instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static StorageDirectory instance()
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。

戻り値:
File クラスのインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の使用

PermanentDataDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.information このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

jp.co.intra_mart.foundation.service.provider.information での PermanentDataDirectory の使用

PermanentDataDirectory を返す jp.co.intra_mart.foundation.service.provider.information のメソッド
static PermanentDataDirectory PermanentDataDirectory.instance()
データ保存ディレクトリを表すオブジェクトを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.information (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.provider.information
クラス
PermanentDataDirectory


jp.co.intra_mart.foundation.service.provider.information (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.information

このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

参照:
説明

クラスの概要
PermanentDataDirectory Permanent-data を保存するディレクトリを表すオブジェクトです。

パッケージ jp.co.intra_mart.foundation.service.provider.information の説明

このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。 このパッケージに含まれるクラスは、特定の実行環境内でのみ利用可能であり、クラスと各種サービスが密接に関わりあっています。したがって、このパッケージのクラスを利用する場合は、プログラムの実行環境に関して十分に注意をしてください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.provider.information クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.information の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.provider.information の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.information の使用

jp.co.intra_mart.foundation.service.provider.information を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.information このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。

jp.co.intra_mart.foundation.service.provider.information により使用される jp.co.intra_mart.foundation.service.provider.information のクラス
PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PermanentDataDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.information
クラス PermanentDataDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory
すべての実装インタフェース:
Comparable, Serializable
public class PermanentDataDirectory
extends ExtendedDirectory

Permanent-data を保存するディレクトリを表すオブジェクトです。 このオブジェクトが表すパスにデータファイルが作成されます。

導入されたバージョン:
Version 4.2
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
void | backup(File f) このデータを指定のファイルにバックアップします。
ExtendedDirectory | entityDirectory() データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
static PermanentDataDirectory | instance() データ保存ディレクトリを表すオブジェクトを取得します。
ExtendedDirectory | temporaryDirectory() 削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static PermanentDataDirectory instance()
データ保存ディレクトリを表すオブジェクトを取得します。

戻り値:
File クラスのインスタンス

entityDirectory

public ExtendedDirectory entityDirectory()
データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。

戻り値:
ディレクトリを表すオブジェクト

temporaryDirectory

public ExtendedDirectory temporaryDirectory()
削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。

このディレクトリには、データを更新する直前のデータファイルが 保存されます。

戻り値:
ディレクトリを表すオブジェクト

backup

public void backup(File f)
            throws IOException
このデータを指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Environment (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース Environment

public interface Environment

このクラスは、 システムプロパティへアクセスするためのインターフェースです。

システムプロパティとは、サーバが動作するために必要な環境設定値のことです。 このクラスでアクセスできるプロパティは、Java-VM の持つシステムプロパティ とは異なります。Java-VM のシステムプロパティ値を取得する場合は、 java.lang.System クラスを利用して下さい。
このシステムプロパティのセットには、必ず以下のキーに対応する値が 含まれています。

キー | 対応する値の説明
system/server-charset | サーバが外部(ファイルなど)にアクセスする際に標準で利用する文字エンコーディング名
system/root | サーバのインストールディレクトリ

導入されたバージョン:
version4.0
関連項目:
System,
System.getProperty(String),
System.getProperty(String key, String),
System.getProperties()

メソッドの概要
String | getProperty(String key) 指定されたキーによって示されるシステムプロパティを取得します。
String | getProperty(String key, String defaultValue) 指定されたキーによって示されるシステムプロパティを取得します。
Enumeration | propertyNames() システムプロパティリストにあるすべてのキーのリストを返します。

メソッドの詳細

getProperty

public String getProperty(String key)
指定されたキーによって示されるシステムプロパティを取得します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

パラメータ:
key - システムプロパティの名前
戻り値:
システムプロパティの文字列値。そのキーにプロパティがない場合は null。
導入されたバージョン:
version4.0

getProperty

public String getProperty(String key,
                          String defaultValue)
指定されたキーによって示されるシステムプロパティを取得します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

パラメータ:
key - システムプロパティの名前
defaultValue - デフォルト値
戻り値:
システムプロパティの文字列値。そのキーにプロパティがない場合はデフォルト値。
導入されたバージョン:
version4.0

propertyNames

public Enumeration propertyNames()
システムプロパティリストにあるすべてのキーのリストを返します。 Enumeration から取得できる各要素は、すべて String クラスのインスタンス になります。

戻り値:
プロパティリストにあるすべてのキーのリスト。
導入されたバージョン:
version4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GarbageController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス GarbageController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.GarbageController
public class GarbageController
extends Object

ガーベージコレクタを実行するクラスです。

このクラスにリスナーを登録しておくことにより、 gc メソッドが呼び出された時に任意のロジックを実行させることができます。 この機能を利用することにより、ガーベージコレクタ実行前に キャッシュデータなどを削除して、効率的にメモリ空間を開放することができます。

導入されたバージョン:
Version 3.2

メソッドの概要
static void | addConditioner(GCConditioner conditioner) 推奨されていません。
static void | addListener(EventListener listener) リスナーを登録します。
static void | clean() システムのガベージコレクタを実行します。
static void | removeConditioner(GCConditioner conditioner) 推奨されていません。
static boolean | removeListener(EventListener listener) 指定されたリスナーを削除します。
static void | startAutomaticExecution(long millis) 推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
static void | stopAutomaticExecution() 推奨されていません。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

addListener

public static void addListener(EventListener listener)
                        throws NullPointerException
リスナーを登録します。
clean メソッドが呼び出された時に、登録されているすべてのリスナーの handleEvent メソッドを呼び出します。 リスナーの実行順は、保証されません。
このメソッドは、listener が既に登録済みの場合は何もしません。

例外:
NullPointerException - listener が null の場合
関連項目:
clean(), EventListener.handleEvent()

removeListener

public static boolean removeListener(EventListener listener)
指定されたリスナーを削除します。

戻り値:
指定されたリスナーを格納していた場合 true

startAutomaticExecution

public static void startAutomaticExecution(long millis)
推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。

gc の自動実行を行うモードを開始します。

この機能は、新しい専用のスレッドで millis ミリ秒おきに addConditioner メソッドで登録されたコンディショナオブジェクトを 実行して gc 実行の必要があると判断された場合に clean メソッドを実行します。 この自動実行スレッドは、stopAutomaticExecution メソッドが 呼び出されるまで上記処理を継続実行します。

gc 実行をするかどうかの判定をするためのコンディショナオブジェクトが 一つも登録されていない場合、このメソッドは何も行いません。
gc 自動実行モードが有効な状態でも、clean メソッドを呼び出すことによって 明示的に gc を実行することができます。

パラメータ:
millis - gc 自動実行のための監視間隔

stopAutomaticExecution

public static void stopAutomaticExecution()
推奨されていません。

gc 自動実行モードを終了します。

addConditioner

public static void addConditioner(GCConditioner conditioner)
推奨されていません。

gc 自動実行において gc を実行するかどうかを判断するための コンディショナを登録します。

パラメータ:
conditioner - コンディショナ
例外:
NullPointerException - conditioner が null の場合

removeConditioner

public static void removeConditioner(GCConditioner conditioner)
推奨されていません。

コンディショナを削除します。

パラメータ:
conditioner - コンディショナ

clean

public static void clean()
システムのガベージコレクタを実行します。

このメソッドは、addListener メソッドで登録された全てのイベントリスナーを 呼び出した後に、ＶＭのガーベージコレクタを実行します。
ガーベージコレクタの実行は、以下の呼出とおなじです。

System.gc()

このメソッドは、複数のスレッドからの多重処理を行いません。 あるスレッドによる実行中に他のスレッドでこのメソッドが呼び出された場合、 このメソッドは何もせずにリターンします。

関連項目:
System.gc()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GCConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース GCConditioner

public interface GCConditioner

GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
GarbageController クラスは、startAutomaticExecution メソッドにより 自動実行されている場合、gc を実行するかどうか判断するために このインターフェースのサブクラスを呼び出します。 GarbageController クラスに登録されている GCConditioner のサブクラスのうち、 １つ以上のオブジェクトの cleanUp メソッドが true を返した場合、 GarbageController クラスは gc を実行します。

関連項目:
GarbageController

メソッドの概要
 boolean cleanUp()
gc を実行するかどうかを判断します。

メソッドの詳細

cleanUp

public boolean cleanUp()
gc を実行するかどうかを判断します。
このメソッドは、GarbageController クラスの自動実行プログラムにより gc を実行する前に呼び出されます。

戻り値:
gc を実行させたい場合 true
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HomeDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス HomeDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.HomeDirectory
すべての実装インタフェース:
Comparable, Serializable
public class HomeDirectory
extends ExtendedDirectory

このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static void | definePath(String path) 推奨されていません。
static String | findPath() システムのホームディレクトリを返します。
static HomeDirectory | instance() ホームディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

instance

public static HomeDirectory instance()
ホームディレクトリを表すオブジェクトを取得します。

戻り値:
ホームディレクトリを表す File クラスのインスタンス

definePath

public static void definePath(String path)
推奨されていません。

システムのホームディレクトリを設定します。 ホームディレクトリは、インストールディレクトリと同義です。

このメソッドは、システム全体を不安定にしてしまう危険性があるため、 通常は使用してはいけません。

パラメータ:
path - ホームディレクトリを表すパス名
例外:
NullPointerException - 引数が null の場合

findPath

public static String findPath()
システムのホームディレクトリを返します。 ホームディレクトリは、インストールディレクトリと同義です。

通常は、インストールされた環境と設定値から自動的にホームディレクトリが 決定されます。例外として、definePath() メソッドを使用して 意図的にホームディレクトリの情報を書き換えてしまった場合は、 書き換えられたパス情報が返されます。

戻り値:
ホームディレクトリを表すパス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.provider (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.service.provider
インタフェース
Environment
GCConditioner
SystemErrorReporter
SystemReporter
クラス
GarbageController
HomeDirectory
Platform
TemporaryDirectory
TemporaryFile


jp.co.intra_mart.foundation.service.provider (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider

このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

参照:
説明

インタフェースの概要
Environment | このクラスは、 システムプロパティへアクセスするためのインターフェースです。
GCConditioner | GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
SystemErrorReporter | エラーログ出力用のインターフェースです。
SystemReporter | システムログの共通インターフェースです。

クラスの概要
GarbageController | ガーベージコレクタを実行するクラスです。
HomeDirectory | このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
Platform | Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。
TemporaryDirectory | このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。
TemporaryFile | このクラスは、一時ファイルに関する機能を提供します。

パッケージ jp.co.intra_mart.foundation.service.provider の説明

このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
このパッケージまたはサブパッケージに含まれるクラスは、現在動作しているサーバプロセス環境において実行されます。他のサーバプロセスに対してリモートアクセスするためには、jp.co.intra_mart.foundation.service.client パッケージおよびそのサブパッケージに含まれるクラスを利用して下さい。

関連項目:
jp.co.intra_mart.foundation.service.client
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.service.provider クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.HomeDirectory
          • class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile
        • class jp.co.intra_mart.foundation.service.provider.TemporaryFile
    • class jp.co.intra_mart.foundation.service.provider.GarbageController
    • class jp.co.intra_mart.foundation.service.provider.Platform

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.Environment
  • interface jp.co.intra_mart.foundation.service.provider.GCConditioner
  • interface jp.co.intra_mart.foundation.service.provider.SystemReporter
    • interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.service.provider の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider の使用

jp.co.intra_mart.foundation.service.provider を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.service.provider のクラス
Environment
このクラスは、 システムプロパティへアクセスするためのインターフェースです。
GCConditioner
GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
HomeDirectory
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
SystemErrorReporter
エラーログ出力用のインターフェースです。
SystemReporter
システムログの共通インターフェースです。
TemporaryDirectory
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Platform (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス Platform

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.Platform
public final class Platform
extends Object

Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。 インスタンスを生成することはできません。

導入されたバージョン:
version 4.2

フィールドの概要
static SystemErrorReporter | err エラーログに対するメッセージ出力ストリームです。
static SystemReporter | out システムログに対するメッセージ出力ストリームです。
メソッドの概要
static Environment | getEnvironment() システムの設定値を持つオブジェクトを取得します。
static String | getEnvironmentProperty(String key) 指定のキーに対応するシステムの設定値を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

public static SystemReporter out
システムログに対するメッセージ出力ストリームです。 この出力に対して書き込まれたメッセージは、 システムログの設定に指定された出力先に書き出されます。

err

public static SystemErrorReporter err
エラーログに対するメッセージ出力ストリームです。 この出力に対して書き込まれたメッセージは、 エラーログの設定に指定された出力先に書き出されます。

メソッドの詳細

getEnvironmentProperty

public static String getEnvironmentProperty(String key)
指定のキーに対応するシステムの設定値を取得します。 このメソッドは該当するキーが存在しない場合 null を返します。

このメソッドの呼び出しは、以下の呼び出しと同じです。
Platform.getEnvironment().getProperty(key)

パラメータ:
key - 設定値へのキー名
戻り値:
キーに対応する設定値

getEnvironment

public static Environment getEnvironment()
システムの設定値を持つオブジェクトを取得します。 このメソッドにより返される設定値オブジェクトの状態は、 設定ファイル(conf/imart.xml)の状態に影響されます。

戻り値:
設定値オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemErrorReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース SystemErrorReporter

すべてのスーパーインタフェース:
SystemReporter
public interface SystemErrorReporter
extends SystemReporter

エラーログ出力用のインターフェースです。

メソッドの概要
 void write(String message, Throwable t)
メッセージをログに書き込みます。
インタフェース jp.co.intra_mart.foundation.service.provider.SystemReporter から継承したメソッド
flush, write

メソッドの詳細

write

public void write(String message,
                  Throwable t)
メッセージをログに書き込みます。 例外は、個別にファイル出力されます。

パラメータ:
message - ログに書き込むエラーメッセージ
t - 発生した例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
インタフェース SystemReporter

既知のサブインタフェースの一覧:
SystemErrorReporter
public interface SystemReporter

システムログの共通インターフェースです。

メソッドの概要
void | flush() ストリームをフラッシュします。
void | write(String message) メッセージをログに書き込みます。

メソッドの詳細

write

public void write(String message)
メッセージをログに書き込みます。

パラメータ:
message - ログに書き込むメッセージ

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TemporaryDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス TemporaryDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
                拡張 jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
すべての実装インタフェース:
Comparable, Serializable
public class TemporaryDirectory
extends ExtendedDirectory

このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

アプリケーション実行時に利用する一時ファイルを保存するための ディレクトリとして利用することができます。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
メソッドの概要
static File | getSystemTemporaryDirectory() システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
static TemporaryDirectory | instance() 一時ファイル保存用ディレクトリを表すオブジェクトを取得します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory から継承したメソッド
archive, archive, archive, archive, archive, archive, childDirectory, childFile, childPath, findDirectory, findFile, findPath, reset
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

メソッドの詳細

getSystemTemporaryDirectory

public static File getSystemTemporaryDirectory()
システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
このメソッドが返すディレクトリに対してサブディレクトリや ファイルを作成すると、システムが不安定になる可能性があります。 ユーザプログラムで一時ファイルを利用する場合は、 instance() メソッドにて得られるパスに 作成するようにしてください。

戻り値:
一時ファイル保存用ディレクトリを表す File クラスのインスタンス

instance

public static TemporaryDirectory instance()
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。

戻り値:
一時ファイル保存用ディレクトリを表す File クラスのインスタンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TemporaryFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider
クラス TemporaryFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.ExtendedFile
            拡張 jp.co.intra_mart.foundation.service.provider.TemporaryFile
すべての実装インタフェース:
Comparable, Serializable
public class TemporaryFile
extends ExtendedFile

このクラスは、一時ファイルに関する機能を提供します。

アプリケーション実行時に一時的にデータを保存するための ファイルとして利用することができます。
このクラスは、インスタンス化されるたびに、新しいファイルのパスを 作成します。そのパスは、インスタンス化の時点ではディスク上に ファイルとして存在していません。

このクラスは、インスタンス化のたびに新しいファイルのパスを作成するため、 作成したファイルを削除しない場合、ディスク上に不要ファイルとして 残りつづけてしまう可能性がありますので、使用の際には十分に注意してください。

導入されたバージョン:
version 4.2
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
TemporaryFile()
一時ファイルのパスを作成します。
クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile から継承したメソッド
append, append, append, getBytes, readLines, readLines, readString, readString, write, write, write
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TemporaryFile

public TemporaryFile()
一時ファイルのパスを作成します。 このコンストラクタを呼び出した時点では、ファイルとして 存在していないため、インスタンス化の後に新規ファイルとして 作成する必要があります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.smtp.Mail の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.smtp.Mail の使用

jp.co.intra_mart.foundation.smtp.Mail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Mail (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.smtp
クラス Mail

java.lang.Object
    拡張 jp.co.intra_mart.system.mail.smtp.InetMail
        拡張 jp.co.intra_mart.foundation.smtp.Mail
すべての実装インタフェース:
jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, Serializable
推奨されていません。 MailSenderに置き換えられました。

public class Mail
extends jp.co.intra_mart.system.mail.smtp.InetMail
implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, Serializable

SMTPサーバに対し、メールを送信します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.system.mail.smtp.InetMail から継承したフィールド
MAILER_NAME
インタフェース jp.co.intra_mart.system.javascript.imapi.MailSendErrDef から継承したフィールド
ERR_MAIL_CONFIG, ERR_MAIL_CONNECT, ERR_MAIL_FROM, ERR_MAIL_SERVER, ERR_MAIL_TO, ERR_UNEXPECTED, MAIL_SENDED
コンストラクタの概要
Mail()
推奨されていません。 メール送信オブジェクトの生成。
Mail(String server)
推奨されていません。 メール送信オブジェクトの生成。
Mail(String server, int port)
推奨されていません。 メール送信オブジェクトの生成。
メソッドの概要
void | attachFile(String fName, String b64Body) 推奨されていません。 添付ファイルの内容をセットする。
int | getErrCode() 推奨されていません。 メール送信時のエラーコードを返す。
String | getErrMessage() 推奨されていません。 メール送信時のエラーメッセージを返す。
boolean | send() 推奨されていません。 指定されたSMTPサーバへメールを送信する。
boolean | setBcc(String bcc) 推奨されていません。 Bccをセットする。
boolean | setBcc(String bcc, String alias) 推奨されていません。 Bccをセットする。
boolean | setBody(String body) 推奨されていません。 本文をセットする。
boolean | setCc(String cc) 推奨されていません。 Ccをセットする。
boolean | setCc(String cc, String alias) 推奨されていません。 Ccをセットする。
boolean | setFrom(String from) 推奨されていません。 Fromをセットする。
boolean | setFrom(String from, String alias) 推奨されていません。 Fromをセットする。
boolean | setHeader(String key, String value) 推奨されていません。 メールヘッダを設定する。
boolean | setReplyTo(String replyto) 推奨されていません。 リプライをセットする。
boolean | setReplyTo(String replyto, String alias) 推奨されていません。 リプライをセットする。
boolean | setSubject(String subject) 推奨されていません。 タイトルをセットする。
boolean | setTo(String to) 推奨されていません。 To(宛先)をセットする。
boolean | setTo(String to, String alias) 推奨されていません。 To(宛先)をセットする。
クラス jp.co.intra_mart.system.mail.smtp.InetMail から継承したメソッド
addBcc, addCc, addFile, addReplyTo, addTo, getBody, getHead, removeBcc, removeCc, removeReplyTo, removeTo, sendMail, setAnyHeader, setMailerName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Mail

public Mail(String server,
            int port)
推奨されていません。
メール送信オブジェクトの生成。

パラメータ:
server - SMTPサーバアドレス

Mail

public Mail(String server)
推奨されていません。
メール送信オブジェクトの生成。

パラメータ:
server - SMTPサーバアドレス
ポート番号は 25 を使用します。

Mail

public Mail()
推奨されていません。
メール送信オブジェクトの生成。 SMTPサーバは conf/imart.confで設定されたサーバ を使用します。

メソッドの詳細

getErrMessage

public String getErrMessage()
推奨されていません。
メール送信時のエラーメッセージを返す。

戻り値:
エラーメッセージ

getErrCode

public int getErrCode()
推奨されていません。
メール送信時のエラーコードを返す。

戻り値:
エラーコード

attachFile

public void attachFile(String fName,
                       String b64Body)
                throws UnsupportedEncodingException,
                       IOException
推奨されていません。
添付ファイルの内容をセットする。

パラメータ:
fName - ファイル名
b64Body - BASE64エンコードされたファイルの内容
戻り値:
成功 true/失敗 false
例外:
UnsupportedEncodingException,IOException
UnsupportedEncodingException
IOException

setHeader

public boolean setHeader(String key,
                         String value)
推奨されていません。
メールヘッダを設定する。

送信するメールヘッダ情報を設定する。 設定可能なメールヘッダの種類は以下の通り。
Sender : 送った人のメールアドレス
Reply-To: 返信先メールアドレス
(その他にも任意にヘッダ情報を追加できますが、任意のヘッダを追加した場合の動作は 未検証です。)

パラメータ:
key - 設定するメールヘッダの種類
value - メールヘッダへの情報
戻り値:
成功 true/失敗 false

setBody

public boolean setBody(String body)
推奨されていません。
本文をセットする。

パラメータ:
body - 本文文字列
戻り値:
成功 true/失敗 false

setFrom

public boolean setFrom(String from,
                       String alias)
推奨されていません。
Fromをセットする。

パラメータ:
from - 送信者アドレス
alias - 送信者ニックネーム
戻り値:
成功 true/失敗 false

setFrom

public boolean setFrom(String from)
推奨されていません。
Fromをセットする。

パラメータ:
from - 送信者アドレス
戻り値:
成功 true/失敗 false

setSubject

public boolean setSubject(String subject)
推奨されていません。
タイトルをセットする。

パラメータ:
subject - タイトル文字列
戻り値:
成功 true/失敗 false

setReplyTo

public boolean setReplyTo(String replyto,
                          String alias)
推奨されていません。
リプライをセットする。

パラメータ:
replyto - リプライアドレス文字列
alias - リプライニックネーム
戻り値:
成功 true/失敗 false

setReplyTo

public boolean setReplyTo(String replyto)
推奨されていません。
リプライをセットする。

パラメータ:
replyto - リプライアドレス文字列
戻り値:
成功 true/失敗 false

setBcc

public boolean setBcc(String bcc,
                      String alias)
推奨されていません。
Bccをセットする。

パラメータ:
bcc - Bccアドレス文字列
alias - Bccニックネーム
戻り値:
成功 true/失敗 false

setBcc

public boolean setBcc(String bcc)
推奨されていません。
Bccをセットする。

パラメータ:
bcc - Bccアドレス文字列
戻り値:
成功 true/失敗 false

setCc

public boolean setCc(String cc,
                     String alias)
推奨されていません。
Ccをセットする。

パラメータ:
cc - Ccアドレス文字列
alias - Ccニックネーム
戻り値:
成功 true/失敗 false

setCc

public boolean setCc(String cc)
推奨されていません。
Ccをセットする。

パラメータ:
cc - Ccアドレス文字列
戻り値:
成功 true/失敗 false

setTo

public boolean setTo(String to,
                     String alias)
推奨されていません。
To(宛先)をセットする。

パラメータ:
to - Toアドレス文字列
alias - Toニックネーム
戻り値:
成功 true/失敗 false

setTo

public boolean setTo(String to)
推奨されていません。
To(宛先)をセットする。

パラメータ:
to - Toアドレス文字列
戻り値:
成功 true/失敗 false

send

public boolean send()
推奨されていません。
指定されたSMTPサーバへメールを送信する。

他のメソッドで設定した情報をもとにメールを送信する。 最低限必要な設定は宛先と送信者（setTo(),setFrom()メソッドで設定）

戻り値:
成功 true/失敗 false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.smtp (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.smtp
クラス
Mail


jp.co.intra_mart.foundation.smtp (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.smtp

メール連携モジュール。

参照:
説明

クラスの概要
Mail 推奨されていません。 MailSenderに置き換えられました。

パッケージ jp.co.intra_mart.foundation.smtp の説明

メール連携モジュール。 メール送信のためのAPI群。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.smtp クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.smtp の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.system.mail.smtp.InetMail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.smtp.Mail (implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.smtp の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.smtp の使用

jp.co.intra_mart.foundation.smtp はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の使用

jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.CharacterEncoder の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.CharacterEncoder の使用

jp.co.intra_mart.foundation.utility.charset.CharacterEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.ResourceFormatException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.ResourceFormatException の使用

ResourceFormatException を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset での ResourceFormatException の使用

ResourceFormatException をスローする jp.co.intra_mart.foundation.utility.charset のメソッド
protected void | CharacterEncoder.setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
static AdvancedOutputStreamWriter | AdvancedOutputStreamWriter.createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

ResourceFormatException をスローする jp.co.intra_mart.foundation.utility.charset のコンストラクタ
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException の使用

ResourceNotFoundException を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset での ResourceNotFoundException の使用

ResourceNotFoundException をスローする jp.co.intra_mart.foundation.utility.charset のメソッド
protected void | CharacterEncoder.setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
static AdvancedOutputStreamWriter | AdvancedOutputStreamWriter.createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

ResourceNotFoundException をスローする jp.co.intra_mart.foundation.utility.charset のコンストラクタ
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AdvancedOutputStreamWriter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス AdvancedOutputStreamWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。

public class AdvancedOutputStreamWriter
extends FilterWriter

このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。

通常、ASCII の範囲に含まれない文字は、java.io.OutputStreamWriter を 利用して相互に文字コード変換した場合、各文字エンコーディングの Unicode に対するマッピングの相違により、本来その文字エンコーディングにおいて 存在する文字であってもコード不明を意味する「?」に置き換えられてしまう ことがあります。 いわゆる、この文字化けに対して、文字コード変換前に、 対象となる文字エンコーディングに対する Unicode の正しい文字に 置換することで、いくつかの文字については正しく文字コード変換することが できます。
このクラスでは、この方式により文字化けを回避します。

文字化けに対する文字のマッピングおよび対応する文字エンコーディングに 関しては、CharacterEncoder クラスの仕様に準じます。

導入されたバージョン:
version4.3
関連項目:
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter, jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException, jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException, CharacterEncoder

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
AdvancedOutputStreamWriter(OutputStream out)
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
メソッドの概要
static AdvancedOutputStreamWriter | createWriter(OutputStreamWriter writer) 推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。
String | getCharacterEncoding() 推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
OutputStreamWriter | getOutputStreamWriter() 推奨されていません。 このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
void | write(char[] cbuf, int off, int len) 推奨されていません。 文字の配列の一部を書き込みます。
void | write(int c) 推奨されていません。 単一の文字を書き込みます。
void | write(String str, int off, int len) 推奨されていません。 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  String charsetName)
                           throws UnsupportedEncodingException,
                                  ResourceNotFoundException,
                                  ResourceFormatException,
                                  IOException
推奨されていません。
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
charsetName - サポートされる charset の名前
例外:
UnsupportedEncodingException - 指定された文字エンコーディングがサポートされていない場合
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out)
                           throws ResourceFormatException,
                                  ResourceNotFoundException,
                                  IOException
推奨されていません。
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  Charset cs)
                           throws IOException,
                                  ResourceFormatException,
                                  ResourceNotFoundException
推奨されていません。
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
cs - サポートされる Charset
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 入出力エラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  CharsetEncoder enc)
                           throws ResourceFormatException,
                                  IOException,
                                  ResourceNotFoundException
推奨されていません。
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
enc - 文字エンコーディングエンコーダ
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStreamWriter writer)
                           throws ResourceNotFoundException,
                                  IOException,
                                  ResourceFormatException
推奨されていません。
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

なお、このオブジェクトが対応する文字エンコーディングは、 java.io.OutputStreamWriter#getEncoding() の返す値によって 決定します。 java.io.OutputStreamWriter#getEncoding() が null を返す場合、 このコンストラクタは NUllPointerException をスローして オブジェクトの作成に失敗します。

パラメータ:
writer - 基本となるストリームを提供する java.io.OutputStreamWriter オブジェクト
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
ResourceFormatException - 設定に不整合がある場合
IOException - 設定の読み込みエラー
ResourceNotFoundException
ResourceFormatException
メソッドの詳細

createWriter

public static AdvancedOutputStreamWriter createWriter(OutputStreamWriter writer)
                                               throws IOException,
                                                      ResourceNotFoundException,
                                                      ResourceFormatException
推奨されていません。
AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。

パラメータ:
writer -
戻り値:
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
例外:
IOException
ResourceNotFoundException
ResourceFormatException

getCharacterEncoding

public String getCharacterEncoding()
推奨されていません。
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字の配列の一部を書き込みます。

パラメータ:
cbuf - き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
推奨されていません。
単一の文字を書き込みます。

パラメータ:
c - 書き込む文字を指定する int
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字列の一部を書き込みます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

getOutputStreamWriter

public OutputStreamWriter getOutputStreamWriter()
推奨されていません。
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。

戻り値:
基礎となっている java.io.OutputStreamWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CharacterEncoder (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス CharacterEncoder

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。

public class CharacterEncoder
extends Object

このクラスは、文字エンコードの機能を提供します。

このクラスは、Java runtime が提供する通常の文字コード変換において 文字のマッピング定義の相違に起因して文字化けしてしまう現象を解決するための 一つの方法となります。 実際には、定義ファイルに設定されている文字をネイティブコードへ変換する前に 他の文字へ変更する事により、文字化けを防ぎます。

例えば、EUC_JP における文字「～」は、 Unicode へ変換した際 0x301C(Wave Dash) にマッピングされます。 これに対して、SJIS では文字「～」は、 Unicode の 0xFF5E(Fullwidth Tilde) にマッピングされています。 このため、相互に文字コード変換をすると、 文字「?」に置き換わると言う現象(いわゆる文字化け)が発生します。
このクラスでは、Unicode から SJIS へ変換する際に Unicode の文字 0x301C(Wave Dash) を 0xFF5E(Fullwidth Tilde) へ変更してから 文字コード変換を行います。

定義ファイルは、クラスローダを利用して検索および読み込まれます。 したがって、定義ファイルはクラスパスに設定されているディレクトリまたは アーカイブファイル内に配置する必要があります。
各文字エンコーディングと文字の変換テーブルの関連については、 定義ファイル jp/co/intra_mart/resources/charset/encoding/mapping.xml に記載されています。

導入されたバージョン:
version4.3
関連項目:
CharacterEncoder, ResourceNotFoundException, ResourceFormatException

コンストラクタの概要
CharacterEncoder(String enc)
推奨されていません。 文字コード変換のためのエンコーダを作成します。
メソッドの概要
byte[] | encode(char c) 推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(char[] c) 推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(String str) 推奨されていません。 指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。
String | getCharacterEncoding() 推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
String | newString(char[] c) 推奨されていません。 getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
String | newString(String str) 推奨されていません。 getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
protected void | setCharacterEncoding(String enc) 推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterEncoder

public CharacterEncoder(String enc)
                 throws ResourceNotFoundException,
                        ResourceFormatException,
                        IOException
推奨されていません。
文字コード変換のためのエンコーダを作成します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
推奨されていません。
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

protected void setCharacterEncoding(String enc)
                             throws ResourceFormatException,
                                    ResourceNotFoundException,
                                    IOException
推奨されていません。
このオブジェクトが対象とする文字エンコーディングを設定します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー

encode

public byte[] encode(char c)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(char[] c)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字配列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(String str)
              throws UnsupportedEncodingException,
                     IOException
推奨されていません。
指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
str - 文字列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

newString

public String newString(String str)
推奨されていません。
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 str のマッピングを修正した 新しい文字列です。

パラメータ:
str - 文字列
戻り値:
マッピングを修正された新しい文字列

newString

public String newString(char[] c)
推奨されていません。
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 c のマッピングを修正した 新しい文字列です。
引数の配列 c は変化しません。

パラメータ:
c - 文字配列
戻り値:
新しい文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.charset (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.utility.charset
クラス
AdvancedOutputStreamWriter
CharacterEncoder
例外
ResourceFormatException
ResourceNotFoundException


jp.co.intra_mart.foundation.utility.charset (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.charset

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
AdvancedOutputStreamWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
CharacterEncoder | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。

例外の概要
ResourceFormatException | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceNotFoundException | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.charset の説明

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.utility.charset クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.charset の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.utility.charset の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.charset の使用

jp.co.intra_mart.foundation.utility.charset を使用しているパッケージ
jp.co.intra_mart.foundation.utility.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.charset により使用される jp.co.intra_mart.foundation.utility.charset のクラス
ResourceFormatException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceNotFoundException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ResourceFormatException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス ResourceFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
                拡張 jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。

public class ResourceFormatException
extends ResourceFormatException

リソースの内容が不適切であることを通知する例外です。

設定の内容に誤りがあるか、または定義の書式が正しくない場合にスローされます。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ResourceFormatException(String msg)
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String msg, Throwable cause)
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceFormatException

public ResourceFormatException(String msg)
推奨されていません。
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceFormatException

public ResourceFormatException(String msg,
                               Throwable cause)
推奨されていません。
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResourceNotFoundException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.charset
クラス ResourceNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
                拡張 jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。

public class ResourceNotFoundException
extends ResourceNotFoundException

リソースがないことを通知する例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ResourceNotFoundException(String msg)
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String msg, Throwable cause)
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceNotFoundException

public ResourceNotFoundException(String msg)
推奨されていません。
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceNotFoundException

public ResourceNotFoundException(String msg,
                                 Throwable cause)
推奨されていません。
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.AbstractDualComparator の使用

AbstractDualComparator を使用しているパッケージ
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.page での AbstractDualComparator の使用

jp.co.intra_mart.foundation.page での AbstractDualComparator のサブクラス
 class NodeTypeComparator
ツリービューのノードを種類順にソートするためのコンパレータです。

jp.co.intra_mart.foundation.utility での AbstractDualComparator の使用

jp.co.intra_mart.foundation.utility での AbstractDualComparator のサブクラス
 class MultiComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.Counter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.Counter の使用

jp.co.intra_mart.foundation.utility.Counter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.DualComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.DualComparator の使用

jp.co.intra_mart.foundation.utility.DualComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ErrorEvent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ErrorEvent の使用

ErrorEvent を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での ErrorEvent の使用

ErrorEvent 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void ErrorEventListener.reportError(ErrorEvent err)
推奨されていません。 発生した例外を通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.ErrorEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.ErrorEventListener の使用

ErrorEventListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility.io このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.io での ErrorEventListener の使用

ErrorEventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility.io のコンストラクタ
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
推奨されていません。 出力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
推奨されていません。 入力ストリームを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.EventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider のメソッド
static void | GarbageController.addListener(EventListener listener) リスナーを登録します。
static boolean | GarbageController.removeListener(EventListener listener) 指定されたリスナーを削除します。

jp.co.intra_mart.foundation.utility での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void EventQueueController.entry(EventListener listener)
推奨されていません。 イベントリスナーの登録。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.EventQueueController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.EventQueueController の使用

EventQueueController を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での EventQueueController の使用

EventQueueController 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ExtendedThread の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ExtendedThread の使用

jp.co.intra_mart.foundation.utility.ExtendedThread はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.FilterComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.FilterComparator の使用

FilterComparator を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での FilterComparator の使用

jp.co.intra_mart.foundation.utility での FilterComparator のサブクラス
 class ReverseComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.FixedSizeMap の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.FixedSizeMap の使用

jp.co.intra_mart.foundation.utility.FixedSizeMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.LockMonitor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.LockMonitor の使用

jp.co.intra_mart.foundation.utility.LockMonitor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.MultiComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.MultiComparator の使用

jp.co.intra_mart.foundation.utility.MultiComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions の使用

MultipurposeInternetMailExtensions を使用しているパッケージ
jp.co.intra_mart.foundation.http ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.http での MultipurposeInternetMailExtensions の使用

MultipurposeInternetMailExtensions 型のパラメータを持つ jp.co.intra_mart.foundation.http のコンストラクタ
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse httpResponse, MultipurposeInternetMailExtensions mimeType, String filename)
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ResourceBundleProperties の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ResourceBundleProperties の使用

jp.co.intra_mart.foundation.utility.ResourceBundleProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.ReverseComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.ReverseComparator の使用

jp.co.intra_mart.foundation.utility.ReverseComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.SequenceComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.SequenceComparator の使用

jp.co.intra_mart.foundation.utility.SequenceComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.ThreadStopListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.ThreadStopListener の使用

ThreadStopListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility での ThreadStopListener の使用

ThreadStopListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility のメソッド
 void ExtendedThread.addThreadStopListener(ThreadStopListener listener)
推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.Directory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.Directory の使用

Directory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での Directory の使用

jp.co.intra_mart.foundation.service.provider での Directory のサブクラス
class | HomeDirectory このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
class | TemporaryDirectory このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

jp.co.intra_mart.foundation.service.provider.file での Directory の使用

jp.co.intra_mart.foundation.service.provider.file での Directory のサブクラス
 class StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

jp.co.intra_mart.foundation.service.provider.information での Directory の使用

jp.co.intra_mart.foundation.service.provider.information での Directory のサブクラス
 class PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

jp.co.intra_mart.foundation.utility.file での Directory の使用

jp.co.intra_mart.foundation.utility.file での Directory のサブクラス
 class ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.ExtendedDirectory の使用

ExtendedDirectory を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider での ExtendedDirectory のサブクラス
class | HomeDirectory このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
class | TemporaryDirectory このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。

jp.co.intra_mart.foundation.service.provider.file での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider.file での ExtendedDirectory のサブクラス
 class StorageDirectory
Storage Service の基準ディレクトリを表すクラスです。

jp.co.intra_mart.foundation.service.provider.information での ExtendedDirectory の使用

jp.co.intra_mart.foundation.service.provider.information での ExtendedDirectory のサブクラス
 class PermanentDataDirectory
Permanent-data を保存するディレクトリを表すオブジェクトです。

ExtendedDirectory を返す jp.co.intra_mart.foundation.service.provider.information のメソッド
ExtendedDirectory | PermanentDataDirectory.entityDirectory() データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
ExtendedDirectory | PermanentDataDirectory.temporaryDirectory() 削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。

jp.co.intra_mart.foundation.utility.file での ExtendedDirectory の使用

ExtendedDirectory を返す jp.co.intra_mart.foundation.utility.file のメソッド
ExtendedDirectory | ExtendedDirectory.childDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedDirectory | ExtendedDirectory.findDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.file.ExtendedFile の使用

ExtendedFile を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider での ExtendedFile の使用

jp.co.intra_mart.foundation.service.provider での ExtendedFile のサブクラス
 class TemporaryFile
このクラスは、一時ファイルに関する機能を提供します。

jp.co.intra_mart.foundation.utility.file での ExtendedFile の使用

ExtendedFile を返す jp.co.intra_mart.foundation.utility.file のメソッド
ExtendedFile | ExtendedDirectory.childFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected ExtendedFile | ExtendedDirectory.findFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


Directory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス Directory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。

public class Directory
extends File

このクラスは、ディレクトリを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ディレクトリである場合に利用することができます。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
Directory(File parent, String child)
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String pathname)
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(String parent, String child)
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
Collection | childDirectories() 推奨されていません。 この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
Collection | childFiles() 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | files(int depth) 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | paths(int depth) 推奨されていません。 この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Directory

public Directory(String pathname)
推奨されていません。
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(File parent,
                 String child)
推奨されていません。
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(String parent,
                 String child)
推奨されていません。
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

childDirectories

public Collection childDirectories()
推奨されていません。
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ディレクトリを表す java.io.File クラスのインスタンスです。

戻り値:
ディレクトリパスを繰り返し処理する反復子

childFiles

public Collection childFiles()
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

戻り値:
ファイルパスを繰り返し処理する反復子

paths

public Collection paths(int depth)
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルまたはディレクトリを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合

files

public Collection files(int depth)
推奨されていません。
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedDirectory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス ExtendedDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.Directory
            拡張 jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
HomeDirectory, PermanentDataDirectory, StorageDirectory, TemporaryDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

public class ExtendedDirectory
extends Directory

File インスタンスを作成するためのファクトリクラスです。

このクラスは、指定のディレクトリを親とすして、相対パスにより解決される 抽象パスを表す File インスタンスを生成する機能を提供します。 生成された File インスタンスは、オブジェクト内にプールされるため、 同じパスを繰り返し利用ようなプログラムで利用することにより、 メモリリソースを節約することができます。

関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedDirectory(File parent, String path, int size)
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(String pathname, int size)
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
メソッドの概要
void | archive(File f) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(File f, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(OutputStream out) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(OutputStream out, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out, FileFilter filter) 推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
ExtendedDirectory | childDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
ExtendedFile | childFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
File | childPath(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
protected ExtendedDirectory | findDirectory(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedFile | findFile(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected File | findPath(String path) 推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
void | reset() 推奨されていません。 キャッシュ領域をクリアします。
クラス jp.co.intra_mart.foundation.utility.file.Directory から継承したメソッド
childDirectories, childFiles, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedDirectory

public ExtendedDirectory(String pathname,
                         int size)
推奨されていません。
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
pathname - ディレクトリパス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合

ExtendedDirectory

public ExtendedDirectory(File parent,
                         String path,
                         int size)
推奨されていません。
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 このオブジェクトのパスは、parent を親ディレクトリとした 子抽象パス path により解決されます。
引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
parent - 親ディレクトリ
path - パス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合
メソッドの詳細

childFile

public ExtendedFile childFile(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

findFile

protected ExtendedFile findFile(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

このメソッドは、childFile メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

childDirectory

public ExtendedDirectory childDirectory(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。 このメソッドは、このオブジェクトのプール許容値と等しい プール許容値を持つ ExtendedDirectory のインスタンスを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

findDirectory

protected ExtendedDirectory findDirectory(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

このメソッドは、childDirectory メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

childPath

public File childPath(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

findPath

protected File findPath(String path)
推奨されていません。
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

このメソッドは、childPath メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

reset

public void reset()
推奨されていません。
キャッシュ領域をクリアします。

archive

public void archive(File f)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(File f,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。 ファイルに出力されるファイルは、フィルタの基準を満たす必要があります。 圧縮されるファイルは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out,
                    FileFilter filter)
             throws IOException
推奨されていません。
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
filter - ファイル名フィルタ
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedFile (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.file
クラス ExtendedFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.foundation.utility.file.ExtendedFile
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
TemporaryFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

public class ExtendedFile
extends File

このクラスは、ファイルを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ファイルである場合に利用することができます。

関連項目:
File, ExtendedDirectory, 直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedFile(File parent, String child)
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String pathname)
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(String parent, String child)
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
void | append(byte[] b) 推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | append(String str) 推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | append(String str, String enc) 推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
byte[] | getBytes() 推奨されていません。 この抽象パスが表すファイルからデータを読み込みます。
Iterator | readLines() 推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
Iterator | readLines(String enc) 推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
String | readString() 推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
String | readString(String enc) 推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
void | write(byte[] b) 推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | write(String str) 推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | write(String str, String enc) 推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedFile

public ExtendedFile(String pathname)
推奨されていません。
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(File parent,
                    String child)
推奨されていません。
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(String parent,
                    String child)
推奨されていません。
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

getBytes

public byte[] getBytes()
                throws FileNotFoundException,
                       IOException
推奨されていません。
この抽象パスが表すファイルからデータを読み込みます。

戻り値:
ファイルの内容
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString()
                  throws FileNotFoundException,
                         IOException
推奨されていません。
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、デフォルトの文字エンコーディングから Unicode に変換して返します。

戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString(String enc)
                  throws FileNotFoundException,
                         UnsupportedEncodingException,
                         IOException
推奨されていません。
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、指定の文字エンコーディングから Unicode に変換して返します。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines()
                   throws FileNotFoundException,
                          IOException
推奨されていません。
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、デフォルトの文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines(String enc)
                   throws FileNotFoundException,
                          UnsupportedEncodingException,
                          IOException
推奨されていません。
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、指定の文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

write

public void write(String str)
           throws IOException
推奨されていません。
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  String enc)
           throws UnsupportedEncodingException,
                  IOException
推奨されていません。
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(String str)
            throws IOException
推奨されていません。
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

append

public void append(String str,
                   String enc)
            throws UnsupportedEncodingException,
                   IOException
推奨されていません。
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(byte[] b)
            throws IOException
推奨されていません。
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

バイトは、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対してバイトを追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成してバイトをファイルの先頭に書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合

write

public void write(byte[] b)
           throws IOException
推奨されていません。
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.file (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.utility.file
クラス
Directory
ExtendedDirectory
ExtendedFile


jp.co.intra_mart.foundation.utility.file (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.file

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

参照:
説明

クラスの概要
Directory | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.file の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.utility.file クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.utility.file の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.file の使用

jp.co.intra_mart.foundation.utility.file を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

jp.co.intra_mart.foundation.service.provider.file により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

jp.co.intra_mart.foundation.service.provider.information により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。

jp.co.intra_mart.foundation.utility.file により使用される jp.co.intra_mart.foundation.utility.file のクラス
Directory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
ExtendedDirectory
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedFile
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ExtendedInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ExtendedInputStream の使用

ExtendedInputStream を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedInputStream の使用

ExtendedInputStream を返す jp.co.intra_mart.foundation.utility.net のメソッド
 ExtendedInputStream ExtendedSocket.getInputStream()
推奨されていません。 入力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の使用

ExtendedOutputStream を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedOutputStream の使用

ExtendedOutputStream を返す jp.co.intra_mart.foundation.utility.net のメソッド
 ExtendedOutputStream ExtendedSocket.getOutputStream()
推奨されていません。 出力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.HexInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.HexInputStream の使用

jp.co.intra_mart.foundation.utility.io.HexInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.HexOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.HexOutputStream の使用

jp.co.intra_mart.foundation.utility.io.HexOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.ReplaceWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.ReplaceWriter の使用

jp.co.intra_mart.foundation.utility.io.ReplaceWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream の使用

jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream の使用

jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.XORInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.XORInputStream の使用

jp.co.intra_mart.foundation.utility.io.XORInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.io.XOROutputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.io.XOROutputStream の使用

jp.co.intra_mart.foundation.utility.io.XOROutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


BASE64DecodeInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64DecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。

public class BASE64DecodeInputStream
extends FilterInputStream

このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、BASE64 デコードされ read() メソッドにより返されます。

関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
BASE64DecodeInputStream(InputStream in)
推奨されていません。 指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeInputStream

public BASE64DecodeInputStream(InputStream in)
推奨されていません。
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BASE64DecodeOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64DecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。

public class BASE64DecodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 デコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64DecodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeOutputStream

public BASE64DecodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が ASCII 文字の範囲に含まれない場合（ASCII のコントロールコードの場合も含む）や不正なコードが指定された場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BASE64EncodeOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス BASE64EncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。

public class BASE64EncodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 エンコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64EncodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
void | finish() 推奨されていません。 出力ストリームへのエンコードデータの書き込みを終了します。
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、3 バイトのデータを受け取るとエンコードされたバイトを 出力ストリームに書き込みます。入力されたバイトが 3 バイトに満たない 場合は、入力されたバイトが合計で 3 バイトになるまでバッファに 溜め込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

finish

public void finish()
            throws IOException
推奨されていません。
出力ストリームへのエンコードデータの書き込みを終了します。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。 もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。
このメソッドは、finish メソッドを呼び出した後、 スーパークラス(java.io.FilterOutputStream)の close メソッドを呼び出します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ExtendedInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。

public class ExtendedInputStream
extends InputStream

このクラスは、標準の入力ストリームを拡張した機能を提供します。

このクラスは、jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream により 書き出されたストリームを読み込むための実装を提供します。
このクラスの各メソッドは、データをストリームから読み込むときに、 java.io.DataInputStream または java.io.ObjectInputStream の 適切なメソッドを使います。

データをストリームに書き出したときに使ったメソッドに対応した 適切なメソッドを利用することにより、データを読み込むことができます。

このクラスを jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream と対で使うことにより、 データをファイルに保存したり、ネットワークにより他のプロセスへ データを転送することができます。

jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream の writeObject メソッドにより 書き出されたオブジェクトは、readObject メソッドにより インスタンス化することができます。 この時、インスタンスに必要なクラスが存在している必要があります。

コンストラクタの概要
ExtendedInputStream(InputStream in)
推奨されていません。 入力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
推奨されていません。 入力ストリームを構築します。
メソッドの概要
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
boolean | isClosed() 推奨されていません。 この入出力ストリームが閉じられているかチェックします。
int | read() 推奨されていません。 データ取得。
int | read(byte[] b, int off, int len) 推奨されていません。 データ取得。
boolean | readBoolean() 推奨されていません。 boolean 型データ取得。
int | readInt() 推奨されていません。 int 型データ取得。
long | readLong() 推奨されていません。 long 型データ取得。
Object | readObject() 推奨されていません。 Object の取得。
String | readString() 推奨されていません。 文字列の取得。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedInputStream

public ExtendedInputStream(InputStream in)
                    throws IOException
推奨されていません。
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedInputStream

public ExtendedInputStream(InputStream in,
                           ErrorEventListener listener)
                    throws IOException
推奨されていません。
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
データ取得。

入力ストリームから次のバイトのデータを取得します。

戻り値:
取得したバイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(), ExtendedOutputStream.write(int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
データ取得。

入力ストリームから len バイトまでのデータをバイト配列に 読み込みます。

パラメータ:
b - バイト配列
off - データの開始オフセット
len - 読み込むバイト数
戻り値:
取得したバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(byte[], int, int), ExtendedOutputStream.write(int)

readInt

public int readInt()
            throws IOException
推奨されていません。
int 型データ取得。

基本データ型の整数データを読み込みます。

戻り値:
int 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readInt(), ExtendedOutputStream.writeInt(int)

readLong

public long readLong()
              throws IOException
推奨されていません。
long 型データ取得。

基本データ型の長整数データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readLong(), ExtendedOutputStream.writeLong(long)

readBoolean

public boolean readBoolean()
                    throws IOException
推奨されていません。
boolean 型データ取得。

基本データ型の真偽値データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readBoolean(), ExtendedOutputStream.writeBoolean(boolean)

readObject

public Object readObject()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
推奨されていません。
Object の取得。

戻り値:
入力して復元したオブジェクト
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ObjectInputStream.readObject(), ExtendedOutputStream.writeObject(Object)

readString

public String readString()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
推奨されていません。
文字列の取得。

このメソッドは、jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream クラスの writeString メソッドを使って書き込んだデータを読み込むための メソッドです。他の方法で書き込んだデータを読み込むことはできません。

戻り値:
入力した文字列
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ExtendedOutputStream.writeString(String)

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ExtendedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。

public class ExtendedOutputStream
extends OutputStream

このクラスは、標準の出力ストリームを拡張した機能を提供します。

このクラスの各メソッドは、データをストリームに書き出すときに、 java.io.DataOutputStream または java.io.ObjectOutputStream の 適切なメソッドを使います。
writeObject メソッドを使ってオブジェクトをストリームに書き出す 場合、ストリームに書き込めるのは java.io.Serializable インタフェースを サポートするオブジェクトに限ります。それ以外のオブジェクトを ストリームに書き込もうとした場合、例外がスローされます。

この出力ストリームに書き込んだデータを入力する場合、 jp.co.intra_mart.foundation.utility.io.ExtendedInputStream を利用する必要があります。 他の入力ストリームから読み込んだ場合例外がスローされることがあります。

関連項目:
ExtendedInputStream

コンストラクタの概要
ExtendedOutputStream(OutputStream out)
推奨されていません。 出力ストリームを構築します。
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
推奨されていません。 出力ストリームを構築します。
メソッドの概要
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
void | flush() 推奨されていません。 書き出しストリーム内のデータをすべて出力。
boolean | isClosed() 推奨されていません。 この入出力ストリームが閉じられているかチェックします。
void | write(byte[] b, int off, int len) 推奨されていません。 オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
void | write(int data) 推奨されていません。 指定されたバイトを書き込みます。
void | writeBoolean(boolean data) 推奨されていません。 boolean 型データの送信。
void | writeInt(int data) 推奨されていません。 int 型データの送信。
void | writeLong(long data) 推奨されていません。 long 型データの送信。
void | writeObject(Object data) 推奨されていません。 オブジェクトの送信。
void | writeString(String data) 推奨されていません。 文字列の送信。
クラス java.io.OutputStream から継承したメソッド
write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out)
                     throws IOException
推奨されていません。
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out,
                            ErrorEventListener listener)
                     throws IOException
推奨されていません。
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

write

public void write(int data)
           throws IOException
推奨されていません。
指定されたバイトを書き込みます。

パラメータ:
data - バイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(int), ExtendedInputStream.read()

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(byte[],int,int), ExtendedInputStream.read()

writeInt

public void writeInt(int data)
              throws IOException
推奨されていません。
int 型データの送信。
基本データ型の整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeInt(int), ExtendedInputStream.readInt()

writeLong

public void writeLong(long data)
               throws IOException
推奨されていません。
long 型データの送信。
基本データ型の長整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeLong(long), ExtendedInputStream.readLong()

writeBoolean

public void writeBoolean(boolean data)
                  throws IOException
推奨されていません。
boolean 型データの送信。
基本データ型の真偽値データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeBoolean(boolean), ExtendedInputStream.readBoolean()

writeObject

public void writeObject(Object data)
                 throws IOException
推奨されていません。
オブジェクトの送信。

java.io.Serializable インタフェースを実装している オブジェクトを基礎出力ストリームに書き込みます。
このメソッドはオブジェクトをストリームに書き込む際に、 java.io.ObjectOutputStream の writeObject メソッドを使います。

パラメータ:
data - オブジェクト
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
ObjectOutputStream.writeObject(Object), Serializable, ExtendedInputStream.readObject()

writeString

public void writeString(String data)
                 throws IOException
推奨されていません。
文字列の送信。
このメソッドは、writeObject() メソッドを使い文字列をストリームに 書き込みます。 java.io.DataOutputStream や java.io.ObjectOutputStream の writeUTF メソッドとの違いは、ストリームに書き込める文字列の 長さに制約がないことです。

パラメータ:
data - ストリームに書き込む文字列
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
DataOutputStream.writeUTF(String),
ObjectOutputStream.writeUTF(String),
ExtendedInputStream.readString()

flush

public void flush()
           throws IOException
推奨されていません。
書き出しストリーム内のデータをすべて出力。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス HexInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.foundation.utility.io.HexInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。

public class HexInputStream
extends InputStream

このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、16進数表現からバイトに変換され read() メソッドにより返されます。

関連項目:
InputStream

フィールドの概要
protected  InputStream in
推奨されていません。 フィルタ処理される入力ストリームです。
コンストラクタの概要
HexInputStream(InputStream in)
推奨されていません。 指定された InputStream から読み込む HexInputStream を作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

in

protected InputStream in
推奨されていません。
フィルタ処理される入力ストリームです。

コンストラクタの詳細

HexInputStream

public HexInputStream(InputStream in)
推奨されていません。
指定された InputStream から読み込む HexInputStream を作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
推奨されていません。
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

入力ストリームを閉じ、これに関連するすべての システムリソースを解放します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス HexOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.foundation.utility.io.HexOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。

public class HexOutputStream
extends OutputStream

このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、16進数表現され 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 [0-9a-f] の範囲のキャラクタで構成されます。

関連項目:
OutputStream

フィールドの概要
protected  OutputStream out
推奨されていません。 フィルタ処理される基礎出力ストリームです。
コンストラクタの概要
HexOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む HexOutputStream を作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じます。
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.OutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected OutputStream out
推奨されていません。
フィルタ処理される基礎出力ストリームです。

コンストラクタの詳細

HexOutputStream

public HexOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む HexOutputStream を作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、バイトを上位４ビットと下位ビットに分け、 それぞれ16進数表現されたキャラクターコードに置き換えて、 計２バイトのデータを基礎ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。
もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.io (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.utility.io
クラス
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
ExtendedInputStream
ExtendedOutputStream
HexInputStream
HexOutputStream
ReplaceWriter
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
XORInputStream
XOROutputStream


jp.co.intra_mart.foundation.utility.io (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.io

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

参照:
説明

クラスの概要
BASE64DecodeInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
BASE64DecodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
BASE64EncodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
ExtendedInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
HexInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
HexOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
ReplaceWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
URLDecodeInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
URLDecodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
URLEncodeOutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
XORInputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
XOROutputStream | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.io の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
このパッケージには、java.io パッケージに含まれるクラスを拡張したものが多く含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.utility.io クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.io の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.XORInputStream
      • class jp.co.intra_mart.foundation.utility.io.HexInputStream
    • class java.io.OutputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.XOROutputStream
      • class jp.co.intra_mart.foundation.utility.io.HexOutputStream
    • class java.io.Writer
      • class jp.co.intra_mart.foundation.utility.io.ReplaceWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.utility.io の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.io の使用

jp.co.intra_mart.foundation.utility.io を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net により使用される jp.co.intra_mart.foundation.utility.io のクラス
ExtendedInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ReplaceWriter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス ReplaceWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.foundation.utility.io.ReplaceWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。

public class ReplaceWriter
extends Writer

このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
置換対象となる部分文字列と置換する文字列の長さは同じ必要はありません。 置換対象となる文字データと異なる長さの文字データを置換後のデータとして 指定することも可能です。この場合、 このクラスによって基礎ストリームに書き込まれるデータ量は、 元のデータ量と変化します。

   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("abc");
   String result = sw.toString();
文字データ "abc" は、"xyz" に変化します。この場合、以下のように 記述しても同様の結果が得られます。
   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("a");
   rw.write("b");
   rw.write("c");
   String result = sw.toString();

導入されたバージョン:
version 3.2

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReplaceWriter(Writer out, char[] oldChars)
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, char[] oldChars, char[] newChars)
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString)
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString, String newString)
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じてフラッシュします。
void | finish() 推奨されていません。 バッファに保存してあるデータを書き出します。
void | flush() 推奨されていません。 ストリームをフラッシュします。
void | write(char[] cbuf, int off, int len) 推奨されていません。 文字列の一部を基礎ストリームに書き込みます。
void | write(int c) 推奨されていません。 単一文字を書き込みます。
クラス java.io.Writer から継承したメソッド
write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars)
推奨されていません。
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 削除対象となる文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString)
推奨されていません。
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldString - 削除対象となる文字列

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars,
                     char[] newChars)
推奨されていません。
文字列置換のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは適切な置換を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 置換対象となる文字の配列
newChars - 置換する文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString,
                     String newString)
推奨されていません。
文字列置換のためのストリームフィルタを作成します。

パラメータ:
out - 基礎ストリーム
oldString - 置換対象となる文字列
newString - 置換する文字列
メソッドの詳細

write

public void write(int c)
           throws IOException
推奨されていません。
単一文字を書き込みます。 書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
文字列の一部を基礎ストリームに書き込みます。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

finish

public void finish()
            throws IOException
推奨されていません。
バッファに保存してあるデータを書き出します。

ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字を基礎ストリームへただちに 書き込みます。
このメソッドは、このストリームの持つ置換対象データと比較中の 文字データを含むすべてのバッファを基礎ストリームに書き込みます。 このメソッドを呼び出し後は、write() メソッドによって与えられる データを改めて検索し直します。この機能のより、このストリームフィルタの 複数のストリームでの再利用が可能となります。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLDecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。

public class URLDecodeInputStream
extends FilterInputStream

このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
この入力ストリームに読み込まれたバイトは、URL デコードされ 基礎入力ストリームに読み込まれます。

導入されたバージョン:
version 4.0

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
URLDecodeInputStream(InputStream in)
推奨されていません。 指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeInputStream

public URLDecodeInputStream(InputStream in)
推奨されていません。
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
推奨されていません。
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLDecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。

public class URLDecodeOutputStream
extends FilterOutputStream

このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL デコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLDecodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeOutputStream

public URLDecodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLEncodeOutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス URLEncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。

public class URLEncodeOutputStream
extends FilterOutputStream

このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL エンコードされ 基礎出力ストリームに書き込まれます。

関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLEncodeOutputStream(OutputStream out)
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLEncodeOutputStream

public URLEncodeOutputStream(OutputStream out)
推奨されていません。
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XORInputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス XORInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.foundation.utility.io.XORInputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。

public class XORInputStream
extends FilterInputStream

このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、 指定されたバイトデータとの排他論理和を計算した結果として read() メソッドにより返されます。

導入されたバージョン:
version4.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
XORInputStream(InputStream in, int b)
推奨されていません。 指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
メソッドの概要
int | read() 推奨されていません。 デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 推奨されていません。 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XORInputStream

public XORInputStream(InputStream in,
                      int b)
推奨されていません。
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。

パラメータ:
in - 入力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
推奨されていません。
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
推奨されていません。
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。このメソッドは、入力が可能になるまでブロックします。

パラメータ:
b - データの読み込み先のバッファ
off - データの開始オフセット
len - 読み込まれる最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XOROutputStream (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.io
クラス XOROutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.foundation.utility.io.XOROutputStream
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

public class XOROutputStream
extends FilterOutputStream

このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、指定のバイトデータとの 排他論理和を計算して、その結果のバイトデータが 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 同じバイトデータによって排他論理和を取ることにより、 もとのバイトデータに戻すことができます。

導入されたバージョン:
version4.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
XOROutputStream(OutputStream out, int b)
推奨されていません。 指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
メソッドの概要
void | write(byte[] b, int off, int len) 推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) 推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XOROutputStream

public XOROutputStream(OutputStream out,
                       int b)
推奨されていません。
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。

パラメータ:
out - 出力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

write

public void write(int b)
           throws IOException
推奨されていません。
バイトをエンコード出力ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
推奨されていません。
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor の使用

AbstractSocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での AbstractSocketConnectionDistributor の使用

jp.co.intra_mart.foundation.utility.net での AbstractSocketConnectionDistributor のサブクラス
 class SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.ExtendedSocket の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.ExtendedSocket の使用

ExtendedSocket を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での ExtendedSocket の使用

jp.co.intra_mart.foundation.utility.net での ExtendedSocket のサブクラス
 class SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
 void SocketEventListener.handleSocketEvent(ExtendedSocket socket)
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のコンストラクタ
SocketConnection(ExtendedSocket socket)
推奨されていません。 ソケット入出力インスタンスを構築します。
ExtendedSocket(ExtendedSocket socket)
推奨されていません。 ソケットを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.Localhost の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.Localhost の使用

Localhost を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での Localhost の使用

Localhost を返す jp.co.intra_mart.foundation.utility.net のメソッド
static Localhost Localhost.instance()
推奨されていません。 このクラスから生成される唯一のインスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.SocketConnection の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.SocketConnection の使用

SocketConnection を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client のメソッド
protected abstract  SocketConnection NetworkConnector.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.batch での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.batch のメソッド
protected  SocketConnection Scheduler.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.file での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.file のメソッド
protected  SocketConnection AbstractComponent.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.information での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.information のメソッド
protected SocketConnection | PermanentFile.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | PermanentDirectory.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | Lock.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | ExternalMemory.connection() サーバに接続するためのコネクションを取得します。
protected SocketConnection | ExternalDirectory.connection() サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.service.client.manager での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.service.client.manager のメソッド
protected  SocketConnection ServerConnector.connection()
サーバに接続するためのコネクションを取得します。

jp.co.intra_mart.foundation.utility.net での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.foundation.utility.net のメソッド
SocketConnection | SocketPool.connection() 推奨されていません。 コネクションの取得。
SocketConnection | SocketConnectionDistributor.connection() 推奨されていません。 コネクションの取得。

SocketConnection 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
 boolean SocketPool.eject(SocketConnection connection)
推奨されていません。 指定コネクションをこのプールの管理から切り離します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor の使用

SocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client.manager での SocketConnectionDistributor の使用

SocketConnectionDistributor を返す jp.co.intra_mart.foundation.service.client.manager のメソッド
SocketConnectionDistributor | SocketConnectionDistributorFactory.createSocketConnectionDistributor(String passwd) Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
SocketConnectionDistributor | ServerConnector.getSocketConnectionDistributor() このオブジェクトが保持しているネットワークのコネクションプールを 返します。

SocketConnectionDistributor 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.manager のコンストラクタ
ServerConnector(SocketConnectionDistributor socketConnectionDistributor)
オブジェクトを作成します。

jp.co.intra_mart.foundation.utility.net での SocketConnectionDistributor の使用

jp.co.intra_mart.foundation.utility.net での SocketConnectionDistributor のサブインタフェース
 interface SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。

SocketConnectionDistributor を実装している jp.co.intra_mart.foundation.utility.net のクラス
class | AbstractSocketConnectionDistributor 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
class | SocketPool 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketConnectionManager の使用

SocketConnectionManager を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での SocketConnectionManager の使用

SocketConnectionManager を実装している jp.co.intra_mart.foundation.utility.net のクラス
 class SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.net.SocketEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.net.SocketEventListener の使用

SocketEventListener を使用しているパッケージ
jp.co.intra_mart.foundation.utility.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.utility.net での SocketEventListener の使用

SocketEventListener 型のパラメータを持つ jp.co.intra_mart.foundation.utility.net のメソッド
void | SocketPool.addCreateSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | SocketPool.addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | ExtendedSocket.addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.SocketPool の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.SocketPool の使用

jp.co.intra_mart.foundation.utility.net.SocketPool はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException の使用

UnsupportedNetworkConnectException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。

jp.co.intra_mart.foundation.service.client での UnsupportedNetworkConnectException の使用

UnsupportedNetworkConnectException をスローする jp.co.intra_mart.foundation.service.client のメソッド
protected abstract  SocketConnection NetworkConnector.connection()
サーバに接続するためのコネクションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractSocketConnectionDistributor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス AbstractSocketConnectionDistributor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
すべての実装インタフェース:
SocketConnectionDistributor
直系の既知のサブクラス:
SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。

public abstract class AbstractSocketConnectionDistributor
extends Object
implements SocketConnectionDistributor

このクラスは、通信ソケットを作成する機能を提供します。

このクラスを継承してソケットプールを作成することができます。

コンストラクタの概要
protected AbstractSocketConnectionDistributor(String address, int port)
推奨されていません。 ソケット作成オブジェクトを構築します。
メソッドの概要
protected Socket | createSocket() 推奨されていません。 新しいソケットを作成します。
String | getAddress() 推奨されていません。 アドレスを返します。
int | getPort() 推奨されていません。 ポートを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

コンストラクタの詳細

AbstractSocketConnectionDistributor

protected AbstractSocketConnectionDistributor(String address,
                                              int port)
推奨されていません。
ソケット作成オブジェクトを構築します。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
メソッドの詳細

createSocket

protected Socket createSocket()
                       throws UnknownHostException,
                              IOException
推奨されていません。
新しいソケットを作成します。

戻り値:
ソケット
例外:
UnknownHostException - ホストの IP アドレスを判定できなかった場合
IOException - ソケットの生成中に入出力エラーが発生した場合

getAddress

public String getAddress()
推奨されていません。
アドレスを返します。

戻り値:
このプールのネットワーク接続先サーバアドレス

getPort

public int getPort()
推奨されていません。
ポートを返します。

戻り値:
このプールのネットワーク接続先サーバポート
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedSocket (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス ExtendedSocket

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.ExtendedSocket
直系の既知のサブクラス:
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。

public class ExtendedSocket
extends Object

このクラスは、ソケット通信用の入出力機能を提供します。

このクラスの提供している独自機能や、このクラスの持つメソッドから 取得したオブジェクトを使っている最中に例外がスローされた場合、 このクラスのインスタンスは発生した例外を保存します。 保存された例外は、lastError メソッドにより知ることができます。
ただし、このクラスが継承しているスーパークラスのメソッドの 呼び出し時にスローされた例外に関しては感知することはできません。

コンストラクタの概要
protected | ExtendedSocket(ExtendedSocket socket) 推奨されていません。 ソケットを構築します。
 | ExtendedSocket(Socket socket) 推奨されていません。 ソケットを構築します。
 | ExtendedSocket(String address, int port) 推奨されていません。 ソケットを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | clearError() 推奨されていません。 このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
void | close() 推奨されていません。 入出力ストリームおよびソケットを閉じます。
Iterator | errorIterator() 推奨されていません。 このインスタンスのメソッド実行中に発生した例外を返します。
Collection | getCloseSocketEventListeners() 推奨されていません。 このソケットに登録されているクローズ・イベント・リスナーを返します。
ExtendedInputStream | getInputStream() 推奨されていません。 入力ストリームの取得。
ExtendedOutputStream | getOutputStream() 推奨されていません。 出力ストリームの取得。
Socket | getSocket() 推奨されていません。 このオブジェクトの持つソケットオブジェクトを返します。
boolean | isClosed() 推奨されていません。 このソケットが閉じられているかどうかをチェックします。
Throwable | lastError() 推奨されていません。 このインスタンスのメソッド中で最後に発生した例外を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedSocket

public ExtendedSocket(String address,
                      int port)
               throws UnknownHostException,
                      IOException
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
UnknownHostException - ホストの IP アドレスが判定できなかった場合にスローされます。
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

public ExtendedSocket(Socket socket)
               throws IOException
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

protected ExtendedSocket(ExtendedSocket socket)
推奨されていません。
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
メソッドの詳細

getSocket

public Socket getSocket()
推奨されていません。
このオブジェクトの持つソケットオブジェクトを返します。 このメソッドから取得したソケットオブジェクトの入出力ストリームと このオブジェクト自身から取得した入出力ストリームを 同時に利用した場合、データ送受信の整合性が失われてしまう可能性が あります。

戻り値:
ソケットオブジェクト

getInputStream

public ExtendedInputStream getInputStream()
推奨されていません。
入力ストリームの取得。

戻り値:
入力ストリーム

getOutputStream

public ExtendedOutputStream getOutputStream()
推奨されていません。
出力ストリームの取得。

戻り値:
出力ストリーム

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー
導入されたバージョン:
version 4.2

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
推奨されていません。
このソケットに登録されているクローズ・イベント・リスナーを返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection
導入されたバージョン:
version 4.2

lastError

public Throwable lastError()
推奨されていません。
このインスタンスのメソッド中で最後に発生した例外を返します。

戻り値:
最後に発生した例外

clearError

public void clearError()
推奨されていません。
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。

このメソッドを実行すると、次に例外が発生するまで lastError()メソッドは null を返し、 errorIterator()メソッドは空の反復子を返します。

導入されたバージョン:
version 4.0

errorIterator

public Iterator errorIterator()
推奨されていません。
このインスタンスのメソッド実行中に発生した例外を返します。 このメソッドの返す反復子は発生時間順に例外オブジェクトを返します。 反復子の返すオブジェクトは、Throwable クラスと代入互換のある オブジェクトになります。

戻り値:
例外の反復子

close

public void close()
           throws IOException
推奨されていません。
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
推奨されていません。
このソケットが閉じられているかどうかをチェックします。

戻り値:
ソケットが閉じられている場合は true
導入されたバージョン:
version4.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Localhost (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス Localhost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.Localhost
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。

public class Localhost
extends Object
implements Serializable

このクラスは、サーバプロセスの基礎情報を管理します。

導入されたバージョン:
version 4.0
関連項目:
直列化された形式

メソッドの概要
byte[] | getAddress() 推奨されていません。 このコンピュータのＩＰアドレスを返します。
String | getHostAddress() 推奨されていません。 このコンピュータのアドレスを返します。
String | getHostName() 推奨されていません。 このコンピュータのホスト名を返します。
static Localhost | instance() 推奨されていません。 このクラスから生成される唯一のインスタンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

instance

public static Localhost instance()
推奨されていません。
このクラスから生成される唯一のインスタンスを返します。 このメソッドが返すインスタンスは、常に一定で、 VM 内で共有されます。

戻り値:
このクラスのインスタンス

getAddress

public byte[] getAddress()
推奨されていません。
このコンピュータのＩＰアドレスを返します。

戻り値:
IPアドレス

getHostAddress

public String getHostAddress()
推奨されていません。
このコンピュータのアドレスを返します。

戻り値:
アドレス

getHostName

public String getHostName()
推奨されていません。
このコンピュータのホスト名を返します。

戻り値:
ホスト名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.net (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.utility.net
インタフェース
SocketConnectionDistributor
SocketConnectionManager
SocketEventListener
クラス
AbstractSocketConnectionDistributor
ExtendedSocket
Localhost
SocketConnection
SocketPool
例外
UnsupportedNetworkConnectException


jp.co.intra_mart.foundation.utility.net (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.net

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

参照:
説明

インタフェースの概要
SocketConnectionDistributor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionManager | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

クラスの概要
AbstractSocketConnectionDistributor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
ExtendedSocket | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
Localhost | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
SocketConnection | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketPool | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

例外の概要
UnsupportedNetworkConnectException 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.net の説明

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.utility.net クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.foundation.utility.net.SocketPool (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.utility.net.ExtendedSocket
      • class jp.co.intra_mart.foundation.utility.net.SocketConnection
    • class jp.co.intra_mart.foundation.utility.net.Localhost (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException

インタフェース階層

  • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
  • interface jp.co.intra_mart.foundation.utility.net.SocketEventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.utility.net の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.net の使用

jp.co.intra_mart.foundation.utility.net を使用しているパッケージ
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
UnsupportedNetworkConnectException
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

jp.co.intra_mart.foundation.service.client.batch により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

jp.co.intra_mart.foundation.service.client.manager により使用される jp.co.intra_mart.foundation.utility.net のクラス
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。

jp.co.intra_mart.foundation.utility.net により使用される jp.co.intra_mart.foundation.utility.net のクラス
AbstractSocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
ExtendedSocket
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
Localhost
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnectionDistributor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SocketConnection (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス SocketConnection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.ExtendedSocket
        拡張 jp.co.intra_mart.foundation.utility.net.SocketConnection
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。

public abstract class SocketConnection
extends ExtendedSocket

ソケットプール用のスケルトン実装を提供します。

関連項目:
SocketPool

コンストラクタの概要
protected | SocketConnection(ExtendedSocket socket) 推奨されていません。 ソケット入出力インスタンスを構築します。
protected | SocketConnection(Socket socket) 推奨されていません。 ソケット入出力インスタンスを構築します。
protected | SocketConnection(String address, int port) 推奨されていません。 ソケット入出力インスタンスを構築します。
メソッドの概要
abstract  void release()
推奨されていません。 ソケットおよび入出力ストリームの利用を中止します。
クラス jp.co.intra_mart.foundation.utility.net.ExtendedSocket から継承したメソッド
addCloseSocketEventListener, clearError, close, errorIterator, getCloseSocketEventListeners, getInputStream, getOutputStream, getSocket, isClosed, lastError
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnection

protected SocketConnection(String address,
                           int port)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(Socket socket)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(ExtendedSocket socket)
                    throws IOException
推奨されていません。
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

release

public abstract void release()
                      throws IOException
推奨されていません。
ソケットおよび入出力ストリームの利用を中止します。

このインスタンスの利用が終了したら、必ず呼び出して下さい。
このメソッドを呼び出さないと、プール領域中のリソースが完全には 開放されません。
また、スーパークラス ExtendedSocket の close メソッドを呼び出した場合も プール中のリソースが完全に開放されない可能性があります。

リソースの開放は、プールオブジェクトが必要に応じて行います。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketConnectionDistributor

既知のサブインタフェースの一覧:
SocketConnectionManager
既知の実装クラスの一覧:
AbstractSocketConnectionDistributor, SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。

public interface SocketConnectionDistributor

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

メソッドの概要
void | clean() 推奨されていません。 プール中のコネクションをすべて破棄します。
SocketConnection | connection() 推奨されていません。 コネクションの取得。
void | destroy() 推奨されていません。 このプールを破棄します。

メソッドの詳細

connection

public SocketConnection connection()
                            throws IOException
推奨されていません。
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

destroy

public void destroy()
推奨されていません。
このプールを破棄します。

clean

public void clean()
推奨されていません。
プール中のコネクションをすべて破棄します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketConnectionManager

すべてのスーパーインタフェース:
SocketConnectionDistributor
既知の実装クラスの一覧:
SocketPool
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。

public interface SocketConnectionManager
extends SocketConnectionDistributor

通信ソケットをプールする機能のインターフェースです。

導入されたバージョン:
version 4.2

メソッドの概要
int | getCapacity() 推奨されていません。 コネクション作成最大数の取得。
int | getSize() 推奨されていません。 このプールが現在管理しているコネクション数です。
int | usableConnection() 推奨されていません。 現在待機中のコネクションをです。
インタフェース jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

メソッドの詳細

getCapacity

public int getCapacity()
推奨されていません。
コネクション作成最大数の取得。

戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
推奨されていません。
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
推奨されていません。
現在待機中のコネクションをです。

戻り値:
待機中のコネクション数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
インタフェース SocketEventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。

public interface SocketEventListener

通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

ソケットに関するイベント通知側と組み合わせて利用することにより、 ソケットに関する特定のイベント発生時に独自の処理を実行することができます。

メソッドの概要
 void handleSocketEvent(ExtendedSocket socket)
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。

メソッドの詳細

handleSocketEvent

public void handleSocketEvent(ExtendedSocket socket)
                       throws IOException
推奨されていません。
ソケットに関するイベント発生時に呼び出されるメソッド。 サブクラスは、このメソッドを実装することにより、特定のソケットに関する イベントの発生を知ることができます。

パラメータ:
socket - イベントの発生したソケット
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketPool (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス SocketPool

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
        拡張 jp.co.intra_mart.foundation.utility.net.SocketPool
すべての実装インタフェース:
SocketConnectionDistributor, SocketConnectionManager
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。

public class SocketPool
extends AbstractSocketConnectionDistributor
implements SocketConnectionManager

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

コンストラクタの概要
SocketPool(String address, int port)
推奨されていません。 ソケットプールを構築します。
SocketPool(String address, int port, int capacity)
推奨されていません。 ソケットプールを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | addCreateSocketEventListener(SocketEventListener listener) 推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | clean() 推奨されていません。 プール中のコネクションをすべて破棄します。
SocketConnection | connection() 推奨されていません。 コネクションの取得。
void | destroy() 推奨されていません。 このプールを破棄します。
boolean | eject(SocketConnection connection) 推奨されていません。 指定コネクションをこのプールの管理から切り離します。
protected void | finalize() 推奨されていません。 このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
int | getCapacity() 推奨されていません。 コネクション作成最大数の取得。
Collection | getCloseSocketEventListeners() 推奨されていません。 このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
Collection | getCreateSocketEventListeners() 推奨されていません。 このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
int | getSize() 推奨されていません。 このプールが現在管理しているコネクション数です。
int | usableConnection() 推奨されていません。 現在待機中のコネクションをです。
クラス jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor から継承したメソッド
createSocket, getAddress, getPort
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketPool

public SocketPool(String address,
                  int port)
推奨されていません。
ソケットプールを構築します。

このプールで管理できるソケットコネクションは 1 個になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート

SocketPool

public SocketPool(String address,
                  int port,
                  int capacity)
推奨されていません。
ソケットプールを構築します。

コネクションは動的に生成されます。 capacity 個よりも多くのコネクション要求があった場合、 コネクションが開放されるまで待ち状態になります。
capacity にはプールの性質上、 1 以上の値を指定して下さい。 capacity に 1 より小さな値を指定した場合、プール数は 1 になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
capacity - 接続コネクションの最大数
メソッドの詳細

addCreateSocketEventListener

public void addCreateSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールで新規にソケットが 作成されたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCreateSocketEventListeners

public Collection getCreateSocketEventListeners()
推奨されていません。
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
推奨されていません。
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールのソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
推奨されていません。
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

getCapacity

public int getCapacity()
推奨されていません。
コネクション作成最大数の取得。

定義:
インタフェース SocketConnectionManager 内の getCapacity
戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
推奨されていません。
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

定義:
インタフェース SocketConnectionManager 内の getSize
戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
推奨されていません。
現在待機中のコネクションをです。

定義:
インタフェース SocketConnectionManager 内の usableConnection
戻り値:
待機中のコネクション数

connection

public SocketConnection connection()
                            throws IOException
推奨されていません。
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

定義:
インタフェース SocketConnectionDistributor 内の connection
戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

eject

public boolean eject(SocketConnection connection)
推奨されていません。
指定コネクションをこのプールの管理から切り離します。

指定コネクションがこのプールに管理されていたものなら、 このメソッド実行後はこのプールの管理するコネクションが１つ減少するので、 新たにコネクションを作成することができるようになります。

指定のコネクションをこのプールが管理していて他のスレッドによって 使用（connection() メソッドにより取得）されていない場合 true を 返します。指定のコネクションがこのプールにより管理されているもの であった場合でも、他のスレッドにより使用中の場合は false を返します。

パラメータ:
connection - 管理から切り離すコネクション
戻り値:
コネクションの切り離しに成功した場合 true

destroy

public void destroy()
推奨されていません。
このプールを破棄します。

定義:
インタフェース SocketConnectionDistributor 内の destroy

clean

public void clean()
推奨されていません。
プール中のコネクションをすべて破棄します。

定義:
インタフェース SocketConnectionDistributor 内の clean

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。 SocketPool クラスは、このメソッドによりオブジェクトの破棄前に リソースのクリーンアップをします。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UnsupportedNetworkConnectException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.net
クラス UnsupportedNetworkConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.io.IOException
                拡張 jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

public class UnsupportedNetworkConnectException
extends IOException

関連項目:
直列化された形式

コンストラクタの概要
UnsupportedNetworkConnectException()
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String arg0)
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException()
推奨されていません。
Constructor for UnsupportedNetworkConnectException.

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException(String arg0)
推奨されていません。
Constructor for UnsupportedNetworkConnectException.

パラメータ:
arg0 -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter の使用

AbstractMessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での AbstractMessageReporter の使用

jp.co.intra_mart.foundation.utility.report での AbstractMessageReporter のサブクラス
class | FileReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
class | MultiCastReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
class | PrintStreamReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.EverydayConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.EverydayConditioner の使用

jp.co.intra_mart.foundation.utility.report.EverydayConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FileReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FileReporter の使用

jp.co.intra_mart.foundation.utility.report.FileReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FileSizeConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FileSizeConditioner の使用

jp.co.intra_mart.foundation.utility.report.FileSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の使用

FilterMessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での FilterMessageReporter の使用

jp.co.intra_mart.foundation.utility.report での FilterMessageReporter のサブクラス
class | LineReportFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
class | ReportLevelFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
class | RepresentativeReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.LineReportFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.LineReportFilter の使用

jp.co.intra_mart.foundation.utility.report.LineReportFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.MessageReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.MessageReporter の使用

MessageReporter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での MessageReporter の使用

MessageReporter を実装している jp.co.intra_mart.foundation.utility.report のクラス
class | AbstractMessageReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
class | FileReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
class | FilterMessageReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
class | LineReportFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
class | MultiCastReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
class | PrintStreamReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
class | ReportLevelFilter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
class | RepresentativeReporter 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

MessageReporter として宣言されている jp.co.intra_mart.foundation.utility.report のフィールド
protected  MessageReporter FilterMessageReporter.out
推奨されていません。 基礎出力ストリームです。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
void | MultiCastReporter.addReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
boolean | MultiCastReporter.hasReporter(MessageReporter reporter) 推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | MultiCastReporter.removeReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
ReportLevelFilter(MessageReporter out, int level)
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
LineReportFilter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
FilterMessageReporter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.MultiCastReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.MultiCastReporter の使用

jp.co.intra_mart.foundation.utility.report.MultiCastReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner の使用

jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.PeriodicConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.PeriodicConditioner の使用

jp.co.intra_mart.foundation.utility.report.PeriodicConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.PrintStreamReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.PrintStreamReporter の使用

jp.co.intra_mart.foundation.utility.report.PrintStreamReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.ReportFileConditioner の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.ReportFileConditioner の使用

ReportFileConditioner を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportFileConditioner の使用

ReportFileConditioner を実装している jp.co.intra_mart.foundation.utility.report のクラス
class | EverydayConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
class | FileSizeConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
class | OutputSizeConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
class | PeriodicConditioner 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。

ReportFileConditioner 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
void | FileReporter.addConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
boolean | FileReporter.removeConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.ReportFileWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.ReportFileWriter の使用

ReportFileWriter を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportFileWriter の使用

ReportFileWriter として宣言されている jp.co.intra_mart.foundation.utility.report のフィールド
protected  ReportFileWriter FileReporter.out
推奨されていません。 基礎出力ストリームです。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のメソッド
boolean | ReportFileConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | PeriodicConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | OutputSizeConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | FileSizeConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | EverydayConditioner.expiration(ReportFileWriter writer) 推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.foundation.utility.report のコンストラクタ
FileReporter(ReportFileWriter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.utility.report.ReportLevel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.report.ReportLevel の使用

ReportLevel を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report での ReportLevel の使用

ReportLevel を実装している jp.co.intra_mart.foundation.utility.report のクラス
 class ReportLevelFilter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の使用

jp.co.intra_mart.foundation.utility.report.ReportLevelFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.utility.report.RepresentativeReporter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.utility.report.RepresentativeReporter の使用

jp.co.intra_mart.foundation.utility.report.RepresentativeReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractMessageReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス AbstractMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
FileReporter, MultiCastReporter, PrintStreamReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。

public abstract class AbstractMessageReporter
extends Object
implements MessageReporter

メッセージ出力用のスケルトンクラスです。

サブクラスでは、report メソッドをオーバーライドして、 任意の出力先にメッセージを出力する機能を実装する必要があります。

導入されたバージョン:
version 3.2

コンストラクタの概要
protected AbstractMessageReporter()
推奨されていません。 唯一のコンストラクタ。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
abstract void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractMessageReporter

protected AbstractMessageReporter()
推奨されていません。
唯一のコンストラクタ。

メソッドの詳細

report

public abstract void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(String.valueOf(data))

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EverydayConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス EverydayConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.EverydayConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。

public class EverydayConditioner
extends Object
implements ReportFileConditioner

このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 指定時間になった(指定時間を経過した)ときに、 メッセージファイルのローテイト機能イベントを発生させることができます。 時間のチェックは時および分によるものなので、FileReporter の中で リフレッシュイベントは毎日発生することになります。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
EverydayConditioner(int hours, int minutes)
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes)
                    throws IllegalArgumentException
推奨されていません。
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
例外:
IllegalArgumentException - 引数が有効範囲外の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
このオブジェクトの作成時に指定された時刻を経過して最初の呼び出し時 の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FileReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.FileReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。

public class FileReporter
extends AbstractMessageReporter

メッセージのファイル出力機能を提供します。

このクラスは、report メソッドで渡されたメッセージを指定のファイルに 出力します。

導入されたバージョン:
version 3.2

フィールドの概要
protected  ReportFileWriter out
推奨されていません。 基礎出力ストリームです。
コンストラクタの概要
FileReporter(ReportFileWriter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | addConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
void | close() 推奨されていません。 このオブジェクトを閉じます。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
boolean | removeConditioner(ReportFileConditioner conditioner) 推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected ReportFileWriter out
推奨されていません。
基礎出力ストリームです。

コンストラクタの詳細

FileReporter

public FileReporter(ReportFileWriter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

addConditioner

public void addConditioner(ReportFileConditioner conditioner)
推奨されていません。
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
引数が null の場合は、何の効果もありません。 また、conditioner が既に登録済みのインスタンスである場合、 追加登録はされません。

パラメータ:
conditioner - 追加する ReportFileConditioner のインスタンス

removeConditioner

public boolean removeConditioner(ReportFileConditioner conditioner)
推奨されていません。
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
引数が null の場合は、何の効果もありません。

パラメータ:
conditioner - 削除する ReportFileConditioner のインスタンス
戻り値:
指定のオブジェクトを削除できた場合 true。

report

public void report(String message)
推奨されていません。
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileSizeConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FileSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FileSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。

public class FileSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
FileSizeConditioner(long max)
推奨されていません。 メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSizeConditioner

public FileSizeConditioner(long max)
                    throws IllegalArgumentException
推奨されていません。
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、メッセージファイルが指定の大きさ(max)以上に なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルサイズが、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterMessageReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス FilterMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
LineReportFilter, ReportLevelFilter, RepresentativeReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。

public class FilterMessageReporter
extends Object
implements MessageReporter

メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。

基礎出力ストリームにメッセージを出力する前にメッセージを加工したりする 追加機能を提供するクラスを作成するために利用することができます。

このクラスは、単に MessageReporter の全てのメソッドを オーバーライドし、各要求を基礎出力ストリームに渡す機能を提供しています。 サブクラスでは、メソッドを追加したり、必要に応じてメソッドをオーバーライド することがあります。

導入されたバージョン:
version 3.2

フィールドの概要
protected  MessageReporter out
推奨されていません。 基礎出力ストリームです。
コンストラクタの概要
FilterMessageReporter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected MessageReporter out
推奨されていません。
基礎出力ストリームです。

コンストラクタの詳細

FilterMessageReporter

public FilterMessageReporter(MessageReporter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に message を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドでは、基礎出力リポートオブジェクトも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineReportFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス LineReportFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.LineReportFilter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。

public class LineReportFilter
extends FilterMessageReporter

メッセージを行出力するためのフィルタークラスです。

このクラスを利用すると、report メソッドに渡されたメッセージ文字列に 改行コードを付加して、行出力することができます。
以下のようなプログラムにより、ログファイルをログファイルを作成することが できます。

FIle logFile = new File("test.log");
ReportFileWriter writer = new ReportFileWriter(logFile);
FileReporter writer = new FileReporter(writer);
MessageReporter reporter = new LineReportFilter(writer);
これで、変数 reporter の report メソッドを呼び出す毎に、 ファイル test.log に report メソッド指定したメッセージが １行として出力されます。

導入されたバージョン:
version 3.2
関連項目:
ReportLevel

フィールドの概要
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
LineReportFilter(MessageReporter out)
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
メソッドの概要
void | report(Object data) 推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LineReportFilter

public LineReportFilter(MessageReporter out)
推奨されていません。
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。
このメソッドは、基礎出力ストリームに対して、message に 改行コードを付加してメッセージを１行出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース MessageReporter

既知の実装クラスの一覧:
AbstractMessageReporter, FilterMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。

public interface MessageReporter

メッセージ出力のためのインターフェースです。

このインターフェースを実装したクラスでは、report メソッドで 指定されたメッセージを任意の出力先に対して出力する機能を提供します。

導入されたバージョン:
version 3.2

メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。

メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。

パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultiCastReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス MultiCastReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.MultiCastReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。

public class MultiCastReporter
extends AbstractMessageReporter

メッセージを複数のストリームに出力するためのフィルタークラスです。

このクラスは、MessageReporter インターフェースを実装したクラスに対する フィルタークラスとして働きます。 report メソッドに渡されたメッセージデータは、指定された複数の MessageReporter インターフェースすべてに渡されます。
このフィルタークラスを利用することにより、複数の MessageReporter に 対して同じメッセージを渡すことができるため、メッセージ出力プログラムを 効率的に記述することができます。

メッセージの出力先となる MessageReporter は、addReporter メソッドで 定義します。addReporter メソッドでの定義順と、実際の実行順は 保証されません。

導入されたバージョン:
version 3.2

コンストラクタの概要
MultiCastReporter()
推奨されていません。 唯一のコンストラクタ。
メソッドの概要
void | addReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
Iterator | getReporters() 推奨されていません。 セット内の要素についての反復子を返します。
boolean | hasReporter(MessageReporter reporter) 推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | removeReporter(MessageReporter reporter) 推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultiCastReporter

public MultiCastReporter()
推奨されていません。
唯一のコンストラクタ。

メソッドの詳細

addReporter

public void addReporter(MessageReporter reporter)
推奨されていません。
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。 すでに指定のオブジェクトを要素としてもっていた場合、 このメソッドは何も行いません。

パラメータ:
reporter - セットに追加される要素

hasReporter

public boolean hasReporter(MessageReporter reporter)
推奨されていません。
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。

パラメータ:
reporter - セットに含まれているかチェックする要素
戻り値:
セット内に指定された要素がある場合は true

removeReporter

public boolean removeReporter(MessageReporter reporter)
推奨されていません。
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

パラメータ:
reporter - セットにあった場合に削除されるオブジェクト
戻り値:
指定された要素がセット内にあった場合は true

getReporters

public Iterator getReporters()
推奨されていません。
セット内の要素についての反復子を返します。 反復子から取得される各要素は、addReporter メソッドにより追加された リポーターオブジェクトになります。 各要素の取得順は保証されません。 このオブジェクトが閉じられている場合 null を返します。

戻り値:
セット内の要素についての反復子

report

public void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス AbstractMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このオブジェクトの持つすべての Reporter オブジェクトを閉じて、 リソースを開放します。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 このオブジェクトの持つすべての Reporter オブジェクトをフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OutputSizeConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス OutputSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。

public class OutputSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
OutputSizeConditioner(long max)
推奨されていません。 メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

OutputSizeConditioner

public OutputSizeConditioner(long max)
                      throws IllegalArgumentException
推奨されていません。
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
このオブジェクトは、ログファイルへ書き出したメッセージの量が 一定(max)以上の大きさに なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルへの出力文字数が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility.report (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.utility.report
インタフェース
MessageReporter
ReportFileConditioner
ReportLevel
クラス
AbstractMessageReporter
EverydayConditioner
FileReporter
FileSizeConditioner
FilterMessageReporter
LineReportFilter
MultiCastReporter
OutputSizeConditioner
PeriodicConditioner
PrintStreamReporter
ReportFileWriter
ReportLevelFilter
RepresentativeReporter


jp.co.intra_mart.foundation.utility.report (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.report

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
ReportFileConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportLevel | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

クラスの概要
AbstractMessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
EverydayConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
FileReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
FileSizeConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
FilterMessageReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
LineReportFilter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
MultiCastReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
OutputSizeConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
PeriodicConditioner | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
PrintStreamReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
ReportFileWriter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportLevelFilter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
RepresentativeReporter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility.report の説明

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.utility.report クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility.report の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.FileReporter
      • class jp.co.intra_mart.foundation.utility.report.MultiCastReporter
      • class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
    • class jp.co.intra_mart.foundation.utility.report.EverydayConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.LineReportFilter
      • class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter (implements jp.co.intra_mart.foundation.utility.report.ReportLevel)
      • class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
    • class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class java.io.Writer
      • class jp.co.intra_mart.foundation.utility.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.foundation.utility.report.MessageReporter
  • interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
  • interface jp.co.intra_mart.foundation.utility.report.ReportLevel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.utility.report の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility.report の使用

jp.co.intra_mart.foundation.utility.report を使用しているパッケージ
jp.co.intra_mart.foundation.utility.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.utility.report により使用される jp.co.intra_mart.foundation.utility.report のクラス
AbstractMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
FilterMessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportFileWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportLevel
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PeriodicConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス PeriodicConditioner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.PeriodicConditioner
すべての実装インタフェース:
ReportFileConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。

public class PeriodicConditioner
extends Object
implements ReportFileConditioner

このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 一定期間の経過に合わせてに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 3.2
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
PeriodicConditioner(long millis)
推奨されていません。 タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PeriodicConditioner

public PeriodicConditioner(long millis)
                    throws IllegalArgumentException
推奨されていません。
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、指定の時間が経過した時に リフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - millis がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
引数 outputSize の値が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrintStreamReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス PrintStreamReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。

public class PrintStreamReporter
extends AbstractMessageReporter

メッセージ出力用クラスです。

このクラスは、指定の PrintStream に対してメッセージを出力するための 機能を実装しています。 例えば、このクラスのコンストラクタの引数に java.lang.System.out を指定した 場合、標準出力に対してメッセージを出力することができます。
このクラスの特徴は、report メソッドに渡されたメッセージを PrintStream の println メソッドに渡します。 これにより、report メソッドの呼び出し毎にメッセージを改行付きで 指定の PrintStream に出力することができます（１行毎に出力）。

導入されたバージョン:
version 3.2

コンストラクタの概要
PrintStreamReporter(PrintStream out)
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 このオブジェクトを閉じます。
void | flush() 推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrintStreamReporter

public PrintStreamReporter(PrintStream out)
推奨されていません。
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
推奨されていません。
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
推奨されていません。
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileConditioner (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース ReportFileConditioner

既知の実装クラスの一覧:
EverydayConditioner, FileSizeConditioner, OutputSizeConditioner, PeriodicConditioner
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。

public interface ReportFileConditioner

このクラスは、ReportFileWriter の初期化チェックのインターフェースです。

このクラスは FileReporter クラスにより ReportFileWriter へのメッセージ 書き出し前に呼び出されます。
このクラスは、FileReporter および ReportFileWriter オブジェクトと 組み合わせて使います。 これらのクラスと連携することにより、メッセージファイルの ローテイト機能などを実装することができます。

導入されたバージョン:
version 3.2

メソッドの概要
 boolean expiration(ReportFileWriter writer)
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。

メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
推奨されていません。
メッセージファイルを再作成する必要があるかどうかを判定します。
このメソッドは、FileReporter クラスにより呼び出されます。 真値(true)を返すと、ReportFileWriter は現在のログファイルに対して 初期化処理を行います。 メッセージファイルの初期化処理に関しては、 ReportFileWriter クラス(または、そのサブクラス)により行われます。

パラメータ:
writer - メッセージファイルへの出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileWriter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス ReportFileWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.foundation.utility.report.ReportFileWriter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。

public class ReportFileWriter
extends Writer

メッセージをファイルに出力するストリームクラスです。

このクラスは、メッセージを指定のファイルに対して出力するための スケルトンです。 また、このクラスは reset メソッドをオーバーライドすることにより、 ファイルのローテイト機能などを実装することができます。

導入されたバージョン:
version 3.2

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReportFileWriter(File f)
推奨されていません。 ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
メソッドの概要
void | close() 推奨されていません。 ストリームを閉じてフラッシュします。
protected Writer | createWriter() 推奨されていません。 メッセージをファイルへ書き出すための出力ストリームを作成します。
Writer | currentWriter() 推奨されていません。 このオブジェクトが文字を書き出している基礎 Writer を返します。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 ストリームをフラッシュします。
File | getFile() 推奨されていません。 このオブジェクトが文字を書き出すファイルを取得します。
long | length() 推奨されていません。 このライターの出力文字数を取得します。
protected void | reconstruction() 推奨されていません。 現在使用中の Writer をリセットします。
protected Writer | reset(Writer writer) 推奨されていません。 文字の出力ストリームをリセットします。
void | write(char[] cbuf, int off, int len) 推奨されていません。 基礎ストリームに文字を出力します。
クラス java.io.Writer から継承したメソッド
write, write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReportFileWriter

public ReportFileWriter(File f)
                 throws IOException
推奨されていません。
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。

パラメータ:
f - このライターで書き出すファイル
例外:
IOException - 入出力エラー
メソッドの詳細

getFile

public File getFile()
推奨されていません。
このオブジェクトが文字を書き出すファイルを取得します。
このメソッドは、このオブジェクトの作成時にコンストラクタの引数として 与えられた File オブジェクトへの参照を返します。

戻り値:
このライターで書き出すファイル

createWriter

protected Writer createWriter()
                       throws IOException
推奨されていません。
メッセージをファイルへ書き出すための出力ストリームを作成します。

このメソッドは、単に getFile メソッドが返すファイルに対して 文字を書き出すための出力ストリームを作成して返します。 このメソッドの返す出力ストリームを使うことで、 getFile メソッドの返す ファイルに対してメッセージを追記していくことができます。
メッセージを任意の文字コードに変換したり、出力バッファを備えた Writer オブジェクトを作成する必要がある場合には、サブクラスで このメソッドをオーバーライドして実装して下さい。

戻り値:
出力ストリーム
例外:
IOException

length

public long length()
推奨されていません。
このライターの出力文字数を取得します。
このメソッドで返される文字数は、このファイルに対して 現在までに出力した文字数です。 文字数カウンタは、reset メソッドを実行することにより 0 (ゼロ)にリセットされます。

戻り値:
出力文字数

currentWriter

public Writer currentWriter()
推奨されていません。
このオブジェクトが文字を書き出している基礎 Writer を返します。

戻り値:
基礎 Writer オブジェクト

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
推奨されていません。
基礎ストリームに文字を出力します。
このメソッドをサブクラスがオーバーライドすることにより、 バッファ機能などを実装することができます。 ただし、このメソッドをオーバーライドしたサブクラスは、 同時に length メソッドもオーバーライドする必要があります。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException

reconstruction

protected void reconstruction()
                       throws IOException
推奨されていません。
現在使用中の Writer をリセットします。
このメソッドは、FileReporter クラスにより呼び出されます。 FileReporter オブジェクトでは、ReportFileConditioner オブジェクトが ファイルの初期化を必要と判断した場合に、このメソッドを呼び出して、 Writer の初期化を求めてきます。 これにより、リポートファイルのローテイト機能などを 実装することができます。

例外:
IOException

reset

protected Writer reset(Writer writer)
                throws IOException
推奨されていません。
文字の出力ストリームをリセットします。

このメソッドは reset メソッドに呼び出されます。
このメソッドは、単に引数のストリーム(writer)をそのまま リターンします。ファイルのローテイト機能などを実装する場合、 サブクラスでこのメソッドをオーバーライドして下さい。

パラメータ:
writer - 現在のストリーム
戻り値:
新しいストリーム
例外:
IOException

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。
ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字の目的の宛先にただちに文字を書き込みます。 宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。 つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream の すべてのバッファをフラッシュします。

サブクラスで、文字のバッファリング機能を実装している場合、 このメソッドをオーバーライドしてバッファに保存している 文字をフラッシュするように実装しなければいけません。

例外:
IOException - 入出力エラーが発生した場合

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportLevel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
インタフェース ReportLevel

既知の実装クラスの一覧:
ReportLevelFilter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。

public interface ReportLevel

メッセージレベルのインターフェースです。

このインターフェースは、定数値化したメッセージレベルを示します。 すべてのメッセージに関して、必ずしもこのインターフェースで定義されている レベル値を使う必要はありませんが、このインターフェースを利用することにより プログラム全体でレベル値を統一することができます。

導入されたバージョン:
version 3.2

フィールドの概要
static int | MAX_VALUE 推奨されていません。 レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
static int | MIN_VALUE 推奨されていません。 レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
static int | TYPE_DEBUG 推奨されていません。 デバッグレベル。
static int | TYPE_ERROR 推奨されていません。 エラーレベル。
static int | TYPE_REPORT 推奨されていません。 通常の情報レベル。
static int | TYPE_WARNING 推奨されていません。 警告レベル。

フィールドの詳細

MIN_VALUE

public static final int MIN_VALUE
推奨されていません。
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。

関連項目:
定数フィールド値

MAX_VALUE

public static final int MAX_VALUE
推奨されていません。
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。

関連項目:
定数フィールド値

TYPE_DEBUG

public static final int TYPE_DEBUG
推奨されていません。
デバッグレベル。 デバッグ情報を出力する場合に利用します。

関連項目:
定数フィールド値

TYPE_REPORT

public static final int TYPE_REPORT
推奨されていません。
通常の情報レベル。
常に以下の関係が成り立ちます。

TYPE_DEBUG < TYPE_REPORT

関連項目:
定数フィールド値

TYPE_WARNING

public static final int TYPE_WARNING
推奨されていません。
警告レベル。 警告メッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_REPORT < TYPE_WARNING

関連項目:
定数フィールド値

TYPE_ERROR

public static final int TYPE_ERROR
推奨されていません。
エラーレベル。 エラーメッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_WARNING < TYPE_ERROR

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ReportLevelFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス ReportLevelFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.ReportLevelFilter
すべての実装インタフェース:
MessageReporter, ReportLevel
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。

public class ReportLevelFilter
extends FilterMessageReporter
implements ReportLevel

メッセージの出力制御を行うためのフィルタークラスです。

このクラスを利用することにより、メッセージをメッセージレベルにより、 出力制御を行うことができます。

導入されたバージョン:
version 3.2
関連項目:
ReportLevel

フィールドの概要
protected  int datumpoint
推奨されていません。 このリポーターがフィルタリングする基準レベル値
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
インタフェース jp.co.intra_mart.foundation.utility.report.ReportLevel から継承したフィールド
MAX_VALUE, MIN_VALUE, TYPE_DEBUG, TYPE_ERROR, TYPE_REPORT, TYPE_WARNING
コンストラクタの概要
ReportLevelFilter(MessageReporter out, int level)
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(Object data, int level) 推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
void | report(String message, int level) 推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

datumpoint

protected int datumpoint
推奨されていません。
このリポーターがフィルタリングする基準レベル値

コンストラクタの詳細

ReportLevelFilter

public ReportLevelFilter(MessageReporter out,
                         int level)
推奨されていません。
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
推奨されていません。
メッセージを出力します。
このメソッドは、以下の呼出と同じです。

report(message, ReportLevel.MAX_VALUE)

つまり、メッセージ message は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(String message,
                   int level)
推奨されていません。
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
message - メッセージ
level - メッセージレベル

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(data, ReportLevel.MAX_VALUE)

つまり、メッセージデータ data は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

report

public void report(Object data,
                   int level)
推奨されていません。
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
data - データ
level - メッセージレベル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RepresentativeReporter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility.report
クラス RepresentativeReporter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
        拡張 jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
すべての実装インタフェース:
MessageReporter
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。

public class RepresentativeReporter
extends FilterMessageReporter

メッセージ出力をイベント処理するためのフィルタークラスです。

このクラスを利用することにより、メッセージの MessageReporter における 処理を現在のスレッドと並列実行させることができます。 これにより、このクラスの report メソッドと、出力先となる MessageReporter の report メソッドの実行は非同期に処理されます。

このクラスを利用することのメリットは、メッセージの出力処理を 待たなくても、現在のスレッドの実行を継続できることにあります。 逆に、このクラスを利用することにより、メッセージ出力処理と現在のスレッド処理 がスレッドセーフであることが保証されなければなりません。
report メソッドで指定されたメッセージはキューに蓄積され、 現在のスレッドと異なるメッセージ処理専用のスレッドで 基礎出力ストリームに渡されます。 メッセージの出力処理は、現在のスレッドと非同期ですが、 report メソッドの実行順とメッセージの出力順は保証されます。

導入されたバージョン:
version 3.2

フィールドの概要
クラス jp.co.intra_mart.foundation.utility.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
RepresentativeReporter(MessageReporter out, EventQueueController queue)
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
メソッドの概要
boolean | canReport() 推奨されていません。 このストリームが書き込み可能かどうかをチェックします。
void | close() 推奨されていません。 ストリームを閉じます。
void | flush() 推奨されていません。 ストリームをフラッシュします。
void | report(Object data) 推奨されていません。 data をメッセージとして出力します。
void | report(String message) 推奨されていません。 メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RepresentativeReporter

public RepresentativeReporter(MessageReporter out,
                              EventQueueController queue)
推奨されていません。
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

canReport

public boolean canReport()
推奨されていません。
このストリームが書き込み可能かどうかをチェックします。

戻り値:
ストリームの書き込みが可能な場合 true、そうでない場合 false。

report

public void report(String message)
推奨されていません。
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
推奨されていません。
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
推奨されていません。
ストリームを閉じます。
このメソッドは、ストリームを閉じる前に flush メソッドを実行します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス FilterMessageReporter 内の close
例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
推奨されていません。
ストリームをフラッシュします。

ストリームに蓄積されているすべてのメッセージイベントを処理します。 このメソッドを実行した場合、現在のスレッドで メッセージが処理されます。また、このメソッドはすべてのメッセージ出力 処理が完了するまでブロックします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス FilterMessageReporter 内の flush
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractDualComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス AbstractDualComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
直系の既知のサブクラス:
MultiComparator, NodeTypeComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。

public abstract class AbstractDualComparator
extends Object
implements DualComparator

２つのコンパレータを使用してソートを行うクラスです。
比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 もし、その比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
AbstractDualComparator()
推奨されていません。 新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.utility.DualComparator から継承したメソッド
getPrimaryComparator, getSecondaryComparator
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

AbstractDualComparator

public AbstractDualComparator()
推奨されていません。
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は ０、最初の引数が ２ 番目の引 数より大きい場合は正の整数を返します。
このメソッドは ２ つのコンパレータを使用して比較を行いその結果を返します。 比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 比較の結果が０でないときは、その比較した結果を返します。もし比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Counter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス Counter

java.lang.Object
    拡張 java.lang.Number
        拡張 jp.co.intra_mart.foundation.utility.Counter
すべての実装インタフェース:
Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。

public class Counter
extends Number
implements Serializable

このクラスは、カウンター機能を提供します。

ある数値を基準として１ずつ増やしたり１ずつ減らしたりすることができます。

導入されたバージョン:
version4.2
関連項目:
直列化された形式

コンストラクタの概要
Counter()
推奨されていません。 カウンターオブジェクトを作成します。
Counter(long initValue)
推奨されていません。 指定の初期値でカウンターオブジェクトを作成します。
メソッドの概要
long | decrement() 推奨されていません。 カウンターの値を１だけ減少させます。
double | doubleValue() 推奨されていません。 カウンターの現在の値を double 型として返します。
float | floatValue() 推奨されていません。 カウンターの現在の値を float 型として返します。
long | increment() 推奨されていません。 カウンターの値を１だけ増加させます。
int | intValue() 推奨されていません。 カウンターの現在の値を int 型として返します。
long | longValue() 推奨されていません。 カウンターの現在の値を long 型として返します。
クラス java.lang.Number から継承したメソッド
byteValue, shortValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Counter

public Counter()
推奨されていません。
カウンターオブジェクトを作成します。

初期値は０です。したがって、このコンストラクタの呼び出しは、 以下の呼び出しと同義です。
new Counter(0)

Counter

public Counter(long initValue)
推奨されていません。
指定の初期値でカウンターオブジェクトを作成します。

パラメータ:
initValue - カウンターの初期値
メソッドの詳細

increment

public long increment()
推奨されていません。
カウンターの値を１だけ増加させます。

戻り値:
変化後のカウンターの値

decrement

public long decrement()
推奨されていません。
カウンターの値を１だけ減少させます。

戻り値:
変化後のカウンターの値

intValue

public int intValue()
推奨されていません。
カウンターの現在の値を int 型として返します。 値を丸めたり切り捨てたりすることもあります。

戻り値:
このオブジェクトが表す数値を int 型に変換した値;

longValue

public long longValue()
推奨されていません。
カウンターの現在の値を long 型として返します。

戻り値:
このオブジェクトが表す数値を long 型に変換した値

floatValue

public float floatValue()
推奨されていません。
カウンターの現在の値を float 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を float 型に変換した値

doubleValue

public double doubleValue()
推奨されていません。
カウンターの現在の値を double 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を double 型に変換した値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DualComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース DualComparator

すべてのスーパーインタフェース:
Comparator, Serializable
既知の実装クラスの一覧:
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。

public interface DualComparator
extends Serializable, Comparator

２つのコンパレータを使用してソートを行うためのインターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Comparator | getPrimaryComparator() 推奨されていません。 １番目コンパレータを取得します。
Comparator | getSecondaryComparator() 推奨されていません。 ２番目コンパレータを取得します。
インタフェース java.util.Comparator から継承したメソッド
compare, equals

メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
推奨されていません。
１番目コンパレータを取得します。

戻り値:
１番目のコンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
推奨されていません。
２番目コンパレータを取得します。

戻り値:
２番目のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ErrorEvent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ErrorEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.ErrorEvent
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。

public class ErrorEvent
extends Object

例外をイベントとして扱うためのプロトコルです。

イベントリスナー(インターフェース ErrorEventListener を実装したクラス) のオーナーオブジェクトは、例外の発生時にこのクラスのインスタンスを 生成して各リスナーに通知する義務があります。

関連項目:
ErrorEventListener

コンストラクタの概要
ErrorEvent(Throwable t, Object obj)
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable t, String msg, Object obj)
推奨されていません。 エラーを通知するためのイベントを構築します。
メソッドの概要
Throwable | getException() 推奨されていません。 通知されたエラーまたは例外を取得します。
String | getMessage() 推奨されていません。 通知されたエラーメッセージを取得します。
Object | getObject() 推奨されていません。 通知されたエラー発生オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorEvent

public ErrorEvent(Throwable t,
                  Object obj)
推奨されていません。
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
obj - エラーの発生したオブジェクト

ErrorEvent

public ErrorEvent(Throwable t,
                  String msg,
                  Object obj)
推奨されていません。
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
msg - エラーメッセージ
obj - エラーの発生したオブジェクト
メソッドの詳細

getObject

public Object getObject()
推奨されていません。
通知されたエラー発生オブジェクトを取得します。

戻り値:
通知されたエラーオブジェクト

getMessage

public String getMessage()
推奨されていません。
通知されたエラーメッセージを取得します。 メッセージが通知されていない場合、通知されたエラーのメッセージを 返します。

戻り値:
通知されたエラーメッセージ
関連項目:
Throwable.getMessage()

getException

public Throwable getException()
推奨されていません。
通知されたエラーまたは例外を取得します。

戻り値:
通知されたエラーまたは例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ErrorEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース ErrorEventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。

public interface ErrorEventListener

例外をイベントとして扱うためのスケルトン実装を提供します。

このインターフェースを実装したクラスのインスタンスは例外の発生に伴い その例外をイベントとして受け取ることができます。 このインターフェースを実装しているクラスから生成されたインスタンスの オーナーオブジェクトは、 例外発生をイベントとしてインスタンスに対して通知する義務があります。

メソッドの概要
 void reportError(ErrorEvent err)
推奨されていません。 発生した例外を通知します。

メソッドの詳細

reportError

public void reportError(ErrorEvent err)
推奨されていません。
発生した例外を通知します。

パラメータ:
err - 発生したエラーイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース EventListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。

public interface EventListener

このクラスは、イベントリスナーのインターフェースです。

イベントコントローラと組み合わせて使うことにより、 様々なイベント機能を実装することができます。

導入されたバージョン:
version 3.2
関連項目:
EventQueueController

メソッドの概要
 void handleEvent()
推奨されていません。 イベントが発生した時にコントローラから呼び出されます。

メソッドの詳細

handleEvent

public void handleEvent()
推奨されていません。
イベントが発生した時にコントローラから呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventQueueController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス EventQueueController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.EventQueueController
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。

public class EventQueueController
extends Object

このクラスは、イベントリスナーを実行するイベント機能を実装します。

イベントコントローラは、指定された時間間隔に従ってリスナー登録状況を確認し、 リスナーの登録が１つ以上あった場合、これらを専用スレッドで実行します。 このとき、イベントリスナーの実行順と実行の直列化が保証されます。
これらの機能により、通常の関数実行や java.lang.Thread クラスを利用した 並列処理などと異なった機能を実装することができます。

このクラスを利用することにより、現在の処理とイベント処理を並列化することが できます。また、一つのコントローラは同時に一つのイベントリスナーしか 実行しないため、それぞれのリスナーの処理が並列処理されることはありません。 従って、リスナーはマルチスレッドを意識したプログラムにする必要がありますが、 リスナー間でマルチスレッドを意識する必要はありません。

導入されたバージョン:
version 3.2
関連項目:
EventListener

コンストラクタの概要
EventQueueController()
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long millis)
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
メソッドの概要
void | destroy() 推奨されていません。 このイベントコントローラの破棄処理を行います。
void | entry(EventListener listener) 推奨されていません。 イベントリスナーの登録。
void | eventGenerating() 推奨されていません。 キューに登録されているイベントリスナーを一つ実行します。
protected void | finalize() 推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() 推奨されていません。 キューに溜まっているすべてのイベントリスナーを実行します。
boolean | isAlive() 推奨されていません。 このイベントコントローラが有効かどうかチェックします。
void | setCapacity(int max) 推奨されていません。 キューの容量を変更します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventQueueController

public EventQueueController()
推奨されていません。
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 コントローラがリスナー登録状況を監視する時間間隔はデフォルト値(60秒)が 適用されます。

EventQueueController

public EventQueueController(long millis)
                     throws IllegalArgumentException
推奨されていません。
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 millis は、リスナーの登録状況を監視する時間間隔です。 コントローラは、リスナーが一つも登録されていない状態になると、 millis ミリ秒間隔でリスナー登録の有無を確認します。

パラメータ:
millis - イベントの監視間隔(ミリ秒)
例外:
IllegalArgumentException - millis が 0 以下の場合
メソッドの詳細

setCapacity

public void setCapacity(int max)
                 throws IllegalStateException,
                        IllegalArgumentException
推奨されていません。
キューの容量を変更します。

パラメータ:
max - イベントをプールできる最大量
例外:
IllegalStateException - max 個以上のリスナーが登録されている場合
IllegalArgumentException - max が 0 以下の場合

entry

public void entry(EventListener listener)
           throws NullPointerException,
                  IndexOutOfBoundsException,
                  IllegalStateException
推奨されていません。
イベントリスナーの登録。
イベントリスナーは、一旦キューに溜められます。 キューに保管されたリスナーは、 このコントローラにより現在実行中のスレッドとは 別のスレッドで登録順に呼び出されます。

実行されたリスナーは、処理が終了すると破棄されます。

通常のスレッドクラスを利用した並列処理との違いは、 イベントリスナーが登録順に実行される点と、 イベントリスナーの実行が直列化される点にあります。

パラメータ:
listener - イベントリスナー
例外:
NullPointerException - listener が null の場合
IndexOutOfBoundsException - キューが飽和状態の場合
IllegalStateException - コントローラが破棄処理済の場合

isAlive

public boolean isAlive()
推奨されていません。
このイベントコントローラが有効かどうかチェックします。

戻り値:
イベントコントローラが有効な場合は true、すでに破棄処理済の場合は false。

destroy

public void destroy()
推奨されていません。
このイベントコントローラの破棄処理を行います。 破棄処理を行うと、それ以上リスナーを登録することができなくなります。

このメソッドによる破棄処理と、登録済みリスナーの実行は非同期に 行われます。そのため、このメソッドがリターンしても 実行されないリスナーが残ることがあります。
すでに登録済みのリスナーの実行は破棄処理後も保証されます (登録済みのリスナーは非同期にすべて実行されます)。

flush

public void flush()
推奨されていません。
キューに溜まっているすべてのイベントリスナーを実行します。

このメソッドは、現在実行中のスレッドで すべてのイベント処理を行います。

eventGenerating

public void eventGenerating()
                     throws NoSuchElementException
推奨されていません。
キューに登録されているイベントリスナーを一つ実行します。 実行されるリスナーは、現在キューに保管されているリスナーの中で 最も過去に登録されたリスナーです。 このメソッドは、現在実行中のスレッドで 登録順で最も過去のイベントを１つ実行します。

例外:
NoSuchElementException - 登録リスナーがない場合

finalize

protected void finalize()
                 throws Throwable
推奨されていません。
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedThread (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ExtendedThread

java.lang.Object
    拡張 java.lang.Thread
        拡張 jp.co.intra_mart.foundation.utility.ExtendedThread
すべての実装インタフェース:
Runnable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。

public class ExtendedThread
extends Thread

フィールドの概要
クラス java.lang.Thread から継承したフィールド
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
コンストラクタの概要
ExtendedThread()
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable target)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable target, String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target, String name)
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, String name)
推奨されていません。 Constructor for ExtendedThread.
メソッドの概要
void | addThreadStopListener(ThreadStopListener listener) 推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
void | fire() 推奨されていません。 スレッド実行されるロジック。
void | run() 推奨されていません。 このオブジェクトのスレッド実行ロジックです。
クラス java.lang.Thread から継承したメソッド
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getContextClassLoader, getName, getPriority, getThreadGroup, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setName, setPriority, sleep, sleep, start, stop, stop, suspend, toString, yield
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedThread

public ExtendedThread()
推奨されていません。
Constructor for ExtendedThread.

ExtendedThread

public ExtendedThread(Runnable target)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
target -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
target -

ExtendedThread

public ExtendedThread(String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
name -

ExtendedThread

public ExtendedThread(Runnable target,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
target -
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target,
                      String name)
推奨されていません。
Constructor for ExtendedThread.

パラメータ:
group -
target -
name -
メソッドの詳細

run

public final void run()
推奨されていません。
このオブジェクトのスレッド実行ロジックです。 このメソッドをサブクラスがオーバーライドすることはできません。 サブクラスがスレッド実行ロジックを定義するためには、fireメソッドを オーバーライドしてください。

fire

public void fire()
推奨されていません。
スレッド実行されるロジック。 Thread クラスを継承したサブクラスにおいて、通常 run メソッドに 記述する内容をこのメソッドに定義してください。

addThreadStopListener

public void addThreadStopListener(ThreadStopListener listener)
推奨されていません。
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

パラメータ:
listener - スレッド終了イベントリスナー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス FilterComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.FilterComparator
すべての実装インタフェース:
Comparator, Serializable
直系の既知のサブクラス:
ReverseComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。

public abstract class FilterComparator
extends Object
implements Comparator, Serializable

コンパレータのフィルターとして機能する抽象クラスです。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
FilterComparator(Comparator comparator)
推奨されていません。 指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
int | compare(Object arg0, Object arg1) 推奨されていません。 順序付けのために 2 つの引数を比較するメソッドです。
Comparator | getParentComparator() 推奨されていません。 フィルター対象のコンパレータを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

FilterComparator

public FilterComparator(Comparator comparator)
推奨されていません。
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果

getParentComparator

public Comparator getParentComparator()
推奨されていません。
フィルター対象のコンパレータを返します。

戻り値:
フィルター対象のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FixedSizeMap (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス FixedSizeMap

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 jp.co.intra_mart.foundation.utility.FixedSizeMap
すべての実装インタフェース:
Map
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。

public class FixedSizeMap
extends AbstractMap

LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。

このクラスのマップは、決められたサイズの領域持ちます。 キーはコンストラクタで指定された マップのサイズに等しい個数しか、このマップに関連付けることはできません。 すでにマップのサイズに等しい個数のキーが関連付けられている状態で、 別の新しいキーを関連付けようとした場合、LRU アルゴリズムに従い 最も古くに使われたキーが削除され、全体のキー数がマップのサイズに 等しくなるように調整されます。
このオブジェクトは、Thread safe となっています。
このマップは LRU アルゴリズムにより動作するため、 マッピングの追加や更新をしたり、キーにマッピングされている値の取得を した時に、キーのアクセス順をチェックします。 したがって、マップのサイズが大きさに比例して put() や get() メソッドの レスポンス時間が長くなります。 このハッシュテーブルは、適度な大きさで利用することを推奨します。

導入されたバージョン:
Version 3.2
関連項目:
Hashtable

入れ子クラスの概要
クラス java.util.Map から継承した入れ子クラス
Map.Entry
コンストラクタの概要
FixedSizeMap(int size)
推奨されていません。 指定されたサイズの領域を持つマップを構築します。
メソッドの概要
int | capacity() 推奨されていません。 このマップに対してマップできるキーの最大個数を返します。
void | clear() 推奨されていません。 マップからマッピングをすべて削除します。
boolean | containsKey(Object key) 推奨されていません。 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
Set | entrySet() 推奨されていません。 このマップに格納されているマッピングのセットビューを返します。
Object | get(Object key) 推奨されていません。 マップが、指定されたキーにマッピングしている値を返します。
Object | put(Object key, Object value) 推奨されていません。 指定された値を、マップ内の指定されたキーに関連付けます 。
Object | remove(Object key) 推奨されていません。 このキーにマッピングがある場合に、そのマッピングをマップから削除します。
クラス java.util.AbstractMap から継承したメソッド
clone, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FixedSizeMap

public FixedSizeMap(int size)
             throws IllegalArgumentException
推奨されていません。
指定されたサイズの領域を持つマップを構築します。

パラメータ:
size - ハッシュテーブルの容量
例外:
IllegalArgumentException - 容量が 1 より小さい場合
メソッドの詳細

capacity

public int capacity()
推奨されていません。
このマップに対してマップできるキーの最大個数を返します。 このメソッドの返す値は、コンストラクタで指定されたハッシュテーブルの 容量値をそのまま返すものです。

戻り値:
このマップにエントリできるキーの最大個数

clear

public void clear()
推奨されていません。
マップからマッピングをすべて削除します。

containsKey

public boolean containsKey(Object key)
推奨されていません。
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。

パラメータ:
key - このマップにあるかどうかを判定するキー
戻り値:
指定されたキーへのマッピングをこのマップが含む場合は true

entrySet

public Set entrySet()
推奨されていません。
このマップに格納されているマッピングのセットビューを返します。 このセットの各要素は Map.Entry です。セットはこのマップを 基にしているので、マップへの変更、およびセットへの変更は、 互いに反映されます。 セットでの繰り返し処理が進行中にマップが変更された場合、 反復の結果は保証されません。セットは要素の削除をサポートしており、 対応するエントリをマップから削除することができます。 削除には、Iterator.remove、Set.remove、removeAll、retainAll、 および clear オペレーションが使えます。 add または addAll オペレーションはサポートされません。

戻り値:
このマップに格納されているマッピングのセットビュー

get

public Object get(Object key)
推奨されていません。
マップが、指定されたキーにマッピングしている値を返します。 マップに、このキーに対するマッピングがない場合は null を返します。

パラメータ:
key - 関連付けられている値が返されるキー
戻り値:
マップが、指定されたキーにマッピングしている値。このキーに対するマッピングがマップにない場合は null
関連項目:
containsKey(Object)

put

public Object put(Object key,
                  Object value)
推奨されていません。
指定された値を、マップ内の指定されたキーに関連付けます 。 マップにすでにこのキーに対するマッピングがある場合、 古い値は置き換えられます。

パラメータ:
key - 指定された値が関連付けられるキー
value - 指定されたキーに関連付けられる値
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
例外:
NullPointerException - キーまたは値が null の場合

remove

public Object remove(Object key)
推奨されていません。
このキーにマッピングがある場合に、そのマッピングをマップから削除します。

パラメータ:
key - マッピングがマップから削除されるキー
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LockMonitor (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス LockMonitor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.LockMonitor
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。

public class LockMonitor
extends Object

このクラスはモニター機能を提供します。
このクラスでは、複数個のモニターを管理することができます。 アプリケーションでは、entry() メソッドによりモニターを取得し、 release() メソッドでモニターを開放します。

コンストラクタの概要
LockMonitor(int max)
推奨されていません。 モニターを構築します。
メソッドの概要
int | activeCount() 推奨されていません。 現在取得済みモニターの数を取得します。
void | entry() 推奨されていません。 モニターの取得。
int | queue() 推奨されていません。 モニターを取得するための待ち行列に入っているスレッドの数です。
void | release() 推奨されていません。 モニターの開放。
int | size() 推奨されていません。 このオブジェクトの管理するモニターの数を取得します。
int | total() 推奨されていません。 モニターを利用中、または利用しようとしているスレッドの数です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LockMonitor

public LockMonitor(int max)
推奨されていません。
モニターを構築します。

パラメータ:
max - 管理するモニターの個数
メソッドの詳細

entry

public void entry()
推奨されていません。
モニターの取得。

モニターを取得できるまでブロックします。 モニターの取得＝動作の権利を取得

size

public int size()
推奨されていません。
このオブジェクトの管理するモニターの数を取得します。

戻り値:
モニターの数

activeCount

public int activeCount()
推奨されていません。
現在取得済みモニターの数を取得します。

戻り値:
取得済みモニターの数

total

public int total()
推奨されていません。
モニターを利用中、または利用しようとしているスレッドの数です。

戻り値:
entry() メソッドを実行して release() メソッドを実行していないスレッドの数
導入されたバージョン:
version 4.2

queue

public int queue()
推奨されていません。
モニターを取得するための待ち行列に入っているスレッドの数です。

戻り値:
entry() メソッドを実行して、ブロック状態になっているスレッドの数
導入されたバージョン:
version 4.2

release

public void release()
推奨されていません。
モニターの開放。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultiComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス MultiComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.AbstractDualComparator
        拡張 jp.co.intra_mart.foundation.utility.MultiComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。

public class MultiComparator
extends AbstractDualComparator

複数のコンパレータを使用してソートを行うためにクラスです。
実行したコンパレータの compare() メソッドの戻り値が０でなくなるか、全てのコンパレータの実行が完了するまで下記の順番でコンパレータの実行が行われます。

・コンストラクタで指定された第１コンパレータ
・コンストラクタで指定された第２コンパレータ
・addComparator()で追加されたコンパレータ

このクラスは同じインスタンスのコンパレータを２つ以上持つことを想定されていません。 そのような操作を行うと、正しい結果が得られない可能性があります。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
MultiComparator(Comparator primaryComparator, Comparator secondaryComparator)
推奨されていません。 第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
メソッドの概要
void | addComparator(Comparator comparator) 推奨されていません。 指定されたコンパレータ comparator を追加します。
Collection | getComparators() 推奨されていません。 設定されている全てのコンパレータを取得します。
Comparator | getPrimaryComparator() 推奨されていません。 第１コンパレータを返します。
Comparator | getSecondaryComparator() 推奨されていません。 第２コンパレータを返します。
boolean | removeComparator(Comparator comparator) 推奨されていません。 指定されたコンパレータ comparatorを削除します。
クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

MultiComparator

public MultiComparator(Comparator primaryComparator,
                       Comparator secondaryComparator)
                throws NullPointerException
推奨されていません。
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
もし primaryComparator がnullで、 secondaryComparator がnullでない時は、secondaryComparator が第１コンパレータとして扱われます。
primaryComparator 、secondaryComparator がともにnullの時は例外を発生させます。

パラメータ:
primaryComparator - 第１コンパレータ
secondaryComparator - 第２コンパレータ
例外:
NullPointerException - primaryComparator 、 secondaryComparator がともにnullの時発生します。
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
推奨されていません。
第１コンパレータを返します。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
推奨されていません。
第２コンパレータを返します。 このメソッドの戻り値は、設定された第２コンパレータをラップしたMultiComparatorのオブジェクトになります。 もし、第２コンパレータが設定されていないときはnullを返します。

戻り値:
第２コンパレータ

addComparator

public void addComparator(Comparator comparator)
                   throws NullPointerException
推奨されていません。
指定されたコンパレータ comparator を追加します。 指定されたコンパレータ comparatorがnullの時は例外を発生させます。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 指定されたcomparatorがnullの時に発生します。

removeComparator

public boolean removeComparator(Comparator comparator)
                         throws IllegalArgumentException
推奨されていません。
指定されたコンパレータ comparatorを削除します。 指定されたコンパレータの削除に成功したときはtrue、失敗したときはfalseを返します。 このクラスのオブジェクトが持つ全てのコンパレータを削除しようとすると例外が発生します。

パラメータ:
comparator - 削除対象のコンパレータ
戻り値:
削除に成功したときはtrue、失敗したときはfalseを返す。
例外:
IllegalArgumentException - 全てのコンパレータを削除しようとした時に発生します。

getComparators

public Collection getComparators()
推奨されていません。
設定されている全てのコンパレータを取得します。

戻り値:
設定されている全てのコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipurposeInternetMailExtensions (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス MultipurposeInternetMailExtensions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。

public class MultipurposeInternetMailExtensions
extends Object

MIME タイプを持つオブジェクトです。

コンストラクタの概要
MultipurposeInternetMailExtensions(File path)
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String filename)
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String mediaType, String subType)
推奨されていません。 指定のMIMEタイプを表すオブジェクトを構築します。
メソッドの概要
String | getMediaType() 推奨されていません。 このオブジェクトが表す MIME タイプの Media Type を返します。
String | getSubType() 推奨されていません。 このオブジェクトが表す MIME タイプの subtype を返します。
String | getType() 推奨されていません。 このオブジェクトが表す MIME タイプを返します。
String | toString() 推奨されていません。 このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String filename)
推奨されていません。
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 filename の拡張子により解決されます。
引数 filename に拡張子がない場合や、拡張子から MIME タイプを解決 出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
filename - ファイル名

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(File path)
推奨されていません。
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 path の表すファイル名の拡張子により解決されます。
引数 path の表すファイル名に拡張子がない場合や、拡張子から MIME タイプを 解決出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
path - ファイル名を表す File クラスのインスタンス

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String mediaType,
                                          String subType)
推奨されていません。
指定のMIMEタイプを表すオブジェクトを構築します。

このコンストラクタにより構築されたオブジェクトの表す MIME タイプは、 mediaType "/" subType となります。

パラメータ:
mediaType - メディアタイプを表すキーワード
subType - サブタイプを表すキーワード
メソッドの詳細

getMediaType

public String getMediaType()
推奨されていません。
このオブジェクトが表す MIME タイプの Media Type を返します。

戻り値:
Media Type を表す文字列

getSubType

public String getSubType()
推奨されていません。
このオブジェクトが表す MIME タイプの subtype を返します。

戻り値:
subtype を表す文字列

getType

public String getType()
推奨されていません。
このオブジェクトが表す MIME タイプを返します。

戻り値:
MIME タイプを表す文字列

toString

public String toString()
推奨されていません。
このオブジェクトの文字列表現を返します。

戻り値:
MIME タイプを表す文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.utility (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.foundation.utility
インタフェース
DualComparator
ErrorEventListener
EventListener
ThreadStopListener
クラス
AbstractDualComparator
Counter
ErrorEvent
EventQueueController
ExtendedThread
FilterComparator
FixedSizeMap
LockMonitor
MultiComparator
MultipurposeInternetMailExtensions
ResourceBundleProperties
ReverseComparator
SequenceComparator


jp.co.intra_mart.foundation.utility (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
DualComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
ErrorEventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
EventListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
ThreadStopListener | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

クラスの概要
AbstractDualComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
Counter | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
ErrorEvent | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
EventQueueController | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
ExtendedThread | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
FilterComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
FixedSizeMap | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
LockMonitor | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
MultiComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
MultipurposeInternetMailExtensions | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
ResourceBundleProperties | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
ReverseComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
SequenceComparator | 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。

パッケージ jp.co.intra_mart.foundation.utility の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.foundation.utility クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.utility の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.utility.MultiComparator
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.foundation.utility.FixedSizeMap
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.foundation.utility.ResourceBundleProperties
    • class jp.co.intra_mart.foundation.utility.ErrorEvent
    • class jp.co.intra_mart.foundation.utility.EventQueueController
    • class jp.co.intra_mart.foundation.utility.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.ReverseComparator
    • class jp.co.intra_mart.foundation.utility.LockMonitor
    • class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.foundation.utility.ExtendedThread

インタフェース階層

  • interface java.util.Comparator
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.foundation.utility.ErrorEventListener
  • interface jp.co.intra_mart.foundation.utility.EventListener
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.util.Comparator)
  • interface jp.co.intra_mart.foundation.utility.ThreadStopListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.foundation.utility の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility の使用

jp.co.intra_mart.foundation.utility を使用しているパッケージ
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.http により使用される jp.co.intra_mart.foundation.utility のクラス
MultipurposeInternetMailExtensions
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。

jp.co.intra_mart.foundation.page により使用される jp.co.intra_mart.foundation.utility のクラス
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.utility のクラス
EventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。

jp.co.intra_mart.foundation.utility により使用される jp.co.intra_mart.foundation.utility のクラス
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
ErrorEvent
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
EventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
FilterComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
ThreadStopListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

jp.co.intra_mart.foundation.utility.io により使用される jp.co.intra_mart.foundation.utility のクラス
ErrorEventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。

jp.co.intra_mart.foundation.utility.report により使用される jp.co.intra_mart.foundation.utility のクラス
EventQueueController
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ResourceBundleProperties (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ResourceBundleProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.foundation.utility.ResourceBundleProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。

public class ResourceBundleProperties
extends Properties

このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。プロパティデータは、java.util.ResourceBundle により取得されます。
ロードできるリソースに関しては、java.util.ResourceBundle の 説明を参照して下さい。
このクラスのコンストラクタが、java.util.ResourceBundle クラスの getBundle() メソッドと同様の機能を提供しています。 各コンストラクタは、引数の同じ getBundle() メソッドに対応しています。

導入されたバージョン:
version 4.0
関連項目:
Properties, ResourceBundle, 直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ResourceBundleProperties(String baseName)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale, ClassLoader loader)
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
メソッドの概要
 Locale getLocale()
推奨されていません。 ResourceBundle の Locale を返します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceBundleProperties

public ResourceBundleProperties(String baseName)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale,
                                ClassLoader loader)
                         throws MissingResourceException
推奨されていません。
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
loader - リソースをロードする ClassLoader
例外:
MissingResourceException - リソースの照合に失敗した場合
メソッドの詳細

getLocale

public Locale getLocale()
推奨されていません。
ResourceBundle の Locale を返します。
この関数は、このオブジェクトが本当に要求されたロケールに対応しているか、 またはフォールバックであるかを判定するために、このオブジェクトが 構築されたあとで使用できます。

この関数は、java.util.ResourceBundle クラスの getLocale() と 同じであり、java.util.ResourceBundle クラスとインターフェースを 合わせるために提供されています。 java.util.ResourceBundle クラスの getLocale() の説明を参照して下さい。

戻り値:
ロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReverseComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス ReverseComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.FilterComparator
        拡張 jp.co.intra_mart.foundation.utility.ReverseComparator
すべての実装インタフェース:
Comparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。

public class ReverseComparator
extends FilterComparator

コンパレータのフィルタとして機能します。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
ReverseComparator(Comparator comparator)
推奨されていません。 指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
クラス jp.co.intra_mart.foundation.utility.FilterComparator から継承したメソッド
getParentComparator
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

ReverseComparator

public ReverseComparator(Comparator comparator)
推奨されていません。
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

定義:
インタフェース Comparator 内の compare
オーバーライド:
クラス FilterComparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
フィルタ対象のコンパレータの compare() メソッドの結果を反転させた値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SequenceComparator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
クラス SequenceComparator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.utility.SequenceComparator
すべての実装インタフェース:
Comparator, Serializable
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。

public class SequenceComparator
extends Object
implements Comparator, Serializable

挿入順にソートするためのコンパレータです。
このコンパレータは挿入が早い物から遅い物の順に並べます。
このコンパレータは、挿入されたオブジェクトの順番をインスタンス変数として持っています。 そのため、複数のオブジェクトでこのコンパレータを共有使用すると正しく動作しない可能性があります。
またこのクラスは、java.lang.TreeSet、java.lang.TreeMapで使用されることを想定して作られています。 そのため、他のクラスのコンパレータとして使用すると正しく動作しない可能性があります。 クラスで管理できるオブジェクトの数は、２の３１乗-１までのみ管理できます。

導入されたバージョン:
version 4.3
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SequenceComparator()
推奨されていません。 新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

SequenceComparator

public SequenceComparator()
推奨されていません。
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
推奨されていません。
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドの目的は、挿入順にソートすることです。 引数１と引数２を比較したとき、引数１の方が挿入が遅いときは正の数、早い時は負の数を返します。
引数１と引数２が同じインスタンスの時は０を返します

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引き数１
arg1 - 引き数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ThreadStopListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.utility
インタフェース ThreadStopListener

推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

public interface ThreadStopListener

メソッドの概要
 void handleThreadStop()
推奨されていません。 監視していたスレッドが終了したときに実行されるメソッドです。

メソッドの詳細

handleThreadStop

public void handleThreadStop()
推奨されていません。
監視していたスレッドが終了したときに実行されるメソッドです。 このメソッドをサブクラスが実行することで、特定のスレッド終了時に プログラムを実行することができます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.data.ConnectorModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ConnectorModel の使用

jp.co.intra_mart.framework.base.data.ConnectorModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.data.DAO の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.DAO の使用

DAO を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DAO の使用

DAO を実装している jp.co.intra_mart.framework.base.data のクラス
class | DAOAdapter DAOのすべてのメソッドを何もしないように実装したクラスです。
class | DBDAO データベースに特化したDAOです。
class | IntramartDBDAO 推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
class | IntramartFileServerDAO intra-martのStorageサービスを使用する場合のDAOです。
class | LoginGroupDBDAO イントラマートで設定されたDBへアクセスするDAOです。
class | SystemDBDAO イントラマートで設定されたDBへアクセスするDAOです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DAOAdapter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DAOAdapter の使用

jp.co.intra_mart.framework.base.data.DAOAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DAOException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DAOException の使用

DAOException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.base.data のメソッド
 Object DataAccessController.getDAO(String application, String key, String connect)
DAOを取得します。

jp.co.intra_mart.framework.base.event での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DaoModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DaoModel の使用

jp.co.intra_mart.framework.base.data.DaoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataAccessController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataAccessController の使用

DataAccessController を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.data のメソッド
 DataAccessController DataManager.getDataAccessController()
データアクセスコントローラを取得します。

jp.co.intra_mart.framework.base.event での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.event のメソッド
protected  DataAccessController StandardEventListener.getDataAccessController()
このイベントリスナで使用するデータアクセスコントローラです。

DataAccessController 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataAccessException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataAccessException の使用

jp.co.intra_mart.framework.base.data.DataAccessException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnectException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnectException の使用

DataConnectException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.base.data のメソッド
void | SystemDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
Connection | SystemDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | SystemDBConnector.commit() コミットします。
void | SystemDBConnector.rollback() ロールバックします。
void | SystemDBConnector.release() データストアの資源を解放します。
Connection | SystemDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | SystemDBConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | LoginGroupDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
Connection | LoginGroupDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | LoginGroupDBConnector.commit() コミットします。
void | LoginGroupDBConnector.rollback() ロールバックします。
void | LoginGroupDBConnector.release() データストアの資源を解放します。
Connection | LoginGroupDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | LoginGroupDBConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | JDBCConnector.commit() 推奨されていません。 コミットします。
void | JDBCConnector.rollback() 推奨されていません。 ロールバックします。
void | JDBCConnector.release() 推奨されていません。 データストアの資源を解放します。
protected Connection | JDBCConnector.putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
void | IntramartFileServerDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
protected Object | IntramartFileServerConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | IntramartFileServerConnector.commit() コミットします。
void | IntramartFileServerConnector.rollback() ロールバックします。
void | IntramartFileServerConnector.release() データストアの資源を解放します。
void | IntramartDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
void | IntramartDBConnector.commit() 推奨されていません。 コミットします。
void | IntramartDBConnector.rollback() 推奨されていません。 ロールバックします。
void | IntramartDBConnector.release() 推奨されていません。 データストアの資源を解放します。
protected Object | IntramartDBConnector.getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
void | DataSourceConnector.commit() コミットします。
void | DataSourceConnector.rollback() ロールバックします。
void | DataSourceConnector.release() データストアの資源を解放します。
protected Connection | DataSourceConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected abstract Object | DataConnector.getResource(String key, String connect, String resource) リソースを取得します。
abstract void | DataConnector.commit() コミットします。
abstract void | DataConnector.rollback() ロールバックします。
abstract void | DataConnector.release() データストアの資源を解放します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。
void | DataAccessController.commit() すべてのデータコネクタをコミットします。
void | DataAccessController.rollback() すべてのデータコネクタをロールバックします。
void | DataAccessController.release() すべてのデータストアの資源を解放します。
void | DBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
protected Connection | DBDAO.getConnection() このDAOに関連づけられたコネクションを取得します。
protected abstract Connection | DBConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected Object | DBConnector.getResource(String key, String connect, String resource) リソースを取得します。
Connection | DBConnector.getConnection(String resource) データベースへのコネクションを取得します。
void | DBConnector.commit() コミットします。
void | DBConnector.rollback() ロールバックします。
void | DBConnector.release() データストアの資源を解放します。
void | DAOAdapter.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。

jp.co.intra_mart.framework.base.event での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnector の使用

DataConnector を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnector の使用

jp.co.intra_mart.framework.base.data での DataConnector のサブクラス
class | DataSourceConnector DataSourceに関連するデータコネクタです。
class | DBConnector データベースに対するコネクタです。
class | IntramartDBConnector 推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
class | IntramartFileServerConnector intra-martのStorageサービスに接続するデータコネクタです。
class | JDBCConnector 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
class | LoginGroupDBConnector イントラマートで設定されているDBコネクションです。
class | SystemDBConnector イントラマートで設定されているDBコネクションです。

DataConnector 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
void | SystemDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | LoginGroupDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | IntramartFileServerDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | IntramartDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
void | DBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAOAdapter.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataConnectorException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnectorException の使用

DataConnectorException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.base.data のメソッド
protected NetworkFile | IntramartFileServerDAO.getNetworkFile(String path) パスに該当するNetworkFileを取得します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.base.event での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataManager の使用

DataManager を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataManager の使用

DataManager を返す jp.co.intra_mart.framework.base.data のメソッド
static DataManager DataManager.getDataManager()
データマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataManagerException の使用

DataManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataManagerException の使用

DataManagerException をスローする jp.co.intra_mart.framework.base.data のメソッド
static DataManager DataManager.getDataManager()
データマネージャを取得します。

DataManagerException をスローする jp.co.intra_mart.framework.base.data のコンストラクタ
DataManager()
データマネージャを生成するコンストラクタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataPropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataPropertyException の使用

DataPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.base.data のメソッド
boolean | XmlDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | XmlDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | XmlDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | XmlDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | XmlDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | XmlDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
String | TextFileDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | TextFileDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | TextFileDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | TextFileDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | TextFileDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
Connection | SystemDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
Connection | SystemDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
Connection | LoginGroupDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
Connection | LoginGroupDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | IntramartFileServerConnector.getResource(String key, String connect, String resource) リソースを取得します。
DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
protected Object | IntramartDBConnector.getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
boolean | DistributesDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DistributesDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DistributesDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DistributesDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DistributesDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DistributesDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
boolean | DefaultDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DefaultDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DefaultDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DefaultDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DefaultDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DefaultDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
boolean | DataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
protected abstract Object | DataConnector.getResource(String key, String connect, String resource) リソースを取得します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。
protected Connection | DBDAO.getConnection() このDAOに関連づけられたコネクションを取得します。
protected Object | DBConnector.getResource(String key, String connect, String resource) リソースを取得します。
Connection | DBConnector.getConnection(String resource) データベースへのコネクションを取得します。

jp.co.intra_mart.framework.base.event での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.data.DataPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.DataPropertyHandler の使用

DataPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataPropertyHandler の使用

DataPropertyHandler を実装している jp.co.intra_mart.framework.base.data のクラス
class | DefaultDataPropertyHandler デフォルトのデータプロパティハンドラです。
class | DistributesDataPropertyHandler アプリケーション毎のプロパティハンドラを呼び出します。
class | TextFileDataPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlDataPropertyHandler XMLのデータプロパティハンドラです。

DataPropertyHandler を返す jp.co.intra_mart.framework.base.data のメソッド
DataPropertyHandler | DataManager.getDataPropertyHandler() データプロパティハンドラを取得します。
DataPropertyHandler | DataConnector.getDataPropertyHandler() データプロパティハンドラを取得します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
 void DataConnector.setDataPropertyHandler(DataPropertyHandler handler)
データプロパティハンドラを設定します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.base.data のコンストラクタ
DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DataSourceConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataSourceConnector の使用

jp.co.intra_mart.framework.base.data.DataSourceConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DBConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DBConnector の使用

DBConnector を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DBConnector の使用

jp.co.intra_mart.framework.base.data での DBConnector のサブクラス
class | DataSourceConnector DataSourceに関連するデータコネクタです。
class | JDBCConnector 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DBDAO の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DBDAO の使用

jp.co.intra_mart.framework.base.data.DBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartDBConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartDBConnector の使用

jp.co.intra_mart.framework.base.data.IntramartDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartDBDAO の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartDBDAO の使用

jp.co.intra_mart.framework.base.data.IntramartDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の使用

jp.co.intra_mart.framework.base.data.IntramartFileServerConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.IntramartFileServerDAO の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartFileServerDAO の使用

jp.co.intra_mart.framework.base.data.IntramartFileServerDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.JDBCConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.JDBCConnector の使用

jp.co.intra_mart.framework.base.data.JDBCConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の使用

jp.co.intra_mart.framework.base.data.LoginGroupDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.LoginGroupDBDAO の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.LoginGroupDBDAO の使用

jp.co.intra_mart.framework.base.data.LoginGroupDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.ResourceModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ResourceModel の使用

jp.co.intra_mart.framework.base.data.ResourceModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.ResourceParam の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ResourceParam の使用

ResourceParam を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での ResourceParam の使用

ResourceParam を返す jp.co.intra_mart.framework.base.data のメソッド
ResourceParam[] | XmlDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | TextFileDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DistributesDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DefaultDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。

ResourceParam 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
protected Connection | JDBCConnector.putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
protected Connection | DataSourceConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected abstract Connection | DBConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.SystemDBConnector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.SystemDBConnector の使用

jp.co.intra_mart.framework.base.data.SystemDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.SystemDBDAO の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.SystemDBDAO の使用

jp.co.intra_mart.framework.base.data.SystemDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ConnectorModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ConnectorModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.ConnectorModel
public class ConnectorModel
extends Object

コネクタ情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_CONNECTOR_CLASS
static String | P_ID_CONNECTOR_NAME
static String | P_ID_RESOURCE_NAME
コンストラクタの概要
ConnectorModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONNECTOR_NAME

public static final String P_ID_CONNECTOR_NAME
関連項目:
定数フィールド値

P_ID_CONNECTOR_CLASS

public static final String P_ID_CONNECTOR_CLASS
関連項目:
定数フィールド値

P_ID_RESOURCE_NAME

public static final String P_ID_RESOURCE_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

ConnectorModel

public ConnectorModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DAO (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
インタフェース DAO

既知の実装クラスの一覧:
DAOAdapter, DBDAO, IntramartDBDAO, IntramartFileServerDAO, LoginGroupDBDAO, SystemDBDAO
public interface DAO

データリソースにアクセスするインタフェースです。 すべてのDAOはこのインタフェースを実装する必要があります。

バージョン:
1.0

メソッドの概要
 void setConnectInfo(DataConnector connector, String resource, String key, String connect)
データリソースに接続する時の情報を設定します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DAOAdapter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DAOAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DAOAdapter
すべての実装インタフェース:
DAO
public class DAOAdapter
extends Object
implements DAO

DAOのすべてのメソッドを何もしないように実装したクラスです。 データリソースへの接続を必要としない場合や、 開発時のスタブ用のDAOとして一時的に使うDAOを作るときなどは このクラスを継承すると便利です。

導入されたバージョン:
3.2

コンストラクタの概要
DAOAdapter()
DAOAdapterを新規に生成します。
メソッドの概要
 void setConnectInfo(DataConnector connector, String resource, String key, String connect)
データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DAOAdapter

public DAOAdapter()
DAOAdapterを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。 このクラスではkのメソッドは何もしません。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DAOException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DAOException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DAOException
すべての実装インタフェース:
Serializable
public class DAOException
extends SystemException

リソースコネクタの情報取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DAOException()
詳細メッセージを指定しないで DAOException を構築します。
DAOException(String msg)
指定された詳細メッセージを持つ DAOException を構築します。
DAOException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DAOException

public DAOException()
詳細メッセージを指定しないで DAOException を構築します。

DAOException

public DAOException(String msg)
指定された詳細メッセージを持つ DAOException を構築します。

パラメータ:
msg - 詳細メッセージ

DAOException

public DAOException(String msg,
                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DaoModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DaoModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DaoModel
public class DaoModel
extends Object

DaoModelを管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_CONNECT_NAME
static String | P_ID_DAO_CLASS
static String | P_ID_DAO_CONNECTOR_NAME
コンストラクタの概要
DaoModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONNECT_NAME

public static final String P_ID_CONNECT_NAME
関連項目:
定数フィールド値

P_ID_DAO_CLASS

public static final String P_ID_DAO_CLASS
関連項目:
定数フィールド値

P_ID_DAO_CONNECTOR_NAME

public static final String P_ID_DAO_CONNECTOR_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

DaoModel

public DaoModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataAccessController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataAccessController

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataAccessController
public class DataAccessController
extends Object

データアクセスを制御します。 DAOの取得、コネクタの管理等を行います。 このクラスを利用して簡易トランザクションを実現することも可能ですが、この方法は推奨されません。 トランザクションはできる限りJava Transaction API(JTA)のUserTransactionを利用して行ってください。

バージョン:
1.0

コンストラクタの概要
DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。
メソッドの概要
void | commit() すべてのデータコネクタをコミットします。
Object | getDAO(String application, String key, String connect) DAOを取得します。
void | release() すべてのデータストアの資源を解放します。
void | rollback() すべてのデータコネクタをロールバックします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataAccessController

public DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

パラメータ:
handler - データプロパティハンドラ
メソッドの詳細

getDAO

public Object getDAO(String application,
                     String key,
                     String connect)
              throws DataPropertyException,
                     DataConnectorException,
                     DAOException,
                     DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

commit

public void commit()
            throws DataConnectException
すべてのデータコネクタをコミットします。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.commit()を順に呼び出すことで簡易的なトランザクションを実現しています。 そのため、複数のデータベースにアクセスしたトランザクションの場合は2-Phaseコミットほど堅牢なトランザクションにはならない場合があります。

例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
すべてのデータコネクタをロールバックします。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.rollback()を順に呼び出すことで簡易的なトランザクションを実現しています。 そのため、複数のデータベースにアクセスしたトランザクションの場合は2-Phaseコミットほど堅牢なトランザクションにはならない場合があります。

例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
すべてのデータストアの資源を解放します。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.release()を順に呼び出しています。

例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataAccessException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataAccessException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataAccessException
すべての実装インタフェース:
Serializable
public class DataAccessException
extends SystemException

データアクセス時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataAccessException()
詳細メッセージを指定しないで DataAccessException を構築します。
DataAccessException(String msg)
指定された詳細メッセージを持つ DataAccessException を構築します。
DataAccessException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataAccessException

public DataAccessException()
詳細メッセージを指定しないで DataAccessException を構築します。

DataAccessException

public DataAccessException(String msg)
指定された詳細メッセージを持つ DataAccessException を構築します。

パラメータ:
msg - 詳細メッセージ

DataAccessException

public DataAccessException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnectException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataConnectException
すべての実装インタフェース:
Serializable
public class DataConnectException
extends SystemException

データ接続に関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataConnectException()
詳細メッセージを指定しないで DataConnectException を構築します。
DataConnectException(String msg)
指定された詳細メッセージを持つ DataConnectException を構築します。
DataConnectException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataConnectException

public DataConnectException()
詳細メッセージを指定しないで DataConnectException を構築します。

DataConnectException

public DataConnectException(String msg)
指定された詳細メッセージを持つ DataConnectException を構築します。

パラメータ:
msg - 詳細メッセージ

DataConnectException

public DataConnectException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
直系の既知のサブクラス:
DBConnector, IntramartDBConnector, IntramartFileServerConnector, LoginGroupDBConnector, SystemDBConnector
public abstract class DataConnector
extends Object

データストアに接続するコネクタです。

バージョン:
1.0

コンストラクタの概要
DataConnector()
新規のDataConnectorを生成します。
メソッドの概要
abstract void | commit() コミットします。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
protected abstract Object | getResource(String key, String connect, String resource) リソースを取得します。
abstract void | release() データストアの資源を解放します。
abstract void | rollback() ロールバックします。
void | setDataPropertyHandler(DataPropertyHandler handler) データプロパティハンドラを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataConnector

public DataConnector()
新規のDataConnectorを生成します。

メソッドの詳細

setDataPropertyHandler

public void setDataPropertyHandler(DataPropertyHandler handler)
データプロパティハンドラを設定します。

パラメータ:
handler - データプロパティハンドラ

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ

getResource

protected abstract Object getResource(String key,
                                      String connect,
                                      String resource)
                               throws DataPropertyException,
                                      DataConnectException
リソースを取得します。

パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

commit

public abstract void commit()
                     throws DataConnectException
コミットします。

例外:
DataConnectException - コミットに失敗

rollback

public abstract void rollback()
                       throws DataConnectException
ロールバックします。

例外:
DataConnectException - ロールバックに失敗

release

public abstract void release()
                      throws DataConnectException
データストアの資源を解放します。

例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataConnectorException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnectorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataConnectorException
すべての実装インタフェース:
Serializable
public class DataConnectorException
extends SystemException

データコネクタ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataConnectorException()
詳細メッセージを指定しないで DataConnectorException を構築します。
DataConnectorException(String msg)
指定された詳細メッセージを持つ DataConnectorException を構築します。
DataConnectorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataConnectorException

public DataConnectorException()
詳細メッセージを指定しないで DataConnectorException を構築します。

DataConnectorException

public DataConnectorException(String msg)
指定された詳細メッセージを持つ DataConnectorException を構築します。

パラメータ:
msg - 詳細メッセージ

DataConnectorException

public DataConnectorException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataManager
public class DataManager
extends Object

データストアとの接続を管理します。

バージョン:
1.0

フィールドの概要
static String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー
コンストラクタの概要
protected DataManager()
データマネージャを生成するコンストラクタです。
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
static DataManager | getDataManager() データマネージャを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DATA_PROPERTY_HANDLER_KEY

public static final String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー

関連項目:
定数フィールド値
コンストラクタの詳細

DataManager

protected DataManager()
               throws DataManagerException
データマネージャを生成するコンストラクタです。 このコンストラクタは明示的に呼び出すことはできません。

例外:
DataManagerException - データマネージャの生成に失敗した
メソッドの詳細

getDataManager

public static DataManager getDataManager()
                                  throws DataManagerException
データマネージャを取得します。

戻り値:
データマネージャ
例外:
DataManagerException - データマネージャの設定に失敗した

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

戻り値:
データアクセスコントローラ

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataManagerException
すべての実装インタフェース:
Serializable
public class DataManagerException
extends SystemException

データマネージャの設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataManagerException()
詳細メッセージを指定しないで DataManagerException を構築します。
DataManagerException(String msg)
指定された詳細メッセージを持つ DataManagerException を構築します。
DataManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataManagerException

public DataManagerException()
詳細メッセージを指定しないで DataManagerException を構築します。

DataManagerException

public DataManagerException(String msg)
指定された詳細メッセージを持つ DataManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

DataManagerException

public DataManagerException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DataPropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataPropertyException
すべての実装インタフェース:
Serializable
public class DataPropertyException
extends SystemException

データプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataPropertyException()
詳細メッセージを指定しないで DataPropertyException を構築します。
DataPropertyException(String msg)
指定された詳細メッセージを持つ DataPropertyException を構築します。
DataPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataPropertyException

public DataPropertyException()
詳細メッセージを指定しないで DataPropertyException を構築します。

DataPropertyException

public DataPropertyException(String msg)
指定された詳細メッセージを持つ DataPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

DataPropertyException

public DataPropertyException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
インタフェース DataPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultDataPropertyHandler, DistributesDataPropertyHandler, TextFileDataPropertyHandler, XmlDataPropertyHandler
public interface DataPropertyHandler
extends PropertyHandler

DAOの設定情報に接続するクラスです。

バージョン:
1.0

メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DataSourceConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataSourceConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
            拡張 jp.co.intra_mart.framework.base.data.DataSourceConnector
public class DataSourceConnector
extends DBConnector

DataSourceに関連するデータコネクタです。 このデータコネクタはJava Transaction API(JTA)のUserTransactionの中で使うことが前提となっています。 また、KEY_JNDI_NAMEで指定されるパラメータにDataSourceのJNDI名を必ず指定してください。

バージョン:
1.0

フィールドの概要
static String KEY_JNDI_NAME
DataSourceのJNDI名のキー
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したフィールド
resources
コンストラクタの概要
DataSourceConnector()
DataSourceConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
protected Connection | putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したメソッド
getConnection, getResource
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_JNDI_NAME

public static final String KEY_JNDI_NAME
DataSourceのJNDI名のキー

関連項目:
定数フィールド値
コンストラクタの詳細

DataSourceConnector

public DataSourceConnector()
DataSourceConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

オーバーライド:
クラス DBConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

オーバーライド:
クラス DBConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

オーバーライド:
クラス DBConnector 内の release
例外:
DataConnectException - 資源開放に失敗

putResource

protected Connection putResource(String resource,
                                 ResourceParam[] params)
                          throws DataConnectException
接続先のリソースを追加します。

定義:
クラス DBConnector 内の putResource
パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
コネクション
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
直系の既知のサブクラス:
DataSourceConnector, JDBCConnector
public abstract class DBConnector
extends DataConnector

データベースに対するコネクタです。

バージョン:
1.0

フィールドの概要
protected  Map resources
リソース一覧
コンストラクタの概要
DBConnector()
DBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String resource) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
protected abstract Connection | putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

resources

protected Map resources
リソース一覧

コンストラクタの詳細

DBConnector

public DBConnector()
DBConnectorを新規に生成します。

メソッドの詳細

putResource

protected abstract Connection putResource(String resource,
                                          ResourceParam[] params)
                                   throws DataConnectException
接続先のリソースを追加します。

パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
コネクション
例外:
DataConnectException - 接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getConnection

public Connection getConnection(String resource)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
resource - リソース名
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗 実際にはこのクラスではこのメソッドは何もしません。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBDAO (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DBDAO
すべての実装インタフェース:
DAO
public abstract class DBDAO
extends Object
implements DAO

データベースに特化したDAOです。

バージョン:
1.0

コンストラクタの概要
DBDAO()
デフォルトのコンストラクタ
メソッドの概要
protected Connection | getConnection() このDAOに関連づけられたコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBDAO

public DBDAO()
デフォルトのコンストラクタ

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

protected Connection getConnection()
                            throws DataConnectException,
                                   DataPropertyException
このDAOに関連づけられたコネクションを取得します。

戻り値:
コネクション
例外:
DataConnectException - コネクションの取得に失敗
DataPropertyException - データプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DefaultDataPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DefaultDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class DefaultDataPropertyHandler
extends Object
implements DataPropertyHandler

デフォルトのデータプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」です。また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「プレフィックス_アプリケーションID.properties」が優先されます。該当するプロパティが見つからない場合、引き続いて「プレフィックス.properties」を検索します。
プロパティの設定内容は以下のとおりです。

キー | 内容 | 共通 | アプリケーション毎
dao.class.キー.接続名 | キーと接続名に対応するDAOのクラス名 | × | ○
dao.class.キー | キーに対応するデフォルトのDAOのクラス名 | × | ○
dao.connector.キー.接続名 | キーと接続名に対応するDAOのデータコネクタ名 | × | ○
dao.connector.キー | キーに対応するデフォルトのDAOのデータコネクタ名 | × | ○
connector.class.データコネクタ名 | データコネクタ名に対応するデータコネクタのクラス名 | ○ | ×
connector.resource.データコネクタ名 | データコネクタ名に対応するデータコネクタのリソース名 | ○ | ×
resource.param.リソース名.パラメータ名 | リソース名に対応するリソースのパラメータの値 | ○ | ×

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultDataPropertyHandler

public DefaultDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributesDataPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DistributesDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class DistributesDataPropertyHandler
extends Object
implements DataPropertyHandler

アプリケーション毎のプロパティハンドラを呼び出します。
プロパティファイルはアプリケーション毎に分割されます。
この場合のファイル名は「プレフィックス_アプリケーションID.properties」、「プレフィックス_アプリケーションID.xml」です。
また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION プロパティファイルのアプリケーションのパラメータ名
static String | PARAM_APPLICATION_CLASS プロパティファイルのクラスのパラメータ名
static String | PARAM_APPLICATION_PARAM プロパティファイルのパラメータのパラメータ名
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT プロパティファイルのデフォルトのパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
DistributesDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
プロパティファイルのデフォルトのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
プロパティファイルのアプリケーションのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
プロパティファイルのパラメータのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
プロパティファイルのクラスのパラメータ名

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesDataPropertyHandler

public DistributesDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.IntramartDBConnector
推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。

public class IntramartDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。

バージョン:
1.0

フィールドの概要
protected  Map connections
推奨されていません。 DbsConnectionの一覧
コンストラクタの概要
IntramartDBConnector()
推奨されていません。 IntramartDBConnectorを新規に生成します。
メソッドの概要
void | commit() 推奨されていません。 コミットします。
DbsConnection | getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
void | release() 推奨されていません。 データストアの資源を解放します。
void | rollback() 推奨されていません。 ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
推奨されていません。
DbsConnectionの一覧

コンストラクタの詳細

IntramartDBConnector

public IntramartDBConnector()
推奨されていません。
IntramartDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
推奨されていません。
コミットします。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
推奨されていません。
ロールバックします。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
推奨されていません。
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
推奨されていません。
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getConnection

public DbsConnection getConnection(String connect)
                            throws DataPropertyException,
                                   DataConnectException
推奨されていません。
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartDBDAO (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.IntramartDBDAO
すべての実装インタフェース:
DAO
推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。

public class IntramartDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 イントラマートで設定されたDBへアクセスするDAOを作る場合、このクラスをextendsします。

バージョン:
1.0

コンストラクタの概要
IntramartDBDAO()
推奨されていません。 IntramartDBDAOを新規に生成します。
メソッドの概要
DbsConnection | getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartDBDAO

public IntramartDBDAO()
推奨されていません。
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
推奨されていません。
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public DbsConnection getConnection()
                            throws DataConnectException,
                                   DataPropertyException
推奨されていません。
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartFileServerConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartFileServerConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
public class IntramartFileServerConnector
extends DataConnector

intra-martのStorageサービスに接続するデータコネクタです。 Storageサービスに対する各種のオペレーションは呼び出し終了時に書き込み等が完了するため、 実際にはトランザクションの対象とならないため注意が必要です。

導入されたバージョン:
3.2

フィールドの概要
protected  Map resources
リソース一覧
コンストラクタの概要
IntramartFileServerConnector()
IntramartFileServerConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
NetworkFile | getNetworkFile(String path) Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

resources

protected Map resources
リソース一覧

コンストラクタの詳細

IntramartFileServerConnector

public IntramartFileServerConnector()
IntramartFileServerConnectorを新規に生成します。

メソッドの詳細

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getNetworkFile

public NetworkFile getNetworkFile(String path)
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。

パラメータ:
path - Storageサービス上のパス
戻り値:
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFile

commit

public void commit()
            throws DataConnectException
コミットします。 注意:実際にはNetworkFileの各種のメソッド完了時に書き込み等が行われています。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 注意:実際にはNetworkFileの各種のメソッド完了時に書き込み等が行われているため、既にファイルに書き込んだ情報は元に戻りません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartFileServerDAO (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartFileServerDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.IntramartFileServerDAO
すべての実装インタフェース:
DAO
public class IntramartFileServerDAO
extends Object
implements DAO

intra-martのStorageサービスを使用する場合のDAOです。

導入されたバージョン:
3.2

コンストラクタの概要
IntramartFileServerDAO()
IntramartFileServerDAOを新規に生成します。
メソッドの概要
protected NetworkFile | getNetworkFile(String path) パスに該当するNetworkFileを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartFileServerDAO

public IntramartFileServerDAO()
IntramartFileServerDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getNetworkFile

protected NetworkFile getNetworkFile(String path)
                              throws DataConnectorException
パスに該当するNetworkFileを取得します。

パラメータ:
path - intra-martStorageサービス上のファイルパス
戻り値:
パスに該当するNetworkFile
例外:
DataConnectorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


JDBCConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス JDBCConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
            拡張 jp.co.intra_mart.framework.base.data.JDBCConnector
推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。

public class JDBCConnector
extends DBConnector

JDBCを利用するデータコネクタです。

バージョン:
1.0
関連項目:
DataSourceConnector

フィールドの概要
static String | KEY_DRIVER 推奨されていません。 データベースドライバのキー
static String | KEY_PASSWORD 推奨されていません。 データベース接続ユーザパスワードのキー
static String | KEY_URL 推奨されていません。 データベースURLのキー
static String | KEY_USERNAME 推奨されていません。 データベース接続ユーザ名のキー
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したフィールド
resources
コンストラクタの概要
JDBCConnector()
推奨されていません。 新規のJDBCConnectorを生成します。
メソッドの概要
void | commit() 推奨されていません。 コミットします。
protected Connection | putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
void | release() 推奨されていません。 データストアの資源を解放します。
void | rollback() 推奨されていません。 ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したメソッド
getConnection, getResource
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_DRIVER

public static final String KEY_DRIVER
推奨されていません。
データベースドライバのキー

関連項目:
定数フィールド値

KEY_URL

public static final String KEY_URL
推奨されていません。
データベースURLのキー

関連項目:
定数フィールド値

KEY_USERNAME

public static final String KEY_USERNAME
推奨されていません。
データベース接続ユーザ名のキー

関連項目:
定数フィールド値

KEY_PASSWORD

public static final String KEY_PASSWORD
推奨されていません。
データベース接続ユーザパスワードのキー

関連項目:
定数フィールド値
コンストラクタの詳細

JDBCConnector

public JDBCConnector()
推奨されていません。
新規のJDBCConnectorを生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
推奨されていません。
コミットします。

オーバーライド:
クラス DBConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
推奨されていません。
ロールバックします。

オーバーライド:
クラス DBConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
推奨されていません。
データストアの資源を解放します。

オーバーライド:
クラス DBConnector 内の release
例外:
DataConnectException - 資源開放に失敗

putResource

protected Connection putResource(String resource,
                                 ResourceParam[] params)
                          throws DataConnectException
推奨されていません。
接続先のリソースを追加します。

定義:
クラス DBConnector 内の putResource
パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
リソース
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupDBConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス LoginGroupDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
public class LoginGroupDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。
ログイングループIDからコネクションを取得します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
protected  Map connections
リソース一覧
コンストラクタの概要
LoginGroupDBConnector()
LoginGroupDBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String connect) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
リソース一覧

コンストラクタの詳細

LoginGroupDBConnector

public LoginGroupDBConnector()
LoginGroupDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getConnection

public Connection getConnection(String connect)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupDBDAO (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス LoginGroupDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.LoginGroupDBDAO
すべての実装インタフェース:
DAO
public class LoginGroupDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 ログイングループIDをキーとしてDBへアクセスするDAOを作る場合、このクラスをextendsします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
LoginGroupDBDAO()
IntramartDBDAOを新規に生成します。
メソッドの概要
Connection | getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroupDBDAO

public LoginGroupDBDAO()
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public Connection getConnection()
                         throws DataConnectException,
                                DataPropertyException
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.data (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.data
インタフェース
DAO
DataPropertyHandler
クラス
ConnectorModel
DAOAdapter
DaoModel
DataAccessController
DataConnector
DataManager
DataSourceConnector
DBConnector
DBDAO
DefaultDataPropertyHandler
DistributesDataPropertyHandler
IntramartDBConnector
IntramartDBDAO
IntramartFileServerConnector
IntramartFileServerDAO
JDBCConnector
LoginGroupDBConnector
LoginGroupDBDAO
ResourceModel
ResourceParam
SystemDBConnector
SystemDBDAO
TextFileDataPropertyHandler
XmlDataPropertyHandler
例外
DAOException
DataAccessException
DataConnectException
DataConnectorException
DataManagerException
DataPropertyException


jp.co.intra_mart.framework.base.data (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data

データアクセスに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
DAO | データリソースにアクセスするインタフェースです。
DataPropertyHandler | DAOの設定情報に接続するクラスです。

クラスの概要
ConnectorModel | コネクタ情報を管理するクラスです。
DAOAdapter | DAOのすべてのメソッドを何もしないように実装したクラスです。
DaoModel | DaoModelを管理するクラスです。
DataAccessController | データアクセスを制御します。
DataConnector | データストアに接続するコネクタです。
DataManager | データストアとの接続を管理します。
DataSourceConnector | DataSourceに関連するデータコネクタです。
DBConnector | データベースに対するコネクタです。
DBDAO | データベースに特化したDAOです。
DefaultDataPropertyHandler | デフォルトのデータプロパティハンドラです。
DistributesDataPropertyHandler | アプリケーション毎のプロパティハンドラを呼び出します。
IntramartDBConnector | 推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
IntramartDBDAO | 推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
IntramartFileServerConnector | intra-martのStorageサービスに接続するデータコネクタです。
IntramartFileServerDAO | intra-martのStorageサービスを使用する場合のDAOです。
JDBCConnector | 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
LoginGroupDBConnector | イントラマートで設定されているDBコネクションです。
LoginGroupDBDAO | イントラマートで設定されたDBへアクセスするDAOです。
ResourceModel | Resource情報を管理するクラスです。
ResourceParam | データコネクタの初期パラメータです。
SystemDBConnector | イントラマートで設定されているDBコネクションです。
SystemDBDAO | イントラマートで設定されたDBへアクセスするDAOです。
TextFileDataPropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
XmlDataPropertyHandler | XMLのデータプロパティハンドラです。

例外の概要
DAOException | リソースコネクタの情報取得時の例外です。
DataAccessException | データアクセス時の例外です。
DataConnectException | データ接続に関連する例外です。
DataConnectorException | データコネクタ取得時の例外です。
DataManagerException | データマネージャの設定時の例外です。
DataPropertyException | データプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.data の説明

データアクセスに関連するクラスのパッケージです。 EIS層（データベース、基幹システムなど）にアクセスするためのクラスがあります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.data クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.ConnectorModel
    • class jp.co.intra_mart.framework.base.data.DAOAdapter (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DaoModel
    • class jp.co.intra_mart.framework.base.data.DataAccessController
    • class jp.co.intra_mart.framework.base.data.DataConnector
      • class jp.co.intra_mart.framework.base.data.DBConnector
        • class jp.co.intra_mart.framework.base.data.DataSourceConnector
        • class jp.co.intra_mart.framework.base.data.JDBCConnector
      • class jp.co.intra_mart.framework.base.data.IntramartDBConnector
      • class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
      • class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
      • class jp.co.intra_mart.framework.base.data.SystemDBConnector
    • class jp.co.intra_mart.framework.base.data.DataManager
    • class jp.co.intra_mart.framework.base.data.DBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.IntramartDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.data.ResourceParam
    • class jp.co.intra_mart.framework.base.data.ResourceModel
    • class jp.co.intra_mart.framework.base.data.SystemDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.data.DAOException
            • class jp.co.intra_mart.framework.base.data.DataAccessException
            • class jp.co.intra_mart.framework.base.data.DataConnectException
            • class jp.co.intra_mart.framework.base.data.DataConnectorException
            • class jp.co.intra_mart.framework.base.data.DataManagerException
            • class jp.co.intra_mart.framework.base.data.DataPropertyException
    • class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.base.data.DAO
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.data.DataPropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.data の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.data の使用

jp.co.intra_mart.framework.base.data を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.base.data のクラス
DAO
データリソースにアクセスするインタフェースです。
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnector
データストアに接続するコネクタです。
DataConnectorException
データコネクタ取得時の例外です。
DataManager
データストアとの接続を管理します。
DataManagerException
データマネージャの設定時の例外です。
DataPropertyException
データプロパティ取得時の例外です。
DataPropertyHandler
DAOの設定情報に接続するクラスです。
DBConnector
データベースに対するコネクタです。
ResourceParam
データコネクタの初期パラメータです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.data のクラス
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnectorException
データコネクタ取得時の例外です。
DataPropertyException
データプロパティ取得時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ResourceModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ResourceModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.ResourceModel
public class ResourceModel
extends Object

Resource情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
static String | P_ID_RESOURCE_NAME
static String | P_ID_RESOURCE_PARAM
コンストラクタの概要
ResourceModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_RESOURCE_NAME

public static final String P_ID_RESOURCE_NAME
関連項目:
定数フィールド値

P_ID_RESOURCE_PARAM

public static final String P_ID_RESOURCE_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

ResourceModel

public ResourceModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ResourceParam (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ResourceParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.data.ResourceParam
public class ResourceParam
extends PropertyParam

データコネクタの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
ResourceParam()
ResourceParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResourceParam

public ResourceParam()
ResourceParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemDBConnector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス SystemDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.SystemDBConnector
public class SystemDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。
システムに設定されている情報からコネクションを取得します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
protected  Map connections
リソース一覧
コンストラクタの概要
SystemDBConnector()
SystemDBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String connect) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
リソース一覧

コンストラクタの詳細

SystemDBConnector

public SystemDBConnector()
SystemDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getConnection

public Connection getConnection(String connect)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemDBDAO (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス SystemDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.SystemDBDAO
すべての実装インタフェース:
DAO
public class SystemDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 システム登録されているIDをキーとしてDBへアクセスするDAOを作る場合、このクラスをextendsします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
SystemDBDAO()
IntramartDBDAOを新規に生成します。
メソッドの概要
Connection | getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SystemDBDAO

public SystemDBDAO()
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public Connection getConnection()
                         throws DataConnectException,
                                DataPropertyException
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileDataPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス TextFileDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class TextFileDataPropertyHandler
extends Object
implements DataPropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultDataPropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileDataPropertyHandler()
TextFileDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileDataPropertyHandler

public TextFileDataPropertyHandler()
TextFileDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlDataPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス XmlDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class XmlDataPropertyHandler
extends Object
implements DataPropertyHandler

XMLのデータプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.xml」です。また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのXMLファイル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM XMLファイル名のパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
コンストラクタの概要
XmlDataPropertyHandler()
コンストラクタです。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのXMLファイル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
XMLファイル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlDataPropertyHandler

public XmlDataPropertyHandler()
コンストラクタです。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListener の使用

EJBEventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListener の使用

jp.co.intra_mart.framework.base.event での EJBEventListener のサブクラス
class | GenericEJBEventListener EJBを利用する汎用的なイベントリスナです。
class | GenericEJBEventListenerLocal ローカルEJBを利用する汎用的なイベントリスナです。
class | StandardEJBEventListener StandardEJBEventListenerAgentに接続するイベントリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の使用

EJBEventListenerAgentBean を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event での EJBEventListenerAgentBean のサブクラス
class | GenericEJBEventListenerAgentBean EJBを利用する汎用的なイベントリスナーのBeanです。
class | StandardEJBEventListenerAgentBean EJBを利用する場合の抽象的なイベントリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の使用

EJBEventListenerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event での EJBEventListenerFactory のサブクラス
class | GenericEJBEventListenerFactory GenericEJBEventListenerを生成します。
class | GenericEJBEventListenerLocalFactory GenericEJBEventListnerLocalを新規に生成します。
class | StandardEJBEventListenerFactory 標準的なEJB用のイベントリスナファクトリです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EmptyEvent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EmptyEvent の使用

jp.co.intra_mart.framework.base.event.EmptyEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.Event の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.Event の使用

Event を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での Event の使用

jp.co.intra_mart.framework.base.event での Event のサブクラス
 class EmptyEvent
情報を何も持たないイベントです。

Event を返す jp.co.intra_mart.framework.base.event のメソッド
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.service での Event の使用

Event を返す jp.co.intra_mart.framework.base.service のメソッド
protected  Event ServiceControllerAdapter.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での Event の使用

Event を返す jp.co.intra_mart.framework.base.web.bean のメソッド
protected  Event HelperBean.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での Event の使用

Event を返す jp.co.intra_mart.framework.extension.common.util のメソッド
static Event ServiceUtils.createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.struts.action での Event の使用

Event を返す jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  Event IntramartAction.createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation.view での Event の使用

Event を返す jp.co.intra_mart.framework.presentation.view のメソッド
protected  Event AbstractViewConverter.createEvent(RequestInfo info, String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
protected  EventResult AbstractViewConverter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventException の使用

EventException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected  EventResult StandardEventListener.dispatchEvent(Event event)
イベント処理を実行します。
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
 EventResult EventManager.dispatch(Event event)
イベントに対する処理を実行します。
 EventResult EventManager.dispatch(Event event, boolean transaction)
イベントに対する処理を実行します。
protected  EventResult EJBEventListenerAgentBean.dispatchEvent(Event event)
イベント処理を実行します。
protected  EventResult EJBEventListener.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.service での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での EventException の使用

EventException をスローする jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.struts.action での EventException の使用

EventException をスローする jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation.view での EventException の使用

EventException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
protected  EventResult AbstractViewConverter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventFactoryModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventFactoryModel の使用

jp.co.intra_mart.framework.base.event.EventFactoryModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventGroupModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventGroupModel の使用

jp.co.intra_mart.framework.base.event.EventGroupModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListener の使用

EventListener を実装している jp.co.intra_mart.framework.base.event のクラス
class | EJBEventListener EJBを利用する場合のイベントリスナです。
class | GenericEJBEventListener EJBを利用する汎用的なイベントリスナです。
class | GenericEJBEventListenerLocal ローカルEJBを利用する汎用的なイベントリスナです。
class | GenericEventListener 汎用的なイベントリスナです。
class | StandardEJBEventListener StandardEJBEventListenerAgentに接続するイベントリスナです。
class | StandardEventListener 汎用的なビジネスロジック用のクラスです。

EventListener を返す jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventListenerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventListenerException の使用

EventListenerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerException の使用

EventListenerException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
void | StandardEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
void | StandardEJBEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
void | GenericEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
void | GenericEJBEventListenerLocalFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
void | GenericEJBEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。
void | EventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventListenerFactory の使用

EventListenerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerFactory の使用

EventListenerFactory を実装している jp.co.intra_mart.framework.base.event のクラス
class | EJBEventListenerFactory EJBEventListenerFactoryを生成します。
class | GenericEJBEventListenerFactory GenericEJBEventListenerを生成します。
class | GenericEJBEventListenerLocalFactory GenericEJBEventListnerLocalを新規に生成します。
class | GenericEventListenerFactory GenericEventListenerを生成するイベントリスナファクトリです。
class | StandardEJBEventListenerFactory 標準的なEJB用のイベントリスナファクトリです。
class | StandardEventListenerFactory 通常のJavaクラスのイベントリスナを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventListenerFactoryParam の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventListenerFactoryParam の使用

EventListenerFactoryParam を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerFactoryParam の使用

EventListenerFactoryParam を返す jp.co.intra_mart.framework.base.event のメソッド
EventListenerFactoryParam[] | XmlEventPropertyHandler.getEventListenerFactoryParams(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | TextFileEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | EventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | DistributesEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | DefaultEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventManager の使用

EventManager を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventManager の使用

EventManager を返す jp.co.intra_mart.framework.base.event のメソッド
static EventManager EventManager.getEventManager()
イベントマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventManagerException の使用

EventManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
static EventManager | EventManager.getEventManager() イベントマネージャを取得します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

EventManagerException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

jp.co.intra_mart.framework.base.service での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.struts.action での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation.view での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
protected  EventResult AbstractViewConverter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventModelProducer の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventModelProducer の使用

jp.co.intra_mart.framework.base.event.EventModelProducer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventPropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventPropertyException の使用

EventPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventPropertyException の使用

EventPropertyException をスローする jp.co.intra_mart.framework.base.event のメソッド
 boolean XmlEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String XmlEventPropertyHandler.getEventName(String application, String key)
アプリケーションIDとキーに該当するイベントのクラス名を取得します。
 String XmlEventPropertyHandler.getEventListenerFactoryName(String application, String key)
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] XmlEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection XmlEventPropertyHandler.getEventTriggerInfos(String application, String key)
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection XmlEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 String TextFileEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String TextFileEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] TextFileEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection TextFileEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection TextFileEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 boolean EventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String EventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String EventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] EventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection EventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection EventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
 boolean DistributesEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DistributesEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String DistributesEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] DistributesEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection DistributesEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection DistributesEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 boolean DefaultEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DefaultEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String DefaultEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] DefaultEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection DefaultEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection DefaultEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。

EventPropertyException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventPropertyHandler の使用

EventPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventPropertyHandler の使用

EventPropertyHandler を実装している jp.co.intra_mart.framework.base.event のクラス
class | DefaultEventPropertyHandler デフォルトのEventPropertyHandlerです。
class | DistributesEventPropertyHandler アプリケーション毎のEventPropertyHandlerを呼び出します。
class | TextFileEventPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlEventPropertyHandler XMLのEventPropertyHandlerです。

EventPropertyHandler を返す jp.co.intra_mart.framework.base.event のメソッド
 EventPropertyHandler EventManager.getEventPropertyHandler()
イベントプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventResult の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventResult の使用

EventResult を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.service での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.struts.action での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation.view での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.presentation.view のメソッド
protected  EventResult AbstractViewConverter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.EventTrigger の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventTrigger の使用

EventTrigger を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventTrigger の使用

EventTrigger を実装している jp.co.intra_mart.framework.base.event のクラス
 class EventTriggerAdapter
DAOを取得するメソッドを持ったイベントトリガです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerAdapter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerAdapter の使用

jp.co.intra_mart.framework.base.event.EventTriggerAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerException の使用

EventTriggerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventTriggerException の使用

EventTriggerException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerInfo の使用

jp.co.intra_mart.framework.base.event.EventTriggerInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.EventTriggerList の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerList の使用

jp.co.intra_mart.framework.base.event.EventTriggerList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListener の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent の使用

GenericEJBEventListenerAgent を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgent の使用

GenericEJBEventListenerAgent を返す jp.co.intra_mart.framework.base.event のメソッド
 GenericEJBEventListenerAgent GenericEJBEventListenerAgentHome.create()
リモートインタフェースGenericEJBEventListenerAgentを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome の使用

GenericEJBEventListenerAgentHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentHome の使用

GenericEJBEventListenerAgentHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
GenericEJBEventListener(GenericEJBEventListenerAgentHome home, String listenerName)
GenericEJBEventListenerを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal の使用

GenericEJBEventListenerAgentLocal を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentLocal の使用

GenericEJBEventListenerAgentLocal を返す jp.co.intra_mart.framework.base.event のメソッド
 GenericEJBEventListenerAgentLocal GenericEJBEventListenerAgentLocalHome.create()
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome の使用

GenericEJBEventListenerAgentLocalHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentLocalHome の使用

GenericEJBEventListenerAgentLocalHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home, String listenerName)
GenericEJBEventListnerLocalを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEventListener の使用

jp.co.intra_mart.framework.base.event.GenericEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.GenericEventListenerFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.GenericEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListener の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent の使用

StandardEJBEventListenerAgent を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEJBEventListenerAgent の使用

StandardEJBEventListenerAgent を返す jp.co.intra_mart.framework.base.event のメソッド
 StandardEJBEventListenerAgent StandardEJBEventListenerAgentHome.create()
StandardEJBEventListenerAgentと接続します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome の使用

StandardEJBEventListenerAgentHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEJBEventListenerAgentHome の使用

StandardEJBEventListenerAgentHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEventListener の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEventListener の使用

StandardEventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEventListener の使用

StandardEventListener 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
 void GenericEventListener.setListener(StandardEventListener listener)
イベント処理クラスを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.StandardEventListenerFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.StandardEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DefaultEventPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス DefaultEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class DefaultEventPropertyHandler
extends Object
implements EventPropertyHandler

デフォルトのEventPropertyHandlerです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの設定内容は以下のとおりです。

キー | 内容
event.class.キー | キーに対応するEventのクラス名
factory.class.キー | キーに対応するEventListenerFactoryのクラス名
factory.param.キー.パラメータ名 | キーに対応するEventListenerFactoryのパラメータの値
trigger.class.キー.ソート番号[.pre] | キーに対応するEventTriggerのクラス名 複数指定した場合、トリガはソート番号の順番に処理されます。 このトリガは該当するイベントリスナが処理される前に起動します。
trigger.class.キー.ソート番号.post | キーに対応するEventTriggerのクラス名 複数指定した場合、トリガはソート番号の順番に処理されます。 このトリガは該当するイベントリスナが処理された後に起動します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultEventPropertyHandler

public DefaultEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DistributesEventPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス DistributesEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class DistributesEventPropertyHandler
extends Object
implements EventPropertyHandler

アプリケーション毎のEventPropertyHandlerを呼び出します。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」、または「プレフィックス_アプリケーションID.xml」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION アプリケーション
static String | PARAM_APPLICATION_CLASS クラス
static String | PARAM_APPLICATION_PARAM パラメータ
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT デフォルト
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
DistributesEventPropertyHandler()
DistributesEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
デフォルト

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
アプリケーション

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
パラメータ

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
クラス

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesEventPropertyHandler

public DistributesEventPropertyHandler()
DistributesEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
すべての実装インタフェース:
EventListener
直系の既知のサブクラス:
GenericEJBEventListener, GenericEJBEventListenerLocal, StandardEJBEventListener
public abstract class EJBEventListener
extends Object
implements EventListener

EJBを利用する場合のイベントリスナです。

バージョン:
1.0

コンストラクタの概要
EJBEventListener()
EJBEventListenerを新規に生成します。
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.event.EventListener から継承したメソッド
execute

コンストラクタの詳細

EJBEventListener

public EJBEventListener()
EJBEventListenerを新規に生成します。

メソッドの詳細

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。 このクラスでは実際には何も行いません。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListenerAgentBean (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
直系の既知のサブクラス:
GenericEJBEventListenerAgentBean, StandardEJBEventListenerAgentBean
public abstract class EJBEventListenerAgentBean
extends Object
implements SessionBean

Session Beanを利用したイベントリスナの抽象クラスです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
protected  SessionContext sessionContext
セッションコンテキスト
コンストラクタの概要
EJBEventListenerAgentBean()
EJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
void | ejbActivate() "passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。
void | ejbPassivate() インスタンスが"passive"状態に移る前に呼ばれるメソッドです。
void | ejbRemove() Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。
void | setSessionContext(SessionContext sessionContext) 関連するSessionContextを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

sessionContext

protected SessionContext sessionContext
セッションコンテキスト

コンストラクタの詳細

EJBEventListenerAgentBean

public EJBEventListenerAgentBean()
EJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

setSessionContext

public void setSessionContext(SessionContext sessionContext)
関連するSessionContextを設定します。 コンテナはインスタンス生成後にこのメソッドを呼び出します。

定義:
インタフェース SessionBean 内の setSessionContext
パラメータ:
sessionContext - SessionContextインタフェース

ejbRemove

public void ejbRemove()
               throws EJBException
Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。

定義:
インタフェース SessionBean 内の ejbRemove
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

ejbActivate

public void ejbActivate()
                 throws EJBException
"passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。 ejbPassivate()メソッドで先にリリースされたすべてのリソースを再取得します。

定義:
インタフェース SessionBean 内の ejbActivate
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

ejbPassivate

public void ejbPassivate()
                  throws EJBException
インスタンスが"passive"状態に移る前に呼ばれるメソッドです。 ejbActivate()メソッドで再取得されるリソースをすべてリリースします。

定義:
インタフェース SessionBean 内の ejbPassivate
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EJBEventListenerFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
直系の既知のサブクラス:
GenericEJBEventListenerFactory, GenericEJBEventListenerLocalFactory, StandardEJBEventListenerFactory
public abstract class EJBEventListenerFactory
extends Object
implements EventListenerFactory

EJBEventListenerFactoryを生成します。 イベントリスナファクトリの設定では、以下の初期パラメータの設定が必須です。

バージョン:
1.0

フィールドの概要
static String HOME_PARAM
ホームインタフェースを取得するときのJNDI名のパラメータ名
コンストラクタの概要
EJBEventListenerFactory()
EJBEventListenerFactoryを新規に生成します。
メソッドの概要
String | getJNDIName() EJBEventListenerAgentHomeのJNDI名を取得します。
protected void | setJNDIName(String jndiName) EJBEventListenerAgentHomeのJNDI名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory から継承したメソッド
create, initParam

フィールドの詳細

HOME_PARAM

public static final String HOME_PARAM
ホームインタフェースを取得するときのJNDI名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

EJBEventListenerFactory

public EJBEventListenerFactory()
EJBEventListenerFactoryを新規に生成します。

メソッドの詳細

setJNDIName

protected void setJNDIName(String jndiName)
EJBEventListenerAgentHomeのJNDI名を設定します。

パラメータ:
jndiName - EJBEventListenerAgentHomeのJNDI名

getJNDIName

public String getJNDIName()
EJBEventListenerAgentHomeのJNDI名を取得します。

戻り値:
EJBEventListenerAgentHomeのJNDI名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EmptyEvent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EmptyEvent

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.Event
        拡張 jp.co.intra_mart.framework.base.event.EmptyEvent
すべての実装インタフェース:
Serializable
public class EmptyEvent
extends Event

情報を何も持たないイベントです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyEvent()
クラス jp.co.intra_mart.framework.base.event.Event から継承したメソッド
getApplication, getKey, getLoginGroup, getLoginGroupID, getLoginUser, getLoginUserID, getUserInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyEvent

public EmptyEvent()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Event (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス Event

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.Event
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EmptyEvent
public abstract class Event
extends Object
implements Serializable

処理を実行するための情報です。 処理はEventListenerで行われますが、その際に渡される情報をEventのサブクラスで定義します。 Eventのサブクラスを生成する場合はコンストラクタを使用せず、変わりにEventManager.createEvent(String, String, String, String)を使用してください。
注意：
このクラスのサブクラスでは以下のフィールドは定義しないでください。

  • applicationフィールド
  • keyフィールド
  • loginUserIDフィールド
  • loginGroupIDフィールド

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
Event()
イベントを新規に生成します。
メソッドの概要
String | getApplication() アプリケーションを取得します。
String | getKey() イベントキーを取得します。
String | getLoginGroup() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUser() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
UserInfo | getUserInfo() ログインユーザの情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Event

public Event()
イベントを新規に生成します。

メソッドの詳細

getKey

public final String getKey()
イベントキーを取得します。

戻り値:
イベントキー

getApplication

public final String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

getUserInfo

public UserInfo getUserInfo()
ログインユーザの情報を取得します。
ログインセッションが存在しない場合nullを返却します。

戻り値:
ログインユーザの情報
導入されたバージョン:
5.0

getLoginUser

public final String getLoginUser()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID

getLoginUserID

public final String getLoginUserID()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
導入されたバージョン:
3.2

getLoginGroup

public final String getLoginGroup()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID

getLoginGroupID

public final String getLoginGroupID()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventException
すべての実装インタフェース:
Serializable
public class EventException
extends SystemException

イベント生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventException()
詳細メッセージを指定しないで EventException を構築します。
EventException(String msg)
指定された詳細メッセージを持つ EventException を構築します。
EventException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventException

public EventException()
詳細メッセージを指定しないで EventException を構築します。

EventException

public EventException(String msg)
指定された詳細メッセージを持つ EventException を構築します。

パラメータ:
msg - 詳細メッセージ

EventException

public EventException(String msg,
                      Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventFactoryModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventFactoryModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventFactoryModel
public class EventFactoryModel
extends Object

イベントリスナーファクトリー情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_FACTORY_CLASS
static String | P_ID_FACTORY_PARAM
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
コンストラクタの概要
EventFactoryModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_FACTORY_CLASS

public static final String P_ID_FACTORY_CLASS
関連項目:
定数フィールド値

P_ID_FACTORY_PARAM

public static final String P_ID_FACTORY_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

EventFactoryModel

public EventFactoryModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventGroupModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventGroupModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventGroupModel
public class EventGroupModel
extends Object

Event情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_EVENT_KEY
static String | P_ID_EVENT_NAME
static String | P_ID_POST_TRIGGER
static String | P_ID_PRE_TRIGGER
static String | P_ID_TRIGGER_CLASS
コンストラクタの概要
EventGroupModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_EVENT_KEY

public static final String P_ID_EVENT_KEY
関連項目:
定数フィールド値

P_ID_EVENT_NAME

public static final String P_ID_EVENT_NAME
関連項目:
定数フィールド値

P_ID_PRE_TRIGGER

public static final String P_ID_PRE_TRIGGER
関連項目:
定数フィールド値

P_ID_POST_TRIGGER

public static final String P_ID_POST_TRIGGER
関連項目:
定数フィールド値

P_ID_TRIGGER_CLASS

public static final String P_ID_TRIGGER_CLASS
関連項目:
定数フィールド値
コンストラクタの詳細

EventGroupModel

public EventGroupModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventListener

既知の実装クラスの一覧:
EJBEventListener, GenericEventListener, StandardEventListener
public interface EventListener

イベントリスナです。

バージョン:
1.0

メソッドの概要
EventResult | execute(Event event) 処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventListenerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventListenerException
すべての実装インタフェース:
Serializable
public class EventListenerException
extends SystemException

イベントリスナ生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventListenerException()
詳細メッセージを指定しないで EventListenerException を構築します。
EventListenerException(String msg)
指定された詳細メッセージを持つ EventListenerException を構築します。
EventListenerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventListenerException

public EventListenerException()
詳細メッセージを指定しないで EventListenerException を構築します。

EventListenerException

public EventListenerException(String msg)
指定された詳細メッセージを持つ EventListenerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventListenerException

public EventListenerException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListenerFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventListenerFactory

既知の実装クラスの一覧:
EJBEventListenerFactory, GenericEventListenerFactory, StandardEventListenerFactory
public interface EventListenerFactory

イベントリスナを生成します。 EventListenerFactoryは生成するEventListenerの種別ごとに必要です。

バージョン:
1.0

メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventListenerFactoryParam (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventListenerFactoryParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
public class EventListenerFactoryParam
extends PropertyParam

イベントリスナファクトリの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
EventListenerFactoryParam()
EventListenerFactoryParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventListenerFactoryParam

public EventListenerFactoryParam()
EventListenerFactoryParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventManager
public class EventManager
extends Object

イベントマネージャです。

バージョン:
1.0

フィールドの概要
static String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー
メソッドの概要
Event | createEvent(String application, String key, String loginUser, String loginGroup) 推奨されていません。 このメソッドではなくcreateEvent(String, String, UserInfo)を使用してください。
Event | createEvent(String application, String key, UserInfo info) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event) イベントに対する処理を実行します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
static EventManager | getEventManager() イベントマネージャを取得します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

EVENT_PROPERTY_HANDLER_KEY

public static final String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getEventManager

public static EventManager getEventManager()
                                    throws EventManagerException
イベントマネージャを取得します。

戻り値:
イベントマネージャ
例外:
EventManagerException - イベントマネージャの生成時に例外が発生

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
イベントプロパティハンドラを取得します。

戻り値:
イベントプロパティハンドラ

createEvent

public Event createEvent(String application,
                         String key,
                         UserInfo info)
                  throws EventPropertyException,
                         EventException
パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

パラメータ:
application - アプリケーション名
key - キー
info - ログインユーザ情報
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗
導入されたバージョン:
5.0

createEvent

public Event createEvent(String application,
                         String key,
                         String loginUser,
                         String loginGroup)
                  throws EventPropertyException,
                         EventException
推奨されていません。 このメソッドではなくcreateEvent(String, String, UserInfo)を使用してください。

パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

パラメータ:
application - アプリケーション名
key - キー
loginUser - ログインユーザ
loginGroup - ログイングループ
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗

dispatch

public EventResult dispatch(Event event)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。 イベントを渡されると、イベントに関連するEventListenerFactoryから EventListenerを生成し、EventListenerに処理を依頼します。 eventには必ずcreateEvent(String, String, String, String)で取得したイベントを設定してください。 このメソッドはdispatch(event, false)を呼び出したときと同じ効果があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。 イベントを渡されると、イベントに関連するEventListenerFactoryから EventListenerを生成し、EventListenerに処理を依頼します。 eventには必ずcreateEvent(String, String, String, String)で取得したイベントを設定してください。
EventListenerに処理を依頼する際、EventListener.setInTransaction(boolean)メソッドが呼ばれます。 このときにnestで指定された値が渡されます。

パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventManagerException
すべての実装インタフェース:
Serializable
public class EventManagerException
extends SystemException

イベントマネージャ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventManagerException()
詳細メッセージを指定しないで EventManagerException を構築します。
EventManagerException(String msg)
指定された詳細メッセージを持つ EventManagerException を構築します。
EventManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventManagerException

public EventManagerException()
詳細メッセージを指定しないで EventManagerException を構築します。

EventManagerException

public EventManagerException(String msg)
指定された詳細メッセージを持つ EventManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventManagerException

public EventManagerException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventModelProducer (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventModelProducer

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventModelProducer
public class EventModelProducer
extends Object

イベント情報を作成するクラスです。

バージョン:
1.0

コンストラクタの概要
EventModelProducer()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventModelProducer

public EventModelProducer()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventPropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventPropertyException
すべての実装インタフェース:
Serializable
public class EventPropertyException
extends SystemException

イベントプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventPropertyException()
詳細メッセージを指定しないで EventPropertyException を構築します。
EventPropertyException(String msg)
指定された詳細メッセージを持つ EventPropertyException を構築します。
EventPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventPropertyException

public EventPropertyException()
詳細メッセージを指定しないで EventPropertyException を構築します。

EventPropertyException

public EventPropertyException(String msg)
指定された詳細メッセージを持つ EventPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

EventPropertyException

public EventPropertyException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultEventPropertyHandler, DistributesEventPropertyHandler, TextFileEventPropertyHandler, XmlEventPropertyHandler
public interface EventPropertyHandler
extends PropertyHandler

イベントの設定情報に接続するクラスです。

バージョン:
1.0

メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventResult (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventResult

すべてのスーパーインタフェース:
Serializable
public interface EventResult
extends Serializable

イベント処理の結果です。

バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTrigger (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventTrigger

既知の実装クラスの一覧:
EventTriggerAdapter
public interface EventTrigger

イベントトリガです。 このインタフェースを実装するクラスでは、定数(static final)以外のフィールドは定義しないでください。

バージョン:
1.0

メソッドの概要
 void fire(Event event, DataAccessController controller)
イベントに対する処理を行います。

メソッドの詳細

fire

public void fire(Event event,
                 DataAccessController controller)
          throws SystemException,
                 ApplicationException
イベントに対する処理を行います。 トランザクションはcontrollerで管理されています。 このメソッドを実装するとき、内部でトランザクションのロールバックやコミットを行わないようにしてください。 メソッドが失敗した場合、またはロールバックを行いたい場合は、ApplicationExceptionのサブクラスを例外としてthrowしてください。

パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerAdapter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerAdapter
すべての実装インタフェース:
EventTrigger
public abstract class EventTriggerAdapter
extends Object
implements EventTrigger

DAOを取得するメソッドを持ったイベントトリガです。

バージョン:
1.0

コンストラクタの概要
EventTriggerAdapter()
EventTriggerAdapterを新規に生成します。
メソッドの概要
protected abstract void | fire(Event event) イベントに対する処理を行います。
void | fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected Object | getDAO(String application, String key, String connect) DAOを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerAdapter

public EventTriggerAdapter()
EventTriggerAdapterを新規に生成します。

メソッドの詳細

getDAO

protected Object getDAO(String application,
                        String key,
                        String connect)
                 throws DataPropertyException,
                        DataConnectorException,
                        DAOException,
                        DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

fire

public void fire(Event event,
                 DataAccessController controller)
          throws SystemException,
                 ApplicationException
イベントに対する処理を行います。 トランザクションはcontrollerで管理されています。 このメソッドはfire(jp.co.intra_mart.framework.base.event.Event)メソッドを呼ぶように実装されています。

定義:
インタフェース EventTrigger 内の fire
パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生

fire

protected abstract void fire(Event event)
                      throws SystemException,
                             ApplicationException
イベントに対する処理を行います。 このメソッドを実装するとき、内部でトランザクションのロールバックやコミットを行わないようにしてください。 メソッドが失敗した場合、またはロールバックを行いたい場合は、ApplicationExceptionのサブクラスを例外としてthrowしてください。

パラメータ:
event - イベント
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventTriggerException
すべての実装インタフェース:
Serializable
public class EventTriggerException
extends SystemException

イベントトリガ生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventTriggerException()
詳細メッセージを指定しないで EventTriggerException を構築します。
EventTriggerException(String msg)
指定された詳細メッセージを持つ EventTriggerException を構築します。
EventTriggerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventTriggerException

public EventTriggerException()
詳細メッセージを指定しないで EventTriggerException を構築します。

EventTriggerException

public EventTriggerException(String msg)
指定された詳細メッセージを持つ EventTriggerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventTriggerException

public EventTriggerException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventTriggerInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerInfo
public class EventTriggerInfo
extends Object

イベントトリガの情報です。

バージョン:
1.0

コンストラクタの概要
EventTriggerInfo()
EventTriggerInfoを新規に生成します。
メソッドの概要
String | getName() イベントトリガ名を取得します。
int | getNumber() ソート番号を取得します。
void | setName(String name) イベントトリガ名を設定します。
void | setNumber(int number) ソート番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerInfo

public EventTriggerInfo()
EventTriggerInfoを新規に生成します。

メソッドの詳細

setNumber

public void setNumber(int number)
ソート番号を設定します。

パラメータ:
number - ソート番号

getNumber

public int getNumber()
ソート番号を取得します。

戻り値:
ソート番号

setName

public void setName(String name)
イベントトリガ名を設定します。

パラメータ:
name - イベントトリガ名

getName

public String getName()
イベントトリガ名を取得します。

戻り値:
イベントトリガ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


EventTriggerList (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerList

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerList
public class EventTriggerList
extends Object

イベントトリガの集合を扱います。 イベントトリガの生成し、順番に実行します。

バージョン:
1.0

コンストラクタの概要
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。
メソッドの概要
 void fireAll(Event event, DataAccessController controller)
すべてのトリガに対してイベントの処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerList

public EventTriggerList(String application,
                        String key)
                 throws EventManagerException,
                        EventPropertyException,
                        EventTriggerException
EventTriggerListを新規に生成します。 このコンストラクタではイベントの前に処理するEventTriggerListを生成します。 このコンストラクタはEvent(application, key, true) と同じ結果となります。

パラメータ:
application - アプリケーション名
key - キー
例外:
EventManagerException - EventManager生成時に例外が発生した
EventPropertyException - イベントプロパティの取得時に例外が発生した
EventTriggerException - イベントトリガ生成時に例外が発生した

EventTriggerList

public EventTriggerList(String application,
                        String key,
                        boolean pre)
                 throws EventManagerException,
                        EventPropertyException,
                        EventTriggerException
EventTriggerListを新規に生成します。 preによってイベントの前に処理されるイベントトリガであるか イベントの後に処理されるイベントトリガであるかを指定します。

パラメータ:
application - アプリケーション名
key - キー
pre - true:イベントの前に起動するイベントトリガ、false:イベントの後に起動するイベントトリガ
例外:
EventManagerException - EventManager生成時に例外が発生した
EventPropertyException - イベントプロパティの取得時に例外が発生した
EventTriggerException - イベントトリガ生成時に例外が発生した
導入されたバージョン:
4.3
メソッドの詳細

fireAll

public void fireAll(Event event,
                    DataAccessController controller)
             throws SystemException,
                    ApplicationException
すべてのトリガに対してイベントの処理を行います。

パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生した
ApplicationException - アプリケーション例外が発生した
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListener
すべての実装インタフェース:
EventListener
public class GenericEJBEventListener
extends EJBEventListener

EJBを利用する汎用的なイベントリスナです。

バージョン:
1.0

コンストラクタの概要
GenericEJBEventListener(GenericEJBEventListenerAgentHome home, String listenerName)
GenericEJBEventListenerを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListener

public GenericEJBEventListener(GenericEJBEventListenerAgentHome home,
                               String listenerName)
GenericEJBEventListenerを新規に生成します。

パラメータ:
home - ホームインタフェースGenericEJBEventListenerAgentHome
listenerName - 実際に処理を行うStandardEventListenerのクラス名
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgent

すべてのスーパーインタフェース:
EJBObject, Remote
public interface GenericEJBEventListenerAgent
extends EJBObject

汎用的なEJB用のイベントリスナのリモートインタフェースです。

バージョン:
1.0

メソッドの概要
 EventResult execute(Event event, String listenerName)
イベント処理を行います。
インタフェース javax.ejb.EJBObject から継承したメソッド
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           RemoteException,
                           EJBException
イベント処理を行います。 実際の処理はlistenerNameで定義されたクラスで行われます。 listenerNameで指定されるクラスはStandardEventListenerを継承し、引数のないコンストラクタを持つ必要があります。

パラメータ:
event - イベント
listenerName - イベントリスナのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
RemoteException - システムエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentBean (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
public class GenericEJBEventListenerAgentBean
extends EJBEventListenerAgentBean

EJBを利用する汎用的なイベントリスナーのBeanです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したフィールド
sessionContext
コンストラクタの概要
GenericEJBEventListenerAgentBean()
GenericEJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
void | ejbCreate() ホームインタフェースの引数なしのcreate()メソッドに対応します。
EventResult | execute(Event event, String listenerName) イベント処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したメソッド
dispatchEvent, ejbActivate, ejbPassivate, ejbRemove, setSessionContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListenerAgentBean

public GenericEJBEventListenerAgentBean()
GenericEJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

ejbCreate

public void ejbCreate()
ホームインタフェースの引数なしのcreate()メソッドに対応します。

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を実行します。 listenerNameはStandardEventListenerを継承したクラスであり、引数を持たないコンストラクタが存在する必要があります。

パラメータ:
event - イベント
listenerName - リスナーのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentHome (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentHome

すべてのスーパーインタフェース:
EJBHome, Remote
public interface GenericEJBEventListenerAgentHome
extends EJBHome

リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。

バージョン:
1.0

メソッドの概要
 GenericEJBEventListenerAgent create()
リモートインタフェースGenericEJBEventListenerAgentを取得します。
インタフェース javax.ejb.EJBHome から継承したメソッド
getEJBMetaData, getHomeHandle, remove, remove

メソッドの詳細

create

public GenericEJBEventListenerAgent create()
                                    throws RemoteException,
                                           CreateException
リモートインタフェースGenericEJBEventListenerAgentを取得します。

戻り値:
GenericEJBEventListenerAgent
例外:
RemoteException - システムエラー
CreateException - リモートインタフェース取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentLocal (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentLocal

すべてのスーパーインタフェース:
EJBLocalObject
public interface GenericEJBEventListenerAgentLocal
extends EJBLocalObject

汎用的なEJB用のイベントリスナのローカルインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 EventResult execute(Event event, String listenerName)
イベント処理を行います。
インタフェース javax.ejb.EJBLocalObject から継承したメソッド
getEJBLocalHome, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を行います。 実際の処理はlistenerNameで定義されたクラスで行われます。 listenerNameで指定されるクラスはStandardEventListenerを継承し、引数のないコンストラクタを持つ必要があります。

パラメータ:
event - イベント
listenerName - イベントリスナのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerAgentLocalHome (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentLocalHome

すべてのスーパーインタフェース:
EJBLocalHome
public interface GenericEJBEventListenerAgentLocalHome
extends EJBLocalHome

ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 GenericEJBEventListenerAgentLocal create()
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。
インタフェース javax.ejb.EJBLocalHome から継承したメソッド
remove

メソッドの詳細

create

public GenericEJBEventListenerAgentLocal create()
                                         throws CreateException
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。

戻り値:
GenericEJBEventListenerAgentLocal
例外:
RemoteException - システムエラー
CreateException - リモートインタフェース取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEJBEventListenerFactory
extends EJBEventListenerFactory

GenericEJBEventListenerを生成します。

バージョン:
1.0

フィールドの概要
static String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
GenericEJBEventListenerFactory()
GenericEJBEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
String | getListenerName() EJBEventListenerAgentBeanのクラス名を取得します。
void | initParam(String name, String value) 初期パラメータを設定します。
protected void | setListenerName(String listenerName) EJBEventListenerAgentBeanのクラス名を設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LISTENER_PARAM

public static final String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

GenericEJBEventListenerFactory

public GenericEJBEventListenerFactory()
GenericEJBEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生

setListenerName

protected void setListenerName(String listenerName)
EJBEventListenerAgentBeanのクラス名を設定します。

パラメータ:
listenerName - EJBEventListenerAgentBeanのクラス名

getListenerName

public String getListenerName()
EJBEventListenerAgentBeanのクラス名を取得します。

戻り値:
EJBEventListenerAgentBeanのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerLocal (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerLocal

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
すべての実装インタフェース:
EventListener
public class GenericEJBEventListenerLocal
extends EJBEventListener

ローカルEJBを利用する汎用的なイベントリスナです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home, String listenerName)
GenericEJBEventListnerLocalを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListenerLocal

public GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home,
                                    String listenerName)
GenericEJBEventListnerLocalを新規に生成します。

パラメータ:
home - ホームインタフェース
listenerName - 実際に処理を行うStandardEventListenerのクラス名
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEJBEventListenerLocalFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerLocalFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEJBEventListenerLocalFactory
extends EJBEventListenerFactory

GenericEJBEventListnerLocalを新規に生成します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
GenericEJBEventListenerLocalFactory()
GenericEJBEventListnerLocalFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
String | getListenerName() EJBEventListenerAgentBeanのクラス名を取得します。
void | initParam(String name, String value) 初期パラメータを設定します。
protected void | setListenerName(String listenerName) EJBEventListenerAgentBeanのクラス名を設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LISTENER_PARAM

public static final String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

GenericEJBEventListenerLocalFactory

public GenericEJBEventListenerLocalFactory()
GenericEJBEventListnerLocalFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生

setListenerName

protected void setListenerName(String listenerName)
EJBEventListenerAgentBeanのクラス名を設定します。

パラメータ:
listenerName - EJBEventListenerAgentBeanのクラス名

getListenerName

public String getListenerName()
EJBEventListenerAgentBeanのクラス名を取得します。

戻り値:
EJBEventListenerAgentBeanのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.GenericEventListener
すべての実装インタフェース:
EventListener
public class GenericEventListener
extends Object
implements EventListener

汎用的なイベントリスナです。

バージョン:
1.0

コンストラクタの概要
GenericEventListener()
GenericEventListenerを新規に生成します。
メソッドの概要
EventResult | execute(Event event) 処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
void | setListener(StandardEventListener listener) イベント処理クラスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEventListener

public GenericEventListener()
GenericEventListenerを新規に生成します。

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

定義:
インタフェース EventListener 内の execute
パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

setListener

public void setListener(StandardEventListener listener)
イベント処理クラスを設定します。

パラメータ:
listener - イベント処理クラス

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericEventListenerFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.GenericEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEventListenerFactory
extends Object
implements EventListenerFactory

GenericEventListenerを生成するイベントリスナファクトリです。 このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 包含するイベントリスナ

バージョン:
1.0

コンストラクタの概要
GenericEventListenerFactory()
GenericEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEventListenerFactory

public GenericEventListenerFactory()
GenericEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.event (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.event
インタフェース
EventListener
EventListenerFactory
EventPropertyHandler
EventResult
EventTrigger
GenericEJBEventListenerAgent
GenericEJBEventListenerAgentHome
GenericEJBEventListenerAgentLocal
GenericEJBEventListenerAgentLocalHome
StandardEJBEventListenerAgent
StandardEJBEventListenerAgentHome
クラス
DefaultEventPropertyHandler
DistributesEventPropertyHandler
EJBEventListener
EJBEventListenerAgentBean
EJBEventListenerFactory
EmptyEvent
Event
EventFactoryModel
EventGroupModel
EventListenerFactoryParam
EventManager
EventModelProducer
EventTriggerAdapter
EventTriggerInfo
EventTriggerList
GenericEJBEventListener
GenericEJBEventListenerAgentBean
GenericEJBEventListenerFactory
GenericEJBEventListenerLocal
GenericEJBEventListenerLocalFactory
GenericEventListener
GenericEventListenerFactory
StandardEJBEventListener
StandardEJBEventListenerAgentBean
StandardEJBEventListenerFactory
StandardEventListener
StandardEventListenerFactory
TextFileEventPropertyHandler
XmlEventPropertyHandler
例外
EventException
EventListenerException
EventManagerException
EventPropertyException
EventTriggerException


jp.co.intra_mart.framework.base.event (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event

イベントフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
EventListener | イベントリスナです。
EventListenerFactory | イベントリスナを生成します。
EventPropertyHandler | イベントの設定情報に接続するクラスです。
EventResult | イベント処理の結果です。
EventTrigger | イベントトリガです。
GenericEJBEventListenerAgent | 汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentHome | リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal | 汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome | ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
StandardEJBEventListenerAgent | EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentHome | StandardEJBEventListenerAgentのホームインタフェースです。

クラスの概要
DefaultEventPropertyHandler | デフォルトのEventPropertyHandlerです。
DistributesEventPropertyHandler | アプリケーション毎のEventPropertyHandlerを呼び出します。
EJBEventListener | EJBを利用する場合のイベントリスナです。
EJBEventListenerAgentBean | Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerFactory | EJBEventListenerFactoryを生成します。
EmptyEvent | 情報を何も持たないイベントです。
Event | 処理を実行するための情報です。
EventFactoryModel | イベントリスナーファクトリー情報を管理するクラスです。
EventGroupModel | Event情報を管理するクラスです。
EventListenerFactoryParam | イベントリスナファクトリの初期パラメータです。
EventManager | イベントマネージャです。
EventModelProducer | イベント情報を作成するクラスです。
EventTriggerAdapter | DAOを取得するメソッドを持ったイベントトリガです。
EventTriggerInfo | イベントトリガの情報です。
EventTriggerList | イベントトリガの集合を扱います。
GenericEJBEventListener | EJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerAgentBean | EJBを利用する汎用的なイベントリスナーのBeanです。
GenericEJBEventListenerFactory | GenericEJBEventListenerを生成します。
GenericEJBEventListenerLocal | ローカルEJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerLocalFactory | GenericEJBEventListnerLocalを新規に生成します。
GenericEventListener | 汎用的なイベントリスナです。
GenericEventListenerFactory | GenericEventListenerを生成するイベントリスナファクトリです。
StandardEJBEventListener | StandardEJBEventListenerAgentに接続するイベントリスナです。
StandardEJBEventListenerAgentBean | EJBを利用する場合の抽象的なイベントリスナです。
StandardEJBEventListenerFactory | 標準的なEJB用のイベントリスナファクトリです。
StandardEventListener | 汎用的なビジネスロジック用のクラスです。
StandardEventListenerFactory | 通常のJavaクラスのイベントリスナを生成します。
TextFileEventPropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
XmlEventPropertyHandler | XMLのEventPropertyHandlerです。

例外の概要
EventException | イベント生成時の例外です。
EventListenerException | イベントリスナ生成時の例外です。
EventManagerException | イベントマネージャ設定時の例外です。
EventPropertyException | イベントプロパティ取得時の例外です。
EventTriggerException | イベントトリガ生成時の例外です。

パッケージ jp.co.intra_mart.framework.base.event の説明

イベントフレームワークに関連するクラスのパッケージです。 イベントフレームワークを利用して処理を行う手順の概要は次のとおりです。

  • アプリケーションIDとイベントキーからEventを生成する。
  • Eventに処理に必要となる情報を設定する。
  • アプリケーションIDとイベントキーに対応するEventListenerにEventを渡し、処理を行う。
  • EventListenerは処理結果となるEventResultを返す。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.event クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.EJBEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListener
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListener
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean (implements javax.ejb.SessionBean)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
    • class jp.co.intra_mart.framework.base.event.Event (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.event.EmptyEvent
    • class jp.co.intra_mart.framework.base.event.EventFactoryModel
    • class jp.co.intra_mart.framework.base.event.EventGroupModel
    • class jp.co.intra_mart.framework.base.event.EventManager
    • class jp.co.intra_mart.framework.base.event.EventModelProducer
    • class jp.co.intra_mart.framework.base.event.EventTriggerAdapter (implements jp.co.intra_mart.framework.base.event.EventTrigger)
    • class jp.co.intra_mart.framework.base.event.EventTriggerInfo
    • class jp.co.intra_mart.framework.base.event.EventTriggerList
    • class jp.co.intra_mart.framework.base.event.GenericEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
    • class jp.co.intra_mart.framework.base.event.StandardEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.event.EventException
            • class jp.co.intra_mart.framework.base.event.EventListenerException
            • class jp.co.intra_mart.framework.base.event.EventManagerException
            • class jp.co.intra_mart.framework.base.event.EventPropertyException
            • class jp.co.intra_mart.framework.base.event.EventTriggerException
    • class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)

インタフェース階層

  • interface javax.ejb.EJBLocalHome
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome
  • interface javax.ejb.EJBLocalObject
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal
  • interface jp.co.intra_mart.framework.base.event.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListenerFactory
  • interface jp.co.intra_mart.framework.base.event.EventTrigger
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.event.EventPropertyHandler
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
    • interface javax.ejb.EJBObject
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.event.EventResult
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.event の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.event の使用

jp.co.intra_mart.framework.base.event を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.event のクラス
EJBEventListener
EJBを利用する場合のイベントリスナです。
EJBEventListenerAgentBean
Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerFactory
EJBEventListenerFactoryを生成します。
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventListener
イベントリスナです。
EventListenerException
イベントリスナ生成時の例外です。
EventListenerFactory
イベントリスナを生成します。
EventListenerFactoryParam
イベントリスナファクトリの初期パラメータです。
EventManager
イベントマネージャです。
EventManagerException
イベントマネージャ設定時の例外です。
EventPropertyException
イベントプロパティ取得時の例外です。
EventPropertyHandler
イベントの設定情報に接続するクラスです。
EventResult
イベント処理の結果です。
EventTrigger
イベントトリガです。
EventTriggerException
イベントトリガ生成時の例外です。
GenericEJBEventListenerAgent
汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentHome
リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal
汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome
ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
StandardEJBEventListenerAgent
EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentHome
StandardEJBEventListenerAgentのホームインタフェースです。
StandardEventListener
汎用的なビジネスロジック用のクラスです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.extension.common.util により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.extension.struts.action により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StandardEJBEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListener
すべての実装インタフェース:
EventListener
public class StandardEJBEventListener
extends EJBEventListener

StandardEJBEventListenerAgentに接続するイベントリスナです。

バージョン:
1.0

コンストラクタの概要
StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListener

public StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。

パラメータ:
home - ホームインタフェースStandardEJBEventListenerAgentHome
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース StandardEJBEventListenerAgent

すべてのスーパーインタフェース:
EJBObject, Remote
public interface StandardEJBEventListenerAgent
extends EJBObject

EJBを利用するときのイベントリスナのリモートインタフェースです。

バージョン:
1.0

メソッドの概要
 EventResult execute(Event event)
イベント処理を実行します。
インタフェース javax.ejb.EJBObject から継承したメソッド
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws ApplicationException,
                           SystemException,
                           RemoteException,
                           EJBException
イベント処理を実行します。 実際の処理はStandardEJBEventListenerAgentBean.execute(jp.co.intra_mart.framework.base.event.Event)で行われます。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
RemoteException - システムエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgentBean (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
public abstract class StandardEJBEventListenerAgentBean
extends EJBEventListenerAgentBean

EJBを利用する場合の抽象的なイベントリスナです。 メソッドfire(jp.co.intra_mart.framework.base.event.Event, jp.co.intra_mart.framework.base.data.DataAccessController)を実装する必要があります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したフィールド
sessionContext
コンストラクタの概要
StandardEJBEventListenerAgentBean()
StandardEJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
void | ejbCreate() ホームインタフェースの引数なしのcreate()メソッドに対応します。
EventResult | execute(Event event) イベント処理を実行します。
protected abstract EventResult | fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したメソッド
dispatchEvent, ejbActivate, ejbPassivate, ejbRemove, setSessionContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListenerAgentBean

public StandardEJBEventListenerAgentBean()
StandardEJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

ejbCreate

public void ejbCreate()
ホームインタフェースの引数なしのcreate()メソッドに対応します。

導入されたバージョン:
3.2

execute

public EventResult execute(Event event)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を実行します。 このクラスでは以下のような順番で処理を行います。
  1. イベントトリガの実行(前処理)
  2. イベント処理の実行(fire(Event, DataAccessController))
  3. イベントトリガの実行(後処理)
  4. 簡易トランザクションのコミット(DataAccessController.commit())
このクラスではStandardEventListener.execute(Event)とは違い直接UserTransactionを扱っていません。そのため、このEJBを使うためにはコンテナ管理トランザクション(Container-management Transaction:CMT)を使用してください。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー

fire

protected abstract EventResult fire(Event event,
                                    DataAccessController dataAccessController)
                             throws SystemException,
                                    ApplicationException
イベントに対する処理です。

パラメータ:
event - イベント
dataAccessController - データアクセスコントローラ
戻り値:
イベント処理結果
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerAgentHome (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース StandardEJBEventListenerAgentHome

すべてのスーパーインタフェース:
EJBHome, Remote
public interface StandardEJBEventListenerAgentHome
extends EJBHome

StandardEJBEventListenerAgentのホームインタフェースです。

バージョン:
1.0

メソッドの概要
 StandardEJBEventListenerAgent create()
StandardEJBEventListenerAgentと接続します。
インタフェース javax.ejb.EJBHome から継承したメソッド
getEJBMetaData, getHomeHandle, remove, remove

メソッドの詳細

create

public StandardEJBEventListenerAgent create()
                                     throws RemoteException,
                                            CreateException
StandardEJBEventListenerAgentと接続します。

戻り値:
StandardEJBEventListenerAgent
例外:
RemoteException - システムレベルエラー
CreateException - EJBEventListenerAgent生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StandardEJBEventListenerFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class StandardEJBEventListenerFactory
extends EJBEventListenerFactory

標準的なEJB用のイベントリスナファクトリです。

バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
StandardEJBEventListenerFactory()
StandardEJBEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListenerFactory

public StandardEJBEventListenerFactory()
StandardEJBEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventListener (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.StandardEventListener
すべての実装インタフェース:
EventListener
public abstract class StandardEventListener
extends Object
implements EventListener

汎用的なビジネスロジック用のクラスです。

バージョン:
1.0

コンストラクタの概要
StandardEventListener()
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
EventResult | execute(Event event) 処理を実行します。
protected abstract EventResult | fire(Event event) イベントに対する処理です。
protected Object | getDAO(String application, String key, String connect) DAOを取得します。
protected DataAccessController | getDataAccessController() このイベントリスナで使用するデータアクセスコントローラです。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventListener

public StandardEventListener()
メソッドの詳細

getDataAccessController

protected DataAccessController getDataAccessController()
このイベントリスナで使用するデータアクセスコントローラです。 このクラスを継承する場合、メソッドfire(jp.co.intra_mart.framework.base.event.Event)内ではデータアクセスコントローラの取得にはこのメソッドを使うようにしてください。

戻り値:
データアクセスコントローラ

getDAO

protected Object getDAO(String application,
                        String key,
                        String connect)
                 throws DataPropertyException,
                        DataConnectorException,
                        DAOException,
                        DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 このクラスでは以下のような順番で処理を行います。
  1. ユーザトランザクションの開始
  2. イベントトリガの実行(前処理)
  3. イベント処理の実行(fire(jp.co.intra_mart.framework.base.event.Event))
  4. イベントトリガの実行(後処理)
  5. 簡易トランザクションのコミット(DataAccessController.commit())
  6. ユーザトランザクションのコミット

定義:
インタフェース EventListener 内の execute
パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

fire

protected abstract EventResult fire(Event event)
                             throws SystemException,
                                    ApplicationException
イベントに対する処理です。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardEventListenerFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.StandardEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class StandardEventListenerFactory
extends Object
implements EventListenerFactory

通常のJavaクラスのイベントリスナを生成します。 このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 生成するイベントリスナ

バージョン:
1.0

コンストラクタの概要
StandardEventListenerFactory()
StandardEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventListenerFactory

public StandardEventListenerFactory()
StandardEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。 初期パラメータで指定されたクラスをイベントリスナとして生成します。 初期パラメータで指定されたクラスはStandardEventListenerを継承している必要があります。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileEventPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス TextFileEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class TextFileEventPropertyHandler
extends Object
implements EventPropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultEventPropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileEventPropertyHandler()
TextFileEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileEventPropertyHandler

public TextFileEventPropertyHandler()
TextFileEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlEventPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス XmlEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class XmlEventPropertyHandler
extends Object
implements EventPropertyHandler

XMLのEventPropertyHandlerです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.xml」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの設定内容は以下のとおりです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのxmlファイルのプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM xmlのパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
コンストラクタの概要
XmlEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) アプリケーションIDとキーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのxmlファイルのプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
xmlのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlEventPropertyHandler

public XmlEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
アプリケーションIDとキーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーションID
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の使用

jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessageManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.framework.base.message のメソッド
static MessageManager MessageManager.getMessageManager()
メッセージマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessageManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessageManagerException の使用

MessageManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessageManagerException の使用

MessageManagerException をスローする jp.co.intra_mart.framework.base.message のメソッド
static MessageManager MessageManager.getMessageManager()
メッセージマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.MessagePropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessagePropertyException の使用

MessagePropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessagePropertyException の使用

MessagePropertyException をスローする jp.co.intra_mart.framework.base.message のメソッド
boolean | TextFileMessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | TextFileMessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | TextFileMessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | MessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | MessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | MessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | DefaultMessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DefaultMessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | DefaultMessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.message.MessagePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.message.MessagePropertyHandler の使用

MessagePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessagePropertyHandler の使用

MessagePropertyHandler を実装している jp.co.intra_mart.framework.base.message のクラス
class | DefaultMessagePropertyHandler メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
class | TextFileMessagePropertyHandler 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

MessagePropertyHandler を返す jp.co.intra_mart.framework.base.message のメソッド
 MessagePropertyHandler MessageManager.getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の使用

jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DefaultMessagePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス DefaultMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class DefaultMessagePropertyHandler
extends Object
implements MessagePropertyHandler

メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID[_ロケール].properties」です。
_ロケールを追加することによってロケールごとにメッセージを変更することも可能です。ロケールによるプロパティファイルの優先順位はJavaTMのjava.util.ResourceBundleと同様のルールに従って決定されます。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにMessageManager.MESSAGE_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

プロパティの内容は「キー=メッセージ」の形式で指定します。

導入されたバージョン:
4.2

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultMessagePropertyHandler

public DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース MessagePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されたロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessageManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.MessageManager
public class MessageManager
extends Object

メッセージマネージャです。

導入されたバージョン:
4.2

フィールドの概要
static String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー
メソッドの概要
String | getMessage(String application, String key, Object[] args) ロケールを指定せず、キーに該当するメッセージを取得します。
String | getMessage(String application, String key, Object[] args, Locale locale) ロケールを指定し、キーに該当するメッセージを取得します。
static MessageManager | getMessageManager() メッセージマネージャを取得します。
MessagePropertyHandler | getMessagePropertyHandler() メッセージプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MESSAGE_PROPERTY_HANDLER_KEY

public static final String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getMessageManager

public static MessageManager getMessageManager()
                                        throws MessageManagerException
メッセージマネージャを取得します。

戻り値:
メッセージマネージャ
例外:
MessageManagerException - メッセージマネージャの生成に失敗した

getMessage

public String getMessage(String application,
                         String key,
                         Object[] args)
ロケールを指定せず、キーに該当するメッセージを取得します。 このメソッドはgetMessage(application, key, args, java.util.Locale.getDefault())を呼んだときと同じ動作をします。

パラメータ:
application - アプリケーションID
key - キー
args - メッセージに設定するパラメータ
戻り値:
メッセージ（存在しない場合???key???）

getMessage

public String getMessage(String application,
                         String key,
                         Object[] args,
                         Locale locale)
ロケールを指定し、キーに該当するメッセージを取得します。 指定されたアプリケーションID、キー、ロケールに一致するメッセージをプロパティから取得し、 パラメータをメッセージ内部に埋め込んだ結果を返します。

このメソッドでは内部で以下のような動作をします。
  1. getMessagePropertyHandler()を呼び、MessagePropertyHandlerを取得する。
  2. MessagePropertyHandler.getMessage(application, key, locale)を呼び、メッセージを取得する。
  3. new java.text.MessageFormat(上で取得したメッセージ).format(args)を呼び、パラメータを埋め込んだメッセージを返す。

パラメータ:
application - アプリケーションID
key - キー
args - メッセージに設定するパラメータ
locale - ロケール
戻り値:
メッセージ（存在しない場合???key???）

getMessagePropertyHandler

public MessagePropertyHandler getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

戻り値:
メッセージプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessageManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.message.MessageManagerException
すべての実装インタフェース:
Serializable
public class MessageManagerException
extends SystemException

サービスマネージャ設定時の例外です。

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessageManagerException

public MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。

MessageManagerException

public MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

MessageManagerException

public MessageManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessagePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.message.MessagePropertyException
すべての実装インタフェース:
Serializable
public class MessagePropertyException
extends SystemException

メッセージプロパティ取得時の例外です。 * @author INTRAMART

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessagePropertyException

public MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。

MessagePropertyException

public MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

MessagePropertyException

public MessagePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
インタフェース MessagePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultMessagePropertyHandler, TextFileMessagePropertyHandler
public interface MessagePropertyHandler
extends PropertyHandler

メッセージの設定情報に接続するクラスです。

導入されたバージョン:
4.2

メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されるロケールをヒントにメッセージを取得します。

パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.message (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.message
インタフェース
MessagePropertyHandler
クラス
DefaultMessagePropertyHandler
MessageManager
TextFileMessagePropertyHandler
例外
MessageManagerException
MessagePropertyException


jp.co.intra_mart.framework.base.message (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.message

メッセージフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
MessagePropertyHandler メッセージの設定情報に接続するクラスです。

クラスの概要
DefaultMessagePropertyHandler | メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
MessageManager | メッセージマネージャです。
TextFileMessagePropertyHandler | 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

例外の概要
MessageManagerException | サービスマネージャ設定時の例外です。
MessagePropertyException | メッセージプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.message の説明

メッセージフレームワークに関連するクラスのパッケージです。 国際化対応したメッセージを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.message クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.message.MessageManager
    • class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.message.MessageManagerException
            • class jp.co.intra_mart.framework.base.message.MessagePropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.message の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.message の使用

jp.co.intra_mart.framework.base.message を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.base.message のクラス
MessageManager
メッセージマネージャです。
MessageManagerException
サービスマネージャ設定時の例外です。
MessagePropertyException
メッセージプロパティ取得時の例外です。
MessagePropertyHandler
メッセージの設定情報に接続するクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


TextFileMessagePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス TextFileMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class TextFileMessagePropertyHandler
extends Object
implements MessagePropertyHandler

指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。 ファイルの書式はDefaultMessagePropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
4.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileMessagePropertyHandler()
メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileMessagePropertyHandler

public TextFileMessagePropertyHandler()
メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース MessagePropertyHandler 内の isDynamic
戻り値:
true 再設定可能、false 再設定不可
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されたロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.DefaultTransition の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DefaultTransition の使用

jp.co.intra_mart.framework.base.service.DefaultTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.EncodingFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.EncodingFilter の使用

jp.co.intra_mart.framework.base.service.EncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.FileUploadFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.FileUploadFilter の使用

jp.co.intra_mart.framework.base.service.FileUploadFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter の使用

jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartConnectFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartConnectFilter の使用

jp.co.intra_mart.framework.base.service.IntramartConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartConnectServlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartConnectServlet の使用

jp.co.intra_mart.framework.base.service.IntramartConnectServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartLocaleFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartLocaleFilter の使用

jp.co.intra_mart.framework.base.service.IntramartLocaleFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition の使用

jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.LocaleFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.LocaleFilter の使用

jp.co.intra_mart.framework.base.service.LocaleFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.RequestException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.RequestException の使用

RequestException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での RequestException の使用

RequestException 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
abstract String | Transition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | IntramartPageBaseTransition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | DefaultTransition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。

RequestException をスローする jp.co.intra_mart.framework.base.service のメソッド
void | ServiceControllerAdapter.check() 入力内容をチェックします。
void | ServiceController.check() 入力内容をチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServiceController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServiceController の使用

ServiceController を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。

jp.co.intra_mart.framework.base.service での ServiceController の使用

ServiceController を実装している jp.co.intra_mart.framework.base.service のクラス
 class ServiceControllerAdapter
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。

ServiceController を返す jp.co.intra_mart.framework.base.service のメソッド
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。

jp.co.intra_mart.framework.presentation.service での ServiceController の使用

ServiceController を実装している jp.co.intra_mart.framework.presentation.service のクラス
 class PresentationServiceController
Presentation Framework用のServiceControllerです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceControllerAdapter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter の使用

ServiceControllerAdapter を使用しているパッケージ
jp.co.intra_mart.framework.presentation.service サービスに関連するパッケージです。

jp.co.intra_mart.framework.presentation.service での ServiceControllerAdapter の使用

jp.co.intra_mart.framework.presentation.service での ServiceControllerAdapter のサブクラス
 class PresentationServiceController
Presentation Framework用のServiceControllerです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceControllerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceControllerException の使用

ServiceControllerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.base.service のメソッド
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。
 String ServiceControllerAdapter.getLoginUserID()
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
 String ServiceControllerAdapter.getLoginGroupID()
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
 UserInfo ServiceControllerAdapter.getUserInfo()
ユーザ情報を取得します。
protected  Event ServiceControllerAdapter.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

jp.co.intra_mart.framework.presentation.view での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
protected Event | AbstractViewConverter.createEvent(RequestInfo info, String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
String | AbstractViewConverter.getLoginUserID(RequestInfo info) 推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
String | AbstractViewConverter.getLoginGroupID(RequestInfo info) 推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
UserInfo | AbstractViewConverter.getUserInfo(RequestInfo info) ログインユーザ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceManager の使用

ServiceManager を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceManager の使用

ServiceManager を返す jp.co.intra_mart.framework.base.service のメソッド
protected ServiceManager | Transition.getServiceManager() サービスマネージャを取得します。
static ServiceManager | ServiceManager.getServiceManager() サービスマネージャを取得します。
protected ServiceManager | IntramartConnectServlet.getServiceManager() 推奨されていません。 サービスマネージャを取得します。

ServiceManager 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
protected  void Transition.setServiceManager(ServiceManager manager)
サービスマネージャを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceManagerException の使用

ServiceManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceManagerException の使用

ServiceManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
static ServiceManager | ServiceManager.getServiceManager() サービスマネージャを取得します。
String | ServiceManager.getExtesion() サービスフレームワークを呼び出すための拡張子を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServicePropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServicePropertyException の使用

ServicePropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServicePropertyException の使用

ServicePropertyException をスローする jp.co.intra_mart.framework.base.service のメソッド
 boolean XmlServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String XmlServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale XmlServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String XmlServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String XmlServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String XmlServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String XmlServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String XmlServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String XmlServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String XmlServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
protected  String Transition.getNextPagePath()
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
protected  String Transition.getNextPagePath(String key)
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
abstract  String Transition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
abstract  String Transition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
abstract  String Transition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
abstract  String Transition.getNextPage()
次に遷移するページを取得します。
 String TextFileServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale TextFileServicePropertyHandler.getClientLocale()
クライアントのロケールを取得します。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String TextFileServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String TextFileServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String TextFileServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String TextFileServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String TextFileServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String TextFileServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String TextFileServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String TextFileServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 boolean ServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String ServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 String ServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 Locale ServicePropertyHandler.getClientLocale()
クライアントのロケールを取得します。
 String ServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String ServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String ServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String ServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String ServicePropertyHandler.getServiceServletPath()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String ServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。
 String ServiceManager.getApplication(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するアプリケーションIDを取得します。
 String ServiceManager.getService(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するサービスIDを取得します。
 Locale ServiceManager.getLocale(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するロケールを取得します。
 String ServiceManager.getEncoding(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するエンコーディングを取得します。
 String IntramartPageBaseTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String IntramartPageBaseTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String IntramartPageBaseTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String IntramartPageBaseTransition.getNextPage()
次に遷移するページを取得します。
 boolean DistributesServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DistributesServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale DistributesServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String DistributesServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String DistributesServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String DistributesServicePropertyHandler.getApplicationParamName()
アプリケーションIDに該当するパラメータ名を取得します。
 String DistributesServicePropertyHandler.getServiceParamName()
サービスIDに該当するパラメータ名を取得します。
 String DistributesServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String DistributesServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String DistributesServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String DefaultTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String DefaultTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String DefaultTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String DefaultTransition.getNextPage()
次に遷移するページを取得します。
 boolean DefaultServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DefaultServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale DefaultServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String DefaultServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String DefaultServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String DefaultServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String DefaultServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String DefaultServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String DefaultServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String DefaultServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServicePropertyHandler の使用

ServicePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServicePropertyHandler の使用

ServicePropertyHandler を実装している jp.co.intra_mart.framework.base.service のクラス
class | DefaultServicePropertyHandler サービスの設定情報に接続するデフォルトのプロパティハンドラです。
class | DistributesServicePropertyHandler アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
class | TextFileServicePropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlServicePropertyHandler サービスの設定情報に接続するプロパティハンドラです。

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.service のメソッド
ServicePropertyHandler | ServiceManager.getServicePropertyHandler() サービスプロパティハンドラを取得します。
protected ServicePropertyHandler | IntramartConnectServlet.getServicePropertyHandler() 推奨されていません。 サービスプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.web.bean での ServicePropertyHandler の使用

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 ServicePropertyHandler HelperBean.getServicePropertyHandler()
サービスプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.service.ServiceResult の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServiceResult の使用

ServiceResult を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.base.service での ServiceResult の使用

ServiceResult を返す jp.co.intra_mart.framework.base.service のメソッド
ServiceResult | Transition.getResult() サービス処理結果を取得します。
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。

ServiceResult 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
 void Transition.setResult(ServiceResult result)
サービス処理結果を設定します。

jp.co.intra_mart.framework.presentation での ServiceResult の使用

ServiceResult を返す jp.co.intra_mart.framework.presentation のメソッド
 ServiceResult RequestInfo.getResult()
サービス処理結果を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の使用

jp.co.intra_mart.framework.base.service.ServiceSecurityFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceServlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceServlet の使用

jp.co.intra_mart.framework.base.service.ServiceServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.ServiceServletException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceServletException の使用

jp.co.intra_mart.framework.base.service.ServiceServletException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.Transition の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.Transition の使用

Transition を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での Transition の使用

jp.co.intra_mart.framework.base.service での Transition のサブクラス
class | DefaultTransition デフォルトの画面遷移をします。
class | IntramartPageBaseTransition ページベースの画面に遷移する場合に使用するトランジションです。

Transition を返す jp.co.intra_mart.framework.base.service のメソッド
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.TransitionException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.TransitionException の使用

TransitionException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での TransitionException の使用

TransitionException をスローする jp.co.intra_mart.framework.base.service のメソッド
abstract  String Transition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
abstract  String Transition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
abstract  String Transition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
abstract  void Transition.setInformation()
次の遷移先に渡す情報を設定します。
abstract  String Transition.getNextPage()
次に遷移するページを取得します。
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。
 String IntramartPageBaseTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String IntramartPageBaseTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String IntramartPageBaseTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String IntramartPageBaseTransition.getNextPage()
次に遷移するページを取得します。
 void IntramartPageBaseTransition.setInformation()
次の遷移先に渡す情報を設定します。
 String DefaultTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String DefaultTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String DefaultTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 void DefaultTransition.setInformation()
次の遷移先に渡す情報を設定します。
 String DefaultTransition.getNextPage()
次に遷移するページを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DefaultServicePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DefaultServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class DefaultServicePropertyHandler
extends Object
implements ServicePropertyHandler

サービスの設定情報に接続するデフォルトのプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「 プレフィックス _ アプリケーションID .properties」です。また、アプリケーションに依存しない「 プレフィックス .properties」があります。
プロパティファイルのプレフィックスは PropertyManager.getPropertyHandlerParams(String) でキーに ServiceManager.SERVICE_PROPERTY_HANDLER_KEY を指定したときに取得されるパラメータのうち DEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスは DEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「 プレフィックス _ アプリケーションID .properties」が優先されます。該当するプロパティが見つからない場合、引き続いて「 プレフィックス .properties」を検索します。
プロパティの設定内容は以下のとおりです。 プロパティの設定内容は以下のとおりです。

キー | 内容 | 共通 | アプリケーション毎
client.encoding | クライアントのエンコーディング 設定しない場合、リクエストに対する文字コードの変換は行われません。 | ○ | ×
encoding.attribute | ログインユーザのエンコーディングを保存する属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
client.locale | クライアントのロケール クライアントからのリクエストのロケールのデフォルトです。 | ○ | ×
locale.attribute | ログインユーザのロケールを保存する属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
context.path | 非推奨です。このプロパティは設定しないでください。コンテキストパスの取得はjavax.servlet.http.HttpServletRequestのgetContextPathメソッドを使用してください。 コンテキストパス / コンテキストパス で指定します。 パスの指定は必ず"/"で開始してください。（例：/imart） このプロパティは共通のプロパティファイルのみに設定します。 このプロパティが設定されている場合、im-J2EE Frameworkのタグライブラリを使用したときに遷移するWebアプリケーションが変更されます。 | ○ | ×
servlet.path | ServiceServletにマッピングされているパス（必須） / web.xmlで指定したサーブレットのマッピング で指定します。 パスの指定は必ず"/"で開始してください。（例：/ServiceServlet） このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
application.param | アプリケーションIDを引き渡すときに使われる、リクエストのパラメータ名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
service.param | サービスIDを引き渡すときに使われる、リクエストのパラメータ名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
exception.attribute | 例外を例外ページに渡すときの属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
controller.class. サービスID | アプリケーションID と サービスID に対応する ServiceControllerのクラス名 | × | ○
transition.class. サービスID | アプリケーションID と サービスID に対応する Transitionのクラス名 | × | ○
nextpage.path. サービスID . キー | アプリケーションID 、 サービスID と キー に対応する次の遷移先のパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） 遷移先を アプリケーションID と サービスID よりも細かく指定したい場合などに使用します。 | × | ○
nextpage.path. サービスID | アプリケーションID と サービスID に対応する次の遷移先のパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path. サービスID . キー | サービスID と キー に対応する入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path. サービスID | サービスID に対応するデフォルトの入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path | デフォルトの入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○
service.error.page.path. サービスID . キー | サービスID と キー に対応するサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
service.error.page.path. サービスID | サービスID に対応するデフォルトのサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
service.error.page.path | デフォルトのサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○
system.error.page.path. サービスID . キー | サービスID と キー に対応するシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
system.error.page.path. サービスID | サービスID に対応するデフォルトのシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
system.error.page.path | デフォルトのシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER
コンストラクタの概要
DefaultServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultServicePropertyHandler

public DefaultServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
5.0
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド


DefaultTransition (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DefaultTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.DefaultTransition
public class DefaultTransition
extends Transition

デフォルトの画面遷移をします。

バージョン:
1.0

コンストラクタの概要
DefaultTransition()
DefaultTransitionを新規に生成します。
メソッドの概要
String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | getNextPage() 次に遷移するページを取得します。
String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
void | setInformation() 次の遷移先に渡す情報を設定します。
void | transfer() 次のページに遷移します。
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultTransition

public DefaultTransition()
DefaultTransitionを新規に生成します。

メソッドの詳細

getInputErrorPage

public String getInputErrorPage(RequestException e)
                         throws ServicePropertyException,
                                TransitionException
入力エラーのページを取得します。

定義:
クラス Transition 内の getInputErrorPage
パラメータ:
e - 例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public String getSystemErrorPage(Exception e)
                          throws ServicePropertyException,
                                 TransitionException
システムエラーのページを取得します。

定義:
クラス Transition 内の getSystemErrorPage
パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public String getServiceErrorPage(Exception e)
                           throws ServicePropertyException,
                                  TransitionException
処理エラーのページを取得します。

定義:
クラス Transition 内の getServiceErrorPage
パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public void setInformation()
                    throws TransitionException
次の遷移先に渡す情報を設定します。 このクラスでは何も行いません。

定義:
クラス Transition 内の setInformation
例外:
TransitionException - 情報設定時に例外が発生

getNextPage

public String getNextPage()
                   throws ServicePropertyException,
                          TransitionException
次に遷移するページを取得します。

定義:
クラス Transition 内の getNextPage
戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

transfer

public void transfer()
              throws SystemException
次のページに遷移します。 getNextPage()で取得されるページにforwardされます。

定義:
クラス Transition 内の transfer
例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributesServicePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DistributesServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class DistributesServicePropertyHandler
extends Object
implements ServicePropertyHandler

アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
通常時に使用されるサービスプロパティハンドラは default.class で示されるパラメータ名で指定します。 ここで指定されるサービスプロパティハンドラに渡す初期値は、 default.param.パラメータ名 で示されるパラメータ名で指定します。 ある特定のアプリケーションに対して特定のサービスプロパティハンドラを割り当てたい場合、 application.class.アプリケーションID で示されるパラメータ名で指定します。 ここで指定されるサービスプロパティハンドラに渡す初期値は、 application.param.アプリケーションID.パラメータ名 で示されるパラメータ名で指定します。 ファイルが存在するディレクトリ名は PARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
5.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION アプリケーション
static String | PARAM_APPLICATION_CLASS クラス
static String | PARAM_APPLICATION_PARAM パラメータ
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT デフォルト
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER
コンストラクタの概要
DistributesServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
アプリケーションIDに該当するパラメータ名を取得します。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
サービスIDに該当するパラメータ名を取得します。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
デフォルト

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
アプリケーション

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
パラメータ

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
クラス

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesServicePropertyHandler

public DistributesServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
5.0
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


EncodingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス EncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.EncodingFilter
すべての実装インタフェース:
Filter
public class EncodingFilter
extends Object
implements Filter

リクエストのエンコードを設定します。 リクエストに対するエンコードは

  1. ServicePropertyHandler.getClientEncoding()で取得されるもの
  2. ServiceManager.getLocale(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
の順位で決定されます。

この時に取得されたエンコードはServletRequest.setCharacterEncoding(java.lang.String)に設定され、 さらにHttpSessionが存在すればその中にも設定されます。この場合の属性名はServicePropertyHandler.getEncodingAttributeName()で取得されるものです。

バージョン:
1.0

コンストラクタの概要
EncodingFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのエンコードを設定します。
void | init(FilterConfig filterConfig) エンコーディング用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EncodingFilter

public EncodingFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
エンコーディング用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのエンコードを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileUploadFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス FileUploadFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.FileUploadFilter
すべての実装インタフェース:
Filter
public class FileUploadFilter
extends Object
implements Filter

ファイルアップロード用にリクエストを変換するフィルタです。 このフィルタは受け取ったリクエストが以下の条件をすべて満たす場合にServiceControllerAdapter.getEntity(String)でアップロードされた内容が取得できるようにします。

  • メソッドが"POST"である
  • ContentTypeが"multipart/form-data"である

    導入されたバージョン:
    3.2

    コンストラクタの概要
    FileUploadFilter()
    メソッドの概要
     void destroy()
    フィルタを破棄します。
     void doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain)
    リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。
     void init(FilterConfig filterConfig)
    ファイルアップロード用のフィルタを初期化します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    コンストラクタの詳細

    FileUploadFilter

    public FileUploadFilter()
    メソッドの詳細

    init

    public void init(FilterConfig filterConfig)
          throws ServletException
    ファイルアップロード用のフィルタを初期化します。

    定義:
    インタフェース Filter 内の init
    パラメータ:
    filterConfig - FilterConfig
    例外:
    ServletException - フィルタ内で例外が発生

    doFilter

    public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
    リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。

    定義:
    インタフェース Filter 内の doFilter
    パラメータ:
    servletRequest - リクエスト
    servletResponse - レスポンス
    filterChain - フィルタ
    例外:
    IOException - フィルタ処理実行時にIOExceptionが発生
    ServletException - フィルタ処理実行時にServletExceptionが発生

    destroy

    public void destroy()
    フィルタを破棄します。

    定義:
    インタフェース Filter 内の destroy
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart(R)
    5.0
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameworkParameterSettingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス FrameworkParameterSettingFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter
すべての実装インタフェース:
Filter
推奨されていません。 このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。

public class FrameworkParameterSettingFilter
extends Object
implements Filter

以前のバージョンのサービスフレームワークが使用していたアプリケーションID及びサービスIDを リクエストのパラメータに設定します。
このフィルタを使用することによりServletRequest.getParameter(String)から アプリケーションID及びサービスIDを取得することができますが、この方法は正しくありません。
正しくは以下のメソッドを使用してください。

ServiceManager.getApplication(HttpServletRequest, HttpServletResponse)
ServiceManager.getService(HttpServletRequest, HttpServletResponse)

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
FrameworkParameterSettingFilter()
推奨されていません。
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 リクエストのパラメーターを設定後、次の処理に遷移します。
void | init(FilterConfig filterConfig) 推奨されていません。 フィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameworkParameterSettingFilter

public FrameworkParameterSettingFilter()
推奨されていません。
メソッドの詳細

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
推奨されていません。
リクエストのパラメーターを設定後、次の処理に遷移します。
パラメータ名は以下のメソッドから取得したものを使用します。
ServicePropertyHandler.getApplicationParamName()
ServicePropertyHandler.getServiceParamName()

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタのチェーン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
フィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - フィルタ設定オブジェクト
例外:
ServletException - フィルタを初期化時に例外が発生。

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartConnectFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.IntramartConnectFilter
すべての実装インタフェース:
Filter
推奨されていません。 この機能は廃止されました。

public class IntramartConnectFilter
extends Object
implements Filter

intra-martのページベースの画面からim-J2EE Frameworkの画面に遷移する時に使うフィルタです。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。 このフィルタで変換されたリクエストはServiceServletで扱えるようになります。

このフィルタは以下の初期化パラメータを設定することができます。

パラメータ名 | パラメータの値
referrerFormat | セッションに登録されるintramartのページベースへの画面に戻るためのURLの書式を決定します。 short（大文字と小文字は区別しない）：URLからプロトコル、ホスト名、ポート番号が省略された形式をセッションに登録 それ以外：パラメータreferrerの内容をそのままセッションに登録
securityExt | セキュリティの有効／無効を設定する拡張子です。 このパラメータが設定されるとセキュリティが有効になります。 ServiceServletに対するURLマッピングは*.拡張子とする必要があります。 拡張子（ドットは含まない）

導入されたバージョン:
4.2

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
static String | PARAM_ARGUMENT 推奨されていません。 ページ引数のリクエストパラメータ名
static String | PARAM_ARGUMENT_DELIMITER 推奨されていません。 ページ引数のデリミタ
static String | PARAM_ARGUMENT_OPERATOR 推奨されていません。 ページ引数の演算子
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 ログイングループIDのリクエストパラメータ名
static String | PARAM_LOGIN_USER_ID 推奨されていません。 ログインユーザIDのリクエストパラメータ名
static String | PARAM_REFERER 推奨されていません。 参照元URLのリクエストパラメータ名
static String | PARAM_SECURITY_EXT 推奨されていません。 セキュリティの拡張子
コンストラクタの概要
IntramartConnectFilter()
推奨されていません。
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。
String | getSecurityExt() 推奨されていません。 セキュリティの拡張子を取得します。
void | init(FilterConfig filterConfig) 推奨されていません。 このフィルタを初期化します。
void | setSecurityExt(String securityExt) 推奨されていません。 セキュリティの拡張子を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。
ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。
ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。
ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。
参照元URLのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT_DELIMITER

public static final String PARAM_ARGUMENT_DELIMITER
推奨されていません。
ページ引数のデリミタ

関連項目:
定数フィールド値

PARAM_ARGUMENT_OPERATOR

public static final String PARAM_ARGUMENT_OPERATOR
推奨されていません。
ページ引数の演算子

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。
セッションに登録するintra-martのサーブレットのURLの属性名

関連項目:
定数フィールド値

PARAM_SECURITY_EXT

public static final String PARAM_SECURITY_EXT
推奨されていません。
セキュリティの拡張子

導入されたバージョン:
4.3
関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectFilter

public IntramartConnectFilter()
推奨されていません。
メソッドの詳細

getSecurityExt

public String getSecurityExt()
推奨されていません。
セキュリティの拡張子を取得します。

戻り値:
セキュリティの拡張子

setSecurityExt

public void setSecurityExt(String securityExt)
推奨されていません。
セキュリティの拡張子を設定します。

パラメータ:
securityExt - セキュリティの拡張子

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
推奨されていません。
intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartConnectServlet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartConnectServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.base.service.IntramartConnectServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
推奨されていません。 この機能は廃止されました。

public class IntramartConnectServlet
extends HttpServlet

intra-martのページベースの画面からJ2EEベースの画面に遷移する時に使うサーブレットです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
static String | PARAM_ARGUMENT 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
static String | PARAM_ARGUMENT_DELIMITER 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
static String | PARAM_ARGUMENT_OPERATOR 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
static String | PARAM_LOGIN_USER_ID 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
static String | PARAM_REFERER 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。
コンストラクタの概要
IntramartConnectServlet()
推奨されていません。 IntramartConnectServletを新規に生成します。
メソッドの概要
protected void | doGet(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 GETメソッドに対応します。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 POSTメソッドに対応します。
protected void | execute(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 intra-martベースモジュールのメニューからのリクエストを受け付けます。
protected ServiceManager | getServiceManager() 推奨されていません。 サービスマネージャを取得します。
protected ServicePropertyHandler | getServicePropertyHandler() 推奨されていません。 サービスプロパティハンドラを取得します。
protected SessionManager | getSessionManager() 推奨されていません。 セッションマネージャを取得します。
protected SessionPropertyHandler | getSessionPropertyHandler() 推奨されていません。 セッションプロパティハンドラを取得します。
void | init(ServletConfig servletConfig) 推奨されていません。 このサーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。

ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。

ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。

ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。

参照元URLのリクエストパラメータ名

導入されたバージョン:
3.2
関連項目:
定数フィールド値

PARAM_ARGUMENT_DELIMITER

public static final String PARAM_ARGUMENT_DELIMITER
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。

ページ引数のデリミタ

関連項目:
定数フィールド値

PARAM_ARGUMENT_OPERATOR

public static final String PARAM_ARGUMENT_OPERATOR
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。

ページ引数の演算子

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。

セッションに登録するintra-martのサーブレットのURLの属性名 （この値はVersion 4.0から変更されています）

導入されたバージョン:
3.2
関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectServlet

public IntramartConnectServlet()
推奨されていません。
IntramartConnectServletを新規に生成します。

メソッドの詳細

getServiceManager

protected ServiceManager getServiceManager()
推奨されていません。
サービスマネージャを取得します。

戻り値:
サービスマネージャ

getServicePropertyHandler

protected ServicePropertyHandler getServicePropertyHandler()
推奨されていません。
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getSessionManager

protected SessionManager getSessionManager()
推奨されていません。
セッションマネージャを取得します。

戻り値:
セッションマネージャ

getSessionPropertyHandler

protected SessionPropertyHandler getSessionPropertyHandler()
推奨されていません。
セッションプロパティハンドラを取得します。

戻り値:
セッションプロパティハンドラ

init

public void init(ServletConfig servletConfig)
          throws ServletException
推奨されていません。
このサーブレットを初期化します。

パラメータ:
servletConfig - Servlet Config
例外:
ServletException - 初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
推奨されていません。
GETメソッドに対応します。 詳細はexecute(HttpServletRequest, HttpServletResponse)を参照してください。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
推奨されていません。
POSTメソッドに対応します。 詳細はexecute(HttpServletRequest, HttpServletResponse)を参照してください。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

execute

protected void execute(HttpServletRequest request,
                       HttpServletResponse response)
                throws ServletException,
                       IOException
推奨されていません。
intra-martベースモジュールのメニューからのリクエストを受け付けます。 ページ引数に以下の情報を含める必要があります。
application=<アプリケーションＩＤ>,service=<サービスＩＤ>

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartLocaleFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartLocaleFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.IntramartLocaleFilter
すべての実装インタフェース:
Filter
public class IntramartLocaleFilter
extends Object
implements Filter

セッションにロケールを設定します。
ロケールはクライアントの保持するアクセスセキュリティ情報が優先されます。

アクセスセキュリティ情報からロケールを取得できない場合はServiceManager.getLocale(HttpServletRequest, HttpServletResponse) から取得した値が設定されます。

この時に取得されたロケールはHttpSessionが存在すればその中に設定されます。この場合の属性名はServicePropertyHandler.getLocaleAttributeName()で取得されるものです。

導入されたバージョン:
5.0

コンストラクタの概要
IntramartLocaleFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのロケールを設定します。
void | init(FilterConfig filterConfig) ロケール用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartLocaleFilter

public IntramartLocaleFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
ロケール用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのロケールを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartPageBaseTransition (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartPageBaseTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
public class IntramartPageBaseTransition
extends Transition

ページベースの画面に遷移する場合に使用するトランジションです。

導入されたバージョン:
3.2

コンストラクタの概要
IntramartPageBaseTransition()
IntramartPageBaseTransitionを新規に生成します。
メソッドの概要
String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | getNextPage() 次に遷移するページを取得します。
String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
void | setInformation() 次の遷移先に渡す情報を設定します。
void | transfer() ページベースの画面に遷移します。
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartPageBaseTransition

public IntramartPageBaseTransition()
IntramartPageBaseTransitionを新規に生成します。

メソッドの詳細

getInputErrorPage

public String getInputErrorPage(RequestException e)
                         throws ServicePropertyException,
                                TransitionException
入力エラーのページを取得します。

定義:
クラス Transition 内の getInputErrorPage
パラメータ:
e - 入力時の例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public String getServiceErrorPage(Exception e)
                           throws ServicePropertyException,
                                  TransitionException
処理エラーのページを取得します。

定義:
クラス Transition 内の getServiceErrorPage
パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public String getSystemErrorPage(Exception e)
                          throws ServicePropertyException,
                                 TransitionException
システムエラーのページを取得します。

定義:
クラス Transition 内の getSystemErrorPage
パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getNextPage

public String getNextPage()
                   throws ServicePropertyException,
                          TransitionException
次に遷移するページを取得します。

定義:
クラス Transition 内の getNextPage
戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public void setInformation()
                    throws TransitionException
次の遷移先に渡す情報を設定します。

定義:
クラス Transition 内の setInformation
例外:
TransitionException - 情報設定時に例外が発生

transfer

public void transfer()
              throws SystemException
ページベースの画面に遷移します。 遷移する方法は次のページで要求される形式に依存します。

定義:
クラス Transition 内の transfer
例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス LocaleFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.LocaleFilter
すべての実装インタフェース:
Filter
public class LocaleFilter
extends Object
implements Filter

リクエストのロケールを設定します。 リクエストに対するロケールの決定方法はServiceManager.getLocale(HttpServletRequest, HttpServletResponse)と同じです。

この時に取得されたロケールはHttpSessionが存在すればその中に設定されます。この場合の属性名はServicePropertyHandler.getLocaleAttributeName()で取得されるものです。

導入されたバージョン:
4.2

コンストラクタの概要
LocaleFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのロケールを設定します。
void | init(FilterConfig filterConfig) ロケール用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LocaleFilter

public LocaleFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
ロケール用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのロケールを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.service (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.service
インタフェース
ServiceController
ServicePropertyHandler
ServiceResult
クラス
DefaultServicePropertyHandler
DefaultTransition
DistributesServicePropertyHandler
EncodingFilter
FileUploadFilter
FrameworkParameterSettingFilter
IntramartConnectFilter
IntramartConnectServlet
IntramartLocaleFilter
IntramartPageBaseTransition
LocaleFilter
ServiceControllerAdapter
ServiceManager
ServiceSecurityFilter
ServiceServlet
TextFileServicePropertyHandler
Transition
XmlServicePropertyHandler
例外
RequestException
ServiceControllerException
ServiceManagerException
ServicePropertyException
ServiceServletException
TransitionException


jp.co.intra_mart.framework.base.service (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service

サービスフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
ServiceController | クライアントからの入力に対する処理を行います。
ServicePropertyHandler | サービスの設定情報に接続するクラスです。
ServiceResult | サービスの処理結果です。

クラスの概要
DefaultServicePropertyHandler | サービスの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultTransition | デフォルトの画面遷移をします。
DistributesServicePropertyHandler | アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
EncodingFilter | リクエストのエンコードを設定します。
FileUploadFilter | ファイルアップロード用にリクエストを変換するフィルタです。
FrameworkParameterSettingFilter | 推奨されていません。 このフィルタは下位互換のためのフィルタです。
IntramartConnectFilter | 推奨されていません。 この機能は廃止されました。
IntramartConnectServlet | 推奨されていません。 この機能は廃止されました。
IntramartLocaleFilter | セッションにロケールを設定します。
IntramartPageBaseTransition | ページベースの画面に遷移する場合に使用するトランジションです。
LocaleFilter | リクエストのロケールを設定します。
ServiceControllerAdapter | いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。
ServiceManager | サービスマネージャです。
ServiceSecurityFilter | intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。
ServiceServlet | サービスを振り分けるサーブレットです。
TextFileServicePropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
Transition | 画面遷移に関連するクラスのインタフェースです。
XmlServicePropertyHandler | サービスの設定情報に接続するプロパティハンドラです。

例外の概要
RequestException | リクエストの内容に関連する間違いがある場合の例外です。
ServiceControllerException | サービスコントローラに関連する例外です。
ServiceManagerException | サービスマネージャ設定時の例外です。
ServicePropertyException | サービスプロパティ取得時の例外です。
ServiceServletException | サービスに関連する例外です。
TransitionException | トランジションに関連する例外です。

パッケージ jp.co.intra_mart.framework.base.service の説明

サービスフレームワークに関連するクラスのパッケージです。 画面からのアクション（Submit、リンク等）に対して処理や画面遷移の制御をします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.service クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.EncodingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.FileUploadFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter (implements javax.servlet.Filter)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.framework.base.service.IntramartConnectServlet
        • class jp.co.intra_mart.framework.base.service.ServiceServlet
    • class jp.co.intra_mart.framework.base.service.IntramartConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.LocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
    • class jp.co.intra_mart.framework.base.service.ServiceManager
    • class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.base.service.RequestException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.ServiceControllerException
            • class jp.co.intra_mart.framework.base.service.ServiceManagerException
            • class jp.co.intra_mart.framework.base.service.ServicePropertyException
            • class jp.co.intra_mart.framework.base.service.ServiceServletException
            • class jp.co.intra_mart.framework.base.service.TransitionException
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
      • class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
    • class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler
  • interface jp.co.intra_mart.framework.base.service.ServiceController
  • interface jp.co.intra_mart.framework.base.service.ServiceResult
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.service の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service の使用

jp.co.intra_mart.framework.base.service を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.service のクラス
RequestException
リクエストの内容に関連する間違いがある場合の例外です。
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerException
サービスコントローラに関連する例外です。
ServiceManager
サービスマネージャです。
ServiceManagerException
サービスマネージャ設定時の例外です。
ServicePropertyException
サービスプロパティ取得時の例外です。
ServicePropertyHandler
サービスの設定情報に接続するクラスです。
ServiceResult
サービスの処理結果です。
Transition
画面遷移に関連するクラスのインタフェースです。
TransitionException
トランジションに関連する例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.service のクラス
ServicePropertyHandler
サービスの設定情報に接続するクラスです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceResult
サービスの処理結果です。

jp.co.intra_mart.framework.presentation.service により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerAdapter
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceControllerException
サービスコントローラに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RequestException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス RequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.base.service.RequestException
すべての実装インタフェース:
Serializable
public class RequestException
extends ApplicationException

リクエストの内容に関連する間違いがある場合の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
RequestException()
詳細メッセージを指定しないで RequestException を構築します。
RequestException(String msg)
指定された詳細メッセージを持つ RequestException を構築します。
RequestException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestException

public RequestException()
詳細メッセージを指定しないで RequestException を構築します。

RequestException

public RequestException(String msg)
指定された詳細メッセージを持つ RequestException を構築します。

パラメータ:
msg - 詳細メッセージ

RequestException

public RequestException(String msg,
                        Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServiceController

既知の実装クラスの一覧:
ServiceControllerAdapter
public interface ServiceController

クライアントからの入力に対する処理を行います。

バージョン:
1.0

メソッドの概要
void | check() 入力内容をチェックします。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | service() 入力に対する処理を実行します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。

メソッドの詳細

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

check

public void check()
           throws RequestException,
                  SystemException
入力内容をチェックします。

例外:
RequestException - 入力内容に誤りがある
SystemException - チェック時にシステム例外が発生

service

public ServiceResult service()
                      throws SystemException,
                             ApplicationException
入力に対する処理を実行します。

戻り値:
処理結果
例外:
SystemException - 処理実行時にシステム例外が発生
ApplicationException - 処理実行時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceControllerAdapter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceControllerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerAdapter
すべての実装インタフェース:
ServiceController
直系の既知のサブクラス:
PresentationServiceController
public class ServiceControllerAdapter
extends Object
implements ServiceController

いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。 このクラスにはいくつかのユーティリティメソッドがあります。 このクラスを継承し、必要に応じてcheck()やservice()を実装することでコーディング量を減らすことが可能です。

バージョン:
1.0

コンストラクタの概要
ServiceControllerAdapter()
ServiceControllerAdapterを新規に生成します。
メソッドの概要
void | check() 入力内容をチェックします。
protected Event | createEvent(String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
MultipartFormData.Entity | getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
UserInfo | getUserInfo() ユーザ情報を取得します。
ServiceResult | service() 入力に対する処理を実行します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceControllerAdapter

public ServiceControllerAdapter()
ServiceControllerAdapterを新規に生成します。

メソッドの詳細

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

定義:
インタフェース ServiceController 内の setRequest
パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

定義:
インタフェース ServiceController 内の getRequest
戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

定義:
インタフェース ServiceController 内の setResponse
パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

定義:
インタフェース ServiceController 内の getResponse
戻り値:
レスポンス

getEntity

public MultipartFormData.Entity getEntity(String name)
                                   throws SystemException
リクエストから指定された名前に該当するエンティティを取得します。 このメソッドは、ファイルアップロード時にその内容を取得する場合などに使用します。 このメソッドは、ファイルアップロードのリクエストが送られた場合のみ使用できます。 それ以外のリクエストが送られた場合にこのメソッドを呼ぶと例外が発生します。

パラメータ:
name - パラメータ名
戻り値:
パラメータ名に該当するエンティティ
例外:
SystemException - エンティティの取得に失敗
導入されたバージョン:
3.2

check

public void check()
           throws RequestException,
                  SystemException
入力内容をチェックします。

定義:
インタフェース ServiceController 内の check
例外:
RequestException - 入力内容に誤りがある
SystemException - チェック時にシステム例外が発生

service

public ServiceResult service()
                      throws SystemException,
                             ApplicationException
入力に対する処理を実行します。 このサービスコントローラでは何もせず、nullを返します。

定義:
インタフェース ServiceController 内の service
戻り値:
処理結果(null)
例外:
SystemException - 処理実行時にシステム例外が発生
ApplicationException - 処理実行時にアプリケーション例外が発生

getLoginUserID

public String getLoginUserID()
                      throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
例外:
ServiceControllerException - ログインユーザID取得時に例外が発生

getLoginGroupID

public String getLoginGroupID()
                       throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
例外:
ServiceControllerException - ログイングループID取得時に例外が発生

getUserInfo

public UserInfo getUserInfo()
                     throws ServiceControllerException
ユーザ情報を取得します。

戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ユーザ情報取得時に例外が発生
導入されたバージョン:
5.0

createEvent

protected Event createEvent(String application,
                            String key)
                     throws ServiceControllerException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
ServiceControllerException - イベント取得時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceControllerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceControllerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerException
すべての実装インタフェース:
Serializable
public class ServiceControllerException
extends SystemException

サービスコントローラに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceControllerException()
詳細メッセージを指定しないで ServiceControllerException を構築します。
ServiceControllerException(String msg)
指定された詳細メッセージを持つ ServiceControllerException を構築します。
ServiceControllerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceControllerException

public ServiceControllerException()
詳細メッセージを指定しないで ServiceControllerException を構築します。

ServiceControllerException

public ServiceControllerException(String msg)
指定された詳細メッセージを持つ ServiceControllerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceControllerException

public ServiceControllerException(String msg,
                                  Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceManager
public class ServiceManager
extends Object

サービスマネージャです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_SERVICE_EXTENSION サービスフレームワークをコールするためのデフォルトの拡張子
static String | SERVICE_EXTENSION_KEY 拡張子を指定するキー
static String | SERVICE_PROPERTY_HANDLER_KEY サービスプロパティハンドラのキー
メソッドの概要
String | getApplication(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するアプリケーションIDを取得します。
String | getEncoding(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するエンコーディングを取得します。
String | getExtesion() サービスフレームワークを呼び出すための拡張子を取得します。
Locale | getLocale(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するロケールを取得します。
String | getService(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するサービスIDを取得します。
ServiceController | getServiceController(String application, String service) 推奨されていません。 このメソッドではなくgetServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
static ServiceManager | getServiceManager() サービスマネージャを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service) 推奨されていません。 このメソッドではなくgetTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SERVICE_PROPERTY_HANDLER_KEY

public static final String SERVICE_PROPERTY_HANDLER_KEY
サービスプロパティハンドラのキー

関連項目:
定数フィールド値

SERVICE_EXTENSION_KEY

public static final String SERVICE_EXTENSION_KEY
拡張子を指定するキー

導入されたバージョン:
5.0
関連項目:
getExtesion(), 定数フィールド値

DEFAULT_SERVICE_EXTENSION

public static final String DEFAULT_SERVICE_EXTENSION
サービスフレームワークをコールするためのデフォルトの拡張子

導入されたバージョン:
5.0
関連項目:
getExtesion(), 定数フィールド値
メソッドの詳細

getServiceManager

public static ServiceManager getServiceManager()
                                        throws ServiceManagerException
サービスマネージャを取得します。

戻り値:
サービスマネージャ
例外:
ServiceManagerException - サービスマネージャの生成に失敗した

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getServiceController

public ServiceController getServiceController(String application,
                                              String service)
                                       throws ServicePropertyException,
                                              ServiceControllerException
推奨されていません。 このメソッドではなくgetServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。

サービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceController(application, service, null)を呼んだときと同じ結果を返します。

パラメータ:
application - アプリケーション
service - サービス
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生
導入されたバージョン:
4.2

getTransition

public Transition getTransition(String application,
                                String service)
                         throws ServicePropertyException,
                                TransitionException
推奨されていません。 このメソッドではなくgetTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。

トランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。 このメソッドはgetTransition(application, service, null)を呼んだときと同じ結果を返します。

パラメータ:
application - アプリケーション
service - サービス
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生
導入されたバージョン:
4.2

getApplication

public String getApplication(HttpServletRequest request,
                             HttpServletResponse response)
                      throws ServicePropertyException
現在のリクエストに対するアプリケーションIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
現在のリクエストに対するアプリケーションID
例外:
ServicePropertyException - アプリケーションID取得時に例外が発生
導入されたバージョン:
4.2

getService

public String getService(HttpServletRequest request,
                         HttpServletResponse response)
                  throws ServicePropertyException
現在のリクエストに対するサービスIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
現在のリクエストに対するサービスID
例外:
ServicePropertyException - サービスID取得時に例外が発生
導入されたバージョン:
4.2

getLocale

public Locale getLocale(HttpServletRequest request,
                        HttpServletResponse response)
                 throws ServicePropertyException
現在のリクエストに対するロケールを取得します。 ロケールの取得は以下の優先順位に従います。
  1. セッション内のServicePropertyHandler.getLocaleAttributeName()で取得される属性名で登録されたロケール
  2. ServicePropertyHandler.getClientLocale()で取得されるロケール
  3. ServletRequest.getLocale()で取得されるロケール
  4. Locale.getDefault()で取得されるロケール

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ロケール
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
導入されたバージョン:
4.2

getEncoding

public String getEncoding(HttpServletRequest request,
                          HttpServletResponse response)
                   throws ServicePropertyException
現在のリクエストに対するエンコーディングを取得します。 エンコーディングの取得は以下の優先順位に従います。
  1. セッション内のServicePropertyHandler.getEncodingAttributeName()で取得される属性名で登録されたエンコーディング
  2. ServicePropertyHandler.getClientEncoding()で取得されるエンコーディング
  3. ServletRequest.getCharacterEncoding()で取得されるエンコーディング
  4. null

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
エンコーディング
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
導入されたバージョン:
4.2

getExtesion

public String getExtesion()
                   throws ServiceManagerException
サービスフレームワークを呼び出すための拡張子を取得します。
#SERVICE_EXTESION_KEYをキーとしたシステムプロパティを検索し、 存在しない場合は#DEFAULT_SERVICE_EXTを返却します。

戻り値:
サービスフレームワークを呼び出すための拡張子
例外:
ServiceManagerException
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceManagerException
すべての実装インタフェース:
Serializable
public class ServiceManagerException
extends SystemException

サービスマネージャ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceManagerException()
詳細メッセージを指定しないで ServiceManagerException を構築します。
ServiceManagerException(String msg)
指定された詳細メッセージを持つ ServiceManagerException を構築します。
ServiceManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceManagerException

public ServiceManagerException()
詳細メッセージを指定しないで ServiceManagerException を構築します。

ServiceManagerException

public ServiceManagerException(String msg)
指定された詳細メッセージを持つ ServiceManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceManagerException

public ServiceManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServicePropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServicePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServicePropertyException
すべての実装インタフェース:
Serializable
public class ServicePropertyException
extends SystemException

サービスプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServicePropertyException()
詳細メッセージを指定しないで ServicePropertyException を構築します。
ServicePropertyException(String msg)
指定された詳細メッセージを持つ ServicePropertyException を構築します。
ServicePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServicePropertyException

public ServicePropertyException()
詳細メッセージを指定しないで ServicePropertyException を構築します。

ServicePropertyException

public ServicePropertyException(String msg)
指定された詳細メッセージを持つ ServicePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

ServicePropertyException

public ServicePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServicePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServicePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultServicePropertyHandler, DistributesServicePropertyHandler, TextFileServicePropertyHandler, XmlServicePropertyHandler
public interface ServicePropertyHandler
extends PropertyHandler

サービスの設定情報に接続するクラスです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_APPLICATION_PARAMETER 推奨されていません。 この実装は廃止されました。
static String | DEFAULT_ENCODING_ATTRIBUTE ログインユーザのエンコーディングのデフォルトの属性名
static String | DEFAULT_EXCEPTION_ATTRIBUTE 例外属性のデフォルトの属性名
static String | DEFAULT_LOCALE_ATTRIBUTE ログインユーザのロケールのデフォルトの属性名
static String | DEFAULT_SERVICE_PARAMETER 推奨されていません。 この実装は廃止されました。
メソッドの概要
String | getApplicationParamName() 推奨されていません。 この実装は廃止されました。
String | getClientEncoding() クライアントのエンコードを取得します。
Locale | getClientLocale() クライアントのロケールを取得します。
String | getContextPath() 推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
String | getEncodingAttributeName() ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
String | getExceptionAttributeName() 例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
String | getInputErrorPagePath() 推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。
String | getInputErrorPagePath(Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。
String | getInputErrorPagePath(String application, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, String key, Locale locale) 入力例外時のページのパスを取得します。
String | getLocaleAttributeName() ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
String | getNextPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, Locale locale) 遷移先のページのパスを取得します。
String | getNextPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, String key, Locale locale) 遷移先のページのパスを取得します。
String | getServiceControllerName(String application, String service) 推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。
String | getServiceControllerName(String application, String service, Locale locale) サービスコントローラのクラス名を取得します。
String | getServiceErrorPagePath() 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。
String | getServiceErrorPagePath(Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, String key, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceParamName() 推奨されていません。 この実装は廃止されました。
String | getServiceServletPath() 推奨されていません。 この実装は廃止されました。
String | getSystemErrorPagePath() 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。
String | getSystemErrorPagePath(Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, String key, Locale locale) システム例外時のページのパスを取得します。
String | getTransitionName(String application, String service) 推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。
String | getTransitionName(String application, String service, Locale locale) トランジションのクラス名を取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

フィールドの詳細

DEFAULT_APPLICATION_PARAMETER

public static final String DEFAULT_APPLICATION_PARAMETER
推奨されていません。 この実装は廃止されました。

アプリケーションIDのデフォルトのパラメータ名

関連項目:
定数フィールド値

DEFAULT_SERVICE_PARAMETER

public static final String DEFAULT_SERVICE_PARAMETER
推奨されていません。 この実装は廃止されました。

サービスIDのデフォルトのパラメータ名

関連項目:
定数フィールド値

DEFAULT_EXCEPTION_ATTRIBUTE

public static final String DEFAULT_EXCEPTION_ATTRIBUTE
例外属性のデフォルトの属性名

関連項目:
定数フィールド値

DEFAULT_ENCODING_ATTRIBUTE

public static final String DEFAULT_ENCODING_ATTRIBUTE
ログインユーザのエンコーディングのデフォルトの属性名

関連項目:
定数フィールド値

DEFAULT_LOCALE_ATTRIBUTE

public static final String DEFAULT_LOCALE_ATTRIBUTE
ログインユーザのロケールのデフォルトの属性名

関連項目:
定数フィールド値
メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
ServicePropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのロケールを取得します。

戻り値:
クライアントのロケール（設定されていない場合はnull）
例外:
ServicePropertyException - クライアントのロケールの取得時に例外が発生
導入されたバージョン:
4.2

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します。

戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドはgetNextPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。 このメソッドはgetNextPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドはgetInputErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。

処理例外時のページのパスを取得します。 このメソッドはgetServiceErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドはgetSystemErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceControllerName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドはgetTransitionName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスサーブレットのパスを取得します。

戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

戻り値:
コンテキストパス(設定されていない場合はnull)
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、DEFAULT_APPLICATION_PARAMETERで定義されている値を返します。

戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。

戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
5.0
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


ServiceResult (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServiceResult

public interface ServiceResult

サービスの処理結果です。

バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ServiceSecurityFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceSecurityFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceSecurityFilter
すべての実装インタフェース:
Filter
public class ServiceSecurityFilter
extends Object
implements Filter

intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。 このフィルタは次の初期化パラメータを設定する必要があります。

パラメータ名 | 値
error-page | セキュリティ違反時に遷移するページのパス。 コンテキストパスからの相対パスで指定する必要がある。 パスの先頭は"/"で指定する。

このフィルタを設定する場合、ServiceServletは拡張子によるマッピングが行われる必要があります。

導入されたバージョン:
4.3

フィールドの概要
static String | ID_SERVICE_SECURITY_FILTER リクエストに登録するServiceServletFilterの属性名
static String | PARAM_ERROR_PAGE エラーページパスのパラメータ名
コンストラクタの概要
ServiceSecurityFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) sessionに登録された情報と、parameterの情報を比較します。
void | init(FilterConfig filterConfig) このフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SERVICE_SECURITY_FILTER

public static final String ID_SERVICE_SECURITY_FILTER
リクエストに登録するServiceServletFilterの属性名

関連項目:
定数フィールド値

PARAM_ERROR_PAGE

public static final String PARAM_ERROR_PAGE
エラーページパスのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

ServiceSecurityFilter

public ServiceSecurityFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
sessionに登録された情報と、parameterの情報を比較します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceServlet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.base.service.ServiceServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class ServiceServlet
extends HttpServlet

サービスを振り分けるサーブレットです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ
コンストラクタの概要
ServiceServlet()
ServiceServletを新規に生成します。
メソッドの概要
void | destroy() サーブレットを解放します。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init(ServletConfig servletConfig) サーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REQUEST_SEPARATOR

public static final String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ

導入されたバージョン:
5.0
関連項目:
定数フィールド値
コンストラクタの詳細

ServiceServlet

public ServiceServlet()
ServiceServletを新規に生成します。

メソッドの詳細

init

public void init(ServletConfig servletConfig)
          throws ServletException
サーブレットを初期化します。

パラメータ:
servletConfig - ServletConfig
例外:
ServletException - サーブレット初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。 このメソッドでは対応するサービスコントローラを呼び、次の画面に遷移します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。 このメソッドでは対応するサービスコントローラを呼び、次の画面に遷移します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

destroy

public void destroy()
サーブレットを解放します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceServletException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceServletException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceServletException
すべての実装インタフェース:
Serializable
public class ServiceServletException
extends SystemException

サービスに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceServletException()
詳細メッセージを指定しないで ServiceServletException を構築します。
ServiceServletException(String msg)
指定された詳細メッセージを持つ ServiceServletException を構築します。
ServiceServletException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceServletException

public ServiceServletException()
詳細メッセージを指定しないで ServiceServletException を構築します。

ServiceServletException

public ServiceServletException(String msg)
指定された詳細メッセージを持つ ServiceServletException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceServletException

public ServiceServletException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextFileServicePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス TextFileServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class TextFileServicePropertyHandler
extends Object
implements ServicePropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultServicePropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER
コンストラクタの概要
TextFileServicePropertyHandler()
TextFileServicePropertyHandlerを新規に生成します。
メソッドの概要
String | getApplicationParamName() 推奨されていません。 この実装は廃止されました。
String | getClientEncoding() クライアントのエンコードを取得します。
Locale | getClientLocale() クライアントのロケールを取得します。
String | getContextPath() 推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
String | getEncodingAttributeName() ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
String | getExceptionAttributeName() 例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
String | getInputErrorPagePath() 推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。
String | getInputErrorPagePath(Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。
String | getInputErrorPagePath(String application, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, String key, Locale locale) 入力例外時のページのパスを取得します。
String | getLocaleAttributeName() ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
String | getNextPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, Locale locale) 遷移先のページのパスを取得します。
String | getNextPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, String key, Locale locale) 遷移先のページのパスを取得します。
String | getServiceControllerName(String application, String service) 推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。
String | getServiceControllerName(String application, String service, Locale locale) サービスコントローラのクラス名を取得します。
String | getServiceErrorPagePath() 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。
String | getServiceErrorPagePath(Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, String key, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceParamName() 推奨されていません。 この実装は廃止されました。
String | getServiceServletPath() サービスサーブレットのパスを取得します。
String | getSystemErrorPagePath() 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。
String | getSystemErrorPagePath(Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, String key, Locale locale) システム例外時のページのパスを取得します。
String | getTransitionName(String application, String service) 推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。
String | getTransitionName(String application, String service, Locale locale) トランジションのクラス名を取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() 再設定可能かどうかをチェックします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileServicePropertyHandler

public TextFileServicePropertyHandler()
TextFileServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
再設定可能かどうかをチェックします。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
true 再設定可能、false 再設定不可

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのロケールを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのロケール
例外:
ServicePropertyException - クライアントのロケールの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドはgetNextPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。 このメソッドはgetNextPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドはgetInputErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。

処理例外時のページのパスを取得します。 このメソッドはgetServiceErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドはgetSystemErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceControllerName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドはgetTransitionName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
5.0
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


Transition (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス Transition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
直系の既知のサブクラス:
DefaultTransition, IntramartPageBaseTransition
public abstract class Transition
extends Object

画面遷移に関連するクラスのインタフェースです。

バージョン:
1.0

コンストラクタの概要
Transition()
Transitionを新規に生成します。
メソッドの概要
protected String | getApplication() アプリケーションIDを取得します。
MultipartFormData.Entity | getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
abstract String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
abstract String | getNextPage() 次に遷移するページを取得します。
protected String | getNextPagePath() このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
protected String | getNextPagePath(String key) このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | getResult() サービス処理結果を取得します。
protected String | getService() サービスIDを取得します。
abstract String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
protected ServiceManager | getServiceManager() サービスマネージャを取得します。
SessionObject | getSessionObject() 推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
abstract String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
abstract void | setInformation() 次の遷移先に渡す情報を設定します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
void | setResult(ServiceResult result) サービス処理結果を設定します。
protected void | setServiceManager(ServiceManager manager) サービスマネージャを設定します。
abstract void | transfer() 次のページに遷移します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Transition

public Transition()
Transitionを新規に生成します。

メソッドの詳細

setServiceManager

protected void setServiceManager(ServiceManager manager)
サービスマネージャを設定します。

パラメータ:
manager - サービスマネージャ

getServiceManager

protected ServiceManager getServiceManager()
サービスマネージャを取得します。

戻り値:
サービスマネージャ

getApplication

protected String getApplication()
アプリケーションIDを取得します。

戻り値:
アプリケーションID

getService

protected String getService()
サービスIDを取得します。

戻り値:
サービスID

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getEntity

public MultipartFormData.Entity getEntity(String name)
                                   throws SystemException
リクエストから指定された名前に該当するエンティティを取得します。 このメソッドは、ファイルアップロード時にその内容を取得する場合などに使用します。 このメソッドは、ファイルアップロードのリクエストが送られた場合のみ使用できます。 それ以外のリクエストが送られた場合にこのメソッドを呼ぶと例外が発生します。

パラメータ:
name - パラメータ名
戻り値:
パラメータ名に該当するエンティティ
例外:
SystemException - エンティティの取得に失敗
導入されたバージョン:
3.2

getSessionObject

public SessionObject getSessionObject()
                               throws SessionManagerException,
                                      SessionPropertyException,
                                      SessionFactoryException
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

セッションオブジェクトを取得します。

戻り値:
セッションオブジェクト
例外:
SessionManagerException - セッションマネージャの取得時に例外が発生
SessionPropertyException - セッションのプロパティ情報取得時に例外が発生
SessionFactoryException - セッションオブジェクトの生成時に例外が発生

setResult

public void setResult(ServiceResult result)
サービス処理結果を設定します。

パラメータ:
result - サービス処理結果

getResult

public ServiceResult getResult()
サービス処理結果を取得します。

戻り値:
サービス処理結果

getNextPagePath

protected String getNextPagePath()
                          throws ServicePropertyException
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。

戻り値:
次ページのパス
例外:
ServicePropertyException - プロパティの取得時に例外が発生

getNextPagePath

protected String getNextPagePath(String key)
                          throws ServicePropertyException
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。

パラメータ:
key - キー
戻り値:
次ページのパス
例外:
ServicePropertyException - プロパティの取得時に例外が発生

getInputErrorPage

public abstract String getInputErrorPage(RequestException e)
                                  throws ServicePropertyException,
                                         TransitionException
入力エラーのページを取得します。

パラメータ:
e - 入力時の例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public abstract String getSystemErrorPage(Exception e)
                                   throws ServicePropertyException,
                                          TransitionException
システムエラーのページを取得します。

パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public abstract String getServiceErrorPage(Exception e)
                                    throws ServicePropertyException,
                                           TransitionException
処理エラーのページを取得します。

パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public abstract void setInformation()
                             throws TransitionException
次の遷移先に渡す情報を設定します。

例外:
TransitionException - 情報設定時に例外が発生

getNextPage

public abstract String getNextPage()
                            throws ServicePropertyException,
                                   TransitionException
次に遷移するページを取得します。

戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

transfer

public abstract void transfer()
                       throws SystemException
次のページに遷移します。 遷移する方法は次のページで要求される形式に依存します。

例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TransitionException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス TransitionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.TransitionException
すべての実装インタフェース:
Serializable
public class TransitionException
extends SystemException

トランジションに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
TransitionException()
詳細メッセージを指定しないで TransitionException を構築します。
TransitionException(String msg)
指定された詳細メッセージを持つ TransitionException を構築します。
TransitionException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TransitionException

public TransitionException()
詳細メッセージを指定しないで TransitionException を構築します。

TransitionException

public TransitionException(String msg)
指定された詳細メッセージを持つ TransitionException を構築します。

パラメータ:
msg - 詳細メッセージ

TransitionException

public TransitionException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


XmlServicePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス XmlServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class XmlServicePropertyHandler
extends Object
implements ServicePropertyHandler

サービスの設定情報に接続するプロパティハンドラです。
XML形式で記述されたプロパティ情報を読み取ります。XMLファイルはアプリケーション毎に分割されます。この場合のファイル名は「 プレフィックス _ アプリケーションID .xml」です。また、アプリケーションに依存しない「 プレフィックス .xml」があります。
XMLファイルのプレフィックスは PropertyManager.getPropertyHandlerParams(String) でキーに ServiceManager.SERVICE_PROPERTY_HANDLER_KEY を指定したときに取得されるパラメータのうち DEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスは DEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「 プレフィックス _ アプリケーションID .xml」が優先されます。該当するプロパティが見つからない場合、引き続いて「 プレフィックス .xml」を検索します。

導入されたバージョン:
5.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER
コンストラクタの概要
XmlServicePropertyHandler()
XmlServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlServicePropertyHandler

public XmlServicePropertyHandler()
XmlServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
5.0
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の使用

jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.HttpSessionFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.HttpSessionFactory の使用

jp.co.intra_mart.framework.base.session.HttpSessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.HttpSessionObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.HttpSessionObject の使用

jp.co.intra_mart.framework.base.session.HttpSessionObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IllegalSessionException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IllegalSessionException の使用

jp.co.intra_mart.framework.base.session.IllegalSessionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IntramartSessionFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IntramartSessionFactory の使用

jp.co.intra_mart.framework.base.session.IntramartSessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.IntramartSessionObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IntramartSessionObject の使用

jp.co.intra_mart.framework.base.session.IntramartSessionObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionFactory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionFactory の使用

SessionFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.session セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.session での SessionFactory の使用

SessionFactory を実装している jp.co.intra_mart.framework.base.session のクラス
class | HttpSessionFactory 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
class | IntramartSessionFactory 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

SessionFactory を返す jp.co.intra_mart.framework.base.session のメソッド
 SessionFactory SessionManager.getSessionFactory()
セッションファクトリを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionFactoryException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionFactoryException の使用

SessionFactoryException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionFactoryException の使用

SessionFactoryException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionFactoryException の使用

SessionFactoryException をスローする jp.co.intra_mart.framework.base.session のメソッド
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionObject | SessionFactory.createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
String | SessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) セッションIDをエンコードしてURLに追加します。
SessionObject | IntramartSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | IntramartSessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
SessionObject | HttpSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | HttpSessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionFilter の使用

jp.co.intra_mart.framework.base.session.SessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionManager の使用

SessionManager を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionManager の使用

SessionManager を返す jp.co.intra_mart.framework.base.service のメソッド
protected  SessionManager IntramartConnectServlet.getSessionManager()
推奨されていません。 セッションマネージャを取得します。

jp.co.intra_mart.framework.base.session での SessionManager の使用

SessionManager を返す jp.co.intra_mart.framework.base.session のメソッド
static SessionManager SessionManager.getSessionManager()
セッションマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionManagerException の使用

SessionManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionManagerException の使用

SessionManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionManagerException の使用

SessionManagerException をスローする jp.co.intra_mart.framework.base.session のメソッド
static SessionManager SessionManager.getSessionManager()
セッションマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionObject の使用

SessionObject を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionObject の使用

SessionObject を返す jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionObject の使用

SessionObject を実装している jp.co.intra_mart.framework.base.session のクラス
class | HttpSessionObject 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
class | IntramartSessionObject 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

SessionObject を返す jp.co.intra_mart.framework.base.session のメソッド
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionObject | SessionFactory.createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
SessionObject | IntramartSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
SessionObject | HttpSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。

jp.co.intra_mart.framework.base.web.bean での SessionObject の使用

SessionObject を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 SessionObject HelperBean.getSession()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionObjectException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionObjectException の使用

SessionObjectException を使用しているパッケージ
jp.co.intra_mart.framework.base.session セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.session での SessionObjectException の使用

SessionObjectException をスローする jp.co.intra_mart.framework.base.session のメソッド
void | SessionObject.setAttribute(String name, Object value) 指定された名前に対応するオブジェクトを追加します。
Object | SessionObject.getAttribute(String name) 指定された名前に対応するオブジェクトを取得します。
void | SessionObject.removeAttribute(String name) 指定された名前に対応するオブジェクトを削除します。
Enumeration | SessionObject.getAttributeNames() セッション内に存在する名前の一覧を取得します。
void | SessionObject.clear() セッション内に存在するすべてのオブジェクトを削除します。
void | IntramartSessionObject.setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
Object | IntramartSessionObject.getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | IntramartSessionObject.getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
void | IntramartSessionObject.removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | IntramartSessionObject.clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
void | HttpSessionObject.setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
void | HttpSessionObject.removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
Object | HttpSessionObject.getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | HttpSessionObject.getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
void | HttpSessionObject.clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.SessionPropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionPropertyException の使用

SessionPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionPropertyException の使用

SessionPropertyException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionPropertyException の使用

SessionPropertyException をスローする jp.co.intra_mart.framework.base.session のメソッド
String | XmlSessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | XmlSessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | XmlSessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | XmlSessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | XmlSessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | XmlSessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | SessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | SessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | SessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | SessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | SessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | SessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
String | DefaultSessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | DefaultSessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | DefaultSessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | DefaultSessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | DefaultSessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | DefaultSessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.session.SessionPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionPropertyHandler の使用

SessionPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionPropertyHandler の使用

SessionPropertyHandler を返す jp.co.intra_mart.framework.base.service のメソッド
protected  SessionPropertyHandler IntramartConnectServlet.getSessionPropertyHandler()
推奨されていません。 セッションプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.session での SessionPropertyHandler の使用

SessionPropertyHandler を実装している jp.co.intra_mart.framework.base.session のクラス
class | DefaultSessionPropertyHandler セッションに関連するデフォルトのプロパティハンドラです。
class | XmlSessionPropertyHandler セッションに関連するXMLのプロパティハンドラです。

SessionPropertyHandler を返す jp.co.intra_mart.framework.base.session のメソッド
 SessionPropertyHandler SessionManager.getSessionPropertyHandler()
セッションプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の使用

jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DefaultSessionPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス DefaultSessionPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler
すべての実装インタフェース:
PropertyHandler, SessionPropertyHandler
public class DefaultSessionPropertyHandler
extends Object
implements SessionPropertyHandler

セッションに関連するデフォルトのプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

キー | 内容
factory.name | SessionFactoryのクラス名
object.param | リクエストに渡すセッションIDのパラメータ名
error.page.path | セッションエラー（セッションタイムアウト等）のときに表示するページのパス
object.key | リクエストの属性にSessionObjectを保存する時のキー
reserved.user.key | SessionObjectの属性に設定されているユーザIDのキー
reserved.group.key | SessionObjectの属性に設定されているログイングループIDのキー

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultSessionPropertyHandler()
DefaultSessionPropertyHandlerを新規に生成します。
メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultSessionPropertyHandler

public DefaultSessionPropertyHandler()
DefaultSessionPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionFactoryName
戻り値:
セッションファクトリのクラス名（設定されていない場合null）
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionParameter
戻り値:
セッションIDのパラメータ名（設定されていない場合null）
例外:
SessionPropertyException - セッションIDのパラメータ名の取得時に例外が発生

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionObjectKey
戻り値:
セッションオブジェクトのキー（設定されていない場合null）
例外:
SessionPropertyException - セッションオブジェクトのキーの取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginUserIDKey
戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginGroupIDKey
戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

定義:
インタフェース SessionPropertyHandler 内の getSessionErrorPagePath
戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス HttpSessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.HttpSessionFactory
すべての実装インタフェース:
SessionFactory
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class HttpSessionFactory
extends Object
implements SessionFactory

HTTPセッションに関連するセッションファクトリです。

バージョン:
1.0

コンストラクタの概要
HttpSessionFactory()
推奨されていません。 HttpSessionFactoryを新規に生成します。
メソッドの概要
SessionObject | createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() 推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionFactory

public HttpSessionFactory()
推奨されていません。
HttpSessionFactoryを新規に生成します。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
推奨されていません。
セッションオブジェクトを新規に生成します。 HttpSessionObjectを生成します。

定義:
インタフェース SessionFactory 内の createSessionObject
パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗
関連項目:
HttpSessionObject

isEncodeRequired

public boolean isEncodeRequired()
推奨されていません。
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

定義:
インタフェース SessionFactory 内の isEncodeRequired
戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
推奨されていません。
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

定義:
インタフェース SessionFactory 内の encodeURL
パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス HttpSessionObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.HttpSessionObject
すべての実装インタフェース:
SessionObject
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class HttpSessionObject
extends Object
implements SessionObject

HttpSessionを利用したSessionObjectです。

バージョン:
1.0

コンストラクタの概要
HttpSessionObject(HttpSession session)
推奨されていません。 HttpSessionObjectを新規に生成します。
メソッドの概要
void | clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
String | getSessionID() 推奨されていません。 セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionObject

public HttpSessionObject(HttpSession session)
推奨されていません。
HttpSessionObjectを新規に生成します。

パラメータ:
session - HttpSession
メソッドの詳細

getSessionID

public String getSessionID()
推奨されていません。
セッションを一意に識別するIDを取得します。

定義:
インタフェース SessionObject 内の getSessionID
戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを追加します。

定義:
インタフェース SessionObject 内の setAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

定義:
インタフェース SessionObject 内の removeAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

定義:
インタフェース SessionObject 内の getAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
推奨されていません。
セッション内に存在する名前の一覧を取得します。

定義:
インタフェース SessionObject 内の getAttributeNames
戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

clear

public void clear()
           throws SessionObjectException
推奨されていません。
セッション内に存在するすべてのオブジェクトを削除します。

定義:
インタフェース SessionObject 内の clear
例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalSessionException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IllegalSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.IllegalSessionException
すべての実装インタフェース:
Serializable
public class IllegalSessionException
extends SystemException

セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalSessionException()
詳細メッセージを指定しないで IllegalSessionException を構築します。
IllegalSessionException(String msg)
指定された詳細メッセージを持つ IllegalSessionException を構築します。
IllegalSessionException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalSessionException

public IllegalSessionException()
詳細メッセージを指定しないで IllegalSessionException を構築します。

IllegalSessionException

public IllegalSessionException(String msg)
指定された詳細メッセージを持つ IllegalSessionException を構築します。

パラメータ:
msg - 詳細メッセージ

IllegalSessionException

public IllegalSessionException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IntramartSessionFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IntramartSessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.IntramartSessionFactory
すべての実装インタフェース:
SessionFactory
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class IntramartSessionFactory
extends Object
implements SessionFactory

intra-martのセッションを利用するセッションオブジェクトを生成します。 このクラスを利用するためには、intra-martをインストールする必要があります。

バージョン:
1.0

コンストラクタの概要
IntramartSessionFactory()
推奨されていません。 IntramartSessionFactoryを新規に生成します。
メソッドの概要
SessionObject | createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() 推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartSessionFactory

public IntramartSessionFactory()
推奨されていません。
IntramartSessionFactoryを新規に生成します。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
推奨されていません。
セッションオブジェクトを新規に生成します。

定義:
インタフェース SessionFactory 内の createSessionObject
パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗

isEncodeRequired

public boolean isEncodeRequired()
推奨されていません。
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

定義:
インタフェース SessionFactory 内の isEncodeRequired
戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
推奨されていません。
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

定義:
インタフェース SessionFactory 内の encodeURL
パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartSessionObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IntramartSessionObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.IntramartSessionObject
すべての実装インタフェース:
SessionObject
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class IntramartSessionObject
extends Object
implements SessionObject

intra-martのSessionを利用したSessionObjectです。 このクラスを利用するためには、intra-martをインストールする必要があります。

バージョン:
1.0

コンストラクタの概要
IntramartSessionObject(SessionMemory session)
推奨されていません。 IntramartSessionObjectを生成します。
メソッドの概要
void | clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
String | getSessionID() 推奨されていません。 セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartSessionObject

public IntramartSessionObject(SessionMemory session)
推奨されていません。
IntramartSessionObjectを生成します。

パラメータ:
session - intra-martの共有データオブジェクト
メソッドの詳細

getSessionID

public String getSessionID()
推奨されていません。
セッションを一意に識別するIDを取得します。

定義:
インタフェース SessionObject 内の getSessionID
戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを追加します。

定義:
インタフェース SessionObject 内の setAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

定義:
インタフェース SessionObject 内の getAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
推奨されていません。
セッション内に存在する名前の一覧を取得します。

定義:
インタフェース SessionObject 内の getAttributeNames
戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

定義:
インタフェース SessionObject 内の removeAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

clear

public void clear()
           throws SessionObjectException
推奨されていません。
セッション内に存在するすべてのオブジェクトを削除します。

定義:
インタフェース SessionObject 内の clear
例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.session (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.session
インタフェース
SessionFactory
SessionObject
SessionPropertyHandler
クラス
DefaultSessionPropertyHandler
HttpSessionFactory
HttpSessionObject
IntramartSessionFactory
IntramartSessionObject
SessionFilter
SessionManager
XmlSessionPropertyHandler
例外
IllegalSessionException
SessionFactoryException
SessionManagerException
SessionObjectException
SessionPropertyException


jp.co.intra_mart.framework.base.session (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.session

セッションに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
SessionFactory | セッションに関連するファクトリクラスとなるインタフェースです。
SessionObject | セッションに関連する情報を持つオブジェクトです。
SessionPropertyHandler | セッションに関連するプロパティを取得します。

クラスの概要
DefaultSessionPropertyHandler | セッションに関連するデフォルトのプロパティハンドラです。
HttpSessionFactory | 推奨されていません。 このクラスは互換性のために残されています。
HttpSessionObject | 推奨されていません。 このクラスは互換性のために残されています。
IntramartSessionFactory | 推奨されていません。 このクラスは互換性のために残されています。
IntramartSessionObject | 推奨されていません。 このクラスは互換性のために残されています。
SessionFilter | セッション管理をします。
SessionManager | セッションマネージャです。
XmlSessionPropertyHandler | セッションに関連するXMLのプロパティハンドラです。

例外の概要
IllegalSessionException | セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
SessionFactoryException | セッションファクトリ内の例外です。
SessionManagerException | セッションマネージャ内の例外です。
SessionObjectException | セッションオブジェクト内の例外です。
SessionPropertyException | セッションプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.session の説明

セッションに関連するクラスのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.session クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.session の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.framework.base.session.HttpSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.HttpSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.session.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.session.IllegalSessionException
            • class jp.co.intra_mart.framework.base.session.SessionFactoryException
            • class jp.co.intra_mart.framework.base.session.SessionManagerException
            • class jp.co.intra_mart.framework.base.session.SessionObjectException
            • class jp.co.intra_mart.framework.base.session.SessionPropertyException
    • class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler
  • interface jp.co.intra_mart.framework.base.session.SessionFactory
  • interface jp.co.intra_mart.framework.base.session.SessionObject
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.session の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.session の使用

jp.co.intra_mart.framework.base.session を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.session のクラス
SessionFactoryException
セッションファクトリ内の例外です。
SessionManager
セッションマネージャです。
SessionManagerException
セッションマネージャ内の例外です。
SessionObject
セッションに関連する情報を持つオブジェクトです。
SessionPropertyException
セッションプロパティ取得時の例外です。
SessionPropertyHandler
セッションに関連するプロパティを取得します。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.base.session のクラス
SessionFactory
セッションに関連するファクトリクラスとなるインタフェースです。
SessionFactoryException
セッションファクトリ内の例外です。
SessionManager
セッションマネージャです。
SessionManagerException
セッションマネージャ内の例外です。
SessionObject
セッションに関連する情報を持つオブジェクトです。
SessionObjectException
セッションオブジェクト内の例外です。
SessionPropertyException
セッションプロパティ取得時の例外です。
SessionPropertyHandler
セッションに関連するプロパティを取得します。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.session のクラス
SessionObject
セッションに関連する情報を持つオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SessionFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionFactory

既知の実装クラスの一覧:
HttpSessionFactory, IntramartSessionFactory
public interface SessionFactory

セッションに関連するファクトリクラスとなるインタフェースです。

バージョン:
1.0

メソッドの概要
SessionObject | createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
セッションオブジェクトを新規に生成します。

パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗

isEncodeRequired

public boolean isEncodeRequired()
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SessionFactoryException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionFactoryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionFactoryException
すべての実装インタフェース:
Serializable
public class SessionFactoryException
extends SystemException

セッションファクトリ内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionFactoryException()
詳細メッセージを指定しないで SessionFactoryException を構築します。
SessionFactoryException(String msg)
指定された詳細メッセージを持つ SessionFactoryException を構築します。
SessionFactoryException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionFactoryException

public SessionFactoryException()
詳細メッセージを指定しないで SessionFactoryException を構築します。

SessionFactoryException

public SessionFactoryException(String msg)
指定された詳細メッセージを持つ SessionFactoryException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionFactoryException

public SessionFactoryException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.SessionFilter
すべての実装インタフェース:
Filter
public class SessionFilter
extends Object
implements Filter

セッション管理をします。

バージョン:
1.0

コンストラクタの概要
SessionFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのセッション管理をします。
void | init(FilterConfig filterConfig) セッション用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionFilter

public SessionFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
セッション用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのセッション管理をします。 SessionFactoryを利用しない場合、以下の条件がすべて満たされるときセッションが継続しているものとみなされます。
  • セッションが存在する
SessionFactoryを利用する場合、以下の条件がすべて満たされるときセッションが継続しているものとみなされます。
  • sessionにSessionPropertyHandler.getLoginUserIDKey()で指定された属性（ログインユーザID）が登録されている
  • sessionにSessionPropertyHandler.getLoginGroupIDKey()で指定された属性（ログイングループID）が登録されている

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.SessionManager
public class SessionManager
extends Object

セッションマネージャです。

バージョン:
1.0

フィールドの概要
static String SESSION_PROPERTY_HANDLER_KEY
セッションプロパティハンドラのキー
メソッドの概要
SessionFactory | getSessionFactory() セッションファクトリを取得します。
static SessionManager | getSessionManager() セッションマネージャを取得します。
SessionObject | getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionPropertyHandler | getSessionPropertyHandler() セッションプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SESSION_PROPERTY_HANDLER_KEY

public static final String SESSION_PROPERTY_HANDLER_KEY
セッションプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getSessionManager

public static SessionManager getSessionManager()
                                        throws SessionManagerException
セッションマネージャを取得します。

戻り値:
セッションマネージャ
例外:
SessionManagerException - セッションマネージャの生成に失敗した

getSessionPropertyHandler

public SessionPropertyHandler getSessionPropertyHandler()
セッションプロパティハンドラを取得します。

戻り値:
セッションプロパティハンドラ

getSessionFactory

public SessionFactory getSessionFactory()
セッションファクトリを取得します。 セッションプロパティにSessionFactoryが指定されていない場合、nullが返ります。

戻り値:
セッションファクトリ（プロパティが設定されていない場合null）

getSessionObject

public SessionObject getSessionObject(ServletRequest request)
                               throws SessionPropertyException,
                                      SessionFactoryException
セッションオブジェクトを取得します。 指定されたリクエスト内にあるセッションオブジェクトを取得します。 セッションが存在しない場合、新規にセッションを生成します。 このメソッドはセッションプロパティにSessionFactoryを指定したときに有効になります。

パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionPropertyException - セッションプロパティの取得に失敗
SessionFactoryException - セッションオブジェクトの生成に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionManagerException
すべての実装インタフェース:
Serializable
public class SessionManagerException
extends SystemException

セッションマネージャ内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionManagerException()
詳細メッセージを指定しないで SessionManagerException を構築します。
SessionManagerException(String msg)
指定された詳細メッセージを持つ SessionManagerException を構築します。
SessionManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionManagerException

public SessionManagerException()
詳細メッセージを指定しないで SessionManagerException を構築します。

SessionManagerException

public SessionManagerException(String msg)
指定された詳細メッセージを持つ SessionManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionManagerException

public SessionManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionObject

既知の実装クラスの一覧:
HttpSessionObject, IntramartSessionObject
public interface SessionObject

セッションに関連する情報を持つオブジェクトです。 セッション管理の方法に応じてこのインタフェースを実装してください。

バージョン:
1.0

メソッドの概要
void | clear() セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() セッション内に存在する名前の一覧を取得します。
String | getSessionID() セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 指定された名前に対応するオブジェクトを追加します。

メソッドの詳細

getSessionID

public String getSessionID()
セッションを一意に識別するIDを取得します。

戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
指定された名前に対応するオブジェクトを追加します。

パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
セッション内に存在する名前の一覧を取得します。

戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

clear

public void clear()
           throws SessionObjectException
セッション内に存在するすべてのオブジェクトを削除します。

例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionObjectException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionObjectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionObjectException
すべての実装インタフェース:
Serializable
public class SessionObjectException
extends SystemException

セッションオブジェクト内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionObjectException()
詳細メッセージを指定しないで SessionObjectException を構築します。
SessionObjectException(String msg)
指定された詳細メッセージを持つ SessionObjectException を構築します。
SessionObjectException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionObjectException

public SessionObjectException()
詳細メッセージを指定しないで SessionObjectException を構築します。

SessionObjectException

public SessionObjectException(String msg)
指定された詳細メッセージを持つ SessionObjectException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionObjectException

public SessionObjectException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionPropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionPropertyException
すべての実装インタフェース:
Serializable
public class SessionPropertyException
extends SystemException

セッションプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionPropertyException()
詳細メッセージを指定しないで SessionPropertyException を構築します。
SessionPropertyException(String msg)
指定された詳細メッセージを持つ SessionPropertyException を構築します。
SessionPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionPropertyException

public SessionPropertyException()
詳細メッセージを指定しないで SessionPropertyException を構築します。

SessionPropertyException

public SessionPropertyException(String msg)
指定された詳細メッセージを持つ SessionPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionPropertyException

public SessionPropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SessionPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultSessionPropertyHandler, XmlSessionPropertyHandler
public interface SessionPropertyHandler
extends PropertyHandler

セッションに関連するプロパティを取得します。

バージョン:
1.0

メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションオブジェクトのキー
例外:
SessionPropertyException - セッションオブジェクトのキーの取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションIDのパラメータ名
例外:
SessionPropertyException - セッションIDのパラメータ名の取得時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションファクトリのクラス名
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


XmlSessionPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス XmlSessionPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler
すべての実装インタフェース:
PropertyHandler, SessionPropertyHandler
public class XmlSessionPropertyHandler
extends Object
implements SessionPropertyHandler

セッションに関連するXMLのプロパティハンドラです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのxmlファイル名
static String | DEFAULT_BUNDLE_NAME_PARAM xmlファイル名のパラメータ名
コンストラクタの概要
XmlSessionPropertyHandler()
メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのxmlファイル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
xmlファイル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlSessionPropertyHandler

public XmlSessionPropertyHandler()
メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionFactoryName
戻り値:
セッションファクトリのクラス名（設定されていない場合null）
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionParameter
戻り値:
セッションIDのパラメータ名（設定されていない場合null）
例外:
SessionPropertyException - セッションパラメータ取得時に例外が発生

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionObjectKey
戻り値:
セッションオブジェクトのキー（設定されていない場合null）
例外:
SessionPropertyException - セッションオブジェクトキー取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginUserIDKey
戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginGroupIDKey
戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

定義:
インタフェース SessionPropertyHandler 内の getSessionErrorPagePath
戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.util.ConfigurationUserInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.ConfigurationUserInfo の使用

jp.co.intra_mart.framework.base.util.ConfigurationUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.EmptyUserInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.EmptyUserInfo の使用

jp.co.intra_mart.framework.base.util.EmptyUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.util.UserInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.util.UserInfo の使用

UserInfo を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.event のメソッド
 UserInfo Event.getUserInfo()
ログインユーザの情報を取得します。

UserInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。

jp.co.intra_mart.framework.base.service での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.service のメソッド
 UserInfo ServiceControllerAdapter.getUserInfo()
ユーザ情報を取得します。

jp.co.intra_mart.framework.base.util での UserInfo の使用

UserInfo を実装している jp.co.intra_mart.framework.base.util のクラス
class | ConfigurationUserInfo 情報を自由に設定可能なUserInfoです。
class | EmptyUserInfo 情報を何も持たないUserInfoです。

UserInfo を返す jp.co.intra_mart.framework.base.util のメソッド
static UserInfo UserInfoUtil.createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。

jp.co.intra_mart.framework.base.web.bean での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 UserInfo HelperBean.getUserInfo()
ログインユーザ情報を取得します。

jp.co.intra_mart.framework.extension.common.util での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.extension.common.util のメソッド
static UserInfo ServiceUtils.getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。

jp.co.intra_mart.framework.extension.struts.action での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  UserInfo IntramartAction.getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。

jp.co.intra_mart.framework.presentation.view での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.presentation.view のメソッド
 UserInfo AbstractViewConverter.getUserInfo(RequestInfo info)
ログインユーザ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.UserInfoException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoException の使用

UserInfoException を使用しているパッケージ
jp.co.intra_mart.framework.base.util

jp.co.intra_mart.framework.base.util での UserInfoException の使用

UserInfoException をスローする jp.co.intra_mart.framework.base.util のメソッド
static UserInfo UserInfoUtil.createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.util.UserInfoUtil の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoUtil の使用

jp.co.intra_mart.framework.base.util.UserInfoUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ConfigurationUserInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス ConfigurationUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.ConfigurationUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class ConfigurationUserInfo
extends Object
implements UserInfo, Serializable

情報を自由に設定可能なUserInfoです。
アクセスセキュリティと連動したユーザ情報が必要ではない場合、このクラスを利用して 任意のUserInfoを生成することが可能です。
バッチ処理などログインセッションに依存しない環境でのイベント実行時にも利用可能です。

 ConfigurationUserInfo info = new ConfigurationUserInfo();
 info.setUserID("user_id");
 info.setLoginGroupID("group_id");

 EventManager manager = EventManager.getEventManager();
 FooEvent event = (FooEvent)manager.createEvent("foo", "bar", info);
 event.doSomething();

 manager.dispatch(event);
アクセスセキュリティと連動したユーザ情報が必要な場合は UserInfoUtil.createUserInfo(HttpServletRequest, HttpServletResponse) を使用してください。

導入されたバージョン:
5.0.5
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ConfigurationUserInfo()
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。
void | setClientType(String clientType) クライアントタイプを設定する。
void | setColorPatternID(String colorPatternID) カラーパターンIDを設定する。
void | setEncoding(String encoding) エンコーディングを設定する。
void | setLocale(Locale locale) ユーザのロケールを設定する。
void | setLoginGroupID(String loginGroupID) ログイングループIDを設定する。
void | setLoginTime(Date loginTime) ログインした時間を設定する。
void | setLoginType(String loginType) ログインタイプを設定する。
void | setUserID(String userID) ログインユーザIDを設定する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConfigurationUserInfo

public ConfigurationUserInfo()
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

setClientType

public void setClientType(String clientType)
クライアントタイプを設定する。

パラメータ:
clientType - クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

setColorPatternID

public void setColorPatternID(String colorPatternID)
カラーパターンIDを設定する。

パラメータ:
colorPatternID - カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

setEncoding

public void setEncoding(String encoding)
エンコーディングを設定する。

パラメータ:
encoding - エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。 値が未設定の場合はnullを返却します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

setLocale

public void setLocale(Locale locale)
ユーザのロケールを設定する。

パラメータ:
locale - ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

setLoginGroupID

public void setLoginGroupID(String loginGroupID)
ログイングループIDを設定する。

パラメータ:
loginGroupID - ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
値が未設定の場合はnullを返却します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログイン時間

setLoginTime

public void setLoginTime(Date loginTime)
ログインした時間を設定する。

パラメータ:
loginTime - ログインした時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
値が未設定の場合はUserInfoUtil.LT_USERを返却します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

setLoginType

public void setLoginType(String loginType)
ログインタイプを設定する。

パラメータ:
loginType - ログインタイプ

getUserID

public String getUserID()
ログインユーザIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID

setUserID

public void setUserID(String userID)
ログインユーザIDを設定する。

パラメータ:
userID - ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EmptyUserInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス EmptyUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.EmptyUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class EmptyUserInfo
extends Object
implements UserInfo, Serializable

情報を何も持たないUserInfoです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyUserInfo()
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyUserInfo

public EmptyUserInfo()
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。 このメソッドは常にnullを返却します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
このメソッドは常にnullを返却します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
このメソッドは常にUserInfoUtil.LT_USERを返却します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ログインユーザIDを取得する。 このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.util (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.util
インタフェース
UserInfo
クラス
ConfigurationUserInfo
EmptyUserInfo
UserInfoUtil
例外
UserInfoException


jp.co.intra_mart.framework.base.util (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.util

インタフェースの概要
UserInfo ログインユーザの情報を管理します。

クラスの概要
ConfigurationUserInfo | 情報を自由に設定可能なUserInfoです。
EmptyUserInfo | 情報を何も持たないUserInfoです。
UserInfoUtil | ログインユーザの情報に関するユーティリティクラスです。

例外の概要
UserInfoException ユーザ情報に関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.util クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.util.EmptyUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.util.UserInfoException
    • class jp.co.intra_mart.framework.base.util.UserInfoUtil

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.util.UserInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.util の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.util の使用

jp.co.intra_mart.framework.base.util を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.base.util により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。
UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.extension.common.util により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.extension.struts.action により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


UserInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
インタフェース UserInfo

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ConfigurationUserInfo, EmptyUserInfo
public interface UserInfo
extends Serializable

ログインユーザの情報を管理します。 イントラマートにアクセスしたクライアント情報をラップしたオブジェクトです。
このオブジェクトは通常UserInfoUtil.createUserInfo(HttpServletRequest, HttpServletResponse) から生成されます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
UserInfoUtil

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
セッション情報にクライアントタイプが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合はデフォルトのカラーパターンIDを返却する。

戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
セッション情報にエンコーディングが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。
セッション情報にロケールが存在しない場合、および空文字列の場合はnullを返却する。

戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
セッション情報にログイングループIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
セッション情報にログイン時間が存在しない場合、nullを返却する。

戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
セッション情報にログインタイプが存在しない場合、および空文字列の場合は UserInfoUtil.LT_USER を返却する。

戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ログインユーザIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserInfoException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.util.UserInfoException
すべての実装インタフェース:
Serializable
public class UserInfoException
extends SystemException

ユーザ情報に関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserInfoException()
詳細メッセージを指定しないで UserInfoException を構築します。
UserInfoException(String msg)
指定された詳細メッセージを持つ UserInfoException を構築します。
UserInfoException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserInfoException

public UserInfoException()
詳細メッセージを指定しないで UserInfoException を構築します。

UserInfoException

public UserInfoException(String msg)
指定された詳細メッセージを持つ UserInfoException を構築します。

パラメータ:
msg - 詳細メッセージ

UserInfoException

public UserInfoException(String msg,
                         Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UserInfoUtil (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoUtil

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.UserInfoUtil
public class UserInfoUtil
extends Object

ログインユーザの情報に関するユーティリティクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | LT_GROUP グループマネージャ
static String | LT_SUPER スーパーユーザ
static String | LT_USER ユーザ
メソッドの概要
static UserInfo createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LT_SUPER

public static final String LT_SUPER
スーパーユーザ

関連項目:
定数フィールド値

LT_GROUP

public static final String LT_GROUP
グループマネージャ

関連項目:
定数フィールド値

LT_USER

public static final String LT_USER
ユーザ

関連項目:
定数フィールド値
メソッドの詳細

createUserInfo

public static UserInfo createUserInfo(HttpServletRequest request,
                                      HttpServletResponse response)
                               throws UserInfoException
intra-martのセッション情報からUserInfoを新規に生成します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザの情報
例外:
UserInfoException - UserInfo生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean の使用

jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.bean.HelperBean の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.HelperBean の使用

HelperBean を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean での HelperBean の使用

jp.co.intra_mart.framework.base.web.bean での HelperBean のサブクラス
 class ErrorHelperBean
例外ページで使用するHelperBeanです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.bean.HelperBeanException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.HelperBeanException の使用

HelperBeanException を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean での HelperBeanException の使用

HelperBeanException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
 void HelperBean.init()
HelperBeanを初期化します。
 SessionObject HelperBean.getSession()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
 String HelperBean.getLoginUserID()
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
 String HelperBean.getLoginGroupID()
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
 UserInfo HelperBean.getUserInfo()
ログインユーザ情報を取得します。
protected  Event HelperBean.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。
 Throwable ErrorHelperBean.getException()
例外を取得します。

HelperBeanException をスローする jp.co.intra_mart.framework.base.web.bean のコンストラクタ
HelperBean()
HelperBeanを新規に生成します。
ErrorHelperBean()
ErrorHelperBeanを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ErrorHelperBean (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス ErrorHelperBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBean
        拡張 jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
すべての実装インタフェース:
Serializable
public class ErrorHelperBean
extends HelperBean

例外ページで使用するHelperBeanです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ErrorHelperBean()
ErrorHelperBeanを新規に生成します。
メソッドの概要
 Throwable getException()
例外を取得します。
クラス jp.co.intra_mart.framework.base.web.bean.HelperBean から継承したメソッド
createEvent, dispatchEvent, getLoginGroupID, getLoginUserID, getRequest, getResponse, getServicePropertyHandler, getSession, getUserInfo, init, setRequest, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorHelperBean

public ErrorHelperBean()
                throws HelperBeanException
ErrorHelperBeanを新規に生成します。

例外:
HelperBeanException - ErrorHelperBean生成時に例外が発生
メソッドの詳細

getException

public Throwable getException()
                       throws HelperBeanException
例外を取得します。

戻り値:
例外
例外:
HelperBeanException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HelperBean (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス HelperBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBean
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ErrorHelperBean
public abstract class HelperBean
extends Object
implements Serializable

画面表示をする時のヘルパークラスです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
HelperBean()
HelperBeanを新規に生成します。
メソッドの概要
protected Event | createEvent(String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
SessionObject | getSession() 推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
UserInfo | getUserInfo() ログインユーザ情報を取得します。
void | init() HelperBeanを初期化します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBean

public HelperBean()
           throws HelperBeanException
HelperBeanを新規に生成します。

例外:
HelperBeanException - HelperBean生成時に例外が発生
メソッドの詳細

init

public void init()
          throws HelperBeanException
HelperBeanを初期化します。

例外:
HelperBeanException - 初期化時に例外が発生
導入されたバージョン:
3.2

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getSession

public SessionObject getSession()
                         throws HelperBeanException
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

セッションオブジェクトを取得します。 このメソッドはセッションプロパティにSessionFactoryとSessionObjectKeyを指定したときに有効になります。

戻り値:
セッションオブジェクト
例外:
HelperBeanException - セッションオブジェクト取得時に例外が発生

getLoginUserID

public String getLoginUserID()
                      throws HelperBeanException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
例外:
HelperBeanException - ログインユーザID取得時に例外が発生
導入されたバージョン:
3.2

getLoginGroupID

public String getLoginGroupID()
                       throws HelperBeanException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
例外:
HelperBeanException - ログイングループID取得時に例外が発生
導入されたバージョン:
3.2

getUserInfo

public UserInfo getUserInfo()
                     throws HelperBeanException
ログインユーザ情報を取得します。
ログインセッションが存在しない場合はnullを返却します。

戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ログインユーザ情報取得時に例外が発生
HelperBeanException
導入されたバージョン:
5.0

createEvent

protected Event createEvent(String application,
                            String key)
                     throws HelperBeanException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
HelperBeanException - イベント生成時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventException - イベント処理時に例外が発生
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HelperBeanException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス HelperBeanException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBeanException
すべての実装インタフェース:
Serializable
public class HelperBeanException
extends SystemException

HelperBean内で発生した例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
HelperBeanException()
詳細メッセージを指定しないで HelperBeanException を構築します。
HelperBeanException(String msg)
指定された詳細メッセージを持つ HelperBeanException を構築します。
HelperBeanException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HelperBeanException

public HelperBeanException()
詳細メッセージを指定しないで HelperBeanException を構築します。

HelperBeanException

public HelperBeanException(String msg)
指定された詳細メッセージを持つ HelperBeanException を構築します。

パラメータ:
msg - 詳細メッセージ

HelperBeanException

public HelperBeanException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.bean (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.web.bean
クラス
ErrorHelperBean
HelperBean
例外
HelperBeanException


jp.co.intra_mart.framework.base.web.bean (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.bean

JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

参照:
説明

クラスの概要
ErrorHelperBean | 例外ページで使用するHelperBeanです。
HelperBean | 画面表示をする時のヘルパークラスです。

例外の概要
HelperBeanException HelperBean内で発生した例外です。

パッケージ jp.co.intra_mart.framework.base.web.bean の説明

JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.web.bean クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.bean の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.bean.HelperBean (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.web.bean.HelperBeanException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.web.bean の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.bean の使用

jp.co.intra_mart.framework.base.web.bean を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.web.bean のクラス
HelperBean
画面表示をする時のヘルパークラスです。
HelperBeanException
HelperBean内で発生した例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes の使用

GenericAttributes を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute での GenericAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute での GenericAttributes のサブクラス
class | CoreAttributes コア属性です。
class | EventsAttributes ブラウザのイベントに関連するタグの属性情報です。
class | I18nAttributes 国際化の属性です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


CoreAttributes (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス CoreAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
public class CoreAttributes
extends GenericAttributes

コア属性です。

バージョン:
1.0

コンストラクタの概要
CoreAttributes()
CoreAttributesを新規に生成します。
メソッドの概要
String | getStyle() 属性styleの値を取得します。
String | getTagClass() 属性classの値を取得します。
String | getTitle() 属性titleの値を取得します。
void | printAttributes() 属性の内容を表示します。
void | setStyle(String style) 属性styleの値を設定します。
void | setTagClass(String tagClass) 属性classの値を設定します。
void | setTitle(String title) 属性titleの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CoreAttributes

public CoreAttributes()
CoreAttributesを新規に生成します。

メソッドの詳細

getTagClass

public String getTagClass()
属性classの値を取得します。

戻り値:
class

setTagClass

public void setTagClass(String tagClass)
属性classの値を設定します。

パラメータ:
tagClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventsAttributes (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス EventsAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
public class EventsAttributes
extends GenericAttributes

ブラウザのイベントに関連するタグの属性情報です。

バージョン:
1.0

コンストラクタの概要
EventsAttributes()
EventsAttributesを新規に生成します。
メソッドの概要
String | getOnClick() 属性onClickの値を取得します。
String | getOnDblClick() 属性onDblClickの値を取得します。
String | getOnKeyDown() 属性onKeyDownの値を取得します。
String | getOnKeyPress() 属性onKeyPressの値を取得します。
String | getOnKeyUp() 属性onKeyUpの値を取得します。
String | getOnMouseDown() 属性onMouseDownの値を取得します。
String | getOnMouseMove() 属性onMouseMoveの値を取得します。
String | getOnMouseOut() 属性onMouseOutの値を取得します。
String | getOnMouseOver() 属性onMouseOverの値を取得します。
String | getOnMouseUp() 属性onMouseUpの値を取得します。
void | printAttributes() 属性の内容を表示します。
protected void | printOnClick() 属性onClickを出力します。
protected void | printOnDblClick() 属性onDblClickを出力します。
protected void | printOnKeyDown() 属性onKeyDownを出力します。
protected void | printOnKeyPress() 属性onKeyPressを出力します。
protected void | printOnKeyUp() 属性onKeyUpを出力します。
protected void | printOnMouseDown() 属性onMouseDownを出力します。
protected void | printOnMouseMove() 属性onMouseMoveを出力します。
protected void | printOnMouseOut() 属性onMouseOutを出力します。
protected void | printOnMouseOver() 属性onMouseOverを出力します。
protected void | printOnMouseUp() 属性onMouseUpを出力します。
void | setOnClick(String onClick) 属性onClickの値を設定します。
void | setOnDblClick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnKeyDown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnKeyPress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnKeyUp(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnMouseDown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnMouseMove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnMouseOut(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnMouseOver(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnMouseUp(String onMouseUp) 属性onMouseUpの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventsAttributes

public EventsAttributes()
EventsAttributesを新規に生成します。

メソッドの詳細

getOnClick

public String getOnClick()
属性onClickの値を取得します。

戻り値:
onClick

setOnClick

public void setOnClick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOnDblClick

public String getOnDblClick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOnDblClick

public void setOnDblClick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnMouseDown

public String getOnMouseDown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnMouseDown

public void setOnMouseDown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnMouseUp

public String getOnMouseUp()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnMouseUp

public void setOnMouseUp(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnMouseOver

public String getOnMouseOver()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnMouseOver

public void setOnMouseOver(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnMouseMove

public String getOnMouseMove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnMouseMove

public void setOnMouseMove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnMouseOut

public String getOnMouseOut()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnMouseOut

public void setOnMouseOut(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnKeyPress

public String getOnKeyPress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnKeyPress

public void setOnKeyPress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnKeyDown

public String getOnKeyDown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnKeyDown

public void setOnKeyDown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnKeyUp

public String getOnKeyUp()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnKeyUp

public void setOnKeyUp(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp

printOnClick

protected void printOnClick()
                     throws IOException
属性onClickを出力します。

例外:
IOException - 出力中に例外が発生

printOnDblClick

protected void printOnDblClick()
                        throws IOException
属性onDblClickを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseDown

protected void printOnMouseDown()
                         throws IOException
属性onMouseDownを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseUp

protected void printOnMouseUp()
                       throws IOException
属性onMouseUpを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseOver

protected void printOnMouseOver()
                         throws IOException
属性onMouseOverを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseMove

protected void printOnMouseMove()
                         throws IOException
属性onMouseMoveを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseOut

protected void printOnMouseOut()
                        throws IOException
属性onMouseOutを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyPress

protected void printOnKeyPress()
                        throws IOException
属性onKeyPressを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyDown

protected void printOnKeyDown()
                       throws IOException
属性onKeyDownを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyUp

protected void printOnKeyUp()
                     throws IOException
属性onKeyUpを出力します。

例外:
IOException - 出力中に例外が発生

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GenericAttributes (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス GenericAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
直系の既知のサブクラス:
CoreAttributes, EventsAttributes, I18nAttributes
public abstract class GenericAttributes
extends Object

汎用属性の集合です。

バージョン:
1.0

コンストラクタの概要
GenericAttributes()
GenericAttributesを新規に生成します。
メソッドの概要
TagWriter | getTagWriter() TagWriterを取得します。
abstract void | printAttributes() 属性の内容を表示します。
void | setTagWriter(TagWriter writer) TagWriterを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericAttributes

public GenericAttributes()
GenericAttributesを新規に生成します。

メソッドの詳細

getTagWriter

public TagWriter getTagWriter()
TagWriterを取得します。

戻り値:
TagWriter

setTagWriter

public void setTagWriter(TagWriter writer)
TagWriterを設定します。

パラメータ:
writer - TagWriter

printAttributes

public abstract void printAttributes()
                              throws IOException
属性の内容を表示します。

例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


I18nAttributes (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス I18nAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
public class I18nAttributes
extends GenericAttributes

国際化の属性です。

バージョン:
1.0

コンストラクタの概要
I18nAttributes()
I18nAttributesを新規に生成します。
メソッドの概要
String | getDir() 属性dirの値を取得します。
String | getLang() 属性langの値を取得します。
void | printAttributes() 属性の内容を表示します。
void | setDir(String dir) 属性dirの値を取得します。
void | setLang(String lang) 属性langの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

I18nAttributes

public I18nAttributes()
I18nAttributesを新規に生成します。

メソッドの詳細

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を取得します。

パラメータ:
dir - dir

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.tag.attribute (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.web.tag.attribute
クラス
CoreAttributes
EventsAttributes
GenericAttributes
I18nAttributes


jp.co.intra_mart.framework.base.web.tag.attribute (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute

タグ属性のパッケージです。

参照:
説明

クラスの概要
CoreAttributes | コア属性です。
EventsAttributes | ブラウザのイベントに関連するタグの属性情報です。
GenericAttributes | 汎用属性の集合です。
I18nAttributes | 国際化の属性です。

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の説明

タグ属性のパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.web.tag.attribute クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.tag.attribute の使用

jp.co.intra_mart.framework.base.web.tag.attribute を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute により使用される jp.co.intra_mart.framework.base.web.tag.attribute のクラス
GenericAttributes
汎用属性の集合です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTag の使用

jp.co.intra_mart.framework.base.web.tag.FormTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FormTEI の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTEI の使用

jp.co.intra_mart.framework.base.web.tag.FormTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTag の使用

jp.co.intra_mart.framework.base.web.tag.FrameTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameTEI の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTEI の使用

jp.co.intra_mart.framework.base.web.tag.FrameTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameworkTagException の使用

jp.co.intra_mart.framework.base.web.tag.FrameworkTagException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam の使用

jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTag の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTag の使用

jp.co.intra_mart.framework.base.web.tag.LinkTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.LinkTEI の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTEI の使用

jp.co.intra_mart.framework.base.web.tag.LinkTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageParamTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageParamTag の使用

jp.co.intra_mart.framework.base.web.tag.MessageParamTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageTag の使用

jp.co.intra_mart.framework.base.web.tag.MessageTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.MessageTEI の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageTEI の使用

jp.co.intra_mart.framework.base.web.tag.MessageTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.base.web.tag.ParameterSendable の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.web.tag.ParameterSendable の使用

ParameterSendable を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag J2EEフレームワークで使用する各種のタグのパッケージです。

jp.co.intra_mart.framework.base.web.tag での ParameterSendable の使用

ParameterSendable を実装している jp.co.intra_mart.framework.base.web.tag のクラス
class | FrameTag FRAMEタグです。
class | LinkTag LINKタグです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.ParamTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.ParamTag の使用

jp.co.intra_mart.framework.base.web.tag.ParamTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag の使用

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTag の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTEI の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTEI の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.web.tag.TagWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.TagWriter の使用

TagWriter を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute での TagWriter の使用

TagWriter を返す jp.co.intra_mart.framework.base.web.tag.attribute のメソッド
 TagWriter GenericAttributes.getTagWriter()
TagWriterを取得します。

TagWriter 型のパラメータを持つ jp.co.intra_mart.framework.base.web.tag.attribute のメソッド
 void GenericAttributes.setTagWriter(TagWriter writer)
TagWriterを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


FormTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.FormTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class FormTag
extends BodyTagSupport

FORMタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
FormTag()
FormTagを新規に生成します。
メソッドの概要
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccept() 属性acceptの値を取得します。
String | getAcceptcharset() 属性accept-charsetの値を取得します。
String | getApplication() 属性applicationの値を取得します。
String | getDir() 属性dirの値を取得します。
String | getEnctype() 属性enctypeの値を取得します。
String | getFormclass() 属性classの値を取得します。
String | getLang() 属性langの値を取得します。
String | getMethod() 属性methodの値を取得します。
String | getName() 属性nameの値を取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getOnreset() 属性onResetの値を取得します。
String | getOnsubmit() 属性onSubmitの値を取得します。
String | getService() 属性serviceの値を取得します。
String | getStyle() 属性styleの値を取得します。
String | getTarget() 属性targetの値を取得します。
String | getTitle() 属性titleの値を取得します。
void | setAccept(String accept) 属性acceptの値を設定します。
void | setAcceptcharset(String acceptCharset) 属性accept-charsetの値を設定します。
void | setApplication(String application) 属性applicationの値を設定します。
void | setDir(String dir) 属性dirの値を設定します。
void | setEnctype(String enctype) 属性enctypeの値を設定します。
void | setFormclass(String formClass) 属性classの値を設定します。
void | setLang(String lang) 属性langの値を設定します。
void | setMethod(String method) 属性methodの値を設定します。
void | setName(String name) 属性nameの値を設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setOnreset(String onReset) 属性onResetの値を設定します。
void | setOnsubmit(String onSubmit) 属性onSubmitの値を設定します。
void | setService(String service) 属性serviceの値を設定します。
void | setStyle(String style) 属性styleの値を設定します。
void | setTarget(String target) 属性targetの値を設定します。
void | setTitle(String title) 属性titleの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

FormTag

public FormTag()
FormTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 FORMタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 FORMタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

getApplication

public String getApplication()
属性applicationの値を取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
属性applicationの値を設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
属性serviceの値を取得します。

戻り値:
サービス

setService

public void setService(String service)
属性serviceの値を設定します。

パラメータ:
service - サービス

getMethod

public String getMethod()
属性methodの値を取得します。

戻り値:
method

setMethod

public void setMethod(String method)
属性methodの値を設定します。

パラメータ:
method - method

getEnctype

public String getEnctype()
属性enctypeの値を取得します。

戻り値:
enctype

getTarget

public String getTarget()
属性targetの値を取得します。

戻り値:
target

setTarget

public void setTarget(String target)
属性targetの値を設定します。

パラメータ:
target - target

setEnctype

public void setEnctype(String enctype)
属性enctypeの値を設定します。

パラメータ:
enctype - enctype

getAccept

public String getAccept()
属性acceptの値を取得します。

戻り値:
accept

setAccept

public void setAccept(String accept)
属性acceptの値を設定します。

パラメータ:
accept - accept

getName

public String getName()
属性nameの値を取得します。

戻り値:
name

setName

public void setName(String name)
属性nameの値を設定します。

パラメータ:
name - name

getOnsubmit

public String getOnsubmit()
属性onSubmitの値を取得します。

戻り値:
onSubmit

setOnsubmit

public void setOnsubmit(String onSubmit)
属性onSubmitの値を設定します。

パラメータ:
onSubmit - onSubmit

getOnreset

public String getOnreset()
属性onResetの値を取得します。

戻り値:
onReset

setOnreset

public void setOnreset(String onReset)
属性onResetの値を設定します。

パラメータ:
onReset - onReset

getAcceptcharset

public String getAcceptcharset()
属性accept-charsetの値を取得します。

戻り値:
accept-charset

setAcceptcharset

public void setAcceptcharset(String acceptCharset)
属性accept-charsetの値を設定します。

パラメータ:
acceptCharset - accept-charset

getFormclass

public String getFormclass()
属性classの値を取得します。

戻り値:
class

setFormclass

public void setFormclass(String formClass)
属性classの値を設定します。

パラメータ:
formClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FormTagBeanInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class FormTagBeanInfo
extends SimpleBeanInfo

FormTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
FormTagBeanInfo()
FormTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FormTagBeanInfo

public FormTagBeanInfo()
FormTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FormTEI (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FormTEI
public class FormTEI
extends TagExtraInfo

Formタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
FormTEI()
FormTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Formタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FormTEI

public FormTEI()
FormTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Formタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはformclass属性がある場合、いずれかのみが設定されている
  • acceptcharset属性またはaccept-charset属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.FrameTag
すべての実装インタフェース:
BodyTag, IterationTag, ParameterSendable, Serializable, Tag
public class FrameTag
extends BodyTagSupport
implements ParameterSendable

FRAMEタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
FrameTag()
FrameTagを新規に生成します。
メソッドの概要
void | addParameter(String name, String value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() アプリケーションを取得します。
String | getFrameborder() frameborderを取得します。
String | getFrameclass() frameClassを取得します。
String | getFrameClass() 推奨されていません。 このメソッドではなくgetFrameclass()メソッドを使用してください。
String | getLongdesc() longdescを取得します。
String | getMarginheight() marginheightを取得します。
String | getMarginwidth() marginwidthを取得します。
String | getName() nameを取得します。
String | getNoresize() noresizeを取得します。
String | getScrolling() scrollingを取得します。
String | getService() サービスを取得します。
String | getStyle() styleを取得します。
String | getTitle() titleを取得します。
void | setApplication(String application) アプリケーションを設定します。
void | setFrameborder(String frameborder) frameborderを設定します。
void | setFrameclass(String frameClass) frameClassを設定します。
void | setFrameClass(String frameClass) 推奨されていません。 このメソッドではなくsetFrameclass(String)メソッドを使用してください。
void | setLongdesc(String longdesc) longdescを設定します。
void | setMarginheight(String marginheight) marginheightを設定します。
void | setMarginwidth(String marginwidth) marginwidthを設定します。
void | setName(String name) nameを設定します。
void | setNoresize(String noresize) noresizeを設定します。
void | setScrolling(String scrolling) scrollingを設定します。
void | setService(String service) serviceを設定します。
void | setStyle(String style) styleを設定します。
void | setTitle(String title) titleを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

FrameTag

public FrameTag()
FrameTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 FRAMEタグを解釈します。

定義:
インタフェース Tag 内の doStartTag
戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 FRAMEタグを終了します。

定義:
インタフェース Tag 内の doEndTag
戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

定義:
インタフェース ParameterSendable 内の addParameter
パラメータ:
name - パラメータ名
value - パラメータの値

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
serviceを設定します。

パラメータ:
service - サービス

getLongdesc

public String getLongdesc()
longdescを取得します。

戻り値:
longdesc

setLongdesc

public void setLongdesc(String longdesc)
longdescを設定します。

パラメータ:
longdesc - longdesc

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getFrameborder

public String getFrameborder()
frameborderを取得します。

戻り値:
frameborder

setFrameborder

public void setFrameborder(String frameborder)
frameborderを設定します。

パラメータ:
frameborder - frameborder

getMarginwidth

public String getMarginwidth()
marginwidthを取得します。

戻り値:
marginwidth

setMarginwidth

public void setMarginwidth(String marginwidth)
marginwidthを設定します。

パラメータ:
marginwidth - marginwidth

getMarginheight

public String getMarginheight()
marginheightを取得します。

戻り値:
marginheight

setMarginheight

public void setMarginheight(String marginheight)
marginheightを設定します。

パラメータ:
marginheight - marginheight

getNoresize

public String getNoresize()
noresizeを取得します。

戻り値:
noresize

setNoresize

public void setNoresize(String noresize)
noresizeを設定します。

パラメータ:
noresize - noresize

getScrolling

public String getScrolling()
scrollingを取得します。

戻り値:
scrolling

setScrolling

public void setScrolling(String scrolling)
scrollingを設定します。

パラメータ:
scrolling - scrolling

getFrameClass

public String getFrameClass()
推奨されていません。 このメソッドではなくgetFrameclass()メソッドを使用してください。

frameClassを取得します。

戻り値:
frameClass

setFrameClass

public void setFrameClass(String frameClass)
推奨されていません。 このメソッドではなくsetFrameclass(String)メソッドを使用してください。

frameClassを設定します。

パラメータ:
frameClass - frameClass

getFrameclass

public String getFrameclass()
frameClassを取得します。

戻り値:
frameClass

setFrameclass

public void setFrameclass(String frameClass)
frameClassを設定します。

パラメータ:
frameClass - frameClass

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTagBeanInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class FrameTagBeanInfo
extends SimpleBeanInfo

FrameTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
FrameTagBeanInfo()
FrameTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameTagBeanInfo

public FrameTagBeanInfo()
FrameTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameTEI (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameTEI
public class FrameTEI
extends TagExtraInfo

Frameタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
FrameTEI()
FrameTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Frameタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameTEI

public FrameTEI()
FrameTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Frameタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはframeclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FrameworkTagException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameworkTagException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.jsp.JspException
                拡張 jp.co.intra_mart.framework.base.web.tag.FrameworkTagException
すべての実装インタフェース:
Serializable
public class FrameworkTagException
extends JspException

拡張タグの例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkTagException()
詳細メッセージを指定しないで FrameworkTagException を構築します。
FrameworkTagException(String msg)
指定された詳細メッセージを持つ FrameworkTagException を構築します。
FrameworkTagException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。
メソッドの概要
void | printStackTrace()
void | printStackTrace(PrintStream printStream)
void | printStackTrace(PrintWriter printWriter)
クラス javax.servlet.jsp.JspException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkTagException

public FrameworkTagException()
詳細メッセージを指定しないで FrameworkTagException を構築します。

FrameworkTagException

public FrameworkTagException(String msg)
指定された詳細メッセージを持つ FrameworkTagException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkTagException

public FrameworkTagException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外

FrameworkTagException

public FrameworkTagException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外
メソッドの詳細

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream printStream)

printStackTrace

public void printStackTrace(PrintWriter printWriter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FrameworkTagParam (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameworkTagParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
public class FrameworkTagParam
extends PropertyParam

タグに追加されるパラメータです。

バージョン:
1.0

コンストラクタの概要
FrameworkTagParam()
FrameworkTagParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameworkTagParam

public FrameworkTagParam()
FrameworkTagParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class HelperBeanTag
extends BodyTagSupport

HelperBeanタグです。

導入されたバージョン:
3.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
HelperBeanTag()
HelperBeanTagを新規に生成します。
メソッドの概要
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getHelperclass() クラス名を取得します。
void | setClass(String className) 推奨されていません。 このメソッドではなくsetHelperclass(java.lang.String)メソッドを使用してください。
void | setHelperclass(String helperclass) クラス名を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

HelperBeanTag

public HelperBeanTag()
HelperBeanTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 HelperBeanタグを解釈します。

戻り値:
SKIP_BODY
例外:
JspException - タグの解釈時に例外が発生

setClass

public void setClass(String className)
推奨されていません。 このメソッドではなくsetHelperclass(java.lang.String)メソッドを使用してください。

クラス名を設定します。

パラメータ:
className - クラス名

setHelperclass

public void setHelperclass(String helperclass)
クラス名を設定します。

パラメータ:
helperclass - クラス名
導入されたバージョン:
4.0

getHelperclass

public String getHelperclass()
クラス名を取得します。

戻り値:
クラス名
導入されたバージョン:
4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTagBeanInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class HelperBeanTagBeanInfo
extends SimpleBeanInfo

HelperBeanTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
HelperBeanTagBeanInfo()
HelperBeanTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBeanTagBeanInfo

public HelperBeanTagBeanInfo()
HelperBeanTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HelperBeanTEI (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
public class HelperBeanTEI
extends TagExtraInfo

HelperBeanタグの拡張情報です。

導入されたバージョン:
3.2

コンストラクタの概要
HelperBeanTEI()
HelperBeanTEIを新規に生成します。
メソッドの概要
VariableInfo[] | getVariableInfo(TagData tagData) スクリプティング変数に関連付けたHelperBeanの情報を取得します。
boolean | isValid(TagData tagData) HelperBeanタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBeanTEI

public HelperBeanTEI()
HelperBeanTEIを新規に生成します。

メソッドの詳細

getVariableInfo

public VariableInfo[] getVariableInfo(TagData tagData)
スクリプティング変数に関連付けたHelperBeanの情報を取得します。 属性idで指定された変数に属性class（またはhelperclass）で指定されたHelperBeanを割り当てます。

パラメータ:
tagData - タグデータ
戻り値:
スクリプティング変数の情報

isValid

public boolean isValid(TagData tagData)
HelperBeanタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはhelperclass属性のいずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
導入されたバージョン:
4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.LinkTag
すべての実装インタフェース:
BodyTag, IterationTag, ParameterSendable, Serializable, Tag
public class LinkTag
extends BodyTagSupport
implements ParameterSendable

LINKタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
LinkTag()
LinkTagを新規に生成します。
メソッドの概要
void | addParameter(String name, String value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccesskey() accesskeyを取得します。
String | getApplication() アプリケーションを取得します。
String | getCharset() charsetを取得します。
String | getCoords() coordsを取得します。
String | getDir() dirを取得します。
String | getHreflang() hreflangを取得します。
String | getLang() langを取得します。
String | getLinkclass() linkClassを取得します。
String | getLinkClass() 推奨されていません。 このメソッドではなくgetLinkclass()メソッドを使用してください。
String | getName() nameを取得します。
String | getOnblur() onblurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() onfocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getRel() relを取得します。
String | getRev() revを取得します。
String | getService() サービスを取得します。
String | getShape() shapeを取得します。
String | getStyle() styleを取得します。
String | getTabindex() tabindexを取得します。
String | getTarget() targetを取得します。
String | getTitle() titleを取得します。
String | getType() typeを取得します。
void | setAccesskey(String accesskey) accesskeyを設定します。
void | setApplication(String application) アプリケーションを設定します。
void | setCharset(String charset) charsetを設定します。
void | setCoords(String coords) coordsを設定します。
void | setDir(String dir) dirを設定します。
void | setHreflang(String hreflang) hreflangを設定します。
void | setLang(String lang) langを設定します。
void | setLinkclass(String linkClass) linkClassを設定します。
void | setLinkClass(String linkClass) 推奨されていません。 このメソッドではなくsetLinkclass(String)メソッドを使用してください。
void | setName(String name) nameを設定します。
void | setOnblur(String onblur) onblurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onfocus) onfocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setRel(String rel) relを設定します。
void | setRev(String rev) relを設定します。
void | setService(String service) serviceを設定します。
void | setShape(String shape) shapeを設定します。
void | setStyle(String style) styleを設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTarget(String target) targetを設定します。
void | setTitle(String title) titleを設定します。
void | setType(String type) typeを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

LinkTag

public LinkTag()
LinkTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 LINKタグを解釈します。

定義:
インタフェース Tag 内の doStartTag
戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 LINKタグを終了します。

定義:
インタフェース Tag 内の doEndTag
戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

定義:
インタフェース ParameterSendable 内の addParameter
パラメータ:
name - パラメータ名
value - パラメータの値

getCharset

public String getCharset()
charsetを取得します。

戻り値:
charset

setCharset

public void setCharset(String charset)
charsetを設定します。

パラメータ:
charset - charset

getType

public String getType()
typeを取得します。

戻り値:
type

setType

public void setType(String type)
typeを設定します。

パラメータ:
type - type

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
serviceを設定します。

パラメータ:
service - サービス

getHreflang

public String getHreflang()
hreflangを取得します。

戻り値:
hreflang

setHreflang

public void setHreflang(String hreflang)
hreflangを設定します。

パラメータ:
hreflang - hreflang

getRel

public String getRel()
relを取得します。

戻り値:
rel

setRel

public void setRel(String rel)
relを設定します。

パラメータ:
rel - rel

getRev

public String getRev()
revを取得します。

戻り値:
rev

setRev

public void setRev(String rev)
relを設定します。

パラメータ:
rev - rev

getAccesskey

public String getAccesskey()
accesskeyを取得します。

戻り値:
accesskey

setAccesskey

public void setAccesskey(String accesskey)
accesskeyを設定します。

パラメータ:
accesskey - accesskey

getShape

public String getShape()
shapeを取得します。

戻り値:
shape

setShape

public void setShape(String shape)
shapeを設定します。

パラメータ:
shape - shape

getCoords

public String getCoords()
coordsを取得します。

戻り値:
coords

setCoords

public void setCoords(String coords)
coordsを設定します。

パラメータ:
coords - coords

getTarget

public String getTarget()
targetを取得します。

戻り値:
target
導入されたバージョン:
3.2

setTarget

public void setTarget(String target)
targetを設定します。

パラメータ:
target - target
導入されたバージョン:
3.2

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
onfocusを取得します。

戻り値:
onfocus

setOnfocus

public void setOnfocus(String onfocus)
onfocusを設定します。

パラメータ:
onfocus - onfocus

getOnblur

public String getOnblur()
onblurを取得します。

戻り値:
onblur

setOnblur

public void setOnblur(String onblur)
onblurを設定します。

パラメータ:
onblur - onblur

getLinkClass

public String getLinkClass()
推奨されていません。 このメソッドではなくgetLinkclass()メソッドを使用してください。

linkClassを取得します。

戻り値:
linkClass

setLinkClass

public void setLinkClass(String linkClass)
推奨されていません。 このメソッドではなくsetLinkclass(String)メソッドを使用してください。

linkClassを設定します。

パラメータ:
linkClass - class

getLinkclass

public String getLinkclass()
linkClassを取得します。

戻り値:
linkClass

setLinkclass

public void setLinkclass(String linkClass)
linkClassを設定します。

パラメータ:
linkClass - class

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title

getLang

public String getLang()
langを取得します。

戻り値:
lang

setLang

public void setLang(String lang)
langを設定します。

パラメータ:
lang - lang

getDir

public String getDir()
dirを取得します。

戻り値:
dir

setDir

public void setDir(String dir)
dirを設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTagBeanInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class LinkTagBeanInfo
extends SimpleBeanInfo

LinkTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
LinkTagBeanInfo()
LinkTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkTagBeanInfo

public LinkTagBeanInfo()
LinkTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LinkTEI (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.LinkTEI
public class LinkTEI
extends TagExtraInfo

Linkタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
LinkTEI()
LinkTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkTEI

public LinkTEI()
LinkTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはlinkclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageParamTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageParamTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.MessageParamTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class MessageParamTag
extends BodyTagSupport

メッセージの生成で使用するパラメータを設定します。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
MessageParamTag()
ParamTagを新規に生成します。
メソッドの概要
int | doStartTag() 外側の一番近いMessageTagにパラメータを設定します。
Object | getValue() パラメータの値を取得します。
void | setValue(Object value) パラメータの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

MessageParamTag

public MessageParamTag()
ParamTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
外側の一番近いMessageTagにパラメータを設定します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getValue

public Object getValue()
パラメータの値を取得します。

戻り値:
パラメータの値

setValue

public void setValue(Object value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.MessageTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class MessageTag
extends BodyTagSupport

Messageタグです。 im-J2EE Frameworkを使用する場合のMessageフレームワークの一部となります。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
MessageTag()
MessageTagを新規に生成します。
メソッドの概要
void | addParameter(Object value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() applicationを取得します。
String | getKey() keyを取得します。
String | getLocale() localeを取得します。
void | setApplication(String application) applicationを設定します。
void | setKey(String key) keyを設定します。
void | setLocale(String locale) localeを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

MessageTag

public MessageTag()
MessageTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 Messageタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 Messageタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(Object value)
パラメータを追加します。

パラメータ:
value - パラメータの値

getApplication

public String getApplication()
applicationを取得します。

戻り値:
application

setApplication

public void setApplication(String application)
applicationを設定します。

パラメータ:
application - application

getKey

public String getKey()
keyを取得します。

戻り値:
key

setKey

public void setKey(String key)
keyを設定します。

パラメータ:
key - key

getLocale

public String getLocale()
localeを取得します。

戻り値:
locale

setLocale

public void setLocale(String locale)
localeを設定します。

パラメータ:
locale - locale
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageTEI (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.MessageTEI
public class MessageTEI
extends TagExtraInfo

Messageタグの拡張情報です。

導入されたバージョン:
4.2

コンストラクタの概要
MessageTEI()
メソッドの概要
 boolean isValid(TagData tagData)
Messageタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MessageTEI

public MessageTEI()
メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Messageタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • locale属性が指定されている場合、書式が言語_国[_バリアント]となっていること
    ロケール文字列のアンダーバー(_)はハイフン(-)であってもかまいません。
locale属性が指定されていない場合、trueが返されます。

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.tag (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.web.tag
インタフェース
ParameterSendable
クラス
FormTag
FormTagBeanInfo
FormTEI
FrameTag
FrameTagBeanInfo
FrameTEI
FrameworkTagParam
HelperBeanTag
HelperBeanTagBeanInfo
HelperBeanTEI
LinkTag
LinkTagBeanInfo
LinkTEI
MessageParamTag
MessageTag
MessageTEI
ParamTag
SubmitLinkTag
SubmitLinkTagBeanInfo
SubmitTag
SubmitTagBeanInfo
SubmitTEI
TagWriter
例外
FrameworkTagException


jp.co.intra_mart.framework.base.web.tag (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag

J2EEフレームワークで使用する各種のタグのパッケージです。

参照:
説明

インタフェースの概要
ParameterSendable パラメータを渡すことができるタグです。

クラスの概要
FormTag | FORMタグです。
FormTagBeanInfo | FormTagのBeanInfoです。
FormTEI | Formタグの拡張情報です。
FrameTag | FRAMEタグです。
FrameTagBeanInfo | FrameTagのBeanInfoです。
FrameTEI | Frameタグの拡張情報です。
FrameworkTagParam | タグに追加されるパラメータです。
HelperBeanTag | HelperBeanタグです。
HelperBeanTagBeanInfo | HelperBeanTagのBeanInfoです。
HelperBeanTEI | HelperBeanタグの拡張情報です。
LinkTag | LINKタグです。
LinkTagBeanInfo | LinkTagのBeanInfoです。
LinkTEI | Linkタグの拡張情報です。
MessageParamTag | メッセージの生成で使用するパラメータを設定します。
MessageTag | Messageタグです。
MessageTEI | Messageタグの拡張情報です。
ParamTag | リンク先、遷移先に渡すパラメータを設定します。
SubmitLinkTag | サブミット専用のLINKタグです。
SubmitLinkTagBeanInfo | SubmitLinkTagのBeanInfoです。
SubmitTag | Submitタグです。
SubmitTagBeanInfo | SubmitTagのBeanInfoです。
SubmitTEI | Submitタグの拡張情報です。
TagWriter | タグの出力を行います。

例外の概要
FrameworkTagException 拡張タグの例外です。

パッケージ jp.co.intra_mart.framework.base.web.tag の説明

J2EEフレームワークで使用する各種のタグのパッケージです。 セッション情報を保ったまま画面遷移することが可能になります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.web.tag クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
    • class java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
      • class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
    • class javax.servlet.jsp.tagext.TagExtraInfo
      • class jp.co.intra_mart.framework.base.web.tag.FormTEI
      • class jp.co.intra_mart.framework.base.web.tag.FrameTEI
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
      • class jp.co.intra_mart.framework.base.web.tag.LinkTEI
      • class jp.co.intra_mart.framework.base.web.tag.MessageTEI
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTEI
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • class jp.co.intra_mart.framework.base.web.tag.FormTag
        • class jp.co.intra_mart.framework.base.web.tag.FrameTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
        • class jp.co.intra_mart.framework.base.web.tag.LinkTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.MessageParamTag
        • class jp.co.intra_mart.framework.base.web.tag.MessageTag
        • class jp.co.intra_mart.framework.base.web.tag.ParamTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitTag
    • class jp.co.intra_mart.framework.base.web.tag.TagWriter
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.jsp.JspException
          • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException

インタフェース階層

  • interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.web.tag の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.tag の使用

jp.co.intra_mart.framework.base.web.tag を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute | タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag により使用される jp.co.intra_mart.framework.base.web.tag のクラス
ParameterSendable
パラメータを渡すことができるタグです。

jp.co.intra_mart.framework.base.web.tag.attribute により使用される jp.co.intra_mart.framework.base.web.tag のクラス
TagWriter
タグの出力を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ParameterSendable (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
インタフェース ParameterSendable

既知の実装クラスの一覧:
FrameTag, LinkTag
public interface ParameterSendable

パラメータを渡すことができるタグです。

バージョン:
1.0

メソッドの概要
 void addParameter(String name, String value)
パラメータを追加します。

メソッドの詳細

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

パラメータ:
name - パラメータ名
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ParamTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス ParamTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.ParamTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class ParamTag
extends BodyTagSupport

リンク先、遷移先に渡すパラメータを設定します。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
ParamTag()
ParamTagを新規に生成します。
メソッドの概要
int | doStartTag() 外側の一番近いParameterSendableにパラメータを設定します。
String | getName() パラメータ名を取得します。
String | getValue() パラメータの値を取得します。
void | setName(String name) パラメータ名を設定します。
void | setValue(String value) パラメータの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

ParamTag

public ParamTag()
ParamTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
外側の一番近いParameterSendableにパラメータを設定します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getName

public String getName()
パラメータ名を取得します。

戻り値:
パラメータ名

setName

public void setName(String name)
パラメータ名を設定します。

パラメータ:
name - パラメータ名

getValue

public String getValue()
パラメータの値を取得します。

戻り値:
パラメータの値

setValue

public void setValue(String value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitLinkTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitLinkTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class SubmitLinkTag
extends BodyTagSupport

サブミット専用のLINKタグです。 im-J2EE Frameworkを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
SubmitLinkTag()
SubmitLinkTagを新規に生成します。
メソッドの概要
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccesskey() accesskeyを取得します。
String | getApplication() アプリケーションを取得します。
String | getCoords() coordsを取得します。
String | getDir() dirを取得します。
String | getForm() ターゲットとなるフォーム名を取得します。
String | getLang() langを取得します。
String | getLinkclass() linkClassを取得します。
String | getName() nameを取得します。
String | getOnblur() onblurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() onfocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getService() サービスを取得します。
String | getShape() shapeを取得します。
String | getStyle() styleを取得します。
String | getTabindex() tabindexを取得します。
String | getTitle() titleを取得します。
void | setAccesskey(String accesskey) accesskeyを設定します。
void | setApplication(String application) アプリケーションを設定します。
void | setCoords(String coords) coordsを設定します。
void | setDir(String dir) dirを設定します。
void | setForm(String form) ターゲットとなるフォーム名を設定します。
void | setLang(String lang) langを設定します。
void | setLinkclass(String linkClass) linkClassを設定します。
void | setName(String name) nameを設定します。
void | setOnblur(String onblur) onblurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onfocus) onfocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setService(String service) サービスを設定します。
void | setShape(String shape) shapeを設定します。
void | setStyle(String style) styleを設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTitle(String title) titleを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

SubmitLinkTag

public SubmitLinkTag()
SubmitLinkTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 SUBMIT LINKタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 SUBMIT LINKタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
サービスを設定します。

パラメータ:
service - サービス

getForm

public String getForm()
ターゲットとなるフォーム名を取得します。

戻り値:
ターゲットとなるフォーム名

setForm

public void setForm(String form)
ターゲットとなるフォーム名を設定します。

パラメータ:
form - ターゲットとなるフォーム名

getAccesskey

public String getAccesskey()
accesskeyを取得します。

戻り値:
accesskey

setAccesskey

public void setAccesskey(String accesskey)
accesskeyを設定します。

パラメータ:
accesskey - accesskey

getShape

public String getShape()
shapeを取得します。

戻り値:
shape

setShape

public void setShape(String shape)
shapeを設定します。

パラメータ:
shape - shape

getCoords

public String getCoords()
coordsを取得します。

戻り値:
coords

setCoords

public void setCoords(String coords)
coordsを設定します。

パラメータ:
coords - coords

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
onfocusを取得します。

戻り値:
onfocus

setOnfocus

public void setOnfocus(String onfocus)
onfocusを設定します。

パラメータ:
onfocus - onfocus

getOnblur

public String getOnblur()
onblurを取得します。

戻り値:
onblur

setOnblur

public void setOnblur(String onblur)
onblurを設定します。

パラメータ:
onblur - onblur

getLinkclass

public String getLinkclass()
linkClassを取得します。

戻り値:
linkClass

setLinkclass

public void setLinkclass(String linkClass)
linkClassを設定します。

パラメータ:
linkClass - class

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title

getLang

public String getLang()
langを取得します。

戻り値:
lang

setLang

public void setLang(String lang)
langを設定します。

パラメータ:
lang - lang

getDir

public String getDir()
dirを取得します。

戻り値:
dir

setDir

public void setDir(String dir)
dirを設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitLinkTagBeanInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitLinkTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class SubmitLinkTagBeanInfo
extends SimpleBeanInfo

SubmitLinkTagのBeanInfoです。

導入されたバージョン:
4.2

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
SubmitLinkTagBeanInfo()
SubmitLinkTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitLinkTagBeanInfo

public SubmitLinkTagBeanInfo()
SubmitLinkTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTag (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class SubmitTag
extends BodyTagSupport

Submitタグです。 intra-martフレームワークのFormタグ内でのみ使用できるタグです。

導入されたバージョン:
3.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
SubmitTag()
SubmitTagを新規に生成します。
メソッドの概要
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() 属性applicationの値を取得します。
String | getDir() 属性dirの値を取得します。
String | getLang() 属性langの値を取得します。
String | getName() 属性nameを取得します。
String | getOnblur() 属性onBlurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() 属性onFocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getService() 属性serviceの値を取得します。
String | getStyle() 属性styleの値を取得します。
String | getSubmitclass() 属性classの値を取得します。
String | getTabindex() tabindexを取得します。
String | getTitle() 属性titleの値を取得します。
String | getValue() 属性valueを取得します。
void | setApplication(String application) 属性applicationの値を設定します。
void | setDir(String dir) 属性dirの値を設定します。
void | setLang(String lang) 属性langの値を設定します。
void | setName(String name) 属性nameを設定します。
void | setOnblur(String onBlur) 属性onBlurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onFocus) 属性onFocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setService(String service) 属性serviceの値を設定します。
void | setStyle(String style) 属性styleの値を設定します。
void | setSubmitclass(String submitClass) 属性classの値を設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTitle(String title) 属性titleの値を設定します。
void | setValue(String value) 属性valueを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

SubmitTag

public SubmitTag()
SubmitTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 Submitタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getApplication

public String getApplication()
属性applicationの値を取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
属性applicationの値を設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
属性serviceの値を取得します。

戻り値:
サービス

setService

public void setService(String service)
属性serviceの値を設定します。

パラメータ:
service - サービス

getName

public String getName()
属性nameを取得します。

戻り値:
name

setName

public void setName(String name)
属性nameを設定します。

パラメータ:
name - name

getValue

public String getValue()
属性valueを取得します。

戻り値:
value

setValue

public void setValue(String value)
属性valueを設定します。

パラメータ:
value - value

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
属性onFocusを取得します。

戻り値:
onFocus

setOnfocus

public void setOnfocus(String onFocus)
属性onFocusを設定します。

パラメータ:
onFocus - onFocus

getOnblur

public String getOnblur()
属性onBlurを取得します。

戻り値:
onBlur

setOnblur

public void setOnblur(String onBlur)
属性onBlurを設定します。

パラメータ:
onBlur - onBlur

getSubmitclass

public String getSubmitclass()
属性classの値を取得します。

戻り値:
class

setSubmitclass

public void setSubmitclass(String submitClass)
属性classの値を設定します。

パラメータ:
submitClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTagBeanInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class SubmitTagBeanInfo
extends SimpleBeanInfo

SubmitTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
SubmitTagBeanInfo()
SubmitTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitTagBeanInfo

public SubmitTagBeanInfo()
SubmitTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SubmitTEI (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTEI
public class SubmitTEI
extends TagExtraInfo

Submitタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
SubmitTEI()
SubmitTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitTEI

public SubmitTEI()
SubmitTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはsubmitclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TagWriter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス TagWriter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.TagWriter
public class TagWriter
extends Object

タグの出力を行います。

バージョン:
1.0

コンストラクタの概要
TagWriter(JspWriter writer)
TagWriterを新規に生成します。
メソッドの概要
static String | createURL(String url, Collection params) 推奨されていません。 このメソッドではなくcreateURL(String, Collection, String)を使用してください。
static String | createURL(String url, Collection params, String encoding) 複数のパラメータをURLに追加します。
void | printAttribute(String name, String value) 属性を出力します。
void | printURL(String url) URLを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TagWriter

public TagWriter(JspWriter writer)
TagWriterを新規に生成します。

パラメータ:
writer - JSP出力子
メソッドの詳細

createURL

public static String createURL(String url,
                               Collection params)
                        throws IOException
推奨されていません。 このメソッドではなくcreateURL(String, Collection, String)を使用してください。

複数のパラメータをURLに追加します。 paramsはFrameworkTagParamの集合（java.util.Collection）である必要があります。

パラメータ:
url - 元のURL
params - 追加するパラメータ
戻り値:
パラメータが追加されたURL
例外:
IOException - 出力時に例外が発生

createURL

public static String createURL(String url,
                               Collection params,
                               String encoding)
                        throws IOException
複数のパラメータをURLに追加します。 paramsはFrameworkTagParamの集合（java.util.Collection）である必要があります。

パラメータ:
url - 元のURL
params - 追加するパラメータ
encoding - エンコーディング
戻り値:
パラメータが追加されたURL
例外:
IOException - 出力時に例外が発生
導入されたバージョン:
4.3

printURL

public void printURL(String url)
              throws IOException
URLを出力します。 このurlは<FORM>タグのaction属性、<A>タグのhref属性、<FRAME>タグのsrc属性などに定義するものと同じです。

パラメータ:
url - 出力するURL
例外:
IOException - 出力時に例外が発生

printAttribute

public void printAttribute(String name,
                           String value)
                    throws IOException
属性を出力します。 タグの属性として属性名="属性値"の形式で出力します。 属性値がnullまたは空文字列である場合、何も出力しません。

パラメータ:
name - 属性名
value - 属性値
例外:
IOException - 出力時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.base.web.util.HTMLEncoder の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.util.HTMLEncoder の使用

jp.co.intra_mart.framework.base.web.util.HTMLEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


HTMLEncoder (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.util
クラス HTMLEncoder

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.util.HTMLEncoder
public class HTMLEncoder
extends Object

文字列をHTML形式で表示するための変換を行うユーティリティクラスです。

バージョン:
1.0

コンストラクタの概要
HTMLEncoder()
メソッドの概要
static String | encodeCaption(String caption) キャプションを変換します。
static String | encodeValue(String value) <TEXTAREA>タグまたはvalue属性に入る文字列を変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTMLEncoder

public HTMLEncoder()
メソッドの詳細

encodeCaption

public static String encodeCaption(String caption)
キャプションを変換します。 HTML中で特殊な扱いを受ける文字（>,<等）を変換します。
ここでは以下の変換が行われます。
変換前 | 変換後
> &gt;
< &lt;
& &amp;
" &quot;
(半角空白) | &nbsp;
(改行)(*) | <BR>

(*)変換ルールは以下のとおりです。
"\n" -> "\n"
"\r" -> "\n"
ただし、"\r"と"\n"が連続して続く箇所は"\r\n" -> "\n"となります。

パラメータ:
caption - 変換前のキャプション
戻り値:
変換後のキャプション

encodeValue

public static String encodeValue(String value)
<TEXTAREA>タグまたはvalue属性に入る文字列を変換します。 ここでは以下の変換が行われます。
変換前 変換後
> &gt;
< &lt;
& &amp;
" &quot;

パラメータ:
value - 変換前の値
戻り値:
変換後の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.base.web.util (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.base.web.util
クラス
HTMLEncoder


jp.co.intra_mart.framework.base.web.util (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.util

Web上で使用するユーティリティのパッケージです。

参照:
説明

クラスの概要
HTMLEncoder 文字列をHTML形式で表示するための変換を行うユーティリティクラスです。

パッケージ jp.co.intra_mart.framework.base.web.util の説明

Web上で使用するユーティリティのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.base.web.util クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.util.HTMLEncoder
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.base.web.util の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.util の使用

jp.co.intra_mart.framework.base.web.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.common.util.ServiceUtils の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.common.util.ServiceUtils の使用

jp.co.intra_mart.framework.extension.common.util.ServiceUtils はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.common.util (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.extension.common.util
クラス
ServiceUtils


jp.co.intra_mart.framework.extension.common.util (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.common.util

im-J2EE Frameworkに連携するためのユーティリティです。

参照:
説明

クラスの概要
ServiceUtils im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。

パッケージ jp.co.intra_mart.framework.extension.common.util の説明

im-J2EE Frameworkに連携するためのユーティリティです。 im-J2EE Framework以外のコンポーネントからim-J2EE Frameworkにアクセスできます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.extension.common.util クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.common.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.common.util.ServiceUtils
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.extension.common.util の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.common.util の使用

jp.co.intra_mart.framework.extension.common.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ServiceUtils (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.common.util
クラス ServiceUtils

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.common.util.ServiceUtils
public class ServiceUtils
extends Object

im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。

コンストラクタの概要
ServiceUtils()
メソッドの概要
static Event createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
static EventResult dispatchEvent(Event event)
イベントを実行します。
static String getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static String getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static UserInfo getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceUtils

public ServiceUtils()
メソッドの詳細

getLoginUserID

public static String getLoginUserID(HttpServletRequest request,
                                    HttpServletResponse response)
                             throws SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログインユーザIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザID
例外:
SystemException - ログインユーザID取得時に例外が発生

getLoginGroupID

public static String getLoginGroupID(HttpServletRequest request,
                                     HttpServletResponse response)
                              throws SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログイングループIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログイングループID
例外:
SystemException - ログイングループID取得時に例外が発生

getUserInfo

public static UserInfo getUserInfo(HttpServletRequest request,
                                   HttpServletResponse response)
                            throws SystemException
ユーザ情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ユーザ情報
例外:
SystemException - ユーザ情報取得時に例外が発生

createEvent

public static Event createEvent(String application,
                                String key,
                                HttpServletRequest request,
                                HttpServletResponse response)
                         throws SystemException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
request - リクエスト
response - レスポンス
戻り値:
イベント
例外:
SystemException - イベント取得時に例外が発生

dispatchEvent

public static EventResult dispatchEvent(Event event)
                                 throws EventManagerException,
                                        EventException,
                                        ApplicationException,
                                        SystemException
イベントを実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - イベント処理時にシステム例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.struts.action.IntramartAction の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.struts.action.IntramartAction の使用

jp.co.intra_mart.framework.extension.struts.action.IntramartAction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter の使用

jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


IntramartAction (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.struts.action
クラス IntramartAction

java.lang.Object
    拡張 org.apache.struts.action.Action
        拡張 jp.co.intra_mart.framework.extension.struts.action.IntramartAction
public class IntramartAction
extends org.apache.struts.action.Action

ServiceControllerAdapterと似たメソッドを持つActionクラスです。 いくつかのメソッドはHttpServletRequestと HttpServletResponseを必要とする点が ServiceControllerAdapter と異なります。

関連項目:
ServiceControllerAdapter

フィールドの概要
クラス org.apache.struts.action.Action から継承したフィールド
ACTION_SERVLET_KEY, APPLICATION_KEY, DATA_SOURCE_KEY, defaultLocale, ERROR_KEY, EXCEPTION_KEY, FORM_BEANS_KEY, FORWARDS_KEY, LOCALE_KEY, MAPPING_KEY, MAPPINGS_KEY, MESSAGE_KEY, MESSAGES_KEY, MULTIPART_KEY, PLUG_INS_KEY, REQUEST_PROCESSOR_KEY, servlet, SERVLET_KEY, TRANSACTION_TOKEN_KEY
コンストラクタの概要
IntramartAction()
メソッドの概要
protected  Event createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
protected  EventResult dispatchEvent(Event event)
イベント処理を実行します。
protected  String getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  String getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  UserInfo getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
クラス org.apache.struts.action.Action から継承したメソッド
execute, execute, generateToken, getDataSource, getDataSource, getLocale, getResources, getResources, getResources, getServlet, isCancelled, isTokenValid, isTokenValid, perform, perform, resetToken, saveErrors, saveMessages, saveToken, setLocale, setServlet, toHex
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartAction

public IntramartAction()
メソッドの詳細

getLoginUserID

protected String getLoginUserID(HttpServletRequest request,
                                HttpServletResponse response)
                         throws SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログインユーザIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザID
例外:
SystemException - ログインユーザID取得時に例外が発生

getLoginGroupID

protected String getLoginGroupID(HttpServletRequest request,
                                 HttpServletResponse response)
                          throws SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログイングループIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログイングループID
例外:
SystemException - ログイングループID取得時に例外が発生

getUserInfo

protected UserInfo getUserInfo(HttpServletRequest request,
                               HttpServletResponse response)
                        throws SystemException
ユーザ情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ユーザ情報
例外:
SystemException - ユーザ情報取得時に例外が発生

createEvent

protected Event createEvent(String application,
                            String key,
                            HttpServletRequest request,
                            HttpServletResponse response)
                     throws SystemException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
request - リクエスト
response - レスポンス
戻り値:
イベント
例外:
SystemException - イベント取得時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.extension.struts.action (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.extension.struts.action
クラス
IntramartAction
StrutsConnectFilter


jp.co.intra_mart.framework.extension.struts.action (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.struts.action

im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

参照:
説明

クラスの概要
IntramartAction | ServiceControllerAdapterと似たメソッドを持つActionクラスです。
StrutsConnectFilter | intra-martのメニューからStrutsに接続するフィルターです。

パッケージ jp.co.intra_mart.framework.extension.struts.action の説明

im-J2EE FrameworkとStrutsを連携するためのユーティリティです。 Strutsからim-J2EE Frameworkにアクセスできます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.extension.struts.action クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.struts.action の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class org.apache.struts.action.Action
      • class jp.co.intra_mart.framework.extension.struts.action.IntramartAction
    • class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter (implements javax.servlet.Filter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.extension.struts.action の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.struts.action の使用

jp.co.intra_mart.framework.extension.struts.action はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StrutsConnectFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.struts.action
クラス StrutsConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter
すべての実装インタフェース:
Filter
public class StrutsConnectFilter
extends Object
implements Filter

intra-martのメニューからStrutsに接続するフィルターです。 Struts用のロケールをセッションに登録します。

コンストラクタの概要
StrutsConnectFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) ロケールをセッションに登録し、次のフィルタに処理を移します。
void | init(FilterConfig filterConfig) フィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StrutsConnectFilter

public StrutsConnectFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
フィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
ロケールをセッションに登録し、次のフィルタに処理を移します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.presentation.BadRequestException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.BadRequestException の使用

jp.co.intra_mart.framework.presentation.BadRequestException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.DuplicateException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.DuplicateException の使用

jp.co.intra_mart.framework.presentation.DuplicateException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.MismatchException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.MismatchException の使用

jp.co.intra_mart.framework.presentation.MismatchException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.NameFormatException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.NameFormatException の使用

jp.co.intra_mart.framework.presentation.NameFormatException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.PresentationConnectFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationConnectFilter の使用

jp.co.intra_mart.framework.presentation.PresentationConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.PresentationManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationManager の使用

PresentationManager を使用しているパッケージ
jp.co.intra_mart.framework.presentation Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.presentation での PresentationManager の使用

PresentationManager を返す jp.co.intra_mart.framework.presentation のメソッド
static PresentationManager PresentationManager.getManager()
PresentationManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.PresentationManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationManagerException の使用

PresentationManagerException を使用しているパッケージ
jp.co.intra_mart.framework.presentation Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.presentation での PresentationManagerException の使用

PresentationManagerException をスローする jp.co.intra_mart.framework.presentation のメソッド
static PresentationManager | PresentationManager.getManager() PresentationManagerを取得します。
abstract String | PresentationManager.createToken() 新しいトークンを取得します。
abstract void | PresentationManager.lockSession(String id) セッションをロックします。
abstract void | PresentationManager.unlockSession(String id) セッションのロックを解除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.PresentationPropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationPropertyException の使用

PresentationPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.presentation Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.presentation での PresentationPropertyException の使用

PresentationPropertyException をスローする jp.co.intra_mart.framework.presentation のメソッド
boolean | PresentationPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
jp.co.intra_mart.framework.presentation.property.Application | PresentationPropertyHandler.getApplication(String name) アプリケーションの情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.PresentationPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.PresentationPropertyHandler の使用

PresentationPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.presentation Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.presentation での PresentationPropertyHandler の使用

PresentationPropertyHandler を返す jp.co.intra_mart.framework.presentation のメソッド
abstract  PresentationPropertyHandler PresentationManager.getPresentationPropertyHandler()
PresentationPropertyHandlerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.PresentationServlet の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationServlet の使用

jp.co.intra_mart.framework.presentation.PresentationServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.RequestInfo の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.RequestInfo の使用

RequestInfo を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.presentation.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

jp.co.intra_mart.framework.presentation.forward での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.presentation.forward のメソッド
 String ForwardSelector.getForwardReference(RequestInfo info)
リクエスト情報から遷移先の参照を取得します。

jp.co.intra_mart.framework.presentation.service での RequestInfo の使用

RequestInfo を返す jp.co.intra_mart.framework.presentation.service のメソッド
 RequestInfo PresentationServiceController.getRequestInfo()
リクエスト情報を取得します。

jp.co.intra_mart.framework.presentation.validator での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.presentation.validator のメソッド
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

jp.co.intra_mart.framework.presentation.view での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
ViewObject | ViewConverter.convert(RequestInfo info) リクエスト情報をもとにビューオブジェクトを生成します。
protected Event | AbstractViewConverter.createEvent(RequestInfo info, String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
String | AbstractViewConverter.getLoginUserID(RequestInfo info) 推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
String | AbstractViewConverter.getLoginGroupID(RequestInfo info) 推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
UserInfo | AbstractViewConverter.getUserInfo(RequestInfo info) ログインユーザ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.TokenInvalidException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.TokenInvalidException の使用

jp.co.intra_mart.framework.presentation.TokenInvalidException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.controller.ControllerConverter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.controller.ControllerConverter の使用

ControllerConverter を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での ControllerConverter の使用

ControllerConverter を実装している jp.co.intra_mart.framework.presentation.controller のクラス
 class SimpleControllerConverter
リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig の使用

ControllerConverterConfig を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での ControllerConverterConfig の使用

ControllerConverterConfig 型のパラメータを持つ jp.co.intra_mart.framework.presentation.controller のメソッド
void | SimpleControllerConverter.init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
void | ControllerConverter.init(ControllerConverterConfig config) ControllerConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.controller.ControllerConverterException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.controller.ControllerConverterException の使用

ControllerConverterException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での ControllerConverterException の使用

ControllerConverterException をスローする jp.co.intra_mart.framework.presentation.controller のメソッド
void | SimpleControllerConverter.init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
void | ControllerConverter.init(ControllerConverterConfig config) ControllerConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.controller.ControllerObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.controller.ControllerObject の使用

ControllerObject を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation での ControllerObject の使用

ControllerObject を返す jp.co.intra_mart.framework.presentation のメソッド
 ControllerObject RequestInfo.getControllerObject()
リクエストから生成されたコントローラオブジェクトを取得します。

jp.co.intra_mart.framework.presentation.controller での ControllerObject の使用

ControllerObject を返す jp.co.intra_mart.framework.presentation.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.controller.RequestFormatException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.controller.RequestFormatException の使用

RequestFormatException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での RequestFormatException の使用

RequestFormatException をスローする jp.co.intra_mart.framework.presentation.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter の使用

jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ControllerConverter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
インタフェース ControllerConverter

既知の実装クラスの一覧:
SimpleControllerConverter
public interface ControllerConverter

リクエストをコントローラオブジェクトに変換します。 コントローラオブジェクトはリクエストの内容を入力情報として変換されたものです。 開発者はこのインタフェースを実装し、適切なコントローラオブジェクトを返すように convert(RequestInfo)メソッドを実装する 必要があります。

生成されるコントローラオブジェクトはJavaBeansTM の仕様に従う必要があります。

導入されたバージョン:
4.3

メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() ControllerConverterを破棄します。
void | init(ControllerConverterConfig config) ControllerConverterを初期化します。

メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
ControllerConverterを初期化します。

パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
ControllerConverterを破棄します。

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterConfig (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
インタフェース ControllerConverterConfig

public interface ControllerConverterConfig

ControllerConverterの初期化情報です。

導入されたバージョン:
4.3

メソッドの概要
String | getInitParameter(String name) ControllerConverterを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
ControllerConverterを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllerConverterException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
クラス ControllerConverterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.controller.ControllerConverterException
すべての実装インタフェース:
Serializable
public class ControllerConverterException
extends SystemException

ControllerConverterに関連する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ControllerConverterException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ControllerConverterException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ControllerConverterException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllerConverterException

public ControllerConverterException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。

ControllerConverterException

public ControllerConverterException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ

ControllerConverterException

public ControllerConverterException(String msg,
                                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ControllerObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
インタフェース ControllerObject

すべてのスーパーインタフェース:
Serializable
public interface ControllerObject
extends Serializable

コントローラオブジェクトのインタフェースです。 すべてのコントローラオブジェクトはこのインタフェースを実装する必要があります。 このインタフェースを実装するクラスはJavaBeansの仕様に沿っている必要があります。

導入されたバージョン:
4.3

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.presentation.controller (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.presentation.controller
インタフェース
ControllerConverter
ControllerConverterConfig
ControllerObject
クラス
SimpleControllerConverter
例外
ControllerConverterException
RequestFormatException


jp.co.intra_mart.framework.presentation.controller (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.controller

入力情報に関連するパッケージです。

参照:
説明

インタフェースの概要
ControllerConverter | リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig | ControllerConverterの初期化情報です。
ControllerObject | コントローラオブジェクトのインタフェースです。

クラスの概要
SimpleControllerConverter リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。

例外の概要
ControllerConverterException | ControllerConverterに関連する例外です。
RequestFormatException | フォーマットが不正であるときの例外です。

パッケージ jp.co.intra_mart.framework.presentation.controller の説明

入力情報に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.presentation.controller クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.controller の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter (implements jp.co.intra_mart.framework.presentation.controller.ControllerConverter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException
            • class jp.co.intra_mart.framework.presentation.controller.RequestFormatException

インタフェース階層

  • interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter
  • interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.presentation.controller.ControllerObject
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.presentation.controller の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.controller の使用

jp.co.intra_mart.framework.presentation.controller を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.presentation.controller のクラス
ControllerObject
コントローラオブジェクトのインタフェースです。

jp.co.intra_mart.framework.presentation.controller により使用される jp.co.intra_mart.framework.presentation.controller のクラス
ControllerConverter
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig
ControllerConverterの初期化情報です。
ControllerConverterException
ControllerConverterに関連する例外です。
ControllerObject
コントローラオブジェクトのインタフェースです。
RequestFormatException
フォーマットが不正であるときの例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RequestFormatException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
クラス RequestFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.controller.RequestFormatException
すべての実装インタフェース:
Serializable
public class RequestFormatException
extends SystemException

フォーマットが不正であるときの例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
RequestFormatException()
詳細メッセージを指定しないで RequestFormatException を構築します。
RequestFormatException(String msg)
指定された詳細メッセージを持つ RequestFormatException を構築します。
RequestFormatException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestFormatException

public RequestFormatException()
詳細メッセージを指定しないで RequestFormatException を構築します。

RequestFormatException

public RequestFormatException(String msg)
指定された詳細メッセージを持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ

RequestFormatException

public RequestFormatException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SimpleControllerConverter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
クラス SimpleControllerConverter

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter
すべての実装インタフェース:
ControllerConverter
public class SimpleControllerConverter
extends Object
implements ControllerConverter

リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。 ここではコントローラオブジェクトはJavaBeansとして扱われます。 リクエストのパラメータから取得される値をコントローラオブジェクトのプロパティに設定します。 ここで対応付けられるコントローラオブジェクトのプロパティはすべてStringである必要があります。 パラメータとプロパティの対応ルールは以下のとおりです。

  • リクエストのパラメータ名とコントローラオブジェクトのプロパティ名が一致するものが対応付けられる
  • ある名前に対してリクエストのパラメータが存在するがコントローラオブジェクトのプロパティが存在しない、 またはリクエストのパラメータは存在しないがコントローラオブジェクトのプロパティが存在する場合は何も行われない
  • リクエストのパラメータが同一のパラメータ名でただ1つの値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringまたはその配列）を持つ場合はそのメソッドが使用される
  • リクエストのパラメータが同一のパラメータ名でただ1つの値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持たない場合は インデックス付きのsetterメソッド（第1引数はint、第2引数はString）が使用される
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持つ場合はそのメソッドが使用される
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持たない場合は インデックス付きのsetterメソッド（第1引数はint、第2引数はString）が使用される （この場合設定される順番はリクエストのパラメータと同一となる）
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティにおいて複数の値を扱うsetterメソッドを持たない場合は インデックスなしのsetterメソッド（引数はString）が使用される （この場合リクエストのパラメータの最初の値のみが設定される）
  • コントローラオブジェクトが対応するプロパティのsetterメソッドを持たない場合何も行われない

導入されたバージョン:
4.3

フィールドの概要
static String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名
コンストラクタの概要
SimpleControllerConverter()
メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() SimpleControllerConverterを破棄します。
void | init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

OBJECT_PARAM_NAME

public static final String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

SimpleControllerConverter

public SimpleControllerConverter()
メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
SimpleControllerConverterを初期化します。

定義:
インタフェース ControllerConverter 内の init
パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
SimpleControllerConverterを破棄します。

定義:
インタフェース ControllerConverter 内の destroy

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

定義:
インタフェース ControllerConverter 内の convert
パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.framework.presentation.forward.ForwardSelector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.forward.ForwardSelector の使用

jp.co.intra_mart.framework.presentation.forward.ForwardSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig の使用

ForwardSelectorConfig を使用しているパッケージ
jp.co.intra_mart.framework.presentation.forward 遷移先の決定に関連するパッケージです。

jp.co.intra_mart.framework.presentation.forward での ForwardSelectorConfig の使用

ForwardSelectorConfig 型のパラメータを持つ jp.co.intra_mart.framework.presentation.forward のメソッド
 void ForwardSelector.init(ForwardSelectorConfig config)
ForwardSelectorを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException の使用

ForwardSelectorException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.forward 遷移先の決定に関連するパッケージです。

jp.co.intra_mart.framework.presentation.forward での ForwardSelectorException の使用

ForwardSelectorException をスローする jp.co.intra_mart.framework.presentation.forward のメソッド
 void ForwardSelector.init(ForwardSelectorConfig config)
ForwardSelectorを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ForwardSelector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.forward
インタフェース ForwardSelector

public interface ForwardSelector

遷移先の参照を決定するセレクタです。 すべてのセレクタはこのインタフェースを実装する必要があります。

導入されたバージョン:
4.3

メソッドの概要
void | destroy() ForwardSelectorを破棄します。
String | getForwardReference(RequestInfo info) リクエスト情報から遷移先の参照を取得します。
void | init(ForwardSelectorConfig config) ForwardSelectorを初期化します。

メソッドの詳細

init

public void init(ForwardSelectorConfig config)
          throws ForwardSelectorException
ForwardSelectorを初期化します。

パラメータ:
config - 初期化情報
例外:
ForwardSelectorException - 初期化時に例外が発生

destroy

public void destroy()
ForwardSelectorを破棄します。

getForwardReference

public String getForwardReference(RequestInfo info)
リクエスト情報から遷移先の参照を取得します。

パラメータ:
info - リクエスト情報
戻り値:
遷移先の参照
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ForwardSelectorConfig (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.forward
インタフェース ForwardSelectorConfig

public interface ForwardSelectorConfig

ForwardSelectorの初期化情報です。

導入されたバージョン:
4.3

メソッドの概要
String | getInitParameter(String name) ForwardSelectorを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
ForwardSelectorを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ForwardSelectorException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.forward
クラス ForwardSelectorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException
すべての実装インタフェース:
Serializable
public class ForwardSelectorException
extends SystemException

ForwardSelectorに関連する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ForwardSelectorException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ForwardSelectorException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ForwardSelectorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForwardSelectorException

public ForwardSelectorException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。

ForwardSelectorException

public ForwardSelectorException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ

ForwardSelectorException

public ForwardSelectorException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.presentation.forward (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.presentation.forward
インタフェース
ForwardSelector
ForwardSelectorConfig
例外
ForwardSelectorException


jp.co.intra_mart.framework.presentation.forward (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.forward

遷移先の決定に関連するパッケージです。

参照:
説明

インタフェースの概要
ForwardSelector | 遷移先の参照を決定するセレクタです。
ForwardSelectorConfig | ForwardSelectorの初期化情報です。

例外の概要
ForwardSelectorException ForwardSelectorに関連する例外です。

パッケージ jp.co.intra_mart.framework.presentation.forward の説明

遷移先の決定に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.presentation.forward クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.forward の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException

インタフェース階層

  • interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector
  • interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.presentation.forward の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.forward の使用

jp.co.intra_mart.framework.presentation.forward を使用しているパッケージ
jp.co.intra_mart.framework.presentation.forward 遷移先の決定に関連するパッケージです。

jp.co.intra_mart.framework.presentation.forward により使用される jp.co.intra_mart.framework.presentation.forward のクラス
ForwardSelectorConfig
ForwardSelectorの初期化情報です。
ForwardSelectorException
ForwardSelectorに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.service.PresentationServiceController の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.service.PresentationServiceController の使用

jp.co.intra_mart.framework.presentation.service.PresentationServiceController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.presentation.service (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.presentation.service
クラス
PresentationServiceController


jp.co.intra_mart.framework.presentation.service (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.service

サービスに関連するパッケージです。

参照:
説明

クラスの概要
PresentationServiceController Presentation Framework用のServiceControllerです。

パッケージ jp.co.intra_mart.framework.presentation.service の説明

サービスに関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.presentation.service クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
      • class jp.co.intra_mart.framework.presentation.service.PresentationServiceController
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.presentation.service の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.service の使用

jp.co.intra_mart.framework.presentation.service はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PresentationServiceController (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.service
クラス PresentationServiceController

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerAdapter
        拡張 jp.co.intra_mart.framework.presentation.service.PresentationServiceController
すべての実装インタフェース:
ServiceController
public class PresentationServiceController
extends ServiceControllerAdapter

Presentation Framework用のServiceControllerです。

導入されたバージョン:
4.3
関連項目:
ServiceController

コンストラクタの概要
PresentationServiceController()
メソッドの概要
 RequestInfo getRequestInfo()
リクエスト情報を取得します。
クラス jp.co.intra_mart.framework.base.service.ServiceControllerAdapter から継承したメソッド
check, createEvent, dispatchEvent, getEntity, getLoginGroupID, getLoginUserID, getRequest, getResponse, getUserInfo, service, setRequest, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationServiceController

public PresentationServiceController()
メソッドの詳細

getRequestInfo

public RequestInfo getRequestInfo()
リクエスト情報を取得します。

戻り値:
リクエスト情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.presentation.validator.FormatValidator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.FormatValidator の使用

jp.co.intra_mart.framework.presentation.validator.FormatValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.validator.LengthValidator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.LengthValidator の使用

jp.co.intra_mart.framework.presentation.validator.LengthValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の使用

jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.validator.NumericValidator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.NumericValidator の使用

jp.co.intra_mart.framework.presentation.validator.NumericValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.validator.ValidationException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.ValidationException の使用

jp.co.intra_mart.framework.presentation.validator.ValidationException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail の使用

ValidationExceptionDetail を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator での ValidationExceptionDetail の使用

ValidationExceptionDetail を返す jp.co.intra_mart.framework.presentation.validator のメソッド
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.validator.Validator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.validator.Validator の使用

Validator を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator での Validator の使用

Validator を実装している jp.co.intra_mart.framework.presentation.validator のクラス
class | FormatValidator 文字列の不正文字（フォーマット）チェックを行います。
class | LengthValidator 文字列の長さをチェックします。
class | NumericRangeValidator 数値の範囲をチェックします。
class | NumericValidator 数値（整数）として妥当であるかどうかをチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.validator.ValidatorConfig の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.validator.ValidatorConfig の使用

ValidatorConfig を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator での ValidatorConfig の使用

ValidatorConfig 型のパラメータを持つ jp.co.intra_mart.framework.presentation.validator のメソッド
void | Validator.init(ValidatorConfig config) Validatorを初期化します。
void | NumericValidator.init(ValidatorConfig config) NumericValidatorを初期化します。
void | NumericRangeValidator.init(ValidatorConfig config) NumericRangeValidatorを初期化します。
void | LengthValidator.init(ValidatorConfig config) LengthValidatorを初期化します。
void | FormatValidator.init(ValidatorConfig config) FormatValidatorを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.validator.ValidatorException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.ValidatorException の使用

ValidatorException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator での ValidatorException の使用

ValidatorException をスローする jp.co.intra_mart.framework.presentation.validator のメソッド
void | Validator.init(ValidatorConfig config) Validatorを初期化します。
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
void | NumericValidator.init(ValidatorConfig config) NumericValidatorを初期化します。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
void | NumericRangeValidator.init(ValidatorConfig config) NumericRangeValidatorを初期化します。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
void | LengthValidator.init(ValidatorConfig config) LengthValidatorを初期化します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
void | FormatValidator.init(ValidatorConfig config) FormatValidatorを初期化します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


FormatValidator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス FormatValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.FormatValidator
すべての実装インタフェース:
Validator
public class FormatValidator
extends Object
implements Validator

文字列の不正文字（フォーマット）チェックを行います。 このクラスではControllerObjectのプロパティが、指定された正規表現に一致しているかどうかを検証します。

検証対象となるプロパティ名と正規表現のフォーマットは初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、フォーマットはPARAM_REGEXで与えられる名前でそれぞれ指定します。 正規表現はString.matches(java.lang.String)の引数で指定できるものと同じです。

該当するプロパティの内容がnullだった場合、 そのプロパティには空文字列が設定されているものとみなされます。

プロパティが正規表現に一致しない場合、PARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。 このパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
4.3

フィールドの概要
static String | PARAM_MESSAGE 不正文字列である場合のメッセージが設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名
static String | PARAM_REGEX 正規表現によるフォーマットが設定されているパラメータ名
コンストラクタの概要
FormatValidator()
メソッドの概要
void | destroy() FormatValidatorを破棄します。
void | init(ValidatorConfig config) FormatValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名

関連項目:
定数フィールド値

PARAM_REGEX

public static final String PARAM_REGEX
正規表現によるフォーマットが設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
不正文字列である場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

FormatValidator

public FormatValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
FormatValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
FormatValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
文字列の不正文字（フォーマット）を検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LengthValidator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス LengthValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.LengthValidator
すべての実装インタフェース:
Validator
public class LengthValidator
extends Object
implements Validator

文字列の長さをチェックします。 このクラスではControllerObjectのプロパティの文字列長が、指定された範囲に含まれるかどうかを検証します。

検証対象となるプロパティ名と長さの範囲は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、長さの範囲はPARAM_MINとPARAM_MAXで与えられる名前でそれぞれ指定します。 文字列長の最小値と最大値で設定できる値は、ともに0以上の整数かつintの最大値以下です。 最大値と最小値のパラメータは0以上かつInteger.MAX_VALUE以下である必要があります。 該当するプロパティの内容がnullだった場合、 そのプロパティには空文字列が設定されているものとみなされます。

プロパティの文字列長が最小値に満たない場合、PARAM_MESSAGE_SHORTで与えられる名前のパラメータに設定されたメッセージが返されます。 プロパティの文字列長が最大値を超える場合、PARAM_MESSAGE_LONGで与えられる名前のパラメータに設定されたメッセージが返されます。 これらのパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
4.3

フィールドの概要
static String | PARAM_MAX 文字列長の最大値が設定されているパラメータ名
static String | PARAM_MESSAGE_LONG 文字列長が長い場合のメッセージが設定されているパラメータ名
static String | PARAM_MESSAGE_SHORT 文字列長が短い場合のメッセージが設定されているパラメータ名
static String | PARAM_MIN 文字列長の最小値が設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
LengthValidator()
メソッドの概要
void | destroy() LengthValidatorを破棄します。
void | init(ValidatorConfig config) LengthValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 文字列の長さを検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MIN

public static final String PARAM_MIN
文字列長の最小値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MAX

public static final String PARAM_MAX
文字列長の最大値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE_SHORT

public static final String PARAM_MESSAGE_SHORT
文字列長が短い場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE_LONG

public static final String PARAM_MESSAGE_LONG
文字列長が長い場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

LengthValidator

public LengthValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
LengthValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
LengthValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
文字列の長さを検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NumericRangeValidator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス NumericRangeValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator
すべての実装インタフェース:
Validator
public class NumericRangeValidator
extends Object
implements Validator

数値の範囲をチェックします。 このクラスではControllerObjectのプロパティの数値が、指定された範囲に含まれるかどうかを検証します。

検証対象となるプロパティ名と範囲は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、数値の範囲はPARAM_MINとPARAM_MAXで与えられる名前でそれぞれ指定します。 数値の最小値と最大値で設定できる値は、ともに整数のみです。

最小値が省略された場合、数値の下限はチェックされません。 最大値が省略された場合、数値の上限はチェックされません。

最大値と最小値はともにチェック対象の範囲に含まれます。

最大値と最小値のパラメータはLong.parseLong(java.lang.String)の引数に指定できるものである必要があります。

プロパティの値が次のいずれかに該当する場合、 PARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。

  • nullである
  • プロパティの数値が最小値に満たない
  • プロパティの数値が最大値を超える
  • プロパティがStringであり、その値がBigInteger.BigInteger(java.lang.String)の引数に指定できる値ではない
チェック対象のプロパティが以下のいずれかでもない場合、例外が返されます。
  • int
  • long
  • Integer
  • Long
  • BigInteger
  • String
チェック対象のプロパティが存在しない場合も、例外が返されます。

導入されたバージョン:
4.3

フィールドの概要
static String | PARAM_MAX 数値の最大値が設定されているパラメータ名
static String | PARAM_MESSAGE 数値が範囲外の場合のメッセージが設定されているパラメータ名
static String | PARAM_MIN 数値の最小値が設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
NumericRangeValidator()
メソッドの概要
void | destroy() NumericRangeValidatorを破棄します。
void | init(ValidatorConfig config) NumericRangeValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 数値の範囲を検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_MIN

public static final String PARAM_MIN
数値の最小値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MAX

public static final String PARAM_MAX
数値の最大値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
数値が範囲外の場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

NumericRangeValidator

public NumericRangeValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
NumericRangeValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
NumericRangeValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
数値の範囲を検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティが数値として正しくない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NumericValidator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス NumericValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.NumericValidator
すべての実装インタフェース:
Validator
public class NumericValidator
extends Object
implements Validator

数値（整数）として妥当であるかどうかをチェックします。 このクラスではControllerObjectのプロパティが整数として妥当であるかどうかを検証します。

検証対象となるプロパティ名は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで指定します。

プロパティの型が以下のものであれば無条件で整数であるとみなされます。

  • int
  • long
プロパティの型が以下のものであり、かつnullでなければ無条件で整数であるとみなされます。
  • Integer
  • Long
  • BigInteger
プロパティがStringである場合、以下の条件をすべて満たせば整数として妥当であるとみなされます。
  • nullではない
  • 先頭にはマイナス符号が1つだけ付いてもよい。
  • 以降は1つ以上の10進数字の列で構成される。
上記以外の場合、該当するプロパティは数値として妥当でないものとみなされます。 この場合、validate(RequestInfo)の戻り値であるValidationExceptionにはPARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。 このパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
4.3

フィールドの概要
static String | PARAM_MESSAGE 数値として妥当ではない場合のメッセージが設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
NumericValidator()
メソッドの概要
void | destroy() NumericValidatorを破棄します。
void | init(ValidatorConfig config) NumericValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 数値の検証をします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
数値として妥当ではない場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

NumericValidator

public NumericValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
NumericValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
NumericValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
数値の検証をします。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.presentation.validator (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.presentation.validator
インタフェース
Validator
ValidatorConfig
クラス
FormatValidator
LengthValidator
NumericRangeValidator
NumericValidator
ValidationExceptionDetail
例外
ValidationException
ValidatorException


jp.co.intra_mart.framework.presentation.validator (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.validator

検証に関連するパッケージです。

参照:
説明

インタフェースの概要
Validator | リクエスト内容の検証をします。
ValidatorConfig | Validatorの初期化情報です。

クラスの概要
FormatValidator | 文字列の不正文字（フォーマット）チェックを行います。
LengthValidator | 文字列の長さをチェックします。
NumericRangeValidator | 数値の範囲をチェックします。
NumericValidator | 数値（整数）として妥当であるかどうかをチェックします。
ValidationExceptionDetail | 検証結果の詳細情報です。

例外の概要
ValidationException | 検証結果が不正であるときの例外です。
ValidatorException | Validatorに関連する例外です。

パッケージ jp.co.intra_mart.framework.presentation.validator の説明

検証に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.presentation.validator クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.validator の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.presentation.validator.FormatValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.validator.LengthValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.validator.NumericValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.presentation.validator.ValidationException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.validator.ValidatorException
    • class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail

インタフェース階層

  • interface jp.co.intra_mart.framework.presentation.validator.Validator
  • interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.presentation.validator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.validator の使用

jp.co.intra_mart.framework.presentation.validator を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator により使用される jp.co.intra_mart.framework.presentation.validator のクラス
ValidationExceptionDetail
検証結果の詳細情報です。
Validator
リクエスト内容の検証をします。
ValidatorConfig
Validatorの初期化情報です。
ValidatorException
Validatorに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ValidationException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス ValidationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.presentation.validator.ValidationException
すべての実装インタフェース:
Serializable
public class ValidationException
extends ApplicationException

検証結果が不正であるときの例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ValidationException()
詳細メッセージを指定しないで ValidationException を構築します。
ValidationException(String msg)
指定された詳細メッセージを持つ ValidationException を構築します。
ValidationException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
メソッドの概要
String | getMessage() 例外メッセージを取得します。
Iterator | getValidationExceptionDetails() 検証結果の詳細の一覧を取得します。
void | setValidationExceptionDetails(Collection details) 検証結果の詳細を設定します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValidationException

public ValidationException()
詳細メッセージを指定しないで ValidationException を構築します。

ValidationException

public ValidationException(String msg)
指定された詳細メッセージを持つ ValidationException を構築します。

パラメータ:
msg - 詳細メッセージ

ValidationException

public ValidationException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
メソッドの詳細

setValidationExceptionDetails

public void setValidationExceptionDetails(Collection details)
検証結果の詳細を設定します。 detailsはValidationExceptionDetailのコレクションである必要があります。

パラメータ:
details - 検証結果の詳細

getValidationExceptionDetails

public Iterator getValidationExceptionDetails()
検証結果の詳細の一覧を取得します。 戻り値はValidationExceptionDetailのコレクションのIteratorです。

戻り値:
検証結果の詳細の一覧

getMessage

public String getMessage()
例外メッセージを取得します。 詳細情報を含んだ形式で例外情報が取得されます。

戻り値:
例外メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidationExceptionDetail (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス ValidationExceptionDetail

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail
public class ValidationExceptionDetail
extends Object

検証結果の詳細情報です。

導入されたバージョン:
4.3

コンストラクタの概要
ValidationExceptionDetail()
メッセージなしのValidatorExceptionDetailを生成します。
ValidationExceptionDetail(String message)
メッセージ付きのValidatorExceptionDetailを生成します。
メソッドの概要
void | addDetail(String detail) 検証結果の詳細を追加します。
Iterator | getDetails() 検証結果の詳細の一覧を取得します。
String | getMessage() 検証結果のメッセージを取得します。
void | setMessage(String message) 検証結果のメッセージを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ValidationExceptionDetail

public ValidationExceptionDetail()
メッセージなしのValidatorExceptionDetailを生成します。 この場合、メッセージとして空文字列が設定されたものとみなされます。

ValidationExceptionDetail

public ValidationExceptionDetail(String message)
メッセージ付きのValidatorExceptionDetailを生成します。

パラメータ:
message - メッセージ
メソッドの詳細

getMessage

public String getMessage()
検証結果のメッセージを取得します。

戻り値:
検証結果のメッセージ

setMessage

public void setMessage(String message)
検証結果のメッセージを設定します。

パラメータ:
message - 検証結果のメッセージ

addDetail

public void addDetail(String detail)
検証結果の詳細を追加します。

パラメータ:
detail - 検証結果の詳細

getDetails

public Iterator getDetails()
検証結果の詳細の一覧を取得します。 StringのCollectionのIteratorが返されます。

戻り値:
検証結果の詳細の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Validator (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
インタフェース Validator

既知の実装クラスの一覧:
FormatValidator, LengthValidator, NumericRangeValidator, NumericValidator
public interface Validator

リクエスト内容の検証をします。

導入されたバージョン:
4.3

メソッドの概要
void | destroy() Validatorを破棄します。
void | init(ValidatorConfig config) Validatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) リクエスト内容の検証をします。

メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
Validatorを初期化します。

パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
Validatorを破棄します。

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
リクエスト内容の検証をします。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
検証中に想定外の例外が発生
ValidatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorConfig (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
インタフェース ValidatorConfig

public interface ValidatorConfig

Validatorの初期化情報です。

導入されたバージョン:
4.3

メソッドの概要
String | getInitParameter(String name) Validatorを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
Validatorを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ValidatorException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス ValidatorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.validator.ValidatorException
すべての実装インタフェース:
Serializable
public class ValidatorException
extends SystemException

Validatorに関連する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ValidatorException()
詳細メッセージを指定しないで ValidatorException を構築します。
ValidatorException(String msg)
指定された詳細メッセージを持つ ValidatorException を構築します。
ValidatorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValidatorException

public ValidatorException()
詳細メッセージを指定しないで ValidatorException を構築します。

ValidatorException

public ValidatorException(String msg)
指定された詳細メッセージを持つ ValidatorException を構築します。

パラメータ:
msg - 詳細メッセージ

ValidatorException

public ValidatorException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.presentation.view.AbstractViewConverter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.AbstractViewConverter の使用

jp.co.intra_mart.framework.presentation.view.AbstractViewConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.view.MultiSelectableItem の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.MultiSelectableItem の使用

jp.co.intra_mart.framework.presentation.view.MultiSelectableItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.view.Option の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.Option の使用

Option を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での Option の使用

Option を返す jp.co.intra_mart.framework.presentation.view のメソッド
Option | SingleSelectableItem.getSelected() 選択済の選択肢を取得します。
Option[] | SelectableItem.getOption() 選択肢をすべて取得します。
Option | SelectableItem.getOption(int index) 選択肢を取得します。
Option | SelectableItem.findOption(String value) 値に該当する選択肢を取得します。
Option[] | MultiSelectableItem.getSelected() 選択済の選択肢をすべて取得します。
Option | MultiSelectableItem.getSelected(int index) 選択済みである選択肢を取得します。

Option 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
void | SingleSelectableItem.setSelected(Option option) 選択済の選択肢を設定します。
protected boolean | SingleSelectableItem.isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | SelectableItem.setOption(Option[] items) 選択肢を設定します。
void | SelectableItem.setOption(int index, Option option) 選択肢を設定します。
protected abstract boolean | SelectableItem.isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | MultiSelectableItem.setSelected(Option[] options) 選択済みである選択肢を設定します。
void | MultiSelectableItem.setSelected(int index, Option option) 選択済みである選択肢を設定します。
protected boolean | MultiSelectableItem.isSelected(Option option) 指定された選択肢が選択済かどうか判定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject の使用

PanelBasedViewObject を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での PanelBasedViewObject の使用

PanelBasedViewObject を実装している jp.co.intra_mart.framework.presentation.view のクラス
 class SimplePanelBasedViewObject
パネルコンポーネントの表示に関連するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.view.SelectableItem の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.SelectableItem の使用

SelectableItem を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での SelectableItem の使用

jp.co.intra_mart.framework.presentation.view での SelectableItem のサブクラス
class | MultiSelectableItem 複数の選択肢を選択することが可能な項目です。
class | SingleSelectableItem 単一の選択肢のみ選択することが可能な項目です。

SelectableItem 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
protected  void Option.setParent(SelectableItem item)
この選択肢が含まれる選択項目を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject の使用

jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.view.SimpleViewObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.SimpleViewObject の使用

SimpleViewObject を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での SimpleViewObject の使用

jp.co.intra_mart.framework.presentation.view での SimpleViewObject のサブクラス
 class SimplePanelBasedViewObject
パネルコンポーネントの表示に関連するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.view.SingleSelectableItem の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.SingleSelectableItem の使用

jp.co.intra_mart.framework.presentation.view.SingleSelectableItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.view.ViewConverter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.view.ViewConverter の使用

ViewConverter を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での ViewConverter の使用

ViewConverter を実装している jp.co.intra_mart.framework.presentation.view のクラス
 class AbstractViewConverter
いくつかのユーティリティメソッドが含まれる抽象的なビューコンバータです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.view.ViewConverterConfig の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.view.ViewConverterConfig の使用

ViewConverterConfig を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での ViewConverterConfig の使用

ViewConverterConfig 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
 void ViewConverter.init(ViewConverterConfig config)
ViewConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.presentation.view.ViewConverterException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.ViewConverterException の使用

ViewConverterException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での ViewConverterException の使用

ViewConverterException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
 void ViewConverter.init(ViewConverterConfig config)
ViewConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.presentation.view.ViewObject の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.view.ViewObject の使用

ViewObject を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation での ViewObject の使用

ViewObject を返す jp.co.intra_mart.framework.presentation のメソッド
 ViewObject RequestInfo.getViewObject()
生成されたビューオブジェクトを取得します。

jp.co.intra_mart.framework.presentation.view での ViewObject の使用

jp.co.intra_mart.framework.presentation.view での ViewObject のサブインタフェース
 interface PanelBasedViewObject
パネルコンポーネントの表示に関連するオブジェクトです。

ViewObject を実装している jp.co.intra_mart.framework.presentation.view のクラス
class | SimplePanelBasedViewObject パネルコンポーネントの表示に関連するオブジェクトです。
class | SimpleViewObject 単純なビューオブジェクトです。

ViewObject を返す jp.co.intra_mart.framework.presentation.view のメソッド
 ViewObject ViewConverter.convert(RequestInfo info)
リクエスト情報をもとにビューオブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbstractViewConverter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス AbstractViewConverter

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.AbstractViewConverter
すべての実装インタフェース:
ViewConverter
public abstract class AbstractViewConverter
extends Object
implements ViewConverter

いくつかのユーティリティメソッドが含まれる抽象的なビューコンバータです。 このクラスにはいくつかのユーティリティメソッドがあります。 このクラスを継承することでコーディング量を減らすことが可能です。

導入されたバージョン:
5.0

コンストラクタの概要
AbstractViewConverter()
メソッドの概要
protected Event | createEvent(RequestInfo info, String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
String | getLoginGroupID(RequestInfo info) 推奨されていません。 このメソッドではなくgetUserInfo(RequestInfo)を使用してください。
String | getLoginUserID(RequestInfo info) 推奨されていません。 このメソッドではなくgetUserInfo(RequestInfo)を使用してください。
UserInfo | getUserInfo(RequestInfo info) ログインユーザ情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.presentation.view.ViewConverter から継承したメソッド
convert, destroy, init

コンストラクタの詳細

AbstractViewConverter

public AbstractViewConverter()
メソッドの詳細

createEvent

protected Event createEvent(RequestInfo info,
                            String application,
                            String key)
                     throws ServiceControllerException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
ServiceControllerException - イベント取得時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

getLoginUserID

public String getLoginUserID(RequestInfo info)
                      throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo(RequestInfo)を使用してください。

ログインユーザIDを取得します。

パラメータ:
info - リクエスト情報
戻り値:
ログインユーザID
例外:
ServiceControllerException - ログインユーザID取得時に例外が発生

getLoginGroupID

public String getLoginGroupID(RequestInfo info)
                       throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo(RequestInfo)を使用してください。

ログイングループIDを取得します。

パラメータ:
info - リクエスト情報
戻り値:
ログイングループID
例外:
ServiceControllerException - ログイングループID取得時に例外が発生

getUserInfo

public UserInfo getUserInfo(RequestInfo info)
                     throws ServiceControllerException
ログインユーザ情報を取得します。
ログインセッションが存在しない場合はnullを返却します。

パラメータ:
info - リクエスト情報
戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ログインユーザ情報取得時に例外が発生
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultiSelectableItem (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス MultiSelectableItem

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SelectableItem
        拡張 jp.co.intra_mart.framework.presentation.view.MultiSelectableItem
public class MultiSelectableItem
extends SelectableItem

複数の選択肢を選択することが可能な項目です。

導入されたバージョン:
4.3

コンストラクタの概要
MultiSelectableItem()
メソッドの概要
Option[] | getSelected() 選択済の選択肢をすべて取得します。
Option | getSelected(int index) 選択済みである選択肢を取得します。
protected boolean | isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | setSelected(int index, Option option) 選択済みである選択肢を設定します。
void | setSelected(Option[] options) 選択済みである選択肢を設定します。
クラス jp.co.intra_mart.framework.presentation.view.SelectableItem から継承したメソッド
findOption, getOption, getOption, setOption, setOption
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultiSelectableItem

public MultiSelectableItem()
メソッドの詳細

getSelected

public Option[] getSelected()
選択済の選択肢をすべて取得します。

戻り値:
選択済の選択肢

getSelected

public Option getSelected(int index)
選択済みである選択肢を取得します。 indexで指定した場所の選択肢を取得します。

パラメータ:
index - インデックス。
戻り値:
選択肢

setSelected

public void setSelected(Option[] options)
選択済みである選択肢を設定します。

パラメータ:
options - 選択済みである選択肢の配列

setSelected

public void setSelected(int index,
                        Option option)
選択済みである選択肢を設定します。 indexで指定した場所に選択肢設定します。

パラメータ:
index - インデックス
option - 選択肢

isSelected

protected boolean isSelected(Option option)
指定された選択肢が選択済かどうか判定します。

定義:
クラス SelectableItem 内の isSelected
パラメータ:
option - 選択肢
戻り値:
選択されていればtrue、選択されていなければfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Option (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス Option

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.Option
public class Option
extends Object

選択項目における選択肢です。 SelectableItemの選択肢です。

導入されたバージョン:
4.3

コンストラクタの概要
Option()
メソッドの概要
String | getDisplayName() 表示名を取得します。
String | getSelectString() この選択肢が選択済である場合の表示名を取得します。
String | getValue() 値を取得します。
boolean | isSelected() この選択肢が選択済であるかどうかを判定します。
void | setDisplayName(String displayName) 表示名を設定します。
protected void | setParent(SelectableItem item) この選択肢が含まれる選択項目を設定します。
void | setValue(String value) 値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Option

public Option()
メソッドの詳細

getDisplayName

public String getDisplayName()
表示名を取得します。

戻り値:
表示名

getSelectString

public String getSelectString()
この選択肢が選択済である場合の表示名を取得します。

戻り値:
項目が選択済である場合は"selected"、選択済でない場合は空文字列

getValue

public String getValue()
値を取得します。

戻り値:
値

isSelected

public boolean isSelected()
この選択肢が選択済であるかどうかを判定します。

戻り値:
選択済である場合はtrue、選択済でない場合はfalse

setParent

protected void setParent(SelectableItem item)
この選択肢が含まれる選択項目を設定します。

パラメータ:
item - この選択肢が含まれる選択項目

setDisplayName

public void setDisplayName(String displayName)
表示名を設定します。

パラメータ:
displayName - 表示名

setValue

public void setValue(String value)
値を設定します。

パラメータ:
value - 値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.presentation.view (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.presentation.view
インタフェース
PanelBasedViewObject
ViewConverter
ViewConverterConfig
ViewObject
クラス
AbstractViewConverter
MultiSelectableItem
Option
SelectableItem
SimplePanelBasedViewObject
SimpleViewObject
SingleSelectableItem
例外
ViewConverterException


jp.co.intra_mart.framework.presentation.view (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.view

出力情報に関連するパッケージです。

参照:
説明

インタフェースの概要
PanelBasedViewObject | パネルコンポーネントの表示に関連するオブジェクトです。
ViewConverter | 出力情報をビューオブジェクトに変換します。
ViewConverterConfig | ViewConverterの初期化情報です。
ViewObject | ビューオブジェクトのインタフェースです。

クラスの概要
AbstractViewConverter | いくつかのユーティリティメソッドが含まれる抽象的なビューコンバータです。
MultiSelectableItem | 複数の選択肢を選択することが可能な項目です。
Option | 選択項目における選択肢です。
SelectableItem | 選択肢を持つ項目です。
SimplePanelBasedViewObject | パネルコンポーネントの表示に関連するオブジェクトです。
SimpleViewObject | 単純なビューオブジェクトです。
SingleSelectableItem | 単一の選択肢のみ選択することが可能な項目です。

例外の概要
ViewConverterException ViewConverterに関連する例外です。

パッケージ jp.co.intra_mart.framework.presentation.view の説明

出力情報に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.presentation.view クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.view の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter (implements jp.co.intra_mart.framework.presentation.view.ViewConverter)
    • class jp.co.intra_mart.framework.presentation.view.Option
    • class jp.co.intra_mart.framework.presentation.view.SelectableItem
      • class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem
      • class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem
    • class jp.co.intra_mart.framework.presentation.view.SimpleViewObject (implements jp.co.intra_mart.framework.presentation.view.ViewObject)
      • class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject (implements jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.view.ViewConverterException

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.presentation.view.ViewObject
      • interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject
  • interface jp.co.intra_mart.framework.presentation.view.ViewConverter
  • interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.presentation.view の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.view の使用

jp.co.intra_mart.framework.presentation.view を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.presentation.view のクラス
ViewObject
ビューオブジェクトのインタフェースです。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.presentation.view のクラス
Option
選択項目における選択肢です。
PanelBasedViewObject
パネルコンポーネントの表示に関連するオブジェクトです。
SelectableItem
選択肢を持つ項目です。
SimpleViewObject
単純なビューオブジェクトです。
ViewConverter
出力情報をビューオブジェクトに変換します。
ViewConverterConfig
ViewConverterの初期化情報です。
ViewConverterException
ViewConverterに関連する例外です。
ViewObject
ビューオブジェクトのインタフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PanelBasedViewObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
インタフェース PanelBasedViewObject

すべてのスーパーインタフェース:
Serializable, ViewObject
既知の実装クラスの一覧:
SimplePanelBasedViewObject
public interface PanelBasedViewObject
extends ViewObject

パネルコンポーネントの表示に関連するオブジェクトです。

導入されたバージョン:
4.3

メソッドの概要
 Map getSubPanelViewObjects()
サブパネルに対応するPanelBasedViewObjectを取得します。
インタフェース jp.co.intra_mart.framework.presentation.view.ViewObject から継承したメソッド
getFormObjects, getViewInfo

メソッドの詳細

getSubPanelViewObjects

public Map getSubPanelViewObjects()
サブパネルに対応するPanelBasedViewObjectを取得します。 このメソッドで取得されるマップは、名前とPanelBasedViewObjectが対応付けられたものである必要があります。

戻り値:
サブパネル名に対応するPanelBasedViewObjectのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SelectableItem (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス SelectableItem

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SelectableItem
直系の既知のサブクラス:
MultiSelectableItem, SingleSelectableItem
public abstract class SelectableItem
extends Object

選択肢を持つ項目です。 選択肢としてOptionを複数個持ちます。

導入されたバージョン:
4.3

コンストラクタの概要
SelectableItem()
メソッドの概要
Option | findOption(String value) 値に該当する選択肢を取得します。
Option[] | getOption() 選択肢をすべて取得します。
Option | getOption(int index) 選択肢を取得します。
protected abstract boolean | isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | setOption(int index, Option option) 選択肢を設定します。
void | setOption(Option[] items) 選択肢を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SelectableItem

public SelectableItem()
メソッドの詳細

getOption

public Option[] getOption()
選択肢をすべて取得します。

戻り値:
選択肢の配列

getOption

public Option getOption(int index)
選択肢を取得します。 indexで指定された選択肢を取得します。

パラメータ:
index - インデックス
戻り値:
選択肢

setOption

public void setOption(Option[] items)
選択肢を設定します。

パラメータ:
items - 選択肢の配列

setOption

public void setOption(int index,
                      Option option)
選択肢を設定します。 indexで指定された場所に選択肢を設定します。

パラメータ:
index - インデックス
option - 選択肢

findOption

public Option findOption(String value)
値に該当する選択肢を取得します。

パラメータ:
value - 値
戻り値:
選択肢

isSelected

protected abstract boolean isSelected(Option option)
指定された選択肢が選択済かどうか判定します。

パラメータ:
option - 選択肢
戻り値:
選択されていればtrue、選択されていなければfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SimplePanelBasedViewObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス SimplePanelBasedViewObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SimpleViewObject
        拡張 jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject
すべての実装インタフェース:
PanelBasedViewObject, Serializable, ViewObject
public class SimplePanelBasedViewObject
extends SimpleViewObject
implements PanelBasedViewObject

パネルコンポーネントの表示に関連するオブジェクトです。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
SimplePanelBasedViewObject()
メソッドの概要
Map | getSubPanelViewObjects() サブパネルに対応するPanelBasedViewObjectを取得します。
void | setSubPanelViewObjects(Map views) サブパネルに対応するPanelBasedViewObjectを設定します。
クラス jp.co.intra_mart.framework.presentation.view.SimpleViewObject から継承したメソッド
getFormObjects, getViewInfo, setFormObjects, setViewInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.presentation.view.ViewObject から継承したメソッド
getFormObjects, getViewInfo

コンストラクタの詳細

SimplePanelBasedViewObject

public SimplePanelBasedViewObject()
メソッドの詳細

getSubPanelViewObjects

public Map getSubPanelViewObjects()
サブパネルに対応するPanelBasedViewObjectを取得します。 このメソッドで取得されるマップは、名前とPanelBasedViewObjectが対応付けられたものである必要があります。

定義:
インタフェース PanelBasedViewObject 内の getSubPanelViewObjects
戻り値:
サブパネル名に対応するPanelBasedViewObjectのマップ

setSubPanelViewObjects

public void setSubPanelViewObjects(Map views)
サブパネルに対応するPanelBasedViewObjectを設定します。 このメソッドで設定するマップは、名前とPanelBasedViewObjectが対応付けられたものである必要があります。

パラメータ:
views - サブパネルに対応するPanelBasedViewObjectのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SimpleViewObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス SimpleViewObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SimpleViewObject
すべての実装インタフェース:
Serializable, ViewObject
直系の既知のサブクラス:
SimplePanelBasedViewObject
public class SimpleViewObject
extends Object
implements ViewObject

単純なビューオブジェクトです。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
SimpleViewObject()
メソッドの概要
Map | getFormObjects() フォームオブジェクトのマップを取得します。
Object | getViewInfo() 表示情報を取得します。
void | setFormObjects(Map obj) フォームオブジェクトのマップを設定します。
void | setViewInfo(Object info) 表示情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SimpleViewObject

public SimpleViewObject()
メソッドの詳細

getViewInfo

public Object getViewInfo()
表示情報を取得します。 このメソッドで取得されるインスタンスはJavaBeansの仕様に沿っている必要があります。

定義:
インタフェース ViewObject 内の getViewInfo
戻り値:
表示情報

setViewInfo

public void setViewInfo(Object info)
表示情報を設定します。 このメソッドで設定するインスタンスはJavaBeansの仕様に沿っている必要があります。

パラメータ:
info - 表示情報

getFormObjects

public Map getFormObjects()
フォームオブジェクトのマップを取得します。 このメソッドで取得されるマップは、名前とフォームオブジェクトが対応付けられたものである必要があります。

定義:
インタフェース ViewObject 内の getFormObjects
戻り値:
フォームオブジェクト

setFormObjects

public void setFormObjects(Map obj)
フォームオブジェクトのマップを設定します。 このメソッドで設定されるマップは、名前とフォームオブジェクトが対応付けられたものである必要があります。

パラメータ:
obj - フォームオブジェクトのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SingleSelectableItem (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス SingleSelectableItem

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SelectableItem
        拡張 jp.co.intra_mart.framework.presentation.view.SingleSelectableItem
public class SingleSelectableItem
extends SelectableItem

単一の選択肢のみ選択することが可能な項目です。

導入されたバージョン:
4.3

コンストラクタの概要
SingleSelectableItem()
メソッドの概要
Option | getSelected() 選択済の選択肢を取得します。
protected boolean | isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | setSelected(Option option) 選択済の選択肢を設定します。
クラス jp.co.intra_mart.framework.presentation.view.SelectableItem から継承したメソッド
findOption, getOption, getOption, setOption, setOption
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SingleSelectableItem

public SingleSelectableItem()
メソッドの詳細

getSelected

public Option getSelected()
選択済の選択肢を取得します。

戻り値:
選択済の選択肢、選択済のものがない場合はnull

setSelected

public void setSelected(Option option)
選択済の選択肢を設定します。

パラメータ:
option - 選択済の選択肢

isSelected

protected boolean isSelected(Option option)
指定された選択肢が選択済かどうか判定します。

定義:
クラス SelectableItem 内の isSelected
パラメータ:
option - 選択肢
戻り値:
選択されていればtrue、選択されていなければfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ViewConverter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
インタフェース ViewConverter

既知の実装クラスの一覧:
AbstractViewConverter
public interface ViewConverter

出力情報をビューオブジェクトに変換します。 開発者はこのインタフェースを実装し、適切なビューオブジェクトを返すように convert(RequestInfo)メソッドを実装する 必要があります。

導入されたバージョン:
4.3

メソッドの概要
ViewObject | convert(RequestInfo info) リクエスト情報をもとにビューオブジェクトを生成します。
void | destroy() ViewConverterを破棄します。
void | init(ViewConverterConfig config) ViewConverterを初期化します。

メソッドの詳細

init

public void init(ViewConverterConfig config)
          throws ViewConverterException
ViewConverterを初期化します。

パラメータ:
config - 初期化情報
例外:
ForwardSelectorException - 初期化時に例外が発生
ViewConverterException

destroy

public void destroy()
ViewConverterを破棄します。

convert

public ViewObject convert(RequestInfo info)
                   throws SystemException,
                          ApplicationException
リクエスト情報をもとにビューオブジェクトを生成します。

パラメータ:
info - リクエスト情報
戻り値:
出力時に必要となる内容が含まれるビューオブジェクト
例外:
SystemException - ビューオブジェクトの生成時にシステム例外が発生
ApplicationException - ビューオブジェクトの生成時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ViewConverterConfig (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
インタフェース ViewConverterConfig

public interface ViewConverterConfig

ViewConverterの初期化情報です。

導入されたバージョン:
4.3

メソッドの概要
String | getInitParameter(String name) ViewConverterを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
ViewConverterを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ViewConverterException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス ViewConverterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.view.ViewConverterException
すべての実装インタフェース:
Serializable
public class ViewConverterException
extends SystemException

ViewConverterに関連する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ViewConverterException()
詳細メッセージを指定しないで ViewConverterException を構築します。
ViewConverterException(String msg)
指定された詳細メッセージを持つ ViewConverterException を構築します。
ViewConverterException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ViewConverterException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ViewConverterException

public ViewConverterException()
詳細メッセージを指定しないで ViewConverterException を構築します。

ViewConverterException

public ViewConverterException(String msg)
指定された詳細メッセージを持つ ViewConverterException を構築します。

パラメータ:
msg - 詳細メッセージ

ViewConverterException

public ViewConverterException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ViewConverterException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ViewObject (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
インタフェース ViewObject

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
PanelBasedViewObject
既知の実装クラスの一覧:
SimplePanelBasedViewObject, SimpleViewObject
public interface ViewObject
extends Serializable

ビューオブジェクトのインタフェースです。 すべてのビューオブジェクトはこのインタフェースを実装する必要があります。 このインタフェースを実装するクラスはJavaBeansの仕様に沿っている必要があります。

導入されたバージョン:
4.3

メソッドの概要
Map | getFormObjects() フォームオブジェクトのマップを取得します。
Object | getViewInfo() 表示情報を取得します。

メソッドの詳細

getViewInfo

public Object getViewInfo()
表示情報を取得します。 このメソッドで取得されるインスタンスはJavaBeansの仕様に沿っている必要があります。

戻り値:
表示情報

getFormObjects

public Map getFormObjects()
フォームオブジェクトのマップを取得します。 このメソッドで取得されるマップは、名前とフォームオブジェクトが対応付けられたものである必要があります。

戻り値:
フォームオブジェクトのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BadRequestException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス BadRequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.presentation.BadRequestException
すべての実装インタフェース:
Serializable
public class BadRequestException
extends ApplicationException

クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
BadRequestException()
詳細メッセージを指定しないで BadRequestException を構築します。
BadRequestException(String msg)
指定された詳細メッセージを持つ BadRequestException を構築します。
BadRequestException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ BadRequestException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BadRequestException

public BadRequestException()
詳細メッセージを指定しないで BadRequestException を構築します。

BadRequestException

public BadRequestException(String msg)
指定された詳細メッセージを持つ BadRequestException を構築します。

パラメータ:
msg - 詳細メッセージ

BadRequestException

public BadRequestException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ BadRequestException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DuplicateException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス DuplicateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.DuplicateException
すべての実装インタフェース:
Serializable
public class DuplicateException
extends SystemException

重複しているときに発生する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
DuplicateException()
詳細メッセージを指定しないで DuplicateException を構築します。
DuplicateException(String msg)
指定された詳細メッセージを持つ DuplicateException を構築します。
DuplicateException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateException

public DuplicateException()
詳細メッセージを指定しないで DuplicateException を構築します。

DuplicateException

public DuplicateException(String msg)
指定された詳細メッセージを持つ DuplicateException を構築します。

パラメータ:
msg - 詳細メッセージ

DuplicateException

public DuplicateException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MismatchException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス MismatchException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.MismatchException
すべての実装インタフェース:
Serializable
public class MismatchException
extends SystemException

キーが重複しているときに発生する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
MismatchException()
詳細メッセージを指定しないで DuplicateException を構築します。
MismatchException(String msg)
指定された詳細メッセージを持つ DuplicateException を構築します。
MismatchException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MismatchException

public MismatchException()
詳細メッセージを指定しないで DuplicateException を構築します。

MismatchException

public MismatchException(String msg)
指定された詳細メッセージを持つ DuplicateException を構築します。

パラメータ:
msg - 詳細メッセージ

MismatchException

public MismatchException(String msg,
                         Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NameFormatException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス NameFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.NameFormatException
すべての実装インタフェース:
Serializable
public class NameFormatException
extends SystemException

名前が不正であることを示します。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
NameFormatException()
詳細メッセージを指定しないで NameFormatException を構築します。
NameFormatException(String msg)
指定された詳細メッセージを持つ NameFormatException を構築します。
NameFormatException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ NameFormatException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NameFormatException

public NameFormatException()
詳細メッセージを指定しないで NameFormatException を構築します。

NameFormatException

public NameFormatException(String msg)
指定された詳細メッセージを持つ NameFormatException を構築します。

パラメータ:
msg - 詳細メッセージ

NameFormatException

public NameFormatException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ NameFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.presentation (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.presentation
インタフェース
PresentationPropertyHandler
RequestInfo
クラス
PresentationConnectFilter
PresentationManager
PresentationServlet
例外
BadRequestException
DuplicateException
MismatchException
NameFormatException
PresentationManagerException
PresentationPropertyException
TokenInvalidException


jp.co.intra_mart.framework.presentation (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation

Presentation Frameworkに関連するパッケージです。

参照:
説明

インタフェースの概要
PresentationPropertyHandler | プレゼンテーションフレームワークのプロパティ設定のハンドラです。
RequestInfo | リクエストに対する情報を取得します。

クラスの概要
PresentationConnectFilter | 推奨されていません。 この機能は廃止されました。
PresentationManager | プレゼンテーションマネージャです。
PresentationServlet | プレゼンテーションフレームワークのサーブレットです。

例外の概要
BadRequestException | クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。
DuplicateException | 重複しているときに発生する例外です。
MismatchException | キーが重複しているときに発生する例外です。
NameFormatException | 名前が不正であることを示します。
PresentationManagerException | PresentationManager設定時の例外です。
PresentationPropertyException | PresentationProperty取得時の例外です。
TokenInvalidException | トークンが不正な場合に発生する例外です。

パッケージ jp.co.intra_mart.framework.presentation の説明

Presentation Frameworkに関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.presentation クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.framework.presentation.PresentationServlet
    • class jp.co.intra_mart.framework.presentation.PresentationConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.presentation.PresentationManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.presentation.BadRequestException
            • class jp.co.intra_mart.framework.presentation.TokenInvalidException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.DuplicateException
            • class jp.co.intra_mart.framework.presentation.MismatchException
            • class jp.co.intra_mart.framework.presentation.NameFormatException
            • class jp.co.intra_mart.framework.presentation.PresentationManagerException
            • class jp.co.intra_mart.framework.presentation.PresentationPropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler
  • interface jp.co.intra_mart.framework.presentation.RequestInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.presentation の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation の使用

jp.co.intra_mart.framework.presentation を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.presentation のクラス
PresentationManager
プレゼンテーションマネージャです。
PresentationManagerException
PresentationManager設定時の例外です。
PresentationPropertyException
PresentationProperty取得時の例外です。
PresentationPropertyHandler
プレゼンテーションフレームワークのプロパティ設定のハンドラです。

jp.co.intra_mart.framework.presentation.controller により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.presentation.forward により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.presentation.service により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.presentation.validator により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PresentationConnectFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.PresentationConnectFilter
すべての実装インタフェース:
Filter
推奨されていません。 この機能は廃止されました。

public class PresentationConnectFilter
extends Object
implements Filter

intra-martのページベースの画面からPresentation Frameworkの画面に遷移する時に使うフィルタです。 intra-martから来るリクエストをPresentation Frameworkで扱う形式に変換します。 このフィルタで変換されたリクエストは PresentationServletで扱えるようになります。

導入されたバージョン:
4.3

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
static String | LICENSE_PATH 推奨されていません。 Append-Product定義ファイルのアクセス権記述子
static String | PARAM_ARGUMENT 推奨されていません。 ページ引数のリクエストパラメータ名
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 ログイングループIDのリクエストパラメータ名
static String | PARAM_LOGIN_USER_ID 推奨されていません。 ログインユーザIDのリクエストパラメータ名
static String | PARAM_REFERER 推奨されていません。 参照元URLのリクエストパラメータ名
static String | PARAM_WINDOW_NAME 推奨されていません。 基本ウィンドウ名
コンストラクタの概要
PresentationConnectFilter()
推奨されていません。 ライセンス情報の設定
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 intra-martから来るリクエストをPresentation Frameworkで扱う形式に変換します。
void | init(FilterConfig filterConfig) 推奨されていません。 このフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。
ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。
ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。
ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。
参照元URLのリクエストパラメータ名

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。
セッションに登録するintra-martのサーブレットのURLの属性名

関連項目:
定数フィールド値

PARAM_WINDOW_NAME

public static final String PARAM_WINDOW_NAME
推奨されていません。
基本ウィンドウ名

関連項目:
定数フィールド値

LICENSE_PATH

public static final String LICENSE_PATH
推奨されていません。
Append-Product定義ファイルのアクセス権記述子

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationConnectFilter

public PresentationConnectFilter()
推奨されていません。
ライセンス情報の設定

メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
推奨されていません。
intra-martから来るリクエストをPresentation Frameworkで扱う形式に変換します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PresentationManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.PresentationManager
public abstract class PresentationManager
extends Object

プレゼンテーションマネージャです。

導入されたバージョン:
4.3

フィールドの概要
static String | CONFIG PresentationManagerの生成情報が設定されているリソースバンドル名
static String | MANAGER_CLASS_KEY PresentationManagerの実装クラス名が記述されているキー
コンストラクタの概要
protected PresentationManager()
PresentationManagerを新規に生成します。
メソッドの概要
abstract String | createToken() 新しいトークンを取得します。
static PresentationManager | getManager() PresentationManagerを取得します。
abstract PresentationPropertyHandler | getPresentationPropertyHandler() PresentationPropertyHandlerを取得します。
abstract void | lockSession(String id) セッションをロックします。
abstract void | unlockSession(String id) セッションのロックを解除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONFIG

public static final String CONFIG
PresentationManagerの生成情報が設定されているリソースバンドル名

関連項目:
定数フィールド値

MANAGER_CLASS_KEY

public static final String MANAGER_CLASS_KEY
PresentationManagerの実装クラス名が記述されているキー

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationManager

protected PresentationManager()
PresentationManagerを新規に生成します。 このクラスのインスタンスは明示的に生成できません。 代わりにgetManager()でこのクラスのインスタンスを取得してください。

メソッドの詳細

getManager

public static PresentationManager getManager()
                                      throws PresentationManagerException
PresentationManagerを取得します。

戻り値:
PresentationManager
例外:
PresentationManagerException - PresentationManagerの生成が失敗した

getPresentationPropertyHandler

public abstract PresentationPropertyHandler getPresentationPropertyHandler()
PresentationPropertyHandlerを取得します。

戻り値:
PresentationPropertyHandler

createToken

public abstract String createToken()
                            throws PresentationManagerException
新しいトークンを取得します。

戻り値:
新しいトークン
例外:
PresentationManagerException - トークンの取得に失敗

lockSession

public abstract void lockSession(String id)
                          throws PresentationManagerException
セッションをロックします。

パラメータ:
id - セッションID
例外:
PresentationManagerException - ロックに失敗

unlockSession

public abstract void unlockSession(String id)
                            throws PresentationManagerException
セッションのロックを解除します。

パラメータ:
id - セッションID
例外:
PresentationManagerException - ロック解除に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PresentationManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.PresentationManagerException
すべての実装インタフェース:
Serializable
public class PresentationManagerException
extends SystemException

PresentationManager設定時の例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
PresentationManagerException()
詳細メッセージを指定しないで PresentationManagerException を構築します。
PresentationManagerException(String msg)
指定された詳細メッセージを持つ PresentationManagerException を構築します。
PresentationManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PresentationManagerException

public PresentationManagerException()
詳細メッセージを指定しないで PresentationManagerException を構築します。

PresentationManagerException

public PresentationManagerException(String msg)
指定された詳細メッセージを持つ PresentationManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

PresentationManagerException

public PresentationManagerException(String msg,
                                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PresentationPropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.PresentationPropertyException
すべての実装インタフェース:
Serializable
public class PresentationPropertyException
extends SystemException

PresentationProperty取得時の例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
PresentationPropertyException()
詳細メッセージを指定しないで PresentationPropertyException を構築します。
PresentationPropertyException(String msg)
指定された詳細メッセージを持つ PresentationPropertyException を構築します。
PresentationPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PresentationPropertyException

public PresentationPropertyException()
詳細メッセージを指定しないで PresentationPropertyException を構築します。

PresentationPropertyException

public PresentationPropertyException(String msg)
指定された詳細メッセージを持つ PresentationPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

PresentationPropertyException

public PresentationPropertyException(String msg,
                                     Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PresentationPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
インタフェース PresentationPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
public interface PresentationPropertyHandler
extends PropertyHandler

プレゼンテーションフレームワークのプロパティ設定のハンドラです。

導入されたバージョン:
4.3

メソッドの概要
jp.co.intra_mart.framework.presentation.property.Application | getApplication(String name) アプリケーションの情報を取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws PresentationPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
PresentationPropertyException - チェック時に例外が発生

getApplication

public jp.co.intra_mart.framework.presentation.property.Application getApplication(String name)
                                                                            throws PresentationPropertyException
アプリケーションの情報を取得します。

パラメータ:
name - パッケージまで指定した完全なアプリケーション名
戻り値:
アプリケーション情報
例外:
PresentationPropertyException - アプリケーション情報取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PresentationServlet (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.presentation.PresentationServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class PresentationServlet
extends HttpServlet

プレゼンテーションフレームワークのサーブレットです。

導入されたバージョン:
4.3
関連項目:
直列化された形式

フィールドの概要
static String | ACTION_ID アクションによる遷移をする場合のID
static String | LICENSE_PATH Append-Product定義ファイルのアクセス権記述子
static String | PREFIX_ATTRIBUTE HttpServletRequestにおけるURLのプレフィックスの保存先
static String | REQUEST_INFO_ATTRIBUTE HttpServletRequestにおける RequestInfoの保存先
static String | REQUEST_SEPARATOR リクエストの情報を分割するセパレータ
static String | START_ID スタートポイントに入る場合のID
static String | SUFFIX_ATTRIBUTE HttpServletRequestにおけるURLのサフィックスの保存先
static String | TOKEN_ATTRIBUTE HttpServletRequestにおける次の画面のトークンの保存先
コンストラクタの概要
PresentationServlet()
メソッドの概要
void | destroy() サーブレットを破棄します。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) リクエストがGETで来た場合の処理をします。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) リクエストがPOSTで来た場合の処理をします。
jp.co.intra_mart.framework.presentation.PresentationServlet.RequestInfoImpl | getRequestInfo(HttpServletRequest request, HttpServletResponse response) RequestInfoを取得します。
void | init(ServletConfig config) サーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

START_ID

public static final String START_ID
スタートポイントに入る場合のID

関連項目:
定数フィールド値

ACTION_ID

public static final String ACTION_ID
アクションによる遷移をする場合のID

関連項目:
定数フィールド値

REQUEST_SEPARATOR

public static final String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ

関連項目:
定数フィールド値

REQUEST_INFO_ATTRIBUTE

public static final String REQUEST_INFO_ATTRIBUTE
HttpServletRequestにおける RequestInfoの保存先

関連項目:
定数フィールド値

PREFIX_ATTRIBUTE

public static final String PREFIX_ATTRIBUTE
HttpServletRequestにおけるURLのプレフィックスの保存先

関連項目:
定数フィールド値

SUFFIX_ATTRIBUTE

public static final String SUFFIX_ATTRIBUTE
HttpServletRequestにおけるURLのサフィックスの保存先

関連項目:
定数フィールド値

TOKEN_ATTRIBUTE

public static final String TOKEN_ATTRIBUTE
HttpServletRequestにおける次の画面のトークンの保存先

関連項目:
定数フィールド値

LICENSE_PATH

public static final String LICENSE_PATH
Append-Product定義ファイルのアクセス権記述子

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationServlet

public PresentationServlet()
メソッドの詳細

init

public void init(ServletConfig config)
          throws ServletException
サーブレットを初期化します。

パラメータ:
config -
例外:
ServletException - 初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
リクエストがGETで来た場合の処理をします。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - Servletの例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
リクエストがPOSTで来た場合の処理をします。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - Servletの例外が発生
IOException - 入出力例外が発生

destroy

public void destroy()
サーブレットを破棄します。

getRequestInfo

public jp.co.intra_mart.framework.presentation.PresentationServlet.RequestInfoImpl getRequestInfo(HttpServletRequest request,
                                                                                HttpServletResponse response)
                                                                                throws ServletException,
                                                                                IOException
RequestInfoを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
RequestInfo
例外:
ServletException - サーブレット例外が発生
IOException - IO例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


RequestInfo (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
インタフェース RequestInfo

public interface RequestInfo

リクエストに対する情報を取得します。

導入されたバージョン:
4.3

メソッドの概要
ControllerObject | getControllerObject() リクエストから生成されたコントローラオブジェクトを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | getResult() サービス処理結果を取得します。
Throwable | getThrowable() 処理中に発生した例外を取得します。
ViewObject | getViewObject() 生成されたビューオブジェクトを取得します。

メソッドの詳細

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getControllerObject

public ControllerObject getControllerObject()
リクエストから生成されたコントローラオブジェクトを取得します。 このメソッドはコントローラオブジェクトが生成されていないとき、 またはControllerConverterが指定されていないときはnullが戻ります。

戻り値:
リクエストから生成されたコントローラオブジェクト（コントローラオブジェクトが生成されていない、またはControllerConverterが指定されていないときはnull）

getViewObject

public ViewObject getViewObject()
生成されたビューオブジェクトを取得します。 このメソッドはビューオブジェクトが生成されていないとき、 またはViewConverterが指定されていないときはnullが戻ります。

戻り値:
生成されたビューオブジェクト（ビューオブジェクトが生成されていない、またはViewConverterが指定されていないときはnull）

getResult

public ServiceResult getResult()
サービス処理結果を取得します。 このメソッドはサービス処理結果が生成されていないとき、 またはServiceControllerが指定されていないときはnullが戻ります。

戻り値:
サービス処理結果（サービス処理結果が生成されていない、またはServiceControllerが指定されていないときはnull）

getThrowable

public Throwable getThrowable()
処理中に発生した例外を取得します。

戻り値:
処理中に発生した例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


TokenInvalidException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス TokenInvalidException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.presentation.TokenInvalidException
すべての実装インタフェース:
Serializable
public class TokenInvalidException
extends ApplicationException

トークンが不正な場合に発生する例外です。 ブラウザのBackボタンなどによって不正にリクエストが送信されたときなどにthrowされます。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
TokenInvalidException()
詳細メッセージを指定しないで TokenInvalidException を構築します。
TokenInvalidException(String msg)
指定された詳細メッセージを持つ TokenInvalidException を構築します。
TokenInvalidException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TokenInvalidException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TokenInvalidException

public TokenInvalidException()
詳細メッセージを指定しないで TokenInvalidException を構築します。

TokenInvalidException

public TokenInvalidException(String msg)
指定された詳細メッセージを持つ TokenInvalidException を構築します。

パラメータ:
msg - 詳細メッセージ

TokenInvalidException

public TokenInvalidException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TokenInvalidException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.exception.ApplicationException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.ApplicationException の使用

ApplicationException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.service での ApplicationException の使用

jp.co.intra_mart.framework.base.service での ApplicationException のサブクラス
 class RequestException
リクエストの内容に関連する間違いがある場合の例外です。

ApplicationException をスローする jp.co.intra_mart.framework.base.service のメソッド
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
protected EventResult | ServiceControllerAdapter.dispatchEvent(Event event) イベント処理を実行します。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。

jp.co.intra_mart.framework.base.web.bean での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.extension.common.util のメソッド
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.struts.action での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation での ApplicationException の使用

jp.co.intra_mart.framework.presentation での ApplicationException のサブクラス
class | BadRequestException クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。
class | TokenInvalidException トークンが不正な場合に発生する例外です。

jp.co.intra_mart.framework.presentation.validator での ApplicationException の使用

jp.co.intra_mart.framework.presentation.validator での ApplicationException のサブクラス
 class ValidationException
検証結果が不正であるときの例外です。

jp.co.intra_mart.framework.presentation.view での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
ViewObject | ViewConverter.convert(RequestInfo info) リクエスト情報をもとにビューオブジェクトを生成します。
protected EventResult | AbstractViewConverter.dispatchEvent(Event event) イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.FrameworkException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.FrameworkException の使用

FrameworkException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での FrameworkException の使用

jp.co.intra_mart.framework.base.data での FrameworkException のサブクラス
class | DAOException リソースコネクタの情報取得時の例外です。
class | DataAccessException データアクセス時の例外です。
class | DataConnectException データ接続に関連する例外です。
class | DataConnectorException データコネクタ取得時の例外です。
class | DataManagerException データマネージャの設定時の例外です。
class | DataPropertyException データプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.event での FrameworkException の使用

jp.co.intra_mart.framework.base.event での FrameworkException のサブクラス
class | EventException イベント生成時の例外です。
class | EventListenerException イベントリスナ生成時の例外です。
class | EventManagerException イベントマネージャ設定時の例外です。
class | EventPropertyException イベントプロパティ取得時の例外です。
class | EventTriggerException イベントトリガ生成時の例外です。

jp.co.intra_mart.framework.base.message での FrameworkException の使用

jp.co.intra_mart.framework.base.message での FrameworkException のサブクラス
class | MessageManagerException サービスマネージャ設定時の例外です。
class | MessagePropertyException メッセージプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.service での FrameworkException の使用

jp.co.intra_mart.framework.base.service での FrameworkException のサブクラス
class | RequestException リクエストの内容に関連する間違いがある場合の例外です。
class | ServiceControllerException サービスコントローラに関連する例外です。
class | ServiceManagerException サービスマネージャ設定時の例外です。
class | ServicePropertyException サービスプロパティ取得時の例外です。
class | ServiceServletException サービスに関連する例外です。
class | TransitionException トランジションに関連する例外です。

jp.co.intra_mart.framework.base.session での FrameworkException の使用

jp.co.intra_mart.framework.base.session での FrameworkException のサブクラス
class | IllegalSessionException セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
class | SessionFactoryException セッションファクトリ内の例外です。
class | SessionManagerException セッションマネージャ内の例外です。
class | SessionObjectException セッションオブジェクト内の例外です。
class | SessionPropertyException セッションプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.util での FrameworkException の使用

jp.co.intra_mart.framework.base.util での FrameworkException のサブクラス
 class UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean での FrameworkException の使用

jp.co.intra_mart.framework.base.web.bean での FrameworkException のサブクラス
 class HelperBeanException
HelperBean内で発生した例外です。

jp.co.intra_mart.framework.presentation での FrameworkException の使用

jp.co.intra_mart.framework.presentation での FrameworkException のサブクラス
class | BadRequestException クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。
class | DuplicateException 重複しているときに発生する例外です。
class | MismatchException キーが重複しているときに発生する例外です。
class | NameFormatException 名前が不正であることを示します。
class | PresentationManagerException PresentationManager設定時の例外です。
class | PresentationPropertyException PresentationProperty取得時の例外です。
class | TokenInvalidException トークンが不正な場合に発生する例外です。

jp.co.intra_mart.framework.presentation.controller での FrameworkException の使用

jp.co.intra_mart.framework.presentation.controller での FrameworkException のサブクラス
class | ControllerConverterException ControllerConverterに関連する例外です。
class | RequestFormatException フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.presentation.forward での FrameworkException の使用

jp.co.intra_mart.framework.presentation.forward での FrameworkException のサブクラス
 class ForwardSelectorException
ForwardSelectorに関連する例外です。

jp.co.intra_mart.framework.presentation.validator での FrameworkException の使用

jp.co.intra_mart.framework.presentation.validator での FrameworkException のサブクラス
class | ValidationException 検証結果が不正であるときの例外です。
class | ValidatorException Validatorに関連する例外です。

jp.co.intra_mart.framework.presentation.view での FrameworkException の使用

jp.co.intra_mart.framework.presentation.view での FrameworkException のサブクラス
 class ViewConverterException
ViewConverterに関連する例外です。

jp.co.intra_mart.framework.system.exception での FrameworkException の使用

jp.co.intra_mart.framework.system.exception での FrameworkException のサブクラス
class | ApplicationException フレームワーク内で発生したアプリケーション例外です。
class | IllegalSystemException 想定外の例外が発生したときの例外です。
class | SystemException フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.log での FrameworkException の使用

jp.co.intra_mart.framework.system.log での FrameworkException のサブクラス
 class LogPropertyException
ログプロパティ取得時の例外です。

jp.co.intra_mart.framework.system.property での FrameworkException の使用

jp.co.intra_mart.framework.system.property での FrameworkException のサブクラス
class | PropertyHandlerException プロパティハンドラの情報取得時の例外です。
class | PropertyManagerException プロパティマネージャの設定時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.IllegalSystemException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.IllegalSystemException の使用

jp.co.intra_mart.framework.system.exception.IllegalSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.exception.SystemException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.SystemException の使用

SystemException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.base.data での SystemException の使用

jp.co.intra_mart.framework.base.data での SystemException のサブクラス
class | DAOException リソースコネクタの情報取得時の例外です。
class | DataAccessException データアクセス時の例外です。
class | DataConnectException データ接続に関連する例外です。
class | DataConnectorException データコネクタ取得時の例外です。
class | DataManagerException データマネージャの設定時の例外です。
class | DataPropertyException データプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.event での SystemException の使用

jp.co.intra_mart.framework.base.event での SystemException のサブクラス
class | EventException イベント生成時の例外です。
class | EventListenerException イベントリスナ生成時の例外です。
class | EventManagerException イベントマネージャ設定時の例外です。
class | EventPropertyException イベントプロパティ取得時の例外です。
class | EventTriggerException イベントトリガ生成時の例外です。

SystemException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.message での SystemException の使用

jp.co.intra_mart.framework.base.message での SystemException のサブクラス
class | MessageManagerException サービスマネージャ設定時の例外です。
class | MessagePropertyException メッセージプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.service での SystemException の使用

jp.co.intra_mart.framework.base.service での SystemException のサブクラス
class | ServiceControllerException サービスコントローラに関連する例外です。
class | ServiceManagerException サービスマネージャ設定時の例外です。
class | ServicePropertyException サービスプロパティ取得時の例外です。
class | ServiceServletException サービスに関連する例外です。
class | TransitionException トランジションに関連する例外です。

SystemException をスローする jp.co.intra_mart.framework.base.service のメソッド
MultipartFormData.Entity | Transition.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
abstract void | Transition.transfer() 次のページに遷移します。
MultipartFormData.Entity | ServiceControllerAdapter.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
void | ServiceControllerAdapter.check() 入力内容をチェックします。
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
protected EventResult | ServiceControllerAdapter.dispatchEvent(Event event) イベント処理を実行します。
void | ServiceController.check() 入力内容をチェックします。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。
void | IntramartPageBaseTransition.transfer() ページベースの画面に遷移します。
void | DefaultTransition.transfer() 次のページに遷移します。

jp.co.intra_mart.framework.base.session での SystemException の使用

jp.co.intra_mart.framework.base.session での SystemException のサブクラス
class | IllegalSessionException セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
class | SessionFactoryException セッションファクトリ内の例外です。
class | SessionManagerException セッションマネージャ内の例外です。
class | SessionObjectException セッションオブジェクト内の例外です。
class | SessionPropertyException セッションプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.util での SystemException の使用

jp.co.intra_mart.framework.base.util での SystemException のサブクラス
 class UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean での SystemException の使用

jp.co.intra_mart.framework.base.web.bean での SystemException のサブクラス
 class HelperBeanException
HelperBean内で発生した例外です。

SystemException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.extension.common.util での SystemException の使用

SystemException をスローする jp.co.intra_mart.framework.extension.common.util のメソッド
static String ServiceUtils.getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static String ServiceUtils.getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static UserInfo ServiceUtils.getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
static Event ServiceUtils.createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
static EventResult ServiceUtils.dispatchEvent(Event event)
イベントを実行します。

jp.co.intra_mart.framework.extension.struts.action での SystemException の使用

SystemException をスローする jp.co.intra_mart.framework.extension.struts.action のメソッド
protected  String IntramartAction.getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  String IntramartAction.getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  UserInfo IntramartAction.getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
protected  Event IntramartAction.createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
protected  EventResult IntramartAction.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation での SystemException の使用

jp.co.intra_mart.framework.presentation での SystemException のサブクラス
class | DuplicateException 重複しているときに発生する例外です。
class | MismatchException キーが重複しているときに発生する例外です。
class | NameFormatException 名前が不正であることを示します。
class | PresentationManagerException PresentationManager設定時の例外です。
class | PresentationPropertyException PresentationProperty取得時の例外です。

jp.co.intra_mart.framework.presentation.controller での SystemException の使用

jp.co.intra_mart.framework.presentation.controller での SystemException のサブクラス
class | ControllerConverterException ControllerConverterに関連する例外です。
class | RequestFormatException フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.presentation.forward での SystemException の使用

jp.co.intra_mart.framework.presentation.forward での SystemException のサブクラス
 class ForwardSelectorException
ForwardSelectorに関連する例外です。

jp.co.intra_mart.framework.presentation.validator での SystemException の使用

jp.co.intra_mart.framework.presentation.validator での SystemException のサブクラス
 class ValidatorException
Validatorに関連する例外です。

jp.co.intra_mart.framework.presentation.view での SystemException の使用

jp.co.intra_mart.framework.presentation.view での SystemException のサブクラス
 class ViewConverterException
ViewConverterに関連する例外です。

SystemException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
ViewObject | ViewConverter.convert(RequestInfo info) リクエスト情報をもとにビューオブジェクトを生成します。
protected EventResult | AbstractViewConverter.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.system.exception での SystemException の使用

jp.co.intra_mart.framework.system.exception での SystemException のサブクラス
 class IllegalSystemException
想定外の例外が発生したときの例外です。

jp.co.intra_mart.framework.system.log での SystemException の使用

jp.co.intra_mart.framework.system.log での SystemException のサブクラス
 class LogPropertyException
ログプロパティ取得時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ApplicationException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス ApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BadRequestException, RequestException, TokenInvalidException, ValidationException
public class ApplicationException
extends FrameworkException

フレームワーク内で発生したアプリケーション例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ApplicationException()
詳細メッセージを指定しないで ApplicationException を構築します。
ApplicationException(String msg)
指定された詳細メッセージを持つ ApplicationException を構築します。
ApplicationException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationException(Throwable throwable)
この例外の発生原因となる例外を持つ ApplicationException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ApplicationException

public ApplicationException()
詳細メッセージを指定しないで ApplicationException を構築します。

ApplicationException

public ApplicationException(String msg)
指定された詳細メッセージを持つ ApplicationException を構築します。

パラメータ:
msg - 詳細メッセージ

ApplicationException

public ApplicationException(Throwable throwable)
この例外の発生原因となる例外を持つ ApplicationException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

ApplicationException

public ApplicationException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FrameworkException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス FrameworkException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ApplicationException, PropertyHandlerException, PropertyManagerException, SystemException
public class FrameworkException
extends Exception

フレームワークに共通するの例外のスーパークラスです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkException()
詳細メッセージを指定しないで FrameworkException を構築します。
FrameworkException(String msg)
指定された詳細メッセージを持つ FrameworkException を構築します。
FrameworkException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkException を構築します。
メソッドの概要
Throwable | getException() この例外が発生した原因となる例外を取得します。
void | printStackTrace()
void | printStackTrace(PrintStream printStream)
void | printStackTrace(PrintWriter printWriter)
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkException

public FrameworkException()
詳細メッセージを指定しないで FrameworkException を構築します。

FrameworkException

public FrameworkException(String msg)
指定された詳細メッセージを持つ FrameworkException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkException

public FrameworkException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

FrameworkException

public FrameworkException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
メソッドの詳細

getException

public Throwable getException()
この例外が発生した原因となる例外を取得します。

戻り値:
この例外が発生した原因となる例外

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream printStream)

printStackTrace

public void printStackTrace(PrintWriter printWriter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IllegalSystemException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス IllegalSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.exception.IllegalSystemException
すべての実装インタフェース:
Serializable
public class IllegalSystemException
extends SystemException

想定外の例外が発生したときの例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalSystemException()
詳細メッセージを指定しないで IllegalSystemException を構築します。
IllegalSystemException(String msg)
指定された詳細メッセージを持つ IllegalSystemException を構築します。
IllegalSystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalSystemException

public IllegalSystemException()
詳細メッセージを指定しないで IllegalSystemException を構築します。

IllegalSystemException

public IllegalSystemException(String msg)
指定された詳細メッセージを持つ IllegalSystemException を構築します。

パラメータ:
msg - 詳細メッセージ

IllegalSystemException

public IllegalSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

IllegalSystemException

public IllegalSystemException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.exception (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.system.exception
例外
ApplicationException
FrameworkException
IllegalSystemException
SystemException


jp.co.intra_mart.framework.system.exception (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.exception

J2EEフレームワークの例外に関連するパッケージです。

参照:
説明

例外の概要
ApplicationException | フレームワーク内で発生したアプリケーション例外です。
FrameworkException | フレームワークに共通するの例外のスーパークラスです。
IllegalSystemException | 想定外の例外が発生したときの例外です。
SystemException | フレームワーク内で発生したシステム例外です。

パッケージ jp.co.intra_mart.framework.system.exception の説明

J2EEフレームワークの例外に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.system.exception クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.exception.IllegalSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.system.exception の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.exception の使用

jp.co.intra_mart.framework.system.exception を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.util により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.extension.common.util により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.extension.struts.action により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation.controller により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation.forward により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation.validator により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.exception により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.property により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SystemException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス SystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ControllerConverterException, DAOException, DataAccessException, DataConnectException, DataConnectorException, DataManagerException, DataPropertyException, DuplicateException, EventException, EventListenerException, EventManagerException, EventPropertyException, EventTriggerException, ForwardSelectorException, HelperBeanException, IllegalSessionException, IllegalSystemException, LogPropertyException, MessageManagerException, MessageManagerException, MessagePropertyException, MessagePropertyException, MismatchException, NameFormatException, PresentationManagerException, PresentationPropertyException, RequestFormatException, ServiceControllerException, ServiceManagerException, ServicePropertyException, ServiceServletException, SessionFactoryException, SessionManagerException, SessionObjectException, SessionPropertyException, TransitionException, UserInfoException, ValidatorException, ViewConverterException
public class SystemException
extends FrameworkException

フレームワーク内で発生したシステム例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SystemException()
詳細メッセージを指定しないで SystemException を構築します。
SystemException(String msg)
指定された詳細メッセージを持つ SystemException を構築します。
SystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。
SystemException(Throwable throwable)
この例外の発生原因となる例外を持つ SystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemException

public SystemException()
詳細メッセージを指定しないで SystemException を構築します。

SystemException

public SystemException(String msg)
指定された詳細メッセージを持つ SystemException を構築します。

パラメータ:
msg - 詳細メッセージ

SystemException

public SystemException(Throwable throwable)
この例外の発生原因となる例外を持つ SystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

SystemException

public SystemException(String msg,
                       Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.log.DefaultLogAgent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.DefaultLogAgent の使用

jp.co.intra_mart.framework.system.log.DefaultLogAgent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の使用

jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.IntramartLogAgent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.IntramartLogAgent の使用

jp.co.intra_mart.framework.system.log.IntramartLogAgent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogAgent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogAgent の使用

LogAgent を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogAgent の使用

LogAgent を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogAgent デフォルトのログエージェントです。
class | IntramartLogAgent intra-mart で管理されているログに出力するログエージェントです。

LogAgent を返す jp.co.intra_mart.framework.system.log のメソッド
 LogAgent LogManager.getLogAgent()
ログエージェントを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogAgentParam の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogAgentParam の使用

LogAgentParam を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogAgentParam の使用

LogAgentParam を返す jp.co.intra_mart.framework.system.log のメソッド
LogAgentParam[] | XmlLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
LogAgentParam[] | LogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
LogAgentParam[] | DefaultLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。

LogAgentParam 型のパラメータを持つ jp.co.intra_mart.framework.system.log のメソッド
void | LogAgent.init(LogAgentParam[] params) 初期化します。
void | IntramartLogAgent.init(LogAgentParam[] params) 初期化します。
void | DefaultLogAgent.init(LogAgentParam[] params) 初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogConstant の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogConstant の使用

jp.co.intra_mart.framework.system.log.LogConstant はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogManager の使用

LogManager を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogManager の使用

LogManager を返す jp.co.intra_mart.framework.system.log のメソッド
static LogManager LogManager.getLogManager()
ログマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.LogPropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogPropertyException の使用

LogPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogPropertyException の使用

LogPropertyException をスローする jp.co.intra_mart.framework.system.log のメソッド
String | XmlLogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | XmlLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
String | LogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | LogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
String | DefaultLogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | DefaultLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.log.LogPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogPropertyHandler の使用

LogPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogPropertyHandler の使用

LogPropertyHandler を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogPropertyHandler ログに関連するデフォルトのプロパティハンドラです。
class | XmlLogPropertyHandler リソースからログプロパティ情報を取得するプロパティハンドラです。

LogPropertyHandler を返す jp.co.intra_mart.framework.system.log のメソッド
 LogPropertyHandler LogManager.getLogPropertyHandler()
ログプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の使用

jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DefaultLogAgent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス DefaultLogAgent

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.DefaultLogAgent
すべての実装インタフェース:
LogAgent
public class DefaultLogAgent
extends Object
implements LogAgent

デフォルトのログエージェントです。 標準出力にログを出力します。 出力されるメッセージは以下のような形式になります。
[カテゴリ][レベル]メッセージ

導入されたバージョン:
4.2

コンストラクタの概要
DefaultLogAgent()

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultLogAgent

public DefaultLogAgent()
メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。 このクラスでは実際には何も行われません。

定義:
インタフェース LogAgent 内の init
パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。 このクラスでは通常、messageを標準出力にログとして出力します。 ただし、levelがLogConstant.LEVEL_ERRORである場合は 標準例外出力にログを出力します。

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 このクラスでは通常、messageはそのまま、 detailはObject.toString()の値を標準出力にログとして出力します。 ただし、levelがLogConstant.LEVEL_ERRORである場合は 標準例外出力にログを出力します。

detailがThrowableのサブクラスである場合、 Throwable.printStackTrace(java.io.PrintWriter)を使用して スタックトレースが出力されます。出力先はdetailによる出力先に従います。

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
5.0
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド


DefaultLogPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス DefaultLogPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler
すべての実装インタフェース:
LogPropertyHandler, PropertyHandler
public class DefaultLogPropertyHandler
extends Object
implements LogPropertyHandler

ログに関連するデフォルトのプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

キー | 内容
agent.class | LogAgentのクラス名
agent.param.パラメータ名 | ログエージェントに渡すパラメータ

導入されたバージョン:
4.2

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultLogPropertyHandler()
DefaultLogPropertyHandlerを新規に生成します。
メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultLogPropertyHandler

public DefaultLogPropertyHandler()
DefaultLogPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentName
戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列が返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentParams
戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IntramartLogAgent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス IntramartLogAgent

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.IntramartLogAgent
すべての実装インタフェース:
LogAgent
public class IntramartLogAgent
extends Object
implements LogAgent

intra-mart で管理されているログに出力するログエージェントです。 出力先は intra-mart の設定に依存します。 出力されるメッセージは以下のような形式になります。
[レベル]メッセージ
init(LogAgentParam[])に渡すパラメータは以下のように解釈されます。

パラメータ名 | パラメータの値
カテゴリ | カテゴリの種類

カテゴリの種類にTYPE_DBの値を指定するとデータベースログとして出力されます。

導入されたバージョン:
4.2

フィールドの概要
static String TYPE_DB
          データベースログに出力する場合のカテゴリの種類

コンストラクタの概要
IntramartLogAgent()
          IntramartLogAgentを新規に生成します。

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_DB

public static final String TYPE_DB
データベースログに出力する場合のカテゴリの種類

関連項目:
定数フィールド値
コンストラクタの詳細

IntramartLogAgent

public IntramartLogAgent()
IntramartLogAgentを新規に生成します。

メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。 パラメータで指定されたカテゴリを登録します。

定義:
インタフェース LogAgent 内の init
パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。 levelがLogConstant.LEVEL_ERROR以外の場合はメッセージをintra-martのシステムログとして出力します。 levelがLogConstant.LEVEL_ERRORである場合、 categoryをもとに取得されるカテゴリの種類によって以下のようにさらに出力先が分かれます。
  • カテゴリの種類がTYPE_DBである場合、データベースログとして出力
  • カテゴリの種類がTYPE_DB以外である場合、エラーログとして出力

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 levelがLogConstant.LEVEL_ERROR以外の場合はメッセージをintra-martのシステムログとして出力します。 levelがLogConstant.LEVEL_ERRORである場合、以下のように出力先が異なります。
  • detailがThrowableのインスタンスであり
    • カテゴリがDBに関連するものはデータベースログとして出力
    • カテゴリがDBに関連するもの以外であるときはエラーログとして出力
  • detailがThrowable以外のインスタンスであり
    • 詳細文字列が存在し
      • カテゴリの種類がTYPE_DBである場合データベースログとして詳細ごと出力
      • カテゴリの種類がTYPE_DB以外であるときはエラーログとして詳細ごと出力
    • 詳細文字列が存在しないで
      • カテゴリがDBに関連するものはデータベースログとして詳細なしで出力
      • カテゴリがDBに関連するもの以外であるときはエラーログとして詳細なしで出力

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
5.0
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド


LogAgent (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogAgent

既知の実装クラスの一覧:
DefaultLogAgent, IntramartLogAgent
public interface LogAgent

ログに出力するエージェントです。 im-J2EE Framework から出るログの出力先を変更したい場合、 このインタフェースを実装したクラスを設定します。

導入されたバージョン:
4.2

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。

パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。

パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 詳細な情報が添付されたメッセージを出力します。

パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogAgentParam (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogAgentParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.log.LogAgentParam
public class LogAgentParam
extends PropertyParam

ログエージェントの初期パラメータです。

導入されたバージョン:
4.2

コンストラクタの概要
LogAgentParam()
LogAgentParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LogAgentParam

public LogAgentParam()
LogAgentParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogConstant (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogConstant

public interface LogConstant

ログフレームワークで使用される定数値です。

導入されたバージョン:
4.2

フィールドの概要
static String | LEVEL_DEBUG DEBUG時に出力するレベルです。
static String | LEVEL_ERROR 例外を出力するレベルです。
static String | LEVEL_INFO 情報を出力するレベルです。
static String | LEVEL_WARNNING 警告を出力するレベルです。

フィールドの詳細

LEVEL_DEBUG

public static final String LEVEL_DEBUG
DEBUG時に出力するレベルです。

関連項目:
定数フィールド値

LEVEL_INFO

public static final String LEVEL_INFO
情報を出力するレベルです。

関連項目:
定数フィールド値

LEVEL_WARNNING

public static final String LEVEL_WARNNING
警告を出力するレベルです。

関連項目:
定数フィールド値

LEVEL_ERROR

public static final String LEVEL_ERROR
例外を出力するレベルです。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.LogManager
public class LogManager
extends Object

ログマネージャです。

導入されたバージョン:
4.2

フィールドの概要
static String LOG_PROPERTY_HANDLER_KEY
ログプロパティハンドラのキー
メソッドの概要
LogAgent | getLogAgent() ログエージェントを取得します。
static LogManager | getLogManager() ログマネージャを取得します。
LogPropertyHandler | getLogPropertyHandler() ログプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LOG_PROPERTY_HANDLER_KEY

public static final String LOG_PROPERTY_HANDLER_KEY
ログプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getLogManager

public static LogManager getLogManager()
ログマネージャを取得します。

戻り値:
ログマネージャ

getLogPropertyHandler

public LogPropertyHandler getLogPropertyHandler()
ログプロパティハンドラを取得します。

戻り値:
ログプロパティハンドラ

getLogAgent

public LogAgent getLogAgent()
ログエージェントを取得します。

戻り値:
ログエージェント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogPropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.log.LogPropertyException
すべての実装インタフェース:
Serializable
public class LogPropertyException
extends SystemException

ログプロパティ取得時の例外です。

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
LogPropertyException()
詳細メッセージを指定しないで LogPropertyException を構築します。
LogPropertyException(String msg)
指定された詳細メッセージを持つ LogPropertyException を構築します。
LogPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LogPropertyException

public LogPropertyException()
詳細メッセージを指定しないで LogPropertyException を構築します。

LogPropertyException

public LogPropertyException(String msg)
指定された詳細メッセージを持つ LogPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

LogPropertyException

public LogPropertyException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LogPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultLogPropertyHandler, XmlLogPropertyHandler
public interface LogPropertyHandler
extends PropertyHandler

ログフレームワークで使用するプロパティハンドラです。

導入されたバージョン:
4.2

メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullを返すように実装する必要があります。

戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列を返すように実装する必要があります。

戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.log (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.system.log
インタフェース
LogAgent
LogConstant
LogPropertyHandler
クラス
DefaultLogAgent
DefaultLogPropertyHandler
IntramartLogAgent
LogAgentParam
LogManager
XmlLogPropertyHandler
例外
LogPropertyException


jp.co.intra_mart.framework.system.log (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.log

J2EEフレームワークのログに関連するパッケージです。

参照:
説明

インタフェースの概要
LogAgent | ログに出力するエージェントです。
LogConstant | ログフレームワークで使用される定数値です。
LogPropertyHandler | ログフレームワークで使用するプロパティハンドラです。

クラスの概要
DefaultLogAgent | デフォルトのログエージェントです。
DefaultLogPropertyHandler | ログに関連するデフォルトのプロパティハンドラです。
IntramartLogAgent | intra-mart で管理されているログに出力するログエージェントです。
LogAgentParam | ログエージェントの初期パラメータです。
LogManager | ログマネージャです。
XmlLogPropertyHandler | リソースからログプロパティ情報を取得するプロパティハンドラです。

例外の概要
LogPropertyException ログプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.system.log の説明

J2EEフレームワークのログに関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.system.log クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.log の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.log.DefaultLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.IntramartLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.LogManager
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.log.LogAgentParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.log.LogPropertyException
    • class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.log.LogAgent
  • interface jp.co.intra_mart.framework.system.log.LogConstant
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.system.log.LogPropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.system.log の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.log の使用

jp.co.intra_mart.framework.system.log を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.log のクラス
LogAgent
ログに出力するエージェントです。
LogAgentParam
ログエージェントの初期パラメータです。
LogManager
ログマネージャです。
LogPropertyException
ログプロパティ取得時の例外です。
LogPropertyHandler
ログフレームワークで使用するプロパティハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


XmlLogPropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス XmlLogPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler
すべての実装インタフェース:
LogPropertyHandler, PropertyHandler
public class XmlLogPropertyHandler
extends Object
implements LogPropertyHandler

リソースからログプロパティ情報を取得するプロパティハンドラです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのXMLファイル名
static String | DEFAULT_BUNDLE_NAME_PARAM XMLファイル名のパラメータ名
コンストラクタの概要
XmlLogPropertyHandler()
XMLLogPropertyHandlerを新規に生成します。
メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのXMLファイル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
XMLファイル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlLogPropertyHandler

public XmlLogPropertyHandler()
XMLLogPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentName
戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列が返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentParams
戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の使用

jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler の使用

jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessageManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.framework.system.message のメソッド
static MessageManager MessageManager.getMessageManager()
MessageManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessageManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessageManagerException の使用

MessageManagerException を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessageManagerException の使用

MessageManagerException をスローする jp.co.intra_mart.framework.system.message のメソッド
static MessageManager MessageManager.getMessageManager()
MessageManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessagePropertyException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessagePropertyException の使用

jp.co.intra_mart.framework.system.message.MessagePropertyException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.message.MessagePropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.message.MessagePropertyHandler の使用

MessagePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessagePropertyHandler の使用

MessagePropertyHandler を返す jp.co.intra_mart.framework.system.message のメソッド
 MessagePropertyHandler MessageManager.getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.message.MessagePropertyParam の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessagePropertyParam の使用

jp.co.intra_mart.framework.system.message.MessagePropertyParam はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DefaultMessagePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス DefaultMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class DefaultMessagePropertyHandler
extends Object
implements MessagePropertyHandler

デフォルトのメッセージプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 getMessage(String)を使用してください。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultMessagePropertyHandler

public DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。 プロパティの設定内容は以下のとおりです。
キー | 内容
ログイングループID.キー | ログイングループIDとキーに対応するメッセージ

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。 プロパティの設定内容は以下のとおりです。
キー | 内容
キー | キーに対応するメッセージ

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IntramartMessagePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス IntramartMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class IntramartMessagePropertyHandler
extends Object
implements MessagePropertyHandler

イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。

バージョン:
1.0

コンストラクタの概要
IntramartMessagePropertyHandler()
IntramartMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 パラメータloginGroupは実際には使用しません。getMessage(String)を使用してください。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartMessagePropertyHandler

public IntramartMessagePropertyHandler()
IntramartMessagePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.MessageManager
public class MessageManager
extends Object

メッセージを制御します。

バージョン:
1.0

フィールドの概要
static String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。getMessage(String)を使用してください。
static MessageManager | getMessageManager() MessageManagerを取得します。
MessagePropertyHandler | getMessagePropertyHandler() メッセージプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MESSAGE_PROPERTY_HANDLER_KEY

public static final String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getMessageManager

public static MessageManager getMessageManager()
                                        throws MessageManagerException
MessageManagerを取得します。

戻り値:
メッセージマネージャ
例外:
MessageManagerException - メッセージマネージャの取得時に例外が発生

getMessagePropertyHandler

public MessagePropertyHandler getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

戻り値:
メッセージプロパティハンドラ

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 キーがnullの場合、またはキーに該当するメッセージが存在しない場合、空文字列を返します。

パラメータ:
key - キー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 キーがnullの場合、またはキーに該当するメッセージが存在しない場合、空文字列を返します。

パラメータ:
key - キー
戻り値:
メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessageManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.message.MessageManagerException
すべての実装インタフェース:
Serializable
public class MessageManagerException
extends SystemException

メッセージマネージャに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessageManagerException

public MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。

MessageManagerException

public MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

MessageManagerException

public MessageManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessagePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.message.MessagePropertyException
すべての実装インタフェース:
Serializable
public class MessagePropertyException
extends SystemException

メッセージプロパティハンドラに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessagePropertyException

public MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。

MessagePropertyException

public MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

MessagePropertyException

public MessagePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
インタフェース MessagePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultMessagePropertyHandler, IntramartMessagePropertyHandler
public interface MessagePropertyHandler
extends PropertyHandler

メッセージに関連するプロパティを取得します。

バージョン:
1.0

メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 getMessage(String)を使用してください。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MessagePropertyParam (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessagePropertyParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.message.MessagePropertyParam
public class MessagePropertyParam
extends PropertyParam

メッセージプロパティハンドラの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
MessagePropertyParam()
MessagePropertyParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MessagePropertyParam

public MessagePropertyParam()
MessagePropertyParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.message (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.system.message
インタフェース
MessagePropertyHandler
クラス
DefaultMessagePropertyHandler
IntramartMessagePropertyHandler
MessageManager
MessagePropertyParam
例外
MessageManagerException
MessagePropertyException


jp.co.intra_mart.framework.system.message (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.message

メッセージに関連するパッケージです。

参照:
説明

インタフェースの概要
MessagePropertyHandler メッセージに関連するプロパティを取得します。

クラスの概要
DefaultMessagePropertyHandler | デフォルトのメッセージプロパティハンドラです。
IntramartMessagePropertyHandler | イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。
MessageManager | メッセージを制御します。
MessagePropertyParam | メッセージプロパティハンドラの初期パラメータです。

例外の概要
MessageManagerException | メッセージマネージャに関連する例外です。
MessagePropertyException | メッセージプロパティハンドラに関連する例外です。

パッケージ jp.co.intra_mart.framework.system.message の説明

メッセージに関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.system.message クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.MessageManager
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.message.MessagePropertyParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.message.MessageManagerException
            • class jp.co.intra_mart.framework.system.message.MessagePropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.system.message の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.message の使用

jp.co.intra_mart.framework.system.message を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message により使用される jp.co.intra_mart.framework.system.message のクラス
MessageManager
メッセージを制御します。
MessageManagerException
メッセージマネージャに関連する例外です。
MessagePropertyHandler
メッセージに関連するプロパティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.DefaultPropertyManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.DefaultPropertyManager の使用

jp.co.intra_mart.framework.system.property.DefaultPropertyManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyConfigModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyConfigModel の使用

jp.co.intra_mart.framework.system.property.PropertyConfigModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.property.PropertyHandler の使用

PropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyHandler の使用

jp.co.intra_mart.framework.base.data での PropertyHandler のサブインタフェース
 interface DataPropertyHandler
DAOの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.data のクラス
class | DefaultDataPropertyHandler デフォルトのデータプロパティハンドラです。
class | DistributesDataPropertyHandler アプリケーション毎のプロパティハンドラを呼び出します。
class | TextFileDataPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlDataPropertyHandler XMLのデータプロパティハンドラです。

jp.co.intra_mart.framework.base.event での PropertyHandler の使用

jp.co.intra_mart.framework.base.event での PropertyHandler のサブインタフェース
 interface EventPropertyHandler
イベントの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.event のクラス
class | DefaultEventPropertyHandler デフォルトのEventPropertyHandlerです。
class | DistributesEventPropertyHandler アプリケーション毎のEventPropertyHandlerを呼び出します。
class | TextFileEventPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlEventPropertyHandler XMLのEventPropertyHandlerです。

jp.co.intra_mart.framework.base.message での PropertyHandler の使用

jp.co.intra_mart.framework.base.message での PropertyHandler のサブインタフェース
 interface MessagePropertyHandler
メッセージの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.message のクラス
class | DefaultMessagePropertyHandler メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
class | TextFileMessagePropertyHandler 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

jp.co.intra_mart.framework.base.service での PropertyHandler の使用

jp.co.intra_mart.framework.base.service での PropertyHandler のサブインタフェース
 interface ServicePropertyHandler
サービスの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.service のクラス
class | DefaultServicePropertyHandler サービスの設定情報に接続するデフォルトのプロパティハンドラです。
class | DistributesServicePropertyHandler アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
class | TextFileServicePropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlServicePropertyHandler サービスの設定情報に接続するプロパティハンドラです。

jp.co.intra_mart.framework.base.session での PropertyHandler の使用

jp.co.intra_mart.framework.base.session での PropertyHandler のサブインタフェース
 interface SessionPropertyHandler
セッションに関連するプロパティを取得します。

PropertyHandler を実装している jp.co.intra_mart.framework.base.session のクラス
class | DefaultSessionPropertyHandler セッションに関連するデフォルトのプロパティハンドラです。
class | XmlSessionPropertyHandler セッションに関連するXMLのプロパティハンドラです。

jp.co.intra_mart.framework.presentation での PropertyHandler の使用

jp.co.intra_mart.framework.presentation での PropertyHandler のサブインタフェース
 interface PresentationPropertyHandler
プレゼンテーションフレームワークのプロパティ設定のハンドラです。

jp.co.intra_mart.framework.system.log での PropertyHandler の使用

jp.co.intra_mart.framework.system.log での PropertyHandler のサブインタフェース
 interface LogPropertyHandler
ログフレームワークで使用するプロパティハンドラです。

PropertyHandler を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogPropertyHandler ログに関連するデフォルトのプロパティハンドラです。
class | XmlLogPropertyHandler リソースからログプロパティ情報を取得するプロパティハンドラです。

jp.co.intra_mart.framework.system.message での PropertyHandler の使用

PropertyHandler を実装している jp.co.intra_mart.framework.system.message のクラス
 class IntramartMessagePropertyHandler
イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。

jp.co.intra_mart.framework.system.property での PropertyHandler の使用

PropertyHandler を返す jp.co.intra_mart.framework.system.property のメソッド
 PropertyHandler PropertyManager.getPropertyHandler(String key)
キーで指定されたプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyHandlerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyHandlerException の使用

PropertyHandlerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.data のメソッド
void | XmlDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.event での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.event のメソッド
void | XmlEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.message での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.message のメソッド
void | TextFileMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.service での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.service のメソッド
void | XmlServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.session での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.session のメソッド
void | XmlSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.log での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.log のメソッド
void | XmlLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.message での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.message のメソッド
void | IntramartMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.property での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.property のメソッド
protected String | XmlPropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected abstract String | PropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
PropertyHandler | PropertyManager.getPropertyHandler(String key) キーで指定されたプロパティハンドラを取得します。
void | PropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
protected String | DefaultPropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyHandlerParam の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyHandlerParam の使用

PropertyHandlerParam を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyHandlerParam の使用

PropertyHandlerParam を返す jp.co.intra_mart.framework.system.property のメソッド
protected PropertyHandlerParam[] | XmlPropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
protected abstract PropertyHandlerParam[] | PropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
protected PropertyHandlerParam[] | PropertyConfigModel.getPropertyParams(String key) 指定されたキーのプロパティのパラメータを取得します。
protected PropertyHandlerParam[] | DefaultPropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyManager の使用

PropertyManager を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyManager の使用

jp.co.intra_mart.framework.system.property での PropertyManager のサブクラス
class | DefaultPropertyManager デフォルトのプロパティマネージャです。
class | XmlPropertyManager xmlのプロパティマネージャです。

PropertyManager を返す jp.co.intra_mart.framework.system.property のメソッド
static PropertyManager PropertyManager.getPropertyManager()
プロパティマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyManagerException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyManagerException の使用

PropertyManagerException を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyManagerException の使用

PropertyManagerException をスローする jp.co.intra_mart.framework.system.property のメソッド
static PropertyManager PropertyManager.getPropertyManager()
プロパティマネージャを取得します。

PropertyManagerException をスローする jp.co.intra_mart.framework.system.property のコンストラクタ
XmlPropertyManager()
コンストラクタです。
DefaultPropertyManager()
コンストラクタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyModel の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyModel の使用

jp.co.intra_mart.framework.system.property.PropertyModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.PropertyParam の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyParam の使用

PropertyParam を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyParam の使用

jp.co.intra_mart.framework.base.data での PropertyParam のサブクラス
 class ResourceParam
データコネクタの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
void | XmlDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.event での PropertyParam の使用

jp.co.intra_mart.framework.base.event での PropertyParam のサブクラス
 class EventListenerFactoryParam
イベントリスナファクトリの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
void | XmlEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.message での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.message のメソッド
void | TextFileMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.service での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
void | XmlServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.session での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.session のメソッド
void | XmlSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.web.tag での PropertyParam の使用

jp.co.intra_mart.framework.base.web.tag での PropertyParam のサブクラス
 class FrameworkTagParam
タグに追加されるパラメータです。

jp.co.intra_mart.framework.system.log での PropertyParam の使用

jp.co.intra_mart.framework.system.log での PropertyParam のサブクラス
 class LogAgentParam
ログエージェントの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.log のメソッド
void | XmlLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.message での PropertyParam の使用

jp.co.intra_mart.framework.system.message での PropertyParam のサブクラス
 class MessagePropertyParam
メッセージプロパティハンドラの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.message のメソッド
void | IntramartMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.property での PropertyParam の使用

jp.co.intra_mart.framework.system.property での PropertyParam のサブクラス
 class PropertyHandlerParam
プロパティハンドラを生成する時の初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.property のメソッド
 void PropertyHandler.init(PropertyParam[] params)
プロパティハンドラを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.system.property.XmlPropertyManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.XmlPropertyManager の使用

jp.co.intra_mart.framework.system.property.XmlPropertyManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


DefaultPropertyManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス DefaultPropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
        拡張 jp.co.intra_mart.framework.system.property.DefaultPropertyManager
public class DefaultPropertyManager
extends PropertyManager

デフォルトのプロパティマネージャです。 リソースバンドルで設定されたプロパティ情報を管理します。 プロパティ情報のリソースバンドルは以下の順番で決定されます。

 1.システムプロパティKEYで設定されているリソースバンドル
 2.デフォルトのプロパティマネージャDEFAULT_BUNDLE_NAMEで設定されているリソースバンドル

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | KEY プロパティマネージャを指定するキー
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したフィールド
DEFAULT_SYSTEM_MANAGER
コンストラクタの概要
DefaultPropertyManager()
コンストラクタです。
メソッドの概要
protected String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したメソッド
getPropertyHandler, getPropertyManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultPropertyManager

public DefaultPropertyManager()
                       throws PropertyManagerException
コンストラクタです。

例外:
PropertyManagerException - プロパティマネージャの設定に失敗
メソッドの詳細

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
                                 throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

定義:
クラス PropertyManager 内の getPropertyHandlerName
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - クラス名の取得に失敗

getPropertyHandlerParams

protected PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

定義:
クラス PropertyManager 内の getPropertyHandlerParams
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.system.property (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.framework.system.property
インタフェース
PropertyHandler
クラス
DefaultPropertyManager
PropertyConfigModel
PropertyHandlerParam
PropertyManager
PropertyModel
PropertyParam
XmlPropertyManager
例外
PropertyHandlerException
PropertyManagerException


jp.co.intra_mart.framework.system.property (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.property

プロパティ取得に関連するパッケージです。

参照:
説明

インタフェースの概要
PropertyHandler プロパティにアクセスするインタフェースです。

クラスの概要
DefaultPropertyManager | デフォルトのプロパティマネージャです。
PropertyConfigModel | データモデルクラスです。
PropertyHandlerParam | プロパティハンドラを生成する時の初期パラメータです。
PropertyManager | システム設定の情報を管理します。
PropertyModel | プロパティモデルクラスです。
PropertyParam | プロパティのパラメータを表現する汎用的なクラスです。
XmlPropertyManager | xmlのプロパティマネージャです。

例外の概要
PropertyHandlerException | プロパティハンドラの情報取得時の例外です。
PropertyManagerException | プロパティマネージャの設定時の例外です。

パッケージ jp.co.intra_mart.framework.system.property の説明

プロパティ取得に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


jp.co.intra_mart.framework.system.property クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.property.PropertyConfigModel
    • class jp.co.intra_mart.framework.system.property.PropertyManager
      • class jp.co.intra_mart.framework.system.property.DefaultPropertyManager
      • class jp.co.intra_mart.framework.system.property.XmlPropertyManager
    • class jp.co.intra_mart.framework.system.property.PropertyModel
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.property.PropertyHandlerParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.property.PropertyHandlerException
          • class jp.co.intra_mart.framework.system.property.PropertyManagerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0


パッケージ jp.co.intra_mart.framework.system.property の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.property の使用

jp.co.intra_mart.framework.system.property を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.web.tag により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.message により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.property により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyHandlerParam
プロパティハンドラを生成する時の初期パラメータです。
PropertyManager
システム設定の情報を管理します。
PropertyManagerException
プロパティマネージャの設定時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PropertyConfigModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyConfigModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyConfigModel
public class PropertyConfigModel
extends Object

データモデルクラスです。

バージョン:
1.0

コンストラクタの概要
PropertyConfigModel()
メソッドの概要
protected String | getPropertyHandlerName(String key) 指定されたキーのプロパティハンドラ名を取得します。
protected PropertyHandlerParam[] | getPropertyParams(String key) 指定されたキーのプロパティのパラメータを取得します。
protected void | setProperties(Map map) パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyConfigModel

public PropertyConfigModel()
メソッドの詳細

setProperties

protected void setProperties(Map map)
パラメータを設定します。

パラメータ:
map -

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
指定されたキーのプロパティハンドラ名を取得します。

戻り値:
String

getPropertyParams

protected PropertyHandlerParam[] getPropertyParams(String key)
指定されたキーのプロパティのパラメータを取得します。

戻り値:
PropertyParam[]
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
インタフェース PropertyHandler

既知のサブインタフェースの一覧:
DataPropertyHandler, EventPropertyHandler, LogPropertyHandler, MessagePropertyHandler, MessagePropertyHandler, PresentationPropertyHandler, ServicePropertyHandler, SessionPropertyHandler
既知の実装クラスの一覧:
DefaultDataPropertyHandler, DefaultEventPropertyHandler, DefaultLogPropertyHandler, DefaultMessagePropertyHandler, DefaultMessagePropertyHandler, DefaultServicePropertyHandler, DefaultSessionPropertyHandler, DistributesDataPropertyHandler, DistributesEventPropertyHandler, DistributesServicePropertyHandler, IntramartMessagePropertyHandler, TextFileDataPropertyHandler, TextFileEventPropertyHandler, TextFileMessagePropertyHandler, TextFileServicePropertyHandler, XmlDataPropertyHandler, XmlEventPropertyHandler, XmlLogPropertyHandler, XmlServicePropertyHandler, XmlSessionPropertyHandler
public interface PropertyHandler

プロパティにアクセスするインタフェースです。 このインタフェースを実装するすべてのクラスは、引数なしのコンストラクタが必要です。

バージョン:
1.0

メソッドの概要
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyHandlerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyHandlerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.property.PropertyHandlerException
すべての実装インタフェース:
Serializable
public class PropertyHandlerException
extends FrameworkException

プロパティハンドラの情報取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PropertyHandlerException()
詳細メッセージを指定しないで PropertyHandlerException を構築します。
PropertyHandlerException(String msg)
指定された詳細メッセージを持つ PropertyHandlerException を構築します。
PropertyHandlerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertyHandlerException

public PropertyHandlerException()
詳細メッセージを指定しないで PropertyHandlerException を構築します。

PropertyHandlerException

public PropertyHandlerException(String msg)
指定された詳細メッセージを持つ PropertyHandlerException を構築します。

パラメータ:
msg - 詳細メッセージ

PropertyHandlerException

public PropertyHandlerException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyHandlerParam (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyHandlerParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.property.PropertyHandlerParam
public class PropertyHandlerParam
extends PropertyParam

プロパティハンドラを生成する時の初期パラメータです。

バージョン:
1.0

コンストラクタの概要
PropertyHandlerParam()
PropertyHandlerParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyHandlerParam

public PropertyHandlerParam()
PropertyHandlerParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
直系の既知のサブクラス:
DefaultPropertyManager, XmlPropertyManager
public abstract class PropertyManager
extends Object

システム設定の情報を管理します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_SYSTEM_MANAGER デフォルトのプロパティマネージャクラス
static String | KEY プロパティマネージャを指定するキー
コンストラクタの概要
protected PropertyManager()
プロパティマネージャのコンストラクタです。
メソッドの概要
PropertyHandler | getPropertyHandler(String key) キーで指定されたプロパティハンドラを取得します。
protected abstract String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected abstract PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
static PropertyManager | getPropertyManager() プロパティマネージャを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_SYSTEM_MANAGER

public static final String DEFAULT_SYSTEM_MANAGER
デフォルトのプロパティマネージャクラス

関連項目:
定数フィールド値
コンストラクタの詳細

PropertyManager

protected PropertyManager()
プロパティマネージャのコンストラクタです。 コンストラクタの明示的な使用はできません。

メソッドの詳細

getPropertyManager

public static PropertyManager getPropertyManager()
                                          throws PropertyManagerException
プロパティマネージャを取得します。 プロパティマネージャは常に１つだけ存在します。 プロパティマネージャが未設定の状態でこのメソッドが呼ばれた場合、以下の順番でプロパティマネージャを取得します。
 1.システムプロパティKEYで設定されているプロパティマネージャ
 2.デフォルトのプロパティマネージャ

戻り値:
プロパティマネージャ
例外:
PropertyManagerException - プロパティマネージャの設定時に発生する例外

getPropertyHandlerName

protected abstract String getPropertyHandlerName(String key)
                                          throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - プロパティハンドラのクラス名を取得できなかった場合に発生する例外

getPropertyHandlerParams

protected abstract PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ

getPropertyHandler

public PropertyHandler getPropertyHandler(String key)
                                   throws PropertyHandlerException
キーで指定されたプロパティハンドラを取得します。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラ
例外:
PropertyHandlerException - プロパティハンドラの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyManagerException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.property.PropertyManagerException
すべての実装インタフェース:
Serializable
public class PropertyManagerException
extends FrameworkException

プロパティマネージャの設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PropertyManagerException()
詳細メッセージを指定しないで PropertyManagerException を構築します。
PropertyManagerException(String msg)
指定された詳細メッセージを持つ PropertyManagerException を構築します。
PropertyManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertyManagerException

public PropertyManagerException()
詳細メッセージを指定しないで PropertyManagerException を構築します。

PropertyManagerException

public PropertyManagerException(String msg)
指定された詳細メッセージを持つ PropertyManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

PropertyManagerException

public PropertyManagerException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PropertyModel (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyModel
public class PropertyModel
extends Object

プロパティモデルクラスです。

バージョン:
1.0

コンストラクタの概要
PropertyModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyModel

public PropertyModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PropertyParam (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
直系の既知のサブクラス:
EventListenerFactoryParam, FrameworkTagParam, LogAgentParam, MessagePropertyParam, PropertyHandlerParam, ResourceParam
public class PropertyParam
extends Object

プロパティのパラメータを表現する汎用的なクラスです。 このクラスのインスタンス１つがパラメータ名とパラメータの値という１つのペアに対応します。

バージョン:
1.0

コンストラクタの概要
PropertyParam()
PropertyParamを新規に生成します。
メソッドの概要
String | getName() パラメータ名を取得します。
String | getValue() パラメータの値を取得します。
void | setName(String name) パラメータ名を設定します。
void | setValue(String value) パラメータの値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyParam

public PropertyParam()
PropertyParamを新規に生成します。

メソッドの詳細

setName

public void setName(String name)
パラメータ名を設定します。

パラメータ:
name - パラメータ名

getName

public String getName()
パラメータ名を取得します。

戻り値:
パラメータ名

setValue

public void setValue(String value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値

getValue

public String getValue()
パラメータの値を取得します。

戻り値:
パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XmlPropertyManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス XmlPropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
        拡張 jp.co.intra_mart.framework.system.property.XmlPropertyManager
public class XmlPropertyManager
extends PropertyManager

xmlのプロパティマネージャです。 プロパティ情報を管理します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | KEY プロパティマネージャを指定するキー
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したフィールド
DEFAULT_SYSTEM_MANAGER
コンストラクタの概要
XmlPropertyManager()
コンストラクタです。
メソッドの概要
protected String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したメソッド
getPropertyHandler, getPropertyManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlPropertyManager

public XmlPropertyManager()
                   throws PropertyManagerException
コンストラクタです。

例外:
PropertyManagerException - プロパティマネージャの設定に失敗
メソッドの詳細

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
                                 throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

定義:
クラス PropertyManager 内の getPropertyHandlerName
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - クラス名の取得に失敗

getPropertyHandlerParams

protected PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

定義:
クラス PropertyManager 内の getPropertyHandlerParams
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.jssp.net.GenericURLBuilder の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.jssp.net.GenericURLBuilder の使用

GenericURLBuilder を使用しているパッケージ
jp.co.intra_mart.jssp.net

jp.co.intra_mart.jssp.net での GenericURLBuilder の使用

jp.co.intra_mart.jssp.net での GenericURLBuilder のサブクラス
 class URLBuilder
ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.jssp.net.URLBuilder の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.jssp.net.URLBuilder の使用

jp.co.intra_mart.jssp.net.URLBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


GenericURLBuilder (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.jssp.net
クラス GenericURLBuilder

java.lang.Object
    拡張 jp.co.intra_mart.jssp.net.GenericURLBuilder
直系の既知のサブクラス:
URLBuilder
public class GenericURLBuilder
extends Object

ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。

このクラスを利用する事により、 ページベース開発モデルの画面へアクセスする URL を作成できます。 また、このクラスが生成する URL は、セッションチェック機能を持ったものに なるため、異なるセッションに対して生成された URL を用いてアクセスすると、 セッションエラーとなります。 つまり、このクラスが生成する URL は、セキュリティの強固なリンクとなります。

以下は「sample/example/string/main」を呼び出すためのURLを作成するサンプルコードです。

 HttpServletRequest request   = ... ;
 HttpServletResponse response = ... ;

 GenericURLBuilder urlBuilder = new GenericURLBuilder(request, response);
 URL urlContext = jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.getContextURL(request);

 URL url = urlBuilder.createURL(urlContext, "sample/example/string/main");
 String urlString = url.toExternalForm();

 URL sessionURL = new URL(response.encodeURL(urlString));
 String pageURL = sessionURL.toExternalForm();

バージョン:
Version 5.0

コンストラクタの概要
GenericURLBuilder(HttpServletRequest request, HttpServletResponse response)
新しいビルダを作成します。
メソッドの概要
String | createFilePath(String path) 指定のページパスからリンクの為のページパスを作成して返します。
URL | createURL(String path) 現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。
URL | createURL(URL context, String path) 指定の URL を仕様解析のコンテキストとして ページベース開発モデルの画面への URL を解決した URL を返します。
protected HttpServletRequest | getRequest() 現在のリクエストを返します。
protected HttpServletResponse | getResponse() 現在のレスポンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericURLBuilder

public GenericURLBuilder(HttpServletRequest request,
                         HttpServletResponse response)
新しいビルダを作成します。

このオブジェクトでは、指定のリクエストおよびレスポンスにを利用して、 ページベース開発モデルの画面へリンクするための情報を操作します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
NullPointerException - 引数が null
メソッドの詳細

getRequest

protected HttpServletRequest getRequest()
現在のリクエストを返します。 返すリクエストは、コンストラクタの引数に渡されたリクエストです。

戻り値:
リクエスト

getResponse

protected HttpServletResponse getResponse()
現在のレスポンスを返します。 返すレスポンスは、コンストラクタの引数に渡されたレスポンスです。

戻り値:
レスポンス

createURL

public URL createURL(String path)
              throws MalformedURLException
現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。

現在のリクエストを生成するのに使用した URL をコンテキストＵＲＬとして 絶対形式のＵＲＬを自動解決します。 コンテキストＵＲＬを任意に指定したい場合は、 createURL(URL context, String path)を利用してください。

パラメータ:
path - ページベース開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createURL

public URL createURL(URL context,
                     String path)
              throws MalformedURLException
指定の URL を仕様解析のコンテキストとして ページベース開発モデルの画面への URL を解決した URL を返します。

このメソッドは、以下の動作と同じです。
new java.net.URL(context, this.createURL(path))

パラメータ:
context - 仕様を解析するコンテキスト
path - ページベース開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createFilePath

public String createFilePath(String path)
指定のページパスからリンクの為のページパスを作成して返します。

パラメータ:
path - ページベース開発モデルの画面プログラムのパス
戻り値:
リンクの為のパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.jssp.net (5.0 J2EE-Base Programing Model API Specifications)

 jp.co.intra_mart.jssp.net
クラス
GenericURLBuilder
URLBuilder


jp.co.intra_mart.jssp.net (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.jssp.net

クラスの概要
GenericURLBuilder | ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。
URLBuilder | ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.jssp.net クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.jssp.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.jssp.net.GenericURLBuilder
      • class jp.co.intra_mart.jssp.net.URLBuilder
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.jssp.net の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.jssp.net の使用

jp.co.intra_mart.jssp.net を使用しているパッケージ
jp.co.intra_mart.jssp.net

jp.co.intra_mart.jssp.net により使用される jp.co.intra_mart.jssp.net のクラス
GenericURLBuilder
ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


URLBuilder (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.jssp.net
クラス URLBuilder

java.lang.Object
    拡張 jp.co.intra_mart.jssp.net.GenericURLBuilder
        拡張 jp.co.intra_mart.jssp.net.URLBuilder
public class URLBuilder
extends GenericURLBuilder

ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。

このクラスを利用する事により、セッションを維持したまま ページベース開発モデルの画面へリンクさせる事ができます。 また、このクラスが生成する URL は、セッションチェック機能を持ったものに なるため、異なるセッションに対して生成された URL を用いてアクセスすると、 セッションエラーとなります。 つまり、このクラスが生成する URL は、セキュリティの強固なリンクとなります。

以下は「sample/example/string/main」を呼び出すためのURLを作成するサンプルコードです。

 HttpServletRequest request   = ... ;
 HttpServletResponse response = ... ;

 URLBuilder urlBuilder = new URLBuilder(request, response);
 URL urlContext = jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.getContextURL(request);

 URL sessionURL = urlBuilder.createURLonSession(urlContext, "sample/example/string/main");
 String pageURL = sessionURL.toExternalForm();

バージョン:
Version 5.0

コンストラクタの概要
URLBuilder(HttpServletRequest request, HttpServletResponse response)
新しいビルダを作成します。
メソッドの概要
URL | createURLonSession(String path) HTTP セッションを維持したまま指定のページベース開発モデルの画面へ リンクするための URL を返します。
URL | createURLonSession(URL context, String path) HTTP セッションを維持したまま指定のページベース開発モデルの画面へ リンクするための URL を返します。
クラス jp.co.intra_mart.jssp.net.GenericURLBuilder から継承したメソッド
createFilePath, createURL, createURL, getRequest, getResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLBuilder

public URLBuilder(HttpServletRequest request,
                  HttpServletResponse response)
新しいビルダを作成します。

このオブジェクトでは、指定のリクエストおよびレスポンスにを利用して、 ページベース開発モデルの画面へリンクするための情報を操作します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
NullPointerException - 引数が null
メソッドの詳細

createURLonSession

public URL createURLonSession(String path)
                       throws MalformedURLException
HTTP セッションを維持したまま指定のページベース開発モデルの画面へ リンクするための URL を返します。

このメソッドは、 GenericURLBuilder.createURL(String path)が返す URL に対して、 HttpServletResponse.encodeURL(String url)を 実行した結果を返します。

パラメータ:
path - ページベース開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合

createURLonSession

public URL createURLonSession(URL context,
                              String path)
                       throws MalformedURLException
HTTP セッションを維持したまま指定のページベース開発モデルの画面へ リンクするための URL を返します。

このメソッドは、 GenericURLBuilder.createURL(URL context, String path)が返す URL に対して、 HttpServletResponse.encodeURL(String url)を 実行した結果を返します。

なお、このメソッドの引数 context の生成に便利なユーティリティクラス URLUtilが存在します。

パラメータ:
context - 仕様を解析するコンテキスト
path - ページベース開発モデルのプログラムパス
戻り値:
指定の画面へリンクするためのＵＲＬ
例外:
MalformedURLException - URL が無効な書式の場合
関連項目:
URLUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (5.0 J2EE-Base Programing Model API Specifications)

 すべてのクラス
AbsoluteLinkFilter
AbstractComponent
AbstractDrawer
AbstractDualComparator
AbstractDualComparator
AbstractFilter
AbstractHttpSessionManager
AbstractMessageReporter
AbstractMessageReporter
AbstractSocketConnectionDistributor
AbstractSocketConnectionDistributor
AbstractTreeNodeContainer
AbstractViewConverter
AccEmployeePayPostController
AccessSecurityConfigException
AccessSecurityCreateException
AccessSecurityDeleteException
AccessSecurityException
AccessSecurityExportException
AccessSecurityImportException
AccessSecurityListenerExcpetion
AccessSecurityManager
AccessSecurityReadException
AccessSecurityRuntimeException
AccessSecurityUpdateException
AccessSecurityWriteException
AccessibleLinkHTTPActionEventFilterHandler
AccessorClosedException
AccessorException
AccessorIllegalPropertyValueException
AccessorSystemException
Account
AccountAccessor
AccountChangedListener
AccountExporter
AccountGl
AccountImporter
AccountManager
AccountManager
AccountPayable
AccountPostWriterListener
AccountQueryWriterListener
AccountReaderDecorator
AccountRole
AccountRolePermissionSelector
AccountSecurityHTTPActionEventFilterHandler
AccountTax
AcsData
AcssecurityException
ActionListener
ActivationKey
ActivityFrameworkHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
AdminMenuAccessor
AdminMenuExporter
AdminMenuImporter
AdminMenuInclusion
AdminMenuManager
AdminMenuPostWriterListener
AdminMenuQueryWriterListener
AdminMenuReaderDecorator
AdvancedOutputStreamWriter
AdvancedOutputStreamWriter
AppcomnException
Application
ApplicationException
ApplicationInfo
Attribute
AttributeType
BASE64DecodeInputStream
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
BASE64EncodeOutputStream
BadRequestException
BadRequestException
Bank
BankController
BankList
BapiController
BapiHash
BapiReturn
BarGraphDrawer
BarGraphObject
BaseAccessor
BaseModel
BaseModel
BaseModelContext
BaseTable
Batch
BatchAccessor
BatchExporter
BatchImporter
BatchManager
BatchPostWriterListener
BatchQueryWriterListener
BatchReaderDecorator
BrowseString
BusinessArea
BusinessAreaController
BusinessAreaList
CGIEnvironment
CalendarAccessor
CalendarExporter
CalendarImporter
CalendarInfo
CalendarManager
CalendarPlugin
CalendarPluginAutumnalEquinox
CalendarPluginEndOfTheMonth
CalendarPluginInfo
CalendarPluginLastDayInTheMonth
CalendarPluginMondayMakeupHoliday
CalendarPluginVernalEquinox
CalendarPostWriterListener
CalendarQueryWriterListener
CalendarReaderDecorator
CategorizedCalendarInfo
Category
CategoryDetail
CategoryDetailBaseModel
CategoryDetailInternational
CategoryDetailInternationalModel
CategoryDetailMapper
CategoryManager
CateogryClass
CateogryClassBaseModel
CateogryClassInternational
CateogryClassInternationalModel
CateogryClassMapper
ChangedListenerException
CharacterEncoder
CharacterEncoder
CharacterSetManager
CircleGraphDrawer
CircleGraphObject
ClientTypeInfo
ColorPatternInfo
Column
ColumnMapping
CommandLineArgument
Company
Company
CompanyBaseModel
CompanyCategory
CompanyCategoryBaseModel
CompanyCategoryMapper
CompanyCategoryTerminable
CompanyCategoryTerminableModel
CompanyChangedListener
CompanyChangedMenuListener
CompanyController
CompanyImporter
CompanyList
CompanyManager
CompanyMapper
CompanyPost
CompanyPostBaseModel
CompanyPostImporter
CompanyPostMapper
CompanyPostTerminable
CompanyPostTerminableInternational
CompanyPostTerminableInternationalModel
CompanyPostTerminableModel
CompanyTerminable
CompanyTerminableInternational
CompanyVersion
CompanyVersionBaseModel
CompanyVersionMapper
ConInfo
ConcreteHTTPActionEventHandler
Configuration
ConfigurationFactory
ConfigurationUserInfo
ConnectionManager
ConnectorModel
ControllerConverter
ControllerConverterConfig
ControllerConverterException
ControllerObject
ControllingArea
ControllingAreaController
ControllingAreaList
Convertor
CoreAttributes
CostCenter
CostCenterController
CostCenterList
Counter
Counter
Cryption
CurlFieldBean
CurlRecordBeanIF
CurlXMLComposer
CurlXMLParser
CurrencyAmount
DAO
DAOAdapter
DAOException
DBConnector
DBDAO
DaoModel
DataAccessController
DataAccessException
DataConnectException
DataConnector
DataConnectorException
DataManager
DataManagerException
DataNotFoundException
DataPropertyException
DataPropertyHandler
DataSourceConnector
DataSourceProvider
DataStoreApplicationException
DataStoreConfigException
DataStoreSystemException
DatabaseAccessor
DatabaseManager
DatabaseSQLException
DateHandler
DateUtil
DayInfo
DbManager
DbsConnection
DefaultDataPropertyHandler
DefaultEventPropertyHandler
DefaultLogAgent
DefaultLogPropertyHandler
DefaultMessagePropertyHandler
DefaultMessagePropertyHandler
DefaultPropertyManager
DefaultServicePropertyHandler
DefaultSessionPropertyHandler
DefaultTransition
Delete
DeleteType
Department
DepartmentAttach
DepartmentAttachBaseModel
DepartmentAttachMapper
DepartmentAttachTerminable
DepartmentAttachTerminableModel
DepartmentBaseModel
DepartmentInclusionBaseModel
DepartmentInclusionMapper
DepartmentInfo
DepartmentMain
DepartmentMainBaseModel
DepartmentMainMapper
DepartmentMainTerminable
DepartmentMainTerminableModel
DepartmentMapper
DepartmentStruct
DepartmentTerminable
DepartmentTerminableInternational
DepartmentTerminableInternationalModel
DepartmentTerminableModel
Directory
Directory
DistributesDataPropertyHandler
DistributesEventPropertyHandler
DistributesServicePropertyHandler
DocumentHeader
DualComparator
DualComparator
DuplicateException
DuplicateException
EJBEventListener
EJBEventListenerAgentBean
EJBEventListenerFactory
ElementProperties
EmptyEvent
EmptyQueryException
EmptyUserInfo
EncodingFilter
Entity
Environment
ErrorEvent
ErrorEvent
ErrorEventListener
ErrorEventListener
ErrorHelperBean
ErrorPageProvider
Event
EventException
EventFactoryModel
EventGroupModel
EventListener
EventListener
EventListener
EventListenerException
EventListenerFactory
EventListenerFactoryParam
EventManager
EventManagerException
EventModelProducer
EventPropertyException
EventPropertyHandler
EventQueueController
EventQueueController
EventResult
EventScript
EventTrigger
EventTriggerAdapter
EventTriggerException
EventTriggerInfo
EventTriggerList
EventsAttributes
EverydayConditioner
EverydayConditioner
ExceptionHandlingFilter
ExcessiveQueryException
ExpirationKey
ExtendedBaseAccessor
ExtendedBaseAccessorMap
ExtendedBaseModel
ExtendedBaseModel
ExtendedBaseModelMap
ExtendedBaseTable
ExtendedClassLoader
ExtendedDirectory
ExtendedDirectory
ExtendedEntity
ExtendedFile
ExtendedFile
ExtendedGenericBaseModel
ExtendedGenericBaseModelMap
ExtendedGenericInternationalModel
ExtendedGenericInternationalModelMap
ExtendedGenericTerminableInternationalModel
ExtendedGenericTerminableInternationalModelMap
ExtendedGenericTerminableModel
ExtendedGenericTerminableModelMap
ExtendedInputStream
ExtendedInputStream
ExtendedInternationalAccessor
ExtendedInternationalAccessorMap
ExtendedInternationalModel
ExtendedInternationalModel
ExtendedInternationalModelMap
ExtendedInternationalTable
ExtendedModel
ExtendedOutputStream
ExtendedOutputStream
ExtendedProperties
ExtendedServletException
ExtendedSocket
ExtendedSocket
ExtendedTable
ExtendedTerminableAccessor
ExtendedTerminableAccessorMap
ExtendedTerminableInternationalAccessor
ExtendedTerminableInternationalAccessorMap
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModelMap
ExtendedTerminableInternationalTable
ExtendedTerminableModel
ExtendedTerminableModel
ExtendedTerminableModelMap
ExtendedTerminableTable
ExtendedThread
ExtendedThread
ExtendsImport
ExtendsImportManager
ExternalDirectory
ExternalMemory
FavoriteMenu
FileReporter
FileReporter
FileSender
FileSizeConditioner
FileSizeConditioner
FileUploadFilter
FilterComparator
FilterComparator
FilterHTTPActionEvent
FilterHTTPActionEventChain
FilterMessageReporter
FilterMessageReporter
FilterServletInputStream
FixedSizeMap
FixedSizeMap
ForbiddenException
FormTEI
FormTag
FormTagBeanInfo
FormatValidator
ForwardSelector
ForwardSelectorConfig
ForwardSelectorException
FoundationException
FoundationRuntimeException
FrameTEI
FrameTag
FrameTagBeanInfo
FrameworkException
FrameworkParameterSettingFilter
FrameworkTagException
FrameworkTagParam
FunctionContainer
FunctionContainerFile
GCConditioner
GarbageController
GenericAttributes
GenericBaseModel
GenericEJBEventListener
GenericEJBEventListenerAgent
GenericEJBEventListenerAgentBean
GenericEJBEventListenerAgentHome
GenericEJBEventListenerAgentLocal
GenericEJBEventListenerAgentLocalHome
GenericEJBEventListenerFactory
GenericEJBEventListenerLocal
GenericEJBEventListenerLocalFactory
GenericEventListener
GenericEventListenerFactory
GenericInternationalModel
GenericInternationalModelMap
GenericTerminableInternationalModel
GenericTerminableInternationalModelMap
GenericTerminableModel
GenericTerminableModelMap
GenericURLBuilder
GlAcc
GlAccController
GlAccList
GroupSecurityHTTPActionEventFilterHandler
GroupSuperUserAccessor
GroupSuperUserInitialServlet
GroupSuperUserPostWriterListener
GroupSuperUserQueryWriterListener
GroupSuperUserReaderDecorator
Grouping
HTMLEncoder
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContent
HTTPActionEventContext
HTTPActionEventEntityHandler
HTTPActionEventException
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException
HTTPActionEventListenerContext
HTTPActionEventResult
HTTPActionEventResultWrapper
HTTPActionEventURL
HTTPContext
HTTPContextHandlingFilter
HTTPContextManager
HelperBean
HelperBeanException
HelperBeanTEI
HelperBeanTag
HelperBeanTagBeanInfo
HexInputStream
HexInputStream
HexOutputStream
HexOutputStream
HomeDirectory
HttpServletRequestMessageBodyWrapper
HttpServletRequestMessageBodyWrapperBuilder
HttpSessionFactory
HttpSessionManager
HttpSessionManagerFactory
HttpSessionMonitoringFilter
HttpSessionMonitoringListener
HttpSessionObject
I18nAttributes
INonTransaction
Identifier
IllegalArgumentException
IllegalExtensionException
IllegalLocaleException
IllegalPasswordException
IllegalRelationshipException
IllegalSessionException
IllegalSystemException
IllegalTermException
ImportException
InitialFile
InputCheck
InternationalAccessor
InternationalAccessorMap
InternationalKey
InternationalModel
InternationalModel
InternationalModelContext
InternationalModelMap
InternationalTable
IntramartAction
IntramartConnectFilter
IntramartConnectServlet
IntramartDBConnector
IntramartDBDAO
IntramartDBMapper
IntramartFileServerConnector
IntramartFileServerDAO
IntramartLocaleFilter
IntramartLogAgent
IntramartMessagePropertyHandler
IntramartPageBaseTransition
IntramartSessionFactory
IntramartSessionObject
JDBCConnector
JavaMailPropertyException
JavaMailPropertyHandler
JavaMailSender
LDAPUserCertification
LengthRequiredException
LengthValidator
LicenseManager
Lifetime
LifetimeType
LimitedSessionHTTPActionEventFilterHandler
LineGraphDrawer
LineGraphObject
LineProperty
LineReportFilter
LineReportFilter
LinkTEI
LinkTag
LinkTagBeanInfo
LocaleFilter
LocaleInfo
LocaleProvider
Localhost
Localhost
Lock
LockMonitor
LockMonitor
LogAgent
LogAgentParam
LogConstant
LogManager
LogPropertyException
LogPropertyHandler
LoginGroup
LoginGroupAccessor
LoginGroupDBConnector
LoginGroupDBDAO
LoginGroupManager
LoginGroupPostWriterListener
LoginGroupQueryWriterListener
LoginGroupReaderDecorator
LoginInfo
LoginRequestInfo
Logingp
LuxuryResponseWriterFilter
Mail
MailSender
MailSenderException
MainPageImportLoginGroupPostWriterListener
MainPagePatternInfo
ManagerException
Mapper
MapperDAOException
MapperException
MapperFactory
MenuAccessor
MenuExporter
MenuImporter
MenuInclusion
MenuItem
MenuManager
MenuPermissionSelector
MenuPostWriterListener
MenuQueryWriterListener
MenuReaderDecorator
MenuServlet
MenuTree
MessageManager
MessageManager
MessageManager
MessageManagerException
MessageManagerException
MessageParamTag
MessagePropertyException
MessagePropertyException
MessagePropertyHandler
MessagePropertyHandler
MessagePropertyParam
MessageReporter
MessageReporter
MessageTEI
MessageTag
MismatchException
Model
MultiCastReporter
MultiCastReporter
MultiComparator
MultiComparator
MultiSelectableItem
MultipartFormData
MultipartFormData.Entity
MultipleOutputStream
MultipurposeInternetMailExtensions
MultipurposeInternetMailExtensions
NameFormatException
NetworkAgent
NetworkConnector
NetworkFile
NoCacheFilter
NoCryption
NoFilterException
NoSessionCookieException
NoSessionException
NoSuchPropertyException
NoSuchSessionException
NodeNameComparator
NodeTypeComparator
NotExistException
NotFoundDataSourceException
NotFoundException
NotSupportMethodException
NumericRangeValidator
NumericValidator
Option
OutputSizeConditioner
OutputSizeConditioner
PanelBasedViewObject
ParamTag
ParameterSendable
PasswordSecurityHTTPActionEventFilterHandler
PeriodicConditioner
PeriodicConditioner
PermanentDataArchiveFactory
PermanentDataDirectory
PermanentDirectory
PermanentFile
PermissionManager
PermissionSelector
PlainCompanyPost
Platform
PortFolioDrawer
PortFolioObject
PostInfo
PresentationConnectFilter
PresentationFrameworkHTTPActionEventHandler
PresentationManager
PresentationManagerException
PresentationPage
PresentationPageHTTPActionEventHandler
PresentationPropertyException
PresentationPropertyHandler
PresentationServiceController
PresentationServlet
PrimaryKeyMapping
PrintStreamReporter
PrintStreamReporter
PrivateGroup
PrivateGroupAttach
PrivateGroupAttachBaseModel
PrivateGroupAttachMapper
PrivateGroupBaseModel
PrivateGroupChangedListener
PrivateGroupManager
PrivateGroupMapper
ProcedureComponent
Profile
ProfitCenter
ProfitCenterController
ProfitCenterList
PropertiesFile
Property
PropertyConfigModel
PropertyHandler
PropertyHandlerException
PropertyHandlerParam
PropertyManager
PropertyManagerException
PropertyModel
PropertyParam
PublicGroup
PublicGroupAttach
PublicGroupAttachBaseModel
PublicGroupAttachMapper
PublicGroupAttachTerminable
PublicGroupAttachTerminableModel
PublicGroupBaseModel
PublicGroupCategory
PublicGroupCategoryBaseModel
PublicGroupCategoryMapper
PublicGroupCategoryTerminable
PublicGroupCategoryTerminableModel
PublicGroupChangedListener
PublicGroupChangedMenuListener
PublicGroupImporter
PublicGroupInclusionBaseModel
PublicGroupInclusionMapper
PublicGroupInfo
PublicGroupManager
PublicGroupMapper
PublicGroupSet
PublicGroupSetBaseModel
PublicGroupSetMapper
PublicGroupSetTerminable
PublicGroupSetTerminableInternational
PublicGroupStruct
PublicGroupTerminable
PublicGroupTerminableInternational
PublicGroupTerminableInternationalModel
PublicGroupTerminableModel
PublicGroupVersion
PublicGroupVersionBaseModel
PublicGroupVersionMapper
RadarChartDrawer
RadarChartObject
Relationship
ReplaceWriter
ReplaceWriter
ReportFileConditioner
ReportFileConditioner
ReportFileWriter
ReportFileWriter
ReportLevel
ReportLevel
ReportLevelFilter
ReportLevelFilter
RepresentativeReporter
RepresentativeReporter
RequestAnalyzer
RequestCharacterEncodingFilter
RequestEntityTooLargeException
RequestException
RequestFormatException
RequestInfo
RequestMessageBodyFilter
RequestParameter
ResourceBundleProperties
ResourceBundleProperties
ResourceFormatException
ResourceFormatException
ResourceLoader
ResourceModel
ResourceNotFoundException
ResourceNotFoundException
ResourceParam
ResponseCharacterEncodingFilter
ResponseContentTypeManagementFilter
ReverseComparator
ReverseComparator
Role
RoleAccessor
RoleChangedAccountListener
RoleChangedListener
RoleChangedMenuListener
RoleExporter
RoleImporter
RoleManager
RoleManager
RolePostWriterListener
RoleQueryWriterListener
RoleReaderDecorator
SAPAccountingAppException
SAPAccountingSystemException
SAPAuthAppException
SAPAuthSystemException
SAPGeneralAppException
SAPGeneralSystemException
SSORequestAnalyzer
SapConnector
SapRepositoryManager
Scheduler
ScriptCompileException
ScriptRuntimeException
ScriptValue
SecurityConstraint
SelectableItem
SequenceComparator
SequenceComparator
ServerConnector
ServiceController
ServiceControllerAdapter
ServiceControllerException
ServiceFrameworkHTTPActionEventHandler
ServiceManager
ServiceManagerException
ServicePropertyException
ServicePropertyHandler
ServiceResult
ServiceSecurityFilter
ServiceServlet
ServiceServletException
ServiceUnavailableException
ServiceUtils
ServletHTTPActionEventHandler
SessionConfig
SessionFactory
SessionFactory
SessionFactoryException
SessionFilter
SessionFilter
SessionInfo
SessionManager
SessionManagerException
SessionMemory
SessionObject
SessionObjectException
SessionPropertyException
SessionPropertyHandler
SessionQuery
ShutdownEventController
ShutdownListener
SimpleControllerConverter
SimplePanelBasedViewObject
SimpleViewObject
SingleSelectableItem
SocketConnection
SocketConnection
SocketConnectionDistributor
SocketConnectionDistributor
SocketConnectionDistributorFactory
SocketConnectionManager
SocketConnectionManager
SocketEventListener
SocketEventListener
SocketPool
SocketPool
StandardAccountBackup
StandardAdminMenuBackup
StandardBatchBackup
StandardCalendarBackup
StandardCompanyImporter
StandardCompanyPostImporter
StandardCryption
StandardEJBEventListener
StandardEJBEventListenerAgent
StandardEJBEventListenerAgentBean
StandardEJBEventListenerAgentHome
StandardEJBEventListenerFactory
StandardErrorPageProvider
StandardEventListener
StandardEventListenerFactory
StandardGroupSuperUserPageProvider
StandardMail
StandardMenuBackup
StandardPublicGroupImporter
StandardRequestAnalyzer
StandardRoleBackup
StandardSuperUserCertification
StandardSuperUserPageProvider
StandardUserCertification
StandardUserImporter
StandardUserPageProvider
StdErr
StdOut
StorageDirectory
StrutsConnectFilter
SubmitLinkTag
SubmitLinkTagBeanInfo
SubmitTEI
SubmitTag
SubmitTagBeanInfo
SuperCertification
SuperUser
SuperUserAccessor
SuperUserInitialServlet
SuperUserNoCertification
SuperUserPostWriterListener
SuperUserQueryWriterListener
SuperUserReaderDecorator
SystemConfigException
SystemDBConnector
SystemDBDAO
SystemErrorReporter
SystemException
SystemManager
SystemReporter
SystemSourceProvider
Table
TagWriter
TemporaryDirectory
TemporaryFile
Term
TermManager
TermManagerException
TerminableAccessor
TerminableAccessorMap
TerminableInternationalAccessor
TerminableInternationalAccessorMap
TerminableInternationalModel
TerminableInternationalModel
TerminableInternationalModelContext
TerminableInternationalModelMap
TerminableInternationalTable
TerminableKey
TerminableModel
TerminableModel
TerminableModelContext
TerminableModelMap
TerminableTable
TextFileDataPropertyHandler
TextFileEventPropertyHandler
TextFileMessagePropertyHandler
TextFileServicePropertyHandler
ThreadStopListener
ThreadStopListener
ThrowablePrintListener
TokenInvalidException
Transition
TransitionException
TreasureDirectory
TreasureFile
TreeBranch
TreeLeaf
TreeNode
TreeNodeContainer
TreeNodeProvider
TreeRoot
TrimmedFilterReader
TrimmedFilterWriter
URLAccessFilter
URLBuilder
URLDecodeInputStream
URLDecodeInputStream
URLDecodeOutputStream
URLDecodeOutputStream
URLEncodeOutputStream
URLEncodeOutputStream
URLUtil
UnauthorizedException
UnlimitedBufferedOutputStream
UnripeQueryException
UnsupportedNetworkConnectException
UnsupportedNetworkConnectException
UpdateInfo
User
UserBaseModel
UserCertification
UserCertificationServlet
UserChangedListener
UserImporter
UserInfo
UserInfoException
UserInfoUtil
UserInitialServlet
UserManager
UserMapper
UserPageProvider
UserTerminable
UserTerminableInternational
UserTerminableInternationalModel
UserTerminableModel
ValidationException
ValidationExceptionDetail
Validator
ValidatorConfig
ValidatorException
VariableScope
ViewConverter
ViewConverterConfig
ViewConverterException
ViewObject
WebApplicationHTTPActionEventHandler
XMLProperties
XORInputStream
XORInputStream
XOROutputStream
XOROutputStream
XmlDataPropertyHandler
XmlEventPropertyHandler
XmlLogPropertyHandler
XmlPropertyManager
XmlServicePropertyHandler
XmlSessionPropertyHandler


定数フィールド値 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | TYPE_DEBUG | 0
public static final int | TYPE_ERROR | 3
public static final int | TYPE_REPORT | 1
public static final int | TYPE_WARNING | 2

jp.co.intra_mart.foundation.database.ConInfo
public static final String | TYPE_DATA_SOURCE | "DataSource"
public static final String | TYPE_GROUP | "Group"
public static final String | TYPE_JDBC | "Jdbc"
public static final String | TYPE_SYSTEM | "System"

jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | POST_CODE | "postCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
public static final String | ADDRESS1 | "address1"
public static final String | ADDRESS2 | "address2"
public static final String | COMPANY_CODE | "companyCode"
public static final String | COUNTRY_CODE | "countryCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | EMAIL_ADDRESS1 | "emailAddress1"
public static final String | EMAIL_ADDRESS2 | "emailAddress2"
public static final String | EXTENSION_FAX_NUMBER | "extensionFaxNumber"
public static final String | EXTENSION_NUMBER | "extensionNumber"
public static final String | FAX_NUMBER | "faxNumber"
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | TELEPHONE_NUMBER | "telephoneNumber"
public static final String | URL | "url"
public static final String | ZIP_CODE | "zipCode"

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | DEPTH | "depth"
public static final String | PARENT_DEPARTMENT_CODE | "parentDepartmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | POST_CODE | "postCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | END_DATE | "endDate"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | START_DATE | "startDate"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
public static final String | OWNER_CODE | "ownerCode"
public static final String | PRIVATE_GROUP_CODE | "privateGroupCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | OWNER_CODE | "ownerCode"
public static final String | PRIVATE_GROUP_CODE | "privateGroupCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
public static final String | DEPTH | "depth"
public static final String | PARENT_PUBLIC_GROUP_CODE | "parentPublicGroupCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
public static final String | END_DATE | "endDate"
public static final String | NOTES | "notes"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | START_DATE | "startDate"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
public static final String | ACCOUNT_FLAG | "accountFlag"
public static final String | ADDRESS | "address"
public static final String | AVALIABLE_LOGIN_USER | "1"
public static final String | COUNTRY_CODE | "countryCode"
public static final String | EMAIL_ADDRESS1 | "emailAddress1"
public static final String | EMAIL_ADDRESS2 | "emailAddress2"
public static final String | EXTENSION_FAX_NUMBER | "extensionFaxNumber"
public static final String | EXTENSION_NUMBER | "extensionNumber"
public static final String | FAX_NUMBER | "faxNumber"
public static final String | MOBILE_EMAIL_ADDRESS | "mobileEmailAddress"
public static final String | MOBILE_NUMBER | "mobileNumber"
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | TELEPHONE_NUMBER | "telephoneNumber"
public static final String | UNAVALIABLE_LOGIN_USER | "0"
public static final String | URL | "url"
public static final String | USER_CODE | "userCode"
public static final String | ZIP_CODE | "zipCode"

jp.co.intra_mart.foundation.security.SecurityConstraint
public static final String | ATTR_DO_FILTER | "jp.co.intr_mart.session.filter.do"
public static final String | CP_COOKIE | "jp.co.intra_mart.session.cookie"
public static final int | CR_ERROR | -7
public static final int | CR_LOCKED | -3
public static final int | CR_NG | 0
public static final int | CR_NO_GROUP | -2
public static final int | CR_NO_LICENSE | -1
public static final int | CR_NO_PERMISSION | -6
public static final int | CR_NO_USER | -8
public static final int | CR_OK | 1
public static final int | CR_SESSION_INITIAL | 2
public static final int | CR_SESSION_LOGON | 3
public static final int | CR_SESSION_TIMEOUT | -5
public static final int | CR_SESSION_UNMATCH | -4
public static final String | LT_GROUP | "group"
public static final String | LT_SUPER | "super"
public static final String | LT_USER | "user"
public static final String | RP_CLIENT_TYPE | "im_client_type"
public static final String | RP_ENCODING | "im_encoding"
public static final String | RP_INITIAL_URL | "im_initial_url"
public static final String | RP_LOCALE | "im_locale"
public static final String | RP_LOGIN_GROUP | "im_login_group"
public static final String | RP_LOGIN_TYPE | "im_login_type"
public static final String | RP_PASSWORD | "im_password"
public static final String | RP_URL | "im_url"
public static final String | RP_URL_SIGN | "im_url_sign"
public static final String | RP_USER | "im_user"
public static final String | SP_CLIENT_TYPE | "jp.co.intra_mart.session.client_type"
public static final String | SP_COLOR_PATTERN_ID | "jp.co.intra_mart.session.color_pattern_id"
public static final String | SP_ENCODING | "jp.co.intra_mart.session.encoding"
public static final String | SP_INITIAL_URL | "jp.co.intra_mart.session.initial.url"
public static final String | SP_LOCALE | "jp.co.intra_mart.session.locale"
public static final String | SP_LOGIN_GROUP | "jp.co.intra_mart.session.group"
public static final String | SP_LOGIN_TIME | "jp.co.intra_mart.session.login_time"
public static final String | SP_LOGIN_TYPE | "jp.co.intra_mart.session.login_type"
public static final String | SP_SIGNATURE | "jp.co.intra_mart.session.signature"
public static final String | SP_URL | "jp.co.intra_mart.session.url"
public static final String | SP_URL_SIGN | "jp.co.intra_mart.session.url.signature"
public static final String | SP_USER | "jp.co.intra_mart.session.user"

jp.co.intra_mart.foundation.security.SessionInfo
public static final String COOKIE_SEPARATOR "|"

jp.co.intra_mart.foundation.security.batch.Batch
public static final String | LANG_JAVA | "JAVA"
public static final String | LANG_JAVA_SCRIPT | "JavaScript"

jp.co.intra_mart.foundation.security.calendar.CalendarInfo
public static final String | TYPE_CONFIG | "config"
public static final String | TYPE_HOLIDAY | "holiday"
public static final String | TYPE_NATIONAL_HOLDAY | "nationalHoliday"
public static final String | TYPE_WEEKDAY | "weekday"

jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
public static final String | DEFAULT_AUTH_COOKIE_NAME | "comauth"
public static final String | DEFAULT_LOGIN_KEY | "comid"
public static final String | KEY_AUTH_COOKIE_NAME | "comauth"
public static final String | KEY_LOGIN_KEY | "comid"
public static final String | SSO_LOGOUT_URL | "sso-logout-url"

jp.co.intra_mart.foundation.security.exception.AccessSecurityException
public static final String | KIND_ROLE | "Role"
public static final String | KIND_ROLE_SUB | "SubRole"

jp.co.intra_mart.foundation.security.menu.MenuItem
public static final String | CONTENT_TYPE_IN | "in"
public static final String | CONTENT_TYPE_OUT | "out"
public static final String | MENU_TYPE_FOLDER | "folder"
public static final String | MENU_TYPE_ITEM | "item"

jp.co.intra_mart.foundation.security.role.StandardRoleBackup
public static final String KIND_ROLE "Role"

jp.co.intra_mart.foundation.service.client.NetworkConnector
protected static final int | GET | 32
protected static final int | GET_ENTIRETY | 34
protected static final int | GET_ENTIRETY_KEY | 40
protected static final int | GET_ITEM | 33
protected static final int | GET_ITEM_KEY | 36
protected static final int | GET_SUBSET | 35
protected static final int | MOVE | 128
protected static final int | MOVE_ENTIRETY | 130
protected static final int | MOVE_ITEM | 129
protected static final int | REMOVE | 64
protected static final int | REMOVE_ENTIRETY | 66
protected static final int | REMOVE_ITEM | 65
protected static final int | SET | 16
protected static final int | SET_ENTIRETY | 18
protected static final int | SET_ITEM | 17

jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_ACCOUNT "filter-security-account"

jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_GROUP "filter-security-group"

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_PASSWORD "filter-security-password"

jp.co.intra_mart.foundation.utility.report.ReportLevel
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | TYPE_DEBUG | 0
public static final int | TYPE_ERROR | 3
public static final int | TYPE_REPORT | 1
public static final int | TYPE_WARNING | 2

jp.co.intra_mart.framework.base.data.ConnectorModel
public static final String | ID | "connector"
public static final String | P_ID_CONNECTOR_CLASS | "connector-class"
public static final String | P_ID_CONNECTOR_NAME | "connector-name"
public static final String | P_ID_RESOURCE_NAME | "resource-name"

jp.co.intra_mart.framework.base.data.DaoModel
public static final String | ID | "dao"
public static final String | P_ID_CONNECT_NAME | "connect-name"
public static final String | P_ID_DAO_CLASS | "dao-class"
public static final String | P_ID_DAO_CONNECTOR_NAME | "connector-name"

jp.co.intra_mart.framework.base.data.DataManager
public static final String DATA_PROPERTY_HANDLER_KEY "data"

jp.co.intra_mart.framework.base.data.DataSourceConnector
public static final String KEY_JNDI_NAME "jndi"

jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "DataConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "DataConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.data.JDBCConnector
public static final String | KEY_DRIVER | "driver"
public static final String | KEY_PASSWORD | "password"
public static final String | KEY_URL | "url"
public static final String | KEY_USERNAME | "username"

jp.co.intra_mart.framework.base.data.ResourceModel
public static final String | ID | "resource"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"
public static final String | P_ID_RESOURCE_NAME | "resource-name"
public static final String | P_ID_RESOURCE_PARAM | "init-param"

jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "data-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "EventConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "EventConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
public static final String HOME_PARAM "home"

jp.co.intra_mart.framework.base.event.EventFactoryModel
public static final String | ID | "event-factory"
public static final String | P_ID_FACTORY_CLASS | "factory-class"
public static final String | P_ID_FACTORY_PARAM | "init-param"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"

jp.co.intra_mart.framework.base.event.EventGroupModel
public static final String | ID | "event-group"
public static final String | P_ID_EVENT_KEY | "event-key"
public static final String | P_ID_EVENT_NAME | "event-class"
public static final String | P_ID_POST_TRIGGER | "post-trigger"
public static final String | P_ID_PRE_TRIGGER | "pre-trigger"
public static final String | P_ID_TRIGGER_CLASS | "trigger-class"

jp.co.intra_mart.framework.base.event.EventManager
public static final String EVENT_PROPERTY_HANDLER_KEY "event"

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
public static final String LISTENER_PARAM "listener"

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
public static final String LISTENER_PARAM "listener"

jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "event-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "MessageConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.message.MessageManager
public static final String MESSAGE_PROPERTY_HANDLER_KEY "i18n_message"

jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "ServiceConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "ServiceConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.IntramartConnectFilter
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_ARGUMENT_DELIMITER | ","
public static final String | PARAM_ARGUMENT_OPERATOR | "="
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"
public static final String | PARAM_SECURITY_EXT | "securityExt"

jp.co.intra_mart.framework.base.service.IntramartConnectServlet
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_ARGUMENT_DELIMITER | ","
public static final String | PARAM_ARGUMENT_OPERATOR | "="
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"

jp.co.intra_mart.framework.base.service.ServiceManager
public static final String | DEFAULT_SERVICE_EXTENSION | "service"
public static final String | SERVICE_EXTENSION_KEY | "jp.co.intra_mart.framework.base.service.ServiceManager.extesion"
public static final String | SERVICE_PROPERTY_HANDLER_KEY | "service"

jp.co.intra_mart.framework.base.service.ServicePropertyHandler
public static final String | DEFAULT_APPLICATION_PARAMETER | "application"
public static final String | DEFAULT_ENCODING_ATTRIBUTE | "jp.co.intra_mart.framework.base.service.encoding"
public static final String | DEFAULT_EXCEPTION_ATTRIBUTE | "exception"
public static final String | DEFAULT_LOCALE_ATTRIBUTE | "jp.co.intra_mart.framework.base.service.locale"
public static final String | DEFAULT_SERVICE_PARAMETER | "service"

jp.co.intra_mart.framework.base.service.ServiceSecurityFilter
public static final String | ID_SERVICE_SECURITY_FILTER | "jp.co.intra_mart.framework.base.service.ServiceSecurityFilter"
public static final String | PARAM_ERROR_PAGE | "error-page"

jp.co.intra_mart.framework.base.service.ServiceServlet
public static final String REQUEST_SEPARATOR "-"

jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "service-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "SessionConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.session.SessionManager
public static final String SESSION_PROPERTY_HANDLER_KEY "session"

jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "session-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.util.UserInfoUtil
public static final String | LT_GROUP | "group"
public static final String | LT_SUPER | "super"
public static final String | LT_USER | "user"

jp.co.intra_mart.framework.presentation.PresentationConnectFilter
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | LICENSE_PATH | "license/presentation-framework/filter"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"
public static final String | PARAM_WINDOW_NAME | "IM_MAIN"

jp.co.intra_mart.framework.presentation.PresentationManager
public static final String | CONFIG | "jp.co.intra_mart.framework.presentation.manager"
public static final String | MANAGER_CLASS_KEY | "manager"

jp.co.intra_mart.framework.presentation.PresentationServlet
public static final String | ACTION_ID | "action"
public static final String | LICENSE_PATH | "license/presentation-framework/filter"
public static final String | PREFIX_ATTRIBUTE | "jp.co.intra_mart.framework.presentation.PresentationServlet.prefix"
public static final String | REQUEST_INFO_ATTRIBUTE | "jp.co.intra_mart.framework.presentation.PresentationServlet.request"
public static final String | REQUEST_SEPARATOR | "-"
public static final String | START_ID | "start"
public static final String | SUFFIX_ATTRIBUTE | "jp.co.intra_mart.framework.presentation.PresentationServlet.suffix"
public static final String | TOKEN_ATTRIBUTE | "jp.co.intra_mart.framework.presentation.PresentationServlet.token"

jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter
public static final String OBJECT_PARAM_NAME "object"

jp.co.intra_mart.framework.presentation.validator.FormatValidator
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_PROPERTY | "property"
public static final String | PARAM_REGEX | "regex"

jp.co.intra_mart.framework.presentation.validator.LengthValidator
public static final String | PARAM_MAX | "max"
public static final String | PARAM_MESSAGE_LONG | "message_long"
public static final String | PARAM_MESSAGE_SHORT | "message_short"
public static final String | PARAM_MIN | "min"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator
public static final String | PARAM_MAX | "max"
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_MIN | "min"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.presentation.validator.NumericValidator
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "LogConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.log.IntramartLogAgent
public static final String TYPE_DB "DB"

jp.co.intra_mart.framework.system.log.LogConstant
public static final String | LEVEL_DEBUG | "DEBUG"
public static final String | LEVEL_ERROR | "ERROR"
public static final String | LEVEL_INFO | "INFO"
public static final String | LEVEL_WARNNING | "WARNNING"

jp.co.intra_mart.framework.system.log.LogManager
public static final String LOG_PROPERTY_HANDLER_KEY "log"

jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "log-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "MessageConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.message.MessageManager
public static final String MESSAGE_PROPERTY_HANDLER_KEY "message"

jp.co.intra_mart.framework.system.property.DefaultPropertyManager
public static final String | DEFAULT_BUNDLE_NAME | "/PropertyConfig.properties"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.DefaultPropertyManager"

jp.co.intra_mart.framework.system.property.PropertyManager
public static final String | DEFAULT_SYSTEM_MANAGER | "jp.co.intra_mart.framework.system.property.XmlPropertyManager"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.PropertyManager"

jp.co.intra_mart.framework.system.property.XmlPropertyManager
public static final String | DEFAULT_BUNDLE_NAME | "property-config.xml"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.XmlPropertyManager"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


非推奨 API のリスト (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.foundation.utility.AbstractDualComparator
jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.AccountManager
jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.appcomn.Category
jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。
jp.co.intra_mart.foundation.utility.Counter
jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
jp.co.intra_mart.foundation.database.DbManager
DatabaseManagerを使用してください。
jp.co.intra_mart.foundation.utility.file.Directory
jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
jp.co.intra_mart.foundation.utility.ErrorEvent
jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
jp.co.intra_mart.foundation.utility.EventQueueController
jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.EverydayConditioner
jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
jp.co.intra_mart.foundation.utility.file.ExtendedFile
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.ExtendedSocket
jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
jp.co.intra_mart.foundation.utility.ExtendedThread
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FileReporter
jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FileSizeConditioner
jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.FilterComparator
jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.FixedSizeMap
jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter
このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。
jp.co.intra_mart.foundation.appcomn.Grouping
jp.co.intra_mart.foundation.utility.io.HexInputStream
jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.HexOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
jp.co.intra_mart.framework.base.session.HttpSessionFactory
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.HttpSessionObject
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.service.IntramartConnectFilter
この機能は廃止されました。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet
この機能は廃止されました。
jp.co.intra_mart.framework.base.data.IntramartDBConnector
このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
jp.co.intra_mart.framework.base.data.IntramartDBDAO
このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
jp.co.intra_mart.framework.base.session.IntramartSessionFactory
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.IntramartSessionObject
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.data.JDBCConnector
JDBCを直接扱わず、DataSourceを使用するようにしてください。
jp.co.intra_mart.foundation.utility.report.LineReportFilter
jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.Localhost
jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
jp.co.intra_mart.foundation.utility.LockMonitor
jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.Logingp
jp.co.intra_mart.foundation.smtp.Mail
MailSenderに置き換えられました。
jp.co.intra_mart.foundation.utility.report.MultiCastReporter
jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.MultiComparator
jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner
jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.PeriodicConditioner
jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory
jp.co.intra_mart.framework.presentation.PresentationConnectFilter
この機能は廃止されました。
jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
jp.co.intra_mart.foundation.appcomn.Profile
jp.co.intra_mart.foundation.utility.io.ReplaceWriter
jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportFileWriter
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportLevelFilter
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.ResourceBundleProperties
jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
jp.co.intra_mart.foundation.utility.ReverseComparator
jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager
jp.co.intra_mart.foundation.utility.SequenceComparator
jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。
jp.co.intra_mart.foundation.http.SessionQuery
GenericURLBuilder および URLBuilder に置き替えられました。
jp.co.intra_mart.foundation.utility.net.SocketConnection
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketPool
jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.XORInputStream
jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.XOROutputStream
jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

推奨されていないインタフェース
jp.co.intra_mart.foundation.database.DbsConnection
DatabaseManagerから取得したコネクションを使用してください。
jp.co.intra_mart.foundation.utility.DualComparator
jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.ErrorEventListener
jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.EventListener
jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.MessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportLevel
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketEventListener
jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.ThreadStopListener
jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

推奨されていない例外
jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

推奨されていないフィールド
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.DEFAULT_SERVICE_PARAMETER
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.INTRAMART_URL_NAME
このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT_DELIMITER
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT_OPERATOR
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_LOGIN_GROUP_ID
このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_LOGIN_USER_ID
このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_REFERER
このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。

推奨されていないメソッド
jp.co.intra_mart.foundation.acssecurity.AcsData.acntFromDBToIS(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.acntFromISToDB(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.client.batch.Scheduler.action(Object)
jp.co.intra_mart.foundation.service.client.file.NetworkFile.action(Object)
jp.co.intra_mart.foundation.service.client.information.PermanentFile.action(Object)
jp.co.intra_mart.foundation.service.client.information.PermanentDirectory.action(Object)
jp.co.intra_mart.foundation.service.client.information.Lock.action(Object)
jp.co.intra_mart.foundation.service.client.information.ExternalMemory.action(Object)
jp.co.intra_mart.foundation.service.client.information.ExternalDirectory.action(Object)
jp.co.intra_mart.foundation.appcomn.Category.addCategoryDetail(Map)
CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
jp.co.intra_mart.foundation.service.provider.GarbageController.addConditioner(GCConditioner)
jp.co.intra_mart.foundation.appcomn.Profile.addProfile(Map)
UserManager.addUser(User user) に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.addURL(String)
GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
jp.co.intra_mart.foundation.database.DbManager.contact()
代替えメソッドはありません。
jp.co.intra_mart.foundation.database.DbManager.contact(ConInfo)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.RoleManager.contains(String)
jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.contains(String)
jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.count()
jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.count()
LoginGroupManager.countLoginGroups()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.count()
jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
jp.co.intra_mart.framework.base.event.EventManager.createEvent(String, String, String, String)
このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
jp.co.intra_mart.framework.base.web.tag.TagWriter.createURL(String, Collection)
このメソッドではなくTagWriter.createURL(String, Collection, String)を使用してください。
jp.co.intra_mart.foundation.database.DbManager.dateToString(Date)
DatabaseManager.dateToString(Date)を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.dbConsistChk(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.provider.HomeDirectory.definePath(String)
jp.co.intra_mart.foundation.acssecurity.Logingp.del(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllAccount(String)
AccountManager.deleteAccounts()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllLink(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllMenu(String)
MenuManager.deleteMenuItems()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllMessage(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllRole(String)
RoleManager.deleteRoles()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllSchedule(String)
BatchManager.deleteBatches()に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.delAttachInfo(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.delData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.delData(String)
jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.delData(String, boolean)
jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.delData(String, boolean)
jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Category.deleteCategoryDetail(String, String)
CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.deleteData(String)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.deleteData(String, String[])
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.deletePostData(String, String)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Profile.deleteProfile(String)
UserManager.deleteUser(User user) に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.entries()
LoginGroupManager.getLoginGroupIds()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.get(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.getAccount(String, String)
AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.foundation.appcomn.AppcomnException.getCode()
jp.co.intra_mart.foundation.database.DbManager.getConnectIDs()
DatabaseManager.getConnectIdsBySystem()を使用してください。
jp.co.intra_mart.foundation.database.DbManager.getConnectInfo()
代替えメソッドはありません。
jp.co.intra_mart.foundation.database.DbManager.getConnection()
DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.getData(String)
jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
jp.co.intra_mart.framework.base.web.tag.FrameTag.getFrameClass()
このメソッドではなくFrameTag.getFrameclass()メソッドを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getIdByName(String)
jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getIDs()
jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.getIDs()
jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
jp.co.intra_mart.foundation.graph.RadarChartDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.PortFolioDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.LineGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.BarGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.RadarChartDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.PortFolioDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.LineGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.BarGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath()
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.getLink(String, String)
代替えメソッドはありません。
jp.co.intra_mart.framework.base.web.tag.LinkTag.getLinkClass()
このメソッドではなくLinkTag.getLinkclass()メソッドを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getListData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
jp.co.intra_mart.framework.base.event.Event.getLoginGroup()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginGroupID()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.getLoginGroupID()
このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getLoginGroupID()
このメソッドではなくHelperBean.getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.common.util.ServiceUtils.getLoginGroupID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.struts.action.IntramartAction.getLoginGroupID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.presentation.view.AbstractViewConverter.getLoginGroupID(RequestInfo)
このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginUser()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginUserID()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.getLoginUserID()
このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getLoginUserID()
このメソッドではなくHelperBean.getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.common.util.ServiceUtils.getLoginUserID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.struts.action.IntramartAction.getLoginUserID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.presentation.view.AbstractViewConverter.getLoginUserID(RequestInfo)
このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.getMenu(String, String)
MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.appcomn.AppcomnException.getMessage()
jp.co.intra_mart.foundation.acssecurity.AcsData.getMessage(String, String)
代替えメソッドはありません。
jp.co.intra_mart.framework.system.message.MessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
MessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.MessageManager.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。MessageManager.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。IntramartMessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
DefaultMessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getParentData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.getQuery()
代替えメソッドはありません。
jp.co.intra_mart.foundation.http.SessionQuery.getQueryName()
代替えメソッドはありません。
jp.co.intra_mart.foundation.http.SessionQuery.getQueryValue()
GenericURLBuilder.createFilePath(String) に置き替えられました。
jp.co.intra_mart.foundation.database.DbManager.getReference()
DatabaseManager.getConnectIdsBySystem()を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.getRole(String, String)
RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.getSchedule(String, String)
BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.framework.base.service.ServiceManager.getServiceController(String, String)
このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceServletPath()
この実装は廃止されました。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getSession()
このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.service.Transition.getSessionObject()
このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.foundation.appcomn.Grouping.getStruct(String)
CompnanyManager,PublicGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.ServiceManager.getTransition(String, String)
このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getTransitionName(String, String)
このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getTransitionName(String, String)
このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.foundation.appcomn.Grouping.insertData(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.insertData(Map, String[])
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.insertPostData(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.isConnect()
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.Logingp.isGroup(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isValidDate(String, String, String)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isWeekDate(String, int)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isWeekDate(String, Integer)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.service.provider.GarbageController.removeConditioner(GCConditioner)
jp.co.intra_mart.foundation.acssecurity.Logingp.set(String, Number)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.Logingp.set(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setAccount(String, String)
AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.setAttachInfo(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.database.DbsConnection.setAutoCommit(boolean)
jp.co.intra_mart.framework.base.web.tag.HelperBeanTag.setClass(String)
このメソッドではなくHelperBeanTag.setHelperclass(java.lang.String)メソッドを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.setData(Map)
jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.setData(Map)
jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.setData(Map, boolean)
jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.setData(Map, boolean)
jp.co.intra_mart.framework.base.web.tag.FrameTag.setFrameClass(String)
このメソッドではなくFrameTag.setFrameclass(String)メソッドを使用してください。
jp.co.intra_mart.foundation.graph.RadarChartDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.PortFolioDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.LineGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.BarGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.RadarChartDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.PortFolioDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.LineGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.BarGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.acssecurity.AcsData.setLink(String, String)
代替えメソッドはありません。
jp.co.intra_mart.framework.base.web.tag.LinkTag.setLinkClass(String)
このメソッドではなくLinkTag.setLinkclass(String)メソッドを使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.setMenu(String, String)
MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.setMessage(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setRole(String, String)
RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.setSchedule(String, String)
BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.setTo(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.provider.GarbageController.startAutomaticExecution(long)
gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
jp.co.intra_mart.foundation.service.provider.GarbageController.stopAutomaticExecution()
jp.co.intra_mart.foundation.database.DbManager.stringToDate(String)
DatabaseManager.stringToDate(String)を使用してください。
jp.co.intra_mart.foundation.appcomn.Category.updateCategoryDetail(Map)
CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.updateData(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.updateData(Map, String[])
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.updatePostData(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Profile.updateProfile(Map)
UserManager.updateUser(User user) に置き換えられました。

推奨されていないコンストラクタ
jp.co.intra_mart.foundation.acssecurity.AccountManager(String)
jp.co.intra_mart.foundation.database.DbManager(String)
DatabaseManagerを使用してください。
jp.co.intra_mart.foundation.acssecurity.Logingp(String)
LoginGroupManagerに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager(String)
jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery(HttpServletRequest, HttpServletResponse)
GenericURLBuilder および URLBuilder に置き替えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


API ヘルプ (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


索引 (5.0 J2EE-Base Programing Model API Specifications)

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart(R)
5.0

前 次

フレームあり フレームなし

A B C D E F G H I J K L M N O P Q R S T U V W X Z

A

ACCOUNT_FLAG - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
アカウントフラグ
ACTION_ID - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
アクションによる遷移をする場合のID
ADDRESS - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
住所
ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
住所1
ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
住所2
ATTR_DO_FILTER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションフィルター制御パラメータ名。
AVALIABLE_LOGIN_USER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ログインできるアカウントを表す定数
AbsoluteLinkFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter.
絶対表現のＵＲＬをレスポンスするためのフィルタ。
AbsoluteLinkFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter のコンストラクタ
フィルタを新しく作成します。
AbstractComponent - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent.
このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
AbstractComponent() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent のコンストラクタ
唯一のコンストラクタ。
AbstractDrawer - class jp.co.intra_mart.foundation.drawer.AbstractDrawer.
画像ファイル出力用のスケルトンクラスです。
AbstractDrawer() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のコンストラクタ
唯一のコンストラクタ。
AbstractDualComparator - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator.
２つのコンパレータを使用してソートを行うクラスです。
AbstractDualComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator のコンストラクタ
新しいオブジェクトを生成します。
AbstractDualComparator - class jp.co.intra_mart.foundation.utility.AbstractDualComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
AbstractDualComparator() - class jp.co.intra_mart.foundation.utility.AbstractDualComparator のコンストラクタ
推奨されていません。 新しいオブジェクトを生成します。
AbstractFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter.
フィルタを実装するための抽象クラスです。
AbstractFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のコンストラクタ
フィルタオブジェクトを作成します。
AbstractHttpSessionManager - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager.
インタフェース HttpSessionManager の抽象実装です。
AbstractHttpSessionManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のコンストラクタ
HttpSessionManager の抽象実装を構築します。
AbstractMessageReporter - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter.
メッセージ出力用のスケルトンクラスです。
AbstractMessageReporter() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のコンストラクタ
唯一のコンストラクタ。
AbstractMessageReporter - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
AbstractMessageReporter() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のコンストラクタ
推奨されていません。 唯一のコンストラクタ。
AbstractSocketConnectionDistributor - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor.
このクラスは、通信ソケットを作成する機能を提供します。
AbstractSocketConnectionDistributor(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のコンストラクタ
ソケット作成オブジェクトを構築します。
AbstractSocketConnectionDistributor - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
AbstractSocketConnectionDistributor(String, int) - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のコンストラクタ
推奨されていません。 ソケット作成オブジェクトを構築します。
AbstractTreeNodeContainer - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer.
ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
AbstractTreeNodeContainer() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のコンストラクタ
子ノードを追加順に並べる、新しいオブジェクトを生成します。
AbstractTreeNodeContainer(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のコンストラクタ
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。
AbstractViewConverter - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter.
いくつかのユーティリティメソッドが含まれる抽象的なビューコンバータです。
AbstractViewConverter() - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のコンストラクタ

AccEmployeePayPostController - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController.
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。
AccEmployeePayPostController() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccessSecurityConfigException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException.
アクセスセキュリティ設定に関する例外クラス。
AccessSecurityConfigException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException.
アクセスセキュリティ情報作成例外クラス。
AccessSecurityCreateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException.
アクセスセキュリティ情報削除例外クラス。
AccessSecurityDeleteException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityException.
アクセスセキュリティの基本となる例外クラス。
AccessSecurityException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityExportException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException.
エクスポート時例外クラス。
AccessSecurityExportException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException のコンストラクタ
コンストラクタ。
AccessSecurityExportException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException のコンストラクタ
コンストラクタ。
AccessSecurityImportException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException.
インポート時例外クラス。
AccessSecurityImportException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException のコンストラクタ
コンストラクタ。
AccessSecurityImportException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion.
アクセスセキュリティリスナーの例外クラス。
AccessSecurityListenerExcpetion() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityManager - class jp.co.intra_mart.foundation.security.AccessSecurityManager.
アクセスセキュリティマネージャクラス。
AccessSecurityReadException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException.
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityReadException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException.
アクセスセキュリティランタイム例外クラス。
AccessSecurityRuntimeException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException.
アクセスセキュリティ情報更新例外クラス。
AccessSecurityUpdateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException.
アクセスセキュリティ情報の更新例外クラス。
AccessSecurityWriteException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessibleLinkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler.
再接続の為のＵＲＬを制御するフィルタ実装です。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のコンストラクタ
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
AccessorClosedException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException.
アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorClosedException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorException.
アクセサで発生する例外の基底クラス
AccessorException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException.
アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。
AccessorIllegalPropertyValueException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorSystemException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException.
アクセサのプロパティに関する例外クラス

指定されたプロパティがアクセサに存在しない場合にスローする。
AccessorSystemException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
Account - class jp.co.intra_mart.foundation.security.account.Account.
アカウントモデル。
Account(String) - class jp.co.intra_mart.foundation.security.account.Account のコンストラクタ
コンストラクタ。
AccountAccessor - interface jp.co.intra_mart.foundation.security.account.AccountAccessor.
アカウントアクセッサインタフェース。
AccountChangedListener - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener.
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountExporter - interface jp.co.intra_mart.foundation.security.account.AccountExporter.
アカウントエクスポートインタフェースです。
AccountGl - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl.
G/L 勘定明細クラス
機能は以下の通り
G/L 勘定明細の情報を保持します。
AccountGl(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のコンストラクタ
G/L 勘定明細情報を作成します。
AccountImporter - interface jp.co.intra_mart.foundation.security.account.AccountImporter.
アカウントインポートインタフェースです。
AccountManager - class jp.co.intra_mart.foundation.acssecurity.AccountManager.
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
AccountManager(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のコンストラクタ
推奨されていません。
AccountManager - class jp.co.intra_mart.foundation.security.account.AccountManager.
アカウントマネージャクラス。
AccountManager(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のコンストラクタ
コンストラクタ。
AccountPayable - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable.
仕入先明細クラス
機能は以下の通り
仕入先明細の情報を保持します。
AccountPayable(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のコンストラクタ
仕入先明細情報を作成します。
AccountPostWriterListener - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener.
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener.
アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountReaderDecorator - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator.
アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AccountRole - class jp.co.intra_mart.foundation.security.account.AccountRole.
アカウント用ロールモデル。
AccountRole(String) - class jp.co.intra_mart.foundation.security.account.AccountRole のコンストラクタ
コンストラクタ。
AccountRolePermissionSelector - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector.
ユーザIDから有効なすべてのロールを取得するセレクタ。
AccountRolePermissionSelector() - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のコンストラクタ
コンストラクタ。
AccountSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AccountTax - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax.
税明細クラス
機能は以下の通り
税明細の情報を保持します。
AccountTax(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のコンストラクタ
指定されたレコード番号でAccountTaxを作成します｡
AcsData - class jp.co.intra_mart.foundation.acssecurity.AcsData.
推奨されていません。
AcsData() - class jp.co.intra_mart.foundation.acssecurity.AcsData のコンストラクタ
推奨されていません。
AcssecurityException - exception jp.co.intra_mart.foundation.acssecurity.AcssecurityException.
アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。
ActionListener - interface jp.co.intra_mart.foundation.service.client.ActionListener.
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
ActivationKey - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey.
ライフタイム期間の有効開始日時を定義します。
ActivityFrameworkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler.
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のコンストラクタ
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
ActivityHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler.
持続したセッションを確立するためのハンドラです。
ActivityHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。
AdminMenuAccessor - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor.
メニューアクセッサインタフェース。
AdminMenuExporter - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter.
メニューエクスポートインタフェースです。
AdminMenuImporter - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter.
メニューインポートインタフェースです。
AdminMenuInclusion - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion.
メニュー内包情報クラス。
AdminMenuInclusion(String, String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のコンストラクタ
コンストラクタ。
AdminMenuManager - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager.
管理メニューマネージャクラス。
AdminMenuPostWriterListener - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener.
メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AdminMenuQueryWriterListener - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener.
メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AdminMenuReaderDecorator - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator.
メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AdvancedOutputStreamWriter - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter.
このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
AdvancedOutputStreamWriter(OutputStream, String) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, Charset) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, CharsetEncoder) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
AdvancedOutputStreamWriter(OutputStream, String) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, Charset) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, CharsetEncoder) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
AppcomnException - exception jp.co.intra_mart.foundation.appcomn.AppcomnException.
アプリケーション共通マスタの情報操作時にエラーが発生した場合にスローされます。
Application - interface jp.co.intra_mart.foundation.datastore.common.config.Application.
アプリケーションを定義します。
ApplicationException - exception jp.co.intra_mart.framework.system.exception.ApplicationException.
フレームワーク内で発生したアプリケーション例外です。
ApplicationException() - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
詳細メッセージを指定しないで ApplicationException を構築します。
ApplicationException(String) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
指定された詳細メッセージを持つ ApplicationException を構築します。
ApplicationException(Throwable) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
この例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationInfo - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo.
アプリケーション情報のインタフェース。
Attribute - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute.
属性を定義します。
AttributeType - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType.
属性で指定できる型です。
accountAdded(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
accountDeleted(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
accountRoleAdded(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
accountRoleDeleted(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
accountRoleUpdated(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
accountUpdated(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
acntFromDBToIS(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
acntFromISToDB(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
action(Object) - interface jp.co.intra_mart.foundation.service.client.ActionListener のメソッド
このメソッドは、特定のイベント発生時に実行されます。
action(Object) - class jp.co.intra_mart.foundation.service.client.NetworkAgent のメソッド
このオブジェクトの実行ロジック。
action(Object) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
推奨されていません。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent のメソッド
イベント処理メソッドです。
activeCount() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
現在取得済みモニターの数を取得します。
activeCount() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 現在取得済みモニターの数を取得します。
addAccount(Account) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを新規追加します。
addAccountRole(String, AccountRole) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを新規追加します。
addAttachment(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを追加します。
addBatch(Batch) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を新規登録します。
addBcc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addBcc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addCalendarInfo(String, CalendarInfo) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを新規に追加します。
addCategoryDetail(Map) - class jp.co.intra_mart.foundation.appcomn.Category のメソッド
推奨されていません。 CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
addCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
分類区分詳細を登録します。
addCc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addCc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addChild(MenuTree) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューを追加します。
addChildBranch(TreeBranch) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたブランチ branchを子ノードとして追加します。
addChildLeaf(TreeLeaf) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたリーフ leafを子ノードとして追加します。
addChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード node を子ノードとして追加します。
addClassArchive(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスに指定のアーカイブファイルを追加します。
addClassArchiveLibrary(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。
addClassPath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスを追加します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCompany(Company) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社を登録します。
addComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
指定されたコンパレータ comparator を追加します。
addComparator(Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 指定されたコンパレータ comparator を追加します。
addConditioner(ReportFileConditioner) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
addConditioner(GCConditioner) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
addConditioner(ReportFileConditioner) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
addCreateSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
addCreateSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
addData(BarGraphObject) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, BarGraphObject) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値を追加します。
addData(CircleGraphObject) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, CircleGraphObject) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(LineGraphObject) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, LineGraphObject) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値を追加します。
addData(PortFolioObject) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, PortFolioObject) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(RadarChartObject) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, RadarChartObject) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値を追加します。
addDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織を登録します。
addDetail(String) - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のメソッド
検証結果の詳細を追加します。
addFavoriteMenu(String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを新規追加します。
addField(CurlFieldBean) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
フィールド一覧リストにフィールドを追加します。
addGroupSet(PublicGroupSet) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループセットを登録します。
addHeader(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ヘッダーを追加します。
addListener(ShutdownListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウンリスナーを登録します。
addListener(EventListener) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
リスナーを登録します。
addLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループを新規追加します。
addMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを新規追加します。
addMenuDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織をメニューに紐付けます。
addMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを追加します。
addMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを追加します。
addMenuPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役職をメニューに紐付けます。
addMenuPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループをメニューに紐付けます。
addMenuRole(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールをメニューに紐付けます。
addNativePath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
クラスパスを追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
メッセージの出力先を追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージの出力先を追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージの出力先を追加します。
addParameter(String, String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
パラメータを追加します。
addParameter(String, String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
パラメータを追加します。
addParameter(Object) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
パラメータを追加します。
addParameter(String, String) - interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable のメソッド
パラメータを追加します。
addPost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
役職を登録します。
addPrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループを登録します。
addProfile(Map) - class jp.co.intra_mart.foundation.appcomn.Profile のメソッド
推奨されていません。 UserManager.addUser(User user) に置き換えられました。
addPublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループを登録します。
addRecord(CurlRecordBeanIF) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
レコード一覧リストにレコードを追加します。
addReplyTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ReplyToを追加します。
addReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
addReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
addRole(Role) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を新規登録します。
addSubRole(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
サブロールIDを追加します。
addSuperUser(SuperUser) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を新規に作成します。
addSuperUser(String, SuperUser) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者を新規追加します。
addThreadStopListener(ThreadStopListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
addThreadStopListener(ThreadStopListener) - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
addTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addTo(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addURL(String) - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
addUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
ユーザを登録します。
addVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社構成バージョンを新規に登録します。
addVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループセット構成バージョンを新規に登録します。
append(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
append(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにテキストを追記します。
append(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(byte[]) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
archive(File) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(File, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(OutputStream, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(File) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(File, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(OutputStream) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(OutputStream, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
attachFile(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 添付ファイルの内容をセットする。
available() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。

B

BASE64DecodeInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream.
このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
BASE64DecodeInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のコンストラクタ
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
BASE64DecodeInputStream - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
BASE64DecodeInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のコンストラクタ
推奨されていません。 指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
BASE64DecodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream.
このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64DecodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64デコーダーを作成します。
BASE64DecodeOutputStream - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
BASE64DecodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
BASE64EncodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream.
このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64EncodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
BASE64EncodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BadRequestException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException.
不正なリクエストを受け付けたことを通知するための例外です。
BadRequestException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
指定のメッセージを持つ例外を作成します。
BadRequestException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
BadRequestException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
例外を作成します。
BadRequestException - exception jp.co.intra_mart.framework.presentation.BadRequestException.
クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。
BadRequestException() - class jp.co.intra_mart.framework.presentation.BadRequestException のコンストラクタ
詳細メッセージを指定しないで BadRequestException を構築します。
BadRequestException(String) - class jp.co.intra_mart.framework.presentation.BadRequestException のコンストラクタ
指定された詳細メッセージを持つ BadRequestException を構築します。
BadRequestException(String, Throwable) - class jp.co.intra_mart.framework.presentation.BadRequestException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ BadRequestException を構築します。
Bank - class jp.co.intra_mart.foundation.sap.module.accounting.Bank.
銀行情報クラス
機能は以下の通り
銀行の情報を保持します。
Bank() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のコンストラクタ
銀行情報を作成します。
BankController - class jp.co.intra_mart.foundation.sap.module.accounting.BankController.
銀行コントローラクラス
機能は以下の通り
銀行の情報を取得します。
BankController() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankList - class jp.co.intra_mart.foundation.sap.module.accounting.BankList.
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のコンストラクタ
executeBapiを呼び出し銀行一覧を作成します。
BapiController - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.
BAPIコントローラクラス
機能は以下の通り
ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡
展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開メソッドを使用して取得します｡

BapiController(String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiHash - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash.
BapiHashクラス
機能は以下の通り
汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡ R/3のBAPI処理にて使用されるパラメータの値を保持します。
BapiHash(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡
BapiHash(String, String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。
BapiHash(String, String, String, int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。
BapiReturn - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn.
BapiReturnクラス
機能は以下の通り
R/3のBAPI処理の実行結果に関する値を保持します。
BapiReturn(JCO.Structure) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のコンストラクタ
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(JCO.Table) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のコンストラクタ
指定されたJCO.Table情報でBapiReturnを作成します。
BarGraphDrawer - class jp.co.intra_mart.foundation.graph.BarGraphDrawer.
棒グラフを描画します。
BarGraphDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で棒グラフを作成します。
BarGraphDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現で棒グラフを作成します。
BarGraphObject - class jp.co.intra_mart.foundation.graph.BarGraphObject.
BarGraphDrawerクラスのデータを保存するオブジェクトです。
BarGraphObject() - class jp.co.intra_mart.foundation.graph.BarGraphObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
BarGraphObject(Color) - class jp.co.intra_mart.foundation.graph.BarGraphObject のコンストラクタ
線の色を指定して、データオブジェクトを作成します。
BaseAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor.
基本エンティティに対する情報操作用のインタフェースです。
BaseModel - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel.
基本モデルを定義します。
BaseModel - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel.
基本モデルの情報です。
BaseModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext.
基本モデルの初期化に必要な設定を持ちます。
BaseTable - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable.
基本テーブルを定義します。
Batch - class jp.co.intra_mart.foundation.security.batch.Batch.
バッチ・モデルクラス
Batch() - class jp.co.intra_mart.foundation.security.batch.Batch のコンストラクタ
コンストラクタ。
Batch(String) - class jp.co.intra_mart.foundation.security.batch.Batch のコンストラクタ
コンストラクタ。
BatchAccessor - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor.

BatchExporter - interface jp.co.intra_mart.foundation.security.batch.BatchExporter.
バッチバックアップインタフェースです。
BatchImporter - interface jp.co.intra_mart.foundation.security.batch.BatchImporter.
バッチバックアップインタフェースです。
BatchManager - class jp.co.intra_mart.foundation.security.batch.BatchManager.
バッチマネージャクラス。
BatchManager(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のコンストラクタ
コンストラクタ。
BatchPostWriterListener - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener.

BatchQueryWriterListener - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener.

BatchReaderDecorator - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator.

BrowseString - class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString.
HTML表示用文字列変換ユーティリティクラス。
BusinessArea - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea.
事業領域情報クラス
機能は以下の通り
事業領域の情報を保持します。
BusinessArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のコンストラクタ
事業領域情報を作成します。
BusinessAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController.
事業領域コントローラクラス
機能は以下の通り
事業領域の情報を取得します。
BusinessAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList.
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
BusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のコンストラクタ
executeBapiを呼び出し事業領域一覧を作成します。
backup(File) - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
このデータを指定のファイルにバックアップします。
begin() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
begin(long) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
beginTransaction() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースアクセスのトランザクションを開始します。
beginTransaction() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースアクセスのトランザクションを開始します。
booleanValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の真偽値表現を取得します。
buildExtendedHttpServletRequest(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
ExtendedHttpServletRequest を作成して返します。

C

CASCADE - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
CASCADE - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
分類区分コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
分類コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
分類コード
CGIEnvironment - class jp.co.intra_mart.foundation.http.CGIEnvironment.
このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
CGIEnvironment(HttpServletRequest) - class jp.co.intra_mart.foundation.http.CGIEnvironment のコンストラクタ
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
会社コード
CONFIG - class jp.co.intra_mart.framework.presentation.PresentationManager の static 変数
PresentationManagerの生成情報が設定されているリソースバンドル名
CONTENT_TYPE_IN - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニューコンテンツの種類（内部URL）。
CONTENT_TYPE_OUT - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニューコンテンツの種類（外部URL）。
COOKIE_SEPARATOR - interface jp.co.intra_mart.foundation.security.SessionInfo の static 変数
セッション情報をクッキーに保管する際のセパレータ。
COUNTRY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
国コード
COUNTRY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
国コード
CP_COOKIE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション情報をクッキーに保管するパラメータ名。
CR_ERROR - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証処理エラーの返却値。
CR_LOCKED - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
アカウントロック状態の返却値。
CR_NG - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエラーの返却値。
CR_NO_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループ未登録状態の返却値。
CR_NO_LICENSE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ライセンスなし、または有効期間外状態の返却値。
CR_NO_PERMISSION - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
無許可ページへのアクセスの返却値。
CR_NO_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ユーザ未登録状態の返却値。
CR_OK - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証成功の返却値。
CR_SESSION_INITIAL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション初期状態の返却値。
CR_SESSION_LOGON - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションログオン状態の返却値。
CR_SESSION_TIMEOUT - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションタイムアウト状態の返却値。
CR_SESSION_UNMATCH - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション不整合状態の返却値。
CalendarAccessor - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor.
カレンダーアクセッサインタフェース。
CalendarExporter - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter.
カレンダーバックアップインタフェースです。
CalendarImporter - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter.
カレンダーバックアップインタフェースです。
CalendarInfo - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo.
カレンダーデータ・モデルクラス
CalendarInfo() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のコンストラクタ
コンストラクタ。
CalendarInfo(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のコンストラクタ
コンストラクタ。
CalendarManager - class jp.co.intra_mart.foundation.security.calendar.CalendarManager.
カレンダーマネージャクラス

カレンダー情報の操作を行います。
CalendarManager(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のコンストラクタ
コンストラクタ。
CalendarPlugin - interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin.
カレンダデータプラグインインターフェース。
CalendarPluginAutumnalEquinox - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox.
カレンダデータプラグインクラス。
CalendarPluginAutumnalEquinox() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox のコンストラクタ

CalendarPluginEndOfTheMonth - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth.
カレンダデータプラグインクラス。
CalendarPluginEndOfTheMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth のコンストラクタ

CalendarPluginInfo - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo.
カレンダーデータプラグイン情報のインターフェース。
CalendarPluginLastDayInTheMonth - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth.
カレンダデータプラグインクラス。
CalendarPluginLastDayInTheMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth のコンストラクタ

CalendarPluginMondayMakeupHoliday - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday.
カレンダデータプラグインクラス。
CalendarPluginMondayMakeupHoliday() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday のコンストラクタ

CalendarPluginVernalEquinox - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox.
カレンダデータプラグインクラス。
CalendarPluginVernalEquinox() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox のコンストラクタ

CalendarPostWriterListener - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener.
カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
CalendarQueryWriterListener - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener.
カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
CalendarReaderDecorator - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator.
アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
CategorizedCalendarInfo - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo.
カテゴライズカレンダーデータクラス。
CategorizedCalendarInfo(CalendarInfo[]) - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のコンストラクタ
コンストラクタ。
Category - class jp.co.intra_mart.foundation.appcomn.Category.
推奨されていません。
Category(String) - class jp.co.intra_mart.foundation.appcomn.Category のコンストラクタ
推奨されていません。 コンストラクタ
CategoryDetail - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail.
分類区分詳細の基本属性のデータを取り扱います。
CategoryDetail() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のコンストラクタ

CategoryDetailBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel.
分類区分詳細の基本モデルです。
CategoryDetailInternational - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational.
分類区分詳細の国際化属性のデータを取り扱います。
CategoryDetailInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のコンストラクタ

CategoryDetailInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel.
分類区分詳細の国際化モデルです。
CategoryDetailMapper - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper.
分類区分詳細に関連するマッパです。
CategoryManager - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager.
分類に関連する情報を管理します。
CategoryManager() - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のコンストラクタ

CateogryClass - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass.
分類区分の基本属性のデータを取り扱います。
CateogryClass() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のコンストラクタ

CateogryClassBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel.
分類区分の基本モデルです。
CateogryClassInternational - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational.
分類区分の国際化属性のデータを取り扱います。
CateogryClassInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のコンストラクタ

CateogryClassInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel.
分類区分の国際化モデルです。
CateogryClassMapper - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper.
分類区分に関連するマッパです。
ChangedListenerException - exception jp.co.intra_mart.foundation.exception.ChangedListenerException.
更新リスナーの例外クラス。
ChangedListenerException() - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(String) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(Throwable) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(String, Throwable) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
CharacterEncoder - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder.
このクラスは、文字エンコードの機能を提供します。
CharacterEncoder(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のコンストラクタ
文字コード変換のためのエンコーダを作成します。
CharacterEncoder - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。
CharacterEncoder(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のコンストラクタ
推奨されていません。 文字コード変換のためのエンコーダを作成します。
CharacterSetManager - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager.
このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。
CharacterSetManager() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager のコンストラクタ

CircleGraphDrawer - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer.
円グラフを描画します。
CircleGraphDrawer() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で円グラフを作成します。
CircleGraphObject - class jp.co.intra_mart.foundation.graph.CircleGraphObject.
CircleGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphObject(double, Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(int, Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(double, Color, String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
CircleGraphObject(int, Color, String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
ClientTypeInfo - interface jp.co.intra_mart.foundation.security.ClientTypeInfo.
クライアントタイプ情報インタフェース。
ColorPatternInfo - interface jp.co.intra_mart.foundation.security.ColorPatternInfo.
カラーパターン情報を取得するインタフェース。
Column - interface jp.co.intra_mart.foundation.datastore.common.config.Column.
属性に対応するカラムの型を定義します。
ColumnMapping - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping.
分割されたテーブルに割り当てられるカラムを定義します。
CommandLineArgument - class jp.co.intra_mart.common.platform.vm.CommandLineArgument.
このクラスはコマンド実引数を解釈するための共通実装です。
CommandLineArgument(String[]) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のコンストラクタ
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。
Company - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company.
会社の基本属性のデータを取り扱います。
Company() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ

Company - class jp.co.intra_mart.foundation.sap.module.accounting.Company.
会社情報クラス
機能は以下の通り
会社の情報を保持します。
Company() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のコンストラクタ
会社情報を作成します。
CompanyBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel.
会社の基本モデルです。
CompanyCategory - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory.
会社組織分類の基本属性のデータを取り扱います。
CompanyCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のコンストラクタ

CompanyCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel.
会社組織分類の基本モデルです。
CompanyCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper.
会社組織分類に関連するマッパです。
CompanyCategoryTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable.
会社組織分類の期間化属性のデータを取り扱います。
CompanyCategoryTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable のコンストラクタ

CompanyCategoryTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel.
会社組織分類の期間化モデルです。
CompanyChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のコンストラクタ

CompanyController - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController.
会社コントローラクラス
機能は以下の通り
会社の情報を取得します。
CompanyController() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のコンストラクタ
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter.
会社のインポートのインターフェースです。
CompanyList - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList.
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
CompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のコンストラクタ
executeBapiを呼び出し会社一覧を作成します。
CompanyManager - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager.
会社や組織に関連する情報を管理します。
CompanyManager() - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のコンストラクタ

CompanyMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper.
会社に関連するマッパです。
CompanyPost - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost.
役職の基本属性のデータを取り扱います。
CompanyPost() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ

CompanyPostBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel.
役職の基本モデルです。
CompanyPostImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter.
役職のインポートのインターフェースです。
CompanyPostMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper.
役職に関連するマッパです。
CompanyPostTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable.
役職の期間化属性のデータを取り扱います。
CompanyPostTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のコンストラクタ

CompanyPostTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational.
役職の期間国際化属性のデータを取り扱います。
CompanyPostTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のコンストラクタ

CompanyPostTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel.
役職の期間国際化モデルです。
CompanyPostTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel.
役職の期間化モデルです。
CompanyTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable.
会社の期間化属性のデータを取り扱います。
CompanyTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のコンストラクタ

CompanyTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational.
会社の期間国際化属性のデータを取り扱います。
CompanyTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のコンストラクタ

CompanyVersion - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion.
会社構成バージョンの基本属性のデータを取り扱います。
CompanyVersion() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のコンストラクタ

CompanyVersionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel.
会社構成バージョンの基本モデルです。
CompanyVersionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper.
会社構成バージョンに関連するマッパです。
ConInfo - interface jp.co.intra_mart.foundation.database.ConInfo.

ConcreteHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler.
任意の HTTPActionEvent を実行するためのハンドラです。
ConcreteHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のコンストラクタ
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
Configuration - interface jp.co.intra_mart.foundation.datastore.common.config.Configuration.
設定内容を取得します。
ConfigurationFactory - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory.
Configurationを生成します。
ConfigurationFactory() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory のコンストラクタ

ConfigurationUserInfo - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo.
情報を自由に設定可能なUserInfoです。
ConfigurationUserInfo() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のコンストラクタ

ConnectionManager - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager.
ConnectionManagerクラス
R/3へのコネクション(トランザクション)を管理するクラスです。
ConnectionManager() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のコンストラクタ

ConnectorModel - class jp.co.intra_mart.framework.base.data.ConnectorModel.
コネクタ情報を管理するクラスです。
ConnectorModel() - class jp.co.intra_mart.framework.base.data.ConnectorModel のコンストラクタ

ControllerConverter - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter.
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig.
ControllerConverterの初期化情報です。
ControllerConverterException - exception jp.co.intra_mart.framework.presentation.controller.ControllerConverterException.
ControllerConverterに関連する例外です。
ControllerConverterException() - class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException のコンストラクタ
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ControllerConverterException(String) - class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException のコンストラクタ
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ControllerConverterException(String, Throwable) - class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
ControllerObject - interface jp.co.intra_mart.framework.presentation.controller.ControllerObject.
コントローラオブジェクトのインタフェースです。
ControllingArea - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea.
管理領域情報クラス
機能は以下の通り
管理領域の情報を保持します。
ControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のコンストラクタ
管理領域情報を作成します。
ControllingAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController.
管理領域コントローラクラス
機能は以下の通り
管理領域の情報を取得します。
ControllingAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のコンストラクタ
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList.
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
ControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のコンストラクタ
executeBapiを呼び出し管理領域一覧を作成します。
Convertor - class jp.co.intra_mart.foundation.sap.common.util.data.Convertor.
Converterクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。
CoreAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes.
コア属性です。
CoreAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のコンストラクタ
CoreAttributesを新規に生成します。
CostCenter - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter.
原価センタ情報クラス
機能は以下の通り
原価センタの情報を保持します。
CostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のコンストラクタ
原価センタ情報を取得します。
CostCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController.
原価センタコントローラクラス
機能は以下の通り
原価センタの情報を取得します。
CostCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList.
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
CostCenterList(String, String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のコンストラクタ
executeBapiを呼び出し原価センタ一覧を作成します。
Counter - class jp.co.intra_mart.common.aid.jdk.util.Counter.
このクラスは、カウンター機能を提供します。
Counter() - class jp.co.intra_mart.common.aid.jdk.util.Counter のコンストラクタ
カウンターオブジェクトを作成します。
Counter(long) - class jp.co.intra_mart.common.aid.jdk.util.Counter のコンストラクタ
指定の初期値でカウンターオブジェクトを作成します。
Counter - class jp.co.intra_mart.foundation.utility.Counter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
Counter() - class jp.co.intra_mart.foundation.utility.Counter のコンストラクタ
推奨されていません。 カウンターオブジェクトを作成します。
Counter(long) - class jp.co.intra_mart.foundation.utility.Counter のコンストラクタ
推奨されていません。 指定の初期値でカウンターオブジェクトを作成します。
Cryption - interface jp.co.intra_mart.foundation.security.cryption.Cryption.
文字列の暗号化・復号化インタフェース。
CurlFieldBean - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean.
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlFieldBean() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のコンストラクタ

CurlRecordBeanIF - interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF.
CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース
CurlXMLComposer - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer.
CurlXML生成クラス
機能は以下の通り
Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。
CurlXMLComposer() - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のコンストラクタ

CurlXMLParser - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser.
CurlXMLパーサクラス
機能は以下の通り
Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。
CurlXMLParser(String, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のコンストラクタ
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。
CurlXMLParser(InputStream, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のコンストラクタ
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。
CurrencyAmount - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount.
明細通貨項目クラス
機能は以下の通り
明細通貨項目の情報を保持します。
CurrencyAmount(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のコンストラクタ
指定されたレコード番号でCurrencyAmountを作成します。
canReport() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
このストリームが書き込み可能かどうかをチェックします。
canReport() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 このストリームが書き込み可能かどうかをチェックします。
capacity() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このマップに対してマップできるキーの最大個数を返します。
capacity() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このマップに対してマップできるキーの最大個数を返します。
categoryDetailRemoved(String, CompanyCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のメソッド
ユーザを認証する。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のメソッド
管理者を認証します。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のメソッド
ユーザを認証します。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.SuperCertification のメソッド
管理者を認証する。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のメソッド
管理者を認証します。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserCertification のメソッド
ユーザを認証する。
certify(String[], String[]) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール内包を認証します。
check() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
入力内容をチェックします。
check() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
入力内容をチェックします。
checkByBaseProperty(Relationship[], BaseModel, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基準項目によるリレーションシップの整合性制約をチェックします。
checkByBaseProperty(Relationship[], BaseModel, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
基準項目によるリレーションシップの整合性制約をチェックします。
checkDigitOfNumber(Number, int, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値の整数部、小数部の桁数チェック。
checkDigitOfNumber(Number, Integer, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値の整数部、小数部の桁数チェック（引数がクラス版）。
checkDigitOfNumberString(String, int, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値（文字型）の整数部、小数部の桁数チェック
※数値かどうかのチェックも行う。
checkDigitOfNumberString(String, Integer, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）

childDirectories() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
childDirectories() - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
childDirectory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
childDirectory(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
childFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
childFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
childFiles() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
childFiles() - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
childPath(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
childPath(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
clean() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
システムのガベージコレクタを実行します。
clean() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 プール中のコネクションをすべて破棄します。
cleanUp() - interface jp.co.intra_mart.foundation.service.provider.GCConditioner のメソッド
gc を実行するかどうかを判断します。
clear() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
マップからマッピングをすべて削除します。
clear() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
clear() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
すべてのデータを削除します。
clear() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
このオブジェクトのマップからマッピングをすべて削除します。
clear() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 マップからマッピングをすべて削除します。
clear() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
clear() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
clear() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッション内に存在するすべてのオブジェクトを削除します。
clearError() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
clearError() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
clearInstance() - class jp.co.intra_mart.foundation.security.AccessSecurityManager の static メソッド
アクセスセキュリティマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
システムマネージャのインスタンスを初期化を行います。
clearInstance() - class jp.co.intra_mart.foundation.security.account.AccountManager の static メソッド
アカウントマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.batch.BatchManager の static メソッド
バッチマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager の static メソッド
カレンダーマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager の static メソッド
ログイングループマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager の static メソッド
ログイングループマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.menu.MenuManager の static メソッド
メニューマネージャのインスタンスを初期化します。
clearWarnings() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトに関して通知されたすべての警告をクリアします。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
このストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
このオブジェクトを閉じます。
close() - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力を閉じます。
close() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 releaseメソッドと同等です。
close() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーをクローズします。
close() - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーをクローズします。
close() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
ネットワークを切断します。
close() - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.HexInputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 ストリームを閉じます。
commit() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースのトランザクションをコミットします。
commit() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースのトランザクションをコミットします。
commit() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスの確定処理を行います。
commit() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
ＢＡＰＩ実行結果のCOMMIT処理を行います｡
commit() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータコネクタをコミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 コミットします。
commit() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 コミットします。
commit() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
コミットします。
companyAdded(String, Company) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyAdded(String, Company) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyDeleted(String, Company) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
companyDeleted(String, Company) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator のメソッド
順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のメソッド
順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator のメソッド
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator のメソッド
順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.page.NodeNameComparator のメソッド
順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
順序付けのために 2 つの引数を比較します。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.AbstractDualComparator のメソッド
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.FilterComparator のメソッド
推奨されていません。 順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.ReverseComparator のメソッド
推奨されていません。 フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.SequenceComparator のメソッド
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
compareTo(Object) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
この期間と指定された期間を比較します。
compileReader(Reader) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトのソースをコンパイルします。
compileString(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトのソースをコンパイルします。
connection() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
コネクションの取得。
connection() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
コネクションの取得。
connection() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のメソッド
サーバに接続するためのコネクションを取得します。
connection() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 コネクションの取得。
connection() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 コネクションの取得。
connections - class jp.co.intra_mart.framework.base.data.IntramartDBConnector の変数
推奨されていません。 DbsConnectionの一覧
connections - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の変数
リソース一覧
connections - class jp.co.intra_mart.framework.base.data.SystemDBConnector の変数
リソース一覧
contact(ConInfo) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 代替えメソッドはありません。
contact() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
contains(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
contains(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
contains(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントの存在チェックを行います。
contains(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールの存在チェックを行います。
containsCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーの存在チェックをします。
containsDate(Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
指定された日時が期間内に入っているかどうかを指定します。
containsHeader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
指定された文字列がヘッダの名称かどうかを判定します。
containsKey(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
containsKey(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
convJCOdata(int, int, Object) - class jp.co.intra_mart.foundation.sap.common.util.data.Convertor の static メソッド
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。
convert(String) - class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の static メソッド
HTML表示可能な文字列に変換します。
convert(RequestInfo) - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - interface jp.co.intra_mart.framework.presentation.view.ViewConverter のメソッド
リクエスト情報をもとにビューオブジェクトを生成します。
convertOnlyDate(long) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付のみのjava.util.Dateに変換します。
convertOnlyDate(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付のみのjava.util.Dateに変換します。
convertOnlyDateTime(long) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付と時刻のみのjava.util.Dateに変換します。
convertOnlyDateTime(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付と時刻のみのjava.util.Dateに変換します。
copyVersion(String, String, String, Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンの内容をコピーします。
copyVersion(String, String, String, Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーします。
count() - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
count() - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。
count() - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
count() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントの登録数を取得します。
count() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール数を取得します。
countByCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーに属するロール数を取得します。
countLoginGroups() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ数を取得します。
counter - class jp.co.intra_mart.foundation.page.EventScript の static 変数
このクラスからインスタンスが生成された回数。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
プライマリキーに該当する分類区分を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
プライマリキーに該当する分類区分詳細を生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
プライマリキーに該当する組織所属を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
プライマリキーに該当する会社組織分類を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
プライマリキーに該当する会社を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
プライマリキーに該当する組織を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
プライマリキーに該当する組織内包を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
プライマリキーに該当する主所属を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
プライマリキーに該当する役職を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
プライマリキーに該当する会社構成バージョンを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライマリキーに該当するプライベートグループ所属を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライマリキーに該当するプライベートグループを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
プライマリキーに該当するパブリックグループ所属を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
プライマリキーに該当するパブリックグループ分類を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
プライマリキーに該当するパブリックグループを生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
プライマリキーに該当するパブリックグループ内包を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
プライマリキーに該当するパブリックグループセットを生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
プライマリキーに該当するパブリックグループ構成バージョンを生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
プライマリキーに該当するユーザを生成します。
create(Event) - interface jp.co.intra_mart.framework.base.event.EventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome のメソッド
リモートインタフェースGenericEJBEventListenerAgentを取得します。
create() - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome のメソッド
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome のメソッド
StandardEJBEventListenerAgentと接続します。
create(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のメソッド
イベントリスナを生成します。
createBaseAccessor(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
このマッパーに該当する基本アクセサを新規に生成します。
createBaseModel(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
このマッパーに該当する基本モデルを新規に生成します。
createBaseModel(Map) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
このマッパーに該当する基本モデルを新規に生成します。
createConfiguration() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory のメソッド
Configurationを生成します。
createEvent(String, String, UserInfo) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
パラメータで指定された内容に該当するイベントを生成します。
createEvent(String, String, String, String) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
createEvent(String, String) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(RequestInfo, String, String) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createExtendedBaseAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
createExtendedBaseModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
createExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
createExtendedInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
createExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
createExtendedInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
createExtendedTerminableAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
createExtendedTerminableInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
createExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
createExtendedTerminableInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
createExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
createExtendedTerminableModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
createField(Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
qNameがFieldの場合のパーサの動作を定義します。
createFilePath(String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
指定のページパスからリンクの為のページパスを作成して返します。
createImage(Graphics) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
棒グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
円グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
折れ線グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ポートフォリオを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
レーダーチャートを描画します。
createInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
国際化アクセサを生成します。
createInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
国際化モデルを生成します。
createInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
国際化モデルを生成します。
createLoginRequestInfo(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン情報を作成します。
createMapper(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory のメソッド
マッパーを生成します。
createRecord(Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
qNameがRecordの場合のパーサの動作を定義します。
createRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を新規に追加する。
createSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッションオブジェクトを新規に生成します。
createSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッションオブジェクトを新規に生成します。
createSessionObject(ServletRequest) - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッションオブジェクトを新規に生成します。
createSocket() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
新しいソケットを作成します。
createSocket() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 新しいソケットを作成します。
createSocketConnectionDistributor(String) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のメソッド
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
createStatement() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SQL 文をデータベースに送るための Statement オブジェクトを生成します。
createStatement(int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
createStatement(int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
createTerminableAccessor(Term) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定した期間に期間化アクセサを生成します。
createTerminableInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
期間国際化アクセサを生成します。
createTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
期間国際化モデルを生成します。
createTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
期間国際化モデルを生成します。
createTerminableModel(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定した期間を満たす期間化モデルを生成します。
createTerminableModel(Term) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定した期間を満たす期間化モデルを生成します。
createToken() - class jp.co.intra_mart.framework.presentation.PresentationManager のメソッド
新しいトークンを取得します。
createURL(String, Collection) - class jp.co.intra_mart.framework.base.web.tag.TagWriter の static メソッド
推奨されていません。 このメソッドではなくTagWriter.createURL(String, Collection, String)を使用してください。
createURL(String, Collection, String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter の static メソッド
複数のパラメータをURLに追加します。
createURL(String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。
createURL(URL, String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
指定の URL を仕様解析のコンテキストとして ページベース開発モデルの画面への URL を解決した URL を返します。
createURLonSession(String) - class jp.co.intra_mart.jssp.net.URLBuilder のメソッド
HTTP セッションを維持したまま指定のページベース開発モデルの画面へ リンクするための URL を返します。
createURLonSession(URL, String) - class jp.co.intra_mart.jssp.net.URLBuilder のメソッド
HTTP セッションを維持したまま指定のページベース開発モデルの画面へ リンクするための URL を返します。
createUrlSignature(String, String, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ダイレクトＵＲＬ署名を作成します。
createUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static メソッド
intra-martのセッション情報からUserInfoを新規に生成します。
createWriter() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
メッセージをファイルへ書き出すための出力ストリームを作成します。
createWriter(OutputStreamWriter) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の static メソッド
推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。
createWriter() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 メッセージをファイルへ書き出すための出力ストリームを作成します。
currentWriter() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトが文字を書き出している基礎 Writer を返します。
currentWriter() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトが文字を書き出している基礎 Writer を返します。

D

DAO - interface jp.co.intra_mart.framework.base.data.DAO.
データリソースにアクセスするインタフェースです。
DAOAdapter - class jp.co.intra_mart.framework.base.data.DAOAdapter.
DAOのすべてのメソッドを何もしないように実装したクラスです。
DAOAdapter() - class jp.co.intra_mart.framework.base.data.DAOAdapter のコンストラクタ
DAOAdapterを新規に生成します。
DAOException - exception jp.co.intra_mart.framework.base.data.DAOException.
リソースコネクタの情報取得時の例外です。
DAOException() - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
詳細メッセージを指定しないで DAOException を構築します。
DAOException(String) - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
指定された詳細メッセージを持つ DAOException を構築します。
DAOException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。
DATA_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.data.DataManager の static 変数
データプロパティハンドラのキー
DATE - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
日時型
DBConnector - class jp.co.intra_mart.framework.base.data.DBConnector.
データベースに対するコネクタです。
DBConnector() - class jp.co.intra_mart.framework.base.data.DBConnector のコンストラクタ
DBConnectorを新規に生成します。
DBDAO - class jp.co.intra_mart.framework.base.data.DBDAO.
データベースに特化したDAOです。
DBDAO() - class jp.co.intra_mart.framework.base.data.DBDAO のコンストラクタ
デフォルトのコンストラクタ
DECIMAL - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
整数型
DEFAULT_APPLICATION_PARAMETER - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
推奨されていません。 この実装は廃止されました。
DEFAULT_AUTH_COOKIE_NAME - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
デフォルトのXMLファイル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
デフォルトのxmlファイルのプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の static 変数
デフォルトのxmlファイル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の static 変数
デフォルトのXMLファイル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.property.XmlPropertyManager の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
XMLファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
xmlのパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の static 変数
xmlファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の static 変数
XMLファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_CAPTION_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のキャプション表示位置のマージン
DEFAULT_CAPTION_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のキャプション表示位置のマージン
DEFAULT_ENCODING_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
ログインユーザのエンコーディングのデフォルトの属性名
DEFAULT_EXCEPTION_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
例外属性のデフォルトの属性名
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_FRAME_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ枠の線色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LOCALE_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
ログインユーザのロケールのデフォルトの属性名
DEFAULT_LOGIN_KEY - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_SERVICE_EXTENSION - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
サービスフレームワークをコールするためのデフォルトの拡張子
DEFAULT_SERVICE_PARAMETER - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
推奨されていません。 この実装は廃止されました。
DEFAULT_STROKE - class jp.co.intra_mart.foundation.graph.LineGraphObject の static 変数

DEFAULT_SYSTEM_MANAGER - class jp.co.intra_mart.framework.system.property.PropertyManager の static 変数
デフォルトのプロパティマネージャクラス
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の上部マージン
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
組織コード
DEPTH - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
階層レベル
DEPTH - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
階層レベル
DaoModel - class jp.co.intra_mart.framework.base.data.DaoModel.
DaoModelを管理するクラスです。
DaoModel() - class jp.co.intra_mart.framework.base.data.DaoModel のコンストラクタ

DataAccessController - class jp.co.intra_mart.framework.base.data.DataAccessController.
データアクセスを制御します。
DataAccessController(DataPropertyHandler) - class jp.co.intra_mart.framework.base.data.DataAccessController のコンストラクタ
データアクセスコントローラを生成します。
DataAccessException - exception jp.co.intra_mart.framework.base.data.DataAccessException.
データアクセス時の例外です。
DataAccessException() - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
詳細メッセージを指定しないで DataAccessException を構築します。
DataAccessException(String) - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
指定された詳細メッセージを持つ DataAccessException を構築します。
DataAccessException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。
DataConnectException - exception jp.co.intra_mart.framework.base.data.DataConnectException.
データ接続に関連する例外です。
DataConnectException() - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
詳細メッセージを指定しないで DataConnectException を構築します。
DataConnectException(String) - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
指定された詳細メッセージを持つ DataConnectException を構築します。
DataConnectException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。
DataConnector - class jp.co.intra_mart.framework.base.data.DataConnector.
データストアに接続するコネクタです。
DataConnector() - class jp.co.intra_mart.framework.base.data.DataConnector のコンストラクタ
新規のDataConnectorを生成します。
DataConnectorException - exception jp.co.intra_mart.framework.base.data.DataConnectorException.
データコネクタ取得時の例外です。
DataConnectorException() - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
詳細メッセージを指定しないで DataConnectorException を構築します。
DataConnectorException(String) - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
指定された詳細メッセージを持つ DataConnectorException を構築します。
DataConnectorException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。
DataManager - class jp.co.intra_mart.framework.base.data.DataManager.
データストアとの接続を管理します。
DataManager() - class jp.co.intra_mart.framework.base.data.DataManager のコンストラクタ
データマネージャを生成するコンストラクタです。
DataManagerException - exception jp.co.intra_mart.framework.base.data.DataManagerException.
データマネージャの設定時の例外です。
DataManagerException() - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
詳細メッセージを指定しないで DataManagerException を構築します。
DataManagerException(String) - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
指定された詳細メッセージを持つ DataManagerException を構築します。
DataManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。
DataNotFoundException - exception jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException.
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
DataNotFoundException() - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataPropertyException - exception jp.co.intra_mart.framework.base.data.DataPropertyException.
データプロパティ取得時の例外です。
DataPropertyException() - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
詳細メッセージを指定しないで DataPropertyException を構築します。
DataPropertyException(String) - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
指定された詳細メッセージを持つ DataPropertyException を構築します。
DataPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。
DataPropertyHandler - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler.
DAOの設定情報に接続するクラスです。
DataSourceConnector - class jp.co.intra_mart.framework.base.data.DataSourceConnector.
DataSourceに関連するデータコネクタです。
DataSourceConnector() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のコンストラクタ
DataSourceConnectorを新規に生成します。
DataSourceProvider - interface jp.co.intra_mart.foundation.database.DataSourceProvider.
データソース設定情報取得プロバイダインタフェース。
DataStoreApplicationException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException.
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreApplicationException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreConfigException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException.
アプリケーション共通マスタの設定に関する例外クラス

アプリケーション共通マスタの設定に不整合がある場合にスローする。
DataStoreConfigException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
詳細メッセージを指定しないで DataStoreConfigException を構築します。
DataStoreConfigException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
指定された詳細メッセージを持つ DataStoreConfigException を構築します。
DataStoreConfigException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConfigException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreSystemException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException.
アプリケーション共通マスタで発生するシステム例外の基底クラス
DataStoreSystemException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DatabaseAccessor - interface jp.co.intra_mart.foundation.database.DatabaseAccessor.
データベース接続オブジェクト取得インターフェースを定義します。
DatabaseManager - class jp.co.intra_mart.foundation.database.DatabaseManager.
データベースマネージャクラス。
DatabaseSQLException - exception jp.co.intra_mart.foundation.database.exception.DatabaseSQLException.
データベースSQL例外拡張クラス。
DatabaseSQLException(String) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, int) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, int, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DateHandler - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler.
DateHandlerクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。
DateUtil - class jp.co.intra_mart.common.platform.util.DateUtil.
日付操作ユーティリティクラスです。
DayInfo - interface jp.co.intra_mart.foundation.security.calendar.DayInfo.
日付に対するカレンダーデータ情報の取得インターフェース。
DbManager - class jp.co.intra_mart.foundation.database.DbManager.
推奨されていません。 DatabaseManagerを使用してください。
DbManager(String) - class jp.co.intra_mart.foundation.database.DbManager のコンストラクタ
推奨されていません。 DatabaseManagerを使用してください。
DbsConnection - interface jp.co.intra_mart.foundation.database.DbsConnection.
推奨されていません。 DatabaseManagerから取得したコネクションを使用してください。
DefaultDataPropertyHandler - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler.
デフォルトのデータプロパティハンドラです。
DefaultDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のコンストラクタ
DefaultDataPropertyHandlerを新規に生成します。
DefaultEventPropertyHandler - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler.
デフォルトのEventPropertyHandlerです。
DefaultEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のコンストラクタ
DefaultEventPropertyHandlerを新規に生成します。
DefaultLogAgent - class jp.co.intra_mart.framework.system.log.DefaultLogAgent.
デフォルトのログエージェントです。
DefaultLogAgent() - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のコンストラクタ

DefaultLogPropertyHandler - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler.
ログに関連するデフォルトのプロパティハンドラです。
DefaultLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のコンストラクタ
DefaultLogPropertyHandlerを新規に生成します。
DefaultMessagePropertyHandler - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler.
メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のコンストラクタ
DefaultMessagePropertyHandlerを新規に生成します。
DefaultMessagePropertyHandler - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler.
デフォルトのメッセージプロパティハンドラです。
DefaultMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のコンストラクタ
DefaultMessagePropertyHandlerを新規に生成します。
DefaultPropertyManager - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager.
デフォルトのプロパティマネージャです。
DefaultPropertyManager() - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のコンストラクタ
コンストラクタです。
DefaultServicePropertyHandler - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.
サービスの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のコンストラクタ
DefaultServicePropertyHandlerを新規に生成します。
DefaultSessionPropertyHandler - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.
セッションに関連するデフォルトのプロパティハンドラです。
DefaultSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のコンストラクタ
DefaultSessionPropertyHandlerを新規に生成します。
DefaultTransition - class jp.co.intra_mart.framework.base.service.DefaultTransition.
デフォルトの画面遷移をします。
DefaultTransition() - class jp.co.intra_mart.framework.base.service.DefaultTransition のコンストラクタ
DefaultTransitionを新規に生成します。
Delete - interface jp.co.intra_mart.foundation.datastore.common.config.Delete.
削除時の整合性制約です。
DeleteType - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType.
削除時の整合性制約のタイプです。
Department - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department.
組織の基本属性のデータを取り扱います。
Department() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ

DepartmentAttach - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach.
組織所属の基本属性のデータを取り扱います。
DepartmentAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のコンストラクタ

DepartmentAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel.
組織所属の基本モデルです。
DepartmentAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper.
組織所属に関連するマッパです。
DepartmentAttachTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable.
組織所属の期間化属性のデータを取り扱います。
DepartmentAttachTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のコンストラクタ

DepartmentAttachTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel.
組織所属の期間化モデルです。
DepartmentBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel.
組織の基本モデルです。
DepartmentInclusionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel.
組織内包の基本モデルです。
DepartmentInclusionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper.
組織内包に関連するマッパです。
DepartmentInfo - class jp.co.intra_mart.foundation.security.DepartmentInfo.
組織情報クラス。
DepartmentInfo(String, String) - class jp.co.intra_mart.foundation.security.DepartmentInfo のコンストラクタ
コンストラクタ。
DepartmentMain - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain.
主所属の基本属性のデータを取り扱います。
DepartmentMain() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のコンストラクタ

DepartmentMainBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel.
主所属の基本モデルです。
DepartmentMainMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper.
主所属に関連するマッパです。
DepartmentMainTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable.
主所属の期間化属性のデータを取り扱います。
DepartmentMainTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のコンストラクタ

DepartmentMainTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel.
主所属の期間化モデルです。
DepartmentMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper.
組織に関連するマッパです。
DepartmentStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct.
組織の階層です。
DepartmentTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable.
組織の期間化属性のデータを取り扱います。
DepartmentTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のコンストラクタ

DepartmentTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational.
組織の期間国際化属性のデータを取り扱います。
DepartmentTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のコンストラクタ

DepartmentTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel.
組織の期間国際化モデルです。
DepartmentTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel.
組織の期間化モデルです。
Directory - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory.
このクラスは、ディレクトリを扱う時に便利な機能を提供します。
Directory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(File, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
Directory - class jp.co.intra_mart.foundation.utility.file.Directory.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
Directory(String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(File, String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String, String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
DistributesDataPropertyHandler - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler.
アプリケーション毎のプロパティハンドラを呼び出します。
DistributesDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のコンストラクタ
DefaultDataPropertyHandlerを新規に生成します。
DistributesEventPropertyHandler - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler.
アプリケーション毎のEventPropertyHandlerを呼び出します。
DistributesEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のコンストラクタ
DistributesEventPropertyHandlerを新規に生成します。
DistributesServicePropertyHandler - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.
アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
DistributesServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のコンストラクタ
DefaultServicePropertyHandlerを新規に生成します。
DocumentHeader - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader.
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
DocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のコンストラクタ
伝票ヘッダ情報を作成します。
DualComparator - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator.
２つのコンパレータを使用してソートを行うためのインターフェースです。
DualComparator - interface jp.co.intra_mart.foundation.utility.DualComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
DuplicateException - exception jp.co.intra_mart.foundation.security.exception.DuplicateException.
作成時重複例外クラス。
DuplicateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException - exception jp.co.intra_mart.framework.presentation.DuplicateException.
重複しているときに発生する例外です。
DuplicateException() - class jp.co.intra_mart.framework.presentation.DuplicateException のコンストラクタ
詳細メッセージを指定しないで DuplicateException を構築します。
DuplicateException(String) - class jp.co.intra_mart.framework.presentation.DuplicateException のコンストラクタ
指定された詳細メッセージを持つ DuplicateException を構築します。
DuplicateException(String, Throwable) - class jp.co.intra_mart.framework.presentation.DuplicateException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。
dateToString(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
データベース登録用文字列を取得します。
dateToString(Date) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベース登録用文字列を取得します。
dateToString(Date) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。
datumpoint - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の変数
このリポーターがフィルタリングする基準レベル値
datumpoint - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の変数
推奨されていません。 このリポーターがフィルタリングする基準レベル値
dbConsistChk(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
decrement() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの値を１だけ減少させます。
decrement() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの値を１だけ減少させます。
decrypt(String) - interface jp.co.intra_mart.foundation.security.cryption.Cryption のメソッド
暗号化された文字列を復号するe。
decrypt(String) - class jp.co.intra_mart.foundation.security.cryption.NoCryption のメソッド
暗号化された文字列を復号するe。
decrypt(String) - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のメソッド
暗号化された文字列を復号するe。
defineInitializeTime(int, int, int) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチ初期化時間の設定。
definePath(String) - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
推奨されていません。
del(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
delAllAccount(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。
delAllLink(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
delAllMenu(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。
delAllMessage(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
delAllRole(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。
delAllSchedule(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。
delAttachInfo(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
delData(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
delData(String, boolean) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
delData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
delData(String, boolean) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
delete(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数削除します。
delete(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数削除します。
delete(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数削除します。
delete(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数削除します。
delete(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数削除します。
delete(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数削除します。
delete(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数削除します。
delete(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数削除します。
delete(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数削除します。
delete(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数削除します。
delete(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数削除します。
delete(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数削除します。
delete(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数削除します。
delete(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数削除します。
delete(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数削除します。
delete(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数削除します。
delete(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数削除します。
delete(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数削除します。
delete(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数削除します。
delete(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ削除します。
delete(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
アクセサを複数削除します。
deleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を削除する。
deleteAccount(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを削除します。
deleteAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
指定されたユーザのライセンスを削除します。
deleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を削除する。
deleteAccountRole(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを削除します。
deleteAccountRoles(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールをすべて削除します。
deleteAccounts() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントをすべて削除します。
deleteAll() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
このディレクトリパスを削除します。
deleteApplicationLicenseFromAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アプリケーションライセンスをアカウントから削除します。
deleteBatch(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を削除します。
deleteBatch(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を削除します。
deleteBatches() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
すべてのバッチ情報を削除します。
deleteCalendar(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーを削除します。
deleteCalendar(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーを削除します。
deleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
指定されたカレンダーデータを削除します。
deleteCalendarInfo(String, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを削除します。
deleteCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータを削除します。
deleteCalendars() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーを削除します。
deleteCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのカテゴリーを削除します。
deleteCategory(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのカテゴリを削除する。
deleteCategory(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリを削除する。
deleteCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーを削除します。
deleteCategoryDetail(String, String) - class jp.co.intra_mart.foundation.appcomn.Category のメソッド
推奨されていません。 CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
deleteCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済の分類区分詳細を削除します。
deleteChild(String) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューを削除します。
deleteChilds() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。
deleteCompany(Company) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社を削除します。
deleteData(String) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
deleteData(String, String[]) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
deleteDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織情報を削除します。
deleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を削除する。
deleteFavoriteMenu(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを削除します。
deleteFavoriteMenus(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューをすべて削除します。
deleteGroupSet(PublicGroupSet) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセットを削除します。
deleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを削除します。
deleteLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループを削除します。
deleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを削除します。
deleteMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを削除します。
deleteMainPagePatterns(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンをすべて削除します。
deleteMember(DepartmentAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織から人員をはずします。
deleteMember(PrivateGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループから人員をはずします。
deleteMember(PublicGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループから人員をはずします。
deleteMenuDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー組織を削除します。
deleteMenuDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織の紐付けをメニューから削除します。
deleteMenuDepartments(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー組織を削除します。
deleteMenuDepartments(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織の紐付けをメニューからすべて削除します。
deleteMenuInclusion(MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuInclusion(String, MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuItem(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを削除します。
deleteMenuItem(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを削除します。
deleteMenuItems() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューを削除します。
deleteMenuItems() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューを削除します。
deleteMenuPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー役職を削除します。
deleteMenuPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役織の紐付けをメニューから削除します。
deleteMenuPosts(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー役職を削除します。
deleteMenuPosts(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役織の紐付けをメニューからすべて削除します。
deleteMenuPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューパブリックグループを削除します。
deleteMenuPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループの紐付けをメニューから削除します。
deleteMenuPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューパブリックグループを削除します。
deleteMenuPublicGroups(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループの紐付けをメニューからすべて削除します。
deleteMenuRole(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューロールを削除します。
deleteMenuRole(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールの紐付けをメニューから削除します。
deleteMenuRoles(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューロールを削除します。
deleteMenuRoles(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールの紐付けをメニューから削除します。
deletePost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の役職情報を削除します。
deletePostData(String, String) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
deletePrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループ情報を削除します。
deleteProfile(String) - class jp.co.intra_mart.foundation.appcomn.Profile のメソッド
推奨されていません。 UserManager.deleteUser(User user) に置き換えられました。
deletePublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループ情報を削除します。
deleteRole(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのロール情報を削除する。
deleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を削除する。
deleteRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールを削除します。
deleteRoles() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロールを削除します。
deleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールIDサマリを削除する。
deleteSubRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
指定したロールのサブロールIDサマリを全削除する。
deleteSubRole(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
指定したサブロールIDを削除します。
deleteSubRoles(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全てのサブロールIDを削除します。
deleteSuperUser(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を削除します。
deleteSuperUser(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を削除します。
deleteUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを削除します。
deleteVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンを削除します。
deleteVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンを削除します。
departmentAdded(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentAdded(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentDeleted(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentDeleted(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentJoined(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentLeft(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentUpdated(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
departmentUpdated(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
destroy() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
このプールを破棄します。
destroy() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールを破棄します。
destroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの終了処理。
destroy() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
このオブジェクトの破棄処理をします。
destroy() - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
破棄します。
destroy() - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
破棄します。
destroy() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
グループデータを削除します。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
グループデータを削除します。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
id によりアクセスできるセッションデータを破棄します。
destroy() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このメソッドは、現在のセッションを破棄してしまいます。
destroy(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
グループデータを削除します。
destroy() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このイベントコントローラの破棄処理を行います。
destroy() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 このプールを破棄します。
destroy() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
サーブレットを解放します。
destroy() - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
サーブレットを破棄します。
destroy() - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter のメソッド
ControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter のメソッド
SimpleControllerConverterを破棄します。
destroy() - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector のメソッド
ForwardSelectorを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.validator.FormatValidator のメソッド
FormatValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.validator.LengthValidator のメソッド
LengthValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator のメソッド
NumericRangeValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.validator.NumericValidator のメソッド
NumericValidatorを破棄します。
destroy() - interface jp.co.intra_mart.framework.presentation.validator.Validator のメソッド
Validatorを破棄します。
destroy() - interface jp.co.intra_mart.framework.presentation.view.ViewConverter のメソッド
ViewConverterを破棄します。
directories() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のサブディレクトリの一覧を取得します。
dispatch(Event) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントに対する処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.EJBEventListener のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
イベントを実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
イベント処理を実行します。
doChain() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
doChain(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
doDecoration(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator のメソッド
アカウントをデータストアからの読み込み直後にコールされます。
doDecoration(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator のメソッド
システム管理者情報をデータストアからの読み込み直後にコールされます。
doDecoration(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator のメソッド
バッチをデータストアからの読み込み直後にコールされます。
doDecoration(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator のメソッド
カレンダーデータをデータストアからの読み込み直後にコールされます。
doDecoration(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator のメソッド
アカウントをデータストアからの読み込み直後にコールされます。
doDecoration(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator のメソッド
ログイングループをデータストアからの読み込み直後にコールされます。
doDecoration(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator のメソッド
メニューデータストアからの読み込み直後にコールされます。
doDecoration(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator のメソッド
メニューデータストアからの読み込み直後にコールされます。
doDecoration(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator のメソッド
ロール情報をデータストアから読み込んだ直後にコールされます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doExport(AccountManager, OutputStream) - interface jp.co.intra_mart.foundation.security.account.AccountExporter のメソッド
エクスポートを行います。
doExport(AccountManager, OutputStream) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
エクスポートを行います。
doExport(BatchManager, OutputStream) - interface jp.co.intra_mart.foundation.security.batch.BatchExporter のメソッド
エクスポートを行います。
doExport(BatchManager, OutputStream) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
エクスポートを行います。
doExport(CalendarManager, OutputStream) - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter のメソッド
エクスポートを行います。
doExport(CalendarManager, OutputStream) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
エクスポートを行います。
doExport(AdminMenuManager, OutputStream) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter のメソッド
エクスポートを行います。
doExport(MenuManager, OutputStream) - interface jp.co.intra_mart.foundation.security.menu.MenuExporter のメソッド
エクスポートを行います。
doExport(AdminMenuManager, OutputStream) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
エクスポートを行います。
doExport(MenuManager, OutputStream) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
エクスポートを行います。
doExport(RoleManager, OutputStream) - interface jp.co.intra_mart.foundation.security.role.RoleExporter のメソッド
エクスポートを行います。
doExport(RoleManager, OutputStream) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
エクスポートを行います。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter のメソッド
フィルタ処理します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド

doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter のメソッド

doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のメソッド
レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter のメソッド
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のメソッド
レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
フィルタを実行します。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
リクエストのエンコードを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 リクエストのパラメーターを設定後、次の処理に遷移します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
リクエストのロケールを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
リクエストのロケールを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
sessionに登録された情報と、parameterの情報を比較します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
リクエストのセッション管理をします。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
ロケールをセッションに登録し、次のフィルタに処理を移します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter のメソッド
推奨されていません。 intra-martから来るリクエストをPresentation Frameworkで扱う形式に変換します。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
GETメソッドです。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 GETメソッドに対応します。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
リクエストがGETで来た場合の処理をします。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter のメソッド
インポートを行います。
doImport(String) - interface jp.co.intra_mart.foundation.security.ExtendsImport のメソッド
拡張インポート処理を行います。
doImport(String, String) - class jp.co.intra_mart.foundation.security.ExtendsImportManager のメソッド
拡張インポート処理を実行します。
doImport(InputStream, AccountManager) - interface jp.co.intra_mart.foundation.security.account.AccountImporter のメソッド
インポートを行います。
doImport(InputStream, AccountManager) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
インポートを行います。
doImport(InputStream, BatchManager) - interface jp.co.intra_mart.foundation.security.batch.BatchImporter のメソッド
インポートを行います。
doImport(InputStream, BatchManager) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
インポートを行います。
doImport(InputStream, CalendarManager) - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter のメソッド
インポートを行います。
doImport(InputStream, CalendarManager) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
インポートを行います。
doImport(InputStream, AdminMenuManager) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter のメソッド
インポートを行います。
doImport(InputStream, MenuManager) - interface jp.co.intra_mart.foundation.security.menu.MenuImporter のメソッド
インポートを行います。
doImport(InputStream, AdminMenuManager) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
インポートを行います。
doImport(InputStream, MenuManager) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
インポートを行います。
doImport(InputStream, RoleManager) - interface jp.co.intra_mart.foundation.security.role.RoleImporter のメソッド
インポートを行います。
doImport(InputStream, RoleManager) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
インポートを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
POSTメソッドです。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 POSTメソッドに対応します。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
リクエストがPOSTで来た場合の処理をします。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
外側の一番近いMessageTagにパラメータを設定します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
外側の一番近いParameterSendableにパラメータを設定します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doubleValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
doubleValue(String, double) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
doubleValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を double 型として返します。
doubleValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の数値表現を取得します。
doubleValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を double 型として返します。

E

EJBEventListener - class jp.co.intra_mart.framework.base.event.EJBEventListener.
EJBを利用する場合のイベントリスナです。
EJBEventListener() - class jp.co.intra_mart.framework.base.event.EJBEventListener のコンストラクタ
EJBEventListenerを新規に生成します。
EJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean.
Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のコンストラクタ
EJBEventListenerAgentBeanを新規に生成します。
EJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory.
EJBEventListenerFactoryを生成します。
EJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のコンストラクタ
EJBEventListenerFactoryを新規に生成します。
EMAIL_ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
メールアドレス1
EMAIL_ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
メールアドレス１
EMAIL_ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
メールアドレス2
EMAIL_ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
メールアドレス２
END_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
終了日
END_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
終了日
EVENT_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.event.EventManager の static 変数
イベントプロパティハンドラのキー
EXCEPTION - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
例外 例外を発生させます。
EXCEPTION - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
例外 例外を発生させます。
EXTENSION_FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
内線FAX番号
EXTENSION_FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
内線FAX番号
EXTENSION_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
内線番号
EXTENSION_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
内線番号
ElementProperties - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties.
DOM をベースとした不変のプロパティセットを表します。
ElementProperties(Element) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のコンストラクタ
指定のエレメントの情報をプロパティズ化します。
ElementProperties(Element, Properties) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のコンストラクタ
指定のエレメントの情報をプロパティズ化します。
EmptyEvent - class jp.co.intra_mart.framework.base.event.EmptyEvent.
情報を何も持たないイベントです。
EmptyEvent() - class jp.co.intra_mart.framework.base.event.EmptyEvent のコンストラクタ

EmptyQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException.
クエリがない場合にスローされる例外です。
EmptyQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
EmptyQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
EmptyQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
例外を作成します。
EmptyUserInfo - class jp.co.intra_mart.framework.base.util.EmptyUserInfo.
情報を何も持たないUserInfoです。
EmptyUserInfo() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のコンストラクタ

EncodingFilter - class jp.co.intra_mart.framework.base.service.EncodingFilter.
リクエストのエンコードを設定します。
EncodingFilter() - class jp.co.intra_mart.framework.base.service.EncodingFilter のコンストラクタ

Entity - interface jp.co.intra_mart.foundation.datastore.common.config.Entity.
エンティティを定義します。
Environment - interface jp.co.intra_mart.foundation.service.provider.Environment.
このクラスは、 システムプロパティへアクセスするためのインターフェースです。
ErrorEvent - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent.
例外をイベントとして扱うためのプロトコルです。
ErrorEvent(Throwable, Object) - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のコンストラクタ
エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable, String, Object) - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のコンストラクタ
エラーを通知するためのイベントを構築します。
ErrorEvent - class jp.co.intra_mart.foundation.utility.ErrorEvent.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
ErrorEvent(Throwable, Object) - class jp.co.intra_mart.foundation.utility.ErrorEvent のコンストラクタ
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable, String, Object) - class jp.co.intra_mart.foundation.utility.ErrorEvent のコンストラクタ
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEventListener - interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener.
例外をイベントとして扱うためのスケルトン実装を提供します。
ErrorEventListener - interface jp.co.intra_mart.foundation.utility.ErrorEventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
ErrorHelperBean - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean.
例外ページで使用するHelperBeanです。
ErrorHelperBean() - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean のコンストラクタ
ErrorHelperBeanを新規に生成します。
ErrorPageProvider - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider.
エラーページプロバイダインタフェース。
Event - class jp.co.intra_mart.framework.base.event.Event.
処理を実行するための情報です。
Event() - class jp.co.intra_mart.framework.base.event.Event のコンストラクタ
イベントを新規に生成します。
EventException - exception jp.co.intra_mart.framework.base.event.EventException.
イベント生成時の例外です。
EventException() - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
詳細メッセージを指定しないで EventException を構築します。
EventException(String) - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
指定された詳細メッセージを持つ EventException を構築します。
EventException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。
EventFactoryModel - class jp.co.intra_mart.framework.base.event.EventFactoryModel.
イベントリスナーファクトリー情報を管理するクラスです。
EventFactoryModel() - class jp.co.intra_mart.framework.base.event.EventFactoryModel のコンストラクタ

EventGroupModel - class jp.co.intra_mart.framework.base.event.EventGroupModel.
Event情報を管理するクラスです。
EventGroupModel() - class jp.co.intra_mart.framework.base.event.EventGroupModel のコンストラクタ

EventListener - interface jp.co.intra_mart.common.aid.jdk.util.EventListener.
このクラスは、イベントリスナーのインターフェースです。
EventListener - interface jp.co.intra_mart.foundation.utility.EventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
EventListener - interface jp.co.intra_mart.framework.base.event.EventListener.
イベントリスナです。
EventListenerException - exception jp.co.intra_mart.framework.base.event.EventListenerException.
イベントリスナ生成時の例外です。
EventListenerException() - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
詳細メッセージを指定しないで EventListenerException を構築します。
EventListenerException(String) - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
指定された詳細メッセージを持つ EventListenerException を構築します。
EventListenerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。
EventListenerFactory - interface jp.co.intra_mart.framework.base.event.EventListenerFactory.
イベントリスナを生成します。
EventListenerFactoryParam - class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam.
イベントリスナファクトリの初期パラメータです。
EventListenerFactoryParam() - class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam のコンストラクタ
EventListenerFactoryParamを新規に生成します。
EventManager - class jp.co.intra_mart.framework.base.event.EventManager.
イベントマネージャです。
EventManagerException - exception jp.co.intra_mart.framework.base.event.EventManagerException.
イベントマネージャ設定時の例外です。
EventManagerException() - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
詳細メッセージを指定しないで EventManagerException を構築します。
EventManagerException(String) - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
指定された詳細メッセージを持つ EventManagerException を構築します。
EventManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。
EventModelProducer - class jp.co.intra_mart.framework.base.event.EventModelProducer.
イベント情報を作成するクラスです。
EventModelProducer() - class jp.co.intra_mart.framework.base.event.EventModelProducer のコンストラクタ

EventPropertyException - exception jp.co.intra_mart.framework.base.event.EventPropertyException.
イベントプロパティ取得時の例外です。
EventPropertyException() - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
詳細メッセージを指定しないで EventPropertyException を構築します。
EventPropertyException(String) - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
指定された詳細メッセージを持つ EventPropertyException を構築します。
EventPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。
EventPropertyHandler - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler.
イベントの設定情報に接続するクラスです。
EventQueueController - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController.
このクラスは、イベントリスナーを実行するイベント機能を実装します。
EventQueueController() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のコンストラクタ
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のコンストラクタ
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController - class jp.co.intra_mart.foundation.utility.EventQueueController.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
EventQueueController() - class jp.co.intra_mart.foundation.utility.EventQueueController のコンストラクタ
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long) - class jp.co.intra_mart.foundation.utility.EventQueueController のコンストラクタ
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventResult - interface jp.co.intra_mart.framework.base.event.EventResult.
イベント処理の結果です。
EventScript - class jp.co.intra_mart.foundation.page.EventScript.
ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。
EventScript(String) - class jp.co.intra_mart.foundation.page.EventScript のコンストラクタ
イベントスクリプトを作成するためのインスタンスを構築します。
EventTrigger - interface jp.co.intra_mart.framework.base.event.EventTrigger.
イベントトリガです。
EventTriggerAdapter - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter.
DAOを取得するメソッドを持ったイベントトリガです。
EventTriggerAdapter() - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のコンストラクタ
EventTriggerAdapterを新規に生成します。
EventTriggerException - exception jp.co.intra_mart.framework.base.event.EventTriggerException.
イベントトリガ生成時の例外です。
EventTriggerException() - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
詳細メッセージを指定しないで EventTriggerException を構築します。
EventTriggerException(String) - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
指定された詳細メッセージを持つ EventTriggerException を構築します。
EventTriggerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。
EventTriggerInfo - class jp.co.intra_mart.framework.base.event.EventTriggerInfo.
イベントトリガの情報です。
EventTriggerInfo() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のコンストラクタ
EventTriggerInfoを新規に生成します。
EventTriggerList - class jp.co.intra_mart.framework.base.event.EventTriggerList.
イベントトリガの集合を扱います。
EventTriggerList(String, String) - class jp.co.intra_mart.framework.base.event.EventTriggerList のコンストラクタ
EventTriggerListを新規に生成します。
EventTriggerList(String, String, boolean) - class jp.co.intra_mart.framework.base.event.EventTriggerList のコンストラクタ
EventTriggerListを新規に生成します。
EventsAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes.
ブラウザのイベントに関連するタグの属性情報です。
EventsAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のコンストラクタ
EventsAttributesを新規に生成します。
EverydayConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner.
このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
EverydayConditioner(int, int) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のコンストラクタ
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
EverydayConditioner(int, int) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のコンストラクタ
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
ExceptionHandlingFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter.
サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
ExceptionHandlingFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のコンストラクタ
新しくフィルタオブジェクトを作成します。
ExcessiveQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException.
クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
ExcessiveQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ExcessiveQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ExcessiveQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
例外を作成します。
ExpirationKey - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey.
ライフタイム期間の有効終了日時を定義します。
ExtendedBaseAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor.
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap.
拡張基本アクセサのマッピング情報を持ちます。
ExtendedBaseModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel.
拡張基本モデルを定義します。
ExtendedBaseModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel.
拡張基本モデルの情報です。
ExtendedBaseModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap.
拡張基本モデルのマッピング情報を持ちます。
ExtendedBaseTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable.
拡張基本テーブルを定義します。
ExtendedClassLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader.
このクラスは、拡張されたクラスローダーです。
ExtendedClassLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ExtendedClassLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
ExtendedDirectory - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory.
File インスタンスを作成するためのファクトリクラスです。
ExtendedDirectory(String, int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のコンストラクタ
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(File, String, int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のコンストラクタ
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedDirectory(String, int) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のコンストラクタ
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(File, String, int) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のコンストラクタ
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedEntity - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity.
拡張エンティティを定義します。
ExtendedFile - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile.
このクラスは、ファイルを扱う時に便利な機能を提供します。
ExtendedFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(File, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
ExtendedFile - class jp.co.intra_mart.foundation.utility.file.ExtendedFile.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。
ExtendedFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(File, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
ExtendedGenericBaseModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel.
拡張基本モデルの汎用的な抽象クラスです。
ExtendedGenericBaseModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のコンストラクタ

ExtendedGenericBaseModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap.
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericBaseModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のコンストラクタ

ExtendedGenericInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel.
拡張国際化モデルの汎用的な抽象クラスです。
ExtendedGenericInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のコンストラクタ

ExtendedGenericInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap.
拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のコンストラクタ

ExtendedGenericTerminableInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel.
拡張期間国際化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のコンストラクタ

ExtendedGenericTerminableInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap.
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のコンストラクタ

ExtendedGenericTerminableModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel.
拡張期間化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のコンストラクタ

ExtendedGenericTerminableModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap.
拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のコンストラクタ

ExtendedInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream.
このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のコンストラクタ
入力ストリームを構築します。
ExtendedInputStream(InputStream, ErrorEventListener) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のコンストラクタ
入力ストリームを構築します。
ExtendedInputStream - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のコンストラクタ
推奨されていません。 入力ストリームを構築します。
ExtendedInputStream(InputStream, ErrorEventListener) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のコンストラクタ
推奨されていません。 入力ストリームを構築します。
ExtendedInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor.
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap.
拡張国際アクセサのマッピング情報を持ちます。
ExtendedInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel.
拡張国際化モデルを定義します。
ExtendedInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel.
拡張国際化モデルの情報です。
ExtendedInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap.
拡張国際化モデルのマッピング情報を持ちます。
ExtendedInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable.
拡張国際化テーブルを定義します。
ExtendedModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel.
拡張モデルを定義します。
ExtendedOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream.
このクラスは、標準の出力ストリームを拡張した機能を提供します。
ExtendedOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のコンストラクタ
出力ストリームを構築します。
ExtendedOutputStream(OutputStream, ErrorEventListener) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のコンストラクタ
出力ストリームを構築します。
ExtendedOutputStream - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
ExtendedOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のコンストラクタ
推奨されていません。 出力ストリームを構築します。
ExtendedOutputStream(OutputStream, ErrorEventListener) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のコンストラクタ
推奨されていません。 出力ストリームを構築します。
ExtendedProperties - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties.
java.util.Properties を、より便利に利用するためのインタフェースを提供します。
ExtendedProperties() - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のコンストラクタ
デフォルト値を持たない空のプロパティリストを作成します。
ExtendedProperties(Properties) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のコンストラクタ
指定されたデフォルト値を持つ空のプロパティリストを作成します。
ExtendedServletException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException.
Servlet 例外の拡張モデルです。
ExtendedServletException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
例外オブジェクトを作成します。
ExtendedServletException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
指定されたメッセージを持つ例外を作成します。
ExtendedServletException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
指定されたメッセージと根本原因となった例外を持つ例外を作成します。
ExtendedServletException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
根本原因となった例外を持つ例外を作成します。
ExtendedSocket - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket.
このクラスは、ソケット通信用の入出力機能を提供します。
ExtendedSocket(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket(Socket) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket(ExtendedSocket) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
ExtendedSocket(String, int) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedSocket(Socket) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedSocket(ExtendedSocket) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable.
拡張テーブルを定義します。
ExtendedTerminableAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor.
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap.
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor.
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap.
拡張期間国際化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel.
拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel.
拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap.
拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable.
拡張期間国際化テーブルを定義します。
ExtendedTerminableModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel.
拡張期間化モデルを定義します。
ExtendedTerminableModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel.
拡張期間化モデルの情報です。
ExtendedTerminableModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap.
拡張期間化モデルのマッピング情報を持ちます。
ExtendedTerminableTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable.
拡張期間化テーブルを定義します。
ExtendedThread - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ExtendedThread() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(Runnable) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(Runnable, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread - class jp.co.intra_mart.foundation.utility.ExtendedThread.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
ExtendedThread() - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendsImport - interface jp.co.intra_mart.foundation.security.ExtendsImport.
拡張インポート処理インターフェース。
ExtendsImportManager - class jp.co.intra_mart.foundation.security.ExtendsImportManager.
拡張インポートマネージャクラス。
ExternalDirectory - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory.
共有データグループを管理するオブジェクトです。
ExternalDirectory(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ExternalMemory - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory.
共有データを管理するオブジェクトです。
ExternalMemory(String, String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ExternalMemory(ExternalDirectory, String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ejbActivate() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
"passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。
ejbCreate() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のメソッド
ホームインタフェースの引数なしのcreate()メソッドに対応します。
ejbCreate() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
ホームインタフェースの引数なしのcreate()メソッドに対応します。
ejbPassivate() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
インスタンスが"passive"状態に移る前に呼ばれるメソッドです。
ejbRemove() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。
eject(SocketConnection) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
指定コネクションをこのプールの管理から切り離します。
eject(SocketConnection) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 指定コネクションをこのプールの管理から切り離します。
encode(char) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char[]) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字列を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char[]) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字列を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encodeCaption(String) - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder の static メソッド
キャプションを変換します。
encodeURL(ServletRequest, ServletResponse, String) - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッションIDをエンコードしてURLに追加します。
encodeURL(ServletRequest, ServletResponse, String) - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッションIDをエンコードしてURLに追加します。
encodeURL(ServletRequest, ServletResponse, String) - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッションIDをエンコードしてURLに追加します。
encodeUrl(String) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
文字列をURLエンコードします。
encodeValue(String) - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder の static メソッド
<TEXTAREA>タグまたはvalue属性に入る文字列を変換します。
encrypt(String) - interface jp.co.intra_mart.foundation.security.cryption.Cryption のメソッド
文字列を暗号化する。
encrypt(String) - class jp.co.intra_mart.foundation.security.cryption.NoCryption のメソッド
文字列を暗号化する。
encrypt(String) - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のメソッド
文字列を暗号化する。
end() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックを解除します。
endElement(String, String, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
DefaultHandlerのabstractメソッドをオーバーライドします。
entityDirectory() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
entries() - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。
entries() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entries() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entries() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
セッションＩＤ一覧を取得します。
entries() - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entry(EventListener) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
イベントリスナーの登録。
entry() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターの取得。
entry(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
このフィルタによってＵＲＬの制御を行うことを定義します。
entry(HttpSession) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
このフィルタによってＵＲＬの制御を行うことを定義します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
空のグループを作成します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
空のグループを作成します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しい空のセッションを作成します。
entry() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しい空のセッションを作成します。
entry(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
空のグループを作成します。
entry(EventListener) - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 イベントリスナーの登録。
entry() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターの取得。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
グループデータを取得します。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
グループデータを取得します。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
グループデータを取得します。
entryMap() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
グループデータを取得します。
entrySet() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このマップに格納されているマッピングのセットビューを返します。
entrySet() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このマップに格納されているマッピングのセットビューを返します。
equals(Object) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
この有効期間と他の有効期間が等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
オブジェクトを比較します。
equals(Object) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
オブジェクトの比較。
equals(Object) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
オブジェクトの比較。
equals(Object) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
このオブジェクトと他のオブジェクトが等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
このオブジェクトと他のオブジェクトが等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
データモデルのチェック。
err - class jp.co.intra_mart.foundation.service.provider.Platform の static 変数
エラーログに対するメッセージ出力ストリームです。
errorIterator() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド実行中に発生した例外を返します。
errorIterator() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド実行中に発生した例外を返します。
eventGenerating() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューに登録されているイベントリスナーを一つ実行します。
eventGenerating() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューに登録されているイベントリスナーを一つ実行します。
execute(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 任意のＳＱＬ文をデータベースに対してリクエストする

insert/update/delete文を実行する。
execute() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトの実行。
execute(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトの実行。
execute(String) - class jp.co.intra_mart.foundation.scenario.PresentationPage のメソッド
プログラム実行。
execute(String, Object[]) - class jp.co.intra_mart.foundation.scenario.PresentationPage のメソッド
プログラム実行。
execute(Object) - class jp.co.intra_mart.foundation.service.client.NetworkAgent のメソッド
サーバに対して実行要求をします。
execute(ActionListener, Object) - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバに対して実行要求をします。
execute(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(URL) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
execute(Properties) - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory のメソッド
推奨されていません。
execute(Properties) - interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent のメソッド
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 action() メソッドをバッチプログラムとして実行します。
execute(Event) - interface jp.co.intra_mart.framework.base.event.EventListener のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener のメソッド
処理を実行します。
execute(Event, String) - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent のメソッド
イベント処理を行います。
execute(Event, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のメソッド
イベント処理を実行します。
execute(Event, String) - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal のメソッド
イベント処理を行います。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener のメソッド
処理を実行します。
execute(Event) - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent のメソッド
イベント処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
イベント処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
処理を実行します。
execute(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 intra-martベースモジュールのメニューからのリクエストを受け付けます。
executeBapi() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
BapiControllerにより会計伝票を登録します。
exists(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当する国際化モデルが存在するどうか判定します。
exists(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
exists(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された日時を含む期間化モデルが存在するかどうか判定します。
exists(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当する国際化モデルが存在するどうか判定します。
exists(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
exists(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された日付を含む期間化モデルが存在するかどうか判定します。
exists() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが存在するかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
セッションの維持時間を取得します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー情報・エクスポート。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報・エクスポート。

F

FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
FAX番号
FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
FAX番号
FLOAT - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
浮動少数型
FavoriteMenu - class jp.co.intra_mart.foundation.security.account.FavoriteMenu.
マイメニューモデル。
FavoriteMenu(String, String, int) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のコンストラクタ
コンストラクタ。
FavoriteMenu(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のコンストラクタ
コンストラクタ。
FileReporter - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter.
メッセージのファイル出力機能を提供します。
FileReporter(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
FileReporter - class jp.co.intra_mart.foundation.utility.report.FileReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
FileReporter(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.FileReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
FileSender - class jp.co.intra_mart.foundation.http.FileSender.
このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。
FileSender(HttpServletResponse) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, MultipurposeInternetMailExtensions) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, String) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, MultipurposeInternetMailExtensions, String) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSizeConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner.
このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
FileSizeConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner のコンストラクタ
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
FileSizeConditioner - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
FileSizeConditioner(long) - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner のコンストラクタ
推奨されていません。 メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
FileUploadFilter - class jp.co.intra_mart.framework.base.service.FileUploadFilter.
ファイルアップロード用にリクエストを変換するフィルタです。
FileUploadFilter() - class jp.co.intra_mart.framework.base.service.FileUploadFilter のコンストラクタ

FilterComparator - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator.
コンパレータのフィルターとして機能する抽象クラスです。
FilterComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のコンストラクタ
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
FilterComparator - class jp.co.intra_mart.foundation.utility.FilterComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
FilterComparator(Comparator) - class jp.co.intra_mart.foundation.utility.FilterComparator のコンストラクタ
推奨されていません。 指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
FilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent.
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
FilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のコンストラクタ
指定のイベントをラップするためのフィルターを作成します。
FilterHTTPActionEventChain - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain.
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
FilterMessageReporter - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter.
メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
FilterMessageReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
FilterMessageReporter - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
FilterMessageReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
FilterServletInputStream - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream.
InputStream を ServletInputStream に変換するためのラッパです。
FilterServletInputStream(InputStream) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のコンストラクタ
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。
FixedSizeMap - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap.
LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。
FixedSizeMap(int) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のコンストラクタ
指定されたサイズの領域を持つマップを構築します。
FixedSizeMap - class jp.co.intra_mart.foundation.utility.FixedSizeMap.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
FixedSizeMap(int) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のコンストラクタ
推奨されていません。 指定されたサイズの領域を持つマップを構築します。
ForbiddenException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException.
アクセス権限がないことを通知する例外です。
ForbiddenException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ForbiddenException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ForbiddenException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
例外を作成します。
FormTEI - class jp.co.intra_mart.framework.base.web.tag.FormTEI.
Formタグの拡張情報です。
FormTEI() - class jp.co.intra_mart.framework.base.web.tag.FormTEI のコンストラクタ
FormTEIを新規に生成します。
FormTag - class jp.co.intra_mart.framework.base.web.tag.FormTag.
FORMタグです。
FormTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のコンストラクタ
FormTagを新規に生成します。
FormTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo.
FormTagのBeanInfoです。
FormTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo のコンストラクタ
FormTagBeanInfoを新規に生成します。
FormatValidator - class jp.co.intra_mart.framework.presentation.validator.FormatValidator.
文字列の不正文字（フォーマット）チェックを行います。
FormatValidator() - class jp.co.intra_mart.framework.presentation.validator.FormatValidator のコンストラクタ

ForwardSelector - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector.
遷移先の参照を決定するセレクタです。
ForwardSelectorConfig - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig.
ForwardSelectorの初期化情報です。
ForwardSelectorException - exception jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException.
ForwardSelectorに関連する例外です。
ForwardSelectorException() - class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException のコンストラクタ
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ForwardSelectorException(String) - class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException のコンストラクタ
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ForwardSelectorException(String, Throwable) - class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
FoundationException - exception jp.co.intra_mart.foundation.exception.FoundationException.
システム基盤共通例外クラス。
FoundationException() - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(String) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(Throwable) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(String, Throwable) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationRuntimeException - exception jp.co.intra_mart.foundation.exception.FoundationRuntimeException.
システム基盤共通ランタイム例外クラス。
FoundationRuntimeException() - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(String) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(Throwable) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FrameTEI - class jp.co.intra_mart.framework.base.web.tag.FrameTEI.
Frameタグの拡張情報です。
FrameTEI() - class jp.co.intra_mart.framework.base.web.tag.FrameTEI のコンストラクタ
FrameTEIを新規に生成します。
FrameTag - class jp.co.intra_mart.framework.base.web.tag.FrameTag.
FRAMEタグです。
FrameTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のコンストラクタ
FrameTagを新規に生成します。
FrameTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo.
FrameTagのBeanInfoです。
FrameTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo のコンストラクタ
FrameTagBeanInfoを新規に生成します。
FrameworkException - exception jp.co.intra_mart.framework.system.exception.FrameworkException.
フレームワークに共通するの例外のスーパークラスです。
FrameworkException() - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
詳細メッセージを指定しないで FrameworkException を構築します。
FrameworkException(String) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
指定された詳細メッセージを持つ FrameworkException を構築します。
FrameworkException(Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkParameterSettingFilter - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter.
推奨されていません。 このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。
FrameworkParameterSettingFilter() - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のコンストラクタ
推奨されていません。
FrameworkTagException - exception jp.co.intra_mart.framework.base.web.tag.FrameworkTagException.
拡張タグの例外です。
FrameworkTagException() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
詳細メッセージを指定しないで FrameworkTagException を構築します。
FrameworkTagException(String) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
指定された詳細メッセージを持つ FrameworkTagException を構築します。
FrameworkTagException(String, Throwable) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagException(Throwable) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagParam - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam.
タグに追加されるパラメータです。
FrameworkTagParam() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam のコンストラクタ
FrameworkTagParamを新規に生成します。
FunctionContainer - class jp.co.intra_mart.foundation.scenario.FunctionContainer.
FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
FunctionContainer() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainer(Reader) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainer(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainerFile - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile.
FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
FunctionContainerFile(String, Locale) - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のコンストラクタ
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のコンストラクタ
ファンクション・コンテナをコンパイルします。
fetch(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SELECT文を発行してデータベースから指定範囲のデータを取得する

field - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するCurlFieldBean
fieldsList - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するCurlFieldBeanクラスのインスタンス格納用リスト
files(int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
files() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のファイルの一覧を取得します。
files(int) - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
finalize() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
このオブジェクトをクリーンアップします。
finalize() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
findClass(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
指定されたクラスを探します。
findDirectory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
findDirectory(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
findExtendedBaseAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。
findExtendedBaseModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
findExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
findExtendedInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
findExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
findExtendedInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
findExtendedTerminableAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
findExtendedTerminableInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
findExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
findExtendedTerminableInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
findExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
findExtendedTerminableModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
findFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
findFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
findInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
指定された言語に該当する国際化アクセサを取得します。
findInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当する国際化モデルを取得します。
findInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当する国際化モデルを取得します。
findLibrary(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
ネイティブライブラリの絶対パス名を返します。
findOption(String) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
値に該当する選択肢を取得します。
findPath(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
findPath() - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
システムのホームディレクトリを返します。
findPath(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
findResource(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
指定された名前を持つリソースを探します。
findResources(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。
findTerminableAccessor(Date) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定された日付に該当する期間化アクセサを取得します。
findTerminableInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
指定された言語に該当する期間国際化アクセサを取得します。
findTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルを取得します。
findTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルを取得します。
findTerminableModel(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された日時に該当する期間化モデルを取得します。
findTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された日付に該当する期間化モデルを取得します。
finish() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
出力ストリームへのエンコードデータの書き込みを終了します。
finish() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
バッファに保存してあるデータを書き出します。
finish() - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 出力ストリームへのエンコードデータの書き込みを終了します。
finish() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 バッファに保存してあるデータを書き出します。
fire() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
スレッド実行されるロジック。
fire() - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 スレッド実行されるロジック。
fire(Event, DataAccessController) - interface jp.co.intra_mart.framework.base.event.EventTrigger のメソッド
イベントに対する処理を行います。
fire(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
イベントに対する処理を行います。
fire(Event) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
イベントに対する処理を行います。
fire(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
イベントに対する処理です。
fire(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
イベントに対する処理です。
fireAll(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.EventTriggerList のメソッド
すべてのトリガに対してイベントの処理を行います。
floatValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
floatValue(String, float) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
floatValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を float 型として返します。
floatValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を float 型として返します。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
書き出しストリーム内のデータをすべて出力。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
この出力ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。
flush() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューに溜まっているすべてのイベントリスナーを実行します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
ストリームをフラッシュします。
flush() - interface jp.co.intra_mart.foundation.service.provider.SystemReporter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューに溜まっているすべてのイベントリスナーを実行します。
flush() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 書き出しストリーム内のデータをすべて出力。
flush() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 ストリームをフラッシュします。
forceLogin(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
強制ログイン処理を行います。
forceLogin(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
強制ログイン処理を行います。
forward(HttpServletRequest, HttpServletResponse, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定したURLにフォワードします。
forward(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定したURLにフォワードします。
freeMemory() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバシステムの空きメモリの量を返します。

G

GCConditioner - interface jp.co.intra_mart.foundation.service.provider.GCConditioner.
GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
GET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ENTIRETY_KEY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ITEM_KEY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_SUBSET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GarbageController - class jp.co.intra_mart.foundation.service.provider.GarbageController.
ガーベージコレクタを実行するクラスです。
GenericAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes.
汎用属性の集合です。
GenericAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のコンストラクタ
GenericAttributesを新規に生成します。
GenericBaseModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel.
基本モデルの汎用的な抽象クラスです。
GenericBaseModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のコンストラクタ

GenericEJBEventListener - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener.
EJBを利用する汎用的なイベントリスナです。
GenericEJBEventListener(GenericEJBEventListenerAgentHome, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener のコンストラクタ
GenericEJBEventListenerを新規に生成します。
GenericEJBEventListenerAgent - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent.
汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean.
EJBを利用する汎用的なイベントリスナーのBeanです。
GenericEJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のコンストラクタ
GenericEJBEventListenerAgentBeanを新規に生成します。
GenericEJBEventListenerAgentHome - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome.
リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal.
汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome.
ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
GenericEJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory.
GenericEJBEventListenerを生成します。
GenericEJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のコンストラクタ
GenericEJBEventListenerFactoryを新規に生成します。
GenericEJBEventListenerLocal - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal.
ローカルEJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal のコンストラクタ
GenericEJBEventListnerLocalを新規に生成します。
GenericEJBEventListenerLocalFactory - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory.
GenericEJBEventListnerLocalを新規に生成します。
GenericEJBEventListenerLocalFactory() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のコンストラクタ
GenericEJBEventListnerLocalFactoryを新規に生成します。
GenericEventListener - class jp.co.intra_mart.framework.base.event.GenericEventListener.
汎用的なイベントリスナです。
GenericEventListener() - class jp.co.intra_mart.framework.base.event.GenericEventListener のコンストラクタ
GenericEventListenerを新規に生成します。
GenericEventListenerFactory - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory.
GenericEventListenerを生成するイベントリスナファクトリです。
GenericEventListenerFactory() - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のコンストラクタ
GenericEventListenerFactoryを新規に生成します。
GenericInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel.
国際化モデルの汎用的な抽象クラスです。
GenericInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のコンストラクタ

GenericInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap.
国際化モデルマッピングの汎用的な抽象クラスです。
GenericInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のコンストラクタ

GenericTerminableInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel.
期間国際化モデルの汎用的な抽象クラスです。
GenericTerminableInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のコンストラクタ

GenericTerminableInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap.
期間国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のコンストラクタ

GenericTerminableModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel.
期間化モデルの汎用的な抽象クラスです。
GenericTerminableModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のコンストラクタ

GenericTerminableModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap.
期間化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のコンストラクタ

GenericURLBuilder - class jp.co.intra_mart.jssp.net.GenericURLBuilder.
ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。
GenericURLBuilder(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のコンストラクタ
新しいビルダを作成します。
GlAcc - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc.
勘定項目情報クラス
機能は以下の通り
勘定項目の情報を保持します。
GlAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のコンストラクタ
勘定項目情報を作成します。
GlAccController - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController.
勘定科目コントローラクラス
機能は以下の通り
勘定科目の情報を取得します。
GlAccController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccList - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList.
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
GlAccList(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のコンストラクタ
executeBapiを呼び出し勘定項目一覧を作成します。
GroupSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のコンストラクタ
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
GroupSuperUserAccessor - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor.
グループ管理者アクセッサインタフェース。
GroupSuperUserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet.
グループ管理者初期アクセスサーブレット。
GroupSuperUserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のコンストラクタ

GroupSuperUserPostWriterListener - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener.
グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
GroupSuperUserQueryWriterListener - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener.
グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
GroupSuperUserReaderDecorator - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator.
管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
Grouping - class jp.co.intra_mart.foundation.appcomn.Grouping.
推奨されていません。
Grouping(String) - class jp.co.intra_mart.foundation.appcomn.Grouping のコンストラクタ
推奨されていません。 グルーピング情報操作オブジェクトの作成。
get(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
マップが、指定されたキーにマッピングしている値を返します。
get(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が保持する値を取得します。
get(String, Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の日時に保持している値を取得します。
get(String, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の言語で保持している値を取得します。
get(String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の日時、言語で保持している値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性が保持する値を取得します。
get(String, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性が指定の言語で保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを取得します。
get() - class jp.co.intra_mart.foundation.service.client.information.Identifier のメソッド
一意性を保証されたＩＤを取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを取得します。
get(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを取得します。
get(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 マップが、指定されたキーにマッピングしている値を返します。
getAccept() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性acceptの値を取得します。
getAcceptTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベント実行要求を受け付けたおよその時刻を返します。
getAcceptcharset() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性accept-charsetの値を取得します。
getAccesskey() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
accesskeyを取得します。
getAccesskey() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
accesskeyを取得します。
getAccount(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を取得する。
getAccount(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ユーザIDにマッチしたユーザデータを１件取得します。
getAccount() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
設定されているアカウントＩＤを返します。
getAccountCount(String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント数を取得する。
getAccountFlag() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
アカウントフラグを取得します。
getAccountFlag() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
アカウントフラグを取得します。
getAccountGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細一覧を取得します｡
getAccountMenuTree(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定したアカウントのメニュー構成を取得します。
getAccountPayableList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細一覧を取得します｡
getAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を取得する。
getAccountRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロールIDをすべて取得する。
getAccountRoleIds(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールIDをすべて取得します。
getAccountRoles(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報をすべて取得する。
getAccountRoles(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールをすべて取得します。
getAccountRoles(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
有効期間内のアカウントロールをすべて取得します。
getAccountTaxList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細一覧を取得します｡
getAccounts() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループ内のすべてのユーザアカウントを取得します。
getAccountsByUserIds(String, String[]) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
指定されたユーザIDのアカウント情報をすべて取得する。
getAccountsByUserIds(String[]) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
getActivationDate() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職情報の有効開始日を取得します。
getActivationDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
開始時間を取得します。
getActivationKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティのライフタイム期間の有効開始日時を取得します。
getAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
アドレスを返します。
getAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのＩＰアドレスを返します。
getAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を取得します。
getAddress(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 アドレスを返します。
getAddress() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのＩＰアドレスを返します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所1を取得します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を取得します。
getAddress1(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所2を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を取得します。
getAddress2(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を取得します。
getAllContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
マネージャーが保持するすべての HTTP コンテキストを返します。
getAllIds() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
現在有効なすべての HttpSession のセッションＩＤを返します。
getAllIds() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
現在有効なすべての HttpSession のセッションＩＤを返します。
getAllParentRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべての親ロールの一覧を取得する。
getAllParentRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全ての親ロールIDを取得します。
getAllSubRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのサブロールの一覧を取得する。
getAllSubRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全てのサブロールサマリを取得します。
getApplication(String) - interface jp.co.intra_mart.foundation.datastore.common.config.Configuration のメソッド
指定された名前に該当するアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
リレーションシップが定義されているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブルを定義しているアプリケーションを取得します。
getApplication(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーション情報を取得します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーション名を返します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーションＩＤを返します。
getApplication() - class jp.co.intra_mart.framework.base.event.Event のメソッド
アプリケーションを取得します。
getApplication(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するアプリケーションIDを取得します。
getApplication() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
アプリケーションIDを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性applicationの値を取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
applicationを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性applicationの値を取得します。
getApplication(String) - interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler のメソッド
アプリケーションの情報を取得します。
getApplicationLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーションの登録ユーザ数を取得します。
getApplicationName() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーが定義されているアプリケーション名を取得します。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
アプリケーションIDに該当するパラメータ名を取得します。
getApplicationParamName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplications() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーション情報の一覧を取得します。
getArgument(int) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのコマンドライン引数の引数を返します。
getArgument() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
引数文字列を取得します。
getArgument() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
引数文字列を取得します。
getArgument() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
引数文字列を取得します。
getArgument(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を取得します。
getArgumentKeys() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数キーの一覧を取得します。
getArguments() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのコマンドライン引数の引数を返します。
getAshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
接続先サーバIPアドレスを取得します｡
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ライフタイム期間の有効開始日時となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.Column のメソッド
カラムに対応付ける属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping のメソッド
カラムに割り当てる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ライフタイム期間の有効終了日時となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
国際化基準項目となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping のメソッド
プライマリーキーとなる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.Property のメソッド
プロパティに対応付ける属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
期間化基準項目となる属性を取得します。
getAttribute(String) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを取得します。
getAttribute(String) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを取得します。
getAttribute(String) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを取得します。
getAttributeNames() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッション内に存在する名前の一覧を取得します。
getAttributeNames() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッション内に存在する名前の一覧を取得します。
getAttributeNames() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッション内に存在する名前の一覧を取得します。
getAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティに含まれる属性をすべて取得します。
getAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティに含まれる属性をすべて取得します。
getAutoCommit() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在の自動コミットの状態を取得します。
getBaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します｡
getBankKey() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを取得します｡
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します。
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧を取得します｡
getBankName() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を取得します｡
getBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して銀行名を取得します。
getBapiHashList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiHashの一覧を取得します。
getBapiReturnList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturnの一覧を取得します｡
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
拡張元となる基本エンティティの基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
この国際化アクセサが所属する基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサが所属する基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
基本アクセサ BaseAccessor を取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
基本アクセサを取得します。
getBaseAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
この基本モデルに割り当てられた基本アクセサを取得します。
getBaseModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
基本モデルを取得します。
getBaseName() - class jp.co.intra_mart.foundation.datastore.exception.MapperException のメソッド
メッセージを取得するためのリソースバンドルの基底名を返します。
getBaseTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
基本テーブルを取得します。
getBatch(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を取得します。
getBatch(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を取得します。
getBatchId() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチＩＤを取得します。
getBatchIds(String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
すべてのバッチIDを取得します。
getBatchIds() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチIDの一覧を取得します。
getBatches(String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
すべてのバッチ情報を取得します。
getBatches() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
すべてのバッチ情報を取得します。
getBatchesByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
引数に指定したバッチIDのバッチ情報をすべて取得します。
getBatchesByIds(String[]) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
getBusArDes() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を取得します｡
getBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域を指定して事業領域名を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を取得します｡
getBusAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します｡
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します。
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧を取得します｡
getBytes() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
この抽象パスが表すファイルからデータを読み込みます。
getBytes() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部をバイト配列として取得します。
getBytes() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
サーバからレスポンスされたコンテンツのソースをバイト列として返します。
getBytes() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 この抽象パスが表すファイルからデータを読み込みます。
getCalendarIds(String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーIDを取得します。
getCalendarIds() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーIDを取得します。
getCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを取得します。
getCalendarInfo(String, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを取得します。
getCalendarInfo() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
マッチしたカレンダーデータの一覧を取得します。
getCalendarInfoIds(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfoIds(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfos(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfosByIds(String, String, String[]) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
指定されたカレンダIDのカレンダ情報をすべて取得する。
getCalendarInfosByIds(String, String[]) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
getCapacity() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
コネクション作成最大数の取得。
getCapacity() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
コネクション作成最大数の取得。
getCapacity() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 コネクション作成最大数の取得。
getCapacity() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 コネクション作成最大数の取得。
getCaption() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプション文字列を返します。
getCaption() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
キャプションを返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプションの文字色を返します。
getCaptionMargin() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
キャプション表示位置のマージンを返します。
getCaptionMargin() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプション表示位置のマージンを返します。
getCatalog() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection の現在のカタログ名を返します。
getCategories() - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
getCategories(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリの一覧を取得する。
getCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーの一覧を取得します。
getCategorizedCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータをデータタイプ別に分類して取得します。
getCategory() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールカテゴリを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
分類区分コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
分類コードを取得します。
getCategoryDetailInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を取得します。
getCategoryManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の static メソッド
CategoryManagerを取得します。
getCateogryClassInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を取得します。
getCenterPointX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の中心値を返します。
getCenterPointY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の中心値を返します。
getCertificationErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
認証失敗エラーページURLを取得する。
getCertificationErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
認証失敗エラーページURLを取得します。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を返します。
getCharacterEncoding() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
リクエストパラメータの文字エンコーディングを返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
getCharset(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
キャラクターセットを取得します。
getCharset() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
charsetを取得します。
getChildMenuId() - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のメソッド
子メニューIDを取得します。
getChildMenuId() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
子メニューIDを取得します。
getChildMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で指定されたノードの直下の子ノードを配列で取得します。
getChildMenuIds(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
子メニューIDを取得します。
getChildMenuIds(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で指定されたノードの直下の子ノードを配列で取得します。
getChildMenuIds(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
子メニューIDを取得します。
getChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの子ノードをすべて含む Collectionを返します。
getChildNodes() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードの子をすべて含む Collectionを返します。
getChildren() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューの一覧を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を取得します｡
getCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して市区町村名を取得します。
getClassArchives() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
このクラスローダーに設定されているクラスアーカイブパスを返します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel のメソッド
基本モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel のメソッド
拡張基本モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel のメソッド
拡張国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel のメソッド
拡張期間化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel のメソッド
国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel のメソッド
期間国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel のメソッド
期間化モデルのクラス名を取得します。
getClassPaths() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
このクラスローダーに設定されているクラスパスを返します。
getClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
クライアントを取得します｡
getClientContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
クライアントのロケールを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
クライアントのロケールを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientType() - interface jp.co.intra_mart.foundation.security.ClientTypeInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
クライアントタイプを取得する。
getClientType(Locale, String) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでクライアントタイプ情報を取得します。
getClientType() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
クライアントタイプを取します。
getClientType() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
クライアントタイプを取得する。
getClientTypeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
クライアントタイプをセッションに保管するためのパラメータ名を取得する。
getClientTypes(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでクライアントタイプ情報の一覧を取得します。
getCloseSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このソケットに登録されているクローズ・イベント・リスナーを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このソケットに登録されているクローズ・イベント・リスナーを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を取得します｡
getCode() - class jp.co.intra_mart.foundation.acssecurity.AcssecurityException のメソッド

getCode() - class jp.co.intra_mart.foundation.appcomn.AppcomnException のメソッド
推奨されていません。
getCode() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
コードを取得します｡
getColor() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
棒の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフの色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
線の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
グラフ線の色を返します。
getColor() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
色を取得します。
getColor() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
背景色を取得します。
getColorCode() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンコードを取得します。
getColorPattern(Locale, String) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでカラーパターン情報を取得します。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternId() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンIDを取得します。
getColorPatternId() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
カラーパターンIDを取得する。
getColorPatternId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
カラーパターンIDを取得します。
getColorPatternId() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
カラーパターンIDを取得します。
getColorPatternIdName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
カラーパターンIDをセッションに保管するためのパラメータ名を取得する。
getColorPatterns(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでカラーパターン情報の一覧を取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumns() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブルに含まれるカラムをすべて取得します。
getColumns() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブルに含まれるカラムをすべて取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを取得します｡
getCompList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します｡
getCompName() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を取得します｡
getCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社コードを指定して会社名を取得します。
getCompanyCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyCategoryTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
会社コードを取得する。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを取得します。
getCompanyCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを取得します｡
getCompanyCode() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
会社コードを取得します。
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します。
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を取得します｡
getCompanyManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の static メソッド
CompanyManagerを取得します。
getCompanyPostTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyPostTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyPostTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getCompanyTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getComparators() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
設定されている全てのコンパレータを取得します。
getComparators() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 設定されている全てのコンパレータを取得します。
getConId() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
接続参照名を取得します。
getConfigDayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが名称であるカレンダーデータの一覧を取得します。
getConnectIDs() - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
getConnectIdsBySystem() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システムに紐付くシステム接続名の一覧を取得します。
getConnectInfo() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
getConnection(ConInfo) - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
Connectionオブジェクトを取得します。
getConnection() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
getConnection() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
接続に利用したコネクションを返します。
getConnection() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
接続に利用したコネクションを返します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.DBDAO のメソッド
このDAOに関連づけられたコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のメソッド
推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のメソッド
イントラマートで設定されているDBへのコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.SystemDBDAO のメソッド
イントラマートで設定されているDBへのコネクションを取得します。
getConnectionInfo() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベース設定情報を取得します。
getConnectionTimeout() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションのタイムアウトを取得します｡
getConnectionType() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
接続の種別を取得します。
getConnectorClassName(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorName(String, String, String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorResource(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getContent() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部を文字列表現として取得します。
getContent(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
getContent() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。
getContentLength() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部をバイト長を取得します。
getContentTransferEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
Content-Transfer-Encodingを取得します。
getContentType() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルのフォーマットを返却します。
getContentType(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
コンテントタイプを取得します。
getContents() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
コンテンツの種類を取得します。
getContextPath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextURL(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
引数で与えられたリクエストのコンテキストを示すURLを生成します。
getContextURL(HttpServletRequest, boolean) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
引数で与えられたリクエストのコンテキストを示すURLを生成します。
getControllAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します｡
getControllerObject() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
リクエストから生成されたコントローラオブジェクトを取得します。
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域コードを取得します｡
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します。
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を取得します｡
getCookieSessionInfo() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
getCookieSessionInfo(HttpServletRequest) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
クッキーからintra-martセッション情報を取得します。
getCoords() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
coordsを取得します。
getCoords() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
coordsを取得します。
getCostCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します｡
getCostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを取得します｡
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します。
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を取得します｡
getCount() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
現在有効な HttpSession の数を返します。
getCount(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定条件に該当する表内のデータ件数を取得する

getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを取得します。
getCountryCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを取得します。
getCountryCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
国コードを取得します。
getCreateSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
getCreateSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
getCreationTime(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
getCreationTime(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
getCssFile() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのCSSファイルパスを取得します。
getCuAmtBase() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を取得します｡
getCuAmtDoccur() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額を取得します｡
getCuCurrency() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを取得します｡
getCuIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を取得します｡
getCuItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号を取得します｡
getCurrencyAmountList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目一覧を取得します｡
getCurrentContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
現在のスレッドに関連付けられた HTTP コンテキストを返します。
getCurrentRequest() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在処理中のリクエストを返します。
getCurrentSession() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
このリクエストに関連づけられている現在のセッションを返します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
DAOを取得します。
getDAOName(String, String, String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getData(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。

getData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
getData(int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
指定された位置にある値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフ値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
指定された位置にある値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
指定された位置にある値を返します。
getDataAccessController() - class jp.co.intra_mart.framework.base.data.DataManager のメソッド
データアクセスコントローラを取得します。
getDataAccessController() - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
このイベントリスナで使用するデータアクセスコントローラです。
getDataId() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データＩＤを取得します。
getDataManager() - class jp.co.intra_mart.framework.base.data.DataManager の static メソッド
データマネージャを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataManager のメソッド
データプロパティハンドラを取得します。
getDataSizeX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の中心値からのデータサイズを返します。
getDataSizeY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の中心値からのデータサイズを返します。
getDataSourceNameByLoginGroup(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループIDからデータソース参照名を取得します。
getDataSourceNameBySystem(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システム接続名からデータソース参照名を取得します。
getDataSourceRefName() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
DataSourceへの参照名を取得します。
getDataType() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データタイプを取得します。
getDataX() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフのｘ値を返します。
getDataY() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフのｙ値を返します。
getDate() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
対象の日付を取得します。
getDateValue(String) - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
日付書式[YYYYMMDD]の文字列をDate型に変換します。
getDay() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
日を取得します。
getDayInfo(CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
日付情報を取得します。
getDayWeek() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
曜日を取得します。
getDbName() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このデータベース製品の名前を取得します。
getDbVersion() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このデータベース製品のバージョンを取得します。
getDebugOption() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
JavaMailに設定するデバック設定の有無を取得します。
getDefaultCalendarId() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
デフォルトカレンダーIDを取得します。
getDefaultClientType() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システムのデフォルトクライアントタイプを取得します。
getDefaultColorPatternId() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
デフォルトカラーパターンIDを取得します。
getDefaultDate() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
モデル生成時に設定されたデフォルト日時を取得します。
getDefaultEncoding(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
ロケールに対応するデフォルトエンコーディングを取得します。
getDefaultLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
モデル生成時に設定されたデフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
モデル生成時に指定された言語を取得します。
getDefaultLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
デフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
デフォルトロケールを取得します。
getDefaultPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
このクラスがロードされた時点の、System.err を 返します。
getDefaultPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
このクラスがロードされた時点の、System.out を 返します。
getDefault_value() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
デフォルト値を返します。
getDelete() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティのデータ削除時の整合性制約を取得します。
getDeleteType() - interface jp.co.intra_mart.foundation.datastore.common.config.Delete のメソッド
ターゲットエンティティの削除時の整合性制約のタイプを取得します。
getDepartmentAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentAttachTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
組織コードを取得する。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを取得します。
getDepartmentCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
組織コードを取得します。
getDepartmentMainTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentMainTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentStructs(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織の階層構造を取得します。
getDepartmentTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getDepth() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
階層レベルを取得します。
getDepth() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
階層レベルを取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを取得します｡
getDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定してテキストを取得します。
getDescription() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ内容を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データの説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
説明を取得します。
getDetails() - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のメソッド
検証結果の詳細の一覧を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性dirの値を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
dirを取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
dirを取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性dirの値を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性dirの値を取得します。
getDisplayName() - interface jp.co.intra_mart.foundation.security.ClientTypeInfo のメソッド
クライアントタイプ表示名を取得する。
getDisplayName() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターン表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ル表示名取得。
getDisplayName() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニュー表示名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール表示名を取得します。
getDisplayName() - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
表示名を取得します。
getDocAcDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号を取得します｡
getDocCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードを取得します｡
getDocDocDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付を取得します｡
getDocDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプを取得します｡
getDocFisPeriod() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間を取得します｡
getDocFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度を取得します｡
getDocHeaderTxt() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストを取得します｡
getDocObjKey() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーを取得します｡
getDocObjType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理を取得します｡
getDocPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付を取得します｡
getDocRefDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号を取得します｡
getDocUsername() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名を取得します｡
getDocument() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のメソッド
設定ファイルのドキュメントノードを返します。
getDocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダを取得します｡
getDomain() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
ドメインを返します。
getElement() - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のメソッド
現在のプロパティズの元となったエレメントノードを返します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス１を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を取得します。
getEmailAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス1を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を取得します。
getEmailAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス１を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス２を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を取得します。
getEmailAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス2を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を取得します。
getEmailAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス２を取得します。
getEncoding() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
デフォルトエンコーディングの取得。
getEncoding() - interface jp.co.intra_mart.foundation.security.LocaleProvider のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
エンコーディング情報を取得します。
getEncoding() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
エンコーディングの取得。
getEncoding() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
エンコーディングを取得します。
getEncoding(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するエンコーディングを取得します。
getEncoding() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
エンコーディングを取得する。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
エンコーディングをセッションに保管するためのパラメータ名を取得する。
getEncodings() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ルに対応しているエンコーディングの一覧の取得。
getEnctype() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性enctypeの値を取得します。
getEndDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
終了日を取得します。
getEndDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
終了日を取得します。
getEndDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
終了日を取得します。
getEndDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
終了日を取得します。
getEndDateColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間の日時に該当するカラムのカラム名を取得します。
getEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているエンティティの一覧を取得します。
getEntities(String) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
指定の名前を持つエンティティをすべて取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
アクセサの基となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が定義されているエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張対象となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデル定義の基となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブル定義の基となるエンティティを取得します。
getEntity(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
指定のインデックスに該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
指定の名前を持つエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストから指定された名前に該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストから指定された名前に該当するエンティティを取得します。
getEntityName() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーがアクセスするエンティティ名を取得します。
getEnvironment() - class jp.co.intra_mart.foundation.service.provider.Platform の static メソッド
システムの設定値を持つオブジェクトを取得します。
getEnvironmentProperty(String) - class jp.co.intra_mart.foundation.service.provider.Platform の static メソッド
指定のキーに対応するシステムの設定値を取得します。
getErrCode() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メール送信時のエラーコードを返す。
getErrMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。
getErrMessage() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メール送信時のエラーメッセージを返す。
getErrorPage(int) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からエラーページＵＲＬを取得します。
getErrorPage(int, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
エラーページＵＲＬを取得します。
getEscape() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventManager() - class jp.co.intra_mart.framework.base.event.EventManager の static メソッド
イベントマネージャを取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントのクラス名を取得します。
getEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントプロパティハンドラを取得します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
getException() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラーまたは例外を取得します。
getException() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラーまたは例外を取得します。
getException() - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean のメソッド
例外を取得します。
getException() - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
この例外が発生した原因となる例外を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExpExpList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(export(Export))の一覧を取得します｡
getExpStrList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Export))の一覧を取得します｡
getExpTblList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Export))の一覧を取得します｡
getExpirationDate() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職情報の有効終了日を取得します。
getExpirationDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
終了時間を取得します。
getExpirationKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティのライフタイム期間の有効終了日時を取得します。
getExpiredDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用期限の日付を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
管理メニューエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールエクスポート用のカテゴリの一覧を取得します。
getExportParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
export(Export)情報を返します。
getExtendedBaseAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する拡張基本アクセサのマップを取得します。
getExtendedBaseModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張基本モデルを取得します。
getExtendedBaseModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
拡張基本エンティティに対応する拡張基本モデルのマップを取得します。
getExtendedBaseModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
拡張基本モデルマップを取得します。
getExtendedBaseModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
拡張基本モデルのマップを取得します。
getExtendedBaseTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張基本テーブルを取得します。
getExtendedEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張エンティティの一覧を取得します。
getExtendedEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを拡張している拡張エンティティをすべて取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が定義されている拡張エンティティを取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデル定義の基となる拡張エンティティを取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブル定義の基となる拡張エンティティを取得します。
getExtendedInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。
getExtendedInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張国際化モデルを取得します。
getExtendedInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
拡張国際化モデルのマップを取得します。
getExtendedInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
getExtendedInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
拡張国際化モデルマップを取得します。
getExtendedInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張国際化テーブルを取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel のメソッド
拡張基本モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
この拡張エンティティを参照している拡張モデルを取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel のメソッド
拡張国際化モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel のメソッド
拡張期間化モデルが定義されている拡張モデル定義を取得します。
getExtendedModels() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張モデル定義の一覧を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
この拡張エンティティを参照している拡張テーブルを取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTables() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張テーブル定義の一覧を取得します。
getExtendedTerminableAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。
getExtendedTerminableInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。
getExtendedTerminableInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張期間国際化モデルを取得します。
getExtendedTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
拡張期間国際化モデルのマップを取得します。
getExtendedTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
getExtendedTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
拡張期間国際化モデルマップを取得します。
getExtendedTerminableInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張期間国際化テーブルを取得します。
getExtendedTerminableModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張期間化モデルを取得します。
getExtendedTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
拡張期間化モデルのマップを取得します。
getExtendedTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
getExtendedTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
拡張期間化モデルマップを取得します。
getExtendedTerminableTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張期間化テーブルを取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線FAX番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を取得します。
getExtensionNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を取得します。
getExtensionNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線番号を取得します。
getExtesion() - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスフレームワークを呼び出すための拡張子を取得します。
getFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を取得する。
getFavoriteMenuIds(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニューIDをすべて取得する。
getFavoriteMenuIds(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューIDをすべて取得します。
getFavoriteMenus(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報をすべて取得する。
getFavoriteMenus(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューをすべて取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を取得します。
getFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を取得します。
getFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
FAX番号を取得します。
getField() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
フィールドを取得します｡
getFieldsList() - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
パースした結果のフィールド一覧リストを返します。
getFile() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトが文字を書き出すファイルを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
getFile() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
現在有効なセッションを扱う SessionMemory インスタンスを取得します。
getFile(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
getFile() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトが文字を書き出すファイルを取得します。
getFileName() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
アップロードされたファイルのファイル名を取得します。
getFill() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
描画されるグラフの塗りつぶし可否を返します。
getFilterConfig() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
このフィルタの設定オブジェクトを返します。
getFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを返します。
getFilterParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
getFirstMenuIds() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
第一階層に属するノードを配列で取得します。
getFirstMenuIds() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
第一階層のメニューIDをすべて取得します。
getFirstMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
第一階層に属するノードを配列で取得します。
getFirstMenuIds() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
第一階層のメニューIDをすべて取得します。
getFlowComponent() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているフローコンポーネント名を返します。
getFontColor() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字色を返します。
getFontSize() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字サイズを返します。
getForeignKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの外部キーの集合を取得します。
getForm() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
ターゲットとなるフォーム名を取得します。
getFormObjects() - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のメソッド
フォームオブジェクトのマップを取得します。
getFormObjects() - interface jp.co.intra_mart.framework.presentation.view.ViewObject のメソッド
フォームオブジェクトのマップを取得します。
getFormclass() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性classの値を取得します。
getForwardReference(RequestInfo) - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector のメソッド
リクエスト情報から遷移先の参照を取得します。
getFrameClass() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
推奨されていません。 このメソッドではなくFrameTag.getFrameclass()メソッドを使用してください。
getFrameborder() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameborderを取得します。
getFrameclass() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameClassを取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目一覧を取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを取得します｡
getGlAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーを取得します｡
getGlBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域を取得します｡
getGlCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードを取得します｡
getGlCostcenter() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタを取得します｡
getGlDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプを取得します｡
getGlFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度を取得します｡
getGlGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定を取得します｡
getGlIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を取得します｡
getGlItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストを取得します｡
getGlItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号を取得します｡
getGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を取得します｡
getGlOrderid() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号を取得します｡
getGlPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付を取得します｡
getGlRefKey1() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーを取得します｡
getGlTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードを取得します｡
getGlWbsElement() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素を取得します｡
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphFrameColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ枠の線色を返します。
getGroup() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
設定されているグループＩＤを返します。
getGroupCode() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
グループコードを取得します。
getGroupErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ログイングループエラーページURLを取得する。
getGroupErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ログイングループエラーページURLを取得します。
getGroupSetCode() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
グループセットコードを取得します。
getHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
指定のヘッダの値を返します。
getHeader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
ヘッダの取得。
getHeaderNames() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
ヘッダ名称一覧を返します。
getHeaderNames() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
ヘッダ名称一覧の取得。
getHeight() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの高さを返却します。
getHelperclass() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
クラス名を取得します。
getHodildayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが休日であるカレンダーデータの一覧を取得します。
getHoldability() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。
getHostAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのアドレスを返します。
getHostAddress() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのアドレスを返します。
getHostName() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのホスト名を返します。
getHostName() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのホスト名を返します。
getHreflang() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
hreflangを取得します。
getHttpServletRequest() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
現在のイベントを要求したリクエストを返します。
getIDs() - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
getIDs() - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
getId() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを取得します｡
getId() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションIDを取得します。
getId() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューIDを取得します。
getIdByName(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
getIdentifier() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
コネクションの識別子を取得します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルの背景色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageFolder() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのイメージファイルのフォルダを取得します。
getImagePath() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューイメージパスを取得します。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
getImpExpType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
入力／出力区分を取得します｡
getImpImpList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(import(Import))の一覧を取得します。
getImpStrList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Import))一覧を取得します。
getImpTblList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Import))の一覧を取得します｡
getImportCategories() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
管理メニューインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールインポート用のカテゴリの一覧を取得します。
getInCharge() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を取得します｡
getInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して利益センタ責任者を取得します。
getIndex_type() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
インデックスタイプを返します。
getInitParameter(String) - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig のメソッド
ControllerConverterを初期化するときのパラメータを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig のメソッド
ForwardSelectorを初期化するときのパラメータを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig のメソッド
Validatorを初期化するときのパラメータを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig のメソッド
ViewConverterを初期化するときのパラメータを取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
初期ページURLを取得する。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
初期ページURLを取得する。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
初期ページURLを取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
初期ページURLを取得する。
getInitialCertification(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッドの情報から初期アクセス処理を行います。
getInitialCertification(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
初期アクセス処理を行います。
getInitialPage() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報から初期アクセスページURLを取得します。
getInitialPage(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報から初期アクセスページURLを取得します。
getInitialPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
初期アクセスページURLを取得します。
getInitialUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
初期ページURLを取得します。
getInitialUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
初期アクセスURLを取得する。
getInitialUrlName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
初期ページURLをセッションに保管するためパラメータ名を取得する。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
入力エラーのページを取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
入力エラーのページを取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
入力エラーのページを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
getInputErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputStream() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
入力ストリームの取得。
getInputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
このオブジェクトがラップしている入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在のリクエストのメッセージボディを返します。
getInputStream() - interface jp.co.intra_mart.foundation.database.DataSourceProvider のメソッド
データソース設定ファイルのストリームを取得します。
getInputStream() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部を入力ストリームとして取得します。
getInputStream() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 入力ストリームの取得。
getInstallDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストールされた日付を取得します。
getInstance() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の static メソッド
HTTP コンテキスト・マネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の static メソッド
インスタンスを返します。
getInstance() - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
データべースマネージャインスタンスを生成します。
getInstance() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の static メソッド
ConfigurationFactoryのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の static メソッド
JavaMailPropertyHandlerのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.AccessSecurityManager の static メソッド
セキュリティマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.ExtendsImportManager の static メソッド

getInstance() - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
システムマネージャインスタンスを生成します。
getInstance() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager の static メソッド
ログイングループマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager の static メソッド
ログイングループマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.message.MessageManager の static メソッド
メッセージマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent の static メソッド
このクラスの新しいインスタンスを取得します。
getInstance(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の static メソッド
共有データを扱うためのオブジェクトを取得します。
getInstance(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の static メソッド
共有データを扱うためのオブジェクトを取得します。
getInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
拡張もととなる国際化アクセサを取得します。
getInternationalAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
この国際化モデルに割り当てられた国際化アクセサを取得します。
getInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
国際化アクセサを取得します。
getInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する国際化アクセサのマップを取得します。
getInternationalKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの国際化基準項目を取得します。
getInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
国際化モデルを取得します。
getInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
国際化モデルのマップを取得します。
getInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
国際化モデルマップを取得します。
getInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
国際化モデルのマップを取得します。
getInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
国際化テーブルを取得します。
getJCORepository(SapConnector) - class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の static メソッド
Repository情報を生成もしくは、取得します。
getJNDIName() - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のメソッド
EJBEventListenerAgentHomeのJNDI名を取得します。
getJdbcConnection(String, String, String, String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
JDBCからコネクションオブジェクトを取得します。
getKey() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージを作成するための識別子を取得します。
getKey() - class jp.co.intra_mart.framework.base.event.Event のメソッド
イベントキーを取得します。
getKey() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
keyを取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
組織情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
役職情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
パブリックグループ情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
メニュー内包情報の識別子を取得します。
getLang() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
言語を取得します｡
getLang() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性langの値を取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
langを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
langを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性langの値を取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性langの値を取得します。
getLanguage() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
言語名を返します。
getLanguageVersion() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
言語のバージョンを返します。
getLastAccessedTime(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
getLastAccessedTime(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
getLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
マネージャーが保持する HTTP コンテキストの数を返します。
getLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
現在有効な HttpSession の数を返します。
getLicenceErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ライセンスエラーページURLを取得する。
getLicenceErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ライセンスエラーページURLを取得します。
getLicense(LoginInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
アカウントライセンスチェックを行います。
getLicense() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションライセンスが登録されているアカウント数を取得する。
getLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
グループ内で登録されているライセンス数を取得します。
getLifetime() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティの期間削除時の整合性制約を取得します。
getLifetimeType() - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime のメソッド
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します
getLimitedDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
使用期限の日付を取得します。
getLink(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
getLinkClass() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
推奨されていません。 このメソッドではなくLinkTag.getLinkclass()メソッドを使用してください。
getLinkclass() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
linkClassを取得します。
getLinkclass() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
linkClassを取得します。
getListData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
getListenerClass() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
リスナーとなっている Servlet の実行時クラスを返します。
getListenerContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
getListenerName() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
EJBEventListenerAgentBeanのクラス名を取得します。
getListenerName() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
EJBEventListenerAgentBeanのクラス名を取得します。
getLocale() - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のメソッド
ResourceBundle の Locale を返します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職名の言語を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
ロケールを取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
国際化モデルが保持する言語 Locale を取得します。
getLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
期間国際化モデルが保持する言語 Locale を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
国際化モデルが保持する言語 Locale を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
期間国際化モデルが保持する言語 Locale を取得します。
getLocale() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ロケールを取得します。
getLocale() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ル取得。
getLocale() - interface jp.co.intra_mart.foundation.security.LocaleProvider のメソッド
ロケールを取得する。
getLocale() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ロケールを取得する。
getLocale(Locale, Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでロケール情報を取得します。
getLocale() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ロケールの取得。
getLocale() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ロケールを取得する。
getLocale() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ロケールを取得する。
getLocale() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のメソッド
推奨されていません。 ResourceBundle の Locale を返します。
getLocale(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するロケールを取得します。
getLocale() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
localeを取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ロケールをセッションに保管するためのパラメータ名を取得する。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
この分類区分で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
この分類区分詳細で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
この会社で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
この組織で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
この役職で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
このパブリックグループで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
このパブリックグループセットで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
このユーザで管理している言語（ロケール）をすべて取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
現在管理している言語の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
現在管理している言語の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。
getLocales(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでロケール情報の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名として保管されているロケールの一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名として保管されているロケールの一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロケールの一覧を取得します。
getLocation() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
設定されている遷移先パスを返します。
getLockCount() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックするログイン失敗回数を取得します。
getLockDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック日付を取得します。
getLockTerm() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックする期間を取得します。
getLockedErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ユーザロックエラーページURLを取得する。
getLockedErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ユーザロックエラーページURLを取得します。
getLogAgent() - class jp.co.intra_mart.framework.system.log.LogManager のメソッド
ログエージェントを取得します。
getLogAgentName() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentName() - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentName() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentParams() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogAgentParams() - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogAgentParams() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogManager() - class jp.co.intra_mart.framework.system.log.LogManager の static メソッド
ログマネージャを取得します。
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログメッセージナンバーを取得します｡
getLogNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログナンバーを取得します｡
getLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.LogManager のメソッド
ログプロパティハンドラを取得します。
getLoginCertification() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からログイン処理を行います。
getLoginCertification(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
getLoginFailureCount() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数を取得します。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログイングループIDを取得する。
getLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループ情報を取得します。
getLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ情報を取得します。
getLoginGroup() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginGroupConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループIDからコネクションオブジェクトを取得します。
getLoginGroupID() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
getLoginGroupID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginGroupID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginGroupID(RequestInfo) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
getLoginGroupIDKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupIDKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupIDKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ログイングループIDを取得します。
getLoginGroupIds() - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループIDの一覧を取得します。
getLoginGroupIds() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループIDの一覧を取得します。
getLoginGroupName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイングループをセッションに保管するためのパラメータ名を取得する。
getLoginGroupParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ログイングループＩＤリクエストパラメータ名を取得する。
getLoginGroupParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ログイングループＩＤリクエストパラメータ名を取得する。
getLoginGroups() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループの一覧を取得します。
getLoginTime() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインした時間を取得する。
getLoginTimeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイン時間をセッションに保管するためのパラメータ名を取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインタイプを取得する。
getLoginTypeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログインタイプをセッションに保管するためのパラメータ名を取得する。
getLoginUser() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
getLoginUserID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginUserID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginUserID(RequestInfo) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
getLoginUserIDKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLoginUserIDKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLoginUserIDKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLongText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を取得します｡
getLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
getLongdesc() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
longdescを取得します。
getMailAddress() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
メールアドレス取得。
getMainPage() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からメインページURLを取得します。
getMainPage(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からメインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
メインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
メインページURLを取得する。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
メインページURLを取得する。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
メインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
メインページURLを取得する。
getMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを取得します。
getMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを取得します。
getMainPagePatternId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
メインページパターンIDを取得します。
getMainPagePatternId() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンIDを取得する。
getMainPagePatternIds(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンIDの一覧を取得します。
getMainPagePatternIds(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンIDの一覧を取得します。
getMainPagePatternImageUrl() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンイメージURLを取得する。
getMainPagePatternUrl() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンURLを取得する。
getMainPagePatterns(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンの一覧を取得します。
getManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory のメソッド
マネージャを返します。
getManager() - class jp.co.intra_mart.framework.presentation.PresentationManager の static メソッド
PresentationManagerを取得します。
getMapperClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
マッパのクラス名を取得します。
getMarginheight() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginheightを取得します。
getMarginwidth() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginwidthを取得します。
getMatchCount() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
名称設定以外でマッチしたカレンダーデータの数を取得します。
getMax() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の最大値を返します。
getMax() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の最大値を返します。
getMax() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の最大値を返します。
getMaxDate() - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
システムで許可されている最大日時を取得します。
getMaxDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term の static メソッド
システムで設定できる期間の最大日時を取得します。
getMaxDate() - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
システムで設定できる期間の最大日時を取得します。
getMaxInactiveInterval(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
getMaxInactiveInterval(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
getMaxLicense() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションの最大登録可能なラインセンス数を取得します。
getMaxLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループ内の最大登録可能ライセンス数を取得します。
getMaxProcess() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
getMediaType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプの Media Type を返します。
getMediaType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプの Media Type を返します。
getMenu(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getMenuDepartments(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー組織を取得します。
getMenuDepartments(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いた組織の一覧を取得します。
getMenuId() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
メニューIDを取得します。
getMenuIds() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューIDを取得します。
getMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューIDを取得します。
getMenuIdsByDepartment(String, DepartmentInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByDepartment(DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByPost(String, PostInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPost(PostInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(String, PublicGroupInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByRole(String, String[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuIdsByRole(String[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuInclusions() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuInclusions(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuItem(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定されたメニューIDに対応するメニューを取得します。
getMenuItem(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたメニューIDに対応するメニューを取得します。
getMenuItem() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
メニューを取得します。
getMenuItems() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューを取得します。
getMenuItems(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューを取得します。
getMenuItemsByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたユーザIDのメニュー情報をすべて取得します。
getMenuItemsByIds(String[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
getMenuPosts(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー役職を取得します。
getMenuPosts(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いた役職の一覧を取得します。
getMenuPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューパブリックグループを取得します。
getMenuPublicGroups(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いたパブリックグループの一覧を取得します。
getMenuRoles(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューロールを取得します。
getMenuRoles(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いたロールの一覧を取得します。
getMenuTree() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー構成を取得します。
getMenuTree() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー構成を取得します。
getMenuTree(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたクライアントタイプのみのメニュー構成を取得します。
getMenuTree(String, String[], boolean) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
getMessage() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラーメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
getMessage() - class jp.co.intra_mart.foundation.acssecurity.AcssecurityException のメソッド

getMessage() - class jp.co.intra_mart.foundation.appcomn.AppcomnException のメソッド
推奨されていません。
getMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージを取得します｡
getMessage(Locale, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String[]) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String[]) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラーメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Object[]) - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
ロケールを指定せず、キーに該当するメッセージを取得します。
getMessage(String, String, Object[], Locale) - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
ロケールを指定し、キーに該当するメッセージを取得します。
getMessage(String, String) - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.framework.presentation.validator.ValidationException のメソッド
例外メッセージを取得します。
getMessage() - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のメソッド
検証結果のメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
DefaultMessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。IntramartMessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。MessageManager.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
MessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessageBody() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper のメソッド
リクエストのメッセージボディを返します。
getMessageManager() - class jp.co.intra_mart.framework.base.message.MessageManager の static メソッド
メッセージマネージャを取得します。
getMessageManager() - class jp.co.intra_mart.framework.system.message.MessageManager の static メソッド
MessageManagerを取得します。
getMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
メッセージプロパティハンドラを取得します。
getMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
メッセージプロパティハンドラを取得します。
getMessageV1() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ１を取得します｡
getMessageV2() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ２を取得します｡
getMessageV3() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ３を取得します｡
getMessageV4() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ４を取得します｡
getMetaData() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続のデータベースに関するメタデータを取得します。
getMethod() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性methodの値を取得します。
getMimeEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
MIMEエンコードを取得します。
getMin() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の最小値を返します。
getMin() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の最小値を返します。
getMin() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の最小値を返します。
getMinDate() - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
システムで許可されている最小日時を取得します。
getMinDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term の static メソッド
システムで設定できる期間の最小日時を取得します。
getMinDate() - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
システムで設定できる期間の最小日時を取得します。
getMobileEmailAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを取得します。
getMobileEmailAddress(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯用メールを取得します。
getMobileNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯電話番号を取得します。
getMobileNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を取得します。
getMobileNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を取得します。
getMobileNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯電話番号を取得します。
getMobilePassword() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
モバイル用パスワードを取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel のメソッド
基本モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを参照しているモデルを取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel のメソッド
国際化モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel のメソッド
期間国際化モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel のメソッド
期間化モデルが定義されているモデル定義を取得します。
getModels() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているモデル定義の一覧を取得します。
getModifiable() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
変更可能の可否を返します。
getMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
月を取得します。
getMonthInfos(CategorizedCalendarInfo, int, int) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
月情報を取得します。
getName() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
パラメータ名を返します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のメソッド
分類区分名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
会社名または組織名を取得する。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のメソッド
役職名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel のメソッド
分類区分名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーション名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping のメソッド
カラム名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping のメソッド
プライマリーキーとなるカラム名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
リレーションシップ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
フォームのコントロール名称の取得。
getName() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
名前を返します。
getName() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
項目の表示名称のを取得します。
getName() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
項目の表示名称のを取得します。
getName() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
項目の表示名称のを取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域を指定して管理領域名を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定して一般名称を取得します。
getName() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ名を取得します。
getName() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーション名を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のメソッド
推奨されていません。 フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
このインスタンスが表すグループＩＤを取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
このインスタンスの表すロックＩＤを返します。
getName() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
このインスタンスが表すグループＩＤを取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
このインスタンスが表すセッションＩＤを取得します。
getName() - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表す名称を取得します。
getName() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
このオブジェクトの表す名称を取得します。
getName() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
イベントトリガ名を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性nameの値を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータ名を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性nameを取得します。
getName() - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータ名を取得します。
getNameAsStream() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
パラメータの名称を返します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを取得します。
getNationalHodildayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが祝祭日であるカレンダーデータの一覧を取得します。
getNativePaths() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
このクラスローダーに設定されているネイティブライブラリパスを返します。
getNetworkFile(String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。
getNetworkFile(String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のメソッド
パスに該当するNetworkFileを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次に遷移するページを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
次に遷移するページを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次に遷移するページを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
getNextPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
getNextPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
getNextPagePath(String) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNoPermissionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
無許可アクセスエラーページURLを取得する。
getNoPermissionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
無許可アクセスエラーページURLを取得する。
getNodeSet() - interface jp.co.intra_mart.foundation.page.TreeNodeProvider のメソッド
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
getNodeSet() - class jp.co.intra_mart.foundation.page.TreeRoot のメソッド
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
getNoresize() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
noresizeを取得します。
getNote() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNote() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNote() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
備考を取得します。
getNullKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Delete のメソッド
ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
getNullKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime のメソッド
ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
getNullable() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
Null受付の可否を返します。
getNumber() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ナンバーを取得します｡
getNumber() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
ソート番号を取得します。
getObject() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラー発生オブジェクトを取得します。
getObject() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラー発生オブジェクトを取得します。
getOnClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickの値を取得します。
getOnDblClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onDblClickの値を取得します。
getOnKeyDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownの値を取得します。
getOnKeyPress() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressの値を取得します。
getOnKeyUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpの値を取得します。
getOnMouseDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownの値を取得します。
getOnMouseMove() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveの値を取得します。
getOnMouseOut() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutの値を取得します。
getOnMouseOver() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverの値を取得します。
getOnMouseUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpの値を取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onblurを取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onblurを取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onBlurを取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onDblClickの値を取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onfocusを取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onfocusを取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onFocusを取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyDownの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyPressの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyUpの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseDownの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseMoveの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseUpの値を取得します。
getOnreset() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onResetの値を取得します。
getOnsubmit() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onSubmitの値を取得します。
getOption(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOption(String, String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOption() - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
選択肢をすべて取得します。
getOption(int) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
選択肢を取得します。
getOptionNames() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのオプションの名前を返します。
getOptions(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOutputStream() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
出力ストリームの取得。
getOutputStream() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 出力ストリームの取得。
getOutputStreamWriter() - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
getOutputStreamWriter() - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
getOverlap(Term[], Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
2つの期間配列 term1 と term2 で重なっている期間を返します。
getOwnerCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
所有者コードを取得します。
getOwnerCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
所有者コードを取得します。
getOwnerCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
所有者コードを取得します。
getOwnerCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
所有者コードを取得します。
getPaAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーを取得します｡
getPaBlineDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日を取得します｡
getPaGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定を取得します｡
getPaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を取得します｡
getPaItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストを取得します｡
getPaItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号を取得します｡
getPaPymtMeth() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を取得します｡
getPaVendorNo() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードを取得します｡
getPackageVersion() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
パッケージバージョンを取得します。
getPagePath() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
設定されているページパスを返します。
getParamName() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ名を取得します｡
getParamType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ属性を取得します｡
getParameter() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
パラメーターを取得します｡
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ値を取得します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このオブジェクトがフィルタリングしているハンドラを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
ラップしている親オブジェクトを返します。
getParentComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のメソッド
フィルター対象のコンパレータを返します。
getParentComparator() - class jp.co.intra_mart.foundation.utility.FilterComparator のメソッド
推奨されていません。 フィルター対象のコンパレータを返します。
getParentData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
getParentDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
親組織コードを取得します。
getParentMenuId(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId() - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のメソッド
親メニューIDを取得します。
getParentMenuId(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定されたメニューの親メニューを取得します。
getParentMenuId(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
親メニューIDを取得します。
getParentMenuId(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたメニューの親メニューを取得します。
getParentName() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
保存ディレクトリを取得します。
getParentPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
親グループコードを取得します。
getParentRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
親ロールの一覧を取得する。
getParentRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
親ロールIDを取得します。
getPasswd() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
パスワードを取得します｡
getPassword() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
パスワードを取得します。
getPassword() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
パスワード取得。
getPassword() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインパスワードを取得する。
getPassword() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインパスワードを取得する。
getPassword() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
設定されているパスワードを返します。
getPath() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このオブジェクトが表すパスを返します。
getPctrName() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を取得します｡
getPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して一般名称を取得します。
getPermissionSelector(String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
getPlugin() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
プラグインIDを取得します。
getPlugin(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータプラグインを取得します。
getPluginClass() - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo のメソッド
カレンダーデータプラグインクラス名を取得します。
getPluginId() - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo のメソッド
カレンダーデータプラグインIDを取得します。
getPluginIds() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータプラグインIDの一覧を取得します。
getPoolName() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
プール名称を取得します｡
getPoolSize() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
プール内のコネクション数を取得します｡
getPort() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
ポートを返します。
getPort() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 ポートを返します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のメソッド
役職CDを取得します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職コードを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職コードを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを取得します。
getPostCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel のメソッド
役職CDを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職コードを取得します。
getPostCode() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
役職コードを取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostName() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職名を取得します。
getPostsInCompany(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsOfUser(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPresentationPropertyHandler() - class jp.co.intra_mart.framework.presentation.PresentationManager のメソッド
PresentationPropertyHandlerを取得します。
getPrimaryComparator() - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator のメソッド
１番目コンパレータを取得します。
getPrimaryComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
第１コンパレータを返します。
getPrimaryComparator() - class jp.co.intra_mart.foundation.page.NodeTypeComparator のメソッド
第１コンパレータを取得します。
getPrimaryComparator() - interface jp.co.intra_mart.foundation.utility.DualComparator のメソッド
推奨されていません。 １番目コンパレータを取得します。
getPrimaryComparator() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 第１コンパレータを返します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティのプライマリキーとなる属性をすべて取得します。
getPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージを出力する出力ストリームを返します。
getPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージを出力する出力ストリームを返します。
getPriority() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
優先度を取得します。
getPrivateGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
グループコードを取得します。
getPrivateGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループコードを取得します。
getPrivateGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
グループコードを取得します。
getPrivateGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループコードを取得します。
getPrivateGroupManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の static メソッド
PrivateGroupManagerを取得します。
getProduct() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム情報を取得します。
getProfitCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します｡
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します。
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧を取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを取得します｡
getProgramLanguage() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラム言語を取得します。
getProgramPath() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラムパスを取得します。
getProperties(String) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のメソッド
指定のキーにマップされた値のリストを返します。
getProperties() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデルに含まれるプロパティをすべて取得します。
getProperties() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデルに含まれるプロパティをすべて取得します。
getProperties() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
JavaMailのSMTPセッションに渡す属性を初期化します。
getProperties() - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
プロパティを取得します｡
getProperties(String) - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストール情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
プロパティを取得します。
getProperty() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティ値を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのプロパティ情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストール情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
指定されたキーによって示されるシステムプロパティを取得します。
getProperty(String, String) - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
指定されたキーによって示されるシステムプロパティを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyHandler(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラを取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
指定されたキーのプロパティハンドラ名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyKeyPart() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティのキーを取得します｡
getPropertyKeys() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのプロパティ情報のキー一覧を取得します。
getPropertyManager() - class jp.co.intra_mart.framework.system.property.PropertyManager の static メソッド
プロパティマネージャを取得します。
getPropertyName() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル名を取得します。
getPropertyParams(String) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
指定されたキーのプロパティのパラメータを取得します。
getPropertyStreamAsClientType(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(クライアントタイプ)の内容取得。
getPropertyStreamAsColor(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(カラーパターン)の内容取得。
getPropertyStreamAsColorProperty(String, Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(カラーパターン)の内容取得。
getPropertyStreamAsLocale(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(ロケール)の内容取得。
getPropertyValue() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティの値を取得します｡
getPublicGroupAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupAttachTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupCategoryTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
グループコードを取得します。
getPublicGroupManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の static メソッド
PublicGroupManagerを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupSetTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupSetTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getPublicGroupStructs(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループの階層構造を取得します。
getPublicGroupTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getQuery() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
引数情報を取得します。
getQuery() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
getQueryName() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
getQueryString() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
設定されているパラメータ情報からクエリ文字列を作成して返します。
getQueryValue() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。
getReader() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部を Reader として取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
最終更新日を取得します。
getRecordList() - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
パースした結果のレコード一覧リストを返します。
getRecordNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
レコード番号を取得します｡
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
最終更新者を取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
getReferedRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
getReference() - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
getRegisteredAccountLicenses() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループにライセンス登録されているすべてのユーザIDを返します。
getRegisteredApplicationLicensesToAccount(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アカウントに登録されているアプリケーションライセンスの一覧を取得します。
getRel() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを取得します。
getRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているリレーションシップの一覧を取得します。
getRemoteHostAddress() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのアドレスを返します。
getRemoteHostName() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのホスト名を返します。
getReporters() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
セット内の要素についての反復子を返します。
getReporters() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 セット内の要素についての反復子を返します。
getRequest() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
リクエストを返します。
getRequest() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
getRequest() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
リクエストを取得します。
getRequest() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のリクエストを返します。
getRequestInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
RequestInfoを取得します。
getRequestInfo() - class jp.co.intra_mart.framework.presentation.service.PresentationServiceController のメソッド
リクエスト情報を取得します。
getRequestParameters() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper のメソッド
パラメータ情報を返します。
getRequestParameters() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在のリクエストのパラメータを返します。
getRequestTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求した時刻を返します。
getRequestURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
このコンテンツを取得するために使用した URL を返します。
getRequired() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
フォーカスの要求の有無を返します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
リソースを取得します。
getResourceConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
リソース参照名からコネクションオブジェクト取得を取得します。
getResourceParams(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResponse() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
レスポンスを返します。
getResponse() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。
getResponse() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
レスポンスを取得します。
getResponse() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のレスポンスを返します。
getResponseCode() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseCode() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseMessage() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResponseMessage() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResult() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービス処理結果を取得します。
getResult() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
サービス処理結果を取得します。
getReturn() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行結果を取得します。
getReturnList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行結果の一覧を取得します。
getRev() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
revを取得します。
getRole(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を取得します。
getRoleData(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を全件取得する。
getRoleData(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を取得する。
getRoleDataByCategory(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリからロール情報を取得する。
getRoleId() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロールIDを取得します。
getRoleId() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールIDを取得します。
getRoleIds(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントに紐付く有効なロールIDをすべて取得します。
getRoleIds() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロールIDを取得します。
getRoleName() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール名を取得します。
getRoleValidEndDate() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効終了日を取得します。
getRoleValidStartDate() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効開始日を取得します。
getRoles() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロール情報を取得します。
getRolesByCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリー検索によりロールを取得します。
getRolesByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
指定されたロールIDのロール情報をすべて取得する。
getRolesByIds(String[]) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
getRow() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
行番号を取得します｡
getRunDay() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行日を取得します。
getRunDayWeek() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行曜日を取得します。
getRunHour() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行時を取得します。
getRunMinute() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行分を取得します。
getRunMonth() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行月を取得します。
getRunSecond() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行秒を取得します。
getRunYear() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行年を取得します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCountX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の目盛間隔を返します。
getScaleCountY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScalePosition() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛りの表示位置を返します。
getSchedule(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getScript() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
設定された情報からイベントのためのスクリプトを作成します。
getScrolling() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
scrollingを取得します。
getSecondaryComparator() - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator のメソッド
２番目コンパレータを取得します。
getSecondaryComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
第２コンパレータを返します。
getSecondaryComparator() - class jp.co.intra_mart.foundation.page.NodeTypeComparator のメソッド
第２コンパレータを取得します。
getSecondaryComparator() - interface jp.co.intra_mart.foundation.utility.DualComparator のメソッド
推奨されていません。 ２番目コンパレータを取得します。
getSecondaryComparator() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 第２コンパレータを返します。
getSecurityExt() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 セキュリティの拡張子を取得します。
getSelectString() - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
この選択肢が選択済である場合の表示名を取得します。
getSelected() - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
選択済の選択肢をすべて取得します。
getSelected(int) - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
選択済みである選択肢を取得します。
getSelected() - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem のメソッド
選択済の選択肢を取得します。
getSeparateKey(int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
getSerialNo() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
シリアルナンバーを取得します。
getServerType() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
サーバタイプを取得します｡
getService() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているサービスＩＤを返します。
getService(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するサービスIDを取得します。
getService() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスIDを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性serviceの値を取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性serviceの値を取得します。
getServiceController(String, String) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
getServiceController(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスコントローラを取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
getServiceControllerName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
処理エラーのページを取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
処理エラーのページを取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
処理エラーのページを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
getServiceErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
getServiceErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 サービスマネージャを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.ServiceManager の static メソッド
サービスマネージャを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスマネージャを取得します。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスIDに該当するパラメータ名を取得します。
getServiceParamName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
サービスプロパティハンドラを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServletConfig() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。
getServletContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
この Filter を実行している ServletContext への参照を返します。
getServletContext() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
サーブレットコンテキストを返します。
getSession() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
このリクエストに関連づけられている現在のセッションを返します。
getSession() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
getSessionConfig() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
セッション情報保管パラメータを取得します。
getSessionCookieName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
クッキーにセッション情報を保管するためパラメータ名を取得する。
getSessionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
セッションエラーページURLを取得する。
getSessionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
セッションエラーページURLを取得する。
getSessionErrorPagePath() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionErrorPagePath() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionErrorPagePath() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionFactory() - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションファクトリを取得します。
getSessionFactoryName() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionFactoryName() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionFactoryName() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionID() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッションを一意に識別するIDを取得します。
getSessionID() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッションを一意に識別するIDを取得します。
getSessionID() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッションを一意に識別するIDを取得します。
getSessionInfo() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からintra-martセッション情報を取得します。
getSessionInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッション情報を取得します。
getSessionManager() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 セッションマネージャを取得します。
getSessionManager() - class jp.co.intra_mart.framework.base.session.SessionManager の static メソッド
セッションマネージャを取得します。
getSessionMode() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッションの状態を取得します。
getSessionMode(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッションの状態を取得します。
getSessionObject() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
getSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションオブジェクトを取得します。
getSessionObjectKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionObjectKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionObjectKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionParameter() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionParameter() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionParameter() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionPropertyHandler() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 セッションプロパティハンドラを取得します。
getSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションプロパティハンドラを取得します。
getSessionTimeoutErrorPage(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
セッションタイムアウトエラーページURLを取得する。
getSessionTimeoutErrorPage(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
セッションタイムアウトエラーページURLを取得する。
getShape() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
shapeを取得します。
getShape() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
shapeを取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を取得します｡
getShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
getShutdownListeners() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
現在登録されているリスナを返します。
getSignature() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログイン署名を取得する。
getSignatureName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイン署名をセッションに保管するためのパラメータ名を取得する。
getSize() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点のサイズを返します。
getSize() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールが現在管理しているコネクション数です。
getSocket() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このオブジェクトの持つソケットオブジェクトを返します。
getSocket() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このオブジェクトの持つソケットオブジェクトを返します。
getSocketConnectionDistributor() - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のメソッド
このオブジェクトが保持しているネットワークのコネクションプールを 返します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ソートキーを取得します。
getSortNumber() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
ソート番号を取得します。
getSortNumber() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ソート番号を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
国際化基準項目の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
期間化基準項目の基点となるソースエンティティの情報を取得します。
getSourceRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティをソースとしているリレーションシップをすべて取得します。
getStartDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
開始日を取得します。
getStartDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
開始日を取得します。
getStartDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
開始日を取得します。
getStartDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
開始日を取得します。
getStartDateColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間の開始日時に該当するカラムのカラム名を取得します。
getStartPoint() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているスタートポイント名を返します。
getStream() - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
システム設定ファイルの内容取得。
getStringDate(Date) - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。
getStroke() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
描画される線の描画属性を返します。
getStruct(String) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManagerの各メソッドに置き換えられました。
getStructureParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
structure(Export)情報を返します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性styleの値を取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性styleの値を取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性styleの値を取得します。
getSubPanelViewObjects() - interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject のメソッド
サブパネルに対応するPanelBasedViewObjectを取得します。
getSubPanelViewObjects() - class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject のメソッド
サブパネルに対応するPanelBasedViewObjectを取得します。
getSubRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
サブロール(一階層のみ)を取得します。
getSubRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールIDサマリを取得する。
getSubType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプの subtype を返します。
getSubType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプの subtype を返します。
getSubmitclass() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性classの値を取得します。
getSuperUser() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を取得します。
getSuperUser() - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を取得します。
getSuperUser(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を取得します。
getSuperUser(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を取得します。
getSysdate() - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
システム日付を取得します。
getSysnr() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
システム番号を取得します｡
getSystem() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを取得します｡
getSystemConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システム接続名からコネクションオブジェクトを取得します。
getSystemErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
認証処理エラーページURLを取得する。
getSystemErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
認証処理エラーページURLを取得する。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
システムエラーのページを取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
システムエラーのページを取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
システムエラーのページを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
getSystemErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム全体の登録ライセンス数。
getSystemMaxDate() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
最大の未来日を取得します。
getSystemMaxLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム全体のライセンス数。
getSystemMenu() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システムメニューを取得します。
getSystemMinDate() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
最大の過去日を取得します。
getSystemProperty(String) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの値を返します。
getSystemPropertyNameSet() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。
getSystemTemporaryDirectory() - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の static メソッド
システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
getTaGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定を取得します｡
getTaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を取得します｡
getTaItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号を取得します｡
getTaTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードを取得します｡
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
tabindexを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
tabindexを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
tabindexを取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを参照しているテーブルを取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルが定義されているテーブル定義を取得します。
getTableParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
table(Export)情報を返します。
getTables() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているテーブル定義の一覧を取得します。
getTagClass() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性classの値を取得します。
getTagWriter() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
TagWriterを取得します。
getTarget() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性targetの値を取得します。
getTarget() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
targetを取得します。
getTargetEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティの情報を取得します。
getTargetRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティをターゲットとしているリレーションシップをすべて取得します。
getTelNo() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
電話番号取得。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
電話番号を取得します。
getTerm() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
期間を取得します。
getTerm() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間化モデルが保持する期間 Term を取得します。
getTerm() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間化モデルが保持する期間 Term を取得します。
getTermCode() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
期間CDを取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
拡張もととなる期間化アクセサを取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
この期間国際化アクセサが所属する期間化アクセサを取得します。
getTerminableAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
この期間化モデルに割り当てられた期間化アクセサを取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間化アクセサを取得します。
getTerminableAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する期間化アクセサのマップを取得します。
getTerminableInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
拡張もととなる期間国際化アクセサを取得します。
getTerminableInternationalAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。
getTerminableInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
期間国際化アクセサを取得します。
getTerminableInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサに対する期間国際化アクセサのマップを取得します。
getTerminableInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
期間国際化モデルを取得します。
getTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間国際化モデルのマップを取得します。
getTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間国際化モデルを取得します。
getTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間国際化モデルマップを取得します。
getTerminableInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
期間国際化テーブルを取得します。
getTerminableKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの期間化基準項目を取得します。
getTerminableModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
期間化モデルを取得します。
getTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
期間化モデルのマップを取得します。
getTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
期間化モデルマップを取得します。
getTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
期間化モデルのマップを取得します。
getTerminableTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
期間化テーブルを取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
この組織所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
この会社組織分類で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
この会社で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
この組織で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
この主所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
この役職で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
このパブリックグループ所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
このパブリックグループ分類で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
このパブリックグループで管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
このパブリックグループセットで管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このユーザで管理している期間をすべて取得します。
getTerms() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
現在管理している期間の一覧を取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
getTerms() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
getThrowable() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
処理中に発生した例外を取得します。
getThrowablePrintListener() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
現在の例外出力リスナを返します。
getTimeoutCheckPeriod() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションのタイムアウトのチェック間隔を取得します｡
getTimes() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
次を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性titleの値を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性titleの値を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性titleの値を取得します。
getTransactionIsolation() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection の現在のトランザクション遮断レベルを取得します。
getTransition(String, String) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
getTransition(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
トランジションを取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
getTransitionName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプを返します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性の型を取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Column のメソッド
カラムの型を取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Property のメソッド
プロパティの型を取得します。
getType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
タイプを取得します｡
getType() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションタイプを取得します。
getType() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ノードのタイプを取得します。
getType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプを返します。
getType() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
typeを取得します。
getTypeMap() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続に関連した型マップオブジェクトを取得します。
getURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
サーバから返されたＵＲＬを返します。
getURL(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getUpdateInfo() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティの更新情報を取得します。
getUpdateTimestamp() - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo のメソッド
エンティティの更新日付となる属性を取得します。
getUpdateUser() - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo のメソッド
エンティティの更新ユーザとなる属性を取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを取得します。
getUrl(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを取得します。
getUrl(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
URLを取得します。
getUrlName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。
getUrlParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ダイレクトＵＲＬリクエストパラメータ名を取得する。
getUrlParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ダイレクトＵＲＬリクエストパラメータ名を取得する。
getUrlSignParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
getUrlSignParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignatureName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。
getUser() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
ユーザを取得します｡
getUser() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインユーザIDを取得する。
getUser() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインユーザIDを取得する。
getUser() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインユーザIDを取得する。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザコードを取得します。
getUserID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインユーザIDを取得する。
getUserId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ユーザIDを取得します。
getUserId() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ユーザID取得。
getUserIds(String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
ユーザIDの一覧を取得する。
getUserIds() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
すべてのユーザIDを取得します。
getUserIdsByAccountRole(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByAccountRole(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByRole(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
有効なロールIDを持つすべてのユーザIDを取得します。
getUserIdsByRoles(String, String[], Date) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.event.Event のメソッド
ログインユーザの情報を取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
ユーザ情報を取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
ログインユーザ情報を取得します。
getUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
ユーザ情報を取得します。
getUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
ユーザ情報を取得します。
getUserInfo(RequestInfo) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
ログインユーザ情報を取得します。
getUserManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の static メソッド
UserManagerを取得します。
getUserName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ユーザＩＤをセッションに保管するためのパラメータ名を取得する。
getUserParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ユーザＩＤリクエストパラメータ名を取得する。
getUserParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ユーザＩＤリクエストパラメータ名を取得する。
getUserTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を取得します。
getUserTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された日時に対する期間化情報を取得します。
getUserTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getValidEndDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効終了日を取得します。
getValidEndYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効終了年を取得します。
getValidStartDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効開始日取得。
getValidStartYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効開始年を取得します。
getValidTo() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を取得します｡
getValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して有効終了日を取得します。
getValidationExceptionDetails() - class jp.co.intra_mart.framework.presentation.validator.ValidationException のメソッド
検証結果の詳細の一覧を取得します。
getValue() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を文字列表現として返します。
getValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性valueを取得します。
getValue() - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
値を取得します。
getValue() - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータの値を取得します。
getValueAsReader() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を Reader として取得します。
getValueAsStream() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を入力ストリームとして取得します。
getValueLength() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部のバイト長を返します。
getValues() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージで使用する置換用の文字列を取得します。
getVariableInfo(TagData) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のメソッド
スクリプティング変数に関連付けたHelperBeanの情報を取得します。
getVersion() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
バージョンを取得します。
getVersionCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
バージョンコードを取得します。
getVersionCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
バージョンコードを取得します。
getViewInfo() - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のメソッド
表示情報を取得します。
getViewInfo() - interface jp.co.intra_mart.framework.presentation.view.ViewObject のメソッド
表示情報を取得します。
getViewObject() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
生成されたビューオブジェクトを取得します。
getWaitTime() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクション取得の待機時間を取得します｡
getWarnings() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection に関する呼び出しによって通知された最初の警告を返します。
getWeek() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
週を取得します。
getWeekdayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが非休日であるカレンダーデータの一覧を取得します。
getWidth() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの幅を返却します。
getXMailerHeader() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
送信メールに付加するX-Mailerヘッダを取得します。
getYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
年を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を取得します。
getZipCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を取得します。
getZipCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
郵便番号を取得します。
getenv(String) - class jp.co.intra_mart.foundation.http.CGIEnvironment のメソッド
値の取得。
groupSetAdded(String, PublicGroupSet) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetAdded(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。

H

HOME_PARAM - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の static 変数
ホームインタフェースを取得するときのJNDI名のパラメータ名
HTMLEncoder - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder.
文字列をHTML形式で表示するための変換を行うユーティリティクラスです。
HTMLEncoder() - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder のコンストラクタ

HTTPActionEvent - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext.
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContent - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent.
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext.
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventEntityHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler.
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventEntityHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventException - exception jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException.
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventException(String) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler.
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のコンストラクタ
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
HTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler.
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventHandlerException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException.
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException.
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventHandlerParameterException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventListenerContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext.
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。
HTTPActionEventResult - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult.
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventResultWrapper - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper.
HTTPActionEventResult のラッパーオブジェクトです。
HTTPActionEventResultWrapper(HTTPActionEventResult) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のコンストラクタ
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
HTTPActionEventURL - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL.
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
HTTPContext - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext.
リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。
HTTPContextHandlingFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter.
このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
HTTPContextHandlingFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のコンストラクタ
デフォルト・コンストラクタ
HTTPContextManager - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager.
HTTP コンテキスト・マネージャ
HTTPContextManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のコンストラクタ
デフォルトコンストラクタ HTTPContextManager.getInstance()を利用してください。
HelperBean - class jp.co.intra_mart.framework.base.web.bean.HelperBean.
画面表示をする時のヘルパークラスです。
HelperBean() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のコンストラクタ
HelperBeanを新規に生成します。
HelperBeanException - exception jp.co.intra_mart.framework.base.web.bean.HelperBeanException.
HelperBean内で発生した例外です。
HelperBeanException() - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
詳細メッセージを指定しないで HelperBeanException を構築します。
HelperBeanException(String) - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
指定された詳細メッセージを持つ HelperBeanException を構築します。
HelperBeanException(String, Throwable) - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。
HelperBeanTEI - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI.
HelperBeanタグの拡張情報です。
HelperBeanTEI() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のコンストラクタ
HelperBeanTEIを新規に生成します。
HelperBeanTag - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag.
HelperBeanタグです。
HelperBeanTag() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のコンストラクタ
HelperBeanTagを新規に生成します。
HelperBeanTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo.
HelperBeanTagのBeanInfoです。
HelperBeanTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo のコンストラクタ
HelperBeanTagBeanInfoを新規に生成します。
HexInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream.
このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
HexInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のコンストラクタ
指定された InputStream から読み込む HexInputStream を作成します。
HexInputStream - class jp.co.intra_mart.foundation.utility.io.HexInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
HexInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.HexInputStream のコンストラクタ
推奨されていません。 指定された InputStream から読み込む HexInputStream を作成します。
HexOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream.
このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
HexOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のコンストラクタ
指定された OutputStream に書き込む HexOutputStream を作成します。
HexOutputStream - class jp.co.intra_mart.foundation.utility.io.HexOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
HexOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む HexOutputStream を作成します。
HomeDirectory - class jp.co.intra_mart.foundation.service.provider.HomeDirectory.
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
HttpServletRequestMessageBodyWrapper - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper.
HttpServletRequest を拡張したインタフェースです。
HttpServletRequestMessageBodyWrapperBuilder - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder.
HttpServletRequest を拡張したインタフェースです。
HttpSessionFactory - class jp.co.intra_mart.framework.base.session.HttpSessionFactory.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
HttpSessionFactory() - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のコンストラクタ
推奨されていません。 HttpSessionFactoryを新規に生成します。
HttpSessionManager - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager.
HttpSession に関する情報を提供するクラスの共通インタフェース定義です。
HttpSessionManagerFactory - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory.
HttpSessionManager を作成するファクトリクラスの抽象実装です。
HttpSessionManagerFactory() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory のコンストラクタ
新しい HttpSessionManagerFactory を構築します。
HttpSessionMonitoringFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter.
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。
HttpSessionMonitoringFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のコンストラクタ
新しい HttpSessionMonitoringFilter を構築します。
HttpSessionMonitoringListener - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener.
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。
HttpSessionMonitoringListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のコンストラクタ
新しいセッションリスナを構築します。
HttpSessionObject - class jp.co.intra_mart.framework.base.session.HttpSessionObject.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
HttpSessionObject(HttpSession) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のコンストラクタ
推奨されていません。 HttpSessionObjectを新規に生成します。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの破棄処理。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド

handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタの破棄処理。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタの破棄処理。
handleError(ErrorEvent) - interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener のメソッド
発生した例外を通知します。
handleEvent() - interface jp.co.intra_mart.common.aid.jdk.util.EventListener のメソッド
イベントが発生した時にコントローラから呼び出されます。
handleEvent() - interface jp.co.intra_mart.foundation.utility.EventListener のメソッド
推奨されていません。 イベントが発生した時にコントローラから呼び出されます。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド

handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のメソッド
このフィルタを初期化します。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のメソッド
このフィルタを初期化します。
handleShutdown() - interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener のメソッド
シャットダウンイベントが発生したときに実行されるメソッドです。
handleShutdown() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
シャットダウンイベントが発生したときに実行されるメソッドです。
handleSocketEvent(ExtendedSocket) - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener のメソッド
ソケットに関するイベント発生時に呼び出されるメソッド。
handleSocketEvent(ExtendedSocket) - interface jp.co.intra_mart.foundation.utility.net.SocketEventListener のメソッド
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。
handleThreadStop() - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener のメソッド
監視していたスレッドが終了したときに実行されるメソッドです。
handleThreadStop() - interface jp.co.intra_mart.foundation.utility.ThreadStopListener のメソッド
推奨されていません。 監視していたスレッドが終了したときに実行されるメソッドです。
hasArguments() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
コマンドライン引数があるかどうか判定します。
hasBaseAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。
hasChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード node を持っているか調べます。
hasChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードが子ノードを持っているかどうかを判断します。
hasChildNodes() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが子ノードを持っているかどうかを判断します。
hasChildren() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューが存在するかどうかを取得します。
hasHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
指定された文字列がヘッダの名称かどうかを判定します。
hasHeaders() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
このオブジェクトがヘッダ情報を持つかどうかを判定します。
hasInternationalAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。
hasOption(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションが指定されているかどうか判定します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasProperty(String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティが存在しているかをチェックします。
hasReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
hasReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
hasTerminableAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。
hasTerminableInternationalAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。
hashCode() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
有効期間のハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ハッシュコード値取得。
hashCode() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ハッシュコードを取得します。

I

I18nAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes.
国際化の属性です。
I18nAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のコンストラクタ
I18nAttributesを新規に生成します。
ID - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数

ID - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数

ID - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

ID - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

ID - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

ID_SECURITY_ACCOUNT - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の static 変数

ID_SECURITY_GROUP - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の static 変数

ID_SECURITY_PASSWORD - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の static 変数

ID_SERVICE_SECURITY_FILTER - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の static 変数
リクエストに登録するServiceServletFilterの属性名
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
INonTransaction - interface jp.co.intra_mart.foundation.security.INonTransaction.
分散トランザクション未対応のアクセッサに実装するインターフェース。
Identifier - class jp.co.intra_mart.foundation.service.client.information.Identifier.
ユニークなＩＤを生成する機能を提供します。
Identifier() - class jp.co.intra_mart.foundation.service.client.information.Identifier のコンストラクタ
唯一のコンストラクタ。
IllegalArgumentException - exception jp.co.intra_mart.foundation.security.exception.IllegalArgumentException.
引数が不正の例外クラス。
IllegalArgumentException(String, String) - class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException のコンストラクタ
コンストラクタ。
IllegalArgumentException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException のコンストラクタ
コンストラクタ。
IllegalExtensionException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException.
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalExtensionException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalLocaleException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException.
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalLocaleException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalPasswordException - exception jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException.
パスワードが認証されなかったことを通知するための例外です。
IllegalPasswordException(String) - class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException のコンストラクタ
指定のメッセージで例外を作成します。
IllegalRelationshipException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException.
リレーションシップに関する例外クラス

リレーションシップの整合性が正しくない場合にスローする。
IllegalRelationshipException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalSessionException - exception jp.co.intra_mart.framework.base.session.IllegalSessionException.
セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
IllegalSessionException() - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
詳細メッセージを指定しないで IllegalSessionException を構築します。
IllegalSessionException(String) - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
指定された詳細メッセージを持つ IllegalSessionException を構築します。
IllegalSessionException(String, Throwable) - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。
IllegalSystemException - exception jp.co.intra_mart.framework.system.exception.IllegalSystemException.
想定外の例外が発生したときの例外です。
IllegalSystemException() - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
詳細メッセージを指定しないで IllegalSystemException を構築します。
IllegalSystemException(String) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
指定された詳細メッセージを持つ IllegalSystemException を構築します。
IllegalSystemException(Throwable) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalSystemException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalTermException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalTermException.
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
IllegalTermException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
ImportException - exception jp.co.intra_mart.foundation.datastore.exception.ImportException.
アプリケーション共通マスタのインポートに関する例外クラス

ImportException() - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(String) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
InitialFile - class jp.co.intra_mart.foundation.service.client.information.InitialFile.
設定ファイル(*.ini)の内容を読み込むためのクラスです。
InitialFile(String) - class jp.co.intra_mart.foundation.service.client.information.InitialFile のコンストラクタ
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。
InputCheck - class jp.co.intra_mart.foundation.commons.validation.InputCheck.
入力チェック関数ライブラリ
InputCheck() - class jp.co.intra_mart.foundation.commons.validation.InputCheck のコンストラクタ

InternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor.
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap.
国際化アクセサのマッピング情報を持ちます。
InternationalKey - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey.
国際化基準項目を定義します。
InternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel.
国際化モデルを定義します。
InternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel.
国際化モデルの情報です。
InternationalModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext.
国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap.
国際化モデルのマッピング情報を持ちます。
InternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable.
国際化テーブルを定義します。
IntramartAction - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction.
ServiceControllerAdapterと似たメソッドを持つActionクラスです。
IntramartAction() - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のコンストラクタ

IntramartConnectFilter - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter.
推奨されていません。 この機能は廃止されました。
IntramartConnectFilter() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のコンストラクタ
推奨されていません。
IntramartConnectServlet - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet.
推奨されていません。 この機能は廃止されました。
IntramartConnectServlet() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のコンストラクタ
推奨されていません。 IntramartConnectServletを新規に生成します。
IntramartDBConnector - class jp.co.intra_mart.framework.base.data.IntramartDBConnector.
推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
IntramartDBConnector() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のコンストラクタ
推奨されていません。 IntramartDBConnectorを新規に生成します。
IntramartDBDAO - class jp.co.intra_mart.framework.base.data.IntramartDBDAO.
推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
IntramartDBDAO() - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のコンストラクタ
推奨されていません。 IntramartDBDAOを新規に生成します。
IntramartDBMapper - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper.
intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。
IntramartDBMapper() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のコンストラクタ

IntramartFileServerConnector - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector.
intra-martのStorageサービスに接続するデータコネクタです。
IntramartFileServerConnector() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のコンストラクタ
IntramartFileServerConnectorを新規に生成します。
IntramartFileServerDAO - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO.
intra-martのStorageサービスを使用する場合のDAOです。
IntramartFileServerDAO() - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のコンストラクタ
IntramartFileServerDAOを新規に生成します。
IntramartLocaleFilter - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter.
セッションにロケールを設定します。
IntramartLocaleFilter() - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のコンストラクタ

IntramartLogAgent - class jp.co.intra_mart.framework.system.log.IntramartLogAgent.
intra-mart で管理されているログに出力するログエージェントです。
IntramartLogAgent() - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のコンストラクタ
IntramartLogAgentを新規に生成します。
IntramartMessagePropertyHandler - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler.
イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。
IntramartMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のコンストラクタ
IntramartMessagePropertyHandlerを新規に生成します。
IntramartPageBaseTransition - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition.
ページベースの画面に遷移する場合に使用するトランジションです。
IntramartPageBaseTransition() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のコンストラクタ
IntramartPageBaseTransitionを新規に生成します。
IntramartSessionFactory - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
IntramartSessionFactory() - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のコンストラクタ
推奨されていません。 IntramartSessionFactoryを新規に生成します。
IntramartSessionObject - class jp.co.intra_mart.framework.base.session.IntramartSessionObject.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
IntramartSessionObject(SessionMemory) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のコンストラクタ
推奨されていません。 IntramartSessionObjectを生成します。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー情報・インポート。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報・インポート。
in - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の変数
フィルタ処理される入力ストリームです。
in - class jp.co.intra_mart.foundation.utility.io.HexInputStream の変数
推奨されていません。 フィルタ処理される入力ストリームです。
increaseLoginFailureCount() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数をカウントアップします。
increment() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの値を１だけ増加させます。
increment() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの値を１だけ増加させます。
init(FilterConfig) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタを初期化します。
init(FilterConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
このオブジェクトを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
CategoryManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社リスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
CompanyManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
PrivateGroupManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
アカウントリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
PublicGroupManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
UserManagerを初期化します。
init(BaseModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
基本モデルを初期化します。
init(ExtendedBaseAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel のメソッド
拡張基本モデルを初期化します。
init(ExtendedBaseAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
拡張基本モデルを初期化します。
init(ExtendedBaseAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
初期化を行います。
init(ExtendedInternationalAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
拡張国際化モデルを初期化します。
init(ExtendedInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
初期化を行います。
init(ExtendedTerminableInternationalAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
拡張期間国際化モデルを初期化します。
init(ExtendedTerminableInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
初期化を行います。
init(ExtendedTerminableAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
拡張期間化モデルを初期化します。
init(ExtendedTerminableAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
初期化を行います。
init(ExtendedInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel のメソッド
拡張国際化モデルを初期化します。
init(ExtendedTerminableInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルを初期化します。
init(ExtendedTerminableAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel のメソッド
拡張期間化モデルを初期化します。
init(BaseModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
基本モデルを初期化します。
init(InternationalModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
国際化モデルを初期化します。
init(String, InternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
初期化処理を行います。
init(TerminableInternationalModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
期間国際化モデルを初期化します。
init(String, TerminableInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
初期化処理を行います。
init(TerminableModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間化モデルを初期化します。
init(String, String, TerminableAccessorMap, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
初期化処理を行います。
init(InternationalModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
国際化モデルを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーを初期化します。
init(String, String) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーを初期化します。
init(TerminableInternationalModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
期間国際化モデルを初期化します。
init(TerminableModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間化モデルを初期化します。
init() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
StandardMailオブジェクトを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator のメソッド
アカウントデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者アクセッサを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator のメソッド
システム管理者デコレータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
アクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchExporter のメソッド
バッチバックアップエクスポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchImporter のメソッド
バッチバックアップインポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator のメソッド
バッチデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
バッチバックアップの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter のメソッド
カレンダーバックアップエクスポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter のメソッド
カレンダーバックアップインポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator のメソッド
カレンダーデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
カレンダーバックアップの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.SuperCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(FilterConfig) - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
初期化します。
init(FilterConfig) - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者アクセッサを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator のメソッド
管理者デコレータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator のメソッド
ログイングループデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator のメソッド
メニューデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社リスナーの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator のメソッド
メニューデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
アカウントリスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
初期化。
init(Map) - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロールアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator のメソッド
ロールデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
初期化。
init() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
メニューサーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
サーブレットの初期化を行います。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
エンコーディング用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
ファイルアップロード用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 フィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 このサーブレットを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
ロケール用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
ロケール用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
サーブレットを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
セッション用のフィルタを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
HelperBeanを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
フィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter のメソッド
推奨されていません。 このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
サーブレットを初期化します。
init(ControllerConverterConfig) - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter のメソッド
ControllerConverterを初期化します。
init(ControllerConverterConfig) - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter のメソッド
SimpleControllerConverterを初期化します。
init(ForwardSelectorConfig) - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector のメソッド
ForwardSelectorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.presentation.validator.FormatValidator のメソッド
FormatValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.presentation.validator.LengthValidator のメソッド
LengthValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator のメソッド
NumericRangeValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.presentation.validator.NumericValidator のメソッド
NumericValidatorを初期化します。
init(ValidatorConfig) - interface jp.co.intra_mart.framework.presentation.validator.Validator のメソッド
Validatorを初期化します。
init(ViewConverterConfig) - interface jp.co.intra_mart.framework.presentation.view.ViewConverter のメソッド
ViewConverterを初期化します。
init(LogAgentParam[]) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(LogAgentParam[]) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
初期化します。
init(LogAgentParam[]) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - interface jp.co.intra_mart.framework.system.property.PropertyHandler のメソッド
プロパティハンドラを初期化します。
initParam(String, String) - interface jp.co.intra_mart.framework.base.event.EventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のメソッド
初期パラメータを設定します。
initializeTime() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチ初期化時間の取得。
insert(String, Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを追加挿入するメソッド

データベースにインサート処理をする。
insert(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数挿入します。
insert(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数挿入します。
insert(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数挿入します。
insert(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数挿入します。
insert(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数挿入します。
insert(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数挿入します。
insert(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数挿入します。
insert(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数挿入します。
insert(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数挿入します。
insert(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数挿入します。
insert(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数挿入します。
insert(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数挿入します。
insert(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数挿入します。
insert(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数挿入します。
insert(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数挿入します。
insert(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数挿入します。
insert(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数挿入します。
insert(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数挿入します。
insert(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数挿入します。
insert(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ挿入します。
insert(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを複数挿入します。
insertAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を新規追加する。
insertAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を新規追加する。
insertBatch(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を新規に追加します。
insertCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを新規に作成します。
insertData(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
insertData(Map, String[]) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
insertFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を新規追加する。
insertLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを新規追加します。
insertMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを新規追加します。
insertMenuDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー組織を新規に作成します。
insertMenuInclusion(MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuInclusion(String, MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuItem(MenuItem, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuItem(String, MenuItem, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー役職を新規に作成します。
insertMenuPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューパブリックグループを新規に作成します。
insertMenuRole(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューロールを新規に作成します。
insertPostData(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
insertSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールを作成する。
insertSuperUser(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を新規追加します。
insertSuperUser(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を新規追加します。
instance() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost の static メソッド
このクラスから生成される唯一のインスタンスを返します。
instance - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するJavaBeans
instance() - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
ホームディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の static メソッド
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の static メソッド
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の static メソッド
データ保存ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.utility.net.Localhost の static メソッド
推奨されていません。 このクラスから生成される唯一のインスタンスを返します。
intValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 数値として取得します。
intValue(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 数値として取得します。
intValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を int 型として返します。
intValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を int 型として返します。
invoke(String, String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
invoke(String, Number) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
invoke(String, Object[]) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
isAlive() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラが動作しているかどうかをチェックします。
isAlive() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このイベントコントローラが有効かどうかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このソケットが閉じられているかどうかをチェックします。
isClosed() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection がクローズされているかどうかを判定します。
isClosed() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
このアクセサがクローズされた状態かどうかを確認します。
isClosed() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーがクローズされているかどうか確認します。
isClosed() - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーがクローズされているかどうか確認します。
isClosed() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このソケットが閉じられているかどうかをチェックします。
isColumn(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースの表内に指定カラムが存在するか調べる

isConnect() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
isConnected() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバとの接続状態をチェックします。
isDataSource() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このコネクションがDataSourceかを返します。
isDateString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。
isDateTimeString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。
isDateTimeString(String, SimpleDateFormat) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日時文字列が指定フォーマットにそっているかどうかをチェックする。
isDirectory() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルがディレクトリであるかどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフ値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフ値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDynamic() - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
再設定可能かどうかをチェックします。
isDynamic() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isEMailAddress(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
入力文字列がメールアドレスの形式をとっているかのチェック。
isEmpty(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
渡された文字列が、空文字列かまたはNULLかチェック。
isEmpty(Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値のNULLチェック。
isEmpty() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの下に子ノードがないか調べます。
isEmpty() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが一つも子を持っていないときにtrueを返します。
isEncodeRequired() - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEncodeRequired() - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEncodeRequired() - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isError() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
処理要求が成功したかどうかを判定します。
isError() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
処理要求が成功したかどうかを判定します。
isExistString(String[], String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
配列内に指定した文字列が含まれているかどうかをチェックする。
isExpired() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用期限が切れているかどうかを判定します。
isFalse(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を真偽判定します。
isFile() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが普通のファイルかどうかを判定します。
isFree() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
ライセンスフリーであるかどうかを判定します。
isFunction() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が関数かどうか判定します。
isGoOut() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
外出状態を取得します。
isGroup(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 代替えメソッドはありません。
isHoliday(String, CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
休日かどうか判定します。
isHoliday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
休日設定にマッチしているかどうかを取得します。
isInput(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの空値チェック。
isInput(Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの空値チェック。
isInstance(Class) - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。
isInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が国際化の対象であるかどうかを取得します。
isInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが国際化の対象であるかどうかを取得します。
isKatakanaString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
文字列が半角カナ文字列かチェックする。
isKessaiDateString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
決済年月日(YYYYMMDD)として有効かをチェックする。
isLenEqual(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力バイト数チェック。
isLenEqual(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力バイト数チェック（引数がクラス版）。
isLenEqual(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力桁数チェック。
isLenEqual(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力桁数チェック（引数がクラス版）。
isLenLessThan(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より小さいか(等号を含まない)。
isLenLessThan(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より小さいか(等号を含まない)（引数がクラス版）。
isLenLessThan(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より小さいか(等号を含まない)。
isLenLessThan(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より小さいか(等号を含まない)（引数がクラス版）。
isLenMoreThan(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より大きいか(等号を含まない)。
isLenMoreThan(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。
isLenMoreThan(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より大きいか(等号を含まない)。
isLenMoreThan(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。
isLimited() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
期限付きライセンスであるかどうかを判定します。
isLock() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック状態を取得します。
isLocked() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックの状態を確認します。
isNationalHoliday(CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
祝日かどうか判定します。
isNationalHoliday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
祝祭日設定にマッチしているかどうかを取得します。。
isNengetsuString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。
isNotNull(Object) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
not nullチェック not nullのとき true nullのとき false
isNull() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が null かどうか判定します。
isNullAcceptable() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性にnullが設定可能であるかどうかを取得します。
isNumberString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
文字列が数値かどうかをチェックする。
isNumeralRange(String, Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
指定した数値カラムが指定した数値の範囲なのかチェック
範囲最大値、または最小値と同じ値は範囲内に含まれる。
isObject() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値がオブジェクトかどうか判定します。
isOpenSource() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
オープンソースであるかどうかを判定します。
isReadOnly() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection が読み込み専用モードかどうかを判定します。
isRegisteredAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
指定されたユーザがライセンスに登録されているかどうかをチェックします。
isRegisteredApplicationLicenseToAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アカウントにアプリケーションライセンスが登録されてるか検証します。
isRuntime() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
ランタイムライセンスであるかどうかを判定します。
isSelected(Option) - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
指定された選択肢が選択済かどうか判定します。
isSelected() - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
この選択肢が選択済であるかどうかを判定します。
isSelected(Option) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
指定された選択肢が選択済かどうか判定します。
isSelected(Option) - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem のメソッド
指定された選択肢が選択済かどうか判定します。
isShimebiString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
締め日(YYYYMMDD)として有効かをチェックする。
isShutdown() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウン中（またはシャットダウン処理終了）かどうかを判定。
isSuccess() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行が正常に行われたか判定します｡ＢＡＰＩ実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡
isTerminable() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が期間化の対象であるかどうかを取得します。
isTerminable() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが期間化の対象であるかどうかを取得します。
isTerminableInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが期間国際化の対象であるかどうかを取得します。
isTransaction() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースアクセスのトランザクション状態を取得します。
isTransaction() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースアクセスのトランザクション状態を取得します。
isTrial() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用版であるかどうかを判定します。
isTrue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を真偽判定します。
isUndefined() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が undefined かどうか判定します。
isUpdate(String, String, Date) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータが指定された日付よりも新しいかチェックします。
isUpdate(String, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータが指定された日付よりも新しいかチェックします。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.FormTEI のメソッド
Formタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.FrameTEI のメソッド
Frameタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のメソッド
HelperBeanタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.LinkTEI のメソッド
Linkタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.MessageTEI のメソッド
Messageタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI のメソッド
Linkタグに指定された内容の正当性を検証します。
isValidDate(String, String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isValidate() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
有効・無効フラグを取得します。
isValueEqual(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値とカラム２の値が同一かのチェック。
isValueEqual(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値とカラム２の値が同一かのチェック。
isValueLessThan(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
isValueLessThan(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
isValueMoreThan(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
isValueMoreThan(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
isWeekDate(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isWeekDate(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isWeekday(String, CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
平日かどうか判定します。
isWeekday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
非休日設定にマッチしているかどうかを取得します。

J

JDBCConnector - class jp.co.intra_mart.framework.base.data.JDBCConnector.
推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
JDBCConnector() - class jp.co.intra_mart.framework.base.data.JDBCConnector のコンストラクタ
推奨されていません。 新規のJDBCConnectorを生成します。
JavaMailPropertyException - exception jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException.
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyException() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String, Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyHandler - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler.
JavaMailSenderの設定を保持します。
JavaMailSender - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender.
JavaMailをラップしたメール送信オブジェクトです。
JavaMailSender(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のコンストラクタ
JavaMailSenderを新規に作成します。
joinDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成に組織を登録します。
joinPublicGroup(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成にパブリックグループを登録します。
jp.co.intra_mart.common.aid.jdk.java.io - package jp.co.intra_mart.common.aid.jdk.java.io
このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io.file - package jp.co.intra_mart.common.aid.jdk.java.io.file
このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.lang - package jp.co.intra_mart.common.aid.jdk.java.lang
このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.net - package jp.co.intra_mart.common.aid.jdk.java.net
ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.common.aid.jdk.java.util - package jp.co.intra_mart.common.aid.jdk.java.util
このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml - package jp.co.intra_mart.common.aid.jdk.javax.xml
このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom - package jp.co.intra_mart.common.aid.jdk.org.w3c.dom
このパッケージには、ＤＯＭを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util - package jp.co.intra_mart.common.aid.jdk.util
このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.charset - package jp.co.intra_mart.common.aid.jdk.util.charset
このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report - package jp.co.intra_mart.common.aid.jdk.util.report
このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet - package jp.co.intra_mart.common.aid.jsdk.javax.servlet
このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.utility - package jp.co.intra_mart.common.aid.jsdk.utility
このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.platform.util - package jp.co.intra_mart.common.platform.util
このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。
jp.co.intra_mart.common.platform.vm - package jp.co.intra_mart.common.platform.vm
このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。
jp.co.intra_mart.foundation.acssecurity - package jp.co.intra_mart.foundation.acssecurity
アクセスセキュリティモジュールを利用するためのクラスを提供します。
jp.co.intra_mart.foundation.appcomn - package jp.co.intra_mart.foundation.appcomn
アプリケーション共通モジュール。
jp.co.intra_mart.foundation.commons.validation - package jp.co.intra_mart.foundation.commons.validation
このパッケージは、入力チェック関数ライブラリを提供します。
jp.co.intra_mart.foundation.database - package jp.co.intra_mart.foundation.database
データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.database.exception - package jp.co.intra_mart.foundation.database.exception
データベースＳＱＬ例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category - package jp.co.intra_mart.foundation.datastore.application.domain.category
分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class - package jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
分類区分情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail - package jp.co.intra_mart.foundation.datastore.application.domain.category.detail
分類詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company - package jp.co.intra_mart.foundation.datastore.application.domain.company
会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach - package jp.co.intra_mart.foundation.datastore.application.domain.company.attach
組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category - package jp.co.intra_mart.foundation.datastore.application.domain.company.category
会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company - package jp.co.intra_mart.foundation.datastore.application.domain.company.company
会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department - package jp.co.intra_mart.foundation.datastore.application.domain.company.department
組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main - package jp.co.intra_mart.foundation.datastore.application.domain.company.main
主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post - package jp.co.intra_mart.foundation.datastore.application.domain.company.post
役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.version - package jp.co.intra_mart.foundation.datastore.application.domain.company.version
バーション情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group - package jp.co.intra_mart.foundation.datastore.application.domain.private_group
プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach - package jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
プライベートグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group - package jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group - package jp.co.intra_mart.foundation.datastore.application.domain.public_group
パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
パブリックグループバージョン情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user - package jp.co.intra_mart.foundation.datastore.application.domain.user
ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class - package jp.co.intra_mart.foundation.datastore.application.model.category.category_class
分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail - package jp.co.intra_mart.foundation.datastore.application.model.category.detail
分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach - package jp.co.intra_mart.foundation.datastore.application.model.company.attach
組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category - package jp.co.intra_mart.foundation.datastore.application.model.company.category
会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company - package jp.co.intra_mart.foundation.datastore.application.model.company.company
会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department - package jp.co.intra_mart.foundation.datastore.application.model.company.department
組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion - package jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main - package jp.co.intra_mart.foundation.datastore.application.model.company.main
組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post - package jp.co.intra_mart.foundation.datastore.application.model.company.post
会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version - package jp.co.intra_mart.foundation.datastore.application.model.company.version
会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach - package jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group - package jp.co.intra_mart.foundation.datastore.application.model.private_group.group
プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach - package jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category - package jp.co.intra_mart.foundation.datastore.application.model.public_group.category
パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group - package jp.co.intra_mart.foundation.datastore.application.model.public_group.group
パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion - package jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set - package jp.co.intra_mart.foundation.datastore.application.model.public_group.set
パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version - package jp.co.intra_mart.foundation.datastore.application.model.public_group.version
パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user - package jp.co.intra_mart.foundation.datastore.application.model.user
ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor - package jp.co.intra_mart.foundation.datastore.common.accessor
情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config - package jp.co.intra_mart.foundation.datastore.common.config
アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model - package jp.co.intra_mart.foundation.datastore.common.model
情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure - package jp.co.intra_mart.foundation.datastore.common.structure
期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception - package jp.co.intra_mart.foundation.datastore.exception
アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.drawer - package jp.co.intra_mart.foundation.drawer
画像ファイル出力用クラスを提供します。
jp.co.intra_mart.foundation.exception - package jp.co.intra_mart.foundation.exception
システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.graph - package jp.co.intra_mart.foundation.graph
グラフ描画に関するクラスを提供します。
jp.co.intra_mart.foundation.http - package jp.co.intra_mart.foundation.http
ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.im_curl - package jp.co.intra_mart.foundation.im_curl
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
jp.co.intra_mart.foundation.mail - package jp.co.intra_mart.foundation.mail
メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail - package jp.co.intra_mart.foundation.mail.javamail
メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.property - package jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.page - package jp.co.intra_mart.foundation.page
ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth - package jp.co.intra_mart.foundation.sap.common.auth
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth.exception - package jp.co.intra_mart.foundation.sap.common.auth.exception
ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose - package jp.co.intra_mart.foundation.sap.common.general_purpose
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception - package jp.co.intra_mart.foundation.sap.common.general_purpose.exception
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data - package jp.co.intra_mart.foundation.sap.common.util.data
ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.date - package jp.co.intra_mart.foundation.sap.common.util.date
ＳＡＰ連携にて使用する日付操作クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file - package jp.co.intra_mart.foundation.sap.common.util.file
ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting - package jp.co.intra_mart.foundation.sap.module.accounting
ＳＡＰ連携会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception - package jp.co.intra_mart.foundation.sap.module.accounting.exception
ＳＡＰ連携会計系例外クラスを提供します。
jp.co.intra_mart.foundation.scenario - package jp.co.intra_mart.foundation.scenario
ページベース開発モデルのプログラムと連携するＡＰＩ。
jp.co.intra_mart.foundation.security - package jp.co.intra_mart.foundation.security
アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account - package jp.co.intra_mart.foundation.security.account
アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin - package jp.co.intra_mart.foundation.security.admin
システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch - package jp.co.intra_mart.foundation.security.batch
バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar - package jp.co.intra_mart.foundation.security.calendar
カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification - package jp.co.intra_mart.foundation.security.certification
認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.cryption - package jp.co.intra_mart.foundation.security.cryption
暗号化に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception - package jp.co.intra_mart.foundation.security.exception
アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.filter - package jp.co.intra_mart.foundation.security.filter
アクセスセキュリティのフィルタに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group - package jp.co.intra_mart.foundation.security.group
グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license - package jp.co.intra_mart.foundation.security.license
ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu - package jp.co.intra_mart.foundation.security.menu
メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message - package jp.co.intra_mart.foundation.security.message
メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.permission - package jp.co.intra_mart.foundation.security.permission
権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role - package jp.co.intra_mart.foundation.security.role
ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.servlet - package jp.co.intra_mart.foundation.security.servlet
サーブレットに関連するクラスを提供します。
jp.co.intra_mart.foundation.service.client - package jp.co.intra_mart.foundation.service.client
このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.application - package jp.co.intra_mart.foundation.service.client.application
このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content - package jp.co.intra_mart.foundation.service.client.application.content
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.batch - package jp.co.intra_mart.foundation.service.client.batch
Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file - package jp.co.intra_mart.foundation.service.client.file
Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information - package jp.co.intra_mart.foundation.service.client.information
このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager - package jp.co.intra_mart.foundation.service.client.manager
このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider - package jp.co.intra_mart.foundation.service.provider
このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.application - package jp.co.intra_mart.foundation.service.provider.application
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.batch - package jp.co.intra_mart.foundation.service.provider.batch
このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider.file - package jp.co.intra_mart.foundation.service.provider.file
このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information - package jp.co.intra_mart.foundation.service.provider.information
このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.smtp - package jp.co.intra_mart.foundation.smtp
メール連携モジュール。
jp.co.intra_mart.foundation.utility - package jp.co.intra_mart.foundation.utility
このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset - package jp.co.intra_mart.foundation.utility.charset
このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.file - package jp.co.intra_mart.foundation.utility.file
このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io - package jp.co.intra_mart.foundation.utility.io
このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.net - package jp.co.intra_mart.foundation.utility.net
ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.foundation.utility.report - package jp.co.intra_mart.foundation.utility.report
このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.framework.base.data - package jp.co.intra_mart.framework.base.data
データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event - package jp.co.intra_mart.framework.base.event
イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message - package jp.co.intra_mart.framework.base.message
メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service - package jp.co.intra_mart.framework.base.service
サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session - package jp.co.intra_mart.framework.base.session
セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util - package jp.co.intra_mart.framework.base.util

jp.co.intra_mart.framework.base.web.bean - package jp.co.intra_mart.framework.base.web.bean
JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag - package jp.co.intra_mart.framework.base.web.tag
J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute - package jp.co.intra_mart.framework.base.web.tag.attribute
タグ属性のパッケージです。
jp.co.intra_mart.framework.base.web.util - package jp.co.intra_mart.framework.base.web.util
Web上で使用するユーティリティのパッケージです。
jp.co.intra_mart.framework.extension.common.util - package jp.co.intra_mart.framework.extension.common.util
im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action - package jp.co.intra_mart.framework.extension.struts.action
im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation - package jp.co.intra_mart.framework.presentation
Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller - package jp.co.intra_mart.framework.presentation.controller
入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward - package jp.co.intra_mart.framework.presentation.forward
遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.service - package jp.co.intra_mart.framework.presentation.service
サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator - package jp.co.intra_mart.framework.presentation.validator
検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view - package jp.co.intra_mart.framework.presentation.view
出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception - package jp.co.intra_mart.framework.system.exception
J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log - package jp.co.intra_mart.framework.system.log
J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message - package jp.co.intra_mart.framework.system.message
メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property - package jp.co.intra_mart.framework.system.property
プロパティ取得に関連するパッケージです。
jp.co.intra_mart.jssp.net - package jp.co.intra_mart.jssp.net

K

KEY - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager の static 変数
プロパティマネージャを指定するキー
KEY - class jp.co.intra_mart.framework.system.property.PropertyManager の static 変数
プロパティマネージャを指定するキー
KEY - class jp.co.intra_mart.framework.system.property.XmlPropertyManager の static 変数
プロパティマネージャを指定するキー
KEY_AUTH_COOKIE_NAME - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

KEY_DRIVER - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベースドライバのキー
KEY_JNDI_NAME - class jp.co.intra_mart.framework.base.data.DataSourceConnector の static 変数
DataSourceのJNDI名のキー
KEY_LOGIN_KEY - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

KEY_PASSWORD - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベース接続ユーザパスワードのキー
KEY_URL - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベースURLのキー
KEY_USERNAME - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベース接続ユーザ名のキー
KIND_ROLE - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException の static 変数
種別 ロール。
KIND_ROLE - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup の static 変数
種別 ロール。
KIND_ROLE_SUB - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException の static 変数
種別 サブロール(ロール)。
keyList() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
キー一覧を取得します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
キー一覧を取得します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
キー一覧を取得します。
keyList() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
キー一覧を取得します。
keys() - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティの名称一覧を取得します。

L

LANG_JAVA - class jp.co.intra_mart.foundation.security.batch.Batch の static 変数
プログラム言語(JAVA)。
LANG_JAVA_SCRIPT - class jp.co.intra_mart.foundation.security.batch.Batch の static 変数
プログラム言語(JavaScript)。
LDAPUserCertification - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification.
ユーザログインLDAP認証クラス。
LDAPUserCertification() - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のコンストラクタ

LEVEL_DEBUG - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
DEBUG時に出力するレベルです。
LEVEL_ERROR - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
例外を出力するレベルです。
LEVEL_INFO - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
情報を出力するレベルです。
LEVEL_WARNNING - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
警告を出力するレベルです。
LICENSE_PATH - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 Append-Product定義ファイルのアクセス権記述子
LICENSE_PATH - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
Append-Product定義ファイルのアクセス権記述子
LISTENER_PARAM - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の static 変数
イベントリスナーのクラス名のパラメータ名
LISTENER_PARAM - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の static 変数
イベントリスナーのクラス名のパラメータ名
LOCALE - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
ロケール
LOG_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.system.log.LogManager の static 変数
ログプロパティハンドラのキー
LT_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
グループマネージャー（ログインタイプ）。
LT_GROUP - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
グループマネージャ
LT_SUPER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
スーパーユーザ（ログインタイプ）。
LT_SUPER - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
スーパーユーザ
LT_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ユーザ（ログインタイプ）。
LT_USER - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
ユーザ
LengthRequiredException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException.
Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
LengthRequiredException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
指定のメッセージを持つ例外を作成します。
LengthRequiredException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
LengthRequiredException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
例外を作成します。
LengthValidator - class jp.co.intra_mart.framework.presentation.validator.LengthValidator.
文字列の長さをチェックします。
LengthValidator() - class jp.co.intra_mart.framework.presentation.validator.LengthValidator のコンストラクタ

LicenseManager - class jp.co.intra_mart.foundation.security.license.LicenseManager.
ライセンス・マネージャクラス。
LicenseManager(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のコンストラクタ
コンストラクタ。
Lifetime - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime.
期間削除時の整合性制約です。
LifetimeType - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType.
期間削除時の整合性制約のタイプです。
LimitedSessionHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler.
セッションを一時利用のみに限定するためのフィルタです。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のコンストラクタ
セッションを一時利用に限定するためのフィルタハンドラを作成します。
LineGraphDrawer - class jp.co.intra_mart.foundation.graph.LineGraphDrawer.
折れ線グラフを描画します。
LineGraphDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で折れ線グラフを作成します。
LineGraphDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。
LineGraphObject - class jp.co.intra_mart.foundation.graph.LineGraphObject.
LineGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphObject() - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
LineGraphObject(Color) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の色を指定して、データオブジェクトを作成します。
LineGraphObject(Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の描画属性を指定して、データオブジェクトを作成します。
LineGraphObject(Color, Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の色と描画属性を指定して、データオブジェクトを作成します。
LineProperty - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty.
LinePropertyクラス
機能は以下の通り
Propertyファイル１行ごとの情報を保持します｡
上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。
LineProperty(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のコンストラクタ
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
LineReportFilter - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter.
メッセージを行出力するためのフィルタークラスです。
LineReportFilter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のコンストラクタ
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
LineReportFilter - class jp.co.intra_mart.foundation.utility.report.LineReportFilter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
LineReportFilter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
LinkTEI - class jp.co.intra_mart.framework.base.web.tag.LinkTEI.
Linkタグの拡張情報です。
LinkTEI() - class jp.co.intra_mart.framework.base.web.tag.LinkTEI のコンストラクタ
LinkTEIを新規に生成します。
LinkTag - class jp.co.intra_mart.framework.base.web.tag.LinkTag.
LINKタグです。
LinkTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のコンストラクタ
LinkTagを新規に生成します。
LinkTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo.
LinkTagのBeanInfoです。
LinkTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo のコンストラクタ
LinkTagBeanInfoを新規に生成します。
LocaleFilter - class jp.co.intra_mart.framework.base.service.LocaleFilter.
リクエストのロケールを設定します。
LocaleFilter() - class jp.co.intra_mart.framework.base.service.LocaleFilter のコンストラクタ

LocaleInfo - interface jp.co.intra_mart.foundation.security.LocaleInfo.
ロケｰル情報・モデルインタフェース。
LocaleProvider - interface jp.co.intra_mart.foundation.security.LocaleProvider.
ロケール取得プロバイダーインタフェース。
Localhost - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost.
このクラスは、サーバプロセスの基礎情報を管理します。
Localhost - class jp.co.intra_mart.foundation.utility.net.Localhost.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
Lock - class jp.co.intra_mart.foundation.service.client.information.Lock.
アプリケーションロックをするための機能を提供します。
Lock(String) - class jp.co.intra_mart.foundation.service.client.information.Lock のコンストラクタ
ロックをするためのインスタンスを作ります。
LockMonitor - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor.
このクラスはモニター機能を提供します。
LockMonitor(int) - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のコンストラクタ
モニターを構築します。
LockMonitor - class jp.co.intra_mart.foundation.utility.LockMonitor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
LockMonitor(int) - class jp.co.intra_mart.foundation.utility.LockMonitor のコンストラクタ
推奨されていません。 モニターを構築します。
LogAgent - interface jp.co.intra_mart.framework.system.log.LogAgent.
ログに出力するエージェントです。
LogAgentParam - class jp.co.intra_mart.framework.system.log.LogAgentParam.
ログエージェントの初期パラメータです。
LogAgentParam() - class jp.co.intra_mart.framework.system.log.LogAgentParam のコンストラクタ
LogAgentParamを新規に生成します。
LogConstant - interface jp.co.intra_mart.framework.system.log.LogConstant.
ログフレームワークで使用される定数値です。
LogManager - class jp.co.intra_mart.framework.system.log.LogManager.
ログマネージャです。
LogPropertyException - exception jp.co.intra_mart.framework.system.log.LogPropertyException.
ログプロパティ取得時の例外です。
LogPropertyException() - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
詳細メッセージを指定しないで LogPropertyException を構築します。
LogPropertyException(String) - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
指定された詳細メッセージを持つ LogPropertyException を構築します。
LogPropertyException(String, Throwable) - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。
LogPropertyHandler - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler.
ログフレームワークで使用するプロパティハンドラです。
LoginGroup - class jp.co.intra_mart.foundation.security.group.LoginGroup.
ログイングループ・モデル。
LoginGroup() - class jp.co.intra_mart.foundation.security.group.LoginGroup のコンストラクタ
コンストラクタ。
LoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のコンストラクタ
コンストラクタ。
LoginGroupAccessor - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor.
ログイングループアクセッサインタフェース。
LoginGroupDBConnector - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector.
イントラマートで設定されているDBコネクションです。
LoginGroupDBConnector() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のコンストラクタ
LoginGroupDBConnectorを新規に生成します。
LoginGroupDBDAO - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO.
イントラマートで設定されたDBへアクセスするDAOです。
LoginGroupDBDAO() - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のコンストラクタ
IntramartDBDAOを新規に生成します。
LoginGroupManager - class jp.co.intra_mart.foundation.security.group.LoginGroupManager.
ログイングループマネージャクラス。
LoginGroupPostWriterListener - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener.
ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
LoginGroupQueryWriterListener - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener.
ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
LoginGroupReaderDecorator - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator.
ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
LoginInfo - interface jp.co.intra_mart.foundation.security.certification.LoginInfo.
intra-martログイン情報操作インタフェース。
LoginRequestInfo - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo.
intra-martログイン情報操作インタフェース。
Logingp - class jp.co.intra_mart.foundation.acssecurity.Logingp.
推奨されていません。
Logingp(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のコンストラクタ
推奨されていません。 LoginGroupManagerに置き換えられました。
LuxuryResponseWriterFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter.

LuxuryResponseWriterFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter のコンストラクタ
デフォルトコンストラクタ
lastError() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド中で最後に発生した例外を返します。
lastError() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド中で最後に発生した例外を返します。
lastModified() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが最後に変更された時刻を返します。
leave(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
指定のセッションに関する、このフィルタの処理を停止します。
leave(HttpSession) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
指定のセッションに関する、このフィルタの処理を停止します。
leaveDepartment(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成から組織情報を離脱させます。
leavePublicGroup(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成からパブリックグループ情報を離脱させます。
length() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このライターの出力文字数を取得します。
length() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルの長さを返します。
length() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このライターの出力文字数を取得します。
lists() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中の一覧を取得します。
load() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルの内容を取得します。
lockSession(String) - class jp.co.intra_mart.framework.presentation.PresentationManager のメソッド
セッションをロックします。
log(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
Servlet ログファイルに指定されたメッセージを出力します。
log(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
log(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
Servlet ログファイルに指定されたメッセージを出力します。
log(String, Throwable) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
login(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
login(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
logout() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログアウト処理を行います。
logout(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログアウト処理を行います。
longValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 長整数として取得します。
longValue(String, long) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 長整数として取得します。
longValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を long 型として返します。
longValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を long 型として返します。

M

MANAGER_CLASS_KEY - class jp.co.intra_mart.framework.presentation.PresentationManager の static 変数
PresentationManagerの実装クラス名が記述されているキー
MAX_VALUE - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
MAX_VALUE - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
MENU_TYPE_FOLDER - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニュータイプ（フォルダ）。
MENU_TYPE_ITEM - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニュータイプ（アイテム）。
MESSAGE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.message.MessageManager の static 変数
メッセージプロパティハンドラのキー
MESSAGE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.system.message.MessageManager の static 変数
メッセージプロパティハンドラのキー
MIN_VALUE - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
MIN_VALUE - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
MOBILE_EMAIL_ADDRESS - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
携帯用メール
MOBILE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
携帯電話番号
MOVE - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MOVE_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MOVE_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

Mail - class jp.co.intra_mart.foundation.smtp.Mail.
推奨されていません。 MailSenderに置き換えられました。
Mail(String, int) - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
Mail(String) - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
Mail() - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
MailSender - interface jp.co.intra_mart.foundation.mail.MailSender.
メールを送信するためのインターフェースです。
MailSenderException - exception jp.co.intra_mart.foundation.mail.MailSenderException.
メール送信時またはその他の不正な処理に関する情報を提供する例外です。
MailSenderException() - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
MailSenderExceptionを構築します。
MailSenderException(String) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された詳細メッセージを使用してMailSenderExceptionを構築します。
MailSenderException(String, Throwable) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。
MailSenderException(Throwable) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された原因を使用してMailSenderExceptionを構築します。
MainPageImportLoginGroupPostWriterListener - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener.
ログイングループ作成時にメインページパターンを設定するリスナークラス。
MainPageImportLoginGroupPostWriterListener() - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のコンストラクタ
コンストラクタ。
MainPagePatternInfo - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo.
メインページパターン情報クラス。
MainPagePatternInfo(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のコンストラクタ
コンストラクタ。
ManagerException - exception jp.co.intra_mart.foundation.datastore.exception.ManagerException.
マネージャに関する例外クラス

ManagerException() - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(String) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
Mapper - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper.
エンティティの情報のマッパーです。
MapperDAOException - exception jp.co.intra_mart.foundation.datastore.exception.MapperDAOException.
マッパーのデータベース接続に関する例外クラス

マッパーがデータベース接続で問題が発生した場合にスローする。
MapperDAOException() - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperException - exception jp.co.intra_mart.foundation.datastore.exception.MapperException.
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。
MapperException() - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperFactory - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory.
マッパーを生成します。
MapperFactory() - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory のコンストラクタ

MenuAccessor - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor.
メニューアクセッサインタフェース。
MenuExporter - interface jp.co.intra_mart.foundation.security.menu.MenuExporter.
メニューエクスポートインタフェースです。
MenuImporter - interface jp.co.intra_mart.foundation.security.menu.MenuImporter.
メニューインポートインタフェースです。
MenuInclusion - class jp.co.intra_mart.foundation.security.menu.MenuInclusion.
メニュー内包情報クラス。
MenuInclusion(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のコンストラクタ
コンストラクタ。
MenuItem - class jp.co.intra_mart.foundation.security.menu.MenuItem.
メニュー・モデルクラス。
MenuItem() - class jp.co.intra_mart.foundation.security.menu.MenuItem のコンストラクタ
コンストラクタ。
MenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のコンストラクタ
コンストラクタ。
MenuManager - class jp.co.intra_mart.foundation.security.menu.MenuManager.
メニューマネージャクラス。
MenuManager(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のコンストラクタ
コンストラクタ。
MenuPermissionSelector - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector.
ユーザIDから有効なメニューのID一覧を取得するセレクタ。
MenuPermissionSelector() - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のコンストラクタ
コンストラクタ。
MenuPostWriterListener - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener.
メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MenuQueryWriterListener - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener.
メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
MenuReaderDecorator - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator.
メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
MenuServlet - class jp.co.intra_mart.foundation.security.servlet.MenuServlet.
メニュー連携サーブレットクラス。
MenuServlet() - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のコンストラクタ
コンストラクタ。
MenuTree - class jp.co.intra_mart.foundation.security.menu.MenuTree.
メニューツリークラス。
MenuTree(MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuTree のコンストラクタ
コンストラクタ。
MessageManager - class jp.co.intra_mart.foundation.security.message.MessageManager.
メッセージマネージャクラス。
MessageManager - class jp.co.intra_mart.framework.base.message.MessageManager.
メッセージマネージャです。
MessageManager - class jp.co.intra_mart.framework.system.message.MessageManager.
メッセージを制御します。
MessageManagerException - exception jp.co.intra_mart.framework.base.message.MessageManagerException.
サービスマネージャ設定時の例外です。
MessageManagerException() - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String) - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
MessageManagerException - exception jp.co.intra_mart.framework.system.message.MessageManagerException.
メッセージマネージャに関連する例外です。
MessageManagerException() - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String) - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String, Throwable) - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
MessageParamTag - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag.
メッセージの生成で使用するパラメータを設定します。
MessageParamTag() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のコンストラクタ
ParamTagを新規に生成します。
MessagePropertyException - exception jp.co.intra_mart.framework.base.message.MessagePropertyException.
メッセージプロパティ取得時の例外です。
MessagePropertyException() - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String) - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
MessagePropertyException - exception jp.co.intra_mart.framework.system.message.MessagePropertyException.
メッセージプロパティハンドラに関連する例外です。
MessagePropertyException() - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String) - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String, Throwable) - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
MessagePropertyHandler - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler.
メッセージの設定情報に接続するクラスです。
MessagePropertyHandler - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler.
メッセージに関連するプロパティを取得します。
MessagePropertyParam - class jp.co.intra_mart.framework.system.message.MessagePropertyParam.
メッセージプロパティハンドラの初期パラメータです。
MessagePropertyParam() - class jp.co.intra_mart.framework.system.message.MessagePropertyParam のコンストラクタ
MessagePropertyParamを新規に生成します。
MessageReporter - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter.
メッセージ出力のためのインターフェースです。
MessageReporter - interface jp.co.intra_mart.foundation.utility.report.MessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
MessageTEI - class jp.co.intra_mart.framework.base.web.tag.MessageTEI.
Messageタグの拡張情報です。
MessageTEI() - class jp.co.intra_mart.framework.base.web.tag.MessageTEI のコンストラクタ

MessageTag - class jp.co.intra_mart.framework.base.web.tag.MessageTag.
Messageタグです。
MessageTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のコンストラクタ
MessageTagを新規に生成します。
MismatchException - exception jp.co.intra_mart.framework.presentation.MismatchException.
キーが重複しているときに発生する例外です。
MismatchException() - class jp.co.intra_mart.framework.presentation.MismatchException のコンストラクタ
詳細メッセージを指定しないで DuplicateException を構築します。
MismatchException(String) - class jp.co.intra_mart.framework.presentation.MismatchException のコンストラクタ
指定された詳細メッセージを持つ DuplicateException を構築します。
MismatchException(String, Throwable) - class jp.co.intra_mart.framework.presentation.MismatchException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。
Model - interface jp.co.intra_mart.foundation.datastore.common.config.Model.
モデルを定義します。
MultiCastReporter - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter.
メッセージを複数のストリームに出力するためのフィルタークラスです。
MultiCastReporter() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のコンストラクタ
唯一のコンストラクタ。
MultiCastReporter - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
MultiCastReporter() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のコンストラクタ
推奨されていません。 唯一のコンストラクタ。
MultiComparator - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator.
複数のコンパレータを使用してソートを行うためにクラスです。
MultiComparator(Comparator, Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のコンストラクタ
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
MultiComparator - class jp.co.intra_mart.foundation.utility.MultiComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
MultiComparator(Comparator, Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のコンストラクタ
推奨されていません。 第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
MultiSelectableItem - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem.
複数の選択肢を選択することが可能な項目です。
MultiSelectableItem() - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のコンストラクタ

MultipartFormData - class jp.co.intra_mart.foundation.http.MultipartFormData.
フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。
MultipartFormData(ServletRequest) - class jp.co.intra_mart.foundation.http.MultipartFormData のコンストラクタ
リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData.Entity - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity.
フォームデータのエンティティです。
MultipleOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream.
複数の出力ストリームにバイトを書き出すためのフィルタ実装です。
MultipleOutputStream() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のコンストラクタ
唯一のコンストラクタ
MultipurposeInternetMailExtensions - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions.
MIME タイプを持つオブジェクトです。
MultipurposeInternetMailExtensions(String) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(File) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String, String) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
指定のMIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
MultipurposeInternetMailExtensions(String) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(File) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String, String) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 指定のMIMEタイプを表すオブジェクトを構築します。
mainRemoved(String, DepartmentMain) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainRemoved(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainSet(String, DepartmentMain) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
mainSet(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
make() - class jp.co.intra_mart.foundation.service.client.information.Identifier の static メソッド

makeDirectories() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すディレクトリを生成します。
mark(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力ストリームの現在位置にマークを設定します。
markSupported() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。
memberDeleted(String, DepartmentAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PrivateGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループ所属情報がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberSet(String, DepartmentAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PrivateGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
move(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルの名前を変更します。
move(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
グループキーを変更します。
moveCategory(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーを更新します。
moveDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成に登録済の組織情報を移動します。
moveMenuItem(MenuInclusion) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを移動します。
moveMenuItem(MenuInclusion) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを移動します。
movePublicGroup(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成に登録済のパブリックグループ情報を移動します。

N

NAME - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
分類区分名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
役職名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名英字
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名カナ
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
備考
NULL - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
NULL - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
NULL_DATA - class jp.co.intra_mart.foundation.service.client.NetworkAgent の static 変数
NULL を表します。
NameFormatException - exception jp.co.intra_mart.framework.presentation.NameFormatException.
名前が不正であることを示します。
NameFormatException() - class jp.co.intra_mart.framework.presentation.NameFormatException のコンストラクタ
詳細メッセージを指定しないで NameFormatException を構築します。
NameFormatException(String) - class jp.co.intra_mart.framework.presentation.NameFormatException のコンストラクタ
指定された詳細メッセージを持つ NameFormatException を構築します。
NameFormatException(String, Throwable) - class jp.co.intra_mart.framework.presentation.NameFormatException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ NameFormatException を構築します。
NetworkAgent - class jp.co.intra_mart.foundation.service.client.NetworkAgent.
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkAgent() - class jp.co.intra_mart.foundation.service.client.NetworkAgent のコンストラクタ
唯一のコンストラクタ。
NetworkConnector - class jp.co.intra_mart.foundation.service.client.NetworkConnector.
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。
NetworkConnector() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のコンストラクタ
唯一のコンストラクタ。
NetworkFile - class jp.co.intra_mart.foundation.service.client.file.NetworkFile.
Storage Service のファイルを扱う事の出来るオブジェクトです。
NetworkFile(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のコンストラクタ
新しいオブジェクトを構築します。
NoCacheFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter.
ブラウザのキャッシュを無効にするフィルタ。
NoCacheFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のコンストラクタ

NoCryption - class jp.co.intra_mart.foundation.security.cryption.NoCryption.
暗号化処理を行わない実装クラス。
NoCryption() - class jp.co.intra_mart.foundation.security.cryption.NoCryption のコンストラクタ
コンストラクタ。
NoFilterException - exception jp.co.intra_mart.foundation.security.exception.NoFilterException.
HTTPリクエスト・レスポンス取得例外クラス。
NoFilterException(String) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException() - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoSessionCookieException - exception jp.co.intra_mart.foundation.security.exception.NoSessionCookieException.
セッション情報クッキー取得例外クラス。
NoSessionCookieException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException のコンストラクタ
コンストラクタ。
NoSessionCookieException(String) - class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException のコンストラクタ
コンストラクタ。
NoSessionException - exception jp.co.intra_mart.foundation.security.exception.NoSessionException.
セッション取得例外クラス。
NoSessionException(String) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException() - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSuchPropertyException - exception jp.co.intra_mart.foundation.scenario.NoSuchPropertyException.
NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
NoSuchPropertyException(String) - class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException のコンストラクタ
詳細メッセージを指定して NoSuchPropertyException を構築します。
NoSuchSessionException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException.
特定のＨＴＴＰセッションが見つからない場合にスローされます。
NoSuchSessionException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
詳細メッセージを持たない NoSuchSessionException を構築します。
NoSuchSessionException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
詳細メッセージを持つ NoSuchSessionException を構築します。
NoSuchSessionException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。
NoSuchSessionException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
指定された原因を使用して新しい NoSuchSessionException を構築します。
NodeNameComparator - class jp.co.intra_mart.foundation.page.NodeNameComparator.
ツリービューのノードを名前順にソートするためのコンパレータです。
NodeNameComparator() - class jp.co.intra_mart.foundation.page.NodeNameComparator のコンストラクタ

NodeTypeComparator - class jp.co.intra_mart.foundation.page.NodeTypeComparator.
ツリービューのノードを種類順にソートするためのコンパレータです。
NodeTypeComparator(Comparator) - class jp.co.intra_mart.foundation.page.NodeTypeComparator のコンストラクタ
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。
NotExistException - exception jp.co.intra_mart.foundation.security.exception.NotExistException.
アクセスセキュリティ情報が存在しなかった場合の例外クラス。
NotExistException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotFoundDataSourceException - exception jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException.
データソースの参照名未解決例外クラス。
NotFoundDataSourceException(String, String) - class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException のコンストラクタ
コンストラクタ。
NotFoundDataSourceException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException のコンストラクタ
コンストラクタ。
NotFoundException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException.
指定されたコンテンツが見つからないことを通知するための例外です。
NotFoundException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
指定のメッセージを持つ例外を作成します。
NotFoundException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
NotFoundException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
例外を作成します。
NotSupportMethodException - exception jp.co.intra_mart.foundation.security.exception.NotSupportMethodException.
アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。
NotSupportMethodException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException のコンストラクタ
コンストラクタ。
NotSupportMethodException() - class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException のコンストラクタ
コンストラクタ。
NumericRangeValidator - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator.
数値の範囲をチェックします。
NumericRangeValidator() - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator のコンストラクタ

NumericValidator - class jp.co.intra_mart.framework.presentation.validator.NumericValidator.
数値（整数）として妥当であるかどうかをチェックします。
NumericValidator() - class jp.co.intra_mart.framework.presentation.validator.NumericValidator のコンストラクタ

nativeSQL(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された SQL 文をシステムの本来の SQL 文法に変換します。
newExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
初期化されていない拡張基本モデルのインスタンスを取得します。
newExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
初期化されていない拡張国際化モデルのインスタンスを取得します。
newExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
初期化されていない拡張期間国際化モデルのインスタンスを取得します。
newExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
初期化されてていない拡張期間化モデルのインスタンスを取得します。
newIdentifier() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しいセッションＩＤを生成します。
newInstance() - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の static メソッド
マッパーファクトリを取得します。
newInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
初期化されていない国際化モデルのインスタンスを取得します。
newString(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(char[]) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(char[]) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
初期化されていない期間国際化モデルのインスタンスを取得します。
newTerminableModel(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
初期化されていない期間化モデルのインスタンスを取得します。
notifyDelete(Relationship, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
notifyDelete(Relationship, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
notifyUpdate(Relationship, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
notifyUpdate(Relationship, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。

O

OBJECT_PARAM_NAME - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter の static 変数
コントローラオブジェクトのクラス名を設定するパラメータ名
OWNER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
所有者コード
OWNER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
所有者コード
Option - class jp.co.intra_mart.framework.presentation.view.Option.
選択項目における選択肢です。
Option() - class jp.co.intra_mart.framework.presentation.view.Option のコンストラクタ

OutputSizeConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner.
このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
OutputSizeConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner のコンストラクタ
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
OutputSizeConditioner - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
OutputSizeConditioner(long) - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner のコンストラクタ
推奨されていません。 メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
out - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の変数
フィルタ処理される基礎出力ストリームです。
out - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の変数
基礎出力ストリームです。
out - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の変数
基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.service.provider.Platform の static 変数
システムログに対するメッセージ出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.io.HexOutputStream の変数
推奨されていません。 フィルタ処理される基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.report.FileReporter の変数
推奨されていません。 基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の変数
推奨されていません。 基礎出力ストリームです。

P

PARAM_APPLICATION - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのアプリケーションのパラメータ名
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
アプリケーション
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
アプリケーション
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのクラスのパラメータ名
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
クラス
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
クラス
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのパラメータのパラメータ名
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
パラメータ
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
パラメータ
PARAM_ARGUMENT - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数のリクエストパラメータ名
PARAM_ARGUMENT - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
PARAM_ARGUMENT - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 ページ引数のリクエストパラメータ名
PARAM_ARGUMENT_DELIMITER - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数のデリミタ
PARAM_ARGUMENT_DELIMITER - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
PARAM_ARGUMENT_OPERATOR - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数の演算子
PARAM_ARGUMENT_OPERATOR - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのデフォルトのパラメータ名
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
デフォルト
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
デフォルト
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_ERROR_PAGE - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の static 変数
エラーページパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ログイングループIDのリクエストパラメータ名
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 ログイングループIDのリクエストパラメータ名
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ログインユーザIDのリクエストパラメータ名
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 ログインユーザIDのリクエストパラメータ名
PARAM_MAX - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
文字列長の最大値が設定されているパラメータ名
PARAM_MAX - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の static 変数
数値の最大値が設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.presentation.validator.FormatValidator の static 変数
不正文字列である場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の static 変数
数値が範囲外の場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.presentation.validator.NumericValidator の static 変数
数値として妥当ではない場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE_LONG - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
文字列長が長い場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE_SHORT - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
文字列長が短い場合のメッセージが設定されているパラメータ名
PARAM_MIN - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
文字列長の最小値が設定されているパラメータ名
PARAM_MIN - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の static 変数
数値の最小値が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.presentation.validator.FormatValidator の static 変数
検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.presentation.validator.NumericValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_REFERER - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 参照元URLのリクエストパラメータ名
PARAM_REFERER - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。
PARAM_REFERER - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 参照元URLのリクエストパラメータ名
PARAM_REGEX - class jp.co.intra_mart.framework.presentation.validator.FormatValidator の static 変数
正規表現によるフォーマットが設定されているパラメータ名
PARAM_SECURITY_EXT - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 セキュリティの拡張子
PARAM_WINDOW_NAME - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 基本ウィンドウ名
PARENT_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
親組織コード
PARENT_PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
親グループコード
POST_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
役職CD
POST_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
役職コード
PREFIX_ATTRIBUTE - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
HttpServletRequestにおけるURLのプレフィックスの保存先
PRIVATE_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
グループコード
PRIVATE_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
グループコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
グループセットコード
P_ID_CONNECTOR_CLASS - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数

P_ID_CONNECTOR_NAME - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数

P_ID_CONNECT_NAME - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数

P_ID_DAO_CLASS - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数

P_ID_DAO_CONNECTOR_NAME - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数

P_ID_EVENT_KEY - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_EVENT_NAME - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_FACTORY_CLASS - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

P_ID_FACTORY_PARAM - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数

P_ID_POST_TRIGGER - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_PRE_TRIGGER - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

P_ID_RESOURCE_NAME - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数

P_ID_RESOURCE_NAME - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

P_ID_RESOURCE_PARAM - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数

P_ID_TRIGGER_CLASS - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数

PanelBasedViewObject - interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject.
パネルコンポーネントの表示に関連するオブジェクトです。
ParamTag - class jp.co.intra_mart.framework.base.web.tag.ParamTag.
リンク先、遷移先に渡すパラメータを設定します。
ParamTag() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のコンストラクタ
ParamTagを新規に生成します。
ParameterSendable - interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable.
パラメータを渡すことができるタグです。
PasswordSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String, String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
PeriodicConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner.
このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PeriodicConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner のコンストラクタ
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
PeriodicConditioner - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
PeriodicConditioner(long) - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner のコンストラクタ
推奨されていません。 タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
PermanentDataArchiveFactory - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory.
推奨されていません。
PermanentDataArchiveFactory() - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory のコンストラクタ
推奨されていません。 バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。
PermanentDataDirectory - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory.
Permanent-data を保存するディレクトリを表すオブジェクトです。
PermanentDirectory - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory.
ファイルベースでデータを保存します。
PermanentDirectory(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermanentFile - class jp.co.intra_mart.foundation.service.client.information.PermanentFile.
ファイルベースでデータを保存します。
PermanentFile(String, String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermanentFile(PermanentDirectory, String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermissionManager - class jp.co.intra_mart.foundation.security.permission.PermissionManager.
パーミッション・マネージャクラス。
PermissionManager(String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のコンストラクタ
コンストラクタ。
PermissionSelector - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector.
パーミッション・作成クラスインタフェース。
PlainCompanyPost - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost.
役職データを扱います。
Platform - class jp.co.intra_mart.foundation.service.provider.Platform.
Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。
PortFolioDrawer - class jp.co.intra_mart.foundation.graph.PortFolioDrawer.
ポートフォリオを描画します。
PortFolioDrawer(int, int, int, int, int, int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のコンストラクタ
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。
PortFolioDrawer(double, double, double, double, double, double) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のコンストラクタ
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。
PortFolioObject - class jp.co.intra_mart.foundation.graph.PortFolioObject.
PortFolioDrawerクラスのデータを保存するオブジェクトです。
PortFolioObject(double, double) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(int, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(double, double, Color, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortFolioObject(int, int, Color, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PostInfo - class jp.co.intra_mart.foundation.security.PostInfo.
役職情報クラス。
PostInfo(String, String) - class jp.co.intra_mart.foundation.security.PostInfo のコンストラクタ
コンストラクタ。
PresentationConnectFilter - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter.
推奨されていません。 この機能は廃止されました。
PresentationConnectFilter() - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter のコンストラクタ
推奨されていません。 ライセンス情報の設定
PresentationFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler.
im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
PresentationFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のコンストラクタ
プレゼンテーションフレームワークを実行するためのハンドラを作成します。
PresentationFrameworkHTTPActionEventHandler(String, String, String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のコンストラクタ
プレゼンテーションフレームワークを実行するためのハンドラを作成します。
PresentationManager - class jp.co.intra_mart.framework.presentation.PresentationManager.
プレゼンテーションマネージャです。
PresentationManager() - class jp.co.intra_mart.framework.presentation.PresentationManager のコンストラクタ
PresentationManagerを新規に生成します。
PresentationManagerException - exception jp.co.intra_mart.framework.presentation.PresentationManagerException.
PresentationManager設定時の例外です。
PresentationManagerException() - class jp.co.intra_mart.framework.presentation.PresentationManagerException のコンストラクタ
詳細メッセージを指定しないで PresentationManagerException を構築します。
PresentationManagerException(String) - class jp.co.intra_mart.framework.presentation.PresentationManagerException のコンストラクタ
指定された詳細メッセージを持つ PresentationManagerException を構築します。
PresentationManagerException(String, Throwable) - class jp.co.intra_mart.framework.presentation.PresentationManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationManagerException を構築します。
PresentationPage - class jp.co.intra_mart.foundation.scenario.PresentationPage.
PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。
PresentationPage() - class jp.co.intra_mart.foundation.scenario.PresentationPage のコンストラクタ
セッションを持たないページ作成用オブジェクトを作成します。
PresentationPage(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.scenario.PresentationPage のコンストラクタ
任意のセッションを持つページ作成オブジェクトを構築します。
PresentationPageHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler.
ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
PresentationPageHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPageHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPropertyException - exception jp.co.intra_mart.framework.presentation.PresentationPropertyException.
PresentationProperty取得時の例外です。
PresentationPropertyException() - class jp.co.intra_mart.framework.presentation.PresentationPropertyException のコンストラクタ
詳細メッセージを指定しないで PresentationPropertyException を構築します。
PresentationPropertyException(String) - class jp.co.intra_mart.framework.presentation.PresentationPropertyException のコンストラクタ
指定された詳細メッセージを持つ PresentationPropertyException を構築します。
PresentationPropertyException(String, Throwable) - class jp.co.intra_mart.framework.presentation.PresentationPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
PresentationPropertyHandler - interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler.
プレゼンテーションフレームワークのプロパティ設定のハンドラです。
PresentationServiceController - class jp.co.intra_mart.framework.presentation.service.PresentationServiceController.
Presentation Framework用のServiceControllerです。
PresentationServiceController() - class jp.co.intra_mart.framework.presentation.service.PresentationServiceController のコンストラクタ

PresentationServlet - class jp.co.intra_mart.framework.presentation.PresentationServlet.
プレゼンテーションフレームワークのサーブレットです。
PresentationServlet() - class jp.co.intra_mart.framework.presentation.PresentationServlet のコンストラクタ

PrimaryKeyMapping - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping.
分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。
PrintStreamReporter - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter.
メッセージ出力用クラスです。
PrintStreamReporter(PrintStream) - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
PrintStreamReporter - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
PrintStreamReporter(PrintStream) - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
PrivateGroup - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup.
プライベートグループの基本属性のデータを取り扱います。
PrivateGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のコンストラクタ

PrivateGroupAttach - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach.
プライベートグループ所属の基本属性のデータを取り扱います。
PrivateGroupAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のコンストラクタ

PrivateGroupAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel.
プライベートグループ所属の基本モデルです。
PrivateGroupAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper.
プライベートグループ所属に関連するマッパです。
PrivateGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel.
プライベートグループの基本モデルです。
PrivateGroupChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener.
プライベートグループに関する情報の更新時のリスナーです。
PrivateGroupManager - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager.
プライベートグループに関連する情報を管理します。
PrivateGroupManager() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のコンストラクタ

PrivateGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper.
プライベートグループに関連するマッパです。
ProcedureComponent - interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent.
スケジュール実行されるバッチプログラムのためのインターフェースを定義します。
Profile - class jp.co.intra_mart.foundation.appcomn.Profile.
推奨されていません。
Profile(String) - class jp.co.intra_mart.foundation.appcomn.Profile のコンストラクタ
推奨されていません。 コンストラクタ
ProfitCenter - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter.
利益センタ情報クラス
機能は以下の通り
利益センタの情報を保持します。
ProfitCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のコンストラクタ
利益センタ情報を作成します。
ProfitCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController.
利益センタコントローラクラス
機能は以下の通り
利益センタの情報を取得します。
ProfitCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList.
利益センタ一覧クラス
機能は以下の通り
利益センタの情報を一覧形式で取得します。
ProfitCenterList(String, String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のコンストラクタ
executeBapiを呼び出し利益センタ一覧を作成します。
PropertiesFile - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile.
プロパティファイルクラス
機能は以下の通り
ファイル名を指定してプロパティファイルを呼び出します。
PropertiesFile(String) - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のコンストラクタ
ファイル名を指定してプロパティファイルを取得します。
Property - interface jp.co.intra_mart.foundation.datastore.common.config.Property.
プロパティを定義します。
PropertyConfigModel - class jp.co.intra_mart.framework.system.property.PropertyConfigModel.
データモデルクラスです。
PropertyConfigModel() - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のコンストラクタ

PropertyHandler - interface jp.co.intra_mart.framework.system.property.PropertyHandler.
プロパティにアクセスするインタフェースです。
PropertyHandlerException - exception jp.co.intra_mart.framework.system.property.PropertyHandlerException.
プロパティハンドラの情報取得時の例外です。
PropertyHandlerException() - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
詳細メッセージを指定しないで PropertyHandlerException を構築します。
PropertyHandlerException(String) - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
指定された詳細メッセージを持つ PropertyHandlerException を構築します。
PropertyHandlerException(String, Throwable) - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。
PropertyHandlerParam - class jp.co.intra_mart.framework.system.property.PropertyHandlerParam.
プロパティハンドラを生成する時の初期パラメータです。
PropertyHandlerParam() - class jp.co.intra_mart.framework.system.property.PropertyHandlerParam のコンストラクタ
PropertyHandlerParamを新規に生成します。
PropertyManager - class jp.co.intra_mart.framework.system.property.PropertyManager.
システム設定の情報を管理します。
PropertyManager() - class jp.co.intra_mart.framework.system.property.PropertyManager のコンストラクタ
プロパティマネージャのコンストラクタです。
PropertyManagerException - exception jp.co.intra_mart.framework.system.property.PropertyManagerException.
プロパティマネージャの設定時の例外です。
PropertyManagerException() - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
詳細メッセージを指定しないで PropertyManagerException を構築します。
PropertyManagerException(String) - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
指定された詳細メッセージを持つ PropertyManagerException を構築します。
PropertyManagerException(String, Throwable) - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。
PropertyModel - class jp.co.intra_mart.framework.system.property.PropertyModel.
プロパティモデルクラスです。
PropertyModel() - class jp.co.intra_mart.framework.system.property.PropertyModel のコンストラクタ

PropertyParam - class jp.co.intra_mart.framework.system.property.PropertyParam.
プロパティのパラメータを表現する汎用的なクラスです。
PropertyParam() - class jp.co.intra_mart.framework.system.property.PropertyParam のコンストラクタ
PropertyParamを新規に生成します。
PublicGroup - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup.
パブリックグループの基本属性のデータを取り扱います。
PublicGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ

PublicGroupAttach - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach.
パブリックグループ所属の基本属性のデータを取り扱います。
PublicGroupAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のコンストラクタ

PublicGroupAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel.
パブリックグループ所属の基本モデルです。
PublicGroupAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper.
パブリックグループ所属に関連するマッパです。
PublicGroupAttachTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable.
パブリックグループ所属の期間化属性のデータを取り扱います。
PublicGroupAttachTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable のコンストラクタ

PublicGroupAttachTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel.
パブリックグループ所属の期間化モデルです。
PublicGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel.
パブリックグループの基本モデルです。
PublicGroupCategory - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory.
パブリックグループ分類の基本属性のデータを取り扱います。
PublicGroupCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のコンストラクタ

PublicGroupCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel.
パブリックグループ分類の基本モデルです。
PublicGroupCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper.
パブリックグループ分類に関連するマッパです。
PublicGroupCategoryTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable.
パブリックグループ分類の期間化属性のデータを取り扱います。
PublicGroupCategoryTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable のコンストラクタ

PublicGroupCategoryTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel.
パブリックグループ分類の期間化モデルです。
PublicGroupChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener.
パブリックグループに関する情報の更新時のリスナーです。
PublicGroupChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener.
パブリックグループに関する情報の変更時のリスナーです。
PublicGroupChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のコンストラクタ

PublicGroupImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter.
パブリックグループのインポートのインターフェースです
PublicGroupInclusionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel.
パブリックグループ内包の基本モデルです。
PublicGroupInclusionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper.
パブリックグループ内包に関連するマッパです。
PublicGroupInfo - class jp.co.intra_mart.foundation.security.PublicGroupInfo.
パブリックグループ情報クラス。
PublicGroupInfo(String, String) - class jp.co.intra_mart.foundation.security.PublicGroupInfo のコンストラクタ
コンストラクタ。
PublicGroupManager - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager.
パブリックグループに関連する情報を管理します。
PublicGroupManager() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のコンストラクタ

PublicGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper.
パブリックグループに関連するマッパです。
PublicGroupSet - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet.
パブリックグループセットの基本属性のデータを取り扱います。
PublicGroupSet() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ

PublicGroupSetBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel.
パブリックグループセットの基本モデルです。
PublicGroupSetMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper.
パブリックグループセットに関連するマッパです。
PublicGroupSetTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable.
パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のコンストラクタ

PublicGroupSetTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational.
パブリックグループセットの期間国際化属性のデータを取り扱います。
PublicGroupSetTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のコンストラクタ

PublicGroupStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct.
組織の階層です。
PublicGroupTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable.
パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のコンストラクタ

PublicGroupTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational.
パブリックグループの期間国際化属性のデータを取り扱います。
PublicGroupTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のコンストラクタ

PublicGroupTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel.
パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel.
パブリックグループの期間化モデルです。
PublicGroupVersion - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion.
パブリックグループ構成バージョンの基本属性のデータを取り扱います。
PublicGroupVersion() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のコンストラクタ

PublicGroupVersionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel.
パブリックグループ構成バージョンの基本モデルです。
PublicGroupVersionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper.
パブリックグループ構成バージョンに関連するマッパです。
parseInt(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。
parseLong(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。
parseRequest(LoginRequestInfo, HttpServletRequest) - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
リクエストパラメータの解析。
parseRequest(LoginRequestInfo, HttpServletRequest) - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のメソッド
リクエストパラメータの解析。
parseRequest(LoginRequestInfo, HttpServletRequest) - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
リクエストパラメータの解析。
paths(int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
paths(int) - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
postAdded(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postAdded(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postCreate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者情報をデータストアに作成した直後にコールされます。
postCreate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアに作成した直後にコールされます。
postCreate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアに作成した直後にコールされます。
postCreate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアに作成した直後にコールされます。
postCreate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアに作成した直後にコールされます。
postCreateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
postCreateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
postCreateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアに作成した直後にコールされます。
postCreateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアに作成した直後にコールされます。
postCreateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに作成した直後にコールされます。
postCreateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに作成した直後にコールされます。
postCreateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに作成した直後にコールされます。
postCreateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに作成した直後にコールされます。
postCreateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
postCreateSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールにサブロールを追加した直後にコールされます。
postCreateSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールにサブロールを追加する直前にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアから削除した直後にコールされます。
postDelete(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアから削除した直後にコールされます。
postDelete(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアから削除した直後にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアから削除した直後にコールされます。
postDeleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
postDeleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
postDeleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアから削除した直後にコールされます。
postDeleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアから削除した直後にコールされます。
postDeleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアから削除した直後にコールされます。
postDeleteLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアから削除した直後にコールされます。
postDeleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアから削除した直後にコールされます。
postDeleteMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアから削除した直後にコールされます。
postDeleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
postDeleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールからサブロールを削除した直後にコールされます。
postDeleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールからサブロールを削除する直前にコールされます。
postDeleted(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postDeleted(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postMove(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニューの親子関係を更新した直後にコールされます。
postMove(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニューの親子関係を更新した直後にコールされます。
postUpdate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者情報をデータストアに更新した直後にコールされます。
postUpdate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアに更新した直後にコールされます。
postUpdate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアに更新した直後にコールされます。
postUpdate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアに更新した直後にコールされます。
postUpdate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアに更新した直後にコールされます。
postUpdateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
postUpdateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
postUpdateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアに更新した直後にコールされます。
postUpdateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアに更新した直後にコールされます。
postUpdateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに更新した直後にコールされます。
postUpdateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに更新した直後にコールされます。
postUpdateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに更新した直後にコールされます。
postUpdateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに更新した直後にコールされます。
postUpdateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
postUpdated(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
postUpdated(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
prepareCall(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。
prepareCall(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
prepareCall(String, int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
prepareMimeMessage(MimeMessage) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
MIMEメッセージに対して操作を行います。
prepareSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションに対して操作を行います。
prepareStatement(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。
prepareStatement(String, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
prepareStatement(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。
prepareStatement(String, int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。
prepareStatement(String, int[]) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
prepareStatement(String, String[]) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
printAttribute(String, String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のメソッド
属性を出力します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性の内容を表示します。
printMessage(Throwable) - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener のメソッド
例外のメッセージを出力します。
printOnClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickを出力します。
printOnDblClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onDblClickを出力します。
printOnKeyDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownを出力します。
printOnKeyPress() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressを出力します。
printOnKeyUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpを出力します。
printOnMouseDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownを出力します。
printOnMouseMove() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveを出力します。
printOnMouseOut() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutを出力します。
printOnMouseOver() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverを出力します。
printOnMouseUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpを出力します。
printStackTrace(Throwable) - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener のメソッド
例外のスタックトレースを出力します。
printStackTrace() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド

printStackTrace(PrintStream) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド

printStackTrace(PrintWriter) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド

printStackTrace() - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド

printStackTrace(PrintStream) - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド

printStackTrace(PrintWriter) - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド

printURL(String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のメソッド
URLを出力します。
privateGroupAdded(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアに登録された後に呼び出されます。
privateGroupDeleted(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアから削除された後に呼び出されます。
privateGroupUpdated(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアに更新された後に呼び出されます。
propertyNames() - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
システムプロパティリストにあるすべてのキーのリストを返します。
publicGroupAdded(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupAdded(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupLeft(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
put(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
指定された値を、マップ内の指定されたキーに関連付けます 。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを保存します。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを保存します。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを保存します。
put(String, Object) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを保存します。
put(Object, Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 指定された値を、マップ内の指定されたキーに関連付けます 。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを保存します。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを保存します。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを保存します。
putAll(Map) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを保存します。
putCompanyCategoryTerminable(Term, CompanyCategoryTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyPostTerminable(Term, CompanyPostTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyPostTerminableInternational(Locale, CompanyPostTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putCompanyTerminable(Term, CompanyTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyTerminableInternational(Locale, CompanyTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putDepartmentAttachTerminable(Term, DepartmentAttachTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentMainTerminable(Term, DepartmentMainTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentTerminable(Term, DepartmentTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentTerminableInternational(Locale, DepartmentTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putImage(OutputStream) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
指定のストリームにファイルを出力します。
putImportParam(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
putInternational(Locale, CateogryClassInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, CategoryDetailInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を設定します。
putPublicGroupAttachTerminable(Term, PublicGroupAttachTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupCategoryTerminable(Term, PublicGroupCategoryTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupSetTerminable(Term, PublicGroupSetTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupSetTerminableInternational(Locale, PublicGroupSetTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putPublicGroupTerminable(Term, PublicGroupTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupTerminableInternational(Locale, PublicGroupTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
接続先のリソースを追加します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
接続先のリソースを追加します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 接続先のリソースを追加します。
putStructParam(String, String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
putTableParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
putUserTerminable(Term, UserTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を設定します。
putUserTerminableInternational(Locale, UserTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。

Q

queryCreate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者情報をデータストアに作成する直前にコールされます。
queryCreate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアに作成する直前にコールされます。
queryCreate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアに作成する直前にコールされます。
queryCreate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアに作成する直前にコールされます。
queryCreate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアに作成する直前にコールされます。
queryCreateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアに作成する直前にコールされます。
queryCreateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
queryCreateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアに作成する直前にコールされます。
queryCreateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアに作成する直前にコールされます。
queryCreateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアに作成する直前にコールされます。
queryCreateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアに作成する前にコールされます。
queryCreateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアに作成する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアから削除する直前にコールされます。
queryDelete(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアから削除する直前にコールされます。
queryDelete(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアから削除する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアから削除する直前にコールされます。
queryDeleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアから削除する直前にコールされます。
queryDeleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアから削除する直前にコールされます。
queryDeleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアから削除する直前にコールされます。
queryDeleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアから削除する直前にコールされます。
queryDeleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアから削除する直前にコールされます。
queryDeleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアから削除する前にコールされます。
queryDeleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアから削除する直前にコールされます。
queryMove(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニューの親子関係を更新する直前にコールされます。
queryMove(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニューの親子関係を更新する直前にコールされます。
queryUpdate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者情報をデータストアに更新する直前にコールされます。
queryUpdate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアに更新する直前にコールされます。
queryUpdate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアに更新する直前にコールされます。
queryUpdate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアに更新する直前にコールされます。
queryUpdate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアに更新する直前にコールされます。
queryUpdateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアに更新する直前にコールされます。
queryUpdateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアに更新する直前にコールされます。
queryUpdateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアに更新する直前にコールされます。
queryUpdateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアに更新する直前にコールされます。
queryUpdateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアに更新する直前にコールされます。
queryUpdateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアに更新する前にコールされます。
queryUpdateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアに更新する直前にコールされます。
queue() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターを取得するための待ち行列に入っているスレッドの数です。
queue() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターを取得するための待ち行列に入っているスレッドの数です。

R

RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
最終更新日
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
最終更新者
REMOVE - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REMOVE_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REMOVE_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REQUEST_INFO_ATTRIBUTE - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
HttpServletRequestにおける RequestInfoの保存先
REQUEST_SEPARATOR - class jp.co.intra_mart.framework.base.service.ServiceServlet の static 変数
リクエストの情報を分割するセパレータ
REQUEST_SEPARATOR - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
リクエストの情報を分割するセパレータ
RP_CLIENT_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
クライアントタイプのデフォルトＵＲＬ引数名。
RP_ENCODING - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエンコーディングのデフォルトＵＲＬ引数名。
RP_INITIAL_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
初期ＵＲＬのデフォルトＵＲＬ引数名。
RP_LOCALE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインロケールのデフォルトＵＲＬ引数名。
RP_LOGIN_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループIDのデフォルトＵＲＬ引数名。
RP_LOGIN_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインタイプのデフォルトＵＲＬ引数名。
RP_PASSWORD - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
パスワードのデフォルトＵＲＬ引数名。
RP_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
RP_URL_SIGN - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
RP_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインユーザＩＤのデフォルトＵＲＬ引数名。
RadarChartDrawer - class jp.co.intra_mart.foundation.graph.RadarChartDrawer.
レーダーチャートを描画します。
RadarChartDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のコンストラクタ
ｙ軸の目盛値をint表現でレーダーチャートを作成します。
RadarChartDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。
RadarChartObject - class jp.co.intra_mart.foundation.graph.RadarChartObject.
RadarChartDrawerクラスのデータを保存するオブジェクトです。
RadarChartObject() - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
RadarChartObject(Color) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
グラフ線の色を指定して、データオブジェクトを作成します。
RadarChartObject(boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
塗りつぶしの可否を指定して、データオブジェクトを作成します。
RadarChartObject(Color, boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。
Relationship - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship.
リレーションシップを定義します。
ReplaceWriter - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter.
このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
ReplaceWriter(Writer, char[]) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, char[], char[]) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
ReplaceWriter(Writer, char[]) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, char[], char[]) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String, String) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReportFileConditioner - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner.
このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportFileConditioner - interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportFileWriter - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter.
メッセージをファイルに出力するストリームクラスです。
ReportFileWriter(File) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のコンストラクタ
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
ReportFileWriter - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportFileWriter(File) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のコンストラクタ
推奨されていません。 ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
ReportLevel - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel.
メッセージレベルのインターフェースです。
ReportLevel - interface jp.co.intra_mart.foundation.utility.report.ReportLevel.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。
ReportLevelFilter - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter.
メッセージの出力制御を行うためのフィルタークラスです。
ReportLevelFilter(MessageReporter, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のコンストラクタ
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
ReportLevelFilter - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
ReportLevelFilter(MessageReporter, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のコンストラクタ
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
RepresentativeReporter - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter.
メッセージ出力をイベント処理するためのフィルタークラスです。
RepresentativeReporter(MessageReporter, EventQueueController) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のコンストラクタ
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
RepresentativeReporter - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。
RepresentativeReporter(MessageReporter, EventQueueController) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のコンストラクタ
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
RequestAnalyzer - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer.
リクエストアナライザインタフェース。
RequestCharacterEncodingFilter - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter.
リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
RequestCharacterEncodingFilter() - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter のコンストラクタ

RequestEntityTooLargeException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException.
処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
RequestEntityTooLargeException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
指定のメッセージを持つ例外を作成します。
RequestEntityTooLargeException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
RequestEntityTooLargeException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
例外を作成します。
RequestException - exception jp.co.intra_mart.framework.base.service.RequestException.
リクエストの内容に関連する間違いがある場合の例外です。
RequestException() - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
詳細メッセージを指定しないで RequestException を構築します。
RequestException(String) - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
指定された詳細メッセージを持つ RequestException を構築します。
RequestException(String, Throwable) - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。
RequestFormatException - exception jp.co.intra_mart.framework.presentation.controller.RequestFormatException.
フォーマットが不正であるときの例外です。
RequestFormatException() - class jp.co.intra_mart.framework.presentation.controller.RequestFormatException のコンストラクタ
詳細メッセージを指定しないで RequestFormatException を構築します。
RequestFormatException(String) - class jp.co.intra_mart.framework.presentation.controller.RequestFormatException のコンストラクタ
指定された詳細メッセージを持つ RequestFormatException を構築します。
RequestFormatException(String, Throwable) - class jp.co.intra_mart.framework.presentation.controller.RequestFormatException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
RequestInfo - interface jp.co.intra_mart.framework.presentation.RequestInfo.
リクエストに対する情報を取得します。
RequestMessageBodyFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter.
リクエストをラップするフィルタです。
RequestMessageBodyFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のコンストラクタ
フィルタを作成します。
RequestParameter - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter.
１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。
ResourceBundleProperties - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties.
このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。
ResourceBundleProperties(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale, ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
ResourceBundleProperties(String) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale, ClassLoader) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceFormatException - exception jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException.
リソースの内容が不適切であることを通知する例外です。
ResourceFormatException(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceFormatException - exception jp.co.intra_mart.foundation.utility.charset.ResourceFormatException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceFormatException(String) - class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException のコンストラクタ
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String, Throwable) - class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException のコンストラクタ
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader.
このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
ResourceLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ResourceLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
ResourceModel - class jp.co.intra_mart.framework.base.data.ResourceModel.
Resource情報を管理するクラスです。
ResourceModel() - class jp.co.intra_mart.framework.base.data.ResourceModel のコンストラクタ

ResourceNotFoundException - exception jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException.
リソースがないことを通知する例外です。
ResourceNotFoundException(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceNotFoundException - exception jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。
ResourceNotFoundException(String) - class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException のコンストラクタ
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String, Throwable) - class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException のコンストラクタ
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceParam - class jp.co.intra_mart.framework.base.data.ResourceParam.
データコネクタの初期パラメータです。
ResourceParam() - class jp.co.intra_mart.framework.base.data.ResourceParam のコンストラクタ
ResourceParamを新規に生成します。
ResponseCharacterEncodingFilter - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter.
レスポンスの文字エンコーディングを自動解決するフィルタです。
ResponseCharacterEncodingFilter() - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のコンストラクタ
新しくフィルタを作成します。
ResponseContentTypeManagementFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter.
レスポンスの Content-Type を自動解決するフィルタです。
ResponseContentTypeManagementFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のコンストラクタ
新しくフィルタを作成します。
ReverseComparator - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator.
コンパレータのフィルタとして機能します。
ReverseComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator のコンストラクタ
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
ReverseComparator - class jp.co.intra_mart.foundation.utility.ReverseComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
ReverseComparator(Comparator) - class jp.co.intra_mart.foundation.utility.ReverseComparator のコンストラクタ
推奨されていません。 指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
Role - class jp.co.intra_mart.foundation.security.role.Role.
ロール・モデルインタフェース。
Role() - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
Role(String) - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
Role(String, String) - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
RoleAccessor - interface jp.co.intra_mart.foundation.security.role.RoleAccessor.
ロールアクセッサインタフェース。
RoleChangedAccountListener - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener.
ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。
RoleChangedAccountListener() - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のコンストラクタ
コンストラクタ。
RoleChangedListener - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener.
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener.
ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。
RoleChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のコンストラクタ
コンストラクタ。
RoleExporter - interface jp.co.intra_mart.foundation.security.role.RoleExporter.
ロールエクスポートインタフェースです。
RoleImporter - interface jp.co.intra_mart.foundation.security.role.RoleImporter.
ロールインポートインタフェースです。
RoleManager - class jp.co.intra_mart.foundation.acssecurity.RoleManager.
推奨されていません。
RoleManager(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のコンストラクタ
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
RoleManager - class jp.co.intra_mart.foundation.security.role.RoleManager.
ロールマネージャクラス。
RoleManager(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のコンストラクタ
コンストラクタ。
RolePostWriterListener - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener.
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleQueryWriterListener - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener.
ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
RoleReaderDecorator - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator.
ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のメソッド
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
データ取得。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
データ取得。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のメソッド
デコードデータのバイトを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のメソッド
単一の文字を読み込みます。
read(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のメソッド
配列の一部に文字を読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のメソッド
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のメソッド
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から１バイト読み込みます。
read(byte[]) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から指定のバイト配列にデータを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から指定のバイト配列にデータを読み込みます。
read() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルの内容を取得します。
read() - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 データ取得。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 データ取得。
read() - class jp.co.intra_mart.foundation.utility.io.HexInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.XORInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.XORInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
readBoolean() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
boolean 型データ取得。
readBoolean() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 boolean 型データ取得。
readInt() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
int 型データ取得。
readInt() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 int 型データ取得。
readLines() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
ファイルの行を繰り返し処理する反復子を作成します。
readLines(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
ファイルの行を繰り返し処理する反復子を作成します。
readLines() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
readLines(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
readLong() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
long 型データ取得。
readLong() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 long 型データ取得。
readObject() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
Object の取得。
readObject() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 Object の取得。
readString() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
文字列の取得。
readString() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 文字列の取得。
reconstruction() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
現在使用中の Writer をリセットします。
reconstruction() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 現在使用中の Writer をリセットします。
recordList - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するクラスのインスタンス格納用リスト
registerAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ライセンス登録します。
registerApplicationLicenseToAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アプリケーションライセンスをアカウントに登録します。
release() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のメソッド
ソケットおよび入出力ストリームの利用を中止します。
release() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターの開放。
release() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースコネクションを解放します。
release() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターの開放。
release() - class jp.co.intra_mart.foundation.utility.net.SocketConnection のメソッド
推奨されていません。 ソケットおよび入出力ストリームの利用を中止します。
release() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
データストアの資源を解放します。
releaseConnection(JCO.Client) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector の static メソッド
コネクションをリリースします。
releaseCurrentThread() - class jp.co.intra_mart.foundation.service.client.information.Lock の static メソッド
現在のスレッドに紐付いたロックを全て解除します。
releaseSavepoint(Savepoint) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションから指定された Savepoint オブジェクトを削除します。
remove(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このキーにマッピングがある場合に、そのマッピングをマップから削除します。
remove(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを削除するメソッド

データベースのデータを削除(デリート)する。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定された期間に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
指定された言語に該当するデータを削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
remove(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された期間に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された期間に該当するデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
指定された位置の値を削除します。
remove() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルまたはディレクトリを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを削除します。
remove(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを削除します。
remove(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このキーにマッピングがある場合に、そのマッピングをマップから削除します。
removeArgument(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を削除します。
removeAttribute(String) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを削除します。
removeAttribute(String) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを削除します。
removeAttribute(String) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを削除します。
removeCategoryDetail(CompanyCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に対して指定された分類区分情報を削除します。
removeCategoryDetail(PublicGroupCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに対して指定された分類区分情報を削除します。
removeChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード　node をこのノードの子から削除します。
removeChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
子ノードを全て削除します。
removeCompanyCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を削除します。
removeCompanyPostTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を削除します。
removeCompanyTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を削除します。
removeComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
指定されたコンパレータ comparatorを削除します。
removeComparator(Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 指定されたコンパレータ comparatorを削除します。
removeConditioner(ReportFileConditioner) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
removeConditioner(GCConditioner) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
removeConditioner(ReportFileConditioner) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
removeDepartmentAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentMainTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
ロケールに対応した表示名を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ロケールに対応したメニュー名を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロケールに対応したロール表示名を削除します。
removeFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を削除します。
removeListener(ShutdownListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウンリスナーを削除します。
removeListener(EventListener) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
指定されたリスナーを削除します。
removeMain(DepartmentMain) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定されたユーザの主所属を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
メッセージの出力先を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージの出力先を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージの出力先を削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定のキーのマップを削除します。
removePublicGroupAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupSetTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を削除します。
removeReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
removeReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
removeUserTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を削除します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
メッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(String) - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
メッセージを出力します。
report(Object) - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
メッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
メッセージを出力します。
report(String, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
指定のメッセージレベルが基準値以上のメッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
data をメッセージとして出力します。
report(Object, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
指定のメッセージレベルが基準値以上のメッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 メッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(String) - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 メッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 メッセージを出力します。
report(String, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(Object, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
reportError(ErrorEvent) - interface jp.co.intra_mart.foundation.utility.ErrorEventListener のメソッド
推奨されていません。 発生した例外を通知します。
reset() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
キャッシュ領域をクリアします。
reset(Writer) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
文字の出力ストリームをリセットします。
reset() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。
reset() - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 キャッシュ領域をクリアします。
reset(Writer) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 文字の出力ストリームをリセットします。
resetLock() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロックをリセットします。
resources - class jp.co.intra_mart.framework.base.data.DBConnector の変数
リソース一覧
resources - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の変数
リソース一覧
restart() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの再開通知。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
rollback() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースのトランザクションをロールバックします。
rollback() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースのトランザクションをロールバックします。
rollback() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスの取り消し処理をする

トランザクションを終了(rollback)させる。
rollback(Savepoint) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。
rollback() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
ＢＡＰＩ実行結果のROLLBACK処理を行います｡
rollback() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータコネクタをロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
ロールバックします。
run() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
このオブジェクトのスレッド実行ロジックです。
run() - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 このオブジェクトのスレッド実行ロジックです。

S

SAPAccountingAppException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException.
会計系APIアプリケーション例外クラス
SAPAccountingAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingAppException(String) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingSystemException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException.
会計系APIシステム例外クラス
SAPAccountingSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException のコンストラクタ
会計系APIシステム例外
SAPAuthAppException - exception jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException.
認証系APIアプリケーション例外クラス
SAPAuthAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException のコンストラクタ
認証系APIアプリケーション例外
SAPAuthAppException(String) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException のコンストラクタ
認証系APIアプリケーション例外
SAPAuthSystemException - exception jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException.
認証系APIシステム例外クラス
SAPAuthSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException のコンストラクタ
認証系APIシステム例外
SAPGeneralAppException - exception jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException.
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException のコンストラクタ
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralAppException(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException のコンストラクタ
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralSystemException - exception jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException.
共通API/汎用データ取得・追加・更新APIシステム例外クラス
SAPGeneralSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException のコンストラクタ
共通API/汎用データ取得・追加・更新APIシステム例外
SCALE_POSITION_CENTER - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定
SCALE_POSITION_SIDE - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定
SERVICE_EXTENSION_KEY - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
拡張子を指定するキー
SERVICE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
サービスプロパティハンドラのキー
SESSION_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.session.SessionManager の static 変数
セッションプロパティハンドラのキー
SET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SET_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SET_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ソートキー
SP_CLIENT_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
クライアントタイプをセッションに保管するパラメータ名。
SP_COLOR_PATTERN_ID - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
カラーパターンIDをセッションに保管するパラメータ名。
SP_ENCODING - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエンコーディングをセッションに保管するパラメータ名。
SP_INITIAL_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
初期ページURLを属性に保管するパラメータ名。
SP_LOCALE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインロケールをセッションに保管するパラメータ名。
SP_LOGIN_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループIDをセッションに保管するパラメータ名。
SP_LOGIN_TIME - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインした時間をセッションに保管するパラメータ名。
SP_LOGIN_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインタイプをセッションに保管するパラメータ名。
SP_SIGNATURE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイン署名をセッションに保管するパラメータ名。
SP_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証後表示するメインページをセッションに保管するパラメータ名。
SP_URL_SIGN - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
SP_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインユーザＩＤをセッションに保管するパラメータ名。
SSORequestAnalyzer - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer.
SSOのログインリクエスト解析クラス。
SSORequestAnalyzer() - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のコンストラクタ

SSO_LOGOUT_URL - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

START_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
開始日
START_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
開始日
START_ID - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
スタートポイントに入る場合のID
STRING - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
文字列型
SUFFIX_ATTRIBUTE - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
HttpServletRequestにおけるURLのサフィックスの保存先
SapConnector - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector.
SAPコネクタークラス
機能は以下の通り
単一ユーザIDで任意のコネクションプールを作成し、R/3にログインします。
SapConnector() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のコンストラクタ
プロパティファイルを読込み属性に値をセットします。
SapConnector(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のコンストラクタ
プロパティファイルを読込み属性に値をセットします。
SapRepositoryManager - class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager.
JCO.Repository を管理クラス。
Scheduler - class jp.co.intra_mart.foundation.service.client.batch.Scheduler.
Schedule Service の制御をするオブジェクトです。
Scheduler() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のコンストラクタ
新しいオブジェクトを構築します。
ScriptCompileException - exception jp.co.intra_mart.foundation.scenario.ScriptCompileException.
ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptCompileException(String) - class jp.co.intra_mart.foundation.scenario.ScriptCompileException のコンストラクタ
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptCompileException(String, Throwable) - class jp.co.intra_mart.foundation.scenario.ScriptCompileException のコンストラクタ
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptRuntimeException - exception jp.co.intra_mart.foundation.scenario.ScriptRuntimeException.
ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException(String) - class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException のコンストラクタ
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException のコンストラクタ
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptValue - interface jp.co.intra_mart.foundation.scenario.ScriptValue.
スクリプトの値を保持するオブジェクトです。
SecurityConstraint - interface jp.co.intra_mart.foundation.security.SecurityConstraint.
アクセスセキュリティ定数インタフェース。
SelectableItem - class jp.co.intra_mart.framework.presentation.view.SelectableItem.
選択肢を持つ項目です。
SelectableItem() - class jp.co.intra_mart.framework.presentation.view.SelectableItem のコンストラクタ

SequenceComparator - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator.
挿入順にソートするためのコンパレータです。
SequenceComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator のコンストラクタ
新しいオブジェクトを生成します。
SequenceComparator - class jp.co.intra_mart.foundation.utility.SequenceComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。
SequenceComparator() - class jp.co.intra_mart.foundation.utility.SequenceComparator のコンストラクタ
推奨されていません。 新しいオブジェクトを生成します。
ServerConnector - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector.
このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。
ServerConnector(SocketConnectionDistributor) - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のコンストラクタ
オブジェクトを作成します。
ServiceController - interface jp.co.intra_mart.framework.base.service.ServiceController.
クライアントからの入力に対する処理を行います。
ServiceControllerAdapter - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。
ServiceControllerAdapter() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のコンストラクタ
ServiceControllerAdapterを新規に生成します。
ServiceControllerException - exception jp.co.intra_mart.framework.base.service.ServiceControllerException.
サービスコントローラに関連する例外です。
ServiceControllerException() - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
詳細メッセージを指定しないで ServiceControllerException を構築します。
ServiceControllerException(String) - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
指定された詳細メッセージを持つ ServiceControllerException を構築します。
ServiceControllerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。
ServiceFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler.
im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServiceFrameworkHTTPActionEventHandler(String, String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServiceManager - class jp.co.intra_mart.framework.base.service.ServiceManager.
サービスマネージャです。
ServiceManagerException - exception jp.co.intra_mart.framework.base.service.ServiceManagerException.
サービスマネージャ設定時の例外です。
ServiceManagerException() - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
詳細メッセージを指定しないで ServiceManagerException を構築します。
ServiceManagerException(String) - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
指定された詳細メッセージを持つ ServiceManagerException を構築します。
ServiceManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。
ServicePropertyException - exception jp.co.intra_mart.framework.base.service.ServicePropertyException.
サービスプロパティ取得時の例外です。
ServicePropertyException() - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
詳細メッセージを指定しないで ServicePropertyException を構築します。
ServicePropertyException(String) - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
指定された詳細メッセージを持つ ServicePropertyException を構築します。
ServicePropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。
ServicePropertyHandler - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler.
サービスの設定情報に接続するクラスです。
ServiceResult - interface jp.co.intra_mart.framework.base.service.ServiceResult.
サービスの処理結果です。
ServiceSecurityFilter - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter.
intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。
ServiceSecurityFilter() - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のコンストラクタ

ServiceServlet - class jp.co.intra_mart.framework.base.service.ServiceServlet.
サービスを振り分けるサーブレットです。
ServiceServlet() - class jp.co.intra_mart.framework.base.service.ServiceServlet のコンストラクタ
ServiceServletを新規に生成します。
ServiceServletException - exception jp.co.intra_mart.framework.base.service.ServiceServletException.
サービスに関連する例外です。
ServiceServletException() - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
詳細メッセージを指定しないで ServiceServletException を構築します。
ServiceServletException(String) - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
指定された詳細メッセージを持つ ServiceServletException を構築します。
ServiceServletException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。
ServiceUnavailableException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException.
サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
ServiceUnavailableException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ServiceUnavailableException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ServiceUnavailableException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
例外を作成します。
ServiceUtils - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils.
im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。
ServiceUtils() - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils のコンストラクタ

ServletHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler.
Web-Application を実行するためのイベントハンドラです。
ServletHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
ServletHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
SessionConfig - interface jp.co.intra_mart.foundation.security.SessionConfig.
セッションに関する設定情報を取得するインタフェース。
SessionFactory - class jp.co.intra_mart.foundation.service.client.information.SessionFactory.
共有データグループを管理するオブジェクトです。
SessionFactory(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
SessionFactory - interface jp.co.intra_mart.framework.base.session.SessionFactory.
セッションに関連するファクトリクラスとなるインタフェースです。
SessionFactoryException - exception jp.co.intra_mart.framework.base.session.SessionFactoryException.
セッションファクトリ内の例外です。
SessionFactoryException() - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
詳細メッセージを指定しないで SessionFactoryException を構築します。
SessionFactoryException(String) - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
指定された詳細メッセージを持つ SessionFactoryException を構築します。
SessionFactoryException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。
SessionFilter - class jp.co.intra_mart.foundation.security.filter.SessionFilter.
セッションフィルタ。
SessionFilter() - class jp.co.intra_mart.foundation.security.filter.SessionFilter のコンストラクタ

SessionFilter - class jp.co.intra_mart.framework.base.session.SessionFilter.
セッション管理をします。
SessionFilter() - class jp.co.intra_mart.framework.base.session.SessionFilter のコンストラクタ

SessionInfo - interface jp.co.intra_mart.foundation.security.SessionInfo.
intra-martセッション情報参照インタフェース。
SessionManager - class jp.co.intra_mart.framework.base.session.SessionManager.
セッションマネージャです。
SessionManagerException - exception jp.co.intra_mart.framework.base.session.SessionManagerException.
セッションマネージャ内の例外です。
SessionManagerException() - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
詳細メッセージを指定しないで SessionManagerException を構築します。
SessionManagerException(String) - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
指定された詳細メッセージを持つ SessionManagerException を構築します。
SessionManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。
SessionMemory - class jp.co.intra_mart.foundation.service.client.information.SessionMemory.
共有データを管理するオブジェクトです。
SessionMemory(HttpSession) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
SessionObject - interface jp.co.intra_mart.framework.base.session.SessionObject.
セッションに関連する情報を持つオブジェクトです。
SessionObjectException - exception jp.co.intra_mart.framework.base.session.SessionObjectException.
セッションオブジェクト内の例外です。
SessionObjectException() - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
詳細メッセージを指定しないで SessionObjectException を構築します。
SessionObjectException(String) - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
指定された詳細メッセージを持つ SessionObjectException を構築します。
SessionObjectException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。
SessionPropertyException - exception jp.co.intra_mart.framework.base.session.SessionPropertyException.
セッションプロパティ取得時の例外です。
SessionPropertyException() - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
詳細メッセージを指定しないで SessionPropertyException を構築します。
SessionPropertyException(String) - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
指定された詳細メッセージを持つ SessionPropertyException を構築します。
SessionPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。
SessionPropertyHandler - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler.
セッションに関連するプロパティを取得します。
SessionQuery - class jp.co.intra_mart.foundation.http.SessionQuery.
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
SessionQuery(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.http.SessionQuery のコンストラクタ
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
ShutdownEventController - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController.
このクラスは、サーバプロセスの基礎ロジック。
ShutdownListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener.
シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
SimpleControllerConverter - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter.
リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。
SimpleControllerConverter() - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter のコンストラクタ

SimplePanelBasedViewObject - class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject.
パネルコンポーネントの表示に関連するオブジェクトです。
SimplePanelBasedViewObject() - class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject のコンストラクタ

SimpleViewObject - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject.
単純なビューオブジェクトです。
SimpleViewObject() - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のコンストラクタ

SingleSelectableItem - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem.
単一の選択肢のみ選択することが可能な項目です。
SingleSelectableItem() - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem のコンストラクタ

SocketConnection - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection.
ソケットプール用のスケルトン実装を提供します。
SocketConnection(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection(Socket) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection(ExtendedSocket) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection - class jp.co.intra_mart.foundation.utility.net.SocketConnection.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnection(String, int) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnection(Socket) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnection(ExtendedSocket) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnectionDistributor - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor.
このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionDistributor - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionDistributorFactory - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory.
このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。
SocketConnectionDistributorFactory(String, int) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のコンストラクタ
オブジェクトを作成します。
SocketConnectionDistributorFactory(String, int, int) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のコンストラクタ
オブジェクトを作成します。
SocketConnectionManager - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager.
通信ソケットをプールする機能のインターフェースです。
SocketConnectionManager - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener.
通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。
SocketEventListener - interface jp.co.intra_mart.foundation.utility.net.SocketEventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。
SocketPool - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool.
このクラスは、通信ソケットをプールする機能を提供します。
SocketPool(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のコンストラクタ
ソケットプールを構築します。
SocketPool(String, int, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のコンストラクタ
ソケットプールを構築します。
SocketPool - class jp.co.intra_mart.foundation.utility.net.SocketPool.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。
SocketPool(String, int) - class jp.co.intra_mart.foundation.utility.net.SocketPool のコンストラクタ
推奨されていません。 ソケットプールを構築します。
SocketPool(String, int, int) - class jp.co.intra_mart.foundation.utility.net.SocketPool のコンストラクタ
推奨されていません。 ソケットプールを構築します。
StandardAccountBackup - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup.
アカウントバックアップクラスです。
StandardAccountBackup() - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のコンストラクタ

StandardAdminMenuBackup - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup.
メニューバックアップクラスです。
StandardAdminMenuBackup() - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のコンストラクタ

StandardBatchBackup - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup.
バッチバックアップクラスです。
StandardBatchBackup() - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のコンストラクタ

StandardCalendarBackup - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup.
カレンダーバックアップクラスです。
StandardCalendarBackup() - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のコンストラクタ

StandardCompanyImporter - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter.
会社のインポートを行います。
StandardCompanyImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter のコンストラクタ

StandardCompanyPostImporter - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter.
役職のインポートを行います。
StandardCompanyPostImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter のコンストラクタ

StandardCryption - class jp.co.intra_mart.foundation.security.cryption.StandardCryption.
文字列の暗号化・復号化を行う標準の実装クラスです。
StandardCryption() - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のコンストラクタ
コンストラクタ。
StandardEJBEventListener - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener.
StandardEJBEventListenerAgentに接続するイベントリスナです。
StandardEJBEventListener(StandardEJBEventListenerAgentHome) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener のコンストラクタ
StandardEJBEventListenerを新規に生成します。
StandardEJBEventListenerAgent - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent.
EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean.
EJBを利用する場合の抽象的なイベントリスナです。
StandardEJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のコンストラクタ
StandardEJBEventListenerAgentBeanを新規に生成します。
StandardEJBEventListenerAgentHome - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome.
StandardEJBEventListenerAgentのホームインタフェースです。
StandardEJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory.
標準的なEJB用のイベントリスナファクトリです。
StandardEJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のコンストラクタ
StandardEJBEventListenerFactoryを新規に生成します。
StandardErrorPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider.
標準のエラーページプロバイダクラス。
StandardErrorPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardEventListener - class jp.co.intra_mart.framework.base.event.StandardEventListener.
汎用的なビジネスロジック用のクラスです。
StandardEventListener() - class jp.co.intra_mart.framework.base.event.StandardEventListener のコンストラクタ

StandardEventListenerFactory - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory.
通常のJavaクラスのイベントリスナを生成します。
StandardEventListenerFactory() - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のコンストラクタ
StandardEventListenerFactoryを新規に生成します。
StandardGroupSuperUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider.
標準のログイングループ管理者用ページプロバイダクラス。
StandardGroupSuperUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardMail - class jp.co.intra_mart.foundation.mail.javamail.StandardMail.
送信するメールの属性を保管します。
StandardMail() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
ロケールを指定してメール属性オブジェクトを新規に作成します。
StandardMenuBackup - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup.
メニューバックアップクラスです。
StandardMenuBackup() - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のコンストラクタ

StandardPublicGroupImporter - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter.
パブリックグループのインポートを行います。
StandardPublicGroupImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter のコンストラクタ

StandardRequestAnalyzer - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer.
標準のログインリクエスト解析クラス。
StandardRequestAnalyzer() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のコンストラクタ
デフォルトコンストラクタ。
StandardRoleBackup - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup.
ロールバックアップクラスです。
StandardRoleBackup() - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のコンストラクタ

StandardSuperUserCertification - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification.
管理者ログイン認証の実装クラス。
StandardSuperUserCertification() - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のコンストラクタ
デフォルトコンストラクタ

StandardSuperUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider.
標準のシステム管理者用のユーザページプロバイダクラス。
StandardSuperUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardUserCertification - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification.
ユーザログイン認証クラス。
StandardUserCertification() - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のコンストラクタ
デフォルトコンストラクタ。
StandardUserImporter - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter.
ユーザプロファイルのインポートを行います。
StandardUserImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter のコンストラクタ

StandardUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider.
標準のユーザページプロバイダクラス。
StandardUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StdErr - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr.
このクラスは、エラーメッセージ出力用です。
StdOut - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut.
このクラスは、システムメッセージ出力用です。
StorageDirectory - class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory.
Storage Service の基準ディレクトリを表すクラスです。
StrutsConnectFilter - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter.
intra-martのメニューからStrutsに接続するフィルターです。
StrutsConnectFilter() - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のコンストラクタ

SubmitLinkTag - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag.
サブミット専用のLINKタグです。
SubmitLinkTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のコンストラクタ
SubmitLinkTagを新規に生成します。
SubmitLinkTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo.
SubmitLinkTagのBeanInfoです。
SubmitLinkTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo のコンストラクタ
SubmitLinkTagBeanInfoを新規に生成します。
SubmitTEI - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI.
Submitタグの拡張情報です。
SubmitTEI() - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI のコンストラクタ
SubmitTEIを新規に生成します。
SubmitTag - class jp.co.intra_mart.framework.base.web.tag.SubmitTag.
Submitタグです。
SubmitTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のコンストラクタ
SubmitTagを新規に生成します。
SubmitTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo.
SubmitTagのBeanInfoです。
SubmitTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo のコンストラクタ
SubmitTagBeanInfoを新規に生成します。
SuperCertification - interface jp.co.intra_mart.foundation.security.certification.SuperCertification.
管理者ログイン認証インタフェース。
SuperUser - class jp.co.intra_mart.foundation.security.admin.SuperUser.
スーパーユーザ・モデルインタフェース。
SuperUser() - class jp.co.intra_mart.foundation.security.admin.SuperUser のコンストラクタ
コンストラクタ。
SuperUser(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のコンストラクタ
コンストラクタ。
SuperUserAccessor - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor.
システム管理者アクセッサインタフェース。
SuperUserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet.
システム管理者初期アクセスサーブレット。
SuperUserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のコンストラクタ

SuperUserNoCertification - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification.
システム管理者ログイン時に強制認証を行う実装クラスです。
SuperUserNoCertification() - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のコンストラクタ
デフォルトコンストラクタ

SuperUserPostWriterListener - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener.
システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
SuperUserQueryWriterListener - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener.
システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
SuperUserReaderDecorator - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator.
システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
SystemConfigException - exception jp.co.intra_mart.foundation.security.exception.SystemConfigException.
システム設定に関する例外クラス。
SystemConfigException() - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(String) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(Throwable) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemDBConnector - class jp.co.intra_mart.framework.base.data.SystemDBConnector.
イントラマートで設定されているDBコネクションです。
SystemDBConnector() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のコンストラクタ
SystemDBConnectorを新規に生成します。
SystemDBDAO - class jp.co.intra_mart.framework.base.data.SystemDBDAO.
イントラマートで設定されたDBへアクセスするDAOです。
SystemDBDAO() - class jp.co.intra_mart.framework.base.data.SystemDBDAO のコンストラクタ
IntramartDBDAOを新規に生成します。
SystemErrorReporter - interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter.
エラーログ出力用のインターフェースです。
SystemException - exception jp.co.intra_mart.framework.system.exception.SystemException.
フレームワーク内で発生したシステム例外です。
SystemException() - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
詳細メッセージを指定しないで SystemException を構築します。
SystemException(String) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
指定された詳細メッセージを持つ SystemException を構築します。
SystemException(Throwable) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
この例外の発生原因となる例外を持つ SystemException を構築します。
SystemException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。
SystemManager - class jp.co.intra_mart.foundation.security.SystemManager.
システムマネージャクラス。
SystemReporter - interface jp.co.intra_mart.foundation.service.provider.SystemReporter.
システムログの共通インターフェースです。
SystemSourceProvider - interface jp.co.intra_mart.foundation.security.SystemSourceProvider.
ロケール情報取得インターフェース。
save(byte[]) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにバイトを出力します。
searchAccounts(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報の読み込みます。
searchAccounts(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ユーザIDを検索してマッチしたアカウントを配列で返します。
searchRolesById(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールID検索によりロールを取得します。
searchRolesByName(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール名称検索によりロールを取得します。
secureRedirect(HttpServletRequest, HttpServletResponse, String, Map) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
secureRedirect(String, Map) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
select(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SELECT文を発行してデータベースからデータを取得する

select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
プライマリーキーで特定される分類区分の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
プライマリーキーで特定される組織所属の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
プライマリーキーで特定される会社組織分類の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
プライマリーキーで特定される会社の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
プライマリーキーで特定される組織の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
プライマリーキーで特定される組織内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
プライマリーキーで特定される主所属の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
プライマリーキーで特定される役職の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
プライマリーキーで特定されるユーザの基本モデルを取得します。
select(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
プライマリーキーで特定される基本モデルを取得します。
select(Relationship, Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
外部キーで特定される基本モデルをすべて取得します。
select(Map) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
プライマリーキーで特定される基本モデルを取得します。
selectCategoryDetailInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
指定された言語に該当する分類区分詳細の国際化モデルを取得します。
selectCateogryClassInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
指定された言語に該当する分類区分の国際化モデルを取得します。
selectCompanyPostTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
指定された言語に該当する役職の期間国際化モデルを取得します。
selectCompanyPostTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
指定された日付に該当する役職の期間化モデルを取得します。
selectDepartmentAttachTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
指定された日付に該当する組織所属の期間化モデルを取得します。
selectDepartmentMainTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
指定された日付に該当する主所属の期間化モデルを取得します。
selectDepartmentTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
指定された言語に該当する組織の期間国際化モデルを取得します。
selectDepartmentTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
指定された日付に該当する組織の期間化モデルを取得します。
selectInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定された言語に該当する国際化モデルを取得します。
selectPublicGroupTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。
selectPublicGroupTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
指定された日付に該当するパブリックグループの期間化モデルを取得します。
selectTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定された言語に該当する期間国際化モデルを取得します。
selectTerminableModel(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定された日時に該当する期間化モデルを取得します。
selectUserTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
指定された言語に該当するユーザの期間国際化モデルを取得します。
selectUserTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
指定された日付に該当するユーザの期間化モデルを取得します。
send() - interface jp.co.intra_mart.foundation.mail.MailSender のメソッド
メールを送信します。
send() - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のメソッド
メールを送信します。
send() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 指定されたSMTPサーバへメールを送信する。
sendMessage(String, String, String) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
メッセージを出力します。
serverTime() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバのミリ秒で表される現在の時間を返します。
service() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
入力に対する処理を実行します。
service() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
入力に対する処理を実行します。
sessionContext - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の変数
セッションコンテキスト
sessionCreated(HttpSessionEvent) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のメソッド
セッションが作成されたことを通知します。
sessionDestroyed(HttpSessionEvent) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のメソッド
セッションが無効になったことを通知します。
set(String, Number) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
set(String, String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に値を設定します。
set(String, Object, Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の日時で値を設定します。
set(String, Object, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の言語で値を設定します。
set(String, Object, Date, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の日時、言語で値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性に値を設定します。
set(String, Object, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性に値を設定します。
setAccept(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性acceptの値を設定します。
setAcceptcharset(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性accept-charsetの値を設定します。
setAccesskey(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
accesskeyを設定します。
setAccesskey(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
accesskeyを設定します。
setAccount(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
setAccount(String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
アカウントＩＤを設定します。
setAccountFlag(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このメソッドはシステム内で使用されます。
setAccountFlag(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
アカウントフラグを設定します。
setAccountGlList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細一覧を設定します｡
setAccountPayableList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細一覧を設定します｡
setAccountTaxList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細一覧を設定します｡
setAddress(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を設定します。
setAddress(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を設定します。
setAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所1を設定します。
setAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を設定します。
setAddress1(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を設定します。
setAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所2を設定します。
setAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を設定します。
setAddress2(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を設定します。
setAll(TreeBranch) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーション名を設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーションＩＤを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性applicationの値を設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
applicationを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性applicationの値を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
引数文字列を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。
setArgument(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を設定します。
setAshost(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
接続先サーバIPアドレスを設定します｡
setAttachInfo(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
setAttribute(String, Object) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを追加します。
setAttribute(String, Object) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを追加します。
setAttribute(String, Object) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを追加します。
setAutoCommit(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。
setBaList(BankList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を設定します｡
setBankKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを設定します｡
setBankList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧を設定します｡
setBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を設定します｡
setBapiHashList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiHashの一覧を設定します｡
setBapiReturnList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturnの一覧を設定します｡
setBaseAccessor(BaseAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
基本アクセサを設定します。
setBaseName(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperException の static メソッド
リソースバンドルの基底名を設定します。
setBatchId(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチＩＤを設定します。
setBcc(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Bccをセットする。
setBcc(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Bccをセットする。
setBody(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 本文をセットする。
setBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を設定します｡
setBusAreaList(BusinessAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を設定します｡
setBusinessAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧を設定します｡
setCapacity(int) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューの容量を変更します。
setCapacity(int) - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューの容量を変更します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプション文字列を返します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
キャプションを格納します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプションの文字色を設定します。
setCaptionMargin(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
キャプション表示位置のマージンを設定します。
setCaptionMargin(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプション表示位置のマージンを設定します。
setCatalog(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。
setCategory(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールカテゴリを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類区分コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類コードを設定します。
setCategoryDetail(CompanyCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に対して指定された分類区分情報を設定します。
setCategoryDetail(PublicGroupCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに対して指定された分類区分情報を設定します。
setCc(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Ccをセットする。
setCc(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Ccをセットする。
setCharacterEncoding(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
このオブジェクトが対象とする文字エンコーディングを設定します。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を指定します。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
setCharset(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
charsetを設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を設定します｡
setClass(String) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
推奨されていません。 このメソッドではなくHelperBeanTag.setHelperclass(java.lang.String)メソッドを使用してください。
setClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
クライアントを設定します｡
setClientType(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
クライアントタイプを設定する。
setClientType(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
クライアントタイプを設定します。
setClientType(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
クライアントタイプを設定する。
setClosed() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
このアクセサをクローズします。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を設定します｡
setCode(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
コードを設定します｡
setColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
棒の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
線の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
グラフ線の色を設定します。
setColor(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
色を設定します。
setColorPatternID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
カラーパターンIDを設定する。
setColorPatternId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
カラーパターンIDを設定します。
setColorPatternId(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
カラーパターンIDを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを設定します｡
setCompList(CompanyList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を設定します｡
setCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を設定します｡
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
会社コードを設定します。
setCompanyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを設定します。
setCompanyCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを設定します。
setCompanyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを設定します｡
setCompanyList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を設定します｡
setConnectInfo(DataConnector, String, String, String) - interface jp.co.intra_mart.framework.base.data.DAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.DAOAdapter のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.DBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のメソッド
推奨されていません。 データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.SystemDBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectionTimeout(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションのタイムアウトを設定します｡
setContentType(String) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルのフォーマットを設定します。
setContents(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
コンテンツの種類を設定します。
setControllAreaList(ControllingAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域を設定します｡
setControllingAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を設定します｡
setCoords(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
coordsを設定します。
setCoords(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
coordsを設定します。
setCostCentList(CostCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を設定します｡
setCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを設定します｡
setCostCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を設定します｡
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを設定します。
setCountryCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを設定します。
setCountryCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
国コードを設定します。
setCuAmtBase(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の課税基準額に値を設定します。
setCuAmtBase(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を設定します｡
setCuAmtDoccur(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の伝票通貨額に値を設定します。
setCuAmtDoccur(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額設定します｡
setCuCurrency(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の通貨コードに値を設定します。
setCuCurrency(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを設定します｡
setCuIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を設定します｡
setCuItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の会計伝票明細番号に値を設定します。
setCuItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号コードを設定します｡
setCurrencyAmountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目一覧を設定します｡
setData(Map) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。

setData(Map, boolean) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。
setData(Map) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
setData(Map, boolean) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
setDataId(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データIDを設定します。
setDataPropertyHandler(DataPropertyHandler) - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データプロパティハンドラを設定します。
setDataSourceRefName(String) - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
DataSourceへの参照名を設定します。
setDataType(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データタイプを設定します。
setDatabaseAccessor(DatabaseAccessor) - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
データベースアクセッサを設定します。
setDay(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
日を設定します。
setDayWeek(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
曜日を設定します。
setDefaultDate(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト日時を設定します。
setDefaultLocale(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト言語を設定します。
setDefaultLocale(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
デフォルト言語を設定します。
setDefault_value(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
デフォルト値を格納します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
組織コードを設定します。
setDepartmentCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを設定します。
setDepartmentCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを設定します。
setDepartmentCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
組織コードを設定します。
setDepth(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
階層レベルを設定します。
setDepth(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
階層レベルを設定します。
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを設定します｡
setDescription(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ内容を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データの説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
説明を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性dirの値を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
dirを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
dirを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性dirの値を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性dirの値を取得します。
setDisplayName(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニュー表示名を設定する。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名を設定します。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名を設定します。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール表示名を設定します。
setDisplayName(String) - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
表示名を設定します。
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計伝票番号に値を設定します。
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号コードを設定します｡
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会社コードに値を設定します。
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードコードを設定します｡
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票の伝票日付に値を設定します。
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付コードを設定します｡
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票タイプに値を設定します。
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプコードを設定します｡
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計期間に値を設定します。
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間コードを設定します｡
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計年度に値を設定します。
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度コードを設定します｡
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票ヘッダテキストに値を設定します。
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストコードを設定します｡
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダのオブジェクトキーに値を設定します。
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーコードを設定します｡
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの参照処理に値を設定します。
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理コードを設定します｡
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票の転記日付に値を設定します。
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付コードを設定します｡
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの参照伝票番号に値を設定します。
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号コードを設定します｡
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダのユーザ名に値を設定します。
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名コードを設定します｡
setDocumentHeader(DocumentHeader) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダを設定します｡
setDomain(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
ドメインを格納します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス１を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を設定します。
setEmailAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス１を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス２を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を設定します。
setEmailAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス２を設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
エンコーディング情報を設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
エンコーディングの設定。
setEncoding(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインエンコーディングを設定する。
setEncoding(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
エンコーディングを設定します。
setEncoding(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
エンコーディングを設定する。
setEnctype(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性enctypeの値を設定します。
setEndDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
終了日を設定します。
setEndDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
終了日を設定します。
setEndDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
終了日を設定します。
setEndDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
終了日を設定します。
setExpExpList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(export(Export))の一覧を設定します｡
setExpStrList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Export))の一覧を設定します｡
setExpTblList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Export))の一覧を設定します｡
setExtendedBaseModelMap(ExtendedBaseModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
拡張基本モデルマップを設定します。
setExtendedInternationalModelMap(ExtendedInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
拡張国際化モデルマップを設定します。
setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
拡張期間国際化モデルマップを設定します。
setExtendedTerminableModelMap(ExtendedTerminableModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
拡張期間化モデルマップを設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線FAX番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
FAX番号を設定します。
setField(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
フィールドを設定します｡
setFieldList(ArrayList) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
フィールド一覧リストをセットします。
setFill(boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
描画されるグラフの塗りつぶし可否を設定します。
setFilterParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを設定します。
setFlowComponent(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのフローコンポーネント名を設定します。
setFocus(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントとして監視する変数名を指定します。
setFontColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字色を設定します。
setFontSize(int) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字サイズを設定します。
setForm(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
ターゲットとなるフォーム名を設定します。
setFormObjects(Map) - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のメソッド
フォームオブジェクトのマップを設定します。
setFormclass(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性classの値を設定します。
setFrameClass(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
推奨されていません。 このメソッドではなくFrameTag.setFrameclass(String)メソッドを使用してください。
setFrameborder(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameborderを設定します。
setFrameclass(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameClassを設定します。
setFrom(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Fromをセットする。
setFrom(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Fromをセットする。
setGlAccList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目一覧を設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを設定します｡
setGlAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細のソートキーに値を設定します。
setGlAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーコードを設定します｡
setGlBusArea(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の事業領域に値を設定します。
setGlBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域コードを設定します｡
setGlCompCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会社コードに値を設定します。
setGlCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードコードを設定します｡
setGlCostcenter(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の原価センタに値を設定します。
setGlCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタコードを設定します｡
setGlDocType(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の伝票タイプに値を設定します。
setGlDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプコードを設定します｡
setGlFiscYear(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会計年度に値を設定します。
setGlFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度コードを設定します｡
setGlGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の総勘定元帳勘定に値を設定します。
setGlGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定コードを設定します｡
setGlIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を設定します｡
setGlItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の明細テキストに値を設定します。
setGlItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストコードを設定します｡
setGlItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会計伝票明細番号に値を設定します。
setGlItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号コードを設定します｡
setGlList(GlAccList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を設定します｡
setGlOrderid(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の指図番号に値を設定します。
setGlOrderid(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号コードを設定します｡
setGlPstngDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の伝票の転記日付に値を設定します。
setGlPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付コードを設定します｡
setGlRefKey1(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の取引先参照キーに値を設定します。
setGlRefKey1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーコードを設定します｡
setGlTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の消費税コードに値を設定します。
setGlTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードコードを設定します｡
setGlWbsElement(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細のWBS 要素に値を設定します。
setGlWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素コードを設定します｡
setGoOut(boolean) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
外出状態を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphFrameColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ枠の線色を設定します。
setGroup(String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
グループＩＤを設定します。
setHeader(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メールヘッダを設定する。
setHeight(int) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの高さを設定します。
setHelperclass(String) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
クラス名を設定します。
setHoldability(int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。
setHreflang(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
hreflangを設定します。
setId(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを設定します｡
setId(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューIDを設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImagePath(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューイメージパスを設定します。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
setImpExpType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
入力／出力区分を設定します｡
setImpImpList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(import(Import))の一覧を設定します｡
setImpStrList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Import))の一覧を設定します｡
setImpTblList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Import))の一覧を設定します｡
setInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を設定します｡
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.EJBEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - interface jp.co.intra_mart.framework.base.event.EventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setIndex_type(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
インデックスタイプを格納します。
setInformation() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次の遷移先に渡す情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
次の遷移先に渡す情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次の遷移先に渡す情報を設定します。
setInitialUrl(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
初期アクセスURLを設定する。
setInitialize(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントの初期値を指定します。
setInternationalAccessor(InternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
国際化アクセサを設定します。
setInternationalModelMap(InternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
国際化モデルマップを設定します。
setJNDIName(String) - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のメソッド
EJBEventListenerAgentHomeのJNDI名を設定します。
setKey(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージを作成するためのキーを取得します。
setKey(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
keyを設定します。
setLang(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
言語を設定します｡
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性langの値を設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
langを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
langを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性langの値を設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性langの値を設定します。
setLink(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
setLinkClass(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
推奨されていません。 このメソッドではなくLinkTag.setLinkclass(String)メソッドを使用してください。
setLinkclass(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
linkClassを設定します。
setLinkclass(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
linkClassを設定します。
setListener(StandardEventListener) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
イベント処理クラスを設定します。
setListenerName(String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
EJBEventListenerAgentBeanのクラス名を設定します。
setListenerName(String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
EJBEventListenerAgentBeanのクラス名を設定します。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ロケールを設定します。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ロケールの設定。
setLocale(Locale) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインロケールを設定する。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ロケールを設定します。
setLocale(Locale) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ユーザのロケールを設定する。
setLocale(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
localeを設定します。
setLocation(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
遷移先のページパスを設定します。
setLockCount(int) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックするログイン失敗回数を設定します。
setLockDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック日付を設定します。
setLockTerm(int) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックする期間を設定します。
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログメッセージナンバーを設定します｡
setLogNo(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログナンバーを設定します｡
setLoginFailureCount(int) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数を設定します。
setLoginGroup(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログイングループIDを設定する。
setLoginGroupID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログイングループIDを設定する。
setLoginGroupId(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ログイングループIDを設定します。
setLoginTime(Date) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインした時間を設定する。
setLoginType(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインタイプを設定する。
setLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を設定します｡
setLongdesc(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
longdescを設定します。
setMailAddress(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
メールアドレス設定。
setMain(DepartmentMain) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザが主所属する組織を設定します。
setMainPagePatternId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
メインページパターンIDを設定する。
setMainPagePatternImageUrl(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンイメージURLを設定する。
setMainPagePatternUrl(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンURLを設定する。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ領域のマージンを設定します。
setMarginheight(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginheightを設定します。
setMarginwidth(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginwidthを設定します。
setMaxLicense(double) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループ内の最大登録可能ライセンス数を設定します。
setMember(DepartmentAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に人員を割り当てます。
setMember(PrivateGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループに人員を割り当てます。
setMember(PublicGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに人員を割り当てます。
setMenu(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
setMenuId(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
メニューIDを設定します。
setMessage(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
setMessage(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージを設定します｡
setMessage(String) - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のメソッド
検証結果のメッセージを設定します。
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ１を設定します｡
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ２を設定します｡
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ３を設定します｡
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ４を設定します｡
setMethod(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性methodの値を設定します。
setMobileEmailAddress(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯用メールを設定します。
setMobileNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯電話番号を設定します。
setMobileNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を設定します。
setMobileNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を設定します。
setMobileNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯電話番号を設定します。
setMobilePassword(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
モバイル用パスワードを設定します。
setModifiable(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
変更可能の可否を格納します。
setMonth(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
月を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のメソッド
分類区分名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のメソッド
分類名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のメソッド
役職名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel のメソッド
分類区分名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel のメソッド
分類名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
名前を格納します。
setName(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
項目の表示名称のを設定します。
setName(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
項目の表示名称を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を設定します｡
setName(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
イベントトリガ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性nameの値を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性nameを設定します。
setName(String) - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータ名を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを設定します。
setNoresize(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
noresizeを設定します。
setNote(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
マウスポイント時に表示されるポップアップ文字列を設定します。
setNote(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスポイント時に表示されるポップアップ文字列を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
備考を設定します。
setNullable(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
Null受付の可否を格納します。
setNumber(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ナンバーを設定します｡
setNumber(int) - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
ソート番号を設定します。
setOnChange(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
監視している値に変更があった場合に実行するスクリプトを指定します。
setOnClick(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickの値を設定します。
setOnDblClick(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性obDblClickの値を設定します。
setOnKeyDown(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownの値を設定します。
setOnKeyPress(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressの値を設定します。
setOnKeyUp(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpの値を設定します。
setOnMouseDown(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownの値を設定します。
setOnMouseMove(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveの値を設定します。
setOnMouseOut(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutの値を設定します。
setOnMouseOver(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverの値を設定します。
setOnMouseUp(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpの値を設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onblurを設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onblurを設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onBlurを設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性obDblClickの値を設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onfocusを設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onfocusを設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onFocusを設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyDownの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyPressの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyUpの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseDownの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseMoveの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseUpの値を設定します。
setOnreset(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onResetの値を設定します。
setOnsubmit(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onSubmitの値を設定します。
setOption(Option[]) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
選択肢を設定します。
setOption(int, Option) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
選択肢を設定します。
setOwnerCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
所有者コードを設定します。
setOwnerCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
所有者コードを設定します。
setPaAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細のソートキーに値を設定します。
setPaAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーコードを設定します｡
setPaBlineDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の期日計算の支払基準日に値を設定します。
setPaBlineDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日コードを設定します｡
setPaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の総勘定元帳勘定に値を設定します。
setPaGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定コードを設定します｡
setPaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を設定します｡
setPaItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の明細テキストに値を設定します。
setPaItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストコードを設定します｡
setPaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の会計伝票明細番号に値を設定します。
setPaItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号コードを設定します｡
setPaPymtMeth(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の支払方法に値を設定します。
setPaPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を設定します｡
setPaVendorNo(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の仕入先または債権者の勘定コードに値を設定します。
setPaVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードコードを設定します｡
setPagePath(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
実行するページベース開発モデルのページパスを設定します。
setParamName(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ名を設定します｡
setParamType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ属性を設定します｡
setParameter(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
パラメーターを設定します｡
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントへのパラメータを設定します。
setParent(SelectableItem) - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
この選択肢が含まれる選択項目を設定します。
setPasswd(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
パスワードを設定します｡
setPassword(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
パスワードを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
パスワード設定。
setPassword(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインパスワードを設定する。
setPassword(String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
パスワードを設定します。
setPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を設定します｡
setPlugin(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
プラグインIDを設定します。
setPoolName(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
プール名称を設定します｡
setPoolSize(int) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
プール内のコネクション数を設定します｡
setPostCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のメソッド
役職CDを設定します。
setPostCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職コードを設定します。
setPostCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを設定します。
setPostCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを設定します。
setPostCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel のメソッド
役職CDを設定します。
setPrivateGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
グループコードを設定します。
setPrivateGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループコードを設定します。
setProfitCentList(ProfitCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を設定します｡
setProfitCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧を設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを設定します｡
setProgramLanguage(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラム言語の種類を設定します。
setProgramPath(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラムパスを設定します。
setProperties(Map) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
パラメータを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
プロパティを設定します。
setProperty(Properties) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル情報を設定します｡
setPropertyKeyPart(String[]) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティのキーを設定します｡
setPropertyName(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル名を設定します｡
setPropertyValue(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティの値を設定します｡
setPropeties(Properties) - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
プロパティを設定します｡
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
グループセットコードを設定します。
setReadOnly(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。
setReceive(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントから値を受け取る変数名を指定します。
setRecordList(ArrayList) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
レコード一覧リストをセットします。
setRecordNo(int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
レコード番号を設定します｡
setRel(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを設定します。
setReplyTo(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 リプライをセットする。
setReplyTo(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 リプライをセットする。
setRequest(HttpServletRequest) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
リクエストを設定します。
setRequired(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
フォーカスの要求の有無を格納します。
setResponse(HttpServletResponse) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
レスポンスを設定します。
setResult(ServiceResult) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービス処理結果を設定します。
setRev(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを設定します。
setRole(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
setRoleId(String) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロールIDを設定します。
setRoleId(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールIDを設定します。
setRoleName(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール名を設定します。
setRoleValidEndDate(Date) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効終了日を設定します。
setRoleValidStartDate(Date) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効開始日を設定します。
setRow(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
行番号を設定します｡
setRunDay(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行日を設定します。
setRunDayWeek(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行曜日を設定します。
setRunHour(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行時を設定します。
setRunMinute(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行分を設定します。
setRunMonth(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行月を設定します。
setRunSecond(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行秒を設定します。
setRunYear(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行年を設定します。
setSavepoint() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
setSavepoint(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
setScalePosition(String) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛りの表示位置を設定します。
setSchedule(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
setScrolling(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
scrollingを設定します。
setSecurityExt(String) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 セキュリティの拡張子を設定します。
setSelected(Option[]) - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
選択済みである選択肢を設定します。
setSelected(int, Option) - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
選択済みである選択肢を設定します。
setSelected(Option) - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem のメソッド
選択済の選択肢を設定します。
setServerType(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
サーバタイプを設定します｡
setService(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのサービスＩＤを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性serviceの値を設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
serviceを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
serviceを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
サービスを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性serviceの値を設定します。
setServiceManager(ServiceManager) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスマネージャを設定します。
setSessionContext(SessionContext) - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
関連するSessionContextを設定します。
setShape(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
shapeを設定します。
setShape(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
shapeを設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を設定します｡
setSize(int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点のサイズを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ソートキーを設定します。
setSortNumber(int) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
ソート番号を設定します。
setSortNumber(int) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ソート番号を設定します。
setSorucePovider(SystemSourceProvider) - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
ソースプロバイダを設定します。
setSourceProvider(DataSourceProvider) - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
ソースプロバイダを設定します。
setStartDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
開始日を設定します。
setStartDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
開始日を設定します。
setStartDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
開始日を設定します。
setStartDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
開始日を設定します。
setStartPoint(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフローのスタートポイント名を設定します。
setStroke(Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
描画される線の描画属性を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性styleの値を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性styleの値を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性styleの値を設定します。
setSubPanelViewObjects(Map) - class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject のメソッド
サブパネルに対応するPanelBasedViewObjectを設定します。
setSubject(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを設定します。
setSubject(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 タイトルをセットする。
setSubmitclass(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性classの値を設定します。
setSysnr(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
システム番号を設定します｡
setSystem(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
システムを設定します｡
setTaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の総勘定元帳勘定に値を設定します。
setTaGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定コードを設定します｡
setTaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を設定します｡
setTaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の会計伝票明細番号に値を設定します。
setTaItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号コードを設定します｡
setTaTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の消費税コードに値を設定します。
setTaTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードコードを設定します｡
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
tabindexを設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
tabindexを設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
tabindexを設定します。
setTagClass(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性classの値を設定します。
setTagWriter(TagWriter) - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
TagWriterを設定します。
setTarget(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性targetの値を設定します。
setTarget(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
targetを設定します。
setTelNo(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
電話番号設定。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
電話番号を設定します。
setTerminableAccessor(TerminableAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間化アクセサを設定します。
setTerminableInternationalAccessor(TerminableInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
期間国際化アクセサを設定します。
setTerminableInternationalModelMap(TerminableInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間国際化モデルマップを設定します。
setTerminableModelMap(TerminableModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
期間化モデルマップを設定します。
setText(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を設定します。
setThrowablePrintListener(ThrowablePrintListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定の例外出力リスナを割り当て直します。
setTimeoutCheckPeriod(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションのタイムアウトのチェック間隔を設定します｡
setTimer(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）

setTimer(int) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントの監視間隔を設定します。
setTimes(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
第ｎ～曜日を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性titleの値を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性titleの値を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性titleの値を設定します。
setTo(String) - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
setTo(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 To(宛先)をセットする。
setTo(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 To(宛先)をセットする。
setTransactionIsolation(int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 トランザクション遮断レベルを指定されたものに変更することを試みます。
setType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
タイプを設定します｡
setType(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ノードのタイプを設定します。
setType(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
typeを設定します。
setTypeMap(Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続の型マップとして指定された型マップをインストールします。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
ログインユーザIDを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを設定します。
setUrl(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを設定します。
setUrl(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬを設定する。
setUrl(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
URLを設定します。
setUrlSignature(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬ署名を設定する。
setUser(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
ユーザを設定します｡
setUser(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインユーザIDを設定する。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザコードを設定します。
setUserID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインユーザIDを設定する。
setUserId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
ログインユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ユーザID設定。
setUserId(String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
ログインユーザIDを設定します。
setValidEndDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効終了日を設定します。
setValidEndYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効終了年を設定します。
setValidStartDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効開始日を設定します。
setValidStartYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効開始年を設定します。
setValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を設定します｡
setValidate(boolean) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチの有効・無効を設定します。
setValidationExceptionDetails(Collection) - class jp.co.intra_mart.framework.presentation.validator.ValidationException のメソッド
検証結果の詳細を設定します。
setValue(Object) - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性valueを設定します。
setValue(String) - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
値を設定します。
setValue(String) - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータの値を設定します。
setValues(String[]) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージで使用する置換用の文字列を設定します。
setVersionCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
バージョンコードを設定します。
setVersionCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
バージョンコードを設定します。
setViewInfo(Object) - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のメソッド
表示情報を設定します。
setWaitTime(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクション取得の待機時間を設定します｡
setWeek(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
第ｎ週目を設定します。
setWidth(int) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの幅を設定します。
setYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
年を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を設定します。
setZipCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を設定します。
setZipCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
郵便番号を設定します。
shutdown() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
このプロセスを終了します。
shutdown(int) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
このプロセスを終了します。
size() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
このオブジェクトの管理するモニターの数を取得します。
size() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードが持つ子ノードの数を返します。
size() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが持つ子ノードの数を返します。
size() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 このオブジェクトの管理するモニターの数を取得します。
skip(long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
指定のバイト数だけ入力をスキップします。
sort(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたコンパレータに従って、子ノードをソートします。
sortAll(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。
sourceName() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
ソース名称の取得。
sourceName() - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のメソッド
スクリプトのファイルパス名を返します。
start() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの開始通知。
startAutomaticExecution(long) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
startElement(String, String, String, Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
DefaultHandlerのabstractメソッドをオーバーライドします。
stop() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの停止通知。
stopAutomaticExecution() - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
stringToDate(String) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
データベース登録用文字列からjava.util.Dateを取得します。
stringToDate(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベース登録用文字列からjava.util.Dateを取得します。
stringToDate(String) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを取得します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを取得します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを取得します。
subMap(String[]) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを取得します。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subtract(Term[], Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。

T

TELEPHONE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
電話番号
TELEPHONE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
電話番号
TOKEN_ATTRIBUTE - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
HttpServletRequestにおける次の画面のトークンの保存先
TYPE_CONFIG - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
名称（データタイプの定数）。
TYPE_DATA_SOURCE - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_DB - class jp.co.intra_mart.framework.system.log.IntramartLogAgent の static 変数
データベースログに出力する場合のカテゴリの種類
TYPE_DEBUG - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
デバッグレベル。
TYPE_DEBUG - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 デバッグレベル。
TYPE_ERROR - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
エラーレベル。
TYPE_ERROR - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 エラーレベル。
TYPE_GROUP - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_HOLIDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
休日（データタイプの定数）。
TYPE_JDBC - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_NATIONAL_HOLDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
祝祭日（データタイプの定数）。
TYPE_REPORT - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
通常の情報レベル。
TYPE_REPORT - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 通常の情報レベル。
TYPE_SYSTEM - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_WARNING - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
警告レベル。
TYPE_WARNING - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 警告レベル。
TYPE_WEEKDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
非休日（データタイプの定数）。
Table - interface jp.co.intra_mart.foundation.datastore.common.config.Table.
テーブルを定義します。
TagWriter - class jp.co.intra_mart.framework.base.web.tag.TagWriter.
タグの出力を行います。
TagWriter(JspWriter) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のコンストラクタ
TagWriterを新規に生成します。
TemporaryDirectory - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory.
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。
TemporaryFile - class jp.co.intra_mart.foundation.service.provider.TemporaryFile.
このクラスは、一時ファイルに関する機能を提供します。
TemporaryFile() - class jp.co.intra_mart.foundation.service.provider.TemporaryFile のコンストラクタ
一時ファイルのパスを作成します。
Term - class jp.co.intra_mart.foundation.datastore.common.structure.Term.
有効期間を表します。
Term() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間、終了時間とも指定されていない有効期間を生成します。
Term(Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間のみが指定された有効期間を生成します。
Term(Date, Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間と終了時間がともに指定された有効期間を生成します。
TermManager - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager.
期間 Term を取り扱うマネージャクラスです。
TermManagerException - exception jp.co.intra_mart.foundation.datastore.exception.TermManagerException.
期間に関する例外クラス

TermManagerException() - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(String) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TerminableAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor.
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap.
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor.
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap.
期間国際化アクセサのマッピング情報を持ちます。
TerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel.
期間国際化モデルを定義します。
TerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel.
期間国際化モデルの情報です。
TerminableInternationalModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext.
期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap.
期間国際化モデルのマッピング情報を持ちます。
TerminableInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable.
期間国際化テーブルを定義します。
TerminableKey - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey.
期間化基準項目を定義します。
TerminableModel - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel.
期間化モデルを定義します。
TerminableModel - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel.
期間化モデルの情報です。
TerminableModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext.
期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap.
期間化モデルのマッピング情報を持ちます。
TerminableTable - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable.
期間化テーブルを定義します。
TextFileDataPropertyHandler - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のコンストラクタ
TextFileDataPropertyHandlerを新規に生成します。
TextFileEventPropertyHandler - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のコンストラクタ
TextFileEventPropertyHandlerを新規に生成します。
TextFileMessagePropertyHandler - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler.
指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。
TextFileMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のコンストラクタ

TextFileServicePropertyHandler - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のコンストラクタ
TextFileServicePropertyHandlerを新規に生成します。
ThreadStopListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThreadStopListener - interface jp.co.intra_mart.foundation.utility.ThreadStopListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。
ThrowablePrintListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener.
このインタフェースは、例外情報を出力するためのものです。
TokenInvalidException - exception jp.co.intra_mart.framework.presentation.TokenInvalidException.
トークンが不正な場合に発生する例外です。
TokenInvalidException() - class jp.co.intra_mart.framework.presentation.TokenInvalidException のコンストラクタ
詳細メッセージを指定しないで TokenInvalidException を構築します。
TokenInvalidException(String) - class jp.co.intra_mart.framework.presentation.TokenInvalidException のコンストラクタ
指定された詳細メッセージを持つ TokenInvalidException を構築します。
TokenInvalidException(String, Throwable) - class jp.co.intra_mart.framework.presentation.TokenInvalidException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TokenInvalidException を構築します。
Transition - class jp.co.intra_mart.framework.base.service.Transition.
画面遷移に関連するクラスのインタフェースです。
Transition() - class jp.co.intra_mart.framework.base.service.Transition のコンストラクタ
Transitionを新規に生成します。
TransitionException - exception jp.co.intra_mart.framework.base.service.TransitionException.
トランジションに関連する例外です。
TransitionException() - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
詳細メッセージを指定しないで TransitionException を構築します。
TransitionException(String) - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
指定された詳細メッセージを持つ TransitionException を構築します。
TransitionException(String, Throwable) - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。
TreasureDirectory - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory.
情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile.
情報データベースのファイルを操作するためのインターフェースを定義します。
TreeBranch - class jp.co.intra_mart.foundation.page.TreeBranch.
ツリービュー内の「フォルダ」をあらわすクラスです。
TreeBranch() - class jp.co.intra_mart.foundation.page.TreeBranch のコンストラクタ
新しいTreeBranchオブジェクトを生成します。
TreeBranch(Comparator) - class jp.co.intra_mart.foundation.page.TreeBranch のコンストラクタ
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。
TreeLeaf - class jp.co.intra_mart.foundation.page.TreeLeaf.
ツリービュー内の「ページ」をあらわすクラスです。
TreeLeaf() - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成します。
TreeLeaf(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。
TreeLeaf(String, String) - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。
TreeNode - interface jp.co.intra_mart.foundation.page.TreeNode.
ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer - interface jp.co.intra_mart.foundation.page.TreeNodeContainer.
子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider - interface jp.co.intra_mart.foundation.page.TreeNodeProvider.
ツリービューの「ホーム」をあらわすインターフェースです。
TreeRoot - class jp.co.intra_mart.foundation.page.TreeRoot.
ツリービュー内の「ホーム」をあらわすクラスです。
TreeRoot() - class jp.co.intra_mart.foundation.page.TreeRoot のコンストラクタ
新しいTreeRootオブジェクトを生成します。
TreeRoot(Comparator) - class jp.co.intra_mart.foundation.page.TreeRoot のコンストラクタ
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。
TrimmedFilterReader - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader.
このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。
TrimmedFilterReader(Reader) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のコンストラクタ
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。
TrimmedFilterWriter - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter.
このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。
TrimmedFilterWriter(Writer) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のコンストラクタ
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。
temporaryDirectory() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。
toIANAName(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の static メソッド
指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
toJDKName(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の static メソッド
指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
toString() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
オブジェクトの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
オブジェクトを文字列に変換します。
toString() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
このオブジェクトの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
デバッグ用のメソッドです。
toString() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の文字列表現を取得します。
toString() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトの文字列表現を返します。
toXML() - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
toXMLNode() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
このインスタンスのXMLノードとしての文字列を返します。
toXMLNode() - interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF のメソッド
保持しているデータをXMLノードの文字列に変換します。
total() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターを利用中、または利用しようとしているスレッドの数です。
total() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターを利用中、または利用しようとしているスレッドの数です。
totalMemory() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバプロセスの Java Virtual Machine のメモリの総容量を返します。
transaction() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスのトランザクションを開始する

トランザクションを開始させる。
transfer() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次のページに遷移します。
transfer() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
ページベースの画面に遷移します。
transfer() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次のページに遷移します。

U

UNAVALIABLE_LOGIN_USER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ログイン出来ないアカウントを表す定数
URL - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
URL
URL - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
URL
URLAccessFilter - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter.
URLアクセスフィルタ。
URLAccessFilter() - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のコンストラクタ

URLBuilder - class jp.co.intra_mart.jssp.net.URLBuilder.
ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。
URLBuilder(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.jssp.net.URLBuilder のコンストラクタ
新しいビルダを作成します。
URLDecodeInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream.
このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
URLDecodeInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のコンストラクタ
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
URLDecodeInputStream - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
URLDecodeInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のコンストラクタ
推奨されていません。 指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
URLDecodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream.
このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
URLDecodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のコンストラクタ
指定された OutputStream に書き込む URLデコーダーを作成します。
URLDecodeOutputStream - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
URLDecodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
URLEncodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream.
このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
URLEncodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64デコーダーを作成します。
URLEncodeOutputStream - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
URLEncodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
URLUtil - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.
URL関連のユーティリティクラス。
URLUtil() - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil のコンストラクタ

USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザコード
UnauthorizedException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException.
リクエストを受け付けるためには認証が必要であることを通知するための例外です。
UnauthorizedException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
指定のメッセージを持つ例外を作成します。
UnauthorizedException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
UnauthorizedException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
例外を作成します。
UnlimitedBufferedOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream.
出力データを一時的にバッファリングする出力ストリームの実装です。
UnlimitedBufferedOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のコンストラクタ
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。
UnripeQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException.
クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。
UnripeQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
UnripeQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
UnripeQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
例外を作成します。
UnsupportedNetworkConnectException - exception jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
UnsupportedNetworkConnectException() - class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException のコンストラクタ
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String) - class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException のコンストラクタ
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException - exception jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。
UnsupportedNetworkConnectException() - class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException のコンストラクタ
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String) - class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException のコンストラクタ
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UpdateInfo - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo.
エンティティの更新情報です。
User - class jp.co.intra_mart.foundation.datastore.application.domain.user.User.
ユーザの基本属性のデータを取り扱います。
User() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ

UserBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel.
ユーザの基本モデルです。
UserCertification - interface jp.co.intra_mart.foundation.security.certification.UserCertification.
ユーザログイン認証インタフェース。
UserCertificationServlet - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet.
ユーザ認証サーブレット。
UserCertificationServlet() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のコンストラクタ

UserChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener.
ユーザに関する情報の変更時のリスナーです。
UserImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter.
ユーザインポーターのインタフェースです。
UserInfo - interface jp.co.intra_mart.framework.base.util.UserInfo.
ログインユーザの情報を管理します。
UserInfoException - exception jp.co.intra_mart.framework.base.util.UserInfoException.
ユーザ情報に関連する例外です。
UserInfoException() - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
詳細メッセージを指定しないで UserInfoException を構築します。
UserInfoException(String) - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
指定された詳細メッセージを持つ UserInfoException を構築します。
UserInfoException(String, Throwable) - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。
UserInfoUtil - class jp.co.intra_mart.framework.base.util.UserInfoUtil.
ログインユーザの情報に関するユーティリティクラスです。
UserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet.
ユーザ初期アクセスサーブレット。
UserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のコンストラクタ

UserManager - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager.
ユーザに関連する情報を管理します。
UserManager() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のコンストラクタ

UserMapper - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper.
ユーザに関連するマッパです。
UserPageProvider - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider.
ユーザページプロバイダインタフェース。
UserTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable.
ユーザの期間化属性のデータを取り扱います。
UserTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のコンストラクタ

UserTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational.
ユーザの期間国際化属性のデータを取り扱います。
UserTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のコンストラクタ

UserTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel.
ユーザの期間国際化モデルです。
UserTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel.
ユーザの期間化モデルです。
unlockSession(String) - class jp.co.intra_mart.framework.presentation.PresentationManager のメソッド
セッションのロックを解除します。
update(String, String, Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを更新するメソッド

データベースのデータを更新(アップデート)する。
update(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数更新します。
update(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数更新します。
update(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数更新します。
update(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数更新します。
update(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数更新します。
update(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数更新します。
update(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数更新します。
update(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数更新します。
update(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数更新します。
update(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数更新します。
update(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数更新します。
update(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数更新します。
update(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数更新します。
update(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数更新します。
update(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数更新します。
update(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数更新します。
update(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数更新します。
update(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数更新します。
update(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数更新します。
update(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ更新します。
update(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを複数更新します。
updateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を更新する。
updateAccount(Account) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを更新します。
updateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を更新する。
updateAccountRole(String, AccountRole) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを更新します。
updateBatch(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を更新します。
updateBatch(Batch) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を更新します。
updateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを更新します。
updateCalendarInfo(String, CalendarInfo) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを更新します。
updateCategory(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリを更新する。
updateCategoryDetail(Map) - class jp.co.intra_mart.foundation.appcomn.Category のメソッド
推奨されていません。 CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
updateCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済の分類区分詳細を更新します。
updateData(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
updateData(Map, String[]) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
updateDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織情報を更新します。
updateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を更新する。
updateFavoriteMenu(String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを更新します。
updateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを更新します。
updateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ情報を更新します。
updateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを更新します。
updateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを更新します。
updateMenuItem(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを更新します。
updateMenuItem(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを更新します。
updatePost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の役職情報を更新します。
updatePostData(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
updatePrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループ情報を更新します。
updateProfile(Map) - class jp.co.intra_mart.foundation.appcomn.Profile のメソッド
推奨されていません。 UserManager.updateUser(User user) に置き換えられました。
updatePublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループ情報を更新します。
updateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を更新する。
updateRole(Role) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を更新します。
updateSuperUser(SuperUser) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を更新します。
updateSuperUser(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を更新します。
updateSuperUser(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を更新します。
updateSuperUser(String, SuperUser) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を更新します。
updateUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを更新します。
updateVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンを更新します。
updateVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンを更新します。
usableConnection() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
現在待機中のコネクションをです。
usableConnection() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
現在待機中のコネクションをです。
usableConnection() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 現在待機中のコネクションをです。
usableConnection() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 現在待機中のコネクションをです。
useConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションを生成します。
userAdded(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアに登録された後に呼び出されます。
userDeleted(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアから削除された後に呼び出されます。
userUpdated(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアに対して更新された後に呼び出されます。

V

VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
バージョンコード
ValidationException - exception jp.co.intra_mart.framework.presentation.validator.ValidationException.
検証結果が不正であるときの例外です。
ValidationException() - class jp.co.intra_mart.framework.presentation.validator.ValidationException のコンストラクタ
詳細メッセージを指定しないで ValidationException を構築します。
ValidationException(String) - class jp.co.intra_mart.framework.presentation.validator.ValidationException のコンストラクタ
指定された詳細メッセージを持つ ValidationException を構築します。
ValidationException(String, Throwable) - class jp.co.intra_mart.framework.presentation.validator.ValidationException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
ValidationExceptionDetail - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail.
検証結果の詳細情報です。
ValidationExceptionDetail() - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のコンストラクタ
メッセージなしのValidatorExceptionDetailを生成します。
ValidationExceptionDetail(String) - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のコンストラクタ
メッセージ付きのValidatorExceptionDetailを生成します。
Validator - interface jp.co.intra_mart.framework.presentation.validator.Validator.
リクエスト内容の検証をします。
ValidatorConfig - interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig.
Validatorの初期化情報です。
ValidatorException - exception jp.co.intra_mart.framework.presentation.validator.ValidatorException.
Validatorに関連する例外です。
ValidatorException() - class jp.co.intra_mart.framework.presentation.validator.ValidatorException のコンストラクタ
詳細メッセージを指定しないで ValidatorException を構築します。
ValidatorException(String) - class jp.co.intra_mart.framework.presentation.validator.ValidatorException のコンストラクタ
指定された詳細メッセージを持つ ValidatorException を構築します。
ValidatorException(String, Throwable) - class jp.co.intra_mart.framework.presentation.validator.ValidatorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。
VariableScope - interface jp.co.intra_mart.foundation.scenario.VariableScope.
スクリプトのスコープを表すオブジェクトです。
ViewConverter - interface jp.co.intra_mart.framework.presentation.view.ViewConverter.
出力情報をビューオブジェクトに変換します。
ViewConverterConfig - interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig.
ViewConverterの初期化情報です。
ViewConverterException - exception jp.co.intra_mart.framework.presentation.view.ViewConverterException.
ViewConverterに関連する例外です。
ViewConverterException() - class jp.co.intra_mart.framework.presentation.view.ViewConverterException のコンストラクタ
詳細メッセージを指定しないで ViewConverterException を構築します。
ViewConverterException(String) - class jp.co.intra_mart.framework.presentation.view.ViewConverterException のコンストラクタ
指定された詳細メッセージを持つ ViewConverterException を構築します。
ViewConverterException(String, Throwable) - class jp.co.intra_mart.framework.presentation.view.ViewConverterException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ViewConverterException を構築します。
ViewObject - interface jp.co.intra_mart.framework.presentation.view.ViewObject.
ビューオブジェクトのインタフェースです。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox のメソッド
カレンダーデータが有効かどうか検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.presentation.validator.FormatValidator のメソッド
文字列の不正文字（フォーマット）を検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.presentation.validator.LengthValidator のメソッド
文字列の長さを検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator のメソッド
数値の範囲を検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.presentation.validator.NumericValidator のメソッド
数値の検証をします。
validate(RequestInfo) - interface jp.co.intra_mart.framework.presentation.validator.Validator のメソッド
リクエスト内容の検証をします。
validateTerm(Date, Date) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
指定された2つの日時が有効な期間を構成するかどうか調べます。
validateTerms(Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
指定された期間配列が有効かどうかを調べます。
versionAdded(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionDeleted(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionUpdated(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

W

WebApplicationHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler.
フレームワークを実行するためのイベントハンドラの抽象実装です。
WebApplicationHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
指定されたバイトを書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
単一文字を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
文字列の一部を基礎ストリームに書き込みます。
write(String, int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
文字列の一部を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
指定のバイトを出力します。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
b.length バイトのデータを出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定のメッセージを標準エラー出力および指定の出力先に書き出します。
write(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定のメッセージを標準エラー出力および指定の出力先に書き出します。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
指定のメッセージを標準出力および指定の出力先に書き出します。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
単一の文字を書き込みます。
write(String, int, int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
文字列の一部を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
基礎ストリームに文字を出力します。
write(byte) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(byte[]) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(byte[], int, int) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにテキストを出力します。
write(String, Throwable) - interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter のメソッド
メッセージをログに書き込みます。
write(String) - interface jp.co.intra_mart.foundation.service.provider.SystemReporter のメソッド
メッセージをログに書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 単一の文字を書き込みます。
write(String, int, int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 文字列の一部を書き込みます。
write(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(byte[]) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 指定されたバイトを書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 単一文字を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 文字列の一部を基礎ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 基礎ストリームに文字を出力します。
writeBoolean(boolean) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
boolean 型データの送信。
writeBoolean(boolean) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 boolean 型データの送信。
writeInt(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
int 型データの送信。
writeInt(int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 int 型データの送信。
writeLong(long) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
long 型データの送信。
writeLong(long) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 long 型データの送信。
writeObject(Object) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
オブジェクトの送信。
writeObject(Object) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 オブジェクトの送信。
writeString(String) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
文字列の送信。
writeString(String) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 文字列の送信。

X

XMLProperties - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties.
XML をベースとした不変のプロパティセットを表します。
XMLProperties(File) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream, Properties) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource, Properties) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XORInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream.
このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
XORInputStream(InputStream, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のコンストラクタ
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
XORInputStream - class jp.co.intra_mart.foundation.utility.io.XORInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
XORInputStream(InputStream, int) - class jp.co.intra_mart.foundation.utility.io.XORInputStream のコンストラクタ
推奨されていません。 指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
XOROutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream.
このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
XOROutputStream(OutputStream, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のコンストラクタ
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
XOROutputStream - class jp.co.intra_mart.foundation.utility.io.XOROutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。
XOROutputStream(OutputStream, int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
XmlDataPropertyHandler - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler.
XMLのデータプロパティハンドラです。
XmlDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のコンストラクタ
コンストラクタです。
XmlEventPropertyHandler - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler.
XMLのEventPropertyHandlerです。
XmlEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のコンストラクタ
DefaultEventPropertyHandlerを新規に生成します。
XmlLogPropertyHandler - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler.
リソースからログプロパティ情報を取得するプロパティハンドラです。
XmlLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のコンストラクタ
XMLLogPropertyHandlerを新規に生成します。
XmlPropertyManager - class jp.co.intra_mart.framework.system.property.XmlPropertyManager.
xmlのプロパティマネージャです。
XmlPropertyManager() - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のコンストラクタ
コンストラクタです。
XmlServicePropertyHandler - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.
サービスの設定情報に接続するプロパティハンドラです。
XmlServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のコンストラクタ
XmlServicePropertyHandlerを新規に生成します。
XmlSessionPropertyHandler - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.
セッションに関連するXMLのプロパティハンドラです。
XmlSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のコンストラクタ

Z

ZIP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
郵便番号
ZIP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
郵便番号
A B C D E F G H I J K L M N O P Q R S T U V W X Z

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart(R)
5.0

前 次

フレームあり フレームなし


5.0 J2EE-Base Programing Model API Specifications

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (5.0 J2EE-Base Programing Model API Specifications)

すべてのクラス

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io
jp.co.intra_mart.common.aid.jdk.java.io.file
jp.co.intra_mart.common.aid.jdk.java.lang
jp.co.intra_mart.common.aid.jdk.java.net
jp.co.intra_mart.common.aid.jdk.java.util
jp.co.intra_mart.common.aid.jdk.javax.xml
jp.co.intra_mart.common.aid.jdk.org.w3c.dom
jp.co.intra_mart.common.aid.jdk.util
jp.co.intra_mart.common.aid.jdk.util.charset
jp.co.intra_mart.common.aid.jdk.util.report
jp.co.intra_mart.common.aid.jsdk.javax.servlet
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
jp.co.intra_mart.common.aid.jsdk.utility
jp.co.intra_mart.common.platform.util
jp.co.intra_mart.common.platform.vm
jp.co.intra_mart.foundation.acssecurity
jp.co.intra_mart.foundation.appcomn
jp.co.intra_mart.foundation.commons.validation
jp.co.intra_mart.foundation.database
jp.co.intra_mart.foundation.database.exception
jp.co.intra_mart.foundation.datastore.application.domain.category
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
jp.co.intra_mart.foundation.datastore.application.domain.category.detail
jp.co.intra_mart.foundation.datastore.application.domain.company
jp.co.intra_mart.foundation.datastore.application.domain.company.attach
jp.co.intra_mart.foundation.datastore.application.domain.company.category
jp.co.intra_mart.foundation.datastore.application.domain.company.company
jp.co.intra_mart.foundation.datastore.application.domain.company.department
jp.co.intra_mart.foundation.datastore.application.domain.company.main
jp.co.intra_mart.foundation.datastore.application.domain.company.post
jp.co.intra_mart.foundation.datastore.application.domain.company.version
jp.co.intra_mart.foundation.datastore.application.domain.private_group
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
jp.co.intra_mart.foundation.datastore.application.domain.public_group
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
jp.co.intra_mart.foundation.datastore.application.domain.user
jp.co.intra_mart.foundation.datastore.application.model.category.category_class
jp.co.intra_mart.foundation.datastore.application.model.category.detail
jp.co.intra_mart.foundation.datastore.application.model.company.attach
jp.co.intra_mart.foundation.datastore.application.model.company.category
jp.co.intra_mart.foundation.datastore.application.model.company.company
jp.co.intra_mart.foundation.datastore.application.model.company.department
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
jp.co.intra_mart.foundation.datastore.application.model.company.main
jp.co.intra_mart.foundation.datastore.application.model.company.post
jp.co.intra_mart.foundation.datastore.application.model.company.version
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
jp.co.intra_mart.foundation.datastore.application.model.private_group.group
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
jp.co.intra_mart.foundation.datastore.application.model.public_group.category
jp.co.intra_mart.foundation.datastore.application.model.public_group.group
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
jp.co.intra_mart.foundation.datastore.application.model.public_group.set
jp.co.intra_mart.foundation.datastore.application.model.public_group.version
jp.co.intra_mart.foundation.datastore.application.model.user
jp.co.intra_mart.foundation.datastore.common.accessor
jp.co.intra_mart.foundation.datastore.common.config
jp.co.intra_mart.foundation.datastore.common.model
jp.co.intra_mart.foundation.datastore.common.structure
jp.co.intra_mart.foundation.datastore.exception
jp.co.intra_mart.foundation.drawer
jp.co.intra_mart.foundation.exception
jp.co.intra_mart.foundation.graph
jp.co.intra_mart.foundation.http
jp.co.intra_mart.foundation.im_curl
jp.co.intra_mart.foundation.mail
jp.co.intra_mart.foundation.mail.javamail
jp.co.intra_mart.foundation.mail.javamail.property
jp.co.intra_mart.foundation.page
jp.co.intra_mart.foundation.sap.common.auth
jp.co.intra_mart.foundation.sap.common.auth.exception
jp.co.intra_mart.foundation.sap.common.general_purpose
jp.co.intra_mart.foundation.sap.common.general_purpose.exception
jp.co.intra_mart.foundation.sap.common.util.data
jp.co.intra_mart.foundation.sap.common.util.date
jp.co.intra_mart.foundation.sap.common.util.file
jp.co.intra_mart.foundation.sap.module.accounting
jp.co.intra_mart.foundation.sap.module.accounting.exception
jp.co.intra_mart.foundation.scenario
jp.co.intra_mart.foundation.security
jp.co.intra_mart.foundation.security.account
jp.co.intra_mart.foundation.security.admin
jp.co.intra_mart.foundation.security.batch
jp.co.intra_mart.foundation.security.calendar
jp.co.intra_mart.foundation.security.certification
jp.co.intra_mart.foundation.security.cryption
jp.co.intra_mart.foundation.security.exception
jp.co.intra_mart.foundation.security.filter
jp.co.intra_mart.foundation.security.group
jp.co.intra_mart.foundation.security.license
jp.co.intra_mart.foundation.security.menu
jp.co.intra_mart.foundation.security.message
jp.co.intra_mart.foundation.security.permission
jp.co.intra_mart.foundation.security.role
jp.co.intra_mart.foundation.security.servlet
jp.co.intra_mart.foundation.service.client
jp.co.intra_mart.foundation.service.client.application
jp.co.intra_mart.foundation.service.client.application.content
jp.co.intra_mart.foundation.service.client.batch
jp.co.intra_mart.foundation.service.client.file
jp.co.intra_mart.foundation.service.client.information
jp.co.intra_mart.foundation.service.client.manager
jp.co.intra_mart.foundation.service.provider
jp.co.intra_mart.foundation.service.provider.application
jp.co.intra_mart.foundation.service.provider.batch
jp.co.intra_mart.foundation.service.provider.file
jp.co.intra_mart.foundation.service.provider.information
jp.co.intra_mart.foundation.smtp
jp.co.intra_mart.foundation.utility
jp.co.intra_mart.foundation.utility.charset
jp.co.intra_mart.foundation.utility.file
jp.co.intra_mart.foundation.utility.io
jp.co.intra_mart.foundation.utility.net
jp.co.intra_mart.foundation.utility.report
jp.co.intra_mart.framework.base.data
jp.co.intra_mart.framework.base.event
jp.co.intra_mart.framework.base.message
jp.co.intra_mart.framework.base.service
jp.co.intra_mart.framework.base.session
jp.co.intra_mart.framework.base.util
jp.co.intra_mart.framework.base.web.bean
jp.co.intra_mart.framework.base.web.tag
jp.co.intra_mart.framework.base.web.tag.attribute
jp.co.intra_mart.framework.base.web.util
jp.co.intra_mart.framework.extension.common.util
jp.co.intra_mart.framework.extension.struts.action
jp.co.intra_mart.framework.presentation
jp.co.intra_mart.framework.presentation.controller
jp.co.intra_mart.framework.presentation.forward
jp.co.intra_mart.framework.presentation.service
jp.co.intra_mart.framework.presentation.validator
jp.co.intra_mart.framework.presentation.view
jp.co.intra_mart.framework.system.exception
jp.co.intra_mart.framework.system.log
jp.co.intra_mart.framework.system.message
jp.co.intra_mart.framework.system.property
jp.co.intra_mart.jssp.net


概要 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

intra-mart(R) 5.0 J2EE-Base Programing Model API Specifications

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.lang | このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.common.aid.jdk.java.util | このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet | このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception | このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.utility | このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.platform.util | このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。
jp.co.intra_mart.common.platform.vm | このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。
jp.co.intra_mart.foundation.acssecurity | アクセスセキュリティモジュールを利用するためのクラスを提供します。
jp.co.intra_mart.foundation.appcomn | アプリケーション共通モジュール。
jp.co.intra_mart.foundation.commons.validation | このパッケージは、入力チェック関数ライブラリを提供します。
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.database.exception | データベースＳＱＬ例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class | 分類区分情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail | 分類詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.version | バーション情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach | プライベートグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version | パブリックグループバージョン情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.drawer | 画像ファイル出力用クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.graph | グラフ描画に関するクラスを提供します。
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.im_curl | intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.property |
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth.exception | ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.date | ＳＡＰ連携にて使用する日付操作クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携会計系例外クラスを提供します。
jp.co.intra_mart.foundation.scenario | ページベース開発モデルのプログラムと連携するＡＰＩ。
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.cryption | 暗号化に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.filter | アクセスセキュリティのフィルタに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.servlet | サーブレットに関連するクラスを提供します。
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.batch | このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.smtp | メール連携モジュール。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.foundation.utility.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute | タグ属性のパッケージです。
jp.co.intra_mart.framework.base.web.util | Web上で使用するユーティリティのパッケージです。
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。
jp.co.intra_mart.jssp.net |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.common.aid.jdk.java.io, jp.co.intra_mart.common.aid.jdk.java.io.file, jp.co.intra_mart.common.aid.jdk.java.lang, jp.co.intra_mart.common.aid.jdk.java.net, jp.co.intra_mart.common.aid.jdk.java.util, jp.co.intra_mart.common.aid.jdk.javax.xml, jp.co.intra_mart.common.aid.jdk.org.w3c.dom, jp.co.intra_mart.common.aid.jdk.util, jp.co.intra_mart.common.aid.jdk.util.charset, jp.co.intra_mart.common.aid.jdk.util.report, jp.co.intra_mart.common.aid.jsdk.javax.servlet, jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception, jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter, jp.co.intra_mart.common.aid.jsdk.javax.servlet.http, jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session, jp.co.intra_mart.common.aid.jsdk.utility, jp.co.intra_mart.common.platform.util, jp.co.intra_mart.common.platform.vm, jp.co.intra_mart.foundation.acssecurity, jp.co.intra_mart.foundation.appcomn, jp.co.intra_mart.foundation.commons.validation, jp.co.intra_mart.foundation.database, jp.co.intra_mart.foundation.database.exception, jp.co.intra_mart.foundation.datastore.application.domain.category, jp.co.intra_mart.foundation.datastore.application.domain.category.category_class, jp.co.intra_mart.foundation.datastore.application.domain.category.detail, jp.co.intra_mart.foundation.datastore.application.domain.company, jp.co.intra_mart.foundation.datastore.application.domain.company.attach, jp.co.intra_mart.foundation.datastore.application.domain.company.category, jp.co.intra_mart.foundation.datastore.application.domain.company.company, jp.co.intra_mart.foundation.datastore.application.domain.company.department, jp.co.intra_mart.foundation.datastore.application.domain.company.main, jp.co.intra_mart.foundation.datastore.application.domain.company.post, jp.co.intra_mart.foundation.datastore.application.domain.company.version, jp.co.intra_mart.foundation.datastore.application.domain.private_group, jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach, jp.co.intra_mart.foundation.datastore.application.domain.private_group.group, jp.co.intra_mart.foundation.datastore.application.domain.public_group, jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach, jp.co.intra_mart.foundation.datastore.application.domain.public_group.category, jp.co.intra_mart.foundation.datastore.application.domain.public_group.group, jp.co.intra_mart.foundation.datastore.application.domain.public_group.set, jp.co.intra_mart.foundation.datastore.application.domain.public_group.version, jp.co.intra_mart.foundation.datastore.application.domain.user, jp.co.intra_mart.foundation.datastore.application.model.category.category_class, jp.co.intra_mart.foundation.datastore.application.model.category.detail, jp.co.intra_mart.foundation.datastore.application.model.company.attach, jp.co.intra_mart.foundation.datastore.application.model.company.category, jp.co.intra_mart.foundation.datastore.application.model.company.company, jp.co.intra_mart.foundation.datastore.application.model.company.department, jp.co.intra_mart.foundation.datastore.application.model.company.inclusion, jp.co.intra_mart.foundation.datastore.application.model.company.main, jp.co.intra_mart.foundation.datastore.application.model.company.post, jp.co.intra_mart.foundation.datastore.application.model.company.version, jp.co.intra_mart.foundation.datastore.application.model.private_group.attach, jp.co.intra_mart.foundation.datastore.application.model.private_group.group, jp.co.intra_mart.foundation.datastore.application.model.public_group.attach, jp.co.intra_mart.foundation.datastore.application.model.public_group.category, jp.co.intra_mart.foundation.datastore.application.model.public_group.group, jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion, jp.co.intra_mart.foundation.datastore.application.model.public_group.set, jp.co.intra_mart.foundation.datastore.application.model.public_group.version, jp.co.intra_mart.foundation.datastore.application.model.user, jp.co.intra_mart.foundation.datastore.common.accessor, jp.co.intra_mart.foundation.datastore.common.config, jp.co.intra_mart.foundation.datastore.common.model, jp.co.intra_mart.foundation.datastore.common.structure, jp.co.intra_mart.foundation.datastore.exception, jp.co.intra_mart.foundation.drawer, jp.co.intra_mart.foundation.exception, jp.co.intra_mart.foundation.graph, jp.co.intra_mart.foundation.http, jp.co.intra_mart.foundation.im_curl, jp.co.intra_mart.foundation.mail, jp.co.intra_mart.foundation.mail.javamail, jp.co.intra_mart.foundation.mail.javamail.property, jp.co.intra_mart.foundation.page, jp.co.intra_mart.foundation.sap.common.auth, jp.co.intra_mart.foundation.sap.common.auth.exception, jp.co.intra_mart.foundation.sap.common.general_purpose, jp.co.intra_mart.foundation.sap.common.general_purpose.exception, jp.co.intra_mart.foundation.sap.common.util.data, jp.co.intra_mart.foundation.sap.common.util.date, jp.co.intra_mart.foundation.sap.common.util.file, jp.co.intra_mart.foundation.sap.module.accounting, jp.co.intra_mart.foundation.sap.module.accounting.exception, jp.co.intra_mart.foundation.scenario, jp.co.intra_mart.foundation.security, jp.co.intra_mart.foundation.security.account, jp.co.intra_mart.foundation.security.admin, jp.co.intra_mart.foundation.security.batch, jp.co.intra_mart.foundation.security.calendar, jp.co.intra_mart.foundation.security.certification, jp.co.intra_mart.foundation.security.cryption, jp.co.intra_mart.foundation.security.exception, jp.co.intra_mart.foundation.security.filter, jp.co.intra_mart.foundation.security.group, jp.co.intra_mart.foundation.security.license, jp.co.intra_mart.foundation.security.menu, jp.co.intra_mart.foundation.security.message, jp.co.intra_mart.foundation.security.permission, jp.co.intra_mart.foundation.security.role, jp.co.intra_mart.foundation.security.servlet, jp.co.intra_mart.foundation.service.client, jp.co.intra_mart.foundation.service.client.application, jp.co.intra_mart.foundation.service.client.application.content, jp.co.intra_mart.foundation.service.client.batch, jp.co.intra_mart.foundation.service.client.file, jp.co.intra_mart.foundation.service.client.information, jp.co.intra_mart.foundation.service.client.manager, jp.co.intra_mart.foundation.service.provider, jp.co.intra_mart.foundation.service.provider.application, jp.co.intra_mart.foundation.service.provider.batch, jp.co.intra_mart.foundation.service.provider.file, jp.co.intra_mart.foundation.service.provider.information, jp.co.intra_mart.foundation.smtp, jp.co.intra_mart.foundation.utility, jp.co.intra_mart.foundation.utility.charset, jp.co.intra_mart.foundation.utility.file, jp.co.intra_mart.foundation.utility.io, jp.co.intra_mart.foundation.utility.net, jp.co.intra_mart.foundation.utility.report, jp.co.intra_mart.framework.base.data, jp.co.intra_mart.framework.base.event, jp.co.intra_mart.framework.base.message, jp.co.intra_mart.framework.base.service, jp.co.intra_mart.framework.base.session, jp.co.intra_mart.framework.base.util, jp.co.intra_mart.framework.base.web.bean, jp.co.intra_mart.framework.base.web.tag, jp.co.intra_mart.framework.base.web.tag.attribute, jp.co.intra_mart.framework.base.web.util, jp.co.intra_mart.framework.extension.common.util, jp.co.intra_mart.framework.extension.struts.action, jp.co.intra_mart.framework.presentation, jp.co.intra_mart.framework.presentation.controller, jp.co.intra_mart.framework.presentation.forward, jp.co.intra_mart.framework.presentation.service, jp.co.intra_mart.framework.presentation.validator, jp.co.intra_mart.framework.presentation.view, jp.co.intra_mart.framework.system.exception, jp.co.intra_mart.framework.system.log, jp.co.intra_mart.framework.system.message, jp.co.intra_mart.framework.system.property, jp.co.intra_mart.jssp.net

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.foundation.http.MultipartFormData
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.graph.BarGraphDrawer
      • class jp.co.intra_mart.foundation.graph.CircleGraphDrawer
      • class jp.co.intra_mart.foundation.graph.LineGraphDrawer
      • class jp.co.intra_mart.foundation.graph.PortFolioDrawer
      • class jp.co.intra_mart.foundation.graph.RadarChartDrawer
    • class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator (implements jp.co.intra_mart.common.aid.jdk.java.util.DualComparator)
      • class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.utility.MultiComparator
      • class jp.co.intra_mart.foundation.page.NodeTypeComparator
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
      • class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
      • class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager)
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
      • class jp.co.intra_mart.foundation.utility.FixedSizeMap
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.http.CGIEnvironment
    • class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
    • class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.FileReporter
      • class jp.co.intra_mart.foundation.utility.report.MultiCastReporter
      • class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
    • class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.foundation.utility.net.SocketPool (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer (implements jp.co.intra_mart.foundation.page.TreeNodeContainer)
      • class jp.co.intra_mart.foundation.page.TreeBranch (implements jp.co.intra_mart.foundation.page.TreeNode)
      • class jp.co.intra_mart.foundation.page.TreeRoot (implements jp.co.intra_mart.foundation.page.TreeNodeProvider)
    • class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter (implements jp.co.intra_mart.framework.presentation.view.ViewConverter)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.AccessSecurityManager
    • class jp.co.intra_mart.foundation.security.account.Account (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.acssecurity.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountManager
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.AccountRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.acssecurity.AcsData
    • class org.apache.struts.action.Action
      • class jp.co.intra_mart.framework.extension.struts.action.IntramartAction
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuManager
    • class jp.co.intra_mart.foundation.datastore.common.config.AttributeType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.BarGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.Batch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.BatchManager
    • class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
    • class jp.co.intra_mart.foundation.appcomn.Category
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
    • class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
    • class jp.co.intra_mart.foundation.graph.CircleGraphObject (implements java.io.Serializable)
    • class java.lang.ClassLoader
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
        • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
    • class jp.co.intra_mart.common.platform.vm.CommandLineArgument
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
    • class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.data.ConnectorModel
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.data.Convertor (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.im_curl.CurlFieldBean
    • class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.data.DAOAdapter (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DaoModel
    • class jp.co.intra_mart.framework.base.data.DataAccessController
    • class jp.co.intra_mart.foundation.database.DatabaseManager
    • class jp.co.intra_mart.framework.base.data.DataConnector
      • class jp.co.intra_mart.framework.base.data.DBConnector
        • class jp.co.intra_mart.framework.base.data.DataSourceConnector
        • class jp.co.intra_mart.framework.base.data.JDBCConnector
      • class jp.co.intra_mart.framework.base.data.IntramartDBConnector
      • class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
      • class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
      • class jp.co.intra_mart.framework.base.data.SystemDBConnector
    • class jp.co.intra_mart.framework.base.data.DataManager
    • class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler (implements java.io.Serializable)
    • class jp.co.intra_mart.common.platform.util.DateUtil
    • class jp.co.intra_mart.framework.base.data.DBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.foundation.database.DbManager
    • class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class jp.co.intra_mart.foundation.im_curl.CurlXMLParser
    • class jp.co.intra_mart.framework.system.log.DefaultLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.foundation.datastore.common.config.DeleteType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.DepartmentInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational (implements java.io.Serializable)
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
              • class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
          • class jp.co.intra_mart.foundation.service.client.information.InitialFile
          • class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
          • class jp.co.intra_mart.foundation.utility.ResourceBundleProperties
    • class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.event.EJBEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListener
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListener
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean (implements javax.ejb.SessionBean)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
    • class jp.co.intra_mart.framework.base.util.EmptyUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.service.EncodingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
    • class jp.co.intra_mart.foundation.utility.ErrorEvent
    • class jp.co.intra_mart.framework.base.event.Event (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.event.EmptyEvent
    • class jp.co.intra_mart.framework.base.event.EventFactoryModel
    • class jp.co.intra_mart.framework.base.event.EventGroupModel
    • class jp.co.intra_mart.framework.base.event.EventManager
    • class jp.co.intra_mart.framework.base.event.EventModelProducer
    • class jp.co.intra_mart.common.aid.jdk.util.EventQueueController
    • class jp.co.intra_mart.foundation.utility.EventQueueController
    • class jp.co.intra_mart.foundation.page.EventScript
    • class jp.co.intra_mart.framework.base.event.EventTriggerAdapter (implements jp.co.intra_mart.framework.base.event.EventTrigger)
    • class jp.co.intra_mart.framework.base.event.EventTriggerInfo
    • class jp.co.intra_mart.framework.base.event.EventTriggerList
    • class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.EverydayConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap)
    • class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
    • class jp.co.intra_mart.foundation.utility.net.ExtendedSocket
      • class jp.co.intra_mart.foundation.utility.net.SocketConnection
    • class jp.co.intra_mart.foundation.security.ExtendsImportManager
    • class jp.co.intra_mart.foundation.security.account.FavoriteMenu (implements java.io.Serializable)
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.HomeDirectory
          • class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory
          • class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory
          • class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile
        • class jp.co.intra_mart.foundation.service.provider.TemporaryFile
    • class jp.co.intra_mart.foundation.http.FileSender
    • class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.framework.base.service.FileUploadFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
    • class jp.co.intra_mart.foundation.utility.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.ReverseComparator
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel)
      • class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
    • class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.LineReportFilter
      • class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter (implements jp.co.intra_mart.foundation.utility.report.ReportLevel)
      • class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
    • class jp.co.intra_mart.framework.presentation.validator.FormatValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.scenario.FunctionContainer
      • class jp.co.intra_mart.foundation.scenario.FunctionContainerFile
    • class jp.co.intra_mart.foundation.service.provider.GarbageController
    • class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.BaseModel)
    • class jp.co.intra_mart.framework.base.event.GenericEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
        • class jp.co.intra_mart.framework.base.service.IntramartConnectServlet
        • class jp.co.intra_mart.foundation.security.servlet.MenuServlet
        • class jp.co.intra_mart.framework.presentation.PresentationServlet
        • class jp.co.intra_mart.framework.base.service.ServiceServlet
        • class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap)
    • class jp.co.intra_mart.jssp.net.GenericURLBuilder
      • class jp.co.intra_mart.jssp.net.URLBuilder
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.appcomn.Grouping
    • class jp.co.intra_mart.framework.base.web.bean.HelperBean (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
    • class jp.co.intra_mart.framework.base.web.util.HTMLEncoder
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
    • class jp.co.intra_mart.framework.base.session.HttpSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener (implements javax.servlet.http.HttpSessionListener)
    • class jp.co.intra_mart.framework.base.session.HttpSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.foundation.service.client.information.Identifier
    • class jp.co.intra_mart.system.mail.smtp.InetMail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.smtp.Mail (implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, java.io.Serializable)
    • class jp.co.intra_mart.foundation.commons.validation.InputCheck
    • class java.io.InputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
        • class jp.co.intra_mart.foundation.utility.io.XORInputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
      • class jp.co.intra_mart.foundation.utility.io.HexInputStream
      • class javax.servlet.ServletInputStream
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
    • class jp.co.intra_mart.framework.base.service.IntramartConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.data.IntramartDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper (implements jp.co.intra_mart.foundation.datastore.common.model.Mapper)
    • class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.system.log.IntramartLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.framework.presentation.validator.LengthValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.foundation.security.license.LicenseManager
    • class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType
    • class jp.co.intra_mart.foundation.graph.LineGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.LocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.common.aid.jdk.java.net.Localhost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.net.Localhost (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.util.LockMonitor
    • class jp.co.intra_mart.foundation.utility.LockMonitor
    • class jp.co.intra_mart.foundation.acssecurity.Logingp
    • class jp.co.intra_mart.foundation.security.group.LoginGroup (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.foundation.security.group.LoginGroupManager
    • class jp.co.intra_mart.framework.system.log.LogManager
    • class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener (implements jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener)
    • class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory
    • class jp.co.intra_mart.foundation.security.menu.MenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuManager
    • class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.menu.MenuTree (implements java.util.Comparator)
    • class jp.co.intra_mart.foundation.security.message.MessageManager
    • class jp.co.intra_mart.framework.base.message.MessageManager
    • class jp.co.intra_mart.framework.system.message.MessageManager
    • class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
    • class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.file.AbstractComponent (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.service.client.file.NetworkFile (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalMemory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.information.Lock (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentFile (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.batch.Scheduler (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.manager.ServerConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.cryption.NoCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.page.NodeNameComparator (implements java.util.Comparator, java.io.Serializable)
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.util.Counter (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.validator.NumericValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.view.Option
    • class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class java.io.OutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
        • class jp.co.intra_mart.foundation.utility.io.XOROutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
      • class jp.co.intra_mart.foundation.utility.io.HexOutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
    • class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory (implements jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent)
    • class jp.co.intra_mart.foundation.security.permission.PermissionManager
    • class jp.co.intra_mart.foundation.service.provider.Platform
    • class jp.co.intra_mart.foundation.graph.PortFolioObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.PostInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.presentation.PresentationConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.presentation.PresentationManager
    • class jp.co.intra_mart.foundation.scenario.PresentationPage
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager
    • class jp.co.intra_mart.foundation.appcomn.Profile
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.system.property.PropertyConfigModel
    • class jp.co.intra_mart.framework.system.property.PropertyManager
      • class jp.co.intra_mart.framework.system.property.DefaultPropertyManager
      • class jp.co.intra_mart.framework.system.property.XmlPropertyManager
    • class jp.co.intra_mart.framework.system.property.PropertyModel
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
      • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
      • class jp.co.intra_mart.framework.system.log.LogAgentParam
      • class jp.co.intra_mart.framework.system.message.MessagePropertyParam
      • class jp.co.intra_mart.framework.system.property.PropertyHandlerParam
      • class jp.co.intra_mart.framework.base.data.ResourceParam
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.PublicGroupInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.RadarChartObject (implements java.io.Serializable)
    • class java.io.Reader
      • class java.io.FilterReader
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
    • class jp.co.intra_mart.framework.base.data.ResourceModel
    • class jp.co.intra_mart.foundation.security.role.Role (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.acssecurity.RoleManager
    • class jp.co.intra_mart.foundation.security.role.RoleManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
    • class jp.co.intra_mart.framework.presentation.view.SelectableItem
      • class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem
      • class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem
    • class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
      • class jp.co.intra_mart.framework.presentation.service.PresentationServiceController
    • class jp.co.intra_mart.framework.base.service.ServiceManager
    • class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.extension.common.util.ServiceUtils
    • class jp.co.intra_mart.foundation.service.client.information.SessionFactory (implements jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
    • class jp.co.intra_mart.foundation.security.filter.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionManager
    • class jp.co.intra_mart.foundation.service.client.information.SessionMemory (implements jp.co.intra_mart.foundation.service.client.information.TreasureFile)
    • class jp.co.intra_mart.foundation.http.SessionQuery
    • class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
    • class java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
      • class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
    • class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter (implements jp.co.intra_mart.framework.presentation.controller.ControllerConverter)
    • class jp.co.intra_mart.framework.presentation.view.SimpleViewObject (implements jp.co.intra_mart.framework.presentation.view.ViewObject)
      • class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject (implements jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject)
    • class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
    • class jp.co.intra_mart.foundation.security.account.StandardAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)
    • class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup (implements jp.co.intra_mart.foundation.security.menu.AdminMenuExporter, jp.co.intra_mart.foundation.security.menu.AdminMenuImporter)
    • class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup (implements jp.co.intra_mart.foundation.security.batch.BatchExporter, jp.co.intra_mart.foundation.security.batch.BatchImporter)
    • class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup (implements jp.co.intra_mart.foundation.security.calendar.CalendarExporter, jp.co.intra_mart.foundation.security.calendar.CalendarImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter)
    • class jp.co.intra_mart.foundation.security.cryption.StandardCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider (implements jp.co.intra_mart.foundation.security.certification.ErrorPageProvider)
    • class jp.co.intra_mart.framework.base.event.StandardEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
    • class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup (implements jp.co.intra_mart.foundation.security.menu.MenuExporter, jp.co.intra_mart.foundation.security.menu.MenuImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer (implements jp.co.intra_mart.foundation.security.certification.RequestAnalyzer)
      • class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
    • class jp.co.intra_mart.foundation.security.role.StandardRoleBackup (implements jp.co.intra_mart.foundation.security.role.RoleExporter, jp.co.intra_mart.foundation.security.role.RoleImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
    • class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.security.admin.SuperUser (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.framework.base.data.SystemDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.foundation.security.SystemManager
    • class javax.servlet.jsp.tagext.TagExtraInfo
      • class jp.co.intra_mart.framework.base.web.tag.FormTEI
      • class jp.co.intra_mart.framework.base.web.tag.FrameTEI
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
      • class jp.co.intra_mart.framework.base.web.tag.LinkTEI
      • class jp.co.intra_mart.framework.base.web.tag.MessageTEI
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTEI
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • class jp.co.intra_mart.framework.base.web.tag.FormTag
        • class jp.co.intra_mart.framework.base.web.tag.FrameTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
        • class jp.co.intra_mart.framework.base.web.tag.LinkTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.MessageParamTag
        • class jp.co.intra_mart.framework.base.web.tag.MessageTag
        • class jp.co.intra_mart.framework.base.web.tag.ParamTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitTag
    • class jp.co.intra_mart.framework.base.web.tag.TagWriter
    • class jp.co.intra_mart.foundation.datastore.common.structure.Term (implements java.lang.Comparable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.structure.TermManager
    • class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread
      • class jp.co.intra_mart.foundation.utility.ExtendedThread
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.acssecurity.AcssecurityException
        • class jp.co.intra_mart.foundation.appcomn.AppcomnException
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.exception.AccessSecurityException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateException
              • class jp.co.intra_mart.foundation.security.exception.NotExistException
              • class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
            • class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
            • class jp.co.intra_mart.foundation.security.exception.NoFilterException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionException
            • class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
          • class jp.co.intra_mart.foundation.exception.ChangedListenerException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.datastore.exception.AccessorException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
              • class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
              • class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
            • class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
            • class jp.co.intra_mart.foundation.datastore.exception.ManagerException
            • class jp.co.intra_mart.foundation.datastore.exception.MapperException
            • class jp.co.intra_mart.foundation.datastore.exception.TermManagerException
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.presentation.BadRequestException
            • class jp.co.intra_mart.framework.base.service.RequestException
            • class jp.co.intra_mart.framework.presentation.TokenInvalidException
            • class jp.co.intra_mart.framework.presentation.validator.ValidationException
          • class jp.co.intra_mart.framework.system.property.PropertyHandlerException
          • class jp.co.intra_mart.framework.system.property.PropertyManagerException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException
            • class jp.co.intra_mart.framework.base.data.DAOException
            • class jp.co.intra_mart.framework.base.data.DataAccessException
            • class jp.co.intra_mart.framework.base.data.DataConnectException
            • class jp.co.intra_mart.framework.base.data.DataConnectorException
            • class jp.co.intra_mart.framework.base.data.DataManagerException
            • class jp.co.intra_mart.framework.base.data.DataPropertyException
            • class jp.co.intra_mart.framework.presentation.DuplicateException
            • class jp.co.intra_mart.framework.base.event.EventException
            • class jp.co.intra_mart.framework.base.event.EventListenerException
            • class jp.co.intra_mart.framework.base.event.EventManagerException
            • class jp.co.intra_mart.framework.base.event.EventPropertyException
            • class jp.co.intra_mart.framework.base.event.EventTriggerException
            • class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException
            • class jp.co.intra_mart.framework.base.web.bean.HelperBeanException
            • class jp.co.intra_mart.framework.base.session.IllegalSessionException
            • class jp.co.intra_mart.framework.system.exception.IllegalSystemException
            • class jp.co.intra_mart.framework.system.log.LogPropertyException
            • class jp.co.intra_mart.framework.base.message.MessageManagerException
            • class jp.co.intra_mart.framework.system.message.MessageManagerException
            • class jp.co.intra_mart.framework.base.message.MessagePropertyException
            • class jp.co.intra_mart.framework.system.message.MessagePropertyException
            • class jp.co.intra_mart.framework.presentation.MismatchException
            • class jp.co.intra_mart.framework.presentation.NameFormatException
            • class jp.co.intra_mart.framework.presentation.PresentationManagerException
            • class jp.co.intra_mart.framework.presentation.PresentationPropertyException
            • class jp.co.intra_mart.framework.presentation.controller.RequestFormatException
            • class jp.co.intra_mart.framework.base.service.ServiceControllerException
            • class jp.co.intra_mart.framework.base.service.ServiceManagerException
            • class jp.co.intra_mart.framework.base.service.ServicePropertyException
            • class jp.co.intra_mart.framework.base.service.ServiceServletException
            • class jp.co.intra_mart.framework.base.session.SessionFactoryException
            • class jp.co.intra_mart.framework.base.session.SessionManagerException
            • class jp.co.intra_mart.framework.base.session.SessionObjectException
            • class jp.co.intra_mart.framework.base.session.SessionPropertyException
            • class jp.co.intra_mart.framework.base.service.TransitionException
            • class jp.co.intra_mart.framework.base.util.UserInfoException
            • class jp.co.intra_mart.framework.presentation.validator.ValidatorException
            • class jp.co.intra_mart.framework.presentation.view.ViewConverterException
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException
        • class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException
        • class jp.co.intra_mart.foundation.datastore.exception.ImportException
        • class java.io.IOException
          • class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException
          • class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
        • class javax.servlet.jsp.JspException
          • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException
        • class jp.co.intra_mart.foundation.mail.MailSenderException
        • class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
              • class jp.co.intra_mart.foundation.security.exception.SystemConfigException
            • class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
              • class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException
        • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
        • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
        • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
        • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
        • class jp.co.intra_mart.foundation.scenario.ScriptCompileException
        • class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException
        • class java.sql.SQLException
          • class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
      • class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
    • class jp.co.intra_mart.foundation.page.TreeLeaf (implements jp.co.intra_mart.foundation.page.TreeNode)
    • class jp.co.intra_mart.foundation.security.filter.URLAccessFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.User (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.base.util.UserInfoUtil
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
        • class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
      • class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
      • class jp.co.intra_mart.foundation.utility.io.ReplaceWriter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter
      • class jp.co.intra_mart.foundation.utility.report.ReportFileWriter
    • class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.account.AccountAccessor
  • interface jp.co.intra_mart.foundation.security.account.AccountChangedListener
  • interface jp.co.intra_mart.foundation.security.account.AccountExporter
  • interface jp.co.intra_mart.foundation.security.account.AccountImporter
  • interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.Application
  • interface jp.co.intra_mart.foundation.security.license.ApplicationInfo
  • interface jp.co.intra_mart.foundation.datastore.common.config.Attribute
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable
  • interface jp.co.intra_mart.foundation.security.batch.BatchAccessor
  • interface jp.co.intra_mart.foundation.security.batch.BatchExporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchImporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator
  • interface jp.co.intra_mart.foundation.security.ClientTypeInfo
  • interface jp.co.intra_mart.foundation.security.ColorPatternInfo
  • interface jp.co.intra_mart.foundation.datastore.common.config.Column
  • interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter
  • interface java.util.Comparator
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.io.Serializable)
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.foundation.datastore.common.config.Configuration
  • interface jp.co.intra_mart.foundation.database.ConInfo
  • interface java.sql.Connection
    • interface jp.co.intra_mart.foundation.database.DbsConnection
  • interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter
  • interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig
  • interface jp.co.intra_mart.foundation.security.cryption.Cryption
  • interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF
  • interface jp.co.intra_mart.framework.base.data.DAO
  • interface jp.co.intra_mart.foundation.database.DatabaseAccessor
  • interface jp.co.intra_mart.foundation.database.DataSourceProvider
  • interface jp.co.intra_mart.foundation.security.calendar.DayInfo
  • interface jp.co.intra_mart.foundation.datastore.common.config.Delete
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct
  • interface javax.ejb.EJBLocalHome
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome
  • interface javax.ejb.EJBLocalObject
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal
  • interface jp.co.intra_mart.foundation.datastore.common.config.Entity
  • interface jp.co.intra_mart.foundation.service.provider.Environment
  • interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener
  • interface jp.co.intra_mart.foundation.utility.ErrorEventListener
  • interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider
  • interface jp.co.intra_mart.common.aid.jdk.util.EventListener
  • interface jp.co.intra_mart.foundation.utility.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListenerFactory
  • interface jp.co.intra_mart.framework.base.event.EventTrigger
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable
  • interface jp.co.intra_mart.foundation.security.ExtendsImport
  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector
  • interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig
  • interface jp.co.intra_mart.foundation.service.provider.GCConditioner
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager
  • interface jp.co.intra_mart.foundation.security.INonTransaction
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.LocaleInfo
    • interface jp.co.intra_mart.foundation.security.certification.LoginInfo
      • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
    • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
    • interface jp.co.intra_mart.foundation.security.SessionInfo
  • interface jp.co.intra_mart.framework.system.log.LogAgent
  • interface jp.co.intra_mart.framework.system.log.LogConstant
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator
  • interface jp.co.intra_mart.foundation.mail.MailSender
  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper
  • interface jp.co.intra_mart.foundation.security.menu.MenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.MenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator
  • interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter
  • interface jp.co.intra_mart.foundation.utility.report.MessageReporter
  • interface jp.co.intra_mart.foundation.datastore.common.config.Model
  • interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity
  • interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable
  • interface jp.co.intra_mart.foundation.security.permission.PermissionSelector
  • interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping
  • interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener
  • interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent
  • interface jp.co.intra_mart.foundation.datastore.common.config.Property
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.data.DataPropertyHandler
    • interface jp.co.intra_mart.framework.base.event.EventPropertyHandler
    • interface jp.co.intra_mart.framework.system.log.LogPropertyHandler
    • interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler
    • interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler
    • interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler
    • interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler
    • interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct
  • interface jp.co.intra_mart.foundation.datastore.common.config.Relationship
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
    • interface javax.ejb.EJBObject
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
    • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner
  • interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
  • interface jp.co.intra_mart.foundation.utility.report.ReportLevel
  • interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer
  • interface jp.co.intra_mart.framework.presentation.RequestInfo
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter
  • interface jp.co.intra_mart.foundation.security.role.RoleAccessor
  • interface jp.co.intra_mart.foundation.security.role.RoleChangedListener
  • interface jp.co.intra_mart.foundation.security.role.RoleExporter
  • interface jp.co.intra_mart.foundation.security.role.RoleImporter
  • interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator
  • interface jp.co.intra_mart.foundation.scenario.ScriptValue
    • interface jp.co.intra_mart.foundation.scenario.VariableScope
  • interface jp.co.intra_mart.foundation.security.SecurityConstraint
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.service.client.ActionListener
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
    • interface jp.co.intra_mart.framework.presentation.controller.ControllerObject
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.util.Comparator)
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.util.Comparator)
    • interface jp.co.intra_mart.framework.base.event.EventResult
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap
    • interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject
    • interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.framework.base.util.UserInfo
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
    • interface jp.co.intra_mart.framework.presentation.view.ViewObject
      • interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject
  • interface jp.co.intra_mart.framework.base.service.ServiceController
  • interface jp.co.intra_mart.framework.base.service.ServiceResult
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
  • interface jp.co.intra_mart.foundation.security.SessionConfig
  • interface jp.co.intra_mart.framework.base.session.SessionFactory
  • interface jp.co.intra_mart.framework.base.session.SessionObject
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager
  • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener
  • interface jp.co.intra_mart.foundation.utility.net.SocketEventListener
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertification
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.service.provider.SystemReporter
    • interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter
  • interface jp.co.intra_mart.foundation.security.SystemSourceProvider
  • interface jp.co.intra_mart.foundation.datastore.common.config.Table
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener
  • interface jp.co.intra_mart.foundation.utility.ThreadStopListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureFile
  • interface jp.co.intra_mart.foundation.page.TreeNode
  • interface jp.co.intra_mart.foundation.page.TreeNodeContainer
    • interface jp.co.intra_mart.foundation.page.TreeNodeProvider
  • interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo
  • interface jp.co.intra_mart.foundation.security.certification.UserCertification
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter
  • interface jp.co.intra_mart.foundation.security.certification.UserPageProvider
  • interface jp.co.intra_mart.framework.presentation.validator.Validator
  • interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig
  • interface jp.co.intra_mart.framework.presentation.view.ViewConverter
  • interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


(5.0 J2EE-Base Programing Model API Specifications)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory は File を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory は Directory を拡張し、Serializable を実装しています

直列化されたフィールド

POOL

FixedSizeMap POOL
このディレクトリを親とするファイルオブジェクトのキャッシュ領域

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile は File を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.java.net

クラス jp.co.intra_mart.common.aid.jdk.java.net.Localhost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

localhostIPAddress

byte[] localhostIPAddress

localhostAddress

String localhostAddress

localhostName

String localhostName

クラス jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException は IOException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.java.util

クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties は Properties を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

Comparator parent

クラス jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator
第１コンパレータ

secondaryComparator

MultiComparator secondaryComparator
第２コンパレータ

クラス jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties は Properties を拡張し、Serializable を実装しています

直列化されたフィールド

currentLocale

Locale currentLocale

クラス jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator は FilterComparator を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

map

WeakHashMap map
map

count

long count
挿入順番

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml

クラス jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties は ElementProperties を拡張し、Serializable を実装しています

直列化されたフィールド

domDocument

Document domDocument
このプロパティセットの元データとなった DOM

propertyList

Map propertyList
プロパティのリスト

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom

クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties は ExtendedProperties を拡張し、Serializable を実装しています

直列化されたフィールド

propertyList

Map propertyList
プロパティのリスト

element

Element element
このオブジェクトがラップするエレメントノード

パッケージ jp.co.intra_mart.common.aid.jdk.util

クラス jp.co.intra_mart.common.aid.jdk.util.Counter は Number を拡張し、Serializable を実装しています

直列化されたフィールド

currentValue

long currentValue
カウンターの値

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset

クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException は UnripeQueryException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException は BadRequestException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException は ServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException は BadRequestException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException は BadRequestException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.application

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException は HTTPActionEventHandlerException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.acssecurity

クラス jp.co.intra_mart.foundation.acssecurity.AcssecurityException は Exception を拡張し、Serializable を実装しています

直列化されたフィールド

message

String message

code

int code

パッケージ jp.co.intra_mart.foundation.database.exception

クラス jp.co.intra_mart.foundation.database.exception.DatabaseSQLException は SQLException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.drawer

クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer は Object を拡張し、Serializable を実装しています

直列化されたフィールド

width

int width

height

int height

type

String type

パッケージ jp.co.intra_mart.foundation.exception

クラス jp.co.intra_mart.foundation.exception.ChangedListenerException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.exception.FoundationException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.exception.FoundationRuntimeException は RuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.graph

クラス jp.co.intra_mart.foundation.graph.BarGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.BarGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.CircleGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption_margin

int caption_margin

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.CircleGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

data

double data

color

Color color

caption

String caption

font_color

Color font_color

font_size

int font_size

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.LineGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.LineGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.PortFolioDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

data

ArrayList data

x_max

Number x_max

x_min

Number x_min

y_max

Number y_max

y_min

Number y_min

isDouble

boolean isDouble

x_center

Number x_center

x_size

Number x_size

x_count

Number x_count

y_center

Number y_center

y_size

Number y_size

y_count

Number y_count

scale_position

String scale_position

クラス jp.co.intra_mart.foundation.graph.PortFolioObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

x_data

double x_data

y_data

double y_data

color

Color color

size

int size

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.RadarChartDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_frame_color

Color graph_frame_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption_margin

int caption_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.RadarChartObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

fill

boolean fill

data

ArrayList data

パッケージ jp.co.intra_mart.foundation.http

クラス jp.co.intra_mart.foundation.http.CGIEnvironment は HashMap を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.http.MultipartFormData は ArrayList を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.mail

クラス jp.co.intra_mart.foundation.mail.MailSenderException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.page

クラス jp.co.intra_mart.foundation.page.NodeNameComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.page.NodeTypeComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator

secondaryComparator

Comparator secondaryComparator

パッケージ jp.co.intra_mart.foundation.scenario

クラス jp.co.intra_mart.foundation.scenario.NoSuchPropertyException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.scenario.ScriptCompileException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.scenario.ScriptRuntimeException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security

クラス jp.co.intra_mart.foundation.security.DepartmentInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード。

departmentCode

String departmentCode
組織コード。

クラス jp.co.intra_mart.foundation.security.PostInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード。

postCode

String postCode
役職コード。

クラス jp.co.intra_mart.foundation.security.PublicGroupInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

groupSetCode

String groupSetCode
グループセットコード。

groupCode

String groupCode
グループコード。

パッケージ jp.co.intra_mart.foundation.security.account

クラス jp.co.intra_mart.foundation.security.account.Account は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

goOut

boolean goOut
外出フラグ

locale

Locale locale
ロケール

lockdate

Date lockdate
アカウントロック日付

loginFailureCount

int loginFailureCount
ログイン失敗回数

mainPagePatternId

String mainPagePatternId
メインページパターンID

mobilePassword

String mobilePassword
モバイル用パスワード

description

String description
説明

colorPatternId

String colorPatternId
カラーパターンID

password

String password
パスワード

userId

String userId
ユーザID

validEndDate

Date validEndDate
有効終了日

validStartDate

Date validStartDate
有効開始日

クラス jp.co.intra_mart.foundation.security.account.AccountRole は Object を拡張し、Serializable を実装しています

直列化されたフィールド

roleId

String roleId
ロールID

roleValidEndDate

Date roleValidEndDate
ロール有効終了日

roleValidStartDate

Date roleValidStartDate
ロール有効開始日

クラス jp.co.intra_mart.foundation.security.account.FavoriteMenu は Object を拡張し、Serializable を実装しています

直列化されたフィールド

displayName

String displayName
マイメニュー表示名

menuId

String menuId
メニューID

sortNumber

int sortNumber
ソート番号

パッケージ jp.co.intra_mart.foundation.security.admin

クラス jp.co.intra_mart.foundation.security.admin.SuperUser は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

locale

Locale locale
ロケール

mailAddress

String mailAddress
メールアドレス

password

String password
パスワード

telNo

String telNo
電話番号

userId

String userId
ユーザーID

パッケージ jp.co.intra_mart.foundation.security.batch

クラス jp.co.intra_mart.foundation.security.batch.Batch は Object を拡張し、Serializable を実装しています

直列化されたフィールド

batchId

String batchId
バッチＩＤ

description

String description
バッチ内容

name

String name
バッチ名

programLanguage

String programLanguage
実行プログラム言語

programPath

String programPath
実行プログラムパス

runDay

int runDay
実行日

runDayWeek

int runDayWeek
実行曜日

runHour

int runHour
実行時

runMinute

int runMinute
実行分

runMonth

int runMonth
実行月

runSecond

int runSecond
実行秒

runYear

int runYear
実行年

validate

boolean validate
有効・無効フラグ

パッケージ jp.co.intra_mart.foundation.security.calendar

クラス jp.co.intra_mart.foundation.security.calendar.CalendarInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

String color
表示色

dataId

String dataId
データＩＤ（入力必須）

dataType

String dataType
データタイプ

day

int day
日

dayWeek

int dayWeek
曜日

description

String description
カレンダーデータの説明

displayName

Map displayName
表示名

month

int month
月

plugin

String plugin
プラグインID

times

int times
第ｎ～曜日

validEndYear

int validEndYear
有効終了年

validStartYear

int validStartYear
有効開始年

week

int week
第ｎ週目

year

int year
年

regExpPattern

Pattern regExpPattern
検証パターン(正規表現)

priority

int priority
優先度

パッケージ jp.co.intra_mart.foundation.security.exception

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException は AccessSecurityRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException は FoundationRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.DuplicateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.IllegalArgumentException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoFilterException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoSessionCookieException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoSessionException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotExistException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotSupportMethodException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.SystemConfigException は AccessSecurityRuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security.group

クラス jp.co.intra_mart.foundation.security.group.LoginGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

locale

Locale locale
ロケール

lockCount

int lockCount
アカウントロックカウント

lockTerm

int lockTerm
アカウントロック時間（分）

loginGroupId

String loginGroupId
ログイングループID

colorPatternId

String colorPatternId
カラーパターンID

クラス jp.co.intra_mart.foundation.security.group.MainPagePatternInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

mainPagePatternId

String mainPagePatternId
メインページパターンID。

mainPagePatternImageUrl

String mainPagePatternImageUrl
メインページパターンイメージURL。

mainPagePatternUrl

String mainPagePatternUrl
メインページパターンURL。

パッケージ jp.co.intra_mart.foundation.security.menu

クラス jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

childMenuId

String childMenuId
子メニューID。

parentMenuId

String parentMenuId
親メニューID。

クラス jp.co.intra_mart.foundation.security.menu.MenuInclusion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

childMenuId

String childMenuId
子メニューID。

parentMenuId

String parentMenuId
親メニューID。

クラス jp.co.intra_mart.foundation.security.menu.MenuItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

arguments

Map arguments
引数

clientType

String clientType
クライアントタイプ

contents

String contents
コンテンツの種類

description

String description
説明

displayNames

Map displayNames
メニュー名 (多言語化対応、 key:ロケール、value メニュー名)

id

String id
メニューID

sortNumber

int sortNumber
ソート番号

type

String type
ノードタイプ

url

String url
URL

imagePath

String imagePath
メニューイメージパス。

パッケージ jp.co.intra_mart.foundation.security.role

クラス jp.co.intra_mart.foundation.security.role.Role は Object を拡張し、Serializable を実装しています

直列化されたフィールド

category

String category
ロールカテゴリ。

description

String description
ロールの詳細。

displayName

Map displayName
ロールの表示名 (key:ロケール、value:ロール表示名)。

roleId

String roleId
ロールID。

roleName

String roleName
ロール名。

パッケージ jp.co.intra_mart.foundation.security.servlet

クラス jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.MenuServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.UserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

パッケージ jp.co.intra_mart.foundation.service.client

クラス jp.co.intra_mart.foundation.service.client.NetworkAgent は NetworkConnector を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.NetworkConnector は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.batch

クラス jp.co.intra_mart.foundation.service.client.batch.Scheduler は NetworkAgent を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.file

クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent は NetworkAgent を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.file.NetworkFile は AbstractComponent を拡張し、Serializable を実装しています

直列化されたフィールド

path

String path

パッケージ jp.co.intra_mart.foundation.service.client.information

クラス jp.co.intra_mart.foundation.service.client.information.ExternalDirectory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

dir

String dir

クラス jp.co.intra_mart.foundation.service.client.information.ExternalMemory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

parent

String parent

クラス jp.co.intra_mart.foundation.service.client.information.InitialFile は Properties を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.information.Lock は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

クラス jp.co.intra_mart.foundation.service.client.information.PermanentDirectory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

dir

String dir

クラス jp.co.intra_mart.foundation.service.client.information.PermanentFile は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

parent

String parent

パッケージ jp.co.intra_mart.foundation.service.client.manager

クラス jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.manager.ServerConnector は NetworkConnector を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider

クラス jp.co.intra_mart.foundation.service.provider.HomeDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.TemporaryDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.TemporaryFile は ExtendedFile を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.file

クラス jp.co.intra_mart.foundation.service.provider.file.StorageDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.information

クラス jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.information.ProgramDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.smtp

クラス jp.co.intra_mart.foundation.smtp.Mail は jp.co.intra_mart.system.mail.smtp.InetMail を拡張し、Serializable を実装しています

直列化されたフィールド

tempSmtpsvr

String tempSmtpsvr
推奨されていません。

badAdrs

ArrayList badAdrs
推奨されていません。

errCode

int errCode
推奨されていません。

errMsg

String errMsg
推奨されていません。

toFlg

boolean toFlg
推奨されていません。

fromFlg

boolean fromFlg
推奨されていません。

replyFlg

boolean replyFlg
推奨されていません。

パッケージ jp.co.intra_mart.foundation.utility

クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.Counter は Number を拡張し、Serializable を実装しています

直列化されたフィールド

currentValue

long currentValue
推奨されていません。
カウンターの値

クラス jp.co.intra_mart.foundation.utility.FilterComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

Comparator parent
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.MultiComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator
推奨されていません。
第１コンパレータ

secondaryComparator

MultiComparator secondaryComparator
推奨されていません。
第２コンパレータ

クラス jp.co.intra_mart.foundation.utility.ResourceBundleProperties は Properties を拡張し、Serializable を実装しています

直列化されたフィールド

currentLocale

Locale currentLocale
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.ReverseComparator は FilterComparator を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.SequenceComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

map

WeakHashMap map
推奨されていません。
map

count

long count
推奨されていません。
挿入順番

パッケージ jp.co.intra_mart.foundation.utility.charset

クラス jp.co.intra_mart.foundation.utility.charset.ResourceFormatException は ResourceFormatException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException は ResourceNotFoundException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.utility.file

クラス jp.co.intra_mart.foundation.utility.file.Directory は File を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory は Directory を拡張し、Serializable を実装しています

直列化されたフィールド

POOL

FixedSizeMap POOL
推奨されていません。
このディレクトリを親とするファイルオブジェクトのキャッシュ領域

クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile は File を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.utility.net

クラス jp.co.intra_mart.foundation.utility.net.Localhost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

localhostIPAddress

byte[] localhostIPAddress
推奨されていません。

localhostAddress

String localhostAddress
推奨されていません。

localhostName

String localhostName
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException は IOException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.appcomn

クラス jp.co.intra_mart.foundation.appcomn.AppcomnException は Exception を拡張し、Serializable を実装しています

直列化されたフィールド

message

String message

code

int code

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryClassCode

String categoryClassCode
分類区分コード

notes

String notes
備考

internationals

Map internationals
分類区分の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
分類区分名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

notes

String notes
備考

internationals

Map internationals
分類区分詳細の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
分類名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
組織所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

postCode

String postCode
役職CD

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

terminables

SortedMap terminables
会社組織分類の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
会社の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス1

emailAddress2

String emailAddress2
メールアドレス2

url

String url
URL

terminableInternationals

Map terminableInternationals
会社の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
組織名

nameSyllabary

String nameSyllabary
組織名カナ

nameEnglish

String nameEnglish
組織名英字

address1

String address1
住所1

address2

String address2
住所2

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
組織の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス1

emailAddress2

String emailAddress2
メールアドレス2

url

String url
URL

terminableInternationals

Map terminableInternationals
組織の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
組織名

nameSyllabary

String nameSyllabary
組織名カナ

nameEnglish

String nameEnglish
組織名英字

address1

String address1
住所1

address2

String address2
住所2

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

terminables

SortedMap terminables
主所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

postCode

String postCode
役職コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
役職の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
役職の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
役職名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

versionCode

String versionCode
バージョンコード

startDate

Date startDate
開始日

endDate

Date endDate
終了日

notes

String notes
備考

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ownerCode

String ownerCode
所有者コード

privateGroupCode

String privateGroupCode
グループコード

userCode

String userCode
ユーザコード

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group

クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ownerCode

String ownerCode
所有者コード

privateGroupCode

String privateGroupCode
グループコード

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

notes

String notes
備考

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
パブリックグループ所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

terminables

SortedMap terminables
パブリックグループ分類の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
パブリックグループの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
パブリックグループの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
パブリックグループセットの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
パブリックグループセットの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

versionCode

String versionCode
バージョンコード

startDate

Date startDate
開始日

endDate

Date endDate
終了日

notes

String notes
備考

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.User は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

accountFlag

String accountFlag
アカウントフラグ

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
ユーザの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

mobileNumber

String mobileNumber
携帯電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス１

emailAddress2

String emailAddress2
メールアドレス２

mobileEmailAddress

String mobileEmailAddress
携帯用メール

url

String url
URL

terminableInternationals

Map terminableInternationals
ユーザの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
ユーザ名

nameSyllabary

String nameSyllabary
ユーザ名カナ

nameEnglish

String nameEnglish
ユーザ名英字

address

String address
住所

パッケージ jp.co.intra_mart.foundation.datastore.common.config

クラス jp.co.intra_mart.foundation.datastore.common.config.AttributeType は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.common.config.DeleteType は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.common.model

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedBaseAccessor accessor
拡張基本アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedInternationalAccessor accessor
拡張国際化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedTerminableInternationalAccessor accessor
拡張期間国際化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedTerminableAccessor accessor
拡張期間化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

BaseModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

InternationalModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
国際化モデルを管理するマップ

modelName

String modelName
国際化モデルのクラス名

accessorMap

InternationalAccessorMap accessorMap
国際化アクセサマッピング

key

String key
メッセージキー

関連項目:
定数フィールド値

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

TerminableInternationalModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
期間国際化モデルを管理するマップ

modelName

String modelName
期間国際化モデル名

accessorMap

TerminableInternationalAccessorMap accessorMap
国際化アクセサマッピング

key

String key
メッセージキー

関連項目:
定数フィールド値

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

TerminableModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
期間化モデルを管理するマップ

terminableName

String terminableName
期間化モデルのクラス名

terminableInternationalName

String terminableInternationalName
期間国際化モデルのクラス名

accessorMap

TerminableAccessorMap accessorMap
期間化アクセサマッピング

defaultLocale

Locale defaultLocale
デフォルト言語

helper

jp.co.intra_mart.system.datastore.common.model.GenericTerminableModelMapHelper helper
期間化モデルマッピングヘルパー

key

String key
メッセージキー

関連項目:
定数フィールド値

パッケージ jp.co.intra_mart.foundation.datastore.common.structure

クラス jp.co.intra_mart.foundation.datastore.common.structure.Term は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activationCal

Calendar activationCal
有効開始時間

expirationCal

Calendar expirationCal
有効終了時間

termByString

String termByString
期間の文字列表現

パッケージ jp.co.intra_mart.foundation.datastore.exception

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException は FoundationException を拡張し、Serializable を実装しています

直列化されたフィールド

key

String key
メッセージキー

values

String[] values
置換用文字列

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException は FoundationRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException は DataNotFoundException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalTermException は DataNotFoundException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.ImportException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.ManagerException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.MapperDAOException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.MapperException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.TermManagerException は DataStoreApplicationException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.data

クラス jp.co.intra_mart.framework.base.data.DAOException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataAccessException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataConnectException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataConnectorException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.event

クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sessionContext

SessionContext sessionContext
セッションコンテキスト

クラス jp.co.intra_mart.framework.base.event.EmptyEvent は Event を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.Event は Object を拡張し、Serializable を実装しています

直列化されたフィールド

application

String application
アプリケーション

key

String key
イベントキー

loginUserID

String loginUserID
ログインユーザ

loginGroupID

String loginGroupID
ログイングループ

info

UserInfo info
ユーザ情報

クラス jp.co.intra_mart.framework.base.event.EventException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventListenerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventPropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventTriggerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean は EJBEventListenerAgentBean を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean は EJBEventListenerAgentBean を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.message

クラス jp.co.intra_mart.framework.base.message.MessageManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.message.MessagePropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service

クラス jp.co.intra_mart.framework.base.service.IntramartConnectServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

serviceManager

ServiceManager serviceManager
推奨されていません。
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
推奨されていません。
サービスプロパティハンドラ

sessionManager

SessionManager sessionManager
推奨されていません。
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
推奨されていません。
セッションプロパティハンドラ

referrerFormatShort

boolean referrerFormatShort
推奨されていません。
referrerのフォーマット

導入されたバージョン:
4.1.5

クラス jp.co.intra_mart.framework.base.service.RequestException は ApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceControllerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServicePropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

manager

ServiceManager manager
サービスマネージャ

handler

ServicePropertyHandler handler
サービスプロパティハンドラ

クラス jp.co.intra_mart.framework.base.service.ServiceServletException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.TransitionException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.session

クラス jp.co.intra_mart.framework.base.session.IllegalSessionException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionFactoryException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionObjectException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.util

クラス jp.co.intra_mart.framework.base.util.ConfigurationUserInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

clientType

String clientType

colorPatternID

String colorPatternID

encoding

String encoding

language

String language

country

String country

variant

String variant

loginGroupID

String loginGroupID

loginTime

Date loginTime

loginType

String loginType

userID

String userID

クラス jp.co.intra_mart.framework.base.util.EmptyUserInfo は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.util.UserInfoException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.web.bean

クラス jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean は HelperBean を拡張し、Serializable を実装しています

直列化されたフィールド

exception

Throwable exception
例外

クラス jp.co.intra_mart.framework.base.web.bean.HelperBean は Object を拡張し、Serializable を実装しています

直列化されたフィールド

eventManager

EventManager eventManager
イベントマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

request

HttpServletRequest request
リクエスト

response

HttpServletResponse response
レスポンス

userInfo

UserInfo userInfo
ユーザ情報

クラス jp.co.intra_mart.framework.base.web.bean.HelperBeanException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.web.tag

クラス jp.co.intra_mart.framework.base.web.tag.FormTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

EventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

method

String method
method

enctype

String enctype
enctype

accept

String accept
accept

name

String name
name

onSubmit

String onSubmit
onSubmit

onReset

String onReset
onReset

acceptCharset

String acceptCharset
accept-charset

target

String target
target

クラス jp.co.intra_mart.framework.base.web.tag.FrameTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

params

Collection params
パラメータの集合

application

String application
アプリケーション

service

String service
サービス

longdesc

String longdesc
longdesc

name

String name
name

frameborder

String frameborder
frameborder

marginwidth

String marginwidth
marginwidth

marginheight

String marginheight
marginheight

noresize

String noresize
noresize

scrolling

String scrolling
scrolling

クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagException は JspException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

helperclass

String helperclass
クラス名

クラス jp.co.intra_mart.framework.base.web.tag.LinkTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

EventsAttributes events
イベント属性

params

Collection params
パラメータの集合

application

String application
アプリケーション

service

String service
サービス

charset

String charset
charset

type

String type
type

name

String name
name

hreflang

String hreflang
hreflang

rel

String rel
rel

rev

String rev
rev

accesskey

String accesskey
accesskey

shape

String shape
shape

coords

String coords
coords

target

String target
target

導入されたバージョン:
3.2

tabindex

String tabindex
tabindex

onfocus

String onfocus
onfocus

onblur

String onblur
onblur

クラス jp.co.intra_mart.framework.base.web.tag.MessageParamTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

value

Object value
パラメータの値

クラス jp.co.intra_mart.framework.base.web.tag.MessageTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

messageManager

MessageManager messageManager
MessageManager

serviceManager

ServiceManager serviceManager
ServiceManager

params

Vector params
パラメータの集合

application

String application
アプリケーション

key

String key
キー

locale

String locale
ロケール

クラス jp.co.intra_mart.framework.base.web.tag.ParamTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
パラメータ名

value

String value
パラメータの値

クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag.SubmitLinkEventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

form

String form
フォーム名

name

String name
name

accesskey

String accesskey
accesskey

shape

String shape
shape

coords

String coords
coords

tabindex

String tabindex
tabindex

onfocus

String onfocus
onfocus

onblur

String onblur
onblur

serviceManager

ServiceManager serviceManager
サービスマネージャ

導入されたバージョン:
4.3

sessionManager

SessionManager sessionManager
セッションマネージャ

導入されたバージョン:
4.3

クラス jp.co.intra_mart.framework.base.web.tag.SubmitTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

jp.co.intra_mart.framework.base.web.tag.SubmitTag.SubmitEventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

name

String name
name

value

String value
value

tabindex

String tabindex
tabindex

onFocus

String onFocus
onFocus

onBlur

String onBlur
onBlur

serviceManager

ServiceManager serviceManager
サービスマネージャ

導入されたバージョン:
4.3

sessionManager

SessionManager sessionManager
セッションマネージャ

導入されたバージョン:
4.3

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

導入されたバージョン:
4.3

パッケージ jp.co.intra_mart.framework.presentation

クラス jp.co.intra_mart.framework.presentation.BadRequestException は ApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.DuplicateException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.MismatchException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.NameFormatException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.PresentationManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.PresentationPropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.PresentationServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

manager

PresentationManager manager
エンジンマネージャ

handler

PresentationPropertyHandler handler
プロパティハンドラ

クラス jp.co.intra_mart.framework.presentation.TokenInvalidException は ApplicationException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.presentation.controller

クラス jp.co.intra_mart.framework.presentation.controller.ControllerConverterException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.controller.RequestFormatException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.presentation.forward

クラス jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.presentation.validator

クラス jp.co.intra_mart.framework.presentation.validator.ValidationException は ApplicationException を拡張し、Serializable を実装しています

直列化されたフィールド

validationExceptionDetails

Collection validationExceptionDetails
検証例外の詳細

クラス jp.co.intra_mart.framework.presentation.validator.ValidatorException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.presentation.view

クラス jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject は SimpleViewObject を拡張し、Serializable を実装しています

直列化されたフィールド

subPanelViews

Map subPanelViews
サブパネルに対応するPanelBasedViewObjectの集合

クラス jp.co.intra_mart.framework.presentation.view.SimpleViewObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

viewInfo

Object viewInfo
表示情報

formObjects

Map formObjects
フォームオブジェクトの集合

クラス jp.co.intra_mart.framework.presentation.view.ViewConverterException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.exception

クラス jp.co.intra_mart.framework.system.exception.ApplicationException は FrameworkException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.FrameworkException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.IllegalSystemException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.SystemException は FrameworkException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.log

クラス jp.co.intra_mart.framework.system.log.LogPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.message

クラス jp.co.intra_mart.framework.system.message.MessageManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.message.MessagePropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.property

クラス jp.co.intra_mart.framework.system.property.PropertyHandlerException は FrameworkException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.property.PropertyManagerException は FrameworkException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.application

クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.auth

クラス jp.co.intra_mart.foundation.sap.common.auth.SapConnector は Object を拡張し、Serializable を実装しています

直列化されたフィールド

serverType

String serverType
サーバタイプ

client

String client
クライアント

user

String user
ユーザ

passwd

String passwd
パスワード

lang

String lang
言語

sysnr

String sysnr
システム番号

ashost

String ashost
接続先サーバIPアドレス

poolName

String poolName
プール名称

poolSize

int poolSize
プール内のコネクション数

waitTime

long waitTime
コネクション取得の待機時間

connectionTimeout

long connectionTimeout
コネクションのタイムアウト

timeoutCheckPeriod

long timeoutCheckPeriod
コネクションのタイムアウトのチェック間隔

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception

クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

propertyName

String propertyName
プロパティファイル名

property

Properties property
プロパティファイル

bapiHashList

ArrayList bapiHashList
BapiHashオブジェクトの一覧

impImpList

ArrayList impImpList
プロパティ情報(import(Import))一覧

impStrList

ArrayList impStrList
プロパティ情報(structure(Import))一覧

impTblList

ArrayList impTblList
プロパティ情報(table(Import))一覧

expExpList

ArrayList expExpList
プロパティ情報(export(Export))一覧

expStrList

ArrayList expStrList
プロパティ情報(structure(Export))一覧

expTblList

ArrayList expTblList
プロパティ情報(table(Export))一覧

bapiReturnList

ArrayList bapiReturnList
ＢＡＰＩ処理実行結果

hasTransaction

boolean hasTransaction
コネクション(トランザクション)保持フラグ

connectionManager

ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash は HashMap を拡張し、Serializable を実装しています

直列化されたフィールド

impExpType

String impExpType
入力／出力区分

paramType

String paramType
パラメタ属性

paramName

String paramName
パラメタ名

recordNo

int recordNo
レコード番号

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

type

String type
TYPE

id

String id
ID

code

String code
Code

number

String number
NUMBER

message

String message
MESSAGE

logNo

String logNo
LOG NO

logMsgNo

String logMsgNo
LOG MSG NO

messageV1

String messageV1
MESSAGE V1

messageV2

String messageV2
MESSAGE V2

messageV3

String messageV3
MESSAGE V3

messageV4

String messageV4
MESSAGE V4

parameter

String parameter
PARAMETER

row

String row
ROW

field

String field
FIELD

system

String system
SYSTEM

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager は Object を拡張し、Serializable を実装しています

直列化されたフィールド

connection

com.sap.mw.jco.JCO.Client connection
JCOコネクション

sapConnector

SapConnector sapConnector
SAPコネクター

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty は Object を拡張し、Serializable を実装しています

直列化されたフィールド

propertyValue

String propertyValue
プロパティの値

propertyKeyPart

String[] propertyKeyPart
プロパティのキー

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.data

クラス jp.co.intra_mart.foundation.sap.common.util.data.Convertor は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.date

クラス jp.co.intra_mart.foundation.sap.common.util.date.DateHandler は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.file

クラス jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile は Object を拡張し、Serializable を実装しています

直列化されたフィールド

properties

Properties properties
プロパティ

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

documentHeader

DocumentHeader documentHeader
伝票ヘッダ

accountPayableList

ArrayList accountPayableList
仕入先明細一覧

accountGlList

ArrayList accountGlList
G/L 勘定明細一覧

accountTaxList

ArrayList accountTaxList
税明細一覧

currencyAmountList

ArrayList currencyAmountList
明細通貨項目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glItemnoAcc

String glItemnoAcc
会計伝票明細番号

glGlAccount

String glGlAccount
総勘定元帳勘定

glCompCode

String glCompCode
会社コード

glPstngDate

String glPstngDate
伝票の転記日付

glDocType

String glDocType
伝票タイプ

glFiscYear

String glFiscYear
会計年度

glRefKey1

String glRefKey1
取引先参照キー

glItemText

String glItemText
明細テキスト

glTaxCode

String glTaxCode
消費税コード

glAllocNmbr

String glAllocNmbr
ソートキー

glBusArea

String glBusArea
事業領域

glCostcenter

String glCostcenter
原価センタ

glOrderid

String glOrderid
指図番号

glWbsElement

String glWbsElement
WBS 要素

glIndex

int glIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

paItemnoAcc

String paItemnoAcc
会計伝票明細番号

paVendorNo

String paVendorNo
仕入先または債権者の勘定コード

paGlAccount

String paGlAccount
総勘定元帳勘定

paBlineDate

String paBlineDate
期日計算の支払基準日

paPymtMeth

String paPymtMeth
支払方法

paAllocNmbr

String paAllocNmbr
ソートキー

paItemText

String paItemText
明細テキスト

paIndex

int paIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax は Object を拡張し、Serializable を実装しています

直列化されたフィールド

taItemnoAcc

String taItemnoAcc
会計伝票明細番号

taGlAccount

String taGlAccount
総勘定元帳勘定

taTaxCode

String taTaxCode
消費税コード

taIndex

int taIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bankKey

String bankKey
銀行コード

bankName

String bankName
銀行名

city

String city
市区町村名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

baList

BankList baList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bankList

ArrayList bankList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busArea

String busArea
事業領域

busArDes

String busArDes
事業領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busAreaList

BusinessAreaList busAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

businessAreaList

ArrayList businessAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compCode

String compCode
会社コード

compName

String compName
会社名

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compList

CompanyList compList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyList

ArrayList companyList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

coArea

String coArea
管理領域

name

String name
管理領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllAreaList

ControllingAreaList controllAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingAreaList

ArrayList controllingAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

costCenter

String costCenter
原価センタ

name

String name
一般名称

descript

String descript
テキスト

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCentList

CostCenterList costCentList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCenterList

ArrayList costCenterList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

cuItemnoAcc

String cuItemnoAcc
会計伝票明細番号

cuCurrency

String cuCurrency
通貨コード

cuAmtDoccur

String cuAmtDoccur
伝票通貨額

cuAmtBase

String cuAmtBase
課税基準額

cuIndex

int cuIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docObjType

String docObjType
参照処理

docObjKey

String docObjKey
オブジェクトキー

docUsername

String docUsername
ユーザ名

docHeaderTxt

String docHeaderTxt
伝票ヘッダテキスト

docCompCode

String docCompCode
会社コード

docAcDocNo

String docAcDocNo
会計伝票番号

docFiscYear

String docFiscYear
会計年度

docDocDate

String docDocDate
伝票の伝票日付

docPstngDate

String docPstngDate
伝票の転記日付

docFisPeriod

String docFisPeriod
会計期間

docDocType

String docDocType
伝票タイプ

docRefDocNo

String docRefDocNo
参照伝票番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

glAccount

String glAccount
G/L勘定コード

shortText

String shortText
G/L勘定コードテキスト(短)

longText

String longText
総勘定元帳勘定テキスト(長)

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glList

GlAccList glList
勘定科目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glAccList

ArrayList glAccList
勘定項目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

profitCtr

String profitCtr
利益センタ

validTo

String validTo
有効終了日

pctrName

String pctrName
一般名称

inCharge

String inCharge
利益センタ責任者

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCentList

ProfitCenterList profitCentList
利益センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCenterList

ArrayList profitCenterList
利益センタ一覧

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.acssecurity (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.acssecurity

アクセスセキュリティモジュールを利用するためのクラスを提供します。

参照:
説明

クラスの概要
AccountManager | 推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
AcsData | 推奨されていません。
Logingp | 推奨されていません。
RoleManager | 推奨されていません。

例外の概要
AcssecurityException アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。

パッケージ jp.co.intra_mart.foundation.acssecurity の説明

アクセスセキュリティモジュールを利用するためのクラスを提供します。 このパッケージのクラスを利用することで、アクセスセキュリティ機能の持つ 以下の情報に対してアクセスすることができます。

  • アカウント
  • ログイングループ
  • ロール
  • メニュー
  • メッセージ
  • バッチ
  • リンク

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.acssecurity クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.acssecurity の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.acssecurity.AccountManager
    • class jp.co.intra_mart.foundation.acssecurity.AcsData
    • class jp.co.intra_mart.foundation.acssecurity.Logingp
    • class jp.co.intra_mart.foundation.acssecurity.RoleManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.acssecurity.AcssecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.database.DbsConnection の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DbsConnection の使用

DbsConnection を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DbsConnection の使用

DbsConnection を返す jp.co.intra_mart.foundation.database のメソッド
 DbsConnection DbManager.getConnection()
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.database の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.database の使用

jp.co.intra_mart.foundation.database を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database により使用される jp.co.intra_mart.foundation.database のクラス
ConInfo
DatabaseAccessor
データベース接続オブジェクト取得インターフェースを定義します。
DatabaseManager
データベースマネージャクラス。
DataSourceProvider
データソース設定情報取得プロバイダインタフェース。
DbsConnection
推奨されていません。 DatabaseManagerから取得したコネクションを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.http.MultipartFormData.Entity の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.http.MultipartFormData.Entity の使用

MultipartFormData.Entity を使用しているパッケージ
jp.co.intra_mart.foundation.http ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.http での MultipartFormData.Entity の使用

MultipartFormData.Entity を返す jp.co.intra_mart.foundation.http のメソッド
MultipartFormData.Entity | MultipartFormData.getEntity(int index) 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | MultipartFormData.getEntity(String name) 指定の名前を持つエンティティを取得します。
MultipartFormData.Entity[] | MultipartFormData.getEntities(String name) 指定の名前を持つエンティティをすべて取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.http の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.http の使用

jp.co.intra_mart.foundation.http を使用しているパッケージ
jp.co.intra_mart.foundation.http ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。

jp.co.intra_mart.foundation.http により使用される jp.co.intra_mart.foundation.http のクラス
MultipartFormData.Entity
フォームデータのエンティティです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


RequestCharacterEncodingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス RequestCharacterEncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
すべての実装インタフェース:
Filter
public class RequestCharacterEncodingFilter
extends AbstractFilter

リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。 リクエストの文字エンコーディングは、 ServletRequest.setCharacterEncoding(java.lang.String) によってセットされます。
ここでSessionInfo.getEncoding() を取得できなかった場合エンコードの設定はしないで次の処理に遷移します。

バージョン:
1.0

コンストラクタの概要
RequestCharacterEncodingFilter()
メソッドの概要
 void doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain)
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RequestCharacterEncodingFilter

public RequestCharacterEncodingFilter()
メソッドの詳細

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。

パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResponseCharacterEncodingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.filter
クラス ResponseCharacterEncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
すべての実装インタフェース:
Filter
public class ResponseCharacterEncodingFilter
extends AbstractFilter

レスポンスの文字エンコーディングを自動解決するフィルタです。

レスポンスに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。 レスポンスの文字エンコーディングは、Content-Type 設定と共に ServletResponse.setContentType(java.lang.String) によってセットされます。

このフィルタでは、ServletResponse をラップします。 ラップされた ServletResponse に対して #setContentType(String) を 明示的に実行した場合、自動的に Content-Type を書き換えません。 このフィルタ動作によって Content-Type が自動的にセットされるのは、 ラップされた ServletResponse の #setContentType(String) が実行されていない 状態で、ServletResponse の #getOutputStream() または #getWriter() が 呼び出された場合に限られます。

このフィルタに設定可能な初期化パラメータは以下のとおりです。

mime このフィルタがContent-Typeを自動的にセットする時の MIME タイプ。標準は text/html です。

バージョン:
1.0

コンストラクタの概要
ResponseCharacterEncodingFilter()
新しくフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
void | handleInit() このフィルタを初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResponseCharacterEncodingFilter

public ResponseCharacterEncodingFilter()
新しくフィルタを作成します。

メソッドの詳細

handleInit

public void handleInit()
このフィルタを初期化します。

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。

このメソッドが作る HttpServletResponse は、引数 response をラップし、 #getWriter() メソッドが実行された時に #setContentType() を一度も 呼び出されていない場合、アクセスセキュリティＡＰＩを通して、 現在のセッションで有効な文字エンコーディングを自動解決し、 Content-Type をセットしてから、引数 response の #getWriter() メソッドを 呼び出します。

パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.file.NetworkFile の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.file.NetworkFile の使用

jp.co.intra_mart.foundation.service.client.file.NetworkFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.service.client.file の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.file の使用

jp.co.intra_mart.foundation.service.client.file を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.file Storage Service を利用するためのクラスを提供します。

jp.co.intra_mart.foundation.service.client.file により使用される jp.co.intra_mart.foundation.service.client.file のクラス
AbstractComponent
このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.information.SessionMemory の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.information.SessionMemory の使用

SessionMemory を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information での SessionMemory の使用

SessionMemory を返す jp.co.intra_mart.foundation.service.client.information のメソッド
SessionMemory | SessionFactory.getFile() 現在有効なセッションを扱う SessionMemory インスタンスを取得します。
SessionMemory | SessionFactory.entry() 新しい空のセッションを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.service.client.information の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.information の使用

jp.co.intra_mart.foundation.service.client.information を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.information このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.information により使用される jp.co.intra_mart.foundation.service.client.information のクラス
ExternalDirectory
共有データグループを管理するオブジェクトです。
PermanentDirectory
ファイルベースでデータを保存します。
SessionMemory
共有データを管理するオブジェクトです。
TreasureDirectory
情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile
情報データベースのファイルを操作するためのインターフェースを定義します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PermanentDataArchiveFactory (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.batch
クラス PermanentDataArchiveFactory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory
すべての実装インタフェース:
ProcedureComponent

public class PermanentDataArchiveFactory
extends Object
implements ProcedureComponent

Permanent-data Service に保存されている永続データをバックアップするための バッチプログラムです。
このクラスをバッチプログラムとして登録することで、 定期的にデータをバックアップすることができます。

なお、このバッチプログラムは、マルチログイングループ環境を サポートしておりません。 バッチとして実行されると、すべてのデータをバックアップします。 したがって、複数のログイングループでバッチ設定をしても ログイングループ単位でのデータバックアップ等を行うことはできません。

導入されたバージョン:
Version 4.2

コンストラクタの概要
PermanentDataArchiveFactory()
推奨されていません。 バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。
メソッドの概要
 void execute(Properties arg)
推奨されていません。 インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 action() メソッドをバッチプログラムとして実行します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PermanentDataArchiveFactory

public PermanentDataArchiveFactory()
推奨されていません。
バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。

メソッドの詳細

execute

public void execute(Properties arg)
             throws RuntimeException,
                    Error
推奨されていません。
インタフェース ProcedureComponent の記述:
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 action() メソッドをバッチプログラムとして実行します。

バッチとして動作するロジック。

バッチ起動引数は、バッチの設定がバッチ設定画面で登録されている場合、 以下のような項目を持ちます。

group | バッチ設定グループ名（通常はログイングループＩＤ） | String
name | バッチ名称 | String

定義:
インタフェース ProcedureComponent 内の execute
パラメータ:
arg - バッチ起動引数
例外:
RuntimeException - 実行時エラー
Error - 致命的なエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.utility.DualComparator の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.utility.DualComparator の使用

DualComparator を使用しているパッケージ
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.foundation.page での DualComparator の使用

DualComparator を実装している jp.co.intra_mart.foundation.page のクラス
 class NodeTypeComparator
ツリービューのノードを種類順にソートするためのコンパレータです。

jp.co.intra_mart.foundation.utility での DualComparator の使用

DualComparator を実装している jp.co.intra_mart.foundation.utility のクラス
class | AbstractDualComparator 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
class | MultiComparator 推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.utility の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.utility の使用

jp.co.intra_mart.foundation.utility を使用しているパッケージ
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.foundation.http により使用される jp.co.intra_mart.foundation.utility のクラス
MultipurposeInternetMailExtensions
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。

jp.co.intra_mart.foundation.page により使用される jp.co.intra_mart.foundation.utility のクラス
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
DualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。

jp.co.intra_mart.foundation.service.provider により使用される jp.co.intra_mart.foundation.utility のクラス
EventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。

jp.co.intra_mart.foundation.utility により使用される jp.co.intra_mart.foundation.utility のクラス
AbstractDualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
DualComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
ErrorEvent
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
EventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
FilterComparator
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
ThreadStopListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

jp.co.intra_mart.foundation.utility.io により使用される jp.co.intra_mart.foundation.utility のクラス
ErrorEventListener
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。

jp.co.intra_mart.foundation.utility.report により使用される jp.co.intra_mart.foundation.utility のクラス
EventQueueController
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


すべてのクラス (5.0 J2EE-Base Programing Model API Specifications)

 すべてのクラス
AbstractComponent
AbstractDrawer
AbstractDualComparator
AbstractMessageReporter
AbstractSocketConnectionDistributor
AbstractTreeNodeContainer
AccessSecurityConfigException
AccessSecurityCreateException
AccessSecurityDeleteException
AccessSecurityException
AccessSecurityExportException
AccessSecurityImportException
AccessSecurityListenerExcpetion
AccessSecurityManager
AccessSecurityReadException
AccessSecurityRuntimeException
AccessSecurityUpdateException
AccessSecurityWriteException
AccessibleLinkHTTPActionEventFilterHandler
AccessorClosedException
AccessorException
AccessorIllegalPropertyValueException
AccessorSystemException
Account
AccountAccessor
AccountChangedListener
AccountExporter
AccountImporter
AccountManager
AccountManager
AccountPostWriterListener
AccountQueryWriterListener
AccountReaderDecorator
AccountRole
AccountRolePermissionSelector
AccountSecurityHTTPActionEventFilterHandler
AcsData
AcssecurityException
ActionListener
ActivationKey
ActivityFrameworkHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
AdminMenuAccessor
AdminMenuExporter
AdminMenuImporter
AdminMenuInclusion
AdminMenuManager
AdminMenuPostWriterListener
AdminMenuQueryWriterListener
AdminMenuReaderDecorator
AdvancedOutputStreamWriter
AppcomnException
Application
ApplicationInfo
Attribute
AttributeType
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
BarGraphDrawer
BarGraphObject
BaseAccessor
BaseModel
BaseModel
BaseModelContext
BaseTable
Batch
BatchAccessor
BatchExporter
BatchImporter
BatchManager
BatchPostWriterListener
BatchQueryWriterListener
BatchReaderDecorator
CGIEnvironment
CalendarAccessor
CalendarExporter
CalendarImporter
CalendarInfo
CalendarManager
CalendarPlugin
CalendarPluginAutumnalEquinox
CalendarPluginEndOfTheMonth
CalendarPluginInfo
CalendarPluginLastDayInTheMonth
CalendarPluginMondayMakeupHoliday
CalendarPluginVernalEquinox
CalendarPostWriterListener
CalendarQueryWriterListener
CalendarReaderDecorator
CategorizedCalendarInfo
Category
CategoryDetail
CategoryDetailBaseModel
CategoryDetailInternational
CategoryDetailInternationalModel
CategoryDetailMapper
CategoryManager
CateogryClass
CateogryClassBaseModel
CateogryClassInternational
CateogryClassInternationalModel
CateogryClassMapper
ChangedListenerException
CharacterEncoder
CircleGraphDrawer
CircleGraphObject
ClientTypeInfo
ColorPatternInfo
Column
ColumnMapping
Company
CompanyBaseModel
CompanyCategory
CompanyCategoryBaseModel
CompanyCategoryMapper
CompanyCategoryTerminable
CompanyCategoryTerminableModel
CompanyChangedListener
CompanyChangedMenuListener
CompanyImporter
CompanyManager
CompanyMapper
CompanyPost
CompanyPostBaseModel
CompanyPostImporter
CompanyPostMapper
CompanyPostTerminable
CompanyPostTerminableInternational
CompanyPostTerminableInternationalModel
CompanyPostTerminableModel
CompanyTerminable
CompanyTerminableInternational
CompanyVersion
CompanyVersionBaseModel
CompanyVersionMapper
ConInfo
ConcreteHTTPActionEventHandler
Configuration
ConfigurationFactory
Counter
Cryption
DataNotFoundException
DataSourceProvider
DataStoreApplicationException
DataStoreConfigException
DataStoreSystemException
DatabaseAccessor
DatabaseManager
DatabaseSQLException
DayInfo
DbManager
DbsConnection
Delete
DeleteType
Department
DepartmentAttach
DepartmentAttachBaseModel
DepartmentAttachMapper
DepartmentAttachTerminable
DepartmentAttachTerminableModel
DepartmentBaseModel
DepartmentInclusionBaseModel
DepartmentInclusionMapper
DepartmentInfo
DepartmentMain
DepartmentMainBaseModel
DepartmentMainMapper
DepartmentMainTerminable
DepartmentMainTerminableModel
DepartmentMapper
DepartmentStruct
DepartmentTerminable
DepartmentTerminableInternational
DepartmentTerminableInternationalModel
DepartmentTerminableModel
Directory
DualComparator
DuplicateException
Entity
Environment
ErrorEvent
ErrorEventListener
ErrorPageProvider
EventListener
EventQueueController
EventScript
EverydayConditioner
ExpirationKey
ExtendedBaseAccessor
ExtendedBaseAccessorMap
ExtendedBaseModel
ExtendedBaseModel
ExtendedBaseModelMap
ExtendedBaseTable
ExtendedDirectory
ExtendedEntity
ExtendedFile
ExtendedGenericBaseModel
ExtendedGenericBaseModelMap
ExtendedGenericInternationalModel
ExtendedGenericInternationalModelMap
ExtendedGenericTerminableInternationalModel
ExtendedGenericTerminableInternationalModelMap
ExtendedGenericTerminableModel
ExtendedGenericTerminableModelMap
ExtendedInputStream
ExtendedInternationalAccessor
ExtendedInternationalAccessorMap
ExtendedInternationalModel
ExtendedInternationalModel
ExtendedInternationalModelMap
ExtendedInternationalTable
ExtendedModel
ExtendedOutputStream
ExtendedSocket
ExtendedTable
ExtendedTerminableAccessor
ExtendedTerminableAccessorMap
ExtendedTerminableInternationalAccessor
ExtendedTerminableInternationalAccessorMap
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModel
ExtendedTerminableInternationalModelMap
ExtendedTerminableInternationalTable
ExtendedTerminableModel
ExtendedTerminableModel
ExtendedTerminableModelMap
ExtendedTerminableTable
ExtendedThread
ExtendsImport
ExtendsImportManager
ExternalDirectory
ExternalMemory
FavoriteMenu
FileReporter
FileSender
FileSizeConditioner
FilterComparator
FilterHTTPActionEvent
FilterHTTPActionEventChain
FilterMessageReporter
FixedSizeMap
FoundationException
FoundationRuntimeException
FunctionContainer
FunctionContainerFile
GCConditioner
GarbageController
GenericBaseModel
GenericInternationalModel
GenericInternationalModelMap
GenericTerminableInternationalModel
GenericTerminableInternationalModelMap
GenericTerminableModel
GenericTerminableModelMap
GenericURLBuilder
GroupSecurityHTTPActionEventFilterHandler
GroupSuperUserAccessor
GroupSuperUserInitialServlet
GroupSuperUserPostWriterListener
GroupSuperUserQueryWriterListener
GroupSuperUserReaderDecorator
Grouping
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContent
HTTPActionEventContext
HTTPActionEventEntityHandler
HTTPActionEventException
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException
HTTPActionEventListenerContext
HTTPActionEventResult
HTTPActionEventResultWrapper
HTTPActionEventURL
HexInputStream
HexOutputStream
HomeDirectory
INonTransaction
Identifier
IllegalArgumentException
IllegalExtensionException
IllegalLocaleException
IllegalPasswordException
IllegalRelationshipException
IllegalTermException
ImportException
InitialFile
InputCheck
InternationalAccessor
InternationalAccessorMap
InternationalKey
InternationalModel
InternationalModel
InternationalModelContext
InternationalModelMap
InternationalTable
IntramartDBMapper
JavaMailPropertyException
JavaMailPropertyHandler
JavaMailSender
LDAPUserCertification
LicenseManager
Lifetime
LifetimeType
LimitedSessionHTTPActionEventFilterHandler
LineGraphDrawer
LineGraphObject
LineReportFilter
LocaleInfo
LocaleProvider
Localhost
Lock
LockMonitor
LoginGroup
LoginGroupAccessor
LoginGroupManager
LoginGroupPostWriterListener
LoginGroupQueryWriterListener
LoginGroupReaderDecorator
LoginInfo
LoginRequestInfo
Logingp
Mail
MailSender
MailSenderException
MainPageImportLoginGroupPostWriterListener
MainPagePatternInfo
ManagerException
Mapper
MapperDAOException
MapperException
MapperFactory
MenuAccessor
MenuExporter
MenuImporter
MenuInclusion
MenuItem
MenuManager
MenuPermissionSelector
MenuPostWriterListener
MenuQueryWriterListener
MenuReaderDecorator
MenuServlet
MenuTree
MessageManager
MessageReporter
Model
MultiCastReporter
MultiComparator
MultipartFormData
MultipartFormData.Entity
MultipurposeInternetMailExtensions
NetworkAgent
NetworkConnector
NetworkFile
NoCryption
NoFilterException
NoSessionCookieException
NoSessionException
NoSuchPropertyException
NodeNameComparator
NodeTypeComparator
NotExistException
NotFoundDataSourceException
NotSupportMethodException
OutputSizeConditioner
PasswordSecurityHTTPActionEventFilterHandler
PeriodicConditioner
PermanentDataArchiveFactory
PermanentDataDirectory
PermanentDirectory
PermanentFile
PermissionManager
PermissionSelector
PlainCompanyPost
Platform
PortFolioDrawer
PortFolioObject
PostInfo
PresentationFrameworkHTTPActionEventHandler
PresentationPage
PresentationPageHTTPActionEventHandler
PrimaryKeyMapping
PrintStreamReporter
PrivateGroup
PrivateGroupAttach
PrivateGroupAttachBaseModel
PrivateGroupAttachMapper
PrivateGroupBaseModel
PrivateGroupChangedListener
PrivateGroupManager
PrivateGroupMapper
ProcedureComponent
Profile
Property
PublicGroup
PublicGroupAttach
PublicGroupAttachBaseModel
PublicGroupAttachMapper
PublicGroupAttachTerminable
PublicGroupAttachTerminableModel
PublicGroupBaseModel
PublicGroupCategory
PublicGroupCategoryBaseModel
PublicGroupCategoryMapper
PublicGroupCategoryTerminable
PublicGroupCategoryTerminableModel
PublicGroupChangedListener
PublicGroupChangedMenuListener
PublicGroupImporter
PublicGroupInclusionBaseModel
PublicGroupInclusionMapper
PublicGroupInfo
PublicGroupManager
PublicGroupMapper
PublicGroupSet
PublicGroupSetBaseModel
PublicGroupSetMapper
PublicGroupSetTerminable
PublicGroupSetTerminableInternational
PublicGroupStruct
PublicGroupTerminable
PublicGroupTerminableInternational
PublicGroupTerminableInternationalModel
PublicGroupTerminableModel
PublicGroupVersion
PublicGroupVersionBaseModel
PublicGroupVersionMapper
RadarChartDrawer
RadarChartObject
Relationship
ReplaceWriter
ReportFileConditioner
ReportFileWriter
ReportLevel
ReportLevelFilter
RepresentativeReporter
RequestAnalyzer
RequestCharacterEncodingFilter
ResourceBundleProperties
ResourceFormatException
ResourceNotFoundException
ResponseCharacterEncodingFilter
ReverseComparator
Role
RoleAccessor
RoleChangedAccountListener
RoleChangedListener
RoleChangedMenuListener
RoleExporter
RoleImporter
RoleManager
RoleManager
RolePostWriterListener
RoleQueryWriterListener
RoleReaderDecorator
SSORequestAnalyzer
Scheduler
ScriptCompileException
ScriptRuntimeException
ScriptValue
SecurityConstraint
SequenceComparator
ServerConnector
ServiceFrameworkHTTPActionEventHandler
ServletHTTPActionEventHandler
SessionConfig
SessionFactory
SessionFilter
SessionInfo
SessionMemory
SessionQuery
SocketConnection
SocketConnectionDistributor
SocketConnectionDistributorFactory
SocketConnectionManager
SocketEventListener
SocketPool
StandardAccountBackup
StandardAdminMenuBackup
StandardBatchBackup
StandardCalendarBackup
StandardCompanyImporter
StandardCompanyPostImporter
StandardCryption
StandardErrorPageProvider
StandardGroupSuperUserPageProvider
StandardMail
StandardMenuBackup
StandardPublicGroupImporter
StandardRequestAnalyzer
StandardRoleBackup
StandardSuperUserCertification
StandardSuperUserPageProvider
StandardUserCertification
StandardUserImporter
StandardUserPageProvider
StorageDirectory
SuperCertification
SuperUser
SuperUserAccessor
SuperUserInitialServlet
SuperUserNoCertification
SuperUserPostWriterListener
SuperUserQueryWriterListener
SuperUserReaderDecorator
SystemConfigException
SystemErrorReporter
SystemManager
SystemReporter
SystemSourceProvider
Table
TemporaryDirectory
TemporaryFile
Term
TermManager
TermManagerException
TerminableAccessor
TerminableAccessorMap
TerminableInternationalAccessor
TerminableInternationalAccessorMap
TerminableInternationalModel
TerminableInternationalModel
TerminableInternationalModelContext
TerminableInternationalModelMap
TerminableInternationalTable
TerminableKey
TerminableModel
TerminableModel
TerminableModelContext
TerminableModelMap
TerminableTable
ThreadStopListener
TreasureDirectory
TreasureFile
TreeBranch
TreeLeaf
TreeNode
TreeNodeContainer
TreeNodeProvider
TreeRoot
URLAccessFilter
URLBuilder
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
UnsupportedNetworkConnectException
UpdateInfo
User
UserBaseModel
UserCertification
UserCertificationServlet
UserChangedListener
UserImporter
UserInitialServlet
UserManager
UserMapper
UserPageProvider
UserTerminable
UserTerminableInternational
UserTerminableInternationalModel
UserTerminableModel
VariableScope
WebApplicationHTTPActionEventHandler
XORInputStream
XOROutputStream


定数フィールド値 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.database.ConInfo
public static final String | TYPE_DATA_SOURCE | "DataSource"
public static final String | TYPE_GROUP | "Group"
public static final String | TYPE_JDBC | "Jdbc"
public static final String | TYPE_SYSTEM | "System"

jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | POST_CODE | "postCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
public static final String | ADDRESS1 | "address1"
public static final String | ADDRESS2 | "address2"
public static final String | COMPANY_CODE | "companyCode"
public static final String | COUNTRY_CODE | "countryCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | EMAIL_ADDRESS1 | "emailAddress1"
public static final String | EMAIL_ADDRESS2 | "emailAddress2"
public static final String | EXTENSION_FAX_NUMBER | "extensionFaxNumber"
public static final String | EXTENSION_NUMBER | "extensionNumber"
public static final String | FAX_NUMBER | "faxNumber"
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | TELEPHONE_NUMBER | "telephoneNumber"
public static final String | URL | "url"
public static final String | ZIP_CODE | "zipCode"

jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | DEPTH | "depth"
public static final String | PARENT_DEPARTMENT_CODE | "parentDepartmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | DEPARTMENT_CODE | "departmentCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | NAME | "name"
public static final String | NOTES | "notes"
public static final String | POST_CODE | "postCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
public static final String | COMPANY_CODE | "companyCode"
public static final String | END_DATE | "endDate"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | START_DATE | "startDate"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
public static final String | OWNER_CODE | "ownerCode"
public static final String | PRIVATE_GROUP_CODE | "privateGroupCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | OWNER_CODE | "ownerCode"
public static final String | PRIVATE_GROUP_CODE | "privateGroupCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | USER_CODE | "userCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
public static final String | CATEGORY_CLASS_CODE | "categoryClassCode"
public static final String | CATEGORY_CODE | "categoryCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"

jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
public static final String | DEPTH | "depth"
public static final String | PARENT_PUBLIC_GROUP_CODE | "parentPublicGroupCode"
public static final String | PUBLIC_GROUP_CODE | "publicGroupCode"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"

jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
public static final String | END_DATE | "endDate"
public static final String | NOTES | "notes"
public static final String | PUBLIC_GROUP_SET_CODE | "publicGroupSetCode"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | START_DATE | "startDate"
public static final String | VERSION_CODE | "versionCode"

jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
public static final String | ACCOUNT_FLAG | "accountFlag"
public static final String | ADDRESS | "address"
public static final String | AVALIABLE_LOGIN_USER | "1"
public static final String | COUNTRY_CODE | "countryCode"
public static final String | EMAIL_ADDRESS1 | "emailAddress1"
public static final String | EMAIL_ADDRESS2 | "emailAddress2"
public static final String | EXTENSION_FAX_NUMBER | "extensionFaxNumber"
public static final String | EXTENSION_NUMBER | "extensionNumber"
public static final String | FAX_NUMBER | "faxNumber"
public static final String | MOBILE_EMAIL_ADDRESS | "mobileEmailAddress"
public static final String | MOBILE_NUMBER | "mobileNumber"
public static final String | NAME | "name"
public static final String | NAME_ENGLISH | "nameEnglish"
public static final String | NAME_SYLLABARY | "nameSyllabary"
public static final String | NOTES | "notes"
public static final String | RECORD_DATE | "recordDate"
public static final String | RECORD_USER_CODE | "recordUserCode"
public static final String | SORT_KEY | "sortKey"
public static final String | TELEPHONE_NUMBER | "telephoneNumber"
public static final String | UNAVALIABLE_LOGIN_USER | "0"
public static final String | URL | "url"
public static final String | USER_CODE | "userCode"
public static final String | ZIP_CODE | "zipCode"

jp.co.intra_mart.foundation.security.SecurityConstraint
public static final String | ATTR_DO_FILTER | "jp.co.intr_mart.session.filter.do"
public static final String | CP_COOKIE | "jp.co.intra_mart.session.cookie"
public static final int | CR_ERROR | -7
public static final int | CR_LOCKED | -3
public static final int | CR_NG | 0
public static final int | CR_NO_GROUP | -2
public static final int | CR_NO_LICENSE | -1
public static final int | CR_NO_PERMISSION | -6
public static final int | CR_NO_USER | -8
public static final int | CR_OK | 1
public static final int | CR_SESSION_INITIAL | 2
public static final int | CR_SESSION_LOGON | 3
public static final int | CR_SESSION_TIMEOUT | -5
public static final int | CR_SESSION_UNMATCH | -4
public static final String | LT_GROUP | "group"
public static final String | LT_SUPER | "super"
public static final String | LT_USER | "user"
public static final String | RP_CLIENT_TYPE | "im_client_type"
public static final String | RP_ENCODING | "im_encoding"
public static final String | RP_INITIAL_URL | "im_initial_url"
public static final String | RP_LOCALE | "im_locale"
public static final String | RP_LOGIN_GROUP | "im_login_group"
public static final String | RP_LOGIN_TYPE | "im_login_type"
public static final String | RP_PASSWORD | "im_password"
public static final String | RP_URL | "im_url"
public static final String | RP_URL_SIGN | "im_url_sign"
public static final String | RP_USER | "im_user"
public static final String | SP_CLIENT_TYPE | "jp.co.intra_mart.session.client_type"
public static final String | SP_COLOR_PATTERN_ID | "jp.co.intra_mart.session.color_pattern_id"
public static final String | SP_ENCODING | "jp.co.intra_mart.session.encoding"
public static final String | SP_INITIAL_URL | "jp.co.intra_mart.session.initial.url"
public static final String | SP_LOCALE | "jp.co.intra_mart.session.locale"
public static final String | SP_LOGIN_GROUP | "jp.co.intra_mart.session.group"
public static final String | SP_LOGIN_TIME | "jp.co.intra_mart.session.login_time"
public static final String | SP_LOGIN_TYPE | "jp.co.intra_mart.session.login_type"
public static final String | SP_SIGNATURE | "jp.co.intra_mart.session.signature"
public static final String | SP_URL | "jp.co.intra_mart.session.url"
public static final String | SP_URL_SIGN | "jp.co.intra_mart.session.url.signature"
public static final String | SP_USER | "jp.co.intra_mart.session.user"

jp.co.intra_mart.foundation.security.SessionInfo
public static final String COOKIE_SEPARATOR "|"

jp.co.intra_mart.foundation.security.batch.Batch
public static final String | LANG_JAVA | "JAVA"
public static final String | LANG_JAVA_SCRIPT | "JavaScript"

jp.co.intra_mart.foundation.security.calendar.CalendarInfo
public static final String | TYPE_CONFIG | "config"
public static final String | TYPE_HOLIDAY | "holiday"
public static final String | TYPE_NATIONAL_HOLDAY | "nationalHoliday"
public static final String | TYPE_WEEKDAY | "weekday"

jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
public static final String | DEFAULT_AUTH_COOKIE_NAME | "comauth"
public static final String | DEFAULT_LOGIN_KEY | "comid"
public static final String | KEY_AUTH_COOKIE_NAME | "comauth"
public static final String | KEY_LOGIN_KEY | "comid"
public static final String | SSO_LOGOUT_URL | "sso-logout-url"

jp.co.intra_mart.foundation.security.exception.AccessSecurityException
public static final String | KIND_ROLE | "Role"
public static final String | KIND_ROLE_SUB | "SubRole"

jp.co.intra_mart.foundation.security.menu.MenuItem
public static final String | CONTENT_TYPE_IN | "in"
public static final String | CONTENT_TYPE_OUT | "out"
public static final String | MENU_TYPE_FOLDER | "folder"
public static final String | MENU_TYPE_ITEM | "item"

jp.co.intra_mart.foundation.security.role.StandardRoleBackup
public static final String KIND_ROLE "Role"

jp.co.intra_mart.foundation.service.client.NetworkConnector
protected static final int | GET | 32
protected static final int | GET_ENTIRETY | 34
protected static final int | GET_ENTIRETY_KEY | 40
protected static final int | GET_ITEM | 33
protected static final int | GET_ITEM_KEY | 36
protected static final int | GET_SUBSET | 35
protected static final int | MOVE | 128
protected static final int | MOVE_ENTIRETY | 130
protected static final int | MOVE_ITEM | 129
protected static final int | REMOVE | 64
protected static final int | REMOVE_ENTIRETY | 66
protected static final int | REMOVE_ITEM | 65
protected static final int | SET | 16
protected static final int | SET_ENTIRETY | 18
protected static final int | SET_ITEM | 17

jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_ACCOUNT "filter-security-account"

jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_GROUP "filter-security-group"

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_PASSWORD "filter-security-password"

jp.co.intra_mart.foundation.utility.report.ReportLevel
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | TYPE_DEBUG | 0
public static final int | TYPE_ERROR | 3
public static final int | TYPE_REPORT | 1
public static final int | TYPE_WARNING | 2

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


非推奨 API のリスト (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.foundation.utility.AbstractDualComparator
jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor
jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.AccountManager
jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.appcomn.Category
jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。
jp.co.intra_mart.foundation.utility.Counter
jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
jp.co.intra_mart.foundation.database.DbManager
DatabaseManagerを使用してください。
jp.co.intra_mart.foundation.utility.file.Directory
jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
jp.co.intra_mart.foundation.utility.ErrorEvent
jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
jp.co.intra_mart.foundation.utility.EventQueueController
jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.EverydayConditioner
jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
jp.co.intra_mart.foundation.utility.file.ExtendedFile
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.ExtendedSocket
jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
jp.co.intra_mart.foundation.utility.ExtendedThread
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FileReporter
jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FileSizeConditioner
jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.FilterComparator
jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.FilterMessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.FixedSizeMap
jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
jp.co.intra_mart.foundation.appcomn.Grouping
jp.co.intra_mart.foundation.utility.io.HexInputStream
jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.HexOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.LineReportFilter
jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.Localhost
jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
jp.co.intra_mart.foundation.utility.LockMonitor
jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.Logingp
jp.co.intra_mart.foundation.smtp.Mail
MailSenderに置き換えられました。
jp.co.intra_mart.foundation.utility.report.MultiCastReporter
jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.MultiComparator
jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner
jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.PeriodicConditioner
jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory
jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
jp.co.intra_mart.foundation.appcomn.Profile
jp.co.intra_mart.foundation.utility.io.ReplaceWriter
jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportFileWriter
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportLevelFilter
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.ResourceBundleProperties
jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
jp.co.intra_mart.foundation.utility.ReverseComparator
jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager
jp.co.intra_mart.foundation.utility.SequenceComparator
jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。
jp.co.intra_mart.foundation.http.SessionQuery
GenericURLBuilder および URLBuilder に置き替えられました。
jp.co.intra_mart.foundation.utility.net.SocketConnection
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketPool
jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.XORInputStream
jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
jp.co.intra_mart.foundation.utility.io.XOROutputStream
jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。

推奨されていないインタフェース
jp.co.intra_mart.foundation.database.DbsConnection
DatabaseManagerから取得したコネクションを使用してください。
jp.co.intra_mart.foundation.utility.DualComparator
jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
jp.co.intra_mart.foundation.utility.ErrorEventListener
jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.EventListener
jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.MessageReporter
jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
jp.co.intra_mart.foundation.utility.report.ReportLevel
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.SocketEventListener
jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。
jp.co.intra_mart.foundation.utility.ThreadStopListener
jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。

推奨されていない例外
jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。
jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。

推奨されていないメソッド
jp.co.intra_mart.foundation.acssecurity.AcsData.acntFromDBToIS(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.acntFromISToDB(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.client.batch.Scheduler.action(Object)
jp.co.intra_mart.foundation.service.client.file.NetworkFile.action(Object)
jp.co.intra_mart.foundation.service.client.information.PermanentFile.action(Object)
jp.co.intra_mart.foundation.service.client.information.PermanentDirectory.action(Object)
jp.co.intra_mart.foundation.service.client.information.Lock.action(Object)
jp.co.intra_mart.foundation.service.client.information.ExternalMemory.action(Object)
jp.co.intra_mart.foundation.service.client.information.ExternalDirectory.action(Object)
jp.co.intra_mart.foundation.appcomn.Category.addCategoryDetail(Map)
CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
jp.co.intra_mart.foundation.service.provider.GarbageController.addConditioner(GCConditioner)
jp.co.intra_mart.foundation.appcomn.Profile.addProfile(Map)
UserManager.addUser(User user) に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.addURL(String)
GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
jp.co.intra_mart.foundation.database.DbManager.contact()
代替えメソッドはありません。
jp.co.intra_mart.foundation.database.DbManager.contact(ConInfo)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.RoleManager.contains(String)
jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.contains(String)
jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.count()
jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.count()
LoginGroupManager.countLoginGroups()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.count()
jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.dateToString(Date)
DatabaseManager.dateToString(Date)を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.dbConsistChk(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.provider.HomeDirectory.definePath(String)
jp.co.intra_mart.foundation.acssecurity.Logingp.del(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllAccount(String)
AccountManager.deleteAccounts()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllLink(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllMenu(String)
MenuManager.deleteMenuItems()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllMessage(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllRole(String)
RoleManager.deleteRoles()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.delAllSchedule(String)
BatchManager.deleteBatches()に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.delAttachInfo(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.delData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.delData(String)
jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.delData(String, boolean)
jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.delData(String, boolean)
jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Category.deleteCategoryDetail(String, String)
CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.deleteData(String)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.deleteData(String, String[])
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.deletePostData(String, String)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Profile.deleteProfile(String)
UserManager.deleteUser(User user) に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.entries()
LoginGroupManager.getLoginGroupIds()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.Logingp.get(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.getAccount(String, String)
AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.appcomn.AppcomnException.getCode()
jp.co.intra_mart.foundation.database.DbManager.getConnectIDs()
DatabaseManager.getConnectIdsBySystem()を使用してください。
jp.co.intra_mart.foundation.database.DbManager.getConnectInfo()
代替えメソッドはありません。
jp.co.intra_mart.foundation.database.DbManager.getConnection()
DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.getData(String)
jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getIdByName(String)
jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getIDs()
jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.getIDs()
jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
jp.co.intra_mart.foundation.graph.RadarChartDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.PortFolioDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.LineGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.BarGraphDrawer.getImgaeBackgroundColor()
jp.co.intra_mart.foundation.graph.RadarChartDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.PortFolioDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.LineGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.graph.BarGraphDrawer.getImgaeBorderColor()
jp.co.intra_mart.foundation.acssecurity.AcsData.getLink(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getListData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.getMenu(String, String)
MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.appcomn.AppcomnException.getMessage()
jp.co.intra_mart.foundation.acssecurity.AcsData.getMessage(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.RoleManager.getParentData(String)
jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.getQuery()
代替えメソッドはありません。
jp.co.intra_mart.foundation.http.SessionQuery.getQueryName()
代替えメソッドはありません。
jp.co.intra_mart.foundation.http.SessionQuery.getQueryValue()
GenericURLBuilder.createFilePath(String) に置き替えられました。
jp.co.intra_mart.foundation.database.DbManager.getReference()
DatabaseManager.getConnectIdsBySystem()を使用してください。
jp.co.intra_mart.foundation.acssecurity.AcsData.getRole(String, String)
RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.getSchedule(String, String)
BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.getStruct(String)
CompnanyManager,PublicGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.insertData(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.insertData(Map, String[])
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.insertPostData(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.database.DbManager.isConnect()
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.Logingp.isGroup(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isValidDate(String, String, String)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isWeekDate(String, int)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.commons.validation.InputCheck.isWeekDate(String, Integer)
この関数は使用できません。次期バージョンにて削除されます。
jp.co.intra_mart.foundation.service.provider.GarbageController.removeConditioner(GCConditioner)
jp.co.intra_mart.foundation.acssecurity.Logingp.set(String, Number)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.Logingp.set(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setAccount(String, String)
AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.setAttachInfo(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.database.DbsConnection.setAutoCommit(boolean)
jp.co.intra_mart.foundation.acssecurity.RoleManager.setData(Map)
jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.setData(Map)
jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。
jp.co.intra_mart.foundation.acssecurity.RoleManager.setData(Map, boolean)
jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AccountManager.setData(Map, boolean)
jp.co.intra_mart.foundation.graph.RadarChartDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.PortFolioDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.LineGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.BarGraphDrawer.setImgaeBackgroundColor(Color)
jp.co.intra_mart.foundation.graph.RadarChartDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.PortFolioDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.LineGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.CircleGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.graph.BarGraphDrawer.setImgaeBorderColor(Color)
jp.co.intra_mart.foundation.acssecurity.AcsData.setLink(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setMenu(String, String)
MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.setMessage(String, String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.acssecurity.AcsData.setRole(String, String)
RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.acssecurity.AcsData.setSchedule(String, String)
BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery.setTo(String)
代替えメソッドはありません。
jp.co.intra_mart.foundation.service.provider.GarbageController.startAutomaticExecution(long)
gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
jp.co.intra_mart.foundation.service.provider.GarbageController.stopAutomaticExecution()
jp.co.intra_mart.foundation.database.DbManager.stringToDate(String)
DatabaseManager.stringToDate(String)を使用してください。
jp.co.intra_mart.foundation.appcomn.Category.updateCategoryDetail(Map)
CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.updateData(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.updateData(Map, String[])
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Grouping.updatePostData(Map)
CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
jp.co.intra_mart.foundation.appcomn.Profile.updateProfile(Map)
UserManager.updateUser(User user) に置き換えられました。

推奨されていないコンストラクタ
jp.co.intra_mart.foundation.acssecurity.AccountManager(String)
jp.co.intra_mart.foundation.database.DbManager(String)
DatabaseManagerを使用してください。
jp.co.intra_mart.foundation.acssecurity.Logingp(String)
LoginGroupManagerに置き換えられました。
jp.co.intra_mart.foundation.acssecurity.RoleManager(String)
jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
jp.co.intra_mart.foundation.http.SessionQuery(HttpServletRequest, HttpServletResponse)
GenericURLBuilder および URLBuilder に置き替えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


索引 (5.0 J2EE-Base Programing Model API Specifications)

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart(R)
5.0

前 次

フレームあり フレームなし

A B C D E F G H I J K L M N O P Q R S T U V W X Z

A

ACCOUNT_FLAG - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
アカウントフラグ
ADDRESS - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
住所
ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
住所1
ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
住所2
ATTR_DO_FILTER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションフィルター制御パラメータ名。
AVALIABLE_LOGIN_USER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ログインできるアカウントを表す定数
AbstractComponent - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent.
このクラスは、Storage Service で実行される ロジックを実装するためのスケルトンを提供します。
AbstractComponent() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent のコンストラクタ
唯一のコンストラクタ。
AbstractDrawer - class jp.co.intra_mart.foundation.drawer.AbstractDrawer.
画像ファイル出力用のスケルトンクラスです。
AbstractDrawer() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のコンストラクタ
唯一のコンストラクタ。
AbstractDualComparator - class jp.co.intra_mart.foundation.utility.AbstractDualComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator クラスを使用してください。
AbstractDualComparator() - class jp.co.intra_mart.foundation.utility.AbstractDualComparator のコンストラクタ
推奨されていません。 新しいオブジェクトを生成します。
AbstractMessageReporter - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter クラスを使用してください。
AbstractMessageReporter() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のコンストラクタ
推奨されていません。 唯一のコンストラクタ。
AbstractSocketConnectionDistributor - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor クラスを使用してください。
AbstractSocketConnectionDistributor(String, int) - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のコンストラクタ
推奨されていません。 ソケット作成オブジェクトを構築します。
AbstractTreeNodeContainer - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer.
ツリービューの子ノードを扱うためのメソッドを提供する抽象クラスです。
AbstractTreeNodeContainer() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のコンストラクタ
子ノードを追加順に並べる、新しいオブジェクトを生成します。
AbstractTreeNodeContainer(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のコンストラクタ
指定されたコンパレータに従って子ノードを並べる、新しいオブジェクトを生成します。
AccessSecurityConfigException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException.
アクセスセキュリティ設定に関する例外クラス。
AccessSecurityConfigException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityConfigException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException.
アクセスセキュリティ情報作成例外クラス。
AccessSecurityCreateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityCreateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException.
アクセスセキュリティ情報削除例外クラス。
AccessSecurityDeleteException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityDeleteException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException のコンストラクタ
コンストラクタ。
AccessSecurityException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityException.
アクセスセキュリティの基本となる例外クラス。
AccessSecurityException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException のコンストラクタ
コンストラクタ。
AccessSecurityExportException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException.
エクスポート時例外クラス。
AccessSecurityExportException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException のコンストラクタ
コンストラクタ。
AccessSecurityExportException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException のコンストラクタ
コンストラクタ。
AccessSecurityImportException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException.
インポート時例外クラス。
AccessSecurityImportException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException のコンストラクタ
コンストラクタ。
AccessSecurityImportException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion.
アクセスセキュリティリスナーの例外クラス。
AccessSecurityListenerExcpetion() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityListenerExcpetion(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion のコンストラクタ
コンストラクタ。
AccessSecurityManager - class jp.co.intra_mart.foundation.security.AccessSecurityManager.
アクセスセキュリティマネージャクラス。
AccessSecurityReadException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException.
アクセスセキュリティ情報の取得例外クラス。
AccessSecurityReadException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityReadException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException.
アクセスセキュリティランタイム例外クラス。
AccessSecurityRuntimeException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException.
アクセスセキュリティ情報更新例外クラス。
AccessSecurityUpdateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityUpdateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException - exception jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException.
アクセスセキュリティ情報の更新例外クラス。
AccessSecurityWriteException() - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(String) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessSecurityWriteException(Throwable) - class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException のコンストラクタ
コンストラクタ。
AccessibleLinkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler.
再接続の為のＵＲＬを制御するフィルタ実装です。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のコンストラクタ
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
AccessorClosedException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException.
アクセサのクローズ時に発生する例外クラス

アクセサがクローズされている場合に、以下のメソッドを呼び出された時にスローする。
AccessorClosedException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorClosedException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException のコンストラクタ
コンストラクタ
AccessorException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorException.
アクセサで発生する例外の基底クラス
AccessorException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException.
アクセサのプロパティ設定に関する例外クラス

アクセサに不正な値が設定された場合にスローする。
AccessorIllegalPropertyValueException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorIllegalPropertyValueException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException のコンストラクタ
コンストラクタ
AccessorSystemException - exception jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException.
アクセサのプロパティに関する例外クラス

指定されたプロパティがアクセサに存在しない場合にスローする。
AccessorSystemException() - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
AccessorSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException のコンストラクタ
コンストラクタ
Account - class jp.co.intra_mart.foundation.security.account.Account.
アカウントモデル。
Account(String) - class jp.co.intra_mart.foundation.security.account.Account のコンストラクタ
コンストラクタ。
AccountAccessor - interface jp.co.intra_mart.foundation.security.account.AccountAccessor.
アカウントアクセッサインタフェース。
AccountChangedListener - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener.
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountExporter - interface jp.co.intra_mart.foundation.security.account.AccountExporter.
アカウントエクスポートインタフェースです。
AccountImporter - interface jp.co.intra_mart.foundation.security.account.AccountImporter.
アカウントインポートインタフェースです。
AccountManager - class jp.co.intra_mart.foundation.acssecurity.AccountManager.
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManagerに置き換えられました。
AccountManager(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のコンストラクタ
推奨されていません。
AccountManager - class jp.co.intra_mart.foundation.security.account.AccountManager.
アカウントマネージャクラス。
AccountManager(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のコンストラクタ
コンストラクタ。
AccountPostWriterListener - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener.
アカウント情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AccountQueryWriterListener - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener.
アカウント情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AccountReaderDecorator - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator.
アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AccountRole - class jp.co.intra_mart.foundation.security.account.AccountRole.
アカウント用ロールモデル。
AccountRole(String) - class jp.co.intra_mart.foundation.security.account.AccountRole のコンストラクタ
コンストラクタ。
AccountRolePermissionSelector - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector.
ユーザIDから有効なすべてのロールを取得するセレクタ。
AccountRolePermissionSelector() - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のコンストラクタ
コンストラクタ。
AccountSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AcsData - class jp.co.intra_mart.foundation.acssecurity.AcsData.
推奨されていません。
AcsData() - class jp.co.intra_mart.foundation.acssecurity.AcsData のコンストラクタ
推奨されていません。
AcssecurityException - exception jp.co.intra_mart.foundation.acssecurity.AcssecurityException.
アクセスセキュリティ情報操作時にエラーが発生した場合にスローされます。
ActionListener - interface jp.co.intra_mart.foundation.service.client.ActionListener.
このクラスは、主にイベントにより処理されるリスナーを実装する ためのスケルトンを提供します。
ActivationKey - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey.
ライフタイム期間の有効開始日時を定義します。
ActivityFrameworkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler.
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のコンストラクタ
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
ActivityHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler.
持続したセッションを確立するためのハンドラです。
ActivityHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。
AdminMenuAccessor - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor.
メニューアクセッサインタフェース。
AdminMenuExporter - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter.
メニューエクスポートインタフェースです。
AdminMenuImporter - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter.
メニューインポートインタフェースです。
AdminMenuInclusion - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion.
メニュー内包情報クラス。
AdminMenuInclusion(String, String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のコンストラクタ
コンストラクタ。
AdminMenuManager - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager.
管理メニューマネージャクラス。
AdminMenuPostWriterListener - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener.
メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
AdminMenuQueryWriterListener - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener.
メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
AdminMenuReaderDecorator - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator.
メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
AdvancedOutputStreamWriter - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter クラスを使用してください。
AdvancedOutputStreamWriter(OutputStream, String) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, Charset) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, CharsetEncoder) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のコンストラクタ
推奨されていません。 OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
AppcomnException - exception jp.co.intra_mart.foundation.appcomn.AppcomnException.
アプリケーション共通マスタの情報操作時にエラーが発生した場合にスローされます。
Application - interface jp.co.intra_mart.foundation.datastore.common.config.Application.
アプリケーションを定義します。
ApplicationInfo - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo.
アプリケーション情報のインタフェース。
Attribute - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute.
属性を定義します。
AttributeType - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType.
属性で指定できる型です。
accountAdded(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
accountDeleted(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
accountRoleAdded(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
accountRoleDeleted(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
accountRoleUpdated(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
accountUpdated(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
acntFromDBToIS(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
acntFromISToDB(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
action(Object) - interface jp.co.intra_mart.foundation.service.client.ActionListener のメソッド
このメソッドは、特定のイベント発生時に実行されます。
action(Object) - class jp.co.intra_mart.foundation.service.client.NetworkAgent のメソッド
このオブジェクトの実行ロジック。
action(Object) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
推奨されていません。
action(Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
推奨されていません。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent のメソッド
イベント処理メソッドです。
activeCount() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 現在取得済みモニターの数を取得します。
addAccount(Account) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを新規追加します。
addAccountRole(String, AccountRole) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを新規追加します。
addAttachment(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを追加します。
addBatch(Batch) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を新規登録します。
addBcc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addBcc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addCalendarInfo(String, CalendarInfo) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを新規に追加します。
addCategoryDetail(Map) - class jp.co.intra_mart.foundation.appcomn.Category のメソッド
推奨されていません。 CategoryManager.addCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
addCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
分類区分詳細を登録します。
addCc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addCc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addChild(MenuTree) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューを追加します。
addChildBranch(TreeBranch) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたブランチ branchを子ノードとして追加します。
addChildLeaf(TreeLeaf) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたリーフ leafを子ノードとして追加します。
addChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード node を子ノードとして追加します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCompany(Company) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社を登録します。
addComparator(Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 指定されたコンパレータ comparator を追加します。
addConditioner(GCConditioner) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
addConditioner(ReportFileConditioner) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
addCreateSocketEventListener(SocketEventListener) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
addData(BarGraphObject) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, BarGraphObject) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値を追加します。
addData(CircleGraphObject) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, CircleGraphObject) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(LineGraphObject) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, LineGraphObject) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値を追加します。
addData(PortFolioObject) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, PortFolioObject) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(RadarChartObject) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
描画オブジェクトに新しいデータを追加します。
addData(int, RadarChartObject) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
指定された位置に、指定された描画オブジェクトを追加します。
addData(double) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値を追加します。
addData(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値を追加します。
addDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織を登録します。
addFavoriteMenu(String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを新規追加します。
addGroupSet(PublicGroupSet) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループセットを登録します。
addHeader(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ヘッダーを追加します。
addListener(EventListener) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
リスナーを登録します。
addLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループを新規追加します。
addMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを新規追加します。
addMenuDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織をメニューに紐付けます。
addMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを追加します。
addMenuItem(String, MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを追加します。
addMenuPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役職をメニューに紐付けます。
addMenuPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループをメニューに紐付けます。
addMenuRole(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールをメニューに紐付けます。
addPost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
役職を登録します。
addPrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループを登録します。
addProfile(Map) - class jp.co.intra_mart.foundation.appcomn.Profile のメソッド
推奨されていません。 UserManager.addUser(User user) に置き換えられました。
addPublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループを登録します。
addReplyTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ReplyToを追加します。
addReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
addRole(Role) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を新規登録します。
addSubRole(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
サブロールIDを追加します。
addSuperUser(SuperUser) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を新規に作成します。
addSuperUser(String, SuperUser) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者を新規追加します。
addThreadStopListener(ThreadStopListener) - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
addTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addTo(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addURL(String) - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 GenericURLBuilder.createFilePath(String) および URLBuilder.createURLonSession(String)に置き替えられました。
addUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
ユーザを登録します。
addVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社構成バージョンを新規に登録します。
addVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループセット構成バージョンを新規に登録します。
append(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにテキストを追記します。
append(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(byte[]) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
archive(File) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(File, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(OutputStream) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(OutputStream, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream, FileFilter) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
attachFile(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 添付ファイルの内容をセットする。

B

BASE64DecodeInputStream - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream クラスを使用してください。
BASE64DecodeInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のコンストラクタ
推奨されていません。 指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
BASE64DecodeOutputStream - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream クラスを使用してください。
BASE64DecodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
BASE64EncodeOutputStream - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream クラスを使用してください。
BASE64EncodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BarGraphDrawer - class jp.co.intra_mart.foundation.graph.BarGraphDrawer.
棒グラフを描画します。
BarGraphDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で棒グラフを作成します。
BarGraphDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現で棒グラフを作成します。
BarGraphObject - class jp.co.intra_mart.foundation.graph.BarGraphObject.
BarGraphDrawerクラスのデータを保存するオブジェクトです。
BarGraphObject() - class jp.co.intra_mart.foundation.graph.BarGraphObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
BarGraphObject(Color) - class jp.co.intra_mart.foundation.graph.BarGraphObject のコンストラクタ
線の色を指定して、データオブジェクトを作成します。
BaseAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor.
基本エンティティに対する情報操作用のインタフェースです。
BaseModel - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel.
基本モデルを定義します。
BaseModel - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel.
基本モデルの情報です。
BaseModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext.
基本モデルの初期化に必要な設定を持ちます。
BaseTable - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable.
基本テーブルを定義します。
Batch - class jp.co.intra_mart.foundation.security.batch.Batch.
バッチ・モデルクラス
Batch() - class jp.co.intra_mart.foundation.security.batch.Batch のコンストラクタ
コンストラクタ。
Batch(String) - class jp.co.intra_mart.foundation.security.batch.Batch のコンストラクタ
コンストラクタ。
BatchAccessor - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor.

BatchExporter - interface jp.co.intra_mart.foundation.security.batch.BatchExporter.
バッチバックアップインタフェースです。
BatchImporter - interface jp.co.intra_mart.foundation.security.batch.BatchImporter.
バッチバックアップインタフェースです。
BatchManager - class jp.co.intra_mart.foundation.security.batch.BatchManager.
バッチマネージャクラス。
BatchManager(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のコンストラクタ
コンストラクタ。
BatchPostWriterListener - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener.

BatchQueryWriterListener - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener.

BatchReaderDecorator - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator.

backup(File) - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
このデータを指定のファイルにバックアップします。
begin() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
begin(long) - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックフラグを立てます。
beginTransaction() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースアクセスのトランザクションを開始します。
beginTransaction() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースアクセスのトランザクションを開始します。
booleanValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の真偽値表現を取得します。

C

CASCADE - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
削除 ターゲットエンティティのデータを参照しているソースエンティティのデータを削除します。
CASCADE - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
削除 ターゲットエンティティの期間を参照しているソースエンティティのデータを削除します。
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
分類区分コード
CATEGORY_CLASS_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
分類区分コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
分類コード
CATEGORY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
分類コード
CGIEnvironment - class jp.co.intra_mart.foundation.http.CGIEnvironment.
このクラスは、サーブレットクラス内で CGI 環境変数を扱えるように 各パラメータを CGI 環境変数で定義されているキーワードにマップします。
CGIEnvironment(HttpServletRequest) - class jp.co.intra_mart.foundation.http.CGIEnvironment のコンストラクタ
HTTP リクエストヘッダおよび Web サーバ情報から CGI 環境変数情報を構築します。
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
会社コード
COMPANY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
会社コード
CONTENT_TYPE_IN - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニューコンテンツの種類（内部URL）。
CONTENT_TYPE_OUT - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニューコンテンツの種類（外部URL）。
COOKIE_SEPARATOR - interface jp.co.intra_mart.foundation.security.SessionInfo の static 変数
セッション情報をクッキーに保管する際のセパレータ。
COUNTRY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
国コード
COUNTRY_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
国コード
CP_COOKIE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション情報をクッキーに保管するパラメータ名。
CR_ERROR - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証処理エラーの返却値。
CR_LOCKED - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
アカウントロック状態の返却値。
CR_NG - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエラーの返却値。
CR_NO_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループ未登録状態の返却値。
CR_NO_LICENSE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ライセンスなし、または有効期間外状態の返却値。
CR_NO_PERMISSION - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
無許可ページへのアクセスの返却値。
CR_NO_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ユーザ未登録状態の返却値。
CR_OK - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証成功の返却値。
CR_SESSION_INITIAL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション初期状態の返却値。
CR_SESSION_LOGON - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションログオン状態の返却値。
CR_SESSION_TIMEOUT - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッションタイムアウト状態の返却値。
CR_SESSION_UNMATCH - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
セッション不整合状態の返却値。
CalendarAccessor - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor.
カレンダーアクセッサインタフェース。
CalendarExporter - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter.
カレンダーバックアップインタフェースです。
CalendarImporter - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter.
カレンダーバックアップインタフェースです。
CalendarInfo - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo.
カレンダーデータ・モデルクラス
CalendarInfo() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のコンストラクタ
コンストラクタ。
CalendarInfo(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のコンストラクタ
コンストラクタ。
CalendarManager - class jp.co.intra_mart.foundation.security.calendar.CalendarManager.
カレンダーマネージャクラス

カレンダー情報の操作を行います。
CalendarManager(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のコンストラクタ
コンストラクタ。
CalendarPlugin - interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin.
カレンダデータプラグインインターフェース。
CalendarPluginAutumnalEquinox - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox.
カレンダデータプラグインクラス。
CalendarPluginAutumnalEquinox() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox のコンストラクタ

CalendarPluginEndOfTheMonth - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth.
カレンダデータプラグインクラス。
CalendarPluginEndOfTheMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth のコンストラクタ

CalendarPluginInfo - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo.
カレンダーデータプラグイン情報のインターフェース。
CalendarPluginLastDayInTheMonth - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth.
カレンダデータプラグインクラス。
CalendarPluginLastDayInTheMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth のコンストラクタ

CalendarPluginMondayMakeupHoliday - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday.
カレンダデータプラグインクラス。
CalendarPluginMondayMakeupHoliday() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday のコンストラクタ

CalendarPluginVernalEquinox - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox.
カレンダデータプラグインクラス。
CalendarPluginVernalEquinox() - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox のコンストラクタ

CalendarPostWriterListener - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener.
カレンダー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
CalendarQueryWriterListener - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener.
カレンダー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
CalendarReaderDecorator - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator.
アカウント情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
CategorizedCalendarInfo - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo.
カテゴライズカレンダーデータクラス。
CategorizedCalendarInfo(CalendarInfo[]) - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のコンストラクタ
コンストラクタ。
Category - class jp.co.intra_mart.foundation.appcomn.Category.
推奨されていません。
Category(String) - class jp.co.intra_mart.foundation.appcomn.Category のコンストラクタ
推奨されていません。 コンストラクタ
CategoryDetail - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail.
分類区分詳細の基本属性のデータを取り扱います。
CategoryDetail() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のコンストラクタ

CategoryDetailBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel.
分類区分詳細の基本モデルです。
CategoryDetailInternational - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational.
分類区分詳細の国際化属性のデータを取り扱います。
CategoryDetailInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のコンストラクタ

CategoryDetailInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel.
分類区分詳細の国際化モデルです。
CategoryDetailMapper - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper.
分類区分詳細に関連するマッパです。
CategoryManager - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager.
分類に関連する情報を管理します。
CategoryManager() - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のコンストラクタ

CateogryClass - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass.
分類区分の基本属性のデータを取り扱います。
CateogryClass() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のコンストラクタ

CateogryClassBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel.
分類区分の基本モデルです。
CateogryClassInternational - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational.
分類区分の国際化属性のデータを取り扱います。
CateogryClassInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のコンストラクタ

CateogryClassInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel.
分類区分の国際化モデルです。
CateogryClassMapper - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper.
分類区分に関連するマッパです。
ChangedListenerException - exception jp.co.intra_mart.foundation.exception.ChangedListenerException.
更新リスナーの例外クラス。
ChangedListenerException() - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(String) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(Throwable) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
ChangedListenerException(String, Throwable) - class jp.co.intra_mart.foundation.exception.ChangedListenerException のコンストラクタ
コンストラクタ。
CharacterEncoder - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスを使用してください。
CharacterEncoder(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のコンストラクタ
推奨されていません。 文字コード変換のためのエンコーダを作成します。
CircleGraphDrawer - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer.
円グラフを描画します。
CircleGraphDrawer() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で円グラフを作成します。
CircleGraphObject - class jp.co.intra_mart.foundation.graph.CircleGraphObject.
CircleGraphDrawerクラスのデータを保存するオブジェクトです。
CircleGraphObject(double, Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(int, Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色を指定して、データオブジェクトを作成します。
CircleGraphObject(double, Color, String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
CircleGraphObject(int, Color, String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のコンストラクタ
グラフ値と色とキャプションを指定して、データオブジェクトを作成します。
ClientTypeInfo - interface jp.co.intra_mart.foundation.security.ClientTypeInfo.
クライアントタイプ情報インタフェース。
ColorPatternInfo - interface jp.co.intra_mart.foundation.security.ColorPatternInfo.
カラーパターン情報を取得するインタフェース。
Column - interface jp.co.intra_mart.foundation.datastore.common.config.Column.
属性に対応するカラムの型を定義します。
ColumnMapping - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping.
分割されたテーブルに割り当てられるカラムを定義します。
Company - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company.
会社の基本属性のデータを取り扱います。
Company() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のコンストラクタ

CompanyBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel.
会社の基本モデルです。
CompanyCategory - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory.
会社組織分類の基本属性のデータを取り扱います。
CompanyCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のコンストラクタ

CompanyCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel.
会社組織分類の基本モデルです。
CompanyCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper.
会社組織分類に関連するマッパです。
CompanyCategoryTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable.
会社組織分類の期間化属性のデータを取り扱います。
CompanyCategoryTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable のコンストラクタ

CompanyCategoryTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel.
会社組織分類の期間化モデルです。
CompanyChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のコンストラクタ

CompanyImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter.
会社のインポートのインターフェースです。
CompanyManager - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager.
会社や組織に関連する情報を管理します。
CompanyManager() - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のコンストラクタ

CompanyMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper.
会社に関連するマッパです。
CompanyPost - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost.
役職の基本属性のデータを取り扱います。
CompanyPost() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のコンストラクタ

CompanyPostBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel.
役職の基本モデルです。
CompanyPostImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter.
役職のインポートのインターフェースです。
CompanyPostMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper.
役職に関連するマッパです。
CompanyPostTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable.
役職の期間化属性のデータを取り扱います。
CompanyPostTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のコンストラクタ

CompanyPostTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational.
役職の期間国際化属性のデータを取り扱います。
CompanyPostTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のコンストラクタ

CompanyPostTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel.
役職の期間国際化モデルです。
CompanyPostTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel.
役職の期間化モデルです。
CompanyTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable.
会社の期間化属性のデータを取り扱います。
CompanyTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のコンストラクタ

CompanyTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational.
会社の期間国際化属性のデータを取り扱います。
CompanyTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のコンストラクタ

CompanyVersion - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion.
会社構成バージョンの基本属性のデータを取り扱います。
CompanyVersion() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のコンストラクタ

CompanyVersionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel.
会社構成バージョンの基本モデルです。
CompanyVersionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper.
会社構成バージョンに関連するマッパです。
ConInfo - interface jp.co.intra_mart.foundation.database.ConInfo.

ConcreteHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler.
任意の HTTPActionEvent を実行するためのハンドラです。
ConcreteHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のコンストラクタ
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
Configuration - interface jp.co.intra_mart.foundation.datastore.common.config.Configuration.
設定内容を取得します。
ConfigurationFactory - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory.
Configurationを生成します。
ConfigurationFactory() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory のコンストラクタ

Counter - class jp.co.intra_mart.foundation.utility.Counter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.Counter クラスを使用してください。
Counter() - class jp.co.intra_mart.foundation.utility.Counter のコンストラクタ
推奨されていません。 カウンターオブジェクトを作成します。
Counter(long) - class jp.co.intra_mart.foundation.utility.Counter のコンストラクタ
推奨されていません。 指定の初期値でカウンターオブジェクトを作成します。
Cryption - interface jp.co.intra_mart.foundation.security.cryption.Cryption.
文字列の暗号化・復号化インタフェース。
canReport() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 このストリームが書き込み可能かどうかをチェックします。
capacity() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このマップに対してマップできるキーの最大個数を返します。
categoryDetailRemoved(String, CompanyCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, CompanyCategory) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のメソッド
ユーザを認証する。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のメソッド
管理者を認証します。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のメソッド
ユーザを認証します。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.SuperCertification のメソッド
管理者を認証する。
certification(LoginInfo, SuperUser, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のメソッド
管理者を認証します。
certification(LoginInfo, Account, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserCertification のメソッド
ユーザを認証する。
certify(String[], String[]) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール内包を認証します。
checkByBaseProperty(Relationship[], BaseModel, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基準項目によるリレーションシップの整合性制約をチェックします。
checkByBaseProperty(Relationship[], BaseModel, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
基準項目によるリレーションシップの整合性制約をチェックします。
checkDigitOfNumber(Number, int, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値の整数部、小数部の桁数チェック。
checkDigitOfNumber(Number, Integer, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値の整数部、小数部の桁数チェック（引数がクラス版）。
checkDigitOfNumberString(String, int, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値（文字型）の整数部、小数部の桁数チェック
※数値かどうかのチェックも行う。
checkDigitOfNumberString(String, Integer, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値（文字型）の整数部、小数部の桁数チェック（引数がクラス版）

childDirectories() - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
childDirectory(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
childFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
childFiles() - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
childPath(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
clean() - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
システムのガベージコレクタを実行します。
clean() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 プール中のコネクションをすべて破棄します。
cleanUp() - interface jp.co.intra_mart.foundation.service.provider.GCConditioner のメソッド
gc を実行するかどうかを判断します。
clear() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
すべてのデータを削除します。
clear() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
すべての値を削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを削除します。
clear() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
すべてのデータを削除します。
clear() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
このオブジェクトのマップからマッピングをすべて削除します。
clear() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 マップからマッピングをすべて削除します。
clearError() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
clearInstance() - class jp.co.intra_mart.foundation.security.AccessSecurityManager の static メソッド
アクセスセキュリティマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
システムマネージャのインスタンスを初期化を行います。
clearInstance() - class jp.co.intra_mart.foundation.security.account.AccountManager の static メソッド
アカウントマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.batch.BatchManager の static メソッド
バッチマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager の static メソッド
カレンダーマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager の static メソッド
ログイングループマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager の static メソッド
ログイングループマネージャのインスタンスを初期化します。
clearInstance() - class jp.co.intra_mart.foundation.security.menu.MenuManager の static メソッド
メニューマネージャのインスタンスを初期化します。
clearWarnings() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトに関して通知されたすべての警告をクリアします。
close() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 releaseメソッドと同等です。
close() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーをクローズします。
close() - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーをクローズします。
close() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
ネットワークを切断します。
close() - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.HexInputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 ストリームを閉じます。
close() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 このオブジェクトを閉じます。
close() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 ストリームを閉じます。
commit() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースのトランザクションをコミットします。
commit() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースのトランザクションをコミットします。
commit() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスの確定処理を行います。
companyAdded(String, Company) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyAdded(String, Company) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社情報がデータストアに登録された後に呼び出されます。
companyDeleted(String, Company) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
companyDeleted(String, Company) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社情報がデータストアから削除された後に呼び出されます。
compare(Object, Object) - class jp.co.intra_mart.foundation.page.NodeNameComparator のメソッド
順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
順序付けのために 2 つの引数を比較します。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.AbstractDualComparator のメソッド
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.FilterComparator のメソッド
推奨されていません。 順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.ReverseComparator のメソッド
推奨されていません。 フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
compare(Object, Object) - class jp.co.intra_mart.foundation.utility.SequenceComparator のメソッド
推奨されていません。 順序付けのために ２ つの引数を比較するメソッドです。
compareTo(Object) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
この期間と指定された期間を比較します。
compileReader(Reader) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトのソースをコンパイルします。
compileString(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトのソースをコンパイルします。
connection() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
サーバに接続するためのコネクションを取得します。
connection() - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のメソッド
サーバに接続するためのコネクションを取得します。
connection() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 コネクションの取得。
connection() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 コネクションの取得。
contact(ConInfo) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 代替えメソッドはありません。
contact() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
contains(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.contains(String)に置き換えられました。
contains(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.contains(String)に置き換えられました。
contains(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントの存在チェックを行います。
contains(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールの存在チェックを行います。
containsCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーの存在チェックをします。
containsDate(Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
指定された日時が期間内に入っているかどうかを指定します。
containsHeader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
指定された文字列がヘッダの名称かどうかを判定します。
containsKey(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
copyVersion(String, String, String, Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンの内容をコピーします。
copyVersion(String, String, String, Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーします。
count() - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.count()に置き換えられました。
count() - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 LoginGroupManager.countLoginGroups()に置き換えられました。
count() - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.count()に置き換えられました。
count() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントの登録数を取得します。
count() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール数を取得します。
countByCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーに属するロール数を取得します。
countLoginGroups() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ数を取得します。
counter - class jp.co.intra_mart.foundation.page.EventScript の static 変数
このクラスからインスタンスが生成された回数。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
プライマリキーに該当する分類区分を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
プライマリキーに該当する分類区分詳細を生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
プライマリキーに該当する組織所属を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
プライマリキーに該当する会社組織分類を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
プライマリキーに該当する会社を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
プライマリキーに該当する組織を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
プライマリキーに該当する組織内包を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
プライマリキーに該当する主所属を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
プライマリキーに該当する役職を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
プライマリキーに該当する会社構成バージョンを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライマリキーに該当するプライベートグループ所属を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライマリキーに該当するプライベートグループを生成します。
create(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
プライマリキーに該当するパブリックグループ所属を生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
プライマリキーに該当するパブリックグループ分類を生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
プライマリキーに該当するパブリックグループを生成します。
create(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
プライマリキーに該当するパブリックグループ内包を生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
プライマリキーに該当するパブリックグループセットを生成します。
create(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
プライマリキーに該当するパブリックグループ構成バージョンを生成します。
create(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
プライマリキーに該当するユーザを生成します。
createBaseAccessor(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
このマッパーに該当する基本アクセサを新規に生成します。
createBaseModel(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
このマッパーに該当する基本モデルを新規に生成します。
createBaseModel(Map) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
このマッパーに該当する基本モデルを新規に生成します。
createConfiguration() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory のメソッド
Configurationを生成します。
createExtendedBaseAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を生成します。
createExtendedBaseModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
createExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を生成します。
createExtendedInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を生成します。
createExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
createExtendedInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を生成します。
createExtendedTerminableAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を生成します。
createExtendedTerminableInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を生成します。
createExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
createExtendedTerminableInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を生成します。
createExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
createExtendedTerminableModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を生成します。
createFilePath(String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
指定のページパスからリンクの為のページパスを作成して返します。
createImage(Graphics) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
棒グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
円グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
折れ線グラフを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ポートフォリオを描画します。
createImage(Graphics) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
レーダーチャートを描画します。
createInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
国際化アクセサを生成します。
createInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
国際化モデルを生成します。
createInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
国際化モデルを生成します。
createLoginRequestInfo(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン情報を作成します。
createMapper(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory のメソッド
マッパーを生成します。
createRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を新規に追加する。
createSocket() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 新しいソケットを作成します。
createSocketConnectionDistributor(String) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のメソッド
Server-Manager に接続するためのネットワークコネクション管理 オブジェクトを取得します。
createStatement() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SQL 文をデータベースに送るための Statement オブジェクトを生成します。
createStatement(int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
createStatement(int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型、並行処理、および holdability で ResultSet オブジェクトを生成する Statement オブジェクトを生成します。
createTerminableAccessor(Term) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定した期間に期間化アクセサを生成します。
createTerminableInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
期間国際化アクセサを生成します。
createTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
期間国際化モデルを生成します。
createTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
期間国際化モデルを生成します。
createTerminableModel(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定した期間を満たす期間化モデルを生成します。
createTerminableModel(Term) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定した期間を満たす期間化モデルを生成します。
createURL(String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のリクエストを元にして、指定の画面へリンクするための URL を作成します。
createURL(URL, String) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
指定の URL を仕様解析のコンテキストとして ページベース開発モデルの画面への URL を解決した URL を返します。
createURLonSession(String) - class jp.co.intra_mart.jssp.net.URLBuilder のメソッド
HTTP セッションを維持したまま指定のページベース開発モデルの画面へ リンクするための URL を返します。
createURLonSession(URL, String) - class jp.co.intra_mart.jssp.net.URLBuilder のメソッド
HTTP セッションを維持したまま指定のページベース開発モデルの画面へ リンクするための URL を返します。
createUrlSignature(String, String, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ダイレクトＵＲＬ署名を作成します。
createWriter(OutputStreamWriter) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter の static メソッド
推奨されていません。 AdvancedOutputStreamWriter のスーパークラス AdvancedOutputStreamWriter を作成します。
createWriter() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 メッセージをファイルへ書き出すための出力ストリームを作成します。
currentWriter() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトが文字を書き出している基礎 Writer を返します。

D

DATE - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
日時型
DECIMAL - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
整数型
DEFAULT_AUTH_COOKIE_NAME - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_BOTTOM_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の下部マージン
DEFAULT_CAPTION_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のキャプション表示位置のマージン
DEFAULT_CAPTION_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のキャプション表示位置のマージン
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の背景色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域のボーダー色
DEFAULT_GRAPH_FRAME_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ枠の線色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BACKGROUND_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準の画像ファイル背景色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_IMAGE_BORDER_COLOR - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準の画像ファイルのボーダ色
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LEFT_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の左側マージン
DEFAULT_LOGIN_KEY - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_RIGHT_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の右側マージン
DEFAULT_STROKE - class jp.co.intra_mart.foundation.graph.LineGraphObject の static 変数

DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.BarGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.LineGraphDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
標準のグラフ領域の上部マージン
DEFAULT_TOP_MARGIN - class jp.co.intra_mart.foundation.graph.RadarChartDrawer の static 変数
標準のグラフ領域の上部マージン
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
組織コード
DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
組織コード
DEPTH - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
階層レベル
DEPTH - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
階層レベル
DataNotFoundException - exception jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException.
アクセサのプロパティ値の取得に関する例外クラス

指定されたプロパティに対する値が設定されていない場合にスローする。
DataNotFoundException() - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataNotFoundException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException のコンストラクタ
コンストラクタ
DataSourceProvider - interface jp.co.intra_mart.foundation.database.DataSourceProvider.
データソース設定情報取得プロバイダインタフェース。
DataStoreApplicationException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException.
アプリケーション共通マスタで発生するアプリケーション例外の基底クラス
DataStoreApplicationException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreApplicationException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のコンストラクタ
コンストラクタ
DataStoreConfigException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException.
アプリケーション共通マスタの設定に関する例外クラス

アプリケーション共通マスタの設定に不整合がある場合にスローする。
DataStoreConfigException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
詳細メッセージを指定しないで DataStoreConfigException を構築します。
DataStoreConfigException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
指定された詳細メッセージを持つ DataStoreConfigException を構築します。
DataStoreConfigException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreConfigException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException のコンストラクタ
この例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
DataStoreSystemException - exception jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException.
アプリケーション共通マスタで発生するシステム例外の基底クラス
DataStoreSystemException() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DataStoreSystemException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException のコンストラクタ
コンストラクタ
DatabaseAccessor - interface jp.co.intra_mart.foundation.database.DatabaseAccessor.
データベース接続オブジェクト取得インターフェースを定義します。
DatabaseManager - class jp.co.intra_mart.foundation.database.DatabaseManager.
データベースマネージャクラス。
DatabaseSQLException - exception jp.co.intra_mart.foundation.database.exception.DatabaseSQLException.
データベースSQL例外拡張クラス。
DatabaseSQLException(String) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, int) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DatabaseSQLException(String, String, int, Throwable) - class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException のコンストラクタ
コンストラクタ。
DayInfo - interface jp.co.intra_mart.foundation.security.calendar.DayInfo.
日付に対するカレンダーデータ情報の取得インターフェース。
DbManager - class jp.co.intra_mart.foundation.database.DbManager.
推奨されていません。 DatabaseManagerを使用してください。
DbManager(String) - class jp.co.intra_mart.foundation.database.DbManager のコンストラクタ
推奨されていません。 DatabaseManagerを使用してください。
DbsConnection - interface jp.co.intra_mart.foundation.database.DbsConnection.
推奨されていません。 DatabaseManagerから取得したコネクションを使用してください。
Delete - interface jp.co.intra_mart.foundation.datastore.common.config.Delete.
削除時の整合性制約です。
DeleteType - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType.
削除時の整合性制約のタイプです。
Department - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department.
組織の基本属性のデータを取り扱います。
Department() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のコンストラクタ

DepartmentAttach - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach.
組織所属の基本属性のデータを取り扱います。
DepartmentAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のコンストラクタ

DepartmentAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel.
組織所属の基本モデルです。
DepartmentAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper.
組織所属に関連するマッパです。
DepartmentAttachTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable.
組織所属の期間化属性のデータを取り扱います。
DepartmentAttachTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のコンストラクタ

DepartmentAttachTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel.
組織所属の期間化モデルです。
DepartmentBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel.
組織の基本モデルです。
DepartmentInclusionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel.
組織内包の基本モデルです。
DepartmentInclusionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper.
組織内包に関連するマッパです。
DepartmentInfo - class jp.co.intra_mart.foundation.security.DepartmentInfo.
組織情報クラス。
DepartmentInfo(String, String) - class jp.co.intra_mart.foundation.security.DepartmentInfo のコンストラクタ
コンストラクタ。
DepartmentMain - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain.
主所属の基本属性のデータを取り扱います。
DepartmentMain() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のコンストラクタ

DepartmentMainBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel.
主所属の基本モデルです。
DepartmentMainMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper.
主所属に関連するマッパです。
DepartmentMainTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable.
主所属の期間化属性のデータを取り扱います。
DepartmentMainTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のコンストラクタ

DepartmentMainTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel.
主所属の期間化モデルです。
DepartmentMapper - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper.
組織に関連するマッパです。
DepartmentStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct.
組織の階層です。
DepartmentTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable.
組織の期間化属性のデータを取り扱います。
DepartmentTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のコンストラクタ

DepartmentTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational.
組織の期間国際化属性のデータを取り扱います。
DepartmentTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のコンストラクタ

DepartmentTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel.
組織の期間国際化モデルです。
DepartmentTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel.
組織の期間化モデルです。
Directory - class jp.co.intra_mart.foundation.utility.file.Directory.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory クラスを使用してください。
Directory(String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(File, String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String, String) - class jp.co.intra_mart.foundation.utility.file.Directory のコンストラクタ
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
DualComparator - interface jp.co.intra_mart.foundation.utility.DualComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.DualComparator クラスを使用してください。
DuplicateException - exception jp.co.intra_mart.foundation.security.exception.DuplicateException.
作成時重複例外クラス。
DuplicateException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
DuplicateException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.DuplicateException のコンストラクタ
コンストラクタ。
dateToString(Date) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベース登録用文字列を取得します。
dateToString(Date) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.dateToString(Date)を使用してください。
datumpoint - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter の変数
推奨されていません。 このリポーターがフィルタリングする基準レベル値
dbConsistChk(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
decrement() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの値を１だけ減少させます。
decrypt(String) - interface jp.co.intra_mart.foundation.security.cryption.Cryption のメソッド
暗号化された文字列を復号するe。
decrypt(String) - class jp.co.intra_mart.foundation.security.cryption.NoCryption のメソッド
暗号化された文字列を復号するe。
decrypt(String) - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のメソッド
暗号化された文字列を復号するe。
defineInitializeTime(int, int, int) - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチ初期化時間の設定。
definePath(String) - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
推奨されていません。
del(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
delAllAccount(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.deleteAccounts()に置き換えられました。
delAllLink(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
delAllMenu(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.deleteMenuItems()に置き換えられました。
delAllMessage(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
delAllRole(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.deleteRoles()に置き換えられました。
delAllSchedule(String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.deleteBatches()に置き換えられました。
delAttachInfo(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
delData(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
delData(String, boolean) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.deleteAccount(String)に置き換えられました。
delData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
delData(String, boolean) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.deleteRole(String)に置き換えられました。
delete(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数削除します。
delete(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数削除します。
delete(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数削除します。
delete(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数削除します。
delete(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数削除します。
delete(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数削除します。
delete(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数削除します。
delete(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数削除します。
delete(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数削除します。
delete(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数削除します。
delete(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数削除します。
delete(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数削除します。
delete(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数削除します。
delete(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数削除します。
delete(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数削除します。
delete(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数削除します。
delete(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数削除します。
delete(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数削除します。
delete(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ削除します。
delete(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数削除します。
delete(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ削除します。
delete(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
アクセサを複数削除します。
deleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を削除する。
deleteAccount(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを削除します。
deleteAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
指定されたユーザのライセンスを削除します。
deleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を削除する。
deleteAccountRole(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを削除します。
deleteAccountRoles(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールをすべて削除します。
deleteAccounts() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントをすべて削除します。
deleteApplicationLicenseFromAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アプリケーションライセンスをアカウントから削除します。
deleteBatch(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を削除します。
deleteBatch(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を削除します。
deleteBatches() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
すべてのバッチ情報を削除します。
deleteCalendar(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーを削除します。
deleteCalendar(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーを削除します。
deleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
指定されたカレンダーデータを削除します。
deleteCalendarInfo(String, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを削除します。
deleteCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータを削除します。
deleteCalendars() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーを削除します。
deleteCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのカテゴリーを削除します。
deleteCategory(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのカテゴリを削除する。
deleteCategory(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリを削除する。
deleteCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーを削除します。
deleteCategoryDetail(String, String) - class jp.co.intra_mart.foundation.appcomn.Category のメソッド
推奨されていません。 CategoryManager.deleteCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
deleteCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済の分類区分詳細を削除します。
deleteChild(String) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューを削除します。
deleteCompany(Company) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社を削除します。
deleteData(String) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
deleteData(String, String[]) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
deleteDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織情報を削除します。
deleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を削除する。
deleteFavoriteMenu(String, String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを削除します。
deleteFavoriteMenus(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューをすべて削除します。
deleteGroupSet(PublicGroupSet) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセットを削除します。
deleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを削除します。
deleteLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループを削除します。
deleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを削除します。
deleteMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを削除します。
deleteMainPagePatterns(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンをすべて削除します。
deleteMember(DepartmentAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織から人員をはずします。
deleteMember(PrivateGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループから人員をはずします。
deleteMember(PublicGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループから人員をはずします。
deleteMenuDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー組織を削除します。
deleteMenuDepartment(String, DepartmentInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織の紐付けをメニューから削除します。
deleteMenuDepartments(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー組織を削除します。
deleteMenuDepartments(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
組織の紐付けをメニューからすべて削除します。
deleteMenuInclusion(MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuInclusion(String, MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー構成を削除します。
deleteMenuItem(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを削除します。
deleteMenuItem(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを削除します。
deleteMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを削除します。
deleteMenuItems() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューを削除します。
deleteMenuItems() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューを削除します。
deleteMenuPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー役職を削除します。
deleteMenuPost(String, PostInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役織の紐付けをメニューから削除します。
deleteMenuPosts(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー役職を削除します。
deleteMenuPosts(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
役織の紐付けをメニューからすべて削除します。
deleteMenuPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューパブリックグループを削除します。
deleteMenuPublicGroup(String, PublicGroupInfo) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループの紐付けをメニューから削除します。
deleteMenuPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューパブリックグループを削除します。
deleteMenuPublicGroups(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
パブリックグループの紐付けをメニューからすべて削除します。
deleteMenuRole(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューロールを削除します。
deleteMenuRole(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールの紐付けをメニューから削除します。
deleteMenuRoles(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューロールを削除します。
deleteMenuRoles(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ロールの紐付けをメニューから削除します。
deletePost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の役職情報を削除します。
deletePostData(String, String) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
deletePrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループ情報を削除します。
deleteProfile(String) - class jp.co.intra_mart.foundation.appcomn.Profile のメソッド
推奨されていません。 UserManager.deleteUser(User user) に置き換えられました。
deletePublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループ情報を削除します。
deleteRole(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのロール情報を削除する。
deleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を削除する。
deleteRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールを削除します。
deleteRoles() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロールを削除します。
deleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールIDサマリを削除する。
deleteSubRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
指定したロールのサブロールIDサマリを全削除する。
deleteSubRole(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
指定したサブロールIDを削除します。
deleteSubRoles(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全てのサブロールIDを削除します。
deleteSuperUser(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を削除します。
deleteSuperUser(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を削除します。
deleteUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを削除します。
deleteVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンを削除します。
deleteVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンを削除します。
departmentAdded(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentAdded(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアに登録された後に呼び出されます。
departmentDeleted(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentDeleted(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアに更新された後に呼び出されます。
departmentJoined(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成がデータストアに登録された後に呼び出されます。
departmentLeft(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます。
departmentUpdated(String, Department) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
departmentUpdated(String, Department) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織情報がデータストアから削除された後に呼び出されます。
destroy() - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
破棄します。
destroy() - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
破棄します。
destroy() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
サーブレットの放棄を行います。
destroy() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
サーブレットの放棄を行います。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
グループデータを削除します。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
グループデータを削除します。
destroy(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
id によりアクセスできるセッションデータを破棄します。
destroy() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このメソッドは、現在のセッションを破棄してしまいます。
destroy(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
グループデータを削除します。
destroy() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このイベントコントローラの破棄処理を行います。
destroy() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor のメソッド
推奨されていません。 このプールを破棄します。
destroy() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールを破棄します。
directories() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のサブディレクトリの一覧を取得します。
doChain() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
doChain(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
doDecoration(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator のメソッド
アカウントをデータストアからの読み込み直後にコールされます。
doDecoration(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator のメソッド
システム管理者情報をデータストアからの読み込み直後にコールされます。
doDecoration(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator のメソッド
バッチをデータストアからの読み込み直後にコールされます。
doDecoration(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator のメソッド
カレンダーデータをデータストアからの読み込み直後にコールされます。
doDecoration(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator のメソッド
アカウントをデータストアからの読み込み直後にコールされます。
doDecoration(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator のメソッド
ログイングループをデータストアからの読み込み直後にコールされます。
doDecoration(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator のメソッド
メニューデータストアからの読み込み直後にコールされます。
doDecoration(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator のメソッド
メニューデータストアからの読み込み直後にコールされます。
doDecoration(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator のメソッド
ロール情報をデータストアから読み込んだ直後にコールされます。
doExport(AccountManager, OutputStream) - interface jp.co.intra_mart.foundation.security.account.AccountExporter のメソッド
エクスポートを行います。
doExport(AccountManager, OutputStream) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
エクスポートを行います。
doExport(BatchManager, OutputStream) - interface jp.co.intra_mart.foundation.security.batch.BatchExporter のメソッド
エクスポートを行います。
doExport(BatchManager, OutputStream) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
エクスポートを行います。
doExport(CalendarManager, OutputStream) - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter のメソッド
エクスポートを行います。
doExport(CalendarManager, OutputStream) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
エクスポートを行います。
doExport(AdminMenuManager, OutputStream) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter のメソッド
エクスポートを行います。
doExport(MenuManager, OutputStream) - interface jp.co.intra_mart.foundation.security.menu.MenuExporter のメソッド
エクスポートを行います。
doExport(AdminMenuManager, OutputStream) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
エクスポートを行います。
doExport(MenuManager, OutputStream) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
エクスポートを行います。
doExport(RoleManager, OutputStream) - interface jp.co.intra_mart.foundation.security.role.RoleExporter のメソッド
エクスポートを行います。
doExport(RoleManager, OutputStream) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
エクスポートを行います。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter のメソッド
リクエストの文字エンコードをアクセスセキュリティ情報を基にエンコーディングを設定して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のメソッド
レスポンスソースの文字エンコードをアクセスセキュリティ情報を基にして 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
フィルタを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
フィルタを実行します。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
GETメソッドです。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
GETメソッドに対するサービスを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter のメソッド
インポートを行います。
doImport(InputStream, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter のメソッド
インポートを行います。
doImport(String) - interface jp.co.intra_mart.foundation.security.ExtendsImport のメソッド
拡張インポート処理を行います。
doImport(String, String) - class jp.co.intra_mart.foundation.security.ExtendsImportManager のメソッド
拡張インポート処理を実行します。
doImport(InputStream, AccountManager) - interface jp.co.intra_mart.foundation.security.account.AccountImporter のメソッド
インポートを行います。
doImport(InputStream, AccountManager) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
インポートを行います。
doImport(InputStream, BatchManager) - interface jp.co.intra_mart.foundation.security.batch.BatchImporter のメソッド
インポートを行います。
doImport(InputStream, BatchManager) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
インポートを行います。
doImport(InputStream, CalendarManager) - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter のメソッド
インポートを行います。
doImport(InputStream, CalendarManager) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
インポートを行います。
doImport(InputStream, AdminMenuManager) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter のメソッド
インポートを行います。
doImport(InputStream, MenuManager) - interface jp.co.intra_mart.foundation.security.menu.MenuImporter のメソッド
インポートを行います。
doImport(InputStream, AdminMenuManager) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
インポートを行います。
doImport(InputStream, MenuManager) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
インポートを行います。
doImport(InputStream, RoleManager) - interface jp.co.intra_mart.foundation.security.role.RoleImporter のメソッド
インポートを行います。
doImport(InputStream, RoleManager) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
インポートを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
POSTメソッドです。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
POSTメソッドに対するサービスを行います。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doSelection(String, String[]) - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector のメソッド
選択用情報を利用して選別された情報のリストを返却します。
doubleValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の数値表現を取得します。
doubleValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を double 型として返します。

E

EMAIL_ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
メールアドレス1
EMAIL_ADDRESS1 - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
メールアドレス１
EMAIL_ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
メールアドレス2
EMAIL_ADDRESS2 - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
メールアドレス２
END_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
終了日
END_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
終了日
EXCEPTION - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
例外 例外を発生させます。
EXCEPTION - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
例外 例外を発生させます。
EXTENSION_FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
内線FAX番号
EXTENSION_FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
内線FAX番号
EXTENSION_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
内線番号
EXTENSION_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
内線番号
Entity - interface jp.co.intra_mart.foundation.datastore.common.config.Entity.
エンティティを定義します。
Environment - interface jp.co.intra_mart.foundation.service.provider.Environment.
このクラスは、 システムプロパティへアクセスするためのインターフェースです。
ErrorEvent - class jp.co.intra_mart.foundation.utility.ErrorEvent.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent クラスを使用してください。
ErrorEvent(Throwable, Object) - class jp.co.intra_mart.foundation.utility.ErrorEvent のコンストラクタ
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable, String, Object) - class jp.co.intra_mart.foundation.utility.ErrorEvent のコンストラクタ
推奨されていません。 エラーを通知するためのイベントを構築します。
ErrorEventListener - interface jp.co.intra_mart.foundation.utility.ErrorEventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener クラスを使用してください。
ErrorPageProvider - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider.
エラーページプロバイダインタフェース。
EventListener - interface jp.co.intra_mart.foundation.utility.EventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventListener クラスを使用してください。
EventQueueController - class jp.co.intra_mart.foundation.utility.EventQueueController.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.EventQueueController クラスを使用してください。
EventQueueController() - class jp.co.intra_mart.foundation.utility.EventQueueController のコンストラクタ
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long) - class jp.co.intra_mart.foundation.utility.EventQueueController のコンストラクタ
推奨されていません。 イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventScript - class jp.co.intra_mart.foundation.page.EventScript.
ブラウザでスクリプトの各変数に対する変更イベントを実装するための スクリプトコードを提供します。
EventScript(String) - class jp.co.intra_mart.foundation.page.EventScript のコンストラクタ
イベントスクリプトを作成するためのインスタンスを構築します。
EverydayConditioner - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner クラスを使用してください。
EverydayConditioner(int, int) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のコンストラクタ
推奨されていません。 毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
ExpirationKey - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey.
ライフタイム期間の有効終了日時を定義します。
ExtendedBaseAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor.
拡張基本エンティティに対する情報操作用のインタフェースです。
ExtendedBaseAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap.
拡張基本アクセサのマッピング情報を持ちます。
ExtendedBaseModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel.
拡張基本モデルを定義します。
ExtendedBaseModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel.
拡張基本モデルの情報です。
ExtendedBaseModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap.
拡張基本モデルのマッピング情報を持ちます。
ExtendedBaseTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable.
拡張基本テーブルを定義します。
ExtendedDirectory - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory クラスを使用してください。
ExtendedDirectory(String, int) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のコンストラクタ
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(File, String, int) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のコンストラクタ
推奨されていません。 File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedEntity - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity.
拡張エンティティを定義します。
ExtendedFile - class jp.co.intra_mart.foundation.utility.file.ExtendedFile.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile クラスを使用してください。
ExtendedFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(File, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のコンストラクタ
推奨されていません。 親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
ExtendedGenericBaseModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel.
拡張基本モデルの汎用的な抽象クラスです。
ExtendedGenericBaseModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のコンストラクタ

ExtendedGenericBaseModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap.
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericBaseModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のコンストラクタ

ExtendedGenericInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel.
拡張国際化モデルの汎用的な抽象クラスです。
ExtendedGenericInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のコンストラクタ

ExtendedGenericInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap.
拡張国際化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のコンストラクタ

ExtendedGenericTerminableInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel.
拡張期間国際化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のコンストラクタ

ExtendedGenericTerminableInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap.
拡張基本モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のコンストラクタ

ExtendedGenericTerminableModel - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel.
拡張期間化モデルの汎用的な抽象クラスです。
ExtendedGenericTerminableModel() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のコンストラクタ

ExtendedGenericTerminableModelMap - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap.
拡張期間化モデルのマッピング情報を持つ汎用的な抽象クラスです。
ExtendedGenericTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のコンストラクタ

ExtendedInputStream - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream クラスを使用してください。
ExtendedInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のコンストラクタ
推奨されていません。 入力ストリームを構築します。
ExtendedInputStream(InputStream, ErrorEventListener) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のコンストラクタ
推奨されていません。 入力ストリームを構築します。
ExtendedInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor.
拡張国際化エンティティに対する情報操作用のインタフェースです。
ExtendedInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap.
拡張国際アクセサのマッピング情報を持ちます。
ExtendedInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel.
拡張国際化モデルを定義します。
ExtendedInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel.
拡張国際化モデルの情報です。
ExtendedInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap.
拡張国際化モデルのマッピング情報を持ちます。
ExtendedInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable.
拡張国際化テーブルを定義します。
ExtendedModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel.
拡張モデルを定義します。
ExtendedOutputStream - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスを使用してください。
ExtendedOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のコンストラクタ
推奨されていません。 出力ストリームを構築します。
ExtendedOutputStream(OutputStream, ErrorEventListener) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のコンストラクタ
推奨されていません。 出力ストリームを構築します。
ExtendedSocket - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket クラスを使用してください。
ExtendedSocket(String, int) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedSocket(Socket) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedSocket(ExtendedSocket) - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のコンストラクタ
推奨されていません。 ソケットを構築します。
ExtendedTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable.
拡張テーブルを定義します。
ExtendedTerminableAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor.
拡張期間化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap.
拡張期間化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor.
拡張期間国際化エンティティに対する情報操作用のインタフェースです。
ExtendedTerminableInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap.
拡張期間国際化アクセサのマッピング情報を持ちます。
ExtendedTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel.
拡張期間国際化モデルを定義します。
ExtendedTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel.
拡張期間国際化モデルの情報です。
ExtendedTerminableInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap.
拡張期間国際化モデルのマッピング情報を持ちます。
ExtendedTerminableInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable.
拡張期間国際化テーブルを定義します。
ExtendedTerminableModel - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel.
拡張期間化モデルを定義します。
ExtendedTerminableModel - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel.
拡張期間化モデルの情報です。
ExtendedTerminableModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap.
拡張期間化モデルのマッピング情報を持ちます。
ExtendedTerminableTable - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable.
拡張期間化テーブルを定義します。
ExtendedThread - class jp.co.intra_mart.foundation.utility.ExtendedThread.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread クラスを使用してください。
ExtendedThread() - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(Runnable, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable, String) - class jp.co.intra_mart.foundation.utility.ExtendedThread のコンストラクタ
推奨されていません。 Constructor for ExtendedThread.
ExtendsImport - interface jp.co.intra_mart.foundation.security.ExtendsImport.
拡張インポート処理インターフェース。
ExtendsImportManager - class jp.co.intra_mart.foundation.security.ExtendsImportManager.
拡張インポートマネージャクラス。
ExternalDirectory - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory.
共有データグループを管理するオブジェクトです。
ExternalDirectory(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ExternalMemory - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory.
共有データを管理するオブジェクトです。
ExternalMemory(String, String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
ExternalMemory(ExternalDirectory, String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
eject(SocketConnection) - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 指定コネクションをこのプールの管理から切り離します。
encode(char) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char[]) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 指定の文字列を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encrypt(String) - interface jp.co.intra_mart.foundation.security.cryption.Cryption のメソッド
文字列を暗号化する。
encrypt(String) - class jp.co.intra_mart.foundation.security.cryption.NoCryption のメソッド
文字列を暗号化する。
encrypt(String) - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のメソッド
文字列を暗号化する。
end() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックを解除します。
entityDirectory() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
データファイルを保存しておくための ディレクトリを表すオブジェクトを取得します。
entries() - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 LoginGroupManager.getLoginGroupIds()に置き換えられました。
entries() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entries() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entries() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
セッションＩＤ一覧を取得します。
entries() - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表す dir に属するグループＩＤ一覧を取得します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
空のグループを作成します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
空のグループを作成します。
entry(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しい空のセッションを作成します。
entry() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しい空のセッションを作成します。
entry(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
空のグループを作成します。
entry(EventListener) - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 イベントリスナーの登録。
entry() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターの取得。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
グループデータを取得します。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
グループデータを取得します。
entryMap() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
グループデータを取得します。
entryMap() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
グループデータを取得します。
entrySet() - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このマップに格納されているマッピングのセットビューを返します。
equals(Object) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
この有効期間と他の有効期間が等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
オブジェクトを比較します。
equals(Object) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
オブジェクトの比較。
equals(Object) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
オブジェクトの比較。
equals(Object) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
このオブジェクトと他のオブジェクトが等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
このオブジェクトと他のオブジェクトが等しいかどうかを示します。
equals(Object) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
データモデルのチェック。
err - class jp.co.intra_mart.foundation.service.provider.Platform の static 変数
エラーログに対するメッセージ出力ストリームです。
errorIterator() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド実行中に発生した例外を返します。
eventGenerating() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューに登録されているイベントリスナーを一つ実行します。
execute(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 任意のＳＱＬ文をデータベースに対してリクエストする

insert/update/delete文を実行する。
execute() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトの実行。
execute(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
スクリプトの実行。
execute(String) - class jp.co.intra_mart.foundation.scenario.PresentationPage のメソッド
プログラム実行。
execute(String, Object[]) - class jp.co.intra_mart.foundation.scenario.PresentationPage のメソッド
プログラム実行。
execute(Object) - class jp.co.intra_mart.foundation.service.client.NetworkAgent のメソッド
サーバに対して実行要求をします。
execute(ActionListener, Object) - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバに対して実行要求をします。
execute(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(URL) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
execute(Properties) - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory のメソッド
推奨されていません。
execute(Properties) - interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent のメソッド
インタフェース ProcedureComponent を実装したオブジェクトの実行クラスを Application Runtime に登録することで、 Application Runtime はこのクラスをインスタンス化し、 action() メソッドをバッチプログラムとして実行します。
exists(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当する国際化モデルが存在するどうか判定します。
exists(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
exists(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された日時を含む期間化モデルが存在するかどうか判定します。
exists(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当する国際化モデルが存在するどうか判定します。
exists(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルが存在するかどうか判定します。
exists(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された日付を含む期間化モデルが存在するかどうか判定します。
exists() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが存在するかどうかを判定します。
expiration() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
セッションの維持時間を取得します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.EverydayConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner のメソッド
推奨されていません。 メッセージファイルを再作成する必要があるかどうかを判定します。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
エクスポートを行います。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー情報・エクスポート。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報をエクスポートします。
exportData(String, OutputStream) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報・エクスポート。

F

FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
FAX番号
FAX_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
FAX番号
FLOAT - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
浮動少数型
FavoriteMenu - class jp.co.intra_mart.foundation.security.account.FavoriteMenu.
マイメニューモデル。
FavoriteMenu(String, String, int) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のコンストラクタ
コンストラクタ。
FavoriteMenu(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のコンストラクタ
コンストラクタ。
FileReporter - class jp.co.intra_mart.foundation.utility.report.FileReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter クラスを使用してください。
FileReporter(ReportFileWriter) - class jp.co.intra_mart.foundation.utility.report.FileReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
FileSender - class jp.co.intra_mart.foundation.http.FileSender.
このクラスは、HTTP レスポンスに対して指定のバイトをストリームとして 出力します。
FileSender(HttpServletResponse) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, MultipurposeInternetMailExtensions) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, String) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSender(HttpServletResponse, MultipurposeInternetMailExtensions, String) - class jp.co.intra_mart.foundation.http.FileSender のコンストラクタ
HTTP レスポンスに対してバイトを書き出すためのインスタンスを構築します。
FileSizeConditioner - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner クラスを使用してください。
FileSizeConditioner(long) - class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner のコンストラクタ
推奨されていません。 メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
FilterComparator - class jp.co.intra_mart.foundation.utility.FilterComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator クラスを使用してください。
FilterComparator(Comparator) - class jp.co.intra_mart.foundation.utility.FilterComparator のコンストラクタ
推奨されていません。 指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
FilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent.
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
FilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のコンストラクタ
指定のイベントをラップするためのフィルターを作成します。
FilterHTTPActionEventChain - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain.
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
FilterMessageReporter - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter クラスを使用してください。
FilterMessageReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
FixedSizeMap - class jp.co.intra_mart.foundation.utility.FixedSizeMap.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap クラスを使用してください。
FixedSizeMap(int) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のコンストラクタ
推奨されていません。 指定されたサイズの領域を持つマップを構築します。
FoundationException - exception jp.co.intra_mart.foundation.exception.FoundationException.
システム基盤共通例外クラス。
FoundationException() - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(String) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(Throwable) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationException(String, Throwable) - class jp.co.intra_mart.foundation.exception.FoundationException のコンストラクタ
コンストラクタ。
FoundationRuntimeException - exception jp.co.intra_mart.foundation.exception.FoundationRuntimeException.
システム基盤共通ランタイム例外クラス。
FoundationRuntimeException() - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(String) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(Throwable) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FoundationRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.exception.FoundationRuntimeException のコンストラクタ
コンストラクタ。
FunctionContainer - class jp.co.intra_mart.foundation.scenario.FunctionContainer.
FunctionContainer クラスは、ファンクション・コンテナとなるスクリプトを コンパイルして実行可能な環境を提供します。
FunctionContainer() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainer(Reader) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainer(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainer のコンストラクタ
新しいインスタンスを構築します。
FunctionContainerFile - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile.
FunctionContainerFile クラスは、ファンクション・コンテナとなるファイルを コンパイルして実行可能な環境を提供します。
FunctionContainerFile(String, Locale) - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のコンストラクタ
ファンクション・コンテナをコンパイルします。
FunctionContainerFile(String) - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のコンストラクタ
ファンクション・コンテナをコンパイルします。
fetch(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SELECT文を発行してデータベースから指定範囲のデータを取得する

files() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中のファイルの一覧を取得します。
files(int) - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
finalize() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
findDirectory(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
findExtendedBaseAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を取得します。
findExtendedBaseModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
findExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を取得します。
findExtendedInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を取得します。
findExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
findExtendedInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を取得します。
findExtendedTerminableAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を取得します。
findExtendedTerminableInternationalAccessor(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を取得します。
findExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
findExtendedTerminableInternationalModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を取得します。
findExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
findExtendedTerminableModel(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を取得します。
findFile(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
findInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
指定された言語に該当する国際化アクセサを取得します。
findInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当する国際化モデルを取得します。
findInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当する国際化モデルを取得します。
findPath() - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
システムのホームディレクトリを返します。
findPath(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
findTerminableAccessor(Date) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定された日付に該当する期間化アクセサを取得します。
findTerminableInternationalAccessor(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
指定された言語に該当する期間国際化アクセサを取得します。
findTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルを取得します。
findTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当する期間国際化モデルを取得します。
findTerminableModel(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された日時に該当する期間化モデルを取得します。
findTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された日付に該当する期間化モデルを取得します。
finish() - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 出力ストリームへのエンコードデータの書き込みを終了します。
finish() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 バッファに保存してあるデータを書き出します。
fire() - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 スレッド実行されるロジック。
floatValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を float 型として返します。
flush() - interface jp.co.intra_mart.foundation.service.provider.SystemReporter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューに溜まっているすべてのイベントリスナーを実行します。
flush() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 書き出しストリーム内のデータをすべて出力。
flush() - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 ストリームをフラッシュします。
flush() - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 ストリームをフラッシュします。
forceLogin(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
強制ログイン処理を行います。
forceLogin(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
強制ログイン処理を行います。
forward(HttpServletRequest, HttpServletResponse, String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定したURLにフォワードします。
forward(String) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
指定したURLにフォワードします。
freeMemory() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバシステムの空きメモリの量を返します。

G

GCConditioner - interface jp.co.intra_mart.foundation.service.provider.GCConditioner.
GarbageController クラスが gc を実行するかどうか判断するための インターフェースを提供します。
GET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ENTIRETY_KEY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_ITEM_KEY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GET_SUBSET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

GarbageController - class jp.co.intra_mart.foundation.service.provider.GarbageController.
ガーベージコレクタを実行するクラスです。
GenericBaseModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel.
基本モデルの汎用的な抽象クラスです。
GenericBaseModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のコンストラクタ

GenericInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel.
国際化モデルの汎用的な抽象クラスです。
GenericInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のコンストラクタ

GenericInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap.
国際化モデルマッピングの汎用的な抽象クラスです。
GenericInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のコンストラクタ

GenericTerminableInternationalModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel.
期間国際化モデルの汎用的な抽象クラスです。
GenericTerminableInternationalModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のコンストラクタ

GenericTerminableInternationalModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap.
期間国際化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のコンストラクタ

GenericTerminableModel - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel.
期間化モデルの汎用的な抽象クラスです。
GenericTerminableModel() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のコンストラクタ

GenericTerminableModelMap - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap.
期間化モデルマッピングの汎用的な抽象クラスです。
GenericTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のコンストラクタ

GenericURLBuilder - class jp.co.intra_mart.jssp.net.GenericURLBuilder.
ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。
GenericURLBuilder(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.jssp.net.GenericURLBuilder のコンストラクタ
新しいビルダを作成します。
GroupSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のコンストラクタ
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
GroupSuperUserAccessor - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor.
グループ管理者アクセッサインタフェース。
GroupSuperUserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet.
グループ管理者初期アクセスサーブレット。
GroupSuperUserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のコンストラクタ

GroupSuperUserPostWriterListener - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener.
グループ管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
GroupSuperUserQueryWriterListener - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener.
グループ管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
GroupSuperUserReaderDecorator - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator.
管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
Grouping - class jp.co.intra_mart.foundation.appcomn.Grouping.
推奨されていません。
Grouping(String) - class jp.co.intra_mart.foundation.appcomn.Grouping のコンストラクタ
推奨されていません。 グルーピング情報操作オブジェクトの作成。
get(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が保持する値を取得します。
get(String, Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の日時に保持している値を取得します。
get(String, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の言語で保持している値を取得します。
get(String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性が、指定の日時、言語で保持している値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
指定の属性が保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性が保持する値を取得します。
get(String, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性が指定の言語で保持する値を取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを取得します。
get() - class jp.co.intra_mart.foundation.service.client.information.Identifier のメソッド
一意性を保証されたＩＤを取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを取得します。
get(String) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを取得します。
get(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを取得します。
get(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 マップが、指定されたキーにマッピングしている値を返します。
getAcceptTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベント実行要求を受け付けたおよその時刻を返します。
getAccount(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を取得する。
getAccount(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ユーザIDにマッチしたユーザデータを１件取得します。
getAccount() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
設定されているアカウントＩＤを返します。
getAccountCount(String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント数を取得する。
getAccountFlag() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
アカウントフラグを取得します。
getAccountFlag() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
アカウントフラグを取得します。
getAccountMenuTree(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定したアカウントのメニュー構成を取得します。
getAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を取得する。
getAccountRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロールIDをすべて取得する。
getAccountRoleIds(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールIDをすべて取得します。
getAccountRoles(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報をすべて取得する。
getAccountRoles(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールをすべて取得します。
getAccountRoles(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
有効期間内のアカウントロールをすべて取得します。
getAccounts() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループ内のすべてのユーザアカウントを取得します。
getAccountsByUserIds(String, String[]) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
指定されたユーザIDのアカウント情報をすべて取得する。
getAccountsByUserIds(String[]) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループ内で引数指定したユーザIDのユーザアカウントをすべて取得します。
getActivationDate() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職情報の有効開始日を取得します。
getActivationDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
開始時間を取得します。
getActivationKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティのライフタイム期間の有効開始日時を取得します。
getAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
住所を取得します。
getAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を取得します。
getAddress(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 アドレスを返します。
getAddress() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのＩＰアドレスを返します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所1を取得します。
getAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所1を取得します。
getAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を取得します。
getAddress1(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所2を取得します。
getAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所2を取得します。
getAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を取得します。
getAddress2(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を取得します。
getAllParentRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべての親ロールの一覧を取得する。
getAllParentRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全ての親ロールIDを取得します。
getAllSubRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
すべてのサブロールの一覧を取得する。
getAllSubRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
全てのサブロールサマリを取得します。
getApplication(String) - interface jp.co.intra_mart.foundation.datastore.common.config.Configuration のメソッド
指定された名前に該当するアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデルを定義しているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
リレーションシップが定義されているアプリケーションを取得します。
getApplication() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブルを定義しているアプリケーションを取得します。
getApplication(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーション情報を取得します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーション名を返します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーションＩＤを返します。
getApplicationLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーションの登録ユーザ数を取得します。
getApplicationName() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーが定義されているアプリケーション名を取得します。
getApplications() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
アプリケーション情報の一覧を取得します。
getArgument() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
引数文字列を取得します。
getArgument() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
引数文字列を取得します。
getArgument() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
引数文字列を取得します。
getArgument(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を取得します。
getArgumentKeys() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数キーの一覧を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ライフタイム期間の有効開始日時となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.Column のメソッド
カラムに対応付ける属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping のメソッド
カラムに割り当てる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ライフタイム期間の有効終了日時となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
国際化基準項目となる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping のメソッド
プライマリーキーとなる属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.Property のメソッド
プロパティに対応付ける属性を取得します。
getAttribute() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
期間化基準項目となる属性を取得します。
getAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティに含まれる属性をすべて取得します。
getAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティに含まれる属性をすべて取得します。
getAutoCommit() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在の自動コミットの状態を取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
拡張元となる基本エンティティの基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
この国際化アクセサが所属する基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサが所属する基本アクセサを取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
基本アクセサ BaseAccessor を取得します。
getBaseAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
基本アクセサを取得します。
getBaseAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
この基本モデルに割り当てられた基本アクセサを取得します。
getBaseModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
基本モデルを取得します。
getBaseName() - class jp.co.intra_mart.foundation.datastore.exception.MapperException のメソッド
メッセージを取得するためのリソースバンドルの基底名を返します。
getBaseTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
基本テーブルを取得します。
getBatch(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を取得します。
getBatch(String) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を取得します。
getBatchId() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチＩＤを取得します。
getBatchIds(String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
すべてのバッチIDを取得します。
getBatchIds() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチIDの一覧を取得します。
getBatches(String) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
すべてのバッチ情報を取得します。
getBatches() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
すべてのバッチ情報を取得します。
getBatchesByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
引数に指定したバッチIDのバッチ情報をすべて取得します。
getBatchesByIds(String[]) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
ログイングループ内で引数指定したバッチIDのバッチ情報をすべて取得します。
getBytes() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部をバイト配列として取得します。
getBytes() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
サーバからレスポンスされたコンテンツのソースをバイト列として返します。
getBytes() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 この抽象パスが表すファイルからデータを読み込みます。
getCalendarIds(String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーIDを取得します。
getCalendarIds() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーIDを取得します。
getCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを取得します。
getCalendarInfo(String, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを取得します。
getCalendarInfo() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
マッチしたカレンダーデータの一覧を取得します。
getCalendarInfoIds(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfoIds(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータIDを取得します。
getCalendarInfos(String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータを取得します。
getCalendarInfosByIds(String, String, String[]) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
指定されたカレンダIDのカレンダ情報をすべて取得する。
getCalendarInfosByIds(String, String[]) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
ログイングループ内で引数指定したカレンダーデータIDのカレンダーをすべて取得します。
getCapacity() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 コネクション作成最大数の取得。
getCapacity() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 コネクション作成最大数の取得。
getCaption() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプション文字列を返します。
getCaption() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｘ軸のキャプションを返します。
getCaption() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｘ軸のキャプションを返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
キャプションの文字色を返します。
getCaptionColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプションの文字色を返します。
getCaptionMargin() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
キャプション表示位置のマージンを返します。
getCaptionMargin() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプション表示位置のマージンを返します。
getCatalog() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection の現在のカタログ名を返します。
getCategories() - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
getCategories(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリの一覧を取得する。
getCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーの一覧を取得します。
getCategorizedCalendarInfos(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
すべてのカレンダーデータをデータタイプ別に分類して取得します。
getCategory() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールカテゴリを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類区分コードを取得します。
getCategoryClassCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
分類区分コードを取得します。
getCategoryClassCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
分類区分コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類コードを取得します。
getCategoryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
分類コードを取得します。
getCategoryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
分類コードを取得します。
getCategoryDetailInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を取得します。
getCategoryManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager の static メソッド
CategoryManagerを取得します。
getCateogryClassInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を取得します。
getCenterPointX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の中心値を返します。
getCenterPointY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の中心値を返します。
getCertificationErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
認証失敗エラーページURLを取得する。
getCertificationErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
認証失敗エラーページURLを取得します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を返します。
getCharacterEncoding() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
リクエストパラメータの文字エンコーディングを返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 このオブジェクトが対象としている文字エンコーディング名を返します。
getCharset(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
キャラクターセットを取得します。
getChildMenuId() - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のメソッド
子メニューIDを取得します。
getChildMenuId() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
子メニューIDを取得します。
getChildMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で指定されたノードの直下の子ノードを配列で取得します。
getChildMenuIds(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
子メニューIDを取得します。
getChildMenuIds(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で指定されたノードの直下の子ノードを配列で取得します。
getChildMenuIds(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
子メニューIDを取得します。
getChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの子ノードをすべて含む Collectionを返します。
getChildNodes() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードの子をすべて含む Collectionを返します。
getChildren() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューの一覧を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel のメソッド
基本モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel のメソッド
拡張基本モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel のメソッド
拡張国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel のメソッド
拡張期間化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel のメソッド
国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel のメソッド
期間国際化モデルのクラス名を取得します。
getClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel のメソッド
期間化モデルのクラス名を取得します。
getClientContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
getClientType() - interface jp.co.intra_mart.foundation.security.ClientTypeInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
クライアントタイプを取得する。
getClientType(Locale, String) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでクライアントタイプ情報を取得します。
getClientType() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
クライアントタイプを取します。
getClientTypeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
クライアントタイプをセッションに保管するためのパラメータ名を取得する。
getClientTypes(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでクライアントタイプ情報の一覧を取得します。
getCloseSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このソケットに登録されているクローズ・イベント・リスナーを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
getCode() - class jp.co.intra_mart.foundation.acssecurity.AcssecurityException のメソッド

getCode() - class jp.co.intra_mart.foundation.appcomn.AppcomnException のメソッド
推奨されていません。
getColor() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
棒の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフの色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
線の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点の色を返します。
getColor() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
グラフ線の色を返します。
getColor() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
色を取得します。
getColor() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
背景色を取得します。
getColorCode() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンコードを取得します。
getColorPattern(Locale, String) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでカラーパターン情報を取得します。
getColorPatternId() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンIDを取得します。
getColorPatternId() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
カラーパターンIDを取得する。
getColorPatternId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
カラーパターンIDを取得します。
getColorPatternId() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
カラーパターンIDを取得します。
getColorPatternIdName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
カラーパターンIDをセッションに保管するためのパラメータ名を取得する。
getColorPatterns(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでカラーパターン情報の一覧を取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumnMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルに含まれる属性に関連するカラムマッピングの情報をすべて取得します。
getColumns() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブルに含まれるカラムをすべて取得します。
getColumns() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブルに含まれるカラムをすべて取得します。
getCompanyCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyCategoryTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
会社コードを取得する。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを取得します。
getCompanyCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
会社コードを取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
会社コードを取得します。
getCompanyManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager の static メソッド
CompanyManagerを取得します。
getCompanyPostTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyPostTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyPostTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getCompanyTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を取得します。
getCompanyTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された日時に対する期間化情報を取得します。
getCompanyTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getComparators() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 設定されている全てのコンパレータを取得します。
getConId() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
接続参照名を取得します。
getConfigDayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが名称であるカレンダーデータの一覧を取得します。
getConnectIDs() - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
getConnectIdsBySystem() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システムに紐付くシステム接続名の一覧を取得します。
getConnectInfo() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
getConnection(ConInfo) - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
Connectionオブジェクトを取得します。
getConnection() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 DatabaseManager.getLoginGroupConnection(String) および DatabaseManager.getSystemConnection(String)を使用してください。
getConnection() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
接続に利用したコネクションを返します。
getConnection() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
接続に利用したコネクションを返します。
getConnectionInfo() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベース設定情報を取得します。
getConnectionType() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
接続の種別を取得します。
getContent() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部を文字列表現として取得します。
getContent(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
getContent() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。
getContentLength() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部をバイト長を取得します。
getContentTransferEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
Content-Transfer-Encodingを取得します。
getContentType() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルのフォーマットを返却します。
getContentType(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
コンテントタイプを取得します。
getContents() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
コンテンツの種類を取得します。
getCookieSessionInfo() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
getCookieSessionInfo(HttpServletRequest) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
クッキーからintra-martセッション情報を取得します。
getCount(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定条件に該当する表内のデータ件数を取得する

getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
国コードを取得します。
getCountryCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを取得します。
getCountryCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを取得します。
getCountryCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを取得します。
getCountryCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
国コードを取得します。
getCreateSocketEventListeners() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
getCssFile() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのCSSファイルパスを取得します。
getData(String) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getAccount(String)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.isRegisteredAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.model.user.UserMapperを利用して取得してください。

getData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRole(String)に置き換えられました。
getData(int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
指定された位置にある値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフ値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
指定された位置にある値を返します。
getData(int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
リスト内の指定された位置にあるデータを返します。
getData(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
指定された位置にある値を返します。
getDataId() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データＩＤを取得します。
getDataSizeX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の中心値からのデータサイズを返します。
getDataSizeY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の中心値からのデータサイズを返します。
getDataSourceNameByLoginGroup(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループIDからデータソース参照名を取得します。
getDataSourceNameBySystem(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システム接続名からデータソース参照名を取得します。
getDataSourceRefName() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
DataSourceへの参照名を取得します。
getDataType() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データタイプを取得します。
getDataX() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフのｘ値を返します。
getDataY() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフのｙ値を返します。
getDate() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
対象の日付を取得します。
getDay() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
日を取得します。
getDayInfo(CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
日付情報を取得します。
getDayWeek() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
曜日を取得します。
getDbName() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このデータベース製品の名前を取得します。
getDbVersion() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このデータベース製品のバージョンを取得します。
getDebugOption() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
JavaMailに設定するデバック設定の有無を取得します。
getDefaultCalendarId() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
デフォルトカレンダーIDを取得します。
getDefaultClientType() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システムのデフォルトクライアントタイプを取得します。
getDefaultColorPatternId() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
デフォルトカラーパターンIDを取得します。
getDefaultDate() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト日時を取得します。
getDefaultDate() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
モデル生成時に設定されたデフォルト日時を取得します。
getDefaultEncoding(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
ロケールに対応するデフォルトエンコーディングを取得します。
getDefaultLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
モデル生成時に設定されたデフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
モデル生成時に指定された言語を取得します。
getDefaultLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
デフォルト言語を取得します。
getDefaultLocale() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
デフォルトロケールを取得します。
getDelete() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティのデータ削除時の整合性制約を取得します。
getDeleteType() - interface jp.co.intra_mart.foundation.datastore.common.config.Delete のメソッド
ターゲットエンティティの削除時の整合性制約のタイプを取得します。
getDepartmentAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentAttachTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
組織コードを取得する。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを取得します。
getDepartmentCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを取得します。
getDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
組織コードを取得します。
getDepartmentCode() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
組織コードを取得します。
getDepartmentMainTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentMainTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentStructs(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織の階層構造を取得します。
getDepartmentTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を取得します。
getDepartmentTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された日時に対する期間化情報を取得します。
getDepartmentTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getDepth() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
階層レベルを取得します。
getDepth() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
階層レベルを取得します。
getDescription() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ内容を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データの説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
説明を取得します。
getDescription() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
説明を取得します。
getDisplayName() - interface jp.co.intra_mart.foundation.security.ClientTypeInfo のメソッド
クライアントタイプ表示名を取得する。
getDisplayName() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターン表示名を取得します。
getDisplayName() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ル表示名取得。
getDisplayName() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニュー表示名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名を取得します。
getDisplayName(Locale) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール表示名を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス1を取得します。
getEmailAddress1() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス１を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を取得します。
getEmailAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス1を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を取得します。
getEmailAddress1(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を取得します。
getEmailAddress1() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス１を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス2を取得します。
getEmailAddress2() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス２を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を取得します。
getEmailAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス2を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を取得します。
getEmailAddress2(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を取得します。
getEmailAddress2() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス２を取得します。
getEncoding() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
デフォルトエンコーディングの取得。
getEncoding() - interface jp.co.intra_mart.foundation.security.LocaleProvider のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
エンコーディング情報を取得します。
getEncoding() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
エンコーディングの取得。
getEncoding() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
エンコーディングを取得します。
getEncodingName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
エンコーディングをセッションに保管するためのパラメータ名を取得する。
getEncodings() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ルに対応しているエンコーディングの一覧の取得。
getEndDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
終了日を取得します。
getEndDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
終了日を取得します。
getEndDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
終了日を取得します。
getEndDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
終了日を取得します。
getEndDateColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間の日時に該当するカラムのカラム名を取得します。
getEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているエンティティの一覧を取得します。
getEntities(String) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
指定の名前を持つエンティティをすべて取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
アクセサの基となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が定義されているエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張対象となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデル定義の基となるエンティティを取得します。
getEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
テーブル定義の基となるエンティティを取得します。
getEntity(int) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
指定のインデックスに該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.foundation.http.MultipartFormData のメソッド
指定の名前を持つエンティティを取得します。
getEntityName() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーがアクセスするエンティティ名を取得します。
getEnvironment() - class jp.co.intra_mart.foundation.service.provider.Platform の static メソッド
システムの設定値を持つオブジェクトを取得します。
getEnvironmentProperty(String) - class jp.co.intra_mart.foundation.service.provider.Platform の static メソッド
指定のキーに対応するシステムの設定値を取得します。
getErrCode() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メール送信時のエラーコードを返す。
getErrMessage() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メール送信時のエラーメッセージを返す。
getErrorPage(int) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からエラーページＵＲＬを取得します。
getErrorPage(int, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
エラーページＵＲＬを取得します。
getEscape() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getException() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラーまたは例外を取得します。
getExpirationDate() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職情報の有効終了日を取得します。
getExpirationDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
終了時間を取得します。
getExpirationKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティのライフタイム期間の有効終了日時を取得します。
getExpiredDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用期限の日付を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
管理メニューエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューエクスポート用のカテゴリの一覧を取得します。
getExportCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールエクスポート用のカテゴリの一覧を取得します。
getExtendedBaseAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する拡張基本アクセサのマップを取得します。
getExtendedBaseModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張基本モデルを取得します。
getExtendedBaseModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
拡張基本エンティティに対応する拡張基本モデルのマップを取得します。
getExtendedBaseModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
拡張基本モデルマップを取得します。
getExtendedBaseModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
拡張基本モデルのマップを取得します。
getExtendedBaseTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張基本テーブルを取得します。
getExtendedEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張エンティティの一覧を取得します。
getExtendedEntities() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを拡張している拡張エンティティをすべて取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が定義されている拡張エンティティを取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデル定義の基となる拡張エンティティを取得します。
getExtendedEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張テーブル定義の基となる拡張エンティティを取得します。
getExtendedInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
この国際化アクセサに対する拡張国際化アクセサのマップを取得します。
getExtendedInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張国際化モデルを取得します。
getExtendedInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
拡張国際化モデルのマップを取得します。
getExtendedInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
拡張国際化エンティティに対応する拡張国際化モデルのマップを取得します。
getExtendedInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
拡張国際化モデルマップを取得します。
getExtendedInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張国際化テーブルを取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel のメソッド
拡張基本モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
この拡張エンティティを参照している拡張モデルを取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel のメソッド
拡張国際化モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルが定義されている拡張モデル定義を取得します。
getExtendedModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel のメソッド
拡張期間化モデルが定義されている拡張モデル定義を取得します。
getExtendedModels() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張モデル定義の一覧を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
この拡張エンティティを参照している拡張テーブルを取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルが定義されている拡張テーブル定義を取得します。
getExtendedTables() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義している拡張テーブル定義の一覧を取得します。
getExtendedTerminableAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサに対する拡張期間化アクセサのマップを取得します。
getExtendedTerminableInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
この期間国際化アクセサの拡張期間国際化アクセサのマップを取得します。
getExtendedTerminableInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張期間国際化モデルを取得します。
getExtendedTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
拡張期間国際化モデルのマップを取得します。
getExtendedTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
拡張期間国際化エンティティに対応する拡張期間国際化モデルのマップを取得します。
getExtendedTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
拡張期間国際化モデルマップを取得します。
getExtendedTerminableInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張期間国際化テーブルを取得します。
getExtendedTerminableModel() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張期間化モデルを取得します。
getExtendedTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
拡張期間化モデルのマップを取得します。
getExtendedTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
拡張期間化エンティティに対応する拡張期間化モデルのマップを取得します。
getExtendedTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
拡張期間化モデルマップを取得します。
getExtendedTerminableTable() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable のメソッド
拡張期間化テーブルを取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を取得します。
getExtensionFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線FAX番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を取得します。
getExtensionNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を取得します。
getExtensionNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を取得します。
getExtensionNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線番号を取得します。
getFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を取得する。
getFavoriteMenuIds(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニューIDをすべて取得する。
getFavoriteMenuIds(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューIDをすべて取得します。
getFavoriteMenus(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報をすべて取得する。
getFavoriteMenus(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューをすべて取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を取得します。
getFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を取得します。
getFaxNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を取得します。
getFaxNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
FAX番号を取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた ExternalMemory インスタンスを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた PermanentFile インスタンスを取得します。
getFile(String) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた SessionMemory インスタンスを取得します。
getFile() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
現在有効なセッションを扱う SessionMemory インスタンスを取得します。
getFile(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表すディレクトリにキー id でマップされた TreasureFile インスタンスを取得します。
getFile() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このオブジェクトが文字を書き出すファイルを取得します。
getFileName() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
アップロードされたファイルのファイル名を取得します。
getFill() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
描画されるグラフの塗りつぶし可否を返します。
getFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを返します。
getFilterParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
getFirstMenuIds() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
第一階層に属するノードを配列で取得します。
getFirstMenuIds() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
第一階層のメニューIDをすべて取得します。
getFirstMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
第一階層に属するノードを配列で取得します。
getFirstMenuIds() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
第一階層のメニューIDをすべて取得します。
getFlowComponent() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているフローコンポーネント名を返します。
getFontColor() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字色を返します。
getFontSize() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字サイズを返します。
getForeignKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの外部キーの集合を取得します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域の背景色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のボーダーの色を返します。
getGraphFrameColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ枠の線色を返します。
getGroup() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
設定されているグループＩＤを返します。
getGroupCode() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
グループコードを取得します。
getGroupErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ログイングループエラーページURLを取得する。
getGroupErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ログイングループエラーページURLを取得します。
getGroupSetCode() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
グループセットコードを取得します。
getHeader(String) - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
ヘッダの取得。
getHeaderNames() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
ヘッダ名称一覧の取得。
getHeight() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの高さを返却します。
getHodildayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが休日であるカレンダーデータの一覧を取得します。
getHoldability() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの現在の保持機能を取得します。
getHostAddress() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのアドレスを返します。
getHostName() - class jp.co.intra_mart.foundation.utility.net.Localhost のメソッド
推奨されていません。 このコンピュータのホスト名を返します。
getHttpServletRequest() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
現在のイベントを要求したリクエストを返します。
getIDs() - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.getUserIds()に置き換えられました。
getIDs() - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getRoleIds()に置き換えられました。
getId() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションIDを取得します。
getId() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューIDを取得します。
getIdByName(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.searchRolesByName(String)に置き換えられました。
getIdentifier() - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
コネクションの識別子を取得します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルの背景色を返します。
getImageBackgroundColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルの背景色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageBorderColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルのボーダ色を返します。
getImageFolder() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのイメージファイルのフォルダを取得します。
getImagePath() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューイメージパスを取得します。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
getImgaeBackgroundColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
getImgaeBorderColor() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
getImportCategories() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
管理メニューインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューインポート用のカテゴリの一覧を取得します。
getImportCategories() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールインポート用のカテゴリの一覧を取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
初期ページURLを取得する。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
初期ページURLを取得する。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
初期ページURLを取得します。
getInitalPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
初期ページURLを取得する。
getInitialCertification(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッドの情報から初期アクセス処理を行います。
getInitialCertification(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
初期アクセス処理を行います。
getInitialPage() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報から初期アクセスページURLを取得します。
getInitialPage(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報から初期アクセスページURLを取得します。
getInitialPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
初期アクセスページURLを取得します。
getInitialUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
初期ページURLを取得します。
getInitialUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
初期アクセスURLを取得する。
getInitialUrlName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
初期ページURLをセッションに保管するためパラメータ名を取得する。
getInputStream() - interface jp.co.intra_mart.foundation.database.DataSourceProvider のメソッド
データソース設定ファイルのストリームを取得します。
getInputStream() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部を入力ストリームとして取得します。
getInputStream() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 入力ストリームの取得。
getInstallDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストールされた日付を取得します。
getInstance() - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
データべースマネージャインスタンスを生成します。
getInstance() - class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory の static メソッド
ConfigurationFactoryのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の static メソッド
JavaMailPropertyHandlerのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.AccessSecurityManager の static メソッド
セキュリティマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.ExtendsImportManager の static メソッド

getInstance() - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
システムマネージャインスタンスを生成します。
getInstance() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager の static メソッド
ログイングループマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager の static メソッド
ログイングループマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.security.message.MessageManager の static メソッド
メッセージマネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.service.client.file.AbstractComponent の static メソッド
このクラスの新しいインスタンスを取得します。
getInstance(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory の static メソッド
共有データを扱うためのオブジェクトを取得します。
getInstance(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory の static メソッド
共有データを扱うためのオブジェクトを取得します。
getInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
拡張もととなる国際化アクセサを取得します。
getInternationalAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
この国際化モデルに割り当てられた国際化アクセサを取得します。
getInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
国際化アクセサを取得します。
getInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する国際化アクセサのマップを取得します。
getInternationalKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの国際化基準項目を取得します。
getInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
国際化モデルを取得します。
getInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
国際化モデルのマップを取得します。
getInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
国際化モデルマップを取得します。
getInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
国際化モデルのマップを取得します。
getInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
国際化テーブルを取得します。
getJdbcConnection(String, String, String, String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
JDBCからコネクションオブジェクトを取得します。
getKey() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージを作成するための識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.DepartmentInfo のメソッド
組織情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
役職情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.PublicGroupInfo のメソッド
パブリックグループ情報の識別子を取得します。
getKeyString() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
メニュー内包情報の識別子を取得します。
getLanguage() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
言語名を返します。
getLanguageVersion() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
言語のバージョンを返します。
getLicenceErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ライセンスエラーページURLを取得する。
getLicenceErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ライセンスエラーページURLを取得します。
getLicense(LoginInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
アカウントライセンスチェックを行います。
getLicense() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションライセンスが登録されているアカウント数を取得する。
getLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
グループ内で登録されているライセンス数を取得します。
getLifetime() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティの期間削除時の整合性制約を取得します。
getLifetimeType() - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime のメソッド
ターゲットエンティティの期間削除時の整合性制約のタイプを取得します
getLimitedDate() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
使用期限の日付を取得します。
getLink(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
getListData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getAllSubRoleIds(String)に置き換えられました。
getListenerClass() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
リスナーとなっている Servlet の実行時クラスを返します。
getListenerContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職名の言語を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
ロケールを取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
国際化モデルが保持する言語 Locale を取得します。
getLocale() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
期間国際化モデルが保持する言語 Locale を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
国際化モデルが保持する言語 Locale を取得します。
getLocale() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
期間国際化モデルが保持する言語 Locale を取得します。
getLocale() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ロケールを取得します。
getLocale() - interface jp.co.intra_mart.foundation.security.LocaleInfo のメソッド
ロケ－ル取得。
getLocale() - interface jp.co.intra_mart.foundation.security.LocaleProvider のメソッド
ロケールを取得する。
getLocale() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ロケールを取得する。
getLocale(Locale, Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでロケール情報を取得します。
getLocale() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ロケールの取得。
getLocale() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ロケールを取得する。
getLocale() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ロケールを取得する。
getLocale() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ロケールを取得します。
getLocale() - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のメソッド
推奨されていません。 ResourceBundle の Locale を返します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
ロケールに該当するカラムのカラム名を取得します。
getLocaleName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ロケールをセッションに保管するためのパラメータ名を取得する。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
この分類区分で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
この分類区分詳細で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
この会社で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
この組織で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
この役職で管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
このパブリックグループで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
このパブリックグループセットで管理している言語（ロケール）をすべて取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
このユーザで管理している言語（ロケール）をすべて取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
現在管理している言語の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
現在管理している言語の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
マッピングされている国際化モデル InternationalModel の言語 Locale の一覧を取得します。
getLocales() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
マッピングされている期間国際化モデル TerminableInternationalModel の言語 Locale の一覧を取得します。
getLocales(Locale) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
指定ロケールでロケール情報の一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名として保管されているロケールの一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名として保管されているロケールの一覧を取得します。
getLocales() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロケールの一覧を取得します。
getLocation() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
設定されている遷移先パスを返します。
getLockCount() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックするログイン失敗回数を取得します。
getLockDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック日付を取得します。
getLockTerm() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックする期間を取得します。
getLockedErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ユーザロックエラーページURLを取得する。
getLockedErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ユーザロックエラーページURLを取得します。
getLoginCertification() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からログイン処理を行います。
getLoginCertification(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
getLoginFailureCount() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数を取得します。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログイングループIDを取得する。
getLoginGroup() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログイングループIDを取得する。
getLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループ情報を取得します。
getLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ情報を取得します。
getLoginGroupConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
ログイングループIDからコネクションオブジェクトを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ログイングループIDを取得します。
getLoginGroupIds() - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループIDの一覧を取得します。
getLoginGroupIds() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループIDの一覧を取得します。
getLoginGroupName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイングループをセッションに保管するためのパラメータ名を取得する。
getLoginGroupParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ログイングループＩＤリクエストパラメータ名を取得する。
getLoginGroupParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ログイングループＩＤリクエストパラメータ名を取得する。
getLoginGroups() - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループの一覧を取得します。
getLoginTime() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインした時間を取得する。
getLoginTimeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイン時間をセッションに保管するためのパラメータ名を取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインタイプを取得する。
getLoginTypeName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログインタイプをセッションに保管するためのパラメータ名を取得する。
getMailAddress() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
メールアドレス取得。
getMainPage() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からメインページURLを取得します。
getMainPage(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からメインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
メインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
メインページURLを取得する。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
メインページURLを取得する。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
メインページURLを取得します。
getMainPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
メインページURLを取得する。
getMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを取得します。
getMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを取得します。
getMainPagePatternId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
メインページパターンIDを取得します。
getMainPagePatternId() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンIDを取得する。
getMainPagePatternIds(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンIDの一覧を取得します。
getMainPagePatternIds(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンIDの一覧を取得します。
getMainPagePatternImageUrl() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンイメージURLを取得する。
getMainPagePatternUrl() - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンURLを取得する。
getMainPagePatterns(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンの一覧を取得します。
getMapperClassName() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
マッパのクラス名を取得します。
getMatchCount() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
名称設定以外でマッチしたカレンダーデータの数を取得します。
getMax() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の最大値を返します。
getMax() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の最大値を返します。
getMax() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の最大値を返します。
getMaxDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term の static メソッド
システムで設定できる期間の最大日時を取得します。
getMaxDate() - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
システムで設定できる期間の最大日時を取得します。
getMaxLicense() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションの最大登録可能なラインセンス数を取得します。
getMaxLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループ内の最大登録可能ライセンス数を取得します。
getMaxProcess() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションランタイムの最大使用可能なラインセンス数を取得します。
getMediaType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプの Media Type を返します。
getMenu(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getMenuDepartments(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー組織を取得します。
getMenuDepartments(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いた組織の一覧を取得します。
getMenuId() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
メニューIDを取得します。
getMenuIds() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューIDを取得します。
getMenuIds(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューIDを取得します。
getMenuIds() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューIDを取得します。
getMenuIdsByDepartment(String, DepartmentInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByDepartment(DepartmentInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定された組織を持つメニューIDをすべて取得します。
getMenuIdsByPost(String, PostInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPost(PostInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定された役職を持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(String, PublicGroupInfo[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByPublicGroup(PublicGroupInfo[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたパブリックグループを持つメニューIDをすべて取得します。
getMenuIdsByRole(String, String[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuIdsByRole(String[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたロールIDを持つメニューIDをすべて取得します。
getMenuInclusions() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuInclusions(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー構成を取得します。
getMenuItem(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定されたメニューIDに対応するメニューを取得します。
getMenuItem(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたメニューIDに対するノードを取得します。
getMenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたメニューIDに対応するメニューを取得します。
getMenuItem() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
メニューを取得します。
getMenuItems() - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
すべてのメニューを取得します。
getMenuItems(String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのノードを取得します。
getMenuItems() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
すべてのメニューを取得します。
getMenuItemsByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
指定されたユーザIDのメニュー情報をすべて取得します。
getMenuItemsByIds(String[]) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
ログイングループ内で引数指定したメニューIDのメニュー情報をすべて取得します。
getMenuPosts(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニュー役職を取得します。
getMenuPosts(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いた役職の一覧を取得します。
getMenuPublicGroups(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューパブリックグループを取得します。
getMenuPublicGroups(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いたパブリックグループの一覧を取得します。
getMenuRoles(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
すべてのメニューロールを取得します。
getMenuRoles(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューに紐付いたロールの一覧を取得します。
getMenuTree() - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー構成を取得します。
getMenuTree() - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー構成を取得します。
getMenuTree(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたクライアントタイプのみのメニュー構成を取得します。
getMenuTree(String, String[], boolean) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたクライアントタイプと指定されたメニューIDのみのメニュー構成を取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
getMessage() - class jp.co.intra_mart.foundation.acssecurity.AcssecurityException のメソッド

getMessage() - class jp.co.intra_mart.foundation.appcomn.AppcomnException のメソッド
推奨されていません。
getMessage(Locale, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(Locale, String, String[]) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String, String, String) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage(String, String[]) - class jp.co.intra_mart.foundation.security.message.MessageManager のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラーメッセージを取得します。
getMetaData() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続のデータベースに関するメタデータを取得します。
getMimeEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
MIMEエンコードを取得します。
getMin() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の最小値を返します。
getMin() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の最小値を返します。
getMin() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の最小値を返します。
getMinDate() - class jp.co.intra_mart.foundation.datastore.common.structure.Term の static メソッド
システムで設定できる期間の最小日時を取得します。
getMinDate() - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
システムで設定できる期間の最小日時を取得します。
getMobileEmailAddress() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを取得します。
getMobileEmailAddress(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを取得します。
getMobileEmailAddress() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯用メールを取得します。
getMobileNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯電話番号を取得します。
getMobileNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を取得します。
getMobileNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を取得します。
getMobileNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯電話番号を取得します。
getMobilePassword() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
モバイル用パスワードを取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel のメソッド
基本モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを参照しているモデルを取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel のメソッド
国際化モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel のメソッド
期間国際化モデルが定義されているモデル定義を取得します。
getModel() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel のメソッド
期間化モデルが定義されているモデル定義を取得します。
getModels() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているモデル定義の一覧を取得します。
getMonth() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
月を取得します。
getMonthInfos(CategorizedCalendarInfo, int, int) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
月情報を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のメソッド
分類区分名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct のメソッド
会社名または組織名を取得する。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のメソッド
役職名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名を取得します。
getName() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel のメソッド
分類区分名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel のメソッド
分類名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を取得します。
getName(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーション名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping のメソッド
カラム名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping のメソッド
プライマリーキーとなるカラム名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
リレーションシップ名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルのテーブル名を取得します。
getName() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
フォームのコントロール名称の取得。
getName() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
項目の表示名称のを取得します。
getName() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
項目の表示名称のを取得します。
getName() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
項目の表示名称のを取得します。
getName() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ名を取得します。
getName() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーション名を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のメソッド
推奨されていません。 フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
このインスタンスが表すグループＩＤを取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
このインスタンスの表すロックＩＤを返します。
getName() - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
このインスタンスが表すグループＩＤを取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
このオブジェクトの表すディレクトリ名称を取得します。
getName() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
このインスタンスが表すセッションＩＤを取得します。
getName() - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory のメソッド
このオブジェクトの表す名称を取得します。
getName() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
このオブジェクトの表す名称を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名英字を取得します。
getNameEnglish() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名英字を取得します。
getNameEnglish() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を取得します。
getNameEnglish(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名カナを取得します。
getNameSyllabary() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを取得します。
getNameSyllabary(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを取得します。
getNationalHodildayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが祝祭日であるカレンダーデータの一覧を取得します。
getNoPermissionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
無許可アクセスエラーページURLを取得する。
getNoPermissionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
無許可アクセスエラーページURLを取得する。
getNodeSet() - interface jp.co.intra_mart.foundation.page.TreeNodeProvider のメソッド
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
getNodeSet() - class jp.co.intra_mart.foundation.page.TreeRoot のメソッド
ツリービュー内の「ホーム」以外の全てのノードが含まれるSetを返します。
getNote() - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNote() - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNote() - interface jp.co.intra_mart.foundation.page.TreeNode のメソッド
マウスポイント時に表示されるポップアップ文字列を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
備考を取得します。
getNotes() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
備考を取得します。
getNotes() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
備考を取得します。
getNullKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Delete のメソッド
ターゲットエンティティのデータ削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
getNullKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime のメソッド
ターゲットエンティティの期間削除時の整合性制約が「Null」の時の対象となる外部キーを取得します。
getObject() - class jp.co.intra_mart.foundation.utility.ErrorEvent のメソッド
推奨されていません。 通知されたエラー発生オブジェクトを取得します。
getOutputStream() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 出力ストリームの取得。
getOutputStreamWriter() - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
getOverlap(Term[], Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
2つの期間配列 term1 と term2 で重なっている期間を返します。
getOwnerCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
所有者コードを取得します。
getOwnerCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
所有者コードを取得します。
getOwnerCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
所有者コードを取得します。
getOwnerCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
所有者コードを取得します。
getPackageVersion() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
パッケージバージョンを取得します。
getPagePath() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
設定されているページパスを返します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ値を取得します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このオブジェクトがフィルタリングしているハンドラを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
ラップしている親オブジェクトを返します。
getParentComparator() - class jp.co.intra_mart.foundation.utility.FilterComparator のメソッド
推奨されていません。 フィルター対象のコンパレータを返します。
getParentData(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.getParentRoleIds(String)に置き換えられました。
getParentDepartmentCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
親組織コードを取得します。
getParentMenuId(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId() - class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion のメソッド
親メニューIDを取得します。
getParentMenuId(String) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
指定されたメニューの親メニューを取得します。
getParentMenuId(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で指定されたノードの親ノードを取得します。
getParentMenuId() - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のメソッド
親メニューIDを取得します。
getParentMenuId(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
指定されたメニューの親メニューを取得します。
getParentName() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
保存ディレクトリを取得します。
getParentPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
親グループコードを取得します。
getParentRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
親ロールの一覧を取得する。
getParentRoleIds(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
親ロールIDを取得します。
getPassword() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
パスワードを取得します。
getPassword() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
パスワード取得。
getPassword() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインパスワードを取得する。
getPassword() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインパスワードを取得する。
getPassword() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
設定されているパスワードを返します。
getPath() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このオブジェクトが表すパスを返します。
getPermissionSelector(String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のメソッド
指定されたカテゴリについて、設定XMLファイルで定義されているPermissionSelectorを返します。
getPlugin() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
プラグインIDを取得します。
getPlugin(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータプラグインを取得します。
getPluginClass() - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo のメソッド
カレンダーデータプラグインクラス名を取得します。
getPluginId() - interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo のメソッド
カレンダーデータプラグインIDを取得します。
getPluginIds() - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータプラグインIDの一覧を取得します。
getPort() - class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor のメソッド
推奨されていません。 ポートを返します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のメソッド
役職CDを取得します。
getPostCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職コードを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職コードを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを取得します。
getPostCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel のメソッド
役職CDを取得します。
getPostCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職コードを取得します。
getPostCode() - class jp.co.intra_mart.foundation.security.PostInfo のメソッド
役職コードを取得します。
getPostName() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
役職名を取得します。
getPostsInCompany(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsInCompany(String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
会社に登録済の役職をすべて取得します。
getPostsOfUser(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPostsOfUser(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザに設定された役職をすべて取得します。
getPrimaryComparator() - class jp.co.intra_mart.foundation.page.NodeTypeComparator のメソッド
第１コンパレータを取得します。
getPrimaryComparator() - interface jp.co.intra_mart.foundation.utility.DualComparator のメソッド
推奨されていません。 １番目コンパレータを取得します。
getPrimaryComparator() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 第１コンパレータを返します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable のメソッド
拡張基本テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable のメソッド
拡張国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
拡張期間国際化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeyMappings() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
拡張期間化テーブルに含まれる属性に関連するプライマリーキーマッピングの情報をすべて取得します。
getPrimaryKeys() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティのプライマリキーとなる属性をすべて取得します。
getPriority() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
優先度を取得します。
getPrivateGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
グループコードを取得します。
getPrivateGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループコードを取得します。
getPrivateGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
グループコードを取得します。
getPrivateGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループコードを取得します。
getPrivateGroupManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager の static メソッド
PrivateGroupManagerを取得します。
getProduct() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム情報を取得します。
getProgramLanguage() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラム言語を取得します。
getProgramPath() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラムパスを取得します。
getProperties() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel のメソッド
拡張モデルに含まれるプロパティをすべて取得します。
getProperties() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
モデルに含まれるプロパティをすべて取得します。
getProperties() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
JavaMailのSMTPセッションに渡す属性を初期化します。
getProperties(String) - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストール情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
プロパティを取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティ値を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのプロパティ情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
インストール情報を取得します。
getProperty(String) - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
指定されたキーによって示されるシステムプロパティを取得します。
getProperty(String, String) - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
指定されたキーによって示されるシステムプロパティを取得します。
getPropertyKeys() - interface jp.co.intra_mart.foundation.security.ColorPatternInfo のメソッド
カラーパターンのプロパティ情報のキー一覧を取得します。
getPropertyStreamAsClientType(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(クライアントタイプ)の内容取得。
getPropertyStreamAsColor(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(カラーパターン)の内容取得。
getPropertyStreamAsColorProperty(String, Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(カラーパターン)の内容取得。
getPropertyStreamAsLocale(Locale) - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
プロパティファイル(ロケール)の内容取得。
getPublicGroupAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupAttachTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupCategoryTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループコードを取得します。
getPublicGroupCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループコードを取得します。
getPublicGroupCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
グループコードを取得します。
getPublicGroupManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager の static メソッド
PublicGroupManagerを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
グループセットコードを取得します。
getPublicGroupSetTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupSetTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupSetTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getPublicGroupStructs(String, String, Date, Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループの階層構造を取得します。
getPublicGroupTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を取得します。
getPublicGroupTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された日時に対する期間化情報を取得します。
getPublicGroupTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getQuery() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
getQueryName() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
getQueryString() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
設定されているパラメータ情報からクエリ文字列を作成して返します。
getQueryValue() - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 GenericURLBuilder.createFilePath(String) に置き替えられました。
getReader() - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity のメソッド
データ部を Reader として取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
最終更新日を取得します。
getRecordDate() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
最終更新日を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
最終更新者を取得します。
getRecordUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
最終更新者を取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ソースエンティティから有効開始日時を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ソースエンティティから有効終了日時を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
ソースエンティティから国際化基準項目を持つエンティティまでのリレーションシップを取得します。
getRefereRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
ソースエンティティから期間化基準項目を持つエンティティまでのリレーションシップを取得します。
getReferedRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティの属性を、国際化基準項目や期間化基準項目などを使用して参照している全てのリレーションシップを取得します。
getReference() - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.getConnectIdsBySystem()を使用してください。
getRegisteredAccountLicenses() - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループにライセンス登録されているすべてのユーザIDを返します。
getRegisteredApplicationLicensesToAccount(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アカウントに登録されているアプリケーションライセンスの一覧を取得します。
getRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているリレーションシップの一覧を取得します。
getRemoteHostAddress() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのアドレスを返します。
getRemoteHostName() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのホスト名を返します。
getReporters() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 セット内の要素についての反復子を返します。
getRequest() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
getRequest() - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のリクエストを返します。
getRequestTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求した時刻を返します。
getRequestURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
このコンテンツを取得するために使用した URL を返します。
getResourceConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
リソース参照名からコネクションオブジェクト取得を取得します。
getResponse() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。
getResponse() - class jp.co.intra_mart.jssp.net.GenericURLBuilder のメソッド
現在のレスポンスを返します。
getResponseCode() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseCode() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseMessage() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResponseMessage() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getRole(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を取得します。
getRoleData(String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を全件取得する。
getRoleData(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を取得する。
getRoleDataByCategory(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリからロール情報を取得する。
getRoleId() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロールIDを取得します。
getRoleId() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールIDを取得します。
getRoleIds(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントに紐付く有効なロールIDをすべて取得します。
getRoleIds() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロールIDを取得します。
getRoleName() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール名を取得します。
getRoleValidEndDate() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効終了日を取得します。
getRoleValidStartDate() - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効開始日を取得します。
getRoles() - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
すべてのロール情報を取得します。
getRolesByCategory(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリー検索によりロールを取得します。
getRolesByIds(String, String[]) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
指定されたロールIDのロール情報をすべて取得する。
getRolesByIds(String[]) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ログイングループ内で引数指定したロールIDのロール情報をすべて取得します。
getRunDay() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行日を取得します。
getRunDayWeek() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行曜日を取得します。
getRunHour() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行時を取得します。
getRunMinute() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行分を取得します。
getRunMonth() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行月を取得します。
getRunSecond() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行秒を取得します。
getRunYear() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行年を取得します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCount() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScaleCountX() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸の目盛間隔を返します。
getScaleCountY() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｙ軸の目盛間隔を返します。
getScalePosition() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛りの表示位置を返します。
getSchedule(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.exportData(String category, OutputStream outputStream)に置き換えられました。
getScript() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
設定された情報からイベントのためのスクリプトを作成します。
getSecondaryComparator() - class jp.co.intra_mart.foundation.page.NodeTypeComparator のメソッド
第２コンパレータを取得します。
getSecondaryComparator() - interface jp.co.intra_mart.foundation.utility.DualComparator のメソッド
推奨されていません。 ２番目コンパレータを取得します。
getSecondaryComparator() - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 第２コンパレータを返します。
getSerialNo() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
シリアルナンバーを取得します。
getService() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているサービスＩＤを返します。
getServletConfig() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。
getSessionConfig() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
セッション情報保管パラメータを取得します。
getSessionCookieName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
クッキーにセッション情報を保管するためパラメータ名を取得する。
getSessionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
セッションエラーページURLを取得する。
getSessionErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
セッションエラーページURLを取得する。
getSessionInfo() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
カレントスレッド情報からintra-martセッション情報を取得します。
getSessionInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッション情報を取得します。
getSessionMode() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッションの状態を取得します。
getSessionMode(SessionInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
intra-martセッションの状態を取得します。
getSessionTimeoutErrorPage(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
セッションタイムアウトエラーページURLを取得する。
getSessionTimeoutErrorPage(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
セッションタイムアウトエラーページURLを取得する。
getSignature() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログイン署名を取得する。
getSignatureName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ログイン署名をセッションに保管するためのパラメータ名を取得する。
getSize() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点のサイズを返します。
getSize() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 このプールが現在管理しているコネクション数です。
getSocket() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このオブジェクトの持つソケットオブジェクトを返します。
getSocketConnectionDistributor() - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のメソッド
このオブジェクトが保持しているネットワークのコネクションプールを 返します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
ソートキーを取得します。
getSortKey() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
ソートキーを取得します。
getSortKey() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ソートキーを取得します。
getSortNumber() - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
ソート番号を取得します。
getSortNumber() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ソート番号を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey のメソッド
ライフタイム期間の有効開始日時の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey のメソッド
ライフタイム期間の有効終了日時の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey のメソッド
国際化基準項目の基点となるソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの情報を取得します。
getSourceEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey のメソッド
期間化基準項目の基点となるソースエンティティの情報を取得します。
getSourceRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティをソースとしているリレーションシップをすべて取得します。
getStartDate() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
開始日を取得します。
getStartDate() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
開始日を取得します。
getStartDate() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
開始日を取得します。
getStartDate() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
開始日を取得します。
getStartDateColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間の開始日時に該当するカラムのカラム名を取得します。
getStartPoint() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているスタートポイント名を返します。
getStream() - interface jp.co.intra_mart.foundation.security.SystemSourceProvider のメソッド
システム設定ファイルの内容取得。
getStroke() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
描画される線の描画属性を返します。
getStruct(String) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManagerの各メソッドに置き換えられました。
getSubRole(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
サブロール(一階層のみ)を取得します。
getSubRoleIds(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールIDサマリを取得する。
getSubType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプの subtype を返します。
getSuperUser() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を取得します。
getSuperUser() - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を取得します。
getSuperUser(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を取得します。
getSuperUser(String) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を取得します。
getSystemConnection(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
システム接続名からコネクションオブジェクトを取得します。
getSystemErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
認証処理エラーページURLを取得する。
getSystemErrorPage(SessionInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
認証処理エラーページURLを取得する。
getSystemLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム全体の登録ライセンス数。
getSystemMaxDate() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
最大の未来日を取得します。
getSystemMaxLicense() - class jp.co.intra_mart.foundation.security.license.LicenseManager の static メソッド
システム全体のライセンス数。
getSystemMenu() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システムメニューを取得します。
getSystemMinDate() - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
最大の過去日を取得します。
getSystemProperty(String) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの値を返します。
getSystemPropertyNameSet() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。
getSystemTemporaryDirectory() - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の static メソッド
システムが使用する一時ファイル保存ディレクトリを表す オブジェクトを返します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable のメソッド
基本テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティを参照しているテーブルを取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable のメソッド
国際化テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間国際化テーブルが定義されているテーブル定義を取得します。
getTable() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間化テーブルが定義されているテーブル定義を取得します。
getTables() - interface jp.co.intra_mart.foundation.datastore.common.config.Application のメソッド
アプリケーションで定義しているテーブル定義の一覧を取得します。
getTargetEntity() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ターゲットエンティティの情報を取得します。
getTargetRelationships() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
このエンティティをターゲットとしているリレーションシップをすべて取得します。
getTelNo() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
電話番号取得。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を取得します。
getTelephoneNumber() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
電話番号を取得します。
getTerm() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
期間を取得します。
getTerm() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間化モデルが保持する期間 Term を取得します。
getTerm() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間化モデルが保持する期間 Term を取得します。
getTermCode() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
期間CDを取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTermColumnName() - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable のメソッド
期間CDに該当するカラムのカラム名を取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
拡張もととなる期間化アクセサを取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
この期間国際化アクセサが所属する期間化アクセサを取得します。
getTerminableAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
この期間化モデルに割り当てられた期間化アクセサを取得します。
getTerminableAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間化アクセサを取得します。
getTerminableAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
基本アクセサに関連する期間化アクセサのマップを取得します。
getTerminableInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
拡張もととなる期間国際化アクセサを取得します。
getTerminableInternationalAccessor() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
この期間国際化モデルに割り当てられた期間国際化アクセサを取得します。
getTerminableInternationalAccessor() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
期間国際化アクセサを取得します。
getTerminableInternationalAccessorMap() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
この期間化アクセサに対する期間国際化アクセサのマップを取得します。
getTerminableInternationalModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
期間国際化モデルを取得します。
getTerminableInternationalModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間国際化モデルのマップを取得します。
getTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間国際化モデルを取得します。
getTerminableInternationalModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間国際化モデルマップを取得します。
getTerminableInternationalTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
期間国際化テーブルを取得します。
getTerminableKey() - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship のメソッド
ソースエンティティの期間化基準項目を取得します。
getTerminableModel() - interface jp.co.intra_mart.foundation.datastore.common.config.Model のメソッド
期間化モデルを取得します。
getTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
期間化モデルのマップを取得します。
getTerminableModelMap() - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
期間化モデルマップを取得します。
getTerminableModelMap() - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
期間化モデルのマップを取得します。
getTerminableTable() - interface jp.co.intra_mart.foundation.datastore.common.config.Table のメソッド
期間化テーブルを取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
この組織所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
この会社組織分類で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
この会社で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
この組織で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
この主所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
この役職で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
このパブリックグループ所属で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
このパブリックグループ分類で管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
このパブリックグループで管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
このパブリックグループセットで管理している期間をすべて取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このユーザで管理している期間をすべて取得します。
getTerms() - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
現在管理している期間の一覧を取得します。
getTerms() - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
getTerms() - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
マッピングされている期間化モデル TerminableModel の期間 Term の一覧を取得します。
getTimes() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
次を取得します。
getTransactionIsolation() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection の現在のトランザクション遮断レベルを取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性の型を取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Column のメソッド
カラムの型を取得します。
getType() - interface jp.co.intra_mart.foundation.datastore.common.config.Property のメソッド
プロパティの型を取得します。
getType() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
アプリケーションタイプを取得します。
getType() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ノードのタイプを取得します。
getType() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトが表す MIME タイプを返します。
getTypeMap() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続に関連した型マップオブジェクトを取得します。
getURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
サーバから返されたＵＲＬを返します。
getURL(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getUpdateInfo() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティの更新情報を取得します。
getUpdateTimestamp() - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo のメソッド
エンティティの更新日付となる属性を取得します。
getUpdateUser() - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo のメソッド
エンティティの更新ユーザとなる属性を取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
URLを取得します。
getUrl() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを取得します。
getUrl(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを取得します。
getUrl(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
URLを取得します。
getUrl() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬを取得する。
getUrl() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
URLを取得します。
getUrlName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ダイレクトＵＲＬをセッションに保管するためパラメータ名を取得する。
getUrlParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ダイレクトＵＲＬリクエストパラメータ名を取得する。
getUrlParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ダイレクトＵＲＬリクエストパラメータ名を取得する。
getUrlSignParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
getUrlSignParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ダイレクトＵＲＬ署名リクエストパラメータ名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignature() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬ署名を取得する。
getUrlSignatureName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名を取得する。
getUser() - interface jp.co.intra_mart.foundation.security.SessionInfo のメソッド
ログインユーザIDを取得する。
getUser() - interface jp.co.intra_mart.foundation.security.certification.LoginInfo のメソッド
ログインユーザIDを取得する。
getUser() - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインユーザIDを取得する。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ユーザコードを取得します。
getUserCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ユーザコードを取得します。
getUserCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザコードを取得します。
getUserId() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ユーザIDを取得します。
getUserId() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ユーザID取得。
getUserIds(String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
ユーザIDの一覧を取得する。
getUserIds() - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
すべてのユーザIDを取得します。
getUserIdsByAccountRole(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByAccountRole(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
getUserIdsByRole(String, Date) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
有効なロールIDを持つすべてのユーザIDを取得します。
getUserIdsByRoles(String, String[], Date) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
指定したロールID一覧に有効なアカウントロールが含まれるアカウントのユーザIDを取得します。
getUserManager(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager の static メソッド
UserManagerを取得します。
getUserName() - interface jp.co.intra_mart.foundation.security.SessionConfig のメソッド
ユーザＩＤをセッションに保管するためのパラメータ名を取得する。
getUserParameterName() - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ユーザＩＤリクエストパラメータ名を取得する。
getUserParameterName() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ユーザＩＤリクエストパラメータ名を取得する。
getUserTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を取得します。
getUserTerminable(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された日時に対する期間化情報を取得します。
getUserTerminableInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された言語に対する期間国際化情報を取得します。
getValidEndDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効終了日を取得します。
getValidEndYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効終了年を取得します。
getValidStartDate() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効開始日取得。
getValidStartYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効開始年を取得します。
getValue() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値を取得します。
getValues() - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージで使用する置換用の文字列を取得します。
getVersion() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
バージョンを取得します。
getVersionCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
バージョンコードを取得します。
getVersionCode() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
バージョンコードを取得します。
getVersionCode() - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
バージョンコードを取得します。
getWarnings() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection に関する呼び出しによって通知された最初の警告を返します。
getWeek() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
週を取得します。
getWeekdayInfos() - class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo のメソッド
データタイプが非休日であるカレンダーデータの一覧を取得します。
getWidth() - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの幅を返却します。
getXMailerHeader() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
送信メールに付加するX-Mailerヘッダを取得します。
getYear() - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
年を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
郵便番号を取得します。
getZipCode() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を取得します。
getZipCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を取得します。
getZipCode(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を取得します。
getZipCode() - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
郵便番号を取得します。
getenv(String) - class jp.co.intra_mart.foundation.http.CGIEnvironment のメソッド
値の取得。
groupSetAdded(String, PublicGroupSet) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetAdded(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
グループセットがデータストアに登録された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。
groupSetDeleted(String, PublicGroupSet) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
グループセットがデータストアから削除された後に呼び出されます。

H

HTTPActionEvent - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext.
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContent - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent.
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext.
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventEntityHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler.
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventEntityHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventException - exception jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException.
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventException(String) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler.
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のコンストラクタ
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
HTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler.
HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventHandlerException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException.
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException.
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventHandlerParameterException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventListenerContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext.
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。
HTTPActionEventResult - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult.
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventResultWrapper - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper.
HTTPActionEventResult のラッパーオブジェクトです。
HTTPActionEventResultWrapper(HTTPActionEventResult) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のコンストラクタ
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
HTTPActionEventURL - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL.
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
HexInputStream - class jp.co.intra_mart.foundation.utility.io.HexInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream クラスを使用してください。
HexInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.HexInputStream のコンストラクタ
推奨されていません。 指定された InputStream から読み込む HexInputStream を作成します。
HexOutputStream - class jp.co.intra_mart.foundation.utility.io.HexOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream クラスを使用してください。
HexOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む HexOutputStream を作成します。
HomeDirectory - class jp.co.intra_mart.foundation.service.provider.HomeDirectory.
このクラスは、サーバ実行システムのホームディレクトリに関する機能を 提供します。
handleEvent() - interface jp.co.intra_mart.foundation.utility.EventListener のメソッド
推奨されていません。 イベントが発生した時にコントローラから呼び出されます。
handleInit() - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のメソッド
このフィルタを初期化します。
handleSocketEvent(ExtendedSocket) - interface jp.co.intra_mart.foundation.utility.net.SocketEventListener のメソッド
推奨されていません。 ソケットに関するイベント発生時に呼び出されるメソッド。
handleThreadStop() - interface jp.co.intra_mart.foundation.utility.ThreadStopListener のメソッド
推奨されていません。 監視していたスレッドが終了したときに実行されるメソッドです。
hasBaseAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間化も国際化もされていない従属属性を持つかどうか判定します。
hasChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード node を持っているか調べます。
hasChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードが子ノードを持っているかどうかを判断します。
hasChildNodes() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが子ノードを持っているかどうかを判断します。
hasChildren() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
子メニューが存在するかどうかを取得します。
hasInternationalAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが国際化のみされている従属属性を持つかどうか判定します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasProperty(String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティが存在しているかをチェックします。
hasReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
hasTerminableAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間化のみされている従属属性を持つかどうか判定します。
hasTerminableInternationalAttributes() - interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity のメソッド
拡張エンティティが期間国際化されている従属属性を持つかどうか判定します。
hashCode() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
有効期間のハッシュコード値を返します。
hashCode() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ハッシュコード値取得。
hashCode() - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.menu.MenuTree のメソッド
ハッシュコードを取得します。
hashCode() - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ハッシュコードを取得します。

I

ID_SECURITY_ACCOUNT - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の static 変数

ID_SECURITY_GROUP - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の static 変数

ID_SECURITY_PASSWORD - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の static 変数

INonTransaction - interface jp.co.intra_mart.foundation.security.INonTransaction.
分散トランザクション未対応のアクセッサに実装するインターフェース。
Identifier - class jp.co.intra_mart.foundation.service.client.information.Identifier.
ユニークなＩＤを生成する機能を提供します。
Identifier() - class jp.co.intra_mart.foundation.service.client.information.Identifier のコンストラクタ
唯一のコンストラクタ。
IllegalArgumentException - exception jp.co.intra_mart.foundation.security.exception.IllegalArgumentException.
引数が不正の例外クラス。
IllegalArgumentException(String, String) - class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException のコンストラクタ
コンストラクタ。
IllegalArgumentException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException のコンストラクタ
コンストラクタ。
IllegalExtensionException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException.
拡張アクセサに関する例外クラス

拡張アクセサに対して不正な操作が行われた場合にスローする。
IllegalExtensionException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalExtensionException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException のコンストラクタ
コンストラクタ
IllegalLocaleException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException.
アクセサが保持する言語に関する例外クラス

アクセサが保持していない言語を要求された場合にスローする。
IllegalLocaleException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalLocaleException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException のコンストラクタ
コンストラクタ
IllegalPasswordException - exception jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException.
パスワードが認証されなかったことを通知するための例外です。
IllegalPasswordException(String) - class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException のコンストラクタ
指定のメッセージで例外を作成します。
IllegalRelationshipException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException.
リレーションシップに関する例外クラス

リレーションシップの整合性が正しくない場合にスローする。
IllegalRelationshipException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalRelationshipException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException のコンストラクタ
コンストラクタ
IllegalTermException - exception jp.co.intra_mart.foundation.datastore.exception.IllegalTermException.
アクセサが保持する期間に関する例外クラス

アクセサが保持しない日時または期間が指定されたときにスローする。
IllegalTermException() - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(String) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
IllegalTermException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException のコンストラクタ
コンストラクタ
ImportException - exception jp.co.intra_mart.foundation.datastore.exception.ImportException.
アプリケーション共通マスタのインポートに関する例外クラス

ImportException() - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(String) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
ImportException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ImportException のコンストラクタ
コンストラクタ
InitialFile - class jp.co.intra_mart.foundation.service.client.information.InitialFile.
設定ファイル(*.ini)の内容を読み込むためのクラスです。
InitialFile(String) - class jp.co.intra_mart.foundation.service.client.information.InitialFile のコンストラクタ
リソースサービスが動作しているサーバのリソースディレクトリ内にある 指定の ini ファイルを読み込みます。
InputCheck - class jp.co.intra_mart.foundation.commons.validation.InputCheck.
入力チェック関数ライブラリ
InputCheck() - class jp.co.intra_mart.foundation.commons.validation.InputCheck のコンストラクタ

InternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor.
国際化エンティティに対する情報操作用のインタフェースです。
InternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap.
国際化アクセサのマッピング情報を持ちます。
InternationalKey - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey.
国際化基準項目を定義します。
InternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel.
国際化モデルを定義します。
InternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel.
国際化モデルの情報です。
InternationalModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext.
国際化モデルの初期化に必要な設定を持ちます。
InternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap.
国際化モデルのマッピング情報を持ちます。
InternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable.
国際化テーブルを定義します。
IntramartDBMapper - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper.
intra-martで管理されるデータベースにアクセスするマッパーの汎用的な抽象クラスです。
IntramartDBMapper() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のコンストラクタ

importData(String, InputStream) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウント情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
インポートを行います。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニュー情報・インポート。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニュー情報をインポートします。
importData(String, InputStream) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報・インポート。
in - class jp.co.intra_mart.foundation.utility.io.HexInputStream の変数
推奨されていません。 フィルタ処理される入力ストリームです。
increaseLoginFailureCount() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数をカウントアップします。
increment() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの値を１だけ増加させます。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
CategoryManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社リスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
CompanyManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
PrivateGroupManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
アカウントリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
PublicGroupManagerを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザリスナーの初期化を行います。
init(String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
UserManagerを初期化します。
init(BaseModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel のメソッド
基本モデルを初期化します。
init(ExtendedBaseAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel のメソッド
拡張基本モデルを初期化します。
init(ExtendedBaseAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
拡張基本モデルを初期化します。
init(ExtendedBaseAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
初期化を行います。
init(ExtendedInternationalAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
拡張国際化モデルを初期化します。
init(ExtendedInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
初期化を行います。
init(ExtendedTerminableInternationalAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
拡張期間国際化モデルを初期化します。
init(ExtendedTerminableInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
初期化を行います。
init(ExtendedTerminableAccessor) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
拡張期間化モデルを初期化します。
init(ExtendedTerminableAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
初期化を行います。
init(ExtendedInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel のメソッド
拡張国際化モデルを初期化します。
init(ExtendedTerminableInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel のメソッド
拡張期間国際化モデルを初期化します。
init(ExtendedTerminableAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel のメソッド
拡張期間化モデルを初期化します。
init(BaseModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
基本モデルを初期化します。
init(InternationalModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
国際化モデルを初期化します。
init(String, InternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
初期化処理を行います。
init(TerminableInternationalModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
期間国際化モデルを初期化します。
init(String, TerminableInternationalAccessorMap) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
初期化処理を行います。
init(TerminableModelContext) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
期間化モデルを初期化します。
init(String, String, TerminableAccessorMap, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
初期化処理を行います。
init(InternationalModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel のメソッド
国際化モデルを初期化します。
init(String, String) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーを初期化します。
init(String, String) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーを初期化します。
init(TerminableInternationalModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel のメソッド
期間国際化モデルを初期化します。
init(TerminableModelContext) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel のメソッド
期間化モデルを初期化します。
init() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
StandardMailオブジェクトを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountChangedListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator のメソッド
アカウントデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者アクセッサを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator のメソッド
システム管理者デコレータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
アクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchExporter のメソッド
バッチバックアップエクスポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchImporter のメソッド
バッチバックアップインポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator のメソッド
バッチデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のメソッド
バッチバックアップの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter のメソッド
カレンダーバックアップエクスポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter のメソッド
カレンダーバックアップインポータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator のメソッド
カレンダーデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のメソッド
カレンダーバックアップの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
ログインリクエストアナライザの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.SuperCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のメソッド
管理者ログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserCertification のメソッド
ユーザログイン認証の初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider のメソッド
ページプロバイダの初期化を行います。
init(FilterConfig) - class jp.co.intra_mart.foundation.security.filter.SessionFilter のメソッド
初期化します。
init(FilterConfig) - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のメソッド
初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者アクセッサを初期化します。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者リスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator のメソッド
管理者デコレータの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator のメソッド
ログイングループデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ書き込み時（書き込み直前）のリスナの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator のメソッド
メニューデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社リスナーの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニューリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator のメソッド
メニューデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
アカウントリスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のメソッド
初期化。
init(Map) - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のメソッド
初期化。
init(Map) - class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector のメソッド
インスタンスの初期化を行います。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロールアクセッサの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleExporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleImporter のメソッド
初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールリスナーの初期化。
init(Map) - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator のメソッド
ロールデコレータの初期化。
init(Map) - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のメソッド
初期化。
init() - class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のメソッド
メニューサーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のメソッド
サーブレットの初期化を行います。
init() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のメソッド
サーブレットの初期化を行います。
initializeTime() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
バッチ初期化時間の取得。
insert(String, Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを追加挿入するメソッド

データベースにインサート処理をする。
insert(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数挿入します。
insert(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数挿入します。
insert(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数挿入します。
insert(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数挿入します。
insert(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数挿入します。
insert(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数挿入します。
insert(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数挿入します。
insert(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数挿入します。
insert(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数挿入します。
insert(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数挿入します。
insert(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数挿入します。
insert(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数挿入します。
insert(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数挿入します。
insert(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数挿入します。
insert(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数挿入します。
insert(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数挿入します。
insert(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数挿入します。
insert(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数挿入します。
insert(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ挿入します。
insert(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数挿入します。
insert(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ挿入します。
insert(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを複数挿入します。
insertAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を新規追加する。
insertAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を新規追加する。
insertBatch(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を新規に追加します。
insertCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを新規に作成します。
insertData(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
insertData(Map, String[]) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
insertFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を新規追加する。
insertLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを新規追加します。
insertMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを新規追加します。
insertMenuDepartment(String, String, DepartmentInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー組織を新規に作成します。
insertMenuInclusion(MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuInclusion(String, MenuInclusion) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー構成を新規に作成します。
insertMenuItem(MenuItem, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuItem(String, MenuItem, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを新規追加します。
insertMenuPost(String, String, PostInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニュー役職を新規に作成します。
insertMenuPublicGroup(String, String, PublicGroupInfo) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューパブリックグループを新規に作成します。
insertMenuRole(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
メニューロールを新規に作成します。
insertPostData(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
insertSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
サブロールを作成する。
insertSuperUser(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を新規追加します。
insertSuperUser(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を新規追加します。
instance() - class jp.co.intra_mart.foundation.service.provider.HomeDirectory の static メソッド
ホームディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory の static メソッド
一時ファイル保存用ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory の static メソッド
ファイルコンテンツの保存ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory の static メソッド
データ保存ディレクトリを表すオブジェクトを取得します。
instance() - class jp.co.intra_mart.foundation.utility.net.Localhost の static メソッド
推奨されていません。 このクラスから生成される唯一のインスタンスを返します。
intValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を int 型として返します。
invoke(String, String) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
invoke(String, Number) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
invoke(String, Object[]) - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
指定関数を実行します。
isAlive() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラが動作しているかどうかをチェックします。
isAlive() - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 このイベントコントローラが有効かどうかチェックします。
isClosed() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection がクローズされているかどうかを判定します。
isClosed() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
このアクセサがクローズされた状態かどうかを確認します。
isClosed() - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
マッパーがクローズされているかどうか確認します。
isClosed() - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
マッパーがクローズされているかどうか確認します。
isClosed() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このソケットが閉じられているかどうかをチェックします。
isColumn(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースの表内に指定カラムが存在するか調べる

isConnect() - class jp.co.intra_mart.foundation.database.DbManager のメソッド
推奨されていません。 代替えメソッドはありません。
isConnected() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバとの接続状態をチェックします。
isDataSource() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 このコネクションがDataSourceかを返します。
isDateString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日付文字列が日付フォーマット（YYYYMMDD）にそっているかチェックする。
isDateTimeString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日時文字列がフォーマット（YYYY-MM-DD HH:MM:SS）にそっているかどうかをチェックする。
isDateTimeString(String, SimpleDateFormat) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
日時文字列が指定フォーマットにそっているかどうかをチェックする。
isDirectory() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルがディレクトリであるかどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
グラフ値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
グラフ値がdouble表現かどうかを判定します。
isDouble() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｙ軸の目盛値がdouble表現かどうかを判定します。
isEMailAddress(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
入力文字列がメールアドレスの形式をとっているかのチェック。
isEmpty(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
渡された文字列が、空文字列かまたはNULLかチェック。
isEmpty(Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
数値のNULLチェック。
isEmpty() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの下に子ノードがないか調べます。
isEmpty() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが一つも子を持っていないときにtrueを返します。
isError() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
処理要求が成功したかどうかを判定します。
isError() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
処理要求が成功したかどうかを判定します。
isExistString(String[], String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
配列内に指定した文字列が含まれているかどうかをチェックする。
isExpired() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用期限が切れているかどうかを判定します。
isFile() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが普通のファイルかどうかを判定します。
isFree() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
ライセンスフリーであるかどうかを判定します。
isFunction() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が関数かどうか判定します。
isGoOut() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
外出状態を取得します。
isGroup(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp の static メソッド
推奨されていません。 代替えメソッドはありません。
isHoliday(String, CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
休日かどうか判定します。
isHoliday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
休日設定にマッチしているかどうかを取得します。
isInput(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの空値チェック。
isInput(Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの空値チェック。
isInstance(Class) - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が c が表すオブジェクトと代入互換の 関係にあるかどうか判定します。
isInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が国際化の対象であるかどうかを取得します。
isInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが国際化の対象であるかどうかを取得します。
isKatakanaString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
文字列が半角カナ文字列かチェックする。
isKessaiDateString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
決済年月日(YYYYMMDD)として有効かをチェックする。
isLenEqual(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力バイト数チェック。
isLenEqual(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力バイト数チェック（引数がクラス版）。
isLenEqual(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力桁数チェック。
isLenEqual(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの入力桁数チェック（引数がクラス版）。
isLenLessThan(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より小さいか(等号を含まない)。
isLenLessThan(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より小さいか(等号を含まない)（引数がクラス版）。
isLenLessThan(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より小さいか(等号を含まない)。
isLenLessThan(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より小さいか(等号を含まない)（引数がクラス版）。
isLenMoreThan(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より大きいか(等号を含まない)。
isLenMoreThan(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムのバイト数が指定バイト数より大きいか(等号を含まない)（引数がクラス版）。
isLenMoreThan(Number, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より大きいか(等号を含まない)。
isLenMoreThan(Number, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラムの桁数が指定桁数より大きいか(等号を含まない)（引数がクラス版）。
isLimited() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
期限付きライセンスであるかどうかを判定します。
isLock() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック状態を取得します。
isLocked() - class jp.co.intra_mart.foundation.service.client.information.Lock のメソッド
ロックの状態を確認します。
isNationalHoliday(CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
祝日かどうか判定します。
isNationalHoliday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
祝祭日設定にマッチしているかどうかを取得します。。
isNengetsuString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
年月指定文字列が年月フォーマット（YYYYMM）にそっているかチェックする。
isNotNull(Object) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
not nullチェック not nullのとき true nullのとき false
isNull() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が null かどうか判定します。
isNullAcceptable() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性にnullが設定可能であるかどうかを取得します。
isNumberString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
文字列が数値かどうかをチェックする。
isNumeralRange(String, Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
指定した数値カラムが指定した数値の範囲なのかチェック
範囲最大値、または最小値と同じ値は範囲内に含まれる。
isObject() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値がオブジェクトかどうか判定します。
isOpenSource() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
オープンソースであるかどうかを判定します。
isReadOnly() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 Connection が読み込み専用モードかどうかを判定します。
isRegisteredAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
指定されたユーザがライセンスに登録されているかどうかをチェックします。
isRegisteredApplicationLicenseToAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アカウントにアプリケーションライセンスが登録されてるか検証します。
isRuntime() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
ランタイムライセンスであるかどうかを判定します。
isShimebiString(String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
締め日(YYYYMMDD)として有効かをチェックする。
isTerminable() - interface jp.co.intra_mart.foundation.datastore.common.config.Attribute のメソッド
属性が期間化の対象であるかどうかを取得します。
isTerminable() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが期間化の対象であるかどうかを取得します。
isTerminableInternational() - interface jp.co.intra_mart.foundation.datastore.common.config.Entity のメソッド
エンティティが期間国際化の対象であるかどうかを取得します。
isTransaction() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースアクセスのトランザクション状態を取得します。
isTransaction() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースアクセスのトランザクション状態を取得します。
isTrial() - interface jp.co.intra_mart.foundation.security.license.ApplicationInfo のメソッド
試用版であるかどうかを判定します。
isUndefined() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値が undefined かどうか判定します。
isUpdate(String, String, Date) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータが指定された日付よりも新しいかチェックします。
isUpdate(String, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータが指定された日付よりも新しいかチェックします。
isValidDate(String, String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isValidate() - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
有効・無効フラグを取得します。
isValueEqual(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値とカラム２の値が同一かのチェック。
isValueEqual(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値とカラム２の値が同一かのチェック。
isValueLessThan(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
isValueLessThan(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より小さいか(等号を含まず)のチェック。
isValueMoreThan(String, String) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
isValueMoreThan(Number, Number) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
カラム１の値がカラム２の値より大きいか(等号を含まず)のチェック。
isWeekDate(String, int) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isWeekDate(String, Integer) - class jp.co.intra_mart.foundation.commons.validation.InputCheck の static メソッド
推奨されていません。 この関数は使用できません。次期バージョンにて削除されます。
isWeekday(String, CategorizedCalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
平日かどうか判定します。
isWeekday() - interface jp.co.intra_mart.foundation.security.calendar.DayInfo のメソッド
非休日設定にマッチしているかどうかを取得します。

J

JavaMailPropertyException - exception jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException.
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyException() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String, Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyHandler - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler.
JavaMailSenderの設定を保持します。
JavaMailSender - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender.
JavaMailをラップしたメール送信オブジェクトです。
JavaMailSender(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のコンストラクタ
JavaMailSenderを新規に作成します。
joinDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成に組織を登録します。
joinPublicGroup(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成にパブリックグループを登録します。
jp.co.intra_mart.foundation.acssecurity - package jp.co.intra_mart.foundation.acssecurity
アクセスセキュリティモジュールを利用するためのクラスを提供します。
jp.co.intra_mart.foundation.appcomn - package jp.co.intra_mart.foundation.appcomn
アプリケーション共通モジュール。
jp.co.intra_mart.foundation.commons.validation - package jp.co.intra_mart.foundation.commons.validation
このパッケージは、入力チェック関数ライブラリを提供します。
jp.co.intra_mart.foundation.database - package jp.co.intra_mart.foundation.database
データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.database.exception - package jp.co.intra_mart.foundation.database.exception
データベースＳＱＬ例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category - package jp.co.intra_mart.foundation.datastore.application.domain.category
分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class - package jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
分類区分情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail - package jp.co.intra_mart.foundation.datastore.application.domain.category.detail
分類詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company - package jp.co.intra_mart.foundation.datastore.application.domain.company
会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach - package jp.co.intra_mart.foundation.datastore.application.domain.company.attach
組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category - package jp.co.intra_mart.foundation.datastore.application.domain.company.category
会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company - package jp.co.intra_mart.foundation.datastore.application.domain.company.company
会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department - package jp.co.intra_mart.foundation.datastore.application.domain.company.department
組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main - package jp.co.intra_mart.foundation.datastore.application.domain.company.main
主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post - package jp.co.intra_mart.foundation.datastore.application.domain.company.post
役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.version - package jp.co.intra_mart.foundation.datastore.application.domain.company.version
バーション情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group - package jp.co.intra_mart.foundation.datastore.application.domain.private_group
プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach - package jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
プライベートグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group - package jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group - package jp.co.intra_mart.foundation.datastore.application.domain.public_group
パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version - package jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
パブリックグループバージョン情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user - package jp.co.intra_mart.foundation.datastore.application.domain.user
ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class - package jp.co.intra_mart.foundation.datastore.application.model.category.category_class
分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail - package jp.co.intra_mart.foundation.datastore.application.model.category.detail
分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach - package jp.co.intra_mart.foundation.datastore.application.model.company.attach
組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category - package jp.co.intra_mart.foundation.datastore.application.model.company.category
会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company - package jp.co.intra_mart.foundation.datastore.application.model.company.company
会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department - package jp.co.intra_mart.foundation.datastore.application.model.company.department
組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion - package jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main - package jp.co.intra_mart.foundation.datastore.application.model.company.main
組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post - package jp.co.intra_mart.foundation.datastore.application.model.company.post
会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version - package jp.co.intra_mart.foundation.datastore.application.model.company.version
会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach - package jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group - package jp.co.intra_mart.foundation.datastore.application.model.private_group.group
プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach - package jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category - package jp.co.intra_mart.foundation.datastore.application.model.public_group.category
パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group - package jp.co.intra_mart.foundation.datastore.application.model.public_group.group
パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion - package jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set - package jp.co.intra_mart.foundation.datastore.application.model.public_group.set
パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version - package jp.co.intra_mart.foundation.datastore.application.model.public_group.version
パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user - package jp.co.intra_mart.foundation.datastore.application.model.user
ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor - package jp.co.intra_mart.foundation.datastore.common.accessor
情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config - package jp.co.intra_mart.foundation.datastore.common.config
アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model - package jp.co.intra_mart.foundation.datastore.common.model
情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure - package jp.co.intra_mart.foundation.datastore.common.structure
期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception - package jp.co.intra_mart.foundation.datastore.exception
アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.drawer - package jp.co.intra_mart.foundation.drawer
画像ファイル出力用クラスを提供します。
jp.co.intra_mart.foundation.exception - package jp.co.intra_mart.foundation.exception
システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.graph - package jp.co.intra_mart.foundation.graph
グラフ描画に関するクラスを提供します。
jp.co.intra_mart.foundation.http - package jp.co.intra_mart.foundation.http
ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.mail - package jp.co.intra_mart.foundation.mail
メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail - package jp.co.intra_mart.foundation.mail.javamail
メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.property - package jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.page - package jp.co.intra_mart.foundation.page
ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.scenario - package jp.co.intra_mart.foundation.scenario
ページベース開発モデルのプログラムと連携するＡＰＩ。
jp.co.intra_mart.foundation.security - package jp.co.intra_mart.foundation.security
アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account - package jp.co.intra_mart.foundation.security.account
アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin - package jp.co.intra_mart.foundation.security.admin
システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch - package jp.co.intra_mart.foundation.security.batch
バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar - package jp.co.intra_mart.foundation.security.calendar
カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification - package jp.co.intra_mart.foundation.security.certification
認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.cryption - package jp.co.intra_mart.foundation.security.cryption
暗号化に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception - package jp.co.intra_mart.foundation.security.exception
アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.filter - package jp.co.intra_mart.foundation.security.filter
アクセスセキュリティのフィルタに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group - package jp.co.intra_mart.foundation.security.group
グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license - package jp.co.intra_mart.foundation.security.license
ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu - package jp.co.intra_mart.foundation.security.menu
メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message - package jp.co.intra_mart.foundation.security.message
メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.permission - package jp.co.intra_mart.foundation.security.permission
権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role - package jp.co.intra_mart.foundation.security.role
ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.servlet - package jp.co.intra_mart.foundation.security.servlet
サーブレットに関連するクラスを提供します。
jp.co.intra_mart.foundation.service.client - package jp.co.intra_mart.foundation.service.client
このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.application - package jp.co.intra_mart.foundation.service.client.application
このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content - package jp.co.intra_mart.foundation.service.client.application.content
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.batch - package jp.co.intra_mart.foundation.service.client.batch
Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file - package jp.co.intra_mart.foundation.service.client.file
Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information - package jp.co.intra_mart.foundation.service.client.information
このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager - package jp.co.intra_mart.foundation.service.client.manager
このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider - package jp.co.intra_mart.foundation.service.provider
このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.application - package jp.co.intra_mart.foundation.service.provider.application
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.batch - package jp.co.intra_mart.foundation.service.provider.batch
このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider.file - package jp.co.intra_mart.foundation.service.provider.file
このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information - package jp.co.intra_mart.foundation.service.provider.information
このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.smtp - package jp.co.intra_mart.foundation.smtp
メール連携モジュール。
jp.co.intra_mart.foundation.utility - package jp.co.intra_mart.foundation.utility
このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset - package jp.co.intra_mart.foundation.utility.charset
このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.file - package jp.co.intra_mart.foundation.utility.file
このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io - package jp.co.intra_mart.foundation.utility.io
このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.net - package jp.co.intra_mart.foundation.utility.net
ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.foundation.utility.report - package jp.co.intra_mart.foundation.utility.report
このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.jssp.net - package jp.co.intra_mart.jssp.net

K

KEY_AUTH_COOKIE_NAME - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

KEY_LOGIN_KEY - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

KIND_ROLE - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException の static 変数
種別 ロール。
KIND_ROLE - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup の static 変数
種別 ロール。
KIND_ROLE_SUB - class jp.co.intra_mart.foundation.security.exception.AccessSecurityException の static 変数
種別 サブロール(ロール)。
keyList() - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
キー一覧を取得します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
キー一覧を取得します。
keyList() - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
キー一覧を取得します。
keyList() - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
キー一覧を取得します。
keys() - interface jp.co.intra_mart.foundation.scenario.VariableScope のメソッド
プロパティの名称一覧を取得します。

L

LANG_JAVA - class jp.co.intra_mart.foundation.security.batch.Batch の static 変数
プログラム言語(JAVA)。
LANG_JAVA_SCRIPT - class jp.co.intra_mart.foundation.security.batch.Batch の static 変数
プログラム言語(JavaScript)。
LDAPUserCertification - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification.
ユーザログインLDAP認証クラス。
LDAPUserCertification() - class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification のコンストラクタ

LOCALE - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
ロケール
LT_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
グループマネージャー（ログインタイプ）。
LT_SUPER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
スーパーユーザ（ログインタイプ）。
LT_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ユーザ（ログインタイプ）。
LicenseManager - class jp.co.intra_mart.foundation.security.license.LicenseManager.
ライセンス・マネージャクラス。
LicenseManager(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のコンストラクタ
コンストラクタ。
Lifetime - interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime.
期間削除時の整合性制約です。
LifetimeType - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType.
期間削除時の整合性制約のタイプです。
LimitedSessionHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler.
セッションを一時利用のみに限定するためのフィルタです。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のコンストラクタ
セッションを一時利用に限定するためのフィルタハンドラを作成します。
LineGraphDrawer - class jp.co.intra_mart.foundation.graph.LineGraphDrawer.
折れ線グラフを描画します。
LineGraphDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のコンストラクタ
ｙ軸の目盛値をint表現で折れ線グラフを作成します。
LineGraphDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現で折れ線グラフを作成します。
LineGraphObject - class jp.co.intra_mart.foundation.graph.LineGraphObject.
LineGraphDrawerクラスのデータを保存するオブジェクトです。
LineGraphObject() - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
LineGraphObject(Color) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の色を指定して、データオブジェクトを作成します。
LineGraphObject(Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の描画属性を指定して、データオブジェクトを作成します。
LineGraphObject(Color, Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のコンストラクタ
線の色と描画属性を指定して、データオブジェクトを作成します。
LineReportFilter - class jp.co.intra_mart.foundation.utility.report.LineReportFilter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter クラスを使用してください。
LineReportFilter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
LocaleInfo - interface jp.co.intra_mart.foundation.security.LocaleInfo.
ロケｰル情報・モデルインタフェース。
LocaleProvider - interface jp.co.intra_mart.foundation.security.LocaleProvider.
ロケール取得プロバイダーインタフェース。
Localhost - class jp.co.intra_mart.foundation.utility.net.Localhost.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.Localhost クラスを使用してください。
Lock - class jp.co.intra_mart.foundation.service.client.information.Lock.
アプリケーションロックをするための機能を提供します。
Lock(String) - class jp.co.intra_mart.foundation.service.client.information.Lock のコンストラクタ
ロックをするためのインスタンスを作ります。
LockMonitor - class jp.co.intra_mart.foundation.utility.LockMonitor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.LockMonitor クラスを使用してください。
LockMonitor(int) - class jp.co.intra_mart.foundation.utility.LockMonitor のコンストラクタ
推奨されていません。 モニターを構築します。
LoginGroup - class jp.co.intra_mart.foundation.security.group.LoginGroup.
ログイングループ・モデル。
LoginGroup() - class jp.co.intra_mart.foundation.security.group.LoginGroup のコンストラクタ
コンストラクタ。
LoginGroup(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のコンストラクタ
コンストラクタ。
LoginGroupAccessor - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor.
ログイングループアクセッサインタフェース。
LoginGroupManager - class jp.co.intra_mart.foundation.security.group.LoginGroupManager.
ログイングループマネージャクラス。
LoginGroupPostWriterListener - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener.
ログイングループ情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
LoginGroupQueryWriterListener - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener.
ログイングループ情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
LoginGroupReaderDecorator - interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator.
ログイングループ情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
LoginInfo - interface jp.co.intra_mart.foundation.security.certification.LoginInfo.
intra-martログイン情報操作インタフェース。
LoginRequestInfo - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo.
intra-martログイン情報操作インタフェース。
Logingp - class jp.co.intra_mart.foundation.acssecurity.Logingp.
推奨されていません。
Logingp(String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のコンストラクタ
推奨されていません。 LoginGroupManagerに置き換えられました。
lastError() - class jp.co.intra_mart.foundation.utility.net.ExtendedSocket のメソッド
推奨されていません。 このインスタンスのメソッド中で最後に発生した例外を返します。
lastModified() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルが最後に変更された時刻を返します。
leaveDepartment(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成から組織情報を離脱させます。
leavePublicGroup(String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成からパブリックグループ情報を離脱させます。
length() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルの長さを返します。
length() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 このライターの出力文字数を取得します。
lists() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ディレクトリ中の一覧を取得します。
load() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルの内容を取得します。
login(LoginRequestInfo) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
login(LoginRequestInfo, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログイン処理を行います。
logout() - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログアウト処理を行います。
logout(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
ログアウト処理を行います。
longValue() - class jp.co.intra_mart.foundation.utility.Counter のメソッド
推奨されていません。 カウンターの現在の値を long 型として返します。

M

MAX_VALUE - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
MENU_TYPE_FOLDER - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニュータイプ（フォルダ）。
MENU_TYPE_ITEM - class jp.co.intra_mart.foundation.security.menu.MenuItem の static 変数
メニュータイプ（アイテム）。
MIN_VALUE - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
MOBILE_EMAIL_ADDRESS - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
携帯用メール
MOBILE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
携帯電話番号
MOVE - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MOVE_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

MOVE_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

Mail - class jp.co.intra_mart.foundation.smtp.Mail.
推奨されていません。 MailSenderに置き換えられました。
Mail(String, int) - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
Mail(String) - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
Mail() - class jp.co.intra_mart.foundation.smtp.Mail のコンストラクタ
推奨されていません。 メール送信オブジェクトの生成。
MailSender - interface jp.co.intra_mart.foundation.mail.MailSender.
メールを送信するためのインターフェースです。
MailSenderException - exception jp.co.intra_mart.foundation.mail.MailSenderException.
メール送信時またはその他の不正な処理に関する情報を提供する例外です。
MailSenderException() - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
MailSenderExceptionを構築します。
MailSenderException(String) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された詳細メッセージを使用してMailSenderExceptionを構築します。
MailSenderException(String, Throwable) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された詳細メッセージおよび原因を使用してMailSenderExceptionを構築します。
MailSenderException(Throwable) - class jp.co.intra_mart.foundation.mail.MailSenderException のコンストラクタ
指定された原因を使用してMailSenderExceptionを構築します。
MainPageImportLoginGroupPostWriterListener - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener.
ログイングループ作成時にメインページパターンを設定するリスナークラス。
MainPageImportLoginGroupPostWriterListener() - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のコンストラクタ
コンストラクタ。
MainPagePatternInfo - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo.
メインページパターン情報クラス。
MainPagePatternInfo(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のコンストラクタ
コンストラクタ。
ManagerException - exception jp.co.intra_mart.foundation.datastore.exception.ManagerException.
マネージャに関する例外クラス

ManagerException() - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(String) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
ManagerException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.ManagerException のコンストラクタ
コンストラクタ
Mapper - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper.
エンティティの情報のマッパーです。
MapperDAOException - exception jp.co.intra_mart.foundation.datastore.exception.MapperDAOException.
マッパーのデータベース接続に関する例外クラス

マッパーがデータベース接続で問題が発生した場合にスローする。
MapperDAOException() - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperDAOException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException のコンストラクタ
コンストラクタ
MapperException - exception jp.co.intra_mart.foundation.datastore.exception.MapperException.
マッパーに関する例外クラス

マッパーの処理中に問題が発生した場合にスローする。
MapperException() - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.MapperException のコンストラクタ
コンストラクタ
MapperFactory - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory.
マッパーを生成します。
MapperFactory() - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory のコンストラクタ

MenuAccessor - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor.
メニューアクセッサインタフェース。
MenuExporter - interface jp.co.intra_mart.foundation.security.menu.MenuExporter.
メニューエクスポートインタフェースです。
MenuImporter - interface jp.co.intra_mart.foundation.security.menu.MenuImporter.
メニューインポートインタフェースです。
MenuInclusion - class jp.co.intra_mart.foundation.security.menu.MenuInclusion.
メニュー内包情報クラス。
MenuInclusion(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuInclusion のコンストラクタ
コンストラクタ。
MenuItem - class jp.co.intra_mart.foundation.security.menu.MenuItem.
メニュー・モデルクラス。
MenuItem() - class jp.co.intra_mart.foundation.security.menu.MenuItem のコンストラクタ
コンストラクタ。
MenuItem(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のコンストラクタ
コンストラクタ。
MenuManager - class jp.co.intra_mart.foundation.security.menu.MenuManager.
メニューマネージャクラス。
MenuManager(String) - class jp.co.intra_mart.foundation.security.menu.MenuManager のコンストラクタ
コンストラクタ。
MenuPermissionSelector - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector.
ユーザIDから有効なメニューのID一覧を取得するセレクタ。
MenuPermissionSelector() - class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector のコンストラクタ
コンストラクタ。
MenuPostWriterListener - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener.
メニュー情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
MenuQueryWriterListener - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener.
メニュー情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
MenuReaderDecorator - interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator.
メニュー情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
MenuServlet - class jp.co.intra_mart.foundation.security.servlet.MenuServlet.
メニュー連携サーブレットクラス。
MenuServlet() - class jp.co.intra_mart.foundation.security.servlet.MenuServlet のコンストラクタ
コンストラクタ。
MenuTree - class jp.co.intra_mart.foundation.security.menu.MenuTree.
メニューツリークラス。
MenuTree(MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuTree のコンストラクタ
コンストラクタ。
MessageManager - class jp.co.intra_mart.foundation.security.message.MessageManager.
メッセージマネージャクラス。
MessageReporter - interface jp.co.intra_mart.foundation.utility.report.MessageReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter クラスを使用してください。
Model - interface jp.co.intra_mart.foundation.datastore.common.config.Model.
モデルを定義します。
MultiCastReporter - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter クラスを使用してください。
MultiCastReporter() - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のコンストラクタ
推奨されていません。 唯一のコンストラクタ。
MultiComparator - class jp.co.intra_mart.foundation.utility.MultiComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator クラスを使用してください。
MultiComparator(Comparator, Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のコンストラクタ
推奨されていません。 第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
MultipartFormData - class jp.co.intra_mart.foundation.http.MultipartFormData.
フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。
MultipartFormData(ServletRequest) - class jp.co.intra_mart.foundation.http.MultipartFormData のコンストラクタ
リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData.Entity - interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity.
フォームデータのエンティティです。
MultipurposeInternetMailExtensions - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions クラスを使用してください。
MultipurposeInternetMailExtensions(String) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(File) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String, String) - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のコンストラクタ
推奨されていません。 指定のMIMEタイプを表すオブジェクトを構築します。
mainRemoved(String, DepartmentMain) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainRemoved(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainSet(String, DepartmentMain) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
mainSet(String, DepartmentMain) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
make() - class jp.co.intra_mart.foundation.service.client.information.Identifier の static メソッド

makeDirectories() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すディレクトリを生成します。
memberDeleted(String, DepartmentAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PrivateGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループ所属情報がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberSet(String, DepartmentAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PrivateGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループ所属情報がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, DepartmentAttach) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます。
move(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルの名前を変更します。
move(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
グループキーを変更します。
moveCategory(String, String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
カテゴリーを更新します。
moveDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織構成に登録済の組織情報を移動します。
moveMenuItem(MenuInclusion) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを移動します。
moveMenuItem(MenuInclusion) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを移動します。
movePublicGroup(String, String, String, String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループ構成に登録済のパブリックグループ情報を移動します。

N

NAME - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
分類区分名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
分類名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
役職名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名
NAME - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名英字
NAME_ENGLISH - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名英字
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
組織名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループ名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループ名カナ
NAME_SYLLABARY - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザ名カナ
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
備考
NOTES - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
備考
NULL - class jp.co.intra_mart.foundation.datastore.common.config.DeleteType の static 変数
Null ターゲットエンティティのデータを参照しているソースエンティティの外部キーをnullにします。
NULL - class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType の static 変数
Null ターゲットエンティティの期間を参照しているソースエンティティの外部キーをnullにします。
NULL_DATA - class jp.co.intra_mart.foundation.service.client.NetworkAgent の static 変数
NULL を表します。
NetworkAgent - class jp.co.intra_mart.foundation.service.client.NetworkAgent.
このクラスは、他のサーバで実行されるロジックを実装する ためのスケルトンを提供します。
NetworkAgent() - class jp.co.intra_mart.foundation.service.client.NetworkAgent のコンストラクタ
唯一のコンストラクタ。
NetworkConnector - class jp.co.intra_mart.foundation.service.client.NetworkConnector.
このクラスは、他のサーバで実行されるロジックを転送する ためのスケルトンを提供します。
NetworkConnector() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のコンストラクタ
唯一のコンストラクタ。
NetworkFile - class jp.co.intra_mart.foundation.service.client.file.NetworkFile.
Storage Service のファイルを扱う事の出来るオブジェクトです。
NetworkFile(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のコンストラクタ
新しいオブジェクトを構築します。
NoCryption - class jp.co.intra_mart.foundation.security.cryption.NoCryption.
暗号化処理を行わない実装クラス。
NoCryption() - class jp.co.intra_mart.foundation.security.cryption.NoCryption のコンストラクタ
コンストラクタ。
NoFilterException - exception jp.co.intra_mart.foundation.security.exception.NoFilterException.
HTTPリクエスト・レスポンス取得例外クラス。
NoFilterException(String) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoFilterException() - class jp.co.intra_mart.foundation.security.exception.NoFilterException のコンストラクタ
コンストラクタ。
NoSessionCookieException - exception jp.co.intra_mart.foundation.security.exception.NoSessionCookieException.
セッション情報クッキー取得例外クラス。
NoSessionCookieException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException のコンストラクタ
コンストラクタ。
NoSessionCookieException(String) - class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException のコンストラクタ
コンストラクタ。
NoSessionException - exception jp.co.intra_mart.foundation.security.exception.NoSessionException.
セッション取得例外クラス。
NoSessionException(String) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSessionException() - class jp.co.intra_mart.foundation.security.exception.NoSessionException のコンストラクタ
コンストラクタ。
NoSuchPropertyException - exception jp.co.intra_mart.foundation.scenario.NoSuchPropertyException.
NoSuchPropertyException クラスは、指定されたプロパティがオブジェクトには ないことを通知します。
NoSuchPropertyException(String) - class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException のコンストラクタ
詳細メッセージを指定して NoSuchPropertyException を構築します。
NodeNameComparator - class jp.co.intra_mart.foundation.page.NodeNameComparator.
ツリービューのノードを名前順にソートするためのコンパレータです。
NodeNameComparator() - class jp.co.intra_mart.foundation.page.NodeNameComparator のコンストラクタ

NodeTypeComparator - class jp.co.intra_mart.foundation.page.NodeTypeComparator.
ツリービューのノードを種類順にソートするためのコンパレータです。
NodeTypeComparator(Comparator) - class jp.co.intra_mart.foundation.page.NodeTypeComparator のコンストラクタ
第２コンパレータ secondaryComparatorを指定して、新たなオブジェクトを生成します。
NotExistException - exception jp.co.intra_mart.foundation.security.exception.NotExistException.
アクセスセキュリティ情報が存在しなかった場合の例外クラス。
NotExistException(String, String, String) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotExistException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotExistException のコンストラクタ
コンストラクタ。
NotFoundDataSourceException - exception jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException.
データソースの参照名未解決例外クラス。
NotFoundDataSourceException(String, String) - class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException のコンストラクタ
コンストラクタ。
NotFoundDataSourceException(String, String, Throwable) - class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException のコンストラクタ
コンストラクタ。
NotSupportMethodException - exception jp.co.intra_mart.foundation.security.exception.NotSupportMethodException.
アクセスセキュリティのマネージャでサポートされないメソッドがコールされた場合の例外クラス。
NotSupportMethodException(Throwable) - class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException のコンストラクタ
コンストラクタ。
NotSupportMethodException() - class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException のコンストラクタ
コンストラクタ。
nativeSQL(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された SQL 文をシステムの本来の SQL 文法に変換します。
newExtendedBaseModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
初期化されていない拡張基本モデルのインスタンスを取得します。
newExtendedInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
初期化されていない拡張国際化モデルのインスタンスを取得します。
newExtendedTerminableInternationalModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
初期化されていない拡張期間国際化モデルのインスタンスを取得します。
newExtendedTerminableModel(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
初期化されてていない拡張期間化モデルのインスタンスを取得します。
newIdentifier() - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のメソッド
新しいセッションＩＤを生成します。
newInstance() - class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory の static メソッド
マッパーファクトリを取得します。
newInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
初期化されていない国際化モデルのインスタンスを取得します。
newString(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(char[]) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
初期化されていない期間国際化モデルのインスタンスを取得します。
newTerminableModel(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
初期化されていない期間化モデルのインスタンスを取得します。
notifyDelete(Relationship, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
notifyDelete(Relationship, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
リレーションシップで定義された参照先基本モデルが削除されたことを通知します。
notifyUpdate(Relationship, BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。
notifyUpdate(Relationship, BaseModel) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
リレーションシップで定義された参照先基本モデルが更新されたことを通知します。

O

OWNER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
所有者コード
OWNER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
所有者コード
OutputSizeConditioner - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner クラスを使用してください。
OutputSizeConditioner(long) - class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner のコンストラクタ
推奨されていません。 メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
out - class jp.co.intra_mart.foundation.service.provider.Platform の static 変数
システムログに対するメッセージ出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.io.HexOutputStream の変数
推奨されていません。 フィルタ処理される基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.report.FileReporter の変数
推奨されていません。 基礎出力ストリームです。
out - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter の変数
推奨されていません。 基礎出力ストリームです。

P

PARENT_DEPARTMENT_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
親組織コード
PARENT_PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
親グループコード
POST_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
役職CD
POST_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
役職コード
PRIVATE_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
グループコード
PRIVATE_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループコード
PUBLIC_GROUP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
グループコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
グループセットコード
PUBLIC_GROUP_SET_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
グループセットコード
PasswordSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String, String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
PeriodicConditioner - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner クラスを使用してください。
PeriodicConditioner(long) - class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner のコンストラクタ
推奨されていません。 タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
PermanentDataArchiveFactory - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory.
推奨されていません。
PermanentDataArchiveFactory() - class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory のコンストラクタ
推奨されていません。 バッチプログラム実行環境からインスタンス化されるためのコンストラクタ。
PermanentDataDirectory - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory.
Permanent-data を保存するディレクトリを表すオブジェクトです。
PermanentDirectory - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory.
ファイルベースでデータを保存します。
PermanentDirectory(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermanentFile - class jp.co.intra_mart.foundation.service.client.information.PermanentFile.
ファイルベースでデータを保存します。
PermanentFile(String, String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermanentFile(PermanentDirectory, String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
PermissionManager - class jp.co.intra_mart.foundation.security.permission.PermissionManager.
パーミッション・マネージャクラス。
PermissionManager(String) - class jp.co.intra_mart.foundation.security.permission.PermissionManager のコンストラクタ
コンストラクタ。
PermissionSelector - interface jp.co.intra_mart.foundation.security.permission.PermissionSelector.
パーミッション・作成クラスインタフェース。
PlainCompanyPost - interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost.
役職データを扱います。
Platform - class jp.co.intra_mart.foundation.service.provider.Platform.
Platform クラスには、システム動作に関わる有用な情報を持つ フィールドおよびメソッドがあります。
PortFolioDrawer - class jp.co.intra_mart.foundation.graph.PortFolioDrawer.
ポートフォリオを描画します。
PortFolioDrawer(int, int, int, int, int, int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のコンストラクタ
ｘ軸、ｙ軸の目盛値をint表現でポートフォリオを作成します。
PortFolioDrawer(double, double, double, double, double, double) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のコンストラクタ
ｘ軸、ｙ軸の目盛値をdouble表現でポートフォリオを作成します。
PortFolioObject - class jp.co.intra_mart.foundation.graph.PortFolioObject.
PortFolioDrawerクラスのデータを保存するオブジェクトです。
PortFolioObject(double, double) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(int, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値を指定して、データオブジェクトを作成します。
PortFolioObject(double, double, Color, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PortFolioObject(int, int, Color, int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のコンストラクタ
グラフのｘ値、ｙ値と描画する点の色とサイズを指定して、データオブジェクトを作成します。
PostInfo - class jp.co.intra_mart.foundation.security.PostInfo.
役職情報クラス。
PostInfo(String, String) - class jp.co.intra_mart.foundation.security.PostInfo のコンストラクタ
コンストラクタ。
PresentationFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler.
im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
PresentationFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のコンストラクタ
プレゼンテーションフレームワークを実行するためのハンドラを作成します。
PresentationFrameworkHTTPActionEventHandler(String, String, String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のコンストラクタ
プレゼンテーションフレームワークを実行するためのハンドラを作成します。
PresentationPage - class jp.co.intra_mart.foundation.scenario.PresentationPage.
PresentationPage クラスは、プレゼンテーション・ページとなるスクリプトを コンパイルして実行可能な環境を提供します。
PresentationPage() - class jp.co.intra_mart.foundation.scenario.PresentationPage のコンストラクタ
セッションを持たないページ作成用オブジェクトを作成します。
PresentationPage(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.scenario.PresentationPage のコンストラクタ
任意のセッションを持つページ作成オブジェクトを構築します。
PresentationPageHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler.
ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
PresentationPageHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPageHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PrimaryKeyMapping - interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping.
分割されたテーブルに割り当てられるプライマリーキーとなるカラムを定義します。
PrintStreamReporter - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter クラスを使用してください。
PrintStreamReporter(PrintStream) - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のコンストラクタ
推奨されていません。 指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
PrivateGroup - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup.
プライベートグループの基本属性のデータを取り扱います。
PrivateGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のコンストラクタ

PrivateGroupAttach - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach.
プライベートグループ所属の基本属性のデータを取り扱います。
PrivateGroupAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のコンストラクタ

PrivateGroupAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel.
プライベートグループ所属の基本モデルです。
PrivateGroupAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper.
プライベートグループ所属に関連するマッパです。
PrivateGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel.
プライベートグループの基本モデルです。
PrivateGroupChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener.
プライベートグループに関する情報の更新時のリスナーです。
PrivateGroupManager - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager.
プライベートグループに関連する情報を管理します。
PrivateGroupManager() - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のコンストラクタ

PrivateGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper.
プライベートグループに関連するマッパです。
ProcedureComponent - interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent.
スケジュール実行されるバッチプログラムのためのインターフェースを定義します。
Profile - class jp.co.intra_mart.foundation.appcomn.Profile.
推奨されていません。
Profile(String) - class jp.co.intra_mart.foundation.appcomn.Profile のコンストラクタ
推奨されていません。 コンストラクタ
Property - interface jp.co.intra_mart.foundation.datastore.common.config.Property.
プロパティを定義します。
PublicGroup - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup.
パブリックグループの基本属性のデータを取り扱います。
PublicGroup() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のコンストラクタ

PublicGroupAttach - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach.
パブリックグループ所属の基本属性のデータを取り扱います。
PublicGroupAttach() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のコンストラクタ

PublicGroupAttachBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel.
パブリックグループ所属の基本モデルです。
PublicGroupAttachMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper.
パブリックグループ所属に関連するマッパです。
PublicGroupAttachTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable.
パブリックグループ所属の期間化属性のデータを取り扱います。
PublicGroupAttachTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable のコンストラクタ

PublicGroupAttachTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel.
パブリックグループ所属の期間化モデルです。
PublicGroupBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel.
パブリックグループの基本モデルです。
PublicGroupCategory - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory.
パブリックグループ分類の基本属性のデータを取り扱います。
PublicGroupCategory() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のコンストラクタ

PublicGroupCategoryBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel.
パブリックグループ分類の基本モデルです。
PublicGroupCategoryMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper.
パブリックグループ分類に関連するマッパです。
PublicGroupCategoryTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable.
パブリックグループ分類の期間化属性のデータを取り扱います。
PublicGroupCategoryTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable のコンストラクタ

PublicGroupCategoryTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel.
パブリックグループ分類の期間化モデルです。
PublicGroupChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener.
パブリックグループに関する情報の更新時のリスナーです。
PublicGroupChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener.
パブリックグループに関する情報の変更時のリスナーです。
PublicGroupChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のコンストラクタ

PublicGroupImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter.
パブリックグループのインポートのインターフェースです
PublicGroupInclusionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel.
パブリックグループ内包の基本モデルです。
PublicGroupInclusionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper.
パブリックグループ内包に関連するマッパです。
PublicGroupInfo - class jp.co.intra_mart.foundation.security.PublicGroupInfo.
パブリックグループ情報クラス。
PublicGroupInfo(String, String) - class jp.co.intra_mart.foundation.security.PublicGroupInfo のコンストラクタ
コンストラクタ。
PublicGroupManager - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager.
パブリックグループに関連する情報を管理します。
PublicGroupManager() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のコンストラクタ

PublicGroupMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper.
パブリックグループに関連するマッパです。
PublicGroupSet - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet.
パブリックグループセットの基本属性のデータを取り扱います。
PublicGroupSet() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のコンストラクタ

PublicGroupSetBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel.
パブリックグループセットの基本モデルです。
PublicGroupSetMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper.
パブリックグループセットに関連するマッパです。
PublicGroupSetTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable.
パブリックグループセットの期間化属性のデータを取り扱います。
PublicGroupSetTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のコンストラクタ

PublicGroupSetTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational.
パブリックグループセットの期間国際化属性のデータを取り扱います。
PublicGroupSetTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のコンストラクタ

PublicGroupStruct - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct.
組織の階層です。
PublicGroupTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable.
パブリックグループの期間化属性のデータを取り扱います。
PublicGroupTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のコンストラクタ

PublicGroupTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational.
パブリックグループの期間国際化属性のデータを取り扱います。
PublicGroupTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のコンストラクタ

PublicGroupTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel.
パブリックグループの期間国際化モデルです。
PublicGroupTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel.
パブリックグループの期間化モデルです。
PublicGroupVersion - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion.
パブリックグループ構成バージョンの基本属性のデータを取り扱います。
PublicGroupVersion() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のコンストラクタ

PublicGroupVersionBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel.
パブリックグループ構成バージョンの基本モデルです。
PublicGroupVersionMapper - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper.
パブリックグループ構成バージョンに関連するマッパです。
parseRequest(LoginRequestInfo, HttpServletRequest) - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer のメソッド
リクエストパラメータの解析。
parseRequest(LoginRequestInfo, HttpServletRequest) - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のメソッド
リクエストパラメータの解析。
parseRequest(LoginRequestInfo, HttpServletRequest) - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のメソッド
リクエストパラメータの解析。
paths(int) - class jp.co.intra_mart.foundation.utility.file.Directory のメソッド
推奨されていません。 この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
postAdded(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postAdded(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアに登録された後に呼び出されます。
postCreate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者情報をデータストアに作成した直後にコールされます。
postCreate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアに作成した直後にコールされます。
postCreate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアに作成した直後にコールされます。
postCreate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアに作成した直後にコールされます。
postCreate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアに作成した直後にコールされます。
postCreateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
postCreateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
postCreateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアに作成した直後にコールされます。
postCreateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアに作成した直後にコールされます。
postCreateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに作成した直後にコールされます。
postCreateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに作成した直後にコールされます。
postCreateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに作成した直後にコールされます。
postCreateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに作成した直後にコールされます。
postCreateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
postCreateSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールにサブロールを追加した直後にコールされます。
postCreateSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールにサブロールを追加する直前にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアから削除した直後にコールされます。
postDelete(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアから削除した直後にコールされます。
postDelete(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアから削除した直後にコールされます。
postDelete(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアから削除した直後にコールされます。
postDeleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
postDeleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
postDeleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアから削除した直後にコールされます。
postDeleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアから削除した直後にコールされます。
postDeleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアから削除した直後にコールされます。
postDeleteLoginGroup(String) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアから削除した直後にコールされます。
postDeleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアから削除した直後にコールされます。
postDeleteMainPagePattern(String, String) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアから削除した直後にコールされます。
postDeleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
postDeleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロールからサブロールを削除した直後にコールされます。
postDeleteSubRole(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロールからサブロールを削除する直前にコールされます。
postDeleted(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postDeleted(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアから削除された後に呼び出されます。
postMove(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニューの親子関係を更新した直後にコールされます。
postMove(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニューの親子関係を更新した直後にコールされます。
postUpdate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener のメソッド
システム管理者情報をデータストアに更新した直後にコールされます。
postUpdate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener のメソッド
バッチ情報をデータストアに更新した直後にコールされます。
postUpdate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener のメソッド
グループ管理者情報をデータストアに更新した直後にコールされます。
postUpdate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener のメソッド
メニュー情報をデータストアに更新した直後にコールされます。
postUpdate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener のメソッド
メニュー情報をデータストアに更新した直後にコールされます。
postUpdateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。
postUpdateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます。
postUpdateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener のメソッド
カレンダーデータをデータストアに更新した直後にコールされます。
postUpdateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener のメソッド
マイメニュー情報をデータストアに更新した直後にコールされます。
postUpdateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに更新した直後にコールされます。
postUpdateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
ログイングループ情報をデータストアに更新した直後にコールされます。
postUpdateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに更新した直後にコールされます。
postUpdateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener のメソッド
メインページパターン情報をデータストアに更新した直後にコールされます。
postUpdateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
postUpdated(String, CompanyPost) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
postUpdated(String, CompanyPost) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
役職情報がデータストアに更新された後に呼び出されます。
prepareCall(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースのストアドプロシージャを呼び出すための CallableStatement オブジェクトを生成します。
prepareCall(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
prepareCall(String, int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型と並行処理で ResultSet オブジェクトを生成する CallableStatement オブジェクトを生成します。
prepareMimeMessage(MimeMessage) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
MIMEメッセージに対して操作を行います。
prepareSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションに対して操作を行います。
prepareStatement(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 パラメータ付き SQL 文をデータベースに送るための PreparedStatement オブジェクトを作成します。
prepareStatement(String, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 自動生成キーを取得する機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
prepareStatement(String, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定されたタイプと並行処理で ResultSet オブジェクトを生成する PreparedStatementオブジェクトを生成します。
prepareStatement(String, int, int, int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された型、並行処理、および保持機能で ResultSet オブジェクトを生成する PreparedStatement オブジェクトを生成します。
prepareStatement(String, int[]) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
prepareStatement(String, String[]) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された配列によって指定された自動生成キーを返す機能を持つデフォルトの PreparedStatement オブジェクトを生成します。
privateGroupAdded(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアに登録された後に呼び出されます。
privateGroupDeleted(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアから削除された後に呼び出されます。
privateGroupUpdated(String, PrivateGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
プライベートグループがデータストアに更新された後に呼び出されます。
propertyNames() - interface jp.co.intra_mart.foundation.service.provider.Environment のメソッド
システムプロパティリストにあるすべてのキーのリストを返します。
publicGroupAdded(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupAdded(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupDeleted(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます。
publicGroupLeft(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupLeft(String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
publicGroupUpdated(String, PublicGroup) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを保存します。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを保存します。
put(String, Object) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを保存します。
put(String, Object) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを保存します。
put(Object, Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 指定された値を、マップ内の指定されたキーに関連付けます 。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを保存します。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを保存します。
putAll(Map) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを保存します。
putAll(Map) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを保存します。
putCompanyCategoryTerminable(Term, CompanyCategoryTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyPostTerminable(Term, CompanyPostTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyPostTerminableInternational(Locale, CompanyPostTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putCompanyTerminable(Term, CompanyTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を設定します。
putCompanyTerminableInternational(Locale, CompanyTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putDepartmentAttachTerminable(Term, DepartmentAttachTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentMainTerminable(Term, DepartmentMainTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentTerminable(Term, DepartmentTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を設定します。
putDepartmentTerminableInternational(Locale, DepartmentTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putImage(OutputStream) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
指定のストリームにファイルを出力します。
putInternational(Locale, CateogryClassInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を設定します。
putInternational(Locale, CategoryDetailInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を設定します。
putPublicGroupAttachTerminable(Term, PublicGroupAttachTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupCategoryTerminable(Term, PublicGroupCategoryTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupSetTerminable(Term, PublicGroupSetTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupSetTerminableInternational(Locale, PublicGroupSetTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putPublicGroupTerminable(Term, PublicGroupTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を設定します。
putPublicGroupTerminableInternational(Locale, PublicGroupTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。
putUserTerminable(Term, UserTerminable) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を設定します。
putUserTerminableInternational(Locale, UserTerminableInternational) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
指定された言語に対する期間国際化情報を設定します。

Q

queryCreate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者情報をデータストアに作成する直前にコールされます。
queryCreate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアに作成する直前にコールされます。
queryCreate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアに作成する直前にコールされます。
queryCreate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアに作成する直前にコールされます。
queryCreate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアに作成する直前にコールされます。
queryCreateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアに作成する直前にコールされます。
queryCreateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます。
queryCreateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアに作成する直前にコールされます。
queryCreateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアに作成する直前にコールされます。
queryCreateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアに作成する直前にコールされます。
queryCreateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアに作成する前にコールされます。
queryCreateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアに作成する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアから削除する直前にコールされます。
queryDelete(String) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアから削除する直前にコールされます。
queryDelete(String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアから削除する直前にコールされます。
queryDelete(String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアから削除する直前にコールされます。
queryDeleteAccount(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアから削除する直前にコールされます。
queryDeleteAccountRole(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアから削除する直前にコールされます。
queryDeleteCalendarInfo(String, String, String) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアから削除する直前にコールされます。
queryDeleteFavoriteMenu(String, String, String) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアから削除する直前にコールされます。
queryDeleteLoginGroup(String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアから削除する直前にコールされます。
queryDeleteMainPagePattern(String, String) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアから削除する前にコールされます。
queryDeleteRole(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアから削除する直前にコールされます。
queryMove(String, String) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニューの親子関係を更新する直前にコールされます。
queryMove(String, String, String) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニューの親子関係を更新する直前にコールされます。
queryUpdate(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener のメソッド
システム管理者情報をデータストアに更新する直前にコールされます。
queryUpdate(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener のメソッド
バッチ情報をデータストアに更新する直前にコールされます。
queryUpdate(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener のメソッド
グループ管理者情報をデータストアに更新する直前にコールされます。
queryUpdate(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener のメソッド
メニュー情報をデータストアに更新する直前にコールされます。
queryUpdate(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener のメソッド
メニュー情報をデータストアに更新する直前にコールされます。
queryUpdateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウント情報をデータストアに更新する直前にコールされます。
queryUpdateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
アカウントロール情報をデータストアに更新する直前にコールされます。
queryUpdateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener のメソッド
カレンダーデータをデータストアに更新する直前にコールされます。
queryUpdateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener のメソッド
マイメニュー情報をデータストアに更新する直前にコールされます。
queryUpdateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
ログイングループ情報をデータストアに更新する直前にコールされます。
queryUpdateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener のメソッド
メインページパターン情報をデータストアに更新する前にコールされます。
queryUpdateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener のメソッド
ロール情報をデータストアに更新する直前にコールされます。
queue() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターを取得するための待ち行列に入っているスレッドの数です。

R

RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
最終更新日
RECORD_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
最終更新日
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
最終更新者
RECORD_USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
最終更新者
REMOVE - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REMOVE_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

REMOVE_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

RP_CLIENT_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
クライアントタイプのデフォルトＵＲＬ引数名。
RP_ENCODING - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエンコーディングのデフォルトＵＲＬ引数名。
RP_INITIAL_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
初期ＵＲＬのデフォルトＵＲＬ引数名。
RP_LOCALE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインロケールのデフォルトＵＲＬ引数名。
RP_LOGIN_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループIDのデフォルトＵＲＬ引数名。
RP_LOGIN_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインタイプのデフォルトＵＲＬ引数名。
RP_PASSWORD - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
パスワードのデフォルトＵＲＬ引数名。
RP_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
RP_URL_SIGN - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
RP_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインユーザＩＤのデフォルトＵＲＬ引数名。
RadarChartDrawer - class jp.co.intra_mart.foundation.graph.RadarChartDrawer.
レーダーチャートを描画します。
RadarChartDrawer(int, int, int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のコンストラクタ
ｙ軸の目盛値をint表現でレーダーチャートを作成します。
RadarChartDrawer(double, double, double) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のコンストラクタ
ｙ軸の目盛値をdouble表現でレーダーチャートを作成します。
RadarChartObject - class jp.co.intra_mart.foundation.graph.RadarChartObject.
RadarChartDrawerクラスのデータを保存するオブジェクトです。
RadarChartObject() - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
デフォルトのデータオブジェクトを作成します。
RadarChartObject(Color) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
グラフ線の色を指定して、データオブジェクトを作成します。
RadarChartObject(boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
塗りつぶしの可否を指定して、データオブジェクトを作成します。
RadarChartObject(Color, boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のコンストラクタ
グラフの色と塗りつぶしの可否を指定して、データオブジェクトを作成します。
Relationship - interface jp.co.intra_mart.foundation.datastore.common.config.Relationship.
リレーションシップを定義します。
ReplaceWriter - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter クラスを使用してください。
ReplaceWriter(Writer, char[]) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, char[], char[]) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String, String) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のコンストラクタ
推奨されていません。 文字列置換のためのストリームフィルタを作成します。
ReportFileConditioner - interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner クラスを使用してください。
ReportFileWriter - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter クラスを使用してください。
ReportFileWriter(File) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のコンストラクタ
推奨されていません。 ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
ReportLevel - interface jp.co.intra_mart.foundation.utility.report.ReportLevel.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel クラスを使用してください。
ReportLevelFilter - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter クラスを使用してください。
ReportLevelFilter(MessageReporter, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のコンストラクタ
推奨されていません。 指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
RepresentativeReporter - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter クラスを使用してください。
RepresentativeReporter(MessageReporter, EventQueueController) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のコンストラクタ
推奨されていません。 指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
RequestAnalyzer - interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer.
リクエストアナライザインタフェース。
RequestCharacterEncodingFilter - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter.
リクエストに対するエンコードは SessionInfo.getEncoding()が 返す値をになります。
RequestCharacterEncodingFilter() - class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter のコンストラクタ

ResourceBundleProperties - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties クラスを使用してください。
ResourceBundleProperties(String) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale, ClassLoader) - class jp.co.intra_mart.foundation.utility.ResourceBundleProperties のコンストラクタ
推奨されていません。 リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceFormatException - exception jp.co.intra_mart.foundation.utility.charset.ResourceFormatException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException クラスを使用してください。
ResourceFormatException(String) - class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException のコンストラクタ
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String, Throwable) - class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException のコンストラクタ
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceNotFoundException - exception jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException クラスを使用してください。
ResourceNotFoundException(String) - class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException のコンストラクタ
推奨されていません。 指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String, Throwable) - class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException のコンストラクタ
推奨されていません。 指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResponseCharacterEncodingFilter - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter.
レスポンスの文字エンコーディングを自動解決するフィルタです。
ResponseCharacterEncodingFilter() - class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter のコンストラクタ
新しくフィルタを作成します。
ReverseComparator - class jp.co.intra_mart.foundation.utility.ReverseComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator クラスを使用してください。
ReverseComparator(Comparator) - class jp.co.intra_mart.foundation.utility.ReverseComparator のコンストラクタ
推奨されていません。 指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
Role - class jp.co.intra_mart.foundation.security.role.Role.
ロール・モデルインタフェース。
Role() - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
Role(String) - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
Role(String, String) - class jp.co.intra_mart.foundation.security.role.Role のコンストラクタ
コンストラクタ。
RoleAccessor - interface jp.co.intra_mart.foundation.security.role.RoleAccessor.
ロールアクセッサインタフェース。
RoleChangedAccountListener - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener.
ロールが削除された場合にアカウントに紐付くロールを削除するリスナークラス。
RoleChangedAccountListener() - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のコンストラクタ
コンストラクタ。
RoleChangedListener - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener.
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleChangedMenuListener - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener.
ロールが削除された場合にメニューに紐付くロールを削除するリスナークラス。
RoleChangedMenuListener() - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のコンストラクタ
コンストラクタ。
RoleExporter - interface jp.co.intra_mart.foundation.security.role.RoleExporter.
ロールエクスポートインタフェースです。
RoleImporter - interface jp.co.intra_mart.foundation.security.role.RoleImporter.
ロールインポートインタフェースです。
RoleManager - class jp.co.intra_mart.foundation.acssecurity.RoleManager.
推奨されていません。
RoleManager(String) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のコンストラクタ
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManagerに置き換えられました。
RoleManager - class jp.co.intra_mart.foundation.security.role.RoleManager.
ロールマネージャクラス。
RoleManager(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のコンストラクタ
コンストラクタ。
RolePostWriterListener - interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener.
ロール情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
RoleQueryWriterListener - interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener.
ロール情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
RoleReaderDecorator - interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator.
ロール情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
read() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルの内容を取得します。
read() - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 データ取得。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 データ取得。
read() - class jp.co.intra_mart.foundation.utility.io.HexInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.foundation.utility.io.XORInputStream のメソッド
推奨されていません。 デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.XORInputStream のメソッド
推奨されていません。 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
readBoolean() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 boolean 型データ取得。
readInt() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 int 型データ取得。
readLines() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
readLines(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 ファイルの行を繰り返し処理する反復子を作成します。
readLong() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 long 型データ取得。
readObject() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 Object の取得。
readString() - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString() - class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream のメソッド
推奨されていません。 文字列の取得。
reconstruction() - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 現在使用中の Writer をリセットします。
registerAccountLicense(String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ライセンス登録します。
registerApplicationLicenseToAccount(String, String) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
アプリケーションライセンスをアカウントに登録します。
release() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースコネクションを解放します。
release() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターの開放。
release() - class jp.co.intra_mart.foundation.utility.net.SocketConnection のメソッド
推奨されていません。 ソケットおよび入出力ストリームの利用を中止します。
releaseCurrentThread() - class jp.co.intra_mart.foundation.service.client.information.Lock の static メソッド
現在のスレッドに紐付いたロックを全て解除します。
releaseSavepoint(Savepoint) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションから指定された Savepoint オブジェクトを削除します。
remove(String, String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを削除するメソッド

データベースのデータを削除(デリート)する。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap のメソッド
拡張名で指定された拡張基本アクセサ ExtendedBaseAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap のメソッド
拡張名で指定された拡張国際化アクセサ ExtendedInternationalAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap のメソッド
拡張名で指定された拡張期間化アクセサ ExtendedTerminableAccessor を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap のメソッド
拡張名で指定された拡張期間国際化アクセサ ExtendedTerminableInternationalAccessor を削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap のメソッド
指定された期間に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap のメソッド
指定された言語に該当するデータを削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap のメソッド
拡張名で指定された拡張基本モデル ExtendedBaseModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
remove(String) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap のメソッド
拡張名で指定された拡張国際化モデル ExtendedInternationalModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap のメソッド
拡張名で指定された拡張期間国際化モデル ExtendedTerminableInternationalModel を削除します。
remove(String) - interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap のメソッド
拡張名で指定された拡張期間化モデル ExtendedTerminableModel を削除します。
remove(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap のメソッド
指定された期間に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap のメソッド
指定された言語に該当するデータを削除します。
remove(Term) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap のメソッド
指定された期間に該当するデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
指定された位置の値を削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
指定された位置のデータを削除します。
remove(int) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
指定された位置の値を削除します。
remove() - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
このパス名が示すファイルまたはディレクトリを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを削除します。
remove(String) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを削除します。
remove(String) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを削除します。
remove(Object) - class jp.co.intra_mart.foundation.utility.FixedSizeMap のメソッド
推奨されていません。 このキーにマッピングがある場合に、そのマッピングをマップから削除します。
removeArgument(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を削除します。
removeCategoryDetail(CompanyCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に対して指定された分類区分情報を削除します。
removeCategoryDetail(PublicGroupCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに対して指定された分類区分情報を削除します。
removeChildNode(TreeNode) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたノード　node をこのノードの子から削除します。
removeChildNodes() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
子ノードを全て削除します。
removeCompanyCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
指定された期間に対する期間化情報を削除します。
removeCompanyPostTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
指定された期間に対する期間化情報を削除します。
removeCompanyTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
指定された期間に対する期間化情報を削除します。
removeComparator(Comparator) - class jp.co.intra_mart.foundation.utility.MultiComparator のメソッド
推奨されていません。 指定されたコンパレータ comparatorを削除します。
removeConditioner(GCConditioner) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
removeConditioner(ReportFileConditioner) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
removeDepartmentAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentMainTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
指定された期間に対する期間化情報を削除します。
removeDepartmentTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
指定された期間に対する期間化情報を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
ロケールに対応した表示名を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ロケールに対応したメニュー名を削除します。
removeDisplayName(Locale) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロケールに対応したロール表示名を削除します。
removeFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
指定された言語に対する国際化情報を削除します。
removeInternational(Locale) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
指定された言語に対する国際化情報を削除します。
removeListener(EventListener) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
指定されたリスナーを削除します。
removeMain(DepartmentMain) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
指定されたユーザの主所属を削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定のキーのマップを削除します。
removePublicGroupAttachTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupCategoryTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupSetTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
指定された期間に対する期間化情報を削除します。
removePublicGroupTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
指定された期間に対する期間化情報を削除します。
removeReporter(MessageReporter) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
removeUserTerminable(Term) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
指定された期間に対する期間化情報を削除します。
report(String) - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.FileReporter のメソッド
推奨されていません。 メッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.LineReportFilter のメソッド
推奨されていません。 基礎出力ストリームに対してメッセージを出力します。
report(String) - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - interface jp.co.intra_mart.foundation.utility.report.MessageReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.MultiCastReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter のメソッド
推奨されていません。 メッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 メッセージを出力します。
report(String, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 data をメッセージとして出力します。
report(Object, int) - class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter のメソッド
推奨されていません。 指定のメッセージレベルが基準値以上のメッセージを出力します。
report(String) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 メッセージを出力します。
report(Object) - class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter のメソッド
推奨されていません。 data をメッセージとして出力します。
reportError(ErrorEvent) - interface jp.co.intra_mart.foundation.utility.ErrorEventListener のメソッド
推奨されていません。 発生した例外を通知します。
reset() - class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory のメソッド
推奨されていません。 キャッシュ領域をクリアします。
reset(Writer) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 文字の出力ストリームをリセットします。
resetLock() - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロックをリセットします。
restart() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの再開通知。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleAdded(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleDeleted(String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアから削除した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
roleUpdated(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロール情報をデータストアに更新した直後にコールされます。
rollback() - interface jp.co.intra_mart.foundation.database.DatabaseAccessor のメソッド
データベースのトランザクションをロールバックします。
rollback() - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベースのトランザクションをロールバックします。
rollback() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスの取り消し処理をする

トランザクションを終了(rollback)させる。
rollback(Savepoint) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 指定された Savepoint オブジェクトが設定されたあとに行われたすべての変更を元に戻します。
run() - class jp.co.intra_mart.foundation.utility.ExtendedThread のメソッド
推奨されていません。 このオブジェクトのスレッド実行ロジックです。

S

SCALE_POSITION_CENTER - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの中心」に設定
SCALE_POSITION_SIDE - class jp.co.intra_mart.foundation.graph.PortFolioDrawer の static 変数
ｘ軸、ｙ軸の目盛りの表示位置を「グラフの枠」に設定
SET - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SET_ENTIRETY - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SET_ITEM - class jp.co.intra_mart.foundation.service.client.NetworkConnector の static 変数

SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel の static 変数
ソートキー
SORT_KEY - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ソートキー
SP_CLIENT_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
クライアントタイプをセッションに保管するパラメータ名。
SP_COLOR_PATTERN_ID - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
カラーパターンIDをセッションに保管するパラメータ名。
SP_ENCODING - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインエンコーディングをセッションに保管するパラメータ名。
SP_INITIAL_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
初期ページURLを属性に保管するパラメータ名。
SP_LOCALE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインロケールをセッションに保管するパラメータ名。
SP_LOGIN_GROUP - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイングループIDをセッションに保管するパラメータ名。
SP_LOGIN_TIME - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインした時間をセッションに保管するパラメータ名。
SP_LOGIN_TYPE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインタイプをセッションに保管するパラメータ名。
SP_SIGNATURE - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログイン署名をセッションに保管するパラメータ名。
SP_URL - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
認証後表示するメインページをセッションに保管するパラメータ名。
SP_URL_SIGN - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
SP_USER - interface jp.co.intra_mart.foundation.security.SecurityConstraint の static 変数
ログインユーザＩＤをセッションに保管するパラメータ名。
SSORequestAnalyzer - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer.
SSOのログインリクエスト解析クラス。
SSORequestAnalyzer() - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer のコンストラクタ

SSO_LOGOUT_URL - class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer の static 変数

START_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
開始日
START_DATE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
開始日
STRING - class jp.co.intra_mart.foundation.datastore.common.config.AttributeType の static 変数
文字列型
Scheduler - class jp.co.intra_mart.foundation.service.client.batch.Scheduler.
Schedule Service の制御をするオブジェクトです。
Scheduler() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のコンストラクタ
新しいオブジェクトを構築します。
ScriptCompileException - exception jp.co.intra_mart.foundation.scenario.ScriptCompileException.
ScriptCompileException クラスは、スクリプトのコンパイル時にエラーが発生 場合にスローされる例外です。
ScriptCompileException(String) - class jp.co.intra_mart.foundation.scenario.ScriptCompileException のコンストラクタ
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptCompileException(String, Throwable) - class jp.co.intra_mart.foundation.scenario.ScriptCompileException のコンストラクタ
詳細メッセージを指定して ScriptCompileException を構築します。
ScriptRuntimeException - exception jp.co.intra_mart.foundation.scenario.ScriptRuntimeException.
ScriptRuntimeException クラスは、スクリプトの実行時にエラーが発生 場合にスローされる例外です。
ScriptRuntimeException(String) - class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException のコンストラクタ
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException のコンストラクタ
詳細メッセージを指定して ScriptRuntimeException を構築します。
ScriptValue - interface jp.co.intra_mart.foundation.scenario.ScriptValue.
スクリプトの値を保持するオブジェクトです。
SecurityConstraint - interface jp.co.intra_mart.foundation.security.SecurityConstraint.
アクセスセキュリティ定数インタフェース。
SequenceComparator - class jp.co.intra_mart.foundation.utility.SequenceComparator.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator クラスを使用してください。
SequenceComparator() - class jp.co.intra_mart.foundation.utility.SequenceComparator のコンストラクタ
推奨されていません。 新しいオブジェクトを生成します。
ServerConnector - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector.
このクラスは、Server-Manager にリクエストを送信して 処理を要求するためのオブジェクトです。
ServerConnector(SocketConnectionDistributor) - class jp.co.intra_mart.foundation.service.client.manager.ServerConnector のコンストラクタ
オブジェクトを作成します。
ServiceFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler.
im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServiceFrameworkHTTPActionEventHandler(String, String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServletHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler.
Web-Application を実行するためのイベントハンドラです。
ServletHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
ServletHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
SessionConfig - interface jp.co.intra_mart.foundation.security.SessionConfig.
セッションに関する設定情報を取得するインタフェース。
SessionFactory - class jp.co.intra_mart.foundation.service.client.information.SessionFactory.
共有データグループを管理するオブジェクトです。
SessionFactory(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.client.information.SessionFactory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
SessionFilter - class jp.co.intra_mart.foundation.security.filter.SessionFilter.
セッションフィルタ。
SessionFilter() - class jp.co.intra_mart.foundation.security.filter.SessionFilter のコンストラクタ

SessionInfo - interface jp.co.intra_mart.foundation.security.SessionInfo.
intra-martセッション情報参照インタフェース。
SessionMemory - class jp.co.intra_mart.foundation.service.client.information.SessionMemory.
共有データを管理するオブジェクトです。
SessionMemory(HttpSession) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のコンストラクタ
共有データを扱うための新しいオブジェクトを構築します。
SessionQuery - class jp.co.intra_mart.foundation.http.SessionQuery.
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
SessionQuery(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.http.SessionQuery のコンストラクタ
推奨されていません。 GenericURLBuilder および URLBuilder に置き替えられました。
SocketConnection - class jp.co.intra_mart.foundation.utility.net.SocketConnection.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection クラスを使用してください。
SocketConnection(String, int) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnection(Socket) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnection(ExtendedSocket) - class jp.co.intra_mart.foundation.utility.net.SocketConnection のコンストラクタ
推奨されていません。 ソケット入出力インスタンスを構築します。
SocketConnectionDistributor - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor クラスを使用してください。
SocketConnectionDistributorFactory - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory.
このクラスは、Server-Manager に接続するための ネットワークコネクション管理オブジェクトを作成するためのクラスです。
SocketConnectionDistributorFactory(String, int) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のコンストラクタ
オブジェクトを作成します。
SocketConnectionDistributorFactory(String, int, int) - class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory のコンストラクタ
オブジェクトを作成します。
SocketConnectionManager - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager クラスを使用してください。
SocketEventListener - interface jp.co.intra_mart.foundation.utility.net.SocketEventListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener クラスを使用してください。
SocketPool - class jp.co.intra_mart.foundation.utility.net.SocketPool.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool クラスを使用してください。
SocketPool(String, int) - class jp.co.intra_mart.foundation.utility.net.SocketPool のコンストラクタ
推奨されていません。 ソケットプールを構築します。
SocketPool(String, int, int) - class jp.co.intra_mart.foundation.utility.net.SocketPool のコンストラクタ
推奨されていません。 ソケットプールを構築します。
StandardAccountBackup - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup.
アカウントバックアップクラスです。
StandardAccountBackup() - class jp.co.intra_mart.foundation.security.account.StandardAccountBackup のコンストラクタ

StandardAdminMenuBackup - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup.
メニューバックアップクラスです。
StandardAdminMenuBackup() - class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup のコンストラクタ

StandardBatchBackup - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup.
バッチバックアップクラスです。
StandardBatchBackup() - class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup のコンストラクタ

StandardCalendarBackup - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup.
カレンダーバックアップクラスです。
StandardCalendarBackup() - class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup のコンストラクタ

StandardCompanyImporter - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter.
会社のインポートを行います。
StandardCompanyImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter のコンストラクタ

StandardCompanyPostImporter - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter.
役職のインポートを行います。
StandardCompanyPostImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter のコンストラクタ

StandardCryption - class jp.co.intra_mart.foundation.security.cryption.StandardCryption.
文字列の暗号化・復号化を行う標準の実装クラスです。
StandardCryption() - class jp.co.intra_mart.foundation.security.cryption.StandardCryption のコンストラクタ
コンストラクタ。
StandardErrorPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider.
標準のエラーページプロバイダクラス。
StandardErrorPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardGroupSuperUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider.
標準のログイングループ管理者用ページプロバイダクラス。
StandardGroupSuperUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardMail - class jp.co.intra_mart.foundation.mail.javamail.StandardMail.
送信するメールの属性を保管します。
StandardMail() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
ロケールを指定してメール属性オブジェクトを新規に作成します。
StandardMenuBackup - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup.
メニューバックアップクラスです。
StandardMenuBackup() - class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup のコンストラクタ

StandardPublicGroupImporter - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter.
パブリックグループのインポートを行います。
StandardPublicGroupImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter のコンストラクタ

StandardRequestAnalyzer - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer.
標準のログインリクエスト解析クラス。
StandardRequestAnalyzer() - class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer のコンストラクタ
デフォルトコンストラクタ。
StandardRoleBackup - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup.
ロールバックアップクラスです。
StandardRoleBackup() - class jp.co.intra_mart.foundation.security.role.StandardRoleBackup のコンストラクタ

StandardSuperUserCertification - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification.
管理者ログイン認証の実装クラス。
StandardSuperUserCertification() - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification のコンストラクタ
デフォルトコンストラクタ

StandardSuperUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider.
標準のシステム管理者用のユーザページプロバイダクラス。
StandardSuperUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StandardUserCertification - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification.
ユーザログイン認証クラス。
StandardUserCertification() - class jp.co.intra_mart.foundation.security.certification.StandardUserCertification のコンストラクタ
デフォルトコンストラクタ。
StandardUserImporter - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter.
ユーザプロファイルのインポートを行います。
StandardUserImporter() - class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter のコンストラクタ

StandardUserPageProvider - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider.
標準のユーザページプロバイダクラス。
StandardUserPageProvider() - class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider のコンストラクタ
デフォルトコンストラクタ

StorageDirectory - class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory.
Storage Service の基準ディレクトリを表すクラスです。
SuperCertification - interface jp.co.intra_mart.foundation.security.certification.SuperCertification.
管理者ログイン認証インタフェース。
SuperUser - class jp.co.intra_mart.foundation.security.admin.SuperUser.
スーパーユーザ・モデルインタフェース。
SuperUser() - class jp.co.intra_mart.foundation.security.admin.SuperUser のコンストラクタ
コンストラクタ。
SuperUser(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のコンストラクタ
コンストラクタ。
SuperUserAccessor - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor.
システム管理者アクセッサインタフェース。
SuperUserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet.
システム管理者初期アクセスサーブレット。
SuperUserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet のコンストラクタ

SuperUserNoCertification - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification.
システム管理者ログイン時に強制認証を行う実装クラスです。
SuperUserNoCertification() - class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification のコンストラクタ
デフォルトコンストラクタ

SuperUserPostWriterListener - interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener.
システム管理者情報書き込み時（書き込み直後）のリスナ・インターフェースを定義します。
SuperUserQueryWriterListener - interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener.
システム管理者情報書き込み時（書き込み直前）のリスナ・インターフェースを定義します。
SuperUserReaderDecorator - interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator.
システム管理者情報読み込み時（読み込み直後）の拡張インターフェースを定義します。
SystemConfigException - exception jp.co.intra_mart.foundation.security.exception.SystemConfigException.
システム設定に関する例外クラス。
SystemConfigException() - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(String) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(String, Throwable) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemConfigException(Throwable) - class jp.co.intra_mart.foundation.security.exception.SystemConfigException のコンストラクタ
コンストラクタ。
SystemErrorReporter - interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter.
エラーログ出力用のインターフェースです。
SystemManager - class jp.co.intra_mart.foundation.security.SystemManager.
システムマネージャクラス。
SystemReporter - interface jp.co.intra_mart.foundation.service.provider.SystemReporter.
システムログの共通インターフェースです。
SystemSourceProvider - interface jp.co.intra_mart.foundation.security.SystemSourceProvider.
ロケール情報取得インターフェース。
save(byte[]) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにバイトを出力します。
searchAccounts(String, String) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報の読み込みます。
searchAccounts(String) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
ユーザIDを検索してマッチしたアカウントを配列で返します。
searchRolesById(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロールID検索によりロールを取得します。
searchRolesByName(String) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール名称検索によりロールを取得します。
secureRedirect(HttpServletRequest, HttpServletResponse, String, Map) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
secureRedirect(String, Map) - class jp.co.intra_mart.foundation.security.AccessSecurityManager のメソッド
呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
select(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 SELECT文を発行してデータベースからデータを取得する

select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
プライマリーキーで特定される分類区分の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
プライマリーキーで特定される分類区分詳細の基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
プライマリーキーで特定される組織所属の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
プライマリーキーで特定される会社組織分類の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
プライマリーキーで特定される会社の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
プライマリーキーで特定される組織の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
プライマリーキーで特定される組織内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
プライマリーキーで特定される主所属の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
プライマリーキーで特定される役職の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
プライマリーキーで特定される会社構成バージョンの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライマリーキーで特定されるプライベートグループ所属の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライマリーキーで特定されるプライベートグループの基本モデルを取得します。
select(String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
プライマリーキーで特定されるパブリックグループ所属の基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
プライマリーキーで特定されるパブリックグループ分類の基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
プライマリーキーで特定されるパブリックグループの基本モデルを取得します。
select(String, String, String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
プライマリーキーで特定されるパブリックグループ内包の基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
プライマリーキーで特定されるパブリックグループセットの基本モデルを取得します。
select(String, String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
プライマリーキーで特定されるパブリックグループ構成バージョンの基本モデルを取得します。
select(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
プライマリーキーで特定されるユーザの基本モデルを取得します。
select(Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
プライマリーキーで特定される基本モデルを取得します。
select(Relationship, Map) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
外部キーで特定される基本モデルをすべて取得します。
select(Map) - interface jp.co.intra_mart.foundation.datastore.common.model.Mapper のメソッド
プライマリーキーで特定される基本モデルを取得します。
selectCategoryDetailInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
指定された言語に該当する分類区分詳細の国際化モデルを取得します。
selectCateogryClassInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
指定された言語に該当する分類区分の国際化モデルを取得します。
selectCompanyPostTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
指定された言語に該当する役職の期間国際化モデルを取得します。
selectCompanyPostTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
指定された日付に該当する役職の期間化モデルを取得します。
selectDepartmentAttachTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
指定された日付に該当する組織所属の期間化モデルを取得します。
selectDepartmentMainTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
指定された日付に該当する主所属の期間化モデルを取得します。
selectDepartmentTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
指定された言語に該当する組織の期間国際化モデルを取得します。
selectDepartmentTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
指定された日付に該当する組織の期間化モデルを取得します。
selectInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定された言語に該当する国際化モデルを取得します。
selectPublicGroupTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
指定された言語に該当するパブリックグループの期間国際化モデルを取得します。
selectPublicGroupTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
指定された日付に該当するパブリックグループの期間化モデルを取得します。
selectTerminableInternationalModel(Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定された言語に該当する期間国際化モデルを取得します。
selectTerminableModel(Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定された日時に該当する期間化モデルを取得します。
selectUserTerminableInternationalModel(Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
指定された言語に該当するユーザの期間国際化モデルを取得します。
selectUserTerminableModel(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
指定された日付に該当するユーザの期間化モデルを取得します。
send() - interface jp.co.intra_mart.foundation.mail.MailSender のメソッド
メールを送信します。
send() - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のメソッド
メールを送信します。
send() - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 指定されたSMTPサーバへメールを送信する。
serverTime() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバのミリ秒で表される現在の時間を返します。
set(String, Number) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
set(String, String) - class jp.co.intra_mart.foundation.acssecurity.Logingp のメソッド
推奨されていません。 代替えメソッドはありません。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に値を設定します。
set(String, Object, Date) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の日時で値を設定します。
set(String, Object, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の言語で値を設定します。
set(String, Object, Date, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel のメソッド
指定の属性に、指定の日時、言語で値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel のメソッド
指定の属性に値を設定します。
set(String, Object) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性に値を設定します。
set(String, Object, Locale) - class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel のメソッド
指定の属性に値を設定します。
setAccount(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 AccountManager.importData(String category, InputStream inputStream)に置き換えられました。
setAccount(String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
アカウントＩＤを設定します。
setAccountFlag(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
このメソッドはシステム内で使用されます。
setAccountFlag(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
アカウントフラグを設定します。
setAddress(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
住所を設定します。
setAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を設定します。
setAddress(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
住所を設定します。
setAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所1を設定します。
setAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所1を設定します。
setAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を設定します。
setAddress1(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所1を設定します。
setAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
住所2を設定します。
setAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
住所2を設定します。
setAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を設定します。
setAddress2(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
住所2を設定します。
setAll(TreeBranch) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
指定された branch 内の表示名称、ポップアップ文字列、引数文字列をこのオブジェクトに設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーション名を設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーションＩＤを設定します。
setArgument(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
引数文字列を設定します。
setArgument(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列を設定します。
setArgument(String, String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
引数を設定します。
setAttachInfo(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
setAutoCommit(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。
setBaseAccessor(BaseAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
基本アクセサを設定します。
setBaseName(String) - class jp.co.intra_mart.foundation.datastore.exception.MapperException の static メソッド
リソースバンドルの基底名を設定します。
setBatchId(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチＩＤを設定します。
setBcc(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Bccをセットする。
setBcc(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Bccをセットする。
setBody(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 本文をセットする。
setCapacity(int) - class jp.co.intra_mart.foundation.utility.EventQueueController のメソッド
推奨されていません。 キューの容量を変更します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプション文字列を返します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaption(String[]) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
ｘ軸のキャプションを設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
キャプションの文字色を設定します。
setCaptionColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプションの文字色を設定します。
setCaptionMargin(int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
キャプション表示位置のマージンを設定します。
setCaptionMargin(int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
キャプション表示位置のマージンを設定します。
setCatalog(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection のデータベースに作業のためのサブスペースを選択するために、カタログ名を設定します。
setCategory(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールカテゴリを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類区分コードを設定します。
setCategoryClassCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類区分コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
分類コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
分類コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
分類コードを設定します。
setCategoryDetail(CompanyCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に対して指定された分類区分情報を設定します。
setCategoryDetail(PublicGroupCategory) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに対して指定された分類区分情報を設定します。
setCc(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Ccをセットする。
setCc(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Ccをセットする。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を指定します。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder のメソッド
推奨されていません。 このオブジェクトが対象とする文字エンコーディングを設定します。
setClientType(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
クライアントタイプを設定する。
setClientType(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
クライアントタイプを設定します。
setClosed() - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
このアクセサをクローズします。
setColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
棒の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
線の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点の色を設定します。
setColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
グラフ線の色を設定します。
setColor(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
色を設定します。
setColorPatternId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
カラーパターンIDを設定します。
setColorPatternId(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
カラーパターンIDを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
会社コードを設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
会社コードを設定します。
setCompanyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを設定します。
setCompanyCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
会社コードを設定します。
setCompanyCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
会社コードを設定します。
setContentType(String) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルのフォーマットを設定します。
setContents(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
コンテンツの種類を設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
国コードを設定します。
setCountryCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを設定します。
setCountryCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを設定します。
setCountryCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
国コードを設定します。
setCountryCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
国コードを設定します。
setData(Map) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.account.AccountManager.addAcount(Account) およびupdateAccount(Account)に置き換えられました。
ライセンス情報はjp.co.intra_mart.foundation.security.license.LicenseManager.registerAccountLicense(String)に置き換えられました。
Accountクラスに含まれない情報はjp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerを利用して、更新してください。

setData(Map, boolean) - class jp.co.intra_mart.foundation.acssecurity.AccountManager のメソッド
推奨されていません。
setData(Map) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
setData(Map, boolean) - class jp.co.intra_mart.foundation.acssecurity.RoleManager のメソッド
推奨されていません。 jp.co.intra_mart.foundation.security.role.RoleManager.addRole(Role)およびupdateRole(Role)に置き換えられました。
setDataId(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データIDを設定します。
setDataSourceRefName(String) - interface jp.co.intra_mart.foundation.database.ConInfo のメソッド
DataSourceへの参照名を設定します。
setDataType(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データタイプを設定します。
setDatabaseAccessor(DatabaseAccessor) - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
データベースアクセッサを設定します。
setDay(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
日を設定します。
setDayWeek(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
曜日を設定します。
setDefaultDate(Date) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト日時を設定します。
setDefaultLocale(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
デフォルト言語を設定します。
setDefaultLocale(Locale) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
デフォルト言語を設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
組織コードを設定します。
setDepartmentCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable のメソッド
組織コードを設定します。
setDepartmentCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを設定します。
setDepartmentCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel のメソッド
組織コードを設定します。
setDepartmentCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel のメソッド
組織コードを設定します。
setDepth(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel のメソッド
階層レベルを設定します。
setDepth(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel のメソッド
階層レベルを設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ内容を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
データの説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
説明を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
説明を設定します。
setDisplayName(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
マイメニュー表示名を設定する。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
表示名を設定します。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニュー名を設定します。
setDisplayName(Locale, String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール表示名を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス１を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス1を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を設定します。
setEmailAddress1(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス１を設定します。
setEmailAddress1(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス１を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
メールアドレス２を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
メールアドレス2を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を設定します。
setEmailAddress2(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
メールアドレス２を設定します。
setEmailAddress2(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
メールアドレス２を設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
エンコーディング情報を設定します。
setEncoding(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
エンコーディングの設定。
setEncoding(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインエンコーディングを設定する。
setEncoding(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
エンコーディングを設定します。
setEndDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
終了日を設定します。
setEndDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
終了日を設定します。
setEndDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
終了日を設定します。
setEndDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
終了日を設定します。
setExtendedBaseModelMap(ExtendedBaseModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
拡張基本モデルマップを設定します。
setExtendedInternationalModelMap(ExtendedInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
拡張国際化モデルマップを設定します。
setExtendedTerminableInternationalModelMap(ExtendedTerminableInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
拡張期間国際化モデルマップを設定します。
setExtendedTerminableModelMap(ExtendedTerminableModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
拡張期間化モデルマップを設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線FAX番号を設定します。
setExtensionFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線FAX番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
内線番号を設定します。
setExtensionNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
内線番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
FAX番号を設定します。
setFaxNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
FAX番号を設定します。
setFill(boolean) - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
描画されるグラフの塗りつぶし可否を設定します。
setFilterParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを設定します。
setFlowComponent(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのフローコンポーネント名を設定します。
setFocus(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントとして監視する変数名を指定します。
setFontColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字色を設定します。
setFontSize(int) - class jp.co.intra_mart.foundation.graph.CircleGraphObject のメソッド
キャプションの文字サイズを設定します。
setFrom(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Fromをセットする。
setFrom(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 Fromをセットする。
setGoOut(boolean) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
外出状態を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域の背景色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のボーダーの色を設定します。
setGraphFrameColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ枠の線色を設定します。
setGroup(String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
グループＩＤを設定します。
setHeader(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 メールヘッダを設定する。
setHeight(int) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの高さを設定します。
setHoldability(int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection オブジェクトを使用して生成された ResultSet オブジェクトの保持機能を指定された保持機能へ変更します。
setId(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューIDを設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルの背景色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImageBorderColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
画像ファイルのボーダ色を設定します。
setImagePath(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
メニューイメージパスを設定します。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
setImgaeBackgroundColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
推奨されていません。
setImgaeBorderColor(Color) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
推奨されていません。
setInitialUrl(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
初期アクセスURLを設定する。
setInitialize(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントの初期値を指定します。
setInternationalAccessor(InternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext のメソッド
国際化アクセサを設定します。
setInternationalModelMap(InternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
国際化モデルマップを設定します。
setKey(String) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージを作成するためのキーを取得します。
setLink(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ロケールを設定します。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ロケールの設定。
setLocale(Locale) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインロケールを設定する。
setLocale(Locale) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ロケールを設定します。
setLocation(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
遷移先のページパスを設定します。
setLockCount(int) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックするログイン失敗回数を設定します。
setLockDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
アカウントロック日付を設定します。
setLockTerm(int) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
アカウントをロックする期間を設定します。
setLoginFailureCount(int) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ログイン失敗回数を設定します。
setLoginGroup(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログイングループIDを設定する。
setLoginGroupId(String) - class jp.co.intra_mart.foundation.security.group.LoginGroup のメソッド
ログイングループIDを設定します。
setMailAddress(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
メールアドレス設定。
setMain(DepartmentMain) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
ユーザが主所属する組織を設定します。
setMainPagePatternId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
メインページパターンIDを設定する。
setMainPagePatternImageUrl(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンイメージURLを設定する。
setMainPagePatternUrl(String) - class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo のメソッド
メインページパターンURLを設定する。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
グラフ領域のマージンを設定します。
setMargin(int, int, int, int) - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
グラフ領域のマージンを設定します。
setMaxLicense(double) - class jp.co.intra_mart.foundation.security.license.LicenseManager のメソッド
ログイングループ内の最大登録可能ライセンス数を設定します。
setMember(DepartmentAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
組織に人員を割り当てます。
setMember(PrivateGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
プライベートグループに人員を割り当てます。
setMember(PublicGroupAttach) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
パブリックグループに人員を割り当てます。
setMenu(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 MenuManager.importData(String category, InputStream inputStream)に置き換えられました。
setMenuId(String) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
メニューIDを設定します。
setMessage(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 代替えメソッドはありません。
setMobileEmailAddress(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯用メールを設定します。
setMobileEmailAddress(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯用メールを設定します。
setMobileNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
携帯電話番号を設定します。
setMobileNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を設定します。
setMobileNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
携帯電話番号を設定します。
setMobileNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
携帯電話番号を設定します。
setMobilePassword(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
モバイル用パスワードを設定します。
setMonth(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
月を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational のメソッド
分類区分名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational のメソッド
分類名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational のメソッド
役職名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
分類区分名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel のメソッド
分類区分名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
分類名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel のメソッド
分類名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel のメソッド
役職名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名を設定します。
setName(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を設定します。
setName(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名を設定します。
setName(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
項目の表示名称のを設定します。
setName(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
項目の表示名称を設定します。
setName(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチ名を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名英字を設定します。
setNameEnglish(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を設定します。
setNameEnglish(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名英字を設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational のメソッド
組織名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational のメソッド
組織名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
組織名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel のメソッド
グループ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Date, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを設定します。
setNameSyllabary(String, Locale) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
ユーザ名カナを設定します。
setNote(String) - class jp.co.intra_mart.foundation.page.TreeBranch のメソッド
マウスポイント時に表示されるポップアップ文字列を設定します。
setNote(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のメソッド
マウスポイント時に表示されるポップアップ文字列を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
備考を設定します。
setNotes(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
備考を設定します。
setNotes(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
備考を設定します。
setOnChange(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
監視している値に変更があった場合に実行するスクリプトを指定します。
setOwnerCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
所有者コードを設定します。
setOwnerCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
所有者コードを設定します。
setPagePath(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
実行するページベース開発モデルのページパスを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントへのパラメータを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
パスワードを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
パスワード設定。
setPassword(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインパスワードを設定する。
setPassword(String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
パスワードを設定します。
setPlugin(String) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
プラグインIDを設定します。
setPostCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable のメソッド
役職CDを設定します。
setPostCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
役職コードを設定します。
setPostCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを設定します。
setPostCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
役職CDを設定します。
setPostCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel のメソッド
役職CDを設定します。
setPrivateGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
グループコードを設定します。
setPrivateGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
グループコードを設定します。
setProgramLanguage(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラム言語の種類を設定します。
setProgramPath(String) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行プログラムパスを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor のメソッド
プロパティを設定します。
setProperty(String, Object) - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor のメソッド
プロパティを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループコードを設定します。
setPublicGroupCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
グループセットコードを設定します。
setPublicGroupSetCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
グループセットコードを設定します。
setReadOnly(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この Connection を読み込み専用モードに設定して、データベース最適化を実行するヒントとします。
setReceive(String) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントから値を受け取る変数名を指定します。
setReplyTo(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 リプライをセットする。
setReplyTo(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 リプライをセットする。
setRole(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 RoleManager.importData(String category, InputStream inputStream)に置き換えられました。
setRoleId(String) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロールIDを設定します。
setRoleId(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロールIDを設定します。
setRoleName(String) - class jp.co.intra_mart.foundation.security.role.Role のメソッド
ロール名を設定します。
setRoleValidEndDate(Date) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効終了日を設定します。
setRoleValidStartDate(Date) - class jp.co.intra_mart.foundation.security.account.AccountRole のメソッド
ロール有効開始日を設定します。
setRunDay(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行日を設定します。
setRunDayWeek(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行曜日を設定します。
setRunHour(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行時を設定します。
setRunMinute(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行分を設定します。
setRunMonth(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行月を設定します。
setRunSecond(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行秒を設定します。
setRunYear(int) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
実行年を設定します。
setSavepoint() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションで名前のないセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
setSavepoint(String) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 現在のトランザクションで指定された名前のセーブポイントを作成し、それを表す新しい Savepoint オブジェクトを返します。
setScalePosition(String) - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
ｘ軸、ｙ軸の目盛りの表示位置を設定します。
setSchedule(String, String) - class jp.co.intra_mart.foundation.acssecurity.AcsData の static メソッド
推奨されていません。 BatchManager.importData(String category, InputStream inputStream)に置き換えられました。
setService(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのサービスＩＤを設定します。
setSize(int) - class jp.co.intra_mart.foundation.graph.PortFolioObject のメソッド
描画する点のサイズを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet のメソッド
ソートキーを設定します。
setSortKey(int) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel のメソッド
ソートキーを設定します。
setSortKey(int) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
ソートキーを設定します。
setSortNumber(int) - class jp.co.intra_mart.foundation.security.account.FavoriteMenu のメソッド
ソート番号を設定します。
setSortNumber(int) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ソート番号を設定します。
setSorucePovider(SystemSourceProvider) - class jp.co.intra_mart.foundation.security.SystemManager の static メソッド
ソースプロバイダを設定します。
setSourceProvider(DataSourceProvider) - class jp.co.intra_mart.foundation.database.DatabaseManager の static メソッド
ソースプロバイダを設定します。
setStartDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
開始日を設定します。
setStartDate(Date) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
開始日を設定します。
setStartDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel のメソッド
開始日を設定します。
setStartDate(Date) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel のメソッド
開始日を設定します。
setStartPoint(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフローのスタートポイント名を設定します。
setStroke(Stroke) - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
描画される線の描画属性を設定します。
setSubject(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを設定します。
setSubject(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 タイトルをセットする。
setTelNo(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
電話番号設定。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
電話番号を設定します。
setTelephoneNumber(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
電話番号を設定します。
setTerminableAccessor(TerminableAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間化アクセサを設定します。
setTerminableInternationalAccessor(TerminableInternationalAccessor) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext のメソッド
期間国際化アクセサを設定します。
setTerminableInternationalModelMap(TerminableInternationalModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext のメソッド
期間国際化モデルマップを設定します。
setTerminableModelMap(TerminableModelMap) - interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext のメソッド
期間化モデルマップを設定します。
setText(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を設定します。
setTimer(boolean) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 トランザクション自動切断機能のタイマーをセットする（デフォルトtrue）

setTimer(int) - class jp.co.intra_mart.foundation.page.EventScript のメソッド
イベントの監視間隔を設定します。
setTimes(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
第ｎ～曜日を設定します。
setTo(String) - class jp.co.intra_mart.foundation.http.SessionQuery のメソッド
推奨されていません。 代替えメソッドはありません。
setTo(String, String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 To(宛先)をセットする。
setTo(String) - class jp.co.intra_mart.foundation.smtp.Mail のメソッド
推奨されていません。 To(宛先)をセットする。
setTransactionIsolation(int) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 トランザクション遮断レベルを指定されたものに変更することを試みます。
setType(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
ノードのタイプを設定します。
setTypeMap(Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 この接続の型マップとして指定された型マップをインストールします。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ログインユーザIDを設定します。
setUesrId(String) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
ログインユーザIDを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
URLを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを設定します。
setUrl(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを設定します。
setUrl(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
URLを設定します。
setUrl(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬを設定する。
setUrl(String) - class jp.co.intra_mart.foundation.security.menu.MenuItem のメソッド
URLを設定します。
setUrlSignature(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ダイレクトＵＲＬ署名を設定する。
setUser(String) - interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo のメソッド
ログインユーザIDを設定する。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach のメソッド
ユーザコードを設定します。
setUserCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のメソッド
ユーザコードを設定します。
setUserId(String) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
ログインユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
ユーザIDを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.security.admin.SuperUser のメソッド
ユーザID設定。
setUserId(String) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
ログインユーザIDを設定します。
setValidEndDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効終了日を設定します。
setValidEndYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効終了年を設定します。
setValidStartDate(Date) - class jp.co.intra_mart.foundation.security.account.Account のメソッド
有効開始日を設定します。
setValidStartYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
有効開始年を設定します。
setValidate(boolean) - class jp.co.intra_mart.foundation.security.batch.Batch のメソッド
バッチの有効・無効を設定します。
setValues(String[]) - class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException のメソッド
エラーメッセージで使用する置換用の文字列を設定します。
setVersionCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion のメソッド
バージョンコードを設定します。
setVersionCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion のメソッド
バージョンコードを設定します。
setWeek(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
第ｎ週目を設定します。
setWidth(int) - class jp.co.intra_mart.foundation.drawer.AbstractDrawer のメソッド
画像ファイルの幅を設定します。
setYear(int) - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo のメソッド
年を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を設定します。
setZipCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を設定します。
setZipCode(String, Date) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel のメソッド
郵便番号を設定します。
setZipCode(String) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel のメソッド
郵便番号を設定します。
size() - class jp.co.intra_mart.foundation.graph.BarGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.BarGraphObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.graph.CircleGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.LineGraphDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.LineGraphObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.graph.PortFolioDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.RadarChartDrawer のメソッド
データの数を返します。
size() - class jp.co.intra_mart.foundation.graph.RadarChartObject のメソッド
値の数を返します。
size() - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードが持つ子ノードの数を返します。
size() - interface jp.co.intra_mart.foundation.page.TreeNodeContainer のメソッド
このノードが持つ子ノードの数を返します。
size() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 このオブジェクトの管理するモニターの数を取得します。
sort(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
指定されたコンパレータに従って、子ノードをソートします。
sortAll(Comparator) - class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer のメソッド
このノードの下にある、全ての子ノードを指定されたコンパレータに従ってソートします。
sourceName() - class jp.co.intra_mart.foundation.scenario.FunctionContainer のメソッド
ソース名称の取得。
sourceName() - class jp.co.intra_mart.foundation.scenario.FunctionContainerFile のメソッド
スクリプトのファイルパス名を返します。
start() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの開始通知。
startAutomaticExecution(long) - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。 gc によるシステム停止や監視スレッドを停止処理しないことによるメモリリークなどの問題を引き起こす危険性があります。
stop() - class jp.co.intra_mart.foundation.service.client.batch.Scheduler のメソッド
スケジューラの停止通知。
stopAutomaticExecution() - class jp.co.intra_mart.foundation.service.provider.GarbageController の static メソッド
推奨されていません。
stringToDate(String) - class jp.co.intra_mart.foundation.database.DatabaseManager のメソッド
データベース登録用文字列からjava.util.Dateを取得します。
stringToDate(String) - class jp.co.intra_mart.foundation.database.DbManager の static メソッド
推奨されていません。 DatabaseManager.stringToDate(String)を使用してください。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.ExternalMemory のメソッド
データを取得します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.PermanentFile のメソッド
データを取得します。
subMap(String[]) - class jp.co.intra_mart.foundation.service.client.information.SessionMemory のメソッド
データを取得します。
subMap(String[]) - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile のメソッド
データを取得します。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleAdded(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールにサブロールを追加した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subRoleDeleted(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleChangedListener のメソッド
ロールからサブロールを削除した直後にコールされます。
subtract(Term[], Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。

T

TELEPHONE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
電話番号
TELEPHONE_NUMBER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
電話番号
TYPE_CONFIG - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
名称（データタイプの定数）。
TYPE_DATA_SOURCE - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_DEBUG - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 デバッグレベル。
TYPE_ERROR - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 エラーレベル。
TYPE_GROUP - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_HOLIDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
休日（データタイプの定数）。
TYPE_JDBC - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_NATIONAL_HOLDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
祝祭日（データタイプの定数）。
TYPE_REPORT - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 通常の情報レベル。
TYPE_SYSTEM - interface jp.co.intra_mart.foundation.database.ConInfo の static 変数

TYPE_WARNING - interface jp.co.intra_mart.foundation.utility.report.ReportLevel の static 変数
推奨されていません。 警告レベル。
TYPE_WEEKDAY - class jp.co.intra_mart.foundation.security.calendar.CalendarInfo の static 変数
非休日（データタイプの定数）。
Table - interface jp.co.intra_mart.foundation.datastore.common.config.Table.
テーブルを定義します。
TemporaryDirectory - class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory.
このクラスは、一時ファイル保存用ディレクトリに関する機能を 提供します。
TemporaryFile - class jp.co.intra_mart.foundation.service.provider.TemporaryFile.
このクラスは、一時ファイルに関する機能を提供します。
TemporaryFile() - class jp.co.intra_mart.foundation.service.provider.TemporaryFile のコンストラクタ
一時ファイルのパスを作成します。
Term - class jp.co.intra_mart.foundation.datastore.common.structure.Term.
有効期間を表します。
Term() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間、終了時間とも指定されていない有効期間を生成します。
Term(Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間のみが指定された有効期間を生成します。
Term(Date, Date) - class jp.co.intra_mart.foundation.datastore.common.structure.Term のコンストラクタ
開始時間と終了時間がともに指定された有効期間を生成します。
TermManager - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager.
期間 Term を取り扱うマネージャクラスです。
TermManagerException - exception jp.co.intra_mart.foundation.datastore.exception.TermManagerException.
期間に関する例外クラス

TermManagerException() - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(String) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(Throwable) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TermManagerException(String, Throwable) - class jp.co.intra_mart.foundation.datastore.exception.TermManagerException のコンストラクタ
コンストラクタ
TerminableAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor.
期間化エンティティに対する情報操作用のインタフェースです。
TerminableAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap.
期間化アクセサのマッピング情報を持ちます。
TerminableInternationalAccessor - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor.
期間国際化エンティティに対する情報操作用のインタフェースです。
TerminableInternationalAccessorMap - interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap.
期間国際化アクセサのマッピング情報を持ちます。
TerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel.
期間国際化モデルを定義します。
TerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel.
期間国際化モデルの情報です。
TerminableInternationalModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext.
期間国際化モデルの初期化に必要な設定を持ちます。
TerminableInternationalModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap.
期間国際化モデルのマッピング情報を持ちます。
TerminableInternationalTable - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable.
期間国際化テーブルを定義します。
TerminableKey - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey.
期間化基準項目を定義します。
TerminableModel - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel.
期間化モデルを定義します。
TerminableModel - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel.
期間化モデルの情報です。
TerminableModelContext - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext.
期間化化モデルの初期化に必要な設定を持ちます。
TerminableModelMap - interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap.
期間化モデルのマッピング情報を持ちます。
TerminableTable - interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable.
期間化テーブルを定義します。
ThreadStopListener - interface jp.co.intra_mart.foundation.utility.ThreadStopListener.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener クラスを使用してください。
TreasureDirectory - interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory.
情報データベースのディレクトリを操作するためのインターフェースを定義します。
TreasureFile - interface jp.co.intra_mart.foundation.service.client.information.TreasureFile.
情報データベースのファイルを操作するためのインターフェースを定義します。
TreeBranch - class jp.co.intra_mart.foundation.page.TreeBranch.
ツリービュー内の「フォルダ」をあらわすクラスです。
TreeBranch() - class jp.co.intra_mart.foundation.page.TreeBranch のコンストラクタ
新しいTreeBranchオブジェクトを生成します。
TreeBranch(Comparator) - class jp.co.intra_mart.foundation.page.TreeBranch のコンストラクタ
指定されたコンパレータに従って子ノードをソートする、新しいTreeBranchオブジェクトを生成します。
TreeLeaf - class jp.co.intra_mart.foundation.page.TreeLeaf.
ツリービュー内の「ページ」をあらわすクラスです。
TreeLeaf() - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成します。
TreeLeaf(String) - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成し、表示名称を設定します。
TreeLeaf(String, String) - class jp.co.intra_mart.foundation.page.TreeLeaf のコンストラクタ
新しくTreeLeafオブジェクトを生成し、表示名称と、ポップアップ文字列を設定します。
TreeNode - interface jp.co.intra_mart.foundation.page.TreeNode.
ツリービュー内の単一のノードを表すインターフェースです。
TreeNodeContainer - interface jp.co.intra_mart.foundation.page.TreeNodeContainer.
子ノードを参照するためのメソッドが定義されたインターフェースです。
TreeNodeProvider - interface jp.co.intra_mart.foundation.page.TreeNodeProvider.
ツリービューの「ホーム」をあらわすインターフェースです。
TreeRoot - class jp.co.intra_mart.foundation.page.TreeRoot.
ツリービュー内の「ホーム」をあらわすクラスです。
TreeRoot() - class jp.co.intra_mart.foundation.page.TreeRoot のコンストラクタ
新しいTreeRootオブジェクトを生成します。
TreeRoot(Comparator) - class jp.co.intra_mart.foundation.page.TreeRoot のコンストラクタ
指定されたコンパレータに従って子ノードをソートする、新しいTreeRootオブジェクトを生成します。
temporaryDirectory() - class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory のメソッド
削除対象のデータファイルを一時的に保存しておくための ディレクトリを表すオブジェクトを取得します。
toString() - class jp.co.intra_mart.foundation.datastore.common.structure.Term のメソッド
オブジェクトの文字列表現を返します。
toString() - class jp.co.intra_mart.foundation.page.EventScript のメソッド
このオブジェクトの文字列表現を返します。
toString() - interface jp.co.intra_mart.foundation.scenario.ScriptValue のメソッド
このオブジェクトの示す値の文字列表現を取得します。
toString() - class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions のメソッド
推奨されていません。 このオブジェクトの文字列表現を返します。
total() - class jp.co.intra_mart.foundation.utility.LockMonitor のメソッド
推奨されていません。 モニターを利用中、または利用しようとしているスレッドの数です。
totalMemory() - class jp.co.intra_mart.foundation.service.client.NetworkConnector のメソッド
サーバプロセスの Java Virtual Machine のメモリの総容量を返します。
transaction() - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースアクセスのトランザクションを開始する

トランザクションを開始させる。

U

UNAVALIABLE_LOGIN_USER - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ログイン出来ないアカウントを表す定数
URL - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
URL
URL - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
URL
URLAccessFilter - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter.
URLアクセスフィルタ。
URLAccessFilter() - class jp.co.intra_mart.foundation.security.filter.URLAccessFilter のコンストラクタ

URLBuilder - class jp.co.intra_mart.jssp.net.URLBuilder.
ページベース開発モデルの画面を呼び出すための URL を作成するビルダです。
URLBuilder(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.jssp.net.URLBuilder のコンストラクタ
新しいビルダを作成します。
URLDecodeInputStream - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream クラスを使用してください。
URLDecodeInputStream(InputStream) - class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream のコンストラクタ
推奨されていません。 指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
URLDecodeOutputStream - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream クラスを使用してください。
URLDecodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
URLEncodeOutputStream - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream クラスを使用してください。
URLEncodeOutputStream(OutputStream) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に書き込む BASE64デコーダーを作成します。
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel の static 変数
ユーザコード
USER_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
ユーザコード
UnsupportedNetworkConnectException - exception jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException クラスを使用してください。
UnsupportedNetworkConnectException() - class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException のコンストラクタ
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String) - class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException のコンストラクタ
推奨されていません。 Constructor for UnsupportedNetworkConnectException.
UpdateInfo - interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo.
エンティティの更新情報です。
User - class jp.co.intra_mart.foundation.datastore.application.domain.user.User.
ユーザの基本属性のデータを取り扱います。
User() - class jp.co.intra_mart.foundation.datastore.application.domain.user.User のコンストラクタ

UserBaseModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel.
ユーザの基本モデルです。
UserCertification - interface jp.co.intra_mart.foundation.security.certification.UserCertification.
ユーザログイン認証インタフェース。
UserCertificationServlet - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet.
ユーザ認証サーブレット。
UserCertificationServlet() - class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet のコンストラクタ

UserChangedListener - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener.
ユーザに関する情報の変更時のリスナーです。
UserImporter - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter.
ユーザインポーターのインタフェースです。
UserInitialServlet - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet.
ユーザ初期アクセスサーブレット。
UserInitialServlet() - class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet のコンストラクタ

UserManager - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager.
ユーザに関連する情報を管理します。
UserManager() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のコンストラクタ

UserMapper - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper.
ユーザに関連するマッパです。
UserPageProvider - interface jp.co.intra_mart.foundation.security.certification.UserPageProvider.
ユーザページプロバイダインタフェース。
UserTerminable - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable.
ユーザの期間化属性のデータを取り扱います。
UserTerminable() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable のコンストラクタ

UserTerminableInternational - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational.
ユーザの期間国際化属性のデータを取り扱います。
UserTerminableInternational() - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational のコンストラクタ

UserTerminableInternationalModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel.
ユーザの期間国際化モデルです。
UserTerminableModel - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel.
ユーザの期間化モデルです。
update(String, String, Map) - interface jp.co.intra_mart.foundation.database.DbsConnection のメソッド
推奨されていません。 データベースにデータを更新するメソッド

データベースのデータを更新(アップデート)する。
update(CateogryClassBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper のメソッド
分類区分の基本モデルを複数更新します。
update(CategoryDetailBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper のメソッド
分類区分詳細の基本モデルを複数更新します。
update(DepartmentAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper のメソッド
組織所属の基本モデルを複数更新します。
update(CompanyCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper のメソッド
会社組織分類の基本モデルを複数更新します。
update(CompanyBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper のメソッド
会社の基本モデルを複数更新します。
update(DepartmentBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper のメソッド
組織の基本モデルを複数更新します。
update(DepartmentInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper のメソッド
組織内包の基本モデルを複数更新します。
update(DepartmentMainBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper のメソッド
主所属の基本モデルを複数更新します。
update(CompanyPostBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper のメソッド
役職の基本モデルを複数更新します。
update(CompanyVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper のメソッド
会社構成バージョンの基本モデルを複数更新します。
update(PrivateGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper のメソッド
プライベートグループ所属の基本モデルを複数更新します。
update(PrivateGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper のメソッド
プライベートグループの基本モデルを複数更新します。
update(PublicGroupAttachBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper のメソッド
パブリックグループ所属の基本モデルを複数更新します。
update(PublicGroupCategoryBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper のメソッド
パブリックグループ分類の基本モデルを複数更新します。
update(PublicGroupBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper のメソッド
パブリックグループの基本モデルを複数更新します。
update(PublicGroupInclusionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper のメソッド
パブリックグループ内包の基本モデルを複数更新します。
update(PublicGroupSetBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper のメソッド
パブリックグループセットの基本モデルを複数更新します。
update(PublicGroupVersionBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper のメソッド
パブリックグループ構成バージョンの基本モデルを複数更新します。
update(UserBaseModel) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを1つだけ更新します。
update(Collection) - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper のメソッド
ユーザの基本モデルを複数更新します。
update(BaseModel) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを1つだけ更新します。
update(Collection) - class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper のメソッド
基本モデルを複数更新します。
updateAccount(String, Account) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウント情報を更新する。
updateAccount(Account) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントを更新します。
updateAccountRole(String, String, AccountRole) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
アカウントロール情報を更新する。
updateAccountRole(String, AccountRole) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
アカウントロールを更新します。
updateBatch(String, Batch) - interface jp.co.intra_mart.foundation.security.batch.BatchAccessor のメソッド
バッチ情報を更新します。
updateBatch(Batch) - class jp.co.intra_mart.foundation.security.batch.BatchManager のメソッド
バッチ情報を更新します。
updateCalendarInfo(String, String, CalendarInfo) - interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor のメソッド
カレンダーデータを更新します。
updateCalendarInfo(String, CalendarInfo) - class jp.co.intra_mart.foundation.security.calendar.CalendarManager のメソッド
カレンダーデータを更新します。
updateCategory(String, String, String) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
カテゴリを更新する。
updateCategoryDetail(Map) - class jp.co.intra_mart.foundation.appcomn.Category のメソッド
推奨されていません。 CategoryManager.updateCategoryDetail(CategoryDetail categoryDetail) に置き換えられました。
updateCategoryDetail(CategoryDetail) - class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager のメソッド
登録済の分類区分詳細を更新します。
updateData(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
updateData(Map, String[]) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
updateDepartment(Department) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の組織情報を更新します。
updateFavoriteMenu(String, String, FavoriteMenu) - interface jp.co.intra_mart.foundation.security.account.AccountAccessor のメソッド
マイメニュー情報を更新する。
updateFavoriteMenu(String, FavoriteMenu) - class jp.co.intra_mart.foundation.security.account.AccountManager のメソッド
マイメニューを更新します。
updateLoginGroup(LoginGroup) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
ログイングループを更新します。
updateLoginGroup(LoginGroup) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
ログイングループ情報を更新します。
updateMainPagePattern(String, MainPagePatternInfo) - interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor のメソッド
メインページパターンを更新します。
updateMainPagePattern(String, MainPagePatternInfo) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
メインページパターンを更新します。
updateMenuItem(MenuItem) - interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - class jp.co.intra_mart.foundation.security.menu.AdminMenuManager のメソッド
メニューを更新します。
updateMenuItem(String, MenuItem) - interface jp.co.intra_mart.foundation.security.menu.MenuAccessor のメソッド
引数で渡されたノードを更新します。
updateMenuItem(MenuItem) - class jp.co.intra_mart.foundation.security.menu.MenuManager のメソッド
メニューを更新します。
updatePost(CompanyPost) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の役職情報を更新します。
updatePostData(Map) - class jp.co.intra_mart.foundation.appcomn.Grouping のメソッド
推奨されていません。 CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
updatePrivateGroup(PrivateGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager のメソッド
登録済のプライベートグループ情報を更新します。
updateProfile(Map) - class jp.co.intra_mart.foundation.appcomn.Profile のメソッド
推奨されていません。 UserManager.updateUser(User user) に置き換えられました。
updatePublicGroup(PublicGroup) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループ情報を更新します。
updateRole(String, Role) - interface jp.co.intra_mart.foundation.security.role.RoleAccessor のメソッド
ロール情報を更新する。
updateRole(Role) - class jp.co.intra_mart.foundation.security.role.RoleManager のメソッド
ロール情報を更新します。
updateSuperUser(SuperUser) - class jp.co.intra_mart.foundation.security.SystemManager のメソッド
システム管理者情報を更新します。
updateSuperUser(SuperUser) - interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor のメソッド
システム管理者情報を更新します。
updateSuperUser(String, SuperUser) - interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor のメソッド
グループ管理者情報を更新します。
updateSuperUser(String, SuperUser) - class jp.co.intra_mart.foundation.security.group.LoginGroupManager のメソッド
グループ管理者情報を更新します。
updateUser(User) - class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager のメソッド
登録済のユーザを更新します。
updateVersion(CompanyVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager のメソッド
登録済の会社構成バージョンを更新します。
updateVersion(PublicGroupVersion) - class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager のメソッド
登録済のパブリックグループセット構成バージョンを更新します。
usableConnection() - interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager のメソッド
推奨されていません。 現在待機中のコネクションをです。
usableConnection() - class jp.co.intra_mart.foundation.utility.net.SocketPool のメソッド
推奨されていません。 現在待機中のコネクションをです。
userAdded(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアに登録された後に呼び出されます。
userDeleted(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアから削除された後に呼び出されます。
userUpdated(String, User) - interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener のメソッド
ユーザ情報がデータストアに対して更新された後に呼び出されます。

V

VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel の static 変数
バージョンコード
VERSION_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel の static 変数
バージョンコード
VariableScope - interface jp.co.intra_mart.foundation.scenario.VariableScope.
スクリプトのスコープを表すオブジェクトです。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday のメソッド
カレンダーデータが有効かどうか検証します。
validate(CalendarManager, CategorizedCalendarInfo, CalendarInfo, Date) - class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox のメソッド
カレンダーデータが有効かどうか検証します。
validateTerm(Date, Date) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
指定された2つの日時が有効な期間を構成するかどうか調べます。
validateTerms(Term[]) - class jp.co.intra_mart.foundation.datastore.common.structure.TermManager の static メソッド
指定された期間配列が有効かどうかを調べます。
versionAdded(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionDeleted(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionUpdated(String, CompanyVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, CompanyVersion) - class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

W

WebApplicationHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler.
フレームワークを実行するためのイベントハンドラの抽象実装です。
WebApplicationHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
write(byte) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(byte[]) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(byte[], int, int) - class jp.co.intra_mart.foundation.http.FileSender のメソッド
バイトの出力。
write(String) - class jp.co.intra_mart.foundation.service.client.file.NetworkFile のメソッド
ファイルにテキストを出力します。
write(String, Throwable) - interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter のメソッド
メッセージをログに書き込みます。
write(String) - interface jp.co.intra_mart.foundation.service.provider.SystemReporter のメソッド
メッセージをログに書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 単一の文字を書き込みます。
write(String, int, int) - class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter のメソッド
推奨されていません。 文字列の一部を書き込みます。
write(String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(String, String) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(byte[]) - class jp.co.intra_mart.foundation.utility.file.ExtendedFile のメソッド
推奨されていません。 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 指定されたバイトを書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.HexOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 単一文字を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.io.ReplaceWriter のメソッド
推奨されていません。 文字列の一部を基礎ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のメソッド
推奨されていません。 バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のメソッド
推奨されていません。 バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のメソッド
推奨されていません。 バイト列をエンコード出力ストリームに書き込みます。
write(char[], int, int) - class jp.co.intra_mart.foundation.utility.report.ReportFileWriter のメソッド
推奨されていません。 基礎ストリームに文字を出力します。
writeBoolean(boolean) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 boolean 型データの送信。
writeInt(int) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 int 型データの送信。
writeLong(long) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 long 型データの送信。
writeObject(Object) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 オブジェクトの送信。
writeString(String) - class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream のメソッド
推奨されていません。 文字列の送信。

X

XORInputStream - class jp.co.intra_mart.foundation.utility.io.XORInputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream クラスを使用してください。
XORInputStream(InputStream, int) - class jp.co.intra_mart.foundation.utility.io.XORInputStream のコンストラクタ
推奨されていません。 指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
XOROutputStream - class jp.co.intra_mart.foundation.utility.io.XOROutputStream.
推奨されていません。 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream クラスを使用してください。
XOROutputStream(OutputStream, int) - class jp.co.intra_mart.foundation.utility.io.XOROutputStream のコンストラクタ
推奨されていません。 指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。

Z

ZIP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel の static 変数
郵便番号
ZIP_CODE - interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel の static 変数
郵便番号
A B C D E F G H I J K L M N O P Q R S T U V W X Z

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart(R)
5.0

前 次

フレームあり フレームなし


概要 (5.0 J2EE-Base Programing Model API Specifications)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.acssecurity
jp.co.intra_mart.foundation.appcomn
jp.co.intra_mart.foundation.commons.validation
jp.co.intra_mart.foundation.database
jp.co.intra_mart.foundation.database.exception
jp.co.intra_mart.foundation.datastore.application.domain.category
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class
jp.co.intra_mart.foundation.datastore.application.domain.category.detail
jp.co.intra_mart.foundation.datastore.application.domain.company
jp.co.intra_mart.foundation.datastore.application.domain.company.attach
jp.co.intra_mart.foundation.datastore.application.domain.company.category
jp.co.intra_mart.foundation.datastore.application.domain.company.company
jp.co.intra_mart.foundation.datastore.application.domain.company.department
jp.co.intra_mart.foundation.datastore.application.domain.company.main
jp.co.intra_mart.foundation.datastore.application.domain.company.post
jp.co.intra_mart.foundation.datastore.application.domain.company.version
jp.co.intra_mart.foundation.datastore.application.domain.private_group
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group
jp.co.intra_mart.foundation.datastore.application.domain.public_group
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version
jp.co.intra_mart.foundation.datastore.application.domain.user
jp.co.intra_mart.foundation.datastore.application.model.category.category_class
jp.co.intra_mart.foundation.datastore.application.model.category.detail
jp.co.intra_mart.foundation.datastore.application.model.company.attach
jp.co.intra_mart.foundation.datastore.application.model.company.category
jp.co.intra_mart.foundation.datastore.application.model.company.company
jp.co.intra_mart.foundation.datastore.application.model.company.department
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion
jp.co.intra_mart.foundation.datastore.application.model.company.main
jp.co.intra_mart.foundation.datastore.application.model.company.post
jp.co.intra_mart.foundation.datastore.application.model.company.version
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach
jp.co.intra_mart.foundation.datastore.application.model.private_group.group
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach
jp.co.intra_mart.foundation.datastore.application.model.public_group.category
jp.co.intra_mart.foundation.datastore.application.model.public_group.group
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion
jp.co.intra_mart.foundation.datastore.application.model.public_group.set
jp.co.intra_mart.foundation.datastore.application.model.public_group.version
jp.co.intra_mart.foundation.datastore.application.model.user
jp.co.intra_mart.foundation.datastore.common.accessor
jp.co.intra_mart.foundation.datastore.common.config
jp.co.intra_mart.foundation.datastore.common.model
jp.co.intra_mart.foundation.datastore.common.structure
jp.co.intra_mart.foundation.datastore.exception
jp.co.intra_mart.foundation.drawer
jp.co.intra_mart.foundation.exception
jp.co.intra_mart.foundation.graph
jp.co.intra_mart.foundation.http
jp.co.intra_mart.foundation.mail
jp.co.intra_mart.foundation.mail.javamail
jp.co.intra_mart.foundation.mail.javamail.property
jp.co.intra_mart.foundation.page
jp.co.intra_mart.foundation.scenario
jp.co.intra_mart.foundation.security
jp.co.intra_mart.foundation.security.account
jp.co.intra_mart.foundation.security.admin
jp.co.intra_mart.foundation.security.batch
jp.co.intra_mart.foundation.security.calendar
jp.co.intra_mart.foundation.security.certification
jp.co.intra_mart.foundation.security.cryption
jp.co.intra_mart.foundation.security.exception
jp.co.intra_mart.foundation.security.filter
jp.co.intra_mart.foundation.security.group
jp.co.intra_mart.foundation.security.license
jp.co.intra_mart.foundation.security.menu
jp.co.intra_mart.foundation.security.message
jp.co.intra_mart.foundation.security.permission
jp.co.intra_mart.foundation.security.role
jp.co.intra_mart.foundation.security.servlet
jp.co.intra_mart.foundation.service.client
jp.co.intra_mart.foundation.service.client.application
jp.co.intra_mart.foundation.service.client.application.content
jp.co.intra_mart.foundation.service.client.batch
jp.co.intra_mart.foundation.service.client.file
jp.co.intra_mart.foundation.service.client.information
jp.co.intra_mart.foundation.service.client.manager
jp.co.intra_mart.foundation.service.provider
jp.co.intra_mart.foundation.service.provider.application
jp.co.intra_mart.foundation.service.provider.batch
jp.co.intra_mart.foundation.service.provider.file
jp.co.intra_mart.foundation.service.provider.information
jp.co.intra_mart.foundation.smtp
jp.co.intra_mart.foundation.utility
jp.co.intra_mart.foundation.utility.charset
jp.co.intra_mart.foundation.utility.file
jp.co.intra_mart.foundation.utility.io
jp.co.intra_mart.foundation.utility.net
jp.co.intra_mart.foundation.utility.report
jp.co.intra_mart.jssp.net


概要 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

intra-mart(R) 5.0 J2EE-Base Programing Model API Specifications

パッケージ
jp.co.intra_mart.foundation.acssecurity | アクセスセキュリティモジュールを利用するためのクラスを提供します。
jp.co.intra_mart.foundation.appcomn | アプリケーション共通モジュール。
jp.co.intra_mart.foundation.commons.validation | このパッケージは、入力チェック関数ライブラリを提供します。
jp.co.intra_mart.foundation.database | データベースへアクセスするためのクラスを提供します。
jp.co.intra_mart.foundation.database.exception | データベースＳＱＬ例外クラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category | 分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.category_class | 分類区分情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.category.detail | 分類詳細情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.attach | 組織所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.category | 会社分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.company | 会社情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.department | 組織情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.main | 主所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.post | 役職情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.company.version | バーション情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach | プライベートグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.private_group.group | プライベートグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach | パブリックグループ所属情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.category | パブリックグループ分類情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.group | パブリックグループ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.set | パブリックグループセット情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.public_group.version | パブリックグループバージョン情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.domain.user | ユーザ情報を操作するクラスを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.category_class | 分類区分情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.category.detail | 分類詳細情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.attach | 組織所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.category | 会社分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.company | 会社情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.department | 組織情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.inclusion | 組織内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.main | 組織主所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.post | 会社役職情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.company.version | 会社バージョン情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.attach | プライベートグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.private_group.group | プライベートグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.attach | パブリックグループ所属情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.category | パブリックグループ分類情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.group | パブリックグループ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion | パブリックグループ内包情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.set | パブリックグループセット情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.public_group.version | パブリックグループバーション情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.application.model.user | ユーザ情報を操作するマッパーとモデルを提供します。
jp.co.intra_mart.foundation.datastore.common.accessor | 情報を扱うためのアクセサを提供します。
jp.co.intra_mart.foundation.datastore.common.config | アプリケーション共通マスタの設定ファイルの情報を扱うためのクラスを提供します。
jp.co.intra_mart.foundation.datastore.common.model | 情報を扱うための、モデルやマッパーを提供します。
jp.co.intra_mart.foundation.datastore.common.structure | 期間情報などを扱うクラスを提供します。
jp.co.intra_mart.foundation.datastore.exception | アプリケーション共通マスタで発生する例外クラスを提供します。
jp.co.intra_mart.foundation.drawer | 画像ファイル出力用クラスを提供します。
jp.co.intra_mart.foundation.exception | システムでスローされる例外クラスを提供します。
jp.co.intra_mart.foundation.graph | グラフ描画に関するクラスを提供します。
jp.co.intra_mart.foundation.http | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.mail | メール送信に関するクラスを提供します。
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.property |
jp.co.intra_mart.foundation.page | ブラウザとデータを送受信する場合に利用すると便利な ユーティリティクラスを提供します。
jp.co.intra_mart.foundation.scenario | ページベース開発モデルのプログラムと連携するＡＰＩ。
jp.co.intra_mart.foundation.security | アクセスセキュリティに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.account | アカウントに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.admin | システム管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.batch | バッチに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.calendar | カレンダーに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.certification | 認証に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.cryption | 暗号化に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.exception | アクセスセキュリティ例外に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.filter | アクセスセキュリティのフィルタに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.group | グループ管理者に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.license | ライセンスに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.menu | メニューに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.message | メッセージに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.permission | 権限に関連するクラスを提供します。
jp.co.intra_mart.foundation.security.role | ロールに関連するクラスを提供します。
jp.co.intra_mart.foundation.security.servlet | サーブレットに関連するクラスを提供します。
jp.co.intra_mart.foundation.service.client | このパッケージには、intra-mart の各サーバを利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.batch | Schedule Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.file | Storage Service を利用するためのクラスを提供します。
jp.co.intra_mart.foundation.service.client.information | このパッケージには、様々な情報にアクセスしたり、情報を制御するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.manager | このパッケージには、intra-mart の Server-Manager を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider | このパッケージには、現在実行中のサーバ環境で利用する機能を提供します。
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.batch | このパッケージには、スケジュール実行されるバッチプログラム機能を利用するための共通的な機能を提供します。
jp.co.intra_mart.foundation.service.provider.file | このパッケージには、Storage Service 環境内で利用可能な機能を提供します。
jp.co.intra_mart.foundation.service.provider.information | このパッケージには、intra-mart の各種情報に対してアクセスするためのクラスが含まれています。
jp.co.intra_mart.foundation.smtp | メール連携モジュール。
jp.co.intra_mart.foundation.utility | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.foundation.utility.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.foundation.utility.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。
jp.co.intra_mart.jssp.net |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.acssecurity, jp.co.intra_mart.foundation.appcomn, jp.co.intra_mart.foundation.commons.validation, jp.co.intra_mart.foundation.database, jp.co.intra_mart.foundation.database.exception, jp.co.intra_mart.foundation.datastore.application.domain.category, jp.co.intra_mart.foundation.datastore.application.domain.category.category_class, jp.co.intra_mart.foundation.datastore.application.domain.category.detail, jp.co.intra_mart.foundation.datastore.application.domain.company, jp.co.intra_mart.foundation.datastore.application.domain.company.attach, jp.co.intra_mart.foundation.datastore.application.domain.company.category, jp.co.intra_mart.foundation.datastore.application.domain.company.company, jp.co.intra_mart.foundation.datastore.application.domain.company.department, jp.co.intra_mart.foundation.datastore.application.domain.company.main, jp.co.intra_mart.foundation.datastore.application.domain.company.post, jp.co.intra_mart.foundation.datastore.application.domain.company.version, jp.co.intra_mart.foundation.datastore.application.domain.private_group, jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach, jp.co.intra_mart.foundation.datastore.application.domain.private_group.group, jp.co.intra_mart.foundation.datastore.application.domain.public_group, jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach, jp.co.intra_mart.foundation.datastore.application.domain.public_group.category, jp.co.intra_mart.foundation.datastore.application.domain.public_group.group, jp.co.intra_mart.foundation.datastore.application.domain.public_group.set, jp.co.intra_mart.foundation.datastore.application.domain.public_group.version, jp.co.intra_mart.foundation.datastore.application.domain.user, jp.co.intra_mart.foundation.datastore.application.model.category.category_class, jp.co.intra_mart.foundation.datastore.application.model.category.detail, jp.co.intra_mart.foundation.datastore.application.model.company.attach, jp.co.intra_mart.foundation.datastore.application.model.company.category, jp.co.intra_mart.foundation.datastore.application.model.company.company, jp.co.intra_mart.foundation.datastore.application.model.company.department, jp.co.intra_mart.foundation.datastore.application.model.company.inclusion, jp.co.intra_mart.foundation.datastore.application.model.company.main, jp.co.intra_mart.foundation.datastore.application.model.company.post, jp.co.intra_mart.foundation.datastore.application.model.company.version, jp.co.intra_mart.foundation.datastore.application.model.private_group.attach, jp.co.intra_mart.foundation.datastore.application.model.private_group.group, jp.co.intra_mart.foundation.datastore.application.model.public_group.attach, jp.co.intra_mart.foundation.datastore.application.model.public_group.category, jp.co.intra_mart.foundation.datastore.application.model.public_group.group, jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion, jp.co.intra_mart.foundation.datastore.application.model.public_group.set, jp.co.intra_mart.foundation.datastore.application.model.public_group.version, jp.co.intra_mart.foundation.datastore.application.model.user, jp.co.intra_mart.foundation.datastore.common.accessor, jp.co.intra_mart.foundation.datastore.common.config, jp.co.intra_mart.foundation.datastore.common.model, jp.co.intra_mart.foundation.datastore.common.structure, jp.co.intra_mart.foundation.datastore.exception, jp.co.intra_mart.foundation.drawer, jp.co.intra_mart.foundation.exception, jp.co.intra_mart.foundation.graph, jp.co.intra_mart.foundation.http, jp.co.intra_mart.foundation.mail, jp.co.intra_mart.foundation.mail.javamail, jp.co.intra_mart.foundation.mail.javamail.property, jp.co.intra_mart.foundation.page, jp.co.intra_mart.foundation.scenario, jp.co.intra_mart.foundation.security, jp.co.intra_mart.foundation.security.account, jp.co.intra_mart.foundation.security.admin, jp.co.intra_mart.foundation.security.batch, jp.co.intra_mart.foundation.security.calendar, jp.co.intra_mart.foundation.security.certification, jp.co.intra_mart.foundation.security.cryption, jp.co.intra_mart.foundation.security.exception, jp.co.intra_mart.foundation.security.filter, jp.co.intra_mart.foundation.security.group, jp.co.intra_mart.foundation.security.license, jp.co.intra_mart.foundation.security.menu, jp.co.intra_mart.foundation.security.message, jp.co.intra_mart.foundation.security.permission, jp.co.intra_mart.foundation.security.role, jp.co.intra_mart.foundation.security.servlet, jp.co.intra_mart.foundation.service.client, jp.co.intra_mart.foundation.service.client.application, jp.co.intra_mart.foundation.service.client.application.content, jp.co.intra_mart.foundation.service.client.batch, jp.co.intra_mart.foundation.service.client.file, jp.co.intra_mart.foundation.service.client.information, jp.co.intra_mart.foundation.service.client.manager, jp.co.intra_mart.foundation.service.provider, jp.co.intra_mart.foundation.service.provider.application, jp.co.intra_mart.foundation.service.provider.batch, jp.co.intra_mart.foundation.service.provider.file, jp.co.intra_mart.foundation.service.provider.information, jp.co.intra_mart.foundation.smtp, jp.co.intra_mart.foundation.utility, jp.co.intra_mart.foundation.utility.charset, jp.co.intra_mart.foundation.utility.file, jp.co.intra_mart.foundation.utility.io, jp.co.intra_mart.foundation.utility.net, jp.co.intra_mart.foundation.utility.report, jp.co.intra_mart.jssp.net

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.foundation.http.MultipartFormData
    • class jp.co.intra_mart.foundation.drawer.AbstractDrawer (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.graph.BarGraphDrawer
      • class jp.co.intra_mart.foundation.graph.CircleGraphDrawer
      • class jp.co.intra_mart.foundation.graph.LineGraphDrawer
      • class jp.co.intra_mart.foundation.graph.PortFolioDrawer
      • class jp.co.intra_mart.foundation.graph.RadarChartDrawer
    • class jp.co.intra_mart.foundation.utility.AbstractDualComparator (implements jp.co.intra_mart.foundation.utility.DualComparator)
      • class jp.co.intra_mart.foundation.utility.MultiComparator
      • class jp.co.intra_mart.foundation.page.NodeTypeComparator
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.foundation.security.filter.RequestCharacterEncodingFilter
      • class jp.co.intra_mart.foundation.security.filter.ResponseCharacterEncodingFilter
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.foundation.utility.FixedSizeMap
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.http.CGIEnvironment
    • class jp.co.intra_mart.foundation.utility.report.AbstractMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.FileReporter
      • class jp.co.intra_mart.foundation.utility.report.MultiCastReporter
      • class jp.co.intra_mart.foundation.utility.report.PrintStreamReporter
    • class jp.co.intra_mart.foundation.utility.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.foundation.utility.net.SocketPool (implements jp.co.intra_mart.foundation.utility.net.SocketConnectionManager)
    • class jp.co.intra_mart.foundation.page.AbstractTreeNodeContainer (implements jp.co.intra_mart.foundation.page.TreeNodeContainer)
      • class jp.co.intra_mart.foundation.page.TreeBranch (implements jp.co.intra_mart.foundation.page.TreeNode)
      • class jp.co.intra_mart.foundation.page.TreeRoot (implements jp.co.intra_mart.foundation.page.TreeNodeProvider)
    • class jp.co.intra_mart.foundation.security.AccessSecurityManager
    • class jp.co.intra_mart.foundation.security.account.Account (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.acssecurity.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountManager
    • class jp.co.intra_mart.foundation.security.account.AccountRole (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.acssecurity.AcsData
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.AdminMenuManager
    • class jp.co.intra_mart.foundation.datastore.common.config.AttributeType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.BarGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.Batch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.batch.BatchManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarManager
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginAutumnalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginEndOfTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginLastDayInTheMonth (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginMondayMakeupHoliday (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CalendarPluginVernalEquinox (implements jp.co.intra_mart.foundation.security.calendar.CalendarPlugin)
    • class jp.co.intra_mart.foundation.security.calendar.CategorizedCalendarInfo
    • class jp.co.intra_mart.foundation.appcomn.Category
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.CategoryManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.charset.CharacterEncoder
    • class jp.co.intra_mart.foundation.graph.CircleGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.CompanyChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.config.ConfigurationFactory
    • class jp.co.intra_mart.foundation.database.DatabaseManager
    • class jp.co.intra_mart.foundation.database.DbManager
    • class jp.co.intra_mart.foundation.datastore.common.config.DeleteType (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.DepartmentInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational (implements java.io.Serializable)
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.foundation.service.client.information.InitialFile
          • class jp.co.intra_mart.foundation.utility.ResourceBundleProperties
    • class jp.co.intra_mart.foundation.utility.ErrorEvent
    • class jp.co.intra_mart.foundation.utility.EventQueueController
    • class jp.co.intra_mart.foundation.page.EventScript
    • class jp.co.intra_mart.foundation.utility.report.EverydayConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap)
    • class jp.co.intra_mart.foundation.utility.net.ExtendedSocket
      • class jp.co.intra_mart.foundation.utility.net.SocketConnection
    • class jp.co.intra_mart.foundation.security.ExtendsImportManager
    • class jp.co.intra_mart.foundation.security.account.FavoriteMenu (implements java.io.Serializable)
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.file.Directory
        • class jp.co.intra_mart.foundation.utility.file.ExtendedDirectory
          • class jp.co.intra_mart.foundation.service.provider.HomeDirectory
          • class jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory
          • class jp.co.intra_mart.foundation.service.provider.file.StorageDirectory
          • class jp.co.intra_mart.foundation.service.provider.TemporaryDirectory
      • class jp.co.intra_mart.foundation.utility.file.ExtendedFile
        • class jp.co.intra_mart.foundation.service.provider.TemporaryFile
    • class jp.co.intra_mart.foundation.http.FileSender
    • class jp.co.intra_mart.foundation.utility.report.FileSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.utility.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.ReverseComparator
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class jp.co.intra_mart.foundation.utility.report.FilterMessageReporter (implements jp.co.intra_mart.foundation.utility.report.MessageReporter)
      • class jp.co.intra_mart.foundation.utility.report.LineReportFilter
      • class jp.co.intra_mart.foundation.utility.report.ReportLevelFilter (implements jp.co.intra_mart.foundation.utility.report.ReportLevel)
      • class jp.co.intra_mart.foundation.utility.report.RepresentativeReporter
    • class jp.co.intra_mart.foundation.scenario.FunctionContainer
      • class jp.co.intra_mart.foundation.scenario.FunctionContainerFile
    • class jp.co.intra_mart.foundation.service.provider.GarbageController
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel (implements jp.co.intra_mart.foundation.datastore.common.model.BaseModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.MenuServlet
        • class jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet
        • class jp.co.intra_mart.foundation.security.servlet.UserInitialServlet
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModel)
    • class jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap (implements jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap)
    • class jp.co.intra_mart.jssp.net.GenericURLBuilder
      • class jp.co.intra_mart.jssp.net.URLBuilder
    • class jp.co.intra_mart.foundation.appcomn.Grouping
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class jp.co.intra_mart.foundation.service.client.information.Identifier
    • class jp.co.intra_mart.system.mail.smtp.InetMail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.smtp.Mail (implements jp.co.intra_mart.system.javascript.imapi.MailSendErrDef, java.io.Serializable)
    • class jp.co.intra_mart.foundation.commons.validation.InputCheck
    • class java.io.InputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeInputStream
        • class jp.co.intra_mart.foundation.utility.io.XORInputStream
      • class jp.co.intra_mart.foundation.utility.io.HexInputStream
    • class jp.co.intra_mart.foundation.datastore.common.model.IntramartDBMapper (implements jp.co.intra_mart.foundation.datastore.common.model.Mapper)
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.security.license.LicenseManager
    • class jp.co.intra_mart.foundation.datastore.common.config.LifetimeType
    • class jp.co.intra_mart.foundation.graph.LineGraphObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.net.Localhost (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.LockMonitor
    • class jp.co.intra_mart.foundation.acssecurity.Logingp
    • class jp.co.intra_mart.foundation.security.group.LoginGroup (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.group.LoginGroupManager
    • class jp.co.intra_mart.foundation.security.group.MainPageImportLoginGroupPostWriterListener (implements jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener)
    • class jp.co.intra_mart.foundation.security.group.MainPagePatternInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.model.MapperFactory
    • class jp.co.intra_mart.foundation.security.menu.MenuInclusion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.MenuManager
    • class jp.co.intra_mart.foundation.security.permission.MenuPermissionSelector (implements jp.co.intra_mart.foundation.security.permission.PermissionSelector)
    • class jp.co.intra_mart.foundation.security.menu.MenuTree (implements java.util.Comparator)
    • class jp.co.intra_mart.foundation.security.message.MessageManager
    • class jp.co.intra_mart.foundation.utility.MultipurposeInternetMailExtensions
    • class jp.co.intra_mart.foundation.service.client.NetworkConnector (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.NetworkAgent (implements jp.co.intra_mart.foundation.service.client.ActionListener)
        • class jp.co.intra_mart.foundation.service.client.file.AbstractComponent (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.service.client.file.NetworkFile (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.ExternalMemory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.information.Lock (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentDirectory (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
        • class jp.co.intra_mart.foundation.service.client.information.PermanentFile (implements java.io.Serializable, jp.co.intra_mart.foundation.service.client.information.TreasureFile)
        • class jp.co.intra_mart.foundation.service.client.batch.Scheduler (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.service.client.manager.ServerConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.cryption.NoCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.page.NodeNameComparator (implements java.util.Comparator, java.io.Serializable)
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.utility.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.utility.report.OutputSizeConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class java.io.OutputStream
      • class jp.co.intra_mart.foundation.utility.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLDecodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.URLEncodeOutputStream
        • class jp.co.intra_mart.foundation.utility.io.XOROutputStream
      • class jp.co.intra_mart.foundation.utility.io.HexOutputStream
    • class jp.co.intra_mart.foundation.utility.report.PeriodicConditioner (implements jp.co.intra_mart.foundation.utility.report.ReportFileConditioner)
    • class jp.co.intra_mart.foundation.service.provider.batch.PermanentDataArchiveFactory (implements jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent)
    • class jp.co.intra_mart.foundation.security.permission.PermissionManager
    • class jp.co.intra_mart.foundation.service.provider.Platform
    • class jp.co.intra_mart.foundation.graph.PortFolioObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.PostInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.scenario.PresentationPage
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManager
    • class jp.co.intra_mart.foundation.appcomn.Profile
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.menu.PublicGroupChangedMenuListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.security.PublicGroupInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.graph.RadarChartObject (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.role.Role (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.account.RoleChangedAccountListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.security.menu.RoleChangedMenuListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.foundation.acssecurity.RoleManager
    • class jp.co.intra_mart.foundation.security.role.RoleManager
    • class jp.co.intra_mart.foundation.utility.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.foundation.service.client.information.SessionFactory (implements jp.co.intra_mart.foundation.service.client.information.TreasureDirectory)
    • class jp.co.intra_mart.foundation.security.filter.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.service.client.information.SessionMemory (implements jp.co.intra_mart.foundation.service.client.information.TreasureFile)
    • class jp.co.intra_mart.foundation.http.SessionQuery
    • class jp.co.intra_mart.foundation.service.client.manager.SocketConnectionDistributorFactory
    • class jp.co.intra_mart.foundation.security.account.StandardAccountBackup (implements jp.co.intra_mart.foundation.security.account.AccountExporter, jp.co.intra_mart.foundation.security.account.AccountImporter)
    • class jp.co.intra_mart.foundation.security.menu.StandardAdminMenuBackup (implements jp.co.intra_mart.foundation.security.menu.AdminMenuExporter, jp.co.intra_mart.foundation.security.menu.AdminMenuImporter)
    • class jp.co.intra_mart.foundation.security.batch.StandardBatchBackup (implements jp.co.intra_mart.foundation.security.batch.BatchExporter, jp.co.intra_mart.foundation.security.batch.BatchImporter)
    • class jp.co.intra_mart.foundation.security.calendar.StandardCalendarBackup (implements jp.co.intra_mart.foundation.security.calendar.CalendarExporter, jp.co.intra_mart.foundation.security.calendar.CalendarImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.company.StandardCompanyPostImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter)
    • class jp.co.intra_mart.foundation.security.cryption.StandardCryption (implements jp.co.intra_mart.foundation.security.cryption.Cryption)
    • class jp.co.intra_mart.foundation.security.certification.StandardErrorPageProvider (implements jp.co.intra_mart.foundation.security.certification.ErrorPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardGroupSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
    • class jp.co.intra_mart.foundation.security.menu.StandardMenuBackup (implements jp.co.intra_mart.foundation.security.menu.MenuExporter, jp.co.intra_mart.foundation.security.menu.MenuImporter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.public_group.StandardPublicGroupImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardRequestAnalyzer (implements jp.co.intra_mart.foundation.security.certification.RequestAnalyzer)
      • class jp.co.intra_mart.foundation.security.certification.SSORequestAnalyzer
    • class jp.co.intra_mart.foundation.security.role.StandardRoleBackup (implements jp.co.intra_mart.foundation.security.role.RoleExporter, jp.co.intra_mart.foundation.security.role.RoleImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.certification.StandardSuperUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserCertification (implements jp.co.intra_mart.foundation.security.certification.UserCertification)
      • class jp.co.intra_mart.foundation.security.certification.LDAPUserCertification
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.StandardUserImporter (implements jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter)
    • class jp.co.intra_mart.foundation.security.certification.StandardUserPageProvider (implements jp.co.intra_mart.foundation.security.certification.UserPageProvider)
    • class jp.co.intra_mart.foundation.security.admin.SuperUser (implements jp.co.intra_mart.foundation.security.LocaleProvider, java.io.Serializable)
    • class jp.co.intra_mart.foundation.security.certification.SuperUserNoCertification (implements jp.co.intra_mart.foundation.security.certification.SuperCertification)
    • class jp.co.intra_mart.foundation.security.SystemManager
    • class jp.co.intra_mart.foundation.datastore.common.structure.Term (implements java.lang.Comparable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.common.structure.TermManager
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.foundation.utility.ExtendedThread
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.acssecurity.AcssecurityException
        • class jp.co.intra_mart.foundation.appcomn.AppcomnException
        • class jp.co.intra_mart.foundation.exception.FoundationException
          • class jp.co.intra_mart.foundation.security.exception.AccessSecurityException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException
              • class jp.co.intra_mart.foundation.security.exception.DuplicateException
              • class jp.co.intra_mart.foundation.security.exception.NotExistException
              • class jp.co.intra_mart.foundation.security.exception.NotSupportMethodException
            • class jp.co.intra_mart.foundation.security.exception.IllegalArgumentException
            • class jp.co.intra_mart.foundation.security.exception.NoFilterException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionCookieException
            • class jp.co.intra_mart.foundation.security.exception.NoSessionException
            • class jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException
          • class jp.co.intra_mart.foundation.exception.ChangedListenerException
          • class jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException
            • class jp.co.intra_mart.foundation.datastore.exception.AccessorException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException
              • class jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException
                • class jp.co.intra_mart.foundation.datastore.exception.IllegalTermException
              • class jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException
            • class jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException
            • class jp.co.intra_mart.foundation.datastore.exception.ManagerException
            • class jp.co.intra_mart.foundation.datastore.exception.MapperException
            • class jp.co.intra_mart.foundation.datastore.exception.TermManagerException
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException
        • class jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException
        • class jp.co.intra_mart.foundation.datastore.exception.ImportException
        • class java.io.IOException
          • class jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
        • class jp.co.intra_mart.foundation.mail.MailSenderException
        • class jp.co.intra_mart.foundation.scenario.NoSuchPropertyException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
          • class jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.exception.FoundationRuntimeException
            • class jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException
              • class jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException
              • class jp.co.intra_mart.foundation.security.exception.SystemConfigException
            • class jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException
              • class jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException
              • class jp.co.intra_mart.foundation.datastore.exception.MapperDAOException
        • class jp.co.intra_mart.foundation.scenario.ScriptCompileException
        • class jp.co.intra_mart.foundation.scenario.ScriptRuntimeException
        • class java.sql.SQLException
          • class jp.co.intra_mart.foundation.database.exception.DatabaseSQLException
    • class jp.co.intra_mart.foundation.page.TreeLeaf (implements jp.co.intra_mart.foundation.page.TreeNode)
    • class jp.co.intra_mart.foundation.security.filter.URLAccessFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.User (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserManager
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational (implements java.io.Serializable)
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.foundation.utility.charset.AdvancedOutputStreamWriter
      • class jp.co.intra_mart.foundation.utility.io.ReplaceWriter
      • class jp.co.intra_mart.foundation.utility.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.foundation.security.account.AccountAccessor
  • interface jp.co.intra_mart.foundation.security.account.AccountChangedListener
  • interface jp.co.intra_mart.foundation.security.account.AccountExporter
  • interface jp.co.intra_mart.foundation.security.account.AccountImporter
  • interface jp.co.intra_mart.foundation.security.account.AccountPostWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.account.AccountReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.ActivationKey
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.AdminMenuReaderDecorator
  • interface jp.co.intra_mart.foundation.datastore.common.config.Application
  • interface jp.co.intra_mart.foundation.security.license.ApplicationInfo
  • interface jp.co.intra_mart.foundation.datastore.common.config.Attribute
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.BaseTable
  • interface jp.co.intra_mart.foundation.security.batch.BatchAccessor
  • interface jp.co.intra_mart.foundation.security.batch.BatchExporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchImporter
  • interface jp.co.intra_mart.foundation.security.batch.BatchPostWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.batch.BatchReaderDecorator
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarAccessor
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarExporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarImporter
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPlugin
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPluginInfo
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarPostWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.calendar.CalendarReaderDecorator
  • interface jp.co.intra_mart.foundation.security.ClientTypeInfo
  • interface jp.co.intra_mart.foundation.security.ColorPatternInfo
  • interface jp.co.intra_mart.foundation.datastore.common.config.Column
  • interface jp.co.intra_mart.foundation.datastore.common.config.ColumnMapping
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyPostImporter
  • interface java.util.Comparator
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.foundation.datastore.common.config.Configuration
  • interface jp.co.intra_mart.foundation.database.ConInfo
  • interface java.sql.Connection
    • interface jp.co.intra_mart.foundation.database.DbsConnection
  • interface jp.co.intra_mart.foundation.security.cryption.Cryption
  • interface jp.co.intra_mart.foundation.database.DatabaseAccessor
  • interface jp.co.intra_mart.foundation.database.DataSourceProvider
  • interface jp.co.intra_mart.foundation.security.calendar.DayInfo
  • interface jp.co.intra_mart.foundation.datastore.common.config.Delete
  • interface jp.co.intra_mart.foundation.datastore.application.domain.company.DepartmentStruct
  • interface jp.co.intra_mart.foundation.datastore.common.config.Entity
  • interface jp.co.intra_mart.foundation.service.provider.Environment
  • interface jp.co.intra_mart.foundation.utility.ErrorEventListener
  • interface jp.co.intra_mart.foundation.security.certification.ErrorPageProvider
  • interface jp.co.intra_mart.foundation.utility.EventListener
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExpirationKey
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedBaseTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedEntity
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedModel
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTable
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessor
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModelMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.ExtendedTerminableTable
  • interface jp.co.intra_mart.foundation.security.ExtendsImport
  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.GCConditioner
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.GroupSuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
  • interface jp.co.intra_mart.foundation.security.INonTransaction
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.InternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.Lifetime
  • interface jp.co.intra_mart.foundation.security.LocaleProvider
    • interface jp.co.intra_mart.foundation.security.LocaleInfo
    • interface jp.co.intra_mart.foundation.security.certification.LoginInfo
      • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
    • interface jp.co.intra_mart.foundation.security.certification.LoginRequestInfo
    • interface jp.co.intra_mart.foundation.security.SessionInfo
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupAccessor
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupPostWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.group.LoginGroupReaderDecorator
  • interface jp.co.intra_mart.foundation.mail.MailSender
  • interface jp.co.intra_mart.foundation.datastore.common.model.Mapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionMapper
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserMapper
  • interface jp.co.intra_mart.foundation.security.menu.MenuAccessor
  • interface jp.co.intra_mart.foundation.security.menu.MenuExporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuImporter
  • interface jp.co.intra_mart.foundation.security.menu.MenuPostWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.menu.MenuReaderDecorator
  • interface jp.co.intra_mart.foundation.utility.report.MessageReporter
  • interface jp.co.intra_mart.foundation.datastore.common.config.Model
  • interface jp.co.intra_mart.foundation.http.MultipartFormData.Entity
  • interface jp.co.intra_mart.foundation.security.permission.PermissionSelector
  • interface jp.co.intra_mart.foundation.datastore.common.config.PrimaryKeyMapping
  • interface jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupChangedListener
  • interface jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent
  • interface jp.co.intra_mart.foundation.datastore.common.config.Property
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupImporter
  • interface jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupStruct
  • interface jp.co.intra_mart.foundation.datastore.common.config.Relationship
  • interface jp.co.intra_mart.foundation.utility.report.ReportFileConditioner
  • interface jp.co.intra_mart.foundation.utility.report.ReportLevel
  • interface jp.co.intra_mart.foundation.security.certification.RequestAnalyzer
  • interface jp.co.intra_mart.foundation.security.role.RoleAccessor
  • interface jp.co.intra_mart.foundation.security.role.RoleChangedListener
  • interface jp.co.intra_mart.foundation.security.role.RoleExporter
  • interface jp.co.intra_mart.foundation.security.role.RoleImporter
  • interface jp.co.intra_mart.foundation.security.role.RolePostWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.role.RoleReaderDecorator
  • interface jp.co.intra_mart.foundation.scenario.ScriptValue
    • interface jp.co.intra_mart.foundation.scenario.VariableScope
  • interface jp.co.intra_mart.foundation.security.SecurityConstraint
  • interface java.io.Serializable
    • interface jp.co.intra_mart.foundation.service.client.ActionListener
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.BaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.BaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.company.CompanyBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.version.CompanyVersionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.inclusion.DepartmentInclusionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
    • interface jp.co.intra_mart.foundation.utility.DualComparator (同様に extends java.util.Comparator)
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedBaseAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.ExtendedTerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.ExtendedTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.InternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.detail.CategoryDetailInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.category.category_class.CateogryClassInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.InternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.application.domain.company.post.PlainCompanyPost
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.attach.PrivateGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.private_group.group.PrivateGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.inclusion.PublicGroupInclusionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.set.PublicGroupSetBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.version.PublicGroupVersionBaseModel
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessor
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableInternationalModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelMap
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.category.CompanyCategoryTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.post.CompanyPostTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.attach.DepartmentAttachTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.main.DepartmentMainTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.company.department.DepartmentTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.attach.PublicGroupAttachTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.category.PublicGroupCategoryTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.public_group.group.PublicGroupTerminableModel
      • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
    • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelMap
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserBaseModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableInternationalModel
    • interface jp.co.intra_mart.foundation.datastore.application.model.user.UserTerminableModel
  • interface jp.co.intra_mart.foundation.security.SessionConfig
  • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.foundation.utility.net.SocketConnectionManager
  • interface jp.co.intra_mart.foundation.utility.net.SocketEventListener
  • interface jp.co.intra_mart.foundation.security.certification.SuperCertification
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserAccessor
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserPostWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserQueryWriterListener
  • interface jp.co.intra_mart.foundation.security.admin.SuperUserReaderDecorator
  • interface jp.co.intra_mart.foundation.service.provider.SystemReporter
    • interface jp.co.intra_mart.foundation.service.provider.SystemErrorReporter
  • interface jp.co.intra_mart.foundation.security.SystemSourceProvider
  • interface jp.co.intra_mart.foundation.datastore.common.config.Table
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.accessor.TerminableInternationalAccessorMap
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableInternationalModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableInternationalTable
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableKey
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableModel
  • interface jp.co.intra_mart.foundation.datastore.common.model.TerminableModelContext
  • interface jp.co.intra_mart.foundation.datastore.common.config.TerminableTable
  • interface jp.co.intra_mart.foundation.utility.ThreadStopListener
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureDirectory
  • interface jp.co.intra_mart.foundation.service.client.information.TreasureFile
  • interface jp.co.intra_mart.foundation.page.TreeNode
  • interface jp.co.intra_mart.foundation.page.TreeNodeContainer
    • interface jp.co.intra_mart.foundation.page.TreeNodeProvider
  • interface jp.co.intra_mart.foundation.datastore.common.config.UpdateInfo
  • interface jp.co.intra_mart.foundation.security.certification.UserCertification
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserChangedListener
  • interface jp.co.intra_mart.foundation.datastore.application.domain.user.UserImporter
  • interface jp.co.intra_mart.foundation.security.certification.UserPageProvider
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


直列化された形式 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.service.client.application

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException は HTTPActionEventHandlerException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.acssecurity

クラス jp.co.intra_mart.foundation.acssecurity.AcssecurityException は Exception を拡張し、Serializable を実装しています

直列化されたフィールド

message

String message

code

int code

パッケージ jp.co.intra_mart.foundation.database.exception

クラス jp.co.intra_mart.foundation.database.exception.DatabaseSQLException は SQLException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.drawer

クラス jp.co.intra_mart.foundation.drawer.AbstractDrawer は Object を拡張し、Serializable を実装しています

直列化されたフィールド

width

int width

height

int height

type

String type

パッケージ jp.co.intra_mart.foundation.exception

クラス jp.co.intra_mart.foundation.exception.ChangedListenerException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.exception.FoundationException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.exception.FoundationRuntimeException は RuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.graph

クラス jp.co.intra_mart.foundation.graph.BarGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.BarGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.CircleGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption_margin

int caption_margin

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.CircleGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

data

double data

color

Color color

caption

String caption

font_color

Color font_color

font_size

int font_size

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.LineGraphDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.LineGraphObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

data

ArrayList data

クラス jp.co.intra_mart.foundation.graph.PortFolioDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_background_color

Color graph_background_color

graph_border_color

Color graph_border_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

data

ArrayList data

x_max

Number x_max

x_min

Number x_min

y_max

Number y_max

y_min

Number y_min

isDouble

boolean isDouble

x_center

Number x_center

x_size

Number x_size

x_count

Number x_count

y_center

Number y_center

y_size

Number y_size

y_count

Number y_count

scale_position

String scale_position

クラス jp.co.intra_mart.foundation.graph.PortFolioObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

x_data

double x_data

y_data

double y_data

color

Color color

size

int size

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.RadarChartDrawer は AbstractDrawer を拡張し、Serializable を実装しています

直列化されたフィールド

image_background_color

Color image_background_color

image_border_color

Color image_border_color

graph_frame_color

Color graph_frame_color

caption_color

Color caption_color

top_margin

int top_margin

right_margin

int right_margin

bottom_margin

int bottom_margin

left_margin

int left_margin

caption_margin

int caption_margin

caption

String[] caption

data

ArrayList data

max

Number max

min

Number min

count

Number count

isDouble

boolean isDouble

クラス jp.co.intra_mart.foundation.graph.RadarChartObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

Color color

fill

boolean fill

data

ArrayList data

パッケージ jp.co.intra_mart.foundation.http

クラス jp.co.intra_mart.foundation.http.CGIEnvironment は HashMap を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.http.MultipartFormData は ArrayList を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.mail

クラス jp.co.intra_mart.foundation.mail.MailSenderException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.page

クラス jp.co.intra_mart.foundation.page.NodeNameComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.page.NodeTypeComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator

secondaryComparator

Comparator secondaryComparator

パッケージ jp.co.intra_mart.foundation.scenario

クラス jp.co.intra_mart.foundation.scenario.NoSuchPropertyException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.scenario.ScriptCompileException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.scenario.ScriptRuntimeException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security

クラス jp.co.intra_mart.foundation.security.DepartmentInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード。

departmentCode

String departmentCode
組織コード。

クラス jp.co.intra_mart.foundation.security.PostInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード。

postCode

String postCode
役職コード。

クラス jp.co.intra_mart.foundation.security.PublicGroupInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

groupSetCode

String groupSetCode
グループセットコード。

groupCode

String groupCode
グループコード。

パッケージ jp.co.intra_mart.foundation.security.account

クラス jp.co.intra_mart.foundation.security.account.Account は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

goOut

boolean goOut
外出フラグ

locale

Locale locale
ロケール

lockdate

Date lockdate
アカウントロック日付

loginFailureCount

int loginFailureCount
ログイン失敗回数

mainPagePatternId

String mainPagePatternId
メインページパターンID

mobilePassword

String mobilePassword
モバイル用パスワード

description

String description
説明

colorPatternId

String colorPatternId
カラーパターンID

password

String password
パスワード

userId

String userId
ユーザID

validEndDate

Date validEndDate
有効終了日

validStartDate

Date validStartDate
有効開始日

クラス jp.co.intra_mart.foundation.security.account.AccountRole は Object を拡張し、Serializable を実装しています

直列化されたフィールド

roleId

String roleId
ロールID

roleValidEndDate

Date roleValidEndDate
ロール有効終了日

roleValidStartDate

Date roleValidStartDate
ロール有効開始日

クラス jp.co.intra_mart.foundation.security.account.FavoriteMenu は Object を拡張し、Serializable を実装しています

直列化されたフィールド

displayName

String displayName
マイメニュー表示名

menuId

String menuId
メニューID

sortNumber

int sortNumber
ソート番号

パッケージ jp.co.intra_mart.foundation.security.admin

クラス jp.co.intra_mart.foundation.security.admin.SuperUser は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

locale

Locale locale
ロケール

mailAddress

String mailAddress
メールアドレス

password

String password
パスワード

telNo

String telNo
電話番号

userId

String userId
ユーザーID

パッケージ jp.co.intra_mart.foundation.security.batch

クラス jp.co.intra_mart.foundation.security.batch.Batch は Object を拡張し、Serializable を実装しています

直列化されたフィールド

batchId

String batchId
バッチＩＤ

description

String description
バッチ内容

name

String name
バッチ名

programLanguage

String programLanguage
実行プログラム言語

programPath

String programPath
実行プログラムパス

runDay

int runDay
実行日

runDayWeek

int runDayWeek
実行曜日

runHour

int runHour
実行時

runMinute

int runMinute
実行分

runMonth

int runMonth
実行月

runSecond

int runSecond
実行秒

runYear

int runYear
実行年

validate

boolean validate
有効・無効フラグ

パッケージ jp.co.intra_mart.foundation.security.calendar

クラス jp.co.intra_mart.foundation.security.calendar.CalendarInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

color

String color
表示色

dataId

String dataId
データＩＤ（入力必須）

dataType

String dataType
データタイプ

day

int day
日

dayWeek

int dayWeek
曜日

description

String description
カレンダーデータの説明

displayName

Map displayName
表示名

month

int month
月

plugin

String plugin
プラグインID

times

int times
第ｎ～曜日

validEndYear

int validEndYear
有効終了年

validStartYear

int validStartYear
有効開始年

week

int week
第ｎ週目

year

int year
年

regExpPattern

Pattern regExpPattern
検証パターン(正規表現)

priority

int priority
優先度

パッケージ jp.co.intra_mart.foundation.security.exception

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityConfigException は AccessSecurityRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityCreateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityDeleteException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityException は FoundationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityExportException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityImportException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityListenerExcpetion は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityReadException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityRuntimeException は FoundationRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityUpdateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.AccessSecurityWriteException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.DuplicateException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.IllegalArgumentException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoFilterException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoSessionCookieException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NoSessionException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotExistException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotFoundDataSourceException は AccessSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.NotSupportMethodException は AccessSecurityWriteException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.security.exception.SystemConfigException は AccessSecurityRuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.security.group

クラス jp.co.intra_mart.foundation.security.group.LoginGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

encoding

String encoding
エンコーディング

locale

Locale locale
ロケール

lockCount

int lockCount
アカウントロックカウント

lockTerm

int lockTerm
アカウントロック時間（分）

loginGroupId

String loginGroupId
ログイングループID

colorPatternId

String colorPatternId
カラーパターンID

クラス jp.co.intra_mart.foundation.security.group.MainPagePatternInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

mainPagePatternId

String mainPagePatternId
メインページパターンID。

mainPagePatternImageUrl

String mainPagePatternImageUrl
メインページパターンイメージURL。

mainPagePatternUrl

String mainPagePatternUrl
メインページパターンURL。

パッケージ jp.co.intra_mart.foundation.security.menu

クラス jp.co.intra_mart.foundation.security.menu.AdminMenuInclusion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

childMenuId

String childMenuId
子メニューID。

parentMenuId

String parentMenuId
親メニューID。

クラス jp.co.intra_mart.foundation.security.menu.MenuInclusion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

childMenuId

String childMenuId
子メニューID。

parentMenuId

String parentMenuId
親メニューID。

クラス jp.co.intra_mart.foundation.security.menu.MenuItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

arguments

Map arguments
引数

clientType

String clientType
クライアントタイプ

contents

String contents
コンテンツの種類

description

String description
説明

displayNames

Map displayNames
メニュー名 (多言語化対応、 key:ロケール、value メニュー名)

id

String id
メニューID

sortNumber

int sortNumber
ソート番号

type

String type
ノードタイプ

url

String url
URL

imagePath

String imagePath
メニューイメージパス。

パッケージ jp.co.intra_mart.foundation.security.role

クラス jp.co.intra_mart.foundation.security.role.Role は Object を拡張し、Serializable を実装しています

直列化されたフィールド

category

String category
ロールカテゴリ。

description

String description
ロールの詳細。

displayName

Map displayName
ロールの表示名 (key:ロケール、value:ロール表示名)。

roleId

String roleId
ロールID。

roleName

String roleName
ロール名。

パッケージ jp.co.intra_mart.foundation.security.servlet

クラス jp.co.intra_mart.foundation.security.servlet.GroupSuperUserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.MenuServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.SuperUserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.UserCertificationServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

クラス jp.co.intra_mart.foundation.security.servlet.UserInitialServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

redilectClientTypes

Set redilectClientTypes
メインページをリダイレクトで返却するクライアントタイプ。

clientType

String clientType
クライアントタイプ。

パッケージ jp.co.intra_mart.foundation.service.client

クラス jp.co.intra_mart.foundation.service.client.NetworkAgent は NetworkConnector を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.NetworkConnector は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.batch

クラス jp.co.intra_mart.foundation.service.client.batch.Scheduler は NetworkAgent を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.client.file

クラス jp.co.intra_mart.foundation.service.client.file.AbstractComponent は NetworkAgent を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.file.NetworkFile は AbstractComponent を拡張し、Serializable を実装しています

直列化されたフィールド

path

String path

パッケージ jp.co.intra_mart.foundation.service.client.information

クラス jp.co.intra_mart.foundation.service.client.information.ExternalDirectory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

dir

String dir

クラス jp.co.intra_mart.foundation.service.client.information.ExternalMemory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

parent

String parent

クラス jp.co.intra_mart.foundation.service.client.information.InitialFile は Properties を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.information.Lock は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

クラス jp.co.intra_mart.foundation.service.client.information.PermanentDirectory は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

dir

String dir

クラス jp.co.intra_mart.foundation.service.client.information.PermanentFile は NetworkAgent を拡張し、Serializable を実装しています

直列化されたフィールド

id

String id

parent

String parent

パッケージ jp.co.intra_mart.foundation.service.client.manager

クラス jp.co.intra_mart.foundation.service.client.manager.IllegalPasswordException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.manager.ServerConnector は NetworkConnector を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider

クラス jp.co.intra_mart.foundation.service.provider.HomeDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.TemporaryDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.TemporaryFile は ExtendedFile を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.file

クラス jp.co.intra_mart.foundation.service.provider.file.StorageDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.information

クラス jp.co.intra_mart.foundation.service.provider.information.PermanentDataDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.information.ProgramDirectory は ExtendedDirectory を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.smtp

クラス jp.co.intra_mart.foundation.smtp.Mail は jp.co.intra_mart.system.mail.smtp.InetMail を拡張し、Serializable を実装しています

直列化されたフィールド

tempSmtpsvr

String tempSmtpsvr
推奨されていません。

badAdrs

ArrayList badAdrs
推奨されていません。

errCode

int errCode
推奨されていません。

errMsg

String errMsg
推奨されていません。

toFlg

boolean toFlg
推奨されていません。

fromFlg

boolean fromFlg
推奨されていません。

replyFlg

boolean replyFlg
推奨されていません。

パッケージ jp.co.intra_mart.foundation.utility

クラス jp.co.intra_mart.foundation.utility.AbstractDualComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.Counter は Number を拡張し、Serializable を実装しています

直列化されたフィールド

currentValue

long currentValue
推奨されていません。
カウンターの値

クラス jp.co.intra_mart.foundation.utility.FilterComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

Comparator parent
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.MultiComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator
推奨されていません。
第１コンパレータ

secondaryComparator

MultiComparator secondaryComparator
推奨されていません。
第２コンパレータ

クラス jp.co.intra_mart.foundation.utility.ResourceBundleProperties は Properties を拡張し、Serializable を実装しています

直列化されたフィールド

currentLocale

Locale currentLocale
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.ReverseComparator は FilterComparator を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.SequenceComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

map

WeakHashMap map
推奨されていません。
map

count

long count
推奨されていません。
挿入順番

パッケージ jp.co.intra_mart.foundation.utility.charset

クラス jp.co.intra_mart.foundation.utility.charset.ResourceFormatException は ResourceFormatException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.charset.ResourceNotFoundException は ResourceNotFoundException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.utility.file

クラス jp.co.intra_mart.foundation.utility.file.Directory は File を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.utility.file.ExtendedDirectory は Directory を拡張し、Serializable を実装しています

直列化されたフィールド

POOL

FixedSizeMap POOL
推奨されていません。
このディレクトリを親とするファイルオブジェクトのキャッシュ領域

クラス jp.co.intra_mart.foundation.utility.file.ExtendedFile は File を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.utility.net

クラス jp.co.intra_mart.foundation.utility.net.Localhost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

localhostIPAddress

byte[] localhostIPAddress
推奨されていません。

localhostAddress

String localhostAddress
推奨されていません。

localhostName

String localhostName
推奨されていません。

クラス jp.co.intra_mart.foundation.utility.net.UnsupportedNetworkConnectException は IOException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.appcomn

クラス jp.co.intra_mart.foundation.appcomn.AppcomnException は Exception を拡張し、Serializable を実装しています

直列化されたフィールド

message

String message

code

int code

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.category_class

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClass は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryClassCode

String categoryClassCode
分類区分コード

notes

String notes
備考

internationals

Map internationals
分類区分の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.category_class.CateogryClassInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
分類区分名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.category.detail

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

notes

String notes
備考

internationals

Map internationals
分類区分詳細の国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.category.detail.CategoryDetailInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
分類名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
組織所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttachTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

postCode

String postCode
役職CD

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

terminables

SortedMap terminables
会社組織分類の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategoryTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.company

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
会社の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス1

emailAddress2

String emailAddress2
メールアドレス2

url

String url
URL

terminableInternationals

Map terminableInternationals
会社の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.company.CompanyTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
組織名

nameSyllabary

String nameSyllabary
組織名カナ

nameEnglish

String nameEnglish
組織名英字

address1

String address1
住所1

address2

String address2
住所2

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.department

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
組織の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス1

emailAddress2

String emailAddress2
メールアドレス2

url

String url
URL

terminableInternationals

Map terminableInternationals
組織の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.department.DepartmentTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
組織名

nameSyllabary

String nameSyllabary
組織名カナ

nameEnglish

String nameEnglish
組織名英字

address1

String address1
住所1

address2

String address2
住所2

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.main

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

terminables

SortedMap terminables
主所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMainTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

departmentCode

String departmentCode
組織コード

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.post

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

postCode

String postCode
役職コード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
役職の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
役職の期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPostTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
役職名

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.company.version

クラス jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

versionCode

String versionCode
バージョンコード

startDate

Date startDate
開始日

endDate

Date endDate
終了日

notes

String notes
備考

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.attach.PrivateGroupAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ownerCode

String ownerCode
所有者コード

privateGroupCode

String privateGroupCode
グループコード

userCode

String userCode
ユーザコード

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.private_group.group

クラス jp.co.intra_mart.foundation.datastore.application.domain.private_group.group.PrivateGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ownerCode

String ownerCode
所有者コード

privateGroupCode

String privateGroupCode
グループコード

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

notes

String notes
備考

sortKey

int sortKey
ソートキー

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
パブリックグループ所属の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttachTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.category

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

categoryClassCode

String categoryClassCode
分類区分コード

categoryCode

String categoryCode
分類コード

terminables

SortedMap terminables
パブリックグループ分類の期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategoryTerminable は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.group

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

publicGroupCode

String publicGroupCode
グループコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
パブリックグループの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
パブリックグループの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroupTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.set

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
パブリックグループセットの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

terminableInternationals

Map terminableInternationals
パブリックグループセットの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSetTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
グループ名

nameSyllabary

String nameSyllabary
グループ名カナ

nameEnglish

String nameEnglish
グループ名英字

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.public_group.version

クラス jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion は Object を拡張し、Serializable を実装しています

直列化されたフィールド

publicGroupSetCode

String publicGroupSetCode
グループセットコード

versionCode

String versionCode
バージョンコード

startDate

Date startDate
開始日

endDate

Date endDate
終了日

notes

String notes
備考

パッケージ jp.co.intra_mart.foundation.datastore.application.domain.user

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.User は Object を拡張し、Serializable を実装しています

直列化されたフィールド

userCode

String userCode
ユーザコード

accountFlag

String accountFlag
アカウントフラグ

notes

String notes
備考

sortKey

int sortKey
ソートキー

terminables

SortedMap terminables
ユーザの期間化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

telephoneNumber

String telephoneNumber
電話番号

mobileNumber

String mobileNumber
携帯電話番号

faxNumber

String faxNumber
FAX番号

extensionNumber

String extensionNumber
内線番号

extensionFaxNumber

String extensionFaxNumber
内線FAX番号

countryCode

String countryCode
国コード

zipCode

String zipCode
郵便番号

emailAddress1

String emailAddress1
メールアドレス１

emailAddress2

String emailAddress2
メールアドレス２

mobileEmailAddress

String mobileEmailAddress
携帯用メール

url

String url
URL

terminableInternationals

Map terminableInternationals
ユーザの期間国際化に関連する情報のマップ

クラス jp.co.intra_mart.foundation.datastore.application.domain.user.UserTerminableInternational は Object を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
ユーザ名

nameSyllabary

String nameSyllabary
ユーザ名カナ

nameEnglish

String nameEnglish
ユーザ名英字

address

String address
住所

パッケージ jp.co.intra_mart.foundation.datastore.common.config

クラス jp.co.intra_mart.foundation.datastore.common.config.AttributeType は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.common.config.DeleteType は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.datastore.common.model

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericBaseModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedBaseAccessor accessor
拡張基本アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedInternationalAccessor accessor
拡張国際化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedTerminableInternationalAccessor accessor
拡張期間国際化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.ExtendedGenericTerminableModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

accessor

ExtendedTerminableAccessor accessor
拡張期間化アクセサ

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericBaseModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

BaseModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

InternationalModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericInternationalModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
国際化モデルを管理するマップ

modelName

String modelName
国際化モデルのクラス名

accessorMap

InternationalAccessorMap accessorMap
国際化アクセサマッピング

key

String key
メッセージキー

関連項目:
定数フィールド値

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

TerminableInternationalModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableInternationalModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
期間国際化モデルを管理するマップ

modelName

String modelName
期間国際化モデル名

accessorMap

TerminableInternationalAccessorMap accessorMap
国際化アクセサマッピング

key

String key
メッセージキー

関連項目:
定数フィールド値

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

context

TerminableModelContext context
コンテキスト

クラス jp.co.intra_mart.foundation.datastore.common.model.GenericTerminableModelMap は Object を拡張し、Serializable を実装しています

直列化されたフィールド

models

Map models
期間化モデルを管理するマップ

terminableName

String terminableName
期間化モデルのクラス名

terminableInternationalName

String terminableInternationalName
期間国際化モデルのクラス名

accessorMap

TerminableAccessorMap accessorMap
期間化アクセサマッピング

defaultLocale

Locale defaultLocale
デフォルト言語

helper

jp.co.intra_mart.system.datastore.common.model.GenericTerminableModelMapHelper helper
期間化モデルマッピングヘルパー

key

String key
メッセージキー

関連項目:
定数フィールド値

パッケージ jp.co.intra_mart.foundation.datastore.common.structure

クラス jp.co.intra_mart.foundation.datastore.common.structure.Term は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activationCal

Calendar activationCal
有効開始時間

expirationCal

Calendar expirationCal
有効終了時間

termByString

String termByString
期間の文字列表現

パッケージ jp.co.intra_mart.foundation.datastore.exception

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorClosedException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorIllegalPropertyValueException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.AccessorSystemException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataNotFoundException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreApplicationException は FoundationException を拡張し、Serializable を実装しています

直列化されたフィールド

key

String key
メッセージキー

values

String[] values
置換用文字列

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreConfigException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.DataStoreSystemException は FoundationRuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalExtensionException は AccessorException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalLocaleException は DataNotFoundException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalRelationshipException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.IllegalTermException は DataNotFoundException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.ImportException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.ManagerException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.MapperDAOException は DataStoreSystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.MapperException は DataStoreApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.datastore.exception.TermManagerException は DataStoreApplicationException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.application

クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.base.data.ConnectorModel の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ConnectorModel の使用

jp.co.intra_mart.framework.base.data.ConnectorModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.data.DAO の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.DAO の使用

DAO を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DAO の使用

DAO を実装している jp.co.intra_mart.framework.base.data のクラス
class | DAOAdapter DAOのすべてのメソッドを何もしないように実装したクラスです。
class | DBDAO データベースに特化したDAOです。
class | IntramartDBDAO 推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
class | IntramartFileServerDAO intra-martのStorageサービスを使用する場合のDAOです。
class | LoginGroupDBDAO イントラマートで設定されたDBへアクセスするDAOです。
class | SystemDBDAO イントラマートで設定されたDBへアクセスするDAOです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DAOAdapter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DAOAdapter の使用

jp.co.intra_mart.framework.base.data.DAOAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DAOException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DAOException の使用

DAOException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.base.data のメソッド
 Object DataAccessController.getDAO(String application, String key, String connect)
DAOを取得します。

jp.co.intra_mart.framework.base.event での DAOException の使用

DAOException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DaoModel の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DaoModel の使用

jp.co.intra_mart.framework.base.data.DaoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataAccessController の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataAccessController の使用

DataAccessController を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.data のメソッド
 DataAccessController DataManager.getDataAccessController()
データアクセスコントローラを取得します。

jp.co.intra_mart.framework.base.event での DataAccessController の使用

DataAccessController を返す jp.co.intra_mart.framework.base.event のメソッド
protected  DataAccessController StandardEventListener.getDataAccessController()
このイベントリスナで使用するデータアクセスコントローラです。

DataAccessController 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataAccessException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataAccessException の使用

jp.co.intra_mart.framework.base.data.DataAccessException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataConnectException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnectException の使用

DataConnectException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.base.data のメソッド
void | SystemDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
Connection | SystemDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | SystemDBConnector.commit() コミットします。
void | SystemDBConnector.rollback() ロールバックします。
void | SystemDBConnector.release() データストアの資源を解放します。
Connection | SystemDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | SystemDBConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | LoginGroupDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
Connection | LoginGroupDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | LoginGroupDBConnector.commit() コミットします。
void | LoginGroupDBConnector.rollback() ロールバックします。
void | LoginGroupDBConnector.release() データストアの資源を解放します。
Connection | LoginGroupDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | LoginGroupDBConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | JDBCConnector.commit() 推奨されていません。 コミットします。
void | JDBCConnector.rollback() 推奨されていません。 ロールバックします。
void | JDBCConnector.release() 推奨されていません。 データストアの資源を解放します。
protected Connection | JDBCConnector.putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
void | IntramartFileServerDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
protected Object | IntramartFileServerConnector.getResource(String key, String connect, String resource) リソースを取得します。
void | IntramartFileServerConnector.commit() コミットします。
void | IntramartFileServerConnector.rollback() ロールバックします。
void | IntramartFileServerConnector.release() データストアの資源を解放します。
void | IntramartDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
jp.co.intra_mart.foundation.database.DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
void | IntramartDBConnector.commit() 推奨されていません。 コミットします。
void | IntramartDBConnector.rollback() 推奨されていません。 ロールバックします。
void | IntramartDBConnector.release() 推奨されていません。 データストアの資源を解放します。
protected Object | IntramartDBConnector.getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
jp.co.intra_mart.foundation.database.DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
void | DataSourceConnector.commit() コミットします。
void | DataSourceConnector.rollback() ロールバックします。
void | DataSourceConnector.release() データストアの資源を解放します。
protected Connection | DataSourceConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected abstract Object | DataConnector.getResource(String key, String connect, String resource) リソースを取得します。
abstract void | DataConnector.commit() コミットします。
abstract void | DataConnector.rollback() ロールバックします。
abstract void | DataConnector.release() データストアの資源を解放します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。
void | DataAccessController.commit() すべてのデータコネクタをコミットします。
void | DataAccessController.rollback() すべてのデータコネクタをロールバックします。
void | DataAccessController.release() すべてのデータストアの資源を解放します。
void | DBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
protected Connection | DBDAO.getConnection() このDAOに関連づけられたコネクションを取得します。
protected abstract Connection | DBConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected Object | DBConnector.getResource(String key, String connect, String resource) リソースを取得します。
Connection | DBConnector.getConnection(String resource) データベースへのコネクションを取得します。
void | DBConnector.commit() コミットします。
void | DBConnector.rollback() ロールバックします。
void | DBConnector.release() データストアの資源を解放します。
void | DAOAdapter.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。

jp.co.intra_mart.framework.base.event での DataConnectException の使用

DataConnectException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataConnector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnector の使用

DataConnector を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnector の使用

jp.co.intra_mart.framework.base.data での DataConnector のサブクラス
class | DataSourceConnector DataSourceに関連するデータコネクタです。
class | DBConnector データベースに対するコネクタです。
class | IntramartDBConnector 推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
class | IntramartFileServerConnector intra-martのStorageサービスに接続するデータコネクタです。
class | JDBCConnector 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
class | LoginGroupDBConnector イントラマートで設定されているDBコネクションです。
class | SystemDBConnector イントラマートで設定されているDBコネクションです。

DataConnector 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
void | SystemDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | LoginGroupDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | IntramartFileServerDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | IntramartDBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
void | DBDAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAOAdapter.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
void | DAO.setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataConnectorException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataConnectorException の使用

DataConnectorException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.base.data のメソッド
protected jp.co.intra_mart.foundation.service.client.file.NetworkFile | IntramartFileServerDAO.getNetworkFile(String path) パスに該当するNetworkFileを取得します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。

jp.co.intra_mart.framework.base.event での DataConnectorException の使用

DataConnectorException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataManager の使用

DataManager を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataManager の使用

DataManager を返す jp.co.intra_mart.framework.base.data のメソッド
static DataManager DataManager.getDataManager()
データマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataManagerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataManagerException の使用

DataManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataManagerException の使用

DataManagerException をスローする jp.co.intra_mart.framework.base.data のメソッド
static DataManager DataManager.getDataManager()
データマネージャを取得します。

DataManagerException をスローする jp.co.intra_mart.framework.base.data のコンストラクタ
DataManager()
データマネージャを生成するコンストラクタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataPropertyException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataPropertyException の使用

DataPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.base.data のメソッド
boolean | XmlDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | XmlDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | XmlDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | XmlDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | XmlDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | XmlDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
String | TextFileDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | TextFileDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | TextFileDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | TextFileDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | TextFileDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
Connection | SystemDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
Connection | SystemDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
Connection | LoginGroupDBDAO.getConnection() イントラマートで設定されているDBへのコネクションを取得します。
Connection | LoginGroupDBConnector.getConnection(String connect) データベースへのコネクションを取得します。
protected Object | IntramartFileServerConnector.getResource(String key, String connect, String resource) リソースを取得します。
jp.co.intra_mart.foundation.database.DbsConnection | IntramartDBDAO.getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
protected Object | IntramartDBConnector.getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
jp.co.intra_mart.foundation.database.DbsConnection | IntramartDBConnector.getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
boolean | DistributesDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DistributesDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DistributesDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DistributesDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DistributesDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DistributesDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
boolean | DefaultDataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DefaultDataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DefaultDataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DefaultDataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DefaultDataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DefaultDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
boolean | DataPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DataPropertyHandler.getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
String | DataPropertyHandler.getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | DataPropertyHandler.getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | DataPropertyHandler.getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
ResourceParam[] | DataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
protected abstract Object | DataConnector.getResource(String key, String connect, String resource) リソースを取得します。
Object | DataAccessController.getDAO(String application, String key, String connect) DAOを取得します。
protected Connection | DBDAO.getConnection() このDAOに関連づけられたコネクションを取得します。
protected Object | DBConnector.getResource(String key, String connect, String resource) リソースを取得します。
Connection | DBConnector.getConnection(String resource) データベースへのコネクションを取得します。

jp.co.intra_mart.framework.base.event での DataPropertyException の使用

DataPropertyException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected Object | StandardEventListener.getDAO(String application, String key, String connect) DAOを取得します。
protected Object | EventTriggerAdapter.getDAO(String application, String key, String connect) DAOを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.data.DataPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.data.DataPropertyHandler の使用

DataPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DataPropertyHandler の使用

DataPropertyHandler を実装している jp.co.intra_mart.framework.base.data のクラス
class | DefaultDataPropertyHandler デフォルトのデータプロパティハンドラです。
class | DistributesDataPropertyHandler アプリケーション毎のプロパティハンドラを呼び出します。
class | TextFileDataPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlDataPropertyHandler XMLのデータプロパティハンドラです。

DataPropertyHandler を返す jp.co.intra_mart.framework.base.data のメソッド
DataPropertyHandler | DataManager.getDataPropertyHandler() データプロパティハンドラを取得します。
DataPropertyHandler | DataConnector.getDataPropertyHandler() データプロパティハンドラを取得します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
 void DataConnector.setDataPropertyHandler(DataPropertyHandler handler)
データプロパティハンドラを設定します。

DataPropertyHandler 型のパラメータを持つ jp.co.intra_mart.framework.base.data のコンストラクタ
DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DataSourceConnector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DataSourceConnector の使用

jp.co.intra_mart.framework.base.data.DataSourceConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DBConnector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DBConnector の使用

DBConnector を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での DBConnector の使用

jp.co.intra_mart.framework.base.data での DBConnector のサブクラス
class | DataSourceConnector DataSourceに関連するデータコネクタです。
class | JDBCConnector 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DBDAO の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DBDAO の使用

jp.co.intra_mart.framework.base.data.DBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.IntramartDBConnector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartDBConnector の使用

jp.co.intra_mart.framework.base.data.IntramartDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.IntramartDBDAO の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartDBDAO の使用

jp.co.intra_mart.framework.base.data.IntramartDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の使用

jp.co.intra_mart.framework.base.data.IntramartFileServerConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.IntramartFileServerDAO の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.IntramartFileServerDAO の使用

jp.co.intra_mart.framework.base.data.IntramartFileServerDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.JDBCConnector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.JDBCConnector の使用

jp.co.intra_mart.framework.base.data.JDBCConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の使用

jp.co.intra_mart.framework.base.data.LoginGroupDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.LoginGroupDBDAO の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.LoginGroupDBDAO の使用

jp.co.intra_mart.framework.base.data.LoginGroupDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.ResourceModel の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ResourceModel の使用

jp.co.intra_mart.framework.base.data.ResourceModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.ResourceParam の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.ResourceParam の使用

ResourceParam を使用しているパッケージ
jp.co.intra_mart.framework.base.data データアクセスに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data での ResourceParam の使用

ResourceParam を返す jp.co.intra_mart.framework.base.data のメソッド
ResourceParam[] | XmlDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | TextFileDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DistributesDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DefaultDataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。
ResourceParam[] | DataPropertyHandler.getResourceParams(String name) リソースのパラメータを取得します。

ResourceParam 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
protected Connection | JDBCConnector.putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
protected Connection | DataSourceConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
protected abstract Connection | DBConnector.putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.SystemDBConnector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.SystemDBConnector の使用

jp.co.intra_mart.framework.base.data.SystemDBConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.SystemDBDAO の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.SystemDBDAO の使用

jp.co.intra_mart.framework.base.data.SystemDBDAO はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の使用

jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ConnectorModel (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ConnectorModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.ConnectorModel
public class ConnectorModel
extends Object

コネクタ情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_CONNECTOR_CLASS
static String | P_ID_CONNECTOR_NAME
static String | P_ID_RESOURCE_NAME
コンストラクタの概要
ConnectorModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONNECTOR_NAME

public static final String P_ID_CONNECTOR_NAME
関連項目:
定数フィールド値

P_ID_CONNECTOR_CLASS

public static final String P_ID_CONNECTOR_CLASS
関連項目:
定数フィールド値

P_ID_RESOURCE_NAME

public static final String P_ID_RESOURCE_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

ConnectorModel

public ConnectorModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DAO (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
インタフェース DAO

既知の実装クラスの一覧:
DAOAdapter, DBDAO, IntramartDBDAO, IntramartFileServerDAO, LoginGroupDBDAO, SystemDBDAO
public interface DAO

データリソースにアクセスするインタフェースです。 すべてのDAOはこのインタフェースを実装する必要があります。

バージョン:
1.0

メソッドの概要
 void setConnectInfo(DataConnector connector, String resource, String key, String connect)
データリソースに接続する時の情報を設定します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DAOAdapter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DAOAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DAOAdapter
すべての実装インタフェース:
DAO
public class DAOAdapter
extends Object
implements DAO

DAOのすべてのメソッドを何もしないように実装したクラスです。 データリソースへの接続を必要としない場合や、 開発時のスタブ用のDAOとして一時的に使うDAOを作るときなどは このクラスを継承すると便利です。

導入されたバージョン:
3.2

コンストラクタの概要
DAOAdapter()
DAOAdapterを新規に生成します。
メソッドの概要
 void setConnectInfo(DataConnector connector, String resource, String key, String connect)
データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DAOAdapter

public DAOAdapter()
DAOAdapterを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。 このクラスではkのメソッドは何もしません。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DAOException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DAOException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DAOException
すべての実装インタフェース:
Serializable
public class DAOException
extends SystemException

リソースコネクタの情報取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DAOException()
詳細メッセージを指定しないで DAOException を構築します。
DAOException(String msg)
指定された詳細メッセージを持つ DAOException を構築します。
DAOException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DAOException

public DAOException()
詳細メッセージを指定しないで DAOException を構築します。

DAOException

public DAOException(String msg)
指定された詳細メッセージを持つ DAOException を構築します。

パラメータ:
msg - 詳細メッセージ

DAOException

public DAOException(String msg,
                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DaoModel (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DaoModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DaoModel
public class DaoModel
extends Object

DaoModelを管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_CONNECT_NAME
static String | P_ID_DAO_CLASS
static String | P_ID_DAO_CONNECTOR_NAME
コンストラクタの概要
DaoModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_CONNECT_NAME

public static final String P_ID_CONNECT_NAME
関連項目:
定数フィールド値

P_ID_DAO_CLASS

public static final String P_ID_DAO_CLASS
関連項目:
定数フィールド値

P_ID_DAO_CONNECTOR_NAME

public static final String P_ID_DAO_CONNECTOR_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

DaoModel

public DaoModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataAccessController (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataAccessController

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataAccessController
public class DataAccessController
extends Object

データアクセスを制御します。 DAOの取得、コネクタの管理等を行います。 このクラスを利用して簡易トランザクションを実現することも可能ですが、この方法は推奨されません。 トランザクションはできる限りJava Transaction API(JTA)のUserTransactionを利用して行ってください。

バージョン:
1.0

コンストラクタの概要
DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。
メソッドの概要
void | commit() すべてのデータコネクタをコミットします。
Object | getDAO(String application, String key, String connect) DAOを取得します。
void | release() すべてのデータストアの資源を解放します。
void | rollback() すべてのデータコネクタをロールバックします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataAccessController

public DataAccessController(DataPropertyHandler handler)
データアクセスコントローラを生成します。

パラメータ:
handler - データプロパティハンドラ
メソッドの詳細

getDAO

public Object getDAO(String application,
                     String key,
                     String connect)
              throws DataPropertyException,
                     DataConnectorException,
                     DAOException,
                     DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

commit

public void commit()
            throws DataConnectException
すべてのデータコネクタをコミットします。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.commit()を順に呼び出すことで簡易的なトランザクションを実現しています。 そのため、複数のデータベースにアクセスしたトランザクションの場合は2-Phaseコミットほど堅牢なトランザクションにはならない場合があります。

例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
すべてのデータコネクタをロールバックします。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.rollback()を順に呼び出すことで簡易的なトランザクションを実現しています。 そのため、複数のデータベースにアクセスしたトランザクションの場合は2-Phaseコミットほど堅牢なトランザクションにはならない場合があります。

例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
すべてのデータストアの資源を解放します。 このメソッドはこのクラスのgetDAO(String, String, String)で取得されたDAOに関連するデータコネクタのDataConnector.release()を順に呼び出しています。

例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataAccessException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataAccessException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataAccessException
すべての実装インタフェース:
Serializable
public class DataAccessException
extends SystemException

データアクセス時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataAccessException()
詳細メッセージを指定しないで DataAccessException を構築します。
DataAccessException(String msg)
指定された詳細メッセージを持つ DataAccessException を構築します。
DataAccessException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataAccessException

public DataAccessException()
詳細メッセージを指定しないで DataAccessException を構築します。

DataAccessException

public DataAccessException(String msg)
指定された詳細メッセージを持つ DataAccessException を構築します。

パラメータ:
msg - 詳細メッセージ

DataAccessException

public DataAccessException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataConnectException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataConnectException
すべての実装インタフェース:
Serializable
public class DataConnectException
extends SystemException

データ接続に関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataConnectException()
詳細メッセージを指定しないで DataConnectException を構築します。
DataConnectException(String msg)
指定された詳細メッセージを持つ DataConnectException を構築します。
DataConnectException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataConnectException

public DataConnectException()
詳細メッセージを指定しないで DataConnectException を構築します。

DataConnectException

public DataConnectException(String msg)
指定された詳細メッセージを持つ DataConnectException を構築します。

パラメータ:
msg - 詳細メッセージ

DataConnectException

public DataConnectException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataConnector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
直系の既知のサブクラス:
DBConnector, IntramartDBConnector, IntramartFileServerConnector, LoginGroupDBConnector, SystemDBConnector
public abstract class DataConnector
extends Object

データストアに接続するコネクタです。

バージョン:
1.0

コンストラクタの概要
DataConnector()
新規のDataConnectorを生成します。
メソッドの概要
abstract void | commit() コミットします。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
protected abstract Object | getResource(String key, String connect, String resource) リソースを取得します。
abstract void | release() データストアの資源を解放します。
abstract void | rollback() ロールバックします。
void | setDataPropertyHandler(DataPropertyHandler handler) データプロパティハンドラを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DataConnector

public DataConnector()
新規のDataConnectorを生成します。

メソッドの詳細

setDataPropertyHandler

public void setDataPropertyHandler(DataPropertyHandler handler)
データプロパティハンドラを設定します。

パラメータ:
handler - データプロパティハンドラ

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ

getResource

protected abstract Object getResource(String key,
                                      String connect,
                                      String resource)
                               throws DataPropertyException,
                                      DataConnectException
リソースを取得します。

パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

commit

public abstract void commit()
                     throws DataConnectException
コミットします。

例外:
DataConnectException - コミットに失敗

rollback

public abstract void rollback()
                       throws DataConnectException
ロールバックします。

例外:
DataConnectException - ロールバックに失敗

release

public abstract void release()
                      throws DataConnectException
データストアの資源を解放します。

例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataConnectorException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataConnectorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataConnectorException
すべての実装インタフェース:
Serializable
public class DataConnectorException
extends SystemException

データコネクタ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataConnectorException()
詳細メッセージを指定しないで DataConnectorException を構築します。
DataConnectorException(String msg)
指定された詳細メッセージを持つ DataConnectorException を構築します。
DataConnectorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataConnectorException

public DataConnectorException()
詳細メッセージを指定しないで DataConnectorException を構築します。

DataConnectorException

public DataConnectorException(String msg)
指定された詳細メッセージを持つ DataConnectorException を構築します。

パラメータ:
msg - 詳細メッセージ

DataConnectorException

public DataConnectorException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataManager
public class DataManager
extends Object

データストアとの接続を管理します。

バージョン:
1.0

フィールドの概要
static String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー
コンストラクタの概要
protected DataManager()
データマネージャを生成するコンストラクタです。
メソッドの概要
DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
static DataManager | getDataManager() データマネージャを取得します。
DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DATA_PROPERTY_HANDLER_KEY

public static final String DATA_PROPERTY_HANDLER_KEY
データプロパティハンドラのキー

関連項目:
定数フィールド値
コンストラクタの詳細

DataManager

protected DataManager()
               throws DataManagerException
データマネージャを生成するコンストラクタです。 このコンストラクタは明示的に呼び出すことはできません。

例外:
DataManagerException - データマネージャの生成に失敗した
メソッドの詳細

getDataManager

public static DataManager getDataManager()
                                  throws DataManagerException
データマネージャを取得します。

戻り値:
データマネージャ
例外:
DataManagerException - データマネージャの設定に失敗した

getDataAccessController

public DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

戻り値:
データアクセスコントローラ

getDataPropertyHandler

public DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

戻り値:
データプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataManagerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataManagerException
すべての実装インタフェース:
Serializable
public class DataManagerException
extends SystemException

データマネージャの設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataManagerException()
詳細メッセージを指定しないで DataManagerException を構築します。
DataManagerException(String msg)
指定された詳細メッセージを持つ DataManagerException を構築します。
DataManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataManagerException

public DataManagerException()
詳細メッセージを指定しないで DataManagerException を構築します。

DataManagerException

public DataManagerException(String msg)
指定された詳細メッセージを持つ DataManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

DataManagerException

public DataManagerException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataPropertyException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.data.DataPropertyException
すべての実装インタフェース:
Serializable
public class DataPropertyException
extends SystemException

データプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
DataPropertyException()
詳細メッセージを指定しないで DataPropertyException を構築します。
DataPropertyException(String msg)
指定された詳細メッセージを持つ DataPropertyException を構築します。
DataPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DataPropertyException

public DataPropertyException()
詳細メッセージを指定しないで DataPropertyException を構築します。

DataPropertyException

public DataPropertyException(String msg)
指定された詳細メッセージを持つ DataPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

DataPropertyException

public DataPropertyException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
インタフェース DataPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultDataPropertyHandler, DistributesDataPropertyHandler, TextFileDataPropertyHandler, XmlDataPropertyHandler
public interface DataPropertyHandler
extends PropertyHandler

DAOの設定情報に接続するクラスです。

バージョン:
1.0

メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DataSourceConnector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DataSourceConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
            拡張 jp.co.intra_mart.framework.base.data.DataSourceConnector
public class DataSourceConnector
extends DBConnector

DataSourceに関連するデータコネクタです。 このデータコネクタはJava Transaction API(JTA)のUserTransactionの中で使うことが前提となっています。 また、KEY_JNDI_NAMEで指定されるパラメータにDataSourceのJNDI名を必ず指定してください。

バージョン:
1.0

フィールドの概要
static String KEY_JNDI_NAME
DataSourceのJNDI名のキー
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したフィールド
resources
コンストラクタの概要
DataSourceConnector()
DataSourceConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
protected Connection | putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したメソッド
getConnection, getResource
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_JNDI_NAME

public static final String KEY_JNDI_NAME
DataSourceのJNDI名のキー

関連項目:
定数フィールド値
コンストラクタの詳細

DataSourceConnector

public DataSourceConnector()
DataSourceConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

オーバーライド:
クラス DBConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

オーバーライド:
クラス DBConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

オーバーライド:
クラス DBConnector 内の release
例外:
DataConnectException - 資源開放に失敗

putResource

protected Connection putResource(String resource,
                                 ResourceParam[] params)
                          throws DataConnectException
接続先のリソースを追加します。

定義:
クラス DBConnector 内の putResource
パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
コネクション
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DBConnector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
直系の既知のサブクラス:
DataSourceConnector, JDBCConnector
public abstract class DBConnector
extends DataConnector

データベースに対するコネクタです。

バージョン:
1.0

フィールドの概要
protected  Map resources
リソース一覧
コンストラクタの概要
DBConnector()
DBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String resource) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
protected abstract Connection | putResource(String resource, ResourceParam[] params) 接続先のリソースを追加します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

resources

protected Map resources
リソース一覧

コンストラクタの詳細

DBConnector

public DBConnector()
DBConnectorを新規に生成します。

メソッドの詳細

putResource

protected abstract Connection putResource(String resource,
                                          ResourceParam[] params)
                                   throws DataConnectException
接続先のリソースを追加します。

パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
コネクション
例外:
DataConnectException - 接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getConnection

public Connection getConnection(String resource)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
resource - リソース名
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗 実際にはこのクラスではこのメソッドは何もしません。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DBDAO (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DBDAO
すべての実装インタフェース:
DAO
public abstract class DBDAO
extends Object
implements DAO

データベースに特化したDAOです。

バージョン:
1.0

コンストラクタの概要
DBDAO()
デフォルトのコンストラクタ
メソッドの概要
protected Connection | getConnection() このDAOに関連づけられたコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBDAO

public DBDAO()
デフォルトのコンストラクタ

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

protected Connection getConnection()
                            throws DataConnectException,
                                   DataPropertyException
このDAOに関連づけられたコネクションを取得します。

戻り値:
コネクション
例外:
DataConnectException - コネクションの取得に失敗
DataPropertyException - データプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultDataPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DefaultDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class DefaultDataPropertyHandler
extends Object
implements DataPropertyHandler

デフォルトのデータプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」です。また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「プレフィックス_アプリケーションID.properties」が優先されます。該当するプロパティが見つからない場合、引き続いて「プレフィックス.properties」を検索します。
プロパティの設定内容は以下のとおりです。

キー | 内容 | 共通 | アプリケーション毎
dao.class.キー.接続名 | キーと接続名に対応するDAOのクラス名 | × | ○
dao.class.キー | キーに対応するデフォルトのDAOのクラス名 | × | ○
dao.connector.キー.接続名 | キーと接続名に対応するDAOのデータコネクタ名 | × | ○
dao.connector.キー | キーに対応するデフォルトのDAOのデータコネクタ名 | × | ○
connector.class.データコネクタ名 | データコネクタ名に対応するデータコネクタのクラス名 | ○ | ×
connector.resource.データコネクタ名 | データコネクタ名に対応するデータコネクタのリソース名 | ○ | ×
resource.param.リソース名.パラメータ名 | リソース名に対応するリソースのパラメータの値 | ○ | ×

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultDataPropertyHandler

public DefaultDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DistributesDataPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス DistributesDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class DistributesDataPropertyHandler
extends Object
implements DataPropertyHandler

アプリケーション毎のプロパティハンドラを呼び出します。
プロパティファイルはアプリケーション毎に分割されます。
この場合のファイル名は「プレフィックス_アプリケーションID.properties」、「プレフィックス_アプリケーションID.xml」です。
また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION プロパティファイルのアプリケーションのパラメータ名
static String | PARAM_APPLICATION_CLASS プロパティファイルのクラスのパラメータ名
static String | PARAM_APPLICATION_PARAM プロパティファイルのパラメータのパラメータ名
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT プロパティファイルのデフォルトのパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
DistributesDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
プロパティファイルのデフォルトのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
プロパティファイルのアプリケーションのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
プロパティファイルのパラメータのパラメータ名

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
プロパティファイルのクラスのパラメータ名

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesDataPropertyHandler

public DistributesDataPropertyHandler()
DefaultDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartDBConnector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.IntramartDBConnector
推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。

public class IntramartDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。

バージョン:
1.0

フィールドの概要
protected  Map connections
推奨されていません。 DbsConnectionの一覧
コンストラクタの概要
IntramartDBConnector()
推奨されていません。 IntramartDBConnectorを新規に生成します。
メソッドの概要
void | commit() 推奨されていません。 コミットします。
jp.co.intra_mart.foundation.database.DbsConnection | getConnection(String connect) 推奨されていません。 データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) 推奨されていません。 リソースを取得します。
void | release() 推奨されていません。 データストアの資源を解放します。
void | rollback() 推奨されていません。 ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
推奨されていません。
DbsConnectionの一覧

コンストラクタの詳細

IntramartDBConnector

public IntramartDBConnector()
推奨されていません。
IntramartDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
推奨されていません。
コミットします。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
推奨されていません。
ロールバックします。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
推奨されていません。
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
推奨されていません。
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getConnection

public jp.co.intra_mart.foundation.database.DbsConnection getConnection(String connect)
                                                                 throws DataPropertyException,
                                                                        DataConnectException
推奨されていません。
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartDBDAO (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.IntramartDBDAO
すべての実装インタフェース:
DAO
推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。

public class IntramartDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 イントラマートで設定されたDBへアクセスするDAOを作る場合、このクラスをextendsします。

バージョン:
1.0

コンストラクタの概要
IntramartDBDAO()
推奨されていません。 IntramartDBDAOを新規に生成します。
メソッドの概要
jp.co.intra_mart.foundation.database.DbsConnection | getConnection() 推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) 推奨されていません。 データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartDBDAO

public IntramartDBDAO()
推奨されていません。
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
推奨されていません。
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public jp.co.intra_mart.foundation.database.DbsConnection getConnection()
                                                                 throws DataConnectException,
                                                                        DataPropertyException
推奨されていません。
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartFileServerConnector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartFileServerConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
public class IntramartFileServerConnector
extends DataConnector

intra-martのStorageサービスに接続するデータコネクタです。 Storageサービスに対する各種のオペレーションは呼び出し終了時に書き込み等が完了するため、 実際にはトランザクションの対象とならないため注意が必要です。

導入されたバージョン:
3.2

フィールドの概要
protected  Map resources
リソース一覧
コンストラクタの概要
IntramartFileServerConnector()
IntramartFileServerConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
jp.co.intra_mart.foundation.service.client.file.NetworkFile | getNetworkFile(String path) Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

resources

protected Map resources
リソース一覧

コンストラクタの詳細

IntramartFileServerConnector

public IntramartFileServerConnector()
IntramartFileServerConnectorを新規に生成します。

メソッドの詳細

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataPropertyException,
                             DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗

getNetworkFile

public jp.co.intra_mart.foundation.service.client.file.NetworkFile getNetworkFile(String path)
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。

パラメータ:
path - Storageサービス上のパス
戻り値:
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFile

commit

public void commit()
            throws DataConnectException
コミットします。 注意:実際にはNetworkFileの各種のメソッド完了時に書き込み等が行われています。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 注意:実際にはNetworkFileの各種のメソッド完了時に書き込み等が行われているため、既にファイルに書き込んだ情報は元に戻りません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartFileServerDAO (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス IntramartFileServerDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.IntramartFileServerDAO
すべての実装インタフェース:
DAO
public class IntramartFileServerDAO
extends Object
implements DAO

intra-martのStorageサービスを使用する場合のDAOです。

導入されたバージョン:
3.2

コンストラクタの概要
IntramartFileServerDAO()
IntramartFileServerDAOを新規に生成します。
メソッドの概要
protected jp.co.intra_mart.foundation.service.client.file.NetworkFile | getNetworkFile(String path) パスに該当するNetworkFileを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartFileServerDAO

public IntramartFileServerDAO()
IntramartFileServerDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getNetworkFile

protected jp.co.intra_mart.foundation.service.client.file.NetworkFile getNetworkFile(String path)
                                                                              throws DataConnectorException
パスに該当するNetworkFileを取得します。

パラメータ:
path - intra-martStorageサービス上のファイルパス
戻り値:
パスに該当するNetworkFile
例外:
DataConnectorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


JDBCConnector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス JDBCConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.DBConnector
            拡張 jp.co.intra_mart.framework.base.data.JDBCConnector
推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。

public class JDBCConnector
extends DBConnector

JDBCを利用するデータコネクタです。

バージョン:
1.0
関連項目:
DataSourceConnector

フィールドの概要
static String | KEY_DRIVER 推奨されていません。 データベースドライバのキー
static String | KEY_PASSWORD 推奨されていません。 データベース接続ユーザパスワードのキー
static String | KEY_URL 推奨されていません。 データベースURLのキー
static String | KEY_USERNAME 推奨されていません。 データベース接続ユーザ名のキー
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したフィールド
resources
コンストラクタの概要
JDBCConnector()
推奨されていません。 新規のJDBCConnectorを生成します。
メソッドの概要
void | commit() 推奨されていません。 コミットします。
protected Connection | putResource(String resource, ResourceParam[] params) 推奨されていません。 接続先のリソースを追加します。
void | release() 推奨されていません。 データストアの資源を解放します。
void | rollback() 推奨されていません。 ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DBConnector から継承したメソッド
getConnection, getResource
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY_DRIVER

public static final String KEY_DRIVER
推奨されていません。
データベースドライバのキー

関連項目:
定数フィールド値

KEY_URL

public static final String KEY_URL
推奨されていません。
データベースURLのキー

関連項目:
定数フィールド値

KEY_USERNAME

public static final String KEY_USERNAME
推奨されていません。
データベース接続ユーザ名のキー

関連項目:
定数フィールド値

KEY_PASSWORD

public static final String KEY_PASSWORD
推奨されていません。
データベース接続ユーザパスワードのキー

関連項目:
定数フィールド値
コンストラクタの詳細

JDBCConnector

public JDBCConnector()
推奨されていません。
新規のJDBCConnectorを生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
推奨されていません。
コミットします。

オーバーライド:
クラス DBConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
推奨されていません。
ロールバックします。

オーバーライド:
クラス DBConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
推奨されていません。
データストアの資源を解放します。

オーバーライド:
クラス DBConnector 内の release
例外:
DataConnectException - 資源開放に失敗

putResource

protected Connection putResource(String resource,
                                 ResourceParam[] params)
                          throws DataConnectException
推奨されていません。
接続先のリソースを追加します。

定義:
クラス DBConnector 内の putResource
パラメータ:
resource - リソース
params - リソースのパラメータ
戻り値:
リソース
例外:
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LoginGroupDBConnector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス LoginGroupDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
public class LoginGroupDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。
ログイングループIDからコネクションを取得します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
protected  Map connections
リソース一覧
コンストラクタの概要
LoginGroupDBConnector()
LoginGroupDBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String connect) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
リソース一覧

コンストラクタの詳細

LoginGroupDBConnector

public LoginGroupDBConnector()
LoginGroupDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getConnection

public Connection getConnection(String connect)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LoginGroupDBDAO (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス LoginGroupDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.LoginGroupDBDAO
すべての実装インタフェース:
DAO
public class LoginGroupDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 ログイングループIDをキーとしてDBへアクセスするDAOを作る場合、このクラスをextendsします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
LoginGroupDBDAO()
IntramartDBDAOを新規に生成します。
メソッドの概要
Connection | getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroupDBDAO

public LoginGroupDBDAO()
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public Connection getConnection()
                         throws DataConnectException,
                                DataPropertyException
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.data (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.data
インタフェース
DAO
DataPropertyHandler
クラス
ConnectorModel
DAOAdapter
DaoModel
DataAccessController
DataConnector
DataManager
DataSourceConnector
DBConnector
DBDAO
DefaultDataPropertyHandler
DistributesDataPropertyHandler
IntramartDBConnector
IntramartDBDAO
IntramartFileServerConnector
IntramartFileServerDAO
JDBCConnector
LoginGroupDBConnector
LoginGroupDBDAO
ResourceModel
ResourceParam
SystemDBConnector
SystemDBDAO
TextFileDataPropertyHandler
XmlDataPropertyHandler
例外
DAOException
DataAccessException
DataConnectException
DataConnectorException
DataManagerException
DataPropertyException


jp.co.intra_mart.framework.base.data (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data

データアクセスに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
DAO | データリソースにアクセスするインタフェースです。
DataPropertyHandler | DAOの設定情報に接続するクラスです。

クラスの概要
ConnectorModel | コネクタ情報を管理するクラスです。
DAOAdapter | DAOのすべてのメソッドを何もしないように実装したクラスです。
DaoModel | DaoModelを管理するクラスです。
DataAccessController | データアクセスを制御します。
DataConnector | データストアに接続するコネクタです。
DataManager | データストアとの接続を管理します。
DataSourceConnector | DataSourceに関連するデータコネクタです。
DBConnector | データベースに対するコネクタです。
DBDAO | データベースに特化したDAOです。
DefaultDataPropertyHandler | デフォルトのデータプロパティハンドラです。
DistributesDataPropertyHandler | アプリケーション毎のプロパティハンドラを呼び出します。
IntramartDBConnector | 推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
IntramartDBDAO | 推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
IntramartFileServerConnector | intra-martのStorageサービスに接続するデータコネクタです。
IntramartFileServerDAO | intra-martのStorageサービスを使用する場合のDAOです。
JDBCConnector | 推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
LoginGroupDBConnector | イントラマートで設定されているDBコネクションです。
LoginGroupDBDAO | イントラマートで設定されたDBへアクセスするDAOです。
ResourceModel | Resource情報を管理するクラスです。
ResourceParam | データコネクタの初期パラメータです。
SystemDBConnector | イントラマートで設定されているDBコネクションです。
SystemDBDAO | イントラマートで設定されたDBへアクセスするDAOです。
TextFileDataPropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
XmlDataPropertyHandler | XMLのデータプロパティハンドラです。

例外の概要
DAOException | リソースコネクタの情報取得時の例外です。
DataAccessException | データアクセス時の例外です。
DataConnectException | データ接続に関連する例外です。
DataConnectorException | データコネクタ取得時の例外です。
DataManagerException | データマネージャの設定時の例外です。
DataPropertyException | データプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.data の説明

データアクセスに関連するクラスのパッケージです。 EIS層（データベース、基幹システムなど）にアクセスするためのクラスがあります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.data クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.ConnectorModel
    • class jp.co.intra_mart.framework.base.data.DAOAdapter (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DaoModel
    • class jp.co.intra_mart.framework.base.data.DataAccessController
    • class jp.co.intra_mart.framework.base.data.DataConnector
      • class jp.co.intra_mart.framework.base.data.DBConnector
        • class jp.co.intra_mart.framework.base.data.DataSourceConnector
        • class jp.co.intra_mart.framework.base.data.JDBCConnector
      • class jp.co.intra_mart.framework.base.data.IntramartDBConnector
      • class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
      • class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
      • class jp.co.intra_mart.framework.base.data.SystemDBConnector
    • class jp.co.intra_mart.framework.base.data.DataManager
    • class jp.co.intra_mart.framework.base.data.DBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.IntramartDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.data.ResourceParam
    • class jp.co.intra_mart.framework.base.data.ResourceModel
    • class jp.co.intra_mart.framework.base.data.SystemDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.data.DAOException
            • class jp.co.intra_mart.framework.base.data.DataAccessException
            • class jp.co.intra_mart.framework.base.data.DataConnectException
            • class jp.co.intra_mart.framework.base.data.DataConnectorException
            • class jp.co.intra_mart.framework.base.data.DataManagerException
            • class jp.co.intra_mart.framework.base.data.DataPropertyException
    • class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.base.data.DAO
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.data.DataPropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.data の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.data の使用

jp.co.intra_mart.framework.base.data を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.base.data のクラス
DAO
データリソースにアクセスするインタフェースです。
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnector
データストアに接続するコネクタです。
DataConnectorException
データコネクタ取得時の例外です。
DataManager
データストアとの接続を管理します。
DataManagerException
データマネージャの設定時の例外です。
DataPropertyException
データプロパティ取得時の例外です。
DataPropertyHandler
DAOの設定情報に接続するクラスです。
DBConnector
データベースに対するコネクタです。
ResourceParam
データコネクタの初期パラメータです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.data のクラス
DAOException
リソースコネクタの情報取得時の例外です。
DataAccessController
データアクセスを制御します。
DataConnectException
データ接続に関連する例外です。
DataConnectorException
データコネクタ取得時の例外です。
DataPropertyException
データプロパティ取得時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ResourceModel (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ResourceModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.ResourceModel
public class ResourceModel
extends Object

Resource情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
static String | P_ID_RESOURCE_NAME
static String | P_ID_RESOURCE_PARAM
コンストラクタの概要
ResourceModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_RESOURCE_NAME

public static final String P_ID_RESOURCE_NAME
関連項目:
定数フィールド値

P_ID_RESOURCE_PARAM

public static final String P_ID_RESOURCE_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

ResourceModel

public ResourceModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ResourceParam (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス ResourceParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.data.ResourceParam
public class ResourceParam
extends PropertyParam

データコネクタの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
ResourceParam()
ResourceParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResourceParam

public ResourceParam()
ResourceParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SystemDBConnector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス SystemDBConnector

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataConnector
        拡張 jp.co.intra_mart.framework.base.data.SystemDBConnector
public class SystemDBConnector
extends DataConnector

イントラマートで設定されているDBコネクションです。
システムに設定されている情報からコネクションを取得します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
protected  Map connections
リソース一覧
コンストラクタの概要
SystemDBConnector()
SystemDBConnectorを新規に生成します。
メソッドの概要
void | commit() コミットします。
Connection | getConnection(String connect) データベースへのコネクションを取得します。
protected Object | getResource(String key, String connect, String resource) リソースを取得します。
void | release() データストアの資源を解放します。
void | rollback() ロールバックします。
クラス jp.co.intra_mart.framework.base.data.DataConnector から継承したメソッド
getDataPropertyHandler, setDataPropertyHandler
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connections

protected Map connections
リソース一覧

コンストラクタの詳細

SystemDBConnector

public SystemDBConnector()
SystemDBConnectorを新規に生成します。

メソッドの詳細

commit

public void commit()
            throws DataConnectException
コミットします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の commit
例外:
DataConnectException - コミットに失敗

rollback

public void rollback()
              throws DataConnectException
ロールバックします。 実際にはこのクラスではこのメソッドは何もしません。

定義:
クラス DataConnector 内の rollback
例外:
DataConnectException - ロールバックに失敗

release

public void release()
             throws DataConnectException
データストアの資源を解放します。

定義:
クラス DataConnector 内の release
例外:
DataConnectException - 資源開放に失敗

getConnection

public Connection getConnection(String connect)
                         throws DataPropertyException,
                                DataConnectException
データベースへのコネクションを取得します。

パラメータ:
connect - 接続情報
戻り値:
データベースへのコネクション
例外:
DataPropertyException - データベースへのコネクションの取得に失敗
DataConnectException - データベースへの接続に失敗

getResource

protected Object getResource(String key,
                             String connect,
                             String resource)
                      throws DataConnectException
リソースを取得します。

定義:
クラス DataConnector 内の getResource
パラメータ:
key - キー
connect - 接続情報
resource - リソース名
戻り値:
リソース
例外:
DataPropertyException - リソースの取得に失敗
DataConnectException - 接続に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SystemDBDAO (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス SystemDBDAO

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.SystemDBDAO
すべての実装インタフェース:
DAO
public class SystemDBDAO
extends Object
implements DAO

イントラマートで設定されたDBへアクセスするDAOです。 システム登録されているIDをキーとしてDBへアクセスするDAOを作る場合、このクラスをextendsします。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
SystemDBDAO()
IntramartDBDAOを新規に生成します。
メソッドの概要
Connection | getConnection() イントラマートで設定されているDBへのコネクションを取得します。
void | setConnectInfo(DataConnector connector, String resource, String key, String connect) データリソースに接続する時の情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SystemDBDAO

public SystemDBDAO()
IntramartDBDAOを新規に生成します。

メソッドの詳細

setConnectInfo

public void setConnectInfo(DataConnector connector,
                           String resource,
                           String key,
                           String connect)
                    throws DataConnectException
データリソースに接続する時の情報を設定します。

定義:
インタフェース DAO 内の setConnectInfo
パラメータ:
connector - データコネクタ
resource - リソース
key - キー
connect - 接続情報
例外:
DataConnectException - 接続に失敗

getConnection

public Connection getConnection()
                         throws DataConnectException,
                                DataPropertyException
イントラマートで設定されているDBへのコネクションを取得します。

戻り値:
イントラマートで設定されているDBへのコネクション
例外:
DataConnectException - データベース接続時に例外が発生
DataPropertyException - データプロパティ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


TextFileDataPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス TextFileDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class TextFileDataPropertyHandler
extends Object
implements DataPropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultDataPropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileDataPropertyHandler()
TextFileDataPropertyHandlerを新規に生成します。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileDataPropertyHandler

public TextFileDataPropertyHandler()
TextFileDataPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


XmlDataPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.data
クラス XmlDataPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler
すべての実装インタフェース:
DataPropertyHandler, PropertyHandler
public class XmlDataPropertyHandler
extends Object
implements DataPropertyHandler

XMLのデータプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.xml」です。また、アプリケーションに依存しない「プレフィックス.properties」があります。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにDataManager.DATA_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのXMLファイル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM XMLファイル名のパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
コンストラクタの概要
XmlDataPropertyHandler()
コンストラクタです。
メソッドの概要
String | getConnectorClassName(String connectorName) データコネクタのクラス名を取得します。
String | getConnectorName(String application, String key, String connect) DAOに対するデータコネクタ名を取得します。
String | getConnectorResource(String connectorName) データコネクタのリソース名を取得します。
String | getDAOName(String application, String key, String connect) DAOのクラス名を取得します。
ResourceParam[] | getResourceParams(String name) リソースのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのXMLファイル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
XMLファイル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlDataPropertyHandler

public XmlDataPropertyHandler()
コンストラクタです。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws DataPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース DataPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
DataPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getDAOName

public String getDAOName(String application,
                         String key,
                         String connect)
                  throws DataPropertyException
DAOのクラス名を取得します。 application、keyとconnectで指定されたDAOのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getDAOName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOのクラス名
例外:
DataPropertyException - DAOのクラス名の取得に失敗

getConnectorName

public String getConnectorName(String application,
                               String key,
                               String connect)
                        throws DataPropertyException
DAOに対するデータコネクタ名を取得します。 application、keyとconnectで指定されたDAOのデータコネクタ名を取得します。 対応するデータコネクタ名が指定されていない場合、nullが返ります。

定義:
インタフェース DataPropertyHandler 内の getConnectorName
パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
データコネクタの名前
例外:
DataPropertyException - データコネクタ名の取得時に例外が発生

getConnectorClassName

public String getConnectorClassName(String connectorName)
                             throws DataPropertyException
データコネクタのクラス名を取得します。 application、keyとconnectで指定されたデータコネクタのクラス名を取得します。

定義:
インタフェース DataPropertyHandler 内の getConnectorClassName
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのクラス名
例外:
DataPropertyException - データコネクタのクラス名の取得に失敗

getConnectorResource

public String getConnectorResource(String connectorName)
                            throws DataPropertyException
データコネクタのリソース名を取得します。 application、keyとconnectで指定されたデータコネクタのリソース名を取得します。 対応するリソース名がない場合、nullを返します。

定義:
インタフェース DataPropertyHandler 内の getConnectorResource
パラメータ:
connectorName - データコネクタ名
戻り値:
データコネクタのリソース名
例外:
DataPropertyException - データコネクタのリソース名の取得時に例外が発生

getResourceParams

public ResourceParam[] getResourceParams(String name)
                                  throws DataPropertyException
リソースのパラメータを取得します。 nameで指定されたリソースのパラメータを取得します。

定義:
インタフェース DataPropertyHandler 内の getResourceParams
パラメータ:
name - リソース名
戻り値:
リソースのパラメータ
例外:
DataPropertyException - リソースのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EJBEventListener の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListener の使用

EJBEventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListener の使用

jp.co.intra_mart.framework.base.event での EJBEventListener のサブクラス
class | GenericEJBEventListener EJBを利用する汎用的なイベントリスナです。
class | GenericEJBEventListenerLocal ローカルEJBを利用する汎用的なイベントリスナです。
class | StandardEJBEventListener StandardEJBEventListenerAgentに接続するイベントリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の使用

EJBEventListenerAgentBean を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event での EJBEventListenerAgentBean のサブクラス
class | GenericEJBEventListenerAgentBean EJBを利用する汎用的なイベントリスナーのBeanです。
class | StandardEJBEventListenerAgentBean EJBを利用する場合の抽象的なイベントリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の使用

EJBEventListenerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event での EJBEventListenerFactory のサブクラス
class | GenericEJBEventListenerFactory GenericEJBEventListenerを生成します。
class | GenericEJBEventListenerLocalFactory GenericEJBEventListnerLocalを新規に生成します。
class | StandardEJBEventListenerFactory 標準的なEJB用のイベントリスナファクトリです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EmptyEvent の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EmptyEvent の使用

jp.co.intra_mart.framework.base.event.EmptyEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.Event の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.Event の使用

Event を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での Event の使用

jp.co.intra_mart.framework.base.event での Event のサブクラス
 class EmptyEvent
情報を何も持たないイベントです。

Event を返す jp.co.intra_mart.framework.base.event のメソッド
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.service での Event の使用

Event を返す jp.co.intra_mart.framework.base.service のメソッド
protected  Event ServiceControllerAdapter.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での Event の使用

Event を返す jp.co.intra_mart.framework.base.web.bean のメソッド
protected  Event HelperBean.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation.view での Event の使用

Event を返す jp.co.intra_mart.framework.presentation.view のメソッド
protected  Event AbstractViewConverter.createEvent(RequestInfo info, String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

Event 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
protected  EventResult AbstractViewConverter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventException の使用

EventException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected  EventResult StandardEventListener.dispatchEvent(Event event)
イベント処理を実行します。
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
 EventResult EventManager.dispatch(Event event)
イベントに対する処理を実行します。
 EventResult EventManager.dispatch(Event event, boolean transaction)
イベントに対する処理を実行します。
protected  EventResult EJBEventListenerAgentBean.dispatchEvent(Event event)
イベント処理を実行します。
protected  EventResult EJBEventListener.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.service での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での EventException の使用

EventException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation.view での EventException の使用

EventException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
protected  EventResult AbstractViewConverter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventFactoryModel の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventFactoryModel の使用

jp.co.intra_mart.framework.base.event.EventFactoryModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventGroupModel の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventGroupModel の使用

jp.co.intra_mart.framework.base.event.EventGroupModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.EventListener の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListener の使用

EventListener を実装している jp.co.intra_mart.framework.base.event のクラス
class | EJBEventListener EJBを利用する場合のイベントリスナです。
class | GenericEJBEventListener EJBを利用する汎用的なイベントリスナです。
class | GenericEJBEventListenerLocal ローカルEJBを利用する汎用的なイベントリスナです。
class | GenericEventListener 汎用的なイベントリスナです。
class | StandardEJBEventListener StandardEJBEventListenerAgentに接続するイベントリスナです。
class | StandardEventListener 汎用的なビジネスロジック用のクラスです。

EventListener を返す jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventListenerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventListenerException の使用

EventListenerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerException の使用

EventListenerException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventListener | StandardEventListenerFactory.create(Event event) イベントリスナを生成します。
void | StandardEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | StandardEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
void | StandardEJBEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEventListenerFactory.create(Event event) イベントリスナを生成します。
void | GenericEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEJBEventListenerLocalFactory.create(Event event) イベントリスナを生成します。
void | GenericEJBEventListenerLocalFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | GenericEJBEventListenerFactory.create(Event event) イベントリスナを生成します。
void | GenericEJBEventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。
EventListener | EventListenerFactory.create(Event event) イベントリスナを生成します。
void | EventListenerFactory.initParam(String name, String value) 初期パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventListenerFactory の使用

EventListenerFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerFactory の使用

EventListenerFactory を実装している jp.co.intra_mart.framework.base.event のクラス
class | EJBEventListenerFactory EJBEventListenerFactoryを生成します。
class | GenericEJBEventListenerFactory GenericEJBEventListenerを生成します。
class | GenericEJBEventListenerLocalFactory GenericEJBEventListnerLocalを新規に生成します。
class | GenericEventListenerFactory GenericEventListenerを生成するイベントリスナファクトリです。
class | StandardEJBEventListenerFactory 標準的なEJB用のイベントリスナファクトリです。
class | StandardEventListenerFactory 通常のJavaクラスのイベントリスナを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventListenerFactoryParam の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventListenerFactoryParam の使用

EventListenerFactoryParam を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventListenerFactoryParam の使用

EventListenerFactoryParam を返す jp.co.intra_mart.framework.base.event のメソッド
EventListenerFactoryParam[] | XmlEventPropertyHandler.getEventListenerFactoryParams(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | TextFileEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | EventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | DistributesEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
EventListenerFactoryParam[] | DefaultEventPropertyHandler.getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventManager の使用

EventManager を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventManager の使用

EventManager を返す jp.co.intra_mart.framework.base.event のメソッド
static EventManager EventManager.getEventManager()
イベントマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventManagerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventManagerException の使用

EventManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.base.event のメソッド
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
static EventManager | EventManager.getEventManager() イベントマネージャを取得します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

EventManagerException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

jp.co.intra_mart.framework.base.service での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation.view での EventManagerException の使用

EventManagerException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
protected  EventResult AbstractViewConverter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventModelProducer の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventModelProducer の使用

jp.co.intra_mart.framework.base.event.EventModelProducer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventPropertyException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventPropertyException の使用

EventPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventPropertyException の使用

EventPropertyException をスローする jp.co.intra_mart.framework.base.event のメソッド
 boolean XmlEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String XmlEventPropertyHandler.getEventName(String application, String key)
アプリケーションIDとキーに該当するイベントのクラス名を取得します。
 String XmlEventPropertyHandler.getEventListenerFactoryName(String application, String key)
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] XmlEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection XmlEventPropertyHandler.getEventTriggerInfos(String application, String key)
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection XmlEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 String TextFileEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String TextFileEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] TextFileEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection TextFileEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection TextFileEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 boolean EventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String EventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String EventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] EventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection EventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection EventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。
 Event EventManager.createEvent(String application, String key, String loginUser, String loginGroup)
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
 boolean DistributesEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DistributesEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String DistributesEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] DistributesEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection DistributesEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection DistributesEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 boolean DefaultEventPropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DefaultEventPropertyHandler.getEventName(String application, String key)
キーに該当するイベントのクラス名を取得します。
 String DefaultEventPropertyHandler.getEventListenerFactoryName(String application, String key)
キーに該当するイベントリスナファクトリのクラス名を取得します。
 EventListenerFactoryParam[] DefaultEventPropertyHandler.getEventListenerFactoryParams(String application, String key)
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
 Collection DefaultEventPropertyHandler.getEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。
 Collection DefaultEventPropertyHandler.getPostEventTriggerInfos(String application, String key)
キーに該当するイベントのイベントトリガ情報をすべて取得します。

EventPropertyException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.EventPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventPropertyHandler の使用

EventPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventPropertyHandler の使用

EventPropertyHandler を実装している jp.co.intra_mart.framework.base.event のクラス
class | DefaultEventPropertyHandler デフォルトのEventPropertyHandlerです。
class | DistributesEventPropertyHandler アプリケーション毎のEventPropertyHandlerを呼び出します。
class | TextFileEventPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlEventPropertyHandler XMLのEventPropertyHandlerです。

EventPropertyHandler を返す jp.co.intra_mart.framework.base.event のメソッド
 EventPropertyHandler EventManager.getEventPropertyHandler()
イベントプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.EventResult の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventResult の使用

EventResult を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.service での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.service のメソッド
protected  EventResult ServiceControllerAdapter.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.base.web.bean での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation.view での EventResult の使用

EventResult を返す jp.co.intra_mart.framework.presentation.view のメソッド
protected  EventResult AbstractViewConverter.dispatchEvent(Event event)
イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.EventTrigger の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.EventTrigger の使用

EventTrigger を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventTrigger の使用

EventTrigger を実装している jp.co.intra_mart.framework.base.event のクラス
 class EventTriggerAdapter
DAOを取得するメソッドを持ったイベントトリガです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventTriggerAdapter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerAdapter の使用

jp.co.intra_mart.framework.base.event.EventTriggerAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventTriggerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerException の使用

EventTriggerException を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での EventTriggerException の使用

EventTriggerException をスローする jp.co.intra_mart.framework.base.event のコンストラクタ
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventTriggerInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerInfo の使用

jp.co.intra_mart.framework.base.event.EventTriggerInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.EventTriggerList の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.EventTriggerList の使用

jp.co.intra_mart.framework.base.event.EventTriggerList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListener の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListener の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent の使用

GenericEJBEventListenerAgent を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgent の使用

GenericEJBEventListenerAgent を返す jp.co.intra_mart.framework.base.event のメソッド
 GenericEJBEventListenerAgent GenericEJBEventListenerAgentHome.create()
リモートインタフェースGenericEJBEventListenerAgentを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome の使用

GenericEJBEventListenerAgentHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentHome の使用

GenericEJBEventListenerAgentHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
GenericEJBEventListener(GenericEJBEventListenerAgentHome home, String listenerName)
GenericEJBEventListenerを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal の使用

GenericEJBEventListenerAgentLocal を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentLocal の使用

GenericEJBEventListenerAgentLocal を返す jp.co.intra_mart.framework.base.event のメソッド
 GenericEJBEventListenerAgentLocal GenericEJBEventListenerAgentLocalHome.create()
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome の使用

GenericEJBEventListenerAgentLocalHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での GenericEJBEventListenerAgentLocalHome の使用

GenericEJBEventListenerAgentLocalHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home, String listenerName)
GenericEJBEventListnerLocalを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の使用

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.GenericEventListener の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEventListener の使用

jp.co.intra_mart.framework.base.event.GenericEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.GenericEventListenerFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.GenericEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.GenericEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListener の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListener の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent の使用

StandardEJBEventListenerAgent を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEJBEventListenerAgent の使用

StandardEJBEventListenerAgent を返す jp.co.intra_mart.framework.base.event のメソッド
 StandardEJBEventListenerAgent StandardEJBEventListenerAgentHome.create()
StandardEJBEventListenerAgentと接続します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome の使用

StandardEJBEventListenerAgentHome を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEJBEventListenerAgentHome の使用

StandardEJBEventListenerAgentHome 型のパラメータを持つ jp.co.intra_mart.framework.base.event のコンストラクタ
StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.StandardEventListener の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEventListener の使用

StandardEventListener を使用しているパッケージ
jp.co.intra_mart.framework.base.event イベントフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.event での StandardEventListener の使用

StandardEventListener 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
 void GenericEventListener.setListener(StandardEventListener listener)
イベント処理クラスを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.StandardEventListenerFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.StandardEventListenerFactory の使用

jp.co.intra_mart.framework.base.event.StandardEventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の使用

jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultEventPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス DefaultEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class DefaultEventPropertyHandler
extends Object
implements EventPropertyHandler

デフォルトのEventPropertyHandlerです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの設定内容は以下のとおりです。

キー | 内容
event.class.キー | キーに対応するEventのクラス名
factory.class.キー | キーに対応するEventListenerFactoryのクラス名
factory.param.キー.パラメータ名 | キーに対応するEventListenerFactoryのパラメータの値
trigger.class.キー.ソート番号[.pre] | キーに対応するEventTriggerのクラス名 複数指定した場合、トリガはソート番号の順番に処理されます。 このトリガは該当するイベントリスナが処理される前に起動します。
trigger.class.キー.ソート番号.post | キーに対応するEventTriggerのクラス名 複数指定した場合、トリガはソート番号の順番に処理されます。 このトリガは該当するイベントリスナが処理された後に起動します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultEventPropertyHandler

public DefaultEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DistributesEventPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス DistributesEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class DistributesEventPropertyHandler
extends Object
implements EventPropertyHandler

アプリケーション毎のEventPropertyHandlerを呼び出します。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.properties」、または「プレフィックス_アプリケーションID.xml」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION アプリケーション
static String | PARAM_APPLICATION_CLASS クラス
static String | PARAM_APPLICATION_PARAM パラメータ
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT デフォルト
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
DistributesEventPropertyHandler()
DistributesEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
デフォルト

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
アプリケーション

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
パラメータ

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
クラス

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesEventPropertyHandler

public DistributesEventPropertyHandler()
DistributesEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EJBEventListener (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
すべての実装インタフェース:
EventListener
直系の既知のサブクラス:
GenericEJBEventListener, GenericEJBEventListenerLocal, StandardEJBEventListener
public abstract class EJBEventListener
extends Object
implements EventListener

EJBを利用する場合のイベントリスナです。

バージョン:
1.0

コンストラクタの概要
EJBEventListener()
EJBEventListenerを新規に生成します。
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.event.EventListener から継承したメソッド
execute

コンストラクタの詳細

EJBEventListener

public EJBEventListener()
EJBEventListenerを新規に生成します。

メソッドの詳細

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。 このクラスでは実際には何も行いません。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EJBEventListenerAgentBean (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
直系の既知のサブクラス:
GenericEJBEventListenerAgentBean, StandardEJBEventListenerAgentBean
public abstract class EJBEventListenerAgentBean
extends Object
implements SessionBean

Session Beanを利用したイベントリスナの抽象クラスです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
protected  SessionContext sessionContext
セッションコンテキスト
コンストラクタの概要
EJBEventListenerAgentBean()
EJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
void | ejbActivate() "passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。
void | ejbPassivate() インスタンスが"passive"状態に移る前に呼ばれるメソッドです。
void | ejbRemove() Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。
void | setSessionContext(SessionContext sessionContext) 関連するSessionContextを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

sessionContext

protected SessionContext sessionContext
セッションコンテキスト

コンストラクタの詳細

EJBEventListenerAgentBean

public EJBEventListenerAgentBean()
EJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

setSessionContext

public void setSessionContext(SessionContext sessionContext)
関連するSessionContextを設定します。 コンテナはインスタンス生成後にこのメソッドを呼び出します。

定義:
インタフェース SessionBean 内の setSessionContext
パラメータ:
sessionContext - SessionContextインタフェース

ejbRemove

public void ejbRemove()
               throws EJBException
Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。

定義:
インタフェース SessionBean 内の ejbRemove
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

ejbActivate

public void ejbActivate()
                 throws EJBException
"passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。 ejbPassivate()メソッドで先にリリースされたすべてのリソースを再取得します。

定義:
インタフェース SessionBean 内の ejbActivate
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

ejbPassivate

public void ejbPassivate()
                  throws EJBException
インスタンスが"passive"状態に移る前に呼ばれるメソッドです。 ejbActivate()メソッドで再取得されるリソースをすべてリリースします。

定義:
インタフェース SessionBean 内の ejbPassivate
例外:
EJBException - システムレベルのエラー
RemoteException - EJB 1.0以前との互換性のための例外

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EJBEventListenerFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
直系の既知のサブクラス:
GenericEJBEventListenerFactory, GenericEJBEventListenerLocalFactory, StandardEJBEventListenerFactory
public abstract class EJBEventListenerFactory
extends Object
implements EventListenerFactory

EJBEventListenerFactoryを生成します。 イベントリスナファクトリの設定では、以下の初期パラメータの設定が必須です。

バージョン:
1.0

フィールドの概要
static String HOME_PARAM
ホームインタフェースを取得するときのJNDI名のパラメータ名
コンストラクタの概要
EJBEventListenerFactory()
EJBEventListenerFactoryを新規に生成します。
メソッドの概要
String | getJNDIName() EJBEventListenerAgentHomeのJNDI名を取得します。
protected void | setJNDIName(String jndiName) EJBEventListenerAgentHomeのJNDI名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory から継承したメソッド
create, initParam

フィールドの詳細

HOME_PARAM

public static final String HOME_PARAM
ホームインタフェースを取得するときのJNDI名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

EJBEventListenerFactory

public EJBEventListenerFactory()
EJBEventListenerFactoryを新規に生成します。

メソッドの詳細

setJNDIName

protected void setJNDIName(String jndiName)
EJBEventListenerAgentHomeのJNDI名を設定します。

パラメータ:
jndiName - EJBEventListenerAgentHomeのJNDI名

getJNDIName

public String getJNDIName()
EJBEventListenerAgentHomeのJNDI名を取得します。

戻り値:
EJBEventListenerAgentHomeのJNDI名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EmptyEvent (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EmptyEvent

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.Event
        拡張 jp.co.intra_mart.framework.base.event.EmptyEvent
すべての実装インタフェース:
Serializable
public class EmptyEvent
extends Event

情報を何も持たないイベントです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyEvent()
クラス jp.co.intra_mart.framework.base.event.Event から継承したメソッド
getApplication, getKey, getLoginGroup, getLoginGroupID, getLoginUser, getLoginUserID, getUserInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyEvent

public EmptyEvent()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Event (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス Event

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.Event
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EmptyEvent
public abstract class Event
extends Object
implements Serializable

処理を実行するための情報です。 処理はEventListenerで行われますが、その際に渡される情報をEventのサブクラスで定義します。 Eventのサブクラスを生成する場合はコンストラクタを使用せず、変わりにEventManager.createEvent(String, String, String, String)を使用してください。
注意：
このクラスのサブクラスでは以下のフィールドは定義しないでください。

  • applicationフィールド
  • keyフィールド
  • loginUserIDフィールド
  • loginGroupIDフィールド

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
Event()
イベントを新規に生成します。
メソッドの概要
String | getApplication() アプリケーションを取得します。
String | getKey() イベントキーを取得します。
String | getLoginGroup() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUser() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
UserInfo | getUserInfo() ログインユーザの情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Event

public Event()
イベントを新規に生成します。

メソッドの詳細

getKey

public final String getKey()
イベントキーを取得します。

戻り値:
イベントキー

getApplication

public final String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

getUserInfo

public UserInfo getUserInfo()
ログインユーザの情報を取得します。
ログインセッションが存在しない場合nullを返却します。

戻り値:
ログインユーザの情報
導入されたバージョン:
5.0

getLoginUser

public final String getLoginUser()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID

getLoginUserID

public final String getLoginUserID()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
導入されたバージョン:
3.2

getLoginGroup

public final String getLoginGroup()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID

getLoginGroupID

public final String getLoginGroupID()
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventException
すべての実装インタフェース:
Serializable
public class EventException
extends SystemException

イベント生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventException()
詳細メッセージを指定しないで EventException を構築します。
EventException(String msg)
指定された詳細メッセージを持つ EventException を構築します。
EventException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventException

public EventException()
詳細メッセージを指定しないで EventException を構築します。

EventException

public EventException(String msg)
指定された詳細メッセージを持つ EventException を構築します。

パラメータ:
msg - 詳細メッセージ

EventException

public EventException(String msg,
                      Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventFactoryModel (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventFactoryModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventFactoryModel
public class EventFactoryModel
extends Object

イベントリスナーファクトリー情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_FACTORY_CLASS
static String | P_ID_FACTORY_PARAM
static String | P_ID_PARAM_NAME
static String | P_ID_PARAM_VALUE
コンストラクタの概要
EventFactoryModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_FACTORY_CLASS

public static final String P_ID_FACTORY_CLASS
関連項目:
定数フィールド値

P_ID_FACTORY_PARAM

public static final String P_ID_FACTORY_PARAM
関連項目:
定数フィールド値

P_ID_PARAM_NAME

public static final String P_ID_PARAM_NAME
関連項目:
定数フィールド値

P_ID_PARAM_VALUE

public static final String P_ID_PARAM_VALUE
関連項目:
定数フィールド値
コンストラクタの詳細

EventFactoryModel

public EventFactoryModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventGroupModel (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventGroupModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventGroupModel
public class EventGroupModel
extends Object

Event情報を管理するクラスです。

バージョン:
1.0

フィールドの概要
static String | ID
static String | P_ID_EVENT_KEY
static String | P_ID_EVENT_NAME
static String | P_ID_POST_TRIGGER
static String | P_ID_PRE_TRIGGER
static String | P_ID_TRIGGER_CLASS
コンストラクタの概要
EventGroupModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID

public static final String ID
関連項目:
定数フィールド値

P_ID_EVENT_KEY

public static final String P_ID_EVENT_KEY
関連項目:
定数フィールド値

P_ID_EVENT_NAME

public static final String P_ID_EVENT_NAME
関連項目:
定数フィールド値

P_ID_PRE_TRIGGER

public static final String P_ID_PRE_TRIGGER
関連項目:
定数フィールド値

P_ID_POST_TRIGGER

public static final String P_ID_POST_TRIGGER
関連項目:
定数フィールド値

P_ID_TRIGGER_CLASS

public static final String P_ID_TRIGGER_CLASS
関連項目:
定数フィールド値
コンストラクタの詳細

EventGroupModel

public EventGroupModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventListener (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventListener

既知の実装クラスの一覧:
EJBEventListener, GenericEventListener, StandardEventListener
public interface EventListener

イベントリスナです。

バージョン:
1.0

メソッドの概要
EventResult | execute(Event event) 処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventListenerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventListenerException
すべての実装インタフェース:
Serializable
public class EventListenerException
extends SystemException

イベントリスナ生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventListenerException()
詳細メッセージを指定しないで EventListenerException を構築します。
EventListenerException(String msg)
指定された詳細メッセージを持つ EventListenerException を構築します。
EventListenerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventListenerException

public EventListenerException()
詳細メッセージを指定しないで EventListenerException を構築します。

EventListenerException

public EventListenerException(String msg)
指定された詳細メッセージを持つ EventListenerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventListenerException

public EventListenerException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventListenerFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventListenerFactory

既知の実装クラスの一覧:
EJBEventListenerFactory, GenericEventListenerFactory, StandardEventListenerFactory
public interface EventListenerFactory

イベントリスナを生成します。 EventListenerFactoryは生成するEventListenerの種別ごとに必要です。

バージョン:
1.0

メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventListenerFactoryParam (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventListenerFactoryParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
public class EventListenerFactoryParam
extends PropertyParam

イベントリスナファクトリの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
EventListenerFactoryParam()
EventListenerFactoryParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventListenerFactoryParam

public EventListenerFactoryParam()
EventListenerFactoryParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventManager
public class EventManager
extends Object

イベントマネージャです。

バージョン:
1.0

フィールドの概要
static String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー
メソッドの概要
Event | createEvent(String application, String key, String loginUser, String loginGroup) 推奨されていません。 このメソッドではなくcreateEvent(String, String, UserInfo)を使用してください。
Event | createEvent(String application, String key, UserInfo info) パラメータで指定された内容に該当するイベントを生成します。
EventResult | dispatch(Event event) イベントに対する処理を実行します。
EventResult | dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
static EventManager | getEventManager() イベントマネージャを取得します。
EventPropertyHandler | getEventPropertyHandler() イベントプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

EVENT_PROPERTY_HANDLER_KEY

public static final String EVENT_PROPERTY_HANDLER_KEY
イベントプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getEventManager

public static EventManager getEventManager()
                                    throws EventManagerException
イベントマネージャを取得します。

戻り値:
イベントマネージャ
例外:
EventManagerException - イベントマネージャの生成時に例外が発生

getEventPropertyHandler

public EventPropertyHandler getEventPropertyHandler()
イベントプロパティハンドラを取得します。

戻り値:
イベントプロパティハンドラ

createEvent

public Event createEvent(String application,
                         String key,
                         UserInfo info)
                  throws EventPropertyException,
                         EventException
パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

パラメータ:
application - アプリケーション名
key - キー
info - ログインユーザ情報
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗
導入されたバージョン:
5.0

createEvent

public Event createEvent(String application,
                         String key,
                         String loginUser,
                         String loginGroup)
                  throws EventPropertyException,
                         EventException
推奨されていません。 このメソッドではなくcreateEvent(String, String, UserInfo)を使用してください。

パラメータで指定された内容に該当するイベントを生成します。 該当するイベントがEventPropertyHandlerのパラメータで設定されていない場合、EmptyEventを返します。

パラメータ:
application - アプリケーション名
key - キー
loginUser - ログインユーザ
loginGroup - ログイングループ
戻り値:
パラメータに該当するイベント
例外:
EventException - イベント生成に失敗
EventPropertyException - イベントプロパティの取得に失敗

dispatch

public EventResult dispatch(Event event)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。 イベントを渡されると、イベントに関連するEventListenerFactoryから EventListenerを生成し、EventListenerに処理を依頼します。 eventには必ずcreateEvent(String, String, String, String)で取得したイベントを設定してください。 このメソッドはdispatch(event, false)を呼び出したときと同じ効果があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

dispatch

public EventResult dispatch(Event event,
                            boolean transaction)
                     throws EventException,
                            SystemException,
                            ApplicationException
イベントに対する処理を実行します。 イベントを渡されると、イベントに関連するEventListenerFactoryから EventListenerを生成し、EventListenerに処理を依頼します。 eventには必ずcreateEvent(String, String, String, String)で取得したイベントを設定してください。
EventListenerに処理を依頼する際、EventListener.setInTransaction(boolean)メソッドが呼ばれます。 このときにnestで指定された値が渡されます。

パラメータ:
event - イベント
transaction - トランザクションの中で実行されているかどうかを示すフラグ（トランザクション内の場合true、トランザクション外の場合false）
戻り値:
イベント処理結果
例外:
EventException - 不正なイベントが渡された
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventManagerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventManagerException
すべての実装インタフェース:
Serializable
public class EventManagerException
extends SystemException

イベントマネージャ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventManagerException()
詳細メッセージを指定しないで EventManagerException を構築します。
EventManagerException(String msg)
指定された詳細メッセージを持つ EventManagerException を構築します。
EventManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventManagerException

public EventManagerException()
詳細メッセージを指定しないで EventManagerException を構築します。

EventManagerException

public EventManagerException(String msg)
指定された詳細メッセージを持つ EventManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventManagerException

public EventManagerException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventModelProducer (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventModelProducer

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventModelProducer
public class EventModelProducer
extends Object

イベント情報を作成するクラスです。

バージョン:
1.0

コンストラクタの概要
EventModelProducer()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventModelProducer

public EventModelProducer()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventPropertyException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventPropertyException
すべての実装インタフェース:
Serializable
public class EventPropertyException
extends SystemException

イベントプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventPropertyException()
詳細メッセージを指定しないで EventPropertyException を構築します。
EventPropertyException(String msg)
指定された詳細メッセージを持つ EventPropertyException を構築します。
EventPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventPropertyException

public EventPropertyException()
詳細メッセージを指定しないで EventPropertyException を構築します。

EventPropertyException

public EventPropertyException(String msg)
指定された詳細メッセージを持つ EventPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

EventPropertyException

public EventPropertyException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultEventPropertyHandler, DistributesEventPropertyHandler, TextFileEventPropertyHandler, XmlEventPropertyHandler
public interface EventPropertyHandler
extends PropertyHandler

イベントの設定情報に接続するクラスです。

バージョン:
1.0

メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
EventPropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventResult (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventResult

すべてのスーパーインタフェース:
Serializable
public interface EventResult
extends Serializable

イベント処理の結果です。

バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventTrigger (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース EventTrigger

既知の実装クラスの一覧:
EventTriggerAdapter
public interface EventTrigger

イベントトリガです。 このインタフェースを実装するクラスでは、定数(static final)以外のフィールドは定義しないでください。

バージョン:
1.0

メソッドの概要
 void fire(Event event, DataAccessController controller)
イベントに対する処理を行います。

メソッドの詳細

fire

public void fire(Event event,
                 DataAccessController controller)
          throws SystemException,
                 ApplicationException
イベントに対する処理を行います。 トランザクションはcontrollerで管理されています。 このメソッドを実装するとき、内部でトランザクションのロールバックやコミットを行わないようにしてください。 メソッドが失敗した場合、またはロールバックを行いたい場合は、ApplicationExceptionのサブクラスを例外としてthrowしてください。

パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventTriggerAdapter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerAdapter
すべての実装インタフェース:
EventTrigger
public abstract class EventTriggerAdapter
extends Object
implements EventTrigger

DAOを取得するメソッドを持ったイベントトリガです。

バージョン:
1.0

コンストラクタの概要
EventTriggerAdapter()
EventTriggerAdapterを新規に生成します。
メソッドの概要
protected abstract void | fire(Event event) イベントに対する処理を行います。
void | fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected Object | getDAO(String application, String key, String connect) DAOを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerAdapter

public EventTriggerAdapter()
EventTriggerAdapterを新規に生成します。

メソッドの詳細

getDAO

protected Object getDAO(String application,
                        String key,
                        String connect)
                 throws DataPropertyException,
                        DataConnectorException,
                        DAOException,
                        DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

fire

public void fire(Event event,
                 DataAccessController controller)
          throws SystemException,
                 ApplicationException
イベントに対する処理を行います。 トランザクションはcontrollerで管理されています。 このメソッドはfire(jp.co.intra_mart.framework.base.event.Event)メソッドを呼ぶように実装されています。

定義:
インタフェース EventTrigger 内の fire
パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生

fire

protected abstract void fire(Event event)
                      throws SystemException,
                             ApplicationException
イベントに対する処理を行います。 このメソッドを実装するとき、内部でトランザクションのロールバックやコミットを行わないようにしてください。 メソッドが失敗した場合、またはロールバックを行いたい場合は、ApplicationExceptionのサブクラスを例外としてthrowしてください。

パラメータ:
event - イベント
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventTriggerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.event.EventTriggerException
すべての実装インタフェース:
Serializable
public class EventTriggerException
extends SystemException

イベントトリガ生成時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EventTriggerException()
詳細メッセージを指定しないで EventTriggerException を構築します。
EventTriggerException(String msg)
指定された詳細メッセージを持つ EventTriggerException を構築します。
EventTriggerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EventTriggerException

public EventTriggerException()
詳細メッセージを指定しないで EventTriggerException を構築します。

EventTriggerException

public EventTriggerException(String msg)
指定された詳細メッセージを持つ EventTriggerException を構築します。

パラメータ:
msg - 詳細メッセージ

EventTriggerException

public EventTriggerException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventTriggerInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerInfo
public class EventTriggerInfo
extends Object

イベントトリガの情報です。

バージョン:
1.0

コンストラクタの概要
EventTriggerInfo()
EventTriggerInfoを新規に生成します。
メソッドの概要
String | getName() イベントトリガ名を取得します。
int | getNumber() ソート番号を取得します。
void | setName(String name) イベントトリガ名を設定します。
void | setNumber(int number) ソート番号を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerInfo

public EventTriggerInfo()
EventTriggerInfoを新規に生成します。

メソッドの詳細

setNumber

public void setNumber(int number)
ソート番号を設定します。

パラメータ:
number - ソート番号

getNumber

public int getNumber()
ソート番号を取得します。

戻り値:
ソート番号

setName

public void setName(String name)
イベントトリガ名を設定します。

パラメータ:
name - イベントトリガ名

getName

public String getName()
イベントトリガ名を取得します。

戻り値:
イベントトリガ名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventTriggerList (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス EventTriggerList

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EventTriggerList
public class EventTriggerList
extends Object

イベントトリガの集合を扱います。 イベントトリガの生成し、順番に実行します。

バージョン:
1.0

コンストラクタの概要
EventTriggerList(String application, String key)
EventTriggerListを新規に生成します。
EventTriggerList(String application, String key, boolean pre)
EventTriggerListを新規に生成します。
メソッドの概要
 void fireAll(Event event, DataAccessController controller)
すべてのトリガに対してイベントの処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventTriggerList

public EventTriggerList(String application,
                        String key)
                 throws EventManagerException,
                        EventPropertyException,
                        EventTriggerException
EventTriggerListを新規に生成します。 このコンストラクタではイベントの前に処理するEventTriggerListを生成します。 このコンストラクタはEvent(application, key, true) と同じ結果となります。

パラメータ:
application - アプリケーション名
key - キー
例外:
EventManagerException - EventManager生成時に例外が発生した
EventPropertyException - イベントプロパティの取得時に例外が発生した
EventTriggerException - イベントトリガ生成時に例外が発生した

EventTriggerList

public EventTriggerList(String application,
                        String key,
                        boolean pre)
                 throws EventManagerException,
                        EventPropertyException,
                        EventTriggerException
EventTriggerListを新規に生成します。 preによってイベントの前に処理されるイベントトリガであるか イベントの後に処理されるイベントトリガであるかを指定します。

パラメータ:
application - アプリケーション名
key - キー
pre - true:イベントの前に起動するイベントトリガ、false:イベントの後に起動するイベントトリガ
例外:
EventManagerException - EventManager生成時に例外が発生した
EventPropertyException - イベントプロパティの取得時に例外が発生した
EventTriggerException - イベントトリガ生成時に例外が発生した
導入されたバージョン:
4.3
メソッドの詳細

fireAll

public void fireAll(Event event,
                    DataAccessController controller)
             throws SystemException,
                    ApplicationException
すべてのトリガに対してイベントの処理を行います。

パラメータ:
event - イベント
controller - データアクセスコントローラ
例外:
SystemException - システム例外が発生した
ApplicationException - アプリケーション例外が発生した
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListener (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListener
すべての実装インタフェース:
EventListener
public class GenericEJBEventListener
extends EJBEventListener

EJBを利用する汎用的なイベントリスナです。

バージョン:
1.0

コンストラクタの概要
GenericEJBEventListener(GenericEJBEventListenerAgentHome home, String listenerName)
GenericEJBEventListenerを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListener

public GenericEJBEventListener(GenericEJBEventListenerAgentHome home,
                               String listenerName)
GenericEJBEventListenerを新規に生成します。

パラメータ:
home - ホームインタフェースGenericEJBEventListenerAgentHome
listenerName - 実際に処理を行うStandardEventListenerのクラス名
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListenerAgent (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgent

すべてのスーパーインタフェース:
EJBObject, Remote
public interface GenericEJBEventListenerAgent
extends EJBObject

汎用的なEJB用のイベントリスナのリモートインタフェースです。

バージョン:
1.0

メソッドの概要
 EventResult execute(Event event, String listenerName)
イベント処理を行います。
インタフェース javax.ejb.EJBObject から継承したメソッド
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           RemoteException,
                           EJBException
イベント処理を行います。 実際の処理はlistenerNameで定義されたクラスで行われます。 listenerNameで指定されるクラスはStandardEventListenerを継承し、引数のないコンストラクタを持つ必要があります。

パラメータ:
event - イベント
listenerName - イベントリスナのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
RemoteException - システムエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListenerAgentBean (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
public class GenericEJBEventListenerAgentBean
extends EJBEventListenerAgentBean

EJBを利用する汎用的なイベントリスナーのBeanです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したフィールド
sessionContext
コンストラクタの概要
GenericEJBEventListenerAgentBean()
GenericEJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
void | ejbCreate() ホームインタフェースの引数なしのcreate()メソッドに対応します。
EventResult | execute(Event event, String listenerName) イベント処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したメソッド
dispatchEvent, ejbActivate, ejbPassivate, ejbRemove, setSessionContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListenerAgentBean

public GenericEJBEventListenerAgentBean()
GenericEJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

ejbCreate

public void ejbCreate()
ホームインタフェースの引数なしのcreate()メソッドに対応します。

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を実行します。 listenerNameはStandardEventListenerを継承したクラスであり、引数を持たないコンストラクタが存在する必要があります。

パラメータ:
event - イベント
listenerName - リスナーのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListenerAgentHome (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentHome

すべてのスーパーインタフェース:
EJBHome, Remote
public interface GenericEJBEventListenerAgentHome
extends EJBHome

リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。

バージョン:
1.0

メソッドの概要
 GenericEJBEventListenerAgent create()
リモートインタフェースGenericEJBEventListenerAgentを取得します。
インタフェース javax.ejb.EJBHome から継承したメソッド
getEJBMetaData, getHomeHandle, remove, remove

メソッドの詳細

create

public GenericEJBEventListenerAgent create()
                                    throws RemoteException,
                                           CreateException
リモートインタフェースGenericEJBEventListenerAgentを取得します。

戻り値:
GenericEJBEventListenerAgent
例外:
RemoteException - システムエラー
CreateException - リモートインタフェース取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListenerAgentLocal (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentLocal

すべてのスーパーインタフェース:
EJBLocalObject
public interface GenericEJBEventListenerAgentLocal
extends EJBLocalObject

汎用的なEJB用のイベントリスナのローカルインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 EventResult execute(Event event, String listenerName)
イベント処理を行います。
インタフェース javax.ejb.EJBLocalObject から継承したメソッド
getEJBLocalHome, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event,
                           String listenerName)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を行います。 実際の処理はlistenerNameで定義されたクラスで行われます。 listenerNameで指定されるクラスはStandardEventListenerを継承し、引数のないコンストラクタを持つ必要があります。

パラメータ:
event - イベント
listenerName - イベントリスナのクラス名
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListenerAgentLocalHome (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース GenericEJBEventListenerAgentLocalHome

すべてのスーパーインタフェース:
EJBLocalHome
public interface GenericEJBEventListenerAgentLocalHome
extends EJBLocalHome

ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
 GenericEJBEventListenerAgentLocal create()
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。
インタフェース javax.ejb.EJBLocalHome から継承したメソッド
remove

メソッドの詳細

create

public GenericEJBEventListenerAgentLocal create()
                                         throws CreateException
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。

戻り値:
GenericEJBEventListenerAgentLocal
例外:
RemoteException - システムエラー
CreateException - リモートインタフェース取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListenerFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEJBEventListenerFactory
extends EJBEventListenerFactory

GenericEJBEventListenerを生成します。

バージョン:
1.0

フィールドの概要
static String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
GenericEJBEventListenerFactory()
GenericEJBEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
String | getListenerName() EJBEventListenerAgentBeanのクラス名を取得します。
void | initParam(String name, String value) 初期パラメータを設定します。
protected void | setListenerName(String listenerName) EJBEventListenerAgentBeanのクラス名を設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LISTENER_PARAM

public static final String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

GenericEJBEventListenerFactory

public GenericEJBEventListenerFactory()
GenericEJBEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生

setListenerName

protected void setListenerName(String listenerName)
EJBEventListenerAgentBeanのクラス名を設定します。

パラメータ:
listenerName - EJBEventListenerAgentBeanのクラス名

getListenerName

public String getListenerName()
EJBEventListenerAgentBeanのクラス名を取得します。

戻り値:
EJBEventListenerAgentBeanのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListenerLocal (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerLocal

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
すべての実装インタフェース:
EventListener
public class GenericEJBEventListenerLocal
extends EJBEventListener

ローカルEJBを利用する汎用的なイベントリスナです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home, String listenerName)
GenericEJBEventListnerLocalを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEJBEventListenerLocal

public GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome home,
                                    String listenerName)
GenericEJBEventListnerLocalを新規に生成します。

パラメータ:
home - ホームインタフェース
listenerName - 実際に処理を行うStandardEventListenerのクラス名
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEJBEventListenerLocalFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEJBEventListenerLocalFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEJBEventListenerLocalFactory
extends EJBEventListenerFactory

GenericEJBEventListnerLocalを新規に生成します。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
GenericEJBEventListenerLocalFactory()
GenericEJBEventListnerLocalFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
String | getListenerName() EJBEventListenerAgentBeanのクラス名を取得します。
void | initParam(String name, String value) 初期パラメータを設定します。
protected void | setListenerName(String listenerName) EJBEventListenerAgentBeanのクラス名を設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LISTENER_PARAM

public static final String LISTENER_PARAM
イベントリスナーのクラス名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

GenericEJBEventListenerLocalFactory

public GenericEJBEventListenerLocalFactory()
GenericEJBEventListnerLocalFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生

setListenerName

protected void setListenerName(String listenerName)
EJBEventListenerAgentBeanのクラス名を設定します。

パラメータ:
listenerName - EJBEventListenerAgentBeanのクラス名

getListenerName

public String getListenerName()
EJBEventListenerAgentBeanのクラス名を取得します。

戻り値:
EJBEventListenerAgentBeanのクラス名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEventListener (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.GenericEventListener
すべての実装インタフェース:
EventListener
public class GenericEventListener
extends Object
implements EventListener

汎用的なイベントリスナです。

バージョン:
1.0

コンストラクタの概要
GenericEventListener()
GenericEventListenerを新規に生成します。
メソッドの概要
EventResult | execute(Event event) 処理を実行します。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
void | setListener(StandardEventListener listener) イベント処理クラスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEventListener

public GenericEventListener()
GenericEventListenerを新規に生成します。

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

定義:
インタフェース EventListener 内の execute
パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

setListener

public void setListener(StandardEventListener listener)
イベント処理クラスを設定します。

パラメータ:
listener - イベント処理クラス

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericEventListenerFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス GenericEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.GenericEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class GenericEventListenerFactory
extends Object
implements EventListenerFactory

GenericEventListenerを生成するイベントリスナファクトリです。 このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 包含するイベントリスナ

バージョン:
1.0

コンストラクタの概要
GenericEventListenerFactory()
GenericEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericEventListenerFactory

public GenericEventListenerFactory()
GenericEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.event (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.event
インタフェース
EventListener
EventListenerFactory
EventPropertyHandler
EventResult
EventTrigger
GenericEJBEventListenerAgent
GenericEJBEventListenerAgentHome
GenericEJBEventListenerAgentLocal
GenericEJBEventListenerAgentLocalHome
StandardEJBEventListenerAgent
StandardEJBEventListenerAgentHome
クラス
DefaultEventPropertyHandler
DistributesEventPropertyHandler
EJBEventListener
EJBEventListenerAgentBean
EJBEventListenerFactory
EmptyEvent
Event
EventFactoryModel
EventGroupModel
EventListenerFactoryParam
EventManager
EventModelProducer
EventTriggerAdapter
EventTriggerInfo
EventTriggerList
GenericEJBEventListener
GenericEJBEventListenerAgentBean
GenericEJBEventListenerFactory
GenericEJBEventListenerLocal
GenericEJBEventListenerLocalFactory
GenericEventListener
GenericEventListenerFactory
StandardEJBEventListener
StandardEJBEventListenerAgentBean
StandardEJBEventListenerFactory
StandardEventListener
StandardEventListenerFactory
TextFileEventPropertyHandler
XmlEventPropertyHandler
例外
EventException
EventListenerException
EventManagerException
EventPropertyException
EventTriggerException


jp.co.intra_mart.framework.base.event (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event

イベントフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
EventListener | イベントリスナです。
EventListenerFactory | イベントリスナを生成します。
EventPropertyHandler | イベントの設定情報に接続するクラスです。
EventResult | イベント処理の結果です。
EventTrigger | イベントトリガです。
GenericEJBEventListenerAgent | 汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentHome | リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal | 汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome | ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
StandardEJBEventListenerAgent | EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentHome | StandardEJBEventListenerAgentのホームインタフェースです。

クラスの概要
DefaultEventPropertyHandler | デフォルトのEventPropertyHandlerです。
DistributesEventPropertyHandler | アプリケーション毎のEventPropertyHandlerを呼び出します。
EJBEventListener | EJBを利用する場合のイベントリスナです。
EJBEventListenerAgentBean | Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerFactory | EJBEventListenerFactoryを生成します。
EmptyEvent | 情報を何も持たないイベントです。
Event | 処理を実行するための情報です。
EventFactoryModel | イベントリスナーファクトリー情報を管理するクラスです。
EventGroupModel | Event情報を管理するクラスです。
EventListenerFactoryParam | イベントリスナファクトリの初期パラメータです。
EventManager | イベントマネージャです。
EventModelProducer | イベント情報を作成するクラスです。
EventTriggerAdapter | DAOを取得するメソッドを持ったイベントトリガです。
EventTriggerInfo | イベントトリガの情報です。
EventTriggerList | イベントトリガの集合を扱います。
GenericEJBEventListener | EJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerAgentBean | EJBを利用する汎用的なイベントリスナーのBeanです。
GenericEJBEventListenerFactory | GenericEJBEventListenerを生成します。
GenericEJBEventListenerLocal | ローカルEJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerLocalFactory | GenericEJBEventListnerLocalを新規に生成します。
GenericEventListener | 汎用的なイベントリスナです。
GenericEventListenerFactory | GenericEventListenerを生成するイベントリスナファクトリです。
StandardEJBEventListener | StandardEJBEventListenerAgentに接続するイベントリスナです。
StandardEJBEventListenerAgentBean | EJBを利用する場合の抽象的なイベントリスナです。
StandardEJBEventListenerFactory | 標準的なEJB用のイベントリスナファクトリです。
StandardEventListener | 汎用的なビジネスロジック用のクラスです。
StandardEventListenerFactory | 通常のJavaクラスのイベントリスナを生成します。
TextFileEventPropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
XmlEventPropertyHandler | XMLのEventPropertyHandlerです。

例外の概要
EventException | イベント生成時の例外です。
EventListenerException | イベントリスナ生成時の例外です。
EventManagerException | イベントマネージャ設定時の例外です。
EventPropertyException | イベントプロパティ取得時の例外です。
EventTriggerException | イベントトリガ生成時の例外です。

パッケージ jp.co.intra_mart.framework.base.event の説明

イベントフレームワークに関連するクラスのパッケージです。 イベントフレームワークを利用して処理を行う手順の概要は次のとおりです。

  • アプリケーションIDとイベントキーからEventを生成する。
  • Eventに処理に必要となる情報を設定する。
  • アプリケーションIDとイベントキーに対応するEventListenerにEventを渡し、処理を行う。
  • EventListenerは処理結果となるEventResultを返す。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.event クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.event の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.EJBEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListener
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListener
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean (implements javax.ejb.SessionBean)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
    • class jp.co.intra_mart.framework.base.event.Event (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.event.EmptyEvent
    • class jp.co.intra_mart.framework.base.event.EventFactoryModel
    • class jp.co.intra_mart.framework.base.event.EventGroupModel
    • class jp.co.intra_mart.framework.base.event.EventManager
    • class jp.co.intra_mart.framework.base.event.EventModelProducer
    • class jp.co.intra_mart.framework.base.event.EventTriggerAdapter (implements jp.co.intra_mart.framework.base.event.EventTrigger)
    • class jp.co.intra_mart.framework.base.event.EventTriggerInfo
    • class jp.co.intra_mart.framework.base.event.EventTriggerList
    • class jp.co.intra_mart.framework.base.event.GenericEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
    • class jp.co.intra_mart.framework.base.event.StandardEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.event.EventException
            • class jp.co.intra_mart.framework.base.event.EventListenerException
            • class jp.co.intra_mart.framework.base.event.EventManagerException
            • class jp.co.intra_mart.framework.base.event.EventPropertyException
            • class jp.co.intra_mart.framework.base.event.EventTriggerException
    • class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)

インタフェース階層

  • interface javax.ejb.EJBLocalHome
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome
  • interface javax.ejb.EJBLocalObject
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal
  • interface jp.co.intra_mart.framework.base.event.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListenerFactory
  • interface jp.co.intra_mart.framework.base.event.EventTrigger
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.event.EventPropertyHandler
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
    • interface javax.ejb.EJBObject
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.event.EventResult
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.event の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.event の使用

jp.co.intra_mart.framework.base.event を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.event のクラス
EJBEventListener
EJBを利用する場合のイベントリスナです。
EJBEventListenerAgentBean
Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerFactory
EJBEventListenerFactoryを生成します。
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventListener
イベントリスナです。
EventListenerException
イベントリスナ生成時の例外です。
EventListenerFactory
イベントリスナを生成します。
EventListenerFactoryParam
イベントリスナファクトリの初期パラメータです。
EventManager
イベントマネージャです。
EventManagerException
イベントマネージャ設定時の例外です。
EventPropertyException
イベントプロパティ取得時の例外です。
EventPropertyHandler
イベントの設定情報に接続するクラスです。
EventResult
イベント処理の結果です。
EventTrigger
イベントトリガです。
EventTriggerException
イベントトリガ生成時の例外です。
GenericEJBEventListenerAgent
汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentHome
リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal
汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome
ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
StandardEJBEventListenerAgent
EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentHome
StandardEJBEventListenerAgentのホームインタフェースです。
StandardEventListener
汎用的なビジネスロジック用のクラスです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventResult
イベント処理の結果です。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.base.event のクラス
Event
処理を実行するための情報です。
EventException
イベント生成時の例外です。
EventManagerException
イベントマネージャ設定時の例外です。
EventResult
イベント処理の結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


StandardEJBEventListener (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListener
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListener
すべての実装インタフェース:
EventListener
public class StandardEJBEventListener
extends EJBEventListener

StandardEJBEventListenerAgentに接続するイベントリスナです。

バージョン:
1.0

コンストラクタの概要
StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。
メソッドの概要
 EventResult execute(Event event)
処理を実行します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListener から継承したメソッド
dispatchEvent, setInTransaction
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListener

public StandardEJBEventListener(StandardEJBEventListenerAgentHome home)
StandardEJBEventListenerを新規に生成します。

パラメータ:
home - ホームインタフェースStandardEJBEventListenerAgentHome
メソッドの詳細

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 イベントを元に処理を実行します。 このインタフェースを実装するすべてのクラスは、 すべてのイベントトリガを実行した後に処理を 実行するように設計されている必要があります。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


StandardEJBEventListenerAgent (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース StandardEJBEventListenerAgent

すべてのスーパーインタフェース:
EJBObject, Remote
public interface StandardEJBEventListenerAgent
extends EJBObject

EJBを利用するときのイベントリスナのリモートインタフェースです。

バージョン:
1.0

メソッドの概要
 EventResult execute(Event event)
イベント処理を実行します。
インタフェース javax.ejb.EJBObject から継承したメソッド
getEJBHome, getHandle, getPrimaryKey, isIdentical, remove

メソッドの詳細

execute

public EventResult execute(Event event)
                    throws ApplicationException,
                           SystemException,
                           RemoteException,
                           EJBException
イベント処理を実行します。 実際の処理はStandardEJBEventListenerAgentBean.execute(jp.co.intra_mart.framework.base.event.Event)で行われます。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー
RemoteException - システムエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


StandardEJBEventListenerAgentBean (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListenerAgentBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
すべての実装インタフェース:
EnterpriseBean, Serializable, SessionBean
public abstract class StandardEJBEventListenerAgentBean
extends EJBEventListenerAgentBean

EJBを利用する場合の抽象的なイベントリスナです。 メソッドfire(jp.co.intra_mart.framework.base.event.Event, jp.co.intra_mart.framework.base.data.DataAccessController)を実装する必要があります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したフィールド
sessionContext
コンストラクタの概要
StandardEJBEventListenerAgentBean()
StandardEJBEventListenerAgentBeanを新規に生成します。
メソッドの概要
void | ejbCreate() ホームインタフェースの引数なしのcreate()メソッドに対応します。
EventResult | execute(Event event) イベント処理を実行します。
protected abstract EventResult | fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean から継承したメソッド
dispatchEvent, ejbActivate, ejbPassivate, ejbRemove, setSessionContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListenerAgentBean

public StandardEJBEventListenerAgentBean()
StandardEJBEventListenerAgentBeanを新規に生成します。

メソッドの詳細

ejbCreate

public void ejbCreate()
ホームインタフェースの引数なしのcreate()メソッドに対応します。

導入されたバージョン:
3.2

execute

public EventResult execute(Event event)
                    throws ApplicationException,
                           SystemException,
                           EJBException
イベント処理を実行します。 このクラスでは以下のような順番で処理を行います。
  1. イベントトリガの実行(前処理)
  2. イベント処理の実行(fire(Event, DataAccessController))
  3. イベントトリガの実行(後処理)
  4. 簡易トランザクションのコミット(DataAccessController.commit())
このクラスではStandardEventListener.execute(Event)とは違い直接UserTransactionを扱っていません。そのため、このEJBを使うためにはコンテナ管理トランザクション(Container-management Transaction:CMT)を使用してください。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生
EJBException - システムレベルのエラー

fire

protected abstract EventResult fire(Event event,
                                    DataAccessController dataAccessController)
                             throws SystemException,
                                    ApplicationException
イベントに対する処理です。

パラメータ:
event - イベント
dataAccessController - データアクセスコントローラ
戻り値:
イベント処理結果
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


StandardEJBEventListenerAgentHome (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
インタフェース StandardEJBEventListenerAgentHome

すべてのスーパーインタフェース:
EJBHome, Remote
public interface StandardEJBEventListenerAgentHome
extends EJBHome

StandardEJBEventListenerAgentのホームインタフェースです。

バージョン:
1.0

メソッドの概要
 StandardEJBEventListenerAgent create()
StandardEJBEventListenerAgentと接続します。
インタフェース javax.ejb.EJBHome から継承したメソッド
getEJBMetaData, getHomeHandle, remove, remove

メソッドの詳細

create

public StandardEJBEventListenerAgent create()
                                     throws RemoteException,
                                            CreateException
StandardEJBEventListenerAgentと接続します。

戻り値:
StandardEJBEventListenerAgent
例外:
RemoteException - システムレベルエラー
CreateException - EJBEventListenerAgent生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


StandardEJBEventListenerFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEJBEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
        拡張 jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class StandardEJBEventListenerFactory
extends EJBEventListenerFactory

標準的なEJB用のイベントリスナファクトリです。

バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したフィールド
HOME_PARAM
コンストラクタの概要
StandardEJBEventListenerFactory()
StandardEJBEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス jp.co.intra_mart.framework.base.event.EJBEventListenerFactory から継承したメソッド
getJNDIName, setJNDIName
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEJBEventListenerFactory

public StandardEJBEventListenerFactory()
StandardEJBEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。

パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


StandardEventListener (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEventListener

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.StandardEventListener
すべての実装インタフェース:
EventListener
public abstract class StandardEventListener
extends Object
implements EventListener

汎用的なビジネスロジック用のクラスです。

バージョン:
1.0

コンストラクタの概要
StandardEventListener()
メソッドの概要
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
EventResult | execute(Event event) 処理を実行します。
protected abstract EventResult | fire(Event event) イベントに対する処理です。
protected Object | getDAO(String application, String key, String connect) DAOを取得します。
protected DataAccessController | getDataAccessController() このイベントリスナで使用するデータアクセスコントローラです。
void | setInTransaction(boolean transaction) このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventListener

public StandardEventListener()
メソッドの詳細

getDataAccessController

protected DataAccessController getDataAccessController()
このイベントリスナで使用するデータアクセスコントローラです。 このクラスを継承する場合、メソッドfire(jp.co.intra_mart.framework.base.event.Event)内ではデータアクセスコントローラの取得にはこのメソッドを使うようにしてください。

戻り値:
データアクセスコントローラ

getDAO

protected Object getDAO(String application,
                        String key,
                        String connect)
                 throws DataPropertyException,
                        DataConnectorException,
                        DAOException,
                        DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAO
例外:
DataPropertyException - プロパティの取得に失敗
DataConnectorException - データコネクタの取得に失敗
DAOException - DAOの取得に失敗
DataConnectException - データリソースとの接続に失敗

execute

public EventResult execute(Event event)
                    throws SystemException,
                           ApplicationException
処理を実行します。 このクラスでは以下のような順番で処理を行います。
  1. ユーザトランザクションの開始
  2. イベントトリガの実行(前処理)
  3. イベント処理の実行(fire(jp.co.intra_mart.framework.base.event.Event))
  4. イベントトリガの実行(後処理)
  5. 簡易トランザクションのコミット(DataAccessController.commit())
  6. ユーザトランザクションのコミット

定義:
インタフェース EventListener 内の execute
パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
ApplicationException - イベント処理時にアプリケーション例外が発生
SystemException - システム処理時にアプリケーション例外が発生

fire

protected abstract EventResult fire(Event event)
                             throws SystemException,
                                    ApplicationException
イベントに対する処理です。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
SystemException - システム例外が発生
ApplicationException - アプリケーション例外が発生

setInTransaction

public void setInTransaction(boolean transaction)
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。

定義:
インタフェース EventListener 内の setInTransaction
パラメータ:
transaction - トランザクションの中で実行されている場合：true、そうでない場合：false
導入されたバージョン:
4.2

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
導入されたバージョン:
4.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


StandardEventListenerFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス StandardEventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.StandardEventListenerFactory
すべての実装インタフェース:
EventListenerFactory
public class StandardEventListenerFactory
extends Object
implements EventListenerFactory

通常のJavaクラスのイベントリスナを生成します。 このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 生成するイベントリスナ

バージョン:
1.0

コンストラクタの概要
StandardEventListenerFactory()
StandardEventListenerFactoryを新規に生成します。
メソッドの概要
EventListener | create(Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardEventListenerFactory

public StandardEventListenerFactory()
StandardEventListenerFactoryを新規に生成します。

メソッドの詳細

create

public EventListener create(Event event)
                     throws EventListenerException
イベントリスナを生成します。 初期パラメータで指定されたクラスをイベントリスナとして生成します。 初期パラメータで指定されたクラスはStandardEventListenerを継承している必要があります。

定義:
インタフェース EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


TextFileEventPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス TextFileEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class TextFileEventPropertyHandler
extends Object
implements EventPropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultEventPropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileEventPropertyHandler()
TextFileEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) キーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) キーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) キーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileEventPropertyHandler

public TextFileEventPropertyHandler()
TextFileEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
キーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
キーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーション
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
キーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


XmlEventPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.event
クラス XmlEventPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler
すべての実装インタフェース:
EventPropertyHandler, PropertyHandler
public class XmlEventPropertyHandler
extends Object
implements EventPropertyHandler

XMLのEventPropertyHandlerです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID.xml」です。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにEventManager.EVENT_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの設定内容は以下のとおりです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのxmlファイルのプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM xmlのパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
コンストラクタの概要
XmlEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。
メソッドの概要
String | getEventListenerFactoryName(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
EventListenerFactoryParam[] | getEventListenerFactoryParams(String application, String key) アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
String | getEventName(String application, String key) アプリケーションIDとキーに該当するイベントのクラス名を取得します。
Collection | getEventTriggerInfos(String application, String key) アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
Collection | getPostEventTriggerInfos(String application, String key) キーに該当するイベントのイベントトリガ情報をすべて取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのxmlファイルのプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
xmlのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlEventPropertyHandler

public XmlEventPropertyHandler()
DefaultEventPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws EventPropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース EventPropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
EventPropertyException - チェック時に例外が発生

getEventName

public String getEventName(String application,
                           String key)
                    throws EventPropertyException
アプリケーションIDとキーに該当するイベントのクラス名を取得します。 該当するイベントが存在しない場合、nullを返します。

定義:
インタフェース EventPropertyHandler 内の getEventName
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントのクラス名
例外:
EventPropertyException - イベントのクラス名の取得に失敗

getEventListenerFactoryName

public String getEventListenerFactoryName(String application,
                                          String key)
                                   throws EventPropertyException
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryName
パラメータ:
application - アプリケーションID
key - イベントリスナファクトリのキー
戻り値:
イベントリスナファクトリのクラス名
例外:
EventPropertyException - イベントリスナファクトリのクラス名の取得に失敗

getEventListenerFactoryParams

public EventListenerFactoryParam[] getEventListenerFactoryParams(String application,
                                                                 String key)
                                                          throws EventPropertyException
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。

定義:
インタフェース EventPropertyHandler 内の getEventListenerFactoryParams
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントリスナファクトリの初期パラメータ
例外:
EventPropertyException - イベントリスナファクトリの初期パラメータの取得に失敗

getEventTriggerInfos

public Collection getEventTriggerInfos(String application,
                                       String key)
                                throws EventPropertyException
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getEventTriggerInfos
パラメータ:
application - アプリケーションID
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener

getPostEventTriggerInfos

public Collection getPostEventTriggerInfos(String application,
                                           String key)
                                    throws EventPropertyException
キーに該当するイベントのイベントトリガ情報をすべて取得します。 ここで取得されるイベントトリガはイベントの処理後に実行されます。 applicationとkeyで定義されるEventTriggerを定義された順番でソートしたCollectionとして取得します。

定義:
インタフェース EventPropertyHandler 内の getPostEventTriggerInfos
パラメータ:
application - アプリケーション
key - イベントのキー
戻り値:
イベントトリガ情報のコレクション
例外:
EventPropertyException - イベントトリガ情報の取得に失敗
関連項目:
EventListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の使用

jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.message.MessageManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.framework.base.message のメソッド
static MessageManager MessageManager.getMessageManager()
メッセージマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.message.MessageManagerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessageManagerException の使用

MessageManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessageManagerException の使用

MessageManagerException をスローする jp.co.intra_mart.framework.base.message のメソッド
static MessageManager MessageManager.getMessageManager()
メッセージマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.message.MessagePropertyException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.MessagePropertyException の使用

MessagePropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessagePropertyException の使用

MessagePropertyException をスローする jp.co.intra_mart.framework.base.message のメソッド
boolean | TextFileMessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | TextFileMessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | TextFileMessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | MessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | MessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | MessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | DefaultMessagePropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
String | DefaultMessagePropertyHandler.getMessage(String application, String key) メッセージを取得します。
String | DefaultMessagePropertyHandler.getMessage(String application, String key, Locale locale) メッセージを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.message.MessagePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.message.MessagePropertyHandler の使用

MessagePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message での MessagePropertyHandler の使用

MessagePropertyHandler を実装している jp.co.intra_mart.framework.base.message のクラス
class | DefaultMessagePropertyHandler メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
class | TextFileMessagePropertyHandler 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

MessagePropertyHandler を返す jp.co.intra_mart.framework.base.message のメソッド
 MessagePropertyHandler MessageManager.getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の使用

jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultMessagePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス DefaultMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class DefaultMessagePropertyHandler
extends Object
implements MessagePropertyHandler

メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「プレフィックス_アプリケーションID[_ロケール].properties」です。
_ロケールを追加することによってロケールごとにメッセージを変更することも可能です。ロケールによるプロパティファイルの優先順位はJavaTMのjava.util.ResourceBundleと同様のルールに従って決定されます。
プロパティファイルのプレフィックスはPropertyManager.getPropertyHandlerParams(String)でキーにMessageManager.MESSAGE_PROPERTY_HANDLER_KEYを指定したときに取得されるパラメータのうちDEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスはDEFAULT_BUNDLE_NAME_PARAMで示されるものです。

プロパティの内容は「キー=メッセージ」の形式で指定します。

導入されたバージョン:
4.2

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultMessagePropertyHandler

public DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース MessagePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されたロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessageManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.MessageManager
public class MessageManager
extends Object

メッセージマネージャです。

導入されたバージョン:
4.2

フィールドの概要
static String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー
メソッドの概要
String | getMessage(String application, String key, Object[] args) ロケールを指定せず、キーに該当するメッセージを取得します。
String | getMessage(String application, String key, Object[] args, Locale locale) ロケールを指定し、キーに該当するメッセージを取得します。
static MessageManager | getMessageManager() メッセージマネージャを取得します。
MessagePropertyHandler | getMessagePropertyHandler() メッセージプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MESSAGE_PROPERTY_HANDLER_KEY

public static final String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getMessageManager

public static MessageManager getMessageManager()
                                        throws MessageManagerException
メッセージマネージャを取得します。

戻り値:
メッセージマネージャ
例外:
MessageManagerException - メッセージマネージャの生成に失敗した

getMessage

public String getMessage(String application,
                         String key,
                         Object[] args)
ロケールを指定せず、キーに該当するメッセージを取得します。 このメソッドはgetMessage(application, key, args, java.util.Locale.getDefault())を呼んだときと同じ動作をします。

パラメータ:
application - アプリケーションID
key - キー
args - メッセージに設定するパラメータ
戻り値:
メッセージ（存在しない場合???key???）

getMessage

public String getMessage(String application,
                         String key,
                         Object[] args,
                         Locale locale)
ロケールを指定し、キーに該当するメッセージを取得します。 指定されたアプリケーションID、キー、ロケールに一致するメッセージをプロパティから取得し、 パラメータをメッセージ内部に埋め込んだ結果を返します。

このメソッドでは内部で以下のような動作をします。
  1. getMessagePropertyHandler()を呼び、MessagePropertyHandlerを取得する。
  2. MessagePropertyHandler.getMessage(application, key, locale)を呼び、メッセージを取得する。
  3. new java.text.MessageFormat(上で取得したメッセージ).format(args)を呼び、パラメータを埋め込んだメッセージを返す。

パラメータ:
application - アプリケーションID
key - キー
args - メッセージに設定するパラメータ
locale - ロケール
戻り値:
メッセージ（存在しない場合???key???）

getMessagePropertyHandler

public MessagePropertyHandler getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

戻り値:
メッセージプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessageManagerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessageManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.message.MessageManagerException
すべての実装インタフェース:
Serializable
public class MessageManagerException
extends SystemException

サービスマネージャ設定時の例外です。

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessageManagerException

public MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。

MessageManagerException

public MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

MessageManagerException

public MessageManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessagePropertyException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス MessagePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.message.MessagePropertyException
すべての実装インタフェース:
Serializable
public class MessagePropertyException
extends SystemException

メッセージプロパティ取得時の例外です。 * @author INTRAMART

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessagePropertyException

public MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。

MessagePropertyException

public MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

MessagePropertyException

public MessagePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessagePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
インタフェース MessagePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultMessagePropertyHandler, TextFileMessagePropertyHandler
public interface MessagePropertyHandler
extends PropertyHandler

メッセージの設定情報に接続するクラスです。

導入されたバージョン:
4.2

メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されるロケールをヒントにメッセージを取得します。

パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.message (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.message
インタフェース
MessagePropertyHandler
クラス
DefaultMessagePropertyHandler
MessageManager
TextFileMessagePropertyHandler
例外
MessageManagerException
MessagePropertyException


jp.co.intra_mart.framework.base.message (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.message

メッセージフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
MessagePropertyHandler メッセージの設定情報に接続するクラスです。

クラスの概要
DefaultMessagePropertyHandler | メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
MessageManager | メッセージマネージャです。
TextFileMessagePropertyHandler | 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

例外の概要
MessageManagerException | サービスマネージャ設定時の例外です。
MessagePropertyException | メッセージプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.message の説明

メッセージフレームワークに関連するクラスのパッケージです。 国際化対応したメッセージを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.message クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.message.MessageManager
    • class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.message.MessageManagerException
            • class jp.co.intra_mart.framework.base.message.MessagePropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.message の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.message の使用

jp.co.intra_mart.framework.base.message を使用しているパッケージ
jp.co.intra_mart.framework.base.message メッセージフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.base.message のクラス
MessageManager
メッセージマネージャです。
MessageManagerException
サービスマネージャ設定時の例外です。
MessagePropertyException
メッセージプロパティ取得時の例外です。
MessagePropertyHandler
メッセージの設定情報に接続するクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


TextFileMessagePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.message
クラス TextFileMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class TextFileMessagePropertyHandler
extends Object
implements MessagePropertyHandler

指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。 ファイルの書式はDefaultMessagePropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
4.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
コンストラクタの概要
TextFileMessagePropertyHandler()
メソッドの概要
String | getMessage(String application, String key) メッセージを取得します。
String | getMessage(String application, String key, Locale locale) メッセージを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileMessagePropertyHandler

public TextFileMessagePropertyHandler()
メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws MessagePropertyException
プロパティの動的読み込みが可能かどうか調べます。

定義:
インタフェース MessagePropertyHandler 内の isDynamic
戻り値:
true 再設定可能、false 再設定不可
例外:
MessagePropertyException - チェック時に例外が発生

getMessage

public String getMessage(String application,
                         String key)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 システムが稼動しているロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

getMessage

public String getMessage(String application,
                         String key,
                         Locale locale)
                  throws MessagePropertyException
メッセージを取得します。 applicationで指定されるアプリケーション固有のプロパティから keyに該当するメッセージを取得します。 localeで指定されたロケールをヒントにメッセージを取得します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
application - アプリケーションID
key - メッセージのキー
locale - ロケール
戻り値:
メッセージ
例外:
MessagePropertyException - メッセージ取得時に例外が発生

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.DefaultTransition の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DefaultTransition の使用

jp.co.intra_mart.framework.base.service.DefaultTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.EncodingFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.EncodingFilter の使用

jp.co.intra_mart.framework.base.service.EncodingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.FileUploadFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.FileUploadFilter の使用

jp.co.intra_mart.framework.base.service.FileUploadFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter の使用

jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.IntramartConnectFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartConnectFilter の使用

jp.co.intra_mart.framework.base.service.IntramartConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.IntramartConnectServlet の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartConnectServlet の使用

jp.co.intra_mart.framework.base.service.IntramartConnectServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.IntramartLocaleFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartLocaleFilter の使用

jp.co.intra_mart.framework.base.service.IntramartLocaleFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition の使用

jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.LocaleFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.LocaleFilter の使用

jp.co.intra_mart.framework.base.service.LocaleFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.RequestException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.RequestException の使用

RequestException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での RequestException の使用

RequestException 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
abstract String | Transition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | IntramartPageBaseTransition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | DefaultTransition.getInputErrorPage(RequestException e) 入力エラーのページを取得します。

RequestException をスローする jp.co.intra_mart.framework.base.service のメソッド
void | ServiceControllerAdapter.check() 入力内容をチェックします。
void | ServiceController.check() 入力内容をチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.service.ServiceController の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServiceController の使用

ServiceController を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。

jp.co.intra_mart.framework.base.service での ServiceController の使用

ServiceController を実装している jp.co.intra_mart.framework.base.service のクラス
 class ServiceControllerAdapter
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。

ServiceController を返す jp.co.intra_mart.framework.base.service のメソッド
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。

jp.co.intra_mart.framework.presentation.service での ServiceController の使用

ServiceController を実装している jp.co.intra_mart.framework.presentation.service のクラス
 class PresentationServiceController
Presentation Framework用のServiceControllerです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.ServiceControllerAdapter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter の使用

ServiceControllerAdapter を使用しているパッケージ
jp.co.intra_mart.framework.presentation.service サービスに関連するパッケージです。

jp.co.intra_mart.framework.presentation.service での ServiceControllerAdapter の使用

jp.co.intra_mart.framework.presentation.service での ServiceControllerAdapter のサブクラス
 class PresentationServiceController
Presentation Framework用のServiceControllerです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.ServiceControllerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceControllerException の使用

ServiceControllerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.base.service のメソッド
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。
 String ServiceControllerAdapter.getLoginUserID()
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
 String ServiceControllerAdapter.getLoginGroupID()
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
 UserInfo ServiceControllerAdapter.getUserInfo()
ユーザ情報を取得します。
protected  Event ServiceControllerAdapter.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。

jp.co.intra_mart.framework.presentation.view での ServiceControllerException の使用

ServiceControllerException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
protected Event | AbstractViewConverter.createEvent(RequestInfo info, String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
String | AbstractViewConverter.getLoginUserID(RequestInfo info) 推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
String | AbstractViewConverter.getLoginGroupID(RequestInfo info) 推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
UserInfo | AbstractViewConverter.getUserInfo(RequestInfo info) ログインユーザ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.ServiceManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceManager の使用

ServiceManager を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceManager の使用

ServiceManager を返す jp.co.intra_mart.framework.base.service のメソッド
protected ServiceManager | Transition.getServiceManager() サービスマネージャを取得します。
static ServiceManager | ServiceManager.getServiceManager() サービスマネージャを取得します。
protected ServiceManager | IntramartConnectServlet.getServiceManager() 推奨されていません。 サービスマネージャを取得します。

ServiceManager 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
protected  void Transition.setServiceManager(ServiceManager manager)
サービスマネージャを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.ServiceManagerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceManagerException の使用

ServiceManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServiceManagerException の使用

ServiceManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
static ServiceManager | ServiceManager.getServiceManager() サービスマネージャを取得します。
String | ServiceManager.getExtesion() サービスフレームワークを呼び出すための拡張子を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.ServicePropertyException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServicePropertyException の使用

ServicePropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServicePropertyException の使用

ServicePropertyException をスローする jp.co.intra_mart.framework.base.service のメソッド
 boolean XmlServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String XmlServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale XmlServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String XmlServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String XmlServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String XmlServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String XmlServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String XmlServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String XmlServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String XmlServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String XmlServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String XmlServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String XmlServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String XmlServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String XmlServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
protected  String Transition.getNextPagePath()
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
protected  String Transition.getNextPagePath(String key)
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
abstract  String Transition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
abstract  String Transition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
abstract  String Transition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
abstract  String Transition.getNextPage()
次に遷移するページを取得します。
 String TextFileServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale TextFileServicePropertyHandler.getClientLocale()
クライアントのロケールを取得します。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String TextFileServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String TextFileServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String TextFileServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
 String TextFileServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String TextFileServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String TextFileServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String TextFileServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String TextFileServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String TextFileServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String TextFileServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String TextFileServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 boolean ServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String ServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 String ServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 Locale ServicePropertyHandler.getClientLocale()
クライアントのロケールを取得します。
 String ServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String ServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String ServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String ServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String ServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String ServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
 String ServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String ServicePropertyHandler.getServiceServletPath()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String ServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String ServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 ServiceController ServiceManager.getServiceController(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 ServiceController ServiceManager.getServiceController(String application, String service, Locale locale)
サービスコントローラを取得します。
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。
 String ServiceManager.getApplication(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するアプリケーションIDを取得します。
 String ServiceManager.getService(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するサービスIDを取得します。
 Locale ServiceManager.getLocale(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するロケールを取得します。
 String ServiceManager.getEncoding(HttpServletRequest request, HttpServletResponse response)
現在のリクエストに対するエンコーディングを取得します。
 String IntramartPageBaseTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String IntramartPageBaseTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String IntramartPageBaseTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String IntramartPageBaseTransition.getNextPage()
次に遷移するページを取得します。
 boolean DistributesServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DistributesServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale DistributesServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String DistributesServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String DistributesServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String DistributesServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String DistributesServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String DistributesServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String DistributesServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String DistributesServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String DistributesServicePropertyHandler.getApplicationParamName()
アプリケーションIDに該当するパラメータ名を取得します。
 String DistributesServicePropertyHandler.getServiceParamName()
サービスIDに該当するパラメータ名を取得します。
 String DistributesServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String DistributesServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String DistributesServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String DefaultTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String DefaultTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String DefaultTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String DefaultTransition.getNextPage()
次に遷移するページを取得します。
 boolean DefaultServicePropertyHandler.isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
 String DefaultServicePropertyHandler.getClientEncoding()
クライアントのエンコードを取得します。
 Locale DefaultServicePropertyHandler.getClientLocale()
クライアントのエンコードを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getInputErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
 String DefaultServicePropertyHandler.getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getServiceErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
 String DefaultServicePropertyHandler.getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getSystemErrorPagePath()
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
 String DefaultServicePropertyHandler.getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String DefaultServicePropertyHandler.getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
 String DefaultServicePropertyHandler.getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 String DefaultServicePropertyHandler.getServiceServletPath()
サービスサーブレットのパスを取得します。
 String DefaultServicePropertyHandler.getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String DefaultServicePropertyHandler.getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String DefaultServicePropertyHandler.getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String DefaultServicePropertyHandler.getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String DefaultServicePropertyHandler.getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String DefaultServicePropertyHandler.getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServicePropertyHandler の使用

ServicePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での ServicePropertyHandler の使用

ServicePropertyHandler を実装している jp.co.intra_mart.framework.base.service のクラス
class | DefaultServicePropertyHandler サービスの設定情報に接続するデフォルトのプロパティハンドラです。
class | DistributesServicePropertyHandler アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
class | TextFileServicePropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlServicePropertyHandler サービスの設定情報に接続するプロパティハンドラです。

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.service のメソッド
ServicePropertyHandler | ServiceManager.getServicePropertyHandler() サービスプロパティハンドラを取得します。
protected ServicePropertyHandler | IntramartConnectServlet.getServicePropertyHandler() 推奨されていません。 サービスプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.web.bean での ServicePropertyHandler の使用

ServicePropertyHandler を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 ServicePropertyHandler HelperBean.getServicePropertyHandler()
サービスプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.service.ServiceResult の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.service.ServiceResult の使用

ServiceResult を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.base.service での ServiceResult の使用

ServiceResult を返す jp.co.intra_mart.framework.base.service のメソッド
ServiceResult | Transition.getResult() サービス処理結果を取得します。
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。

ServiceResult 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
 void Transition.setResult(ServiceResult result)
サービス処理結果を設定します。

jp.co.intra_mart.framework.presentation での ServiceResult の使用

ServiceResult を返す jp.co.intra_mart.framework.presentation のメソッド
 ServiceResult RequestInfo.getResult()
サービス処理結果を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の使用

jp.co.intra_mart.framework.base.service.ServiceSecurityFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.ServiceServlet の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceServlet の使用

jp.co.intra_mart.framework.base.service.ServiceServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.ServiceServletException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.ServiceServletException の使用

jp.co.intra_mart.framework.base.service.ServiceServletException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.Transition の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.Transition の使用

Transition を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での Transition の使用

jp.co.intra_mart.framework.base.service での Transition のサブクラス
class | DefaultTransition デフォルトの画面遷移をします。
class | IntramartPageBaseTransition ページベースの画面に遷移する場合に使用するトランジションです。

Transition を返す jp.co.intra_mart.framework.base.service のメソッド
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.TransitionException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.TransitionException の使用

TransitionException を使用しているパッケージ
jp.co.intra_mart.framework.base.service サービスフレームワークに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での TransitionException の使用

TransitionException をスローする jp.co.intra_mart.framework.base.service のメソッド
abstract  String Transition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
abstract  String Transition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
abstract  String Transition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
abstract  void Transition.setInformation()
次の遷移先に渡す情報を設定します。
abstract  String Transition.getNextPage()
次に遷移するページを取得します。
 Transition ServiceManager.getTransition(String application, String service)
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
 Transition ServiceManager.getTransition(String application, String service, Locale locale)
トランジションを取得します。
 String IntramartPageBaseTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String IntramartPageBaseTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 String IntramartPageBaseTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String IntramartPageBaseTransition.getNextPage()
次に遷移するページを取得します。
 void IntramartPageBaseTransition.setInformation()
次の遷移先に渡す情報を設定します。
 String DefaultTransition.getInputErrorPage(RequestException e)
入力エラーのページを取得します。
 String DefaultTransition.getSystemErrorPage(Exception e)
システムエラーのページを取得します。
 String DefaultTransition.getServiceErrorPage(Exception e)
処理エラーのページを取得します。
 void DefaultTransition.setInformation()
次の遷移先に渡す情報を設定します。
 String DefaultTransition.getNextPage()
次に遷移するページを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の使用

jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultServicePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DefaultServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class DefaultServicePropertyHandler
extends Object
implements ServicePropertyHandler

サービスの設定情報に接続するデフォルトのプロパティハンドラです。
プロパティファイルはアプリケーション毎に分割されます。この場合のファイル名は「 プレフィックス _ アプリケーションID .properties」です。また、アプリケーションに依存しない「 プレフィックス .properties」があります。
プロパティファイルのプレフィックスは PropertyManager.getPropertyHandlerParams(String) でキーに ServiceManager.SERVICE_PROPERTY_HANDLER_KEY を指定したときに取得されるパラメータのうち DEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスは DEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「 プレフィックス _ アプリケーションID .properties」が優先されます。該当するプロパティが見つからない場合、引き続いて「 プレフィックス .properties」を検索します。
プロパティの設定内容は以下のとおりです。 プロパティの設定内容は以下のとおりです。

キー | 内容 | 共通 | アプリケーション毎
client.encoding | クライアントのエンコーディング 設定しない場合、リクエストに対する文字コードの変換は行われません。 | ○ | ×
encoding.attribute | ログインユーザのエンコーディングを保存する属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
client.locale | クライアントのロケール クライアントからのリクエストのロケールのデフォルトです。 | ○ | ×
locale.attribute | ログインユーザのロケールを保存する属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
context.path | 非推奨です。このプロパティは設定しないでください。コンテキストパスの取得はjavax.servlet.http.HttpServletRequestのgetContextPathメソッドを使用してください。 コンテキストパス / コンテキストパス で指定します。 パスの指定は必ず"/"で開始してください。（例：/imart） このプロパティは共通のプロパティファイルのみに設定します。 このプロパティが設定されている場合、im-J2EE Frameworkのタグライブラリを使用したときに遷移するWebアプリケーションが変更されます。 | ○ | ×
servlet.path | ServiceServletにマッピングされているパス（必須） / web.xmlで指定したサーブレットのマッピング で指定します。 パスの指定は必ず"/"で開始してください。（例：/ServiceServlet） このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
application.param | アプリケーションIDを引き渡すときに使われる、リクエストのパラメータ名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
service.param | サービスIDを引き渡すときに使われる、リクエストのパラメータ名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
exception.attribute | 例外を例外ページに渡すときの属性名 このプロパティは共通のプロパティファイルのみに設定します。 | ○ | ×
controller.class. サービスID | アプリケーションID と サービスID に対応する ServiceControllerのクラス名 | × | ○
transition.class. サービスID | アプリケーションID と サービスID に対応する Transitionのクラス名 | × | ○
nextpage.path. サービスID . キー | アプリケーションID 、 サービスID と キー に対応する次の遷移先のパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） 遷移先を アプリケーションID と サービスID よりも細かく指定したい場合などに使用します。 | × | ○
nextpage.path. サービスID | アプリケーションID と サービスID に対応する次の遷移先のパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path. サービスID . キー | サービスID と キー に対応する入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path. サービスID | サービスID に対応するデフォルトの入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
input.error.page.path | デフォルトの入力エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○
service.error.page.path. サービスID . キー | サービスID と キー に対応するサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
service.error.page.path. サービスID | サービスID に対応するデフォルトのサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
service.error.page.path | デフォルトのサービス処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○
system.error.page.path. サービスID . キー | サービスID と キー に対応するシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
system.error.page.path. サービスID | サービスID に対応するデフォルトのシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | × | ○
system.error.page.path | デフォルトのシステム処理エラーページのパス コンテキストルートからの相対パスで指定します。（パスの指定は"/"で開始） | ○ | ○

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER
コンストラクタの概要
DefaultServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultServicePropertyHandler

public DefaultServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultTransition (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DefaultTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.DefaultTransition
public class DefaultTransition
extends Transition

デフォルトの画面遷移をします。

バージョン:
1.0

コンストラクタの概要
DefaultTransition()
DefaultTransitionを新規に生成します。
メソッドの概要
String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | getNextPage() 次に遷移するページを取得します。
String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
void | setInformation() 次の遷移先に渡す情報を設定します。
void | transfer() 次のページに遷移します。
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultTransition

public DefaultTransition()
DefaultTransitionを新規に生成します。

メソッドの詳細

getInputErrorPage

public String getInputErrorPage(RequestException e)
                         throws ServicePropertyException,
                                TransitionException
入力エラーのページを取得します。

定義:
クラス Transition 内の getInputErrorPage
パラメータ:
e - 例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public String getSystemErrorPage(Exception e)
                          throws ServicePropertyException,
                                 TransitionException
システムエラーのページを取得します。

定義:
クラス Transition 内の getSystemErrorPage
パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public String getServiceErrorPage(Exception e)
                           throws ServicePropertyException,
                                  TransitionException
処理エラーのページを取得します。

定義:
クラス Transition 内の getServiceErrorPage
パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public void setInformation()
                    throws TransitionException
次の遷移先に渡す情報を設定します。 このクラスでは何も行いません。

定義:
クラス Transition 内の setInformation
例外:
TransitionException - 情報設定時に例外が発生

getNextPage

public String getNextPage()
                   throws ServicePropertyException,
                          TransitionException
次に遷移するページを取得します。

定義:
クラス Transition 内の getNextPage
戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

transfer

public void transfer()
              throws SystemException
次のページに遷移します。 getNextPage()で取得されるページにforwardされます。

定義:
クラス Transition 内の transfer
例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DistributesServicePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス DistributesServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class DistributesServicePropertyHandler
extends Object
implements ServicePropertyHandler

アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
通常時に使用されるサービスプロパティハンドラは default.class で示されるパラメータ名で指定します。 ここで指定されるサービスプロパティハンドラに渡す初期値は、 default.param.パラメータ名 で示されるパラメータ名で指定します。 ある特定のアプリケーションに対して特定のサービスプロパティハンドラを割り当てたい場合、 application.class.アプリケーションID で示されるパラメータ名で指定します。 ここで指定されるサービスプロパティハンドラに渡す初期値は、 application.param.アプリケーションID.パラメータ名 で示されるパラメータ名で指定します。 ファイルが存在するディレクトリ名は PARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
5.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_APPLICATION アプリケーション
static String | PARAM_APPLICATION_CLASS クラス
static String | PARAM_APPLICATION_PARAM パラメータ
static String | PARAM_BUNDLE プロパティファイルのバンドルのパラメータ名
static String | PARAM_DEFAULT デフォルト
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER
コンストラクタの概要
DistributesServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
アプリケーションIDに該当するパラメータ名を取得します。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
サービスIDに該当するパラメータ名を取得します。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DEFAULT

public static final String PARAM_DEFAULT
デフォルト

関連項目:
定数フィールド値

PARAM_APPLICATION

public static final String PARAM_APPLICATION
アプリケーション

関連項目:
定数フィールド値

PARAM_APPLICATION_PARAM

public static final String PARAM_APPLICATION_PARAM
パラメータ

関連項目:
定数フィールド値

PARAM_APPLICATION_CLASS

public static final String PARAM_APPLICATION_CLASS
クラス

関連項目:
定数フィールド値

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値

PARAM_BUNDLE

public static final String PARAM_BUNDLE
プロパティファイルのバンドルのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DistributesServicePropertyHandler

public DistributesServicePropertyHandler()
DefaultServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EncodingFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス EncodingFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.EncodingFilter
すべての実装インタフェース:
Filter
public class EncodingFilter
extends Object
implements Filter

リクエストのエンコードを設定します。 リクエストに対するエンコードは

  1. ServicePropertyHandler.getClientEncoding()で取得されるもの
  2. ServiceManager.getLocale(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse)
の順位で決定されます。

この時に取得されたエンコードはServletRequest.setCharacterEncoding(java.lang.String)に設定され、 さらにHttpSessionが存在すればその中にも設定されます。この場合の属性名はServicePropertyHandler.getEncodingAttributeName()で取得されるものです。

バージョン:
1.0

コンストラクタの概要
EncodingFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのエンコードを設定します。
void | init(FilterConfig filterConfig) エンコーディング用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EncodingFilter

public EncodingFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
エンコーディング用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのエンコードを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FileUploadFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス FileUploadFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.FileUploadFilter
すべての実装インタフェース:
Filter
public class FileUploadFilter
extends Object
implements Filter

ファイルアップロード用にリクエストを変換するフィルタです。 このフィルタは受け取ったリクエストが以下の条件をすべて満たす場合にServiceControllerAdapter.getEntity(String)でアップロードされた内容が取得できるようにします。

  • メソッドが"POST"である
  • ContentTypeが"multipart/form-data"である

    導入されたバージョン:
    3.2

    コンストラクタの概要
    FileUploadFilter()
    メソッドの概要
     void destroy()
    フィルタを破棄します。
     void doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain)
    リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。
     void init(FilterConfig filterConfig)
    ファイルアップロード用のフィルタを初期化します。
    クラス java.lang.Object から継承したメソッド
    clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    コンストラクタの詳細

    FileUploadFilter

    public FileUploadFilter()
    メソッドの詳細

    init

    public void init(FilterConfig filterConfig)
          throws ServletException
    ファイルアップロード用のフィルタを初期化します。

    定義:
    インタフェース Filter 内の init
    パラメータ:
    filterConfig - FilterConfig
    例外:
    ServletException - フィルタ内で例外が発生

    doFilter

    public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
    リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。

    定義:
    インタフェース Filter 内の doFilter
    パラメータ:
    servletRequest - リクエスト
    servletResponse - レスポンス
    filterChain - フィルタ
    例外:
    IOException - フィルタ処理実行時にIOExceptionが発生
    ServletException - フィルタ処理実行時にServletExceptionが発生

    destroy

    public void destroy()
    フィルタを破棄します。

    定義:
    インタフェース Filter 内の destroy
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart(R)
    im-J2EE Framework 5.0
    前のクラス 次のクラス フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
    Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FrameworkParameterSettingFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス FrameworkParameterSettingFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter
すべての実装インタフェース:
Filter
推奨されていません。 このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。

public class FrameworkParameterSettingFilter
extends Object
implements Filter

以前のバージョンのサービスフレームワークが使用していたアプリケーションID及びサービスIDを リクエストのパラメータに設定します。
このフィルタを使用することによりServletRequest.getParameter(String)から アプリケーションID及びサービスIDを取得することができますが、この方法は正しくありません。
正しくは以下のメソッドを使用してください。

ServiceManager.getApplication(HttpServletRequest, HttpServletResponse)
ServiceManager.getService(HttpServletRequest, HttpServletResponse)

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
FrameworkParameterSettingFilter()
推奨されていません。
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 リクエストのパラメーターを設定後、次の処理に遷移します。
void | init(FilterConfig filterConfig) 推奨されていません。 フィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameworkParameterSettingFilter

public FrameworkParameterSettingFilter()
推奨されていません。
メソッドの詳細

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
推奨されていません。
リクエストのパラメーターを設定後、次の処理に遷移します。
パラメータ名は以下のメソッドから取得したものを使用します。
ServicePropertyHandler.getApplicationParamName()
ServicePropertyHandler.getServiceParamName()

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタのチェーン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
フィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - フィルタ設定オブジェクト
例外:
ServletException - フィルタを初期化時に例外が発生。

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartConnectFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.IntramartConnectFilter
すべての実装インタフェース:
Filter
推奨されていません。 この機能は廃止されました。

public class IntramartConnectFilter
extends Object
implements Filter

intra-martのページベースの画面からim-J2EE Frameworkの画面に遷移する時に使うフィルタです。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。 このフィルタで変換されたリクエストはServiceServletで扱えるようになります。

このフィルタは以下の初期化パラメータを設定することができます。

パラメータ名 | パラメータの値
referrerFormat | セッションに登録されるintramartのページベースへの画面に戻るためのURLの書式を決定します。 short（大文字と小文字は区別しない）：URLからプロトコル、ホスト名、ポート番号が省略された形式をセッションに登録 それ以外：パラメータreferrerの内容をそのままセッションに登録
securityExt | セキュリティの有効／無効を設定する拡張子です。 このパラメータが設定されるとセキュリティが有効になります。 ServiceServletに対するURLマッピングは*.拡張子とする必要があります。 拡張子（ドットは含まない）

導入されたバージョン:
4.2

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
static String | PARAM_ARGUMENT 推奨されていません。 ページ引数のリクエストパラメータ名
static String | PARAM_ARGUMENT_DELIMITER 推奨されていません。 ページ引数のデリミタ
static String | PARAM_ARGUMENT_OPERATOR 推奨されていません。 ページ引数の演算子
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 ログイングループIDのリクエストパラメータ名
static String | PARAM_LOGIN_USER_ID 推奨されていません。 ログインユーザIDのリクエストパラメータ名
static String | PARAM_REFERER 推奨されていません。 参照元URLのリクエストパラメータ名
static String | PARAM_SECURITY_EXT 推奨されていません。 セキュリティの拡張子
コンストラクタの概要
IntramartConnectFilter()
推奨されていません。
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。
String | getSecurityExt() 推奨されていません。 セキュリティの拡張子を取得します。
void | init(FilterConfig filterConfig) 推奨されていません。 このフィルタを初期化します。
void | setSecurityExt(String securityExt) 推奨されていません。 セキュリティの拡張子を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。
ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。
ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。
ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。
参照元URLのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT_DELIMITER

public static final String PARAM_ARGUMENT_DELIMITER
推奨されていません。
ページ引数のデリミタ

関連項目:
定数フィールド値

PARAM_ARGUMENT_OPERATOR

public static final String PARAM_ARGUMENT_OPERATOR
推奨されていません。
ページ引数の演算子

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。
セッションに登録するintra-martのサーブレットのURLの属性名

関連項目:
定数フィールド値

PARAM_SECURITY_EXT

public static final String PARAM_SECURITY_EXT
推奨されていません。
セキュリティの拡張子

導入されたバージョン:
4.3
関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectFilter

public IntramartConnectFilter()
推奨されていません。
メソッドの詳細

getSecurityExt

public String getSecurityExt()
推奨されていません。
セキュリティの拡張子を取得します。

戻り値:
セキュリティの拡張子

setSecurityExt

public void setSecurityExt(String securityExt)
推奨されていません。
セキュリティの拡張子を設定します。

パラメータ:
securityExt - セキュリティの拡張子

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
推奨されていません。
intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartConnectServlet (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartConnectServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.base.service.IntramartConnectServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
推奨されていません。 この機能は廃止されました。

public class IntramartConnectServlet
extends HttpServlet

intra-martのページベースの画面からJ2EEベースの画面に遷移する時に使うサーブレットです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
static String | PARAM_ARGUMENT 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
static String | PARAM_ARGUMENT_DELIMITER 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
static String | PARAM_ARGUMENT_OPERATOR 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
static String | PARAM_LOGIN_USER_ID 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
static String | PARAM_REFERER 推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。
コンストラクタの概要
IntramartConnectServlet()
推奨されていません。 IntramartConnectServletを新規に生成します。
メソッドの概要
protected void | doGet(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 GETメソッドに対応します。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 POSTメソッドに対応します。
protected void | execute(HttpServletRequest request, HttpServletResponse response) 推奨されていません。 intra-martベースモジュールのメニューからのリクエストを受け付けます。
protected ServiceManager | getServiceManager() 推奨されていません。 サービスマネージャを取得します。
protected ServicePropertyHandler | getServicePropertyHandler() 推奨されていません。 サービスプロパティハンドラを取得します。
protected SessionManager | getSessionManager() 推奨されていません。 セッションマネージャを取得します。
protected SessionPropertyHandler | getSessionPropertyHandler() 推奨されていません。 セッションプロパティハンドラを取得します。
void | init(ServletConfig servletConfig) 推奨されていません。 このサーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
destroy, getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。

ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。

ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。

ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。

参照元URLのリクエストパラメータ名

導入されたバージョン:
3.2
関連項目:
定数フィールド値

PARAM_ARGUMENT_DELIMITER

public static final String PARAM_ARGUMENT_DELIMITER
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。

ページ引数のデリミタ

関連項目:
定数フィールド値

PARAM_ARGUMENT_OPERATOR

public static final String PARAM_ARGUMENT_OPERATOR
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。

ページ引数の演算子

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。

セッションに登録するintra-martのサーブレットのURLの属性名 （この値はVersion 4.0から変更されています）

導入されたバージョン:
3.2
関連項目:
定数フィールド値
コンストラクタの詳細

IntramartConnectServlet

public IntramartConnectServlet()
推奨されていません。
IntramartConnectServletを新規に生成します。

メソッドの詳細

getServiceManager

protected ServiceManager getServiceManager()
推奨されていません。
サービスマネージャを取得します。

戻り値:
サービスマネージャ

getServicePropertyHandler

protected ServicePropertyHandler getServicePropertyHandler()
推奨されていません。
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getSessionManager

protected SessionManager getSessionManager()
推奨されていません。
セッションマネージャを取得します。

戻り値:
セッションマネージャ

getSessionPropertyHandler

protected SessionPropertyHandler getSessionPropertyHandler()
推奨されていません。
セッションプロパティハンドラを取得します。

戻り値:
セッションプロパティハンドラ

init

public void init(ServletConfig servletConfig)
          throws ServletException
推奨されていません。
このサーブレットを初期化します。

パラメータ:
servletConfig - Servlet Config
例外:
ServletException - 初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
推奨されていません。
GETメソッドに対応します。 詳細はexecute(HttpServletRequest, HttpServletResponse)を参照してください。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
推奨されていません。
POSTメソッドに対応します。 詳細はexecute(HttpServletRequest, HttpServletResponse)を参照してください。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

execute

protected void execute(HttpServletRequest request,
                       HttpServletResponse response)
                throws ServletException,
                       IOException
推奨されていません。
intra-martベースモジュールのメニューからのリクエストを受け付けます。 ページ引数に以下の情報を含める必要があります。
application=<アプリケーションＩＤ>,service=<サービスＩＤ>

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartLocaleFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartLocaleFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.IntramartLocaleFilter
すべての実装インタフェース:
Filter
public class IntramartLocaleFilter
extends Object
implements Filter

セッションにロケールを設定します。
ロケールはクライアントの保持するアクセスセキュリティ情報が優先されます。

アクセスセキュリティ情報からロケールを取得できない場合はServiceManager.getLocale(HttpServletRequest, HttpServletResponse) から取得した値が設定されます。

この時に取得されたロケールはHttpSessionが存在すればその中に設定されます。この場合の属性名はServicePropertyHandler.getLocaleAttributeName()で取得されるものです。

導入されたバージョン:
5.0

コンストラクタの概要
IntramartLocaleFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのロケールを設定します。
void | init(FilterConfig filterConfig) ロケール用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartLocaleFilter

public IntramartLocaleFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
ロケール用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのロケールを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartPageBaseTransition (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス IntramartPageBaseTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
public class IntramartPageBaseTransition
extends Transition

ページベースの画面に遷移する場合に使用するトランジションです。

導入されたバージョン:
3.2

コンストラクタの概要
IntramartPageBaseTransition()
IntramartPageBaseTransitionを新規に生成します。
メソッドの概要
String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
String | getNextPage() 次に遷移するページを取得します。
String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
void | setInformation() 次の遷移先に渡す情報を設定します。
void | transfer() ページベースの画面に遷移します。
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartPageBaseTransition

public IntramartPageBaseTransition()
IntramartPageBaseTransitionを新規に生成します。

メソッドの詳細

getInputErrorPage

public String getInputErrorPage(RequestException e)
                         throws ServicePropertyException,
                                TransitionException
入力エラーのページを取得します。

定義:
クラス Transition 内の getInputErrorPage
パラメータ:
e - 入力時の例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public String getServiceErrorPage(Exception e)
                           throws ServicePropertyException,
                                  TransitionException
処理エラーのページを取得します。

定義:
クラス Transition 内の getServiceErrorPage
パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public String getSystemErrorPage(Exception e)
                          throws ServicePropertyException,
                                 TransitionException
システムエラーのページを取得します。

定義:
クラス Transition 内の getSystemErrorPage
パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getNextPage

public String getNextPage()
                   throws ServicePropertyException,
                          TransitionException
次に遷移するページを取得します。

定義:
クラス Transition 内の getNextPage
戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public void setInformation()
                    throws TransitionException
次の遷移先に渡す情報を設定します。

定義:
クラス Transition 内の setInformation
例外:
TransitionException - 情報設定時に例外が発生

transfer

public void transfer()
              throws SystemException
ページベースの画面に遷移します。 遷移する方法は次のページで要求される形式に依存します。

定義:
クラス Transition 内の transfer
例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LocaleFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス LocaleFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.LocaleFilter
すべての実装インタフェース:
Filter
public class LocaleFilter
extends Object
implements Filter

リクエストのロケールを設定します。 リクエストに対するロケールの決定方法はServiceManager.getLocale(HttpServletRequest, HttpServletResponse)と同じです。

この時に取得されたロケールはHttpSessionが存在すればその中に設定されます。この場合の属性名はServicePropertyHandler.getLocaleAttributeName()で取得されるものです。

導入されたバージョン:
4.2

コンストラクタの概要
LocaleFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのロケールを設定します。
void | init(FilterConfig filterConfig) ロケール用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LocaleFilter

public LocaleFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
ロケール用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのロケールを設定します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.service (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.service
インタフェース
ServiceController
ServicePropertyHandler
ServiceResult
クラス
DefaultServicePropertyHandler
DefaultTransition
DistributesServicePropertyHandler
EncodingFilter
FileUploadFilter
FrameworkParameterSettingFilter
IntramartConnectFilter
IntramartConnectServlet
IntramartLocaleFilter
IntramartPageBaseTransition
LocaleFilter
ServiceControllerAdapter
ServiceManager
ServiceSecurityFilter
ServiceServlet
TextFileServicePropertyHandler
Transition
XmlServicePropertyHandler
例外
RequestException
ServiceControllerException
ServiceManagerException
ServicePropertyException
ServiceServletException
TransitionException


jp.co.intra_mart.framework.base.service (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service

サービスフレームワークに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
ServiceController | クライアントからの入力に対する処理を行います。
ServicePropertyHandler | サービスの設定情報に接続するクラスです。
ServiceResult | サービスの処理結果です。

クラスの概要
DefaultServicePropertyHandler | サービスの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultTransition | デフォルトの画面遷移をします。
DistributesServicePropertyHandler | アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
EncodingFilter | リクエストのエンコードを設定します。
FileUploadFilter | ファイルアップロード用にリクエストを変換するフィルタです。
FrameworkParameterSettingFilter | 推奨されていません。 このフィルタは下位互換のためのフィルタです。
IntramartConnectFilter | 推奨されていません。 この機能は廃止されました。
IntramartConnectServlet | 推奨されていません。 この機能は廃止されました。
IntramartLocaleFilter | セッションにロケールを設定します。
IntramartPageBaseTransition | ページベースの画面に遷移する場合に使用するトランジションです。
LocaleFilter | リクエストのロケールを設定します。
ServiceControllerAdapter | いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。
ServiceManager | サービスマネージャです。
ServiceSecurityFilter | intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。
ServiceServlet | サービスを振り分けるサーブレットです。
TextFileServicePropertyHandler | 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
Transition | 画面遷移に関連するクラスのインタフェースです。
XmlServicePropertyHandler | サービスの設定情報に接続するプロパティハンドラです。

例外の概要
RequestException | リクエストの内容に関連する間違いがある場合の例外です。
ServiceControllerException | サービスコントローラに関連する例外です。
ServiceManagerException | サービスマネージャ設定時の例外です。
ServicePropertyException | サービスプロパティ取得時の例外です。
ServiceServletException | サービスに関連する例外です。
TransitionException | トランジションに関連する例外です。

パッケージ jp.co.intra_mart.framework.base.service の説明

サービスフレームワークに関連するクラスのパッケージです。 画面からのアクション（Submit、リンク等）に対して処理や画面遷移の制御をします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.service クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.EncodingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.FileUploadFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter (implements javax.servlet.Filter)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.framework.base.service.IntramartConnectServlet
        • class jp.co.intra_mart.framework.base.service.ServiceServlet
    • class jp.co.intra_mart.framework.base.service.IntramartConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.LocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
    • class jp.co.intra_mart.framework.base.service.ServiceManager
    • class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.base.service.RequestException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.service.ServiceControllerException
            • class jp.co.intra_mart.framework.base.service.ServiceManagerException
            • class jp.co.intra_mart.framework.base.service.ServicePropertyException
            • class jp.co.intra_mart.framework.base.service.ServiceServletException
            • class jp.co.intra_mart.framework.base.service.TransitionException
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
      • class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
    • class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler
  • interface jp.co.intra_mart.framework.base.service.ServiceController
  • interface jp.co.intra_mart.framework.base.service.ServiceResult
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.service の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.service の使用

jp.co.intra_mart.framework.base.service を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.service のクラス
RequestException
リクエストの内容に関連する間違いがある場合の例外です。
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerException
サービスコントローラに関連する例外です。
ServiceManager
サービスマネージャです。
ServiceManagerException
サービスマネージャ設定時の例外です。
ServicePropertyException
サービスプロパティ取得時の例外です。
ServicePropertyHandler
サービスの設定情報に接続するクラスです。
ServiceResult
サービスの処理結果です。
Transition
画面遷移に関連するクラスのインタフェースです。
TransitionException
トランジションに関連する例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.service のクラス
ServicePropertyHandler
サービスの設定情報に接続するクラスです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceResult
サービスの処理結果です。

jp.co.intra_mart.framework.presentation.service により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceController
クライアントからの入力に対する処理を行います。
ServiceControllerAdapter
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.base.service のクラス
ServiceControllerException
サービスコントローラに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


RequestException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス RequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.base.service.RequestException
すべての実装インタフェース:
Serializable
public class RequestException
extends ApplicationException

リクエストの内容に関連する間違いがある場合の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
RequestException()
詳細メッセージを指定しないで RequestException を構築します。
RequestException(String msg)
指定された詳細メッセージを持つ RequestException を構築します。
RequestException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestException

public RequestException()
詳細メッセージを指定しないで RequestException を構築します。

RequestException

public RequestException(String msg)
指定された詳細メッセージを持つ RequestException を構築します。

パラメータ:
msg - 詳細メッセージ

RequestException

public RequestException(String msg,
                        Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceController (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServiceController

既知の実装クラスの一覧:
ServiceControllerAdapter
public interface ServiceController

クライアントからの入力に対する処理を行います。

バージョン:
1.0

メソッドの概要
void | check() 入力内容をチェックします。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | service() 入力に対する処理を実行します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。

メソッドの詳細

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

check

public void check()
           throws RequestException,
                  SystemException
入力内容をチェックします。

例外:
RequestException - 入力内容に誤りがある
SystemException - チェック時にシステム例外が発生

service

public ServiceResult service()
                      throws SystemException,
                             ApplicationException
入力に対する処理を実行します。

戻り値:
処理結果
例外:
SystemException - 処理実行時にシステム例外が発生
ApplicationException - 処理実行時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceControllerAdapter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceControllerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerAdapter
すべての実装インタフェース:
ServiceController
直系の既知のサブクラス:
PresentationServiceController
public class ServiceControllerAdapter
extends Object
implements ServiceController

いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。 このクラスにはいくつかのユーティリティメソッドがあります。 このクラスを継承し、必要に応じてcheck()やservice()を実装することでコーディング量を減らすことが可能です。

バージョン:
1.0

コンストラクタの概要
ServiceControllerAdapter()
ServiceControllerAdapterを新規に生成します。
メソッドの概要
void | check() 入力内容をチェックします。
protected Event | createEvent(String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity | getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
UserInfo | getUserInfo() ユーザ情報を取得します。
ServiceResult | service() 入力に対する処理を実行します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceControllerAdapter

public ServiceControllerAdapter()
ServiceControllerAdapterを新規に生成します。

メソッドの詳細

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

定義:
インタフェース ServiceController 内の setRequest
パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

定義:
インタフェース ServiceController 内の getRequest
戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

定義:
インタフェース ServiceController 内の setResponse
パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

定義:
インタフェース ServiceController 内の getResponse
戻り値:
レスポンス

getEntity

public jp.co.intra_mart.foundation.http.MultipartFormData.Entity getEntity(String name)
                                                                    throws SystemException
リクエストから指定された名前に該当するエンティティを取得します。 このメソッドは、ファイルアップロード時にその内容を取得する場合などに使用します。 このメソッドは、ファイルアップロードのリクエストが送られた場合のみ使用できます。 それ以外のリクエストが送られた場合にこのメソッドを呼ぶと例外が発生します。

パラメータ:
name - パラメータ名
戻り値:
パラメータ名に該当するエンティティ
例外:
SystemException - エンティティの取得に失敗
導入されたバージョン:
3.2

check

public void check()
           throws RequestException,
                  SystemException
入力内容をチェックします。

定義:
インタフェース ServiceController 内の check
例外:
RequestException - 入力内容に誤りがある
SystemException - チェック時にシステム例外が発生

service

public ServiceResult service()
                      throws SystemException,
                             ApplicationException
入力に対する処理を実行します。 このサービスコントローラでは何もせず、nullを返します。

定義:
インタフェース ServiceController 内の service
戻り値:
処理結果(null)
例外:
SystemException - 処理実行時にシステム例外が発生
ApplicationException - 処理実行時にアプリケーション例外が発生

getLoginUserID

public String getLoginUserID()
                      throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
例外:
ServiceControllerException - ログインユーザID取得時に例外が発生

getLoginGroupID

public String getLoginGroupID()
                       throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
例外:
ServiceControllerException - ログイングループID取得時に例外が発生

getUserInfo

public UserInfo getUserInfo()
                     throws ServiceControllerException
ユーザ情報を取得します。

戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ユーザ情報取得時に例外が発生
導入されたバージョン:
5.0

createEvent

protected Event createEvent(String application,
                            String key)
                     throws ServiceControllerException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
ServiceControllerException - イベント取得時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceControllerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceControllerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerException
すべての実装インタフェース:
Serializable
public class ServiceControllerException
extends SystemException

サービスコントローラに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceControllerException()
詳細メッセージを指定しないで ServiceControllerException を構築します。
ServiceControllerException(String msg)
指定された詳細メッセージを持つ ServiceControllerException を構築します。
ServiceControllerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceControllerException

public ServiceControllerException()
詳細メッセージを指定しないで ServiceControllerException を構築します。

ServiceControllerException

public ServiceControllerException(String msg)
指定された詳細メッセージを持つ ServiceControllerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceControllerException

public ServiceControllerException(String msg,
                                  Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceManager
public class ServiceManager
extends Object

サービスマネージャです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_SERVICE_EXTENSION サービスフレームワークをコールするためのデフォルトの拡張子
static String | SERVICE_EXTENSION_KEY 拡張子を指定するキー
static String | SERVICE_PROPERTY_HANDLER_KEY サービスプロパティハンドラのキー
メソッドの概要
String | getApplication(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するアプリケーションIDを取得します。
String | getEncoding(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するエンコーディングを取得します。
String | getExtesion() サービスフレームワークを呼び出すための拡張子を取得します。
Locale | getLocale(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するロケールを取得します。
String | getService(HttpServletRequest request, HttpServletResponse response) 現在のリクエストに対するサービスIDを取得します。
ServiceController | getServiceController(String application, String service) 推奨されていません。 このメソッドではなくgetServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
ServiceController | getServiceController(String application, String service, Locale locale) サービスコントローラを取得します。
static ServiceManager | getServiceManager() サービスマネージャを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
Transition | getTransition(String application, String service) 推奨されていません。 このメソッドではなくgetTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
Transition | getTransition(String application, String service, Locale locale) トランジションを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SERVICE_PROPERTY_HANDLER_KEY

public static final String SERVICE_PROPERTY_HANDLER_KEY
サービスプロパティハンドラのキー

関連項目:
定数フィールド値

SERVICE_EXTENSION_KEY

public static final String SERVICE_EXTENSION_KEY
拡張子を指定するキー

導入されたバージョン:
5.0
関連項目:
getExtesion(), 定数フィールド値

DEFAULT_SERVICE_EXTENSION

public static final String DEFAULT_SERVICE_EXTENSION
サービスフレームワークをコールするためのデフォルトの拡張子

導入されたバージョン:
5.0
関連項目:
getExtesion(), 定数フィールド値
メソッドの詳細

getServiceManager

public static ServiceManager getServiceManager()
                                        throws ServiceManagerException
サービスマネージャを取得します。

戻り値:
サービスマネージャ
例外:
ServiceManagerException - サービスマネージャの生成に失敗した

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ

getServiceController

public ServiceController getServiceController(String application,
                                              String service)
                                       throws ServicePropertyException,
                                              ServiceControllerException
推奨されていません。 このメソッドではなくgetServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。

サービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceController(application, service, null)を呼んだときと同じ結果を返します。

パラメータ:
application - アプリケーション
service - サービス
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生

getServiceController

public ServiceController getServiceController(String application,
                                              String service,
                                              Locale locale)
                                       throws ServicePropertyException,
                                              ServiceControllerException
サービスコントローラを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するサービスコントローラを取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
サービスコントローラ、存在しない場合はnull
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
ServiceControllerException - サービスコントローラ取得時に例外が発生
導入されたバージョン:
4.2

getTransition

public Transition getTransition(String application,
                                String service)
                         throws ServicePropertyException,
                                TransitionException
推奨されていません。 このメソッドではなくgetTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。

トランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。 このメソッドはgetTransition(application, service, null)を呼んだときと同じ結果を返します。

パラメータ:
application - アプリケーション
service - サービス
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生

getTransition

public Transition getTransition(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException,
                                TransitionException
トランジションを取得します。 指定されたアプリケーションID、サービスID、ロケールに該当するトランジションを取得します。 該当するトランジションが存在しない場合、DefaultTransitionを返します。

パラメータ:
application - アプリケーション
service - サービス
locale - ロケール
戻り値:
トランジション
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
TransitionException - トランジション取得時に例外が発生
導入されたバージョン:
4.2

getApplication

public String getApplication(HttpServletRequest request,
                             HttpServletResponse response)
                      throws ServicePropertyException
現在のリクエストに対するアプリケーションIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
現在のリクエストに対するアプリケーションID
例外:
ServicePropertyException - アプリケーションID取得時に例外が発生
導入されたバージョン:
4.2

getService

public String getService(HttpServletRequest request,
                         HttpServletResponse response)
                  throws ServicePropertyException
現在のリクエストに対するサービスIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
現在のリクエストに対するサービスID
例外:
ServicePropertyException - サービスID取得時に例外が発生
導入されたバージョン:
4.2

getLocale

public Locale getLocale(HttpServletRequest request,
                        HttpServletResponse response)
                 throws ServicePropertyException
現在のリクエストに対するロケールを取得します。 ロケールの取得は以下の優先順位に従います。
  1. セッション内のServicePropertyHandler.getLocaleAttributeName()で取得される属性名で登録されたロケール
  2. ServicePropertyHandler.getClientLocale()で取得されるロケール
  3. ServletRequest.getLocale()で取得されるロケール
  4. Locale.getDefault()で取得されるロケール

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ロケール
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
導入されたバージョン:
4.2

getEncoding

public String getEncoding(HttpServletRequest request,
                          HttpServletResponse response)
                   throws ServicePropertyException
現在のリクエストに対するエンコーディングを取得します。 エンコーディングの取得は以下の優先順位に従います。
  1. セッション内のServicePropertyHandler.getEncodingAttributeName()で取得される属性名で登録されたエンコーディング
  2. ServicePropertyHandler.getClientEncoding()で取得されるエンコーディング
  3. ServletRequest.getCharacterEncoding()で取得されるエンコーディング
  4. null

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
エンコーディング
例外:
ServicePropertyException - サービスプロパティの取得時に例外が発生
導入されたバージョン:
4.2

getExtesion

public String getExtesion()
                   throws ServiceManagerException
サービスフレームワークを呼び出すための拡張子を取得します。
#SERVICE_EXTESION_KEYをキーとしたシステムプロパティを検索し、 存在しない場合は#DEFAULT_SERVICE_EXTを返却します。

戻り値:
サービスフレームワークを呼び出すための拡張子
例外:
ServiceManagerException
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceManagerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceManagerException
すべての実装インタフェース:
Serializable
public class ServiceManagerException
extends SystemException

サービスマネージャ設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceManagerException()
詳細メッセージを指定しないで ServiceManagerException を構築します。
ServiceManagerException(String msg)
指定された詳細メッセージを持つ ServiceManagerException を構築します。
ServiceManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceManagerException

public ServiceManagerException()
詳細メッセージを指定しないで ServiceManagerException を構築します。

ServiceManagerException

public ServiceManagerException(String msg)
指定された詳細メッセージを持つ ServiceManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceManagerException

public ServiceManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServicePropertyException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServicePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServicePropertyException
すべての実装インタフェース:
Serializable
public class ServicePropertyException
extends SystemException

サービスプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServicePropertyException()
詳細メッセージを指定しないで ServicePropertyException を構築します。
ServicePropertyException(String msg)
指定された詳細メッセージを持つ ServicePropertyException を構築します。
ServicePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServicePropertyException

public ServicePropertyException()
詳細メッセージを指定しないで ServicePropertyException を構築します。

ServicePropertyException

public ServicePropertyException(String msg)
指定された詳細メッセージを持つ ServicePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

ServicePropertyException

public ServicePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServicePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServicePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultServicePropertyHandler, DistributesServicePropertyHandler, TextFileServicePropertyHandler, XmlServicePropertyHandler
public interface ServicePropertyHandler
extends PropertyHandler

サービスの設定情報に接続するクラスです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_APPLICATION_PARAMETER 推奨されていません。 この実装は廃止されました。
static String | DEFAULT_ENCODING_ATTRIBUTE ログインユーザのエンコーディングのデフォルトの属性名
static String | DEFAULT_EXCEPTION_ATTRIBUTE 例外属性のデフォルトの属性名
static String | DEFAULT_LOCALE_ATTRIBUTE ログインユーザのロケールのデフォルトの属性名
static String | DEFAULT_SERVICE_PARAMETER 推奨されていません。 この実装は廃止されました。
メソッドの概要
String | getApplicationParamName() 推奨されていません。 この実装は廃止されました。
String | getClientEncoding() クライアントのエンコードを取得します。
Locale | getClientLocale() クライアントのロケールを取得します。
String | getContextPath() 推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
String | getEncodingAttributeName() ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
String | getExceptionAttributeName() 例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
String | getInputErrorPagePath() 推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。
String | getInputErrorPagePath(Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。
String | getInputErrorPagePath(String application, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, String key, Locale locale) 入力例外時のページのパスを取得します。
String | getLocaleAttributeName() ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
String | getNextPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, Locale locale) 遷移先のページのパスを取得します。
String | getNextPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, String key, Locale locale) 遷移先のページのパスを取得します。
String | getServiceControllerName(String application, String service) 推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。
String | getServiceControllerName(String application, String service, Locale locale) サービスコントローラのクラス名を取得します。
String | getServiceErrorPagePath() 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。
String | getServiceErrorPagePath(Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, String key, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceParamName() 推奨されていません。 この実装は廃止されました。
String | getServiceServletPath() 推奨されていません。 この実装は廃止されました。
String | getSystemErrorPagePath() 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。
String | getSystemErrorPagePath(Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, String key, Locale locale) システム例外時のページのパスを取得します。
String | getTransitionName(String application, String service) 推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。
String | getTransitionName(String application, String service, Locale locale) トランジションのクラス名を取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

フィールドの詳細

DEFAULT_APPLICATION_PARAMETER

public static final String DEFAULT_APPLICATION_PARAMETER
推奨されていません。 この実装は廃止されました。

アプリケーションIDのデフォルトのパラメータ名

関連項目:
定数フィールド値

DEFAULT_SERVICE_PARAMETER

public static final String DEFAULT_SERVICE_PARAMETER
推奨されていません。 この実装は廃止されました。

サービスIDのデフォルトのパラメータ名

関連項目:
定数フィールド値

DEFAULT_EXCEPTION_ATTRIBUTE

public static final String DEFAULT_EXCEPTION_ATTRIBUTE
例外属性のデフォルトの属性名

関連項目:
定数フィールド値

DEFAULT_ENCODING_ATTRIBUTE

public static final String DEFAULT_ENCODING_ATTRIBUTE
ログインユーザのエンコーディングのデフォルトの属性名

関連項目:
定数フィールド値

DEFAULT_LOCALE_ATTRIBUTE

public static final String DEFAULT_LOCALE_ATTRIBUTE
ログインユーザのロケールのデフォルトの属性名

関連項目:
定数フィールド値
メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
ServicePropertyException - チェック時に例外が発生
導入されたバージョン:
3.2

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのロケールを取得します。

戻り値:
クライアントのロケール（設定されていない場合はnull）
例外:
ServicePropertyException - クライアントのロケールの取得時に例外が発生
導入されたバージョン:
4.2

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します。

戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドはgetNextPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。 このメソッドはgetNextPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドはgetInputErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。

処理例外時のページのパスを取得します。 このメソッドはgetServiceErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。

パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドはgetSystemErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceControllerName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドはgetTransitionName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になるように実装される必要があります。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスサーブレットのパスを取得します。

戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

戻り値:
コンテキストパス(設定されていない場合はnull)
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、DEFAULT_APPLICATION_PARAMETERで定義されている値を返します。

戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。

戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceResult (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
インタフェース ServiceResult

public interface ServiceResult

サービスの処理結果です。

バージョン:
1.0

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceSecurityFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceSecurityFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceSecurityFilter
すべての実装インタフェース:
Filter
public class ServiceSecurityFilter
extends Object
implements Filter

intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。 このフィルタは次の初期化パラメータを設定する必要があります。

パラメータ名 | 値
error-page | セキュリティ違反時に遷移するページのパス。 コンテキストパスからの相対パスで指定する必要がある。 パスの先頭は"/"で指定する。

このフィルタを設定する場合、ServiceServletは拡張子によるマッピングが行われる必要があります。

導入されたバージョン:
4.3

フィールドの概要
static String | ID_SERVICE_SECURITY_FILTER リクエストに登録するServiceServletFilterの属性名
static String | PARAM_ERROR_PAGE エラーページパスのパラメータ名
コンストラクタの概要
ServiceSecurityFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) sessionに登録された情報と、parameterの情報を比較します。
void | init(FilterConfig filterConfig) このフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SERVICE_SECURITY_FILTER

public static final String ID_SERVICE_SECURITY_FILTER
リクエストに登録するServiceServletFilterの属性名

関連項目:
定数フィールド値

PARAM_ERROR_PAGE

public static final String PARAM_ERROR_PAGE
エラーページパスのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

ServiceSecurityFilter

public ServiceSecurityFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
sessionに登録された情報と、parameterの情報を比較します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceServlet (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.base.service.ServiceServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class ServiceServlet
extends HttpServlet

サービスを振り分けるサーブレットです。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
static String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ
コンストラクタの概要
ServiceServlet()
ServiceServletを新規に生成します。
メソッドの概要
void | destroy() サーブレットを解放します。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) GETメソッドに対するサービスを行います。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) POSTメソッドに対するサービスを行います。
void | init(ServletConfig servletConfig) サーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REQUEST_SEPARATOR

public static final String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ

導入されたバージョン:
5.0
関連項目:
定数フィールド値
コンストラクタの詳細

ServiceServlet

public ServiceServlet()
ServiceServletを新規に生成します。

メソッドの詳細

init

public void init(ServletConfig servletConfig)
          throws ServletException
サーブレットを初期化します。

パラメータ:
servletConfig - ServletConfig
例外:
ServletException - サーブレット初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
GETメソッドに対するサービスを行います。 このメソッドでは対応するサービスコントローラを呼び、次の画面に遷移します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
POSTメソッドに対するサービスを行います。 このメソッドでは対応するサービスコントローラを呼び、次の画面に遷移します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - サーブレット例外が発生
IOException - 入出力例外が発生

destroy

public void destroy()
サーブレットを解放します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceServletException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス ServiceServletException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.ServiceServletException
すべての実装インタフェース:
Serializable
public class ServiceServletException
extends SystemException

サービスに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceServletException()
詳細メッセージを指定しないで ServiceServletException を構築します。
ServiceServletException(String msg)
指定された詳細メッセージを持つ ServiceServletException を構築します。
ServiceServletException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceServletException

public ServiceServletException()
詳細メッセージを指定しないで ServiceServletException を構築します。

ServiceServletException

public ServiceServletException(String msg)
指定された詳細メッセージを持つ ServiceServletException を構築します。

パラメータ:
msg - 詳細メッセージ

ServiceServletException

public ServiceServletException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


TextFileServicePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス TextFileServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class TextFileServicePropertyHandler
extends Object
implements ServicePropertyHandler

指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。 ファイルの書式はDefaultServicePropertyHandlerで示されるものと同じです。
ファイルが存在するディレクトリ名はPARAM_FILE_DIRで示されるパラメータ名で指定します。
PARAM_DYNAMICで示されるパラメータにtrueを指定した場合 アプリケーション実行時にもプロパティの変更を動的に反映させることが可能となりますが、 パラメータの取得時に毎回ファイル操作を行うためパフォーマンスに悪影響を与える可能性があります。 このオプションは、開発時やデバッグ時のようにパラメータを頻繁に変更する必要がある場合のみtrueとし、 通常はfalseに設定しておいてください。

導入されたバージョン:
3.2

フィールドの概要
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
static String | PARAM_FILE_DIR プロパティファイルのファイルパスのパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER
コンストラクタの概要
TextFileServicePropertyHandler()
TextFileServicePropertyHandlerを新規に生成します。
メソッドの概要
String | getApplicationParamName() 推奨されていません。 この実装は廃止されました。
String | getClientEncoding() クライアントのエンコードを取得します。
Locale | getClientLocale() クライアントのロケールを取得します。
String | getContextPath() 推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
String | getEncodingAttributeName() ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
String | getExceptionAttributeName() 例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
String | getInputErrorPagePath() 推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。
String | getInputErrorPagePath(Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。
String | getInputErrorPagePath(String application, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, Locale locale) 入力例外時のページのパスを取得します。
String | getInputErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。
String | getInputErrorPagePath(String application, String service, String key, Locale locale) 入力例外時のページのパスを取得します。
String | getLocaleAttributeName() ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
String | getNextPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, Locale locale) 遷移先のページのパスを取得します。
String | getNextPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。
String | getNextPagePath(String application, String service, String key, Locale locale) 遷移先のページのパスを取得します。
String | getServiceControllerName(String application, String service) 推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。
String | getServiceControllerName(String application, String service, Locale locale) サービスコントローラのクラス名を取得します。
String | getServiceErrorPagePath() 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。
String | getServiceErrorPagePath(Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。
String | getServiceErrorPagePath(String application, String service, String key, Locale locale) 処理例外時のページのパスを取得します。
String | getServiceParamName() 推奨されていません。 この実装は廃止されました。
String | getServiceServletPath() サービスサーブレットのパスを取得します。
String | getSystemErrorPagePath() 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。
String | getSystemErrorPagePath(Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, Locale locale) システム例外時のページのパスを取得します。
String | getSystemErrorPagePath(String application, String service, String key) 推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。
String | getSystemErrorPagePath(String application, String service, String key, Locale locale) システム例外時のページのパスを取得します。
String | getTransitionName(String application, String service) 推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。
String | getTransitionName(String application, String service, Locale locale) トランジションのクラス名を取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
boolean | isDynamic() 再設定可能かどうかをチェックします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_FILE_DIR

public static final String PARAM_FILE_DIR
プロパティファイルのファイルパスのパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

TextFileServicePropertyHandler

public TextFileServicePropertyHandler()
TextFileServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
再設定可能かどうかをチェックします。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
true 再設定可能、false 再設定不可

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのロケールを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのロケール
例外:
ServicePropertyException - クライアントのロケールの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドはgetNextPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなくgetNextPagePath(String, String, String, Locale)を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。 このメソッドはgetNextPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。keyがnullの場合、getNextPagePath(String, String)と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(String, Locale)を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。 このメソッドはgetInputErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getInputErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなくgetInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドはgetInputErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(String, Locale)を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。 このメソッドはgetServiceErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceErrorPagePath(Locale)を使用してください。

処理例外時のページのパスを取得します。 このメソッドはgetServiceErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, key, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(String, Locale)を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。 このメソッドはgetSystemErrorPagePath(application, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなくgetSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドはgetSystemErrorPagePath((java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生
導入されたバージョン:
4.2

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなくgetServiceControllerName(String, String, Locale)を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドはgetServiceControllerName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなくgetTransitionName(String, String, Locale)を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドはgetTransitionName(application, service, (java.util.Locale)null)を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生
導入されたバージョン:
4.2

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
導入されたバージョン:
4.2
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Transition (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス Transition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
直系の既知のサブクラス:
DefaultTransition, IntramartPageBaseTransition
public abstract class Transition
extends Object

画面遷移に関連するクラスのインタフェースです。

バージョン:
1.0

コンストラクタの概要
Transition()
Transitionを新規に生成します。
メソッドの概要
protected String | getApplication() アプリケーションIDを取得します。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity | getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
abstract String | getInputErrorPage(RequestException e) 入力エラーのページを取得します。
abstract String | getNextPage() 次に遷移するページを取得します。
protected String | getNextPagePath() このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
protected String | getNextPagePath(String key) このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | getResult() サービス処理結果を取得します。
protected String | getService() サービスIDを取得します。
abstract String | getServiceErrorPage(Exception e) 処理エラーのページを取得します。
protected ServiceManager | getServiceManager() サービスマネージャを取得します。
SessionObject | getSessionObject() 推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
abstract String | getSystemErrorPage(Exception e) システムエラーのページを取得します。
abstract void | setInformation() 次の遷移先に渡す情報を設定します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
void | setResult(ServiceResult result) サービス処理結果を設定します。
protected void | setServiceManager(ServiceManager manager) サービスマネージャを設定します。
abstract void | transfer() 次のページに遷移します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Transition

public Transition()
Transitionを新規に生成します。

メソッドの詳細

setServiceManager

protected void setServiceManager(ServiceManager manager)
サービスマネージャを設定します。

パラメータ:
manager - サービスマネージャ

getServiceManager

protected ServiceManager getServiceManager()
サービスマネージャを取得します。

戻り値:
サービスマネージャ

getApplication

protected String getApplication()
アプリケーションIDを取得します。

戻り値:
アプリケーションID

getService

protected String getService()
サービスIDを取得します。

戻り値:
サービスID

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getEntity

public jp.co.intra_mart.foundation.http.MultipartFormData.Entity getEntity(String name)
                                                                    throws SystemException
リクエストから指定された名前に該当するエンティティを取得します。 このメソッドは、ファイルアップロード時にその内容を取得する場合などに使用します。 このメソッドは、ファイルアップロードのリクエストが送られた場合のみ使用できます。 それ以外のリクエストが送られた場合にこのメソッドを呼ぶと例外が発生します。

パラメータ:
name - パラメータ名
戻り値:
パラメータ名に該当するエンティティ
例外:
SystemException - エンティティの取得に失敗
導入されたバージョン:
3.2

getSessionObject

public SessionObject getSessionObject()
                               throws SessionManagerException,
                                      SessionPropertyException,
                                      SessionFactoryException
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

セッションオブジェクトを取得します。

戻り値:
セッションオブジェクト
例外:
SessionManagerException - セッションマネージャの取得時に例外が発生
SessionPropertyException - セッションのプロパティ情報取得時に例外が発生
SessionFactoryException - セッションオブジェクトの生成時に例外が発生

setResult

public void setResult(ServiceResult result)
サービス処理結果を設定します。

パラメータ:
result - サービス処理結果

getResult

public ServiceResult getResult()
サービス処理結果を取得します。

戻り値:
サービス処理結果

getNextPagePath

protected String getNextPagePath()
                          throws ServicePropertyException
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。

戻り値:
次ページのパス
例外:
ServicePropertyException - プロパティの取得時に例外が発生

getNextPagePath

protected String getNextPagePath(String key)
                          throws ServicePropertyException
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。

パラメータ:
key - キー
戻り値:
次ページのパス
例外:
ServicePropertyException - プロパティの取得時に例外が発生

getInputErrorPage

public abstract String getInputErrorPage(RequestException e)
                                  throws ServicePropertyException,
                                         TransitionException
入力エラーのページを取得します。

パラメータ:
e - 入力時の例外
戻り値:
入力エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getSystemErrorPage

public abstract String getSystemErrorPage(Exception e)
                                   throws ServicePropertyException,
                                          TransitionException
システムエラーのページを取得します。

パラメータ:
e - 処理時の例外
戻り値:
システムエラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

getServiceErrorPage

public abstract String getServiceErrorPage(Exception e)
                                    throws ServicePropertyException,
                                           TransitionException
処理エラーのページを取得します。

パラメータ:
e - 処理時の例外
戻り値:
処理エラーページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

setInformation

public abstract void setInformation()
                             throws TransitionException
次の遷移先に渡す情報を設定します。

例外:
TransitionException - 情報設定時に例外が発生

getNextPage

public abstract String getNextPage()
                            throws ServicePropertyException,
                                   TransitionException
次に遷移するページを取得します。

戻り値:
次に遷移するページ
例外:
ServicePropertyException - 遷移ページ取得時にサービスプロパティ例外が発生
TransitionException - 遷移ページ取得時に例外が発生

transfer

public abstract void transfer()
                       throws SystemException
次のページに遷移します。 遷移する方法は次のページで要求される形式に依存します。

例外:
SystemException - システム例外が発生
導入されたバージョン:
3.2
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


TransitionException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス TransitionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.service.TransitionException
すべての実装インタフェース:
Serializable
public class TransitionException
extends SystemException

トランジションに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
TransitionException()
詳細メッセージを指定しないで TransitionException を構築します。
TransitionException(String msg)
指定された詳細メッセージを持つ TransitionException を構築します。
TransitionException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TransitionException

public TransitionException()
詳細メッセージを指定しないで TransitionException を構築します。

TransitionException

public TransitionException(String msg)
指定された詳細メッセージを持つ TransitionException を構築します。

パラメータ:
msg - 詳細メッセージ

TransitionException

public TransitionException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


XmlServicePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.service
クラス XmlServicePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler
すべての実装インタフェース:
PropertyHandler, ServicePropertyHandler
public class XmlServicePropertyHandler
extends Object
implements ServicePropertyHandler

サービスの設定情報に接続するプロパティハンドラです。
XML形式で記述されたプロパティ情報を読み取ります。XMLファイルはアプリケーション毎に分割されます。この場合のファイル名は「 プレフィックス _ アプリケーションID .xml」です。また、アプリケーションに依存しない「 プレフィックス .xml」があります。
XMLファイルのプレフィックスは PropertyManager.getPropertyHandlerParams(String) でキーに ServiceManager.SERVICE_PROPERTY_HANDLER_KEY を指定したときに取得されるパラメータのうち DEFAULT_BUNDLE_NAMEで取得されるものとなります。 指定しなかった場合のプロパティファイルのプレフィックスは DEFAULT_BUNDLE_NAME_PARAMで示されるものです。
プロパティの検索順は、アプリケーションごとのプロパティファイル「 プレフィックス _ アプリケーションID .xml」が優先されます。該当するプロパティが見つからない場合、引き続いて「 プレフィックス .xml」を検索します。

導入されたバージョン:
5.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名のプレフィックス
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
static String | PARAM_DYNAMIC プロパティファイルの再読み込み可能のパラメータ名
インタフェース jp.co.intra_mart.framework.base.service.ServicePropertyHandler から継承したフィールド
DEFAULT_APPLICATION_PARAMETER, DEFAULT_ENCODING_ATTRIBUTE, DEFAULT_EXCEPTION_ATTRIBUTE, DEFAULT_LOCALE_ATTRIBUTE, DEFAULT_SERVICE_PARAMETER
コンストラクタの概要
XmlServicePropertyHandler()
XmlServicePropertyHandlerを新規に生成します。
メソッドの概要
 String getApplicationParamName()
推奨されていません。 この実装は廃止されました。
 String getClientEncoding()
クライアントのエンコードを取得します。
 Locale getClientLocale()
クライアントのエンコードを取得します。
 String getContextPath()
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
 String getEncodingAttributeName()
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
 String getExceptionAttributeName()
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
 String getInputErrorPagePath()
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。
 String getInputErrorPagePath(Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。
 String getInputErrorPagePath(String application, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, Locale locale)
入力例外時のページのパスを取得します。
 String getInputErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。
 String getInputErrorPagePath(String application, String service, String key, Locale locale)
入力例外時のページのパスを取得します。
 String getLocaleAttributeName()
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
 String getNextPagePath(String application, String service)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, Locale locale)
遷移先のページのパスを取得します。
 String getNextPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。
 String getNextPagePath(String application, String service, String key, Locale locale)
遷移先のページのパスを取得します。
 String getServiceControllerName(String application, String service)
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。
 String getServiceControllerName(String application, String service, Locale locale)
サービスコントローラのクラス名を取得します。
 String getServiceErrorPagePath()
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。
 String getServiceErrorPagePath(Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。
 String getServiceErrorPagePath(String application, String service, String key, Locale locale)
処理例外時のページのパスを取得します。
 String getServiceParamName()
推奨されていません。 この実装は廃止されました。
 String getServiceServletPath()
サービスサーブレットのパスを取得します。
 String getSystemErrorPagePath()
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。
 String getSystemErrorPagePath(Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, Locale locale)
システム例外時のページのパスを取得します。
 String getSystemErrorPagePath(String application, String service, String key)
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。
 String getSystemErrorPagePath(String application, String service, String key, Locale locale)
システム例外時のページのパスを取得します。
 String getTransitionName(String application, String service)
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。
 String getTransitionName(String application, String service, Locale locale)
トランジションのクラス名を取得します。
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。
 boolean isDynamic()
プロパティの動的読み込みが可能かどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名のプレフィックス

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値

PARAM_DYNAMIC

public static final String PARAM_DYNAMIC
プロパティファイルの再読み込み可能のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlServicePropertyHandler

public XmlServicePropertyHandler()
XmlServicePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

isDynamic

public boolean isDynamic()
                  throws ServicePropertyException
プロパティの動的読み込みが可能かどうか調べます。 このクラスではこのメソッドは常にfalseを返します。

定義:
インタフェース ServicePropertyHandler 内の isDynamic
戻り値:
常にfalse
例外:
ServicePropertyException - チェック時に例外が発生

getClientEncoding

public String getClientEncoding()
                         throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientEncoding
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getClientLocale

public Locale getClientLocale()
                       throws ServicePropertyException
クライアントのエンコードを取得します。

定義:
インタフェース ServicePropertyHandler 内の getClientLocale
戻り値:
クライアントのエンコーディング
例外:
ServicePropertyException - クライアントのエンコードの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    String key,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    String service,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application)
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(String, Locale) を使用してください。

入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。 このメソッドは getInputErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(String application,
                                    Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getInputErrorPagePath() で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath()
                             throws ServicePropertyException
推奨されていません。 このメソッドではなく getInputErrorPagePath(Locale)を使用してください。

入力例外時のページのパスを取得します。 このメソッドは getInputErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getInputErrorPagePath

public String getInputErrorPagePath(Locale locale)
                             throws ServicePropertyException
入力例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getInputErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。 このメソッドは getNextPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まる場合にこのメソッドを使用します。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key)
                       throws ServicePropertyException
推奨されていません。 このメソッドではなく getNextPagePath(String, String, String, Locale) を使用してください。

遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。 このメソッドは getNextPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getNextPagePath

public String getNextPagePath(String application,
                              String service,
                              String key,
                              Locale locale)
                       throws ServicePropertyException
遷移先のページのパスを取得します。 サービスから遷移先が一意に決まらない場合にこのメソッドを使用します。 key が null の場合、 getNextPagePath(String, String) と同じ動作になります。

定義:
インタフェース ServicePropertyHandler 内の getNextPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service)
                                throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceControllerName(String, String, Locale) を使用してください。

サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。 このメソッドは getServiceControllerName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceControllerName

public String getServiceControllerName(String application,
                                       String service,
                                       Locale locale)
                                throws ServicePropertyException
サービスコントローラのクラス名を取得します。 該当するサービスコントローラが存在しない場合、nullを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceControllerName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
サービスコントローラのクラス名、存在しない場合はnull
例外:
ServicePropertyException - サービスコントローラのクラス名の取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      String key,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      String service,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application)
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(String, Locale) を使用してください。

処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。 このメソッドは getServiceErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(String application,
                                      Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getServiceErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath()
                               throws ServicePropertyException
推奨されていません。 このメソッドではなく getServiceErrorPagePath(Locale) を使用してください。

処理例外時のページのパスを取得します。 このメソッドは getServiceErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getServiceErrorPagePath

public String getServiceErrorPagePath(Locale locale)
                               throws ServicePropertyException
処理例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, key, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     String key,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String, String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
key - 遷移先のキー
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     String service,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath(String)で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application)
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(String, Locale) を使用してください。

システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。 このメソッドは getSystemErrorPagePath(application, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(String application,
                                     Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。 該当するページのパスが取得できない場合、 getSystemErrorPagePath()で取得されるページを返します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
application - アプリケーションID
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath()
                              throws ServicePropertyException
推奨されていません。 このメソッドではなく getSystemErrorPagePath(Locale)を使用してください。

システム例外時のページのパスを取得します。 このメソッドは getSystemErrorPagePath((java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getSystemErrorPagePath

public String getSystemErrorPagePath(Locale locale)
                              throws ServicePropertyException
システム例外時のページのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getSystemErrorPagePath
パラメータ:
locale - ロケール
戻り値:
遷移先のページのパス
例外:
ServicePropertyException - 遷移先のページのパスの取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service)
                         throws ServicePropertyException
推奨されていません。 このメソッドではなく getTransitionName(String, String, Locale) を使用してください。

トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。 このメソッドは getTransitionName(application, service, (java.util.Locale)null) を呼んだときと同じ結果になります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getTransitionName

public String getTransitionName(String application,
                                String service,
                                Locale locale)
                         throws ServicePropertyException
トランジションのクラス名を取得します。 指定されたアプリケーションIDとサービスIDに対応するトランジション名を取得します。 特に設定されていない場合、nullが返ります。

定義:
インタフェース ServicePropertyHandler 内の getTransitionName
パラメータ:
application - アプリケーションID
service - サービスID
locale - ロケール
戻り値:
トランジションのクラス名、設定されていない場合はnull
例外:
ServicePropertyException - トランジションのクラス名の取得時に例外が発生

getServiceServletPath

public String getServiceServletPath()
                             throws ServicePropertyException
サービスサーブレットのパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getServiceServletPath
戻り値:
サービスサーブレットのパス
例外:
ServicePropertyException - サービスサーブレットのパスの取得時に例外が発生

getContextPath

public String getContextPath()
                      throws ServicePropertyException
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。

コンテキストパスを取得します。

定義:
インタフェース ServicePropertyHandler 内の getContextPath
戻り値:
コンテキストパス
例外:
ServicePropertyException - コンテキストパスの取得時に例外が発生

getApplicationParamName

public String getApplicationParamName()
                               throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

アプリケーションIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getApplicationParamName
戻り値:
アプリケーションIDに該当するパラメータ名
例外:
ServicePropertyException - アプリケーションIDに該当するパラメータ名の取得時に例外が発生

getServiceParamName

public String getServiceParamName()
                           throws ServicePropertyException
推奨されていません。 この実装は廃止されました。

サービスIDに該当するパラメータ名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_SERVICE_PARAMETERで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getServiceParamName
戻り値:
サービスIDに該当するパラメータ名
例外:
ServicePropertyException - サービスIDに該当するパラメータ名の取得時に例外が発生

getExceptionAttributeName

public String getExceptionAttributeName()
                                 throws ServicePropertyException
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_EXCEPTION_ATTRIBUTE で定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getExceptionAttributeName
戻り値:
例外の属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getEncodingAttributeName

public String getEncodingAttributeName()
                                throws ServicePropertyException
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_ENCODING_ATTRIBUTEで定義されている値を返します。

定義:
インタフェース ServicePropertyHandler 内の getEncodingAttributeName
戻り値:
エンコードの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生

getLocaleAttributeName

public String getLocaleAttributeName()
                              throws ServicePropertyException
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。 設定されていない場合、 ServicePropertyHandler.DEFAULT_LOCALE_ATTRIBUTEで定義されている値を返します 。

定義:
インタフェース ServicePropertyHandler 内の getLocaleAttributeName
戻り値:
ロケールの属性名
例外:
ServicePropertyException - 属性名の取得時に例外が発生
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の使用

jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.HttpSessionFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.HttpSessionFactory の使用

jp.co.intra_mart.framework.base.session.HttpSessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.HttpSessionObject の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.HttpSessionObject の使用

jp.co.intra_mart.framework.base.session.HttpSessionObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.IllegalSessionException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IllegalSessionException の使用

jp.co.intra_mart.framework.base.session.IllegalSessionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.IntramartSessionFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IntramartSessionFactory の使用

jp.co.intra_mart.framework.base.session.IntramartSessionFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.IntramartSessionObject の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.IntramartSessionObject の使用

jp.co.intra_mart.framework.base.session.IntramartSessionObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.session.SessionFactory の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionFactory の使用

SessionFactory を使用しているパッケージ
jp.co.intra_mart.framework.base.session セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.session での SessionFactory の使用

SessionFactory を実装している jp.co.intra_mart.framework.base.session のクラス
class | HttpSessionFactory 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
class | IntramartSessionFactory 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

SessionFactory を返す jp.co.intra_mart.framework.base.session のメソッド
 SessionFactory SessionManager.getSessionFactory()
セッションファクトリを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.SessionFactoryException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionFactoryException の使用

SessionFactoryException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionFactoryException の使用

SessionFactoryException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionFactoryException の使用

SessionFactoryException をスローする jp.co.intra_mart.framework.base.session のメソッド
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionObject | SessionFactory.createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
String | SessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) セッションIDをエンコードしてURLに追加します。
SessionObject | IntramartSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | IntramartSessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
SessionObject | HttpSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | HttpSessionFactory.encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.SessionFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionFilter の使用

jp.co.intra_mart.framework.base.session.SessionFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.SessionManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionManager の使用

SessionManager を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionManager の使用

SessionManager を返す jp.co.intra_mart.framework.base.service のメソッド
protected  SessionManager IntramartConnectServlet.getSessionManager()
推奨されていません。 セッションマネージャを取得します。

jp.co.intra_mart.framework.base.session での SessionManager の使用

SessionManager を返す jp.co.intra_mart.framework.base.session のメソッド
static SessionManager SessionManager.getSessionManager()
セッションマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.SessionManagerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionManagerException の使用

SessionManagerException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionManagerException の使用

SessionManagerException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionManagerException の使用

SessionManagerException をスローする jp.co.intra_mart.framework.base.session のメソッド
static SessionManager SessionManager.getSessionManager()
セッションマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.session.SessionObject の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionObject の使用

SessionObject を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionObject の使用

SessionObject を返す jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionObject の使用

SessionObject を実装している jp.co.intra_mart.framework.base.session のクラス
class | HttpSessionObject 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
class | IntramartSessionObject 推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

SessionObject を返す jp.co.intra_mart.framework.base.session のメソッド
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionObject | SessionFactory.createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
SessionObject | IntramartSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
SessionObject | HttpSessionFactory.createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。

jp.co.intra_mart.framework.base.web.bean での SessionObject の使用

SessionObject を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 SessionObject HelperBean.getSession()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.SessionObjectException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionObjectException の使用

SessionObjectException を使用しているパッケージ
jp.co.intra_mart.framework.base.session セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.session での SessionObjectException の使用

SessionObjectException をスローする jp.co.intra_mart.framework.base.session のメソッド
void | SessionObject.setAttribute(String name, Object value) 指定された名前に対応するオブジェクトを追加します。
Object | SessionObject.getAttribute(String name) 指定された名前に対応するオブジェクトを取得します。
void | SessionObject.removeAttribute(String name) 指定された名前に対応するオブジェクトを削除します。
Enumeration | SessionObject.getAttributeNames() セッション内に存在する名前の一覧を取得します。
void | SessionObject.clear() セッション内に存在するすべてのオブジェクトを削除します。
void | IntramartSessionObject.setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
Object | IntramartSessionObject.getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | IntramartSessionObject.getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
void | IntramartSessionObject.removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | IntramartSessionObject.clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
void | HttpSessionObject.setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
void | HttpSessionObject.removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
Object | HttpSessionObject.getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | HttpSessionObject.getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
void | HttpSessionObject.clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.SessionPropertyException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.SessionPropertyException の使用

SessionPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionPropertyException の使用

SessionPropertyException をスローする jp.co.intra_mart.framework.base.service のメソッド
 SessionObject Transition.getSessionObject()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

jp.co.intra_mart.framework.base.session での SessionPropertyException の使用

SessionPropertyException をスローする jp.co.intra_mart.framework.base.session のメソッド
String | XmlSessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | XmlSessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | XmlSessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | XmlSessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | XmlSessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | XmlSessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | SessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | SessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | SessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | SessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | SessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | SessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。
SessionObject | SessionManager.getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
String | DefaultSessionPropertyHandler.getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | DefaultSessionPropertyHandler.getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
String | DefaultSessionPropertyHandler.getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | DefaultSessionPropertyHandler.getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | DefaultSessionPropertyHandler.getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | DefaultSessionPropertyHandler.getSessionErrorPagePath() セッションエラーページのパスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.session.SessionPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.session.SessionPropertyHandler の使用

SessionPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service での SessionPropertyHandler の使用

SessionPropertyHandler を返す jp.co.intra_mart.framework.base.service のメソッド
protected  SessionPropertyHandler IntramartConnectServlet.getSessionPropertyHandler()
推奨されていません。 セッションプロパティハンドラを取得します。

jp.co.intra_mart.framework.base.session での SessionPropertyHandler の使用

SessionPropertyHandler を実装している jp.co.intra_mart.framework.base.session のクラス
class | DefaultSessionPropertyHandler セッションに関連するデフォルトのプロパティハンドラです。
class | XmlSessionPropertyHandler セッションに関連するXMLのプロパティハンドラです。

SessionPropertyHandler を返す jp.co.intra_mart.framework.base.session のメソッド
 SessionPropertyHandler SessionManager.getSessionPropertyHandler()
セッションプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の使用

jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultSessionPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス DefaultSessionPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler
すべての実装インタフェース:
PropertyHandler, SessionPropertyHandler
public class DefaultSessionPropertyHandler
extends Object
implements SessionPropertyHandler

セッションに関連するデフォルトのプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

キー | 内容
factory.name | SessionFactoryのクラス名
object.param | リクエストに渡すセッションIDのパラメータ名
error.page.path | セッションエラー（セッションタイムアウト等）のときに表示するページのパス
object.key | リクエストの属性にSessionObjectを保存する時のキー
reserved.user.key | SessionObjectの属性に設定されているユーザIDのキー
reserved.group.key | SessionObjectの属性に設定されているログイングループIDのキー

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultSessionPropertyHandler()
DefaultSessionPropertyHandlerを新規に生成します。
メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultSessionPropertyHandler

public DefaultSessionPropertyHandler()
DefaultSessionPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionFactoryName
戻り値:
セッションファクトリのクラス名（設定されていない場合null）
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionParameter
戻り値:
セッションIDのパラメータ名（設定されていない場合null）
例外:
SessionPropertyException - セッションIDのパラメータ名の取得時に例外が発生

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionObjectKey
戻り値:
セッションオブジェクトのキー（設定されていない場合null）
例外:
SessionPropertyException - セッションオブジェクトのキーの取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginUserIDKey
戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginGroupIDKey
戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

定義:
インタフェース SessionPropertyHandler 内の getSessionErrorPagePath
戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


HttpSessionFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス HttpSessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.HttpSessionFactory
すべての実装インタフェース:
SessionFactory
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class HttpSessionFactory
extends Object
implements SessionFactory

HTTPセッションに関連するセッションファクトリです。

バージョン:
1.0

コンストラクタの概要
HttpSessionFactory()
推奨されていません。 HttpSessionFactoryを新規に生成します。
メソッドの概要
SessionObject | createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() 推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionFactory

public HttpSessionFactory()
推奨されていません。
HttpSessionFactoryを新規に生成します。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
推奨されていません。
セッションオブジェクトを新規に生成します。 HttpSessionObjectを生成します。

定義:
インタフェース SessionFactory 内の createSessionObject
パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗
関連項目:
HttpSessionObject

isEncodeRequired

public boolean isEncodeRequired()
推奨されていません。
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

定義:
インタフェース SessionFactory 内の isEncodeRequired
戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
推奨されていません。
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

定義:
インタフェース SessionFactory 内の encodeURL
パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


HttpSessionObject (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス HttpSessionObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.HttpSessionObject
すべての実装インタフェース:
SessionObject
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class HttpSessionObject
extends Object
implements SessionObject

HttpSessionを利用したSessionObjectです。

バージョン:
1.0

コンストラクタの概要
HttpSessionObject(HttpSession session)
推奨されていません。 HttpSessionObjectを新規に生成します。
メソッドの概要
void | clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
String | getSessionID() 推奨されていません。 セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionObject

public HttpSessionObject(HttpSession session)
推奨されていません。
HttpSessionObjectを新規に生成します。

パラメータ:
session - HttpSession
メソッドの詳細

getSessionID

public String getSessionID()
推奨されていません。
セッションを一意に識別するIDを取得します。

定義:
インタフェース SessionObject 内の getSessionID
戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを追加します。

定義:
インタフェース SessionObject 内の setAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

定義:
インタフェース SessionObject 内の removeAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

定義:
インタフェース SessionObject 内の getAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
推奨されていません。
セッション内に存在する名前の一覧を取得します。

定義:
インタフェース SessionObject 内の getAttributeNames
戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

clear

public void clear()
           throws SessionObjectException
推奨されていません。
セッション内に存在するすべてのオブジェクトを削除します。

定義:
インタフェース SessionObject 内の clear
例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IllegalSessionException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IllegalSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.IllegalSessionException
すべての実装インタフェース:
Serializable
public class IllegalSessionException
extends SystemException

セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalSessionException()
詳細メッセージを指定しないで IllegalSessionException を構築します。
IllegalSessionException(String msg)
指定された詳細メッセージを持つ IllegalSessionException を構築します。
IllegalSessionException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalSessionException

public IllegalSessionException()
詳細メッセージを指定しないで IllegalSessionException を構築します。

IllegalSessionException

public IllegalSessionException(String msg)
指定された詳細メッセージを持つ IllegalSessionException を構築します。

パラメータ:
msg - 詳細メッセージ

IllegalSessionException

public IllegalSessionException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartSessionFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IntramartSessionFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.IntramartSessionFactory
すべての実装インタフェース:
SessionFactory
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class IntramartSessionFactory
extends Object
implements SessionFactory

intra-martのセッションを利用するセッションオブジェクトを生成します。 このクラスを利用するためには、intra-martをインストールする必要があります。

バージョン:
1.0

コンストラクタの概要
IntramartSessionFactory()
推奨されていません。 IntramartSessionFactoryを新規に生成します。
メソッドの概要
SessionObject | createSessionObject(ServletRequest request) 推奨されていません。 セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) 推奨されていません。 セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() 推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartSessionFactory

public IntramartSessionFactory()
推奨されていません。
IntramartSessionFactoryを新規に生成します。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
推奨されていません。
セッションオブジェクトを新規に生成します。

定義:
インタフェース SessionFactory 内の createSessionObject
パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗

isEncodeRequired

public boolean isEncodeRequired()
推奨されていません。
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

定義:
インタフェース SessionFactory 内の isEncodeRequired
戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
推奨されていません。
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

定義:
インタフェース SessionFactory 内の encodeURL
パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartSessionObject (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス IntramartSessionObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.IntramartSessionObject
すべての実装インタフェース:
SessionObject
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。

public class IntramartSessionObject
extends Object
implements SessionObject

intra-martのSessionを利用したSessionObjectです。 このクラスを利用するためには、intra-martをインストールする必要があります。

バージョン:
1.0

コンストラクタの概要
IntramartSessionObject(jp.co.intra_mart.foundation.service.client.information.SessionMemory session)
推奨されていません。 IntramartSessionObjectを生成します。
メソッドの概要
void | clear() 推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() 推奨されていません。 セッション内に存在する名前の一覧を取得します。
String | getSessionID() 推奨されていません。 セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 推奨されていません。 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 推奨されていません。 指定された名前に対応するオブジェクトを追加します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartSessionObject

public IntramartSessionObject(jp.co.intra_mart.foundation.service.client.information.SessionMemory session)
推奨されていません。
IntramartSessionObjectを生成します。

パラメータ:
session - intra-martの共有データオブジェクト
メソッドの詳細

getSessionID

public String getSessionID()
推奨されていません。
セッションを一意に識別するIDを取得します。

定義:
インタフェース SessionObject 内の getSessionID
戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを追加します。

定義:
インタフェース SessionObject 内の setAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

定義:
インタフェース SessionObject 内の getAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
推奨されていません。
セッション内に存在する名前の一覧を取得します。

定義:
インタフェース SessionObject 内の getAttributeNames
戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
推奨されていません。
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

定義:
インタフェース SessionObject 内の removeAttribute
パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

clear

public void clear()
           throws SessionObjectException
推奨されていません。
セッション内に存在するすべてのオブジェクトを削除します。

定義:
インタフェース SessionObject 内の clear
例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.session (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.session
インタフェース
SessionFactory
SessionObject
SessionPropertyHandler
クラス
DefaultSessionPropertyHandler
HttpSessionFactory
HttpSessionObject
IntramartSessionFactory
IntramartSessionObject
SessionFilter
SessionManager
XmlSessionPropertyHandler
例外
IllegalSessionException
SessionFactoryException
SessionManagerException
SessionObjectException
SessionPropertyException


jp.co.intra_mart.framework.base.session (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.session

セッションに関連するクラスのパッケージです。

参照:
説明

インタフェースの概要
SessionFactory | セッションに関連するファクトリクラスとなるインタフェースです。
SessionObject | セッションに関連する情報を持つオブジェクトです。
SessionPropertyHandler | セッションに関連するプロパティを取得します。

クラスの概要
DefaultSessionPropertyHandler | セッションに関連するデフォルトのプロパティハンドラです。
HttpSessionFactory | 推奨されていません。 このクラスは互換性のために残されています。
HttpSessionObject | 推奨されていません。 このクラスは互換性のために残されています。
IntramartSessionFactory | 推奨されていません。 このクラスは互換性のために残されています。
IntramartSessionObject | 推奨されていません。 このクラスは互換性のために残されています。
SessionFilter | セッション管理をします。
SessionManager | セッションマネージャです。
XmlSessionPropertyHandler | セッションに関連するXMLのプロパティハンドラです。

例外の概要
IllegalSessionException | セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
SessionFactoryException | セッションファクトリ内の例外です。
SessionManagerException | セッションマネージャ内の例外です。
SessionObjectException | セッションオブジェクト内の例外です。
SessionPropertyException | セッションプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.base.session の説明

セッションに関連するクラスのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.session クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.session の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.framework.base.session.HttpSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.HttpSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.session.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.session.IllegalSessionException
            • class jp.co.intra_mart.framework.base.session.SessionFactoryException
            • class jp.co.intra_mart.framework.base.session.SessionManagerException
            • class jp.co.intra_mart.framework.base.session.SessionObjectException
            • class jp.co.intra_mart.framework.base.session.SessionPropertyException
    • class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler
  • interface jp.co.intra_mart.framework.base.session.SessionFactory
  • interface jp.co.intra_mart.framework.base.session.SessionObject
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.session の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.session の使用

jp.co.intra_mart.framework.base.session を使用しているパッケージ
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.session のクラス
SessionFactoryException
セッションファクトリ内の例外です。
SessionManager
セッションマネージャです。
SessionManagerException
セッションマネージャ内の例外です。
SessionObject
セッションに関連する情報を持つオブジェクトです。
SessionPropertyException
セッションプロパティ取得時の例外です。
SessionPropertyHandler
セッションに関連するプロパティを取得します。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.base.session のクラス
SessionFactory
セッションに関連するファクトリクラスとなるインタフェースです。
SessionFactoryException
セッションファクトリ内の例外です。
SessionManager
セッションマネージャです。
SessionManagerException
セッションマネージャ内の例外です。
SessionObject
セッションに関連する情報を持つオブジェクトです。
SessionObjectException
セッションオブジェクト内の例外です。
SessionPropertyException
セッションプロパティ取得時の例外です。
SessionPropertyHandler
セッションに関連するプロパティを取得します。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.session のクラス
SessionObject
セッションに関連する情報を持つオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionFactory (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionFactory

既知の実装クラスの一覧:
HttpSessionFactory, IntramartSessionFactory
public interface SessionFactory

セッションに関連するファクトリクラスとなるインタフェースです。

バージョン:
1.0

メソッドの概要
SessionObject | createSessionObject(ServletRequest request) セッションオブジェクトを新規に生成します。
String | encodeURL(ServletRequest request, ServletResponse response, String url) セッションIDをエンコードしてURLに追加します。
boolean | isEncodeRequired() セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

メソッドの詳細

createSessionObject

public SessionObject createSessionObject(ServletRequest request)
                                  throws SessionFactoryException
セッションオブジェクトを新規に生成します。

パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionFactoryException - セッションオブジェクトの取得に失敗

isEncodeRequired

public boolean isEncodeRequired()
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。

戻り値:
エンコードが必要な場合true、そうでない場合false

encodeURL

public String encodeURL(ServletRequest request,
                        ServletResponse response,
                        String url)
                 throws SessionFactoryException
セッションIDをエンコードしてURLに追加します。 追加される内容はセッションオブジェクトの実装に依存します。

パラメータ:
request - リクエスト
response - レスポンス
url - リクエストのURL
戻り値:
セッションIDが反映されたURL
例外:
SessionFactoryException - URLの生成時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionFactoryException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionFactoryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionFactoryException
すべての実装インタフェース:
Serializable
public class SessionFactoryException
extends SystemException

セッションファクトリ内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionFactoryException()
詳細メッセージを指定しないで SessionFactoryException を構築します。
SessionFactoryException(String msg)
指定された詳細メッセージを持つ SessionFactoryException を構築します。
SessionFactoryException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionFactoryException

public SessionFactoryException()
詳細メッセージを指定しないで SessionFactoryException を構築します。

SessionFactoryException

public SessionFactoryException(String msg)
指定された詳細メッセージを持つ SessionFactoryException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionFactoryException

public SessionFactoryException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.SessionFilter
すべての実装インタフェース:
Filter
public class SessionFilter
extends Object
implements Filter

セッション管理をします。

バージョン:
1.0

コンストラクタの概要
SessionFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) リクエストのセッション管理をします。
void | init(FilterConfig filterConfig) セッション用のフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionFilter

public SessionFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
セッション用のフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
リクエストのセッション管理をします。 SessionFactoryを利用しない場合、以下の条件がすべて満たされるときセッションが継続しているものとみなされます。
  • セッションが存在する
SessionFactoryを利用する場合、以下の条件がすべて満たされるときセッションが継続しているものとみなされます。
  • sessionにSessionPropertyHandler.getLoginUserIDKey()で指定された属性（ログインユーザID）が登録されている
  • sessionにSessionPropertyHandler.getLoginGroupIDKey()で指定された属性（ログイングループID）が登録されている

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.SessionManager
public class SessionManager
extends Object

セッションマネージャです。

バージョン:
1.0

フィールドの概要
static String SESSION_PROPERTY_HANDLER_KEY
セッションプロパティハンドラのキー
メソッドの概要
SessionFactory | getSessionFactory() セッションファクトリを取得します。
static SessionManager | getSessionManager() セッションマネージャを取得します。
SessionObject | getSessionObject(ServletRequest request) セッションオブジェクトを取得します。
SessionPropertyHandler | getSessionPropertyHandler() セッションプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

SESSION_PROPERTY_HANDLER_KEY

public static final String SESSION_PROPERTY_HANDLER_KEY
セッションプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getSessionManager

public static SessionManager getSessionManager()
                                        throws SessionManagerException
セッションマネージャを取得します。

戻り値:
セッションマネージャ
例外:
SessionManagerException - セッションマネージャの生成に失敗した

getSessionPropertyHandler

public SessionPropertyHandler getSessionPropertyHandler()
セッションプロパティハンドラを取得します。

戻り値:
セッションプロパティハンドラ

getSessionFactory

public SessionFactory getSessionFactory()
セッションファクトリを取得します。 セッションプロパティにSessionFactoryが指定されていない場合、nullが返ります。

戻り値:
セッションファクトリ（プロパティが設定されていない場合null）

getSessionObject

public SessionObject getSessionObject(ServletRequest request)
                               throws SessionPropertyException,
                                      SessionFactoryException
セッションオブジェクトを取得します。 指定されたリクエスト内にあるセッションオブジェクトを取得します。 セッションが存在しない場合、新規にセッションを生成します。 このメソッドはセッションプロパティにSessionFactoryを指定したときに有効になります。

パラメータ:
request - リクエスト
戻り値:
セッションオブジェクト
例外:
SessionPropertyException - セッションプロパティの取得に失敗
SessionFactoryException - セッションオブジェクトの生成に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionManagerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionManagerException
すべての実装インタフェース:
Serializable
public class SessionManagerException
extends SystemException

セッションマネージャ内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionManagerException()
詳細メッセージを指定しないで SessionManagerException を構築します。
SessionManagerException(String msg)
指定された詳細メッセージを持つ SessionManagerException を構築します。
SessionManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionManagerException

public SessionManagerException()
詳細メッセージを指定しないで SessionManagerException を構築します。

SessionManagerException

public SessionManagerException(String msg)
指定された詳細メッセージを持つ SessionManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionManagerException

public SessionManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionObject (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionObject

既知の実装クラスの一覧:
HttpSessionObject, IntramartSessionObject
public interface SessionObject

セッションに関連する情報を持つオブジェクトです。 セッション管理の方法に応じてこのインタフェースを実装してください。

バージョン:
1.0

メソッドの概要
void | clear() セッション内に存在するすべてのオブジェクトを削除します。
Object | getAttribute(String name) 指定された名前に対応するオブジェクトを取得します。
Enumeration | getAttributeNames() セッション内に存在する名前の一覧を取得します。
String | getSessionID() セッションを一意に識別するIDを取得します。
void | removeAttribute(String name) 指定された名前に対応するオブジェクトを削除します。
void | setAttribute(String name, Object value) 指定された名前に対応するオブジェクトを追加します。

メソッドの詳細

getSessionID

public String getSessionID()
セッションを一意に識別するIDを取得します。

戻り値:
セッションを識別するID

setAttribute

public void setAttribute(String name,
                         Object value)
                  throws SessionObjectException
指定された名前に対応するオブジェクトを追加します。

パラメータ:
name - オブジェクトに関連付けられる名前
value - オブジェクト
例外:
SessionObjectException - オブジェクトの追加時に例外が発生

getAttribute

public Object getAttribute(String name)
                    throws SessionObjectException
指定された名前に対応するオブジェクトを取得します。 対応するオブジェクトがない場合、nullが返ります。

パラメータ:
name - オブジェクトに関連付けられる名前
戻り値:
キーに対応するオブジェクト
例外:
SessionObjectException - オブジェクトの取得時に例外が発生

removeAttribute

public void removeAttribute(String name)
                     throws SessionObjectException
指定された名前に対応するオブジェクトを削除します。 指定された名前で登録されていない場合、何もしません。

パラメータ:
name - オブジェクトに関連付けられる名前
例外:
SessionObjectException - オブジェクトの削除時に例外が発生

getAttributeNames

public Enumeration getAttributeNames()
                              throws SessionObjectException
セッション内に存在する名前の一覧を取得します。

戻り値:
名前のコレクション
例外:
SessionObjectException - 名前の一覧取得時に例外が発生

clear

public void clear()
           throws SessionObjectException
セッション内に存在するすべてのオブジェクトを削除します。

例外:
SessionObjectException - オブジェクトの削除時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionObjectException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionObjectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionObjectException
すべての実装インタフェース:
Serializable
public class SessionObjectException
extends SystemException

セッションオブジェクト内の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionObjectException()
詳細メッセージを指定しないで SessionObjectException を構築します。
SessionObjectException(String msg)
指定された詳細メッセージを持つ SessionObjectException を構築します。
SessionObjectException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionObjectException

public SessionObjectException()
詳細メッセージを指定しないで SessionObjectException を構築します。

SessionObjectException

public SessionObjectException(String msg)
指定された詳細メッセージを持つ SessionObjectException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionObjectException

public SessionObjectException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionPropertyException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス SessionPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.session.SessionPropertyException
すべての実装インタフェース:
Serializable
public class SessionPropertyException
extends SystemException

セッションプロパティ取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SessionPropertyException()
詳細メッセージを指定しないで SessionPropertyException を構築します。
SessionPropertyException(String msg)
指定された詳細メッセージを持つ SessionPropertyException を構築します。
SessionPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SessionPropertyException

public SessionPropertyException()
詳細メッセージを指定しないで SessionPropertyException を構築します。

SessionPropertyException

public SessionPropertyException(String msg)
指定された詳細メッセージを持つ SessionPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

SessionPropertyException

public SessionPropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SessionPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
インタフェース SessionPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultSessionPropertyHandler, XmlSessionPropertyHandler
public interface SessionPropertyHandler
extends PropertyHandler

セッションに関連するプロパティを取得します。

バージョン:
1.0

メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションオブジェクトのキー
例外:
SessionPropertyException - セッションオブジェクトのキーの取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションIDのパラメータ名
例外:
SessionPropertyException - セッションIDのパラメータ名の取得時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

戻り値:
セッションファクトリのクラス名
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


XmlSessionPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.session
クラス XmlSessionPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler
すべての実装インタフェース:
PropertyHandler, SessionPropertyHandler
public class XmlSessionPropertyHandler
extends Object
implements SessionPropertyHandler

セッションに関連するXMLのプロパティハンドラです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのxmlファイル名
static String | DEFAULT_BUNDLE_NAME_PARAM xmlファイル名のパラメータ名
コンストラクタの概要
XmlSessionPropertyHandler()
メソッドの概要
String | getLoginGroupIDKey() セッションに登録されているログイングループIDのキーを取得します。
String | getLoginUserIDKey() セッションに登録されているログインユーザIDのキーを取得します。
String | getSessionErrorPagePath() セッションエラーページのパスを取得します。
String | getSessionFactoryName() 推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
String | getSessionObjectKey() 推奨されていません。 HttpSessionを直接取得するようにしてください。
String | getSessionParameter() 推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのxmlファイル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
xmlファイル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlSessionPropertyHandler

public XmlSessionPropertyHandler()
メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getSessionFactoryName

public String getSessionFactoryName()
                             throws SessionPropertyException
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。

セッションファクトリのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionFactoryName
戻り値:
セッションファクトリのクラス名（設定されていない場合null）
例外:
SessionPropertyException - セッションファクトリのクラス名の取得時に例外が発生

getSessionParameter

public String getSessionParameter()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。

セッションIDのパラメータ名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionParameter
戻り値:
セッションIDのパラメータ名（設定されていない場合null）
例外:
SessionPropertyException - セッションパラメータ取得時に例外が発生

getSessionObjectKey

public String getSessionObjectKey()
                           throws SessionPropertyException
推奨されていません。 HttpSessionを直接取得するようにしてください。

セッションオブジェクトのキーを取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース SessionPropertyHandler 内の getSessionObjectKey
戻り値:
セッションオブジェクトのキー（設定されていない場合null）
例外:
SessionPropertyException - セッションオブジェクトキー取得時に例外が発生

getLoginUserIDKey

public String getLoginUserIDKey()
                         throws SessionPropertyException
セッションに登録されているログインユーザIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginUserIDKey
戻り値:
ログインユーザIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getLoginGroupIDKey

public String getLoginGroupIDKey()
                          throws SessionPropertyException
セッションに登録されているログイングループIDのキーを取得します。

定義:
インタフェース SessionPropertyHandler 内の getLoginGroupIDKey
戻り値:
ログイングループIDのキー
例外:
SessionPropertyException - 属性名の取得時に例外が発生

getSessionErrorPagePath

public String getSessionErrorPagePath()
                               throws SessionPropertyException
セッションエラーページのパスを取得します。

定義:
インタフェース SessionPropertyHandler 内の getSessionErrorPagePath
戻り値:
セッションエラーページのパス
例外:
SessionPropertyException - セッションエラーページのパスの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.util.ConfigurationUserInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.ConfigurationUserInfo の使用

jp.co.intra_mart.framework.base.util.ConfigurationUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.util.EmptyUserInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.EmptyUserInfo の使用

jp.co.intra_mart.framework.base.util.EmptyUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.util.UserInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.util.UserInfo の使用

UserInfo を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.event のメソッド
 UserInfo Event.getUserInfo()
ログインユーザの情報を取得します。

UserInfo 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
 Event EventManager.createEvent(String application, String key, UserInfo info)
パラメータで指定された内容に該当するイベントを生成します。

jp.co.intra_mart.framework.base.service での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.service のメソッド
 UserInfo ServiceControllerAdapter.getUserInfo()
ユーザ情報を取得します。

jp.co.intra_mart.framework.base.util での UserInfo の使用

UserInfo を実装している jp.co.intra_mart.framework.base.util のクラス
class | ConfigurationUserInfo 情報を自由に設定可能なUserInfoです。
class | EmptyUserInfo 情報を何も持たないUserInfoです。

UserInfo を返す jp.co.intra_mart.framework.base.util のメソッド
static UserInfo UserInfoUtil.createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。

jp.co.intra_mart.framework.base.web.bean での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.base.web.bean のメソッド
 UserInfo HelperBean.getUserInfo()
ログインユーザ情報を取得します。

jp.co.intra_mart.framework.presentation.view での UserInfo の使用

UserInfo を返す jp.co.intra_mart.framework.presentation.view のメソッド
 UserInfo AbstractViewConverter.getUserInfo(RequestInfo info)
ログインユーザ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.util.UserInfoException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoException の使用

UserInfoException を使用しているパッケージ
jp.co.intra_mart.framework.base.util

jp.co.intra_mart.framework.base.util での UserInfoException の使用

UserInfoException をスローする jp.co.intra_mart.framework.base.util のメソッド
static UserInfo UserInfoUtil.createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.util.UserInfoUtil の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.util.UserInfoUtil の使用

jp.co.intra_mart.framework.base.util.UserInfoUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ConfigurationUserInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス ConfigurationUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.ConfigurationUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class ConfigurationUserInfo
extends Object
implements UserInfo, Serializable

情報を自由に設定可能なUserInfoです。
アクセスセキュリティと連動したユーザ情報が必要ではない場合、このクラスを利用して 任意のUserInfoを生成することが可能です。
バッチ処理などログインセッションに依存しない環境でのイベント実行時にも利用可能です。

 ConfigurationUserInfo info = new ConfigurationUserInfo();
 info.setUserID("user_id");
 info.setLoginGroupID("group_id");

 EventManager manager = EventManager.getEventManager();
 FooEvent event = (FooEvent)manager.createEvent("foo", "bar", info);
 event.doSomething();

 manager.dispatch(event);
アクセスセキュリティと連動したユーザ情報が必要な場合は UserInfoUtil.createUserInfo(HttpServletRequest, HttpServletResponse) を使用してください。

導入されたバージョン:
5.0.5
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ConfigurationUserInfo()
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。
void | setClientType(String clientType) クライアントタイプを設定する。
void | setColorPatternID(String colorPatternID) カラーパターンIDを設定する。
void | setEncoding(String encoding) エンコーディングを設定する。
void | setLocale(Locale locale) ユーザのロケールを設定する。
void | setLoginGroupID(String loginGroupID) ログイングループIDを設定する。
void | setLoginTime(Date loginTime) ログインした時間を設定する。
void | setLoginType(String loginType) ログインタイプを設定する。
void | setUserID(String userID) ログインユーザIDを設定する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConfigurationUserInfo

public ConfigurationUserInfo()
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

setClientType

public void setClientType(String clientType)
クライアントタイプを設定する。

パラメータ:
clientType - クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

setColorPatternID

public void setColorPatternID(String colorPatternID)
カラーパターンIDを設定する。

パラメータ:
colorPatternID - カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

setEncoding

public void setEncoding(String encoding)
エンコーディングを設定する。

パラメータ:
encoding - エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。 値が未設定の場合はnullを返却します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

setLocale

public void setLocale(Locale locale)
ユーザのロケールを設定する。

パラメータ:
locale - ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

setLoginGroupID

public void setLoginGroupID(String loginGroupID)
ログイングループIDを設定する。

パラメータ:
loginGroupID - ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
値が未設定の場合はnullを返却します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログイン時間

setLoginTime

public void setLoginTime(Date loginTime)
ログインした時間を設定する。

パラメータ:
loginTime - ログインした時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
値が未設定の場合はUserInfoUtil.LT_USERを返却します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

setLoginType

public void setLoginType(String loginType)
ログインタイプを設定する。

パラメータ:
loginType - ログインタイプ

getUserID

public String getUserID()
ログインユーザIDを取得する。
値が未設定の場合は空文字列を返却します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID

setUserID

public void setUserID(String userID)
ログインユーザIDを設定する。

パラメータ:
userID - ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EmptyUserInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス EmptyUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.EmptyUserInfo
すべての実装インタフェース:
Serializable, UserInfo
public class EmptyUserInfo
extends Object
implements UserInfo, Serializable

情報を何も持たないUserInfoです。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyUserInfo()
メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EmptyUserInfo

public EmptyUserInfo()
メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getClientType
戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getColorPatternID
戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getEncoding
戻り値:
エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。 このメソッドは常にnullを返却します。

定義:
インタフェース UserInfo 内の getLocale
戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getLoginGroupID
戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
このメソッドは常にnullを返却します。

定義:
インタフェース UserInfo 内の getLoginTime
戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
このメソッドは常にUserInfoUtil.LT_USERを返却します。

定義:
インタフェース UserInfo 内の getLoginType
戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ログインユーザIDを取得する。 このメソッドは常に空文字列を返却します。

定義:
インタフェース UserInfo 内の getUserID
戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.util (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.util
インタフェース
UserInfo
クラス
ConfigurationUserInfo
EmptyUserInfo
UserInfoUtil
例外
UserInfoException


jp.co.intra_mart.framework.base.util (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.util

インタフェースの概要
UserInfo ログインユーザの情報を管理します。

クラスの概要
ConfigurationUserInfo | 情報を自由に設定可能なUserInfoです。
EmptyUserInfo | 情報を何も持たないUserInfoです。
UserInfoUtil | ログインユーザの情報に関するユーティリティクラスです。

例外の概要
UserInfoException ユーザ情報に関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.util クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.util.EmptyUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.util.UserInfoException
    • class jp.co.intra_mart.framework.base.util.UserInfoUtil

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.base.util.UserInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.util の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.util の使用

jp.co.intra_mart.framework.base.util を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.base.util により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。
UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.base.util のクラス
UserInfo
ログインユーザの情報を管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


UserInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
インタフェース UserInfo

すべてのスーパーインタフェース:
Serializable
既知の実装クラスの一覧:
ConfigurationUserInfo, EmptyUserInfo
public interface UserInfo
extends Serializable

ログインユーザの情報を管理します。 イントラマートにアクセスしたクライアント情報をラップしたオブジェクトです。
このオブジェクトは通常UserInfoUtil.createUserInfo(HttpServletRequest, HttpServletResponse) から生成されます。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
UserInfoUtil

メソッドの概要
String | getClientType() クライアントタイプを取得する。
String | getColorPatternID() カラーパターンIDを取得する。
String | getEncoding() エンコーディングを取得する。
Locale | getLocale() ユーザのロケールを取得する。
String | getLoginGroupID() ログイングループIDを取得する。
Date | getLoginTime() ログインした時間を取得する。
String | getLoginType() ログインタイプを取得する。
String | getUserID() ログインユーザIDを取得する。

メソッドの詳細

getClientType

public String getClientType()
クライアントタイプを取得する。
セッション情報にクライアントタイプが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
クライアントタイプ

getColorPatternID

public String getColorPatternID()
カラーパターンIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合はデフォルトのカラーパターンIDを返却する。

戻り値:
カラーパターンID

getEncoding

public String getEncoding()
エンコーディングを取得する。
セッション情報にエンコーディングが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
エンコーディング

getLocale

public Locale getLocale()
ユーザのロケールを取得する。
セッション情報にロケールが存在しない場合、および空文字列の場合はnullを返却する。

戻り値:
ロケール

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを取得する。
セッション情報にログイングループIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログイングループID

getLoginTime

public Date getLoginTime()
ログインした時間を取得する。
セッション情報にログイン時間が存在しない場合、nullを返却する。

戻り値:
ログイン時間

getLoginType

public String getLoginType()
ログインタイプを取得する。
セッション情報にログインタイプが存在しない場合、および空文字列の場合は UserInfoUtil.LT_USER を返却する。

戻り値:
ログインタイプ
関連項目:
UserInfoUtil.LT_SUPER, UserInfoUtil.LT_GROUP, UserInfoUtil.LT_USER

getUserID

public String getUserID()
ログインユーザIDを取得する。
セッション情報にログインユーザIDが存在しない場合、および空文字列の場合は空文字列を返却する。

戻り値:
ログインユーザID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


UserInfoException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.util.UserInfoException
すべての実装インタフェース:
Serializable
public class UserInfoException
extends SystemException

ユーザ情報に関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
UserInfoException()
詳細メッセージを指定しないで UserInfoException を構築します。
UserInfoException(String msg)
指定された詳細メッセージを持つ UserInfoException を構築します。
UserInfoException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserInfoException

public UserInfoException()
詳細メッセージを指定しないで UserInfoException を構築します。

UserInfoException

public UserInfoException(String msg)
指定された詳細メッセージを持つ UserInfoException を構築します。

パラメータ:
msg - 詳細メッセージ

UserInfoException

public UserInfoException(String msg,
                         Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


UserInfoUtil (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.util
クラス UserInfoUtil

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.UserInfoUtil
public class UserInfoUtil
extends Object

ログインユーザの情報に関するユーティリティクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String | LT_GROUP グループマネージャ
static String | LT_SUPER スーパーユーザ
static String | LT_USER ユーザ
メソッドの概要
static UserInfo createUserInfo(HttpServletRequest request, HttpServletResponse response)
intra-martのセッション情報からUserInfoを新規に生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LT_SUPER

public static final String LT_SUPER
スーパーユーザ

関連項目:
定数フィールド値

LT_GROUP

public static final String LT_GROUP
グループマネージャ

関連項目:
定数フィールド値

LT_USER

public static final String LT_USER
ユーザ

関連項目:
定数フィールド値
メソッドの詳細

createUserInfo

public static UserInfo createUserInfo(HttpServletRequest request,
                                      HttpServletResponse response)
                               throws UserInfoException
intra-martのセッション情報からUserInfoを新規に生成します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザの情報
例外:
UserInfoException - UserInfo生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean の使用

jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.bean.HelperBean の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.HelperBean の使用

HelperBean を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean での HelperBean の使用

jp.co.intra_mart.framework.base.web.bean での HelperBean のサブクラス
 class ErrorHelperBean
例外ページで使用するHelperBeanです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.bean.HelperBeanException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.bean.HelperBeanException の使用

HelperBeanException を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean での HelperBeanException の使用

HelperBeanException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
 void HelperBean.init()
HelperBeanを初期化します。
 SessionObject HelperBean.getSession()
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
 String HelperBean.getLoginUserID()
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
 String HelperBean.getLoginGroupID()
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
 UserInfo HelperBean.getUserInfo()
ログインユーザ情報を取得します。
protected  Event HelperBean.createEvent(String application, String key)
アプリケーションIDとキーに対応するイベントを取得します。
 Throwable ErrorHelperBean.getException()
例外を取得します。

HelperBeanException をスローする jp.co.intra_mart.framework.base.web.bean のコンストラクタ
HelperBean()
HelperBeanを新規に生成します。
ErrorHelperBean()
ErrorHelperBeanを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ErrorHelperBean (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス ErrorHelperBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBean
        拡張 jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
すべての実装インタフェース:
Serializable
public class ErrorHelperBean
extends HelperBean

例外ページで使用するHelperBeanです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ErrorHelperBean()
ErrorHelperBeanを新規に生成します。
メソッドの概要
 Throwable getException()
例外を取得します。
クラス jp.co.intra_mart.framework.base.web.bean.HelperBean から継承したメソッド
createEvent, dispatchEvent, getLoginGroupID, getLoginUserID, getRequest, getResponse, getServicePropertyHandler, getSession, getUserInfo, init, setRequest, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorHelperBean

public ErrorHelperBean()
                throws HelperBeanException
ErrorHelperBeanを新規に生成します。

例外:
HelperBeanException - ErrorHelperBean生成時に例外が発生
メソッドの詳細

getException

public Throwable getException()
                       throws HelperBeanException
例外を取得します。

戻り値:
例外
例外:
HelperBeanException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


HelperBean (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス HelperBean

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBean
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ErrorHelperBean
public abstract class HelperBean
extends Object
implements Serializable

画面表示をする時のヘルパークラスです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
HelperBean()
HelperBeanを新規に生成します。
メソッドの概要
protected Event | createEvent(String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
String | getLoginGroupID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
String | getLoginUserID() 推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServicePropertyHandler | getServicePropertyHandler() サービスプロパティハンドラを取得します。
SessionObject | getSession() 推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
UserInfo | getUserInfo() ログインユーザ情報を取得します。
void | init() HelperBeanを初期化します。
void | setRequest(HttpServletRequest request) リクエストを設定します。
void | setResponse(HttpServletResponse response) レスポンスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBean

public HelperBean()
           throws HelperBeanException
HelperBeanを新規に生成します。

例外:
HelperBeanException - HelperBean生成時に例外が発生
メソッドの詳細

init

public void init()
          throws HelperBeanException
HelperBeanを初期化します。

例外:
HelperBeanException - 初期化時に例外が発生
導入されたバージョン:
3.2

setRequest

public void setRequest(HttpServletRequest request)
リクエストを設定します。

パラメータ:
request - リクエスト

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

setResponse

public void setResponse(HttpServletResponse response)
レスポンスを設定します。

パラメータ:
response - レスポンス

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getSession

public SessionObject getSession()
                         throws HelperBeanException
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。

セッションオブジェクトを取得します。 このメソッドはセッションプロパティにSessionFactoryとSessionObjectKeyを指定したときに有効になります。

戻り値:
セッションオブジェクト
例外:
HelperBeanException - セッションオブジェクト取得時に例外が発生

getLoginUserID

public String getLoginUserID()
                      throws HelperBeanException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログインユーザIDを取得します。

戻り値:
ログインユーザID
例外:
HelperBeanException - ログインユーザID取得時に例外が発生
導入されたバージョン:
3.2

getLoginGroupID

public String getLoginGroupID()
                       throws HelperBeanException
推奨されていません。 このメソッドではなくgetUserInfo()を使用してください。

ログイングループIDを取得します。

戻り値:
ログイングループID
例外:
HelperBeanException - ログイングループID取得時に例外が発生
導入されたバージョン:
3.2

getUserInfo

public UserInfo getUserInfo()
                     throws HelperBeanException
ログインユーザ情報を取得します。
ログインセッションが存在しない場合はnullを返却します。

戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ログインユーザ情報取得時に例外が発生
HelperBeanException
導入されたバージョン:
5.0

createEvent

protected Event createEvent(String application,
                            String key)
                     throws HelperBeanException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
HelperBeanException - イベント生成時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventException - イベント処理時に例外が発生
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

getServicePropertyHandler

public ServicePropertyHandler getServicePropertyHandler()
サービスプロパティハンドラを取得します。

戻り値:
サービスプロパティハンドラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


HelperBeanException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.bean
クラス HelperBeanException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.base.web.bean.HelperBeanException
すべての実装インタフェース:
Serializable
public class HelperBeanException
extends SystemException

HelperBean内で発生した例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
HelperBeanException()
詳細メッセージを指定しないで HelperBeanException を構築します。
HelperBeanException(String msg)
指定された詳細メッセージを持つ HelperBeanException を構築します。
HelperBeanException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HelperBeanException

public HelperBeanException()
詳細メッセージを指定しないで HelperBeanException を構築します。

HelperBeanException

public HelperBeanException(String msg)
指定された詳細メッセージを持つ HelperBeanException を構築します。

パラメータ:
msg - 詳細メッセージ

HelperBeanException

public HelperBeanException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.web.bean (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.web.bean
クラス
ErrorHelperBean
HelperBean
例外
HelperBeanException


jp.co.intra_mart.framework.base.web.bean (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.bean

JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

参照:
説明

クラスの概要
ErrorHelperBean | 例外ページで使用するHelperBeanです。
HelperBean | 画面表示をする時のヘルパークラスです。

例外の概要
HelperBeanException HelperBean内で発生した例外です。

パッケージ jp.co.intra_mart.framework.base.web.bean の説明

JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.web.bean クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.bean の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.bean.HelperBean (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.base.web.bean.HelperBeanException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.web.bean の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.bean の使用

jp.co.intra_mart.framework.base.web.bean を使用しているパッケージ
jp.co.intra_mart.framework.base.web.bean JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.base.web.bean のクラス
HelperBean
画面表示をする時のヘルパークラスです。
HelperBeanException
HelperBean内で発生した例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes の使用

GenericAttributes を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute での GenericAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute での GenericAttributes のサブクラス
class | CoreAttributes コア属性です。
class | EventsAttributes ブラウザのイベントに関連するタグの属性情報です。
class | I18nAttributes 国際化の属性です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes の使用

jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


CoreAttributes (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス CoreAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
public class CoreAttributes
extends GenericAttributes

コア属性です。

バージョン:
1.0

コンストラクタの概要
CoreAttributes()
CoreAttributesを新規に生成します。
メソッドの概要
String | getStyle() 属性styleの値を取得します。
String | getTagClass() 属性classの値を取得します。
String | getTitle() 属性titleの値を取得します。
void | printAttributes() 属性の内容を表示します。
void | setStyle(String style) 属性styleの値を設定します。
void | setTagClass(String tagClass) 属性classの値を設定します。
void | setTitle(String title) 属性titleの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CoreAttributes

public CoreAttributes()
CoreAttributesを新規に生成します。

メソッドの詳細

getTagClass

public String getTagClass()
属性classの値を取得します。

戻り値:
class

setTagClass

public void setTagClass(String tagClass)
属性classの値を設定します。

パラメータ:
tagClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EventsAttributes (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス EventsAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
public class EventsAttributes
extends GenericAttributes

ブラウザのイベントに関連するタグの属性情報です。

バージョン:
1.0

コンストラクタの概要
EventsAttributes()
EventsAttributesを新規に生成します。
メソッドの概要
String | getOnClick() 属性onClickの値を取得します。
String | getOnDblClick() 属性onDblClickの値を取得します。
String | getOnKeyDown() 属性onKeyDownの値を取得します。
String | getOnKeyPress() 属性onKeyPressの値を取得します。
String | getOnKeyUp() 属性onKeyUpの値を取得します。
String | getOnMouseDown() 属性onMouseDownの値を取得します。
String | getOnMouseMove() 属性onMouseMoveの値を取得します。
String | getOnMouseOut() 属性onMouseOutの値を取得します。
String | getOnMouseOver() 属性onMouseOverの値を取得します。
String | getOnMouseUp() 属性onMouseUpの値を取得します。
void | printAttributes() 属性の内容を表示します。
protected void | printOnClick() 属性onClickを出力します。
protected void | printOnDblClick() 属性onDblClickを出力します。
protected void | printOnKeyDown() 属性onKeyDownを出力します。
protected void | printOnKeyPress() 属性onKeyPressを出力します。
protected void | printOnKeyUp() 属性onKeyUpを出力します。
protected void | printOnMouseDown() 属性onMouseDownを出力します。
protected void | printOnMouseMove() 属性onMouseMoveを出力します。
protected void | printOnMouseOut() 属性onMouseOutを出力します。
protected void | printOnMouseOver() 属性onMouseOverを出力します。
protected void | printOnMouseUp() 属性onMouseUpを出力します。
void | setOnClick(String onClick) 属性onClickの値を設定します。
void | setOnDblClick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnKeyDown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnKeyPress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnKeyUp(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnMouseDown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnMouseMove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnMouseOut(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnMouseOver(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnMouseUp(String onMouseUp) 属性onMouseUpの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventsAttributes

public EventsAttributes()
EventsAttributesを新規に生成します。

メソッドの詳細

getOnClick

public String getOnClick()
属性onClickの値を取得します。

戻り値:
onClick

setOnClick

public void setOnClick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOnDblClick

public String getOnDblClick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOnDblClick

public void setOnDblClick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnMouseDown

public String getOnMouseDown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnMouseDown

public void setOnMouseDown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnMouseUp

public String getOnMouseUp()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnMouseUp

public void setOnMouseUp(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnMouseOver

public String getOnMouseOver()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnMouseOver

public void setOnMouseOver(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnMouseMove

public String getOnMouseMove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnMouseMove

public void setOnMouseMove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnMouseOut

public String getOnMouseOut()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnMouseOut

public void setOnMouseOut(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnKeyPress

public String getOnKeyPress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnKeyPress

public void setOnKeyPress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnKeyDown

public String getOnKeyDown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnKeyDown

public void setOnKeyDown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnKeyUp

public String getOnKeyUp()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnKeyUp

public void setOnKeyUp(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp

printOnClick

protected void printOnClick()
                     throws IOException
属性onClickを出力します。

例外:
IOException - 出力中に例外が発生

printOnDblClick

protected void printOnDblClick()
                        throws IOException
属性onDblClickを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseDown

protected void printOnMouseDown()
                         throws IOException
属性onMouseDownを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseUp

protected void printOnMouseUp()
                       throws IOException
属性onMouseUpを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseOver

protected void printOnMouseOver()
                         throws IOException
属性onMouseOverを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseMove

protected void printOnMouseMove()
                         throws IOException
属性onMouseMoveを出力します。

例外:
IOException - 出力中に例外が発生

printOnMouseOut

protected void printOnMouseOut()
                        throws IOException
属性onMouseOutを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyPress

protected void printOnKeyPress()
                        throws IOException
属性onKeyPressを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyDown

protected void printOnKeyDown()
                       throws IOException
属性onKeyDownを出力します。

例外:
IOException - 出力中に例外が発生

printOnKeyUp

protected void printOnKeyUp()
                     throws IOException
属性onKeyUpを出力します。

例外:
IOException - 出力中に例外が発生

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


GenericAttributes (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス GenericAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
直系の既知のサブクラス:
CoreAttributes, EventsAttributes, I18nAttributes
public abstract class GenericAttributes
extends Object

汎用属性の集合です。

バージョン:
1.0

コンストラクタの概要
GenericAttributes()
GenericAttributesを新規に生成します。
メソッドの概要
TagWriter | getTagWriter() TagWriterを取得します。
abstract void | printAttributes() 属性の内容を表示します。
void | setTagWriter(TagWriter writer) TagWriterを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

GenericAttributes

public GenericAttributes()
GenericAttributesを新規に生成します。

メソッドの詳細

getTagWriter

public TagWriter getTagWriter()
TagWriterを取得します。

戻り値:
TagWriter

setTagWriter

public void setTagWriter(TagWriter writer)
TagWriterを設定します。

パラメータ:
writer - TagWriter

printAttributes

public abstract void printAttributes()
                              throws IOException
属性の内容を表示します。

例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


I18nAttributes (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag.attribute
クラス I18nAttributes

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
        拡張 jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
public class I18nAttributes
extends GenericAttributes

国際化の属性です。

バージョン:
1.0

コンストラクタの概要
I18nAttributes()
I18nAttributesを新規に生成します。
メソッドの概要
String | getDir() 属性dirの値を取得します。
String | getLang() 属性langの値を取得します。
void | printAttributes() 属性の内容を表示します。
void | setDir(String dir) 属性dirの値を取得します。
void | setLang(String lang) 属性langの値を設定します。
クラス jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes から継承したメソッド
getTagWriter, setTagWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

I18nAttributes

public I18nAttributes()
I18nAttributesを新規に生成します。

メソッドの詳細

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を取得します。

パラメータ:
dir - dir

printAttributes

public void printAttributes()
                     throws IOException
属性の内容を表示します。

定義:
クラス GenericAttributes 内の printAttributes
例外:
IOException - 出力中に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.web.tag.attribute (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.web.tag.attribute
クラス
CoreAttributes
EventsAttributes
GenericAttributes
I18nAttributes


jp.co.intra_mart.framework.base.web.tag.attribute (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute

タグ属性のパッケージです。

参照:
説明

クラスの概要
CoreAttributes | コア属性です。
EventsAttributes | ブラウザのイベントに関連するタグの属性情報です。
GenericAttributes | 汎用属性の集合です。
I18nAttributes | 国際化の属性です。

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の説明

タグ属性のパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.web.tag.attribute クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.web.tag.attribute の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.tag.attribute の使用

jp.co.intra_mart.framework.base.web.tag.attribute を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute により使用される jp.co.intra_mart.framework.base.web.tag.attribute のクラス
GenericAttributes
汎用属性の集合です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.FormTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTag の使用

jp.co.intra_mart.framework.base.web.tag.FormTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.FormTEI の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FormTEI の使用

jp.co.intra_mart.framework.base.web.tag.FormTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.FrameTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTag の使用

jp.co.intra_mart.framework.base.web.tag.FrameTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.FrameTEI の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameTEI の使用

jp.co.intra_mart.framework.base.web.tag.FrameTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameworkTagException の使用

jp.co.intra_mart.framework.base.web.tag.FrameworkTagException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam の使用

jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTag の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI の使用

jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.LinkTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTag の使用

jp.co.intra_mart.framework.base.web.tag.LinkTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.LinkTEI の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.LinkTEI の使用

jp.co.intra_mart.framework.base.web.tag.LinkTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.MessageParamTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageParamTag の使用

jp.co.intra_mart.framework.base.web.tag.MessageParamTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.MessageTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageTag の使用

jp.co.intra_mart.framework.base.web.tag.MessageTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.MessageTEI の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.MessageTEI の使用

jp.co.intra_mart.framework.base.web.tag.MessageTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.base.web.tag.ParameterSendable の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.base.web.tag.ParameterSendable の使用

ParameterSendable を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag J2EEフレームワークで使用する各種のタグのパッケージです。

jp.co.intra_mart.framework.base.web.tag での ParameterSendable の使用

ParameterSendable を実装している jp.co.intra_mart.framework.base.web.tag のクラス
class | FrameTag FRAMEタグです。
class | LinkTag LINKタグです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.ParamTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.ParamTag の使用

jp.co.intra_mart.framework.base.web.tag.ParamTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag の使用

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTag の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTag はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.SubmitTEI の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.SubmitTEI の使用

jp.co.intra_mart.framework.base.web.tag.SubmitTEI はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.tag.TagWriter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.tag.TagWriter の使用

TagWriter を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag.attribute タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag.attribute での TagWriter の使用

TagWriter を返す jp.co.intra_mart.framework.base.web.tag.attribute のメソッド
 TagWriter GenericAttributes.getTagWriter()
TagWriterを取得します。

TagWriter 型のパラメータを持つ jp.co.intra_mart.framework.base.web.tag.attribute のメソッド
 void GenericAttributes.setTagWriter(TagWriter writer)
TagWriterを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FormTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.FormTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class FormTag
extends BodyTagSupport

FORMタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
FormTag()
FormTagを新規に生成します。
メソッドの概要
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccept() 属性acceptの値を取得します。
String | getAcceptcharset() 属性accept-charsetの値を取得します。
String | getApplication() 属性applicationの値を取得します。
String | getDir() 属性dirの値を取得します。
String | getEnctype() 属性enctypeの値を取得します。
String | getFormclass() 属性classの値を取得します。
String | getLang() 属性langの値を取得します。
String | getMethod() 属性methodの値を取得します。
String | getName() 属性nameの値を取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getOnreset() 属性onResetの値を取得します。
String | getOnsubmit() 属性onSubmitの値を取得します。
String | getService() 属性serviceの値を取得します。
String | getStyle() 属性styleの値を取得します。
String | getTarget() 属性targetの値を取得します。
String | getTitle() 属性titleの値を取得します。
void | setAccept(String accept) 属性acceptの値を設定します。
void | setAcceptcharset(String acceptCharset) 属性accept-charsetの値を設定します。
void | setApplication(String application) 属性applicationの値を設定します。
void | setDir(String dir) 属性dirの値を設定します。
void | setEnctype(String enctype) 属性enctypeの値を設定します。
void | setFormclass(String formClass) 属性classの値を設定します。
void | setLang(String lang) 属性langの値を設定します。
void | setMethod(String method) 属性methodの値を設定します。
void | setName(String name) 属性nameの値を設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setOnreset(String onReset) 属性onResetの値を設定します。
void | setOnsubmit(String onSubmit) 属性onSubmitの値を設定します。
void | setService(String service) 属性serviceの値を設定します。
void | setStyle(String style) 属性styleの値を設定します。
void | setTarget(String target) 属性targetの値を設定します。
void | setTitle(String title) 属性titleの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

FormTag

public FormTag()
FormTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 FORMタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 FORMタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

getApplication

public String getApplication()
属性applicationの値を取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
属性applicationの値を設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
属性serviceの値を取得します。

戻り値:
サービス

setService

public void setService(String service)
属性serviceの値を設定します。

パラメータ:
service - サービス

getMethod

public String getMethod()
属性methodの値を取得します。

戻り値:
method

setMethod

public void setMethod(String method)
属性methodの値を設定します。

パラメータ:
method - method

getEnctype

public String getEnctype()
属性enctypeの値を取得します。

戻り値:
enctype

getTarget

public String getTarget()
属性targetの値を取得します。

戻り値:
target

setTarget

public void setTarget(String target)
属性targetの値を設定します。

パラメータ:
target - target

setEnctype

public void setEnctype(String enctype)
属性enctypeの値を設定します。

パラメータ:
enctype - enctype

getAccept

public String getAccept()
属性acceptの値を取得します。

戻り値:
accept

setAccept

public void setAccept(String accept)
属性acceptの値を設定します。

パラメータ:
accept - accept

getName

public String getName()
属性nameの値を取得します。

戻り値:
name

setName

public void setName(String name)
属性nameの値を設定します。

パラメータ:
name - name

getOnsubmit

public String getOnsubmit()
属性onSubmitの値を取得します。

戻り値:
onSubmit

setOnsubmit

public void setOnsubmit(String onSubmit)
属性onSubmitの値を設定します。

パラメータ:
onSubmit - onSubmit

getOnreset

public String getOnreset()
属性onResetの値を取得します。

戻り値:
onReset

setOnreset

public void setOnreset(String onReset)
属性onResetの値を設定します。

パラメータ:
onReset - onReset

getAcceptcharset

public String getAcceptcharset()
属性accept-charsetの値を取得します。

戻り値:
accept-charset

setAcceptcharset

public void setAcceptcharset(String acceptCharset)
属性accept-charsetの値を設定します。

パラメータ:
acceptCharset - accept-charset

getFormclass

public String getFormclass()
属性classの値を取得します。

戻り値:
class

setFormclass

public void setFormclass(String formClass)
属性classの値を設定します。

パラメータ:
formClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FormTagBeanInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class FormTagBeanInfo
extends SimpleBeanInfo

FormTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
FormTagBeanInfo()
FormTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FormTagBeanInfo

public FormTagBeanInfo()
FormTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FormTEI (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FormTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FormTEI
public class FormTEI
extends TagExtraInfo

Formタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
FormTEI()
FormTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Formタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FormTEI

public FormTEI()
FormTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Formタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはformclass属性がある場合、いずれかのみが設定されている
  • acceptcharset属性またはaccept-charset属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FrameTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.FrameTag
すべての実装インタフェース:
BodyTag, IterationTag, ParameterSendable, Serializable, Tag
public class FrameTag
extends BodyTagSupport
implements ParameterSendable

FRAMEタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
FrameTag()
FrameTagを新規に生成します。
メソッドの概要
void | addParameter(String name, String value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() アプリケーションを取得します。
String | getFrameborder() frameborderを取得します。
String | getFrameclass() frameClassを取得します。
String | getFrameClass() 推奨されていません。 このメソッドではなくgetFrameclass()メソッドを使用してください。
String | getLongdesc() longdescを取得します。
String | getMarginheight() marginheightを取得します。
String | getMarginwidth() marginwidthを取得します。
String | getName() nameを取得します。
String | getNoresize() noresizeを取得します。
String | getScrolling() scrollingを取得します。
String | getService() サービスを取得します。
String | getStyle() styleを取得します。
String | getTitle() titleを取得します。
void | setApplication(String application) アプリケーションを設定します。
void | setFrameborder(String frameborder) frameborderを設定します。
void | setFrameclass(String frameClass) frameClassを設定します。
void | setFrameClass(String frameClass) 推奨されていません。 このメソッドではなくsetFrameclass(String)メソッドを使用してください。
void | setLongdesc(String longdesc) longdescを設定します。
void | setMarginheight(String marginheight) marginheightを設定します。
void | setMarginwidth(String marginwidth) marginwidthを設定します。
void | setName(String name) nameを設定します。
void | setNoresize(String noresize) noresizeを設定します。
void | setScrolling(String scrolling) scrollingを設定します。
void | setService(String service) serviceを設定します。
void | setStyle(String style) styleを設定します。
void | setTitle(String title) titleを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

FrameTag

public FrameTag()
FrameTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 FRAMEタグを解釈します。

定義:
インタフェース Tag 内の doStartTag
戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 FRAMEタグを終了します。

定義:
インタフェース Tag 内の doEndTag
戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

定義:
インタフェース ParameterSendable 内の addParameter
パラメータ:
name - パラメータ名
value - パラメータの値

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
serviceを設定します。

パラメータ:
service - サービス

getLongdesc

public String getLongdesc()
longdescを取得します。

戻り値:
longdesc

setLongdesc

public void setLongdesc(String longdesc)
longdescを設定します。

パラメータ:
longdesc - longdesc

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getFrameborder

public String getFrameborder()
frameborderを取得します。

戻り値:
frameborder

setFrameborder

public void setFrameborder(String frameborder)
frameborderを設定します。

パラメータ:
frameborder - frameborder

getMarginwidth

public String getMarginwidth()
marginwidthを取得します。

戻り値:
marginwidth

setMarginwidth

public void setMarginwidth(String marginwidth)
marginwidthを設定します。

パラメータ:
marginwidth - marginwidth

getMarginheight

public String getMarginheight()
marginheightを取得します。

戻り値:
marginheight

setMarginheight

public void setMarginheight(String marginheight)
marginheightを設定します。

パラメータ:
marginheight - marginheight

getNoresize

public String getNoresize()
noresizeを取得します。

戻り値:
noresize

setNoresize

public void setNoresize(String noresize)
noresizeを設定します。

パラメータ:
noresize - noresize

getScrolling

public String getScrolling()
scrollingを取得します。

戻り値:
scrolling

setScrolling

public void setScrolling(String scrolling)
scrollingを設定します。

パラメータ:
scrolling - scrolling

getFrameClass

public String getFrameClass()
推奨されていません。 このメソッドではなくgetFrameclass()メソッドを使用してください。

frameClassを取得します。

戻り値:
frameClass

setFrameClass

public void setFrameClass(String frameClass)
推奨されていません。 このメソッドではなくsetFrameclass(String)メソッドを使用してください。

frameClassを設定します。

パラメータ:
frameClass - frameClass

getFrameclass

public String getFrameclass()
frameClassを取得します。

戻り値:
frameClass

setFrameclass

public void setFrameclass(String frameClass)
frameClassを設定します。

パラメータ:
frameClass - frameClass

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FrameTagBeanInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class FrameTagBeanInfo
extends SimpleBeanInfo

FrameTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
FrameTagBeanInfo()
FrameTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameTagBeanInfo

public FrameTagBeanInfo()
FrameTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FrameTEI (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameTEI
public class FrameTEI
extends TagExtraInfo

Frameタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
FrameTEI()
FrameTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Frameタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameTEI

public FrameTEI()
FrameTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Frameタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはframeclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FrameworkTagException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameworkTagException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.jsp.JspException
                拡張 jp.co.intra_mart.framework.base.web.tag.FrameworkTagException
すべての実装インタフェース:
Serializable
public class FrameworkTagException
extends JspException

拡張タグの例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkTagException()
詳細メッセージを指定しないで FrameworkTagException を構築します。
FrameworkTagException(String msg)
指定された詳細メッセージを持つ FrameworkTagException を構築します。
FrameworkTagException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。
メソッドの概要
void | printStackTrace()
void | printStackTrace(PrintStream printStream)
void | printStackTrace(PrintWriter printWriter)
クラス javax.servlet.jsp.JspException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkTagException

public FrameworkTagException()
詳細メッセージを指定しないで FrameworkTagException を構築します。

FrameworkTagException

public FrameworkTagException(String msg)
指定された詳細メッセージを持つ FrameworkTagException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkTagException

public FrameworkTagException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外

FrameworkTagException

public FrameworkTagException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外
メソッドの詳細

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream printStream)

printStackTrace

public void printStackTrace(PrintWriter printWriter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FrameworkTagParam (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス FrameworkTagParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
public class FrameworkTagParam
extends PropertyParam

タグに追加されるパラメータです。

バージョン:
1.0

コンストラクタの概要
FrameworkTagParam()
FrameworkTagParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FrameworkTagParam

public FrameworkTagParam()
FrameworkTagParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


HelperBeanTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class HelperBeanTag
extends BodyTagSupport

HelperBeanタグです。

導入されたバージョン:
3.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
HelperBeanTag()
HelperBeanTagを新規に生成します。
メソッドの概要
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getHelperclass() クラス名を取得します。
void | setClass(String className) 推奨されていません。 このメソッドではなくsetHelperclass(java.lang.String)メソッドを使用してください。
void | setHelperclass(String helperclass) クラス名を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

HelperBeanTag

public HelperBeanTag()
HelperBeanTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 HelperBeanタグを解釈します。

戻り値:
SKIP_BODY
例外:
JspException - タグの解釈時に例外が発生

setClass

public void setClass(String className)
推奨されていません。 このメソッドではなくsetHelperclass(java.lang.String)メソッドを使用してください。

クラス名を設定します。

パラメータ:
className - クラス名

setHelperclass

public void setHelperclass(String helperclass)
クラス名を設定します。

パラメータ:
helperclass - クラス名
導入されたバージョン:
4.0

getHelperclass

public String getHelperclass()
クラス名を取得します。

戻り値:
クラス名
導入されたバージョン:
4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


HelperBeanTagBeanInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class HelperBeanTagBeanInfo
extends SimpleBeanInfo

HelperBeanTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
HelperBeanTagBeanInfo()
HelperBeanTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBeanTagBeanInfo

public HelperBeanTagBeanInfo()
HelperBeanTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


HelperBeanTEI (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス HelperBeanTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
public class HelperBeanTEI
extends TagExtraInfo

HelperBeanタグの拡張情報です。

導入されたバージョン:
3.2

コンストラクタの概要
HelperBeanTEI()
HelperBeanTEIを新規に生成します。
メソッドの概要
VariableInfo[] | getVariableInfo(TagData tagData) スクリプティング変数に関連付けたHelperBeanの情報を取得します。
boolean | isValid(TagData tagData) HelperBeanタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HelperBeanTEI

public HelperBeanTEI()
HelperBeanTEIを新規に生成します。

メソッドの詳細

getVariableInfo

public VariableInfo[] getVariableInfo(TagData tagData)
スクリプティング変数に関連付けたHelperBeanの情報を取得します。 属性idで指定された変数に属性class（またはhelperclass）で指定されたHelperBeanを割り当てます。

パラメータ:
tagData - タグデータ
戻り値:
スクリプティング変数の情報

isValid

public boolean isValid(TagData tagData)
HelperBeanタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはhelperclass属性のいずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
導入されたバージョン:
4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LinkTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.LinkTag
すべての実装インタフェース:
BodyTag, IterationTag, ParameterSendable, Serializable, Tag
public class LinkTag
extends BodyTagSupport
implements ParameterSendable

LINKタグです。 intra-martフレームワークを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
LinkTag()
LinkTagを新規に生成します。
メソッドの概要
void | addParameter(String name, String value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccesskey() accesskeyを取得します。
String | getApplication() アプリケーションを取得します。
String | getCharset() charsetを取得します。
String | getCoords() coordsを取得します。
String | getDir() dirを取得します。
String | getHreflang() hreflangを取得します。
String | getLang() langを取得します。
String | getLinkclass() linkClassを取得します。
String | getLinkClass() 推奨されていません。 このメソッドではなくgetLinkclass()メソッドを使用してください。
String | getName() nameを取得します。
String | getOnblur() onblurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() onfocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getRel() relを取得します。
String | getRev() revを取得します。
String | getService() サービスを取得します。
String | getShape() shapeを取得します。
String | getStyle() styleを取得します。
String | getTabindex() tabindexを取得します。
String | getTarget() targetを取得します。
String | getTitle() titleを取得します。
String | getType() typeを取得します。
void | setAccesskey(String accesskey) accesskeyを設定します。
void | setApplication(String application) アプリケーションを設定します。
void | setCharset(String charset) charsetを設定します。
void | setCoords(String coords) coordsを設定します。
void | setDir(String dir) dirを設定します。
void | setHreflang(String hreflang) hreflangを設定します。
void | setLang(String lang) langを設定します。
void | setLinkclass(String linkClass) linkClassを設定します。
void | setLinkClass(String linkClass) 推奨されていません。 このメソッドではなくsetLinkclass(String)メソッドを使用してください。
void | setName(String name) nameを設定します。
void | setOnblur(String onblur) onblurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onfocus) onfocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setRel(String rel) relを設定します。
void | setRev(String rev) relを設定します。
void | setService(String service) serviceを設定します。
void | setShape(String shape) shapeを設定します。
void | setStyle(String style) styleを設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTarget(String target) targetを設定します。
void | setTitle(String title) titleを設定します。
void | setType(String type) typeを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

LinkTag

public LinkTag()
LinkTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 LINKタグを解釈します。

定義:
インタフェース Tag 内の doStartTag
戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 LINKタグを終了します。

定義:
インタフェース Tag 内の doEndTag
戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

定義:
インタフェース ParameterSendable 内の addParameter
パラメータ:
name - パラメータ名
value - パラメータの値

getCharset

public String getCharset()
charsetを取得します。

戻り値:
charset

setCharset

public void setCharset(String charset)
charsetを設定します。

パラメータ:
charset - charset

getType

public String getType()
typeを取得します。

戻り値:
type

setType

public void setType(String type)
typeを設定します。

パラメータ:
type - type

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
serviceを設定します。

パラメータ:
service - サービス

getHreflang

public String getHreflang()
hreflangを取得します。

戻り値:
hreflang

setHreflang

public void setHreflang(String hreflang)
hreflangを設定します。

パラメータ:
hreflang - hreflang

getRel

public String getRel()
relを取得します。

戻り値:
rel

setRel

public void setRel(String rel)
relを設定します。

パラメータ:
rel - rel

getRev

public String getRev()
revを取得します。

戻り値:
rev

setRev

public void setRev(String rev)
relを設定します。

パラメータ:
rev - rev

getAccesskey

public String getAccesskey()
accesskeyを取得します。

戻り値:
accesskey

setAccesskey

public void setAccesskey(String accesskey)
accesskeyを設定します。

パラメータ:
accesskey - accesskey

getShape

public String getShape()
shapeを取得します。

戻り値:
shape

setShape

public void setShape(String shape)
shapeを設定します。

パラメータ:
shape - shape

getCoords

public String getCoords()
coordsを取得します。

戻り値:
coords

setCoords

public void setCoords(String coords)
coordsを設定します。

パラメータ:
coords - coords

getTarget

public String getTarget()
targetを取得します。

戻り値:
target
導入されたバージョン:
3.2

setTarget

public void setTarget(String target)
targetを設定します。

パラメータ:
target - target
導入されたバージョン:
3.2

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
onfocusを取得します。

戻り値:
onfocus

setOnfocus

public void setOnfocus(String onfocus)
onfocusを設定します。

パラメータ:
onfocus - onfocus

getOnblur

public String getOnblur()
onblurを取得します。

戻り値:
onblur

setOnblur

public void setOnblur(String onblur)
onblurを設定します。

パラメータ:
onblur - onblur

getLinkClass

public String getLinkClass()
推奨されていません。 このメソッドではなくgetLinkclass()メソッドを使用してください。

linkClassを取得します。

戻り値:
linkClass

setLinkClass

public void setLinkClass(String linkClass)
推奨されていません。 このメソッドではなくsetLinkclass(String)メソッドを使用してください。

linkClassを設定します。

パラメータ:
linkClass - class

getLinkclass

public String getLinkclass()
linkClassを取得します。

戻り値:
linkClass

setLinkclass

public void setLinkclass(String linkClass)
linkClassを設定します。

パラメータ:
linkClass - class

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title

getLang

public String getLang()
langを取得します。

戻り値:
lang

setLang

public void setLang(String lang)
langを設定します。

パラメータ:
lang - lang

getDir

public String getDir()
dirを取得します。

戻り値:
dir

setDir

public void setDir(String dir)
dirを設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LinkTagBeanInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class LinkTagBeanInfo
extends SimpleBeanInfo

LinkTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
LinkTagBeanInfo()
LinkTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkTagBeanInfo

public LinkTagBeanInfo()
LinkTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LinkTEI (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス LinkTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.LinkTEI
public class LinkTEI
extends TagExtraInfo

Linkタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
LinkTEI()
LinkTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LinkTEI

public LinkTEI()
LinkTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはlinkclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessageParamTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageParamTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.MessageParamTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class MessageParamTag
extends BodyTagSupport

メッセージの生成で使用するパラメータを設定します。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
MessageParamTag()
ParamTagを新規に生成します。
メソッドの概要
int | doStartTag() 外側の一番近いMessageTagにパラメータを設定します。
Object | getValue() パラメータの値を取得します。
void | setValue(Object value) パラメータの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

MessageParamTag

public MessageParamTag()
ParamTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
外側の一番近いMessageTagにパラメータを設定します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getValue

public Object getValue()
パラメータの値を取得します。

戻り値:
パラメータの値

setValue

public void setValue(Object value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessageTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.MessageTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class MessageTag
extends BodyTagSupport

Messageタグです。 im-J2EE Frameworkを使用する場合のMessageフレームワークの一部となります。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
MessageTag()
MessageTagを新規に生成します。
メソッドの概要
void | addParameter(Object value) パラメータを追加します。
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() applicationを取得します。
String | getKey() keyを取得します。
String | getLocale() localeを取得します。
void | setApplication(String application) applicationを設定します。
void | setKey(String key) keyを設定します。
void | setLocale(String locale) localeを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

MessageTag

public MessageTag()
MessageTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 Messageタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 Messageタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

addParameter

public void addParameter(Object value)
パラメータを追加します。

パラメータ:
value - パラメータの値

getApplication

public String getApplication()
applicationを取得します。

戻り値:
application

setApplication

public void setApplication(String application)
applicationを設定します。

パラメータ:
application - application

getKey

public String getKey()
keyを取得します。

戻り値:
key

setKey

public void setKey(String key)
keyを設定します。

パラメータ:
key - key

getLocale

public String getLocale()
localeを取得します。

戻り値:
locale

setLocale

public void setLocale(String locale)
localeを設定します。

パラメータ:
locale - locale
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessageTEI (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス MessageTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.MessageTEI
public class MessageTEI
extends TagExtraInfo

Messageタグの拡張情報です。

導入されたバージョン:
4.2

コンストラクタの概要
MessageTEI()
メソッドの概要
 boolean isValid(TagData tagData)
Messageタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MessageTEI

public MessageTEI()
メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Messageタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • locale属性が指定されている場合、書式が言語_国[_バリアント]となっていること
    ロケール文字列のアンダーバー(_)はハイフン(-)であってもかまいません。
locale属性が指定されていない場合、trueが返されます。

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.web.tag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.web.tag
インタフェース
ParameterSendable
クラス
FormTag
FormTagBeanInfo
FormTEI
FrameTag
FrameTagBeanInfo
FrameTEI
FrameworkTagParam
HelperBeanTag
HelperBeanTagBeanInfo
HelperBeanTEI
LinkTag
LinkTagBeanInfo
LinkTEI
MessageParamTag
MessageTag
MessageTEI
ParamTag
SubmitLinkTag
SubmitLinkTagBeanInfo
SubmitTag
SubmitTagBeanInfo
SubmitTEI
TagWriter
例外
FrameworkTagException


jp.co.intra_mart.framework.base.web.tag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag

J2EEフレームワークで使用する各種のタグのパッケージです。

参照:
説明

インタフェースの概要
ParameterSendable パラメータを渡すことができるタグです。

クラスの概要
FormTag | FORMタグです。
FormTagBeanInfo | FormTagのBeanInfoです。
FormTEI | Formタグの拡張情報です。
FrameTag | FRAMEタグです。
FrameTagBeanInfo | FrameTagのBeanInfoです。
FrameTEI | Frameタグの拡張情報です。
FrameworkTagParam | タグに追加されるパラメータです。
HelperBeanTag | HelperBeanタグです。
HelperBeanTagBeanInfo | HelperBeanTagのBeanInfoです。
HelperBeanTEI | HelperBeanタグの拡張情報です。
LinkTag | LINKタグです。
LinkTagBeanInfo | LinkTagのBeanInfoです。
LinkTEI | Linkタグの拡張情報です。
MessageParamTag | メッセージの生成で使用するパラメータを設定します。
MessageTag | Messageタグです。
MessageTEI | Messageタグの拡張情報です。
ParamTag | リンク先、遷移先に渡すパラメータを設定します。
SubmitLinkTag | サブミット専用のLINKタグです。
SubmitLinkTagBeanInfo | SubmitLinkTagのBeanInfoです。
SubmitTag | Submitタグです。
SubmitTagBeanInfo | SubmitTagのBeanInfoです。
SubmitTEI | Submitタグの拡張情報です。
TagWriter | タグの出力を行います。

例外の概要
FrameworkTagException 拡張タグの例外です。

パッケージ jp.co.intra_mart.framework.base.web.tag の説明

J2EEフレームワークで使用する各種のタグのパッケージです。 セッション情報を保ったまま画面遷移することが可能になります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.web.tag クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.tag の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
    • class java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
      • class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
    • class javax.servlet.jsp.tagext.TagExtraInfo
      • class jp.co.intra_mart.framework.base.web.tag.FormTEI
      • class jp.co.intra_mart.framework.base.web.tag.FrameTEI
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
      • class jp.co.intra_mart.framework.base.web.tag.LinkTEI
      • class jp.co.intra_mart.framework.base.web.tag.MessageTEI
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTEI
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • class jp.co.intra_mart.framework.base.web.tag.FormTag
        • class jp.co.intra_mart.framework.base.web.tag.FrameTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
        • class jp.co.intra_mart.framework.base.web.tag.LinkTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.MessageParamTag
        • class jp.co.intra_mart.framework.base.web.tag.MessageTag
        • class jp.co.intra_mart.framework.base.web.tag.ParamTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitTag
    • class jp.co.intra_mart.framework.base.web.tag.TagWriter
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.jsp.JspException
          • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException

インタフェース階層

  • interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.web.tag の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.tag の使用

jp.co.intra_mart.framework.base.web.tag を使用しているパッケージ
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute | タグ属性のパッケージです。

jp.co.intra_mart.framework.base.web.tag により使用される jp.co.intra_mart.framework.base.web.tag のクラス
ParameterSendable
パラメータを渡すことができるタグです。

jp.co.intra_mart.framework.base.web.tag.attribute により使用される jp.co.intra_mart.framework.base.web.tag のクラス
TagWriter
タグの出力を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ParameterSendable (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
インタフェース ParameterSendable

既知の実装クラスの一覧:
FrameTag, LinkTag
public interface ParameterSendable

パラメータを渡すことができるタグです。

バージョン:
1.0

メソッドの概要
 void addParameter(String name, String value)
パラメータを追加します。

メソッドの詳細

addParameter

public void addParameter(String name,
                         String value)
パラメータを追加します。

パラメータ:
name - パラメータ名
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ParamTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス ParamTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.ParamTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class ParamTag
extends BodyTagSupport

リンク先、遷移先に渡すパラメータを設定します。

バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
ParamTag()
ParamTagを新規に生成します。
メソッドの概要
int | doStartTag() 外側の一番近いParameterSendableにパラメータを設定します。
String | getName() パラメータ名を取得します。
String | getValue() パラメータの値を取得します。
void | setName(String name) パラメータ名を設定します。
void | setValue(String value) パラメータの値を設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

ParamTag

public ParamTag()
ParamTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
外側の一番近いParameterSendableにパラメータを設定します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getName

public String getName()
パラメータ名を取得します。

戻り値:
パラメータ名

setName

public void setName(String name)
パラメータ名を設定します。

パラメータ:
name - パラメータ名

getValue

public String getValue()
パラメータの値を取得します。

戻り値:
パラメータの値

setValue

public void setValue(String value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SubmitLinkTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitLinkTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class SubmitLinkTag
extends BodyTagSupport

サブミット専用のLINKタグです。 im-J2EE Frameworkを使用する場合のセッションフレームワーク、サービスフレームワークの一部となります。

導入されたバージョン:
4.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
SubmitLinkTag()
SubmitLinkTagを新規に生成します。
メソッドの概要
int | doEndTag() 終了タグを検知したときにJSPエンジンから呼ばれます。
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getAccesskey() accesskeyを取得します。
String | getApplication() アプリケーションを取得します。
String | getCoords() coordsを取得します。
String | getDir() dirを取得します。
String | getForm() ターゲットとなるフォーム名を取得します。
String | getLang() langを取得します。
String | getLinkclass() linkClassを取得します。
String | getName() nameを取得します。
String | getOnblur() onblurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() onfocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getService() サービスを取得します。
String | getShape() shapeを取得します。
String | getStyle() styleを取得します。
String | getTabindex() tabindexを取得します。
String | getTitle() titleを取得します。
void | setAccesskey(String accesskey) accesskeyを設定します。
void | setApplication(String application) アプリケーションを設定します。
void | setCoords(String coords) coordsを設定します。
void | setDir(String dir) dirを設定します。
void | setForm(String form) ターゲットとなるフォーム名を設定します。
void | setLang(String lang) langを設定します。
void | setLinkclass(String linkClass) linkClassを設定します。
void | setName(String name) nameを設定します。
void | setOnblur(String onblur) onblurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onfocus) onfocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setService(String service) サービスを設定します。
void | setShape(String shape) shapeを設定します。
void | setStyle(String style) styleを設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTitle(String title) titleを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

SubmitLinkTag

public SubmitLinkTag()
SubmitLinkTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 SUBMIT LINKタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - タグの解釈時に例外が発生

doEndTag

public int doEndTag()
             throws JspException
終了タグを検知したときにJSPエンジンから呼ばれます。 SUBMIT LINKタグを終了します。

戻り値:
EVAL_PAGE
例外:
JspException - タグの終了時に例外が発生

getName

public String getName()
nameを取得します。

戻り値:
name

setName

public void setName(String name)
nameを設定します。

パラメータ:
name - name

getApplication

public String getApplication()
アプリケーションを取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
アプリケーションを設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
サービスを取得します。

戻り値:
サービス

setService

public void setService(String service)
サービスを設定します。

パラメータ:
service - サービス

getForm

public String getForm()
ターゲットとなるフォーム名を取得します。

戻り値:
ターゲットとなるフォーム名

setForm

public void setForm(String form)
ターゲットとなるフォーム名を設定します。

パラメータ:
form - ターゲットとなるフォーム名

getAccesskey

public String getAccesskey()
accesskeyを取得します。

戻り値:
accesskey

setAccesskey

public void setAccesskey(String accesskey)
accesskeyを設定します。

パラメータ:
accesskey - accesskey

getShape

public String getShape()
shapeを取得します。

戻り値:
shape

setShape

public void setShape(String shape)
shapeを設定します。

パラメータ:
shape - shape

getCoords

public String getCoords()
coordsを取得します。

戻り値:
coords

setCoords

public void setCoords(String coords)
coordsを設定します。

パラメータ:
coords - coords

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
onfocusを取得します。

戻り値:
onfocus

setOnfocus

public void setOnfocus(String onfocus)
onfocusを設定します。

パラメータ:
onfocus - onfocus

getOnblur

public String getOnblur()
onblurを取得します。

戻り値:
onblur

setOnblur

public void setOnblur(String onblur)
onblurを設定します。

パラメータ:
onblur - onblur

getLinkclass

public String getLinkclass()
linkClassを取得します。

戻り値:
linkClass

setLinkclass

public void setLinkclass(String linkClass)
linkClassを設定します。

パラメータ:
linkClass - class

getStyle

public String getStyle()
styleを取得します。

戻り値:
style

setStyle

public void setStyle(String style)
styleを設定します。

パラメータ:
style - style

getTitle

public String getTitle()
titleを取得します。

戻り値:
title

setTitle

public void setTitle(String title)
titleを設定します。

パラメータ:
title - title

getLang

public String getLang()
langを取得します。

戻り値:
lang

setLang

public void setLang(String lang)
langを設定します。

パラメータ:
lang - lang

getDir

public String getDir()
dirを取得します。

戻り値:
dir

setDir

public void setDir(String dir)
dirを設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SubmitLinkTagBeanInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitLinkTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class SubmitLinkTagBeanInfo
extends SimpleBeanInfo

SubmitLinkTagのBeanInfoです。

導入されたバージョン:
4.2

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
SubmitLinkTagBeanInfo()
SubmitLinkTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitLinkTagBeanInfo

public SubmitLinkTagBeanInfo()
SubmitLinkTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SubmitTag (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTag

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagSupport
        拡張 javax.servlet.jsp.tagext.BodyTagSupport
            拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTag
すべての実装インタフェース:
BodyTag, IterationTag, Serializable, Tag
public class SubmitTag
extends BodyTagSupport

Submitタグです。 intra-martフレームワークのFormタグ内でのみ使用できるタグです。

導入されたバージョン:
3.2
関連項目:
直列化された形式

フィールドの概要
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したフィールド
bodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したフィールド
id, pageContext
インタフェース javax.servlet.jsp.tagext.BodyTag から継承したフィールド
EVAL_BODY_BUFFERED, EVAL_BODY_TAG
インタフェース javax.servlet.jsp.tagext.IterationTag から継承したフィールド
EVAL_BODY_AGAIN
インタフェース javax.servlet.jsp.tagext.Tag から継承したフィールド
EVAL_BODY_INCLUDE, EVAL_PAGE, SKIP_BODY, SKIP_PAGE
コンストラクタの概要
SubmitTag()
SubmitTagを新規に生成します。
メソッドの概要
int | doStartTag() 開始タグを検知したときにJSPエンジンから呼ばれます。
String | getApplication() 属性applicationの値を取得します。
String | getDir() 属性dirの値を取得します。
String | getLang() 属性langの値を取得します。
String | getName() 属性nameを取得します。
String | getOnblur() 属性onBlurを取得します。
String | getOnclick() 属性onClickの値を取得します。
String | getOndblclick() 属性onDblClickの値を取得します。
String | getOnfocus() 属性onFocusを取得します。
String | getOnkeydown() 属性onKeyDownの値を取得します。
String | getOnkeypress() 属性onKeyPressの値を取得します。
String | getOnkeyup() 属性onKeyUpの値を取得します。
String | getOnmousedown() 属性onMouseDownの値を取得します。
String | getOnmousemove() 属性onMouseMoveの値を取得します。
String | getOnmouseout() 属性onMouseOutの値を取得します。
String | getOnmouseover() 属性onMouseOverの値を取得します。
String | getOnmouseup() 属性onMouseUpの値を取得します。
String | getService() 属性serviceの値を取得します。
String | getStyle() 属性styleの値を取得します。
String | getSubmitclass() 属性classの値を取得します。
String | getTabindex() tabindexを取得します。
String | getTitle() 属性titleの値を取得します。
String | getValue() 属性valueを取得します。
void | setApplication(String application) 属性applicationの値を設定します。
void | setDir(String dir) 属性dirの値を設定します。
void | setLang(String lang) 属性langの値を設定します。
void | setName(String name) 属性nameを設定します。
void | setOnblur(String onBlur) 属性onBlurを設定します。
void | setOnclick(String onClick) 属性onClickの値を設定します。
void | setOndblclick(String onDblClick) 属性obDblClickの値を設定します。
void | setOnfocus(String onFocus) 属性onFocusを設定します。
void | setOnkeydown(String onKeyDown) 属性onKeyDownの値を設定します。
void | setOnkeypress(String onKeyPress) 属性onKeyPressの値を設定します。
void | setOnkeyup(String onKeyUp) 属性onKeyUpの値を設定します。
void | setOnmousedown(String onMouseDown) 属性onMouseDownの値を設定します。
void | setOnmousemove(String onMouseMove) 属性onMouseMoveの値を設定します。
void | setOnmouseout(String onMouseOut) 属性onMouseOutの値を設定します。
void | setOnmouseover(String onMouseOver) 属性onMouseOverの値を設定します。
void | setOnmouseup(String onMouseUp) 属性onMouseUpの値を設定します。
void | setService(String service) 属性serviceの値を設定します。
void | setStyle(String style) 属性styleの値を設定します。
void | setSubmitclass(String submitClass) 属性classの値を設定します。
void | setTabindex(String tabindex) tabindexを設定します。
void | setTitle(String title) 属性titleの値を設定します。
void | setValue(String value) 属性valueを設定します。
クラス javax.servlet.jsp.tagext.BodyTagSupport から継承したメソッド
doAfterBody, doEndTag, doInitBody, getBodyContent, getPreviousOut, release, setBodyContent
クラス javax.servlet.jsp.tagext.TagSupport から継承したメソッド
findAncestorWithClass, getId, getParent, getValue, getValues, removeValue, setId, setPageContext, setParent, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.jsp.tagext.Tag から継承したメソッド
getParent, setPageContext, setParent

コンストラクタの詳細

SubmitTag

public SubmitTag()
SubmitTagを新規に生成します。

メソッドの詳細

doStartTag

public int doStartTag()
               throws JspException
開始タグを検知したときにJSPエンジンから呼ばれます。 Submitタグを解釈します。

戻り値:
EVAL_BODY_BUFFERED
例外:
JspException - JSP出力時に例外が発生

getApplication

public String getApplication()
属性applicationの値を取得します。

戻り値:
アプリケーション

setApplication

public void setApplication(String application)
属性applicationの値を設定します。

パラメータ:
application - アプリケーション

getService

public String getService()
属性serviceの値を取得します。

戻り値:
サービス

setService

public void setService(String service)
属性serviceの値を設定します。

パラメータ:
service - サービス

getName

public String getName()
属性nameを取得します。

戻り値:
name

setName

public void setName(String name)
属性nameを設定します。

パラメータ:
name - name

getValue

public String getValue()
属性valueを取得します。

戻り値:
value

setValue

public void setValue(String value)
属性valueを設定します。

パラメータ:
value - value

getTabindex

public String getTabindex()
tabindexを取得します。

戻り値:
tabindex

setTabindex

public void setTabindex(String tabindex)
tabindexを設定します。

パラメータ:
tabindex - tabindex

getOnfocus

public String getOnfocus()
属性onFocusを取得します。

戻り値:
onFocus

setOnfocus

public void setOnfocus(String onFocus)
属性onFocusを設定します。

パラメータ:
onFocus - onFocus

getOnblur

public String getOnblur()
属性onBlurを取得します。

戻り値:
onBlur

setOnblur

public void setOnblur(String onBlur)
属性onBlurを設定します。

パラメータ:
onBlur - onBlur

getSubmitclass

public String getSubmitclass()
属性classの値を取得します。

戻り値:
class

setSubmitclass

public void setSubmitclass(String submitClass)
属性classの値を設定します。

パラメータ:
submitClass - class

getStyle

public String getStyle()
属性styleの値を取得します。

戻り値:
style

setStyle

public void setStyle(String style)
属性styleの値を設定します。

パラメータ:
style - style

getTitle

public String getTitle()
属性titleの値を取得します。

戻り値:
title

setTitle

public void setTitle(String title)
属性titleの値を設定します。

パラメータ:
title - title

getLang

public String getLang()
属性langの値を取得します。

戻り値:
lang

setLang

public void setLang(String lang)
属性langの値を設定します。

パラメータ:
lang - lang

getDir

public String getDir()
属性dirの値を取得します。

戻り値:
dir

setDir

public void setDir(String dir)
属性dirの値を設定します。

パラメータ:
dir - dir

getOnclick

public String getOnclick()
属性onClickの値を取得します。

戻り値:
onClick

setOnclick

public void setOnclick(String onClick)
属性onClickの値を設定します。

パラメータ:
onClick - onClick

getOndblclick

public String getOndblclick()
属性onDblClickの値を取得します。

戻り値:
onDblClick

setOndblclick

public void setOndblclick(String onDblClick)
属性obDblClickの値を設定します。

パラメータ:
onDblClick - onDblClick

getOnmousedown

public String getOnmousedown()
属性onMouseDownの値を取得します。

戻り値:
onMouseDown

setOnmousedown

public void setOnmousedown(String onMouseDown)
属性onMouseDownの値を設定します。

パラメータ:
onMouseDown - onMouseDown

getOnmouseup

public String getOnmouseup()
属性onMouseUpの値を取得します。

戻り値:
onMouseUp

setOnmouseup

public void setOnmouseup(String onMouseUp)
属性onMouseUpの値を設定します。

パラメータ:
onMouseUp - onMouseUp

getOnmouseover

public String getOnmouseover()
属性onMouseOverの値を取得します。

戻り値:
onMouseOver

setOnmouseover

public void setOnmouseover(String onMouseOver)
属性onMouseOverの値を設定します。

パラメータ:
onMouseOver - onMouseOver

getOnmousemove

public String getOnmousemove()
属性onMouseMoveの値を取得します。

戻り値:
onMouseMove

setOnmousemove

public void setOnmousemove(String onMouseMove)
属性onMouseMoveの値を設定します。

パラメータ:
onMouseMove - onMouseMove

getOnmouseout

public String getOnmouseout()
属性onMouseOutの値を取得します。

戻り値:
onMouseOut

setOnmouseout

public void setOnmouseout(String onMouseOut)
属性onMouseOutの値を設定します。

パラメータ:
onMouseOut - onMouseOut

getOnkeypress

public String getOnkeypress()
属性onKeyPressの値を取得します。

戻り値:
onKeyPress

setOnkeypress

public void setOnkeypress(String onKeyPress)
属性onKeyPressの値を設定します。

パラメータ:
onKeyPress - onKeyPress

getOnkeydown

public String getOnkeydown()
属性onKeyDownの値を取得します。

戻り値:
onKeyDown

setOnkeydown

public void setOnkeydown(String onKeyDown)
属性onKeyDownの値を設定します。

パラメータ:
onKeyDown - onKeyDown

getOnkeyup

public String getOnkeyup()
属性onKeyUpの値を取得します。

戻り値:
onKeyUp

setOnkeyup

public void setOnkeyup(String onKeyUp)
属性onKeyUpの値を設定します。

パラメータ:
onKeyUp - onKeyUp
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SubmitTagBeanInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTagBeanInfo

java.lang.Object
    拡張 java.beans.SimpleBeanInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
すべての実装インタフェース:
BeanInfo
public class SubmitTagBeanInfo
extends SimpleBeanInfo

SubmitTagのBeanInfoです。

導入されたバージョン:
4.0

フィールドの概要
インタフェース java.beans.BeanInfo から継承したフィールド
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
コンストラクタの概要
SubmitTagBeanInfo()
SubmitTagBeanInfoを新規に生成します。
メソッドの概要
 PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。
クラス java.beans.SimpleBeanInfo から継承したメソッド
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, loadImage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitTagBeanInfo

public SubmitTagBeanInfo()
SubmitTagBeanInfoを新規に生成します。

メソッドの詳細

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
PropertyDescriptorを取得します。

戻り値:
PropertyDescriptor
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SubmitTEI (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス SubmitTEI

java.lang.Object
    拡張 javax.servlet.jsp.tagext.TagExtraInfo
        拡張 jp.co.intra_mart.framework.base.web.tag.SubmitTEI
public class SubmitTEI
extends TagExtraInfo

Submitタグの拡張情報です。

導入されたバージョン:
4.0

コンストラクタの概要
SubmitTEI()
SubmitTEIを新規に生成します。
メソッドの概要
 boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。
クラス javax.servlet.jsp.tagext.TagExtraInfo から継承したメソッド
getTagInfo, getVariableInfo, setTagInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SubmitTEI

public SubmitTEI()
SubmitTEIを新規に生成します。

メソッドの詳細

isValid

public boolean isValid(TagData tagData)
Linkタグに指定された内容の正当性を検証します。 検証内容は以下のとおりです。
  • class属性またはsubmitclass属性がある場合、いずれかのみが設定されている

パラメータ:
tagData - タグ情報
戻り値:
タグが正当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


TagWriter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.tag
クラス TagWriter

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.tag.TagWriter
public class TagWriter
extends Object

タグの出力を行います。

バージョン:
1.0

コンストラクタの概要
TagWriter(JspWriter writer)
TagWriterを新規に生成します。
メソッドの概要
static String | createURL(String url, Collection params) 推奨されていません。 このメソッドではなくcreateURL(String, Collection, String)を使用してください。
static String | createURL(String url, Collection params, String encoding) 複数のパラメータをURLに追加します。
void | printAttribute(String name, String value) 属性を出力します。
void | printURL(String url) URLを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TagWriter

public TagWriter(JspWriter writer)
TagWriterを新規に生成します。

パラメータ:
writer - JSP出力子
メソッドの詳細

createURL

public static String createURL(String url,
                               Collection params)
                        throws IOException
推奨されていません。 このメソッドではなくcreateURL(String, Collection, String)を使用してください。

複数のパラメータをURLに追加します。 paramsはFrameworkTagParamの集合（java.util.Collection）である必要があります。

パラメータ:
url - 元のURL
params - 追加するパラメータ
戻り値:
パラメータが追加されたURL
例外:
IOException - 出力時に例外が発生

createURL

public static String createURL(String url,
                               Collection params,
                               String encoding)
                        throws IOException
複数のパラメータをURLに追加します。 paramsはFrameworkTagParamの集合（java.util.Collection）である必要があります。

パラメータ:
url - 元のURL
params - 追加するパラメータ
encoding - エンコーディング
戻り値:
パラメータが追加されたURL
例外:
IOException - 出力時に例外が発生
導入されたバージョン:
4.3

printURL

public void printURL(String url)
              throws IOException
URLを出力します。 このurlは<FORM>タグのaction属性、<A>タグのhref属性、<FRAME>タグのsrc属性などに定義するものと同じです。

パラメータ:
url - 出力するURL
例外:
IOException - 出力時に例外が発生

printAttribute

public void printAttribute(String name,
                           String value)
                    throws IOException
属性を出力します。 タグの属性として属性名="属性値"の形式で出力します。 属性値がnullまたは空文字列である場合、何も出力しません。

パラメータ:
name - 属性名
value - 属性値
例外:
IOException - 出力時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.base.web.util.HTMLEncoder の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.base.web.util.HTMLEncoder の使用

jp.co.intra_mart.framework.base.web.util.HTMLEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


HTMLEncoder (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.base.web.util
クラス HTMLEncoder

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.web.util.HTMLEncoder
public class HTMLEncoder
extends Object

文字列をHTML形式で表示するための変換を行うユーティリティクラスです。

バージョン:
1.0

コンストラクタの概要
HTMLEncoder()
メソッドの概要
static String | encodeCaption(String caption) キャプションを変換します。
static String | encodeValue(String value) <TEXTAREA>タグまたはvalue属性に入る文字列を変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTMLEncoder

public HTMLEncoder()
メソッドの詳細

encodeCaption

public static String encodeCaption(String caption)
キャプションを変換します。 HTML中で特殊な扱いを受ける文字（>,<等）を変換します。
ここでは以下の変換が行われます。
変換前 | 変換後
> &gt;
< &lt;
& &amp;
" &quot;
(半角空白) | &nbsp;
(改行)(*) | <BR>

(*)変換ルールは以下のとおりです。
"\n" -> "\n"
"\r" -> "\n"
ただし、"\r"と"\n"が連続して続く箇所は"\r\n" -> "\n"となります。

パラメータ:
caption - 変換前のキャプション
戻り値:
変換後のキャプション

encodeValue

public static String encodeValue(String value)
<TEXTAREA>タグまたはvalue属性に入る文字列を変換します。 ここでは以下の変換が行われます。
変換前 変換後
> &gt;
< &lt;
& &amp;
" &quot;

パラメータ:
value - 変換前の値
戻り値:
変換後の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.web.util (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.base.web.util
クラス
HTMLEncoder


jp.co.intra_mart.framework.base.web.util (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.util

Web上で使用するユーティリティのパッケージです。

参照:
説明

クラスの概要
HTMLEncoder 文字列をHTML形式で表示するための変換を行うユーティリティクラスです。

パッケージ jp.co.intra_mart.framework.base.web.util の説明

Web上で使用するユーティリティのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.base.web.util クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.base.web.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.web.util.HTMLEncoder
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.base.web.util の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.base.web.util の使用

jp.co.intra_mart.framework.base.web.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.BadRequestException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.BadRequestException の使用

jp.co.intra_mart.framework.presentation.BadRequestException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.DuplicateException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.DuplicateException の使用

jp.co.intra_mart.framework.presentation.DuplicateException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.MismatchException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.MismatchException の使用

jp.co.intra_mart.framework.presentation.MismatchException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.NameFormatException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.NameFormatException の使用

jp.co.intra_mart.framework.presentation.NameFormatException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.PresentationConnectFilter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationConnectFilter の使用

jp.co.intra_mart.framework.presentation.PresentationConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.PresentationManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationManager の使用

PresentationManager を使用しているパッケージ
jp.co.intra_mart.framework.presentation Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.presentation での PresentationManager の使用

PresentationManager を返す jp.co.intra_mart.framework.presentation のメソッド
static PresentationManager PresentationManager.getManager()
PresentationManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.PresentationManagerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationManagerException の使用

PresentationManagerException を使用しているパッケージ
jp.co.intra_mart.framework.presentation Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.presentation での PresentationManagerException の使用

PresentationManagerException をスローする jp.co.intra_mart.framework.presentation のメソッド
static PresentationManager | PresentationManager.getManager() PresentationManagerを取得します。
abstract String | PresentationManager.createToken() 新しいトークンを取得します。
abstract void | PresentationManager.lockSession(String id) セッションをロックします。
abstract void | PresentationManager.unlockSession(String id) セッションのロックを解除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.PresentationPropertyException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationPropertyException の使用

PresentationPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.presentation Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.presentation での PresentationPropertyException の使用

PresentationPropertyException をスローする jp.co.intra_mart.framework.presentation のメソッド
boolean | PresentationPropertyHandler.isDynamic() プロパティの動的読み込みが可能かどうか調べます。
jp.co.intra_mart.framework.presentation.property.Application | PresentationPropertyHandler.getApplication(String name) アプリケーションの情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.PresentationPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.PresentationPropertyHandler の使用

PresentationPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.presentation Presentation Frameworkに関連するパッケージです。

jp.co.intra_mart.framework.presentation での PresentationPropertyHandler の使用

PresentationPropertyHandler を返す jp.co.intra_mart.framework.presentation のメソッド
abstract  PresentationPropertyHandler PresentationManager.getPresentationPropertyHandler()
PresentationPropertyHandlerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.PresentationServlet の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.PresentationServlet の使用

jp.co.intra_mart.framework.presentation.PresentationServlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.RequestInfo の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.RequestInfo の使用

RequestInfo を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.presentation.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

jp.co.intra_mart.framework.presentation.forward での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.presentation.forward のメソッド
 String ForwardSelector.getForwardReference(RequestInfo info)
リクエスト情報から遷移先の参照を取得します。

jp.co.intra_mart.framework.presentation.service での RequestInfo の使用

RequestInfo を返す jp.co.intra_mart.framework.presentation.service のメソッド
 RequestInfo PresentationServiceController.getRequestInfo()
リクエスト情報を取得します。

jp.co.intra_mart.framework.presentation.validator での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.presentation.validator のメソッド
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

jp.co.intra_mart.framework.presentation.view での RequestInfo の使用

RequestInfo 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
ViewObject | ViewConverter.convert(RequestInfo info) リクエスト情報をもとにビューオブジェクトを生成します。
protected Event | AbstractViewConverter.createEvent(RequestInfo info, String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
String | AbstractViewConverter.getLoginUserID(RequestInfo info) 推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
String | AbstractViewConverter.getLoginGroupID(RequestInfo info) 推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
UserInfo | AbstractViewConverter.getUserInfo(RequestInfo info) ログインユーザ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.TokenInvalidException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.TokenInvalidException の使用

jp.co.intra_mart.framework.presentation.TokenInvalidException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.controller.ControllerConverter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.controller.ControllerConverter の使用

ControllerConverter を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での ControllerConverter の使用

ControllerConverter を実装している jp.co.intra_mart.framework.presentation.controller のクラス
 class SimpleControllerConverter
リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig の使用

ControllerConverterConfig を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での ControllerConverterConfig の使用

ControllerConverterConfig 型のパラメータを持つ jp.co.intra_mart.framework.presentation.controller のメソッド
void | SimpleControllerConverter.init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
void | ControllerConverter.init(ControllerConverterConfig config) ControllerConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.controller.ControllerConverterException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.controller.ControllerConverterException の使用

ControllerConverterException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での ControllerConverterException の使用

ControllerConverterException をスローする jp.co.intra_mart.framework.presentation.controller のメソッド
void | SimpleControllerConverter.init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
void | ControllerConverter.init(ControllerConverterConfig config) ControllerConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.controller.ControllerObject の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.controller.ControllerObject の使用

ControllerObject を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation での ControllerObject の使用

ControllerObject を返す jp.co.intra_mart.framework.presentation のメソッド
 ControllerObject RequestInfo.getControllerObject()
リクエストから生成されたコントローラオブジェクトを取得します。

jp.co.intra_mart.framework.presentation.controller での ControllerObject の使用

ControllerObject を返す jp.co.intra_mart.framework.presentation.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.controller.RequestFormatException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.controller.RequestFormatException の使用

RequestFormatException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.controller 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.controller での RequestFormatException の使用

RequestFormatException をスローする jp.co.intra_mart.framework.presentation.controller のメソッド
ControllerObject | SimpleControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
ControllerObject | ControllerConverter.convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter の使用

jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ControllerConverter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
インタフェース ControllerConverter

既知の実装クラスの一覧:
SimpleControllerConverter
public interface ControllerConverter

リクエストをコントローラオブジェクトに変換します。 コントローラオブジェクトはリクエストの内容を入力情報として変換されたものです。 開発者はこのインタフェースを実装し、適切なコントローラオブジェクトを返すように convert(RequestInfo)メソッドを実装する 必要があります。

生成されるコントローラオブジェクトはJavaBeansTM の仕様に従う必要があります。

導入されたバージョン:
4.3

メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() ControllerConverterを破棄します。
void | init(ControllerConverterConfig config) ControllerConverterを初期化します。

メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
ControllerConverterを初期化します。

パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
ControllerConverterを破棄します。

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ControllerConverterConfig (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
インタフェース ControllerConverterConfig

public interface ControllerConverterConfig

ControllerConverterの初期化情報です。

導入されたバージョン:
4.3

メソッドの概要
String | getInitParameter(String name) ControllerConverterを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
ControllerConverterを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ControllerConverterException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
クラス ControllerConverterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.controller.ControllerConverterException
すべての実装インタフェース:
Serializable
public class ControllerConverterException
extends SystemException

ControllerConverterに関連する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ControllerConverterException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ControllerConverterException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ControllerConverterException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllerConverterException

public ControllerConverterException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。

ControllerConverterException

public ControllerConverterException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ

ControllerConverterException

public ControllerConverterException(String msg,
                                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ControllerObject (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
インタフェース ControllerObject

すべてのスーパーインタフェース:
Serializable
public interface ControllerObject
extends Serializable

コントローラオブジェクトのインタフェースです。 すべてのコントローラオブジェクトはこのインタフェースを実装する必要があります。 このインタフェースを実装するクラスはJavaBeansの仕様に沿っている必要があります。

導入されたバージョン:
4.3

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.controller (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.presentation.controller
インタフェース
ControllerConverter
ControllerConverterConfig
ControllerObject
クラス
SimpleControllerConverter
例外
ControllerConverterException
RequestFormatException


jp.co.intra_mart.framework.presentation.controller (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.controller

入力情報に関連するパッケージです。

参照:
説明

インタフェースの概要
ControllerConverter | リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig | ControllerConverterの初期化情報です。
ControllerObject | コントローラオブジェクトのインタフェースです。

クラスの概要
SimpleControllerConverter リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。

例外の概要
ControllerConverterException | ControllerConverterに関連する例外です。
RequestFormatException | フォーマットが不正であるときの例外です。

パッケージ jp.co.intra_mart.framework.presentation.controller の説明

入力情報に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.controller クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.controller の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter (implements jp.co.intra_mart.framework.presentation.controller.ControllerConverter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException
            • class jp.co.intra_mart.framework.presentation.controller.RequestFormatException

インタフェース階層

  • interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter
  • interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.presentation.controller.ControllerObject
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.presentation.controller の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.controller の使用

jp.co.intra_mart.framework.presentation.controller を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.presentation.controller のクラス
ControllerObject
コントローラオブジェクトのインタフェースです。

jp.co.intra_mart.framework.presentation.controller により使用される jp.co.intra_mart.framework.presentation.controller のクラス
ControllerConverter
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig
ControllerConverterの初期化情報です。
ControllerConverterException
ControllerConverterに関連する例外です。
ControllerObject
コントローラオブジェクトのインタフェースです。
RequestFormatException
フォーマットが不正であるときの例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


RequestFormatException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
クラス RequestFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.controller.RequestFormatException
すべての実装インタフェース:
Serializable
public class RequestFormatException
extends SystemException

フォーマットが不正であるときの例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
RequestFormatException()
詳細メッセージを指定しないで RequestFormatException を構築します。
RequestFormatException(String msg)
指定された詳細メッセージを持つ RequestFormatException を構築します。
RequestFormatException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestFormatException

public RequestFormatException()
詳細メッセージを指定しないで RequestFormatException を構築します。

RequestFormatException

public RequestFormatException(String msg)
指定された詳細メッセージを持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ

RequestFormatException

public RequestFormatException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SimpleControllerConverter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.controller
クラス SimpleControllerConverter

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter
すべての実装インタフェース:
ControllerConverter
public class SimpleControllerConverter
extends Object
implements ControllerConverter

リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。 ここではコントローラオブジェクトはJavaBeansとして扱われます。 リクエストのパラメータから取得される値をコントローラオブジェクトのプロパティに設定します。 ここで対応付けられるコントローラオブジェクトのプロパティはすべてStringである必要があります。 パラメータとプロパティの対応ルールは以下のとおりです。

  • リクエストのパラメータ名とコントローラオブジェクトのプロパティ名が一致するものが対応付けられる
  • ある名前に対してリクエストのパラメータが存在するがコントローラオブジェクトのプロパティが存在しない、 またはリクエストのパラメータは存在しないがコントローラオブジェクトのプロパティが存在する場合は何も行われない
  • リクエストのパラメータが同一のパラメータ名でただ1つの値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringまたはその配列）を持つ場合はそのメソッドが使用される
  • リクエストのパラメータが同一のパラメータ名でただ1つの値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持たない場合は インデックス付きのsetterメソッド（第1引数はint、第2引数はString）が使用される
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持つ場合はそのメソッドが使用される
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティのインデックスなしのsetterメソッド （引数はStringの配列）を持たない場合は インデックス付きのsetterメソッド（第1引数はint、第2引数はString）が使用される （この場合設定される順番はリクエストのパラメータと同一となる）
  • リクエストのパラメータが同一のパラメータ名で複数の値を持ち、 コントローラオブジェクトが同一名のプロパティにおいて複数の値を扱うsetterメソッドを持たない場合は インデックスなしのsetterメソッド（引数はString）が使用される （この場合リクエストのパラメータの最初の値のみが設定される）
  • コントローラオブジェクトが対応するプロパティのsetterメソッドを持たない場合何も行われない

導入されたバージョン:
4.3

フィールドの概要
static String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名
コンストラクタの概要
SimpleControllerConverter()
メソッドの概要
ControllerObject | convert(RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() SimpleControllerConverterを破棄します。
void | init(ControllerConverterConfig config) SimpleControllerConverterを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

OBJECT_PARAM_NAME

public static final String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

SimpleControllerConverter

public SimpleControllerConverter()
メソッドの詳細

init

public void init(ControllerConverterConfig config)
          throws ControllerConverterException
SimpleControllerConverterを初期化します。

定義:
インタフェース ControllerConverter 内の init
パラメータ:
config - 初期化情報
例外:
ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
SimpleControllerConverterを破棄します。

定義:
インタフェース ControllerConverter 内の destroy

convert

public ControllerObject convert(RequestInfo info)
                         throws RequestFormatException,
                                ServletException,
                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

定義:
インタフェース ControllerConverter 内の convert
パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.forward.ForwardSelector の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.forward.ForwardSelector の使用

jp.co.intra_mart.framework.presentation.forward.ForwardSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig の使用

ForwardSelectorConfig を使用しているパッケージ
jp.co.intra_mart.framework.presentation.forward 遷移先の決定に関連するパッケージです。

jp.co.intra_mart.framework.presentation.forward での ForwardSelectorConfig の使用

ForwardSelectorConfig 型のパラメータを持つ jp.co.intra_mart.framework.presentation.forward のメソッド
 void ForwardSelector.init(ForwardSelectorConfig config)
ForwardSelectorを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException の使用

ForwardSelectorException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.forward 遷移先の決定に関連するパッケージです。

jp.co.intra_mart.framework.presentation.forward での ForwardSelectorException の使用

ForwardSelectorException をスローする jp.co.intra_mart.framework.presentation.forward のメソッド
 void ForwardSelector.init(ForwardSelectorConfig config)
ForwardSelectorを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ForwardSelector (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.forward
インタフェース ForwardSelector

public interface ForwardSelector

遷移先の参照を決定するセレクタです。 すべてのセレクタはこのインタフェースを実装する必要があります。

導入されたバージョン:
4.3

メソッドの概要
void | destroy() ForwardSelectorを破棄します。
String | getForwardReference(RequestInfo info) リクエスト情報から遷移先の参照を取得します。
void | init(ForwardSelectorConfig config) ForwardSelectorを初期化します。

メソッドの詳細

init

public void init(ForwardSelectorConfig config)
          throws ForwardSelectorException
ForwardSelectorを初期化します。

パラメータ:
config - 初期化情報
例外:
ForwardSelectorException - 初期化時に例外が発生

destroy

public void destroy()
ForwardSelectorを破棄します。

getForwardReference

public String getForwardReference(RequestInfo info)
リクエスト情報から遷移先の参照を取得します。

パラメータ:
info - リクエスト情報
戻り値:
遷移先の参照
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ForwardSelectorConfig (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.forward
インタフェース ForwardSelectorConfig

public interface ForwardSelectorConfig

ForwardSelectorの初期化情報です。

導入されたバージョン:
4.3

メソッドの概要
String | getInitParameter(String name) ForwardSelectorを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
ForwardSelectorを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ForwardSelectorException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.forward
クラス ForwardSelectorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException
すべての実装インタフェース:
Serializable
public class ForwardSelectorException
extends SystemException

ForwardSelectorに関連する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ForwardSelectorException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ForwardSelectorException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ForwardSelectorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForwardSelectorException

public ForwardSelectorException()
詳細メッセージを指定しないで ForwardSelectorException を構築します。

ForwardSelectorException

public ForwardSelectorException(String msg)
指定された詳細メッセージを持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ

ForwardSelectorException

public ForwardSelectorException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.forward (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.presentation.forward
インタフェース
ForwardSelector
ForwardSelectorConfig
例外
ForwardSelectorException


jp.co.intra_mart.framework.presentation.forward (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.forward

遷移先の決定に関連するパッケージです。

参照:
説明

インタフェースの概要
ForwardSelector | 遷移先の参照を決定するセレクタです。
ForwardSelectorConfig | ForwardSelectorの初期化情報です。

例外の概要
ForwardSelectorException ForwardSelectorに関連する例外です。

パッケージ jp.co.intra_mart.framework.presentation.forward の説明

遷移先の決定に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.forward クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.forward の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException

インタフェース階層

  • interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector
  • interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.presentation.forward の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.forward の使用

jp.co.intra_mart.framework.presentation.forward を使用しているパッケージ
jp.co.intra_mart.framework.presentation.forward 遷移先の決定に関連するパッケージです。

jp.co.intra_mart.framework.presentation.forward により使用される jp.co.intra_mart.framework.presentation.forward のクラス
ForwardSelectorConfig
ForwardSelectorの初期化情報です。
ForwardSelectorException
ForwardSelectorに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.service.PresentationServiceController の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.service.PresentationServiceController の使用

jp.co.intra_mart.framework.presentation.service.PresentationServiceController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.service (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.presentation.service
クラス
PresentationServiceController


jp.co.intra_mart.framework.presentation.service (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.service

サービスに関連するパッケージです。

参照:
説明

クラスの概要
PresentationServiceController Presentation Framework用のServiceControllerです。

パッケージ jp.co.intra_mart.framework.presentation.service の説明

サービスに関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.service クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
      • class jp.co.intra_mart.framework.presentation.service.PresentationServiceController
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.presentation.service の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.service の使用

jp.co.intra_mart.framework.presentation.service はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PresentationServiceController (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.service
クラス PresentationServiceController

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.ServiceControllerAdapter
        拡張 jp.co.intra_mart.framework.presentation.service.PresentationServiceController
すべての実装インタフェース:
ServiceController
public class PresentationServiceController
extends ServiceControllerAdapter

Presentation Framework用のServiceControllerです。

導入されたバージョン:
4.3
関連項目:
ServiceController

コンストラクタの概要
PresentationServiceController()
メソッドの概要
 RequestInfo getRequestInfo()
リクエスト情報を取得します。
クラス jp.co.intra_mart.framework.base.service.ServiceControllerAdapter から継承したメソッド
check, createEvent, dispatchEvent, getEntity, getLoginGroupID, getLoginUserID, getRequest, getResponse, getUserInfo, service, setRequest, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationServiceController

public PresentationServiceController()
メソッドの詳細

getRequestInfo

public RequestInfo getRequestInfo()
リクエスト情報を取得します。

戻り値:
リクエスト情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.validator.FormatValidator の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.FormatValidator の使用

jp.co.intra_mart.framework.presentation.validator.FormatValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.validator.LengthValidator の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.LengthValidator の使用

jp.co.intra_mart.framework.presentation.validator.LengthValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の使用

jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.validator.NumericValidator の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.NumericValidator の使用

jp.co.intra_mart.framework.presentation.validator.NumericValidator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.validator.ValidationException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.ValidationException の使用

jp.co.intra_mart.framework.presentation.validator.ValidationException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail の使用

ValidationExceptionDetail を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator での ValidationExceptionDetail の使用

ValidationExceptionDetail を返す jp.co.intra_mart.framework.presentation.validator のメソッド
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.validator.Validator の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.validator.Validator の使用

Validator を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator での Validator の使用

Validator を実装している jp.co.intra_mart.framework.presentation.validator のクラス
class | FormatValidator 文字列の不正文字（フォーマット）チェックを行います。
class | LengthValidator 文字列の長さをチェックします。
class | NumericRangeValidator 数値の範囲をチェックします。
class | NumericValidator 数値（整数）として妥当であるかどうかをチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.validator.ValidatorConfig の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.validator.ValidatorConfig の使用

ValidatorConfig を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator での ValidatorConfig の使用

ValidatorConfig 型のパラメータを持つ jp.co.intra_mart.framework.presentation.validator のメソッド
void | Validator.init(ValidatorConfig config) Validatorを初期化します。
void | NumericValidator.init(ValidatorConfig config) NumericValidatorを初期化します。
void | NumericRangeValidator.init(ValidatorConfig config) NumericRangeValidatorを初期化します。
void | LengthValidator.init(ValidatorConfig config) LengthValidatorを初期化します。
void | FormatValidator.init(ValidatorConfig config) FormatValidatorを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.validator.ValidatorException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.validator.ValidatorException の使用

ValidatorException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator での ValidatorException の使用

ValidatorException をスローする jp.co.intra_mart.framework.presentation.validator のメソッド
void | Validator.init(ValidatorConfig config) Validatorを初期化します。
ValidationExceptionDetail | Validator.validate(RequestInfo info) リクエスト内容の検証をします。
void | NumericValidator.init(ValidatorConfig config) NumericValidatorを初期化します。
ValidationExceptionDetail | NumericValidator.validate(RequestInfo info) 数値の検証をします。
void | NumericRangeValidator.init(ValidatorConfig config) NumericRangeValidatorを初期化します。
ValidationExceptionDetail | NumericRangeValidator.validate(RequestInfo info) 数値の範囲を検証します。
void | LengthValidator.init(ValidatorConfig config) LengthValidatorを初期化します。
ValidationExceptionDetail | LengthValidator.validate(RequestInfo info) 文字列の長さを検証します。
void | FormatValidator.init(ValidatorConfig config) FormatValidatorを初期化します。
ValidationExceptionDetail | FormatValidator.validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FormatValidator (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス FormatValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.FormatValidator
すべての実装インタフェース:
Validator
public class FormatValidator
extends Object
implements Validator

文字列の不正文字（フォーマット）チェックを行います。 このクラスではControllerObjectのプロパティが、指定された正規表現に一致しているかどうかを検証します。

検証対象となるプロパティ名と正規表現のフォーマットは初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、フォーマットはPARAM_REGEXで与えられる名前でそれぞれ指定します。 正規表現はString.matches(java.lang.String)の引数で指定できるものと同じです。

該当するプロパティの内容がnullだった場合、 そのプロパティには空文字列が設定されているものとみなされます。

プロパティが正規表現に一致しない場合、PARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。 このパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
4.3

フィールドの概要
static String | PARAM_MESSAGE 不正文字列である場合のメッセージが設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名
static String | PARAM_REGEX 正規表現によるフォーマットが設定されているパラメータ名
コンストラクタの概要
FormatValidator()
メソッドの概要
void | destroy() FormatValidatorを破棄します。
void | init(ValidatorConfig config) FormatValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 文字列の不正文字（フォーマット）を検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名

関連項目:
定数フィールド値

PARAM_REGEX

public static final String PARAM_REGEX
正規表現によるフォーマットが設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
不正文字列である場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

FormatValidator

public FormatValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
FormatValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
FormatValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
文字列の不正文字（フォーマット）を検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LengthValidator (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス LengthValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.LengthValidator
すべての実装インタフェース:
Validator
public class LengthValidator
extends Object
implements Validator

文字列の長さをチェックします。 このクラスではControllerObjectのプロパティの文字列長が、指定された範囲に含まれるかどうかを検証します。

検証対象となるプロパティ名と長さの範囲は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、長さの範囲はPARAM_MINとPARAM_MAXで与えられる名前でそれぞれ指定します。 文字列長の最小値と最大値で設定できる値は、ともに0以上の整数かつintの最大値以下です。 最大値と最小値のパラメータは0以上かつInteger.MAX_VALUE以下である必要があります。 該当するプロパティの内容がnullだった場合、 そのプロパティには空文字列が設定されているものとみなされます。

プロパティの文字列長が最小値に満たない場合、PARAM_MESSAGE_SHORTで与えられる名前のパラメータに設定されたメッセージが返されます。 プロパティの文字列長が最大値を超える場合、PARAM_MESSAGE_LONGで与えられる名前のパラメータに設定されたメッセージが返されます。 これらのパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
4.3

フィールドの概要
static String | PARAM_MAX 文字列長の最大値が設定されているパラメータ名
static String | PARAM_MESSAGE_LONG 文字列長が長い場合のメッセージが設定されているパラメータ名
static String | PARAM_MESSAGE_SHORT 文字列長が短い場合のメッセージが設定されているパラメータ名
static String | PARAM_MIN 文字列長の最小値が設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
LengthValidator()
メソッドの概要
void | destroy() LengthValidatorを破棄します。
void | init(ValidatorConfig config) LengthValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 文字列の長さを検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MIN

public static final String PARAM_MIN
文字列長の最小値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MAX

public static final String PARAM_MAX
文字列長の最大値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE_SHORT

public static final String PARAM_MESSAGE_SHORT
文字列長が短い場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE_LONG

public static final String PARAM_MESSAGE_LONG
文字列長が長い場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

LengthValidator

public LengthValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
LengthValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
LengthValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
文字列の長さを検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


NumericRangeValidator (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス NumericRangeValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator
すべての実装インタフェース:
Validator
public class NumericRangeValidator
extends Object
implements Validator

数値の範囲をチェックします。 このクラスではControllerObjectのプロパティの数値が、指定された範囲に含まれるかどうかを検証します。

検証対象となるプロパティ名と範囲は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで、数値の範囲はPARAM_MINとPARAM_MAXで与えられる名前でそれぞれ指定します。 数値の最小値と最大値で設定できる値は、ともに整数のみです。

最小値が省略された場合、数値の下限はチェックされません。 最大値が省略された場合、数値の上限はチェックされません。

最大値と最小値はともにチェック対象の範囲に含まれます。

最大値と最小値のパラメータはLong.parseLong(java.lang.String)の引数に指定できるものである必要があります。

プロパティの値が次のいずれかに該当する場合、 PARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。

  • nullである
  • プロパティの数値が最小値に満たない
  • プロパティの数値が最大値を超える
  • プロパティがStringであり、その値がBigInteger.BigInteger(java.lang.String)の引数に指定できる値ではない
チェック対象のプロパティが以下のいずれかでもない場合、例外が返されます。
  • int
  • long
  • Integer
  • Long
  • BigInteger
  • String
チェック対象のプロパティが存在しない場合も、例外が返されます。

導入されたバージョン:
4.3

フィールドの概要
static String | PARAM_MAX 数値の最大値が設定されているパラメータ名
static String | PARAM_MESSAGE 数値が範囲外の場合のメッセージが設定されているパラメータ名
static String | PARAM_MIN 数値の最小値が設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
NumericRangeValidator()
メソッドの概要
void | destroy() NumericRangeValidatorを破棄します。
void | init(ValidatorConfig config) NumericRangeValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 数値の範囲を検証します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_MIN

public static final String PARAM_MIN
数値の最小値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MAX

public static final String PARAM_MAX
数値の最大値が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
数値が範囲外の場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

NumericRangeValidator

public NumericRangeValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
NumericRangeValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
NumericRangeValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
数値の範囲を検証します。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティが数値として正しくない
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


NumericValidator (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス NumericValidator

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.NumericValidator
すべての実装インタフェース:
Validator
public class NumericValidator
extends Object
implements Validator

数値（整数）として妥当であるかどうかをチェックします。 このクラスではControllerObjectのプロパティが整数として妥当であるかどうかを検証します。

検証対象となるプロパティ名は初期化パラメータで指定します。 プロパティ名はPARAM_PROPERTYで指定します。

プロパティの型が以下のものであれば無条件で整数であるとみなされます。

  • int
  • long
プロパティの型が以下のものであり、かつnullでなければ無条件で整数であるとみなされます。
  • Integer
  • Long
  • BigInteger
プロパティがStringである場合、以下の条件をすべて満たせば整数として妥当であるとみなされます。
  • nullではない
  • 先頭にはマイナス符号が1つだけ付いてもよい。
  • 以降は1つ以上の10進数字の列で構成される。
上記以外の場合、該当するプロパティは数値として妥当でないものとみなされます。 この場合、validate(RequestInfo)の戻り値であるValidationExceptionにはPARAM_MESSAGEで与えられる名前のパラメータに設定されたメッセージが返されます。 このパラメータが設定されていない場合、このクラスで用意されたメッセージが返されます。

導入されたバージョン:
4.3

フィールドの概要
static String | PARAM_MESSAGE 数値として妥当ではない場合のメッセージが設定されているパラメータ名
static String | PARAM_PROPERTY 検証対象のプロパティ名が設定されているパラメータ名
コンストラクタの概要
NumericValidator()
メソッドの概要
void | destroy() NumericValidatorを破棄します。
void | init(ValidatorConfig config) NumericValidatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) 数値の検証をします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_PROPERTY

public static final String PARAM_PROPERTY
検証対象のプロパティ名が設定されているパラメータ名

関連項目:
定数フィールド値

PARAM_MESSAGE

public static final String PARAM_MESSAGE
数値として妥当ではない場合のメッセージが設定されているパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

NumericValidator

public NumericValidator()
メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
NumericValidatorを初期化します。

定義:
インタフェース Validator 内の init
パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
NumericValidatorを破棄します。

定義:
インタフェース Validator 内の destroy

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
数値の検証をします。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

定義:
インタフェース Validator 内の validate
パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
ValidatorException - 該当するプロパティが存在しない、またはプロパティの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.validator (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.presentation.validator
インタフェース
Validator
ValidatorConfig
クラス
FormatValidator
LengthValidator
NumericRangeValidator
NumericValidator
ValidationExceptionDetail
例外
ValidationException
ValidatorException


jp.co.intra_mart.framework.presentation.validator (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.validator

検証に関連するパッケージです。

参照:
説明

インタフェースの概要
Validator | リクエスト内容の検証をします。
ValidatorConfig | Validatorの初期化情報です。

クラスの概要
FormatValidator | 文字列の不正文字（フォーマット）チェックを行います。
LengthValidator | 文字列の長さをチェックします。
NumericRangeValidator | 数値の範囲をチェックします。
NumericValidator | 数値（整数）として妥当であるかどうかをチェックします。
ValidationExceptionDetail | 検証結果の詳細情報です。

例外の概要
ValidationException | 検証結果が不正であるときの例外です。
ValidatorException | Validatorに関連する例外です。

パッケージ jp.co.intra_mart.framework.presentation.validator の説明

検証に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.validator クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.validator の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.presentation.validator.FormatValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.validator.LengthValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.validator.NumericValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.presentation.validator.ValidationException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.validator.ValidatorException
    • class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail

インタフェース階層

  • interface jp.co.intra_mart.framework.presentation.validator.Validator
  • interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.presentation.validator の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.validator の使用

jp.co.intra_mart.framework.presentation.validator を使用しているパッケージ
jp.co.intra_mart.framework.presentation.validator 検証に関連するパッケージです。

jp.co.intra_mart.framework.presentation.validator により使用される jp.co.intra_mart.framework.presentation.validator のクラス
ValidationExceptionDetail
検証結果の詳細情報です。
Validator
リクエスト内容の検証をします。
ValidatorConfig
Validatorの初期化情報です。
ValidatorException
Validatorに関連する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ValidationException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス ValidationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.presentation.validator.ValidationException
すべての実装インタフェース:
Serializable
public class ValidationException
extends ApplicationException

検証結果が不正であるときの例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ValidationException()
詳細メッセージを指定しないで ValidationException を構築します。
ValidationException(String msg)
指定された詳細メッセージを持つ ValidationException を構築します。
ValidationException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
メソッドの概要
String | getMessage() 例外メッセージを取得します。
Iterator | getValidationExceptionDetails() 検証結果の詳細の一覧を取得します。
void | setValidationExceptionDetails(Collection details) 検証結果の詳細を設定します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValidationException

public ValidationException()
詳細メッセージを指定しないで ValidationException を構築します。

ValidationException

public ValidationException(String msg)
指定された詳細メッセージを持つ ValidationException を構築します。

パラメータ:
msg - 詳細メッセージ

ValidationException

public ValidationException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
メソッドの詳細

setValidationExceptionDetails

public void setValidationExceptionDetails(Collection details)
検証結果の詳細を設定します。 detailsはValidationExceptionDetailのコレクションである必要があります。

パラメータ:
details - 検証結果の詳細

getValidationExceptionDetails

public Iterator getValidationExceptionDetails()
検証結果の詳細の一覧を取得します。 戻り値はValidationExceptionDetailのコレクションのIteratorです。

戻り値:
検証結果の詳細の一覧

getMessage

public String getMessage()
例外メッセージを取得します。 詳細情報を含んだ形式で例外情報が取得されます。

戻り値:
例外メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ValidationExceptionDetail (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス ValidationExceptionDetail

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail
public class ValidationExceptionDetail
extends Object

検証結果の詳細情報です。

導入されたバージョン:
4.3

コンストラクタの概要
ValidationExceptionDetail()
メッセージなしのValidatorExceptionDetailを生成します。
ValidationExceptionDetail(String message)
メッセージ付きのValidatorExceptionDetailを生成します。
メソッドの概要
void | addDetail(String detail) 検証結果の詳細を追加します。
Iterator | getDetails() 検証結果の詳細の一覧を取得します。
String | getMessage() 検証結果のメッセージを取得します。
void | setMessage(String message) 検証結果のメッセージを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ValidationExceptionDetail

public ValidationExceptionDetail()
メッセージなしのValidatorExceptionDetailを生成します。 この場合、メッセージとして空文字列が設定されたものとみなされます。

ValidationExceptionDetail

public ValidationExceptionDetail(String message)
メッセージ付きのValidatorExceptionDetailを生成します。

パラメータ:
message - メッセージ
メソッドの詳細

getMessage

public String getMessage()
検証結果のメッセージを取得します。

戻り値:
検証結果のメッセージ

setMessage

public void setMessage(String message)
検証結果のメッセージを設定します。

パラメータ:
message - 検証結果のメッセージ

addDetail

public void addDetail(String detail)
検証結果の詳細を追加します。

パラメータ:
detail - 検証結果の詳細

getDetails

public Iterator getDetails()
検証結果の詳細の一覧を取得します。 StringのCollectionのIteratorが返されます。

戻り値:
検証結果の詳細の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Validator (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
インタフェース Validator

既知の実装クラスの一覧:
FormatValidator, LengthValidator, NumericRangeValidator, NumericValidator
public interface Validator

リクエスト内容の検証をします。

導入されたバージョン:
4.3

メソッドの概要
void | destroy() Validatorを破棄します。
void | init(ValidatorConfig config) Validatorを初期化します。
ValidationExceptionDetail | validate(RequestInfo info) リクエスト内容の検証をします。

メソッドの詳細

init

public void init(ValidatorConfig config)
          throws ValidatorException
Validatorを初期化します。

パラメータ:
config - 初期化情報
例外:
ValidatorException - 初期化時に例外が発生

destroy

public void destroy()
Validatorを破棄します。

validate

public ValidationExceptionDetail validate(RequestInfo info)
                                   throws ValidatorException
リクエスト内容の検証をします。 検証の結果、リクエスト内容が不正である場合ValidationExceptionDetailを返します。 リクエスト内容が正常なものである場合、nullを返します。

パラメータ:
info - リクエスト情報
戻り値:
リクエスト内容が不正な場合：検証結果の詳細
正常な場合：null
例外:
検証中に想定外の例外が発生
ValidatorException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ValidatorConfig (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
インタフェース ValidatorConfig

public interface ValidatorConfig

Validatorの初期化情報です。

導入されたバージョン:
4.3

メソッドの概要
String | getInitParameter(String name) Validatorを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
Validatorを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ValidatorException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.validator
クラス ValidatorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.validator.ValidatorException
すべての実装インタフェース:
Serializable
public class ValidatorException
extends SystemException

Validatorに関連する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ValidatorException()
詳細メッセージを指定しないで ValidatorException を構築します。
ValidatorException(String msg)
指定された詳細メッセージを持つ ValidatorException を構築します。
ValidatorException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValidatorException

public ValidatorException()
詳細メッセージを指定しないで ValidatorException を構築します。

ValidatorException

public ValidatorException(String msg)
指定された詳細メッセージを持つ ValidatorException を構築します。

パラメータ:
msg - 詳細メッセージ

ValidatorException

public ValidatorException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.view.AbstractViewConverter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.AbstractViewConverter の使用

jp.co.intra_mart.framework.presentation.view.AbstractViewConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.view.MultiSelectableItem の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.MultiSelectableItem の使用

jp.co.intra_mart.framework.presentation.view.MultiSelectableItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.view.Option の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.Option の使用

Option を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での Option の使用

Option を返す jp.co.intra_mart.framework.presentation.view のメソッド
Option | SingleSelectableItem.getSelected() 選択済の選択肢を取得します。
Option[] | SelectableItem.getOption() 選択肢をすべて取得します。
Option | SelectableItem.getOption(int index) 選択肢を取得します。
Option | SelectableItem.findOption(String value) 値に該当する選択肢を取得します。
Option[] | MultiSelectableItem.getSelected() 選択済の選択肢をすべて取得します。
Option | MultiSelectableItem.getSelected(int index) 選択済みである選択肢を取得します。

Option 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
void | SingleSelectableItem.setSelected(Option option) 選択済の選択肢を設定します。
protected boolean | SingleSelectableItem.isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | SelectableItem.setOption(Option[] items) 選択肢を設定します。
void | SelectableItem.setOption(int index, Option option) 選択肢を設定します。
protected abstract boolean | SelectableItem.isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | MultiSelectableItem.setSelected(Option[] options) 選択済みである選択肢を設定します。
void | MultiSelectableItem.setSelected(int index, Option option) 選択済みである選択肢を設定します。
protected boolean | MultiSelectableItem.isSelected(Option option) 指定された選択肢が選択済かどうか判定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject の使用

PanelBasedViewObject を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での PanelBasedViewObject の使用

PanelBasedViewObject を実装している jp.co.intra_mart.framework.presentation.view のクラス
 class SimplePanelBasedViewObject
パネルコンポーネントの表示に関連するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.view.SelectableItem の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.SelectableItem の使用

SelectableItem を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での SelectableItem の使用

jp.co.intra_mart.framework.presentation.view での SelectableItem のサブクラス
class | MultiSelectableItem 複数の選択肢を選択することが可能な項目です。
class | SingleSelectableItem 単一の選択肢のみ選択することが可能な項目です。

SelectableItem 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
protected  void Option.setParent(SelectableItem item)
この選択肢が含まれる選択項目を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject の使用

jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.view.SimpleViewObject の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.SimpleViewObject の使用

SimpleViewObject を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での SimpleViewObject の使用

jp.co.intra_mart.framework.presentation.view での SimpleViewObject のサブクラス
 class SimplePanelBasedViewObject
パネルコンポーネントの表示に関連するオブジェクトです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.view.SingleSelectableItem の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.SingleSelectableItem の使用

jp.co.intra_mart.framework.presentation.view.SingleSelectableItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.view.ViewConverter の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.view.ViewConverter の使用

ViewConverter を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での ViewConverter の使用

ViewConverter を実装している jp.co.intra_mart.framework.presentation.view のクラス
 class AbstractViewConverter
いくつかのユーティリティメソッドが含まれる抽象的なビューコンバータです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.view.ViewConverterConfig の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.view.ViewConverterConfig の使用

ViewConverterConfig を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での ViewConverterConfig の使用

ViewConverterConfig 型のパラメータを持つ jp.co.intra_mart.framework.presentation.view のメソッド
 void ViewConverter.init(ViewConverterConfig config)
ViewConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.presentation.view.ViewConverterException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.presentation.view.ViewConverterException の使用

ViewConverterException を使用しているパッケージ
jp.co.intra_mart.framework.presentation.view 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation.view での ViewConverterException の使用

ViewConverterException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
 void ViewConverter.init(ViewConverterConfig config)
ViewConverterを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.presentation.view.ViewObject の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.presentation.view.ViewObject の使用

ViewObject を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation での ViewObject の使用

ViewObject を返す jp.co.intra_mart.framework.presentation のメソッド
 ViewObject RequestInfo.getViewObject()
生成されたビューオブジェクトを取得します。

jp.co.intra_mart.framework.presentation.view での ViewObject の使用

jp.co.intra_mart.framework.presentation.view での ViewObject のサブインタフェース
 interface PanelBasedViewObject
パネルコンポーネントの表示に関連するオブジェクトです。

ViewObject を実装している jp.co.intra_mart.framework.presentation.view のクラス
class | SimplePanelBasedViewObject パネルコンポーネントの表示に関連するオブジェクトです。
class | SimpleViewObject 単純なビューオブジェクトです。

ViewObject を返す jp.co.intra_mart.framework.presentation.view のメソッド
 ViewObject ViewConverter.convert(RequestInfo info)
リクエスト情報をもとにビューオブジェクトを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


AbstractViewConverter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス AbstractViewConverter

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.AbstractViewConverter
すべての実装インタフェース:
ViewConverter
public abstract class AbstractViewConverter
extends Object
implements ViewConverter

いくつかのユーティリティメソッドが含まれる抽象的なビューコンバータです。 このクラスにはいくつかのユーティリティメソッドがあります。 このクラスを継承することでコーディング量を減らすことが可能です。

導入されたバージョン:
5.0

コンストラクタの概要
AbstractViewConverter()
メソッドの概要
protected Event | createEvent(RequestInfo info, String application, String key) アプリケーションIDとキーに対応するイベントを取得します。
protected EventResult | dispatchEvent(Event event) イベント処理を実行します。
String | getLoginGroupID(RequestInfo info) 推奨されていません。 このメソッドではなくgetUserInfo(RequestInfo)を使用してください。
String | getLoginUserID(RequestInfo info) 推奨されていません。 このメソッドではなくgetUserInfo(RequestInfo)を使用してください。
UserInfo | getUserInfo(RequestInfo info) ログインユーザ情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.presentation.view.ViewConverter から継承したメソッド
convert, destroy, init

コンストラクタの詳細

AbstractViewConverter

public AbstractViewConverter()
メソッドの詳細

createEvent

protected Event createEvent(RequestInfo info,
                            String application,
                            String key)
                     throws ServiceControllerException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
戻り値:
イベント
例外:
ServiceControllerException - イベント取得時に例外が発生

dispatchEvent

protected EventResult dispatchEvent(Event event)
                             throws EventManagerException,
                                    EventException,
                                    SystemException,
                                    ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
EventManagerException - イベントマネージャの生成に失敗
EventException - イベント処理実行に失敗
SystemException - イベント処理時にシステム例外が発生
ApplicationException - イベント処理時にアプリケーション例外が発生

getLoginUserID

public String getLoginUserID(RequestInfo info)
                      throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo(RequestInfo)を使用してください。

ログインユーザIDを取得します。

パラメータ:
info - リクエスト情報
戻り値:
ログインユーザID
例外:
ServiceControllerException - ログインユーザID取得時に例外が発生

getLoginGroupID

public String getLoginGroupID(RequestInfo info)
                       throws ServiceControllerException
推奨されていません。 このメソッドではなくgetUserInfo(RequestInfo)を使用してください。

ログイングループIDを取得します。

パラメータ:
info - リクエスト情報
戻り値:
ログイングループID
例外:
ServiceControllerException - ログイングループID取得時に例外が発生

getUserInfo

public UserInfo getUserInfo(RequestInfo info)
                     throws ServiceControllerException
ログインユーザ情報を取得します。
ログインセッションが存在しない場合はnullを返却します。

パラメータ:
info - リクエスト情報
戻り値:
ログインユーザ情報
例外:
ServiceControllerException - ログインユーザ情報取得時に例外が発生
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MultiSelectableItem (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス MultiSelectableItem

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SelectableItem
        拡張 jp.co.intra_mart.framework.presentation.view.MultiSelectableItem
public class MultiSelectableItem
extends SelectableItem

複数の選択肢を選択することが可能な項目です。

導入されたバージョン:
4.3

コンストラクタの概要
MultiSelectableItem()
メソッドの概要
Option[] | getSelected() 選択済の選択肢をすべて取得します。
Option | getSelected(int index) 選択済みである選択肢を取得します。
protected boolean | isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | setSelected(int index, Option option) 選択済みである選択肢を設定します。
void | setSelected(Option[] options) 選択済みである選択肢を設定します。
クラス jp.co.intra_mart.framework.presentation.view.SelectableItem から継承したメソッド
findOption, getOption, getOption, setOption, setOption
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultiSelectableItem

public MultiSelectableItem()
メソッドの詳細

getSelected

public Option[] getSelected()
選択済の選択肢をすべて取得します。

戻り値:
選択済の選択肢

getSelected

public Option getSelected(int index)
選択済みである選択肢を取得します。 indexで指定した場所の選択肢を取得します。

パラメータ:
index - インデックス。
戻り値:
選択肢

setSelected

public void setSelected(Option[] options)
選択済みである選択肢を設定します。

パラメータ:
options - 選択済みである選択肢の配列

setSelected

public void setSelected(int index,
                        Option option)
選択済みである選択肢を設定します。 indexで指定した場所に選択肢設定します。

パラメータ:
index - インデックス
option - 選択肢

isSelected

protected boolean isSelected(Option option)
指定された選択肢が選択済かどうか判定します。

定義:
クラス SelectableItem 内の isSelected
パラメータ:
option - 選択肢
戻り値:
選択されていればtrue、選択されていなければfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Option (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス Option

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.Option
public class Option
extends Object

選択項目における選択肢です。 SelectableItemの選択肢です。

導入されたバージョン:
4.3

コンストラクタの概要
Option()
メソッドの概要
String | getDisplayName() 表示名を取得します。
String | getSelectString() この選択肢が選択済である場合の表示名を取得します。
String | getValue() 値を取得します。
boolean | isSelected() この選択肢が選択済であるかどうかを判定します。
void | setDisplayName(String displayName) 表示名を設定します。
protected void | setParent(SelectableItem item) この選択肢が含まれる選択項目を設定します。
void | setValue(String value) 値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Option

public Option()
メソッドの詳細

getDisplayName

public String getDisplayName()
表示名を取得します。

戻り値:
表示名

getSelectString

public String getSelectString()
この選択肢が選択済である場合の表示名を取得します。

戻り値:
項目が選択済である場合は"selected"、選択済でない場合は空文字列

getValue

public String getValue()
値を取得します。

戻り値:
値

isSelected

public boolean isSelected()
この選択肢が選択済であるかどうかを判定します。

戻り値:
選択済である場合はtrue、選択済でない場合はfalse

setParent

protected void setParent(SelectableItem item)
この選択肢が含まれる選択項目を設定します。

パラメータ:
item - この選択肢が含まれる選択項目

setDisplayName

public void setDisplayName(String displayName)
表示名を設定します。

パラメータ:
displayName - 表示名

setValue

public void setValue(String value)
値を設定します。

パラメータ:
value - 値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.view (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.presentation.view
インタフェース
PanelBasedViewObject
ViewConverter
ViewConverterConfig
ViewObject
クラス
AbstractViewConverter
MultiSelectableItem
Option
SelectableItem
SimplePanelBasedViewObject
SimpleViewObject
SingleSelectableItem
例外
ViewConverterException


jp.co.intra_mart.framework.presentation.view (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.view

出力情報に関連するパッケージです。

参照:
説明

インタフェースの概要
PanelBasedViewObject | パネルコンポーネントの表示に関連するオブジェクトです。
ViewConverter | 出力情報をビューオブジェクトに変換します。
ViewConverterConfig | ViewConverterの初期化情報です。
ViewObject | ビューオブジェクトのインタフェースです。

クラスの概要
AbstractViewConverter | いくつかのユーティリティメソッドが含まれる抽象的なビューコンバータです。
MultiSelectableItem | 複数の選択肢を選択することが可能な項目です。
Option | 選択項目における選択肢です。
SelectableItem | 選択肢を持つ項目です。
SimplePanelBasedViewObject | パネルコンポーネントの表示に関連するオブジェクトです。
SimpleViewObject | 単純なビューオブジェクトです。
SingleSelectableItem | 単一の選択肢のみ選択することが可能な項目です。

例外の概要
ViewConverterException ViewConverterに関連する例外です。

パッケージ jp.co.intra_mart.framework.presentation.view の説明

出力情報に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation.view クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation.view の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter (implements jp.co.intra_mart.framework.presentation.view.ViewConverter)
    • class jp.co.intra_mart.framework.presentation.view.Option
    • class jp.co.intra_mart.framework.presentation.view.SelectableItem
      • class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem
      • class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem
    • class jp.co.intra_mart.framework.presentation.view.SimpleViewObject (implements jp.co.intra_mart.framework.presentation.view.ViewObject)
      • class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject (implements jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.view.ViewConverterException

インタフェース階層

  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.presentation.view.ViewObject
      • interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject
  • interface jp.co.intra_mart.framework.presentation.view.ViewConverter
  • interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.presentation.view の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation.view の使用

jp.co.intra_mart.framework.presentation.view を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.presentation.view のクラス
ViewObject
ビューオブジェクトのインタフェースです。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.presentation.view のクラス
Option
選択項目における選択肢です。
PanelBasedViewObject
パネルコンポーネントの表示に関連するオブジェクトです。
SelectableItem
選択肢を持つ項目です。
SimpleViewObject
単純なビューオブジェクトです。
ViewConverter
出力情報をビューオブジェクトに変換します。
ViewConverterConfig
ViewConverterの初期化情報です。
ViewConverterException
ViewConverterに関連する例外です。
ViewObject
ビューオブジェクトのインタフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PanelBasedViewObject (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
インタフェース PanelBasedViewObject

すべてのスーパーインタフェース:
Serializable, ViewObject
既知の実装クラスの一覧:
SimplePanelBasedViewObject
public interface PanelBasedViewObject
extends ViewObject

パネルコンポーネントの表示に関連するオブジェクトです。

導入されたバージョン:
4.3

メソッドの概要
 Map getSubPanelViewObjects()
サブパネルに対応するPanelBasedViewObjectを取得します。
インタフェース jp.co.intra_mart.framework.presentation.view.ViewObject から継承したメソッド
getFormObjects, getViewInfo

メソッドの詳細

getSubPanelViewObjects

public Map getSubPanelViewObjects()
サブパネルに対応するPanelBasedViewObjectを取得します。 このメソッドで取得されるマップは、名前とPanelBasedViewObjectが対応付けられたものである必要があります。

戻り値:
サブパネル名に対応するPanelBasedViewObjectのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SelectableItem (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス SelectableItem

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SelectableItem
直系の既知のサブクラス:
MultiSelectableItem, SingleSelectableItem
public abstract class SelectableItem
extends Object

選択肢を持つ項目です。 選択肢としてOptionを複数個持ちます。

導入されたバージョン:
4.3

コンストラクタの概要
SelectableItem()
メソッドの概要
Option | findOption(String value) 値に該当する選択肢を取得します。
Option[] | getOption() 選択肢をすべて取得します。
Option | getOption(int index) 選択肢を取得します。
protected abstract boolean | isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | setOption(int index, Option option) 選択肢を設定します。
void | setOption(Option[] items) 選択肢を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SelectableItem

public SelectableItem()
メソッドの詳細

getOption

public Option[] getOption()
選択肢をすべて取得します。

戻り値:
選択肢の配列

getOption

public Option getOption(int index)
選択肢を取得します。 indexで指定された選択肢を取得します。

パラメータ:
index - インデックス
戻り値:
選択肢

setOption

public void setOption(Option[] items)
選択肢を設定します。

パラメータ:
items - 選択肢の配列

setOption

public void setOption(int index,
                      Option option)
選択肢を設定します。 indexで指定された場所に選択肢を設定します。

パラメータ:
index - インデックス
option - 選択肢

findOption

public Option findOption(String value)
値に該当する選択肢を取得します。

パラメータ:
value - 値
戻り値:
選択肢

isSelected

protected abstract boolean isSelected(Option option)
指定された選択肢が選択済かどうか判定します。

パラメータ:
option - 選択肢
戻り値:
選択されていればtrue、選択されていなければfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SimplePanelBasedViewObject (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス SimplePanelBasedViewObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SimpleViewObject
        拡張 jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject
すべての実装インタフェース:
PanelBasedViewObject, Serializable, ViewObject
public class SimplePanelBasedViewObject
extends SimpleViewObject
implements PanelBasedViewObject

パネルコンポーネントの表示に関連するオブジェクトです。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
SimplePanelBasedViewObject()
メソッドの概要
Map | getSubPanelViewObjects() サブパネルに対応するPanelBasedViewObjectを取得します。
void | setSubPanelViewObjects(Map views) サブパネルに対応するPanelBasedViewObjectを設定します。
クラス jp.co.intra_mart.framework.presentation.view.SimpleViewObject から継承したメソッド
getFormObjects, getViewInfo, setFormObjects, setViewInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.framework.presentation.view.ViewObject から継承したメソッド
getFormObjects, getViewInfo

コンストラクタの詳細

SimplePanelBasedViewObject

public SimplePanelBasedViewObject()
メソッドの詳細

getSubPanelViewObjects

public Map getSubPanelViewObjects()
サブパネルに対応するPanelBasedViewObjectを取得します。 このメソッドで取得されるマップは、名前とPanelBasedViewObjectが対応付けられたものである必要があります。

定義:
インタフェース PanelBasedViewObject 内の getSubPanelViewObjects
戻り値:
サブパネル名に対応するPanelBasedViewObjectのマップ

setSubPanelViewObjects

public void setSubPanelViewObjects(Map views)
サブパネルに対応するPanelBasedViewObjectを設定します。 このメソッドで設定するマップは、名前とPanelBasedViewObjectが対応付けられたものである必要があります。

パラメータ:
views - サブパネルに対応するPanelBasedViewObjectのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SimpleViewObject (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス SimpleViewObject

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SimpleViewObject
すべての実装インタフェース:
Serializable, ViewObject
直系の既知のサブクラス:
SimplePanelBasedViewObject
public class SimpleViewObject
extends Object
implements ViewObject

単純なビューオブジェクトです。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
SimpleViewObject()
メソッドの概要
Map | getFormObjects() フォームオブジェクトのマップを取得します。
Object | getViewInfo() 表示情報を取得します。
void | setFormObjects(Map obj) フォームオブジェクトのマップを設定します。
void | setViewInfo(Object info) 表示情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SimpleViewObject

public SimpleViewObject()
メソッドの詳細

getViewInfo

public Object getViewInfo()
表示情報を取得します。 このメソッドで取得されるインスタンスはJavaBeansの仕様に沿っている必要があります。

定義:
インタフェース ViewObject 内の getViewInfo
戻り値:
表示情報

setViewInfo

public void setViewInfo(Object info)
表示情報を設定します。 このメソッドで設定するインスタンスはJavaBeansの仕様に沿っている必要があります。

パラメータ:
info - 表示情報

getFormObjects

public Map getFormObjects()
フォームオブジェクトのマップを取得します。 このメソッドで取得されるマップは、名前とフォームオブジェクトが対応付けられたものである必要があります。

定義:
インタフェース ViewObject 内の getFormObjects
戻り値:
フォームオブジェクト

setFormObjects

public void setFormObjects(Map obj)
フォームオブジェクトのマップを設定します。 このメソッドで設定されるマップは、名前とフォームオブジェクトが対応付けられたものである必要があります。

パラメータ:
obj - フォームオブジェクトのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SingleSelectableItem (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス SingleSelectableItem

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.view.SelectableItem
        拡張 jp.co.intra_mart.framework.presentation.view.SingleSelectableItem
public class SingleSelectableItem
extends SelectableItem

単一の選択肢のみ選択することが可能な項目です。

導入されたバージョン:
4.3

コンストラクタの概要
SingleSelectableItem()
メソッドの概要
Option | getSelected() 選択済の選択肢を取得します。
protected boolean | isSelected(Option option) 指定された選択肢が選択済かどうか判定します。
void | setSelected(Option option) 選択済の選択肢を設定します。
クラス jp.co.intra_mart.framework.presentation.view.SelectableItem から継承したメソッド
findOption, getOption, getOption, setOption, setOption
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SingleSelectableItem

public SingleSelectableItem()
メソッドの詳細

getSelected

public Option getSelected()
選択済の選択肢を取得します。

戻り値:
選択済の選択肢、選択済のものがない場合はnull

setSelected

public void setSelected(Option option)
選択済の選択肢を設定します。

パラメータ:
option - 選択済の選択肢

isSelected

protected boolean isSelected(Option option)
指定された選択肢が選択済かどうか判定します。

定義:
クラス SelectableItem 内の isSelected
パラメータ:
option - 選択肢
戻り値:
選択されていればtrue、選択されていなければfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ViewConverter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
インタフェース ViewConverter

既知の実装クラスの一覧:
AbstractViewConverter
public interface ViewConverter

出力情報をビューオブジェクトに変換します。 開発者はこのインタフェースを実装し、適切なビューオブジェクトを返すように convert(RequestInfo)メソッドを実装する 必要があります。

導入されたバージョン:
4.3

メソッドの概要
ViewObject | convert(RequestInfo info) リクエスト情報をもとにビューオブジェクトを生成します。
void | destroy() ViewConverterを破棄します。
void | init(ViewConverterConfig config) ViewConverterを初期化します。

メソッドの詳細

init

public void init(ViewConverterConfig config)
          throws ViewConverterException
ViewConverterを初期化します。

パラメータ:
config - 初期化情報
例外:
ForwardSelectorException - 初期化時に例外が発生
ViewConverterException

destroy

public void destroy()
ViewConverterを破棄します。

convert

public ViewObject convert(RequestInfo info)
                   throws SystemException,
                          ApplicationException
リクエスト情報をもとにビューオブジェクトを生成します。

パラメータ:
info - リクエスト情報
戻り値:
出力時に必要となる内容が含まれるビューオブジェクト
例外:
SystemException - ビューオブジェクトの生成時にシステム例外が発生
ApplicationException - ビューオブジェクトの生成時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ViewConverterConfig (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
インタフェース ViewConverterConfig

public interface ViewConverterConfig

ViewConverterの初期化情報です。

導入されたバージョン:
4.3

メソッドの概要
String | getInitParameter(String name) ViewConverterを初期化するときのパラメータを取得します。
Enumeration | getInitParameterNames() 初期化パラメータの名前の一覧を取得します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
ViewConverterを初期化するときのパラメータを取得します。

パラメータ:
name - 初期化パラメータ名
戻り値:
初期化パラメータの値

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前の一覧を取得します。

戻り値:
初期化パラメータの名前の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ViewConverterException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
クラス ViewConverterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.view.ViewConverterException
すべての実装インタフェース:
Serializable
public class ViewConverterException
extends SystemException

ViewConverterに関連する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
ViewConverterException()
詳細メッセージを指定しないで ViewConverterException を構築します。
ViewConverterException(String msg)
指定された詳細メッセージを持つ ViewConverterException を構築します。
ViewConverterException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ViewConverterException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ViewConverterException

public ViewConverterException()
詳細メッセージを指定しないで ViewConverterException を構築します。

ViewConverterException

public ViewConverterException(String msg)
指定された詳細メッセージを持つ ViewConverterException を構築します。

パラメータ:
msg - 詳細メッセージ

ViewConverterException

public ViewConverterException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ViewConverterException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ViewObject (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation.view
インタフェース ViewObject

すべてのスーパーインタフェース:
Serializable
既知のサブインタフェースの一覧:
PanelBasedViewObject
既知の実装クラスの一覧:
SimplePanelBasedViewObject, SimpleViewObject
public interface ViewObject
extends Serializable

ビューオブジェクトのインタフェースです。 すべてのビューオブジェクトはこのインタフェースを実装する必要があります。 このインタフェースを実装するクラスはJavaBeansの仕様に沿っている必要があります。

導入されたバージョン:
4.3

メソッドの概要
Map | getFormObjects() フォームオブジェクトのマップを取得します。
Object | getViewInfo() 表示情報を取得します。

メソッドの詳細

getViewInfo

public Object getViewInfo()
表示情報を取得します。 このメソッドで取得されるインスタンスはJavaBeansの仕様に沿っている必要があります。

戻り値:
表示情報

getFormObjects

public Map getFormObjects()
フォームオブジェクトのマップを取得します。 このメソッドで取得されるマップは、名前とフォームオブジェクトが対応付けられたものである必要があります。

戻り値:
フォームオブジェクトのマップ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


BadRequestException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス BadRequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.presentation.BadRequestException
すべての実装インタフェース:
Serializable
public class BadRequestException
extends ApplicationException

クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
BadRequestException()
詳細メッセージを指定しないで BadRequestException を構築します。
BadRequestException(String msg)
指定された詳細メッセージを持つ BadRequestException を構築します。
BadRequestException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ BadRequestException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BadRequestException

public BadRequestException()
詳細メッセージを指定しないで BadRequestException を構築します。

BadRequestException

public BadRequestException(String msg)
指定された詳細メッセージを持つ BadRequestException を構築します。

パラメータ:
msg - 詳細メッセージ

BadRequestException

public BadRequestException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ BadRequestException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DuplicateException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス DuplicateException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.DuplicateException
すべての実装インタフェース:
Serializable
public class DuplicateException
extends SystemException

重複しているときに発生する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
DuplicateException()
詳細メッセージを指定しないで DuplicateException を構築します。
DuplicateException(String msg)
指定された詳細メッセージを持つ DuplicateException を構築します。
DuplicateException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DuplicateException

public DuplicateException()
詳細メッセージを指定しないで DuplicateException を構築します。

DuplicateException

public DuplicateException(String msg)
指定された詳細メッセージを持つ DuplicateException を構築します。

パラメータ:
msg - 詳細メッセージ

DuplicateException

public DuplicateException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MismatchException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス MismatchException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.MismatchException
すべての実装インタフェース:
Serializable
public class MismatchException
extends SystemException

キーが重複しているときに発生する例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
MismatchException()
詳細メッセージを指定しないで DuplicateException を構築します。
MismatchException(String msg)
指定された詳細メッセージを持つ DuplicateException を構築します。
MismatchException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MismatchException

public MismatchException()
詳細メッセージを指定しないで DuplicateException を構築します。

MismatchException

public MismatchException(String msg)
指定された詳細メッセージを持つ DuplicateException を構築します。

パラメータ:
msg - 詳細メッセージ

MismatchException

public MismatchException(String msg,
                         Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


NameFormatException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス NameFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.NameFormatException
すべての実装インタフェース:
Serializable
public class NameFormatException
extends SystemException

名前が不正であることを示します。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
NameFormatException()
詳細メッセージを指定しないで NameFormatException を構築します。
NameFormatException(String msg)
指定された詳細メッセージを持つ NameFormatException を構築します。
NameFormatException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ NameFormatException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NameFormatException

public NameFormatException()
詳細メッセージを指定しないで NameFormatException を構築します。

NameFormatException

public NameFormatException(String msg)
指定された詳細メッセージを持つ NameFormatException を構築します。

パラメータ:
msg - 詳細メッセージ

NameFormatException

public NameFormatException(String msg,
                           Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ NameFormatException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.presentation
インタフェース
PresentationPropertyHandler
RequestInfo
クラス
PresentationConnectFilter
PresentationManager
PresentationServlet
例外
BadRequestException
DuplicateException
MismatchException
NameFormatException
PresentationManagerException
PresentationPropertyException
TokenInvalidException


jp.co.intra_mart.framework.presentation (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation

Presentation Frameworkに関連するパッケージです。

参照:
説明

インタフェースの概要
PresentationPropertyHandler | プレゼンテーションフレームワークのプロパティ設定のハンドラです。
RequestInfo | リクエストに対する情報を取得します。

クラスの概要
PresentationConnectFilter | 推奨されていません。 この機能は廃止されました。
PresentationManager | プレゼンテーションマネージャです。
PresentationServlet | プレゼンテーションフレームワークのサーブレットです。

例外の概要
BadRequestException | クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。
DuplicateException | 重複しているときに発生する例外です。
MismatchException | キーが重複しているときに発生する例外です。
NameFormatException | 名前が不正であることを示します。
PresentationManagerException | PresentationManager設定時の例外です。
PresentationPropertyException | PresentationProperty取得時の例外です。
TokenInvalidException | トークンが不正な場合に発生する例外です。

パッケージ jp.co.intra_mart.framework.presentation の説明

Presentation Frameworkに関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.presentation クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.presentation の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.framework.presentation.PresentationServlet
    • class jp.co.intra_mart.framework.presentation.PresentationConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.presentation.PresentationManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.presentation.BadRequestException
            • class jp.co.intra_mart.framework.presentation.TokenInvalidException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.DuplicateException
            • class jp.co.intra_mart.framework.presentation.MismatchException
            • class jp.co.intra_mart.framework.presentation.NameFormatException
            • class jp.co.intra_mart.framework.presentation.PresentationManagerException
            • class jp.co.intra_mart.framework.presentation.PresentationPropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler
  • interface jp.co.intra_mart.framework.presentation.RequestInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.presentation の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.presentation の使用

jp.co.intra_mart.framework.presentation を使用しているパッケージ
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.presentation のクラス
PresentationManager
プレゼンテーションマネージャです。
PresentationManagerException
PresentationManager設定時の例外です。
PresentationPropertyException
PresentationProperty取得時の例外です。
PresentationPropertyHandler
プレゼンテーションフレームワークのプロパティ設定のハンドラです。

jp.co.intra_mart.framework.presentation.controller により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.presentation.forward により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.presentation.service により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.presentation.validator により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.presentation のクラス
RequestInfo
リクエストに対する情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PresentationConnectFilter (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.PresentationConnectFilter
すべての実装インタフェース:
Filter
推奨されていません。 この機能は廃止されました。

public class PresentationConnectFilter
extends Object
implements Filter

intra-martのページベースの画面からPresentation Frameworkの画面に遷移する時に使うフィルタです。 intra-martから来るリクエストをPresentation Frameworkで扱う形式に変換します。 このフィルタで変換されたリクエストは PresentationServletで扱えるようになります。

導入されたバージョン:
4.3

フィールドの概要
static String | INTRAMART_URL_NAME 推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
static String | LICENSE_PATH 推奨されていません。 Append-Product定義ファイルのアクセス権記述子
static String | PARAM_ARGUMENT 推奨されていません。 ページ引数のリクエストパラメータ名
static String | PARAM_LOGIN_GROUP_ID 推奨されていません。 ログイングループIDのリクエストパラメータ名
static String | PARAM_LOGIN_USER_ID 推奨されていません。 ログインユーザIDのリクエストパラメータ名
static String | PARAM_REFERER 推奨されていません。 参照元URLのリクエストパラメータ名
static String | PARAM_WINDOW_NAME 推奨されていません。 基本ウィンドウ名
コンストラクタの概要
PresentationConnectFilter()
推奨されていません。 ライセンス情報の設定
メソッドの概要
void | destroy() 推奨されていません。 フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) 推奨されていません。 intra-martから来るリクエストをPresentation Frameworkで扱う形式に変換します。
void | init(FilterConfig filterConfig) 推奨されていません。 このフィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PARAM_LOGIN_USER_ID

public static final String PARAM_LOGIN_USER_ID
推奨されていません。
ログインユーザIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_LOGIN_GROUP_ID

public static final String PARAM_LOGIN_GROUP_ID
推奨されていません。
ログイングループIDのリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_ARGUMENT

public static final String PARAM_ARGUMENT
推奨されていません。
ページ引数のリクエストパラメータ名

関連項目:
定数フィールド値

PARAM_REFERER

public static final String PARAM_REFERER
推奨されていません。
参照元URLのリクエストパラメータ名

関連項目:
定数フィールド値

INTRAMART_URL_NAME

public static final String INTRAMART_URL_NAME
推奨されていません。
セッションに登録するintra-martのサーブレットのURLの属性名

関連項目:
定数フィールド値

PARAM_WINDOW_NAME

public static final String PARAM_WINDOW_NAME
推奨されていません。
基本ウィンドウ名

関連項目:
定数フィールド値

LICENSE_PATH

public static final String LICENSE_PATH
推奨されていません。
Append-Product定義ファイルのアクセス権記述子

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationConnectFilter

public PresentationConnectFilter()
推奨されていません。
ライセンス情報の設定

メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
推奨されていません。
このフィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
推奨されていません。
intra-martから来るリクエストをPresentation Frameworkで扱う形式に変換します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタチェイン
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
推奨されていません。
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PresentationManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.presentation.PresentationManager
public abstract class PresentationManager
extends Object

プレゼンテーションマネージャです。

導入されたバージョン:
4.3

フィールドの概要
static String | CONFIG PresentationManagerの生成情報が設定されているリソースバンドル名
static String | MANAGER_CLASS_KEY PresentationManagerの実装クラス名が記述されているキー
コンストラクタの概要
protected PresentationManager()
PresentationManagerを新規に生成します。
メソッドの概要
abstract String | createToken() 新しいトークンを取得します。
static PresentationManager | getManager() PresentationManagerを取得します。
abstract PresentationPropertyHandler | getPresentationPropertyHandler() PresentationPropertyHandlerを取得します。
abstract void | lockSession(String id) セッションをロックします。
abstract void | unlockSession(String id) セッションのロックを解除します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONFIG

public static final String CONFIG
PresentationManagerの生成情報が設定されているリソースバンドル名

関連項目:
定数フィールド値

MANAGER_CLASS_KEY

public static final String MANAGER_CLASS_KEY
PresentationManagerの実装クラス名が記述されているキー

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationManager

protected PresentationManager()
PresentationManagerを新規に生成します。 このクラスのインスタンスは明示的に生成できません。 代わりにgetManager()でこのクラスのインスタンスを取得してください。

メソッドの詳細

getManager

public static PresentationManager getManager()
                                      throws PresentationManagerException
PresentationManagerを取得します。

戻り値:
PresentationManager
例外:
PresentationManagerException - PresentationManagerの生成が失敗した

getPresentationPropertyHandler

public abstract PresentationPropertyHandler getPresentationPropertyHandler()
PresentationPropertyHandlerを取得します。

戻り値:
PresentationPropertyHandler

createToken

public abstract String createToken()
                            throws PresentationManagerException
新しいトークンを取得します。

戻り値:
新しいトークン
例外:
PresentationManagerException - トークンの取得に失敗

lockSession

public abstract void lockSession(String id)
                          throws PresentationManagerException
セッションをロックします。

パラメータ:
id - セッションID
例外:
PresentationManagerException - ロックに失敗

unlockSession

public abstract void unlockSession(String id)
                            throws PresentationManagerException
セッションのロックを解除します。

パラメータ:
id - セッションID
例外:
PresentationManagerException - ロック解除に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PresentationManagerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.PresentationManagerException
すべての実装インタフェース:
Serializable
public class PresentationManagerException
extends SystemException

PresentationManager設定時の例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
PresentationManagerException()
詳細メッセージを指定しないで PresentationManagerException を構築します。
PresentationManagerException(String msg)
指定された詳細メッセージを持つ PresentationManagerException を構築します。
PresentationManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PresentationManagerException

public PresentationManagerException()
詳細メッセージを指定しないで PresentationManagerException を構築します。

PresentationManagerException

public PresentationManagerException(String msg)
指定された詳細メッセージを持つ PresentationManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

PresentationManagerException

public PresentationManagerException(String msg,
                                    Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PresentationPropertyException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.presentation.PresentationPropertyException
すべての実装インタフェース:
Serializable
public class PresentationPropertyException
extends SystemException

PresentationProperty取得時の例外です。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
PresentationPropertyException()
詳細メッセージを指定しないで PresentationPropertyException を構築します。
PresentationPropertyException(String msg)
指定された詳細メッセージを持つ PresentationPropertyException を構築します。
PresentationPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PresentationPropertyException

public PresentationPropertyException()
詳細メッセージを指定しないで PresentationPropertyException を構築します。

PresentationPropertyException

public PresentationPropertyException(String msg)
指定された詳細メッセージを持つ PresentationPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

PresentationPropertyException

public PresentationPropertyException(String msg,
                                     Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PresentationPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
インタフェース PresentationPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
public interface PresentationPropertyHandler
extends PropertyHandler

プレゼンテーションフレームワークのプロパティ設定のハンドラです。

導入されたバージョン:
4.3

メソッドの概要
jp.co.intra_mart.framework.presentation.property.Application | getApplication(String name) アプリケーションの情報を取得します。
boolean | isDynamic() プロパティの動的読み込みが可能かどうか調べます。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

isDynamic

public boolean isDynamic()
                  throws PresentationPropertyException
プロパティの動的読み込みが可能かどうか調べます。

戻り値:
true：プロパティの動的読み込みが可能、false：プロパティの動的読み込み不可
例外:
PresentationPropertyException - チェック時に例外が発生

getApplication

public jp.co.intra_mart.framework.presentation.property.Application getApplication(String name)
                                                                            throws PresentationPropertyException
アプリケーションの情報を取得します。

パラメータ:
name - パッケージまで指定した完全なアプリケーション名
戻り値:
アプリケーション情報
例外:
PresentationPropertyException - アプリケーション情報取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PresentationServlet (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス PresentationServlet

java.lang.Object
    拡張 javax.servlet.GenericServlet
        拡張 javax.servlet.http.HttpServlet
            拡張 jp.co.intra_mart.framework.presentation.PresentationServlet
すべての実装インタフェース:
Serializable, Servlet, ServletConfig
public class PresentationServlet
extends HttpServlet

プレゼンテーションフレームワークのサーブレットです。

導入されたバージョン:
4.3
関連項目:
直列化された形式

フィールドの概要
static String | ACTION_ID アクションによる遷移をする場合のID
static String | LICENSE_PATH Append-Product定義ファイルのアクセス権記述子
static String | PREFIX_ATTRIBUTE HttpServletRequestにおけるURLのプレフィックスの保存先
static String | REQUEST_INFO_ATTRIBUTE HttpServletRequestにおける RequestInfoの保存先
static String | REQUEST_SEPARATOR リクエストの情報を分割するセパレータ
static String | START_ID スタートポイントに入る場合のID
static String | SUFFIX_ATTRIBUTE HttpServletRequestにおけるURLのサフィックスの保存先
static String | TOKEN_ATTRIBUTE HttpServletRequestにおける次の画面のトークンの保存先
コンストラクタの概要
PresentationServlet()
メソッドの概要
void | destroy() サーブレットを破棄します。
protected void | doGet(HttpServletRequest request, HttpServletResponse response) リクエストがGETで来た場合の処理をします。
protected void | doPost(HttpServletRequest request, HttpServletResponse response) リクエストがPOSTで来た場合の処理をします。
jp.co.intra_mart.framework.presentation.PresentationServlet.RequestInfoImpl | getRequestInfo(HttpServletRequest request, HttpServletResponse response) RequestInfoを取得します。
void | init(ServletConfig config) サーブレットを初期化します。
クラス javax.servlet.http.HttpServlet から継承したメソッド
doDelete, doHead, doOptions, doPut, doTrace, getLastModified, service, service
クラス javax.servlet.GenericServlet から継承したメソッド
getInitParameter, getInitParameterNames, getServletConfig, getServletContext, getServletInfo, getServletName, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

START_ID

public static final String START_ID
スタートポイントに入る場合のID

関連項目:
定数フィールド値

ACTION_ID

public static final String ACTION_ID
アクションによる遷移をする場合のID

関連項目:
定数フィールド値

REQUEST_SEPARATOR

public static final String REQUEST_SEPARATOR
リクエストの情報を分割するセパレータ

関連項目:
定数フィールド値

REQUEST_INFO_ATTRIBUTE

public static final String REQUEST_INFO_ATTRIBUTE
HttpServletRequestにおける RequestInfoの保存先

関連項目:
定数フィールド値

PREFIX_ATTRIBUTE

public static final String PREFIX_ATTRIBUTE
HttpServletRequestにおけるURLのプレフィックスの保存先

関連項目:
定数フィールド値

SUFFIX_ATTRIBUTE

public static final String SUFFIX_ATTRIBUTE
HttpServletRequestにおけるURLのサフィックスの保存先

関連項目:
定数フィールド値

TOKEN_ATTRIBUTE

public static final String TOKEN_ATTRIBUTE
HttpServletRequestにおける次の画面のトークンの保存先

関連項目:
定数フィールド値

LICENSE_PATH

public static final String LICENSE_PATH
Append-Product定義ファイルのアクセス権記述子

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationServlet

public PresentationServlet()
メソッドの詳細

init

public void init(ServletConfig config)
          throws ServletException
サーブレットを初期化します。

パラメータ:
config -
例外:
ServletException - 初期化時に例外が発生

doGet

protected void doGet(HttpServletRequest request,
                     HttpServletResponse response)
              throws ServletException,
                     IOException
リクエストがGETで来た場合の処理をします。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - Servletの例外が発生
IOException - 入出力例外が発生

doPost

protected void doPost(HttpServletRequest request,
                      HttpServletResponse response)
               throws ServletException,
                      IOException
リクエストがPOSTで来た場合の処理をします。

パラメータ:
request - リクエスト
response - レスポンス
例外:
ServletException - Servletの例外が発生
IOException - 入出力例外が発生

destroy

public void destroy()
サーブレットを破棄します。

getRequestInfo

public jp.co.intra_mart.framework.presentation.PresentationServlet.RequestInfoImpl getRequestInfo(HttpServletRequest request,
                                                                                HttpServletResponse response)
                                                                                throws ServletException,
                                                                                IOException
RequestInfoを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
RequestInfo
例外:
ServletException - サーブレット例外が発生
IOException - IO例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


RequestInfo (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
インタフェース RequestInfo

public interface RequestInfo

リクエストに対する情報を取得します。

導入されたバージョン:
4.3

メソッドの概要
ControllerObject | getControllerObject() リクエストから生成されたコントローラオブジェクトを取得します。
HttpServletRequest | getRequest() リクエストを取得します。
HttpServletResponse | getResponse() レスポンスを取得します。
ServiceResult | getResult() サービス処理結果を取得します。
Throwable | getThrowable() 処理中に発生した例外を取得します。
ViewObject | getViewObject() 生成されたビューオブジェクトを取得します。

メソッドの詳細

getRequest

public HttpServletRequest getRequest()
リクエストを取得します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
レスポンスを取得します。

戻り値:
レスポンス

getControllerObject

public ControllerObject getControllerObject()
リクエストから生成されたコントローラオブジェクトを取得します。 このメソッドはコントローラオブジェクトが生成されていないとき、 またはControllerConverterが指定されていないときはnullが戻ります。

戻り値:
リクエストから生成されたコントローラオブジェクト（コントローラオブジェクトが生成されていない、またはControllerConverterが指定されていないときはnull）

getViewObject

public ViewObject getViewObject()
生成されたビューオブジェクトを取得します。 このメソッドはビューオブジェクトが生成されていないとき、 またはViewConverterが指定されていないときはnullが戻ります。

戻り値:
生成されたビューオブジェクト（ビューオブジェクトが生成されていない、またはViewConverterが指定されていないときはnull）

getResult

public ServiceResult getResult()
サービス処理結果を取得します。 このメソッドはサービス処理結果が生成されていないとき、 またはServiceControllerが指定されていないときはnullが戻ります。

戻り値:
サービス処理結果（サービス処理結果が生成されていない、またはServiceControllerが指定されていないときはnull）

getThrowable

public Throwable getThrowable()
処理中に発生した例外を取得します。

戻り値:
処理中に発生した例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


TokenInvalidException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.presentation
クラス TokenInvalidException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.framework.presentation.TokenInvalidException
すべての実装インタフェース:
Serializable
public class TokenInvalidException
extends ApplicationException

トークンが不正な場合に発生する例外です。 ブラウザのBackボタンなどによって不正にリクエストが送信されたときなどにthrowされます。

導入されたバージョン:
4.3
関連項目:
直列化された形式

コンストラクタの概要
TokenInvalidException()
詳細メッセージを指定しないで TokenInvalidException を構築します。
TokenInvalidException(String msg)
指定された詳細メッセージを持つ TokenInvalidException を構築します。
TokenInvalidException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TokenInvalidException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TokenInvalidException

public TokenInvalidException()
詳細メッセージを指定しないで TokenInvalidException を構築します。

TokenInvalidException

public TokenInvalidException(String msg)
指定された詳細メッセージを持つ TokenInvalidException を構築します。

パラメータ:
msg - 詳細メッセージ

TokenInvalidException

public TokenInvalidException(String msg,
                             Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TokenInvalidException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.exception.ApplicationException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.ApplicationException の使用

ApplicationException を使用しているパッケージ
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。

jp.co.intra_mart.framework.base.event での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.service での ApplicationException の使用

jp.co.intra_mart.framework.base.service での ApplicationException のサブクラス
 class RequestException
リクエストの内容に関連する間違いがある場合の例外です。

ApplicationException をスローする jp.co.intra_mart.framework.base.service のメソッド
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
protected EventResult | ServiceControllerAdapter.dispatchEvent(Event event) イベント処理を実行します。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。

jp.co.intra_mart.framework.base.web.bean での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation での ApplicationException の使用

jp.co.intra_mart.framework.presentation での ApplicationException のサブクラス
class | BadRequestException クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。
class | TokenInvalidException トークンが不正な場合に発生する例外です。

jp.co.intra_mart.framework.presentation.validator での ApplicationException の使用

jp.co.intra_mart.framework.presentation.validator での ApplicationException のサブクラス
 class ValidationException
検証結果が不正であるときの例外です。

jp.co.intra_mart.framework.presentation.view での ApplicationException の使用

ApplicationException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
ViewObject | ViewConverter.convert(RequestInfo info) リクエスト情報をもとにビューオブジェクトを生成します。
protected EventResult | AbstractViewConverter.dispatchEvent(Event event) イベント処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.exception.FrameworkException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.FrameworkException の使用

FrameworkException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での FrameworkException の使用

jp.co.intra_mart.framework.base.data での FrameworkException のサブクラス
class | DAOException リソースコネクタの情報取得時の例外です。
class | DataAccessException データアクセス時の例外です。
class | DataConnectException データ接続に関連する例外です。
class | DataConnectorException データコネクタ取得時の例外です。
class | DataManagerException データマネージャの設定時の例外です。
class | DataPropertyException データプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.event での FrameworkException の使用

jp.co.intra_mart.framework.base.event での FrameworkException のサブクラス
class | EventException イベント生成時の例外です。
class | EventListenerException イベントリスナ生成時の例外です。
class | EventManagerException イベントマネージャ設定時の例外です。
class | EventPropertyException イベントプロパティ取得時の例外です。
class | EventTriggerException イベントトリガ生成時の例外です。

jp.co.intra_mart.framework.base.message での FrameworkException の使用

jp.co.intra_mart.framework.base.message での FrameworkException のサブクラス
class | MessageManagerException サービスマネージャ設定時の例外です。
class | MessagePropertyException メッセージプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.service での FrameworkException の使用

jp.co.intra_mart.framework.base.service での FrameworkException のサブクラス
class | RequestException リクエストの内容に関連する間違いがある場合の例外です。
class | ServiceControllerException サービスコントローラに関連する例外です。
class | ServiceManagerException サービスマネージャ設定時の例外です。
class | ServicePropertyException サービスプロパティ取得時の例外です。
class | ServiceServletException サービスに関連する例外です。
class | TransitionException トランジションに関連する例外です。

jp.co.intra_mart.framework.base.session での FrameworkException の使用

jp.co.intra_mart.framework.base.session での FrameworkException のサブクラス
class | IllegalSessionException セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
class | SessionFactoryException セッションファクトリ内の例外です。
class | SessionManagerException セッションマネージャ内の例外です。
class | SessionObjectException セッションオブジェクト内の例外です。
class | SessionPropertyException セッションプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.util での FrameworkException の使用

jp.co.intra_mart.framework.base.util での FrameworkException のサブクラス
 class UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean での FrameworkException の使用

jp.co.intra_mart.framework.base.web.bean での FrameworkException のサブクラス
 class HelperBeanException
HelperBean内で発生した例外です。

jp.co.intra_mart.framework.presentation での FrameworkException の使用

jp.co.intra_mart.framework.presentation での FrameworkException のサブクラス
class | BadRequestException クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。
class | DuplicateException 重複しているときに発生する例外です。
class | MismatchException キーが重複しているときに発生する例外です。
class | NameFormatException 名前が不正であることを示します。
class | PresentationManagerException PresentationManager設定時の例外です。
class | PresentationPropertyException PresentationProperty取得時の例外です。
class | TokenInvalidException トークンが不正な場合に発生する例外です。

jp.co.intra_mart.framework.presentation.controller での FrameworkException の使用

jp.co.intra_mart.framework.presentation.controller での FrameworkException のサブクラス
class | ControllerConverterException ControllerConverterに関連する例外です。
class | RequestFormatException フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.presentation.forward での FrameworkException の使用

jp.co.intra_mart.framework.presentation.forward での FrameworkException のサブクラス
 class ForwardSelectorException
ForwardSelectorに関連する例外です。

jp.co.intra_mart.framework.presentation.validator での FrameworkException の使用

jp.co.intra_mart.framework.presentation.validator での FrameworkException のサブクラス
class | ValidationException 検証結果が不正であるときの例外です。
class | ValidatorException Validatorに関連する例外です。

jp.co.intra_mart.framework.presentation.view での FrameworkException の使用

jp.co.intra_mart.framework.presentation.view での FrameworkException のサブクラス
 class ViewConverterException
ViewConverterに関連する例外です。

jp.co.intra_mart.framework.system.exception での FrameworkException の使用

jp.co.intra_mart.framework.system.exception での FrameworkException のサブクラス
class | ApplicationException フレームワーク内で発生したアプリケーション例外です。
class | IllegalSystemException 想定外の例外が発生したときの例外です。
class | SystemException フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.log での FrameworkException の使用

jp.co.intra_mart.framework.system.log での FrameworkException のサブクラス
 class LogPropertyException
ログプロパティ取得時の例外です。

jp.co.intra_mart.framework.system.property での FrameworkException の使用

jp.co.intra_mart.framework.system.property での FrameworkException のサブクラス
class | PropertyHandlerException プロパティハンドラの情報取得時の例外です。
class | PropertyManagerException プロパティマネージャの設定時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.exception.IllegalSystemException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.IllegalSystemException の使用

jp.co.intra_mart.framework.system.exception.IllegalSystemException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.exception.SystemException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.exception.SystemException の使用

SystemException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.base.data での SystemException の使用

jp.co.intra_mart.framework.base.data での SystemException のサブクラス
class | DAOException リソースコネクタの情報取得時の例外です。
class | DataAccessException データアクセス時の例外です。
class | DataConnectException データ接続に関連する例外です。
class | DataConnectorException データコネクタ取得時の例外です。
class | DataManagerException データマネージャの設定時の例外です。
class | DataPropertyException データプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.event での SystemException の使用

jp.co.intra_mart.framework.base.event での SystemException のサブクラス
class | EventException イベント生成時の例外です。
class | EventListenerException イベントリスナ生成時の例外です。
class | EventManagerException イベントマネージャ設定時の例外です。
class | EventPropertyException イベントプロパティ取得時の例外です。
class | EventTriggerException イベントトリガ生成時の例外です。

SystemException をスローする jp.co.intra_mart.framework.base.event のメソッド
EventResult | StandardEventListener.execute(Event event) 処理を実行します。
protected abstract EventResult | StandardEventListener.fire(Event event) イベントに対する処理です。
protected EventResult | StandardEventListener.dispatchEvent(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListenerAgentBean.execute(Event event) イベント処理を実行します。
protected abstract EventResult | StandardEJBEventListenerAgentBean.fire(Event event, DataAccessController dataAccessController) イベントに対する処理です。
EventResult | StandardEJBEventListenerAgent.execute(Event event) イベント処理を実行します。
EventResult | StandardEJBEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEventListener.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerLocal.execute(Event event) 処理を実行します。
EventResult | GenericEJBEventListenerAgentLocal.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListenerAgentBean.execute(Event event, String listenerName) イベント処理を実行します。
EventResult | GenericEJBEventListenerAgent.execute(Event event, String listenerName) イベント処理を行います。
EventResult | GenericEJBEventListener.execute(Event event) 処理を実行します。
void | EventTriggerList.fireAll(Event event, DataAccessController controller) すべてのトリガに対してイベントの処理を行います。
void | EventTriggerAdapter.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
protected abstract void | EventTriggerAdapter.fire(Event event) イベントに対する処理を行います。
void | EventTrigger.fire(Event event, DataAccessController controller) イベントに対する処理を行います。
EventResult | EventManager.dispatch(Event event) イベントに対する処理を実行します。
EventResult | EventManager.dispatch(Event event, boolean transaction) イベントに対する処理を実行します。
EventResult | EventListener.execute(Event event) 処理を実行します。
protected EventResult | EJBEventListenerAgentBean.dispatchEvent(Event event) イベント処理を実行します。
protected EventResult | EJBEventListener.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.base.message での SystemException の使用

jp.co.intra_mart.framework.base.message での SystemException のサブクラス
class | MessageManagerException サービスマネージャ設定時の例外です。
class | MessagePropertyException メッセージプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.service での SystemException の使用

jp.co.intra_mart.framework.base.service での SystemException のサブクラス
class | ServiceControllerException サービスコントローラに関連する例外です。
class | ServiceManagerException サービスマネージャ設定時の例外です。
class | ServicePropertyException サービスプロパティ取得時の例外です。
class | ServiceServletException サービスに関連する例外です。
class | TransitionException トランジションに関連する例外です。

SystemException をスローする jp.co.intra_mart.framework.base.service のメソッド
jp.co.intra_mart.foundation.http.MultipartFormData.Entity | Transition.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
abstract void | Transition.transfer() 次のページに遷移します。
jp.co.intra_mart.foundation.http.MultipartFormData.Entity | ServiceControllerAdapter.getEntity(String name) リクエストから指定された名前に該当するエンティティを取得します。
void | ServiceControllerAdapter.check() 入力内容をチェックします。
ServiceResult | ServiceControllerAdapter.service() 入力に対する処理を実行します。
protected EventResult | ServiceControllerAdapter.dispatchEvent(Event event) イベント処理を実行します。
void | ServiceController.check() 入力内容をチェックします。
ServiceResult | ServiceController.service() 入力に対する処理を実行します。
void | IntramartPageBaseTransition.transfer() ページベースの画面に遷移します。
void | DefaultTransition.transfer() 次のページに遷移します。

jp.co.intra_mart.framework.base.session での SystemException の使用

jp.co.intra_mart.framework.base.session での SystemException のサブクラス
class | IllegalSessionException セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
class | SessionFactoryException セッションファクトリ内の例外です。
class | SessionManagerException セッションマネージャ内の例外です。
class | SessionObjectException セッションオブジェクト内の例外です。
class | SessionPropertyException セッションプロパティ取得時の例外です。

jp.co.intra_mart.framework.base.util での SystemException の使用

jp.co.intra_mart.framework.base.util での SystemException のサブクラス
 class UserInfoException
ユーザ情報に関連する例外です。

jp.co.intra_mart.framework.base.web.bean での SystemException の使用

jp.co.intra_mart.framework.base.web.bean での SystemException のサブクラス
 class HelperBeanException
HelperBean内で発生した例外です。

SystemException をスローする jp.co.intra_mart.framework.base.web.bean のメソッド
protected  EventResult HelperBean.dispatchEvent(Event event)
イベント処理を実行します。

jp.co.intra_mart.framework.presentation での SystemException の使用

jp.co.intra_mart.framework.presentation での SystemException のサブクラス
class | DuplicateException 重複しているときに発生する例外です。
class | MismatchException キーが重複しているときに発生する例外です。
class | NameFormatException 名前が不正であることを示します。
class | PresentationManagerException PresentationManager設定時の例外です。
class | PresentationPropertyException PresentationProperty取得時の例外です。

jp.co.intra_mart.framework.presentation.controller での SystemException の使用

jp.co.intra_mart.framework.presentation.controller での SystemException のサブクラス
class | ControllerConverterException ControllerConverterに関連する例外です。
class | RequestFormatException フォーマットが不正であるときの例外です。

jp.co.intra_mart.framework.presentation.forward での SystemException の使用

jp.co.intra_mart.framework.presentation.forward での SystemException のサブクラス
 class ForwardSelectorException
ForwardSelectorに関連する例外です。

jp.co.intra_mart.framework.presentation.validator での SystemException の使用

jp.co.intra_mart.framework.presentation.validator での SystemException のサブクラス
 class ValidatorException
Validatorに関連する例外です。

jp.co.intra_mart.framework.presentation.view での SystemException の使用

jp.co.intra_mart.framework.presentation.view での SystemException のサブクラス
 class ViewConverterException
ViewConverterに関連する例外です。

SystemException をスローする jp.co.intra_mart.framework.presentation.view のメソッド
ViewObject | ViewConverter.convert(RequestInfo info) リクエスト情報をもとにビューオブジェクトを生成します。
protected EventResult | AbstractViewConverter.dispatchEvent(Event event) イベント処理を実行します。

jp.co.intra_mart.framework.system.exception での SystemException の使用

jp.co.intra_mart.framework.system.exception での SystemException のサブクラス
 class IllegalSystemException
想定外の例外が発生したときの例外です。

jp.co.intra_mart.framework.system.log での SystemException の使用

jp.co.intra_mart.framework.system.log での SystemException のサブクラス
 class LogPropertyException
ログプロパティ取得時の例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ApplicationException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス ApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BadRequestException, RequestException, TokenInvalidException, ValidationException
public class ApplicationException
extends FrameworkException

フレームワーク内で発生したアプリケーション例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
ApplicationException()
詳細メッセージを指定しないで ApplicationException を構築します。
ApplicationException(String msg)
指定された詳細メッセージを持つ ApplicationException を構築します。
ApplicationException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationException(Throwable throwable)
この例外の発生原因となる例外を持つ ApplicationException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ApplicationException

public ApplicationException()
詳細メッセージを指定しないで ApplicationException を構築します。

ApplicationException

public ApplicationException(String msg)
指定された詳細メッセージを持つ ApplicationException を構築します。

パラメータ:
msg - 詳細メッセージ

ApplicationException

public ApplicationException(Throwable throwable)
この例外の発生原因となる例外を持つ ApplicationException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

ApplicationException

public ApplicationException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FrameworkException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス FrameworkException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ApplicationException, PropertyHandlerException, PropertyManagerException, SystemException
public class FrameworkException
extends Exception

フレームワークに共通するの例外のスーパークラスです。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
FrameworkException()
詳細メッセージを指定しないで FrameworkException を構築します。
FrameworkException(String msg)
指定された詳細メッセージを持つ FrameworkException を構築します。
FrameworkException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkException を構築します。
メソッドの概要
Throwable | getException() この例外が発生した原因となる例外を取得します。
void | printStackTrace()
void | printStackTrace(PrintStream printStream)
void | printStackTrace(PrintWriter printWriter)
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FrameworkException

public FrameworkException()
詳細メッセージを指定しないで FrameworkException を構築します。

FrameworkException

public FrameworkException(String msg)
指定された詳細メッセージを持つ FrameworkException を構築します。

パラメータ:
msg - 詳細メッセージ

FrameworkException

public FrameworkException(Throwable throwable)
この例外の発生原因となる例外を持つ FrameworkException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

FrameworkException

public FrameworkException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
メソッドの詳細

getException

public Throwable getException()
この例外が発生した原因となる例外を取得します。

戻り値:
この例外が発生した原因となる例外

printStackTrace

public void printStackTrace()

printStackTrace

public void printStackTrace(PrintStream printStream)

printStackTrace

public void printStackTrace(PrintWriter printWriter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IllegalSystemException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス IllegalSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.exception.IllegalSystemException
すべての実装インタフェース:
Serializable
public class IllegalSystemException
extends SystemException

想定外の例外が発生したときの例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
IllegalSystemException()
詳細メッセージを指定しないで IllegalSystemException を構築します。
IllegalSystemException(String msg)
指定された詳細メッセージを持つ IllegalSystemException を構築します。
IllegalSystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IllegalSystemException

public IllegalSystemException()
詳細メッセージを指定しないで IllegalSystemException を構築します。

IllegalSystemException

public IllegalSystemException(String msg)
指定された詳細メッセージを持つ IllegalSystemException を構築します。

パラメータ:
msg - 詳細メッセージ

IllegalSystemException

public IllegalSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

IllegalSystemException

public IllegalSystemException(String msg,
                              Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.system.exception (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.system.exception
例外
ApplicationException
FrameworkException
IllegalSystemException
SystemException


jp.co.intra_mart.framework.system.exception (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.exception

J2EEフレームワークの例外に関連するパッケージです。

参照:
説明

例外の概要
ApplicationException | フレームワーク内で発生したアプリケーション例外です。
FrameworkException | フレームワークに共通するの例外のスーパークラスです。
IllegalSystemException | 想定外の例外が発生したときの例外です。
SystemException | フレームワーク内で発生したシステム例外です。

パッケージ jp.co.intra_mart.framework.system.exception の説明

J2EEフレームワークの例外に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.system.exception クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.exception.IllegalSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.system.exception の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.exception の使用

jp.co.intra_mart.framework.system.exception を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.util により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.base.web.bean により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation.controller により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation.forward により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation.validator により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.presentation.view により使用される jp.co.intra_mart.framework.system.exception のクラス
ApplicationException
フレームワーク内で発生したアプリケーション例外です。
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.exception により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。
SystemException
フレームワーク内で発生したシステム例外です。

jp.co.intra_mart.framework.system.property により使用される jp.co.intra_mart.framework.system.exception のクラス
FrameworkException
フレームワークに共通するの例外のスーパークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SystemException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.exception
クラス SystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ControllerConverterException, DAOException, DataAccessException, DataConnectException, DataConnectorException, DataManagerException, DataPropertyException, DuplicateException, EventException, EventListenerException, EventManagerException, EventPropertyException, EventTriggerException, ForwardSelectorException, HelperBeanException, IllegalSessionException, IllegalSystemException, LogPropertyException, MessageManagerException, MessageManagerException, MessagePropertyException, MessagePropertyException, MismatchException, NameFormatException, PresentationManagerException, PresentationPropertyException, RequestFormatException, ServiceControllerException, ServiceManagerException, ServicePropertyException, ServiceServletException, SessionFactoryException, SessionManagerException, SessionObjectException, SessionPropertyException, TransitionException, UserInfoException, ValidatorException, ViewConverterException
public class SystemException
extends FrameworkException

フレームワーク内で発生したシステム例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
SystemException()
詳細メッセージを指定しないで SystemException を構築します。
SystemException(String msg)
指定された詳細メッセージを持つ SystemException を構築します。
SystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。
SystemException(Throwable throwable)
この例外の発生原因となる例外を持つ SystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemException

public SystemException()
詳細メッセージを指定しないで SystemException を構築します。

SystemException

public SystemException(String msg)
指定された詳細メッセージを持つ SystemException を構築します。

パラメータ:
msg - 詳細メッセージ

SystemException

public SystemException(Throwable throwable)
この例外の発生原因となる例外を持つ SystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

SystemException

public SystemException(String msg,
                       Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.log.DefaultLogAgent の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.DefaultLogAgent の使用

jp.co.intra_mart.framework.system.log.DefaultLogAgent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の使用

jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.log.IntramartLogAgent の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.IntramartLogAgent の使用

jp.co.intra_mart.framework.system.log.IntramartLogAgent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.system.log.LogAgent の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogAgent の使用

LogAgent を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogAgent の使用

LogAgent を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogAgent デフォルトのログエージェントです。
class | IntramartLogAgent intra-mart で管理されているログに出力するログエージェントです。

LogAgent を返す jp.co.intra_mart.framework.system.log のメソッド
 LogAgent LogManager.getLogAgent()
ログエージェントを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.log.LogAgentParam の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogAgentParam の使用

LogAgentParam を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogAgentParam の使用

LogAgentParam を返す jp.co.intra_mart.framework.system.log のメソッド
LogAgentParam[] | XmlLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
LogAgentParam[] | LogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
LogAgentParam[] | DefaultLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。

LogAgentParam 型のパラメータを持つ jp.co.intra_mart.framework.system.log のメソッド
void | LogAgent.init(LogAgentParam[] params) 初期化します。
void | IntramartLogAgent.init(LogAgentParam[] params) 初期化します。
void | DefaultLogAgent.init(LogAgentParam[] params) 初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.system.log.LogConstant の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogConstant の使用

jp.co.intra_mart.framework.system.log.LogConstant はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.log.LogManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogManager の使用

LogManager を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogManager の使用

LogManager を返す jp.co.intra_mart.framework.system.log のメソッド
static LogManager LogManager.getLogManager()
ログマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.log.LogPropertyException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.LogPropertyException の使用

LogPropertyException を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogPropertyException の使用

LogPropertyException をスローする jp.co.intra_mart.framework.system.log のメソッド
String | XmlLogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | XmlLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
String | LogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | LogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。
String | DefaultLogPropertyHandler.getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | DefaultLogPropertyHandler.getLogAgentParams() ログエージェントのパラメータを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.system.log.LogPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.log.LogPropertyHandler の使用

LogPropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log での LogPropertyHandler の使用

LogPropertyHandler を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogPropertyHandler ログに関連するデフォルトのプロパティハンドラです。
class | XmlLogPropertyHandler リソースからログプロパティ情報を取得するプロパティハンドラです。

LogPropertyHandler を返す jp.co.intra_mart.framework.system.log のメソッド
 LogPropertyHandler LogManager.getLogPropertyHandler()
ログプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の使用

jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultLogAgent (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス DefaultLogAgent

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.DefaultLogAgent
すべての実装インタフェース:
LogAgent
public class DefaultLogAgent
extends Object
implements LogAgent

デフォルトのログエージェントです。 標準出力にログを出力します。 出力されるメッセージは以下のような形式になります。
[カテゴリ][レベル]メッセージ

導入されたバージョン:
4.2

コンストラクタの概要
DefaultLogAgent()

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultLogAgent

public DefaultLogAgent()
メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。 このクラスでは実際には何も行われません。

定義:
インタフェース LogAgent 内の init
パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。 このクラスでは通常、messageを標準出力にログとして出力します。 ただし、levelがLogConstant.LEVEL_ERRORである場合は 標準例外出力にログを出力します。

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 このクラスでは通常、messageはそのまま、 detailはObject.toString()の値を標準出力にログとして出力します。 ただし、levelがLogConstant.LEVEL_ERRORである場合は 標準例外出力にログを出力します。

detailがThrowableのサブクラスである場合、 Throwable.printStackTrace(java.io.PrintWriter)を使用して スタックトレースが出力されます。出力先はdetailによる出力先に従います。

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
 前のクラス   次のクラス | フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド | 詳細:  フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultLogPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス DefaultLogPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler
すべての実装インタフェース:
LogPropertyHandler, PropertyHandler
public class DefaultLogPropertyHandler
extends Object
implements LogPropertyHandler

ログに関連するデフォルトのプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

キー | 内容
agent.class | LogAgentのクラス名
agent.param.パラメータ名 | ログエージェントに渡すパラメータ

導入されたバージョン:
4.2

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultLogPropertyHandler()
DefaultLogPropertyHandlerを新規に生成します。
メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultLogPropertyHandler

public DefaultLogPropertyHandler()
DefaultLogPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentName
戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列が返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentParams
戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartLogAgent (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス IntramartLogAgent

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.IntramartLogAgent
すべての実装インタフェース:
LogAgent
public class IntramartLogAgent
extends Object
implements LogAgent

intra-mart で管理されているログに出力するログエージェントです。 出力先は intra-mart の設定に依存します。 出力されるメッセージは以下のような形式になります。
[レベル]メッセージ
init(LogAgentParam[])に渡すパラメータは以下のように解釈されます。

パラメータ名 | パラメータの値
カテゴリ | カテゴリの種類

カテゴリの種類にTYPE_DBの値を指定するとデータベースログとして出力されます。

導入されたバージョン:
4.2

フィールドの概要
static String TYPE_DB
          データベースログに出力する場合のカテゴリの種類

コンストラクタの概要
IntramartLogAgent()
          IntramartLogAgentを新規に生成します。

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_DB

public static final String TYPE_DB
データベースログに出力する場合のカテゴリの種類

関連項目:
定数フィールド値
コンストラクタの詳細

IntramartLogAgent

public IntramartLogAgent()
IntramartLogAgentを新規に生成します。

メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。 パラメータで指定されたカテゴリを登録します。

定義:
インタフェース LogAgent 内の init
パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。 levelがLogConstant.LEVEL_ERROR以外の場合はメッセージをintra-martのシステムログとして出力します。 levelがLogConstant.LEVEL_ERRORである場合、 categoryをもとに取得されるカテゴリの種類によって以下のようにさらに出力先が分かれます。
  • カテゴリの種類がTYPE_DBである場合、データベースログとして出力
  • カテゴリの種類がTYPE_DB以外である場合、エラーログとして出力

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 levelがLogConstant.LEVEL_ERROR以外の場合はメッセージをintra-martのシステムログとして出力します。 levelがLogConstant.LEVEL_ERRORである場合、以下のように出力先が異なります。
  • detailがThrowableのインスタンスであり
    • カテゴリがDBに関連するものはデータベースログとして出力
    • カテゴリがDBに関連するもの以外であるときはエラーログとして出力
  • detailがThrowable以外のインスタンスであり
    • 詳細文字列が存在し
      • カテゴリの種類がTYPE_DBである場合データベースログとして詳細ごと出力
      • カテゴリの種類がTYPE_DB以外であるときはエラーログとして詳細ごと出力
    • 詳細文字列が存在しないで
      • カテゴリがDBに関連するものはデータベースログとして詳細なしで出力
      • カテゴリがDBに関連するもの以外であるときはエラーログとして詳細なしで出力

定義:
インタフェース LogAgent 内の sendMessage
パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要  パッケージ   クラス  使用  階層ツリー  非推奨 API  索引  ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
 前のクラス   次のクラス フレームあり    フレームなし
概要:  入れ子 | フィールド | コンストラクタ | メソッド 詳細:  フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LogAgent (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogAgent

既知の実装クラスの一覧:
DefaultLogAgent, IntramartLogAgent
public interface LogAgent

ログに出力するエージェントです。 im-J2EE Framework から出るログの出力先を変更したい場合、 このインタフェースを実装したクラスを設定します。

導入されたバージョン:
4.2

メソッドの概要
void | init(LogAgentParam[] params) 初期化します。
void | sendMessage(String category, String level, String message) メッセージを出力します。
void | sendMessage(String category, String level, String message, Object detail) メッセージを出力します。

メソッドの詳細

init

public void init(LogAgentParam[] params)
初期化します。

パラメータ:
params - ログエージェントのパラメータ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message)
メッセージを出力します。

パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ

sendMessage

public void sendMessage(String category,
                        String level,
                        String message,
                        Object detail)
メッセージを出力します。 詳細な情報が添付されたメッセージを出力します。

パラメータ:
category - ログのカテゴリ
level - メッセージのレベル
message - メッセージ
detail - 詳細
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LogAgentParam (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogAgentParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.log.LogAgentParam
public class LogAgentParam
extends PropertyParam

ログエージェントの初期パラメータです。

導入されたバージョン:
4.2

コンストラクタの概要
LogAgentParam()
LogAgentParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LogAgentParam

public LogAgentParam()
LogAgentParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LogConstant (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogConstant

public interface LogConstant

ログフレームワークで使用される定数値です。

導入されたバージョン:
4.2

フィールドの概要
static String | LEVEL_DEBUG DEBUG時に出力するレベルです。
static String | LEVEL_ERROR 例外を出力するレベルです。
static String | LEVEL_INFO 情報を出力するレベルです。
static String | LEVEL_WARNNING 警告を出力するレベルです。

フィールドの詳細

LEVEL_DEBUG

public static final String LEVEL_DEBUG
DEBUG時に出力するレベルです。

関連項目:
定数フィールド値

LEVEL_INFO

public static final String LEVEL_INFO
情報を出力するレベルです。

関連項目:
定数フィールド値

LEVEL_WARNNING

public static final String LEVEL_WARNNING
警告を出力するレベルです。

関連項目:
定数フィールド値

LEVEL_ERROR

public static final String LEVEL_ERROR
例外を出力するレベルです。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LogManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.LogManager
public class LogManager
extends Object

ログマネージャです。

導入されたバージョン:
4.2

フィールドの概要
static String LOG_PROPERTY_HANDLER_KEY
ログプロパティハンドラのキー
メソッドの概要
LogAgent | getLogAgent() ログエージェントを取得します。
static LogManager | getLogManager() ログマネージャを取得します。
LogPropertyHandler | getLogPropertyHandler() ログプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

LOG_PROPERTY_HANDLER_KEY

public static final String LOG_PROPERTY_HANDLER_KEY
ログプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getLogManager

public static LogManager getLogManager()
ログマネージャを取得します。

戻り値:
ログマネージャ

getLogPropertyHandler

public LogPropertyHandler getLogPropertyHandler()
ログプロパティハンドラを取得します。

戻り値:
ログプロパティハンドラ

getLogAgent

public LogAgent getLogAgent()
ログエージェントを取得します。

戻り値:
ログエージェント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LogPropertyException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス LogPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.log.LogPropertyException
すべての実装インタフェース:
Serializable
public class LogPropertyException
extends SystemException

ログプロパティ取得時の例外です。

導入されたバージョン:
4.2
関連項目:
直列化された形式

コンストラクタの概要
LogPropertyException()
詳細メッセージを指定しないで LogPropertyException を構築します。
LogPropertyException(String msg)
指定された詳細メッセージを持つ LogPropertyException を構築します。
LogPropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LogPropertyException

public LogPropertyException()
詳細メッセージを指定しないで LogPropertyException を構築します。

LogPropertyException

public LogPropertyException(String msg)
指定された詳細メッセージを持つ LogPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

LogPropertyException

public LogPropertyException(String msg,
                            Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


LogPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
インタフェース LogPropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultLogPropertyHandler, XmlLogPropertyHandler
public interface LogPropertyHandler
extends PropertyHandler

ログフレームワークで使用するプロパティハンドラです。

導入されたバージョン:
4.2

メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullを返すように実装する必要があります。

戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列を返すように実装する必要があります。

戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.system.log (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.system.log
インタフェース
LogAgent
LogConstant
LogPropertyHandler
クラス
DefaultLogAgent
DefaultLogPropertyHandler
IntramartLogAgent
LogAgentParam
LogManager
XmlLogPropertyHandler
例外
LogPropertyException


jp.co.intra_mart.framework.system.log (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.log

J2EEフレームワークのログに関連するパッケージです。

参照:
説明

インタフェースの概要
LogAgent | ログに出力するエージェントです。
LogConstant | ログフレームワークで使用される定数値です。
LogPropertyHandler | ログフレームワークで使用するプロパティハンドラです。

クラスの概要
DefaultLogAgent | デフォルトのログエージェントです。
DefaultLogPropertyHandler | ログに関連するデフォルトのプロパティハンドラです。
IntramartLogAgent | intra-mart で管理されているログに出力するログエージェントです。
LogAgentParam | ログエージェントの初期パラメータです。
LogManager | ログマネージャです。
XmlLogPropertyHandler | リソースからログプロパティ情報を取得するプロパティハンドラです。

例外の概要
LogPropertyException ログプロパティ取得時の例外です。

パッケージ jp.co.intra_mart.framework.system.log の説明

J2EEフレームワークのログに関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.system.log クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.log の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.log.DefaultLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.IntramartLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.LogManager
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.log.LogAgentParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.log.LogPropertyException
    • class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.system.log.LogAgent
  • interface jp.co.intra_mart.framework.system.log.LogConstant
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.system.log.LogPropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.system.log の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.log の使用

jp.co.intra_mart.framework.system.log を使用しているパッケージ
jp.co.intra_mart.framework.system.log J2EEフレームワークのログに関連するパッケージです。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.log のクラス
LogAgent
ログに出力するエージェントです。
LogAgentParam
ログエージェントの初期パラメータです。
LogManager
ログマネージャです。
LogPropertyException
ログプロパティ取得時の例外です。
LogPropertyHandler
ログフレームワークで使用するプロパティハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


XmlLogPropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.log
クラス XmlLogPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler
すべての実装インタフェース:
LogPropertyHandler, PropertyHandler
public class XmlLogPropertyHandler
extends Object
implements LogPropertyHandler

リソースからログプロパティ情報を取得するプロパティハンドラです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのXMLファイル名
static String | DEFAULT_BUNDLE_NAME_PARAM XMLファイル名のパラメータ名
コンストラクタの概要
XmlLogPropertyHandler()
XMLLogPropertyHandlerを新規に生成します。
メソッドの概要
String | getLogAgentName() ログエージェントのクラス名を取得します。
LogAgentParam[] | getLogAgentParams() ログエージェントのパラメータを取得します。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのXMLファイル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
XMLファイル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlLogPropertyHandler

public XmlLogPropertyHandler()
XMLLogPropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getLogAgentName

public String getLogAgentName()
                       throws LogPropertyException
ログエージェントのクラス名を取得します。 何も設定されていない場合nullが返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentName
戻り値:
ログエージェントのクラス名（設定されていない場合null）
例外:
LogPropertyException - ログエージェントのクラス名の取得時に例外が発生

getLogAgentParams

public LogAgentParam[] getLogAgentParams()
                                  throws LogPropertyException
ログエージェントのパラメータを取得します。 何も設定されていない場合大きさが0の配列が返ります。

定義:
インタフェース LogPropertyHandler 内の getLogAgentParams
戻り値:
ログエージェントのパラメータの配列
例外:
LogPropertyException - ログエージェントのパラメータの取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の使用

jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler の使用

jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.message.MessageManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessageManager の使用

MessageManager を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessageManager の使用

MessageManager を返す jp.co.intra_mart.framework.system.message のメソッド
static MessageManager MessageManager.getMessageManager()
MessageManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.message.MessageManagerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessageManagerException の使用

MessageManagerException を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessageManagerException の使用

MessageManagerException をスローする jp.co.intra_mart.framework.system.message のメソッド
static MessageManager MessageManager.getMessageManager()
MessageManagerを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.message.MessagePropertyException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessagePropertyException の使用

jp.co.intra_mart.framework.system.message.MessagePropertyException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.system.message.MessagePropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.message.MessagePropertyHandler の使用

MessagePropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message での MessagePropertyHandler の使用

MessagePropertyHandler を返す jp.co.intra_mart.framework.system.message のメソッド
 MessagePropertyHandler MessageManager.getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.message.MessagePropertyParam の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.message.MessagePropertyParam の使用

jp.co.intra_mart.framework.system.message.MessagePropertyParam はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultMessagePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス DefaultMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class DefaultMessagePropertyHandler
extends Object
implements MessagePropertyHandler

デフォルトのメッセージプロパティハンドラです。 プロパティの設定内容は以下のとおりです。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | DEFAULT_BUNDLE_NAME_PARAM リソースバンドル名のパラメータ名
コンストラクタの概要
DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 getMessage(String)を使用してください。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME_PARAM

public static final String DEFAULT_BUNDLE_NAME_PARAM
リソースバンドル名のパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultMessagePropertyHandler

public DefaultMessagePropertyHandler()
DefaultMessagePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。 プロパティの設定内容は以下のとおりです。
キー | 内容
ログイングループID.キー | ログイングループIDとキーに対応するメッセージ

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。 プロパティの設定内容は以下のとおりです。
キー | 内容
キー | キーに対応するメッセージ

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartMessagePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス IntramartMessagePropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler
すべての実装インタフェース:
MessagePropertyHandler, PropertyHandler
public class IntramartMessagePropertyHandler
extends Object
implements MessagePropertyHandler

イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。

バージョン:
1.0

コンストラクタの概要
IntramartMessagePropertyHandler()
IntramartMessagePropertyHandlerを新規に生成します。
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 パラメータloginGroupは実際には使用しません。getMessage(String)を使用してください。
void | init(PropertyParam[] params) プロパティハンドラを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartMessagePropertyHandler

public IntramartMessagePropertyHandler()
IntramartMessagePropertyHandlerを新規に生成します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

定義:
インタフェース PropertyHandler 内の init
パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

定義:
インタフェース MessagePropertyHandler 内の getMessage
パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessageManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessageManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.message.MessageManager
public class MessageManager
extends Object

メッセージを制御します。

バージョン:
1.0

フィールドの概要
static String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー
メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。getMessage(String)を使用してください。
static MessageManager | getMessageManager() MessageManagerを取得します。
MessagePropertyHandler | getMessagePropertyHandler() メッセージプロパティハンドラを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MESSAGE_PROPERTY_HANDLER_KEY

public static final String MESSAGE_PROPERTY_HANDLER_KEY
メッセージプロパティハンドラのキー

関連項目:
定数フィールド値
メソッドの詳細

getMessageManager

public static MessageManager getMessageManager()
                                        throws MessageManagerException
MessageManagerを取得します。

戻り値:
メッセージマネージャ
例外:
MessageManagerException - メッセージマネージャの取得時に例外が発生

getMessagePropertyHandler

public MessagePropertyHandler getMessagePropertyHandler()
メッセージプロパティハンドラを取得します。

戻り値:
メッセージプロパティハンドラ

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 キーがnullの場合、またはキーに該当するメッセージが存在しない場合、空文字列を返します。

パラメータ:
key - キー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 キーがnullの場合、またはキーに該当するメッセージが存在しない場合、空文字列を返します。

パラメータ:
key - キー
戻り値:
メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessageManagerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessageManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.message.MessageManagerException
すべての実装インタフェース:
Serializable
public class MessageManagerException
extends SystemException

メッセージマネージャに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessageManagerException

public MessageManagerException()
詳細メッセージを指定しないで MessageManagerException を構築します。

MessageManagerException

public MessageManagerException(String msg)
指定された詳細メッセージを持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

MessageManagerException

public MessageManagerException(String msg,
                               Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessagePropertyException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessagePropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.framework.system.message.MessagePropertyException
すべての実装インタフェース:
Serializable
public class MessagePropertyException
extends SystemException

メッセージプロパティハンドラに関連する例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MessagePropertyException

public MessagePropertyException()
詳細メッセージを指定しないで MessagePropertyException を構築します。

MessagePropertyException

public MessagePropertyException(String msg)
指定された詳細メッセージを持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ

MessagePropertyException

public MessagePropertyException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessagePropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
インタフェース MessagePropertyHandler

すべてのスーパーインタフェース:
PropertyHandler
既知の実装クラスの一覧:
DefaultMessagePropertyHandler, IntramartMessagePropertyHandler
public interface MessagePropertyHandler
extends PropertyHandler

メッセージに関連するプロパティを取得します。

バージョン:
1.0

メソッドの概要
String | getMessage(String key) キーに該当するメッセージを取得します。
String | getMessage(String key, String loginGroup) 推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。 getMessage(String)を使用してください。
インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler から継承したメソッド
init

メソッドの詳細

getMessage

public String getMessage(String key,
                         String loginGroup)
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
getMessage(String)を使用してください。

キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

パラメータ:
key - メッセージのキー
loginGroup - ログイングループ
戻り値:
メッセージ

getMessage

public String getMessage(String key)
キーに該当するメッセージを取得します。 該当するキーが存在しない場合、空文字列を返します。

パラメータ:
key - メッセージのキー
戻り値:
メッセージ
導入されたバージョン:
5.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MessagePropertyParam (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.message
クラス MessagePropertyParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.message.MessagePropertyParam
public class MessagePropertyParam
extends PropertyParam

メッセージプロパティハンドラの初期パラメータです。

バージョン:
1.0

コンストラクタの概要
MessagePropertyParam()
MessagePropertyParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MessagePropertyParam

public MessagePropertyParam()
MessagePropertyParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.system.message (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.system.message
インタフェース
MessagePropertyHandler
クラス
DefaultMessagePropertyHandler
IntramartMessagePropertyHandler
MessageManager
MessagePropertyParam
例外
MessageManagerException
MessagePropertyException


jp.co.intra_mart.framework.system.message (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.message

メッセージに関連するパッケージです。

参照:
説明

インタフェースの概要
MessagePropertyHandler メッセージに関連するプロパティを取得します。

クラスの概要
DefaultMessagePropertyHandler | デフォルトのメッセージプロパティハンドラです。
IntramartMessagePropertyHandler | イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。
MessageManager | メッセージを制御します。
MessagePropertyParam | メッセージプロパティハンドラの初期パラメータです。

例外の概要
MessageManagerException | メッセージマネージャに関連する例外です。
MessagePropertyException | メッセージプロパティハンドラに関連する例外です。

パッケージ jp.co.intra_mart.framework.system.message の説明

メッセージに関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.system.message クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.MessageManager
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.message.MessagePropertyParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.system.message.MessageManagerException
            • class jp.co.intra_mart.framework.system.message.MessagePropertyException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.system.message の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.message の使用

jp.co.intra_mart.framework.system.message を使用しているパッケージ
jp.co.intra_mart.framework.system.message メッセージに関連するパッケージです。

jp.co.intra_mart.framework.system.message により使用される jp.co.intra_mart.framework.system.message のクラス
MessageManager
メッセージを制御します。
MessageManagerException
メッセージマネージャに関連する例外です。
MessagePropertyHandler
メッセージに関連するプロパティを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.DefaultPropertyManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.DefaultPropertyManager の使用

jp.co.intra_mart.framework.system.property.DefaultPropertyManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.PropertyConfigModel の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyConfigModel の使用

jp.co.intra_mart.framework.system.property.PropertyConfigModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.framework.system.property.PropertyHandler の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.framework.system.property.PropertyHandler の使用

PropertyHandler を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyHandler の使用

jp.co.intra_mart.framework.base.data での PropertyHandler のサブインタフェース
 interface DataPropertyHandler
DAOの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.data のクラス
class | DefaultDataPropertyHandler デフォルトのデータプロパティハンドラです。
class | DistributesDataPropertyHandler アプリケーション毎のプロパティハンドラを呼び出します。
class | TextFileDataPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlDataPropertyHandler XMLのデータプロパティハンドラです。

jp.co.intra_mart.framework.base.event での PropertyHandler の使用

jp.co.intra_mart.framework.base.event での PropertyHandler のサブインタフェース
 interface EventPropertyHandler
イベントの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.event のクラス
class | DefaultEventPropertyHandler デフォルトのEventPropertyHandlerです。
class | DistributesEventPropertyHandler アプリケーション毎のEventPropertyHandlerを呼び出します。
class | TextFileEventPropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlEventPropertyHandler XMLのEventPropertyHandlerです。

jp.co.intra_mart.framework.base.message での PropertyHandler の使用

jp.co.intra_mart.framework.base.message での PropertyHandler のサブインタフェース
 interface MessagePropertyHandler
メッセージの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.message のクラス
class | DefaultMessagePropertyHandler メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
class | TextFileMessagePropertyHandler 指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。

jp.co.intra_mart.framework.base.service での PropertyHandler の使用

jp.co.intra_mart.framework.base.service での PropertyHandler のサブインタフェース
 interface ServicePropertyHandler
サービスの設定情報に接続するクラスです。

PropertyHandler を実装している jp.co.intra_mart.framework.base.service のクラス
class | DefaultServicePropertyHandler サービスの設定情報に接続するデフォルトのプロパティハンドラです。
class | DistributesServicePropertyHandler アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
class | TextFileServicePropertyHandler 指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
class | XmlServicePropertyHandler サービスの設定情報に接続するプロパティハンドラです。

jp.co.intra_mart.framework.base.session での PropertyHandler の使用

jp.co.intra_mart.framework.base.session での PropertyHandler のサブインタフェース
 interface SessionPropertyHandler
セッションに関連するプロパティを取得します。

PropertyHandler を実装している jp.co.intra_mart.framework.base.session のクラス
class | DefaultSessionPropertyHandler セッションに関連するデフォルトのプロパティハンドラです。
class | XmlSessionPropertyHandler セッションに関連するXMLのプロパティハンドラです。

jp.co.intra_mart.framework.presentation での PropertyHandler の使用

jp.co.intra_mart.framework.presentation での PropertyHandler のサブインタフェース
 interface PresentationPropertyHandler
プレゼンテーションフレームワークのプロパティ設定のハンドラです。

jp.co.intra_mart.framework.system.log での PropertyHandler の使用

jp.co.intra_mart.framework.system.log での PropertyHandler のサブインタフェース
 interface LogPropertyHandler
ログフレームワークで使用するプロパティハンドラです。

PropertyHandler を実装している jp.co.intra_mart.framework.system.log のクラス
class | DefaultLogPropertyHandler ログに関連するデフォルトのプロパティハンドラです。
class | XmlLogPropertyHandler リソースからログプロパティ情報を取得するプロパティハンドラです。

jp.co.intra_mart.framework.system.message での PropertyHandler の使用

PropertyHandler を実装している jp.co.intra_mart.framework.system.message のクラス
 class IntramartMessagePropertyHandler
イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。

jp.co.intra_mart.framework.system.property での PropertyHandler の使用

PropertyHandler を返す jp.co.intra_mart.framework.system.property のメソッド
 PropertyHandler PropertyManager.getPropertyHandler(String key)
キーで指定されたプロパティハンドラを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.PropertyHandlerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyHandlerException の使用

PropertyHandlerException を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.data のメソッド
void | XmlDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.event での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.event のメソッド
void | XmlEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.message での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.message のメソッド
void | TextFileMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.service での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.service のメソッド
void | XmlServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.session での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.base.session のメソッド
void | XmlSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.log での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.log のメソッド
void | XmlLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.message での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.message のメソッド
void | IntramartMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.property での PropertyHandlerException の使用

PropertyHandlerException をスローする jp.co.intra_mart.framework.system.property のメソッド
protected String | XmlPropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected abstract String | PropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
PropertyHandler | PropertyManager.getPropertyHandler(String key) キーで指定されたプロパティハンドラを取得します。
void | PropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
protected String | DefaultPropertyManager.getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.PropertyHandlerParam の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyHandlerParam の使用

PropertyHandlerParam を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyHandlerParam の使用

PropertyHandlerParam を返す jp.co.intra_mart.framework.system.property のメソッド
protected PropertyHandlerParam[] | XmlPropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
protected abstract PropertyHandlerParam[] | PropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
protected PropertyHandlerParam[] | PropertyConfigModel.getPropertyParams(String key) 指定されたキーのプロパティのパラメータを取得します。
protected PropertyHandlerParam[] | DefaultPropertyManager.getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.PropertyManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyManager の使用

PropertyManager を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyManager の使用

jp.co.intra_mart.framework.system.property での PropertyManager のサブクラス
class | DefaultPropertyManager デフォルトのプロパティマネージャです。
class | XmlPropertyManager xmlのプロパティマネージャです。

PropertyManager を返す jp.co.intra_mart.framework.system.property のメソッド
static PropertyManager PropertyManager.getPropertyManager()
プロパティマネージャを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.PropertyManagerException の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyManagerException の使用

PropertyManagerException を使用しているパッケージ
jp.co.intra_mart.framework.system.property プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.system.property での PropertyManagerException の使用

PropertyManagerException をスローする jp.co.intra_mart.framework.system.property のメソッド
static PropertyManager PropertyManager.getPropertyManager()
プロパティマネージャを取得します。

PropertyManagerException をスローする jp.co.intra_mart.framework.system.property のコンストラクタ
XmlPropertyManager()
コンストラクタです。
DefaultPropertyManager()
コンストラクタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.PropertyModel の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyModel の使用

jp.co.intra_mart.framework.system.property.PropertyModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.PropertyParam の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.PropertyParam の使用

PropertyParam を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data での PropertyParam の使用

jp.co.intra_mart.framework.base.data での PropertyParam のサブクラス
 class ResourceParam
データコネクタの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.data のメソッド
void | XmlDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultDataPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.event での PropertyParam の使用

jp.co.intra_mart.framework.base.event での PropertyParam のサブクラス
 class EventListenerFactoryParam
イベントリスナファクトリの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.event のメソッド
void | XmlEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultEventPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.message での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.message のメソッド
void | TextFileMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.service での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.service のメソッド
void | XmlServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | TextFileServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DistributesServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultServicePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.session での PropertyParam の使用

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.base.session のメソッド
void | XmlSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultSessionPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.base.web.tag での PropertyParam の使用

jp.co.intra_mart.framework.base.web.tag での PropertyParam のサブクラス
 class FrameworkTagParam
タグに追加されるパラメータです。

jp.co.intra_mart.framework.system.log での PropertyParam の使用

jp.co.intra_mart.framework.system.log での PropertyParam のサブクラス
 class LogAgentParam
ログエージェントの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.log のメソッド
void | XmlLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultLogPropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.message での PropertyParam の使用

jp.co.intra_mart.framework.system.message での PropertyParam のサブクラス
 class MessagePropertyParam
メッセージプロパティハンドラの初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.message のメソッド
void | IntramartMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。
void | DefaultMessagePropertyHandler.init(PropertyParam[] params) プロパティハンドラを初期化します。

jp.co.intra_mart.framework.system.property での PropertyParam の使用

jp.co.intra_mart.framework.system.property での PropertyParam のサブクラス
 class PropertyHandlerParam
プロパティハンドラを生成する時の初期パラメータです。

PropertyParam 型のパラメータを持つ jp.co.intra_mart.framework.system.property のメソッド
 void PropertyHandler.init(PropertyParam[] params)
プロパティハンドラを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.system.property.XmlPropertyManager の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.system.property.XmlPropertyManager の使用

jp.co.intra_mart.framework.system.property.XmlPropertyManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


DefaultPropertyManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス DefaultPropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
        拡張 jp.co.intra_mart.framework.system.property.DefaultPropertyManager
public class DefaultPropertyManager
extends PropertyManager

デフォルトのプロパティマネージャです。 リソースバンドルで設定されたプロパティ情報を管理します。 プロパティ情報のリソースバンドルは以下の順番で決定されます。

 1.システムプロパティKEYで設定されているリソースバンドル
 2.デフォルトのプロパティマネージャDEFAULT_BUNDLE_NAMEで設定されているリソースバンドル

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | KEY プロパティマネージャを指定するキー
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したフィールド
DEFAULT_SYSTEM_MANAGER
コンストラクタの概要
DefaultPropertyManager()
コンストラクタです。
メソッドの概要
protected String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したメソッド
getPropertyHandler, getPropertyManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値
コンストラクタの詳細

DefaultPropertyManager

public DefaultPropertyManager()
                       throws PropertyManagerException
コンストラクタです。

例外:
PropertyManagerException - プロパティマネージャの設定に失敗
メソッドの詳細

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
                                 throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

定義:
クラス PropertyManager 内の getPropertyHandlerName
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - クラス名の取得に失敗

getPropertyHandlerParams

protected PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

定義:
クラス PropertyManager 内の getPropertyHandlerParams
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.system.property (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 jp.co.intra_mart.framework.system.property
インタフェース
PropertyHandler
クラス
DefaultPropertyManager
PropertyConfigModel
PropertyHandlerParam
PropertyManager
PropertyModel
PropertyParam
XmlPropertyManager
例外
PropertyHandlerException
PropertyManagerException


jp.co.intra_mart.framework.system.property (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.property

プロパティ取得に関連するパッケージです。

参照:
説明

インタフェースの概要
PropertyHandler プロパティにアクセスするインタフェースです。

クラスの概要
DefaultPropertyManager | デフォルトのプロパティマネージャです。
PropertyConfigModel | データモデルクラスです。
PropertyHandlerParam | プロパティハンドラを生成する時の初期パラメータです。
PropertyManager | システム設定の情報を管理します。
PropertyModel | プロパティモデルクラスです。
PropertyParam | プロパティのパラメータを表現する汎用的なクラスです。
XmlPropertyManager | xmlのプロパティマネージャです。

例外の概要
PropertyHandlerException | プロパティハンドラの情報取得時の例外です。
PropertyManagerException | プロパティマネージャの設定時の例外です。

パッケージ jp.co.intra_mart.framework.system.property の説明

プロパティ取得に関連するパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のパッケージ 次のパッケージ フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.system.property クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.system.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.system.property.PropertyConfigModel
    • class jp.co.intra_mart.framework.system.property.PropertyManager
      • class jp.co.intra_mart.framework.system.property.DefaultPropertyManager
      • class jp.co.intra_mart.framework.system.property.XmlPropertyManager
    • class jp.co.intra_mart.framework.system.property.PropertyModel
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.system.property.PropertyHandlerParam
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.property.PropertyHandlerException
          • class jp.co.intra_mart.framework.system.property.PropertyManagerException

インタフェース階層

  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.system.property の使用 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.system.property の使用

jp.co.intra_mart.framework.system.property を使用しているパッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

jp.co.intra_mart.framework.base.data により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.event により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.message により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.service により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.session により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.base.web.tag により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.presentation により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。

jp.co.intra_mart.framework.system.log により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.message により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

jp.co.intra_mart.framework.system.property により使用される jp.co.intra_mart.framework.system.property のクラス
PropertyHandler
プロパティにアクセスするインタフェースです。
PropertyHandlerException
プロパティハンドラの情報取得時の例外です。
PropertyHandlerParam
プロパティハンドラを生成する時の初期パラメータです。
PropertyManager
システム設定の情報を管理します。
PropertyManagerException
プロパティマネージャの設定時の例外です。
PropertyParam
プロパティのパラメータを表現する汎用的なクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PropertyConfigModel (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyConfigModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyConfigModel
public class PropertyConfigModel
extends Object

データモデルクラスです。

バージョン:
1.0

コンストラクタの概要
PropertyConfigModel()
メソッドの概要
protected String | getPropertyHandlerName(String key) 指定されたキーのプロパティハンドラ名を取得します。
protected PropertyHandlerParam[] | getPropertyParams(String key) 指定されたキーのプロパティのパラメータを取得します。
protected void | setProperties(Map map) パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyConfigModel

public PropertyConfigModel()
メソッドの詳細

setProperties

protected void setProperties(Map map)
パラメータを設定します。

パラメータ:
map -

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
指定されたキーのプロパティハンドラ名を取得します。

戻り値:
String

getPropertyParams

protected PropertyHandlerParam[] getPropertyParams(String key)
指定されたキーのプロパティのパラメータを取得します。

戻り値:
PropertyParam[]
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PropertyHandler (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
インタフェース PropertyHandler

既知のサブインタフェースの一覧:
DataPropertyHandler, EventPropertyHandler, LogPropertyHandler, MessagePropertyHandler, MessagePropertyHandler, PresentationPropertyHandler, ServicePropertyHandler, SessionPropertyHandler
既知の実装クラスの一覧:
DefaultDataPropertyHandler, DefaultEventPropertyHandler, DefaultLogPropertyHandler, DefaultMessagePropertyHandler, DefaultMessagePropertyHandler, DefaultServicePropertyHandler, DefaultSessionPropertyHandler, DistributesDataPropertyHandler, DistributesEventPropertyHandler, DistributesServicePropertyHandler, IntramartMessagePropertyHandler, TextFileDataPropertyHandler, TextFileEventPropertyHandler, TextFileMessagePropertyHandler, TextFileServicePropertyHandler, XmlDataPropertyHandler, XmlEventPropertyHandler, XmlLogPropertyHandler, XmlServicePropertyHandler, XmlSessionPropertyHandler
public interface PropertyHandler

プロパティにアクセスするインタフェースです。 このインタフェースを実装するすべてのクラスは、引数なしのコンストラクタが必要です。

バージョン:
1.0

メソッドの概要
 void init(PropertyParam[] params)
プロパティハンドラを初期化します。

メソッドの詳細

init

public void init(PropertyParam[] params)
          throws PropertyHandlerException
プロパティハンドラを初期化します。

パラメータ:
params - 初期パラメータ
例外:
PropertyHandlerException - プロパティハンドラの初期化時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PropertyHandlerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyHandlerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.property.PropertyHandlerException
すべての実装インタフェース:
Serializable
public class PropertyHandlerException
extends FrameworkException

プロパティハンドラの情報取得時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PropertyHandlerException()
詳細メッセージを指定しないで PropertyHandlerException を構築します。
PropertyHandlerException(String msg)
指定された詳細メッセージを持つ PropertyHandlerException を構築します。
PropertyHandlerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertyHandlerException

public PropertyHandlerException()
詳細メッセージを指定しないで PropertyHandlerException を構築します。

PropertyHandlerException

public PropertyHandlerException(String msg)
指定された詳細メッセージを持つ PropertyHandlerException を構築します。

パラメータ:
msg - 詳細メッセージ

PropertyHandlerException

public PropertyHandlerException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PropertyHandlerParam (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyHandlerParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
        拡張 jp.co.intra_mart.framework.system.property.PropertyHandlerParam
public class PropertyHandlerParam
extends PropertyParam

プロパティハンドラを生成する時の初期パラメータです。

バージョン:
1.0

コンストラクタの概要
PropertyHandlerParam()
PropertyHandlerParamを新規に生成します。
クラス jp.co.intra_mart.framework.system.property.PropertyParam から継承したメソッド
getName, getValue, setName, setValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyHandlerParam

public PropertyHandlerParam()
PropertyHandlerParamを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PropertyManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
直系の既知のサブクラス:
DefaultPropertyManager, XmlPropertyManager
public abstract class PropertyManager
extends Object

システム設定の情報を管理します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_SYSTEM_MANAGER デフォルトのプロパティマネージャクラス
static String | KEY プロパティマネージャを指定するキー
コンストラクタの概要
protected PropertyManager()
プロパティマネージャのコンストラクタです。
メソッドの概要
PropertyHandler | getPropertyHandler(String key) キーで指定されたプロパティハンドラを取得します。
protected abstract String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected abstract PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
static PropertyManager | getPropertyManager() プロパティマネージャを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_SYSTEM_MANAGER

public static final String DEFAULT_SYSTEM_MANAGER
デフォルトのプロパティマネージャクラス

関連項目:
定数フィールド値
コンストラクタの詳細

PropertyManager

protected PropertyManager()
プロパティマネージャのコンストラクタです。 コンストラクタの明示的な使用はできません。

メソッドの詳細

getPropertyManager

public static PropertyManager getPropertyManager()
                                          throws PropertyManagerException
プロパティマネージャを取得します。 プロパティマネージャは常に１つだけ存在します。 プロパティマネージャが未設定の状態でこのメソッドが呼ばれた場合、以下の順番でプロパティマネージャを取得します。
 1.システムプロパティKEYで設定されているプロパティマネージャ
 2.デフォルトのプロパティマネージャ

戻り値:
プロパティマネージャ
例外:
PropertyManagerException - プロパティマネージャの設定時に発生する例外

getPropertyHandlerName

protected abstract String getPropertyHandlerName(String key)
                                          throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - プロパティハンドラのクラス名を取得できなかった場合に発生する例外

getPropertyHandlerParams

protected abstract PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ

getPropertyHandler

public PropertyHandler getPropertyHandler(String key)
                                   throws PropertyHandlerException
キーで指定されたプロパティハンドラを取得します。

パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラ
例外:
PropertyHandlerException - プロパティハンドラの取得に失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PropertyManagerException (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.property.PropertyManagerException
すべての実装インタフェース:
Serializable
public class PropertyManagerException
extends FrameworkException

プロパティマネージャの設定時の例外です。

バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PropertyManagerException()
詳細メッセージを指定しないで PropertyManagerException を構築します。
PropertyManagerException(String msg)
指定された詳細メッセージを持つ PropertyManagerException を構築します。
PropertyManagerException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertyManagerException

public PropertyManagerException()
詳細メッセージを指定しないで PropertyManagerException を構築します。

PropertyManagerException

public PropertyManagerException(String msg)
指定された詳細メッセージを持つ PropertyManagerException を構築します。

パラメータ:
msg - 詳細メッセージ

PropertyManagerException

public PropertyManagerException(String msg,
                                Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PropertyModel (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyModel

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyModel
public class PropertyModel
extends Object

プロパティモデルクラスです。

バージョン:
1.0

コンストラクタの概要
PropertyModel()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyModel

public PropertyModel()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


PropertyParam (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス PropertyParam

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyParam
直系の既知のサブクラス:
EventListenerFactoryParam, FrameworkTagParam, LogAgentParam, MessagePropertyParam, PropertyHandlerParam, ResourceParam
public class PropertyParam
extends Object

プロパティのパラメータを表現する汎用的なクラスです。 このクラスのインスタンス１つがパラメータ名とパラメータの値という１つのペアに対応します。

バージョン:
1.0

コンストラクタの概要
PropertyParam()
PropertyParamを新規に生成します。
メソッドの概要
String | getName() パラメータ名を取得します。
String | getValue() パラメータの値を取得します。
void | setName(String name) パラメータ名を設定します。
void | setValue(String value) パラメータの値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PropertyParam

public PropertyParam()
PropertyParamを新規に生成します。

メソッドの詳細

setName

public void setName(String name)
パラメータ名を設定します。

パラメータ:
name - パラメータ名

getName

public String getName()
パラメータ名を取得します。

戻り値:
パラメータ名

setValue

public void setValue(String value)
パラメータの値を設定します。

パラメータ:
value - パラメータの値

getValue

public String getValue()
パラメータの値を取得します。

戻り値:
パラメータの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


XmlPropertyManager (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.system.property
クラス XmlPropertyManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.system.property.PropertyManager
        拡張 jp.co.intra_mart.framework.system.property.XmlPropertyManager
public class XmlPropertyManager
extends PropertyManager

xmlのプロパティマネージャです。 プロパティ情報を管理します。

バージョン:
1.0

フィールドの概要
static String | DEFAULT_BUNDLE_NAME デフォルトのリソースバンドル名
static String | KEY プロパティマネージャを指定するキー
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したフィールド
DEFAULT_SYSTEM_MANAGER
コンストラクタの概要
XmlPropertyManager()
コンストラクタです。
メソッドの概要
protected String | getPropertyHandlerName(String key) キーで指定されたプロパティハンドラのクラス名を取得します。
protected PropertyHandlerParam[] | getPropertyHandlerParams(String key) キーで指定されたプロパティハンドラの初期化データを取得します。
クラス jp.co.intra_mart.framework.system.property.PropertyManager から継承したメソッド
getPropertyHandler, getPropertyManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

KEY

public static final String KEY
プロパティマネージャを指定するキー

関連項目:
定数フィールド値

DEFAULT_BUNDLE_NAME

public static final String DEFAULT_BUNDLE_NAME
デフォルトのリソースバンドル名

関連項目:
定数フィールド値
コンストラクタの詳細

XmlPropertyManager

public XmlPropertyManager()
                   throws PropertyManagerException
コンストラクタです。

例外:
PropertyManagerException - プロパティマネージャの設定に失敗
メソッドの詳細

getPropertyHandlerName

protected String getPropertyHandlerName(String key)
                                 throws PropertyHandlerException
キーで指定されたプロパティハンドラのクラス名を取得します。

定義:
クラス PropertyManager 内の getPropertyHandlerName
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラのクラス名
例外:
PropertyHandlerException - クラス名の取得に失敗

getPropertyHandlerParams

protected PropertyHandlerParam[] getPropertyHandlerParams(String key)
キーで指定されたプロパティハンドラの初期化データを取得します。 初期化データが存在しない場合、nullが返ります。

定義:
クラス PropertyManager 内の getPropertyHandlerParams
パラメータ:
key - プロパティハンドラのキー
戻り値:
プロパティハンドラの初期化データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


すべてのクラス (intra-mart im-J2EE Framework 5.0 API ドキュメント)

 すべてのクラス
AbstractViewConverter
ApplicationException
BadRequestException
ConfigurationUserInfo
ConnectorModel
ControllerConverter
ControllerConverterConfig
ControllerConverterException
ControllerObject
CoreAttributes
DAO
DAOAdapter
DAOException
DBConnector
DBDAO
DaoModel
DataAccessController
DataAccessException
DataConnectException
DataConnector
DataConnectorException
DataManager
DataManagerException
DataPropertyException
DataPropertyHandler
DataSourceConnector
DefaultDataPropertyHandler
DefaultEventPropertyHandler
DefaultLogAgent
DefaultLogPropertyHandler
DefaultMessagePropertyHandler
DefaultMessagePropertyHandler
DefaultPropertyManager
DefaultServicePropertyHandler
DefaultSessionPropertyHandler
DefaultTransition
DistributesDataPropertyHandler
DistributesEventPropertyHandler
DistributesServicePropertyHandler
DuplicateException
EJBEventListener
EJBEventListenerAgentBean
EJBEventListenerFactory
EmptyEvent
EmptyUserInfo
EncodingFilter
ErrorHelperBean
Event
EventException
EventFactoryModel
EventGroupModel
EventListener
EventListenerException
EventListenerFactory
EventListenerFactoryParam
EventManager
EventManagerException
EventModelProducer
EventPropertyException
EventPropertyHandler
EventResult
EventTrigger
EventTriggerAdapter
EventTriggerException
EventTriggerInfo
EventTriggerList
EventsAttributes
FileUploadFilter
FormTEI
FormTag
FormTagBeanInfo
FormatValidator
ForwardSelector
ForwardSelectorConfig
ForwardSelectorException
FrameTEI
FrameTag
FrameTagBeanInfo
FrameworkException
FrameworkParameterSettingFilter
FrameworkTagException
FrameworkTagParam
GenericAttributes
GenericEJBEventListener
GenericEJBEventListenerAgent
GenericEJBEventListenerAgentBean
GenericEJBEventListenerAgentHome
GenericEJBEventListenerAgentLocal
GenericEJBEventListenerAgentLocalHome
GenericEJBEventListenerFactory
GenericEJBEventListenerLocal
GenericEJBEventListenerLocalFactory
GenericEventListener
GenericEventListenerFactory
HTMLEncoder
HelperBean
HelperBeanException
HelperBeanTEI
HelperBeanTag
HelperBeanTagBeanInfo
HttpSessionFactory
HttpSessionObject
I18nAttributes
IllegalSessionException
IllegalSystemException
IntramartConnectFilter
IntramartConnectServlet
IntramartDBConnector
IntramartDBDAO
IntramartFileServerConnector
IntramartFileServerDAO
IntramartLocaleFilter
IntramartLogAgent
IntramartMessagePropertyHandler
IntramartPageBaseTransition
IntramartSessionFactory
IntramartSessionObject
JDBCConnector
LengthValidator
LinkTEI
LinkTag
LinkTagBeanInfo
LocaleFilter
LogAgent
LogAgentParam
LogConstant
LogManager
LogPropertyException
LogPropertyHandler
LoginGroupDBConnector
LoginGroupDBDAO
MessageManager
MessageManager
MessageManagerException
MessageManagerException
MessageParamTag
MessagePropertyException
MessagePropertyException
MessagePropertyHandler
MessagePropertyHandler
MessagePropertyParam
MessageTEI
MessageTag
MismatchException
MultiSelectableItem
NameFormatException
NumericRangeValidator
NumericValidator
Option
PanelBasedViewObject
ParamTag
ParameterSendable
PresentationConnectFilter
PresentationManager
PresentationManagerException
PresentationPropertyException
PresentationPropertyHandler
PresentationServiceController
PresentationServlet
PropertyConfigModel
PropertyHandler
PropertyHandlerException
PropertyHandlerParam
PropertyManager
PropertyManagerException
PropertyModel
PropertyParam
RequestException
RequestFormatException
RequestInfo
ResourceModel
ResourceParam
SelectableItem
ServiceController
ServiceControllerAdapter
ServiceControllerException
ServiceManager
ServiceManagerException
ServicePropertyException
ServicePropertyHandler
ServiceResult
ServiceSecurityFilter
ServiceServlet
ServiceServletException
SessionFactory
SessionFactoryException
SessionFilter
SessionManager
SessionManagerException
SessionObject
SessionObjectException
SessionPropertyException
SessionPropertyHandler
SimpleControllerConverter
SimplePanelBasedViewObject
SimpleViewObject
SingleSelectableItem
StandardEJBEventListener
StandardEJBEventListenerAgent
StandardEJBEventListenerAgentBean
StandardEJBEventListenerAgentHome
StandardEJBEventListenerFactory
StandardEventListener
StandardEventListenerFactory
SubmitLinkTag
SubmitLinkTagBeanInfo
SubmitTEI
SubmitTag
SubmitTagBeanInfo
SystemDBConnector
SystemDBDAO
SystemException
TagWriter
TextFileDataPropertyHandler
TextFileEventPropertyHandler
TextFileMessagePropertyHandler
TextFileServicePropertyHandler
TokenInvalidException
Transition
TransitionException
UserInfo
UserInfoException
UserInfoUtil
ValidationException
ValidationExceptionDetail
Validator
ValidatorConfig
ValidatorException
ViewConverter
ViewConverterConfig
ViewConverterException
ViewObject
XmlDataPropertyHandler
XmlEventPropertyHandler
XmlLogPropertyHandler
XmlPropertyManager
XmlServicePropertyHandler
XmlSessionPropertyHandler


定数フィールド値 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.framework.base.data.ConnectorModel
public static final String | ID | "connector"
public static final String | P_ID_CONNECTOR_CLASS | "connector-class"
public static final String | P_ID_CONNECTOR_NAME | "connector-name"
public static final String | P_ID_RESOURCE_NAME | "resource-name"

jp.co.intra_mart.framework.base.data.DaoModel
public static final String | ID | "dao"
public static final String | P_ID_CONNECT_NAME | "connect-name"
public static final String | P_ID_DAO_CLASS | "dao-class"
public static final String | P_ID_DAO_CONNECTOR_NAME | "connector-name"

jp.co.intra_mart.framework.base.data.DataManager
public static final String DATA_PROPERTY_HANDLER_KEY "data"

jp.co.intra_mart.framework.base.data.DataSourceConnector
public static final String KEY_JNDI_NAME "jndi"

jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "DataConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "DataConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.data.JDBCConnector
public static final String | KEY_DRIVER | "driver"
public static final String | KEY_PASSWORD | "password"
public static final String | KEY_URL | "url"
public static final String | KEY_USERNAME | "username"

jp.co.intra_mart.framework.base.data.ResourceModel
public static final String | ID | "resource"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"
public static final String | P_ID_RESOURCE_NAME | "resource-name"
public static final String | P_ID_RESOURCE_PARAM | "init-param"

jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "data-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "EventConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "EventConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.event.EJBEventListenerFactory
public static final String HOME_PARAM "home"

jp.co.intra_mart.framework.base.event.EventFactoryModel
public static final String | ID | "event-factory"
public static final String | P_ID_FACTORY_CLASS | "factory-class"
public static final String | P_ID_FACTORY_PARAM | "init-param"
public static final String | P_ID_PARAM_NAME | "param-name"
public static final String | P_ID_PARAM_VALUE | "param-value"

jp.co.intra_mart.framework.base.event.EventGroupModel
public static final String | ID | "event-group"
public static final String | P_ID_EVENT_KEY | "event-key"
public static final String | P_ID_EVENT_NAME | "event-class"
public static final String | P_ID_POST_TRIGGER | "post-trigger"
public static final String | P_ID_PRE_TRIGGER | "pre-trigger"
public static final String | P_ID_TRIGGER_CLASS | "trigger-class"

jp.co.intra_mart.framework.base.event.EventManager
public static final String EVENT_PROPERTY_HANDLER_KEY "event"

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
public static final String LISTENER_PARAM "listener"

jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
public static final String LISTENER_PARAM "listener"

jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "event-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "MessageConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.message.MessageManager
public static final String MESSAGE_PROPERTY_HANDLER_KEY "i18n_message"

jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "ServiceConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "ServiceConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_APPLICATION | "application"
public static final String | PARAM_APPLICATION_CLASS | "class"
public static final String | PARAM_APPLICATION_PARAM | "param"
public static final String | PARAM_BUNDLE | "bundle"
public static final String | PARAM_DEFAULT | "default"
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.IntramartConnectFilter
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_ARGUMENT_DELIMITER | ","
public static final String | PARAM_ARGUMENT_OPERATOR | "="
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"
public static final String | PARAM_SECURITY_EXT | "securityExt"

jp.co.intra_mart.framework.base.service.IntramartConnectServlet
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_ARGUMENT_DELIMITER | ","
public static final String | PARAM_ARGUMENT_OPERATOR | "="
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"

jp.co.intra_mart.framework.base.service.ServiceManager
public static final String | DEFAULT_SERVICE_EXTENSION | "service"
public static final String | SERVICE_EXTENSION_KEY | "jp.co.intra_mart.framework.base.service.ServiceManager.extesion"
public static final String | SERVICE_PROPERTY_HANDLER_KEY | "service"

jp.co.intra_mart.framework.base.service.ServicePropertyHandler
public static final String | DEFAULT_APPLICATION_PARAMETER | "application"
public static final String | DEFAULT_ENCODING_ATTRIBUTE | "jp.co.intra_mart.framework.base.service.encoding"
public static final String | DEFAULT_EXCEPTION_ATTRIBUTE | "exception"
public static final String | DEFAULT_LOCALE_ATTRIBUTE | "jp.co.intra_mart.framework.base.service.locale"
public static final String | DEFAULT_SERVICE_PARAMETER | "service"

jp.co.intra_mart.framework.base.service.ServiceSecurityFilter
public static final String | ID_SERVICE_SECURITY_FILTER | "jp.co.intra_mart.framework.base.service.ServiceSecurityFilter"
public static final String | PARAM_ERROR_PAGE | "error-page"

jp.co.intra_mart.framework.base.service.ServiceServlet
public static final String REQUEST_SEPARATOR "-"

jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler
public static final String | PARAM_DYNAMIC | "dynamic"
public static final String | PARAM_FILE_DIR | "file_dir"

jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "service-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"
public static final String | PARAM_DYNAMIC | "dynamic"

jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "SessionConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.session.SessionManager
public static final String SESSION_PROPERTY_HANDLER_KEY "session"

jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "session-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.base.util.UserInfoUtil
public static final String | LT_GROUP | "group"
public static final String | LT_SUPER | "super"
public static final String | LT_USER | "user"

jp.co.intra_mart.framework.presentation.PresentationConnectFilter
public static final String | INTRAMART_URL_NAME | "jp.co.intra_mart.framework.base.service.IntramartConnectServlet.intramart"
public static final String | LICENSE_PATH | "license/presentation-framework/filter"
public static final String | PARAM_ARGUMENT | "argument"
public static final String | PARAM_LOGIN_GROUP_ID | "group"
public static final String | PARAM_LOGIN_USER_ID | "account"
public static final String | PARAM_REFERER | "referrer"
public static final String | PARAM_WINDOW_NAME | "IM_MAIN"

jp.co.intra_mart.framework.presentation.PresentationManager
public static final String | CONFIG | "jp.co.intra_mart.framework.presentation.manager"
public static final String | MANAGER_CLASS_KEY | "manager"

jp.co.intra_mart.framework.presentation.PresentationServlet
public static final String | ACTION_ID | "action"
public static final String | LICENSE_PATH | "license/presentation-framework/filter"
public static final String | PREFIX_ATTRIBUTE | "jp.co.intra_mart.framework.presentation.PresentationServlet.prefix"
public static final String | REQUEST_INFO_ATTRIBUTE | "jp.co.intra_mart.framework.presentation.PresentationServlet.request"
public static final String | REQUEST_SEPARATOR | "-"
public static final String | START_ID | "start"
public static final String | SUFFIX_ATTRIBUTE | "jp.co.intra_mart.framework.presentation.PresentationServlet.suffix"
public static final String | TOKEN_ATTRIBUTE | "jp.co.intra_mart.framework.presentation.PresentationServlet.token"

jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter
public static final String OBJECT_PARAM_NAME "object"

jp.co.intra_mart.framework.presentation.validator.FormatValidator
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_PROPERTY | "property"
public static final String | PARAM_REGEX | "regex"

jp.co.intra_mart.framework.presentation.validator.LengthValidator
public static final String | PARAM_MAX | "max"
public static final String | PARAM_MESSAGE_LONG | "message_long"
public static final String | PARAM_MESSAGE_SHORT | "message_short"
public static final String | PARAM_MIN | "min"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator
public static final String | PARAM_MAX | "max"
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_MIN | "min"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.presentation.validator.NumericValidator
public static final String | PARAM_MESSAGE | "message"
public static final String | PARAM_PROPERTY | "property"

jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "LogConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.log.IntramartLogAgent
public static final String TYPE_DB "DB"

jp.co.intra_mart.framework.system.log.LogConstant
public static final String | LEVEL_DEBUG | "DEBUG"
public static final String | LEVEL_ERROR | "ERROR"
public static final String | LEVEL_INFO | "INFO"
public static final String | LEVEL_WARNNING | "WARNNING"

jp.co.intra_mart.framework.system.log.LogManager
public static final String LOG_PROPERTY_HANDLER_KEY "log"

jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "log-config"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler
public static final String | DEFAULT_BUNDLE_NAME | "MessageConfig"
public static final String | DEFAULT_BUNDLE_NAME_PARAM | "bundle"

jp.co.intra_mart.framework.system.message.MessageManager
public static final String MESSAGE_PROPERTY_HANDLER_KEY "message"

jp.co.intra_mart.framework.system.property.DefaultPropertyManager
public static final String | DEFAULT_BUNDLE_NAME | "/PropertyConfig.properties"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.DefaultPropertyManager"

jp.co.intra_mart.framework.system.property.PropertyManager
public static final String | DEFAULT_SYSTEM_MANAGER | "jp.co.intra_mart.framework.system.property.XmlPropertyManager"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.PropertyManager"

jp.co.intra_mart.framework.system.property.XmlPropertyManager
public static final String | DEFAULT_BUNDLE_NAME | "property-config.xml"
public static final String | KEY | "jp.co.intra_mart.framework.system.property.XmlPropertyManager"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


非推奨 API のリスト (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter
このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。
jp.co.intra_mart.framework.base.session.HttpSessionFactory
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.HttpSessionObject
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.service.IntramartConnectFilter
この機能は廃止されました。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet
この機能は廃止されました。
jp.co.intra_mart.framework.base.data.IntramartDBConnector
このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
jp.co.intra_mart.framework.base.data.IntramartDBDAO
このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
jp.co.intra_mart.framework.base.session.IntramartSessionFactory
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.IntramartSessionObject
このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.data.JDBCConnector
JDBCを直接扱わず、DataSourceを使用するようにしてください。
jp.co.intra_mart.framework.presentation.PresentationConnectFilter
この機能は廃止されました。

推奨されていないフィールド
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.DEFAULT_APPLICATION_PARAMETER
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.DEFAULT_SERVICE_PARAMETER
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.INTRAMART_URL_NAME
このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT_DELIMITER
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_ARGUMENT_OPERATOR
このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_LOGIN_GROUP_ID
このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_LOGIN_USER_ID
このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
jp.co.intra_mart.framework.base.service.IntramartConnectServlet.PARAM_REFERER
このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。

推奨されていないメソッド
jp.co.intra_mart.framework.base.event.EventManager.createEvent(String, String, String, String)
このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
jp.co.intra_mart.framework.base.web.tag.TagWriter.createURL(String, Collection)
このメソッドではなくTagWriter.createURL(String, Collection, String)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getApplicationParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getContextPath()
このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
jp.co.intra_mart.framework.base.web.tag.FrameTag.getFrameClass()
このメソッドではなくFrameTag.getFrameclass()メソッドを使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath()
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.web.tag.LinkTag.getLinkClass()
このメソッドではなくLinkTag.getLinkclass()メソッドを使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginGroup()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginGroupID()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.getLoginGroupID()
このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getLoginGroupID()
このメソッドではなくHelperBean.getUserInfo()を使用してください。
jp.co.intra_mart.framework.presentation.view.AbstractViewConverter.getLoginGroupID(RequestInfo)
このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginUser()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.event.Event.getLoginUserID()
このメソッドではなくEvent.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.getLoginUserID()
このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getLoginUserID()
このメソッドではなくHelperBean.getUserInfo()を使用してください。
jp.co.intra_mart.framework.presentation.view.AbstractViewConverter.getLoginUserID(RequestInfo)
このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
jp.co.intra_mart.framework.system.message.MessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
MessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.MessageManager.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。MessageManager.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。IntramartMessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler.getMessage(String, String)
intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
DefaultMessagePropertyHandler.getMessage(String)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getNextPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getNextPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.ServiceManager.getServiceController(String, String)
このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceControllerName(String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getServiceParamName()
この実装は廃止されました。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getServiceServletPath()
この実装は廃止されました。
jp.co.intra_mart.framework.base.web.bean.HelperBean.getSession()
このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionFactoryName()
セッションとしてはHttpSessionを直接利用するようにしてください。
jp.co.intra_mart.framework.base.service.Transition.getSessionObject()
このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionObjectKey()
HttpSessionを直接取得するようにしてください。
jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.session.SessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.getSessionParameter()
HttpSessionを直接使用する場合、このメソッドは不要になります。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath()
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String, String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String)
このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.ServiceManager.getTransition(String, String)
このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.getTransitionName(String, String)
このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.ServicePropertyHandler.getTransitionName(String, String)
このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.getTransitionName(String, String)
このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
jp.co.intra_mart.framework.base.web.tag.HelperBeanTag.setClass(String)
このメソッドではなくHelperBeanTag.setHelperclass(java.lang.String)メソッドを使用してください。
jp.co.intra_mart.framework.base.web.tag.FrameTag.setFrameClass(String)
このメソッドではなくFrameTag.setFrameclass(String)メソッドを使用してください。
jp.co.intra_mart.framework.base.web.tag.LinkTag.setLinkClass(String)
このメソッドではなくLinkTag.setLinkclass(String)メソッドを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


API ヘルプ (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


索引 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし
A B C D E F G H I J K L M N O P R S T U V X

A

ACTION_ID - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
アクションによる遷移をする場合のID
AbstractViewConverter - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter.
いくつかのユーティリティメソッドが含まれる抽象的なビューコンバータです。
AbstractViewConverter() - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のコンストラクタ
ApplicationException - exception jp.co.intra_mart.framework.system.exception.ApplicationException.
フレームワーク内で発生したアプリケーション例外です。
ApplicationException() - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
詳細メッセージを指定しないで ApplicationException を構築します。
ApplicationException(String) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
指定された詳細メッセージを持つ ApplicationException を構築します。
ApplicationException(Throwable) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
この例外の発生原因となる例外を持つ ApplicationException を構築します。
ApplicationException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.ApplicationException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ApplicationException を構築します。
addDetail(String) - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のメソッド
検証結果の詳細を追加します。
addParameter(String, String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
パラメータを追加します。
addParameter(String, String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
パラメータを追加します。
addParameter(Object) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
パラメータを追加します。
addParameter(String, String) - interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable のメソッド
パラメータを追加します。

B

BadRequestException - exception jp.co.intra_mart.framework.presentation.BadRequestException.
クライアントによって送信された要求が、プレゼンテーションフレームワークの構文仕様を満たしていないときに発生する例外です。
BadRequestException() - class jp.co.intra_mart.framework.presentation.BadRequestException のコンストラクタ
詳細メッセージを指定しないで BadRequestException を構築します。
BadRequestException(String) - class jp.co.intra_mart.framework.presentation.BadRequestException のコンストラクタ
指定された詳細メッセージを持つ BadRequestException を構築します。
BadRequestException(String, Throwable) - class jp.co.intra_mart.framework.presentation.BadRequestException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ BadRequestException を構築します。

C

CONFIG - class jp.co.intra_mart.framework.presentation.PresentationManager の static 変数
PresentationManagerの生成情報が設定されているリソースバンドル名
ConfigurationUserInfo - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo.
情報を自由に設定可能なUserInfoです。
ConfigurationUserInfo() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のコンストラクタ
ConnectorModel - class jp.co.intra_mart.framework.base.data.ConnectorModel.
コネクタ情報を管理するクラスです。
ConnectorModel() - class jp.co.intra_mart.framework.base.data.ConnectorModel のコンストラクタ
ControllerConverter - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter.
リクエストをコントローラオブジェクトに変換します。
ControllerConverterConfig - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig.
ControllerConverterの初期化情報です。
ControllerConverterException - exception jp.co.intra_mart.framework.presentation.controller.ControllerConverterException.
ControllerConverterに関連する例外です。
ControllerConverterException() - class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException のコンストラクタ
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ControllerConverterException(String) - class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException のコンストラクタ
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ControllerConverterException(String, Throwable) - class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
ControllerObject - interface jp.co.intra_mart.framework.presentation.controller.ControllerObject.
コントローラオブジェクトのインタフェースです。
CoreAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes.
コア属性です。
CoreAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のコンストラクタ
CoreAttributesを新規に生成します。
check() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
入力内容をチェックします。
check() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
入力内容をチェックします。
clear() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
clear() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッション内に存在するすべてのオブジェクトを削除します。
clear() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッション内に存在するすべてのオブジェクトを削除します。
commit() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータコネクタをコミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 コミットします。
commit() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 コミットします。
commit() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
コミットします。
commit() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
コミットします。
connections - class jp.co.intra_mart.framework.base.data.IntramartDBConnector の変数
推奨されていません。 DbsConnectionの一覧
connections - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector の変数
リソース一覧
connections - class jp.co.intra_mart.framework.base.data.SystemDBConnector の変数
リソース一覧
convert(RequestInfo) - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - interface jp.co.intra_mart.framework.presentation.view.ViewConverter のメソッド
リクエスト情報をもとにビューオブジェクトを生成します。
create(Event) - interface jp.co.intra_mart.framework.base.event.EventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome のメソッド
リモートインタフェースGenericEJBEventListenerAgentを取得します。
create() - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome のメソッド
ローカルインタフェース GenericEJBEventListenerAgentLocalを取得します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のメソッド
イベントリスナを生成します。
create() - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome のメソッド
StandardEJBEventListenerAgentと接続します。
create(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のメソッド
イベントリスナを生成します。
create(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のメソッド
イベントリスナを生成します。
createEvent(String, String, UserInfo) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
パラメータで指定された内容に該当するイベントを生成します。
createEvent(String, String, String, String) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
推奨されていません。 このメソッドではなくEventManager.createEvent(String, String, UserInfo)を使用してください。
createEvent(String, String) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(RequestInfo, String, String) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
アプリケーションIDとキーに対応するイベントを取得します。
createSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッションオブジェクトを新規に生成します。
createSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッションオブジェクトを新規に生成します。
createSessionObject(ServletRequest) - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッションオブジェクトを新規に生成します。
createToken() - class jp.co.intra_mart.framework.presentation.PresentationManager のメソッド
新しいトークンを取得します。
createURL(String, Collection) - class jp.co.intra_mart.framework.base.web.tag.TagWriter の static メソッド
推奨されていません。 このメソッドではなくTagWriter.createURL(String, Collection, String)を使用してください。
createURL(String, Collection, String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter の static メソッド
複数のパラメータをURLに追加します。
createUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static メソッド
intra-martのセッション情報からUserInfoを新規に生成します。

D

DAO - interface jp.co.intra_mart.framework.base.data.DAO.
データリソースにアクセスするインタフェースです。
DAOAdapter - class jp.co.intra_mart.framework.base.data.DAOAdapter.
DAOのすべてのメソッドを何もしないように実装したクラスです。
DAOAdapter() - class jp.co.intra_mart.framework.base.data.DAOAdapter のコンストラクタ
DAOAdapterを新規に生成します。
DAOException - exception jp.co.intra_mart.framework.base.data.DAOException.
リソースコネクタの情報取得時の例外です。
DAOException() - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
詳細メッセージを指定しないで DAOException を構築します。
DAOException(String) - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
指定された詳細メッセージを持つ DAOException を構築します。
DAOException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DAOException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DAOException を構築します。
DATA_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.data.DataManager の static 変数
データプロパティハンドラのキー
DBConnector - class jp.co.intra_mart.framework.base.data.DBConnector.
データベースに対するコネクタです。
DBConnector() - class jp.co.intra_mart.framework.base.data.DBConnector のコンストラクタ
DBConnectorを新規に生成します。
DBDAO - class jp.co.intra_mart.framework.base.data.DBDAO.
データベースに特化したDAOです。
DBDAO() - class jp.co.intra_mart.framework.base.data.DBDAO のコンストラクタ
デフォルトのコンストラクタ
DEFAULT_APPLICATION_PARAMETER - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
推奨されていません。 この実装は廃止されました。
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
デフォルトのXMLファイル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
デフォルトのxmlファイルのプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
デフォルトのリソースバンドル名のプレフィックス
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の static 変数
デフォルトのxmlファイル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の static 変数
デフォルトのXMLファイル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME - class jp.co.intra_mart.framework.system.property.XmlPropertyManager の static 変数
デフォルトのリソースバンドル名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
XMLファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
xmlのパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler の static 変数
xmlファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler の static 変数
XMLファイル名のパラメータ名
DEFAULT_BUNDLE_NAME_PARAM - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler の static 変数
リソースバンドル名のパラメータ名
DEFAULT_ENCODING_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
ログインユーザのエンコーディングのデフォルトの属性名
DEFAULT_EXCEPTION_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
例外属性のデフォルトの属性名
DEFAULT_LOCALE_ATTRIBUTE - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
ログインユーザのロケールのデフォルトの属性名
DEFAULT_SERVICE_EXTENSION - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
サービスフレームワークをコールするためのデフォルトの拡張子
DEFAULT_SERVICE_PARAMETER - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler の static 変数
推奨されていません。 この実装は廃止されました。
DEFAULT_SYSTEM_MANAGER - class jp.co.intra_mart.framework.system.property.PropertyManager の static 変数
デフォルトのプロパティマネージャクラス
DaoModel - class jp.co.intra_mart.framework.base.data.DaoModel.
DaoModelを管理するクラスです。
DaoModel() - class jp.co.intra_mart.framework.base.data.DaoModel のコンストラクタ
DataAccessController - class jp.co.intra_mart.framework.base.data.DataAccessController.
データアクセスを制御します。
DataAccessController(DataPropertyHandler) - class jp.co.intra_mart.framework.base.data.DataAccessController のコンストラクタ
データアクセスコントローラを生成します。
DataAccessException - exception jp.co.intra_mart.framework.base.data.DataAccessException.
データアクセス時の例外です。
DataAccessException() - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
詳細メッセージを指定しないで DataAccessException を構築します。
DataAccessException(String) - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
指定された詳細メッセージを持つ DataAccessException を構築します。
DataAccessException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataAccessException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataAccessException を構築します。
DataConnectException - exception jp.co.intra_mart.framework.base.data.DataConnectException.
データ接続に関連する例外です。
DataConnectException() - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
詳細メッセージを指定しないで DataConnectException を構築します。
DataConnectException(String) - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
指定された詳細メッセージを持つ DataConnectException を構築します。
DataConnectException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataConnectException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectException を構築します。
DataConnector - class jp.co.intra_mart.framework.base.data.DataConnector.
データストアに接続するコネクタです。
DataConnector() - class jp.co.intra_mart.framework.base.data.DataConnector のコンストラクタ
新規のDataConnectorを生成します。
DataConnectorException - exception jp.co.intra_mart.framework.base.data.DataConnectorException.
データコネクタ取得時の例外です。
DataConnectorException() - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
詳細メッセージを指定しないで DataConnectorException を構築します。
DataConnectorException(String) - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
指定された詳細メッセージを持つ DataConnectorException を構築します。
DataConnectorException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataConnectorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataConnectorException を構築します。
DataManager - class jp.co.intra_mart.framework.base.data.DataManager.
データストアとの接続を管理します。
DataManager() - class jp.co.intra_mart.framework.base.data.DataManager のコンストラクタ
データマネージャを生成するコンストラクタです。
DataManagerException - exception jp.co.intra_mart.framework.base.data.DataManagerException.
データマネージャの設定時の例外です。
DataManagerException() - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
詳細メッセージを指定しないで DataManagerException を構築します。
DataManagerException(String) - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
指定された詳細メッセージを持つ DataManagerException を構築します。
DataManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataManagerException を構築します。
DataPropertyException - exception jp.co.intra_mart.framework.base.data.DataPropertyException.
データプロパティ取得時の例外です。
DataPropertyException() - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
詳細メッセージを指定しないで DataPropertyException を構築します。
DataPropertyException(String) - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
指定された詳細メッセージを持つ DataPropertyException を構築します。
DataPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.data.DataPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DataPropertyException を構築します。
DataPropertyHandler - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler.
DAOの設定情報に接続するクラスです。
DataSourceConnector - class jp.co.intra_mart.framework.base.data.DataSourceConnector.
DataSourceに関連するデータコネクタです。
DataSourceConnector() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のコンストラクタ
DataSourceConnectorを新規に生成します。
DefaultDataPropertyHandler - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler.
デフォルトのデータプロパティハンドラです。
DefaultDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のコンストラクタ
DefaultDataPropertyHandlerを新規に生成します。
DefaultEventPropertyHandler - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler.
デフォルトのEventPropertyHandlerです。
DefaultEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のコンストラクタ
DefaultEventPropertyHandlerを新規に生成します。
DefaultLogAgent - class jp.co.intra_mart.framework.system.log.DefaultLogAgent.
デフォルトのログエージェントです。
DefaultLogAgent() - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のコンストラクタ
DefaultLogPropertyHandler - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler.
ログに関連するデフォルトのプロパティハンドラです。
DefaultLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のコンストラクタ
DefaultLogPropertyHandlerを新規に生成します。
DefaultMessagePropertyHandler - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler.
メッセージの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のコンストラクタ
DefaultMessagePropertyHandlerを新規に生成します。
DefaultMessagePropertyHandler - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler.
デフォルトのメッセージプロパティハンドラです。
DefaultMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のコンストラクタ
DefaultMessagePropertyHandlerを新規に生成します。
DefaultPropertyManager - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager.
デフォルトのプロパティマネージャです。
DefaultPropertyManager() - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のコンストラクタ
コンストラクタです。
DefaultServicePropertyHandler - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler.
サービスの設定情報に接続するデフォルトのプロパティハンドラです。
DefaultServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のコンストラクタ
DefaultServicePropertyHandlerを新規に生成します。
DefaultSessionPropertyHandler - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler.
セッションに関連するデフォルトのプロパティハンドラです。
DefaultSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のコンストラクタ
DefaultSessionPropertyHandlerを新規に生成します。
DefaultTransition - class jp.co.intra_mart.framework.base.service.DefaultTransition.
デフォルトの画面遷移をします。
DefaultTransition() - class jp.co.intra_mart.framework.base.service.DefaultTransition のコンストラクタ
DefaultTransitionを新規に生成します。
DistributesDataPropertyHandler - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler.
アプリケーション毎のプロパティハンドラを呼び出します。
DistributesDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のコンストラクタ
DefaultDataPropertyHandlerを新規に生成します。
DistributesEventPropertyHandler - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler.
アプリケーション毎のEventPropertyHandlerを呼び出します。
DistributesEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のコンストラクタ
DistributesEventPropertyHandlerを新規に生成します。
DistributesServicePropertyHandler - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler.
アプリケーションごとに異なるサービスプロパティハンドラを使用するサービスプロパティハンドラです。
DistributesServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のコンストラクタ
DefaultServicePropertyHandlerを新規に生成します。
DuplicateException - exception jp.co.intra_mart.framework.presentation.DuplicateException.
重複しているときに発生する例外です。
DuplicateException() - class jp.co.intra_mart.framework.presentation.DuplicateException のコンストラクタ
詳細メッセージを指定しないで DuplicateException を構築します。
DuplicateException(String) - class jp.co.intra_mart.framework.presentation.DuplicateException のコンストラクタ
指定された詳細メッセージを持つ DuplicateException を構築します。
DuplicateException(String, Throwable) - class jp.co.intra_mart.framework.presentation.DuplicateException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。
destroy() - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
サーブレットを解放します。
destroy() - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter のメソッド
推奨されていません。 フィルタを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
サーブレットを破棄します。
destroy() - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter のメソッド
ControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter のメソッド
SimpleControllerConverterを破棄します。
destroy() - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector のメソッド
ForwardSelectorを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.validator.FormatValidator のメソッド
FormatValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.validator.LengthValidator のメソッド
LengthValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator のメソッド
NumericRangeValidatorを破棄します。
destroy() - class jp.co.intra_mart.framework.presentation.validator.NumericValidator のメソッド
NumericValidatorを破棄します。
destroy() - interface jp.co.intra_mart.framework.presentation.validator.Validator のメソッド
Validatorを破棄します。
destroy() - interface jp.co.intra_mart.framework.presentation.view.ViewConverter のメソッド
ViewConverterを破棄します。
dispatch(Event) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントに対する処理を実行します。
dispatch(Event, boolean) - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントに対する処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.EJBEventListener のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
イベント処理を実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
イベント処理を実行します。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doEndTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
終了タグを検知したときにJSPエンジンから呼ばれます。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
リクエストのエンコードを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
リクエストの内容がファイルアップロードを含むかどうかによってリクエストを選択します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 リクエストのパラメーターを設定後、次の処理に遷移します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 intra-martから来るリクエストをim-J2EE Frameworkで扱う形式に変換します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
リクエストのロケールを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
リクエストのロケールを設定します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
sessionに登録された情報と、parameterの情報を比較します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
リクエストのセッション管理をします。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter のメソッド
推奨されていません。 intra-martから来るリクエストをPresentation Frameworkで扱う形式に変換します。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 GETメソッドに対応します。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
GETメソッドに対するサービスを行います。
doGet(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
リクエストがGETで来た場合の処理をします。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 POSTメソッドに対応します。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
POSTメソッドに対するサービスを行います。
doPost(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
リクエストがPOSTで来た場合の処理をします。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
外側の一番近いMessageTagにパラメータを設定します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
外側の一番近いParameterSendableにパラメータを設定します。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。
doStartTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
開始タグを検知したときにJSPエンジンから呼ばれます。

E

EJBEventListener - class jp.co.intra_mart.framework.base.event.EJBEventListener.
EJBを利用する場合のイベントリスナです。
EJBEventListener() - class jp.co.intra_mart.framework.base.event.EJBEventListener のコンストラクタ
EJBEventListenerを新規に生成します。
EJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean.
Session Beanを利用したイベントリスナの抽象クラスです。
EJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のコンストラクタ
EJBEventListenerAgentBeanを新規に生成します。
EJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory.
EJBEventListenerFactoryを生成します。
EJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のコンストラクタ
EJBEventListenerFactoryを新規に生成します。
EVENT_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.event.EventManager の static 変数
イベントプロパティハンドラのキー
EmptyEvent - class jp.co.intra_mart.framework.base.event.EmptyEvent.
情報を何も持たないイベントです。
EmptyEvent() - class jp.co.intra_mart.framework.base.event.EmptyEvent のコンストラクタ
EmptyUserInfo - class jp.co.intra_mart.framework.base.util.EmptyUserInfo.
情報を何も持たないUserInfoです。
EmptyUserInfo() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のコンストラクタ
EncodingFilter - class jp.co.intra_mart.framework.base.service.EncodingFilter.
リクエストのエンコードを設定します。
EncodingFilter() - class jp.co.intra_mart.framework.base.service.EncodingFilter のコンストラクタ
ErrorHelperBean - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean.
例外ページで使用するHelperBeanです。
ErrorHelperBean() - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean のコンストラクタ
ErrorHelperBeanを新規に生成します。
Event - class jp.co.intra_mart.framework.base.event.Event.
処理を実行するための情報です。
Event() - class jp.co.intra_mart.framework.base.event.Event のコンストラクタ
イベントを新規に生成します。
EventException - exception jp.co.intra_mart.framework.base.event.EventException.
イベント生成時の例外です。
EventException() - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
詳細メッセージを指定しないで EventException を構築します。
EventException(String) - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
指定された詳細メッセージを持つ EventException を構築します。
EventException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventException を構築します。
EventFactoryModel - class jp.co.intra_mart.framework.base.event.EventFactoryModel.
イベントリスナーファクトリー情報を管理するクラスです。
EventFactoryModel() - class jp.co.intra_mart.framework.base.event.EventFactoryModel のコンストラクタ
EventGroupModel - class jp.co.intra_mart.framework.base.event.EventGroupModel.
Event情報を管理するクラスです。
EventGroupModel() - class jp.co.intra_mart.framework.base.event.EventGroupModel のコンストラクタ
EventListener - interface jp.co.intra_mart.framework.base.event.EventListener.
イベントリスナです。
EventListenerException - exception jp.co.intra_mart.framework.base.event.EventListenerException.
イベントリスナ生成時の例外です。
EventListenerException() - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
詳細メッセージを指定しないで EventListenerException を構築します。
EventListenerException(String) - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
指定された詳細メッセージを持つ EventListenerException を構築します。
EventListenerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventListenerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventListenerException を構築します。
EventListenerFactory - interface jp.co.intra_mart.framework.base.event.EventListenerFactory.
イベントリスナを生成します。
EventListenerFactoryParam - class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam.
イベントリスナファクトリの初期パラメータです。
EventListenerFactoryParam() - class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam のコンストラクタ
EventListenerFactoryParamを新規に生成します。
EventManager - class jp.co.intra_mart.framework.base.event.EventManager.
イベントマネージャです。
EventManagerException - exception jp.co.intra_mart.framework.base.event.EventManagerException.
イベントマネージャ設定時の例外です。
EventManagerException() - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
詳細メッセージを指定しないで EventManagerException を構築します。
EventManagerException(String) - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
指定された詳細メッセージを持つ EventManagerException を構築します。
EventManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventManagerException を構築します。
EventModelProducer - class jp.co.intra_mart.framework.base.event.EventModelProducer.
イベント情報を作成するクラスです。
EventModelProducer() - class jp.co.intra_mart.framework.base.event.EventModelProducer のコンストラクタ
EventPropertyException - exception jp.co.intra_mart.framework.base.event.EventPropertyException.
イベントプロパティ取得時の例外です。
EventPropertyException() - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
詳細メッセージを指定しないで EventPropertyException を構築します。
EventPropertyException(String) - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
指定された詳細メッセージを持つ EventPropertyException を構築します。
EventPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventPropertyException を構築します。
EventPropertyHandler - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler.
イベントの設定情報に接続するクラスです。
EventResult - interface jp.co.intra_mart.framework.base.event.EventResult.
イベント処理の結果です。
EventTrigger - interface jp.co.intra_mart.framework.base.event.EventTrigger.
イベントトリガです。
EventTriggerAdapter - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter.
DAOを取得するメソッドを持ったイベントトリガです。
EventTriggerAdapter() - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のコンストラクタ
EventTriggerAdapterを新規に生成します。
EventTriggerException - exception jp.co.intra_mart.framework.base.event.EventTriggerException.
イベントトリガ生成時の例外です。
EventTriggerException() - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
詳細メッセージを指定しないで EventTriggerException を構築します。
EventTriggerException(String) - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
指定された詳細メッセージを持つ EventTriggerException を構築します。
EventTriggerException(String, Throwable) - class jp.co.intra_mart.framework.base.event.EventTriggerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ EventTriggerException を構築します。
EventTriggerInfo - class jp.co.intra_mart.framework.base.event.EventTriggerInfo.
イベントトリガの情報です。
EventTriggerInfo() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のコンストラクタ
EventTriggerInfoを新規に生成します。
EventTriggerList - class jp.co.intra_mart.framework.base.event.EventTriggerList.
イベントトリガの集合を扱います。
EventTriggerList(String, String) - class jp.co.intra_mart.framework.base.event.EventTriggerList のコンストラクタ
EventTriggerListを新規に生成します。
EventTriggerList(String, String, boolean) - class jp.co.intra_mart.framework.base.event.EventTriggerList のコンストラクタ
EventTriggerListを新規に生成します。
EventsAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes.
ブラウザのイベントに関連するタグの属性情報です。
EventsAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のコンストラクタ
EventsAttributesを新規に生成します。
ejbActivate() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
"passive"状態の時にインスタンスが活性化される時に呼ばれるメソッドです。
ejbCreate() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のメソッド
ホームインタフェースの引数なしのcreate()メソッドに対応します。
ejbCreate() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
ホームインタフェースの引数なしのcreate()メソッドに対応します。
ejbPassivate() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
インスタンスが"passive"状態に移る前に呼ばれるメソッドです。
ejbRemove() - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
Session Beanのが終了する前にEJBコンテナが呼び出すメソッドです。
encodeCaption(String) - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder の static メソッド
キャプションを変換します。
encodeURL(ServletRequest, ServletResponse, String) - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッションIDをエンコードしてURLに追加します。
encodeURL(ServletRequest, ServletResponse, String) - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッションIDをエンコードしてURLに追加します。
encodeURL(ServletRequest, ServletResponse, String) - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッションIDをエンコードしてURLに追加します。
encodeValue(String) - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder の static メソッド
<TEXTAREA>タグまたはvalue属性に入る文字列を変換します。
execute(Event) - interface jp.co.intra_mart.framework.base.event.EventListener のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener のメソッド
処理を実行します。
execute(Event, String) - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent のメソッド
イベント処理を行います。
execute(Event, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のメソッド
イベント処理を実行します。
execute(Event, String) - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal のメソッド
イベント処理を行います。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener のメソッド
処理を実行します。
execute(Event) - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent のメソッド
イベント処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
イベント処理を実行します。
execute(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
処理を実行します。
execute(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 intra-martベースモジュールのメニューからのリクエストを受け付けます。

F

FileUploadFilter - class jp.co.intra_mart.framework.base.service.FileUploadFilter.
ファイルアップロード用にリクエストを変換するフィルタです。
FileUploadFilter() - class jp.co.intra_mart.framework.base.service.FileUploadFilter のコンストラクタ
FormTEI - class jp.co.intra_mart.framework.base.web.tag.FormTEI.
Formタグの拡張情報です。
FormTEI() - class jp.co.intra_mart.framework.base.web.tag.FormTEI のコンストラクタ
FormTEIを新規に生成します。
FormTag - class jp.co.intra_mart.framework.base.web.tag.FormTag.
FORMタグです。
FormTag() - class jp.co.intra_mart.framework.base.web.tag.FormTag のコンストラクタ
FormTagを新規に生成します。
FormTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo.
FormTagのBeanInfoです。
FormTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo のコンストラクタ
FormTagBeanInfoを新規に生成します。
FormatValidator - class jp.co.intra_mart.framework.presentation.validator.FormatValidator.
文字列の不正文字（フォーマット）チェックを行います。
FormatValidator() - class jp.co.intra_mart.framework.presentation.validator.FormatValidator のコンストラクタ
ForwardSelector - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector.
遷移先の参照を決定するセレクタです。
ForwardSelectorConfig - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig.
ForwardSelectorの初期化情報です。
ForwardSelectorException - exception jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException.
ForwardSelectorに関連する例外です。
ForwardSelectorException() - class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException のコンストラクタ
詳細メッセージを指定しないで ForwardSelectorException を構築します。
ForwardSelectorException(String) - class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException のコンストラクタ
指定された詳細メッセージを持つ ForwardSelectorException を構築します。
ForwardSelectorException(String, Throwable) - class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ForwardSelectorException を構築します。
FrameTEI - class jp.co.intra_mart.framework.base.web.tag.FrameTEI.
Frameタグの拡張情報です。
FrameTEI() - class jp.co.intra_mart.framework.base.web.tag.FrameTEI のコンストラクタ
FrameTEIを新規に生成します。
FrameTag - class jp.co.intra_mart.framework.base.web.tag.FrameTag.
FRAMEタグです。
FrameTag() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のコンストラクタ
FrameTagを新規に生成します。
FrameTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo.
FrameTagのBeanInfoです。
FrameTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo のコンストラクタ
FrameTagBeanInfoを新規に生成します。
FrameworkException - exception jp.co.intra_mart.framework.system.exception.FrameworkException.
フレームワークに共通するの例外のスーパークラスです。
FrameworkException() - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
詳細メッセージを指定しないで FrameworkException を構築します。
FrameworkException(String) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
指定された詳細メッセージを持つ FrameworkException を構築します。
FrameworkException(Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.FrameworkException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkException を構築します。
FrameworkParameterSettingFilter - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter.
推奨されていません。 このフィルタは下位互換のためのフィルタです。将来廃止される可能性があります。
FrameworkParameterSettingFilter() - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のコンストラクタ
推奨されていません。
FrameworkTagException - exception jp.co.intra_mart.framework.base.web.tag.FrameworkTagException.
拡張タグの例外です。
FrameworkTagException() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
詳細メッセージを指定しないで FrameworkTagException を構築します。
FrameworkTagException(String) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
指定された詳細メッセージを持つ FrameworkTagException を構築します。
FrameworkTagException(String, Throwable) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagException(Throwable) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のコンストラクタ
この例外の発生原因となる例外を持つ FrameworkTagException を構築します。
FrameworkTagParam - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam.
タグに追加されるパラメータです。
FrameworkTagParam() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam のコンストラクタ
FrameworkTagParamを新規に生成します。
findOption(String) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
値に該当する選択肢を取得します。
fire(Event, DataAccessController) - interface jp.co.intra_mart.framework.base.event.EventTrigger のメソッド
イベントに対する処理を行います。
fire(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
イベントに対する処理を行います。
fire(Event) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
イベントに対する処理を行います。
fire(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のメソッド
イベントに対する処理です。
fire(Event) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
イベントに対する処理です。
fireAll(Event, DataAccessController) - class jp.co.intra_mart.framework.base.event.EventTriggerList のメソッド
すべてのトリガに対してイベントの処理を行います。

G

GenericAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes.
汎用属性の集合です。
GenericAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のコンストラクタ
GenericAttributesを新規に生成します。
GenericEJBEventListener - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener.
EJBを利用する汎用的なイベントリスナです。
GenericEJBEventListener(GenericEJBEventListenerAgentHome, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListener のコンストラクタ
GenericEJBEventListenerを新規に生成します。
GenericEJBEventListenerAgent - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent.
汎用的なEJB用のイベントリスナのリモートインタフェースです。
GenericEJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean.
EJBを利用する汎用的なイベントリスナーのBeanです。
GenericEJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean のコンストラクタ
GenericEJBEventListenerAgentBeanを新規に生成します。
GenericEJBEventListenerAgentHome - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome.
リモートインタフェースGenericEJBEventListenerAgentを取得するホームインタフェースです。
GenericEJBEventListenerAgentLocal - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal.
汎用的なEJB用のイベントリスナのローカルインタフェースです。
GenericEJBEventListenerAgentLocalHome - interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome.
ローカルインタフェースGenericEJBEventListenerAgentLocalを取得するホームインタフェースです。
GenericEJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory.
GenericEJBEventListenerを生成します。
GenericEJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のコンストラクタ
GenericEJBEventListenerFactoryを新規に生成します。
GenericEJBEventListenerLocal - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal.
ローカルEJBを利用する汎用的なイベントリスナです。
GenericEJBEventListenerLocal(GenericEJBEventListenerAgentLocalHome, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal のコンストラクタ
GenericEJBEventListnerLocalを新規に生成します。
GenericEJBEventListenerLocalFactory - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory.
GenericEJBEventListnerLocalを新規に生成します。
GenericEJBEventListenerLocalFactory() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のコンストラクタ
GenericEJBEventListnerLocalFactoryを新規に生成します。
GenericEventListener - class jp.co.intra_mart.framework.base.event.GenericEventListener.
汎用的なイベントリスナです。
GenericEventListener() - class jp.co.intra_mart.framework.base.event.GenericEventListener のコンストラクタ
GenericEventListenerを新規に生成します。
GenericEventListenerFactory - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory.
GenericEventListenerを生成するイベントリスナファクトリです。
GenericEventListenerFactory() - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のコンストラクタ
GenericEventListenerFactoryを新規に生成します。
getAccept() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性acceptの値を取得します。
getAcceptcharset() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性accept-charsetの値を取得します。
getAccesskey() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
accesskeyを取得します。
getAccesskey() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
accesskeyを取得します。
getApplication() - class jp.co.intra_mart.framework.base.event.Event のメソッド
アプリケーションを取得します。
getApplication(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するアプリケーションIDを取得します。
getApplication() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
アプリケーションIDを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性applicationの値を取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
applicationを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
アプリケーションを取得します。
getApplication() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性applicationの値を取得します。
getApplication(String) - interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler のメソッド
アプリケーションの情報を取得します。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
アプリケーションIDに該当するパラメータ名を取得します。
getApplicationParamName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getApplicationParamName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getAttribute(String) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを取得します。
getAttribute(String) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを取得します。
getAttribute(String) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを取得します。
getAttributeNames() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッション内に存在する名前の一覧を取得します。
getAttributeNames() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッション内に存在する名前の一覧を取得します。
getAttributeNames() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッション内に存在する名前の一覧を取得します。
getCharset() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
charsetを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientEncoding() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientLocale() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
クライアントのロケールを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
クライアントのロケールを取得します。
getClientLocale() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
クライアントのエンコードを取得します。
getClientType() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
クライアントタイプを取得する。
getClientType() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
クライアントタイプを取得する。
getClientType() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
クライアントタイプを取得する。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
カラーパターンIDを取得する。
getColorPatternID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
カラーパターンIDを取得する。
getConnection(String) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.DBDAO のメソッド
このDAOに関連づけられたコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のメソッド
推奨されていません。 イントラマートで設定されているDBへのコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のメソッド
イントラマートで設定されているDBへのコネクションを取得します。
getConnection(String) - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
データベースへのコネクションを取得します。
getConnection() - class jp.co.intra_mart.framework.base.data.SystemDBDAO のメソッド
イントラマートで設定されているDBへのコネクションを取得します。
getConnectorClassName(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorClassName(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
データコネクタのクラス名を取得します。
getConnectorName(String, String, String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorName(String, String, String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
DAOに対するデータコネクタ名を取得します。
getConnectorResource(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getConnectorResource(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
データコネクタのリソース名を取得します。
getContextPath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getContextPath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく、javax.servlet.http.HttpRequestのgetContextPathを使用するようにしてください。
getControllerObject() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
リクエストから生成されたコントローラオブジェクトを取得します。
getCoords() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
coordsを取得します。
getCoords() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
coordsを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.event.EventTriggerAdapter のメソッド
DAOを取得します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
DAOを取得します。
getDAOName(String, String, String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDAOName(String, String, String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
DAOのクラス名を取得します。
getDataAccessController() - class jp.co.intra_mart.framework.base.data.DataManager のメソッド
データアクセスコントローラを取得します。
getDataAccessController() - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
このイベントリスナで使用するデータアクセスコントローラです。
getDataManager() - class jp.co.intra_mart.framework.base.data.DataManager の static メソッド
データマネージャを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データプロパティハンドラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.DataManager のメソッド
データプロパティハンドラを取得します。
getDetails() - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のメソッド
検証結果の詳細の一覧を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性dirの値を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
dirを取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
dirを取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性dirの値を取得します。
getDir() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性dirの値を取得します。
getDisplayName() - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
表示名を取得します。
getEncoding(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するエンコーディングを取得します。
getEncoding() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
エンコーディングを取得する。
getEncoding() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
エンコーディングを取得する。
getEncoding() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
エンコーディングを取得する。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEncodingAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
ログインユーザが使用するエンコードを保存しておくときの属性名を取得します。
getEnctype() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性enctypeの値を取得します。
getEntity(String) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストから指定された名前に該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストから指定された名前に該当するエンティティを取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryName(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントリスナファクトリのクラス名を取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventListenerFactoryParams(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントリスナファクトリの初期パラメータを取得します。
getEventManager() - class jp.co.intra_mart.framework.base.event.EventManager の static メソッド
イベントマネージャを取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのクラス名を取得します。
getEventName(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントのクラス名を取得します。
getEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.EventManager のメソッド
イベントプロパティハンドラを取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
アプリケーションIDとキーに該当するイベントのイベントトリガ情報をすべて取得します。
getException() - class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean のメソッド
例外を取得します。
getException() - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
この例外が発生した原因となる例外を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExceptionAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
例外ページに遷移するときにjavax.servlet.http.HttpServletRequestに例外情報を属性として追加する場合の属性名を取得します。
getExtesion() - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスフレームワークを呼び出すための拡張子を取得します。
getForm() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
ターゲットとなるフォーム名を取得します。
getFormObjects() - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のメソッド
フォームオブジェクトのマップを取得します。
getFormObjects() - interface jp.co.intra_mart.framework.presentation.view.ViewObject のメソッド
フォームオブジェクトのマップを取得します。
getFormclass() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性classの値を取得します。
getForwardReference(RequestInfo) - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector のメソッド
リクエスト情報から遷移先の参照を取得します。
getFrameClass() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
推奨されていません。 このメソッドではなくFrameTag.getFrameclass()メソッドを使用してください。
getFrameborder() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameborderを取得します。
getFrameclass() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameClassを取得します。
getHelperclass() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
クラス名を取得します。
getHreflang() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
hreflangを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig のメソッド
ControllerConverterを初期化するときのパラメータを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig のメソッド
ForwardSelectorを初期化するときのパラメータを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig のメソッド
Validatorを初期化するときのパラメータを取得します。
getInitParameter(String) - interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig のメソッド
ViewConverterを初期化するときのパラメータを取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInitParameterNames() - interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig のメソッド
初期化パラメータの名前の一覧を取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
入力エラーのページを取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
入力エラーのページを取得します。
getInputErrorPage(RequestException) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
入力エラーのページを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
getInputErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, String, Locale)を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(String, Locale)を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, String, Locale) を使用してください。
getInputErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(String, Locale) を使用してください。
getInputErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getInputErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getInputErrorPagePath(Locale)を使用してください。
getInputErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
入力例外時のページのパスを取得します。
getJNDIName() - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のメソッド
EJBEventListenerAgentHomeのJNDI名を取得します。
getKey() - class jp.co.intra_mart.framework.base.event.Event のメソッド
イベントキーを取得します。
getKey() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
keyを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性langの値を取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
langを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
langを取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性langの値を取得します。
getLang() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性langの値を取得します。
getLinkClass() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
推奨されていません。 このメソッドではなくLinkTag.getLinkclass()メソッドを使用してください。
getLinkclass() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
linkClassを取得します。
getLinkclass() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
linkClassを取得します。
getListenerName() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
EJBEventListenerAgentBeanのクラス名を取得します。
getListenerName() - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
EJBEventListenerAgentBeanのクラス名を取得します。
getLocale(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するロケールを取得します。
getLocale() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ユーザのロケールを取得する。
getLocale() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
localeを取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLocaleAttributeName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
ログインユーザが使用するロケールを保存しておくときの属性名を取得します。
getLogAgent() - class jp.co.intra_mart.framework.system.log.LogManager のメソッド
ログエージェントを取得します。
getLogAgentName() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentName() - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentName() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
ログエージェントのクラス名を取得します。
getLogAgentParams() - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogAgentParams() - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogAgentParams() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
ログエージェントのパラメータを取得します。
getLogManager() - class jp.co.intra_mart.framework.system.log.LogManager の static メソッド
ログマネージャを取得します。
getLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.LogManager のメソッド
ログプロパティハンドラを取得します。
getLoginGroup() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログイングループIDを取得する。
getLoginGroupID() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
getLoginGroupID(RequestInfo) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
getLoginGroupIDKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupIDKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginGroupIDKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションに登録されているログイングループIDのキーを取得します。
getLoginTime() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインした時間を取得する。
getLoginTime() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインした時間を取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインタイプを取得する。
getLoginType() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインタイプを取得する。
getLoginType() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインタイプを取得する。
getLoginUser() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.event.Event のメソッド
推奨されていません。 このメソッドではなくEvent.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
推奨されていません。 このメソッドではなくServiceControllerAdapter.getUserInfo()を使用してください。
getLoginUserID() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくHelperBean.getUserInfo()を使用してください。
getLoginUserID(RequestInfo) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
推奨されていません。 このメソッドではなくAbstractViewConverter.getUserInfo(RequestInfo)を使用してください。
getLoginUserIDKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLoginUserIDKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLoginUserIDKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションに登録されているログインユーザIDのキーを取得します。
getLongdesc() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
longdescを取得します。
getManager() - class jp.co.intra_mart.framework.presentation.PresentationManager の static メソッド
PresentationManagerを取得します。
getMarginheight() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginheightを取得します。
getMarginwidth() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginwidthを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Object[]) - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
ロケールを指定せず、キーに該当するメッセージを取得します。
getMessage(String, String, Object[], Locale) - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
ロケールを指定し、キーに該当するメッセージを取得します。
getMessage(String, String) - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage(String, String, Locale) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
メッセージを取得します。
getMessage() - class jp.co.intra_mart.framework.presentation.validator.ValidationException のメソッド
例外メッセージを取得します。
getMessage() - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のメソッド
検証結果のメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
DefaultMessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
パラメータloginGroupは実際には使用しません。IntramartMessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
設定されているMessagePropertyHandlerによっては、 パラメータloginGroupは実際には使用しない可能性があります。MessageManager.getMessage(String)を使用してください。
getMessage(String) - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
キーに該当するメッセージを取得します。
getMessage(String, String) - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler のメソッド
推奨されていません。 intra-mart v5.0からのメッセージマスタにはログイングループの概念がありません。
MessagePropertyHandler.getMessage(String)を使用してください。
getMessage(String) - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler のメソッド
キーに該当するメッセージを取得します。
getMessageManager() - class jp.co.intra_mart.framework.base.message.MessageManager の static メソッド
メッセージマネージャを取得します。
getMessageManager() - class jp.co.intra_mart.framework.system.message.MessageManager の static メソッド
MessageManagerを取得します。
getMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.MessageManager のメソッド
メッセージプロパティハンドラを取得します。
getMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.MessageManager のメソッド
メッセージプロパティハンドラを取得します。
getMethod() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性methodの値を取得します。
getName() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
イベントトリガ名を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性nameの値を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータ名を取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
nameを取得します。
getName() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性nameを取得します。
getName() - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータ名を取得します。
getNetworkFile(String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
Storageサービス上の指定されたパスのファイルにアクセスするNetworkFileを取得します。
getNetworkFile(String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のメソッド
パスに該当するNetworkFileを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次に遷移するページを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
次に遷移するページを取得します。
getNextPage() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次に遷移するページを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
getNextPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
getNextPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, Locale)を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getNextPagePath(String, String, String, Locale)を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
このトランジションに設定されているアプリケーションIDとサービスIDに該当する次ページのパスを取得します。
getNextPagePath(String) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
このトランジションに設定されているアプリケーションIDとサービスIDと、指定されたキーに該当する次ページのパスを取得します。
getNextPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, Locale) を使用してください。
getNextPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNextPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getNextPagePath(String, String, String, Locale) を使用してください。
getNextPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
遷移先のページのパスを取得します。
getNoresize() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
noresizeを取得します。
getNumber() - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
ソート番号を取得します。
getOnClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickの値を取得します。
getOnDblClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onDblClickの値を取得します。
getOnKeyDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownの値を取得します。
getOnKeyPress() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressの値を取得します。
getOnKeyUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpの値を取得します。
getOnMouseDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownの値を取得します。
getOnMouseMove() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveの値を取得します。
getOnMouseOut() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutの値を取得します。
getOnMouseOver() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverの値を取得します。
getOnMouseUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpの値を取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onblurを取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onblurを取得します。
getOnblur() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onBlurを取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onClickの値を取得します。
getOnclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onDblClickの値を取得します。
getOndblclick() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onDblClickの値を取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onfocusを取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onfocusを取得します。
getOnfocus() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onFocusを取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyDownの値を取得します。
getOnkeydown() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyDownの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyPressの値を取得します。
getOnkeypress() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyPressの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyUpの値を取得します。
getOnkeyup() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyUpの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseDownの値を取得します。
getOnmousedown() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseDownの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseMoveの値を取得します。
getOnmousemove() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseMoveの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseout() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOutの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseover() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOverの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseUpの値を取得します。
getOnmouseup() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseUpの値を取得します。
getOnreset() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onResetの値を取得します。
getOnsubmit() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onSubmitの値を取得します。
getOption() - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
選択肢をすべて取得します。
getOption(int) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
選択肢を取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPostEventTriggerInfos(String, String) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
キーに該当するイベントのイベントトリガ情報をすべて取得します。
getPresentationPropertyHandler() - class jp.co.intra_mart.framework.presentation.PresentationManager のメソッド
PresentationPropertyHandlerを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyDescriptors() - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo のメソッド
PropertyDescriptorを取得します。
getPropertyHandler(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラを取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
指定されたキーのプロパティハンドラ名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerName(String) - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のメソッド
キーで指定されたプロパティハンドラのクラス名を取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.PropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyHandlerParams(String) - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のメソッド
キーで指定されたプロパティハンドラの初期化データを取得します。
getPropertyManager() - class jp.co.intra_mart.framework.system.property.PropertyManager の static メソッド
プロパティマネージャを取得します。
getPropertyParams(String) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
指定されたキーのプロパティのパラメータを取得します。
getRel() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを取得します。
getRequest() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストを取得します。
getRequest() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
リクエストを取得します。
getRequest() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
リクエストを取得します。
getRequestInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
RequestInfoを取得します。
getRequestInfo() - class jp.co.intra_mart.framework.presentation.service.PresentationServiceController のメソッド
リクエスト情報を取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
リソースを取得します。
getResource(String, String, String) - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
リソースを取得します。
getResourceParams(String) - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResourceParams(String) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
リソースのパラメータを取得します。
getResponse() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
レスポンスを取得します。
getResponse() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
レスポンスを取得します。
getResponse() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
レスポンスを取得します。
getResult() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービス処理結果を取得します。
getResult() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
サービス処理結果を取得します。
getRev() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
revを取得します。
getScrolling() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
scrollingを取得します。
getSecurityExt() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 セキュリティの拡張子を取得します。
getSelectString() - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
この選択肢が選択済である場合の表示名を取得します。
getSelected() - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
選択済の選択肢をすべて取得します。
getSelected(int) - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
選択済みである選択肢を取得します。
getSelected() - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem のメソッド
選択済の選択肢を取得します。
getService(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
現在のリクエストに対するサービスIDを取得します。
getService() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスIDを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性serviceの値を取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
サービスを取得します。
getService() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性serviceの値を取得します。
getServiceController(String, String) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
推奨されていません。 このメソッドではなくServiceManager.getServiceController(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
getServiceController(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスコントローラを取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
getServiceControllerName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceControllerName(String, String, Locale)を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceControllerName(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceControllerName(String, String, Locale) を使用してください。
getServiceControllerName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
サービスコントローラのクラス名を取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
処理エラーのページを取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
処理エラーのページを取得します。
getServiceErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
処理エラーのページを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
getServiceErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
getServiceErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, String, Locale)を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(String, Locale)を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getServiceErrorPagePath(Locale)を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, String, Locale) を使用してください。
getServiceErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(String, Locale) を使用してください。
getServiceErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getServiceErrorPagePath(Locale) を使用してください。
getServiceErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
処理例外時のページのパスを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 サービスマネージャを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.ServiceManager の static メソッド
サービスマネージャを取得します。
getServiceManager() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスマネージャを取得します。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスIDに該当するパラメータ名を取得します。
getServiceParamName() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceParamName() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
サービスプロパティハンドラを取得します。
getServicePropertyHandler() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
サービスプロパティハンドラを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 この実装は廃止されました。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getServiceServletPath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
サービスサーブレットのパスを取得します。
getSession() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
getSessionErrorPagePath() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionErrorPagePath() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionErrorPagePath() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
セッションエラーページのパスを取得します。
getSessionFactory() - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションファクトリを取得します。
getSessionFactoryName() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionFactoryName() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionFactoryName() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 セッションとしてはHttpSessionを直接利用するようにしてください。
getSessionID() - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 セッションを一意に識別するIDを取得します。
getSessionID() - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 セッションを一意に識別するIDを取得します。
getSessionID() - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
セッションを一意に識別するIDを取得します。
getSessionManager() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 セッションマネージャを取得します。
getSessionManager() - class jp.co.intra_mart.framework.base.session.SessionManager の static メソッド
セッションマネージャを取得します。
getSessionObject() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
推奨されていません。 このメソッドではなくjavax.servlet.http.HttpServletRequestのgetSessionメソッドを利用してください。
getSessionObject(ServletRequest) - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションオブジェクトを取得します。
getSessionObjectKey() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionObjectKey() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionObjectKey() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接取得するようにしてください。
getSessionParameter() - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionParameter() - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionParameter() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
推奨されていません。 HttpSessionを直接使用する場合、このメソッドは不要になります。
getSessionPropertyHandler() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 セッションプロパティハンドラを取得します。
getSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.SessionManager のメソッド
セッションプロパティハンドラを取得します。
getShape() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
shapeを取得します。
getShape() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
shapeを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性styleの値を取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
styleを取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性styleの値を取得します。
getStyle() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性styleの値を取得します。
getSubPanelViewObjects() - interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject のメソッド
サブパネルに対応するPanelBasedViewObjectを取得します。
getSubPanelViewObjects() - class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject のメソッド
サブパネルに対応するPanelBasedViewObjectを取得します。
getSubmitclass() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性classの値を取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
システムエラーのページを取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
システムエラーのページを取得します。
getSystemErrorPage(Exception) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
システムエラーのページを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
getSystemErrorPagePath(String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, String, Locale)を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(String, Locale)を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, String, Locale) を使用してください。
getSystemErrorPagePath(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath(String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(String, Locale) を使用してください。
getSystemErrorPagePath(String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getSystemErrorPagePath() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getSystemErrorPagePath(Locale)を使用してください。
getSystemErrorPagePath(Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
システム例外時のページのパスを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
tabindexを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
tabindexを取得します。
getTabindex() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
tabindexを取得します。
getTagClass() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性classの値を取得します。
getTagWriter() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
TagWriterを取得します。
getTarget() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性targetの値を取得します。
getTarget() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
targetを取得します。
getThrowable() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
処理中に発生した例外を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性titleの値を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
titleを取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性titleの値を取得します。
getTitle() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性titleの値を取得します。
getTransition(String, String) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
推奨されていません。 このメソッドではなくServiceManager.getTransition(java.lang.String, java.lang.String, java.util.Locale)を使用してください。
getTransition(String, String, Locale) - class jp.co.intra_mart.framework.base.service.ServiceManager のメソッド
トランジションを取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DefaultServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく DistributesServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
getTransitionName(String, String, Locale) - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなくTextFileServicePropertyHandler.getTransitionName(String, String, Locale)を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getTransitionName(String, String) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
推奨されていません。 このメソッドではなく XmlServicePropertyHandler.getTransitionName(String, String, Locale) を使用してください。
getTransitionName(String, String, Locale) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
トランジションのクラス名を取得します。
getType() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
typeを取得します。
getUserID() - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - class jp.co.intra_mart.framework.base.util.EmptyUserInfo のメソッド
ログインユーザIDを取得する。
getUserID() - interface jp.co.intra_mart.framework.base.util.UserInfo のメソッド
ログインユーザIDを取得する。
getUserInfo() - class jp.co.intra_mart.framework.base.event.Event のメソッド
ログインユーザの情報を取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
ユーザ情報を取得します。
getUserInfo() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
ログインユーザ情報を取得します。
getUserInfo(RequestInfo) - class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter のメソッド
ログインユーザ情報を取得します。
getValidationExceptionDetails() - class jp.co.intra_mart.framework.presentation.validator.ValidationException のメソッド
検証結果の詳細の一覧を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータの値を取得します。
getValue() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性valueを取得します。
getValue() - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
値を取得します。
getValue() - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータの値を取得します。
getVariableInfo(TagData) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のメソッド
スクリプティング変数に関連付けたHelperBeanの情報を取得します。
getViewInfo() - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のメソッド
表示情報を取得します。
getViewInfo() - interface jp.co.intra_mart.framework.presentation.view.ViewObject のメソッド
表示情報を取得します。
getViewObject() - interface jp.co.intra_mart.framework.presentation.RequestInfo のメソッド
生成されたビューオブジェクトを取得します。

H

HOME_PARAM - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory の static 変数
ホームインタフェースを取得するときのJNDI名のパラメータ名
HTMLEncoder - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder.
文字列をHTML形式で表示するための変換を行うユーティリティクラスです。
HTMLEncoder() - class jp.co.intra_mart.framework.base.web.util.HTMLEncoder のコンストラクタ
HelperBean - class jp.co.intra_mart.framework.base.web.bean.HelperBean.
画面表示をする時のヘルパークラスです。
HelperBean() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のコンストラクタ
HelperBeanを新規に生成します。
HelperBeanException - exception jp.co.intra_mart.framework.base.web.bean.HelperBeanException.
HelperBean内で発生した例外です。
HelperBeanException() - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
詳細メッセージを指定しないで HelperBeanException を構築します。
HelperBeanException(String) - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
指定された詳細メッセージを持つ HelperBeanException を構築します。
HelperBeanException(String, Throwable) - class jp.co.intra_mart.framework.base.web.bean.HelperBeanException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ HelperBeanException を構築します。
HelperBeanTEI - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI.
HelperBeanタグの拡張情報です。
HelperBeanTEI() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のコンストラクタ
HelperBeanTEIを新規に生成します。
HelperBeanTag - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag.
HelperBeanタグです。
HelperBeanTag() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のコンストラクタ
HelperBeanTagを新規に生成します。
HelperBeanTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo.
HelperBeanTagのBeanInfoです。
HelperBeanTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo のコンストラクタ
HelperBeanTagBeanInfoを新規に生成します。
HttpSessionFactory - class jp.co.intra_mart.framework.base.session.HttpSessionFactory.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
HttpSessionFactory() - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のコンストラクタ
推奨されていません。 HttpSessionFactoryを新規に生成します。
HttpSessionObject - class jp.co.intra_mart.framework.base.session.HttpSessionObject.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
HttpSessionObject(HttpSession) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のコンストラクタ
推奨されていません。 HttpSessionObjectを新規に生成します。

I

I18nAttributes - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes.
国際化の属性です。
I18nAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のコンストラクタ
I18nAttributesを新規に生成します。
ID - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数
ID - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数
ID - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
ID - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
ID - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
ID_SERVICE_SECURITY_FILTER - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の static 変数
リクエストに登録するServiceServletFilterの属性名
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.INTRAMART_URL_NAMEを使用してください。
INTRAMART_URL_NAME - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 セッションに登録するintra-martのサーブレットのURLの属性名
IllegalSessionException - exception jp.co.intra_mart.framework.base.session.IllegalSessionException.
セッション情報取得の失敗や不正なセッションを検出した場合にスローされます。
IllegalSessionException() - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
詳細メッセージを指定しないで IllegalSessionException を構築します。
IllegalSessionException(String) - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
指定された詳細メッセージを持つ IllegalSessionException を構築します。
IllegalSessionException(String, Throwable) - class jp.co.intra_mart.framework.base.session.IllegalSessionException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSessionException を構築します。
IllegalSystemException - exception jp.co.intra_mart.framework.system.exception.IllegalSystemException.
想定外の例外が発生したときの例外です。
IllegalSystemException() - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
詳細メッセージを指定しないで IllegalSystemException を構築します。
IllegalSystemException(String) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
指定された詳細メッセージを持つ IllegalSystemException を構築します。
IllegalSystemException(Throwable) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
この例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IllegalSystemException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.IllegalSystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ IllegalSystemException を構築します。
IntramartConnectFilter - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter.
推奨されていません。 この機能は廃止されました。
IntramartConnectFilter() - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のコンストラクタ
推奨されていません。
IntramartConnectServlet - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet.
推奨されていません。 この機能は廃止されました。
IntramartConnectServlet() - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のコンストラクタ
推奨されていません。 IntramartConnectServletを新規に生成します。
IntramartDBConnector - class jp.co.intra_mart.framework.base.data.IntramartDBConnector.
推奨されていません。 このクラスではなくLoginGroupDBConnectorまたは SystemDBConnectorを使用してください。
IntramartDBConnector() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のコンストラクタ
推奨されていません。 IntramartDBConnectorを新規に生成します。
IntramartDBDAO - class jp.co.intra_mart.framework.base.data.IntramartDBDAO.
推奨されていません。 このクラスではなくLoginGroupDBDAOまたは SystemDBDAOを使用してください。
IntramartDBDAO() - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のコンストラクタ
推奨されていません。 IntramartDBDAOを新規に生成します。
IntramartFileServerConnector - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector.
intra-martのStorageサービスに接続するデータコネクタです。
IntramartFileServerConnector() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のコンストラクタ
IntramartFileServerConnectorを新規に生成します。
IntramartFileServerDAO - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO.
intra-martのStorageサービスを使用する場合のDAOです。
IntramartFileServerDAO() - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のコンストラクタ
IntramartFileServerDAOを新規に生成します。
IntramartLocaleFilter - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter.
セッションにロケールを設定します。
IntramartLocaleFilter() - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のコンストラクタ
IntramartLogAgent - class jp.co.intra_mart.framework.system.log.IntramartLogAgent.
intra-mart で管理されているログに出力するログエージェントです。
IntramartLogAgent() - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のコンストラクタ
IntramartLogAgentを新規に生成します。
IntramartMessagePropertyHandler - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler.
イントラマートで設定されたメッセージにアクセスするメッセージプロパティハンドラです。
IntramartMessagePropertyHandler() - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のコンストラクタ
IntramartMessagePropertyHandlerを新規に生成します。
IntramartPageBaseTransition - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition.
ページベースの画面に遷移する場合に使用するトランジションです。
IntramartPageBaseTransition() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のコンストラクタ
IntramartPageBaseTransitionを新規に生成します。
IntramartSessionFactory - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
IntramartSessionFactory() - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のコンストラクタ
推奨されていません。 IntramartSessionFactoryを新規に生成します。
IntramartSessionObject - class jp.co.intra_mart.framework.base.session.IntramartSessionObject.
推奨されていません。 このクラスは互換性のために残されています。HttpSessionを直接利用するようにしてください。
IntramartSessionObject(SessionMemory) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のコンストラクタ
推奨されていません。 IntramartSessionObjectを生成します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.EncodingFilter のメソッド
エンコーディング用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.FileUploadFilter のメソッド
ファイルアップロード用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter のメソッド
推奨されていません。 フィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet のメソッド
推奨されていません。 このサーブレットを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter のメソッド
ロケール用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.LocaleFilter のメソッド
ロケール用のフィルタを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のメソッド
このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.base.service.ServiceServlet のメソッド
サーブレットを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.base.session.SessionFilter のメソッド
セッション用のフィルタを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のメソッド
プロパティハンドラを初期化します。
init() - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
HelperBeanを初期化します。
init(FilterConfig) - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter のメソッド
推奨されていません。 このフィルタを初期化します。
init(ServletConfig) - class jp.co.intra_mart.framework.presentation.PresentationServlet のメソッド
サーブレットを初期化します。
init(ControllerConverterConfig) - interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter のメソッド
ControllerConverterを初期化します。
init(ControllerConverterConfig) - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter のメソッド
SimpleControllerConverterを初期化します。
init(ForwardSelectorConfig) - interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector のメソッド
ForwardSelectorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.presentation.validator.FormatValidator のメソッド
FormatValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.presentation.validator.LengthValidator のメソッド
LengthValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator のメソッド
NumericRangeValidatorを初期化します。
init(ValidatorConfig) - class jp.co.intra_mart.framework.presentation.validator.NumericValidator のメソッド
NumericValidatorを初期化します。
init(ValidatorConfig) - interface jp.co.intra_mart.framework.presentation.validator.Validator のメソッド
Validatorを初期化します。
init(ViewConverterConfig) - interface jp.co.intra_mart.framework.presentation.view.ViewConverter のメソッド
ViewConverterを初期化します。
init(LogAgentParam[]) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(LogAgentParam[]) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
初期化します。
init(LogAgentParam[]) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler のメソッド
プロパティハンドラを初期化します。
init(PropertyParam[]) - interface jp.co.intra_mart.framework.system.property.PropertyHandler のメソッド
プロパティハンドラを初期化します。
initParam(String, String) - interface jp.co.intra_mart.framework.base.event.EventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のメソッド
初期パラメータを設定します。
initParam(String, String) - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のメソッド
初期パラメータを設定します。
isDynamic() - interface jp.co.intra_mart.framework.base.data.DataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.event.EventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のメソッド
再設定可能かどうかをチェックします。
isDynamic() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isDynamic() - interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler のメソッド
プロパティの動的読み込みが可能かどうか調べます。
isEncodeRequired() - class jp.co.intra_mart.framework.base.session.HttpSessionFactory のメソッド
推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEncodeRequired() - class jp.co.intra_mart.framework.base.session.IntramartSessionFactory のメソッド
推奨されていません。 セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isEncodeRequired() - interface jp.co.intra_mart.framework.base.session.SessionFactory のメソッド
セッション情報をURLに含めてエンコードする必要があるかどうか調べます。
isSelected(Option) - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
指定された選択肢が選択済かどうか判定します。
isSelected() - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
この選択肢が選択済であるかどうかを判定します。
isSelected(Option) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
指定された選択肢が選択済かどうか判定します。
isSelected(Option) - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem のメソッド
指定された選択肢が選択済かどうか判定します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.FormTEI のメソッド
Formタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.FrameTEI のメソッド
Frameタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI のメソッド
HelperBeanタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.LinkTEI のメソッド
Linkタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.MessageTEI のメソッド
Messageタグに指定された内容の正当性を検証します。
isValid(TagData) - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI のメソッド
Linkタグに指定された内容の正当性を検証します。

J

JDBCConnector - class jp.co.intra_mart.framework.base.data.JDBCConnector.
推奨されていません。 JDBCを直接扱わず、DataSourceを使用するようにしてください。
JDBCConnector() - class jp.co.intra_mart.framework.base.data.JDBCConnector のコンストラクタ
推奨されていません。 新規のJDBCConnectorを生成します。
jp.co.intra_mart.framework.base.data - package jp.co.intra_mart.framework.base.data
データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event - package jp.co.intra_mart.framework.base.event
イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message - package jp.co.intra_mart.framework.base.message
メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service - package jp.co.intra_mart.framework.base.service
サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session - package jp.co.intra_mart.framework.base.session
セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util - package jp.co.intra_mart.framework.base.util
jp.co.intra_mart.framework.base.web.bean - package jp.co.intra_mart.framework.base.web.bean
JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag - package jp.co.intra_mart.framework.base.web.tag
J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute - package jp.co.intra_mart.framework.base.web.tag.attribute
タグ属性のパッケージです。
jp.co.intra_mart.framework.base.web.util - package jp.co.intra_mart.framework.base.web.util
Web上で使用するユーティリティのパッケージです。
jp.co.intra_mart.framework.presentation - package jp.co.intra_mart.framework.presentation
Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller - package jp.co.intra_mart.framework.presentation.controller
入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward - package jp.co.intra_mart.framework.presentation.forward
遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.service - package jp.co.intra_mart.framework.presentation.service
サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator - package jp.co.intra_mart.framework.presentation.validator
検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view - package jp.co.intra_mart.framework.presentation.view
出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception - package jp.co.intra_mart.framework.system.exception
J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log - package jp.co.intra_mart.framework.system.log
J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message - package jp.co.intra_mart.framework.system.message
メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property - package jp.co.intra_mart.framework.system.property
プロパティ取得に関連するパッケージです。

K

KEY - class jp.co.intra_mart.framework.system.property.DefaultPropertyManager の static 変数
プロパティマネージャを指定するキー
KEY - class jp.co.intra_mart.framework.system.property.PropertyManager の static 変数
プロパティマネージャを指定するキー
KEY - class jp.co.intra_mart.framework.system.property.XmlPropertyManager の static 変数
プロパティマネージャを指定するキー
KEY_DRIVER - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベースドライバのキー
KEY_JNDI_NAME - class jp.co.intra_mart.framework.base.data.DataSourceConnector の static 変数
DataSourceのJNDI名のキー
KEY_PASSWORD - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベース接続ユーザパスワードのキー
KEY_URL - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベースURLのキー
KEY_USERNAME - class jp.co.intra_mart.framework.base.data.JDBCConnector の static 変数
推奨されていません。 データベース接続ユーザ名のキー

L

LEVEL_DEBUG - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
DEBUG時に出力するレベルです。
LEVEL_ERROR - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
例外を出力するレベルです。
LEVEL_INFO - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
情報を出力するレベルです。
LEVEL_WARNNING - interface jp.co.intra_mart.framework.system.log.LogConstant の static 変数
警告を出力するレベルです。
LICENSE_PATH - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 Append-Product定義ファイルのアクセス権記述子
LICENSE_PATH - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
Append-Product定義ファイルのアクセス権記述子
LISTENER_PARAM - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory の static 変数
イベントリスナーのクラス名のパラメータ名
LISTENER_PARAM - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory の static 変数
イベントリスナーのクラス名のパラメータ名
LOG_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.system.log.LogManager の static 変数
ログプロパティハンドラのキー
LT_GROUP - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
グループマネージャ
LT_SUPER - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
スーパーユーザ
LT_USER - class jp.co.intra_mart.framework.base.util.UserInfoUtil の static 変数
ユーザ
LengthValidator - class jp.co.intra_mart.framework.presentation.validator.LengthValidator.
文字列の長さをチェックします。
LengthValidator() - class jp.co.intra_mart.framework.presentation.validator.LengthValidator のコンストラクタ
LinkTEI - class jp.co.intra_mart.framework.base.web.tag.LinkTEI.
Linkタグの拡張情報です。
LinkTEI() - class jp.co.intra_mart.framework.base.web.tag.LinkTEI のコンストラクタ
LinkTEIを新規に生成します。
LinkTag - class jp.co.intra_mart.framework.base.web.tag.LinkTag.
LINKタグです。
LinkTag() - class jp.co.intra_mart.framework.base.web.tag.LinkTag のコンストラクタ
LinkTagを新規に生成します。
LinkTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo.
LinkTagのBeanInfoです。
LinkTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo のコンストラクタ
LinkTagBeanInfoを新規に生成します。
LocaleFilter - class jp.co.intra_mart.framework.base.service.LocaleFilter.
リクエストのロケールを設定します。
LocaleFilter() - class jp.co.intra_mart.framework.base.service.LocaleFilter のコンストラクタ
LogAgent - interface jp.co.intra_mart.framework.system.log.LogAgent.
ログに出力するエージェントです。
LogAgentParam - class jp.co.intra_mart.framework.system.log.LogAgentParam.
ログエージェントの初期パラメータです。
LogAgentParam() - class jp.co.intra_mart.framework.system.log.LogAgentParam のコンストラクタ
LogAgentParamを新規に生成します。
LogConstant - interface jp.co.intra_mart.framework.system.log.LogConstant.
ログフレームワークで使用される定数値です。
LogManager - class jp.co.intra_mart.framework.system.log.LogManager.
ログマネージャです。
LogPropertyException - exception jp.co.intra_mart.framework.system.log.LogPropertyException.
ログプロパティ取得時の例外です。
LogPropertyException() - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
詳細メッセージを指定しないで LogPropertyException を構築します。
LogPropertyException(String) - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
指定された詳細メッセージを持つ LogPropertyException を構築します。
LogPropertyException(String, Throwable) - class jp.co.intra_mart.framework.system.log.LogPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ LogPropertyException を構築します。
LogPropertyHandler - interface jp.co.intra_mart.framework.system.log.LogPropertyHandler.
ログフレームワークで使用するプロパティハンドラです。
LoginGroupDBConnector - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector.
イントラマートで設定されているDBコネクションです。
LoginGroupDBConnector() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のコンストラクタ
LoginGroupDBConnectorを新規に生成します。
LoginGroupDBDAO - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO.
イントラマートで設定されたDBへアクセスするDAOです。
LoginGroupDBDAO() - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のコンストラクタ
IntramartDBDAOを新規に生成します。
lockSession(String) - class jp.co.intra_mart.framework.presentation.PresentationManager のメソッド
セッションをロックします。

M

MANAGER_CLASS_KEY - class jp.co.intra_mart.framework.presentation.PresentationManager の static 変数
PresentationManagerの実装クラス名が記述されているキー
MESSAGE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.message.MessageManager の static 変数
メッセージプロパティハンドラのキー
MESSAGE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.system.message.MessageManager の static 変数
メッセージプロパティハンドラのキー
MessageManager - class jp.co.intra_mart.framework.base.message.MessageManager.
メッセージマネージャです。
MessageManager - class jp.co.intra_mart.framework.system.message.MessageManager.
メッセージを制御します。
MessageManagerException - exception jp.co.intra_mart.framework.base.message.MessageManagerException.
サービスマネージャ設定時の例外です。
MessageManagerException() - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String) - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.message.MessageManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
MessageManagerException - exception jp.co.intra_mart.framework.system.message.MessageManagerException.
メッセージマネージャに関連する例外です。
MessageManagerException() - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
詳細メッセージを指定しないで MessageManagerException を構築します。
MessageManagerException(String) - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
指定された詳細メッセージを持つ MessageManagerException を構築します。
MessageManagerException(String, Throwable) - class jp.co.intra_mart.framework.system.message.MessageManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessageManagerException を構築します。
MessageParamTag - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag.
メッセージの生成で使用するパラメータを設定します。
MessageParamTag() - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のコンストラクタ
ParamTagを新規に生成します。
MessagePropertyException - exception jp.co.intra_mart.framework.base.message.MessagePropertyException.
メッセージプロパティ取得時の例外です。
MessagePropertyException() - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String) - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
MessagePropertyException - exception jp.co.intra_mart.framework.system.message.MessagePropertyException.
メッセージプロパティハンドラに関連する例外です。
MessagePropertyException() - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
詳細メッセージを指定しないで MessagePropertyException を構築します。
MessagePropertyException(String) - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージを持つ MessagePropertyException を構築します。
MessagePropertyException(String, Throwable) - class jp.co.intra_mart.framework.system.message.MessagePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MessagePropertyException を構築します。
MessagePropertyHandler - interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler.
メッセージの設定情報に接続するクラスです。
MessagePropertyHandler - interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler.
メッセージに関連するプロパティを取得します。
MessagePropertyParam - class jp.co.intra_mart.framework.system.message.MessagePropertyParam.
メッセージプロパティハンドラの初期パラメータです。
MessagePropertyParam() - class jp.co.intra_mart.framework.system.message.MessagePropertyParam のコンストラクタ
MessagePropertyParamを新規に生成します。
MessageTEI - class jp.co.intra_mart.framework.base.web.tag.MessageTEI.
Messageタグの拡張情報です。
MessageTEI() - class jp.co.intra_mart.framework.base.web.tag.MessageTEI のコンストラクタ
MessageTag - class jp.co.intra_mart.framework.base.web.tag.MessageTag.
Messageタグです。
MessageTag() - class jp.co.intra_mart.framework.base.web.tag.MessageTag のコンストラクタ
MessageTagを新規に生成します。
MismatchException - exception jp.co.intra_mart.framework.presentation.MismatchException.
キーが重複しているときに発生する例外です。
MismatchException() - class jp.co.intra_mart.framework.presentation.MismatchException のコンストラクタ
詳細メッセージを指定しないで DuplicateException を構築します。
MismatchException(String) - class jp.co.intra_mart.framework.presentation.MismatchException のコンストラクタ
指定された詳細メッセージを持つ DuplicateException を構築します。
MismatchException(String, Throwable) - class jp.co.intra_mart.framework.presentation.MismatchException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ DuplicateException を構築します。
MultiSelectableItem - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem.
複数の選択肢を選択することが可能な項目です。
MultiSelectableItem() - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のコンストラクタ

N

NameFormatException - exception jp.co.intra_mart.framework.presentation.NameFormatException.
名前が不正であることを示します。
NameFormatException() - class jp.co.intra_mart.framework.presentation.NameFormatException のコンストラクタ
詳細メッセージを指定しないで NameFormatException を構築します。
NameFormatException(String) - class jp.co.intra_mart.framework.presentation.NameFormatException のコンストラクタ
指定された詳細メッセージを持つ NameFormatException を構築します。
NameFormatException(String, Throwable) - class jp.co.intra_mart.framework.presentation.NameFormatException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ NameFormatException を構築します。
NumericRangeValidator - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator.
数値の範囲をチェックします。
NumericRangeValidator() - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator のコンストラクタ
NumericValidator - class jp.co.intra_mart.framework.presentation.validator.NumericValidator.
数値（整数）として妥当であるかどうかをチェックします。
NumericValidator() - class jp.co.intra_mart.framework.presentation.validator.NumericValidator のコンストラクタ

O

OBJECT_PARAM_NAME - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter の static 変数
コントローラオブジェクトのクラス名を設定するパラメータ名
Option - class jp.co.intra_mart.framework.presentation.view.Option.
選択項目における選択肢です。
Option() - class jp.co.intra_mart.framework.presentation.view.Option のコンストラクタ

P

PARAM_APPLICATION - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのアプリケーションのパラメータ名
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
アプリケーション
PARAM_APPLICATION - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
アプリケーション
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのクラスのパラメータ名
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
クラス
PARAM_APPLICATION_CLASS - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
クラス
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのパラメータのパラメータ名
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
パラメータ
PARAM_APPLICATION_PARAM - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
パラメータ
PARAM_ARGUMENT - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数のリクエストパラメータ名
PARAM_ARGUMENT - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENTを使用してください。
PARAM_ARGUMENT - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 ページ引数のリクエストパラメータ名
PARAM_ARGUMENT_DELIMITER - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数のデリミタ
PARAM_ARGUMENT_DELIMITER - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_DELIMITERを使用してください。
PARAM_ARGUMENT_OPERATOR - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ページ引数の演算子
PARAM_ARGUMENT_OPERATOR - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_ARGUMENT_OPERATORを使用してください。
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_BUNDLE - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルのバンドルのパラメータ名
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのデフォルトのパラメータ名
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
デフォルト
PARAM_DEFAULT - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
デフォルト
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_DYNAMIC - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler の static 変数
プロパティファイルの再読み込み可能のパラメータ名
PARAM_ERROR_PAGE - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter の static 変数
エラーページパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_FILE_DIR - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler の static 変数
プロパティファイルのファイルパスのパラメータ名
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ログイングループIDのリクエストパラメータ名
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_GROUP_IDを使用してください。
PARAM_LOGIN_GROUP_ID - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 ログイングループIDのリクエストパラメータ名
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 ログインユーザIDのリクエストパラメータ名
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_LOGIN_USER_IDを使用してください。
PARAM_LOGIN_USER_ID - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 ログインユーザIDのリクエストパラメータ名
PARAM_MAX - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
文字列長の最大値が設定されているパラメータ名
PARAM_MAX - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の static 変数
数値の最大値が設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.presentation.validator.FormatValidator の static 変数
不正文字列である場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の static 変数
数値が範囲外の場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE - class jp.co.intra_mart.framework.presentation.validator.NumericValidator の static 変数
数値として妥当ではない場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE_LONG - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
文字列長が長い場合のメッセージが設定されているパラメータ名
PARAM_MESSAGE_SHORT - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
文字列長が短い場合のメッセージが設定されているパラメータ名
PARAM_MIN - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
文字列長の最小値が設定されているパラメータ名
PARAM_MIN - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の static 変数
数値の最小値が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.presentation.validator.FormatValidator の static 変数
検証対象となるコントローラオブジェクトのプロパティ名を示すパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.presentation.validator.LengthValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_PROPERTY - class jp.co.intra_mart.framework.presentation.validator.NumericValidator の static 変数
検証対象のプロパティ名が設定されているパラメータ名
PARAM_REFERER - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 参照元URLのリクエストパラメータ名
PARAM_REFERER - class jp.co.intra_mart.framework.base.service.IntramartConnectServlet の static 変数
推奨されていません。 このパラメータではなくIntramartConnectFilter.PARAM_REFERERを使用してください。
PARAM_REFERER - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 参照元URLのリクエストパラメータ名
PARAM_REGEX - class jp.co.intra_mart.framework.presentation.validator.FormatValidator の static 変数
正規表現によるフォーマットが設定されているパラメータ名
PARAM_SECURITY_EXT - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter の static 変数
推奨されていません。 セキュリティの拡張子
PARAM_WINDOW_NAME - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter の static 変数
推奨されていません。 基本ウィンドウ名
PREFIX_ATTRIBUTE - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
HttpServletRequestにおけるURLのプレフィックスの保存先
P_ID_CONNECTOR_CLASS - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数
P_ID_CONNECTOR_NAME - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数
P_ID_CONNECT_NAME - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数
P_ID_DAO_CLASS - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数
P_ID_DAO_CONNECTOR_NAME - class jp.co.intra_mart.framework.base.data.DaoModel の static 変数
P_ID_EVENT_KEY - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_EVENT_NAME - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_FACTORY_CLASS - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
P_ID_FACTORY_PARAM - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
P_ID_PARAM_NAME - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
P_ID_PARAM_VALUE - class jp.co.intra_mart.framework.base.event.EventFactoryModel の static 変数
P_ID_POST_TRIGGER - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_PRE_TRIGGER - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
P_ID_RESOURCE_NAME - class jp.co.intra_mart.framework.base.data.ConnectorModel の static 変数
P_ID_RESOURCE_NAME - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
P_ID_RESOURCE_PARAM - class jp.co.intra_mart.framework.base.data.ResourceModel の static 変数
P_ID_TRIGGER_CLASS - class jp.co.intra_mart.framework.base.event.EventGroupModel の static 変数
PanelBasedViewObject - interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject.
パネルコンポーネントの表示に関連するオブジェクトです。
ParamTag - class jp.co.intra_mart.framework.base.web.tag.ParamTag.
リンク先、遷移先に渡すパラメータを設定します。
ParamTag() - class jp.co.intra_mart.framework.base.web.tag.ParamTag のコンストラクタ
ParamTagを新規に生成します。
ParameterSendable - interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable.
パラメータを渡すことができるタグです。
PresentationConnectFilter - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter.
推奨されていません。 この機能は廃止されました。
PresentationConnectFilter() - class jp.co.intra_mart.framework.presentation.PresentationConnectFilter のコンストラクタ
推奨されていません。 ライセンス情報の設定
PresentationManager - class jp.co.intra_mart.framework.presentation.PresentationManager.
プレゼンテーションマネージャです。
PresentationManager() - class jp.co.intra_mart.framework.presentation.PresentationManager のコンストラクタ
PresentationManagerを新規に生成します。
PresentationManagerException - exception jp.co.intra_mart.framework.presentation.PresentationManagerException.
PresentationManager設定時の例外です。
PresentationManagerException() - class jp.co.intra_mart.framework.presentation.PresentationManagerException のコンストラクタ
詳細メッセージを指定しないで PresentationManagerException を構築します。
PresentationManagerException(String) - class jp.co.intra_mart.framework.presentation.PresentationManagerException のコンストラクタ
指定された詳細メッセージを持つ PresentationManagerException を構築します。
PresentationManagerException(String, Throwable) - class jp.co.intra_mart.framework.presentation.PresentationManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationManagerException を構築します。
PresentationPropertyException - exception jp.co.intra_mart.framework.presentation.PresentationPropertyException.
PresentationProperty取得時の例外です。
PresentationPropertyException() - class jp.co.intra_mart.framework.presentation.PresentationPropertyException のコンストラクタ
詳細メッセージを指定しないで PresentationPropertyException を構築します。
PresentationPropertyException(String) - class jp.co.intra_mart.framework.presentation.PresentationPropertyException のコンストラクタ
指定された詳細メッセージを持つ PresentationPropertyException を構築します。
PresentationPropertyException(String, Throwable) - class jp.co.intra_mart.framework.presentation.PresentationPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PresentationPropertyException を構築します。
PresentationPropertyHandler - interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler.
プレゼンテーションフレームワークのプロパティ設定のハンドラです。
PresentationServiceController - class jp.co.intra_mart.framework.presentation.service.PresentationServiceController.
Presentation Framework用のServiceControllerです。
PresentationServiceController() - class jp.co.intra_mart.framework.presentation.service.PresentationServiceController のコンストラクタ
PresentationServlet - class jp.co.intra_mart.framework.presentation.PresentationServlet.
プレゼンテーションフレームワークのサーブレットです。
PresentationServlet() - class jp.co.intra_mart.framework.presentation.PresentationServlet のコンストラクタ
PropertyConfigModel - class jp.co.intra_mart.framework.system.property.PropertyConfigModel.
データモデルクラスです。
PropertyConfigModel() - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のコンストラクタ
PropertyHandler - interface jp.co.intra_mart.framework.system.property.PropertyHandler.
プロパティにアクセスするインタフェースです。
PropertyHandlerException - exception jp.co.intra_mart.framework.system.property.PropertyHandlerException.
プロパティハンドラの情報取得時の例外です。
PropertyHandlerException() - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
詳細メッセージを指定しないで PropertyHandlerException を構築します。
PropertyHandlerException(String) - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
指定された詳細メッセージを持つ PropertyHandlerException を構築します。
PropertyHandlerException(String, Throwable) - class jp.co.intra_mart.framework.system.property.PropertyHandlerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyHandlerException を構築します。
PropertyHandlerParam - class jp.co.intra_mart.framework.system.property.PropertyHandlerParam.
プロパティハンドラを生成する時の初期パラメータです。
PropertyHandlerParam() - class jp.co.intra_mart.framework.system.property.PropertyHandlerParam のコンストラクタ
PropertyHandlerParamを新規に生成します。
PropertyManager - class jp.co.intra_mart.framework.system.property.PropertyManager.
システム設定の情報を管理します。
PropertyManager() - class jp.co.intra_mart.framework.system.property.PropertyManager のコンストラクタ
プロパティマネージャのコンストラクタです。
PropertyManagerException - exception jp.co.intra_mart.framework.system.property.PropertyManagerException.
プロパティマネージャの設定時の例外です。
PropertyManagerException() - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
詳細メッセージを指定しないで PropertyManagerException を構築します。
PropertyManagerException(String) - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
指定された詳細メッセージを持つ PropertyManagerException を構築します。
PropertyManagerException(String, Throwable) - class jp.co.intra_mart.framework.system.property.PropertyManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ PropertyManagerException を構築します。
PropertyModel - class jp.co.intra_mart.framework.system.property.PropertyModel.
プロパティモデルクラスです。
PropertyModel() - class jp.co.intra_mart.framework.system.property.PropertyModel のコンストラクタ
PropertyParam - class jp.co.intra_mart.framework.system.property.PropertyParam.
プロパティのパラメータを表現する汎用的なクラスです。
PropertyParam() - class jp.co.intra_mart.framework.system.property.PropertyParam のコンストラクタ
PropertyParamを新規に生成します。
printAttribute(String, String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のメソッド
属性を出力します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
属性の内容を表示します。
printAttributes() - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性の内容を表示します。
printOnClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickを出力します。
printOnDblClick() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onDblClickを出力します。
printOnKeyDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownを出力します。
printOnKeyPress() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressを出力します。
printOnKeyUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpを出力します。
printOnMouseDown() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownを出力します。
printOnMouseMove() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveを出力します。
printOnMouseOut() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutを出力します。
printOnMouseOver() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverを出力します。
printOnMouseUp() - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpを出力します。
printStackTrace() - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド
printStackTrace(PrintStream) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド
printStackTrace(PrintWriter) - class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException のメソッド
printStackTrace() - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
printStackTrace(PrintStream) - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
printStackTrace(PrintWriter) - class jp.co.intra_mart.framework.system.exception.FrameworkException のメソッド
printURL(String) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のメソッド
URLを出力します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
接続先のリソースを追加します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
接続先のリソースを追加します。
putResource(String, ResourceParam[]) - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 接続先のリソースを追加します。

R

REQUEST_INFO_ATTRIBUTE - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
HttpServletRequestにおける RequestInfoの保存先
REQUEST_SEPARATOR - class jp.co.intra_mart.framework.base.service.ServiceServlet の static 変数
リクエストの情報を分割するセパレータ
REQUEST_SEPARATOR - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
リクエストの情報を分割するセパレータ
RequestException - exception jp.co.intra_mart.framework.base.service.RequestException.
リクエストの内容に関連する間違いがある場合の例外です。
RequestException() - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
詳細メッセージを指定しないで RequestException を構築します。
RequestException(String) - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
指定された詳細メッセージを持つ RequestException を構築します。
RequestException(String, Throwable) - class jp.co.intra_mart.framework.base.service.RequestException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestException を構築します。
RequestFormatException - exception jp.co.intra_mart.framework.presentation.controller.RequestFormatException.
フォーマットが不正であるときの例外です。
RequestFormatException() - class jp.co.intra_mart.framework.presentation.controller.RequestFormatException のコンストラクタ
詳細メッセージを指定しないで RequestFormatException を構築します。
RequestFormatException(String) - class jp.co.intra_mart.framework.presentation.controller.RequestFormatException のコンストラクタ
指定された詳細メッセージを持つ RequestFormatException を構築します。
RequestFormatException(String, Throwable) - class jp.co.intra_mart.framework.presentation.controller.RequestFormatException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
RequestInfo - interface jp.co.intra_mart.framework.presentation.RequestInfo.
リクエストに対する情報を取得します。
ResourceModel - class jp.co.intra_mart.framework.base.data.ResourceModel.
Resource情報を管理するクラスです。
ResourceModel() - class jp.co.intra_mart.framework.base.data.ResourceModel のコンストラクタ
ResourceParam - class jp.co.intra_mart.framework.base.data.ResourceParam.
データコネクタの初期パラメータです。
ResourceParam() - class jp.co.intra_mart.framework.base.data.ResourceParam のコンストラクタ
ResourceParamを新規に生成します。
release() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
データストアの資源を解放します。
release() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
データストアの資源を解放します。
removeAttribute(String) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを削除します。
removeAttribute(String) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを削除します。
removeAttribute(String) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを削除します。
resources - class jp.co.intra_mart.framework.base.data.DBConnector の変数
リソース一覧
resources - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector の変数
リソース一覧
rollback() - class jp.co.intra_mart.framework.base.data.DBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataAccessController のメソッド
すべてのデータコネクタをロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.DataSourceConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.IntramartDBConnector のメソッド
推奨されていません。 ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.JDBCConnector のメソッド
推奨されていません。 ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector のメソッド
ロールバックします。
rollback() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のメソッド
ロールバックします。

S

SERVICE_EXTENSION_KEY - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
拡張子を指定するキー
SERVICE_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.service.ServiceManager の static 変数
サービスプロパティハンドラのキー
SESSION_PROPERTY_HANDLER_KEY - class jp.co.intra_mart.framework.base.session.SessionManager の static 変数
セッションプロパティハンドラのキー
START_ID - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
スタートポイントに入る場合のID
SUFFIX_ATTRIBUTE - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
HttpServletRequestにおけるURLのサフィックスの保存先
SelectableItem - class jp.co.intra_mart.framework.presentation.view.SelectableItem.
選択肢を持つ項目です。
SelectableItem() - class jp.co.intra_mart.framework.presentation.view.SelectableItem のコンストラクタ
ServiceController - interface jp.co.intra_mart.framework.base.service.ServiceController.
クライアントからの入力に対する処理を行います。
ServiceControllerAdapter - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter.
いくつかのユーティリティメソッドと空のメソッドを実装したサービスコントローラです。
ServiceControllerAdapter() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のコンストラクタ
ServiceControllerAdapterを新規に生成します。
ServiceControllerException - exception jp.co.intra_mart.framework.base.service.ServiceControllerException.
サービスコントローラに関連する例外です。
ServiceControllerException() - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
詳細メッセージを指定しないで ServiceControllerException を構築します。
ServiceControllerException(String) - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
指定された詳細メッセージを持つ ServiceControllerException を構築します。
ServiceControllerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceControllerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceControllerException を構築します。
ServiceManager - class jp.co.intra_mart.framework.base.service.ServiceManager.
サービスマネージャです。
ServiceManagerException - exception jp.co.intra_mart.framework.base.service.ServiceManagerException.
サービスマネージャ設定時の例外です。
ServiceManagerException() - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
詳細メッセージを指定しないで ServiceManagerException を構築します。
ServiceManagerException(String) - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
指定された詳細メッセージを持つ ServiceManagerException を構築します。
ServiceManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceManagerException を構築します。
ServicePropertyException - exception jp.co.intra_mart.framework.base.service.ServicePropertyException.
サービスプロパティ取得時の例外です。
ServicePropertyException() - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
詳細メッセージを指定しないで ServicePropertyException を構築します。
ServicePropertyException(String) - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
指定された詳細メッセージを持つ ServicePropertyException を構築します。
ServicePropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServicePropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServicePropertyException を構築します。
ServicePropertyHandler - interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler.
サービスの設定情報に接続するクラスです。
ServiceResult - interface jp.co.intra_mart.framework.base.service.ServiceResult.
サービスの処理結果です。
ServiceSecurityFilter - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter.
intra-mart画面を表示するURLの詐称をチェックするためのフィルタです。
ServiceSecurityFilter() - class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter のコンストラクタ
ServiceServlet - class jp.co.intra_mart.framework.base.service.ServiceServlet.
サービスを振り分けるサーブレットです。
ServiceServlet() - class jp.co.intra_mart.framework.base.service.ServiceServlet のコンストラクタ
ServiceServletを新規に生成します。
ServiceServletException - exception jp.co.intra_mart.framework.base.service.ServiceServletException.
サービスに関連する例外です。
ServiceServletException() - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
詳細メッセージを指定しないで ServiceServletException を構築します。
ServiceServletException(String) - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
指定された詳細メッセージを持つ ServiceServletException を構築します。
ServiceServletException(String, Throwable) - class jp.co.intra_mart.framework.base.service.ServiceServletException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ServiceServletException を構築します。
SessionFactory - interface jp.co.intra_mart.framework.base.session.SessionFactory.
セッションに関連するファクトリクラスとなるインタフェースです。
SessionFactoryException - exception jp.co.intra_mart.framework.base.session.SessionFactoryException.
セッションファクトリ内の例外です。
SessionFactoryException() - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
詳細メッセージを指定しないで SessionFactoryException を構築します。
SessionFactoryException(String) - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
指定された詳細メッセージを持つ SessionFactoryException を構築します。
SessionFactoryException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionFactoryException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionFactoryException を構築します。
SessionFilter - class jp.co.intra_mart.framework.base.session.SessionFilter.
セッション管理をします。
SessionFilter() - class jp.co.intra_mart.framework.base.session.SessionFilter のコンストラクタ
SessionManager - class jp.co.intra_mart.framework.base.session.SessionManager.
セッションマネージャです。
SessionManagerException - exception jp.co.intra_mart.framework.base.session.SessionManagerException.
セッションマネージャ内の例外です。
SessionManagerException() - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
詳細メッセージを指定しないで SessionManagerException を構築します。
SessionManagerException(String) - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
指定された詳細メッセージを持つ SessionManagerException を構築します。
SessionManagerException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionManagerException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionManagerException を構築します。
SessionObject - interface jp.co.intra_mart.framework.base.session.SessionObject.
セッションに関連する情報を持つオブジェクトです。
SessionObjectException - exception jp.co.intra_mart.framework.base.session.SessionObjectException.
セッションオブジェクト内の例外です。
SessionObjectException() - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
詳細メッセージを指定しないで SessionObjectException を構築します。
SessionObjectException(String) - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
指定された詳細メッセージを持つ SessionObjectException を構築します。
SessionObjectException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionObjectException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionObjectException を構築します。
SessionPropertyException - exception jp.co.intra_mart.framework.base.session.SessionPropertyException.
セッションプロパティ取得時の例外です。
SessionPropertyException() - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
詳細メッセージを指定しないで SessionPropertyException を構築します。
SessionPropertyException(String) - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
指定された詳細メッセージを持つ SessionPropertyException を構築します。
SessionPropertyException(String, Throwable) - class jp.co.intra_mart.framework.base.session.SessionPropertyException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SessionPropertyException を構築します。
SessionPropertyHandler - interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler.
セッションに関連するプロパティを取得します。
SimpleControllerConverter - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter.
リクエストの内容をコントローラオブジェクトにマッピングする単純なコントローラコンバータです。
SimpleControllerConverter() - class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter のコンストラクタ
SimplePanelBasedViewObject - class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject.
パネルコンポーネントの表示に関連するオブジェクトです。
SimplePanelBasedViewObject() - class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject のコンストラクタ
SimpleViewObject - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject.
単純なビューオブジェクトです。
SimpleViewObject() - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のコンストラクタ
SingleSelectableItem - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem.
単一の選択肢のみ選択することが可能な項目です。
SingleSelectableItem() - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem のコンストラクタ
StandardEJBEventListener - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener.
StandardEJBEventListenerAgentに接続するイベントリスナです。
StandardEJBEventListener(StandardEJBEventListenerAgentHome) - class jp.co.intra_mart.framework.base.event.StandardEJBEventListener のコンストラクタ
StandardEJBEventListenerを新規に生成します。
StandardEJBEventListenerAgent - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent.
EJBを利用するときのイベントリスナのリモートインタフェースです。
StandardEJBEventListenerAgentBean - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean.
EJBを利用する場合の抽象的なイベントリスナです。
StandardEJBEventListenerAgentBean() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean のコンストラクタ
StandardEJBEventListenerAgentBeanを新規に生成します。
StandardEJBEventListenerAgentHome - interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome.
StandardEJBEventListenerAgentのホームインタフェースです。
StandardEJBEventListenerFactory - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory.
標準的なEJB用のイベントリスナファクトリです。
StandardEJBEventListenerFactory() - class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory のコンストラクタ
StandardEJBEventListenerFactoryを新規に生成します。
StandardEventListener - class jp.co.intra_mart.framework.base.event.StandardEventListener.
汎用的なビジネスロジック用のクラスです。
StandardEventListener() - class jp.co.intra_mart.framework.base.event.StandardEventListener のコンストラクタ
StandardEventListenerFactory - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory.
通常のJavaクラスのイベントリスナを生成します。
StandardEventListenerFactory() - class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory のコンストラクタ
StandardEventListenerFactoryを新規に生成します。
SubmitLinkTag - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag.
サブミット専用のLINKタグです。
SubmitLinkTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のコンストラクタ
SubmitLinkTagを新規に生成します。
SubmitLinkTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo.
SubmitLinkTagのBeanInfoです。
SubmitLinkTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo のコンストラクタ
SubmitLinkTagBeanInfoを新規に生成します。
SubmitTEI - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI.
Submitタグの拡張情報です。
SubmitTEI() - class jp.co.intra_mart.framework.base.web.tag.SubmitTEI のコンストラクタ
SubmitTEIを新規に生成します。
SubmitTag - class jp.co.intra_mart.framework.base.web.tag.SubmitTag.
Submitタグです。
SubmitTag() - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のコンストラクタ
SubmitTagを新規に生成します。
SubmitTagBeanInfo - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo.
SubmitTagのBeanInfoです。
SubmitTagBeanInfo() - class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo のコンストラクタ
SubmitTagBeanInfoを新規に生成します。
SystemDBConnector - class jp.co.intra_mart.framework.base.data.SystemDBConnector.
イントラマートで設定されているDBコネクションです。
SystemDBConnector() - class jp.co.intra_mart.framework.base.data.SystemDBConnector のコンストラクタ
SystemDBConnectorを新規に生成します。
SystemDBDAO - class jp.co.intra_mart.framework.base.data.SystemDBDAO.
イントラマートで設定されたDBへアクセスするDAOです。
SystemDBDAO() - class jp.co.intra_mart.framework.base.data.SystemDBDAO のコンストラクタ
IntramartDBDAOを新規に生成します。
SystemException - exception jp.co.intra_mart.framework.system.exception.SystemException.
フレームワーク内で発生したシステム例外です。
SystemException() - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
詳細メッセージを指定しないで SystemException を構築します。
SystemException(String) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
指定された詳細メッセージを持つ SystemException を構築します。
SystemException(Throwable) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
この例外の発生原因となる例外を持つ SystemException を構築します。
SystemException(String, Throwable) - class jp.co.intra_mart.framework.system.exception.SystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ SystemException を構築します。
sendMessage(String, String, String) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - class jp.co.intra_mart.framework.system.log.DefaultLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - class jp.co.intra_mart.framework.system.log.IntramartLogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
メッセージを出力します。
sendMessage(String, String, String, Object) - interface jp.co.intra_mart.framework.system.log.LogAgent のメソッド
メッセージを出力します。
service() - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
入力に対する処理を実行します。
service() - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
入力に対する処理を実行します。
sessionContext - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean の変数
セッションコンテキスト
setAccept(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性acceptの値を設定します。
setAcceptcharset(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性accept-charsetの値を設定します。
setAccesskey(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
accesskeyを設定します。
setAccesskey(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
accesskeyを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性applicationの値を設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
applicationを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
アプリケーションを設定します。
setApplication(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性applicationの値を設定します。
setAttribute(String, Object) - class jp.co.intra_mart.framework.base.session.HttpSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを追加します。
setAttribute(String, Object) - class jp.co.intra_mart.framework.base.session.IntramartSessionObject のメソッド
推奨されていません。 指定された名前に対応するオブジェクトを追加します。
setAttribute(String, Object) - interface jp.co.intra_mart.framework.base.session.SessionObject のメソッド
指定された名前に対応するオブジェクトを追加します。
setCharset(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
charsetを設定します。
setClass(String) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
推奨されていません。 このメソッドではなくHelperBeanTag.setHelperclass(java.lang.String)メソッドを使用してください。
setClientType(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
クライアントタイプを設定する。
setColorPatternID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
カラーパターンIDを設定する。
setConnectInfo(DataConnector, String, String, String) - interface jp.co.intra_mart.framework.base.data.DAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.DAOAdapter のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.DBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartDBDAO のメソッド
推奨されていません。 データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO のメソッド
データリソースに接続する時の情報を設定します。
setConnectInfo(DataConnector, String, String, String) - class jp.co.intra_mart.framework.base.data.SystemDBDAO のメソッド
データリソースに接続する時の情報を設定します。
setCoords(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
coordsを設定します。
setCoords(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
coordsを設定します。
setDataPropertyHandler(DataPropertyHandler) - class jp.co.intra_mart.framework.base.data.DataConnector のメソッド
データプロパティハンドラを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性dirの値を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
dirを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
dirを設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性dirの値を設定します。
setDir(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性dirの値を取得します。
setDisplayName(String) - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
表示名を設定します。
setEncoding(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
エンコーディングを設定する。
setEnctype(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性enctypeの値を設定します。
setForm(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
ターゲットとなるフォーム名を設定します。
setFormObjects(Map) - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のメソッド
フォームオブジェクトのマップを設定します。
setFormclass(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性classの値を設定します。
setFrameClass(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
推奨されていません。 このメソッドではなくFrameTag.setFrameclass(String)メソッドを使用してください。
setFrameborder(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameborderを設定します。
setFrameclass(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
frameClassを設定します。
setHelperclass(String) - class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag のメソッド
クラス名を設定します。
setHreflang(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
hreflangを設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.EJBEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - interface jp.co.intra_mart.framework.base.event.EventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInTransaction(boolean) - class jp.co.intra_mart.framework.base.event.StandardEventListener のメソッド
このイベントリスナがトランザクションの中で実行されているかどうかの情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次の遷移先に渡す情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
次の遷移先に渡す情報を設定します。
setInformation() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次の遷移先に渡す情報を設定します。
setJNDIName(String) - class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory のメソッド
EJBEventListenerAgentHomeのJNDI名を設定します。
setKey(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
keyを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性langの値を設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
langを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
langを設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性langの値を設定します。
setLang(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes のメソッド
属性langの値を設定します。
setLinkClass(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
推奨されていません。 このメソッドではなくLinkTag.setLinkclass(String)メソッドを使用してください。
setLinkclass(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
linkClassを設定します。
setLinkclass(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
linkClassを設定します。
setListener(StandardEventListener) - class jp.co.intra_mart.framework.base.event.GenericEventListener のメソッド
イベント処理クラスを設定します。
setListenerName(String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory のメソッド
EJBEventListenerAgentBeanのクラス名を設定します。
setListenerName(String) - class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory のメソッド
EJBEventListenerAgentBeanのクラス名を設定します。
setLocale(Locale) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ユーザのロケールを設定する。
setLocale(String) - class jp.co.intra_mart.framework.base.web.tag.MessageTag のメソッド
localeを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログイングループIDを設定する。
setLoginTime(Date) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインした時間を設定する。
setLoginType(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインタイプを設定する。
setLongdesc(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
longdescを設定します。
setMarginheight(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginheightを設定します。
setMarginwidth(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
marginwidthを設定します。
setMessage(String) - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のメソッド
検証結果のメッセージを設定します。
setMethod(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性methodの値を設定します。
setName(String) - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
イベントトリガ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性nameの値を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータ名を設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
nameを設定します。
setName(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性nameを設定します。
setName(String) - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータ名を設定します。
setNoresize(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
noresizeを設定します。
setNumber(int) - class jp.co.intra_mart.framework.base.event.EventTriggerInfo のメソッド
ソート番号を設定します。
setOnClick(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onClickの値を設定します。
setOnDblClick(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性obDblClickの値を設定します。
setOnKeyDown(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyDownの値を設定します。
setOnKeyPress(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyPressの値を設定します。
setOnKeyUp(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onKeyUpの値を設定します。
setOnMouseDown(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseDownの値を設定します。
setOnMouseMove(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseMoveの値を設定します。
setOnMouseOut(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOutの値を設定します。
setOnMouseOver(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseOverの値を設定します。
setOnMouseUp(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes のメソッド
属性onMouseUpの値を設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onblurを設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onblurを設定します。
setOnblur(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onBlurを設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onClickの値を設定します。
setOnclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性obDblClickの値を設定します。
setOndblclick(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性obDblClickの値を設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
onfocusを設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
onfocusを設定します。
setOnfocus(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onFocusを設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyDownの値を設定します。
setOnkeydown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyDownの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyPressの値を設定します。
setOnkeypress(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyPressの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onKeyUpの値を設定します。
setOnkeyup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onKeyUpの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseDownの値を設定します。
setOnmousedown(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseDownの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseMoveの値を設定します。
setOnmousemove(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseMoveの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseout(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOutの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseover(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseOverの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
属性onMouseUpの値を設定します。
setOnmouseup(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性onMouseUpの値を設定します。
setOnreset(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onResetの値を設定します。
setOnsubmit(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性onSubmitの値を設定します。
setOption(Option[]) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
選択肢を設定します。
setOption(int, Option) - class jp.co.intra_mart.framework.presentation.view.SelectableItem のメソッド
選択肢を設定します。
setParent(SelectableItem) - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
この選択肢が含まれる選択項目を設定します。
setProperties(Map) - class jp.co.intra_mart.framework.system.property.PropertyConfigModel のメソッド
パラメータを設定します。
setRel(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを設定します。
setRequest(HttpServletRequest) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
リクエストを設定します。
setRequest(HttpServletRequest) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
リクエストを設定します。
setResponse(HttpServletResponse) - interface jp.co.intra_mart.framework.base.service.ServiceController のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
レスポンスを設定します。
setResponse(HttpServletResponse) - class jp.co.intra_mart.framework.base.web.bean.HelperBean のメソッド
レスポンスを設定します。
setResult(ServiceResult) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービス処理結果を設定します。
setRev(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
relを設定します。
setScrolling(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
scrollingを設定します。
setSecurityExt(String) - class jp.co.intra_mart.framework.base.service.IntramartConnectFilter のメソッド
推奨されていません。 セキュリティの拡張子を設定します。
setSelected(Option[]) - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
選択済みである選択肢を設定します。
setSelected(int, Option) - class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem のメソッド
選択済みである選択肢を設定します。
setSelected(Option) - class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem のメソッド
選択済の選択肢を設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性serviceの値を設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
serviceを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
serviceを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
サービスを設定します。
setService(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性serviceの値を設定します。
setServiceManager(ServiceManager) - class jp.co.intra_mart.framework.base.service.Transition のメソッド
サービスマネージャを設定します。
setSessionContext(SessionContext) - class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean のメソッド
関連するSessionContextを設定します。
setShape(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
shapeを設定します。
setShape(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
shapeを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性styleの値を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
styleを設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性styleの値を設定します。
setStyle(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性styleの値を設定します。
setSubPanelViewObjects(Map) - class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject のメソッド
サブパネルに対応するPanelBasedViewObjectを設定します。
setSubmitclass(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性classの値を設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
tabindexを設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
tabindexを設定します。
setTabindex(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
tabindexを設定します。
setTagClass(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性classの値を設定します。
setTagWriter(TagWriter) - class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes のメソッド
TagWriterを設定します。
setTarget(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性targetの値を設定します。
setTarget(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
targetを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.FormTag のメソッド
属性titleの値を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.FrameTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag のメソッド
titleを設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性titleの値を設定します。
setTitle(String) - class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes のメソッド
属性titleの値を設定します。
setType(String) - class jp.co.intra_mart.framework.base.web.tag.LinkTag のメソッド
typeを設定します。
setUserID(String) - class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo のメソッド
ログインユーザIDを設定する。
setValidationExceptionDetails(Collection) - class jp.co.intra_mart.framework.presentation.validator.ValidationException のメソッド
検証結果の詳細を設定します。
setValue(Object) - class jp.co.intra_mart.framework.base.web.tag.MessageParamTag のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.base.web.tag.ParamTag のメソッド
パラメータの値を設定します。
setValue(String) - class jp.co.intra_mart.framework.base.web.tag.SubmitTag のメソッド
属性valueを設定します。
setValue(String) - class jp.co.intra_mart.framework.presentation.view.Option のメソッド
値を設定します。
setValue(String) - class jp.co.intra_mart.framework.system.property.PropertyParam のメソッド
パラメータの値を設定します。
setViewInfo(Object) - class jp.co.intra_mart.framework.presentation.view.SimpleViewObject のメソッド
表示情報を設定します。

T

TOKEN_ATTRIBUTE - class jp.co.intra_mart.framework.presentation.PresentationServlet の static 変数
HttpServletRequestにおける次の画面のトークンの保存先
TYPE_DB - class jp.co.intra_mart.framework.system.log.IntramartLogAgent の static 変数
データベースログに出力する場合のカテゴリの種類
TagWriter - class jp.co.intra_mart.framework.base.web.tag.TagWriter.
タグの出力を行います。
TagWriter(JspWriter) - class jp.co.intra_mart.framework.base.web.tag.TagWriter のコンストラクタ
TagWriterを新規に生成します。
TextFileDataPropertyHandler - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler のコンストラクタ
TextFileDataPropertyHandlerを新規に生成します。
TextFileEventPropertyHandler - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler のコンストラクタ
TextFileEventPropertyHandlerを新規に生成します。
TextFileMessagePropertyHandler - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler.
指定されたファイルからプロパティ情報を取得するメッセージプロパティハンドラです。
TextFileMessagePropertyHandler() - class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler のコンストラクタ
TextFileServicePropertyHandler - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler.
指定されたファイルからプロパティ情報を取得するサービスプロパティハンドラです。
TextFileServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler のコンストラクタ
TextFileServicePropertyHandlerを新規に生成します。
TokenInvalidException - exception jp.co.intra_mart.framework.presentation.TokenInvalidException.
トークンが不正な場合に発生する例外です。
TokenInvalidException() - class jp.co.intra_mart.framework.presentation.TokenInvalidException のコンストラクタ
詳細メッセージを指定しないで TokenInvalidException を構築します。
TokenInvalidException(String) - class jp.co.intra_mart.framework.presentation.TokenInvalidException のコンストラクタ
指定された詳細メッセージを持つ TokenInvalidException を構築します。
TokenInvalidException(String, Throwable) - class jp.co.intra_mart.framework.presentation.TokenInvalidException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TokenInvalidException を構築します。
Transition - class jp.co.intra_mart.framework.base.service.Transition.
画面遷移に関連するクラスのインタフェースです。
Transition() - class jp.co.intra_mart.framework.base.service.Transition のコンストラクタ
Transitionを新規に生成します。
TransitionException - exception jp.co.intra_mart.framework.base.service.TransitionException.
トランジションに関連する例外です。
TransitionException() - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
詳細メッセージを指定しないで TransitionException を構築します。
TransitionException(String) - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
指定された詳細メッセージを持つ TransitionException を構築します。
TransitionException(String, Throwable) - class jp.co.intra_mart.framework.base.service.TransitionException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ TransitionException を構築します。
transfer() - class jp.co.intra_mart.framework.base.service.DefaultTransition のメソッド
次のページに遷移します。
transfer() - class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition のメソッド
ページベースの画面に遷移します。
transfer() - class jp.co.intra_mart.framework.base.service.Transition のメソッド
次のページに遷移します。

U

UserInfo - interface jp.co.intra_mart.framework.base.util.UserInfo.
ログインユーザの情報を管理します。
UserInfoException - exception jp.co.intra_mart.framework.base.util.UserInfoException.
ユーザ情報に関連する例外です。
UserInfoException() - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
詳細メッセージを指定しないで UserInfoException を構築します。
UserInfoException(String) - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
指定された詳細メッセージを持つ UserInfoException を構築します。
UserInfoException(String, Throwable) - class jp.co.intra_mart.framework.base.util.UserInfoException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ UserInfoException を構築します。
UserInfoUtil - class jp.co.intra_mart.framework.base.util.UserInfoUtil.
ログインユーザの情報に関するユーティリティクラスです。
unlockSession(String) - class jp.co.intra_mart.framework.presentation.PresentationManager のメソッド
セッションのロックを解除します。

V

ValidationException - exception jp.co.intra_mart.framework.presentation.validator.ValidationException.
検証結果が不正であるときの例外です。
ValidationException() - class jp.co.intra_mart.framework.presentation.validator.ValidationException のコンストラクタ
詳細メッセージを指定しないで ValidationException を構築します。
ValidationException(String) - class jp.co.intra_mart.framework.presentation.validator.ValidationException のコンストラクタ
指定された詳細メッセージを持つ ValidationException を構築します。
ValidationException(String, Throwable) - class jp.co.intra_mart.framework.presentation.validator.ValidationException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ RequestFormatException を構築します。
ValidationExceptionDetail - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail.
検証結果の詳細情報です。
ValidationExceptionDetail() - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のコンストラクタ
メッセージなしのValidatorExceptionDetailを生成します。
ValidationExceptionDetail(String) - class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail のコンストラクタ
メッセージ付きのValidatorExceptionDetailを生成します。
Validator - interface jp.co.intra_mart.framework.presentation.validator.Validator.
リクエスト内容の検証をします。
ValidatorConfig - interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig.
Validatorの初期化情報です。
ValidatorException - exception jp.co.intra_mart.framework.presentation.validator.ValidatorException.
Validatorに関連する例外です。
ValidatorException() - class jp.co.intra_mart.framework.presentation.validator.ValidatorException のコンストラクタ
詳細メッセージを指定しないで ValidatorException を構築します。
ValidatorException(String) - class jp.co.intra_mart.framework.presentation.validator.ValidatorException のコンストラクタ
指定された詳細メッセージを持つ ValidatorException を構築します。
ValidatorException(String, Throwable) - class jp.co.intra_mart.framework.presentation.validator.ValidatorException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ValidatorException を構築します。
ViewConverter - interface jp.co.intra_mart.framework.presentation.view.ViewConverter.
出力情報をビューオブジェクトに変換します。
ViewConverterConfig - interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig.
ViewConverterの初期化情報です。
ViewConverterException - exception jp.co.intra_mart.framework.presentation.view.ViewConverterException.
ViewConverterに関連する例外です。
ViewConverterException() - class jp.co.intra_mart.framework.presentation.view.ViewConverterException のコンストラクタ
詳細メッセージを指定しないで ViewConverterException を構築します。
ViewConverterException(String) - class jp.co.intra_mart.framework.presentation.view.ViewConverterException のコンストラクタ
指定された詳細メッセージを持つ ViewConverterException を構築します。
ViewConverterException(String, Throwable) - class jp.co.intra_mart.framework.presentation.view.ViewConverterException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ ViewConverterException を構築します。
ViewObject - interface jp.co.intra_mart.framework.presentation.view.ViewObject.
ビューオブジェクトのインタフェースです。
validate(RequestInfo) - class jp.co.intra_mart.framework.presentation.validator.FormatValidator のメソッド
文字列の不正文字（フォーマット）を検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.presentation.validator.LengthValidator のメソッド
文字列の長さを検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator のメソッド
数値の範囲を検証します。
validate(RequestInfo) - class jp.co.intra_mart.framework.presentation.validator.NumericValidator のメソッド
数値の検証をします。
validate(RequestInfo) - interface jp.co.intra_mart.framework.presentation.validator.Validator のメソッド
リクエスト内容の検証をします。

X

XmlDataPropertyHandler - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler.
XMLのデータプロパティハンドラです。
XmlDataPropertyHandler() - class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler のコンストラクタ
コンストラクタです。
XmlEventPropertyHandler - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler.
XMLのEventPropertyHandlerです。
XmlEventPropertyHandler() - class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler のコンストラクタ
DefaultEventPropertyHandlerを新規に生成します。
XmlLogPropertyHandler - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler.
リソースからログプロパティ情報を取得するプロパティハンドラです。
XmlLogPropertyHandler() - class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler のコンストラクタ
XMLLogPropertyHandlerを新規に生成します。
XmlPropertyManager - class jp.co.intra_mart.framework.system.property.XmlPropertyManager.
xmlのプロパティマネージャです。
XmlPropertyManager() - class jp.co.intra_mart.framework.system.property.XmlPropertyManager のコンストラクタ
コンストラクタです。
XmlServicePropertyHandler - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler.
サービスの設定情報に接続するプロパティハンドラです。
XmlServicePropertyHandler() - class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler のコンストラクタ
XmlServicePropertyHandlerを新規に生成します。
XmlSessionPropertyHandler - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler.
セッションに関連するXMLのプロパティハンドラです。
XmlSessionPropertyHandler() - class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler のコンストラクタ
A B C D E F G H I J K L M N O P R S T U V X
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


intra-mart im-J2EE Framework 5.0 API ドキュメント

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
すべてのクラス

パッケージ
jp.co.intra_mart.framework.base.data
jp.co.intra_mart.framework.base.event
jp.co.intra_mart.framework.base.message
jp.co.intra_mart.framework.base.service
jp.co.intra_mart.framework.base.session
jp.co.intra_mart.framework.base.util
jp.co.intra_mart.framework.base.web.bean
jp.co.intra_mart.framework.base.web.tag
jp.co.intra_mart.framework.base.web.tag.attribute
jp.co.intra_mart.framework.base.web.util
jp.co.intra_mart.framework.presentation
jp.co.intra_mart.framework.presentation.controller
jp.co.intra_mart.framework.presentation.forward
jp.co.intra_mart.framework.presentation.service
jp.co.intra_mart.framework.presentation.validator
jp.co.intra_mart.framework.presentation.view
jp.co.intra_mart.framework.system.exception
jp.co.intra_mart.framework.system.log
jp.co.intra_mart.framework.system.message
jp.co.intra_mart.framework.system.property


概要 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

intra-mart(R) im-J2EE Framework 5.0
API 仕様

このドキュメントは、intra-martTM im-J2EE Framework 5.0 の API 仕様です。

参照:
説明

パッケージ
jp.co.intra_mart.framework.base.data | データアクセスに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.event | イベントフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.message | メッセージフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.service | サービスフレームワークに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.session | セッションに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.util |
jp.co.intra_mart.framework.base.web.bean | JSPの表示を補助するHelperBeanに関連するクラスのパッケージです。
jp.co.intra_mart.framework.base.web.tag | J2EEフレームワークで使用する各種のタグのパッケージです。
jp.co.intra_mart.framework.base.web.tag.attribute | タグ属性のパッケージです。
jp.co.intra_mart.framework.base.web.util | Web上で使用するユーティリティのパッケージです。
jp.co.intra_mart.framework.presentation | Presentation Frameworkに関連するパッケージです。
jp.co.intra_mart.framework.presentation.controller | 入力情報に関連するパッケージです。
jp.co.intra_mart.framework.presentation.forward | 遷移先の決定に関連するパッケージです。
jp.co.intra_mart.framework.presentation.service | サービスに関連するパッケージです。
jp.co.intra_mart.framework.presentation.validator | 検証に関連するパッケージです。
jp.co.intra_mart.framework.presentation.view | 出力情報に関連するパッケージです。
jp.co.intra_mart.framework.system.exception | J2EEフレームワークの例外に関連するパッケージです。
jp.co.intra_mart.framework.system.log | J2EEフレームワークのログに関連するパッケージです。
jp.co.intra_mart.framework.system.message | メッセージに関連するパッケージです。
jp.co.intra_mart.framework.system.property | プロパティ取得に関連するパッケージです。

このドキュメントは、intra-martTM im-J2EE Framework 5.0 の API 仕様です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス階層 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.framework.base.data, jp.co.intra_mart.framework.base.event, jp.co.intra_mart.framework.base.message, jp.co.intra_mart.framework.base.service, jp.co.intra_mart.framework.base.session, jp.co.intra_mart.framework.base.util, jp.co.intra_mart.framework.base.web.bean, jp.co.intra_mart.framework.base.web.tag, jp.co.intra_mart.framework.base.web.tag.attribute, jp.co.intra_mart.framework.base.web.util, jp.co.intra_mart.framework.presentation, jp.co.intra_mart.framework.presentation.controller, jp.co.intra_mart.framework.presentation.forward, jp.co.intra_mart.framework.presentation.service, jp.co.intra_mart.framework.presentation.validator, jp.co.intra_mart.framework.presentation.view, jp.co.intra_mart.framework.system.exception, jp.co.intra_mart.framework.system.log, jp.co.intra_mart.framework.system.message, jp.co.intra_mart.framework.system.property

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.presentation.view.AbstractViewConverter (implements jp.co.intra_mart.framework.presentation.view.ViewConverter)
    • class jp.co.intra_mart.framework.base.util.ConfigurationUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.data.ConnectorModel
    • class jp.co.intra_mart.framework.base.data.DAOAdapter (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DaoModel
    • class jp.co.intra_mart.framework.base.data.DataAccessController
    • class jp.co.intra_mart.framework.base.data.DataConnector
      • class jp.co.intra_mart.framework.base.data.DBConnector
        • class jp.co.intra_mart.framework.base.data.DataSourceConnector
        • class jp.co.intra_mart.framework.base.data.JDBCConnector
      • class jp.co.intra_mart.framework.base.data.IntramartDBConnector
      • class jp.co.intra_mart.framework.base.data.IntramartFileServerConnector
      • class jp.co.intra_mart.framework.base.data.LoginGroupDBConnector
      • class jp.co.intra_mart.framework.base.data.SystemDBConnector
    • class jp.co.intra_mart.framework.base.data.DataManager
    • class jp.co.intra_mart.framework.base.data.DBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.DefaultDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DefaultEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.DefaultLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.log.DefaultLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.base.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.system.message.DefaultMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DefaultServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.DefaultSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)
    • class jp.co.intra_mart.framework.base.data.DistributesDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.DistributesEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.service.DistributesServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.event.EJBEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListener
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocal
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListener
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean (implements javax.ejb.SessionBean)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean
    • class jp.co.intra_mart.framework.base.event.EJBEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerFactory
      • class jp.co.intra_mart.framework.base.event.GenericEJBEventListenerLocalFactory
      • class jp.co.intra_mart.framework.base.event.StandardEJBEventListenerFactory
    • class jp.co.intra_mart.framework.base.util.EmptyUserInfo (implements java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo)
    • class jp.co.intra_mart.framework.base.service.EncodingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.event.Event (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.event.EmptyEvent
    • class jp.co.intra_mart.framework.base.event.EventFactoryModel
    • class jp.co.intra_mart.framework.base.event.EventGroupModel
    • class jp.co.intra_mart.framework.base.event.EventManager
    • class jp.co.intra_mart.framework.base.event.EventModelProducer
    • class jp.co.intra_mart.framework.base.event.EventTriggerAdapter (implements jp.co.intra_mart.framework.base.event.EventTrigger)
    • class jp.co.intra_mart.framework.base.event.EventTriggerInfo
    • class jp.co.intra_mart.framework.base.event.EventTriggerList
    • class jp.co.intra_mart.framework.base.service.FileUploadFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.presentation.validator.FormatValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.FrameworkParameterSettingFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.web.tag.attribute.GenericAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.CoreAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.EventsAttributes
      • class jp.co.intra_mart.framework.base.web.tag.attribute.I18nAttributes
    • class jp.co.intra_mart.framework.base.event.GenericEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.GenericEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class javax.servlet.GenericServlet (implements java.io.Serializable, javax.servlet.Servlet, javax.servlet.ServletConfig)
      • class javax.servlet.http.HttpServlet (implements java.io.Serializable)
        • class jp.co.intra_mart.framework.base.service.IntramartConnectServlet
        • class jp.co.intra_mart.framework.presentation.PresentationServlet
        • class jp.co.intra_mart.framework.base.service.ServiceServlet
    • class jp.co.intra_mart.framework.base.web.bean.HelperBean (implements java.io.Serializable)
      • class jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean
    • class jp.co.intra_mart.framework.base.web.util.HTMLEncoder
    • class jp.co.intra_mart.framework.base.session.HttpSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.HttpSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.base.service.IntramartConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.data.IntramartDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.data.IntramartFileServerDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.base.service.IntramartLocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.system.log.IntramartLogAgent (implements jp.co.intra_mart.framework.system.log.LogAgent)
    • class jp.co.intra_mart.framework.system.message.IntramartMessagePropertyHandler (implements jp.co.intra_mart.framework.system.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionFactory (implements jp.co.intra_mart.framework.base.session.SessionFactory)
    • class jp.co.intra_mart.framework.base.session.IntramartSessionObject (implements jp.co.intra_mart.framework.base.session.SessionObject)
    • class jp.co.intra_mart.framework.presentation.validator.LengthValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.base.service.LocaleFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.data.LoginGroupDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class jp.co.intra_mart.framework.system.log.LogManager
    • class jp.co.intra_mart.framework.base.message.MessageManager
    • class jp.co.intra_mart.framework.system.message.MessageManager
    • class jp.co.intra_mart.framework.presentation.validator.NumericRangeValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.validator.NumericValidator (implements jp.co.intra_mart.framework.presentation.validator.Validator)
    • class jp.co.intra_mart.framework.presentation.view.Option
    • class jp.co.intra_mart.framework.presentation.PresentationConnectFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.presentation.PresentationManager
    • class jp.co.intra_mart.framework.system.property.PropertyConfigModel
    • class jp.co.intra_mart.framework.system.property.PropertyManager
      • class jp.co.intra_mart.framework.system.property.DefaultPropertyManager
      • class jp.co.intra_mart.framework.system.property.XmlPropertyManager
    • class jp.co.intra_mart.framework.system.property.PropertyModel
    • class jp.co.intra_mart.framework.system.property.PropertyParam
      • class jp.co.intra_mart.framework.base.event.EventListenerFactoryParam
      • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagParam
      • class jp.co.intra_mart.framework.system.log.LogAgentParam
      • class jp.co.intra_mart.framework.system.message.MessagePropertyParam
      • class jp.co.intra_mart.framework.system.property.PropertyHandlerParam
      • class jp.co.intra_mart.framework.base.data.ResourceParam
    • class jp.co.intra_mart.framework.base.data.ResourceModel
    • class jp.co.intra_mart.framework.presentation.view.SelectableItem
      • class jp.co.intra_mart.framework.presentation.view.MultiSelectableItem
      • class jp.co.intra_mart.framework.presentation.view.SingleSelectableItem
    • class jp.co.intra_mart.framework.base.service.ServiceControllerAdapter (implements jp.co.intra_mart.framework.base.service.ServiceController)
      • class jp.co.intra_mart.framework.presentation.service.PresentationServiceController
    • class jp.co.intra_mart.framework.base.service.ServiceManager
    • class jp.co.intra_mart.framework.base.service.ServiceSecurityFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.framework.base.session.SessionManager
    • class java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
      • class jp.co.intra_mart.framework.base.web.tag.FormTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.FrameTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.LinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTagBeanInfo
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTagBeanInfo
    • class jp.co.intra_mart.framework.presentation.controller.SimpleControllerConverter (implements jp.co.intra_mart.framework.presentation.controller.ControllerConverter)
    • class jp.co.intra_mart.framework.presentation.view.SimpleViewObject (implements jp.co.intra_mart.framework.presentation.view.ViewObject)
      • class jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject (implements jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject)
    • class jp.co.intra_mart.framework.base.event.StandardEventListener (implements jp.co.intra_mart.framework.base.event.EventListener)
    • class jp.co.intra_mart.framework.base.event.StandardEventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.base.data.SystemDBDAO (implements jp.co.intra_mart.framework.base.data.DAO)
    • class javax.servlet.jsp.tagext.TagExtraInfo
      • class jp.co.intra_mart.framework.base.web.tag.FormTEI
      • class jp.co.intra_mart.framework.base.web.tag.FrameTEI
      • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTEI
      • class jp.co.intra_mart.framework.base.web.tag.LinkTEI
      • class jp.co.intra_mart.framework.base.web.tag.MessageTEI
      • class jp.co.intra_mart.framework.base.web.tag.SubmitTEI
    • class javax.servlet.jsp.tagext.TagSupport (implements javax.servlet.jsp.tagext.IterationTag, java.io.Serializable)
      • class javax.servlet.jsp.tagext.BodyTagSupport (implements javax.servlet.jsp.tagext.BodyTag)
        • class jp.co.intra_mart.framework.base.web.tag.FormTag
        • class jp.co.intra_mart.framework.base.web.tag.FrameTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.HelperBeanTag
        • class jp.co.intra_mart.framework.base.web.tag.LinkTag (implements jp.co.intra_mart.framework.base.web.tag.ParameterSendable)
        • class jp.co.intra_mart.framework.base.web.tag.MessageParamTag
        • class jp.co.intra_mart.framework.base.web.tag.MessageTag
        • class jp.co.intra_mart.framework.base.web.tag.ParamTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag
        • class jp.co.intra_mart.framework.base.web.tag.SubmitTag
    • class jp.co.intra_mart.framework.base.web.tag.TagWriter
    • class jp.co.intra_mart.framework.base.data.TextFileDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.TextFileEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.base.message.TextFileMessagePropertyHandler (implements jp.co.intra_mart.framework.base.message.MessagePropertyHandler)
    • class jp.co.intra_mart.framework.base.service.TextFileServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.framework.presentation.BadRequestException
            • class jp.co.intra_mart.framework.base.service.RequestException
            • class jp.co.intra_mart.framework.presentation.TokenInvalidException
            • class jp.co.intra_mart.framework.presentation.validator.ValidationException
          • class jp.co.intra_mart.framework.system.property.PropertyHandlerException
          • class jp.co.intra_mart.framework.system.property.PropertyManagerException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.framework.presentation.controller.ControllerConverterException
            • class jp.co.intra_mart.framework.base.data.DAOException
            • class jp.co.intra_mart.framework.base.data.DataAccessException
            • class jp.co.intra_mart.framework.base.data.DataConnectException
            • class jp.co.intra_mart.framework.base.data.DataConnectorException
            • class jp.co.intra_mart.framework.base.data.DataManagerException
            • class jp.co.intra_mart.framework.base.data.DataPropertyException
            • class jp.co.intra_mart.framework.presentation.DuplicateException
            • class jp.co.intra_mart.framework.base.event.EventException
            • class jp.co.intra_mart.framework.base.event.EventListenerException
            • class jp.co.intra_mart.framework.base.event.EventManagerException
            • class jp.co.intra_mart.framework.base.event.EventPropertyException
            • class jp.co.intra_mart.framework.base.event.EventTriggerException
            • class jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException
            • class jp.co.intra_mart.framework.base.web.bean.HelperBeanException
            • class jp.co.intra_mart.framework.base.session.IllegalSessionException
            • class jp.co.intra_mart.framework.system.exception.IllegalSystemException
            • class jp.co.intra_mart.framework.system.log.LogPropertyException
            • class jp.co.intra_mart.framework.base.message.MessageManagerException
            • class jp.co.intra_mart.framework.system.message.MessageManagerException
            • class jp.co.intra_mart.framework.base.message.MessagePropertyException
            • class jp.co.intra_mart.framework.system.message.MessagePropertyException
            • class jp.co.intra_mart.framework.presentation.MismatchException
            • class jp.co.intra_mart.framework.presentation.NameFormatException
            • class jp.co.intra_mart.framework.presentation.PresentationManagerException
            • class jp.co.intra_mart.framework.presentation.PresentationPropertyException
            • class jp.co.intra_mart.framework.presentation.controller.RequestFormatException
            • class jp.co.intra_mart.framework.base.service.ServiceControllerException
            • class jp.co.intra_mart.framework.base.service.ServiceManagerException
            • class jp.co.intra_mart.framework.base.service.ServicePropertyException
            • class jp.co.intra_mart.framework.base.service.ServiceServletException
            • class jp.co.intra_mart.framework.base.session.SessionFactoryException
            • class jp.co.intra_mart.framework.base.session.SessionManagerException
            • class jp.co.intra_mart.framework.base.session.SessionObjectException
            • class jp.co.intra_mart.framework.base.session.SessionPropertyException
            • class jp.co.intra_mart.framework.base.service.TransitionException
            • class jp.co.intra_mart.framework.base.util.UserInfoException
            • class jp.co.intra_mart.framework.presentation.validator.ValidatorException
            • class jp.co.intra_mart.framework.presentation.view.ViewConverterException
        • class javax.servlet.jsp.JspException
          • class jp.co.intra_mart.framework.base.web.tag.FrameworkTagException
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
      • class jp.co.intra_mart.framework.base.service.IntramartPageBaseTransition
    • class jp.co.intra_mart.framework.base.util.UserInfoUtil
    • class jp.co.intra_mart.framework.presentation.validator.ValidationExceptionDetail
    • class jp.co.intra_mart.framework.base.data.XmlDataPropertyHandler (implements jp.co.intra_mart.framework.base.data.DataPropertyHandler)
    • class jp.co.intra_mart.framework.base.event.XmlEventPropertyHandler (implements jp.co.intra_mart.framework.base.event.EventPropertyHandler)
    • class jp.co.intra_mart.framework.system.log.XmlLogPropertyHandler (implements jp.co.intra_mart.framework.system.log.LogPropertyHandler)
    • class jp.co.intra_mart.framework.base.service.XmlServicePropertyHandler (implements jp.co.intra_mart.framework.base.service.ServicePropertyHandler)
    • class jp.co.intra_mart.framework.base.session.XmlSessionPropertyHandler (implements jp.co.intra_mart.framework.base.session.SessionPropertyHandler)

インタフェース階層

  • interface jp.co.intra_mart.framework.presentation.controller.ControllerConverter
  • interface jp.co.intra_mart.framework.presentation.controller.ControllerConverterConfig
  • interface jp.co.intra_mart.framework.base.data.DAO
  • interface javax.ejb.EJBLocalHome
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocalHome
  • interface javax.ejb.EJBLocalObject
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentLocal
  • interface jp.co.intra_mart.framework.base.event.EventListener
  • interface jp.co.intra_mart.framework.base.event.EventListenerFactory
  • interface jp.co.intra_mart.framework.base.event.EventTrigger
  • interface jp.co.intra_mart.framework.presentation.forward.ForwardSelector
  • interface jp.co.intra_mart.framework.presentation.forward.ForwardSelectorConfig
  • interface jp.co.intra_mart.framework.system.log.LogAgent
  • interface jp.co.intra_mart.framework.system.log.LogConstant
  • interface jp.co.intra_mart.framework.base.web.tag.ParameterSendable
  • interface jp.co.intra_mart.framework.system.property.PropertyHandler
    • interface jp.co.intra_mart.framework.base.data.DataPropertyHandler
    • interface jp.co.intra_mart.framework.base.event.EventPropertyHandler
    • interface jp.co.intra_mart.framework.system.log.LogPropertyHandler
    • interface jp.co.intra_mart.framework.base.message.MessagePropertyHandler
    • interface jp.co.intra_mart.framework.system.message.MessagePropertyHandler
    • interface jp.co.intra_mart.framework.presentation.PresentationPropertyHandler
    • interface jp.co.intra_mart.framework.base.service.ServicePropertyHandler
    • interface jp.co.intra_mart.framework.base.session.SessionPropertyHandler
  • interface java.rmi.Remote
    • interface javax.ejb.EJBHome
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
    • interface javax.ejb.EJBObject
      • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
      • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentHome
    • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgent
    • interface jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentHome
  • interface jp.co.intra_mart.framework.presentation.RequestInfo
  • interface java.io.Serializable
    • interface jp.co.intra_mart.framework.presentation.controller.ControllerObject
    • interface jp.co.intra_mart.framework.base.event.EventResult
    • interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject
    • interface jp.co.intra_mart.framework.base.util.UserInfo
    • interface jp.co.intra_mart.framework.presentation.view.ViewObject
      • interface jp.co.intra_mart.framework.presentation.view.PanelBasedViewObject
  • interface jp.co.intra_mart.framework.base.service.ServiceController
  • interface jp.co.intra_mart.framework.base.service.ServiceResult
  • interface jp.co.intra_mart.framework.base.session.SessionFactory
  • interface jp.co.intra_mart.framework.base.session.SessionObject
  • interface jp.co.intra_mart.framework.presentation.validator.Validator
  • interface jp.co.intra_mart.framework.presentation.validator.ValidatorConfig
  • interface jp.co.intra_mart.framework.presentation.view.ViewConverter
  • interface jp.co.intra_mart.framework.presentation.view.ViewConverterConfig
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


(intra-mart im-J2EE Framework 5.0 API ドキュメント)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (intra-mart im-J2EE Framework 5.0 API ドキュメント)

im-J2EE Framework 5.0
前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.framework.base.data

クラス jp.co.intra_mart.framework.base.data.DAOException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataAccessException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataConnectException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataConnectorException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.data.DataPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.event

クラス jp.co.intra_mart.framework.base.event.EJBEventListenerAgentBean は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sessionContext

SessionContext sessionContext
セッションコンテキスト

クラス jp.co.intra_mart.framework.base.event.EmptyEvent は Event を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.Event は Object を拡張し、Serializable を実装しています

直列化されたフィールド

application

String application
アプリケーション

key

String key
イベントキー

loginUserID

String loginUserID
ログインユーザ

loginGroupID

String loginGroupID
ログイングループ

info

UserInfo info
ユーザ情報

クラス jp.co.intra_mart.framework.base.event.EventException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventListenerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventPropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.EventTriggerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.GenericEJBEventListenerAgentBean は EJBEventListenerAgentBean を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.event.StandardEJBEventListenerAgentBean は EJBEventListenerAgentBean を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.message

クラス jp.co.intra_mart.framework.base.message.MessageManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.message.MessagePropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.service

クラス jp.co.intra_mart.framework.base.service.IntramartConnectServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

serviceManager

ServiceManager serviceManager
推奨されていません。
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
推奨されていません。
サービスプロパティハンドラ

sessionManager

SessionManager sessionManager
推奨されていません。
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
推奨されていません。
セッションプロパティハンドラ

referrerFormatShort

boolean referrerFormatShort
推奨されていません。
referrerのフォーマット

導入されたバージョン:
4.1.5

クラス jp.co.intra_mart.framework.base.service.RequestException は ApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceControllerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServicePropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.ServiceServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

manager

ServiceManager manager
サービスマネージャ

handler

ServicePropertyHandler handler
サービスプロパティハンドラ

クラス jp.co.intra_mart.framework.base.service.ServiceServletException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.service.TransitionException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.session

クラス jp.co.intra_mart.framework.base.session.IllegalSessionException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionFactoryException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionObjectException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.session.SessionPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.util

クラス jp.co.intra_mart.framework.base.util.ConfigurationUserInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

clientType

String clientType

colorPatternID

String colorPatternID

encoding

String encoding

language

String language

country

String country

variant

String variant

loginGroupID

String loginGroupID

loginTime

Date loginTime

loginType

String loginType

userID

String userID

クラス jp.co.intra_mart.framework.base.util.EmptyUserInfo は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.util.UserInfoException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.web.bean

クラス jp.co.intra_mart.framework.base.web.bean.ErrorHelperBean は HelperBean を拡張し、Serializable を実装しています

直列化されたフィールド

exception

Throwable exception
例外

クラス jp.co.intra_mart.framework.base.web.bean.HelperBean は Object を拡張し、Serializable を実装しています

直列化されたフィールド

eventManager

EventManager eventManager
イベントマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

request

HttpServletRequest request
リクエスト

response

HttpServletResponse response
レスポンス

userInfo

UserInfo userInfo
ユーザ情報

クラス jp.co.intra_mart.framework.base.web.bean.HelperBeanException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.base.web.tag

クラス jp.co.intra_mart.framework.base.web.tag.FormTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

EventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

method

String method
method

enctype

String enctype
enctype

accept

String accept
accept

name

String name
name

onSubmit

String onSubmit
onSubmit

onReset

String onReset
onReset

acceptCharset

String acceptCharset
accept-charset

target

String target
target

クラス jp.co.intra_mart.framework.base.web.tag.FrameTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

params

Collection params
パラメータの集合

application

String application
アプリケーション

service

String service
サービス

longdesc

String longdesc
longdesc

name

String name
name

frameborder

String frameborder
frameborder

marginwidth

String marginwidth
marginwidth

marginheight

String marginheight
marginheight

noresize

String noresize
noresize

scrolling

String scrolling
scrolling

クラス jp.co.intra_mart.framework.base.web.tag.FrameworkTagException は JspException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.base.web.tag.HelperBeanTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

helperclass

String helperclass
クラス名

クラス jp.co.intra_mart.framework.base.web.tag.LinkTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

sessionManager

SessionManager sessionManager
セッションマネージャ

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

serviceManager

ServiceManager serviceManager
サービスマネージャ

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

EventsAttributes events
イベント属性

params

Collection params
パラメータの集合

application

String application
アプリケーション

service

String service
サービス

charset

String charset
charset

type

String type
type

name

String name
name

hreflang

String hreflang
hreflang

rel

String rel
rel

rev

String rev
rev

accesskey

String accesskey
accesskey

shape

String shape
shape

coords

String coords
coords

target

String target
target

導入されたバージョン:
3.2

tabindex

String tabindex
tabindex

onfocus

String onfocus
onfocus

onblur

String onblur
onblur

クラス jp.co.intra_mart.framework.base.web.tag.MessageParamTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

value

Object value
パラメータの値

クラス jp.co.intra_mart.framework.base.web.tag.MessageTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

messageManager

MessageManager messageManager
MessageManager

serviceManager

ServiceManager serviceManager
ServiceManager

params

Vector params
パラメータの集合

application

String application
アプリケーション

key

String key
キー

locale

String locale
ロケール

クラス jp.co.intra_mart.framework.base.web.tag.ParamTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

name

String name
パラメータ名

value

String value
パラメータの値

クラス jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

jp.co.intra_mart.framework.base.web.tag.SubmitLinkTag.SubmitLinkEventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

form

String form
フォーム名

name

String name
name

accesskey

String accesskey
accesskey

shape

String shape
shape

coords

String coords
coords

tabindex

String tabindex
tabindex

onfocus

String onfocus
onfocus

onblur

String onblur
onblur

serviceManager

ServiceManager serviceManager
サービスマネージャ

導入されたバージョン:
4.3

sessionManager

SessionManager sessionManager
セッションマネージャ

導入されたバージョン:
4.3

クラス jp.co.intra_mart.framework.base.web.tag.SubmitTag は BodyTagSupport を拡張し、Serializable を実装しています

直列化されたフィールド

serviceHandler

ServicePropertyHandler serviceHandler
サービスプロパティハンドラ

coreAttrs

CoreAttributes coreAttrs
コア属性

i18n

I18nAttributes i18n
国際化属性

events

jp.co.intra_mart.framework.base.web.tag.SubmitTag.SubmitEventsAttributes events
イベント属性

application

String application
アプリケーション

service

String service
サービス

name

String name
name

value

String value
value

tabindex

String tabindex
tabindex

onFocus

String onFocus
onFocus

onBlur

String onBlur
onBlur

serviceManager

ServiceManager serviceManager
サービスマネージャ

導入されたバージョン:
4.3

sessionManager

SessionManager sessionManager
セッションマネージャ

導入されたバージョン:
4.3

sessionHandler

SessionPropertyHandler sessionHandler
セッションプロパティハンドラ

導入されたバージョン:
4.3

パッケージ jp.co.intra_mart.framework.presentation

クラス jp.co.intra_mart.framework.presentation.BadRequestException は ApplicationException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.DuplicateException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.MismatchException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.NameFormatException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.PresentationManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.PresentationPropertyException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.PresentationServlet は HttpServlet を拡張し、Serializable を実装しています

直列化されたフィールド

manager

PresentationManager manager
エンジンマネージャ

handler

PresentationPropertyHandler handler
プロパティハンドラ

クラス jp.co.intra_mart.framework.presentation.TokenInvalidException は ApplicationException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.presentation.controller

クラス jp.co.intra_mart.framework.presentation.controller.ControllerConverterException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.presentation.controller.RequestFormatException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.presentation.forward

クラス jp.co.intra_mart.framework.presentation.forward.ForwardSelectorException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.presentation.validator

クラス jp.co.intra_mart.framework.presentation.validator.ValidationException は ApplicationException を拡張し、Serializable を実装しています

直列化されたフィールド

validationExceptionDetails

Collection validationExceptionDetails
検証例外の詳細

クラス jp.co.intra_mart.framework.presentation.validator.ValidatorException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.presentation.view

クラス jp.co.intra_mart.framework.presentation.view.SimplePanelBasedViewObject は SimpleViewObject を拡張し、Serializable を実装しています

直列化されたフィールド

subPanelViews

Map subPanelViews
サブパネルに対応するPanelBasedViewObjectの集合

クラス jp.co.intra_mart.framework.presentation.view.SimpleViewObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

viewInfo

Object viewInfo
表示情報

formObjects

Map formObjects
フォームオブジェクトの集合

クラス jp.co.intra_mart.framework.presentation.view.ViewConverterException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.exception

クラス jp.co.intra_mart.framework.system.exception.ApplicationException は FrameworkException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.FrameworkException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.IllegalSystemException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.exception.SystemException は FrameworkException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.log

クラス jp.co.intra_mart.framework.system.log.LogPropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.message

クラス jp.co.intra_mart.framework.system.message.MessageManagerException は SystemException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.message.MessagePropertyException は SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.framework.system.property

クラス jp.co.intra_mart.framework.system.property.PropertyHandlerException は FrameworkException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.framework.system.property.PropertyManagerException は FrameworkException を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


 CurlFieldBean オブジェクト

CurlFieldBeanオブジェクト。
CurlのRecordFieldクラスの属性情報を格納するオブジェクトです。
設定できる属性情報は以下の通りです。なお、各項目の詳細はCurlのドキュメントを参照してください。

CurlFieldBeanオブジェクト
name [必須] 名前 (String)
caption − キャプション (String)
domain − ドメイン (String)
modifiable − 編集可否フラグ (String)
nullable − Null許容可否フラグ (String)
default-value − デフォルト値 (String)
index-type − インデックスタイプ (String)
required − 明示的設定の可否フラグ (String)
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CurlFieldBean()
コンストラクタ。
メソッドの概要
String | getCaption() キャプションを取得します。
String | getDefault_value() デフォルト値を取得します。
String | getDomain() ドメインを取得します。
String | getIndex_type() インデックスタイプを取得します。
String | getModifiable() 編集可能フラグを取得します。
String | getName() 名前を取得します。
String | getNullable() Null許容フラグを取得します。
String | getRequired() 必須フラグを取得します。
void | setCaption(String value) キャプションを設定します。
void | setDefault_value(String value) デフォルト値を設定します。
void | setDomain(String value) ドメインを設定します。
void | setIndex_type(String value) インデックスタイプを設定します。
void | setModifiable(String value) 編集可能フラグを設定します。
void | setName(String value) 名前を設定します。
void | setNullable(String value) Null許容フラグを設定します。
void | setRequired(String value) 必須フラグを設定します。
コンストラクタの詳細
CurlFieldBean

CurlFieldBean()
コンストラクタ。

CurlFieldBeanオブジェクトを生成します。

メソッドの詳細
getCaption

String getCaption()

キャプションを取得します。

返却値
String キャプション
getDefault_value

String getDefault_value()

デフォルト値を取得します。

返却値
String デフォルト値
getDomain

String getDomain()

ドメインを取得します。

返却値
String ドメイン
getIndex_type

String getIndex_type()

インデックスタイプを取得します。

返却値
String インデックスタイプ
getModifiable

String getModifiable()

編集可能フラグを取得します。

返却値
String 編集可能フラグ(true/false)
getName

String getName()

名前を取得します。

返却値
String 名前
getNullable

String getNullable()

Null許容フラグを取得します。

返却値
String Null許容フラグ(true/false)
getRequired

String getRequired()

必須フラグを取得します。

返却値
String 必須フラグ(true/false)
setCaption

void setCaption(String value)

キャプションを設定します。

パラメータ
value String キャプション
返却値
void
setDefault_value

void setDefault_value(String value)

デフォルト値を設定します。

パラメータ
value String デフォルト値
返却値
void
setDomain

void setDomain(String value)

ドメインを設定します。

パラメータ
value String ドメイン
返却値
void
setIndex_type

void setIndex_type(String value)

インデックスタイプを設定します。

パラメータ
value String インデックスタイプ
返却値
void
setModifiable

void setModifiable(String value)

編集可能フラグを設定します。

パラメータ
value String 編集可能フラグ(true/false)
返却値
void
setName

void setName(String value)

名前を設定します。

パラメータ
value String 名前
返却値
void
setNullable

void setNullable(String value)

Null許容フラグを設定します。

パラメータ
value String Null許容フラグ(true/false)
返却値
void
setRequired

void setRequired(String value)

必須フラグを設定します。

パラメータ
value String 必須フラグ(true/false)
返却値
void


 CurlXMLComposer オブジェクト

CurlXMLComposerオブジェクト。
Curlのelaborate-recordsetで解釈可能なXMLを生成するオブジェクトです。
このオブジェクトに対して、CurlFieldBeanオブジェクトとそれに対応するレコード情報を セットしたオブジェクトをセットすることでCurlのRecordSetに変換可能なXMLデータを 生成します。

CurlFieldBeanオブジェクトとレコード情報をセットしたオブジェクトを結びつけるためには、 CurlFieldBeanオブジェクトのsetName()で指定した文字列をオブジェクトのプロパティ名に 指定する必要があります。
 var curlFieldBean = new CurlFieldBean();
 curlFieldBean.setName("fieldName");
 ...
 var record = new Object();
 record.fieldName = "value";
 ...
 var curlXMLComposer = new CurlXMLComposer();
 curlXMLComposer.addField(curlFieldBean);
 curlXMLComposer.addRecord(record);

 xmlString = curlXMLComposer.toXML();
この実行結果(xmlString)の内容は次のようになります。
 <RecordSet>
 <Fields>
 <Field name="fieldName" ...>
 </Fields>
 <Record fieldName="value">
 </RecordSet>
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CurlXMLComposer()
コンストラクタ。
メソッドの概要
void | addField(Object obj) CurlFieldBeanをパラメータとして指定した場合、 フィールド一覧リストにフィールドとして追加します。
void | addRecord(Object obj) レコード一覧リストにレコードを追加します。
void | setFieldList(Object obj) フィールド一覧リストをセットします。
String | toXML() 指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
コンストラクタの詳細
CurlXMLComposer

CurlXMLComposer()
コンストラクタ。

CurlXMLComposerオブジェクトを生成します。
メソッドの詳細
addField

void addField(Object obj)

CurlFieldBeanをパラメータとして指定した場合、 フィールド一覧リストにフィールドとして追加します。
パラメータ
obj Object CurlFieldBeanObject
返却値
void
addRecord

void addRecord(Object obj)

レコード一覧リストにレコードを追加します。
パラメータ
obj Object レコード
返却値
void
setFieldList

void setFieldList(Object obj)

フィールド一覧リストをセットします。
主にCurlXMLParser.getFieldsList()の結果を使用したい場合に使用します。
パラメータ
obj Object フィールド一覧リスト
返却値
void
toXML

String toXML()

指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
通常、このメソッドの結果をHTMLへ引き渡し、Curlアプレットへの入力とします。
返却値
String Curlのelaborate-xmlで解釈可能なXML


 CurlXMLParser オブジェクト

CurlXMLParserオブジェクト。
Curlで出力されたXML(recordset-to-xmlでの出力)を解釈し、CurlFieldBeanおよびレコード情報を 含むオブジェクトを生成します。
Curlアプレットから送信されたRecordSetの情報を取得するには、このオブジェクトの生成時に パラメータとして送信された文字列を与え、生成されたオブジェクトからgetRecordList()、 getFieldList()を呼び出します。
それぞれのメソッドの返り値はObject、CurlFieldBeanが格納されたArrayとなっています。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CurlXMLParser(String xml)
コンストラクタ。
メソッドの概要
Array | getFieldList() パースした結果のフィールド一覧リストを返します。
Array | getRecordList() パースした結果のレコード一覧リストを返します。
コンストラクタの詳細
CurlXMLParser

CurlXMLParser(String xml)
コンストラクタ。

RecordSetから変換されたXMLを解釈した結果を持つオブジェクトを生成します。
生成に失敗した場合は、nullを返却します。
パラメータ
xml String RecordSetを変換したXML
メソッドの詳細
getFieldList

Array getFieldList()

パースした結果のフィールド一覧リストを返します。
返却値
Array CurlFieldBeanの配列
getRecordList

Array getRecordList()

パースした結果のレコード一覧リストを返します。

次のようなXMLをコンストラクタのパラメータに指定した場合
 <RecordSet>
 <Fields>
 <Field name="fieldName" ...>
 </Fields>
 <Record fieldName="value">
 </RecordSet>

getRecordListの結果、および内容は次のようになります。
 var curlXMLParser = new CurlXMLParser(xmlString);
 var recordList = curlXMLParser.getRecordList();

 var record = recordList[0];
 var value = record.fieldName; // valueの内容は"value"
 var length = record.length;  // length(配列の要素数)は1
返却値
Array Objectの配列


JavaScript API リスト概要

 JavaScript API リスト 概要

ページベース開発モデルで利用可能なJavaScript API の概要です。

オブジェクトの概要
CurlFieldBean | CurlFieldBeanオブジェクト。
CurlXMLComposer | CurlXMLComposerオブジェクト。
CurlXMLParser | CurlXMLParserオブジェクト。


JavaScript API リスト

 オブジェクト
CurlFieldBean
CurlXMLComposer
CurlXMLParser


 AccEmployeePayPostController オブジェクト

伝票登録コントローラクラス。

会計伝票を登録します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
AccEmployeePayPostController()
コンストラクタ。
メソッドの概要
Object | executeBapi() BapiControllerにより会計伝票を登録します。
void | setCuAmtBase(String value ,Number recNo) 明細通貨項目の課税基準額に値を設定します。
void | setCuAmtDoccur(String value ,Number recNo) 明細通貨項目の伝票通貨額に値を設定します。
void | setCuCurrency(String value ,Number recNo) 明細通貨項目の通貨コードに値を設定します。
void | setCuItemnoAcc(String value ,Number recNo) 明細通貨項目の会計伝票明細番号に値を設定します。
void | setDocAcDocNo(String value) 伝票ヘッダの会計伝票番号に値を設定します。
void | setDocCompCode(String value) 伝票ヘッダの会社コードに値を設定します。
void | setDocDocDate(String value) 伝票ヘッダの伝票の伝票日付に値を設定します。
void | setDocDocType(String value) 伝票ヘッダの伝票タイプに値を設定します。
void | setDocFisPeriod(String value) 伝票ヘッダの会計期間に値を設定します。
void | setDocFiscYear(String value) 伝票ヘッダの会計年度に値を設定します。
void | setDocHeaderTxt(String value) 伝票ヘッダの伝票ヘッダテキストに値を設定します。
void | setDocObjKey(String value) 伝票ヘッダのオブジェクトキーに値を設定します。
void | setDocObjType(String value) 伝票ヘッダの参照処理に値を設定します。
void | setDocPstngDate(String value) 伝票ヘッダの伝票の転記日付に値を設定します。
void | setDocRefDocNo(String value) 伝票ヘッダの参照伝票番号に値を設定します。
void | setDocUsername(String value) 伝票ヘッダのユーザ名に値を設定します。
void | setGlAllocNmbr(String value ,Number recNo) G/L 勘定明細のソートキーに値を設定します。
void | setGlBusArea(String value ,Number recNo) G/L 勘定明細の事業領域に値を設定します。
void | setGlCompCode(String value ,Number recNo) G/L 勘定明細の会社コードに値を設定します。
void | setGlCostcenter(String value ,Number recNo) G/L 勘定明細の原価センタに値を設定します。
void | setGlDocType(String value ,Number recNo) G/L 勘定明細の伝票タイプに値を設定します。
void | setGlFiscYear(String value ,Number recNo) G/L 勘定明細の会計年度に値を設定します。
void | setGlGlAccount(String value ,Number recNo) G/L 勘定明細の総勘定元帳勘定に値を設定します。
void | setGlItemText(String value ,Number recNo) G/L 勘定明細の明細テキストに値を設定します。
void | setGlItemnoAcc(String value ,Number recNo) G/L 勘定明細の会計伝票明細番号に値を設定します。
void | setGlOrderid(String value ,Number recNo) G/L 勘定明細の指図番号に値を設定します。
void | setGlPstngDate(String value ,Number recNo) G/L 勘定明細の伝票の転記日付に値を設定します。
void | setGlRefKey1(String value ,Number recNo) G/L 勘定明細の取引先参照キーに値を設定します。
void | setGlTaxCode(String value ,Number recNo) G/L 勘定明細の消費税コードに値を設定します。
void | setGlWbsElement(String value ,Number recNo) G/L 勘定明細のWBS 要素に値を設定します。
void | setPaAllocNmbr(String value ,Number recNo) 仕入先明細のソートキーに値を設定します。
void | setPaBlineDate(String value ,Number recNo) 仕入先明細の期日計算の支払基準日に値を設定します。
void | setPaGlAccount(String value ,Number recNo) 仕入先明細の総勘定元帳勘定に値を設定します。
void | setPaItemText(String value ,Number recNo) 仕入先明細の明細テキストに値を設定します。
void | setPaItemnoAcc(String value ,Number recNo) 仕入先明細の会計伝票明細番号に値を設定します。
void | setPaPymtMeth(String value ,Number recNo) 仕入先明細の支払方法に値を設定します。
void | setPaVendorNo(String value ,Number recNo) 仕入先明細の仕入先または債権者の勘定コードに値を設定します。
void | setTaGlAccount(String value ,Number recNo) 税明細の総勘定元帳勘定に値を設定します。
void | setTaItemnoAcc(String value ,Number recNo) 税明細の会計伝票明細番号に値を設定します。
void | setTaTaxCode(String value ,Number recNo) 税明細の消費税コードに値を設定します。
コンストラクタの詳細
AccEmployeePayPostController

AccEmployeePayPostController()
コンストラクタ。

メソッドの詳細
executeBapi

Object executeBapi()

BapiControllerにより会計伝票を登録します。

返却値
Object エラー情報オブジェクト

エラーオブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG エラーメッセージ (String)
ERR_DESC システム例外のメッセージ詳細 (String)
setCuAmtBase

void setCuAmtBase(String value ,Number recNo)

明細通貨項目の課税基準額に値を設定します。

パラメータ
value | String | 課税基準額
recNo | Number | レコード番号
返却値
void
setCuAmtDoccur

void setCuAmtDoccur(String value ,Number recNo)

明細通貨項目の伝票通貨額に値を設定します。

パラメータ
value | String | 伝票通貨額
recNo | Number | レコード番号
返却値
void
setCuCurrency

void setCuCurrency(String value ,Number recNo)

明細通貨項目の通貨コードに値を設定します。

パラメータ
value | String | 通貨コード
recNo | Number | レコード番号
返却値
void
setCuItemnoAcc

void setCuItemnoAcc(String value ,Number recNo)

明細通貨項目の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setDocAcDocNo

void setDocAcDocNo(String value)

伝票ヘッダの会計伝票番号に値を設定します。

パラメータ
value String 会計伝票番号
返却値
void
setDocCompCode

void setDocCompCode(String value)

伝票ヘッダの会社コードに値を設定します。

パラメータ
value String 会社コード
返却値
void
setDocDocDate

void setDocDocDate(String value)

伝票ヘッダの伝票の伝票日付に値を設定します。

パラメータ
value String 伝票の伝票日付
返却値
void
setDocDocType

void setDocDocType(String value)

伝票ヘッダの伝票タイプに値を設定します。

パラメータ
value String 伝票タイプ
返却値
void
setDocFisPeriod

void setDocFisPeriod(String value)

伝票ヘッダの会計期間に値を設定します。

パラメータ
value String 会計期間
返却値
void
setDocFiscYear

void setDocFiscYear(String value)

伝票ヘッダの会計年度に値を設定します。

パラメータ
value String 会計年度
返却値
void
setDocHeaderTxt

void setDocHeaderTxt(String value)

伝票ヘッダの伝票ヘッダテキストに値を設定します。

パラメータ
value String 伝票ヘッダテキスト
返却値
void
setDocObjKey

void setDocObjKey(String value)

伝票ヘッダのオブジェクトキーに値を設定します。

パラメータ
value String オブジェクトキー
返却値
void
setDocObjType

void setDocObjType(String value)

伝票ヘッダの参照処理に値を設定します。

パラメータ
value String 参照処理
返却値
void
setDocPstngDate

void setDocPstngDate(String value)

伝票ヘッダの伝票の転記日付に値を設定します。

パラメータ
value String 伝票の転記日付
返却値
void
setDocRefDocNo

void setDocRefDocNo(String value)

伝票ヘッダの参照伝票番号に値を設定します。

パラメータ
value String 参照伝票番号
返却値
void
setDocUsername

void setDocUsername(String value)

伝票ヘッダのユーザ名に値を設定します。

パラメータ
value String ユーザ名
返却値
void
setGlAllocNmbr

void setGlAllocNmbr(String value ,Number recNo)

G/L 勘定明細のソートキーに値を設定します。

パラメータ
value | String | ソートキー
recNo | Number | レコード番号
返却値
void
setGlBusArea

void setGlBusArea(String value ,Number recNo)

G/L 勘定明細の事業領域に値を設定します。

パラメータ
value | String | 事業領域
recNo | Number | レコード番号
返却値
void
setGlCompCode

void setGlCompCode(String value ,Number recNo)

G/L 勘定明細の会社コードに値を設定します。

パラメータ
value | String | 会社コード
recNo | Number | レコード番号
返却値
void
setGlCostcenter

void setGlCostcenter(String value ,Number recNo)

G/L 勘定明細の原価センタに値を設定します。

パラメータ
value | String | 原価センタ
recNo | Number | レコード番号
返却値
void
setGlDocType

void setGlDocType(String value ,Number recNo)

G/L 勘定明細の伝票タイプに値を設定します。

パラメータ
value | String | 伝票タイプ
recNo | Number | レコード番号
返却値
void
setGlFiscYear

void setGlFiscYear(String value ,Number recNo)

G/L 勘定明細の会計年度に値を設定します。

パラメータ
value | String | 会計年度
recNo | Number | レコード番号
返却値
void
setGlGlAccount

void setGlGlAccount(String value ,Number recNo)

G/L 勘定明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setGlItemText

void setGlItemText(String value ,Number recNo)

G/L 勘定明細の明細テキストに値を設定します。

パラメータ
value | String | 明細テキスト
recNo | Number | レコード番号
返却値
void
setGlItemnoAcc

void setGlItemnoAcc(String value ,Number recNo)

G/L 勘定明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setGlOrderid

void setGlOrderid(String value ,Number recNo)

G/L 勘定明細の指図番号に値を設定します。

パラメータ
value | String | 指図番号
recNo | Number | レコード番号
返却値
void
setGlPstngDate

void setGlPstngDate(String value ,Number recNo)

G/L 勘定明細の伝票の転記日付に値を設定します。

パラメータ
value | String | 伝票の転記日付
recNo | Number | レコード番号
返却値
void
setGlRefKey1

void setGlRefKey1(String value ,Number recNo)

G/L 勘定明細の取引先参照キーに値を設定します。

パラメータ
value | String | 取引先参照キー
recNo | Number | レコード番号
返却値
void
setGlTaxCode

void setGlTaxCode(String value ,Number recNo)

G/L 勘定明細の消費税コードに値を設定します。

パラメータ
value | String | 消費税コード
recNo | Number | レコード番号
返却値
void
setGlWbsElement

void setGlWbsElement(String value ,Number recNo)

G/L 勘定明細のWBS 要素に値を設定します。

パラメータ
value | String | WBS要素
recNo | Number | レコード番号
返却値
void
setPaAllocNmbr

void setPaAllocNmbr(String value ,Number recNo)

仕入先明細のソートキーに値を設定します。

パラメータ
value | String | ソートキー
recNo | Number | レコード番号
返却値
void
setPaBlineDate

void setPaBlineDate(String value ,Number recNo)

仕入先明細の期日計算の支払基準日に値を設定します。

パラメータ
value | String | 期日計算の支払基準日
recNo | Number | レコード番号
返却値
void
setPaGlAccount

void setPaGlAccount(String value ,Number recNo)

仕入先明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setPaItemText

void setPaItemText(String value ,Number recNo)

仕入先明細の明細テキストに値を設定します。

パラメータ
value | String | 明細テキスト
recNo | Number | レコード番号
返却値
void
setPaItemnoAcc

void setPaItemnoAcc(String value ,Number recNo)

仕入先明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setPaPymtMeth

void setPaPymtMeth(String value ,Number recNo)

仕入先明細の支払方法に値を設定します。

パラメータ
value | String | 支払方法
recNo | Number | レコード番号
返却値
void
setPaVendorNo

void setPaVendorNo(String value ,Number recNo)

仕入先明細の仕入先または債権者の勘定コードに値を設定します。

パラメータ
value | String | 仕入先または債権者の勘定コード
recNo | Number | レコード番号
返却値
void
setTaGlAccount

void setTaGlAccount(String value ,Number recNo)

税明細の総勘定元帳勘定に値を設定します。

パラメータ
value | String | 総勘定元帳勘定
recNo | Number | レコード番号
返却値
void
setTaItemnoAcc

void setTaItemnoAcc(String value ,Number recNo)

税明細の会計伝票明細番号に値を設定します。

パラメータ
value | String | 会計伝票明細番号
recNo | Number | レコード番号
返却値
void
setTaTaxCode

void setTaTaxCode(String value ,Number recNo)

税明細の消費税コードに値を設定します。

パラメータ
value | String | 消費税コード
recNo | Number | レコード番号
返却値
void


 BankController オブジェクト

銀行コントローラクラス。

銀行の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
BankController()
コンストラクタ。
メソッドの概要
Object[] | getBankList() 銀行一覧を取得します。
Object | getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
Object | getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
String | getErrCode() コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc() コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg() コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
BankController

BankController()
コンストラクタ。

メソッドの詳細
getBankList

Object[] getBankList()

銀行一覧を取得します。
返却値
Object[] 銀行情報が格納された配列

銀行情報オブジェクトの構成は以下のとおりです。
銀行情報
オブジェクト
(Object)
BANK_KEY 銀行コード (String)
BANK_NAME 銀行名 (String)
CITY 市区町村名 (String)

取得した銀行情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BANK_KEY"]　→　配列内のidx番目の銀行の「銀行コード」
[idx]["BANK_NAME"]　→　配列内のidx番目の銀行の「銀行名」
[idx]["CITY"]　→　配列内のidx番目の銀行の「市区町村名」

※ idxは0〜n （配列サイズ-1）

getBankName

Object getBankName(String bankKey)

銀行コードを指定して銀行名を取得します。

パラメータ
bankKey String SAP R/3上に存在する銀行コード
返却値
Object 指定した銀行コードに対応する銀行名
（成功時の返却値は String になります。）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCity

Object getCity(String bankKey)

銀行コードを指定して市区町村名を取得します。

パラメータ
bankKey String SAP R/3上に存在する銀行コード
返却値
Object 指定した銀行コードに対応する市区町村名
（成功時の返却値は String になります。）

（失敗時） エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 BapiController オブジェクト

BAPIコントローラクラス。

ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、
BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡
展開後、BAPI処理を実行し、実行結果を保持します｡
ソリューション特化型APIは、実行結果を当クラスの公開アクセサメソッドを
使用して取得します｡
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
BapiController(String propertyName)
コンストラクタ。
メソッドの概要
void | clear() セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
Object | executeBapi() BAPI処理を実行します。
String | getErrCode() コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc() コンストラクタでエラー時の実行時エラー内容を取得します。
Object | getErrMessage() ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getErrMsg() コンストラクタでエラー時のエラーメッセージを取得します。
Object | getExportParam(String key) export(Export)情報を返します。
Object | getReturn() ＢＡＰＩ実行結果を取得します。
Object | getReturnList() ＢＡＰＩ実行結果の一覧を取得します。
Object | getStructureParam(String paramName) structure(Export)情報を返します。
Object | getTableParam(String paramName) table(Export)情報を返します。
Object | isSuccess() ＢＡＰＩ実行が正常に行われたか判定します。
Object | putImportParam(String key ,String val) BAPI処理実行パラメータを格納します。
Object | putStructParam(String key ,String val ,String structName) BAPI処理実行パラメータを格納します。
Object | putTableParam(String key ,String val ,String tableName ,Number recordNo) BAPI処理実行パラメータを格納します。
コンストラクタの詳細
BapiController

BapiController(String propertyName)
コンストラクタ。

パラメータ
propertyName String BAPIコントローラが使用するプロパティファイル名
メソッドの詳細
clear

void clear()

セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。

返却値
void
executeBapi

Object executeBapi()

BAPI処理を実行します。

JCO.Connectionを生成し､JCO.Functionの生成、
BAPI引渡しパラメータの生成を行いBAPI処理を実行します｡
またBAPI実行結果から、BapiHashオブジェクトの生成とBapiHashListへの追加、
BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
返却値
Object 空文字列 ""
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMessage

Object getErrMessage()

ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩの実行結果でBapiReturnのType情報が正常(S)以外の
BapiReturnオブジェクトのメッセージ情報を全て返します。
全て正常(S)の場合は、nullが返却されます｡
返却値
Object SAP R/3のエラーメッセージ
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrMsg

String getErrMsg()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getExportParam

Object getExportParam(String key)

export(Export)情報を返します。

入力／出力区分、パラメータ属性、パラメータ名、プロパティファイルのキー情報で
一覧から該当するBapiHashオブジェクトを検索して、値を返します｡
パラメータ
key String 検索条件となるPropertyKey
返却値
Object 引数のキーに対応する値
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getReturn

Object getReturn()

ＢＡＰＩ実行結果を取得します。(Structure用)

structure型のBAPI実行結果（RETURNパラメータ）を取得します。

返却値
Object BAPI実行結果（RETURNパラメータ）が格納された配列
（成功時の返却値は Object[] になります。）

BAPI実行結果情報オブジェクトの構成は以下のとおりです。
BAPI実行結果情報
オブジェクト
(Object)
TYPE メッセージタイプ (String)
ID メッセージクラス (String)
CODE メッセージコード (String)
NUMBER メッセージ番号 (String)
MESSAGE メッセージテキスト (String)
LOG_NO ログ番号 (String)
LOG_MSG_NO メッセージシリアル番号 (String)
MESSAGE_V1 メッセージ変数 (String)
MESSAGE_V2 メッセージ変数 (String)
MESSAGE_V3 メッセージ変数 (String)
MESSAGE_V4 メッセージ変数 (String)
PARAMETER パラメータ名 (String)
ROW パラメータの行 (String)
FIELD パラメータの項目 (String)
SYSTEM メッセージが発行された論理システム (String)

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getReturnList

Object getReturnList()

ＢＡＰＩ実行結果の一覧を取得します。(Table用)

table型のBAPI実行結果（RETURNパラメータ）の一覧を取得します。

返却値
Object BAPI実行結果（RETURNパラメータ）が格納された配列
（成功時の返却値は Object[] になります。）

BAPI実行結果情報オブジェクトの構成は以下のとおりです。
BAPI実行結果情報
オブジェクト
(Object)
TYPE メッセージタイプ (String)
ID メッセージクラス (String)
CODE メッセージコード (String)
NUMBER メッセージ番号 (String)
MESSAGE メッセージテキスト (String)
LOG_NO ログ番号 (String)
LOG_MSG_NO メッセージシリアル番号 (String)
MESSAGE_V1 メッセージ変数 (String)
MESSAGE_V2 メッセージ変数 (String)
MESSAGE_V3 メッセージ変数 (String)
MESSAGE_V4 メッセージ変数 (String)
PARAMETER パラメータ名 (String)
ROW パラメータの行 (String)
FIELD パラメータの項目 (String)
SYSTEM メッセージが発行された論理システム (String)

取得した銀行情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["TYPE"]　→　配列内のidx番目のBAPI実行結果の「メッセージType」
[idx]["ID"]　→　配列内のidx番目のBAPI実行結果の「メッセージクラス」
[idx]["CODE"]　→　配列内のidx番目のBAPI実行結果の「メッセージコード」
[idx]["NUMBER"]　→　配列内のidx番目のBAPI実行結果の「メッセージ番号」
[idx]["MESSAGE"]　→　配列内のidx番目のBAPI実行結果の「メッセージテキスト」
[idx]["LOG_NO"]　→　配列内のidx番目のBAPI実行結果の「ログ番号」
[idx]["LOG_MSG_NO"]　→　配列内のidx番目のBAPI実行結果の「メッセージシリアル番号」
[idx]["MESSAGE_V1"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
[idx]["MESSAGE_V2"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
[idx]["MESSAGE_V3"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
[idx]["MESSAGE_V4"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
[idx]["PARAMETER"]　→　配列内のidx番目のBAPI実行結果の「パラメータ名」
[idx]["ROW"]　→　配列内のidx番目のBAPI実行結果の「パラメータの行」
[idx]["FIELD"]　→　配列内のidx番目のBAPI実行結果の「パラメータの項目」
[idx]["SYSTEM"]　→　配列内のidx番目のBAPI実行結果の「メッセージが発行された論理システム」

※ idxは0〜n （配列サイズ-1）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getStructureParam

Object getStructureParam(String paramName)

structure(Export)情報を返します。

入力／出力区分、パラメータ属性、パラメータ名で、
一覧から該当するBapiHashオブジェクトを検索して返します｡
パラメータ
paramName String 検索条件となるParamName
返却値
Object 検索結果となるBapiHash

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getTableParam

Object getTableParam(String paramName)

table(Export)情報を返します。

入力／出力区分、パラメータ属性、パラメータ名で、
一覧から該当するBapiHashオブジェクトを検索し、一覧に格納して返します｡
パラメータ
paramName String 検索条件となるParamName
返却値
Object 検索結果となるBapiHash

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

isSuccess

Object isSuccess()

ＢＡＰＩ実行が正常に行われたか判定します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(S)であった場合"true"を、
それ以外は"false"を返します｡
返却値
Object 処理結果判定
（成功時の返却値は Boolean になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

putImportParam

Object putImportParam(String key ,String val)

BAPI処理実行パラメータを格納します。

引数に指定された条件でBapiHashオブジェクト
(入力／出力区分="import", パラメータ属性="import") を生成し､
一覧に格納します｡
パラメータ
key | String | BapiHashに設定するHashMapのキー
val | String | BapiHashに設定するHashMapの値
返却値
Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

putStructParam

Object putStructParam(String key ,String val ,String structName)

BAPI処理実行パラメータを格納します。

引数に指定された条件でBapiHashオブジェクト
(入力／出力区分="import", パラメータ属性="structure",パラメータ名=第３引数)を生成し､
一覧に格納します｡
パラメータ
key | String | BapiHashに設定するHashMapのキー
val | String | BapiHashに設定するHashMapの値
structName | String | BapiHashに設定するparamTypeの値
返却値
Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

putTableParam

Object putTableParam(String key ,String val ,String tableName ,Number recordNo)

BAPI処理実行パラメータを格納します。

引数に指定された条件でBapiHashオブジェクト
(入力／出力区分="import", パラメータ属性="table",パラメータ名=第３引数,レコード番号=第４引数)を生成し､
一覧に格納します｡
パラメータ
key | String | BapiHashに設定するHashMapのキー
val | String | BapiHashに設定するHashMapの値
tableName | String | BapiHashに設定するparamTypeの値
recordNo | Number | BapiHashに設定するrecordNoの値
返却値
Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 BusinessAreaController オブジェクト

事業領域コントローラクラス。

事業領域の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
BusinessAreaController()
コンストラクタ。
メソッドの概要
Object | getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
Object[] | getBusinessAreaList() 事業領域一覧を取得します。
String | getErrCode() コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc() コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg() コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
BusinessAreaController

BusinessAreaController()
コンストラクタ。

メソッドの詳細
getBusArDes

Object getBusArDes(String busArea)

事業領域を指定して事業領域名を取得します。

パラメータ
busArea String SAP R/3上に存在する事業領域コード
返却値
Object 指定した事業領域コードに対応する事業領域名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getBusinessAreaList

Object[] getBusinessAreaList()

事業領域一覧を取得します。

返却値
Object[] 事業領域情報が格納された配列

事業領域情報オブジェクトの構成は以下のとおりです。
事業領域情報
オブジェクト
(Object)
BUS_AREA 事業領域コード (String)
BUS_AREA_DES 事業領域名 (String)

取得した事業領域情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["BUS_AREA"]　→　配列内のidx番目の事業領域の「事業領域コード」
[idx]["BUS_AREA_DES"]　→　配列内のidx番目の事業領域の「事業領域名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 CompanyController オブジェクト

会社コントローラクラス。

会社の情報を取得します｡
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CompanyController()
コンストラクタ。
メソッドの概要
Object | getCompName(String compCode) 会社コードを指定して会社名を取得します。
Object[] | getCompanyList() 会社一覧を取得します。
String | getErrCode() コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc() コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg() コンストラクタでエラー時のエラーメッセージを取得します。
コンストラクタの詳細
CompanyController

CompanyController()
コンストラクタ。

メソッドの詳細
getCompName

Object getCompName(String compCode)

会社コードを指定して会社名を取得します。

パラメータ
compCode String SAP R/3上に存在する会社コード
返却値
Object 指定した会社コードに対応する会社名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getCompanyList

Object[] getCompanyList()

会社一覧を取得します。

返却値
Object[] 会社情報が格納された配列

会社情報オブジェクトの構成は以下のとおりです。
会社情報
オブジェクト
(Object)
COMP_CODE 会社コード (String)
COMP_NAME 会社名 (String)

取得した会社情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["COMP_CODE"]　→　配列内のidx番目の会社の「会社コード」
[idx]["COMP_NAME"]　→　配列内のidx番目の会社の「会社名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ


 ConnectionManager オブジェクト

ConnectionManagerクラス

R/3へのコネクション(トランザクション)を管理するクラスです。
commitとrollbackの2つのパブリックメソッドを持ち、業務ロジックの最後に実行することで R/3への変更を確定/取り消しすることができます。
なお、R/3へのコネクションの開放も上記2メソッド内で実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
ConnectionManager()
コンストラクタ
メソッドの概要
Object | commit() ＢＡＰＩ実行結果のCOMMIT処理を行います｡
Object | rollback() ＢＡＰＩ実行結果のROLLBACK処理を行います｡
コンストラクタの詳細
ConnectionManager

ConnectionManager()
コンストラクタ
メソッドの詳細
commit

Object commit()

ＢＡＰＩ実行結果のCOMMIT処理を行います｡
返却値
Object 空文字列 ""
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

rollback

Object rollback()

ＢＡＰＩ実行結果のROLLBACK処理を行います｡
返却値
Object 空文字列 ""
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
3： 汎用系システムエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 ControllingAreaController オブジェクト

管理領域コントローラクラス。

管理領域の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
ControllingAreaController()
コンストラクタ。
メソッドの概要
Object[] | getControllingAreaList() 管理領域一覧を取得します。
String | getErrCode() コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc() コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg() コンストラクタでエラー時のエラーメッセージを取得します。
Object | getName(String coArea) 管理領域を指定して管理領域名を取得します。
コンストラクタの詳細
ControllingAreaController

ControllingAreaController()
コンストラクタ。

メソッドの詳細
getControllingAreaList

Object[] getControllingAreaList()

管理領域一覧を取得します。

返却値
Object[] 管理領域情報が格納された配列

管理領域情報オブジェクトの構成は以下のとおりです。
管理領域情報
オブジェクト
(Object)
CO_AREA 管理領域コード (String)
NAME 管理領域名 (String)

取得した管理領域情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CO_AREA"]　→　配列内のidx番目の管理領域の「管理領域コード」
[idx]["NAME"]　→　配列内のidx番目の管理領域の「管理領域名」

※ idxは0〜n （配列サイズ-1）

getErrCode

String getErrCode()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getName

Object getName(String coArea)

管理領域を指定して管理領域名を取得します。

パラメータ
coArea String SAP R/3上に存在する管理領域コード
返却値
Object 指定した管理領域コードに対応する管理領域名
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 CostCenterController オブジェクト

原価センタコントローラクラス。

原価センタの情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CostCenterController(String controllingArea)
コンストラクタ。
CostCenterController(String controllingArea ,String date)
コンストラクタ。
メソッドの概要
Object[] | getCostCenterList() 原価センタ一覧を取得します。
Object | getDescript(SAP costCenter) 原価センタを指定してテキストを取得します。
String | getErrCode() コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc() コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg() コンストラクタでエラー時のエラーメッセージを取得します。
Object | getName(String costCenter) 原価センタを指定して一般名称を取得します。
コンストラクタの詳細
CostCenterController

CostCenterController(String controllingArea)
コンストラクタ。

引数１つのコンストラクタです。
システム日付で有効な原価センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP R/3上に存在する管理領域コード
CostCenterController

CostCenterController(String controllingArea ,String date)
コンストラクタ。

引数２つのコンストラクタです。
指定したYYYYMMDDの日付で有効な原価センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP R/3上に存在する管理領域コード
date String 有効期間(開始) ※日付書式「YYYYMMDD」
メソッドの詳細
getCostCenterList

Object[] getCostCenterList()

原価センタ一覧を取得します。

返却値
Object[] 原価センタ情報が格納された配列

原価センタ情報オブジェクトの構成は以下のとおりです。
原価センタ情報
オブジェクト
(Object)
CONTROLLING_AREA 管理領域コード (String)
COST_CENTER 原価センタコード (String)
DESCRIPT 一般名称 (String)
NAME テキスト (String)

取得した原価センタ情報の配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONTROLLING_AREA"]　→　配列内のidx番目の原価センタの「管理領域コード」
[idx]["COST_CENTER"]　→　配列内のidx番目の原価センタの「原価センタコード」
[idx]["DESCRIPT"]　→　配列内のidx番目の原価センタの「一般名称」
[idx]["NAME"]　→　配列内のidx番目の原価センタの「テキスト」

※ idxは0〜n （配列サイズ-1）

getDescript

Object getDescript(SAP costCenter)

原価センタを指定してテキストを取得します。

パラメータ
costCenter SAP R/3上に存在する原価センタコード
返却値
Object 指定した原価センタコードに対応するテキスト
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getErrCode

String getErrCode()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getName

Object getName(String costCenter)

原価センタを指定して一般名称を取得します。

パラメータ
costCenter String SAP R/3上に存在する原価センタコード
返却値
Object 指定した原価センタコードに対応する一般名称
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 GlAccController オブジェクト

勘定科目コントローラクラス。

勘定科目の情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
GlAccController(String companyCode)
コンストラクタ。
メソッドの概要
String | getErrCode() コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc() コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg() コンストラクタでエラー時のエラーメッセージを取得します。
Object[] | getGlAccList() 勘定科目一覧を取得します。
Object | getLongText(String glAccount) 総勘定元帳勘定テキスト(長)を取得します。
Object | getShortText(String glAccount) G/L勘定コードテキスト(短)を取得します。
コンストラクタの詳細
GlAccController

GlAccController(String companyCode)
コンストラクタ。

パラメータ
companyCode String SAP R/3上に存在する会社コード
メソッドの詳細
getErrCode

String getErrCode()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getGlAccList

Object[] getGlAccList()

勘定科目一覧を取得します。

返却値
Object[] 勘定科目情報が格納された配列

勘定科目情報オブジェクトの構成は以下のとおりです。
勘定科目情報
オブジェクト
(Object)
COMPANY_CODE 会社コード (String)
GL_ACCOUNT G/L勘定コード (String)
SHORT_TEXT G/L勘定コードテキスト(短) (String)
LONG_TEXT 総勘定元帳勘定テキスト(長) (String)

取得した勘定科目情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["COMPANY_CODE"]　→　配列内のidx番目の勘定科目の「会社コード」
[idx]["GL_ACCOUNT"]　→　配列内のidx番目の勘定科目の「G/L勘定コード」
[idx]["SHORT_TEXT"]　→　配列内のidx番目の勘定科目の「G/L勘定コードテキスト(短)」
[idx]["LONG_TEXT"]　→　配列内のidx番目の勘定科目の「総勘定元帳勘定テキスト(長)」

※ idxは0〜n （配列サイズ-1）

getLongText

Object getLongText(String glAccount)

総勘定元帳勘定テキスト(長)を取得します。

G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
パラメータ
glAccount String SAP R/3上に存在するG/L勘定コード
返却値
Object 指定したG/L勘定コードに対応する総勘定元帳勘定テキスト(長)
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getShortText

Object getShortText(String glAccount)

G/L勘定コードテキスト(短)を取得します。

G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
パラメータ
glAccount String SAP R/3上に存在するG/L勘定コード
返却値
Object 指定したG/L勘定コードに対応するG/L勘定コードテキスト(短)
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


JavaScript API リスト概要

 JavaScript API リスト 概要

ページベース開発モデルで利用可能なJavaScript API の概要です。

オブジェクトの概要
AccEmployeePayPostController | 伝票登録コントローラクラス。
BankController | 銀行コントローラクラス。
BapiController | BAPIコントローラクラス。
BusinessAreaController | 事業領域コントローラクラス。
CompanyController | 会社コントローラクラス。
ConnectionManager | ConnectionManagerクラス R/3へのコネクション(トランザクション)を管理するクラスです。
ControllingAreaController | 管理領域コントローラクラス。
CostCenterController | 原価センタコントローラクラス。
GlAccController | 勘定科目コントローラクラス。
ProfitCenterController | 利益センタコントローラクラス。


JavaScript API リスト

 オブジェクト
AccEmployeePayPostController
BankController
BapiController
BusinessAreaController
CompanyController
ConnectionManager
ControllingAreaController
CostCenterController
GlAccController
ProfitCenterController


 ProfitCenterController オブジェクト

利益センタコントローラクラス。

利益センタの情報を取得します。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
ProfitCenterController(String controllingArea)
コンストラクタ。
ProfitCenterController(String controllingArea ,String date)
コンストラクタ。
メソッドの概要
String | getErrCode() コンストラクタでエラー時のエラーコードを取得します。
String | getErrDesc() コンストラクタでエラー時の実行時エラー内容を取得します。
String | getErrMsg() コンストラクタでエラー時のエラーメッセージを取得します。
Object | getInCharge(String profitCtr) 利益センタ責任者を取得します。
Object指定した利益センタコードに対応する一般名称 | getPctrName(String profitCtr) 一般名称を取得します。
Object[] | getProfitCenterList() 利益センタ情報一覧を取得します。
Object | getValidTo(String profitCtr) 有効終了日を取得します。
コンストラクタの詳細
ProfitCenterController

ProfitCenterController(String controllingArea)
コンストラクタ。

引数１つのコンストラクタです。
システム日付で有効な利益センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP R/3上に存在する管理領域コード
ProfitCenterController

ProfitCenterController(String controllingArea ,String date)
コンストラクタ。

引数２つコンストラクタです。
指定したYYYYMMDDの日付で有効な利益センタ情報が抽出対象となります。
パラメータ
controllingArea String SAP R/3上に存在する管理領域コード
date String 日付 ※日付書式「YYYYMMDD」
メソッドの詳細
getErrCode

String getErrCode()

コンストラクタでエラー時のエラーコードを取得します。

コンストラクタでエラーが発生した場合のエラーコードを取得します。
コンストラクタでエラーが発生しなかった場合は、常に "0" を返します。
返却値
String エラーコード
getErrDesc

String getErrDesc()

コンストラクタでエラー時の実行時エラー内容を取得します。

コンストラクタでエラーが発生した場合の実行時エラー内容を取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String 実行時エラー内容
getErrMsg

String getErrMsg()

コンストラクタでエラー時のエラーメッセージを取得します。

コンストラクタでエラーが発生した場合のエラーメッセージを取得します。
コンストラクタでエラーが発生しなかった場合は、常に null を返します。
返却値
String エラーメッセージ
getInCharge

Object getInCharge(String profitCtr)

利益センタ責任者を取得します。

利益センタコードを指定して利益センタ責任者を取得します。
パラメータ
profitCtr String SAP R/3上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する利益センタ責任者
（成功時の返却値は String になります。）
（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getPctrName

Object指定した利益センタコードに対応する一般名称
         getPctrName(String profitCtr)

一般名称を取得します。

利益センタコードを指定して一般名称を取得します。
パラメータ
profitCtr String SAP R/3上に存在する利益センタコード
返却値
Object指定した利益センタコードに対応する一般名称
         （成功時の返却値は String になります。）
（失敗時）Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)

getProfitCenterList

Object[] getProfitCenterList()

利益センタ情報一覧を取得します。

返却値
Object[] 利益センタ情報が格納された配列

利益センタ情報オブジェクトの構成は以下のとおりです。
利益センタ情報
オブジェクト
(Object)
CONTROLLING_AREA 管理領域コードコード (String)
PROFIT_CTR 利益センタコード (String)
VALID_TO 有効終了日 (String)
IN_CHARGE 利益センタ責任者 (String)
PCTR_NAME 一般名称 (String)

取得した利益センタ情報オブジェクトの配列は、２次元配列になっています。
値を取得する 際に指定する配列のキー値は以下の通りです。

[idx]["CONTROLLING_AREA"]　→　配列内のidx番目の利益センタの「管理領域コード」
[idx]["PROFIT_CTR"]　→　配列内のidx番目の利益センタの「利益センタコード」
[idx]["VALID_TO"]　→　配列内のidx番目の利益センタの「有効終了日」
[idx]["IN_CHARGE"]　→　配列内のidx番目の利益センタの「利益センタ責任者」
[idx]["PCTR_NAME"]　→　配列内のidx番目の利益センタの「一般名称」

※ idxは0〜n （配列サイズ-1）

getValidTo

Object getValidTo(String profitCtr)

有効終了日を取得します。

利益センタコードを指定して有効終了日を取得します。
パラメータ
profitCtr String SAP R/3上に存在する利益センタコード
返却値
Object 指定した利益センタコードに対応する有効終了日
（成功時の返却値は String になります。）

（失敗時） Object エラー情報オブジェクト

エラー情報オブジェクトの構成は以下のとおりです。
エラー情報
オブジェクト
(Object)
ERR_CODE エラーコード (String)
1： 認証系システムエラー
2： 認証系アプリケーションエラー
3： 汎用系システムエラー
4： 汎用系アプリケーションエラー
5： 会計業務系システムエラー
6： 会計業務系アプリケーションエラー
ERR_MSG アプリケーション例外(システム例外)のメッセージ概要 (String)
ERR_DESC システム例外のメッセージ詳細 (String)


 AccessSecurityManager オブジェクト

セキュリティマネージャオブジェクト。

セキュリティ情報の参照を行うマネージャオブジェクトです。

セッションに関する設定情報を操作する場合に用いるセッションコンフィグオブジェクトの構成は以下の通りです。
セッションコンフィグオブジェクト
セッションコンフィグ
オブジェクト
(Object)
clientTypeName クライアントタイプをセッションに保管するためのパラメータ名 (String)
colorPatternIdName カラーパターンIDをセッションに保管するためのパラメータ名 (String)
encodingName エンコーディングをセッションに保管するためのパラメータ名 (String)
initialUrlName 初期ページURLをセッションに保管するためのパラメータ名 (String)
localeName ロケールをセッションに保管するためのパラメータ名 (String)
loginGroupName ログイングループをセッションに保管するためのパラメータ名 (String)
loginTimeName ログイン時間をセッションに保管するためのパラメータ名 (String)
loginTypeName ログインタイプをセッションに保管するためのパラメータ名 (String)
sessionCookieName クッキーにセッション情報を保管するためパラメータ名 (String)
signatureName ログイン署名をセッションに保管するためのパラメータ名 (String)
urlName ダイレクトＵＲＬをセッションに保管するためパラメータ名 (String)
urlSignatureName ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名 (String)
userName ユーザＩＤをセッションに保管するためのパラメータ名 (String)

セッション情報を操作する場合に用いるセッションオブジェクトの構成は以下の通りです。
セッションオブジェクト
セッション
オブジェクト
(Object)
clientType [必須] クライアントタイプ (String)
colorPatternId カラーパターンID (String)
encoding エンコーディング (String)
initialUrl 初期ページURL (String)
locale ロケール (String)
loginGroup ログイングループ (String)
loginTime ログイン時間 (Date)
loginType ログインタイプ (String)
signature 署名 (String)
url URL (String)
urlSignature URL署名 (String)
user ユーザＩＤ (String)

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | createUrlSignature(String url ,String groupId ,String userId) ダイレクトＵＲＬ署名を作成します。
static void | forward(String url) 指定のＵＲＬにフォワードします。
static Object | getCookieSessionInfo() カレントスレッド情報のクッキーからintra-martセッション情報を取得します。
static String | getErrorPage(int errorCode) カレントスレッド情報からエラーページＵＲＬを取得します。
static String | getInitialPage() カレントスレッド情報から初期アクセスページURLを取得します。
static int | getLoginCertification() カレントスレッド情報からログイン処理を行います。
static String | getMainPage() カレントスレッド情報からメインページURLを取得します。
static Object | getSessionConfig() セッション情報保管パラメータを取得します。
static Object | getSessionInfo() カレントスレッド情報からintra-martセッション情報を取得します。
static int | getSessionMode() intra-martセッションの状態を取得します。
static void | logout() ログアウト処理を行います。
メソッドの詳細
createUrlSignature

static String createUrlSignature(String url ,String groupId ,String userId)

ダイレクトＵＲＬ署名を作成します。

パラメータ
url | String | ダイレクトＵＲＬ
groupId | String | ログイングループＩＤ
userId | String | ユーザＩＤ
返却値
String ダイレクトURL署名
forward

static void forward(String url)

指定のＵＲＬにフォワードします。

urlにはコンテキストパス（'/'）から始まるURLを指定してください。
パラメータ
url String ＵＲＬ
返却値
void
getCookieSessionInfo

static Object getCookieSessionInfo()

カレントスレッド情報のクッキーからintra-martセッション情報を取得します。

このメソッドを利用するためには、jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestManagementFilterを
web.xmlにフィルタとして設定する必要があります。
返却値
Object クッキーに保管されているintra-martセッション情報
セッション情報保管用のクッキーが存在しない場合はnull
getErrorPage

static String getErrorPage(int errorCode)

カレントスレッド情報からエラーページＵＲＬを取得します。

引数で指定したエラーページＵＲＬを返却します。
パラメータ
errorCode int ログインエラーコード
返却値
String エラーページのＵＲＬ
ページが存在しなかった場合は、null
getInitialPage

static String getInitialPage()

カレントスレッド情報から初期アクセスページURLを取得します。

返却値
String 初期アクセスページURL
getLoginCertification

static int getLoginCertification()

カレントスレッド情報からログイン処理を行います。

ログイン処理後のページを取得します。

返却値
int ログインエラーコード
getMainPage

static String getMainPage()

カレントスレッド情報からメインページURLを取得します。

ログイン後のメインページを取得します。

返却値
String メインページURL
ページが存在しなかった場合は、nullを返却します。
getSessionConfig

static Object getSessionConfig()

セッション情報保管パラメータを取得します。

返却値
Object セッション情報保管パラメータ情報
getSessionInfo

static Object getSessionInfo()

カレントスレッド情報からintra-martセッション情報を取得します。

返却値
Object intra-martセッション情報
セッションが存在しない場合はnull
getSessionMode

static int getSessionMode()

intra-martセッションの状態を取得します。

返却値
int セッション状態
初期状態 | SecurityConst.CR_SESSION_INITIAL
ログオン状態 | SecurityConst.CR_SESSION_LOGON
セッション不整合状態 | SecurityConst.CR_SESSION_UNMATCH
セッションタイムアウト状態 | SecurityConst.CR_SESSION_TIMEOUT
logout

static void logout()

ログアウト処理を行います。

返却値
void


 AccountManager オブジェクト

アカウントマネージャオブジェクト
アカウント情報の参照、更新を行うマネージャオブジェクトです。
アカウント情報を操作する場合に用いるアカウントオブジェクトの構成は以下の通りです。
アカウントオブジェクト
アカウント
オブジェクト
(Object)
encoding エンコーディング (String)
goOut 外出フラグ (Boolean)
locale ロケール (String)
lockDate アカウントロック日付 (String)
loginFailureCount ログイン失敗回数 (Number)
mainPagePatternId メインページパターンID (String)
mobilePassword モバイル用パスワード (String)
note 説明 (String)
colorPatternId カラーパターンID (String)
password パスワード (String)
userId ユーザID (String)
validEndDate 有効終了日 (Date)
validStartDate 有効開始日 (Date)

アカウントロール情報を操作する場合に用いるアカウントロールオブジェクトの構成は以下の通りです。
アカウントロールオブジェクト
アカウント
ロールオブジェクト
(Object)
roleId
ロールID(String)
validEndDate
アカウントロール用の有効期間終了日を保存する属性名 (Date)
validStartDate
アカウントロール用の有効期間開始日を保存する属性名 (Date)

マイメニュー情報を操作する場合に用いるマイメニューオブジェクトの構成は以下の通りです。
マイメニューオブジェクト
マイメニュー
オブジェクト
(Object)
name
マイメニュー情報・表示名ID (String)
menuId
マイメニュー情報・メニューID (String)
sortNum
マイメニュー情報・ソート番号 (String)
バージョン：2.0
導入されたバージョン：2.0
コンストラクタの概要
AccountManager(String groupId)
コンストラクタ。
メソッドの概要
Boolean addAccount(Object object)
アカウントを新規に登録します。
Boolean addAccountRole(String userId ,Object object)
アカウントロールを新規追加します。
Boolean addFavoriteMenu(String userId ,Object object)
マイメニューを新規追加します。
Boolean contains(String userId)
アカウントの存在チェックを行います。
Number count()
アカウントの登録数を取得します。
Object del(String uid [,Array funcs] [,Boolean isTransaction])
推奨されていません。AccountManager.deleteAccount(String userId) に置き換えられました。
Boolean deleteAccount(String userId)
アカウントを削除します。
Boolean deleteAccountRole(String userId ,String roleId)
アカウントロールを削除します。
Boolean deleteAccountRoles(String userId)
全てのアカウントロールを削除します。
Boolean deleteAccounts()
すべてのアカウントを削除します。
String exportData(String category)
アカウントのエクスポートを行います。
DataForAccount get(String userId)
推奨されていません。AccountManager.getAccount(String userId) に置き換えられました。
Object getAccount(String userId)
ユーザIDにマッチしたアカウントを取得します。
Array getAccountRoleIds(String userId)
アカウントロールIDを全て取得します。
Array getAccountRoles(String userId [,Date date])
アカウントロールを全て取得します。
Array getAccounts()
すべてのアカウントを取得します。
Array getAccountsByUserIds(Array userIds)
引数のユーザIDのアカウントをすべて取得します。
Array getFavoriteMenuIds(String userId)
マイメニューIDを全て取得します。
Array getFavoriteMenus(String userId)
マイメニューを全て取得します。
Array getKeys()
推奨されていません。AccountManager.getUserIds() に置き換えられました。
String getLoginGroupId()
ログイングループIDを取得します。
Array getRoleIds(String userId ,Date date)
アカウントが持つ有効なロールIDを全て取得する。
Array getUserIds()
すべてのアカウントのユーザIDを取得します。
Array getUserIdsByAccountRole(String roleId)
引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。
Array getUserIdsByRole(String roleId ,Date date)
引数で指定したロールを持つすべてのアカウントのユーザIDを取得する。
Boolean importData(String category ,String str)
アカウントのインポートを行います。
Array searchAccounts(String userId)
アカウントのユーザIDを検索してマッチしたアカウント取得します。
Object set(Object request [,Array funcs] [,Boolean isTransaction])
推奨されていません。AccountManager.addAccount(Object account) および AccountManager.updateAccount(Object account)に置き換えられました。
Boolean updateAccount(Object account)
アカウントを更新します。
Boolean updateAccountRole(String userId ,Object accountRole)
アカウントロールを更新します。
Boolean updateFavoriteMenu(String userId ,Object favoriteMenu)
マイメニューを更新します。
コンストラクタの詳細
AccountManager

AccountManager(String groupId)
コンストラクタ。

指定したログイングループのアカウントマネージャオブジェクトを生成します。
パラメータ
groupId String ログイングループID
導入されたバージョン：2.0
メソッドの詳細
addAccount

Boolean addAccount(Object object)

アカウントを新規に登録します。

パラメータ
object Object アカウントオブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
addAccountRole

Boolean addAccountRole(String userId ,Object object)

アカウントロールを新規追加します。

パラメータ
userId | String | ユーザID
object | Object | アカウントロールオブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
addFavoriteMenu

Boolean addFavoriteMenu(String userId ,Object object)

マイメニューを新規追加します。

パラメータ
userId | String | ユーザID
object | Object | マイメニューオブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
contains

Boolean contains(String userId)

アカウントの存在チェックを行います。

パラメータ
userId String ユーザID
返却値
Boolean true : 存在する / false : 存在しない、または情報取得に失敗した場合 * @since 2.0
count

Number count()

アカウントの登録数を取得します。

返却値
Number アカウント登録数（エラーの場合は-1を返します）
導入されたバージョン：2.0
del

Object del(String uid [,Array funcs] [,Boolean isTransaction])

推奨されていません。AccountManager.deleteAccount(String userId) に置き換えられました。
アカウントを削除します。

パラメータ
uid | String | ユーザID
funcs | Array | 動かしたい関数があれば、パスを配列にいれて渡します。(任意)
isTransaction Boolean DBトランザクションフラグ(任意)
trueの場合 このメソッドの中でDBトランザクションを張る。
falseの場合 このメソッドの中でDBトランザクションを張らない。デフォルトはtrue。
返却値
Object 結果オブジェクトまたは、引数が不正の場合、falseを返却します。
結果オブジェクト getCode() エラーコード
-1 実行エラー
0 成功
その他 各アプリに依存
getMessage() エラーメッセージ
導入されたバージョン：2.0
deleteAccount

Boolean deleteAccount(String userId)

アカウントを削除します。

パラメータ
userId String 削除対象アカウントのユーザID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
deleteAccountRole

Boolean deleteAccountRole(String userId ,String roleId)

アカウントロールを削除します。

パラメータ
userId | String | 削除ユーザID
roleId | String | ロールID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
deleteAccountRoles

Boolean deleteAccountRoles(String userId)

全てのアカウントロールを削除します。

パラメータ
userId String 削除ユーザID
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
deleteAccounts

Boolean deleteAccounts()

すべてのアカウントを削除します。

返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
exportData

String exportData(String category)

アカウントのエクスポートを行います。

パラメータ
category String カテゴリ
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
導入されたバージョン：5.0
get

DataForAccount get(String userId)

推奨されていません。AccountManager.getAccount(String userId) に置き換えられました。
アカウントを取得します。

パラメータ
userId String ユーザID
返却値
DataForAccount DataForAccountオブジェクト
存在しない場合はnullを返却します。
導入されたバージョン：2.0
getAccount

Object getAccount(String userId)

ユーザIDにマッチしたアカウントを取得します。

存在しなかった場合および取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Object アカウントオブジェクト
getAccountRoleIds

Array getAccountRoleIds(String userId)

アカウントロールIDを全て取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Array アカウントロールIDの配列
導入されたバージョン：5.0
getAccountRoles

Array getAccountRoles(String userId [,Date date])

アカウントロールを全て取得します。

引数dateで有効範囲にあるアカウントロールの一覧を取得します。
引数dateを省略した場合は、すべてのアカウントロールの一覧が返却されます。

取得に失敗した場合は、nullを返却します。
パラメータ
userId | String | ユーザID
date | Date | 対象日付
返却値
Array アカウントロールオブジェクト の配列
導入されたバージョン：5.0
getAccounts

Array getAccounts()

すべてのアカウントを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array アカウントオブジェクト の配列（データがない場合は空の配列を返します）
導入されたバージョン：5.0
getAccountsByUserIds

Array getAccountsByUserIds(Array userIds)

引数のユーザIDのアカウントをすべて取得します。

引数のユーザIDの一覧の中で存在するアカウントのみを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userIds Array ユーザIDの配列
返却値
Array アカウントオブジェクト の配列（データがない場合は空の配列を返します）
導入されたバージョン：5.0
getFavoriteMenuIds

Array getFavoriteMenuIds(String userId)

マイメニューIDを全て取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Array マイメニューIDの配列
導入されたバージョン：5.0
getFavoriteMenus

Array getFavoriteMenus(String userId)

マイメニューを全て取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Array マイメニューオブジェクト の配列
導入されたバージョン：5.0
getKeys

Array getKeys()

推奨されていません。AccountManager.getUserIds() に置き換えられました。
ユーザIDをすべて取得します。

返却値
Array ユーザIDの配列。
存在しない場合は空の配列を返却します。
導入されたバージョン：2.0
getLoginGroupId

String getLoginGroupId()

ログイングループIDを取得します。

返却値
String ログイングループID
導入されたバージョン：5.0
getRoleIds

Array getRoleIds(String userId ,Date date)

アカウントが持つ有効なロールIDを全て取得する。
指定日付でアカウントに紐付く有効なアカウントロールをすべて取得し、
有効なアカウントロールが持つすべてのサブロールを取得して、ロールIDの一覧を返却します。
存在しなかった場合および取得に失敗した場合は、空の配列を返却します。
パラメータ
userId | String | ユーザID
date | Date | 日付
返却値
Array ロールIDの配列
導入されたバージョン：5.0
getUserIds

Array getUserIds()

すべてのアカウントのユーザIDを取得します。

存在しなかった場合および取得に失敗した場合は、空の配列を返却します。
返却値
Array ユーザIDの配列
導入されたバージョン：5.0
getUserIdsByAccountRole

Array getUserIdsByAccountRole(String roleId)

引数で指定したアカウントロールを持つすべてのアカウントのユーザIDを取得する。

引数で指定したアカウントロールを持つアカウントのユーザIDの一覧を返却します。
指定したアカウントロールの階層のチェックはお行いません。
存在しなかった場合および取得に失敗した場合は、空の配列を返却します。
パラメータ
roleId String ロールID
返却値
Array ユーザIDの配列
導入されたバージョン：5.0
getUserIdsByRole

Array getUserIdsByRole(String roleId ,Date date)

引数で指定したロールを持つすべてのアカウントのユーザIDを取得する。 指定したロールIDからすべての親ロールを取得し、
指定日付で有効なアカウントロールを持つアカウントのユーザIDの一覧を返却します。
存在しなかった場合および取得に失敗した場合は、空の配列を返却します。
パラメータ
roleId | String | ロールID
date | Date | 日付
返却値
Array ユーザIDの配列
導入されたバージョン：5.0
importData

Boolean importData(String category ,String str)

アカウントのインポートを行います。

パラメータ
category | String | カテゴリ
str | String | ストリーム
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
searchAccounts

Array searchAccounts(String userId)

アカウントのユーザIDを検索してマッチしたアカウント取得します。
ユーザIDまたはユーザIDの一部をキーとして検索し、マッチしたアカウントを返します。
ただし、以下の文字列を特殊文字列として扱う。
* 0以上の長さの文字列とマッチ
? 1文字の文字列とマッチ

取得に失敗した場合は、nullを返却します。
パラメータ
userId String 検索キー
返却値
Array アカウントオブジェクト の配列（データがない場合は空の配列を返します）
導入されたバージョン：5.0
set

Object set(Object request [,Array funcs] [,Boolean isTransaction])

推奨されていません。AccountManager.addAccount(Object account) および AccountManager.updateAccount(Object account)に置き換えられました。
アカウントを登録します。

引数に指定したユーザIDが既に存在していた場合、上書きします。
request
リクエストオブジェクト 		id ユーザID(String)[必須]
pwd パスワード(String)
mpwd モバイル用パスワード(String)
name ユーザ名(String)[必須]
madrs メールアドレス(String)
mbladrs モバイル用メールアドレス(String)
explan 説明(String)
vldDate 有効期限(Number(ミリ秒))
roles ロールIDの配列(Array)
license ライセンス(あり true/なし false)
apps アプリケーションロール（Array）
favorite マイメニュー（Object） メニューID (プロパティ) sort_no ソート番号 （Number）
alias 表示名（String）
attr その他、IMISにのみ登録する属性(Object)
((new AccountManager(gId)).get(uId)).getAttr()で取得できる値
kana ユーザ名カナ(String)
eng ユーザ名英字(String)
tel 電話番号(String)
hndy 携帯電話番号(String)
fax FAX番号(String)
extens 内線電話番号(String)
exFax 内線FAX(String)
cntry_cd 国コード(String)
zip 郵便番号(String)
adrs 住所(String)
madrs2 メールアドレス２(String)
url URL(String)
note 備考(String)
sort_key ソート番号(Number)
mainGp 主所属グループCD(String)
groups 所属グループCDの配列(主所属グループは含めない)(Array)
その他 各アプリに依存
パラメータ
request | Object | 登録画面からのリクエストオブジェクト
funcs | Array | 動かしたい関数があれば、パスを配列にいれて渡す（任意）
isTransaction Boolean DBトランザクションフラグ(任意)
trueの場合 このメソッドの中でDBトランザクションを張る。
falseの場合 このメソッドの中でDBトランザクションを張らない。デフォルトはtrue。
返却値
Object 結果オブジェクトまたは、引数が不正の場合、falseを返却します。
結果オブジェクト
(Object) 		getCode() エラーコード
-1 実行エラー
0 成功
その他 各アプリに依存
getMessage() エラーメッセージ
導入されたバージョン：2.0
updateAccount

Boolean updateAccount(Object account)

アカウントを更新します。

パラメータ
account Object アカウントオブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
updateAccountRole

Boolean updateAccountRole(String userId ,Object accountRole)

アカウントロールを更新します。

パラメータ
userId | String | ユーザID
accountRole | Object | アカウントロールオブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0
updateFavoriteMenu

Boolean updateFavoriteMenu(String userId ,Object favoriteMenu)

マイメニューを更新します。

パラメータ
userId | String | ユーザID
favoriteMenu | Object | マイメニューオブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：5.0


 AdminMenuManager オブジェクト

管理メニューマネージャクラス。

グループ管理者が利用する管理メニュー情報の操作を行います。

メニュー・モデルの情報を操作する場合に用いるメニュー・モデルオブジェクトの構成は以下の通りです。
メニュー・モデルオブジェクト
メニュー・モデル
オブジェクト
(Object)
type ノードタイプ (String)
AdminMenuManager.MENU_TYPE_FOLDER
AdminMenuManager.MENU_TYPE_ITEM
description 説明 (String)
clientType クライアントタイプ (String)
contents コンテンツの種類 (String)
AdminMenuManager.CONTENT_TYPE_IN
AdminMenuManager.CONTENT_TYPE_IN
url URL (String)
argument 引数 (Object)
id メニューID (String)
displayName[ロケール] メニュー名 (Object)
imagePath メニューイメージパス (String)
メニューのアイコンイメージです。
sortNumber ソート番号 (Number)

メニュー内包情報を操作する場合に用いるメニュー内包情報オブジェクトの構成は以下の通りです。
メニュー内包情報オブジェクト
メニュー内包情報
オブジェクト
(Object)
parentMenuId 親メニューID (String)
childMenuId 子メニューID (String)

メニューツリー情報を操作する場合に用いるメニューツリーオブジェクトの構成は以下の通りです。
メニューツリーオブジェクト
メニューツリー
オブジェクト
(Object)
menuItem メニュー・モデル (メニュー・モデルオブジェクト)
children メニューの子供の配列 (メニューツリーオブジェクト の配列)

バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | CONTENT_TYPE_IN メニューコンテンツの種類（内部URL）。
static String | CONTENT_TYPE_OUT メニューコンテンツの種類（外部URL）。
static String | MENU_TYPE_FOLDER メニュータイプ（フォルダ）。
static String | MENU_TYPE_ITEM メニュータイプ（アイテム）。
メソッドの概要
static Boolean | addMenuItem(String parentMenuId ,Object object) メニューを新規追加します。
static Boolean | deleteMenuItem(String menuId) 指定したメニューを削除します。
static Boolean | deleteMenuItems() メニューを削除します。
static String | exportData(String category) 管理メニューのエクスポートを行います。
static Array | getChildMenuIds(String menuId) 子メニューIDを取得します。
static Array | getExportCategories() 管理メニューエクスポート用のカテゴリの一覧を取得します。
static Array | getFirstMenuIds(String menuId) 第一階層の子メニューIDをすべて取得します。
static Array | getImportCategories() 管理メニューインポート用のカテゴリの一覧を取得します。
static Array | getMenuIds() すべてのメニューIDを取得します。
static Object | getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
static Array | getMenuItems() すべてのメニューを取得します。
static Array | getMenuTree() メニュー構成を取得します。
static String | getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
static Boolean | importData(String category ,String inputString) 管理メニューのインポートを行います。
static Boolean | moveMenuItem(Object object) メニューを移動します。
static Boolean | updateMenuItem(Object object) メニューを更新します。
定数の詳細
CONTENT_TYPE_IN

static String CONTENT_TYPE_IN

メニューコンテンツの種類（内部URL）。
定数値 ： "in"
CONTENT_TYPE_OUT

static String CONTENT_TYPE_OUT

メニューコンテンツの種類（外部URL）。
定数値 ： "out"
MENU_TYPE_FOLDER

static String MENU_TYPE_FOLDER

メニュータイプ（フォルダ）。
定数値 ： "folder"
MENU_TYPE_ITEM

static String MENU_TYPE_ITEM

メニュータイプ（アイテム）。
定数値 ： "item"
メソッドの詳細
addMenuItem

static Boolean addMenuItem(String parentMenuId ,Object object)

メニューを新規追加します。
パラメータ
parentMenuId | String | 親メニューID
object | Object | メニュー・モデルオブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteMenuItem

static Boolean deleteMenuItem(String menuId)

指定したメニューを削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuItems

static Boolean deleteMenuItems()

メニューを削除します。
返却値
Boolean true : 成功 / false : 失敗
exportData

static String exportData(String category)

管理メニューのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getChildMenuIds

static Array getChildMenuIds(String menuId)

子メニューIDを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array 子メニューIDの配列
getExportCategories

static Array getExportCategories()

管理メニューエクスポート用のカテゴリの一覧を取得します。

返却値
Array 管理メニューエクスポート用のカテゴリの一覧
getFirstMenuIds

static Array getFirstMenuIds(String menuId)

第一階層の子メニューIDをすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array メニューIDの配列
getImportCategories

static Array getImportCategories()

管理メニューインポート用のカテゴリの一覧を取得します。

返却値
Array 管理メニューインポート用カテゴリの一覧
getMenuIds

static Array getMenuIds()

すべてのメニューIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニューIDの配列
getMenuItem

static Object getMenuItem(String menuId)

指定されたメニューIDに対応するメニューを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Object メニュー・モデルオブジェクト
getMenuItems

static Array getMenuItems()

すべてのメニューを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニュー・モデルオブジェクト の配列
getMenuTree

static Array getMenuTree()

メニュー構成を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニュー構成オブジェクト の配列
getParentMenuId

static String getParentMenuId(String menuId)

指定されたメニューの親メニューを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
String 親メニュー
importData

static Boolean importData(String category ,String inputString)

管理メニューのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
moveMenuItem

static Boolean moveMenuItem(Object object)

メニューを移動します。

パラメータ
object Object メニュー内包情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
updateMenuItem

static Boolean updateMenuItem(Object object)

メニューを更新します。
パラメータ
object Object メニュー・モデルオブジェクト
返却値
Boolean true : 成功 / false : 失敗


 ApplicationInfo オブジェクト

アプリケーション情報オブジェクト。

アプリケーション情報を保持するオブジェクトです。
アプリケーション情報は値を参照することのみ許可されています
アプリケーション情報オブジェクトの構成は以下の通りです。
アプリケーション情報オブジェクト
アプリケーション情報
オブジェクト
(Object)
name アプリケーション名 (String)
id アプリケーションID (String)
type アプリケーションタイプ (String)
version バージョン (String)
packageVersion パッケージバーション (String)
serialNo シリアル番号 (Number)
maxProcess 最大サーバー数 (Number)
maxAccount 最大ユーザ数 (Number)
trial 試用版かどうか (Boolean)
free フリーライセンスかどうか (Boolean)
expired 試用期限がきているかどうか (Boolean)
limited 使用期限付きライセンスかどうか (Boolean)
openSource ソースコード公開ライセンスかどうか (Boolean)
runtime ランタイムライセンスかどうか (Boolean)
installDate アプリケーションがインストールされた日付 [ms](Number)
expiredDate アプリケーションの試用期限の日付 [ms](Number)
limitedDate 期限付きライセンスの使用期限の日付 (Number)

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
Array | getProperties(String key) インストール情報を取得します。
String | getProperty(String key) インストール情報を取得します。
メソッドの詳細
getProperties

Array getProperties(String key)

インストール情報を取得します。
キーが存在しない場合はnullを返します。
パラメータ
key String 取得情報のキー
返却値
Array 文字列の配列(String)
getProperty

String getProperty(String key)

インストール情報を取得します。
キーが存在しない場合はnullを返します。
パラメータ
key String 取得情報のキー
返却値
String 文字列


 Batch オブジェクト

推奨されていません。BatchManagerに置き替えられました。
バッチオブジェクト。

バッチ情報の参照および更新を行うオブジェクトです。

バッチ情報オブジェクト
バッチ情報の参照、更新を行う場合に使用するオブジェクトです。
バッチ情報
オブジェクト
(Object)
key 保存名称（キーワード）(Object)
name バッチ名称（画面への表示名称）(Object)
year 年(毎設定の場合には非数を指定) (double)
month 月(毎設定の場合には非数を指定) (double)
date 日(毎設定の場合には非数を指定) (double)
day 曜日(毎設定の場合には非数を指定) (double)
hour 時間(毎設定の場合には非数を指定) (double)
minute 分(毎設定の場合には非数を指定) (double)
second 秒(毎設定の場合には非数を指定) (double)
path 起動プログラム・パス名 (path) (Object)
valid 有効無効フラグ (boolean)
lang バッチプログラムの記述言語 (Object)

バージョン：1.0
導入されたバージョン：2.0
コンストラクタの概要
Batch(String groupId)
推奨されていません。BatchManagerに置き換えられました。
BatchObject(String group)
コンストラクタ。
メソッドの概要
Array elements()
推奨されていません。BatchManager.getBatches() に置き換えられました。
static Array entries()
推奨されていません。LoginGroupManager.getLoginGroupIds()に置き換えられました。
Array extinction()
推奨されていません。BatchManager.deleteBatches()に置き換えられました。
Object get(String key)
推奨されていません。BatchManager.getBatch(String id)に置き換えられました。
Array keys()
推奨されていません。BatchManager.getBatchIds()に置き換えられました。
Object remove(String name)
推奨されていません。BatchManager.deleteBatch(String batchId)に置き換えられました。
Object set(String key ,String name ,Number year ,Number month ,Number date ,Number day ,Number hour ,Number minute ,Number second ,String path ,Boolean valid ,String lang)
推奨されていません。BatchManager.addBatch(Object batch)および BatchManager.updateBatch(Object batch)に置き換えられました。 に置き換えられました。
コンストラクタの詳細
Batch

Batch(String groupId)
推奨されていません。BatchManagerに置き換えられました。
コンストラクタ。

パラメータ
groupId String ログイングループID
BatchObject

BatchObject(String group)
コンストラクタ。
パラメータ
group String 登録時のグループ名称
メソッドの詳細
elements

Array elements()

推奨されていません。BatchManager.getBatches() に置き換えられました。
バッチ情報の一覧を取得します。

返却値
Array バッチ情報オブジェクトの配列
entries

static Array entries()

推奨されていません。LoginGroupManager.getLoginGroupIds()に置き換えられました。
ログイングループの一覧を取得します。

取得に失敗した場合は、空の配列を返却します。
返却値
Array ログイングループIDの配列
extinction

Array extinction()

推奨されていません。BatchManager.deleteBatches()に置き換えられました。
すべてのバッチ情報を削除します。
返却値
Array 削除したバッチ情報オブジェクトの配列
get

Object get(String key)

推奨されていません。BatchManager.getBatch(String id)に置き換えられました。
バッチ設定データを取得します。

バッチIDに該当するバッチ設定データを検索し、返却します。
バッチIDに該当するデータが存在しない場合には nullを返却します。
パラメータ
key String バッチID
返却値
Object バッチ情報オブジェクト
keys

Array keys()

推奨されていません。BatchManager.getBatchIds()に置き換えられました。
バッチIDの一覧を取得します。

取得に失敗した場合は、空の配列を返却します。
返却値
Array バッチIDの配列
remove

Object remove(String name)

推奨されていません。BatchManager.deleteBatch(String batchId)に置き換えられました。
バッチ情報を削除します。

削除に失敗した場合は、nullを返却します。
パラメータ
name String バッチID
返却値
Object 削除したバッチ情報オブジェクト
set

Object set(String key ,String name ,Number year ,Number month ,Number date ,Number day ,Number hour ,Number minute ,Number second ,String path ,Boolean valid ,String lang)

推奨されていません。BatchManager.addBatch(Object batch)および BatchManager.updateBatch(Object batch)に置き換えられました。 に置き換えられました。
バッチ設定データを保存します。

指定のバッチ設定データを指定のキーで保存します。
指定キーが既に存在している場合には、過去データを破棄し 指定データで置き換えます。
時間設定が不要な項目に対しては、非数を指定。
日設定および曜日設定は、同時には指定できません。
引数 lang には以下のどちらかのキーワードを指定。
JavaScript: バッチプログラムがファンクションコンテナ
JAVA : バッチプログラムがクラス
パラメータ
key | String | バッチプログラムの記述言語保存名称（バッチID）
name | String | バッチ名称（画面への表示名称）
year | Number | 年(毎設定の場合には非数を指定)
month | Number | 月(毎設定の場合には非数を指定)
date | Number | 日(毎設定の場合には非数を指定)
day | Number | 曜日(毎設定の場合には非数を指定)
hour | Number | 時間(毎設定の場合には非数を指定)
minute | Number | 分(毎設定の場合には非数を指定)
second | Number | 秒(毎設定の場合には非数を指定)
path | String | 起動プログラム・パス名
valid | Boolean | 有効無効フラグ
lang | String | バッチプログラムの記述言語
返却値
Object 保存したバッチ情報オブジェクト


 BatchManager オブジェクト

バッチマネージャオブジェクト。

バッチ情報を参照、更新することができます。
バッチの情報を操作する場合に用いるバッチオブジェクトの構成は以下の通りです。
バッチオブジェクト
バッチ
オブジェクト
(Object)
id [必須] バッチID (String)
name [必須] バッチ名 (String)
description 説明 (String)
programLanguage [必須] 実行プログラム言語 (String)
'JavaScript' または 'JAVA' です。
programPath [必須] 実行プログラムパス (String)
実行プログラム言語がJavaScriptである場合は、pages以下のパスです。
実行プログラム言語がjavaである場合は、クラスのフルパッケージ名です。
runYear 実行年 (Number)
設定できる値は、-1,０〜です。
-1を設定した場合は、毎年実行されます。
runMonth 実行月 (Number)
設定できる値は、-1,１〜１２です。
-1を設定した場合は、毎月実行されます。
runDay 実行日 (Number)
設定できる値は、-1,１〜３１です。
-1を設定した場合は、毎日実行されます。
runDayWeek 実行曜日 (Number)
設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
実行日(runDay)が設定されいる場合は、この設定は無視されます。
runHour 実行時 (Number)
設定できる値は、-1,０〜２３です。
-1を設定した場合は、毎時実行されます。
runMinute 実行分 (Number)
設定できる値は、-1,０〜５９です。
-1を設定した場合は、毎分実行されます。
runSecond 実行秒 (Number)
設定できる値は、-1,０〜５９です。
-1を設定した場合は、毎秒実行されます。
validate バッチの有効・無効 (Boolean)
バッチの有効・無効です。無効の場合は、実行されません。
バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | LANG_JAVA プログラム言語(JAVA)。
static String | LANG_JAVA_SCRIPT プログラム言語(JavaScript)。
コンストラクタの概要
BatchManager(String groupId)
コンストラクタ。
メソッドの概要
Boolean | addBatch(Object batch) バッチ情報を新規に追加します。
Boolean | deleteBatch(String batchId) バッチ情報を削除します。
Boolean | deleteBatches() すべてのバッチ情報を削除します。
String | exportData(String category) バッチのエクスポートを行います。
Object | getBatch(String batchId) バッチ情報を取得します。
Array | getBatchIds() バッチIDの一覧を取得します。
Array | getBatches() すべてのバッチ情報を取得します。
Array | getBatchesByIds(Array batchIds) 引数のバッチIDのバッチ情報をすべて取得します。
Array | getExportCategories() バッチエクスポート用のカテゴリの一覧を取得します。
Array | getImportCategories() バッチインポート用のカテゴリの一覧を取得します。
Boolean | importData(String category ,String inputString) バッチのインポートを行います。
Boolean | updateBatch(Object batch) バッチ情報を更新します。
定数の詳細
LANG_JAVA

static String LANG_JAVA

プログラム言語(JAVA)。
バッチを実行するプログラム言語の種類。
定数値 ： "JAVA"
LANG_JAVA_SCRIPT

static String LANG_JAVA_SCRIPT

プログラム言語(JavaScript)。
バッチを実行するプログラム言語の種類。
定数値 ： "JavaScript"
コンストラクタの詳細
BatchManager

BatchManager(String groupId)
コンストラクタ。

パラメータ
groupId String ログイングループID
メソッドの詳細
addBatch

Boolean addBatch(Object batch)

バッチ情報を新規に追加します。

パラメータ
batch Object バッチオブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteBatch

Boolean deleteBatch(String batchId)

バッチ情報を削除します。

パラメータ
batchId String バッチID
返却値
Boolean true : 成功 / false : 失敗
deleteBatches

Boolean deleteBatches()

すべてのバッチ情報を削除します。

返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData(String category)

バッチのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getBatch

Object getBatch(String batchId)

バッチ情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
batchId String バッチID
返却値
Object バッチオブジェクト
getBatchIds

Array getBatchIds()

バッチIDの一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array バッチIDの配列
getBatches

Array getBatches()

すべてのバッチ情報を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array バッチオブジェクト の配列
getBatchesByIds

Array getBatchesByIds(Array batchIds)

引数のバッチIDのバッチ情報をすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
batchIds Array バッチIDの配列
返却値
Array バッチオブジェクト の配列（データがない場合は空の配列を返します）
getExportCategories

Array getExportCategories()

バッチエクスポート用のカテゴリの一覧を取得します。

返却値
Array バッチエクスポート用カテゴリの一覧
バッチエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getImportCategories

Array getImportCategories()

バッチインポート用のカテゴリの一覧を取得します。

返却値
Array バッチインポート用カテゴリの一覧
バッチインポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
importData

Boolean importData(String category ,String inputString)

バッチのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
updateBatch

Boolean updateBatch(Object batch)

バッチ情報を更新します。

パラメータ
batch Object バッチオブジェクト
返却値
Boolean true : 成功 / false : 失敗


 BatchServer オブジェクト

バッチサーバーオブジェクト。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
String | getRefresh() Batch Server 現在の設定初期化時間取得メソッド。
Boolean | isConnected() Batch Server 動作チェックメソッド。
Boolean | isRun() Batch Server 動作状態取得メソッド。
Boolean | restart() Batch Server 再起動メソッド。
Boolean | setRefresh(int hour ,int minute ,int second) Batch Server 初期化時間設定メソッド。
Boolean | start() Batch Server 起動メソッド。
Boolean | stop() Batch Server 停止メソッド。
メソッドの詳細
getRefresh

String getRefresh()

Batch Server 現在の設定初期化時間取得メソッド。

Batch Server の初期化時間を返却します。
Batch Server との通信に失敗した場合は、null を返却。
返却値
String 設定データ
isConnected

Boolean isConnected()

Batch Server 動作チェックメソッド。
Batch Server への接続状況を確認します。
真値の場合、Batch Server を利用可能。偽値の場合、Batch Server を利用不可能。
返却値
Boolean 真値：サーバー動作中/偽値：サーバーアクセスエラー
isRun

Boolean isRun()

Batch Server 動作状態取得メソッド。
返却値
Boolean 真値：サーバー動作中/偽値：サーバー休眠中またはサーバーが動作していない
restart

Boolean restart()

Batch Server 再起動メソッド。
Batch Server に対して再起動要求します。
返却値
Boolean 真値：サーバー再起動/偽値：サーバー再起動失敗
setRefresh

Boolean setRefresh(int hour ,int minute ,int second)

Batch Server 初期化時間設定メソッド。

Batch Server に対して初期化時間の設定をします。
パラメータ
hour | int | 時間
minute | int | 分
second | int | 秒
返却値
Boolean 真値：設定成功/偽値：設定失敗
start

Boolean start()

Batch Server 起動メソッド。
Batch Server に対して起動要求します。
返却値
Boolean 真値：サーバー起動/偽値：サーバー起動失敗
stop

Boolean stop()

Batch Server 停止メソッド。
Batch Server に対して停止要求します。
返却値
Boolean 真値：サーバー停止/偽値：サーバー停止失敗


 CalendarManager オブジェクト

カレンダーマネージャオブジェクト。

カレンダーの参照、更新を行うマネージャオブジェクトです。 カレンダーデータオブジェクトは、1つのカレンダーオブジェクトに属します。
カレンダーデータを操作する場合に用いるカレンダーデータオブジェクトの構成は以下の通りです。

カレンダーデータオブジェクト
カレンダーデータ
オブジェクト
(Object)
id [必須] データID (String)
カレンダーデータを一意に識別するIDです。
type [必須] データタイプ (String)
設定できる値は、 'config'(名称)、'holiday'(休日)、 'weekday'(非休日)、'nationalHoliday'(公休日)のいずれかです。
上記以外の値が設定された場合は、 'config'(名称)に設定されます。
name [必須] データ名 (String)
displayName[ロケール] データ表示名 (String)
ロケール別の表示名です。
description 説明 (String)
year 年 (Number)
この設定を無効にするには-1を設定します。
month 月 (Number)
設定できる値は、1から12までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
day 日 (Number)
設定できる値は、1から31までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。
dayWeek 曜日 (Number)
設定できる値は、0(日曜日)から6(土曜日)までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

設定した曜日(日)を特定したい場合は、第ｎ〜曜日の設定(times)
または第ｎ週の設定(week)と共に設定してください。
第ｎ〜曜日の設定、第ｎ週の設定、共に設定を行わなかった場合は、すべての指定曜日の設定となります。
times 第ｎ〜曜日 (Number)
設定できる値は、1から5までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定(dayWeek) と共に設定すると、日を特定できます。
week 第ｎ週 (Number)
設定できる値は、1から6までです。
上記の値以外を設定した場合は、-1に設定されます。
この設定を無効にするには-1を設定します。

曜日の設定(dayWeek) と共に設定すると、日が特定できます。
color 背景色 (String)
plugin プラグインID (String)
この設定を無効にするにはnullまたは空文字列を設定します。
validStartYear 有効開始年 (Number)
この設定を無効にするには-1を設定します。
validEndYear 有効終了年 (Number)
この設定を無効にするには-1を設定します。

カレンダー日付情報を操作する場合に用いるカレンダー日付情報オブジェクトの構成は以下の通りです。
カレンダー日付情報オブジェクト
カレンダー日付情報
オブジェクト
(Object)
color 背景色 (String)
date 対象の日付 (Date)
holiday 名称設定以外でマッチしたカレンダーデータの数 (Number)
matchcount 休日判定 (Boolean)
nationalholiday 祝日判定 (Boolean)
weekday 平日判定 (Boolean)
data カレンダーデータオブジェクトの配列 (Array)
バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | TYPE_CONFIG 名称（データタイプの定数）。
static String | TYPE_HOLIDAY 休日（データタイプの定数）。
static String | TYPE_NATIONAL_HOLDAY 祝祭日（データタイプの定数）。
static String | TYPE_WEEKDAY 非休日（データタイプの定数）。
コンストラクタの概要
CalendarManager(String groupId)
コンストラクタ。
メソッドの概要
Boolean | addCalendarInfo(String calendarId ,Object object) カレンダーデータを新規に追加します。
Boolean | deleteCalendar(String calendarId) カレンダーを削除します。
Boolean | deleteCalendarInfo(String calendarId ,String dataId) カレンダーデータを削除します。
Boolean | deleteCalendarInfos(String calendarId) すべてのカレンダーデータを削除します。
Boolean | deleteCalendars() すべてのカレンダーを削除します。
String | exportData(String category) カレンダーのエクスポートを行います。
Array | getCalendarIds() すべてのカレンダーIDを取得します。
Object | getCalendarInfo(String calendarId ,String dataId) カレンダーデータを取得します。
Array | getCalendarInfoIds(String calendarId) すべてのカレンダーデータIDを取得します。
Array | getCalendarInfos(String calendarId) すべてのカレンダーデータを取得します。
Array | getCalendarInfosByIds(String calendarId ,Object calendarInfoIds) 指定されたカレンダーデータIDに一致するカレンダーデータを取得します。
Object | getDayInfo(String calendarId ,Date date) 日付に対するカレンダーデータ情報を取得します。
String | getDefaultCalendarId() デフォルトカレンダーIDを取得します。
Array | getExportCategories() カレンダーエクスポート用のカテゴリの一覧を取得します。
Array | getImportCategories() カレンダーインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
Array | getMonthInfos(String calendarId ,int year ,int month) 月情報を取得します。
Array | getPluginIds() カレンダーデータプラグインIDの一覧を取得します。
Boolean | importData(String category ,String inputString) カレンダーのインポートを行います。
Boolean | isHoliday(String calendarId ,Date date) 休日かどうか判定します。
Boolean | isNationalHoliday(String calendarId ,Date date) 祝日かどうか判定します。
boolean | isUpdate(String calendarId ,Date date) カレンダーデータが指定された日付よりも後に更新されたかチェックします。
Boolean | isWeekday(String calendarId ,Date date) 平日かどうか判定します。
Boolean | updateCalendarInfo(String calendarId ,Object object) カレンダーデータを更新します。
Boolean | validatePlugin(String calendarId ,Object calendarInfo ,Date date) カレンダーデータをプラグインで検証します。
定数の詳細
TYPE_CONFIG

static String TYPE_CONFIG

名称（データタイプの定数）。
定数値 ： "config"
TYPE_HOLIDAY

static String TYPE_HOLIDAY

休日（データタイプの定数）。
定数値 ： "holiday"
TYPE_NATIONAL_HOLDAY

static String TYPE_NATIONAL_HOLDAY

祝祭日（データタイプの定数）。
定数値 ： "nationalHoliday"
TYPE_WEEKDAY

static String TYPE_WEEKDAY

非休日（データタイプの定数）。
定数値 ： "weekday"
コンストラクタの詳細
CalendarManager

CalendarManager(String groupId)
コンストラクタ。
パラメータ
groupId String ログイングループID
メソッドの詳細
addCalendarInfo

Boolean addCalendarInfo(String calendarId ,Object object)

カレンダーデータを新規に追加します。
パラメータ
calendarId | String | カレンダーID
object | Object | カレンダーデータオブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteCalendar

Boolean deleteCalendar(String calendarId)

カレンダーを削除します。
パラメータ
calendarId String カレンダーID
返却値
Boolean true : 成功 / false : 失敗
deleteCalendarInfo

Boolean deleteCalendarInfo(String calendarId ,String dataId)

カレンダーデータを削除します。
パラメータ
calendarId | String | カレンダーID
dataId | String | カレンダーデータID
返却値
Boolean true : 成功 / false : 失敗
deleteCalendarInfos

Boolean deleteCalendarInfos(String calendarId)

すべてのカレンダーデータを削除します。
パラメータ
calendarId String カレンダーID
返却値
Boolean true : 成功 / false : 失敗
deleteCalendars

Boolean deleteCalendars()

すべてのカレンダーを削除します。
返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData(String category)

カレンダーのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getCalendarIds

Array getCalendarIds()

すべてのカレンダーIDを取得します。
取得に失敗した場合は、nullを返却します。
返却値
Array カレンダーIDの配列
getCalendarInfo

Object getCalendarInfo(String calendarId ,String dataId)

カレンダーデータを取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
calendarId | String | カレンダーID
dataId | String | カレンダーデータID
返却値
Object カレンダーデータオブジェクト
getCalendarInfoIds

Array getCalendarInfoIds(String calendarId)

すべてのカレンダーデータIDを取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
calendarId String カレンダーID
返却値
Array カレンダーデータIDの配列
getCalendarInfos

Array getCalendarInfos(String calendarId)

すべてのカレンダーデータを取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
calendarId String カレンダーID
返却値
Array カレンダーデータオブジェクトの配列
getCalendarInfosByIds

Array getCalendarInfosByIds(String calendarId ,Object calendarInfoIds)

指定されたカレンダーデータIDに一致するカレンダーデータを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
calendarId | String | カレンダーID
calendarInfoIds | Object | カレンダーデータIDの配列
返却値
Array カレンダーデータオブジェクトの配列
getDayInfo

Object getDayInfo(String calendarId ,Date date)

日付に対するカレンダーデータ情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
calendarId | String | カレンダーID
date | Date | 日付
返却値
Object 日付に対するカレンダーデータ情報
getDefaultCalendarId

String getDefaultCalendarId()

デフォルトカレンダーIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
String デフォルトカレンダーID
getExportCategories

Array getExportCategories()

カレンダーエクスポート用のカテゴリの一覧を取得します。

返却値
Array カレンダーエクスポート用カテゴリの一覧
カレンダーエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getImportCategories

Array getImportCategories()

カレンダーインポート用のカテゴリの一覧を取得します。
返却値
Array カレンダーインポート用カテゴリの一覧
カレンダーインポート用のカテゴリの取得に失敗した場合は、空の配列を返却します。
getLoginGroupId

String getLoginGroupId()

ログイングループIDを取得します。
返却値
String ログイングループID
getMonthInfos

Array getMonthInfos(String calendarId ,int year ,int month)

月情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
calendarId | String | カレンダーId
year | int | year 年
month | int | month 月
返却値
Array カレンダー日付情報クラスの配列
配列の添え字が日に対応します。
添え字[20]は20日の情報になります。
getPluginIds

Array getPluginIds()

カレンダーデータプラグインIDの一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array カレンダーデータプラグインIDの配列
importData

Boolean importData(String category ,String inputString)

カレンダーのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
isHoliday

Boolean isHoliday(String calendarId ,Date date)

休日かどうか判定します。

パラメータ
calendarId | String | カレンダーID
date | Date | 日付
返却値
Boolean 判定結果　true : 休日 / false : 平日
isNationalHoliday

Boolean isNationalHoliday(String calendarId ,Date date)

祝日かどうか判定します。

パラメータ
calendarId | String | カレンダーID
date | Date | 日付
返却値
Boolean 判定結果　true : 祝日 / false : 祝日以外の日
isUpdate

boolean isUpdate(String calendarId ,Date date)

カレンダーデータが指定された日付よりも後に更新されたかチェックします。
パラメータ
calendarId | String | カレンダーID
date | Date | チェック日付
返却値
boolean 判定結果　true:存在 / false:存在しない
isWeekday

Boolean isWeekday(String calendarId ,Date date)

平日かどうか判定します。

パラメータ
calendarId | String | カレンダーID
date | Date | 日付
返却値
Boolean 判定結果 true:平日 / false:休日
updateCalendarInfo

Boolean updateCalendarInfo(String calendarId ,Object object)

カレンダーデータを更新します。
パラメータ
calendarId | String | カレンダーID
object | Object | カレンダーデータオブジェクト
返却値
Boolean true : 成功 / false : 失敗
validatePlugin

Boolean validatePlugin(String calendarId ,Object calendarInfo ,Date date)

カレンダーデータをプラグインで検証します。

カレンダーデータにプラグインの設定がない場合、検証結果は true となります。
パラメータ
calendarId | String | カレンダーID
calendarInfo | Object | カレンダーデータオブジェクト
date | Date | 検証する日付
返却値
Boolean カレンダーデータのプラグインでの検証結果


 Category オブジェクト

推奨されていません。CategoryManagerに置き換えられました。
Categoryオブジェクト。

カテゴリに関連する情報の更新を行う互換用マネージャオブジェクトです。

分類情報を操作するために用いる分類情報オブジェクトの構成は以下の通りです。
分類情報オブジェクト
分類区分情報
オブジェクト
(Object)
category_cls_cd 分類区分コード (String)
category_cd 分類コード (String)
category_name 分類名 (String)
notes 備考 (String)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(失敗) (Number)
message エラー発生時のメッセージ (String)

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
Category(String loginGroup)
コンストラクタ
メソッドの概要
object | addCategoryDetail(Object data) 推奨されていません。CategoryManager.addCategoryDetailに置き換えられました。
Object | deleteCategoryDetail(String category_cls_cd ,String category_cd) 推奨されていません。CategoryManager.deleteCategoryDetailに置き換えられました。
Object | updateCategoryDetail(Object data) 推奨されていません。CategoryManager.updateCategoryDetailに置き換えられました。
コンストラクタの詳細
Category

Category(String loginGroup)
コンストラクタ
パラメータ
loginGroup String ログイングループ
メソッドの詳細
addCategoryDetail

object addCategoryDetail(Object data)

推奨されていません。CategoryManager.addCategoryDetailに置き換えられました。
カテゴリ詳細を登録します。

このメソッドは内部でDBトランザクションを発行します。
パラメータ
data Object 分類情報オブジェクト
返却値
object 処理結果オブジェクト
deleteCategoryDetail

Object deleteCategoryDetail(String category_cls_cd ,String category_cd)

推奨されていません。CategoryManager.deleteCategoryDetailに置き換えられました。
登録済のカテゴリ詳細を削除します。

このメソッドは内部でDBトランザクションを発行しています。
パラメータ
category_cls_cd | String | 分類区分コード
category_cd | String | 分類コード
返却値
Object 処理結果オブジェクト
updateCategoryDetail

Object updateCategoryDetail(Object data)

推奨されていません。CategoryManager.updateCategoryDetailに置き換えられました。
登録済のカテゴリ詳細を更新します。

このメソッドは内部でDBトランザクションを発行しています。
パラメータ
data Object 分類情報オブジェクト
返却値
Object 処理結果オブジェクト


 CategoryManager オブジェクト

CategoryManagerオブジェクト。
カテゴリに関連する情報の更新を行うマネージャオブジェクトです。

カテゴリ詳細に関連する情報を操作する場合に用いるカテゴリ詳細情報オブジェクトの構成は以下の通りです。
カテゴリ詳細情報オブジェクト
カテゴリ詳細情報
オブジェクト
(Object)
categoryClassCode 分類区分コード (String)
categoryCode 分類コード (String)
notes 備考 (String)
locales 国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name 分類名 (String)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(失敗) (Number)
message エラー発生時のメッセージ (String)

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CategoryManager(String user ,String group)
コンストラクタ

メソッドの概要
Object | addCategoryDetail(Object categoryDetail) カテゴリ詳細を登録します。
Object | deleteCategoryDetail(Object categoryDetail) 登録済のカテゴリ詳細を削除します。
Object | updateCategoryDetail(Object categoryDetail) 登録済のカテゴリ詳細を更新します。
コンストラクタの詳細
CategoryManager

CategoryManager(String user ,String group)
コンストラクタ

パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addCategoryDetail

Object addCategoryDetail(Object categoryDetail)

カテゴリ詳細を登録します。
パラメータ
categoryDetail Object カテゴリ詳細情報
返却値
Object 処理結果オブジェクト
deleteCategoryDetail

Object deleteCategoryDetail(Object categoryDetail)

登録済のカテゴリ詳細を削除します。

指定された分類区分詳細の情報が存在しない場合は処理失敗となります。
パラメータ
categoryDetail Object カテゴリ詳細情報
返却値
Object 処理結果オブジェクト
updateCategoryDetail

Object updateCategoryDetail(Object categoryDetail)

登録済のカテゴリ詳細を更新します。
パラメータ
categoryDetail Object カテゴリ詳細情報
返却値
Object 処理結果オブジェクト


 Client オブジェクト

セッション情報を取得するオブジェクト。

バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static Object | get(String key) クライアント固有保存情報を取得します。
static String | identifier() セッションＩＤを取得します。
static Array | keys() 保存キー一覧を取得します。
static void | remove(String key) クライアント固有情報を削除します。
static void | set(String key ,Object value) クライアント固有情報を保存します。
static void | sleep(Number millis) 推奨されていません。このメソッドは推奨されません。代替えメソッドも存在しません。
メソッドの詳細
get

static Object get(String key)

クライアント固有保存情報を取得します。

パラメータ
key String 保存時の保存キーコード
返却値
Object 保存データ
identifier

static String identifier()

セッションＩＤを取得します。

返却値
String セッションＩＤ
keys

static Array keys()

保存キー一覧を取得します。

返却値
Array 保存キー一覧
remove

static void remove(String key)

クライアント固有情報を削除します。

パラメータ
key String 保存キーコード
返却値
void
set

static void set(String key ,Object value)

クライアント固有情報を保存します。

セッションにクライアント固有情報を保存します。
保存可能なデータは、プログラム中で自作したオブジェクト（Object,String,Arrayなどのインスタンス）です。

なお、Requestオブジェクト や Module.XXXXオブジェクト 等の、 intra-mart標準の組み込みオブジェクトは保存できません。
パラメータ
key | String | 保存キーコード
value | Object | 保存するデータ
返却値
void
sleep

static void sleep(Number millis)

推奨されていません。このメソッドは推奨されません。代替えメソッドも存在しません。
実行処理を中断します。

指定時間だけ、プログラムの実行を中断します。
時間指定の単位はミリ秒
引数には自然数を指定します。
仕様外の引数指定時の動作は保証外です。
パラメータ
millis Number 中断する時間（ミリ秒）
返却値
void


 CompanyManager オブジェクト

CompanyManagerオブジェクト。

会社や組織に関連する情報の参照、更新を行うマネージャオブジェクトです。

会社に関連する情報を操作する場合に用いる 会社情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
会社情報オブジェクト
会社情報
オブジェクト
(Object)
companyCode 会社コード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
telephoneNumber 電話番号 (String)
faxNumber FAX番号 (String)
extensionNumber 内線番号 (String)
extensionFaxNumber 内線FAX番号 (String)
countryCode 国コード (String)
zipCode 郵便番号 (String)
emailAddress1 メールアドレス１ (String)
emailAddress2 メールアドレス２ (String)
url URL (String)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name 会社名 (String)
nameSyllabary 会社名カナ (String)
nameEnglish 会社名英字 (String)
address1 住所１ (String)
address2 住所２ (String)

組織に関連する情報を操作する場合に用いる 組織情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
組織情報オブジェクト
組織情報
オブジェクト
(Object)
companyCode 会社コード (String)
departmentCode 組織コード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
telephoneNumber 電話番号 (String)
faxNumber FAX番号 (String)
extensionNumber 内線番号 (String)
extensionFaxNumber 内線FAX番号 (String)
countryCode 国コード (String)
zipCode 郵便番号 (String)
emailAddress1 メールアドレス１ (String)
emailAddress2 メールアドレス２ (String)
url URL (String)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name 組織名 (String)
nameSyllabary 組織名カナ (String)
nameEnglish 組織名英字 (String)
address1 住所１ (String)
address2 住所２ (String)

役職に関連する情報を操作する場合に用いる 役職情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
役職情報オブジェクト
役職情報
オブジェクト
(Object)
companyCode 会社コード (String)
postCode 役職コード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name 役職名 (String)

役職に関連する情報を操作する場合に用いる 非構造化役職情報オブジェクトの構成は以下の通りです。
非構造化役職情報オブジェクトは１つのオブジェクトの中で、役職についての期間および言語に関する情報を扱います。
非構造化役職オブジェクト
非構造化
役職情報
オブジェクト
(Object)
companyCode 会社コード (String)
postCode 役職コード (String)
postName 役職名 (String)
notes 備考 (String)
sortKey ソートキー (String)
startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
locale 役職名に対する言語(ja, en等のロケールID) (String)

会社構成バージョンに関連する情報を操作する場合に用いる 会社構成バージョン情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
会社構成バージョン情報オブジェクト
会社構成バージョン情報
オブジェクト
(Object)
companyCode 会社コード (String)
versionCode バージョンコード (String)
startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
notes 備考 (String)

組織への所属に関連する情報を操作する場合に用いる 組織への所属情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
組織への所属情報オブジェクト
組織への所属情報
オブジェクト
(Object)
userCode ユーザコード (String)
companyCode 会社コード (String)
departmentCode 組織コード (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
postCode 役職コード (String)

会社組織分類区分に関連する情報を操作する場合に用いる 会社組織分類区分情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
会社組織分類区分情報オブジェクト
会社組織分類区分情報
オブジェクト
(Object)
companyCode 会社コード (String)
departmentCode 組織コード (String)
categoryClassCode 分類区分コード (String)
categoryCode 分類コード (String)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)

主所属情報に関連する情報を操作する場合に用いる 主所属情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
主所属情報オブジェクト
主所属情報
オブジェクト
(Object)
userCode ユーザコード (String)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
companyCode 会社コード (String)
departmentCode 組織コード (String)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(処理失敗) or -2(引数オブジェクト不正) (Number)
message エラー発生時のメッセージ (String)
data 任意のオブジェクト　(検索処理の成功時のみ)

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CompanyManager(String user ,String group)
コンストラクタ
メソッドの概要
Object | addCompany(Object company) 会社を登録します。
Object | addDepartment(Object department) 組織を登録します。
Object | addPost(Object post) 役職を登録します。
Object | addVersion(Object version) 会社構成バージョンを登録します。
Object | copyVersion(String company ,String srcVersion ,String destVersion ,Date startDate ,Date endDate) 登録済の会社構成バージョンの内容をコピーします。
Object | deleteCompany(Object company) 登録済の会社を削除します。
Object | deleteDepartment(Object department) 登録済の組織情報を削除します。
Object | deleteMember(Object departmentAttach) 組織から人員をはずします。
Object | deletePost(Object post) 登録済の役職情報を削除します。
Object | deleteVersion(Object version) 登録済の会社構成バージョンを削除します。
Object | getDepartmentStructs(String company ,String department ,Date date ,String locale) 組織の階層構造を取得します。
Object | getPostsInCompany(String company [,Date date] [,String locale]) 会社に登録されている役職の一覧を取得します。
Object | getPostsOfUser(String company ,String user [,Date date] [,String locale]) ユーザに対して設定されている役職の一覧を取得します。
Object | joinDepartment(String company ,String parentDepartment ,String department ,String version) 組織構成に組織を登録します。
Object | leaveDepartment(String company ,String department ,String version) 組織構成から組織情報を離脱させます。
Object | moveDepartment(String company ,String parentDepartment ,String department ,String version) 組織構成に登録済の組織情報を移動します。
Object | removeCategoryDetail(Object category) 組織に対して指定された分類区分情報を削除します。
Object | removeMain(Object main) 指定されたユーザの主所属を削除します。
Object | setCategoryDetail(Object category) 組織に対して指定された分類区分情報を設定します。
Object | setMain(Object main) ユーザが主所属する組織を設定します。
Object | setMember(Object departmentAttach) 組織に人員を割り当てます。
Object | updateDepartment(Object department) 登録済の組織情報を更新します。
Object | updatePost(Object post) 登録済の役職情報を更新します。
Object | updateVersion(Object version) 登録済の会社構成バージョンを更新します。
コンストラクタの詳細
CompanyManager

CompanyManager(String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addCompany

Object addCompany(Object company)

会社を登録します。

このメソッドを実行すると下記のような動作が行われます。
  1. 会社を新規登録する。
  2. 会社に対応する組織を新規登録する。
パラメータ
company Object 会社情報オブジェクト
返却値
Object 処理結果オブジェクト
addDepartment

Object addDepartment(Object department)

組織を登録します。

このメソッドを実行しただけではまだ会社の組織構成には追加されていません。
組織構成に追加したい場合はjoinDepartment(String, String, String, String) を使用してください。
パラメータ
department Object 組織情報オブジェクト
返却値
Object 処理結果オブジェクト
addPost

Object addPost(Object post)

役職を登録します。

パラメータ
post Object 役職情報オブジェクト
返却値
Object 処理結果オブジェクト
addVersion

Object addVersion(Object version)

会社構成バージョンを登録します。

追加された構成バージョンのトップレベルには、会社に該当する組織が自動的に追加されます。
パラメータ
version Object 会社構成バージョン情報オブジェクト
返却値
Object 処理結果オブジェクト
copyVersion

Object copyVersion(String company ,String srcVersion ,String destVersion ,Date startDate ,Date endDate)

登録済の会社構成バージョンの内容をコピーします。

コピー元の会社構成バージョンに関連する、
全ての組織内包がコピー先の会社構成バージョンに関連づくようにコピーされます。
コピー元のバージョンコードは登録済みのものを選択してください。
コピー先のバージョンコードは登録されていないものを選択してください。
パラメータ
company | String | コピー元、コピー先の会社構成バージョンの会社コード
srcVersion | String | コピー元の会社構成バージョンのバージョンコード
destVersion | String | コピー先の会社構成バージョンのバージョンコード
startDate | Date | コピー先のパブリックグループセット構成バージョンの有効期間開始日時
endDate | Date | コピー先のパブリックグループセット構成バージョンの有効期間終了日時
返却値
Object 処理結果オブジェクト
deleteCompany

Object deleteCompany(Object company)

登録済の会社を削除します。

このメソッドを実行すると指定された会社に関連する全ての情報が削除されます。
指定された会社の情報が存在しない場合は処理失敗となります。
パラメータ
company Object 会社情報オブジェクト
返却値
Object 処理結果オブジェクト
deleteDepartment

Object deleteDepartment(Object department)

登録済の組織情報を削除します。

指定された組織情報が存在しない場合は処理失敗となります。
パラメータ
department Object 組織情報オブジェクト
返却値
Object 処理結果オブジェクト
deleteMember

Object deleteMember(Object departmentAttach)

組織から人員をはずします。

指定された人員の情報が存在しない場合は処理失敗となります。
パラメータ
departmentAttach Object 組織から外す人員の情報
返却値
Object 処理結果オブジェクト
deletePost

Object deletePost(Object post)

登録済の役職情報を削除します。

指定された役職情報が存在しない場合は処理失敗となります。
パラメータ
post Object 役職情報オブジェクト
返却値
Object 処理結果オブジェクト
deleteVersion

Object deleteVersion(Object version)

登録済の会社構成バージョンを削除します。

パラメータ
version Object 会社構成バージョン情報オブジェクト
返却値
Object 処理結果オブジェクト
getDepartmentStructs

Object getDepartmentStructs(String company ,String department ,Date date ,String locale)

組織の階層構造を取得します。

指定された日付に該当する、会社構成バージョンがない時はエラーとなります。
パラメータ
company | String | 会社コード
department | String | 組織コード
date | Date | 日付
locale | String | 言語
返却値
Object 処理結果オブジェクト

処理結果オブジェクトの構成は以下の通りです。
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(処理失敗) or -2(引数オブジェクト不正) (Number)
message エラー発生時のメッセージ (String)
data 組織の階層構造 (Array)
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
getPostsInCompany

Object getPostsInCompany(String company [,Date date] [,String locale])

会社に登録されている役職の一覧を取得します。

日付が指定されない場合は、システム日付を含む期間の情報を取得します。
また言語が指定されない場合は、ログインユーザのデフォルト言語の情報が取得されます。

検索結果は、処理結果オブジェクトの data属性に非構造化役職オブジェクト の配列 (Array) として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

パラメータ
company | String | 会社コード
date | Date | 日付 (省略可能)
locale | String | 言語 (省略可能)
返却値
Object 処理結果オブジェクト
getPostsOfUser

Object getPostsOfUser(String company ,String user [,Date date] [,String locale])

ユーザに対して設定されている役職の一覧を取得します。

日付が指定されない場合は、システム日付を含む期間の情報を取得します。
また言語が指定されない場合は、ログインユーザのデフォルト言語の情報が取得されます。

検索結果は、処理結果オブジェクトの data属性に非構造化役職オブジェクト の配列 (Array) として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

パラメータ
company | String | 会社コード
user | String | ユーザコード
date | Date | 日付 (省略可能)
locale | String | 言語 (省略可能)
返却値
Object 処理結果オブジェクト
joinDepartment

Object joinDepartment(String company ,String parentDepartment ,String department ,String version)

組織構成に組織を登録します。

新しく親となる組織と登録対象の組織は同一の会社に所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。

指定された組織が対象のバージョンにおいて既に登録されているときはこのメソッドは使用できません。
パラメータ
company | String | 会社コード
parentDepartment | String | 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department | String | 新規登録する組織の組織コード（会社に該当する組織は指定できない）
version | String | バージョンコード
返却値
Object 処理結果オブジェクト
leaveDepartment

Object leaveDepartment(String company ,String department ,String version)

組織構成から組織情報を離脱させます。

このメソッドを実行すると、指定された組織を指定されたバージョンから削除します。
指定された組織が子組織を持っていた場合、それらの組織も再帰的にこのバージョンから削除されます。
このメソッドを実行しても組織情報そのものは残ります。
パラメータ
company | String | 会社コード
department | String | 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version | String | バージョンコード
返却値
Object 処理結果オブジェクト
moveDepartment

Object moveDepartment(String company ,String parentDepartment ,String department ,String version)

組織構成に登録済の組織情報を移動します。

新しく上位となる組織と移動対象の組織は同一の会社に所属している必要があります。
また、組織構成が循環するような移動はできません。
バージョンコードは登録済みのものを指定する必要があります
パラメータ
company | String | 上位組織と移動対象の組織画所属する会社の会社コード
parentDepartment | String | 上位組織の組織コード（または会社の会社コード）
department | String | 移動する組織の組織コード（会社に該当する組織は指定できない）
version | String | バージョンコード
返却値
Object 処理結果オブジェクト
removeCategoryDetail

Object removeCategoryDetail(Object category)

組織に対して指定された分類区分情報を削除します。

パラメータ
category Object 削除する会社分類区分情報オブジェクト
返却値
Object 処理結果オブジェクト
removeMain

Object removeMain(Object main)

指定されたユーザの主所属を削除します。

パラメータ
main Object 主所属情報オブジェクト
返却値
Object 処理結果オブジェクト
setCategoryDetail

Object setCategoryDetail(Object category)

組織に対して指定された分類区分情報を設定します。

パラメータ
category Object 設定する会社分類区分情報オブジェクト
返却値
Object 処理結果オブジェクト
setMain

Object setMain(Object main)

ユーザが主所属する組織を設定します。

既存の主所属情報は新しい情報で上書きされます。
パラメータ
main Object 主所属情報オブジェクト
返却値
Object 処理結果オブジェクト
setMember

Object setMember(Object departmentAttach)

組織に人員を割り当てます。

人員の割当情報がすでに設定されている場合は、パラメータで渡された情報で完全に上書きされます。
パラメータ
departmentAttach Object 割当人員の情報
返却値
Object 処理結果オブジェクト
updateDepartment

Object updateDepartment(Object department)

登録済の組織情報を更新します。

パラメータ
department Object 組織情報オブジェクト
返却値
Object 処理結果オブジェクト
updatePost

Object updatePost(Object post)

登録済の役職情報を更新します。

パラメータ
post Object 役職情報オブジェクト
返却値
Object 処理結果オブジェクト
updateVersion

Object updateVersion(Object version)

登録済の会社構成バージョンを更新します。

パラメータ
version Object 会社構成バージョン情報オブジェクト
返却値
Object 処理結果オブジェクト


 Constant オブジェクト

定数値管理オブジェクト。

定数値を管理するＡＰＩです。
メソッド define()で設定された値は、Constant オブジェクトのプロパティ値としてプロセス内のすべてのファンクション・コンテナから変更不能な定数値として参照することができます。
このＡＰＩの設定値は、Application Runtime の動作しているサーバ・プロセスをスコープとして管理されます。他のサーバ・プロセスから参照(値の共有)をすることはできません。
また、プロセスが終了するまで値の参照は保証されます(プロセスが終了した場合は、値も破棄されます)。

このオブジェクトの同一プロパティ(key)に対して定数値の二重定義はできません。
バージョン：1.0
導入されたバージョン：2.11
メソッドの概要
static void | define(String key ,String value) 定数値を設定します。
static void | load(String src) 定数値設定ファイルを読込ます。
メソッドの詳細
define

static void define(String key ,String value)

定数値を設定します。

システムで共通の定数値を設定します。
引数 key で指定した文字列が Constant オブジェクトのプロパティとなり、設定後は Constant オブジェクトを介して key で指定されたプロパティにより定数値 value を参照できるようになります。

Constant.key == value

例:
Constant.define("product_name", "intra-mart");
Debug.browse(Constant.product_name);

画面には、変数の内容として intra-mart が表示されます。
パラメータ
key | String | 定数値参照名称
value | String | 定数値
返却値
void
load

static void load(String src)

定数値設定ファイルを読込ます。

指定ファイル内に定義されたシステムで共通の定数値を設定します。
引数には、ファイルのラベル名称を指定して下さい。このＡＰＩは自動的に file.js というファイルを検索して読み込みます。

設定ファイル内には、通常のファンクション・コンテナを作成する要領で、グローバル変数を定義して下さい。
グローバル変数の宣言は初期化（初期値代入）を伴うように記述して下さい。グローバル変数に対して初期値が設定されていない場合、正しく定数値を設定することができません。

定義ファイルが読み込まれた後は、定義ファイル内のグローバル変数名が Constant オブジェクトのプロパティ名称となり、グローバル変数値が定数値として設定されます。

Constant.変数名 == 変数値

例:
定義ファイル（test.js）
var SUN = 0;
var MON = 1;
var TUE = 2;
var WED = 3;
var THU = 4;
var FRI = 5;
var SAT = 6;
ファンクション・コンテナ

Constant.load("test");
Debug.browse(Constant.WED);

画面には、変数の内容として 3 が表示されます。
パラメータ
src String 定数値設定ファイル名称（拡張子なし）
返却値
void


 Content オブジェクト

コンテンツクラス。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
Content(String srcPath)
コンストラクタ。
メソッドの概要
String | execute(Object value) コンテンツの実行と生成をします。
Boolean | isError() コンテンツが実行可能かどうかチェックします。
String | toString() オブジェクトの文字列表現を返却します。
コンストラクタの詳細
Content

Content(String srcPath)
コンストラクタ。

ソースパスは サーバディレクトリ/pagesからの相対指定で拡張子なしの形式の文字列を指定します。
該当する .html ファイルと .js ファイルを読込＆解析し、実行可能オブジェクトを構築します。
パラメータ
srcPath String ソースパス
メソッドの詳細
execute

String execute(Object value)

コンテンツの実行と生成をします。
パラメータ
value Object ファンクションコンテナ内 init() への引数
返却値
String 実行結果HTMLソース
isError

Boolean isError()

コンテンツが実行可能かどうかチェックします。
ＨＴＭＬファイルが見つからなかった場合 true を返却します。
返却値
Boolean true ： 実行不可能状態 / false ： 実行可能
toString

String toString()

オブジェクトの文字列表現を返却します。
返却値
String このインスタンスの文字列表現


 CSVParser オブジェクト

CSV解析オブジェクト。

CSV形式で書かれている文字列から２次元配列を作成します。
バージョン：1.0
導入されたバージョン：2.11
メソッドの概要
static Array parse(String csvtext ,String delimita)
CSV形式の文字列の解析を行います。
メソッドの詳細
parse

static Array parse(String csvtext ,String delimita)

CSV形式の文字列の解析を行います。

CSV形式のデータが保管されている文字列を２次元配列データに変換します。
パラメータ
csvtext | String | CSV形式の文字列
delimita | String | CSV形式の区切り文字（" ","\t","," など１文字で指定）
返却値
Array 文字列の２次元配列データ


 DatabaseManager オブジェクト

データベースマネージャ。

データベースに対する操作を行うマネージャです。

各メソッドの引数に、”接続名”とありますが、この引数を指定した場合は、指定した引数値と同じ接続名のシステムデータベースへ接続されます。
これを指定しなかった場合、現在ログインしているログイングループのログイングループのデータベースへ接続されます。
システムデータベースとは、ServerManager/conf/data-source.xml内で<system-data-source>タグで設定されているデータベースです。
ログイングループのデータベースとは、ServerManager/conf/data-source.xml内で<group-data-source>タグで設定されているデータベースです。

DBから取得するカラムの型変換は以下の通りです。
Javaでの型 | JavaScriptでの型
String | String
int | Number
short | Number
float | Number
double | Number
Date | Date
Time | Date
byte[] | String
Blob | String
null | null
その他 | StringまたはJavaオブジェクト
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static DatabaseResult | beginTransaction() データベーストランザクションを開始します。
static DatabaseResult | commit() データベーストランザクションをコミットします。
static Date | dateToString(Date date) 日付型変数から日付文字列を取得します。
static Date | dateToString(Number year ,Number month ,Number day ,Number hour ,Number minute ,Number second) 日付情報から日付文字列を取得します。
static DatabaseResult | execStoredFunc(String functionName ,Number type ,Array arg ,String connectId ,Boolean isGroup) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc(String functionName ,Number type ,Array arg ,String connectId) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc(String functionName ,Number type ,Array arg) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc(String functionName ,Number type ,String connectId ,Boolean isGroup) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc(String functionName ,Number type ,String connectId) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc(String functionName ,Number type) ストアドファンクションを実行します。
static DatabaseResult | execStoredProc(String functionName ,Array arg ,String connectId ,Boolean isGroup) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc(String functionName ,Array arg ,String connectId) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc(String functionName ,Array arg) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc(String functionName ,String connectId ,Boolean isGroup) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc(String functionName ,String connectId) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc(String functionName) ストアドプロシジャを実行します。
static DatabaseResult | execute(String sql ,Array params ,String connectId ,Boolean isGroup) 任意のSQL文を実行します。
static DatabaseResult | execute(String sql ,Array params ,String connectId) 任意のSQL文を実行します。
static DatabaseResult | execute(String sql ,Array params) 任意のSQL文を実行します。
static DatabaseResult | execute(String sql ,String connectId ,Boolean isGroup) 任意のSQL文を実行します。
static DatabaseResult | execute(String sql ,String connectId) 任意のSQL文を実行します。
static DatabaseResult | execute(String sql) 任意のSQL文を実行します。
static DatabaseResult | fetch(String sql ,Number stratRow ,Number maxRow ,Array params ,String connectId ,Boolean isGroup) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch(String sql ,Number stratRow ,Number maxRow ,Array params ,String connectId) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch(String sql ,Number stratRow ,Number maxRow ,Array params) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch(String sql ,Number stratRow ,Number maxRow ,String connectId ,Boolean isGroup) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch(String sql ,Number stratRow ,Number maxRow ,String connectId) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch(String sql ,Number stratRow ,Number maxRow) SELECT文を発行後、取得データをフェッチして取得します。
static Array | getConnectIdsBySystem() システム接続名の一覧を取得します。
static Number | getCount(String tableName [,String condition] ,String connectId ,Boolean isGroup) 指定されたテーブルと検索条件に一致したレコード数を取得します。
static Number | getCount(String tableName ,String condition ,String connectId) 指定されたテーブルと検索条件に一致したレコード数を取得します。
static Number | getCount(String tableName ,String condition) 指定されたテーブルと検索条件に一致したレコード数を取得します。
static Number | getCount(String tableName) 指定されたテーブルと検索条件に一致したレコード数を取得します。
static String | getDataSourceNameByLoginGroup(groupId String) ログイングループIDからデータソース参照名を取得します。
static String | getDataSourceNameBySystem(String connectId) システム接続名からデータソース参照名を取得します。
static String | getDbName(String connectId ,Boolean isGroup) データベースの名称を取得します。
static String | getDbName(String connectId) データベースの名称を取得します。
static String | getDbName() データベースの名称を取得します。
static String | getDbVersion(String connectId ,Boolean isGroup) データベースのバージョンを取得します。
static String | getDbVersion(String connectId) データベースのバージョンを取得します。
static String | getDbVersion() データベースのバージョンを取得します。
static String | getEscape(String connectId ,Boolean isGroup) ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
static String | getEscape(String connectId) ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
static String | getEscape() ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
static Object | getMax(String columnName ,String tableName ,String condition ,String connectId ,Boolean isGroup) テーブル内の指定列の最大値を取得します。
static Object | getMax(String columnName ,String tableName ,String condition ,String connectId) テーブル内の指定列の最大値を取得します。
static Object | getMax(String columnName ,String tableName ,String condition) テーブル内の指定列の最大値を取得します。
static Object | getMax(String columnName ,String tableName) テーブル内の指定列の最大値を取得します。
static Object | getMin(String columnName ,String tableName [,String condition] ,String connectId ,Boolean isGroup) テーブル内の指定列の最小値を取得します。
static Object | getMin(String columnName ,String tableName ,String condition ,String connectId) テーブル内の指定列の最小値を取得します。
static Object | getMin(String columnName ,String tableName ,String condition) テーブル内の指定列の最小値を取得します。
static Object | getMin(String columnName ,String tableName) テーブル内の指定列の最小値を取得します。
static DbStoredProcArg | getStoredArg() ストアドプロシジャーの引数オブジェクトを取得する。
static DatabaseResult | insert(String tableName ,Object insertData ,String connectId ,Boolean isGroup) 指定されたテーブルにデータを挿入します。
static DatabaseResult | insert(String tableName ,Object insertData ,String connectId) 指定されたテーブルにデータを挿入します。
static DatabaseResult | insert(String tableName ,Object insertData) 指定されたテーブルにデータを挿入します。
static Boolean | isColumn(String columnName ,String tableName ,String connectId ,Boolean isGroup) 指定された名前の列がテーブルに存在するかどうかを調べます。
static Boolean | isColumn(String columnName ,String tableName ,String connectId) 指定された名前の列がテーブルに存在するかどうかを調べます。
static Boolean | isColumn(String columnName ,String tableName) 指定された名前の列がテーブルに存在するかどうかを調べます。
static Boolean | isConnect(String connectId ,Boolean isGroup) データベース接続の確認を行います。
static Boolean | isConnect(String connectId) データベース接続の確認を行います。
static Boolean | isConnect() データベース接続の確認を行います。
static Boolean | isTransaction() データベースアクセスのトランザクション状態を取得します。
static DatabaseResult | remove(String tableName ,String condition ,String connectId ,Boolean isGroup) レコードを削除します。
static DatabaseResult | remove(String tableName ,String condition ,String connectId) レコードを削除します。
static DatabaseResult | remove(String tableName ,String condition) レコードを削除します。
static DatabaseResult | rollback() データベーストランザクションをロールバックします。
static DatabaseResult | select(String sql ,Array params ,Number max ,String connectId ,Boolean isGroup) SELECT文を発行してデータを取得します。
static DatabaseResult | select(String sql ,Array params ,Number max ,String connectId) SELECT文を発行してデータを取得します。
static DatabaseResult | select(String sql ,Array params ,Number max) SELECT文を発行してデータを取得します。
static DatabaseResult | select(String sql ,Array params) SELECT文を発行してデータを取得します。
static DatabaseResult | select(String sql ,Number max ,String connectId ,Boolean isGroup) SELECT文を発行してデータを取得します。
static DatabaseResult | select(String sql ,Number max ,String connectId) SELECT文を発行してデータを取得します。
static DatabaseResult | select(String sql ,Number max) SELECT文を発行してデータを取得します。
static DatabaseResult | select(String sql) SELECT文を発行してデータを取得します。
static Date | stringToDate(String date) 文字列から日付型変数を取得します。
static DatabaseResult | update(String tableName ,String condition ,Object updateData ,String connectId ,Boolean isGroup) データベースのデータを更新します。
static DatabaseResult | update(String tableName ,String condition ,Object updateData ,String connectId) データベースのデータを更新します。
static DatabaseResult | update(String tableName ,String condition ,Object updateData) データベースのデータを更新します。
メソッドの詳細
beginTransaction

static DatabaseResult beginTransaction()

データベーストランザクションを開始します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
commit

static DatabaseResult commit()

データベーストランザクションをコミットします。
返却値
DatabaseResult データベースアクセス結果オブジェクト
dateToString

static Date dateToString(Date date)

日付型変数から日付文字列を取得します。

日付を表わす日付型変数から日付をあらわす文字列を生成します。
引数が不正の場合、nullを返却します。

例:DatabaseManager.dateToString(new Date());
パラメータ
date Date 日付
返却値
Date 日付を表わす文字列(yyyy/MM/dd|hh:mm:ss)
dateToString

static Date dateToString(Number year ,Number month ,Number day ,Number hour ,Number minute ,Number second)

日付情報から日付文字列を取得します。

日付情報から日付をあらわす文字列を生成します。
引数が不正の場合、nullを返却します。

例：DatabaseManager.dateToString(2000,1,1,10,10,10);
パラメータ
year | Number | 年
month | Number | 月
day | Number | 日
hour | Number | 時
minute | Number | 分
second | Number | 秒
返却値
Date 日付を表わす文字列(YYYY/MM/DD|hh:mm:ss)
execStoredFunc

static DatabaseResult execStoredFunc(String functionName ,Number type ,Array arg ,String connectId ,Boolean isGroup)

ストアドファンクションを実行します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc(String functionName ,Number type ,Array arg ,String connectId)

ストアドファンクションを実行します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc(String functionName ,Number type ,Array arg)

ストアドファンクションを実行します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
arg | Array | 引数オブジェクト(DbStoredProcArg)の配列
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc(String functionName ,Number type ,String connectId ,Boolean isGroup)

ストアドファンクションを実行します。

引数オブジェクトの配列を使用しません。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc(String functionName ,Number type ,String connectId)

ストアドファンクションを実行します。

引数オブジェクトの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc(String functionName ,Number type)

ストアドファンクションを実行します。

引数オブジェクトの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc(String functionName ,Array arg ,String connectId ,Boolean isGroup)

ストアドプロシジャを実行します。
パラメータ
functionName | String | storedFunction名
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc(String functionName ,Array arg ,String connectId)

ストアドプロシジャを実行します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
functionName | String | storedFunction名
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc(String functionName ,Array arg)

ストアドプロシジャを実行します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
functionName | String | storedFunction名
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc(String functionName ,String connectId ,Boolean isGroup)

ストアドプロシジャを実行します。

引数オブジェクトの配列を使用しません。
パラメータ
functionName | String | storedFunction名
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc(String functionName ,String connectId)

ストアドプロシジャを実行します。

引数オブジェクトの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
functionName | String | storedFunction名
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc(String functionName)

ストアドプロシジャを実行します。

引数オブジェクトの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
functionName String storedFunction名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execute

static DatabaseResult execute(String sql ,Array params ,String connectId ,Boolean isGroup)

任意のSQL文を実行します。
パラメータ
sql | String | SQL文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute(String sql ,Array params ,String connectId)

任意のSQL文を実行します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql | String | SQL文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute(String sql ,Array params)

任意のSQL文を実行します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql | String | SQL文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute(String sql ,String connectId ,Boolean isGroup)

任意のSQL文を実行します。

パラメータの配列を使用しません。
パラメータ
sql String SQL文
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute(String sql ,String connectId)

任意のSQL文を実行します。

パラメータの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql String SQL文
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute(String sql)

任意のSQL文を実行します。

パラメータの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql String SQL文
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch(String sql ,Number stratRow ,Number maxRow ,Array params ,String connectId ,Boolean isGroup)

SELECT文を発行後、取得データをフェッチして取得します。
パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
maxRow | Number | 取得するデータの最大レコード数(1以上)
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult 参照系データベースアクセス結果オブジェクト。
fetch

static DatabaseResult fetch(String sql ,Number stratRow ,Number maxRow ,Array params ,String connectId)

SELECT文を発行後、取得データをフェッチして取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
maxRow | Number | 取得するデータの最大レコード数(1以上)
params Array SQL文に渡すパラメータの配列(DbParameterの配列)
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch(String sql ,Number stratRow ,Number maxRow ,Array params)

SELECT文を発行後、取得データをフェッチして取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
maxRow | Number | 取得するデータの最大レコード数(1以上)
params Array SQL文に渡すパラメータの配列(DbParameterの配列)
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch(String sql ,Number stratRow ,Number maxRow ,String connectId ,Boolean isGroup)

SELECT文を発行後、取得データをフェッチして取得します。

パラメータの配列を使用しません。
パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
maxRow | Number | 取得するデータの最大レコード数(1以上)
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch(String sql ,Number stratRow ,Number maxRow ,String connectId)

SELECT文を発行後、取得データをフェッチして取得します。

パラメータの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
maxRow | Number | 取得するデータの最大レコード数(1以上)
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch(String sql ,Number stratRow ,Number maxRow)

SELECT文を発行後、取得データをフェッチして取得します。

パラメータの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
maxRow | Number | 取得するデータの最大レコード数(1以上)
返却値
DatabaseResult データベースアクセス結果オブジェクト
getConnectIdsBySystem

static Array getConnectIdsBySystem()

システム接続名の一覧を取得します。

返却値
Array 接続名の配列
getCount

static Number getCount(String tableName [,String condition] ,String connectId ,Boolean isGroup)

指定されたテーブルと検索条件に一致したレコード数を取得します。
パラメータ
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Number レコード件数
getCount

static Number getCount(String tableName ,String condition ,String connectId)

指定されたテーブルと検索条件に一致したレコード数を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
返却値
Number レコード件数
getCount

static Number getCount(String tableName ,String condition)

指定されたテーブルと検索条件に一致したレコード数を取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
tableName String テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
返却値
Number レコード件数
getCount

static Number getCount(String tableName)

指定されたテーブルと検索条件に一致したレコード数を取得します。

現在ログインしているログイングループのデータベースに接続します。
条件句を指定しません。
パラメータ
tableName String テーブル名
返却値
Number レコード件数
getDataSourceNameByLoginGroup

static String getDataSourceNameByLoginGroup(groupId String)

ログイングループIDからデータソース参照名を取得します。

ログイングループIDに紐付くデータソース参照名が存在しない場合はnullを返却します。
パラメータ
String groupId ログイングループID
返却値
String データソース参照名
getDataSourceNameBySystem

static String getDataSourceNameBySystem(String connectId)

システム接続名からデータソース参照名を取得します。

システム接続名に紐付くデータソース参照名が存在しない場合はnullを返却します。
パラメータ
connectId String システム接続名
返却値
String データソース参照名
getDbName

static String getDbName(String connectId ,Boolean isGroup)

データベースの名称を取得します。
パラメータ
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
String データベースの名称
getDbName

static String getDbName(String connectId)

データベースの名称を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
connectId String 接続名
返却値
String データベースの名称
getDbName

static String getDbName()

データベースの名称を取得します。

現在ログインしているログイングループのデータベースに接続します。
返却値
String データベースの名称
getDbVersion

static String getDbVersion(String connectId ,Boolean isGroup)

データベースのバージョンを取得します。
パラメータ
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
String データベースのバージョン
getDbVersion

static String getDbVersion(String connectId)

データベースのバージョンを取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
connectId String 接続名
返却値
String データベースのバージョン
getDbVersion

static String getDbVersion()

データベースのバージョンを取得します。

現在ログインしているログイングループのデータベースに接続します。
返却値
String データベースのバージョン
getEscape

static String getEscape(String connectId ,Boolean isGroup)

ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
パラメータ
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
String ワイルドカード文字をエスケープするのに使用できる文字列
getEscape

static String getEscape(String connectId)

ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
connectId String 接続名
返却値
String ワイルドカード文字をエスケープするのに使用できる文字列
getEscape

static String getEscape()

ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

現在ログインしているログイングループのデータベースに接続します。
返却値
String ワイルドカード文字をエスケープするのに使用できる文字列
getMax

static Object getMax(String columnName ,String tableName ,String condition ,String connectId ,Boolean isGroup)

テーブル内の指定列の最大値を取得します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Object DBデータ型のオブジェクト
getMax

static Object getMax(String columnName ,String tableName ,String condition ,String connectId)

テーブル内の指定列の最大値を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
返却値
Object DBデータ型のオブジェクト
getMax

static Object getMax(String columnName ,String tableName ,String condition)

テーブル内の指定列の最大値を取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
返却値
Object DBデータ型のオブジェクト
getMax

static Object getMax(String columnName ,String tableName)

テーブル内の指定列の最大値を取得します。

現在ログインしているログイングループのデータベースに接続します。
条件句を指定しません。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
返却値
Object DBデータ型のオブジェクト
getMin

static Object getMin(String columnName ,String tableName [,String condition] ,String connectId ,Boolean isGroup)

テーブル内の指定列の最小値を取得します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Object DBデータ型のオブジェクト
getMin

static Object getMin(String columnName ,String tableName ,String condition ,String connectId)

テーブル内の指定列の最小値を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
返却値
Object DBデータ型のオブジェクト
getMin

static Object getMin(String columnName ,String tableName ,String condition)

テーブル内の指定列の最小値を取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
返却値
Object DBデータ型のオブジェクト
getMin

static Object getMin(String columnName ,String tableName)

テーブル内の指定列の最小値を取得します。

現在ログインしているログイングループのデータベースに接続します。
条件句を指定しません。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
返却値
Object DBデータ型のオブジェクト
getStoredArg

static DbStoredProcArg getStoredArg()

ストアドプロシジャーの引数オブジェクトを取得する。
返却値
DbStoredProcArg ストアドプロシジャーの引数オブジェクト
insert

static DatabaseResult insert(String tableName ,Object insertData ,String connectId ,Boolean isGroup)

指定されたテーブルにデータを挿入します。
パラメータ
tableName | String | テーブル名
insertData Object 挿入データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
insert

static DatabaseResult insert(String tableName ,Object insertData ,String connectId)

指定されたテーブルにデータを挿入します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
tableName | String | テーブル名
insertData Object 挿入データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
insert

static DatabaseResult insert(String tableName ,Object insertData)

指定されたテーブルにデータを挿入します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
tableName String テーブル名
insertData Object 挿入データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
返却値
DatabaseResult データベースアクセス結果オブジェクト
isColumn

static Boolean isColumn(String columnName ,String tableName ,String connectId ,Boolean isGroup)

指定された名前の列がテーブルに存在するかどうかを調べます。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Boolean true : 存在する / false : 存在しない
isColumn

static Boolean isColumn(String columnName ,String tableName ,String connectId)

指定された名前の列がテーブルに存在するかどうかを調べます。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
connectId | String | 接続名
返却値
Boolean true : 存在する / false : 存在しない
isColumn

static Boolean isColumn(String columnName ,String tableName)

指定された名前の列がテーブルに存在するかどうかを調べます。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
返却値
Boolean true : 存在する / false : 存在しない
isConnect

static Boolean isConnect(String connectId ,Boolean isGroup)

データベース接続の確認を行います。
パラメータ
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Boolean true : 成功 / false : 失敗
isConnect

static Boolean isConnect(String connectId)

データベース接続の確認を行います。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
connectId String 接続名
返却値
Boolean true : 成功 / false : 失敗
isConnect

static Boolean isConnect()

データベース接続の確認を行います。

現在ログインしているログイングループのデータベースに接続します。
返却値
Boolean true : 成功 / false : 失敗
isTransaction

static Boolean isTransaction()

データベースアクセスのトランザクション状態を取得します。

返却値
Boolean true : トランザクション中 / false : トランザクション外 / null : エラー
remove

static DatabaseResult remove(String tableName ,String condition ,String connectId ,Boolean isGroup)

レコードを削除します。
パラメータ
tableName | String | 対象テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
remove

static DatabaseResult remove(String tableName ,String condition ,String connectId)

レコードを削除します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
tableName | String | 対象テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
remove

static DatabaseResult remove(String tableName ,String condition)

レコードを削除します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
tableName String 対象テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
返却値
DatabaseResult データベースアクセス結果オブジェクト
rollback

static DatabaseResult rollback()

データベーストランザクションをロールバックします。

返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select(String sql ,Array params ,Number max ,String connectId ,Boolean isGroup)

SELECT文を発行してデータを取得します。
パラメータ
sql | String | SELECT文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
max Number 最大取得行数
最大取得行数を指定しない場合で、かつ接続名指定する場合は0を指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult 参照系データベースアクセス結果オブジェクト。
select

static DatabaseResult select(String sql ,Array params ,Number max ,String connectId)

SELECT文を発行してデータを取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql | String | SELECT文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
max Number 最大取得行数
最大取得行数を指定しない場合で、かつ接続名指定する場合は0を指定してください。
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select(String sql ,Array params ,Number max)

SELECT文を発行してデータを取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql | String | SELECT文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
max | Number | 最大取得行数
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select(String sql ,Array params)

SELECT文を発行してデータを取得します。

現在ログインしているログイングループのデータベースに接続します。
最大取得行数を指定しません。
パラメータ
sql | String | SELECT文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select(String sql ,Number max ,String connectId ,Boolean isGroup)

SELECT文を発行してデータを取得します。

パラメータの配列を使用しません。
パラメータ
sql String SQL文
max Number 最大取得行数
最大取得行数を指定しない場合で、かつ接続名指定する場合は0を指定してください。
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select(String sql ,Number max ,String connectId)

SELECT文を発行してデータを取得します。

パラメータの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql String SQL文
max Number 最大取得行数
最大取得行数を指定しない場合で、かつ接続名指定する場合は0を指定してください。
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select(String sql ,Number max)

SELECT文を発行してデータを取得します。

パラメータの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql | String | SQL文
max | Number | 最大取得行数
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select(String sql)

SELECT文を発行してデータを取得します。

パラメータの配列を使用しません。
最大取得行数を指定しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql String SQL文
返却値
DatabaseResult データベースアクセス結果オブジェクト
stringToDate

static Date stringToDate(String date)

文字列から日付型変数を取得します。

引数が不正の場合、nullを返却します。
パラメータ
date String 日付を表わす文字列(yyyy/MM/dd|hh:mm:ss)
返却値
Date 変換後の日付
update

static DatabaseResult update(String tableName ,String condition ,Object updateData ,String connectId ,Boolean isGroup)

データベースのデータを更新します。
パラメータ
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
updateData Object 更新データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
update

static DatabaseResult update(String tableName ,String condition ,Object updateData ,String connectId)

データベースのデータを更新します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
updateData Object 更新データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
update

static DatabaseResult update(String tableName ,String condition ,Object updateData)

データベースのデータを更新します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
tableName String テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
updateData Object 更新データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
返却値
DatabaseResult データベースアクセス結果オブジェクト


 DatabaseResult オブジェクト

データベースアクセス結果オブジェクト。

データベースアクセス処理結果を格納するオブジェクトです。

データベースアクセス結果オブジェクト の構成は以下の通りです。
データベースアクセス
結果オブジェクト (Object)
error
エラー判定 (Boolean)
errorMessage
エラーメッセージ (String)
errorCode
メジャーエラーコード (Number)
sqlState
SQL State (String)
maxRow
最大取得行数 (Number)
select
参照系SQLの場合はtrue (Boolean)
countRow
取得行数 または 実行行数 (Number)
sql
実行SQL または ストアドプロシージャ（ファンクション）(String)
params
パラメータ (Array)
ストアドプロシージャ（ファンクション）に設定したパラメータの値が取得できます。
data
取得情報 (Array)
カラム名 (プロパティ)
カラム名はすべて小文字で表現されます。
各プロパティの値に取得されたデータが格納されます。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
String | getMessage() メッセージを取得します。
Boolean | isSuccess() データベースアクセスが成功したかどうかを取得します。
メソッドの詳細
getMessage

String getMessage()

メッセージを取得します。

返却値
String メッセージ
isSuccess

Boolean isSuccess()

データベースアクセスが成功したかどうかを取得します。

返却値
Boolean true : 成功 / false ： 失敗


 DataForAccount オブジェクト

推奨されていません。代替えのオブジェクトはありません。
ログインユーザ情報オブジェクト。

ログインユーザ情報を保持するオブジェクトです。
バージョン：1.0
導入されたバージョン：2.1
メソッドの概要
Object getAttr()
推奨されていません。AccountManagerおよびProfileManagerの各メソッドに置き換えられました。
String getGroupId()
推奨されていません。代替えのメソッドはありません。
String getId()
推奨されていません。代替えのメソッドはありません。
String getMblPswd()
推奨されていません。AccountManager.getAccount()に置き換えられました。
String getPswd()
推奨されていません。AccountManager.getAccount()に置き換えられました。
Array getRoles()
推奨されていません。AccountManager.getAccountRoleIds()に置き換えられました。
Boolean isLicense()
推奨されていません。LicenseManager.isRegisteredAccountLicense()に置き換えられました。
メソッドの詳細
getAttr

Object getAttr()

推奨されていません。AccountManagerおよびProfileManagerの各メソッドに置き換えられました。
属性情報を取得します。

データがない場合はnull を返却します。
返却値
Object 属性情報オブジェクト
属性情報オブジェクト
(Object)
name
ユーザ名(String)
madrs
メールアドレス(String)
mbladrs
モバイル用メールアドレス(String)
explan
説明(String)
vldDate
有効期限(Number(ミリ秒))
apps
アプリケーションロール(Array) （V4.0.0以上）
favorite
マイメニュー（Object）（V4.1.0以上） 		メニューID
(プロパティ) 		sort_no
ソート番号(Number)
alias
表示名
getGroupId

String getGroupId()

推奨されていません。代替えのメソッドはありません。
ログイングループIDを取得します。

返却値
String ログイングループID
getId

String getId()

推奨されていません。代替えのメソッドはありません。
ユーザIDを取得します。

返却値
String ユーザID
getMblPswd

String getMblPswd()

推奨されていません。AccountManager.getAccount()に置き換えられました。
モバイル用パスワードを取得します。

返却値
String モバイル用パスワード
getPswd

String getPswd()

推奨されていません。AccountManager.getAccount()に置き換えられました。
パスワードを取得します。

返却値
String パスワード
getRoles

Array getRoles()

推奨されていません。AccountManager.getAccountRoleIds()に置き換えられました。
ロールの一覧を取得します。

返却値
Array ロールIDの配列
isLicense

Boolean isLicense()

推奨されていません。LicenseManager.isRegisteredAccountLicense()に置き換えられました。
ライセンスのチェックを行います。

返却値
Boolean true : あり / false : なし


 DataForDatabase オブジェクト

推奨されていません。DatabaseResultに置き換えられました。
参照系データベースアクセス結果オブジェクト。

参照系SQL処理結果を格納するオブジェクトです。

参照系データベースアクセス結果オブジェクト の構成は以下の通りです。
参照系データベースアクセス
結果オブジェクト (Object)
error
エラー判定 (Boolean)
majorErrorCode
メジャーエラーコード (Number)
majorErrorMessage
メジャーエラーメッセージ (String)
minorErrorCode
マイナーエラーコード (Number)
minorErrorMessage
マイナーエラーメッセージ (String)
errorMessage
エラーメッセージ (String)
maxRow
最大取得行数 (Number)
countRow
取得行数 (Number)
sql
実行SQL (String)
data
取得情報 (Array)
カラム名 (プロパティ)
カラム名はすべて小文字で表現されます。
各プロパティの値に取得されたデータが格納されます。
バージョン：1.0
導入されたバージョン：4.3
コンストラクタの概要
DataForDatabase(処理結果オブジェクト result)
コンストラクタ。
コンストラクタの詳細
DataForDatabase

DataForDatabase(処理結果オブジェクト result)
コンストラクタ。

パラメータ
result 処理結果オブジェクト


 DataForRole オブジェクト

推奨されていません。代替えのオブジェクトはありません。
ロール情報オブジェクト。

ロール情報を保持するオブジェクトです。
バージョン：1.0
導入されたバージョン：2.1
メソッドの概要
Object getAttr()
推奨されていません。RoleManager.getRole()に置き換えられました。
String getGroupId()
推奨されていません。代替えのメソッドはありません。
String getId()
推奨されていません。代替えのメソッドはありません。
Array getRoles()
推奨されていません。RoleManager.getSubRole()に置き換えられました。
メソッドの詳細
getAttr

Object getAttr()

推奨されていません。RoleManager.getRole()に置き換えられました。
属性オブジェクトの取得をします。

返却値
Object 属性情報オブジェクト
属性情報オブジェクト
(Object)
name
ロール名(String)
explan
表示名(String)
detail
説明(String)
getGroupId

String getGroupId()

推奨されていません。代替えのメソッドはありません。
ログイングループIDを取得します。

返却値
String ログイングループID
getId

String getId()

推奨されていません。代替えのメソッドはありません。
ロールIDを取得します。

返却値
String ロールID
getRoles

Array getRoles()

推奨されていません。RoleManager.getSubRole()に置き換えられました。
サブロールID配列を取得します。

返却値
Array サブロールIDの配列


 DataForStoredProc オブジェクト

推奨されていません。DatabaseResultに置き換えられました。
ストアドプロシージャ(ファンクション)実行結果オブジェクト。

ストアドプロシージャ(ファンクション)実行結果の情報を保管するオブジェクトです。

ストアドプロシージャ(ファンクション)の構成は以下の通りです。
ストアドプロシージャ(ファンクション)
実行結果オブジェクト(Object)
error
エラー判定 (Boolean)
majorErrorCode
メジャーエラーコード (Number)
majorErrorMessage
メジャーエラーメッセージ (String)
minorErrorCode
マイナーエラーコード (Number)
minorErrorMessage
マイナーエラーメッセージ (String)
errorMessage
エラーメッセージ (String)
countRow
取得行数 (Number)
funcName
実行SQL (String)
data
取得情報 (Array)
カラム名 (プロパティ)
カラム名はすべて小文字で表現されます。
各プロパティの値に取得されたデータが格納されます。
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
String | getDate(Number order) ストアドプロシージャ(ファンクション)のパラメータ値を日付型で取得します。
String | getNumber(Number order) ストアドプロシージャ(ファンクション)のパラメータ値を数値型で取得します。
String/Number/Date | getResult(String type) ストアドファンクションの返却値を指定した型で取得します。
String | getString(Number order) ストアドプロシージャ(ファンクション)のパラメータ値を文字列型で取得します。
Boolean | isSuccess() ストアドプロシージャ(ファンクション)の実行が成功したかどうかを取得します。
メソッドの詳細
getDate

String getDate(Number order)

ストアドプロシージャ(ファンクション)のパラメータ値を日付型で取得します。

パラメータ
order Number パラメータインデックス（1以上を指定します。）
返却値
String パラメータの値
インデックスが不正か、日付に変換できなかった場合は、nullを返却します。
getNumber

String getNumber(Number order)

ストアドプロシージャ(ファンクション)のパラメータ値を数値型で取得します。

パラメータ
order Number パラメータインデックス（1以上を指定します。）
返却値
String パラメータの値
インデックスが不正か、数値に変換できなかった場合は、nullを返却します。
getResult

String/Number/Date getResult(String type)

ストアドファンクションの返却値を指定した型で取得します。

パラメータ
type String 取得する型("String","Number","Date"のいずれか)
返却値
String/Number/Date ストアドプロシージャの返却値（指定した型で返却）
指定した型に変換できなかった場合またはストアドファンクションから作成されたオブジェクトでない場合は、nullを返却します。
getString

String getString(Number order)

ストアドプロシージャ(ファンクション)のパラメータ値を文字列型で取得します。

パラメータ
order Number パラメータインデックス（1以上を指定します。）
返却値
String パラメータの値
インデックスが不正か、文字列に変換できなかった場合は、nullを返却します。
isSuccess

Boolean isSuccess()

ストアドプロシージャ(ファンクション)の実行が成功したかどうかを取得します。

返却値
Boolean true : 成功 / false : 失敗


 DbParameter オブジェクト

SQLパラメータオブジェクト。

SQLのパラメータを保管するオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
定数の概要
static Number | TYPE_DATE 引数のタイプ（日付）。
static Number | TYPE_NUMBER 引数のタイプ（数値）。
static Number | TYPE_STRING 引数のタイプ（文字列）。
コンストラクタの概要
DbParameter(Object data ,Number type)
コンストラクタ。
定数の詳細
TYPE_DATE

static Number TYPE_DATE

引数のタイプ（日付）。
定数値 ： 91
TYPE_NUMBER

static Number TYPE_NUMBER

引数のタイプ（数値）。
定数値 ： 3
TYPE_STRING

static Number TYPE_STRING

引数のタイプ（文字列）。
定数値 ： 12
コンストラクタの詳細
DbParameter

DbParameter(Object data ,Number type)
コンストラクタ。

パラメータ値に渡せる値は文字列型(String),数値型(Number),日付型(Date)のいずれかです。
パラメータの型は、データベースのカラムの型と同じものを指定してください。
パラメータ
data Object パラメータ値
type Number パラメータの型
文字列型 | DbParameter.TYPE_STRING
数値型 | DbParameter.TYPE_NUMBER
日付型 | DbParameter.TYPE_DATE


 DbResultObject オブジェクト

推奨されていません。DatabaseResultに置き換えられました。
データベースアクセス結果オブジェクト。

更新系SQLおよびトランザクション処理結果を格納するオブジェクトです。

データベースアクセス結果オブジェクトの構成は以下の通りです。
データベースアクセス
結果オブジェクト (Object)
error
エラー判定 (Boolean)
majorErrorCode
メジャーエラーコード (Number)
majorErrorMessage
メジャーエラーメッセージ (String)
minorErrorCode
マイナーエラーコード (Number)
minorErrorMessage
マイナーエラーメッセージ (String)
errorMessage
エラーメッセージ (String)
execRow
実行行数 (Number)
sql
実行SQL (String)
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
String | getMessage() メッセージを取得します。
Boolean | isSuccess() データベースアクセスが成功したかどうかを取得します。
メソッドの詳細
getMessage

String getMessage()

メッセージを取得します。

返却値
String メッセージ
isSuccess

Boolean isSuccess()

データベースアクセスが成功したかどうかを取得します。

返却値
Boolean true : 成功 / false ： 失敗


 DbStoredProcArg オブジェクト

ストアドプロシージャ、ファンクション引数オブジェクト。

ストアドプロシージャ、ファンクション引数を保管するオブジェクトです。
バージョン：1.0
導入されたバージョン：4.0
定数の概要
static Number | TYPE_IN 引数のタイプ（入力）。
static Number | TYPE_IN_OUT 引数のタイプ（入出力）。
static Number | TYPE_OUT 引数のタイプ（出力）。
メソッドの概要
Boolean | isDate() 引数が日付タイプかどうか判定します。
Boolean | isIn() 引数が入力タイプかどうか判定します。
Boolean | isInOut() 引数が入出力タイプかどうか判定します。
Boolean | isNumber() 引数が数値タイプかどうか判定します。
Boolean | isOut() 引数が出力タイプかどうか判定します。
Boolean | isString() 引数が文字列タイプかどうか判定します。
Boolean | setDate(Date data ,Object type) 日付型の引数を設定します。
Boolean | setNumber(Number data ,Object type) 数値型の引数を設定します。
Boolean | setString(String data ,Object type) 文字型の引数を設定します。
定数の詳細
TYPE_IN

static Number TYPE_IN

引数のタイプ（入力）。
定数値 ： 1
TYPE_IN_OUT

static Number TYPE_IN_OUT

引数のタイプ（入出力）。
定数値 ： 3
TYPE_OUT

static Number TYPE_OUT

引数のタイプ（出力）。
定数値 ： 2
メソッドの詳細
isDate

Boolean isDate()

引数が日付タイプかどうか判定します。

返却値
Boolean true : 日付タイプの引数 / false ： 日付タイプの引数ではない
isIn

Boolean isIn()

引数が入力タイプかどうか判定します。

返却値
Boolean true : 入力タイプの引数 / false ： 入力タイプの引数ではない
isInOut

Boolean isInOut()

引数が入出力タイプかどうか判定します。

返却値
Boolean true : 入出力タイプの引数 / false ： 入出力タイプの引数ではない
isNumber

Boolean isNumber()

引数が数値タイプかどうか判定します。

返却値
Boolean true : 数値タイプの引数 / false ： 数値タイプの引数ではない
isOut

Boolean isOut()

引数が出力タイプかどうか判定します。

返却値
Boolean true : 出力タイプの引数 / false ： 出力タイプの引数ではない
isString

Boolean isString()

引数が文字列タイプかどうか判定します。

返却値
Boolean true : 文字列タイプの引数 / false ： 文字列タイプの引数ではない
setDate

Boolean setDate(Date data ,Object type)

日付型の引数を設定します。

パラメータ
data Date データ
type Object データタイプ
入力引数 | DbStoredProcArg.TYPE_IN
出力引数 | DbStoredProcArg.TYPE_OUT
入出力引数 | DbStoredProcArg.TYPE_IN_OUT
返却値
Boolean true ： 成功 / false : 失敗
setNumber

Boolean setNumber(Number data ,Object type)

数値型の引数を設定します。

パラメータ
data Number データ
type Object データタイプ
入力引数 | DbStoredProcArg.TYPE_IN
出力引数 | DbStoredProcArg.TYPE_OUT
入出力引数 | DbStoredProcArg.TYPE_IN_OUT
返却値
Boolean true ： 成功 / false : 失敗
setString

Boolean setString(String data ,Object type)

文字型の引数を設定します。

パラメータ
data String データ
type Object データタイプ
入力引数 | DbStoredProcArg.TYPE_IN
出力引数 | DbStoredProcArg.TYPE_OUT
入出力引数 | DbStoredProcArg.TYPE_IN_OUT
返却値
Boolean true ： 成功 / false : 失敗


 Debug オブジェクト

デバッグ情報を表示するオブジェクト。

開発中のデバッグ時に利用するＡＰＩが含まれるオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static void | browse(Object arg [,... ...]) ブラウザへの変数情報を表示します。
static void | print(String msg) コンソールへメッセージを出力します。
static void | write(String msg) ファイルへメッセージを出力します。
メソッドの詳細
browse

static void browse(Object arg [,... ...])

ブラウザへの変数情報を表示します。

指定の変数の情報をブラウザ画面上に表示します。
いかなる JavaScript 変数型の変数も表示対象として指定可能です。
表示対象とする変数の引数への指定個数は任意個（無限）指定可能です。
このＡＰＩが実行されると、このＡＰＩ以降のプログラムは実行されません。
パラメータ
arg Object 表示対象となる変数
... ... 複数指定する場合は、カンマの後に続けて変数を指定します。
返却値
void
print

static void print(String msg)

コンソールへメッセージを出力します。

パラメータ
msg String メッセージ
返却値
void
write

static void write(String msg)

ファイルへメッセージを出力します。

指定の文字列をファイル内へ出力します。
出力ファイルはインストールディレクトリ直下の debug.txt という名前のファイルです。
メソッドの呼び出しが複数回にわたる場合、ファイルへは追記モードで全てのメッセージが出力されます。
パラメータ
msg String メッセージ
返却値
void


 Drawer オブジェクト

画像描画オブジェクト。

画像ファイルを描画、生成するＡＰＩを持つオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
コンストラクタの概要
Drawer(Number imageWidth ,Number imageHeight)
コンストラクタ。
メソッドの概要
void | clearClip() クリッピング領域を解除します。
void | copyArea(Number x ,Number y ,Number width ,Number height ,Number dx ,Number dy) コンポーネント領域を複写します。
void | draw3DRect(Number x ,Number y ,Number width ,Number height ,Boolean raised) 指定された矩形を３Ｄ強調表示にします。
void | drawArc(Number x ,Number y ,Number width ,Number height ,Number startAngle ,Number arcAngle) 円弧または楕円弧の輪郭を描画します。
void | drawLine(Number x1 ,Number y1 ,Number x2 ,Number y2) 線を描画します。
void | drawOval(Number x ,Number y ,Number width ,Number height) 楕円の輪郭を描画します。
void | drawPolygon(Array xPoints ,Array yPoints) 多角形を描画します。
void | drawRect(Number x ,Number y ,Number width ,Number height) 矩形の輪郭を描画します。
void | drawRoundRect(Number x ,Number y ,Number width ,Number height ,Number arcwidth ,Number archeight) 丸いコーナー付きの矩形を描画します。
void | drawString(String string ,Number x ,Number y ,String xPosition ,String yPosition) 文字列を描画します。
void | fill3DRect(Number x ,Number y ,Number width ,Number height ,Boolean raised) 塗りつぶし矩形を３Ｄ強調表示で描画します。
void | fillArc(Number x ,Number y ,Number width ,Number height ,Number startAngle ,Number arcAngle) 円弧または楕円弧を塗りつぶして描画します。
void | fillOval(Number x ,Number y ,Number width ,Number height) 楕円形を塗りつぶして描画します。
void | fillPolygon(Array xPoints ,Array yPoints) 多角形を塗りつぶして描画します。
void | fillRect(Number x ,Number y ,Number width ,Number height) 塗りつぶし矩形を描画します。
void | fillRoundRect(Number x ,Number y ,Number width ,Number height ,Number arcWidth ,Number arcHeight) 丸いコーナー付きの矩形を塗りつぶして描画します。
String | getColor() 現在の色を取得します。
String | getFontName() 現在のフォント名を取得します。
String | getFontSize() 現在のフォントサイズを取得します。
String | getFontStyle() 現在のフォントスタイルを取得します。
Number | getLineSize() 現在の線幅を取得します。
Array | getLineStyle() 現在の破線スタイルを取得します。
String | putImage(String imageType) 画像ファイルのバイナリデータを取得します。
void | setClipArc(Number x ,Number x ,Number width ,Number height ,Number start ,Number extent) 円弧または楕円弧のクリッピング領域を構築します。
void | setClipPolygon(Array xPoints ,Array yPoints) 多角形のクリッピング領域を構築します。
void | setClipRect(Number x ,Number y ,Number width ,Number height) 矩形のクリッピング領域を構築します。
void | setColor(Object color) 描画する色を設定します。
void | setFontName(String font) 描画するフォントを設定します。
void | setFontSize(Number size) 描画するフォントサイズを設定します。
void | setFontStyle(String style) 描画するフォントスタイルを設定。
void | setLineSize(Number lineSize) 描画する線幅を設定します。
void | setLineStyle(Array lineStyle) 描画する線のスタイルを設定します。
コンストラクタの詳細
Drawer

Drawer(Number imageWidth ,Number imageHeight)
コンストラクタ。

指定された幅・高さで画像ファイルを作成し、グラフの描画を実行するためのインスタンスを生成します。
パラメータ
imageWidth | Number | 画像ファイルの幅
imageHeight | Number | 画像ファイルの高さ
メソッドの詳細
clearClip

void clearClip()

クリッピング領域を解除します。

現在、設定されているクリッピング領域が解除されます。
返却値
void
copyArea

void copyArea(Number x ,Number y ,Number width ,Number height ,Number dx ,Number dy)

コンポーネント領域を複写します。

コンポーネントの領域を、dx と dy で指定された距離でコピーします。
このメソッドは x と y で指定された座標から、コンポーネントの下方向や右方向の領域をコピーします。
コンポーネントの左方向や上方向の領域をコピーするには、dx と dy に負の値を指定します。
ソースの矩形のある部分がコンポーネントの境界外にある場合や、別のコンポーネントやウィンドウで隠されている場合は、copyArea は対応しているピクセルをコピーできません。
隠された領域は、そのコンポーネントの paint メソッドを呼び出すことにより修復されます。
パラメータ
x | Number | 元の矩形の ｘ座標
y | Number | 元の矩形の ｙ座標
width | Number | 元の矩形の幅
height | Number | 元の矩形の高さ
dx | Number | ピクセルをコピーする水平距離
dy | Number | ピクセルをコピーする垂直距離
返却値
void
draw3DRect

void draw3DRect(Number x ,Number y ,Number width ,Number height ,Boolean raised)

指定された矩形を３Ｄ強調表示にします。

指定された矩形の輪郭を ３Ｄ で強調表示して描画します。
矩形の端は、傾斜し、左上隅から光を当てたように強調表示されます。
強調表示効果に使われる色は、現在の色に基づいて指定されます。
描画された矩形は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。
raised に true を指定すると、矩形が表面から浮き出たように表示され、 false を指定すると、表面に彫り込まれたように表示されます。
パラメータ
x | Number | 描画される矩形の ｘ座標
y | Number | 描画される矩形の ｙ座標
width | Number | 描画される矩形の幅
height | Number | 描画される矩形の高さ
raised | Boolean | 矩形の３Ｄ強調表示方法を指定する
返却値
void
drawArc

void drawArc(Number x ,Number y ,Number width ,Number height ,Number startAngle ,Number arcAngle)

円弧または楕円弧の輪郭を描画します。

指定された矩形をカバーする円弧または楕円弧の輪郭を描きます。
startAngle から始まって arcAngle の角度で展開された弧が、現在の色を使って描かれます。
角度は 3 時の位置を 0 度として変換され、正の値は反時計方向、負の値は時計方向の回転を示します。

弧の中心は、原点が (x, y) で、サイズが width 引数と height 引数で指定される矩形の中心となります。
描かれる弧は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。

角度の広がりは、直角でない、境界の矩形を基準に指定し、楕円の中心から境界の矩形の右上隅までを結ぶ線が常に 45 度になるようにします。
境界の矩形の軸の長さがかなり違う場合には、弧セグメントの開始角度と終了角度は境界の長軸にそってさらに傾斜します。
パラメータ
x | Number | 描画される弧の左上隅の ｘ座標
y | Number | 描画される弧の左上隅の ｙ座標
width | Number | 描画される弧の幅
height | Number | 描画される弧の高さ
startAngle | Number | 開始角度
arcAngle | Number | 開始角度に対する弧の展開角度
返却値
void
drawLine

void drawLine(Number x1 ,Number y1 ,Number x2 ,Number y2)

線を描画します。

このグラフィックスコンテキストの座標体系の座標 (x1, y1) と座標 (x2, y2) との間に現在の色を使って線を描きます。
パラメータ
x1 | Number | 描画する線の始点 ｘ座標
y1 | Number | 描画する線の始点 ｙ座標
x2 | Number | 描画する線の終点 ｘ座標
y2 | Number | 描画する線の終点 ｙ座標
返却値
void
drawOval

void drawOval(Number x ,Number y ,Number width ,Number height)

楕円の輪郭を描画します。

楕円の輪郭を描きます。
引数の x、y、width、height で指定される矩形内に収まる円または楕円が描かれます。
楕円は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。
パラメータ
x | Number | 描画される楕円の左上隅の ｘ座標
y | Number | 描画される楕円の左上隅の ｙ座標
width | Number | 描画される楕円の幅
height | Number | 描画される楕円の高さ
返却値
void
drawPolygon

void drawPolygon(Array xPoints ,Array yPoints)

多角形を描画します。

x 座標と y 座標の配列で定義された閉じた多角形を描きます。

座標 (x, y) の各ペアは点を定義します。
ｘ座標の配列数とｙ座標の配列数が一致しない場合、少ないほうの配列数を多角形の座標点数とします。
最後の点と最初の点が一致しない場合、それらを接続するラインを描画すれば図は自動的に閉じます。
パラメータ
xPoints | Array | ｘ座標の配列(Numberの配列)
yPoints | Array | ｙ座標の配列(Numberの配列)
返却値
void
drawRect

void drawRect(Number x ,Number y ,Number width ,Number height)

矩形の輪郭を描画します。

指定された矩形の輪郭を描きます。
矩形は、左端と右端がそれぞれ x と x + width、上端と下端がそれぞれ y と y + height で指定されます。
矩形は、グラフィックスコンテキストの現在の色を使って描画されます。
パラメータ
x | Number | 描画される矩形の ｘ座標
y | Number | 描画される矩形の ｙ座標
width | Number | 描画される矩形の幅
height | Number | 描画される矩形の高さ
返却値
void
drawRoundRect

void drawRoundRect(Number x ,Number y ,Number width ,Number height ,Number arcwidth ,Number archeight)

丸いコーナー付きの矩形を描画します。

丸いコーナー付きの矩形を、このグラフィックスコンテキストの現在の色を使用して描きます。
描かれる矩形は、左端と右端がそれぞれ x と x + width、上端と下端がそれぞれ y と y + height で指定されます。
パラメータ
x | Number | 描画される矩形の ｘ座標
y | Number | 描画される矩形の ｙ座標
width | Number | 描画される矩形の幅
height | Number | 描画される矩形の高さ
arcwidth | Number | ４隅の弧の水平方向の直径
archeight | Number | ４隅の弧の垂直方向の直径
返却値
void
drawString

void drawString(String string ,Number x ,Number y ,String xPosition ,String yPosition)

文字列を描画します。

グラフィックスコンテキストの現在の色とフォントを使用して、指定された文字列を描きます。
座標点（x, y）に対して、文字列をどの位置に表示するかを xPosition および yPosition で指定することができます。
xPosition には "right"（右側）／ "center"（中央）／ "left"（左側）を指定してください。
yPosition には "top"（上側）／ "middle"（中央）／ "bottom"（下側）を指定してください。
パラメータ
string | String | 描画する文字列
x | Number | 文字列が描画される ｘ座標
y | Number | 文字列が描画される ｙ座標
xPosition | String | ｘ座標点に対して 文字列をどの位置に表示するか指定
yPosition | String | ｙ座標点に対して 文字列をどの位置に表示するか指定
返却値
void
fill3DRect

void fill3DRect(Number x ,Number y ,Number width ,Number height ,Boolean raised)

塗りつぶし矩形を３Ｄ強調表示で描画します。

現在の色で塗りつぶされている、３Ｄ で強調表示された矩形を描画します。
矩形の端は、傾斜し、左上隅から光を当てたように強調表示されます。
強調表示効果および塗りつぶしに使われる色は、現在の Color によって指定されます。 raised に true を指定すると、矩形が表面から浮き出たように表示され、 false を指定すると、表面に彫り込まれたように表示されます。
パラメータ
x | Number | 塗りつぶされる矩形の ｘ座標
y | Number | 塗りつぶされる矩形の ｙ座標
width | Number | 塗りつぶされる矩形の幅
height | Number | 塗りつぶされる矩形の高さ
raised | Boolean | 矩形の３Ｄ強調表示方法を指定する
返却値
void
fillArc

void fillArc(Number x ,Number y ,Number width ,Number height ,Number startAngle ,Number arcAngle)

円弧または楕円弧を塗りつぶして描画します。

指定された矩形をカバーする円弧または楕円弧を塗りつぶします。

startAngle から始まって arcAngle の角度で展開された弧が描かれます。
角度は 3 時の位置を 0 度として変換され、正の値は反時計方向、負の値は時計方向の回転を示します。
弧の中心は、原点が (x, y) で、サイズが width 引数と height 引数で指定される矩形の中心となります。
描かれる弧は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。
角度の広がりは、直角でない、境界の矩形を基準に指定し、楕円の中心から境界の矩形の右上隅までを結ぶ線が常に 45 度になるようにします。
境界の矩形の軸の長さがかなり違う場合には、弧セグメントの開始角度と終了角度は境界の長軸にそってさらに傾斜します。
パラメータ
x | Number | 塗りつぶされる弧の左上隅の ｘ座標
y | Number | 塗りつぶされる弧の左上隅の ｙ座標
width | Number | 塗りつぶされる弧の幅
height | Number | 塗りつぶされる弧の高さ
startAngle | Number | 開始角度
arcAngle | Number | 開始角度に対する弧の展開角度
返却値
void
fillOval

void fillOval(Number x ,Number y ,Number width ,Number height)

楕円形を塗りつぶして描画します。

楕円形を現在の色で塗りつぶします。
引数の x、y、width、height で指定される矩形内に収まる円または楕円形が塗りつぶされて描かれます。
楕円は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。
パラメータ
x | Number | 塗りつぶされる楕円の左上隅の ｘ座標
y | Number | 塗りつぶされる楕円の左上隅の ｙ座標
width | Number | 塗りつぶされる楕円の幅
height | Number | 塗りつぶされる楕円の高さ
返却値
void
fillPolygon

void fillPolygon(Array xPoints ,Array yPoints)

多角形を塗りつぶして描画します。

x 座標と y 座標の配列で定義される閉じた多角形を塗りつぶします。

座標 (x, y) の各ペアは点を定義します。
ｘ座標の配列数とｙ座標の配列数が一致しない場合、少ないほうの配列数を多角形の座標点数とします。
最後の点と最初の点が一致しない場合、それらを接続するラインを描画すれば図は自動的に閉じます。
パラメータ
xPoints | Array | ｘ座標の配列(Numberの配列)
yPoints | Array | ｙ座標の配列(Numberの配列)
返却値
void
fillRect

void fillRect(Number x ,Number y ,Number width ,Number height)

塗りつぶし矩形を描画します。

指定された矩形を塗りつぶします。
矩形の左端と右端はそれぞれ x と x + width - 1 で、上端と下端はそれぞれ y と y + height - 1 です。
これで指定される矩形は、幅 width ピクセル、高さ height ピクセルの領域です。
矩形は、グラフィックスコンテキストの現在の色を使って塗りつぶされます。
パラメータ
x | Number | 塗りつぶされる矩形の ｘ座標
y | Number | 塗りつぶされる矩形の ｙ座標
width | Number | 塗りつぶされる矩形の幅
height | Number | 塗りつぶされる矩形の高さ
返却値
void
fillRoundRect

void fillRoundRect(Number x ,Number y ,Number width ,Number height ,Number arcWidth ,Number arcHeight)

丸いコーナー付きの矩形を塗りつぶして描画します。

指定された丸いコーナー付きの矩形を現在の色で塗りつぶします。
矩形は、左端と右端がそれぞれ x と x + width - 1、上端と下端がそれぞれ y と y + height - 1 で指定されます。
パラメータ
x | Number | 塗りつぶされる矩形の ｘ座標
y | Number | 塗りつぶされる矩形の ｙ座標
width | Number | 塗りつぶされる矩形の幅
height | Number | 塗りつぶされる矩形の高さ
arcWidth | Number | ４隅の弧の水平方向の直径
arcHeight | Number | ４隅の弧の垂直方向の直径
返却値
void
getColor

String getColor()

現在の色を取得します。

グラフィックスコンテキストの現在の色を返却します。
返却値は色のRGB値（文字列）です。
返却値
String 現在の色のRGB値
getFontName

String getFontName()

現在のフォント名を取得します。

現在のフォント名を返却します。
返却値
String 現在のフォント名
getFontSize

String getFontSize()

現在のフォントサイズを取得します。

整数に丸められた、現在のフォントのポイントサイズを返却します。
返却値
String 現在のフォントサイズ
getFontStyle

String getFontStyle()

現在のフォントスタイルを取得します。

現在のフォントのスタイルを返却します。
返却値は、PLAIN、BOLD、ITALIC、または ITALIC_BOLD のいずれかです。
返却値
String 現在のフォントのスタイル
getLineSize

Number getLineSize()

現在の線幅を取得します。

現在の線幅を返却します。
返却値
Number 現在の線幅
getLineStyle

Array getLineStyle()

現在の破線スタイルを取得します。

破線セグメントの長さを表す配列を返却します。
配列内のエントリが、破線の非透明の部分と透明の部分の長さを交互に表しています。
現在の線の形状が実線の場合、null が返ります。
返却値
Array 破線のパターン配列(Numberの配列)
putImage

String putImage(String imageType)

画像ファイルのバイナリデータを取得します。

指定した形式の、画像ファイルのバイナリを返却します。
引数の imageType には、"png" または "jpeg" を指定して下さい。
パラメータ
imageType String 画像ファイル形式
返却値
String 画像ファイルのバイナリデータ
setClipArc

void setClipArc(Number x ,Number x ,Number width ,Number height ,Number start ,Number extent)

円弧または楕円弧のクリッピング領域を構築します。

指定された位置、サイズ、角の大きさにより、新しい円弧または楕円弧のクリッピング領域を構築します。
パラメータ
x | Number | 弧の左上隅の ｘ座標
x | Number | 弧の左上隅の ｙ座標
width | Number | この弧が一部を構成する楕円の幅
height | Number | この弧が一部を構成する楕円の高さ
start | Number | 弧の始角（度単位）
extent | Number | 弧の角の大きさ
返却値
void
setClipPolygon

void setClipPolygon(Array xPoints ,Array yPoints)

多角形のクリッピング領域を構築します。

x 座標と y 座標の配列で定義された閉じた多角形により、新しいクリッピング領域を構築します。
パラメータ
xPoints | Array | ｘ座標の配列(Numberの配列)
yPoints | Array | ｙ座標の配列(Numberの配列)
返却値
void
setClipRect

void setClipRect(Number x ,Number y ,Number width ,Number height)

矩形のクリッピング領域を構築します。

指定された矩形により、新しいクリッピング領域を構築します。
パラメータ
x | Number | 矩形の ｘ座標
y | Number | 矩形の ｙ座標
width | Number | 矩形の幅
height | Number | 矩形の高さ
返却値
void
setColor

void setColor(Object color)

描画する色を設定します。

グラフィックスコンテキストの現在の色を、指定された色に設定します。 このグラフィックスコンテキストを使うこれ以降のレンダリング操作は、ここで指定された色を使用します。 引数の color にはカラーチャートのカラー名を指定して下さい。
パラメータ
color Object カラー名（String または Number)
返却値
void
setFontName

void setFontName(String font)

描画するフォントを設定します。

グラフィックスコンテキストのフォント名を、指定されたフォント名に設定します。
このグラフィックスコンテキストを使用する、それ以降のテキスト描画操作は、このフォント名を使用します。
パラメータ
font String フォント名
返却値
void
setFontSize

void setFontSize(Number size)

描画するフォントサイズを設定します。

グラフィックスコンテキストのフォントサイズを、指定されたフォントサイズに設定します。
このグラフィックスコンテキストを使用する、それ以降のテキスト描画操作は、このフォントサイズを使用します。
パラメータ
size Number フォントサイズ
返却値
void
setFontStyle

void setFontStyle(String style)

描画するフォントスタイルを設定。

グラフィックスコンテキストのフォントスタイルを、指定されたフォントスタイルに設定します。
このグラフィックスコンテキストを使用する、それ以降のテキスト描画操作は、このフォントスタイルを使用します。
引数の style には、"plain"、"bold"、"italic" または "italic_bold" のいずれかを指定して下さい。
パラメータ
style String フォントスタイル
返却値
void
setLineSize

void setLineSize(Number lineSize)

描画する線幅を設定します。

指定された値で、線幅を設定します。
パラメータ
lineSize Number 線幅
返却値
void
setLineStyle

void setLineStyle(Array lineStyle)

描画する線のスタイルを設定します。

線のスタイルを設定します。 引数の lineStyle には、破線のパターンの配列を指定して下さい。
配列内のエントリに、破線の非透明の部分と透明の部分の長さを交互に指定します。
引数の lineStyle が null の場合、線のスタイルは実線になります。
パラメータ
lineStyle Array 線のスタイル(Numberの配列)
返却値
void


 DOMAttribute オブジェクト

ノードの属性オブジェクト。

ノードの属性情報を保持するオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
メソッドの概要
String | getName() 属性名を取得します。
DOMNode | getParentNode() 親ノードを取得します。
String | getValue() 属性値を取得します。
メソッドの詳細
getName

String getName()

属性名を取得します。

返却値
String 属性名
getParentNode

DOMNode getParentNode()

親ノードを取得します。

親ノードを持たない場合は null を返します。
返却値
DOMNode 親ノードのオブジェクト
getValue

String getValue()

属性値を取得します。

返却値
String 属性値


 DOMDocument オブジェクト

XML 文書全体を表す DOM Document オブジェクト。

このオブジェクトでは、XML の各タグをノードとして管理します。
各ノードは､属性と子供ノードを持ちます。
属性と子供ノードは複数持つ事ができ、子供ノードは更に属性と子供ノードを持つ事が出来ます。 すべてのノードの頂点となる親ノード（ドキュメントノード）は、XML ソース中の最も外側のタグであり、getDocumentElement() によって取得する事が出来ます。

XMLを解析してDOMツリーを作成するには、XMLParserオブジェクトのparse()メソッド、または、parseString()メソッドを使います。
（ドキュメントノードが複数存在する場合は、XML 解析エラーとなりますのでご注意下さい。）

例えば、以下のようなＸＭＬ
 <A>
   <B>Ｂタグの中のテキスト</B>
   <C>Ｃタグの中のテキスト</C>
 </A>
から、<C> タグに囲まれたテキスト値を取得する場合は以下のようにプログラムします。

 var xmlString = "<A><B>Ｂタグの中のテキスト</B><C>Ｃタグの中のテキスト</C></A>";

 var parser = new XMLParser();
 var dom = parser.parseString(xmlString);

 if(!parser.isError()){
     var elms = dom.getElementsByTagName("C");
     var elm = elms[0];
     var childs = elm.getChildNodes();
     var data = childs[0].getValue();

     Debug.print("C's text: " + data);
 }
 else {
     Debug.print("Error occured ! : " + parser.getErrorMessage() );
 }
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
DOMNode | createElement(String tagName) 新しいノードを作成します。
DOMNode | createTextNode(String data) 新しいテキストノードを作成します。
DOMDocumentType | getDoctype() ドキュメントタイプを取得します。
DOMNode | getDocumentElement() Documentノードを取得します。
DOMNode | getElementById(String elementId) 識別子に該当するノードを取得します。
Array | getElementsByTagName(String tagname) 指定のタグにマッチするエレメントを取得します。
String | getErrorMessage() エラーメッセージの取得を行います。
Boolean | isError() エラー発生のチェックを行います。
メソッドの詳細
createElement

DOMNode createElement(String tagName)

新しいノードを作成します。

パラメータ
tagName String タグ名
返却値
DOMNode 新しいノードオブジェクト
createTextNode

DOMNode createTextNode(String data)

新しいテキストノードを作成します。

パラメータ
data String テキスト
返却値
DOMNode 新しいノードオブジェクト
getDoctype

DOMDocumentType getDoctype()

ドキュメントタイプを取得します。

返却値
DOMDocumentType ドキュメントタイプオブジェクト
getDocumentElement

DOMNode getDocumentElement()

Documentノードを取得します。

返却値
DOMNode ドキュメントを示すノード
getElementById

DOMNode getElementById(String elementId)

識別子に該当するノードを取得します。

指定の識別子にマッチしたノードを返します。
指定の識別子を持つノードが存在しなかった場合 null を返します。
パラメータ
elementId String ノード識別子
返却値
DOMNode ノードオブジェクト
getElementsByTagName

Array getElementsByTagName(String tagname)

指定のタグにマッチするエレメントを取得します。

XML ソース中から指定のタグに該当するエンティティを返します。
返却値は、DOMNode オブジェクトを要素に持つ配列です。
パラメータ
tagname String タグ名
返却値
Array ノードオブジェクト(DOMNode)の配列
getErrorMessage

String getErrorMessage()

エラーメッセージの取得を行います。

新しいノード作成時にエラーが発生していた場合、そのエラーメッセージを返します。
返却値
String エラーメッセージ
isError

Boolean isError()

エラー発生のチェックを行います。

新しいノード作成時にエラーが発生していた場合 true を返します。
返却値
Boolean true : エラーあり / false : エラーなし


 DOMDocumentType オブジェクト

ドキュメントタイプオブジェクト。

ドキュメントタイプを示すオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
メソッドの概要
Array | getEntities() エンティティを取得します。
String | getInternalSubset() インターナルサブセットを取得します。
String | getName() ノードの名称を取得します。
Array | getNotations() ノーテーションを取得します。
String | getPublicId() パブリックIDを取得します。
String | getSystemId() システムIDを取得します。
メソッドの詳細
getEntities

Array getEntities()

エンティティを取得します。

このオブジェクトから取得できるエンティティをすべて取得します。
配列の要素は、DOMEntity オブジェクトです。
返却値
Array このオブジェクトから取得できるエンティティ(DOMEntity)を要素に持つ配列
getInternalSubset

String getInternalSubset()

インターナルサブセットを取得します。

返却値
String インターナルサブセット
getName

String getName()

ノードの名称を取得します。

返却値
String ノードの名称
getNotations

Array getNotations()

ノーテーションを取得します。

このオブジェクトから取得できるノーテーションをすべて取得します。
配列の要素は、DOMNotation オブジェクトです。
返却値
Array このオブジェクトから取得できるノーテーション(DOMNotation)を要素に持つ配列
getPublicId

String getPublicId()

パブリックIDを取得します。

返却値
String パブリックID
getSystemId

String getSystemId()

システムIDを取得します。

返却値
String システムID


 DOMEntity オブジェクト

エンティティオブジェクト。

エンティティを示すオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
メソッドの概要
String | getPublicId() パブリックIDを取得します。
String | getSystemId() システムIDを取得します。
メソッドの詳細
getPublicId

String getPublicId()

パブリックIDを取得します。

返却値
String パブリックID
getSystemId

String getSystemId()

システムIDを取得します。

返却値
String システムID


 DOMNode オブジェクト

DOM ツリーのノードオブジェクトです。

DOM ツリーのノードを示すオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
定数の概要
static Number | ATTRIBUTE_NODE 属性ノード（ノード種別）。
static Number | CDATA_SECTION_NODE CDDATAセクションノード（ノード種別）。
static Number | COMMENT_NODE コメントノード（ノード種別）。
static Number | DOCUMENT_FRAGMENT_NODE ドキュメントフラグメントノード（ノード種別）。
static Number | DOCUMENT_NODE ドキュメントノード（ノード種別）。
static Number | DOCUMENT_TYPE_NODE ドキュメントタイプノード（ノード種別）。
static Number | ELEMENT_NODE エレメントノード（ノード種別）。
static Number | ENTITY_NODE エンティティノード（ノード種別）。
static Number | ENTITY_REFERENCE_NODE エンティティリファレンスノード（ノード種別）。
static Number | NOTATION_NODE ノーテーションノード（ノード種別）。
static Number | PROCESSING_INSTRUCTION_NODE PROCESSING INSTRUCTION ノード（ノード種別）。
static Number | TEXT_NODE テキストノード（ノード種別）。
メソッドの概要
Boolean | appendChild(DOMNode newChild) このノードに子ノードを追加します。
DOMNode | cloneNode(Boolean deep) ノードのコピーを作成します。
String | getAttribute(String name) 属性値を取得します。
Array | getAttributes() 属性情報の一覧を取得します。
Array | getChildNodes() 子ノードの一覧を取得します。
String | getName() ノード名を取得します。
Number | getNodeType() ノードの種別を取得します。
DOMNode | getParentNode() 親ノードを取得します。
タグ名 | getTagName() タグ名を取得します。
String | getValue() ノードの値を取得します。
Boolean | hasAttribute(String name) 指定の属性名が存在するかどうか判定します。
Boolean | hasAttributes() このノードが属性を持っているかどうか判定します。
Boolean | hasChildNodes() このノードが子ノードを持っているかどうか判定します。
Boolean | insertBefore(DOMNode newChild ,DOMNode refChild) 新しい子ノードを追加します。
void | normalize() 子ノードを統合します。
void | removeAttribute(String name) 属性を削除します。
Boolean | removeChild(DOMNode oldChild) 子ノードを削除します。
Boolean | replaceChild(DOMNode newChild ,DOMNode oldChild) 子ノードの置き換えます。
void | setAttribute(String name ,String value) 属性を設定します。
定数の詳細
ATTRIBUTE_NODE

static Number ATTRIBUTE_NODE

属性ノード（ノード種別）。
定数値 ： 2
CDATA_SECTION_NODE

static Number CDATA_SECTION_NODE

CDDATAセクションノード（ノード種別）。
定数値 ： 4
COMMENT_NODE

static Number COMMENT_NODE

コメントノード（ノード種別）。
定数値 ： 8
DOCUMENT_FRAGMENT_NODE

static Number DOCUMENT_FRAGMENT_NODE

ドキュメントフラグメントノード（ノード種別）。
定数値 ： 11
DOCUMENT_NODE

static Number DOCUMENT_NODE

ドキュメントノード（ノード種別）。
定数値 ： 9
DOCUMENT_TYPE_NODE

static Number DOCUMENT_TYPE_NODE

ドキュメントタイプノード（ノード種別）。
定数値 ： 10
ELEMENT_NODE

static Number ELEMENT_NODE

エレメントノード（ノード種別）。
定数値 ： 1
ENTITY_NODE

static Number ENTITY_NODE

エンティティノード（ノード種別）。
定数値 ： 6
ENTITY_REFERENCE_NODE

static Number ENTITY_REFERENCE_NODE

エンティティリファレンスノード（ノード種別）。
定数値 ： 5
NOTATION_NODE

static Number NOTATION_NODE

ノーテーションノード（ノード種別）。
定数値 ： 12
PROCESSING_INSTRUCTION_NODE

static Number PROCESSING_INSTRUCTION_NODE

PROCESSING INSTRUCTION ノード（ノード種別）。
定数値 ： 7
TEXT_NODE

static Number TEXT_NODE

テキストノード（ノード種別）。
定数値 ： 3
メソッドの詳細
appendChild

Boolean appendChild(DOMNode newChild)

このノードに子ノードを追加します。

このノードの子供として、子供ノード列の最後に newChild を追加します。
追加する子ノードは、 DOMDocument.createElement() から作成します。
パラメータ
newChild DOMNode 新しいノード
返却値
Boolean ノードの追加に成功した場合 true、そうでない場合 false
cloneNode

DOMNode cloneNode(Boolean deep)

ノードのコピーを作成します。

deep が true の場合、このノードの持つ子供もすべてコピーし、 そうでない場合、このノードのみをコピーします。
パラメータ
deep Boolean コピーレベルを指定する真偽値
返却値
DOMNode コピーによって新しく作成されたノード
getAttribute

String getAttribute(String name)

属性値を取得します。

このノードの属性の中から、name にマップされている値を返します。
name にマップされた値が存在しない場合 null を返します。
また、このノードが属性を持つ要素ではない場合 null を返します。
パラメータ
name String 属性名
返却値
String 属性値
getAttributes

Array getAttributes()

属性情報の一覧を取得します。

このノードが持つすべての属性を配列で返します。
このノードが属性を１つも持たない場合、空の配列が返されます。
返される配列の各要素は、DOMAttribute オブジェクトです。
返却値
Array このノードが持つすべての属性(DOMAttribute)の配列
getChildNodes

Array getChildNodes()

子ノードの一覧を取得します。

このノードが持つすべての子供ノードを配列で返します。
このノードが子供を１つも持たない場合、空の配列が返されます。
返される配列の各要素は、DOMNode オブジェクトです。
返却値
Array このノードが持つすべてのノード(DOMNode)の配列
getName

String getName()

ノード名を取得します。

返却値
String ノード名
getNodeType

Number getNodeType()

ノードの種別を取得します。

返却値
Number ノード種別
getParentNode

DOMNode getParentNode()

親ノードを取得します。

このノードの親にあたるノードを返します。
このノードが親を持たない場合は null を返します。
返却値
DOMNode 親ノード
getTagName

タグ名 getTagName()

タグ名を取得します。

このノードの示すタグ名を返します。
このノードがタグを示す要素でない場合 null を返します。
返却値
タグ名
getValue

String getValue()

ノードの値を取得します。

返却値
String ノードの値
hasAttribute

Boolean hasAttribute(String name)

指定の属性名が存在するかどうか判定します。

このノードが属性を持つ要素ではない場合 false を返します。
パラメータ
name String 属性名
返却値
Boolean true : 存在する / false : 存在しない
hasAttributes

Boolean hasAttributes()

このノードが属性を持っているかどうか判定します。

このノードが１つ以上の属性を持っている場合 true を返します。
返却値
Boolean true : 属性が存在する / false : 属性が存在しない
hasChildNodes

Boolean hasChildNodes()

このノードが子ノードを持っているかどうか判定します。

このノードが１つ以上の子供ノードを持っている場合 true を返します。
返却値
Boolean true : 子ノードが存在する / false : 子ノードが存在しない
insertBefore

Boolean insertBefore(DOMNode newChild ,DOMNode refChild)

新しい子ノードを追加します。

このノードの子供ノード refChild の位置に、新しいノード newChild を追加します。
追加する子ノードは、 DOMDocument.createElement() から作成します。
パラメータ
newChild | DOMNode | 新しく追加するノード
refChild | DOMNode | 追加すべきノードの位置
返却値
Boolean ノードの追加に成功した場合 true、そうでない場合 false
normalize

void normalize()

子ノードを統合します。

このノードの持つ子供ノードのうち隣接しているテキストノード同士を統合します。 このメソッド実行後は、テキストノードと他のテキストノードが隣り合った状態はなくなります。
返却値
void
removeAttribute

void removeAttribute(String name)

属性を削除します。

このノードのnameで指定された属性を削除します。
パラメータ
name String 属性名
返却値
void
removeChild

Boolean removeChild(DOMNode oldChild)

子ノードを削除します。

このノードのoldChildで指定された子ノードを削除します。
パラメータ
oldChild DOMNode 削除する子ノード
返却値
Boolean true : 削除成功 / false : 削除失敗
replaceChild

Boolean replaceChild(DOMNode newChild ,DOMNode oldChild)

子ノードの置き換えます。

このノードの子供の中から oldChile を削除して、oldChild の保存されていた位置に newChild を挿入します。
パラメータ
newChild | DOMNode | 新しく追加するノード
oldChild | DOMNode | 追加するノードの位置
返却値
Boolean ノードの置換に成功した場合 true、そうでない場合 false
setAttribute

void setAttribute(String name ,String value)

属性を設定します。

このノードに属性を設定します。
パラメータ
name | String | 属性名
value | String | 属性値
返却値
void


 DOMNotation オブジェクト

ノーテーションオブジェクト。

ノーテーションを示すオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
メソッドの概要
String | getPublicId() パブリックIDを取得します。
String | getSystemId() システムIDを取得します。
メソッドの詳細
getPublicId

String getPublicId()

パブリックIDを取得します。

返却値
String パブリックID
getSystemId

String getSystemId()

システムIDを取得します。

返却値
String システムID


 ExtendsImportManager オブジェクト

拡張インポートマネージャクラス。

拡張インポート処理を実行するマネージャクラスです。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static Boolean doImport(String groupId ,String module)
拡張インポート処理を実行します。
メソッドの詳細
doImport

static Boolean doImport(String groupId ,String module)

拡張インポート処理を実行します。

引数moduleには、クラスまたはJSのパスを指定できます。
クラスを指定する場合は、ExtendsImportを継承したクラスのフルパッケージ名を指定してください。

JSのパスを指定する場合は、指定するJSファイルに記述されている"doImport""関数をコールします。
"doImport""関数の第一引数にログイングループIDを引き渡します。
パスの指定は、pagesからの相対パスで、最後に".js"を含んだものである必要があります。
例：
function doImport(group){
......

}
パラメータ
groupId | String | ログイングループID
module | String | 拡張インポート処理を行うクラス名またはJSのパス
返却値
Boolean true : 成功 / false : 失敗


 File オブジェクト

ファイル操作オブジェクト。

Application Runtime 環境のファイルを操作するＡＰＩを持つオブジェクトです。
このＡＰＩは、Application Runtime の動作しているマシンを対象としてファイル操作を行いますので、Application Runtime を分散構築にて複数のコンピュータで運用しているしている場合には、ファイルを共有する事ができません。
各リクエスト、また各クライアント、また各プログラム間で、ファイルおよびディレクトリ名が重複しないように工夫する必要があります。
バージョン：1.0
導入されたバージョン：2.0
コンストラクタの概要
File(String path)
コンストラクタ。
File(String parent ,String child)
コンストラクタ。
メソッドの概要
Boolean | append(String strm) テキストのファイルへ追記を行います。
Array | directories() ディレクトリ一覧を取得します。
Boolean | exist() ファイル(ディレクトリ)の存在確認を行います。
Array | files() ファイル一覧を取得します。
Boolean | isDirectory() ディレクトリの存在確認を行います。
Boolean | isFile() ファイルの存在確認を行います。
Number | lastModified() ファイルの最終更新日付を取得します。
String | load() ファイルの内容を取得します。
Boolean | makeDirectories() ディレクトリを作成します。
Boolean | move(String newFile) ファイル名を変更します。
String | path() パス名を取得します。
String | read() テキストファイル内容を取得します。
Boolean | remove() ファイルまたはディレクトリを削除します。
Boolean | save(String strm) ファイルへのデータ出力を行います。
Number | size() ファイルサイズを取得します。
Boolean | write(String strm) テキストファイルの出力を行います。
コンストラクタの詳細
File

File(String path)
コンストラクタ。

指定のパスに対するファイル(ディレクトリ)操作を行うためのインスタンスを生成します。
このコンストラクタで生成されたインスタンスが、実際に操作する対象は、Application Runtime が動作している環境のファイルになります。
パスが相対パス形式で指定された場合、このコンストラクタは Application Runtime をインストールしたディレクトリ内にある work/ ディレクトリを親として絶対パスを解決します。
パラメータ
path String ファイルパス
File

File(String parent ,String child)
コンストラクタ。

指定のパスに対するファイル(ディレクトリ)操作を行うためのインスタンスを生成します。
実際にアクセスするファイルは、parent + child が表すファイルまたはディレクトリになります。
このコンストラクタで生成されたインスタンスが、実際に操作する対象は、Application Runtime が動作している環境のファイルになります。
パラメータ
parent | String | 親ディレクトリパス
child | String | ファイルパス
メソッドの詳細
append

Boolean append(String strm)

テキストのファイルへ追記を行います。

ファイルに対して指定のテキストデータを追記します。
引数 strm へは Unicode 体系のテキストデータを渡して下さい。
ファイルへの出力時に、Application Runtime の サーバ文字エンコーディング設定で解決される文字コードへ変換をしてファイルに出力します。
ファイルが存在しない場合には、新規にファイルを作成してデータ出力を行います。
パラメータ
strm String テキストデータ
返却値
Boolean true : 成功 / false : 失敗
directories

Array directories()

ディレクトリ一覧を取得します。

コンストラクタで指定されたディレクトリ・パスに含まれる全てのディレクトリ名称を返却します。
コンストラクタで指定されたパスが存在するディレクトリではなかった場合の動作は保証されません。
返却値
Array ディレクトリ一覧（配列型）
exist

Boolean exist()

ファイル(ディレクトリ)の存在確認を行います。

コンストラクタで指定されたパスが存在しているかどうかをチェックした結果を返却します。
返却値
Boolean true : 存在する / false : 存在しない
files

Array files()

ファイル一覧を取得します。

コンストラクタで指定されたディレクトリ・パスに含まれる全てのファイル名称を返却します。
コンストラクタで指定されたパスが存在するディレクトリではなかった場合の動作は保証されません。
返却値
Array ファイル一覧（配列型）
isDirectory

Boolean isDirectory()

ディレクトリの存在確認を行います。

コンストラクタで指定されたパスがディレクトリとして存在しているかどうかをチェックした結果を返却します。
返却値
Boolean true : 存在する / false : 存在しない
isFile

Boolean isFile()

ファイルの存在確認を行います。

コンストラクタで指定されたパスがファイルとして存在しているかどうかをチェックした結果を返却します。
返却値
Boolean true : 存在する / false : 存在しない
lastModified

Number lastModified()

ファイルの最終更新日付を取得します。

コンストラクタで指定されたパスの最終更新時刻を返却します。
返却値は、1970/01/01からのミリ秒で返す。
返却値
Number 最終更新日付（ミリ秒）
load

String load()

ファイルの内容を取得します。

コンストラクタで指定されたファイル内のデータをストリームとして返します。
ファイルの内容はバイナリとして扱われます。
返却値
String ファイルの内容
makeDirectories

Boolean makeDirectories()

ディレクトリを作成します。

コンストラクタで指定されたパスをディレクトリとして新規作成します。
存在していないが必要な親ディレクトリも一緒に作成されます。
このオペレーションが失敗した場合でも、いくつかの必要な親ディレクトリの作成には成功した場合があります。
返却値
Boolean true : 成功 / false : 失敗
move

Boolean move(String newFile)

ファイル名を変更します。

コンストラクタで指定されたパスを引数 newPath に変更します。
引数 newFile には、File ＡＰＩのインスタンスを渡して下さい。
パラメータ
newFile String 新しいパス名
返却値
Boolean true : 成功 / false : 失敗
path

String path()

パス名を取得します。

このインスタンスの示すパス名を返却します。
返却値
String パス名
read

String read()

テキストファイル内容を取得します。

このインスタンスの示すファイルの内容を返却します。
ファイルデータはテキストとして扱われます。
ファイルデータは、読込後、自動的に Unicode に変換されます。
返却値
String ファイルの内容
remove

Boolean remove()

ファイルまたはディレクトリを削除します。

このインスタンスの示すパスを削除します。
返却値
Boolean true : 成功 / false : 失敗
save

Boolean save(String strm)

ファイルへのデータ出力を行います。

このインスタンスの示すファイル・パスに対して引数に指定されたデータを書き出します。
データはバイナリとして扱われます。
パラメータ
strm String データ
返却値
Boolean true : 成功 / false : 失敗
size

Number size()

ファイルサイズを取得します。

このインスタンスの示すファイル・パスのファイルの大きさを返却します。
返却値の単位は、バイトです。
このインスタンスの示すファイルパスが存在しない場合の動作は未定義です。
返却値
Number ファイルサイズ(バイト数)
write

Boolean write(String strm)

テキストファイルの出力を行います。

このインスタンスの示すファイル・パスに対して引数に指定されたデータを書き出します。
データはテキストとして扱われます。
引数 strm には Unicode のデータを渡して下さい。
ファイルに対して出力する際には、自動的にサーバ文字エンコーディング設定の文字コードに変換されます。
パラメータ
strm String テキストデータ
返却値
Boolean true : 成功 / false : 失敗


 Format オブジェクト

文字列変換オブジェクト。

文字列変換を行うＡＰＩを持つオブジェクトです。

使用例:
ファンクション・コンテナ

var objFormat = new Object();

objFormat.testS =
 Format.get("文字列の変換を「%4s」行います。","intra-mart");
objFormat.testN = Format.get("数値データを４進数に変換「%4n」します。",20);
objFormat.testD =
 Format.get("数値データを１０進数に変換「%7.3d」します。",1234567.89123);
objFormat.testX = Format.get("数値データを１６進数に変換「%3x」します。",55);
objFormat.testB = Format.get("数値データを２進数に変換「%4b」します。",12);
objFormat.testM =
 Format.get("数値データを３桁カンマ区切り数字列に変換「%m」します。",333444555666);
objFormat.testT = Format.get("今日の日付を日付文字列（フォーマット固定）に変換「%t」します。",new
 Date());
objFormat.test = Format.get("％文字を表示「%%」します。");

2001年2月13日というデータを表示する場合、月のデータは0 - 11で表現される(1月=0)ため、(月-1)したデータを new Date
 関数の第2引数に指定する。

objFormat.testDate = Format.fromDate("yyyy/MM/dd", new Date(2001,1,
 13));

Debug.browse(objFormat);
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static String | fromDate(String format ,Date date) フォーマット指定に沿った形に日付を文字列に変換します。
static String | fromNumber(String format ,Number value) フォーマット指定に沿った形に数値を文字列に変換します。
static String | get(String format ,Object arg [,... ...]) 引数値をformatにあわせて文字列に変換します。
static String | toMoney(Number value) ３桁ずつのカンマ区切り数字列を生成します。
メソッドの詳細
fromDate

static String fromDate(String format ,Date date)

フォーマット指定に沿った形に日付を文字列に変換します。

フォーマット指定文字
記号 | 意味
y | 年
M | 月
d | 日
h | 午前/午後の時 (1 - 12)
H | 一日における時 (0 - 23)
k | 一日における時 (1 - 24)
m | 分
s | 秒
S | ミリ秒
a | 午前/午後
E | 曜日
' テキスト用エスケープ
'' 単一引用符
パラメータ
format | String | フォーマット指定文字列
date | Date | 日付データ
返却値
String 変換後の文字列
fromNumber

static String fromNumber(String format ,Number value)

フォーマット指定に沿った形に数値を文字列に変換します。

フォーマット指定文字
0 - 数字
# - 数字。ゼロだと表示されない
. - 数値桁区切り文字の位置
, - グループ区切り文字位置
パラメータ
format | String | フォーマット指定文字列
value | Number | 数値データ
返却値
String 変換後の文字列
get

static String get(String format ,Object arg [,... ...])

引数値をformatにあわせて文字列に変換します。

フォーマット指定文字
%s → 文字列の変換 (%3s で後方３バイトのみ変換、指定文字列が３バイトより短い場合、前方に空白を追加)
%n → 数値変換 (%4n で４進数に変換)
%d → 10進数変換 (%8.3d で整数8桁＆小数＆桁変換)
%x → 16進数変換 (%4x で４桁 "0" マスク変換)
%b → 2進数変換 (%8b で８桁 "0" マスク変換)
%m → 数値まはた数字の３桁カンマ区切り数字列への変換
%t → DATE変数変換
%% → "%" 文字へ変換
パラメータ
format | String | フォーマット指定文字列
arg | Object | データ
... ... 複数指定する場合は、カンマの後に続けて指定します。(データは16個までです)
返却値
String 変換後の文字列
toMoney

static String toMoney(Number value)

３桁ずつのカンマ区切り数字列を生成します。

少数部分の値は２桁までの表示となります。
パラメータ
value Number 数値データ
返却値
String 変換された文字列


 グローバル関数

グローバル関数。

バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
Object | duplicate(Object object) 推奨されていません。代替えメソッドはありません。
void | echo(String message) メッセージをシステム出力に出力します。
Object | execute(String command) システムコールを行います。
void | forward(String prgram_name ,Object argument) 現在のプログラム実行を中断して別プログラムを実行します。
void | garbageCollector() ガーベージコレクションの実行を行います。
Object | include(String path [,... ...]) JSファイルをロードして実行します。
Boolean | isArray(Object object) 指定の値の型が配列型であるかどうか判別します。
Boolean | isBlank(Object object) 空文字列であるか判別します。
Boolean | isBoolean(Object object) 指定の値の型が真偽値型であるかどうか判別します。
Boolean | isDate(Object object) 指定の値の型がDate型であるかどうか判別します。
Boolean | isEqual(Object value_a ,Object value_b) 引数に指定された２つの値が等しいかどうか判別します。
Boolean | isFalse(Object object) 指定の値が偽値であるかどうか判別します。
Boolean | isFunction(Object object) 指定の値の型が関数型であるかどうか判別します。
Boolean | isNull(Object object) 指定の値が null であるかどうか判別します。
Boolean | isNumber(Object object) 指定の値の型が数値型であるかどうか判別します。
Boolean | isObject(Object object) 指定の値の型がObject型であるかどうか判別します。
Boolean | isString(Object object) 指定の値の型が文字列型であるかどうか判別します。
Boolean | isTrue(Object object) 指定の値が真値であるかどうか判別します。
Boolean | isUndefined(Object object) 指定の値が undefined であるかどうか判別します。
String | mdv(String value) 文字列の暗号化を行います。
void | redirect(String url) 指定ＵＲＬへリダイレクトを行います。
void | secureRedirect(String url ,Object args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
void | transmission(String stream) 現在処理中のプログラム実行を中断して、指定のソースを送信します。
メソッドの詳細
duplicate

Object duplicate(Object object)

推奨されていません。代替えメソッドはありません。
オブジェクトのコピーを作成します。

引数のオブジェクトのコピーを生成して返却します。
ただし、prototype オブジェクトや、変数の持つスコープ情報など、
一部の情報に関しては完全には引き継がれない場合があります。
パラメータ
object Object コピーを作成するオブジェクト。
返却値
Object 引数のオブジェクトのコピー
echo

void echo(String message)

メッセージをシステム出力に出力します。

与えられたメッセージ message をシステム出力に出力します。
初期設定では、システムログと標準出力に出力されます。
メッセージの出力先に関しては、システムログの設定に依存します。
パラメータ
message String 出力するメッセージ
返却値
void
execute

Object execute(String command)

システムコールを行います。

指定された文字列 command を、コマンド・プロセッサによって実行されるホスト環境へ渡して、独立した新しいプロセスとして実行します。
この関数は、実行したプロセスが終了するまで待機状態になります。
返却値はオブジェクト型で以下の形式になります。

・実行したプロセスが正常終了した場合

          return_object
              ├ output // プロセスからの標準出力ストリーム(String)
              ├ error // プロセスからのエラー出力ストリーム(String)
              └ exit // プロセスの終了コード

・実行したプロセスが正常終了しなかった場合

          return_object
              ├ error // エラー内容(String)
              └ exit // プロセスの終了コード

・プロセス実行時にランタイム内でエラーが発生した場合

          return_object
              └ exception // エラー内容(String)
プロセスの終了コードは、0 の場合正常終了となります。
上記は一例です。環境により上記プロパティの組合わせが異なる場合があります。
パラメータ
command String 実行するシステムコマンド
返却値
Object 結果オブジェクト
forward

void forward(String prgram_name ,Object argument)

現在のプログラム実行を中断して別プログラムを実行します。

現在処理中のプログラム実行を中断して、別プログラムの実行を開始します。
第２引数 argument に渡された値は、リダイレクト実行先ファンクションコンテナ内 init() 関数の引数になります。
実行先プログラムの init() 関数に渡す引数データとして argument に対して request オブジェクトを指定した場合、実行先プログラムの思わぬ誤動作をすることがあります。
request オブジェクトを引数としてプログラムを呼び出す場合は、動作の仕組を十分に考慮してプログラムする必要があります。
パラメータ
prgram_name | String | リダイレクト先ＵＲＬ
argument | Object | 引数オブジェクト
返却値
void
garbageCollector

void garbageCollector()

ガーベージコレクションの実行を行います。

返却値
void
include

Object include(String path [,... ...])

JSファイルをロードして実行します。

JSファイルをロードして、その中に定義されている init() 関数を実行目的のプログラム内の init() 関数には引数として arg_1[, ..., arg_n]が渡されます。
パラメータ
path String ロードするＪＳファイルパス(拡張子なし)
... ... JSファイルの init() 関数へ渡す引数群
複数ある場合は、カンマ区切りで続けて設定します。
返却値
Object 指定したJSファイルの init() 関数の返却値
isArray

Boolean isArray(Object object)

指定の値の型が配列型であるかどうか判別します。

指定値の型が配列型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
配列型 | : true
上記以外 | : false
isBlank

Boolean isBlank(Object object)

空文字列であるか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
空文字列 | : true
null | : true
false | : true
true | : false
undefined | : true
上記以外 | : false
isBoolean

Boolean isBoolean(Object object)

指定の値の型が真偽値型であるかどうか判別します。

指定値の型が真偽値型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
真偽値型 | : true
上記以外 | : false
isDate

Boolean isDate(Object object)

指定の値の型がDate型であるかどうか判別します。

指定値の型がDate型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
Date型 | : true
上記以外 | : false
isEqual

Boolean isEqual(Object value_a ,Object value_b)

引数に指定された２つの値が等しいかどうか判別します。

指定の値の内部構造の等価判定をした結果を返却します。
参照判定ではないので、別インスタンス同志の値の比較が可能です。
パラメータ
value_a | Object | 等価判定対象の値
value_b | Object | 等価判定対象の値
返却値
Boolean 判別結果
等しい | : true
上記以外 | : false
isFalse

Boolean isFalse(Object object)

指定の値が偽値であるかどうか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
真偽値型であり false | : true
上記以外 | : false
isFunction

Boolean isFunction(Object object)

指定の値の型が関数型であるかどうか判別します。

指定値の型が関数型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
関数型 | : true
上記以外 | : false
isNull

Boolean isNull(Object object)

指定の値が null であるかどうか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
null | : true
上記以外 | : false
isNumber

Boolean isNumber(Object object)

指定の値の型が数値型であるかどうか判別します。

指定値の型が数値型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
数値型 | : true
上記以外 | : false
isObject

Boolean isObject(Object object)

指定の値の型がObject型であるかどうか判別します。

指定値が null ではなく、指定値の型が Object 型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
Object 型 | : true
上記以外 | : false
isString

Boolean isString(Object object)

指定の値の型が文字列型であるかどうか判別します。

指定値の型が文字列型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
文字列型 | : true
上記以外 | : false
isTrue

Boolean isTrue(Object object)

指定の値が真値であるかどうか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
真偽値型であり true | : true
上記以外 | : false
isUndefined

Boolean isUndefined(Object object)

指定の値が undefined であるかどうか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
undefined | : true
上記以外 | : false
mdv

String mdv(String value)

文字列の暗号化を行います。

引数に指定された文字列データを MD5 により暗号化します。
暗号化対象データ内に ASCII 以外の文字を含む場合には、ローカルの文字コード体系に変換したものを引数に指定してください。
パラメータ
value String 暗号化対象文字列
返却値
String 暗号化された文字列
redirect

void redirect(String url)

指定ＵＲＬへリダイレクトを行います。

パラメータ
url String リダイレクト先ＵＲＬ
返却値
void
secureRedirect

void secureRedirect(String url ,Object args)

呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

外部のURLの場合は、プロトコルから指定します。

内部のURLの場合は以下の通りです。
ページベースのパスにリダイレクトする場合は、最後に拡張子".jssp"が必要です。
その他のパスにダイレクトする場合は、コンテキストパスからの相対URLとなります。
パラメータ
url | String | リダイレクト先ＵＲＬ
args | Object | リダイレクト引数
返却値
void
transmission

void transmission(String stream)

現在処理中のプログラム実行を中断して、指定のソースを送信します。

指定されたソースは、バイナリデータ（指定されたまま）として扱われます（SYSTEM_CLIENT_CHARSET への文字コード変換はおこりません）。
送信ソースには、ＨＴＴＰレスポンスヘッダを含める必要があります。
(このＡＰＩを利用した場合、ランタイムは指定ソースに対する一切の情報操作をおこないません。)
ＨＴＴＰレスポンスヘッダの作成法法に関しては、一般的なＣＧＩプログラムの作成方法を参考にして下さい。
このＡＰＩにより送信されたソースは、セッション管理対象外となります。
request オブジェクトを引数としてプログラムを呼び出す場合は、動作の仕組を十分に考慮してプログラムする必要があります。
パラメータ
stream String ブラウザへの送信ソース
返却値
void


 HTTPResponse オブジェクト

HTTPレスポンスオブジェクト。

クライアントへ応答を送信する際の処理を支援するオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
void | sendMessageBody(String strm) 指定のデータを送信します。
void | sendMessageBodyString(String str) 指定のデータを送信します。
void | setContentLength(Number len) レスポンスのメッセージボディ部分の長さをセットします。
void | setContentType(String type) レスポンスの Content-Type を設定します。
void | setHeader(String name ,String value) 指定された名前と値を持つレスポンスヘッダを設定します このヘッダが既に設定されている場合は上書きされます。
メソッドの詳細
sendMessageBody

void sendMessageBody(String strm)

指定のデータを送信します。
JavaScript の現在の実行は中断します。再開する事はありません。
パラメータ
strm String 送信データ
返却値
void
sendMessageBodyString

void sendMessageBodyString(String str)

指定のデータを送信します。
JavaScript の現在の実行は中断します。再開する事はありません。
送信データは文字列として扱われ、ServletResponse#getWriter() が 返す Writer によって出力されます。したがって、文字コードは自動的に 自動的に変換されます。
パラメータ
str String 送信データ
返却値
void
setContentLength

void setContentLength(Number len)

レスポンスのメッセージボディ部分の長さをセットします。
HTTP Servlet ではこのメソッドは HTTP ヘッダの
Content-Length フィールドにセットします。
パラメータ
len Number クライアントに送り返すメッセージボディの長さを指定する整数値。 HTTP の Content-Length ヘッダフィールドの値
返却値
void
setContentType

void setContentType(String type)

レスポンスの Content-Type を設定します。
パラメータ
type String コンテントタイプを指定する String
返却値
void
setHeader

void setHeader(String name ,String value)

指定された名前と値を持つレスポンスヘッダを設定します
このヘッダが既に設定されている場合は上書きされます。
パラメータ
name | String | ヘッダの名称
value | String | ヘッダの値
返却値
void


 Identifier オブジェクト

ユニークなＩＤを自動生成するオブジェクト。

ユニークなＩＤを自動生成するＡＰＩを持つオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static String get()
ユニークなIDを作成します。
メソッドの詳細
get

static String get()

ユニークなIDを作成します。

ユニークＩＤを生成して返却します。
生成されるＩＤは 15 [byte] 文字列です。
生成されるＩＤは、時間に対してユニークです。
生成されるＩＤは、１つのシステムに対してユニークです。
返却値
String ユニークなID


 Imart オブジェクト

IMARTタグ管理オブジェクト。

プレゼンテーション・ページと連携するためのＡＰＩを持つオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static InnerText | compile(String src) ＨＴＭＬソースのコンパイルを行います。
static void | defineAttribute(String name ,Object value) <IMART> タグ内の属性値に対する定数を定義します。
static void | defineType(String name ,Function func) <IMART> タグの実行関数を定義します。
static String | execute(String name ,Object oAttr ,InnerText oInner) 推奨されていません。代替えのメソッドはありません。
static Boolean | isType(String name) <IMART> タグ定義の存在チェックを行います。
メソッドの詳細
compile

static InnerText compile(String src)

ＨＴＭＬソースのコンパイルを行います。

引数のＨＴＭＬソース文字列を解析してコンパイルします。
返却値は InnerText のインスタンスです。これは、ＨＴＭＬ生成のための実行可能オブジェクトです。
この InnerTextのインスタンスでは、InnerText.execute() メソッドを実行する事により、解析された <IMART> が順次実行されます。
InnerText.execute() メソッドの実行結果として、生成されたＨＴＭＬソースが文字列として返されます。
引数に文字列以外の値を指定した場合の動作は保証外です。
パラメータ
src String 解析対象ＨＴＭＬソース
返却値
InnerText 実行可能オブジェクト
defineAttribute

static void defineAttribute(String name ,Object value)

<IMART> タグ内の属性値に対する定数を定義します。

<IMART> タグ内で使用される属性値に対する定数定義をします。
<IMART> タグ内で宣言される各属性に対する属性値のうち、ダブルクォートで囲まれている定数値に対して適応されます。
<IMART> タグ内で宣言されたダブルクォートで囲まれた定数属性値が定義名称と一致する場合、実行時に自動的に実行時値が適応されます。
パラメータ
name | String | 定義名称
value | Object | 実行時値
返却値
void
defineType

static void defineType(String name ,Function func)

<IMART> タグの実行関数を定義します。

引数 name で指定した定義名称が <IMART> タグの type 属性での指定名称になります。
第２引数には、<IMART> タグの type 属性により定義名称でコールされた際に実行する関数を指定します。
関数内では、実行時に２つの引数を取ります。

function my_tag(oAttr, oInner){ ... }

実行関数内の第１引数 oAttr は、<IMART> タグにより指定された引数群になります。
第２引数 oInner は、<IMART> と </IMART> に挟まれた内部ソース（実行オブジェクト形式）になります。
引数が不適切であった場合の動作は保証外です。
パラメータ
name | String | 定義名称
func | Function | 実行関数
返却値
void
execute

static String execute(String name ,Object oAttr ,InnerText oInner)

推奨されていません。代替えのメソッドはありません。
任意の <IMART> タグ定義関数を実行します。

現在定義されている <IMART> タグの任意の定義関数を実行します。
第１引数 name には、<IMART> タグの type 属性に定義されている定義名称を指定します。
第２引数 oAttr は、そのタグ関数の実行に必要なタグ引数をオブジェクトの形式で渡します。
タグ引数オブジェクトは、タグ属性名をプロパティ名として、対応する属性値をプロパティ値としたオブジェクトです。
第３引数 oInner は、<IMART> および </IMART> に挟まれた部分の実行可能オブジェクトになります。
パラメータ
name | String | <IMART> タグ定義名称
oAttr | Object | タグ引数
oInner | InnerText | 実行可能オブジェクト
返却値
String 実行結果ＨＴＭＬソース
isType

static Boolean isType(String name)

<IMART> タグ定義の存在チェックを行います。

指定の定義名称が <IMART> タグの type 属性に定義されているかどうかを判定します。
（Imart.defineType()を利用して定義された <IMART> タグを判定対象とします）
指定の定義名称が <IMART> タグの type 属性に対して定義済みである場合、その定義名称で <IMART> を利用可能である事を示します。
パラメータ
name String 定義名称
返却値
Boolean true : 存在する / false : 存在しない


 InnerText オブジェクト

IMARTタグ引数情報オブジェクト。

タグ関数の引数に渡されるオブジェクトです。
拡張 <IMART> タグ用の関数を定義した時に、関数の第２引数として実行エンジンから実行時に受け取るオブジェクトで、<IMART> タグおよび対応する </IMART> タグに挟まれた範囲のスクリプト情報を保持しています。
このオブジェクトにより、タグに挟まれた範囲のスクリプトを実行する事が出来ます(タグのネストを有効にすることができます)。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
String execute()
オブジェクトの実行を行います。
メソッドの詳細
execute

String execute()

オブジェクトの実行を行います。

このオブジェクトの示すスクリプトを実行します。
スクリプト中に <IMART> タグの記述があった場合、これを順次実行します。
すべての実行が終了した結果のソースを文字列として返します。
返却値
String 実行結果のソース


JavaScript API リスト概要

 JavaScript API リスト 概要

ページベース開発モデルで利用可能なJavaScript API の概要です。

グローバル関数の概要
グローバル関数 グローバル関数。

オブジェクトの概要
AccessSecurityManager | セキュリティマネージャオブジェクト。
AccountManager | アカウントマネージャオブジェクト アカウント情報の参照、更新を行うマネージャオブジェクトです。
AdminMenuManager | 管理メニューマネージャクラス。
ApplicationInfo | アプリケーション情報オブジェクト。
BatchManager | バッチマネージャオブジェクト。
BatchServer | バッチサーバーオブジェクト。
CSVParser | CSV解析オブジェクト。
CalendarManager | カレンダーマネージャオブジェクト。
CategoryManager | CategoryManagerオブジェクト。
Client | セッション情報を取得するオブジェクト。
CompanyManager | CompanyManagerオブジェクト。
Constant | 定数値管理オブジェクト。
Content | コンテンツクラス。
DOMAttribute | ノードの属性オブジェクト。
DOMDocument | XML 文書全体を表す DOM Document オブジェクト。
DOMDocumentType | ドキュメントタイプオブジェクト。
DOMEntity | エンティティオブジェクト。
DOMNode | DOM ツリーのノードオブジェクトです。
DOMNotation | ノーテーションオブジェクト。
DatabaseManager | データベースマネージャ。
DatabaseResult | データベースアクセス結果オブジェクト。
DbParameter | SQLパラメータオブジェクト。
DbStoredProcArg | ストアドプロシージャ、ファンクション引数オブジェクト。
Debug | デバッグ情報を表示するオブジェクト。
Drawer | 画像描画オブジェクト。
ExtendsImportManager | 拡張インポートマネージャクラス。
File | ファイル操作オブジェクト。
Format | 文字列変換オブジェクト。
HTTPResponse | HTTPレスポンスオブジェクト。
Identifier | ユニークなＩＤを自動生成するオブジェクト。
Imart | IMARTタグ管理オブジェクト。
InnerText | IMARTタグ引数情報オブジェクト。
LicenseManager | ライセンスマネージャクラス。
Lock | アプリケーション・ロック管理オブジェクト。
LoginGroupManager | ログイングループマネージャオブジェクト。
MailSender | メールを送信するオブジェクトです。
MenuManager | メニューマネージャオブジェクト。
MessageManager | メッセージマネージャオブジェクト。
Permanent | 永続情報操作オブジェクト。
PermissionManager | パーミッションマネージャクラス。
PrivateGroupManager | PrivateGroupManagerオブジェクト。
Procedure | プロシージャクラス。
PublicGroupManager | PublicGroupManagerオブジェクト。
RCV | RC-5 暗号・復号化オブジェクト。
Request | リクエストオブジェクト。
RequestParameter | リクエストパラメータ情報オブジェクト。
RoleManager | ロールマネージャオブジェクト。
SecurityConst | アクセスセキュリティ定数オブジェクト。
System | システムマネージャオブジェクト。
TermManager | TermManagerオブジェクト 期間に関する情報を扱うマネージャオブジェクトです。
URL | URL操作クラス。
Unicode | Unicodeクラス。
UserManager | UserManagerオブジェクト。
VirtualFile | VirtualFile操作クラス。
Web | Webクラス。
XMLDocument | XMLを解析するパーサーオブジェクト。
XMLParser | XMLを解析するパーサーオブジェクト。
Batch | 推奨されません。BatchManagerに置き替えられました。
Category | 推奨されません。CategoryManagerに置き換えられました。
DataForAccount | 推奨されません。代替えのオブジェクトはありません。
DataForDatabase | 推奨されません。DatabaseResultに置き換えられました。
DataForRole | 推奨されません。代替えのオブジェクトはありません。
DataForStoredProc | 推奨されません。DatabaseResultに置き換えられました。
DbResultObject | 推奨されません。DatabaseResultに置き換えられました。
Mail | 推奨されません。MailSenderに置き換えられました。
Profile | 推奨されません。UserManagerに置き換えられました。

Moduleオブジェクトの概要
Module.alert | 警告画面オブジェクト 警告画面を表示します。
Module.array | 配列データを扱うためのオブジェクト。
Module.calendar | 日本の元号を扱うオブジェクト。
Module.client | ログインしているカレント・ユーザー情報に関するオブジェクト。
Module.data | JavaScript の各種データを扱うオブジェクト。
Module.date | 日付データの日情報に対して指定増分を加算するオブジェクト。
Module.download | データのダウンロード機能を提供するオブジェクト。
Module.external | 各リクエスト間、各クライアント間、および各サーバ間で共有の値を操作するオブジェクト。
Module.formatfile | データをフォーマットされた形式のファイルとして出力するオブジェクト。
Module.ldap | LDAPサーバにアクセスするオブジェクト。
Module.mailpool | メール・プール機能を提供するオブジェクト。
Module.mobile | モバイル用画面開発時に必要になる各種機能を提供するオブジェクト。
Module.number | 数値データを扱うメソッドを提供するオブジェクト。
Module.string | 文字列データを扱うメソッドを提供するオブジェクト。
Module.access | 推奨されません。アクセスセキュリティの各Managerオブジェクトのメソッドに置き換えられました。
Module.almanac | 推奨されません。CalendarManagerに置き換えられました。
Module.database | 推奨されません。DatabaseManagerに置き換えられました。
Module.grouping | 推奨されません。CompnanyManager,PublicGroupManager,PrivateGroupManagerに置き換えられました。
Module.logingp | 推奨されません。LoginGroupManagerに置き換えられました。
Module.message | 推奨されません。MessageManagerに置き換えられました。

Procedureオブジェクトの概要
Procedure.AppCommonUtil | アプリケーション共通マスタで使用する共通関数です。
Procedure.RealNumber | 推奨されません。代替オブジェクトはありません。
Procedure.age | 推奨されません。代替オブジェクトはありません。
Procedure.imode | 推奨されません。代替オブジェクトはありません。
Procedure.upload | 推奨されません。代替のオブジェクトはありません。


JavaScript API リスト

グローバル関数
オブジェクト
AccessSecurityManager
AccountManager
AdminMenuManager
ApplicationInfo
BatchManager
BatchServer
CSVParser
CalendarManager
CategoryManager
Client
CompanyManager
Constant
Content
DOMAttribute
DOMDocument
DOMDocumentType
DOMEntity
DOMNode
DOMNotation
DatabaseManager
DatabaseResult
DbParameter
DbStoredProcArg
Debug
Drawer
ExtendsImportManager
File
Format
HTTPResponse
Identifier
Imart
InnerText
LicenseManager
Lock
LoginGroupManager
MailSender
MenuManager
MessageManager
Permanent
PermissionManager
PrivateGroupManager
Procedure
PublicGroupManager
RCV
Request
RequestParameter
RoleManager
SecurityConst
System
TermManager
URL
Unicode
UserManager
VirtualFile
Web
XMLDocument
XMLParser

Batch 非推奨
Category 非推奨
DataForAccount 非推奨
DataForDatabase 非推奨
DataForRole 非推奨
DataForStoredProc 非推奨
DbResultObject 非推奨
Mail 非推奨
Profile 非推奨
Moduleオブジェクト
Module.alert
Module.array
Module.calendar
Module.client
Module.data
Module.date
Module.download
Module.external
Module.formatfile
Module.ldap
Module.mailpool
Module.mobile
Module.number
Module.string

Module.access 非推奨
Module.almanac 非推奨
Module.database 非推奨
Module.grouping 非推奨
Module.logingp 非推奨
Module.message 非推奨
Procedureオブジェクト
Procedure.AppCommonUtil

Procedure.RealNumber 非推奨
Procedure.age 非推奨
Procedure.imode 非推奨
Procedure.upload 非推奨


 LicenseManager オブジェクト

ライセンスマネージャクラス。

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
LicenseManager(String groupId)
コンストラクタ。
メソッドの概要
boolean | deleteAccountLicense(String userId) 指定されたユーザのライセンスを削除する。
boolean | deleteApplicationLicenseFromAccount(String userId ,String applicationId) アプリケーションライセンスをアカウントから削除する。
static ApplicationInfo | getApplication(String applicaionId) アプリケーション情報を取得します。
static Number | getApplicationLicense(String applicaionId) アプリケーションの登録ユーザ数を取得します。
static Array | getApplications() アプリケーション情報の一覧を取得する。
double | getLicense() グループ内で登録されているライセンス数を取得する。
double | getMaxLicense() ログイングループ内の最大登録可能ライセンス数を取得します。
static ApplicationInfo | getProduct() システム情報を取得します。
Array | getRegisteredAccountLicenses() ログイングループにライセンス登録されているすべてのユーザIDを返します。
Array | getRegisteredApplicationLicensesToAccount(String userId) アカウントに登録されているアプリケーションライセンスの一覧を取得する。
static double | getSystemLicense() システム全体の登録ライセンス数。
static double | getSystemMaxLicense() システム全体のライセンス数。
Boolean | isRegisteredAccountLicense(String userId) 指定されたユーザがライセンスに登録されているかどうかをチェックします。
Boolean | isRegisteredApplicationLicenseToAccount(String userId ,String applicationId) アカウントにアプリケーションライセンスが登録されてるか検証する。
Boolean | registerAccountLicense(String userId) ライセンス登録する。
Boolean | registerApplicationLicenseToAccount(String userId ,String applicationId) アプリケーションライセンスをアカウントに登録する。
Boolean | setMaxLicense(double maxLicense) ログイングループ内の最大登録可能ライセンス数を設定します。
コンストラクタの詳細
LicenseManager

LicenseManager(String groupId)
コンストラクタ。

パラメータ
groupId String ログイングループID
メソッドの詳細
deleteAccountLicense

boolean deleteAccountLicense(String userId)

指定されたユーザのライセンスを削除する。

パラメータ
userId String ユーザID
返却値
boolean true：処理成功 / false：処理失敗（ログを参照してください）
deleteApplicationLicenseFromAccount

boolean deleteApplicationLicenseFromAccount(String userId ,String applicationId)

アプリケーションライセンスをアカウントから削除する。

パラメータ
userId | String | ユーザID
applicationId | String | アプリケーションID
返却値
boolean true：処理成功 / false：処理失敗（ログを参照してください）
getApplication

static ApplicationInfo getApplication(String applicaionId)

アプリケーション情報を取得します。

引数に指定されたアプリケーションの情報を取得します。

パラメータ
applicaionId String アプリケーションID
返却値
ApplicationInfo アプリケーション情報
指定したアプリケーションが存在しない場合はnull
getApplicationLicense

static Number getApplicationLicense(String applicaionId)

アプリケーションの登録ユーザ数を取得します。

引数に指定されたアプリケーションIDを持つユーザの数を取得します。

パラメータ
applicaionId String アプリケーションID
返却値
Number アプリケーションIDを持つユーザの数
指定したアプリケーションが存在しない場合は0
getApplications

static Array getApplications()

アプリケーション情報の一覧を取得する。

取得に失敗した場合は、nullを返却します。
返却値
Array ApplicationInfoの配列
getLicense

double getLicense()

グループ内で登録されているライセンス数を取得する。

取得に失敗した場合は、-1を返却します。
返却値
double 登録ライセンス数
getMaxLicense

double getMaxLicense()

ログイングループ内の最大登録可能ライセンス数を取得します。

無制限の場合は Number.POSITIVE_INFINITY を返します。
取得に失敗した場合は、-1を返却します。

返却値
double 最大登録可能ライセンス数
getProduct

static ApplicationInfo getProduct()

システム情報を取得します。

返却値
ApplicationInfo システム情報
システム情報の取得に失敗した場合はnull
getRegisteredAccountLicenses

Array getRegisteredAccountLicenses()

ログイングループにライセンス登録されているすべてのユーザIDを返します。

返却値
Array ユーザIDの配列
getRegisteredApplicationLicensesToAccount

Array getRegisteredApplicationLicensesToAccount(String userId)

アカウントに登録されているアプリケーションライセンスの一覧を取得する。

取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Array アカウントに登録されているアプリケーションライセンス(ID)の配列
getSystemLicense

static double getSystemLicense()

システム全体の登録ライセンス数。

取得に失敗した場合は、-1を返却します。
返却値
double システム全体の登録ライセンス数
getSystemMaxLicense

static double getSystemMaxLicense()

システム全体のライセンス数。

無制限の場合は Number.POSITIVE_INFINITY を返します。

取得に失敗した場合は、-1を返却します。

返却値
double システム全体のライセンス数
isRegisteredAccountLicense

Boolean isRegisteredAccountLicense(String userId)

指定されたユーザがライセンスに登録されているかどうかをチェックします。

パラメータ
userId String ユーザID
返却値
Boolean true : 登録されている / false : 登録されていない
isRegisteredApplicationLicenseToAccount

Boolean isRegisteredApplicationLicenseToAccount(String userId ,String applicationId)

アカウントにアプリケーションライセンスが登録されてるか検証する。

パラメータ
userId | String | ユーザID
applicationId | String | アプリケーションID
返却値
Boolean true : 登録されている / false : 登録されていない
registerAccountLicense

Boolean registerAccountLicense(String userId)

ライセンス登録する。

指定されたユーザIDとコンストラクタで指定したログイングループIDでライセンス登録をします。
最大登録可能ライセンス数とログイングループ内最大登録可能ライセンス数を調査して
これを超えた場合はエラーとする。

パラメータ
userId String ユーザID
返却値
Boolean true：成功 / false：失敗
registerApplicationLicenseToAccount

Boolean registerApplicationLicenseToAccount(String userId ,String applicationId)

アプリケーションライセンスをアカウントに登録する。

すでに登録されているアプリケーション最大登録可能ライセンス数と合わせて
最大登録可能ライセンス数を超えた場合はエラーとする。

パラメータ
userId | String | ユーザID
applicationId | String | アプリケーションID
返却値
Boolean true：成功 / false：失敗
setMaxLicense

Boolean setMaxLicense(double maxLicense)

ログイングループ内の最大登録可能ライセンス数を設定します。

すでに登録されているログイングループ内最大登録可能ライセンス数の合計と合わせて
最大登録可能ライセンス数を超えた場合はエラーとする。

パラメータ
maxLicense double 最大登録可能ライセンス数
返却値
Boolean true：成功 / false：失敗


 Lock オブジェクト

アプリケーション・ロック管理オブジェクト。

アプリケーション・ロックの制御を行うオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static Boolean | begin(String name [,Number timeout]) アプリケーションロックを開始します。
static Boolean | end(String name) アプリケーションロックを開放します。
static Boolean | isLocked(String name) アプリケーションロックが開始されているかどうか判定します。
メソッドの詳細
begin

static Boolean begin(String name [,Number timeout])

アプリケーションロックを開始します。

指定のカテゴリキーワードにてロックを開始します。
第２引数 timeout を設定することで、他のプロセスによって ロック中であった場合のロックの開放待ちまでの時間を指定可能です。
引数の指定は自然数で、単位は秒です。
第２引数 timeout を省略した場合、または 0(ゼロ)を指定した場合、 このメソッドが実行された時に、他のプロセスによってロック中で あった場合、このカテゴリキーワードで指定されるロックが開放される まで永久的に待機状態になります。
このメソッドでロックが開始されると、ロックのセッションが同時に 開始され設定されているタイムアウト([install_directory]/conf/imart.xml で設定)の期間をセッション保持されます。
このメソッドが実行されてからセッションタイムアウトの期間中に end() メソッドにてロックの開放が行われなかった場合、自動的に ロックが開放されます。
パラメータ
name | String | 開始するロックカテゴリキーワード
timeout | Number | ロック開始までの待ち時間
返却値
Boolean true : ロック開始成功 / false : ロック開始失敗
end

static Boolean end(String name)

アプリケーションロックを開放します。

指定のカテゴリキーワードにてロックの開放処理をします。
指定のカテゴリキーワードがロック中である場合も、ロック中でない 場合もロック開放処理を行います。
パラメータ
name String ロックカテゴリキーワード
返却値
Boolean true : ロック解放成功 / false : ロック解放失敗
isLocked

static Boolean isLocked(String name)

アプリケーションロックが開始されているかどうか判定します。

指定のカテゴリキーワードがロック中であるかどうかをチェックします。
パラメータ
name String ロックカテゴリキーワード
返却値
Boolean true : ロック中 / false : 未ロック


 LoginGroupManager オブジェクト

ログイングループマネージャオブジェクト。

ログイングループ情報の参照、更新を行うマネージャオブジェクトです。

ログイングループの情報を操作する場合に用いるログイングループオブジェクトの構成は以下の通りです。
ログイングループオブジェクト
ログイングループ
オブジェクト
(Object)
id [必須] ログイングループID (String)
locale ロケール (String)
ログイングループでのデフォルトのロケールです。
このログイイングループに属するアカウントにこの設定がされていない場合に、アカウントのロケールとして使用されます。
encoding エンコーディング (String)
ログイングループでのデフォルトのエンコーディングです。
このログイイングループに属するアカウントにこの設定がされていない場合に、アカウントのエンコーディングとして使用されます。
lockCount アカウントロックを行うログイン失敗回数 (Number)
0が設定された場合はアカウントロックを行ないません。
lockTerm アカウントをロックする期間 (Number)
アカウントがロックされた場合の、ロック解除までの時間を分単位で設定します。
0が設定された場合は、自動的にアカウントロックは解除されません。
colorPatternId カラーパターンID (String)
ログイングループでのデフォルトのカラーパターンIDです。
このログイイングループに属するアカウントにこの設定がされていない場合に、アカウントのカラーパターンIDとして使用されます。

ログイングループに属するグループ管理者の参照、更新を行うことができます。
グループ管理者の情報を操作する場合に用いるグループ管理者オブジェクトの構成は以下の通りです。
グループ管理者オブジェクト
グループ管理者
オブジェクト
(Object)
userId [必須] ユーザID (String)
password パスワード (String)
locale ロケール (String)
encoding エンコーディング (String)
mailAddress メールアドレス (String)
telNo 電話番号 (String)

ログイングループに属するメインページパターンの情報を操作する場合に用いるメインページパターンオブジェクトの構成は以下の通りです。
メインページパターンオブジェクト
メインページ
パターンオブジェクト
(Object)
id [必須] メインページパターンID (String)
url [必須] メインページパターンURL (String)
コンテキストパスまたはpagesからの相対でパスで指定します。
先頭は'/'から始めます。
imageUrl メインページパターンイメージURL (String)
コンテキストパスからの相対でパスで指定します。
先頭は'/'から始めます。

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static Boolean | addLoginGroup(Object loginGroup) ログイングループを新規追加します。
static Boolean | addMainPagePattern(String groupId ,Object mainPagePattern) メインページパターンを新規追加します。
static Boolean | addSuperUser(String groupId ,Object superUser) グループ管理者情報を作成します。
static Number | countLoginGroup() ログイングループ数を取得します。
static Boolean | deleteLoginGroup(String groupId) ログイングループを削除します。
static Boolean | deleteMainPagePattern(String groupId ,String mainPagePatternId) メインページパターンを削除します。
static Boolean | deleteMainPagePatterns(String groupId) メインページパターンをすべて削除します。
static Boolean | deleteSuperUser(String groupId) グループ管理者情報を削除します。
static LoginGroup | getLoginGroup(String groupId) ログイングループを取得します。
static Array | getLoginGroupIds() ログイングループIDの一覧を取得します。
static Array | getLoginGroups() ログイングループの一覧を取得します。
static Object | getMainPagePattern(String groupId ,String mainPagePatternId) メインページパターンを取得します。
static Array | getMainPagePatternIds(String groupId) メインページパターンIDの一覧を取得します。
static Array | getMainPagePatterns(String groupId) メインページパターンの一覧を取得します。
static Object | getSuperUser(String groupId) グループ管理者情報を取得します。
static Boolean | updateLoginGroup(LoginGroup groupId) ログイングループを更新します。
static Boolean | updateMainPagePattern(String groupId ,Object mainPagePattern) メインページパターンを更新します。
static Boolean | updateSuperUser(String groupId ,Object superUser) グループ管理者情報を更新します。
メソッドの詳細
addLoginGroup

static Boolean addLoginGroup(Object loginGroup)

ログイングループを新規追加します。

パラメータ
loginGroup Object ログイングループオブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMainPagePattern

static Boolean addMainPagePattern(String groupId ,Object mainPagePattern)

メインページパターンを新規追加します。

パラメータ
groupId String ログイングループID
mainPagePattern Object メインページパターンオブジェクト
返却値
Boolean true : 成功 / false : 失敗
addSuperUser

static Boolean addSuperUser(String groupId ,Object superUser)

グループ管理者情報を作成します。

パラメータ
groupId | String | ログイングループのグループID
superUser | Object | グループ管理者オブジェクト
返却値
Boolean true : 成功 / false : 失敗
countLoginGroup

static Number countLoginGroup()

ログイングループ数を取得します。

返却値
Number 登録ログイングループ数
取得に失敗した場合は（-1）が返却されます。
deleteLoginGroup

static Boolean deleteLoginGroup(String groupId)

ログイングループを削除します。

パラメータ
groupId String 削除するログイングループのグループID
返却値
Boolean true : 成功 / false : 失敗
deleteMainPagePattern

static Boolean deleteMainPagePattern(String groupId ,String mainPagePatternId)

メインページパターンを削除します。

パラメータ
groupId | String | ログイングループID
mainPagePatternId | String | メインページパターンID
返却値
Boolean true : 成功 / false : 失敗
deleteMainPagePatterns

static Boolean deleteMainPagePatterns(String groupId)

メインページパターンをすべて削除します。

パラメータ
groupId String ログイングループID
返却値
Boolean true : 成功 / false : 失敗
deleteSuperUser

static Boolean deleteSuperUser(String groupId)

グループ管理者情報を削除します。

パラメータ
groupId String ログイングループID
返却値
Boolean true : 成功 / false : 失敗
getLoginGroup

static LoginGroup getLoginGroup(String groupId)

ログイングループを取得します。

存在しなかった場合および取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループID
返却値
LoginGroup ログイングループオブジェクト
getLoginGroupIds

static Array getLoginGroupIds()

ログイングループIDの一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array ログイングループIDの配列
getLoginGroups

static Array getLoginGroups()

ログイングループの一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array ログイングループオブジェクト の配列
getMainPagePattern

static Object getMainPagePattern(String groupId ,String mainPagePatternId)

メインページパターンを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
groupId | String | ログイングループID
mainPagePatternId | String | メインページパターンID
返却値
Object メインページパターンオブジェクト
getMainPagePatternIds

static Array getMainPagePatternIds(String groupId)

メインページパターンIDの一覧を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループID
返却値
Array メインページパターンIDの配列
getMainPagePatterns

static Array getMainPagePatterns(String groupId)

メインページパターンの一覧を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループID
返却値
Array メインページパターンオブジェクト の配列
getSuperUser

static Object getSuperUser(String groupId)

グループ管理者情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループのグループID
返却値
Object グループ管理者オブジェクト
updateLoginGroup

static Boolean updateLoginGroup(LoginGroup groupId)

ログイングループを更新します。

パラメータ
groupId LoginGroup ログイングループオブジェクト
返却値
Boolean true : 成功 / false : 失敗
updateMainPagePattern

static Boolean updateMainPagePattern(String groupId ,Object mainPagePattern)

メインページパターンを更新します。

パラメータ
groupId | String | ログイングループID
mainPagePattern | Object | メインページパターンオブジェクト
返却値
Boolean true : 成功 / false : 失敗
updateSuperUser

static Boolean updateSuperUser(String groupId ,Object superUser)

グループ管理者情報を更新します。

パラメータ
groupId | String | ログイングループのグループID
superUser | Object | グループ管理者オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 Mail オブジェクト

推奨されていません。MailSenderに置き換えられました。
メール送信オブジェクト。

メール送信を行うオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
コンストラクタの概要
Mail([String smtpServer])
推奨されていません。MailSenderに置き換えられました。
メソッドの概要
Boolean | attachFile(String sName ,String sContents) 推奨されていません。MailSenderのメソッドに置き換えられました。
Number | getErrCode() 推奨されていません。MailSenderのメソッドに置き換えられました。
String | getErrMessage() 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | send() 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setAttachment(String rPath [,String fPath]) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setBcc(String bcc) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setBody(String body) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setCc(String cc) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setFrom(String from [,String name]) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setHeader(String key ,String value) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setReplyTo(String reply) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setSubject(String title) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setTo(String to) 推奨されていません。MailSenderのメソッドに置き換えられました。
コンストラクタの詳細
Mail

Mail([String smtpServer])
推奨されていません。MailSenderに置き換えられました。
コンストラクタ。

引数を省略した場合は [install_directory]/conf/imart.xml の <smtp-server> で指定した SMTPサーバに接続します。
パラメータ
smtpServer String SMTPサーバのアドレス
メソッドの詳細
attachFile

Boolean attachFile(String sName ,String sContents)

推奨されていません。MailSenderのメソッドに置き換えられました。
メールへファイルを添付します。

第二引数（sContents）には、(new VirtualFile(FILE_PATH)).load()メソッドなどで 取得したバイナリ形式の文字列や、Unicode.to(STRING)メソッドで変換された 文字列を指定します。
このメソッドを複数回実行することで、複数ファイルをメールに 添付することがきます。
パラメータ
sName | String | ファイル名称
sContents | String | ファイルの内容(バイナリ形式)
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：2.0.2
getErrCode

Number getErrCode()

推奨されていません。MailSenderのメソッドに置き換えられました。
メール送信時のエラーコートを取得します。

send()メソッド発行後の状態を調べるときに使います。

エラーコードの内容は以下のとおり。

1 ：メールサーバが設定されていません。
2 ：指定の メールサーバがダウンしているか、または存在しません。
3 ：メールの送信先が全て不正です。
4 ：送信者アドレスが不正です。
5 ：メールサーバに接続できませんでした。
その他はRFC821に準拠。
返却値
Number -1 :エラーコードの取得に失敗、またはシステムエラー
0 ：正常終了
1 - 5 ：エラー終了
その他
getErrMessage

String getErrMessage()

推奨されていません。MailSenderのメソッドに置き換えられました。
メール送信時のエラーメッセージを取得取得します。

send()メソッド発行後の状態を調べるときに利用します。
返却値
String エラーメッセージ
send

Boolean send()

推奨されていません。MailSenderのメソッドに置き換えられました。
指定されたSMTPサーバへメールを送信します。

他のメソッドで設定した情報をもとにメールを送信します。
最低限必要な設定は宛先と送信者。（setTo(),setFrom()メソッドで設定します。）
返却値
Boolean true : 送信成功 / false : 送信失敗
setAttachment

Boolean setAttachment(String rPath [,String fPath])

推奨されていません。MailSenderのメソッドに置き換えられました。
メールへファイルを添付します。

第二引数（ファイルへの絶対パス）が指定されている場合には、『ファイルへの絶対パス ＋ ファイル名称』で 表わされるファイルを対象します。
※操作対象のファイルはApplicationRuntimeまたはBatchService上のファイルになります。
このメソッドを複数回実行することで、複数ファイルをメールに 添付することがきます。
パラメータ
rPath String ファイル名(拡張子付き)
第2引数(fPath)を指定しない場合：システムルートからの相対パス + ファイル名。
第2引数(fPath)を指定した場合：ファイル名。
fPath String ファイルのルートからのパス
返却値
Boolean true : 成功 / false : 失敗
setBcc

Boolean setBcc(String bcc)

推奨されていません。MailSenderのメソッドに置き換えられました。
bccを設定します。

このメソッドを複数回実行することで、複数bccをメールに設定することがきます。
パラメータ
bcc String bccに設定するメールアドレス
返却値
Boolean true : 成功 / false : 失敗
setBody

Boolean setBody(String body)

推奨されていません。MailSenderのメソッドに置き換えられました。
メール本文を設定します。

パラメータ
body String メール本文
返却値
Boolean true : 成功 / false : 失敗
setCc

Boolean setCc(String cc)

推奨されていません。MailSenderのメソッドに置き換えられました。
ccを設定します。

このメソッドを複数回実行することで、複数ccをメールに設定することがきます。
パラメータ
cc String ccに設定するメールアドレス
返却値
Boolean true : 成功 / false : 失敗
setFrom

Boolean setFrom(String from [,String name])

推奨されていません。MailSenderのメソッドに置き換えられました。
fromを設定します。

パラメータ
from | String | fromにセットするメールアドレス
name | String | fromのニックネーム
返却値
Boolean true : 成功 / false : 失敗
setHeader

Boolean setHeader(String key ,String value)

推奨されていません。MailSenderのメソッドに置き換えられました。
メールヘッダを設定します。

送信するメールヘッダ情報を設定します。
設定可能なメールヘッダの種類は以下の通り。
Sender : 送った人のメールアドレス
Reply-To: 返信先メールアドレス
(その他にも任意にヘッダ情報を追加できますが、任意のヘッダを追加した場合の動作は 未検証です。)
パラメータ
key | String | 設定するメールヘッダの種類
value | String | メールヘッダへの情報
返却値
Boolean true : 成功 / false : 失敗
setReplyTo

Boolean setReplyTo(String reply)

推奨されていません。MailSenderのメソッドに置き換えられました。
reply-toを設定します。

このメソッドを複数回実行することで、複数reply-toをメールに セットすることがきます。
パラメータ
reply String reply-toに設定するメールアドレス
返却値
Boolean true : 成功 / false : 失敗
setSubject

Boolean setSubject(String title)

推奨されていません。MailSenderのメソッドに置き換えられました。
メールのタイトルを設定します。

パラメータ
title String メールのタイトル
返却値
Boolean true : 成功 / false : 失敗
setTo

Boolean setTo(String to)

推奨されていません。MailSenderのメソッドに置き換えられました。
toを設定します。

このメソッドを複数回実行することで、複数toをメールに セットすることがきます。
パラメータ
to String toに設定するメールアドレス
返却値
Boolean true : 成功 / false : 失敗


 MailSender オブジェクト

メールを送信するオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
MailSender(String locale)
コンストラクタ
メソッドの概要
void | addAttachment(String filename ,String file) 添付ファイルを追加します。
void | addBcc(String address ,String personal) Bccを追加します。
void | addCc(String address ,String personal) Ccを追加します。
void | addHeader(String name ,String value) メールヘッダーを追加します。
void | addReplyTo(String replyto) ReplyToを追加します。
void | addTo(String address ,String personal) Toを追加します。
String | getErrorMessage() メール送信エラー時のメッセージを返します。
Boolean | send() メールを送信します。
void | setFrom(String address ,String personal) Fromを設定します。
void | setSubject(String subject) Subjectを設定します。
void | setText(String text) 本文を設定します。
コンストラクタの詳細
MailSender

MailSender(String locale)
コンストラクタ
パラメータ
locale String ロケール名
メソッドの詳細
addAttachment

void addAttachment(String filename ,String file)

添付ファイルを追加します。
パラメータ
filename | String | 添付ファイル名
file | String | ファイルの内容
返却値
void
addBcc

void addBcc(String address ,String personal)

Bccを追加します。
パラメータ
address | String | メールアドレス
personal | String | 名前
返却値
void
addCc

void addCc(String address ,String personal)

Ccを追加します。
パラメータ
address | String | メールアドレス
personal | String | 名前
返却値
void
addHeader

void addHeader(String name ,String value)

メールヘッダーを追加します。
パラメータ
name | String | ヘッダーの名前
value | String | ヘッダーの値
返却値
void
addReplyTo

void addReplyTo(String replyto)

ReplyToを追加します。
パラメータ
replyto String ReplyToに追加するメールアドレス
返却値
void
addTo

void addTo(String address ,String personal)

Toを追加します。
パラメータ
address | String | メールアドレス
personal | String | 名前
返却値
void
getErrorMessage

String getErrorMessage()

メール送信エラー時のメッセージを返します。
返却値
String 送信エラーのメッセージ
send

Boolean send()

メールを送信します。
返却値
Boolean true 送信成功 / false 送信失敗
setFrom

void setFrom(String address ,String personal)

Fromを設定します。
パラメータ
address | String | メールアドレス
personal | String | 名前
返却値
void
setSubject

void setSubject(String subject)

Subjectを設定します。
パラメータ
subject String Subject
返却値
void
setText

void setText(String text)

本文を設定します。
パラメータ
text String 本文
返却値
void


 MenuManager オブジェクト

メニューマネージャオブジェクト。

メニュー・モデルの参照、更新を行うマネージャオブジェクトです。

メニュー・モデルの情報を操作する場合に用いるメニュー・モデルオブジェクトの構成は以下の通りです。
メニュー・モデルオブジェクト
メニュー・モデル
オブジェクト
(Object)
type ノードタイプ (String)
description 説明 (String)
clientType クライアントタイプ (String)
contents コンテンツの種類 (String)
url URL (String)
argument 引数 (Object)
id メニューID (String)
displayName[ロケール] メニュー名 (String)
ロケール別の表示名です。
imagePath メニューイメージパス (String)
メニューのアイコンイメージです。
sortNumber ソート番号 (Number)

メニュー内包情報を操作する場合に用いるメニュー内包情報オブジェクトの構成は以下の通りです。
メニュー内包情報オブジェクト
メニュー内包情報
オブジェクト
(Object)
parentMenuId 親メニューID (String)
childMenuId 子メニューID (String)

メニューツリー情報を操作する場合に用いるメニューツリーオブジェクトの構成は以下の通りです。
メニューツリーオブジェクト
メニューツリー
オブジェクト
(Object)
menuItem メニュー・モデル ( メニュー・モデルオブジェクト )
children メニューの子供の配列 ( メニューツリーオブジェクト の配列)

組織情報を操作する場合に用いる組織情報オブジェクトの構成は以下の通りです。
組織情報オブジェクト
組織情報
オブジェクト
(Object)
companyCode 会社コード (String)
departmentCode 組織コード (String)

役職情報を操作する場合に用いる役職情報オブジェクトの構成は以下の通りです。
役職情報オブジェクト
役職情報
オブジェクト
(Object)
companyCode 会社コード (String)
postCode 役職コード (String)

パブリックグループ情報を操作する場合に用いるパブリックグループ情報オブジェクトの構成は以下の通りです。
パブリックグループ情報オブジェクト
パブリックグループ情報
オブジェクト
(Object)
groupSetCode グループセットコード (String)
groupCode グループコード (String)

バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | CONTENT_TYPE_IN メニューコンテンツの種類（内部URL）。
static String | CONTENT_TYPE_OUT メニューコンテンツの種類（外部URL）。
static String | MENU_TYPE_FOLDER メニュータイプ（フォルダ）。
static String | MENU_TYPE_ITEM メニュータイプ（アイテム）。
コンストラクタの概要
MenuManager(String groupId)
JSコンストラクタ。
メソッドの概要
Boolean | addMenuDepartment(String menuId ,Object object) 組織情報を新規追加します。
Boolean | addMenuItem(String parentMenuId ,Object object) メニューを新規追加します。
Boolean | addMenuPost(String menuId ,Object object) 役職情報を新規追加します。
Boolean | addMenuPublicGroup(String menuId ,Object object) メニューパブリックグループを新規追加します。
Boolean | addMenuRole(String menuId ,String roleId) メニューロールを新規追加します。
Boolean | deleteMenuDepartment(String menuId ,Object object) 指定した組織情報を削除します。
Boolean | deleteMenuDepartments(String menuId) 組織情報を削除します。
Boolean | deleteMenuItem(String menuId) 指定したメニューを削除します。
Boolean | deleteMenuItems() メニューを削除します。
Boolean | deleteMenuPost(String menuId ,Object object) 役職情報を削除します。
Boolean | deleteMenuPosts(String menuId) 役職情報をすべて削除します。
Boolean | deleteMenuPublicGroup(String menuId ,Object object) 指定したメニューパブリックグループを削除します。
Boolean | deleteMenuPublicGroups(String menuId) メニューパブリックグループを削除します。
Boolean | deleteMenuRole(String menuId ,String roleId) 指定したメニューロールを削除します。
Boolean | deleteMenuRoles(String menuId) メニューロールを削除します。
String | exportData(String category) メニューのエクスポートを行います。
Array | getAccountMenuTree(String userId ,String clientType) 指定されたユーザIDおよび指定されたクライアントタイプのみのメニュー構成を取得します。
Array | getChildMenuIds(String menuId) 子メニューIDを取得します。
Array | getExportCategories() メニューエクスポート用のカテゴリの一覧を取得します。
Array | getFirstMenuIds(String menuId) 第一階層の子メニューIDをすべて取得します。
Array | getImportCategories() メニューインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId() ログイングループIDを取得します。
Array | getMenuDepartments(String menuId) 組織情報をすべて取得します。
Array | getMenuIds() すべてのメニューIDを取得します。
Array | getMenuIdsByDepartment(Array departments) 指定された組織を持つメニューIDをすべて取得します。
Array | getMenuIdsByPost(Array posts) 指定された役職を持つメニューIDをすべて取得します。
Array | getMenuIdsByPublicGroup(publicGroups Array) 指定されたパブリックグループを持つメニューIDをすべて取得します。
Array | getMenuIdsByRole(Array roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
Object | getMenuItem(String menuId) 指定されたメニューIDに対応するメニューを取得します。
Array | getMenuItems() すべてのメニューを取得します。
Array | getMenuItemsByIds(Array userIds) 引数のメニューIDのメニューをすべて取得します。
Array | getMenuPosts(String menuId) 役職情報を取得します。
Array | getMenuPublicGroups(String menuId) パブリックグループ情報を取得します。
Array | getMenuRoles(String menuId) メニューロールを取得します。
Array | getMenuTree() メニュー構成を取得します。
String | getParentMenuId(String menuId) 指定されたメニューの親メニューを取得します。
Boolean | importData(String category ,String inputString) メニューのインポートを行います。
Boolean | moveMenuItem(Object object) メニューを移動します。
Boolean | updateMenuItem(Object object) メニューを更新します。
定数の詳細
CONTENT_TYPE_IN

static String CONTENT_TYPE_IN

メニューコンテンツの種類（内部URL）。
定数値 ： "in"
CONTENT_TYPE_OUT

static String CONTENT_TYPE_OUT

メニューコンテンツの種類（外部URL）。
定数値 ： "out"
MENU_TYPE_FOLDER

static String MENU_TYPE_FOLDER

メニュータイプ（フォルダ）。
定数値 ： "folder"
MENU_TYPE_ITEM

static String MENU_TYPE_ITEM

メニュータイプ（アイテム）。
定数値 ： "item"
コンストラクタの詳細
MenuManager

MenuManager(String groupId)
JSコンストラクタ。
パラメータ
groupId String ログイングループID
メソッドの詳細
addMenuDepartment

Boolean addMenuDepartment(String menuId ,Object object)

組織情報を新規追加します。
パラメータ
menuId | String | メニューID
object | Object | 組織情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuItem

Boolean addMenuItem(String parentMenuId ,Object object)

メニューを新規追加します。
パラメータ
parentMenuId | String | 親メニューID
object | Object | 組織情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuPost

Boolean addMenuPost(String menuId ,Object object)

役職情報を新規追加します。
パラメータ
menuId | String | メニューID
object | Object | 役職情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuPublicGroup

Boolean addMenuPublicGroup(String menuId ,Object object)

メニューパブリックグループを新規追加します。
パラメータ
menuId | String | メニューID
object | Object | パブリックグループ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuRole

Boolean addMenuRole(String menuId ,String roleId)

メニューロールを新規追加します。
パラメータ
menuId | String | メニューID
roleId | String | ロールID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuDepartment

Boolean deleteMenuDepartment(String menuId ,Object object)

指定した組織情報を削除します。
パラメータ
menuId | String | メニューID
object | Object | 組織情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteMenuDepartments

Boolean deleteMenuDepartments(String menuId)

組織情報を削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuItem

Boolean deleteMenuItem(String menuId)

指定したメニューを削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuItems

Boolean deleteMenuItems()

メニューを削除します。
返却値
Boolean true : 成功 / false : 失敗
deleteMenuPost

Boolean deleteMenuPost(String menuId ,Object object)

役職情報を削除します。
パラメータ
menuId | String | メニューID
object | Object | 役職情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteMenuPosts

Boolean deleteMenuPosts(String menuId)

役職情報をすべて削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuPublicGroup

Boolean deleteMenuPublicGroup(String menuId ,Object object)

指定したメニューパブリックグループを削除します。
パラメータ
menuId | String | メニューID
object | Object | パブリックグループ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteMenuPublicGroups

Boolean deleteMenuPublicGroups(String menuId)

メニューパブリックグループを削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuRole

Boolean deleteMenuRole(String menuId ,String roleId)

指定したメニューロールを削除します。
パラメータ
menuId | String | メニューID
roleId | String | ロールID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuRoles

Boolean deleteMenuRoles(String menuId)

メニューロールを削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData(String category)

メニューのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getAccountMenuTree

Array getAccountMenuTree(String userId ,String clientType)

指定されたユーザIDおよび指定されたクライアントタイプのみのメニュー構成を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userId | String | ユーザID
clientType | String | クライアントタイプ
返却値
Array メニュー構成オブジェクト の配列
getChildMenuIds

Array getChildMenuIds(String menuId)

子メニューIDを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array 子メニューIDの配列
getExportCategories

Array getExportCategories()

メニューエクスポート用のカテゴリの一覧を取得します。

返却値
Array メニューエクスポート用カテゴリの一覧
メニューエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getFirstMenuIds

Array getFirstMenuIds(String menuId)

第一階層の子メニューIDをすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array メニューIDの配列
getImportCategories

Array getImportCategories()

メニューインポート用のカテゴリの一覧を取得します。

返却値
Array メニューインポート用カテゴリの一覧
メニューインポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getLoginGroupId

String getLoginGroupId()

ログイングループIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
String ログイングループID
getMenuDepartments

Array getMenuDepartments(String menuId)

組織情報をすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array 組織情報オブジェクト の配列
getMenuIds

Array getMenuIds()

すべてのメニューIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニューIDの配列
getMenuIdsByDepartment

Array getMenuIdsByDepartment(Array departments)

指定された組織を持つメニューIDをすべて取得します。
パラメータ
departments Array 組織情報の配列
返却値
Array メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
getMenuIdsByPost

Array getMenuIdsByPost(Array posts)

指定された役職を持つメニューIDをすべて取得します。
パラメータ
posts Array 役職情報の配列
返却値
Array メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
getMenuIdsByPublicGroup

Array getMenuIdsByPublicGroup(publicGroups Array)

指定されたパブリックグループを持つメニューIDをすべて取得します。
パラメータ
Array publicGroups パブリックグループの配列
返却値
Array メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
getMenuIdsByRole

Array getMenuIdsByRole(Array roleIds)

指定されたロールIDを持つメニューIDをすべて取得します。
パラメータ
roleIds Array ロールIDの配列
返却値
Array メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
getMenuItem

Object getMenuItem(String menuId)

指定されたメニューIDに対応するメニューを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Object メニューオブジェクト
getMenuItems

Array getMenuItems()

すべてのメニューを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニューオブジェクト の配列
getMenuItemsByIds

Array getMenuItemsByIds(Array userIds)

引数のメニューIDのメニューをすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userIds Array メニューIDの配列
返却値
Array メニューオブジェクト の配列（データがない場合は空の配列を返します）
getMenuPosts

Array getMenuPosts(String menuId)

役職情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array 役職情報オブジェクト の配列
getMenuPublicGroups

Array getMenuPublicGroups(String menuId)

パブリックグループ情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array パブリックグループ情報オブジェクト の配列
getMenuRoles

Array getMenuRoles(String menuId)

メニューロールを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array ロールIDの配列
getMenuTree

Array getMenuTree()

メニュー構成を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニュー構成オブジェクト の配列
getParentMenuId

String getParentMenuId(String menuId)

指定されたメニューの親メニューを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
String 親メニュー
importData

Boolean importData(String category ,String inputString)

メニューのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
moveMenuItem

Boolean moveMenuItem(Object object)

メニューを移動します。
パラメータ
object Object メニュー内包情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
updateMenuItem

Boolean updateMenuItem(Object object)

メニューを更新します。
パラメータ
object Object メニューオブジェクト
返却値
Boolean true : 成功 / false : 失敗


 MessageManager オブジェクト

メッセージマネージャオブジェクト。

メッセージIDからメッセージ文字列を取得するオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String getMessage(String key ,String ....)
メッセージを取得する。
メソッドの詳細
getMessage

static String getMessage(String key ,String ....)

メッセージを取得する。

取得に失敗した場合は、nullを返却します。
パラメータ
key String メッセージＩＤ
.... String メッセージ引数（複数設定可能）
返却値
String メッセージ文字列


 Module.access オブジェクト

推奨されていません。アクセスセキュリティの各Managerオブジェクトのメソッドに置き換えられました。
セキュリティ情報を操作するオブジェクト。

ロール、メニュー、アカウント、バッチ 情報のインポート／エクスポート／削除を行います。

メソッドの概要
static Number delAccount(String groupId ,String userId)
推奨されていません。AccountManager.deleteAccount()に置き換えられました。
static Number delAllAccount(String groupId)
推奨されていません。AccountManager.deleteAccounts()に置き換えられました。
static Number delAllMenu(String groupId)
推奨されていません。MenuManager.deleteMenuItems()に置き換えられました。
static Number delAllRole(String groupId)
推奨されていません。RoleManager.deleteRoles()に置き換えられました。
static Number delAllSchedule(String groupId)
推奨されていません。BatchManager.deleteBatches()に置き換えられました。
static Number getAccount(String groupId ,String path)
推奨されていません。AccountManager.exportData()に置き換えられました。
static Number getMenu(String groupId ,String path)
推奨されていません。MenuManager.exportData()に置き換えられました。
static Number getRole(String groupId ,String path)
推奨されていません。RoleManager.exportData()に置き換えられました。
static Number getSchedule(String groupId ,String path)
推奨されていません。BatchManager.exportData()に置き換えられました。
static Number setAccount(String groupId ,String path)
推奨されていません。AccountManager.importData()に置き換えられました。
static Number setMenu(String groupId ,String path)
推奨されていません。MenuManager.importData()に置き換えられました。
static Number setRole(String groupId ,String path)
推奨されていません。RoleManager.importData()に置き換えられました。
static Number setSchedule(String groupId ,String path)
推奨されていません。BatchManager.importData()に置き換えられました。
メソッドの詳細
delAccount

static Number delAccount(String groupId ,String userId)

推奨されていません。AccountManager.deleteAccount()に置き換えられました。
アカウント情報を削除します。

指定のログイングループ内の指定のアカウント情報を削除します。
パラメータ
groupId | String | ログイングループID
userId | String | ユーザーCD
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
delAllAccount

static Number delAllAccount(String groupId)

推奨されていません。AccountManager.deleteAccounts()に置き換えられました。
アカウント情報を全て削除します。

指定のログイングループ内のアカウント情報を全て削除します。 現在ログインしてるグループのデータは全削除できません。
パラメータ
groupId String
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
delAllMenu

static Number delAllMenu(String groupId)

推奨されていません。MenuManager.deleteMenuItems()に置き換えられました。
メニュー情報を全て削除します。

指定のログイングループ内のメニュー情報を全て削除します。 現在ログインしてるグループのデータは全削除できません。
パラメータ
groupId String
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
delAllRole

static Number delAllRole(String groupId)

推奨されていません。RoleManager.deleteRoles()に置き換えられました。
ロール情報を全て削除します。

指定のログイングループ内のロール情報を全て削除します。 現在ログインしてるグループのデータは全削除できません。
パラメータ
groupId String
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
delAllSchedule

static Number delAllSchedule(String groupId)

推奨されていません。BatchManager.deleteBatches()に置き換えられました。
バッチ情報を全て削除します。

指定のログイングループ内のバッチ情報を全て削除します。 現在ログインしてるグループのデータは全削除できません。
パラメータ
groupId String
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
getAccount

static Number getAccount(String groupId ,String path)

推奨されていません。AccountManager.exportData()に置き換えられました。
アカウント情報をエクスポートします。

指定のログイングループ内のアカウント情報を ファイルへ出力します。 ファイルは Storage Service 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはStorage Serviceルート/storageからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。
パラメータ
groupId | String
path | String
返却値
Number
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
4：ファイルへの書き込みに失敗
5：引数が不正
getMenu

static Number getMenu(String groupId ,String path)

推奨されていません。MenuManager.exportData()に置き換えられました。
メニュー情報をエクスポートします。

指定のログイングループ内のメニュー情報を ファイルへ出力します。 ファイルは Storage Service 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはStorage Serviceルート/storageからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。
パラメータ
groupId | String
path | String
返却値
Number
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
4：ファイルへの書き込みに失敗
5：引数が不正
getRole

static Number getRole(String groupId ,String path)

推奨されていません。RoleManager.exportData()に置き換えられました。
ロール情報をエクスポートします。

指定のログイングループ内のロール情報を ファイルへ出力します。 ファイルは Storage Service 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはStorage Serviceルート/storageからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。
パラメータ
groupId | String
path | String
返却値
Number
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
4：ファイルへの書き込みに失敗
5：引数が不正
getSchedule

static Number getSchedule(String groupId ,String path)

推奨されていません。BatchManager.exportData()に置き換えられました。
バッチ情報をエクスポートします。

指定のログイングループ内のバッチ情報をファイルへ出力します。 ファイルは Storage Service 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはStorage Serviceルート/storageからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。
パラメータ
groupId | String
path | String
返却値
Number
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
4：ファイルへの書き込みに失敗
5：引数が不正
setAccount

static Number setAccount(String groupId ,String path)

推奨されていません。AccountManager.importData()に置き換えられました。
アカウント情報をインポートします。

第2引数のファイルパスはStorageServiceルート/storageからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（stderr.log）に出力されます。 既に同一のアカウントIDがシステムに登録されている場合、上書きされます。
パラメータ
groupId | String | ログイングループID
path | String | ファイルパス
返却値
Number
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：エラー
setMenu

static Number setMenu(String groupId ,String path)

推奨されていません。MenuManager.importData()に置き換えられました。
メニュー情報をインポートします。

第2引数のファイルパスはStorageServiceルート/storageからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（stderr.log）に出力されます。 既に同一のメニューIDがシステムに登録されている場合、上書きされます。
パラメータ
groupId | String | ログイングループID
path | String | ファイルパス
返却値
Number
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：エラー
setRole

static Number setRole(String groupId ,String path)

推奨されていません。RoleManager.importData()に置き換えられました。
ロール情報をインポートします。

第2引数のファイルパスはStorageServiceルート/storageからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（stderr.log）に出力されます。 既に同一のロールIDがシステムに登録されている場合、上書きされます。
パラメータ
groupId | String | ログイングループID
path | String | ファイルパス
返却値
Number
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：エラー
setSchedule

static Number setSchedule(String groupId ,String path)

推奨されていません。BatchManager.importData()に置き換えられました。
バッチ情報をインポートします。

第2引数のファイルパスはStorageServiceルート/storageからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（stderr.log）に出力されます。 既に同一のバッチIDがシステムに登録されている場合、上書きされます。
パラメータ
groupId | String | ログイングループID
path | String | ファイルパス
返却値
Number
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：エラー


 Module.alert オブジェクト

警告画面オブジェクト

警告画面を表示します。

メソッドの概要
static void | back(String messageId ,String detail) 警告画面表示後、前表示ページへ戻る機能を持つ警告画面を表示します。
static void | link(String messageId ,String detail ,String path ,Object arg) 警告画面表示後、任意のページの再表示機能を持つ警告画面を表示します。
static void | reload(String messageId ,String detail ,Object arg) 警告画面表示後、前表示ページの再表示機能を持つ警告画面を表示します。
static void | write(String messageId ,String detail) 警告画面の表示を表示します。
メソッドの詳細
back

static void back(String messageId ,String detail)

警告画面表示後、前表示ページへ戻る機能を持つ警告画面を表示します。

現在ログインしているユーザのロケールのメッセージＩＤに該当するメッセージを表示します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
また、第２引数 detail に渡された文字列を詳細メッセージとして 警告画面上に表示します。 このメソッドで表示される警告画面上には、ボタンが表示され、この ボタンをクリックする事で、ブラウザのキャッシュ機能を利用して 直前まで表示されていた画面を再表示します。 キャッシュを利用しないように設定されているブラウザ上では、 期待通りの動作をしない場合が有ります。

このAPIは、try...catch 文では使用できません。
パラメータ
messageId | String | メッセージID
detail | String | 画面に表示する詳細メッセージ文字列
返却値
void
link

static void link(String messageId ,String detail ,String path ,Object arg)

警告画面表示後、任意のページの再表示機能を持つ警告画面を表示します。

現在ログインしているユーザのロケールのメッセージＩＤに該当するメッセージを表示します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
また、第２引数 detail に渡された文字列を詳細メッセージとして 警告画面上に表示します。 このメソッドで表示された警告画面上のボタンをクリックする事で、 引数 path で指定した任意のページプログラムをリクエストして、 表示させる事ができます。 引数 arg には、再表示リクエスト時のプログラムへのＵＲＬ引数を 定義する事ができます。オブジェクト arg の内容が、そのままリクエスト されたファンクションコンテナの init() 関数への引数 request として渡されます。 リンク先プログラムの init() 関数に渡す引数データとして arg に対して request オブジェクトを指定すると 正常に動作しないことがあります。

このAPIは、try...catch 文では使用できません。
パラメータ
messageId | String | メッセージID
detail | String | 画面に表示する詳細メッセージ文字列
path | String | 先ページプログラムパス(拡張子なし)
arg | Object | 画面プログラムへの引数群
返却値
void
reload

static void reload(String messageId ,String detail ,Object arg)

警告画面表示後、前表示ページの再表示機能を持つ警告画面を表示します。

現在ログインしているユーザのロケールのメッセージＩＤに該当するメッセージを表示します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
また、第２引数 detail に渡された文字列を詳細メッセージとして 警告画面上に表示します。 このメソッドで表示された警告画面上のボタンをクリックする事で、 直前に表示していたページプログラムを再度リクエストして、 再表示させる事ができます。 引数 arg には、再表示リクエスト時のプログラムへのＵＲＬ引数を 定義する事ができます。オブジェクト arg の内容が、そのままリクエスト されたファンクションコンテナの init() 関数への引数 request として渡されます。 リロード時の init() 関数に渡す引数データとして arg に対して request オブジェクトを指定すると正常に動作しないことがあります。

このAPIは、try...catch 文では使用できません。
パラメータ
messageId | String | メッセージID
detail | String | 画面に表示する詳細メッセージ文字列
arg | Object | 画面プログラムへの引数群
返却値
void
write

static void write(String messageId ,String detail)

警告画面の表示を表示します。

現在ログインしているユーザのロケールのメッセージＩＤに該当するメッセージを表示します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
また、第２引数 detail に渡された文字列を詳細メッセージとして 警告画面上に表示します。

このAPIは、try...catch 文では使用できません。
パラメータ
messageId | String | メッセージID
detail | String | 画面に表示する詳細メッセージ文字列
返却値
void


 Module.almanac オブジェクト

推奨されていません。CalendarManagerに置き換えられました。
暦オブジェクト。

暦を扱います。
警告画面を表示します。

メソッドの概要
static void definePlugin(String key ,String name ,Function plugin)
推奨されていません。代替えメソッドはありません。
static void extinction(String group)
推奨されていません。calendarManager.deleteCalendar()に置き換えられました。
static Array getConfig(String id)
推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static Object getDate(Date target ,String group)
推奨されていません。calendarManager.getDayInfo()に置き換えられました。
static Object getGroup(String id)
推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static Array getHoliday(String id)
推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static Array getMonth(Number year ,Number month ,String id)
推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static Object getPlugin()
推奨されていません。calendarManager.getPluginIds()に置き換えられました。
static Array getWeekday(String id)
推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static void insert(String group ,Number year ,Number month ,Number date ,Number day ,Number times ,Number week ,Number begin ,Number terminate ,String plugin ,String exp ,String color ,String type ,String caption)
推奨されていません。calendarManager.addCalendarInfo()に置き換えられました。
static Boolean isHoliday(Date target ,String id)
推奨されていません。calendarManager.isHoliday()に置き換えられました。
static Boolean isWeekday(Date target ,String id)
推奨されていません。CalendarManager.isWeekday()に置き換えられました。
static void remove(group String ,String id)
推奨されていません。CalendarManager.deleteCalendarInfo(String ,String)に置き換えられました。
static Object update(String group ,String id ,Number year ,Number month ,Number date ,Number day ,Number times ,Number week ,Number begin ,Number terminate ,String plugin ,String exp ,String color ,String type ,String caption)
推奨されていません。calendarManager.updateCalendarInfo()に置き換えられました。
メソッドの詳細
definePlugin

static void definePlugin(String key ,String name ,Function plugin)

推奨されていません。代替えメソッドはありません。
休日・非休日判定用プラグイン関数の登録をします。

この関数は何も処理を行いません。 プラグイン関数の登録は、設定ファイル(サーバマネージャのインストールディレクトリ/conf/access-security.xml)で行います。
設定ファイルにて登録する方式に変更されました。
サーバマネージャ/conf/access-security.xmlファイル。
access-config/calendar/pluginタグにて設定します。
パラメータ
key | String | プラグイン設定キー
name | String | マスタメンテ画面での表示名称
plugin | Function | 実行関数
返却値
void
extinction

static void extinction(String group)

推奨されていません。calendarManager.deleteCalendar()に置き換えられました。
設定カテゴリを削除します。

指定のカテゴリを削除します。 指定のカテゴリ内に保存されていたデータはすべて破棄されます。
パラメータ
group String カテゴリID
返却値
void
getConfig

static Array getConfig(String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
指定カテゴリ内名称設定データ一覧を取得します。

 指定のカテゴリに対する名称設定情報を取得します。
 このメソッドの返却オブジェクトを無闇に変更すると暦モジュールの
 動作が不安定になる場合が有ります。
 返却オブジェクトは、以下の構造を持つオブジェクトになります。
 return_object
      ├ [0]
      │ ・
      │ ・
      │ ・
      └ [n]
          ├ id          設定ＩＤ
          ├ year        年設定
          ├ month       月設定
          ├ date        日設定
          ├ day         曜日設定
          ├ times       第何何曜日設定
          ├ week        第何週設定
          ├ start       有効開始年
          ├ end         有効終了年
          ├ expression  備考データ
          └ plugin      プラグイン関数への参照名
パラメータ
id String カテゴリID
返却値
Array 名称設定データ一覧配列
getDate

static Object getDate(Date target ,String group)

推奨されていません。calendarManager.getDayInfo()に置き換えられました。
指定日付の暦情報を取得します。

 返却されるオブジェクトの構造は以下のようになっています。
 return_object
 ├ date 日付データ（ＤＡＴＥ型）
 ├ data[] 備考データ
 │ ├ 0
 │ │ ・
 │ └ n
 ├ match 休日または非休日設定で該当した設定項目数
 ├ color 最高優先度項目の設定表示色
 ├ holiday 休日フラグ（真偽値）
 └ weekday 平日フラグ（真偽値）
 返却オブジェクトのプロパティ match は、休日判定の場合、該当した
 休日設定項目の数が保存されます。
 また、該当日付が非休日判定の場合には、該当した非休日設定項目の
 数が保存されます。
パラメータ
target | Date | チェック対象日付データ
group | String | カテゴリID
返却値
Object 該当日付の暦データオブジェクト
getGroup

static Object getGroup(String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
指定カテゴリ内設定データ一覧を取得します。

 指定のカテゴリに対する設定情報をすべて取得します。
 このメソッドの返却オブジェクトを無闇に変更すると暦モジュールの
 動作が不安定になる場合が有ります。
 返却オブジェクトは、以下の構造を持つオブジェクトになります。

 return_object
  ├ name           グループ名称
  ├ holiday[]      休日設定(自動ＩＤ割付)
  ├ weekday[]      非休日設定(自動ＩＤ割付)
  └ config[]       特定日設定(自動ＩＤ割付)
       ├ id           割付ユニーク・データＩＤ
       ├ pattern      チェックパターン文字列
       ├ expression   備考（名称など）
       ├ color        表示色
       ├ point        有効得点（データの優先度）
       ├ year         年
       ├ month        月
       ├ date         日
       ├ day          曜日
       ├ times        その月の第何回目の曜日
       ├ week         その月の第何週
       ├ start        データの有効開始年
       ├ end          データの有効終了年
       └ plugin       プラグイン関数
パラメータ
id String カテゴリID
返却値
Object 設定データオブジェクト
getHoliday

static Array getHoliday(String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
指定カテゴリ内休日設定データ一覧を取得します。

 指定のカテゴリに対する休日設定情報を取得します。
 このメソッドの返却オブジェクトを無闇に変更すると暦モジュールの
 動作が不安定になる場合が有ります。
 返却オブジェクトは、以下の構造を持つオブジェクトになります。

 return_object
      ├ [0]
      │ ・
      │ ・
      │ ・
      └ [n]
          ├ id          設定ＩＤ
          ├ year        年設定
          ├ month       月設定
          ├ date        日設定
          ├ day         曜日設定
          ├ times       第何何曜日設定
          ├ week        第何週設定
          ├ start       有効開始年
          ├ end         有効終了年
          ├ expression  備考データ
          └ plugin      プラグイン関数への参照名
パラメータ
id String カテゴリID
返却値
Array 休日設定データ一覧配列
getMonth

static Array getMonth(Number year ,Number month ,String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
１ヶ月分の暦情報を取得します。

指定年月の１ヶ月分の休日・非休日の暦情報を作成して返却します。 返却する配列の要素番号は 1 から始まる連想配列になります。 各要素番号が指定年月の日に該当します。
例）要素番号 10 には、その月の 10 日の情報が格納されています。 返却する配列の各要素はオブジェクトになっていて、その構造は、 getDate() メソッドの返却値と同様になっています。
パラメータ
year | Number | 年
month | Number | 月
id | String | カテゴリID
返却値
Array 指定年月の暦情報を持つ配列
getPlugin

static Object getPlugin()

推奨されていません。calendarManager.getPluginIds()に置き換えられました。
プラグイン関数情報を取得します。

登録されているプラグイン関数に関する情報を返します。 返却値は、プラグイン設定キーをプロパティ名に、 該当するプラグイン名称を値とするオブジェクト型データになります。
返却値
Object 登録されているプラグインのキーと名称
getWeekday

static Array getWeekday(String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
指定カテゴリ内非休日設定データ一覧を取得します。

指定のカテゴリに対する非休日設定情報を取得します。 このメソッドの返却オブジェクトを無闇に変更すると暦モジュールの 動作が不安定になる場合が有ります。 返却オブジェクトは、以下の構造を持つオブジェクトになります。
 return_object
      ├ [0]
      │ ・
      │ ・
      │ ・
      └ [n]
          ├ id          設定ＩＤ
          ├ year        年設定
          ├ month       月設定
          ├ date        日設定
          ├ day         曜日設定
          ├ times       第何何曜日設定
          ├ week        第何週設定
          ├ start       有効開始年
          ├ end         有効終了年
          ├ expression  備考データ
          └ plugin      プラグイン関数への参照名
パラメータ
id String カテゴリID
返却値
Array 非休日設定データ一覧配列
insert

static void insert(String group ,Number year ,Number month ,Number date ,Number day ,Number times ,Number week ,Number begin ,Number terminate ,String plugin ,String exp ,String color ,String type ,String caption)

推奨されていません。calendarManager.addCalendarInfo()に置き換えられました。
設定データを登録します。

パラメータ
group | String | カテゴリID
year | Number | 年情報（数値）
month | Number | 月情報（数値）
date | Number | 日情報（数値）
day | Number | 曜日情報（数値）
times | Number | その月の何回目の曜日かの情報（数値）
week | Number | 第何週かの情報（数値）
begin | Number | 設定の有効開始年（数値）
terminate | Number | 設定の有効終了年（数値）
plugin | String | プラグイン関数への参照名（文字列）
exp | String | データへの備考（文字列）
color | String | データの表示色（文字列）
type | String | データの種別（キーワード）
caption | String | データ名称
返却値
void
isHoliday

static Boolean isHoliday(Date target ,String id)

推奨されていません。calendarManager.isHoliday()に置き換えられました。
指定日付が休日かをチェックします。

暦マスタの設定情報と照合して、指定の日付が休日判定なら true を 返却して、非休日判定なら false を返却します。
パラメータ
target | Date | チェック対象日付データ
id | String | カテゴリＩＤ
返却値
Boolean
真値：指定日付が休日設定
偽値：指定日付は非休日設定
isWeekday

static Boolean isWeekday(Date target ,String id)

推奨されていません。CalendarManager.isWeekday()に置き換えられました。
指定日付が非休日かをチェックします。

暦マスタの設定情報と照合して、指定の日付が非休日判定なら true を 返却して、休日判定なら false を返却します。
パラメータ
target | Date | チェック対象日付データ
id | String | カテゴリID
返却値
Boolean
真値：指定日付が非休日設定
偽値：指定日付は休日設定
remove

static void remove(group String ,String id)

推奨されていません。CalendarManager.deleteCalendarInfo(String ,String)に置き換えられました。
設定データを削除します。

パラメータ
String | group | カテゴリID
id | String | 設定データID
返却値
void
update

static Object update(String group ,String id ,Number year ,Number month ,Number date ,Number day ,Number times ,Number week ,Number begin ,Number terminate ,String plugin ,String exp ,String color ,String type ,String caption)

推奨されていません。calendarManager.updateCalendarInfo()に置き換えられました。
設定データの更新をします。
パラメータ
group | String | カテゴリID
id | String | 設定データID
year | Number | 年情報（数値）
month | Number | 月情報（数値）
date | Number | 日情報（数値）
day | Number | 曜日情報（数値）
times | Number | その月の何回目の曜日かの情報（数値）
week | Number | 第何週かの情報（数値）
begin | Number | 設定の有効開始年（数値）
terminate | Number | 設定の有効終了年（数値）
plugin | String | プラグイン関数への参照名（文字列）
exp | String | データへの備考（文字列）
color | String | データの表示色（文字列）
type | String | データの種別（キーワード）
caption | String | データ名称
返却値
Object 更新前データ


 Module.array オブジェクト

配列データを扱うためのオブジェクト。

メソッドの概要
static Array | add(Array head ,Array tail) ２つの配列データを連結します。
static Array | insert(Array target ,Object item ,Number index) 配列データへ要素を追加します。
static Array | remove(Array target ,Number index) 配列データ内の要素を削除します。
static Array | sort(Array target) 配列内のデータをソートします。
static Object | toList(Array src ,String key ,String data) オブジェクト型の配列データからオブジェクトを生成します。
メソッドの詳細
add

static Array add(Array head ,Array tail)

２つの配列データを連結します。

指定の２つの配列の全ての要素を持つ新しい配列を作成します。 作成される新しい配列は、0 ? head.length-1 までが head の各要素 であり、head.length ? (head.length + tail.length - 1) までが tail の各要素となります。
このメソッドは、元のデータに影響を与えません。 指定の配列データの指定の位置に指定のデータを挿入します。 このメソッドは、元のデータに影響を与えません。
パラメータ
head | Array | 連結されるデータ
tail | Array | 連結されるデータ
返却値
Array 連結された新しい配列データ
insert

static Array insert(Array target ,Object item ,Number index)

配列データへ要素を追加します。

指定の配列データの指定の位置に指定のデータを挿入します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target | Array | 配列データ
item | Object | 配列への追加データ
index | Number | データを追加する配列内のインデックス
返却値
Array データを追加された新しい配列データ
remove

static Array remove(Array target ,Number index)

配列データ内の要素を削除します。

指定の配列データの指定の位置のデータを削除します。 削除されたデータ以降のデータは、要素番号が１つずつ詰められます。 このメソッドは、元のデータに影響を与えません。
パラメータ
target | Array | 配列データ
index | Number | 削除する配列内のインデックス
返却値
Array データを削除された新しい配列データ
sort

static Array sort(Array target)

配列内のデータをソートします。

指定の配列データの各要素をソートして返します。 ソートは、昇順で行われます。 ソート対象の配列内データは、すべての要素が同一の型でなくては なりません。 このメソッドは、元のデータに影響を与えません。
パラメータ
target Array 配列データ
返却値
Array ソートされた結果の新しい配列データ
toList

static Object toList(Array src ,String key ,String data)

オブジェクト型の配列データからオブジェクトを生成します。

プロパティ名を渡すと、そのオブジェクト内のプロパティのデータをプロパティ名にして、そのオブジェクトを返します。
第２引数に与えたプロパティ名のデータがプロパティの名称になります。
第３引数に与えたプロパティ名のデータがプロパティの値になります。
引数がない場合には、空のオブジェクトが返されます。
パラメータ
src | Array | オブジェクト型の配列
key | String | キーになるプロパティ名
data | String | データになるプロパティ名
返却値
Object 生成されたオブジェクト


 Module.calendar オブジェクト

日本の元号を扱うオブジェクト。

メソッドの概要
static String | getName(Date target) 指定日付の年号を取得します。
static Object | getObject() 年号の設定データ情報を取得します。
static Number | getYear(Date target) 指定日付の該当年号内での年数を取得します。
static void | set(String name ,String key ,Number year ,Number month ,Number day) カテゴリ内の指定保存キーで指定データを保存します。
static Number | toADYear(String key ,Number year) 年号および年号年数より西暦年への変換をします。
メソッドの詳細
getName

static String getName(Date target)

指定日付の年号を取得します。

指定日付データの該当する年号名称を返却します。
パラメータ
target Date 日付データ
返却値
String 年号名称文字列
getObject

static Object getObject()

年号の設定データ情報を取得します。

設定データの key をプロパティ、name を値とするオブジェクトを生成して返却します。
返却値
Object 全保存データ群
getYear

static Number getYear(Date target)

指定日付の該当年号内での年数を取得します。

指定日付データの該当する年号での年数を返却します。
パラメータ
target Date 日付データ
返却値
Number 暦年数を返却
set

static void set(String name ,String key ,Number year ,Number month ,Number day)

カテゴリ内の指定保存キーで指定データを保存します。

指定のデータで年号情報を設定します。
パラメータ
name | String | 年号名称
key | String | 設定キー
year | Number | 年号の開始年
month | Number | 年号の開始月
day | Number | 年号の開始日
返却値
void
toADYear

static Number toADYear(String key ,Number year)

年号および年号年数より西暦年への変換をします。

年号および年数より、西暦年を算出して返却します。
パラメータ
key | String | 設定キー
year | Number | 年号年数
返却値
Number 指定データより求められる西暦年


 Module.client オブジェクト

ログインしているカレント・ユーザー情報に関するオブジェクト。

バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
String get(String key)
ログインユーザ情報を取得します。
メソッドの詳細
get

String get(String key)

ログインユーザ情報を取得します。

ユーザ情報取得用パラメータの詳細は以下の通り
パラメータ | 取得情報id | 導入バージョン
id | ログインユーザーコード | 2.0
name | ログインユーザー名 | 2.0
group | ログイングループID | 2.0
locale | ログインロケール | 5.0
encoding | ログインエンコーディング | 5.0
colorPatternId | カラーパターンID | 5.0
mail | ログインユーザーメールアドレス | 2.0
mblmail | ログインユーザーモバイル用メールアドレス | 2.0
パラメータ
key String ユーザ情報取得用パラメータ
返却値
String 引数指定のログインユーザ情報


 Module.data オブジェクト

JavaScript の各種データを扱うオブジェクト。

メソッドの概要
static String varType(Object target)
変数データの型をチェックします。
メソッドの詳細
varType

static String varType(Object target)

変数データの型をチェックします。

 指定データの変数型をチェックして、型を示すキーワードを返却します。
 返却されるキーワードは以下のようになります。
 string : 文字列
 number : 数値
 boolean : 真偽値
 undefined : 未定義
 object : オブジェクト
 array : 配列
 date : 日付
 null : NULL
 function : 関数
パラメータ
target Object チェック対象データ
返却値
String 型を示すキーワード文字列


 Module.database オブジェクト

推奨されていません。DatabaseManagerに置き換えられました。
データベースにアクセスするためのオブジェクト。

各メソッドの引数に、”接続データベースの参照名”とありますが、この引数を指定した場合は、指定した引数値と同じ接続名のシステムデータベースへ接続されます。
これを指定しなかった場合、現在ログインしているログイングループIDと同じ接続名のシステムデータベースへ接続されます。
システムデータベースとは、ServerManager/conf/data-source.xml内で<system-data-source>タグで設定されているデータベースです。

このオブジェクトのメソッドでは、ログイングループのデータベースに接続されません。
ログイングループのデータベースに接続する場合は DatabaseManager を利用してください。
ログイングループのデータベースとは、ServerManager/conf/data-source.xml内で<group-data-source>タグで設定されているデータベースです。

メソッドの概要
static Object commit()
推奨されていません。DatabaseManager.commitに置き換えられました。
static Object commit(String name)
推奨されていません。DatabaseManager.commitに置き換えられました。
static Boolean contact()
推奨されていません。代替えメソッドはありません。
static Boolean contact(String name)
推奨されていません。代替えメソッドはありません。
static Boolean contact(Object info)
推奨されていません。代替えメソッドはありません。
static Number count(String tableName ,String where ,String name)
推奨されていません。DatabaseManager.getCount()に置き換えられました。
static Number count(String tableName ,String where)
推奨されていません。DatabaseManager.getCount()に置き換えられました。
static Number count(String tableName)
推奨されていません。DatabaseManager.getCount()に置き換えられました。
static String dateToString(Date date)
推奨されていません。DatabaseManager.dateToString()に置き換えられました。
static String dateToString(String year ,String month ,String month ,String month ,String month ,String month)
推奨されていません。DatabaseManager.dateToString()に置き換えられました。
static DataForStoredProc execStoredFunc(String functionName ,String returnType ,Array arrayArg ,String connectId)
推奨されていません。DatabaseManager.execStoredFunc()に置き換えられました。
static DataForStoredProc execStoredFunc(String functionName ,String returnType ,Array arrayArg)
推奨されていません。DatabaseManager.execStoredFunc()に置き換えられました。
static DataForStoredProc execStoredProc(String functionName ,Array arrayArg ,String connectId)
推奨されていません。DatabaseManager.execStoredProc()に置き換えられました。
static DataForStoredProc execStoredProc(String functionName ,Array arrayArg)
推奨されていません。DatabaseManager.execStoredProc()に置き換えられました。
static DbResultObject execute(String sql ,String connectId)
推奨されていません。DatabaseManager.execute()に置き換えられました。
static DbResultObject execute(String sql)
推奨されていません。DatabaseManager.execute()に置き換えられました。
static Object fetch(String sql ,Number start ,Number length ,String name)
推奨されていません。DatabaseManager.fetch()に置き換えられました。
static Object fetch(String sql ,Number start ,Number length)
推奨されていません。DatabaseManager.fetch()に置き換えられました。
static String getDbName(String name)
推奨されていません。DatabaseManager.getDbName()に置き換えられました。
static String getDbName()
推奨されていません。DatabaseManager.getDbName()に置き換えられました。
static String getDbVersion(String name)
推奨されていません。DatabaseManager.getDbVersion()に置き換えられました。
static String getDbVersion()
推奨されていません。DatabaseManager.getDbVersion()に置き換えられました。
static Boolean getEscape(String name)
推奨されていません。DatabaseManager.getEscape()に置き換えられました。
static Boolean getEscape()
推奨されていません。DatabaseManager.getEscape()に置き換えられました。
static Array getReference()
推奨されていません。DatabaseManager.getConnectIdsBySystem()に置き換えられました。
static Object getStoredArg()
推奨されていません。DatabaseManager.getStoredArg()に置き換えられました。
static DbResultObject insert(String tableName ,Object value ,String refName)
推奨されていません。DatabaseManager.execute()に置き換えられました。
static DbResultObject insert(String tableName ,Object value)
推奨されていません。DatabaseManager.execute()に置き換えられました。
static Boolean isColumn(String columnName ,String tableName ,String refName)
推奨されていません。DatabaseManager.isColumn()に置き換えられました。
static Boolean isColumn(String columnName ,String tableName)
推奨されていません。DatabaseManager.isColumn()に置き換えられました。
static Boolean isConnect(String refName)
推奨されていません。DatabaseManager.isConnect()に置き換えられました。
static Boolean isConnect()
推奨されていません。DatabaseManager.isConnect()に置き換えられました。
static Object max(String columnName ,String tableName ,String where ,String refName)
推奨されていません。DatabaseManager.getMax()に置き換えられました。
static Object max(String columnName ,String tableName ,String where)
推奨されていません。DatabaseManager.getMax()に置き換えられました。
static Object max(String columnName ,String tableName)
推奨されていません。DatabaseManager.getMax() に置き換えられました。
static Object min(String columnName ,String tableName ,String where ,String refName)
推奨されていません。DatabaseManager.getMin()に置き換えられました。
static Object min(String columnName ,String tableName ,String where)
推奨されていません。DatabaseManager.getMin()に置き換えられました。
static Object min(String columnName ,String tableName)
推奨されていません。DatabaseManager.getMin()に置き換えられました。
static Object mkConfData(String databaseType ,String prop ,Object refNamae)
推奨されていません。代替えメソッドはありません。
static Object remove(String tableName ,String where ,String refName)
推奨されていません。DatabaseManager.execute()に置き換えられました。
static Object remove(String tableName ,String where)
推奨されていません。DatabaseManager.execute()に置き換えられました。
static Object rollback(String refName)
推奨されていません。DatabaseManager.rollback()に置き換えられました。
static Object rollback()
推奨されていません。DatabaseManager.rollback()に置き換えられました。
static Object select(String sql ,String refName ,String max)
推奨されていません。DatabaseManager.select()に置き換えられました。
static Object select(String sql ,String refName)
推奨されていません。DatabaseManager.select()に置き換えられました。
static Object select(String sql)
推奨されていません。DatabaseManager.select()に置き換えられました。
static Boolean setDeleteSQL(Function func ,String refName)
推奨されていません。代替えメソッドはありません。
static Boolean setDeleteSQL(Function func)
推奨されていません。代替えメソッドはありません。
static Boolean setInsertSQL(Function func ,String refName)
推奨されていません。代替えメソッドはありません。
static Boolean setInsertSQL(Function func)
推奨されていません。代替えメソッドはありません。
static Boolean setUpdateSQL(Function func ,String refName)
推奨されていません。代替えメソッドはありません。
static Boolean setUpdateSQL(Function func)
推奨されていません。代替えメソッドはありません。
static Date toDate(String date)
推奨されていません。DatabaseManager.stringToDate()に置き換えられました。
static Object toList(Array src ,String key ,String data)
推奨されていません。Module.array.toList()に置き換えられました。
static Object transaction(String refName)
推奨されていません。DatabaseManager.beginTransaction()に置き換えられました。
static Object transaction()
推奨されていません。DatabaseManager.beginTransaction()に置き換えられました。
static Object update(String tableName ,String where ,Object value ,String refName)
推奨されていません。DatabaseManager.execute()に置き換えられました。
static Object update(String tableName ,String where ,Object value)
推奨されていません。DatabaseManager.execute()に置き換えられました。
メソッドの詳細
commit

static Object commit()

推奨されていません。DatabaseManager.commitに置き換えられました。
データベースアクセスの確定処理をします。

トランザクションの確定処理を行います。 トランザクションが開始されていない場合には働きません。
返却値
Object DbResultObjectオブジェクト
commit

static Object commit(String name)

推奨されていません。DatabaseManager.commitに置き換えられました。
データベースアクセスの確定処理をします。

トランザクションの確定処理を行います。 トランザクションが開始されていない場合には働きません。
パラメータ
name String 接続データベースの参照名
返却値
Object DbResultObjectオブジェクト
contact

static Boolean contact()

推奨されていません。代替えメソッドはありません。
データベース接続をします。

第1引数を指定しなかった場合は、現在ログインしているログイングループが デフォルトで使用するDBに接続を試みます。
返却値
Boolean
真値： 接続成功
偽値： 接続失敗
contact

static Boolean contact(String name)

推奨されていません。代替えメソッドはありません。
データベース接続をします。

第1引数に接続情報オブジェクトを渡すと、 [システム設定]-[データベース]、 [システム設定]-[マルチデータベース]画面でDB接続情報を登録しなくても、 接続情報オブジェクトの情報によってDBに接続することができます。
この方法で接続したDBにModule.database.select()などを行うときは、 必ずModule.database.select()などの引数に接続参照名を渡して下さい。
接続情報オブジェクトは、Module.database.mkConfData() Module.database.mkConfData() メソッドを使って取得します。
パラメータ
name String 接続データベースの参照名
返却値
Boolean
真値： 接続成功
偽値： 接続失敗
contact

static Boolean contact(Object info)

推奨されていません。代替えメソッドはありません。
データベース接続をします。

パラメータ
info Object 接続情報オブジェクト
返却値
Boolean
真値： 接続成功
偽値： 接続失敗
count

static Number count(String tableName ,String where ,String name)

推奨されていません。DatabaseManager.getCount()に置き換えられました。
指定条件に該当する表内のデータ件数を取得します。

パラメータ
tableName | String | テーブル名
where | String | "WHERE"を除いたWHERE句 (WHERE句なしで第3引数を指定するときはnullを入れます。)
name | String | 接続データベースの参照名
返却値
Number
成功： 件数
失敗： null
count

static Number count(String tableName ,String where)

推奨されていません。DatabaseManager.getCount()に置き換えられました。
指定条件に該当する表内のデータ件数を取得します。

パラメータ
tableName | String | テーブル名
where | String | "WHERE"を除いたWHERE句
返却値
Number
成功： 件数
失敗： null
count

static Number count(String tableName)

推奨されていません。DatabaseManager.getCount()に置き換えられました。
指定条件に該当する表内のデータ件数を取得します。

パラメータ
tableName String テーブル名
返却値
Number
成功： 件数
失敗： null
dateToString

static String dateToString(Date date)

推奨されていません。DatabaseManager.dateToString()に置き換えられました。
日付型変数から日付文字列を取得します。

日付を表わす日付型変数から日付をあらわす文字列を生成します。
引数が適正ではない場合の動作は未定義です。
日付型文字列は以下の形式に準拠する。
YYYY/MM/DD|hh:mm:ss
パラメータ
date Date 日付型変数
返却値
String 指定日付データを表わす文字列
dateToString

static String dateToString(String year ,String month ,String month ,String month ,String month ,String month)

推奨されていません。DatabaseManager.dateToString()に置き換えられました。
日付情報から日付文字列を取得します。

日付情報から日付をあらわす文字列を生成します。
引数が適正ではない場合の動作は未定義です。
日付型文字列は以下の形式に準拠します。
YYYY/MM/DD|hh:mm:ss
パラメータ
year | String | 年
month | String | 月
month | String | 日
month | String | 時間
month | String | 分
month | String | 秒
返却値
String 指定日付データを表わす文字列
execStoredFunc

static DataForStoredProc execStoredFunc(String functionName ,String returnType ,Array arrayArg ,String connectId)

推奨されていません。DatabaseManager.execStoredFunc()に置き換えられました。
ストアドファンクションを実行します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
このメソッドの返却値であるDataForStoredProcは必ず受け取り、 必要な 操作の後、必ずDataForStoredProcのclose()メソッドを呼び出して下さい。
パラメータ
functionName | String | storedFunction名
returnType | String | 返値の型（1-3を指定(1:String,2:Number,3:Date)
arrayArg | Array | 引数オブジェクト配列
connectId | String | DB接続参照名
返却値
DataForStoredProc DataForStoredProcオブジェクト
execStoredFunc

static DataForStoredProc execStoredFunc(String functionName ,String returnType ,Array arrayArg)

推奨されていません。DatabaseManager.execStoredFunc()に置き換えられました。
ストアドファンクションを実行します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
このメソッドの返却値であるDataForStoredProcは必ず受け取り、 必要な 操作の後、必ずDataForStoredProcのclose()メソッドを呼び出して下さい。
パラメータ
functionName | String | storedFunction名
returnType | String | 返値の型（1-3を指定(1:String,2:Number,3:Date)
arrayArg | Array | 引数オブジェクト配列
返却値
DataForStoredProc DataForStoredProcオブジェクト
execStoredProc

static DataForStoredProc execStoredProc(String functionName ,Array arrayArg ,String connectId)

推奨されていません。DatabaseManager.execStoredProc()に置き換えられました。
ストアドプロシジャーを実行します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
このメソッドの返却値であるDataForStoredProcは必ず受け取り、 必要な 操作の後、必ずDataForStoredProcのclose()メソッドを呼び出して下さい。
パラメータ
functionName | String | storedFunction名
arrayArg | Array | 引数オブジェクト配列(配列の要素は実際の引数の順番とします。)
connectId | String | DB接続参照名
返却値
DataForStoredProc DataForStoredProcオブジェクト
execStoredProc

static DataForStoredProc execStoredProc(String functionName ,Array arrayArg)

推奨されていません。DatabaseManager.execStoredProc()に置き換えられました。
ストアドプロシジャーを実行します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
このメソッドの返却値であるDataForStoredProcは必ず受け取り、 必要な 操作の後、必ずDataForStoredProcのclose()メソッドを呼び出して下さい。
パラメータ
functionName | String | storedFunction名
arrayArg | Array | 引数オブジェクト配列(配列の要素は実際の引数の順番とします。)
返却値
DataForStoredProc DataForStoredProcオブジェクト
execute

static DbResultObject execute(String sql ,String connectId)

推奨されていません。DatabaseManager.execute()に置き換えられました。
任意のＳＱＬ文をデータベースに対してリクエストします。

引数に指定されたＳＱＬ文をデータベースに対して発行する。 SQL文の最後には文末文字（";","/"など）をいれないで下さい。
パラメータ
sql | String | SQL名
connectId | String | 接続データベースの参照名
返却値
DbResultObject エラー・オブジェクト
execute

static DbResultObject execute(String sql)

推奨されていません。DatabaseManager.execute()に置き換えられました。
任意のＳＱＬ文をデータベースに対してリクエストします。

引数に指定されたＳＱＬ文をデータベースに対して発行する。 SQL文の最後には文末文字（";","/"など）をいれないで下さい。
パラメータ
sql String SQL名
返却値
DbResultObject エラー・オブジェクト
fetch

static Object fetch(String sql ,Number start ,Number length ,String name)

推奨されていません。DatabaseManager.fetch()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
nStart, nLength には、それぞれ数値（自然数）で 与えてください。（１?）
例）１０件目から２０件目までのデータが欲しい場合
Module.database.fetch(SQL, 10, 11);
引数 nStart を数値指定しなかった場合の初期値は 1 である。
引数 nLength を数値で指定しなかった場合の初期値は long の 最大値（0x7fffffff == 2147483647）である。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。 数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
sql | String | カーソルを当てるべき SQL 文を指定
start | Number | 取得するデータの開始レコード位置
length | Number | 取得するデータの最大レコード
name | String | 接続データベースの参照名
返却値
Object DataForDatabase型オブジェクト
fetch

static Object fetch(String sql ,Number start ,Number length)

推奨されていません。DatabaseManager.fetch()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
nStart, nLength には、それぞれ数値（自然数）で 与えてください。（１?）
例）１０件目から２０件目までのデータが欲しい場合
Module.database.fetch(SQL, 10, 11);
引数 nStart を数値指定しなかった場合の初期値は 1 である。
引数 nLength を数値で指定しなかった場合の初期値は long の 最大値（0x7fffffff == 2147483647）である。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。 数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
sql | String | カーソルを当てるべき SQL 文を指定
start | Number | 取得するデータの開始レコード位置
length | Number | 取得するデータの最大レコード
返却値
Object DataForDatabase型オブジェクト
getDbName

static String getDbName(String name)

推奨されていません。DatabaseManager.getDbName()に置き換えられました。
接続データベース名を取得します。

[システム設定]のデータベース設定画面で指定されたＤＢのバージョンを返します。 戻り値はデータベースに依存します。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
name String 複数ＤＢを使用する場合のＤＢ別名
返却値
String
成功： データベース名
失敗： null
getDbName

static String getDbName()

推奨されていません。DatabaseManager.getDbName()に置き換えられました。
接続データベース名を取得します。

[システム設定]のデータベース設定画面で指定されたＤＢのバージョンを返します。 戻り値はデータベースに依存します。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
返却値
String
成功： データベース名
失敗： null
getDbVersion

static String getDbVersion(String name)

推奨されていません。DatabaseManager.getDbVersion()に置き換えられました。
接続データベースのバージョンを取得します。

[システム設定]のデータベース設定画面で指定されたＤＢのバージョンを返す。 戻り値はデータベースに依存します。
パラメータ
name String 複数ＤＢを使用する場合のＤＢ別名
返却値
String
成功： データベース名
失敗： null
getDbVersion

static String getDbVersion()

推奨されていません。DatabaseManager.getDbVersion()に置き換えられました。
接続データベースのバージョンを取得します。

[システム設定]のデータベース設定画面で指定されたＤＢのバージョンを返す。 戻り値はデータベースに依存します。
返却値
String
成功： データベース名
失敗： null
getEscape

static Boolean getEscape(String name)

推奨されていません。DatabaseManager.getEscape()に置き換えられました。
ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

パラメータ
name String 接続データベースの参照名
返却値
Boolean
成功： ワイルドカード文字をエスケープするのに使用できる文字列
失敗： null
getEscape

static Boolean getEscape()

推奨されていません。DatabaseManager.getEscape()に置き換えられました。
ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

返却値
Boolean
成功： ワイルドカード文字をエスケープするのに使用できる文字列
失敗： null
getReference

static Array getReference()

推奨されていません。DatabaseManager.getConnectIdsBySystem()に置き換えられました。
データベース接続設定参照名配列を取得します。

返却値
Array 参照名あり：参照名配列 / 参照名なし：null
参照名あり： 参照名配列
参照名なし： null
getStoredArg

static Object getStoredArg()

推奨されていません。DatabaseManager.getStoredArg()に置き換えられました。
execStoredFunc(),execStoredProcに渡す引数作成オブジェクトを取得します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
返却値
Object DbStoredProcArgオブジェクト
insert

static DbResultObject insert(String tableName ,Object value ,String refName)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースにデータを追加挿入します。

データベースにインサート処理をします。
挿入データはオブジェクト形式のデータをセットします。
なお、オブジェクトのプロパティ名称は、挿入したいデータベース のカラム名称に等しく作成し、そのプロパティに対して挿入したい データをセットします。
パラメータ
tableName | String | 処理対象のデータベース表名
value | Object | 挿入データ
refName | String | 接続データベースの参照名
返却値
DbResultObject DbResultObjectオブジェクト
insert

static DbResultObject insert(String tableName ,Object value)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースにデータを追加挿入します。

データベースにインサート処理をします。
挿入データはオブジェクト形式のデータをセットします。
なお、オブジェクトのプロパティ名称は、挿入したいデータベース のカラム名称に等しく作成し、そのプロパティに対して挿入したい データをセットします。
パラメータ
tableName | String | 処理対象のデータベース表名
value | Object | 挿入データ
返却値
DbResultObject DbResultObjectオブジェクト
isColumn

static Boolean isColumn(String columnName ,String tableName ,String refName)

推奨されていません。DatabaseManager.isColumn()に置き換えられました。
データベースの表内の定義情報をチェックします。

データベースの表内に指定カラムが存在するか調べます。
パラメータ
columnName | String | 処理対象のデータベース表名
tableName | String | 挿入データ
refName | String | 接続データベースの参照名
返却値
Boolean
真値： 指定のカラムは存在する
偽値： 指定のカラムは存在しない
isColumn

static Boolean isColumn(String columnName ,String tableName)

推奨されていません。DatabaseManager.isColumn()に置き換えられました。
データベースの表内の定義情報をチェックします。

データベースの表内に指定カラムが存在するか調べます。
パラメータ
columnName | String | 処理対象のデータベース表名
tableName | String | 挿入データ
返却値
Boolean
真値： 指定のカラムは存在する
偽値： 指定のカラムは存在しない
isConnect

static Boolean isConnect(String refName)

推奨されていません。DatabaseManager.isConnect()に置き換えられました。
データベース接続の状態を確認します。

指定された設定で現在接続が確立されているかをチェックする。
動的コネクション数変更機能を使用している場合は、実際に 接続されているかどうかではなく、接続できる状態にあるかどうかを 返す。
一度データベースと接続されると、trueを返しつづけます。 (途中でデータベースがダウンした場合もtrueを返します。)
パラメータ
refName String 接続データベースの参照名
返却値
Boolean
真値： 接続されている
偽値： 接続されていない
isConnect

static Boolean isConnect()

推奨されていません。DatabaseManager.isConnect()に置き換えられました。
データベース接続の状態を確認します。

指定された設定で現在接続が確立されているかをチェックする。
動的コネクション数変更機能を使用している場合は、実際に 接続されているかどうかではなく、接続できる状態にあるかどうかを 返す。

一度データベースと接続されると、trueを返しつづけます。 (途中でデータベースがダウンした場合もtrueを返します。)
返却値
Boolean
真値： 接続されている
偽値： 接続されていない
max

static Object max(String columnName ,String tableName ,String where ,String refName)

推奨されていません。DatabaseManager.getMax()に置き換えられました。
テーブル内の指定カラムの最大値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
where | String | WHERE句(WHERE句なしで第4引数を指定するときはnullを入れます。)
refName | String | 接続データベースの参照名
返却値
Object
成功： DBのデータ型Object
失敗： null
max

static Object max(String columnName ,String tableName ,String where)

推奨されていません。DatabaseManager.getMax()に置き換えられました。
テーブル内の指定カラムの最大値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
where | String | WHERE句
返却値
Object
成功： DBのデータ型Object
失敗： null
max

static Object max(String columnName ,String tableName)

推奨されていません。DatabaseManager.getMax() に置き換えられました。
テーブル内の指定カラムの最大値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
返却値
Object
成功： DBのデータ型Object
失敗： null
min

static Object min(String columnName ,String tableName ,String where ,String refName)

推奨されていません。DatabaseManager.getMin()に置き換えられました。
テーブル内の指定カラムの最小値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
where | String | WHERE句(WHERE句なしで第4引数を指定するときはnullを入れます。)
refName | String | 接続データベースの参照名
返却値
Object
成功： DBのデータ型Object
失敗： null
min

static Object min(String columnName ,String tableName ,String where)

推奨されていません。DatabaseManager.getMin()に置き換えられました。
テーブル内の指定カラムの最小値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
where | String | WHERE句
返却値
Object 成功：DBのデータ型Object / 失敗：null
min

static Object min(String columnName ,String tableName)

推奨されていません。DatabaseManager.getMin()に置き換えられました。
テーブル内の指定カラムの最小値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
返却値
Object
成功： DBのデータ型Object
失敗： null
mkConfData

static Object mkConfData(String databaseType ,String prop ,Object refNamae)

推奨されていません。代替えメソッドはありません。
Module.database.contact()メソッドの引数に使用するデータベース接続情報オブジェクトを取得します。

接続参照名が第3引数の接続情報オブジェクトを取得します。
 第1引数には、以下の文字列を渡します。
 "DS"
 第2引数には、以下のようなオブジェクトを渡します。
 Object
 └ ds_ref_name    DataSourceへの参照名
パラメータ
databaseType | String | 接続データベースタイプ
prop | String | 接続情報
refNamae | Object | 接続データベースの参照名
返却値
Object 接続情報オブジェクト
remove

static Object remove(String tableName ,String where ,String refName)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースのデータを削除します。

データベースのデータを削除します。 条件を設定すると、条件に合致したすべてのレコードを削除します。
パラメータ
tableName | String | 処理対象のデータベース表名
where | String | 削除レコード検索条件(WHERE 句)
refName | String | 接続データベースの参照名
返却値
Object DbResultObjectオブジェクト
remove

static Object remove(String tableName ,String where)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースのデータを削除します。

データベースのデータを削除します。 条件を設定すると、条件に合致したすべてのレコードを削除します。
パラメータ
tableName | String | 処理対象のデータベース表名
where | String | 削除レコード検索条件(WHERE 句)
返却値
Object DbResultObjectオブジェクト
rollback

static Object rollback(String refName)

推奨されていません。DatabaseManager.rollback()に置き換えられました。
データベースアクセスのトランザクションを取り消します。

トランザクションの取り消し処理を行います。 トランザクションが開始されていない場合には働きません。
パラメータ
refName String 接続データベースの参照名
返却値
Object DbResultObjectオブジェクト
rollback

static Object rollback()

推奨されていません。DatabaseManager.rollback()に置き換えられました。
データベースアクセスのトランザクションを取り消します。

トランザクションの取り消し処理を行います。 トランザクションが開始されていない場合には働きません。
返却値
Object DbResultObjectオブジェクト
select

static Object select(String sql ,String refName ,String max)

推奨されていません。DatabaseManager.select()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
第3引数には数値型を指定して下さい。変数ではなく、直接数値を指定する場合は、parseInt,parseFloatなどを使用して 明示的に数値型にする必要があります。
例）Module.database.select(SQL,GROUP,parseInt(3));
パラメータ
sql | String | SQL文を指定します。(SELECT *** )
refName | String | 接続データベースの参照名
max | String | 最大取得行数 0は無制限
返却値
Object DataForDatabase型オブジェクト
select

static Object select(String sql ,String refName)

推奨されていません。DatabaseManager.select()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
sql | String | SQL文を指定します。(SELECT *** )
refName | String | 接続データベースの参照名
返却値
Object DataForDatabase型オブジェクト
select

static Object select(String sql)

推奨されていません。DatabaseManager.select()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
sql String SQL文を指定します。(SELECT *** )
返却値
Object DataForDatabase型オブジェクト
setDeleteSQL

static Boolean setDeleteSQL(Function func ,String refName)

推奨されていません。代替えメソッドはありません。
delete 文を作成する関数を登録します。

Module.database.remove(),Module.database.deleteData() 関数を実行した時にDBに対して実際に実行 されるSQL(DELETE文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
第二引数を省略すると、Module.database.remove(),Module.database.deleteData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func | Function | 関数
refName | String | DB接続参照名
返却値
Boolean
成功： true
失敗： false
setDeleteSQL

static Boolean setDeleteSQL(Function func)

推奨されていません。代替えメソッドはありません。
delete 文を作成する関数を登録します。

Module.database.remove(),Module.database.deleteData() 関数を実行した時にDBに対して実際に実行 されるSQL(DELETE文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
第二引数を省略すると、Module.database.remove(),Module.database.deleteData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func Function 関数
返却値
Boolean
成功： true
失敗： false
setInsertSQL

static Boolean setInsertSQL(Function func ,String refName)

推奨されていません。代替えメソッドはありません。
Insert 文を作成する関数を登録します。

Module.database.insert(),Module.database.insertData() 関数を実行した時にDBに対して実際に実行 されるSQL(INSERT文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
  使用目的としては、JavaScriptの日付型のデータをDBの日付型データに変換する時 などに利用する。
第二引数を省略すると、Module.database.insert(),Module.database.insertData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func | Function | 関数
refName | String | DB接続参照名
返却値
Boolean
成功： true
失敗： false
setInsertSQL

static Boolean setInsertSQL(Function func)

推奨されていません。代替えメソッドはありません。
Insert 文を作成する関数を登録します。

Module.database.insert(),Module.database.insertData() 関数を実行した時にDBに対して実際に実行 されるSQL(INSERT文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
  使用目的としては、JavaScriptの日付型のデータをDBの日付型データに変換する時 などに利用する。
第二引数を省略すると、Module.database.insert(),Module.database.insertData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func Function 関数
返却値
Boolean
成功： true
失敗： false
setUpdateSQL

static Boolean setUpdateSQL(Function func ,String refName)

推奨されていません。代替えメソッドはありません。
update 文を作成する関数を登録します。

Module.database.update(),Module.database.updateData() 関数を実行した時にDBに対して実際に実行 されるSQL(UPDATE文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
  使用目的としては、JavaScriptの日付型のデータをDBの日付型データに変換する時 などに利用します。
第二引数を省略すると、Module.database.update(),Module.database.updateData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func | Function | 関数
refName | String | DB接続参照名
返却値
Boolean
成功： true
失敗： false
setUpdateSQL

static Boolean setUpdateSQL(Function func)

推奨されていません。代替えメソッドはありません。
update 文を作成する関数を登録します。

Module.database.update(),Module.database.updateData() 関数を実行した時にDBに対して実際に実行 されるSQL(UPDATE文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
  使用目的としては、JavaScriptの日付型のデータをDBの日付型データに変換する時 などに利用します。
第二引数を省略すると、Module.database.update(),Module.database.updateData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func Function 関数
返却値
Boolean
成功： true
失敗： false
toDate

static Date toDate(String date)

推奨されていません。DatabaseManager.stringToDate()に置き換えられました。
字列から日付型変数を取得します。

日付を表わす文字列から日付型変数を生成します。
引数が適正ではない場合の動作は、未定義です。
日付型文字列は以下の形式に準拠します。
YYYY/MM/DD|hh:mm:ss
パラメータ
date String 日付を表わす文字列
返却値
Date 指定日付データを持つ日付型変数
toList

static Object toList(Array src ,String key ,String data)

推奨されていません。Module.array.toList()に置き換えられました。
オブジェクト型の配列データからオブジェクトを生成します。

プロパティ名を渡すと、そのオブジェクト内のプロパティのデータをプロパティ名にして、そのオブジェクトを返します。
第２引数に与えたプロパティ名のデータがプロパティの名称になります。
第３引数に与えたプロパティ名のデータがプロパティの値になります。
引数がない場合には、空のオブジェクトが返されます。
パラメータ
src | Array | オブジェクト型の配列
key | String | キーになるプロパティ名
data | String | データになるプロパティ名
返却値
Object 生成されたオブジェクト
transaction

static Object transaction(String refName)

推奨されていません。DatabaseManager.beginTransaction()に置き換えられました。
データベースアクセスのトランザクションを開始します。

このメソッドを発行した後は、必ず以下のいづれかのメソッドを発行しなければならない。
Module.database.commit()
Module.database.rollback()

パラメータ
refName String 接続データベースの参照名
返却値
Object DbResultObject型オブジェクト
transaction

static Object transaction()

推奨されていません。DatabaseManager.beginTransaction()に置き換えられました。
データベースアクセスのトランザクションを開始します。

このメソッドを発行した後は、必ず以下のいづれかのメソッドを発行しなければならない。
Module.database.commit()
Module.database.rollback()

返却値
Object DbResultObject型オブジェクト
update

static Object update(String tableName ,String where ,Object value ,String refName)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースのデータを更新します。

データベースのデータを更新(アップデート)します。
更新データは、オブジェクト形式でセットします。
なお、オブジェクトのプロパティ名称は、更新したいデータベースのカラム名称に等しく作成し、 そのプロパティに対して更新したいデータをセットします。
パラメータ
tableName | String | 処理対象のデータベース表名
where | String | 更新部分検索条件(WHERE 句)
value | Object | 更新データ
refName | String | 接続データベースの参照名
返却値
Object DbResultObjectオブジェクト
update

static Object update(String tableName ,String where ,Object value)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースのデータを更新します。

データベースのデータを更新(アップデート)します。
更新データは、オブジェクト形式でセットします。
なお、オブジェクトのプロパティ名称は、更新したいデータベースのカラム名称に等しく作成し、 そのプロパティに対して更新したいデータをセットします。
パラメータ
tableName | String | 処理対象のデータベース表名
where | String | 更新部分検索条件(WHERE 句)
value | Object | 更新データ
返却値
Object DbResultObjectオブジェクト


 Module.date オブジェクト

日付データの日情報に対して指定増分を加算するオブジェクト。

メソッドの概要
static Date | addDay(Date date ,Number plus) 日付データの日情報に対して指定増分を加算します。
static Date | addHour(Date date ,Number plus) 日付データの時間情報に対して指定増分を加算します。
static Date | addMinute(Date date ,Number plus) 日付データの分情報に対して指定増分を加算します。
static Date | addMonth(Date date ,Number plus) 日付データの月情報に対して指定増分を加算します。
static Date | addSecond(Date date ,Number plus) 日付データの秒情報に対して指定増分を加算します。
static Date | addYear(Date date ,Number plus) 日付データの年情報に対して指定増分を加算します。
static String | dayName(Date date) 曜日を表す文字列を取得します。
static Date | get(number year ,number month ,number day ,number hour ,number minute ,numbe second) 変数データの型をチェックします。
static Date | getFuture(Date target_a ,Date target_b) 未来を表す日付データを取得します。
static Date | getFuture(Date target_a) 未来を表す日付データを取得します。
static Date | getPast(Date target_a ,Date target_b) 過去を表す日付データを取得します。
static Date | getPast(Date target_a) 過去を表す日付データを取得します。
static Number | getYear(Date date) 西暦年を取得します。
static Number | interval(Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalDay(Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalHour(Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalMinute(Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalMonth(Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalSecond(Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalYear(Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Boolean | isBetween(Date left ,String l_op ,Date target ,String r_op ,Date right) 日付情報の範囲をチェックします。
static Boolean | isBetween(Date left ,String l_op ,Date target) 日付情報の範囲をチェックします。
static Boolean | isFuture(Date target) 日付データが未来を示すかどうかをチェックします。
static Boolean | isLeapYear(Date target) 閏年チェックをします。
static Boolean | isPast(Date target) 日付データが過去を示すかどうかをチェックします。
static Boolean | isValid(Number year ,Number month ,Number day) 日付データとしての正当性をチェックします 。
static String | monthName(Date target) 月を表す文字列を取得します。
static Date | today() “今日”という日付を表す日付オブジェクトを取得します。
メソッドの詳細
addDay

static Date addDay(Date date ,Number plus)

日付データの日情報に対して指定増分を加算します。

指定日付データの日情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addHour

static Date addHour(Date date ,Number plus)

日付データの時間情報に対して指定増分を加算します。

指定日付データの時間情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addMinute

static Date addMinute(Date date ,Number plus)

日付データの分情報に対して指定増分を加算します。

指定日付データの分情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addMonth

static Date addMonth(Date date ,Number plus)

日付データの月情報に対して指定増分を加算します。

指定日付データの月情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addSecond

static Date addSecond(Date date ,Number plus)

日付データの秒情報に対して指定増分を加算します。

指定日付データの秒情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addYear

static Date addYear(Date date ,Number plus)

日付データの年情報に対して指定増分を加算します。

指定日付データの年情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
dayName

static String dayName(Date date)

曜日を表す文字列を取得します。

以下の曜日を表すキーワード文字列を返却します。 Sunday : 日曜日 Monday : 月曜日 Tuesday : 火曜日 Wednesday: 水曜日 Thursday : 木曜日 Friday : 金曜日 Saturday : 土曜日
パラメータ
date Date 対象データ
返却値
String 指定の日付データが表す曜日を示すキーワード文字列
get

static Date get(number year ,number month ,number day ,number hour ,number minute ,numbe second)

変数データの型をチェックします。

指定された日付情報を表す日付型オブジェクトを生成して返却します。 引数 hour, minute, second を省略した場合、0 が適応されます。
パラメータ
year | number | 年（数字）
month | number | 月（数字）
day | number | 日（数字）
hour | number | 時（数字）
minute | number | 分（数字）
second | numbe | 秒（数字）
返却値
Date 指定日付を表す日付型オブジェクト
getFuture

static Date getFuture(Date target_a ,Date target_b)

未来を表す日付データを取得します。

引数に与えられた２つの日付データのうち、より未来を示す日付データを 返却します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Date ２つの日付データのうち未来を示す方の日付データ
getFuture

static Date getFuture(Date target_a)

未来を表す日付データを取得します。

このメソッドの実行時の“現在”を 表す日付データと引数 target_a との比較が行われ、 より未来を示す日付データを返却します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target_a Date チェック対象データa
返却値
Date メソッド実行時の“現在”を表す日付データと引数 target_aのうち未来を示す方の日付データ
getPast

static Date getPast(Date target_a ,Date target_b)

過去を表す日付データを取得します。

引数に与えられた２つの日付データのうち、より過去を示す日付データを 返却します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Date ２つの日付データのうち過去を示す方の日付データ
getPast

static Date getPast(Date target_a)

過去を表す日付データを取得します。

このメソッドの実行時の“現在”を 表す日付データと引数 target_a との比較が行われ、 より過去を示す日付データを返却します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target_a Date チェック対象データa
返却値
Date メソッド実行時の“現在”を表す日付データと引数 target_aのうち過去を示す方の日付データ
getYear

static Number getYear(Date date)

西暦年を取得します。

指定の日付データの表す年情報を４桁で返却します。 このメソッドでは西暦 0 〜 1000 年の間のデータを扱う事はできません。
パラメータ
date Date 対象データ
返却値
Number 指定日付データの表す西暦年
interval

static Number interval(Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“年”です。 返却データは、浮動小数点形式で表され、小数点以下は１２進法で 表されます。 例）23ヶ月→1.11年
パラメータ
target_a | Date | チェック対象データ a
target_b | Date | チェック対象データ b
返却値
Number ２つの日付データの時間的差分
intervalDay

static Number intervalDay(Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“日”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalHour

static Number intervalHour(Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“時間”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalMinute

static Number intervalMinute(Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“分”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalMonth

static Number intervalMonth(Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“月”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalSecond

static Number intervalSecond(Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“秒”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalYear

static Number intervalYear(Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“年”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
isBetween

static Boolean isBetween(Date left ,String l_op ,Date target ,String r_op ,Date right)

日付情報の範囲をチェックします。

チェック対象日付データを左辺および右辺の両境界における範囲チェック を指定のオペレーションでおこないます。
 チェックオペレータは、以下のキーワードにより指定します。
 "<" or ">"  ：大小比較１（同値は含まない）
 "<=" or ">="：大小比較２（同値も真とする）
 "= ="       ：同値比較（同値の場合を真とする）
 "<>" or "!="：異値比較（値が異なる場合を真とする）

 例）var datA = Module.date.get(2000, 1, 1);
     var datB = Module.date.get(2001, 1, 1);
     var datNow = Module.date.getToday();

 Module.date.isBetween(datA, "<=", datNow, "<", datB);
 この返却値で、“今日”が2000年であるかを判定できる。
 注意）このメソッドのチェックは、ミリ秒単位にて判定します。
 Module.date.isBetween(new Date() , "= =", new Date());
 これは、偽値(false)になる可能性があります。

パラメータ
left | Date | 左辺境界を表す日付データ
l_op | String | 左辺チェックオペレータ
target | Date | チェック対象日付データ
r_op | String | 右辺チェックオペレータ
right | Date | 右辺境界を表す日付データ
返却値
Boolean
真値：対象日付データは指定の範囲に合致
偽値：対象日付データは指定の範囲外を表します。
isBetween

static Boolean isBetween(Date left ,String l_op ,Date target)

日付情報の範囲をチェックします。

チェック対象日付データを左辺および右辺の両境界における範囲チェック を指定のオペレーションでおこないます。
 チェックオペレータは、以下のキーワードにより指定します。
 "<" or ">"  ：大小比較１（同値は含まない）
 "<=" or ">="：大小比較２（同値も真とする）
 "= ="       ：同値比較（同値の場合を真とする）
 "<>" or "!="：異値比較（値が異なる場合を真とする）

 例）var datA = Module.date.get(2000, 1, 1);
     var datB = Module.date.get(2001, 1, 1);
     var datNow = Module.date.getToday();

 Module.date.isBetween(datA, "<=", datNow, "<", datB);
 この返却値で、“今日”が2000年であるかを判定できる。
 注意）このメソッドのチェックは、ミリ秒単位にて判定します。
 Module.date.isBetween(new Date() , "= =", new Date());
 これは、偽値(false)になる可能性があります。

パラメータ
left | Date | 左辺境界を表す日付データ
l_op | String | 左辺チェックオペレータ
target | Date | チェック対象日付データ
返却値
Boolean
真値：対象日付データは指定の範囲に合致
偽値：対象日付データは指定の範囲外を表します。
isFuture

static Boolean isFuture(Date target)

日付データが未来を示すかどうかをチェックします。

指定の日付データが、このメソッド実行時における“現在”時間よりも 未来である場合 true を返却し、過去である場合 false を返却します。 指定の日付データが、このメソッド実行時における“現在”時間と 等しい場合には、false が返却されます。
パラメータ
target Date チェック対象データ
返却値
Boolean
真値：指定の日付データは、現在よりも未来
偽値：指定日付データは、現在よりも過去
isLeapYear

static Boolean isLeapYear(Date target)

閏年チェックをします。

指定日付の年が閏年に該当しているかをチェックしています。 太陽暦（グレゴリオ歴）を基本として計算されています。
パラメータ
target Date チェック対象データ
返却値
Boolean
真値：指定年は閏年
偽値：指定年は閏年ではない
isPast

static Boolean isPast(Date target)

日付データが過去を示すかどうかをチェックします。

指定の日付データが、このメソッド実行時における“現在”時間よりも 過去である場合 true を返却し、未来である場合 false を返却します。 指定の日付データが、このメソッド実行時における“現在”時間と 等しい場合には、false が返却されます。
パラメータ
target Date チェック対象データ
返却値
Boolean
真値：指定の日付データは、現在よりも過去
偽値：指定日付データは、現在よりも未来
isValid

static Boolean isValid(Number year ,Number month ,Number day)

日付データとしての正当性をチェックします 。

指定年月日情報が日付データとして正しい値である事をチェックします。
パラメータ
year | Number | チェック対象年
month | Number | チェック対象月
day | Number | チェック対象日
返却値
Boolean
真値：指定データは日付として正しい値を示している
偽値：指定データは日付データとして正しくない
monthName

static String monthName(Date target)

月を表す文字列を取得します。

以下の月を表すキーワード文字列を返却します。
January | : １月
February | : ２月
March | : ３月
April | : ４月
May | : ５月
June | : ６月
July | : ７月
August | : ８月
September | : ９月
October | : １０月
November | : １１月
December | : １２月

パラメータ
target Date チェック対象データ
返却値
String 指定日付データの表す月を示すキーワード文字列
today

static Date today()

“今日”という日付を表す日付オブジェクトを取得します。

実行時の日にちを表す日付型データを生成して返却します。
生成された日付型データの表す年月日情報は、メソッド実行時の日付を 表し、時間は 00:00:00:000 を表します。
返却値
Date “今日”を表す日付オブジェクト


 Module.download オブジェクト

データのダウンロード機能を提供するオブジェクト。

ファイルダウンロード・モジュールは、サーバーからクライアントに対してファイルを送信するための機能です。
ダウンロードには、HTTP プロトコルを利用します。

ファイル拡張子とＭＩＭＥタイプ
ダウンロード時には、ファイルの拡張子によって自動的にＭＩＭＥタイプが決定されます。
ファイル拡張子とＭＩＭＥの関係は、以下の表を参考にして下さい。

.pdf | application/pdf
.gif | image/gif
.html
.htm 		text/html
.jar | application/java-archive
.js | application/x-javascript
.jpeg
.jpg 		image/jpeg
.xls | application/vnd.ms-excel
.ppt | application/vnd.ms-powerpoint
.mp2 | audio/x-mpeg
.mpeg
.mpg 		video/mpeg
.txt
.text 		text/plain
.doc | application/msword

上記表でＭＩＭＥタイプを決定できない場合は、application/octet-stream が適応されます。

また、ダウンロードＡＰＩへの引数の与え方により、ダウンロードＡＰＩを利用するプログラム側で任意にＭＩＭＥタイプを指定することもできます。

注意事項
ファイルダウンロード・モジュールは、ブラウザへデータを送信するための機能です。

ダウンロードＡＰＩは、クライアントへのデータの送信時に文字コード変換を行いません。クライアントが受信する文字コード形式への適切な変換は、ダウンロードＡＰＩへデータを渡す前に、ダウンロードＡＰＩを利用するプログラム側で行うようにしてください。
メソッドの概要
static void | send(String stream ,String name ,String mime) 現在実行中のプログラムを中断して、指定データを送信します。
static void | send(String stream ,String name) 現在実行中のプログラムを中断して、指定データを送信します。
static void | send(String stream) 現在実行中のプログラムを中断して、指定データを送信します。
メソッドの詳細
send

static void send(String stream ,String name ,String mime)

現在実行中のプログラムを中断して、指定データを送信します。 （ブラウザ側では、指定されたデータのダウンロードになります。）

送信データはバイナリとして扱われます。テキストデータを送信する場合には、 このＡＰＩをコールする前に送信する対象となるテキストデータのローカル文字コード体系への明示的な変換をしておく必要があります。
引数 name に対して文字列を指定すると、ブラウザでデータをダウンロードした際のファイル名となります。
引数 mime に対して任意の MIME 形式を指定可能です。

このAPIは、try...catch 文では使用できません。
パラメータ
stream | String | 送信データ
name | String | ダウンロード時のファイル名
mime | String | ダウンロードデータの MIME タイプ
返却値
void
send

static void send(String stream ,String name)

現在実行中のプログラムを中断して、指定データを送信します。 （ブラウザ側では、指定されたデータのダウンロードになります。）

送信データはバイナリとして扱われます。テキストデータを送信する場合には、 このＡＰＩをコールする前に送信する対象となるテキストデータのローカル文字コード体系への明示的な変換をしておく必要があります。
指定ファイル名の拡張子、および unit/file_download/mime.ini で定義されているデータにより自動的に決定された MIME 形式で送信されます。 (MIME 形式を特定できなかった場合には application/octet-stream になります。)

このAPIは、try...catch 文では使用できません。
パラメータ
stream | String | 送信データ
name | String | ダウンロード時のファイル名
返却値
void
send

static void send(String stream)

現在実行中のプログラムを中断して、指定データを送信します。 （ブラウザ側では、指定されたデータのダウンロードになります。）

送信データはバイナリとして扱われます。テキストデータを送信する場合には、 このＡＰＩをコールする前に送信する対象となるテキストデータのローカル文字コード体系への明示的な変換をしておく必要があります。
ダウンロード時のファイル名は、適当なファイル名になります。（ブラウザの動作に依存します。）
指定ファイル名の拡張子、および unit/file_download/mime.ini で定義されているデータにより自動的に決定された MIME 形式で送信されます。 (MIME 形式を特定できなかった場合には application/octet-stream になります。)

このAPIは、try...catch 文では使用できません。
パラメータ
stream String 送信データ
返却値
void


 Module.external オブジェクト

各リクエスト間、各クライアント間、および各サーバ間で共有の値を操作するオブジェクト。

詳細

値は Shared Memory Service にて一元的に管理されます。 したがって、システム内のすべてのプログラムから値を共有することが可能です。
セッションタイムアウトによって値が破棄されることはありません。
値の保存はメモリ内で行われるので、すべての Shared Memory Service が再起動すると値は失われます。
共有データは、ログイングループ内でユニークになります (ログイングループが異なると共有空間も別になります)。
メソッドの概要
static Object | elements() カテゴリ内のすべての設定済みデータを取得します。
static String | get(String key) カテゴリ内の指定保存キーにマップされているデータを取得します。
static Array | keys() カテゴリ内の保存キー一覧を取得します。
static void | remove(String key) カテゴリ内の指定保存キーとマップされているデータを削除します。
static void | set(String key ,Object value) カテゴリ内の指定保存キーで指定データを保存します。
メソッドの詳細
elements

static Object elements()

カテゴリ内のすべての設定済みデータを取得します。

ログイングループ内共有データ群に対してすべての設定済みの データを返却します。
返却オブジェクトは、保存キーがプロパティ名称で保存キーにマップ されているデータが該当するプロパティの値として保存されます。
返却値
Object 全保存データ群
get

static String get(String key)

カテゴリ内の指定保存キーにマップされているデータを取得します。

ログイングループ内共有データ群において指定保存キーに マップされているデータを取得します。
指定保存キーに対応するキーが存在しない場合は null を返却します。
パラメータ
key String 値へのキーコード
返却値
String 保存キーにマップされているデータ
keys

static Array keys()

カテゴリ内の保存キー一覧を取得します。

ログイングループ内共有データ群に対してすべての設定済みの 保存キーを返却します。
保存キーの設定順と配列内の保存キーの格納順は保証されません。
返却値
Array 全保存キー一覧（配列型）
remove

static void remove(String key)

カテゴリ内の指定保存キーとマップされているデータを削除します。

ログイングループ内共有データ群において指定保存キーに マップされているデータと指定保存キーを削除します。
指定保存キーにマップされたデータが存在しない場合は null を返却します。
パラメータ
key String 値へのキーコード
返却値
void
set

static void set(String key ,Object value)

カテゴリ内の指定保存キーで指定データを保存します。

ログイングループ内共有データ群に対して指定保存キーを 指定データにマップする形で保存します。
保存対象データは null や undefined 以外の Java Script の変数型なら いかなるものでも保存対象として適応可能です。
ただし、プロトタイプオブジェクトにより保持されている情報に関しては、 保存対象外となります。
パラメータ
key | String | 保存キー
value | Object | 保存データ
返却値
void


 Module.formatfile オブジェクト

データをフォーマットされた形式のファイルとして出力するオブジェクト。

詳細

フォーマットされたデータファイルの出力先は Storage Service になります。 このため、分散システムを構築している場合においても、 データファイルの共有が可能であり、また環境に依存する事なくデータファイルを 操作する事が可能となります。
このＡＰＩでは、テキスト形式を前提としているため、 バイナリやサポート対象外の文字コード体系データを出力した場合、 データが破壊される可能性があります。
また、分散システムを構築している場合、Storage Service へデータを転送するため、 処理に時間がかかる場合があります。
メソッドの概要
static Boolean | append(String style ,String file ,Object data) フォーマットされたデータファイルの追記をします。
static Boolean | write(String style ,String file ,Object data) フォーマットされたデータファイルの出力をします。
メソッドの詳細
append

static Boolean append(String style ,String file ,Object data)

フォーマットされたデータファイルの追記をします。

指定フォーマットで指定ファイルへデータを書き出します。 ファイルは、Storage Service に出力されます。
指定名称のファイルが存在しない場合はファイルが新規作成され、指定名称のファイルが存在する場合は既存ファイルに追記されます。 出力ファイルパスは、Storage Service のインストールディレクトリ直下 storage/ ディレクトリからの相対になります。 出力データは、フォーマット定義プログラムの使用に合わせて渡すようにして下さい。 引数 style とフォーマットの関係は、以下の表を参考にして下さい。
引数 style | 出力形式 | 引数 data
style/csv | CSV 形式 | 二次元配列
style/pdf | ＰＤＦモジュール連携用 CSV 形式 | 二次元配列

パラメータ
style | String | フォーマットを表すキーワード
file | String | 出力ファイルパス
data | Object | 出力データ
返却値
Boolean 真値：ファイルの追記に成功 / 偽値：ファイルの追記に失敗
write

static Boolean write(String style ,String file ,Object data)

フォーマットされたデータファイルの出力をします。

指定フォーマットで指定ファイルへデータを書き出します。 ファイルは、Storage Service に出力されます。
指定名称のファイルが存在しない場合はファイルが新規作成され、指定名称のファイルが存在する場合は既存ファイルに上書きされます。
出力ファイルパスは、Storage Service のインストールディレクトリ直下 storage/ ディレクトリからの相対になります。 出力データは、フォーマット定義プログラムの使用に合わせて渡すようにして下さい。 引数 style とフォーマットの関係は、以下の表を参考にして下さい。
引数 style | 出力形式 | 引数 data
style/csv | CSV 形式 | 二次元配列
style/html | HTML 表形式 | 二次元配列
style/pdf | ＰＤＦモジュール連携用 CSV 形式 | 二次元配列

パラメータ
style | String | フォーマットを表すキーワード
file | String | 出力ファイルパス
data | Object | 出力データ
返却値
Boolean 真値：ファイルの追記に成功 / 偽値：ファイルの追記に失敗


 Module.grouping オブジェクト

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerに置き換えられました。
会社・組織、パブリックグループ、プライベートグループ データの登録、更新、削除するオブジェクト。

メソッドの概要
static Object | delBelongInfo(String user_cd ,String grouping_cd ,String main_flag ,String post_cd ,String groupId) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static Object | deleteData(Object args ,String logn_group_id ,Array execPaths) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static Object | deleteData(String grouping_cd ,String logn_group_id ,Array execPaths) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static void | deleteData(Object args ,String logn_group_id) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static void | deleteData(String grouping_cd ,String logn_group_id) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static Object | deletePostData(Object grouping_cd ,String post_cd ,String logn_group_id) 推奨されていません。CompnanyManagerのメソッドに置き換えられました。
static Array | getStruct(String grouping_cd ,String groupId) 推奨されていません。CompnanyManager,PublicGroupManagerの各メソッドに置き換えられました。
static Object | insertData(Object args ,String logn_group_id ,Array execPaths) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static Object | insertData(Object args ,String logn_group_id) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static Object | insertPostData(Object obj ,String logn_group_id) 推奨されていません。CompnanyManagerのメソッドに置き換えられました。
static Object | setBelongInfo(String user_cd ,String grouping_cd ,String main_flag ,String post_cd ,String groupId) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static Object | updateData(Object args ,String logn_group_id ,Array execPaths) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static Object | updateData(Object args ,String logn_group_id) 推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
static Object | updatePostData(Object obj ,String logn_group_id) 推奨されていません。CompnanyManagerのメソッドに置き換えられました。
メソッドの詳細
delBelongInfo

static Object delBelongInfo(String user_cd ,String grouping_cd ,String main_flag ,String post_cd ,String groupId)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
所属情報を削除します。

引数に該当する所属情報レコードを削除。 引数を一つも指定しない場合はエラーとする。 このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。

このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。
指定されたグループピングのグルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 組織所属削除 | CompanyListener#memeberDeleted
orgn | 組織所属削除 | CompanyListener#memberDeleted
official(トップの場合) | オフィシャルG所属削除 | PublicGroupListener#memberDeleted
official(トップ以外の場合) | オフィシャルG所蔵設定 | PublicGroupListener#memberDeleted
private | プライベートG所属設定 | PrivateGroupListener#memberDeleted

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
user_cd | String | ユーザコード(任意。指定しないときはnullをセットします。)
grouping_cd | String | グルーピングコード(任意。指定しないときはnullをセットします。)
main_flag | String | 主所属フラグ(任意。副所属 0/主所属 1。指定しないときはnullをセットします。) 主所属を指定できるのはグルーピングコードが会社・組織のときのみです。 デフォルト 0)
post_cd | String | 役職コード(任意。指定しないときはnullをセットします。)
groupId | String | ログイングループコード
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
deleteData

static Object deleteData(Object args ,String logn_group_id ,Array execPaths)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
グルーピングを削除します。

引数に該当する所属情報レコードを削除します。 引数を一つも指定しない場合はエラーとします。 このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。

このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。
指定されたグループピングのグルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 会社削除 | CompanyListener#departmentDeleted
orgn | 組織削除 | CompanyListener#departmentDeleted
official(トップの削除の場合) | オフィシャルG削除 | PublicGroupListener#groupSetDeleted
official(トップ以外の削除の場合) | オフィシャルG削除 | PublicGroupListener#publicGroupDeleteded
private | プライベートG削除 | PrivateGroupListener#privateGroupDeleteded

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
args | Object | グルーピングデータ格納オブジェクト
logn_group_id | String | ログイングループID
execPaths | Array | このメソッド内で呼び出したいJSのパス配列(任意)
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
deleteData

static Object deleteData(String grouping_cd ,String logn_group_id ,Array execPaths)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
グルーピングを削除します。

引数に該当する所属情報レコードを削除します。
引数を一つも指定しない場合はエラーとします。
このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。

このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。
指定されたグループピングのグルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 会社削除 | CompanyListener#departmentDeleted
orgn | 組織削除 | CompanyListener#departmentDeleted
official(トップの削除の場合) | オフィシャルG削除 | PublicGroupListener#groupSetDeleted
official(トップ以外の削除の場合) | オフィシャルG削除 | PublicGroupListener#publicGroupDeleteded
private | プライベートG削除 | PrivateGroupListener#privateGroupDeleteded

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
grouping_cd | String | グルーピングCD
logn_group_id | String | ログイングループID
execPaths | Array | このメソッド内で呼び出したいJSのパス配列(任意)
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
deleteData

static void deleteData(Object args ,String logn_group_id)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
グルーピングを削除します。

引数に該当する所属情報レコードを削除。 引数を一つも指定しない場合はエラーとする。 このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。

このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。
指定されたグループピングのグルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 会社削除 | CompanyListener#departmentDeleted
orgn | 組織削除 | CompanyListener#departmentDeleted
official(トップの削除の場合) | オフィシャルG削除 | PublicGroupListener#groupSetDeleted
official(トップ以外の削除の場合) | オフィシャルG削除 | PublicGroupListener#publicGroupDeleteded
private | プライベートG削除 | PrivateGroupListener#privateGroupDeleteded

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
args | Object | グルーピングデータ格納オブジェクト
logn_group_id | String | ログイングループID
返却値
void
deleteData

static void deleteData(String grouping_cd ,String logn_group_id)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
グルーピングを削除します。

引数に該当する所属情報レコードを削除します。 引数を一つも指定しない場合はエラーとする。 このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。

このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。
指定されたグループピングのグルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 会社削除 | CompanyListener#departmentDeleted
orgn | 組織削除 | CompanyListener#departmentDeleted
official(トップの削除の場合) | オフィシャルG削除 | PublicGroupListener#groupSetDeleted
official(トップ以外の削除の場合) | オフィシャルG削除 | PublicGroupListener#publicGroupDeleteded
private | プライベートG削除 | PrivateGroupListener#privateGroupDeleteded

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
grouping_cd | String | グルーピングCD
logn_group_id | String | ログイングループID
返却値
void
deletePostData

static Object deletePostData(Object grouping_cd ,String post_cd ,String logn_group_id)

推奨されていません。CompnanyManagerのメソッドに置き換えられました。
役職データを削除します。

 役職データ格納オブジェクト
 args.grouping_cd          グルーピング(String)[必須]
 args.post_cd              役職コード(String)[必須]
 args.post_name            役職名(String)[必須]
 args.notes                備考(String)
 args.sort_key             ソート番号(Number)
引数で指定した役職データを更新します。
このメソッドを実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
呼び出されるメソッドは、CompanyListener#postAddedです。
このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
grouping_cd | Object | グルーピングコード
post_cd | String | 役職コード
logn_group_id | String | ログイングループID
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
getStruct

static Array getStruct(String grouping_cd ,String groupId)

推奨されていません。CompnanyManager,PublicGroupManagerの各メソッドに置き換えられました。
第一引数グループの階層構造を取得します。

パラメータ
grouping_cd | String | グルーピングコード
groupId | String | ログイングループコード
返却値
Array 返却オブジェクトの配列
Object
cd | 組織コード
name | 組織名
上位階層から順番に入ります。
エラー時はnullです。
insertData

static Object insertData(Object args ,String logn_group_id ,Array execPaths)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
グルーピングを登録します。

グルーピングデータ格納オブジェクト
 args.grouping_cd          グルーピング(String)[必須]
 args.grouping_cls_cd      グルーピング種別CD(String)[必須]
                               プライベートG（"private"）、オフィシャルG（"official"）、
                               会社（"comp"）、組織（"orgn"）
 args.grouping_type        グルーピングタイプ(String) 互換していません
 args.grouping_name        グルーピング名(String)[必須]
 args.parent_grouping_cd   親グルーピングCD(String)
                               グルーピング種別CD(grouping_cls_cd)を会社("comp")にした場合は指定できません。
 args.grouping_name_kana   グルーピング名カナ(String)
 args.grouping_name_eng    グルーピング名英字(String)
 args.telephone_number     電話番号(String)
 args.fax_number           FAX番号(String)
 args.extension_number     内線番号(String)
 args.extension_fax_number 内線FAX番号(String)
 args.country_cd           国コード(String)
 args.zip_code             郵便番号(String)
 args.address              住所(String)
 args.address2             住所２(String)
 args.email_address1       メールアドレス1(String)
 args.email_address2       メールアドレス2(String)
 args.url                  URL(String)
 args.notes                備考(String)
 args.sort_key             ソート番号(Number)
 args.owner_cd             所有者CD(String)
                                プライベートGのみ必須
 args.zone                 公開ゾーンCD(Array)
 args.attribute            検索属性CD(Array)
 args.channel              販売チャネル(Array)
 args.calc_type_flag       税率計算方法(String、文字で０?２を指定) 互換していません
 以下、フレームワーク以外のパッケージ（スタートパックなど）が使用する予約項目
 args.reserve01 互換していません
 args.reserve02 互換していません
 args.reserve03 互換していません
 args.reserve04 互換していません
 args.reserve05 互換していません
 args.reserve06 互換していません
 args.reserve07 互換していません
 args.reserve08 互換していません
 args.reserve09 互換していません
 args.reserve10 互換していません
 args.reserve11 互換していません
 args.reserve12 互換していません
 args.reserve13 互換していません
 args.reserve14 互換していません
 args.reserve15 互換していません
引数で指定したグルーピングデータを登録します。 第３引数で指定されたJSファイルを呼び出し、実行します。
（Resource Serviceルートからのパスを拡張子なしで指定。呼び出すファイルが一つでも、必ず配列形式 で指定して下さい。呼び出すJSファイルの引数や戻り値の形式については、このメソッドの 引数(第3引数を除く)と戻り値と同じです。(Resource Serviceルート/system/config/goruping/grp_spl020.jsを参照してください。))
これら呼び出されたJSの実行すべて成功した場合のみ、グルーピングデータ を登録します。
このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。
このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。
グルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 会社登録 | CompanyListener#companyAdded
会社の分類区分設定 | CompanyListener#categoryDetailSet
orgn | 組織登録 | CompanyListener#departmentAdded
組織構成登録 | CompanyListener#departmentJoined
組織の分類区分登録 | CompanyListener#categoryDetailSet
official(トップの追加の場合) | オフィシャルG登録 | PublicGroupListener#groupSetAdded
オフィシャルG分類区分設定 | PublicGroupListener#categoryDetailSet
official(トップ以外の追加の場合) | オフィシャルG登録 | PublicGroupListener#publicGroupAdded
オフィシャルG構成登録 | PublicGroupListener#publicGroupJoined
オフィシャルG分類区分設定 | PublicGroupListener#categoryDetailSet
private | プライベートG登録 | PrivateGroupListener#privateGroupAdded

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
args | Object | グルーピングデータ格納オブジェクト
logn_group_id | String | ログイングループID
execPaths | Array | このメソッド内で呼び出したいJSのパス配列
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
insertData

static Object insertData(Object args ,String logn_group_id)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
グルーピングを登録します。

グルーピングデータ格納オブジェクト
 args.grouping_cd          グルーピング(String)[必須]
 args.grouping_cls_cd      グルーピング種別CD(String)[必須]
                               プライベートG（"private"）、オフィシャルG（"official"）、
                               会社（"comp"）、組織（"orgn"）
 args.grouping_type        グルーピングタイプ(String) 互換していません
 args.grouping_name        グルーピング名(String)[必須]
 args.parent_grouping_cd   親グルーピングCD(String)
                               グルーピング種別CD(grouping_cls_cd)を会社("comp")にした場合は指定できません。
 args.grouping_name_kana   グルーピング名カナ(String)
 args.grouping_name_eng    グルーピング名英字(String)
 args.telephone_number     電話番号(String)
 args.fax_number           FAX番号(String)
 args.extension_number     内線番号(String)
 args.extension_fax_number 内線FAX番号(String)
 args.country_cd           国コード(String)
 args.zip_code             郵便番号(String)
 args.address              住所(String)
 args.address2             住所２(String)
 args.email_address1       メールアドレス1(String)
 args.email_address2       メールアドレス2(String)
 args.url                  URL(String)
 args.notes                備考(String)
 args.sort_key             ソート番号(Number)
 args.owner_cd             所有者CD(String)
                                プライベートGのみ必須
 args.zone                 公開ゾーンCD(Array)
 args.attribute            検索属性CD(Array)
 args.channel              販売チャネル(Array)
 args.calc_type_flag       税率計算方法(String、文字で０?２を指定) 互換していません
 以下、フレームワーク以外のパッケージ（スタートパックなど）が使用する予約項目
 args.reserve01 互換していません
 args.reserve02 互換していません
 args.reserve03 互換していません
 args.reserve04 互換していません
 args.reserve05 互換していません
 args.reserve06 互換していません
 args.reserve07 互換していません
 args.reserve08 互換していません
 args.reserve09 互換していません
 args.reserve10 互換していません
 args.reserve11 互換していません
 args.reserve12 互換していません
 args.reserve13 互換していません
 args.reserve14 互換していません
 args.reserve15 互換していません
引数で指定したグルーピングデータを登録します。 このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。
このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。
グルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 会社登録 | CompanyListener#companyAdded
会社の分類区分設定 | CompanyListener#categoryDetailSet
orgn | 組織登録 | CompanyListener#departmentAdded
組織構成登録 | CompanyListener#departmentJoined
組織の分類区分登録 | CompanyListener#categoryDetailSet
official(トップの追加の場合) | オフィシャルG登録 | PublicGroupListener#groupSetAdded
オフィシャルG分類区分設定 | PublicGroupListener#categoryDetailSet
official(トップ以外の追加の場合) | オフィシャルG登録 | PublicGroupListener#publicGroupAdded
オフィシャルG構成登録 | PublicGroupListener#publicGroupJoined
オフィシャルG分類区分設定 | PublicGroupListener#categoryDetailSet
private | プライベートG登録 | PrivateGroupListener#privateGroupAdded

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
args | Object | グルーピングデータ格納オブジェクト
logn_group_id | String | ログイングループID
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
insertPostData

static Object insertPostData(Object obj ,String logn_group_id)

推奨されていません。CompnanyManagerのメソッドに置き換えられました。
役職データを登録します。

 役職データ格納オブジェクト
 args.grouping_cd          グルーピング(String)[必須]
 args.post_cd              役職コード(String)[必須]
 args.post_name            役職名(String)[必須]
 args.notes                備考(String)
 args.sort_key             ソート番号(Number)
引数で指定した役職データを登録します。
このメソッドを実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
呼び出されるメソッドは、CompanyListener#postAddedです。
このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
obj | Object | 役職データ格納オブジェクト
logn_group_id | String | ログイングループID
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
setBelongInfo

static Object setBelongInfo(String user_cd ,String grouping_cd ,String main_flag ,String post_cd ,String groupId)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
所属情報を登録します。

既に存在するレコードは更新します。 このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。

このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。
指定されたグループピングのグルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 組織所属設定 | CompanyListener#memebrSet
主所属設定 | CompanyListener#mainSet
主所属削除 | CompanyListener#mainRemoved
orgn | 組織所属設定 | CompanyListener#memberSet
主所属設定 | CompanyListener#mainSet
主所属削除 | CompanyListener#mainRemoved
official(トップの場合) | オフィシャルG所属設定 | PublicGroupListener#memberSet
official(トップ以外の場合) | オフィシャルG所蔵設定 | PublicGroupListener#memberSet
private | プライベートG所属設定 | PrivateGroupListener#memberSet

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
user_cd | String | ユーザコード
grouping_cd | String | グルーピングコード
main_flag | String | 主所属フラグ(任意。副所属 0/主所属 1。指定しないときはnullをセット。 主所属を指定できるのはグルーピングコードが会社・組織のときのみ。 デフォルト 0)
post_cd | String | 役職コード(任意。指定しないときはnullをセット。グルーピングコードが会社・組織のときのみ)
groupId | String | ログイングループコード
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
updateData

static Object updateData(Object args ,String logn_group_id ,Array execPaths)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
グルーピングデータを更新します。

グルーピングデータ格納オブジェクト
 args.grouping_cd          グルーピング(String)[必須]
 args.grouping_cls_cd      グルーピング種別CD(String)[必須]
                               プライベートG（"private"）、オフィシャルG（"official"）、
                               会社（"comp"）、組織（"orgn"）
 args.grouping_type        グルーピングタイプ(String) 互換していません
 args.grouping_name        グルーピング名(String)[必須]
 args.parent_grouping_cd   親グルーピングCD(String)
                               グルーピング種別CD(grouping_cls_cd)を会社("comp")にした場合は指定できません。
                               空文字列（""）を指定すると、階層の一番上に移動されます。
 args.grouping_name_kana   グルーピング名カナ(String)
 args.grouping_name_eng    グルーピング名英字(String)
 args.telephone_number     電話番号(String)
 args.fax_number           FAX番号(String)
 args.extension_number     内線番号(String)
 args.extension_fax_number 内線FAX番号(String)
 args.country_cd           国コード(String)
 args.zip_code             郵便番号(String)
 args.address              住所(String)
 args.address2             住所２(String)
 args.email_address1       メールアドレス1(String)
 args.email_address2       メールアドレス2(String)
 args.url                  URL(String)
 args.notes                備考(String)
 args.sort_key             ソート番号(Number)
 args.owner_cd             所有者CD(String)
                                プライベートGのみ必須
 args.zone                 公開ゾーンCD(Array)
 args.attribute            検索属性CD(Array)
 args.channel              販売チャネル(Array)
 args.calc_type_flag       税率計算方法(String、文字で０?２を指定) 互換していません
 以下、フレームワーク以外のパッケージ（スタートパックなど）が使用する予約項目
 args.reserve01 互換していません
 args.reserve02 互換していません
 args.reserve03 互換していません
 args.reserve04 互換していません
 args.reserve05 互換していません
 args.reserve06 互換していません
 args.reserve07 互換していません
 args.reserve08 互換していません
 args.reserve09 互換していません
 args.reserve10 互換していません
 args.reserve11 互換していません
 args.reserve12 互換していません
 args.reserve13 互換していません
 args.reserve14 互換していません
 args.reserve15 互換していません
引数で指定したグルーピングデータを更新します。 第３引数で指定されたJSファイルを呼び出し、実行します。
（Resource Serviceルートからのパスを拡張子なしで指定。呼び出すファイルが一つでも、必ず配列形式 で指定して下さい。呼び出すJSファイルの引数や戻り値の形式については、このメソッドの 引数(第3引数を除く)と戻り値と同じです。(Resource Serviceルート/system/config/goruping/grp_spl030.jsを参照))
これら呼び出されたJSの実行すべて成功した場合のみ、グルーピングデータ を更新します。
このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。
このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。

グルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 会社更新 | CompanyListener#departmentUpdated
会社の分類区分設定 | CompanyListener#categoryDetailSet
会社の分類区分削除 | CompanyListener#categoryDatailRemoved
orgn | 組織更新 | CompanyListener#departmentUpdated
組織構成移動 | CompanyListener#departmentMoved
組織の分類区分登録 | CompanyListener#categoryDetailSet
会社の分類区分削除 | CompanyListener#categoryDatailRemoved
official(トップの更新の場合) | オフィシャルG更新 | PublicGroupListener#groupSetAdded
オフィシャルG分類区分設定 | PublicGroupListener#categoryDetailSet
オフィシャルG分類区分削除 | PublicGroupListener#categoryDetailRemoved
official(トップ以外の更新の場合) | オフィシャルG更新 | PublicGroupListener#publicGroupAdded
オフィシャルG構成移動 | PublicGroupListener#publicGroupJoined
オフィシャルG分類区分設定 | PublicGroupListener#categoryDetailSet
オフィシャルG分類区分削除 | PublicGroupListener#categoryDetailRemoved
private | プライベートG更新 | PrivateGroupListener#privateGroupAdded

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
args | Object | グルーピングデータ格納オブジェクト
logn_group_id | String | ログイングループID
execPaths | Array | このメソッド内で呼び出したいJSのパス配列
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
updateData

static Object updateData(Object args ,String logn_group_id)

推奨されていません。CompnanyManager,PublicGroupManager,PrivateGroupManagerの各メソッドに置き換えられました。
グルーピングデータを更新します。

グルーピングデータ格納オブジェクト
 args.grouping_cd          グルーピング(String)[必須]
 args.grouping_cls_cd      グルーピング種別CD(String)[必須]
                               プライベートG（"private"）、オフィシャルG（"official"）、
                               会社（"comp"）、組織（"orgn"）
 args.grouping_type        グルーピングタイプ(String) 互換していません
 args.grouping_name        グルーピング名(String)[必須]
 args.parent_grouping_cd   親グルーピングCD(String)
                               グルーピング種別CD(grouping_cls_cd)を会社("comp")にした場合は指定できません。
                               空文字列（""）を指定すると、階層の一番上に移動されます。
 args.grouping_name_kana   グルーピング名カナ(String)
 args.grouping_name_eng    グルーピング名英字(String)
 args.telephone_number     電話番号(String)
 args.fax_number           FAX番号(String)
 args.extension_number     内線番号(String)
 args.extension_fax_number 内線FAX番号(String)
 args.country_cd           国コード(String)
 args.zip_code             郵便番号(String)
 args.address              住所(String)
 args.address2             住所２(String)
 args.email_address1       メールアドレス1(String)
 args.email_address2       メールアドレス2(String)
 args.url                  URL(String)
 args.notes                備考(String)
 args.sort_key             ソート番号(Number)
 args.owner_cd             所有者CD(String)
                                プライベートGのみ必須
 args.zone                 公開ゾーンCD(Array)
 args.attribute            検索属性CD(Array)
 args.channel              販売チャネル(Array)
 args.calc_type_flag       税率計算方法(String、文字で０?２を指定) 互換していません
 以下、フレームワーク以外のパッケージ（スタートパックなど）が使用する予約項目
 args.reserve01 互換していません
 args.reserve02 互換していません
 args.reserve03 互換していません
 args.reserve04 互換していません
 args.reserve05 互換していません
 args.reserve06 互換していません
 args.reserve07 互換していません
 args.reserve08 互換していません
 args.reserve09 互換していません
 args.reserve10 互換していません
 args.reserve11 互換していません
 args.reserve12 互換していません
 args.reserve13 互換していません
 args.reserve14 互換していません
 args.reserve15 互換していません
引数で指定したグルーピングデータを更新します。 このメソッドを実行すると、install.xmlファイル中に定義されているリスナーが呼び出されます。
会社や組織に対する処理を実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
オフィシャルGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/public-group-listener"に定義されているリスナーが呼び出されます。
プライベートGに対する処理を実行すると、install.xmlのパラメータ "system-install/listener/private-group-listener"に定義されているリスナーが呼び出されます。
このメソッドの実行により行われる処理と、呼び出されるリスナーの対応は下記のようになります。

グルーピング種別CD | 実行される処理 | 呼び出されるリスナーのメソッド
comp | 会社更新 | CompanyListener#departmentUpdated
会社の分類区分設定 | CompanyListener#categoryDetailSet
会社の分類区分削除 | CompanyListener#categoryDatailRemoved
orgn | 組織更新 | CompanyListener#departmentUpdated
組織構成移動 | CompanyListener#departmentMoved
組織の分類区分登録 | CompanyListener#categoryDetailSet
会社の分類区分削除 | CompanyListener#categoryDatailRemoved
official(トップの更新の場合) | オフィシャルG更新 | PublicGroupListener#groupSetAdded
オフィシャルG分類区分設定 | PublicGroupListener#categoryDetailSet
オフィシャルG分類区分削除 | PublicGroupListener#categoryDetailRemoved
official(トップ以外の更新の場合) | オフィシャルG更新 | PublicGroupListener#publicGroupAdded
オフィシャルG構成移動 | PublicGroupListener#publicGroupJoined
オフィシャルG分類区分設定 | PublicGroupListener#categoryDetailSet
オフィシャルG分類区分削除 | PublicGroupListener#categoryDetailRemoved
private | プライベートG更新 | PrivateGroupListener#privateGroupAdded

このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
args | Object | グルーピングデータ格納オブジェクト
logn_group_id | String | ログイングループID
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ
updatePostData

static Object updatePostData(Object obj ,String logn_group_id)

推奨されていません。CompnanyManagerのメソッドに置き換えられました。
役職データを登録します。

 役職データ格納オブジェクト
 args.grouping_cd          グルーピング(String)[必須]
 args.post_cd              役職コード(String)[必須]
 args.post_name            役職名(String)[必須]
 args.notes                備考(String)
 args.sort_key             ソート番号(Number)
引数で指定した役職データを更新します。 このメソッドを実行すると、install.xmlのパラメータ "system-install/listener/department-listener"に定義されているリスナーが呼び出されます。
呼び出されるメソッドは、CompanyListener#postAddedです。
このメソッドは内部でDBトランザクションを発行しています。 このメソッドをDBトランザクション内で使用しないで下さい。
パラメータ
obj | Object | 役職データ格納オブジェクト
logn_group_id | String | ログイングループID
返却値
Object 返却オブジェクト
error | エラーフラグ (true :エラーあり／false : エラーなし)
code | エラーコード (0 : エラーなし／その他)
message | エラーメッセージ


 Module.ldap オブジェクト

LDAPサーバにアクセスするオブジェクト。

メソッドの概要
static Object | add(String dn ,String name ,String value ,Object env) 属性値を追加します。
static Object | del(String dn ,String name ,String value ,Object env) 属性値を削除します。
static Object | get(String DN ,Object env) 属性値を検索します。
static Object | modify(String DN ,String id ,String new_val ,String old_val ,Object env) 属性値の変更をします。
static Object | search(String DN ,String filter ,Object env) 属性値を検索します。
メソッドの詳細
add

static Object add(String dn ,String name ,String value ,Object env)

属性値を追加します。

第4引数にLDAP接続情報オブジェクトを指定します。
LDAP接続情報オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 env.dn = "uid=ldap1,ou=People, o=intra.intra-mart.com";
 env.pwd = "ldap1";
 var ret = Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-789",env);
 Debug.browse(ret,Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env));
パラメータ
dn | String | 識別名
name | String | 属性名
value | String | 属性値（Stringのみ）
env | Object | 接続情報
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
del

static Object del(String dn ,String name ,String value ,Object env)

属性値を削除します。

第2引数に指定した属性の中で、第3引数にマッチした値を削除します。
第3引数を指定したくない場合は、undefinedを指定して下さい。
第4引数にLDAP接続情報オブジェクトを指定します。
オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 env.dn = "uid=ldap1,ou=People, o=intra.intra-mart.com";
 env.pwd = "ldap1";
 Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7890",env);
 Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7891",env);
 var ret1 = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 var ret2 = Module.ldap.del("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7890",env);
 var ret3 = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 Debug.browse(ret1,ret2,ret3);
パラメータ
dn | String | 識別名
name | String | 属性名
value | String | 属性値
env | Object | 接続情報
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
get

static Object get(String DN ,Object env)

属性値を検索します。

第1引数にマッチした属性値を取得します。
第2引数にLDAP接続情報オブジェクトを指定します。
LDAP接続情報オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 var ret = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 Debug.browse(ret);
パラメータ
DN | String | 識別名
env | Object | 接続情報Object
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
data 取得データObject(検索結果がない場合は空Object)
属性名=属性値の配列(属性値が一つの場合も配列形式)
modify

static Object modify(String DN ,String id ,String new_val ,String old_val ,Object env)

属性値の変更をします。

第2引数に指定した属性の中で、第4引数にマッチした値を第3引数の値に置き換えます。
第4引数を指定しない場合は、属性名に関連する値は全て第3引数の値になります。
第4引数を指定したくない場合は、undefinedを指定して下さい。
第5引数にLDAP接続情報オブジェクトを指定します。
LDAP接続情報オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 env.dn = "uid=ldap1,ou=People, o=intra.intra-mart.com";
 env.pwd = "ldap1";
 Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7890",env);
 Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7891",env);
 var ret1 = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 var ret2 = Module.ldap.modify("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-78900","5123-7890",env);
 var ret3 = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 Debug.browse(ret1,ret2,ret3);
パラメータ
DN | String | 識別名
id | String | 属性名
new_val | String | 変更後の属性値（Stringのみ）
old_val | String | 変更前の属性値（Stringのみ。）
env | Object | 接続情報Object
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
data 取得データObject(検索結果がない場合は空Object)
属性名=属性値の配列(属性値が一つの場合も配列形式)
search

static Object search(String DN ,String filter ,Object env)

属性値を検索します。

第2引数にマッチした属性値を取得します。 第2引数の検索フィルターの詳細は RFC 2254 を参照して下さい。 第3引数にLDAP接続情報オブジェクトを指定します。
LDAP接続情報オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 var ret = Module.ldap.search("ou=People,o=intra.intra-mart.com","(&(uid=ld*)(objectclass=*)",env);
 Debug.browse(ret);

パラメータ
DN | String | 識別名
filter | String | 検索フィルター(フィルターの解釈は、RFC 2254 に基づいています。)
env | Object | 接続情報Object
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
data 取得データObject(検索結果がない場合は空Object)
属性名=属性値の配列(属性値が一つの場合も配列形式)


 Module.logingp オブジェクト

推奨されていません。LoginGroupManagerに置き換えられました。
ログイングループ情報を操作するオブジェクト。

メソッドの概要
static Number count()
推奨されていません。LoginGroupManager.countLoginGroup()に置き換えられました。
static Boolean del(String key ,String groupId)
ログイングループ付随情報を削除します。
static Array entries()
推奨されていません。LoginGroupManager.getLoginGroupIds()に置き換えられました。
static Object get(String key ,String groupId)
ログイングループ付随情報を取得します。
static Boolean isGroup(String groupId)
推奨されていません。LoginGroupManager.getLoginGroupに置き換えられました。
static Boolean remove(String groupId)
推奨されていません。LoginGroupManager.deleteLoginGroup()に置き換えられました。
static Boolean set(String key ,Object data ,String groupId)
ログイングループ付随情報をセットします。
メソッドの詳細
count

static Number count()

推奨されていません。LoginGroupManager.countLoginGroup()に置き換えられました。
登録されているログイングループ数を返します。

返却値
Number ログイングループ数
del

static Boolean del(String key ,String groupId)

ログイングループ付随情報を削除します。

set()メソッドで登録した値を削除します。
パラメータ
key | String | データのキー
groupId | String | ログイングループID
返却値
Boolean 真値：成功 偽値：失敗
entries

static Array entries()

推奨されていません。LoginGroupManager.getLoginGroupIds()に置き換えられました。
登録されているログイングループIDの配列を取得します。

返却値
Array 成功：ログイングループIDの配列 / 値がないとき：null
get

static Object get(String key ,String groupId)

ログイングループ付随情報を取得します。

パラメータ
key | String | データのキー
groupId | String | ログイングループID
返却値
Object set()メソッドで登録した値 / ない場合: null
isGroup

static Boolean isGroup(String groupId)

推奨されていません。LoginGroupManager.getLoginGroupに置き換えられました。
指定のログイングループの存在チェックをします。

パラメータ
groupId String ログイングループID
返却値
Boolean 真値：ある / 偽値：ない
remove

static Boolean remove(String groupId)

推奨されていません。LoginGroupManager.deleteLoginGroup()に置き換えられました。
指定のログイングループ情報を全て削除します。

指定のログイングループに関する情報 （ロール、ユーザ、メニュー、 リンク、データベース接続参照名、カレンダー、バッチ処理、メッセージ） をすべて削除します。 現在ログインしているグループは削除しません。
パラメータ
groupId String ログイングループID
返却値
Boolean 真値：成功 / 偽値：失敗(現在ログイン中のグループが指定されたため。)
set

static Boolean set(String key ,Object data ,String groupId)

ログイングループ付随情報をセットします。

指定のログイングループに関連するデータを登録します。 第1引数：データのキーのprefixに"IM_"は使用できません。システムが 使用します。
パラメータ
key | String | データのキー
data | Object | (String、Numberのみ)
groupId | String | ログイングループID
返却値
Boolean 真値：成功 / 偽値：失敗(現在ログイン中のグループが指定されたため。)


 Module.mailpool オブジェクト

メール・プール機能を提供するオブジェクト。

このＡＰＩを利用する事で、何らかの送信に失敗したメールを再送する事ができます。
この機能では、メールの送信通知と送信処理の２つの機能を有しており、 メールの送信通知においては、送信するメールの情報を貯える処理を行い、 実際にメールが送信されるのは、メールの送信処理時になります。
よって、メール送信通知とメール送信の間に、若干の時間的誤差が生じる事になります。

メソッドの概要
static Number | delivery() メールの配信処理を行います。
static Boolean | post(Array to ,Array cc ,Array bcc ,String from ,String subject ,String body ,Object header ,Array attachment) メールの送信設定を行います。
メソッドの詳細
delivery

static Number delivery()

メールの配信処理を行います。

送信通知されているメールを配信します。
このＡＰＩが実行された時点でプールされているメール情報すべてが、 配信対象となります。
プールされている量が多い場合、処理に時間がかかる事があります。
このＡＰＩは、プールされているすべてのメールを配信対象とするため、 実行時のボトルネックとなる可能性があります。
このＡＰＩを利用したメール配信専用バッチスクリプトが用意されています。
バッチ設定画面にて適切に設定した上で、ご利用ください。
このＡＰＩは、マルチ・グループに対応していません。

返却値
Number ログイングループ数
post

static Boolean post(Array to ,Array cc ,Array bcc ,String from ,String subject ,String body ,Object header ,Array attachment)

メールの送信設定を行います。

メールの送信設定を行います。 この時点では、メールは送信されません。
ここで設定したメールは delivery() ＡＰＩが実行された時に送信されます。
必須指定の引数を適切に設定しなかった場合には、メールを正しく送信できない場合があります。
また、任意指定の引数は、不要な場合には、null 値を指定して下さい。
引数 to, cc, bcc に対しては、送信先メールアドレスを必要な個数分だけ配列として指定します。
この時、配列の個数は送信先の数に等しくなるようにします。
引数 to, cc, bcc, from には、メールアドレスのみを指定するようにしてください。
メールアドレス以外の文字が含まれている場合、メール送信時にエラーとなる場合があります。
引数 header には、メールヘッダに含める情報を任意に指定できます。
引数 header はオブジェクト形式であり、オブジェクトのプロパティ名がヘッダ名称となり プロパティ値がそのメールヘッダ名に対応する値となるようにデータオブジェクトを作成して下さい。
引数 attachment に指定するファイルは、intra-mart File Server が対象となります。
このＡＰＩは、マルチ・グループに対応していません。
パラメータ
to | Array | 宛先(必須)
cc | Array | 宛先(任意)
bcc | Array | 宛先(任意)
from | String | 差出人(必須)
subject | String | メールタイトル(必須)
body | String | メールの本文(必須)
header | Object | 任意のメールヘッダ内容(任意)
attachment | Array | 添付ファイル名称(任意)
返却値
Boolean 真値：設定に成功 / 偽値：設定時に何らかのエラーが発生


 Module.message オブジェクト

推奨されていません。MessageManagerに置き換えられました。
メッセージマスタの設定情報を扱うオブジェクト。

メソッドの概要
static String get(String id)
推奨されていません。MessageManager.getMessage()に置き換えられました。
メソッドの詳細
get

static String get(String id)

推奨されていません。MessageManager.getMessage()に置き換えられました。
指定のメッセージを取得します。

メッセージマスタに登録されている指定の保存キーに該当する メッセージ文字列を返却します。
パラメータ
id String メッセージ保存キー
返却値
String 保存キーに該当するメッセージ


 Module.mobile オブジェクト

モバイル用画面開発時に必要になる各種機能を提供するオブジェクト。

メソッドの概要
static void alert(String id ,String detail ,String path ,String args)
警告画面を表示します。
メソッドの詳細
alert

static void alert(String id ,String detail ,String path ,String args)

警告画面を表示します。

メッセージマスタに登録されている指定の保存キーに該当する メッセージ文字列を警告画面として表示します。
このＡＰＩを実行すると、以降のプログラムは実行が中断されて、強制的に警告画面が表示されます。
引数 detail に渡した文字列を警告メッセージとは別に同じ画面内に詳細メッセージとして表示します。
引数 path には、警告画面の次に表示するページパスを指定します。
ページパスは、システムルートからの相対形式で拡張子を省略した形で指定します。
引数 args に対してオブジェクトを指定すると、遷移先ページ(path) の init() 関数で request オブジェクトとしてデータを渡す事ができます。

このAPIは、try...catch 文では使用できません。
パラメータ
id | String | メッセージID
detail | String | 詳細メッセージ
path | String | 遷移先ページ
args | String | 遷移先ページへの引数データ
返却値
void


 Module.number オブジェクト

数値データを扱うメソッドを提供するオブジェクト。

メソッドの概要
static Array | getArray(Number min ,Number max ,Number step) 配列を作成します。
static Number | round(Number target ,Number point) 数値の四捨五入をします。
static Number | toFloat(Object target) データの実数変換を行います。
static Number | toInt(Object target) データの整数変換を行います。
メソッドの詳細
getArray

static Array getArray(Number min ,Number max ,Number step)

配列を作成します。

要素 min で始まり step ずつ増加する max までの要素を持つ配列データ を作成して返却します。
引数 step を省略した場合の増分は 1 になります。
パラメータ
min | Number | 要素開始番号
max | Number | 要素終了番号
step | Number | 要素番号の増分
返却値
Array 作成された配列
round

static Number round(Number target ,Number point)

数値の四捨五入をします。

指定の数値を指定の桁で四捨五入した結果を返却します。
パラメータ
target | Number | チェック対象データ
point | Number | 四捨五入結果の数値
返却値
Number 数値配列
toFloat

static Number toFloat(Object target)

データの実数変換を行います。

引数 target を実数値に変換します。 変換対象データが文字列の場合は、parsefloat() と同様の振る舞いを します。 変換結果が非数(NaN)になった場合は、0 を返却します。
パラメータ
target Object 対象データ
返却値
Number 数値変換されたデータ
toInt

static Number toInt(Object target)

データの整数変換を行います。

引数 target を数値に変換します。 変換対象データが小数であった場合、整数に丸め込まれます。 変換対象データが文字列の場合は、parseInt() と同様の振る舞いを します。 変換結果が非数(NaN)になった場合は、0 を返却します。
パラメータ
target Object 対象データ
返却値
Number 数値変換されたデータ


 Module.string オブジェクト

文字列データを扱うメソッドを提供するオブジェクト。

メソッドの概要
static String | browse(String target) ＨＴＭＬ特殊文字を変換します。
static Array | chars(String target) 文字配列を取得します。
static String | from(Object target) 文字列を取得します。
static Boolean | isASCII(String target) ＡＳＣＩＩコードチェックをします。
static Number | quantity(String target ,String searchWord) 部分文字列の個数を取得します。
static Number | refer(String target ,String piece ,String condition) キーワードの個数の取得をします。
static Number | size(String target) 文字列長を取得します。
メソッドの詳細
browse

static String browse(String target)

ＨＴＭＬ特殊文字を変換します。

ＨＴＭＬ形式でブラウザに表示するための特殊文字の変換をします。 変換される文字は以下の通りです。
 < → &lt;
 > → &gt;
 & → &amp;
 " → &quot;
 半角スペース → &nbsp;
 改行・復帰 → <BR>

パラメータ
target String 対象データ
返却値
String 変換結果文字列
chars

static Array chars(String target)

文字配列を取得します。

引数で指定された文字列内の各文字が要素となる配列を生成して 返却します。
返却される配列の要素数は、引数で指定された文字列内の文字数に 等しくなります。
パラメータ
target String 文字列データ
返却値
Array 文字配列
from

static String from(Object target)

文字列を取得します。

指定のデータを文字列に変換して返却します。
文字列および数値データは文字列変換して返却します。
それ以外の型のデータである場合、長さが 0 の文字列を返却します。

パラメータ
target Object 対象データ
返却値
String 変換結果文字列
isASCII

static Boolean isASCII(String target)

ＡＳＣＩＩコードチェックをします。

指定の文字列が ASCII コードのみで構成されているかどうかを チェックして結果を返却します。
返却値が false であった場合、指定の文字列ないにはダブルバイト文字 が含まれている可能性があります。
パラメータ
target String 対象データ
返却値
Boolean 真値：ASCII コードのみで構成されている / 偽値：ASCII コード以外の文字データが含まれている
quantity

static Number quantity(String target ,String searchWord)

部分文字列の個数を取得します。

指定文字列(target)内の部分文字列(piece)の個数を返します。
返却値は、0 以上の正整数になります。
指定文字列内に部分文字列が１つも検索できなかった場合には、0 を 返します。

パラメータ
target | String | 文字列データ
searchWord | String | 検索キーワード
返却値
Number 個数
refer

static Number refer(String target ,String piece ,String condition)

キーワードの個数の取得をします。

文字列から指定キーワードの個数を条件検索します。
検索キーワードは複数指定可能です。その場合、各キーワード を半角スペースで区切って指定してください。
引数 condition には、文字列定数として "AND" または "OR" を指定してください(大文字小文字は問いません)。 "AND" を指定した場合には、AND 条件でキーワード検索します。
"OR" を指定した場合には、OR 条件でキーワード検索します。
指定が正しくない場合には、デフォルトで AND 条件が適応されます。
返却値は、0 以上の正整数になります。
指定文字列内に部分文字列が１つも検索できなかった場合には、0 を返します。
パラメータ
target | String | 文字列データ
piece | String | 検索する部分文字列群
condition | String | パターンマッチ条件キーワード("AND" or "OR")
返却値
Number 個数
size

static Number size(String target)

文字列長を取得します。

Unicode で扱われている文字列を [install_directory]/conf/imart.xml の server-charset で指定されているローカルの文字コード体系に変換した結果の文字列長を 返却します。
パラメータ
target String 文字列データ
返却値
Number 文字列のバイト数(単位は byte)


 Permanent オブジェクト

永続情報操作オブジェクト。

各リクエスト間、各クライアント間、および各サーバ間で共有の値を操作するＡＰＩを持つオブジェクトです。
値は Permanent Data Service で保管されるため、 システム内のすべてのプログラムにおいて値を共有可能です。
値にはセッションタイムアウトが存在しないので、永続的に保存されるます。
また、値の保存はファイルで行われるので、明示的な削除が行われない限り永久的に保存されます。
バージョン：1.0
導入されたバージョン：2.0
コンストラクタの概要
Permanent(String domain ,String group)
コンストラクタ。
メソッドの概要
Object | elements() カテゴリ内のすべての設定済みデータを取得します。
static Array | entries(String domain) カテゴリ・キーの一覧を取得します。
Object | extinction() カテゴリ・データを削除します。
Object | get(String key) カテゴリ内の指定保存キーにマップされているデータを取得します。
Array | keys() カテゴリ内の保存キーの一覧を取得します。
Object | remove(String key) カテゴリ内の指定保存キーとマップされているデータを削除します。
Object | set(String key ,Object value) カテゴリ内の指定保存キーで指定データを保存します。
コンストラクタの詳細
Permanent

Permanent(String domain ,String group)
コンストラクタ。

domain および group で解決される一意のカテゴリに対するデータ操作オブジェクトを提供します。
引数 domain は、データファイルの保存先ディレクトリ名称として利用されるので、ＯＳ環境に依存したファイル命名規則に準じた文字列を指定する必要があります。
domain がファイル命名規則に違反した場合は、正しくデータを入出力できません。
このインスタンスで操作されるデータは、Permanent Data Service の インストールディレクトリ/treasure/box/articles/ 以下に保存されます。
パラメータ
domain | String | 保存先ディレクトリ名
group | String | カテゴリ名称
メソッドの詳細
elements

Object elements()

カテゴリ内のすべての設定済みデータを取得します。

コンストラクタで指定されたカテゴリに対して設定済みのすべてのデータを返却します。
返却オブジェクトは、保存キーがプロパティ名称で保存キーにマップされているデータが該当するプロパティの値として保存されます。
返却値
Object カテゴリ内の保存データ群
entries

static Array entries(String domain)

カテゴリ・キーの一覧を取得します。

domain に含まれる設定済みのカテゴリ・キーの一覧を返却します。
カテゴリの設定順と配列内のキーの格納順は保証されません。
パラメータ
domain String 保存先ディレクトリ名称
返却値
Array カテゴリ・キーの一覧（Stringの配列）
extinction

Object extinction()

カテゴリ・データを削除します。

コンストラクタで指定されたカテゴリに対して設定済みのすべてのデータを削除すると共にカテゴリ自身を削除します。
削除に成功した場合は、削除されたカテゴリ内データ群を返却します。
削除できなかった場合は、空のオブジェクトを返却します。
返却オブジェクトは、保存キーがプロパティ名称で保存キーにマップされているデータが該当するプロパティの値として保存されます。
返却値
Object 削除したカテゴリ・データ群
get

Object get(String key)

カテゴリ内の指定保存キーにマップされているデータを取得します。

コンストラクタで指定されたカテゴリ内において指定保存キーにマップされているデータを取得します。
指定保存キーに対応するキーが存在しない場合 null を返却します。
パラメータ
key String 値へのキーコード
返却値
Object 保存キーにマップされているデータ
keys

Array keys()

カテゴリ内の保存キーの一覧を取得します。

コンストラクタで指定されたカテゴリに対してすべての設定済みの保存キーを返却します。
保存キーの設定順と配列内の保存キーの格納順は保証されません。
返却値
Array カテゴリ内の保存キー一覧（Stringの配列）
remove

Object remove(String key)

カテゴリ内の指定保存キーとマップされているデータを削除します。

コンストラクタで指定されたカテゴリ内において指定保存キーにマップされているデータと指定保存キーを削除します。
返却値は削除されたデータを返却します。
指定保存キーにマップされたデータが存在しない場合は null を返却します。
パラメータ
key String 値へのキーコード
返却値
Object 保存キーにマップされていた値
set

Object set(String key ,Object value)

カテゴリ内の指定保存キーで指定データを保存します。

コンストラクタで指定されたカテゴリに対して指定保存キーを指定データにマップする形で保存します。
パラメータ
key | String | 保存キー
value | Object | 保存対象データ
返却値
Object 指定されたキーに関連した以前の値。キーが新しいものの場合は null。


 PermissionManager オブジェクト

パーミッションマネージャクラス。

パーミッションを生成するためのマネージャクラスです。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
PermissionManager(String groupId)
コンストラクタ。
メソッドの概要
Array | doSelection(Object category ,Object infos) 選択用情報を利用して選別された情報のリストを返却します。
Array | getCategories() 設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
コンストラクタの詳細
PermissionManager

PermissionManager(String groupId)
コンストラクタ。

パラメータ
groupId String ログイングループID
メソッドの詳細
doSelection

Array doSelection(Object category ,Object infos)

選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトです。
パラメータ
category Object カテゴリ
設定XMLファイルで定義されています。
infos Object 選択用情報
この情報を利用して、選別された情報のリストを作成して返却します。
文字列(String)または文字列の配列(Array)を指定します。
返却値
Array 選別された情報リスト
カテゴリが存在しなかった場合は、nullを返却します。
getCategories

Array getCategories()

設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
返却値
Array カテゴリ名配列
導入されたバージョン：5.0


 PrivateGroupManager オブジェクト

PrivateGroupManagerオブジェクト。

プライベートグループ情報の更新を行うマネージャオブジェクトです。

プライベートグループ情報を操作する場合に用いる プライベートグループ情報オブジェクトの構成は以下の通りです。
プライベートグループ情報ブジェクト
プライベートグループ情報
オブジェクト
(Object)
ownerCode 所有者コード (String)
privateGroupCode プライベートグループコード (String)
name プライベートグループ名 (String)
nameSyllabary プライベートグループ名カナ (String)
nameEnglish プライベートクループ名英字 (String)
notes 備考 (String)
sortKey ソートキー (Number)

プライベートグループ所属情報を操作する場合に用いる プライベートグループ所属情報オブジェクトの構成は以下の通りです。
プライベートグループ所属情報ブジェクト
プライベートグループ所属情報
オブジェクト
(Object)
ownerCode 所有者コード (String)
privateGroupCode プライベートグループコード (String)
userCode ユーザコード (String)
sortKey ソートキー (Number)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(処理失敗) or -2(引数オブジェクト不正) (Number)
message エラー発生時のメッセージ (String)

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
PrivateGroupManager(String user ,String group)
コンストラクタ
メソッドの概要
Object | addPrivateGroup(Object group) プライベートグループを登録します。
Object | deleteMember(Object groupAttach) プライベートグループから人員をはずします。
Object | deletePrivateGroup(Object group) 登録済のプライベートグループ情報を削除します。
Object | setMember(Object groupAttach) プライベートグループに人員を割り当てます。
Object | updatePrivateGroup(Object group) 登録済のプライベートグループ情報を更新します。
コンストラクタの詳細
PrivateGroupManager

PrivateGroupManager(String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addPrivateGroup

Object addPrivateGroup(Object group)

プライベートグループを登録します。

パラメータ
group Object プライベートグループ情報
返却値
Object 処理結果オブジェクト
deleteMember

Object deleteMember(Object groupAttach)

プライベートグループから人員をはずします。

指定された人員の情報が存在しない場合は処理失敗となります。
パラメータ
groupAttach Object プライベートグループ所属情報
返却値
Object 処理結果オブジェクト
deletePrivateGroup

Object deletePrivateGroup(Object group)

登録済のプライベートグループ情報を削除します。

指定されたプライベートグループの情報が存在しない場合は処理失敗となります。
パラメータ
group Object プライベートグループ情報
返却値
Object 処理結果オブジェクト
setMember

Object setMember(Object groupAttach)

プライベートグループに人員を割り当てます。

パラメータ
groupAttach Object プライベートグループ所属情報
返却値
Object 処理結果オブジェクト
updatePrivateGroup

Object updatePrivateGroup(Object group)

登録済のプライベートグループ情報を更新します。

パラメータ
group Object プライベートグループ情報
返却値
Object 処理結果オブジェクト


 Procedure オブジェクト

プロシージャクラス。
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
void define(String name ,Object func)
ＪＳ関数（オブジェクト等）を設定します。
メソッドの詳細
define

void define(String name ,Object func)

ＪＳ関数（オブジェクト等）を設定します。
関数を登録。以後 Procedure.name() で利用可能。
関数以外も登録可能（オブジェクトなど）。
パラメータ
name | String | 設定プロパティ名称（文字列）
func | Object | JS関数
返却値
void


 Procedure.age オブジェクト

推奨されていません。代替オブジェクトはありません。
年齢計算をするライブラリです。
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static Number | get(Date datBirthday) 推奨されていません。代替メソッドはありません。
static Number | getReal(Date datBirthday) 推奨されていません。代替メソッドはありません。
メソッドの詳細
get

static Number get(Date datBirthday)

推奨されていません。代替メソッドはありません。
満年齢を計算します。
誕生日を渡すと満年齢を求めて返します。
返却値である満年齢は、年月の小数型で、小数点以下は１２進法 の形で返されます。
例）14ヶ月 → 1.02年
23ヶ月 → 1.11年

パラメータ
datBirthday Date 誕生日
返却値
Number 年齢
getReal

static Number getReal(Date datBirthday)

推奨されていません。代替メソッドはありません。
実年齢を計算します。
返却値である実年齢は年月の小数型で、小数点以下は１２進法の形で返します。
例）14ヶ月 → 1.02年
23ヶ月 → 1.11年
実年齢とは、４月になると年を一つカウントする方式。
パラメータ
datBirthday Date 誕生日
返却値
Number 年齢


 Procedure.imode オブジェクト

推奨されていません。代替オブジェクトはありません。
i-modeオブジェクト。
i-modeアプリで使用する関数です。
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static Number | checkAbsence(String user_cd) 推奨されていません。代替メソッドはありません。
static Boolean | isDoCoMo() 推奨されていません。代替メソッドはありません。
static Object | sendMail(Object userObj ,Object cc ,String subject ,String body ,Object header) 推奨されていません。代替メソッドはありません。
メソッドの詳細
checkAbsence

static Number checkAbsence(String user_cd)

推奨されていません。代替メソッドはありません。
ユーザーの状態(会社内/外出)を取得する。
パラメータ
user_cd String 送り先のユーザーコード
返却値
Number 0:会社内 / 1:外出中 / -1:未設定
isDoCoMo

static Boolean isDoCoMo()

推奨されていません。代替メソッドはありません。
ユーザーエージェントがi-modeであるかを判定します。
i-modeであれば「真」を、
それ以外(NetscapeNavigatorやInternetExplorerなど) であれば「偽」を返す。
返却値
Boolean 真:i-mode/偽：i-mode以外
sendMail

static Object sendMail(Object userObj ,Object cc ,String subject ,String body ,Object header)

推奨されていません。代替メソッドはありません。
送り先のユーザーの状態(会社内/外出)によって送るアドレスを切り替えて
(通常のアドレス/ i-mode用アドレス)送信する。
パラメータ
userObj Object オブジェクト型配列
├ user:ユーザーコード
└ type:送信方法(0:通常アドレス 1:i-modeアドレス 2:外出設定による)
cc | Object | userObjと同じ
subject | String | メールの題目
body | String | 本文
header | Object | メールヘッダ情報（任意）
返却値
Object エラー・オブジェクト
├ Success: メール送信の成否(真値:正常終了 偽値:エラー終了)
├ ErrCode: エラーコード(APIリスト メール連携モジュール参照)
└ ErrMessage:エラーメッセージ


 Procedure.upload オブジェクト

推奨されていません。代替のオブジェクトはありません。
ファイルアップロードオブジェクト。

機能概要

ファイルアップロード・モジュールは、クライアントにあるファイルを サーバーに対して送信するための機能です。
アップロードには、HTTP プロトコルを利用します。

プレゼンテーションページとの連携

プレゼンテーション・ページでは、以下のようにフォームを構築します。
<IMART type='form' method='POST' enctype='multipart/form-data'>
    <INPUT type='file'>
    <INPUT type='submit'>
</IMART>

情報の取得方法

通常のリンクやフォームと同様に、ファンクションコンテナ内において request オブジェクトにてフォームの内容を取得できます。

注意事項

ファイルアップロード・モジュールは、ブラウザからアップロードされたファイルの内容をデータとして取得するための機能です。
アップロードされたファイルがサーバー上に保存されるわけではありません。
ファイルアップロード用のフォームからのデータは、文字コード変換が一切おこりません。
ファイルの内容や、それに付随する他のコントロールからのデータも、すべてローカルの文字コード体系(SYSTEM_CLIENT_CHARSET)となっています。
これらのデータをファンクション・コンテナ内で扱う場合には、Unicode 体系への明示的な文字コード変換が必要です
(Unicode への変換には Unicode API を利用して下さい)。
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static String getPath(String query ,String name)
推奨されていません。RequestParameter#getFileName()に置換えられました。
メソッドの詳細
getPath

static String getPath(String query ,String name)

推奨されていません。RequestParameter#getFileName()に置換えられました。
アップロードファイル名を取得します。
ファイルアップロード時の受信（アップロード）したファイルのファイル名を取得します。
引数 query には、request.query() の返却値を渡してください。
引数 name には、ファイルアップロードのフォーム内にある <INPUT type='file'>
のコントロール名称（name 属性値）を指定して下さい。
指定されたコントロール名称に該当するファイル名を返却します。
指定のコントロール名称が間違っている場合の動作は未定義です。
また、アップロードされたファイルのパスに空白文字が含まれている場合
ファイル名を正しく取得する事ができません。
パラメータ
query | String | ファイルアップロード時のＵＲＬクエリー
name | String | ファイルアップロードコントロールのコントロール名称
返却値
String ファイル名


 Procedure.AppCommonUtil オブジェクト

アプリケーション共通マスタで使用する共通関数です。
※注意 このクラスのメソッドはアプリケーション開発で使う必要はありません。

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | addTime(String dateString) YYYY/MM/DD形式の文字列に時刻(00:00:00)を付加します。
static String | formatDate(String dateString) 日付型文字列をイントラマートで定義された日付フォーマットに変換します。
static String | formatMsg(String msg) 終了日付を修正し、メッセージの体裁を整えます。
static String | getLoginGroup() ログイングループIDを取得します。
static String | getOffsetDate(String strDate ,Number nOffset) 引数strDateにstrOffsetの日数分、日付をずらします。
static String | getString(String value ,String substitute) 文字列のチェックをします。
static String | getSystemDate() システム日付を文字列型で返します。
static Object | getTransactionError() トランザクション処理失敗時の汎用的なエラー情報を返します。
static String | getUser() ログインユーザIDを取得します。
static String | getUserLocale() ユーザロケールを取得します。
static String | removeTime(String dateString) YYYY/MM/DD|hh:mm:ss形式の文字列から時刻(00:00:00)を除去します。
static String | setLineFeedCode(String string) 改行文字を改行コードに変換します。
static Array | split(String string ,String sep) 文字列を分割して配列に格納して返します。
static Date | stringToDate(String dateString) YYYY/MM/DD形式の文字列をDate型オブジェクトに変換します。
static Object | validateTerms(Object terms) 期間の整合性をチェックします。
メソッドの詳細
addTime

static String addTime(String dateString)

YYYY/MM/DD形式の文字列に時刻(00:00:00)を付加します。

パラメータ
dateString String 日付を表す文字列
返却値
String 日付を表す文字列
formatDate

static String formatDate(String dateString)

日付型文字列をイントラマートで定義された日付フォーマットに変換します。

パラメータ
dateString String 日時を表す文字列
返却値
String 日時を表す文字列
formatMsg

static String formatMsg(String msg)

終了日付を修正し、メッセージの体裁を整えます。

パラメータ
msg String 終了日付を含んだメッセージ
返却値
String 終了日付を修正したメッセージ
getLoginGroup

static String getLoginGroup()

ログイングループIDを取得します。
返却値
String ログイングループID
getOffsetDate

static String getOffsetDate(String strDate ,Number nOffset)

引数strDateにstrOffsetの日数分、日付をずらします。

パラメータ
strDate | String | 日付を表す文字列
nOffset | Number | オフセット日数
返却値
String オフセット後の日付を表す文字列
getString

static String getString(String value ,String substitute)

文字列のチェックをします。
第一引数で指定された文字列がNullまたは定義されていない場合に
第二引数で指定された文字列を返します。

パラメータ
value | String | チェック対象の文字列
substitute | String | 置換される文字列
返却値
String 文字列
getSystemDate

static String getSystemDate()

システム日付を文字列型で返します。

返却値
String 日時を表す文字列
getTransactionError

static Object getTransactionError()

トランザクション処理失敗時の汎用的なエラー情報を返します。

返却値
Object トランザクション処理失敗時のエラー情報
getUser

static String getUser()

ログインユーザIDを取得します。
返却値
String ログインユーザID
getUserLocale

static String getUserLocale()

ユーザロケールを取得します。
返却値
String ユーザロケール
removeTime

static String removeTime(String dateString)

YYYY/MM/DD|hh:mm:ss形式の文字列から時刻(00:00:00)を除去します。

パラメータ
dateString String 日時を表す文字列
返却値
String 日時を表す文字列
setLineFeedCode

static String setLineFeedCode(String string)

改行文字を改行コードに変換します。

パラメータ
string String 置換対象の文字列
返却値
String 改行コードに置換された文字列
split

static Array split(String string ,String sep)

文字列を分割して配列に格納して返します。

パラメータ
string | String | 文字列
sep | String | 区切り文字
返却値
Array 文字列を分割した配列
stringToDate

static Date stringToDate(String dateString)

YYYY/MM/DD形式の文字列をDate型オブジェクトに変換します。

パラメータ
dateString String 日時を表す文字列
返却値
Date Date型オブジェクト
validateTerms

static Object validateTerms(Object terms)

期間の整合性をチェックします。

パラメータ
terms Object 期間オブジェクト
返却値
Object チェック結果


 Procedure.RealNumber オブジェクト

推奨されていません。代替オブジェクトはありません。
小数演算を可能にするオブジェクトです。

使用例
ファンクションコンテナで
//変数 oRN を 2.1 で初期化
var oRN = new Procedure.RealNumber( 2.1 );
//減算 oRN - 0.9 を実行し、その数値データ(Number)を取得する。
var nAns = oRN.getSub(0.9).get();
//変数 oRN を 2.1 で初期化
var oRN = new Procedure.RealNumber( 2.1 );
//加算 oRN + 0.9 を実行し、その数字データ(String)を取得する。
var nAns = oRN.getAdd(0.9).toString();
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static RealNumber | RealNumber(Number nTarget) 推奨されていません。代替メソッドはありません。
Number | get() 推奨されていません。代替メソッドはありません。
RealNumber | getAdd(Number nTarget) 推奨されていません。代替メソッドはありません。
RealNumber | getDiv(Number nTarget) 推奨されていません。代替メソッドはありません。
RealNumber | getMlt(Number nTarget) 推奨されていません。代替メソッドはありません。
RealNumber | getSub(Number nTarget) 推奨されていません。代替メソッドはありません。
String | toString() 推奨されていません。代替メソッドはありません。
メソッドの詳細
RealNumber

static RealNumber RealNumber(Number nTarget)

推奨されていません。代替メソッドはありません。
コンストラクタ・メソッド。
引数に指定した数値を表す実数オブジェクトのインスタンスを生成します。

パラメータ
nTarget Number 数値
返却値
RealNumber RealNumberオブジェクト
get

Number get()

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データを取得します。
このオブジェクトのもつ数値情報を返します。

返却値
Number 数値データ
getAdd

RealNumber getAdd(Number nTarget)

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データと加法演算します。
このオブジェクトのもつ数値と足し算をします。
返却値は新たなインスタンスを生成して返すので、
もとの オブジェクト自体の値は変化しません。

パラメータ
nTarget Number 演算数値
返却値
RealNumber RealNumberオブジェクト
getDiv

RealNumber getDiv(Number nTarget)

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データと除法演算します。
このオブジェクトのもつ数値と割り算をします。
返却値は新たなインスタンスを生成して返すので、
もとの オブジェクト自体の値は変化しません。

パラメータ
nTarget Number 演算数値
返却値
RealNumber RealNumberオブジェクト
getMlt

RealNumber getMlt(Number nTarget)

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データと乗法演算します。
このオブジェクトのもつ数値と掛け算をします。
返却値は新たなインスタンスを生成して返すので、
もとの オブジェクト自体の値は変化しません。

パラメータ
nTarget Number 演算数値
返却値
RealNumber RealNumberオブジェクト
getSub

RealNumber getSub(Number nTarget)

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データと減法演算します。
このオブジェクトのもつ数値と引き算をします。
返却値は新たなインスタンスを生成して返すので、
もとの オブジェクト自体の値は変化しません。

パラメータ
nTarget Number 演算数値
返却値
RealNumber RealNumberオブジェクト
toString

String toString()

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データを文字列として取得します。
このオブジェクトのもつ数値情報を文字列で返します。

返却値
String 数値データ（文字列）


 Profile オブジェクト

推奨されていません。UserManagerに置き換えられました。
Profileオブジェクト。

プロファイルに関連する情報の更新を行う互換用マネージャオブジェクトです。

プロファイル情報を操作するために用いるプロファイル情報オブジェクトの構成は以下の通りです。
プロファイル情報オブジェクト
プロファイル情報
オブジェクト
(Object)
user_cd ユーザコード (String)
user_name ユーザ名 (String)
user_name_kana ユーザ名カナ (String)
user_name_eng ユーザ名英字 (String)
telephone_number 電話番号 (String)
mobile_number 携帯電話番号 (String)
fax_number FAX番号 (String)
extension_number 内線番号 (String)
extension_fax_number 内線FAX番号 (String)
country_cd 国コード (String)
zip_code 郵便番号 (String)
address 住所 (String)
email_address1 メールアドレス１ (String)
email_address2 メールアドレス２ (String)
mobile_email_address 携帯用メール (String)
url URL (String)
notes 備考 (String)
sort_key ソートキー (Number)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(失敗) (Number)
message エラー発生時のメッセージ (String)

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
Profile(String loginGroup)
コンストラクタ
メソッドの概要
Object | addProfile(Object data) 推奨されていません。UserManager.addUserに置き換えられました。
Object | deleteProfile(String user_cd) 推奨されていません。UserManager.deleteUserに置き換えられました。
Object | updateProfile(Object data) 推奨されていません。UserManager.updateUserに置き換えられました。
コンストラクタの詳細
Profile

Profile(String loginGroup)
コンストラクタ
パラメータ
loginGroup String ログイングループID
メソッドの詳細
addProfile

Object addProfile(Object data)

推奨されていません。UserManager.addUserに置き換えられました。
プロファイル情報を登録します。

このメソッドは内部でDBトランザクションを発行します。
パラメータ
data Object プロファイル情報オブジェクト
返却値
Object 処理結果オブジェクト
deleteProfile

Object deleteProfile(String user_cd)

推奨されていません。UserManager.deleteUserに置き換えられました。
登録済のプロファイル情報を削除します。

このメソッドは内部でDBトランザクションを発行します。
パラメータ
user_cd String ユーザコード
返却値
Object 処理結果オブジェクト
updateProfile

Object updateProfile(Object data)

推奨されていません。UserManager.updateUserに置き換えられました。
登録済のプロファイル情報を更新します。

このメソッドは内部でDBトランザクションを発行します。
パラメータ
data Object プロファイル情報オブジェクト
返却値
Object 処理結果オブジェクト


 PublicGroupManager オブジェクト

PublicGroupManagerオブジェクト。
パブリックグループに関連する情報の参照、更新を行うマネージャオブジェクトです。

パブリックグループセットに関連する情報を操作する場合に用いる パブリックグループセット情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループセット情報オブジェクト
パブリックグループセット情報
オブジェクト
(Object)
publicGroupSetCode グループセットコード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name パブリックグループセット名 (String)
nameSyllabary パブリックグループセット名カナ (String)
nameEnglish パブリックグループセット名英字 (String)

パブリックグループに関連する情報を操作する場合に用いる パブリックグループ情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループ情報オブジェクト
パブリックグループ情報
オブジェクト
(Object)
publicGroupSetCode グループセットコード (String)
publicGroupCode グループコード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name パブリックグループ名 (String)
nameSyllabary パブリックグループ名カナ (String)
nameEnglish パブリックグループ名英字 (String)

パブリックグループ構成バージョンに関連する情報を操作する場合に用いる パブリックグループ構成バージョン情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループ構成バージョン情報オブジェクト
パブリックグループ
構成バージョン情報
オブジェクト
(Object)
publicGroupSetCode グループセットコード (String)
versionCode バージョンコード (String)
startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
notes 備考 (String)

パブリックグループへの所属に関連する情報を操作する場合に用いる パブリックグループへの所属情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループへの所属情報オブジェクト
パブリックグループへの
所属情報
オブジェクト
(Object)
userCode ユーザコード (String)
publicGroupSetCode グループセットコード (String)
publicGroupCode グループコード (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)

パブリックグループ分類区分に関連する情報を操作する場合に用いる パブリックグループ分類区分情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループ分類区分情報オブジェクト
パブリックグループ
分類区分情報
オブジェクト
(Object)
publicGroupSetCode グループセットコード (String)
publicGroupCode グループコード (String)
categoryClassCode 分類区分コード (String)
categoryCode 分類コード (String)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(処理失敗) or -2(引数オブジェクト不正) (Number)
message エラー発生時のメッセージ (String)

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
PublicGroupManager(String user ,String group)
コンストラクタ
メソッドの概要
Object | addGroupSet(Object groupSet) パブリックグループセットを登録します。
Object | addPublicGroup(Object publicGroup) パブリックグループを登録します。
Object | addVersion(Object version) パブリックグループセット構成バージョンを新規に登録します。
Object | copyVersion(String groupSet ,String srcVersion ,String destVersion ,Date startDate ,Date endDate) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
Object | deleteGroupSet(Object groupSet) 登録済のパブリックグループセットを削除します。
Object | deleteMember(Object publicGroupAttach) パブリックグループから人員をはずします。
Object | deletePublicGroup(Object publicGroup) 登録済のパブリックグループ情報を削除します。
Object | deleteVersion(Object version) 登録済のパブリックグループセット構成バージョンを削除します。
Object | getPublicGroupStructs(String groupSet ,String publicGroup ,Date date ,String locale) パブリックグループの階層構造を取得します。
Object | joinPublicGroup(String groupSet ,String parentGroup ,String publicGroup ,String version) パブリックグループ構成にパブリックグループを登録します。
Object | leavePublicGroup(String groupSet ,String publicGroup ,String version) パブリックグループ構成からパブリックグループ情報を離脱させます。
Object | movePublicGroup(String groupSet ,String parentGroup ,String publicGroup ,String version) パブリックグループ構成に登録済のパブリックグループ情報を移動します。
Object | removeCategoryDetail(Object category) パブリックグループに対して指定された分類区分情報を削除します。
Object | setCategoryDetail(Object category) パブリックグループに対して指定された分類区分情報を設定します。
Object | setMember(Object publicGroupAttach) パブリックグループに人員を割り当てます。
Object | updatePublicGroup(Object publicGroup) 登録済のパブリックグループ情報を更新します。
Object | updateVersion(Object version) 登録済のパブリックグループセット構成バージョンを更新します。
コンストラクタの詳細
PublicGroupManager

PublicGroupManager(String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addGroupSet

Object addGroupSet(Object groupSet)

パブリックグループセットを登録します。

このメソッドを実行すると下記のような動作が行われます。
  1. パブリックグループセットを新規登録する。
  2. パブリックグループセットに対応するパブリックグループを新規登録する。
パラメータ
groupSet Object パブリックグループセット情報オブジェクト
返却値
Object 処理結果オブジェクト
addPublicGroup

Object addPublicGroup(Object publicGroup)

パブリックグループを登録します。

このメソッドを実行しただけではまだパブリックグループセットの パブリックグループ構成には追加されていません。
パブリックグループ構成に追加したい場合は、 joinPublicGroup(String, String, String, String)
を使用してください。
パラメータ
publicGroup Object パブリックグループ情報オブジェクト
返却値
Object 処理結果オブジェクト
addVersion

Object addVersion(Object version)

パブリックグループセット構成バージョンを新規に登録します。

追加された構成バージョンのトップレベルには、パブリックグループセットが自動的に追加されます。
パラメータ
version Object パブリックグループ構成バージョン情報オブジェクト
返却値
Object 処理結果オブジェクト
copyVersion

Object copyVersion(String groupSet ,String srcVersion ,String destVersion ,Date startDate ,Date endDate)

登録済のパブリックグループセット構成バージョンの内容をコピーします。

コピー元のバージョンコードは登録済みのものを選択してください。
コピー先のバージョンコードは登録されていないものを選択してください。
パラメータ
groupSet | String | コピー元、コピー先のパブリックグループセット構成バージョンのグループセットコード
srcVersion | String | コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion | String | コピー先のパブリックグループセット構成バージョンのバージョンコード
startDate | Date | コピー先のパブリックグループセット構成バージョンの有効期間開始日時
endDate | Date | コピー先のパブリックグループセット構成バージョンの有効期間終了日時
返却値
Object 処理結果オブジェクト
deleteGroupSet

Object deleteGroupSet(Object groupSet)

登録済のパブリックグループセットを削除します。

このメソッドを実行すると 指定されたパブリックグループセットに関連する全ての情報が削除されます。
パラメータ
groupSet Object パブリックグループセット情報オブジェクト
返却値
Object 処理結果オブジェクト
deleteMember

Object deleteMember(Object publicGroupAttach)

パブリックグループから人員をはずします。
パラメータ
publicGroupAttach Object パブリックグループから外す人員の情報
返却値
Object 処理結果オブジェクト
deletePublicGroup

Object deletePublicGroup(Object publicGroup)

登録済のパブリックグループ情報を削除します。
パラメータ
publicGroup Object パブリックグループ情報オブジェクト
返却値
Object 処理結果オブジェクト
deleteVersion

Object deleteVersion(Object version)

登録済のパブリックグループセット構成バージョンを削除します。
指定されたパブリックグループセット構成バージョンが存在しない場合は処理失敗となります。
パラメータ
version Object パブリックグループ構成バージョン情報オブジェクト
返却値
Object 処理結果オブジェクト
getPublicGroupStructs

Object getPublicGroupStructs(String groupSet ,String publicGroup ,Date date ,String locale)

パブリックグループの階層構造を取得します。

指定された日付に該当する、パブリックグループ構成バージョンがない時はエラーとなります。
パラメータ
groupSet | String | グループセットコード
publicGroup | String | グループコード
date | Date | 日付
locale | String | 言語
返却値
Object 処理結果オブジェクト

処理結果オブジェクトの構成は以下の通りです。
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(処理失敗) or -2(引数オブジェクト不正) (Number)
message エラー発生時のメッセージ (String)
data パブリックグループの階層構造 (Array)
(該当データが存在しない場合はnullが返却されます。)
joinPublicGroup

Object joinPublicGroup(String groupSet ,String parentGroup ,String publicGroup ,String version)

パブリックグループ構成にパブリックグループを登録します。

新しく親となるパブリックグループと登録対象のパブリックグループは同一の
パブリックグループセットに所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。
親となるパブリックグループは、パブリックグループ内包に登録済みのものを指定する必要があります。

指定されたパブリックグループが対象のバージョンにおいて既に登録されているときは
このメソッドは使用できません。
パラメータ
groupSet | String | 上位パブリックグループと 新規登録されるパブリックグループが所属する パブリックグループセットのグループセットコード
parentGroup | String | 新規登録するパブリックグループの 上位となるパブリックグループのグループコード （またはパブリックグループセットのグループセットコード）
publicGroup | String | 新規登録するパブリックグループのグループコード （パブリックグループセットに該当するパブリックグループは指定できない）
version | String | バージョンコード
返却値
Object 処理結果オブジェクト
leavePublicGroup

Object leavePublicGroup(String groupSet ,String publicGroup ,String version)

パブリックグループ構成からパブリックグループ情報を離脱させます。

このメソッドを実行すると、指定されたパブリックグループを 指定されたバージョンから削除します。
指定されたパブリックグループが子パブリックグループを持っていた場合、それらのパブリックグループも
再帰的にこのバージョンから削除されます。
このメソッドを実行してもパブリックグループ情報そのものは残ります。
指定されたパブリックグループがグループ構成に登録されていない場合は処理失敗となります。
パラメータ
groupSet | String | グループセットコード
publicGroup | String | 離脱させるパブリックグループのグループコード （パブリックグループセットに該当するパブリックグループは指定できない）
version | String | バージョンコード
返却値
Object 処理結果オブジェクト
movePublicGroup

Object movePublicGroup(String groupSet ,String parentGroup ,String publicGroup ,String version)

パブリックグループ構成に登録済のパブリックグループ情報を移動します。

新しく上位となるパブリックグループと移動対象のパブリックグループは同一のパブリックグループセットに
所属している必要があります。
また、パブリックグループ構成が循環するような移動はできません。
バージョンコードは登録済みのものを指定する必要があります。
パラメータ
groupSet | String | 上位パブリックグループと移動対象の パブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup | String | 上位パブリックグループのグループコード （またはパブリックグループセットのグループセットコード）
publicGroup | String | 移動するパブリックグループのグループコード （パブリックグループセットに該当するパブリックグループは指定できない）
version | String | バージョンコード
返却値
Object 処理結果オブジェクト
removeCategoryDetail

Object removeCategoryDetail(Object category)

パブリックグループに対して指定された分類区分情報を削除します。

パラメータ
category Object 削除するパブリックグループ分類区分情報オブジェクト
返却値
Object 処理結果オブジェクト
setCategoryDetail

Object setCategoryDetail(Object category)

パブリックグループに対して指定された分類区分情報を設定します。
パラメータ
category Object 設定するパブリックグループ分類区分情報オブジェクト
返却値
Object 処理結果オブジェクト
setMember

Object setMember(Object publicGroupAttach)

パブリックグループに人員を割り当てます。

人員の割当情報がすでに設定されている場合は、パラメータで渡された情報で完全に上書きされます。
パラメータ
publicGroupAttach Object 割当人員の情報
返却値
Object 処理結果オブジェクト
updatePublicGroup

Object updatePublicGroup(Object publicGroup)

登録済のパブリックグループ情報を更新します。
パラメータ
publicGroup Object パブリックグループ情報オブジェクト
返却値
Object 処理結果オブジェクト
updateVersion

Object updateVersion(Object version)

登録済のパブリックグループセット構成バージョンを更新します。
パラメータ
version Object パブリックグループ構成バージョン情報オブジェクト
返却値
Object 処理結果オブジェクト


 Request オブジェクト

リクエストオブジェクト。

クライアントからのリクエスト情報を保持するオブジェクトです。
このオブジェクトは、ブラウザからの要求があるたびに生成され、ファンクション・コンテナの init() 関数や action に対するバインド関数の実行時に関数引数として渡されます。

URL引数を取得する場合は、request.URL引数名で取得できます。
(request.getParameterValue(String name)と動作は同じです。)
バージョン：2.0
導入されたバージョン：2.0
メソッドの概要
Array get(String key)
推奨されていません。Request.getParameterValues()に置き換えられました。
Object getAttribute(String name)
指定された名前の属性値を返します。
Array getAttributeNames()
このリクエストで利用可能な属性名を含む配列型のオブジェクトを返します。
Number getContentLength()
リクエストコンテンツの長さを取得します。
String getContentType()
リクエストコンテンツタイプを取得します。
String getCookie(String name)
指定の名前を持つクッキーの値を返します。
Array getCookieNames()
すべてのクッキーの名前の配列を返します。
Array getCookies(String name)
指定の名前を持つすべてのクッキーの値の配列を返します。
String getHeader(String name)
指定されたリクエストヘッダの値をStringとして返します。
Array getHeaderNames()
このリクエストに含まれる全てのヘッダ名の配列を返します。
Array getHeaders(String name)
指定されたリクエストヘッダの全ての値をStringの配列として返します。
String getMessageBody(String enc)
メッセージボディに含まれているバイナリデータをStringとして返します。
String getMessageBodyAsStream()
メッセージボディに含まれているバイナリデータをStringとして返します。
String getMessageBodyAsString()
メッセージボディに含まれているデータをStringとして返します。
String getMethod()
このリクエストを生成したHTTPメソッドの名前を返します。
RequestParameter getParameter(String name)
指定の名前をもつリクエストパラメータを返します。
String getParameterNames()
すべてのリクエストパラメータ名を返します。
String getParameterValue(String key)
指定のキーに該当する URL 引数データを返却します。
Array getParameterValues(String key)
指定のキーに該当する URL 引数データ群を返却します。
String getQueryString()
リクエストされたURLのパスの後ろに含まれているクエリ文字列を返します。
String query()
推奨されていません。Request.getMessageBodyAsStream()およびgetQueryString()に置き換えられました。
void removeAttribute(String name)
このリクエストから属性を削除します。
void setAttribute(String name ,Object object)
このリクエストに属性をセットします。
メソッドの詳細
get

Array get(String key)

推奨されていません。Request.getParameterValues()に置き換えられました。
指定のキーに該当する URL 引数データ群を返却します。

キーは、フォームのコントロール名称(name 属性)を指定します。
返却値は指定キーに該当するデータ(文字列)の個数と同等の要素を持つ配列です。
指定キーに該当する URL 引数が１つも存在しない場合は空の配列を返却します。
パラメータ
key String URL 引数設定名称
返却値
Array URL 引数データの配列
導入されたバージョン：2.0
getAttribute

Object getAttribute(String name)

指定された名前の属性値を返します。

指定された名前が存在しない場合は、null を返します。
パラメータ
name String 属性の名前を指定する String
返却値
Object 属性の値が含まれている Object。 指定された名前の属性が無い場合は null
導入されたバージョン：5.0
getAttributeNames

Array getAttributeNames()

このリクエストで利用可能な属性名を含む配列型のオブジェクトを返します。

返却値
Array リクエストに付随する属性名を含む文字列からなる配列
導入されたバージョン：5.0
getContentLength

Number getContentLength()

リクエストコンテンツの長さを取得します。

リクエストのメッセージボディ、あるいは、入力ストリームから読み込めるバイト長を返しますが、長さがわからない場合は -1 を返します。
HTTP Servlet では CGI 環境変数 CONTENT_LENGTH の値に相当します。
返却値
Number リクエストのメッセージボディの長さを表す整数値
導入されたバージョン：5.0
getContentType

String getContentType()

リクエストコンテンツタイプを取得します。

リクエストに含まれるメッセージボディの MIME タイプを返しますが、タイプがわからない場合は null を返します。
HTTP Servlet では CGI 環境変数の CONTENT_TYPE の値に相当します。
返却値
String リクエストの MIME タイプの名前を含む String
導入されたバージョン：5.0
getCookie

String getCookie(String name)

指定の名前を持つクッキーの値を返します。

指定の名前を持つクッキーの値が複数あった場合、その中のどれかが返されます。
指定の名前をもつクッキーの値が存在しない場合、nullを返します。
リクエストに Cookie が付加されていない場合も null を返します。
パラメータ
name String クッキーの名前を表すString
返却値
String 指定された名前をもつ値を表すString
導入されたバージョン：5.0
getCookieNames

Array getCookieNames()

すべてのクッキーの名前の配列を返します。

クッキーが一つも存在しない場合、空の配列を返します。
リクエストに Cookie が付加されていない場合は null を返します。
返却値
Array 指定された名前をもつ値の配列
導入されたバージョン：5.0
getCookies

Array getCookies(String name)

指定の名前を持つすべてのクッキーの値の配列を返します。

指定の名前をもつクッキーの値が存在しない場合、空の配列を返します。
リクエストに Cookie が付加されていない場合は null を返します。
パラメータ
name String クッキーの名前を表すString
返却値
Array 指定された名前をもつ値の配列
導入されたバージョン：5.0
getHeader

String getHeader(String name)

指定されたリクエストヘッダの値をStringとして返します。

指定した名前を持つヘッダが複数ある場合は、先頭のヘッダを返却します。
指定した名前を持つヘッダが存在しない場合はnullを返却します。
パラメータ
name String ヘッダ名を表すString
返却値
String 要求したヘッダの値を持つString
導入されたバージョン：5.0
getHeaderNames

Array getHeaderNames()

このリクエストに含まれる全てのヘッダ名の配列を返します。

リクエストがヘッダを1つも持たない場合は空の配列を返します。
Servletがこのメソッドを用いることを Servletコンテナが禁止している場合はnullを返却します。
返却値
Array このリクエストとともに送信された全てのヘッダの名前の配列
導入されたバージョン：5.0
getHeaders

Array getHeaders(String name)

指定されたリクエストヘッダの全ての値をStringの配列として返します。

このリクエストが指定された名前のヘッダを持たない場合、 空の配列を返します。
コンテナがヘッダ情報へのアクセスを禁止している場合、 nullを返します。
パラメータ
name String ヘッダ名を表すString
返却値
Array リクエストヘッダの値を持つ配列
導入されたバージョン：5.0
getMessageBody

String getMessageBody(String enc)

メッセージボディに含まれているバイナリデータをStringとして返します。

返されるデータは、指定の文字エンコーディング名によってUnicode に変換されています。
パラメータ
enc String エンコーディング名
返却値
String メッセージボディ部を表すString
導入されたバージョン：5.0
getMessageBodyAsStream

String getMessageBodyAsStream()

メッセージボディに含まれているバイナリデータをStringとして返します。

文字コード変換されません。バイナリデータ１バイトが１文字となります。
返却値
String メッセージボディ部を表すString
導入されたバージョン：5.0
getMessageBodyAsString

String getMessageBodyAsString()

メッセージボディに含まれているデータをStringとして返します。

データは、ServletRequest のエンコーディング名によって Unicode に変換します。
返却値
String メッセージボディ部を表すString
導入されたバージョン：5.0
getMethod

String getMethod()

このリクエストを生成したHTTPメソッドの名前を返します。

例えばGET、POST、PUTのような、HTTPメソッドの名前です。
返却値
String このリクエストを生成したメソッドの名前を表すString
導入されたバージョン：5.0
getParameter

RequestParameter getParameter(String name)

指定の名前をもつリクエストパラメータを返します。

パラメータ
name String パラメータ名
返却値
RequestParameter パラメータ情報をもつオブジェクト
導入されたバージョン：5.0
getParameterNames

String getParameterNames()

すべてのリクエストパラメータ名を返します。

配列の各要素は、パラメータ名を表す String です。
返却値
String パラメータ名の配列
導入されたバージョン：5.0
getParameterValue

String getParameterValue(String key)

指定のキーに該当する URL 引数データを返却します。

キーは、フォームのコントロール名称(name 属性)を指定します。
返却値は指定キーに該当するデータ(文字列)です。
該当するデータが配列の場合は、先頭のデータを返却します。
指定キーに該当する URL 引数が１つも存在しない場合はnullを返却します。
パラメータ
key String URL 引数設定名称
返却値
String URL 引数データ
導入されたバージョン：5.0
getParameterValues

Array getParameterValues(String key)

指定のキーに該当する URL 引数データ群を返却します。

キーは、フォームのコントロール名称(name 属性)を指定します。
返却値は指定キーに該当するデータ(文字列)の個数と同等の要素を持つ配列です。
指定キーに該当する URL 引数が１つも存在しない場合は空の配列を返却します。
パラメータ
key String URL 引数設定名称
返却値
Array URL 引数データの配列
導入されたバージョン：5.0
getQueryString

String getQueryString()

リクエストされたURLのパスの後ろに含まれているクエリ文字列を返します。

URLがクエリ文字列を持っていない場合はnullを返します。
値はコンテナによってデコードされません。
この値はCGI変数のQUERY_STRINGの値と同じです。
返却値
String クエリ文字列を表すString
導入されたバージョン：5.0
query

String query()

推奨されていません。Request.getMessageBodyAsStream()およびgetQueryString()に置き換えられました。
URL 引数文字列の取得します。

返却値はクライアントより受信した状態の URL 引数文字列です。
POST or GET どちらのリクエストでも引数を受け取る事が可能です
返却値
String クライアントから受け取った URL 引数文字列
導入されたバージョン：2.0
removeAttribute

void removeAttribute(String name)

このリクエストから属性を削除します。

属性はリクエストがコンテナ内で処理されている間だけ維持されるにすぎないので、 通常、このメソッドは必要ありません。
パラメータ
name String 削除する属性の名前を示す String
返却値
void
導入されたバージョン：5.0
setAttribute

void setAttribute(String name ,Object object)

このリクエストに属性をセットします。

パラメータ
name | String | 属性名を示す String
object | Object | セットするObject
返却値
void
導入されたバージョン：5.0


 RequestParameter オブジェクト

リクエストパラメータ情報オブジェクト。

リクエストパラメータの情報を保持します。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
String | getFileName() アップロードされたファイルのファイル名を取得します。
String | getHeader(String name) 指定のヘッダ名をもつ値を返します。
Array | getHeaderNames() ヘッダ名称一覧を返します。
Number | getLength() データ長を返します。
String | getName() このオブジェクトのパラメータ名を取得します。
String | getValue() 現在のパラメータ値を返します。
String | getValueAsStream() 現在のパラメータ値を返します。
メソッドの詳細
getFileName

String getFileName()

アップロードされたファイルのファイル名を取得します。

ファイルアップロードをしたリクエストではない場合は、null を返します。
Content-Disposition: form-data; name="ctrl_name"; filename="file_path"
ヘッダは、上記のような形式で受け取れる
ctrl_name: <INPUT type="file"> の name 属性
file_path: クライアントでのファイル名
ヘッダ情報は他にもあるが、上記の行のみを対象に解析を行う
返却値
String ファイル名
導入されたバージョン：5.0
getHeader

String getHeader(String name)

指定のヘッダ名をもつ値を返します。

パラメータ
name String ヘッダ名
返却値
String ヘッダの値
導入されたバージョン：5.0
getHeaderNames

Array getHeaderNames()

ヘッダ名称一覧を返します。

このエンティティのもつヘッダ情報の名称一覧を返します。
ヘッダ情報がない場合、このメソッドは null を返します。
返却値
Array ヘッダ名称の配列
導入されたバージョン：5.0
getLength

Number getLength()

データ長を返します。

返却値
Number データ長（単位はバイト）
導入されたバージョン：5.0
getName

String getName()

このオブジェクトのパラメータ名を取得します。

返却値
String パラメータ名
導入されたバージョン：5.0
getValue

String getValue()

現在のパラメータ値を返します。

パラメータ値は、リクエストの文字エンコーディングから文字コード変換されています。
返却値
String パラメータ値
導入されたバージョン：5.0
getValueAsStream

String getValueAsStream()

現在のパラメータ値を返します。

パラメータ値は、文字コード変換されません。
パラメータ値の各バイトがそれぞれ String の１文字に対応します。
つまり、パラメータ値のバイト数は、そのまま String の文字数に等しくなります。
返却値
String パラメータ値
導入されたバージョン：5.0


 RoleManager オブジェクト

ロールマネージャオブジェクト。

ロール情報の参照、更新を行うマネージャオブジェクトです。

ロールの情報を操作する場合に用いるロールオブジェクトの構成は以下の通りです。
ロールオブジェクト
ロール
オブジェクト
(Object)
category ロールカテゴリ (String)
description ロールの詳細 (String)
displayName[ロケール] ロール表示名 (String)
ロケール別の表示名です。
roleId ロールID (String)
roleName ロール名 (String)
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
RoleManager(String loginGroupId)
コンストラクタ。
メソッドの概要
Boolean addRole(Object object)
ロール情報を新規登録します。
Boolean addSubRole(String roleId ,String subRoleId)
サブロールIDを追加します。
Boolean certify(Object users ,Object roles)
ロール認証を行います。
Boolean contains(String roleId)
ロールの存在チェックを行います。
Boolean containsCategory(String category)
カテゴリーの登録チェックを行います。
Number count()
ロール数を取得します。
Number countByCategory(String category)
カテゴリーに属するロール数を取得します。
Object del(String roleId [,Array funcs] [,Boolean isTransaction])
推奨されていません。RoleManager.deleteRole(String roleId) に置き換えられました。
Boolean deleteCategories()
カテゴリーを全件削除します。
Boolean deleteCategory(String category)
カテゴリーを削除します。
Boolean deleteRole(String roleId)
ロールを削除します。
Boolean deleteRoles()
ロールを全削除します。
Boolean deleteSubRole(String roleId ,String subRoleId)
指定したサブロールIDを削除します。
Boolean deleteSubRoles(String roleId)
全てのサブロールIDを削除します。
String exportData(String category)
ロールのエクスポートを行います。
DataForRole get(String roleId)
推奨されていません。RoleManager.getRole(String roleId) に置き換えられました。
Array getAllParentRoleIds(String roleId)
全ての親ロールIDを取得します。
Array getAllSubRoleIds(String roleId)
指定したロールIDのサブロールサマリを取得します。
Array getCategories()
カテゴリー一覧を取得します。
Array getExportCategories()
ロールエクスポート用のカテゴリの一覧を取得します。
String getIdByName(String name)
推奨されていません。代替えメソッドはありません。
Array getImportCategories()
ロールインポート用のカテゴリの一覧を取得します。
Array getKeys()
推奨されていません。RoleManager.getRoleIds() に置き換えられました。
Array getList(String roleId)
推奨されていません。RoleManager.getAllSubRoleIds(String) に置き換えられました。
String getLoginGroupId()
ログイングループIDを取得します。
Array getParentRoleIds(String roleId)
親ロール(一階層上のみ)を取得します。
Array getParents(String roleId)
推奨されていません。RoleManager.getParentIds(Object String) に置き換えられました。
Object getRole(String roleId)
ロール情報を取得します。
Array getRoleIds()
すべてのロールIDを取得します。
Array getRoles()
ロール情報を全取得します。
Array getRolesByCategory(String category)
カテゴリーで検索を行い、ロールを取得します。
Array getRolesByIds(Array roleIds)
引数のロールIDのロールをすべて取得します。
Array getSubRole(String roleId)
サブロール(一階層のみ)を取得します。
Boolean importData(String category ,String str)
ロールのインポートを行います。
Boolean moveCategory(String oldCategory ,String newCategory)
カテゴリーを更新します。
Array searchRolesByName(String name)
ロール名称検索でロールを取得します。
ReturnObject set(Object request [,Array funcs] [,Boolean isTransaction])
推奨されていません。RoleManager.addRole(Object role) および RoleManager.updateRole(Object role)に置き換えられました。
Boolean updateRole(Object object)
ロール情報を更新します。
コンストラクタの詳細
RoleManager

RoleManager(String loginGroupId)
コンストラクタ。

パラメータ
loginGroupId String ログイングループID
メソッドの詳細
addRole

Boolean addRole(Object object)

ロール情報を新規登録します。

パラメータ
object Object ロールオブジェクト
返却値
Boolean true : 成功 / false : 失敗
addSubRole

Boolean addSubRole(String roleId ,String subRoleId)

サブロールIDを追加します。

パラメータ
roleId | String | ロールID
subRoleId | String | サブロールID
返却値
Boolean true : 成功 / false : 失敗
certify

Boolean certify(Object users ,Object roles)

ロール認証を行います。

パラメータ
users | Object | userDataのロールID(String)の配列
roles | Object | その他のオブジェクトのロールID(String)の配列
返却値
Boolean true : 成功 / false : 失敗
contains

Boolean contains(String roleId)

ロールの存在チェックを行います。

パラメータ
roleId String ロールID
返却値
Boolean true:存在する false:存在しない
containsCategory

Boolean containsCategory(String category)

カテゴリーの登録チェックを行います。

パラメータ
category String カテゴリ名
返却値
Boolean true:登録有り false:登録なし または エラー発生
count

Number count()

ロール数を取得します。

返却値
Number ロールの数（エラーの場合は-1を返します）
countByCategory

Number countByCategory(String category)

カテゴリーに属するロール数を取得します。

パラメータ
category String カテゴリ
返却値
Number カテゴリーに属するロール数（エラーの場合は-1を返します）
del

Object del(String roleId [,Array funcs] [,Boolean isTransaction])

推奨されていません。RoleManager.deleteRole(String roleId) に置き換えられました。
ロールデータを削除します。

パラメータ
roleId | String | ロールID
funcs | Array | 動かしたい関数があれば、パスを配列にいれて渡す（任意）
isTransaction Boolean DBトランザクションフラグ(任意)
（true このメソッドの中でDBトランザクションを張ります。／false このメソッドの中でDBトランザクションを張りません。デフォルトはtrueです。）
返却値
Object 結果オブジェクトまたは、引数が不正の場合、falseを返却します。
結果オブジェクト
(Object) 		getCode() エラーコード
-1 実行エラー
0 成功
その他 各アプリに依存します。
getMessage() エラーメッセージ
deleteCategories

Boolean deleteCategories()

カテゴリーを全件削除します。

返却値
Boolean true : 成功 / false : 失敗
deleteCategory

Boolean deleteCategory(String category)

カテゴリーを削除します。

パラメータ
category String カテゴリ名
返却値
Boolean true : 成功 / false : 失敗
deleteRole

Boolean deleteRole(String roleId)

ロールを削除します。

パラメータ
roleId String ロールID
返却値
Boolean true : 成功 / false : 失敗
deleteRoles

Boolean deleteRoles()

ロールを全削除します。

返却値
Boolean true : 成功 / false : 失敗
deleteSubRole

Boolean deleteSubRole(String roleId ,String subRoleId)

指定したサブロールIDを削除します。

パラメータ
roleId | String | ロールID
subRoleId | String | サブロールID
返却値
Boolean true : 成功 / false : 失敗
deleteSubRoles

Boolean deleteSubRoles(String roleId)

全てのサブロールIDを削除します。

パラメータ
roleId String ロールID
返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData(String category)

ロールのエクスポートを行います。

パラメータ
category String カテゴリ
返却値
String 出力情報
エクスポートに失敗した場合は、nullを返却します。
get

DataForRole get(String roleId)

推奨されていません。RoleManager.getRole(String roleId) に置き換えられました。
ロールデータを取得します。

パラメータ
roleId String ロールID
返却値
DataForRole ロールデータ
存在しない場合はnullを返却します。
getAllParentRoleIds

Array getAllParentRoleIds(String roleId)

全ての親ロールIDを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Array 全ての親ロールIDの配列
getAllSubRoleIds

Array getAllSubRoleIds(String roleId)

指定したロールIDのサブロールサマリを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Array 指定されたロールIDのサブロールの配列（エラーの場合はnullを返します。）
getCategories

Array getCategories()

カテゴリー一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array カテゴリの配列（エラーの場合はnullを返します。）
getExportCategories

Array getExportCategories()

ロールエクスポート用のカテゴリの一覧を取得します。

返却値
Array ロールエクスポート用カテゴリの一覧
ロールエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getIdByName

String getIdByName(String name)

推奨されていません。代替えメソッドはありません。
ロール名からロールIDを取得します。

パラメータ
name String ロール名
返却値
String ロールID 存在しない場合はnullを返却します。
getImportCategories

Array getImportCategories()

ロールインポート用のカテゴリの一覧を取得します。

返却値
Array ロールインポート用カテゴリの一覧
ロールインポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getKeys

Array getKeys()

推奨されていません。RoleManager.getRoleIds() に置き換えられました。
ロールIDを全て取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array 成功：ロールIDの配列(データがない場合は空の配列)
getList

Array getList(String roleId)

推奨されていません。RoleManager.getAllSubRoleIds(String) に置き換えられました。
サブロールデータを取得します。
(子ロールも含めたロールデータをすべて取得します。)

パラメータ
roleId String ロールID
返却値
Array サブロールIDの配列
getLoginGroupId

String getLoginGroupId()

ログイングループIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
String ログイングループID
getParentRoleIds

Array getParentRoleIds(String roleId)

親ロール(一階層上のみ)を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Array 親ロールIDの配列
getParents

Array getParents(String roleId)

推奨されていません。RoleManager.getParentIds(Object String) に置き換えられました。
直接の親（一階層上）ロールIDを取得します。

パラメータ
roleId String ロールID
返却値
Array ロールIDの配列(データがない場合はnullを返却します。)
getRole

Object getRole(String roleId)

ロール情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Object ロールオブジェクト
getRoleIds

Array getRoleIds()

すべてのロールIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array ロールIDの配列
getRoles

Array getRoles()

ロール情報を全取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array ロールオブジェクト の配列
getRolesByCategory

Array getRolesByCategory(String category)

カテゴリーで検索を行い、ロールを取得します。

指定したカテゴリーに属するロール情報を全て取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
category String カテゴリ名
返却値
Array 指定されたカテゴリに属するロールオブジェクト の配列
getRolesByIds

Array getRolesByIds(Array roleIds)

引数のロールIDのロールをすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleIds Array ロールIDの配列
返却値
Array ロールオブジェクト の配列（データがない場合は空の配列を返します）
getSubRole

Array getSubRole(String roleId)

サブロール(一階層のみ)を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Array サブロールIDの配列
importData

Boolean importData(String category ,String str)

ロールのインポートを行います。

パラメータ
category | String | カテゴリ
str | String | ストリーム
返却値
Boolean true : 成功 / false : 失敗
moveCategory

Boolean moveCategory(String oldCategory ,String newCategory)

カテゴリーを更新します。

パラメータ
oldCategory | String | 変更前のカテゴリ名
newCategory | String | 変更後のカテゴリ名
返却値
Boolean true : 成功 / false : 失敗
searchRolesByName

Array searchRolesByName(String name)

ロール名称検索でロールを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
name String ロールの名称
返却値
Array ロールオブジェクト の配列
set

ReturnObject set(Object request [,Array funcs] [,Boolean isTransaction])

推奨されていません。RoleManager.addRole(Object role) および RoleManager.updateRole(Object role)に置き換えられました。
ロールデータを登録します。

引数に指定したユーザIDが既に存在していた場合、上書きします。
request
リクエストオブジェクト 		id ロールID(String)
name ロール名(String)
explan 説明(ロケール表示名)(String)
detail 詳細(String)
roles サブロールIDの配列(Array)
attr その他、IMISにのみ登録する属性(Object)
(((new RoleManager(gId)).get(uId)).getAttr()で取得できる値)
その他 各アプリに依存
パラメータ
request | Object | 登録画面からのリクエスト
funcs | Array | 動かしたい関数があれば、パスを配列にいれて渡す（任意）
isTransaction Boolean DBトランザクションフラグ(任意) （true このメソッドの中でDBトランザクションを張ります。／false このメソッドの中でDBトランザクションを張りません。デフォルトはtrueです。）
返却値
ReturnObject true / false
updateRole

Boolean updateRole(Object object)

ロール情報を更新します。
パラメータ
object Object ロールオブジェクト
返却値
Boolean true : 成功 / false : 失敗


 RCV オブジェクト

RC-5 暗号・復号化オブジェクト。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
RCV(String keytext ,String ivtext ,Number rounds)
RC-5 暗号化・復号化オブジェクトを生成します。
メソッドの概要
String | decrypt(String ciphertext ,String enctype) 指定文字列をRC-5で復号化します。
String | decryptStream(String ciphertext) 指定文字列をRC-5で復号化します。
String | decryptString(String ciphertext) 指定文字列をRC-5で復号化します。
String | encrypt(String plaintext ,String enctype) 文字列情報を暗号化します。
String | encryptStream(String plaintext) 文字列情報を暗号化します。
String | encryptString(String plaintext) 文字列情報を暗号化します。
Boolean | isError() 暗号化・復号化の可・否を判定します。
コンストラクタの詳細
RCV

RCV(String keytext ,String ivtext ,Number rounds)
RC-5 暗号化・復号化オブジェクトを生成します。
ivtext は、暗号化・復号化時の鍵になります。
keytext, rounds は鍵拡張アルゴリズムとして使われます。
rounds を省略した場合 RC5_ROUNDS_MIN が適応されます。
パラメータ
keytext | String | 鍵文字列(必須)
ivtext | String | イニシャライズベクタ(必須)
rounds | Number | ラウンド数(任意)
メソッドの詳細
decrypt

String decrypt(String ciphertext ,String enctype)

指定文字列をRC-5で復号化します。
復号化できなかった場合には null を返却します。
このメソッドでは、暗号化された文字列を復号化した結果を 指定の文字エンコードで文字コード変換した結果の文字列を返します。
パラメータ
ciphertext | String | 復号化対象文字列
enctype | String | 文字エンコード
返却値
String 復号化された結果の文字列
decryptStream

String decryptStream(String ciphertext)

指定文字列をRC-5で復号化します。
復号化できなかった場合には null を返却します。
このメソッドでは、暗号化された文字列を復号化した結果をストリームとして扱います。
jsFunction_encryptStream() と対で利用してください。
パラメータ
ciphertext String 復号化対象文字列
返却値
String 復号化された結果の文字列
decryptString

String decryptString(String ciphertext)

指定文字列をRC-5で復号化します。
復号化できなかった場合には null を返却します。
このメソッドでは、暗号化された文字列を復号化した結果をUNICODE として扱います。
jsFunction_encryptString() と対で利用してください。
パラメータ
ciphertext String 復号化対象文字列
返却値
String 復号化された結果の文字列
encrypt

String encrypt(String plaintext ,String enctype)

文字列情報を暗号化します。
指定文字列を RC-5 で暗号化します。
このメソッドでは、指定の値を指定のエンコードで変換した結果に対して暗号化を行います。
暗号化できなかった場合には null を返却します。
パラメータ
plaintext | String | 暗号化対象文字列
enctype | String | 文字エンコード
返却値
String 暗号化された結果の文字列
encryptStream

String encryptStream(String plaintext)

文字列情報を暗号化します。
指定文字列を RC-5 で暗号化します。
このメソッドでは、指定の値をストリームとして扱います。
暗号化できなかった場合には null を返却します。
jsFunction_decryptStream() と対で利用してください。
パラメータ
plaintext String 暗号化対象文字列
返却値
String 暗号化された結果の文字列
encryptString

String encryptString(String plaintext)

文字列情報を暗号化します。
指定文字列を RC-5 で暗号化します。
このメソッドでは、指定の値を UNICODE として扱います。
暗号化できなかった場合には null を返却します。
jsFunction_decryptString() と対で利用してください。
パラメータ
plaintext String 暗号化対象文字列
返却値
String 暗号化された結果の文字列
isError

Boolean isError()

暗号化・復号化の可・否を判定します。
このインスタンスが暗号化や復号化ができる状態かを判定します。

返却値
Boolean 真値：暗号化・復号化可能/偽値：オプション指定が無効


 SecurityConst オブジェクト

アクセスセキュリティ定数オブジェクト。
バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | CP_COOKIE セッション情報をクッキーに保管するパラメータ名。
static Number | CR_ERROR 認証処理エラーの返却値。
static Number | CR_LOCKED アカウントロック状態の返却値。
static Number | CR_NG ログインエラーの返却値。
static Number | CR_NO_GROUP ログイングループ未登録状態の返却値。
static Number | CR_NO_LICENSE ライセンスなし、または有効期間外状態の返却値。
static Number | CR_NO_PERMISSION 無許可ページへのアクセスの返却値。
static Number | CR_NO_USER ユーザ未登録状態の返却値。
static Number | CR_OK 認証成功の返却値。
static Number | CR_SESSION_INITIAL セッション初期状態の返却値。
static Number | CR_SESSION_LOGON セッションログオン状態の返却値。
static Number | CR_SESSION_TIMEOUT セッションタイムアウト状態の返却値。
static Number | CR_SESSION_UNMATCH セッション不整合状態の返却値。
static String | LT_GROUP グループマネージャー（ログインタイプ）。
static String | LT_SUPER スーパーユーザ（ログインタイプ）。
static String | LT_USER ユーザ（ログインタイプ）。
static String | RP_CLIENT_TYPE クライアントタイプのデフォルトＵＲＬ引数名。
static String | RP_ENCODING ログインエンコーディングのデフォルトＵＲＬ引数名。
static String | RP_INITIAL_URL 初期ＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_LOCALE ログインロケールのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_GROUP ログイングループIDのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_TYPE ログインタイプのデフォルトＵＲＬ引数名。
static String | RP_PASSWORD パスワードのデフォルトＵＲＬ引数名。
static String | RP_URL ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_URL_SIGN ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
static String | RP_USER ログインユーザＩＤのデフォルトＵＲＬ引数名。
static String | SP_CLIENT_TYPE クライアントタイプをセッションに保管するパラメータ名。
static String | SP_COLOR_PATTERN_ID カラーパターンIDをセッションに保管するパラメータ名。
static String | SP_ENCODING ログインエンコーディングをセッションに保管するパラメータ名。
static String | SP_INITIAL_URL 初期ページURLを属性に保管するパラメータ名。
static String | SP_LOCALE ログインロケールをセッションに保管するパラメータ名。
static String | SP_LOGIN_GROUP ログイングループIDをセッションに保管するパラメータ名。
static String | SP_LOGIN_TIME ログインした時間をセッションに保管するパラメータ名。
static String | SP_LOGIN_TYPE ログインタイプをセッションに保管するパラメータ名。
static String | SP_SIGNATURE ログイン署名をセッションに保管するパラメータ名。
static String | SP_URL 認証後表示するメインページをセッションに保管するパラメータ名。
static String | SP_URL_SIGN ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
static String | SP_USER ログインユーザＩＤをセッションに保管するパラメータ名。
定数の詳細
CP_COOKIE

static String CP_COOKIE

セッション情報をクッキーに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.cookie"
CR_ERROR

static Number CR_ERROR

認証処理エラーの返却値。
定数値 ： -7
CR_LOCKED

static Number CR_LOCKED

アカウントロック状態の返却値。
定数値 ： -3
CR_NG

static Number CR_NG

ログインエラーの返却値。
定数値 ： 0
CR_NO_GROUP

static Number CR_NO_GROUP

ログイングループ未登録状態の返却値。
定数値 ： -2
CR_NO_LICENSE

static Number CR_NO_LICENSE

ライセンスなし、または有効期間外状態の返却値。
定数値 ： -1
CR_NO_PERMISSION

static Number CR_NO_PERMISSION

無許可ページへのアクセスの返却値。
定数値 ： -6
CR_NO_USER

static Number CR_NO_USER

ユーザ未登録状態の返却値。
定数値 ： 2
CR_OK

static Number CR_OK

認証成功の返却値。
定数値 ： 1
CR_SESSION_INITIAL

static Number CR_SESSION_INITIAL

セッション初期状態の返却値。
定数値 ： 2
CR_SESSION_LOGON

static Number CR_SESSION_LOGON

セッションログオン状態の返却値。
定数値 ： 3
CR_SESSION_TIMEOUT

static Number CR_SESSION_TIMEOUT

セッションタイムアウト状態の返却値。
定数値 ： -5
CR_SESSION_UNMATCH

static Number CR_SESSION_UNMATCH

セッション不整合状態の返却値。
定数値 ： -4
LT_GROUP

static String LT_GROUP

グループマネージャー（ログインタイプ）。
定数値 ： "group"
LT_SUPER

static String LT_SUPER

スーパーユーザ（ログインタイプ）。
定数値 ： "super"
LT_USER

static String LT_USER

ユーザ（ログインタイプ）。
定数値 ： "user"
RP_CLIENT_TYPE

static String RP_CLIENT_TYPE

クライアントタイプのデフォルトＵＲＬ引数名。
定数値 ： "im_client_type"
RP_ENCODING

static String RP_ENCODING

ログインエンコーディングのデフォルトＵＲＬ引数名。
定数値 ： "im_encoding"
RP_INITIAL_URL

static String RP_INITIAL_URL

初期ＵＲＬのデフォルトＵＲＬ引数名。
定数値 ： "im_initial_url"
RP_LOCALE

static String RP_LOCALE

ログインロケールのデフォルトＵＲＬ引数名。
定数値 ： "im_locale"
RP_LOGIN_GROUP

static String RP_LOGIN_GROUP

ログイングループIDのデフォルトＵＲＬ引数名。
定数値 ： "im_login_group"
RP_LOGIN_TYPE

static String RP_LOGIN_TYPE

ログインタイプのデフォルトＵＲＬ引数名。
定数値 ： "im_login_type"
RP_PASSWORD

static String RP_PASSWORD

パスワードのデフォルトＵＲＬ引数名。
定数値 ： "im_password"
RP_URL

static String RP_URL

ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
定数値 ： "im_url"
RP_URL_SIGN

static String RP_URL_SIGN

ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
定数値 ： "im_url_sign"
RP_USER

static String RP_USER

ログインユーザＩＤのデフォルトＵＲＬ引数名。
定数値 ： "im_user"
SP_CLIENT_TYPE

static String SP_CLIENT_TYPE

クライアントタイプをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.client_type"
SP_COLOR_PATTERN_ID

static String SP_COLOR_PATTERN_ID

カラーパターンIDをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.color_pattern_id"
SP_ENCODING

static String SP_ENCODING

ログインエンコーディングをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.encoding"
SP_INITIAL_URL

static String SP_INITIAL_URL

初期ページURLを属性に保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.initial.url"
SP_LOCALE

static String SP_LOCALE

ログインロケールをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.locale"
SP_LOGIN_GROUP

static String SP_LOGIN_GROUP

ログイングループIDをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.group"
SP_LOGIN_TIME

static String SP_LOGIN_TIME

ログインした時間をセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.login_time"
SP_LOGIN_TYPE

static String SP_LOGIN_TYPE

ログインタイプをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.login_type"
SP_SIGNATURE

static String SP_SIGNATURE

ログイン署名をセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.signature"
SP_URL

static String SP_URL

認証後表示するメインページをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.url"
SP_URL_SIGN

static String SP_URL_SIGN

ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.url.signature"
SP_USER

static String SP_USER

ログインユーザＩＤをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.user"


 System オブジェクト

システムマネージャオブジェクト。

システム設定情報を取得することができます。
通常 [install_directory]/conf/imart.xml が読み込まれた状態になっていますが、
任意の *.iniファイルを読み込んで値を定義する事も可能です。
複数の *.ini ファイルを読み込む場合、同じキーを定義しないように注意する必要があります。

システム管理者の参照、更新を行うことができます。
システム管理者の情報を操作する場合に用いるシステム管理者オブジェクトの構成は以下の通りです。
システム管理者オブジェクト
システム管理者
オブジェクト
(Object)
userId [必須] ユーザID (String)
password パスワード (String)
locale ロケール (String)
encoding エンコーディング (String)
mailAddress メールアドレス (String)
telNo 電話番号 (String)

システムで有効な、クライアントタイプ、ロケール、カラーパターンの情報を取得することができます。
上記の情報は、サーバマネージャの[install_directory]/conf/system.xmlで定義することが可能です。

システムマネージャで取得できるクライアントタイプオブジェクトの構成は以下の通りです。
クライアントタイプオブジェクト
クライアントタイプ
オブジェクト
(Object)
clientType [読み取り専用] クライアントタイプ (String)
displayName [読み取り専用] クライアントタイプ表示名 (String)

システムマネージャで取得できるロケールオブジェクトの構成は以下の通りです。
ロケールオブジェクト
ロケール
オブジェクト
(Object)
locale [読み取り専用] ロケール (String)
displayName [読み取り専用] ロケール表示名 (String)
encoding [読み取り専用] エンコーディング (String)
このロケールに対応したデフォルトのエンコーディングです。
encodings [読み取り専用] ロケール対応エンコーディングの配列 (StringのArray)
このロケールに対応したエンコーディングの一覧です。

システムマネージャで取得できるカラーパターンオブジェクトの構成は以下の通りです。
カラーパターンオブジェクト
カラーパターン
オブジェクト
(Object)
id [読み取り専用] カラーパターンID (String)
displayName [読み取り専用] カラーパターン表示名 (String)
このカラーパターンの表示名です。
code [読み取り専用] カラーコード (String)
このカラーパターンをイメージするカラーコードです。
cssFile [読み取り専用] CSSファイルのパス (String)
このカラーパターン用のCSSファイルが格納されているファイルのパスです。
コンテキストパスからの相対パスです。
imageFolder [読み取り専用] イメージフォルダのパス (String)
このカラーパターン用のイメージファイルが格納されているフォルダのパスです。
コンテキストパスからの相対パスです。
property[キー名] [読み取り専用] プロパティ (String)
このカラーパターンのキーに対する属性情報です。

システムメニューオブジェクトの構成は以下の通りです。
システムメニューオブジェクト
メニュー・モデル
オブジェクト
(Object)
id メニューID (String)
url URL (String)
displayName[ロケール] メニュー名 (String)
ロケール別の表示名です。
imagePath メニューイメージパス (String)
メニューのアイコンイメージです。
contents コンテンツの種類 (String)

バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static Boolean | addSuperUser(Object superUser) システム管理者を作成します。
static void | defineProperty(String key ,String value) システム設定情報を設定します。
static Object | getClientType(String locale ,String clientType) システムで有効なクライアントタイプ情報を取得します。
static Array | getClientTypes(String locale) システムで有効なクライアントタイプ情報の一覧を取得します。
static Object | getColorPattern(String reqLocale ,String colorId) システムで有効なカラーパターン情報を取得します。
static Object | getColorPatterns(String locale) システムで有効なカラーパターン情報の一覧を取得する。
static String | getDefaultClientType() デフォルトクライアントタイプを取得します。
static String | getDefaultColorPatternId() デフォルトカラーパターンIDを取得します。
static String | getDefaultLocale() デフォルトロケールを取得します。
static Number | getFloat(String key ,Number def) システム設定情報を取得します。
static Number | getInteger(String key ,Number def) システム設定情報を取得します。
static Object | getLocale(String regLocale ,String locale) システムで有効なロケール情報を取得します。
static Object | getLocales(String locale) システムで有効なロケール情報の一覧を取得します。
static Object | getSuperUser() システム管理者を取得します。
Date | getSystemMaxDate() 最大の未来日を取得します。
static Array | getSystemMenu() システムメニューを取得します。
Date | getSystemMinDate() 最大の過去日を取得します。
static Object | getValue(String key ,Object def) システム設定情報を取得します。
static Boolean | isFalse(String key) システム設定情報を真偽値としてチェックします。
static Boolean | isTrue(String key) システム設定情報を真偽値としてチェックします。
static Boolean | isValid(String key) システム設定情報をチェックします。
static Boolean | read(String file_name) iniファイルを読込みます。
static Boolean | updateSuperUser(Object superUser) システム管理者を更新します。
メソッドの詳細
addSuperUser

static Boolean addSuperUser(Object superUser)

システム管理者を作成します。
パラメータ
superUser Object システム管理者オブジェクト
返却値
Boolean 成功/失敗(true/false)
defineProperty

static void defineProperty(String key ,String value)

システム設定情報を設定します。

このメソッドはスレッドセーフではありません。
パラメータ
key | String | キー
value | String | キーに対応する値
返却値
void
getClientType

static Object getClientType(String locale ,String clientType)

システムで有効なクライアントタイプ情報を取得します。
存在しない指定ロケールおよびクライアントタイプが指定された場合はデフォルトのクライアントタイプ情報を返却します。
パラメータ
locale | String | ロケール
clientType | String | クライアントタイプ
返却値
Object クライアントタイプオブジェクト
getClientTypes

static Array getClientTypes(String locale)

システムで有効なクライアントタイプ情報の一覧を取得します。
指定したロケールのクライアントタイプオブジェクトの一覧を取得します。
クライアントタイプが一件も存在しない場合は、空の配列を返却します。
パラメータ
locale String ロケール
返却値
Array クライアントタイプオブジェクト の配列
getColorPattern

static Object getColorPattern(String reqLocale ,String colorId)

システムで有効なカラーパターン情報を取得します。

存在しない指定ロケールおよびカラーパターンIDが指定された場合はデフォルトのカラーパターン情報を返却します。
パラメータ
reqLocale | String | 指定ロケール
colorId | String | カラーパターンID
返却値
Object カラーパターンオブジェクト
getColorPatterns

static Object getColorPatterns(String locale)

システムで有効なカラーパターン情報の一覧を取得する。

指定したロケールのカラーパターンオブジェクトの一覧を取得します。
カラーパターン情報が一件も存在しない場合は空の配列を返却します。
パラメータ
locale String 指定ロケール
返却値
Object カラーパターンオブジェクト の配列
getDefaultClientType

static String getDefaultClientType()

デフォルトクライアントタイプを取得します。

デフォルトクライアントタイプが存在しない場合はnullが返却されます。
返却値
String デフォルトクライアントタイプ
getDefaultColorPatternId

static String getDefaultColorPatternId()

デフォルトカラーパターンIDを取得します。

デフォルトカラーパターンIDが存在しない場合はnullが返却されます。
返却値
String デフォルトカラーパターンID
getDefaultLocale

static String getDefaultLocale()

デフォルトロケールを取得します。

デフォルトロケールが存在しない場合はnullが返却されます。
返却値
String デフォルトロケール
getFloat

static Number getFloat(String key ,Number def)

システム設定情報を取得します。

指定したキーに対応するシステム設定情報を数値型で取得します。 指定キーが未定義の場合は null を返却します。 引数にて未定義時デフォルト値を指定の場合は、指定データを返却します。
パラメータ
key | String | 取得キー
def | Number | 指定キーが未定義の場合の返却値（浮動小数点型）
返却値
Number 取得情報（浮動小数点型）
getInteger

static Number getInteger(String key ,Number def)

システム設定情報を取得します。

指定したキーに対応するシステム設定情報を数値型で取得します。 指定キーが未定義の場合は null を返却します。 引数にて未定義時デフォルト値を指定の場合は、指定データを返却します。
パラメータ
key | String | 取得キー
def | Number | 指定キーが未定義の場合の返却値（整数型）
返却値
Number 取得情報（整数型）
getLocale

static Object getLocale(String regLocale ,String locale)

システムで有効なロケール情報を取得します。

存在しない指定ロケールおよび取得ロケールが指定された場合はデフォルトのロケール情報を返却します。
パラメータ
regLocale | String | 指定ロケール
locale | String | ロケール
返却値
Object ロケールオブジェクト
getLocales

static Object getLocales(String locale)

システムで有効なロケール情報の一覧を取得します。

指定したロケールのロケールオブジェクトの一覧を取得します。
ロケール情報が一件も存在しない場合は空の配列を返却します。
パラメータ
locale String 要求元ロケール
返却値
Object ロケールオブジェクト の配列
getSuperUser

static Object getSuperUser()

システム管理者を取得します。
返却値
Object システム管理者オブジェクト
getSystemMaxDate

Date getSystemMaxDate()

最大の未来日を取得します。

システムで取り扱う最大未来日を返却します。
取得に失敗した場合は、nullを返却します。
返却値
Date システムで取り扱う最大未来日
getSystemMenu

static Array getSystemMenu()

システムメニューを取得します。
返却値
Array システムメニューオブジェクトの配列
getSystemMinDate

Date getSystemMinDate()

最大の過去日を取得します。

システムで取り扱う最大過去日を返却します。
取得に失敗した場合は、nullを返却します。
返却値
Date システムで取り扱う最大過去日
getValue

static Object getValue(String key ,Object def)

システム設定情報を取得します。

指定したキーに対応するシステム設定情報を取得します。 指定キーが未定義の場合は null を返却します。 引数にて未定義時デフォルト値を指定の場合は、指定データを返却します。
パラメータ
key | String | 取得キー
def | Object | 指定キーが未定義の場合の返却値（任意指定）
返却値
Object 取得情報
isFalse

static Boolean isFalse(String key)

システム設定情報を真偽値としてチェックします。

指定したキーに対応するシステム設定情報が OFF または FALSE かどうかチェックします。
OFF または FALSE は大文字小文字も厳密に区別します。
パラメータ
key String 取得キー
返却値
Boolean OFF または FALSE の場合は、true
isTrue

static Boolean isTrue(String key)

システム設定情報を真偽値としてチェックします。

指定したキーに対応するシステム設定情報が ON または TRUE かどうかチェックします。
ON または TRUE は大文字小文字も厳密に区別します。
パラメータ
key String 取得キー
返却値
Boolean ON または TRUE の場合は、true
isValid

static Boolean isValid(String key)

システム設定情報をチェックします。

指定したキーがシステム設定情報として存在するかどうかチェックします。
パラメータ
key String 取得キー
返却値
Boolean 存在する場合は、true
read

static Boolean read(String file_name)

iniファイルを読込みます。

iniファイルを読み込んでシステム設定情報に設定します。
ファイル名は拡張子なしのファイルラベル名のみ指定します。
(自動で .ini を付加してファイル検索します。)
パラメータ
file_name String ファイル名(拡張子省略形式)
返却値
Boolean true ：ini ファイルの読込と設定が成功終了 false：ini ファイルの読込または設定に失敗
updateSuperUser

static Boolean updateSuperUser(Object superUser)

システム管理者を更新します。
パラメータ
superUser Object システム管理者オブジェクト
返却値
Boolean 成功/失敗(true/false)


 TermManager オブジェクト

TermManagerオブジェクト
期間に関する情報を扱うマネージャオブジェクトです。

TermManagerで扱われる期間情報オブジェクトの構成は以下の通りです。
期間情報オブジェクト
期間情報オブジェクト
(Object)
startDate 有効開始日時 (Date)
endDate 有効終了日時 (Date)

ここで有効開始日時と有効終了日時は常に次の関係である必要があります。

有効開始日時 < 有効終了日時

また、設定された有効開始日時および有効終了日時の時刻は、00:00:00 に切り捨てられます。
ただし、有効最大日時が設定された場合はその限りではありません。

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
message エラー発生時のメッセージ (String)
terms 期間配列 (期間情報オブジェクトの配列 (Array))
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static Date | getMaxDate() システムで設定できる期間の最大日時を取得します。
static Date | getMinDate() システムで設定できる期間の最小日時を取得します。
static Object | getOverlap(Array terms1 ,Array terms2) 2つの期間配列 term1 と term2 で重なっている期間を返します。
static Object | subtract(Array terms1 ,Array terms2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static Object | validateTerm(Date startDate ,Date endDate) 指定された2つの日時が有効な期間を構成するかどうか調べます。
static Object | validateTerms(Array terms) 指定された期間配列が有効かどうかを調べます。
メソッドの詳細
getMaxDate

static Date getMaxDate()

システムで設定できる期間の最大日時を取得します。
返却値
Date 期間の最大日時
getMinDate

static Date getMinDate()

システムで設定できる期間の最小日時を取得します。

返却値
Date 期間の最小日時
getOverlap

static Object getOverlap(Array terms1 ,Array terms2)

2つの期間配列 term1 と term2 で重なっている期間を返します。
期間に重なりが存在しない場合は、処理結果オブジェクトの期間配列に空の配列を設定します。
期間配列 term1 または term2 が null の場合も、空の配列を設定します。
パラメータ
terms1 | Array | 期間情報オブジェクトの配列
terms2 | Array | 期間情報オブジェクトの配列
返却値
Object 処理結果オブジェクト
subtract

static Object subtract(Array terms1 ,Array terms2)

期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
差し引かれる期間が存在しない場合は、処理結果オブジェクトの期間配列に空の配列を設定します。
期間配列 term1 または term2 が null の場合も、空の配列を設定します。
パラメータ
terms1 | Array | 期間情報オブジェクトの配列
terms2 | Array | 期間情報オブジェクトの配列
返却値
Object 処理結果オブジェクト
validateTerm

static Object validateTerm(Date startDate ,Date endDate)

指定された2つの日時が有効な期間を構成するかどうか調べます。
指定された日時が有効な期間を構成する場合は、処理結果オブジェクトの error に false を設定します。
そうでない場合は error に true、message に有効な期間を構成しないと判定した理由を設定します。
パラメータ
startDate | Date | 有効開始日時
endDate | Date | 有効終了日時
返却値
Object 処理結果オブジェクト
validateTerms

static Object validateTerms(Array terms)

指定された期間配列が有効かどうかを調べます。
指定された期間配列が有効である場合は、処理結果オブジェクトの error に false を設定します。
そうでない場合は error に true、message に期間配列が有効でないと判定した理由を設定します。
期間配列は以下の場合に有効でないと判定されます。

  ・期間配列にnullの要素が含まれている場合
  ・互いに重なる要素が含まれている場合
パラメータ
terms Array 期間情報オブジェクトの配列
返却値
Object 処理結果オブジェクト


 Unicode オブジェクト

Unicodeクラス。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | from(String target ,String code) 文字列を Unicode コード体系に変換します。
static String | to(String target ,String code) 文字列を他の文字コード体系に変換します。
メソッドの詳細
from

static String from(String target ,String code)

文字列を Unicode コード体系に変換します。
引数 code が未指定の場合、conf/imart.xml の intra-mart/server-charset の設定値をデフォルト値として適応します。
引数 codeには、java.io API と java.lang API でサポートされる文字エンコーディング名を指定できます。詳しくは以下を参照してください。
http://java.sun.com/j2se/1.4/ja/docs/ja/guide/intl/encoding.doc.html
引数不正時の動作については、未定義（保証外）。
パラメータ
target | String | 変換対象となる文字列(必須)
code | String | 変換対象となる文字列の現在の文字コード体系(任意)
返却値
String 変換結果文字列
to

static String to(String target ,String code)

文字列を他の文字コード体系に変換します。
引数 code が未指定の場合、conf/imart.xml の intra-mart/server-charset の設定値をデフォルト値として適応します。
引数 codeには、java.io API と java.lang API でサポートされる文字エンコーディング名を指定できます。詳しくは以下を参照してください。
http://java.sun.com/j2se/1.4/ja/docs/ja/guide/intl/encoding.doc.html
引数不正時の動作については、未定義（保証外）。
パラメータ
target | String | 変換対象文字列
code | String | 変換対象後の文字コード体系
返却値
String 変換結果文字列


 UserManager オブジェクト

UserManagerオブジェクト。

ユーザに関連する情報の更新を行うマネージャオブジェクトです。

ユーザに関連する情報を操作する場合に用いる ユーザ情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
ユーザ情報オブジェクト
ユーザ情報オブジェクト
(Object)
userCode ユーザコード (String)
accountFlag アカウントフラグ (String)
本プロパティはシステム内で利用されます。値を設定しても無視されます。
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
telephoneNumber 電話番号 (String)
mobileNumber 携帯電話番号 (String)
faxNumber FAX番号 (String)
extensionNumber 内線番号 (String)
extensionFaxNumber 内線FAX番号 (String)
countryCode 国コード (String)
zipCode 郵便番号 (String)
emailAddress1 メールアドレス１ (String)
emailAddress2 メールアドレス２ (String)
mobileEmailAddress 携帯用メール (String)
url URL (String)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name ユーザ名 (String)
nameSyllabary ユーザ名カナ (String)
nameEnglish ユーザ名英字 (String)
address 住所 (String)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(失敗) (Number)
message エラー発生時のメッセージ (String)

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
UserManager(String user ,String group)
コンストラクタ

メソッドの概要
Object | addUser(Object user) ユーザを登録します。
Object | deleteUser(Object user) 登録済のユーザを削除します。
Object | updateUser(Object user) 登録済のユーザを更新します。
コンストラクタの詳細
UserManager

UserManager(String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addUser

Object addUser(Object user)

ユーザを登録します。

パラメータ
user Object ユーザ情報オブジェクト
返却値
Object 処理結果オブジェクト
deleteUser

Object deleteUser(Object user)

登録済のユーザを削除します。

指定されたユーザの情報が存在しない場合は処理失敗となります。
パラメータ
user Object ユーザ情報オブジェクト
返却値
Object 処理結果オブジェクト
updateUser

Object updateUser(Object user)

登録済のユーザを更新します。

パラメータ
user Object ユーザ情報オブジェクト
返却値
Object 処理結果オブジェクト


 URL オブジェクト

URL操作クラス。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
URL(String page_path)
コンストラクタ。
メソッドの概要
String | absoluteLocation() ＵＲＬ（絶対パス）を取得します。
static String | createSessionURL(String url) 指定のＵＲＬに現在のセッションを維持するための情報を付加した ＵＲＬを作成して返します。
static String | decode(String target ,String enctype) ＵＲＬをデコードします。
static String | encode(String target ,String enctype) ＵＲＬをエンコードします。
String | getArgument() ＵＲＬ引数を取得します。
String | location() ＵＲＬを取得します。
void | setAction(String func_name) リクエスト時起動関数引数を設定します。
void | setArgument(String name ,String value) ＵＲＬ引数を設定します。
void | setLabel(String name) ラベルを設定します。
コンストラクタの詳細
URL

URL(String page_path)
コンストラクタ。
パラメータ
page_path String プログラムのページパス
メソッドの詳細
absoluteLocation

String absoluteLocation()

ＵＲＬ（絶対パス）を取得します。
返却値
String ＵＲＬ文字列（完全体）
createSessionURL

static String createSessionURL(String url)

指定のＵＲＬに現在のセッションを維持するための情報を付加した ＵＲＬを作成して返します。
パラメータ
url String ＵＲＬ
返却値
String セッションを維持したまま遷移するためのＵＲＬ
decode

static String decode(String target ,String enctype)

ＵＲＬをデコードします。
enctype 指定の場合
decode -> String(enctype) -> return(Unicode)
パラメータ
target | String | デコード対象文字列
enctype | String | デコード後の文字コード（任意）
返却値
String ＵＲＬデコード結果文字列
encode

static String encode(String target ,String enctype)

ＵＲＬをエンコードします。
enctype 指定の場合
argument(Unicode) -> String(enctype) -> encode
パラメータ
target | String | エンコード対象文字列
enctype | String | エンコード前の文字コード（任意）
返却値
String ＵＲＬエンコード結果文字列
getArgument

String getArgument()

ＵＲＬ引数を取得します。
name=value&name=value形式の文字列です。
返却値
String ＵＲＬ引数文字列
location

String location()

ＵＲＬを取得します。
返却値
String ＵＲＬ文字列
setAction

void setAction(String func_name)

リクエスト時起動関数引数を設定します。
パラメータ
func_name String JavaScript関数名
返却値
void
setArgument

void setArgument(String name ,String value)

ＵＲＬ引数を設定します。
パラメータ
name | String | キー
value | String | 値
返却値
void
setLabel

void setLabel(String name)

ラベルを設定します。
パラメータ
name String ラベル名
返却値
void


 VirtualFile オブジェクト

VirtualFile操作クラス。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
VirtualFile(Strig fileName)
ファイルオブジェクトを生成します。
メソッドの概要
Boolean | append(String strm) ファイルへのデータ追記出力します。
Array | directories() ディレクトリの一覧を取得します。
Boolean | exist() ファイルまたはディレクトリの存在をチェックします。
Array | files() ファイルの一覧を取得します。
Boolean | isDirectory() ディレクトリの存在をチェックします。
Boolean | isFile() ファイルの存在をチェックします。
Number | lastModified() 最終更新時刻の取得をします。
Array | lists() ファイルおよびディレクトリの一覧を取得します。
String | load() ファイルのデータを取得します。
Boolean | makeDirectories() ディレクトリを新規作成します。
Boolean | move(String newFile) ファイル名を変更します。
String | path() ファイルまたはディレクトリの名前を取得します。
String | read() ファイルのデータを取得します。
Boolean | remove() ファイルまたはディレクトリを削除します。
Boolean | save(String strm) ファイルへのデータ出力します。
Number | size() ファイルサイズを取得します。
Boolean | write(String strm) ファイルへデータ出力します。
コンストラクタの詳細
VirtualFile

VirtualFile(Strig fileName)
ファイルオブジェクトを生成します。
new VirtualFile(file_name) file_name: ファイル名(必須)
パラメータ
fileName Strig ファイル名
メソッドの詳細
append

Boolean append(String strm)

ファイルへのデータ追記出力します。
コンストラクタで指定されたファイルパスにアクセスします。
出力データは Unicode とみなしてローカルの文字コードに変換した結果を出力します。
パラメータ
strm String ファイルへ書き込むデータ（テキスト）
返却値
Boolean 真値：成功/偽値：失敗
directories

Array directories()

ディレクトリの一覧を取得します。
このオブジェクトが示すディレクトリ下のディレクトリを検索します。
返却は、ＪＳの配列データ。各要素は、ディレクトリ名称。
返却値
Array 一覧配列
exist

Boolean exist()

ファイルまたはディレクトリの存在をチェックします。
返却値
Boolean 真値：存在を確認/偽値：存在しない
files

Array files()

ファイルの一覧を取得します。
このオブジェクトが示すディレクトリ下のファイルを検索
返却は、ＪＳの配列データ。各要素は、ファイル名称。
返却値
Array 一覧配列
isDirectory

Boolean isDirectory()

ディレクトリの存在をチェックします。
返却値
Boolean 真値：ディレクトリとしての存在を確認/偽値：ディレクトリとして存在しない
isFile

Boolean isFile()

ファイルの存在をチェックします。
返却値
Boolean 真値：ファイルとしての存在を確認/偽値：ファイルとして存在しない
lastModified

Number lastModified()

最終更新時刻の取得をします。
返却値
Number ファイルが最後に変更された時刻をあらわす数値。
00:00:00 GMT. January 1, 1970 からのミリ秒
ファイルが存在しないか、入出力エラーの場合 0L
lists

Array lists()

ファイルおよびディレクトリの一覧を取得します。
このオブジェクトが示すディレクトリ下のメンバーを検索
返却は、ＪＳの配列データ。
各要素は、ディレクトリおよびファイル名称。
サブディレクトリまで再帰的に検索
返却値
Array 一覧配列
load

String load()

ファイルのデータを取得します。
ファイルデータ（バイナリ）の取得。エラーが発生した場合は null を返却
返却値
String ファイルの内容（バイナリ）
makeDirectories

Boolean makeDirectories()

ディレクトリを新規作成します。
存在していない必要な親ディレクトリも同時に作成します。
返却値
Boolean 真値：生成成功/偽値：生成失敗
move

Boolean move(String newFile)

ファイル名を変更します。
パラメータ
newFile String 新しいファイル名
返却値
Boolean 真値：名称変更に成功/偽値：名称変更に失敗
path

String path()

ファイルまたはディレクトリの名前を取得します。
返却値
String ファイルまたはディレクトリ名
read

String read()

ファイルのデータを取得します。
ファイルデータ（テキスト）を取得します。
返却データは Unicode に変換されています。
エラーが発生した場合は null を返却
返却値
String ファイルの内容（テキスト）
remove

Boolean remove()

ファイルまたはディレクトリを削除します。
ディレクトリが削除されるためには空である必要があります。
返却値
Boolean 真値：ファイルまたはディレクトリが正常の削除された/偽値：削除失敗
save

Boolean save(String strm)

ファイルへのデータ出力します。
コンストラクタで指定されたファイルパスにアクセスします。
パラメータ
strm String ファイルへ書き込むデータ（バイナリ）
返却値
Boolean 真値：成功/偽値：失敗
size

Number size()

ファイルサイズを取得します。
返却値
Number ファイルサイズ(バイト単位)/ファイルが存在しない場合 0L
write

Boolean write(String strm)

ファイルへデータ出力します。
コンストラクタで指定されたファイルパスにアクセスします。
出力データは Unicode とみなしてローカルの文字コードに変換した結果を出力します。
パラメータ
strm String ファイルへ書き込むデータ（テキスト）
返却値
Boolean 真値：成功/偽値：失敗


 Web オブジェクト

Webクラス。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | base() WebサーバのベースURLを取得します。
static String | current() 現在処理中ページパスを取得します。
static String | encodeRedirectURL(String url) sendRedirectメソッドの中で使えるように、 指定されたURLをエンコードします。
static String | encodeURL(String url) 指定されたURLがセッションIDを含むようにエンコードします。
static String | getContextPath() リクエストされたURIのうち、 リクエストのコンテキストを指す部分を返します。
static HTTPResponse | getHTTPResponse() レスポンスオブジェクトを返します。
static String | getHTTPResponseHeader(String name) 推奨されていません。代替えメソッドはありません。
static String | getProtocol() リクエストのプロトコル名とバージョンを HTTP/1.1 のように プロトコル名/メジャーバージョン番号.マイナーバージョン番号 の形式で返します。
static String | getRemoteAddr() リクエストを送ってきたクライアントの IP(Internet Protocol) アドレスを返します。
static String | getRemoteHost() リクエストを送ってきたクライアントの FQDN(Fully Qualified Domain Name: 完全修飾ドメイン名)を返します。
static String | getScheme() 例えば http や https, ftp のようなリクエストのスキームを返します。
static String | getServerName() リクエストを受け取ったサーバのホスト名を返します。
static int | getServerPort() このリクエストを受け取るのに使われたポート番号を返します。
static String | getenv(String ref_name) CGI 環境変数データを取得します。
static String | host() Ｗｅｂサーバ名を取得します。
static Boolean | isSecure() このリクエストが HTTPS のようなセキュアなチャネルを使って 送られたものかどうかを示す boolean を返します。
static String | location() リクエストURLを取得します。
static int | port() ＷｅｂサーバのＨＴＴＰポートを取得します。
static String | protocol() Ｗｅｂサーバのプロトコルを取得します。
static String | referer() リクエストを要求したページパスを取得します。
static String | referrer() 推奨されていません。Web.refererに置き換えられました。
static String | removeHTTPResponseHeader(String name) 推奨されていません。代替えメソッドはありません。
static String | script() Ｗｅｂサーバスクリプト名を取得します。
static void | setHTTPResponseHeader(String name ,String value) HTTP ヘッダを設定します。
メソッドの詳細
base

static String base()

WebサーバのベースURLを取得します。
"http://server:port/path" を返却します。
返却値
String ベースURL
current

static String current()

現在処理中ページパスを取得します。
返却値
String 処理中のページパス
encodeRedirectURL

static String encodeRedirectURL(String url)

sendRedirectメソッドの中で使えるように、 指定されたURLをエンコードします。
エンコードが不要である場合は指定されたURLをそのまま返します。 このメソッドの実装はセッションIDを URLにエンコードするかどうかを決定するためのロジックを含みます。
このメソッドがencodeURLメソッドとは別になっているのは、 この決定をするための規則が通常のリンクをエンコードするかどうかを 決定する規則と異なることがあるからです。
HttpServletResponse.sendRedirect メソッドに送られる全てのURLは このメソッドを通すべきです。
そうでなければ、Cookieをサポートしないブラウザでは URLリライティングの処理を行なうことができません。
パラメータ
url String エンコードするURL
返却値
String エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
encodeURL

static String encodeURL(String url)

指定されたURLがセッションIDを含むようにエンコードします。
パラメータ
url String エンコードするURL
返却値
String エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
getContextPath

static String getContextPath()

リクエストされたURIのうち、 リクエストのコンテキストを指す部分を返します。
コンテキストパスは通常リクエストURIの最初に来ます。 コンテキストパスは "/" から始まりますが、"/" では終わりません。
デフォルト（ルート）のコンテキストに属するServletの場合、 このメソッドは "" を返します。
コンテナはこの文字列をデコードしません。
返却値
String リクエストされたURIのうち、 リクエストのコンテキストを指す部分のString
getHTTPResponse

static HTTPResponse getHTTPResponse()

レスポンスオブジェクトを返します。
返却値
HTTPResponse レスポンス
getHTTPResponseHeader

static String getHTTPResponseHeader(String name)

推奨されていません。代替えメソッドはありません。
HTTP ヘッダを取得します。
パラメータ
name String HTTPヘッダの名称（文字列）
返却値
String 常にnullを返します。
getProtocol

static String getProtocol()

リクエストのプロトコル名とバージョンを HTTP/1.1 のように プロトコル名/メジャーバージョン番号.マイナーバージョン番号 の形式で返します。
HTTP Servlet ではこのメソッドで取得できる値は CGI で使用する環境変数の SERVER_PROTOCOL と同等です。
返却値
String プロトコル名とバージョンを示す
getRemoteAddr

static String getRemoteAddr()

リクエストを送ってきたクライアントの IP(Internet Protocol) アドレスを返します。
HTTP Servlet では CGI で使用される環境変数の REMOTE_ADDR と同等です。
返却値
String リクエストを送ってきたクライアントの IP アドレスを示す文字列
getRemoteHost

static String getRemoteHost()

リクエストを送ってきたクライアントの FQDN(Fully Qualified Domain Name: 完全修飾ドメイン名)を返します。
コンテナがホスト名を解決できないか、 (パフォーマンスを上げるため)解決しないように設定されている場合は IP アドレスをピリオドで区切った形式にして返します。
HTTP Servlet では CGI で使用される環境変数の REMOTE_HOST と同等です。
返却値
String クライアントの FQDN(Fullu Qualified Domain Name) を示す String
getScheme

static String getScheme()

例えば http や https, ftp のようなリクエストのスキームを返します。
RFC1738 で詳説されているように、スキームが違うと URL の形式も 違ってきます。
返却値
String このリクエストに使われたスキームを示す文字列
getServerName

static String getServerName()

リクエストを受け取ったサーバのホスト名を返します。
HTTP Servlet では CGI で使用する環境変数の SERVER_NAME と同等です。
返却値
String リクエストが送り込まれたサーバの名前を示す
getServerPort

static int getServerPort()

このリクエストを受け取るのに使われたポート番号を返します。
HTTP Servlet では CGI で使用される環境変数の SERVER_PORT と同等です。
返却値
int ポート番号を示す整数値
getenv

static String getenv(String ref_name)

CGI 環境変数データを取得します。
ＣＧＩ環境変数引数を取得
指定キーに該当するＣＧＩ環境変数が存在しない場合は null
パラメータ
ref_name String CGI 環境変数参照名称
返却値
String 環境変数データ
host

static String host()

Ｗｅｂサーバ名を取得します。
返却値
String Ｗｅｂサーバ名
isSecure

static Boolean isSecure()

このリクエストが HTTPS のようなセキュアなチャネルを使って 送られたものかどうかを示す boolean を返します。
返却値
Boolean リクエストがセキュアなチャネルを使って送られたものかどうかを示す boolean
location

static String location()

リクエストURLを取得します。
返却値
String リクエストURL
port

static int port()

ＷｅｂサーバのＨＴＴＰポートを取得します。
返却値
int ＷｅｂサーバのＨＴＴＰ待ち受けポート
protocol

static String protocol()

Ｗｅｂサーバのプロトコルを取得します。
返却値
String Ｗｅｂサーバのプロトコル
referer

static String referer()

リクエストを要求したページパスを取得します。
返却値
String リクエストを要求したページパス
referrer

static String referrer()

推奨されていません。Web.refererに置き換えられました。
リクエストを要求したページパスを取得します。
返却値
String リクエストを要求したページパス
removeHTTPResponseHeader

static String removeHTTPResponseHeader(String name)

推奨されていません。代替えメソッドはありません。
HTTPヘッダ情報を削除します。
パラメータ
name String HTTPヘッダの名称（文字列）
返却値
String 常にnullを返します。
script

static String script()

Ｗｅｂサーバスクリプト名を取得します。
返却値
String Ｗｅｂスクリプトファイル名
setHTTPResponseHeader

static void setHTTPResponseHeader(String name ,String value)

HTTP ヘッダを設定します。
パラメータ
name | String | HTTPヘッダの名称（文字列）
value | String | 値（文字列）
返却値
void


 XMLDocument オブジェクト

XMLを解析するパーサーオブジェクト。

XML を解析するパーサーを提供します。
このオブジェクトでは、XML の各タグをノードとして管理します。
各ノードは､属性と子供ノードを持ちます。
属性と子供ノードは複数持つ事ができ、子供ノードは更に属性と子供ノードを持つ事が出来ます。 すべてのノードの頂点となる親ノード（ドキュメントノード）は、XML ソース中の最も外側のタグであり、getDocumentElement() によって取得する事が出来ます。
ドキュメントノードが複数存在する場合は、XML 解析エラーとなりますのでご注意下さい。

XMLを解析してDOMツリーを作成するには、コンストラクタを使います。

例えば、以下のようなＸＭＬ
<A>
<B>Ｂタグの中のテキスト</B>
<C>Ｃタグの中のテキスト</C>
</A>

から、<C> タグに囲まれたテキスト値を取得する場合は以下のようにプログラムします。
var xml = "<A><B>Ｂタグの中のテキスト</B><C>Ｃタグの中のテキスト</C></A>";
var dom = new XMLDocument(xml);
var elms = dom.getElementsByTagName("C");
var elm = elms[0];
var childs = elm.getChildNodes();
var data = childs[0].getValue();
Debug.print("C's text: " + data);
バージョン：1.0
導入されたバージョン：3.0
コンストラクタの概要
XMLDocument(String src)
コンストラクタ。
メソッドの概要
DOMNode | createElement(String tagName) 新しいノードを作成します。
DOMNode | createTextNode(String data) 新しいテキストノードを作成します。
DOMDocumentType | getDoctype() ドキュメントタイプを取得します。
DOMNode | getDocumentElement() Documentノードを取得します。
DOMNode | getElementById(String elementId) 識別子に該当するノードを取得します。
Array | getElementsByTagName(String tagname) 指定のタグにマッチするエレメントを取得します。
String | getXmlString() XMLの文字列を取得します。
Boolean | isError() エラー発生のチェックを行います。
コンストラクタの詳細
XMLDocument

XMLDocument(String src)
コンストラクタ。

XML ソースを解析して各エンティティを操作するためのオブジェクトを構築します。
パラメータ
src String XML ソース
メソッドの詳細
createElement

DOMNode createElement(String tagName)

新しいノードを作成します。

パラメータ
tagName String タグ名
返却値
DOMNode 新しいノードオブジェクト
createTextNode

DOMNode createTextNode(String data)

新しいテキストノードを作成します。

パラメータ
data String テキスト
返却値
DOMNode 新しいノードオブジェクト
getDoctype

DOMDocumentType getDoctype()

ドキュメントタイプを取得します。

返却値
DOMDocumentType ドキュメントタイプオブジェクト
getDocumentElement

DOMNode getDocumentElement()

Documentノードを取得します。

返却値
DOMNode ドキュメントを示すノード
getElementById

DOMNode getElementById(String elementId)

識別子に該当するノードを取得します。

指定の識別子にマッチしたノードを返します。
指定の識別子を持つノードが存在しなかった場合 null を返します。
パラメータ
elementId String ノード識別子
返却値
DOMNode ノードオブジェクト
getElementsByTagName

Array getElementsByTagName(String tagname)

指定のタグにマッチするエレメントを取得します。

XML ソース中から指定のタグに該当するエンティティを返します。
返却値は、DOMNode オブジェクトを要素に持つ配列です。
不整合が発生してデータが取得できなかった場合 null が返ります。
パラメータ
tagname String タグ名
返却値
Array ノードオブジェクト(DOMNode)の配列
getXmlString

String getXmlString()

XMLの文字列を取得します。

返却値
String XML文字列
導入されたバージョン：5.0
isError

Boolean isError()

エラー発生のチェックを行います。

XML ソースを解析中にエラーが発生していた場合 true を返します。
返却値
Boolean true : エラーあり / false : エラーなし


 XMLParser オブジェクト

XMLを解析するパーサーオブジェクト。

XML を解析するパーサーを提供します。
ドキュメントノードが複数存在する場合は、XML 解析エラーとなりますのでご注意下さい。

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
XMLParser()
コンストラクタ。
メソッドの概要
String | getErrorMessage() エラーメッセージの取得を行います。
Boolean | isError() エラー発生のチェックを行います。
DOMDocument | parse(String path) Application Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。
DOMDocument | parse(File file) Application Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。
DOMDocument | parse(VirtualFile virtualFile) Storage Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。
DOMDocument | parseString(String src) 引数で与えられた文字列を XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。
コンストラクタの詳細
XMLParser

XMLParser()
コンストラクタ。

XMLを解析するパーサーオブジェクトを構築します。
メソッドの詳細
getErrorMessage

String getErrorMessage()

エラーメッセージの取得を行います。

XML ソースを解析中にエラーが発生していた場合、そのエラーメッセージを返します。
返却値
String エラーメッセージ
isError

Boolean isError()

エラー発生のチェックを行います。

XML ソースを解析中にエラーが発生していた場合 true を返します。
返却値
Boolean true : エラーあり / false : エラーなし
parse

DOMDocument parse(String path)

Application Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。

パラメータ
path String Application Runtime 環境のファイル・パス (Application Runtimeが稼動しているマシン上での絶対パス、または、 システムプロパティ user.dir で指定されるディレクトリからの相対パス)
返却値
DOMDocument DOMDocumentオブジェクト
parse

DOMDocument parse(File file)

Application Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。

パラメータ
file File ファイル操作オブジェクト
返却値
DOMDocument DOMDocumentオブジェクト
parse

DOMDocument parse(VirtualFile virtualFile)

Storage Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。

パラメータ
virtualFile VirtualFile VirtualFile操作クラス
返却値
DOMDocument DOMDocumentオブジェクト
parseString

DOMDocument parseString(String src)

引数で与えられた文字列を XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。

例えば、以下のようなＸＭＬ
 <A>
   <B>Ｂタグの中のテキスト</B>
   <C>Ｃタグの中のテキスト</C>
 </A>
から、<C> タグに囲まれたテキスト値を取得する場合は以下のようにプログラムします。

 var xmlString = "<A><B>Ｂタグの中のテキスト</B><C>Ｃタグの中のテキスト</C></A>";

 var parser = new XMLParser();
 var dom = parser.parseString(xmlString);

 if(!parser.isError()){
     var elms = dom.getElementsByTagName("C");
     var elm = elms[0];
     var childs = elm.getChildNodes();
     var data = childs[0].getValue();

     Debug.print("C's text: " + data);
 }
 else {
     Debug.print("Error occured ! : " + parser.getErrorMessage() );
 }
パラメータ
src String XML形式の文字列
返却値
DOMDocument DOMDocumentオブジェクト


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用

HTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | HTTPActionEventEntityHandler jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
class | HTTPActionEventFilterHandler HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

HTTPActionEventHandler を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventHandler HTTPActionEventFilterHandler.getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
class | PresentationFrameworkHTTPActionEventHandler im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
class | PresentationPageHTTPActionEventHandler ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application.content のコンストラクタ
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AccessibleLinkHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス AccessibleLinkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
public class AccessibleLinkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

再接続の為のＵＲＬを制御するフィルタ実装です。

このフィルタを利用する事で、同じセッション内でのその他のリクエストにおいて、 AbsoluteLinkFilter を経由した場合、全ての再接続リクエストのためのＵＲＬが 絶対形式の表現となります。
つまり、返される画面ソース(HTML)内の、 <FORM> の action 属性や、<A> の href 属性に指定する URL が、プロトコルおよびサーバアドレス等を含む絶対形式となります (javax.servlet.HttpServletResponse#encodeURL(java.lang.String) を利用して URL をエンコードしなかった場合は除く)。

これにより、例えばポータルサーバが別サイトとして運用されている場合においても、 各ポートレット内に配置されたリンクやフォームからシステムに直接アクセス できるようになります。

このフィルタは、サーバでの処理実行時に HttpSession が開始されていなかった場合、 HttpSession を新しく開始するように働きます。 それでもセッションを取得できなかった場合、将来の予期せぬエラーを防ぐため、 例外をスローしてサーバ処理をエラー終了します。 結果として、ハンドラの #execute() メソッドは、エラーを示す結果オブジェクトを 返す事になります。

導入されたバージョン:
version 4.3

コンストラクタの概要
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessibleLinkHTTPActionEventFilterHandler

public AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityFrameworkHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ActivityFrameworkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

public class ActivityFrameworkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

サービスフレームワークおよびプレゼンテーションフレームワークの実行環境を作成するためのフィルタ実装です。

このフィルタを利用する場合、事前にログイン環境を作成しておく必要があります。 したがって、AccountSecurityHTTPActionEventFilterHandler も 併用するようにしてください。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
推奨されていません。 フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityFrameworkHTTPActionEventFilterHandler

public ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。
フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
推奨されていません。
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application.content (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

参照:
説明

クラスの概要
AccessibleLinkHTTPActionEventFilterHandler | 再接続の為のＵＲＬを制御するフィルタ実装です。
ActivityFrameworkHTTPActionEventFilterHandler | 推奨されていません。 このフィルタは、何もしません。
PresentationFrameworkHTTPActionEventHandler | im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
PresentationPageHTTPActionEventHandler | ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler | im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

パッケージ jp.co.intra_mart.foundation.service.client.application.content の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

導入されたバージョン:
version 4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.service.client.application.content クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AccountSecurityHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス AccountSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
PasswordSecurityHTTPActionEventFilterHandler
public class AccountSecurityHTTPActionEventFilterHandler
extends GroupSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getAccount() 設定されているアカウントＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setAccount(String accountId) アカウントＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_ACCOUNT

protected static final String ID_SECURITY_ACCOUNT
関連項目:
定数フィールド値
コンストラクタの詳細

AccountSecurityHTTPActionEventFilterHandler

public AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                   String groupId,
                                                   String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス GroupSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setAccount

protected void setAccount(String accountId)
アカウントＩＤを設定します。

パラメータ:
accountId - アカウントＩＤ

getAccount

public String getAccount()
設定されているアカウントＩＤを返します。

戻り値:
アカウントＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ConcreteHTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ConcreteHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
public class ConcreteHTTPActionEventHandler
extends HTTPActionEventEntityHandler

任意の HTTPActionEvent を実行するためのハンドラです。

このハンドラを利用する事により、作成したイベントに 対応するハンドラを特別に作成することなく、 任意のイベントを実行する事ができます。
このハンドラは、jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の汎用ハンドラのため、 jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent 呼び出し時のパラメータを隠蔽化したい場合などは、 独自のハンドラを定義する必要がありますが、通常はこのハンドラで ほとんどの要件を満たせると思われます。

導入されたバージョン:
version 4.3

コンストラクタの概要
ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
メソッドの概要
 String getName()
イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getEventRequestParameterMap, getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConcreteHTTPActionEventHandler

public ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。

パラメータ:
name - イベント名
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSecurityHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス GroupSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
AccountSecurityHTTPActionEventFilterHandler
public class GroupSecurityHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループによる ログインセッション環境を作る事ができます。 このフィルタを利用する事により、 イベントプログラム中でログイングループを自動解決するＡＰＩを 利用可能になります。

実在しないグループを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_GROUP
コンストラクタの概要
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getGroup() 設定されているグループＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setGroup(String groupId) グループＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_GROUP

protected static final String ID_SECURITY_GROUP
関連項目:
定数フィールド値
コンストラクタの詳細

GroupSecurityHTTPActionEventFilterHandler

public GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                 String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setGroup

protected void setGroup(String groupId)
グループＩＤを設定します。

パラメータ:
groupId - グループＩＤ

getGroup

public String getGroup()
設定されているグループＩＤを返します。

戻り値:
グループＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventEntityHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventEntityHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
直系の既知のサブクラス:
ConcreteHTTPActionEventHandler, WebApplicationHTTPActionEventHandler
public abstract class HTTPActionEventEntityHandler
extends HTTPActionEventHandler

jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
void | removeParameter(String key) 指定のキーのマップを削除します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventEntityHandler

protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
直系の既知のサブクラス:
AccessibleLinkHTTPActionEventFilterHandler, ActivityFrameworkHTTPActionEventFilterHandler, GroupSecurityHTTPActionEventFilterHandler, LimitedSessionHTTPActionEventFilterHandler
public abstract class HTTPActionEventFilterHandler
extends HTTPActionEventHandler

HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。

HTTPActionEventHandler をフィルタリングする HTTPActionEventHandler は、 このクラスをスーパークラスとして実装する事を推奨します。

ユーザプログラムでは、フィルタリングしたいハンドラを基礎ハンドラとして フィルタハンドラを作成し、フィルタハンドラの HTTPActionEventHandler.execute(java.net.HttpURLConnection) を呼び出すことで、 Application Runtime でフィルタされた効果を得ながら 基礎ハンドラが指定するイベントを実行する事ができます。
なお、このハンドラを利用して呼び出すフィルターイベントは、 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を実装しているクラスでなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected String | getFilterParameter(String key) このフィルタのパラメータを返します。
protected Properties | getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
abstract String | getName() フィルタイベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
HTTPActionEventHandler | getParent() このオブジェクトがフィルタリングしているハンドラを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
protected String | removeFilterParameter(String key) このフィルタのパラメータを削除します。
void | removeParameter(String key) 指定のキーのマップを削除します。
protected void | setFilterParameter(String key, String value) このフィルタのパラメータを設定します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventFilterHandler

protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getParent

public HTTPActionEventHandler getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

戻り値:
ハンドラ

getName

public abstract String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String, String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

このメソッドは、単純のラップしている親ハンドラの #hasParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterKeySet() を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

このメソッドは、単純のラップしている親ハンドラの #removeParameter(String) を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterMap() を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

setFilterParameter

protected void setFilterParameter(String key,
                                  String value)
このフィルタのパラメータを設定します。

パラメータ:
key - パラメータ名
value - パラメータの値

getFilterParameter

protected String getFilterParameter(String key)
このフィルタのパラメータを返します。

パラメータ:
key - パラメータ名
戻り値:
パラメータの値

removeFilterParameter

protected String removeFilterParameter(String key)
このフィルタのパラメータを削除します。

パラメータ:
key - パラメータ名
戻り値:
設定されていたパラメータの値

getFilterParameterMap

protected Properties getFilterParameterMap()
                                    throws HTTPActionEventHandlerParameterException
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected final Properties getEventRequestParameterMap()
                                                throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
直系の既知のサブクラス:
HTTPActionEventEntityHandler, HTTPActionEventFilterHandler
public abstract class HTTPActionEventHandler
extends Object

jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

ハンドラを作成してイベント実行を要求する場合、execute(String) または execute(java.net.URL) を利用します。 execute(java.net.HttpURLConnection) も利用できますが、 通常はこの方法を使わない方が良いと思われます。

イベント実行を要求するＵＲＬは、 HTTPActionEventListener へ接続できるものを指定します。 標準では、下記のようになります。
http://<サーバアドレス>[:<ポート番号>]/imart/HTTPActionEventListener

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。
メソッドの概要
HTTPActionEventResult | execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
HTTPActionEventResult | execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
String | getCharacterEncoding() パラメータを符号化するためのエンコーディング名を返します。
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
abstract String | getParameter(String key) 設定したパラメータ値を取得します。
abstract Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
abstract Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
abstract boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
abstract void | removeParameter(String key) 指定のキーのマップを削除します。
void | setCharacterEncoding(String enc) パラメータを符号化するためのエンコーディング名を指定します。
abstract void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandler

protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

戻り値:
イベント名

setParameter

public abstract void setParameter(String key,
                                  String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

パラメータ:
key - キー
value - 値

getParameter

public abstract String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public abstract boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public abstract Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

戻り値:
キーのセット

removeParameter

public abstract void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

パラメータ:
key - キー

getParameterMap

public abstract Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getCharacterEncoding

public String getCharacterEncoding()
パラメータを符号化するためのエンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

public void setCharacterEncoding(String enc)
                          throws UnsupportedEncodingException
パラメータを符号化するためのエンコーディング名を指定します。

デフォルトでは UTF-8 を用いてパラメータを符号化します。 また、イベントへの各パラメータ値は Unicode のまま扱われますので、 通常は文字エンコーディングを変更する必要はありません。

パラメータ:
enc - 文字エンコーディング名
例外:
UnsupportedEncodingException - 指定のエンコーディング名がサポートされない場合

execute

public HTTPActionEventResult execute(String url)
                              throws MalformedURLException,
                                     IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の URL 文字列から java.net.URL のインスタンスを 作成して execute(java.net.URL) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
MalformedURLException
IOException

execute

public HTTPActionEventResult execute(URL url)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の java.net.URL から java.net.HttpURLConnection を取得して execute(java.net.HttpURLConnection) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
IOException

execute

public HTTPActionEventResult execute(HttpURLConnection connection)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

このメソッドは、 getParameterMap() の返り値をイベントの引数として サーバに対して getName() が表すイベントの 実行を要求します。

パラメータ:
connection - コネクション
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LimitedSessionHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス LimitedSessionHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
public class LimitedSessionHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

セッションを一時利用のみに限定するためのフィルタです。

イベント HTTPActionEvent では、セッション情報を扱う場合 javax.servlet.http.HttpSession を利用します。 したがって、明示的にセッション(javax.servlet.http.HttpSession)を破棄しない場合、 セッションのタイムアウトが発生するまで、サーバのメモリリソースを 消費したままの状態が維持されてしまいます。
このフィルタは、イベント処理終了時に javax.servlet.http.HttpSession#invalidate() を 実行してセッションを明示的に破棄します。 セッションを維持する必要のないイベント実行では、 このフィルタを利用することにより、サーバリソースの無駄な利用を 回避する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LimitedSessionHTTPActionEventFilterHandler

public LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

参照:
説明

インタフェースの概要
HTTPActionEventContent | Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventResult | HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL | Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

クラスの概要
AccountSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ActivityHTTPActionEventHandler | 持続したセッションを確立するためのハンドラです。
ConcreteHTTPActionEventHandler | 任意の HTTPActionEvent を実行するためのハンドラです。
GroupSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventEntityHandler | jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler | HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler | jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventResultWrapper | HTTPActionEventResult のラッパーオブジェクトです。
LimitedSessionHTTPActionEventFilterHandler | セッションを一時利用のみに限定するためのフィルタです。
PasswordSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ServletHTTPActionEventHandler | Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler | フレームワークを実行するためのイベントハンドラの抽象実装です。

例外の概要
HTTPActionEventHandlerException | HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException | HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.client.application の説明

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
このパッケージを利用することにより、intra-mart ではない環境から intra-mart 内のプログラム実行を行うことができるようになりますので、例えばユーザ情報の同期など、様々なことを実現することができます。

導入されたバージョン:
version 4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.service.client.application クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.service.client.application の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application の使用

jp.co.intra_mart.foundation.service.client.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application により使用される jp.co.intra_mart.foundation.service.client.application のクラス
AccountSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventContent
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventEntityHandler
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerException
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventResult
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
ServletHTTPActionEventHandler
Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content により使用される jp.co.intra_mart.foundation.service.client.application のクラス
HTTPActionEventEntityHandler
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


PasswordSecurityHTTPActionEventFilterHandler (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス PasswordSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
public class PasswordSecurityHTTPActionEventFilterHandler
extends AccountSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタは、AccountSecurityHTTPActionEventFilterHandler の機能に加えて パスワード認証も行います。したがって、AccountSecurityHTTPActionEventFilterHandler よりも 高度なセキュリティを実現しながらイベントを実行する事が可能となります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定したりパスワードが正しくない場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_PASSWORD
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getName() フィルタイベント名を返します。
String | getPassword() 設定されているパスワードを返します。
protected void | setPassword(String password) パスワードを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したメソッド
getAccount, setAccount
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_PASSWORD

protected static final String ID_SECURITY_PASSWORD
関連項目:
定数フィールド値
コンストラクタの詳細

PasswordSecurityHTTPActionEventFilterHandler

public PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                    String groupId,
                                                    String accountId,
                                                    String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
password - パスワード
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス AccountSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setPassword

protected void setPassword(String password)
パスワードを設定します。

パラメータ:
password - パスワード

getPassword

public String getPassword()
設定されているパスワードを返します。

戻り値:
パスワード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (5.0 J2EE-Base Programing Model API Specifications)

 すべてのクラス
AccessibleLinkHTTPActionEventFilterHandler
AccountSecurityHTTPActionEventFilterHandler
ActivityFrameworkHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
ConcreteHTTPActionEventHandler
GroupSecurityHTTPActionEventFilterHandler
HTTPActionEventContent
HTTPActionEventEntityHandler
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException
HTTPActionEventResult
HTTPActionEventResultWrapper
HTTPActionEventURL
LimitedSessionHTTPActionEventFilterHandler
PasswordSecurityHTTPActionEventFilterHandler
PresentationFrameworkHTTPActionEventHandler
PresentationPageHTTPActionEventHandler
ServiceFrameworkHTTPActionEventHandler
ServletHTTPActionEventHandler
WebApplicationHTTPActionEventHandler


定数フィールド値 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_ACCOUNT "filter-security-account"

jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_GROUP "filter-security-group"

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_PASSWORD "filter-security-password"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


非推奨 API のリスト (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


索引 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし
A C E G H I J L P R S W

A

AccessibleLinkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler.
再接続の為のＵＲＬを制御するフィルタ実装です。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のコンストラクタ
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
AccountSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
ActivityFrameworkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler.
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のコンストラクタ
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
ActivityHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler.
持続したセッションを確立するためのハンドラです。
ActivityHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。

C

ConcreteHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler.
任意の HTTPActionEvent を実行するためのハンドラです。
ConcreteHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のコンストラクタ
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。

E

execute(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(URL) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

G

GroupSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のコンストラクタ
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
getAccount() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
設定されているアカウントＩＤを返します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーション名を返します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーションＩＤを返します。
getBytes() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
サーバからレスポンスされたコンテンツのソースをバイト列として返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を返します。
getConnection() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
接続に利用したコネクションを返します。
getConnection() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
接続に利用したコネクションを返します。
getContent() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを返します。
getFilterParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
getFlowComponent() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているフローコンポーネント名を返します。
getGroup() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
設定されているグループＩＤを返します。
getInputStream() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getLocation() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
設定されている遷移先パスを返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のメソッド
推奨されていません。 フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getPagePath() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
設定されているページパスを返します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ値を取得します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このオブジェクトがフィルタリングしているハンドラを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
ラップしている親オブジェクトを返します。
getPassword() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
設定されているパスワードを返します。
getQueryString() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
設定されているパラメータ情報からクエリ文字列を作成して返します。
getRequestURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
このコンテンツを取得するために使用した URL を返します。
getResponseCode() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseCode() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseMessage() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResponseMessage() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getService() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているサービスＩＤを返します。
getStartPoint() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
設定されているスタートポイント名を返します。
getURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
サーバから返されたＵＲＬを返します。
getURL(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

H

HTTPActionEventContent - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent.
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventEntityHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler.
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventEntityHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler.
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のコンストラクタ
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
HTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler.
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventHandlerException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException.
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException.
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventHandlerParameterException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventResult - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult.
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventResultWrapper - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper.
HTTPActionEventResult のラッパーオブジェクトです。
HTTPActionEventResultWrapper(HTTPActionEventResult) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のコンストラクタ
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
HTTPActionEventURL - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL.
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

I

ID_SECURITY_ACCOUNT - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の static 変数
ID_SECURITY_GROUP - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の static 変数
ID_SECURITY_PASSWORD - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の static 変数
isError() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
処理要求が成功したかどうかを判定します。
isError() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
処理要求が成功したかどうかを判定します。

J

jp.co.intra_mart.foundation.service.client.application - package jp.co.intra_mart.foundation.service.client.application
このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content - package jp.co.intra_mart.foundation.service.client.application.content
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

L

LimitedSessionHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler.
セッションを一時利用のみに限定するためのフィルタです。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のコンストラクタ
セッションを一時利用に限定するためのフィルタハンドラを作成します。

P

PasswordSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String, String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
PresentationFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler.
im-J2EE Framework のプレゼンテーションフレームワークを実行するためのハンドラです。
PresentationFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のコンストラクタ
プレゼンテーションフレームワークを実行するためのハンドラを作成します。
PresentationFrameworkHTTPActionEventHandler(String, String, String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のコンストラクタ
プレゼンテーションフレームワークを実行するためのハンドラを作成します。
PresentationPageHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler.
ページベース開発モデルのプレゼンテーションページを実行するためのハンドラです。
PresentationPageHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPageHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。

R

removeFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定のキーのマップを削除します。

S

ServiceFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler.
im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServiceFrameworkHTTPActionEventHandler(String, String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServletHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler.
Web-Application を実行するためのイベントハンドラです。
ServletHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
ServletHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
setAccount(String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
アカウントＩＤを設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーション名を設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーションＩＤを設定します。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を指定します。
setFilterParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを設定します。
setFlowComponent(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのフローコンポーネント名を設定します。
setGroup(String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
グループＩＤを設定します。
setLocation(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
遷移先のページパスを設定します。
setPagePath(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
実行するページベース開発モデルのページパスを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントへのパラメータを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
パスワードを設定します。
setService(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのサービスＩＤを設定します。
setStartPoint(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler のメソッド
実行するフローのスタートポイント名を設定します。

W

WebApplicationHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler.
フレームワークを実行するためのイベントハンドラの抽象実装です。
WebApplicationHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
A C E G H I J L P R S W
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


概要 (5.0 J2EE-Base Programing Model API Specifications)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.service.client.application
jp.co.intra_mart.foundation.service.client.application.content


概要 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

intra-mart(R) 5.0 J2EE-Base Programing Model API Specifications

パッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.service.client.application, jp.co.intra_mart.foundation.service.client.application.content

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


直列化された形式 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.service.client.application

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException は HTTPActionEventHandlerException を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用

jp.co.intra_mart.foundation.service.provider.application での FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
protected abstract  void FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain)
イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEvent の使用

HTTPActionEvent を実装している jp.co.intra_mart.foundation.service.provider.application のクラス
 class FilterHTTPActionEvent
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventClientContext の使用

HTTPActionEventClientContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventClientContext HTTPActionEventContext.getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventContext の使用

HTTPActionEventContext 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
void | HTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
void | FilterHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventException の使用

HTTPActionEventException をスローする jp.co.intra_mart.foundation.service.provider.application のメソッド
 long HTTPActionEventContext.getRequestTime()
イベントの実行を要求した時刻を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventListenerContext HTTPActionEventContext.getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.application (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

参照:
説明

インタフェースの概要
FilterHTTPActionEventChain | FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent | Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext | Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext | Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventListenerContext | Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

クラスの概要
FilterHTTPActionEvent Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

例外の概要
HTTPActionEventException HTTPActionEvent に関するエラーを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.provider.application の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

導入されたバージョン:
version 4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.application クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application の階層

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.service.provider.application の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.application の使用

jp.co.intra_mart.foundation.service.provider.application により使用される jp.co.intra_mart.foundation.service.provider.application のクラス
FilterHTTPActionEventChain
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventException
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventListenerContext
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


すべてのクラス (5.0 J2EE-Base Programing Model API Specifications)

 すべてのクラス
FilterHTTPActionEvent
FilterHTTPActionEventChain
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContext
HTTPActionEventException
HTTPActionEventListenerContext


定数フィールド値 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


非推奨 API のリスト (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


索引 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし
A D F G H J

A

action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent のメソッド
イベント処理メソッドです。

D

doChain() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
doChain(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。

F

FilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent.
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
FilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のコンストラクタ
指定のイベントをラップするためのフィルターを作成します。
FilterHTTPActionEventChain - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain.
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。

G

getAcceptTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベント実行要求を受け付けたおよその時刻を返します。
getCharacterEncoding() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
リクエストパラメータの文字エンコーディングを返します。
getClientContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
getHttpServletRequest() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
現在のイベントを要求したリクエストを返します。
getListenerClass() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
リスナーとなっている Servlet の実行時クラスを返します。
getListenerContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
getRemoteHostAddress() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのアドレスを返します。
getRemoteHostName() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのホスト名を返します。
getRequest() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
getRequestTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求した時刻を返します。
getResponse() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。
getServletConfig() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。
getSystemProperty(String) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの値を返します。
getSystemPropertyNameSet() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。

H

HTTPActionEvent - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext.
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext.
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventException - exception jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException.
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventException(String) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventListenerContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext.
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

J

jp.co.intra_mart.foundation.service.provider.application - package jp.co.intra_mart.foundation.service.provider.application
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
A D F G H J
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


概要 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

intra-mart(R) 5.0 J2EE-Base Programing Model API Specifications

パッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.service.provider.application

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


直列化された形式 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.service.provider.application

クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.common.util.ServiceUtils の使用 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.common.util.ServiceUtils の使用

jp.co.intra_mart.framework.extension.common.util.ServiceUtils はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.extension.common.util (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

 jp.co.intra_mart.framework.extension.common.util
クラス
ServiceUtils


jp.co.intra_mart.framework.extension.common.util (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.common.util

im-J2EE Frameworkに連携するためのユーティリティです。

参照:
説明

クラスの概要
ServiceUtils im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。

パッケージ jp.co.intra_mart.framework.extension.common.util の説明

im-J2EE Frameworkに連携するためのユーティリティです。 im-J2EE Framework以外のコンポーネントからim-J2EE Frameworkにアクセスできます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前のパッケージ 次のパッケージ フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.extension.common.util クラス階層 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.common.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.common.util.ServiceUtils
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.extension.common.util の使用 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.common.util の使用

jp.co.intra_mart.framework.extension.common.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ServiceUtils (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.common.util
クラス ServiceUtils

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.common.util.ServiceUtils
public class ServiceUtils
extends Object

im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。

コンストラクタの概要
ServiceUtils()
メソッドの概要
static jp.co.intra_mart.framework.base.event.Event createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
static jp.co.intra_mart.framework.base.event.EventResult dispatchEvent(jp.co.intra_mart.framework.base.event.Event event)
イベントを実行します。
static String getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static String getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static jp.co.intra_mart.framework.base.util.UserInfo getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceUtils

public ServiceUtils()
メソッドの詳細

getLoginUserID

public static String getLoginUserID(HttpServletRequest request,
                                    HttpServletResponse response)
                             throws jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログインユーザIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザID
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ログインユーザID取得時に例外が発生

getLoginGroupID

public static String getLoginGroupID(HttpServletRequest request,
                                     HttpServletResponse response)
                              throws jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログイングループIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログイングループID
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ログイングループID取得時に例外が発生

getUserInfo

public static jp.co.intra_mart.framework.base.util.UserInfo getUserInfo(HttpServletRequest request,
                                                                        HttpServletResponse response)
                                                                 throws jp.co.intra_mart.framework.system.exception.SystemException
ユーザ情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ユーザ情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ユーザ情報取得時に例外が発生

createEvent

public static jp.co.intra_mart.framework.base.event.Event createEvent(String application,
                                                                      String key,
                                                                      HttpServletRequest request,
                                                                      HttpServletResponse response)
                                                               throws jp.co.intra_mart.framework.system.exception.SystemException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
request - リクエスト
response - レスポンス
戻り値:
イベント
例外:
jp.co.intra_mart.framework.system.exception.SystemException - イベント取得時に例外が発生

dispatchEvent

public static jp.co.intra_mart.framework.base.event.EventResult dispatchEvent(jp.co.intra_mart.framework.base.event.Event event)
                                                                       throws jp.co.intra_mart.framework.base.event.EventManagerException,
                                                                              jp.co.intra_mart.framework.base.event.EventException,
                                                                              jp.co.intra_mart.framework.system.exception.ApplicationException,
                                                                              jp.co.intra_mart.framework.system.exception.SystemException
イベントを実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
jp.co.intra_mart.framework.base.event.EventManagerException - イベントマネージャの生成に失敗
jp.co.intra_mart.framework.base.event.EventException - イベント処理実行に失敗
jp.co.intra_mart.framework.system.exception.ApplicationException - イベント処理時にアプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - イベント処理時にシステム例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.extension.struts.action.IntramartAction の使用 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.struts.action.IntramartAction の使用

jp.co.intra_mart.framework.extension.struts.action.IntramartAction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter の使用 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter の使用

jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


IntramartAction (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.struts.action
クラス IntramartAction

java.lang.Object
    拡張 org.apache.struts.action.Action
        拡張 jp.co.intra_mart.framework.extension.struts.action.IntramartAction
public class IntramartAction
extends org.apache.struts.action.Action

jp.co.intra_mart.framework.base.service.ServiceControllerAdapterと似たメソッドを持つActionクラスです。 いくつかのメソッドはHttpServletRequestと HttpServletResponseを必要とする点が jp.co.intra_mart.framework.base.service.ServiceControllerAdapter と異なります。

関連項目:
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter

フィールドの概要
クラス org.apache.struts.action.Action から継承したフィールド
ACTION_SERVLET_KEY, APPLICATION_KEY, DATA_SOURCE_KEY, defaultLocale, ERROR_KEY, EXCEPTION_KEY, FORM_BEANS_KEY, FORWARDS_KEY, LOCALE_KEY, MAPPING_KEY, MAPPINGS_KEY, MESSAGE_KEY, MESSAGES_KEY, MULTIPART_KEY, PLUG_INS_KEY, REQUEST_PROCESSOR_KEY, servlet, SERVLET_KEY, TRANSACTION_TOKEN_KEY
コンストラクタの概要
IntramartAction()
メソッドの概要
protected  jp.co.intra_mart.framework.base.event.Event createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
protected  jp.co.intra_mart.framework.base.event.EventResult dispatchEvent(jp.co.intra_mart.framework.base.event.Event event)
イベント処理を実行します。
protected  String getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  String getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  jp.co.intra_mart.framework.base.util.UserInfo getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
クラス org.apache.struts.action.Action から継承したメソッド
execute, execute, generateToken, getDataSource, getDataSource, getLocale, getResources, getResources, getResources, getServlet, isCancelled, isTokenValid, isTokenValid, perform, perform, resetToken, saveErrors, saveMessages, saveToken, setLocale, setServlet, toHex
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartAction

public IntramartAction()
メソッドの詳細

getLoginUserID

protected String getLoginUserID(HttpServletRequest request,
                                HttpServletResponse response)
                         throws jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログインユーザIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザID
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ログインユーザID取得時に例外が発生

getLoginGroupID

protected String getLoginGroupID(HttpServletRequest request,
                                 HttpServletResponse response)
                          throws jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログイングループIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログイングループID
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ログイングループID取得時に例外が発生

getUserInfo

protected jp.co.intra_mart.framework.base.util.UserInfo getUserInfo(HttpServletRequest request,
                                                                    HttpServletResponse response)
                                                             throws jp.co.intra_mart.framework.system.exception.SystemException
ユーザ情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ユーザ情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ユーザ情報取得時に例外が発生

createEvent

protected jp.co.intra_mart.framework.base.event.Event createEvent(String application,
                                                                  String key,
                                                                  HttpServletRequest request,
                                                                  HttpServletResponse response)
                                                           throws jp.co.intra_mart.framework.system.exception.SystemException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
request - リクエスト
response - レスポンス
戻り値:
イベント
例外:
jp.co.intra_mart.framework.system.exception.SystemException - イベント取得時に例外が発生

dispatchEvent

protected jp.co.intra_mart.framework.base.event.EventResult dispatchEvent(jp.co.intra_mart.framework.base.event.Event event)
                                                                   throws jp.co.intra_mart.framework.base.event.EventManagerException,
                                                                          jp.co.intra_mart.framework.base.event.EventException,
                                                                          jp.co.intra_mart.framework.system.exception.SystemException,
                                                                          jp.co.intra_mart.framework.system.exception.ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
jp.co.intra_mart.framework.base.event.EventManagerException - イベントマネージャの生成に失敗
jp.co.intra_mart.framework.base.event.EventException - イベント処理実行に失敗
jp.co.intra_mart.framework.system.exception.SystemException - イベント処理時にシステム例外が発生
jp.co.intra_mart.framework.system.exception.ApplicationException - イベント処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.extension.struts.action (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

 jp.co.intra_mart.framework.extension.struts.action
クラス
IntramartAction
StrutsConnectFilter


jp.co.intra_mart.framework.extension.struts.action (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.struts.action

im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

参照:
説明

クラスの概要
IntramartAction | jp.co.intra_mart.framework.base.service.ServiceControllerAdapterと似たメソッドを持つActionクラスです。
StrutsConnectFilter | intra-martのメニューからStrutsに接続するフィルターです。

パッケージ jp.co.intra_mart.framework.extension.struts.action の説明

im-J2EE FrameworkとStrutsを連携するためのユーティリティです。 Strutsからim-J2EE Frameworkにアクセスできます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前のパッケージ 次のパッケージ フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.framework.extension.struts.action クラス階層 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.struts.action の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class org.apache.struts.action.Action
      • class jp.co.intra_mart.framework.extension.struts.action.IntramartAction
    • class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter (implements javax.servlet.Filter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.framework.extension.struts.action の使用 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.struts.action の使用

jp.co.intra_mart.framework.extension.struts.action はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


StrutsConnectFilter (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.struts.action
クラス StrutsConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter
すべての実装インタフェース:
Filter
public class StrutsConnectFilter
extends Object
implements Filter

intra-martのメニューからStrutsに接続するフィルターです。 Struts用のロケールをセッションに登録します。

コンストラクタの概要
StrutsConnectFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) ロケールをセッションに登録し、次のフィルタに処理を移します。
void | init(FilterConfig filterConfig) フィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StrutsConnectFilter

public StrutsConnectFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
フィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
ロケールをセッションに登録し、次のフィルタに処理を移します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


すべてのクラス (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

 すべてのクラス
IntramartAction
ServiceUtils
StrutsConnectFilter


定数フィールド値 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


非推奨 API のリスト (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

推奨されていない API

推奨されていないメソッド
jp.co.intra_mart.framework.extension.common.util.ServiceUtils.getLoginGroupID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.struts.action.IntramartAction.getLoginGroupID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.common.util.ServiceUtils.getLoginUserID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.struts.action.IntramartAction.getLoginUserID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


API ヘルプ (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


索引 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
C D G I J S

C

createEvent(String, String, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
アプリケーションIDとキーに対応するイベントを取得します。

D

destroy() - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
フィルタを破棄します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
イベントを実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
イベント処理を実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
ロケールをセッションに登録し、次のフィルタに処理を移します。

G

getLoginGroupID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginGroupID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginUserID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginUserID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
ユーザ情報を取得します。
getUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
ユーザ情報を取得します。

I

IntramartAction - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction.
jp.co.intra_mart.framework.base.service.ServiceControllerAdapterと似たメソッドを持つActionクラスです。
IntramartAction() - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のコンストラクタ
init(FilterConfig) - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
フィルタを初期化します。

J

jp.co.intra_mart.framework.extension.common.util - package jp.co.intra_mart.framework.extension.common.util
im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action - package jp.co.intra_mart.framework.extension.struts.action
im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

S

ServiceUtils - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils.
im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。
ServiceUtils() - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils のコンストラクタ
StrutsConnectFilter - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter.
intra-martのメニューからStrutsに接続するフィルターです。
StrutsConnectFilter() - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のコンストラクタ
C D G I J S
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
すべてのクラス

パッケージ
jp.co.intra_mart.framework.extension.common.util
jp.co.intra_mart.framework.extension.struts.action


概要 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

intra-mart(R) im-J2EE Framework 5.0 Struts 連携
API 仕様

このドキュメントは、intra-martTM im-J2EE Framework 4.1 Struts 連携モジュールの API 仕様です。

参照:
説明

パッケージ
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

このドキュメントは、intra-martTM im-J2EE Framework 4.1 Struts 連携モジュールの API 仕様です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス階層 (intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.framework.extension.common.util, jp.co.intra_mart.framework.extension.struts.action

クラス階層

  • class java.lang.Object
    • class org.apache.struts.action.Action
      • class jp.co.intra_mart.framework.extension.struts.action.IntramartAction
    • class jp.co.intra_mart.framework.extension.common.util.ServiceUtils
    • class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter (implements javax.servlet.Filter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
im-J2EE Framework 5.0 Extension for Struts
前 次 フレームあり フレームなし
Copyright © 2003 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


(intra-mart im-J2EE Framework 5.0 Struts 連携 API ドキュメント)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


 backToMenu タグ

<IMART type="backToMenu"> タグ。

アンカータグ(<A>)によるリンクを生成します。
このタグは、モバイル用画面作成時専用ＡＰＩです。
内部タグ:
IMARTタグおよびHTML
使用例;
<IMART type="backToMenu">[MENU]</IMART>
画面上には「[MENU]」というリンクが表示されます。
このリンクをクリックしたら、メニュー画面が表示されます。
バージョン：1.0
導入されたバージョン：5.0


 barGraph タグ

<IMART type="barGraph"> タグ。

棒グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 dataMax および 属性 dataMin に対しては、負数の値を指定することも出来ます。
必ず　（属性dataMin の値）＜（属性 dataMax の値）　となるように指定して下さい。
属性 dataMax および 属性 dataMin を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
dataMin | true | 目盛りの最小値
dataMax | true | 目盛りの最大値
scaleCount | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="bar_graph"
       data=oData
       imageWidth="300"
       imageHeight="300"
       dataMin="-10"
       dataMax="50"
       scaleCount="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     グラフの色
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     グラフの色
oData.aData[2] = new Object();                                       // データ３
oData.aData[2].aData = new Array(20, 30, 50, 25, 45);                //     グラフデータ値
oData.aData[2].sColor = "green";                                     //     グラフの色

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               └ (String) sColor           // グラフの色（任意）

    sColor プロパティが未設定のとき、グラフの色にはデフォルト値（黒）が設定されます。
    sColorプロパティには カラーチャート のカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：5.0


 calendar タグ

<IMART type="calendar"> タグ。

カレンダー画面ＨＴＭＬソースを作成します。
group にはカレンダーＩＤを指定（任意）。
無指定の場合は、ログイングループＩＤを自動的に選択する。
format 属性には、以下のキーワードのうちの１つを指定する。
standard | 標準形式
compact | 標準形式の簡易機能版
horizontal | 横１行形式
vertical | 縦１行形式

click_action 属性は必ず“正しく”指定します。
（指定が正しくない場合にはスクリプトエラーとなる。）
click_action 属性に指定されたＣＳＪＳ関数は、日リンクがキックされた時にコールされる。
その時、引数が6つ渡される。

引数 | データ型 | 説明
第1引数 | Number | クリックされた年月日情報（1970/1/1からのミリ秒）
第2引数 | String | その日に設定されている名称
第3引数 | boolean | その日が休日かどうか
第4引数 | Number | クリックされた年情報
第5引数 | Number | クリックされた月情報
第6引数 | Number | クリックされた日情報

注意事項：
フレームワークに標準で組み込まれている『振替休日』をチェックするプラグイン関数は、“前日に対して休日設定が２種類以上適合”した場合に“休日”と判定するようにプログラムされています。
振替休日にしたくない場合には、非休日設定などを利用して設定を工夫するようにして下さい。

フレームワークに標準で組み込まれている『春分の日』および『秋分の日』をチェックするプラグイン関数は、予測値を計算するためのものであり、実際の法律で制定された祝日と異なる結果を示す場合があります。
『春分の日』および『秋分の日』に関する正式な日付に関しては、国立天文台が公示する文書を参考に設定するようにして下さい。

また、『春分の日』および『秋分の日』をチェックするプラグインは 1900 年以降 2099 年まで有効であり、この期間に含まれない年においては、正しくチェックできません。
初期データインポートで設定した初期データは、『春分の日』に関しては 1960 年から 2058 年まで、『秋分の日』に関しては 1983 年から 2099 年まで有効なデータのみを登録しています。この期間以外の年を指定してカレンダー表示を行うと、『春分の日』または『秋分の日』を正しく表示できない場合があります。

なお、カレンダー画面の表示は、<IMART type="link"> タグを利用する方法もあります。
詳しくは、APIリスト [ページベース開発モデル]-[ユニット]-[カレンダー表示モジュール] を参照してください。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
year | true | 作成するカレンダーの年
month | true | 作成するカレンダーの月(1 - 12)
group | false | カレンダー作成時に利用するカレンダーID
format | false | 使用するフォーマットファイルの指定
click_action | false | 日リンクのクリック時に実行する関数名
weekCaption | false | 曜日のキャプション（文字列の配列） 日曜 - 土曜までのキャプションを配列で指定します。 未指定の場合は、デフォルト値{"S","M","T","W","T","F","S"} になります。
使用例;
１９９９年５月のカレンダーを表示するＨＴＭＬ
<SCRIPT language="JavaScript">
function click_date(nDate, sName, bHoliday, nYear, nMonth, nDay) {
    // クリックされた日付情報をもつ DATE 変数作成
     var dClick = new Date(nDate);
     // 画面表示文字列変数
     var sStr = dClick.toString();
     // 画面表示文字列の作成
     sStr += "　[ " + sName + " ]";
     sStr += "　[ " + bHoliday + " ]";
     sStr += "　[ " + nYear + "/" + nMonth + "/" + nDay + " ]";
     // 画面に表示して引数の確認
     window.alert(sStr);
}
</SCRIPT>
<IMART type="calendar" year="1999"
month="5"
click_action="click_date">
</IMART>
バージョン：1.0
導入されたバージョン：5.0


 circleGraph タグ

<IMART type="circleGraph"> タグ。

円グラフの描画を行います。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
属性 marginCaption を指定すると、キャプションの表示位置を変更することが出来ます。
属性 marginCaption には、グラフの中心点からのマージンを指定して下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
marginCaption | false | キャプションの表示位置
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="circleGraph"
       data=oData
       imageWidth="300"
       imageHeight="300"
       marginCaption="60">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();

oData = new Array();
oData[0] = new Object();                 // データ１
oData[0].nData      = 500;               //     グラフデータ値
oData[0].sColor     = "red";             //     グラフの色
oData[0].sCaption   = "自動車";          //     キャプション文字列
oData[0].sFontColor = "pink";            //     キャプション文字色
oData[0].nFontSize  = 15;                //     キャプション文字サイズ
oData[1] = new Object();                 // データ２
oData[1].nData      = 400;               //     グラフデータ値
oData[1].sColor     = "blue";            //     グラフの色
oData[1].sCaption   = "工業機械"         //     キャプション文字列
oData[1].sFontColor = "skyblue";         //     キャプション文字色
oData[1].nFontSize  = 15;                //     キャプション文字サイズ
oData[2] = new Object();                 // データ３
oData[2].nData      = 300;               //     グラフデータ値
oData[2].sColor     = "green";           //     グラフの色
oData[2].sCaption   = "精密機械"         //     キャプション文字列
oData[2].nFontSize  = 15;                //     キャプション文字サイズ
oData[3] = new Object();                 // データ４
oData[3].nData      = 250;               //     グラフデータ値
oData[3].sColor     = "yellow";          //     グラフの色
oData[3].sCaption   = "家電"             //     キャプション文字列
oData[3].nFontSize  = 15;                //     キャプション文字サイズ

[data属性の構造]
    円グラフのデータ数分、data属性のObjectを配列（0 - n）で指定します。

      data属性 Object[]
         ├ (number) nData                  // グラフ値
         ├ (String) sColor                 // グラフの色
         ├ (String) sCaption               // 項目に表示するキャプションの文字列
         ├ (String) sFontColor             // キャプションの文字色（任意）
         └ (number) nFontSize              // キャプションの文字サイズ（任意）

    sColor プロパティが未設定のとき、該当するデータのグラフ色は無色で表示されます。
    sFontColor プロパティが未設定のとき、キャプション文字色にはデフォルト値（黒）が設定されます。
    nFontSize プロパティが未設定のとき、キャプション文字サイズにはデフォルト値（15）が設定されます。

    sColor または sFontColor プロパティには カラーチャートのカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：4.0


 condition タグ

<IMART type="condition"> タグ。

タグに挟まれた範囲内の部分の実行を制御します。
属性 validity に対して true 値を指定した場合は内部の処理を実行し、false 値を指定した場合は内部の処理を無視します。
属性 negative に対して true 値を指定した場合、 属性 validity に対して指定した値を逆解釈して処理します。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
validity | true | 有効・無効フラグ
negative | false | 条件反転判定
使用例;
<IMART type="condition" validity=flg>
真値
</IMART>
<IMART type="condition" validity=flg negative>
偽値
</IMART>
ファンクション・コンテナ側から変数 flg によりバインドされた真偽値により表示文字を動的選択します。
変数 flg の値が true であった場合は「真値」と表示され、false であった場合には「偽値」と表示されます。
バージョン：1.0
導入されたバージョン：2.0


 Content-Type タグ

<IMART type="Content-Type"> タグ。

クライアントへ送信される応答のコンテンツ形式を設定します。
属性 value に指定したコンテンツ形式が、応答ヘッダ Content-type の値になります。
コンテンツ形式には、たとえば text/html; charset=Shift_JIS のように、
使用される文字エンコーディングのタイプを含めることができます。

内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
value | true | コンテンツの MIME タイプを指定する文字列
使用例;
<IMART type="Content-Type" value="text/html; charset=Shift_JIS"></IMART>
応答ヘッダ Content-type が text/html; charset=Shift_JIS に設定されます。
バージョン：1.0
導入されたバージョン：5.0


 date タグ

<IMART type="date"> タグ。

タグの指定された場所に、指定された日付データを文字列として挿入します。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
value | true | 挿入する日付データ(Date型)
format | true | 表現フォーマット指定文字列
使用例;
<IMART type="date" value=dNow format="yyyy/MM/dd"></IMART>
このタグの位置に「2000/11/26」という形式で日付情報を表示します。
表示値は、ファンクション・コンテナから変数のバインドによって動的に指定します(バインド変数 dNow に対して)。
バージョン：1.0
導入されたバージョン：2.0


 decision タグ

<IMART type="decision"> タグ。

タグに挟まれた部分の実行の条件分岐を行います。
属性 value に与えられた値が、属性 case に与えられた値に等しい場合のみタグに挟まれた範囲内の実行を行います。
value または case 属性に対しては null および undefined 値以外の値を指定するようにして下さい。
上記の各属性に対して null および undefined 値を指定した場合の動作は保証外です。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
value | true | チェック対象の値
case | true | チェック値
使用例;
<IMART type="decision" case="OK" value=check>
該当
</IMART>
ファンクション・コンテナ側から変数 value によりバインドされた値がcase 属性に指定された値(この場合は "OK" という文字列)と等しい場合に内容を処理します。
変数 check の値が "OK" であった場合「該当」と表示されます。
バージョン：1.0
導入されたバージョン：2.0


 event タグ

<IMART type="event"> タグ。

ページに対して、ブラウザ上で動作するイベント処理型ロジックを追加します。
このタグは、Client Side Java Script を利用して実現されています。
また、値のブリッジには、ブラウザのクッキーを利用しています。
(クッキーを利用しているので別ウィンドウ同士の通信にも利用できます。)
そのため、クッキーの容量制限を越える量の値をやり取り(監視や受取)は できません。
また、このタグではクッキーを保存する際、クッキーの path 属性を 「/」として値を保存しています。
セキュリティ的に問題と なる場合には、この機能を利用しないで下さい。
属性 name には、動作する際のイベント名称(キーコード)を指定します。 この name 属性に指定したコードが等しい <IMART type="event"> 同士が連携して動作します。
属性 focus には、監視対象となる Client Side Java Script の変数名称を 文字列として指定して下さい。 focus 属性で指定された変数の内容が送信される事になります。
属性 receive には、監視対象値を受け取るための Client Side Java Script の変数名称を文字列として指定して下さい。 ここで指定した変数によって focus で監視している変数の値を受信する事が できます。
属性 init には、動作前にクッキーを初期化する必要がある場合、 その初期値を文字列として指定する事ができます。
属性 onChange には、focus 属性で指定された変数内の値が変化した際に 実行される Client Side Java Script のソースコードを文字列として指定します。
属性 time には、監視のタイミングをミリ秒で指定します。 focus 属性で指定された変数やクッキー内の情報は、タイマー機能を利用して 一定時間毎の監視を行っています。 デフォルトでは 250 ミリ秒毎に監視していますが、連動のタイミングをより リアルタイムにしたい場合は、この値を小さく設定し、ブラウザ処理の負荷が 高く動作が重い場合には、この値を大きく設定する事で任意に調整して下さい。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
name | true | カテゴリ名称
focus | true | 監視対象ＣＳＪＳ変数名称
receive | true | 監視変数内データの受け入れＣＳＪＳ変数名称
init | true | クッキー内初期値
onChange | true | データ変更時の実行スクリプト
time | true | クッキー監視間隔時間（ミリ秒）
使用例;
<FORM name="form_a">
<INPUT type="text" name="a_text">
</FORM>
<IMART type="event" name="text_copy" focus="document.form_a.a_text.value">
</IMART>
<FORM name="form_b">
<INPUT type="text" name="b_text">
</FORM>
<IMART type="event" name="text_copy" receive="document.form_b.b_text.value">
</IMART>
画面には二つのテキストフィールドが表示されます。
上のテキストフィールドに文字を記入すると、下のテキストフィールド内に上のテキストフィールドに入力した内容と同じものが表示されます。
バージョン：1.0
導入されたバージョン：2.0


 floatingCalendar タグ

<IMART type="floatingCalendar"> タグ。

ドラッグ＆ドロップで移動可能なカレンダーをフレーム上に表示します

表示されたカレンダーの日付をクリックすると、 引数「element」で指定された要素に、選択された日付の文字列を反映します。 （日付文字列の形式は、引数「format」で指定可能です。）
カレンダーは、「カレンダー表示基準年月」を元に表示します。
（カレンダー表示基準年月は、引数「year」「month」を元に算出されます）

引数「year」および「month」が正しい年月に変換できない場合（未指定時含む）、 カレンダー表示基準年月はシステム日付の「年月」となります。
引数「year」が2桁の場合、「00から49」は 2000年代、「50から99」は 1900年代として処理されます。
引数「year」および「month」にて生成される年月は、1582年10月以降である必要があります。（1582年10月以前の動作は未定義）

引数「addMonth」が未設定の場合、「カレンダー表示基準年月」のカレンダーを表示します。
引数「addMonth」が設定された場合、「カレンダー表示基準年月 + (addMonth)ヶ月」のカレンダーを表示します。

[リロード]ボタン押下時、システム日付の「年月」のカレンダーを表示します。
ただし、引数「element」で指定された要素の値が、日付フォーマット形式に合致している場合、 その要素の値から算出される年月のカレンダーを表示します。

注意事項：
HTMLファイルの <HEAD> タグ内に、必ずデザインスタイルシートタグ（imDesignCss タグ）および、
< SCRIPT src=" < %web_path% > /csjs/im_floating_calendar.js" > を記述してください。
（ < %web_path% > はWeb Server Connectorをインストールしたディレクトリ）

なお、 < %web_path% > /csjs/im_floating_calendar.jsは、URLの関係で呼び出し時のソースパスは変わります。
ページベース開発モデルの場合は、csjs/im_floating_calendar.js でリンクできます。

引数「position」に「event」を指定し、マウスクリック以外でカレンダーを表示すると、 IEの場合、マウスポインタがフレームから外れていると、カレンダーはフレームの外に表示されます。 NNの場合、フレームの左上（「left：0, top：0」）にカレンダーが表示されます。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
element | true | 選択した日付の文字列表現を反映する要素
year | false | カレンダー表示基準年（デフォルトは システム日付の「年」)
month | false | カレンダー表示基準月 [1-12]（デフォルトは システム日付の「月」)
addMonth | false | カレンダー表示基準年月からの移動量 [月単位で数値指定]（デフォルトは「0」）
calendarId false カレンダーID（デフォルトは「ログイングループのデフォルトカレンダーID」）
指定されたカレンダーIDが存在しない場合は、デフォルトカレンダーIDのカレンダーを表示します。
position false カレンダー表示位置 [event | 'left,top']（デフォルトは「event」)
event | マウスカーソルのそばに表示
'left,top' | 指定位置に表示(ピクセル指定)
format false 日付フォーマット（デフォルトは「yyyy/MM/dd」）
フォーマット指定文字（Format.fromDate()のフォーマット指定文字に準拠）
y | 年
M | 月
d | 日
E | 曜日
weekCaptions false カレンダーに表示する曜日のキャプション。（デフォルトは、"Su,Mo,Tu,We,Th,Fr,Sa"）
カンマ区切りでキャプションを7つ指定します。（例."日,月,火,水,木,金,土"）
キャプション数が7つではない場合、デフォルト値を表示します。
callback false カレンダーの日付をクリックした際に呼び出されるJavascript関数名。（デフォルトは、"callBackFloatingCalendar"）
指定された関数には、「引数「element」で指定された要素」、「選択された日付の文字列」が引数として渡されます。 （サンプルコード参照）
isUseElementMonth false trueが指定された場合、elementで指定された要素の値をカレンダー表示基準年月とします。
（ただし、elementで指定された要素の値が日付フォーマット形式でない場合、falseが指定されたことになります）
falseが指定された場合、引数「year」および「month」を元にカレンダー表示基準年月を算出します。
（デフォルトは「true」）
使用例;
●今月のカレンダーを表示するHTML
  ・テキストフィールド「document.floatingCalendarForm.date」にカレンダーで選択した日付を反映します。

<HTML>
  <HEAD>
    <IMART type="imDesignCss"></IMART>
    <SCRIPT src="csjs/im_floating_calendar.js"></SCRIPT>
  </HEAD>
  <BODY>
    <FORM name="floatingCalendarForm">
      <INPUT name="date" type="text" size="20" class="default">

      <!-- カレンダー（フローティング形式）を表示 -->
      <IMART type="floatingCalendar" element="document.floatingCalendarForm.date">
          <IMG src="sample.gif" border="0" alt="カレンダー用の画像">
      </IMART>
    </FORM>
  </BODY>
</HTML>

●以下の条件を満たしたカレンダーを表示するHTML
  ・2006年10月（＝2006年8月の2ヵ月後）のカレンダーを表示
  ・フレーム左上から、右に100px、下に200pxの位置にカレンダーを表示
  ・日付選択時に反映される文字列のフォーマットが「yyyy/MM/dd (E)」形式
  ・カレンダーID「sample」のカレンダーデータを表示
  ・表示カレンダーのキャプションを「日,月,火,水,木,金,土」で表示
  ・カレンダーの日付をクリックした際にJavascript関数「sampleCallBack」を呼び出す

<HTML>
  <HEAD>
    <IMART type="imDesignCss"></IMART>
    <SCRIPT src="csjs/im_floating_calendar.js"></SCRIPT>
    <SCRIPT type="text/javascript">
        function sampleCallBack(element, value){

            alert("sampleCallBack");
            alert("element.value = " + element.value);
            alert("value = " + value);

            element.value = value;
        }
    </SCRIPT>
  </HEAD>
  <BODY>
    <FORM name="floatingCalendarForm">
      <INPUT name="date" type="text" size="20" class="default">

      <!-- カレンダー（フローティング形式）を表示 -->
      <IMART type="floatingCalendar"
             element="document.floatingCalendarForm.date"
             year         = "2006"
             month        = "8"
             addMonth     = "2"
             position     = "100,200"
             format       = "yyyy/MM/dd (E)"
             calendarId   = "sample"
             weekCaptions = "日,月,火,水,木,金,土"
             callback     = "sampleCallBack">
          <IMG src="sample.gif" border="0" alt="カレンダー用の画像">
      </IMART>
    </FORM>
  </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：6.0


 form タグ

<IMART type="form"> タグ。

ページベース開発モデルのプログラムと連携するためのフォームを生成します。
フォームタグ(<FORM>)を生成します。
このタグを利用する事で intra-mart のセッションを維持しながら プログラムを動作させる事ができます。

属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定することで、ページ遷移をさせることができます。
ここで指定するパスは、インストールディレクトリ/pages/ からの相対パス形式になります。

属性 label は、遷移ページ内の任意のアンカータグ(<A name="*">)の位置を初期表示位置として指定する事ができます。
この指定はブラウザの機能を利用しているため、ブラウザ製品により期待通りに動作しない場合があります。

属性 action は、このリンクにより intra-mart がコールされた際に、同ページのファンクション・コンテナ内に定義されている関数をリクエスト時に起動するための指定で、起動させたい関数名称を指定する事で可能になります。
action 関数の実行は、次に表示するべきページの作成処理(該当ページのファンクション・コンテナ内 init() 関数)よりも先に動作します。

上記以外の属性と属性値は、そのまま <FORM> タグの属性となります。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
page | false | 表示ページパス
label | false | リンクラベル
action | false | コール時起動関数(同ページ js 内)
その他 | false | タグ属性と属性値
使用例;
<IMART type="form" page="sample/next" action="chkValue">
<INPUT type="submit">
</IMART>
画面上にはサブミットボタンが表示されます。
このボタンをクリックしたら、このページのファンクション・コンテナ内に定義されているchkValue() 関数を起動した後に sample/next ページを読込＆実行して画面上には sample/next ページが表示されます。
バージョン：1.0
導入されたバージョン：2.0


 frame タグ

<IMART type="frame"> タグ。

ページベースプログラムと連携するためのフレームを生成
フレームタグ(<FRAME>)を生成します。
このタグを利用する事で intra-mart のセッションを維持しながら プログラムを動作させる事が出来ます。
属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定する ことで、ページを表示させることができます。
ここで指定するパスは、インストールディレクトリ/pages/ からの相対パス形式になります。
属性 label は、遷移ページ内の任意のアンカータグ(<A name="*">)の位置を初期表示位置として指定する事ができます。
この指定はブラウザの機能を利用しているため、ブラウザ製品により期待通りに動作しない場合があります。
その他、表示ページ(属性 page に指定しているプログラム)に対して引き渡す ＵＲＬ引数を、任意の個数だけ指定可能です。
page に指定されたページの ファンクション・コンテナ内 init() 関数では、指定されたＵＲＬ引数を関数引数 request で受け取る事ができます。
その際、属性名称が引数 request オブジェクトのプロパティ名となり、 属性値が引数 request オブジェクトの該当プロパティに格納されます。
また <FRAME> タグに指定可能なオプション属性を任意に指定する事が出来ます。
<FRAME> タグの動作仕様に関しては、市販の HTML リファレンスを参照してください。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
page | true | 表示ページパス
label | false | リンクラベル
その他 | false | 表示ページへ渡すＵＲＬ引数および <FRAME> タグの各オプション属性
使用例;
<FRAMESET rows="50%,*">
<IMART type="frame" page="sample/top"></IMART>
<IMART type="frame" page="sample/bottom"></IMART>
</FRAMESET>
フレームを上下２つに分けて、それぞれ別なページをフレーム内に表示することができます（これはＨＴＭＬの機能です）。
この時、上のフレーム内にはページ sample/top が表示され、下のフレーム内にはページ sample/bottom が表示されます。
ページ sample/top と smple/bottom のリクエスト順と動作順は非同期であり保証される事はありません（ブラウザの制約です）。
バージョン：1.0
導入されたバージョン：2.0


 hidden タグ

<IMART type="hidden"> タグ。

フォームサブミット時のリクエスト引数となる隠しフィールドを作成します。
属性名がＵＲＬ引数の名称となり、属性値がＵＲＬ引数名称にマップされる値となります。
ブラウザからの受取時は、request.属性名 で取得可能です。
(request は、ファンクション・コンテナ実行時の関数引数です。)
ここでの指定は、ＵＲＬ引数となるため、属性名および属性値には定数または文字列型の値を指定するようにしてください。
(文字列以外の値が指定された場合の動作に関しては保証外。)
属性名と属性値は、複数個の同時指定が可能です。
(指定する属性値が１組の場合は、 <IMART type="input" style="hidden"> を利用して指定することもできます。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
その他 | false | hidden タグ名称と値
使用例;
<IMART type="form" action="form_action" page="sample/form_next">
<IMART type="hidden" arg_a="A" arg_b="B"></IMART>
</IMART>
このフォームをサブミットすると、該当するファンクション・コンテナ内に 定義されている form_action() 関数が起動されます。
この関数に引き渡される request オブジェクトを利用して hidden に指定した 値を受け取る事が出来ます。
また、この関数の実行終了後、sample/form_next ページの作成に入りますが、 この時、上記ページのファンクション・コンテナ内に定義されている init() 関数が起動されます。
この init() 関数でも request オブジェクトが引き渡されて、hidden の 値を受け取る事が出来ます。
受け取る request の構造は、以下のような形になります。
        request ┬ arg_a = "A"
                └ arg_b = "B"
バージョン：1.0
導入されたバージョン：2.0


 HTTP-EQUIV タグ

<IMART type="HTTP-EQUIV"> タグ。

指定された名前と値を持つ応答ヘッダを設定します。
属性 name にはヘッダの名前、属性 value にはヘッダの値を設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
name | true | ヘッダの名前
value | true | ヘッダの値
使用例;
<IMART type="HTTP-EQUIV" name="AAA" value="BBB"></IMART>
<IMART type="HTTP-EQUIV" name="CCC" value="DDD"></IMART>
以下の応答ヘッダが設定されます。

AAA: BBB
CCC: DDD
バージョン：1.0
導入されたバージョン：5.0


 IMART タグ リスト

このページでは、プレゼンテーション・ページで利用する各ＡＰＩに関して、プログラム・インターフェースの詳細仕様を記載しています。

<IMART> タグＡＰＩ仕様
1. | <IMART> タグは、必ず </IMART> と１対１の関係になるように記述しなければなりません（ </IMART> を未記述時の動作は未定義）。
2. | <IMART> タグ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。
3. | <IMART> タグ内に定義する各属性名、および属性値は、大文字・小文字を厳密に判定します。
4. <IMART> タグ内に定義する属性値は、" (ダブルクォート)で囲む事で定数値として扱われます。
(定数値バインド機能(アプリケーション共通モジュール Imart.defineAttribute() を参照)を利用している場合には、定数値バインド機能で定義されている値への変換対象としてみなされます。)

逆に、" (ダブルクォート)で囲まない場合には、対応するファンクション・コンテナ内に宣言された変数、または関数へのバインド対象として実行されます。
5. <IMART> タグ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。
6. プレゼンテーション・ページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内の <IMART> は実行されません。)


IMART タグ リスト

 IMART タグ

表示系タグ
calendar
date
floatingCalendar
frame
include
number
picture
string
tag
cal_view 非推奨

制御系タグ
condition
decision
event
loop
repeat

リクエスト系タグ
form
link
submit

レスポンス系タグ
Content-Type
HTTP-EQUIV

コントロール系タグ
hidden
input
select
textarea

グラフ描画系タグ
barGraph
circleGraph
lineGraph
portFolio
radarChart
bar_graph 非推奨
circle_graph 非推奨
line_graph 非推奨
port_folio 非推奨
radar_chart 非推奨

モバイル系タグ
backToMenu
back_to_menu 非推奨


 include タグ

<IMART type="include"> タグ。

任意のページベースプログラムをコールして部分ページソースを挿入します。
属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定する ことで、部分ページを表示させることができます。
ここで指定するパスは、 インストールディレクトリ/pages/ からの相対パス形式になります。
その他、表示ページ(属性 page に指定しているプログラム)に対して引き渡す 引数を、任意の個数だけ指定可能です。
page に指定されたページの ファンクション・コンテナ内 init() 関数では、引数 argV で受け取る事ができます。
その際、属性名称が引数 argV オブジェクトのプロパティ名となり、属性値が引数 argV オブジェクトの該当プロパティに格納されます。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
page | true | 実行対象ページソースパス
その他 | false | 実行ページへ渡す引数
使用例;
<IMART type="include" page="sample/sub"></IMART>
このタグの位置にページ sample/sub を実行した結果のソースを挿入します。
ページ sample/sub のファンクション・コンテナ内 init() 関数では、以下のように宣言する事で引数を受け取る事が出来ます。
function init(argV){ ・・・ }
バージョン：1.0
導入されたバージョン：2.0


 input タグ

<IMART type="input"> タグ。

任意のフォームコントロールを挿入します。
ＨＴＭＬの <INPUT> タグを生成します（ＨＴＭＬリファレンスを参照）。
属性 style に指定した文字列が <INPUT> タグの type 属性となります。
その他の属性と属性値は、そのまま <INPUT> タグの属性となります。
属性 style に対して有効な指定値には以下のものがあります。
text | テキストフィールド
password | パスワードフィールド
radio | ラジオボタン
checkbox | チェックボックス
hidden | 隠しフィールド
button | ボタン

<INPUT> タグの type 属性および各種設定可能な属性とその動作に関しては、ＨＴＭＬリファレンスをご参照下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
style | true | <INPUT> の type 属性名
その他 | false | タグ属性と属性値
使用例;
<IMART type="input" style="text" name="test1" value="default"></IMART>
フォームコントロールの一つであるテキストフィールドを表示します。
表示されたテキストフィールド内には「default」と初期表示されます。
出力されるＨＴＭＬソースは以下のようになります。
<INPUT type="text" name="test1" value="default">
属性 value などは、ファンクション・コンテナの変数をバインドする事によって動的な指定が可能です。
バージョン：1.0
導入されたバージョン：2.0


 lineGraph タグ

<IMART type="lineGraph"> タグ。

折れ線グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 dataMax および 属性 dataMin に対しては、負数の値を指定することも出来ます。
必ず、（属性dataMin の値）＜（属性 dataMax の値）　となるように指定して下さい。
属性 dataMax および 属性 dataMin を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
dataMin | true | 目盛りの最小値
dataMax | true | 目盛りの最大値
scaleCount | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="lineGraph"
       data=oData
       imageWidth="300"
       imageHeight="300"
       dataMin="-10"
       dataMax="50"
       scaleCount="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     線の色
oData.aData[0].nWidth = 2;                                           //     線の幅
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     線の色
oData.aData[1].nStyle = new Array(10, 5);                            //     線の形状

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               ├ (String) sColor           // 線の色（任意）
               ├ (number) nWidth           // 線の幅（任意）
               └ (number) nStyle[0...n]    // 線の形状（任意）［配列］

    sColor プロパティが未設定のとき、線の色にはデフォルト値（黒）が設定されます。
    nWidth プロパティが未設定のとき、線の幅にはデフォルト値（1）が設定されます。
    nStyle プロパティが未設定のとき、線の形状にはデフォルト値（実線）が設定されます。

    sColorプロパティには カラーチャート のカラー名を指定して下さい。

    nStyle プロパティは破線を引く時に使用します。
    破線のパターンを配列で指定することで、非透明の部分と透明の部分の長さを設定することができます。

    例１)
         oData.aData[0].nStyle[0] = 10;
         と指定した場合、破線パターンの指定が１つしかありませんので、
         表示される部分と表示されない部分がそれぞれ 10 のパターンが繰り返されます。

    例２)
         oData.aData[0].nStyle[0] = 10;
         oData.aData[0].nStyle[1] = 5;
         と指定した場合、破線パターンの指定が２つのため、
         表示される部分が 10 で、表示されない部分が 5 のパターンが繰り返されます。
バージョン：1.0
導入されたバージョン：5.0


 link タグ

<IMART type="link"> タグ。

アンカータグ(<A>)を生成します。
このタグを利用する事で intra-mart のセッションを維持しながらプログラムを 動作させる事が出来ます。
属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定する ことで、ページ遷移をさせることができます。ここで指定するパスは、インストールディレクトリ/pages/ からの相対パス形式になります。
属性 label は、遷移ページ内の任意のアンカータグ(<A name="*">)の位置を初期表示位置として指定する事ができます。この指定はブラウザの機能を利用しているため、ブラウザ製品により期待通りに動作しない場合があります。
属性 action に関数名称を指定すると、このリンクにより intra-mart がコールされた際に、同ページの ファンクション・コンテナ内に定義されている関数をリクエスト時に起動します。
属性 action で指定された関数は、次に表示するべきページの作成処理(該当ページの ファンクション・コンテナ内 init() 関数)よりも先に動作します。
リンクの画面表示名称は、このタグに挟まれた範囲内の文字列になります。
その他、表示ページ(属性 page に指定しているプログラム)に対して引き渡す ＵＲＬ引数を、任意の個数だけ指定可能です。属性 page に指定されたページの ファンクション・コンテナ内 init() 関数または、属性 action で指定された関数では、関数引数として request を受け取る事が できます。その際、属性名称が引数 request オブジェクトのプロパティ名となり、 属性値が引数 request オブジェクトの該当プロパティに格納されます。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
page | true | 表示ページパス
label | false | リンクラベル
action | false | コール時起動関数(同ページ js 内)
その他 | false | 表示ページへ渡すＵＲＬ引数
使用例;
<IMART type="link" page="sample/next" action="chkValue">
次ページ
</IMART>
画面上には「次ページ」というリンクが表示されます。
このリンクをクリックしたら、このページのファンクション・コンテナ内に定義されている chkValue() 関数を起動した後に sample/next ページを読込＆実行して画面上には sample/next ページが表示されます。
バージョン：1.0
導入されたバージョン：2.0


 loop タグ

<IMART type="loop"> タグ。

タグに挟まれている範囲内のソースを繰り返し処理します。
繰り返し処理は、属性 count に指定されている回数だけ行います。 (属性 count に、整数字列以外の指定がされた場合の動作は保証外。)
属性 index に、ファンクション・コンテナ内で定義してある変数名称を 指定する事で、何回目の繰り返しかを表す数値を受け取る事が出来ます。
(周回数は、0 から始まる整数値で、周回ごとに 1 ずつインクリメントされます。)
属性 action に対して、対応するファンクション・コンテナ内に定義されている 関数名称を文字列として指定すると、繰り返し処理毎に実行されます。
実行タイミングは、繰り返し処理の最初(タグに挟まれた範囲内の実行前)です。
指定関数は、繰り返し処理の開始から終了までに、繰り返し回数に 等しい回数だけ実行されます。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
count | true | 繰り返し回数
index | true | 周回番号の通知先変数名
action | true | 繰り返し毎に動作する関数
使用例;
<IMART type="loop" count="5" index="loop_number">
<IMART type="string" value=loop_number></IMART> 回目<BR>
</IMART>
画面には、以下のように出力されます。
0 回目
1 回目
2 回目
3 回目
4 回目
この場合は、必ず５回の繰り返し処理が行われます。
繰り返し毎に、属性 index で指定したファンクション・コンテナ内の変数に対して、繰り返し回数 - 1 の値が設定されます。
上記例では、ファンクション・コンテナ内に定義されている loop_number という変数を通して <IMART type="string"> タグを用いて、動的に回数を表示しています。
バージョン：1.0
導入されたバージョン：2.0


 number タグ

<IMART type="number"> タグ。

タグの指定されている個所に指定の数値データを文字列として挿入します。
（実際には、タグ部分が指定文字列で置換されるように動作します。）
フォーマット文字列は ###,### のように指定して下さい。
format 属性指定時の仕様に関しては、intra-mart Function Container APIの Format.fromNumber() メソッドに準拠します。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
value | true | 挿入する数値データ
format | true | 表現フォーマット指定文字列
使用例;
<IMART type="number" value=nMoney format="###,###"></IMART>
このタグの位置に「12,345」という形式で数値情報を表示します。
表示値は、ファンクション・コンテナから変数のバインドによって動的に指定します。
(バインド変数 nMoney に対して)
バージョン：1.0
導入されたバージョン：2.0


 picture タグ

<IMART type="picture"> タグ。

指定の画像ファイルを画面上に表示します。
表示するための画像ファイルは Storage Server に保存されている 必要があり、属性 src に対しては、Storage Server の storage/(標準) からの 相対でパス形式で指定します。 画像ファイルパスは拡張子まで完全な形で指定してください。
このタグでは、ファイルダウンロード機能を利用しています。ファイルダウンロード機能のＭＩＭＥ設定を適切におこなってください。
(標準で *.jpg, *.jpeg, *.gif ファイルに対応しています)
属性 src 以外は、<IMG> タグで利用可能な属性を任意に指定可能です。
(<IMG> タグの属性に関しては市販のＨＴＭＬリファレンスを参考にして下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
src | true | 画像ファイルのパス
その他 | false | <IMG> タグで指定可能な属性(複数指定可能)
使用例;
<IMART type="picture" src="picture/my_img.jpg" width="100%" height="100%"></IMART>
このタグの位置に Storage Server に保存されている画像ファイル storage/picture/my_img.jpg が表示されます。
属性 width および height を指定している事により、画像は縦横がフレームと同サイズで表示されます。
バージョン：1.0
導入されたバージョン：2.0


 portFolio タグ

<IMART type="portFolio"> タグ。

ポートフォリオ・グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）

属性 xDataSize には、横軸の中心値からのデータサイズを指定して下さい。
属性 yDataSize には、縦軸の中心値からのデータサイズを指定して下さい。
属性 xDataSize および yDataSize には負の値が指定されても、正の値として扱われます。

属性 scalePosition には、目盛りの表示位置を "center" か "side" で指定します。
未指定のときは、デフォルト位置（center:グラフの中心）に表示されます。

      center： グラフの中心（縦横軸に沿って）に表示
      side ： グラフの外枠に表示
その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
xCenterPoint | true | 横軸の中心値
xDataSize | true | 横軸の中心値からのデータサイズ
xScaleCount | true | 横軸１目盛りあたりの数
yCenterPoint | true | 縦軸の中心値
yDataSize | true | 縦軸の中心値からのデータサイズ
yScaleCount | true | 縦軸１目盛りあたりの数
scalePosition | false | 目盛りの表示位置
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="portFolio"
       data=oData
       imageWidth="300"
       imageHeight="300"
       xCenterPoint="10"
       xDataSize="-10"
       xScaleCount="5"
       yCenterPoint="0"
       yDataSize="50"
       yScaleCount="10">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();

oData = new Array();
oData[0] = new Object();                 // データ１
oData[0].nXData = 5;                     //     グラフ横軸データ値
oData[0].nYData = -30;                   //     グラフ縦軸データ値
oData[0].sColor = "red";                 //     点の色
oData[0].nSize  = 10;                    //     点のサイズ

oData[1] = new Object();                 // データ２
oData[1].nXData = 15;                    //     グラフの横軸データ値
oData[1].nYData = 20;                    //     グラフの縦軸データ値
oData[1].sColor = "blue";                //     点の色
oData[1].nSize  = 10;                    //     点のサイズ

oData[2] = new Object();                 // データ３
oData[2].nXData = 18;                    //     グラフの横軸データ値
oData[2].nYData = -20;                   //     グラフの縦軸データ値

[data属性の構造]
    グラフのデータ数分、data属性のObjectを配列（0 - n）で指定します。

      data属性 Object[]
         ├ (number) nXData                 // グラフ横軸値
         ├ (number) nYData                 // グラフ縦軸値
         ├ (String) sColor                 // 点の色（任意）
         └ (number) nSize                  // 点のサイズ（任意）

    sColor プロパティが未設定のとき、点の色にはデフォルト値（黒）が設定されます。
    nSize プロパティが未設定のとき、点のサイズにはデフォルト値（5）が設定されます。

    sColor プロパティには カラーチャート のカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：5.0


 radarChart タグ

<IMART type="radarChart"> タグ。

レーダーチャート・グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 dataMax および 属性 dataMin に対しては、負数の値を指定することも出来ます。
必ず　（属性dataMin の値）＜（属性 dataMax の値）　となるように指定して下さい。
属性 dataMax および 属性 dataMin を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)

属性 marginCaption を指定すると、キャプションの表示位置を変更することが出来ます。
属性 marginCaption には、グラフの外枠点からのマージンを指定して下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
dataMin | true | 目盛りの最小値
dataMax | true | 目盛りの最大値
marginCaption | false | キャプションの表示位置
scaleCount | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="radarChart"
       data=oData
       imageWidth="300"
       imageHeight="300"
       dataMin="-10"
       dataMax="50"
       marginCaption="120"
       scaleCount="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     グラフの色
oData.aData[0].bFill = true;                                         //     塗りつぶし可否
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     グラフの色

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               ├ (String) sColor           // グラフの色（任意）
               └ (boolean) bFill           // 塗りつぶしの可否（任意）

    sColor プロパティが未設定のとき、グラフの色にはデフォルト値（黒）が設定されます。
    sColor プロパティには カラーチャート のカラー名を指定して下さい。

    bFill プロパティはグラフの塗りつぶし可否を指定する時に使用します。
    bFill プロパティに対して true 値を指定したときは、グラフのデータ内部が塗りつぶされて表示され、
    false 値を指定したときは、グラフのデータ内部は塗りつぶされずに線のみで表示されます。
    bFill プロパティが未設定のとき、塗りつぶしの可否にはデフォルト値（false）が設定されます。
バージョン：1.0
導入されたバージョン：5.0


 repeat タグ

<IMART type="repeat"> タグ。

タグに挟まれた範囲内（ネスト部分）を指定の回数だけ繰り返し処理します。
属性 list に指定されたオブジェクト(or 配列)の要素数に 等しい回数だけk繰り返し処理を実行します。
属性 item に指定された変数名に該当する変数に対して、繰り返し毎に list から順次取得したデータを代入します。
属性 index に指定された変数名に該当する変数に対して、繰り返し毎に list から順次取得したプロパティ名称(or 要素番号)を代入します。
属性 min に動作開始インデックスを指定した場合、それ以前に取得できた値は 無視されて、指定インデックス以降のデータのみを繰り返し処理の対象とします。
属性 min を未指定にした場合のデフォルト動作は、0 を指定した場合と同様です。
属性 max に動作終了インデックスを指定した場合、それ以後に取得できた値は 無視されて、指定インデックス以前のデータのみを繰り返し処理の対象とします。
属性 max を未指定にした場合のデフォルト動作は、list に渡されたオブジェクト内に格納されているデータのうち、順次取得可能な最終データまでが処理対象となります。
属性 action に対して、対応するファンクション・コンテナ内に定義されている関数名称を文字列として指定すると、繰り返し処理毎に実行されます。
関数の実行タイミングは、繰り返し処理の最初(タグに挟まれた範囲内の実行前)です。
指定関数は、繰り返し処理の開始から終了までに、繰り返し回数に 等しい回数だけ実行されます。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
list | true | 繰り返し処理をする配列
item | true | 繰り返し処理中の配列内該当要素取得変数名
index | false | 繰り返し処理中の配列要素番号取得変数名
min | false | 繰り返し処理対象の最小要素番号
max | false | 繰り返し処理対象の最大要素番号
action | false | 繰り返し毎に動作する関数
使用例;
<IMART type="repeat" list=listObject item="record" index="idx">
<IMART type="string" value=idx></IMART> :
<IMART type="string" value=record></IMART><BR>
</IMART>
ファンクション・コンテナ側から変数 listObject によりバインドされたオブジェクトの中身を表示します。
画面上ではオブジェクト listObject の持つデータが『プロパティ名称 : 値』という組み合わせでオブジェクトの持つプロパティの数に等しい行数が表示されます。
バージョン：1.0
導入されたバージョン：2.0


 select タグ

<IMART type="select"> タグ。

フォーム内にコンボボックス（またはリストボックス）を表示します。
属性 list に対しては、オブジェクトを指定して下さい。
属性 list に指定したオブジェクトに格納されているすべての値が、コンボボックス内の表示要素になります。
属性 list に指定されたオブジェクトのプロパティ名がコンボボックス内の各要素(<OPTION> タグ)の value 値になり、該当するプロパティに格納されている値がコンボボックス内の要素の画面上での表示名になります。
(オブジェクトに格納されている値が文字列以外の場合の動作は保証外。)
属性 selected には、コンボボックスの初期選択(初期表示)値を指定します。
初期選択状態にする値のキー(属性 list に指定したオブジェクトの該当するプロパティ名)を指定することで、初期選択状態にすることができます。
属性 select に指定した値に該当するキーが属性 list に指定したオブジェクトのプロパティとして存在しない場合は、どの値も選択状態にはなりません。
(ただし、コンボボックスの初期選択指定が存在しない場合は、ブラウザの仕様で自動的にコンボボックス内の先頭の要素が初期選択状態として表示されます。)
また、初期選択状態とするキーを同時に複数個指定する場合は、属性 selected に対して配列を指定する事で可能になります。
その際、配列内の各要素の値として、初期選択状態にするキー(属性 list に指定したオブジェクトの該当するプロパティ名)を格納してください。
属性 blank は、コンボボックス内の任意の位置に空データを表示させるための属性指定になります。
値としてキーワード "top" を指定するとボックス内の先頭位置に空データが表示され、
キーワード "bottom" を指定するとボックス内の最後尾位置に空データが表示されます。
上記以外の属性を指定した場合、それらは <SELECT> タグの各属性として出力されます。
(<SELECT> タグの仕様に関しては市販のＨＴＭＬリファレンスを参照して下さい)。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
list | true | 表示リストの配列
selected | false | 初期選択値の設定
blank | false | キーワードの示す位置へブランクデータを挿入
その他 | false | <SELECT>タグ内に指定する各属性値
使用例;
<IMART type="form">
<IMART type="select" list=list_object></IMART>
<IMART type="select" list=list_object size="4"></IMART>
</IMART>
画面には、コンボボックスとリストボックスが表示されます。
ボックス内には、ファンクション・コンテナ内で作成された変数 list_objectオブジェクト内のデータが表示されます。
バージョン：1.0
導入されたバージョン：2.0


 string タグ

<IMART type="string"> タグ。

タグの指定されている個所に指定のデータを文字列として挿入 （実際には、タグ部分が指定文字列で置換されるように動作）します。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
value | true | 挿入データ
使用例;
<IMART type="string" value="ABC"></IMART>
このタグの位置に「ABC」と表示します。
表示値は、ファンクション・コンテナから変数のバインドによって動的な指定も可能です。
バージョン：1.0
導入されたバージョン：2.0


 submit タグ

<IMART type="submit"> タグ。

サブミットボタンを表示します。
属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定する ことで、ページを表示させることができます。
ここで指定するパスは、インストールディレクトリ/pages/ からの相対パス形式になります。
また、<IMART type="form"> にて page 属性が指定されていて遷移ページ先の 指定要求が重複した場合、<IMART type="submit"> で指定した page 指定が 優先され、<IMART type="form"> で指定した page 指定は無視されます。
属性 action は、このリンクにより intra-mart がコールされた際に、同ページの ファンクション・コンテナ内に定義されている関数をリクエスト時に起動するため の指定で、起動させたい関数名称を指定する事で可能になります。
action 関数の実行は、次に表示するべきページの作成処理(該当ページの ファンクション・コンテナ内 init() 関数)よりも先に動作します。
また、<IMART type="form"> にて action 属性が指定されていて関数実行要求が 重複した場合、<IMART type="submit"> で指定した action 関数が優先的に 実行され、<IMART type="form"> で指定した action 関数の実行要求は無視されます。
この <IMART type="submit"> は、１つのフォーム内に複数の配置が可能であり、 その際に指定した page および action 指定は、クリックされたサブミットボタン に対して個々に指定可能で、独立した動作をします。
なお、このタグは HTML の <INPUT type="submit"> の name 属性を利用して制御を行っています。 したがって、任意属性として name を記述した場合、 画面遷移や関数実行指定等が正常に動作しなくなります。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
page | false | リクエスト後の遷移先ページパス
action | false | リクエスト時の起動関数名
その他 | false | タグ属性と属性値
使用例;
<IMART type="form" action="form_action" page="sample/form_next">
<INPUT type="submit" value="submit_0">
<IMART type="submit" value="submit_1"></IMART>
<IMART type="submit" value="submit_2" action="sub_action_2"></IMART>
<IMART type="submit" value="submit_3" action="sub_action_3" page="sample/sub_next"></IMART>
</IMART>
画面には「submit_0」「submit_1」「submit_2」および「submit_3」という表示名称のサブミットボタンが４つ表示されます。
「submit_0」をクリックした場合は、ファンクション・コンテナ内のform_action() 関数を実行した後に sample/form_next というページを表示します。
「submit_1」をクリックした場合は、「submit_0」をクリックした場合と同様の動作をします。 「submit_2」をクリックした場合は、ファンクション・コンテナ内のsub_action_2() 関数を実行した後に sample/form_next というページを表示します。
「submit_3」をクリックした場合は、ファンクション・コンテナ内のsub_action_3() 関数を実行した後に sample/sub_next というページを表示します。
バージョン：1.0
導入されたバージョン：2.0


 tag タグ

<IMART type="tag"> タグ。

任意のタグを生成します。
属性 name には、目的のタグ名称を文字列として指定します。
(属性 name に対して、文字列型以外の値が指定された場合の動作は保証外。)
その他の属性は、そのまま、生成される任意タグの属性値となります。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
name | true | タグ名称
その他 | false | タグ属性と属性値
使用例;
<IMART type="tag" name="FONT" color="red">赤い文字</IMART>
画面には「赤い文字」という文字列が赤色で表示されます。
上記スクリプトで生成されるＨＴＭＬソースは以下のようになります。
<FONT color="red">赤い文字</FONT>
バージョン：1.0
導入されたバージョン：2.0


 textarea タグ

<IMART type="textarea"> タグ。

フォーム内にテキストエリアを表示します。 属性 value に対して指定した文字列を初期表示文字列とします。
(属性 value に対して文字列以外の値を指定した場合の動作は保証外。)
その他のタグ属性は、そのまま <TEXTAREA> タグの属性として指定されます。
(<TEXTAREA> タグの仕様に関しては、ＨＴＭＬリファレンスを参照下さい。)
タグに挟まれた範囲内に文字列を指定すると、テキストエリアの初期表示値とすることができます。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
value | true | テキストエリアに対する初期表示値(文字列)
その他 | false | タグ属性と属性値
使用例;
<IMART type="form">
<IMART type="textarea" value="バインド値"></IMART>
<IMART type="textarea">定数値</IMART>
</IMART>
画面には、２つのテキストエリアが表示されます。
一つは、テキストエリア内に「バインド値」という文字列が初期表示されます。
もう一つは、「定数値」という文字列が初期表示されます。
バージョン：1.0
導入されたバージョン：2.0


 back_to_menu タグ

奨励されていません。backToMenu タグに置き換えられました。
<IMART type="back_to_menu"> タグ。

アンカータグ(<A>)によるリンクを生成します。
このタグは、モバイル用画面作成時専用ＡＰＩです。
内部タグ:
IMARTタグおよびHTML
使用例;
<IMART type="back_to_menu">[MENU]</IMART>
画面上には「[MENU]」というリンクが表示されます。
このリンクをクリックしたら、メニュー画面が表示されます。
バージョン：1.0
導入されたバージョン：2.0


 bar_graph タグ

奨励されていません。barGraph タグに置き換えられました。
<IMART type="bar_graph"> タグ。

棒グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 data_max および 属性 data_min に対しては、負数の値を指定することも出来ます。
必ず　（属性data_min の値）＜（属性 data_max の値）　となるように指定して下さい。
属性 data_max および 属性 data_min を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
data_min | true | 目盛りの最小値
data_max | true | 目盛りの最大値
scale_count | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="bar_graph"
       data=oData
       image_width="300"
       image_height="300"
       data_min="-10"
       data_max="50"
       scale_count="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     グラフの色
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     グラフの色
oData.aData[2] = new Object();                                       // データ３
oData.aData[2].aData = new Array(20, 30, 50, 25, 45);                //     グラフデータ値
oData.aData[2].sColor = "green";                                     //     グラフの色

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               └ (String) sColor           // グラフの色（任意）

    sColor プロパティが未設定のとき、グラフの色にはデフォルト値（黒）が設定されます。
    sColorプロパティには カラーチャート のカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：4.0


 cal_view タグ

奨励されていません。calendar タグに置き換えられました。
<IMART type="cal_view"> タグ。

カレンダー画面ＨＴＭＬソースを作成します。
group にはデータカテゴリＩＤを指定（任意）。
無指定の場合は、ログイングループＩＤを自動的に選択する。
format 属性には、以下のキーワードのうちの１つを指定する。
standard | 標準形式
compact | 標準形式の簡易機能版
horizontal | 横１行形式
vertical | 縦１行形式

click_action 属性は必ず“正しく”指定します。
（指定が正しくない場合にはスクリプトエラーとなる。）
click_action 属性に指定されたＣＳＪＳ関数は、日リンクがキックされた時にコールされる。
その時、引数が6つ渡される。

引数 | データ型 | 説明
第1引数 | Number | クリックされた年月日情報（1970/1/1からのミリ秒）
第2引数 | String | その日に設定されている名称
第3引数 | boolean | その日が休日かどうか
第4引数 | Number | クリックされた年情報
第5引数 | Number | クリックされた月情報
第6引数 | Number | クリックされた日情報

<IMART type="link" page="@IM_CALENDAR_VIEW">カレンダー表示</IMART>
リンクタグにキーワード "@IM_CALENDAR_VIEW" を指定すると、カレンダー表示ページに遷移する。
また、キーワードを "@IM_CALENDAR_VIEW_COMPACT" とすると、"@IM_CALENDAR_VIEW" に比べて動作の軽いカレンダー画面が表示されます。

注意事項：
フレームワークに標準で組み込まれている『振替休日』をチェックするプラグイン関数は、“前日に対して休日設定が２種類以上適合”した場合に“休日”と判定するようにプログラムされています。
振替休日にしたくない場合には、非休日設定などを利用して設定を工夫するようにして下さい。

フレームワークに標準で組み込まれている『春分の日』および『秋分の日』をチェックするプラグイン関数は、予測値を計算するためのものであり、実際の法律で制定された祝日と異なる結果を示す場合があります。
『春分の日』および『秋分の日』に関する正式な日付に関しては、国立天文台が公示する文書を参考に設定するようにして下さい。

また、『春分の日』および『秋分の日』をチェックするプラグインは 1900 年以降 2099 年まで有効であり、この期間に含まれない年においては、正しくチェックできません。
初期データインポートで設定した初期データは、『春分の日』に関しては 1960 年から 2058 年まで、『秋分の日』に関しては 1983 年から 2099 年まで有効なデータのみを登録しています。この期間以外の年を指定してカレンダー表示を行うと、『春分の日』または『秋分の日』を正しく表示できない場合があります。

内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
year | true | 作成するカレンダーの年
month | true | 作成するカレンダーの月(1 - 12)
group | false | カレンダー作成時に利用するデータカテゴリ
format | false | 使用するフォーマットファイルの指定
click_action | false | 日リンクのクリック時に実行する関数名
使用例;
１９９９年５月のカレンダーを表示するＨＴＭＬ
<SCRIPT language="JavaScript">
function click_date(nDate, sName, bHoliday, nYear, nMonth, nDay) {
    // クリックされた日付情報をもつ DATE 変数作成
     var dClick = new Date(nDate);
     // 画面表示文字列変数
     var sStr = dClick.toString();
     // 画面表示文字列の作成
     sStr += "　[ " + sName + " ]";
     sStr += "　[ " + bHoliday + " ]";
     sStr += "　[ " + nYear + "/" + nMonth + "/" + nDay + " ]";
     // 画面に表示して引数の確認
     window.alert(sStr);
}
</SCRIPT>
<IMART type="cal_view" year="1999"
month="5"
click_action="click_date">
</IMART>
バージョン：1.0
導入されたバージョン：2.0


 circle_graph タグ

奨励されていません。circleGraph タグに置き換えられました。
<IMART type="circle_graph"> タグ。

円グラフの描画を行います。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
属性 margin_caption を指定すると、キャプションの表示位置を変更することが出来ます。
属性 margin_caption には、グラフの中心点からのマージンを指定して下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
margin_caption | false | キャプションの表示位置
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="circle_graph"
       data=oData
       image_width="300"
       image_height="300"
       margin_caption="60">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();

oData = new Array();
oData[0] = new Object();                 // データ１
oData[0].nData      = 500;               //     グラフデータ値
oData[0].sColor     = "red";             //     グラフの色
oData[0].sCaption   = "自動車";          //     キャプション文字列
oData[0].sFontColor = "pink";            //     キャプション文字色
oData[0].nFontSize  = 15;                //     キャプション文字サイズ
oData[1] = new Object();                 // データ２
oData[1].nData      = 400;               //     グラフデータ値
oData[1].sColor     = "blue";            //     グラフの色
oData[1].sCaption   = "工業機械"         //     キャプション文字列
oData[1].sFontColor = "skyblue";         //     キャプション文字色
oData[1].nFontSize  = 15;                //     キャプション文字サイズ
oData[2] = new Object();                 // データ３
oData[2].nData      = 300;               //     グラフデータ値
oData[2].sColor     = "green";           //     グラフの色
oData[2].sCaption   = "精密機械"         //     キャプション文字列
oData[2].nFontSize  = 15;                //     キャプション文字サイズ
oData[3] = new Object();                 // データ４
oData[3].nData      = 250;               //     グラフデータ値
oData[3].sColor     = "yellow";          //     グラフの色
oData[3].sCaption   = "家電"             //     キャプション文字列
oData[3].nFontSize  = 15;                //     キャプション文字サイズ

[data属性の構造]
    円グラフのデータ数分、data属性のObjectを配列（0 - n）で指定します。

      data属性 Object[]
         ├ (number) nData                  // グラフ値
         ├ (String) sColor                 // グラフの色
         ├ (String) sCaption               // 項目に表示するキャプションの文字列
         ├ (String) sFontColor             // キャプションの文字色（任意）
         └ (number) nFontSize              // キャプションの文字サイズ（任意）

    sColor プロパティが未設定のとき、該当するデータのグラフ色は無色で表示されます。
    sFontColor プロパティが未設定のとき、キャプション文字色にはデフォルト値（黒）が設定されます。
    nFontSize プロパティが未設定のとき、キャプション文字サイズにはデフォルト値（15）が設定されます。

    sColor または sFontColor プロパティには カラーチャートのカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：4.0


 line_graph タグ

奨励されていません。lineGraph タグに置き換えられました。
<IMART type="line_graph"> タグ。

折れ線グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 data_max および 属性 data_min に対しては、負数の値を指定することも出来ます。
必ず、（属性data_min の値）＜（属性 data_max の値）　となるように指定して下さい。
属性 data_max および 属性 data_min を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
data_min | true | 目盛りの最小値
data_max | true | 目盛りの最大値
scale_count | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="line_graph"
       data=oData
       image_width="300"
       image_height="300"
       data_min="-10"
       data_max="50"
       scale_count="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     線の色
oData.aData[0].nWidth = 2;                                           //     線の幅
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     線の色
oData.aData[1].nStyle = new Array(10, 5);                            //     線の形状

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               ├ (String) sColor           // 線の色（任意）
               ├ (number) nWidth           // 線の幅（任意）
               └ (number) nStyle[0...n]    // 線の形状（任意）［配列］

    sColor プロパティが未設定のとき、線の色にはデフォルト値（黒）が設定されます。
    nWidth プロパティが未設定のとき、線の幅にはデフォルト値（1）が設定されます。
    nStyle プロパティが未設定のとき、線の形状にはデフォルト値（実線）が設定されます。

    sColorプロパティには カラーチャート のカラー名を指定して下さい。

    nStyle プロパティは破線を引く時に使用します。
    破線のパターンを配列で指定することで、非透明の部分と透明の部分の長さを設定することができます。

    例１)
         oData.aData[0].nStyle[0] = 10;
         と指定した場合、破線パターンの指定が１つしかありませんので、
         表示される部分と表示されない部分がそれぞれ 10 のパターンが繰り返されます。

    例２)
         oData.aData[0].nStyle[0] = 10;
         oData.aData[0].nStyle[1] = 5;
         と指定した場合、破線パターンの指定が２つのため、
         表示される部分が 10 で、表示されない部分が 5 のパターンが繰り返されます。
バージョン：1.0
導入されたバージョン：4.0


 port_folio タグ

奨励されていません。portFolio タグに置き換えられました。
<IMART type="port_folio"> タグ。

ポートフォリオ・グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）

属性 x_data_size には、横軸の中心値からのデータサイズを指定して下さい。
属性 y_data_size には、縦軸の中心値からのデータサイズを指定して下さい。
属性 x_data_size および y_data_size には負の値が指定されても、正の値として扱われます。

属性 scale_position には、目盛りの表示位置を "center" か "side" で指定します。
未指定のときは、デフォルト位置（center:グラフの中心）に表示されます。

      center： グラフの中心（縦横軸に沿って）に表示
      side ： グラフの外枠に表示
その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
x_center_point | true | 横軸の中心値
x_data_size | true | 横軸の中心値からのデータサイズ
x_scale_count | true | 横軸１目盛りあたりの数
y_center_point | true | 縦軸の中心値
y_data_size | true | 縦軸の中心値からのデータサイズ
y_scale_count | true | 縦軸１目盛りあたりの数
scale_position | false | 目盛りの表示位置
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="port_folio"
       data=oData
       image_width="300"
       image_height="300"
       x_center_point="10"
       x_data_size="-10"
       x_scale_count="5"
       y_center_point="0"
       y_data_size="50"
       y_scale_count="10">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();

oData = new Array();
oData[0] = new Object();                 // データ１
oData[0].nXData = 5;                     //     グラフ横軸データ値
oData[0].nYData = -30;                   //     グラフ縦軸データ値
oData[0].sColor = "red";                 //     点の色
oData[0].nSize  = 10;                    //     点のサイズ

oData[1] = new Object();                 // データ２
oData[1].nXData = 15;                    //     グラフの横軸データ値
oData[1].nYData = 20;                    //     グラフの縦軸データ値
oData[1].sColor = "blue";                //     点の色
oData[1].nSize  = 10;                    //     点のサイズ

oData[2] = new Object();                 // データ３
oData[2].nXData = 18;                    //     グラフの横軸データ値
oData[2].nYData = -20;                   //     グラフの縦軸データ値

[data属性の構造]
    グラフのデータ数分、data属性のObjectを配列（0 - n）で指定します。

      data属性 Object[]
         ├ (number) nXData                 // グラフ横軸値
         ├ (number) nYData                 // グラフ縦軸値
         ├ (String) sColor                 // 点の色（任意）
         └ (number) nSize                  // 点のサイズ（任意）

    sColor プロパティが未設定のとき、点の色にはデフォルト値（黒）が設定されます。
    nSize プロパティが未設定のとき、点のサイズにはデフォルト値（5）が設定されます。

    sColor プロパティには カラーチャート のカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：4.0


 radar_chart タグ

奨励されていません。radarChart タグに置き換えられました。
<IMART type="radar_chart"> タグ。

レーダーチャート・グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 data_max および 属性 data_min に対しては、負数の値を指定することも出来ます。
必ず　（属性data_min の値）＜（属性 data_max の値）　となるように指定して下さい。
属性 data_max および 属性 data_min を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)

属性 margin_caption を指定すると、キャプションの表示位置を変更することが出来ます。
属性 margin_caption には、グラフの外枠点からのマージンを指定して下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
data_min | true | 目盛りの最小値
data_max | true | 目盛りの最大値
margin_caption | false | キャプションの表示位置
scale_count | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="radar_chart"
       data=oData
       image_width="300"
       image_height="300"
       data_min="-10"
       data_max="50"
       margin_caption="120"
       scale_count="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     グラフの色
oData.aData[0].bFill = true;                                         //     塗りつぶし可否
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     グラフの色

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               ├ (String) sColor           // グラフの色（任意）
               └ (boolean) bFill           // 塗りつぶしの可否（任意）

    sColor プロパティが未設定のとき、グラフの色にはデフォルト値（黒）が設定されます。
    sColor プロパティには カラーチャート のカラー名を指定して下さい。

    bFill プロパティはグラフの塗りつぶし可否を指定する時に使用します。
    bFill プロパティに対して true 値を指定したときは、グラフのデータ内部が塗りつぶされて表示され、
    false 値を指定したときは、グラフのデータ内部は塗りつぶされずに線のみで表示されます。
    bFill プロパティが未設定のとき、塗りつぶしの可否にはデフォルト値（false）が設定されます。
バージョン：1.0
導入されたバージョン：4.0


jp.co.intra_mart.common.platform.util (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.util

このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。

参照:
説明

クラスの概要
DateUtil 日付操作ユーティリティクラスです。

パッケージ jp.co.intra_mart.common.platform.util の説明

このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.platform.util クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.util.DateUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.common.platform.vm (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.vm

このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

参照:
説明

クラスの概要
CommandLineArgument このクラスはコマンド実引数を解釈するための共通実装です。

パッケージ jp.co.intra_mart.common.platform.vm の説明

このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.platform.vm クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.vm の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.vm.CommandLineArgument
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


すべてのクラス (5.0 J2EE-Base Programing Model API Specifications)

 すべてのクラス
CommandLineArgument
DateUtil


索引 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし
C D G H J S

C

CommandLineArgument - class jp.co.intra_mart.common.platform.vm.CommandLineArgument.
このクラスはコマンド実引数を解釈するための共通実装です。
CommandLineArgument(String[]) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のコンストラクタ
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。
convertOnlyDate(long) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付のみのjava.util.Dateに変換します。
convertOnlyDate(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付のみのjava.util.Dateに変換します。
convertOnlyDateTime(long) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付と時刻のみのjava.util.Dateに変換します。
convertOnlyDateTime(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付と時刻のみのjava.util.Dateに変換します。

D

DateUtil - class jp.co.intra_mart.common.platform.util.DateUtil.
日付操作ユーティリティクラスです。
dateToString(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
データベース登録用文字列を取得します。

G

getArgument(int) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのコマンドライン引数の引数を返します。
getArguments() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのコマンドライン引数の引数を返します。
getMaxDate() - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
システムで許可されている最大日時を取得します。
getMinDate() - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
システムで許可されている最小日時を取得します。
getOption(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOption(String, String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOptionNames() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのオプションの名前を返します。
getOptions(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getQuery() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
引数情報を取得します。

H

hasArguments() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
コマンドライン引数があるかどうか判定します。
hasOption(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションが指定されているかどうか判定します。

J

jp.co.intra_mart.common.platform.util - package jp.co.intra_mart.common.platform.util
このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。
jp.co.intra_mart.common.platform.vm - package jp.co.intra_mart.common.platform.vm
このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

S

stringToDate(String) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
データベース登録用文字列からjava.util.Dateを取得します。
C D G H J S
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


概要 (5.0 J2EE-Base Programing Model API Specifications)

すべてのクラス

パッケージ
jp.co.intra_mart.common.platform.util
jp.co.intra_mart.common.platform.vm


概要 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

intra-mart(R) 5.0 J2EE-Base Programing Model API Specifications

パッケージ
jp.co.intra_mart.common.platform.util | このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。
jp.co.intra_mart.common.platform.vm | このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.common.platform.util, jp.co.intra_mart.common.platform.vm

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.vm.CommandLineArgument
    • class jp.co.intra_mart.common.platform.util.DateUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlFieldBean の使用 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlFieldBean の使用

jp.co.intra_mart.foundation.im_curl での CurlFieldBean の使用

CurlFieldBean 型のパラメータを持つ jp.co.intra_mart.foundation.im_curl のメソッド
 void CurlXMLComposer.addField(CurlFieldBean field)
フィールド一覧リストにフィールドを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF の使用 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF の使用

jp.co.intra_mart.foundation.im_curl での CurlRecordBeanIF の使用

CurlRecordBeanIF 型のパラメータを持つ jp.co.intra_mart.foundation.im_curl のメソッド
 void CurlXMLComposer.addRecord(CurlRecordBeanIF record)
レコード一覧リストにレコードを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlXMLComposer の使用 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlXMLComposer の使用

jp.co.intra_mart.foundation.im_curl.CurlXMLComposer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlXMLParser の使用 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlXMLParser の使用

jp.co.intra_mart.foundation.im_curl.CurlXMLParser はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


CurlFieldBean (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlFieldBean

java.lang.Object
    拡張 jp.co.intra_mart.foundation.im_curl.CurlFieldBean
public class CurlFieldBean
extends Object

CurlフィールドBeanクラス
機能は以下の通り

  • CurlのRecordFieldクラスの属性情報を格納するBean

コンストラクタの概要
CurlFieldBean()
メソッドの概要
String | getCaption() キャプションを返します。
String | getDefault_value() デフォルト値を返します。
String | getDomain() ドメインを返します。
String | getIndex_type() インデックスタイプを返します。
String | getModifiable() 変更可能の可否を返します。
String | getName() 名前を返します。
String | getNullable() Null受付の可否を返します。
String | getRequired() フォーカスの要求の有無を返します。
void | setCaption(String string) キャプションを格納します。
void | setDefault_value(String string) デフォルト値を格納します。
void | setDomain(String string) ドメインを格納します。
void | setIndex_type(String string) インデックスタイプを格納します。
void | setModifiable(String string) 変更可能の可否を格納します。
void | setName(String string) 名前を格納します。
void | setNullable(String string) Null受付の可否を格納します。
void | setRequired(String string) フォーカスの要求の有無を格納します。
String | toString() オブジェクトを文字列に変換します。
String | toXMLNode() このインスタンスのXMLノードとしての文字列を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurlFieldBean

public CurlFieldBean()
メソッドの詳細

getCaption

public String getCaption()
キャプションを返します。

戻り値:
キャプション

getDefault_value

public String getDefault_value()
デフォルト値を返します。

戻り値:
デフォルト値

getDomain

public String getDomain()
ドメインを返します。

戻り値:
ドメイン

getIndex_type

public String getIndex_type()
インデックスタイプを返します。

戻り値:
インデックスタイプ

getModifiable

public String getModifiable()
変更可能の可否を返します。

戻り値:
変更可能の可否

getName

public String getName()
名前を返します。

戻り値:
名前

getNullable

public String getNullable()
Null受付の可否を返します。

戻り値:
Null受付の可否

getRequired

public String getRequired()
フォーカスの要求の有無を返します。

戻り値:
フォーカスの要求の有無

setCaption

public void setCaption(String string)
キャプションを格納します。

パラメータ:
string - キャプション

setDefault_value

public void setDefault_value(String string)
デフォルト値を格納します。

パラメータ:
string - デフォルト値

setDomain

public void setDomain(String string)
ドメインを格納します。

パラメータ:
string - ドメイン

setIndex_type

public void setIndex_type(String string)
インデックスタイプを格納します。

パラメータ:
string - インデックスタイプ

setModifiable

public void setModifiable(String string)
変更可能の可否を格納します。

パラメータ:
string - 変更可能の可否

setName

public void setName(String string)
名前を格納します。

パラメータ:
string - 名前

setNullable

public void setNullable(String string)
Null受付の可否を格納します。

パラメータ:
string - Null受付の可否

setRequired

public void setRequired(String string)
フォーカスの要求の有無を格納します。

パラメータ:
string - フォーカスの要求の有無

toString

public String toString()
オブジェクトを文字列に変換します。

戻り値:
このオブジェクトの文字列表現

toXMLNode

public String toXMLNode()
このインスタンスのXMLノードとしての文字列を返します。

戻り値:
XMLノードへ変換した文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlRecordBeanIF (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
インタフェース CurlRecordBeanIF

public interface CurlRecordBeanIF

CurlレコードBeanインタフェース
機能は以下の通り

  • CurlのRecordクラスの属性を格納するBean用のインタフェース

メソッドの概要
 String toXMLNode()
保持しているデータをXMLノードの文字列に変換します。

メソッドの詳細

toXMLNode

public String toXMLNode()
保持しているデータをXMLノードの文字列に変換します。

戻り値:
XMLノード文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlXMLComposer (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlXMLComposer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
public class CurlXMLComposer
extends Object

CurlXML生成クラス
機能は以下の通り

  • Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。

コンストラクタの概要
CurlXMLComposer()
メソッドの概要
void | addField(CurlFieldBean field) フィールド一覧リストにフィールドを追加します。
void | addRecord(CurlRecordBeanIF record) レコード一覧リストにレコードを追加します。
void | setFieldList(ArrayList fieldList) フィールド一覧リストをセットします。
void | setRecordList(ArrayList recordList) レコード一覧リストをセットします。
String | toXML() 指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CurlXMLComposer

public CurlXMLComposer()
メソッドの詳細

addField

public void addField(CurlFieldBean field)
フィールド一覧リストにフィールドを追加します。

パラメータ:
field - フィールド定義クラスのインスタンス

setFieldList

public void setFieldList(ArrayList fieldList)
フィールド一覧リストをセットします。

パラメータ:
fieldList - フィールド一覧リスト

addRecord

public void addRecord(CurlRecordBeanIF record)
レコード一覧リストにレコードを追加します。

パラメータ:
record - レコードクラスのインスタンス

setRecordList

public void setRecordList(ArrayList recordList)
レコード一覧リストをセットします。

パラメータ:
recordList - レコード一覧リスト

toXML

public String toXML()
             throws Exception
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。

戻り値:
Curlで入力可能なXMLの文字列
例外:
Exception
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurlXMLParser (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlXMLParser

java.lang.Object
    拡張 org.xml.sax.helpers.DefaultHandler
        拡張 jp.co.intra_mart.foundation.im_curl.CurlXMLParser
すべての実装インタフェース:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler
public class CurlXMLParser
extends DefaultHandler

CurlXMLパーサクラス
機能は以下の通り

  • Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。

フィールドの概要
protected Object | field に対応するCurlFieldBean
protected ArrayList | fieldsList に対応するCurlFieldBeanクラスのインスタンス格納用リスト
protected Object | instance に対応するJavaBeans
protected ArrayList | recordList に対応するクラスのインスタンス格納用リスト
コンストラクタの概要
CurlXMLParser(InputStream stream, String beanClassName)
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。
CurlXMLParser(String path, String beanClassName)
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。
メソッドの概要
protected void | createField(Attributes atts) qNameがFieldの場合のパーサの動作を定義します。
protected void | createRecord(Attributes atts) qNameがRecordの場合のパーサの動作を定義します。
void | endElement(String uri, String localName, String qName) DefaultHandlerのabstractメソッドをオーバーライドします。
ArrayList | getFieldsList() パースした結果のフィールド一覧リストを返します。
ArrayList | getRecordList() パースした結果のレコード一覧リストを返します。
void | startElement(String uri, String localName, String qName, Attributes atts) DefaultHandlerのabstractメソッドをオーバーライドします。
クラス org.xml.sax.helpers.DefaultHandler から継承したメソッド
characters, endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

fieldsList

protected ArrayList fieldsList
に対応するCurlFieldBeanクラスのインスタンス格納用リスト

recordList

protected ArrayList recordList
に対応するクラスのインスタンス格納用リスト

field

protected Object field
に対応するCurlFieldBean

instance

protected Object instance
に対応するJavaBeans

コンストラクタの詳細

CurlXMLParser

public CurlXMLParser(String path,
                     String beanClassName)
              throws SAXException
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。

パラメータ:
path - パース対象のXMLファイルのパス
beanClassName - パース対象のXMLのRecordタグに対応するJavaBeansクラス名
例外:
SAXException

CurlXMLParser

public CurlXMLParser(InputStream stream,
                     String beanClassName)
              throws SAXException
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。

パラメータ:
stream - パース対象のXMLを読み込むストリーム
beanClassName - パース対象のXMLのRecordタグに対応するJavaBeansクラス名
例外:
SAXException
メソッドの詳細

getRecordList

public ArrayList getRecordList()
パースした結果のレコード一覧リストを返します。

戻り値:
レコード一覧

getFieldsList

public ArrayList getFieldsList()
パースした結果のフィールド一覧リストを返します。

戻り値:
フィールド一覧

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
DefaultHandlerのabstractメソッドをオーバーライドします。
Curlで出力されたXML(elaborate-recordsetでの出力)をパースし、 FieldタグをCurlFieldBeanクラスのリストに、Recordタグを指定したJavaBeans クラスのリストに変換します。処理の詳細は次の通りです。
  1. Fieldタグをパースし、フィールド一覧リストに格納する。
  2. Recordタグのパース
    1. 指定されたJavaBeansクラスのインスタンス生成
    2. Recordタグの属性名、属性値を取得
    3. フィールド一覧リスト内のフィールド名を取得
    4. 指定されたJavaBeansクラスのメソッド一覧を検索しRecordタグの 属性のセッターが存在すればセッターを呼び出し属性値をセットする。 存在の有無は"set"+属性値をすべて小文字に変換した文字列がJavaBeans クラスのメソッド一覧内に存在するかで判断する。

例外:
SAXException

createField

protected void createField(Attributes atts)
qNameがFieldの場合のパーサの動作を定義します。 RecordSetのフィールドを解析する部分になります。

パラメータ:
atts -

createRecord

protected void createRecord(Attributes atts)
                     throws SAXException
qNameがRecordの場合のパーサの動作を定義します。 RecordSetのレコードを解析する部分になります。

パラメータ:
atts -
例外:
SAXException

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
DefaultHandlerのabstractメソッドをオーバーライドします。

例外:
SAXException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.im_curl (intra-mart Curl連携)

 jp.co.intra_mart.foundation.im_curl
インタフェース
CurlRecordBeanIF
クラス
CurlFieldBean
CurlXMLComposer
CurlXMLParser


jp.co.intra_mart.foundation.im_curl (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.im_curl

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

参照:
説明

インタフェースの概要
CurlRecordBeanIF CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース

クラスの概要
CurlFieldBean | CurlフィールドBeanクラス 機能は以下の通り CurlのRecordFieldクラスの属性情報を格納するBean
CurlXMLComposer | CurlXML生成クラス 機能は以下の通り Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。
CurlXMLParser | CurlXMLパーサクラス 機能は以下の通り Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。

パッケージ jp.co.intra_mart.foundation.im_curl の説明

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.im_curl クラス階層 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.im_curl の階層

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.im_curl.CurlFieldBean
    • class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class jp.co.intra_mart.foundation.im_curl.CurlXMLParser

インタフェース階層

  • interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.im_curl の使用 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.im_curl の使用

jp.co.intra_mart.foundation.im_curl により使用される jp.co.intra_mart.foundation.im_curl のクラス
CurlFieldBean
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlRecordBeanIF
CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


すべてのクラス (intra-mart Curl連携)

 すべてのクラス
CurlFieldBean
CurlRecordBeanIF
CurlXMLComposer
CurlXMLParser


定数フィールド値 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


非推奨 API のリスト (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


API ヘルプ (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


索引 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし
A C E F G I J R S T

A

addField(CurlFieldBean) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
フィールド一覧リストにフィールドを追加します。
addRecord(CurlRecordBeanIF) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
レコード一覧リストにレコードを追加します。

C

CurlFieldBean - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean.
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlFieldBean() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のコンストラクタ
CurlRecordBeanIF - interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF.
CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース
CurlXMLComposer - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer.
CurlXML生成クラス
機能は以下の通り
Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。
CurlXMLComposer() - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のコンストラクタ
CurlXMLParser - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser.
CurlXMLパーサクラス
機能は以下の通り
Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。
CurlXMLParser(String, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のコンストラクタ
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。
CurlXMLParser(InputStream, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のコンストラクタ
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。
createField(Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
qNameがFieldの場合のパーサの動作を定義します。
createRecord(Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
qNameがRecordの場合のパーサの動作を定義します。

E

endElement(String, String, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
DefaultHandlerのabstractメソッドをオーバーライドします。

F

field - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するCurlFieldBean
fieldsList - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するCurlFieldBeanクラスのインスタンス格納用リスト

G

getCaption() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
キャプションを返します。
getDefault_value() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
デフォルト値を返します。
getDomain() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
ドメインを返します。
getFieldsList() - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
パースした結果のフィールド一覧リストを返します。
getIndex_type() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
インデックスタイプを返します。
getModifiable() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
変更可能の可否を返します。
getName() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
名前を返します。
getNullable() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
Null受付の可否を返します。
getRecordList() - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
パースした結果のレコード一覧リストを返します。
getRequired() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
フォーカスの要求の有無を返します。

I

instance - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するJavaBeans

J

jp.co.intra_mart.foundation.im_curl - package jp.co.intra_mart.foundation.im_curl
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

R

recordList - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するクラスのインスタンス格納用リスト

S

setCaption(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
キャプションを格納します。
setDefault_value(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
デフォルト値を格納します。
setDomain(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
ドメインを格納します。
setFieldList(ArrayList) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
フィールド一覧リストをセットします。
setIndex_type(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
インデックスタイプを格納します。
setModifiable(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
変更可能の可否を格納します。
setName(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
名前を格納します。
setNullable(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
Null受付の可否を格納します。
setRecordList(ArrayList) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
レコード一覧リストをセットします。
setRequired(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
フォーカスの要求の有無を格納します。
startElement(String, String, String, Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
DefaultHandlerのabstractメソッドをオーバーライドします。

T

toString() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
オブジェクトを文字列に変換します。
toXML() - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
toXMLNode() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
このインスタンスのXMLノードとしての文字列を返します。
toXMLNode() - interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF のメソッド
保持しているデータをXMLノードの文字列に変換します。
A C E F G I J R S T
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


intra-mart Curl連携

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

intra-mart(R) Curl連携 API 仕様

パッケージ
jp.co.intra_mart.foundation.im_curl intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


クラス階層 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.im_curl

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.im_curl.CurlFieldBean
    • class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class jp.co.intra_mart.foundation.im_curl.CurlXMLParser

インタフェース階層

  • interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


(intra-mart Curl連携)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (intra-mart Curl連携)

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし

直列化された形式

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.mail.javamail.property (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラスの概要
JavaMailPropertyHandler JavaMailSenderの設定を保持します。

例外の概要
JavaMailPropertyException JavaMailSenderの設定に関する情報を提供する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.mail.javamail.property クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


JavaMailSender (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス JavaMailSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.JavaMailSender
すべての実装インタフェース:
jp.co.intra_mart.foundation.mail.MailSender
public class JavaMailSender
extends Object
implements jp.co.intra_mart.foundation.mail.MailSender

JavaMailをラップしたメール送信オブジェクトです。
メールの送信情報はStandardMailのインスタンスにより 決定されます。

導入されたバージョン:
5.0
関連項目:
StandardMail

コンストラクタの概要
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。
メソッドの概要
 void send()
メールを送信します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

JavaMailSender

public JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

パラメータ:
mail - 送信メール
メソッドの詳細

send

public void send()
          throws jp.co.intra_mart.foundation.mail.MailSenderException
メールを送信します。

定義:
インタフェース jp.co.intra_mart.foundation.mail.MailSender 内の send
例外:
jp.co.intra_mart.foundation.mail.MailSenderException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail

メール送信クラスを提供します。

参照:
説明

クラスの概要
JavaMailSender | JavaMailをラップしたメール送信オブジェクトです。
StandardMail | 送信するメールの属性を保管します。

パッケージ jp.co.intra_mart.foundation.mail.javamail の説明

メール送信クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.mail.javamail クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


StandardMail (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス StandardMail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.StandardMail
public class StandardMail
extends Object

送信するメールの属性を保管します。
このオブジェクトが保持するメールのキャラクターセット、エンコディングの設定は ロケールに依存します。

ロケール毎の設定は定義ファイルをにより決定されます。
ServerManager上に /conf/mail/encode.properties として、定義ファイルを配置してください。
指定可能なキーの一覧

charset | キャラクターセット
mimeEncoding | MIMEエンコード (B or Q)
contentTransferEncoding | ボディのエンコード

導入されたバージョン:
5.0
関連項目:
JavaMailSender

コンストラクタの概要
StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。
メソッドの概要
void | addAttachment(String filename, String file) 添付ファイルを追加します。
void | addBcc(String address) Bccを追加します。
void | addBcc(String address, String personal) Bccを追加します。
void | addCc(String address) Ccを追加します。
void | addCc(String address, String personal) Ccを追加します。
void | addHeader(String name, String value) ヘッダーを追加します。
void | addReplyTo(String replyto) ReplyToを追加します。
void | addTo(String address) Toを追加します。
void | addTo(String address, String personal) Toを追加します。
Locale | getLocale() ロケールを取得します。
protected Properties | getProperties() JavaMailのSMTPセッションに渡す属性を初期化します。
protected void | init() StandardMailオブジェクトを初期化します。
protected void | prepareMimeMessage(MimeMessage message) MIMEメッセージに対して操作を行います。
protected void | prepareSession(Session session) SMTPセッションに対して操作を行います。
void | setFrom(String address) Fromを設定します。
void | setFrom(String address, String personal) Fromを設定します。
void | setSubject(String subject) Subjectを設定します。
void | setText(String text) 本文を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardMail

public StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。

StandardMail

public StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。

パラメータ:
locale - 送信先ロケール
メソッドの詳細

init

protected void init()
             throws jp.co.intra_mart.foundation.mail.MailSenderException
StandardMailオブジェクトを初期化します。 このメソッドはJavaMailSender.send()から呼ばれます。

例外:
jp.co.intra_mart.foundation.mail.MailSenderException - StandardMailオブジェクトを初期化時に例外が発生。

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getProperties

protected Properties getProperties()
                            throws jp.co.intra_mart.foundation.mail.MailSenderException
JavaMailのSMTPセッションに渡す属性を初期化します。

ここではSMTPサーバのホスト及びポートを設定します。
このメソッドはJavaMailSender.send()から呼ばれます。

戻り値:
属性
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - 属性設定時に例外が発生。

prepareSession

protected void prepareSession(Session session)
                       throws jp.co.intra_mart.foundation.mail.MailSenderException
SMTPセッションに対して操作を行います。

ここでは、JavaMailにデバックオプションを設定します。 設定値は"conf/mail/javaMail.properties"の設定値が有効となります。
このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
session - SMTPセッション
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - セッション操作中に例外が発生。

prepareMimeMessage

protected void prepareMimeMessage(MimeMessage message)
                           throws jp.co.intra_mart.foundation.mail.MailSenderException
MIMEメッセージに対して操作を行います。 このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
message - メッセージ
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - メッセージ操作中に例外が発生。

addHeader

public void addHeader(String name,
                      String value)
ヘッダーを追加します。

パラメータ:
name - ヘッダーの名前
value - ヘッダーの値

addReplyTo

public void addReplyTo(String replyto)
ReplyToを追加します。

パラメータ:
replyto - ReplyToに追加するメールアドレス

setFrom

public void setFrom(String address)
Fromを設定します。

パラメータ:
address - メールアドレス

setFrom

public void setFrom(String address,
                    String personal)
Fromを設定します。

パラメータ:
address - メールアドレス
personal - 名前

setSubject

public void setSubject(String subject)
Subjectを設定します。

パラメータ:
subject - Subject

addTo

public void addTo(String address)
Toを追加します。

パラメータ:
address - メールアドレス

addTo

public void addTo(String address,
                  String personal)
Toを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addCc

public void addCc(String address)
Ccを追加します。

パラメータ:
address - メールアドレス

addCc

public void addCc(String address,
                  String personal)
Ccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addBcc

public void addBcc(String address)
Bccを追加します。

パラメータ:
address - メールアドレス

addBcc

public void addBcc(String address,
                   String personal)
Bccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

setText

public void setText(String text)
本文を設定します。

パラメータ:
text - 本文

addAttachment

public void addAttachment(String filename,
                          String file)
添付ファイルを追加します。

パラメータ:
filename - 添付ファイル名
file - ファイル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (5.0 J2EE-Base Programing Model API Specifications)

 すべてのクラス
JavaMailPropertyException
JavaMailPropertyHandler
JavaMailSender
StandardMail


索引 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし
A G I J P S

A

addAttachment(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを追加します。
addBcc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addBcc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addCc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addCc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addHeader(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ヘッダーを追加します。
addReplyTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ReplyToを追加します。
addTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addTo(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。

G

getCharset(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
キャラクターセットを取得します。
getContentTransferEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
Content-Transfer-Encodingを取得します。
getContentType(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
コンテントタイプを取得します。
getDebugOption() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
JavaMailに設定するデバック設定の有無を取得します。
getInstance() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の static メソッド
JavaMailPropertyHandlerのインスタンスを取得します。
getLocale() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ロケールを取得します。
getMimeEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
MIMEエンコードを取得します。
getProperties() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
JavaMailのSMTPセッションに渡す属性を初期化します。
getXMailerHeader() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
送信メールに付加するX-Mailerヘッダを取得します。

I

init() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
StandardMailオブジェクトを初期化します。

J

JavaMailPropertyException - exception jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException.
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyException() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String, Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyHandler - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler.
JavaMailSenderの設定を保持します。
JavaMailSender - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender.
JavaMailをラップしたメール送信オブジェクトです。
JavaMailSender(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のコンストラクタ
JavaMailSenderを新規に作成します。
jp.co.intra_mart.foundation.mail.javamail - package jp.co.intra_mart.foundation.mail.javamail
メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.property - package jp.co.intra_mart.foundation.mail.javamail.property

P

prepareMimeMessage(MimeMessage) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
MIMEメッセージに対して操作を行います。
prepareSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションに対して操作を行います。

S

StandardMail - class jp.co.intra_mart.foundation.mail.javamail.StandardMail.
送信するメールの属性を保管します。
StandardMail() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
ロケールを指定してメール属性オブジェクトを新規に作成します。
send() - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のメソッド
メールを送信します。
setFrom(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setSubject(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを設定します。
setText(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を設定します。
A G I J P S
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


概要 (5.0 J2EE-Base Programing Model API Specifications)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.mail.javamail
jp.co.intra_mart.foundation.mail.javamail.property


概要 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

intra-mart(R) 5.0 JavaMail API Specifications

パッケージ
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.property |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.mail.javamail, jp.co.intra_mart.foundation.mail.javamail.property

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


直列化された形式 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter の使用

jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException の使用

ResourceFormatException を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での ResourceFormatException の使用

ResourceFormatException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
protected  void CharacterEncoder.setCharacterEncoding(String enc)
このオブジェクトが対象とする文字エンコーディングを設定します。

ResourceFormatException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のコンストラクタ
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException の使用

ResourceNotFoundException を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での ResourceNotFoundException の使用

ResourceNotFoundException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
protected  void CharacterEncoder.setCharacterEncoding(String enc)
このオブジェクトが対象とする文字エンコーディングを設定します。

ResourceNotFoundException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のコンストラクタ
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util.charset の使用

jp.co.intra_mart.common.aid.jdk.util.charset を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset により使用される jp.co.intra_mart.common.aid.jdk.util.charset のクラス
ResourceFormatException
リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException
リソースがないことを通知する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


ResourceFormatException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス ResourceFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
すべての実装インタフェース:
Serializable
public class ResourceFormatException
extends Exception

リソースの内容が不適切であることを通知する例外です。

設定の内容に誤りがあるか、または定義の書式が正しくない場合にスローされます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ResourceFormatException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceFormatException

public ResourceFormatException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceFormatException

public ResourceFormatException(String msg,
                               Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResourceNotFoundException (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス ResourceNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
すべての実装インタフェース:
Serializable
public class ResourceNotFoundException
extends Exception

リソースがないことを通知する例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ResourceNotFoundException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceNotFoundException

public ResourceNotFoundException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceNotFoundException

public ResourceNotFoundException(String msg,
                                 Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util.report (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.report

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MessageReporter | メッセージ出力のためのインターフェースです。
ReportFileConditioner | このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportLevel | メッセージレベルのインターフェースです。

クラスの概要
AbstractMessageReporter | メッセージ出力用のスケルトンクラスです。
EverydayConditioner | このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
FileReporter | メッセージのファイル出力機能を提供します。
FileSizeConditioner | このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
FilterMessageReporter | メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
LineReportFilter | メッセージを行出力するためのフィルタークラスです。
MultiCastReporter | メッセージを複数のストリームに出力するためのフィルタークラスです。
OutputSizeConditioner | このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PeriodicConditioner | このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PrintStreamReporter | メッセージ出力用クラスです。
ReportFileWriter | メッセージをファイルに出力するストリームクラスです。
ReportLevelFilter | メッセージの出力制御を行うためのフィルタークラスです。
RepresentativeReporter | メッセージ出力をイベント処理するためのフィルタークラスです。

パッケージ jp.co.intra_mart.common.aid.jdk.util.report の説明

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.jdk.util.report クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.report の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
    • class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel)
      • class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
    • class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class java.io.Writer
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


すべてのクラス (5.0 J2EE-Base Programing Model API Specifications)

 すべてのクラス
AbstractDualComparator
AbstractMessageReporter
AbstractSocketConnectionDistributor
AdvancedOutputStreamWriter
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
CharacterEncoder
CharacterSetManager
Counter
Directory
DualComparator
ElementProperties
ErrorEvent
ErrorEventListener
EventListener
EventQueueController
EverydayConditioner
ExtendedClassLoader
ExtendedDirectory
ExtendedFile
ExtendedInputStream
ExtendedOutputStream
ExtendedProperties
ExtendedSocket
ExtendedThread
FileReporter
FileSizeConditioner
FilterComparator
FilterMessageReporter
FixedSizeMap
HexInputStream
HexOutputStream
LineReportFilter
Localhost
LockMonitor
MessageReporter
MultiCastReporter
MultiComparator
MultipleOutputStream
MultipurposeInternetMailExtensions
OutputSizeConditioner
PeriodicConditioner
PrintStreamReporter
ReplaceWriter
ReportFileConditioner
ReportFileWriter
ReportLevel
ReportLevelFilter
RepresentativeReporter
ResourceBundleProperties
ResourceFormatException
ResourceLoader
ResourceNotFoundException
ReverseComparator
SequenceComparator
ShutdownEventController
ShutdownListener
SocketConnection
SocketConnectionDistributor
SocketConnectionManager
SocketEventListener
SocketPool
StdErr
StdOut
ThreadStopListener
ThrowablePrintListener
TrimmedFilterReader
TrimmedFilterWriter
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
UnlimitedBufferedOutputStream
UnsupportedNetworkConnectException
XMLProperties
XORInputStream
XOROutputStream


定数フィールド値 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | TYPE_DEBUG | 0
public static final int | TYPE_ERROR | 3
public static final int | TYPE_REPORT | 1
public static final int | TYPE_WARNING | 2

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


索引 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし
A B C D E F G H I J L M N O P Q R S T U W X

A

AbstractDualComparator - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator.
２つのコンパレータを使用してソートを行うクラスです。
AbstractDualComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator のコンストラクタ
新しいオブジェクトを生成します。
AbstractMessageReporter - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter.
メッセージ出力用のスケルトンクラスです。
AbstractMessageReporter() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のコンストラクタ
唯一のコンストラクタ。
AbstractSocketConnectionDistributor - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor.
このクラスは、通信ソケットを作成する機能を提供します。
AbstractSocketConnectionDistributor(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のコンストラクタ
ソケット作成オブジェクトを構築します。
AdvancedOutputStreamWriter - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter.
このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
AdvancedOutputStreamWriter(OutputStream, String) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, Charset) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, CharsetEncoder) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
activeCount() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
現在取得済みモニターの数を取得します。
addClassArchive(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスに指定のアーカイブファイルを追加します。
addClassArchiveLibrary(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。
addClassPath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスを追加します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
指定されたコンパレータ comparator を追加します。
addConditioner(ReportFileConditioner) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
addCreateSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
addListener(ShutdownListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウンリスナーを登録します。
addNativePath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
クラスパスを追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
メッセージの出力先を追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージの出力先を追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージの出力先を追加します。
addReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
addThreadStopListener(ThreadStopListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
append(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
archive(File) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(File, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(OutputStream, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。

B

BASE64DecodeInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream.
このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
BASE64DecodeInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のコンストラクタ
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
BASE64DecodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream.
このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64DecodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64デコーダーを作成します。
BASE64EncodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream.
このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64EncodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

C

CharacterEncoder - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder.
このクラスは、文字エンコードの機能を提供します。
CharacterEncoder(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のコンストラクタ
文字コード変換のためのエンコーダを作成します。
CharacterSetManager - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager.
このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。
CharacterSetManager() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager のコンストラクタ
Counter - class jp.co.intra_mart.common.aid.jdk.util.Counter.
このクラスは、カウンター機能を提供します。
Counter() - class jp.co.intra_mart.common.aid.jdk.util.Counter のコンストラクタ
カウンターオブジェクトを作成します。
Counter(long) - class jp.co.intra_mart.common.aid.jdk.util.Counter のコンストラクタ
指定の初期値でカウンターオブジェクトを作成します。
canReport() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
このストリームが書き込み可能かどうかをチェックします。
capacity() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このマップに対してマップできるキーの最大個数を返します。
childDirectories() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
childDirectory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
childFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
childFiles() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
childPath(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
clean() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
プール中のコネクションをすべて破棄します。
clear() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
マップからマッピングをすべて削除します。
clearError() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
このストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
このオブジェクトを閉じます。
close() - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
ストリームを閉じます。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator のメソッド
順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のメソッド
順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator のメソッド
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator のメソッド
順序付けのために ２ つの引数を比較するメソッドです。
connection() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
コネクションの取得。
connection() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
コネクションの取得。
containsKey(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
createSocket() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
新しいソケットを作成します。
createWriter() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
メッセージをファイルへ書き出すための出力ストリームを作成します。
currentWriter() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトが文字を書き出している基礎 Writer を返します。

D

Directory - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory.
このクラスは、ディレクトリを扱う時に便利な機能を提供します。
Directory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(File, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
DualComparator - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator.
２つのコンパレータを使用してソートを行うためのインターフェースです。
datumpoint - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の変数
このリポーターがフィルタリングする基準レベル値
decrement() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの値を１だけ減少させます。
deleteAll() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
このディレクトリパスを削除します。
deleteChilds() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。
destroy() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
このプールを破棄します。
destroy() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールを破棄します。
doubleValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
doubleValue(String, double) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
doubleValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を double 型として返します。

E

ElementProperties - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties.
DOM をベースとした不変のプロパティセットを表します。
ElementProperties(Element) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のコンストラクタ
指定のエレメントの情報をプロパティズ化します。
ElementProperties(Element, Properties) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のコンストラクタ
指定のエレメントの情報をプロパティズ化します。
ErrorEvent - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent.
例外をイベントとして扱うためのプロトコルです。
ErrorEvent(Throwable, Object) - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のコンストラクタ
エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable, String, Object) - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のコンストラクタ
エラーを通知するためのイベントを構築します。
ErrorEventListener - interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener.
例外をイベントとして扱うためのスケルトン実装を提供します。
EventListener - interface jp.co.intra_mart.common.aid.jdk.util.EventListener.
このクラスは、イベントリスナーのインターフェースです。
EventQueueController - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController.
このクラスは、イベントリスナーを実行するイベント機能を実装します。
EventQueueController() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のコンストラクタ
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のコンストラクタ
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EverydayConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner.
このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
EverydayConditioner(int, int) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のコンストラクタ
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
ExtendedClassLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader.
このクラスは、拡張されたクラスローダーです。
ExtendedClassLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ExtendedClassLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
ExtendedDirectory - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory.
File インスタンスを作成するためのファクトリクラスです。
ExtendedDirectory(String, int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のコンストラクタ
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(File, String, int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のコンストラクタ
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedFile - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile.
このクラスは、ファイルを扱う時に便利な機能を提供します。
ExtendedFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(File, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
ExtendedInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream.
このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のコンストラクタ
入力ストリームを構築します。
ExtendedInputStream(InputStream, ErrorEventListener) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のコンストラクタ
入力ストリームを構築します。
ExtendedOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream.
このクラスは、標準の出力ストリームを拡張した機能を提供します。
ExtendedOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のコンストラクタ
出力ストリームを構築します。
ExtendedOutputStream(OutputStream, ErrorEventListener) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のコンストラクタ
出力ストリームを構築します。
ExtendedProperties - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties.
java.util.Properties を、より便利に利用するためのインタフェースを提供します。
ExtendedProperties() - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のコンストラクタ
デフォルト値を持たない空のプロパティリストを作成します。
ExtendedProperties(Properties) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のコンストラクタ
指定されたデフォルト値を持つ空のプロパティリストを作成します。
ExtendedSocket - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket.
このクラスは、ソケット通信用の入出力機能を提供します。
ExtendedSocket(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket(Socket) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket(ExtendedSocket) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedThread - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ExtendedThread() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(Runnable) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(Runnable, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
eject(SocketConnection) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
指定コネクションをこのプールの管理から切り離します。
encode(char) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char[]) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字列を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
entry(EventListener) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
イベントリスナーの登録。
entry() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターの取得。
entrySet() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このマップに格納されているマッピングのセットビューを返します。
errorIterator() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド実行中に発生した例外を返します。
eventGenerating() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューに登録されているイベントリスナーを一つ実行します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。

F

FileReporter - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter.
メッセージのファイル出力機能を提供します。
FileReporter(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
FileSizeConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner.
このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
FileSizeConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner のコンストラクタ
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
FilterComparator - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator.
コンパレータのフィルターとして機能する抽象クラスです。
FilterComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のコンストラクタ
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
FilterMessageReporter - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter.
メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
FilterMessageReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
FixedSizeMap - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap.
LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。
FixedSizeMap(int) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のコンストラクタ
指定されたサイズの領域を持つマップを構築します。
files(int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
finalize() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
このオブジェクトをクリーンアップします。
finalize() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
findClass(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
指定されたクラスを探します。
findDirectory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
findFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
findLibrary(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
ネイティブライブラリの絶対パス名を返します。
findPath(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
findResource(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
指定された名前を持つリソースを探します。
findResources(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。
finish() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
出力ストリームへのエンコードデータの書き込みを終了します。
finish() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
バッファに保存してあるデータを書き出します。
fire() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
スレッド実行されるロジック。
floatValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
floatValue(String, float) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
floatValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を float 型として返します。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
書き出しストリーム内のデータをすべて出力。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
この出力ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。
flush() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューに溜まっているすべてのイベントリスナーを実行します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
ストリームをフラッシュします。

G

get(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
マップが、指定されたキーにマッピングしている値を返します。
getAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
アドレスを返します。
getAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのＩＰアドレスを返します。
getBytes() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
この抽象パスが表すファイルからデータを読み込みます。
getCapacity() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
コネクション作成最大数の取得。
getCapacity() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
コネクション作成最大数の取得。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
このオブジェクトが対象としている文字エンコーディング名を返します。
getClassArchives() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
このクラスローダーに設定されているクラスアーカイブパスを返します。
getClassPaths() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
このクラスローダーに設定されているクラスパスを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このソケットに登録されているクローズ・イベント・リスナーを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
getComparators() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
設定されている全てのコンパレータを取得します。
getCreateSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
getDefaultPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
このクラスがロードされた時点の、System.err を 返します。
getDefaultPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
このクラスがロードされた時点の、System.out を 返します。
getDocument() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のメソッド
設定ファイルのドキュメントノードを返します。
getElement() - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のメソッド
現在のプロパティズの元となったエレメントノードを返します。
getException() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラーまたは例外を取得します。
getFile() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトが文字を書き出すファイルを取得します。
getHostAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのアドレスを返します。
getHostName() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのホスト名を返します。
getInputStream() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
入力ストリームの取得。
getLocale() - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のメソッド
ResourceBundle の Locale を返します。
getMediaType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプの Media Type を返します。
getMessage() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラーメッセージを取得します。
getNativePaths() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
このクラスローダーに設定されているネイティブライブラリパスを返します。
getObject() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラー発生オブジェクトを取得します。
getOutputStream() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
出力ストリームの取得。
getOutputStreamWriter() - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
getParentComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のメソッド
フィルター対象のコンパレータを返します。
getPort() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
ポートを返します。
getPrimaryComparator() - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator のメソッド
１番目コンパレータを取得します。
getPrimaryComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
第１コンパレータを返します。
getPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージを出力する出力ストリームを返します。
getPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージを出力する出力ストリームを返します。
getProperties(String) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のメソッド
指定のキーにマップされた値のリストを返します。
getReporters() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
セット内の要素についての反復子を返します。
getSecondaryComparator() - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator のメソッド
２番目コンパレータを取得します。
getSecondaryComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
第２コンパレータを返します。
getShutdownListeners() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
現在登録されているリスナを返します。
getSize() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールが現在管理しているコネクション数です。
getSocket() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このオブジェクトの持つソケットオブジェクトを返します。
getSubType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプの subtype を返します。
getThrowablePrintListener() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
現在の例外出力リスナを返します。
getType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプを返します。

H

HexInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream.
このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
HexInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のコンストラクタ
指定された InputStream から読み込む HexInputStream を作成します。
HexOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream.
このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
HexOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のコンストラクタ
指定された OutputStream に書き込む HexOutputStream を作成します。
handleError(ErrorEvent) - interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener のメソッド
発生した例外を通知します。
handleEvent() - interface jp.co.intra_mart.common.aid.jdk.util.EventListener のメソッド
イベントが発生した時にコントローラから呼び出されます。
handleShutdown() - interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener のメソッド
シャットダウンイベントが発生したときに実行されるメソッドです。
handleShutdown() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
シャットダウンイベントが発生したときに実行されるメソッドです。
handleSocketEvent(ExtendedSocket) - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener のメソッド
ソケットに関するイベント発生時に呼び出されるメソッド。
handleThreadStop() - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener のメソッド
監視していたスレッドが終了したときに実行されるメソッドです。
hasReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。

I

in - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の変数
フィルタ処理される入力ストリームです。
increment() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの値を１だけ増加させます。
instance() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost の static メソッド
このクラスから生成される唯一のインスタンスを返します。
intValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 数値として取得します。
intValue(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 数値として取得します。
intValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を int 型として返します。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このソケットが閉じられているかどうかをチェックします。
isFalse(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を真偽判定します。
isShutdown() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウン中（またはシャットダウン処理終了）かどうかを判定。
isTrue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を真偽判定します。

J

jp.co.intra_mart.common.aid.jdk.java.io - package jp.co.intra_mart.common.aid.jdk.java.io
このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io.file - package jp.co.intra_mart.common.aid.jdk.java.io.file
このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.lang - package jp.co.intra_mart.common.aid.jdk.java.lang
このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.net - package jp.co.intra_mart.common.aid.jdk.java.net
ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.common.aid.jdk.java.util - package jp.co.intra_mart.common.aid.jdk.java.util
このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml - package jp.co.intra_mart.common.aid.jdk.javax.xml
このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom - package jp.co.intra_mart.common.aid.jdk.org.w3c.dom
このパッケージには、ＤＯＭを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util - package jp.co.intra_mart.common.aid.jdk.util
このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.charset - package jp.co.intra_mart.common.aid.jdk.util.charset
このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report - package jp.co.intra_mart.common.aid.jdk.util.report
このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

L

LineReportFilter - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter.
メッセージを行出力するためのフィルタークラスです。
LineReportFilter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のコンストラクタ
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
Localhost - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost.
このクラスは、サーバプロセスの基礎情報を管理します。
LockMonitor - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor.
このクラスはモニター機能を提供します。
LockMonitor(int) - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のコンストラクタ
モニターを構築します。
lastError() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド中で最後に発生した例外を返します。
length() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このライターの出力文字数を取得します。
longValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 長整数として取得します。
longValue(String, long) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 長整数として取得します。
longValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を long 型として返します。

M

MAX_VALUE - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
MIN_VALUE - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
MessageReporter - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter.
メッセージ出力のためのインターフェースです。
MultiCastReporter - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter.
メッセージを複数のストリームに出力するためのフィルタークラスです。
MultiCastReporter() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のコンストラクタ
唯一のコンストラクタ。
MultiComparator - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator.
複数のコンパレータを使用してソートを行うためにクラスです。
MultiComparator(Comparator, Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のコンストラクタ
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
MultipleOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream.
複数の出力ストリームにバイトを書き出すためのフィルタ実装です。
MultipleOutputStream() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のコンストラクタ
唯一のコンストラクタ
MultipurposeInternetMailExtensions - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions.
MIME タイプを持つオブジェクトです。
MultipurposeInternetMailExtensions(String) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(File) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String, String) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
指定のMIMEタイプを表すオブジェクトを構築します。

N

newString(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(char[]) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

O

OutputSizeConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner.
このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
OutputSizeConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner のコンストラクタ
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
out - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の変数
フィルタ処理される基礎出力ストリームです。
out - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の変数
基礎出力ストリームです。
out - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の変数
基礎出力ストリームです。

P

PeriodicConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner.
このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PeriodicConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner のコンストラクタ
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
PrintStreamReporter - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter.
メッセージ出力用クラスです。
PrintStreamReporter(PrintStream) - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
parseInt(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。
parseLong(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。
paths(int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
printMessage(Throwable) - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener のメソッド
例外のメッセージを出力します。
printStackTrace(Throwable) - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener のメソッド
例外のスタックトレースを出力します。
put(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
指定された値を、マップ内の指定されたキーに関連付けます 。

Q

queue() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターを取得するための待ち行列に入っているスレッドの数です。

R

ReplaceWriter - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter.
このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
ReplaceWriter(Writer, char[]) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, char[], char[]) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列置換のためのストリームフィルタを作成します。
ReportFileConditioner - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner.
このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportFileWriter - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter.
メッセージをファイルに出力するストリームクラスです。
ReportFileWriter(File) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のコンストラクタ
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
ReportLevel - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel.
メッセージレベルのインターフェースです。
ReportLevelFilter - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter.
メッセージの出力制御を行うためのフィルタークラスです。
ReportLevelFilter(MessageReporter, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のコンストラクタ
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
RepresentativeReporter - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter.
メッセージ出力をイベント処理するためのフィルタークラスです。
RepresentativeReporter(MessageReporter, EventQueueController) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のコンストラクタ
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
ResourceBundleProperties - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties.
このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。
ResourceBundleProperties(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale, ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceFormatException - exception jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException.
リソースの内容が不適切であることを通知する例外です。
ResourceFormatException(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader.
このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
ResourceLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ResourceLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
ResourceNotFoundException - exception jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException.
リソースがないことを通知する例外です。
ResourceNotFoundException(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ReverseComparator - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator.
コンパレータのフィルタとして機能します。
ReverseComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator のコンストラクタ
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のメソッド
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
データ取得。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
データ取得。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のメソッド
デコードデータのバイトを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のメソッド
単一の文字を読み込みます。
read(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のメソッド
配列の一部に文字を読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のメソッド
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のメソッド
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
readBoolean() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
boolean 型データ取得。
readInt() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
int 型データ取得。
readLines() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
ファイルの行を繰り返し処理する反復子を作成します。
readLines(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
ファイルの行を繰り返し処理する反復子を作成します。
readLong() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
long 型データ取得。
readObject() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
Object の取得。
readString() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
文字列の取得。
readString() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
reconstruction() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
現在使用中の Writer をリセットします。
release() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のメソッド
ソケットおよび入出力ストリームの利用を中止します。
release() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターの開放。
remove(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このキーにマッピングがある場合に、そのマッピングをマップから削除します。
removeComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
指定されたコンパレータ comparatorを削除します。
removeConditioner(ReportFileConditioner) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
removeListener(ShutdownListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウンリスナーを削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
メッセージの出力先を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージの出力先を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージの出力先を削除します。
removeReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
メッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(String) - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
メッセージを出力します。
report(Object) - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
メッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
メッセージを出力します。
report(String, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
指定のメッセージレベルが基準値以上のメッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
data をメッセージとして出力します。
report(Object, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
指定のメッセージレベルが基準値以上のメッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
data をメッセージとして出力します。
reset() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
キャッシュ領域をクリアします。
reset(Writer) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
文字の出力ストリームをリセットします。
run() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
このオブジェクトのスレッド実行ロジックです。

S

SequenceComparator - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator.
挿入順にソートするためのコンパレータです。
SequenceComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator のコンストラクタ
新しいオブジェクトを生成します。
ShutdownEventController - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController.
このクラスは、サーバプロセスの基礎ロジック。
ShutdownListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener.
シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
SocketConnection - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection.
ソケットプール用のスケルトン実装を提供します。
SocketConnection(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection(Socket) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection(ExtendedSocket) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnectionDistributor - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor.
このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionManager - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager.
通信ソケットをプールする機能のインターフェースです。
SocketEventListener - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener.
通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。
SocketPool - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool.
このクラスは、通信ソケットをプールする機能を提供します。
SocketPool(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のコンストラクタ
ソケットプールを構築します。
SocketPool(String, int, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のコンストラクタ
ソケットプールを構築します。
StdErr - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr.
このクラスは、エラーメッセージ出力用です。
StdOut - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut.
このクラスは、システムメッセージ出力用です。
setCapacity(int) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューの容量を変更します。
setCharacterEncoding(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
このオブジェクトが対象とする文字エンコーディングを設定します。
setThrowablePrintListener(ThrowablePrintListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定の例外出力リスナを割り当て直します。
shutdown() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
このプロセスを終了します。
shutdown(int) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
このプロセスを終了します。
size() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
このオブジェクトの管理するモニターの数を取得します。

T

TYPE_DEBUG - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
デバッグレベル。
TYPE_ERROR - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
エラーレベル。
TYPE_REPORT - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
通常の情報レベル。
TYPE_WARNING - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
警告レベル。
ThreadStopListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThrowablePrintListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener.
このインタフェースは、例外情報を出力するためのものです。
TrimmedFilterReader - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader.
このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。
TrimmedFilterReader(Reader) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のコンストラクタ
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。
TrimmedFilterWriter - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter.
このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。
TrimmedFilterWriter(Writer) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のコンストラクタ
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。
toIANAName(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の static メソッド
指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
toJDKName(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の static メソッド
指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
toString() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトの文字列表現を返します。
total() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターを利用中、または利用しようとしているスレッドの数です。

U

URLDecodeInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream.
このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
URLDecodeInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のコンストラクタ
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
URLDecodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream.
このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
URLDecodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のコンストラクタ
指定された OutputStream に書き込む URLデコーダーを作成します。
URLEncodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream.
このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
URLEncodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64デコーダーを作成します。
UnlimitedBufferedOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream.
出力データを一時的にバッファリングする出力ストリームの実装です。
UnlimitedBufferedOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のコンストラクタ
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。
UnsupportedNetworkConnectException - exception jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
UnsupportedNetworkConnectException() - class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException のコンストラクタ
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String) - class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException のコンストラクタ
Constructor for UnsupportedNetworkConnectException.
usableConnection() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
現在待機中のコネクションをです。
usableConnection() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
現在待機中のコネクションをです。

W

write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
指定されたバイトを書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
単一文字を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
文字列の一部を基礎ストリームに書き込みます。
write(String, int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
文字列の一部を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
指定のバイトを出力します。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
b.length バイトのデータを出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定のメッセージを標準エラー出力および指定の出力先に書き出します。
write(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定のメッセージを標準エラー出力および指定の出力先に書き出します。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
指定のメッセージを標準出力および指定の出力先に書き出します。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
単一の文字を書き込みます。
write(String, int, int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
文字列の一部を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
基礎ストリームに文字を出力します。
writeBoolean(boolean) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
boolean 型データの送信。
writeInt(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
int 型データの送信。
writeLong(long) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
long 型データの送信。
writeObject(Object) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
オブジェクトの送信。
writeString(String) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
文字列の送信。

X

XMLProperties - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties.
XML をベースとした不変のプロパティセットを表します。
XMLProperties(File) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream, Properties) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource, Properties) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XORInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream.
このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
XORInputStream(InputStream, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のコンストラクタ
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
XOROutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream.
このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
XOROutputStream(OutputStream, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のコンストラクタ
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
A B C D E F G H I J L M N O P Q R S T U W X
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


概要 (5.0 J2EE-Base Programing Model API Specifications)

すべてのクラス

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io
jp.co.intra_mart.common.aid.jdk.java.io.file
jp.co.intra_mart.common.aid.jdk.java.lang
jp.co.intra_mart.common.aid.jdk.java.net
jp.co.intra_mart.common.aid.jdk.java.util
jp.co.intra_mart.common.aid.jdk.javax.xml
jp.co.intra_mart.common.aid.jdk.org.w3c.dom
jp.co.intra_mart.common.aid.jdk.util
jp.co.intra_mart.common.aid.jdk.util.charset
jp.co.intra_mart.common.aid.jdk.util.report


概要 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

intra-mart(R) 5.0 J2EE-Base Programing Model API Specifications

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.lang | このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.common.aid.jdk.java.util | このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.common.aid.jdk.java.io, jp.co.intra_mart.common.aid.jdk.java.io.file, jp.co.intra_mart.common.aid.jdk.java.lang, jp.co.intra_mart.common.aid.jdk.java.net, jp.co.intra_mart.common.aid.jdk.java.util, jp.co.intra_mart.common.aid.jdk.javax.xml, jp.co.intra_mart.common.aid.jdk.org.w3c.dom, jp.co.intra_mart.common.aid.jdk.util, jp.co.intra_mart.common.aid.jdk.util.charset, jp.co.intra_mart.common.aid.jdk.util.report

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator (implements jp.co.intra_mart.common.aid.jdk.java.util.DualComparator)
      • class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
    • class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
    • class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager)
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
    • class java.lang.ClassLoader
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
        • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
              • class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
    • class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
    • class jp.co.intra_mart.common.aid.jdk.util.EventQueueController
    • class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile
    • class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
    • class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel)
      • class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
    • class java.io.InputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
    • class jp.co.intra_mart.common.aid.jdk.java.net.Localhost (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.util.LockMonitor
    • class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.util.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class java.io.OutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
    • class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class java.io.Reader
      • class java.io.FilterReader
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
    • class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
      • class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter

インタフェース階層

  • interface java.util.Comparator
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener
  • interface jp.co.intra_mart.common.aid.jdk.util.EventListener
  • interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
  • interface java.io.Serializable
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.util.Comparator)
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


直列化された形式 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory は File を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory は Directory を拡張し、Serializable を実装しています

直列化されたフィールド

POOL

FixedSizeMap POOL
このディレクトリを親とするファイルオブジェクトのキャッシュ領域

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile は File を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.java.net

クラス jp.co.intra_mart.common.aid.jdk.java.net.Localhost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

localhostIPAddress

byte[] localhostIPAddress

localhostAddress

String localhostAddress

localhostName

String localhostName

クラス jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException は IOException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.java.util

クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties は Properties を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

Comparator parent

クラス jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator
第１コンパレータ

secondaryComparator

MultiComparator secondaryComparator
第２コンパレータ

クラス jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties は Properties を拡張し、Serializable を実装しています

直列化されたフィールド

currentLocale

Locale currentLocale

クラス jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator は FilterComparator を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

map

WeakHashMap map
map

count

long count
挿入順番

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml

クラス jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties は ElementProperties を拡張し、Serializable を実装しています

直列化されたフィールド

domDocument

Document domDocument
このプロパティセットの元データとなった DOM

propertyList

Map propertyList
プロパティのリスト

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom

クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties は ExtendedProperties を拡張し、Serializable を実装しています

直列化されたフィールド

propertyList

Map propertyList
プロパティのリスト

element

Element element
このオブジェクトがラップするエレメントノード

パッケージ jp.co.intra_mart.common.aid.jdk.util

クラス jp.co.intra_mart.common.aid.jdk.util.Counter は Number を拡張し、Serializable を実装しています

直列化されたフィールド

currentValue

long currentValue
カウンターの値

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset

クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter の使用

AbstractFilter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractFilter のサブクラス
class | AbsoluteLinkFilter 絶対表現のＵＲＬをレスポンスするためのフィルタ。
class | ExceptionHandlingFilter サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
class | HTTPContextHandlingFilter このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
class | LuxuryResponseWriterFilter
class | NoCacheFilter ブラウザのキャッシュを無効にするフィルタ。
class | RequestMessageBodyFilter リクエストをラップするフィルタです。
class | ResponseContentTypeManagementFilter レスポンスの Content-Type を自動解決するフィルタです。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での AbstractFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での AbstractFilter のサブクラス
 class HttpSessionMonitoringFilter
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AbsoluteLinkFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbsoluteLinkFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
すべての実装インタフェース:
Filter
public class AbsoluteLinkFilter
extends AbstractFilter

絶対表現のＵＲＬをレスポンスするためのフィルタ。

このフィルタの目的は、ServletResponse#encodeURL() の実行結果として、 単にセッションＩＤ情報を付加するだけではなく、必ず絶対形式のＵＲＬを 作成することです。 したがって、このフィルタは、チェーンの次サーブレットまたはフィルタに対して、 ラップしたレスポンスを渡します。

このフィルタがレスポンスをラップするのは、事前に指定されたセッションに 関連したリクエストのみです。 #entry(ServletRequest) または entry(HttpSession) で 登録していないセッションに関するリクエストについては、 レスポンスをラップすることなくチェーンの次のサーブレットまたはフィルタを 実行します。

コンストラクタの概要
AbsoluteLinkFilter()
フィルタを新しく作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタ処理します。
static void | entry(HttpServletRequest request) このフィルタによってＵＲＬの制御を行うことを定義します。
static void | entry(HttpSession session) このフィルタによってＵＲＬの制御を行うことを定義します。
static void | leave(HttpServletRequest request) 指定のセッションに関する、このフィルタの処理を停止します。
static void | leave(HttpSession session) 指定のセッションに関する、このフィルタの処理を停止します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbsoluteLinkFilter

public AbsoluteLinkFilter()
フィルタを新しく作成します。

メソッドの詳細

entry

public static void entry(HttpServletRequest request)
このフィルタによってＵＲＬの制御を行うことを定義します。

この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
request - リクエスト
例外:
NullPointerException - 引数が null の場合
IllegalStateException - セッションを取得できなかった場合

entry

public static void entry(HttpSession session)
このフィルタによってＵＲＬの制御を行うことを定義します。

この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
session - セッション
例外:
NullPointerException - 引数が null の場合

leave

public static void leave(HttpServletRequest request)
指定のセッションに関する、このフィルタの処理を停止します。 この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

既にセッションが有効でない場合、このメソッドは何も行いません。

パラメータ:
request - リクエスト
例外:
NullPointerException - 引数が null の場合

leave

public static void leave(HttpSession session)
指定のセッションに関する、このフィルタの処理を停止します。 この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
session - セッション
例外:
NullPointerException - 引数が null の場合

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタ処理します。

現在のリクエストに関連付けられているセッションが、 このクラスの entry(HttpSession) で定義済みのセッションの場合、 レスポンスをラップします。 ラップされたレスポンスは、javax.servlet.http.HttpServletResponse#encodeURL(java.lang.String) の 返り値として、必ず絶対形式のＵＲＬを返すようになります。

レスポンスをラップするかどうかに関わらず、 このメソッドは、フィルタチェーン内の次のチェーンを呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - フィルタチェーンの次のビュー
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
すべての実装インタフェース:
Filter
直系の既知のサブクラス:
AbsoluteLinkFilter, ExceptionHandlingFilter, HTTPContextHandlingFilter, HttpSessionMonitoringFilter, LuxuryResponseWriterFilter, NoCacheFilter, RequestMessageBodyFilter, ResponseContentTypeManagementFilter
public abstract class AbstractFilter
extends Object
implements Filter

フィルタを実装するための抽象クラスです。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractFilter()
フィルタオブジェクトを作成します。
メソッドの概要
void | destroy() フィルタの終了処理。
abstract void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
FilterConfig | getFilterConfig() このフィルタの設定オブジェクトを返します。
ServletContext | getServletContext() この Filter を実行している ServletContext への参照を返します。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
void | init(FilterConfig config) フィルタを初期化します。
protected void | log(String msg) Servlet ログファイルに指定されたメッセージを出力します。
protected void | log(String msg, Throwable throwable) 与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractFilter

protected AbstractFilter()
フィルタオブジェクトを作成します。

メソッドの詳細

init

public final void init(FilterConfig config)
                throws ServletException
フィルタを初期化します。

このメソッドは、この抽象クラスの初期化を実行後に、 handleInit() を実行します。 サブクラスが独自の初期化処理を必要とする場合は、 handleInit() をオーバーライドして初期化処理を実装してください。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタ設定オブジェクト
例外:
ServletException - 初期化エラー
関連項目:
Filter.init(FilterConfig)

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

例外:
ServletException - 初期化エラー
関連項目:
init(FilterConfig)

getFilterConfig

public FilterConfig getFilterConfig()
このフィルタの設定オブジェクトを返します。

このメソッドは、コンストラクタでは利用できません。

戻り値:
フィルタ設定オブジェクト。コンストラクタで呼び出した場合は null を返します。

getServletContext

public ServletContext getServletContext()
この Filter を実行している ServletContext への参照を返します。

このメソッドは、コンストラクタでは利用できません。

戻り値:
このフィルタが Servlet コンテナとの対話に使っている ServletContext オブジェクト
例外:
NullPointerException - コンストラクタで呼び出した場合

log

protected void log(String msg)
Servlet ログファイルに指定されたメッセージを出力します。
通常は event ログです。 Servlet ログファイルの名前やタイプは Servlet コンテナによって違います。

このメソッドの呼び出しは、下記と同等です。
this.getFilterConfig().getServletContext().log(msg);

このメソッドは、コンストラクタでは利用できません。

パラメータ:
msg - ログファイルに出力するメッセージ
例外:
NullPointerException - コンストラクタで呼び出した場合
関連項目:
ServletContext.log(String)

log

protected void log(String msg,
                   Throwable throwable)
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
Servlet ログファイルは通常は event ログですが、 名前やタイプは Servlet コンテナによって違います。

このメソッドの呼び出しは、下記と同等です。
this.getFilterConfig().getServletContext().log(msg, throwable);

このメソッドは、コンストラクタでは利用できません。

パラメータ:
msg - ログファイルに出力するメッセージ
throwable - エラーや例外
例外:
NullPointerException - コンストラクタで呼び出した場合
関連項目:
ServletContext.log(String, Throwable)

doFilter

public abstract void doFilter(ServletRequest request,
                              ServletResponse response,
                              FilterChain chain)
                       throws ServletException,
                              IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

destroy

public final void destroy()
フィルタの終了処理。

このメソッドは、handleDestroy() を呼び出します。
handleDestroy() から正常に制御が返ってきた場合も、
また handleDestroy() が例外をスローした場合も、
このメソッドが終了する直前に、この抽象クラスの破棄処理が行われます。

サブクラスが独自の初期化処理を必要とする場合は、 handleDestroy() をオーバーライドして 初期化処理を実装してください。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

関連項目:
destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExceptionHandlingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス ExceptionHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
すべての実装インタフェース:
Filter
public class ExceptionHandlingFilter
extends AbstractFilter

サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。

このフィルタを利用すると、例外の種類によって表示するエラーページを 切り替える事ができます。また、フォワード先ＵＲＬを JSP や Servlet にすると、 エラーログを出力するなどの例外処理をすることもできます。

フィルタの設定値は、以下のとおりです。

id.attribute.exception | フォワード先へ、発生した例外を通知するためのキー名です。 この指定値をキー名として、発生した例外を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.url | フォワード先へ、リクエストＵＲＬを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getRequestURL() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.uri | フォワード先へ、リクエストＵＲＩを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getRequestURI() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.servlet | フォワード先へ、サーブレットパスを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getServletPath() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
path.mapping マッピングに関して定義した定義ファイルです。 定義ファイルはＸＭＬ形式で、以下のフォーマットになります。

   <error-page>
     <mapping>
       <exception-type>例外のクラス名</exception-type>
       <location>例外発生時にフォワードするパス</location>
     </mapping>
   </error-page>
<mapping> は任意の個数だけ定義できます。

フィルタは、指定されたパスをクラスパスから検索します。 定義ファイルは、必ずクラスパスに設定されているディレクトリに 保存してください。

exception.cause.enable 例外がスローされた直接原因となった例外 （Throwable.getCause() が返す値） もチェック対象とするかどうかの設定です。

文字列 'true' を設定した場合、ネストされた例外もチェックします。 ただし、パフォーマンスが悪化する可能性があります。
文字列 'false' を設定した場合、スローされた例外のみをチェック対象とします。 パフォーマンス面では有利ですが、パターンによっては 適切なエラーページを表示できない恐れがあります。

コンストラクタの概要
ExceptionHandlingFilter()
新しくフィルタオブジェクトを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExceptionHandlingFilter

public ExceptionHandlingFilter()
新しくフィルタオブジェクトを作成します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPContextHandlingFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HTTPContextHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
すべての実装インタフェース:
Filter
public class HTTPContextHandlingFilter
extends AbstractFilter

このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。

導入されたバージョン:
version 5.0

コンストラクタの概要
HTTPContextHandlingFilter()
デフォルト・コンストラクタ
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPContextHandlingFilter

public HTTPContextHandlingFilter()
デフォルト・コンストラクタ

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
クラス AbstractFilter の記述:
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws IOException,
                     ServletException
クラス AbstractFilter の記述:
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
クラス AbstractFilter の記述:
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LuxuryResponseWriterFilter (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス LuxuryResponseWriterFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
すべての実装インタフェース:
Filter
public class LuxuryResponseWriterFilter
extends AbstractFilter

導入されたバージョン:
version5.0
関連項目:
AbstractFilter

コンストラクタの概要
LuxuryResponseWriterFilter()
デフォルトコンストラクタ
メソッドの概要
 void doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
フィルタとして動作するロジック。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LuxuryResponseWriterFilter

public LuxuryResponseWriterFilter()
デフォルトコンストラクタ

メソッドの詳細

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
クラス AbstractFilter の記述:
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。
HttpServletRequestMessageBodyWrapper
HttpServletRequest を拡張したインタフェースです。
RequestParameter
１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.common.aid.jsdk.javax.servlet (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet

このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
FilterServletInputStream InputStream を ServletInputStream に変換するためのラッパです。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の説明

このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.jsdk.javax.servlet クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class javax.servlet.ServletInputStream
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


jp.co.intra_mart.common.aid.jsdk.utility (5.0 J2EE-Base Programing Model API Specifications)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.utility

このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
BrowseString | HTML表示用文字列変換ユーティリティクラス。
URLUtil | URL関連のユーティリティクラス。

パッケージ jp.co.intra_mart.common.aid.jsdk.utility の説明

このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.jsdk.utility クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.utility の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
    • class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


すべてのクラス (5.0 J2EE-Base Programing Model API Specifications)

 すべてのクラス
AbsoluteLinkFilter
AbstractFilter
AbstractHttpSessionManager
BadRequestException
BrowseString
EmptyQueryException
ExceptionHandlingFilter
ExcessiveQueryException
ExtendedServletException
FilterServletInputStream
ForbiddenException
HTTPContext
HTTPContextHandlingFilter
HTTPContextManager
HttpServletRequestMessageBodyWrapper
HttpServletRequestMessageBodyWrapperBuilder
HttpSessionManager
HttpSessionManagerFactory
HttpSessionMonitoringFilter
HttpSessionMonitoringListener
LengthRequiredException
LuxuryResponseWriterFilter
NoCacheFilter
NoSuchSessionException
NotFoundException
RequestEntityTooLargeException
RequestMessageBodyFilter
RequestParameter
ResponseContentTypeManagementFilter
ServiceUnavailableException
URLUtil
UnauthorizedException
UnripeQueryException


索引 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし
A B C D E F G H I J L M N R S U

A

AbsoluteLinkFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter.
絶対表現のＵＲＬをレスポンスするためのフィルタ。
AbsoluteLinkFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter のコンストラクタ
フィルタを新しく作成します。
AbstractFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter.
フィルタを実装するための抽象クラスです。
AbstractFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のコンストラクタ
フィルタオブジェクトを作成します。
AbstractHttpSessionManager - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager.
インタフェース HttpSessionManager の抽象実装です。
AbstractHttpSessionManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のコンストラクタ
HttpSessionManager の抽象実装を構築します。
available() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。

B

BadRequestException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException.
不正なリクエストを受け付けたことを通知するための例外です。
BadRequestException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
指定のメッセージを持つ例外を作成します。
BadRequestException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
BadRequestException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
例外を作成します。
BrowseString - class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString.
HTML表示用文字列変換ユーティリティクラス。
buildExtendedHttpServletRequest(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
ExtendedHttpServletRequest を作成して返します。

C

close() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力を閉じます。
convert(String) - class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の static メソッド
HTML表示可能な文字列に変換します。

D

destroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの終了処理。
destroy() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
このオブジェクトの破棄処理をします。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter のメソッド
フィルタ処理します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter のメソッド
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のメソッド
レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタとして動作するロジック。

E

EmptyQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException.
クエリがない場合にスローされる例外です。
EmptyQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
EmptyQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
EmptyQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
例外を作成します。
ExceptionHandlingFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter.
サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
ExceptionHandlingFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のコンストラクタ
新しくフィルタオブジェクトを作成します。
ExcessiveQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException.
クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
ExcessiveQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ExcessiveQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ExcessiveQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
例外を作成します。
ExtendedServletException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException.
Servlet 例外の拡張モデルです。
ExtendedServletException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
例外オブジェクトを作成します。
ExtendedServletException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
指定されたメッセージを持つ例外を作成します。
ExtendedServletException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
指定されたメッセージと根本原因となった例外を持つ例外を作成します。
ExtendedServletException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
根本原因となった例外を持つ例外を作成します。
encodeUrl(String) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
文字列をURLエンコードします。
entry(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
このフィルタによってＵＲＬの制御を行うことを定義します。
entry(HttpSession) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
このフィルタによってＵＲＬの制御を行うことを定義します。

F

FilterServletInputStream - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream.
InputStream を ServletInputStream に変換するためのラッパです。
FilterServletInputStream(InputStream) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のコンストラクタ
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。
ForbiddenException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException.
アクセス権限がないことを通知する例外です。
ForbiddenException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ForbiddenException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ForbiddenException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
例外を作成します。

G

getAllContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
マネージャーが保持するすべての HTTP コンテキストを返します。
getAllIds() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
現在有効なすべての HttpSession のセッションＩＤを返します。
getAllIds() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
現在有効なすべての HttpSession のセッションＩＤを返します。
getContextURL(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
引数で与えられたリクエストのコンテキストを示すURLを生成します。
getContextURL(HttpServletRequest, boolean) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
引数で与えられたリクエストのコンテキストを示すURLを生成します。
getCount() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
現在有効な HttpSession の数を返します。
getCreationTime(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
getCreationTime(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
getCurrentContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
現在のスレッドに関連付けられた HTTP コンテキストを返します。
getCurrentRequest() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在処理中のリクエストを返します。
getCurrentSession() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
このリクエストに関連づけられている現在のセッションを返します。
getFilterConfig() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
このフィルタの設定オブジェクトを返します。
getHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
指定のヘッダの値を返します。
getHeaderNames() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
ヘッダ名称一覧を返します。
getInputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
このオブジェクトがラップしている入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在のリクエストのメッセージボディを返します。
getInstance() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の static メソッド
HTTP コンテキスト・マネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の static メソッド
インスタンスを返します。
getLastAccessedTime(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
getLastAccessedTime(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
getLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
マネージャーが保持する HTTP コンテキストの数を返します。
getLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
現在有効な HttpSession の数を返します。
getManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory のメソッド
マネージャを返します。
getMaxInactiveInterval(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
getMaxInactiveInterval(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
getMessageBody() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper のメソッド
リクエストのメッセージボディを返します。
getName() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
パラメータ名を返します。
getNameAsStream() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
パラメータの名称を返します。
getRequest() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
リクエストを返します。
getRequestParameters() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper のメソッド
パラメータ情報を返します。
getRequestParameters() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在のリクエストのパラメータを返します。
getResponse() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
レスポンスを返します。
getServletContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
この Filter を実行している ServletContext への参照を返します。
getServletContext() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
サーブレットコンテキストを返します。
getSession() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
このリクエストに関連づけられている現在のセッションを返します。
getValue() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を文字列表現として返します。
getValueAsReader() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を Reader として取得します。
getValueAsStream() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を入力ストリームとして取得します。
getValueLength() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部のバイト長を返します。

H

HTTPContext - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext.
リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。
HTTPContextHandlingFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter.
このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
HTTPContextHandlingFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のコンストラクタ
デフォルト・コンストラクタ
HTTPContextManager - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager.
HTTP コンテキスト・マネージャ
HTTPContextManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のコンストラクタ
デフォルトコンストラクタ HTTPContextManager.getInstance()を利用してください。
HttpServletRequestMessageBodyWrapper - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper.
HttpServletRequest を拡張したインタフェースです。
HttpServletRequestMessageBodyWrapperBuilder - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder.
HttpServletRequest を拡張したインタフェースです。
HttpSessionManager - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager.
HttpSession に関する情報を提供するクラスの共通インタフェース定義です。
HttpSessionManagerFactory - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory.
HttpSessionManager を作成するファクトリクラスの抽象実装です。
HttpSessionManagerFactory() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory のコンストラクタ
新しい HttpSessionManagerFactory を構築します。
HttpSessionMonitoringFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter.
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。
HttpSessionMonitoringFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のコンストラクタ
新しい HttpSessionMonitoringFilter を構築します。
HttpSessionMonitoringListener - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener.
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。
HttpSessionMonitoringListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のコンストラクタ
新しいセッションリスナを構築します。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの破棄処理。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタの破棄処理。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタの破棄処理。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のメソッド
このフィルタを初期化します。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタの初期化をします。
hasHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
指定された文字列がヘッダの名称かどうかを判定します。
hasHeaders() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
このオブジェクトがヘッダ情報を持つかどうかを判定します。

I

init(FilterConfig) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタを初期化します。
init(FilterConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
このオブジェクトを初期化します。

J

jp.co.intra_mart.common.aid.jsdk.javax.servlet - package jp.co.intra_mart.common.aid.jsdk.javax.servlet
このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.utility - package jp.co.intra_mart.common.aid.jsdk.utility
このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

L

LengthRequiredException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException.
Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
LengthRequiredException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
指定のメッセージを持つ例外を作成します。
LengthRequiredException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
LengthRequiredException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
例外を作成します。
LuxuryResponseWriterFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter.
LuxuryResponseWriterFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter のコンストラクタ
デフォルトコンストラクタ
leave(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
指定のセッションに関する、このフィルタの処理を停止します。
leave(HttpSession) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
指定のセッションに関する、このフィルタの処理を停止します。
log(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
Servlet ログファイルに指定されたメッセージを出力します。
log(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
log(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
Servlet ログファイルに指定されたメッセージを出力します。
log(String, Throwable) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。

M

mark(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力ストリームの現在位置にマークを設定します。
markSupported() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。

N

NoCacheFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter.
ブラウザのキャッシュを無効にするフィルタ。
NoCacheFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のコンストラクタ
NoSuchSessionException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException.
特定のＨＴＴＰセッションが見つからない場合にスローされます。
NoSuchSessionException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
詳細メッセージを持たない NoSuchSessionException を構築します。
NoSuchSessionException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
詳細メッセージを持つ NoSuchSessionException を構築します。
NoSuchSessionException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。
NoSuchSessionException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
指定された原因を使用して新しい NoSuchSessionException を構築します。
NotFoundException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException.
指定されたコンテンツが見つからないことを通知するための例外です。
NotFoundException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
指定のメッセージを持つ例外を作成します。
NotFoundException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
NotFoundException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
例外を作成します。

R

RequestEntityTooLargeException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException.
処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
RequestEntityTooLargeException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
指定のメッセージを持つ例外を作成します。
RequestEntityTooLargeException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
RequestEntityTooLargeException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
例外を作成します。
RequestMessageBodyFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter.
リクエストをラップするフィルタです。
RequestMessageBodyFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のコンストラクタ
フィルタを作成します。
RequestParameter - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter.
１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。
ResponseContentTypeManagementFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter.
レスポンスの Content-Type を自動解決するフィルタです。
ResponseContentTypeManagementFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のコンストラクタ
新しくフィルタを作成します。
read() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から１バイト読み込みます。
read(byte[]) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から指定のバイト配列にデータを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から指定のバイト配列にデータを読み込みます。
reset() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。

S

ServiceUnavailableException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException.
サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
ServiceUnavailableException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ServiceUnavailableException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ServiceUnavailableException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
例外を作成します。
sessionCreated(HttpSessionEvent) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のメソッド
セッションが作成されたことを通知します。
sessionDestroyed(HttpSessionEvent) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のメソッド
セッションが無効になったことを通知します。
skip(long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
指定のバイト数だけ入力をスキップします。

U

URLUtil - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.
URL関連のユーティリティクラス。
URLUtil() - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil のコンストラクタ
UnauthorizedException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException.
リクエストを受け付けるためには認証が必要であることを通知するための例外です。
UnauthorizedException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
指定のメッセージを持つ例外を作成します。
UnauthorizedException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
UnauthorizedException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
例外を作成します。
UnripeQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException.
クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。
UnripeQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
UnripeQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
UnripeQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
例外を作成します。
A B C D E F G H I J L M N R S U
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


概要 (5.0 J2EE-Base Programing Model API Specifications)

すべてのクラス

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
jp.co.intra_mart.common.aid.jsdk.utility


概要 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

intra-mart(R) 5.0 J2EE-Base Programing Model API Specifications

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet | このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception | このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.utility | このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


クラス階層 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.common.aid.jsdk.javax.servlet, jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception, jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter, jp.co.intra_mart.common.aid.jsdk.javax.servlet.http, jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session, jp.co.intra_mart.common.aid.jsdk.utility

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager)
    • class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener (implements javax.servlet.http.HttpSessionListener)
    • class java.io.InputStream
      • class javax.servlet.ServletInputStream
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException
    • class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


直列化された形式 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException は UnripeQueryException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException は BadRequestException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException は ServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException は BadRequestException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException は BadRequestException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


body (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ body

HTMLのBODYタグに変換されます。

本タグはhtmlタグの中でしか使用できません。

注意事項
本タグを単独で利用することはできません。
htmlタグの内部タグとして利用します。
本タグはパネルコンポーネントの最上位に位置する場合のみレンダリングされます。
それ以外の場合、このタグの間に書かれた内容は省略されます。
サンプル:
<panel:html>
    <panel:head>
        <panel:title>
            パネルコンポーネントの最上位の場合のみ有効なタイトル
        </panel:title>
    </panel:head>
    <panel:body>
    </panel:body>
</panel:html>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
onload | false | true | java.lang.String | BODYタグのonload属性に相当します。
onunload | false | true | java.lang.String | BODYタグのonunload属性に相当します。
id | false | true | java.lang.String | BODYタグのid属性に相当します。
class | false | true | java.lang.String | BODYタグのclass属性に相当します。
style | false | true | java.lang.String | BODYタグのstyle属性に相当します。
title | false | true | java.lang.String | BODYタグのtitle属性に相当します。
lang | false | true | java.lang.String | BODYタグのlang属性に相当します。
dir | false | true | java.lang.String | BODYタグのdir属性に相当します。
onclick | false | true | java.lang.String | BODYタグのonclick属性に相当します。
ondblclick | false | true | java.lang.String | BODYタグのondblclick属性に相当します。
onmousedown | false | true | java.lang.String | BODYタグのonmousedown属性に相当します。
onmouseup | false | true | java.lang.String | BODYタグのonmouseup属性に相当します。
onmouseover | false | true | java.lang.String | BODYタグのonmouseover属性に相当します。
onmousemove | false | true | java.lang.String | BODYタグのonmousemove属性に相当します。
onmouseout | false | true | java.lang.String | BODYタグのonmouseout属性に相当します。
onkeypress | false | true | java.lang.String | BODYタグのonkeypress属性に相当します。
onkeydown | false | true | java.lang.String | BODYタグのonkeydown属性に相当します。
onkeyup | false | true | java.lang.String | BODYタグのonkeyup属性に相当します。
background | false | true | java.lang.String | BODYタグのbackground属性に相当します。
text | false | true | java.lang.String | BODYタグのtext属性に相当します。
link | false | true | java.lang.String | BODYタグのlink属性に相当します。
vlink | false | true | java.lang.String | BODYタグのvlink属性に相当します。
alink | false | true | java.lang.String | BODYタグのalink属性に相当します。
bgcolor | false | true | java.lang.String | BODYタグのbgcolor属性に相当します。

概要 ライブラリ タグ ヘルプ


form (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ form

HTMLのFORMタグに変換されます。
次の処理内容と遷移先を決定します。

注意事項
本タグを配置する場所は、HTMLのFORMタグに準じます。
使用できる属性はHTMLのFORMタグとほとんど同じですが、以下の属性は使用できません。
    action
    target
サンプル:
<panel:html view="view1">
・・・
    <panel:body>
・・・
        <panel:form name="myForm" action-point="myAction" method="POST">
            <%
                MyFormObject myForm =
                    (MyFormObject)view1.getFormObjects().get("sample");
            %>
            <INPUT type="text" name="comment"
                    value="<%= myForm.getComment() %><br>"
                    size="20"><br>
        <panel:submit value=" O K "/>
        </panel:form>
・・・
    </panel:body>
・・・
</panel:html>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
action-point | false | false | java.lang.String | このコンポーネントのパネルモデルで定義されているアクションポイント名を指定します。 このタグが内部タグとしてsubmitタグを含み、そこにaction-point属性を指定している場合のみ省略可能です。
accept | false | true | java.lang.String | FORMタグのaccept属性に相当します。
accept-charset | false | true | java.lang.String | FORMタグのaccept-charset属性に相当します。
enctype | false | true | java.lang.String | FORMタグのenctype属性に相当します。
method | false | true | java.lang.String | FORMタグのmethod属性に相当します。
onsubmit | false | true | java.lang.String | FORMタグのonsubmit属性に相当します。
onreset | false | true | java.lang.String | FORMタグのonreset属性に相当します。
name | false | true | java.lang.String | FORMタグのname属性に相当します。 このタグが内部タグとしてsubmitタグを含む場合は必須となります。
id | false | true | java.lang.String | FORMタグのid属性に相当します。
class | false | true | java.lang.String | FORMタグのclass属性に相当します。
style | false | true | java.lang.String | FORMタグのstyle属性に相当します。
title | false | true | java.lang.String | FORMタグのtitle属性に相当します。
lang | false | true | java.lang.String | FORMタグのlang属性に相当します。
dir | false | true | java.lang.String | FORMタグのdir属性に相当します。
onclick | false | true | java.lang.String | FORMタグのonclick属性に相当します。
ondblclick | false | true | java.lang.String | FORMタグのondblclick属性に相当します。
onmousedown | false | true | java.lang.String | FORMタグのonmousedown属性に相当します。
onmouseup | false | true | java.lang.String | FORMタグのonmouseup属性に相当します。
onmouseover | false | true | java.lang.String | FORMタグのonmouseover属性に相当します。
onmousemove | false | true | java.lang.String | FORMタグのonmousemove属性に相当します。
onmouseout | false | true | java.lang.String | FORMタグのonmouseout属性に相当します。
onkeypress | false | true | java.lang.String | FORMタグのonkeypress属性に相当します。
onkeydown | false | true | java.lang.String | FORMタグのonkeydown属性に相当します。
onkeyup | false | true | java.lang.String | FORMタグのonkeyup属性に相当します。

概要 ライブラリ タグ ヘルプ


frame (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ frame

HTMLのFRAMEタグに変換されます。

本タグはhtmlタグの中でしか使用できません。

注意事項
本タグを単独で利用することはできません。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
action-point | true | false | java.lang.String | このコンポーネントのパネルモデルで定義されているアクションポイント名を指定します。
id | false | true | java.lang.String | HTMLにおけるFRAMEタグのid属性に相当します。
class | false | true | java.lang.String | HTMLにおけるFRAMEタグのclass属性に相当します。
style | false | true | java.lang.String | HTMLにおけるFRAMEタグのstyle属性に相当します。
title | false | true | java.lang.String | HTMLにおけるFRAMEタグのtitle属性に相当します。
frameborder | false | true | java.lang.String | HTMLにおけるFRAMEタグのframeborder属性に相当します。
longdesc | false | true | java.lang.String | HTMLにおけるFRAMEタグのlongdesc属性に相当します。
marginheight | false | true | java.lang.String | HTMLにおけるFRAMEタグのmarginheight属性に相当します。
marginwidth | false | true | java.lang.String | HTMLにおけるFRAMEタグのmarginwidth属性に相当します。
noresize | false | true | java.lang.String | HTMLにおけるFRAMEタグのnoresize属性に相当します。
scrolling | false | true | java.lang.String | HTMLにおけるFRAMEタグのscrolling属性に相当します。

概要 ライブラリ タグ ヘルプ


frameset (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ frameset

HTMLのFRAMESETタグに変換されます。

本タグはhtmlタグの中でしか使用できません。

注意事項
本タグを単独で利用することはできません。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
cols | false | true | java.lang.String | HTMLにおけるFRAMESETタグのcols属性に相当します。
rows | false | true | java.lang.String | HTMLにおけるFRAMESETタグのrows属性に相当します。
border | false | true | java.lang.String | HTMLにおけるFRAMESETタグのborder属性に相当します。
frameborder | false | true | java.lang.String | HTMLにおけるFRAMESETタグのframeborder属性に相当します。
class | false | true | java.lang.String | HTMLにおけるFRAMESETタグのclass属性に相当します。
id | false | true | java.lang.String | HTMLにおけるFRAMESETタグのid属性に相当します。
onload | false | true | java.lang.String | HTMLにおけるFRAMESETタグのonload属性に相当します。
onunload | false | true | java.lang.String | HTMLにおけるFRAMESETタグのonunload属性に相当します。
style | false | true | java.lang.String | HTMLにおけるFRAMESETタグのstyle属性に相当します。
title | false | true | java.lang.String | HTMLにおけるFRAMESETタグのtitle属性に相当します。

概要 ライブラリ タグ ヘルプ


head (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ head

HTMLのHEADタグに変換されます。
最上位のパネルコンポーネントの場合のみこのタグはレンダリングされます。

注意事項
本タグはパネルコンポーネントの最上位に位置する場合のみレンダリングされます。
それ以外の場合、このタグの間に書かれた内容は省略されます。
サンプル:
<panel:html>
    <panel:head>
        ここに書かれた情報はパネルコンポーネントの最上位に
        位置する場合にのみ表示されます。
        サブパネルの中ではこの部分は表示されません。
    </panel:head>
    <panel:body>
    </panel:body>
</panel:html>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
lang | false | true | java.lang.String | HEADタグのlang属性に相当します。
dir | false | true | java.lang.String | HEADタグのdir属性に相当します。
profile | false | true | java.lang.String | HEADタグのprofile属性に相当します。

概要 ライブラリ タグ ヘルプ


html (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ html

HTMLタグに変換されます。
パネルコンポーネントはこのタグを必ず含む必要があります。
最上位のパネルコンポーネントの場合のみこのタグはレンダリングされます。
コンテンツコンポーネントがドキュメントタイプを指定している場合、実際のHTMLタグの直前にドキュメントタイプがレンダリングされます。
最上位以外のパネルコンポーネントではHTMLタグやドキュメントタイプはレンダリングされません。

サンプル:
<panel:html view="myView">
    <%
        MyViewObject myObject = (MyViewObject)myView;
    %>
    <panel:head>
    </panel:head>
    <panel:body>
        message = <%= myObject.getMessage() %>
    </panel:body>
</panel:html>

上記の例では、MyViewObjectはjp.co.intra_mart.framework.presentation.view.PanelBasedViewObjectを実装したクラスであり、 メソッドgetMessage()を持っています。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
view | false | false | java.lang.String | このパネルコンポーネントのビューオブジェクト名を指定します。 この属性でビューオブジェクトの名前を指定すると、以降このパネルコンポーネントはこの名前でビューオブジェクトにアクセスできます。 この属性を使用する場合、直前のViewConverterではjp.co.intra_mart.framework.presentation.view.PanelBasedViewObjectを実装したクラスのインスタンスを返す必要があります。
lang | false | true | java.lang.String | HTMLタグのlang属性に相当します。
dir | false | true | java.lang.String | HTMLタグのdir属性に相当します。

概要 ライブラリ タグ ヘルプ


link (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ link

HTMLのAタグに変換されます。
次の処理内容と遷移先を決定します。

注意事項
本タグを配置する場所は、HTMLのAタグに準じます。
使用できる属性はHTMLのFORMタグとほとんど同じですが、以下の属性は使用できません。
    href
    target
サンプル:
<panel:html view="view1">
・・・
    <panel:body>
・・・
        <panel:link action-point="sample_action">
            <%
                MyFormObject myObj =
                    (MyFormObject)view1.getFormObjects().get("sample");
            %>
            <panel:param name="param1" value="value1"/>
            <panel:param name="message" value="<%= myObj.getMessage() %/>"/>
            リンク１
        </panel:link>
・・・
    </panel:body>
</panel:html>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
action-point | true | false | java.lang.String | このコンポーネントのパネルモデルで定義されているアクションポイント名を指定します。
charset | false | true | java.lang.String | HTMLにおけるAタグのcharset属性に相当します。
type | false | true | java.lang.String | HTMLにおけるAタグのtype属性に相当します。
name | false | true | java.lang.String | HTMLにおけるAタグのname属性に相当します。
hreflang | false | true | java.lang.String | HTMLにおけるAタグのhreflang属性に相当します。
rel | false | true | java.lang.String | HTMLにおけるAタグのrel属性に相当します。
rev | false | true | java.lang.String | HTMLにおけるAタグのrev属性に相当します。
accesskey | false | true | java.lang.String | HTMLにおけるAタグのaccesskey属性に相当します。
shape | false | true | java.lang.String | HTMLにおけるAタグのshape属性に相当します。
coords | false | true | java.lang.String | HTMLにおけるAタグのcoords属性に相当します。
tabindex | false | true | java.lang.String | HTMLにおけるAタグのtabindex属性に相当します。
onfocus | false | true | java.lang.String | HTMLにおけるAタグのonfocus属性に相当します。
onblur | false | true | java.lang.String | HTMLにおけるAタグのonblur属性に相当します。
id | false | true | java.lang.String | HTMLにおけるAタグのid属性に相当します。
class | false | true | java.lang.String | HTMLにおけるAタグのclass属性に相当します。
style | false | true | java.lang.String | HTMLにおけるAタグのstyle属性に相当します。
title | false | true | java.lang.String | HTMLにおけるAタグのtitle属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるAタグのlang属性に相当します。
dir | false | true | java.lang.String | HTMLにおけるAタグのdir属性に相当します。
onclick | false | true | java.lang.String | HTMLにおけるAタグのonclick属性に相当します。
ondblclick | false | true | java.lang.String | HTMLにおけるAタグのondblclick属性に相当します。
onmousedown | false | true | java.lang.String | HTMLにおけるAタグのonmousedown属性に相当します。
onmouseup | false | true | java.lang.String | HTMLにおけるAタグのonmouseup属性に相当します。
onmouseover | false | true | java.lang.String | HTMLにおけるAタグのonmouseover属性に相当します。
onmousemove | false | true | java.lang.String | HTMLにおけるAタグのonmousemove属性に相当します。
onmouseout | false | true | java.lang.String | HTMLにおけるAタグのonmouseout属性に相当します。
onkeypress | false | true | java.lang.String | HTMLにおけるAタグのonkeypress属性に相当します。
onkeydown | false | true | java.lang.String | HTMLにおけるAタグのonkeydown属性に相当します。
onkeyup | false | true | java.lang.String | HTMLにおけるAタグのonkeyup属性に相当します。

概要 ライブラリ タグ ヘルプ


param (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ param

リンク先や遷移先にパラメータを引き渡すために利用します。
本タグを単独で利用することはできません。
linkタグの内部タグとして利用します。

注意事項
本タグを単独で利用することはできません。
linkタグの内部タグとして利用します。
サンプル:
<panel:link action-point="sample_link"">
    <panel:param name="param1" value="value1"/>
    リンク１
</panel:link>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | パラメータ名を指定します。
value | true | true | java.lang.String | パラメータ値を指定します。

概要 ライブラリ タグ ヘルプ


submit (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ submit

サブミットボタンを表示します。
１つのフォーム内で複数のサブミットボタンを配置したいときなどに利用します。本タグを利用して複数のサブミットボタンを配置した場合、formタグとは独立してアクションポイントを指定することが可能です。

本タグはformタグの中でしか使用できません。

注意事項
本タグを単独で利用することはできません。
formタグの内部タグとして利用します。
本タグを使用する場合、formタグのname属性は設定必須となります。
サンプル:
<panel:form action-point="sample_insert" method="POST" >
    コード：<INPUT type="text" name="code" value="" ><BR>
    <panel:submit value="登録"/>
    <panel:submit action-point="sample_other" value="別処理"/>
</panel:form>

この例では２つのボタンが表示されます。それぞれの動作は以下のようになります。
ボタン | 動作
登録 | アクションポイントがsample_insertとなる時の処理、遷移が行われます。
別処理 | アクションポイントがsample_otherとなる時の処理、遷移が行われます。
タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
action-point | false | false | java.lang.String | このコンポーネントのパネルモデルで定義されているアクションポイント名を指定します。
id | false | true | java.lang.String | HTMLにおけるINPUTタグのid属性に相当します。
name | false | true | java.lang.String | HTMLにおけるINPUTタグのname属性に相当します。
class | false | true | java.lang.String | HTMLにおけるINPUTタグのclass属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるINPUTタグのlang属性に相当します。
style | false | true | java.lang.String | HTMLにおけるINPUTタグのstyle属性に相当します。
title | false | true | java.lang.String | HTMLにおけるINPUTタグのtitle属性に相当します。
onclick | false | true | java.lang.String | HTMLにおけるINPUTタグのonclick属性に相当します。
ondblclick | false | true | java.lang.String | HTMLにおけるINPUTタグのondblclick属性に相当します。
onmousedown | false | true | java.lang.String | HTMLにおけるINPUTタグのonmousedown属性に相当します。
onmouseup | false | true | java.lang.String | HTMLにおけるINPUTタグのonmouseup属性に相当します。
onmouseover | false | true | java.lang.String | HTMLにおけるINPUTタグのonmouseover属性に相当します。
onmousemove | false | true | java.lang.String | HTMLにおけるINPUTタグのonmousemove属性に相当します。
onmouseout | false | true | java.lang.String | HTMLにおけるINPUTタグのonmouseout属性に相当します。
onkeypress | false | true | java.lang.String | HTMLにおけるINPUTタグのonkeypress属性に相当します。
onkeydown | false | true | java.lang.String | HTMLにおけるINPUTタグのonkeydown属性に相当します。
onkeyup | false | true | java.lang.String | HTMLにおけるINPUTタグのonkeyup属性に相当します。
dir | false | true | java.lang.String | HTMLにおけるINPUTタグのdir属性に相当します。
value | false | true | java.lang.String | HTMLにおけるINPUTタグのvalue属性に相当します。
onblur | false | true | java.lang.String | HTMLにおけるINPUTタグのonblur属性に相当します。
onfocus | false | true | java.lang.String | HTMLにおけるINPUTタグのonfocus属性に相当します。

概要 ライブラリ タグ ヘルプ


subPanel (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ subPanel

サブパネルを表示します。
サブパネルポイント名で指定されるサブパネルをこの場所に表示します。
サンプル:
<panel:html>
    <panel:head>
    </panel:head>
    <panel:body>
        <panel:subPanel sub-panel-point="top_panel">
        <hr>
        <panel:subPanel sub-panel-point="bottom_panel">
    </panel:body>
</panel:html>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
sub-panel-point | true | false | java.lang.String | このコンポーネントのパネルモデルで定義されているサブパネルポイント名を指定します。

概要 ライブラリ タグ ヘルプ


title (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ
タグ title

HTMLのTITLEタグに変換されます。
最上位のパネルコンポーネントの場合のみこのタグはレンダリングされます。

本タグはheadタグの中でしか使用できません。

注意事項
本タグを単独で利用することはできません。
headタグの内部タグとして利用します。
本タグはパネルコンポーネントの最上位に位置する場合のみレンダリングされます。
それ以外の場合、このタグの間に書かれた内容は省略されます。
サンプル:
<panel:html>
    <panel:head>
        <panel:title>
            パネルコンポーネントの最上位の場合のみ有効なタイトル
        </panel:title>
    </panel:head>
    <panel:body>
    </panel:body>
</panel:html>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
lang | false | true | java.lang.String | TITLEタグのlang属性に相当します。
dir | false | true | java.lang.String | TITLEタグのdir属性に相当します。

概要 ライブラリ タグ ヘルプ


 intra-mart Presentation Framework タグライブラリ
タグ一覧
imart:body
imart:form
imart:frame
imart:frameset
imart:head
imart:html
imart:link
imart:param
imart:submit
imart:subPanel
imart:title


intra-mart Presentation Framework タグライブラリ (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart Presentation Framework タグライブラリ

標準構文:
     <%@ taglib prefix="imart" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
XML構文:
     <anyxmlelement xmlns:imart="http://www.intra-mart.co.jp/taglib/core/standard" />
Presentation Framework タグライブラリ。

intra-mart Presentation Framework タグライブラリ仕様

1. タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。

2. タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。

3. タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。

4. タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。

5. JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法
Presentation Frameworkタグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/presentation/panel" prefix="panel" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/core/presentation/panel" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "panel" として説明します)

サンプル
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/presentation/panel" prefix="panel" %>

<panel:html>

<panel:head>
<panel:title>Hello Presentation Framework.</panel:title>
</panel:head>

<panel:body bgcolor="whitesmoke">

<CENTER><H2>
<panel:form action-point="sample" value="view1" method="POST">
<INPUT type="text" name="column1" size="20"><BR>
<panel:submit value=" O K ">
</panel:Form>
</H2></CENTER>

</panel:body>

</panel:html>

タグライブラリ情報
表示名 | intra-mart Presentation Framework タグライブラリ
Version | 1.0
Short Name | imart
URI | http://www.intra-mart.co.jp/taglib/core/standard

タグ 一覧
body | HTMLのBODYタグに変換されます。
form | HTMLのFORMタグに変換されます。
frame | HTMLのFRAMEタグに変換されます。
frameset | HTMLのFRAMESETタグに変換されます。
head | HTMLのHEADタグに変換されます。
html | HTMLタグに変換されます。
link | HTMLのAタグに変換されます。
param | リンク先や遷移先にパラメータを引き渡すために利用します。
submit | サブミットボタンを表示します。
subPanel | サブパネルを表示します。
title | HTMLのTITLEタグに変換されます。

概要 ライブラリ タグ ヘルプ


 すべてのタグおよび関数
imart:body
imart:form
imart:frame
imart:frameset
imart:head
imart:html
imart:link
imart:param
imart:submit
imart:subPanel
imart:title


API ヘルプ (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
PREV NEXT フレームあり フレームなし

このタグ・ライブラリ・ドキュメントはどう構成されているか。

このTLD(Tag Library Descriptor)ドキュメントのナビゲーション・バーの説明は以下の通り。

概要

概要 ページは、このTLDドキュメントの第一面であり、それぞれのために概要をすべてのタグ・ライブラリのリストを表示します。

ライブラリ

それぞれのタグ・ライブラリには、その検証、リスナー、タグ、関数のリストを含む1ページがあり、それぞれの概要となります。 このページは4つのカテゴリを含みます:
  • 検証
  • リスナー
  • タグ
  • 関数

検証

タグ・ライブラリは０以上の検証を定義することができます。 タグ・ライブラリに検証があるなら、それはそれ自身のページに検証、検証を実行するクラス、および利用可能な初期化パラメータについて説明します。

リスナー

タグ・ライブラリは０以上のリスナを定義することができます。 タグ・ライブラリに少なくとも1つのリスナが定義されているなら、すべてのリスナ・クラスを説明するページがあります。

タグ

タグ・ライブラリは０以上のタグを定義することができます。また、各タグにはタグについて説明するそれ自身のページがあります。 そのディスプレイ名、そのユニークなアクション名、タグを実行するクラス、TagExtraInfoクラス、ボディー内容、タイプ、変数情報、属性、タグが動的属性、およびタグのオプションの使用例を説明します。

関数

タグ・ライブラリは０以上の関数を定義することができます。各関数には、関数について説明するそれ自身のページがあります。 そのユニークなアクション名、そのディスプレイ名、タグを実行するクラスについて説明します。 タグ・ライブラリに少なくとも1つの関数が定義されているなら、機能のすべての機能、機能を実行するクラス、機能署名、およびオプションの使用例を示すページがあります。

Prev/Next

これらのリンクは次か前の検証、リスナー、タグ、関数、または関連するページに移動します。

フレームあり/フレームなし

これらのリンクは、HTMLフレームの使用、未使用を選択できます。

概要 ライブラリ タグ ヘルプ
PREV NEXT フレームあり フレームなし


Tag Library Documentation Generator - Generated Documentation

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link to Non-frame version.


概要 (Tag Library Documentation Generator - Generated Documentation)

タグライブラリ ドキュメント
すべてのタグおよび関数

タグライブラリ
intra-mart Presentation Framework タグライブラリ


概要 (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

タグライブラリ ドキュメント

タグライブラリ
intra-mart Presentation Framework タグライブラリ Presentation Framework タグライブラリ。

概要 ライブラリ タグ ヘルプ


Form (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ Form

HTMLのFORMタグに変換されます。

セッション情報を引き渡すために利用します。

本タグのapplication および service属性によって処理や遷移先が決定されます。

注意事項
本タグを配置する場所は、HTMLのFORMタグに準じます。
サンプル:
<imartj2ee:Form application="sample" service="view1" method="POST">
    <INPUT type="text" name="column1" size="20"><BR>
    <INPUT type="submit" value=" O K ">
</imartj2ee:Form>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
accept | false | true | java.lang.Number | HTMLにおけるFORMタグのaccept属性に相当します。
acceptcharset | false | true | java.lang.String | 奨励されていません。accept-charset属性を使用してください。 HTMLにおけるFORMタグのaccept-charset属性に相当します。 注意：属性名はハイフン無しで記述してください。
accept-charset | false | true | java.lang.String | HTMLにおけるFORMタグのaccept-charset属性に相当します。
application | true | true | java.lang.String | アプリケーションIDを指定します。
class | false | true | java.lang.String | HTMLにおけるFORMタグのclass属性に相当します。
dir | false | true | java.lang.String | HTMLにおけるFORMタグのdir属性に相当します。
enctype | false | true | java.lang.String | HTMLにおけるFORMタグのenctype属性に相当します。
formclass | false | true | java.lang.String | 奨励されていません。class属性を使用してください。 HTMLにおけるFORMタグのclass属性に相当します。 注意：変換後に属性名が変わります。
id | false | true | java.lang.String | HTMLにおけるFORMタグのid属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるFORMタグのlang属性に相当します。
method | false | true | java.lang.String | HTMLにおけるFORMタグのmethod属性に相当します。
name | false | true | java.lang.String | HTMLにおけるFORMタグのname属性に相当します。
onclick | false | true | java.lang.String | HTMLにおけるFORMタグのonClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
ondblclick | false | true | java.lang.String | HTMLにおけるFORMタグのonDblClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeydown | false | true | java.lang.String | HTMLにおけるFORMタグのonKeyUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeypress | false | true | java.lang.String | HTMLにおけるFORMタグのonKeyPress属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeyup | false | true | java.lang.String | HTMLにおけるFORMタグのonKeyUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousedown | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousemove | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseMove属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseout | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseOut属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseover | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseOver属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseup | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onreset | false | true | java.lang.String | HTMLにおけるFORMタグのonReset属性に相当します。 注意：属性名はすべて小文字で記述してください。
onsubmit | false | true | java.lang.String | HTMLにおけるFORMタグのonSubmit属性に相当します。 注意：属性名はすべて小文字で記述してください。
service | true | true | java.lang.String | サービスIDを指定します。
style | false | true | java.lang.String | HTMLにおけるFORMタグのstyle属性に相当します。
target | false | true | java.lang.String | HTMLにおけるFORMタグのtarget属性に相当します。
title | false | true | java.lang.String | HTMLにおけるFORMタグのtitle属性に相当します。

概要 ライブラリ タグ ヘルプ


Frame (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ Frame

HTMLのFRAMEタグに変換されます。
セッション情報を引き渡すために利用します。

本タグのapplication および service属性によって処理や遷移先が決定されます。

注意事項
本タグを配置する場所は、HTMLのFRAMEタグに準じます。
サンプル:
<FRAMESET rows="50%,*">
    <imartj2ee:Frame application="sample" service="frametop">
        <imartj2ee:Param name="param1" value="value1"/>
    </imartj2ee:Frame>
    <imartj2ee:Frame application="sample" service="framebottom">
        <imartj2ee:Param name="param2" value="value2"/>
    </imartj2ee:Frame>
</FRAMESET>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | false | true | java.lang.String | HTMLにおけるFRAMEタグのid属性に相当します。
application | true | true | java.lang.String | アプリケーションIDを指定します。
service | true | true | java.lang.String | サービスIDを指定します。
frameclass | false | true | java.lang.String | 奨励されていません。class属性を使用してください。 HTMLにおけるFRAMEタグのclass属性に相当します。 注意：変換後に属性名が変わります。
class | false | true | java.lang.String | HTMLにおけるFRAMEタグのclass属性に相当します。
frameborder | false | true | java.lang.String | HTMLにおけるFRAMEタグのframeborder属性に相当します。
longdesc | false | true | java.lang.String | HTMLにおけるFRAMEタグのlongdesc属性に相当します。
marginheight | false | true | java.lang.String | HTMLにおけるFRAMEタグのmarginheight属性に相当します。
marginwidth | false | true | java.lang.String | HTMLにおけるFRAMEタグのmarginwidth属性に相当します。
name | false | true | java.lang.String | HTMLにおけるFRAMEタグのname属性に相当します。
noresize | false | true | java.lang.String | HTMLにおけるFRAMEタグのnoresize属性に相当します。
scrolling | false | true | java.lang.String | HTMLにおけるFRAMEタグのscrolling属性に相当します。
style | false | true | java.lang.String | HTMLにおけるFRAMEタグのstyle属性に相当します。
title | false | true | java.lang.String | HTMLにおけるFRAMEタグのtitle属性に相当します。

概要 ライブラリ タグ ヘルプ


HelperBean (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ HelperBean

HelperBeanを使用するための初期化を行います。
ErrorHelperBeanもこのタグで初期化できます。
このタグを使用すると、HelperBeanの生成、Requestの設定、Responseの設定、初期化(initメソッドの呼び出し)が自動的に行われます。

注意事項
JSP内でHelperBean（またはErrorHelperBean）を使用する場合、本タグを先に配置してください。
HelperBean（またはErrorHelperBean）を本タグより先に使用している場合、JSPのエラーが出る場合があります。
HelperBeanの詳細についてはAPIリスト等でjp.co.intra_mart.framework.base.web.bean.HelperBean（ErrorHelperBeanの場合はjp.co.intra_mart.framework.base.web.bean.ErrorHelperBean）を参照してください。

サンプル:
この中で使用されるsample.TestHelperBeanは社員コードを取得する以下のメソッドが実装されているものとします。
public String getCode()

<imartj2ee:HelperBean id="testHelper" class="sample.TestHelperBean" />
社員コード：<jsp:getProperty name="testHelper" property="code" />

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | true | false | java.lang.String | JSPの中でHelperBeanを使用するときの変数名を指定します。
helperclass | false | false | java.lang.String | 奨励されていません。class属性を使用してください。 HelperBeanの完全なクラス名(パッケージを含むクラス名)を指定します。 ここで指定するクラスはjp.co.intra_mart.framework.base.web.bean.HelperBeanを継承している必要があります。
class | false | false | java.lang.String | HelperBeanの完全なクラス名(パッケージを含むクラス名)を指定します。 ここで指定するクラスはjp.co.intra_mart.framework.base.web.bean.HelperBeanを継承している必要があります。

概要 ライブラリ タグ ヘルプ


Link (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ Link

HTMLのAタグに変換されます。
セッション情報を引き渡すために利用します。

本タグのapplication および service属性によって処理や遷移先が決定されます。

注意事項
本タグを配置する場所は、HTMLのFORMタグに準じます。
サンプル:
<imartj2ee:Link application="sample" service="view1">
    <imartj2ee:Param name="param1" value="value1"/>
    リンク１
</imartj2ee:Link>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | false | true | java.lang.String | HTMLにおけるAタグのid属性に相当します。
application | true | true | java.lang.String | アプリケーションIDを指定します。
service | true | true | java.lang.String | サービスIDを指定します。
accesskey | false | true | java.lang.String | HTMLにおけるAタグのaccesskey属性に相当します。
charset | false | true | java.lang.String | HTMLにおけるAタグのcharset属性に相当します。
coords | false | true | java.lang.String | HTMLにおけるAタグのcoords属性に相当します。
dir | false | true | java.lang.String | HTMLにおけるAタグのdir属性に相当します。
hreflang | false | true | java.lang.String | HTMLにおけるAタグのhreflang属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるAタグのlang属性に相当します。
linkclass | false | true | java.lang.String | 奨励されていません。class属性を使用してください。 HTMLにおけるAタグのclass属性に相当します。 注意：変換後に属性名が変わります。
class | false | true | java.lang.String | HTMLにおけるAタグのclass属性に相当します。
name | false | true | java.lang.String | HTMLにおけるAタグのname属性に相当します。
onblur | false | true | java.lang.String | HTMLにおけるAタグのonBlur属性に相当します。 注意：属性名はすべて小文字で記述してください。
onclick | false | true | java.lang.String | HTMLにおけるAタグのonClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
ondblclick | false | true | java.lang.String | HTMLにおけるAタグのonDblClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
onfocus | false | true | java.lang.String | HTMLにおけるAタグのonFocus属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeydown | false | true | java.lang.String | HTMLにおけるAタグのonKeyDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeypress | false | true | java.lang.String | HTMLにおけるAタグのonKeyPress属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeyup | false | true | java.lang.String | HTMLにおけるAタグのonKeyUp属性に相当します。
onmousedown | false | true | java.lang.String | HTMLにおけるAタグのonMouseDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousemove | false | true | java.lang.String | HTMLにおけるAタグのonMouseMove属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseout | false | true | java.lang.String | HTMLにおけるAタグのonMouseOut属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseover | false | true | java.lang.String | HTMLにおけるAタグのonMouseOver属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseup | false | true | java.lang.String | HTMLにおけるAタグのonMouseUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
rel | false | true | java.lang.String | HTMLにおけるAタグのrel属性に相当します。
rev | false | true | java.lang.String | HTMLにおけるAタグのrev属性に相当します。
shape | false | true | java.lang.String | HTMLにおけるAタグのshape属性に相当します。
style | false | true | java.lang.String | HTMLにおけるAタグのstyle属性に相当します。
tabindex | false | true | java.lang.String | HTMLにおけるAタグのtabindex属性に相当します。
title | false | true | java.lang.String | HTMLにおけるAタグのtitle属性に相当します。
type | false | true | java.lang.String | HTMLにおけるAタグのtype属性に相当します。
target | false | true | java.lang.String | HTMLにおけるAタグのtarget属性に相当します。

概要 ライブラリ タグ ヘルプ


Message (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ Message

地域対応されたメッセージを表示します。
メッセージの国際化処理をJSPに埋め込むことなく地域対応したメッセージを表示したいときに利用します。

アプリケーションIDとキーは設定必須ですが、ロケールは省略可能です。ロケールを省略した場合、サービスフレームワークで決定されるロケールが使用されます。

内部タグであるMessageParamタグを使用するとメッセージ内の変数要素に値を入れることもできます。 この場合、MessageParamタグを複数指定すると、指定された順に整列された配列が生成され、Messageタグに渡されます。

注意事項
対応するメッセージが構築できなかった場合、このタグは"???<key>???"と表示します。<key>は属性keyで指定した値です。
メッセージの変換内容やルールは、JavaTMのjava.text.MessageFormatのformat(java.lang.Object obj)メソッドの呼び出しと同様です。

サンプル:
<imartj2ee:Message application="sample" key="welcome">
    <imartj2ee:MessageParam value="intra-mart" />
    <imartj2ee:MessageParam value="master" />
</imartj2ee:Message>

メッセージプロパティハンドラとしてDefaultMessagePropertyHandlerを使用し、MessageConfig_sample_ja_JP.propertiesに以下のような記述をしておきます。
（実際にはMessageConfig_sample_ja_JP.propertiesはnative2asciiなどで変換されている必要があります。）

welcome={0}へようこそ、{1}さん！

同様にMessageConfig_sample.propertiesに以下のような記述をしておきます。

welcome=Hello, {1}. Welcome to {0}!

この場合、最初に示したコードはサービスフレームワークで決定されるロケールによって以下のように表示されます。
ロケール | 表示内容
ja_JP | intra-martへようこそ、masterさん！
(指定なし) | Hello, master. Welcome to intra-mart!

また、以下のように明示的にロケールを指定することも可能です。この場合、サービスフレームワークで決定されるロケールは無視され、「intra-martへようこそ、masterさん！」と表示されます。

<imartj2ee:Message application="sample" key="welcome" locale="ja_JP" >
    <imartj2ee:MessageParam value="intra-mart" />
    <imartj2ee:MessageParam value="master" />
</imartj2ee:Message>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
application | true | true | java.lang.String | アプリケーションIDを指定します。
key | true | true | java.lang.String | メッセージのキーを指定します。
locale | false | true | java.lang.String | メッセージを構築するときのロケールを指定します。 省略した場合、サービスフレームワークで決定されるロケールが使用されます。

概要 ライブラリ タグ ヘルプ


MessageParam (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ MessageParam

地域対応されたメッセージに渡すパラメータを表示します。
メッセージ内部の変数をここで指定した値に置き換えるために使用します。

注意事項
本タグを単独で利用することはできません。
intra-mart J2EEフレームワークタグライブラリのMessageタグの内部タグとして利用します。
サンプル:
Messageタグの例を参照してください。
タグ情報
表示名 | なし
ボディ コンテンツ | tagdependent

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.lang.Object | 変換する値を指定します。

概要 ライブラリ タグ ヘルプ


Param (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ Param

リンク先や遷移先にパラメータを引き渡すために利用します。

本タグを単独で利用することはできません。
intra-mart J2EEフレームワークタグライブラリのFrameおよびLinkタグの内部タグとして利用します。

注意事項
本タグを単独で利用することはできません。
intra-mart J2EEフレームワークタグライブラリのFrameおよびLinkタグの内部タグとして利用します。
サンプル:
パラメータの引渡し（Linkタグ利用時）
<imartj2ee:Link application="sample" service="view1">
    <imartj2ee:Param name="param1" value="value1"/>
    リンク１
</imartj2ee:Link>

タグ情報
表示名 | なし
ボディ コンテンツ | tagdependent

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.lang.String | パラメータ値を指定します。
name | true | true | java.lang.String | パラメータ名を指定します。

概要 ライブラリ タグ ヘルプ


Submit (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ Submit

サブミットボタンを表示します。

１つのフォーム内で複数のサブミットボタンを配置したいときなどに利用します。本タグを利用して複数のサブミットボタンを配置した場合、Formタグとは独立してアプリケーションIDとサービスIDを指定することが可能です。

本タグはFormタグの中でしか使用できません。

注意事項
本タグを単独で利用することはできません。
intra-mart J2EEフレームワークタグライブラリのFormタグの内部タグとして利用します。
本タグを使用する場合、Formタグのname属性は設定必須となります。

サンプル:
<imartj2ee:Form application="sample" service="insert" method="POST" >
    コード：<INPUT type="text" name="code" value="" ><BR>
    <INPUT type="submit" name="normal" value="通常登録"/>
    <imartj2ee:Submit application="sample" service="insert1" value="登録１"/>
    <imartj2ee:Submit application="other" service="insert2" value="登録２"/>
    <imartj2ee:Submit service="insert3" value="登録３"/>
</imartj2ee:Form>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | false | true | java.lang.String | HTMLにおけるINPUTタグのid属性に相当します。
application | false | true | java.lang.String | アプリケーションIDを指定します。 省略した場合、FormタグのアプリケーションIDが使用されます。
service | true | true | java.lang.String | サービスIDを指定します。
name | false | true | java.lang.String | HTMLにおけるINPUTタグのname属性に相当します。
submitclass | false | true | java.lang.String | 奨励されていません。class属性を使用してください。 HTMLにおけるINPUTタグのclass属性に相当します。 注意：変換後に属性名が変わります。
class | false | true | java.lang.String | HTMLにおけるINPUTタグのclass属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるINPUTタグのlang属性に相当します。
style | false | true | java.lang.String | HTMLにおけるINPUTタグのstyle属性に相当します。
tabindex | false | true | java.lang.String | HTMLにおけるINPUTタグのtabindex属性に相当します。
title | false | true | java.lang.String | HTMLにおけるINPUTタグのtitle属性に相当します。
onclick | false | true | java.lang.String | HTMLにおけるINPUTタグのonClick属性に相当します。
ondblclick | false | true | java.lang.String | HTMLにおけるINPUTタグのonDblClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousedown | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseup | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseover | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseOver属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousemove | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseMove属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseout | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseOut属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeypress | false | true | java.lang.String | HTMLにおけるINPUTタグのonKeyPress属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeydown | false | true | java.lang.String | HTMLにおけるINPUTタグのonKeyDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeyup | false | true | java.lang.String | HTMLにおけるINPUTタグのonKeyUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
dir | false | true | java.lang.String | HTMLにおけるINPUTタグのdir属性に相当します。
value | false | true | java.lang.String | HTMLにおけるINPUTタグのvalue属性に相当します。
onblur | false | true | java.lang.String | HTMLにおけるINPUTタグのonBlur属性に相当します。 注意：属性名はすべて小文字で記述してください。
onfocus | false | true | java.lang.String | HTMLにおけるINPUTタグのonFocus属性に相当します。 注意：属性名はすべて小文字で記述してください。

概要 ライブラリ タグ ヘルプ


SubmitLink (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ
タグ SubmitLink

Formタグによって指定されたフォームをサブミットするリンクに変換されます。

Formタグによって指定されたフォームの中で行うサブミットをボタンではなくリンクにしたい場合、また、フォームの外部からサブミットを行いたい場合このタグを利用します。

本タグのapplication および service属性は、該当するFormのapplication および service属性に優先されます。

注意事項
application属性、service属性、form属性は必須属性ではありませんが、以下のルールに従う必要があります。

    Formタグの外部にこのタグを指定する場合、form属性の指定は必須。（この場合、form属性で指定されたFormに対してサブミットが行われます）
    Formタグの内部にこのタグを指定する場合、form属性の指定は不可。（この場合、このタグを内包しているFormに対してサブミットが行われます）
    application属性を指定する場合、service属性の指定は必須。
    application属性を省略する場合、service属性の指定は不可。
    application属性を省略してservice属性を指定することは可能。（この場合、application属性は、このタグがサブミットするFormのapplication属性が指定されたものとみなされます）

一度サブミットした後にブラウザのBackボタンなどによって元の画面に戻り、このタグで再度サブミットした場合の遷移先は不定です。ブラウザの履歴によらない、通常の画面遷移によって同じ画面が表示された場合は上記のルールが再び適用されます。

また、通常のHTMLの<A>タグと違い、以下の属性が使用できません。
    charset
    type
    hreflang
    rel
    rev
    target

サンプル:
<imartj2ee:SubmitLink form="user_form"
                      application="other_out"
                      service="view_out1">Outer 1</imartj2ee:SubmitLink><BR>
<imartj2ee:SubmitLink form="user_form"
                      service="view_out2">Outer 2</imartj2ee:SubmitLink><BR>
<imartj2ee:SubmitLink form="user_form">Out 3</imartj2ee:SubmitLink><BR>

        :

<imartj2ee:Form name="user_form" application="sample" service="original">
    <INPUT type="text" name="user" value=""><BR>
    <imartj2ee:SubmitLink application="other_in"
                          service="view_in1">Inner 1</imartj2ee:SubmitLink><BR>
    <imartj2ee:SubmitLink service="view_in2">Inner 2</imartj2ee:SubmitLink><BR>
    <imartj2ee:SubmitLink>Inner 3</imartj2ee:SubmitLink><BR>
</imartj2ee:Form>

この例では６つのボタンが表示されます。それぞれの動作は以下のようになります。
リンク | 動作
Outer 1 | アプリケーションID=other_out、サービスID=view_out1となる時の処理、遷移が行われます。
Outer 2 | アプリケーションID=sample、サービスID=view_out2となる時の処理、遷移が行われます。
Outer 3 | アプリケーションID=sample、サービスID=originalとなる時の処理、遷移が行われます。
Inner 1 | アプリケーションID=other_in、サービスID=view_in1となる時の処理、遷移が行われます。
Inner 2 | アプリケーションID=sample、サービスID=view_in2となる時の処理、遷移が行われます。
Inner 3 | アプリケーションID=sample、サービスID=originalとなる時の処理、遷移が行われます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | false | true | java.lang.String | HTMLにおけるAタグのid属性に相当します。
application | false | true | java.lang.String | アプリケーションIDを指定します。 この項目を省略した場合、所属するFormタグ、またはform属性で指定されたフォームのアプリケーションIDが使用されます。 この項目を指定する場合、application属性も指定する必要があります。
service | false | true | java.lang.String | サービスIDを指定します。 この項目を省略した場合、所属するFormタグ、またはform属性で指定されたフォームのサービスIDが使用されます。 この項目を省略する場合、application属性も省略する必要があります。
accesskey | false | true | java.lang.String | HTMLにおけるAタグのaccesskey属性に相当します。
coords | false | true | java.lang.String | HTMLにおけるAタグのcoords属性に相当します。
dir | false | true | java.lang.String | HTMLにおけるAタグのdir属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるAタグのlang属性に相当します。
class | false | true | java.lang.String | HTMLにおけるAタグのclass属性に相当します。
name | false | true | java.lang.String | HTMLにおけるAタグのname属性に相当します。
onblur | false | true | java.lang.String | HTMLにおけるAタグのonBlur属性に相当します。 注意：属性名はすべて小文字で記述してください。
onclick | false | true | java.lang.String | HTMLにおけるAタグのonClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
ondblclick | false | true | java.lang.String | HTMLにおけるAタグのonDblClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
onfocus | false | true | java.lang.String | HTMLにおけるAタグのonFocus属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeydown | false | true | java.lang.String | HTMLにおけるAタグのonKeyDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeypress | false | true | java.lang.String | HTMLにおけるAタグのonKeyPress属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeyup | false | true | java.lang.String | HTMLにおけるAタグのonKeyUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousedown | false | true | java.lang.String | HTMLにおけるAタグのonMouseDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousemove | false | true | java.lang.String | HTMLにおけるAタグのonMouseMove属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseout | false | true | java.lang.String | HTMLにおけるAタグのonMouseOut属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseover | false | true | java.lang.String | HTMLにおけるAタグのonMouseOver属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseup | false | true | java.lang.String | HTMLにおけるAタグのonMouseUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
shape | false | true | java.lang.String | HTMLにおけるAタグのshape属性に相当します。
style | false | true | java.lang.String | HTMLにおけるAタグのstyle属性に相当します。
tabindex | false | true | java.lang.String | HTMLにおけるAタグのtabindex属性に相当します。
title | false | true | java.lang.String | HTMLにおけるAタグのtitle属性に相当します。
form | false | true | java.lang.String | サブミットするFormタグのフォーム名です。 この属性を省略した場合、所属するFormタグをサブミットするリンクとして扱われます。 この属性を省略する場合、このタグはFormタグの中で指定される必要があります。

概要 ライブラリ タグ ヘルプ


 intra-mart J2EE フレームワーク タグライブラリ
タグ一覧
imart:Form
imart:Frame
imart:HelperBean
imart:Link
imart:Message
imart:MessageParam
imart:Param
imart:Submit
imart:SubmitLink


intra-mart J2EE フレームワーク タグライブラリ (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart J2EE フレームワーク タグライブラリ

標準構文:
     <%@ taglib prefix="imart" uri="http://www.intra-mart.co.jp/taglib/core/framework" %>
XML構文:
     <anyxmlelement xmlns:imart="http://www.intra-mart.co.jp/taglib/core/framework" />
intra-mart J2EE フレームワーク タグライブラリ。

intra-mart J2EE フレームワーク タグライブラリ 仕様

1. タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。

2. タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。

3. タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。

4. タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。

5. JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法
intra-mart J2EE フレームワーク タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/framework" prefix="imartj2ee" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/core/framework" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "imartj2ee" として説明します)

また下記のように、上記の taglib ディレクティブを XML の書式で記述すること も出来ます。

<jsp:directive.taglib uri="http://www.intra-mart.co.jp/taglib/core/framework" prefix="imartj2ee" />

サンプル
<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/framework" prefix="imartj2ee" %>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 //EN">
<HTML>

<HEAD>
<TITLE>Hello intra-mart J2EE framework.</TITLE>
</HEAD>

<BODY>

<CENTER><H2>
<imartj2ee:Form application="sample" service="view1" method="POST">
<INPUT type="text" name="column1" size="20"><BR>
<INPUT type="submit" value=" O K ">
</imartj2ee:Form>
</H2></CENTER>

</BODY>

</HTML>

タグライブラリ情報
表示名 | intra-mart J2EE フレームワーク タグライブラリ
Version | 1.0
Short Name | imart
URI | http://www.intra-mart.co.jp/taglib/core/framework

タグ 一覧
Form | HTMLのFORMタグに変換されます。
Frame | HTMLのFRAMEタグに変換されます。
HelperBean | HelperBeanを使用するための初期化を行います。
Link | HTMLのAタグに変換されます。
Message | 地域対応されたメッセージを表示します。
MessageParam | 地域対応されたメッセージに渡すパラメータを表示します。
Param | リンク先や遷移先にパラメータを引き渡すために利用します。
Submit | サブミットボタンを表示します。
SubmitLink | Formタグによって指定されたフォームをサブミットするリンクに変換されます。

概要 ライブラリ タグ ヘルプ


 すべてのタグおよび関数
imart:Form
imart:Frame
imart:HelperBean
imart:Link
imart:Message
imart:MessageParam
imart:Param
imart:Submit
imart:SubmitLink


概要 (Tag Library Documentation Generator - Generated Documentation)

タグライブラリ ドキュメント
すべてのタグおよび関数

タグライブラリ
intra-mart J2EE フレームワーク タグライブラリ


概要 (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

タグライブラリ ドキュメント

タグライブラリ
intra-mart J2EE フレームワーク タグライブラリ intra-mart J2EE フレームワーク タグライブラリ。

概要 ライブラリ タグ ヘルプ


calendar (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ calendar

カレンダーモジュールの画面ＨＴＭＬソースを作成します。

年月情報が正しくセットされなかった時の動作は未定義。

group にはデータカテゴリＩＤを指定（任意）。
無指定の場合は、ログイングループＩＤを自動的に選択する。
format 属性には、以下のキーワードのうちの１つを指定する。
standard | 標準形式
compact | 標準形式の簡易機能版
horizontal | 横１行形式
vertical | 縦１行形式
click_action 属性は必ず“正しく”指定する。
（指定が正しくない場合にはスクリプトエラーとなる。）
click_action 属性に指定されたＣＳＪＳ関数は、日リンクがキック
された時にコールされる。その時、引数が6つ渡される。

引数 | データ型 | 説明
第1引数 | Number | クリックされた年月日情報（1970/1/1からのミリ秒）
第2引数 | String | その日に設定されている名称
第3引数 | boolean | その日が休日かどうか
第4引数 | Number | クリックされた年情報
第5引数 | Number | クリックされた月情報
第6引数 | Number | クリックされた日情報

注意事項
フレームワークに標準で組み込まれている『振替休日』をチェックするプラグイン関数は、“前日に対して休日設定が２種類以上適合”した場合に“休日”と判定するようにプログラムされています。
振替休日にしたくない場合には、非休日設定などを利用して設定を工夫するようにして下さい。

フレームワークに標準で組み込まれている『春分の日』および『秋分の日』をチェックするプラグイン関数は、予測値を計算するためのものであり、実際の法律で制定された祝日と異なる結果を示す場合があります。
『春分の日』および『秋分の日』に関する正式な日付に関しては、国立天文台が公示する文書を参考に設定するようにして下さい。

また、『春分の日』および『秋分の日』をチェックするプラグインは 1900 年以降 2099 年まで有効であり、この期間に含まれない年においては、正しくチェックできません。
メンテナンス画面から『構築』ボタンを利用して設定した初期データは、『春分の日』に関しては 1960 年から 2058 年まで、『秋分の日』に関しては 1983 年から 2099 年まで有効なデータのみを登録しています。この期間以外の年を指定してカレンダー表示を行うと、『春分の日』または『秋分の日』を正しく表示できない場合があります。
サンプル:
２００２年９月のカレンダーを表示するＨＴＭＬ
<SCRIPT language="JavaScript">
function click_date(nDate, sName, bHoliday, nYear, nMonth, nDay) {
    // クリックされた日付情報をもつ DATE 変数作成
     var dClick = new Date(nDate);
     // 画面表示文字列変数
     var sStr = dClick.toString();
     // 画面表示文字列の作成
     sStr += "　[ " + sName + " ]";
     sStr += "　[ " + bHoliday + " ]";
     sStr += "　[ " + nYear + "/" + nMonth + "/" + nDay + " ]";
     // 画面に表示して引数の確認
     window.alert(sStr);
}
</SCRIPT>
<imtag:calendar year="2002" month="9" click_action="click_date"/>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
year | true | true | java.lang.String | 作成するカレンダーの年
month | true | true | java.lang.String | 作成するカレンダーの月(1 - 12)
group | true | true | java.lang.String | ログイングループID
calendarId | false | true | java.lang.String | カレンダーID 省略した場合はデフォルトのカレンダID(ログイングループID)となります。
format | false | true | java.lang.String | 使用するフォーマットファイルの指定
click_action | false | true | java.lang.String | 日リンクのクリック時に実行する関数名

概要 ライブラリ タグ ヘルプ


condition (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ condition

タグに挟まれた部分の実行の条件分岐を行います。

タグに挟まれた範囲内の部分の実行を制御します。
属性 validity に対して true 値を指定した場合は内部の処理を実行し、 false 値を指定した場合は内部の処理を無視します。
属性 negative を指定した場合、 属性 validity に対して指定した値を 逆解釈して処理します。

サンプル:
<imtag:condition validity="<%= flg%>">
真値
</imtag:condition>
<imtag:condition validity="<%= flg%>" negative="true" >
偽値
</imtag:condition>
JSPで変数 flg にセットされた真偽値により表示文字を動的選択します。
変数 flg の値が true であった場合は「真値」と表示され、false であった 場合には「偽値」と表示されます。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
validity | true | true | boolean | 有効・無効フラグ
negative | false | true | boolean | 条件反転判定フラグ(指定した場合はtrue,指定しなかった場合はfalse)

概要 ライブラリ タグ ヘルプ


Cal_view (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Cal_view

奨励されていません。calendar タグに置き換えられました。

カレンダーモジュールの画面ＨＴＭＬソースを作成します。

年月情報が正しくセットされなかった時の動作は未定義。

group にはデータカテゴリＩＤを指定（任意）。
無指定の場合は、ログイングループＩＤを自動的に選択する。
format 属性には、以下のキーワードのうちの１つを指定する。
standard | 標準形式
compact | 標準形式の簡易機能版
horizontal | 横１行形式
vertical | 縦１行形式
click_action 属性は必ず“正しく”指定する。
（指定が正しくない場合にはスクリプトエラーとなる。）
click_action 属性に指定されたＣＳＪＳ関数は、日リンクがキック
された時にコールされる。その時、引数が6つ渡される。

引数 | データ型 | 説明
第1引数 | Number | クリックされた年月日情報（1970/1/1からのミリ秒）
第2引数 | String | その日に設定されている名称
第3引数 | boolean | その日が休日かどうか
第4引数 | Number | クリックされた年情報
第5引数 | Number | クリックされた月情報
第6引数 | Number | クリックされた日情報

注意事項
フレームワークに標準で組み込まれている『振替休日』をチェックするプラグイン関数は、“前日に対して休日設定が２種類以上適合”した場合に“休日”と判定するようにプログラムされています。
振替休日にしたくない場合には、非休日設定などを利用して設定を工夫するようにして下さい。

フレームワークに標準で組み込まれている『春分の日』および『秋分の日』をチェックするプラグイン関数は、予測値を計算するためのものであり、実際の法律で制定された祝日と異なる結果を示す場合があります。
『春分の日』および『秋分の日』に関する正式な日付に関しては、国立天文台が公示する文書を参考に設定するようにして下さい。

また、『春分の日』および『秋分の日』をチェックするプラグインは 1900 年以降 2099 年まで有効であり、この期間に含まれない年においては、正しくチェックできません。
メンテナンス画面から『構築』ボタンを利用して設定した初期データは、『春分の日』に関しては 1960 年から 2058 年まで、『秋分の日』に関しては 1983 年から 2099 年まで有効なデータのみを登録しています。この期間以外の年を指定してカレンダー表示を行うと、『春分の日』または『秋分の日』を正しく表示できない場合があります。
サンプル:
２００２年９月のカレンダーを表示するＨＴＭＬ
<SCRIPT language="JavaScript">
function click_date(nDate, sName, bHoliday, nYear, nMonth, nDay) {
    // クリックされた日付情報をもつ DATE 変数作成
     var dClick = new Date(nDate);
     // 画面表示文字列変数
     var sStr = dClick.toString();
     // 画面表示文字列の作成
     sStr += "　[ " + sName + " ]";
     sStr += "　[ " + bHoliday + " ]";
     sStr += "　[ " + nYear + "/" + nMonth + "/" + nDay + " ]";
     // 画面に表示して引数の確認
     window.alert(sStr);
}
</SCRIPT>
<imtag:Cal_view year="2002" month="9" click_action="click_date"/>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
year | true | true | java.lang.String | 作成するカレンダーの年
month | true | true | java.lang.String | 作成するカレンダーの月(1 - 12)
group | true | true | java.lang.String | ログイングループID
calendarId | false | true | java.lang.String | カレンダーID 省略した場合はデフォルトのカレンダID(ログイングループID)となります。
format | false | true | java.lang.String | 使用するフォーマットファイルの指定
click_action | false | true | java.lang.String | 日リンクのクリック時に実行する関数名
weekCaption | false | false | java.lang.String | 曜日のキャプション（文字列の配列） 日曜 - 土曜までのキャプションを配列で指定します。 未指定の場合は、デフォルト値{"S","M","T","W","T","F","S"} になります。

概要 ライブラリ タグ ヘルプ


Condition (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Condition

奨励されていません。condition タグに置き換えられました。

タグに挟まれた部分の実行の条件分岐を行います。

タグに挟まれた範囲内の部分の実行を制御します。
属性 validity に対して true 値を指定した場合は内部の処理を実行し、 false 値を指定した場合は内部の処理を無視します。
属性 negative を指定した場合、 属性 validity に対して指定した値を 逆解釈して処理します。

サンプル:
<imtag:Condition validity="<%= flg%>">
真値
</imtag:Condition>
<imtag:Condition validity="<%= flg%>" negative="true" >
偽値
</imtag:Condition>
JSPで変数 flg にセットされた真偽値により表示文字を動的選択します。
変数 flg の値が true であった場合は「真値」と表示され、false であった 場合には「偽値」と表示されます。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
validity | true | true | boolean | 有効・無効フラグ
negative | false | true | boolean | 条件反転判定フラグ(指定した場合はtrue,指定しなかった場合はfalse)

概要 ライブラリ タグ ヘルプ


decision (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ decision

タグに挟まれた部分の実行の条件分岐をおこないます。

タグに挟まれた範囲内の部分の実行を制御します。
属性 value に与えられた値が、属性 case に与えられた値に等しい場合 のみタグに挟まれた範囲内の実行を行います。
サンプル:
<imtag:decision case="OK" value="<%= check%>">
該当
</imtag:decision>
JSPから変数 value により渡された値が case 属性に指定された値(この場合は "OK" という文字列)と等しい場合 該当という文字が表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
case | true | true | java.lang.Boolean | チェック値
value | true | true | java.lang.String | チェック対象の値

概要 ライブラリ タグ ヘルプ


drawer (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ drawer

画像ファイルを作成しHTMLに表示します。

属性 data にjp.co.intra_mart.foundation.drawer.AbstractDrawer を スーパークラスとしたインスタンスを渡すことにより 任意の画像ファイルをHTMLに表示します。

AbstractDrawerの既知のサブクラスとして、以下の５種類のグラフ描画クラスが用意されています。
jp.co.intra_mart.foundation.graph.BarGraphDrawer - 棒グラフ
jp.co.intra_mart.foundation.graph.CircleGraphDrawer - 円グラフ
jp.co.intra_mart.foundation.graph.LineGraphDrawer - 折れ線グラフ
jp.co.intra_mart.foundation.graph.PortFolioDrawer - ポートフォリオ
jp.co.intra_mart.foundation.graph.RadarChartDrawer - レーダーチャート

サンプル:
<%
BarGraphDrawer drawerBar = new BarGraphDrawer(0, 60, 10);
drawerBar.setWidth(300);
drawerBar.setHeight(300);
drawerBar.setCaption(new String[]{"１月", "２月", "３月"});

BarGraphObject objBar = new BarGraphObject(Color.black);
objBar.addData(50);
objBar.addData(10);
objBar.addData(30);
drawerBar.addData(objBar);
%>
<HTML>
<BODY>
<imtag:drawer data="<%= drawerBar %>" />
</BODY>
</HTML>
属性 data にBarGraphDrawerインスタンスを与え、棒グラフの画像ファイルを表示します。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
data | true | true | java.lang.String | チェック対象の値 (jp.co.intra_mart.foundation.drawer.AbstractDrawerの実装クラス)

概要 ライブラリ タグ ヘルプ


Decision (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Decision

奨励されていません。decision タグに置き換えられました。

タグに挟まれた部分の実行の条件分岐をおこないます。

タグに挟まれた範囲内の部分の実行を制御します。
属性 value に与えられた値が、属性 case に与えられた値に等しい場合 のみタグに挟まれた範囲内の実行を行います。
サンプル:
<imtag:Decision case="OK" value="<%= check%>">
該当
</imtag:Decision>
JSPから変数 value により渡された値が case 属性に指定された値(この場合は "OK" という文字列)と等しい場合 該当という文字が表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
case | true | true | java.lang.Boolean | チェック値
value | true | true | java.lang.String | チェック対象の値

概要 ライブラリ タグ ヘルプ


Drawer (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Drawer

奨励されていません。drawer タグに置き換えられました。

画像ファイルを作成しHTMLに表示します。

属性 data にjp.co.intra_mart.foundation.drawer.AbstractDrawer を スーパークラスとしたインスタンスを渡すことにより 任意の画像ファイルをHTMLに表示します。

AbstractDrawerの既知のサブクラスとして、以下の５種類のグラフ描画クラスが用意されています。
jp.co.intra_mart.foundation.graph.BarGraphDrawer - 棒グラフ
jp.co.intra_mart.foundation.graph.CircleGraphDrawer - 円グラフ
jp.co.intra_mart.foundation.graph.LineGraphDrawer - 折れ線グラフ
jp.co.intra_mart.foundation.graph.PortFolioDrawer - ポートフォリオ
jp.co.intra_mart.foundation.graph.RadarChartDrawer - レーダーチャート

サンプル:
<%
BarGraphDrawer drawerBar = new BarGraphDrawer(0, 60, 10);
drawerBar.setWidth(300);
drawerBar.setHeight(300);
drawerBar.setCaption(new String[]{"１月", "２月", "３月"});

BarGraphObject objBar = new BarGraphObject(Color.black);
objBar.addData(50);
objBar.addData(10);
objBar.addData(30);
drawerBar.addData(objBar);
%>
<HTML>
<BODY>
<imtag:Drawer data="<%= drawerBar %>" />
</BODY>
</HTML>
属性 data にBarGraphDrawerインスタンスを与え、棒グラフの画像ファイルを表示します。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
data | true | true | java.lang.String | チェック対象の値 (jp.co.intra_mart.foundation.drawer.AbstractDrawerの実装クラス)

概要 ライブラリ タグ ヘルプ


floatingCalendar (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ floatingCalendar

ドラッグ＆ドロップで移動可能なカレンダーをフレーム上に表示します

表示されたカレンダーの日付をクリックすると、 引数「element」で指定された要素に、選択された日付の文字列を反映します。 （日付文字列の形式は、引数「format」で指定可能です。）
カレンダーは、「カレンダー表示基準年月」を元に表示します。
（カレンダー表示基準年月は、引数「year」「month」を元に算出されます）

引数「year」および「month」が正しい年月に変換できない場合（未指定時含む）、 カレンダー表示基準年月はシステム日付の「年月」となります。
引数「year」が2桁の場合、「00から49」は 2000年代、「50から99」は 1900年代として処理されます。
引数「year」および「month」にて生成される年月は、1582年10月以降である必要があります。（1582年10月以前の動作は未定義）

引数「addMonth」が未設定の場合、「カレンダー表示基準年月」のカレンダーを表示します。
引数「addMonth」が設定された場合、「カレンダー表示基準年月 + (addMonth)ヶ月」のカレンダーを表示します。

[リロード]ボタン押下時、システム日付の「年月」のカレンダーを表示します。
ただし、引数「element」で指定された要素の値が、日付フォーマット形式に合致している場合、 その要素の値から算出される年月のカレンダーを表示します。

注意事項：
HTMLファイルの <HEAD> タグ内に、必ずデザインスタイルシートタグ（imDesignCss タグ）
および、< SCRIPT src=" < %web_path% > /csjs/im_floating_calendar.js" > を記述してください。
（ < %web_path% > はWeb Server Connectorをインストールしたディレクトリ）

なお、 < %web_path% > /csjs/im_floating_calendar.jsは、URLの関係で呼び出し時のソースパスは変わります。
ページベース開発モデルの場合は、csjs/im_floating_calendar.js でリンクできます。

引数「position」に「event」を指定し、マウスクリック以外でカレンダーを表示すると、 IEの場合、マウスポインタがフレームから外れていると、カレンダーはフレームの外に表示されます。 NNの場合、フレームの左上（「left：0, top：0」）にカレンダーが表示されます。
サンプル:
●今月のカレンダーを表示するJSP
  ・テキストフィールド「document.floatingCalendarForm.date」にカレンダーで選択した日付を反映します。

<%@ taglib prefix="imtag" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<%@ taglib prefix="imdesign"   uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
<HTML>
  <HEAD>
    <imdesign:imartDesignCss />
    <SCRIPT src="csjs/im_floating_calendar.js"></SCRIPT>
  </HEAD>
  <BODY>
    <FORM name="floatingCalendarForm">
      <INPUT name="date" type="text" size="20" class="default">

      <!-- カレンダー（フローティング形式）を表示 -->
      <imtag:floatingCalendar element="document.floatingCalendarForm.date">
          <IMG src="sample.gif" border="0" alt="カレンダー用の画像">
      </imtag:floatingCalendar>
    </FORM>
  </BODY>
</HTML>

●以下の条件を満たしたカレンダーを表示するJSP
  ・2006年10月（＝2006年8月の2ヵ月後）のカレンダーを表示
  ・フレーム左上から、右に100px、下に200pxの位置にカレンダーを表示
  ・日付選択時に反映される文字列のフォーマットが「yyyy/MM/dd (E)」形式
  ・カレンダーID「sample」のカレンダーデータを表示
  ・表示カレンダーのキャプションを「日,月,火,水,木,金,土」で表示
  ・カレンダーの日付をクリックした際にJavascript関数「sampleCallBack」を呼び出す

<%@ taglib prefix="imtag" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<%@ taglib prefix="imdesign"   uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
<HTML>
  <HEAD>
    <imdesign:imartDesignCss />
    <SCRIPT src="csjs/im_floating_calendar.js"></SCRIPT>
    <SCRIPT type="text/javascript">
        function sampleCallBack(element, value){

            alert("sampleCallBack");
            alert("element.value = " + element.value);
            alert("value = " + value);

            element.value = value;
        }
    </SCRIPT>
  </HEAD>
  <BODY>
    <FORM name="floatingCalendarForm">
      <INPUT name="date" type="text" size="20" class="default">

      <!-- カレンダー（フローティング形式）を表示 -->
      <imtag:floatingCalendar
             element="document.floatingCalendarForm.date"
             year         = "2006"
             month        = "8"
             addMonth     = "2"
             position     = "100,200"
             format       = "yyyy/MM/dd (E)"
             calendarId   = "sample"
             weekCaptions = "日,月,火,水,木,金,土"
             callback     = "sampleCallBack">
          <IMG src="sample.gif" border="0" alt="カレンダー用の画像">
      </imtag:floatingCalendar>
    </FORM>
  </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
element | true | true | java.lang.String | 選択した日付の文字列表現を反映する要素
year | false | true | java.lang.String | カレンダー表示基準年（デフォルトは システム日付の「年」)
month | false | true | java.lang.String | カレンダー表示基準月 [1-12]（デフォルトは システム日付の「月」)
addMonth | false | true | java.lang.String | カレンダー表示基準年月からの移動量 [月単位で数値指定]（デフォルトは「0」）
calendarId false true java.lang.String カレンダーID（デフォルトは「ログイングループのデフォルトカレンダーID」）
指定されたカレンダーIDが存在しない場合は、デフォルトカレンダーIDのカレンダーを表示します。
position false true java.lang.String カレンダー表示位置 [event | 'left,top']（デフォルトは「event」)
event | マウスカーソルのそばに表示
'left,top' | 指定位置に表示(ピクセル指定)
format false true java.lang.String 日付フォーマット（デフォルトは「yyyy/MM/dd」）
フォーマット指定文字（Format.fromDate()のフォーマット指定文字に準拠）
y | 年
M | 月
d | 日
E | 曜日
weekCaptions false true java.lang.String カレンダーに表示する曜日のキャプション。（デフォルトは、"Su,Mo,Tu,We,Th,Fr,Sa"）
カンマ区切りでキャプションを7つ指定します。（例."日,月,火,水,木,金,土"）
キャプション数が7つではない場合、デフォルト値を表示します。
callback false true java.lang.String カレンダーの日付をクリックした際に呼び出されるJavascript関数名。（デフォルトは、"callBackFloatingCalendar"）
指定された関数には、「引数「element」で指定された要素」、「選択された日付の文字列」が引数として渡されます。 （サンプルコード参照）
isUseElementMonth false true java.lang.String trueが指定された場合、elementで指定された要素の値をカレンダー表示基準年月とします。
（ただし、elementで指定された要素の値が日付フォーマット形式でない場合、falseが指定されたことになります）
falseが指定された場合、引数「year」および「month」を元にカレンダー表示基準年月を算出します。
（デフォルトは「true」）

概要 ライブラリ タグ ヘルプ


imartDateFormat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ imartDateFormat

タグの指定された場所に、指定された日付データを文字列として挿入します。

実際には、タグ部分が指定文字列で置換されるように動作します。
フォーマット文字列は yyyy/MM/dd のように指定して下さい。
format 属性指定時の仕様に関しては、Java 2 API ドキュメント の SimpleDateFormat クラスに準拠します。
サンプル:
<imtag:imartDateFormat value="<%=new Date()%>" format="yyyy/MM/dd"/>
このタグの位置に「2002/08/30」という形式で今日の日付情報を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.util.Date | 挿入する日付データ
format | true | true | java.lang.String | 表現フォーマット指定文字列

概要 ライブラリ タグ ヘルプ


imartEvent (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ imartEvent

ページに対して、ブラウザ上で動作するイベント処理型ロジックを追加します。

このタグは、Client Side Java Script を利用して実現されています。
また、値のブリッジには、ブラウザのクッキーを利用しています。 (クッキーを利用しているので別ウィンドウ同士の通信にも利用できます。)
そのため、クッキーの容量制限を越える量の値をやり取り(監視や受取)は できません。また、このタグではクッキーを保存する際、クッキーの path 属性を 「/」として値を保存しています。セキュリティ的に問題と なる場合には、この機能を利用しないで下さい。

属性 name には、動作する際のイベント名称(キーコード)を指定します。 この name 属性に指定したコードが等しい <imtag:Event>タグ 同士が連携して動作します。
属性 focus には、監視対象となる Client Side Java Script の変数名称を 文字列として指定して下さい。 focus 属性で指定された変数の内容が送信される事になります。
属性 receive には、監視対象値を受け取るための Client Side Java Script の変数名称を文字列として指定して下さい。 ここで指定した変数によって focus で監視している変数の値を受信する事が できます。
属性 init には、動作前にクッキーを初期化する必要がある場合、 その初期値を文字列として指定する事ができます。
属性 onChange には、focus 属性で指定された変数内の値が変化した際に 実行される Client Side Java Script のソースコードを文字列として指定します。
属性 time には、監視のタイミングをミリ秒で指定します。 focus 属性で指定された変数やクッキー内の情報は、タイマー機能を利用して 一定時間毎の監視を行っています。 デフォルトでは 250 ミリ秒毎に監視していますが、連動のタイミングをより リアルタイムにしたい場合は、この値を小さく設定し、ブラウザ処理の負荷が 高く動作が重い場合には、この値を大きく設定する事で任意に調整して下さい。
サンプル:
<FORM name="form_a">
<INPUT type="text" name="a_text">
</FORM>
<imtag:imartEvent name="text_copy" focus="document.form_a.a_text.value"/>
<FORM name="form_b">
<INPUT type="text" name="b_text">
</FORM>
<imtag:imartEvent name="text_copy" receive="document.form_b.b_text.value"/>
画面には二つのテキストフィールドが表示されます。
上のテキストフィールドに文字を記入すると、下のテキストフィールド内に
上のテキストフィールドに入力した内容と同じものが表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | カテゴリ名称
focus | false | true | java.lang.String | 監視対象ＣＳＪＳ変数名称
receive | false | true | java.lang.String | 監視変数内データの受け入れＣＳＪＳ変数名称
init | false | true | java.lang.String | クッキー内初期値
onChange | false | true | java.lang.String | データ変更時の実行スクリプト
time | false | true | java.lang.String | クッキー監視間隔時間（ミリ秒）

概要 ライブラリ タグ ヘルプ


imartNumberFormat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ imartNumberFormat

タグの指定されている個所に指定の数値データを文字列として挿入します。

実際には、タグ部分が指定文字列で置換されるように動作します。
フォーマット文字列は ###,### のように指定して下さい。
format 属性指定時の仕様に関しては、Java 2 API ドキュメント の DecimalFormat クラスに準拠します。
サンプル:
<imtag:imartNumberFormat value="<%=new Integer(12345)%>" format="###,###"/>
このタグの位置に「12,345」という形式で数値情報を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.lang.String | 挿入する数値データ
format | true | true | java.lang.String | 表現フォーマット指定文字列

概要 ライブラリ タグ ヘルプ


ImartDateFormat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ ImartDateFormat

奨励されていません。imartDateFormat タグに置き換えられました。

タグの指定された場所に、指定された日付データを文字列として挿入します。

実際には、タグ部分が指定文字列で置換されるように動作します。
フォーマット文字列は yyyy/MM/dd のように指定して下さい。
format 属性指定時の仕様に関しては、Java 2 API ドキュメント の SimpleDateFormat クラスに準拠します。
サンプル:
<imtag:ImartDateFormat value="<%=new Date()%>" format="yyyy/MM/dd"/>
このタグの位置に「2002/08/30」という形式で今日の日付情報を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.util.Date | 挿入する日付データ
format | true | true | java.lang.String | 表現フォーマット指定文字列

概要 ライブラリ タグ ヘルプ


ImartEvent (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ ImartEvent

奨励されていません。imartEvent タグに置き換えられました。

ページに対して、ブラウザ上で動作するイベント処理型ロジックを追加します。

このタグは、Client Side Java Script を利用して実現されています。
また、値のブリッジには、ブラウザのクッキーを利用しています。 (クッキーを利用しているので別ウィンドウ同士の通信にも利用できます。)
そのため、クッキーの容量制限を越える量の値をやり取り(監視や受取)は できません。また、このタグではクッキーを保存する際、クッキーの path 属性を 「/」として値を保存しています。セキュリティ的に問題と なる場合には、この機能を利用しないで下さい。

属性 name には、動作する際のイベント名称(キーコード)を指定します。 この name 属性に指定したコードが等しい <imtag:Event>タグ 同士が連携して動作します。
属性 focus には、監視対象となる Client Side Java Script の変数名称を 文字列として指定して下さい。 focus 属性で指定された変数の内容が送信される事になります。
属性 receive には、監視対象値を受け取るための Client Side Java Script の変数名称を文字列として指定して下さい。 ここで指定した変数によって focus で監視している変数の値を受信する事が できます。
属性 init には、動作前にクッキーを初期化する必要がある場合、 その初期値を文字列として指定する事ができます。
属性 onChange には、focus 属性で指定された変数内の値が変化した際に 実行される Client Side Java Script のソースコードを文字列として指定します。
属性 time には、監視のタイミングをミリ秒で指定します。 focus 属性で指定された変数やクッキー内の情報は、タイマー機能を利用して 一定時間毎の監視を行っています。 デフォルトでは 250 ミリ秒毎に監視していますが、連動のタイミングをより リアルタイムにしたい場合は、この値を小さく設定し、ブラウザ処理の負荷が 高く動作が重い場合には、この値を大きく設定する事で任意に調整して下さい。
サンプル:
<FORM name="form_a">
<INPUT type="text" name="a_text">
</FORM>
<imtag:ImartEvent name="text_copy" focus="document.form_a.a_text.value"/>
<FORM name="form_b">
<INPUT type="text" name="b_text">
</FORM>
<imtag:ImartEvent name="text_copy" receive="document.form_b.b_text.value"/>
画面には二つのテキストフィールドが表示されます。
上のテキストフィールドに文字を記入すると、下のテキストフィールド内に
上のテキストフィールドに入力した内容と同じものが表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | カテゴリ名称
focus | false | true | java.lang.String | 監視対象ＣＳＪＳ変数名称
receive | false | true | java.lang.String | 監視変数内データの受け入れＣＳＪＳ変数名称
init | false | true | java.lang.String | クッキー内初期値
onChange | false | true | java.lang.String | データ変更時の実行スクリプト
time | false | true | java.lang.String | クッキー監視間隔時間（ミリ秒）

概要 ライブラリ タグ ヘルプ


ImartNumberFormat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ ImartNumberFormat

奨励されていません。imartNumberFormat タグに置き換えられました。

タグの指定されている個所に指定の数値データを文字列として挿入します。

実際には、タグ部分が指定文字列で置換されるように動作します。
フォーマット文字列は ###,### のように指定して下さい。
format 属性指定時の仕様に関しては、Java 2 API ドキュメント の DecimalFormat クラスに準拠します。
サンプル:
<imtag:ImartNumberFormat value="<%=new Integer(12345)%>" format="###,###"/>
このタグの位置に「12,345」という形式で数値情報を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.lang.String | 挿入する数値データ
format | true | true | java.lang.String | 表現フォーマット指定文字列

概要 ライブラリ タグ ヘルプ


loop (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ loop

タグに挟まれている範囲内のソースを繰り返し処理します。

繰り返し処理は、属性 count に指定されている回数だけ行います。
(属性 count に、整数字列以外の指定がされた場合の動作は保証外。)
属性 index に、ファンクション・コンテナ内で定義してある変数名称を 指定する事で、何回目の繰り返しかを表す数値を受け取る事が出来ます。
(周回数は、0 から始まる整数値で、周回ごとに 1 ずつインクリメントされます。)
また、属性 index は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
サンプル:
<imtag:loop count="5" index="loop_number">
<%=loop_number %> 回目
</imtag:loop>
画面には、以下のように出力されます。
0 回目
1 回目
2 回目
3 回目
4 回目
この場合は、必ず５回の繰り返し処理が行われます。
繰り返し毎に、属性 index で指定したスクリプティング変数に対して、繰り返し回数 - 1 の値が設定されます。
上記例では、タグの内部で参照されている loop_number というスクリプティング変数を通して、動的に回数を表示しています。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
count | true | true | java.lang.String | 繰り返し回数
index | false | true | java.lang.String | 周回番号の通知先変数名
min | false | true | java.lang.String | 繰り返し処理対象の最小要素番号
max | false | true | java.lang.String | 繰り返し処理対象の最大要素番号
mode | false | true | java.lang.String | ループの方向 大きい要素から小さい要素にループさせる場合は、"down"を設定

概要 ライブラリ タグ ヘルプ


Loop (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Loop

奨励されていません。loop タグに置き換えられました。

タグに挟まれている範囲内のソースを繰り返し処理します。

繰り返し処理は、属性 count に指定されている回数だけ行います。
(属性 count に、整数字列以外の指定がされた場合の動作は保証外。)
属性 index に、ファンクション・コンテナ内で定義してある変数名称を 指定する事で、何回目の繰り返しかを表す数値を受け取る事が出来ます。
(周回数は、0 から始まる整数値で、周回ごとに 1 ずつインクリメントされます。)
また、属性 index は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
サンプル:
<imtag:Loop count="5" index="loop_number">
<%=loop_number %> 回目
</imtag:Loop>
画面には、以下のように出力されます。
0 回目
1 回目
2 回目
3 回目
4 回目
この場合は、必ず５回の繰り返し処理が行われます。
繰り返し毎に、属性 index で指定したスクリプティング変数に対して、繰り返し回数 - 1 の値が設定されます。
上記例では、タグの内部で参照されている loop_number というスクリプティング変数を通して、動的に回数を表示しています。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
count | true | true | java.lang.String | 繰り返し回数
index | false | true | java.lang.String | 周回番号の通知先変数名
min | false | true | java.lang.String | 繰り返し処理対象の最小要素番号
max | false | true | java.lang.String | 繰り返し処理対象の最大要素番号
mode | false | true | java.lang.String | ループの方向 大きい要素から小さい要素にループさせる場合は、"down"を設定

概要 ライブラリ タグ ヘルプ


repeat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ repeat

タグに挟まれた範囲内（ネスト部分）を指定の回数だけ繰り返し処理します。

属性 list に指定されたリストに対して、そのリスト内の要素数に 等しい回数だけ繰り返し処理を実行します。
属性 list の各要素は java.util.Mapインターフェースを実装したクラスである必要があります。
属性 item に指定された変数名に該当するスクリプティング変数に対して、 繰り返し毎にlist から順次取得したデータを代入します。
その際、スクリプティング変数はjava.lang.Object型で入ってくるので、 リストに挿入した型にキャストして使用してください。
また、属性 item は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
属性 index に指定された変数名に該当する変数に対して、繰り返し毎に list から順次取得した要素番号(int)を代入します。
また、属性 index は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
属性 min に動作開始インデックスを指定した場合、それ以前に取得できた値は 無視されて、指定インデックス以降のデータのみを繰り返し処理の対象とします。
属性 min を未指定にした場合のデフォルト動作は、0 を指定した場合と同様です。
属性 max に動作終了インデックスを指定した場合、それ以後に取得できた値は 無視されて、指定インデックスより前のデータのみを繰り返し処理の対象とします。
属性 max を未指定にした場合のデフォルト動作は、list に渡されたオブジェクト 内に格納されているデータのうち、順次取得可能な最終データまでが処理対象となります。
サンプル:
<imtag:repeat list="<%= list%>" item="record" index="idx"> <%= idx%>
<%= ((Map)record).get("content")%>
</imtag:repeat>
JSPのページで変数 list に挿入されたインスタンスの中身を表示します。
画面上では要素番号とMapインターフェースを実装したクラスの"content"の値がリストの要素数に等しい行数分、表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List | 繰り返し処理をする配列 配列内の各要素は java.util.Map インターフェースの実装クラス
item | false | true | java.lang.String | 繰り返し処理中の配列内該当要素取得変数名
index | false | true | java.lang.String | 繰り返し処理中の配列要素番号取得変数名
min | false | true | java.lang.String | 繰り返し処理対象の最小要素番号
max | false | true | java.lang.String | 繰り返し処理対象の最大要素番号

概要 ライブラリ タグ ヘルプ


Repeat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Repeat

奨励されていません。repeat タグに置き換えられました。

タグに挟まれた範囲内（ネスト部分）を指定の回数だけ繰り返し処理します。

属性 list に指定されたリストに対して、そのリスト内の要素数に 等しい回数だけ繰り返し処理を実行します。
属性 list の各要素は java.util.Mapインターフェースを実装したクラスである必要があります。
属性 item に指定された変数名に該当するスクリプティング変数に対して、 繰り返し毎にlist から順次取得したデータを代入します。
その際、スクリプティング変数はjava.lang.Object型で入ってくるので、 リストに挿入した型にキャストして使用してください。
また、属性 item は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
属性 index に指定された変数名に該当する変数に対して、繰り返し毎に list から順次取得した要素番号(int)を代入します。
また、属性 index は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
属性 min に動作開始インデックスを指定した場合、それ以前に取得できた値は 無視されて、指定インデックス以降のデータのみを繰り返し処理の対象とします。
属性 min を未指定にした場合のデフォルト動作は、0 を指定した場合と同様です。
属性 max に動作終了インデックスを指定した場合、それ以後に取得できた値は 無視されて、指定インデックスより前のデータのみを繰り返し処理の対象とします。
属性 max を未指定にした場合のデフォルト動作は、list に渡されたオブジェクト 内に格納されているデータのうち、順次取得可能な最終データまでが処理対象となります。
サンプル:
<imtag:Repeat list="<%= list%>" item="record" index="idx"> <%= idx%>
<%= (Map)record.get("content")%>
<imtag:Repeat>
JSPのページで変数 list に挿入されたインスタンスの中身を表示します。
画面上では要素番号とMapインターフェースを実装したクラスの"content"の値がリストの要素数に等しい行数分、表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List | 繰り返し処理をする配列 配列内の各要素は java.util.Map インターフェースの実装クラス
item | false | true | java.lang.String | 繰り返し処理中の配列内該当要素取得変数名
index | false | true | java.lang.String | 繰り返し処理中の配列要素番号取得変数名
min | false | true | java.lang.String | 繰り返し処理対象の最小要素番号
max | false | true | java.lang.String | 繰り返し処理対象の最大要素番号

概要 ライブラリ タグ ヘルプ


select (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ select

フォーム内にコンボボックス（またはリストボックス）を表示します。

属性 list に対しては、Listインターフェースを実装したクラスのインスタンスにMapインターフェースを実装したクラスのインスタンスを 格納して指定して下さい。
属性 list に指定したインスタンスに格納されているすべてのMapインターフェースを実装したクラスのインスタンス の値が、コンボボックス内の表示要素になります。
属性 list に指定されたインスタンスに格納されているMapインターフェースを実装したクラスのoption_value属性で指定された キー名に格納されている値が、コンボボックス内の各要素(<OPTION> タグ)のvalue 値になり、option_text属性で指定されたキー名に格納されている値がコンボボックス内の要素の 画面上での表示名になります。属性 option_valueのデフォルト値は「option_value」、 属性 option_textのデフォルト値は「option_text」です。 (Mapインターフェースを実装したクラスのインスタンスに格納されているキーおよび値が String 以外の場合の動作は保証外。)
属性 selected には、コンボボックスの初期選択(初期表示)値を指定します。 初期選択状態にする値のキー(属性 list に指定したMapインターフェースを実装したクラスのインスタンスの該当する キー名称)と一致する文字列を含むListインターフェースを実装したクラスのインスタンスを指定することで、初期選択状態にする ことができます。
属性 selected に指定した値に該当するキーが属性 list に指定したMapインターフェースを実装したクラスのインスタンス のキー名称として存在しない場合は、どの値も選択状態にはなりません。 (ただし、コンボボックスの初期選択指定が存在しない場合は、ブラウザの仕様で 自動的にコンボボックス内の先頭の要素が初期選択状態として表示されます。) また、初期選択状態とするキーを同時に複数個指定する場合は、属性 selected に 対して複数のキー文字列を含むListインターフェースを実装したクラスのインスタンスを指定する事で可能になります。 その際、配列内の各要素の値として、初期選択状態にするキー(属性 list に格納した Mapインターフェースを実装したクラスのインスタンスのキー名称)を格納してください。
属性 blank は、コンボボックス内の任意の位置に空データを表示させるための 属性指定になります。
値としてキーワード "top" を指定するとボックス内の先頭位置に空データが表示 され、キーワード "bottom" を指定するとボックス内の最後尾位置に空データが 表示されます。
属性 name に指定した値は <SELECT> タグの name 属性に出力されます。
属性 size に指定した値は <SELECT> タグの size 属性に出力されます。
属性 multipleをしてした場合は、 <SELECT> タグに multiple 属性が付加されます。
属性 attr に指定した値は、指定された文字列のまま <SELECT> タグの属性として 出力されます。(<SELECT> タグの仕様に関しては市販のＨＴＭＬリファレンスを 参照して下さい)。

サンプル:
<%
Vector list = new Vector();
Hashtable ht1 = new Hashtable();
Hashtable ht2 = new Hashtable();

ht1.put("value","test");
ht1.put("text","テスト");
ht2.put("value","test");
ht2.put("text","テスト");

list.add(ht1);
list.add(ht2);
%>

<FORM>
<imtag:select list="<%= list%>" option_value="value" option_text="text" name="test1"/>
<imtag:select list="<%= list%>"
option_value="value" option_text="text"
size="4" name="test2"/>
</FORM>
画面には、コンボボックスとリストボックスが表示されます。
ボックス内には、変数 list に格納されているMapインターフェースを実装したHashtableクラスのインスタンス内のデータが表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List | 表示リスト
name | false | true | java.lang.String | <SELECT>タグのname属性
size | false | true | java.lang.String | <SELECT>タグのsize属性
selected | false | true | java.util.List | 初期選択値の設定
blank | false | true | java.lang.String | キーワードの示す位置へブランクデータを挿入
attr | false | true | java.lang.String | <SELECT>タグ内に指定するその他の属性値
multiple | false | true | java.lang.String | <SELECT>タグのmultiple属性(指定した場合は複数選択可)
option_value | false | true | java.lang.String | <option>タグのvalue値に対応するキー名
option_text | false | true | java.lang.String | <option>タグのtext値に対応するキー名

概要 ライブラリ タグ ヘルプ


Select (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Select

奨励されていません。select タグに置き換えられました。

フォーム内にコンボボックス（またはリストボックス）を表示します。

属性 list に対しては、Listインターフェースを実装したクラスのインスタンスにMapインターフェースを実装したクラスのインスタンスを 格納して指定して下さい。
属性 list に指定したインスタンスに格納されているすべてのMapインターフェースを実装したクラスのインスタンス の値が、コンボボックス内の表示要素になります。
属性 list に指定されたインスタンスに格納されているMapインターフェースを実装したクラスのoption_value属性で指定された キー名に格納されている値が、コンボボックス内の各要素(<OPTION> タグ)のvalue 値になり、option_text属性で指定されたキー名に格納されている値がコンボボックス内の要素の 画面上での表示名になります。属性 option_valueのデフォルト値は「option_value」、 属性 option_textのデフォルト値は「option_text」です。 (Mapインターフェースを実装したクラスのインスタンスに格納されているキーおよび値が String 以外の場合の動作は保証外。)
属性 selected には、コンボボックスの初期選択(初期表示)値を指定します。 初期選択状態にする値のキー(属性 list に指定したMapインターフェースを実装したクラスのインスタンスの該当する キー名称)と一致する文字列を含むListインターフェースを実装したクラスのインスタンスを指定することで、初期選択状態にする ことができます。
属性 selected に指定した値に該当するキーが属性 list に指定したMapインターフェースを実装したクラスのインスタンス のキー名称として存在しない場合は、どの値も選択状態にはなりません。 (ただし、コンボボックスの初期選択指定が存在しない場合は、ブラウザの仕様で 自動的にコンボボックス内の先頭の要素が初期選択状態として表示されます。) また、初期選択状態とするキーを同時に複数個指定する場合は、属性 selected に 対して複数のキー文字列を含むListインターフェースを実装したクラスのインスタンスを指定する事で可能になります。 その際、配列内の各要素の値として、初期選択状態にするキー(属性 list に格納した Mapインターフェースを実装したクラスのインスタンスのキー名称)を格納してください。
属性 blank は、コンボボックス内の任意の位置に空データを表示させるための 属性指定になります。
値としてキーワード "top" を指定するとボックス内の先頭位置に空データが表示 され、キーワード "bottom" を指定するとボックス内の最後尾位置に空データが 表示されます。
属性 name に指定した値は <SELECT> タグの name 属性に出力されます。
属性 size に指定した値は <SELECT> タグの size 属性に出力されます。
属性 multipleをしてした場合は、 <SELECT> タグに multiple 属性が付加されます。
属性 attr に指定した値は、指定された文字列のまま <SELECT> タグの属性として 出力されます。(<SELECT> タグの仕様に関しては市販のＨＴＭＬリファレンスを 参照して下さい)。

サンプル:
<%
Vector list = new Vector();
Hashtable ht1 = new Hashtable();
Hashtable ht2 = new Hashtable();

ht1.put("value","test");
ht1.put("text","テスト");
ht2.put("value","test");
ht2.put("text","テスト");

list.add(ht1);
list.add(ht2);
%>

<FORM>
<imtag:Select list="<%= list%>" option_value="value" option_text="text" name="test1"/>
<imtag:Select list="<%= list%>"
option_value="value" option_text="text"
size="4" name="test2"/>
</FORM>
画面には、コンボボックスとリストボックスが表示されます。
ボックス内には、変数 list に格納されているMapインターフェースを実装したHashtableクラスのインスタンス内のデータが表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List | 表示リスト
name | false | true | java.lang.String | <SELECT>タグのname属性
size | false | true | java.lang.String | <SELECT>タグのsize属性
selected | false | true | java.util.List | 初期選択値の設定
blank | false | true | java.lang.String | キーワードの示す位置へブランクデータを挿入
attr | false | true | java.lang.String | <SELECT>タグ内に指定するその他の属性値
multiple | false | true | java.lang.String | <SELECT>タグのmultiple属性(指定した場合は複数選択可)
option_value | false | true | java.lang.String | <option>タグのvalue値に対応するキー名
option_text | false | true | java.lang.String | <option>タグのtext値に対応するキー名

概要 ライブラリ タグ ヘルプ


 intra-mart 標準 タグライブラリ
タグ一覧
imtag:calendar
imtag:condition
imtag:decision
imtag:drawer
imtag:floatingCalendar
imtag:imartDateFormat
imtag:imartEvent
imtag:imartNumberFormat
imtag:loop
imtag:repeat
imtag:select
imtag:tree
imtag:Cal_view 非推奨
imtag:Condition 非推奨
imtag:Decision 非推奨
imtag:Drawer 非推奨
imtag:ImartDateFormat 非推奨
imtag:ImartEvent 非推奨
imtag:ImartNumberFormat 非推奨
imtag:Loop 非推奨
imtag:Repeat 非推奨
imtag:Select 非推奨
imtag:Tree 非推奨


intra-mart 標準 タグライブラリ (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ

標準構文:
     <%@ taglib prefix="imtag" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
XML構文:
     <anyxmlelement xmlns:imtag="http://www.intra-mart.co.jp/taglib/core/standard" />
intra-mart 標準 タグライブラリ。

intra-mart 標準 タグライブラリ仕様

1. タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。

2. タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。

3. タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。

4. タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。

5. JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法
intra-mart タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/core/standard" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "imtag" として説明します)

また下記のように、上記の taglib ディレクティブを XML の書式で記述すること も出来ます。

<jsp:directive.taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" />

サンプル
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" %>
<%@ page import="java.util.*" %>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 //EN">
<HTML>

<HEAD>
<TITLE>Hello intra-mart.</TITLE>
</HEAD>

<%! private Date date = new Date(); %>

<BODY bgcolor="whitesmoke">

<CENTER><H2>
<imtag:ImartDateFormat value="<%= date%>" format="yyyy/MM/dd"/>
</H2></CENTER>

</BODY>

</HTML>

タグライブラリ情報
表示名 | intra-mart 標準 タグライブラリ
Version | 1.0
Short Name | imtag
URI | http://www.intra-mart.co.jp/taglib/core/standard

タグ 一覧
calendar | カレンダーモジュールの画面ＨＴＭＬソースを作成します。
condition | タグに挟まれた部分の実行の条件分岐を行います。
decision | タグに挟まれた部分の実行の条件分岐をおこないます。
drawer | 画像ファイルを作成しHTMLに表示します。
floatingCalendar | ドラッグ＆ドロップで移動可能なカレンダーをフレーム上に表示します 表示されたカレンダーの日付をクリックすると、 引数「element」で指定された要素に、選択された日付の文字列を反映します。
imartDateFormat | タグの指定された場所に、指定された日付データを文字列として挿入します。
imartEvent | ページに対して、ブラウザ上で動作するイベント処理型ロジックを追加します。
imartNumberFormat | タグの指定されている個所に指定の数値データを文字列として挿入します。
loop | タグに挟まれている範囲内のソースを繰り返し処理します。
repeat | タグに挟まれた範囲内（ネスト部分）を指定の回数だけ繰り返し処理します。
select | フォーム内にコンボボックス（またはリストボックス）を表示します。
tree | 階層化データをツリー形式でブラウザ上に表示します。
Cal_view | 奨励されていません。calendar タグに置き換えられました。
Condition | 奨励されていません。condition タグに置き換えられました。
Decision | 奨励されていません。decision タグに置き換えられました。
Drawer | 奨励されていません。drawer タグに置き換えられました。
ImartDateFormat | 奨励されていません。imartDateFormat タグに置き換えられました。
ImartEvent | 奨励されていません。imartEvent タグに置き換えられました。
ImartNumberFormat | 奨励されていません。imartNumberFormat タグに置き換えられました。
Loop | 奨励されていません。loop タグに置き換えられました。
Repeat | 奨励されていません。repeat タグに置き換えられました。
Select | 奨励されていません。select タグに置き換えられました。
Tree | 奨励されていません。tree タグに置き換えられました。

概要 ライブラリ タグ ヘルプ


tree (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ tree

階層化データをツリー形式でブラウザ上に表示します。

このツリー表示ＡＰＩでは、以下の３種類のツリー表示部品を提供します。

フォルダー開閉式(初期表示は全閉)
フォルダー開閉式(初期表示は全開)
フォルダー開閉動作無し

属性 clickHome に対しては、ホーム名をクリックした時に実行したいJavaScript関数を指定してください。 無指定の時は、ホーム名のアンカータグがなくなります。
属性 clickFolder に対しては、フォルダ名をクリックした時に実行したいJavaScript関数を指定してください。 フォルダ名クリック時に引数を伴って実行されます。無指定の時は、フォルダ名のアンカータグがなくなります。
属性 clickItem に対しては、ページ名をクリックした時に実行したいJavaScript関数を指定してください。 ページ名クリック時に引数を伴って実行されます。無指定の時は、ページ名のアンカータグがなくなります。
属性 list には、 jp.co.intra_mart.foundation.page.TreeNodeProviderインターフェースを実装したクラスのインスタンスを指定してください。
属性 list に指定されてインスタンスが、ツリーの原点となる「ホーム」となります。 「ホーム」が持つ子ノードが、ツリーの「フォルダ」、「ページ」となりツリー表示が行われます。
属性 highlight に対しては、選択項目のハイライトカラーを指定してください。無指定の場合はデフォルト色の自動選択となります。（フォルダ開閉式ツリーのみ有効）

属性 type に対しては、ツリーの種類を指定してください。指定できるツリーの種類は下記の通りです。
無指定の時は、フォルダー開閉式（初期表示は全閉）が自動選択になります。
下記に存在しない type が指定されたときは例外が出力されます。
@DYNAMIC_TREE_OPEN_VIEW | フォルダー開閉式(初期表示は全開)
@DYNAMIC_TREE_CLOSE_VIEW | フォルダー開閉式(初期表示は全閉)
@STATIC_TREE_VIEW | フォルダー開閉動作無し

制約
属性 rootName に対しては「ホーム」の表示名称を指定してください。無指定の時は、「ホーム」の表示名称がなくなります。
属性 rootNote に対しては「ホーム」の説明文を指定してください。ポップアップ文字列として表示されます。無指定の時は、「ホーム」のポップアップ文字列がなくなります。

ツリーの各クリックイベントに対応した Client Side の JavaScript 関数は、必ずツリー呼び出しステートメントよりもファイルの上部に定義(記述)してください。

ツリー開閉式ツリー表示ユニットでは、Dynamic-HTML およびスタイルシート(CSS)技術を利用しています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、これらの技術を無闇に利用すると二重定義などが発生しツリーのイベントが正常に動作しなくなることがあります。

ツリー表示ユニットで利用している Dynamic-HTML(ツリー開閉式のみ) および CSS (ツリー開閉式のみ) の定義名や Client Side JavaScript 関数(ページ内グローバル)および変数(ページ内グローバル) の名称には tree_ というプレフィックスがついています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、Client Side JavaScript の各関数(ページ内グローバル)および各変数(ページ内グローバル)の名称などには、tree_ で開始される名称定義をしないでください。

ツリー表示ユニットでは、Dynamic-HTML(ツリー開閉式のみ) および Client Side JavaScript 技術を利用しています。
これら技術に対応していないブラウザでの利用はしないでください。

開閉式ツリー表示では、Dynamic-HTML 技術を利用して各項目の表示位置を自動的に計算して表示をしています。
ツリー表示呼び出しステートメントを記述してある位置を基準に表示位置を計算しているので、ツリー表示ステートメントはページの最下部に記述するようにしてください。
サンプル:
<%@ page contentType="text/html;charset=Shift_JIS" %>
<%@ page import="jp.co.intra_mart.foundation.page.*" %>
<%@ taglib prefix="imtag"
uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<HTML>
<HEAD>
<SCRIPT language="JavaScript">
function onClickHomeFunction(){
window.alert("click home !");
}
function onClickFolderFunction(arg){
window.alert("click folder: " + arg);
}
function onClickPageFunction(arg){
window.alert("click page: " + arg);
}
</SCRIPT>
<TITLE>Sample JSP</TITLE>
</HEAD>
<BODY>

<%
//「ホーム」を作成する
TreeRoot home = new TreeRoot();

//「フォルダ」を作成する
TreeBranch branch1 = new TreeBranch();
//「フォルダ」の表示名を設定する
branch1.setName("フォルダ１");
//「フォルダ」の説明を設定する
branch1.setNote("フォルダ１です");
//「フォルダ」のJavaScriptに渡される引数を設定する
branch1.setArgument("フォルダ１");

TreeBranch branch2 = new TreeBranch();
branch2.setName("フォルダ２");
branch2.setNote("フォルダ２です");
branch2.setArgument("フォルダ２");

//「ページ」を作成する
TreeLeaf leaf1 = new TreeLeaf();
//「ページ」の表示名を設定する
leaf1.setName("ページ１");
//「ページ」の説明を設定する
leaf1.setNote("ページ１です");
//「ページ」のJavaScriptに渡される引数を設定する
leaf1.setArgument("ページ１");

TreeLeaf leaf2 = new TreeLeaf();
leaf2.setName("ページ２");
leaf2.setNote("ページ２です");
leaf2.setArgument("ページ２");

//「ホーム」に「フォルダ」を登録する
home.addChildNode(branch1);
home.addChildNode(branch2);
//「フォルダ」に「ページ」を登録する
branch1.addChildNode(leaf1);
branch1.addChildNode(leaf2);
%>
<!--list属性に home を渡してツリーを表示させる -->
<imtag:tree clickHome="onClickHomeFunction"
clickFolder="onClickFolderFunction"
clickItem="onClickPageFunction"
list="<%=home%>"
type="@DYNAMIC_TREE_OPEN_VIEW"
rootName="ホーム"
rootNote="ホームです"/>

</BODY>
</HTML>
プログラムを実行すると画面には下のような実行結果が表示されます。文字指定は「Shift-JIS」で行っています。
「ホーム」のインスタンスを jp.co.intra_mart.foundation.page.TreeRootクラスから作成していますが、このクラスは jp.co.intra_mart.foundation.page.TreeNodeProviderインターフェースの実装クラスです。
「フォルダ」のインスタンスは jp.co.intra_mart.foundation.page.TreeBranchクラスから、「ページ」のインスタンスは jp.co.intra_mart.foundation.page.TreeLeaf クラスからそれぞれ作成されています。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
clickHome | false | true | java.lang.String | ホーム名をクリックした時に実行するJavaScript関数名
clickFolder | false | true | java.lang.String | フォルダ名をクリックした時に実行するJavaScript関数名
clickItem | false | true | java.lang.String | ページ名をクリックした時に実行するJavaScript関数名
list | true | true | java.lang.String | ツリービュー表示の「ホーム」 (jp.co.intra_mart.foundation.page.TreeNodeProvider)
highlight | false | true | java.lang.String | 選択状態のハイライトカラー
type | false | true | java.lang.String | ツリービュー表示の種類
rootName | false | true | java.lang.String | ホームの名称
rootNote | false | true | java.lang.String | ホームに関する説明

概要 ライブラリ タグ ヘルプ


Tree (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Tree

奨励されていません。tree タグに置き換えられました。

階層化データをツリー形式でブラウザ上に表示します。

このツリー表示ＡＰＩでは、以下の３種類のツリー表示部品を提供します。

フォルダー開閉式(初期表示は全閉)
フォルダー開閉式(初期表示は全開)
フォルダー開閉動作無し

属性 clickHome に対しては、ホーム名をクリックした時に実行したいJavaScript関数を指定してください。 無指定の時は、ホーム名のアンカータグがなくなります。
属性 clickFolder に対しては、フォルダ名をクリックした時に実行したいJavaScript関数を指定してください。 フォルダ名クリック時に引数を伴って実行されます。無指定の時は、フォルダ名のアンカータグがなくなります。
属性 clickItem に対しては、ページ名をクリックした時に実行したいJavaScript関数を指定してください。 ページ名クリック時に引数を伴って実行されます。無指定の時は、ページ名のアンカータグがなくなります。
属性 list には、 jp.co.intra_mart.foundation.page.TreeNodeProviderインターフェースを実装したクラスのインスタンスを指定してください。
属性 list に指定されてインスタンスが、ツリーの原点となる「ホーム」となります。 「ホーム」が持つ子ノードが、ツリーの「フォルダ」、「ページ」となりツリー表示が行われます。
属性 highlight に対しては、選択項目のハイライトカラーを指定してください。無指定の場合はデフォルト色の自動選択となります。（フォルダ開閉式ツリーのみ有効）

属性 type に対しては、ツリーの種類を指定してください。指定できるツリーの種類は下記の通りです。
無指定の時は、フォルダー開閉式（初期表示は全閉）が自動選択になります。
下記に存在しない type が指定されたときは例外が出力されます。
@DYNAMIC_TREE_OPEN_VIEW | フォルダー開閉式(初期表示は全開)
@DYNAMIC_TREE_CLOSE_VIEW | フォルダー開閉式(初期表示は全閉)
@STATIC_TREE_VIEW | フォルダー開閉動作無し

制約
属性 rootName に対しては「ホーム」の表示名称を指定してください。無指定の時は、「ホーム」の表示名称がなくなります。
属性 rootNote に対しては「ホーム」の説明文を指定してください。ポップアップ文字列として表示されます。無指定の時は、「ホーム」のポップアップ文字列がなくなります。

ツリーの各クリックイベントに対応した Client Side の JavaScript 関数は、必ずツリー呼び出しステートメントよりもファイルの上部に定義(記述)してください。

ツリー開閉式ツリー表示ユニットでは、Dynamic-HTML およびスタイルシート(CSS)技術を利用しています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、これらの技術を無闇に利用すると二重定義などが発生しツリーのイベントが正常に動作しなくなることがあります。

ツリー表示ユニットで利用している Dynamic-HTML(ツリー開閉式のみ) および CSS (ツリー開閉式のみ) の定義名や Client Side JavaScript 関数(ページ内グローバル)および変数(ページ内グローバル) の名称には tree_ というプレフィックスがついています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、Client Side JavaScript の各関数(ページ内グローバル)および各変数(ページ内グローバル)の名称などには、tree_ で開始される名称定義をしないでください。

ツリー表示ユニットでは、Dynamic-HTML(ツリー開閉式のみ) および Client Side JavaScript 技術を利用しています。
これら技術に対応していないブラウザでの利用はしないでください。

開閉式ツリー表示では、Dynamic-HTML 技術を利用して各項目の表示位置を自動的に計算して表示をしています。
ツリー表示呼び出しステートメントを記述してある位置を基準に表示位置を計算しているので、ツリー表示ステートメントはページの最下部に記述するようにしてください。
サンプル:
<%@ page contentType="text/html;charset=Shift_JIS" %>
<%@ page import="jp.co.intra_mart.foundation.page.*" %>
<%@ taglib prefix="imtag"
uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<HTML>
<HEAD>
<SCRIPT language="JavaScript">
function onClickHomeFunction(){
window.alert("click home !");
}
function onClickFolderFunction(arg){
window.alert("click folder: " + arg);
}
function onClickPageFunction(arg){
window.alert("click page: " + arg);
}
</SCRIPT>
<TITLE>Sample JSP</TITLE>
</HEAD>
<BODY>

<%
//「ホーム」を作成する
TreeRoot home = new TreeRoot();

//「フォルダ」を作成する
TreeBranch branch1 = new TreeBranch();
//「フォルダ」の表示名を設定する
branch1.setName("フォルダ１");
//「フォルダ」の説明を設定する
branch1.setNote("フォルダ１です");
//「フォルダ」のJavaScriptに渡される引数を設定する
branch1.setArgument("フォルダ１");

TreeBranch branch2 = new TreeBranch();
branch2.setName("フォルダ２");
branch2.setNote("フォルダ２です");
branch2.setArgument("フォルダ２");

//「ページ」を作成する
TreeLeaf leaf1 = new TreeLeaf();
//「ページ」の表示名を設定する
leaf1.setName("ページ１");
//「ページ」の説明を設定する
leaf1.setNote("ページ１です");
//「ページ」のJavaScriptに渡される引数を設定する
leaf1.setArgument("ページ１");

TreeLeaf leaf2 = new TreeLeaf();
leaf2.setName("ページ２");
leaf2.setNote("ページ２です");
leaf2.setArgument("ページ２");

//「ホーム」に「フォルダ」を登録する
home.addChildNode(branch1);
home.addChildNode(branch2);
//「フォルダ」に「ページ」を登録する
branch1.addChildNode(leaf1);
branch1.addChildNode(leaf2);
%>
<!--list属性に home を渡してツリーを表示させる -->
<imtag:Tree clickHome="onClickHomeFunction"
clickFolder="onClickFolderFunction"
clickItem="onClickPageFunction"
list="<%=home%>"
type="@DYNAMIC_TREE_OPEN_VIEW"
rootName="ホーム"
rootNote="ホームです"/>

</BODY>
</HTML>
プログラムを実行すると画面には下のような実行結果が表示されます。文字指定は「Shift-JIS」で行っています。
「ホーム」のインスタンスを jp.co.intra_mart.foundation.page.TreeRootクラスから作成していますが、このクラスは jp.co.intra_mart.foundation.page.TreeNodeProviderインターフェースの実装クラスです。
「フォルダ」のインスタンスは jp.co.intra_mart.foundation.page.TreeBranchクラスから、「ページ」のインスタンスは jp.co.intra_mart.foundation.page.TreeLeaf クラスからそれぞれ作成されています。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
clickHome | false | true | java.lang.String | ホーム名をクリックした時に実行するJavaScript関数名
clickFolder | false | true | java.lang.String | フォルダ名をクリックした時に実行するJavaScript関数名
clickItem | false | true | java.lang.String | ページ名をクリックした時に実行するJavaScript関数名
list | true | true | java.lang.String | ツリービュー表示の「ホーム」 (jp.co.intra_mart.foundation.page.TreeNodeProvider)
highlight | false | true | java.lang.String | 選択状態のハイライトカラー
type | false | true | java.lang.String | ツリービュー表示の種類
rootName | false | true | java.lang.String | ホームの名称
rootNote | false | true | java.lang.String | ホームに関する説明

概要 ライブラリ タグ ヘルプ


 すべてのタグおよび関数
imtag:calendar
imtag:condition
imtag:decision
imtag:drawer
imtag:floatingCalendar
imtag:imartDateFormat
imtag:imartEvent
imtag:imartNumberFormat
imtag:loop
imtag:repeat
imtag:select
imtag:tree
imtag:Cal_view 非推奨
imtag:Condition 非推奨
imtag:Decision 非推奨
imtag:Drawer 非推奨
imtag:ImartDateFormat 非推奨
imtag:ImartEvent 非推奨
imtag:ImartNumberFormat 非推奨
imtag:Loop 非推奨
imtag:Repeat 非推奨
imtag:Select 非推奨
imtag:Tree 非推奨


概要 (Tag Library Documentation Generator - Generated Documentation)

タグライブラリ ドキュメント
すべてのタグおよび関数

タグライブラリ
intra-mart 標準 タグライブラリ


概要 (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

タグライブラリ ドキュメント

タグライブラリ
intra-mart 標準 タグライブラリ intra-mart 標準 タグライブラリ。

概要 ライブラリ タグ ヘルプ


クラス jp.co.intra_mart.foundation.sap.common.auth.SapConnector の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapConnector の使用

SapConnector を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SapConnector の使用

SapConnector 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.auth のメソッド
static com.sap.mw.jco.JCO.Repository SapRepositoryManager.getJCORepository(SapConnector sapConnector)
Repository情報を生成もしくは、取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException の使用

SAPAuthAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.common.auth のコンストラクタ
SapConnector(String serverType)
プロパティファイルを読込み属性に値をセットします。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void BapiController.executeBapi()
BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException の使用

SAPAuthSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.auth のメソッド
static com.sap.mw.jco.JCO.Repository | SapRepositoryManager.getJCORepository(SapConnector sapConnector) Repository情報を生成もしくは、取得します。
com.sap.mw.jco.JCO.Client | SapConnector.useConnection() コネクションを生成します。
static void | SapConnector.releaseConnection(com.sap.mw.jco.JCO.Client connection) コネクションをリリースします。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.auth のコンストラクタ
SapConnector()
プロパティファイルを読込み属性に値をセットします。
SapConnector(String serverType)
プロパティファイルを読込み属性に値をセットします。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void BapiController.executeBapi()
BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

jp.co.intra_mart.foundation.sap.common.util.file での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.file のコンストラクタ
PropertiesFile(String fileName)
ファイル名を指定してプロパティファイルを取得します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.auth.exception (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.common.auth.exception
例外
SAPAuthAppException
SAPAuthSystemException


jp.co.intra_mart.foundation.sap.common.auth.exception (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception

ＳＡＰ連携に関する例外クラスを提供します。

参照:
説明

例外の概要
SAPAuthAppException | 認証系APIアプリケーション例外クラス
SAPAuthSystemException | 認証系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の説明

ＳＡＰ連携に関する例外クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


jp.co.intra_mart.foundation.sap.common.auth.exception クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
        • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.auth.exception の使用

jp.co.intra_mart.foundation.sap.common.auth.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.file により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


SAPAuthAppException (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth.exception
クラス SAPAuthAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
すべての実装インタフェース:
Serializable
public class SAPAuthAppException
extends Exception

認証系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAuthAppException(String message)
認証系APIアプリケーション例外
SAPAuthAppException(String message, Throwable ex)
認証系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAuthAppException

public SAPAuthAppException(String message,
                           Throwable ex)
認証系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAuthAppException

public SAPAuthAppException(String message)
認証系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAuthSystemException (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth.exception
クラス SAPAuthSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
すべての実装インタフェース:
Serializable
public class SAPAuthSystemException
extends Exception

認証系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAuthSystemException(String message, Throwable ex)
認証系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAuthSystemException

public SAPAuthSystemException(String message,
                              Throwable ex)
認証系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.auth (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.common.auth
クラス
SapConnector
SapRepositoryManager


jp.co.intra_mart.foundation.sap.common.auth (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

クラスの概要
SapConnector | SAPコネクタークラス 機能は以下の通り 単一ユーザIDで任意のコネクションプールを作成し、R/3にログインします。
SapRepositoryManager | JCO.Repository を管理クラス。

パッケージ jp.co.intra_mart.foundation.sap.common.auth の説明

ＳＡＰ連携に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.auth クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.auth.SapConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.sap.common.auth の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.auth の使用

jp.co.intra_mart.foundation.sap.common.auth を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapConnector
SAPコネクタークラス
機能は以下の通り
単一ユーザIDで任意のコネクションプールを作成し、R/3にログインします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


SapConnector (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapConnector
すべての実装インタフェース:
Serializable
public class SapConnector
extends Object
implements Serializable

SAPコネクタークラス
機能は以下の通り

  • 単一ユーザIDで任意のコネクションプールを作成し、R/3にログインします。
  • 接続先のR/3サーバが複数存在する場合でも、任意のR/3サーバに接続可能です。

関連項目:
直列化された形式

コンストラクタの概要
SapConnector()
プロパティファイルを読込み属性に値をセットします。
SapConnector(String serverType)
プロパティファイルを読込み属性に値をセットします。
メソッドの概要
String | getAshost() 接続先サーバIPアドレスを取得します｡
String | getClient() クライアントを取得します｡
long | getConnectionTimeout() コネクションのタイムアウトを取得します｡
String | getLang() 言語を取得します｡
String | getPasswd() パスワードを取得します｡
String | getPoolName() プール名称を取得します｡
int | getPoolSize() プール内のコネクション数を取得します｡
String | getServerType() サーバタイプを取得します｡
String | getSysnr() システム番号を取得します｡
long | getTimeoutCheckPeriod() コネクションのタイムアウトのチェック間隔を取得します｡
String | getUser() ユーザを取得します｡
long | getWaitTime() コネクション取得の待機時間を取得します｡
static void | releaseConnection(com.sap.mw.jco.JCO.Client connection) コネクションをリリースします。
void | setAshost(String ashost) 接続先サーバIPアドレスを設定します｡
void | setClient(String client) クライアントを設定します｡
void | setConnectionTimeout(long connectionTimeout) コネクションのタイムアウトを設定します｡
void | setLang(String lang) 言語を設定します｡
void | setPasswd(String passwd) パスワードを設定します｡
void | setPoolName(String poolName) プール名称を設定します｡
void | setPoolSize(int poolSize) プール内のコネクション数を設定します｡
void | setServerType(String serverType) サーバタイプを設定します｡
void | setSysnr(String sysnr) システム番号を設定します｡
void | setTimeoutCheckPeriod(long timeoutCheckPeriod) コネクションのタイムアウトのチェック間隔を設定します｡
void | setUser(String user) ユーザを設定します｡
void | setWaitTime(long waitTime) コネクション取得の待機時間を設定します｡
String | toString() デバッグ用のメソッドです。
com.sap.mw.jco.JCO.Client | useConnection() コネクションを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapConnector

public SapConnector()
             throws SAPAuthSystemException
プロパティファイルを読込み属性に値をセットします。 接続先が１つの場合に使用します。

例外:
SAPAuthSystemException - 認証系システム例外

SapConnector

public SapConnector(String serverType)
             throws SAPAuthAppException,
                    SAPAuthSystemException
プロパティファイルを読込み属性に値をセットします。 接続先が複数の場合に使用します。

パラメータ:
serverType - サーバタイプ
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
メソッドの詳細

setServerType

public void setServerType(String serverType)
サーバタイプを設定します｡

パラメータ:
serverType - サーバタイプ

setClient

public void setClient(String client)
クライアントを設定します｡

パラメータ:
client - クライアント

setUser

public void setUser(String user)
ユーザを設定します｡

パラメータ:
user - ユーザ

setPasswd

public void setPasswd(String passwd)
パスワードを設定します｡

パラメータ:
passwd - パスワード

setLang

public void setLang(String lang)
言語を設定します｡

パラメータ:
lang - 言語

setSysnr

public void setSysnr(String sysnr)
システム番号を設定します｡

パラメータ:
sysnr - システム番号

setAshost

public void setAshost(String ashost)
接続先サーバIPアドレスを設定します｡

パラメータ:
ashost - 接続先サーバIPアドレス

setPoolName

public void setPoolName(String poolName)
プール名称を設定します｡

パラメータ:
poolName - プール名称

setPoolSize

public void setPoolSize(int poolSize)
プール内のコネクション数を設定します｡

パラメータ:
poolSize - プール内のコネクション数

setWaitTime

public void setWaitTime(long waitTime)
コネクション取得の待機時間を設定します｡

パラメータ:
waitTime - コネクション取得の待機時間

setConnectionTimeout

public void setConnectionTimeout(long connectionTimeout)
コネクションのタイムアウトを設定します｡

パラメータ:
connectionTimeout - コネクションのタイムアウト

setTimeoutCheckPeriod

public void setTimeoutCheckPeriod(long timeoutCheckPeriod)
コネクションのタイムアウトのチェック間隔を設定します｡

パラメータ:
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔

getServerType

public String getServerType()
サーバタイプを取得します｡

戻り値:
serverType

getClient

public String getClient()
クライアントを取得します｡

戻り値:
client

getUser

public String getUser()
ユーザを取得します｡

戻り値:
user

getPasswd

public String getPasswd()
パスワードを取得します｡

戻り値:
passwd

getLang

public String getLang()
言語を取得します｡

戻り値:
lang

getSysnr

public String getSysnr()
システム番号を取得します｡

戻り値:
sysnr

getAshost

public String getAshost()
接続先サーバIPアドレスを取得します｡

戻り値:
ashost

getPoolName

public String getPoolName()
プール名称を取得します｡

戻り値:
poolName

getPoolSize

public int getPoolSize()
プール内のコネクション数を取得します｡

戻り値:
poolSize

getWaitTime

public long getWaitTime()
コネクション取得の待機時間を取得します｡

戻り値:
waitTime

getConnectionTimeout

public long getConnectionTimeout()
コネクションのタイムアウトを取得します｡

戻り値:
connectionTimeout

getTimeoutCheckPeriod

public long getTimeoutCheckPeriod()
コネクションのタイムアウトのチェック間隔を取得します｡

戻り値:
timeoutCheckPeriod

useConnection

public com.sap.mw.jco.JCO.Client useConnection()
                                        throws SAPAuthSystemException
コネクションを生成します。

戻り値:
connection
例外:
SAPAuthSystemException - 認証系システム例外

releaseConnection

public static void releaseConnection(com.sap.mw.jco.JCO.Client connection)
                              throws SAPAuthSystemException
コネクションをリリースします。

パラメータ:
connection - コネクション
例外:
SAPAuthSystemException - 認証系システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn の使用

BapiReturn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での BapiReturn の使用

BapiReturn を返す jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 BapiReturn BapiController.getReturn()
ＢＡＰＩ実行結果を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager の使用

ConnectionManager を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException の使用

SAPGeneralAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
String | LineProperty.getSeparateKey(int partIndex) 指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
void | BapiController.putImportParam(String key, String val) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
void | BapiController.putStructParam(String key, String val, String structName) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
void | BapiController.putTableParam(String key, String val, String tableName, int recordNo) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
void | BapiController.executeBapi() BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡ なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

jp.co.intra_mart.foundation.sap.module.accounting での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException の使用

SAPGeneralSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
void | ConnectionManager.commit() ＢＡＰＩ実行結果のCOMMIT処理を行います｡
void | ConnectionManager.rollback() ＢＡＰＩ実行結果のROLLBACK処理を行います｡
void | BapiController.putImportParam(String key, String val) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
void | BapiController.putStructParam(String key, String val, String structName) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
void | BapiController.putTableParam(String key, String val, String tableName, int recordNo) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
void | BapiController.executeBapi() BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡ なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。
boolean | BapiController.isSuccess() ＢＡＰＩ実行が正常に行われたか判定します｡ＢＡＰＩ実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡
String | BapiController.getErrMessage() ＢＡＰＩの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。
String | BapiController.getExportParam(String propKey) export(Export)情報を返します。
HashMap | BapiController.getStructureParam(String paramName) structure(Export)情報を返します。
Iterator | BapiController.getTableParam(String paramName) table(Export)情報を返します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
LineProperty(String propertyKey, String propertyValue)
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
BapiReturn(com.sap.mw.jco.JCO.Structure str)
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(com.sap.mw.jco.JCO.Table tbl)
指定されたJCO.Table情報でBapiReturnを作成します。
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

jp.co.intra_mart.foundation.sap.common.util.data での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.data のメソッド
static String Convertor.convJCOdata(int typ, int len, Object val)
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.general_purpose.exception (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.common.general_purpose.exception
例外
SAPGeneralAppException
SAPGeneralSystemException


jp.co.intra_mart.foundation.sap.common.general_purpose.exception (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

例外の概要
SAPGeneralAppException | 共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException | 共通API/汎用データ取得・追加・更新APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の説明

ＳＡＰ連携に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


jp.co.intra_mart.foundation.sap.common.general_purpose.exception クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose.exception の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.data により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


SAPGeneralAppException (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose.exception
クラス SAPGeneralAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
すべての実装インタフェース:
Serializable
public class SAPGeneralAppException
extends Exception

共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPGeneralAppException(String message)
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralAppException(String message, Throwable ex)
共通API/汎用データ取得・追加・更新APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPGeneralAppException

public SAPGeneralAppException(String message,
                              Throwable ex)
共通API/汎用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPGeneralAppException

public SAPGeneralAppException(String message)
共通API/汎用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPGeneralSystemException (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose.exception
クラス SAPGeneralSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
すべての実装インタフェース:
Serializable
public class SAPGeneralSystemException
extends Exception

共通API/汎用データ取得・追加・更新APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPGeneralSystemException(String message, Throwable ex)
共通API/汎用データ取得・追加・更新APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPGeneralSystemException

public SAPGeneralSystemException(String message,
                                 Throwable ex)
共通API/汎用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BapiController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController
すべての実装インタフェース:
Serializable
public class BapiController
extends Object
implements Serializable

BAPIコントローラクラス
機能は以下の通り

  • ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡
  • 展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開メソッドを使用して取得します｡

関連項目:
直列化された形式

コンストラクタの概要
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
メソッドの概要
void | clear() セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
void | executeBapi() BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡ なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。
ArrayList | getBapiHashList() BapiHashの一覧を取得します。
ArrayList | getBapiReturnList() BapiReturnの一覧を取得します｡
String | getErrMessage() ＢＡＰＩの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。
ArrayList | getExpExpList() プロパティ情報(export(Export))の一覧を取得します｡
String | getExportParam(String propKey) export(Export)情報を返します。
ArrayList | getExpStrList() プロパティ情報(structure(Export))の一覧を取得します｡
ArrayList | getExpTblList() プロパティ情報(table(Export))の一覧を取得します｡
ArrayList | getImpImpList() プロパティ情報(import(Import))の一覧を取得します。
ArrayList | getImpStrList() プロパティ情報(structure(Import))一覧を取得します。
ArrayList | getImpTblList() プロパティ情報(table(Import))の一覧を取得します｡
Properties | getProperty() プロパティファイル情報を取得します。
String | getPropertyName() プロパティファイル名を取得します。
BapiReturn | getReturn() ＢＡＰＩ実行結果を取得します。
Iterator | getReturnList() ＢＡＰＩ実行結果の一覧を取得します。
HashMap | getStructureParam(String paramName) structure(Export)情報を返します。
Iterator | getTableParam(String paramName) table(Export)情報を返します。
boolean | isSuccess() ＢＡＰＩ実行が正常に行われたか判定します｡ＢＡＰＩ実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡
void | putImportParam(String key, String val) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
void | putStructParam(String key, String val, String structName) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
void | putTableParam(String key, String val, String tableName, int recordNo) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
void | setBapiHashList(ArrayList bapiHashList) BapiHashの一覧を設定します｡
void | setBapiReturnList(ArrayList bapiReturnList) BapiReturnの一覧を設定します｡
void | setExpExpList(ArrayList expExpList) プロパティ情報(export(Export))の一覧を設定します｡
void | setExpStrList(ArrayList expStrList) プロパティ情報(structure(Export))の一覧を設定します｡
void | setExpTblList(ArrayList expTblList) プロパティ情報(table(Export))の一覧を設定します｡
void | setImpImpList(ArrayList impImpList) プロパティ情報(import(Import))の一覧を設定します｡
void | setImpStrList(ArrayList impStrList) プロパティ情報(structure(Import))の一覧を設定します｡
void | setImpTblList(ArrayList impTblList) プロパティ情報(table(Import))の一覧を設定します｡
void | setProperty(Properties property) プロパティファイル情報を設定します｡
void | setPropertyName(String propertyName) プロパティファイル名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BapiController

public BapiController(String propertyName,
                      ConnectionManager connectionManager)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
connectionManager - コネクション管理オブジェクト
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

BapiController

public BapiController(String propertyName)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
メソッドの詳細

putImportParam

public void putImportParam(String key,
                           String val)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

putStructParam

public void putStructParam(String key,
                           String val,
                           String structName)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
structName - BapiHashに設定するparamTypeの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

putTableParam

public void putTableParam(String key,
                          String val,
                          String tableName,
                          int recordNo)
                   throws SAPGeneralSystemException,
                          SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
tableName - BapiHashに設定するparamTypeの値
recordNo - BapiHashに設定するrecordNoの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

executeBapi

public void executeBapi()
                 throws SAPGeneralSystemException,
                        SAPGeneralAppException,
                        SAPAuthSystemException,
                        SAPAuthAppException
BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。呼び出し側で明示的にConnectionManager#commit またはConnectionManager#rollbackを実行する必要があります。また、R/3とのコネクションも 上記2メソッド内で行われますので、確実に呼び出すように実装しなくてはなりません。

例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理
SAPAuthAppException - 認証系アプリケーション例外処理

isSuccess

public boolean isSuccess()
                  throws SAPGeneralSystemException
ＢＡＰＩ実行が正常に行われたか判定します｡ＢＡＰＩ実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡

戻り値:
bapiSuccess BAPI実行結果
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getErrMessage

public String getErrMessage()
                     throws SAPGeneralSystemException
ＢＡＰＩの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。全て正常("S" / "")の場合は nullが返却されます｡

戻り値:
buffer BAPI実行結果エラーとなった全てのメッセージ情報
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getExportParam

public String getExportParam(String propKey)
                      throws SAPGeneralSystemException
export(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名、 プロパティファイルのキー情報で一覧から該当するBapiHashオブジェクト を検索して、値を返します｡

パラメータ:
propKey - 検索条件となるPropertyKey
戻り値:
rtnVal 引数のキーに対応する値
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getStructureParam

public HashMap getStructureParam(String paramName)
                          throws SAPGeneralSystemException
structure(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索して返します｡

パラメータ:
paramName - 検索条件となるParamName
戻り値:
retMap 検索結果となるBapiHash
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getTableParam

public Iterator getTableParam(String paramName)
                       throws SAPGeneralSystemException
table(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索し、一覧に格納して返します｡

パラメータ:
paramName - 検索条件となるParamName
戻り値:
retMap 検索結果となるBapiHash
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getReturnList

public Iterator getReturnList()
ＢＡＰＩ実行結果の一覧を取得します。(Table用)

戻り値:
bapiReturnList

getReturn

public BapiReturn getReturn()
ＢＡＰＩ実行結果を取得します。(Structure用)

戻り値:
bapiRet

getBapiHashList

public ArrayList getBapiHashList()
BapiHashの一覧を取得します。

戻り値:
bapiHashList

getProperty

public Properties getProperty()
プロパティファイル情報を取得します。

戻り値:
property

getPropertyName

public String getPropertyName()
プロパティファイル名を取得します。

戻り値:
propertyName

getImpImpList

public ArrayList getImpImpList()
プロパティ情報(import(Import))の一覧を取得します。

戻り値:
impImpList

getImpStrList

public ArrayList getImpStrList()
プロパティ情報(structure(Import))一覧を取得します。

戻り値:
impStrList

getImpTblList

public ArrayList getImpTblList()
プロパティ情報(table(Import))の一覧を取得します｡

戻り値:
impTblList

getExpExpList

public ArrayList getExpExpList()
プロパティ情報(export(Export))の一覧を取得します｡

戻り値:
expExpList

getExpStrList

public ArrayList getExpStrList()
プロパティ情報(structure(Export))の一覧を取得します｡

戻り値:
expStrList

getExpTblList

public ArrayList getExpTblList()
プロパティ情報(table(Export))の一覧を取得します｡

戻り値:
expTblList

getBapiReturnList

public ArrayList getBapiReturnList()
BapiReturnの一覧を取得します｡

戻り値:
bapiReturnList

setBapiHashList

public void setBapiHashList(ArrayList bapiHashList)
BapiHashの一覧を設定します｡

パラメータ:
bapiHashList - BapiHashList

setProperty

public void setProperty(Properties property)
プロパティファイル情報を設定します｡

パラメータ:
property - Property

setPropertyName

public void setPropertyName(String propertyName)
プロパティファイル名を設定します｡

パラメータ:
propertyName - propertyName

setImpImpList

public void setImpImpList(ArrayList impImpList)
プロパティ情報(import(Import))の一覧を設定します｡

パラメータ:
impImpList - impImpList

setImpStrList

public void setImpStrList(ArrayList impStrList)
プロパティ情報(structure(Import))の一覧を設定します｡

パラメータ:
impStrList - impStrList

setImpTblList

public void setImpTblList(ArrayList impTblList)
プロパティ情報(table(Import))の一覧を設定します｡

パラメータ:
impTblList - impTblList

setExpExpList

public void setExpExpList(ArrayList expExpList)
プロパティ情報(export(Export))の一覧を設定します｡

パラメータ:
expExpList - expExpList

setExpStrList

public void setExpStrList(ArrayList expStrList)
プロパティ情報(structure(Export))の一覧を設定します｡

パラメータ:
expStrList - expStrList

setExpTblList

public void setExpTblList(ArrayList expTblList)
プロパティ情報(table(Export))の一覧を設定します｡

パラメータ:
expTblList - expTblList

setBapiReturnList

public void setBapiReturnList(ArrayList bapiReturnList)
BapiReturnの一覧を設定します｡

パラメータ:
bapiReturnList - bapiReturnList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値

clear

public void clear()

セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。

BapiControllerを複数回使用する場合、一度putImportParam()などを実行した後に 同じパラメータをセットする前に実行する必要があります。

実行例は次のようになります。

 BapiController bapiController = new BapiController(...);
 bapiController.putImportParam(...);
 bapiController.putStructParam(...);
 ...
 executeBapi();

 //クリア
 bapiController.clear();

 //BapiControllerを再利用する
 bapiController.putImportParam(...);
 bapiController.putStructParam(...);
 ...
 executeBapi();

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BapiHash (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiHash

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 java.util.HashMap
            拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash
すべての実装インタフェース:
Cloneable, Map, Serializable
public class BapiHash
extends HashMap
implements Serializable

BapiHashクラス
機能は以下の通り

  • 汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡
  • R/3のBAPI処理にて使用されるパラメータの値を保持します。
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
BapiHash(String impExpType, String paramType)
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡
BapiHash(String impExpType, String paramType, String paramName)
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。
BapiHash(String impExpType, String paramType, String paramName, int recordNo)
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。
メソッドの概要
String | getImpExpType() 入力／出力区分を取得します｡
String | getParamName() パラメタ名を取得します｡
String | getParamType() パラメタ属性を取得します｡
int | getRecordNo() レコード番号を取得します｡
void | setImpExpType(String impExpType) 入力／出力区分を設定します｡
void | setParamName(String paramName) パラメタ名を設定します｡
void | setParamType(String paramType) パラメタ属性を設定します｡
void | setRecordNo(int recordNo) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.util.HashMap から継承したメソッド
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
クラス java.util.AbstractMap から継承したメソッド
equals, hashCode
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait
インタフェース java.util.Map から継承したメソッド
equals, hashCode

コンストラクタの詳細

BapiHash

public BapiHash(String impExpType,
                String paramType)
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性

BapiHash

public BapiHash(String impExpType,
                String paramType,
                String paramName)
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性
paramName - BapiHashのパラメタ名

BapiHash

public BapiHash(String impExpType,
                String paramType,
                String paramName,
                int recordNo)
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性
paramName - BapiHashのパラメタ名
recordNo - BapiHashのレコード番号
メソッドの詳細

getImpExpType

public String getImpExpType()
入力／出力区分を取得します｡

戻り値:
impExpType

getParamName

public String getParamName()
パラメタ名を取得します｡

戻り値:
paramName

getParamType

public String getParamType()
パラメタ属性を取得します｡

戻り値:
paramType

getRecordNo

public int getRecordNo()
レコード番号を取得します｡

戻り値:
recordNo

setImpExpType

public void setImpExpType(String impExpType)
入力／出力区分を設定します｡

パラメータ:
impExpType - BapiHashの入出力区分

setParamName

public void setParamName(String paramName)
パラメタ名を設定します｡

パラメータ:
paramName - Importのパラメタ名

setParamType

public void setParamType(String paramType)
パラメタ属性を設定します｡

パラメータ:
paramType - Importのパラメタ属性

setRecordNo

public void setRecordNo(int recordNo)
レコード番号を設定します｡

パラメータ:
recordNo - Importのレコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BapiReturn (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiReturn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn
すべての実装インタフェース:
Serializable
public class BapiReturn
extends Object
implements Serializable

BapiReturnクラス
機能は以下の通り

  • R/3のBAPI処理の実行結果に関する値を保持します。
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
BapiReturn(com.sap.mw.jco.JCO.Structure str)
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(com.sap.mw.jco.JCO.Table tbl)
指定されたJCO.Table情報でBapiReturnを作成します。
メソッドの概要
String | getCode() コードを取得します｡
String | getField() フィールドを取得します｡
String | getId() ＩＤを取得します｡
String | getLogMsgNo() ログメッセージナンバーを取得します｡
String | getLogNo() ログナンバーを取得します｡
String | getMessage() メッセージを取得します｡
String | getMessageV1() メッセージＶ１を取得します｡
String | getMessageV2() メッセージＶ２を取得します｡
String | getMessageV3() メッセージＶ３を取得します｡
String | getMessageV4() メッセージＶ４を取得します｡
String | getNumber() ナンバーを取得します｡
String | getParameter() パラメーターを取得します｡
String | getRow() 行番号を取得します｡
String | getSystem() ＩＤを取得します｡
String | getType() タイプを取得します｡
void | setCode(String code) コードを設定します｡
void | setField(String field) フィールドを設定します｡
void | setId(String id) ＩＤを設定します｡
void | setLogMsgNo(String logMsgNo) ログメッセージナンバーを設定します｡
void | setLogNo(String logNo) ログナンバーを設定します｡
void | setMessage(String message) メッセージを設定します｡
void | setMessageV1(String messageV1) メッセージＶ１を設定します｡
void | setMessageV2(String messageV2) メッセージＶ２を設定します｡
void | setMessageV3(String messageV3) メッセージＶ３を設定します｡
void | setMessageV4(String messageV4) メッセージＶ４を設定します｡
void | setNumber(String number) ナンバーを設定します｡
void | setParameter(String parameter) パラメーターを設定します｡
void | setRow(String row) 行番号を設定します｡
void | setSystem(String system) システムを設定します｡
void | setType(String type) タイプを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BapiReturn

public BapiReturn(com.sap.mw.jco.JCO.Structure str)
           throws SAPGeneralSystemException
指定されたJCO.Structure情報でBapiReturnを作成します。 引数のBAPI RETURN(Structure)情報から属性に値をセットします｡

パラメータ:
str - JCO.Structure
例外:
SAPGeneralSystemException - システム例外処理

BapiReturn

public BapiReturn(com.sap.mw.jco.JCO.Table tbl)
           throws SAPGeneralSystemException
指定されたJCO.Table情報でBapiReturnを作成します。 引数のBAPI RETURN(Table)情報から属性に値をセットします｡

パラメータ:
tbl - JCO.Table
例外:
SAPGeneralSystemException - システム例外処理
メソッドの詳細

getField

public String getField()
フィールドを取得します｡

戻り値:
field

getId

public String getId()
ＩＤを取得します｡

戻り値:
id

getCode

public String getCode()
コードを取得します｡

戻り値:
code

getLogMsgNo

public String getLogMsgNo()
ログメッセージナンバーを取得します｡

戻り値:
logMsgNo

getLogNo

public String getLogNo()
ログナンバーを取得します｡

戻り値:
logNo

getMessage

public String getMessage()
メッセージを取得します｡

戻り値:
message

getMessageV1

public String getMessageV1()
メッセージＶ１を取得します｡

戻り値:
messageV1

getMessageV2

public String getMessageV2()
メッセージＶ２を取得します｡

戻り値:
messageV2

getMessageV3

public String getMessageV3()
メッセージＶ３を取得します｡

戻り値:
messageV3

getMessageV4

public String getMessageV4()
メッセージＶ４を取得します｡

戻り値:
messageV4

getNumber

public String getNumber()
ナンバーを取得します｡

戻り値:
number

getParameter

public String getParameter()
パラメーターを取得します｡

戻り値:
parameter

getRow

public String getRow()
行番号を取得します｡

戻り値:
row

getSystem

public String getSystem()
ＩＤを取得します｡

戻り値:
tableList

getType

public String getType()
タイプを取得します｡

戻り値:
type

setField

public void setField(String field)
フィールドを設定します｡

パラメータ:
field - BapiReturnのfieldの値

setId

public void setId(String id)
ＩＤを設定します｡

パラメータ:
id - BapiReturnのidの値

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
ログメッセージナンバーを設定します｡

パラメータ:
logMsgNo - BapiReturnのlogMsgNoの値

setLogNo

public void setLogNo(String logNo)
ログナンバーを設定します｡

パラメータ:
logNo - BapiReturnのlogNoの値

setMessage

public void setMessage(String message)
メッセージを設定します｡

パラメータ:
message - BapiReturnのmessageの値

setMessageV1

public void setMessageV1(String messageV1)
メッセージＶ１を設定します｡

パラメータ:
messageV1 - BapiReturnのmessageV1の値

setMessageV2

public void setMessageV2(String messageV2)
メッセージＶ２を設定します｡

パラメータ:
messageV2 - BapiReturnのmessageV2の値

setMessageV3

public void setMessageV3(String messageV3)
メッセージＶ３を設定します｡

パラメータ:
messageV3 - BapiReturnのmessageV3の値

setMessageV4

public void setMessageV4(String messageV4)
メッセージＶ４を設定します｡

パラメータ:
messageV4 - BapiReturnのmessageV4の値

setNumber

public void setNumber(String number)
ナンバーを設定します｡

パラメータ:
number - BapiReturnのnumberの値

setParameter

public void setParameter(String parameter)
パラメーターを設定します｡

パラメータ:
parameter - BapiReturnのparameterの値

setRow

public void setRow(String row)
行番号を設定します｡

パラメータ:
row - BapiReturnのrowの値

setSystem

public void setSystem(String system)
システムを設定します｡

パラメータ:
system - BapiReturnのsystemの値

setType

public void setType(String type)
タイプを設定します｡

パラメータ:
type - BapiReturnのtypeの値

setCode

public void setCode(String code)
コードを設定します｡

パラメータ:
code - BapiReturnのcodeの値

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConnectionManager (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス ConnectionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager
すべての実装インタフェース:
Serializable
public class ConnectionManager
extends Object
implements Serializable

ConnectionManagerクラス

R/3へのコネクション(トランザクション)を管理するクラスです。 commitとrollbackの2つのパブリックメソッドを持ち、業務ロジックの最後に実行することで R/3への変更を確定/取り消しすることができます。 なお、R/3へのコネクションの開放も上記2メソッド内で実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

関連項目:
直列化された形式

コンストラクタの概要
ConnectionManager()
メソッドの概要
void | commit() ＢＡＰＩ実行結果のCOMMIT処理を行います｡
void | rollback() ＢＡＰＩ実行結果のROLLBACK処理を行います｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConnectionManager

public ConnectionManager()
メソッドの詳細

commit

public void commit()
            throws SAPGeneralSystemException
ＢＡＰＩ実行結果のCOMMIT処理を行います｡

例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

rollback

public void rollback()
              throws SAPGeneralSystemException
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineProperty (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス LineProperty

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty
すべての実装インタフェース:
Serializable
public class LineProperty
extends Object
implements Serializable

LinePropertyクラス
機能は以下の通り

  • Propertyファイル１行ごとの情報を保持します｡
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
LineProperty(String propertyKey, String propertyValue)
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
メソッドの概要
String[] | getPropertyKeyPart() プロパティのキーを取得します｡
String | getPropertyValue() プロパティの値を取得します｡
String | getSeparateKey(int partIndex) 指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
void | setPropertyKeyPart(String[] propertyKeyPart) プロパティのキーを設定します｡
void | setPropertyValue(String propertyValue) プロパティの値を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LineProperty

public LineProperty(String propertyKey,
                    String propertyValue)
             throws SAPGeneralSystemException
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。

パラメータ:
propertyKey - PropertyKey
propertyValue - PropertyValue
例外:
SAPGeneralSystemException - システム例外処理
メソッドの詳細

getSeparateKey

public String getSeparateKey(int partIndex)
                      throws SAPGeneralAppException
指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
引数 = 0 の場合：入力／出力区分("import"/"export")
引数 = 1 の場合：パラメータ属性("import(export)"/"structure"/"table")
引数 = 2 の場合：パラメータ名
引数 = 3 の場合：コンポーネント名

パラメータ:
partIndex - propertyKeyPart（分割値の格納用配列）の要素を指定する添字
戻り値:
propertyKeyPart[]
例外:
SAPGeneralAppException - アプリケーション例外処理

getPropertyValue

public String getPropertyValue()
プロパティの値を取得します｡

戻り値:
propertyValue

getPropertyKeyPart

public String[] getPropertyKeyPart()
プロパティのキーを取得します｡

戻り値:
propertyKeyPart

setPropertyValue

public void setPropertyValue(String propertyValue)
プロパティの値を設定します｡

パラメータ:
propertyValue - PropertyValue

setPropertyKeyPart

public void setPropertyKeyPart(String[] propertyKeyPart)
プロパティのキーを設定します｡

パラメータ:
propertyKeyPart - propertyKeyPart

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.general_purpose (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.common.general_purpose
クラス
BapiController
BapiHash
BapiReturn
ConnectionManager
LineProperty


jp.co.intra_mart.foundation.sap.common.general_purpose (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

クラスの概要
BapiController | BAPIコントローラクラス 機能は以下の通り ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡ 展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開メソッドを使用して取得します｡
BapiHash | BapiHashクラス 機能は以下の通り 汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡ R/3のBAPI処理にて使用されるパラメータの値を保持します。
BapiReturn | BapiReturnクラス 機能は以下の通り R/3のBAPI処理の実行結果に関する値を保持します。
ConnectionManager | ConnectionManagerクラス R/3へのコネクション(トランザクション)を管理するクラスです。
LineProperty | LinePropertyクラス 機能は以下の通り Propertyファイル１行ごとの情報を保持します｡ 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の説明

ＳＡＰ連携に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


jp.co.intra_mart.foundation.sap.common.general_purpose クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose の使用

jp.co.intra_mart.foundation.sap.common.general_purpose を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiReturn
BapiReturnクラス
機能は以下の通り
R/3のBAPI処理の実行結果に関する値を保持します。
ConnectionManager
ConnectionManagerクラス
R/3へのコネクション(トランザクション)を管理するクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.data.Convertor の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.data.Convertor の使用

jp.co.intra_mart.foundation.sap.common.util.data.Convertor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


Convertor (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.data
クラス Convertor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.data.Convertor
すべての実装インタフェース:
Serializable
public final class Convertor
extends Object
implements Serializable

Converterクラス
機能は以下の通り

  • SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。

関連項目:
直列化された形式

メソッドの概要
static String convJCOdata(int typ, int len, Object val)
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

convJCOdata

public static String convJCOdata(int typ,
                                 int len,
                                 Object val)
                          throws SAPGeneralSystemException
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。それ以外のパラメータ属性の場合は無変換で 文字列を返します｡

パラメータ:
typ - 設定する項目の属性
len - 設定する項目の項目長
val - 変換対象オブジェクト
戻り値:
retVal 変換後文字列
例外:
SAPGeneralSystemException - システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util.data (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.common.util.data
クラス
Convertor


jp.co.intra_mart.foundation.sap.common.util.data (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.data

ＳＡＰ連携にて使用するデータ変換クラスを提供します。

参照:
説明

クラスの概要
Convertor Converterクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.data の説明

ＳＡＰ連携にて使用するデータ変換クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


jp.co.intra_mart.foundation.sap.common.util.data クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.data.Convertor (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


パッケージ jp.co.intra_mart.foundation.sap.common.util.data の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.data の使用

jp.co.intra_mart.foundation.sap.common.util.data はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の使用

jp.co.intra_mart.foundation.sap.common.util.date.DateHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


DateHandler (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.date
クラス DateHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.date.DateHandler
すべての実装インタフェース:
Serializable
public final class DateHandler
extends Object
implements Serializable

DateHandlerクラス
機能は以下の通り

  • SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

関連項目:
直列化された形式

メソッドの概要
static Date | getDateValue(String strValue) 日付書式[YYYYMMDD]の文字列をDate型に変換します。
static String | getStringDate(Date date) Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。
static String | getSysdate() システム日付を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getSysdate

public static String getSysdate()
システム日付を取得します。

戻り値:
nowDate システム日付[YYYYMMDD]

getStringDate

public static String getStringDate(Date date)
Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。

パラメータ:
date - 日付書式変換前Date型オブジェクト
戻り値:
date 日付書式変換後文字列[YYYYMMDD]

getDateValue

public static Date getDateValue(String strValue)
                         throws ParseException
日付書式[YYYYMMDD]の文字列をDate型に変換します。

パラメータ:
strValue - 日付書式[YYYYMMDD]の文字列
戻り値:
dateValue Date型に変換後の値
例外:
ParseException - 日付変換システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util.date (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.common.util.date
クラス
DateHandler


jp.co.intra_mart.foundation.sap.common.util.date (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.date

ＳＡＰ連携にて使用する日付操作クラスを提供します。

参照:
説明

クラスの概要
DateHandler DateHandlerクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.date の説明

ＳＡＰ連携にて使用する日付操作クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


jp.co.intra_mart.foundation.sap.common.util.date クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.date の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


パッケージ jp.co.intra_mart.foundation.sap.common.util.date の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.date の使用

jp.co.intra_mart.foundation.sap.common.util.date はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile の使用

jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.util.file (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.common.util.file
クラス
PropertiesFile


jp.co.intra_mart.foundation.sap.common.util.file (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.file

ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。

参照:
説明

クラスの概要
PropertiesFile プロパティファイルクラス
機能は以下の通り
ファイル名を指定してプロパティファイルを呼び出します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.file の説明

ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


jp.co.intra_mart.foundation.sap.common.util.file クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


パッケージ jp.co.intra_mart.foundation.sap.common.util.file の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.file の使用

jp.co.intra_mart.foundation.sap.common.util.file はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


PropertiesFile (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.file
クラス PropertiesFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile
すべての実装インタフェース:
Serializable
public class PropertiesFile
extends Object
implements Serializable

プロパティファイルクラス
機能は以下の通り

  • ファイル名を指定してプロパティファイルを呼び出します。

関連項目:
直列化された形式

コンストラクタの概要
PropertiesFile(String fileName)
ファイル名を指定してプロパティファイルを取得します。
メソッドの概要
Properties | getProperties() プロパティを取得します｡
void | setPropeties(Properties properties) プロパティを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertiesFile

public PropertiesFile(String fileName)
               throws SAPAuthSystemException
ファイル名を指定してプロパティファイルを取得します。

パラメータ:
fileName - ファイル名
例外:
SAPAuthSystemException - 認証系システム例外
メソッドの詳細

setPropeties

public void setPropeties(Properties properties)
プロパティを設定します｡

パラメータ:
properties - プロパティ

getProperties

public Properties getProperties()
プロパティを取得します｡

戻り値:
properties

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountGl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountTax はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用

jp.co.intra_mart.foundation.sap.module.accounting.Bank はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BankController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用

BankList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BankList の使用

BankList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BankList BankController.getBaList()
銀行一覧を取得します｡

BankList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BankController.setBaList(BankList baList)
銀行一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用

BusinessAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BusinessAreaList の使用

BusinessAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BusinessAreaList BusinessAreaController.getBusAreaList()
事業領域一覧を取得します｡

BusinessAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BusinessAreaController.setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Company の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Company の使用

jp.co.intra_mart.foundation.sap.module.accounting.Company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CompanyController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用

CompanyList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CompanyList の使用

CompanyList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CompanyList CompanyController.getCompList()
会社一覧を取得します｡

CompanyList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CompanyController.setCompList(CompanyList compList)
会社一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用

ControllingAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ControllingAreaList の使用

ControllingAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ControllingAreaList ControllingAreaController.getControllAreaList()
管理領域一覧を取得します｡

ControllingAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ControllingAreaController.setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用

CostCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CostCenterList の使用

CostCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CostCenterList CostCenterController.getCostCentList()
原価センタ一覧を取得します｡

CostCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CostCenterController.setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用

jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用

DocumentHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での DocumentHeader の使用

DocumentHeader を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 DocumentHeader AccEmployeePayPostController.getDocumentHeader()
伝票ヘッダを取得します｡

DocumentHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAcc はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAccController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用

GlAccList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での GlAccList の使用

GlAccList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 GlAccList GlAccController.getGlList()
勘定科目一覧を取得します｡

GlAccList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void GlAccController.setGlList(GlAccList glList)
勘定科目一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用

ProfitCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ProfitCenterList の使用

ProfitCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ProfitCenterList ProfitCenterController.getProfitCentList()
利益センタ一覧を取得します｡

ProfitCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ProfitCenterController.setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用

SAPAccountingAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingAppException の使用

SAPAccountingAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用

SAPAccountingSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingSystemException の使用

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
String | ProfitCenterController.getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
String | ProfitCenterController.getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
String | ProfitCenterController.getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | GlAccController.getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
String | GlAccController.getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | CostCenterController.getName(String costCenter) 原価センタを指定して一般名称を取得します。
String | CostCenterController.getDescript(String costCenter) 原価センタを指定してテキストを取得します。
String | ControllingAreaController.getName(String coArea) 管理領域を指定して管理領域名を取得します。
String | CompanyController.getCompName(String compCode) 会社コードを指定して会社名を取得します。
String | BusinessAreaController.getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
String | BankController.getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | BankController.getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | AccEmployeePayPostController.executeBapi() BapiControllerにより会計伝票を登録します。

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList()
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.accounting.exception (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.module.accounting.exception
例外
SAPAccountingAppException
SAPAccountingSystemException


jp.co.intra_mart.foundation.sap.module.accounting.exception (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

ＳＡＰ連携会計系例外クラスを提供します。

参照:
説明

例外の概要
SAPAccountingAppException | 会計系APIアプリケーション例外クラス
SAPAccountingSystemException | 会計系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の説明

ＳＡＰ連携会計系例外クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.accounting.exception クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
        • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting.exception のクラス
SAPAccountingAppException
会計系APIアプリケーション例外クラス
SAPAccountingSystemException
会計系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


SAPAccountingAppException (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
すべての実装インタフェース:
Serializable
public class SAPAccountingAppException
extends Exception

会計系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingAppException(String message)
会計系APIアプリケーション例外
SAPAccountingAppException(String message, Throwable ex)
会計系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingAppException

public SAPAccountingAppException(String message,
                                 Throwable ex)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAccountingAppException

public SAPAccountingAppException(String message)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAccountingSystemException (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
すべての実装インタフェース:
Serializable
public class SAPAccountingSystemException
extends Exception

会計系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingSystemException(String message, Throwable ex)
会計系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingSystemException

public SAPAccountingSystemException(String message,
                                    Throwable ex)
会計系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccEmployeePayPostController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccEmployeePayPostController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController
すべての実装インタフェース:
Serializable
public class AccEmployeePayPostController
extends Object
implements Serializable

伝票登録コントローラクラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

コンストラクタの概要
AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
メソッドの概要
void | executeBapi() BapiControllerにより会計伝票を登録します。
ArrayList | getAccountGlList() G/L 勘定明細一覧を取得します｡
ArrayList | getAccountPayableList() 仕入先明細一覧を取得します｡
ArrayList | getAccountTaxList() 税明細一覧を取得します｡
ArrayList | getCurrencyAmountList() 明細通貨項目一覧を取得します｡
DocumentHeader | getDocumentHeader() 伝票ヘッダを取得します｡
void | setAccountGlList(ArrayList accountGlList) G/L 勘定明細一覧を設定します｡
void | setAccountPayableList(ArrayList accountPayableList) 仕入先明細一覧を設定します｡
void | setAccountTaxList(ArrayList accountTaxList) 税明細一覧を設定します｡
void | setCuAmtBase(String cuAmtBase, int index) 明細通貨項目の課税基準額に値を設定します。
void | setCuAmtDoccur(String cuAmtDoccur, int index) 明細通貨項目の伝票通貨額に値を設定します。
void | setCuCurrency(String cuCurrency, int index) 明細通貨項目の通貨コードに値を設定します。
void | setCuItemnoAcc(String cuItemnoAcc, int index) 明細通貨項目の会計伝票明細番号に値を設定します。
void | setCurrencyAmountList(ArrayList currencyAmountList) 明細通貨項目一覧を設定します｡
void | setDocAcDocNo(String docAcDocNo) 伝票ヘッダの会計伝票番号に値を設定します。
void | setDocCompCode(String docCompCode) 伝票ヘッダの会社コードに値を設定します。
void | setDocDocDate(String docDocDate) 伝票ヘッダの伝票の伝票日付に値を設定します。
void | setDocDocType(String docDocType) 伝票ヘッダの伝票タイプに値を設定します。
void | setDocFiscYear(String docFiscYear) 伝票ヘッダの会計年度に値を設定します。
void | setDocFisPeriod(String docFisPeriod) 伝票ヘッダの会計期間に値を設定します。
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダの伝票ヘッダテキストに値を設定します。
void | setDocObjKey(String docObjKey) 伝票ヘッダのオブジェクトキーに値を設定します。
void | setDocObjType(String docObjType) 伝票ヘッダの参照処理に値を設定します。
void | setDocPstngDate(String docPstngDate) 伝票ヘッダの伝票の転記日付に値を設定します。
void | setDocRefDocNo(String docRefDocNo) 伝票ヘッダの参照伝票番号に値を設定します。
void | setDocumentHeader(DocumentHeader documentHeader) 伝票ヘッダを設定します｡
void | setDocUsername(String docUsername) 伝票ヘッダのユーザ名に値を設定します。
void | setGlAllocNmbr(String glAllocNmbr, int index) G/L 勘定明細のソートキーに値を設定します。
void | setGlBusArea(String glBusArea, int index) G/L 勘定明細の事業領域に値を設定します。
void | setGlCompCode(String glCompCode, int index) G/L 勘定明細の会社コードに値を設定します。
void | setGlCostcenter(String glCostcenter, int index) G/L 勘定明細の原価センタに値を設定します。
void | setGlDocType(String glDocType, int index) G/L 勘定明細の伝票タイプに値を設定します。
void | setGlFiscYear(String glFiscYear, int index) G/L 勘定明細の会計年度に値を設定します。
void | setGlGlAccount(String glGlAccount, int index) G/L 勘定明細の総勘定元帳勘定に値を設定します。
void | setGlItemnoAcc(String glItemnoAcc, int index) G/L 勘定明細の会計伝票明細番号に値を設定します。
void | setGlItemText(String glItemText, int index) G/L 勘定明細の明細テキストに値を設定します。
void | setGlOrderid(String glOrderid, int index) G/L 勘定明細の指図番号に値を設定します。
void | setGlPstngDate(String glPstngDate, int index) G/L 勘定明細の伝票の転記日付に値を設定します。
void | setGlRefKey1(String glRefKey1, int index) G/L 勘定明細の取引先参照キーに値を設定します。
void | setGlTaxCode(String glTaxCode, int index) G/L 勘定明細の消費税コードに値を設定します。
void | setGlWbsElement(String glWbsElement, int index) G/L 勘定明細のWBS 要素に値を設定します。
void | setPaAllocNmbr(String paAllocNmbr, int index) 仕入先明細のソートキーに値を設定します。
void | setPaBlineDate(String paBlineDate, int index) 仕入先明細の期日計算の支払基準日に値を設定します。
void | setPaGlAccount(String paGlAccount, int index) 仕入先明細の総勘定元帳勘定に値を設定します。
void | setPaItemnoAcc(String paItemnoAcc, int index) 仕入先明細の会計伝票明細番号に値を設定します。
void | setPaItemText(String paItemText, int index) 仕入先明細の明細テキストに値を設定します。
void | setPaPymtMeth(String paPymtMeth, int index) 仕入先明細の支払方法に値を設定します。
void | setPaVendorNo(String paVendorNo, int index) 仕入先明細の仕入先または債権者の勘定コードに値を設定します。
void | setTaGlAccount(String taGlAccount, int index) 税明細の総勘定元帳勘定に値を設定します。
void | setTaItemnoAcc(String taItemnoAcc, int index) 税明細の会計伝票明細番号に値を設定します。
void | setTaTaxCode(String taTaxCode, int index) 税明細の消費税コードに値を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccEmployeePayPostController

public AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡

メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingAppException,
                        SAPAccountingSystemException
BapiControllerにより会計伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingAppException - 会計業務アプリケーション例外
SAPAccountingSystemException - 会計業務システム例外

setDocObjType

public void setDocObjType(String docObjType)
伝票ヘッダの参照処理に値を設定します。

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
伝票ヘッダのオブジェクトキーに値を設定します。

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
伝票ヘッダのユーザ名に値を設定します。

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダの伝票ヘッダテキストに値を設定します。

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
伝票ヘッダの会社コードに値を設定します。

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
伝票ヘッダの会計伝票番号に値を設定します。

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
伝票ヘッダの会計年度に値を設定します。

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票ヘッダの伝票の伝票日付に値を設定します。

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票ヘッダの伝票の転記日付に値を設定します。

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
伝票ヘッダの会計期間に値を設定します。

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票ヘッダの伝票タイプに値を設定します。

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
伝票ヘッダの参照伝票番号に値を設定します。

パラメータ:
docRefDocNo - 参照伝票番号

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc,
                           int index)
仕入先明細の会計伝票明細番号に値を設定します。

パラメータ:
paItemnoAcc - 会計伝票明細番号
index - レコード番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo,
                          int index)
仕入先明細の仕入先または債権者の勘定コードに値を設定します。

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード
index - レコード番号

setPaGlAccount

public void setPaGlAccount(String paGlAccount,
                           int index)
仕入先明細の総勘定元帳勘定に値を設定します。

パラメータ:
paGlAccount - 総勘定元帳勘定
index - レコード番号

setPaBlineDate

public void setPaBlineDate(String paBlineDate,
                           int index)
仕入先明細の期日計算の支払基準日に値を設定します。

パラメータ:
paBlineDate - 期日計算の支払基準日
index - レコード番号

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth,
                          int index)
仕入先明細の支払方法に値を設定します。

パラメータ:
paPymtMeth - 支払方法
index - レコード番号

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr,
                           int index)
仕入先明細のソートキーに値を設定します。

パラメータ:
paAllocNmbr - ソートキー
index - レコード番号

setPaItemText

public void setPaItemText(String paItemText,
                          int index)
仕入先明細の明細テキストに値を設定します。

パラメータ:
paItemText - 明細テキスト
index - レコード番号

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc,
                           int index)
G/L 勘定明細の会計伝票明細番号に値を設定します。

パラメータ:
glItemnoAcc - 会計伝票明細番号
index - レコード番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount,
                           int index)
G/L 勘定明細の総勘定元帳勘定に値を設定します。

パラメータ:
glGlAccount - 総勘定元帳勘定
index - レコード番号

setGlCompCode

public void setGlCompCode(String glCompCode,
                          int index)
G/L 勘定明細の会社コードに値を設定します。

パラメータ:
glCompCode - 会社コード
index - レコード番号

setGlPstngDate

public void setGlPstngDate(String glPstngDate,
                           int index)
G/L 勘定明細の伝票の転記日付に値を設定します。

パラメータ:
glPstngDate - 伝票の転記日付
index - レコード番号

setGlDocType

public void setGlDocType(String glDocType,
                         int index)
G/L 勘定明細の伝票タイプに値を設定します。

パラメータ:
glDocType - 伝票タイプ
index - レコード番号

setGlFiscYear

public void setGlFiscYear(String glFiscYear,
                          int index)
G/L 勘定明細の会計年度に値を設定します。

パラメータ:
glFiscYear - 会計年度
index - レコード番号

setGlRefKey1

public void setGlRefKey1(String glRefKey1,
                         int index)
G/L 勘定明細の取引先参照キーに値を設定します。

パラメータ:
glRefKey1 - 取引先参照キー
index - レコード番号

setGlItemText

public void setGlItemText(String glItemText,
                          int index)
G/L 勘定明細の明細テキストに値を設定します。

パラメータ:
glItemText - 明細テキスト
index - レコード番号

setGlTaxCode

public void setGlTaxCode(String glTaxCode,
                         int index)
G/L 勘定明細の消費税コードに値を設定します。

パラメータ:
glTaxCode - 消費税コード
index - レコード番号

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr,
                           int index)
G/L 勘定明細のソートキーに値を設定します。

パラメータ:
glAllocNmbr - ソートキー
index - レコード番号

setGlBusArea

public void setGlBusArea(String glBusArea,
                         int index)
G/L 勘定明細の事業領域に値を設定します。

パラメータ:
glBusArea - 事業領域
index - レコード番号

setGlCostcenter

public void setGlCostcenter(String glCostcenter,
                            int index)
G/L 勘定明細の原価センタに値を設定します。

パラメータ:
glCostcenter - 原価センタ
index - レコード番号

setGlOrderid

public void setGlOrderid(String glOrderid,
                         int index)
G/L 勘定明細の指図番号に値を設定します。

パラメータ:
glOrderid - 指図番号
index - レコード番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement,
                            int index)
G/L 勘定明細のWBS 要素に値を設定します。

パラメータ:
glWbsElement - WBS 要素
index - レコード番号

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc,
                           int index)
税明細の会計伝票明細番号に値を設定します。

パラメータ:
taItemnoAcc - 会計伝票明細番号
index - レコード番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount,
                           int index)
税明細の総勘定元帳勘定に値を設定します。

パラメータ:
taGlAccount - 総勘定元帳勘定
index - レコード番号

setTaTaxCode

public void setTaTaxCode(String taTaxCode,
                         int index)
税明細の消費税コードに値を設定します。

パラメータ:
taTaxCode - 消費税コード
index - レコード番号

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc,
                           int index)
明細通貨項目の会計伝票明細番号に値を設定します。

パラメータ:
cuItemnoAcc - 会計伝票明細番号
index - レコード番号

setCuCurrency

public void setCuCurrency(String cuCurrency,
                          int index)
明細通貨項目の通貨コードに値を設定します。

パラメータ:
cuCurrency - 通貨コード
index - レコード番号

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur,
                           int index)
明細通貨項目の伝票通貨額に値を設定します。

パラメータ:
cuAmtDoccur - 伝票通貨額
index - レコード番号

setCuAmtBase

public void setCuAmtBase(String cuAmtBase,
                         int index)
明細通貨項目の課税基準額に値を設定します。

パラメータ:
cuAmtBase - 課税基準額
index - レコード番号

setDocumentHeader

public void setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

パラメータ:
documentHeader - 伝票ヘッダ

setAccountPayableList

public void setAccountPayableList(ArrayList accountPayableList)
仕入先明細一覧を設定します｡

パラメータ:
accountPayableList - 仕入先明細一覧

setAccountGlList

public void setAccountGlList(ArrayList accountGlList)
G/L 勘定明細一覧を設定します｡

パラメータ:
accountGlList - G/L 勘定明細一覧

setAccountTaxList

public void setAccountTaxList(ArrayList accountTaxList)
税明細一覧を設定します｡

パラメータ:
accountTaxList - 税明細一覧

setCurrencyAmountList

public void setCurrencyAmountList(ArrayList currencyAmountList)
明細通貨項目一覧を設定します｡

パラメータ:
currencyAmountList - 明細通貨項目一覧

getDocumentHeader

public DocumentHeader getDocumentHeader()
伝票ヘッダを取得します｡

戻り値:
documentHeader

getAccountPayableList

public ArrayList getAccountPayableList()
仕入先明細一覧を取得します｡

戻り値:
accountPayableList

getAccountGlList

public ArrayList getAccountGlList()
G/L 勘定明細一覧を取得します｡

戻り値:
accountGlList

getAccountTaxList

public ArrayList getAccountTaxList()
税明細一覧を取得します｡

戻り値:
accountTaxList

getCurrencyAmountList

public ArrayList getCurrencyAmountList()
明細通貨項目一覧を取得します｡

戻り値:
accountTaxList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountGl (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountGl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountGl
すべての実装インタフェース:
Serializable
public class AccountGl
extends Object
implements Serializable

G/L 勘定明細クラス
機能は以下の通り

  • G/L 勘定明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountGl(int index)
G/L 勘定明細情報を作成します。
メソッドの概要
String | getGlAllocNmbr() ソートキーを取得します｡
String | getGlBusArea() 事業領域を取得します｡
String | getGlCompCode() 会社コードを取得します｡
String | getGlCostcenter() 原価センタを取得します｡
String | getGlDocType() 伝票タイプを取得します｡
String | getGlFiscYear() 会計年度を取得します｡
String | getGlGlAccount() 総勘定元帳勘定を取得します｡
int | getGlIndex() レコード番号を取得します｡
String | getGlItemnoAcc() 会計伝票明細番号を取得します｡
String | getGlItemText() 明細テキストを取得します｡
String | getGlOrderid() 指図番号を取得します｡
String | getGlPstngDate() 伝票の転記日付を取得します｡
String | getGlRefKey1() 取引先参照キーを取得します｡
String | getGlTaxCode() 消費税コードを取得します｡
String | getGlWbsElement() WBS 要素を取得します｡
void | setGlAllocNmbr(String glAllocNmbr) ソートキーコードを設定します｡
void | setGlBusArea(String glBusArea) 事業領域コードを設定します｡
void | setGlCompCode(String glCompCode) 会社コードコードを設定します｡
void | setGlCostcenter(String glCostcenter) 原価センタコードを設定します｡
void | setGlDocType(String glDocType) 伝票タイプコードを設定します｡
void | setGlFiscYear(String glFiscYear) 会計年度コードを設定します｡
void | setGlGlAccount(String glGlAccount) 総勘定元帳勘定コードを設定します｡
void | setGlIndex(int glIndex) レコード番号を設定します｡
void | setGlItemnoAcc(String glItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setGlItemText(String glItemText) 明細テキストコードを設定します｡
void | setGlOrderid(String glOrderid) 指図番号コードを設定します｡
void | setGlPstngDate(String glPstngDate) 伝票の転記日付コードを設定します｡
void | setGlRefKey1(String glRefKey1) 取引先参照キーコードを設定します｡
void | setGlTaxCode(String glTaxCode) 消費税コードコードを設定します｡
void | setGlWbsElement(String glWbsElement) WBS 要素コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountGl

public AccountGl(int index)
G/L 勘定明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
glItemnoAcc - 会計伝票明細番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
glGlAccount - 総勘定元帳勘定

setGlCompCode

public void setGlCompCode(String glCompCode)
会社コードコードを設定します｡

パラメータ:
glCompCode - 会社コード

setGlPstngDate

public void setGlPstngDate(String glPstngDate)
伝票の転記日付コードを設定します｡

パラメータ:
glPstngDate - 伝票の転記日付

setGlDocType

public void setGlDocType(String glDocType)
伝票タイプコードを設定します｡

パラメータ:
glDocType - 伝票タイプ

setGlFiscYear

public void setGlFiscYear(String glFiscYear)
会計年度コードを設定します｡

パラメータ:
glFiscYear - 会計年度

setGlRefKey1

public void setGlRefKey1(String glRefKey1)
取引先参照キーコードを設定します｡

パラメータ:
glRefKey1 - 取引先参照キー

setGlItemText

public void setGlItemText(String glItemText)
明細テキストコードを設定します｡

パラメータ:
glItemText - 明細テキスト

setGlTaxCode

public void setGlTaxCode(String glTaxCode)
消費税コードコードを設定します｡

パラメータ:
glTaxCode - 消費税コード

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr)
ソートキーコードを設定します｡

パラメータ:
glAllocNmbr - ソートキー

setGlBusArea

public void setGlBusArea(String glBusArea)
事業領域コードを設定します｡

パラメータ:
glBusArea - 事業領域

setGlCostcenter

public void setGlCostcenter(String glCostcenter)
原価センタコードを設定します｡

パラメータ:
glCostcenter - 原価センタ

setGlOrderid

public void setGlOrderid(String glOrderid)
指図番号コードを設定します｡

パラメータ:
glOrderid - 指図番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement)
WBS 要素コードを設定します｡

パラメータ:
glWbsElement - WBS 要素

setGlIndex

public void setGlIndex(int glIndex)
レコード番号を設定します｡

パラメータ:
glIndex - レコード番号

getGlItemnoAcc

public String getGlItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
glItemnoAcc

getGlGlAccount

public String getGlGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
glGlAccount

getGlCompCode

public String getGlCompCode()
会社コードを取得します｡

戻り値:
glCompCode

getGlPstngDate

public String getGlPstngDate()
伝票の転記日付を取得します｡

戻り値:
glPstngDate

getGlDocType

public String getGlDocType()
伝票タイプを取得します｡

戻り値:
glDocType

getGlFiscYear

public String getGlFiscYear()
会計年度を取得します｡

戻り値:
glFiscYear

getGlRefKey1

public String getGlRefKey1()
取引先参照キーを取得します｡

戻り値:
glRefKey1

getGlItemText

public String getGlItemText()
明細テキストを取得します｡

戻り値:
glItemText

getGlTaxCode

public String getGlTaxCode()
消費税コードを取得します｡

戻り値:
glTaxCode

getGlAllocNmbr

public String getGlAllocNmbr()
ソートキーを取得します｡

戻り値:
glAllocNmbr

getGlBusArea

public String getGlBusArea()
事業領域を取得します｡

戻り値:
glBusArea

getGlCostcenter

public String getGlCostcenter()
原価センタを取得します｡

戻り値:
glCostcenter

getGlOrderid

public String getGlOrderid()
指図番号を取得します｡

戻り値:
glOrderid

getGlWbsElement

public String getGlWbsElement()
WBS 要素を取得します｡

戻り値:
glWbsElement

getGlIndex

public int getGlIndex()
レコード番号を取得します｡

戻り値:
giIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountPayable (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountPayable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable
すべての実装インタフェース:
Serializable
public class AccountPayable
extends Object
implements Serializable

仕入先明細クラス
機能は以下の通り

  • 仕入先明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountPayable(int index)
仕入先明細情報を作成します。
メソッドの概要
String | getPaAllocNmbr() ソートキーを取得します｡
String | getPaBlineDate() 期日計算の支払基準日を取得します｡
String | getPaGlAccount() 総勘定元帳勘定を取得します｡
int | getPaIndex() レコード番号を取得します｡
String | getPaItemnoAcc() 会計伝票明細番号を取得します｡
String | getPaItemText() 明細テキストを取得します｡
String | getPaPymtMeth() 支払方法を取得します｡
String | getPaVendorNo() 仕入先または債権者の勘定コードを取得します｡
void | setPaAllocNmbr(String paAllocNmbr) ソートキーコードを設定します｡
void | setPaBlineDate(String paBlineDate) 期日計算の支払基準日コードを設定します｡
void | setPaGlAccount(String paGlAccount) 総勘定元帳勘定コードを設定します｡
void | setPaIndex(int paIndex) レコード番号を設定します｡
void | setPaItemnoAcc(String paItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setPaItemText(String paItemText) 明細テキストコードを設定します｡
void | setPaPymtMeth(String paPymtMeth) 支払方法を設定します｡
void | setPaVendorNo(String paVendorNo) 仕入先または債権者の勘定コードコードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountPayable

public AccountPayable(int index)
仕入先明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
paItemnoAcc - 会計伝票明細番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo)
仕入先または債権者の勘定コードコードを設定します｡

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード

setPaGlAccount

public void setPaGlAccount(String paGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
paGlAccount - 総勘定元帳勘定

setPaBlineDate

public void setPaBlineDate(String paBlineDate)
期日計算の支払基準日コードを設定します｡

パラメータ:
paBlineDate - 期日計算の支払基準日

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth)
支払方法を設定します｡

パラメータ:
paPymtMeth - 支払方法

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr)
ソートキーコードを設定します｡

パラメータ:
paAllocNmbr - ソートキー

setPaItemText

public void setPaItemText(String paItemText)
明細テキストコードを設定します｡

パラメータ:
paItemText - 明細テキスト

setPaIndex

public void setPaIndex(int paIndex)
レコード番号を設定します｡

パラメータ:
paIndex - レコード番号

getPaItemnoAcc

public String getPaItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
paItemnoAcc

getPaVendorNo

public String getPaVendorNo()
仕入先または債権者の勘定コードを取得します｡

戻り値:
paVendorNo

getPaGlAccount

public String getPaGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
paGlAccount

getPaBlineDate

public String getPaBlineDate()
期日計算の支払基準日を取得します｡

戻り値:
paBlineDate

getPaPymtMeth

public String getPaPymtMeth()
支払方法を取得します｡

戻り値:
paPymtMeth

getPaAllocNmbr

public String getPaAllocNmbr()
ソートキーを取得します｡

戻り値:
paAllocNmbr

getPaItemText

public String getPaItemText()
明細テキストを取得します｡

戻り値:
paItemText

getPaIndex

public int getPaIndex()
レコード番号を取得します｡

戻り値:
paIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountTax (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountTax

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountTax
すべての実装インタフェース:
Serializable
public class AccountTax
extends Object
implements Serializable

税明細クラス
機能は以下の通り

  • 税明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountTax(int index)
指定されたレコード番号でAccountTaxを作成します｡
メソッドの概要
String | getTaGlAccount() 総勘定元帳勘定を取得します｡
int | getTaIndex() レコード番号を取得します｡
String | getTaItemnoAcc() 会計伝票明細番号を取得します｡
String | getTaTaxCode() 消費税コードを取得します｡
void | setTaGlAccount(String taGlAccount) 総勘定元帳勘定コードを設定します｡
void | setTaIndex(int taIndex) レコード番号を設定します｡
void | setTaItemnoAcc(String taItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setTaTaxCode(String taTaxCode) 消費税コードコードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountTax

public AccountTax(int index)
指定されたレコード番号でAccountTaxを作成します｡

パラメータ:
index - レコード番号
メソッドの詳細

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
taItemnoAcc - 会計伝票明細番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
taGlAccount - 総勘定元帳勘定

setTaTaxCode

public void setTaTaxCode(String taTaxCode)
消費税コードコードを設定します｡

パラメータ:
taTaxCode - 消費税コード

setTaIndex

public void setTaIndex(int taIndex)
レコード番号を設定します｡

パラメータ:
taIndex - レコード番号

getTaItemnoAcc

public String getTaItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
taItemnoAcc

getTaGlAccount

public String getTaGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
taGlAccount

getTaTaxCode

public String getTaTaxCode()
消費税コードを取得します｡

戻り値:
taTaxCode

getTaIndex

public int getTaIndex()
レコード番号を取得します｡

戻り値:
tadex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Bank (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Bank

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Bank
すべての実装インタフェース:
Serializable
public class Bank
extends Object
implements Serializable

銀行情報クラス
機能は以下の通り

  • 銀行の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Bank()
銀行情報を作成します。
メソッドの概要
String | getBankKey() 銀行コードを取得します｡
String | getBankName() 銀行名を取得します｡
String | getCity() 市区町村名を取得します｡
void | setBankKey(String bankKey) 銀行コードを設定します｡
void | setBankName(String bankName) 銀行名を設定します｡
void | setCity(String city) 市区町村名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Bank

public Bank()
銀行情報を作成します。

メソッドの詳細

setBankKey

public void setBankKey(String bankKey)
銀行コードを設定します｡

パラメータ:
bankKey - 銀行コード

setBankName

public void setBankName(String bankName)
銀行名を設定します｡

パラメータ:
bankName - 銀行名

setCity

public void setCity(String city)
市区町村名を設定します｡

パラメータ:
city - 市区町村名

getBankKey

public String getBankKey()
銀行コードを取得します｡

戻り値:
bankKey

getBankName

public String getBankName()
銀行名を取得します｡

戻り値:
bankName

getCity

public String getCity()
市区町村名を取得します｡

戻り値:
city

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankController
すべての実装インタフェース:
Serializable
public class BankController
extends Object
implements Serializable

銀行コントローラクラス
機能は以下の通り

  • 銀行の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
メソッドの概要
BankList | getBaList() 銀行一覧を取得します｡
ArrayList | getBankList() 銀行一覧を取得します。
String | getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | setBaList(BankList baList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankController

public BankController()
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBankList

public ArrayList getBankList()
銀行一覧を取得します。

戻り値:
bankList 銀行一覧

getBankName

public String getBankName(String bankKey)
                   throws SAPAccountingSystemException
銀行コードを指定して銀行名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
bankName 銀行名
例外:
SAPAccountingSystemException - 会計業務システム例外

getCity

public String getCity(String bankKey)
               throws SAPAccountingSystemException
銀行コードを指定して市区町村名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
city 市区町村名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBaList

public void setBaList(BankList baList)
銀行一覧を設定します｡

パラメータ:
baList - 銀行一覧

getBaList

public BankList getBaList()
銀行一覧を取得します｡

戻り値:
baList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankList (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankList
すべての実装インタフェース:
Serializable
public class BankList
extends Object
implements Serializable

銀行一覧クラス
機能は以下の通り

  • 銀行の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
BankList()
executeBapiを呼び出し銀行一覧を作成します。
メソッドの概要
ArrayList | getBankList() 銀行一覧を取得します｡
void | setBankList(ArrayList bankList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankList

public BankList()
         throws SAPAuthAppException,
                SAPAuthSystemException,
                SAPGeneralAppException,
                SAPGeneralSystemException,
                SAPAccountingSystemException
executeBapiを呼び出し銀行一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBankList

public void setBankList(ArrayList bankList)
銀行一覧を設定します｡

パラメータ:
bankList - 銀行一覧

getBankList

public ArrayList getBankList()
銀行一覧を取得します｡

戻り値:
bankList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessArea (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea
すべての実装インタフェース:
Serializable
public class BusinessArea
extends Object
implements Serializable

事業領域情報クラス
機能は以下の通り

  • 事業領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessArea()
事業領域情報を作成します。
メソッドの概要
String | getBusArDes() 事業領域名を取得します｡
String | getBusArea() 事業領域を取得します｡
void | setBusArDes(String busArDes) 事業領域名を設定します｡
void | setBusArea(String busArea) 事業領域を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessArea

public BusinessArea()
事業領域情報を作成します。

メソッドの詳細

setBusArea

public void setBusArea(String busArea)
事業領域を設定します｡

パラメータ:
busArea - 事業領域

setBusArDes

public void setBusArDes(String busArDes)
事業領域名を設定します｡

パラメータ:
busArDes - 事業領域名

getBusArea

public String getBusArea()
事業領域を取得します｡

戻り値:
businessAreaCode

getBusArDes

public String getBusArDes()
事業領域名を取得します｡

戻り値:
busArDes

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController
すべての実装インタフェース:
Serializable
public class BusinessAreaController
extends Object
implements Serializable

事業領域コントローラクラス
機能は以下の通り

  • 事業領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
メソッドの概要
String | getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
BusinessAreaList | getBusAreaList() 事業領域一覧を取得します｡
ArrayList | getBusinessAreaList() 事業領域一覧を取得します。
void | setBusAreaList(BusinessAreaList busAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaController

public BusinessAreaController()
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧を取得します。

戻り値:
businessAreaList 事業領域一覧

getBusArDes

public String getBusArDes(String busArea)
                   throws SAPAccountingSystemException
事業領域を指定して事業領域名を取得します。

パラメータ:
busArea - 事業領域
戻り値:
busArDes 事業領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBusAreaList

public void setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

パラメータ:
busAreaList - 事業領域一覧

getBusAreaList

public BusinessAreaList getBusAreaList()
事業領域一覧を取得します｡

戻り値:
busAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaList (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList
すべての実装インタフェース:
Serializable
public class BusinessAreaList
extends Object
implements Serializable

事業領域一覧クラス
機能は以下の通り

  • 事業領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessAreaList()
executeBapiを呼び出し事業領域一覧を作成します。
メソッドの概要
ArrayList | getBusinessAreaList() 事業領域一覧を取得します｡
void | setBusinessAreaList(ArrayList businessAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaList

public BusinessAreaList()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し事業領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBusinessAreaList

public void setBusinessAreaList(ArrayList businessAreaList)
事業領域一覧を設定します｡

パラメータ:
businessAreaList - 事業領域一覧

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧を取得します｡

戻り値:
businessAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Company (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Company

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Company
すべての実装インタフェース:
Serializable
public class Company
extends Object
implements Serializable

会社情報クラス
機能は以下の通り

  • 会社の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Company()
会社情報を作成します。
メソッドの概要
String | getCompCode() 会社コードを取得します｡
String | getCompName() 会社名を取得します｡
void | setCompCode(String compCode) 会社コードを設定します｡
void | setCompName(String compName) 会社名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Company

public Company()
会社情報を作成します。

メソッドの詳細

setCompCode

public void setCompCode(String compCode)
会社コードを設定します｡

パラメータ:
compCode - 会社コード

setCompName

public void setCompName(String compName)
会社名を設定します｡

パラメータ:
compName - 会社名

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

getCompName

public String getCompName()
会社名を取得します｡

戻り値:
compName

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyController
すべての実装インタフェース:
Serializable
public class CompanyController
extends Object
implements Serializable

会社コントローラクラス
機能は以下の通り

  • 会社の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します。
CompanyList | getCompList() 会社一覧を取得します｡
String | getCompName(String compCode) 会社コードを指定して会社名を取得します。
void | setCompList(CompanyList compList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyController

public CompanyController()
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPAccountingSystemException
CompanyListのコンストラクタを呼び出し会社一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します。

戻り値:
companyList 会社一覧

getCompName

public String getCompName(String compCode)
                   throws SAPAccountingSystemException
会社コードを指定して会社名を取得します。

パラメータ:
compCode - 会社コード
戻り値:
compName 会社名
例外:
SAPAccountingSystemException - 会計業務システム例外

setCompList

public void setCompList(CompanyList compList)
会社一覧を設定します｡

パラメータ:
compList - 会社一覧

getCompList

public CompanyList getCompList()
会社一覧を取得します｡

戻り値:
compList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyList (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyList
すべての実装インタフェース:
Serializable
public class CompanyList
extends Object
implements Serializable

会社一覧クラス
機能は以下の通り

  • 会社の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyList()
executeBapiを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します｡
void | setCompanyList(ArrayList companyList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyList

public CompanyList()
            throws SAPAuthAppException,
                   SAPAuthSystemException,
                   SAPGeneralAppException,
                   SAPGeneralSystemException,
                   SAPAccountingSystemException
executeBapiを呼び出し会社一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCompanyList

public void setCompanyList(ArrayList companyList)
会社一覧を設定します｡

パラメータ:
companyList - 会社一覧

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します｡

戻り値:
companyList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingArea (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea
すべての実装インタフェース:
Serializable
public class ControllingArea
extends Object
implements Serializable

管理領域情報クラス
機能は以下の通り

  • 管理領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingArea()
管理領域情報を作成します。
メソッドの概要
String | getCoArea() 管理領域を取得します｡
String | getName() 管理領域名を取得します｡
void | setCoArea(String coArea) 管理領域を設定します｡
void | setName(String name) 管理領域名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingArea

public ControllingArea()
管理領域情報を作成します。

メソッドの詳細

setCoArea

public void setCoArea(String coArea)
管理領域を設定します｡

パラメータ:
coArea - 管理領域

setName

public void setName(String name)
管理領域名を設定します｡

パラメータ:
name - 管理領域名

getCoArea

public String getCoArea()
管理領域を取得します｡

戻り値:
coArea

getName

public String getName()
管理領域名を取得します｡

戻り値:
name

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController
すべての実装インタフェース:
Serializable
public class ControllingAreaController
extends Object
implements Serializable

管理領域コントローラクラス
機能は以下の通り

  • 管理領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
メソッドの概要
ControllingAreaList | getControllAreaList() 管理領域一覧を取得します｡
ArrayList | getControllingAreaList() 管理領域一覧を取得します。
String | getName(String coArea) 管理領域を指定して管理領域名を取得します。
void | setControllAreaList(ControllingAreaList controllAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaController

public ControllingAreaController()
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPAccountingSystemException
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します。

戻り値:
controllingAreaList 管理領域一覧

getName

public String getName(String coArea)
               throws SAPAccountingSystemException
管理領域を指定して管理領域名を取得します。

パラメータ:
coArea - 管理領域
戻り値:
name 管理領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setControllAreaList

public void setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

パラメータ:
controllAreaList - 管理領域一覧

getControllAreaList

public ControllingAreaList getControllAreaList()
管理領域一覧を取得します｡

戻り値:
controllAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaList (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList
すべての実装インタフェース:
Serializable
public class ControllingAreaList
extends Object
implements Serializable

管理領域一覧クラス
機能は以下の通り

  • 管理領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingAreaList()
executeBapiを呼び出し管理領域一覧を作成します。
メソッドの概要
ArrayList | getControllingAreaList() 管理領域一覧を取得します｡
void | setControllingAreaList(ArrayList controllingAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaList

public ControllingAreaList()
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPAccountingSystemException
executeBapiを呼び出し管理領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setControllingAreaList

public void setControllingAreaList(ArrayList controllingAreaList)
管理領域一覧を設定します｡

パラメータ:
controllingAreaList - 管理領域一覧

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します｡

戻り値:
controllingAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenter (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenter
すべての実装インタフェース:
Serializable
public class CostCenter
extends Object
implements Serializable

原価センタ情報クラス
機能は以下の通り

  • 原価センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenter()
原価センタ情報を取得します。
メソッドの概要
String | getControllingArea() 管理領域を取得します｡
String | getCostCenter() 原価センタを取得します｡
String | getDescript() テキストを取得します｡
String | getName() 一般名称を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setCostCenter(String costCenter) 原価センタを設定します｡
void | setDescript(String descript) テキストを設定します｡
void | setName(String name) 一般名称を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenter

public CostCenter()
原価センタ情報を取得します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setCostCenter

public void setCostCenter(String costCenter)
原価センタを設定します｡

パラメータ:
costCenter - 原価センタ

setName

public void setName(String name)
一般名称を設定します｡

パラメータ:
name - 一般名称

setDescript

public void setDescript(String descript)
テキストを設定します｡

パラメータ:
descript - テキスト

getControllingArea

public String getControllingArea()
管理領域を取得します｡

戻り値:
controllingArea

getCostCenter

public String getCostCenter()
原価センタを取得します｡

戻り値:
costCenter

getName

public String getName()
一般名称を取得します｡

戻り値:
name

getDescript

public String getDescript()
テキストを取得します｡

戻り値:
descript

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController
すべての実装インタフェース:
Serializable
public class CostCenterController
extends Object
implements Serializable

原価センタコントローラクラス
機能は以下の通り

  • 原価センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
メソッドの概要
ArrayList | getCostCenterList() 原価センタ一覧を取得します。
CostCenterList | getCostCentList() 原価センタ一覧を取得します｡
String | getDescript(String costCenter) 原価センタを指定してテキストを取得します。
String | getName(String costCenter) 原価センタを指定して一般名称を取得します。
void | setCostCentList(CostCenterList costCentList) 原価センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterController

public CostCenterController(String controllingArea)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea,
                            Date date)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧を取得します。

戻り値:
costCenterList 原価センタ一覧

getName

public String getName(String costCenter)
               throws SAPAccountingSystemException
原価センタを指定して一般名称を取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
name 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getDescript

public String getDescript(String costCenter)
                   throws SAPAccountingSystemException
原価センタを指定してテキストを取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
descript テキスト
例外:
SAPAccountingSystemException - 会計業務システム例外

setCostCentList

public void setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

パラメータ:
costCentList - 原価センタ一覧

getCostCentList

public CostCenterList getCostCentList()
原価センタ一覧を取得します｡

戻り値:
costCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterList (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList
すべての実装インタフェース:
Serializable
public class CostCenterList
extends Object
implements Serializable

原価センタ一覧クラス
機能は以下の通り

  • 原価センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterList(String controllingArea, String date)
executeBapiを呼び出し原価センタ一覧を作成します。
メソッドの概要
ArrayList | getCostCenterList() 原価センタ一覧を取得します｡
void | setCostCenterList(ArrayList costCenterList) 原価センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterList

public CostCenterList(String controllingArea,
                      String date)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
executeBapiを呼び出し原価センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCostCenterList

public void setCostCenterList(ArrayList costCenterList)
原価センタ一覧を設定します｡

パラメータ:
costCenterList - 原価センタ一覧

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧を取得します｡

戻り値:
costCenterList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurrencyAmount (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CurrencyAmount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount
すべての実装インタフェース:
Serializable
public class CurrencyAmount
extends Object
implements Serializable

明細通貨項目クラス
機能は以下の通り

  • 明細通貨項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CurrencyAmount(int index)
指定されたレコード番号でCurrencyAmountを作成します。
メソッドの概要
String | getCuAmtBase() 課税基準額を取得します｡
String | getCuAmtDoccur() 伝票通貨額を取得します｡
String | getCuCurrency() 通貨コードを取得します｡
int | getCuIndex() レコード番号を取得します｡
String | getCuItemnoAcc() 会計伝票明細番号を取得します｡
void | setCuAmtBase(String cuAmtBase) 課税基準額を設定します｡
void | setCuAmtDoccur(String cuAmtDoccur) 伝票通貨額設定します｡
void | setCuCurrency(String cuCurrency) 通貨コードを設定します｡
void | setCuIndex(int cuIndex) レコード番号を設定します｡
void | setCuItemnoAcc(String cuItemnoAcc) 会計伝票明細番号コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurrencyAmount

public CurrencyAmount(int index)
指定されたレコード番号でCurrencyAmountを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
cuItemnoAcc - 会計伝票明細番号

setCuCurrency

public void setCuCurrency(String cuCurrency)
通貨コードを設定します｡

パラメータ:
cuCurrency - 通貨コード

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur)
伝票通貨額設定します｡

パラメータ:
cuAmtDoccur - 伝票通貨額

setCuAmtBase

public void setCuAmtBase(String cuAmtBase)
課税基準額を設定します｡

パラメータ:
cuAmtBase - 課税基準額

setCuIndex

public void setCuIndex(int cuIndex)
レコード番号を設定します｡

パラメータ:
cuIndex - レコード番号

getCuItemnoAcc

public String getCuItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
cuItemnoAcc

getCuCurrency

public String getCuCurrency()
通貨コードを取得します｡

戻り値:
cuCurrency

getCuAmtDoccur

public String getCuAmtDoccur()
伝票通貨額を取得します｡

戻り値:
cuAmtDoccur

getCuAmtBase

public String getCuAmtBase()
課税基準額を取得します｡

戻り値:
cuAmtBase

getCuIndex

public int getCuIndex()
レコード番号を取得します｡

戻り値:
cuindex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DocumentHeader (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス DocumentHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader
すべての実装インタフェース:
Serializable
public class DocumentHeader
extends Object
implements Serializable

伝票ヘッダクラス
機能は以下の通り

  • 伝票ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DocumentHeader()
伝票ヘッダ情報を作成します。
メソッドの概要
String | getDocAcDocNo() 会計伝票番号を取得します｡
String | getDocCompCode() 会社コードを取得します｡
String | getDocDocDate() 伝票の伝票日付を取得します｡
String | getDocDocType() 伝票タイプを取得します｡
String | getDocFiscYear() 会計年度を取得します｡
String | getDocFisPeriod() 会計期間を取得します｡
String | getDocHeaderTxt() 伝票ヘッダテキストを取得します｡
String | getDocObjKey() オブジェクトキーを取得します｡
String | getDocObjType() 参照処理を取得します｡
String | getDocPstngDate() 伝票の転記日付を取得します｡
String | getDocRefDocNo() 参照伝票番号を取得します｡
String | getDocUsername() ユーザ名を取得します｡
void | setDocAcDocNo(String docAcDocNo) 会計伝票番号コードを設定します｡
void | setDocCompCode(String docCompCode) 会社コードコードを設定します｡
void | setDocDocDate(String docDocDate) 伝票の伝票日付コードを設定します｡
void | setDocDocType(String docDocType) 伝票タイプコードを設定します｡
void | setDocFiscYear(String docFiscYear) 会計年度コードを設定します｡
void | setDocFisPeriod(String docFisPeriod) 会計期間コードを設定します｡
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダテキストコードを設定します｡
void | setDocObjKey(String docObjKey) オブジェクトキーコードを設定します｡
void | setDocObjType(String docObjType) 参照処理コードを設定します｡
void | setDocPstngDate(String docPstngDate) 伝票の転記日付コードを設定します｡
void | setDocRefDocNo(String docRefDocNo) 参照伝票番号コードを設定します｡
void | setDocUsername(String docUsername) ユーザ名コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DocumentHeader

public DocumentHeader()
伝票ヘッダ情報を作成します。

メソッドの詳細

setDocObjType

public void setDocObjType(String docObjType)
参照処理コードを設定します｡

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
オブジェクトキーコードを設定します｡

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
ユーザ名コードを設定します｡

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダテキストコードを設定します｡

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
会社コードコードを設定します｡

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
会計伝票番号コードを設定します｡

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
会計年度コードを設定します｡

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票の伝票日付コードを設定します｡

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票の転記日付コードを設定します｡

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
会計期間コードを設定します｡

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票タイプコードを設定します｡

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
参照伝票番号コードを設定します｡

パラメータ:
docRefDocNo - 参照伝票番号

getDocObjType

public String getDocObjType()
参照処理を取得します｡

戻り値:
docObjType

getDocObjKey

public String getDocObjKey()
オブジェクトキーを取得します｡

戻り値:
docObjKey

getDocUsername

public String getDocUsername()
ユーザ名を取得します｡

戻り値:
docUsername

getDocHeaderTxt

public String getDocHeaderTxt()
伝票ヘッダテキストを取得します｡

戻り値:
docHeaderTxt

getDocCompCode

public String getDocCompCode()
会社コードを取得します｡

戻り値:
docCompCode

getDocAcDocNo

public String getDocAcDocNo()
会計伝票番号を取得します｡

戻り値:
docAcDocNo

getDocFiscYear

public String getDocFiscYear()
会計年度を取得します｡

戻り値:
docFiscYear

getDocDocDate

public String getDocDocDate()
伝票の伝票日付を取得します｡

戻り値:
docDocDate

getDocPstngDate

public String getDocPstngDate()
伝票の転記日付を取得します｡

戻り値:
docPstngDate

getDocFisPeriod

public String getDocFisPeriod()
会計期間を取得します｡

戻り値:
docFisPeriod

getDocDocType

public String getDocDocType()
伝票タイプを取得します｡

戻り値:
docDocType

getDocRefDocNo

public String getDocRefDocNo()
参照伝票番号を取得します｡

戻り値:
docRefDocNo

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAcc (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAcc

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAcc
すべての実装インタフェース:
Serializable
public class GlAcc
extends Object
implements Serializable

勘定項目情報クラス
機能は以下の通り

  • 勘定項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GlAcc()
勘定項目情報を作成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します｡
String | getGlAccount() G/L勘定コードを取得します｡
String | getLongText() 総勘定元帳勘定テキスト(長)を取得します｡
String | getShortText() G/L勘定コードテキスト(短)を取得します｡
void | setCompanyCode(String companyCode) 会社コードを設定します｡
void | setGlAccount(String glAccount) G/L勘定コードを設定します｡
void | setLongText(String longText) 総勘定元帳勘定テキスト(長)を設定します｡
void | setShortText(String shortText) G/L勘定コードテキスト(短)を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAcc

public GlAcc()
勘定項目情報を作成します。

メソッドの詳細

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します｡

パラメータ:
companyCode - 会社コード

setGlAccount

public void setGlAccount(String glAccount)
G/L勘定コードを設定します｡

パラメータ:
glAccount - G/L勘定コード

setShortText

public void setShortText(String shortText)
G/L勘定コードテキスト(短)を設定します｡

パラメータ:
shortText - G/L勘定コードテキスト(短)

setLongText

public void setLongText(String longText)
総勘定元帳勘定テキスト(長)を設定します｡

パラメータ:
longText - 総勘定元帳勘定テキスト(長)

getCompanyCode

public String getCompanyCode()
会社コードを取得します｡

戻り値:
companyCode

getGlAccount

public String getGlAccount()
G/L勘定コードを取得します｡

戻り値:
glAccount

getShortText

public String getShortText()
G/L勘定コードテキスト(短)を取得します｡

戻り値:
shortText

getLongText

public String getLongText()
総勘定元帳勘定テキスト(長)を取得します｡

戻り値:
longText

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccController
すべての実装インタフェース:
Serializable
public class GlAccController
extends Object
implements Serializable

勘定科目コントローラクラス
機能は以下の通り

  • 勘定科目の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定科目一覧を取得します。
GlAccList | getGlList() 勘定科目一覧を取得します｡
String | getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
void | setGlList(GlAccList glList) 勘定科目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccController

public GlAccController(String companyCode)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。

パラメータ:
companyCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getGlAccList

public ArrayList getGlAccList()
勘定科目一覧を取得します。

戻り値:
glAccList 勘定科目一覧

getShortText

public String getShortText(String glAccount)
                    throws SAPAccountingSystemException
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
shortText G/L勘定コードテキスト(短)
例外:
SAPAccountingSystemException - 会計業務システム例外

getLongText

public String getLongText(String glAccount)
                   throws SAPAccountingSystemException
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
longText 総勘定元帳勘定テキスト(長)
例外:
SAPAccountingSystemException - 会計業務システム例外

setGlList

public void setGlList(GlAccList glList)
勘定科目一覧を設定します｡

パラメータ:
glList - 勘定科目一覧

getGlList

public GlAccList getGlList()
勘定科目一覧を取得します｡

戻り値:
glList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccList (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccList
すべての実装インタフェース:
Serializable
public class GlAccList
extends Object
implements Serializable

勘定項目一覧クラス
機能は以下の通り

  • 勘定項目の情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
GlAccList(String companyCode)
executeBapiを呼び出し勘定項目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定項目一覧を取得します｡
void | setGlAccList(ArrayList glAccList) 勘定項目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccList

public GlAccList(String companyCode)
          throws SAPAuthAppException,
                 SAPAuthSystemException,
                 SAPGeneralAppException,
                 SAPGeneralSystemException,
                 SAPAccountingSystemException
executeBapiを呼び出し勘定項目一覧を作成します。

パラメータ:
companyCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setGlAccList

public void setGlAccList(ArrayList glAccList)
勘定項目一覧を設定します｡

パラメータ:
glAccList - 勘定項目一覧

getGlAccList

public ArrayList getGlAccList()
勘定項目一覧を取得します｡

戻り値:
glAccList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.accounting (intra-mart ERP連携モジュール)

 jp.co.intra_mart.foundation.sap.module.accounting
クラス
AccEmployeePayPostController
AccountGl
AccountPayable
AccountTax
Bank
BankController
BankList
BusinessArea
BusinessAreaController
BusinessAreaList
Company
CompanyController
CompanyList
ControllingArea
ControllingAreaController
ControllingAreaList
CostCenter
CostCenterController
CostCenterList
CurrencyAmount
DocumentHeader
GlAcc
GlAccController
GlAccList
ProfitCenter
ProfitCenterController
ProfitCenterList


jp.co.intra_mart.foundation.sap.module.accounting (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

ＳＡＰ連携会計系に関するクラスを提供します。

参照:
説明

クラスの概要
AccEmployeePayPostController | 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
AccountGl | G/L 勘定明細クラス 機能は以下の通り G/L 勘定明細の情報を保持します。
AccountPayable | 仕入先明細クラス 機能は以下の通り 仕入先明細の情報を保持します。
AccountTax | 税明細クラス 機能は以下の通り 税明細の情報を保持します。
Bank | 銀行情報クラス 機能は以下の通り 銀行の情報を保持します。
BankController | 銀行コントローラクラス 機能は以下の通り 銀行の情報を取得します。
BankList | 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
BusinessArea | 事業領域情報クラス 機能は以下の通り 事業領域の情報を保持します。
BusinessAreaController | 事業領域コントローラクラス 機能は以下の通り 事業領域の情報を取得します。
BusinessAreaList | 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
Company | 会社情報クラス 機能は以下の通り 会社の情報を保持します。
CompanyController | 会社コントローラクラス 機能は以下の通り 会社の情報を取得します。
CompanyList | 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
ControllingArea | 管理領域情報クラス 機能は以下の通り 管理領域の情報を保持します。
ControllingAreaController | 管理領域コントローラクラス 機能は以下の通り 管理領域の情報を取得します。
ControllingAreaList | 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
CostCenter | 原価センタ情報クラス 機能は以下の通り 原価センタの情報を保持します。
CostCenterController | 原価センタコントローラクラス 機能は以下の通り 原価センタの情報を取得します。
CostCenterList | 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
CurrencyAmount | 明細通貨項目クラス 機能は以下の通り 明細通貨項目の情報を保持します。
DocumentHeader | 伝票ヘッダクラス 機能は以下の通り 伝票ヘッダの情報を保持します。
GlAcc | 勘定項目情報クラス 機能は以下の通り 勘定項目の情報を保持します。
GlAccController | 勘定科目コントローラクラス 機能は以下の通り 勘定科目の情報を取得します。
GlAccList | 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
ProfitCenter | 利益センタ情報クラス 機能は以下の通り 利益センタの情報を保持します。
ProfitCenterController | 利益センタコントローラクラス 機能は以下の通り 利益センタの情報を取得します。
ProfitCenterList | 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の説明

ＳＡＰ連携会計系に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


jp.co.intra_mart.foundation.sap.module.accounting クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様


パッケージ jp.co.intra_mart.foundation.sap.module.accounting の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting の使用

jp.co.intra_mart.foundation.sap.module.accounting を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting のクラス
BankList
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BusinessAreaList
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
CompanyList
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
ControllingAreaList
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
CostCenterList
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
DocumentHeader
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
GlAccList
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
ProfitCenterList
利益センタ一覧クラス
機能は以下の通り
利益センタの情報を一覧形式で取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


ProfitCenter (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter
すべての実装インタフェース:
Serializable
public class ProfitCenter
extends Object
implements Serializable

利益センタ情報クラス
機能は以下の通り

  • 利益センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenter()
利益センタ情報を作成します。
メソッドの概要
String | getControllingArea() 管理領域コードを取得します｡
String | getInCharge() 利益センタ責任者を取得します｡
String | getPctrName() 一般名称を取得します｡
String | getProfitCtr() 利益センタを取得します｡
String | getValidTo() 有効終了日を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setInCharge(String inCharge) 利益センタ責任者を設定します｡
void | setPctrName(String pctrName) 一般名称を設定します｡
void | setProfitCtr(String profitCtr) 利益センタを設定します｡
void | setValidTo(String validTo) 有効終了日を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenter

public ProfitCenter()
利益センタ情報を作成します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します｡

パラメータ:
profitCtr - 利益センタ

setValidTo

public void setValidTo(String validTo)
有効終了日を設定します｡

パラメータ:
validTo - 有効終了日

setPctrName

public void setPctrName(String pctrName)
一般名称を設定します｡

パラメータ:
pctrName - 一般名称

setInCharge

public void setInCharge(String inCharge)
利益センタ責任者を設定します｡

パラメータ:
inCharge - 利益センタ責任者

getControllingArea

public String getControllingArea()
管理領域コードを取得します｡

戻り値:
controllingArea

getProfitCtr

public String getProfitCtr()
利益センタを取得します｡

戻り値:
profitCtr

getValidTo

public String getValidTo()
有効終了日を取得します｡

戻り値:
validTo

getPctrName

public String getPctrName()
一般名称を取得します｡

戻り値:
pctrName

getInCharge

public String getInCharge()
利益センタ責任者を取得します｡

戻り値:
inCharge

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterController (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController
すべての実装インタフェース:
Serializable
public class ProfitCenterController
extends Object
implements Serializable

利益センタコントローラクラス
機能は以下の通り

  • 利益センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
メソッドの概要
String | getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
ArrayList | getProfitCenterList() 利益センタ一覧を取得します。
ProfitCenterList | getProfitCentList() 利益センタ一覧を取得します｡
String | getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
void | setProfitCentList(ProfitCenterList profitCentList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterController

public ProfitCenterController(String controllingArea)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              Date date)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 日付
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧を取得します。

戻り値:
profitCenterList 管理領域一覧

getValidTo

public String getValidTo(String profitCtr)
                  throws SAPAccountingSystemException
利益センタを指定して有効終了日を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
validTo 有効終了日
例外:
SAPAccountingSystemException - 会計業務システム例外

getPctrName

public String getPctrName(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して一般名称を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
pctrName 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getInCharge

public String getInCharge(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して利益センタ責任者を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
inCharge 利益センタ責任者
例外:
SAPAccountingSystemException - 会計業務システム例外

setProfitCentList

public void setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

パラメータ:
profitCentList - 利益センタ一覧

getProfitCentList

public ProfitCenterList getProfitCentList()
利益センタ一覧を取得します｡

戻り値:
profitCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterList (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList
すべての実装インタフェース:
Serializable
public class ProfitCenterList
extends Object
implements Serializable

利益センタ一覧クラス
機能は以下の通り

  • 利益センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterList(String controllingArea, String date)
executeBapiを呼び出し利益センタ一覧を作成します。
メソッドの概要
ArrayList | getProfitCenterList() 利益センタ一覧を取得します｡
void | setProfitCenterList(ArrayList profitCenterList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterList

public ProfitCenterList(String controllingArea,
                        String date)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し利益センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
date - 日付
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setProfitCenterList

public void setProfitCenterList(ArrayList profitCenterList)
利益センタ一覧を設定します｡

パラメータ:
profitCenterList - 利益センタ一覧

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧を取得します｡

戻り値:
profitCenterList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (intra-mart ERP連携モジュール)

 すべてのクラス
AccEmployeePayPostController
AccountGl
AccountPayable
AccountTax
Bank
BankController
BankList
BapiController
BapiHash
BapiReturn
BusinessArea
BusinessAreaController
BusinessAreaList
Company
CompanyController
CompanyList
ConnectionManager
ControllingArea
ControllingAreaController
ControllingAreaList
Convertor
CostCenter
CostCenterController
CostCenterList
CurrencyAmount
DateHandler
DocumentHeader
GlAcc
GlAccController
GlAccList
LineProperty
ProfitCenter
ProfitCenterController
ProfitCenterList
PropertiesFile
SAPAccountingAppException
SAPAccountingSystemException
SAPAuthAppException
SAPAuthSystemException
SAPGeneralAppException
SAPGeneralSystemException
SapConnector
SapRepositoryManager


定数フィールド値 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


非推奨 API のリスト (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


API ヘルプ (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


索引 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし
A B C D E G I J L P R S T U

A

AccEmployeePayPostController - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController.
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。
AccEmployeePayPostController() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccountGl - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl.
G/L 勘定明細クラス
機能は以下の通り
G/L 勘定明細の情報を保持します。
AccountGl(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のコンストラクタ
G/L 勘定明細情報を作成します。
AccountPayable - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable.
仕入先明細クラス
機能は以下の通り
仕入先明細の情報を保持します。
AccountPayable(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のコンストラクタ
仕入先明細情報を作成します。
AccountTax - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax.
税明細クラス
機能は以下の通り
税明細の情報を保持します。
AccountTax(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のコンストラクタ
指定されたレコード番号でAccountTaxを作成します｡

B

Bank - class jp.co.intra_mart.foundation.sap.module.accounting.Bank.
銀行情報クラス
機能は以下の通り
銀行の情報を保持します。
Bank() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のコンストラクタ
銀行情報を作成します。
BankController - class jp.co.intra_mart.foundation.sap.module.accounting.BankController.
銀行コントローラクラス
機能は以下の通り
銀行の情報を取得します。
BankController() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankList - class jp.co.intra_mart.foundation.sap.module.accounting.BankList.
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のコンストラクタ
executeBapiを呼び出し銀行一覧を作成します。
BapiController - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.
BAPIコントローラクラス
機能は以下の通り
ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡
展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開メソッドを使用して取得します｡
BapiController(String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
コネクションマネージャのセット、 プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiHash - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash.
BapiHashクラス
機能は以下の通り
汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡ R/3のBAPI処理にて使用されるパラメータの値を保持します。
BapiHash(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡
BapiHash(String, String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。
BapiHash(String, String, String, int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。
BapiReturn - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn.
BapiReturnクラス
機能は以下の通り
R/3のBAPI処理の実行結果に関する値を保持します。
BapiReturn(JCO.Structure) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のコンストラクタ
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(JCO.Table) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のコンストラクタ
指定されたJCO.Table情報でBapiReturnを作成します。
BusinessArea - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea.
事業領域情報クラス
機能は以下の通り
事業領域の情報を保持します。
BusinessArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のコンストラクタ
事業領域情報を作成します。
BusinessAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController.
事業領域コントローラクラス
機能は以下の通り
事業領域の情報を取得します。
BusinessAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList.
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
BusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のコンストラクタ
executeBapiを呼び出し事業領域一覧を作成します。

C

Company - class jp.co.intra_mart.foundation.sap.module.accounting.Company.
会社情報クラス
機能は以下の通り
会社の情報を保持します。
Company() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のコンストラクタ
会社情報を作成します。
CompanyController - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController.
会社コントローラクラス
機能は以下の通り
会社の情報を取得します。
CompanyController() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のコンストラクタ
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyList - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList.
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
CompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のコンストラクタ
executeBapiを呼び出し会社一覧を作成します。
ConnectionManager - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager.
ConnectionManagerクラス
R/3へのコネクション(トランザクション)を管理するクラスです。
ConnectionManager() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のコンストラクタ
ControllingArea - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea.
管理領域情報クラス
機能は以下の通り
管理領域の情報を保持します。
ControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のコンストラクタ
管理領域情報を作成します。
ControllingAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController.
管理領域コントローラクラス
機能は以下の通り
管理領域の情報を取得します。
ControllingAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のコンストラクタ
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList.
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
ControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のコンストラクタ
executeBapiを呼び出し管理領域一覧を作成します。
Convertor - class jp.co.intra_mart.foundation.sap.common.util.data.Convertor.
Converterクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。
CostCenter - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter.
原価センタ情報クラス
機能は以下の通り
原価センタの情報を保持します。
CostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のコンストラクタ
原価センタ情報を取得します。
CostCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController.
原価センタコントローラクラス
機能は以下の通り
原価センタの情報を取得します。
CostCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList.
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
CostCenterList(String, String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のコンストラクタ
executeBapiを呼び出し原価センタ一覧を作成します。
CurrencyAmount - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount.
明細通貨項目クラス
機能は以下の通り
明細通貨項目の情報を保持します。
CurrencyAmount(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のコンストラクタ
指定されたレコード番号でCurrencyAmountを作成します。
clear() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
commit() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
ＢＡＰＩ実行結果のCOMMIT処理を行います｡
convJCOdata(int, int, Object) - class jp.co.intra_mart.foundation.sap.common.util.data.Convertor の static メソッド
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。

D

DateHandler - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler.
DateHandlerクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。
DocumentHeader - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader.
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
DocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のコンストラクタ
伝票ヘッダ情報を作成します。

E

executeBapi() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
BapiControllerにより会計伝票を登録します。

G

GlAcc - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc.
勘定項目情報クラス
機能は以下の通り
勘定項目の情報を保持します。
GlAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のコンストラクタ
勘定項目情報を作成します。
GlAccController - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController.
勘定科目コントローラクラス
機能は以下の通り
勘定科目の情報を取得します。
GlAccController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccList - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList.
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
GlAccList(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のコンストラクタ
executeBapiを呼び出し勘定項目一覧を作成します。
getAccountGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細一覧を取得します｡
getAccountPayableList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細一覧を取得します｡
getAccountTaxList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細一覧を取得します｡
getAshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
接続先サーバIPアドレスを取得します｡
getBaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します｡
getBankKey() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを取得します｡
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します。
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧を取得します｡
getBankName() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を取得します｡
getBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して銀行名を取得します。
getBapiHashList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiHashの一覧を取得します。
getBapiReturnList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturnの一覧を取得します｡
getBusArDes() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を取得します｡
getBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域を指定して事業領域名を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を取得します｡
getBusAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します｡
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します。
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧を取得します｡
getCity() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を取得します｡
getCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して市区町村名を取得します。
getClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
クライアントを取得します｡
getCoArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を取得します｡
getCode() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを取得します｡
getCompList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します｡
getCompName() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を取得します｡
getCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社コードを指定して会社名を取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを取得します｡
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します。
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を取得します｡
getConnectionTimeout() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションのタイムアウトを取得します｡
getControllAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域コードを取得します｡
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します。
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を取得します｡
getCostCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します｡
getCostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを取得します｡
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します。
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を取得します｡
getCuAmtBase() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を取得します｡
getCuAmtDoccur() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額を取得します｡
getCuCurrency() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを取得します｡
getCuIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を取得します｡
getCuItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号を取得します｡
getCurrencyAmountList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目一覧を取得します｡
getDateValue(String) - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
日付書式[YYYYMMDD]の文字列をDate型に変換します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを取得します｡
getDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定してテキストを取得します。
getDocAcDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号を取得します｡
getDocCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードを取得します｡
getDocDocDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付を取得します｡
getDocDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプを取得します｡
getDocFisPeriod() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間を取得します｡
getDocFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度を取得します｡
getDocHeaderTxt() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストを取得します｡
getDocObjKey() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーを取得します｡
getDocObjType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理を取得します｡
getDocPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付を取得します｡
getDocRefDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号を取得します｡
getDocUsername() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名を取得します｡
getDocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダを取得します｡
getErrMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。
getExpExpList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(export(Export))の一覧を取得します｡
getExpStrList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Export))の一覧を取得します｡
getExpTblList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Export))の一覧を取得します｡
getExportParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
export(Export)情報を返します。
getField() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
フィールドを取得します｡
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目一覧を取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを取得します｡
getGlAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーを取得します｡
getGlBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域を取得します｡
getGlCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードを取得します｡
getGlCostcenter() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタを取得します｡
getGlDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプを取得します｡
getGlFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度を取得します｡
getGlGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定を取得します｡
getGlIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を取得します｡
getGlItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストを取得します｡
getGlItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号を取得します｡
getGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を取得します｡
getGlOrderid() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号を取得します｡
getGlPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付を取得します｡
getGlRefKey1() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーを取得します｡
getGlTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードを取得します｡
getGlWbsElement() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素を取得します｡
getId() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを取得します｡
getImpExpType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
入力／出力区分を取得します｡
getImpImpList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(import(Import))の一覧を取得します。
getImpStrList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Import))一覧を取得します。
getImpTblList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Import))の一覧を取得します｡
getInCharge() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を取得します｡
getInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して利益センタ責任者を取得します。
getJCORepository(SapConnector) - class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の static メソッド
Repository情報を生成もしくは、取得します。
getLang() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
言語を取得します｡
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログメッセージナンバーを取得します｡
getLogNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログナンバーを取得します｡
getLongText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を取得します｡
getLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージを取得します｡
getMessageV1() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ１を取得します｡
getMessageV2() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ２を取得します｡
getMessageV3() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ３を取得します｡
getMessageV4() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ４を取得します｡
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域を指定して管理領域名を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定して一般名称を取得します。
getNumber() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ナンバーを取得します｡
getPaAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーを取得します｡
getPaBlineDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日を取得します｡
getPaGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定を取得します｡
getPaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を取得します｡
getPaItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストを取得します｡
getPaItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号を取得します｡
getPaPymtMeth() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を取得します｡
getPaVendorNo() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードを取得します｡
getParamName() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ名を取得します｡
getParamType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ属性を取得します｡
getParameter() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
パラメーターを取得します｡
getPasswd() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
パスワードを取得します｡
getPctrName() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を取得します｡
getPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して一般名称を取得します。
getPoolName() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
プール名称を取得します｡
getPoolSize() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
プール内のコネクション数を取得します｡
getProfitCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します｡
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します。
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧を取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを取得します｡
getProperties() - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
プロパティを取得します｡
getProperty() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル情報を取得します。
getPropertyKeyPart() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティのキーを取得します｡
getPropertyName() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル名を取得します。
getPropertyValue() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティの値を取得します｡
getRecordNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
レコード番号を取得します｡
getReturn() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行結果を取得します。
getReturnList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行結果の一覧を取得します。
getRow() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
行番号を取得します｡
getSeparateKey(int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
getServerType() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
サーバタイプを取得します｡
getShortText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を取得します｡
getShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
getStringDate(Date) - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。
getStructureParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
structure(Export)情報を返します。
getSysdate() - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
システム日付を取得します。
getSysnr() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
システム番号を取得します｡
getSystem() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを取得します｡
getTaGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定を取得します｡
getTaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を取得します｡
getTaItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号を取得します｡
getTaTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードを取得します｡
getTableParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
table(Export)情報を返します。
getTimeoutCheckPeriod() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションのタイムアウトのチェック間隔を取得します｡
getType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
タイプを取得します｡
getUser() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
ユーザを取得します｡
getValidTo() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を取得します｡
getValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して有効終了日を取得します。
getWaitTime() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクション取得の待機時間を取得します｡

I

isSuccess() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行が正常に行われたか判定します｡ＢＡＰＩ実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡

J

jp.co.intra_mart.foundation.sap.common.auth - package jp.co.intra_mart.foundation.sap.common.auth
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth.exception - package jp.co.intra_mart.foundation.sap.common.auth.exception
ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose - package jp.co.intra_mart.foundation.sap.common.general_purpose
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception - package jp.co.intra_mart.foundation.sap.common.general_purpose.exception
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data - package jp.co.intra_mart.foundation.sap.common.util.data
ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.date - package jp.co.intra_mart.foundation.sap.common.util.date
ＳＡＰ連携にて使用する日付操作クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file - package jp.co.intra_mart.foundation.sap.common.util.file
ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting - package jp.co.intra_mart.foundation.sap.module.accounting
ＳＡＰ連携会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception - package jp.co.intra_mart.foundation.sap.module.accounting.exception
ＳＡＰ連携会計系例外クラスを提供します。

L

LineProperty - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty.
LinePropertyクラス
機能は以下の通り
Propertyファイル１行ごとの情報を保持します｡
上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。
LineProperty(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のコンストラクタ
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。

P

ProfitCenter - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter.
利益センタ情報クラス
機能は以下の通り
利益センタの情報を保持します。
ProfitCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のコンストラクタ
利益センタ情報を作成します。
ProfitCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController.
利益センタコントローラクラス
機能は以下の通り
利益センタの情報を取得します。
ProfitCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList.
利益センタ一覧クラス
機能は以下の通り
利益センタの情報を一覧形式で取得します。
ProfitCenterList(String, String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のコンストラクタ
executeBapiを呼び出し利益センタ一覧を作成します。
PropertiesFile - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile.
プロパティファイルクラス
機能は以下の通り
ファイル名を指定してプロパティファイルを呼び出します。
PropertiesFile(String) - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のコンストラクタ
ファイル名を指定してプロパティファイルを取得します。
putImportParam(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
putStructParam(String, String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
putTableParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡

R

releaseConnection(JCO.Client) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector の static メソッド
コネクションをリリースします。
rollback() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

S

SAPAccountingAppException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException.
会計系APIアプリケーション例外クラス
SAPAccountingAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingAppException(String) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingSystemException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException.
会計系APIシステム例外クラス
SAPAccountingSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException のコンストラクタ
会計系APIシステム例外
SAPAuthAppException - exception jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException.
認証系APIアプリケーション例外クラス
SAPAuthAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException のコンストラクタ
認証系APIアプリケーション例外
SAPAuthAppException(String) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException のコンストラクタ
認証系APIアプリケーション例外
SAPAuthSystemException - exception jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException.
認証系APIシステム例外クラス
SAPAuthSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException のコンストラクタ
認証系APIシステム例外
SAPGeneralAppException - exception jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException.
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException のコンストラクタ
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralAppException(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException のコンストラクタ
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralSystemException - exception jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException.
共通API/汎用データ取得・追加・更新APIシステム例外クラス
SAPGeneralSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException のコンストラクタ
共通API/汎用データ取得・追加・更新APIシステム例外
SapConnector - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector.
SAPコネクタークラス
機能は以下の通り
単一ユーザIDで任意のコネクションプールを作成し、R/3にログインします。
SapConnector() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のコンストラクタ
プロパティファイルを読込み属性に値をセットします。
SapConnector(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のコンストラクタ
プロパティファイルを読込み属性に値をセットします。
SapRepositoryManager - class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager.
JCO.Repository を管理クラス。
setAccountGlList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細一覧を設定します｡
setAccountPayableList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細一覧を設定します｡
setAccountTaxList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細一覧を設定します｡
setAshost(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
接続先サーバIPアドレスを設定します｡
setBaList(BankList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を設定します｡
setBankKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを設定します｡
setBankList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧を設定します｡
setBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を設定します｡
setBapiHashList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiHashの一覧を設定します｡
setBapiReturnList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturnの一覧を設定します｡
setBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を設定します｡
setBusAreaList(BusinessAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を設定します｡
setBusinessAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧を設定します｡
setCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を設定します｡
setClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
クライアントを設定します｡
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を設定します｡
setCode(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを設定します｡
setCompList(CompanyList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を設定します｡
setCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を設定します｡
setCompanyCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを設定します｡
setCompanyList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を設定します｡
setConnectionTimeout(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションのタイムアウトを設定します｡
setControllAreaList(ControllingAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域を設定します｡
setControllingAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を設定します｡
setCostCentList(CostCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を設定します｡
setCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを設定します｡
setCostCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を設定します｡
setCuAmtBase(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の課税基準額に値を設定します。
setCuAmtBase(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を設定します｡
setCuAmtDoccur(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の伝票通貨額に値を設定します。
setCuAmtDoccur(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額設定します｡
setCuCurrency(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の通貨コードに値を設定します。
setCuCurrency(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを設定します｡
setCuIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を設定します｡
setCuItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の会計伝票明細番号に値を設定します。
setCuItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号コードを設定します｡
setCurrencyAmountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目一覧を設定します｡
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを設定します｡
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計伝票番号に値を設定します。
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号コードを設定します｡
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会社コードに値を設定します。
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードコードを設定します｡
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票の伝票日付に値を設定します。
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付コードを設定します｡
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票タイプに値を設定します。
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプコードを設定します｡
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計期間に値を設定します。
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間コードを設定します｡
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計年度に値を設定します。
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度コードを設定します｡
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票ヘッダテキストに値を設定します。
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストコードを設定します｡
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダのオブジェクトキーに値を設定します。
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーコードを設定します｡
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの参照処理に値を設定します。
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理コードを設定します｡
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票の転記日付に値を設定します。
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付コードを設定します｡
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの参照伝票番号に値を設定します。
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号コードを設定します｡
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダのユーザ名に値を設定します。
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名コードを設定します｡
setDocumentHeader(DocumentHeader) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダを設定します｡
setExpExpList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(export(Export))の一覧を設定します｡
setExpStrList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Export))の一覧を設定します｡
setExpTblList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Export))の一覧を設定します｡
setField(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
フィールドを設定します｡
setGlAccList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目一覧を設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを設定します｡
setGlAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細のソートキーに値を設定します。
setGlAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーコードを設定します｡
setGlBusArea(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の事業領域に値を設定します。
setGlBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域コードを設定します｡
setGlCompCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会社コードに値を設定します。
setGlCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードコードを設定します｡
setGlCostcenter(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の原価センタに値を設定します。
setGlCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタコードを設定します｡
setGlDocType(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の伝票タイプに値を設定します。
setGlDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプコードを設定します｡
setGlFiscYear(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会計年度に値を設定します。
setGlFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度コードを設定します｡
setGlGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の総勘定元帳勘定に値を設定します。
setGlGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定コードを設定します｡
setGlIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を設定します｡
setGlItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の明細テキストに値を設定します。
setGlItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストコードを設定します｡
setGlItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会計伝票明細番号に値を設定します。
setGlItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号コードを設定します｡
setGlList(GlAccList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を設定します｡
setGlOrderid(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の指図番号に値を設定します。
setGlOrderid(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号コードを設定します｡
setGlPstngDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の伝票の転記日付に値を設定します。
setGlPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付コードを設定します｡
setGlRefKey1(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の取引先参照キーに値を設定します。
setGlRefKey1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーコードを設定します｡
setGlTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の消費税コードに値を設定します。
setGlTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードコードを設定します｡
setGlWbsElement(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細のWBS 要素に値を設定します。
setGlWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素コードを設定します｡
setId(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを設定します｡
setImpExpType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
入力／出力区分を設定します｡
setImpImpList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(import(Import))の一覧を設定します｡
setImpStrList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Import))の一覧を設定します｡
setImpTblList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Import))の一覧を設定します｡
setInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を設定します｡
setLang(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
言語を設定します｡
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログメッセージナンバーを設定します｡
setLogNo(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログナンバーを設定します｡
setLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を設定します｡
setMessage(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージを設定します｡
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ１を設定します｡
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ２を設定します｡
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ３を設定します｡
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ４を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を設定します｡
setNumber(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ナンバーを設定します｡
setPaAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細のソートキーに値を設定します。
setPaAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーコードを設定します｡
setPaBlineDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の期日計算の支払基準日に値を設定します。
setPaBlineDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日コードを設定します｡
setPaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の総勘定元帳勘定に値を設定します。
setPaGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定コードを設定します｡
setPaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を設定します｡
setPaItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の明細テキストに値を設定します。
setPaItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストコードを設定します｡
setPaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の会計伝票明細番号に値を設定します。
setPaItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号コードを設定します｡
setPaPymtMeth(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の支払方法に値を設定します。
setPaPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を設定します｡
setPaVendorNo(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の仕入先または債権者の勘定コードに値を設定します。
setPaVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードコードを設定します｡
setParamName(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ名を設定します｡
setParamType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ属性を設定します｡
setParameter(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
パラメーターを設定します｡
setPasswd(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
パスワードを設定します｡
setPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を設定します｡
setPoolName(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
プール名称を設定します｡
setPoolSize(int) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
プール内のコネクション数を設定します｡
setProfitCentList(ProfitCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を設定します｡
setProfitCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧を設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを設定します｡
setProperty(Properties) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル情報を設定します｡
setPropertyKeyPart(String[]) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティのキーを設定します｡
setPropertyName(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル名を設定します｡
setPropertyValue(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティの値を設定します｡
setPropeties(Properties) - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
プロパティを設定します｡
setRecordNo(int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
レコード番号を設定します｡
setRow(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
行番号を設定します｡
setServerType(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
サーバタイプを設定します｡
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を設定します｡
setSysnr(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
システム番号を設定します｡
setSystem(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
システムを設定します｡
setTaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の総勘定元帳勘定に値を設定します。
setTaGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定コードを設定します｡
setTaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を設定します｡
setTaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の会計伝票明細番号に値を設定します。
setTaItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号コードを設定します｡
setTaTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の消費税コードに値を設定します。
setTaTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードコードを設定します｡
setTimeoutCheckPeriod(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションのタイムアウトのチェック間隔を設定します｡
setType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
タイプを設定します｡
setUser(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
ユーザを設定します｡
setValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を設定します｡
setWaitTime(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクション取得の待機時間を設定します｡

T

toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
デバッグ用のメソッドです。

U

useConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
コネクションを生成します。
A B C D E G I J L P R S T U
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


intra-mart ERP連携モジュール

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
すべてのクラス

パッケージ
jp.co.intra_mart.foundation.sap.common.auth
jp.co.intra_mart.foundation.sap.common.auth.exception
jp.co.intra_mart.foundation.sap.common.general_purpose
jp.co.intra_mart.foundation.sap.common.general_purpose.exception
jp.co.intra_mart.foundation.sap.common.util.data
jp.co.intra_mart.foundation.sap.common.util.date
jp.co.intra_mart.foundation.sap.common.util.file
jp.co.intra_mart.foundation.sap.module.accounting
jp.co.intra_mart.foundation.sap.module.accounting.exception


概要 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

intra-mart(R)ERP連携モジュール API 仕様
(BaseModule Advanced版のみ)

このドキュメントは、intra-martTMSAP R/3リアルタイム連携API 仕様です。

参照:
説明

パッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth.exception | ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.date | ＳＡＰ連携にて使用する日付操作クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携会計系例外クラスを提供します。

このドキュメントは、intra-martTMSAP R/3リアルタイム連携API 仕様です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


クラス階層 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.sap.common.auth, jp.co.intra_mart.foundation.sap.common.auth.exception, jp.co.intra_mart.foundation.sap.common.general_purpose, jp.co.intra_mart.foundation.sap.common.general_purpose.exception, jp.co.intra_mart.foundation.sap.common.util.data, jp.co.intra_mart.foundation.sap.common.util.date, jp.co.intra_mart.foundation.sap.common.util.file, jp.co.intra_mart.foundation.sap.module.accounting, jp.co.intra_mart.foundation.sap.module.accounting.exception

クラス階層

  • class java.lang.Object
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.data.Convertor (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.auth.SapConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
        • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
        • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
        • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


(intra-mart ERP連携モジュール)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.sap.common.auth

クラス jp.co.intra_mart.foundation.sap.common.auth.SapConnector は Object を拡張し、Serializable を実装しています

直列化されたフィールド

serverType

String serverType
サーバタイプ

client

String client
クライアント

user

String user
ユーザ

passwd

String passwd
パスワード

lang

String lang
言語

sysnr

String sysnr
システム番号

ashost

String ashost
接続先サーバIPアドレス

poolName

String poolName
プール名称

poolSize

int poolSize
プール内のコネクション数

waitTime

long waitTime
コネクション取得の待機時間

connectionTimeout

long connectionTimeout
コネクションのタイムアウト

timeoutCheckPeriod

long timeoutCheckPeriod
コネクションのタイムアウトのチェック間隔

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception

クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

propertyName

String propertyName
プロパティファイル名

property

Properties property
プロパティファイル

bapiHashList

ArrayList bapiHashList
BapiHashオブジェクトの一覧

impImpList

ArrayList impImpList
プロパティ情報(import(Import))一覧

impStrList

ArrayList impStrList
プロパティ情報(structure(Import))一覧

impTblList

ArrayList impTblList
プロパティ情報(table(Import))一覧

expExpList

ArrayList expExpList
プロパティ情報(export(Export))一覧

expStrList

ArrayList expStrList
プロパティ情報(structure(Export))一覧

expTblList

ArrayList expTblList
プロパティ情報(table(Export))一覧

bapiReturnList

ArrayList bapiReturnList
ＢＡＰＩ処理実行結果

hasTransaction

boolean hasTransaction
コネクション(トランザクション)保持フラグ

connectionManager

ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash は HashMap を拡張し、Serializable を実装しています

直列化されたフィールド

impExpType

String impExpType
入力／出力区分

paramType

String paramType
パラメタ属性

paramName

String paramName
パラメタ名

recordNo

int recordNo
レコード番号

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

type

String type
TYPE

id

String id
ID

code

String code
Code

number

String number
NUMBER

message

String message
MESSAGE

logNo

String logNo
LOG NO

logMsgNo

String logMsgNo
LOG MSG NO

messageV1

String messageV1
MESSAGE V1

messageV2

String messageV2
MESSAGE V2

messageV3

String messageV3
MESSAGE V3

messageV4

String messageV4
MESSAGE V4

parameter

String parameter
PARAMETER

row

String row
ROW

field

String field
FIELD

system

String system
SYSTEM

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager は Object を拡張し、Serializable を実装しています

直列化されたフィールド

connection

com.sap.mw.jco.JCO.Client connection
JCOコネクション

sapConnector

SapConnector sapConnector
SAPコネクター

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty は Object を拡張し、Serializable を実装しています

直列化されたフィールド

propertyValue

String propertyValue
プロパティの値

propertyKeyPart

String[] propertyKeyPart
プロパティのキー

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.data

クラス jp.co.intra_mart.foundation.sap.common.util.data.Convertor は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.date

クラス jp.co.intra_mart.foundation.sap.common.util.date.DateHandler は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.file

クラス jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile は Object を拡張し、Serializable を実装しています

直列化されたフィールド

properties

Properties properties
プロパティ

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

documentHeader

DocumentHeader documentHeader
伝票ヘッダ

accountPayableList

ArrayList accountPayableList
仕入先明細一覧

accountGlList

ArrayList accountGlList
G/L 勘定明細一覧

accountTaxList

ArrayList accountTaxList
税明細一覧

currencyAmountList

ArrayList currencyAmountList
明細通貨項目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glItemnoAcc

String glItemnoAcc
会計伝票明細番号

glGlAccount

String glGlAccount
総勘定元帳勘定

glCompCode

String glCompCode
会社コード

glPstngDate

String glPstngDate
伝票の転記日付

glDocType

String glDocType
伝票タイプ

glFiscYear

String glFiscYear
会計年度

glRefKey1

String glRefKey1
取引先参照キー

glItemText

String glItemText
明細テキスト

glTaxCode

String glTaxCode
消費税コード

glAllocNmbr

String glAllocNmbr
ソートキー

glBusArea

String glBusArea
事業領域

glCostcenter

String glCostcenter
原価センタ

glOrderid

String glOrderid
指図番号

glWbsElement

String glWbsElement
WBS 要素

glIndex

int glIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

paItemnoAcc

String paItemnoAcc
会計伝票明細番号

paVendorNo

String paVendorNo
仕入先または債権者の勘定コード

paGlAccount

String paGlAccount
総勘定元帳勘定

paBlineDate

String paBlineDate
期日計算の支払基準日

paPymtMeth

String paPymtMeth
支払方法

paAllocNmbr

String paAllocNmbr
ソートキー

paItemText

String paItemText
明細テキスト

paIndex

int paIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax は Object を拡張し、Serializable を実装しています

直列化されたフィールド

taItemnoAcc

String taItemnoAcc
会計伝票明細番号

taGlAccount

String taGlAccount
総勘定元帳勘定

taTaxCode

String taTaxCode
消費税コード

taIndex

int taIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bankKey

String bankKey
銀行コード

bankName

String bankName
銀行名

city

String city
市区町村名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

baList

BankList baList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bankList

ArrayList bankList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busArea

String busArea
事業領域

busArDes

String busArDes
事業領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busAreaList

BusinessAreaList busAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

businessAreaList

ArrayList businessAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compCode

String compCode
会社コード

compName

String compName
会社名

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compList

CompanyList compList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyList

ArrayList companyList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

coArea

String coArea
管理領域

name

String name
管理領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllAreaList

ControllingAreaList controllAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingAreaList

ArrayList controllingAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

costCenter

String costCenter
原価センタ

name

String name
一般名称

descript

String descript
テキスト

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCentList

CostCenterList costCentList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCenterList

ArrayList costCenterList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

cuItemnoAcc

String cuItemnoAcc
会計伝票明細番号

cuCurrency

String cuCurrency
通貨コード

cuAmtDoccur

String cuAmtDoccur
伝票通貨額

cuAmtBase

String cuAmtBase
課税基準額

cuIndex

int cuIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docObjType

String docObjType
参照処理

docObjKey

String docObjKey
オブジェクトキー

docUsername

String docUsername
ユーザ名

docHeaderTxt

String docHeaderTxt
伝票ヘッダテキスト

docCompCode

String docCompCode
会社コード

docAcDocNo

String docAcDocNo
会計伝票番号

docFiscYear

String docFiscYear
会計年度

docDocDate

String docDocDate
伝票の伝票日付

docPstngDate

String docPstngDate
伝票の転記日付

docFisPeriod

String docFisPeriod
会計期間

docDocType

String docDocType
伝票タイプ

docRefDocNo

String docRefDocNo
参照伝票番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

glAccount

String glAccount
G/L勘定コード

shortText

String shortText
G/L勘定コードテキスト(短)

longText

String longText
総勘定元帳勘定テキスト(長)

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glList

GlAccList glList
勘定科目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glAccList

ArrayList glAccList
勘定項目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

profitCtr

String profitCtr
利益センタ

validTo

String validTo
有効終了日

pctrName

String pctrName
一般名称

inCharge

String inCharge
利益センタ責任者

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCentList

ProfitCenterList profitCentList
利益センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCenterList

ArrayList profitCenterList
利益センタ一覧

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし


 All Tags / Functions
imarttag:imartDesignCss
imarttag:imartIcon
imarttag:ImartIcon
imarttag:imartInputTd
imarttag:imartItemNameTd
imarttag:imartListControl
imarttag:imartListHeader
imarttag:imartSelectTd
imarttag:imartTitleBar
imarttag:ImartTitleBar
imarttag:imartToolbarFrame
imarttag:ImartToolBarFrame
imarttag:imartToolbarLeft
imarttag:ImartToolbarLeft
imarttag:imartToolbarRight
imarttag:ImartToolbarRight


API Help (Tag Library Documentation Generator - Generated Documentation)

Overview Library Tag Help
PREV NEXT FRAMES NO FRAMES

How This Tag Library Document Is Organized

This TLD (Tag Library Descriptor) document has pages corresponding to the items in the navigation bar, described as follows.

Overview

The Overview page is the front page of this TLD document and provides a list of all tag libraries with a summary for each.

Library

Each tag library has a page that contains a list of its validator, listeners, tags, and functions, with a summary for each. This page can contain four categories:
  • Validator
  • Listeners
  • Tags
  • Functions

Validator

A tag library can have at most one validator. If a tag library has a validator, it has its own page describing the validator, the class that implements the validator, and the available initialization parameters.

Listeners

A tag library can have zero or more listeners. If a tag library has at least one listener, a page is generated that lists all listener classes registered for the tag library.

Tags

A tag library can have zero or more tags. Each tag has its own page that describes the tag, its display name, its unique action name, the class that implements the tag, the TagExtraInfo class, the body content type, scripting variable information, attributes, whether the tag supports dynamic attributes, and an optional example use of the tag.

Functions

A tag library can contain zero or more EL functions. If a tag library has at least one function, a page is generated that lists all functions, the class that implements the function, the function signature, and an optional example use of the function.

Prev/Next

These links take you to the next or previous validator, listener, tag, function, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Overview Library Tag Help
PREV NEXT FRAMES NO FRAMES
Output Generated by Tag Library Documentation Generator. Java, JSP, and JavaServer Pages are trademarks or registered trademarks of Sun Microsystems, Inc. in the US and other countries. Copyright 2002-4 Sun Microsystems, Inc. 4150 Network Circle Santa Clara, CA 95054, U.S.A. All Rights Reserved.


Overview (Tag Library Documentation Generator - Generated Documentation)

Tag Library Documentation Generator - Generated Documentation
All Tags / Functions

Tag Libraries
imarttag


※フィルターについて

各APIには、指定可能なフィルターと指定不可のフィルターがあります。
（詳細は各APIを参照ください。）

フィルターは下記のタスクに分類されます。
    ・未処理タスク   [GO]
    ・引き戻しタスク [PULLBACK]
    ・差し戻しタスク [SENDBACK]
    ・完了タスク     [COMPLETE]

また、タスクは下記の処理に分類されます。
    ・本人処理
    ・代理元処理不可
    ・代理元処理可

 | 本人処理 | 代理元処理不可 | 代理元処理可
未処理タスク | GO_FILTER | AGT_GO_FILTER | CLT_AGT_GO_FILTER
引き戻しタスク | PULLBACK_FILTER | AGT_PULLBACK_FILTER | CLT_AGT_PULLBACK_FILTER
差し戻しタスク | SENDBACK_FILTER | AGT_SENDBACK_FILTER | CLT_AGT_SENDBACK_FILTER
完了タスク | COMPLETE_FILTER | AGT_COMPLETE_FILTER | CLT_AGT_COMPLETE_FILTER

「GO_FILTER」と「AGT_GO_FILTER」のように、同タスクのフィルターは同時に指定可能
でますが、「GO_FILTER」と「COMPLETE_FILTER」のように、タスクが異なるフィルター
を同時に指定することは出来ません。

指定不可のフィルターを設定した場合は、検索結果が0件となります。

クラス Manager

※フィルターについて
メソッド getProcessList
未処理タスク | GO_FILTER | ○
 | AGT_GO_FILTER | －
 | CLT_AGT_GO_FILTER | －
引き戻しタスク | PULLBACK_FILTER | ○
 | AGT_PULLBACK_FILTER | －
 | CLT_AGT_PULLBACK_FILTER | －
差し戻しタスク | SENDBACK_FILTER | ○
 | AGT_SENDBACK_FILTER | －
 | CLT_AGT_SENDBACK_FILTER | －
完了タスク | COMPLETE_FILTER | ○
 | AGT_COMPLETE_FILTER | －
 | CLT_AGT_COMPLETE_FILTER | －

○：指定可能なフィルター
－：指定不可のフィルター

クラス Reference

※フィルターについて
メソッド getReferTaskList
未処理タスク | GO_FILTER | ○
 | AGT_GO_FILTER | －
 | CLT_AGT_GO_FILTER | －
引き戻しタスク | PULLBACK_FILTER | －
 | AGT_PULLBACK_FILTER | －
 | CLT_AGT_PULLBACK_FILTER | －
差し戻しタスク | SENDBACK_FILTER | －
 | AGT_SENDBACK_FILTER | －
 | CLT_AGT_SENDBACK_FILTER | －
完了タスク | COMPLETE_FILTER | ○
 | AGT_COMPLETE_FILTER | －
 | CLT_AGT_COMPLETE_FILTER | －

○：指定可能なフィルター
－：指定不可のフィルター

クラス Drafter

※フィルターについて
メソッド getActivityProcessDefList
未処理タスク | GO_FILTER | △
 | AGT_GO_FILTER | ○
 | CLT_AGT_GO_FILTER | ○
引き戻しタスク | PULLBACK_FILTER | －
 | AGT_PULLBACK_FILTER | －
 | CLT_AGT_PULLBACK_FILTER | －
差し戻しタスク | SENDBACK_FILTER | －
 | AGT_SENDBACK_FILTER | －
 | CLT_AGT_SENDBACK_FILTER | －
完了タスク | COMPLETE_FILTER | －
 | AGT_COMPLETE_FILTER | －
 | CLT_AGT_COMPLETE_FILTER | －
メソッド getEndProcessList
未処理タスク | GO_FILTER | △
 | AGT_GO_FILTER | ○
 | CLT_AGT_GO_FILTER | ○
引き戻しタスク | PULLBACK_FILTER | △
 | AGT_PULLBACK_FILTER | ○
 | CLT_AGT_PULLBACK_FILTER | ○
差し戻しタスク | SENDBACK_FILTER | △
 | AGT_SENDBACK_FILTER | ○
 | CLT_AGT_SENDBACK_FILTER | ○
完了タスク | COMPLETE_FILTER | △
 | AGT_COMPLETE_FILTER | ○
 | CLT_AGT_COMPLETE_FILTER | ○

○：指定可能なフィルター
△：本人インスタンス生成時は可能／代理人インスタンス生成時は不可のフィルター
－：指定不可のフィルター

クラス Approver

※フィルターについて
メソッド getActivityTaskList
未処理タスク | GO_FILTER | △
 | AGT_GO_FILTER | ○
 | CLT_AGT_GO_FILTER | ○
引き戻しタスク | PULLBACK_FILTER | △
 | AGT_PULLBACK_FILTER | ○
 | CLT_AGT_PULLBACK_FILTER | ○
差し戻しタスク | SENDBACK_FILTER | △
 | AGT_SENDBACK_FILTER | ○
 | CLT_AGT_SENDBACK_FILTER | ○
完了タスク | COMPLETE_FILTER | －
 | AGT_COMPLETE_FILTER | －
 | CLT_AGT_COMPLETE_FILTER | －
メソッド getEndTaskList
未処理タスク | GO_FILTER | △
 | AGT_GO_FILTER | ○
 | CLT_AGT_GO_FILTER | ○
引き戻しタスク | PULLBACK_FILTER | －
 | AGT_PULLBACK_FILTER | －
 | CLT_AGT_PULLBACK_FILTER | －
差し戻しタスク | SENDBACK_FILTER | －
 | AGT_SENDBACK_FILTER | －
 | CLT_AGT_SENDBACK_FILTER | －
完了タスク | COMPLETE_FILTER | △
 | AGT_COMPLETE_FILTER | ○
 | CLT_AGT_COMPLETE_FILTER | ○

○：指定可能なフィルター
△：本人インスタンス生成時は可能／代理人インスタンス生成時は不可のフィルター
－：指定不可のフィルター


Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


i ntra-mart The Power for Enterprise Web Solution


プロセス種別コード
ビジネスプロセスワークフロー | 0
ドキュメントワークフロー | 1
申請者ルート作成ワークフロー | 2

プロセスステータス
アクティブ | 1
完了 | 4

アクティビティステータス
準備中 | 0
アクティブ | 1
保留中 | 2
取り消し中 | 3
完了 | 4

到達種別
未到達 | 00
通常到達 | 01
引戻し | 20
被引戻し | 21
差戻し | 30
被差戻し | 31
被差戻し | 32

処理結果
申請 | 0
再申請 | 1
承認 | 2
棄却 | 3
申請者へ差戻し | 4
前処理者へ差戻し | 5
引き戻し | 6
保留 | 7
取り止め | 8
対象者自動パス | 9
プロセス操作 | 99

現在の状態
【本人・代理設定なし】
通常 | 000 | 通常到達にてアクティブ
引戻し | 005 | 引戻しにてアクティブ
差戻し | 006 | 差戻しにてアクティブ
通常(保留) | 010 | 通常到達にてアクティブ後の保留
引戻し(保留) | 015 | 引戻しにてアクティブ後の保留
差戻し(保留) | 016 | 差戻しにてアクティブの保留
【代理設定有り・本人決済可】
通常 | 100 | 通常到達にてアクティブ
引戻し | 105 | 引戻しにてアクティブ
差戻し | 106 | 差戻しにてアクティブ
通常(保留) | 110 | 通常到達にてアクティブ後の保留
引戻し(保留) | 115 | 引戻しにてアクティブ後の保留
差戻し(保留) | 116 | 差戻しにてアクティブの保留
【代理設定有り・本人決不可】
通常 | 200 | 通常到達にてアクティブ
引戻し | 205 | 引戻しにてアクティブ
差戻し | 206 | 差戻しにてアクティブ
通常(保留) | 210 | 通常到達にてアクティブ後の保留
引戻し(保留) | 215 | 引戻しにてアクティブ後の保留
差戻し(保留) | 216 | 差戻しにてアクティブの保留
【共通】
完了 | 999 | 完了

処理結果ID
プロセス定義新規登録 | 1
バージョン追加 | 2
プロセス定義更新 | 3

アクティビティ種別
手動タスク | EMPTY
同期タスク | FLOW
自動実行タスク | INVOKE_AUTO
イベント実行タスク | INVOKE_EVENT
サブプロセスタスク | INVOKE_PROCESS
プロセスタスク | PROCESS
処理タスク | RECEIVE
シーケンスタスク (ルート情報を構成するための管理データ) | SEQUENCE
分岐タスク | SWITCH
ルート選択タスク | MULTI
ルート選択タスク | TERMINATE

承認種別
申請 | DRAFT
再申請 | RETRY
承認 | APPROVAL
否認 | REJECTION
申請者へ差し戻し | RETURN_START
承認者へ差し戻し | RETURN_BEFORE
引戻し | RETURN_PULL
保留 | SUSPENTION
取り止め | CANCEL

アクティビティ種別
処理タスク | 1
プロセス呼出(サブプロセス) | 2
自動呼出(自動実行タスク) | 3
フロー(同期タスク) | 5
ターミネート(終了タスク) | 6
エンプティ(手動タスク) | 7
スイッチ(分岐タスク) | 8
イベント(イベント実行) | 9
ルート選択タスク | A


クラス Manager
メソッド　getProcessList（プロセス一覧情報を取得）

    // パラメータの設定
    String userId  = "ログインユーザーコード";
    String groupCd = "ログイングループID";

    // 検索条件(未処理タスクを取得)
    SearchCondition searchCondition = new SearchCondition();
    Map searchConditionMap          = new HashMap();
    searchConditionMap.put( SearchCondition.GO_FILTER , new Boolean(true) );
    searchCondition.setCondition( searchConditionMap );

    // ソートを指定(昇順)
    Sort[] sortKey = new Sort[5];
    sortKey[0]     = new Sort();
    sortKey[1]     = new Sort();
    sortKey[2]     = new Sort();
    sortKey[3]     = new Sort();
    sortKey[4]     = new Sort();
    sortKey[0].setAscending( "category_cd" );
    sortKey[1].setAscending( "process_def_cd" );
    sortKey[2].setAscending( "version_cd" );
    sortKey[3].setAscending( "process_cd" );
    sortKey[4].setAscending( "activity_cd" );

    // フェッチ開始位置を指定
    int start = 0;

    // フェッチ件数を指定
    int amount = 10;

    // コンストラクタの生成
    Manager manager = new Manager( userId , groupCd );

    // プロセス一覧情報を取得
    List processList = manager.getProcessList( searchCondition , sortKey , start , amount );

クラス Process
メソッド　getTaskResultInfo（タスク処理結果情報を取得）

    // パラメータの設定
    String groupCd      = "ログイングループID";
    String processDefCd = "プロセス定義コード";
    String versionCd    = "バージョンコード";
    String processCd    = "プロセスコード";
    String activityCd   = "アクティビティコード";

    // コンストラクタの生成
    Process process = new Process( processDefCd , versionCd , processCd , groupCd );

    // タスク処理結果情報を取得
    Map taskResultInfoMap = process.getTaskResultInfo( activityCd );

クラス FlowInfo
メソッド　getNext（次タスクのフロー情報を取得）

    // パラメータの設定
    String userId       = "ログインユーザーコード";
    String groupCd      = "ログイングループID";
    String processDefCd = "プロセス定義コード";
    String versionCd    = "バージョンコード";
    String activityCd   = "アクティビティコード";

    // コンストラクタの生成
    Manager manager   = new Manager( userId , groupCd );
    FlowInfo flowinfo = manager.getFlowInfo( processDefCd , versionCd , activityCd );

    // 次タスクのフロー情報を取得
    List nextFlowInfo = flowinfo.getNext();

クラス Reference
メソッド　getReferTaskList（参照可能案件一覧を取得）

    // パラメータの設定
    String userId  = "ログインユーザーコード";
    String groupCd = "ログイングループID";

    // 検索条件(完了タスクを取得)
    SearchCondition searchCondition = new SearchCondition();
    Map searchConditionMap          = new HashMap();
    searchConditionMap.put( SearchCondition.COMPLETE_FILTER , new Boolean(true) );
    searchCondition.setCondition( searchConditionMap );

    // コンストラクタの生成
    Reference reference = new Reference( userId , groupCd );

    // 参照可能案件一覧を取得
    List referTaskListList = reference.getReferTaskList( searchCondition , (Sort[])null , 0 , 0 );

クラス Drafter
メソッド　draft（申請処理）

    // パラメータの設定
    String userId                   = "ログインユーザーコード";
    String groupCd                  = "ログイングループID";

    String processDefCd             = "プロセス定義コード";
    String versionCd                = "バージョンコード";
    String processTemporaryCd       = "一時プロセスID";
    String processName              = "プロセス名";
    ArrayList appKey                = new ArrayList();
    String draftAppointDate         = "起票指定日";
    String compCd                   = "起票会社コード";
    String orgnCd                   = "起票組織コード";
    String comment                  = "起票コメント";
    NegoModel nego                  = new NegoModel();
    RunExecutiveInfoModel executant = new RunExecutiveInfoModel();
    RunUserInfoModel executant      = new RunUserInfoModel();
    String routeSelectCd            = "ルート選択番号";
    String locale                   = "ロケール";

/*------------------------------------------------------------------*/
    // アプリケーションキーの設定
    appKey.add( 0 , "" );
    appKey.add( 1 , "要素1" );
    appKey.add( 2 , "要素2" );
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // RunExecutiveInfoModelとRunUserInfoModelは同時には使用できません。

    // 実行時選択時 - 組織設定の場合
    executant.setCompanyCd( "会社コード" );
    executant.setPostCd( "組織コード" );

    // 実行時選択時 - ユーザー設定の場合
    executant.setUserCd( "ユーザーコード" );

    // 実行時選択ではない場合
    executant = null;
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 根回しメール設定
    ArrayList userList = new ArrayList();
    Map map            = new HashMap();
    map.put( "cd" , "送信先ユーザコード" );
    userList.add( map );

    nego.setUserList( userList );    // 根回しメール送信者リスト
    nego.setTitle( "根回しメールタイトル" );
    nego.setComment( "根回しメール本文" );

    // 根回しメールを送信しない場合
    nego = null;
/*------------------------------------------------------------------*/

    // コンストラクタの生成
    Drafter drafter = new Drafter( userId , groupCd );

    // 申請処理
    ProcessInfoModel processInfoModel = drafter.draft(
        processDefCd,
        versionCd,
        processTemporaryCd,
        processName,
        appKey,
        draftAppointDate,
        compCd,
        orgnCd,
        comment,
        nego,
        executant,
        routeSelectCd,
        locale
    );

クラス Approver
メソッド　Approver（承認処理）

    // パラメータの設定
    String userId                   = "ログインユーザーコード";
    String groupCd                  = "ログイングループID";

    String processDefCd             = "プロセス定義コード";
    String versionCd                = "バージョンコード";
    String processCd               =  "プロセスコード";
    String activityCd               = "アクティビティコード";
    Boolean isFinish                = "途中終了フラグ";
    String compCd                   = "承認会社コード";
    String orgnCd                   = "承認組織コード";
    String comment                  = "承認コメント";
    NegoModel nego                  = new NegoModel();
    RunExecutiveInfoModel executant = new RunExecutiveInfoModel();
    RunUserInfoModel executant      = new RunUserInfoModel();
    String routeSelectCd            = "ルート選択番号";

/*------------------------------------------------------------------*/
    // RunExecutiveInfoModelとRunUserInfoModelは同時には使用できません。

    // 実行時選択時 - 組織設定の場合
    executant.setCompanyCd( "会社コード" );
    executant.setPostCd( "組織コード" );

    // 実行時選択時 - ユーザー設定の場合
    executant.setUserCd( "ユーザーコード" );

    // 実行時選択ではない場合
    executant = null;
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 根回しメール設定
    ArrayList userList = new ArrayList();
    Map map            = new HashMap();
    map.put( "cd" , "送信先ユーザコード" );
    userList.add( map );

    nego.setUserList( userList );    // 根回しメール送信者リスト
    nego.setTitle( "根回しメールタイトル" );
    nego.setComment( "根回しメール本文" );

    // 根回しメールを送信しない場合
    nego = null;
/*------------------------------------------------------------------*/

    // コンストラクタの生成
    Approver approver = new Approver( userId , groupCd );

    // 承認処理
    approver.approve(
        processDefCd,
        versionCd,
        processCd,
        activityCd,
        isFinish,
        compCd,
        orgnCd,
        comment,
        nego,
        executant,
        routeSelectCd
    );


WkfManager オブジェクト
メソッド　getProcessList（プロセス一覧情報を取得）

    // パラメータの設定
    var userId  = "ログインユーザーコード";
    var groupCd = "ログイングループID";

    // 検索条件(未処理タスクを取得)
    var conditionKey       = new Object();
    conditionKey.go_filter = true;
    var wkfSearchCondition = new WkfSearchCondition();
    wkfSearchCondition.setCondition( conditionKey );

    // ソートを指定(昇順)
    var sortKey = new Array();
    var wkfSort = null;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "category_cd" );
    sortKey[0]  = wkfSort;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "process_def_cd" );
    sortKey[1]  = wkfSort;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "version_cd" );
    sortKey[2]  = wkfSort;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "process_cd" );
    sortKey[3]  = wkfSort;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "activity_cd" );
    sortKey[4]  = wkfSort;

    // フェッチ開始位置を指定
    var start = 0;

    // フェッチ件数を指定
    var amount = 10;

    // コンストラクタの生成
    var wkfManager = new WkfManager( userId , groupCd );

    // プロセス一覧情報を取得
    var processList = wkfManager.getProcessList( wkfSearchCondition , sortKey , start , amount );

WkfProcess オブジェクト
メソッド　getTaskResultInfo（タスク処理結果情報を取得）

    // パラメータの設定
    var groupCd      = "ログイングループID";
    var processDefCd = "プロセス定義コード";
    var versionCd    = "バージョンコード";
    var processCd    = "プロセスコード";
    var activityCd   = "アクティビティコード";

    // コンストラクタの生成
    var wkfProcess = new WkfProcess( processDefCd , versionCd , processCd , groupCd );

    // タスク処理結果情報を取得
    var taskResultInfo = wkfProcess.getTaskResultInfo( activityCd );

WkfFlowInfo オブジェクト
メソッド　getNext（次タスクのフロー情報を取得）

    // パラメータの設定
    var userId       = "ログインユーザーコード";
    var groupCd      = "ログイングループID";
    var processDefCd = "プロセス定義コード";
    var versionCd    = "バージョンコード";
    var activityCd   = "アクティビティコード";

    // コンストラクタの生成
    var wkfManager  = new WkfManager( userId , groupCd );
    var flowInfo    = wkfManager.getFlowInfo( processDefCd , versionCd , activityCd );

    //フロー情報オブジェクトの設定
    var wkfFlowInfo = new WkfFlowInfo( flowInfo );

    // 次タスクのフロー情報を取得
    var wkfFlowInfoNext = wkfFlowInfo.getNext();

メソッド　getPrev（最終タスクのフロー情報を取得）

    // パラメータの設定
    var userId       = "ログインユーザーコード";
    var groupCd      = "ログイングループID";
    var processDefCd = "プロセス定義コード";
    var versionCd    = "バージョンコード";
    var activityCd   = "アクティビティコード";

    // コンストラクタの生成
    var wkfManager  = new WkfManager( userId , groupCd );
    var flowInfo    = wkfManager.getFlowInfo( processDefCd , versionCd , activityCd );

    //フロー情報オブジェクトの設定
    var wkfFlowInfo = new WkfFlowInfo( flowInfo );

    // ENDタスクのフロー情報を取得
    var wkfFlowInfoLast = wkfFlowInfo.getLast();

    // 最終処理タスク（ENDのひとつ前のタスク）のフロー情報を取得
    var wkfFlowInfoLastTask = wkfFlowInfoLast.getPrev();
    var flowinfoLastTask = wkfFlowInfoLastTask.get(0);

WkfReference オブジェクト
メソッド　getReferTaskList（参照可能案件一覧を取得）

    // パラメータの設定
    var userId  = "ログインユーザーコード";
    var groupCd = "ログイングループID";

    // 検索条件(完了タスクを取得)
    var conditionKey             = new Object();
    conditionKey.complete_filter = true;
    var wkfSearchCondition       = new WkfSearchCondition();
    wkfSearchCondition.setCondition( conditionKey );

    // コンストラクタの生成
    var wkfReference = new WkfReference( userId , groupCd );

    // 参照可能案件一覧を取得
    var referTaskList = wkfReference.getReferTaskList( wkfSearchCondition , null , 0 , 0 );

WkfDrafter オブジェクト
メソッド　draft（申請処理）

    // パラメータの設定
    var userId             = "ログインユーザーコード";
    var groupCd            = "ログイングループID";

    var processDefCd       = "プロセス定義コード";
    var versionCd          = "バージョンコード";
    var processTemporaryCd = "一時プロセスID";
    var processName        = "プロセス名";
    var appKey             = new Array();
    var draftAppointDate   = "起票指定日";
    var compCd             = "起票会社コード";
    var orgnCd             = "起票組織コード";
    var comment            = "起票コメント";
    var nego               = new Object();
    var executant          = new Object();
    var routeSelectCd      = "ルート選択番号";
    var locale             = "ロケール";

/*------------------------------------------------------------------*/
    // アプリケーションキーの設定
    appKey[0] = "要素1";
    appKey[1] = "要素2";
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 実行時選択時 - 組織設定の場合
    executant.type    = "orgn";
    executant.comp_cd = "会社コード";
    executant.cd      = "組織コード";

    // 実行時選択時 - ユーザー設定の場合
    executant.type    = "user";
    executant.cd      = "ユーザーコード";

    // 実行時選択ではない場合
    executant         = null;
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 根回しメール設定
    nego.userList          = new Array();
    nego.userList[0]       = new Object();
    nego.userList[0].cd    = "送信先ユーザコード";
    nego.title             = "根回しメールタイトル";
    nego.comment           = "根回しメール本文";

    // 根回しメールを送信しない場合
    nego                   = null;
/*------------------------------------------------------------------*/

    // コンストラクタの生成
    var wkfDrafter = new WkfDrafter( userId , groupCd );

    // 申請処理
    var draft = wkfDrafter.draft(
        processDefCd,
        versionCd,
        processTemporaryCd,
        processName,
        appKey,
        draftAppointDate,
        compCd,
        orgnCd,
        comment,
        nego,
        executant,
        routeSelectCd,
        locale
    );

WkfApprover オブジェクト
メソッド　Approver（承認処理）

    // パラメータの設定
    var userId             = "ログインユーザーコード";
    var groupCd            = "ログイングループID";

    var processDefCd       = "プロセス定義コード";
    var versionCd          = "バージョンコード";
    var processCd          = "プロセスコード";
    var activityCd         = "アクティビティコード";
    var isFinish           = "途中終了フラグ";
    var compCd             = "承認会社コード";
    var orgnCd             = "承認組織コード";
    var comment            = "承認コメント";
    var nego               = new Object();
    var executant          = new Object();
    var routeSelectCd      = "ルート選択番号";

/*------------------------------------------------------------------*/
    // 実行時選択時 - 組織設定の場合
    executant.type    = "orgn";
    executant.comp_cd = "会社コード";
    executant.cd      = "組織コード";

    // 実行時選択時 - ユーザー設定の場合
    executant.type    = "user";
    executant.cd      = "ユーザーコード";

    // 実行時選択ではない場合
    executant         = null;
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 根回しメール設定
    nego.userList          = new Array();
    nego.userList[0]       = new Object();
    nego.userList[0].cd    = "送信先ユーザコード";
    nego.title             = "根回しメールタイトル";
    nego.comment           = "根回しメール本文";

    // 根回しメールを送信しない場合
    nego                   = null;
/*------------------------------------------------------------------*/

    // コンストラクタの生成
    var wkfApprover  = new WkfApprover( userId , groupCd );

    // 承認処理
    var approve = wkfApprover.approve(
        processDefCd,
        versionCd,
        processCd,
        activityCd,
        isFinish,
        compCd,
        orgnCd,
        comment,
        nego,
        executant,
        routeSelectCd
    );


インタフェース jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の使用

jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException の使用

WKFApplicationException を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での WKFApplicationException の使用

WKFApplicationException をスローする jp.co.intra_mart.foundation.wkf のメソッド
void | Util.sendMail(java.lang.String template_path, java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.util.ArrayList to, java.util.ArrayList cc, java.util.ArrayList bcc) メール送信処理を行います。
void | Util.autoPass(java.lang.String category_cd, java.lang.String process_def_cd, java.lang.String version_cd, int date) 案件の自動パス(バッチ起動)処理を行います。
void | Util.autoPress(java.lang.String category_cd, java.lang.String process_def_cd, java.lang.String version_cd, int date) 案件の自動催促(バッチ起動)処理を行います。
java.util.Map | Process.getTaskResultInfo(java.lang.String activity_cd) タスク処理結果情報を取得します。
void | Manager.removeProcess(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.Boolean xml_out_flg) 案件を削除を実行します。
java.util.List | Manager.importProcessDef(java.lang.Object xls_file) プロセス定義(Excel形式)をインポートします。
byte[] | Manager.exportProcessDef(java.util.ArrayList process_def_cd) プロセス定義(Excel形式)をエクスポートします。
java.util.Map | Manager.getProcessDefInfo(java.lang.String process_def_cd) プロセス定義コードをキーにしてプロセス定義情報を取得します。
java.util.List | Manager.getProcessDefInfoByName(java.lang.String process_def_name) プロセス定義名をキーにしてプロセス定義情報を取得します。
java.util.Map | Manager.getProcessDefInfoByVersion(java.lang.String process_def_cd, java.lang.String version_cd) プロセス定義コード、バージョンコードをキーにしてプロセス定義情報を取得します。
FlowInfo | Manager.getFlowInfo(java.lang.String processDefCd, java.lang.String versionCd, java.lang.String activityCd) 特定のタスクの位置情報を保持して、フロー情報を取得する。
ProcessInfoModel | Drafter.draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
ProcessInfoModel | Drafter.draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
void | Drafter.retry(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 再起票処理を実行します。
void | Drafter.retry(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 再起票処理を実行します。
void | Drafter.cancel(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 取り止め処理を実行します。
void | Drafter.pullBack(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd) 引戻し処理を実行します。
void | Drafter.subProcessDraft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Drafter.subProcessDraft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.Boolean isFinish, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd) 承認処理を実行します。
void | Approver.approve(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.Boolean isFinish, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd) 承認処理を実行します。
void | Approver.denial(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 否認処理を実行します。
void | Approver.suspend(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 保留処理を実行します。
void | Approver.sendBack(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String type, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 差し戻し処理を実行します。
void | Approver.pullBack(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd) 引き戻し処理を実行します。

WKFApplicationException をスローする jp.co.intra_mart.foundation.wkf のコンストラクタ
Util(java.lang.String login_group_id)
コンストラクタ
Reference(java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ
Process(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String login_group_id)
コンストラクタ
Manager(java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ
カテゴリの編集権限ロールをもつユーザを指定してください。
Drafter(java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ１(本人用)
Drafter(java.lang.String agent_user_cd, java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ２(代理人用)。
Approver(java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ１(本人用)
Approver(java.lang.String agent_user_cd, java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ２(代理人用)。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の使用

jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


BPWErrorCodeIF (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.exception
インタフェース BPWErrorCodeIF

public interface BPWErrorCodeIF

ＢＰＷで利用される例外エラーコードインタフェース定義

フィールドの概要
static java.lang.String | BPW_C_ALREADY_EXIST_TRANSFER 処理委譲できません。
static java.lang.String | BPW_C_ALREADY_SUSPEND 既に保留されている可能性があります。
static java.lang.String | BPW_C_AUTO_EXECUTE_FAULT 自動実行処理が異常復帰しました。
static java.lang.String | BPW_C_CAN_NOT_START_JAVASCRIPT JavaScriptが起動できません。
static java.lang.String | BPW_C_CAN_NOT_TRANSFER 処理委譲できません。
static java.lang.String | BPW_C_CHANGE_INFO 他のユーザに情報が変更されました。
static java.lang.String | BPW_C_CHANGING_NOW 関連する情報が修正中であり反映できません。
static java.lang.String | BPW_C_DATA_NOT_FOUND データが存在しません。
static java.lang.String | BPW_C_DUPLICATE_NAME 名称が重複しています。
static java.lang.String | BPW_C_EXIST_PROCESS_DEF 有効なプロセス定義が存在します。
static java.lang.String | BPW_C_FAILED_GET_HTTP_EXCEL_STREAM Excelファイルストリーム取得に失敗しました。
static java.lang.String | BPW_C_FAILED_READ_EXCEL_STREAM Excelファイルストリーム読み込みに失敗しました。
static java.lang.String | BPW_C_FOUND_AUTO_PASS_TABLE 関連付く自動パス情報が存在します。
static java.lang.String | BPW_C_FOUND_PROCESS 関連付くプロセス情報が存在します。
static java.lang.String | BPW_C_FOUND_RECEIVE_MASTER レシーブマスタ情報が存在しません。
static java.lang.String | BPW_C_FOUND_RECEIVE_TABLE 関連付くレシーブ情報が存在します。
static java.lang.String | BPW_C_FOUND_RUN_USER_TABLE 関連付く実行主体ユーザ情報が存在します。
static java.lang.String | BPW_C_FOUND_RUNNING_PROCESS 実行中のプロセスが存在します。
static java.lang.String | BPW_C_FOUND_VERSION 関連付く履歴情報が存在します。
static java.lang.String | BPW_C_HAVE_NOT_AUTHORITY 権限がありません。
static java.lang.String | BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND 権限、及び権限に関連する情報がありません。
static java.lang.String | BPW_C_ILLIGAL_STATUS ステータスが異常です。
static java.lang.String | BPW_C_ILLIGAL_STATUS_CHG ステータス遷移が異常です。
static java.lang.String | BPW_C_IMPORT_AUTO_PASS_ORGS 自動パス対象ヘ複数組織／グループを指定することは出来ません。
static java.lang.String | BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER 実行時選択のレシーブは指定できません。
static java.lang.String | BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD プロセス種別の設定が不正です。
static java.lang.String | BPW_C_IMPORT_DUPLICATE_APPROVAL_CD 承認対象コードが重複しています。
static java.lang.String | BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE コンテンツ種別が重複して指定されています。
static java.lang.String | BPW_C_IMPORT_DUPLICATE_PROCESS_CONTENTSTYPE コンテンツ種別が重複して指定されています。
static java.lang.String | BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION シート内でプロセス定義名が重複しています。
static java.lang.String | BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID ルート定義IDが重複して指定されています。
static java.lang.String | BPW_C_IMPORT_DUPLICATE_SEND_TO_ID 通知先IDが重複しています。
static java.lang.String | BPW_C_IMPORT_DUPLICATE_TASK_ID タスクIDが重複しています。
static java.lang.String | BPW_C_IMPORT_INVALID_ACTIVITY_TYPE アクティビティ種別の設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_APPLICATION_ID アプリケーションIDが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN アプリケーションID長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_APPROVAL 承認対象種別設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG 承認対象種別設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_APPROVAL_FOCUS 承認対象が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_APPROVAL_OBJECT 承認対象種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD 自動パス役職コードが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND 自動パス役職種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_FLG 自動パス処理フラグが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS 自動パス対象が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_TERM 自動パス期限が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN 自動パス期限長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD 自動パスユーザコードが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD 呼び出しプロセス定義コードが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN 呼び出しプロセス定義コード長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN 実行クラス長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN カテゴリコード長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CODE_KIND コード種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CODE_KIND_VALUE コード種別が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_COMPULSION_END_FLG 強制終了可否フラグが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CONDITION_CALSS 条件クラスが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN 条件クラス長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CONTENTS_PATH コンテンツパスが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN コンテンツパス長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_CONTENTSTYPE コンテンツ種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND 起票タイプが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_EFFECTIVE_DATE 有効日付が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN 有効日付長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_END_DATE 終了日付が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_END_DATE_LEN 終了日付長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID イベントサービスIDが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN イベントサービスID長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_FUNCTION_KBN 処理区分が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN 催促メール内容定義長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT 催促メール猶予日数が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN 催促メール猶予日長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN 催促メール表題定義長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION 催促メール対象種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN 催促メール対象種別長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PAGBE_KIND ページ種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY 実行時選択前アクティビティ種別の設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID アプリケーションIDが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN アプリケーションID長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD プロセス種別が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH コンテンツパスが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN コンテンツパス長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE コンテンツ種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN プロセス定義コード長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT アクティビティ種別設定数が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND ページ種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT アクティビティ種別設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID サービスIDが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN サービスID長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_SWITCH アクティビティ種別設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW プロセス種別とサブプロセス識別フラグの設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW プロセス種別とサブプロセス識別フラグの設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_REFER_FOCUS 参照対象が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_REFER_USER_CD 参照者ユーザコードが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RESULT_CONTENTS_DEF_LEN 結果通知内容定義長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RESULT_FROM_DEF 結果通知元定義が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RESULT_FROM_DEF_LEN 結果通知元定義長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RESULT_NOTICE_FLG 結果通知フラグが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RESULT_TITLE_DEF_LEN 結果通知表題定義長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RESULT_TO_OBJECT_FLG 結果通知対象種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RETURN_PULL_FLG 引戻し・差戻しフラグが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG 引戻し・差戻しメール送信フラグが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG ルート定義が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW フロー情報のルート定義入力が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE サブプロセス（申請者／承認者ルート作成ワークフロー）の前アクティビティ種別の設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE ルート選択の前アクティビティ種別の設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE 実行時選択の前アクティビティ種別の設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD 実効アクティビティコードが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN 実効アクティビティコード長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RUN_CLASS 実行クラスが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD 会社CDが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD 実行主体役職コードが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND 実行主体役職種別が指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RUN_USER_CD 実行主体ユーザコードが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION ルート定義ないのタスクの位置の入力が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SECOND_APPROVAL 承認対象種別設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN 選択ルートコード長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN 選択ルート名長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SERVECE_ID サービスIDが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SERVICE_ID_LEN サービスID長が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG 最短終了フラグが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW 最短終了フラグの設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW 最短終了フラグの設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_START_ACTIVITY ルートの開始アクティビティ種別設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SUB_PROCESS サブプロセスの設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG サブプロセス識別フラグが不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_TASK_ID タスク定義に存在しないタスクIDが指定されました。
static java.lang.String | BPW_C_IMPORT_INVALID_TASK_TYPE タスクタイプが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_TOP_ACTIVITY ルートの先頭アクティビティ種別設定が不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_VERSION_CD 履歴コードが指定されていない、または不正です。
static java.lang.String | BPW_C_IMPORT_INVALID_VERSION_CD_LEN 履歴コード長が不正です。
static java.lang.String | BPW_C_IMPORT_LACK_SEND_TO_INFO 通知先情報の指定が不完全です。
static java.lang.String | BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER オートアダプタマスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER 自動パス役職マスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_AUTO_PASS_INFO 自動パス情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_AUTO_PASS_MASTER 自動パスマスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_AUTO_PASS_USER_CD 自動パスユーザコードが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_CONTENTS_MASTER コンテンツマスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER イベントアダプタマスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT 承認対象種別設定が不正です。
static java.lang.String | BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD 自動パス役職コードが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD 参照者組織コードが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_EXIST_REFER_USER_CD 参照者ユーザコードが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD 会社CDが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD 実行主体役職コードが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_EXIST_RUN_USER_CD 実行主体ユーザコードが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS 始めの条件クラスが指定されていません。
static java.lang.String | BPW_C_IMPORT_NO_FIRST_TASK_ID 始めのタスクIDが指定されていません。
static java.lang.String | BPW_C_IMPORT_NO_FIRST_TASK_ID_OF_ROUTE_SELECT 始めのタスクIDまたは選択ルート名が指定されていません。
static java.lang.String | BPW_C_IMPORT_NO_FLOW_INNER_MASTER フロー内容マスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY フロー内容マスタ情報の実行アクティビティが設定されていません。
static java.lang.String | BPW_C_IMPORT_NO_LICENSE 指定されたプロセス種別に対するライセンスがありません。
static java.lang.String | BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER オートアダプタ・イベントアダプタ情報を設定するライセンスがありません。
static java.lang.String | BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW スイッチ・フロー情報を設定するライセンスがありません。
static java.lang.String | BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER プロセスアダプタマスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE 最初のシーケンスにレシーブが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_RECEIVE_MASTER レシーブマスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_RESULT_SEND_MASTER 結果通知先マスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER ルート選択マスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER 実行主体役職マスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_RUN_USER_MASTER 実行主体ユーザマスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_SELECT_ROUTE_CD ルート選択マスタ情報の選択ルートコードが設定されていません。
static java.lang.String | BPW_C_IMPORT_NO_SELECT_ROUTE_NAME ルート選択マスタ情報の選択ルート名が設定されていません。
static java.lang.String | BPW_C_IMPORT_NO_SEQUENCE_MASTER シーケンス内容マスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY シーケンスマスタ情報の実行アクティビティが設定されていません。
static java.lang.String | BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE フローのサブルートが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT ルート選択のサブルートが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH スイッチのサブルートが存在しません。
static java.lang.String | BPW_C_IMPORT_NO_SWITCH_MASTER スイッチマスタ情報が設定されてません。
static java.lang.String | BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY スイッチマスタ情報の実行アクティビティが設定されていません。
static java.lang.String | BPW_C_IMPORT_NO_TASK_DEF タスク定義が指定されていません。
static java.lang.String | BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF ルート定義内のタスクIDがタスク定義に指定されていません。
static java.lang.String | BPW_C_IMPORT_OVER_NOTE_LEN 備考文字列長が最大文字列長を超えています。
static java.lang.String | BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN プロセス種別文字列長が最大文字列長を超えています。
static java.lang.String | BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN プロセス定義名長が最大文字列長を超えています。
static java.lang.String | BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN プロセス定義備考文字列長が最大文字列長を超えています。
static java.lang.String | BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN サブプロセス識別フラグ文字列長が最大文字列長を超えています。
static java.lang.String | BPW_C_IMPORT_PLURAL_APPROVAL 起案タスク以外は、複数対象者の設定をすることはできません。
static java.lang.String | BPW_C_IMPOSSIBLE_PROCESS_DRAFT 当該プロセスは起票できません。
static java.lang.String | BPW_C_IMPOSSIBLE_PROCESS_DRAFT_TARGET_DATE 指定した起票指定日では、申請を行う事ができません。
static java.lang.String | BPW_C_IMPOSSIBLE_PULL_DRAFT 引き戻し処理が実行できません。
static java.lang.String | BPW_C_IMPOSSIBLE_RETURN 引き戻し・差し戻し処理が実行できません。
static java.lang.String | BPW_C_IMPOSSIBLE_RETURN_DRAFT 差し戻し処理が実行できません。
static java.lang.String | BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO この履歴情報は使用できません。
static java.lang.String | BPW_C_INPOSSIBLE_DRAFT_ACTIVITY 申請イベントに失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_GET_ROOT_INFO アクティビティルート取得イベントに失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_GET_USER_APP_KEY ユーザアプリケーションキー取得イベントに失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND メールテンプレートの送信に失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_PULL_ACTIVITY 引き戻しイベントに失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_RECOGNITION_ACTIVITY 承認イベントに失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_REGIST_USER_APP_KEY ユーザアプリケーションキー登録イベントに失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY 承認者への差し戻しイベントに失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_RETURN_START_ACTIVITY 申請者への差し戻しイベントに失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY 予約メール依頼の設定に失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY テンプレートメール送信抑止の設定に失敗しました。
static java.lang.String | BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY メールテンプレートの設定に失敗しました。
static java.lang.String | BPW_C_INVALID_ACTIVITY_STATUS アクティビティステータスが不正です。
static java.lang.String | BPW_C_INVALID_ACTIVITY_TYPE アクティビティ種別が不正です。
static java.lang.String | BPW_C_INVALID_ADAPTER_TYPE アダプタ種別が不正です。
static java.lang.String | BPW_C_INVALID_APPROVAL_TYPE 承認種別が不正です。
static java.lang.String | BPW_C_INVALID_APPROVAL_USER 承認ユーザコードが不正です。
static java.lang.String | BPW_C_INVALID_ATTACH_INFO 申請・承認時の所属情報が指定されていない、または不正です。
static java.lang.String | BPW_C_INVALID_CATEGORY 関連付けるカテゴリ情報が存在しない、または無効です。
static java.lang.String | BPW_C_INVALID_CATEGORY_CODE カテゴリコードが指定されていない、または不正です。
static java.lang.String | BPW_C_INVALID_CATEGORY_NAME カテゴリ名称が指定されていない、または不正です。
static java.lang.String | BPW_C_INVALID_CONTENTS_M_SELECT_KEY 検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
static java.lang.String | BPW_C_INVALID_CONTENTS_TYPE 差し戻し、引き戻し時、コンテンツ種別タイプが不正です。
static java.lang.String | BPW_C_INVALID_DB_PRIMARY_KEY 指定情報のデータベースプライマリキー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。
static java.lang.String | BPW_C_INVALID_GROUPING_CD_KIND 承認グルーピングコード種別が不正です。
static java.lang.String | BPW_C_INVALID_LOGIN_GROUP_ID ログイングループIDが指定されていない、または不正です。
static java.lang.String | BPW_C_INVALID_LOGIN_USER_ID ログインユーザIDが指定されていない、または不正です。
static java.lang.String | BPW_C_INVALID_NECESSARY_KEY 指定情報の入力必須キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
static java.lang.String | BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY 検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
static java.lang.String | BPW_C_INVALID_PROCESS_DEF_NAME プロセス定義名称が指定されていない、または不正です。
static java.lang.String | BPW_C_INVALID_PROCESSDEF 関連付けるプロセス定義情報が存在しない、または無効です。
static java.lang.String | BPW_C_INVALID_REFER_FLAG 参照権限フラグが不正です。
static java.lang.String | BPW_C_INVALID_REMINDER_TYPE 催促メール対象種別が不正です。
static java.lang.String | BPW_C_INVALID_RETURN_DRAFT_SELECT_KEY 申請者へ差し戻し処理実行時の指定キー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。
static java.lang.String | BPW_C_INVALID_RETURN_FLG 引戻し／差戻しは行えません。
static java.lang.String | BPW_C_INVALID_RETURN_START_RUN_USER_INFO 申請者への差し戻しイベントに失敗しました。
static java.lang.String | BPW_C_INVALID_ROOT_NAME 申請できません。
static java.lang.String | BPW_C_INVALID_RUN_EXECUTIVE_TYPE 実行主体種別が不正です。
static java.lang.String | BPW_C_INVALID_SELECT_CONDITION_PHRASE 条件句の指定が不正です。
static java.lang.String | BPW_C_INVALID_SELECT_IN_PHRASE IN指定は他の条件と複合して設定不可能です。
static java.lang.String | BPW_C_INVALID_TAGET_GROUP 申請できません。
static java.lang.String | BPW_C_INVALID_TRANSFER_CD_KIND 代理承認者コード種別が不正です。
static java.lang.String | BPW_C_INVALID_USER_CD_KIND 承認者コード種別が不正です。
static java.lang.String | BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY 検索実行時のプライマリキー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
static java.lang.String | BPW_C_MAGICAL_ACTIVE_ACTIVITY 強制活性化に失敗しました。
static java.lang.String | BPW_C_MAGICAL_DEACTIVE_PROCESS 強制活性化に失敗しました。
static java.lang.String | BPW_C_MAGICAL_PLURAL_RUN_USER 強制活性化に失敗しました。
static java.lang.String | BPW_C_MAGICAL_RUN_USER 強制活性化に失敗しました。
static java.lang.String | BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND メールテンプレートの取得に失敗しました。
static java.lang.String | BPW_C_MOVE_ACTIVITY_RETURN_PULL この案件は引戻し出来ません。
static java.lang.String | BPW_C_NO_ATTACH_POSITION_GROUP 申請できません。
static java.lang.String | BPW_C_NO_ATTACH_POSITION_GROUP_AGENT 申請できません。
static java.lang.String | BPW_C_NO_AUTHORITY 権限がありません。
static java.lang.String | BPW_C_NO_AUTO_PASS_MASTER_INFO 自動パスマスタ情報と自動パス役職マスタ情報が設定されていません。
static java.lang.String | BPW_C_NO_DRAFT_CHECK_KEY 起票チェックに必要なキーが指定されていません。
static java.lang.String | BPW_C_NO_DRAFT_USER_CD 起票処理者コードが登録されていません。
static java.lang.String | BPW_C_NO_EVENT_ADAPTER イベント実行情報が存在しない。
static java.lang.String | BPW_C_NO_EXECUTE_ADAPTER 外部実行クラスが存在しません。
static java.lang.String | BPW_C_NO_EXECUTIVE_GROUP 実行主体役職マスタに対象グループが登録されていません。
static java.lang.String | BPW_C_NO_FLOW_MASTER_INFO フロー内容マスタ情報が設定されていません。
static java.lang.String | BPW_C_NO_INSERT_VALUE 更新情報が設定されていません。
static java.lang.String | BPW_C_NO_PROCESS_ADAPTER 実行プロセスが存在しません。
static java.lang.String | BPW_C_NO_ROUTE_SELECT_MASTER ルート選択マスタ情報が設定されてません。
static java.lang.String | BPW_C_NO_RUN_SELECT_ACTIVITY 実行時選択可能なアクティビティではありません。
static java.lang.String | BPW_C_NO_RUN_SELECT_USER 実行時選択ユーザが指定されていません。
static java.lang.String | BPW_C_NO_RUNUSER_EXCUTIVE_INFO 実行主体役職マスタ情報が設定されていません。
static java.lang.String | BPW_C_NO_RUNUSER_MASTER_INFO 実行主体ユーザマスタ情報が設定されていません。
static java.lang.String | BPW_C_NO_SELECTED_TARGET_TASK 申請できません。
static java.lang.String | BPW_C_NO_SEQUENCE_MASTER_INFO シーケンス内容マスタ情報が設定されていません。
static java.lang.String | BPW_C_NO_SWHITCH_MASTER_INFO スイッチマスタ情報が設定されていません。
static java.lang.String | BPW_C_NO_TRANSFER_AUTHORITY 代理申請権限がありません。
static java.lang.String | BPW_C_NO_USER_CD ユーザコードが存在しません。
static java.lang.String | BPW_C_NO_VERSION_DRAFT_CD 起票処理コードが登録されていません。
static java.lang.String | BPW_C_NOT_ACTIVITY 関連付けるアクティビティ情報が存在しません。
static java.lang.String | BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL メール送信送信対象アクティビティ情報が存在しません。
static java.lang.String | BPW_C_NOT_ACTIVITY_MASTER アクティビティマスタ情報が存在しません。
static java.lang.String | BPW_C_NOT_BACK_IN_FLOW 同期処理内より、処理外への引戻し／差戻しは行えません。
static java.lang.String | BPW_C_NOT_CATEGORY 関連付けるカテゴリ情報が存在しません。
static java.lang.String | BPW_C_NOT_DELEGATE 振替が出来ません。
static java.lang.String | BPW_C_NOT_DELEGATE_AGENT 振替が出来ません。
static java.lang.String | BPW_C_NOT_DELEGATE_AGENT_SET 振替が出来ません。
static java.lang.String | BPW_C_NOT_DELEGATE_ALREADY 振替が出来ません。
static java.lang.String | BPW_C_NOT_DELEGATE_ALREADY_RIGHT 振替が出来ません。
static java.lang.String | BPW_C_NOT_DELEGATE_BACK 振替が出来ません。
static java.lang.String | BPW_C_NOT_DELEGATE_CIRCULATION 振替が出来ません。
static java.lang.String | BPW_C_NOT_DELETE_VERSION_LASTRECORD 履歴情報を削除できません。
static java.lang.String | BPW_C_NOT_EFFECTIVE_DATE 現在日は有効な日付ではありません。
static java.lang.String | BPW_C_NOT_GET_PROCESS_CODE 案件番号の取得に失敗しました。
static java.lang.String | BPW_C_NOT_GROUP_TABLE 関連付ける実行主体グループテーブルが存在しません。
static java.lang.String | BPW_C_NOT_HISTORY_RETURN_PULL この案件の差戻しの引戻しは出来ません。
static java.lang.String | BPW_C_NOT_PROCESS 関連付けるプロセス情報が存在しません。
static java.lang.String | BPW_C_NOT_PROCESSDEF 関連付けるプロセス定義情報が存在しません。
static java.lang.String | BPW_C_NOT_PULL_DRAFT_ACTIVITY 引き戻し先アクティビティが存在しません。
static java.lang.String | BPW_C_NOT_RECEIVE_TABLE 関連付くレシーブ情報が存在しません。
static java.lang.String | BPW_C_NOT_RECEIVE_USER 承認を実施するユーザ・組織が存在しません。
static java.lang.String | BPW_C_NOT_RETURN_ACTIVITY アクティビティが存在しません。
static java.lang.String | BPW_C_NOT_RETURN_DRAFT_ACTIVITY 差し戻し先アクティビティが存在しません。
static java.lang.String | BPW_C_NOT_ROOT_HISTORY_INFO ルート作成履歴情報が存在しません。
static java.lang.String | BPW_C_NOT_RUN_EXECUTIVE_MASTER 指定された実行主体役職マスタ情報が存在しません。
static java.lang.String | BPW_C_NOT_RUN_USER_EXECUTIVE_MASTER 指定された実行主体(ユーザ/役職)マスタ情報が存在しません。
static java.lang.String | BPW_C_NOT_RUN_USER_MASTER 実行主体ユーザマスタ情報が存在しません。
static java.lang.String | BPW_C_NOT_RUN_USER_TABLE 実行主体ユーザ情報が存在しません。
static java.lang.String | BPW_C_NOT_SET_INVALID_FLAG 論理削除されているデータを更新しようとした場合に発生するエラーです。
static java.lang.String | BPW_C_NOT_SYNCRONIZED 同期情報が設定されていません。
static java.lang.String | BPW_C_NOT_VERSION 関連付ける履歴情報が存在しません。
static java.lang.String | BPW_C_PRAM_ERROR パラメータエラーです。
static java.lang.String | BPW_C_PROCESS_COUNT_FILE_NOT_FOUND 案件番号の採番処理に失敗しました。
static java.lang.String | BPW_C_REPEAT_ORDER_BY_VALUE ORDER BY句に指定されたカラム名が重複しています。
static java.lang.String | BPW_C_REPEAT_RUN_SELECT_USER 複数の実行時選択ユーザが登録されています。
static java.lang.String | BPW_C_RETURN_PULL_DIFFER_PROCESS この案件の差戻しの引戻しは引戻せません プロセスの移動を含む差戻しタスクを引戻すことは出来ません。
static java.lang.String | BPW_C_SHIFT_REFER_DUPLICATION 参照者マスタ移行が出来ません。
static java.lang.String | BPW_C_SHIFT_REFER_TOOL 参照者マスタ移行が出来ません。
static java.lang.String | BPW_C_ZERO_MEMBER_COMPANY 指定された組織に属するユーザが存在しません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW プロセス定義種別がビジネスプロセスワークフローの場合、コンテンツフレーム種別にカスタムを設定することはできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE サブプロセスに申請者/承認者ルート作成ワークフローが設定されているタスクの直前に 申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW 同期の開始・結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH 分岐の開始直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE 起票タスクのタスク種別に誤りがあります。
static java.lang.String | BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH 承認者種別が実行時選択のタスクを 同期・分岐・ルート選択の開始直後に設定する事はできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK 起票タスクに動的承認者は設定できません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER 同期タスクの結合直後に動的な対象者を設定する事はできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT 分岐内に1ルートしか設定されていません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT 分岐内のタスク設定に誤りがあります。
static java.lang.String | BPW_CORE_IMPORT_INVALID_INVOKE_TASK プロセス種別がビジネスプロセスワークフロー以外の場合、自動実行タスク、イベント実行タスクを設定することはできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE ルート選択内に処理タスクがない場合、ルート選択結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_ROOT_SETTING ルート定義に誤りがあります。
static java.lang.String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE ルート選択タスクの直前に申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW 同期の開始・結合直後にルート選択タスクを設定することはできません。
static java.lang.String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH 分岐・ルート選択の開始直後にルート選択タスクを設定する事はできません。
static java.lang.String | BPW_CORE_IMPORT_NO_RECEIVE_TASK 起票(処理)タスクが設定されていない可能性があります。
static java.lang.String | BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO サブプロセス設定情報が設定されていません。
static java.lang.String | BPW_FLOWINFO_INVALID_PARAMETER フローアイコンを取得する際の入力パラメータ不正です。
static java.lang.String | BPW_FLOWINFO_NO_EXIST_FLOWICON フローアイコンが存在しません。
static java.lang.String | BPW_INVALID_DRAFT_COMMENT_LENGTH 申請コメントの入力文字数が制限を越えています。
static java.lang.String | BPW_INVALID_PROCESS_NAME_LENGTH プロセス名の入力文字数が制限を越えています。
static java.lang.String | BPW_INVALID_RECEIVE_COMMENT_LENGTH 審議コメントの入力文字数が制限を越えています。
static java.lang.String | BPW_UT_FAILED_TO_BEGIN ユーザトランザクションの開始に失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_CLOSE ユーザトランザクションの終了に失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_COMMIT ユーザトランザクションのコミットに失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION トランザクションが開始していないためコミットに失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_GET_STATUS ユーザトランザクションのステータスの取得に失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_LOCK ユーザアプリケーションロックの解除に失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_ROLLBACK ユーザトランザクションのロールバックに失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION トランザクションが開始していないためロールバックに失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY ユーザトランザクションのロールバックオンリーの設定に失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT ユーザトランザクションのトランザクションタイムアウトの設定に失敗しました。
static java.lang.String | BPW_UT_FAILED_TO_UNLOCK ユーザアプリケーションロックの解除に失敗しました。

フィールドの詳細

BPW_C_PRAM_ERROR

public static final java.lang.String BPW_C_PRAM_ERROR
パラメータエラーです。

関連項目:
定数フィールド値

BPW_C_HAVE_NOT_AUTHORITY

public static final java.lang.String BPW_C_HAVE_NOT_AUTHORITY
権限がありません。 このエラーコードは参照・更新要求時に対象データに対する権限がない場合に発生します。 処理委譲を行っている場合も該当します。

関連項目:
定数フィールド値

BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND

public static final java.lang.String BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND
権限、及び権限に関連する情報がありません。 このエラーコードは履歴情報取得時に発生します。 権限情報そのものが存在しない、及び権限に関連するプロセス定義情報、 または履歴情報が存在しない可能性があります。

関連項目:
定数フィールド値

BPW_C_DATA_NOT_FOUND

public static final java.lang.String BPW_C_DATA_NOT_FOUND
データが存在しません。 このエラーコードは取得要求時ではなく、更新・削除要求時に対象データが 既に削除されて存在しない場合に発生します。 再度情報の取得を実施してデータが存在するか確認する必要があります。

関連項目:
定数フィールド値

BPW_C_CHANGE_INFO

public static final java.lang.String BPW_C_CHANGE_INFO
他のユーザに情報が変更されました。 修正・削除対象のデータは、他のユーザによって変更されています。 再度情報を取得した後に修正・削除を行う必要があります。

関連項目:
定数フィールド値

BPW_C_CHANGING_NOW

public static final java.lang.String BPW_C_CHANGING_NOW
関連する情報が修正中であり反映できません。 要求された操作を行うと整合性エラーが発生する可能性があるため、反映できません。 しばらくしてから、再度実行する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_CATEGORY

public static final java.lang.String BPW_C_NOT_CATEGORY
関連付けるカテゴリ情報が存在しません。 履歴情報を登録する際にのみ発生し、履歴情報に関連付けようとしたカテゴリ情報が存在しません。 カテゴリ情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_CATEGORY

public static final java.lang.String BPW_C_INVALID_CATEGORY
関連付けるカテゴリ情報が存在しない、または無効です。 履歴情報に関連付けようとしたカテゴリ情報が存在しないか、または無効です。 カテゴリ情報が存在し、かつ無効でないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_PROCESSDEF

public static final java.lang.String BPW_C_NOT_PROCESSDEF
関連付けるプロセス定義情報が存在しません。 履歴情報を登録する際にのみ発生し、履歴情報に関連付けようとしたプロセス定義情報が存在しません。 プロセス定義情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_PROCESSDEF

public static final java.lang.String BPW_C_INVALID_PROCESSDEF
関連付けるプロセス定義情報が存在しない、または無効です。 履歴情報に関連付けようとしたプロセス定義情報が存在しないか、または無効です。 プロセス定義情報が存在し、かつ無効でないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_VERSION

public static final java.lang.String BPW_C_NOT_VERSION
関連付ける履歴情報が存在しません。 プロセス、もしくはワークフロー情報を登録する際に発生します。 それぞれの情報に関連付けようとした履歴情報が存在しません。 履歴情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_GROUP_TABLE

public static final java.lang.String BPW_C_NOT_GROUP_TABLE
関連付ける実行主体グループテーブルが存在しません。 実行主体グループテーブルが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_VERSION

public static final java.lang.String BPW_C_FOUND_VERSION
関連付く履歴情報が存在します。 プロセス定義、もしくはカテゴリ情報を削除する際に発生します。 それぞれの情報に関連付けた履歴情報が存在するため削除できません。 関連のある履歴情報を削除した後に削除する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_PROCESS

public static final java.lang.String BPW_C_NOT_PROCESS
関連付けるプロセス情報が存在しません。 アクティビティ情報を登録、更新、削除する際に発生します。 アクティビティ情報に関連付けるプロセス情報が存在しません。 プロセス情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_ACTIVITY

public static final java.lang.String BPW_C_NOT_ACTIVITY
関連付けるアクティビティ情報が存在しません。 アクティビティ情報に関連付く実行主体ユーザ情報、自動パス情報、レシーブ情報を 登録、更新する際に関連付くアクティビティ情報が存在しないか、もしくは他の処理時に必要なアクティビティ情報を 検索した際に発生します。 アクティビティ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL

public static final java.lang.String BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL
メール送信送信対象アクティビティ情報が存在しません。 メール送信送信対象のアクティビティ情報を検索した際に発生します。 メール送信送信対象のアクティビティ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_RUN_USER_TABLE

public static final java.lang.String BPW_C_FOUND_RUN_USER_TABLE
関連付く実行主体ユーザ情報が存在します。 アクティビティ情報に関連付いた実行主体ユーザ情報が存在するため、削除できません。 関連のある実行主体ユーザ情報を削除した後、削除する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_USER_TABLE

public static final java.lang.String BPW_C_NOT_RUN_USER_TABLE
実行主体ユーザ情報が存在しません。 実行主体ユーザ情報を検索した際に発生します。 指定した実行主体ユーザ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_USER_MASTER

public static final java.lang.String BPW_C_NOT_RUN_USER_MASTER
実行主体ユーザマスタ情報が存在しません。 実行主体ユーザマスタ情報を検索した際に発生します。 指定した実行主体ユーザマスタ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_AUTO_PASS_TABLE

public static final java.lang.String BPW_C_FOUND_AUTO_PASS_TABLE
関連付く自動パス情報が存在します。 アクティビティ情報に関連付いた自動パス情報が存在するために削除できません。 関連のある自動パス情報を削除した後、削除する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_RECEIVE_TABLE

public static final java.lang.String BPW_C_FOUND_RECEIVE_TABLE
関連付くレシーブ情報が存在します。 アクティビティ情報に関連付いたレシーブ情報が存在するために削除できません。 関連のあるレシーブ情報を削除した後、レシーブ情報を削除する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RECEIVE_TABLE

public static final java.lang.String BPW_C_NOT_RECEIVE_TABLE
関連付くレシーブ情報が存在しません。 アクティビティ情報に関連付いたレシーブ情報が存在しない場合に発生します。 関連のあるレシーブ情報が削除されていないか確認する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_RECEIVE_MASTER

public static final java.lang.String BPW_C_FOUND_RECEIVE_MASTER
レシーブマスタ情報が存在しません。 必要なレシーブマスタ情報を検索した際、レシーブマスタ情報が存在しない場合に発生します。 レシーブマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_FOUND_PROCESS

public static final java.lang.String BPW_C_FOUND_PROCESS
関連付くプロセス情報が存在します。 履歴情報に関連付いたプロセスが存在するために削除できません。 関連のあるプロセスを削除した後、履歴情報を削除する必要があります。

関連項目:
定数フィールド値

BPW_C_EXIST_PROCESS_DEF

public static final java.lang.String BPW_C_EXIST_PROCESS_DEF
有効なプロセス定義が存在します。 関連付いたプロセス定義が有効なため、更新・削除ができません。

関連項目:
定数フィールド値

BPW_C_FOUND_RUNNING_PROCESS

public static final java.lang.String BPW_C_FOUND_RUNNING_PROCESS
実行中のプロセスが存在します。 関連付いたプロセスが実行中であるため、更新・削除ができません。

関連項目:
定数フィールド値

BPW_C_NOT_RECEIVE_USER

public static final java.lang.String BPW_C_NOT_RECEIVE_USER
承認を実施するユーザ・組織が存在しません。 申請・承認処理時に発生し、申請・承認を実施することで、ワークフロー上 承認者が存在しないタスクが発生します。 これは、承認を実施するユーザや組織が定義された後に対象が削除されることで 発生します。 ワークフローの再定義、もしくは適切な承認者を再度設定する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_ACTIVITY_MASTER

public static final java.lang.String BPW_C_NOT_ACTIVITY_MASTER
アクティビティマスタ情報が存在しません。 処理に必要なアクティビティマスタ情報を検索した際に発生します。 アクティビティマスタ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_EXECUTIVE_MASTER

public static final java.lang.String BPW_C_NOT_RUN_EXECUTIVE_MASTER
指定された実行主体役職マスタ情報が存在しません。 実行主体役職マスタ情報を参照した際に、指定された実行主体役職マスタ情報が存在しない場合に発生します。 実行主体役職マスタ情報が定義されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_SYNCRONIZED

public static final java.lang.String BPW_C_NOT_SYNCRONIZED
同期情報が設定されていません。 更新・削除実施時に指定するべき同期情報が指定されていないか、誤った同期情報が指定されています。 例えば、履歴情報の更新・削除をＷＥＢ層より実行する際は、一旦対象の履歴情報を参照し、 取得した同期情報を指定する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_DELETE_VERSION_LASTRECORD

public static final java.lang.String BPW_C_NOT_DELETE_VERSION_LASTRECORD
履歴情報を削除できません。 履歴情報を削除する際に削除対象レコードが最後の１件である場合に発生します。 履歴情報の最後の１件を削除するには、プロセス定義より削除する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_CATEGORY_NAME

public static final java.lang.String BPW_C_INVALID_CATEGORY_NAME
カテゴリ名称が指定されていない、または不正です。 カテゴリ情報登録時にカテゴリ名称が指定されていないか、または不正な場合に発生します。 正しくカテゴリ名称を指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_PROCESS_DEF_NAME

public static final java.lang.String BPW_C_INVALID_PROCESS_DEF_NAME
プロセス定義名称が指定されていない、または不正です。 プロセス定義情報登録時にプロセス定義名称が指定されていないか、または不正な場合に発生します。 正しくプロセス定義名称を指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_CATEGORY_CODE

public static final java.lang.String BPW_C_INVALID_CATEGORY_CODE
カテゴリコードが指定されていない、または不正です。 プロセス定義情報登録時にカテゴリコードが指定されていないか、または不正な場合に発生します。 正しくカテゴリコードを指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_LOGIN_USER_ID

public static final java.lang.String BPW_C_INVALID_LOGIN_USER_ID
ログインユーザIDが指定されていない、または不正です。 正しいログインユーザIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_LOGIN_GROUP_ID

public static final java.lang.String BPW_C_INVALID_LOGIN_GROUP_ID
ログイングループIDが指定されていない、または不正です。 正しいログイングループIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_DB_PRIMARY_KEY

public static final java.lang.String BPW_C_INVALID_DB_PRIMARY_KEY
指定情報のデータベースプライマリキー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。 データベースの更新・削除時に発生します。 プライマリキー値がすべて指定されている、もしくは正しいプライマリキーが 指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY

public static final java.lang.String BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY
検索実行時のプライマリキー値に値が指定されていないものが存在する、もしくは指定された値が不正です。 ワークフロー情報の検索時に発生します。 検索対象として指定するワークフロー情報のプライマリキー値がすべて指定されている、 もしくは正しいプライマリキーが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_NECESSARY_KEY

public static final java.lang.String BPW_C_INVALID_NECESSARY_KEY
指定情報の入力必須キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。 データベースの更新・削除時に発生します。 プライマリキー値、およびログインユーザID・ログイングループIDがすべて指定されている、 もしくは正しい値が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_CONTENTS_M_SELECT_KEY

public static final java.lang.String BPW_C_INVALID_CONTENTS_M_SELECT_KEY
検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。 コンテンツマスタ情報の検索時に発生します。 検索対象として指定するコンテンツマスタ情報の指定キー値がすべて指定されている、 もしくは正しい指定キーが指定されていることを確認する必要があります。 指定キーは、プロセス定義コード、履歴コード、アクティビティコードです。

関連項目:
定数フィールド値

BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY

public static final java.lang.String BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY
検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。 プロセスコンテンツマスタ情報の検索時に発生します。 検索対象として指定するプロセスコンテンツマスタ情報の指定キー値がすべて指定されている、 もしくは正しい指定キーが指定されていることを確認する必要があります。 指定キーは、プロセス定義コード、履歴コード、アクティビティコードです。

関連項目:
定数フィールド値

BPW_C_INVALID_RETURN_DRAFT_SELECT_KEY

public static final java.lang.String BPW_C_INVALID_RETURN_DRAFT_SELECT_KEY
申請者へ差し戻し処理実行時の指定キー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。 申請者へ差し戻し処理実行時に発生します。 申請者へ差し戻し処理実行時の指定キー値がすべて指定されている、 もしくは正しい指定キーが指定されたか確認する必要があります。 指定キーは、プロセス定義コード、履歴コード、プロセスコードです。

関連項目:
定数フィールド値

BPW_C_INVALID_SELECT_IN_PHRASE

public static final java.lang.String BPW_C_INVALID_SELECT_IN_PHRASE
IN指定は他の条件と複合して設定不可能です。 IN指定が他の条件と複合して設定された場合に発生します。 カラムの検索条件にIN句を指定した場合は、他の条件句(イコール等)は指定できません。 他の条件句を指定していないか確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_SELECT_CONDITION_PHRASE

public static final java.lang.String BPW_C_INVALID_SELECT_CONDITION_PHRASE
条件句の指定が不正です。 カラムの検索条件にサポート外の条件句が指定された場合に発生します。 サポート外の条件句を指定していないか確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_INSERT_VALUE

public static final java.lang.String BPW_C_NO_INSERT_VALUE
更新情報が設定されていません。 更新情報が設定されていない場合に発生します。 UPDATE対象とする更新情報が設定されている確認する必要があります。

関連項目:
定数フィールド値

BPW_C_REPEAT_ORDER_BY_VALUE

public static final java.lang.String BPW_C_REPEAT_ORDER_BY_VALUE
ORDER BY句に指定されたカラム名が重複しています。 ORDER BY句に重複したカラム名を設定した場合に発生します。 同一カラム名をORDER BY句に複数指定することはできません。

関連項目:
定数フィールド値

BPW_C_INVALID_ACTIVITY_STATUS

public static final java.lang.String BPW_C_INVALID_ACTIVITY_STATUS
アクティビティステータスが不正です。 取得したアクティビティステータスが想定外のステータスであった場合に発生します。 正しいアクティビティステータスが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_ACTIVITY_TYPE

public static final java.lang.String BPW_C_INVALID_ACTIVITY_TYPE
アクティビティ種別が不正です。 取得したアクティビティ種別が想定外の種別であった場合に発生します。 正しいアクティビティ種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_USER_CD_KIND

public static final java.lang.String BPW_C_INVALID_USER_CD_KIND
承認者コード種別が不正です。 取得した承認者コード種別が想定外の種別であった場合に発生します。 正しい承認者コード種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_GROUPING_CD_KIND

public static final java.lang.String BPW_C_INVALID_GROUPING_CD_KIND
承認グルーピングコード種別が不正です。 取得した承認グルーピングコード種別が想定外の種別であった場合に発生します。 正しい承認グルーピングコード種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_TRANSFER_CD_KIND

public static final java.lang.String BPW_C_INVALID_TRANSFER_CD_KIND
代理承認者コード種別が不正です。 取得した代理承認者コード種別が想定外の種別であった場合に発生します。 正しい代理承認者コード種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_REMINDER_TYPE

public static final java.lang.String BPW_C_INVALID_REMINDER_TYPE
催促メール対象種別が不正です。 取得した催促メール対象種別が想定外の種別であった場合に発生します。 正しい催促メール対象種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_REFER_FLAG

public static final java.lang.String BPW_C_INVALID_REFER_FLAG
参照権限フラグが不正です。 アクティビティテーブルの検索時に指定された参照権限フラグが想定外の値であった場合に発生します。 正しい参照権限フラグ値が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_APPROVAL_TYPE

public static final java.lang.String BPW_C_INVALID_APPROVAL_TYPE
承認種別が不正です。 指定された承認種別が想定外の値であった場合に発生します。 正しい承認種別が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_APPROVAL_USER

public static final java.lang.String BPW_C_INVALID_APPROVAL_USER
承認ユーザコードが不正です。 指定された承認ユーザコードが想定外の値であった場合に発生します。 正しい承認ユーザコードが設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_RUN_EXECUTIVE_TYPE

public static final java.lang.String BPW_C_INVALID_RUN_EXECUTIVE_TYPE
実行主体種別が不正です。 取得した実行主体種別が想定外の値であった場合に発生します。 正しい実行主体種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_ADAPTER_TYPE

public static final java.lang.String BPW_C_INVALID_ADAPTER_TYPE
アダプタ種別が不正です。 取得したアダプタ種別が想定外の値であった場合に発生します。 正しいアダプタ種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_TRANSFER_AUTHORITY

public static final java.lang.String BPW_C_NO_TRANSFER_AUTHORITY
代理申請権限がありません。 代理申請指定された際に代理申請権限がない場合に発生します。 指定したユーザに代理申請権限があることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPOSSIBLE_RETURN

public static final java.lang.String BPW_C_IMPOSSIBLE_RETURN
引き戻し・差し戻し処理が実行できません。 指定されたアクティビティが引き戻しもしくは差し戻し処理を行えないアクティビティである場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_RETURN_ACTIVITY

public static final java.lang.String BPW_C_NOT_RETURN_ACTIVITY
アクティビティが存在しません。 指定されたアクティビティのアクティビティが存在しない場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPOSSIBLE_RETURN_DRAFT

public static final java.lang.String BPW_C_IMPOSSIBLE_RETURN_DRAFT
差し戻し処理が実行できません。 指定されたアクティビティが差し戻し処理を行えないアクティビティである場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_RETURN_DRAFT_ACTIVITY

public static final java.lang.String BPW_C_NOT_RETURN_DRAFT_ACTIVITY
差し戻し先アクティビティが存在しません。 指定されたアクティビティの差し戻し先アクティビティが存在しない場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPOSSIBLE_PULL_DRAFT

public static final java.lang.String BPW_C_IMPOSSIBLE_PULL_DRAFT
引き戻し処理が実行できません。 指定されたアクティビティが引き戻し処理を行えないアクティビティである場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_PULL_DRAFT_ACTIVITY

public static final java.lang.String BPW_C_NOT_PULL_DRAFT_ACTIVITY
引き戻し先アクティビティが存在しません。 指定されたアクティビティの引き戻し先アクティビティが存在しない場合に発生します。

関連項目:
定数フィールド値

BPW_C_REPEAT_RUN_SELECT_USER

public static final java.lang.String BPW_C_REPEAT_RUN_SELECT_USER
複数の実行時選択ユーザが登録されています。 指定されたアクティビティの実行時選択ユーザが複数登録されていた場合に発生します。 登録できる実行時選択ユーザは一つのアクティビティに一人のみです。

関連項目:
定数フィールド値

BPW_C_NO_RUN_SELECT_USER

public static final java.lang.String BPW_C_NO_RUN_SELECT_USER
実行時選択ユーザが指定されていません。 実行時選択ユーザ登録時に実行時選択ユーザが指定されていない場合に発生します。 実行時選択ユーザが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_RUN_SELECT_ACTIVITY

public static final java.lang.String BPW_C_NO_RUN_SELECT_ACTIVITY
実行時選択可能なアクティビティではありません。 実行時選択対象でないアクティビティに対し実行時選択指定を行った場合に発生します。 実行時選択可能アクティビティであることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_VERSION_DRAFT_CD

public static final java.lang.String BPW_C_NO_VERSION_DRAFT_CD
起票処理コードが登録されていません。 起案時に該当プロセスの起案処理コードが登録されていない場合に発生します。 起案するプロセスの起票コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_DRAFT_USER_CD

public static final java.lang.String BPW_C_NO_DRAFT_USER_CD
起票処理者コードが登録されていません。 起案時に該当プロセスの起案処理者コードが登録されていない場合に発生します。 起案するプロセスの起票コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_DRAFT_CHECK_KEY

public static final java.lang.String BPW_C_NO_DRAFT_CHECK_KEY
起票チェックに必要なキーが指定されていません。 起票チェックに必要なキーのうち指定されていないキーが存在する場合に発生します。 起票チェックに必要なキーが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPOSSIBLE_PROCESS_DRAFT

public static final java.lang.String BPW_C_IMPOSSIBLE_PROCESS_DRAFT
当該プロセスは起票できません。 起案時に該当プロセスが起票できない場合に発生します。 起案するプロセスのバージョンが有効な最新のバージョンであることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPOSSIBLE_PROCESS_DRAFT_TARGET_DATE

public static final java.lang.String BPW_C_IMPOSSIBLE_PROCESS_DRAFT_TARGET_DATE
指定した起票指定日では、申請を行う事ができません。再度指定し直してください。 起案時に該当プロセスが起票できない場合に発生します。 指定した起票指定日にプロセスのバージョンが存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_EXECUTIVE_GROUP

public static final java.lang.String BPW_C_NO_EXECUTIVE_GROUP
実行主体役職マスタに対象グループが登録されていません。 実行主体役職マスタにコード種別がグループのデータが登録されていない場合に発生します。 コード種別がグループのデータが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_USER_CD

public static final java.lang.String BPW_C_NO_USER_CD
ユーザコードが存在しません。 実行主体役職マスタに登録されているコードに該当するユーザコードが存在しない場合に発生します。 実行主体役職マスタに登録されているコードが正しいことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_EXECUTE_ADAPTER

public static final java.lang.String BPW_C_NO_EXECUTE_ADAPTER
外部実行クラスが存在しません。 オートアダプタ情報の検索時に該当する情報が存在しない場合に発生します。 該当するオートアダプタ情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_PROCESS_ADAPTER

public static final java.lang.String BPW_C_NO_PROCESS_ADAPTER
実行プロセスが存在しません。 プロセスアダプタ情報の検索時に該当する情報が存在しない場合に発生します。 該当するプロセスアダプタ情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_EVENT_ADAPTER

public static final java.lang.String BPW_C_NO_EVENT_ADAPTER
イベント実行情報が存在しない。 イベントアダプタ情報の検索時に該当する情報が存在しない場合に発生します。 該当するイベントアダプタ情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_EFFECTIVE_DATE

public static final java.lang.String BPW_C_NOT_EFFECTIVE_DATE
現在日は有効な日付ではありません。 プロセス登録の際に現在日が有効日付より過去の場合に発生します。 プロセスの登録は有効日付以降に可能となります。

関連項目:
定数フィールド値

BPW_C_ILLIGAL_STATUS

public static final java.lang.String BPW_C_ILLIGAL_STATUS
ステータスが異常です。 プロセス、アクティビティ・ステータスの異常により発生します。

関連項目:
定数フィールド値

BPW_C_ILLIGAL_STATUS_CHG

public static final java.lang.String BPW_C_ILLIGAL_STATUS_CHG
ステータス遷移が異常です。 プロセス、アクティビティ・ステータスの遷移異常により発生します。

関連項目:
定数フィールド値

BPW_C_NO_RUNUSER_MASTER_INFO

public static final java.lang.String BPW_C_NO_RUNUSER_MASTER_INFO
実行主体ユーザマスタ情報が設定されていません。 ワークフロー情報の登録時に実行主体ユーザマスタ情報が設定されていない場合に発生します。 実行主体ユーザマスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_RUNUSER_EXCUTIVE_INFO

public static final java.lang.String BPW_C_NO_RUNUSER_EXCUTIVE_INFO
実行主体役職マスタ情報が設定されていません。 ワークフロー情報の登録時に実行主体役職マスタ情報が設定されていない場合に発生します。 実行主体役職マスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_AUTO_PASS_MASTER_INFO

public static final java.lang.String BPW_C_NO_AUTO_PASS_MASTER_INFO
自動パスマスタ情報と自動パス役職マスタ情報が設定されていません。 ワークフロー情報の登録時に自動パスマスタ情報、自動パス役職マスタ情報のいずれも 設定されていない場合に発生します。 自動パスマスタ情報、自動パス役職マスタ情報のいずれかが設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_SEQUENCE_MASTER_INFO

public static final java.lang.String BPW_C_NO_SEQUENCE_MASTER_INFO
シーケンス内容マスタ情報が設定されていません。 ワークフロー情報の登録時にシーケンス内容マスタ情報が設定されていない場合に発生します。 シーケンス内容マスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_FLOW_MASTER_INFO

public static final java.lang.String BPW_C_NO_FLOW_MASTER_INFO
フロー内容マスタ情報が設定されていません。 ワークフロー情報の登録時にフロー内容マスタ情報が設定されていない場合に発生します。 フロー内容マスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_SWHITCH_MASTER_INFO

public static final java.lang.String BPW_C_NO_SWHITCH_MASTER_INFO
スイッチマスタ情報が設定されていません。 ワークフロー情報の登録時にスイッチマスタ情報が設定されていない場合に発生します。 スイッチマスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_AUTHORITY

public static final java.lang.String BPW_C_NO_AUTHORITY
権限がありません。 引き戻し・差し戻しされた際に権限がない場合に発生します。 指定したユーザに権限があることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_ALREADY_EXIST_TRANSFER

public static final java.lang.String BPW_C_ALREADY_EXIST_TRANSFER
処理委譲できません。 処理委譲設定時に該当アクティビティステータスがアクティブの場合に発生します。

関連項目:
定数フィールド値

BPW_C_CAN_NOT_TRANSFER

public static final java.lang.String BPW_C_CAN_NOT_TRANSFER
処理委譲できません。 処理委譲設定時に該当アクティビティステータスがアクティブの場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAGICAL_ACTIVE_ACTIVITY

public static final java.lang.String BPW_C_MAGICAL_ACTIVE_ACTIVITY
強制活性化に失敗しました。 強制的に活性化しようとしたアクティビティが、既に活性化済みの場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAGICAL_DEACTIVE_PROCESS

public static final java.lang.String BPW_C_MAGICAL_DEACTIVE_PROCESS
強制活性化に失敗しました。 強制的に活性化しようとしたアクティビティを保有するプロセスが、活性化状態で場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAGICAL_RUN_USER

public static final java.lang.String BPW_C_MAGICAL_RUN_USER
強制活性化に失敗しました。 強制的に活性化しようとしたアクティビティが実行時選択ユーザである場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAGICAL_PLURAL_RUN_USER

public static final java.lang.String BPW_C_MAGICAL_PLURAL_RUN_USER
強制活性化に失敗しました。 強制移動するタスク内に複数処理対象者が存在する場合に発生します。。

関連項目:
定数フィールド値

BPW_C_CAN_NOT_START_JAVASCRIPT

public static final java.lang.String BPW_C_CAN_NOT_START_JAVASCRIPT
JavaScriptが起動できません。 JavaScriptの起動に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_PULL_ACTIVITY

public static final java.lang.String BPW_C_INPOSSIBLE_PULL_ACTIVITY
引き戻しイベントに失敗しました。 引き戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INVALID_CONTENTS_TYPE

public static final java.lang.String BPW_C_INVALID_CONTENTS_TYPE
差し戻し、引き戻し時、コンテンツ種別タイプが不正です。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_RETURN_START_ACTIVITY

public static final java.lang.String BPW_C_INPOSSIBLE_RETURN_START_ACTIVITY
申請者への差し戻しイベントに失敗しました。 申請者への差し戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY

public static final java.lang.String BPW_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY
承認者への差し戻しイベントに失敗しました。 承認者への差し戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_DRAFT_ACTIVITY

public static final java.lang.String BPW_C_INPOSSIBLE_DRAFT_ACTIVITY
申請イベントに失敗しました。 申請イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_RECOGNITION_ACTIVITY

public static final java.lang.String BPW_C_INPOSSIBLE_RECOGNITION_ACTIVITY
承認イベントに失敗しました。 承認イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_DUPLICATE_NAME

public static final java.lang.String BPW_C_DUPLICATE_NAME
名称が重複しています。 カテゴリ名、プロセス定義名の重複登録時に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_SET_INVALID_FLAG

public static final java.lang.String BPW_C_NOT_SET_INVALID_FLAG
論理削除されているデータを更新しようとした場合に発生するエラーです。 更新制御時、論理削除フラグＯＮの場合に発生します。

関連項目:
定数フィールド値

BPW_C_AUTO_EXECUTE_FAULT

public static final java.lang.String BPW_C_AUTO_EXECUTE_FAULT
自動実行処理が異常復帰しました。

関連項目:
定数フィールド値

BPW_C_NOT_HISTORY_RETURN_PULL

public static final java.lang.String BPW_C_NOT_HISTORY_RETURN_PULL
この案件の差戻しの引戻しは出来ません。

関連項目:
定数フィールド値

BPW_C_MOVE_ACTIVITY_RETURN_PULL

public static final java.lang.String BPW_C_MOVE_ACTIVITY_RETURN_PULL
この案件は引戻し出来ません。 もう一度、表示しなおして下さい。

関連項目:
定数フィールド値

BPW_C_RETURN_PULL_DIFFER_PROCESS

public static final java.lang.String BPW_C_RETURN_PULL_DIFFER_PROCESS
この案件の差戻しの引戻しは引戻せません プロセスの移動を含む差戻しタスクを引戻すことは出来ません。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE

public static final java.lang.String BPW_C_NOT_DELEGATE
振替が出来ません。 振替ようとしているユーザは処理対象者となっています。 処理対象者へは振替える事が出来ません。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_BACK

public static final java.lang.String BPW_C_NOT_DELEGATE_BACK
振替が出来ません。 差戻しルート上の処理対象者を振替ることは出来ません。 処理対象者へは振替える事が出来ません。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_AGENT

public static final java.lang.String BPW_C_NOT_DELEGATE_AGENT
振替が出来ません。 代理処理者を振替ることは出来ません。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_AGENT_SET

public static final java.lang.String BPW_C_NOT_DELEGATE_AGENT_SET
振替が出来ません。 代理者が設定されている処理者を振替ることは出来ません。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_ALREADY

public static final java.lang.String BPW_C_NOT_DELEGATE_ALREADY
振替が出来ません。 対象者は既に振替処理を実施済みです。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_ALREADY_RIGHT

public static final java.lang.String BPW_C_NOT_DELEGATE_ALREADY_RIGHT
振替が出来ません。 振替先指定者は既に承認権限を有しています。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_CIRCULATION

public static final java.lang.String BPW_C_NOT_DELEGATE_CIRCULATION
振替が出来ません。 既に同様な設定が行われ、かつ振替先は再度振替られています。

関連項目:
定数フィールド値

BPW_C_ZERO_MEMBER_COMPANY

public static final java.lang.String BPW_C_ZERO_MEMBER_COMPANY
指定された組織に属するユーザが存在しません。 もう一度ユーザか組織を選択してください。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_USER_EXECUTIVE_MASTER

public static final java.lang.String BPW_C_NOT_RUN_USER_EXECUTIVE_MASTER
指定された実行主体(ユーザ/役職)マスタ情報が存在しません。 実行主体マスタ情報(ユーザ/役職)を参照した際に、指定された実行主体スタ情報が存在しない場合に発生します。 実行主体マスタ情報(ユーザ/役職)が定義されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_GET_USER_APP_KEY

public static final java.lang.String BPW_C_INPOSSIBLE_GET_USER_APP_KEY
ユーザアプリケーションキー取得イベントに失敗しました。 ユーザアプリケーションキー取得イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_REGIST_USER_APP_KEY

public static final java.lang.String BPW_C_INPOSSIBLE_REGIST_USER_APP_KEY
ユーザアプリケーションキー登録イベントに失敗しました。 ユーザアプリケーションキー登録イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN
プロセス定義コード長が不正です。 プロセス定義コード長が不正な場合に発生します。 プロセス定義コード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN
カテゴリコード長が不正です。 カテゴリコード長が不正な場合に発生します。 カテゴリコード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN

public static final java.lang.String BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN
プロセス定義名長が最大文字列長を超えています。 プロセス定義名長が最大文字列長を超えている場合に発生します。 プロセス定義名長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_NOTE_LEN

public static final java.lang.String BPW_C_IMPORT_OVER_NOTE_LEN
備考文字列長が最大文字列長を超えています。 備考文字列長が最大文字列長を超えている場合に発生します。 備考文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD
プロセス種別が不正です。 プロセス種別が想定外の値であった場合に発生します。 正しいプロセス種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_EFFECTIVE_DATE

public static final java.lang.String BPW_C_IMPORT_INVALID_EFFECTIVE_DATE
有効日付が指定されていない、または不正です。 有効日付が指定されていないか、または不正な場合に発生します。 正しい有効日付が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_END_DATE

public static final java.lang.String BPW_C_IMPORT_INVALID_END_DATE
終了日付が指定されていない、または不正です。 終了日付が指定されていないか、または不正な場合に発生します。 正しい終了日付が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN

public static final java.lang.String BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN
プロセス種別文字列長が最大文字列長を超えています。 プロセス種別文字列長が最大文字列長を超えている場合に発生します。 プロセス種別文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN
有効日付長が不正です。 有効日付長が不正な場合に発生します。 有効日付長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_END_DATE_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_END_DATE_LEN
終了日付長が不正です。 終了日付長が不正な場合に発生します。 終了日付長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN

public static final java.lang.String BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN
プロセス定義備考文字列長が最大文字列長を超えています。 プロセス定義備考文字列長が最大文字列長を超えている場合に発生します。 プロセス定義備考文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_VERSION_CD_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_VERSION_CD_LEN
履歴コード長が不正です。 履歴コード長が不正な場合に発生します。 履歴コード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_VERSION_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_VERSION_CD
履歴コードが指定されていない、または不正です。 履歴コードが指定されていないか、または不正な場合に発生します。 正しい履歴コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE
コンテンツ種別が指定されていない、または不正です。 コンテンツ種別が指定されていないか、または不正な場合に発生します。 正しいコンテンツ種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_PROCESS_CONTENTSTYPE

public static final java.lang.String BPW_C_IMPORT_DUPLICATE_PROCESS_CONTENTSTYPE
コンテンツ種別が重複して指定されています。 コンテンツ種別が重複して指定されている場合に発生します。 コンテンツ種別が重複して指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND
ページ種別が指定されていない、または不正です。 ページ種別が指定されていないか、または不正な場合に発生します。 正しいページ種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID
アプリケーションIDが指定されていない、または不正です。 アプリケーションIDが指定されていないか、または不正な場合に発生します。 正しいアプリケーションIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID
サービスIDが指定されていない、または不正です。 サービスIDが指定されていないか、または不正な場合に発生します。 正しいサービスIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN
アプリケーションID長が不正です。 アプリケーションID長が不正な場合に発生します。 アプリケーションID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN
サービスID長が不正です。 サービスID長が不正な場合に発生します。 サービスID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH
コンテンツパスが指定されていない、または不正です。 コンテンツパスが指定されていないか、または不正な場合に発生します。 正しいコンテンツパスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN
コンテンツパス長が不正です。 コンテンツパス長が不正な場合に発生します。 コンテンツパス長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID

public static final java.lang.String BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID
ルート定義IDが重複して指定されています。 ルート定義IDが著服して指定されている場合に発生します。 ルート定義IDが重複して指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_LICENSE

public static final java.lang.String BPW_C_IMPORT_NO_LICENSE
指定されたプロセス種別に対するライセンスがありません。 指定されたプロセス種別に対するライセンスがない場合に発生します。 ライセンスに応じたプロセス種別を指定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_TASK_DEF

public static final java.lang.String BPW_C_IMPORT_NO_TASK_DEF
タスク定義が指定されていません。 タスク定義が指定されていない場合に発生します。 タスク定義が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_COMPULSION_END_FLG

public static final java.lang.String BPW_C_IMPORT_INVALID_COMPULSION_END_FLG
強制終了可否フラグが指定されていない、または不正です。 強制終了可否フラグが指定されていないか、または不正な場合に発生します。 正しい強制終了可否フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RETURN_PULL_FLG

public static final java.lang.String BPW_C_IMPORT_INVALID_RETURN_PULL_FLG
引戻し・差戻しフラグが指定されていない、または不正です。 引戻し・差戻しフラグが指定されていないか、または不正な場合に発生します。 正しい引戻し・差戻しフラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG

public static final java.lang.String BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG
引戻し・差戻しメール送信フラグが指定されていない、または不正です。 引戻し・差戻しメール送信フラグが指定されていないか、または不正な場合に発生します。 正しい引戻し・差戻しメール送信フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG

public static final java.lang.String BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG
最短終了フラグが指定されていない、または不正です。 最短終了フラグが指定されていないか、または不正な場合に発生します。 正しい最短終了フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION

public static final java.lang.String BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION
シート内でプロセス定義名が重複しています。 シート内で同一のプロセス定義名が存在する場合に発生します。 重複しないプロセス定義名を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RESULT_NOTICE_FLG

public static final java.lang.String BPW_C_IMPORT_INVALID_RESULT_NOTICE_FLG
結果通知フラグが指定されていない、または不正です。 結果通知フラグが指定されていないか、または不正な場合に発生します。 正しい結果通知フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_FLG

public static final java.lang.String BPW_C_IMPORT_INVALID_AUTO_PASS_FLG
自動パス処理フラグが指定されていない、または不正です。 自動パス処理フラグが指定されていないか、または不正な場合に発生します。 正しい自動パス処理フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RESULT_FROM_DEF

public static final java.lang.String BPW_C_IMPORT_INVALID_RESULT_FROM_DEF
結果通知元定義が指定されていない、または不正です。 結果通知元定義が指定されていないか、または不正な場合に発生します。 正しい結果通知元定義が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RESULT_FROM_DEF_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_RESULT_FROM_DEF_LEN
結果通知元定義長が不正です。 結果通知元定義長が不正な場合に発生します。 結果通知元定義長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RESULT_TITLE_DEF_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_RESULT_TITLE_DEF_LEN
結果通知表題定義長が不正です。 結果通知表題定義長が不正な場合に発生します。 結果通知表題定義長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RESULT_CONTENTS_DEF_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_RESULT_CONTENTS_DEF_LEN
結果通知内容定義長が不正です。 結果通知内容定義長が不正な場合に発生します。 結果通知内容定義長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_TERM

public static final java.lang.String BPW_C_IMPORT_INVALID_AUTO_PASS_TERM
自動パス期限が不正です。 自動パス期限が数字以外な場合に発生します。 自動パス期限が数字で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN
自動パス期限長が不正です。 自動パス期限長が不正な場合に発生します。 自動パス期限長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RECEIVE_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_RECEIVE_MASTER
レシーブマスタ情報が設定されてません。 ワークフロー登録時に、レシーブマスタ情報が存在しない場合に発生します。 レシーブマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPROVAL_OBJECT

public static final java.lang.String BPW_C_IMPORT_INVALID_APPROVAL_OBJECT
承認対象種別が指定されていない、または不正です。 承認対象種別が指定されていないか、または不正な場合に発生します。 正しい承認対象種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RUN_USER_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_RUN_USER_MASTER
実行主体ユーザマスタ情報が設定されてません。 ワークフロー登録時に、実行主体ユーザマスタ情報が存在しない場合に発生します。 実行主体ユーザマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER
実行主体役職マスタ情報が設定されてません。 ワークフロー登録時に、実行主体役職マスタ情報が存在しない場合に発生します。 実行主体役職マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER
プロセスアダプタマスタ情報が設定されてません。 ワークフロー登録時に、プロセスアダプタマスタ情報が存在しない場合に発生します。 プロセスアダプタマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER
オートアダプタマスタ情報が設定されてません。 ワークフロー登録時に、オートアダプタマスタ情報が存在しない場合に発生します。 オートアダプタマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER
イベントアダプタマスタ情報が設定されてません。 ワークフロー登録時に、イベントアダプタマスタ情報が存在しない場合に発生します。 イベントアダプタマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FLOW_INNER_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_FLOW_INNER_MASTER
フロー内容マスタ情報が設定されてません。 ワークフロー登録時に、フロー内容マスタ情報が存在しない場合に発生します。 フロー内容マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SWITCH_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_SWITCH_MASTER
スイッチマスタ情報が設定されてません。 ワークフロー登録時に、スイッチマスタ情報が存在しない場合に発生します。 スイッチマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER
ルート選択マスタ情報が設定されてません。 ワークフロー登録時に、ルート選択マスタ情報が存在しない場合に発生します。 ルート選択マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT

public static final java.lang.String BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT
催促メール猶予日数が不正です。 催促メール猶予日数が数字以外な場合に発生します。 催促メール猶予日数が数字で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION

public static final java.lang.String BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION
催促メール対象種別が指定されていない、または不正です。 催促メール対象種別が指定されていないか、または不正な場合に発生します。 正しい催促メール対象種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN
催促メール猶予日長が不正です。 催促メール猶予日長が不正な場合に発生します。 催促メール猶予日長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN
催促メール対象種別長が不正です。 催促メール対象種別長が不正な場合に発生します。 催促メール対象種別長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN
催促メール表題定義長が不正です。 催促メール表題定義長が不正な場合に発生します。 催促メール表題定義長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN
催促メール内容定義長が不正です。 催促メール内容定義長が不正な場合に発生します。 催促メール内容定義長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_PASS_INFO

public static final java.lang.String BPW_C_IMPORT_NO_AUTO_PASS_INFO
自動パス情報が設定されてません。 ワークフロー登録時に、自動パス情報が存在しない場合に発生します。 自動パス情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_PASS_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_AUTO_PASS_MASTER
自動パスマスタ情報が設定されてません。 ワークフロー登録時に、自動パスマスタ情報が存在しない場合に発生します。 自動パスマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER
自動パス役職マスタ情報が設定されてません。 ワークフロー登録時に、自動パス役職マスタ情報が存在しない場合に発生します。 自動パス役職マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RESULT_SEND_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_RESULT_SEND_MASTER
結果通知先マスタ情報が設定されてません。 ワークフロー登録時に、結果通知先マスタ情報が存在しない場合に発生します。 結果通知先マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_CONTENTS_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_CONTENTS_MASTER
コンテンツマスタ情報が設定されてません。 ワークフロー登録時に、コンテンツマスタ情報が存在しない場合に発生します。 コンテンツマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER

public static final java.lang.String BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER
オートアダプタ・イベントアダプタ情報を設定するライセンスがありません。 BPWライセンスを有していない場合に発生します。 オートアダプタ・イベントアダプタ情報は指定できません。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW

public static final java.lang.String BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW
スイッチ・フロー情報を設定するライセンスがありません。 ライセンスを有していない場合に発生します。 スイッチ・フロー情報は指定できません。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RESULT_TO_OBJECT_FLG

public static final java.lang.String BPW_C_IMPORT_INVALID_RESULT_TO_OBJECT_FLG
結果通知対象種別が指定されていない、または不正です。 結果通知対象種別が指定されていないか、または不正な場合に発生します。 正しい結果通知対象種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONTENTSTYPE

public static final java.lang.String BPW_C_IMPORT_INVALID_CONTENTSTYPE
コンテンツ種別が指定されていない、または不正です。 コンテンツ種別が指定されていないか、または不正な場合に発生します。 正しいコンテンツ種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE

public static final java.lang.String BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE
コンテンツ種別が重複して指定されています。 コンテンツ種別が重複して指定されている場合に発生します。 コンテンツ種別が重複して指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PAGBE_KIND

public static final java.lang.String BPW_C_IMPORT_INVALID_PAGBE_KIND
ページ種別が指定されていない、または不正です。 ページ種別が指定されていないか、または不正な場合に発生します。 正しいページ種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPLICATION_ID

public static final java.lang.String BPW_C_IMPORT_INVALID_APPLICATION_ID
アプリケーションIDが指定されていない、または不正です。 アプリケーションIDが指定されていないか、または不正な場合に発生します。 正しいアプリケーションIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SERVECE_ID

public static final java.lang.String BPW_C_IMPORT_INVALID_SERVECE_ID
サービスIDが指定されていない、または不正です。 サービスIDが指定されていないか、または不正な場合に発生します。 正しいサービスIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN
アプリケーションID長が不正です。 アプリケーションID長が不正な場合に発生します。 アプリケーションID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SERVICE_ID_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_SERVICE_ID_LEN
サービスID長が不正です。 サービスID長が不正な場合に発生します。 サービスID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONTENTS_PATH

public static final java.lang.String BPW_C_IMPORT_INVALID_CONTENTS_PATH
コンテンツパスが指定されていない、または不正です。 コンテンツパスが指定されていないか、または不正な場合に発生します。 正しいコンテンツパスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN
コンテンツパス長が不正です。 コンテンツパス長が不正な場合に発生します。 コンテンツパス長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD
呼び出しプロセス定義コードが指定されていない、または不正です。 呼び出しプロセス定義コードが指定されていないか、または不正な場合に発生します。 正しい呼び出しプロセス定義コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND

public static final java.lang.String BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND
起票タイプが指定されていない、または不正です。 起票タイプが指定されていないか、または不正な場合に発生します。 正しい呼び出し起票タイプが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN
呼び出しプロセス定義コード長が不正です。 呼び出しプロセス定義コード長が不正な場合に発生します。 呼び出しプロセス定義コード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_CLASS

public static final java.lang.String BPW_C_IMPORT_INVALID_RUN_CLASS
実行クラスが指定されていない、または不正です。 実行クラスが指定されていないか、または不正な場合に発生します。 正しい呼び出し実行クラスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN
実行クラス長が不正です。 実行クラス長が不正な場合に発生します。 実行クラス長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID

public static final java.lang.String BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID
イベントサービスIDが指定されていない、または不正です。 イベントサービスIDが指定されていないか、または不正な場合に発生します。 正しい呼び出しイベントサービスIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN
イベントサービスID長が不正です。 イベントサービスID長が不正な場合に発生します。 イベントサービスID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONDITION_CALSS

public static final java.lang.String BPW_C_IMPORT_INVALID_CONDITION_CALSS
条件クラスが指定されていない、または不正です。 条件クラスが指定されていないか、または不正な場合に発生します。 正しい呼び出し条件クラスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN
条件クラス長が不正です。 条件クラス長が不正な場合に発生します。 条件クラス長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD
実効アクティビティコードが指定されていない、または不正です。 実効アクティビティコードが指定されていないか、または不正な場合に発生します。 正しい呼び出し実効アクティビティコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN
実効アクティビティコード長が不正です。 実効アクティビティコード長が不正な場合に発生します。 実効アクティビティコード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_USER_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_RUN_USER_CD
実行主体ユーザコードが指定されていない、または不正です。 実行主体ユーザコードが指定されていないか、または不正な場合に発生します。 正しい呼び出し実行主体ユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_RUN_USER_CD

public static final java.lang.String BPW_C_IMPORT_NO_EXIST_RUN_USER_CD
実行主体ユーザコードが存在しません。 存在しない実行主体ユーザコードが指定されてた場合に発生します。 存在する実行主体ユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND

public static final java.lang.String BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND
実行主体役職種別が指定されていない、または不正です。 実行主体役職種別が指定されていないか、または不正な場合に発生します。 正しい実行主体役職種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD
実行主体役職コードが指定されていない、または不正です。 実行主体役職コードが指定されていないか、または不正な場合に発生します。 正しい実行主体役職コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD

public static final java.lang.String BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD
実行主体役職コードが存在しません。 存在しない実行主体役職コードが指定されてた場合に発生します。 存在する実行主体役職コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_REFER_USER_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_REFER_USER_CD
参照者ユーザコードが指定されていない、または不正です。 参照者ユーザコードが指定されていないか、または不正な場合に発生します。 正しい呼び出し参照者ユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CODE_KIND

public static final java.lang.String BPW_C_IMPORT_INVALID_CODE_KIND
コード種別が指定されていない、または不正です。 コード種別が指定されていないか、または不正な場合に発生します。 正しい呼び出しコード種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_REFER_USER_CD

public static final java.lang.String BPW_C_IMPORT_NO_EXIST_REFER_USER_CD
参照者ユーザコードが存在しません。 存在しない参照者ユーザコードが指定されてた場合に発生します。 存在する参照者ユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD

public static final java.lang.String BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD
参照者組織コードが存在しません。 存在しない参照者組織コードが指定されてた場合に発生します。 存在する参照者組織コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD
自動パスユーザコードが指定されていない、または不正です。 自動パスユーザコードが指定されていないか、または不正な場合に発生します。 正しい呼び出し自動パスユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_PASS_USER_CD

public static final java.lang.String BPW_C_IMPORT_NO_AUTO_PASS_USER_CD
自動パスユーザコードが存在しません。 存在しない自動パスユーザコードが指定されてた場合に発生します。 存在する自動パスユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND

public static final java.lang.String BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND
自動パス役職種別が指定されていない、または不正です。 自動パス役職種別が指定されていないか、または不正な場合に発生します。 正しい自動パス役職種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD
自動パス役職コードが指定されていない、または不正です。 自動パス役職コードが指定されていないか、または不正な場合に発生します。 正しい自動パス役職コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD

public static final java.lang.String BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD
自動パス役職コードが存在しません。 存在しない自動パス役職コードが指定されてた場合に発生します。 存在する自動パス役職コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SEQUENCE_MASTER

public static final java.lang.String BPW_C_IMPORT_NO_SEQUENCE_MASTER
シーケンス内容マスタ情報が設定されてません。 ワークフロー登録時に、シーケンス内容マスタ情報が存在しない場合に発生します。 シーケンス内容マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY

public static final java.lang.String BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY
フロー内容マスタ情報の実行アクティビティが設定されていません。 フロー内容マスタ情報の実行アクティビティが設定されていない場合に発生します。 フロー内容マスタ情報の実行アクティビティ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY

public static final java.lang.String BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY
スイッチマスタ情報の実行アクティビティが設定されていません。 スイッチマスタ情報の実行アクティビティが設定されていない場合に発生します。 スイッチマスタ情報の実行アクティビティ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SELECT_ROUTE_NAME

public static final java.lang.String BPW_C_IMPORT_NO_SELECT_ROUTE_NAME
ルート選択マスタ情報の選択ルート名が設定されていません。 ルート選択マスタ情報の選択ルート名が設定されていない場合に発生します。 ルート選択マスタマスタ情報の選択ルート名の情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SELECT_ROUTE_CD

public static final java.lang.String BPW_C_IMPORT_NO_SELECT_ROUTE_CD
ルート選択マスタ情報の選択ルートコードが設定されていません。 ルート選択マスタ情報の選択ルートコードが設定されていない場合に発生します。 ルート選択マスタマスタ情報の選択ルートコードの情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY

public static final java.lang.String BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY
シーケンスマスタ情報の実行アクティビティが設定されていません。 シーケンスマスタ情報の実行アクティビティが設定されていない場合に発生します。 シーケンスマスタ情報の実行アクティビティ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_TOP_ACTIVITY

public static final java.lang.String BPW_C_IMPORT_INVALID_TOP_ACTIVITY
ルートの先頭アクティビティ種別設定が不正です。 ルートの先頭アクティビティ種別設定がシーケンス以外の場合に発生します。 正しいアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_START_ACTIVITY

public static final java.lang.String BPW_C_IMPORT_INVALID_START_ACTIVITY
ルートの開始アクティビティ種別設定が不正です。 ルートの開始アクティビティ種別設定が不正な場合に発生します。 正しいアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY

public static final java.lang.String BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY
実行時選択前アクティビティ種別の設定が不正です。 実行時選択前アクティビティ種別にフローが設定された場合に発生します。 フロー以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_SWITCH

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_SWITCH
アクティビティ種別設定が不正です。 申請者ルート作成ワークフロー選択時、アクティビティ種別にスイッチが設定された場合に発生します。 スイッチ以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT
アクティビティ種別設定数が不正です。 申請者ルート作成ワークフロー選択時、フローのアクティビティ種別が複数設定された場合に発生します。 フローのアクティビティ種別が複数設定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SECOND_APPROVAL

public static final java.lang.String BPW_C_IMPORT_INVALID_SECOND_APPROVAL
承認対象種別設定が不正です。 申請者ルート作成ワークフロー選択時、起票タスクの次タスクに実行時選択の承認対象種別が設定された場合に発生します。 実行時選択以外の承認対象種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT

public static final java.lang.String BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT
承認対象種別設定が不正です。 申請者ルート作成ワークフロー選択時、承認対象種別に申請者定義が設定されていない場合に発生します。 申請者定義を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG

public static final java.lang.String BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG
承認対象種別設定が不正です。 申請者ルート作成ワークフロー選択時、必須選択最終タスク以降の承認対象種別に申請者定義以外が設定された場合に発生します。 申請者定義を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW

public static final java.lang.String BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW
最短終了フラグの設定が不正です。 申請者ルート作成ワークフロー選択時、フロー内で最短終了フラグが設定された場合に発生します。 最短終了フラグが設定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW

public static final java.lang.String BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW
最短終了フラグの設定が不正です。 申請者ルート作成ワークフロー選択時、フローのアクティビティ種別前に最短終了フラグが設定された場合に発生します。 フローのアクティビティ種別より後に最短終了フラグを設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG

public static final java.lang.String BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG
ルート定義が不正です。 申請者ルート作成ワークフロー選択時、必須選択最終タスク以降に申請者タスク以外が設定された場合に発生します。 必須選択最終タスク以降は申請者タスクを設定する必要があります。

関連項目:
定数フィールド値

BPW_C_FAILED_GET_HTTP_EXCEL_STREAM

public static final java.lang.String BPW_C_FAILED_GET_HTTP_EXCEL_STREAM
Excelファイルストリーム取得に失敗しました。 HTTPリクエストからのExcelファイルストリーム取得に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_FAILED_READ_EXCEL_STREAM

public static final java.lang.String BPW_C_FAILED_READ_EXCEL_STREAM
Excelファイルストリーム読み込みに失敗しました。 HTTPリクエストからのExcelファイルストリーム読み込みに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_FUNCTION_KBN

public static final java.lang.String BPW_C_IMPORT_INVALID_FUNCTION_KBN
処理区分が指定されていない、または不正です。 処理区分が指定されていないか、または不正な場合に発生します。 正しい処理区分が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_TASK_ID

public static final java.lang.String BPW_C_IMPORT_INVALID_TASK_ID
タスク定義に存在しないタスクIDが指定されました。 タスク定義に存在しないタスクIDが指定された場合に発生します。 正しいタスクIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_TASK_TYPE

public static final java.lang.String BPW_C_IMPORT_INVALID_TASK_TYPE
タスクタイプが指定されていない、または不正です。 タスクタイプが指定されていないか、または不正な場合に発生します。 正しいタスクタイプが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE

public static final java.lang.String BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE
フローのサブルートが存在しません。 フローのサブルートが存在しない場合に発生します。 フローのサブルートが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH

public static final java.lang.String BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH
スイッチのサブルートが存在しません。 スイッチのサブルートが存在しない場合に発生します。 スイッチのサブルートが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPROVAL_FOCUS

public static final java.lang.String BPW_C_IMPORT_INVALID_APPROVAL_FOCUS
承認対象が指定されていない、または不正です。 承認対象が指定されていないか、または不正な場合に発生します。 正しい承認対象が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_APPROVAL_CD

public static final java.lang.String BPW_C_IMPORT_DUPLICATE_APPROVAL_CD
承認対象コードが重複しています。 承認対象コードが重複している場合に発生します。 重複した承認対象コードが指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_PLURAL_APPROVAL

public static final java.lang.String BPW_C_IMPORT_PLURAL_APPROVAL
起案タスク以外は、複数対象者の設定をすることはできません。 起案タスク以外に、複数対象者が設定されている場合に発生します。 起案タスク以外に、複数対象者が設定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_REFER_FOCUS

public static final java.lang.String BPW_C_IMPORT_INVALID_REFER_FOCUS
参照対象が指定されていない、または不正です。 参照対象が指定されていないか、または不正な場合に発生します。 正しい参照対象が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS

public static final java.lang.String BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS
自動パス対象が指定されていない、または不正です。 自動パス対象が指定されていないか、または不正な場合に発生します。 正しい自動パス対象が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_AUTO_PASS_ORGS

public static final java.lang.String BPW_C_IMPORT_AUTO_PASS_ORGS
自動パス対象ヘ複数組織／グループを指定することは出来ません。 自動パス対象ヘ複数組織／グループを指定している場合に発生します。 正しい自動パス対象が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FIRST_TASK_ID

public static final java.lang.String BPW_C_IMPORT_NO_FIRST_TASK_ID
始めのタスクIDが指定されていません。 始めのタスクIDが指定されていない場合に発生します。 始めのタスクIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_TASK_ID

public static final java.lang.String BPW_C_IMPORT_DUPLICATE_TASK_ID
タスクIDが重複しています。 タスクIDが重複している場合に発生します。 重複したタスクIDが指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER

public static final java.lang.String BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER
実行時選択のレシーブは指定できません。 実行時選択のレシーブが指定できない場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_SEND_TO_ID

public static final java.lang.String BPW_C_IMPORT_DUPLICATE_SEND_TO_ID
通知先IDが重複しています。 通知先IDが重複している場合に発生します。 重複した通知先IDが指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE

public static final java.lang.String BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE
最初のシーケンスにレシーブが存在しません。 最初のシーケンスにレシーブが存在しない場合に発生します。 最初のシーケンスにレシーブが存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_LACK_SEND_TO_INFO

public static final java.lang.String BPW_C_IMPORT_LACK_SEND_TO_INFO
通知先情報の指定が不完全です。 通知先ID、通知対象の一方にしか値が入っていない場合に発生します。 通知先ID、通知対象の双方に値が入っていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF

public static final java.lang.String BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF
ルート定義内のタスクIDがタスク定義に指定されていません。 ルート定義内のタスクIDがタスク定義に指定されていない場合に発生します。 ルート定義内のタスクIDがタスク定義に指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW

public static final java.lang.String BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW
フロー情報のルート定義入力が不正です。 フローの右にタスクIDが指定された場合に発生します。 フローの右にタスクIDが指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION

public static final java.lang.String BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION
ルート定義ないのタスクの位置の入力が不正です。 承認対象種別が実行時選択であるタスクの左に何もない場合に発生します。 ルート定義の左にタスクを持たないタスクの承認対象種別が実行時選択が指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_GET_ROOT_INFO

public static final java.lang.String BPW_C_INPOSSIBLE_GET_ROOT_INFO
アクティビティルート取得イベントに失敗しました。 アクティビティルート取得イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_ROOT_HISTORY_INFO

public static final java.lang.String BPW_C_NOT_ROOT_HISTORY_INFO
ルート作成履歴情報が存在しません。 プロセス定義情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_SELECTED_TARGET_TASK

public static final java.lang.String BPW_C_NO_SELECTED_TARGET_TASK
申請できません。 未設定のタスクがあります。 必要な設定を行ってから再度「申請」ボタンを押下してください。

関連項目:
定数フィールド値

BPW_C_INVALID_ROOT_NAME

public static final java.lang.String BPW_C_INVALID_ROOT_NAME
申請できません。 呼び出した履歴データに対して変更されています。 申請ルート名を変更してください。

関連項目:
定数フィールド値

BPW_C_INVALID_TAGET_GROUP

public static final java.lang.String BPW_C_INVALID_TAGET_GROUP
申請できません。 承認者に指定したグループに所属するユーザが存在しない場合に発生します。 登録した承認者情報が正しいことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_SHIFT_REFER_DUPLICATION

public static final java.lang.String BPW_C_SHIFT_REFER_DUPLICATION
参照者マスタ移行が出来ません。 既に、移行処理済の場合に発生します。

関連項目:
定数フィールド値

BPW_C_SHIFT_REFER_TOOL

public static final java.lang.String BPW_C_SHIFT_REFER_TOOL
参照者マスタ移行が出来ません。 DBに異常があるか、移行済みの場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO

public static final java.lang.String BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO
この履歴情報は使用できません。 ルート作成後、プロセス定義情報が変更されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT
アクティビティ種別設定が不正です。 申請者ルート作成ワークフロー選択時、アクティビティ種別にルート選択が設定された場合に発生します。 ルート選択以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG

public static final java.lang.String BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG
サブプロセス識別フラグが不正です。 サブプロセス識別フラグが想定外の値であった場合に発生します。 正しいサブプロセス識別フラグが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN

public static final java.lang.String BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN
サブプロセス識別フラグ文字列長が最大文字列長を超えています。 サブプロセス識別フラグ文字列長が最大文字列長を超えている場合に発生します。 サブプロセス識別フラグ文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_ATTACH_INFO

public static final java.lang.String BPW_C_INVALID_ATTACH_INFO
申請・承認時の所属情報が指定されていない、または不正です。 申請・承認時の所属情報が不正な場合に発生します。 正しく所属情報が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_FLOWINFO_NO_EXIST_FLOWICON

public static final java.lang.String BPW_FLOWINFO_NO_EXIST_FLOWICON
フローアイコンが存在しません。Storage配下にフローアイコンが存在することを確認する必要があります。 フローアイコンがStorage配下に存在しない場合に発生します。 Storage配下にフローアイコンが存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_FLOWINFO_INVALID_PARAMETER

public static final java.lang.String BPW_FLOWINFO_INVALID_PARAMETER
フローアイコンを取得する際の入力パラメータ不正です。 不正な入力パラメータの場合に発生します。 有効な入力パラメータを渡す必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW
プロセス種別とサブプロセス識別フラグの設定が不正です。 プロセス種別が申請者/承認者ルート作成ワークフローの時、サブプロセス識別フラグに通常のプロセス定義が設定された場合に発生します。 サブプロセス識別フラグにサブプロセスとしてのプロセス定義を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW

public static final java.lang.String BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW
プロセス種別とサブプロセス識別フラグの設定が不正です。 プロセス種別がビジネスプロセスワークフローの時、サブプロセス識別フラグにサブプロセスとしてのプロセス定義が設定された場合に発生します。 サブプロセス識別フラグに通常のプロセス定義を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD

public static final java.lang.String BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD
会社CDが指定されていない、または不正です。 会社CDが指定されていないか、または不正な場合に発生します。 正しい会社CDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD

public static final java.lang.String BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD
会社CDが存在しません。 存在しない会社CDが指定されてた場合に発生します。 存在する会社CDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CODE_KIND_VALUE

public static final java.lang.String BPW_C_IMPORT_INVALID_CODE_KIND_VALUE
コード種別が不正です。 取得したコード種別が想定外の種別であった場合に発生します。 正しいコード種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT

public static final java.lang.String BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT
ルート選択のサブルートが存在しません。 ルート選択のサブルートが存在しない場合に発生します。 ルート選択のサブルートが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPROVAL

public static final java.lang.String BPW_C_IMPORT_INVALID_APPROVAL
承認対象種別設定が不正です。 申請者／承認者ルート作成ワークフロー選択以外の時、申請者定義の承認対象種別が設定された場合に発生します。 申請者定義以外の承認対象種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE

public static final java.lang.String BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE
ルート選択の前アクティビティ種別の設定が不正です。 ルート選択の前アクティビティ種別に処理タスク以外が設定された場合に発生します。 処理タスクのアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE

public static final java.lang.String BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE
サブプロセス（申請者／承認者ルート作成ワークフロー）の前アクティビティ種別の設定が不正です。 サブプロセス（申請者／承認者ルート作成ワークフロー）の前アクティビティ種別に処理タスク以外が設定された場合に発生します。 処理タスクのアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FIRST_TASK_ID_OF_ROUTE_SELECT

public static final java.lang.String BPW_C_IMPORT_NO_FIRST_TASK_ID_OF_ROUTE_SELECT
始めのタスクIDまたは選択ルート名が指定されていません。 始めのタスクIDまたは選択ルート名が指定されていない場合に発生します。 始めのタスクIDまたは選択ルート名が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN
選択ルート名長が不正です。 選択ルート名長が不正な場合に発生します。 選択ルート名長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN

public static final java.lang.String BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN
選択ルートコード長が不正です。 選択ルートコード長が不正な場合に発生します。 選択ルートコード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ACTIVITY_TYPE

public static final java.lang.String BPW_C_IMPORT_INVALID_ACTIVITY_TYPE
アクティビティ種別の設定が不正です。 ドキュメントワークフロー選択以外の時、ルート選択のアクティビティ種別が設定された場合に発生します。 ルート選択以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SUB_PROCESS

public static final java.lang.String BPW_C_IMPORT_INVALID_SUB_PROCESS
サブプロセスの設定が不正です。 プロセス種別が申請者／承認者ルート作成ワークフロー選択の時、サブプロセス（申請者／承認者ルート作成ワークフロー）が設定された場合に発生します。 申請者／承認者ルート作成ワークフロー以外のサブプロセスを設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD

public static final java.lang.String BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD
プロセス種別の設定が不正です。 プロセス種別が申請者／承認者ルート作成ワークフローの変更時、プロセス種別（申請者／承認者ルート作成ワークフロー）以外が設定された場合に発生します。 変更時は申請者／承認者ルート作成ワークフローのプロセス種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE

public static final java.lang.String BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE
実行時選択の前アクティビティ種別の設定が不正です。 実行時選択の前アクティビティ種別にサブプロセス（申請者／承認者ルート作成ワークフロー）が設定された場合に発生します。 サブプロセス（申請者／承認者ルート作成ワークフロー）以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS

public static final java.lang.String BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS
始めの条件クラスが指定されていません。 始めの条件クラスが指定されていない場合に発生します。 始めの条件クラスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_ROUTE_SELECT_MASTER

public static final java.lang.String BPW_C_NO_ROUTE_SELECT_MASTER
ルート選択マスタ情報が設定されてません。 フロー制御時に、ルート選択マスタ情報が存在しない場合に発生します。 ルート選択マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_NOT_BACK_IN_FLOW

public static final java.lang.String BPW_C_NOT_BACK_IN_FLOW
同期処理内より、処理外への引戻し／差戻しは行えません。 同期処理内より、処理外への引戻し／差戻しを実行した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INVALID_RETURN_FLG

public static final java.lang.String BPW_C_INVALID_RETURN_FLG
引戻し／差戻しは行えません。（引戻し／差戻し可否フラグ＝ＯＦＦ） 引戻し／差戻し可否フラグ＝ＯＦＦの場合に引戻し／差戻しを実行した場合に発生します。

関連項目:
定数フィールド値

BPW_INVALID_PROCESS_NAME_LENGTH

public static final java.lang.String BPW_INVALID_PROCESS_NAME_LENGTH
プロセス名の入力文字数が制限を越えています。

関連項目:
定数フィールド値

BPW_INVALID_DRAFT_COMMENT_LENGTH

public static final java.lang.String BPW_INVALID_DRAFT_COMMENT_LENGTH
申請コメントの入力文字数が制限を越えています。

関連項目:
定数フィールド値

BPW_INVALID_RECEIVE_COMMENT_LENGTH

public static final java.lang.String BPW_INVALID_RECEIVE_COMMENT_LENGTH
審議コメントの入力文字数が制限を越えています。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY

public static final java.lang.String BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY
予約メール依頼の設定に失敗しました。 リザーブキーの設定に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY

public static final java.lang.String BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY
テンプレートメール送信抑止の設定に失敗しました。 リザーブキーの設定に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND

public static final java.lang.String BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND
メールテンプレートの取得に失敗しました。 指定されたパスに該当するメールテンプレートが存在しない場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY

public static final java.lang.String BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY
メールテンプレートの設定に失敗しました。 メールテンプレートの設定に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND

public static final java.lang.String BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND
メールテンプレートの送信に失敗しました。 メールテンプレートの送信に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_NO_ATTACH_POSITION_GROUP

public static final java.lang.String BPW_C_NO_ATTACH_POSITION_GROUP
申請できません。 選択した所属組織の有効期間と「起票を行いたい日付」が一致していません。
再度処理を行ってください。それでも現象が改善されない場合は管理者にご連絡ください。

関連項目:
定数フィールド値

BPW_C_NO_ATTACH_POSITION_GROUP_AGENT

public static final java.lang.String BPW_C_NO_ATTACH_POSITION_GROUP_AGENT
申請できません。 選択した代理元の所属組織に誤りがあります。
再度処理を行ってください。それでも現象が改善されない場合は管理者にご連絡ください。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_BEGIN

public static final java.lang.String BPW_UT_FAILED_TO_BEGIN
ユーザトランザクションの開始に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_COMMIT

public static final java.lang.String BPW_UT_FAILED_TO_COMMIT
ユーザトランザクションのコミットに失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_ROLLBACK

public static final java.lang.String BPW_UT_FAILED_TO_ROLLBACK
ユーザトランザクションのロールバックに失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_GET_STATUS

public static final java.lang.String BPW_UT_FAILED_TO_GET_STATUS
ユーザトランザクションのステータスの取得に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_CLOSE

public static final java.lang.String BPW_UT_FAILED_TO_CLOSE
ユーザトランザクションの終了に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY

public static final java.lang.String BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY
ユーザトランザクションのロールバックオンリーの設定に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT

public static final java.lang.String BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT
ユーザトランザクションのトランザクションタイムアウトの設定に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION

public static final java.lang.String BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION
トランザクションが開始していないためコミットに失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION

public static final java.lang.String BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION
トランザクションが開始していないためロールバックに失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_LOCK

public static final java.lang.String BPW_UT_FAILED_TO_LOCK
ユーザアプリケーションロックの解除に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_UNLOCK

public static final java.lang.String BPW_UT_FAILED_TO_UNLOCK
ユーザアプリケーションロックの解除に失敗しました。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE

public static final java.lang.String BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE
起票タスクのタスク種別に誤りがあります。
起票タスクの設定を確認してください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_ROOT_SETTING

public static final java.lang.String BPW_CORE_IMPORT_INVALID_ROOT_SETTING
ルート定義に誤りがあります。
ルート定義を設定しなおしてください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO

public static final java.lang.String BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO
サブプロセス設定情報が設定されていません。
サブプロセスの設定情報を見直してください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK

public static final java.lang.String BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK
起票タスクに動的承認者は設定できません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_NO_RECEIVE_TASK

public static final java.lang.String BPW_CORE_IMPORT_NO_RECEIVE_TASK
起票(処理)タスクが設定されていない可能性があります。
起票(処理)タスクは必ず1つ以上設定してください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER

public static final java.lang.String BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER
同期タスクの結合直後に動的な対象者を設定する事はできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH

public static final java.lang.String BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH
承認者種別が実行時選択のタスクを
同期・分岐・ルート選択の開始直後に設定する事はできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE

public static final java.lang.String BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE
サブプロセスに申請者/承認者ルート作成ワークフローが設定されているタスクの直前に
申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW

public static final java.lang.String BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW
同期の開始・結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH

public static final java.lang.String BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH
分岐の開始直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW

public static final java.lang.String BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW
同期の開始・結合直後にルート選択タスクを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE

public static final java.lang.String BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE
ルート選択タスクの直前に申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH

public static final java.lang.String BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH
分岐・ルート選択の開始直後にルート選択タスクを設定する事はできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT

public static final java.lang.String BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT
分岐内のタスク設定に誤りがあります。
ルート定義を設定しなおしてください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW

public static final java.lang.String BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW
プロセス定義種別がビジネスプロセスワークフローの場合、コンテンツフレーム種別にカスタムを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT

public static final java.lang.String BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT
分岐内に1ルートしか設定されていません。分岐内のルートは必ず2ルート以上作成してください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE

public static final java.lang.String BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE
ルート選択内に処理タスクがない場合、ルート選択結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_INVOKE_TASK

public static final java.lang.String BPW_CORE_IMPORT_INVALID_INVOKE_TASK
プロセス種別がビジネスプロセスワークフロー以外の場合、自動実行タスク、イベント実行タスクを設定することはできません。

関連項目:
定数フィールド値

BPW_C_ALREADY_SUSPEND

public static final java.lang.String BPW_C_ALREADY_SUSPEND
既に保留されている可能性があります。 該当案件の状態を確認し再度処理を行ってください。

関連項目:
定数フィールド値

BPW_C_INVALID_RETURN_START_RUN_USER_INFO

public static final java.lang.String BPW_C_INVALID_RETURN_START_RUN_USER_INFO
申請者への差し戻しイベントに失敗しました。 差し戻し先のユーザ情報が不正な場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_GET_PROCESS_CODE

public static final java.lang.String BPW_C_NOT_GET_PROCESS_CODE
案件番号の取得に失敗しました。 案件番号の採番ロジックで予期せぬエラーが発生しました。

関連項目:
定数フィールド値

BPW_C_PROCESS_COUNT_FILE_NOT_FOUND

public static final java.lang.String BPW_C_PROCESS_COUNT_FILE_NOT_FOUND
案件番号の採番処理に失敗しました。 採番用のコードカウントファイルが存在しない可能性があります。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.bpw.exception (intra-mart ワークフロー)

 jp.co.intra_mart.foundation.bpw.exception
インタフェース
BPWErrorCodeIF
WKFErrorCodeIF
例外
WKFApplicationException


jp.co.intra_mart.foundation.bpw.exception (intra-mart ワークフロー)

ワークフローモジュール
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.exception

インタフェースの概要
BPWErrorCodeIF | ＢＰＷで利用される例外エラーコードインタフェース定義
WKFErrorCodeIF | ＢＰＷで利用される例外エラーコードインタフェース定義

例外の概要
WKFApplicationException ＢＰＷのアプリケーション例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のパッケージ 次のパッケージ フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.bpw.exception クラス階層 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException

インタフェース階層

  • interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF
  • interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.foundation.bpw.exception の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.bpw.exception の使用

jp.co.intra_mart.foundation.bpw.exception を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf により使用される jp.co.intra_mart.foundation.bpw.exception のクラス
WKFApplicationException
ＢＰＷのアプリケーション例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


WKFApplicationException (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.exception
クラス WKFApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException
すべての実装インタフェース:
java.io.Serializable
public class WKFApplicationException
extends jp.co.intra_mart.framework.system.exception.ApplicationException

ＢＰＷのアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
WKFApplicationException()
コンストラクタ
WKFApplicationException(java.lang.String code)
エラーコードを保持した例外を生成します。
WKFApplicationException(java.lang.String code, java.lang.String message)
エラーコードと詳細メッセージを保持した例外を生成します。
WKFApplicationException(java.lang.String code, java.lang.String message, java.lang.Throwable e)
エラーコード、詳細メッセージと例外の発生原因となる例外を保持した例外を生成します。
WKFApplicationException(java.lang.String code, java.lang.Throwable e)
エラーコードと例外の発生原因となる例外を保持した例外を生成します。
メソッドの概要
 java.lang.String getErrorCode()
エラーコードを返却します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

WKFApplicationException

public WKFApplicationException()
コンストラクタ

WKFApplicationException

public WKFApplicationException(java.lang.String code)
エラーコードを保持した例外を生成します。

パラメータ:
code - エラーコード

WKFApplicationException

public WKFApplicationException(java.lang.String code,
                               java.lang.String message)
エラーコードと詳細メッセージを保持した例外を生成します。

パラメータ:
code - エラーコード
message - エラーメッセージ

WKFApplicationException

public WKFApplicationException(java.lang.String code,
                               java.lang.Throwable e)
エラーコードと例外の発生原因となる例外を保持した例外を生成します。

パラメータ:
code - エラーコード
e - 例外発生原因

WKFApplicationException

public WKFApplicationException(java.lang.String code,
                               java.lang.String message,
                               java.lang.Throwable e)
エラーコード、詳細メッセージと例外の発生原因となる例外を保持した例外を生成します。

パラメータ:
code - エラーコード
message - エラーメッセージ
e - 例外発生原因
メソッドの詳細

getErrorCode

public java.lang.String getErrorCode()
エラーコードを返却します。

戻り値:
エラーコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


WKFErrorCodeIF (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.exception
インタフェース WKFErrorCodeIF

public interface WKFErrorCodeIF

ＢＰＷで利用される例外エラーコードインタフェース定義

フィールドの概要
static java.lang.String | WFK_C_NOT_TEMPLATE_PATH 指定されたメールテンプレートが不正です。
static java.lang.String | WKF_C_APPROVAL_TYPE 承認種別の取得に失敗しました。
static java.lang.String | WKF_C_AUTO_PASS 自動パスの処理に失敗しました。
static java.lang.String | WKF_C_AUTO_PRESS 自動催促の処理に失敗しました。
static java.lang.String | WKF_C_DEPARTMENT_INFO_ERROR 所属組織情報が不正です。
static java.lang.String | WKF_C_DRAFT_ACTIVITY_CD 起票アクティビティコードの取得に失敗しました。
static java.lang.String | WKF_C_DRAFT_APPOINT_DATE 起票指定日の取得に失敗しました。
static java.lang.String | WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD 次アクティビティコードが指定されていない、または不正です。
static java.lang.String | WKF_C_INPOSSIBLE_DRAFT_ACTIVITY 申請イベントに失敗しました。
static java.lang.String | WKF_C_INPOSSIBLE_PULL_ACTIVITY 引き戻しイベントに失敗しました。
static java.lang.String | WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY 承認イベントに失敗しました。
static java.lang.String | WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY 承認者への差し戻しイベントに失敗しました。
static java.lang.String | WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY 申請者への差し戻しイベントに失敗しました。
static java.lang.String | WKF_C_NO_MANAGER_AUTHORITY このAPIはワークフロー管理者ロールをもつユーザ以外のユーザでは使用できません。
static java.lang.String | WKF_C_NOT_ACTIVITY アクティビティ情報が存在しません。
static java.lang.String | WKF_C_NOT_APPLICATION_KEY アプリケーションキーが設定されていない、または不正です。
static java.lang.String | WKF_C_NOT_DEPARTMENT_INFO 所属組織情報の取得に失敗しました。
static java.lang.String | WKF_C_NOT_PROCESS_INFO プロセス情報の取得に失敗しました。
static java.lang.String | WKF_C_NOT_REGIST_TYPE 起票タスクの対象者に指定されていない、または不正です。
static java.lang.String | WKF_C_NOT_VERSION 履歴情報が存在しません。
static java.lang.String | WKF_C_PRAM_AGT_ALL 代理元ユーザが不正です。
static java.lang.String | WKF_C_PRAM_ERROR パラメータが不正です。
static java.lang.String | WKF_C_PROCESS_INFO プロセス情報の取得に失敗しました。
static java.lang.String | WKF_C_REMOVE_PROCESS プロセスの削除に失敗しました。
static java.lang.String | WKF_C_SEND_MAIL メール送信に失敗しました。

フィールドの詳細

WKF_C_PRAM_ERROR

public static final java.lang.String WKF_C_PRAM_ERROR
パラメータが不正です。

関連項目:
定数フィールド値

WKF_C_PRAM_AGT_ALL

public static final java.lang.String WKF_C_PRAM_AGT_ALL
代理元ユーザが不正です。代理元ユーザにAGT_ALLが設定されています。

関連項目:
定数フィールド値

WKF_C_SEND_MAIL

public static final java.lang.String WKF_C_SEND_MAIL
メール送信に失敗しました。

関連項目:
定数フィールド値

WFK_C_NOT_TEMPLATE_PATH

public static final java.lang.String WFK_C_NOT_TEMPLATE_PATH
指定されたメールテンプレートが不正です。

関連項目:
定数フィールド値

WKF_C_AUTO_PASS

public static final java.lang.String WKF_C_AUTO_PASS
自動パスの処理に失敗しました。

関連項目:
定数フィールド値

WKF_C_AUTO_PRESS

public static final java.lang.String WKF_C_AUTO_PRESS
自動催促の処理に失敗しました。

関連項目:
定数フィールド値

WKF_C_REMOVE_PROCESS

public static final java.lang.String WKF_C_REMOVE_PROCESS
プロセスの削除に失敗しました。

関連項目:
定数フィールド値

WKF_C_DRAFT_ACTIVITY_CD

public static final java.lang.String WKF_C_DRAFT_ACTIVITY_CD
起票アクティビティコードの取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_PROCESS_INFO

public static final java.lang.String WKF_C_PROCESS_INFO
プロセス情報の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_DRAFT_APPOINT_DATE

public static final java.lang.String WKF_C_DRAFT_APPOINT_DATE
起票指定日の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_APPROVAL_TYPE

public static final java.lang.String WKF_C_APPROVAL_TYPE
承認種別の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_NOT_PROCESS_INFO

public static final java.lang.String WKF_C_NOT_PROCESS_INFO
プロセス情報の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_PULL_ACTIVITY

public static final java.lang.String WKF_C_INPOSSIBLE_PULL_ACTIVITY
引き戻しイベントに失敗しました。 引き戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY

public static final java.lang.String WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY
申請者への差し戻しイベントに失敗しました。 申請者への差し戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY

public static final java.lang.String WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY
承認者への差し戻しイベントに失敗しました。 承認者への差し戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_DRAFT_ACTIVITY

public static final java.lang.String WKF_C_INPOSSIBLE_DRAFT_ACTIVITY
申請イベントに失敗しました。 申請イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY

public static final java.lang.String WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY
承認イベントに失敗しました。 承認イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_NOT_ACTIVITY

public static final java.lang.String WKF_C_NOT_ACTIVITY
アクティビティ情報が存在しません。 アクティビティ情報が存在しない場合に発生します。

関連項目:
定数フィールド値

WKF_C_NOT_VERSION

public static final java.lang.String WKF_C_NOT_VERSION
履歴情報が存在しません。 履歴情報が存在しない場合に発生します。

関連項目:
定数フィールド値

WKF_C_NOT_DEPARTMENT_INFO

public static final java.lang.String WKF_C_NOT_DEPARTMENT_INFO
所属組織情報の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_NOT_REGIST_TYPE

public static final java.lang.String WKF_C_NOT_REGIST_TYPE
起票タスクの対象者に指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_DEPARTMENT_INFO_ERROR

public static final java.lang.String WKF_C_DEPARTMENT_INFO_ERROR
所属組織情報が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_APPLICATION_KEY

public static final java.lang.String WKF_C_NOT_APPLICATION_KEY
アプリケーションキーが設定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD

public static final java.lang.String WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD
次アクティビティコードが指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_NO_MANAGER_AUTHORITY

public static final java.lang.String WKF_C_NO_MANAGER_AUTHORITY
このAPIはワークフロー管理者ロールをもつユーザ以外のユーザでは使用できません。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic の使用

jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter の使用

jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


インタフェース jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の使用

jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


BPWExecuteLogic (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.data
クラス BPWExecuteLogic

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic
public abstract class BPWExecuteLogic
extends java.lang.Object

外部プログラム実行抽象クラス。
ワークフロー上で後処理、自動処理で指定した外部プログラムの呼出を実施する際に、
呼び出されるプログラムが継承するクラスです。
外部プログラムはこの抽象化クラスを必ず継承して下さい。

コンストラクタの概要
BPWExecuteLogic()
コンストラクタ
メソッドの概要
java.lang.String | compulsion(java.lang.String processDef, java.lang.String version, java.lang.String process, java.lang.String activity, java.lang.String groupID, java.lang.String userID) ここで終了後後処理実行メソッド。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ユーザ情報返却メソッド
abstract java.lang.String | proceed(java.lang.String processDef, java.lang.String version, java.lang.String process, java.lang.String activity, java.lang.String groupID, java.lang.String userID) 処理実行メソッド。
java.lang.String | pullDraft(java.lang.String processDef, java.lang.String version, java.lang.String process, java.lang.String activity, java.lang.String groupID, java.lang.String userID) 引戻し後処理実行メソッド。
java.lang.String | rejection(java.lang.String processDef, java.lang.String version, java.lang.String process, java.lang.String activity, java.lang.String groupID, java.lang.String userID) 否認後後処理実行メソッド。
java.lang.String | returnDraft(java.lang.String processDef, java.lang.String version, java.lang.String process, java.lang.String activity, java.lang.String groupID, java.lang.String userID) 処理者へ差戻し後処理実行メソッド。
java.lang.String | returnStart(java.lang.String processDef, java.lang.String version, java.lang.String process, java.lang.String activity, java.lang.String groupID, java.lang.String userID) 申請者へ差戻し後処理実行メソッド。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo userInfo) ユーザ情報設定メソッド
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BPWExecuteLogic

public BPWExecuteLogic()
コンストラクタ

メソッドの詳細

proceed

public abstract java.lang.String proceed(java.lang.String processDef,
                                         java.lang.String version,
                                         java.lang.String process,
                                         java.lang.String activity,
                                         java.lang.String groupID,
                                         java.lang.String userID)
                                  throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                                         jp.co.intra_mart.framework.system.exception.SystemException
処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

pullDraft

public java.lang.String pullDraft(java.lang.String processDef,
                                  java.lang.String version,
                                  java.lang.String process,
                                  java.lang.String activity,
                                  java.lang.String groupID,
                                  java.lang.String userID)
                           throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                                  jp.co.intra_mart.framework.system.exception.SystemException
引戻し後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

returnDraft

public java.lang.String returnDraft(java.lang.String processDef,
                                    java.lang.String version,
                                    java.lang.String process,
                                    java.lang.String activity,
                                    java.lang.String groupID,
                                    java.lang.String userID)
                             throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                                    jp.co.intra_mart.framework.system.exception.SystemException
処理者へ差戻し後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

returnStart

public java.lang.String returnStart(java.lang.String processDef,
                                    java.lang.String version,
                                    java.lang.String process,
                                    java.lang.String activity,
                                    java.lang.String groupID,
                                    java.lang.String userID)
                             throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                                    jp.co.intra_mart.framework.system.exception.SystemException
申請者へ差戻し後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

rejection

public java.lang.String rejection(java.lang.String processDef,
                                  java.lang.String version,
                                  java.lang.String process,
                                  java.lang.String activity,
                                  java.lang.String groupID,
                                  java.lang.String userID)
                           throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                                  jp.co.intra_mart.framework.system.exception.SystemException
否認後後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

compulsion

public java.lang.String compulsion(java.lang.String processDef,
                                   java.lang.String version,
                                   java.lang.String process,
                                   java.lang.String activity,
                                   java.lang.String groupID,
                                   java.lang.String userID)
                            throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                                   jp.co.intra_mart.framework.system.exception.SystemException
ここで終了後後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo userInfo)
ユーザ情報設定メソッド

パラメータ:
userInfo -

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ユーザ情報返却メソッド

戻り値:
ユーザ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ConditionAdapter (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.data
クラス ConditionAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.data.Condition
        拡張 jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter
public abstract class ConditionAdapter
extends jp.co.intra_mart.foundation.bpw.model.data.Condition

外部プログラム実行抽象クラス。
ワークフロー上で条件分岐、結合条件で指定した外部プログラムの呼出を実施する際に、
呼び出されるプログラムが継承するクラスです。
外部プログラムはこの抽象化クラスを必ず継承して下さい。

コンストラクタの概要
ConditionAdapter(ConditionModel model)
コンストラクタ
メソッドの概要
abstract boolean | execute(java.lang.String processDef, java.lang.String version, java.lang.String process, java.lang.String activity, java.lang.String groupID, java.lang.String userID) 条件問い合わせを実行するメソッド 条件分岐および、条件結合の判定を行う場合はこのメソッドを継承してください。
boolean | isSatisfied() 条件問い合わせ
クラス jp.co.intra_mart.foundation.bpw.model.data.Condition から継承したメソッド
getLoginUserInfo, setLoginUserInfo
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConditionAdapter

public ConditionAdapter(ConditionModel model)
コンストラクタ

メソッドの詳細

isSatisfied

public final boolean isSatisfied()
                          throws jp.co.intra_mart.framework.system.exception.SystemException
条件問い合わせ

戻り値:
条件結果
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

execute

public abstract boolean execute(java.lang.String processDef,
                                java.lang.String version,
                                java.lang.String process,
                                java.lang.String activity,
                                java.lang.String groupID,
                                java.lang.String userID)
                         throws jp.co.intra_mart.framework.system.exception.SystemException
条件問い合わせを実行するメソッド
条件分岐および、条件結合の判定を行う場合はこのメソッドを継承してください。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.SystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


EISModelStaticIF (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.data
インタフェース EISModelStaticIF

public interface EISModelStaticIF

アクティビティの状態等を定義するインタフェース。
アクティビティ種別
アクティビティステータス
アクティビティ到達種別
を定義する。

フィールドの概要
static java.lang.String | ACTIVITY_ID_EMPTY エンプティの処理タイプID
static java.lang.String | ACTIVITY_ID_FLOW フローの処理タイプID
static java.lang.String | ACTIVITY_ID_INVOKE_AUTO インボーク(自動呼出)の処理タイプID
static java.lang.String | ACTIVITY_ID_INVOKE_EVENT インボーク(イベント)の処理タイプID
static java.lang.String | ACTIVITY_ID_INVOKE_PROCESS インボーク(プロセス呼出)の処理タイプID
static java.lang.String | ACTIVITY_ID_PROCESS プロセスの処理タイプID
static java.lang.String | ACTIVITY_ID_RECEIVE レシーブの処理タイプID
static java.lang.String | ACTIVITY_ID_ROUTE_SELECT ルート選択の処理タイプID
static java.lang.String | ACTIVITY_ID_SEQUENCE シーケンスの処理タイプID
static java.lang.String | ACTIVITY_ID_SWITCH スイッチの処理タイプID
static java.lang.String | ACTIVITY_ID_TERMINATE ターミネートの処理タイプID
static java.lang.String | ATTAINMENT_NORMAL アクティビティは通常に処理が到達した。
static java.lang.String | ATTAINMENT_NOT アクティビティには処理が到達していない。
static java.lang.String | ATTAINMENT_PULL_ACTIVE 引き戻し（Active)
static java.lang.String | ATTAINMENT_PULL_READY 被・引き戻し（Ready)
static java.lang.String | ATTAINMENT_RETURN_ACTIVE 差し戻し（Active)
static java.lang.String | ATTAINMENT_RETURN_READY 被・差し戻し（Complete→Ready)
static java.lang.String | ATTAINMENT_RETURN_READY_ACTIVE 被・差し戻し（Active→Ready)
static int | EIS_INIT 初期値（数値）
static java.lang.String | EIS_METHOD_ACTIVED リフレクト・メソッド（開始）
static java.lang.String | EIS_METHOD_CANCELED リフレクト・メソッド（取消）
static java.lang.String | EIS_METHOD_CLOSED リフレクト・メソッド（閉じる）
static java.lang.String | EIS_METHOD_COMPENSATED リフレクト・メソッド（補完）
static java.lang.String | EIS_METHOD_COMPLETED リフレクト・メソッド（完了）
static java.lang.String | EIS_METHOD_COMPULSION リフレクト・メソッド（強制完了）
static java.lang.String | EIS_METHOD_EXITED リフレクト・メソッド（終了）
static java.lang.String | EIS_METHOD_FAULTED リフレクト・メソッド（障害）
static java.lang.String | EIS_METHOD_SUSPENDED リフレクト・メソッド（保留中）
static java.lang.String | FLG_OFF フラグOFF
static java.lang.String | FLG_ON フラグON
static java.lang.String | STATUS_ACTIVE 有効な状態であることを示すステータス
static java.lang.String | STATUS_AUTOCLOSING 自動終了を示すステータス
static java.lang.String | STATUS_CANCELING 取消中であることを示すステータス
static java.lang.String | STATUS_CLOSING 終了したことを示すステータス
static java.lang.String | STATUS_COMPENSATING 補完中であることを示すステータス
static java.lang.String | STATUS_COMPLETED 完了したことを示すステータス
static java.lang.String | STATUS_EXIT 処理が終了したことを示すステータス
static java.lang.String | STATUS_FAULT 障害が発生したことを示すステータス
static java.lang.String | STATUS_NONE 有効なステータスではない
static java.lang.String | STATUS_READY 準備完了を示すステータス
static java.lang.String | STATUS_SUSPEND 保留中であることを示すステータス
static java.lang.String | STR_INIT 初期値（文字列）
static java.lang.String | STR_NULL 空文字

フィールドの詳細

ACTIVITY_ID_PROCESS

public static final java.lang.String ACTIVITY_ID_PROCESS
プロセスの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_RECEIVE

public static final java.lang.String ACTIVITY_ID_RECEIVE
レシーブの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_INVOKE_PROCESS

public static final java.lang.String ACTIVITY_ID_INVOKE_PROCESS
インボーク(プロセス呼出)の処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_INVOKE_AUTO

public static final java.lang.String ACTIVITY_ID_INVOKE_AUTO
インボーク(自動呼出)の処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_SEQUENCE

public static final java.lang.String ACTIVITY_ID_SEQUENCE
シーケンスの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_FLOW

public static final java.lang.String ACTIVITY_ID_FLOW
フローの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_TERMINATE

public static final java.lang.String ACTIVITY_ID_TERMINATE
ターミネートの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_EMPTY

public static final java.lang.String ACTIVITY_ID_EMPTY
エンプティの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_SWITCH

public static final java.lang.String ACTIVITY_ID_SWITCH
スイッチの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_INVOKE_EVENT

public static final java.lang.String ACTIVITY_ID_INVOKE_EVENT
インボーク(イベント)の処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_ROUTE_SELECT

public static final java.lang.String ACTIVITY_ID_ROUTE_SELECT
ルート選択の処理タイプID

関連項目:
定数フィールド値

STATUS_NONE

public static final java.lang.String STATUS_NONE
有効なステータスではない

関連項目:
定数フィールド値

STATUS_READY

public static final java.lang.String STATUS_READY
準備完了を示すステータス

関連項目:
定数フィールド値

STATUS_ACTIVE

public static final java.lang.String STATUS_ACTIVE
有効な状態であることを示すステータス

関連項目:
定数フィールド値

STATUS_SUSPEND

public static final java.lang.String STATUS_SUSPEND
保留中であることを示すステータス

関連項目:
定数フィールド値

STATUS_CANCELING

public static final java.lang.String STATUS_CANCELING
取消中であることを示すステータス

関連項目:
定数フィールド値

STATUS_COMPLETED

public static final java.lang.String STATUS_COMPLETED
完了したことを示すステータス

関連項目:
定数フィールド値

STATUS_COMPENSATING

public static final java.lang.String STATUS_COMPENSATING
補完中であることを示すステータス

関連項目:
定数フィールド値

STATUS_CLOSING

public static final java.lang.String STATUS_CLOSING
終了したことを示すステータス

関連項目:
定数フィールド値

STATUS_FAULT

public static final java.lang.String STATUS_FAULT
障害が発生したことを示すステータス

関連項目:
定数フィールド値

STATUS_EXIT

public static final java.lang.String STATUS_EXIT
処理が終了したことを示すステータス

関連項目:
定数フィールド値

STATUS_AUTOCLOSING

public static final java.lang.String STATUS_AUTOCLOSING
自動終了を示すステータス

関連項目:
定数フィールド値

EIS_METHOD_ACTIVED

public static final java.lang.String EIS_METHOD_ACTIVED
リフレクト・メソッド（開始）

関連項目:
定数フィールド値

EIS_METHOD_SUSPENDED

public static final java.lang.String EIS_METHOD_SUSPENDED
リフレクト・メソッド（保留中）

関連項目:
定数フィールド値

EIS_METHOD_COMPLETED

public static final java.lang.String EIS_METHOD_COMPLETED
リフレクト・メソッド（完了）

関連項目:
定数フィールド値

EIS_METHOD_COMPULSION

public static final java.lang.String EIS_METHOD_COMPULSION
リフレクト・メソッド（強制完了）

関連項目:
定数フィールド値

EIS_METHOD_FAULTED

public static final java.lang.String EIS_METHOD_FAULTED
リフレクト・メソッド（障害）

関連項目:
定数フィールド値

EIS_METHOD_EXITED

public static final java.lang.String EIS_METHOD_EXITED
リフレクト・メソッド（終了）

関連項目:
定数フィールド値

EIS_METHOD_COMPENSATED

public static final java.lang.String EIS_METHOD_COMPENSATED
リフレクト・メソッド（補完）

関連項目:
定数フィールド値

EIS_METHOD_CANCELED

public static final java.lang.String EIS_METHOD_CANCELED
リフレクト・メソッド（取消）

関連項目:
定数フィールド値

EIS_METHOD_CLOSED

public static final java.lang.String EIS_METHOD_CLOSED
リフレクト・メソッド（閉じる）

関連項目:
定数フィールド値

ATTAINMENT_NOT

public static final java.lang.String ATTAINMENT_NOT
アクティビティには処理が到達していない。

関連項目:
定数フィールド値

ATTAINMENT_NORMAL

public static final java.lang.String ATTAINMENT_NORMAL
アクティビティは通常に処理が到達した。

関連項目:
定数フィールド値

ATTAINMENT_PULL_ACTIVE

public static final java.lang.String ATTAINMENT_PULL_ACTIVE
引き戻し（Active)

関連項目:
定数フィールド値

ATTAINMENT_PULL_READY

public static final java.lang.String ATTAINMENT_PULL_READY
被・引き戻し（Ready)

関連項目:
定数フィールド値

ATTAINMENT_RETURN_ACTIVE

public static final java.lang.String ATTAINMENT_RETURN_ACTIVE
差し戻し（Active)

関連項目:
定数フィールド値

ATTAINMENT_RETURN_READY

public static final java.lang.String ATTAINMENT_RETURN_READY
被・差し戻し（Complete→Ready)

関連項目:
定数フィールド値

ATTAINMENT_RETURN_READY_ACTIVE

public static final java.lang.String ATTAINMENT_RETURN_READY_ACTIVE
被・差し戻し（Active→Ready)

関連項目:
定数フィールド値

FLG_ON

public static final java.lang.String FLG_ON
フラグON

関連項目:
定数フィールド値

FLG_OFF

public static final java.lang.String FLG_OFF
フラグOFF

関連項目:
定数フィールド値

STR_NULL

public static final java.lang.String STR_NULL
空文字

関連項目:
定数フィールド値

STR_INIT

public static final java.lang.String STR_INIT
初期値（文字列）

関連項目:
定数フィールド値

EIS_INIT

public static final int EIS_INIT
初期値（数値）

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.bpw.model.data (intra-mart ワークフロー)

 jp.co.intra_mart.foundation.bpw.model.data
インタフェース
EISModelStaticIF
クラス
BPWExecuteLogic
ConditionAdapter


jp.co.intra_mart.foundation.bpw.model.data (intra-mart ワークフロー)

ワークフローモジュール
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.model.data

インタフェースの概要
EISModelStaticIF アクティビティの状態等を定義するインタフェース。

クラスの概要
BPWExecuteLogic | 外部プログラム実行抽象クラス。
ConditionAdapter | 外部プログラム実行抽象クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.bpw.model.data クラス階層 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.model.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic
    • class jp.co.intra_mart.foundation.bpw.model.data.Condition
      • class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter

インタフェース階層

  • interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.foundation.bpw.model.data の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.bpw.model.data の使用

jp.co.intra_mart.foundation.bpw.model.data はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の使用

ActivityInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.object

jp.co.intra_mart.foundation.bpw.model.object での ActivityInfoModel の使用

ActivityInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のコンストラクタ
RunUserInfoModel(ActivityInfoModel src)
RunExecutiveInfoModel(ActivityInfoModel src)
RecognitionInfoModel(ActivityInfoModel src)
ConditionModel(ActivityInfoModel src)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.object.ConditionModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.ConditionModel の使用

ConditionModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.data

jp.co.intra_mart.foundation.bpw.model.data での ConditionModel の使用

ConditionModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.data のコンストラクタ
ConditionAdapter(ConditionModel model)
コンストラクタ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel の使用

ProcessInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.bpw.model.object での ProcessInfoModel の使用

ProcessInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のコンストラクタ
RunUserInfoModel(ProcessInfoModel src)
RecognitionInfoModel(ProcessInfoModel src)

jp.co.intra_mart.foundation.wkf での ProcessInfoModel の使用

ProcessInfoModel を返す jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
ProcessInfoModel | Drafter.draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の使用

jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の使用

RunExecutiveInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.bpw.model.object での RunExecutiveInfoModel の使用

RunExecutiveInfoModel を返す jp.co.intra_mart.foundation.bpw.model.object のメソッド
 RunExecutiveInfoModel RecognitionInfoModel.getRunExecuteInfoModel()
実行主体ユーザマスタ情報を返却します。

RunExecutiveInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のメソッド
 void RecognitionInfoModel.setRunExecuteInfoModel(RunExecutiveInfoModel model)
実行時選択時実行主体役職マスタテーブルを設定します。

RunExecutiveInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のコンストラクタ
RunExecutiveInfoModel(RunExecutiveInfoModel src)

jp.co.intra_mart.foundation.wkf での RunExecutiveInfoModel の使用

RunExecutiveInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
void | Drafter.retry(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 再起票処理を実行します。
void | Drafter.subProcessDraft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.Boolean isFinish, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd) 承認処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の使用

RunUserInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.bpw.model.object での RunUserInfoModel の使用

RunUserInfoModel を返す jp.co.intra_mart.foundation.bpw.model.object のメソッド
 RunUserInfoModel RecognitionInfoModel.getRunUserInfoModel()
実行主体役職マスタ情報を返却します。

RunUserInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のメソッド
void | RecognitionInfoModel.setRunUserInfoModel(RunUserInfoModel model) 実行時選択時実行主体ユーザマスタ情報を設定します。
void | ActivityInfoModel.addRunuserlist(RunUserInfoModel model) 実行主体ユーザリスト情報に新たに実行主体ユーザ情報を追加します。

RunUserInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のコンストラクタ
RunUserInfoModel(RunUserInfoModel src)

jp.co.intra_mart.foundation.wkf での RunUserInfoModel の使用

RunUserInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
void | Drafter.retry(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 再起票処理を実行します。
void | Drafter.subProcessDraft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.Boolean isFinish, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd) 承認処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の使用

jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.bpw.model.object.WfeUserInfoModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.WfeUserInfoModel の使用

jp.co.intra_mart.foundation.bpw.model.object.WfeUserInfoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ActivityInfoModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス ActivityInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel
すべての実装インタフェース:
jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable, java.io.Serializable
public class ActivityInfoModel
extends java.lang.Object
implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable, java.io.Serializable

アクティビティ情報を保持するクラス
アクティビティ情報を保持します。

関連項目:
直列化された形式

フィールドの概要
static java.lang.String | END_TASK_OFF 非終了タスク
static java.lang.String | END_TASK_ON 終了タスク
static java.lang.String | PROCESSING_COMPLETED 【共通】完了
static java.lang.String | PROCESSING_NORMALL 【本人・代理設定なし】通常(通常到達にて活性化)
static java.lang.String | PROCESSING_PSN_NORMALL 【代理設定有り・本人決済可】通常(通常到達にて活性化)
static java.lang.String | PROCESSING_PSN_PULL_BACK 【代理設定有り・本人決済可】引戻し(引戻しにて活性化)
static java.lang.String | PROCESSING_PSN_PULL_SUSPEND 【代理設定有り・本人決済可】引戻し(引戻しにて活性化後の保留)
static java.lang.String | PROCESSING_PSN_SEND_BACK 【代理設定有り・本人決済可】差戻し(差戻しにて活性化)
static java.lang.String | PROCESSING_PSN_SEND_SUSPEND 【代理設定有り・本人決済可】差戻し(差戻しにて活性化後の保留)
static java.lang.String | PROCESSING_PSN_SUSPEND 【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)
static java.lang.String | PROCESSING_PULL_BACK 【本人・代理設定なし】引戻し(引戻しにて活性化)
static java.lang.String | PROCESSING_PULL_SUSPEND 【本人・代理設定なし】引戻し(引戻しにて活性化後の保留)
static java.lang.String | PROCESSING_SEND_BACK 【本人・代理設定なし】差戻し(差戻しにて活性化)
static java.lang.String | PROCESSING_SEND_SUSPEND 【本人・代理設定なし】差戻し(差戻しにて活性化後の保留)
static java.lang.String | PROCESSING_SUB_NORMALL 【代理設定有り・本人決不可】通常(通常到達にて活性化)
static java.lang.String | PROCESSING_SUB_PULL_BACK 【代理設定有り・本人決不可】引戻し(引戻しにて活性化)
static java.lang.String | PROCESSING_SUB_PULL_SUSPEND 【代理設定有り・本人決不可】引戻し(引戻しにて活性化後の保留)
static java.lang.String | PROCESSING_SUB_SEND_BACK 【代理設定有り・本人決不可】差戻し(差戻しにて活性化)
static java.lang.String | PROCESSING_SUB_SEND_SUSPEND 【代理設定有り・本人決不可】差戻し(差戻しにて活性化後の保留)
static java.lang.String | PROCESSING_SUB_SUSPEND 【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)
static java.lang.String | PROCESSING_SUSPEND 【本人・代理設定なし】通常(通常到達にて活性化後の保留)
static java.lang.String | PULL_ACTIVITY_OFF 引き戻し不可
static java.lang.String | PULL_ACTIVITY_ON 引き戻し可
static java.lang.String | REFER_ALL 参照者若しくは承認者として関連図けられたアクティビティ
static java.lang.String | REFER_NONE 参照者・承認者を考慮しない
static java.lang.String | REFER_READ 参照者として関連図けられたアクティビティ
static java.lang.String | REFER_RECOGNITION 承認者として関連図けられたアクティビティ
static java.lang.String | RETURN_ACTIVITY_OFF 差し戻し不可
static java.lang.String | RETURN_ACTIVITY_ON 差し戻し可
static java.lang.String | RETURN_MAIL_OFF 差し戻しメール送信なし
static java.lang.String | RETURN_MAIL_ON 差し戻しメール送信あり
static java.lang.String | RUN_AUTH_ALL 処理権限・代理権限供にあるアクティビティ
static java.lang.String | RUN_AUTH_NOT 処理権限がないアクティビティ
static java.lang.String | RUN_AUTH_RUN 処理権限があるアクティビティ
static java.lang.String | RUN_AUTH_TRANSFER 代理処理権限があるアクティビティ
static java.lang.String | RUN_SELECT_OFF 実行時選択OFF
static java.lang.String | RUN_SELECT_ON 実行時選択ON
static java.lang.String | TRANSFER_OFF 代理承認者なし
static java.lang.String | TRANSFER_ON 代理承認者あり
コンストラクタの概要
ActivityInfoModel()
コンストラクタ
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.DelegateUserInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.EditTransferTableInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.SwitchInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel src)
メソッドの概要
void | addAutopasslist(jp.co.intra_mart.foundation.bpw.model.object.AutoPassInfoModel model) 自動パスリスト情報に新たに自動パス情報を追加します。
void | addReceivelist(jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableInfoModel model) レシーブリスト情報に新たにレシーブ情報を追加します。
void | addRunuserlist(RunUserInfoModel model) 実行主体ユーザリスト情報に新たに実行主体ユーザ情報を追加します。
void | addUserAppliKey(int i, jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model) 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
java.lang.Object | clone() クローン
static java.lang.String | convertEndTaskFlag(java.lang.String shortestEndFlg) 最短終了タスク値を最終タスクフラグに変換します。
java.lang.String | getActivityCd() アクティビティコードを返却します。
java.lang.String | getActivityName() アクティビティ名を返却します。
java.lang.String | getActivityStatus() アクティビティステータスを返却します。
java.lang.String | getActivityType() アクティビティ種別を返却します。
java.lang.String | getAttainmentClass() 到達種別を返却します。
java.lang.String | getAutoPassFlag() 自動パス処理フラグを返却します。
java.util.List | getAutoPasslist() 自動パスのリスト情報を返却します。
java.lang.String | getAutoPassTerm() 自動パス期限を返却します。
java.lang.String | getBefActiCd() 前処理アクティビティ名を返却します。
java.lang.String | getBefActiName() 前処理アクティビティ名を返却します。
java.lang.String | getBefActiUserCd() 前処理者CDを返却します。
java.lang.String | getBefActiUserName() 前処理者名を返却します。
java.lang.String | getCallActivityCd() 呼出アクティビティコードを返却します。
java.lang.String | getCallActivityType() 呼出アクティビティ種別を返却します。
java.lang.String | getCompulsionEndFlag() 強制終了可否フラグを返却します。
java.lang.String | getEndTaskFlag() 終了タスクフラグを返却します。
java.lang.String | getLoginGroupID() ログイングループIDを返却します。
java.lang.String | getLoginUserID() ログインユーザIDを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
java.lang.String | getPreActivityCd() 処理契機アクティビティコードを返却します。
java.lang.String | getPreProcessCd() 処理契機プロセスコードを返却します。
java.lang.String | getPreProcessDefCd() 処理契機プロセス定義コードを返却します。
java.lang.String | getPresentProcess() 現処理を返却します。
java.lang.String | getPreVersionCd() 処理契機履歴コードを返却します。
java.lang.String | getProcessCd() プロセスコードを返却します。
java.lang.String | getProcessDefCd() プロセス定義コードを返却します。
java.lang.String | getProcessTermDate() 処理期限日付を返却します。
java.util.List | getReceivelist() レシーブのリスト情報を返却します。
java.lang.String | getReceptionDate() 受信日付を返却します。
java.lang.String | getResultNoticeFlag() 結果通知フラグを返却します。
java.lang.String | getReturnFlag() 引戻し・差戻しフラグを返却します。
java.lang.String | getReturnMailFlag() 引戻し・差戻しメール送信フラグを返却します。
java.lang.String | getRunSelectFlg() 実行時選択フラグを返却します。
java.util.List | getRunuserlist() 実行主体ユーザのリスト情報を返却します。
java.lang.String | getSelectRouteNo() 選択ルート番号を返却します。
java.lang.String | getStatusEndedDate() ステータス完了日付を返却します。
jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel | getUserAppliKey(int i) 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を 返却します。
java.util.Map | getUserApplikeyList() ユーザアプリケーションキーテーブル情報リストを返却します。
java.lang.String | getVersionCd() 履歴コードを返却します。
void | setActivityCd(java.lang.String string) アクティビティコードを設定します。
void | setActivityName(java.lang.String string) アクティビティ名を設定します。
void | setActivityStatus(java.lang.String string) アクティビティステータスを設定します。
void | setActivityType(java.lang.String string) アクティビティ種別を設定します。
void | setAttainmentClass(java.lang.String string) 到達種別を設定します。
void | setAutoPassFlag(java.lang.String string) 自動パス処理フラグを設定します。
void | setAutoPassTerm(java.lang.String string) 自動パス期限を設定します。
void | setBefActiCd(java.lang.String string) 前処理アクティビティコードを設定します。
void | setBefActiName(java.lang.String string) 前処理アクティビティ名を設定します。
void | setBefActiUserCd(java.lang.String string) 前処理者CDを設定します。
void | setBefActiUserName(java.lang.String string) 前処理者名を設定します。
void | setCallActivityCd(java.lang.String string) 呼出アクティビティコードを設定します。
void | setCallActivityType(java.lang.String string) 呼出アクティビティ種別を設定します。
void | setCompulsionEndFlag(java.lang.String string) 強制終了可否フラグを設定します。
void | setEndTaskFlag(java.lang.String string) 終了タスクフラグを設定します。
void | setLoginGroupID(java.lang.String string) ログイングループIDを設定します。
void | setLoginUserID(java.lang.String string) ログインユーザIDを設定します。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info) ログイン情報を設定します。
void | setPreActivityCd(java.lang.String string) 処理契機アクティビティコードを設定します。
void | setPreProcessCd(java.lang.String string) 処理契機プロセスコードを設定します。
void | setPreProcessDefCd(java.lang.String string) 処理契機プロセス定義コードを設定します。
void | setPresentProcess(java.lang.String string) 現処理を設定します。
void | setPreVersionCd(java.lang.String string) 処理契機履歴コードを設定します。
void | setProcessCd(java.lang.String string) 検索条件とするプロセスコードを設定します。
void | setProcessDefCd(java.lang.String string) 検索条件とするプロセス定義コードを設定します。
void | setProcessTermDate(java.lang.String string) 検索条件とするプロセスコードを設定します。
void | setReceptionDate(java.lang.String string) 受信日付をを設定します。
void | setResultNoticeFlag(java.lang.String string) 結果通知フラグを設定します。
void | setReturnFlag(java.lang.String string) 引戻し・差戻しフラグを設定します。
void | setReturnMailFlag(java.lang.String string) 引戻し・差戻しメール送信フラグ設定します。
void | setRunSelectFlg(java.lang.String string) 実行時選択フラグを設定します。
void | setSelectRouteNo(java.lang.String string) 選択ルート番を設定します。
void | setStatusEndedDate(java.lang.String string) ステータス完了日付を設定します。
void | setVersionCd(java.lang.String string) 検索条件とする履歴コードを設定します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REFER_ALL

public static final java.lang.String REFER_ALL
参照者若しくは承認者として関連図けられたアクティビティ

関連項目:
定数フィールド値

REFER_READ

public static final java.lang.String REFER_READ
参照者として関連図けられたアクティビティ

関連項目:
定数フィールド値

REFER_RECOGNITION

public static final java.lang.String REFER_RECOGNITION
承認者として関連図けられたアクティビティ

関連項目:
定数フィールド値

REFER_NONE

public static final java.lang.String REFER_NONE
参照者・承認者を考慮しない

関連項目:
定数フィールド値

RUN_AUTH_NOT

public static final java.lang.String RUN_AUTH_NOT
処理権限がないアクティビティ

関連項目:
定数フィールド値

RUN_AUTH_RUN

public static final java.lang.String RUN_AUTH_RUN
処理権限があるアクティビティ

関連項目:
定数フィールド値

RUN_AUTH_TRANSFER

public static final java.lang.String RUN_AUTH_TRANSFER
代理処理権限があるアクティビティ

関連項目:
定数フィールド値

RUN_AUTH_ALL

public static final java.lang.String RUN_AUTH_ALL
処理権限・代理権限供にあるアクティビティ

関連項目:
定数フィールド値

RUN_SELECT_ON

public static final java.lang.String RUN_SELECT_ON
実行時選択ON

関連項目:
定数フィールド値

RUN_SELECT_OFF

public static final java.lang.String RUN_SELECT_OFF
実行時選択OFF

関連項目:
定数フィールド値

TRANSFER_ON

public static final java.lang.String TRANSFER_ON
代理承認者あり

関連項目:
定数フィールド値

TRANSFER_OFF

public static final java.lang.String TRANSFER_OFF
代理承認者なし

関連項目:
定数フィールド値

PULL_ACTIVITY_ON

public static final java.lang.String PULL_ACTIVITY_ON
引き戻し可

関連項目:
定数フィールド値

PULL_ACTIVITY_OFF

public static final java.lang.String PULL_ACTIVITY_OFF
引き戻し不可

関連項目:
定数フィールド値

RETURN_ACTIVITY_ON

public static final java.lang.String RETURN_ACTIVITY_ON
差し戻し可

関連項目:
定数フィールド値

RETURN_ACTIVITY_OFF

public static final java.lang.String RETURN_ACTIVITY_OFF
差し戻し不可

関連項目:
定数フィールド値

RETURN_MAIL_ON

public static final java.lang.String RETURN_MAIL_ON
差し戻しメール送信あり

関連項目:
定数フィールド値

RETURN_MAIL_OFF

public static final java.lang.String RETURN_MAIL_OFF
差し戻しメール送信なし

関連項目:
定数フィールド値

END_TASK_ON

public static final java.lang.String END_TASK_ON
終了タスク

関連項目:
定数フィールド値

END_TASK_OFF

public static final java.lang.String END_TASK_OFF
非終了タスク

関連項目:
定数フィールド値

PROCESSING_NORMALL

public static final java.lang.String PROCESSING_NORMALL
【本人・代理設定なし】通常(通常到達にて活性化)

関連項目:
定数フィールド値

PROCESSING_PULL_BACK

public static final java.lang.String PROCESSING_PULL_BACK
【本人・代理設定なし】引戻し(引戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_SEND_BACK

public static final java.lang.String PROCESSING_SEND_BACK
【本人・代理設定なし】差戻し(差戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_SUSPEND

public static final java.lang.String PROCESSING_SUSPEND
【本人・代理設定なし】通常(通常到達にて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_PULL_SUSPEND

public static final java.lang.String PROCESSING_PULL_SUSPEND
【本人・代理設定なし】引戻し(引戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_SEND_SUSPEND

public static final java.lang.String PROCESSING_SEND_SUSPEND
【本人・代理設定なし】差戻し(差戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_PSN_NORMALL

public static final java.lang.String PROCESSING_PSN_NORMALL
【代理設定有り・本人決済可】通常(通常到達にて活性化)

関連項目:
定数フィールド値

PROCESSING_PSN_PULL_BACK

public static final java.lang.String PROCESSING_PSN_PULL_BACK
【代理設定有り・本人決済可】引戻し(引戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_PSN_SEND_BACK

public static final java.lang.String PROCESSING_PSN_SEND_BACK
【代理設定有り・本人決済可】差戻し(差戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_PSN_SUSPEND

public static final java.lang.String PROCESSING_PSN_SUSPEND
【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_PSN_PULL_SUSPEND

public static final java.lang.String PROCESSING_PSN_PULL_SUSPEND
【代理設定有り・本人決済可】引戻し(引戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_PSN_SEND_SUSPEND

public static final java.lang.String PROCESSING_PSN_SEND_SUSPEND
【代理設定有り・本人決済可】差戻し(差戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_SUB_NORMALL

public static final java.lang.String PROCESSING_SUB_NORMALL
【代理設定有り・本人決不可】通常(通常到達にて活性化)

関連項目:
定数フィールド値

PROCESSING_SUB_PULL_BACK

public static final java.lang.String PROCESSING_SUB_PULL_BACK
【代理設定有り・本人決不可】引戻し(引戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_SUB_SEND_BACK

public static final java.lang.String PROCESSING_SUB_SEND_BACK
【代理設定有り・本人決不可】差戻し(差戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_SUB_SUSPEND

public static final java.lang.String PROCESSING_SUB_SUSPEND
【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_SUB_PULL_SUSPEND

public static final java.lang.String PROCESSING_SUB_PULL_SUSPEND
【代理設定有り・本人決不可】引戻し(引戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_SUB_SEND_SUSPEND

public static final java.lang.String PROCESSING_SUB_SEND_SUSPEND
【代理設定有り・本人決不可】差戻し(差戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_COMPLETED

public static final java.lang.String PROCESSING_COMPLETED
【共通】完了

関連項目:
定数フィールド値
コンストラクタの詳細

ActivityInfoModel

public ActivityInfoModel()
コンストラクタ

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.SwitchInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.EditTransferTableInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.DelegateUserInfoModel src)
メソッドの詳細

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
クローン

例外:
java.lang.CloneNotSupportedException

getProcessDefCd

public java.lang.String getProcessDefCd()
プロセス定義コードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス定義コード

getVersionCd

public java.lang.String getVersionCd()
履歴コードを返却します。 システムで利用されるメソッドです。

戻り値:
履歴コード

getProcessCd

public java.lang.String getProcessCd()
プロセスコードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセスコード

getActivityCd

public java.lang.String getActivityCd()
アクティビティコードを返却します。 システムで利用されるメソッドです。

戻り値:
アクティビティコード

getActivityName

public java.lang.String getActivityName()
アクティビティ名を返却します。 システムで利用されるメソッドです。

戻り値:
アクティビティ名

getActivityType

public java.lang.String getActivityType()
アクティビティ種別を返却します。 システムで利用されるメソッドです。

戻り値:
アクティビティ種別

getActivityStatus

public java.lang.String getActivityStatus()
アクティビティステータスを返却します。 システムで利用されるメソッドです。

戻り値:
アクティビティステータス

getStatusEndedDate

public java.lang.String getStatusEndedDate()
ステータス完了日付を返却します。 システムで利用されるメソッドです。

戻り値:
ステータス完了日付

getCallActivityCd

public java.lang.String getCallActivityCd()
呼出アクティビティコードを返却します。 システムで利用されるメソッドです。

戻り値:
呼出アクティビティコード

getCallActivityType

public java.lang.String getCallActivityType()
呼出アクティビティ種別を返却します。 システムで利用されるメソッドです。

戻り値:
呼出アクティビティ種別

getResultNoticeFlag

public java.lang.String getResultNoticeFlag()
結果通知フラグを返却します。

戻り値:
結果通知フラグ
関連項目:
通知する, 通知しない

getAutoPassTerm

public java.lang.String getAutoPassTerm()
自動パス期限を返却します。 システムで利用されるメソッドです。

戻り値:
自動パス期限

getAutoPassFlag

public java.lang.String getAutoPassFlag()
自動パス処理フラグを返却します。 システムで利用されるメソッドです。

戻り値:
自動パス処理フラグ

getAttainmentClass

public java.lang.String getAttainmentClass()
到達種別を返却します。

戻り値:
到達種別

getReceptionDate

public java.lang.String getReceptionDate()
受信日付を返却します。 システムで利用されるメソッドです。

戻り値:
受信日付

getProcessTermDate

public java.lang.String getProcessTermDate()
処理期限日付を返却します。

戻り値:
処理期限日付

getPresentProcess

public java.lang.String getPresentProcess()
現処理を返却します。

戻り値:
現処理

getBefActiCd

public java.lang.String getBefActiCd()
前処理アクティビティ名を返却します。

戻り値:
前処理アクティビティ名

getBefActiName

public java.lang.String getBefActiName()
前処理アクティビティ名を返却します。

戻り値:
前処理アクティビティ名

getBefActiUserCd

public java.lang.String getBefActiUserCd()
前処理者CDを返却します。

戻り値:
前処理者CD

getBefActiUserName

public java.lang.String getBefActiUserName()
前処理者名を返却します。

戻り値:
前処理者名

getCompulsionEndFlag

public java.lang.String getCompulsionEndFlag()
強制終了可否フラグを返却します。

戻り値:
強制終了可否フラグ
関連項目:
強制終了：可, 強制終了：不可

getReturnMailFlag

public java.lang.String getReturnMailFlag()
引戻し・差戻しメール送信フラグを返却します。

戻り値:
引戻し・差戻しメール送信フラグ

getReturnFlag

public java.lang.String getReturnFlag()
引戻し・差戻しフラグを返却します。

戻り値:
引戻し・差戻しフラグ

getPreProcessDefCd

public java.lang.String getPreProcessDefCd()
処理契機プロセス定義コードを返却します。

戻り値:
処理契機プロセス定義コード

getPreVersionCd

public java.lang.String getPreVersionCd()
処理契機履歴コードを返却します。

戻り値:
処理契機履歴コード

getPreProcessCd

public java.lang.String getPreProcessCd()
処理契機プロセスコードを返却します。

戻り値:
処理契機プロセスコード

getPreActivityCd

public java.lang.String getPreActivityCd()
処理契機アクティビティコードを返却します。

戻り値:
処理契機アクティビティコード

getEndTaskFlag

public java.lang.String getEndTaskFlag()
終了タスクフラグを返却します。

戻り値:
終了タスクフラグ

getSelectRouteNo

public java.lang.String getSelectRouteNo()
選択ルート番号を返却します。

戻り値:
選択ルート番号

getRunuserlist

public java.util.List getRunuserlist()
実行主体ユーザのリスト情報を返却します。 システムで利用されるメソッドです。

戻り値:
実行主体ユーザのリスト情報

getReceivelist

public java.util.List getReceivelist()
レシーブのリスト情報を返却します。 システムで利用されるメソッドです。

戻り値:
レシーブのリスト情報

getAutoPasslist

public java.util.List getAutoPasslist()
自動パスのリスト情報を返却します。 システムで利用されるメソッドです。

戻り値:
自動パスのリスト情報

getRunSelectFlg

public java.lang.String getRunSelectFlg()
実行時選択フラグを返却します。

戻り値:
実行時選択フラグ
関連項目:
実行時選択ON, 実行時選択OFF

getUserAppliKey

public jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel getUserAppliKey(int i)
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を 返却します。

パラメータ:
i - パラメータ番号
戻り値:
ユーザアプリケーションキーテーブル情報

getUserApplikeyList

public java.util.Map getUserApplikeyList()
ユーザアプリケーションキーテーブル情報リストを返却します。

戻り値:
ユーザアプリケーションキーテーブル情報リスト

setProcessDefCd

public void setProcessDefCd(java.lang.String string)
検索条件とするプロセス定義コードを設定します。

パラメータ:
string - 検索値

setVersionCd

public void setVersionCd(java.lang.String string)
検索条件とする履歴コードを設定します。

パラメータ:
string - 検索値

setProcessCd

public void setProcessCd(java.lang.String string)
検索条件とするプロセスコードを設定します。

パラメータ:
string - 検索値

setActivityCd

public void setActivityCd(java.lang.String string)
アクティビティコードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - アクティビティコード

setActivityName

public void setActivityName(java.lang.String string)
アクティビティ名を設定します。

パラメータ:
string - アクティビティ名

setActivityType

public void setActivityType(java.lang.String string)
アクティビティ種別を設定します。 システムで利用されるメソッドです。

パラメータ:
string - アクティビティ種別

setActivityStatus

public void setActivityStatus(java.lang.String string)
アクティビティステータスを設定します。

パラメータ:
string - アクティビティステータス

setStatusEndedDate

public void setStatusEndedDate(java.lang.String string)
ステータス完了日付を設定します。 システムで利用されるメソッドです。

パラメータ:
string - ステータス完了日付

setCallActivityCd

public void setCallActivityCd(java.lang.String string)
呼出アクティビティコードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 呼出アクティビティコード

setCallActivityType

public void setCallActivityType(java.lang.String string)
呼出アクティビティ種別を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 呼出アクティビティ種別

setResultNoticeFlag

public void setResultNoticeFlag(java.lang.String string)
結果通知フラグを設定します。

パラメータ:
string - 結果通知フラグ
関連項目:
通知する, 通知しない

setAutoPassTerm

public void setAutoPassTerm(java.lang.String string)
自動パス期限を設定します。

パラメータ:
string - 自動パス期限

setAutoPassFlag

public void setAutoPassFlag(java.lang.String string)
自動パス処理フラグを設定します。

パラメータ:
string - 自動パス処理フラグ

setAttainmentClass

public void setAttainmentClass(java.lang.String string)
到達種別を設定します。

パラメータ:
string - 到達種別

setReceptionDate

public void setReceptionDate(java.lang.String string)
受信日付をを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 受信日付

setProcessTermDate

public void setProcessTermDate(java.lang.String string)
検索条件とするプロセスコードを設定します。

パラメータ:
string - 処理期限日付

setPresentProcess

public void setPresentProcess(java.lang.String string)
現処理を設定します。

パラメータ:
string - 現処理

setBefActiCd

public void setBefActiCd(java.lang.String string)
前処理アクティビティコードを設定します。

パラメータ:
string - 前処理アクティビティコード

setBefActiName

public void setBefActiName(java.lang.String string)
前処理アクティビティ名を設定します。

パラメータ:
string - 前処理アクティビティ名

setBefActiUserCd

public void setBefActiUserCd(java.lang.String string)
前処理者CDを設定します。

パラメータ:
string - 前処理者CD

setBefActiUserName

public void setBefActiUserName(java.lang.String string)
前処理者名を設定します。

パラメータ:
string - 前処理者名

setCompulsionEndFlag

public void setCompulsionEndFlag(java.lang.String string)
強制終了可否フラグを設定します。

パラメータ:
string - 強制終了可否フラグ

setReturnMailFlag

public void setReturnMailFlag(java.lang.String string)
引戻し・差戻しメール送信フラグ設定します。

パラメータ:
string - 引戻し・差戻しメール送信フラグ
関連項目:
差し戻しメール送信あり, 差し戻しメール送信なし

setReturnFlag

public void setReturnFlag(java.lang.String string)
引戻し・差戻しフラグを設定します。

パラメータ:
string - 引戻し・差戻しフラグ
関連項目:
差し戻し可, 差し戻し不可

setPreProcessDefCd

public void setPreProcessDefCd(java.lang.String string)
処理契機プロセス定義コードを設定します。

パラメータ:
string - 処理契機プロセス定義コード

setPreVersionCd

public void setPreVersionCd(java.lang.String string)
処理契機履歴コードを設定します。

パラメータ:
string - 処理契機履歴コード

setPreProcessCd

public void setPreProcessCd(java.lang.String string)
処理契機プロセスコードを設定します。

パラメータ:
string - 処理契機プロセスコード

setPreActivityCd

public void setPreActivityCd(java.lang.String string)
処理契機アクティビティコードを設定します。

パラメータ:
string - 処理契機アクティビティコード

setEndTaskFlag

public void setEndTaskFlag(java.lang.String string)
終了タスクフラグを設定します。

パラメータ:
string - 終了タスクフラグ

setSelectRouteNo

public void setSelectRouteNo(java.lang.String string)
選択ルート番を設定します。

パラメータ:
string - 選択ルート番

addRunuserlist

public void addRunuserlist(RunUserInfoModel model)
実行主体ユーザリスト情報に新たに実行主体ユーザ情報を追加します。

パラメータ:
model - 実行主体ユーザ情報

addReceivelist

public void addReceivelist(jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableInfoModel model)
レシーブリスト情報に新たにレシーブ情報を追加します。

パラメータ:
model - レシーブ情報

addAutopasslist

public void addAutopasslist(jp.co.intra_mart.foundation.bpw.model.object.AutoPassInfoModel model)
自動パスリスト情報に新たに自動パス情報を追加します。

パラメータ:
model - 自動パス情報

setRunSelectFlg

public void setRunSelectFlg(java.lang.String string)
実行時選択フラグを設定します。

パラメータ:
string -
関連項目:
実行時選択ON, 実行時選択OFF

addUserAppliKey

public void addUserAppliKey(int i,
                            jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model)
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。

パラメータ:
i - パラメータ番号
model - ユーザアプリケーションキーテーブル情報

convertEndTaskFlag

public static java.lang.String convertEndTaskFlag(java.lang.String shortestEndFlg)
最短終了タスク値を最終タスクフラグに変換します。

パラメータ:
shortestEndFlg - 最終タスクフラグ値

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。 システムで利用されるメソッドです。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserInfo
戻り値:
ログインユーザ情報

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info)
ログイン情報を設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserInfo
パラメータ:
info - ログインユーザ情報

setLoginUserID

public void setLoginUserID(java.lang.String string)
ログインユーザIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserID
パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(java.lang.String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginGroupID
パラメータ:
string - ログイングループID

getLoginUserID

public java.lang.String getLoginUserID()
ログインユーザIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserID
戻り値:
ログインユーザID

getLoginGroupID

public java.lang.String getLoginGroupID()
ログイングループIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginGroupID
戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ConditionModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス ConditionModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ExternalModel
        拡張 jp.co.intra_mart.foundation.bpw.model.object.ConditionModel
public class ConditionModel
extends jp.co.intra_mart.foundation.bpw.model.object.ExternalModel

外部条件クラス（条件分岐, 結合条件)用、パラメータクラス ワークフロー上で条件分岐、結合条件で指定した外部プログラム内で実装する事により、
ログインユーザ情報が取得できます。

コンストラクタの概要
ConditionModel()
コンストラクタ
ConditionModel(ActivityInfoModel src)
メソッドの概要
java.util.Locale | getLocale() ロケールを返却します。
java.lang.String | getLoginGroupId() ログイングループＩＤを返却します。
java.lang.String | getLoginUserId() ログインユーザＩＤを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
void | setLoginGroupID(java.lang.String string) ログイングループIDを設定します。
void | setLoginUserID(java.lang.String string) ログインユーザIDを設定します。
クラス jp.co.intra_mart.foundation.bpw.model.object.ExternalModel から継承したメソッド
getActivityCd, getActivityName, getActivityStatus, getActivityType, getAttainmentClass, getAutoPassFlag, getAutoPassTerm, getBefActiCd, getBefActiName, getBefActiUserCd, getBefActiUserName, getCallActivityCd, getCallActivityType, getPresentProcess, getProcessCd, getProcessDefCd, getProcessTermDate, getReceptionDate, getResultNoticeFlag, getStatusEndedDate, getVersionCd, setActivityCd, setActivityName, setActivityStatus, setActivityType, setAttainmentClass, setAutoPassFlag, setAutoPassTerm, setBefActiCd, setBefActiName, setBefActiUserCd, setBefActiUserName, setCallActivityCd, setCallActivityType, setPresentProcess, setProcessCd, setProcessDefCd, setProcessTermDate, setReceptionDate, setResultNoticeFlag, setStatusEndedDate, setVersionCd
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConditionModel

public ConditionModel()
コンストラクタ

ConditionModel

public ConditionModel(ActivityInfoModel src)
メソッドの詳細

getLoginUserId

public java.lang.String getLoginUserId()
ログインユーザＩＤを返却します。

戻り値:
ログインユーザＩＤ

getLoginGroupId

public java.lang.String getLoginGroupId()
ログイングループＩＤを返却します。

戻り値:
ログイングループＩＤ

getLocale

public java.util.Locale getLocale()
ロケールを返却します。

戻り値:
ロケール

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。

戻り値:
ログインユーザ情報

setLoginUserID

public void setLoginUserID(java.lang.String string)
ログインユーザIDを設定します。

パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(java.lang.String string)
ログイングループIDを設定します。

パラメータ:
string - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.bpw.model.object (intra-mart ワークフロー)

 jp.co.intra_mart.foundation.bpw.model.object
クラス
ActivityInfoModel
ConditionModel
ProcessInfoModel
RecognitionInfoModel
RunExecutiveInfoModel
RunUserInfoModel
VersionInfoModel


jp.co.intra_mart.foundation.bpw.model.object (intra-mart ワークフロー)

ワークフローモジュール
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.model.object

クラスの概要
ActivityInfoModel | アクティビティ情報を保持するクラス アクティビティ情報を保持します。
ConditionModel | 外部条件クラス（条件分岐, 結合条件)用、パラメータクラス ワークフロー上で条件分岐、結合条件で指定した外部プログラム内で実装する事により、 ログインユーザ情報が取得できます。
ProcessInfoModel | プロセス情報を保持する情報クラス
RecognitionInfoModel | 処理要求時情報モデル。
RunExecutiveInfoModel | 実行主体役職マスタの情報保持クラス 次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。
RunUserInfoModel | 実行主体ユーザ情報を保持する情報クラス
VersionInfoModel | 履歴情報を保持する情報クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.bpw.model.object クラス階層 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.model.object の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel
      • class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.io.Serializable)
    • class jp.co.intra_mart.foundation.bpw.model.object.ExternalModel
      • class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel
    • class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable)
    • class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel
    • class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.foundation.bpw.model.object の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.bpw.model.object の使用

jp.co.intra_mart.foundation.bpw.model.object を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.data
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.bpw.model.data により使用される jp.co.intra_mart.foundation.bpw.model.object のクラス
ConditionModel
外部条件クラス（条件分岐, 結合条件)用、パラメータクラス ワークフロー上で条件分岐、結合条件で指定した外部プログラム内で実装する事により、
ログインユーザ情報が取得できます。

jp.co.intra_mart.foundation.bpw.model.object により使用される jp.co.intra_mart.foundation.bpw.model.object のクラス
ActivityInfoModel
アクティビティ情報を保持するクラス
アクティビティ情報を保持します。
ProcessInfoModel
プロセス情報を保持する情報クラス
RunExecutiveInfoModel
実行主体役職マスタの情報保持クラス
次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。
RunUserInfoModel
実行主体ユーザ情報を保持する情報クラス

jp.co.intra_mart.foundation.wkf により使用される jp.co.intra_mart.foundation.bpw.model.object のクラス
ProcessInfoModel
プロセス情報を保持する情報クラス
RunExecutiveInfoModel
実行主体役職マスタの情報保持クラス
次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。
RunUserInfoModel
実行主体ユーザ情報を保持する情報クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


ProcessInfoModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス ProcessInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel
すべての実装インタフェース:
jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable
public class ProcessInfoModel
extends java.lang.Object
implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable

プロセス情報を保持する情報クラス

フィールドの概要
static java.lang.String | TRANSFER_OFF 申請者(申請者)
static java.lang.String | TRANSFER_ON 申請者(代理申請者)
コンストラクタの概要
ProcessInfoModel()
コンストラクタ
メソッドの概要
void | addUserAppliKey(int i, jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model) 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
java.lang.Object | clone() クローン
java.lang.String | getCallProcessCd() 呼出プロセスコードを返却します。
java.lang.String | getCallProcessDefCd() 呼び出しプロセス定義コードを返却します。
java.lang.String | getCallVersionCd() 呼び出し履歴コードを返却します。
java.lang.String | getCodeValue() コード値を返却します。
java.lang.String | getCompanyCd() 会社コードを返却します。
java.lang.Object | getConvertLong(java.lang.String string) 数値型変換後に返却します。
java.lang.String | getCreateDate() 作成日時を返却します。
java.lang.String | getCreateUserCd() 作成者コードを返却します。
java.lang.String | getCreateUserName() 作成者名を返却します。
java.lang.String | getDraftComment() 起票時コメントを返却します。
java.lang.String | getDraftDate() 起票日を返却します。
java.lang.String | getDraftUserCd() 起票者コードを返却します。
java.lang.String | getDraftUserName() 起票者名を返却します。
java.lang.String | getExtensionA() 拡張エリアＡを返却します。
java.lang.String | getExtensionB() 拡張エリアＢを返却します。
java.lang.String | getExtensionC() 拡張エリアＣを返却します。
java.lang.String | getExtensionD() 拡張エリアＤを返却します。
java.lang.String | getExtensionE() 拡張エリアＥを返却します。
java.lang.String | getExtensionF() 拡張エリアＦを返却します。
java.lang.String | getExtensionG() 拡張エリアＧを返却します。
java.lang.String | getExtensionH() 拡張エリアＨを返却します。
java.lang.String | getGroupName() グループ名を返却します。
java.lang.String | getLastManualActivityCd() 最終手動処理コードを返却します。
java.lang.String | getLastManualActivityResult() 最終手動アクティビティ承認結果種別を返却します。
java.lang.String | getLocaleId() 処理者ロケールIDを返却します。
java.lang.String | getLoginGroupID() ログイングループIDを返却します。
java.lang.String | getLoginUserID() ログインユーザIDを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
java.lang.String | getParallelNestCnt() 同期処理階層カウンタを返却します。
java.lang.String | getPresentDisplayInfo() 現処理表示情報を返却します。
java.lang.String | getProcessCallActivityCd() 呼出処理コードを返却します。
java.lang.String | getProcessCd() プロセスコードを返却します。
java.lang.String | getProcessDefCd() プロセス定義コードを返却します。
java.lang.String | getProcessingStatus() 処理状態識別を返却します。
java.lang.String | getProcessName() プロセス名を返却します。
java.lang.String | getProcessNestCnt() サブプロセス呼出カウンタを返却します。
java.lang.String | getProcessStatus() プロセスステータスを返却します。
java.lang.String | getRecordDate() 最終更新日時を返却します。
java.lang.String | getRecordUserCd() 最終更新者コードを返却します。
java.lang.String | getRecordUserName() 最終更新者名を返却します。
jp.co.intra_mart.system.bpw.SyncronizedInfo | getSyncronizedInfo() 同期情報を返却します。
java.lang.String | getTargetMasterDate() 対象マスタ日付を返却します。
java.lang.String | getTransactorCd() 処理者コードを返却します。
java.lang.String | getTransactorName() 処理者名を返却します。
java.lang.String | getTransferFlg() 代理フラグを返却します。
java.util.Map | getUserApplikeyList() ユーザアプリケーションキーテーブル情報リストを返却します。
java.lang.String | getVersionCd() 履歴コードを返却します。
void | setCallProcessCd(java.lang.String string) 呼出案件コードを設定します。
void | setCallProcessDefCd(java.lang.String string) 呼び出しプロセス定義コードを設定します。
void | setCallVersionCd(java.lang.String string) 呼び出し履歴コードを設定します。
void | setCodeValue(java.lang.String string) コード値を設定します。
void | setCompanyCd(java.lang.String string) 会社コードを設定します。
void | setCreateDate(java.lang.String string) 作成日時を設定します。
void | setCreateUserCd(java.lang.String string) 作成者コードを設定します。
void | setCreateUserName(java.lang.String string) 作成者名を設定します。
void | setDraftComment(java.lang.String string) 起票時コメントを設定します。
void | setDraftDate(java.lang.String string) 起票日を設定します。
void | setDraftUserCd(java.lang.String string) 起票者コードを設定します。
void | setDraftUserName(java.lang.String string) 起票者名を設定します。
void | setExtensionA(java.lang.String string) 拡張エリアＡを設定します。
void | setExtensionB(java.lang.String string) 拡張エリアＢを設定します。
void | setExtensionC(java.lang.String string) 拡張エリアＣを設定します。
void | setExtensionD(java.lang.String string) 拡張エリアＤを設定します。
void | setExtensionE(java.lang.String string) 拡張エリアＥを設定します。
void | setExtensionF(java.lang.String string) 拡張エリアＦを設定します。
void | setExtensionG(java.lang.String string) 拡張エリアＧを設定します。
void | setExtensionH(java.lang.String string) 拡張エリアＨを設定します。
void | setGroupName(java.lang.String string) グループ名を設定します。
void | setLastManualActivityCd(java.lang.String string) 最終手動処理コードを設定します。
void | setLastManualActivityResult(java.lang.String string) 最終手動処理コードを設定します。
void | setLocaleId(java.lang.String string) 処理者ロケールIDを設定します。
void | setLoginGroupID(java.lang.String string) ログイングループIDを設定します。
void | setLoginUserID(java.lang.String string) ログインユーザIDを設定します。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info) ログイン情報を設定します。
void | setParallelNestCnt(java.lang.String string) 同期処理階層カウンタを設定します。
void | setPresentDisplayInfo(java.lang.String string) 現処理表示情報を設定します。
void | setProcessCallActivityCd(java.lang.String string) 呼出処理コードを設定します。
void | setProcessCd(java.lang.String string) 検索条件とするプロセスコードを設定します。
void | setProcessDefCd(java.lang.String string) 検索条件とするプロセス定義コードを設定します。
void | setProcessingStatus(java.lang.String string) 処理状態識別を設定します。
void | setProcessName(java.lang.String string) プロセス名を設定します。
void | setProcessNestCnt(java.lang.String string) サブプロセス呼出カウンタを設定します。
void | setProcessStatus(java.lang.String string) プロセスステータスを設定します。
void | setRecordDate(java.lang.String string) 最終更新日時を設定します。
void | setRecordUserCd(java.lang.String string) 最終更新者コードを設定します。
void | setRecordUserName(java.lang.String string) 最終更新者名を設定します。
void | setSyncronizedInfo(jp.co.intra_mart.system.bpw.SyncronizedInfo info) 同期情報を設定します。
void | setTargetMasterDate(java.lang.String string) 対象マスタ日付を設定します。
void | setTransactorCd(java.lang.String string) 処理者コードを設定します。
void | setTransactorName(java.lang.String string) 処理者名を設定します。
void | setTransferFlg(java.lang.String string) 代理フラグを設定します。
void | setUserApplikeyList(java.util.Map ketList) ユーザアプリケーションキーテーブル情報リストを設定します。
void | setVersionCd(java.lang.String string) 検索条件とする履歴コードを設定します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TRANSFER_OFF

public static final java.lang.String TRANSFER_OFF
申請者(申請者)

関連項目:
定数フィールド値

TRANSFER_ON

public static final java.lang.String TRANSFER_ON
申請者(代理申請者)

関連項目:
定数フィールド値
コンストラクタの詳細

ProcessInfoModel

public ProcessInfoModel()
コンストラクタ

メソッドの詳細

clone

public java.lang.Object clone()
                       throws java.lang.CloneNotSupportedException
クローン

例外:
java.lang.CloneNotSupportedException

getProcessDefCd

public java.lang.String getProcessDefCd()
プロセス定義コードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス定義コード

getVersionCd

public java.lang.String getVersionCd()
履歴コードを返却します。 システムで利用されるメソッドです。

戻り値:
履歴コード

getProcessCd

public java.lang.String getProcessCd()
プロセスコードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセスコード

getProcessName

public java.lang.String getProcessName()
プロセス名を返却します。 システムで利用されるメソッドです。

戻り値:
プロセス名

getDraftDate

public java.lang.String getDraftDate()
起票日を返却します。 システムで利用されるメソッドです。

戻り値:
起票日

getDraftUserCd

public java.lang.String getDraftUserCd()
起票者コードを返却します。 システムで利用されるメソッドです。

戻り値:
起票者コード

getDraftUserName

public java.lang.String getDraftUserName()
起票者名を返却します。 システムで利用されるメソッドです。

戻り値:
起票者名

getDraftComment

public java.lang.String getDraftComment()
起票時コメントを返却します。 システムで利用されるメソッドです。

戻り値:
起票時コメント

getCompanyCd

public java.lang.String getCompanyCd()
会社コードを返却します。 システムで利用されるメソッドです。

戻り値:
会社コード

getCodeValue

public java.lang.String getCodeValue()
コード値を返却します。 システムで利用されるメソッドです。

戻り値:
コード値

getGroupName

public java.lang.String getGroupName()
グループ名を返却します。 システムで利用されるメソッドです。

戻り値:
グループ名

getTargetMasterDate

public java.lang.String getTargetMasterDate()
対象マスタ日付を返却します。 システムで利用されるメソッドです。

戻り値:
対象マスタ日付

getTransactorCd

public java.lang.String getTransactorCd()
処理者コードを返却します。 システムで利用されるメソッドです。

戻り値:
処理者コード

getTransactorName

public java.lang.String getTransactorName()
処理者名を返却します。 システムで利用されるメソッドです。

戻り値:
処理者名

getLocaleId

public java.lang.String getLocaleId()
処理者ロケールIDを返却します。 システムで利用されるメソッドです。

戻り値:
処理者ロケールID

getProcessStatus

public java.lang.String getProcessStatus()
プロセスステータスを返却します。 システムで利用されるメソッドです。

戻り値:
プロセスステータス

getLastManualActivityCd

public java.lang.String getLastManualActivityCd()
最終手動処理コードを返却します。 システムで利用されるメソッドです。

戻り値:
最終手動処理コード

getLastManualActivityResult

public java.lang.String getLastManualActivityResult()
最終手動アクティビティ承認結果種別を返却します。 システムで利用されるメソッドです。

戻り値:
最終手動アクティビティ承認結果種別

getCallProcessDefCd

public java.lang.String getCallProcessDefCd()
呼び出しプロセス定義コードを返却します。

戻り値:
呼び出しプロセス定義コード

getCallVersionCd

public java.lang.String getCallVersionCd()
呼び出し履歴コードを返却します。

戻り値:
呼び出し履歴コード

getCallProcessCd

public java.lang.String getCallProcessCd()
呼出プロセスコードを返却します。 システムで利用されるメソッドです。

戻り値:
呼出プロセスコード

getProcessCallActivityCd

public java.lang.String getProcessCallActivityCd()
呼出処理コードを返却します。 システムで利用されるメソッドです。

戻り値:
呼出処理コード

getProcessingStatus

public java.lang.String getProcessingStatus()
処理状態識別を返却します。 システムで利用されるメソッドです。

戻り値:
処理状態識別

getProcessNestCnt

public java.lang.String getProcessNestCnt()
サブプロセス呼出カウンタを返却します。 システムで利用されるメソッドです。

戻り値:
サブプロセス呼出カウンタ

getParallelNestCnt

public java.lang.String getParallelNestCnt()
同期処理階層カウンタを返却します。 システムで利用されるメソッドです。

戻り値:
同期処理階層カウンタ

getPresentDisplayInfo

public java.lang.String getPresentDisplayInfo()
現処理表示情報を返却します。 システムで利用されるメソッドです。

戻り値:
現処理表示情報

getExtensionA

public java.lang.String getExtensionA()
拡張エリアＡを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＡ

getExtensionB

public java.lang.String getExtensionB()
拡張エリアＢを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＢ

getExtensionC

public java.lang.String getExtensionC()
拡張エリアＣを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＣ

getExtensionD

public java.lang.String getExtensionD()
拡張エリアＤを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＤ

getExtensionE

public java.lang.String getExtensionE()
拡張エリアＥを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＥ

getExtensionF

public java.lang.String getExtensionF()
拡張エリアＦを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＦ

getExtensionG

public java.lang.String getExtensionG()
拡張エリアＧを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＧ

getExtensionH

public java.lang.String getExtensionH()
拡張エリアＨを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＨ

getConvertLong

public java.lang.Object getConvertLong(java.lang.String string)
数値型変換後に返却します。 システムで利用されるメソッドです。

パラメータ:
string - 文字列
戻り値:
Long

getCreateDate

public java.lang.String getCreateDate()
作成日時を返却します。 システムで利用されるメソッドです。

戻り値:
作成日時

getCreateUserCd

public java.lang.String getCreateUserCd()
作成者コードを返却します。 システムで利用されるメソッドです。

戻り値:
作成者コード

getCreateUserName

public java.lang.String getCreateUserName()
作成者名を返却します。 システムで利用されるメソッドです。

戻り値:
作成者名

getRecordDate

public java.lang.String getRecordDate()
最終更新日時を返却します。 システムで利用されるメソッドです。

戻り値:
最終更新日時

getRecordUserCd

public java.lang.String getRecordUserCd()
最終更新者コードを返却します。 システムで利用されるメソッドです。

戻り値:
最終更新者コード

getRecordUserName

public java.lang.String getRecordUserName()
最終更新者名を返却します。 システムで利用されるメソッドです。

戻り値:
最終更新者名

getUserApplikeyList

public java.util.Map getUserApplikeyList()
ユーザアプリケーションキーテーブル情報リストを返却します。

戻り値:
ユーザアプリケーションキーテーブル情報リスト

getTransferFlg

public java.lang.String getTransferFlg()
代理フラグを返却します。

戻り値:
代理フラグ

getSyncronizedInfo

public jp.co.intra_mart.system.bpw.SyncronizedInfo getSyncronizedInfo()
同期情報を返却します。

戻り値:
同期情報

setProcessDefCd

public void setProcessDefCd(java.lang.String string)
検索条件とするプロセス定義コードを設定します。

パラメータ:
string - 検索値

setVersionCd

public void setVersionCd(java.lang.String string)
検索条件とする履歴コードを設定します。

パラメータ:
string - 検索値

setProcessCd

public void setProcessCd(java.lang.String string)
検索条件とするプロセスコードを設定します。

パラメータ:
string - 検索値

setProcessName

public void setProcessName(java.lang.String string)
プロセス名を設定します。

パラメータ:
string - プロセス名

setDraftDate

public void setDraftDate(java.lang.String string)
起票日を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 起票日

setDraftUserCd

public void setDraftUserCd(java.lang.String string)
起票者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 起票者コード

setDraftUserName

public void setDraftUserName(java.lang.String string)
起票者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 起票者名

setDraftComment

public void setDraftComment(java.lang.String string)
起票時コメントを設定します。

パラメータ:
string - 起票時コメント

setCompanyCd

public void setCompanyCd(java.lang.String string)
会社コードを設定します。

パラメータ:
string - 会社コード

setCodeValue

public void setCodeValue(java.lang.String string)
コード値を設定します。

パラメータ:
string - コード値

setGroupName

public void setGroupName(java.lang.String string)
グループ名を設定します。

パラメータ:
string - グループ名

setTargetMasterDate

public void setTargetMasterDate(java.lang.String string)
対象マスタ日付を設定します。

パラメータ:
string - 対象マスタ日付

setTransactorCd

public void setTransactorCd(java.lang.String string)
処理者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 処理者コード

setTransactorName

public void setTransactorName(java.lang.String string)
処理者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 処理者名

setLocaleId

public void setLocaleId(java.lang.String string)
処理者ロケールIDを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 処理者ロケールID

setProcessStatus

public void setProcessStatus(java.lang.String string)
プロセスステータスを設定します。 システムで利用されるメソッドです。

パラメータ:
string - プロセスステータス

setLastManualActivityCd

public void setLastManualActivityCd(java.lang.String string)
最終手動処理コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終手動処理コード

setLastManualActivityResult

public void setLastManualActivityResult(java.lang.String string)
最終手動処理コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終手動処理コード

setCallProcessDefCd

public void setCallProcessDefCd(java.lang.String string)
呼び出しプロセス定義コードを設定します。

パラメータ:
string - 呼び出しプロセス定義コード

setCallVersionCd

public void setCallVersionCd(java.lang.String string)
呼び出し履歴コードを設定します。

パラメータ:
string - 呼び出し履歴コード

setCallProcessCd

public void setCallProcessCd(java.lang.String string)
呼出案件コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 呼出案件コード

setProcessCallActivityCd

public void setProcessCallActivityCd(java.lang.String string)
呼出処理コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 呼出処理コード

setProcessingStatus

public void setProcessingStatus(java.lang.String string)
処理状態識別を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 処理状態識別

setProcessNestCnt

public void setProcessNestCnt(java.lang.String string)
サブプロセス呼出カウンタを設定します。 システムで利用されるメソッドです。

パラメータ:
string - サブプロセス呼出カウンタ

setParallelNestCnt

public void setParallelNestCnt(java.lang.String string)
同期処理階層カウンタを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 同期処理階層カウンタ

setPresentDisplayInfo

public void setPresentDisplayInfo(java.lang.String string)
現処理表示情報を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 現処理表示情報

setExtensionA

public void setExtensionA(java.lang.String string)
拡張エリアＡを設定します。

パラメータ:
string - 拡張エリアＡ

setExtensionB

public void setExtensionB(java.lang.String string)
拡張エリアＢを設定します。

パラメータ:
string - 拡張エリアＢ

setExtensionC

public void setExtensionC(java.lang.String string)
拡張エリアＣを設定します。

パラメータ:
string - 拡張エリアＣ

setExtensionD

public void setExtensionD(java.lang.String string)
拡張エリアＤを設定します。

パラメータ:
string - 拡張エリアＤ

setExtensionE

public void setExtensionE(java.lang.String string)
拡張エリアＥを設定します。

パラメータ:
string - 拡張エリアＥ

setExtensionF

public void setExtensionF(java.lang.String string)
拡張エリアＦを設定します。

パラメータ:
string - 拡張エリアＦ

setExtensionG

public void setExtensionG(java.lang.String string)
拡張エリアＧを設定します。

パラメータ:
string - 拡張エリアＧ

setExtensionH

public void setExtensionH(java.lang.String string)
拡張エリアＨを設定します。

パラメータ:
string - 拡張エリアＨ

setCreateDate

public void setCreateDate(java.lang.String string)
作成日時を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成日時

setCreateUserCd

public void setCreateUserCd(java.lang.String string)
作成者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成者コード

setCreateUserName

public void setCreateUserName(java.lang.String string)
作成者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成者名

setRecordDate

public void setRecordDate(java.lang.String string)
最終更新日時を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新日時

setRecordUserCd

public void setRecordUserCd(java.lang.String string)
最終更新者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新者コード

setRecordUserName

public void setRecordUserName(java.lang.String string)
最終更新者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新者名

setUserApplikeyList

public void setUserApplikeyList(java.util.Map ketList)
ユーザアプリケーションキーテーブル情報リストを設定します。

パラメータ:
ketList - ユーザアプリケーションキーテーブル情報リスト

addUserAppliKey

public void addUserAppliKey(int i,
                            jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model)
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。

パラメータ:
i - パラメータ番号
model - ユーザアプリケーションキーテーブル情報

setTransferFlg

public void setTransferFlg(java.lang.String string)
代理フラグを設定します。 申請時に申請するユーザ区分を設定します。初期値は正規の申請者に設定されているので、 代理申請を要求する際にTRANSFER_ONを設定してください。

パラメータ:
string - 代理フラグ

setSyncronizedInfo

public void setSyncronizedInfo(jp.co.intra_mart.system.bpw.SyncronizedInfo info)
同期情報を設定します。 システムで利用されるメソッドです。

パラメータ:
info - 同期情報

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。 システムで利用されるメソッドです。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserInfo
戻り値:
ログインユーザ情報

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info)
ログイン情報を設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserInfo
パラメータ:
info - ログインユーザ情報

setLoginUserID

public void setLoginUserID(java.lang.String string)
ログインユーザIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserID
パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(java.lang.String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginGroupID
パラメータ:
string - ログイングループID

getLoginUserID

public java.lang.String getLoginUserID()
ログインユーザIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserID
戻り値:
ログインユーザID

getLoginGroupID

public java.lang.String getLoginGroupID()
ログイングループIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginGroupID
戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


RecognitionInfoModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス RecognitionInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel
public class RecognitionInfoModel
extends java.lang.Object

処理要求時情報モデル。
アクティブなアクティビティに対して、承認処理要求を行う際に指定する情報クラスです。 処理要求として、
  申請：申請はプロセスの登録要求で実装してください。
  再申請：差戻し等で再申請が必要な場合に指定してください。再申請されます。
  承認：現在のアクティビティは完了され、次のアクティビティが処理されます。
  棄却：現在のアクティビティでプロセスが終了します。
が指定可能です。承認種別にこのクラスに定義されたフィールド値を設定して下さい。
指定必須項目[プロセス定義コード・履歴コード・プロセスコード・ アクティビティコード・承認種別・承認者コード]

フィールドの概要
static java.lang.String | APPLY 承認種別：申請
static java.lang.String | CANCEL 承認種別：取り止め
static java.lang.String | MAGICAL_HAND 承認種別：強制操作
static java.lang.String | RECOGNITION 承認種別：承認
static java.lang.String | REJECTION 承認種別：棄却
static java.lang.String | RETRY 承認種別：再申請
static java.lang.String | RETURN_BEFORE 承認種別：承認者へ差し戻す
static java.lang.String | RETURN_PULL 承認種別：引き戻し
static java.lang.String | RETURN_START 承認種別：申請者へ差し戻す
static java.lang.String | ROLL_SELECT_OFF ロール絞込み指定ON
static java.lang.String | ROLL_SELECT_ON ロール絞込み指定OFF
static java.lang.String | SUSPENSION 承認種別：保留
static java.lang.String | TARGET_AUTOPASS 承認種別：対象者自動パス
コンストラクタの概要
RecognitionInfoModel()
コンストラクタ
RecognitionInfoModel(ActivityInfoModel src)
RecognitionInfoModel(ProcessInfoModel src)
メソッドの概要
void | addUserAppliKey(int i, jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model) 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
java.lang.String | getActivityCd() アクティビティコードを返却します。
java.lang.String | getActivityName() アクティビティ名を返却します。
java.lang.String | getAgentUserCd() 代理元ユーザCDを返却します。
java.lang.String | getApprovalType() 承認種別を返却します。
java.lang.String | getApprovalUserCd() 承認者コードを返却します。
java.lang.String | getApprovalUserName() 承認者名を返却します。
jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel | getAttachPosition() 所属立場を返却します。
java.lang.String | getDraftCd() 起票アクティビティコードを取得します。
java.lang.String | getPreApprovalType() 前承認種別を返却します。
java.lang.String | getProcessCd() プロセスコードを返却します。
java.lang.String | getProcessDefCd() プロセス定義コードを返却します。
java.lang.String | getProcessName() プロセス名(サブプロセス申請用)を返却します。
java.lang.String | getReceiveComment() 承認時コメントを返却します。
java.lang.String | getRollSelectFlg() ロール絞込み指定フラグを返却します。
jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel | getRouteInfoModel() 申請者/承認者ルート作成-ルート情報を取得します。
RunExecutiveInfoModel | getRunExecuteInfoModel() 実行主体ユーザマスタ情報を返却します。
RunUserInfoModel | getRunUserInfoModel() 実行主体役職マスタ情報を返却します。
java.lang.String | getSelectRouteNo() 選択ルート番号を返却します。
java.lang.String | getTargetMasterDate() 対象指定日を返却します。
java.lang.String | getTransferFlg() 代理フラグを返却します。
jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel | getTransferInfoModel() 処理委譲情報を取得します。
java.util.Map | getUserAppliKeyList() ユーザアプリケーションキーテーブル情報リストを返却します。
java.lang.String | getVersionCd() 履歴コードを返却します。
java.lang.String | getVersionName() プロセス定義（履歴名）を取得します。
boolean | isAutoPassFlag() 自動パスフラグを返却します。
void | setActivityCd(java.lang.String string) アクティビティコードを設定します。
void | setActivityName(java.lang.String string) アクティビティ名を設定します。
void | setAgentUserCd(java.lang.String string) 代理元ユーザCDを設定します。
void | setApprovalType(java.lang.String string) 承認種別を設定します。
void | setApprovalUserCd(java.lang.String string) 承認者コードを設定します。
void | setApprovalUserName(java.lang.String string) 承認者名を設定します。
void | setAttachPosition(jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel model) 所属立場を設定します。
void | setAutoPassFlag(boolean value) 自動パスフラグを設定します。
void | setDraftCd(java.lang.String string) * 起票アクティビティコードを設定します。
void | setPreApprovalType(java.lang.String string) 前承認種別を設定します。
void | setProcessCd(java.lang.String string) プロセスコードを設定します。
void | setProcessDefCd(java.lang.String string) プロセス定義コードを設定します。
void | setProcessName(java.lang.String string) プロセス名(サブプロセス申請用)を設定します。
void | setReceiveComment(java.lang.String string) 承認時コメントを設定します。
void | setRollSelectFlg(java.lang.String string) ロール絞込み指定フラグを設定します。
void | setRouteInfoModel(jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel model) 申請者/承認者ルート作成-ルート情報設定します。
void | setRunExecuteInfoModel(RunExecutiveInfoModel model) 実行時選択時実行主体役職マスタテーブルを設定します。
void | setRunUserInfoModel(RunUserInfoModel model) 実行時選択時実行主体ユーザマスタ情報を設定します。
void | setSelectRouteNo(java.lang.String string) 選択ルート番号を設定します。
void | setTargetMasterDate(java.lang.String string) 対象指定日を設定します。
void | setTransferFlg(java.lang.String string) 代理フラグを設定します。
void | setTransferInfoModel(jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel model) 処理委譲情報を設定します。
void | setVersionCd(java.lang.String string) 履歴コードを設定します。
void | setVersionName(java.lang.String string) プロセス定義（履歴名）を設定します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLY

public static final java.lang.String APPLY
承認種別：申請

関連項目:
定数フィールド値

RETRY

public static final java.lang.String RETRY
承認種別：再申請

関連項目:
定数フィールド値

RECOGNITION

public static final java.lang.String RECOGNITION
承認種別：承認

関連項目:
定数フィールド値

REJECTION

public static final java.lang.String REJECTION
承認種別：棄却

関連項目:
定数フィールド値

RETURN_START

public static final java.lang.String RETURN_START
承認種別：申請者へ差し戻す

関連項目:
定数フィールド値

RETURN_BEFORE

public static final java.lang.String RETURN_BEFORE
承認種別：承認者へ差し戻す

関連項目:
定数フィールド値

RETURN_PULL

public static final java.lang.String RETURN_PULL
承認種別：引き戻し

関連項目:
定数フィールド値

SUSPENSION

public static final java.lang.String SUSPENSION
承認種別：保留

関連項目:
定数フィールド値

CANCEL

public static final java.lang.String CANCEL
承認種別：取り止め

関連項目:
定数フィールド値

TARGET_AUTOPASS

public static final java.lang.String TARGET_AUTOPASS
承認種別：対象者自動パス

関連項目:
定数フィールド値

MAGICAL_HAND

public static final java.lang.String MAGICAL_HAND
承認種別：強制操作

関連項目:
定数フィールド値

ROLL_SELECT_ON

public static final java.lang.String ROLL_SELECT_ON
ロール絞込み指定OFF

関連項目:
定数フィールド値

ROLL_SELECT_OFF

public static final java.lang.String ROLL_SELECT_OFF
ロール絞込み指定ON

関連項目:
定数フィールド値
コンストラクタの詳細

RecognitionInfoModel

public RecognitionInfoModel()
コンストラクタ

RecognitionInfoModel

public RecognitionInfoModel(ProcessInfoModel src)

RecognitionInfoModel

public RecognitionInfoModel(ActivityInfoModel src)
メソッドの詳細

getReceiveComment

public java.lang.String getReceiveComment()
承認時コメントを返却します。

戻り値:
承認時コメント

getApprovalUserCd

public java.lang.String getApprovalUserCd()
承認者コードを返却します。

戻り値:
承認者コード

getApprovalUserName

public java.lang.String getApprovalUserName()
承認者名を返却します。

戻り値:
承認者名

getApprovalType

public java.lang.String getApprovalType()
承認種別を返却します。

戻り値:
承認種別
関連項目:
申請, 再申請, 承認, 棄却

getActivityCd

public java.lang.String getActivityCd()
アクティビティコードを返却します。

戻り値:
アクティビティコード

getActivityName

public java.lang.String getActivityName()
アクティビティ名を返却します。

戻り値:
アクティビティ名

getProcessCd

public java.lang.String getProcessCd()
プロセスコードを返却します。

戻り値:
プロセスコード

getProcessDefCd

public java.lang.String getProcessDefCd()
プロセス定義コードを返却します。

戻り値:
プロセス定義コード

getVersionCd

public java.lang.String getVersionCd()
履歴コードを返却します。

戻り値:
履歴コード

getRollSelectFlg

public java.lang.String getRollSelectFlg()
ロール絞込み指定フラグを返却します。

戻り値:
ロール絞込み指定フラグ

getRunExecuteInfoModel

public RunExecutiveInfoModel getRunExecuteInfoModel()
実行主体ユーザマスタ情報を返却します。

戻り値:
実行主体ユーザマスタ情報

getRunUserInfoModel

public RunUserInfoModel getRunUserInfoModel()
実行主体役職マスタ情報を返却します。

戻り値:
実行主体役職マスタ情報

getUserAppliKeyList

public java.util.Map getUserAppliKeyList()
ユーザアプリケーションキーテーブル情報リストを返却します。

戻り値:
ユーザアプリケーションキーテーブル情報リスト

getTransferFlg

public java.lang.String getTransferFlg()
代理フラグを返却します。

戻り値:
代理フラグ

isAutoPassFlag

public boolean isAutoPassFlag()
自動パスフラグを返却します。

戻り値:
自動パスフラグ

getVersionName

public java.lang.String getVersionName()
プロセス定義（履歴名）を取得します。

戻り値:
versionName

getDraftCd

public java.lang.String getDraftCd()
起票アクティビティコードを取得します。

戻り値:
RootInfoModel

getRouteInfoModel

public jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel getRouteInfoModel()
申請者/承認者ルート作成-ルート情報を取得します。

戻り値:
RootInfoModel

getTransferInfoModel

public jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel getTransferInfoModel()
処理委譲情報を取得します。

戻り値:
RootInfoModel

getSelectRouteNo

public java.lang.String getSelectRouteNo()
選択ルート番号を返却します。

戻り値:
選択ルート番号

getAttachPosition

public jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel getAttachPosition()
所属立場を返却します。

戻り値:
所属立場

getTargetMasterDate

public java.lang.String getTargetMasterDate()
対象指定日を返却します。

戻り値:
対象指定日

getAgentUserCd

public java.lang.String getAgentUserCd()
代理元ユーザCDを返却します。

戻り値:
代理元ユーザCD

getProcessName

public java.lang.String getProcessName()
プロセス名(サブプロセス申請用)を返却します。

戻り値:
プロセス名(サブプロセス申請用)

getPreApprovalType

public java.lang.String getPreApprovalType()
前承認種別を返却します。

戻り値:
前承認種別

setReceiveComment

public void setReceiveComment(java.lang.String string)
承認時コメントを設定します。

パラメータ:
string - 承認時コメント

setApprovalUserCd

public void setApprovalUserCd(java.lang.String string)
承認者コードを設定します。 代理による再申請、代理による承認の場合は実際に処理したユーザの ユーザコードを設定して下さい。

パラメータ:
string - 承認者コード

setApprovalUserName

public void setApprovalUserName(java.lang.String string)
承認者名を設定します。 ＢＰＷ内部で設定されます。 通常は設定しないで下さい。

パラメータ:
string - 承認者名

setApprovalType

public void setApprovalType(java.lang.String string)
承認種別を設定します。

パラメータ:
string - 承認種別
関連項目:
申請, 再申請, 承認, 棄却

setActivityCd

public void setActivityCd(java.lang.String string)
アクティビティコードを設定します。

パラメータ:
string - アクティビティコード

setActivityName

public void setActivityName(java.lang.String string)
アクティビティ名を設定します。

パラメータ:
string - アクティビティ名

setProcessCd

public void setProcessCd(java.lang.String string)
プロセスコードを設定します。

パラメータ:
string - プロセスコード

setProcessDefCd

public void setProcessDefCd(java.lang.String string)
プロセス定義コードを設定します。

パラメータ:
string - プロセス定義コード

setVersionCd

public void setVersionCd(java.lang.String string)
履歴コードを設定します。

パラメータ:
string - 履歴コード

setRollSelectFlg

public void setRollSelectFlg(java.lang.String string)
ロール絞込み指定フラグを設定します。

パラメータ:
string - ロール絞込み指定フラグ

setRunExecuteInfoModel

public void setRunExecuteInfoModel(RunExecutiveInfoModel model)
実行時選択時実行主体役職マスタテーブルを設定します。 実行時選択時に、登録する実行主体役職情報を設定してください。

パラメータ:
model - 実行主体役職マスタテーブル

setRunUserInfoModel

public void setRunUserInfoModel(RunUserInfoModel model)
実行時選択時実行主体ユーザマスタ情報を設定します。 実行時選択時に、登録する実行主体ユーザ情報を設定してください。

パラメータ:
model - 実行主体ユーザマスタ情報

addUserAppliKey

public void addUserAppliKey(int i,
                            jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model)
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。 指定されたパラメータ番号でユーザアプリケーションキーテーブル情報リストにマップします。

パラメータ:
i - パラメータ番号
model - ユーザアプリケーションキーテーブル情報

setTransferFlg

public void setTransferFlg(java.lang.String string)
代理フラグを設定します。

パラメータ:
string - 代理フラグ

setAutoPassFlag

public void setAutoPassFlag(boolean value)
自動パスフラグを設定します。

パラメータ:
value - 自動パスフラグ

setVersionName

public void setVersionName(java.lang.String string)
プロセス定義（履歴名）を設定します。

パラメータ:
string - プロセス定義（履歴名）

setDraftCd

public void setDraftCd(java.lang.String string)
* 起票アクティビティコードを設定します。

パラメータ:
string - 起票アクティビティコード

setSelectRouteNo

public void setSelectRouteNo(java.lang.String string)
選択ルート番号を設定します。

パラメータ:
string - 選択ルート番号

setTransferInfoModel

public void setTransferInfoModel(jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel model)
処理委譲情報を設定します。

パラメータ:
model - 処理委譲情報

setRouteInfoModel

public void setRouteInfoModel(jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel model)
申請者/承認者ルート作成-ルート情報設定します。

パラメータ:
model -

setAttachPosition

public void setAttachPosition(jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel model)
所属立場を設定します。

パラメータ:
model - 所属立場

setTargetMasterDate

public void setTargetMasterDate(java.lang.String string)
対象指定日を設定します。

パラメータ:
string - 対象指定日

setAgentUserCd

public void setAgentUserCd(java.lang.String string)
代理元ユーザCDを設定します。

パラメータ:
string - 代理元ユーザCD

setProcessName

public void setProcessName(java.lang.String string)
プロセス名(サブプロセス申請用)を設定します。

パラメータ:
string - プロセス名(サブプロセス申請用)

setPreApprovalType

public void setPreApprovalType(java.lang.String string)
前承認種別を設定します。

パラメータ:
string - 前承認種別
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


RunExecutiveInfoModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス RunExecutiveInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey
        拡張 jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel
すべての実装インタフェース:
java.io.Serializable
public class RunExecutiveInfoModel
extends jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey

実行主体役職マスタの情報保持クラス
次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。 実行時選択には【ユーザ】、【組織】のみが指定できます。 【パブリックグループ】また、【ロール】、【役職】の絞込み指定はできません。

関連項目:
直列化された形式

フィールドの概要
static java.lang.String | CD_KIND_OFFICIAL 指定されたコードがパブリックグループ
static java.lang.String | CD_KIND_ORG 指定されたコードが組織コード
static java.lang.String | CD_KIND_ROLE 指定されたコードがロール
static java.lang.String | CD_KIND_USER 指定されたコードがユーザコード
static java.lang.String | NO_PAIR ペアNOがペアではない
static java.lang.String | NON_BILONGING 無所属時のダミーコード
static java.lang.String | OLD_DATA 旧データ （旧データ：ペアＮＯのデフォルト値）
static java.lang.String | POST_TYPE_POSITION 指定されたコードが役職コード （絞込み）
static java.lang.String | POST_TYPE_ROLE 指定されたコードがロール （絞込み）
コンストラクタの概要
RunExecutiveInfoModel()
RunExecutiveInfoModel(ActivityInfoModel src)
RunExecutiveInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)
RunExecutiveInfoModel(RunExecutiveInfoModel src)
メソッドの概要
java.lang.String | getCompanyCd() 会社コードを返却します。
java.lang.String | getPairNo() ペアNOを返却します。
java.lang.String | getPostCd() 役職コードを返却します。
java.lang.String | getPostCdKind() 役職コード種別を返却します。
void | inputCheck(java.sql.Connection connection, java.lang.String targetDate, jp.co.intra_mart.framework.base.util.UserInfo userInfo) 実行主体役職マスタ入力情報をチェックするメソッドです。
void | setCompanyCd(java.lang.String string) 会社コードを設定します。
void | setPairNo(java.lang.String string) ペアNOを設定します。
void | setPostCd(java.lang.String string) 役職コードを設定します。
void | setPostCdKind(java.lang.String string) 役職コード種別を設定します。
クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey から継承したメソッド
getActivityCd, getProcessDefCd, getVersionCd, setActivityCd, setProcessDefCd, setVersionCd
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CD_KIND_USER

public static final java.lang.String CD_KIND_USER
指定されたコードがユーザコード

関連項目:
定数フィールド値

CD_KIND_ORG

public static final java.lang.String CD_KIND_ORG
指定されたコードが組織コード

関連項目:
定数フィールド値

CD_KIND_OFFICIAL

public static final java.lang.String CD_KIND_OFFICIAL
指定されたコードがパブリックグループ

関連項目:
定数フィールド値

CD_KIND_ROLE

public static final java.lang.String CD_KIND_ROLE
指定されたコードがロール

関連項目:
定数フィールド値

POST_TYPE_ROLE

public static final java.lang.String POST_TYPE_ROLE
指定されたコードがロール （絞込み）

関連項目:
定数フィールド値

POST_TYPE_POSITION

public static final java.lang.String POST_TYPE_POSITION
指定されたコードが役職コード （絞込み）

関連項目:
定数フィールド値

NON_BILONGING

public static final java.lang.String NON_BILONGING
無所属時のダミーコード

関連項目:
定数フィールド値

NO_PAIR

public static final java.lang.String NO_PAIR
ペアNOがペアではない

関連項目:
定数フィールド値

OLD_DATA

public static final java.lang.String OLD_DATA
旧データ （旧データ：ペアＮＯのデフォルト値）

関連項目:
定数フィールド値
コンストラクタの詳細

RunExecutiveInfoModel

public RunExecutiveInfoModel()

RunExecutiveInfoModel

public RunExecutiveInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)

RunExecutiveInfoModel

public RunExecutiveInfoModel(ActivityInfoModel src)

RunExecutiveInfoModel

public RunExecutiveInfoModel(RunExecutiveInfoModel src)
メソッドの詳細

getPostCd

public java.lang.String getPostCd()
役職コードを返却します。

戻り値:
役職コード

getPostCdKind

public java.lang.String getPostCdKind()
役職コード種別を返却します。

戻り値:
役職コード種別

setPostCd

public void setPostCd(java.lang.String string)
役職コードを設定します。

パラメータ:
string - 役職コード

setPostCdKind

public void setPostCdKind(java.lang.String string)
役職コード種別を設定します。

パラメータ:
string - 役職コード種別

getPairNo

public java.lang.String getPairNo()
ペアNOを返却します。

戻り値:
ペアNO

setPairNo

public void setPairNo(java.lang.String string)
ペアNOを設定します。

パラメータ:
string - ペアNO

getCompanyCd

public java.lang.String getCompanyCd()
会社コードを返却します。

戻り値:
会社コード

setCompanyCd

public void setCompanyCd(java.lang.String string)
会社コードを設定します。

パラメータ:
string - 会社コード

inputCheck

public void inputCheck(java.sql.Connection connection,
                       java.lang.String targetDate,
                       jp.co.intra_mart.framework.base.util.UserInfo userInfo)
                throws jp.co.intra_mart.framework.system.exception.SystemException,
                       jp.co.intra_mart.framework.system.exception.ApplicationException
実行主体役職マスタ入力情報をチェックするメソッドです。

パラメータ:
connection - Connection
targetDate - 対象日付
userInfo - ユーザ情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


RunUserInfoModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス RunUserInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey
        拡張 jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel
すべての実装インタフェース:
jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.io.Serializable
public class RunUserInfoModel
extends jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey
implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.io.Serializable

実行主体ユーザ情報を保持する情報クラス

関連項目:
直列化された形式

フィールドの概要
static java.lang.String | RIGHT_DELEGATE 承認可否種別：振替・本人決済可（振替(02)の承認種別CDでのみ有効）
static java.lang.String | RIGHT_INIT 承認可否種別：初期値（全ての承認種別CDで有効）
static java.lang.String | RIGHT_NOT_DELEGATE 承認可否種別：振替・本人決済不可（振替(02)の承認種別CDでのみ有効）
static java.lang.String | RIGHT_NOT_PERSON 承認可否種別：代理・本人決済不可（本人(00)の承認種別CDでのみ有効）
static java.lang.String | RIGHT_PERSON 承認可否種別：代理・本人決済可（本人(00)の承認種別CDでのみ有効）
static java.lang.String | STATUS_COMPLETE 承認ステータス：処理済（全ての承認種別CDで有効）
static java.lang.String | STATUS_DELEGATE_COMPLETE 承認ステータス：振替処理済（本人(00), 振替(02)の承認種別CDでのみ有効）
static java.lang.String | STATUS_INIT 承認ステータス：初期値（全ての承認種別CDで有効）
static java.lang.String | STATUS_SAID_COMPLETE 承認ステータス：代理処理済（本人(00)の承認種別CDでのみ有効）
static java.lang.String | TYPE_DELEGATE 承認対象種別コード：振替
static java.lang.String | TYPE_PERSON 承認対象種別コード：本人
static java.lang.String | TYPE_SAID_PERSON 承認対象種別コード：代理
コンストラクタの概要
RunUserInfoModel()
コンストラクタ
RunUserInfoModel(ActivityInfoModel src)
RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel src)
RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.DelegateUserInfoModel src)
RunUserInfoModel(ProcessInfoModel src)
RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)
RunUserInfoModel(RunUserInfoModel src)
メソッドの概要
void | addGroupList(jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel model) グループ情報リストを追加します。
static void | existUserCd(java.sql.Connection connection, java.lang.String userCd, java.lang.String targetDate, java.lang.String invalidErrCd, java.lang.String noExistErrCd) ユーザコード入力情報をチェックするメソッドです。
java.lang.String | getApprovalRightType() 承認可否種別を返却します。
java.lang.String | getApprovalTypeCd() 承認種別CDを返却します。
java.lang.String | getAuthorityFlg() 処理権限フラグを返却します。
java.lang.String | getDemandReceiptCd() 依頼要求／受付CDを返却します。
java.lang.String | getDemandReceiptName() 依頼要求／受付名を返却します。
jp.co.intra_mart.foundation.bpw.model.object.RunGroupListModel | getGroupList() グループ情報リストを返却します。
java.lang.String | getLoginGroupID() ログイングループIDを返却します。
java.lang.String | getLoginUserID() ログインユーザIDを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
java.lang.String | getProcessCd() プロセスコードを返却します。
java.lang.String | getRecognitionStatus() 承認ステータスを返却します。
java.lang.String | getRepresentationType() 代理コード種別を返却します。
java.lang.String | getTransferUserCd() 振替先ユーザCDを返却します。
java.lang.String | getTransferUserName() 振替先ユーザ名を返却します。
java.lang.String | getUserCd() ユーザコードを返却します。
java.lang.String | getUserName() ユーザ名を返却します。
void | inputCheck(java.sql.Connection connection, java.lang.String targetDate) 実行主体ユーザ入力情報をチェックするメソッドです。
void | setApprovalRightType(java.lang.String string) 承認可否種別を設定します。
void | setApprovalTypeCd(java.lang.String string) 承認種別CDを設定します。
void | setAuthorityFlg(java.lang.String string) 処理権限フラグを設定します。
void | setDemandReceiptCd(java.lang.String string) 依頼要求／受付CDを設定します。
void | setDemandReceiptName(java.lang.String string) 依頼要求／受付名を設定します。
void | setLoginGroupID(java.lang.String string) ログイングループIDを設定します。
void | setLoginUserID(java.lang.String string) ログインユーザIDを設定します。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info) ログイン情報を設定します。
void | setProcessCd(java.lang.String string) プロセスコードを設定します。
void | setRecognitionStatus(java.lang.String string) 承認ステータスを設定します。
void | setRepresentationType(java.lang.String string) 代理コード種別を設定します。
void | setTransferUserCd(java.lang.String string) 振替先ユーザCDを設定します。
void | setTransferUserName(java.lang.String string) 振替先ユーザ名を設定します。
void | setUserCd(java.lang.String string) ユーザコードを設定します。
void | setUserName(java.lang.String string) ユーザ名を設定します。
クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey から継承したメソッド
getActivityCd, getProcessDefCd, getVersionCd, setActivityCd, setProcessDefCd, setVersionCd
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_PERSON

public static final java.lang.String TYPE_PERSON
承認対象種別コード：本人

関連項目:
定数フィールド値

TYPE_SAID_PERSON

public static final java.lang.String TYPE_SAID_PERSON
承認対象種別コード：代理

関連項目:
定数フィールド値

TYPE_DELEGATE

public static final java.lang.String TYPE_DELEGATE
承認対象種別コード：振替

関連項目:
定数フィールド値

RIGHT_INIT

public static final java.lang.String RIGHT_INIT
承認可否種別：初期値（全ての承認種別CDで有効）

関連項目:
定数フィールド値

RIGHT_PERSON

public static final java.lang.String RIGHT_PERSON
承認可否種別：代理・本人決済可（本人(00)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

RIGHT_NOT_PERSON

public static final java.lang.String RIGHT_NOT_PERSON
承認可否種別：代理・本人決済不可（本人(00)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

RIGHT_DELEGATE

public static final java.lang.String RIGHT_DELEGATE
承認可否種別：振替・本人決済可（振替(02)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

RIGHT_NOT_DELEGATE

public static final java.lang.String RIGHT_NOT_DELEGATE
承認可否種別：振替・本人決済不可（振替(02)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

STATUS_INIT

public static final java.lang.String STATUS_INIT
承認ステータス：初期値（全ての承認種別CDで有効）

関連項目:
定数フィールド値

STATUS_COMPLETE

public static final java.lang.String STATUS_COMPLETE
承認ステータス：処理済（全ての承認種別CDで有効）

関連項目:
定数フィールド値

STATUS_SAID_COMPLETE

public static final java.lang.String STATUS_SAID_COMPLETE
承認ステータス：代理処理済（本人(00)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

STATUS_DELEGATE_COMPLETE

public static final java.lang.String STATUS_DELEGATE_COMPLETE
承認ステータス：振替処理済（本人(00), 振替(02)の承認種別CDでのみ有効）

関連項目:
定数フィールド値
コンストラクタの詳細

RunUserInfoModel

public RunUserInfoModel()
コンストラクタ

RunUserInfoModel

public RunUserInfoModel(ProcessInfoModel src)

RunUserInfoModel

public RunUserInfoModel(ActivityInfoModel src)

RunUserInfoModel

public RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel src)

RunUserInfoModel

public RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)

RunUserInfoModel

public RunUserInfoModel(RunUserInfoModel src)

RunUserInfoModel

public RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.DelegateUserInfoModel src)
メソッドの詳細

getUserCd

public java.lang.String getUserCd()
ユーザコードを返却します。

戻り値:
ユーザコード

getUserName

public java.lang.String getUserName()
ユーザ名を返却します。

戻り値:
ユーザ名

getProcessCd

public java.lang.String getProcessCd()
プロセスコードを返却します。

戻り値:
プロセスコード

getGroupList

public jp.co.intra_mart.foundation.bpw.model.object.RunGroupListModel getGroupList()
グループ情報リストを返却します。

戻り値:
グループ情報リスト

getAuthorityFlg

public java.lang.String getAuthorityFlg()
処理権限フラグを返却します。

戻り値:
処理権限フラグ
関連項目:
参照権限, 管理権限

getDemandReceiptCd

public java.lang.String getDemandReceiptCd()
依頼要求／受付CDを返却します。

戻り値:
依頼要求／受付CD

getDemandReceiptName

public java.lang.String getDemandReceiptName()
依頼要求／受付名を返却します。

戻り値:
依頼要求／受付名

getApprovalTypeCd

public java.lang.String getApprovalTypeCd()
承認種別CDを返却します。

戻り値:
承認種別CD

getApprovalRightType

public java.lang.String getApprovalRightType()
承認可否種別を返却します。

戻り値:
承認可否種別

getRepresentationType

public java.lang.String getRepresentationType()
代理コード種別を返却します。

戻り値:
承認可否種別

getTransferUserCd

public java.lang.String getTransferUserCd()
振替先ユーザCDを返却します。

戻り値:
振替先ユーザCD

getTransferUserName

public java.lang.String getTransferUserName()
振替先ユーザ名を返却します。

戻り値:
振替先ユーザ名

getRecognitionStatus

public java.lang.String getRecognitionStatus()
承認ステータスを返却します。

戻り値:
承認ステータス

setUserCd

public void setUserCd(java.lang.String string)
ユーザコードを設定します。

パラメータ:
string - ユーザコード

setUserName

public void setUserName(java.lang.String string)
ユーザ名を設定します。

パラメータ:
string - ユーザ名

setProcessCd

public void setProcessCd(java.lang.String string)
プロセスコードを設定します。

パラメータ:
string - プロセスコード

addGroupList

public void addGroupList(jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel model)
グループ情報リストを追加します。

パラメータ:
model - グループ情報

setAuthorityFlg

public void setAuthorityFlg(java.lang.String string)
処理権限フラグを設定します。

パラメータ:
string - 処理権限フラグ
関連項目:
参照権限, 管理権限

setDemandReceiptCd

public void setDemandReceiptCd(java.lang.String string)
依頼要求／受付CDを設定します。

パラメータ:
string - 依頼要求／受付CD

setDemandReceiptName

public void setDemandReceiptName(java.lang.String string)
依頼要求／受付名を設定します。

パラメータ:
string - 依頼要求／受付名

inputCheck

public void inputCheck(java.sql.Connection connection,
                       java.lang.String targetDate)
                throws jp.co.intra_mart.framework.system.exception.SystemException,
                       jp.co.intra_mart.framework.system.exception.ApplicationException
実行主体ユーザ入力情報をチェックするメソッドです。

パラメータ:
connection - DbsConnection
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生

existUserCd

public static void existUserCd(java.sql.Connection connection,
                               java.lang.String userCd,
                               java.lang.String targetDate,
                               java.lang.String invalidErrCd,
                               java.lang.String noExistErrCd)
                        throws jp.co.intra_mart.framework.system.exception.SystemException,
                               jp.co.intra_mart.framework.system.exception.ApplicationException
ユーザコード入力情報をチェックするメソッドです。

パラメータ:
connection - DbsConnection
userCd - ユーザコード
targetDate - チェック対象日付
invalidErrCd - コード不正時エラーコード
noExistErrCd - コード未存在時エラーコード
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生

setApprovalTypeCd

public void setApprovalTypeCd(java.lang.String string)
承認種別CDを設定します。

パラメータ:
string - 承認種別CD

setApprovalRightType

public void setApprovalRightType(java.lang.String string)
承認可否種別を設定します。

パラメータ:
string - 承認可否種別

setRepresentationType

public void setRepresentationType(java.lang.String string)
代理コード種別を設定します。

パラメータ:
string - 承認可否種別

setTransferUserCd

public void setTransferUserCd(java.lang.String string)
振替先ユーザCDを設定します。

パラメータ:
string - 振替先ユーザCD

setTransferUserName

public void setTransferUserName(java.lang.String string)
振替先ユーザ名を設定します。

パラメータ:
string - 振替先ユーザ名

setRecognitionStatus

public void setRecognitionStatus(java.lang.String string)
承認ステータスを設定します。

パラメータ:
string - 承認ステータス

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。 システムで利用されるメソッドです。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserInfo
戻り値:
ログインユーザ情報

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info)
ログイン情報を設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserInfo
パラメータ:
info - ログインユーザ情報

setLoginUserID

public void setLoginUserID(java.lang.String string)
ログインユーザIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserID
パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(java.lang.String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginGroupID
パラメータ:
string - ログイングループID

getLoginUserID

public java.lang.String getLoginUserID()
ログインユーザIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserID
戻り値:
ログインユーザID

getLoginGroupID

public java.lang.String getLoginGroupID()
ログイングループIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginGroupID
戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


VersionInfoModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス VersionInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel
すべての実装インタフェース:
jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF
public class VersionInfoModel
extends java.lang.Object
implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF

履歴情報を保持する情報クラス

フィールドの概要
static java.lang.String | PROCESS_CLASS_BPW プロセス種別コード : ビジネスプロセスワークフロー
static java.lang.String | PROCESS_CLASS_DRW プロセス種別コード : 申請者／承認者ルート作成ワークフロー
static java.lang.String | PROCESS_CLASS_DW プロセス種別コード : ドキュメントワークフロー
static java.lang.String | SUB_PROCESS_INIT サブプロセス識別フラグ : 通常／サブ利用可能プロセス
static java.lang.String | SUB_PROCESS_ONLY サブプロセス識別フラグ : サブ利用特化プロセス
コンストラクタの概要
VersionInfoModel()
コンストラクタ
メソッドの概要
java.lang.String | getCategoryCode() カテゴリコードを返却します。
java.lang.String | getDraftActivityCd() 起票処理コードを返却します。
java.lang.String | getEffectiveDate() 有効日付を返却します。
java.lang.String | getEndDate() 終了日付を返却します。
java.lang.String | getExtensionNameA() 拡張定義名Ａを返却します。
boolean | getExtensionNameAFlag() 拡張定義名Ａ更新対象フラグを返却します。
java.lang.String | getExtensionNameB() 拡張定義名Ｂを返却します。
boolean | getExtensionNameBFlag() 拡張定義名Ｂ更新対象フラグを返却します。
java.lang.String | getExtensionNameC() 拡張定義名Ｃを返却します。
boolean | getExtensionNameCFlag() 拡張定義名Ｃ更新対象フラグを返却します。
java.lang.String | getExtensionNameD() 拡張定義名Ｄを返却します。
boolean | getExtensionNameDFlag() 拡張定義名Ｄ更新対象フラグを返却します。
java.lang.String | getExtensionNameE() 拡張定義名Ｅを返却します。
boolean | getExtensionNameEFlag() 拡張定義名Ｅ更新対象フラグを返却します。
java.lang.String | getExtensionNameF() 拡張定義名Ｆを返却します。
boolean | getExtensionNameFFlag() 拡張定義名Ｆ更新対象フラグを返却します。
java.lang.String | getExtensionNameG() 拡張定義名Ｇを返却します。
boolean | getExtensionNameGFlag() 拡張定義名Ｇ更新対象フラグを返却します。
java.lang.String | getExtensionNameH() 拡張定義名Ｈを返却します。
boolean | getExtensionNameHFlag() 拡張定義名Ｈ更新対象フラグを返却します。
static java.lang.String | getLicense() ライセンスを取得します。
java.lang.String | getLoginGroupID() ログイングループIDを返却します。
java.lang.String | getLoginUserID() ログインユーザIDを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
java.lang.String | getNote() 備考を返却します。
java.lang.String | getProcessClassCode() プロセス種別コードを返却します。
boolean | getProcessClassCodeFlag() プロセス種別コード更新対象フラグを返却します。
java.lang.String | getProcessDefCd() プロセス定義コードを返却します。
java.lang.String | getRecordUserCd() 最終更新者コードを返却します。
java.lang.String | getStartActivityCd() 開始処理コードを返却します。
boolean | getStartActivityCdFlag() 開始処理コード更新対象フラグを返却します。
java.lang.String | getSubProcessFlag() サブプロセス識別フラグを返却します。
boolean | getSubProcessFlagFlag() サブプロセス識別フラグ更新対象フラグを返却します。
java.lang.String | getVersionCd() 履歴コードを返却します。
java.lang.String | getVersionName() 履歴名を返却します。
boolean | getVersionNameFlag() 履歴名更新対象フラグを返却します。
void | inputCheck(java.sql.Connection connection, java.lang.String processDefName) 履歴マスタ入力情報をチェックするメソッドです。
void | setCategoryCode(java.lang.String string) カテゴリコードを設定します。
void | setCreateDate(java.lang.String string) 作成日時を設定します。
void | setCreateUserCd(java.lang.String string) 作成者コードを設定します。
void | setCreateUserName(java.lang.String string) 作成者名を設定します。
void | setDraftActivityCd(java.lang.String string) 起票処理コードを設定します。
void | setEffectiveDate(java.lang.String string) 有効日付を設定します。
void | setEndDate(java.lang.String string) 終了日付を設定します。
void | setExtensionNameA(java.lang.String string) 拡張定義名Ａを設定します。
void | setExtensionNameB(java.lang.String string) 拡張定義名Ｂを設定します。
void | setExtensionNameC(java.lang.String string) 拡張定義名Ｃを設定します。
void | setExtensionNameD(java.lang.String string) 拡張定義名Ｄを設定します。
void | setExtensionNameE(java.lang.String string) 拡張定義名Ｅを設定します。
void | setExtensionNameF(java.lang.String string) 拡張定義名Ｆを設定します。
void | setExtensionNameG(java.lang.String string) 拡張定義名Ｇを設定します。
void | setExtensionNameH(java.lang.String string) 拡張定義名Ｈを設定します。
void | setLoginGroupID(java.lang.String string) ログイングループIDを設定します。
void | setLoginUserID(java.lang.String string) ログイングループIDを設定します。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info) ログイン情報を設定します。
void | setNote(java.lang.String string) 備考を設定します。
void | setProcessClassCode(java.lang.String string) プロセス種別コードを設定します。
void | setProcessDefCd(java.lang.String string) プロセス定義コードを設定します。
void | setRecordDate(java.lang.String string) 最終更新日時を設定します。
void | setRecordUserCd(java.lang.String string) 最終更新者コードを設定します。
void | setRecordUserName(java.lang.String string) 最終更新者名を設定します。
void | setStartActivityCd(java.lang.String string) 開始処理コードを設定します。
void | setSubProcessFlag(java.lang.String string) サブプロセス識別フラグを設定します。
void | setVersionCd(java.lang.String string) 履歴コードを設定します。
void | setVersionName(java.lang.String string) 履歴名を設定します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PROCESS_CLASS_BPW

public static final java.lang.String PROCESS_CLASS_BPW
プロセス種別コード : ビジネスプロセスワークフロー

関連項目:
定数フィールド値

PROCESS_CLASS_DW

public static final java.lang.String PROCESS_CLASS_DW
プロセス種別コード : ドキュメントワークフロー

関連項目:
定数フィールド値

PROCESS_CLASS_DRW

public static final java.lang.String PROCESS_CLASS_DRW
プロセス種別コード : 申請者／承認者ルート作成ワークフロー

関連項目:
定数フィールド値

SUB_PROCESS_INIT

public static final java.lang.String SUB_PROCESS_INIT
サブプロセス識別フラグ : 通常／サブ利用可能プロセス

関連項目:
定数フィールド値

SUB_PROCESS_ONLY

public static final java.lang.String SUB_PROCESS_ONLY
サブプロセス識別フラグ : サブ利用特化プロセス

関連項目:
定数フィールド値
コンストラクタの詳細

VersionInfoModel

public VersionInfoModel()
コンストラクタ

メソッドの詳細

getDraftActivityCd

public java.lang.String getDraftActivityCd()
起票処理コードを返却します。 システムで利用されるメソッドです。

戻り値:
起票処理コード

getVersionNameFlag

public boolean getVersionNameFlag()
履歴名更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
履歴名更新対象フラグ

getStartActivityCdFlag

public boolean getStartActivityCdFlag()
開始処理コード更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
開始処理コード更新対象フラグ

getProcessClassCodeFlag

public boolean getProcessClassCodeFlag()
プロセス種別コード更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス種別コード更新対象フラグ

getSubProcessFlagFlag

public boolean getSubProcessFlagFlag()
サブプロセス識別フラグ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
サブプロセス識別フラグ更新対象フラグ

getExtensionNameAFlag

public boolean getExtensionNameAFlag()
拡張定義名Ａ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ａ更新対象フラグ

getExtensionNameBFlag

public boolean getExtensionNameBFlag()
拡張定義名Ｂ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｂ更新対象フラグ

getExtensionNameCFlag

public boolean getExtensionNameCFlag()
拡張定義名Ｃ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｃ更新対象フラグ

getExtensionNameDFlag

public boolean getExtensionNameDFlag()
拡張定義名Ｄ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｄ更新対象フラグ

getExtensionNameEFlag

public boolean getExtensionNameEFlag()
拡張定義名Ｅ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｅ更新対象フラグ

getExtensionNameFFlag

public boolean getExtensionNameFFlag()
拡張定義名Ｆ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｆ更新対象フラグ

getExtensionNameGFlag

public boolean getExtensionNameGFlag()
拡張定義名Ｇ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｇ更新対象フラグ

getExtensionNameHFlag

public boolean getExtensionNameHFlag()
拡張定義名Ｈ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｈ更新対象フラグ

getExtensionNameA

public java.lang.String getExtensionNameA()
拡張定義名Ａを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ａ

getExtensionNameB

public java.lang.String getExtensionNameB()
拡張定義名Ｂを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｂ

getExtensionNameC

public java.lang.String getExtensionNameC()
拡張定義名Ｃを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｃ

getExtensionNameD

public java.lang.String getExtensionNameD()
拡張定義名Ｄを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｄ

getExtensionNameE

public java.lang.String getExtensionNameE()
拡張定義名Ｅを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｅ

getExtensionNameF

public java.lang.String getExtensionNameF()
拡張定義名Ｆを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｆ

getExtensionNameG

public java.lang.String getExtensionNameG()
拡張定義名Ｇを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｇ

getExtensionNameH

public java.lang.String getExtensionNameH()
拡張定義名Ｈを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｈ

getCategoryCode

public java.lang.String getCategoryCode()
カテゴリコードを返却します。 システムで利用されるメソッドです。

戻り値:
カテゴリコード

getProcessDefCd

public java.lang.String getProcessDefCd()
プロセス定義コードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス定義コード

getEffectiveDate

public java.lang.String getEffectiveDate()
有効日付を返却します。 システムで利用されるメソッドです。

戻り値:
有効日付

getEndDate

public java.lang.String getEndDate()
終了日付を返却します。 システムで利用されるメソッドです。

戻り値:
終了日付

getNote

public java.lang.String getNote()
備考を返却します。 システムで利用されるメソッドです。

戻り値:
備考

getProcessClassCode

public java.lang.String getProcessClassCode()
プロセス種別コードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス種別コード

getSubProcessFlag

public java.lang.String getSubProcessFlag()
サブプロセス識別フラグを返却します。 システムで利用されるメソッドです。

戻り値:
サブプロセス識別フラグ

getRecordUserCd

public java.lang.String getRecordUserCd()
最終更新者コードを返却します。 システムで利用されるメソッドです。

戻り値:
最終更新者コード

getStartActivityCd

public java.lang.String getStartActivityCd()
開始処理コードを返却します。 システムで利用されるメソッドです。

戻り値:
開始処理コード

getVersionCd

public java.lang.String getVersionCd()
履歴コードを返却します。 システムで利用されるメソッドです。

戻り値:
履歴コード

getVersionName

public java.lang.String getVersionName()
履歴名を返却します。 システムで利用されるメソッドです。

戻り値:
履歴名

setDraftActivityCd

public void setDraftActivityCd(java.lang.String string)
起票処理コードを設定します。

パラメータ:
string - 起票処理コード

setExtensionNameA

public void setExtensionNameA(java.lang.String string)
拡張定義名Ａを設定します。

パラメータ:
string - 拡張定義名Ａ

setExtensionNameB

public void setExtensionNameB(java.lang.String string)
拡張定義名Ｂを設定します。

パラメータ:
string - 拡張定義名Ｂ

setExtensionNameC

public void setExtensionNameC(java.lang.String string)
拡張定義名Ｃを設定します。

パラメータ:
string - 拡張定義名Ｃ

setExtensionNameD

public void setExtensionNameD(java.lang.String string)
拡張定義名Ｄを設定します。

パラメータ:
string - 拡張定義名Ｄ

setExtensionNameE

public void setExtensionNameE(java.lang.String string)
拡張定義名Ｅを設定します。

パラメータ:
string - 拡張定義名Ｅ

setExtensionNameF

public void setExtensionNameF(java.lang.String string)
拡張定義名Ｆを設定します。

パラメータ:
string - 拡張定義名Ｆ

setExtensionNameG

public void setExtensionNameG(java.lang.String string)
拡張定義名Ｇを設定します。

パラメータ:
string - 拡張定義名Ｇ

setExtensionNameH

public void setExtensionNameH(java.lang.String string)
拡張定義名Ｈを設定します。

パラメータ:
string - 拡張定義名Ｈ

setCategoryCode

public void setCategoryCode(java.lang.String string)
カテゴリコードを設定します。

パラメータ:
string - カテゴリコード

setProcessDefCd

public void setProcessDefCd(java.lang.String string)
プロセス定義コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - プロセス定義コード

setCreateDate

public void setCreateDate(java.lang.String string)
作成日時を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成日時

setCreateUserCd

public void setCreateUserCd(java.lang.String string)
作成者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成者コード

setCreateUserName

public void setCreateUserName(java.lang.String string)
作成者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成者名

setEffectiveDate

public void setEffectiveDate(java.lang.String string)
有効日付を設定します。

パラメータ:
string - 有効日付

setEndDate

public void setEndDate(java.lang.String string)
終了日付を設定します。

パラメータ:
string - 終了日付

setNote

public void setNote(java.lang.String string)
備考を設定します。

パラメータ:
string - 備考

setProcessClassCode

public void setProcessClassCode(java.lang.String string)
プロセス種別コードを設定します。

パラメータ:
string - プロセス種別コード

setSubProcessFlag

public void setSubProcessFlag(java.lang.String string)
サブプロセス識別フラグを設定します。

パラメータ:
string - サブプロセス識別フラグ

setRecordDate

public void setRecordDate(java.lang.String string)
最終更新日時を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新日時

setRecordUserCd

public void setRecordUserCd(java.lang.String string)
最終更新者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新者コード

setRecordUserName

public void setRecordUserName(java.lang.String string)
最終更新者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新者名

setStartActivityCd

public void setStartActivityCd(java.lang.String string)
開始処理コードを設定します。

パラメータ:
string - 開始処理コード

setVersionCd

public void setVersionCd(java.lang.String string)
履歴コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 履歴コード

setVersionName

public void setVersionName(java.lang.String string)
履歴名を設定します。

パラメータ:
string - 履歴名

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。 システムで利用されるメソッドです。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserInfo
戻り値:
ログインユーザ情報

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info)
ログイン情報を設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserInfo
パラメータ:
info - ログインユーザ情報

setLoginUserID

public void setLoginUserID(java.lang.String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserID
パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(java.lang.String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginGroupID
パラメータ:
string - ログイングループID

getLoginUserID

public java.lang.String getLoginUserID()
ログインユーザIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserID
戻り値:
ログインユーザID

getLoginGroupID

public java.lang.String getLoginGroupID()
ログイングループIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginGroupID
戻り値:
ログイングループID

inputCheck

public void inputCheck(java.sql.Connection connection,
                       java.lang.String processDefName)
                throws jp.co.intra_mart.framework.system.exception.SystemException,
                       jp.co.intra_mart.framework.system.exception.ApplicationException
履歴マスタ入力情報をチェックするメソッドです。

パラメータ:
connection - DBコネクション
processDefName - プロセス定義名
例外:
jp.co.intra_mart.framework.system.exception.SystemException
jp.co.intra_mart.framework.system.exception.ApplicationException

getLicense

public static java.lang.String getLicense()
ライセンスを取得します。

戻り値:
ライセンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


WfeUserInfoModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス WfeUserInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.WfeUserInfoModel
すべての実装インタフェース:
java.io.Serializable, jp.co.intra_mart.framework.base.util.UserInfo
public class WfeUserInfoModel
extends java.lang.Object
implements jp.co.intra_mart.framework.base.util.UserInfo

ワークフロー内の後処理、条件分岐プログラム内で、
J2EE-Frameworkのイベント呼出しを行うための UserInfo を生成します。
この生成された UserInfo を createEvent 時の引数にセットしてください。

関連項目:
直列化された形式

コンストラクタの概要
WfeUserInfoModel()
WfeUserInfoModel(java.lang.String groupID, java.lang.String userID, java.util.Locale locale)
ログイングループID、ユーザID、ロケールをセットして userInfo を生成します。
メソッドの概要
java.lang.String | getClientType() クライアントタイプを返却する。
java.lang.String | getColorPatternID() カラーパターンIDを返却する。
java.lang.String | getEncoding() エンコーディングを返却する。
java.util.Locale | getLocale() ロケールを返却する。
java.lang.String | getLoginGroupID() ログイングループIDを返却する。
java.util.Date | getLoginTime() ログイン時間を返却する。
java.lang.String | getLoginType() ログインタイプを返却する。
java.lang.String | getSignature() ログイン署名を返却する。
java.lang.String | getUrl() ダイレクトURLを返却する。
java.lang.String | getUrlSignature() ダイレクトURL署名を返却する。
java.lang.String | getUserID() ログインユーザIDを返却する。
void | setClientType(java.lang.String string) クライアントタイプを設定する。
void | setColorPatternID(java.lang.String string) カラーパターンIDを設定する。
void | setEncoding(java.lang.String string) エンコーディングを設定する。
void | setLocale(java.util.Locale value) ロケールを設定する。
void | setLoginGroupID(java.lang.String string) ログイングループIDを設定する。
void | setLoginTime(java.util.Date value) ログイン時間を設定する。
void | setLoginType(java.lang.String string) ログインタイプを設定する。
void | setSignature(java.lang.String string) ログイン署名を設定する。
void | setUrl(java.lang.String string) ダイレクトURLを設定する。
void | setUrlSignature(java.lang.String string) ダイレクトURL署名を設定する。
void | setUserID(java.lang.String string) ログインユーザIDを設定する。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

WfeUserInfoModel

public WfeUserInfoModel()

WfeUserInfoModel

public WfeUserInfoModel(java.lang.String groupID,
                        java.lang.String userID,
                        java.util.Locale locale)
ログイングループID、ユーザID、ロケールをセットして userInfo を生成します。

メソッドの詳細

getClientType

public java.lang.String getClientType()
クライアントタイプを返却する。

定義:
インタフェース jp.co.intra_mart.framework.base.util.UserInfo 内の getClientType
戻り値:
String client_type

getColorPatternID

public java.lang.String getColorPatternID()
カラーパターンIDを返却する。

定義:
インタフェース jp.co.intra_mart.framework.base.util.UserInfo 内の getColorPatternID
戻り値:
String color_pattern_id

getEncoding

public java.lang.String getEncoding()
エンコーディングを返却する。

定義:
インタフェース jp.co.intra_mart.framework.base.util.UserInfo 内の getEncoding
戻り値:
String encoding

getLocale

public java.util.Locale getLocale()
ロケールを返却する。

定義:
インタフェース jp.co.intra_mart.framework.base.util.UserInfo 内の getLocale
戻り値:
Locale locale

getLoginGroupID

public java.lang.String getLoginGroupID()
ログイングループIDを返却する。

定義:
インタフェース jp.co.intra_mart.framework.base.util.UserInfo 内の getLoginGroupID
戻り値:
String login_group_id

getLoginTime

public java.util.Date getLoginTime()
ログイン時間を返却する。

定義:
インタフェース jp.co.intra_mart.framework.base.util.UserInfo 内の getLoginTime
戻り値:
Date login_time

getLoginType

public java.lang.String getLoginType()
ログインタイプを返却する。

定義:
インタフェース jp.co.intra_mart.framework.base.util.UserInfo 内の getLoginType
戻り値:
String login_type

getSignature

public java.lang.String getSignature()
ログイン署名を返却する。

戻り値:
String signature

getUrl

public java.lang.String getUrl()
ダイレクトURLを返却する。

戻り値:
String url

getUrlSignature

public java.lang.String getUrlSignature()
ダイレクトURL署名を返却する。

戻り値:
String url_signature

getUserID

public java.lang.String getUserID()
ログインユーザIDを返却する。

定義:
インタフェース jp.co.intra_mart.framework.base.util.UserInfo 内の getUserID
戻り値:
String user_id

setClientType

public void setClientType(java.lang.String string)
クライアントタイプを設定する。

setColorPatternID

public void setColorPatternID(java.lang.String string)
カラーパターンIDを設定する。

setEncoding

public void setEncoding(java.lang.String string)
エンコーディングを設定する。

setLocale

public void setLocale(java.util.Locale value)
ロケールを設定する。

setLoginGroupID

public void setLoginGroupID(java.lang.String string)
ログイングループIDを設定する。

setLoginTime

public void setLoginTime(java.util.Date value)
ログイン時間を設定する。

setLoginType

public void setLoginType(java.lang.String string)
ログインタイプを設定する。

setSignature

public void setSignature(java.lang.String string)
ログイン署名を設定する。

setUrl

public void setUrl(java.lang.String string)
ダイレクトURLを設定する。

setUrlSignature

public void setUrlSignature(java.lang.String string)
ダイレクトURL署名を設定する。

setUserID

public void setUserID(java.lang.String string)
ログインユーザIDを設定する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.Approver の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Approver の使用

jp.co.intra_mart.foundation.wkf.Approver はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.Drafter の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Drafter の使用

jp.co.intra_mart.foundation.wkf.Drafter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.FlowInfo の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.FlowInfo の使用

FlowInfo を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での FlowInfo の使用

FlowInfo を返す jp.co.intra_mart.foundation.wkf のメソッド
FlowInfo | Manager.getFlowInfo(java.lang.String processDefCd, java.lang.String versionCd, java.lang.String activityCd) 特定のタスクの位置情報を保持して、フロー情報を取得する。
FlowInfo | FlowInfo.getFirst() 自分自身のオブジェクトを、最初のタスクに位置している状態に遷移させる
FlowInfo | FlowInfo.getLast() 自分自身のオブジェクトを、最後のタスクに位置している状態に遷移させる

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.Manager の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Manager の使用

jp.co.intra_mart.foundation.wkf.Manager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.NegoModel の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.NegoModel の使用

NegoModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での NegoModel の使用

NegoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
ProcessInfoModel | Drafter.draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
void | Drafter.retry(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 再起票処理を実行します。
void | Drafter.retry(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 再起票処理を実行します。
void | Drafter.cancel(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 取り止め処理を実行します。
void | Drafter.subProcessDraft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Drafter.subProcessDraft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.Boolean isFinish, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd) 承認処理を実行します。
void | Approver.approve(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.Boolean isFinish, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd) 承認処理を実行します。
void | Approver.denial(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 否認処理を実行します。
void | Approver.suspend(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 保留処理を実行します。
void | Approver.sendBack(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String type, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 差し戻し処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.Process の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Process の使用

jp.co.intra_mart.foundation.wkf.Process はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.Reference の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Reference の使用

jp.co.intra_mart.foundation.wkf.Reference はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.Util の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Util の使用

jp.co.intra_mart.foundation.wkf.Util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.support.SearchCondition の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.support.SearchCondition の使用

SearchCondition を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での SearchCondition の使用

SearchCondition 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
java.util.List | Reference.getReferTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 参照可能案件一覧を取得します。
java.util.List | Manager.getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) プロセス一覧情報を取得します。
java.util.List | Drafter.getActivityProcessDefList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, java.lang.String locale) 起票可能プロセス一覧を取得します。
java.util.List | Drafter.getEndProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 起票済み案件を取得します。
java.util.List | Approver.getActivityTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理可能案件(未処理案件)一覧の取得を行います。
java.util.List | Approver.getEndTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理済案件一覧の取得を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.foundation.wkf.support.Sort の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.support.Sort の使用

Sort を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での Sort の使用

Sort 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
java.util.List | Reference.getReferTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 参照可能案件一覧を取得します。
java.util.List | Manager.getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) プロセス一覧情報を取得します。
java.util.List | Drafter.getActivityProcessDefList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, java.lang.String locale) 起票可能プロセス一覧を取得します。
java.util.List | Drafter.getEndProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 起票済み案件を取得します。
java.util.List | Approver.getActivityTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理可能案件(未処理案件)一覧の取得を行います。
java.util.List | Approver.getEndTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理済案件一覧の取得を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.wkf.support (intra-mart ワークフロー)

 jp.co.intra_mart.foundation.wkf.support
クラス
SearchCondition
Sort


jp.co.intra_mart.foundation.wkf.support (intra-mart ワークフロー)

ワークフローモジュール
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.wkf.support

クラスの概要
SearchCondition | プログラムサポート/検索条件設定オブジェクト。
Sort | プログラムサポート/ソート指定オブジェクト。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.wkf.support クラス階層 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.wkf.support の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.wkf.support.SearchCondition
    • class jp.co.intra_mart.foundation.wkf.support.Sort
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.foundation.wkf.support の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.wkf.support の使用

jp.co.intra_mart.foundation.wkf.support を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf により使用される jp.co.intra_mart.foundation.wkf.support のクラス
SearchCondition
プログラムサポート/検索条件設定オブジェクト。
Sort
プログラムサポート/ソート指定オブジェクト。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


SearchCondition (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf.support
クラス SearchCondition

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.support.SearchCondition
public class SearchCondition
extends java.lang.Object

プログラムサポート/検索条件設定オブジェクト。
指定できる検索条件は各検索メソッドの戻り値に指定されている項目のみとなります。

検索キーにて日付関連のキーを指定する場合には、intra-mart日付フォーマット（yyyy/MM/dd|HH:mm:ss）にて、
指定するようにしてください。
各検索項目キーは以下のフィールドを参照してください。

※フィルターについて

フィールドの概要
static java.lang.String | ACTIVITY_CD 処理タスクコードキー
static java.lang.String | ACTIVITY_NAME 処理タスク名キー
static java.lang.String | AGENT_USER_CD 代理依頼元ユーザコードキー
static java.lang.String | AGENT_USER_NAME 代理依頼元ユーザ名キー
static java.lang.String | AGT_COMPLETE_FILTER 完了タスク表示(委譲)キー
static java.lang.String | AGT_GO_FILTER 未処理タスク表示(委譲)キー
static java.lang.String | AGT_PULLBACK_FILTER 引き戻しタスク表示(委譲)キー
static java.lang.String | AGT_SENDBACK_FILTER 差し戻しタスク表示(委譲)キー
static java.lang.String | APPROVAL_COMP_CD 処理者の会社コードキー
static java.lang.String | APPROVAL_DATE_END 処理日(検索範囲終了日)キー
static java.lang.String | APPROVAL_DATE_START 処理日(検索範囲開始日)キー
static java.lang.String | APPROVAL_ORGN_CD 処理者の組織コードキー
static java.lang.String | APPROVAL_ORGN_NAME 処理者の組織名キー
static java.lang.String | APPROVAL_USER_CD 処理者ユーザコードキー
static java.lang.String | APPROVAL_USER_NAME 処理者ユーザ名キー
static java.lang.String | ARRIVE_DATE_END 到達日(検索範囲終了日)キー
static java.lang.String | ARRIVE_DATE_START 到達日(検索範囲開始日)キー
static java.lang.String | BEFORE_USER_CD 前処理者ユーザコードキー
static java.lang.String | BEFORE_USER_NAME 前処理者ユーザ名キー
static java.lang.String | CATEGORY_CD カテゴリコードキー
static java.lang.String | CATEGORY_NAME カテゴリ名キー
static java.lang.String | CLT_AGT_COMPLETE_FILTER 完了タスク表示(代理元承認可委譲)キー
static java.lang.String | CLT_AGT_GO_FILTER 未処理タスク表示(代理元承認可委譲)キー
static java.lang.String | CLT_AGT_PULLBACK_FILTER 引き戻しタスク表示(代理元承認可委譲)キー
static java.lang.String | CLT_AGT_SENDBACK_FILTER 差し戻しタスク表示(代理元承認可委譲)キー
static java.lang.String | COMPLETE_FILTER 完了タスク表示キー
static java.lang.String | DRAFT_APPOINT_DATE 起票指定日キー
static java.lang.String | DRAFT_COMP_CD 起票者の起票会社コードキー
static java.lang.String | DRAFT_DATE_END 起票日(検索範囲終了)キー
static java.lang.String | DRAFT_DATE_START 起票日(検索範囲開始日)キー
static java.lang.String | DRAFT_ORGN_CD 起票者の起票組織コードキー
static java.lang.String | DRAFT_USER_CD 起票ユーザコードキー
static java.lang.String | DRAFT_USER_NAME 起票ユーザ名キー
static java.lang.String | GO_FILTER 未処理タスク表示キー
static java.lang.String | LIMIT_DATE_END 処理期限日(検索範囲終了日)キー
static java.lang.String | LIMIT_DATE_START 処理期限日(検索範囲開始日)キー
static java.lang.String | PROCESS_CD プロセスコードキー
static java.lang.String | PROCESS_DEF_CD プロセス定義コードキー
static java.lang.String | PROCESS_DEF_NAME プロセス定義名キー
static java.lang.String | PROCESS_NAME プロセス名キー
static java.lang.String | PULLBACK_FILTER 引き戻しタスク表示キー
static java.lang.String | SENDBACK_FILTER 差し戻しタスク表示キー
static java.lang.String | VERSION_CD バージョンコードキー
コンストラクタの概要
SearchCondition()
コンストラクタ

メソッドの概要
java.lang.String | getActivityCd() 処理タスクコードを返却します。
java.lang.String | getActivityName() 処理タスク名を返却します。
java.lang.String | getAgentUserCd() 代理依頼元ユーザコードを返却します。
java.lang.String | getAgentUserName() 代理依頼元ユーザ名を返却します。
boolean | getAgtCompFilter() 完了タスク表示(委譲)を返却します。
boolean | getAgtGoFilter() 未処理タスク表示(委譲)を返却します。
boolean | getAgtPullbackFilter() 引戻しタスク表示(委譲)を返却します。
boolean | getAgtSendbackFilter() 差し戻しタスク表示(委譲)を返却します。
java.lang.String | getApprovalCompCd() 処理者の会社コードを返却します。
java.lang.String | getApprovalDateEnd() 処理日(検索範囲終了日)を返却します。
java.lang.String | getApprovalDateStart() 処理日(検索範囲開始日)を返却します。
java.lang.String | getApprovalOrgnCd() 処理者の会社組織コードを返却します。
java.lang.String | getApprovalOrgnName() 処理者の会社組織名を返却します。
java.lang.String | getApprovalUserCd() 処理者ユーザコードを返却します。
java.lang.String | getApprovalUserName() 処理者ユーザ名を返却します。
java.lang.String | getArriveDateEnd() 到達日(検索範囲終了日)を返却します。
java.lang.String | getArriveDateStart() 到達日(検索範囲開始日)を返却します。
java.lang.String | getBeforeUserCd() 前処理者ユーザコードを返却します。
java.lang.String | getBeforeUserName() 前処理者ユーザ名を返却します。
java.lang.String | getCategoryCd() カテゴリコードを返却します。
java.lang.String | getCategoryName() カテゴリ名を返却します。
boolean | getCltAgtCompFilter() 完了タスク表示(代理元処理可委譲)を返却します。
boolean | getCltAgtGoFilter() 未処理タスク表示(代理元処理可委譲)を返却します。
boolean | getCltAgtPullbackFilter() 引戻しタスク表示(代理元処理可委譲)を返却します。
boolean | getCltAgtSendbackFilter() 差し戻しタスク表示(代理元処理可委譲)を返却します。
boolean | getCompFilter() 完了タスク表示を返却します。
java.lang.String | getDraftAppointDate() 起票指定日を返却します。
java.lang.String | getDraftCompCd() 起票者の会社コードを返却します。
java.lang.String | getDraftDateEnd() 起票日(検索範囲終了日)を返却します。
java.lang.String | getDraftDateStart() 起票日(検索範囲開始日)を返却します。
java.lang.String | getDraftOrgnCd() 起票者の会社組織コードを返却します。
java.lang.String | getDraftUserCd() 起票者ユーザコードを返却します。
java.lang.String | getDraftUserName() 起票者ユーザ名を返却します。
boolean | getGoFilter() 未処理タスク表示を返却します。
java.lang.String | getLimitDateEnd() 処理期限日(検索範囲終了日)を返却します。
java.lang.String | getLimitDateStart() 処理期限日(検索範囲開始日)を返却します。
java.lang.String | getProcessCd() プロセスコードを返却します。
java.lang.String | getProcessDefCd() プロセス定義コードを返却します。
java.lang.String | getProcessDefName() プロセス定義名を返却します。
java.lang.String | getProcessName() プロセス名を返却します。
boolean | getPullbackFilter() 引戻しタスク表示を返却します。
boolean | getSendbackFilter() 差し戻しタスク表示を返却します。
java.lang.String | getVersionCd() バージョンコードを返却します。
void | setCondition(java.util.Map conditionMap) 検索条件を設定します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

GO_FILTER

public static java.lang.String GO_FILTER
未処理タスク表示キー

AGT_GO_FILTER

public static java.lang.String AGT_GO_FILTER
未処理タスク表示(委譲)キー

CLT_AGT_GO_FILTER

public static java.lang.String CLT_AGT_GO_FILTER
未処理タスク表示(代理元承認可委譲)キー

PULLBACK_FILTER

public static java.lang.String PULLBACK_FILTER
引き戻しタスク表示キー

AGT_PULLBACK_FILTER

public static java.lang.String AGT_PULLBACK_FILTER
引き戻しタスク表示(委譲)キー

CLT_AGT_PULLBACK_FILTER

public static java.lang.String CLT_AGT_PULLBACK_FILTER
引き戻しタスク表示(代理元承認可委譲)キー

SENDBACK_FILTER

public static java.lang.String SENDBACK_FILTER
差し戻しタスク表示キー

AGT_SENDBACK_FILTER

public static java.lang.String AGT_SENDBACK_FILTER
差し戻しタスク表示(委譲)キー

CLT_AGT_SENDBACK_FILTER

public static java.lang.String CLT_AGT_SENDBACK_FILTER
差し戻しタスク表示(代理元承認可委譲)キー

COMPLETE_FILTER

public static java.lang.String COMPLETE_FILTER
完了タスク表示キー

AGT_COMPLETE_FILTER

public static java.lang.String AGT_COMPLETE_FILTER
完了タスク表示(委譲)キー

CLT_AGT_COMPLETE_FILTER

public static java.lang.String CLT_AGT_COMPLETE_FILTER
完了タスク表示(代理元承認可委譲)キー

CATEGORY_CD

public static java.lang.String CATEGORY_CD
カテゴリコードキー

CATEGORY_NAME

public static java.lang.String CATEGORY_NAME
カテゴリ名キー

PROCESS_DEF_CD

public static java.lang.String PROCESS_DEF_CD
プロセス定義コードキー

PROCESS_DEF_NAME

public static java.lang.String PROCESS_DEF_NAME
プロセス定義名キー

VERSION_CD

public static java.lang.String VERSION_CD
バージョンコードキー

PROCESS_CD

public static java.lang.String PROCESS_CD
プロセスコードキー

PROCESS_NAME

public static java.lang.String PROCESS_NAME
プロセス名キー

ACTIVITY_CD

public static java.lang.String ACTIVITY_CD
処理タスクコードキー

ACTIVITY_NAME

public static java.lang.String ACTIVITY_NAME
処理タスク名キー

DRAFT_USER_CD

public static java.lang.String DRAFT_USER_CD
起票ユーザコードキー

DRAFT_USER_NAME

public static java.lang.String DRAFT_USER_NAME
起票ユーザ名キー

DRAFT_COMP_CD

public static java.lang.String DRAFT_COMP_CD
起票者の起票会社コードキー

DRAFT_ORGN_CD

public static java.lang.String DRAFT_ORGN_CD
起票者の起票組織コードキー

DRAFT_APPOINT_DATE

public static java.lang.String DRAFT_APPOINT_DATE
起票指定日キー

DRAFT_DATE_START

public static java.lang.String DRAFT_DATE_START
起票日(検索範囲開始日)キー

DRAFT_DATE_END

public static java.lang.String DRAFT_DATE_END
起票日(検索範囲終了)キー

BEFORE_USER_CD

public static java.lang.String BEFORE_USER_CD
前処理者ユーザコードキー

BEFORE_USER_NAME

public static java.lang.String BEFORE_USER_NAME
前処理者ユーザ名キー

APPROVAL_USER_CD

public static java.lang.String APPROVAL_USER_CD
処理者ユーザコードキー

APPROVAL_USER_NAME

public static java.lang.String APPROVAL_USER_NAME
処理者ユーザ名キー

APPROVAL_COMP_CD

public static java.lang.String APPROVAL_COMP_CD
処理者の会社コードキー

APPROVAL_ORGN_CD

public static java.lang.String APPROVAL_ORGN_CD
処理者の組織コードキー

APPROVAL_ORGN_NAME

public static java.lang.String APPROVAL_ORGN_NAME
処理者の組織名キー

APPROVAL_DATE_START

public static java.lang.String APPROVAL_DATE_START
処理日(検索範囲開始日)キー

APPROVAL_DATE_END

public static java.lang.String APPROVAL_DATE_END
処理日(検索範囲終了日)キー

AGENT_USER_CD

public static java.lang.String AGENT_USER_CD
代理依頼元ユーザコードキー

AGENT_USER_NAME

public static java.lang.String AGENT_USER_NAME
代理依頼元ユーザ名キー

ARRIVE_DATE_START

public static java.lang.String ARRIVE_DATE_START
到達日(検索範囲開始日)キー

ARRIVE_DATE_END

public static java.lang.String ARRIVE_DATE_END
到達日(検索範囲終了日)キー

LIMIT_DATE_START

public static java.lang.String LIMIT_DATE_START
処理期限日(検索範囲開始日)キー

LIMIT_DATE_END

public static java.lang.String LIMIT_DATE_END
処理期限日(検索範囲終了日)キー

コンストラクタの詳細

SearchCondition

public SearchCondition()
コンストラクタ

メソッドの詳細

setCondition

public void setCondition(java.util.Map conditionMap)
検索条件を設定します。

パラメータ:
conditionMap - 検索条件オブジェクト
conditionMap 検索条件オブジェクト
├go_filter(Boolean) 未処理タスクの表示(本人)
├agt_go_filter(Boolean) 未処理タスクの表示(代理元承認不可)
├clt_agt_go_filter(Boolean) 未処理タスクの表示(代理元承認可)
├pullback_filter(Boolean) 引き戻しタスクの表示(本人)
├agt_pullback_filter(Boolean) 引き戻しタスクの表示(代理元承認不可)
├clt_agt_pullback_filter(Boolean) 引き戻しタスクの表示(代理元承認可)
├sendback_filter(Boolean) 差し戻しタスクの表示(本人)
├agt_sendback_filter(Boolean) 差し戻しタスクの表示(代理元承認不可)
├clt_agt_sendback_filter(Boolean) 差し戻しタスクの表示(代理元承認可)
├complete_filter(Boolean) 完了タスクの表示(本人)
├agt_complete_filter(Boolean) 完了タスクの表示(代理元承認不可)
├clt_agt_complete_filter(Boolean) 完了タスクの表示(代理元承認可)
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├draft_comp_cd(String) 起票者の起票会社コード
├draft_orgn_cd(String) 起票者の起票組織コード
├draft_appoint_date(String) 起票指定日
├draft_date_start(String) 起票日(検索範囲開始日)
├draft_date_end(String) 起票日(検索範囲終了日)
├before_user_cd(String) 前処理者ユーザコード
├before_user_name(String) 前処理者ユーザ名
├approval_user_cd(String) 処理者ユーザコード
├approval_user_name(String) 処理者ユーザ名
├approval_comp_cd(String) 処理者の会社コード
├approval_orgn_cd(String) 処理者の会社組織コード
├approval_orgn_name(String) 処理者の会社組織名
├approval_date_start(String) 処理日(検索範囲開始日)
├approval_date_end(String) 処理日(検索範囲終了日)
├agent_user_cd(String) 代理依頼元ユーザコード
├agent_user_name(String) 代理依頼元ユーザ名
├arrive_date_start(String) 到達日(検索範囲開始日)
├arrive_date_end(String) 到達日(検索範囲終了日)
├limit_date_start(String) 処理期限日(検索範囲開始日)
└limit_date_end(String) 処理期限日(検索範囲終了日)

getGoFilter

public boolean getGoFilter()
未処理タスク表示を返却します。

戻り値:
未処理タスク表示

getAgtGoFilter

public boolean getAgtGoFilter()
未処理タスク表示(委譲)を返却します。

戻り値:
未処理タスク表示(委譲)

getCltAgtGoFilter

public boolean getCltAgtGoFilter()
未処理タスク表示(代理元処理可委譲)を返却します。

戻り値:
未処理タスク表示(代理元処理可委譲)

getPullbackFilter

public boolean getPullbackFilter()
引戻しタスク表示を返却します。

戻り値:
引戻しタスク表示

getAgtPullbackFilter

public boolean getAgtPullbackFilter()
引戻しタスク表示(委譲)を返却します。

戻り値:
引戻しタスク表示(委譲)

getCltAgtPullbackFilter

public boolean getCltAgtPullbackFilter()
引戻しタスク表示(代理元処理可委譲)を返却します。

戻り値:
引戻しタスク表示(代理元処理可委譲)

getSendbackFilter

public boolean getSendbackFilter()
差し戻しタスク表示を返却します。

戻り値:
差し戻しタスク表示

getAgtSendbackFilter

public boolean getAgtSendbackFilter()
差し戻しタスク表示(委譲)を返却します。

戻り値:
未処理タスク表示(委譲)

getCltAgtSendbackFilter

public boolean getCltAgtSendbackFilter()
差し戻しタスク表示(代理元処理可委譲)を返却します。

戻り値:
未処理タスク表示(代理元処理可委譲)

getCompFilter

public boolean getCompFilter()
完了タスク表示を返却します。

戻り値:
完了タスク表示

getAgtCompFilter

public boolean getAgtCompFilter()
完了タスク表示(委譲)を返却します。

戻り値:
完了タスク表示(委譲)

getCltAgtCompFilter

public boolean getCltAgtCompFilter()
完了タスク表示(代理元処理可委譲)を返却します。

戻り値:
完了タスク表示(代理元処理可委譲)

getCategoryCd

public java.lang.String getCategoryCd()
カテゴリコードを返却します。

戻り値:
カテゴリコード

getCategoryName

public java.lang.String getCategoryName()
カテゴリ名を返却します。

戻り値:
カテゴリ名

getProcessDefCd

public java.lang.String getProcessDefCd()
プロセス定義コードを返却します。

戻り値:
プロセス定義コード

getProcessDefName

public java.lang.String getProcessDefName()
プロセス定義名を返却します。

戻り値:
プロセス定義名

getVersionCd

public java.lang.String getVersionCd()
バージョンコードを返却します。

戻り値:
バージョンコード

getProcessCd

public java.lang.String getProcessCd()
プロセスコードを返却します。

戻り値:
プロセスコード

getProcessName

public java.lang.String getProcessName()
プロセス名を返却します。

戻り値:
プロセス名

getActivityCd

public java.lang.String getActivityCd()
処理タスクコードを返却します。

戻り値:
処理タスクコード

getActivityName

public java.lang.String getActivityName()
処理タスク名を返却します。

戻り値:
処理タスク名

getDraftUserCd

public java.lang.String getDraftUserCd()
起票者ユーザコードを返却します。

戻り値:
起票者ユーザコード

getDraftUserName

public java.lang.String getDraftUserName()
起票者ユーザ名を返却します。

戻り値:
起票者ユーザ名

getDraftCompCd

public java.lang.String getDraftCompCd()
起票者の会社コードを返却します。

戻り値:
起票者の会社コード

getDraftOrgnCd

public java.lang.String getDraftOrgnCd()
起票者の会社組織コードを返却します。

戻り値:
起票者の会社組織コード

getDraftAppointDate

public java.lang.String getDraftAppointDate()
起票指定日を返却します。

戻り値:
起票指定日

getDraftDateStart

public java.lang.String getDraftDateStart()
起票日(検索範囲開始日)を返却します。

戻り値:
起票日(検索範囲開始日)

getDraftDateEnd

public java.lang.String getDraftDateEnd()
起票日(検索範囲終了日)を返却します。

戻り値:
起票日(検索範囲終了日)

getBeforeUserCd

public java.lang.String getBeforeUserCd()
前処理者ユーザコードを返却します。

戻り値:
前処理者ユーザコード

getBeforeUserName

public java.lang.String getBeforeUserName()
前処理者ユーザ名を返却します。

戻り値:
前処理者ユーザ名

getApprovalUserCd

public java.lang.String getApprovalUserCd()
処理者ユーザコードを返却します。

戻り値:
処理者ユーザコード

getApprovalUserName

public java.lang.String getApprovalUserName()
処理者ユーザ名を返却します。

戻り値:
処理者ユーザ名

getApprovalCompCd

public java.lang.String getApprovalCompCd()
処理者の会社コードを返却します。

戻り値:
処理者の会社コード

getApprovalOrgnCd

public java.lang.String getApprovalOrgnCd()
処理者の会社組織コードを返却します。

戻り値:
処理者の会社組織コード

getApprovalOrgnName

public java.lang.String getApprovalOrgnName()
処理者の会社組織名を返却します。

戻り値:
処理者の会社組織名

getApprovalDateStart

public java.lang.String getApprovalDateStart()
処理日(検索範囲開始日)を返却します。

戻り値:
処理日(検索範囲開始日)

getApprovalDateEnd

public java.lang.String getApprovalDateEnd()
処理日(検索範囲終了日)を返却します。

戻り値:
処理日(検索範囲終了日)

getAgentUserCd

public java.lang.String getAgentUserCd()
代理依頼元ユーザコードを返却します。

戻り値:
代理依頼元ユーザコード

getAgentUserName

public java.lang.String getAgentUserName()
代理依頼元ユーザ名を返却します。

戻り値:
代理依頼元ユーザ名

getArriveDateStart

public java.lang.String getArriveDateStart()
到達日(検索範囲開始日)を返却します。

戻り値:
到達日(検索範囲開始日)

getArriveDateEnd

public java.lang.String getArriveDateEnd()
到達日(検索範囲終了日)を返却します。

戻り値:
検索範囲終了日

getLimitDateStart

public java.lang.String getLimitDateStart()
処理期限日(検索範囲開始日)を返却します。

戻り値:
処理期限日(検索範囲開始日)

getLimitDateEnd

public java.lang.String getLimitDateEnd()
処理期限日(検索範囲終了日)を返却します。

戻り値:
処理期限日(検索範囲終了日)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Sort (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf.support
クラス Sort

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.support.Sort
public class Sort
extends java.lang.Object

プログラムサポート/ソート指定オブジェクト。
ソート対象は各検索メソッドの戻り値がソート対象となります。

コンストラクタの概要
Sort()
コンストラクタ

メソッドの概要
java.lang.String | getAscending() 昇順ソートキーを返却します。
java.lang.String | getDescending() 降順ソートキーを返却します。
void | setAscending(java.lang.String sort_key) 昇順ソートキーを設定します。
void | setDescending(java.lang.String sort_key) 降順ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Sort

public Sort()
コンストラクタ

メソッドの詳細

getAscending

public java.lang.String getAscending()
昇順ソートキーを返却します。

戻り値:
昇順ソートキー

setAscending

public void setAscending(java.lang.String sort_key)
昇順ソートキーを設定します。
ソート対象は各検索メソッドの戻り値がソート対象となります。
例えば、category_cdを昇順ソートキーとする場合、setAscending(”category_cd”)と記述してください。

パラメータ:
sort_key - 昇順ソートキー

getDescending

public java.lang.String getDescending()
降順ソートキーを返却します。

戻り値:
降順ソートキー

setDescending

public void setDescending(java.lang.String sort_key)
降順ソートキーを設定します。
ソート対象は各検索メソッドの戻り値がソート対象となります。
例えば、category_cdを降順ソートキーとする場合、setDescending(”category_cd”)と記述してください。

パラメータ:
sort_key - 降順ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Approver (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Approver

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Approver
public class Approver
extends java.lang.Object

承認関連のAPI
承認関連の処理に使用されるクラスです。

<サンプル>

フィールドの概要
static java.lang.String | AGT_ALL 代理依頼されたもの全て表示(代理のみ使用)
static java.lang.String | RETURN_TYPE_BEFORE 差戻し種別：前処理者へ差戻し
static java.lang.String | RETURN_TYPE_START 差戻し種別：申請者へ差戻し
コンストラクタの概要
Approver(java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ１(本人用)
Approver(java.lang.String agent_user_cd, java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ２(代理人用)。
メソッドの概要
void | approve(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.Boolean isFinish, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd) 承認処理を実行します。
void | approve(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.Boolean isFinish, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd) 承認処理を実行します。
void | denial(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 否認処理を実行します。
java.util.List | getActivityTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理可能案件(未処理案件)一覧の取得を行います。
java.util.List | getEndTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理済案件一覧の取得を行います。
java.util.List | getTargetDepartment(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd) 所属組織を取得します。
void | noTransaction() データベーストランザクションを未使用にする。
void | pullBack(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd) 引き戻し処理を実行します。
void | sendBack(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String type, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 差し戻し処理を実行します。
void | suspend(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 保留処理を実行します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

AGT_ALL

public static final java.lang.String AGT_ALL
代理依頼されたもの全て表示(代理のみ使用)

関連項目:
定数フィールド値

RETURN_TYPE_START

public static final java.lang.String RETURN_TYPE_START
差戻し種別：申請者へ差戻し

関連項目:
定数フィールド値

RETURN_TYPE_BEFORE

public static final java.lang.String RETURN_TYPE_BEFORE
差戻し種別：前処理者へ差戻し

関連項目:
定数フィールド値
コンストラクタの詳細

Approver

public Approver(java.lang.String user_cd,
                java.lang.String login_group_id)
         throws WKFApplicationException
コンストラクタ１(本人用)

パラメータ:
user_cd - 承認者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード

Approver

public Approver(java.lang.String agent_user_cd,
                java.lang.String user_cd,
                java.lang.String login_group_id)
         throws WKFApplicationException
コンストラクタ２(代理人用)。
代理依頼されたもの全てを表示する際は、user_cdに「Approver.AGT_ALL」を指定してください。
ただし、AGT_ALLを指定すると承認などの一覧検索以外のメソッドは使えません。

パラメータ:
agent_user_cd - 代理承認者のユーザID(必須)
user_cd - 本来の処理者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

noTransaction

public void noTransaction()
データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。

approve

public void approve(java.lang.String process_def_cd,
                    java.lang.String version_cd,
                    java.lang.String process_cd,
                    java.lang.String activity_cd,
                    java.lang.Boolean isFinish,
                    java.lang.String comp_cd,
                    java.lang.String orgn_cd,
                    java.lang.String comment,
                    NegoModel nego,
                    RunExecutiveInfoModel executant,
                    java.lang.String route_select_cd)
             throws WKFApplicationException
承認処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「組織」を指定した場合の使用します。
次承認者が実行時選択になっていない場合は、
  RunExecutiveInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
isFinish - 途中終了フラグ(任意：未指定時は途中終了しない)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
例外:
WKFApplicationException - エラーコード

approve

public void approve(java.lang.String process_def_cd,
                    java.lang.String version_cd,
                    java.lang.String process_cd,
                    java.lang.String activity_cd,
                    java.lang.Boolean isFinish,
                    java.lang.String comp_cd,
                    java.lang.String orgn_cd,
                    java.lang.String comment,
                    NegoModel nego,
                    RunUserInfoModel executant,
                    java.lang.String route_select_cd)
             throws WKFApplicationException
承認処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「ユーザ」を指定した場合に使用します。
次承認者が実行時選択になっていない場合は、
  RunUserInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
isFinish - 途中終了フラグ(任意：未指定時は途中終了しない)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
例外:
WKFApplicationException - エラーコード

denial

public void denial(java.lang.String process_def_cd,
                   java.lang.String version_cd,
                   java.lang.String process_cd,
                   java.lang.String activity_cd,
                   java.lang.String comp_cd,
                   java.lang.String orgn_cd,
                   java.lang.String comment,
                   NegoModel nego)
            throws WKFApplicationException
否認処理を実行します。
処理失敗時は、Exceptionを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
例外:
WKFApplicationException - エラーコード

suspend

public void suspend(java.lang.String process_def_cd,
                    java.lang.String version_cd,
                    java.lang.String process_cd,
                    java.lang.String activity_cd,
                    java.lang.String comp_cd,
                    java.lang.String orgn_cd,
                    java.lang.String comment,
                    NegoModel nego)
             throws WKFApplicationException
保留処理を実行します。
処理失敗時は、Exceptiopnを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
例外:
WKFApplicationException - エラーコード

sendBack

public void sendBack(java.lang.String process_def_cd,
                     java.lang.String version_cd,
                     java.lang.String process_cd,
                     java.lang.String activity_cd,
                     java.lang.String type,
                     java.lang.String comp_cd,
                     java.lang.String orgn_cd,
                     java.lang.String comment,
                     NegoModel nego)
              throws WKFApplicationException
差し戻し処理を実行します。
処理失敗時は、Exceptiopnを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
type - 差戻し先(必須 start:申請者,before:前処理者)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
例外:
WKFApplicationException - エラーコード

pullBack

public void pullBack(java.lang.String process_def_cd,
                     java.lang.String version_cd,
                     java.lang.String process_cd,
                     java.lang.String activity_cd)
              throws WKFApplicationException
引き戻し処理を実行します。
処理失敗時は、Exceptiopnを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
例外:
WKFApplicationException - エラーコード

getActivityTaskList

public java.util.List getActivityTaskList(SearchCondition condition_key,
                                          Sort[] sort_key,
                                          int start,
                                          int amount)
処理可能案件(未処理案件)一覧の取得を行います。
処理可能案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List 処理可能案件情報オブジェクト配列
Map 処理可能案件オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls_cd(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├activity_status(String) アクティビティステータス
├attainment_class(String) 到達種別
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├reception_date(String) 受信日付
├process_term_date(String) 処理期限日付
├transfer_flg(Boolean) 代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String) 代理依頼先対象(本人用でインスタンス作成時)
├agent_cd(String) 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
├agent_name(String) 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
├client_user_cd(String) 代理依頼元ユーザコード(代理人用でインスタンス作成時)
├client_user_name(String) 代理依頼元ユーザ名(代理人用でインスタンス作成時)
├next_activity_type(String) 次タスクのタスク種別
└compulsion_end_flg(Boolean) 強制終了可否フラグ

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getEndTaskList

public java.util.List getEndTaskList(SearchCondition condition_key,
                                     Sort[] sort_key,
                                     int start,
                                     int amount)
処理済案件一覧の取得を行います。
処理済案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List 処理済案件情報オブジェクト配列
Map 処理済案件情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls_cd(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├draft_user_comp_cd(String) 起票者の処理時の会社コード
├draft_user_orgn_cd(String) 起票者の処理時の組織コード
├draft_user_main_flg(String) 主・副所属フラグ
├isJunction(Boolean) ルートが同期していればtrue
├approval_type(String) 処理結果
├approval_user_cd(String) 処理ユーザコード
├approval_user_name(String) 処理ユーザ名
├approval_date(String) 処理日
├approval_transfer_flg(Boolean) 承認結果履歴代理フラグ
├processing_status(String) 現在の状態
├approval_agent_user_cd(String) 承認代理元ユーザコード(代理人用でインスタンス作成時)
├approval_agent_user_name(String) 承認代理元ユーザ名(代理人用でインスタンス作成時)
├transfer_flg(Boolean) 代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String) 代理依頼先対象(本人用でインスタンス作成時)
├agent_cd(String) 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
├agent_name(String) 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
└pull_activity_flg(Boolean) 引き戻し可否フラグ(true:可/false:不可)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getTargetDepartment

public java.util.List getTargetDepartment(java.lang.String process_def_cd,
                                          java.lang.String version_cd,
                                          java.lang.String process_cd,
                                          java.lang.String activity_cd)
所属組織を取得します。
処理時の所属組織として選択できる組織を取得します。
審議時など、既にプロセスコードがふられているに使用します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
戻り値:
所属組織情報オブジェクト配列 Map 所属組織情報オブジェクト
├company_cd(String) 会社コード
├department_cd(String) 組織コード
└department_name(String) 組織名

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Drafter (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Drafter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Drafter
public class Drafter
extends java.lang.Object

起票関連のAPI
起票関連の処理に使用されるクラスです。

<サンプル>

フィールドの概要
static java.lang.String AGT_ALL
代理依頼されたもの全て表示(代理のみ使用)
コンストラクタの概要
Drafter(java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ１(本人用)
Drafter(java.lang.String agent_user_cd, java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ２(代理人用)。
メソッドの概要
void | cancel(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego) 取り止め処理を実行します。
ProcessInfoModel | draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
ProcessInfoModel | draft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 起票処理を実行します。
java.util.List | getActivityProcessDefList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, java.lang.String locale) 起票可能プロセス一覧を取得します。
java.util.List | getEndProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 起票済み案件を取得します。
java.util.List | getTargetDepartment(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String activity_cd, java.lang.String target_date) 所属組織を取得します。
void | noTransaction() データベーストランザクションを未使用にする。
void | pullBack(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd) 引戻し処理を実行します。
void | retry(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 再起票処理を実行します。
void | retry(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String process_name, java.util.List app_key, java.lang.String draft_appoint_date, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd, java.lang.String locale) 再起票処理を実行します。
void | subProcessDraft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunExecutiveInfoModel executant, java.lang.String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | subProcessDraft(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.lang.String process_temporary_cd, java.lang.String process_name, java.util.List app_key, java.lang.String comp_cd, java.lang.String orgn_cd, java.lang.String comment, NegoModel nego, RunUserInfoModel executant, java.lang.String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

AGT_ALL

public static final java.lang.String AGT_ALL
代理依頼されたもの全て表示(代理のみ使用)

関連項目:
定数フィールド値
コンストラクタの詳細

Drafter

public Drafter(java.lang.String user_cd,
               java.lang.String login_group_id)
        throws WKFApplicationException
コンストラクタ１(本人用)

パラメータ:
user_cd - 起票者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード

Drafter

public Drafter(java.lang.String agent_user_cd,
               java.lang.String user_cd,
               java.lang.String login_group_id)
        throws WKFApplicationException
コンストラクタ２(代理人用)。
代理依頼されたもの全てを表示する際は、user_cdに「Drafter.AGT_ALL」を指定してください。
ただし、AGT_ALLを指定すると承認などの一覧検索以外のメソッドは使えません。

パラメータ:
agent_user_cd - 代理起票者のユーザID(必須)
user_cd - 本来の起票者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

noTransaction

public void noTransaction()
データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。

draft

public ProcessInfoModel draft(java.lang.String process_def_cd,
                              java.lang.String version_cd,
                              java.lang.String process_temporary_cd,
                              java.lang.String process_name,
                              java.util.List app_key,
                              java.lang.String draft_appoint_date,
                              java.lang.String comp_cd,
                              java.lang.String orgn_cd,
                              java.lang.String comment,
                              NegoModel nego,
                              RunExecutiveInfoModel executant,
                              java.lang.String route_select_cd,
                              java.lang.String locale)
                       throws WKFApplicationException
起票処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「組織」を指定した場合に使用します。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
次承認者が実行時選択になっていない場合は、
  RunExecutiveInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：未指定時は起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
戻り値:
ProcessInfoModel プロセス情報
例外:
WKFApplicationException - エラーコード

draft

public ProcessInfoModel draft(java.lang.String process_def_cd,
                              java.lang.String version_cd,
                              java.lang.String process_temporary_cd,
                              java.lang.String process_name,
                              java.util.List app_key,
                              java.lang.String draft_appoint_date,
                              java.lang.String comp_cd,
                              java.lang.String orgn_cd,
                              java.lang.String comment,
                              NegoModel nego,
                              RunUserInfoModel executant,
                              java.lang.String route_select_cd,
                              java.lang.String locale)
                       throws WKFApplicationException
起票処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「ユーザ」を指定した場合に使用します。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
次承認者が実行時選択になっていない場合は、
  RunUserInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：未指定時は起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
戻り値:
ProcessInfoModel プロセス情報
例外:
WKFApplicationException - エラーコード

retry

public void retry(java.lang.String process_def_cd,
                  java.lang.String version_cd,
                  java.lang.String process_cd,
                  java.lang.String process_name,
                  java.util.List app_key,
                  java.lang.String draft_appoint_date,
                  java.lang.String comp_cd,
                  java.lang.String orgn_cd,
                  java.lang.String comment,
                  NegoModel nego,
                  RunExecutiveInfoModel executant,
                  java.lang.String route_select_cd,
                  java.lang.String locale)
           throws WKFApplicationException
再起票処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「組織」を指定した場合の使用します。
次承認者が実行時選択になっていない場合は、
  RunExecutiveInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 再起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
route_select_cd - ルート選択番号(引戻しされたタスクで、次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
例外:
WKFApplicationException - エラーコード

retry

public void retry(java.lang.String process_def_cd,
                  java.lang.String version_cd,
                  java.lang.String process_cd,
                  java.lang.String process_name,
                  java.util.List app_key,
                  java.lang.String draft_appoint_date,
                  java.lang.String comp_cd,
                  java.lang.String orgn_cd,
                  java.lang.String comment,
                  NegoModel nego,
                  RunUserInfoModel executant,
                  java.lang.String route_select_cd,
                  java.lang.String locale)
           throws WKFApplicationException
再起票処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「ユーザ」を指定した場合の使用します。
次承認者が実行時選択になっていない場合は、
  RunUserInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 再起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
route_select_cd - ルート選択番号(引戻しされたタスクで、次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
例外:
WKFApplicationException - エラーコード

cancel

public void cancel(java.lang.String process_def_cd,
                   java.lang.String version_cd,
                   java.lang.String process_cd,
                   java.lang.String comp_cd,
                   java.lang.String orgn_cd,
                   java.lang.String comment,
                   NegoModel nego)
            throws WKFApplicationException
取り止め処理を実行します。
処理失敗時は、Exceptionを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 取り止めコメント(任意)
nego - 根回しメールオブジェクト(任意)
例外:
WKFApplicationException - エラーコード

pullBack

public void pullBack(java.lang.String process_def_cd,
                     java.lang.String version_cd,
                     java.lang.String process_cd)
              throws WKFApplicationException
引戻し処理を実行します。
処理失敗時は、Exceptionを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
例外:
WKFApplicationException - エラーコード

getActivityProcessDefList

public java.util.List getActivityProcessDefList(SearchCondition condition_key,
                                                Sort[] sort_key,
                                                int start,
                                                int amount,
                                                java.lang.String locale)
起票可能プロセス一覧を取得します。
起票可能プロセスオブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
起票指定日を指定する場合は検索条件オブジェクトの「draft_appoint_date」に起票指定日を設定してください。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
locale - ロケール(任意：なければデフォルトロケールを使用)
戻り値:
List 起票可能プロセスオブジェクト配列
Map 起票可能プロセスオブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) 起票可能な最新バージョンコード
├version_name(String) 起票可能な最新バージョン名
├version_note(String) 起票可能な最新バージョンの備考
├effective_date(String) 有効日付
├end_date(String) 終了日付
├process_cls_cd(String) プロセス種別コード
├activity_cd(String) 開始アクティビティコード
├transfer_flg(Boolean) 代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String) 代理依頼先対象(本人用でインスタンス作成時)
├agent_comp_cd(String) 代理依頼先会社コード(本人用でインスタンス作成時)
├agent_cd(String) 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
├agent_name(String) 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
├client_user_cd(String) 代理依頼元ユーザコード(代理人用でインスタンス作成時)
└client_user_name(String) 代理依頼元ユーザ名(代理人用でインスタンス作成時)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getEndProcessList

public java.util.List getEndProcessList(SearchCondition condition_key,
                                        Sort[] sort_key,
                                        int start,
                                        int amount)
起票済み案件を取得します。
起票済み案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List 起票済み案件情報オブジェクト配列
Map 起票済み案件情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls_cd(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├activity_cd(String) アクティビティコード(isJunction=trueのときはnull)
├activity_name(String) アクティビティ名(isJunction=trueのときはnull)
├activity_status(String) アクティビティステータス(isJunction=trueのときはnull)
├attainment_class(String) 到達種別(isJunction=trueのときはnull)
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├draft_user_comp_cd(String) 起票者の処理時の会社コード
├draft_user_orgn_cd(String) 起票者の処理時の組織コード
├draft_user_main_flg(String) 主・副所属フラグ
├isJunction(Boolean) ルートが同期していればtrue
├now_approval_name(String) 現処理ユーザ/組織/オフィシャルG/ロール名(isJunction=trueのときはnull)
├reception_date(String) 受信日付
├process_term_date(String) 処理期限日付
├transfer_flg(Boolean) 代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String) 代理依頼先対象(本人用でインスタンス作成時)
├agent_cd(String) 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
├agent_name(String) 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
├client_user_cd(String) 代理依頼元ユーザコード(代理人用でインスタンス作成時)
├client_user_name(String) 代理依頼元ユーザ名(代理人用でインスタンス作成時)
└pull_activity_flg(Boolean) 引き戻し可否フラグ(true:可/false:不可)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

subProcessDraft

public void subProcessDraft(java.lang.String process_def_cd,
                            java.lang.String version_cd,
                            java.lang.String process_cd,
                            java.lang.String activity_cd,
                            java.lang.String process_temporary_cd,
                            java.lang.String process_name,
                            java.util.List app_key,
                            java.lang.String comp_cd,
                            java.lang.String orgn_cd,
                            java.lang.String comment,
                            NegoModel nego,
                            RunExecutiveInfoModel executant,
                            java.lang.String route_select_cd)
                     throws WKFApplicationException
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「組織」を指定した場合に使用します。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
次承認者が実行時選択になっていない場合は、
  RunExecutiveInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
例外:
WKFApplicationException - エラーコード

subProcessDraft

public void subProcessDraft(java.lang.String process_def_cd,
                            java.lang.String version_cd,
                            java.lang.String process_cd,
                            java.lang.String activity_cd,
                            java.lang.String process_temporary_cd,
                            java.lang.String process_name,
                            java.util.List app_key,
                            java.lang.String comp_cd,
                            java.lang.String orgn_cd,
                            java.lang.String comment,
                            NegoModel nego,
                            RunUserInfoModel executant,
                            java.lang.String route_select_cd)
                     throws WKFApplicationException
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「ユーザ」を指定した場合に使用します。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
次承認者が実行時選択になっていない場合は、
  RunUserInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
例外:
WKFApplicationException - エラーコード

getTargetDepartment

public java.util.List getTargetDepartment(java.lang.String process_def_cd,
                                          java.lang.String version_cd,
                                          java.lang.String activity_cd,
                                          java.lang.String target_date)
所属組織を取得します。
処理時の所属組織として選択できる組織を取得します。
起票時など、プロセスコードがふられていない時に使用します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
activity_cd - アクティビティコード(必須)
target_date - 起票指定日(任意：指定なしの場合はシステム日付)
戻り値:
所属組織情報オブジェクト配列 Map 所属組織情報オブジェクト
├company_cd(String) 会社コード
├department_cd(String) 組織コード
└department_name(String) 組織名

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


FlowInfo (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス FlowInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.FlowInfo
public class FlowInfo
extends java.lang.Object

フロー情報オブジェクト
特定のタスクの位置情報を保持した、フロー情報を取得する。

<サンプル>

コンストラクタの概要
FlowInfo()
コンストラクタ
メソッドの概要
java.lang.String | getActivityCd() アクティビティコードを返却します。
java.lang.String | getActivityType() アクティビティ種別を返却します。
boolean | getEndFlg() 分岐終了フラグを返却します。
FlowInfo | getFirst() 自分自身のオブジェクトを、最初のタスクに位置している状態に遷移させる
boolean | getIsSubProcess() サブプロセスフラグを返却します。
FlowInfo | getLast() 自分自身のオブジェクトを、最後のタスクに位置している状態に遷移させる
java.util.List | getNext() 自分自身のオブジェクトを、次のタスクに位置している状態に遷移させる。
java.util.List | getPrev() 自分自身のオブジェクトを、前のタスクに位置している状態に遷移させる。
java.lang.String | getProcessDefCd() プロセス定義コードを返却します。
java.lang.String | getVersionCd() バージョンコードを返却します。
boolean | hasNext() 次のタスクが存在するかどうかを返却する。
boolean | hasPrev() 前のタスクが存在するかどうかを返却する。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FlowInfo

public FlowInfo()
コンストラクタ

メソッドの詳細

hasNext

public boolean hasNext()
次のタスクが存在するかどうかを返却する。

戻り値:
boolean 存在:true 存在しない:false

hasPrev

public boolean hasPrev()
前のタスクが存在するかどうかを返却する。

戻り値:
boolean 存在:true 存在しない:false

getNext

public java.util.List getNext()
                       throws jp.co.intra_mart.framework.system.exception.SystemException,
                              jp.co.intra_mart.framework.system.exception.ApplicationException
自分自身のオブジェクトを、次のタスクに位置している状態に遷移させる。
（同期でルートが複数存在する場合、同期結合まで各ルートが同時に次タスクに状態遷移する）

戻り値:
List FlowInfoオブジェクト配列
例外:
jp.co.intra_mart.framework.system.exception.SystemException
jp.co.intra_mart.framework.system.exception.ApplicationException

getPrev

public java.util.List getPrev()
                       throws jp.co.intra_mart.framework.system.exception.SystemException,
                              jp.co.intra_mart.framework.system.exception.ApplicationException
自分自身のオブジェクトを、前のタスクに位置している状態に遷移させる。
（同期でルートが複数存在する場合、同期結合まで各ルートが同時に次タスクに状態遷移する）

戻り値:
List FlowInfoオブジェクト配列
例外:
jp.co.intra_mart.framework.system.exception.SystemException
jp.co.intra_mart.framework.system.exception.ApplicationException

getFirst

public FlowInfo getFirst()
自分自身のオブジェクトを、最初のタスクに位置している状態に遷移させる

戻り値:
FlowInfo 最初のタスクオブジェクト

getLast

public FlowInfo getLast()
自分自身のオブジェクトを、最後のタスクに位置している状態に遷移させる

戻り値:
FlowInfo 最後のタスクオブジェクト

getProcessDefCd

public java.lang.String getProcessDefCd()
プロセス定義コードを返却します。

戻り値:
String プロセス定義コード

getVersionCd

public java.lang.String getVersionCd()
バージョンコードを返却します。

戻り値:
String バージョンコード

getActivityCd

public java.lang.String getActivityCd()
アクティビティコードを返却します。

戻り値:
String アクティビティコード

getActivityType

public java.lang.String getActivityType()
アクティビティ種別を返却します。

戻り値:
String アクティビティ種別

getEndFlg

public boolean getEndFlg()
分岐終了フラグを返却します。

戻り値:
boolean 分岐終了フラグ(分岐と同期の終わる時点を表示するフラグ)

getIsSubProcess

public boolean getIsSubProcess()
サブプロセスフラグを返却します。

戻り値:
boolean サブプロセスフラグ(サブプロセスの場合true)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Manager (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Manager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Manager
public class Manager
extends java.lang.Object

マスタ関連のAPI
マスタメンテナンス関連処理で使用されるクラスです。
ワークフロー管理者用のロールを持つユーザのみ使用できるクラスです。

<サンプル>

コンストラクタの概要
Manager(java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ
カテゴリの編集権限ロールをもつユーザを指定してください。
メソッドの概要
byte[] | exportProcessDef(java.util.ArrayList process_def_cd) プロセス定義(Excel形式)をエクスポートします。
java.util.Map | getActivityInfo(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String activity_cd) プロセス定義コード、バージョンコード、アクティビティコードをキーに タスク(アクティビティ)情報を取得します。
java.util.Map | getCategoryInfo(java.lang.String category_cd) カテゴリコードをキーにしてカテゴリ情報を取得します。
java.util.List | getCategoryInfoByName(java.lang.String category_name) カテゴリ名をキーにしてカテゴリ情報を取得します。
FlowInfo | getFlowInfo(java.lang.String processDefCd, java.lang.String versionCd, java.lang.String activityCd) 特定のタスクの位置情報を保持して、フロー情報を取得する。
java.util.Map | getProcessDefInfo(java.lang.String process_def_cd) プロセス定義コードをキーにしてプロセス定義情報を取得します。
java.util.List | getProcessDefInfoByName(java.lang.String process_def_name) プロセス定義名をキーにしてプロセス定義情報を取得します。
java.util.Map | getProcessDefInfoByVersion(java.lang.String process_def_cd, java.lang.String version_cd) プロセス定義コード、バージョンコードをキーにしてプロセス定義情報を取得します。
java.util.List | getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) プロセス一覧情報を取得します。
java.util.Map | getVersionInfo(java.lang.String process_def_cd, java.lang.String version_cd) バージョン(ルート)情報を取得します。
java.util.List | importProcessDef(java.lang.Object xls_file) プロセス定義(Excel形式)をインポートします。
void | noTransaction() データベーストランザクションを未使用にする。
void | removeProcess(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.Boolean xml_out_flg) 案件を削除を実行します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Manager

public Manager(java.lang.String user_cd,
               java.lang.String login_group_id)
        throws WKFApplicationException
コンストラクタ
カテゴリの編集権限ロールをもつユーザを指定してください。

パラメータ:
user_cd - ユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

noTransaction

public void noTransaction()
データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。

getProcessList

public java.util.List getProcessList(SearchCondition condition_key,
                                     Sort[] sort_key,
                                     int start,
                                     int amount)
プロセス一覧情報を取得します。
プロセス情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List プロセス情報オブジェクト配列
Map プロセス情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls_cd(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├activity_status(String) アクティビティステータス
├attainment_class(String) 到達種別
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├now_approval_name(String) 現処理ユーザ/組織名
├reception_date(String) 受信日付
└process_term_date(String) 処理期限日付

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

removeProcess

public void removeProcess(java.lang.String process_def_cd,
                          java.lang.String version_cd,
                          java.lang.String process_cd,
                          java.lang.Boolean xml_out_flg)
                   throws WKFApplicationException
案件を削除を実行します。
このAPIを使用した場合、案件の状態に関係なく削除を行います。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
xml_out_flg - XML出力フラグ(必須)
例外:
WKFApplicationException - エラーコード

importProcessDef

public java.util.List importProcessDef(java.lang.Object xls_file)
                                throws WKFApplicationException
プロセス定義(Excel形式)をインポートします。
処理ステータスオブジェクトを返却します。

パラメータ:
xls_file - ファイルオブジェクト(必須)
戻り値:
List 処理ステータスオブジェクト配列
Map 処理ステータスオブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├process_def_name(String) プロセス定義名
├sheet_name(String) シート名（Excelのシート名）
├status(String) 処理結果ID
└message(String) 処理結果メッセージ
例外:
WKFApplicationException

exportProcessDef

public byte[] exportProcessDef(java.util.ArrayList process_def_cd)
                        throws WKFApplicationException
プロセス定義(Excel形式)をエクスポートします。
エクセルデータファイルを返却します。

パラメータ:
process_def_cd - プロセス定義コード配列(必須)
戻り値:
byte[] エクセルデータファイル
例外:
WKFApplicationException

getCategoryInfo

public java.util.Map getCategoryInfo(java.lang.String category_cd)
カテゴリコードをキーにしてカテゴリ情報を取得します。
カテゴリ情報オブジェクトを返却します。

パラメータ:
category_cd - カテゴリコード(必須)
戻り値:
Object カテゴリ情報オブジェクト Map カテゴリ情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├category_note(String) 備考
├edit_athorities(List) 編集権限リスト。(各要素はロールIDの文字列(String))
└processing_authorities(List) 処理権限リスト。(各要素はロールIDの文字列(String))

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getCategoryInfoByName

public java.util.List getCategoryInfoByName(java.lang.String category_name)
カテゴリ名をキーにしてカテゴリ情報を取得します。
カテゴリ情報オブジェクト配列を返却します。
パラメータにnull または "" を指定するとカテゴリ情報の一覧が取得できます。

パラメータ:
category_name - カテゴリ名(任意)
戻り値:
List カテゴリ情報オブジェクト配列 Map カテゴリ情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├category_note(String) 備考
├edit_authorities(List) 編集権限リスト。(各要素はロールIDの文字列(String))
└processing_authorities(List) 処理権限リスト。(各要素はロールIDの文字列(String))

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getProcessDefInfo

public java.util.Map getProcessDefInfo(java.lang.String process_def_cd)
                                throws WKFApplicationException,
                                       jp.co.intra_mart.framework.system.exception.SystemException
プロセス定義コードをキーにしてプロセス定義情報を取得します。
プロセス定義情報オブジェクトを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
戻り値:
Object プロセス定義オブジェクト
Map プロセス定義オブジェクト
├category_cd(String) カテゴリコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├note(String) 備考
├new_version_cd(String) 最新バージョンコード
├process_count(Int) プロセス数
└activity_process_count(Int) アクティブなプロセス数
例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessDefInfoByName

public java.util.List getProcessDefInfoByName(java.lang.String process_def_name)
                                       throws WKFApplicationException,
                                              jp.co.intra_mart.framework.system.exception.SystemException
プロセス定義名をキーにしてプロセス定義情報を取得します。
プロセス定義情報オブジェクト配列を返却します。
パラメータにnull または "" を指定するとプロセス定義情報の一覧が取得できます。

パラメータ:
process_def_name - プロセス定義名(任意)
戻り値:
List プロセス定義情報オブジェクト配列 Map プロセス定義オブジェクト
├category_cd(String) カテゴリコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├note(String) 備考
├new_version_cd(String) 最新バージョンコード
├process_count(Int) プロセス数
└activity_process_count(Int) アクティブなプロセス数
例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessDefInfoByVersion

public java.util.Map getProcessDefInfoByVersion(java.lang.String process_def_cd,
                                                java.lang.String version_cd)
                                         throws WKFApplicationException,
                                                jp.co.intra_mart.framework.system.exception.SystemException
プロセス定義コード、バージョンコードをキーにしてプロセス定義情報を取得します。
プロセス定義情報オブジェクトを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
戻り値:
Map プロセス定義情報オブジェクト Map プロセス定義オブジェクト
├category_cd(String) カテゴリコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├note(String) 備考
├version_cd(String) バージョンコード
├process_count(Int) プロセス数
└activity_process_count(Int) アクティブなプロセス数
例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getVersionInfo

public java.util.Map getVersionInfo(java.lang.String process_def_cd,
                                    java.lang.String version_cd)
バージョン(ルート)情報を取得します。
バージョン情報オブジェクトを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
戻り値:
Object バージョン情報オブジェクト
Map バージョン情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├note(String) 備考
├start_date(String) 開始日付
├end_date(String) 終了日付
├root_type(String) ルート種別
├contents_path(Map) コンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      ├service_id(String) サービスID(page_kindがframeworkの場合)
      └tab_cd(String) タブコード(page_kindがポータルの場合)
├pull_back_contents_path(Map) 引き戻しコンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      ├service_id(String) サービスID(page_kindがframeworkの場合)
      └tab_cd(String) タブコード(page_kindがポータルの場合)
├return_contents_path(Map) 差し戻しコンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      ├service_id(String) サービスID(page_kindがframeworkの場合)
      └tab_cd(String) タブコード(page_kindがポータルの場合)
├refer_contents_path(Map) 参照コンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      ├service_id(String) サービスID(page_kindがframeworkの場合)
      └tab_cd(String) タブコード(page_kindがポータルの場合)
└detail_contents_path(Map) 詳細コンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      ├service_id(String) サービスID(page_kindがframeworkの場合)
      └tab_cd(String) タブコード(page_kindがポータルの場合)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getActivityInfo

public java.util.Map getActivityInfo(java.lang.String process_def_cd,
                                     java.lang.String version_cd,
                                     java.lang.String activity_cd)
プロセス定義コード、バージョンコード、アクティビティコードをキーに
タスク(アクティビティ)情報を取得します。
タスク(アクティビティ)情報オブジェクトを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須：０マスクしないで指定)
activity_cd - アクティビティコード(必須)
戻り値:
Object タスク情報オブジェクト Map タスク情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├activity_cd(String) アクティビティコード
├activiyty_name(String) アクティビティ名
├activity_type_cd(String) アクティビティ種別

(アクティビティ種別がRECEIVEの場合)
├compulsion_end_flag(Boolean) 終了可能フラグ
├return_flag(Boolean) 差し戻し/引き戻しフラグ
├return_mail_flag(Boolean) 差し戻しメールフラグ
├post_processing_flg(Boolean) 後処理使用フラグ
├post_processing_program(String) 後処理プログラム名
├run_user(List) 対象者情報(MapObjectの配列)
      ├run_type(String) 対象者種別
      ├run_cd(String) 対象者コード
      ├run_group_cd(String) 対象グループコード(対象者種別が組織の場合)
      ├run_role_restrict(String) ロールによる絞込みのロールID(対象者種別が組織の場合)
      └run_post_restrict(String) 役職による絞込みの役職コード(対象者種別が組織の場合)
├refer_user(List) 参照者情報(MapObjectの配列)
      ├run_type(String) 対象者種別
      ├run_cd(String) 対象者コード
      ├run_group_cd(String) 対象グループコード(対象者種別が組織の場合)
      ├run_role_restrict(String) ロールによる絞込みのロールID(対象者種別が組織の場合)
      └run_post_restrict(String) 役職による絞込みの役職コード(対象者種別が組織の場合)
├contents_path(Map) コンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      ├service_id(String) サービスID(page_kindがframeworkの場合)
      └tab_cd(String) タブコード(page_kindがポータルの場合)
├pull_back_contents_path(Map) 引き戻しコンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      ├service_id(String) サービスID(page_kindがframeworkの場合)
      └tab_cd(String) タブコード(page_kindがポータルの場合)
├return_contents_path(Map) 差し戻しコンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      ├service_id(String) サービスID(page_kindがframeworkの場合)
      └tab_cd(String) タブコード(page_kindがポータルの場合)
├auto_pass(Int) 期日による自動パス設定の日数
├auto_pass_executive(Map) 対象者による自動パス設定情報
      ├executive_flg(Boolean) 自動パスフラグ
      └executive_user(List) 自動パス対象者情報配列(MapObjectの配列)
            ├executive_type(String) 対象者種別
            ├executive_cd(String) 対象者コード
            ├executive_group_cd(String) 対象グループコード(対象者種別が組織の場合)
            ├executive_role_restrict(String) ロールによる絞込みのロールID(対象者種別が組織の場合)
            └executive_post_restrict(String) 役職による絞込みの役職コード(対象者種別が組織の場合)
├reminder(Map) 催促メール情報
      ├reminder_flg(Boolean) 催促メール使用フラグ
      └reminder_date(String) 催促猶予日数

(アクティビティ種別がFLOWの場合)
├combine_class(String) 条件結合クラス

(アクティビティ種別がINVOKE_AUTOの場合)
├run_class(String) 自動実行クラス

(アクティビティ種別がINVOKE_EVENTの場合)
├event_id(String) イベントID

(アクティビティ種別がINVOKE_PROCESSの場合)
├call_process_def_cd(String) 呼出しプロセス定義コード
├draft_type_kind(String) 起票タイプ

(アクティビティ種別がSWITCHの場合)
├switch_info(List) 実行クラス情報(MapObjectの配列。配列の順番に評価されます。)
      ├condition_no(Int) 実行比較番号(配列の要素番号と同じ)
      ├run_activity_cd(String) 次に実行されるタスクのアクティビティコード
      └run_class(String) 実行クラス

(アクティビティ種別がMULTIの場合)
└route_info(List) ルート情報(MapObjectの配列。)
      ├select_route_no(String) ルート選択番号
      ├select_route_name(String) ルート名
      ├select_route_cd(String) 呼出先のアクティビティコード
      └isCreateRoute(Boolean) 次タスクがルート作成かどうかを取得します。(true:ルート作成/false:その他)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getFlowInfo

public FlowInfo getFlowInfo(java.lang.String processDefCd,
                            java.lang.String versionCd,
                            java.lang.String activityCd)
                     throws WKFApplicationException
特定のタスクの位置情報を保持して、フロー情報を取得する。
フロー情報オブジェクトについては、FlowInfoクラスを参照してください。

パラメータ:
processDefCd - プロセス定義コード
versionCd - バージョンコード
activityCd - アクティビティコード（NULL可）
戻り値:
object(FlowInfo)　フロー情報オブジェクト
例外:
WKFApplicationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


NegoModel (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス NegoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.NegoModel
public class NegoModel
extends java.lang.Object

BPWModelIFを保持するリストクラス

フィールドの概要
static java.lang.String | MAIL_USER_ADDRESS
static java.lang.String | MAIL_USER_CD 送信先ユーザコードキー
static java.lang.String | MAIL_USER_NAME
コンストラクタの概要
NegoModel()
コンストラクタ

メソッドの概要
void | addUserList(java.util.Map map) 根回しメール送信者リストに情報を追加します。
java.lang.String | getComment() 根回しメール本文を返却します。
java.lang.String | getTitle() 根回しメールタイトルを返却します。
java.util.ArrayList | getUserList() 根回しメール送信者リストを返却します。
void | setComment(java.lang.String string) 根回しメール本文を設定します。
void | setTitle(java.lang.String string) 根回しメールタイトルを設定します。
void | setUserList(java.util.ArrayList list) 根回しメール送信者リストを設定します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MAIL_USER_CD

public static final java.lang.String MAIL_USER_CD
送信先ユーザコードキー

関連項目:
定数フィールド値

MAIL_USER_ADDRESS

public static final java.lang.String MAIL_USER_ADDRESS
関連項目:
定数フィールド値

MAIL_USER_NAME

public static final java.lang.String MAIL_USER_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

NegoModel

public NegoModel()
コンストラクタ

メソッドの詳細

getUserList

public java.util.ArrayList getUserList()
根回しメール送信者リストを返却します。

戻り値:
根回しメール送信者リスト

addUserList

public void addUserList(java.util.Map map)
根回しメール送信者リストに情報を追加します。
システムで利用されるメソッドです。

パラメータ:
map - メール送信者情報 Map メール送信者情報オブジェクト
└cd(String) 送信先ユーザコード

getTitle

public java.lang.String getTitle()
根回しメールタイトルを返却します。

戻り値:
根回しメールタイトル

setUserList

public void setUserList(java.util.ArrayList list)
根回しメール送信者リストを設定します。

パラメータ:
list - メール送信者情報配列 Map メール送信者情報オブジェクト
└cd(String) 送信先ユーザコード

setTitle

public void setTitle(java.lang.String string)
根回しメールタイトルを設定します。

パラメータ:
string - タイトル

setComment

public void setComment(java.lang.String string)
根回しメール本文を設定します。

パラメータ:
string - 本文

getComment

public java.lang.String getComment()
根回しメール本文を返却します。

戻り値:
根回しメール本文
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.wkf (intra-mart ワークフロー)

 jp.co.intra_mart.foundation.wkf
クラス
Approver
Drafter
FlowInfo
Manager
NegoModel
Process
Reference
Util


jp.co.intra_mart.foundation.wkf (intra-mart ワークフロー)

ワークフローモジュール
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.wkf

クラスの概要
Approver | 承認関連のAPI 承認関連の処理に使用されるクラスです。
Drafter | 起票関連のAPI 起票関連の処理に使用されるクラスです。
FlowInfo | フロー情報オブジェクト 特定のタスクの位置情報を保持した、フロー情報を取得する。
Manager | マスタ関連のAPI マスタメンテナンス関連処理で使用されるクラスです。
NegoModel | BPWModelIFを保持するリストクラス
Process | 案件関連のAPI 案件関連の情報取得などに使用されるクラスです。
Reference | 参照関連のAPI 参照案件の取得などに使用されるクラスです。
Util | ユーティリティ バッチ起動用クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.foundation.wkf クラス階層 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.wkf の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.wkf.Approver
    • class jp.co.intra_mart.foundation.wkf.Drafter
    • class jp.co.intra_mart.foundation.wkf.FlowInfo
    • class jp.co.intra_mart.foundation.wkf.Manager
    • class jp.co.intra_mart.foundation.wkf.NegoModel
    • class jp.co.intra_mart.foundation.wkf.Process
    • class jp.co.intra_mart.foundation.wkf.Reference
    • class jp.co.intra_mart.foundation.wkf.Util
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.foundation.wkf の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.wkf の使用

jp.co.intra_mart.foundation.wkf を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf により使用される jp.co.intra_mart.foundation.wkf のクラス
FlowInfo
フロー情報オブジェクト
特定のタスクの位置情報を保持した、フロー情報を取得する。
NegoModel
BPWModelIFを保持するリストクラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Process (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Process

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Process
public class Process
extends java.lang.Object

案件関連のAPI
案件関連の情報取得などに使用されるクラスです。

<サンプル>

コンストラクタの概要
Process(java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String login_group_id)
コンストラクタ
メソッドの概要
java.util.List | getFileList() 添付ファイル一覧を取得します。
java.util.List | getFlow() プロセス上の現在位置を取得します。
java.util.Iterator | getProcessHistory() 案件の処理履歴を取得します。
java.util.Map | getProcessInfo() プロセス情報を取得します。
java.util.Map | getTaskResultInfo(java.lang.String activity_cd) タスク処理結果情報を取得します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Process

public Process(java.lang.String process_def_cd,
               java.lang.String version_cd,
               java.lang.String process_cd,
               java.lang.String login_group_id)
        throws WKFApplicationException
コンストラクタ

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

getFileList

public java.util.List getFileList()
添付ファイル一覧を取得します。
添付ファイル一覧を返却します。

戻り値:
List 添付ファイルオブジェクト
Map 添付ファイルオブジェクト
├path(String) ファイルパス(storageからの相対パス)
├file_cd(String) ファイルID
├file_name(String) ファイル名（論理ファイル名）
└file_size(Int) ファイルサイズ(バイト)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getProcessHistory

public java.util.Iterator getProcessHistory()
案件の処理履歴を取得します。
案件の処理履歴オブジェクトを返却します。

戻り値:
Iterator 案件の処理履歴情報オブジェクト配列
Map 処理履歴情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├process_cd(String) プロセスコード
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├activity_status(String) アクティビティステータス
├activity_type(String) アクティビティ種別(常に"処理タスク"(RECEIVE)となります。)
├call_process_cd(String) 親プロセスコード
├status_ended_date(String) ステータス完了日付
├approval_date(String) 承認日
├approval_user_cd(String) 承認者コード
├approval_user_name(String) 承認者名
├approval_type(String) 承認種別
├comp_cd(String) 処理者の処理時の会社コード
├orgn_cd(String) 処理者の処理時の組織コード
├orgn_name(String) 処理者の処理時の組織名
├main_flg(Boolean) 主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）
├commnet(String) 承認時のコメント
├agent_tran_flg(String) 代理_振替えフラグ
├agent_tran_user_cd(String) 代理_振替元ユーザコード
└agent_tran_user_name(String) 代理_振替元ユーザ名

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getFlow

public java.util.List getFlow()
プロセス上の現在位置を取得します。
現在位置情報オブジェクトを返却します。

戻り値:
List 現在位置情報オブジェクト配列
Map 現在位置情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├process_cd(String) プロセスコード
└activity_cd(String) アクティビティコード

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getProcessInfo

public java.util.Map getProcessInfo()
プロセス情報を取得します。
プロセス情報オブジェクトを返却します。

戻り値:
Object プロセス情報オブジェクト
Map プロセス情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├parent_activity_cd(String) 親アクティビティコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├last_man_activity(String) 最終手動アクティビティコード
├last_man_activity_result(String) 最終手動アクティビティ承認結果種別
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├draft_comment(String) 起票時コメント
└app_key(List) アプリケーションキー配列(StringObjectの配列)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getTaskResultInfo

public java.util.Map getTaskResultInfo(java.lang.String activity_cd)
                                throws WKFApplicationException
タスク処理結果情報を取得します。
タスク処理結果情報オブジェクトを返却します。

パラメータ:
activity_cd - アクティビティコード(必須)
戻り値:
Object タスク処理結果情報オブジェクト
Map タスク処理結果情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├process_cd(String) プロセスコード
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├activity_type(String) アクティビティ種別(常に"処理タスク"(RECEIVE)となります。)
├activity_status(String) アクティビティステータス
├attainment_class(String) 到達種別
├activity_status_comp_date(String) ステータス完了日付
├reception_date(String) 受信日付
├process_term_date(String) 処理期限日付
├approval_type(String) 処理結果
├approval_user_cd(String) 処理ユーザコード
├approval_user_name(String) 処理ユーザ名
├approval_comment(String) 処理時コメント
├approval_date(String) 処理日
├auto_pass_term(String) 自動パス（バッチ）期限
├auto_pass_flag(String) 自動パス（バッチ）処理フラグ
├present_process(String) 現処理表示文字
├transfer_flg(String) 代理依頼フラグ
├delegate_flag(String) 振り替えフラグ
├agent_target(String) 代理依頼先対象(ユーザ/会社組織)
├agent_comp_cd(String) 代理依頼先会社コード（代理に組織を指定時）
├agent_cd(String) 代理依頼先ユーザ/組織コード
├agent_name(String) 代理依頼先ユーザ/組織名
├client_user_cd(String) 代理依頼元ユーザコード
├client_user_name(String) 代理依頼元ユーザ名
├comp_cd(String) 処理者の処理時の会社コード
├orgn_cd(String) 処理者の処理時の組織コード
└main_flg(Boolean) 主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）
例外:
WKFApplicationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Reference (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Reference

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Reference
public class Reference
extends java.lang.Object

参照関連のAPI
参照案件の取得などに使用されるクラスです。

<サンプル>

コンストラクタの概要
Reference(java.lang.String user_cd, java.lang.String login_group_id)
コンストラクタ
メソッドの概要
 java.util.List getReferTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount)
参照可能案件一覧を取得します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Reference

public Reference(java.lang.String user_cd,
                 java.lang.String login_group_id)
          throws WKFApplicationException
コンストラクタ

パラメータ:
user_cd - 参照者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

getReferTaskList

public java.util.List getReferTaskList(SearchCondition condition_key,
                                       Sort[] sort_key,
                                       int start,
                                       int amount)
参照可能案件一覧を取得します。
参照可能案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト配列(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List 参照可能案件情報オブジェクト配列
Map 参照可能案件情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
└draft_user_name(String) 起票者名

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


Util (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Util

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Util
public class Util
extends java.lang.Object

ユーティリティ バッチ起動用クラス

コンストラクタの概要
Util(java.lang.String login_group_id)
コンストラクタ
メソッドの概要
void | autoPass(java.lang.String category_cd, java.lang.String process_def_cd, java.lang.String version_cd, int date) 案件の自動パス(バッチ起動)処理を行います。
void | autoPress(java.lang.String category_cd, java.lang.String process_def_cd, java.lang.String version_cd, int date) 案件の自動催促(バッチ起動)処理を行います。
void | sendMail(java.lang.String template_path, java.lang.String process_def_cd, java.lang.String version_cd, java.lang.String process_cd, java.lang.String activity_cd, java.util.ArrayList to, java.util.ArrayList cc, java.util.ArrayList bcc) メール送信処理を行います。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Util

public Util(java.lang.String login_group_id)
     throws WKFApplicationException
コンストラクタ

パラメータ:
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

sendMail

public void sendMail(java.lang.String template_path,
                     java.lang.String process_def_cd,
                     java.lang.String version_cd,
                     java.lang.String process_cd,
                     java.lang.String activity_cd,
                     java.util.ArrayList to,
                     java.util.ArrayList cc,
                     java.util.ArrayList bcc)
              throws WKFApplicationException
メール送信処理を行います。
メール送信結果を返却します。

パラメータ:
template_path - テンプレートパス(必須)
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
to - Toメールアドレス配列
cc - Ccメールアドレス配列
bcc - Bccメールアドレス配列
例外:
WKFApplicationException - エラーコード

autoPass

public void autoPass(java.lang.String category_cd,
                     java.lang.String process_def_cd,
                     java.lang.String version_cd,
                     int date)
              throws WKFApplicationException
案件の自動パス(バッチ起動)処理を行います。

パラメータ:
category_cd - カテゴリコード(任意：未指定時全カテゴリ)
process_def_cd - プロセス定義コード(任意：未指定時全プロセス定義)
version_cd - 履歴コード(任意：未指定時全バージョン)
date - 承認期限の延長日数(任意)
例外:
WKFApplicationException - エラーコード

autoPress

public void autoPress(java.lang.String category_cd,
                      java.lang.String process_def_cd,
                      java.lang.String version_cd,
                      int date)
               throws WKFApplicationException
案件の自動催促(バッチ起動)処理を行います。

パラメータ:
category_cd - カテゴリコード(任意：未指定時全カテゴリ)
process_def_cd - プロセス定義コード(任意：未指定時全プロセス定義)
version_cd - 履歴コード(任意：未指定時全バージョン)
date - 承認期限の延長日数(任意)
例外:
WKFApplicationException - エラーコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.system.bpw.MailTemplateAnalizer の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.system.bpw.MailTemplateAnalizer の使用

jp.co.intra_mart.system.bpw.MailTemplateAnalizer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス jp.co.intra_mart.system.bpw.WfeResultMailManager の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.system.bpw.WfeResultMailManager の使用

jp.co.intra_mart.system.bpw.WfeResultMailManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


MailTemplateAnalizer (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.bpw
クラス MailTemplateAnalizer

java.lang.Object
    拡張 jp.co.intra_mart.system.bpw.MailTemplateAnalizer
public class MailTemplateAnalizer
extends java.lang.Object

フィールドの概要
static java.lang.String | IWM_DEFINE_BCC テンプレート内指定キー“Bcc”
static java.lang.String | IWM_DEFINE_BODY テンプレート内指定キー“Body”
static java.lang.String | IWM_DEFINE_CC テンプレート内指定キー“Cc”
static java.lang.String | IWM_DEFINE_FROM テンプレート内指定キー“From”
static java.lang.String | IWM_DEFINE_REPLAY テンプレート内指定キー“Reply-To”
static java.lang.String | IWM_DEFINE_SUBJECT テンプレート内指定キー“Subject”
static java.lang.String | IWM_DEFINE_TO テンプレート内指定キー“To”
メソッドの概要
static java.util.HashMap | getInstance(java.lang.String key) 指定されたキーのメールテンプレートファイルを読み込み、テンプレート情報を取得します。
static java.util.HashMap | getInstanceByName(java.lang.String path) 指定されたメールテンプレートファイルを読み込み、テンプレートの情報を返却します。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

IWM_DEFINE_TO

public static java.lang.String IWM_DEFINE_TO
テンプレート内指定キー“To”

IWM_DEFINE_FROM

public static java.lang.String IWM_DEFINE_FROM
テンプレート内指定キー“From”

IWM_DEFINE_CC

public static java.lang.String IWM_DEFINE_CC
テンプレート内指定キー“Cc”

IWM_DEFINE_BCC

public static java.lang.String IWM_DEFINE_BCC
テンプレート内指定キー“Bcc”

IWM_DEFINE_REPLAY

public static java.lang.String IWM_DEFINE_REPLAY
テンプレート内指定キー“Reply-To”

IWM_DEFINE_SUBJECT

public static java.lang.String IWM_DEFINE_SUBJECT
テンプレート内指定キー“Subject”

IWM_DEFINE_BODY

public static java.lang.String IWM_DEFINE_BODY
テンプレート内指定キー“Body”

メソッドの詳細

getInstance

public static java.util.HashMap getInstance(java.lang.String key)
                                     throws jp.co.intra_mart.framework.system.exception.SystemException
指定されたキーのメールテンプレートファイルを読み込み、テンプレート情報を取得します。
ＢＰＷ内部用プロパティーファイルより指定されたキーに対するメールテンプレートファイルを読み込み、 テンプレート情報を取得します。
システム内で利用されるメソッドとなります。

パラメータ:
key - 取得するテンプレートファイルのキー
戻り値:
HashMap テンプレートファイル情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

getInstanceByName

public static java.util.HashMap getInstanceByName(java.lang.String path)
                                           throws jp.co.intra_mart.framework.system.exception.SystemException
指定されたメールテンプレートファイルを読み込み、テンプレートの情報を返却します。
StorageService からのメールテンプレート相対パスを指定してください。

パラメータ:
path - テンプレートパス
戻り値:
HashMap テンプレートファイル情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.system.bpw (intra-mart ワークフロー)

 jp.co.intra_mart.system.bpw
クラス
MailTemplateAnalizer
WfeResultMailManager


jp.co.intra_mart.system.bpw (intra-mart ワークフロー)

ワークフローモジュール
前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.system.bpw

クラスの概要
MailTemplateAnalizer |
WfeResultMailManager | ワークフローエンジン内にて結果送信メール（テンプレート）の送信情報の管理保持を行う。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のパッケージ 次のパッケージ フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


jp.co.intra_mart.system.bpw クラス階層 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.system.bpw の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.system.bpw.MailTemplateAnalizer
    • class jp.co.intra_mart.system.bpw.WfeResultMailManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


パッケージ jp.co.intra_mart.system.bpw の使用 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.system.bpw の使用

jp.co.intra_mart.system.bpw はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


WfeResultMailManager (intra-mart ワークフロー)

ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.bpw
クラス WfeResultMailManager

java.lang.Object
    拡張 jp.co.intra_mart.system.bpw.WfeResultMailManager
public class WfeResultMailManager
extends java.lang.Object

ワークフローエンジン内にて結果送信メール（テンプレート）の送信情報の管理保持を行う。

コンストラクタの概要
WfeResultMailManager()
メソッドの概要
static void | addReserveInfo(jp.co.intra_mart.foundation.bpw.model.object.BPWSendMailInfo info) 送信メール情報を追加設定します。
static java.util.HashMap | getMailTamplate() 設定されたメールテンプレートを取得します。
static java.util.ArrayList | getReserveInfo() 送信されるメール内容情報を取得します。
static boolean | isReserve() メール予約機能使用有無を判定します。
static boolean | isStop() テンプレートメールの送信抑止を判定します。
static void | removeInfo() 共有メモリ内のメール設定情報を削除します。
static void | reserveCancel() メール予約機能の使用を取消します。
static void | reserveRequest() メール予約機能の使用を依頼します。
static void | send() メールの送信を実行します。
static void | setMailTamplate(java.util.HashMap template) メールテンプレートの設定を行います。
static void | setReserveInfo(java.util.ArrayList infoList) 送信メール情報を設定します。
static void | setTamplateRequest(java.lang.String templatePath) メールテンプレートの設定を行います。
static void | stopCancel() テンプレートメールの送信停止を取り止めます。
static void | stopRequest() 同一スレッド内のテンプレートメールの標準送信を停止させます。
クラス java.lang.Object から継承したメソッド
equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

WfeResultMailManager

public WfeResultMailManager()
メソッドの詳細

isReserve

public static boolean isReserve()
                         throws jp.co.intra_mart.framework.system.exception.SystemException
メール予約機能使用有無を判定します。

戻り値:
boolean true(予約機能を使用する)/false(使用しない)
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

reserveRequest

public static void reserveRequest()
                           throws jp.co.intra_mart.framework.system.exception.SystemException
メール予約機能の使用を依頼します。
処理が正常終了した場合にのみテンプレートメールが送信されるように、メール予約を行います。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

reserveCancel

public static void reserveCancel()
                          throws jp.co.intra_mart.framework.system.exception.SystemException
メール予約機能の使用を取消します。
reserveRequest()を使用してメール予約の設定をしてある場合、そのメール予約を取り消します。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

isStop

public static boolean isStop()
                      throws jp.co.intra_mart.framework.system.exception.SystemException
テンプレートメールの送信抑止を判定します。

戻り値:
boolean true(抑止あり)/false(なし)
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

stopRequest

public static void stopRequest()
                        throws jp.co.intra_mart.framework.system.exception.SystemException
同一スレッド内のテンプレートメールの標準送信を停止させます。
テンプレートメールの標準送信機能を停止させたい場合に使用します。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

stopCancel

public static void stopCancel()
                       throws jp.co.intra_mart.framework.system.exception.SystemException
テンプレートメールの送信停止を取り止めます。
stopRequest()を使用してテンプレートメールの送信停止の設定をしてある場合、
その送信停止の設定を取り止め、解除します。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

getMailTamplate

public static java.util.HashMap getMailTamplate()
                                         throws jp.co.intra_mart.framework.system.exception.SystemException
設定されたメールテンプレートを取得します。
メールテンプレートの設定が行われている場合に、設定されたメールテンプレートを取得します。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

setTamplateRequest

public static void setTamplateRequest(java.lang.String templatePath)
                               throws jp.co.intra_mart.framework.system.exception.SystemException
メールテンプレートの設定を行います。
テンプレートメールの送信時に送信されるメールのテンプレートを変更したいときに使用します。
StorageService からのメールテンプレート相対パスを指定してください。

パラメータ:
templatePath - テンプレートパス
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

setMailTamplate

public static void setMailTamplate(java.util.HashMap template)
                            throws jp.co.intra_mart.framework.system.exception.SystemException
メールテンプレートの設定を行います。
テンプレートメールの送信時に送信されるメールのテンプレートを変更したいときに使用します。

パラメータ:
template - テンプレートファイル情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

getReserveInfo

public static java.util.ArrayList getReserveInfo()
                                          throws jp.co.intra_mart.framework.system.exception.SystemException
送信されるメール内容情報を取得します。
システム内で利用されるメソッドとなります。

戻り値:
送信メール情報オブジェクト
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

addReserveInfo

public static void addReserveInfo(jp.co.intra_mart.foundation.bpw.model.object.BPWSendMailInfo info)
                           throws jp.co.intra_mart.framework.system.exception.SystemException
送信メール情報を追加設定します。
システム内で利用されるメソッドとなります。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

setReserveInfo

public static void setReserveInfo(java.util.ArrayList infoList)
                           throws jp.co.intra_mart.framework.system.exception.SystemException
送信メール情報を設定します。
システム内で利用されるメソッドとなります。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

send

public static void send()
                 throws jp.co.intra_mart.framework.system.exception.SystemException
メールの送信を実行します。
送信予約されているメールがある場合に、そのメールの送信を行います。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

removeInfo

public static void removeInfo()
                       throws jp.co.intra_mart.framework.system.exception.SystemException
共有メモリ内のメール設定情報を削除します。
システム内で利用されるメソッドとなります。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


すべてのクラス (intra-mart ワークフロー)

 すべてのクラス
ActivityInfoModel
Approver
BPWErrorCodeIF
BPWExecuteLogic
ConditionAdapter
ConditionModel
Drafter
EISModelStaticIF
FlowInfo
MailTemplateAnalizer
Manager
NegoModel
Process
ProcessInfoModel
RecognitionInfoModel
Reference
RunExecutiveInfoModel
RunUserInfoModel
SearchCondition
Sort
Util
VersionInfoModel
WKFApplicationException
WKFErrorCodeIF
WfeResultMailManager


定数フィールド値 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF
public static final java.lang.String | BPW_C_ALREADY_EXIST_TRANSFER | "BPW_Core_Alredy_Exist_Transfer"
public static final java.lang.String | BPW_C_ALREADY_SUSPEND | "BPW_Core_Already_Suspend"
public static final java.lang.String | BPW_C_AUTO_EXECUTE_FAULT | "BPW_Core_Auto_Execute_Fault"
public static final java.lang.String | BPW_C_CAN_NOT_START_JAVASCRIPT | "BPW_Core_Can_Not_Start_JavaScript"
public static final java.lang.String | BPW_C_CAN_NOT_TRANSFER | "BPW_Core_Can_Not_Transfer"
public static final java.lang.String | BPW_C_CHANGE_INFO | "BPW_Core_Chenge_Info"
public static final java.lang.String | BPW_C_CHANGING_NOW | "BPW_Core_Changing_Now"
public static final java.lang.String | BPW_C_DATA_NOT_FOUND | "BPW_Core_Data_Not_Found"
public static final java.lang.String | BPW_C_DUPLICATE_NAME | "BPW_Core_Duplicate_Name"
public static final java.lang.String | BPW_C_EXIST_PROCESS_DEF | "BPW_Core_Exist_ProcessDef"
public static final java.lang.String | BPW_C_FAILED_GET_HTTP_EXCEL_STREAM | "BPW_Core_Failed_Get_ExcelFileStream"
public static final java.lang.String | BPW_C_FAILED_READ_EXCEL_STREAM | "BPW_Core_Failed_Get_ExcelFileStream"
public static final java.lang.String | BPW_C_FOUND_AUTO_PASS_TABLE | "BPW_Core_Found_AutoPassTable"
public static final java.lang.String | BPW_C_FOUND_PROCESS | "BPW_Core_Found_Process"
public static final java.lang.String | BPW_C_FOUND_RECEIVE_MASTER | "BPW_Core_Found_ReceiveMaster"
public static final java.lang.String | BPW_C_FOUND_RECEIVE_TABLE | "BPW_Core_Found_ReceiveTable"
public static final java.lang.String | BPW_C_FOUND_RUN_USER_TABLE | "BPW_Core_Found_RunUserTable"
public static final java.lang.String | BPW_C_FOUND_RUNNING_PROCESS | "BPW_Core_Found_Running_Process"
public static final java.lang.String | BPW_C_FOUND_VERSION | "BPW_Core_Found_Version"
public static final java.lang.String | BPW_C_HAVE_NOT_AUTHORITY | "BPW_Core_Have_Not_Authority"
public static final java.lang.String | BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND | "BPW_Core_Have_Not_Authority_or_Data_Not_Found"
public static final java.lang.String | BPW_C_ILLIGAL_STATUS | "BPW_Core_Illigal_Status"
public static final java.lang.String | BPW_C_ILLIGAL_STATUS_CHG | "BPW_Core_Illigal_Status_Change"
public static final java.lang.String | BPW_C_IMPORT_AUTO_PASS_ORGS | "BPW_Core_Import_AutoPass_Orgs"
public static final java.lang.String | BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER | "BPW_Core_Import_Can_Not_Set_Run_Refer"
public static final java.lang.String | BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD | "BPW_Core_Import_Change_ProcessClassCd"
public static final java.lang.String | BPW_C_IMPORT_DUPLICATE_APPROVAL_CD | "BPW_Core_Import_Duplicate_Approval_Cd"
public static final java.lang.String | BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE | "BPW_Core_Import_Cuplicate_ContentsType"
public static final java.lang.String | BPW_C_IMPORT_DUPLICATE_PROCESS_CONTENTSTYPE | "BPW_Core_Import_Cuplicate_ProcessContentsType"
public static final java.lang.String | BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION | "BPW_Core_Import_Duplicate_ProcessDefinition"
public static final java.lang.String | BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID | "BPW_Core_Import_Cuplicate_RootDefId"
public static final java.lang.String | BPW_C_IMPORT_DUPLICATE_SEND_TO_ID | "BPW_Core_Import_Duplicate_Send_To_Id"
public static final java.lang.String | BPW_C_IMPORT_DUPLICATE_TASK_ID | "BPW_Core_Import_Duplicate_Task_Id"
public static final java.lang.String | BPW_C_IMPORT_INVALID_ACTIVITY_TYPE | "BPW_Core_Import_Invalid_Activity_Type"
public static final java.lang.String | BPW_C_IMPORT_INVALID_APPLICATION_ID | "BPW_Core_Import_Invalid_ApplitionID"
public static final java.lang.String | BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN | "BPW_Core_Import_Invalid_ApplicationID_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_APPROVAL | "BPW_Core_Import_Invalid_Approval"
public static final java.lang.String | BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG | "BPW_Core_Import_Invalid_Approval_After_ShortestEndFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_APPROVAL_FOCUS | "BPW_Core_Import_Invalid_Approval_Focus"
public static final java.lang.String | BPW_C_IMPORT_INVALID_APPROVAL_OBJECT | "BPW_Core_Import_Invalid_ApprovalObject"
public static final java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD | "BPW_Core_Import_Invalid_AutoPassExecutivePostCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND | "BPW_Core_Import_Invalid_AutoPassExecutivePostCdKind"
public static final java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_FLG | "BPW_Core_Import_Invalid_AutoPassFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS | "BPW_Core_Import_Invalid_AutoPass_Focus"
public static final java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_TERM | "BPW_Core_Import_Invalid_AutoPassTerm"
public static final java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN | "BPW_Core_Import_Invalid_AutoPassTermLen"
public static final java.lang.String | BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD | "BPW_Core_Import_Invalid_AutoPassUserCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD | "BPW_Core_Import_Invalid_CallProcessDefCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN | "BPW_Core_Import_Invalid_CallProcessDefCd_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN | "BPW_Core_Import_Invalid_RunClass_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN | "BPW_Core_Import_Invalid_Category_Cd_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CODE_KIND | "BPW_Core_Import_Invalid_CodeKind"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CODE_KIND_VALUE | "BPW_Core_Import_Invalid_CodeKind_Value"
public static final java.lang.String | BPW_C_IMPORT_INVALID_COMPULSION_END_FLG | "BPW_Core_Import_Invalid_CompulsionEndFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CONDITION_CALSS | "BPW_Core_Import_Invalid_ConditionClass"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN | "BPW_Core_Import_ConditionClass_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CONTENTS_PATH | "BPW_Core_Import_Invalid_ContentsPath"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN | "BPW_Core_Import_Invalid_ContentsPath_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_CONTENTSTYPE | "BPW_Core_Import_Invalid_ContentsType"
public static final java.lang.String | BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND | "BPW_Core_Import_Invalid_DraftTypeKind"
public static final java.lang.String | BPW_C_IMPORT_INVALID_EFFECTIVE_DATE | "BPW_Core_Import_Invalid_EffectiveDate"
public static final java.lang.String | BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN | "BPW_Core_Import_Invalid_EffectiveDate_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_END_DATE | "BPW_Core_Import_Invalid_EndDate"
public static final java.lang.String | BPW_C_IMPORT_INVALID_END_DATE_LEN | "BPW_Core_Import_Invalid_EndDate_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID | "BPW_Core_Import_Invalid_EventServiceID"
public static final java.lang.String | BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN | "BPW_Core_Import_EventServiceID_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_FUNCTION_KBN | "BPW_Core_Import_Invalid_Function_Kbn"
public static final java.lang.String | BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN | "BPW_Core_Import_Invalid_MailContentsDef_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT | "BPW_Core_Import_Invalid_MailPostPonement"
public static final java.lang.String | BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN | "BPW_Core_Import_Invalid_MailPostPonement_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN | "BPW_Core_Import_Invalid_MailTitleDef_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION | "BPW_Core_Import_Invalid_MailToClassification"
public static final java.lang.String | BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN | "BPW_Core_Import_Invalid_MailToClassification_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PAGBE_KIND | "BPW_Core_Import_Invalid_PageKind"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY | "BPW_Core_Import_Invalid_Pre_RunRefer_Activity"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID | "BPW_Core_Import_Invalid_ProcessApplitionID"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN | "BPW_Core_Import_Invalid_ProcessApplicationID_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD | "BPW_Core_Import_Invalid_ProcessClassCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH | "BPW_Core_Import_Invalid_ProcessContentsPath"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN | "BPW_Core_Import_Invalid_ProcessContentsPath_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE | "BPW_Core_Import_Invalid_ProcessContentsType"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN | "BPW_Core_Import_Invalid_Processdef_Cd_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT | "BPW_Core_Import_Invalid_Process_Flow_Count"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND | "BPW_Core_Import_Invalid_ProcessPageKind"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT | "BPW_Core_Import_Invalid_Process_Route_Select"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID | "BPW_Core_Import_Invalid_ProcessServiceID"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN | "BPW_Core_Import_Invalid_ProcessServiceID_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESS_SWITCH | "BPW_Core_Import_Invalid_Process_Switch"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW | "BPW_Core_Import_Invalid_ProcessClassCd_And_SubProcessFlag_Bpw"
public static final java.lang.String | BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW | "BPW_Core_Import_Invalid_ProcessClassCd_And_SubProcessFlag_Drw"
public static final java.lang.String | BPW_C_IMPORT_INVALID_REFER_FOCUS | "BPW_Core_Import_Invalid_Refer_Focus"
public static final java.lang.String | BPW_C_IMPORT_INVALID_REFER_USER_CD | "BPW_Core_Import_Invalid_ReferUserCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RESULT_CONTENTS_DEF_LEN | "BPW_Core_Import_Invalid_ResultContentsDef_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RESULT_FROM_DEF | "BPW_Core_Import_Invalid_ResultFromDef"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RESULT_FROM_DEF_LEN | "BPW_Core_Import_Invalid_ResultFromDef_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RESULT_NOTICE_FLG | "BPW_Core_Import_Invalid_ResultNoticeFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RESULT_TITLE_DEF_LEN | "BPW_Core_Import_Invalid_ResultTitleDef_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RESULT_TO_OBJECT_FLG | "BPW_Core_Import_Invalid_ResultToObjectFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RETURN_PULL_FLG | "BPW_Core_Import_Invalid_ReturnPullFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG | "BPW_Core_Import_Invalid_ReturnPullMailFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG | "BPW_Core_Import_Invalid_Root_After_ShortestEndFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW | "BPW_Core_Import_Invalid_Root_Def_Of_Flow"
public static final java.lang.String | BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE | "BPW_Core_Import_Invalid_Root_Of_Invoke_Process_Before_Receive"
public static final java.lang.String | BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE | "BPW_Core_Import_Invalid_Root_Of_Route_Select_Before_Receive"
public static final java.lang.String | BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE | "BPW_Core_Import_Invalid_Root_Of_Run_Select_User_Before_Task"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD | "BPW_Core_Import_Invalid_RunActivityCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN | "BPW_Core_Import_RunActivityCd_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RUN_CLASS | "BPW_Core_Import_Invalid_RunClass"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD | "BPW_Core_Import_Invalid_RunExecutiveCompanyCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD | "BPW_Core_Import_Invalid_RunExecutivePostCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND | "BPW_Core_Import_Invalid_RunExecutivePostCdKind"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RUN_USER_CD | "BPW_Core_Import_Invalid_RunUserCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION | "BPW_Core_Import_Invalid_RunSelect_Task_Location"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SECOND_APPROVAL | "BPW_Core_Import_Invalid_Second_Approval"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN | "BPW_Core_Import_Select_Route_Cd_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN | "BPW_Core_Import_Select_Route_Name_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SERVECE_ID | "BPW_Core_Import_Invalid_ServiceID"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SERVICE_ID_LEN | "BPW_Core_Import_Invalid_ServiceID_Len"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG | "BPW_Core_Import_Invalid_ShortestEndFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW | "BPW_Core_Import_Invalid_ShortestEndFlag_Before_Flow"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW | "BPW_Core_Import_Invalid_ShortestEndFlag_In_Flow"
public static final java.lang.String | BPW_C_IMPORT_INVALID_START_ACTIVITY | "BPW_Core_Import_Invalid_Start_Activity"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SUB_PROCESS | "BPW_Core_Import_Invalid_Sub_Process"
public static final java.lang.String | BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG | "BPW_Core_Import_Invalid_SubProcessFlag"
public static final java.lang.String | BPW_C_IMPORT_INVALID_TASK_ID | "BPW_Core_Import_Invalid_Task_Id"
public static final java.lang.String | BPW_C_IMPORT_INVALID_TASK_TYPE | "BPW_Core_Import_Invalid_Task_Type"
public static final java.lang.String | BPW_C_IMPORT_INVALID_TOP_ACTIVITY | "BPW_Core_Import_Invalid_Top_Activity"
public static final java.lang.String | BPW_C_IMPORT_INVALID_VERSION_CD | "BPW_Core_Import_Invalid_VersionCd"
public static final java.lang.String | BPW_C_IMPORT_INVALID_VERSION_CD_LEN | "BPW_Core_Import_Invalid_VersionCd_Len"
public static final java.lang.String | BPW_C_IMPORT_LACK_SEND_TO_INFO | "BPW_Core_Import_Lack_Send_To_Info"
public static final java.lang.String | BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER | "BPW_Core_Import_No_AutoAdapterMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER | "BPW_Core_Import_No_AoutPassExecutiveMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_AUTO_PASS_INFO | "BPW_Core_Import_No_AoutPassInfo"
public static final java.lang.String | BPW_C_IMPORT_NO_AUTO_PASS_MASTER | "BPW_Core_Import_No_AoutPassMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_AUTO_PASS_USER_CD | "BPW_Core_Import_NoExist_AutoPassUserCd"
public static final java.lang.String | BPW_C_IMPORT_NO_CONTENTS_MASTER | "BPW_Core_Import_No_ContentsMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER | "BPW_Core_Import_No_EventAdapterMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT | "BPW_Core_Import_No_Exist_Approval_Draft"
public static final java.lang.String | BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD | "BPW_Core_Import_NoExist_AutoPassExecutivePostCd"
public static final java.lang.String | BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD | "BPW_Core_Import_NoExist_ReferGroupingCd"
public static final java.lang.String | BPW_C_IMPORT_NO_EXIST_REFER_USER_CD | "BPW_Core_Import_NoExist_ReferUserCd"
public static final java.lang.String | BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD | "BPW_Core_Import_NoExist_RunExecutiveCompanyCd"
public static final java.lang.String | BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD | "BPW_Core_Import_NoExist_RunExecutivePostCd"
public static final java.lang.String | BPW_C_IMPORT_NO_EXIST_RUN_USER_CD | "BPW_Core_Import_NoExist_RunUserCd"
public static final java.lang.String | BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS | "BPW_Core_Import_No_First_Condition_Class"
public static final java.lang.String | BPW_C_IMPORT_NO_FIRST_TASK_ID | "BPW_Core_Import_No_First_Task_Id"
public static final java.lang.String | BPW_C_IMPORT_NO_FIRST_TASK_ID_OF_ROUTE_SELECT | "BPW_Core_Import_No_First_Task_Id_Of_Route_Select"
public static final java.lang.String | BPW_C_IMPORT_NO_FLOW_INNER_MASTER | "BPW_Core_Import_No_FlowInnerMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY | "BPW_Core_Import_No_FlowRunActivity"
public static final java.lang.String | BPW_C_IMPORT_NO_LICENSE | "BPW_Core_Import_No_License"
public static final java.lang.String | BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER | "BPW_Core_Import_No_License_Auto_Event_Adapter"
public static final java.lang.String | BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW | "BPW_Core_Import_No_FlowSwitch"
public static final java.lang.String | BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER | "BPW_Core_Import_No_ProcessAdapterMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE | "BPW_Core_Import_No_Receive_In_First_Sequence"
public static final java.lang.String | BPW_C_IMPORT_NO_RECEIVE_MASTER | "BPW_Core_Import_No_ReceiveMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_RESULT_SEND_MASTER | "BPW_Core_Import_No_ResultSendMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER | "BPW_Core_Import_No_RouteSelectMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER | "BPW_Core_Import_Found_RunExecutiveMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_RUN_USER_MASTER | "BPW_Core_Import_Found_RunUserMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_SELECT_ROUTE_CD | "BPW_Core_Import_No_SelectRouteCd"
public static final java.lang.String | BPW_C_IMPORT_NO_SELECT_ROUTE_NAME | "BPW_Core_Import_No_SelectRouteName"
public static final java.lang.String | BPW_C_IMPORT_NO_SEQUENCE_MASTER | "BPW_Core_Import_No_SequenceMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY | "BPW_Core_Import_No_SequenceRunActivity"
public static final java.lang.String | BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE | "BPW_Core_Import_No_SubRoot_Of_Flow"
public static final java.lang.String | BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT | "BPW_Core_Import_No_SubRoot_Of_RouteSelect"
public static final java.lang.String | BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH | "BPW_Core_Import_No_SubRoot_Of_Switch"
public static final java.lang.String | BPW_C_IMPORT_NO_SWITCH_MASTER | "BPW_Core_Import_No_SwitchMaster"
public static final java.lang.String | BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY | "BPW_Core_Import_No_SwitchRunActivity"
public static final java.lang.String | BPW_C_IMPORT_NO_TASK_DEF | "BPW_Core_Import_Invalid_TaskDef"
public static final java.lang.String | BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF | "BPW_Core_Import_No_Task_Id_In_Root_Def"
public static final java.lang.String | BPW_C_IMPORT_OVER_NOTE_LEN | "BPW_Core_Import_Over_Note_Cd_Len"
public static final java.lang.String | BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN | "BPW_Core_Import_Over_ProcessClassCd_Len"
public static final java.lang.String | BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN | "BPW_Core_Import_Over_Processdef_Name_Len"
public static final java.lang.String | BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN | "BPW_Core_Import_Over_ProcessDefNote_Cd_Len"
public static final java.lang.String | BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN | "BPW_Core_Import_Over_SubProcessFlag_Len"
public static final java.lang.String | BPW_C_IMPORT_PLURAL_APPROVAL | "BPW_Core_Import_Plural_Approval"
public static final java.lang.String | BPW_C_IMPOSSIBLE_PROCESS_DRAFT | "BPW_Core_Impossible_Process_Draft"
public static final java.lang.String | BPW_C_IMPOSSIBLE_PROCESS_DRAFT_TARGET_DATE | "BPW_Core_Impossible_Process_Draft_Target_date"
public static final java.lang.String | BPW_C_IMPOSSIBLE_PULL_DRAFT | "BPW_Core_Impossible_PullDraft"
public static final java.lang.String | BPW_C_IMPOSSIBLE_RETURN | "BPW_Core_Impossible_Return"
public static final java.lang.String | BPW_C_IMPOSSIBLE_RETURN_DRAFT | "BPW_Core_Impossible_ReturnDraft"
public static final java.lang.String | BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO | "BPW_Core_Impossible_Root_History_info"
public static final java.lang.String | BPW_C_INPOSSIBLE_DRAFT_ACTIVITY | "BPW_Core_Impossible_Draft_Activity"
public static final java.lang.String | BPW_C_INPOSSIBLE_GET_ROOT_INFO | "BPW_Core_Impossible_Get_RootInfo"
public static final java.lang.String | BPW_C_INPOSSIBLE_GET_USER_APP_KEY | "BPW_Core_Impossible_Get_User_App_key"
public static final java.lang.String | BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND | "BPW_Core_Impossible_Mail_Template_Send"
public static final java.lang.String | BPW_C_INPOSSIBLE_PULL_ACTIVITY | "BPW_Core_Impossible_Pull_Activity"
public static final java.lang.String | BPW_C_INPOSSIBLE_RECOGNITION_ACTIVITY | "BPW_Core_Impossible_Recognition_Activity"
public static final java.lang.String | BPW_C_INPOSSIBLE_REGIST_USER_APP_KEY | "BPW_Core_Impossible_Regist_User_App_key"
public static final java.lang.String | BPW_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY | "BPW_Core_Impossible_Return_Before_Activity"
public static final java.lang.String | BPW_C_INPOSSIBLE_RETURN_START_ACTIVITY | "BPW_Core_Impossible_Return_Start_Activity"
public static final java.lang.String | BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY | "BPW_Core_Impossible_Set_Mail_Reserve_key"
public static final java.lang.String | BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY | "BPW_Core_Impossible_Set_Mail_Stop_key"
public static final java.lang.String | BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY | "BPW_Core_Impossible_Mail_Template_key"
public static final java.lang.String | BPW_C_INVALID_ACTIVITY_STATUS | "BPW_Core_Invalid_Activity_Status"
public static final java.lang.String | BPW_C_INVALID_ACTIVITY_TYPE | "BPW_Core_Invalid_Activity_Type"
public static final java.lang.String | BPW_C_INVALID_ADAPTER_TYPE | "BPW_Core_Invalid_AdapterType"
public static final java.lang.String | BPW_C_INVALID_APPROVAL_TYPE | "BPW_Core_Invalid_ApprovalType"
public static final java.lang.String | BPW_C_INVALID_APPROVAL_USER | "BPW_Core_Invalid_ApprovalUser"
public static final java.lang.String | BPW_C_INVALID_ATTACH_INFO | "BPW_Core_Invalid_Attach_Info"
public static final java.lang.String | BPW_C_INVALID_CATEGORY | "BPW_Core_Invalid_Category"
public static final java.lang.String | BPW_C_INVALID_CATEGORY_CODE | "BPW_Core_Invalid_Categorycode"
public static final java.lang.String | BPW_C_INVALID_CATEGORY_NAME | "BPW_Core_Invalid_Category_Name"
public static final java.lang.String | BPW_C_INVALID_CONTENTS_M_SELECT_KEY | "BPW_Core_Invalid_ContentsMaster_Select_Key"
public static final java.lang.String | BPW_C_INVALID_CONTENTS_TYPE | "BPW_Core_Invalid_Contents_Type"
public static final java.lang.String | BPW_C_INVALID_DB_PRIMARY_KEY | "BPW_Core_Invalid_DB_Primary_Key"
public static final java.lang.String | BPW_C_INVALID_GROUPING_CD_KIND | "BPW_Core_Invalid_GroupingCode_Kind"
public static final java.lang.String | BPW_C_INVALID_LOGIN_GROUP_ID | "BPW_Core_Invalid_LoginGroupID"
public static final java.lang.String | BPW_C_INVALID_LOGIN_USER_ID | "BPW_Core_Invalid_LoginUserID"
public static final java.lang.String | BPW_C_INVALID_NECESSARY_KEY | "BPW_Core_Invalid_Necessary_Key"
public static final java.lang.String | BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY | "BPW_Core_Invalid_ProcessContentsMaster_Select_Key"
public static final java.lang.String | BPW_C_INVALID_PROCESS_DEF_NAME | "BPW_Core_Invalid_Processdef_Name"
public static final java.lang.String | BPW_C_INVALID_PROCESSDEF | "BPW_Core_Invalid_Processdef"
public static final java.lang.String | BPW_C_INVALID_REFER_FLAG | "BPW_Core_Invalid_ReferFlag"
public static final java.lang.String | BPW_C_INVALID_REMINDER_TYPE | "BPW_Core_Invalid_Reminder_Type"
public static final java.lang.String | BPW_C_INVALID_RETURN_DRAFT_SELECT_KEY | "BPW_Core_Invalid_ReturnDraft_Select_Key"
public static final java.lang.String | BPW_C_INVALID_RETURN_FLG | "BPW_Core_Invalid_Return_Flag"
public static final java.lang.String | BPW_C_INVALID_RETURN_START_RUN_USER_INFO | "BPW_Core_Invalid_Return_Start_Run_User_Info"
public static final java.lang.String | BPW_C_INVALID_ROOT_NAME | "BPW_Core_Invalid_Root_Name"
public static final java.lang.String | BPW_C_INVALID_RUN_EXECUTIVE_TYPE | "BPW_Core_Invalid_Run_ExecutiveType"
public static final java.lang.String | BPW_C_INVALID_SELECT_CONDITION_PHRASE | "BPW_Core_Invalid_Select_Condition_Phrase"
public static final java.lang.String | BPW_C_INVALID_SELECT_IN_PHRASE | "BPW_Core_Invalid_Select_Inphrase"
public static final java.lang.String | BPW_C_INVALID_TAGET_GROUP | "BPW_Core_Invalid_Target_Group"
public static final java.lang.String | BPW_C_INVALID_TRANSFER_CD_KIND | "BPW_Core_Invalid_TransferCode_Kind"
public static final java.lang.String | BPW_C_INVALID_USER_CD_KIND | "BPW_Core_Invalid_UserCode_Kind"
public static final java.lang.String | BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY | "BPW_Core_Invalid_Workflow_Select_Primary_Key"
public static final java.lang.String | BPW_C_MAGICAL_ACTIVE_ACTIVITY | "BPW_Core_Alredy_Active_Activity"
public static final java.lang.String | BPW_C_MAGICAL_DEACTIVE_PROCESS | "BPW_Core_DeActive_Process"
public static final java.lang.String | BPW_C_MAGICAL_PLURAL_RUN_USER | "BPW_Core_Plural_Run_User"
public static final java.lang.String | BPW_C_MAGICAL_RUN_USER | "BPW_Core_Run_User"
public static final java.lang.String | BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND | "BPW_Core_Mail_Tamplate_Path_Not_Found"
public static final java.lang.String | BPW_C_MOVE_ACTIVITY_RETURN_PULL | "BPW_Core_Move_Activity_Return_Pull"
public static final java.lang.String | BPW_C_NO_ATTACH_POSITION_GROUP | "BPW_Core_No_Attach_Position_Group"
public static final java.lang.String | BPW_C_NO_ATTACH_POSITION_GROUP_AGENT | "BPW_Core_No_Attach_Position_Group_Agent"
public static final java.lang.String | BPW_C_NO_AUTHORITY | "BPW_Core_No_Authority"
public static final java.lang.String | BPW_C_NO_AUTO_PASS_MASTER_INFO | "BPW_Core_No_AutoPassMaster_Info"
public static final java.lang.String | BPW_C_NO_DRAFT_CHECK_KEY | "BPW_Core_No_Draft_CheckKey"
public static final java.lang.String | BPW_C_NO_DRAFT_USER_CD | "BPW_Core_No_Draft_UserCode"
public static final java.lang.String | BPW_C_NO_EVENT_ADAPTER | "BPW_Core_No_Event_Adapter"
public static final java.lang.String | BPW_C_NO_EXECUTE_ADAPTER | "BPW_Core_No_Execute_Adapter"
public static final java.lang.String | BPW_C_NO_EXECUTIVE_GROUP | "BPW_Core_No_Executive_Group"
public static final java.lang.String | BPW_C_NO_FLOW_MASTER_INFO | "BPW_Core_No_FlowMaster_Info"
public static final java.lang.String | BPW_C_NO_INSERT_VALUE | "BPW_Core_Not_Insert_Value"
public static final java.lang.String | BPW_C_NO_PROCESS_ADAPTER | "BPW_Core_No_Process_Adapter"
public static final java.lang.String | BPW_C_NO_ROUTE_SELECT_MASTER | "BPW_Core_No_Route_Select_Master"
public static final java.lang.String | BPW_C_NO_RUN_SELECT_ACTIVITY | "BPW_Core_No_Run_Select_Activity"
public static final java.lang.String | BPW_C_NO_RUN_SELECT_USER | "BPW_Core_No_Run_Select_User"
public static final java.lang.String | BPW_C_NO_RUNUSER_EXCUTIVE_INFO | "BPW_Core_No_RunExcutiveMaster_Info"
public static final java.lang.String | BPW_C_NO_RUNUSER_MASTER_INFO | "BPW_Core_No_RunUserMaster_Info"
public static final java.lang.String | BPW_C_NO_SELECTED_TARGET_TASK | "BPW_Core_No_Selected_Target_Task"
public static final java.lang.String | BPW_C_NO_SEQUENCE_MASTER_INFO | "BPW_Core_No_SequenceMaster_Info"
public static final java.lang.String | BPW_C_NO_SWHITCH_MASTER_INFO | "BPW_Core_No_SwitchMaster_Info"
public static final java.lang.String | BPW_C_NO_TRANSFER_AUTHORITY | "BPW_Core_Not_Transefer_Authority"
public static final java.lang.String | BPW_C_NO_USER_CD | "BPW_Core_No_UserCode"
public static final java.lang.String | BPW_C_NO_VERSION_DRAFT_CD | "BPW_Core_No_Version_DraftCode"
public static final java.lang.String | BPW_C_NOT_ACTIVITY | "BPW_Core_Not_Activity"
public static final java.lang.String | BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL | "BPW_Core_Not_Activity_For_SendMail"
public static final java.lang.String | BPW_C_NOT_ACTIVITY_MASTER | "BPW_Core_Not_Activity_Master"
public static final java.lang.String | BPW_C_NOT_BACK_IN_FLOW | "BPW_Core_Not_Back_In_Flow"
public static final java.lang.String | BPW_C_NOT_CATEGORY | "BPW_Core_Not_Category"
public static final java.lang.String | BPW_C_NOT_DELEGATE | "BPW_Core_Not_Delegate"
public static final java.lang.String | BPW_C_NOT_DELEGATE_AGENT | "BPW_Core_Not_Delegate_Agent"
public static final java.lang.String | BPW_C_NOT_DELEGATE_AGENT_SET | "BPW_Core_Not_Delegate_Agent_Set"
public static final java.lang.String | BPW_C_NOT_DELEGATE_ALREADY | "BPW_Core_Not_Delegate_Already"
public static final java.lang.String | BPW_C_NOT_DELEGATE_ALREADY_RIGHT | "BPW_Core_Not_Delegate_Already_Right"
public static final java.lang.String | BPW_C_NOT_DELEGATE_BACK | "BPW_Core_Not_Delegate_Back"
public static final java.lang.String | BPW_C_NOT_DELEGATE_CIRCULATION | "BPW_Core_Not_Delegate_Circulation"
public static final java.lang.String | BPW_C_NOT_DELETE_VERSION_LASTRECORD | "BPW_Core_Not_Delete_Version_Last_Record"
public static final java.lang.String | BPW_C_NOT_EFFECTIVE_DATE | "BPW_Core_Not_Effective_Date"
public static final java.lang.String | BPW_C_NOT_GET_PROCESS_CODE | "BPW_Core_Not_Get_Process_Code"
public static final java.lang.String | BPW_C_NOT_GROUP_TABLE | "BPW_Core_Not_Group_Table"
public static final java.lang.String | BPW_C_NOT_HISTORY_RETURN_PULL | "BPW_Core_Not_History_Return_Pull"
public static final java.lang.String | BPW_C_NOT_PROCESS | "BPW_Core_Not_Process"
public static final java.lang.String | BPW_C_NOT_PROCESSDEF | "BPW_Core_Not_Processdef"
public static final java.lang.String | BPW_C_NOT_PULL_DRAFT_ACTIVITY | "BPW_Core_Not_PullDraft_Activity"
public static final java.lang.String | BPW_C_NOT_RECEIVE_TABLE | "BPW_Core_Not_ReceiveTable"
public static final java.lang.String | BPW_C_NOT_RECEIVE_USER | "BPW_Core_Not_Receive_User"
public static final java.lang.String | BPW_C_NOT_RETURN_ACTIVITY | "BPW_Core_Not_Return_Activity"
public static final java.lang.String | BPW_C_NOT_RETURN_DRAFT_ACTIVITY | "BPW_Core_Not_ReturnDraft_Activity"
public static final java.lang.String | BPW_C_NOT_ROOT_HISTORY_INFO | "BPW_Core_Not_Root_History"
public static final java.lang.String | BPW_C_NOT_RUN_EXECUTIVE_MASTER | "BPW_Core_Not_Run_Executive_Master"
public static final java.lang.String | BPW_C_NOT_RUN_USER_EXECUTIVE_MASTER | "BPW_Core_Not_Run_User_Executive_Master"
public static final java.lang.String | BPW_C_NOT_RUN_USER_MASTER | "BPW_Core_Not_RunuserMaster"
public static final java.lang.String | BPW_C_NOT_RUN_USER_TABLE | "BPW_Core_Not_RunUserTable"
public static final java.lang.String | BPW_C_NOT_SET_INVALID_FLAG | "BPW_Core_Not_Set_InvalidFlag"
public static final java.lang.String | BPW_C_NOT_SYNCRONIZED | "BPW_Core_Not_Syncronized"
public static final java.lang.String | BPW_C_NOT_VERSION | "BPW_Core_Not_Version"
public static final java.lang.String | BPW_C_PRAM_ERROR | "BPW_Core_Invalid_Parameter"
public static final java.lang.String | BPW_C_PROCESS_COUNT_FILE_NOT_FOUND | "BPW_Core_Process_Count_File_Not_Found"
public static final java.lang.String | BPW_C_REPEAT_ORDER_BY_VALUE | "BPW_Core_Repeat_OrderBy_Value"
public static final java.lang.String | BPW_C_REPEAT_RUN_SELECT_USER | "BPW_Core_Repeat_Run_Select_User"
public static final java.lang.String | BPW_C_RETURN_PULL_DIFFER_PROCESS | "BPW_Core_Return_Pull_Differ_Process"
public static final java.lang.String | BPW_C_SHIFT_REFER_DUPLICATION | "BPW_Core_Shift_Refer_Duplication"
public static final java.lang.String | BPW_C_SHIFT_REFER_TOOL | "BPW_Core_Shift_Refer_Tool"
public static final java.lang.String | BPW_C_ZERO_MEMBER_COMPANY | "BPW_Core_Zero_Member_Company"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW | "BPW_Core_Import_Invalid_Contents_Frame_Type_For_BPW"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE | "BPW_Core_Import_Invalid_Create_Route_Before_Create_Route"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW | "BPW_Core_Import_Invalid_Create_Route_Before_Flow"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH | "BPW_Core_Import_Invalid_Create_Route_Before_Switch"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE | "BPW_Core_Import_Invalid_Draft_Task_Not_Receive"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH | "BPW_Core_Import_Invalid_Dynamic_User_Before_Switch"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK | "BPW_Core_Import_Invalid_Dynamic_User_For_Draft_Task"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER | "BPW_Core_Import_Invalid_Flow_After_Dynamic_User"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT | "BPW_Core_Import_Invalid_Flow_Inner_One_Root"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT | "BPW_Core_Import_Invalid_Flow_Inner_Root"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_INVOKE_TASK | "BPW_Core_Import_Invalid_Invoke_task"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE | "BPW_Core_Import_Invalid_Not_Route_Select_Inner_Receive"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_ROOT_SETTING | "BPW_Core_Import_Invalid_Root_Setting"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE | "BPW_Core_Import_Invalid_Route_Select_Before_Create_Route"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW | "BPW_Core_Import_Invalid_Route_Select_Before_Flow"
public static final java.lang.String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH | "BPW_Core_Import_Invalid_Route_Select_Before_Switch"
public static final java.lang.String | BPW_CORE_IMPORT_NO_RECEIVE_TASK | "BPW_Core_Import_No_Receive_Task"
public static final java.lang.String | BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO | "BPW_Core_Import_No_Sub_Process_Info"
public static final java.lang.String | BPW_FLOWINFO_INVALID_PARAMETER | "BPW_FlowInfo_Invalid_Parameter"
public static final java.lang.String | BPW_FLOWINFO_NO_EXIST_FLOWICON | "BPW_FlowInfo_No_Exist_FlowIcon"
public static final java.lang.String | BPW_INVALID_DRAFT_COMMENT_LENGTH | "bpw_invalid_draft_comment_length"
public static final java.lang.String | BPW_INVALID_PROCESS_NAME_LENGTH | "bpw_invalid_process_name_length"
public static final java.lang.String | BPW_INVALID_RECEIVE_COMMENT_LENGTH | "bpw_invalid_receive_comment_length"
public static final java.lang.String | BPW_UT_FAILED_TO_BEGIN | "Bpw_ut_Failed_To_Begin"
public static final java.lang.String | BPW_UT_FAILED_TO_CLOSE | "Bpw_ut_Failed_To_Close"
public static final java.lang.String | BPW_UT_FAILED_TO_COMMIT | "Bpw_ut_Failed_To_Commit"
public static final java.lang.String | BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION | "Bpw_Ut_Failed_To_Commit_Outside_Of_Transaction"
public static final java.lang.String | BPW_UT_FAILED_TO_GET_STATUS | "Bpw_ut_Failed_To_Get_status"
public static final java.lang.String | BPW_UT_FAILED_TO_LOCK | "Bpw_Ut_Failed_To_Lock"
public static final java.lang.String | BPW_UT_FAILED_TO_ROLLBACK | "Bpw_ut_Failed_To_Rollback"
public static final java.lang.String | BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION | "Bpw_Ut_Failed_To_Rolleback_Outside_Of_Transaction"
public static final java.lang.String | BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY | "Bpw_ut_Failed_To_Set_Rollback_Only"
public static final java.lang.String | BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT | "Bpw_ut_Failed_To_Set_Transaction_Time_Out"
public static final java.lang.String | BPW_UT_FAILED_TO_UNLOCK | "Bpw_Ut_Failed_To_Unlock"

jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF
public static final java.lang.String | WFK_C_NOT_TEMPLATE_PATH | "WKF_Core_Not_Template_path"
public static final java.lang.String | WKF_C_APPROVAL_TYPE | "WKF_Core_Approval_Type"
public static final java.lang.String | WKF_C_AUTO_PASS | "WKF_Core_Auto_Pass"
public static final java.lang.String | WKF_C_AUTO_PRESS | "WKF_Core_Auto_Press"
public static final java.lang.String | WKF_C_DEPARTMENT_INFO_ERROR | "WKF_Core_Invalid_Department_Info"
public static final java.lang.String | WKF_C_DRAFT_ACTIVITY_CD | "WKF_Core_Draft_Activity_Cd"
public static final java.lang.String | WKF_C_DRAFT_APPOINT_DATE | "WKF_Core_Draft_Appoint_Date"
public static final java.lang.String | WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD | "WKF_Core_Import_Invalid_Next_Activity_Cd"
public static final java.lang.String | WKF_C_INPOSSIBLE_DRAFT_ACTIVITY | "WKF_Core_Impossible_Draft_Activity"
public static final java.lang.String | WKF_C_INPOSSIBLE_PULL_ACTIVITY | "WKF_Core_Impossible_Pull_Activity"
public static final java.lang.String | WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY | "WKF_Core_Impossible_Recognition_Activity"
public static final java.lang.String | WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY | "WKF_Core_Impossible_Return_Before_Activity"
public static final java.lang.String | WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY | "WKF_Core_Impossible_Return_Start_Activity"
public static final java.lang.String | WKF_C_NO_MANAGER_AUTHORITY | "WKF_Core_No_Manager_Authority"
public static final java.lang.String | WKF_C_NOT_ACTIVITY | "WKF_Core_Not_Activity"
public static final java.lang.String | WKF_C_NOT_APPLICATION_KEY | "WKF_Core_Not_Application_Key"
public static final java.lang.String | WKF_C_NOT_DEPARTMENT_INFO | "WKF_Core_Not_Department_Info"
public static final java.lang.String | WKF_C_NOT_PROCESS_INFO | "WKF_Core_Not_Process_Info"
public static final java.lang.String | WKF_C_NOT_REGIST_TYPE | "WKF_Core_Not_Regist_Type"
public static final java.lang.String | WKF_C_NOT_VERSION | "WKF_Core_Not_Version"
public static final java.lang.String | WKF_C_PRAM_AGT_ALL | "WKF_Core_Parameter_Agent_All"
public static final java.lang.String | WKF_C_PRAM_ERROR | "WKF_Core_Invalid_Parameter"
public static final java.lang.String | WKF_C_PROCESS_INFO | "WKF_Core_Process_Info"
public static final java.lang.String | WKF_C_REMOVE_PROCESS | "WKF_Core_Remove_Process"
public static final java.lang.String | WKF_C_SEND_MAIL | "WKF_Core_Send_Mail"

jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF
public static final java.lang.String | ACTIVITY_ID_EMPTY | "7"
public static final java.lang.String | ACTIVITY_ID_FLOW | "5"
public static final java.lang.String | ACTIVITY_ID_INVOKE_AUTO | "3"
public static final java.lang.String | ACTIVITY_ID_INVOKE_EVENT | "9"
public static final java.lang.String | ACTIVITY_ID_INVOKE_PROCESS | "2"
public static final java.lang.String | ACTIVITY_ID_PROCESS | "0"
public static final java.lang.String | ACTIVITY_ID_RECEIVE | "1"
public static final java.lang.String | ACTIVITY_ID_ROUTE_SELECT | "A"
public static final java.lang.String | ACTIVITY_ID_SEQUENCE | "4"
public static final java.lang.String | ACTIVITY_ID_SWITCH | "8"
public static final java.lang.String | ACTIVITY_ID_TERMINATE | "6"
public static final java.lang.String | ATTAINMENT_NORMAL | "01"
public static final java.lang.String | ATTAINMENT_NOT | "00"
public static final java.lang.String | ATTAINMENT_PULL_ACTIVE | "20"
public static final java.lang.String | ATTAINMENT_PULL_READY | "21"
public static final java.lang.String | ATTAINMENT_RETURN_ACTIVE | "30"
public static final java.lang.String | ATTAINMENT_RETURN_READY | "31"
public static final java.lang.String | ATTAINMENT_RETURN_READY_ACTIVE | "32"
public static final int | EIS_INIT | 0
public static final java.lang.String | EIS_METHOD_ACTIVED | "actived"
public static final java.lang.String | EIS_METHOD_CANCELED | "canceled"
public static final java.lang.String | EIS_METHOD_CLOSED | "closed"
public static final java.lang.String | EIS_METHOD_COMPENSATED | "compensated"
public static final java.lang.String | EIS_METHOD_COMPLETED | "completed"
public static final java.lang.String | EIS_METHOD_COMPULSION | "compulsion"
public static final java.lang.String | EIS_METHOD_EXITED | "terminated"
public static final java.lang.String | EIS_METHOD_FAULTED | "faulted"
public static final java.lang.String | EIS_METHOD_SUSPENDED | "suspended"
public static final java.lang.String | FLG_OFF | "0"
public static final java.lang.String | FLG_ON | "1"
public static final java.lang.String | STATUS_ACTIVE | "1"
public static final java.lang.String | STATUS_AUTOCLOSING | "9"
public static final java.lang.String | STATUS_CANCELING | "3"
public static final java.lang.String | STATUS_CLOSING | "6"
public static final java.lang.String | STATUS_COMPENSATING | "5"
public static final java.lang.String | STATUS_COMPLETED | "4"
public static final java.lang.String | STATUS_EXIT | "8"
public static final java.lang.String | STATUS_FAULT | "7"
public static final java.lang.String | STATUS_NONE | "-1"
public static final java.lang.String | STATUS_READY | "0"
public static final java.lang.String | STATUS_SUSPEND | "2"
public static final java.lang.String | STR_INIT | "0"
public static final java.lang.String | STR_NULL | ""

jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel
public static final java.lang.String | END_TASK_OFF | "0"
public static final java.lang.String | END_TASK_ON | "1"
public static final java.lang.String | PROCESSING_COMPLETED | "999"
public static final java.lang.String | PROCESSING_NORMALL | "000"
public static final java.lang.String | PROCESSING_PSN_NORMALL | "100"
public static final java.lang.String | PROCESSING_PSN_PULL_BACK | "105"
public static final java.lang.String | PROCESSING_PSN_PULL_SUSPEND | "115"
public static final java.lang.String | PROCESSING_PSN_SEND_BACK | "106"
public static final java.lang.String | PROCESSING_PSN_SEND_SUSPEND | "116"
public static final java.lang.String | PROCESSING_PSN_SUSPEND | "110"
public static final java.lang.String | PROCESSING_PULL_BACK | "005"
public static final java.lang.String | PROCESSING_PULL_SUSPEND | "015"
public static final java.lang.String | PROCESSING_SEND_BACK | "006"
public static final java.lang.String | PROCESSING_SEND_SUSPEND | "016"
public static final java.lang.String | PROCESSING_SUB_NORMALL | "200"
public static final java.lang.String | PROCESSING_SUB_PULL_BACK | "205"
public static final java.lang.String | PROCESSING_SUB_PULL_SUSPEND | "215"
public static final java.lang.String | PROCESSING_SUB_SEND_BACK | "206"
public static final java.lang.String | PROCESSING_SUB_SEND_SUSPEND | "216"
public static final java.lang.String | PROCESSING_SUB_SUSPEND | "210"
public static final java.lang.String | PROCESSING_SUSPEND | "010"
public static final java.lang.String | PULL_ACTIVITY_OFF | "0"
public static final java.lang.String | PULL_ACTIVITY_ON | "1"
public static final java.lang.String | REFER_ALL | "0"
public static final java.lang.String | REFER_NONE | "-1"
public static final java.lang.String | REFER_READ | "1"
public static final java.lang.String | REFER_RECOGNITION | "2"
public static final java.lang.String | RETURN_ACTIVITY_OFF | "0"
public static final java.lang.String | RETURN_ACTIVITY_ON | "1"
public static final java.lang.String | RETURN_MAIL_OFF | "0"
public static final java.lang.String | RETURN_MAIL_ON | "1"
public static final java.lang.String | RUN_AUTH_ALL | "3"
public static final java.lang.String | RUN_AUTH_NOT | "0"
public static final java.lang.String | RUN_AUTH_RUN | "1"
public static final java.lang.String | RUN_AUTH_TRANSFER | "2"
public static final java.lang.String | RUN_SELECT_OFF | "0"
public static final java.lang.String | RUN_SELECT_ON | "1"
public static final java.lang.String | TRANSFER_OFF | "0"
public static final java.lang.String | TRANSFER_ON | "1"

jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel
public static final java.lang.String | TRANSFER_OFF | "0"
public static final java.lang.String | TRANSFER_ON | "1"

jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel
public static final java.lang.String | APPLY | "0"
public static final java.lang.String | CANCEL | "8"
public static final java.lang.String | MAGICAL_HAND | "99"
public static final java.lang.String | RECOGNITION | "2"
public static final java.lang.String | REJECTION | "3"
public static final java.lang.String | RETRY | "1"
public static final java.lang.String | RETURN_BEFORE | "5"
public static final java.lang.String | RETURN_PULL | "6"
public static final java.lang.String | RETURN_START | "4"
public static final java.lang.String | ROLL_SELECT_OFF | "0"
public static final java.lang.String | ROLL_SELECT_ON | "1"
public static final java.lang.String | SUSPENSION | "7"
public static final java.lang.String | TARGET_AUTOPASS | "9"

jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel
public static final java.lang.String | CD_KIND_OFFICIAL | "02"
public static final java.lang.String | CD_KIND_ORG | "01"
public static final java.lang.String | CD_KIND_ROLE | "03"
public static final java.lang.String | CD_KIND_USER | "00"
public static final java.lang.String | NO_PAIR | "no_pair"
public static final java.lang.String | NON_BILONGING | "#non_belonging#"
public static final java.lang.String | OLD_DATA | "0"
public static final java.lang.String | POST_TYPE_POSITION | "14"
public static final java.lang.String | POST_TYPE_ROLE | "13"

jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel
public static final java.lang.String | RIGHT_DELEGATE | "02"
public static final java.lang.String | RIGHT_INIT | "00"
public static final java.lang.String | RIGHT_NOT_DELEGATE | "20"
public static final java.lang.String | RIGHT_NOT_PERSON | "10"
public static final java.lang.String | RIGHT_PERSON | "01"
public static final java.lang.String | STATUS_COMPLETE | "01"
public static final java.lang.String | STATUS_DELEGATE_COMPLETE | "03"
public static final java.lang.String | STATUS_INIT | "00"
public static final java.lang.String | STATUS_SAID_COMPLETE | "02"
public static final java.lang.String | TYPE_DELEGATE | "02"
public static final java.lang.String | TYPE_PERSON | "00"
public static final java.lang.String | TYPE_SAID_PERSON | "01"

jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel
public static final java.lang.String | PROCESS_CLASS_BPW | "0"
public static final java.lang.String | PROCESS_CLASS_DRW | "2"
public static final java.lang.String | PROCESS_CLASS_DW | "1"
public static final java.lang.String | SUB_PROCESS_INIT | "0"
public static final java.lang.String | SUB_PROCESS_ONLY | "1"

jp.co.intra_mart.foundation.wkf.Approver
public static final java.lang.String | AGT_ALL | "1"
public static final java.lang.String | RETURN_TYPE_BEFORE | "before"
public static final java.lang.String | RETURN_TYPE_START | "start"

jp.co.intra_mart.foundation.wkf.Drafter
public static final java.lang.String AGT_ALL "1"

jp.co.intra_mart.foundation.wkf.NegoModel
public static final java.lang.String | MAIL_USER_ADDRESS | "mail"
public static final java.lang.String | MAIL_USER_CD | "cd"
public static final java.lang.String | MAIL_USER_NAME | "name"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


非推奨 API のリスト (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


API ヘルプ (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


索引 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし
A B C D E F G H I J L M N O P R S T U V W

A

ACTIVITY_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理タスクコードキー
ACTIVITY_ID_EMPTY - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
エンプティの処理タイプID
ACTIVITY_ID_FLOW - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
フローの処理タイプID
ACTIVITY_ID_INVOKE_AUTO - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
インボーク(自動呼出)の処理タイプID
ACTIVITY_ID_INVOKE_EVENT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
インボーク(イベント)の処理タイプID
ACTIVITY_ID_INVOKE_PROCESS - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
インボーク(プロセス呼出)の処理タイプID
ACTIVITY_ID_PROCESS - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
プロセスの処理タイプID
ACTIVITY_ID_RECEIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
レシーブの処理タイプID
ACTIVITY_ID_ROUTE_SELECT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
ルート選択の処理タイプID
ACTIVITY_ID_SEQUENCE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
シーケンスの処理タイプID
ACTIVITY_ID_SWITCH - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
スイッチの処理タイプID
ACTIVITY_ID_TERMINATE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
ターミネートの処理タイプID
ACTIVITY_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理タスク名キー
AGENT_USER_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
代理依頼元ユーザコードキー
AGENT_USER_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
代理依頼元ユーザ名キー
AGT_ALL - class jp.co.intra_mart.foundation.wkf.Approver の static 変数
代理依頼されたもの全て表示(代理のみ使用)
AGT_ALL - class jp.co.intra_mart.foundation.wkf.Drafter の static 変数
代理依頼されたもの全て表示(代理のみ使用)
AGT_COMPLETE_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
完了タスク表示(委譲)キー
AGT_GO_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
未処理タスク表示(委譲)キー
AGT_PULLBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
引き戻しタスク表示(委譲)キー
AGT_SENDBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
差し戻しタスク表示(委譲)キー
APPLY - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：申請
APPROVAL_COMP_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者の会社コードキー
APPROVAL_DATE_END - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理日(検索範囲終了日)キー
APPROVAL_DATE_START - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理日(検索範囲開始日)キー
APPROVAL_ORGN_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者の組織コードキー
APPROVAL_ORGN_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者の組織名キー
APPROVAL_USER_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者ユーザコードキー
APPROVAL_USER_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者ユーザ名キー
ARRIVE_DATE_END - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
到達日(検索範囲終了日)キー
ARRIVE_DATE_START - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
到達日(検索範囲開始日)キー
ATTAINMENT_NORMAL - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
アクティビティは通常に処理が到達した。
ATTAINMENT_NOT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
アクティビティには処理が到達していない。
ATTAINMENT_PULL_ACTIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
引き戻し（Active)
ATTAINMENT_PULL_READY - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
被・引き戻し（Ready)
ATTAINMENT_RETURN_ACTIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
差し戻し（Active)
ATTAINMENT_RETURN_READY - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
被・差し戻し（Complete→Ready)
ATTAINMENT_RETURN_READY_ACTIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
被・差し戻し（Active→Ready)
ActivityInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel.
アクティビティ情報を保持するクラス
アクティビティ情報を保持します。
ActivityInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
コンストラクタ
ActivityInfoModel(ActivityMasterUnitModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(ActivityMasterInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(SwitchInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(EditTransferTableInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(TransferTableInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(DelegateUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
Approver - class jp.co.intra_mart.foundation.wkf.Approver.
承認関連のAPI
承認関連の処理に使用されるクラスです。
Approver(String, String) - class jp.co.intra_mart.foundation.wkf.Approver のコンストラクタ
コンストラクタ１(本人用)
Approver(String, String, String) - class jp.co.intra_mart.foundation.wkf.Approver のコンストラクタ
コンストラクタ２(代理人用)。
addAutopasslist(AutoPassInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パスリスト情報に新たに自動パス情報を追加します。
addGroupList(RunGroupInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
グループ情報リストを追加します。
addReceivelist(ReceiveTableInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
レシーブリスト情報に新たにレシーブ情報を追加します。
addReserveInfo(BPWSendMailInfo) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
送信メール情報を追加設定します。
addRunuserlist(RunUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
実行主体ユーザリスト情報に新たに実行主体ユーザ情報を追加します。
addUserAppliKey(int, UserApplicationKeyInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
addUserAppliKey(int, UserApplicationKeyInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
addUserAppliKey(int, UserApplicationKeyInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
addUserList(Map) - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール送信者リストに情報を追加します。
approve(String, String, String, String, Boolean, String, String, String, NegoModel, RunExecutiveInfoModel, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
承認処理を実行します。
approve(String, String, String, String, Boolean, String, String, String, NegoModel, RunUserInfoModel, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
承認処理を実行します。
autoPass(String, String, String, int) - class jp.co.intra_mart.foundation.wkf.Util のメソッド
案件の自動パス(バッチ起動)処理を行います。
autoPress(String, String, String, int) - class jp.co.intra_mart.foundation.wkf.Util のメソッド
案件の自動催促(バッチ起動)処理を行います。

B

BEFORE_USER_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
前処理者ユーザコードキー
BEFORE_USER_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
前処理者ユーザ名キー
BPWErrorCodeIF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF.
ＢＰＷで利用される例外エラーコードインタフェース定義
BPWExecuteLogic - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic.
外部プログラム実行抽象クラス。
BPWExecuteLogic() - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のコンストラクタ
コンストラクタ
BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義種別がビジネスプロセスワークフローの場合、コンテンツフレーム種別にカスタムを設定することはできません。
BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセスに申請者/承認者ルート作成ワークフローが設定されているタスクの直前に
申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。
BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期の開始・結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐の開始直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票タスクのタスク種別に誤りがあります。
BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認者種別が実行時選択のタスクを
同期・分岐・ルート選択の開始直後に設定する事はできません。
BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票タスクに動的承認者は設定できません。
BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期タスクの結合直後に動的な対象者を設定する事はできません。
BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐内に1ルートしか設定されていません。
BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐内のタスク設定に誤りがあります。
BPW_CORE_IMPORT_INVALID_INVOKE_TASK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別がビジネスプロセスワークフロー以外の場合、自動実行タスク、イベント実行タスクを設定することはできません。
BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択内に処理タスクがない場合、ルート選択結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
BPW_CORE_IMPORT_INVALID_ROOT_SETTING - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義に誤りがあります。
BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択タスクの直前に申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。
BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期の開始・結合直後にルート選択タスクを設定することはできません。
BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐・ルート選択の開始直後にルート選択タスクを設定する事はできません。
BPW_CORE_IMPORT_NO_RECEIVE_TASK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票(処理)タスクが設定されていない可能性があります。
BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセス設定情報が設定されていません。
BPW_C_ALREADY_EXIST_TRANSFER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
処理委譲できません。
BPW_C_ALREADY_SUSPEND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
既に保留されている可能性があります。
BPW_C_AUTO_EXECUTE_FAULT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動実行処理が異常復帰しました。
BPW_C_CAN_NOT_START_JAVASCRIPT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
JavaScriptが起動できません。
BPW_C_CAN_NOT_TRANSFER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
処理委譲できません。
BPW_C_CHANGE_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
他のユーザに情報が変更されました。
BPW_C_CHANGING_NOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連する情報が修正中であり反映できません。
BPW_C_DATA_NOT_FOUND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
データが存在しません。
BPW_C_DUPLICATE_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
名称が重複しています。
BPW_C_EXIST_PROCESS_DEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
有効なプロセス定義が存在します。
BPW_C_FAILED_GET_HTTP_EXCEL_STREAM - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
Excelファイルストリーム取得に失敗しました。
BPW_C_FAILED_READ_EXCEL_STREAM - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
Excelファイルストリーム読み込みに失敗しました。
BPW_C_FOUND_AUTO_PASS_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付く自動パス情報が存在します。
BPW_C_FOUND_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付くプロセス情報が存在します。
BPW_C_FOUND_RECEIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
レシーブマスタ情報が存在しません。
BPW_C_FOUND_RECEIVE_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付くレシーブ情報が存在します。
BPW_C_FOUND_RUNNING_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行中のプロセスが存在します。
BPW_C_FOUND_RUN_USER_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付く実行主体ユーザ情報が存在します。
BPW_C_FOUND_VERSION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付く履歴情報が存在します。
BPW_C_HAVE_NOT_AUTHORITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
権限がありません。
BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
権限、及び権限に関連する情報がありません。
BPW_C_ILLIGAL_STATUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ステータスが異常です。
BPW_C_ILLIGAL_STATUS_CHG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ステータス遷移が異常です。
BPW_C_IMPORT_AUTO_PASS_ORGS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス対象ヘ複数組織／グループを指定することは出来ません。
BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択のレシーブは指定できません。
BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別の設定が不正です。
BPW_C_IMPORT_DUPLICATE_APPROVAL_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象コードが重複しています。
BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツ種別が重複して指定されています。
BPW_C_IMPORT_DUPLICATE_PROCESS_CONTENTSTYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツ種別が重複して指定されています。
BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
シート内でプロセス定義名が重複しています。
BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義IDが重複して指定されています。
BPW_C_IMPORT_DUPLICATE_SEND_TO_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
通知先IDが重複しています。
BPW_C_IMPORT_DUPLICATE_TASK_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
タスクIDが重複しています。
BPW_C_IMPORT_INVALID_ACTIVITY_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_APPLICATION_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アプリケーションIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アプリケーションID長が不正です。
BPW_C_IMPORT_INVALID_APPROVAL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別設定が不正です。
BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別設定が不正です。
BPW_C_IMPORT_INVALID_APPROVAL_FOCUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_APPROVAL_OBJECT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス役職コードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス役職種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス処理フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス対象が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_TERM - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス期限が不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス期限長が不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パスユーザコードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
呼び出しプロセス定義コードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
呼び出しプロセス定義コード長が不正です。
BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行クラス長が不正です。
BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリコード長が不正です。
BPW_C_IMPORT_INVALID_CODE_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コード種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CODE_KIND_VALUE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コード種別が不正です。
BPW_C_IMPORT_INVALID_COMPULSION_END_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制終了可否フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONDITION_CALSS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
条件クラスが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
条件クラス長が不正です。
BPW_C_IMPORT_INVALID_CONTENTSTYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツ種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONTENTS_PATH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツパスが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツパス長が不正です。
BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票タイプが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_EFFECTIVE_DATE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
有効日付が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
有効日付長が不正です。
BPW_C_IMPORT_INVALID_END_DATE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
終了日付が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_END_DATE_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
終了日付長が不正です。
BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
イベントサービスIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
イベントサービスID長が不正です。
BPW_C_IMPORT_INVALID_FUNCTION_KBN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
処理区分が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール内容定義長が不正です。
BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール猶予日数が不正です。
BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール猶予日長が不正です。
BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール表題定義長が不正です。
BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール対象種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール対象種別長が不正です。
BPW_C_IMPORT_INVALID_PAGBE_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ページ種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択前アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別とサブプロセス識別フラグの設定が不正です。
BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別とサブプロセス識別フラグの設定が不正です。
BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アプリケーションIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アプリケーションID長が不正です。
BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別が不正です。
BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツ種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツパスが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツパス長が不正です。
BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義コード長が不正です。
BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別設定数が不正です。
BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ページ種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別設定が不正です。
BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サービスIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サービスID長が不正です。
BPW_C_IMPORT_INVALID_PROCESS_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別設定が不正です。
BPW_C_IMPORT_INVALID_REFER_FOCUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照対象が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_REFER_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者ユーザコードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RESULT_CONTENTS_DEF_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
結果通知内容定義長が不正です。
BPW_C_IMPORT_INVALID_RESULT_FROM_DEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
結果通知元定義が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RESULT_FROM_DEF_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
結果通知元定義長が不正です。
BPW_C_IMPORT_INVALID_RESULT_NOTICE_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
結果通知フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RESULT_TITLE_DEF_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
結果通知表題定義長が不正です。
BPW_C_IMPORT_INVALID_RESULT_TO_OBJECT_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
結果通知対象種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RETURN_PULL_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引戻し・差戻しフラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引戻し・差戻しメール送信フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義が不正です。
BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フロー情報のルート定義入力が不正です。
BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセス（申請者／承認者ルート作成ワークフロー）の前アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択の前アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択の前アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義ないのタスクの位置の入力が不正です。
BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実効アクティビティコードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実効アクティビティコード長が不正です。
BPW_C_IMPORT_INVALID_RUN_CLASS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行クラスが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
会社CDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職コードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザコードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_SECOND_APPROVAL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別設定が不正です。
BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
選択ルートコード長が不正です。
BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
選択ルート名長が不正です。
BPW_C_IMPORT_INVALID_SERVECE_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サービスIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_SERVICE_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サービスID長が不正です。
BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
最短終了フラグの設定が不正です。
BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
最短終了フラグの設定が不正です。
BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
最短終了フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_START_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルートの開始アクティビティ種別設定が不正です。
BPW_C_IMPORT_INVALID_SUB_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセスの設定が不正です。
BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセス識別フラグが不正です。
BPW_C_IMPORT_INVALID_TASK_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
タスク定義に存在しないタスクIDが指定されました。
BPW_C_IMPORT_INVALID_TASK_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
タスクタイプが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_TOP_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルートの先頭アクティビティ種別設定が不正です。
BPW_C_IMPORT_INVALID_VERSION_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
履歴コードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_VERSION_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
履歴コード長が不正です。
BPW_C_IMPORT_LACK_SEND_TO_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
通知先情報の指定が不完全です。
BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
オートアダプタマスタ情報が設定されてません。
BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス役職マスタ情報が設定されてません。
BPW_C_IMPORT_NO_AUTO_PASS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス情報が設定されてません。
BPW_C_IMPORT_NO_AUTO_PASS_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パスマスタ情報が設定されてません。
BPW_C_IMPORT_NO_AUTO_PASS_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パスユーザコードが存在しません。
BPW_C_IMPORT_NO_CONTENTS_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツマスタ情報が設定されてません。
BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
イベントアダプタマスタ情報が設定されてません。
BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別設定が不正です。
BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス役職コードが存在しません。
BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者組織コードが存在しません。
BPW_C_IMPORT_NO_EXIST_REFER_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者ユーザコードが存在しません。
BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
会社CDが存在しません。
BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職コードが存在しません。
BPW_C_IMPORT_NO_EXIST_RUN_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザコードが存在しません。
BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
始めの条件クラスが指定されていません。
BPW_C_IMPORT_NO_FIRST_TASK_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
始めのタスクIDが指定されていません。
BPW_C_IMPORT_NO_FIRST_TASK_ID_OF_ROUTE_SELECT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
始めのタスクIDまたは選択ルート名が指定されていません。
BPW_C_IMPORT_NO_FLOW_INNER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フロー内容マスタ情報が設定されてません。
BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フロー内容マスタ情報の実行アクティビティが設定されていません。
BPW_C_IMPORT_NO_LICENSE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定されたプロセス種別に対するライセンスがありません。
BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
オートアダプタ・イベントアダプタ情報を設定するライセンスがありません。
BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチ・フロー情報を設定するライセンスがありません。
BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセスアダプタマスタ情報が設定されてません。
BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
最初のシーケンスにレシーブが存在しません。
BPW_C_IMPORT_NO_RECEIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
レシーブマスタ情報が設定されてません。
BPW_C_IMPORT_NO_RESULT_SEND_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
結果通知先マスタ情報が設定されてません。
BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択マスタ情報が設定されてません。
BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職マスタ情報が設定されてません。
BPW_C_IMPORT_NO_RUN_USER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザマスタ情報が設定されてません。
BPW_C_IMPORT_NO_SELECT_ROUTE_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択マスタ情報の選択ルートコードが設定されていません。
BPW_C_IMPORT_NO_SELECT_ROUTE_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択マスタ情報の選択ルート名が設定されていません。
BPW_C_IMPORT_NO_SEQUENCE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
シーケンス内容マスタ情報が設定されてません。
BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
シーケンスマスタ情報の実行アクティビティが設定されていません。
BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フローのサブルートが存在しません。
BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択のサブルートが存在しません。
BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチのサブルートが存在しません。
BPW_C_IMPORT_NO_SWITCH_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチマスタ情報が設定されてません。
BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチマスタ情報の実行アクティビティが設定されていません。
BPW_C_IMPORT_NO_TASK_DEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
タスク定義が指定されていません。
BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義内のタスクIDがタスク定義に指定されていません。
BPW_C_IMPORT_OVER_NOTE_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
備考文字列長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別文字列長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義名長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義備考文字列長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセス識別フラグ文字列長が最大文字列長を超えています。
BPW_C_IMPORT_PLURAL_APPROVAL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起案タスク以外は、複数対象者の設定をすることはできません。
BPW_C_IMPOSSIBLE_PROCESS_DRAFT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
当該プロセスは起票できません。
BPW_C_IMPOSSIBLE_PROCESS_DRAFT_TARGET_DATE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定した起票指定日では、申請を行う事ができません。
BPW_C_IMPOSSIBLE_PULL_DRAFT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引き戻し処理が実行できません。
BPW_C_IMPOSSIBLE_RETURN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引き戻し・差し戻し処理が実行できません。
BPW_C_IMPOSSIBLE_RETURN_DRAFT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
差し戻し処理が実行できません。
BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
この履歴情報は使用できません。
BPW_C_INPOSSIBLE_DRAFT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請イベントに失敗しました。
BPW_C_INPOSSIBLE_GET_ROOT_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティルート取得イベントに失敗しました。
BPW_C_INPOSSIBLE_GET_USER_APP_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザアプリケーションキー取得イベントに失敗しました。
BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
メールテンプレートの送信に失敗しました。
BPW_C_INPOSSIBLE_PULL_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引き戻しイベントに失敗しました。
BPW_C_INPOSSIBLE_RECOGNITION_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認イベントに失敗しました。
BPW_C_INPOSSIBLE_REGIST_USER_APP_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザアプリケーションキー登録イベントに失敗しました。
BPW_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認者への差し戻しイベントに失敗しました。
BPW_C_INPOSSIBLE_RETURN_START_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請者への差し戻しイベントに失敗しました。
BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
予約メール依頼の設定に失敗しました。
BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
テンプレートメール送信抑止の設定に失敗しました。
BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
メールテンプレートの設定に失敗しました。
BPW_C_INVALID_ACTIVITY_STATUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティステータスが不正です。
BPW_C_INVALID_ACTIVITY_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別が不正です。
BPW_C_INVALID_ADAPTER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アダプタ種別が不正です。
BPW_C_INVALID_APPROVAL_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認種別が不正です。
BPW_C_INVALID_APPROVAL_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認ユーザコードが不正です。
BPW_C_INVALID_ATTACH_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請・承認時の所属情報が指定されていない、または不正です。
BPW_C_INVALID_CATEGORY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるカテゴリ情報が存在しない、または無効です。
BPW_C_INVALID_CATEGORY_CODE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリコードが指定されていない、または不正です。
BPW_C_INVALID_CATEGORY_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリ名称が指定されていない、または不正です。
BPW_C_INVALID_CONTENTS_M_SELECT_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
BPW_C_INVALID_CONTENTS_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
差し戻し、引き戻し時、コンテンツ種別タイプが不正です。
BPW_C_INVALID_DB_PRIMARY_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定情報のデータベースプライマリキー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。
BPW_C_INVALID_GROUPING_CD_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認グルーピングコード種別が不正です。
BPW_C_INVALID_LOGIN_GROUP_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ログイングループIDが指定されていない、または不正です。
BPW_C_INVALID_LOGIN_USER_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ログインユーザIDが指定されていない、または不正です。
BPW_C_INVALID_NECESSARY_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定情報の入力必須キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
BPW_C_INVALID_PROCESSDEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるプロセス定義情報が存在しない、または無効です。
BPW_C_INVALID_PROCESS_DEF_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義名称が指定されていない、または不正です。
BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
BPW_C_INVALID_REFER_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照権限フラグが不正です。
BPW_C_INVALID_REMINDER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール対象種別が不正です。
BPW_C_INVALID_RETURN_DRAFT_SELECT_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請者へ差し戻し処理実行時の指定キー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。
BPW_C_INVALID_RETURN_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引戻し／差戻しは行えません。
BPW_C_INVALID_RETURN_START_RUN_USER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請者への差し戻しイベントに失敗しました。
BPW_C_INVALID_ROOT_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_INVALID_RUN_EXECUTIVE_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体種別が不正です。
BPW_C_INVALID_SELECT_CONDITION_PHRASE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
条件句の指定が不正です。
BPW_C_INVALID_SELECT_IN_PHRASE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
IN指定は他の条件と複合して設定不可能です。
BPW_C_INVALID_TAGET_GROUP - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_INVALID_TRANSFER_CD_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
代理承認者コード種別が不正です。
BPW_C_INVALID_USER_CD_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認者コード種別が不正です。
BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
検索実行時のプライマリキー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
BPW_C_MAGICAL_ACTIVE_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制活性化に失敗しました。
BPW_C_MAGICAL_DEACTIVE_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制活性化に失敗しました。
BPW_C_MAGICAL_PLURAL_RUN_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制活性化に失敗しました。
BPW_C_MAGICAL_RUN_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制活性化に失敗しました。
BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
メールテンプレートの取得に失敗しました。
BPW_C_MOVE_ACTIVITY_RETURN_PULL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
この案件は引戻し出来ません。
BPW_C_NOT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるアクティビティ情報が存在しません。
BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
メール送信送信対象アクティビティ情報が存在しません。
BPW_C_NOT_ACTIVITY_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティマスタ情報が存在しません。
BPW_C_NOT_BACK_IN_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期処理内より、処理外への引戻し／差戻しは行えません。
BPW_C_NOT_CATEGORY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるカテゴリ情報が存在しません。
BPW_C_NOT_DELEGATE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_AGENT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_AGENT_SET - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_ALREADY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_ALREADY_RIGHT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_BACK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_CIRCULATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELETE_VERSION_LASTRECORD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
履歴情報を削除できません。
BPW_C_NOT_EFFECTIVE_DATE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
現在日は有効な日付ではありません。
BPW_C_NOT_GET_PROCESS_CODE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
案件番号の取得に失敗しました。
BPW_C_NOT_GROUP_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付ける実行主体グループテーブルが存在しません。
BPW_C_NOT_HISTORY_RETURN_PULL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
この案件の差戻しの引戻しは出来ません。
BPW_C_NOT_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるプロセス情報が存在しません。
BPW_C_NOT_PROCESSDEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるプロセス定義情報が存在しません。
BPW_C_NOT_PULL_DRAFT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引き戻し先アクティビティが存在しません。
BPW_C_NOT_RECEIVE_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付くレシーブ情報が存在しません。
BPW_C_NOT_RECEIVE_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認を実施するユーザ・組織が存在しません。
BPW_C_NOT_RETURN_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティが存在しません。
BPW_C_NOT_RETURN_DRAFT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
差し戻し先アクティビティが存在しません。
BPW_C_NOT_ROOT_HISTORY_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート作成履歴情報が存在しません。
BPW_C_NOT_RUN_EXECUTIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定された実行主体役職マスタ情報が存在しません。
BPW_C_NOT_RUN_USER_EXECUTIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定された実行主体(ユーザ/役職)マスタ情報が存在しません。
BPW_C_NOT_RUN_USER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザマスタ情報が存在しません。
BPW_C_NOT_RUN_USER_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザ情報が存在しません。
BPW_C_NOT_SET_INVALID_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
論理削除されているデータを更新しようとした場合に発生するエラーです。
BPW_C_NOT_SYNCRONIZED - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期情報が設定されていません。
BPW_C_NOT_VERSION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付ける履歴情報が存在しません。
BPW_C_NO_ATTACH_POSITION_GROUP - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_NO_ATTACH_POSITION_GROUP_AGENT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_NO_AUTHORITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
権限がありません。
BPW_C_NO_AUTO_PASS_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パスマスタ情報と自動パス役職マスタ情報が設定されていません。
BPW_C_NO_DRAFT_CHECK_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票チェックに必要なキーが指定されていません。
BPW_C_NO_DRAFT_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票処理者コードが登録されていません。
BPW_C_NO_EVENT_ADAPTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
イベント実行情報が存在しない。
BPW_C_NO_EXECUTE_ADAPTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
外部実行クラスが存在しません。
BPW_C_NO_EXECUTIVE_GROUP - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職マスタに対象グループが登録されていません。
BPW_C_NO_FLOW_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フロー内容マスタ情報が設定されていません。
BPW_C_NO_INSERT_VALUE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
更新情報が設定されていません。
BPW_C_NO_PROCESS_ADAPTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行プロセスが存在しません。
BPW_C_NO_ROUTE_SELECT_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択マスタ情報が設定されてません。
BPW_C_NO_RUNUSER_EXCUTIVE_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職マスタ情報が設定されていません。
BPW_C_NO_RUNUSER_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザマスタ情報が設定されていません。
BPW_C_NO_RUN_SELECT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択可能なアクティビティではありません。
BPW_C_NO_RUN_SELECT_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択ユーザが指定されていません。
BPW_C_NO_SELECTED_TARGET_TASK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_NO_SEQUENCE_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
シーケンス内容マスタ情報が設定されていません。
BPW_C_NO_SWHITCH_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチマスタ情報が設定されていません。
BPW_C_NO_TRANSFER_AUTHORITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
代理申請権限がありません。
BPW_C_NO_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザコードが存在しません。
BPW_C_NO_VERSION_DRAFT_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票処理コードが登録されていません。
BPW_C_PRAM_ERROR - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
パラメータエラーです。
BPW_C_PROCESS_COUNT_FILE_NOT_FOUND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
案件番号の採番処理に失敗しました。
BPW_C_REPEAT_ORDER_BY_VALUE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ORDER BY句に指定されたカラム名が重複しています。
BPW_C_REPEAT_RUN_SELECT_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
複数の実行時選択ユーザが登録されています。
BPW_C_RETURN_PULL_DIFFER_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
この案件の差戻しの引戻しは引戻せません プロセスの移動を含む差戻しタスクを引戻すことは出来ません。
BPW_C_SHIFT_REFER_DUPLICATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者マスタ移行が出来ません。
BPW_C_SHIFT_REFER_TOOL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者マスタ移行が出来ません。
BPW_C_ZERO_MEMBER_COMPANY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定された組織に属するユーザが存在しません。
BPW_FLOWINFO_INVALID_PARAMETER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フローアイコンを取得する際の入力パラメータ不正です。
BPW_FLOWINFO_NO_EXIST_FLOWICON - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フローアイコンが存在しません。
BPW_INVALID_DRAFT_COMMENT_LENGTH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請コメントの入力文字数が制限を越えています。
BPW_INVALID_PROCESS_NAME_LENGTH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス名の入力文字数が制限を越えています。
BPW_INVALID_RECEIVE_COMMENT_LENGTH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
審議コメントの入力文字数が制限を越えています。
BPW_UT_FAILED_TO_BEGIN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションの開始に失敗しました。
BPW_UT_FAILED_TO_CLOSE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションの終了に失敗しました。
BPW_UT_FAILED_TO_COMMIT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのコミットに失敗しました。
BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
トランザクションが開始していないためコミットに失敗しました。
BPW_UT_FAILED_TO_GET_STATUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのステータスの取得に失敗しました。
BPW_UT_FAILED_TO_LOCK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザアプリケーションロックの解除に失敗しました。
BPW_UT_FAILED_TO_ROLLBACK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのロールバックに失敗しました。
BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
トランザクションが開始していないためロールバックに失敗しました。
BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのロールバックオンリーの設定に失敗しました。
BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのトランザクションタイムアウトの設定に失敗しました。
BPW_UT_FAILED_TO_UNLOCK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザアプリケーションロックの解除に失敗しました。

C

CANCEL - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：取り止め
CATEGORY_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
カテゴリコードキー
CATEGORY_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
カテゴリ名キー
CD_KIND_OFFICIAL - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードがパブリックグループ
CD_KIND_ORG - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードが組織コード
CD_KIND_ROLE - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードがロール
CD_KIND_USER - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードがユーザコード
CLT_AGT_COMPLETE_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
完了タスク表示(代理元承認可委譲)キー
CLT_AGT_GO_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
未処理タスク表示(代理元承認可委譲)キー
CLT_AGT_PULLBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
引き戻しタスク表示(代理元承認可委譲)キー
CLT_AGT_SENDBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
差し戻しタスク表示(代理元承認可委譲)キー
COMPLETE_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
完了タスク表示キー
ConditionAdapter - class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter.
外部プログラム実行抽象クラス。
ConditionAdapter(ConditionModel) - class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter のコンストラクタ
コンストラクタ
ConditionModel - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel.
外部条件クラス（条件分岐, 結合条件)用、パラメータクラス ワークフロー上で条件分岐、結合条件で指定した外部プログラム内で実装する事により、
ログインユーザ情報が取得できます。
ConditionModel() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のコンストラクタ
コンストラクタ
ConditionModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のコンストラクタ
cancel(String, String, String, String, String, String, NegoModel) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
取り止め処理を実行します。
clone() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
クローン
clone() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
クローン
compulsion(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
ここで終了後後処理実行メソッド。
convertEndTaskFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static メソッド
最短終了タスク値を最終タスクフラグに変換します。

D

DRAFT_APPOINT_DATE - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票指定日キー
DRAFT_COMP_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票者の起票会社コードキー
DRAFT_DATE_END - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票日(検索範囲終了)キー
DRAFT_DATE_START - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票日(検索範囲開始日)キー
DRAFT_ORGN_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票者の起票組織コードキー
DRAFT_USER_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票ユーザコードキー
DRAFT_USER_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票ユーザ名キー
Drafter - class jp.co.intra_mart.foundation.wkf.Drafter.
起票関連のAPI
起票関連の処理に使用されるクラスです。
Drafter(String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のコンストラクタ
コンストラクタ１(本人用)
Drafter(String, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のコンストラクタ
コンストラクタ２(代理人用)。
denial(String, String, String, String, String, String, String, NegoModel) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
否認処理を実行します。
draft(String, String, String, String, List, String, String, String, String, NegoModel, RunExecutiveInfoModel, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
起票処理を実行します。
draft(String, String, String, String, List, String, String, String, String, NegoModel, RunUserInfoModel, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
起票処理を実行します。

E

EISModelStaticIF - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF.
アクティビティの状態等を定義するインタフェース。
EIS_INIT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
初期値（数値）
EIS_METHOD_ACTIVED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（開始）
EIS_METHOD_CANCELED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（取消）
EIS_METHOD_CLOSED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（閉じる）
EIS_METHOD_COMPENSATED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（補完）
EIS_METHOD_COMPLETED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（完了）
EIS_METHOD_COMPULSION - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（強制完了）
EIS_METHOD_EXITED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（終了）
EIS_METHOD_FAULTED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（障害）
EIS_METHOD_SUSPENDED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（保留中）
END_TASK_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
非終了タスク
END_TASK_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
終了タスク
execute(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter のメソッド
条件問い合わせを実行するメソッド
条件分岐および、条件結合の判定を行う場合はこのメソッドを継承してください。
existUserCd(Connection, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static メソッド
ユーザコード入力情報をチェックするメソッドです。
exportProcessDef(ArrayList) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義(Excel形式)をエクスポートします。

F

FLG_OFF - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
フラグOFF
FLG_ON - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
フラグON
FlowInfo - class jp.co.intra_mart.foundation.wkf.FlowInfo.
フロー情報オブジェクト
特定のタスクの位置情報を保持した、フロー情報を取得する。
FlowInfo() - class jp.co.intra_mart.foundation.wkf.FlowInfo のコンストラクタ
コンストラクタ

G

GO_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
未処理タスク表示キー
getActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティコードを返却します。
getActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
アクティビティコードを返却します。
getActivityCd() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
アクティビティコードを返却します。
getActivityCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理タスクコードを返却します。
getActivityInfo(String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義コード、バージョンコード、アクティビティコードをキーに
タスク(アクティビティ)情報を取得します。
getActivityName() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティ名を返却します。
getActivityName() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
アクティビティ名を返却します。
getActivityName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理タスク名を返却します。
getActivityProcessDefList(SearchCondition, Sort[], int, int, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
起票可能プロセス一覧を取得します。
getActivityStatus() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティステータスを返却します。
getActivityTaskList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
処理可能案件(未処理案件)一覧の取得を行います。
getActivityType() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティ種別を返却します。
getActivityType() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
アクティビティ種別を返却します。
getAgentUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
代理元ユーザCDを返却します。
getAgentUserCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
代理依頼元ユーザコードを返却します。
getAgentUserName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
代理依頼元ユーザ名を返却します。
getAgtCompFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
完了タスク表示(委譲)を返却します。
getAgtGoFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
未処理タスク表示(委譲)を返却します。
getAgtPullbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
引戻しタスク表示(委譲)を返却します。
getAgtSendbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
差し戻しタスク表示(委譲)を返却します。
getApprovalCompCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者の会社コードを返却します。
getApprovalDateEnd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理日(検索範囲終了日)を返却します。
getApprovalDateStart() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理日(検索範囲開始日)を返却します。
getApprovalOrgnCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者の会社組織コードを返却します。
getApprovalOrgnName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者の会社組織名を返却します。
getApprovalRightType() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認可否種別を返却します。
getApprovalType() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認種別を返却します。
getApprovalTypeCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認種別CDを返却します。
getApprovalUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認者コードを返却します。
getApprovalUserCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者ユーザコードを返却します。
getApprovalUserName() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認者名を返却します。
getApprovalUserName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者ユーザ名を返却します。
getArriveDateEnd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
到達日(検索範囲終了日)を返却します。
getArriveDateStart() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
到達日(検索範囲開始日)を返却します。
getAscending() - class jp.co.intra_mart.foundation.wkf.support.Sort のメソッド
昇順ソートキーを返却します。
getAttachPosition() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
所属立場を返却します。
getAttainmentClass() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
到達種別を返却します。
getAuthorityFlg() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
処理権限フラグを返却します。
getAutoPassFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パス処理フラグを返却します。
getAutoPassTerm() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パス期限を返却します。
getAutoPasslist() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パスのリスト情報を返却します。
getBefActiCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理アクティビティ名を返却します。
getBefActiName() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理アクティビティ名を返却します。
getBefActiUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理者CDを返却します。
getBefActiUserName() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理者名を返却します。
getBeforeUserCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
前処理者ユーザコードを返却します。
getBeforeUserName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
前処理者ユーザ名を返却します。
getCallActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
呼出アクティビティコードを返却します。
getCallActivityType() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
呼出アクティビティ種別を返却します。
getCallProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼出プロセスコードを返却します。
getCallProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼び出しプロセス定義コードを返却します。
getCallVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼び出し履歴コードを返却します。
getCategoryCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
カテゴリコードを返却します。
getCategoryCode() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
カテゴリコードを返却します。
getCategoryInfo(String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
カテゴリコードをキーにしてカテゴリ情報を取得します。
getCategoryInfoByName(String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
カテゴリ名をキーにしてカテゴリ情報を取得します。
getCategoryName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
カテゴリ名を返却します。
getCltAgtCompFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
完了タスク表示(代理元処理可委譲)を返却します。
getCltAgtGoFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
未処理タスク表示(代理元処理可委譲)を返却します。
getCltAgtPullbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
引戻しタスク表示(代理元処理可委譲)を返却します。
getCltAgtSendbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
差し戻しタスク表示(代理元処理可委譲)を返却します。
getCodeValue() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
コード値を返却します。
getComment() - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール本文を返却します。
getCompFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
完了タスク表示を返却します。
getCompanyCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
会社コードを返却します。
getCompanyCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
会社コードを返却します。
getCompulsionEndFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
強制終了可否フラグを返却します。
getConvertLong(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
数値型変換後に返却します。
getCreateDate() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成日時を返却します。
getCreateUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成者コードを返却します。
getCreateUserName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成者名を返却します。
getDemandReceiptCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
依頼要求／受付CDを返却します。
getDemandReceiptName() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
依頼要求／受付名を返却します。
getDescending() - class jp.co.intra_mart.foundation.wkf.support.Sort のメソッド
降順ソートキーを返却します。
getDraftActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
起票処理コードを返却します。
getDraftAppointDate() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票指定日を返却します。
getDraftCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
起票アクティビティコードを取得します。
getDraftComment() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票時コメントを返却します。
getDraftCompCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票者の会社コードを返却します。
getDraftDate() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票日を返却します。
getDraftDateEnd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票日(検索範囲終了日)を返却します。
getDraftDateStart() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票日(検索範囲開始日)を返却します。
getDraftOrgnCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票者の会社組織コードを返却します。
getDraftUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票者コードを返却します。
getDraftUserCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票者ユーザコードを返却します。
getDraftUserName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票者名を返却します。
getDraftUserName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票者ユーザ名を返却します。
getEffectiveDate() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
有効日付を返却します。
getEndDate() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
終了日付を返却します。
getEndFlg() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
分岐終了フラグを返却します。
getEndProcessList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
起票済み案件を取得します。
getEndTaskFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
終了タスクフラグを返却します。
getEndTaskList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
処理済案件一覧の取得を行います。
getErrorCode() - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のメソッド
エラーコードを返却します。
getExtensionA() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＡを返却します。
getExtensionB() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＢを返却します。
getExtensionC() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＣを返却します。
getExtensionD() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＤを返却します。
getExtensionE() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＥを返却します。
getExtensionF() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＦを返却します。
getExtensionG() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＧを返却します。
getExtensionH() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＨを返却します。
getExtensionNameA() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ａを返却します。
getExtensionNameAFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ａ更新対象フラグを返却します。
getExtensionNameB() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｂを返却します。
getExtensionNameBFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｂ更新対象フラグを返却します。
getExtensionNameC() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｃを返却します。
getExtensionNameCFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｃ更新対象フラグを返却します。
getExtensionNameD() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｄを返却します。
getExtensionNameDFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｄ更新対象フラグを返却します。
getExtensionNameE() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｅを返却します。
getExtensionNameEFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｅ更新対象フラグを返却します。
getExtensionNameF() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｆを返却します。
getExtensionNameFFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｆ更新対象フラグを返却します。
getExtensionNameG() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｇを返却します。
getExtensionNameGFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｇ更新対象フラグを返却します。
getExtensionNameH() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｈを返却します。
getExtensionNameHFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｈ更新対象フラグを返却します。
getFileList() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
添付ファイル一覧を取得します。
getFirst() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
自分自身のオブジェクトを、最初のタスクに位置している状態に遷移させる
getFlow() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
プロセス上の現在位置を取得します。
getFlowInfo(String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
特定のタスクの位置情報を保持して、フロー情報を取得する。
getGoFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
未処理タスク表示を返却します。
getGroupList() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
グループ情報リストを返却します。
getGroupName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
グループ名を返却します。
getInstance(String) - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static メソッド
指定されたキーのメールテンプレートファイルを読み込み、テンプレート情報を取得します。
getInstanceByName(String) - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static メソッド
指定されたメールテンプレートファイルを読み込み、テンプレートの情報を返却します。
getIsSubProcess() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
サブプロセスフラグを返却します。
getLast() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
自分自身のオブジェクトを、最後のタスクに位置している状態に遷移させる
getLastManualActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終手動処理コードを返却します。
getLastManualActivityResult() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終手動アクティビティ承認結果種別を返却します。
getLicense() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static メソッド
ライセンスを取得します。
getLimitDateEnd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理期限日(検索範囲終了日)を返却します。
getLimitDateStart() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理期限日(検索範囲開始日)を返却します。
getLocale() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ロケールを返却します。
getLocaleId() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者ロケールIDを返却します。
getLoginGroupID() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログイングループIDを返却します。
getLoginGroupID() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログイングループIDを返却します。
getLoginGroupID() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログイングループIDを返却します。
getLoginGroupID() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログイングループIDを返却します。
getLoginGroupId() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログイングループＩＤを返却します。
getLoginUserID() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログインユーザIDを返却します。
getLoginUserID() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログインユーザIDを返却します。
getLoginUserID() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログインユーザIDを返却します。
getLoginUserID() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログインユーザIDを返却します。
getLoginUserId() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログインユーザＩＤを返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
ユーザ情報返却メソッド
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログインユーザ情報を返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログインユーザ情報を返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログインユーザ情報を返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログインユーザ情報を返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログインユーザ情報を返却します。
getMailTamplate() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
設定されたメールテンプレートを取得します。
getNext() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
自分自身のオブジェクトを、次のタスクに位置している状態に遷移させる。
getNote() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
備考を返却します。
getPairNo() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
ペアNOを返却します。
getParallelNestCnt() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
同期処理階層カウンタを返却します。
getPostCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
役職コードを返却します。
getPostCdKind() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
役職コード種別を返却します。
getPreActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機アクティビティコードを返却します。
getPreApprovalType() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
前承認種別を返却します。
getPreProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機プロセスコードを返却します。
getPreProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機プロセス定義コードを返却します。
getPreVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機履歴コードを返却します。
getPresentDisplayInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
現処理表示情報を返却します。
getPresentProcess() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
現処理を返却します。
getPrev() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
自分自身のオブジェクトを、前のタスクに位置している状態に遷移させる。
getProcessCallActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼出処理コードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
プロセスコードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセスコードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセスコードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
プロセスコードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
プロセスコードを返却します。
getProcessClassCode() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス種別コードを返却します。
getProcessClassCodeFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス種別コード更新対象フラグを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
プロセス定義コードを返却します。
getProcessDefInfo(String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義コードをキーにしてプロセス定義情報を取得します。
getProcessDefInfoByName(String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義名をキーにしてプロセス定義情報を取得します。
getProcessDefInfoByVersion(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義コード、バージョンコードをキーにしてプロセス定義情報を取得します。
getProcessDefName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
プロセス定義名を返却します。
getProcessHistory() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
案件の処理履歴を取得します。
getProcessInfo() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
プロセス情報を取得します。
getProcessList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス一覧情報を取得します。
getProcessName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセス名を返却します。
getProcessName() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス名(サブプロセス申請用)を返却します。
getProcessName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
プロセス名を返却します。
getProcessNestCnt() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
サブプロセス呼出カウンタを返却します。
getProcessStatus() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセスステータスを返却します。
getProcessTermDate() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理期限日付を返却します。
getProcessingStatus() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理状態識別を返却します。
getPullbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
引戻しタスク表示を返却します。
getReceiveComment() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認時コメントを返却します。
getReceivelist() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
レシーブのリスト情報を返却します。
getReceptionDate() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
受信日付を返却します。
getRecognitionStatus() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認ステータスを返却します。
getRecordDate() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新日時を返却します。
getRecordUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新者コードを返却します。
getRecordUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
最終更新者コードを返却します。
getRecordUserName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新者名を返却します。
getReferTaskList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Reference のメソッド
参照可能案件一覧を取得します。
getRepresentationType() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
代理コード種別を返却します。
getReserveInfo() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
送信されるメール内容情報を取得します。
getResultNoticeFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
結果通知フラグを返却します。
getReturnFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
引戻し・差戻しフラグを返却します。
getReturnMailFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
引戻し・差戻しメール送信フラグを返却します。
getRollSelectFlg() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
ロール絞込み指定フラグを返却します。
getRouteInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
申請者/承認者ルート作成-ルート情報を取得します。
getRunExecuteInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
実行主体ユーザマスタ情報を返却します。
getRunSelectFlg() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
実行時選択フラグを返却します。
getRunUserInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
実行主体役職マスタ情報を返却します。
getRunuserlist() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
実行主体ユーザのリスト情報を返却します。
getSelectRouteNo() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
選択ルート番号を返却します。
getSelectRouteNo() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
選択ルート番号を返却します。
getSendbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
差し戻しタスク表示を返却します。
getStartActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
開始処理コードを返却します。
getStartActivityCdFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
開始処理コード更新対象フラグを返却します。
getStatusEndedDate() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ステータス完了日付を返却します。
getSubProcessFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
サブプロセス識別フラグを返却します。
getSubProcessFlagFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
サブプロセス識別フラグ更新対象フラグを返却します。
getSyncronizedInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
同期情報を返却します。
getTargetDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
所属組織を取得します。
getTargetDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
所属組織を取得します。
getTargetMasterDate() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
対象マスタ日付を返却します。
getTargetMasterDate() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
対象指定日を返却します。
getTaskResultInfo(String) - class jp.co.intra_mart.foundation.wkf.Process のメソッド
タスク処理結果情報を取得します。
getTitle() - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメールタイトルを返却します。
getTransactorCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者コードを返却します。
getTransactorName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者名を返却します。
getTransferFlg() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
代理フラグを返却します。
getTransferFlg() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
代理フラグを返却します。
getTransferInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
処理委譲情報を取得します。
getTransferUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
振替先ユーザCDを返却します。
getTransferUserName() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
振替先ユーザ名を返却します。
getUserAppliKey(int) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を 返却します。
getUserAppliKeyList() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
ユーザアプリケーションキーテーブル情報リストを返却します。
getUserApplikeyList() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ユーザアプリケーションキーテーブル情報リストを返却します。
getUserApplikeyList() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ユーザアプリケーションキーテーブル情報リストを返却します。
getUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ユーザコードを返却します。
getUserList() - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール送信者リストを返却します。
getUserName() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ユーザ名を返却します。
getVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
履歴コードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
履歴コードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
履歴コードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴コードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
バージョンコードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
バージョンコードを返却します。
getVersionInfo(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
バージョン(ルート)情報を取得します。
getVersionName() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス定義（履歴名）を取得します。
getVersionName() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴名を返却します。
getVersionNameFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴名更新対象フラグを返却します。

H

hasNext() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
次のタスクが存在するかどうかを返却する。
hasPrev() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
前のタスクが存在するかどうかを返却する。

I

IWM_DEFINE_BCC - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static 変数
テンプレート内指定キー“Bcc”
IWM_DEFINE_BODY - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static 変数
テンプレート内指定キー“Body”
IWM_DEFINE_CC - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static 変数
テンプレート内指定キー“Cc”
IWM_DEFINE_FROM - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static 変数
テンプレート内指定キー“From”
IWM_DEFINE_REPLAY - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static 変数
テンプレート内指定キー“Reply-To”
IWM_DEFINE_SUBJECT - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static 変数
テンプレート内指定キー“Subject”
IWM_DEFINE_TO - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer の static 変数
テンプレート内指定キー“To”
importProcessDef(Object) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義(Excel形式)をインポートします。
inputCheck(Connection, String, UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
実行主体役職マスタ入力情報をチェックするメソッドです。
inputCheck(Connection, String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
実行主体ユーザ入力情報をチェックするメソッドです。
inputCheck(Connection, String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴マスタ入力情報をチェックするメソッドです。
isAutoPassFlag() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
自動パスフラグを返却します。
isReserve() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メール予約機能使用有無を判定します。
isSatisfied() - class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter のメソッド
条件問い合わせ
isStop() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
テンプレートメールの送信抑止を判定します。

J

jp.co.intra_mart.foundation.bpw.exception - package jp.co.intra_mart.foundation.bpw.exception
jp.co.intra_mart.foundation.bpw.model.data - package jp.co.intra_mart.foundation.bpw.model.data
jp.co.intra_mart.foundation.bpw.model.object - package jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf - package jp.co.intra_mart.foundation.wkf
jp.co.intra_mart.foundation.wkf.support - package jp.co.intra_mart.foundation.wkf.support
jp.co.intra_mart.system.bpw - package jp.co.intra_mart.system.bpw

L

LIMIT_DATE_END - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理期限日(検索範囲終了日)キー
LIMIT_DATE_START - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理期限日(検索範囲開始日)キー

M

MAGICAL_HAND - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：強制操作
MAIL_USER_ADDRESS - class jp.co.intra_mart.foundation.wkf.NegoModel の static 変数
MAIL_USER_CD - class jp.co.intra_mart.foundation.wkf.NegoModel の static 変数
送信先ユーザコードキー
MAIL_USER_NAME - class jp.co.intra_mart.foundation.wkf.NegoModel の static 変数
MailTemplateAnalizer - class jp.co.intra_mart.system.bpw.MailTemplateAnalizer.
Manager - class jp.co.intra_mart.foundation.wkf.Manager.
マスタ関連のAPI
マスタメンテナンス関連処理で使用されるクラスです。
Manager(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のコンストラクタ
コンストラクタ
カテゴリの編集権限ロールをもつユーザを指定してください。

N

NON_BILONGING - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
無所属時のダミーコード
NO_PAIR - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
ペアNOがペアではない
NegoModel - class jp.co.intra_mart.foundation.wkf.NegoModel.
BPWModelIFを保持するリストクラス
NegoModel() - class jp.co.intra_mart.foundation.wkf.NegoModel のコンストラクタ
コンストラクタ
noTransaction() - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
データベーストランザクションを未使用にする。
noTransaction() - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
データベーストランザクションを未使用にする。
noTransaction() - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
データベーストランザクションを未使用にする。

O

OLD_DATA - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
旧データ （旧データ：ペアＮＯのデフォルト値）

P

POST_TYPE_POSITION - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードが役職コード （絞込み）
POST_TYPE_ROLE - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードがロール （絞込み）
PROCESSING_COMPLETED - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【共通】完了
PROCESSING_NORMALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】通常(通常到達にて活性化)
PROCESSING_PSN_NORMALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】通常(通常到達にて活性化)
PROCESSING_PSN_PULL_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】引戻し(引戻しにて活性化)
PROCESSING_PSN_PULL_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】引戻し(引戻しにて活性化後の保留)
PROCESSING_PSN_SEND_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】差戻し(差戻しにて活性化)
PROCESSING_PSN_SEND_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】差戻し(差戻しにて活性化後の保留)
PROCESSING_PSN_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)
PROCESSING_PULL_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】引戻し(引戻しにて活性化)
PROCESSING_PULL_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】引戻し(引戻しにて活性化後の保留)
PROCESSING_SEND_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】差戻し(差戻しにて活性化)
PROCESSING_SEND_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】差戻し(差戻しにて活性化後の保留)
PROCESSING_SUB_NORMALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】通常(通常到達にて活性化)
PROCESSING_SUB_PULL_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】引戻し(引戻しにて活性化)
PROCESSING_SUB_PULL_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】引戻し(引戻しにて活性化後の保留)
PROCESSING_SUB_SEND_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】差戻し(差戻しにて活性化)
PROCESSING_SUB_SEND_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】差戻し(差戻しにて活性化後の保留)
PROCESSING_SUB_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)
PROCESSING_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】通常(通常到達にて活性化後の保留)
PROCESS_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
プロセスコードキー
PROCESS_CLASS_BPW - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
プロセス種別コード : ビジネスプロセスワークフロー
PROCESS_CLASS_DRW - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
プロセス種別コード : 申請者／承認者ルート作成ワークフロー
PROCESS_CLASS_DW - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
プロセス種別コード : ドキュメントワークフロー
PROCESS_DEF_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
プロセス定義コードキー
PROCESS_DEF_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
プロセス定義名キー
PROCESS_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
プロセス名キー
PULLBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
引き戻しタスク表示キー
PULL_ACTIVITY_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
引き戻し不可
PULL_ACTIVITY_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
引き戻し可
Process - class jp.co.intra_mart.foundation.wkf.Process.
案件関連のAPI
案件関連の情報取得などに使用されるクラスです。
Process(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Process のコンストラクタ
コンストラクタ
ProcessInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel.
プロセス情報を保持する情報クラス
ProcessInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のコンストラクタ
コンストラクタ
proceed(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
処理実行メソッド。
pullBack(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
引き戻し処理を実行します。
pullBack(String, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
引戻し処理を実行します。
pullDraft(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
引戻し後処理実行メソッド。

R

RECOGNITION - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：承認
REFER_ALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
参照者若しくは承認者として関連図けられたアクティビティ
REFER_NONE - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
参照者・承認者を考慮しない
REFER_READ - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
参照者として関連図けられたアクティビティ
REFER_RECOGNITION - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
承認者として関連図けられたアクティビティ
REJECTION - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：棄却
RETRY - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：再申請
RETURN_ACTIVITY_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
差し戻し不可
RETURN_ACTIVITY_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
差し戻し可
RETURN_BEFORE - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：承認者へ差し戻す
RETURN_MAIL_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
差し戻しメール送信なし
RETURN_MAIL_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
差し戻しメール送信あり
RETURN_PULL - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：引き戻し
RETURN_START - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：申請者へ差し戻す
RETURN_TYPE_BEFORE - class jp.co.intra_mart.foundation.wkf.Approver の static 変数
差戻し種別：前処理者へ差戻し
RETURN_TYPE_START - class jp.co.intra_mart.foundation.wkf.Approver の static 変数
差戻し種別：申請者へ差戻し
RIGHT_DELEGATE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：振替・本人決済可（振替(02)の承認種別CDでのみ有効）
RIGHT_INIT - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：初期値（全ての承認種別CDで有効）
RIGHT_NOT_DELEGATE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：振替・本人決済不可（振替(02)の承認種別CDでのみ有効）
RIGHT_NOT_PERSON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：代理・本人決済不可（本人(00)の承認種別CDでのみ有効）
RIGHT_PERSON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：代理・本人決済可（本人(00)の承認種別CDでのみ有効）
ROLL_SELECT_OFF - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
ロール絞込み指定ON
ROLL_SELECT_ON - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
ロール絞込み指定OFF
RUN_AUTH_ALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
処理権限・代理権限供にあるアクティビティ
RUN_AUTH_NOT - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
処理権限がないアクティビティ
RUN_AUTH_RUN - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
処理権限があるアクティビティ
RUN_AUTH_TRANSFER - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
代理処理権限があるアクティビティ
RUN_SELECT_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
実行時選択OFF
RUN_SELECT_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
実行時選択ON
RecognitionInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel.
処理要求時情報モデル。
RecognitionInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のコンストラクタ
コンストラクタ
RecognitionInfoModel(ProcessInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のコンストラクタ
RecognitionInfoModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のコンストラクタ
Reference - class jp.co.intra_mart.foundation.wkf.Reference.
参照関連のAPI
参照案件の取得などに使用されるクラスです。
Reference(String, String) - class jp.co.intra_mart.foundation.wkf.Reference のコンストラクタ
コンストラクタ
RunExecutiveInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel.
実行主体役職マスタの情報保持クラス
次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。
RunExecutiveInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のコンストラクタ
RunExecutiveInfoModel(ReceiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のコンストラクタ
RunExecutiveInfoModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のコンストラクタ
RunExecutiveInfoModel(RunExecutiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のコンストラクタ
RunUserInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel.
実行主体ユーザ情報を保持する情報クラス
RunUserInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
コンストラクタ
RunUserInfoModel(ProcessInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(ActivityMasterUnitModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(ReceiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(RunUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(DelegateUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
rejection(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
否認後後処理実行メソッド。
removeInfo() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
共有メモリ内のメール設定情報を削除します。
removeProcess(String, String, String, Boolean) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
案件を削除を実行します。
reserveCancel() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メール予約機能の使用を取消します。
reserveRequest() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メール予約機能の使用を依頼します。
retry(String, String, String, String, List, String, String, String, String, NegoModel, RunExecutiveInfoModel, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
再起票処理を実行します。
retry(String, String, String, String, List, String, String, String, String, NegoModel, RunUserInfoModel, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
再起票処理を実行します。
returnDraft(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
処理者へ差戻し後処理実行メソッド。
returnStart(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
申請者へ差戻し後処理実行メソッド。

S

SENDBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
差し戻しタスク表示キー
STATUS_ACTIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
有効な状態であることを示すステータス
STATUS_AUTOCLOSING - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
自動終了を示すステータス
STATUS_CANCELING - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
取消中であることを示すステータス
STATUS_CLOSING - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
終了したことを示すステータス
STATUS_COMPENSATING - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
補完中であることを示すステータス
STATUS_COMPLETE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認ステータス：処理済（全ての承認種別CDで有効）
STATUS_COMPLETED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
完了したことを示すステータス
STATUS_DELEGATE_COMPLETE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認ステータス：振替処理済（本人(00), 振替(02)の承認種別CDでのみ有効）
STATUS_EXIT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
処理が終了したことを示すステータス
STATUS_FAULT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
障害が発生したことを示すステータス
STATUS_INIT - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認ステータス：初期値（全ての承認種別CDで有効）
STATUS_NONE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
有効なステータスではない
STATUS_READY - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
準備完了を示すステータス
STATUS_SAID_COMPLETE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認ステータス：代理処理済（本人(00)の承認種別CDでのみ有効）
STATUS_SUSPEND - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
保留中であることを示すステータス
STR_INIT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
初期値（文字列）
STR_NULL - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
空文字
SUB_PROCESS_INIT - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
サブプロセス識別フラグ : 通常／サブ利用可能プロセス
SUB_PROCESS_ONLY - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
サブプロセス識別フラグ : サブ利用特化プロセス
SUSPENSION - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：保留
SearchCondition - class jp.co.intra_mart.foundation.wkf.support.SearchCondition.
プログラムサポート/検索条件設定オブジェクト。
SearchCondition() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のコンストラクタ
コンストラクタ
Sort - class jp.co.intra_mart.foundation.wkf.support.Sort.
プログラムサポート/ソート指定オブジェクト。
Sort() - class jp.co.intra_mart.foundation.wkf.support.Sort のコンストラクタ
コンストラクタ
send() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メールの送信を実行します。
sendBack(String, String, String, String, String, String, String, String, NegoModel) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
差し戻し処理を実行します。
sendMail(String, String, String, String, String, ArrayList, ArrayList, ArrayList) - class jp.co.intra_mart.foundation.wkf.Util のメソッド
メール送信処理を行います。
setActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティコードを設定します。
setActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
アクティビティコードを設定します。
setActivityName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティ名を設定します。
setActivityName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
アクティビティ名を設定します。
setActivityStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティステータスを設定します。
setActivityType(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティ種別を設定します。
setAgentUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
代理元ユーザCDを設定します。
setApprovalRightType(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認可否種別を設定します。
setApprovalType(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認種別を設定します。
setApprovalTypeCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認種別CDを設定します。
setApprovalUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認者コードを設定します。
setApprovalUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認者名を設定します。
setAscending(String) - class jp.co.intra_mart.foundation.wkf.support.Sort のメソッド
昇順ソートキーを設定します。
setAttachPosition(RunGroupInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
所属立場を設定します。
setAttainmentClass(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
到達種別を設定します。
setAuthorityFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
処理権限フラグを設定します。
setAutoPassFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パス処理フラグを設定します。
setAutoPassFlag(boolean) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
自動パスフラグを設定します。
setAutoPassTerm(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パス期限を設定します。
setBefActiCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理アクティビティコードを設定します。
setBefActiName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理アクティビティ名を設定します。
setBefActiUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理者CDを設定します。
setBefActiUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理者名を設定します。
setCallActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
呼出アクティビティコードを設定します。
setCallActivityType(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
呼出アクティビティ種別を設定します。
setCallProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼出案件コードを設定します。
setCallProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼び出しプロセス定義コードを設定します。
setCallVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼び出し履歴コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
カテゴリコードを設定します。
setCodeValue(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
コード値を設定します。
setComment(String) - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール本文を設定します。
setCompanyCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
会社コードを設定します。
setCompanyCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
会社コードを設定します。
setCompulsionEndFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
強制終了可否フラグを設定します。
setCondition(Map) - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
検索条件を設定します。
setCreateDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成日時を設定します。
setCreateDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
作成日時を設定します。
setCreateUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成者コードを設定します。
setCreateUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
作成者コードを設定します。
setCreateUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成者名を設定します。
setCreateUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
作成者名を設定します。
setDemandReceiptCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
依頼要求／受付CDを設定します。
setDemandReceiptName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
依頼要求／受付名を設定します。
setDescending(String) - class jp.co.intra_mart.foundation.wkf.support.Sort のメソッド
降順ソートキーを設定します。
setDraftActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
起票処理コードを設定します。
setDraftCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
* 起票アクティビティコードを設定します。
setDraftComment(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票時コメントを設定します。
setDraftDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票日を設定します。
setDraftUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票者コードを設定します。
setDraftUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票者名を設定します。
setEffectiveDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
有効日付を設定します。
setEndDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
終了日付を設定します。
setEndTaskFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
終了タスクフラグを設定します。
setExtensionA(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＡを設定します。
setExtensionB(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＢを設定します。
setExtensionC(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＣを設定します。
setExtensionD(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＤを設定します。
setExtensionE(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＥを設定します。
setExtensionF(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＦを設定します。
setExtensionG(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＧを設定します。
setExtensionH(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＨを設定します。
setExtensionNameA(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ａを設定します。
setExtensionNameB(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｂを設定します。
setExtensionNameC(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｃを設定します。
setExtensionNameD(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｄを設定します。
setExtensionNameE(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｅを設定します。
setExtensionNameF(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｆを設定します。
setExtensionNameG(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｇを設定します。
setExtensionNameH(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｈを設定します。
setGroupName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
グループ名を設定します。
setLastManualActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終手動処理コードを設定します。
setLastManualActivityResult(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終手動処理コードを設定します。
setLocaleId(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者ロケールIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログイングループIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログイングループIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログイングループIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログイングループIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログイングループIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログインユーザIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログインユーザIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログインユーザIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログインユーザIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログイングループIDを設定します。
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
ユーザ情報設定メソッド
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログイン情報を設定します。
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログイン情報を設定します。
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログイン情報を設定します。
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログイン情報を設定します。
setMailTamplate(HashMap) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メールテンプレートの設定を行います。
setNote(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
備考を設定します。
setPairNo(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
ペアNOを設定します。
setParallelNestCnt(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
同期処理階層カウンタを設定します。
setPostCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
役職コードを設定します。
setPostCdKind(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
役職コード種別を設定します。
setPreActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機アクティビティコードを設定します。
setPreApprovalType(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
前承認種別を設定します。
setPreProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機プロセスコードを設定します。
setPreProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機プロセス定義コードを設定します。
setPreVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機履歴コードを設定します。
setPresentDisplayInfo(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
現処理表示情報を設定します。
setPresentProcess(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
現処理を設定します。
setProcessCallActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼出処理コードを設定します。
setProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
検索条件とするプロセスコードを設定します。
setProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
検索条件とするプロセスコードを設定します。
setProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセスコードを設定します。
setProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
プロセスコードを設定します。
setProcessClassCode(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス種別コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
検索条件とするプロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
検索条件とするプロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス定義コードを設定します。
setProcessName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセス名を設定します。
setProcessName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス名(サブプロセス申請用)を設定します。
setProcessNestCnt(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
サブプロセス呼出カウンタを設定します。
setProcessStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセスステータスを設定します。
setProcessTermDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
検索条件とするプロセスコードを設定します。
setProcessingStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理状態識別を設定します。
setReceiveComment(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認時コメントを設定します。
setReceptionDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
受信日付をを設定します。
setRecognitionStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認ステータスを設定します。
setRecordDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新日時を設定します。
setRecordDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
最終更新日時を設定します。
setRecordUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新者コードを設定します。
setRecordUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
最終更新者コードを設定します。
setRecordUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新者名を設定します。
setRecordUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
最終更新者名を設定します。
setRepresentationType(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
代理コード種別を設定します。
setReserveInfo(ArrayList) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
送信メール情報を設定します。
setResultNoticeFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
結果通知フラグを設定します。
setReturnFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
引戻し・差戻しフラグを設定します。
setReturnMailFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
引戻し・差戻しメール送信フラグ設定します。
setRollSelectFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
ロール絞込み指定フラグを設定します。
setRouteInfoModel(RouteInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
申請者/承認者ルート作成-ルート情報設定します。
setRunExecuteInfoModel(RunExecutiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
実行時選択時実行主体役職マスタテーブルを設定します。
setRunSelectFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
実行時選択フラグを設定します。
setRunUserInfoModel(RunUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
実行時選択時実行主体ユーザマスタ情報を設定します。
setSelectRouteNo(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
選択ルート番を設定します。
setSelectRouteNo(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
選択ルート番号を設定します。
setStartActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
開始処理コードを設定します。
setStatusEndedDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ステータス完了日付を設定します。
setSubProcessFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
サブプロセス識別フラグを設定します。
setSyncronizedInfo(SyncronizedInfo) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
同期情報を設定します。
setTamplateRequest(String) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メールテンプレートの設定を行います。
setTargetMasterDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
対象マスタ日付を設定します。
setTargetMasterDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
対象指定日を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメールタイトルを設定します。
setTransactorCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者コードを設定します。
setTransactorName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者名を設定します。
setTransferFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
代理フラグを設定します。
setTransferFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
代理フラグを設定します。
setTransferInfoModel(TransferTableInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
処理委譲情報を設定します。
setTransferUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
振替先ユーザCDを設定します。
setTransferUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
振替先ユーザ名を設定します。
setUserApplikeyList(Map) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ユーザアプリケーションキーテーブル情報リストを設定します。
setUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ユーザコードを設定します。
setUserList(ArrayList) - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール送信者リストを設定します。
setUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ユーザ名を設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
検索条件とする履歴コードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
検索条件とする履歴コードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
履歴コードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴コードを設定します。
setVersionName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス定義（履歴名）を設定します。
setVersionName(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴名を設定します。
stopCancel() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
テンプレートメールの送信停止を取り止めます。
stopRequest() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
同一スレッド内のテンプレートメールの標準送信を停止させます。
subProcessDraft(String, String, String, String, String, String, List, String, String, String, NegoModel, RunExecutiveInfoModel, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
subProcessDraft(String, String, String, String, String, String, List, String, String, String, NegoModel, RunUserInfoModel, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
suspend(String, String, String, String, String, String, String, NegoModel) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
保留処理を実行します。

T

TARGET_AUTOPASS - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：対象者自動パス
TRANSFER_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
代理承認者なし
TRANSFER_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel の static 変数
申請者(申請者)
TRANSFER_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
代理承認者あり
TRANSFER_ON - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel の static 変数
申請者(代理申請者)
TYPE_DELEGATE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認対象種別コード：振替
TYPE_PERSON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認対象種別コード：本人
TYPE_SAID_PERSON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認対象種別コード：代理

U

Util - class jp.co.intra_mart.foundation.wkf.Util.
ユーティリティ バッチ起動用クラス
Util(String) - class jp.co.intra_mart.foundation.wkf.Util のコンストラクタ
コンストラクタ

V

VERSION_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
バージョンコードキー
VersionInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel.
履歴情報を保持する情報クラス
VersionInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のコンストラクタ
コンストラクタ

W

WFK_C_NOT_TEMPLATE_PATH - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたメールテンプレートが不正です。
WKFApplicationException - exception jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException.
ＢＰＷのアプリケーション例外クラス
WKFApplicationException() - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
コンストラクタ
WKFApplicationException(String) - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
エラーコードを保持した例外を生成します。
WKFApplicationException(String, String) - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
エラーコードと詳細メッセージを保持した例外を生成します。
WKFApplicationException(String, Throwable) - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
エラーコードと例外の発生原因となる例外を保持した例外を生成します。
WKFApplicationException(String, String, Throwable) - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
エラーコード、詳細メッセージと例外の発生原因となる例外を保持した例外を生成します。
WKFErrorCodeIF - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF.
ＢＰＷで利用される例外エラーコードインタフェース定義
WKF_C_APPROVAL_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
承認種別の取得に失敗しました。
WKF_C_AUTO_PASS - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動パスの処理に失敗しました。
WKF_C_AUTO_PRESS - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動催促の処理に失敗しました。
WKF_C_DEPARTMENT_INFO_ERROR - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
所属組織情報が不正です。
WKF_C_DRAFT_ACTIVITY_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
起票アクティビティコードの取得に失敗しました。
WKF_C_DRAFT_APPOINT_DATE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
起票指定日の取得に失敗しました。
WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
次アクティビティコードが指定されていない、または不正です。
WKF_C_INPOSSIBLE_DRAFT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
申請イベントに失敗しました。
WKF_C_INPOSSIBLE_PULL_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
引き戻しイベントに失敗しました。
WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
承認イベントに失敗しました。
WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
承認者への差し戻しイベントに失敗しました。
WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
申請者への差し戻しイベントに失敗しました。
WKF_C_NOT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
アクティビティ情報が存在しません。
WKF_C_NOT_APPLICATION_KEY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
アプリケーションキーが設定されていない、または不正です。
WKF_C_NOT_DEPARTMENT_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
所属組織情報の取得に失敗しました。
WKF_C_NOT_PROCESS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス情報の取得に失敗しました。
WKF_C_NOT_REGIST_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
起票タスクの対象者に指定されていない、または不正です。
WKF_C_NOT_VERSION - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
履歴情報が存在しません。
WKF_C_NO_MANAGER_AUTHORITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
このAPIはワークフロー管理者ロールをもつユーザ以外のユーザでは使用できません。
WKF_C_PRAM_AGT_ALL - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
代理元ユーザが不正です。
WKF_C_PRAM_ERROR - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
パラメータが不正です。
WKF_C_PROCESS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス情報の取得に失敗しました。
WKF_C_REMOVE_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセスの削除に失敗しました。
WKF_C_SEND_MAIL - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
メール送信に失敗しました。
WfeResultMailManager - class jp.co.intra_mart.system.bpw.WfeResultMailManager.
ワークフローエンジン内にて結果送信メール（テンプレート）の送信情報の管理保持を行う。
WfeResultMailManager() - class jp.co.intra_mart.system.bpw.WfeResultMailManager のコンストラクタ
A B C D E F G H I J L M N O P R S T U V W
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


intra-mart ワークフロー

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (intra-mart ワークフロー)

ワークフローモジュール
すべてのクラス

パッケージ
jp.co.intra_mart.foundation.bpw.exception
jp.co.intra_mart.foundation.bpw.model.data
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf
jp.co.intra_mart.foundation.wkf.support
jp.co.intra_mart.system.bpw


概要 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

intra-mart(R) ワークフローモジュール
API 仕様

パッケージ
jp.co.intra_mart.foundation.bpw.exception
jp.co.intra_mart.foundation.bpw.model.data
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf
jp.co.intra_mart.foundation.wkf.support
jp.co.intra_mart.system.bpw

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


クラス階層 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.bpw.exception, jp.co.intra_mart.foundation.bpw.model.data, jp.co.intra_mart.foundation.bpw.model.object, jp.co.intra_mart.foundation.wkf, jp.co.intra_mart.foundation.wkf.support, jp.co.intra_mart.system.bpw

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel
      • class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.io.Serializable)
    • class jp.co.intra_mart.foundation.wkf.Approver
    • class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic
    • class jp.co.intra_mart.foundation.bpw.model.data.Condition
      • class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter
    • class jp.co.intra_mart.foundation.wkf.Drafter
    • class jp.co.intra_mart.foundation.bpw.model.object.ExternalModel
      • class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel
    • class jp.co.intra_mart.foundation.wkf.FlowInfo
    • class jp.co.intra_mart.system.bpw.MailTemplateAnalizer
    • class jp.co.intra_mart.foundation.wkf.Manager
    • class jp.co.intra_mart.foundation.wkf.NegoModel
    • class jp.co.intra_mart.foundation.wkf.Process
    • class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable)
    • class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel
    • class jp.co.intra_mart.foundation.wkf.Reference
    • class jp.co.intra_mart.foundation.wkf.support.SearchCondition
    • class jp.co.intra_mart.foundation.wkf.support.Sort
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException
    • class jp.co.intra_mart.foundation.wkf.Util
    • class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF)
    • class jp.co.intra_mart.system.bpw.WfeResultMailManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF
  • interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF
  • interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


(intra-mart ワークフロー)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (intra-mart ワークフロー)

ワークフローモジュール
前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.bpw.exception

クラス jp.co.intra_mart.foundation.bpw.exception.BPWApplicationException は jp.co.intra_mart.framework.system.exception.ApplicationException を拡張し、Serializable を実装しています

直列化されたフィールド

errorCode

java.lang.String errorCode

クラス jp.co.intra_mart.foundation.bpw.exception.BPWProcessDefException は jp.co.intra_mart.foundation.bpw.exception.BPWApplicationException を拡張し、Serializable を実装しています

直列化されたフィールド

processDefName

java.lang.String processDefName

クラス jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException は jp.co.intra_mart.framework.system.exception.ApplicationException を拡張し、Serializable を実装しています

直列化されたフィールド

errorCode

java.lang.String errorCode
例外内容を特定する為のエラーコード

パッケージ jp.co.intra_mart.foundation.bpw.model.data

クラス jp.co.intra_mart.foundation.bpw.model.data.RootInfoModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoModel parent

childList

java.util.ArrayList childList

クラス jp.co.intra_mart.foundation.bpw.model.data.RouteDetailInfoModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

dynamicTask

boolean dynamicTask

indispensable

boolean indispensable

displayTask

java.lang.String displayTask

displayModel

ActivityInfoModel displayModel

クラス jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

detailMap

java.util.Map detailMap

displaySize

java.awt.Point displaySize

displayInfo

java.util.ArrayList displayInfo

activityMap

java.util.Map activityMap

rootInfo

jp.co.intra_mart.foundation.bpw.model.data.RootInfoModel rootInfo

pullActivityFlag

boolean pullActivityFlag

draftCreateRootFlag

boolean draftCreateRootFlag

draftHistoryModel

jp.co.intra_mart.foundation.bpw.model.object.DraftRootHistoryInfoModel draftHistoryModel

draftDetailList

jp.co.intra_mart.foundation.bpw.model.object.DraftRootDetailListModel draftDetailList

processDefCd

java.lang.String processDefCd

versionCd

java.lang.String versionCd

processCd

java.lang.String processCd

parentProcessCd

java.lang.String parentProcessCd

パッケージ jp.co.intra_mart.foundation.bpw.model.object

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityCoreListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityData は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityName

java.lang.Object activityName

activityType

java.lang.Object activityType

activityStatus

java.lang.Object activityStatus

statusEndedDate

java.lang.Object statusEndedDate

callActivityCd

java.lang.Object callActivityCd

callActivityType

java.lang.Object callActivityType

resultNoticeFlag

java.lang.Object resultNoticeFlag

autoPassTerm

java.lang.Object autoPassTerm

autoPassFlag

java.lang.Object autoPassFlag

attainmentClass

java.lang.Object attainmentClass

receptionDate

java.lang.Object receptionDate

processTermDate

java.lang.Object processTermDate

presentProcess

java.lang.Object presentProcess

befActiCd

java.lang.Object befActiCd

befActiName

java.lang.Object befActiName

befActiUserCd

java.lang.Object befActiUserCd

befActiUserName

java.lang.Object befActiUserName

compulsionEndFlag

java.lang.Object compulsionEndFlag

returnMailFlag

java.lang.Object returnMailFlag

returnFlag

java.lang.Object returnFlag

preProcessDefCd

java.lang.Object preProcessDefCd

preVersionCd

java.lang.Object preVersionCd

preProcessCd

java.lang.Object preProcessCd

preActivityCd

java.lang.Object preActivityCd

endTaskFlag

java.lang.Object endTaskFlag

selectRouteNo

java.lang.Object selectRouteNo

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoAcknowledgeViewResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

otherAgentFlag

java.lang.String otherAgentFlag

myAgentFlag

java.lang.String myAgentFlag

transferUserCd

java.lang.String transferUserCd

transferCdType

java.lang.String transferCdType

approvalObject

java.lang.String approvalObject

runActivityCd

java.lang.String runActivityCd

hasNextUserFlag

java.lang.String hasNextUserFlag

nextFlowType

java.lang.String nextFlowType

demandUserCd

java.lang.String demandUserCd

demandUserName

java.lang.String demandUserName

approvalRightType

java.lang.String approvalRightType

nextAttainmentClass

java.lang.String nextAttainmentClass

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityKey activityKey
アクティビティＫｅｙ

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityData activityData
アクティビティＤａｔａ

runuserlist

java.util.ArrayList runuserlist
実行主体ユーザ情報

receivelist

java.util.ArrayList receivelist
レシーブ情報

autopasslist

java.util.ArrayList autopasslist
自動パス情報

runSelectFlg

java.lang.String runSelectFlg
実行時選択フラグ

userApplikeyList

java.util.Map userApplikeyList
ユーザアプリケーションキーテーブル情報リスト

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo
ログインユーザ情報

loginUserID

java.lang.String loginUserID
ログインユーザID

loginGroupID

java.lang.String loginGroupID
ログイングループID

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult は jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityKey activityKey

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityData activityData

cotentsMasterList

java.util.ArrayList cotentsMasterList

userApplikeyList

java.util.Map userApplikeyList

receiveTableList

java.util.ArrayList receiveTableList

myTransferTableList

java.util.ArrayList myTransferTableList

otherTransferedTableList

java.util.ArrayList otherTransferedTableList

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

referAuthFlg

java.lang.String referAuthFlg

searchCount

int searchCount

transferFlg

java.lang.String transferFlg

otherTransferFlg

java.lang.String otherTransferFlg

pullActivityFlg

java.lang.String pullActivityFlg

returnActivityFlg

java.lang.String returnActivityFlg

runSelectFlg

java.lang.String runSelectFlg

existRunUserFlg

java.lang.String existRunUserFlg

myTransferRunTableList

java.util.ArrayList myTransferRunTableList

otherTransferedRunTableList

java.util.ArrayList otherTransferedRunTableList

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoViewResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

otherAgentFlag

java.lang.String otherAgentFlag

myAgentFlag

java.lang.String myAgentFlag

transferUserCd

java.lang.String transferUserCd

transferCdType

java.lang.String transferCdType

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityKey は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

java.lang.Object processDefCd

versionCd

java.lang.Object versionCd

processCd

java.lang.Object processCd

activityCd

java.lang.Object activityCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityName

java.lang.Object activityName

activityTypeCd

java.lang.Object activityTypeCd

runReferTypeCd

java.lang.Object runReferTypeCd

resultNoticeFlag

java.lang.Object resultNoticeFlag

resultFromDef

java.lang.Object resultFromDef

resultTitleDef

java.lang.Object resultTitleDef

resultContentsDef

java.lang.Object resultContentsDef

autoPassTerm

java.lang.Object autoPassTerm

autoPassFlag

java.lang.Object autoPassFlag

compulsionEndFlag

java.lang.Object compulsionEndFlag

returnMailFlag

java.lang.Object returnMailFlag

returnFlag

java.lang.Object returnFlag

resultDefaultDef

java.lang.Object resultDefaultDef

shortestEndFlag

java.lang.Object shortestEndFlag

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterKey activityKey

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData activityData

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData activityData

referList

java.util.ArrayList referList

runUserList

java.util.ArrayList runUserList

runExecutiveList

java.util.ArrayList runExecutiveList

autoPassList

java.util.ArrayList autoPassList

autoPassExecutiveList

java.util.ArrayList autoPassExecutiveList

resultSendList

java.util.ArrayList resultSendList

contentsList

java.util.ArrayList contentsList

receiveInfoModel

jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel receiveInfoModel

sequenceInnerList

java.util.ArrayList sequenceInnerList

flowInnerList

java.util.ArrayList flowInnerList

switchList

java.util.ArrayList switchList

routeSelectList

java.util.ArrayList routeSelectList

processAdapterInfoModel

jp.co.intra_mart.foundation.bpw.model.object.ProcessAdapterInfoModel processAdapterInfoModel

executeAdapterInfoModel

jp.co.intra_mart.foundation.bpw.model.object.ExecuteAdapterInfoModel executeAdapterInfoModel

eventAdapterInfoModel

jp.co.intra_mart.foundation.bpw.model.object.EventAdapterInfoModel eventAdapterInfoModel

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoResult は jp.co.intra_mart.foundation.bpw.model.object.VersionInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterKey activityKey

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData activityData

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

myTransferTableList

java.util.ArrayList myTransferTableList

otherTransferedTableList

java.util.ArrayList otherTransferedTableList

cotentsMasterList

java.util.ArrayList cotentsMasterList

receiveMasterList

java.util.ArrayList receiveMasterList

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterKey は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

java.lang.Object processDefCd

versionCd

java.lang.Object versionCd

activityCd

java.lang.Object activityCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData activityData

userApplikeyList

java.util.Map userApplikeyList

クラス jp.co.intra_mart.foundation.bpw.model.object.AgentSettingListInfoResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

transferCount

int transferCount

クラス jp.co.intra_mart.foundation.bpw.model.object.AuthorityInfoResult は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

groupingCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult groupingCd

authorityFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult authorityFlag

groupingName

java.lang.String groupingName

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassExecutiveInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

postCd

java.lang.String postCd

postCdKind

java.lang.String postCdKind

pairNo

java.lang.String pairNo

companyCd

java.lang.String companyCd

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassExecutiveListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

processCd

java.lang.String processCd

userCd

java.lang.String userCd

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

java.lang.String userCd

userName

java.lang.String userName

processCd

java.lang.String processCd

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

authorityFlg

java.lang.String authorityFlg

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.BPWFieldFunctionResult は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

count

java.lang.String count

maximum

java.lang.String maximum

minimum

java.lang.String minimum

sumTotal

java.lang.String sumTotal

average

java.lang.String average

クラス jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

value

java.lang.String value

function

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldFunctionResult function

クラス jp.co.intra_mart.foundation.bpw.model.object.BPWSendMailInfo は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

sendTo

java.util.ArrayList sendTo

from

java.lang.String from

subject

java.lang.String subject

body

java.lang.String body

sendCc

java.util.ArrayList sendCc

sendBcc

java.util.ArrayList sendBcc

replyTo

java.lang.String replyTo

クラス jp.co.intra_mart.foundation.bpw.model.object.CategoryInfoResult は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult categoryCd

categoryName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult categoryName

categoryNote

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult categoryNote

invalidFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult invalidFlag

createDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createDate

createUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserCd

createUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserName

recordDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordDate

recordUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserCd

recordUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserName

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

authlist

java.util.ArrayList authlist

クラス jp.co.intra_mart.foundation.bpw.model.object.CategoryListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ConsentedInfoViewResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

approvalType

java.lang.String approvalType

approvalRightType

java.lang.String approvalRightType

recognitionStatus

java.lang.String recognitionStatus

approvalUserCd

java.lang.String approvalUserCd

agentUserCd

java.lang.String agentUserCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ContentsInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

contentsType

java.lang.String contentsType

pageKind

java.lang.String pageKind

contentsPath

java.lang.String contentsPath

applicationId

java.lang.String applicationId

serviceId

java.lang.String serviceId

tabCd

java.lang.String tabCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ContentsInfoSelectKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

contentsType

java.lang.String contentsType

pageKind

java.lang.String pageKind

contentsPath

java.lang.String contentsPath

applicationId

java.lang.String applicationId

serviceId

java.lang.String serviceId

tabCd

java.lang.String tabCd

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

authorityFlg

java.lang.String authorityFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.ContentsListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ContentsSelectListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.DeleteAllProcessListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.DraftRootDetailInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

rootCd

java.lang.String rootCd

selectedCodeKind

java.lang.String selectedCodeKind

selectedUserCd

java.lang.String selectedUserCd

pairNo

java.lang.String pairNo

userInfo

jp.co.intra_mart.framework.base.util.UserInfo userInfo

companyCd

java.lang.String companyCd

クラス jp.co.intra_mart.foundation.bpw.model.object.DraftRootDetailListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.DraftRootHistoryInfoModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

java.lang.String processDefCd

versionCd

java.lang.String versionCd

rootCd

java.lang.String rootCd

userCd

java.lang.String userCd

rootName

java.lang.String rootName

recordDate

java.lang.String recordDate

userInfo

jp.co.intra_mart.framework.base.util.UserInfo userInfo

クラス jp.co.intra_mart.foundation.bpw.model.object.DraftRootHistoryListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.EventAdapterInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

serviceId

java.lang.String serviceId

クラス jp.co.intra_mart.foundation.bpw.model.object.EventAdapterListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ExecuteAdapterInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

runClass

java.lang.String runClass

クラス jp.co.intra_mart.foundation.bpw.model.object.ExecuteAdapterListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.FlowInnerInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

runId

java.lang.String runId

runActivityCd

java.lang.String runActivityCd

conditionClass

java.lang.String conditionClass

クラス jp.co.intra_mart.foundation.bpw.model.object.FlowInnerListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.HistoryTableInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

callProcessCd

java.lang.String callProcessCd

ackHistoryCd

java.lang.String ackHistoryCd

processDefCd

java.lang.String processDefCd

versionCd

java.lang.String versionCd

processCd

java.lang.String processCd

activityCd

java.lang.String activityCd

approvalType

java.lang.String approvalType

approvalUserCd

java.lang.String approvalUserCd

approvalUserName

java.lang.String approvalUserName

companyCd

java.lang.String companyCd

approvalGroupCd

java.lang.String approvalGroupCd

approvalGroupName

java.lang.String approvalGroupName

affiliationFlag

java.lang.String affiliationFlag

approvalDate

java.lang.String approvalDate

approvalComment

java.lang.String approvalComment

agentTranFlag

java.lang.String agentTranFlag

agentTranUserCd

java.lang.String agentTranUserCd

agentTranUserName

java.lang.String agentTranUserName

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.HistoryTableInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

callProcessCd

java.lang.String callProcessCd

ackHistoryCd

java.lang.String ackHistoryCd

processDefCd

java.lang.String processDefCd

versionCd

java.lang.String versionCd

processCd

java.lang.String processCd

activityCd

java.lang.String activityCd

approvalType

java.lang.String approvalType

approvalUserCd

java.lang.String approvalUserCd

approvalUserName

java.lang.String approvalUserName

companyCd

java.lang.String companyCd

approvalGroupCd

java.lang.String approvalGroupCd

approvalGroupName

java.lang.String approvalGroupName

affiliationFlag

java.lang.String affiliationFlag

approvalDate

java.lang.String approvalDate

approvalComment

java.lang.String approvalComment

agentTranFlag

java.lang.String agentTranFlag

agentTranUserCd

java.lang.String agentTranUserCd

agentTranUserName

java.lang.String agentTranUserName

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.HistoryTableListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.LinkInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

linkActivityCd

java.lang.String linkActivityCd

クラス jp.co.intra_mart.foundation.bpw.model.object.LinkListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ListModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

count

int count

list

java.util.ArrayList list

クラス jp.co.intra_mart.foundation.bpw.model.object.LogTableListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.NegoTemplateModelObject は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

fieldMap

java.util.Map fieldMap

tableName

java.lang.String tableName

modelName

java.lang.String modelName

PKMap

java.util.Map PKMap

クラス jp.co.intra_mart.foundation.bpw.model.object.NewlyArrivalTaskListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

直列化されたフィールド

versionCd

java.lang.String versionCd

processDefCd

java.lang.String processDefCd

processDefName

java.lang.String processDefName

categoryCode

java.lang.String categoryCode

categoryName

java.lang.String categoryName

regist_type

java.lang.String regist_type

groupName

java.lang.String groupName

draftUserName

java.lang.String draftUserName

draftDate

java.lang.String draftDate

demandReceiptCd

java.lang.String demandReceiptCd

demandReceiptName

java.lang.String demandReceiptName

process_Term_Date

java.lang.String process_Term_Date

attainmentClass

java.lang.String attainmentClass

receptionDate

java.lang.String receptionDate

processClassCode

java.lang.String processClassCode

processCode

java.lang.String processCode

processName

java.lang.String processName

processStatus

java.lang.String processStatus

activityCd

java.lang.String activityCd

approvalTypeCd

java.lang.String approvalTypeCd

approvalRightType

java.lang.String approvalRightType

draftActivityCd

java.lang.String draftActivityCd

callProcessCd

java.lang.String callProcessCd

activityStatus

java.lang.String activityStatus

approval_User_Cd

java.lang.String approval_User_Cd

myTransferFlag

java.lang.String myTransferFlag

クラス jp.co.intra_mart.foundation.bpw.model.object.NotCompletedAgentListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

直列化されたフィールド

versionCd

java.lang.String versionCd

processDefCd

java.lang.String processDefCd

processDefName

java.lang.String processDefName

categoryCode

java.lang.String categoryCode

categoryName

java.lang.String categoryName

regist_type

java.lang.String regist_type

groupName

java.lang.String groupName

draftUserName

java.lang.String draftUserName

draftDate

java.lang.String draftDate

demandReceiptCd

java.lang.String demandReceiptCd

demandReceiptName

java.lang.String demandReceiptName

process_Term_Date

java.lang.String process_Term_Date

attainmentClass

java.lang.String attainmentClass

otherTransferFlag

java.lang.String otherTransferFlag

myTransferFlag

java.lang.String myTransferFlag

referAuthFlg

java.lang.String referAuthFlg

processClassCode

java.lang.String processClassCode

processCode

java.lang.String processCode

processName

java.lang.String processName

processStatus

java.lang.String processStatus

activityCd

java.lang.String activityCd

approvalTypeCd

java.lang.String approvalTypeCd

approvalRightType

java.lang.String approvalRightType

draftActivityCd

java.lang.String draftActivityCd

callProcessCd

java.lang.String callProcessCd

activityStatus

java.lang.String activityStatus

pageRec_Cnt

java.lang.String pageRec_Cnt

pageStart_Cnt

java.lang.String pageStart_Cnt

pageEnd_Cnt

java.lang.String pageEnd_Cnt

pageNow_Cnt

java.lang.String pageNow_Cnt

pageTotal_Cnt

java.lang.String pageTotal_Cnt

クラス jp.co.intra_mart.foundation.bpw.model.object.NotCompletedListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

直列化されたフィールド

versionCd

java.lang.String versionCd

processDefCd

java.lang.String processDefCd

processDefName

java.lang.String processDefName

categoryCode

java.lang.String categoryCode

categoryName

java.lang.String categoryName

regist_type

java.lang.String regist_type

groupName

java.lang.String groupName

draftUserName

java.lang.String draftUserName

draftDate

java.lang.String draftDate

demandReceiptCd

java.lang.String demandReceiptCd

demandReceiptName

java.lang.String demandReceiptName

process_Term_Date

java.lang.String process_Term_Date

attainmentClass

java.lang.String attainmentClass

otherTransferFlag

java.lang.String otherTransferFlag

myTransferFlag

java.lang.String myTransferFlag

referAuthFlg

java.lang.String referAuthFlg

processClassCode

java.lang.String processClassCode

processCode

java.lang.String processCode

processName

java.lang.String processName

processStatus

java.lang.String processStatus

activityCd

java.lang.String activityCd

approvalTypeCd

java.lang.String approvalTypeCd

approvalRightType

java.lang.String approvalRightType

draftActivityCd

java.lang.String draftActivityCd

callProcessCd

java.lang.String callProcessCd

activityStatus

java.lang.String activityStatus

approval_User_Cd

java.lang.String approval_User_Cd

pageRec_Cnt

java.lang.String pageRec_Cnt

pageStart_Cnt

java.lang.String pageStart_Cnt

pageEnd_Cnt

java.lang.String pageEnd_Cnt

pageNow_Cnt

java.lang.String pageNow_Cnt

pageTotal_Cnt

java.lang.String pageTotal_Cnt

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessAdapterInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

callProcessDefCd

java.lang.String callProcessDefCd

endRejectionFlg

java.lang.String endRejectionFlg

endCompulsionFlg

java.lang.String endCompulsionFlg

draftTypeKind

java.lang.String draftTypeKind

processClassCode

java.lang.String processClassCode

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessAdapterListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessContentsInfoModel は jp.co.intra_mart.foundation.bpw.model.object.VersionInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

contentsType

java.lang.String contentsType

pageKind

java.lang.String pageKind

contentsPath

java.lang.String contentsPath

applicationId

java.lang.String applicationId

serviceId

java.lang.String serviceId

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessContentsInfoSelectKey は jp.co.intra_mart.foundation.bpw.model.object.VersionInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

contentsType

java.lang.String contentsType

pageKind

java.lang.String pageKind

contentsPath

java.lang.String contentsPath

applicationId

java.lang.String applicationId

serviceId

java.lang.String serviceId

loginUserId

java.lang.String loginUserId

loginGroupId

java.lang.String loginGroupId

authorityFlg

java.lang.String authorityFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessContentsListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessContentsSelectListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessData は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

processName

java.lang.Object processName

draftDate

java.lang.Object draftDate

draftUserCd

java.lang.Object draftUserCd

draftUserName

java.lang.Object draftUserName

draftComment

java.lang.Object draftComment

companyCd

java.lang.Object companyCd

codeValue

java.lang.Object codeValue

groupName

java.lang.Object groupName

targetMasterDate

java.lang.Object targetMasterDate

transactorCd

java.lang.Object transactorCd

transactorName

java.lang.Object transactorName

localeId

java.lang.Object localeId

processStatus

java.lang.Object processStatus

lastManualActivityCd

java.lang.Object lastManualActivityCd

lastManualActivityResult

java.lang.Object lastManualActivityResult

callProcessDefCd

java.lang.Object callProcessDefCd

callVersionCd

java.lang.Object callVersionCd

callProcessCd

java.lang.Object callProcessCd

processCallActivityCd

java.lang.Object processCallActivityCd

processingStatus

java.lang.Object processingStatus

processNestCnt

java.lang.Object processNestCnt

parallelNestCnt

java.lang.Object parallelNestCnt

presentDisplayInfo

java.lang.Object presentDisplayInfo

extensionA

java.lang.Object extensionA

extensionB

java.lang.Object extensionB

extensionC

java.lang.Object extensionC

extensionD

java.lang.Object extensionD

extensionE

java.lang.Object extensionE

extensionF

java.lang.Object extensionF

extensionG

java.lang.Object extensionG

extensionH

java.lang.Object extensionH

createDate

java.lang.Object createDate

createUserCd

java.lang.Object createUserCd

createUserName

java.lang.Object createUserName

recordDate

java.lang.Object recordDate

recordUserCd

java.lang.Object recordUserCd

recordUserName

java.lang.Object recordUserName

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessDefInfoResult は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processDefCd

lastVersionCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult lastVersionCd

invalidFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult invalidFlag

createDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createDate

createUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserCd

createUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserName

recordDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordDate

recordUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserCd

recordUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserName

processDefName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processDefName

processDefNote

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processDefNote

categoryInfo

jp.co.intra_mart.foundation.bpw.model.object.CategoryInfoResult categoryInfo

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

versionName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult versionName

totalCount

int totalCount

activeCount

int activeCount

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessDefListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoResult は jp.co.intra_mart.foundation.bpw.model.object.VersionInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

processKey

jp.co.intra_mart.foundation.bpw.model.object.ProcessKey processKey

processData

jp.co.intra_mart.foundation.bpw.model.object.ProcessData processData

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

processCotentsMasterList

java.util.ArrayList processCotentsMasterList

userApplikeyList

java.util.Map userApplikeyList

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessKey は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

java.lang.Object processDefCd

versionCd

java.lang.Object versionCd

processCd

java.lang.Object processCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

mailSendFlag

java.lang.String mailSendFlag

mailPostPonement

java.lang.String mailPostPonement

mailToClassification

java.lang.String mailToClassification

mailTitleDef

java.lang.String mailTitleDef

mailContentsDef

java.lang.String mailContentsDef

approvalObject

java.lang.String approvalObject

runSelectActivityCd

java.lang.String runSelectActivityCd

nextRouteType

java.lang.String nextRouteType

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

processCd

java.lang.String processCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

processCd

java.lang.String processCd

rcvComment

java.lang.String rcvComment

mailFlg

java.lang.String mailFlg

userCd

java.lang.String userCd

userName

java.lang.String userName

approvalType

java.lang.String approvalType

transferFlg

java.lang.String transferFlg

delegateFlg

java.lang.String delegateFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ReferInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

codeKind

java.lang.String codeKind

userCd

java.lang.String userCd

pairNo

java.lang.String pairNo

companyCd

java.lang.String companyCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ResultSendInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

resultToActivityCd

java.lang.String resultToActivityCd

resultToObjectFlag

java.lang.String resultToObjectFlag

クラス jp.co.intra_mart.foundation.bpw.model.object.ResultSendListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.RouteSelectInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

selectRouteNo

java.lang.String selectRouteNo

selectRouteName

java.lang.String selectRouteName

selectRouteCd

java.lang.String selectRouteCd

selectRouteType

java.lang.String selectRouteType

adapterCd

java.lang.String adapterCd

クラス jp.co.intra_mart.foundation.bpw.model.object.RouteSelectListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveGroupingInfoModel は RunExecutiveInfoModel を拡張し、Serializable を実装しています

直列化されたフィールド

groupingClsCd

java.lang.String groupingClsCd

クラス jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

postCd

java.lang.String postCd
役職コード値

postCdKind

java.lang.String postCdKind
役職コード種別

pairNo

java.lang.String pairNo
ペアNO

companyCd

java.lang.String companyCd
会社CD

クラス jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityKey activityKey

userCd

java.lang.String userCd

registType

java.lang.String registType

companyCd

java.lang.String companyCd

codeValue

java.lang.String codeValue

approvalTypeCd

java.lang.String approvalTypeCd

groupName

java.lang.String groupName

affiliationFlag

java.lang.String affiliationFlag

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.RunGroupListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

processCd

java.lang.String processCd

userCd

java.lang.String userCd

userName

java.lang.String userName

demandReceiptCd

java.lang.String demandReceiptCd

demandReceiptName

java.lang.String demandReceiptName

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

approvalTypeCd

java.lang.String approvalTypeCd

approvalRightType

java.lang.String approvalRightType

representationType

java.lang.String representationType

transferUserCd

java.lang.String transferUserCd

transferUserName

java.lang.String transferUserName

recognitionStatus

java.lang.String recognitionStatus

クラス jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

java.lang.String userCd
ユーザコード

userName

java.lang.String userName
ユーザ名

demandReceiptCd

java.lang.String demandReceiptCd
依頼要求／受付CD

demandReceiptName

java.lang.String demandReceiptName
依頼要求／受付名

processCd

java.lang.String processCd
プロセスコード

groupList

jp.co.intra_mart.foundation.bpw.model.object.RunGroupListModel groupList
グループ情報

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo
ログインユーザ情報

loginUserID

java.lang.String loginUserID
ログインユーザID

loginGroupID

java.lang.String loginGroupID
ログイングループID

authorityFlg

java.lang.String authorityFlg
処理権限フラグ

approvalTypeCd

java.lang.String approvalTypeCd
承認種別コード

approvalRightType

java.lang.String approvalRightType
承認可否種別

representationType

java.lang.String representationType
代理コード種別

transferUserCd

java.lang.String transferUserCd
振替先ユーザCD

transferUserName

java.lang.String transferUserName
振替先ユーザ名

recognitionStatus

java.lang.String recognitionStatus
承認ステータス

クラス jp.co.intra_mart.foundation.bpw.model.object.RunUserListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.SequenceInnerInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

runNo

java.lang.String runNo

runActivityCd

java.lang.String runActivityCd

クラス jp.co.intra_mart.foundation.bpw.model.object.SequenceInnerListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.SwitchInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

conditionNo

java.lang.String conditionNo

runActivityCd

java.lang.String runActivityCd

conditionClass

java.lang.String conditionClass

クラス jp.co.intra_mart.foundation.bpw.model.object.SwitchListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.TransferInfoResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

client_user_cd

java.lang.Object client_user_cd

client_user_name

java.lang.Object client_user_name

クラス jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

java.lang.String userCd

userName

java.lang.String userName

companyCd

java.lang.String companyCd

transferCd

java.lang.String transferCd

transferCdType

java.lang.String transferCdType

transferStart

java.lang.String transferStart

transferEnd

java.lang.String transferEnd

sendMailFlg

java.lang.String sendMailFlg

remark

java.lang.String remark

subRecognitionFlg

java.lang.String subRecognitionFlg

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

authorityFlg

java.lang.String authorityFlg

targetDate

java.lang.String targetDate

クラス jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

java.lang.String userCd

userName

java.lang.String userName

companyCd

java.lang.String companyCd

transferCd

java.lang.String transferCd

transferCdType

java.lang.String transferCdType

transferStart

java.lang.String transferStart

transferEnd

java.lang.String transferEnd

sendMailFlg

java.lang.String sendMailFlg

remark

java.lang.String remark

subRecognitionFlg

java.lang.String subRecognitionFlg

transferName

java.lang.String transferName

transferUserCd

java.lang.String transferUserCd

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.TransferTableListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

java.lang.String processDefCd

versionCd

java.lang.String versionCd

processCd

java.lang.String processCd

parameterNumber

java.lang.String parameterNumber

parameterCd

java.lang.String parameterCd

クラス jp.co.intra_mart.foundation.bpw.model.object.UserInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

java.lang.String userCd

userName

java.lang.String userName

クラス jp.co.intra_mart.foundation.bpw.model.object.VersionInfoKey は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

java.lang.String processDefCd

versionCd

java.lang.String versionCd

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

java.lang.String loginUserID

loginGroupID

java.lang.String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.VersionInfoResult は jp.co.intra_mart.foundation.bpw.model.object.ProcessDefInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

versionCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult versionCd

versionName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult versionName

note

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult note

processDefNote

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processDefNote

startActivityCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult startActivityCd

draftActivityCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult draftActivityCd

processClassCode

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processClassCode

subProcessFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult subProcessFlag

effectiveDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult effectiveDate

endDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult endDate

extensionNameA

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameA

extensionNameB

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameB

extensionNameC

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameC

extensionNameD

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameD

extensionNameE

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameE

extensionNameF

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameF

extensionNameG

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameG

extensionNameH

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameH

createDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createDate

createUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserCd

createUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserName

recordDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordDate

recordUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserCd

recordUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserName

categoryInfo

jp.co.intra_mart.foundation.bpw.model.object.CategoryInfoResult categoryInfo

totalCount

int totalCount

activeCount

int activeCount

クラス jp.co.intra_mart.foundation.bpw.model.object.VersionListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.WfeUserInfoModel は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

clientType

java.lang.String clientType

colorPatternID

java.lang.String colorPatternID

encoding

java.lang.String encoding

locale

java.util.Locale locale

loginGroupID

java.lang.String loginGroupID

loginTime

java.util.Date loginTime

loginType

java.lang.String loginType

signature

java.lang.String signature

url

java.lang.String url

urlSignature

java.lang.String urlSignature

userID

java.lang.String userID

パッケージ jp.co.intra_mart.system.bpw

クラス jp.co.intra_mart.system.bpw.SyncronizedInfo は java.lang.Object を拡張し、Serializable を実装しています

直列化されたフィールド

table

java.util.Hashtable table

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ワークフローモジュール
前 次 フレームあり フレームなし
Copyright © 2002-2005 NTT DATA INTRAMART CO.,LTD. All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Application Common Master Table]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart DTD 定義ファイルについて

このページでは、各種DTD定義ファイルの説明を行います。
各種DTD定義ファイルはシステム全体の設定を行ったり、データのインポートエクスポートを行ったりする場合のXMLファイルのフォーマットの定義が記述されています。

システム定義ファイル
サーバマネージャインストールディレクトリ/specification/dtdに保存されています。

ＤＴＤ定義ファイル名 | 説明
system_5_0.dtd | システムの定義を行います。 サーバマネージャインストールディレクトリ/conf/system.xmlに対する定義ファイルです。 システムの対応ロケール、エンコーディング、クライアントタイプ、画面カラーパターンの定義を行います。
data-source_5_0.dtd | データソースの定義を行います。 サーバマネージャインストールディレクトリ/conf/data-source.xmlに対する定義ファイルです。 システムに紐付くデータソース（複数）およびログイングループに紐付くデータソース（ログイングループ毎に1個）の定義を行います。
system-install_5_0.dtd | 初期データインポート情報、ＡＰＩの登録およびＡＰＩに対するリスナーの定義を行います。 サーバマネージャインストールディレクトリ/conf/system-install.xmlに対する定義ファイルです。 初期データインポート、サンプルデータインポート情報の定義を行います。 ページベース開発モデルで利用するJavaScriptAPIの登録を行います。 アクセスセキュリティAPI、アプリケーション共通マスタAPI、ワークフローAPIのリスナーの定義を行います。

アクセスセキュリティ定義ファイル
サーバマネージャインストールディレクトリ/specification/dtdに保存されています。

ＤＴＤ定義ファイル名 | 説明
access-security_5_0.dtd | アクセスセキュリティ全般の定義を行います。 サーバマネージャインストールディレクトリ/conf/access-security.xmlに対する定義ファイルです。 セッション情報の保管方法の定義を行います。 URLのアクセス制限設定を定義します。 ログイン処理に対する定義を行います。 アクセスセキュリティAPIの動作の定義を行います。 アクセスセキュリティAPIに対するリスナーの定義を行います。 アクセスセキュリティのインポート・エクスポートの定義を行います。
system-menu_5_0.dtd | システム管理者が利用するメニューの定義を行います。 サーバマネージャインストールディレクトリ/conf/system-menu.xmlに対する定義ファイルです。
admin-menu_5_0.dtd | グループ管理者が利用する管理メニューの定義を行います。 管理メニューのインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
account_5_0.dtd | アカウント情報の定義を行います。 アカウント情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
role_5_0.dtd | ロール情報の定義を行います。 ロール情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
user-menu_5_0.dtd | ロール情報の定義を行います。 ロール情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
calendar_5_0.dtd | カレンダー情報の定義を行います。 カレンダー情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
batch_5_0.dtd | バッチ情報の定義を行います。 バッチ情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。

アプリケーション共通マスタ定義ファイル
サーバマネージャインストールディレクトリ/specification/dtdに保存されています。

ＤＴＤ定義ファイル名 | 説明
datastore_5_0.dtd | データストアでのエンティティ、モデル、マッパ、データベース およびエンティティ間のリレーションシップの定義を行います。 標準では、ApplicationRuntimeインストールディレクトリ/conf/datastore/jp/co/intramart/foundation/datastore/common.xmlが定義されています。 common.xmlはアプリケーション共通マスタおよびアクセスセキュリティで使用するエンティティ、モデル、マッパ、データベース およびエンティティ間のリレーションシップの定義を行なっています。通常このファイルを編集することはありません。
profile-data_5_0.dtd | ユーザ情報の定義を行います。 ユーザ情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポートを行います。 ユーザ情報のインポートではユーザ情報に所属情報がある場合は、対象となる会社・組織、役職、およびパブリックグループを事前インポートしておく必要があります。
company-data_5_0.dtd | 会社・組織情報の定義を行います。 会社・組織情報のインポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
company-post-data_5_0.dtd | 役職情報の定義を行います。 役職情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。 役職情報のインポートでは対象となる会社を事前インポートしておく必要があります。
public-group-data_5_0.dtd | ロール情報の定義を行います。 ロール情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[FAQ]]

i ntra-mart The Power for Enterprise Web Solution
トラブル・シューティング
【 データベース篇 】

データベースにアクセスできない

ＪＤＢＣドライバはインストールされていますか？

ご使用になられるデータベース製品のベンダーより提供されているＪＤＢＣドライバをインストールして下さい。

ＪＤＢＣドライバにパスは通っていますか？

ＪＤＢＣドライバへのクラスパスを正しく設定して動作させて下さい。

クラスパスは、ＯＳの環境変数、またはＪＡＶＡ実行時の -cp 引数で指定するなど、用途および環境に応じて適切に設定して下さい。

接続設定はしていますか？

intra-mart に対してログインした後、メニューの【システム設定】-【データベース】でデータベースに対して接続するためのアカウント情報を設定して下さい。

データベース接続のためのアカウント設定をおこなった場合には、intra-mart システム全体を再起動して下さい。

オラクルにアクセスできない

アカウントの設定は正しくしていますか？

メニュー【システム設定】-【データベース】にて、データベースへ接続するための定義を行う必要があります(設定画面上では必須項目になっていません)。

データベースへの接続設定は、設定ファイル conf/http.xml で行います(BaseModule の場合。intra-mart の場合は、ご利用の Web アプリケーションサーバの設定方法に従ってください)。データソースの設定方法に従い、正しく接続設定を定義してください。

ＴＮＳリスナーは動作していますか？

ＴＮＳリスナーが動作していることを確認した上で、intra-mart システムを動作させて下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[FAQ]]

i ntra-mart The Power for Enterprise Web Solution
トラブル・シューティング
【 プログラム(Function Container)篇 】

オブジェクトのプロパティの更新や削除ができない

ユーザー定義でないオブジェクトを操作していませんか？

intra-mart ランタイム・エンジンの持つＡＰＩ自身、intra-mart ランタイム・エンジンが渡す引数オブジェクトや各ＡＰＩの返却オブジェクトについては、そのオブジェクト構造の変更を禁止されているものがあります。

任意のオブジェクト構造を作成したい場合には、明示的に new Object() で作成したオブジェクトを利用するようにしなければいけません。

構文エラーで実行されない

プログラムに文法的な誤りはありませんか？

構文エラーがある場合、スクリプトの解析段階で実行を終了してしまいます。
intra-mart e-Builder のデバッグ機能を利用して、プログラム全体の文法的な見直しをしてから実行して下さい。

全角文字でインデントをしていませんか？

文字列定数宣言以外の部分でＡＳＣＩＩ文字以外を記述すると、構文エラーになります。

特に全角の空白を記述してしまっている場合、半角の空白と区別がつきにくいため、全角の空白が記述されている問題個所の発見が難しくなります。
intra-mart e-Builder のデバッグ機能を利用して、プログラム全体の文法的な見直しをして下さい。

ファイル終端コードを付加して保存していませんか？

Windows 系 OS では、ファイルの終端を示すコードとしてファイル終端コードというものがあります。
このコードは、空白や改行とは違った値を持っているため、スクリプトの実行時に解析不能の文字として認識されてしまいます。

スクリプトファイルを保存する際には、ファイル終端コードを付加せずに保存するようにして下さい。

表示が文字化けしてしまう

外字を記述していませんか？

ファンクション・コンテナの実行時には、ソースコードは Unicode (UTF8) に変換されます。

Unicode に変換できない文字(主に外字)を使用しないで下さい。

言語コードは正しく設定していますか？

保存されているソースコードファイル中の言語コードと、サーバ言語に設定している文字コードが異なる場合、ただしく動作できない事があります。

保存ファイル中の言語コードとサーバ言語設定（[install_directory]/conf/imart.xml 内 <server-charset>）を合わせて下さい。

保存しておいた値やメソッドが消えている

値はオブジェクト自身が直接持っていますか？

セッションデータ保存ＡＰＩ Client.set() により、オブジェクトデータを保存する場合、プロトタイプオブジェクトによって保持している内容は保持されなくなる事があります。

保存したいデータは、オブジェクトが直接持っているプロパティ値として保存するようにして下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[FAQ]]

i ntra-mart The Power for Enterprise Web Solution
トラブル・シューティング
【 プログラム(Presentation Page)篇 】

<IMART> が動作しない

タグは正しく記述されていますか？

<IMART> タグ・インタプリタは、<IMART をキーとして解析・実行をおこなっています。
キーとなる字句 <IMART の前後や文字間に余分な文字を含めたりしないようにしてください。

type 属性はただしく指定していますか？

<IMART> タグ内で指定されている情報は、大文字・小文字を厳密に判定します。
特に、type 属性に関しては、属性名および属性値ともに厳密に判定されますので、正しく記述するようにして下さい。

ＡＰＩに関しては、画面共通モジュール をご参照下さい。

<IMART> タグは正しく閉じられていますか？

<IMART> タグは、必ず </IMART> タグと対で使用する必要があります。
１つのプレゼンテーション・ページ・ファイル中における <IMART> と </IMART> タグの記述数は同数になるようにプログラミングして下さい。

表示が文字化けしてしまう

ブラウザの表示言語は正しく設定されていますか？

ブラウザの言語設定を【自動認識】にしておくと、ページ全体が文字化けして表示されてしまう事があります。
ブラウザの言語設定を明示的におこなうようにして下さい。

ブラウザでの文字化けを防ぐ方法として、 <META> を利用してソースの言語を明示的に指定する事ができます。

外字を記述していませんか？

プレゼンテーション・ページの実行時には、ソースコードは Unicode (UTF8) に変換されます。

Unicode に変換できない文字(主に外字)を使用しないで下さい。

言語コードは正しく設定していますか？

保存されているソースコードファイル中の言語コードと、サーバ言語コードに設定している文字コードが異なる場合、ただしく動作できない事があります。

保存ファイル中の言語コードとサーバ言語設定（conf/imart.xml 内 <server-charset>）を合わせて下さい。

ラウンドロビンしている各サーバ間で同一の言語設定をしていますか？

Application Runtime をラウンドロビンさせて運用している場合、各サーバ間でクライアント送信言語設定を統一させていないと、ブラウザが正しくページを表示できないことがあります。

すべての Application Runtime のクライアント言語設定（conf/imart.xml 内 <client-charset>）を統一させてください。
設定ファイル conf/imart.xml ファイルの内容を更新した場合には、サーバを再起動する必要があります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Application Runtime]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Application Runtime 篇 】

前提

Application Runtime は、Web-Server with Web-Server Connecor と連携して Web Application を提供するランタイム・サービスです(スタンドアロン型で動作している場合、Application Runtime 自身が HTTP サーバとしても機能します)。

Application Runtime 機能を利用するには、Schedule Service 以外のすべてのサービスが正しく動作していることが必要になります(Schedule Service はバッチ管理機能を利用する場合に必要になります)。

動作に必要なプログラム

Application Runtime が動作する際には、以下のプログラムファイルを必要とします。

  • init.js (初期起動用)
  • 各種プレゼンテーション・ページ(*.html)
  • 各種ファンクション・コンテナ(*.js)
  • 各種 JSP プログラム(*.jsp, *.xtp)
  • 各種 Servlet プログラム(*.class)

ページベース開発モデルのプログラム・ファイルは、Resource Service に保存してください。Application Runtime はResource Service より配信されるプログラムを実行します。

J2EE開発モデルのプログラムファイルは、Application Runtime インストールディレクトリ直下の doc/ ディレクトリ内に保存してください（サーブレットの場合は、任意のディレクトリ内に保存してクラスパスを設定しても良いです）。Application Runtimeは、ＵＲＬによりマッピングされたプログラム(*.jsp, *.xtp, *.class)をロードして実行します。

初期起動

サーバ起動後 HTTP リクエストの処理をする前に、各モジュールの初期化を行います。これを 初期起動と呼びます。

初期起動時は、Application Runtime により init.js が実行されます。

初期起動時に実行されるプログラム内では、ページ遷移などの一部のＡＰＩは利用できません。

初期起動時に利用できない Function Container API
  • request.*
  • forward()
  • redirect()
  • transmission()
  • Debug.browse()
  • Module.mobile.alert()
  • Client.*
  • Web.*
  • Module.alert.*
  • Module.client.*
  • Module.download.*
  • Module.external.*

HTTP リクエスト時の実行シーケンス

Application Runtime が HTTP リクエストを受け付けると以下のシーケンスにしたがって該当のプログラム順次実行していきます(ページベース開発モデルにより作成されたプログラムをリクエスト場合)。

ブラウザからのリクエスト時
  1. session.js 内 init() 関数実行
  2. page 指定ファンクションコンテナ内 init() 関数実行
  3. page 指定プレゼンテーションページの実行
  4. page 指定ファンクションコンテナ内 close() 関数実行
  5. session.js 内 close() 関数実行
  6. ページの返却
intra-mart のリンク or フォームからのリクエスト時
  1. session.js 内 init() 関数実行
  2. action 指定関数の実行
  3. page 指定ファンクションコンテナ内 init() 関数実行
  4. page 指定プレゼンテーションページの実行
  5. page 指定ファンクションコンテナ内 close() 関数実行
  6. session.js 内 close() 関数実行
  7. ページの返却

ページ・プログラム(ページベース開発モデル)実行に関する動作仕様に関しては、Presentation Pageについてを参照して下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Batch]]]

i ntra-mart The Power for Enterprise Web Solution
Batch Programについて

前提

ここでは、Application Runtime により実行されるバッチプログラム(ファンクションコンテナ)の動作仕様を説明します。

intra-mart のバッチ機能を利用するには、すべてのサービスをインストールして正しく動作していることが必要になります。

動作に必要なプログラム(バッチ)

バッチプログラム起動設定をした上で Schedule Service を運用した場合、設定した時刻に指定プログラムが実行されます。

指定のファンクションコンテナまたはクラスには、バッチ設定に関する情報オブジェクトが引数として実行時に引き渡されます。

引数オブジェクトが持つプロパティ
group | バッチ設定をしたログイン・グループＩＤ
name | バッチ名称
establish | バッチ実行時間設定
year | バッチ実行指定年
month | バッチ実行指定月
date | バッチ実行指定日
day | バッチ実行指定曜日
hour | バッチ実行指定時間
minute | バッチ実行指定分
second | バッチ実行指定秒
program | バッチとして実行するプログラム・パス

この情報オブジェクトは、バッチプログラムがファンクションコンテナの場合、init() 関数の引数として実行時にプログラムに渡されます。また、バッチプログラムがクラスの場合、execute() 関数の引数として渡されます。

バッチ実行指定の 年・月・日・曜日・時・分・秒 のうち“毎”指定(「毎日」など)をしている場合は、非数(NaN)または-1が格納されています。

Application Runtime によりバッチプログラムとして実行されたファンクションコンテナ内に定義されている init() 関数は、１つの引数を取り実行されます(バッチプログラムがクラスの場合は、jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent インターフェースの仕様に準じます)。

実行シーケンス

バッチ起動設定時刻になった場合、以下のように処理が流れます。

  1. 設定ファンクションコンテナまたはクラスのロード
  2. 設定ファンクションコンテナ内 init() 関数またはクラスの execute() メソッドの実行

バッチプログラム例

下記サンプルプログラムは、ファンクションコンテナ(JavaScript)で開発をした場合の例です。
バッチ起動設定をした時の Web サーバの HTTP リクエスト受付ポートとバッチの実行時間（プログラム実行時の現在時刻）を my_batch.txt というファイルに書き出すバッチプログラムです。

function init(arg){
var f = new VirtualFile("my_batch.txt");
var now = new Date();
f.write(now.toString());
f.append("name=");
f.append(arg.name);
}

JAVA でバッチプログラムを作成する方法に関しては、jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent クラスのＡＰＩ仕様をご覧ください。

注意事項

バッチ・プログラム内では、ページ遷移などの一部のＡＰＩは利用できません。

バッチ・プログラム内で利用できない Function Container API
  • Request
  • forward()
  • redirect()
  • transmission()
  • Debug.browse()
  • Module.mobile.alert()
  • Web.*
  • Module.alert.*
  • Module.client.*
  • Module.download.*
  • Module.external.*

また、バッチプログラムにおいては、View(画面)を前提とした機能であるJ2EE フレームワーク(jp.co.intra_mart.framework.*)を利用することはできません。

戻る
Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Permanent Data Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Permanent Data Service 篇 】

機能概要

Permanent Data Service は、intra-mart システムが動作するために必要な設定情報などを管理しています。
また、このサービスでは情報をファイル保存しますので、サービスが停止した場合も、次の起動時にそれまでに保存されたデータを復元することができます。したがって、簡易的なデータベースとして利用することも可能です。

Permanent Data Service に関連するＡＰＩは以下のとおりです。

  • Permanent(Page-Base Programing Model)
  • jp.co.intra_mart.foundation.service.client.information.PermanentDirectory(J2EE-Base Programing Model)
  • jp.co.intra_mart.foundation.service.client.information.PermanentFile(J2EE-Base Programing Model)

仕様

この機能は、簡易データベースとしての機能を提供します。

この機能を利用したものには、永続情報保存(Function Container API Permanent, JAVA API jp.co.intra_mart.foundation.service.client.information.PermanentDirectory) 機能があります。
また、アカウントやメニューなどの、intra-mart のシステム設定情報もこの機能を利用しています。

この機能を利用して保存した情報は、ファイルとして保管されますので、Permanent Data Service を再起動しても設定情報が失われることがありません。

情報ファイルは、Permanent Data Service の インストールディレクトリ直下の treasure/ ディレクトリ内に保存されます。
また、情報ファイルはバイナリファイルとして保存されますので、テキストエディタなどで編集をすることはできません(バイナリファイルのバージョン間での互換性は保証されません)。

注意事項

Permanent Data Service は、インストールディレクトリ直下の treasure/ ディレクトリにデータファイルを保存します。
treasure/ ディレクトリ内にファイルやディレクトリを保存しないで下さい。Information Server が作成するファイルやディレクトリ以外のファイルおよびディレクトリが存在すると、誤動作を起こす原因になる可能性があります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Resource Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Resource Service 篇 】

機能概要

Resource Service は、特にページベース開発モデルのプログラムファイルを管理および Application Runtime への配布を行います。intra-mart システムの中枢的役割を果たしています。

Resource Service が管理するファイルは以下の通りです。

  • プレゼンテーションページ(*.html)
  • ファンクションコンテナ(*.js)
  • 設定値定義ファイル(*.ini)

プログラム管理

Resource Service では、intra-mart システムの動作に必要な各プレゼンテーションページ(*.html)およびファンクションコンテナ(*.js)のプログラムファイルを集中管理しています。
Application Runtime が必要なプログラムを、Resource Service が自動的に配布します。

プログラムファイルは、Resource Service の ページベースプログラムディレクトリ( %インストールディレクトリ%/pages/ ) 以下に保管 されています。
新規に作成したりカスタマイズしたプログラムファイルは、Resource Service の ページベースプログラムディレクトリ 以下に保存するようにして下さい。
プログラムファイルが更新されると、Resource Service はファイルの更新日付の変化を感知して自動的にシステムに反映させます。

ディレクトリ構成

標準状態を前提として以下に説明します。

プログラムソースのルートディレクトリは、３種類あります。

  • pages/platform/src ・・・ システム用のソース管理ディレクトリ
  • pages/product/src ・・・ 追加パッケージ用のソース管理ディレクトリ
  • pages/src ・・・ 通常のソース管理ディレクトリ
BaseModule/Framework のソースは、pages/platform/src にインストールされます（サンプルプログラムは、pages/src にインストールされます）。 また、追加パッケージ（イントラネット・スタートパックなど）のソースは、pages/product/src にインストールされます。 これらのソースは、変更する事ができません。

ユーザアプリケーション独自のソースは、pages/src に作成してください。また、パッケージのソースに対してカスタマイズをする場合、必要なソースを pages/src にコピーをしてから編集してください。
pages/platform/src または pages/product/src は、システムの基本ソースになります。絶対に編集をしないでください（pages/src にインストールされるサンプルプログラムは編集してもかまいません）。
パッケージのソースをカスタマイズする場合は、pages/platform/src や pages/product/src から必要なソースのみを pages/src にコピーしてから編集してください。pages/src にコピーすることにより、パッケージのパッチを適用したときに、パッチで変更されたソースを上書きされません（パッチは、pages/platform/src または pages/product/src にソースを展開します）。

ページベース実行エンジンは、ソースパスを次の順で検索します。

  1. pages/src
  2. pages/product/src
  3. pages/platform/src
したがって、カスタマイズするソースを pages/src にコピーしてから編集する事によって、カスタマイズしたソースが優先的に検索・実行されます（コピー元のシステムのソースは無視されます）。

ページベース開発モデルの国際化対応機能を利用して地域化をする場合、下記ディレクトリに地域化させたディレクトリを配置してください。

  • pages/i18n/[ロケールを表すキーワード]

ページベース開発モデルの国際化対応機能を利用する場合は、imart.xmlの設定が必要です。 (サーバをインストールした初期状態では、日本語ロケールのみ設定されています。)

imart.xmlに以下のいずれかの設定項目を追加してください。
（詳細は「設定ガイド（Service編）」を参照してください）

  • intra-mart/platform/service/resource/jssp/source-path/international/local
  • intra-mart/platform/service/resource/jssp/source-path/international/directory

設定例１
英語ロケール「en」に対応したソースを格納するディレクトリを「pages/i18n/en」、 英語ロケール「en_US」に対応したソースを格納するディレクトリを「pages/i18n/en_US」とする場合
<intra-mart>
  <platform>
    <service>
      <resource>
        <jssp>
          <source-path>
            <international>
              <local>
                <en>
                  <directory>pages/i18n/en</directory>
                </en>
                <en_US>
                  <directory>pages/i18n/en_US</directory>
                </en_US>
              </local>

設定例２
「ロケールを表すキーワード」を検索する基準ディレクトリを「pages/i18n」とする場合
<intra-mart>
  <platform>
    <service>
      <resource>
        <jssp>
          <source-path>
            <international>
              <directory>pages/i18n</directory>

「ロケールを表すキーワード」とは、java.util.Locale の仕様に準じた文字列になります。日本語ロケールの場合、通常は ja または ja_JP になります。 システムの地域化されたプログラムソースは、下記にインストールされます。

  • pages/platform/i18n/[ロケールを表すキーワード]
  • pages/product/i18n/[ロケールを表すキーワード]
これらも、カスタマイズをするときは、pages/i18n/[ロケールを表すキーワード]にコピーすることで、パッチによる上書きの影響を受けることなくカスタマイズをすることができます。

国際化機能を利用している場合、以下の順にソースが検索されます。

  1. 地域化されたソース
  2. 地域化されていない標準のソース
つまり、ユーザアプリケーションで言えば、以下の順に検索されます。
  1. pages/i18n/[ロケールを表すキーワード]
  2. pages/src
地域化されているソースを検索する場合、java.util.ResourceBundle と同様の検索が行われます。例えば、ロケールが ja_JP だった場合、以下の順にソースが検索されます。
  1. pages/i18n/ja_JP
  2. pages/i18n/ja
  3. pages/src

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Schedule Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Schedule Service 篇 】

機能概要

Schedule Service は、バッチプログラムの実行スケジュールを管理します。

バッチプログラムのスケジューリング機能

設定されたバッチプログラムの実行スケジュール指定に従い、バッチプログラムの実行を管理します。
このサービスは、指定の時間になると該当するバッチプログラムの実行を指定ＵＲＬを用いて Application Runtime に依頼します。したがって、バッチプログラムは、Application Runtime で実行されます。

バッチプログラムの作成

バッチプログラムは、ページベース開発モデルおよびJ2EEベース開発モデルのどちらでも開発可能です。 いずれかのモデルで作成されたプログラムを実行可能な場所に保存してスケジュール設定することで、指定の時間に任意のバッチ処理を実行することができます。
バッチプログラムの動作仕様および作成方法に関しては、Programについてを参照してください。

注意事項

このサービスが動作しているコンピュータの時計は、正しく合わせてください。コンピュータの時計が狂っていると、バッチプログラムが正しく実行されません。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Serialization Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Serialization Service 篇 】

機能概要

Serialization Service は、システム全体における統括的な利用を目的とした機能の集合体です。このサービスでは、アプリケーションロック機能の管理が行われています。

Serialization Service に関連するＡＰＩは以下のとおりです。

  • Lock(Page-Base Programingu Model)
  • jp.co.intra_mart.foundation.service.client.information.Lock(J2EE-Base Programing Model)

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Shared Memory Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Shared Memory Service 篇 】

機能概要

Shared Memory Service は、プログラム間での共有メモリとして利用することができます。

Shared Memory Service に関連するＡＰＩは以下のとおりです。

  • Module.external.*(Page-Base Programing Model)
  • jp.co.intra_mart.foundation.service.client.information.ExternalDirectory(J2EE-Base Programing Model)
  • jp.co.intra_mart.foundation.service.client.information.ExternalMemory(J2EE-Base Programing Model)

仕様

データを一時的に保存しておく目的で利用される機能です。また、このサービスが提供する情報管理は、セッションレスです。タイムアウトなどによりデータが焼失することはありません。
これらの情報(データ)は、Shared Memory Service のメモリ中に保管され、プログラムの要求に応じて取り出したり削除したりします。 従って、分散サーバ構成にてシステムを構築している場合、データの入出力はネットワークを介して行われるため、これらのＡＰＩに対する頻繁なアクセスは実行速度の低下やサーバへの付加増加などを招くことがあります。

注意事項

Shared Memory Service のデータ保存機能では、必要な情報をメモリ中に保管する仕組になっています。
保存データ量がメモリ許容量を超えてしまうと、Shared Memory Service およびこのサービスが動作しているサービスプラットフォームの動作が不安定になってしまいます(同じサービスプラットフォームに複数のサービスを同時運用している場合、他のサービスの実行に影響がでる場合があります)。このような場合は、Shared Memory Service の動作するサービスプラットフォーム起動時の設定メモリ量を考慮して、データを保存し過ぎないように注意して下さい(環境に応じて サービスプラットフォーム 起動時の設定メモリ量を適切に設定して下さい)。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Storage Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Storage Service 篇 】

機能概要

Storage Service は、intra-mart で扱うファイルを一元管理します。

Storage Service の主な仕事は以下の通りです。

  • ファイル(主にデータファイル)の管理
  • PDF ファイルの作成(エクステンションモジュール適用時)
  • XRF ファイルの作成(エクステンションモジュール適用時)

Storage Service に関連するＡＰＩは以下のとおりです。

  • VirtualFile(Page-Base Programing Model)
  • jp.co.intra_mart.foundation.service.client.file.NetworkFile(J2EE-Base Programing Model)

ファイル管理機能

データを一元管理する目的で利用される機能です。

この Storage Service にファイルを保存する事で、intra-mart をネットーワーク型（分散システム）で運用している場合においても、各 Application Runtime が同一のファイルを共有する事ができます（アップロードされたファイルを保存したり、複数のユーザー間で共有するファイルを保存したりなどの目的に利用すると便利です）。

ファイルの保存場所は、Storage Service をインストールしたディレクトリ直下の storage/ 以下になります。
Storage Service のファイルを操作するＡＰＩでファイルパスを指定する場合、storage/ ディレクトリからの相対パス指定をしてください（『..』を利用してパス指定をして storage/ よりも上位のファイルに対してアクセスすると非常に危険なので、絶対にやらないでください）。

エクステンションモジュールによる機能追加

Storage Service はエクステンションモジュールを追加インストールすることで機能追加される場合があります。

Storage Service に機能追加するパッケージ

  • PDF デザイナー
  • XRFコンポーザ

注意事項

storage/ ディレクトリには、Storage Service がファイルの書込や読込をするための権限を与えて下さい。権限が正しく設定されていない場合、Storage Service のファイルを扱うＡＰＩが正しく実行できなくなります。
また、ファイルを新らしく作成する場合、そのファイルが作成できるだけの十分なディスク容量を確保してからファイル作成を行うようにして下さい。storage/ ディレクトリ以下に十分なディスク容量がない場合、ＡＰＩによるファイル作成ができません。

極端に容量の大きいファイルを扱う場合、Storage Service のレスポンスが一時的に低下する事があります。また、ネットワーク型で運用している場合、ネットワーク環境により、Storage Service から Application Server への通信がボトルネックとなり、Storage Service のファイルを扱うＡＰＩの実行速度が遅くなる場合があります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Web Service]]]

i ntra-mart The Power for Enterprise Web Solution
Webサービスについて

概要

i ntra-mart BaseModule は Apache Axis を利用することにより Webサービスの機能を提供することができます。これによりi ntra-mart の機能をネットワークを通じて利用することができます。 以下にその例を示します。

i ntra-mart Framework をご使用の場合は、お使いのウェブアプリケーションサーバのマニュアルをご覧ください。

前提

Webサービスを利用するにはi ntra-mart BaseModule および Apache Axis が正常に動作している必要があります。 インストール方法についてはインストールガイドをご覧ください。

Webサービスの利用

  1. インストール時に使用したApache AXIS を用意してください。
    Apache AXISの展開先を<AXIS_HOME>とします。
    例)C:\axis\axis-1_2

    i ntra-mart BaseModuleのインストール先を<IMART_HOME>とします。
    例)C:\imart

  2. i ntra-mart BaseModuleに添付されているサンプルを例にしてWebサービスを設定します。
    Javaクラス
    • jp.co.intra_mart.sample.soap.ScriptCallerBean.class
      Webサービスを提供するサンプルプログラムです。
      <IMART_HOME>/pages以下に配置された任意のjsプログラムを実行することができます。
    • jp.co.intra_mart.sample.soap.CalculatorClient.class
      Webサービスクライアントのサンプルプログラムです。
      ScriptCallerBean.classのWebサービスを利用して、ネットワークを通じて<IMART_HOME>/pages/src/sample/web_service/calculator.jsを実行します。

    ソースファイルをご覧になる場合はインストールCDの/src/src_sample.zipを展開してご覧ください

    ページベースプログラム
    • <IMART_HOME>/pages/sample/web_service/calculator.js
      Webサービスから呼び出されるページベースプログラムです。
      引数に渡された二つの数値を加算して返却します。

  3. クラスパスの設定
    Webサービスの登録と実行のために必要なApache Axisと i ntra-mart BaseModuleのライブラリをクラスパスに設定します。
    以下がWindows環境でライブラリをクラスパスに追加するバッチファイルの例です。
    set AXIS_HOME=C:\axis\axis-1_1
    set IMART_HOME=C:\imart
    set AXIS_LIB=%AXIS_HOME%\lib
    set CLASSPATH=.
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\axis.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\axis-ant.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\commons-discovery-0.2.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\commons-logging-1.0.4.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\jaxrpc.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\log4j-1.2.8.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\saaj.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\wsdl4j-1.5.1.jar
    set CLASSPATH=%CLASSPATH%;%IMART_HOME%\doc\imart\WEB-INF\classes
    set CLASSPATH=%CLASSPATH%;%IMART_HOME%\bin\intramart.jar

  4. クラスのデプロイ
    Apache Axisの管理用クライアントを利用してクラスファイルをデプロイ（配置）します。 デプロイするにはi ntra-mart BaseModuleに付属の 配置記述ファイル（Deployment Descriptorファイル）を使用します。

    サンプルには以下の配置記述ファイルが付属しています。
    Webサービス配置用 | <IMART_HOME>\doc\imart\WEB-INF\classes\jp\co\intra_mart\sample\soap\ScriptCallerService.wsdd
    Webサービス除去用 | <IMART_HOME>\doc\imart\WEB-INF\classes\jp\co\intra_mart\sample\soap\undeploy.wsdd

    以下のコマンドを実行してください。
    >java org.apache.axis.client.AdminClient -l http://localhost:8080/imart/servlet/AxisServlet
    <IMART_HOME>\doc\imart\WEB-INF\classes\jp\co\intra_mart\sample\soap\ScriptCallerService.wsdd

    <Admin>Done processing</Admin>

    <Admin>Done processing</Admin>と表示されればデプロイは成功です。

  5. Webサービスの実行
    Webサービスを起動しJSプログラムを実行します。以下のコマンドを実行してください。
    >java jp.co.intra_mart.sample.soap.CalculatorClient 5 6
    RESULT=11

    WebサービスのクライアントがWebサービスを起動し、JSプログラムの計算結果が表示されました。 引数に与えた数値の加算結果が表示されれば成功です。
Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[J2EE tag library]]

i ntra-mart The Power for Enterprise Web Solution
J2EE開発モデル
画面共通モジュール
intra-mart タグライブラリ 仕様

注意事項

このページでは、JSPで利用するタグライブラリに関して、プログラム・インターフェースの詳細仕様を記載しています。

intra-mart Tag Library仕様

1. | タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。
2. | タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。
3. | タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。
4. | タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。
5. | JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。 (ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法

intra-mart タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/core/standard" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "imtag" として説明します)

また下記のように、上記の taglib ディレクティブを XML の書式で記述すること も出来ます。

<jsp:directive.taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" />

< サンプル >

<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" %>
<%@ page import="java.util.*" %>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 //EN">
<HTML>

<HEAD>
<TITLE>Hello intra-mart.</TITLE>
</HEAD>

<%! private Date date = new Date(); %>

<BODY bgcolor="whitesmoke">

<CENTER><H2>
<imtag:ImartDateFormat value="<%= date%>" format="yyyy/MM/dd"/>
</H2></CENTER>

</BODY>

</HTML>

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript BASE MODULE Documentation.[Graph]]

i ntra-mart The Power for Enterprise Web Solution
グラフ描画・モジュール

機能概要

入力データをもとに画像ファイルを作成して、ブラウザ画面上にグラフ画面を表示します。

以下の５種類のグラフがサンプルとして用意されています。

  • 折れ線グラフ
  • 棒グラフ
  • 円グラフ
  • レーダーチャート
  • ポートフォリオ

ＡＰＩ仕様

intra-mart 標準 タグライブラリ の drawer タグを利用します。

drawer タグの属性 data にjp.co.intra_mart.foundation.drawer.AbstractDrawer を スーパークラスとしたインスタンスを渡すことによりグラフの画像ファイルをHTMLに表示します。

AbstractDrawerをスーパークラスとした、グラフ描画クラスは以下の５種類です。

クラス | グラフの種類
jp.co.intra_mart.foundation.graph.BarGraphDrawer | 棒グラフ
jp.co.intra_mart.foundation.graph.CircleGraphDrawer | 円グラフ
jp.co.intra_mart.foundation.graph.LineGraphDrawer | 折れ線グラフ
jp.co.intra_mart.foundation.graph.PortFolioDrawer | ポートフォリオ
jp.co.intra_mart.foundation.graph.RadarChartDrawer | レーダーチャート

  • Drawer タグの詳細については画面共通モジュールを参照してください。
  • AbstractDrawerとサブクラスの詳細についてはアプリケーション共通モジュールを参照してください。

グラフ作成例

<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Windows-31J" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<%@ page import="jp.co.intra_mart.foundation.graph.*" %>
<%@ page import="java.awt.Color" %>
<%
  // 棒グラフの作成
  BarGraphDrawer drawerBar = new BarGraphDrawer(0, 60, 10);
  drawerBar.setWidth(300);
  drawerBar.setHeight(300);
  drawerBar.setCaption(new String[]{"１月", "２月", "３月"});

  BarGraphObject objBar = new BarGraphObject(Color.black);
  objBar.addData(50);
  objBar.addData(10);
  objBar.addData(30);
  drawerBar.addData(objBar);
%>
<HTML>
  <BODY>
    <imarttag:drawer data="<%= drawerBar %>" />
  </BODY>
</HTML>

描画された棒グラフ（例）

新しいグラフの作成

グラフを新規に作成する場合、AbstractDrawerを利用します。
AbstractDrawerを継承したクラスを作成し、createImageメソッドをオーバーライドしてください。

public class MyGraphDrawer extends AbstractDrawer {

  public MyGraphDrawer(
    super();
  }

  protected void createImage(Graphics g) {

    g.setColor(Color.red);
    g.drawLine(0, 0, getWidth() - 1, getHeight() - 1);

    g.setColor(Color.blue);
    g.drawRect(0, 0, getWidth() - 1, getHeight() - 1);

    .
    .
    .
    .
  }
}

createImageメソッドには画像描画の実行部分を記述します。
引数のグラフィックコンテキストに対して、グラフイメージを描画してください。

グラフのプログラムソースはインストールディレクトリ/sourceに格納されています。
具体的な記述方法はプログラムソースを参照してください。
AbstractDrawerの詳細についてはアプリケーション共通モジュールを参照してください。

Headless のサポート

X11を搭載していないUNIXなどのOSは、グラフィックスをサポートしていないため通常グラフモジュールを使用することができません。 但し、ヘッドレスモードをサポートしているJava VMを使用している場合、Java環境変数を設定することにより非グラフィックス環境の場合でも グラフモジュールを使用することが可能です。

i ntra-mart BaseModule の場合は、/conf/imart.xmlの以下の場所にJava環境変数を追加してください。

    .
    .
<command>
  <exefile>C:/j2sdk1.4.2_XX/bin/java</exefile>
  <option>-cp %SYSTEMCLASSPATH% -Xms%XMS% -Xmx%XMX% -Djava.awt.headless=true</option>
  <argument/>
</command>
    .
    .

i ntra-mart Frameworkの場合は、同様のJava環境変数をウェブアプリケーションサーバに設定してください。 Java環境変数の設定方法については、ウェブアプリケーションサーバのマニュアルを参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart タグライブラリ メニュー

intra-mart タグライブラリ (ユーティリティ)
<スプレッドシート>
CellDataSelector
ColumnDataSelector
RowDataSelector
SelectionSubmitter
LineHighLight
Sorting
DynamicTable
Column
DBListPaging
<入力制御>
Validate
DblClickForbidden
BackForbidden
<メニュ>
PopMenu
TabPane
Tab
<メッセージプッシュ>
Push
PushMessage


CellDataSelector
HTMLのテーブルのセルのデータを選択可能にするタグです。
このタグ内には、HTMLのテーブル（TDを一つ以上）を置く必要があります。
テーブルのセルをクリックすることで、該当セルが選択された状態になり、指定の前景色と背景色で表示されます。この状態で再びクリックしますと、該当セルの選択状態が解除され、元の前景色と背景色に戻ります。

デフォールトでは、選択できるセルは一つだけですが、属性multipleSelectableを"true"にすることで、複数選択も可能です。複数選択可能の場合の各セルデータの間の区切り文字は、属性cellDataSeperatorで定義することができる。
  このタグの内部に、SelectionSubmitterタグを置くことで、選択されたセルのデータをサーバに送信することができます。詳細はSelectionSubmitterタグに参照してください。
このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグをSortingタグの内部に置くことで、テーブルデータに対するソート機能とセル選択機能を同時に実現することができます。
このタグをLineHighLightタグの内部に置くことで、テーブルデータに対するセル選択と行ハイライト機能を同時に実現することができます。
Tagボディ | JSP
制約 ・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・THの内容は選択不可です。
・テーブルのTABLE、TR、TH、TDにHTMLのID属性を設定することはできません。
・SelectionSubmitterタグとネスとして、選択されたセルのデータをサーバに送信する場合、送信されたデータはセルの中（TDタグ）に挟まれるすべての内容（インプットフィールドや画像などの場合はそのままHTMLコードを送信する）。
・ SelectionSubmitterタグとネストする場合は、SelectionSubmitterタグは必ずこのタグの一層下（SelectionSubmitterタグの一番近い親タグはこのタグであること）に置きます。
属性 | 名前 | 必須 | 実行時評価
bgColor | No | Yes

選択された状態の背景色。デフォルトは"blue"。
fgColor | No | Yes
選択された状態の前景色。デフォルトは"white"。
multipleSelectable | No | Yes

複数選択可否のフラグ。デフォルトは"false"、複数選択不可。
cellDataSeperator | No | Yes

複数選択可能の場合の各セルデータの間の区切り文字。デフォルトは","（カンマ）。
内部タグ | SelectionSubmitterタグ

選択されたセルのデータをサーバに送信する。
使用例 | セル選択と送信機能
<imtag:CellDataSelector bgColor="white" fgColor="red"
    multipleSelectable="true">
  <table border="1" bgcolor="#BFD0EE" width="50%">
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
    <tr>
      <td>002</td>
      <td>Kyoto</td>
      <td>京都</td>
    </tr>
  </table>
  <imtag:SelectionSubmitter formName="form"
        application="taglib" service="testform"/>
</imtag:CellDataSelector>

ColumnDataSelector

HTMLのテーブルの列のデータを選択可能にするタグです。
このタグ内には、HTMLのテーブル（TDを一つ以上）を置く必要があります。
テーブルの列の任意の位置をクリックすることで、該当列が選択された状態になり、指定の前景色と背景色で表示されます。この状態で再びクリックしますと、該当列の選択状態が解除され、元の前景色と背景色に戻ります。
デフォールトでは、選択できる列は一列だけですが、属性multipleSelectableを"true"にすることで、複数列選択も可能です。複数選択可能の場合の各列のデータの間の区切り文字は属性columnDataSeperatorで定義し、列内部の各セルデータの間の区切り文字は、属性cellDataSeperatorで定義することができる。

このタグの内部に、SelectionSubmitterタグを置くことで、選択された列のデータをサーバに送信することができます。詳細はSelectionSubmitterタグに参照してください。
このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグをSortingタグの内部に置くことで、テーブルデータに対するソート機能と列選択機能を同時に実現することができます。
このタグをLineHighLightタグの内部に置くことで、テーブルデータに対する列選択と行ハイライト機能を同時に実現することができます。
Tagボディ | JSP
制約 ・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・THの内容は選択不可です。
・テーブルのTABLE、TR、TH、TDにHTMLのID属性を設定することはできません。
・SelectionSubmitterタグとネスとして、選択されたセルのデータをサーバに送信する場合、送信されたデータはセルの中（TDタグ）に挟まれるすべての内容（インプットフィールドや画像などの場合はそのままHTMLコードを送信する）。
・ SelectionSubmitterタグとネストする場合は、SelectionSubmitterタグは必ずこのタグの一層下（SelectionSubmitterタグの一番近い親タグはこのタグであること）に置きます。
属性 | 名前 | 必須 | 実行時評価
bgColor | No | Yes

選択された状態の背景色。デフォルトは"blue"。
fgColor | No | Yes
選択された状態の前景色。デフォルトは"white"。
multipleSelectable | No | Yes

複数選択可否のフラグ。デフォルトは"false"、複数選択不可。
cellDataSeperator | No | Yes

同列の各セルデータの間の区切り文字。デフォルトは","（カンマ）。
columnDataSeperator | No | Yes

複数列選択可能の場合の列データの間の区切り文字。デフォルトは"|"。
内部タグ | SelectionSubmitterタグ

選択された列のデータをサーバに送信する。
使用例 | 列選択と送信機能
<imtag:ColumnDataSelector bgColor="white" fgColor="red"
    multipleSelectable="true">
  <table border=1 bgcolor="#BFD0EE" bordercolor="#336699" width="50%">
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
    <tr>
      <td>002</td>
      <td>Kyoto</td>
      <td>京都</td>
    </tr>
  </table>
  <imtag:SelectionSubmitter formName="form"
        application="taglib" service="testform"/>
</imtag:ColumnDataSelector>

RowDataSelector

HTMLのテーブルの行のデータを選択可能にするタグです。
このタグ内には、HTMLのテーブル（TDを一つ以上）を置く必要があります。
テーブルの行の任意の位置をクリックすることで、該当行が選択された状態になり、指定の前景色と背景色で表示されます。この状態で再びクリックしますと、該当行の選択状態が解除され、元の前景色と背景色に戻ります。
デフォールトでは、選択できる行は一行だけですが、属性multipleSelectableを"true"にすることで、複数行選択も可能です。複数選択可能の場合の各行のデータの間の区切り文字は属性rowDataSeparatorで定義し、行内部の各セルデータの間の区切り文字は、属性cellDataSeperatorで定義することができる。

このタグの内部に、SelectionSubmitterタグを置くことで、選択された列のデータをサーバに送信することができます。詳細はSelectionSubmitterタグに参照してください。
このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグをSortingタグの内部に置くことで、テーブルデータに対するソート機能と列選択機能を同時に実現することができます。
このタグをLineHighLightタグの内部に置くことで、テーブルデータに対する列選択と行ハイライト機能を同時に実現することができます。
Tagボディ | JSP
制約 ・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・THの内容は選択不可です。
・テーブルのTABLE、TR、TH、TDにHTMLのID属性を設定することはできません。
・SelectionSubmitterタグとネスとして、選択されたセルのデータをサーバに送信する場合、送信されたデータはセルの中（TDタグ）に挟まれるすべての内容（インプットフィールドや画像などの場合はそのままHTMLコードを送信する）。
・ SelectionSubmitterタグとネストする場合は、SelectionSubmitterタグは必ずこのタグの一層下（SelectionSubmitterタグの一番近い親タグはこのタグであること）に置きます。
属性 | 名前 | 必須 | 実行時評価
bgColor | No | Yes

選択された状態の背景色。デフォルトは"blue"。
fgColor | No | Yes
選択された状態の前景色。デフォルトは"white"。
multipleSelectable | No | Yes

複数選択可否のフラグ。デフォルトは"false"、複数選択不可。
cellDataSeperator | No | Yes

同行の各セルデータの間の区切り文字。デフォルトは","（カンマ）。
rowDataSeperator | No | Yes

複数行選択可能の場合の行データの間の区切り文字。デフォルトは"|"。
内部タグ | SelectionSubmitterタグ

選択された行のデータをサーバに送信する。
使用例 | 行選択と送信機能
<imtag:RowDataSelector bgColor="white" fgColor="red"
    multipleSelectable="true">
  <table border=1 bgcolor="#BFD0EE" bordercolor="#336699" width="50%">
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
    <tr>
      <td>002</td>
      <td>Kyoto</td>
      <td>京都</td>
    </tr>
  </table>
  <imtag:SelectionSubmitter formName="form"
        application="taglib" service="testform"/>
</imtag:RowDataSelector>

SelectionSubmitter

CellDataSelector、ColumnDataSelector、またはRowDataSelectorタグ内部で、ネストして利用します。
このタグはCellDataSelector、ColumnDataSelector、またはRowDataSelectorタグで選択されたデータをサーバへ送信します。
このタグで送信用フォームとサブミットボタンを生成します。画面に表示するのは、サブミットボタンです。
Tagボディ | 空
制約 ・このタグはCellDataSelector、ColumnDataSelector、またはRowDataSelectorタグの一層下におく必要があります。（このタグの親タグはCellDataSelector、ColumnDataSelector、またはRowDataSelectorのいずれ一つ）
・このタグで生成されたサブミットボタンを押す場合、送信されたデータはTDの中のすべての内容であり、TD内部でインプットフィールドや画像などがある場合は、そのままインプットフィールドや画像のHTMLコードをサーバに送信します。
属性 | 名前 | 必須 | 実行時評価
formName | Yes | Yes
生成されたFORMの名称。
application | No | Yes
選択されたデータをサーバへ送信する時に、送信対象がim-J2EE FrameworkのService Frameworkである場合のapplication ID。urlまたはactionPointと同時に指定することはできません。serviceと同時に指定する必要があります。
service | No | Yes
選択されたデータをサーバへ送信する時に、送信対象がim-J2EE FrameworkのService Frameworkである場合のservice ID。urlまたはactionPointと同時に指定することはできません。applicationと同時に指定する必要があります。
actionPoint | No | Yes
選択されたデータをサーバへ送信する時に、送信対象がim-J2EE FrameworkのPresentation Frameworkである場合のactionPoint。urlまたはapplication・serviceと同時に指定することはできません。
url | No | Yes
選択されたデータをサーバへ送信する時に、送信対象がim-J2EE Framework以外の一般画面である場合のURL。application・serviceまたはactionPointと同時に指定することはできません。
parameterName | No | Yes
選択されたデータをサーバへ送信する時のパラメータ名。デフォルトは"data"。
styleClass | No | Yes
サブミットボタンに適用するCSSのクラス名。
label | No | Yes

サブミットボタンの上に表示する文字列。デフォルトは"送信"。
method | No | Yes
データサ送信方式。GetかPostの一つ。デフォルトは"POST"。
onClick | No | Yes
ボタンを押す時に実行するJavaScriptの関数名。HTMLのsubmitのonClickと同様。
target | No | Yes
サブミットのターゲット。HTMLのformのtarget属性の同様。
内部タグ | なし
使用例 | サブミットボタンの表示
<imtag:RowDataSelector bgColor="white" fgColor="red">
  <table border=1 bgcolor="#BFD0EE" bordercolor="#336699" width="50%">
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
  </table>
  <imtag:SelectionSubmitter formName="myform"
        application="taglib" service="testform"/>
</imtag:RowDataSelector>

LineHighLight

このタグの内部にあるテーブルにマウスのカーソルが重なった時、行の前景色と背景色が指定値に変わります。
このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグは、CellDataSelector・ColumnDataSelector・RowDataSelector・Sortingタグとネスト利用が可能です。
CellDataSelector・ColumnDataSelector・RowDataSelector・Sortingとネストする場合は、このタグがテーブルの一番外側に置く必要があります。
Tagボディ | JSP
制約

・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・CellDataSelector・ColumnDataSelector・RowDataSelector・Sortingとネストする場合は、このタグがテーブルの一番外側に置く必要があります。
・このタグは行（TR）単位で色を変えますため、行内部のセル（TD）にスタイルを単独に指定する場合、HTMLの制限で、該当セルのスタイルを変えることはできません。
属性 | 名前 | 必須 | 実行時評価
bgColor | No | Yes

カーソルが行と重なった時の行の背景色。デフォルトは"blue"。
fgColor | No | Yes
カーソルが行と重なった時の行の前景色。デフォルトは"white"。
内部タグ | なし

使用例 | 行のハイライト
<imtag:LineHighLight bgColor="#F5FDFF" fgColor="red">
  <table border=1 bordercolor="#336699" width="50%" >
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
    <tr>
      <td>002</td>
      <td>Kyoto</td>
      <td>京都</td>
    </tr>
  </table>
</imtag:LineHighLight>

Sorting

このタグの内部にあるテーブルに対して、各カラムのデータのソート機能を提供します。
ソートしたい列のTHをクリックすることで、該当列をソートすることができます。
選択されたTHの背景色と前景色はそれぞれbgColorClickとfgColorClick属性で指定します。
THを初期クリックする時は、該当列のデータを昇順で表示し、THに、昇順を表すアイコンを表示します。再度クリックすると、降順でデータを表示し、降順アイコンを表示します。

このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグは、CellDataSelector・ColumnDataSelector・RowDataSelectorタグとネストすることができます。ネストする場合は、CellDataSelector・ColumnDataSelector・RowDataSelectorタグの外側に置く必要があります。
このタグはLineHighLightタグとネストすることができます。ネストする場合は、LineHighLightの中に置く必要があります。

(注意) DynamicTableやDBListPagingタグと連携し、DynamicTableやDBListPagingタグがページング機能を利用する場合、このタグは単なる画面に表示する分のデータをソートする。DynamicTableやDBListPagingのリスト全体をソートすることはできません。DynamicTableやDBListPagingのリスト全体をソートしたい場合は、DynamicTableやDBListPagingの内部タグのColumnのsortable属性を利用してください。
Tagボディ | JSP
制約 ・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・このタグでソートできるのは、文字列のみです。テーブル内に画像は入力フィールドのある場合のソートはあまり意味がないです。
・CellDataSelector・ColumnDataSelector・RowDataSelectorタグとネストする場合は、CellDataSelector・ColumnDataSelector・RowDataSelectorタグの外側に置く必要があります。
・LineHighLightタグとネストする場合は、LineHighLightの中に置く必要があります。
・このタグはJavaScriptでテーブルの内容をソートしますので、テーブルにあるデータはすべて文字列と認め、文字列の大小関係でソートします。
属性 | 名前 | 必須 | 実行時評価
bgColorClick | No | Yes

ソート対象列のTHをクリックする時の背景色。デフォルトは"navy"。
fgColorClick | No | Yes

ソート対象列のTHをクリックする時の前景色。デフォルトは"white"。
order | No | Yes

初期ソート順。asc（昇順）かdesc（降順）を設定できます。デフォルトは"asc"。
使用例 | テーブルデータのソート
<imtag:Sorting bgColorClick="#F5FDFF" fgColorClick="red">
  <table border=1 bgcolor="#BFD0EE" width="50%" bordercolor="#336699">
    <tr bgcolor="#86AFFA">
      <th width="30%">ID</th>
      <th width="32%">ローマ字</th>
      <th width="38%">漢字</th>
    </tr>
    <tr>
      <td width="30%">001</td>
      <td width="32%">Tokyo</td>
      <td width="38%">東京</td>
    </tr>
    <tr>
      <td width="30%">002</td>
      <td width="32%">Kyoto</td>
      <td width="38%">京都</td>
    </tr>
  </table>
</imtag:Sorting>

DynamicTable

動的テーブルを生成する機能を提供します。
このタグは、requestやsession内のListインスタンスをテーブルにバインドして、List内部のデータを表示することができます。ページング機能を利用する場合は、自動的に改ページ用リンクを出力し、ユーザ指定のページサイズ・インデックスサイズで、改ページ機能を提供します。
List内部のオブジェクトは、JavaBeanまたはMapに対応します。

このタグで生成されたテーブルは、CellDataSelector・RowDataSelector・ColumnDataSelector・Sorting・LineHighLightなどのタグ内で利用することができます。
Tagボディ | JSP
制約 ・Columnタグと組み合わせて使用する必要があります。
・同じページ内のtableID（DBListPagingを利用する場合のtableIDも同様）を重複することはできません。
・テーブルにバインドできるリストの内部要素は、JavaBeanまたはMapである必要があります。それ以外のオブジェクトをバインドすることはできません。
属性 | 名前 | 必須 | 実行時評価
tableID | Yes | Yes
このテーブルを一意識別するためのID。必ず指定してください。同じ画面で複数のDynamicTable（またはDBListPagingと併用）を利用する場合は、それぞれ違うtableIDを指定する必要があります。
list | Yes | Yes

テーブルにバインドするリストの参照名。このタグは該当参照名で、RequestとSessionからオブジェクトを検索します。該当参照名に対応するインスタンスはjava.util.Listを実現する必要があります。List内部には、JavaBean規約に従うJavaBeanオブジェクトまたはMapオブジェクトを利用することができます。
scope | No | Yes
Listを参照するスコープ。requestまたはsessionを指定することができます。未設定の場合、requestとsessionを順に検索します。デフォルトはrequestとなります。requestとsessionに同じ参照名がある場合はrequestが優先します。
width | No | Yes
生成されたテーブルの幅。デフォルトは"100%"。HTMLのTABLEのwidth属性に相当します。
border | No | Yes
生成されたテーブルの幅。デフォルトは"1"。HTMLのTABLEのborder属性に相当します。
styleClass | No | Yes
生成されたテーブルに適用するCSSのクラス名。HTMLのTABLEのclass属性に相当します。
paging | No | Yes
該当テーブルに対して、ページング機能を利用するかどうかの設定。"true"に設定することで、指定サイズのテーブルを出力し、指定位置に改ページ表示用のリンクを表示します。"false"の場合は、自動ページング機能を利用せず、リスト全体の内容をテーブルに表示します。デフォルトは"true"。
pageSize | No | Yes
自動ページング機能を利用する場合のページ毎の表示行数。デフォルトは"10"。
indexSize | No | Yes
改ページ用のページインデックス数の最大表示個数。デフォルトは"8"。
indexLocation | No | Yes
改ページ用のページインデックスの表示場所。テーブルの上("top")、下("bottom")、または両方("both")を指定することができます。デフォルトは"bottom"。
application | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのService FrameworkのApplication ID。画面JSPがim-J2EE FrameworkのService Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのApplication IDです。service属性と同時に指定する必要があります。actionPointかstartPointと同時指定することができません。
service | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのService FrameworkのService ID。画面JSPがim-J2EE FrameworkのService Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのService IDです。application属性と同時に指定する必要があります。actionPointかstartPointと同時指定することができません。
actionPoint | No | Yes

改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのPresentation FrameworkのactionPoint。画面JSPがim-J2EE FrameworkのPresentation Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのactionPointです。application・service属性とstartPoint属性と同時に指定することができません。
startPoint | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのPresentation FrameworkのstartPoint。画面JSPがim-J2EE FrameworkのPresentation Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのstartPointです。application・service属性actionPoint属性と同時に指定することができません。startPointの指定方法は、im-J2EE Framework仕様書の9.9.7節を参考してください。
内部タグ | Columnタグ

テーブルにバインドするリストの内部の要素を表します。
使用例 | 動的テーブル生成
List内部の要素がMapである場合の例を挙げて説明します。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/util" prefix="imtag" %>
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ page import="java.util.*"%>
<%
    ArrayList list = new ArrayList();
    for(int counter = -128; counter <127; counter++){
        HashMap map = new HashMap();
        map.put("strTest","str_"+counter);
        map.put("byteTest",new Byte(""+counter));
        char aChar = (char)counter;
        map.put("charTest",new Character(aChar));
        map.put("intTest",new Integer(counter));
        map.put("floatTest",new Float(counter));
        map.put("doubleTest",new Double(counter));
        if(counter%2 == 0)
            map.put("blnTest",new Boolean(false));
        else
            map.put("blnTest",new Boolean(true));
        map.put("dateTest",new Date());

        list.add(map);
    }

    request.setAttribute("list",list);
%>
<html>
    <head>
        <title>DynamicTable Map</title>
    </head>
    <body>
        <imtag:DynamicTable list="list" tableID="table_map"
            styleClass="test" pageSize="10" indexLocation="both"
            indexSize="10">
            <imtag:Column attribute="strTest" title="String"
                headerClass="header" styleClass="test" sortable="true"/>
            <imtag:Column attribute="intTest" title="int"
                headerClass="header" sortable="true"/>
            <imtag:Column attribute="byteTest" title="byte"
                headerClass="header" sortable="true"/>
            <imtag:Column attribute="charTest" title="char"
                 headerClass="header" sortable="true"/>
            <imtag:Column attribute="floatTest" title="float"
                 headerClass="header" sortable="true"/>
            <imtag:Column attribute="doubleTest" title="double"
                 headerClass="header" sortable="true"/>
            <imtag:Column attribute="blnTest" title="boolean"
                 headerClass="header" sortable="true"/>
            <imtag:Column attribute="dateTest" title="date"
                 maxLength="10" headerClass="header" sortable="true"/>
            <imtag:Column content="FIXED DATA" title="FIXED"
                 headerClass="header"/>
        </imtag:DynamicTable>
    </body>
</html>

Column

DynamicTableタグまたはDBListPagingタグの中にネストして利用する内部タグです。
このタグはDynamicTableタグまたはDBListPagingタグの中でしか利用することができません。
DynamicTableまたはDBListPagingタグにバインドできるのはListで、ColumnタグはそのListの中の要素であるJavaBeanまたはMapの属性を表します。

Tagボディ | 空
制約 ・本タグを単独で利用することはできません。
・DynamicTableまたはDBListPagingタグの中でネストして利用する必要があります。
・このタグのattribute属性でJavaBeanのプロパティを指定するか、content属性で固定値を指定するか、必ず一つ設定してください。
・content属性の指定するカラムに対してはsortableを"true" にすることはできません。（固定値のソートは無意味ですので）
属性 | 名前 | 必須 | 実行時評価
attribute | No | Yes
親タグの DynamicTable または DBListPaging の list 属性で定義する Listオブジェクト内の要素であるJavaBean のプロパティ名、または Map の Key 名。 attributeに対応する内容がコラムデータとして表示される。 この属性が未指定の場合は、属性 content で固定値を指定されているかをチェックする。この属性を指定するか、 content 属性で固定値を書くかの一つが必要です。
title | Yes | Yes
該当するコラムのヘッダー (TH) に表示するコラム名称。必須。
width | No | Yes
該当カラムの表示幅。HTMLのTH（またはTD）のwidht属性に相当します。
headerClass | No | Yes
該当コラムのヘッダー（TH）に適用するCSSのクラス名。HTMLのTHのclass属性に相当します。
styleClass | No | Yes
該当コラムのデータ出力部（TD）に適用するCSSのクラス名。HTMLのTDのclass属性に相当します。
maxLength | No | Yes
該当カラムに表示するデータの最大表示字数。出力データの字数がこの設定値より大きい場合、最大表示字数を表示し、後ろの文字は" … "になります。 この属性を利用するセルデータにマウスを重ねることで、データ全体を表示することができます。
sortable | No | Yes
該当カラムでソート機能を利用するかのフラグの設定。"true"を設定することで、該当カラムの TH 部にリンクを生成します。リンクを初期クリックする時は、該当カラムのデータの昇順でリスト全体をソートし、 TH に昇順ソートのアイコンを表示します。再度クリックすることで、逆順（昇順→降順→昇順…）でリスト全体を再度ソートし、 TH のそばに逆順のアイコンを表示します。デフォルト値は"false"。DynamicTable と DBListPaging タグは Sorting タグでネストされることで、一ページに表示するデータをソートすることができますが、リスト全体のデータのソートするには、この属性を利用する必要があります。
content | No | Yes
固定値を出力したい場合は、この属性で固定値を設定します。ただし、固定値に対してのソート はできません。 この属性とattribute属性が同時に指定された場合は、この属性が優先されます。
内部タグ | なし

使用例 | DynamicTableとネストし、List内部はJavaBeanである場合の例

JavaBeanの構造は以下のようです。

/*
 * Bean test for DynamicTable tag.
 */

import java.util.Date;

/**
 * Bean test for DynamicTable tag.
 *
 * @author Seki
 */
public class TestBean {

    private String strTest;

    private byte byteTest;

    private char charTest;

    private int intTest;

    private float floatTest;

    private double doubleTest;

    private boolean blnTest;

    private Date dateTest;

    public TestBean(int counter) {
        this.strTest = "str_" + counter;
        this.byteTest = (byte) counter;
        this.charTest = (char) counter;
        this.intTest = counter;
        this.floatTest = counter;
        this.doubleTest = counter;
        if (counter % 2 == 0)
            this.blnTest = false;
        else
            this.blnTest = true;
        this.dateTest = new Date();
    }

    /**
     * @return Returns the byteTest.
     */
    public byte getByteTest() {
        return byteTest;
    }

    /**
     * @param byteTest
     *                   The byteTest to set.
     */
    public void setByteTest(byte byteTest) {
        this.byteTest = byteTest;
    }

    /**
     * @return Returns the charTest.
     */
    public char getCharTest() {
        return charTest;
    }

    /**
     * @param charTest
     *                   The charTest to set.
     */
    public void setCharTest(char charTest) {
        this.charTest = charTest;
    }

    /**
     * @return Returns the blnTest.
     */
    public boolean isBlnTest() {
        return blnTest;
    }

    /**
     * @param blnTest
     *                   The blnTest to set.
     */
    public void setBlnTest(boolean blnTest) {
        this.blnTest = blnTest;
    }

    /**
     * @return Returns the dateTest.
     */
    public Date getDateTest() {
        return dateTest;
    }

    /**
     * @param dateTest
     *                   The dateTest to set.
     */
    public void setDateTest(Date dateTest) {
        this.dateTest = dateTest;
    }

    /**
     * @return Returns the doubleTest.
     */
    public double getDoubleTest() {
        return doubleTest;
    }

    /**
     * @param doubleTest
     *                   The doubleTest to set.
     */
    public void setDoubleTest(double doubleTest) {
        this.doubleTest = doubleTest;
    }

    /**
     * @return Returns the floatTest.
     */
    public float getFloatTest() {
        return floatTest;
    }

    /**
     * @param floatTest
     *                   The floatTest to set.
     */
    public void setFloatTest(float floatTest) {
        this.floatTest = floatTest;
    }

    /**
     * @return Returns the intTest.
     */
    public int getIntTest() {
        return intTest;
    }

    /**
     * @param intTest
     *                   The intTest to set.
     */
    public void setIntTest(int intTest) {
        this.intTest = intTest;
    }

    /**
     * @return Returns the strTest.
     */
    public String getStrTest() {
        return strTest;
    }

    /**
     * @param strTest
     *                   The strTest to set.
     */
    public void setStrTest(String strTest) {
        this.strTest = strTest;
    }
}

JSPの呼び出し。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/util" prefix="imtag" %>
<%@ page contentType="text/html; charset=Shift_JIS" pageEncoding="Windows-31J" %>
<%@ page import="java.util.ArrayList"%>
<%@ page import="TestBean"%>
<%
    ArrayList list = new ArrayList();
    for(int i=-128;i<127;i++){
        TestBean bean = new TestBean(i+1);
        list.add(bean);
    }
    request.setAttribute("list",list);
%>

<html>
    <head>
        <title>DynamicTable JavaBean</title>
    </head>
    <body>

    <imtag:DynamicTable tableID="bean_table_1"list="list"
        styleClass="test" pageSize="10" indexLocation="both" indexSize="10">
         <imtag:Column attribute="strTest" title="String"
             headerClass="header" styleClass="test" sortable="true"/>
        <imtag:Column attribute="intTest" title="int"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="byteTest" title="byte"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="charTest" title="char"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="floatTest" title="float"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="doubleTest" title="double"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="blnTest" title="boolean"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="dateTest" title="date"
             headerClass="header" sortable="true"/>
        <imtag:Column content="FIXED DATA" title="FIXED"
             headerClass="header"/>
    </imtag:DynamicTable>
    </body>
</html>

DBListPaging

ベースモジュール（またはフレームワーク)のデータベース設定（またはマルチデータベース設定）で設定されたデータベースを参照し、データを読み込み、動的にテーブルの作成をします。
ページング機能を利用する場合は、自動的に改ページのリンクを出力し、ユーザ指定のページサイズ・インデックスサイズで、改ページ機能を提供します。

DynamicTableタグとの違いは、テーブルにバインドするListオブジェクトの取得先です。DynamicTableに利用できるListはrequestまたはsession内のListオブジェクトであればよいが、DBListPagingの場合は、ベースモジュール（またはフレームワーク）のデータベース設定で設定されたDBのテーブルからデータを取得します。
それに、ソート機能を利用する場合は、DynamicTableはList内のデータを比較してソートしますが、DBListPagingの場合は、SQL文のorder部を再構成してDBの再検索でソートします。

このタグで生成されたテーブルは、CellDataSelector・RowDataSelector・ColumnDataSelector・Sorting・LineHighLightなどのタグ内で利用することができます。
Tagボディ | JSP
制約 ・Columnタグと組み合わせて使用する必要があります。
・同じページ内のtableID（DynamicTableを利用する場合のtableIDも同様）を重複することはできません。
・tableName・dbColumns・where・orderなどのSQL文関連の属性の内容はSQL文規約に従う必要があります。
属性 | 名前 | 必須 | 実行時評価
tableID | Yes | Yes
このテーブルを一意識別するためのID。必ず指定してください。同じ画面で複数のDBListPaging（またはDynamicTableと併用）を利用する場合は、それぞれ違うtableIDを指定する必要があります。
tableName | Yes | Yes
データ取得対象テーブル名。複数テーブルからデータを取得したい場合は、SQL文規約で複数テーブルを指定することができます。
dbColumns | No | Yes
データ取得対象カラム名。複数カラムからデータを取得したい場合は、SQL文規約で指定することができます（","（カンマ）区切りでカラムを指定する）。未指定の場合は、"*"を利用して、tableNameで指定されたテーブルからすべてのカラムのデータを取得します。
where | No | Yes
データ取得用のSQL文の条件部。SQL文規約に従う必要があります。
order | No | Yes
データ取得用のSQL文のソート部。SQL文規約に従う必要があります。データ初期取得時は、この属性で指定された内容でデータをソートします。但し、サブタグのColumnタグのsortable属性を"true"に設定する場合、データをソートする時は、指定カラムをソート基準でSQL文のorder部を再構成してDBを再検索しますので、ここのorder属性の指定が無視されます。
group | No | Yes
ベースモジュール（またはフレームワーク）のデータベース（またはマルチデータベース）設定で設定されたデータベース参照名です。未指定の場合、ログインユーザのログイングループIDを利用します。
width | No | Yes
生成されたテーブルの幅。デフォルトは"100%"。HTMLのTABLEのwidth属性に相当します。
border | No | Yes
生成されたテーブルの幅。デフォルトは"1"。HTMLのTABLEのborder属性に相当します。
styleClass | No | Yes
生成されたテーブルに適用するCSSのクラス名。HTMLのTABLEのclass属性に相当します。
paging | No | Yes
該当テーブルに対して、ページング機能を利用するかどうかの設定。"true"に設定することで、指定サイズのテーブルを出力し、指定位置に改ページ表示用のリンクを表示します。"false"の場合は、自動ページング機能を利用せず、リスト全体の内容をテーブルに表示します。デフォルトは"true"。
pageSize | No | Yes
自動ページング機能を利用する場合のページ毎の表示行数。デフォルトは"10"。
indexSize | No | Yes
改ページ用のページインデックス数の最大表示個数。デフォルトは"8"。
indexLocation | No | Yes
改ページ用のページインデックスの表示場所。テーブルの上("top")、下("bottom")、または両方("both")を指定することができます。デフォルトは"bottom"。
application | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのService FrameworkのApplication ID。画面JSPがim-J2EE FrameworkのService Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのApplication IDです。service属性と同時に指定する必要があります。actionPointかstartPointと同時指定することができません。
service | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのService FrameworkのService ID。画面JSPがim-J2EE FrameworkのService Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのService IDです。application属性と同時に指定する必要があります。actionPointかstartPointと同時指定することができません。
actionPoint | No | Yes

改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのPresentation FrameworkのactionPoint。画面JSPがim-J2EE FrameworkのPresentation Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのactionPointです。application・service属性とstartPoint属性と同時に指定することができません。
startPoint | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのPresentation FrameworkのstartPoint。画面JSPがim-J2EE FrameworkのPresentation Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのstartPointです。application・service属性actionPoint属性と同時に指定することができません。startPointの指定方法は、im-J2EE Framework仕様書の9.9.7節を参考してください。
内部タグ | Columnタグ

テーブルにバインドするリストの内部の要素を表します。
使用例 | データベースからデータを取得し、テーブルにバインドします
<imtag:DBListPaging tableID="usertable" tableName="b_m_user"
    dbColumns="user_cd,user_name" order="user_cd desc"
    styleClass="test" pageSize="10" indexLocation="both"
    indexSize="10">
    <imtag:Column attribute="user_cd" title="Code" headerClass="header"
        styleClass="test" sortable="true"/>
    <imtag:Column attribute="user_name" title="Name" headerClass="header"
        sortable="true"/>
</imtag:DBListPaging>

複数テーブルからデータを取得する場合の例：
<imtag:DBListPaging tableID="userportaltable"
    tableName="b_m_user a,b_m_user_portal b"
    dbColumns="a.user_cd,a.user_name,b.layout_cls"
    where="a.user_cd=b.user_cd"
    order="a.user_cd desc" styleClass="test" pageSize="10"
    indexLocation="both" indexSize="10">
    <imtag:Column attribute="user_cd" title="Code" />
    <imtag:Column attribute="user_name" title="Name" />
    <imtag:Column attribute="layout_cls" title="Layout" />
</imtag:DBListPaging>

Validate

入力チェックのJavaScriptを自動生成する入力フィールドを提供します。生成された入力フィールドは設定条件に従ってJavaScriptでチェックを行います。
このタグで生成できる入力フィールドは、以下の三種類です。
    ・英数字入力フィールド
    ・数値入力フィールド
    ・日付入力フィールド

このタグで生成された入力フィールドに対するチェックのタイミングは、デフォールトで入力フィールドのonBlur()時です。入力フィールドの所属するFormのonSubmit()時にも入力チェックを行いたい場合は、FormのonSubmit()に、"return validate_check_xxx(yyy)"のようなJavaScript式を埋め込む必要があります。（xxxの部分はこの入力フィールドの名称（name属性で指定された名称）であり、yyyの部分は、生成された入力フィールドを参照できるJavaScriptのオブジェクト名である）

このタグで生成された入力フィールドは、Service FrameworkまたはPresentation FrameworkのFormタグ内部でのネスト利用ができます。
Tagボディ | JSP
制約

・タグの所属するFormのonSubmitに、"return validate_check_xxx(yyy)"のようなJavaScript式を埋め込む必要があります。（xxxの部分はこの入力フィールドの名称（name属性で指定された名称）であり、yyyの部分は、生成された入力フィールドを参照できるJavaScriptのオブジェクト名である）
・Validateタグの利用するFormのサブミットボタンに対して、DblClickForbiddenを適用する場合、FormのonSubmitイベントが実行できなくなるため、Validateに対するチェックタイミングはonBlur()のみになります。
・NetScapeを利用する場合、Netscapeの仕様により、サブミット時、onSubmitイベントとコントローラのonBlurイベントがほぼ同時に発生するので、二重チェックを防ぐため、チェックタイミングはFormのonSubmitイベントのみになります。
属性 | 名前 | 必須 | 実行時評価
name | Yes | Yes
入力フィールドの名前。必須属性です。HTMLのinputタグのnameに相当します。同じページでこのタグを複数利用する場合は、この属性を必ず違う値に設定する必要があります。
callNull | No | Yes
該当入力フィールドにヌル（何も入力しない）を許可するかの設定。"true"に設定しますと、入力フィールドに何も設定しなくても警告が出力されません。"false"を設定すると、入力フィールドに何も設定しないと警告が出力されます。デフォルトでは"false"。
fgColor | No | Yes
入力フィールドの前景色。デフォルト値は"black"。
bgColor | No | Yes
入力フィールドの背景色を。デフォルト値は"white"。
errorBgColor | No | Yes
入力エラー時の入力フィールドの背景色。デフォルトは"red"。
errorFgColor | No | Yes
入力エラー時の入力フィールドの前景色。デフォルトは"white"。
errorMsg | No | Yes
入力エラーが発生した時にユーザへ提示するエラーメッセージ。
size | No | Yes
入力フィールドのサイズ。HTMLのinputタグのsizeに相当します。
type | Yes | Yes
入力フィールドの入力チェックのタイプ。値と入力チェックの対応は下記のようになります。必須属性です。

type | 入力チェックのタイプ
ascii | 英数字チェック
number | 数値チェック
date | 日付チェック

この属性を"ascii" に設定することで、入力できる内容は半角の英数字に限定します。それ以外の内容を入力しますと、エラーメッセージを出力します。
この属性を"number" に設定することで、入力できる内容は半角の数字（設定により、整数と小数を入力することは可能）に限定します。それ以外の内容を入力しますと、エラーメッセージを出力します。
この属性を"date" に設定することで、入力できる内容は指定フォーマットの半角の日付に限定します。それ以外の内容を入力しますと、エラーメッセージを出力します。
dateSeperator | No | Yes
日付チェックの場合の年月日を区切るマークを指定します。属性dateSeperatorを「/」に設定する場合、入力フィールドに20040415を入力するとエラーになり、2004/04/15を入力すると正しいです。デフォルトでは、年月日に区切り文字なし（20040415）。この属性はtypeが"date"に設定される場合のみ有効になります。
maxLength | No | Yes

入力フィールドに入力できる内容の最大の長さ。HTMLのinputのmaxLengthに相当します。
inte | No | Yes
入力できる整数の最大桁数。デフォルトは"9"。type属性が"number"の場合のみ有効になります。
frac | No | Yes
入力できる小数部分の最大桁数。デフォルトは"0"。type属性が"number"の場合のみ有効になります。
maxNum | No | Yes
入力できる数値の最大値。フィールドに入力された値がこの値より大きい場合にエラーメッセージを出力します。デフォルトは"999999999"です。type属性が"number"の場合のみ有効になります。
minNum | No | Yes
入力できる数値の最小値。フィールドに入力された値がこの値より小さい場合にエラーメッセージを出力します。デフォルトは"-999999999"です。type属性が"number"の場合のみ有効になります。
maxDate | No | Yes
入力できる日付の最大値。フィールドに入力された値がこの値より大きい場合にエラーメッセージを出力します。デフォルトは"20991231"です。type属性が"date"の場合のみ有効になります。
minDate | No | Yes
入力できる日付の最小値。フィールドに入力された値がこの値より小さい場合にエラーメッセージを出力します。デフォルトは"19000101"です。type属性が"date"の場合のみ有効になります。
styleClass | No | Yes
生成された入力フィールドに適用するCSSのクラス名。HTMLのinputのclass属性に相当します。
value | No | Yes
入力フィールドの初期値を設定する。minDateやmaxDateなどの属性で範囲を指定する場合は、この初期値は範囲内にある必要があります。
内部タグ | なし

使用例 | 入力フィールドを出力します
<Form name="form_ascii"
    onSubmit="return validate_check_input_ascii(
    this.input_ascii)" >
    <imtag:Validate name="input_ascii" type="ascii"
        size="20" maxLength="20" styleClass="ascii"/>
    <input type="submit" value="送信">
</Form>

<Form name="form_number"
    onsubmit="return validate_check_input_number(
    this.input_number)" >
    <imtag:Validate name="input_number" type="number"
        size="20" maxLength="20" styleClass="number"
        inte="5" frac="2" minNum="-100" maxNum="100"
        bgColor="lightgreen"
        errorMsg="-100から100までの数字を入力してください" />
    <input type="submit" value="送信">
</Form>

<Form name="form_date"
    onsubmit="return validate_check_input_date(
        this.input_date)" >
    <imtag:Validate name = "input_date" type="date"
        size="20" maxLength="20" dateSeperator="/"
        minDate="20000101" maxDate="20100101" styleClass="date"
        errorMsg="2000/01/01から2010/01/01までの日付を
        \"/\"区切りで入力してください。" />
    <input type="submit" value="送信">
</Form>

DblClickForbidden

HTMLのコントローラのボタン・サブミットボタン・イメージボタン・リンクの二次クリックを防止するためのタグです。
ボタン（またはサブミットボタン・イメージボタン・リンク）を一旦クリックすると、そのボタン（またはサブミットボタン）を無効状態にし、再度クリック不能にします。useTimer属性を"true"にすることで、timer属性で定義された時間を経つと、またクリックできるようになります。

このタグの内部は、Service FrameworkのSubmitタグまたはLinkタグを置くことができます。Service FrameworkのSmartLinkタグとのネストはできません。またPresentation Frameworkのタグとのネストはできません。
Tagボディ | JSP
制約 ・このタグの中には、必ずHTMLのbutton、submit、imageボタンまたはリンクがあります。
・ボタンにonClickイベントがある場合、onClickイベントの内容は必ず""で囲む必要があります。（例：onClick=”testFunction()”）。
・リンクの場合、リンクのhref属性は必ず""で囲む必要があります。
・HTMLの仕様により、サブミットボタンを使用せずにフォームをサブミットする場合、フォームのonSubmitイベントが実行できないので、フォームにonSubmitイベントを利用しないほうが望ましいです。
・リンクの場合、IEとNestcapeの仕様により、多少表示スタイルが違いますことにご了承ください。（機能的には影響ありません）
・このタグの内部に、SelectionSubmitterタグをネストすることはできません。
属性 | 名前 | 必須 | 実行時評価
type | Yes | Yes
ダブルクリック禁止対象のコントローラの種別。指定できる値は"button"（HTMLの<input type="button">）、"submit"（HTMLの<input type="submit">）、"image"（HTMLの<input type="image">）、"link"（HTMLの<a>）です。
useTimer | No | Yes
タイマー機能の利用フラグ。"true"にすることで、timer属性で定義された時間を経つと、またクリックできるようになります。デフォールト値は"false"。
timer | No | Yes
タイマー機能の利用する場合のダブルクリック禁止時間。msで指定してください。デフォールト値は"1000"ms、即ち1秒です。
内部タグ

Service FrameworkのLink、Submit。Presentation Frameworkのlink、submit。

リンクやボタン、サブミットボタンを生成できるタグ。

使用例 | ダブルクリックを禁止します。
ボタンの場合。一回クリックすると、ボタン無効にし、2秒経ったらまたクリックできるようになります。
<imtag:DblClickForbidden type="button"
    useTimer="true" timer="2000">
    <input type="button" value="ボタン２">
</imtag:DblClickForbidden>
Service FrameworkのLinkタグとネストして利用する例。
<imtag:DblClickForbidden type="link"
    useTimer="true" timer="2000">
    <imartj2ee:Link application="taglib" service="testform" target="_blank">
        <imartj2ee:Param name="param1" value="value1"/>
        <imartj2ee:Param name="param2" value="value2"/>
         リンク２
    </imartj2ee:Link>
</imtag:DblClickForbidden>

BackForbidden

ブラウザの戻るボタン機能を無効にするタグです。
戻るボタンを使って、特定の画面へ戻ることをできないようにするには、その画面でこのタグを利用することができます。
このタグは利用するJSP画面の任意の位置に置くことができます。

このボタンを利用した効果は、 利用画面の戻るボタン機能を禁止することではなくて、利用からからの遷移先画面での戻るボタン機能を禁止するのです。

このタグでは、以下のClientSideJavaScriptを使用します。
window.history.forward(1);
戻るボタン機能を禁止する画面において、戻るボタンが押された場合、前の画面にはもどりませんが、戻るボタンを押された画面はリロードされます。

例：
画面１でこのタグを利用します。画面１に画面２へのリンクがあります。リンクをクリックして画面２に遷移します。すると、画面２で戻るボタンを押しても、画面１へ戻ることはできなくなります。

このタグに属性はありません。

Tagボディ | JSP
制約 | 特になし
属性 | 名前 | 必須 | 実行時評価
使用例 | 戻るボタンを禁止します。
<imtag:BackForbidden/>

PopMenu

XMLファイルで定義されたメニュ項目をポップアップメニュの形式で表示します。
メニュ項目には、初期表示のメニュ主体部分とサブメニュに分かれています。 メニュ主体部分は画面に初期表示され、サブメニュは主体部分にマウスが当たった時にポップアップして表示されます。
サブメニュには、ポップアップ時の方向があります。属性のpositionでポップアップの方向をコントロールすることができます。
メニュ項目の定義ファイルXMLの形式は以下のようです。

<popmenu>            ルートノード

  <menu>             メインメニュ項目。

    id               メインメニュID。それぞれ違うIDを設定する必要があります。

    caption          メインメニュのキャプション。画面に表示します。

    icon             メニュ項目の前に表示するアイコンのURL。<Application Runtime>/doc/imart以下の相対パスを指定。

    link             メニュ項目クリック時に遷移するURL。一般画面に遷移する時に使います。

    target           リンクのターゲット。HTMLの<A>のtargetに相当します。

    application      Service Frameworkの画面に遷移する時のapplication ID。

    service          Service Frameworkの画面に遷移する時のservice ID。

    actionPoint      Presentation Frameworkの画面に遷移する時のactionPoint。

    startPoint       Presentation Frameworkの画面に遷移する時のstartPoint。

    width            該当メインメニュ項目の高さ。

    height           該当メインメニュ項目の幅。

    <param>          リンクのパラメータ。遷移先画面に渡します。

      name           パラメータ名。

      value          パラメータ値。

    <item>           サブメニュ項目

      id             サブメニュID。それぞれ違うIDを設定する必要があります。

      caption        サブメニュのキャプション。ポップアップ時に表示されます。

      icon           メニュ項目の前に表示するアイコンのURL。<Application Runtime>/doc/imart以下の相対パスを指定。

      link           メニュ項目クリック時に遷移するURL。一般画面に遷移する時に使います。

      target         リンクのターゲット。HTMLの<A>のtargetに相当します。

      application    ServiceFrameworkの画面に遷移する時のapplication ID。

      service        ServiceFrameworkの画面に遷移する時のservice ID。

      actionPoint    Presentation Frameworkの画面に遷移する時のactionPoint。

      startPoint       Presentation Frameworkの画面に遷移する時のstartPoint。

      width          サブメニュ項目の高さ。

      height         サブメニュ項目の幅。

      <param>        リンクのパラメータ。遷移先画面に渡します。

        name         パラメータ名。

        value        パラメータ値。
・ "<>"で囲まれたのはタグでその他は該当タグの属性です。
・ <menu>と<item>の属性の中に、linkとapplication/serviceとactionpointとstartPointの四つの中、一つしか指定できません。
・ actionPointの指定方法は Presentation FrameworkのLinkタグの指定方法と同様です。
・ startPointの指定方法は、im-J2EE Framework仕様書の9.9.7節を参考してください。
Tagボディ | JSP
制約

・XML定義ファイルの<menu>と<item>の属性の中に、linkとapplication/serviceとactionpointとstartPointの四つの中、一つしか指定できません。
・XML定義ファイルの各項目のid属性には、必ず違う値を指定してください。
・XML定義ファイルに、actionPointを利用してPrensetation Frameworkを呼び出す場合は、PopupMenu自体をPresentation Frameworkの中に配置しなければ いけません。
・PageBaseの画面を呼び出すことはできません。
・PopupMenuタグからService Frameworkを呼び出す場合は、事前にConnectServletが呼ばれている必要があります。
・PopupMenuタグからPresentationFrameworkを呼び出す場合は、事前にConnectServletが呼ばれている必要があります。
属性 | 名前 | 必須 | 実行時評価
xml | Yes | Yes
メニュ内容を定義するXMLファイルのパス。必須。<Application Runime>/WEB-INF/classes以下のパスを指定してください。V5では、PopMenuタグ用のxmlファイルをWEB-INF/classesの配下に保存することになります。
bgColor | No | Yes
メニュの背景色。デフォルト値は"#E0E0E0"。
fgColor | No | Yes
メニュの前景色。デフォルト値は"#0000FF"。
borderColor | No | Yes
メニュのボーダーの色。デフォルト値は"#000000"。
mouseOverBgColor | No | Yes
メニュにマウスが当たった時の背景色。デフォルト値は"#C0C0C0"。
mouseOverFgColor | No | Yes
メニュにマウスが当たった時の前景色。デフォルト値は"red"。
height | No | Yes
メニュ項目の高さ。デフォルト値は"22"。
width | No | Yes
メニュ項目の幅。デフォルト値は"110"。
position | No | Yes

メニュの画面にある位置。実際には、メニュ自体は画面のどこにでも配置することができますが、この属性を利用して、サブ項目をポップアップ時の方向をコントロールします。この属性に指定できる値は"left"、"right"、"top"、"bottom"の四つ。サブメニュのポップアップ方向は、この設定値の相対側になります。"left"を指定する場合、サブメニュは右方向へポップアップします。"bottom"を指定する場合、サブメニュは上方向にポップアップします。デフォルト値は"left"（右方向へポップアップ）。
fontFamily | No | Yes

メニュ文字のフォント。
showTime | No | Yes
サブメニュのポップまでの待ち時間。デフォルト値は"350"で、単位はミリ秒。
mainMenuFontSize | Yes
メニュ主体部の文字サイズ。デフォルト値は"9"、単位は"pt"。
mainMenuFontAlign | No | Yes
メニュ主体部の文字整列方法。デフォルト値は"left"。
subMenuFontSize | No | Yes
サブメニュの文字サイズ。デフォルト値は"9"、単位は"pt"。
subMenuFontAlign | No | Yes
サブメニュの文字整列方法。デフォルト値は"left"。
内部タグ | なし

使用例 | ポップアップメニュを生成します
<imtag:popmenu xml="popmenu.xml" fgColor="black" bgColor="whitesmoke"
    showTime="200" borderColor="#000000" mouseOverBgColor="#DDDDDD"
    mainMenuFontAlign="left" position="top"/>

XMLのソース例：

<?xml version="1.0" encoding="shift_jis"?>
<popmenu>
  <menu id="spread" caption="スプレッドシート">
    <item id="cell" caption="セルデータ選択"
      link="../spread/CellDataSelector.jsp" target="content"/>
    <item id="row" caption="行データ選択"
      link="../spread/RowDataSelector.jsp" target="content"/>
    <item id="column" caption="列データ選択"
      link="../spread/ColumnDataSelector.jsp" target="content"/>
    <item id="linehighlight" caption="行ハイライト"
      link="../spread/LineHighLight.jsp" target="content"/>
  </menu>
  <menu id="input" caption="入力制御">
    <item id="validate" caption="入力チェック"
      link="../input/Validate.jsp" target="content"
      icon="taglib/menu/images/icon5.gif"/>
    <item id="dbclick" caption="ダブルクリック防止"
      link="../input/DblClickForbidden.jsp" target="content"
      icon="taglib/menu/images/icon5.gif"/>
  </menu>
  <menu id="service" caption="サービスフレームワーク" width="160">
    <item id="maintenance" caption="商品情報メンテ"
      application="shopping" service="menu_to_seller_list" target="content"/>
    <item id="list" caption="商品一覧"
      application="shopping" service="menu_to_buyer_list" target="content"/>
  </menu>
  <menu id="presentation" caption="プレゼンテーションフレームワーク" width="250">
    <item id="user" caption="ユーザマスタ"
      startPoint="start-sample.presentation.config.sample_component_item-fc_item-sp_menu.presentation"
      target="content"/>
    <item id="template" caption="テンプレート"
      startPoint="start-sample.presentation.template.shopping.seller.wizard_flow_component-fc_wizard-sp_fm_wizard.presentation"
      target="content"/>
  </menu>
</popmenu>

TabPane

このタグはタブ（Tab）メニュのコンテナーです。
このタグは、Tabタグとネストする必要があります。
Tagボディ | JSP
制約 ・同じ画面で、複数のTabPaneを利用する場合は、name属性をそれぞれ違う値に設定する必要があります。
・クライアント側のブラウザーがIEである場合、TabPaneタグをHTMLのTableにネストする時は、TabPaneのwidth属性を指定する必要があります。
属性 | 名前 | 必須 | 実行時評価
name | Yes | Yes
タブのコンテナーであるTabPaneの名前。一つの画面に複数のTabPaneがある場合は、それぞれ違う値を設定してください。
width | No | Yes
タブペインの。未指定の場合は、タブの名前とタブの内容により、自動調整します。明示的に指定することが望ましいです。
height | No | Yes
タブペインの高さ。未指定の場合は、デフォールト値を利用します。デフォールト値は"300"。
内部タグ

Tab

メニュ項目であるTab。
使用例 | タブメニュを生成します。
<imtag:TabPane name="mytabpane" height="400" width="500">
  <imtag:Tab text="セルデータ選択">
    タブコンテント１.
  </imtag:Tab>
  <imtag:Tab text="行データ選択" selected="true">
    タブコンテント２.
  </imtag:Tab>
  <imtag:Tab text="列データ選択">
    タブコンテント３.
  </imtag:Tab>
  <imtag:Tab text="ソース">
    タブコンテント４.
  </imtag:Tab>
</imtag:TabPane>

Tab

TabPaneの上で、各Tabを生成します。
このタグはTabPaneとネストする必要があります。このタグは単独で使うことができません。

このタグのBODY部分に、任意の内容を埋め込むことができます。
JSPのincludeタグで、外部JSPを含めることもできます。ただし、インクルードされたJSPのデータとこのタグの呼び出し元画面のデータの間に、矛盾を発生することはできません。

複数のタブのある場合、属性selectedを"true"にすることで、該当Tabが初期選択になります。
Tagボディ | JSP
制約

・ラベルのフォントサイズを指定することはできますが、あまり字が大きい過ぎますと、Tabの画像の表示がずれる可能性があります。
・一つのTabPaneに、selected属性を"true"に設定できるTabは一個しかありません。
・TabのBODY部分に、必ずなんらかの内容を書き込んでください。FrameworkをWebSphereやWebLogic上で動く場合、BODYにデータがなければ、Tab自体を表示することができません。（ベースモジュールの場合は問題ありません）
属性 | 名前 | 必須 | 実行時評価
text | Yes | Yes
タブのラベルの文字列。複数のTabのある場合、それぞれ違う値を設定する必要があります。必須。
selected | No | Yes

該当タブの初期選定フラグ。"true""false"で指定可能。デフォルトは"false"。"true"を指定する場合、画面初期表示時、該当Tabが選択状態で表示されます。同じTabPaneの中に、selected属性を"true"にするTabは一つしかないことにご注意ください。
font | No | Yes
ラベル文字のフォントスタイル。CSSのfont属性に相当します。デフォルト値は"9pt Tahoma"。
color | No | Yes
ラベル文字の色。デフォルト値は"black"。
使用例 | タブメニュを生成します。
JSPのincludeを利用する場合の例：
<imtag:TabPane name="mytabpane" height="400" width="500">
  <imtag:Tab text="セルデータ選択">
    <%@include file = "../spread/CellDataSelector.jsp"%>
  </imtag:Tab>
  <imtag:Tab text="行データ選択" selected="true">
    <%@include file = "../spread/RowDataSelector.jsp"%>
  </imtag:Tab>
  <imtag:Tab text="列データ選択">
    <%@include file = "../spread/ColumnDataSelector.jsp"%>
  </imtag:Tab>
</imtag:TabPane>

Push

送信側で入力されたメッセージをクライアント側にプッシュする部品です。
受信側のJSPで、このタグを利用することで、画面をリロードしなくても、動的に送信側のメッセージを取得し表示することができます。

属性clientが"send"である場合に、画面にプッシュメッセージ入力用のフォームを生成します。ユーザはこのタグの中で、入力フィールドをネストして書くことができます。
属性clientが"recv"である場合に、PushMessageタグと連携してプッシュメッセージを受け取って表示することができます。受信画面で、プッシュメッセージの受信用タグ以外に内容がある場合は、該当画面のPushタグをHTMLのBODY部全体を囲める必要があります。受信画面は、timeoutの設定値の時間内に、リアルタイムにプッシュされたメッセージを表示することができます。この時間を経つと、画面をリロードしない限り、新しくプッシュされたデータは表示されなくなります。

このタグは、受信側はtimeoutの設定値の時間内で、常にApplicationRuntimeの一つのスレッドを利用するため、この値がApplicationRuntimeのthreads設定値(同時実行スレッド数)を超えることはできません。例えば、ApplicationRuntimeの同時実行スレッド数が１０で、このタグの受信側のmaxConnectionが９の場合、受信画面は９つまで開けます。しかし、その他のリクエストは１つしか同時に処理されなくなります。プッシュ受信側のクライアントの利用者数とサーバのスレッド数の関係をよく考慮した上、適切に設定してください。

Tagボディ | JSP
制約

・受信側の画面（属性clientが"recv"に設定する場合）に、Pushタグを画面全体に一つしか放置できません。
・送信側の画面（属性clientが"send"に設定する場合）に、タグ内部の入力フィールド（フォームのコントローラであれば何でも可）は最大一つ放置することができる。複数ある場合は、最後のコントローラの値をプッシュの内容としてサーバに送信します。
・送信と受信のタグを一つの画面に置くことはできません。
・受信側の画面は、サーバ側でHTMLを再生成しますので、すべての画面スタイルをCSSにまとめる必要があります。画面要素にスタイルを設定したい場合は、各HTMLのclass属性を利用して設定してください。
・受信側の画面で、プッシュメッセージの受信用タグ以外に内容がある場合は、該当画面のPushタグをHTMLのBODY部全体を囲める必要があります。
・受信側の画面のcharsetとCSSの指定は、このタグのcharsetとcsshref属性を利用する必要があります。それに、csshref属性に指定するCSSファイルのパスは絶対パスを利用してください。

１つのクライアントマシンで複数のブラウザを利用して受信画面を開くことはできません。
属性 | 名前 | 必須 | 実行時評価
client | Yes | Yes

送信側か、受信側の指定。必須。"send"を指定する場合は送信側になり、送信用のフォームを生成します。"recv"を指定する場合は、受信側になり、サブタグのPushMessageと一緒にプッシュされたメッセージを表示します。
subject | Yes | Yes
プッシュメッセージのID。送信側は、このIDでメッセージをサーバに送信し保存します。受信側では、このIDを通してプッシュされたメッセージを取得します。
alertMsg | No | Yes
送信側でプッシュ対象内容をサブミット後の確認メッセージの出力フラグ。"true"に設定することで、確認メッセージを出力します。デフォルトは"false"。clientが"send"の場合のみ有効になります。
charset | No | Yes
受信側の画面のヘッダー部のMETAデータに出力する画面エンコーディング。client属性が"recv"の場合のみ有効になります。
csshref | No | Yes
受信側の画面のヘッダー部のファイル参照URL。client属性が"recv"の場合のみ有効になります。
timeout | No | Yes
受信側の画面の最大受信可能時間。受信側の画面は、この時間内でサーバからプッシュされたメッセージをリアルタイムに表示します。この時間を経つと、画面をリロードしない限り、新しくプッシュされたメッセージは表示されなくなります。デフォルトでは、１０分間を指定しています。
maxConnection | No | Yes
プッシュメッセージを受信できるクライアント（セッション）数の最大値。デフォルト値は１０。この値を超えるリクエストが来た場合は、エラーメッセージを表示します。受信側はtimeoutの設定値の時間内で、常にサーバの一つのスレッドを利用しますため、この値がApplicationRuntimeのthreads設定値(同時実行スレッド数)を超えることはできません。例えば、ApplicationRuntimeの同時実行スレッド数が１０で、このタグの受信側のmaxConnectionが９の場合、受信画面は９つまで開けます。しかし、その他のリクエストは１つしか同時に処理されなくなります。プッシュ受信側のクライアントの利用者数とサーバのスレッド数の関係をよく考慮した上、適切に設定してください。
内部タグ | PushMessage

プッシュメッセージ出力用

使用例 | メッセージのプッシュ機能
送信側の呼び出し
<imart:Push client="send" subject="notice" alertMsg="true">
    <input type ="text" name="test" value=""><br>
    <input type="submit"><input type="reset"><br>
</imart:Push>

受信側の呼び出し
<imart:Push client="recv" subject="notice"
    charset="shift_jis" csshref="/imart/css/taglib.css" >
    <imart:PushMessage style="textarea" cols="50" rows="10"
        styleClass="testcss"/><BR>
    <imart:PushMessage style="text" styleClass="testcss"/><BR>
    <imart:PushMessage style="table" width="100%" styleClass="testcss" />
</imart:Push>

PushMessage

プッシュされたメッセージを受信し表示するためのタグです。
このタグはPushタグの内部でしか利用できません。

このタグは指定のスタイルでプッシュされたデータを表示します。
Tagボディ | JSP
制約 ・Pushタグの内部でしか利用できません。
・送信と受信のタグを一つの画面に置くことはできません。
・styleがtableに指定する場合、必ず該当タグのstyleClass属性を指定して、CSSのクラスでテーブルの背景色を指定してください。
・styleがtableに指定する場合、画面表示文字が重なったりする場合は、画面をリロードしてください。
属性 | 名前 | 必須 | 実行時評価
style | Yes | Yes

プッシュされたデータの表示スタイル。"text"（テキストフィールド）、"textarea"（テキストエリア）、"table"（テーブル）の一つを指定することができます。必須。
width | No | Yes
受信側のスタイルが"table"の場合のテーブルの幅。HTMLのTABLEのwidthに相当します。デフォルトでは"100%"。styleが"table"である場合のみ有効になります。
rows | No | Yes
受信側のスタイルが"textarea"の場合のtextareaの行数。HTMLのTEXTAREAのrowsに相当します。styleが"textarea"である場合のみ有効になります。
cols | No | Yes
受信側のスタイルが"textarea"の場合のtextareaのカラム数。HTMLのTEXTAREAのcolsに相当します。styleが"textarea"である場合のみ有効になります。
styleClass | No | Yes
出力対象に適用するCSSのクラス名。
内部タグ

なし

使用例 | 受信されたプッシュ内容を出力します。
<imart:Push client="recv" subject="notice"
    charset="shift_jis" csshref="/imart/css/taglib.css" >
    <imart:PushMessage style="textarea" cols="50" rows="10"
        styleClass="testcss"/><BR>
    <imart:PushMessage style="text" styleClass="testcss"/><BR>
    <imart:PushMessage style="table" width="100%"
        styleClass="testcss" />
</imart:Push>


intra-mart[Server side JavaScript BASE MODULE Documentation.[J2EE framework tag library]]

i ntra-mart The Power for Enterprise Web Solution

intra-mart タグライブラリ (ユーティリティ) 仕様

注意事項

このページでは、JSPで利用するタグライブラリに関して、プログラム・インターフェースの詳細仕様を記載しています。

intra-mart Tag Library (Utility) 仕様

1. | タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。
2. | タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。
3. | タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。
4. | タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。
5. | 組み合わせ可能なタグ一覧

使用方法

intra-mart J2EE フレームワーク タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@taglib uri="http://www.intra-mart.co.jp/taglib/util" prefix="imtag" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/util" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "imtag" として説明します)

< サンプル >

<%@taglib uri="http://www.intra-mart.co.jp/taglib/util" prefix="imtag" %>
<%@ page contentType="text/html; charset=Shift_JIS" pageEncoding="Windows-31J" %>
<html>
<head>
<title>PopMenu</title>
<LINK REL="stylesheet" TYPE="text/css" HREF="../../css/taglib.css" TITLE="default">
<body>

<p>
<imtag:popmenu xml="PopMenu.xml" fgColor="black" bgColor="whitesmoke" showTime="200" borderColor="white" mouseOverBgColor="#DDDDDD" mainMenuFontAlign="left" position="bottom"/>

<a href="PopMenu.xml" target="content">XML Source</a>
</p>
</body>
</html>

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[intra-mart Documentation.[Tooles[External products connector]]]

i ntra-mart The Power for Enterprise Web Solution
外部ソフトウェア接続モジュール
[連携 API Connector]

概要

intra-mart サーバ以外の Java ベースアプリケーションから intra-mart に対してアクセスするためのコネクタです（Java 以外のプログラムから Java 環境を呼び出して利用することも可能です）。

このコネクタを利用することにより、任意の Java 環境から intra-mart Application Runtime における任意の処理を実行することが可能になります。

用途

コネクタは、Java クラスとして提供されますので、Java のインターフェースを利用できる環境であれば、どこからでも intra-mart システムと連携することが可能です。例えば、このコネクタを利用することにより、下記のようなことを実現することができます。

  • 他の製品環境からユーザ情報を intra-mart システムに同期させる場合に、このコネクタを利用してユーザデータを転送しユーザ情報をリアルタイムに同期させることができます。
  • ポータルサーバ製品と連携して、ポータル画面に intra-mart で実行した業務画面を表示させることができます。
  • 他のシステムに対して、Storage Service に保管されているファイルを転送することにより、システム間におけるドキュメントの共有をすることができます。

この他にも、工夫次第で様々な場面において、ダイナミックかつリアルタイムに複数のシステムと intra-mart システムを連携させることが可能です。

構成

外部ソフトウェア接続モジュールのインターフェースは、Java のクラスです。したがって、連携するアプリケーションは、Java インターフェースを利用できることが前提となります。また、Java インターフェースを利用することから、このモジュールが動作する環境には、Java-VM が必要になります。

連携用のコネクタクラスは、ネットワークを介して Application Runtime と連動します。したがって、ネットワークが利用可能な環境であることも前提条件となります。ただし、API は URL によってネットワーク通信を制御するため、開発者がネットワークを直接意識することはありません。

コネクタは Application Runtime に対して、HTTP 接続を行います。ネットワークは、API に指定された URL により解決されますが、この URL は intra-mart システムの運用形態により以下のような注意が必要です。

  • intra-mart システムがスタンドアロンで運用されている場合は、そのスタンドアロンサーバへの URL を指定します。
  • 分散サーバ型のシステム形態で intra-mart を運用している場合には、Web-Server Connector への接続 URL を指定します(URL の接続先として Application Runtime のアドレスおよびサーバポートを指定しても連携させることはできません)。

連携用に指定する URL には、専用のサーブレットパス(/imart/HTTPActionEventListener(標準))を指定します。通常のサーブレットパスである imart/intramart(標準)を指定しても連携させることはできません。

外部ソフトウェア接続モジュールは、大きく２つの種類に大別できます。１つはサーバ側ロジックで、もう１つはクライアント側ロジックです。
サーバ側ロジックは、サーバの Web-Application 領域(通常は WEB-INF 内)にプログラムを配置します。実行は、サーバ環境内です。主にビジネスロジックを記述する事になります。
クライアント側ロジックは、Application Runtime を利用する Java 実行環境内で実行します。プログラムの配置は、呼び出し側環境になります。

クラスの構成と配置

外部ソフトウェア接続モジュールを利用したクラスのコンパイルおよび動作には、以下のクラスアーカイブが必要になります。

  • imaca_client.jar (接続するクライアント用)
  • imaca_provider.jar (サーバ側ロジック用)

サーバ側ロジックはサーバで動作するため、上記アーカイブと共にサーバ側に配置します。配置先ディレクトリは、doc/imart/WEB-INF/ です（上記クラスアーカイブは、doc/imart/WEB-INF/lib にあります）。

クライアント側ロジックは、連携するアプリケーションの動作環境に上記クラスアーカイブと共に配置します。

動作に必要な環境構築

下記の手順で、連携に必要な環境を作成してください。

  1. コネクタの含まれるクラスアーカイブ・ファイル imaca_client.jar を連携させるアプリケーションが動作する環境にコピーしてください(jar ファイルは、CD-ROM 内にあります)。
  2. コピーしたアーカイブファイルの imaca_client.jar に対してクラスパスを設定してください。

これで準備は完了です。アプリケーションを動作させて intra-mart と連動させてみてください。うまく連動できない場合は、クラスパスの設定をもう一度確認してください。また、バージョンの異なる jar ファイルの場合、ファイル名が同じでも連携動作させることができませんので、パッチ等を適用した場合やリビジョンアップをした場合などは、十分注意をしてください。なお、intra-mart サーバに対してパッチを適用したときなどは、パッチに含まれる imaca_client.jar を上書きコピーしてご利用ください。

動作概要

指定された URL により HTTP 接続をして任意のアプリケーションからコネクタを介して Application Runtime で指定プログラムを実行します。

Application Runtime で実行するプログラムは、Java で記述してください。なお、Application Runtime で実行されるプログラムでは、intra-mart が提供している J2EE ベース開発モデル用の API をすべて利用することができます。これらの API を利用することにより、任意のページベース開発モデルのプログラム(Function Container に限ります)を実行することもできます。

このコネクタを利用してプログラムを実行した場合、通常の Web からの接続とは異なりますので、Application Runtime で実行されるプログラムにおいて intra-mart が提供している API の一部が利用できません。API の利用制限に関しては、バッチプログラムの制限に準じます。

API

コネクタクラスは、下記のパッケージに含まれています。

jp.co.intra_mart.foundation.service.client.application

サーバ側のインターフェースは、下記のパッケージに含まれています。

jp.co.intra_mart.foundation.service.provider.application

API の詳細に関しては、『J2EEベース開発モデル』の アプリケーション共通モジュール を参照してください。

サンプルプログラム

この機能を利用したサンプルプログラムが用意されています。

ソースファイルは、インストールCDの intramart5/src/src_sample.zip に格納されています。 この機能を利用したサンプルプログラムのパッケージは jp.co.intra_mart.sample.service.client.application となっています。この中のソースを開き、ソース中に記載されているコメントを良くご覧ください。
サンプルは、以下に列挙するものが用意されています。

  • アカウント登録プログラム
  • ページベース開発プログラムへリンクするＵＲＬ作成プログラム (*)
  • サービスフレームワークへリンクするＵＲＬ作成プログラム (*)
  • プレゼンテーションフレームワークへリンクするＵＲＬ作成、および
    プレゼンテーションフレームワークで作成された画面のソース(HTML)取得プログラム (*)

    (* = ポータルサーバ製品との連携等に利用可能)

なお、コンパイルおよび実行には、doc/imart/WEB-INF/lib/imaca_client.jar , doc/imart/WEB-INF/lib/imaca_provider.jar および JSDK(Java Servlet Development Kit)が必要です。コンパイルや実行の際には、これらをクラスパスに定義してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[intra-mart Documentation.[Tooles[External products connector]]]

i ntra-mart The Power for Enterprise Web Solution
外部ソフトウェア接続モジュール
[連携 API Connector]
Version 4.0.x, 4.1.x, 4.2.x 互換

概要

intra-mart サーバ以外の Java ベースアプリケーションから intra-mart に対してアクセスするためのコネクタです（Java 以外のプログラムから Java 環境を呼び出して利用することも可能です）。

このコネクタを利用することにより、任意の Java 環境から intra-mart Application Runtime における任意の処理を実行することが可能になります。

用途

コネクタは、Java クラスとして提供されますので、Java のインターフェースを利用できる環境であれば、どこからでも intra-mart システムと連携することが可能です。例えば、このコネクタを利用することにより、下記のようなことを実現することができます。

  • 他の製品環境からユーザ情報を intra-mart システムに同期させる場合に、このコネクタを利用してユーザデータを転送しユーザ情報をリアルタイムに同期させることができます。
  • ポータルサーバ製品と連携して、ポータル画面に intra-mart で実行した業務画面を表示させることができます。
  • 他のシステムに対して、Storage Service に保管されているファイルを転送することにより、システム間におけるドキュメントの共有をすることができます。

この他にも、工夫次第で様々な場面において、ダイナミックかつリアルタイムに複数のシステムと intra-mart システムを連携させることが可能です。

構成

外部連携モジュールのインターフェースは、Java のクラスです。したがって、連携するアプリケーションは、Java インターフェースを利用できることが前提となります。また、Java インターフェースを利用することから、このモジュールが動作する環境には、Java-VM が必要になります。

連携用のコネクタクラスは、ネットワークを介して Application Runtime と連動します。したがって、ネットワークが利用可能な環境であることも前提条件となります。ただし、API は URL によってネットワーク通信を制御するため、開発者がネットワークを直接意識することはありません。

コネクタは Application Runtime に対して、HTTP 接続を行います。ネットワークは、API に指定された URL により解決されますが、この URL は intra-mart システムの運用形態により以下のような注意が必要です。

  • intra-mart システムがスタンドアロンで運用されている場合は、そのスタンドアロンサーバへの URL を指定します。
  • 分散サーバ型のシステム形態で intra-mart を運用している場合には、Web-Server Connector への接続 URL を指定します(URL の接続先として Application Runtime のアドレスおよびサーバポートを指定しても連携させることはできません)。

連携用に指定する URL には、専用のサーブレットパス(/imart/BatchRuntimeController(標準))を指定します。通常のサーブレットパスである imart/intramart(標準)を指定しても連携させることはできません。

動作に必要な環境構築

下記の手順で、連携に必要な環境を作成してください。

  1. コネクタの含まれるクラスアーカイブ・ファイル intramart.jar および basemodule.jar を連携させるアプリケーションが動作する環境にコピーしてください(jar ファイルは、CD-ROM 内にあります)。
  2. コピーしたアーカイブファイルの intramart.jar に対してクラスパスを設定してください。

これで準備は完了です。アプリケーションを動作させて intra-mart と連動させてみてください。うまく連動できない場合は、クラスパスの設定をもう一度確認してください。また、バージョンの異なる jar ファイルの場合、ファイル名が同じでも連携動作させることができませんので、パッチ等を適用した場合やリビジョンアップをした場合などは、十分注意をしてください。なお、intra-mart サーバに対してパッチを適用したときなどは、パッチに含まれる intramart.jar および basemodule.jar を上書きコピーしてご利用ください。

動作概要

指定された URL により HTTP 接続をして任意のアプリケーションからコネクタを介して Application Runtime で指定プログラムを実行します。

Application Runtime で実行するプログラムは、Java で記述してください。なお、Application Runtime で実行されるプログラムでは、intra-mart が提供している J2EE ベース開発モデル用の API をすべて利用することができます。これらの API を利用することにより、任意のページベース開発モデルのプログラム(Function Container に限ります)を実行することもできます。

このコネクタを利用してプログラムを実行した場合、通常の Web からの接続とは異なりますので、Application Runtime で実行されるプログラムにおいて intra-mart が提供している API の一部が利用できません。API の利用制限に関しては、バッチプログラムの制限に準じます。

API

コネクタクラスは、下記のパッケージに含まれています。

jp.co.intra_mart.foundation.service.client.application

API の詳細に関しては、『J2EEベース開発モデル』の アプリケーション共通モジュール を参照してください。

サンプルプログラム

この機能を利用したサンプルプログラムが用意されています。

ソースファイルは、Application-Runtimeをインストールしたディレクトリ直下の source/java/ ディレクトリに格納されています。 この機能を利用したサンプルプログラムのパッケージは jp.co.intra_mart.sample.service.client.application となっています。この中のソースを開き、ソース中に記載されているコメントを良くご覧ください。
サンプルは、以下の２種類が用意されています。

  • アカウント登録プログラム
  • ページソース作成プログラム(ポータルサーバ製品との連携等に利用可能)

なお、コンパイルおよび実行には、bin/intramart.jar および JSDK(Java Servlet Development Kit)が必要です。コンパイルや実行の際には、これらをクラスパスに定義してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[intra-mart Documentation.[Tooles[External products connector]]]

i ntra-mart The Power for Enterprise Web Solution
外部ソフトウェア接続モジュール

概要

intra-mart サーバ以外のソフトウェアから intra-mart に対してアクセスするためのモジュールです。

このモジュールを利用することにより、プログラムから intra-mart Application Runtime における任意の処理を実行することが可能になります。なお、このモジュールには２つの方法が用意されています。環境や目的に応じて使い分けてください。

用途

このモジュールにより、どこからでも intra-mart システムと連携することが可能です。例えば、このモジュールを利用することにより、下記のようなことを実現することができます。

  • 他の製品環境とあらゆる情報を intra-mart システムに同期させることができます。
  • intra-mart システムから他の製品環境に対して様々な情報を提供することができます。
  • ポータルサーバ製品と連携して、ポータル画面に intra-mart で実行した業務画面を表示させることができます。

この他にも、工夫次第で様々な場面において、ダイナミックかつリアルタイムに複数のシステムと intra-mart システムを連携させることが可能です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


外部ソフトウェア接続モジュール
連携 API コネクタ Web サービス


intra-mart[Server side JavaScript intra-mart Documentation.[Batch]]

i ntra-mart The Power for Enterprise Web Solution
アクセスセキュリティモジュール

機能概要

ユーザやロールなどのログインセキュリティ情報を操作します。

インポート／エクスポート

セキュリティに関するデータを指定のフォーマット形式のファイルからインポート／エクスポートすることができます。
この操作はシステム設定画面、及びプログラム・インターフェースから行うことができます。
画面から行う方法については、マニュアルを参照して下さい。
プログラム・インターフェースの詳細に関しては、パッケージ jp.co.intra_mart.foundation.security をご参照下さい。

各インポート・エクスポートデータのフォーマットは、こちらを参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side Java intra-mart Documentation.[Batch]]

i ntra-mart The Power for Enterprise Web Solution
バッチ管理モジュール

プログラムの作成

プログラムファイルを Java 言語で作成します。
作成したプログラムはコンパイルをして、Application Runtime のクラスパスに設定されているディレクトリ内に保存します。なお、バッチプログラムは、サーブレット環境で実行されますので、サーブレットから参照できるようにクラスを保存してください(バッチプログラムを実行するサーブレットは、doc/imart/WEB-INF/lib/intramart.jarの中にあります)。

バッチ起動されるクラスには、下記のようなプロパティ情報がメソッド引数として渡されます。

引数 | （プロパティ情報）
├ | group | バッチ設定グループ名 (ログイングループＩＤ）
└ | name | バッチ名称

バッチ用プログラムに関しては、jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent クラスのＡＰＩ仕様を参照して下さい。

システム構成

バッチ機能を利用するためには、すべてのサービスをそれぞれインストールし、正常に動作する必要があります(Schedule Service から Application Runtime に接続できるように適切に接続ＵＲＬを設定してください。)。

バッチの登録と設定

バッチプログラムの登録と起動時間の設定は、i ntra-mart 起動後の『システム設定』-『バッチ』メニュー内で行います。
プログラム種別は、必ず『Java Class』を選択して下さい。

バッチ設定では、バッチ登録と運用可否設定があります。登録したバッチプログラムは、『有効』設定にしておかないと実行されません。
また、バッチサーバの実行状態を『運用中』にしなければバッチプログラムはロードされません。

設定画面の操作に関しては、マニュアルをご参照下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[File Download]]

i ntra-mart The Power for Enterprise Web Solution

ファイル・ダウンロード
(J2EEベース開発モデル)

サンプルプログラム
filebox.jsp
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ page import="jp.co.intra_mart.foundation.service.client.file.*" %>
<%@ page import="java.util.*" %>
<%
NetworkFile file = new NetworkFile("filebox/");
if(!file.isDirectory()){
file.makeDirectories();
}
Collection list = file.files();
Iterator view = list.iterator();
String file_name;
%>
<HTML>
<HEAD>
<TITLE>File Center</TITLE>
</HEAD>
<BODY bgcolor="WhiteSmoke">
<H2>File List</H2>
<TABLE border>
<TR>
<TH>File Name</TH>
<TD><BR></TD>
</TR>
<%
while(view.hasNext()){
file_name = (String)view.next();
%>
<TR>
<TD><%= file_name %></TD>
<TD><A href="download.jsp?file_name=<%= file_name %>">download</A></TD>
</TR>
<%
}
%>
</TABLE>
</BODY>
</HTML>

download.jsp
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ page import="jp.co.intra_mart.foundation.service.client.file.*" %>
<%
String file_name = request.getParameter("file_name");
NetworkFile file = new NetworkFile("filebox/" + file_name);
OutputStream os = response.getOutputStream();
response.setContentType("application/octet-stream");
response.setHeader("Content-Disposition", "attachment; filename=" + file_name);
os.write(file.load());
%>
</TD>
</TR>
</TABLE>

※詳細についてはフレームワークに同梱のサンプルを参照してください。
メニューパスは、[サンプル]-[J2EE開発モデル]-[チュートリアル]-[ファイル操作]となります。

また、上記のサンプル以外にjp.co.intra_mart.foundation.http.FileSender APIを利用することも可能です。


intra-mart[Server side JavaScript intra-mart Documentation.[File Upload]]

i ntra-mart The Power for Enterprise Web Solution

ファイル・アップロード
(J2EEベース開発モデル)

サンプルプログラム
filebox.jsp
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ page import="jp.co.intra_mart.foundation.service.client.file.*" %>
<%@ page import="java.util.*" %>
<%
%>
<HTML>
<HEAD>
<TITLE>File Center</TITLE>
</HEAD>
<BODY bgcolor="WhiteSmoke">
<H2>Upload</H2>
<FORM action="upload.jsp" method="POST" enctype="multipart/form-data">
<INPUT type="file" name="local_file">
<INPUT type="submit" value=" send ">
</FORM>
</TABLE>
</BODY>
</HTML>

upload.jsp
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ page import="jp.co.intra_mart.foundation.http.*" %>
<%@ page import="jp.co.intra_mart.foundation.service.client.file.*" %>
<%
String msg = new String("Upload succeeded.");
try{
MultipartFormData data = new MultipartFormData(request);
MultipartFormData.Entity entity = data.getEntity("local_file");
String header = entity.getHeader("Content-Disposition");
String file_name = header.substring(header.lastIndexOf("\\") + 1, header.length() - 1);
NetworkFile file = new NetworkFile("filebox/" + file_name);
file.save(entity.getBytes());
}catch(Exception e){
msg = "Upload failed.";
}
%>
<HTML>
<HEAD>
<TITLE>File Uploaded.</TITLE>
</HEAD>
<BODY>
<A href="filebox.jsp">return</A>
</BODY>
</HTML>

※詳細についてはフレームワークに同梱のサンプルを参照してください。
メニューパスは、[サンプル]-[J2EE開発モデル]-[チュートリアル]-[ファイル操作]となります。

また、上記のサンプルで使用したMultipartFormData()については、
jp.co.intra_mart.foundation.http.MultipartFormDataに詳細説明があります。


intra-mart[Server side JavaScript BASE MODULE Documentation.[Mail]]

i ntra-mart The Power for Enterprise Web Solution
メール連携モジュール(J2EEベース開発モデル)

準備(前提条件)

Application Runtime からネットワーク接続可能なマシン上にSMTPサーバ(RFC821 に準拠しているソフトウェア)を立ちあげて下さい。

Application Runtime の初期設定ファイル([install_directory]/conf/imart.xml)において、稼働中のSMTPサーバのアドレスおよびポートを指定した後に、i ntra-mart を起動して下さい。

メール連携モジュールを使用するには以下のライブラリが必要です。別途ダウンロードしてください。

  • JavaMail API 1.2
  • JavaBeans Activation Framework 1.0.2

    i ntra-mart BaseModuleの場合はダウンロードしたアーカイブを解凍し、全てのjarファイルを[install_directory]/lib/に配置してください。
    i ntra-mart Frameworkの場合は解凍したjarファイルをウェブアプリケーションサーバのクラスパスに追加してください。

    ＡＰＩ

    JavaMailSender を利用します。

    詳細なプログラム・インターフェースに関しては、アプリケーション共通モジュール を参照下さい。

    例

    JavaMailSender API を利用してメール送信プログラムを記述します。

    以下に、aaa@example.com, bbb@example.com, および ccc@example.com に対して「test mail」という表題の「send mail」という内容のメールを送信する例を示します。
    送信者アドレスは zzz@smtp.srv とします。

    <%@ page contentType="text/html; charset=Shift_JIS" pageEncoding="Windows-31J" %>
<%@ page import="jp.co.intra_mart.foundation.mail.MailSender" %>
<%@ page import="jp.co.intra_mart.foundation.mail.javamail.JavaMailSender" %>
<%@ page import="jp.co.intra_mart.foundation.mail.javamail.StandardMail" %>
<%@ page import="jp.co.intra_mart.foundation.service.client.file.NetworkFile" %>
<%
        boolean success = true;
        try {
            // 送信メールオブジェクトを生成
            StandardMail mail = new StandardMail();
            mail.addTo("aaa@example.com");
            mail.addTo("bbb@example.com");
            mail.addTo("ccc@example.com");
            mail.setFrom("zzz@example.com");
            mail.setSubject("test mail");
            mail.setText("send mail");

            // Storage Serviceから取得したファイルを添付
            NetworkFile file = new NetworkFile("attach.txt");
            mail.addAttachment("attach.txt", new String(file.load(), "8859_1"));

            // メール送信
            MailSender sender = new JavaMailSender(mail);
            sender.send();
        } catch (Exception e) {
            success = false;
            e.printStackTrace();
        }
%>
<HTML>
    <BODY>
    <% if (success) { %>
        <H2>Scucess<H2>
    <% } else { %>
        <H2>Failed<H2>
    <% } %>
    </BODY>
</HTML>

    • Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2003 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Application Common Master Table]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart アプリケーション共通マスタ API 仕様

アプリケーション共通マスタ表は、intra-mart 上で動作するすべてのアプリケーション・プログラムから共通に利用するためのデータベース・アーキテクチャです。
データの参照に関しては、各プログラムから自由に行っても構いませんが、規定の方法以外でのデータ更新を行った場合、他のアプリケーションが正常に動作しなくなることがあります。

詳細はアプリケーション共通マスタ説明資料（PDF）を参照して下さい。

  • ユーザの登録・更新・削除

    • ユーザ（ログインアカウント、ユーザプロファイル）の登録・更新・削除は、 グループ管理者でログインし、メニューの[ログイングループ管理]-[アカウント設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、
    ログインアカウントは    Server Managerルート/specification/dtd/account_5_0.dtd を参照して下さい。
    ユーザプロファイルはServer Managerルート/specification/dtd/profile-data_5_0.dtd を参照して下さい。

    プログラムインターフェースとしては、ログインアカウントに対しては jp.co.intra_mart.foundation.security.account.AccountMangerクラスを使用して下さい。

    ユーザプロファイルに対しては、jp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerクラスを使用して下さい。

  • 会社・組織の登録・更新・削除

    • 会社・組織の登録・更新・削除は、グループ管理者でログインし メニューの[アプリケーション共通マスタ管理用フォルダ]-[組織設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、Server Managerルート/specification/dtd/company-data_5_0.dtd およびcompany-post-data_5_0.dtdを参照して下さい。

    プログラムインターフェースとしては、 jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManagerクラスを使用して下さい。

  • パブリックグループの登録・更新・削除

    • パブリックグループの登録・更新・削除は、グループ管理者でログインし メニューの[アプリケーション共通マスタ管理用フォルダ]-[パブリックグループ設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、Server Managerルート/specification/dtd/public-group-data_5_0.dtd を参照して下さい。

    プログラムインターフェースとしては、 jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManagerクラスを使用して下さい。

  • プライベートグループの登録・更新・削除

    • プライベートグループの登録・更新・削除は、編集対象のユーザでログインし メニューの[ユーザ設定]-[プライベートグループ設定] から行って下さい。

    プログラムインターフェースとしては、 jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManagerクラスを使用して下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


Messaging

  1. Servers: Message-Driven Beans
  2. JNDI Configuration
  3. Clients

JMS(Java Messaging Service)はキューイングシステムです。クライアントはキューにメッセージを追加し、サーバはそのメッセージを削除します。

ベースモジュール（Advanced版）のEJBコンテナ（ApplicationRuntime）の EJB message-bean はJMSを利用できるよう、仕様に忠実に実装したものです。ベースモジュール（Advanced版）のEJBコンテナは、JMSの basic memory-based を含んでいます。

Servers: Message-Driven Beans

message-driven bean server はメッセージを処理します。ベースモジュール（Advanced版）のEJBコンテナはbeanのonMessage()メソッドを個々の新しいメッセージとともに呼び出します。

package test;

import javax.ejb.*;
import javax.jms.*;

public class TestBean implements MessageDrivenBean, MessageListener {
  ...

  public void onMessage(Message msg)
  {
    // process the message
  }
}

JNDI Configuration

サーバはConnectionFactoryとDestinationの両方を形成します。DestinationはQueueまたはTopic objectのいずれかで、ConnectionFactoryはQueueConnectionFactoryかTopicConnectionFactoryのいずれかです。

他のJNDI リソース同様、 JMS オブジェクトはresource-ref directivesで形成されます。init-param値はそれらのオブジェクトのbeanプロパティを形成します。

<!-- conf/http.xml -->
<caucho.com>
<http-server>
  <resource-ref res-ref-name="jms/queue-connection-factory"
                res-type='com.caucho.jms.JVMQueueConnectionFactory'/>

  <resource-ref res-ref-name="jms/queue"
                res-type='com.caucho.jms.memory.MemoryQueue'/>
  ...
</http-server>
</caucho.com>

以下のfactory がベースモジュール（Advanced版）の JMS オブジェクトです。

Class | Description
com.caucho.jms.JVMQueueConnectionFactory | The connection factory for queues.
com.caucho.jms.memory.MemoryQueue | A memory-based queue.
com.caucho.jms.JVMTopicConnectionFactory | The connection factory for topics.
com.caucho.jms.memory.MemoryTopic | A memory-based topic.

Clients

クライアントはメッセージを作り、それらをdestinationへ送ります。クライアントは以下のものが必要です。

  • Lookup the Destination and ConnectionFactory with JNDI
  • Create a Sender (or Publisher for Topics)
  • Create a message
  • Send the message

import javax.naming.*;
import javax.jms.*;

// look up the objects.
Context env = (Context) new InitialContext().lookup("java:comp/env");
Queue queue = (Queue) env.lookup("jms/queue");
QueueConnectionFactory factory;
factory =
  (QueueConnectionFactory) env.lookup("jms/queue-connection-factory");

QueueConnection connection = factory.createQueueConnection();
QueueSession jmsSession = connection.createQueueSession(false, 0);

QueueSender sender = jmsSession.createSender(queue);

// create the message
Message message = jmsSession.createTextMessage("hello, world");

// send the message
sender.send(message);


intra-mart[Server side JavaScript intra-mart Documentation.[Manner]]

i ntra-mart The Power for Enterprise Web Solution
コーディングルール
(J2EEベース開発モデル)

注意事項

このページで記載されている内容は、 i ntra-mart アプリケーション(フレームワークの各画面も含む)をカスタマイズする際の必要事項になりますので、十分に理解した上で、i ntra-mart アプリケーションの開発を行うようにしてください。

J2EEベース開発モデルに関しては、JAVA、JSP および Servlet 等、関連技術のルールに従ってください。

これ以外にintra-mart J2EEベース開発モデルでのルールは、以下の通りとなります。

ルール

1. | i ntra-mart フレームワークで提供している機能において、すべてのＩＤに関して、以下に示す文字を含む名称を与えることはできません。 \ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab) (全角文字)
2. | ファンクション・コンテナ内で [install_directory]/conf/imart.xml を読み込んだり書き込んだりしてはいけません。 設定ファイルをむやみに変更することは、思わぬ誤動作の原因となります。 なお、[install_directory]/conf/imart.xml ファイル内の設定内容を変更した場合には、i ntra-mart システム全体の再起動が必要です。 ただし、i ntra-mart Administrator(サーバ管理ツール)上で設定内容を変更した場合には、i ntra-mart Administrator(サーバ管理ツール)から該当のサーバを再起動するだけで新しい設定内容が反映されます。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[JavaServerPages(Servlet)]]]

i ntra-mart The Power for Enterprise Web Solution
JavaServerPages(Servlet)について

前提

ブラウザから intra-mart に対して Web アクセスするためには、Schedule Service 以外のすべてのサービス および intra-mart Web-Server Connector(StandAlone 型の場合は必要ありません) をインストールして正しく動作していることが必要になります。

intra-martの初期起動

Application Runtime の初期起動時には、ページベース開発モデルのプログラムが 実行されます。
詳しくは、ページベース開発モデルのFunction Containerについてを参照して 下さい。

（ページベース開発モデルと連携する必要がない場合には、特に設定や作業はいりません。）

JSP(Servlet)により生成されるWeb ページ

ブラウザから HTTP リクエストによりページを作成するために必要な JSP または Servlet クラスを実行します。
JSP や Servlet のソースファイルは、プログラムが実行される Application Runtime が動作しているコンピュータに保存します(Resource Service にプログラムを保存しても自動配信はされませんのでご注意下さい)。

JavaServerPages ページプログラムは、拡張子 *.jsp(XML 形式で記述する場合 *.xtp)となります。また、実行可能なディレクトリ(Application Runtime のインストールディレクトリ/doc/)に保存する事で実行する事ができます。

Servlet は、ＵＲＬとの関連付けを [install_directory]/conf/imart.xml で定義することで実行する事ができます(実行前に、クラスファイルを実行可能なディレクトリに保存してください)。

ブラウザから直接リンクをする場合は、該当のファイルを Web-Server Connector をインストールしたディレクトリ内に保存して下さい。
(画像ファイルなども、これに該当します。)

実行シーケンス(JSP)

ブラウザからリクエストがあった場合、以下のように処理が流れます。

  1. ブラウザからのリクエスト受付
  2. JSP ソースのコンパイル
  3. JSP の実行
  4. ページ返却

初めてリクエストされた場合 JSP ソースを JAVA のクラスにコンパイルするので、レスポンスに時間がかかりますが、以後はクラスがメモリ内に常駐しますので高速に動作します。また、１度作成された JAVA クラスは、ファイルとして保存され、サーバ再起動後も保存されているクラスファイルを実行します。ただし、JSP ソースが更新された場合は、保存されていたクラスファイルは破棄され、更新されたソースをもとにコンパイルが行われます。

実行シーケンス(Servlet)

ブラウザからリクエストがあった場合、以下のように処理が流れます。

  1. ブラウザからのリクエスト受付
  2. Servlet クラス の実行
  3. ページ返却

実行前に以下の準備が必要です。

  • java ソースのコンパイル
  • クラスパスの設定
  • ＵＲＬとクラスのマッピングを設定

Servlet クラスを作り直したり、設定を変更した場合には、Application Server の再起動が必要です。

Servlet クラスは、１度実行されるとメモリ内にクラスが保持されますので、高速に動作します。

メニューとの連携

JSP (または Servlet) をメニューに登録した場合、ログインユーザがメニューから JSP (または Servlet) のページを選択した場合、呼び出されたページプログラムにはメニューに指定した引数がＵＲＬ引数として渡されます。

ページベース開発モデルとの連携

プレゼンテーションページから JSP(または Servlet) で開発されたページを呼び出すためには、通常のフォームタグ(<FORM<)やアンカータグ(<A<)を利用して、呼び出して下さい。href や action に指定するＵＲＬは、intra-mart のＵＲＬ（標準では http://host:port/imart/intramart）からの相対で指定するか、または完全形式のＵＲＬで指定して下さい。
JSP(または Servlet) のプログラム内で必要になる情報は、予めＵＲＬ引数として渡すように工夫するようにして下さい。

例）アプリケーションサーバのインストールディレクトリ/doc/myapp/myjsp.jsp を master というユーザＩＤ情報を伴って呼び出す場合
<FORM action="myjsp.jsp">

<INPUT type="hidden" name="account" value="master">
</FORM>

JSP(または Servlet) で開発されたページからプレゼンテーションページを呼び出す場合には、jp.co.intra_mart.foundation.http.SessionQueryを利用することでセッションを維持しつつ各ページが相互に連携する事ができます。

注意事項

JSP や Servlet にてユーザセッションの必要なアプリケーションを作成する場合は、Servlet エンジンの持つ HTTP セッションを利用して作成します。これにより、ページベース開発モデルの画面やアクセスセキュリティ機能とセッション連携したアプリケーションを作成することが出来ます。

JSP ソースがコンパイルされると、インストールディレクトリ/work/ に JSP ソースから作成された JAVA のソースファイルとクラスファイルが作られます。エラーが発生した場合、これらのファイルを参照してデバッグ等を行って下さい(intra-mart BaseModule の場合)。

intra-mart Application Server を分散インストールして、ネットワーク型でシステム運用している場合、各サーバで動作している Java クラス同士の変数の共有はできません。したがって、あるリクエストを処理しているスレッドと他のリクエストを処理しているスレッドで変数の共有は保証されません。プログラム間でのデータの共有には、HTTP セッションや Shared Memory Service 等の機能を利用するようにして下さい。

自作のクラスなどを利用する場合、Application Runtime の実行環境に対してクラスパスを設定する必要があります。クラスパスを設定するには、intra-mart Administrator を利用するか、または Application Runtime を実行している環境に対して設定するようにして下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[intra-mart Documentation.[Knowledge Search Module]]

i ntra-mart The Power for Enterprise Web Solution
統合検索ソリューション
ConceptBase連携

概要

統合検索ソリューションとは、データ資産から目的の情報を検索する機能のことです。

検索対象となるリソースは、ファイルやデータベース内の情報になります。

機能仕様

本機能は、(株)ジャストシステムの『ConceptBase』を利用しています（対応バージョンは ConceptBaseIV）。

ファイルやデータベース中の情報の検索を行います。
検索は、キーワードによる完全一致検索ではなく、類似情報検索が可能です。

連携仕様

(株)ジャストシステムの『ConceptBase』との連携は、「CBRPC-XML」のを利用して行います。
詳しくは(株)ジャストシステムの『ConceptBaseIV』のアプリケーション開発キットのマニュアルをご覧ください。

ファイル検索

多種多様のファイルの中から目的の情報をもつファイルを検索する機能です。
テキストファイルのみでなくWordやPDFファイルなどの検索も可能です。

データベース検索

データベースに保存されている情報からの検索を行います（当機能は、(株)ジャストシステム「CB RDBゲートウェイ」との連係機能を利用することにより可能になります）。
データベース中の任意の表中の各レコードを１つの文書として検索を行います。

前提条件

本機能を利用するためには、(株)ジャストシステムの『ConceptBaseIV』が必要になります。

Storage Serviceが稼働するService Pratform は Windows NT/2000 で動作させる必要があります（『ConceptBaseIV』の制約になります）。

準備

以下の手順でセットアップしてください。

手順

  1. Storage Serviceが稼働するService PlatformがインストールされているコンピュータにConceptBase サーバをインストールおよびセットアップします(すでに設定済みの場合は次へ進んで下さい)。

  2. Webゲートウェイ Java Servlet版を画面の指示に従いインストール作業をしてください)およびセットアップします(すでに設定済みの場合は次へ進んで下さい)。

  3. intra-mart intra-mart をインストールおよびセットアップします(すでに設定済みの場合は次へ進んで下さい)。

  4. ConceptBase サーバを起動します。

  5. intra-mart のすべてのサーバを起動します。

ConceptBase の利用方法等に関しては ConceptBase のマニュアルを参照して下さい。

検索ユーザの設定例

  1. ConceptBase サーバの動作する Windows の参加しているネットワークドメインのプライマリドメインコントローラとなっているWindows NT/2000 Server に管理者権限でログオンします。
  2. ドメインユーザマネージャーでユーザを追加設定します。
  3. 追加設定したユーザに対して Domain Users 権限（ロール）を与えます。
  4. ConceptBase が検索する対象ディレクトリを共有設定します。
  5. ConceptBase が検索する対象ディレクトリに対してロール Domain Users に対して参照権限を与えます。

詳しくは、ConceptBase のマニュアルを参照して下さい。

アンインストール

ConceptBase Server のアンインストールに関しては、ConceptBase のマニュアルに従って下さい。

ConceptBase 接続モジュール（CBSearchアプリケーション開発キット）は、コントロールパネル→アプリケーションの追加と削除からアンインストールすることができます。アンインストーラを起動して画面の指示に従って関連ファイルを削除して下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


統合検索モジュール メニュー

統合検索ソリューション
・仕様
・連携サンプル


intra-mart[intra-mart Documentation.[Knowledge Search Module]]

i ntra-mart The Power for Enterprise Web Solution
統合検索ソリューション
ConceptBase連携サンプル

概要

(株)ジャストシステムの『ConceptBaseIV』の「CBRPC-XML」を利用したサンプルです。
自然文検索の結果と、その詳細を表示することができます。

ログイン後のメニューの「サンプル」-「ページベース開発モデル」-「統合検索」からサンプルを表示することができます。

サンプルファイル

サンプルファイルは、JAVAファイルとページベース開発モデルを利用して作成されています。

ファイル | 配置場所
JAVAファイル (CBRPC-XMLで問い合わせを行うjavaファイルです。) | doc/imart/WEB-INF/classes/jp/co/intra_mart/cb/CBGateWay.java （Application Runtimeが稼働するService Platform上）
ページベースファイル群 (検索を行うページ群です。) | pages/sample/knowledge/search （Resource Serviceが稼働するService Platform上）

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


ＡＰＩリスト(ColorList)

カラーチャート　（カラー名）

■ aliceblue
■ antiquewhite
■ aqua
■ aquamarine
■ azure
■ beige
■ bisque
■ black
■ blanchedalmond
■ blue
■ blueviolet
■ brown
■ burlywood
■ cadetblue
■ chartreuse
■ chocolate
■ coral
■ cornflowerblue
■ cornsilk
■ crimson
■ cyan
■ darkblue
■ darkcyan
■ darkgoldenrod
■ darkgray
■ darkgreen
■ darkkhaki
■ darkmagenta
■ darkolivegreen
■ darkorange
■ darkorchid
■ darkred
■ darksalmon
■ darkseagreen
■ darkslategray
         ■ darkslateblue
■ darkturquoise
■ darkviolet
■ deeppink
■ deepskyblue
■ dimgray
■ dodgerblue
■ firebrick
■ floralwhite
■ forestgreen
■ fuchsia
■ gainsboro
■ ghostwhite
■ goldenrod
■ gold
■ green
■ gray
■ greenyellow
■ honeydew
■ hotpink
■ indianred
■ indigo
■ ivory
■ khaki
■ lavender
■ lavenderblush
■ lawngreen
■ lemonchiffon
■ lightblue
■ lightcoral
■ lightcyan
■ lightgoldenrodyellow
■ lightgreen
■ lightgrey
■ lightpink
         ■ lightsalmon
■ lightseagreen
■ lightskyblue
■ lightslategray
■ lightsteelblue
■ lightyellow
■ lime
■ limegreen
■ linen
■ magenta
■ maroon
■ mediumaquamarine
■ mediumblue
■ mediumorchid
■ mediumpurple
■ mediumseagreen
■ mediumslateblue
■ mediumspringgreen
■ mediumturquoise
■ mediumvioletred
■ midnightblue
■ mintcream
■ mistyrose
■ moccasin
■ navy
■ navajowhite
■ oldlace
■ olive
■ olivedrab
■ orange
■ orangered
■ orchid
■ palegoldenrod
■ palegreen
■ paleturquoise
         ■ palevioletred
■ papayawhip
■ peachpuff
■ peru
■ pink
■ plum
■ powderblue
■ purple
■ red
■ rosybrown
■ royalblue
■ saddlebrown
■ salmon
■ sandybrown
■ seagreen
■ seashell
■ sienna
■ silver
■ skyblue
■ slateblue
■ slategray
■ snow
■ springgreen
■ steelblue
■ tan
■ teal
■ thistle
■ tomato
■ turquoise
■ violet
■ wheat
■ white
■ whitesmoke
■ yellow
■ yellowgreen


intra-mart[Server side JavaScript intra-mart Documentation.[customize]]

i ntra-mart The Power for Enterprise Web Solution
製品のカスタマイズ

規定

intra-mart では、製品として提供されたプログラムを自由にカスタマイズして利用することができます。
カスタマイズが可能なプログラムは、オープン・ソースとして提供されているプログラムファイル(*.ini，*.html，*.js，*.properties，*.java および ，*.jsp など)すべてが対象となります。

製品のソース・コードに対してカスタマイズをした場合、カスタマイズをしたプログラムおよび動作に関連のあるプログラム群に関して、同パッケージの提供元は動作保証をいたしません。 また、カスタマイズをしたことにより発生した不具合に関しては、サポート対象外となります。

環境移行の手順

カスタマイズしたプログラムを別の環境へ移行（例えば開発機から本番運用機への移行）する場合、以下の手順で移行を行って下さい。

  1. 移行先へ intra-mart をインストールします。
  2. 移行先環境の intra-mart に対してライセンス登録を行います（アプリケーションを追加インストールしていてソースを展開している場合には、ソース展開も行います）。
  3. 移行先環境の intra-mart を停止します。
  4. カスタマイズした各プログラムソース(ini, html および js)を元環境から移行先環境へコピーします。
  5. 移行先の intra-mart を起動します。

カスタマイズしたプログラムを移行する場合、Resource Service の pages/ ディレクトリ内にある html および js 以外のファイルと Permanent Data Service の treasure/ ディレクトリを上書きコピーしてしまわないように注意して下さい。万一、元環境から移行先環境に対してバイナリファイルの上書きコピーをしてしまいシステムが正常に動作しなくなった場合には、すべてのファイルを削除して移行先への intra-mart のインストールから再度行うようにして下さい。

注意事項

ソースが公開されているプログラムであっても、そのコード中に非公開のＡＰＩを利用している場合があります。これら、非公開ＡＰＩは予告なく仕様が変更されることがあるので注意が必要です。

製品のソースを直接カスタマイズした場合、カスタマイズをしたソースに関してはバージョンアップ対象外となります。パッチおよびバージョンアップ版のインストールの際にはソースが自動的に上書きされてしまうことがありますので、ご注意下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Original Application]]

i ntra-mart The Power for Enterprise Web Solution
アクセスセキュリティモジュールを利用しないで画面を構築する方法

概要

intra-mart では、アクセスセキュリティモジュールにとらわれない独自のアプリケーション作成を可能にするソリューションを標準機能として提供しています。

準備(インストール)

intra-mart をインストールガイドにしたがってインストールしてください。
分散システムを構築する場合には、すべてのサーバをインストールします。

インストールが完了したら、すべての Application Runtime のdoc/imart/WEB-INF/web.xmlにて 以下のフィルターマッピングの設定(<filter-mapping>)をすべて削除してください。
( intra-mart フレームワークの場合、この設定ファイル編集後に再デプロイを行ってください)

  • RequestCharacterEncodingFilter
  • ResponseCharacterEncodingFilter
  • URLAccessFilter
  • SessionFilter

作成(ページベース開発モデル)

アプリケーション・プログラムを作成する場合、スクリプトファイルの動作仕様にしたがって、それぞれ目的にあったプログラムを記述していきます。

アプリケーションの動作概要と、スクリプトファイルの動作仕様に関しては、動作概要【 Application Runtime 篇 】およびPresentation Pageについてを参照して下さい。

作成したアプリケーションへは、以下のＵＲＬでアクセスできます（下記は標準インストールの場合の例です）。

  • http://<ホスト名>[:<ポート番号>]/imart/<作成したスクリプトのパス>.jssp

※<作成したスクリプトのパス>は、 Resource Service が管理しているリソースルートディレクトリからの相対形式で、 拡張子(.html および .js)を省略したものを指定して下さい。

作成(J2EEベース開発モデル)

アプリケーション・プログラムを作成する場合、Servlet および JSP 等の仕様や im-J2EE Framework の動作仕様にしたがって、それぞれ目的にあったプログラムを記述していきます。

動作仕様等に関しては、JavaServerPages(Servlet)について 、im-J2EE Framework ＡＰＩリスト および製品同梱の im-J2EE Framework 仕様書を参照して下さい。

なお、im-J2EE Framework を利用して作成した画面へは、以下ＵＲＬにてアクセスできます（下記は標準インストールした場合の例です）。

  • http://<ホスト名>[:<ポート番号>]/imart/<アプリケーションID>-<サービスID>.service

注意事項

アクセスセキュリティモジュールを利用せずに画面を作成した場合、標準で提供されている一部の機能(API)が利用できません。

利用できないＡＰＩ(ページベース開発モデル)
  • アクセスセキュリティに関連した機能
    • AccessSecurityManager.*
    • AccountManager.*
    • LicenseManager.*
    • LoginGroupManager.*
    • RoleManager.*
    • UserManager.*
    • Module.client.*
  • アプリケーション共通マスタに関連した機能
    • CategoryManager.*
    • CompanyManager.*
    • PrivateGroupManager.*
    • PublicGroupManager.*
    • Procedure.AppCommonUtil.*
  • ワークフロー機能
    • AckApplicant.*
    • AckItem.*
    • Acknowledge.*
    • AckUtil.*
  • その他
    • Module.alert.*
    • Module.external.*
利用できないＡＰＩ(J2EEベース開発モデル)
  • アクセスセキュリティに関連した機能
    • jp.co.intra_mart.foundation.security.*
    • jp.co.intra_mart.foundation.acssecurity.*
  • アプリケーション共通マスタに関連した機能
    • jp.co.intra_mart.foundation.datastore.*
    • jp.co.intra_mart.foundation.appcomn.*
  • ワークフロー機能
    • jp.co.intra_mart.foundation.ackwkf.*

アクセスセキュリティモジュールを利用せずに画面を作成した場合、[install_directory]/conf/imart.xml 内の設定項目の中で有効に機能しないものがあります。

アクセスセキュリティモジュールを利用せずに画面を作成した場合、intra-mart の他のパッケージおよびアドオン・モジュールを追加インストールすることはできません。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript BASE MODULE Documentation.[Graph]]

i ntra-mart The Power for Enterprise Web Solution
グラフ描画・モジュール

機能概要

入力データをもとに画像ファイルを作成して、ブラウザ画面上にグラフ画面を表示します。

以下の５種類のグラフがサンプルとして用意されています。

  • 折れ線グラフ
  • 棒グラフ
  • 円グラフ
  • レーダーチャート
  • ポートフォリオ

プレゼンテーション・ページＡＰＩ

<IMART> タグを利用します。
<IMART> タグの type 属性に指定する値によって、異なるグラフを描画することができます。

type属性値 | グラフの種類
lineGraph | 折れ線グラフ
barGraph | 棒グラフ
circleGraph | 円グラフ
radarChart | レーダーチャート
portFolio | ポートフォリオ

（例） <IMART type="lineGraph">

詳細なプログラム・インターフェースに関しては、画面共通モジュール を参照下さい。

ファンクション・コンテナＡＰＩ

Drawer.* を利用します。

詳細なプログラム・インターフェースに関しては、アプリケーション共通モジュール を参照下さい。

例： ［折れ線グラフ］

プレゼンテーション・ページ
<HTML>
<HEAD>
<TITLE>Line Graph Sample</TITLE>
</HEAD>
<BODY>

<IMART type="lineGraph"
data=oData
image_width="300"
image_height="300"
data_min="-30"
data_max="60"
scale_count="20"
alt="IM_LineGraph">
</IMART>

</BODY>
</HTML>

<!-- End of File -->

<IMART type="lineGraph"> の data 属性 に対するバインド変数 oData は、ファンクション・コンテナで生成した描画データオブジェクトの格納されている変数名。

ファンクション・コンテナ

// バインド変数宣言
var oData; // 折れ線グラフ描画データ

// ページの初期化関数
function init() {
// 折れ線グラフ描画データオブジェクトの作成
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月", "６月");
oData.aData = new Array();

oData.aData[0] = new Object();
oData.aData[0].aData = new Array(50, 10, 30, 5, 30, 20);
oData.aData[0].sColor = "red";
oData.aData[0].nWidth = 5;

oData.aData[1] = new Object();
oData.aData[1].aData = new Array(10, 40, -20, 30, -10, 45);
oData.aData[1].sColor = "yellow";

oData.aData[2] = new Object();
oData.aData[2].aData = new Array(20, 30, 50, 25, 45, 55);
oData.aData[2].sColor = "green";
oData.aData[2].nStyle = new Array(10,10);
}

/* End of File */

描画された折れ線グラフ（例）

Headless のサポート

X11を搭載していないUNIXなどのOSは、グラフィックスをサポートしていないため通常グラフモジュールを使用することができません。 但し、ヘッドレスモードをサポートしているJava VMを使用している場合、Java環境変数を設定することにより非グラフィックス環境の場合でも グラフモジュールを使用することが可能です。

i ntra-mart BaseModule の場合は、/conf/imart.xmlの以下の場所にJava環境変数を追加してください。

    .
    .
<command>
  <exefile>C:/j2sdk1.4.2_XX/bin/java</exefile>
  <option>-cp %SYSTEMCLASSPATH% -Xms%XMS% -Xmx%XMX% -Djava.awt.headless=true</option>
  <argument/>
</command>
    .
    .

i ntra-mart Frameworkの場合は、同様のJava環境変数をウェブアプリケーションサーバに設定してください。 Java環境変数の設定方法については、ウェブアプリケーションサーバのマニュアルを参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


AccEmployeePayPostController()

  • プロトタイプ

    AccEmployeePayPostController()

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    引数なしコンストラクタ

setDocObjType()

  • プロトタイプ

    (void) setDocObjType((String)value)

  • 入力値

    (String) value: 参照処理

  • 返却値

    なし

  • 詳細

    伝票ヘッダの参照処理に値を設定します。

setDocObjKey()

  • プロトタイプ

    (void) setDocObjKey((String)value)

  • 入力値

    (String) value: オブジェクトキー

  • 返却値

    なし

  • 詳細

    伝票ヘッダのオブジェクトキーに値を設定します。

setDocUsername()

  • プロトタイプ

    (void) setDocUsername((String)value)

  • 入力値

    (String) value: ユーザ名

  • 返却値

    なし

  • 詳細

    伝票ヘッダのユーザ名に値を設定します。

setDocHeaderTxt()

  • プロトタイプ

    (void) setDocHeaderTxt((String)value)

  • 入力値

    (String) value: 伝票ヘッダテキスト

  • 返却値

    なし

  • 詳細

    伝票ヘッダの伝票ヘッダテキストに値を設定します。

setDocCompCode()

  • プロトタイプ

    (void) setDocCompCode((String)value)

  • 入力値

    (String) value: 会社コード

  • 返却値

    なし

  • 詳細

    伝票ヘッダの会社コードに値を設定します。

setDocAcDocNo()

  • プロトタイプ

    (void) setDocAcDocNo((String)value)

  • 入力値

    (String) value: 会計伝票番号

  • 返却値

    なし

  • 詳細

    伝票ヘッダの会計伝票番号に値を設定します。

setDocFiscYear()

  • プロトタイプ

    (void) setDocFiscYear((String)value)

  • 入力値

    (String) value: 会計年度

  • 返却値

    なし

  • 詳細

    伝票ヘッダの会計年度に値を設定します。

setDocDocDate()

  • プロトタイプ

    (void) setDocDocDate((String)value)

  • 入力値

    (String) value: 伝票の伝票日付

  • 返却値

    なし

  • 詳細

    伝票ヘッダの伝票の伝票日付に値を設定します。

setDocPstngDate()

  • プロトタイプ

    (void) setDocPstngDate((String)value)

  • 入力値

    (String) value: 伝票の転記日付

  • 返却値

    なし

  • 詳細

    伝票ヘッダの伝票の転記日付に値を設定します。

setDocFisPeriod()

  • プロトタイプ

    (void) setDocFisPeriod((String)value)

  • 入力値

    (String) value: 会計期間

  • 返却値

    なし

  • 詳細

    伝票ヘッダの会計期間に値を設定します。

setDocDocType()

  • プロトタイプ

    (void) setDocDocType((String)value)

  • 入力値

    (String) value: 伝票タイプ

  • 返却値

    なし

  • 詳細

    伝票ヘッダの伝票タイプに値を設定します。

setDocRefDocNo()

  • プロトタイプ

    (void) setDocRefDocNo((String)value)

  • 入力値

    (String) value: 参照伝票番号

  • 返却値

    なし

  • 詳細

    伝票ヘッダの参照伝票番号に値を設定します。

setPaItemnoAcc()

  • プロトタイプ

    (void) setPaItemnoAcc((String)value, (int)recNo)

  • 入力値

    (String) value: 会計伝票明細番号
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    仕入先明細の会計伝票明細番号に値を設定します。

setPaVendorNo()

  • プロトタイプ

    (void) setPaVendorNo((String)value, (int)recNo)

  • 入力値

    (String) value: 仕入先または債権者の勘定コード
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    仕入先明細の仕入先または債権者の勘定コードに値を設定します。

setPaGlAccount()

  • プロトタイプ

    (void) setPaGlAccount((String)value, (int)recNo)

  • 入力値

    (String) value: 総勘定元帳勘定
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    仕入先明細の総勘定元帳勘定に値を設定します。

setPaBlineDate()

  • プロトタイプ

    (void) setPaBlineDate((String)value, (int)recNo)

  • 入力値

    (String) value: 期日計算の支払基準日
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    仕入先明細の期日計算の支払基準日に値を設定します。

setPaPymtMeth()

  • プロトタイプ

    (void) setPaPymtMeth((String)value, (int)recNo)

  • 入力値

    (String) value: 支払方法
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    仕入先明細の支払方法に値を設定します。

setPaAllocNmbr()

  • プロトタイプ

    (void) setPaAllocNmbr((String)value, (int)recNo)

  • 入力値

    (String) value: ソートキー
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    仕入先明細のソートキーに値を設定します。

setPaItemText()

  • プロトタイプ

    (void) setPaItemText((String)value, (int)recNo)

  • 入力値

    (String) value: 明細テキスト
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    仕入先明細の明細テキストに値を設定します。

setGlItemnoAcc()

  • プロトタイプ

    (void) setGlItemnoAcc((String)value, (int)recNo)

  • 入力値

    (String) value: 会計伝票明細番号
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の会計伝票明細番号に値を設定します。

setGlGlAccount()

  • プロトタイプ

    (void) setGlGlAccount((String)value, (int)recNo)

  • 入力値

    (String) value: 総勘定元帳勘定
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の総勘定元帳勘定に値を設定します。

setGlCompCode()

  • プロトタイプ

    (void) setGlCompCode((String)value, (int)recNo)

  • 入力値

    (String) value: 会社コード
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の会社コードに値を設定します。

setGlPstngDate()

  • プロトタイプ

    (void) setGlPstngDate((String)value, (int)recNo)

  • 入力値

    (String) value: 伝票の転記日付
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の伝票の転記日付に値を設定します。

setGlDocType()

  • プロトタイプ

    (void) setGlDocType((String)value, (int)recNo)

  • 入力値

    (String) value: 伝票タイプ
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の伝票タイプに値を設定します。

setGlFiscYear()

  • プロトタイプ

    (void) setGlFiscYear((String)value, (int)recNo)

  • 入力値

    (String) value: 会計年度
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の会計年度に値を設定します。

setGlRefKey1()

  • プロトタイプ

    (void) setGlRefKey1((String)value, (int)recNo)

  • 入力値

    (String) value: 取引先参照キー
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の取引先参照キーに値を設定します。

setGlItemText()

  • プロトタイプ

    (void) setGlItemText((String)value, (int)recNo)

  • 入力値

    (String) value: 明細テキスト
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の明細テキストに値を設定します。

setGlTaxCode()

  • プロトタイプ

    (void) setGlTaxCode((String)value, (int)recNo)

  • 入力値

    (String) value: 消費税コード
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の消費税コードに値を設定します。

setGlAllocNmbr()

  • プロトタイプ

    (void) setGlAllocNmbr((String)value, (int)recNo)

  • 入力値

    (String) value: ソートキー
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細のソートキーに値を設定します。

setGlBusArea()

  • プロトタイプ

    (void) setGlBusArea((String)value, (int)recNo)

  • 入力値

    (String) value: 事業領域
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の事業領域に値を設定します。

setGlCostcenter()

  • プロトタイプ

    (void) setGlCostcenter((String)value, (int)recNo)

  • 入力値

    (String) value: 原価センタ
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の原価センタに値を設定します。

setGlOrderid()

  • プロトタイプ

    (void) setGlOrderid((String)value, (int)recNo)

  • 入力値

    (String) value: 指図番号
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細の指図番号に値を設定します。

setGlWbsElement()

  • プロトタイプ

    (void) setGlWbsElement((String)value, (int)recNo)

  • 入力値

    (String) value: WBS要素
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    G/L勘定明細のWBS要素に値を設定します。

setTaItemnoAcc()

  • プロトタイプ

    (void) setTaItemnoAcc((String)value, (int)recNo)

  • 入力値

    (String) value: 会計伝票明細番号
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    税明細の会計伝票明細番号に値を設定します。

setTaGlAccount()

  • プロトタイプ

    (void) setTaGlAccount((String)value, (int)recNo)

  • 入力値

    (String) value: 総勘定元帳勘定
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    税明細の総勘定元帳勘定に値を設定します。

setTaTaxCode()

  • プロトタイプ

    (void) setTaTaxCode((String)value, (int)recNo)

  • 入力値

    (String) value: 消費税コード
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    税明細の消費税コードに値を設定します。

setCuItemnoAcc()

  • プロトタイプ

    (void) setCuItemnoAcc((String)value, (int)recNo)

  • 入力値

    (String) value: 会計伝票明細番号
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    明細通貨項目の会計伝票明細番号に値を設定します。

setCuCurrency()

  • プロトタイプ

    (void) setCuCurrency((String)value, (int)recNo)

  • 入力値

    (String) value: 通貨コード
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    明細通貨項目の通貨コードに値を設定します。

setCuAmtDoccur()

  • プロトタイプ

    (void) setCuAmtDoccur((String)value, (int)recNo)

  • 入力値

    (String) value: 伝票通貨額
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    明細通貨項目の伝票通貨額に値を設定します。

setCuAmtBase()

  • プロトタイプ

    (void) setCuAmtBase((String)value, (int)recNo)

  • 入力値

    (String) value: 課税基準額
    (int) recNo: レコード番号

  • 返却値

    なし

  • 詳細

    明細通貨項目の課税基準額に値を設定します。

executeBapi()

  • プロトタイプ

    (Object) executeBapi()

  • 入力値

    なし

  • 返却値

                    成功時
                    返却値なし("")

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    BapiControllerにより会計伝票を登録します。


AccEmployeePayPostController オブジェクト

概要

会計伝票を登録します。

構造図
コンストラクタ
メソッド
setDocObjType() | 参照処理の設定
setDocObjKey() | オブジェクトキーの設定
setDocUsername() | ユーザ名の設定
setDocHeaderTxt() | 伝票ヘッダテキストの設定
setDocCompCode() | 会社コードの設定
setDocAcDocNo() | 会計伝票番号の設定
setDocFiscYear() | 会計年度の設定
setDocDocDate() | 伝票の伝票日付の設定
setDocPstngDate() | 伝票の転記日付の設定
setDocFisPeriod() | 会計期間の設定
setDocDocType() | 伝票タイプの設定
setDocRefDocNo() | 参照伝票番号の設定
setPaItemnoAcc() | 会計伝票明細番号の設定
setPaVendorNo() | 仕入先または債権者の勘定コードの設定
setPaGlAccount() | 総勘定元帳勘定の設定
setPaBlineDate() | 期日計算の支払基準日の設定
setPaPymtMeth() | 支払方法の設定
setPaAllocNmbr() | ソートキーの設定
setPaItemText() | 明細テキストの設定
setGlItemnoAcc() | 会計伝票明細番号の設定
setGlGlAccount() | 総勘定元帳勘定の設定
setGlCompCode() | 会社コードの設定
setGlPstngDate() | 伝票の転記日付の設定
setGlDocType() | 伝票タイプの設定
setGlFiscYear() | 会計年度の設定
setGlRefKey1() | 取引先参照キーの設定
setGlItemText() | 明細テキストの設定
setGlTaxCode() | 消費税コードの設定
setGlAllocNmbr() | ソートキーの設定
setGlBusArea() | 事業領域の設定
setGlCostcenter() | 原価センタの設定
setGlOrderid() | 指図番号の設定
setGlWbsElement() | WBS 要素の設定
setTaItemnoAcc() | 会計伝票明細番号の設定
setTaGlAccount() | 総勘定元帳勘定の設定
setTaTaxCode() | 消費税コードの設定
setCuItemnoAcc() | 会計伝票明細番号の設定
setCuCurrency() | 通貨コードの設定
setCuAmtDoccur() | 伝票通貨額の設定
setCuAmtBase() | 課税基準額 (伝票通貨建て)の設定
executeBapi() | 会計伝票の登録


BankController()

  • プロトタイプ

    BankController()

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    引数なしコンストラクタ

getBankList()

  • プロトタイプ

    (Object[]) getBankList()

  • 入力値

    なし

  • 返却値

    Object[] 銀行情報が格納された配列

  • 詳細

    銀行情報一覧を取得します。取得した配列は２次元配列になっています。値を取得する 際に指定する配列のキー値は以下の通りです。

    [idx]["BANK_KEY"]　→　配列内のidx番目の銀行の「銀行コード」
    [idx]["BANK_NAME"]　→　配列内のidx番目の銀行の「銀行名」
    [idx]["CITY"]　→　配列内のidx番目の銀行の「市区町村名」

    ※idxは0～n（配列サイズ-1）

getBankName()

  • プロトタイプ

    (Object) getBankName((String)bankKey)

  • 入力値

    (String) bankKey: SAP R/3上に存在する銀行コード

  • 返却値

                    成功時
                    指定した銀行コードに対応する銀行名

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    銀行コードを指定して銀行名を取得します。

getCity()

  • プロトタイプ

    (Object) getCity((String)bankKey

  • 入力値

    (String) bankKey: SAP R/3上に存在する銀行コード

  • 返却値

                    成功時
                    指定した銀行コードに対応する市区町村名

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    銀行コードを指定して市区町村名を取得します。


BankController オブジェクト

概要

銀行の情報を取得します。

構造図
コンストラクタ
メソッド
getBankList() | 銀行一覧の取得
getBankName() | 銀行名の取得
getCity() | 市区町村名の取得


BapiController()

  • プロトタイプ

    BapiController((String)propertyName)

  • 入力値

    (String) propertyName: BAPIコントローラが使用するプロパティファイル名

  • 返却値

    なし

  • 詳細

    引数ありコンストラクタ

putImportParam()

  • プロトタイプ

    (void) putImportParam((String)key, (String)val)

  • 入力値

    (String) key: BapiHashオブジェクトのKey
    (String) val: BapiHashオブジェクトのValue

  • 返却値

                    成功時
                    返却値なし("")

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡

putStructParam()

  • プロトタイプ

    (void) putStructParam((String)key, (String)val, (String)structName)

  • 入力値

    (String) key: BapiHashオブジェクトに設定するHashMapのキー
    (String) val: BapiHashオブジェクトに設定するHashMapの値
    (String) structName: BapiHashオブジェクトに設定するStructureの名称

  • 返却値

                    成功時
                    返却値なし("")

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    引数に指定された条件でBapiHashオブジェクト(入力／出力区分= "import", パラメタ属性="structure", パラメタ名=第３引数)を生成し､ 一覧に格納します｡

putTableParam()

  • プロトタイプ

    (void) putTableParam((String)key, (String)val, (String)tableName, (int)recordNo)

  • 入力値

    (String) key: BapiHashオブジェクトに設定するHashMapのキー
    (String) val: BapiHashオブジェクトに設定するHashMapの値
    (String) tableName: BapiHashオブジェクトに設定するTableの名称
    (int)recordNo：BapiHashオブジェクトに設定するrecordNoの値

  • 返却値

                    成功時
                    返却値なし("")

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡

executeBapi()

  • プロトタイプ

    (void) executeBapi()

  • 入力値

    なし

  • 返却値

                    成功時
                    返却値なし("")

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    BAPI実行部のメソッド｡JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI処理を実行します｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、BapiReturnオブジェクト の生成とBapiReturnListへの追加を行います｡

isSuccess()

  • プロトタイプ

    (Object) isSuccess()

  • 入力値

    なし

  • 返却値

                    成功時
                    処理結果判定(boolean)

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    BAPI実行が正常に行われたか判定します｡BAPI実行結果であるBapiReturn のType情報が正常("S" / "")であった場合"true"をそれ以外は"false"を返します｡

getErrMessage()

  • プロトタイプ

    (Object) getErrMessage()

  • 入力値

    なし

  • 返却値

                    成功時
                    SAP R/3のエラーメッセージ

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    BAPIの実行結果でBapiReturnのType情報が正常("S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。全て正常("S" / "")の場合は nullが返却されます｡

getExportParam()

  • プロトタイプ

    (Object) getExportParam((String)key)

  • 入力値

    (String) key: 検索条件となるプロパティファイルのキー情報

  • 返却値

                    成功時
                    引数のキーに対応する値

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    export(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名、 プロパティファイルのキー情報で一覧から該当するBapiHashオブジェクトを検索して、 値を返します｡

getStructureParam()

  • プロトタイプ

    (Object) getStructureParam((String)paramName)

  • 入力値

    (String) paramName: 検索条件となるパラメータ名

  • 返却値

                    成功時
                    検索結果となるBapiHash

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    structure(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索して返します｡

getTableParam()

  • プロトタイプ

    (Object) getTableParam((String)paramName)

  • 入力値

    (String) paramName: 検索条件となるパラメータ名

  • 返却値

                    成功時
                    検索結果となるBapiHash

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    table(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索し、一覧に格納して返します｡

getReturnList()

  • プロトタイプ

    (Object[]) getReturnList()

  • 入力値

    なし

  • 返却値

                    成功時
                    Object[]:BAPI実行結果（RETURNパラメータ）が格納された配列

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    table型のBAPI実行結果（RETURNパラメータ）の一覧を取得します。 取得した配列は２次元配列になっています。値を取得する際に指定する配列のキー値は以下の通りです。

    [idx]["TYPE"]　→　配列内のidx番目のBAPI実行結果の「メッセージType」
    [idx]["ID"]　→　配列内のidx番目のBAPI実行結果の「メッセージクラス」
    [idx]["CODE"]　→　配列内のidx番目のBAPI実行結果の「メッセージコード」
    [idx]["NUMBER"]　→　配列内のidx番目のBAPI実行結果の「メッセージ番号」
    [idx]["MESSAGE"]　→　配列内のidx番目のBAPI実行結果の「メッセージテキスト」
    [idx]["LOG_NO"]　→　配列内のidx番目のBAPI実行結果の「ログ番号」
    [idx]["LOG_MSG_NO"]　→　配列内のidx番目のBAPI実行結果の「メッセージシリアル番号」
    [idx]["MESSAGE_V1"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
    [idx]["MESSAGE_V2"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
    [idx]["MESSAGE_V3"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
    [idx]["MESSAGE_V4"]　→　配列内のidx番目のBAPI実行結果の「メッセージ変数」
    [idx]["PARAMETER"]　→　配列内のidx番目のBAPI実行結果の「パラメータ名」
    [idx]["ROW"]　→　配列内のidx番目のBAPI実行結果の「パラメータの行」
    [idx]["FIELD"]　→　配列内のidx番目のBAPI実行結果の「パラメータの項目」
    [idx]["SYSTEM"]　→　配列内のidx番目のBAPI実行結果の「メッセージが発行された論理システム」

    ※idxは0～n（配列サイズ-1）

getReturn()

  • プロトタイプ

    (Object) getReturn()

  • 入力値

    なし

  • 返却値

                    成功時
                    BAPI実行結果（RETURNパラメータ）が格納された配列

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    structure型のBAPI実行結果（RETURNパラメータ）を取得します。 取得した配列は１次元配列になっています。値を取得する際に指定する配列のキー値は以下の通りです。

    ["TYPE"]　→　BAPI実行結果の「メッセージType」
    ["ID"]　→　BAPI実行結果の「メッセージクラス」
    ["CODE"]　→　BAPI実行結果の「メッセージコード」
    ["NUMBER"]　→　BAPI実行結果の「メッセージ番号」
    ["MESSAGE"]　→　BAPI実行結果の「メッセージテキスト」
    ["LOG_NO"]　→　BAPI実行結果の「ログ番号」
    ["LOG_MSG_NO"]　→　BAPI実行結果の「メッセージシリアル番号」
    ["MESSAGE_V1"]　→　BAPI実行結果の「メッセージ変数」
    ["MESSAGE_V2"]　→　BAPI実行結果の「メッセージ変数」
    ["MESSAGE_V3"]　→　BAPI実行結果の「メッセージ変数」
    ["MESSAGE_V4"]　→　BAPI実行結果の「メッセージ変数」
    ["PARAMETER"]　→　BAPI実行結果の「パラメータ名」
    ["ROW"]　→　BAPI実行結果の「パラメータの行」
    ["FIELD"]　→　BAPI実行結果の「パラメータの項目」
    ["SYSTEM"]　→　BAPI実行結果の「メッセージが発行された論理システム」


BapiController オブジェクト

概要

ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡ 展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開アクセサメソッドを使用して取得します｡

構造図
コンストラクタ
メソッド
putImportParam() | import(Import）情報の設定
putStructParam() | structure(Import）情報の設定
putTableParam() | table(Import）情報の設定
executeBapi() | BAPIの実行
isSuccess() | BAPI処理の正常終了確認
getErrMessage() | BAPI処理の実行結果（エラーメッセージ）の取得
getExportParam() | export(Export）情報の取得
getStructureParam() | structure(Export）情報の取得
getTableParam() | table(Export）情報の取得
getReturnList() | BAPI処理の実行結果情報の取得（table用）
getReturn() | BAPI処理の実行結果情報の取得（structure用）


BusinessAreaController()

  • プロトタイプ

    BusinessAreaController()

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    引数なしコンストラクタ

getBusinessAreaList()

  • プロトタイプ

    (Object[]) getBusinessAreaList()

  • 入力値

    なし

  • 返却値

    Object[] 事業領域情報が格納された配列

  • 詳細

    事業領域情報一覧を取得します。取得した配列は２次元配列になっています。値を取得する 際に指定する配列のキー値は以下の通りです。

    [idx]["BUS_AREA"]　→　配列内のidx番目の事業領域の「事業領域コード」
    [idx]["BUS_AREA_DES"]　→　配列内のidx番目の事業領域の「事業領域名」

    ※idxは0～n（配列サイズ-1）

getBusArDes()

  • プロトタイプ

    (Object) getBusArDes((String)busArea)

  • 入力値

    (String) busArea: SAP R/3上に存在する事業領域コード

  • 返却値

                    成功時
                    指定した事業領域コードに対応する事業領域名

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    事業領域コードを指定して事業領域名を取得します。


BusinessAreaController オブジェクト

概要

事業領域の情報を取得します。

構造図
コンストラクタ
メソッド
getBusinessAreaList() | 事業領域一覧の取得
getBusArDes() | 事業領域名の取得


CompanyController()

  • プロトタイプ

    CompanyController()

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    引数なしコンストラクタ

getCompanyList()

  • プロトタイプ

    (Object[]) getCompanyList()

  • 入力値

    なし

  • 返却値

    Object[] 会社情報が格納された配列

  • 詳細

    会社情報一覧を取得します。取得した配列は２次元配列になっています。値を取得する 際に指定する配列のキー値は以下の通りです。

    [idx]["COMP_CODE"]　→　配列内のidx番目の会社の「会社コード」
    [idx]["COMP_NAME"]　→　配列内のidx番目の会社の「会社名」

    ※idxは0～n（配列サイズ-1）

getName()

  • プロトタイプ

    (Object) getName((String)compCode)

  • 入力値

    (String) compCode: SAP R/3上に存在する会社コード

  • 返却値

                    成功時
                    指定した会社コードに対応する会社名

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    会社コードを指定して会社名を取得します。


CompanyController オブジェクト

概要

会社の情報を取得します。

構造図
コンストラクタ
メソッド
getCompanyList() | 会社一覧の取得
getName() | 会社名の取得


ControllingAreaController()

  • プロトタイプ

    ControllingAreaController()

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    引数なしコンストラクタ

getControllingAreaList()

  • プロトタイプ

    (Object[]) getControllingAreaList()

  • 入力値

    なし

  • 返却値

    Object[] 管理領域情報が格納された配列

  • 詳細

    管理領域情報一覧を取得します。取得した配列は２次元配列になっています。値を取得する 際に指定する配列のキー値は以下の通りです。

    [idx]["CO_AREA"]　→　配列内のidx番目の管理領域の「管理領域コード」
    [idx]["NAME"]　→　配列内のidx番目の管理領域の「管理領域名」

    ※idxは0～n（配列サイズ-1）

getName()

  • プロトタイプ

    (Object) getName((String)coArea)

  • 入力値

    (String) coArea: SAP R/3上に存在する管理領域コード

  • 返却値

                    成功時
                    指定した管理領域コードに対応する管理領域名

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    管理領域コードを指定して管理領域名を取得します。


ControllingAreaController オブジェクト

概要

管理領域の情報を取得します。

構造図
コンストラクタ
メソッド
getControllingAreaList() | 管理領域一覧の取得
getName() | 管理領域名の取得


CostCenterController()

  • プロトタイプ

    CostCenterController((String)controllingArea)

  • 入力値

    (String) controllingArea: SAP R/3上に存在する管理領域コード

  • 返却値

    なし

  • 詳細

    引数１つコンストラクタ
    ※システム日付で有効な原価センタ情報が抽出対象となる。

CostCenterController()

  • プロトタイプ

    (Object) CostCenterController((String)controllingArea, (String)date)

  • 入力値

    (String) controllingArea: SAP R/3上に存在する管理領域コード
    (String) date: 有効期間(開始) ※日付書式「YYYYMMDD」

  • 返却値

    なし

  • 詳細

    引数２つコンストラクタ
    ※指定したYYYYMMDDの日付で有効な原価センタ情報が抽出対象となる。

getCostCenterList()

  • プロトタイプ

    (Object[]) getCostCenterList()

  • 入力値

    なし

  • 返却値

    Object[] 原価センタ情報が格納された配列

  • 詳細

    原価センタ情報一覧を取得します。取得した配列は２次元配列になっています。値を取得する 際に指定する配列のキー値は以下の通りです。

    [idx]["CONTROLLING_AREA"]　→　配列内のidx番目の原価センタの「管理領域コード」
    [idx]["COST_CENTER"]　→　配列内のidx番目の原価センタの「原価センタコード」
    [idx]["DESCRIPT"]　→　配列内のidx番目の原価センタの「一般名称」
    [idx]["NAME"]　→　配列内のidx番目の原価センタの「テキスト」

    ※idxは0～n（配列サイズ-1）

getName()

  • プロトタイプ

    (Object) getName((String)costCenter)

  • 入力値

    (String) costCenter: SAP R/3上に存在する原価センタコード

  • 返却値

                    成功時
                    指定した原価センタコードに対応する一般名称

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    原価センタコードを指定して一般名称を取得します。

getDescript()

  • プロトタイプ

    (Object) getDescript((String)costCenter)

  • 入力値

    (String) costCenter: SAP R/3上に存在する原価センタコード

  • 返却値

                    成功時
                    指定した原価センタコードに対応するテキスト

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    原価センタコードを指定してテキストを取得します。


CostCenterController オブジェクト

概要

原価センタの情報を取得します。

構造図
コンストラクタ(引数１つ)
コンストラクタ(引数２つ)
メソッド
getCostCenterList() | 原価センタ一覧の取得
getName() | 一般名称の取得
getDescript() | テキストの取得


GlAccController()

  • プロトタイプ

    GlAccController((String)companyCode)

  • 入力値

    (String) companyCode: SAP R/3上に存在する会社コード

  • 返却値

    なし

  • 詳細

    引数ありコンストラクタ

getGlAccList()

  • プロトタイプ

    (Object[] ) getGlAccList()

  • 入力値

    なし

  • 返却値

    Object[] 勘定科目情報が格納された配列

  • 詳細

    勘定科目情報一覧を取得します。取得した配列は２次元配列になっています。値を取得する 際に指定する配列のキー値は以下の通りです。

    [idx]["COMPANY_CODE"]　→　配列内のidx番目の勘定科目の「会社コード」
    [idx]["GL_ACCOUNT"]　→　配列内のidx番目の勘定科目の「G/L勘定コード」
    [idx]["SHORT_TEXT"]　→　配列内のidx番目の勘定科目の「G/L勘定コードテキスト(短)」
    [idx]["LONG_TEXT"]　→　配列内のidx番目の勘定科目の「総勘定元帳勘定テキスト(長)」

    ※idxは0～n（配列サイズ-1）

getShortText()

  • プロトタイプ

    (Object) getShortText((String)glAccount)

  • 入力値

    (String) glAccount: SAP R/3上に存在するG/L勘定コード

  • 返却値

                    成功時
                    指定したG/L勘定コードに対応するG/L勘定コードテキスト(短)

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。

getLongText()

  • プロトタイプ

    (Object) getLongText((String)glAccount)

  • 入力値

    (String) glAccount: SAP R/3上に存在するG/L勘定コード

  • 返却値

                    成功時
                    指定したG/L勘定コードに対応する総勘定元帳勘定テキスト(長)

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。


GlAccController オブジェクト

概要

勘定科目の情報を取得します。

構造図
コンストラクタ
メソッド
getGlAccList() | 勘定科目一覧の取得
getShortText() | G/L勘定コードテキスト(短)の取得
getLongText() | 総勘定元帳勘定テキスト(長)の取得


ProfitCenterController()

  • プロトタイプ

    ProfitCenterController((String)controllingArea)

  • 入力値

    (String) controllingArea: SAP R/3上に存在する管理領域コード

  • 返却値

    なし

  • 詳細

    引数１つコンストラクタ
    ※システム日付で有効な利益センタ情報が抽出対象となる。

ProfitCenterController()

  • プロトタイプ

    (Object) ProfitCenterController((String)controllingArea, (String)date)

  • 入力値

    (String) controllingArea: SAP R/3上に存在する管理領域コード
    (String) date: 日付 ※日付書式「YYYYMMDD」

  • 返却値

    なし

  • 詳細

    引数２つコンストラクタ
    ※指定したYYYYMMDDの日付で有効な利益センタ情報が抽出対象となる。

getProfitCenterList()

  • プロトタイプ

    (Object[]) getProfitCenterList()

  • 入力値

    なし

  • 返却値

    Object[] 利益センタ情報が格納された配列

  • 詳細

    利益センタ情報一覧を取得します。取得した配列は２次元配列になっています。値を取得する 際に指定する配列のキー値は以下の通りです。

    [idx]["CONTROLLING_AREA"]　→　配列内のidx番目の利益センタの「管理領域コード」
    [idx]["PROFIT_CTR"]　→　配列内のidx番目の利益センタの「利益センタコード」
    [idx]["VALID_TO"]　→　配列内のidx番目の利益センタの「有効終了日」
    [idx]["IN_CHARGE"]　→　配列内のidx番目の利益センタの「利益センタ責任者」
    [idx]["PCTR_NAME"]　→　配列内のidx番目の利益センタの「一般名称」

    ※idxは0～n（配列サイズ-1）

getValidTo()

  • プロトタイプ

    (Object) getValidTo((String)profitCtr)

  • 入力値

    (String) profitCtr: SAP R/3上に存在する利益センタコード

  • 返却値

                    成功時
                    指定した利益センタコードに対応する有効終了日

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    利益センタコードを指定して有効終了日を取得します。

getPctrName()

  • プロトタイプ

    (Object) getPctrName((String)profitCtr)

  • 入力値

    (String) profitCtr: SAP R/3上に存在する利益センタコード

  • 返却値

                    成功時
                    指定した利益センタコードに対応する一般名称

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    利益センタコードを指定して一般名称を取得します。

getInCharge()

  • プロトタイプ

    (Object) getInCharge((String)profitCtr)

  • 入力値

    (String) profitCtr: SAP R/3上に存在する利益センタコード

  • 返却値

                    成功時
                    指定した利益センタコードに対応する利益センタ責任者

                失敗時
                    エラー情報オブジェクト
                    Object[]
                        ├ERRCODE    //エラーコード
                        ｜             1:認証系システムエラー
                        ｜             2:認証系アプリケーションエラー
                        ｜             3:汎用系システムエラー
                        ｜             4:汎用系アプリケーションエラー
                        ｜             5:会計業務系システムエラー
                        ｜             6:会計業務系アプリケーションエラー
                        ├ERRMSG     //アプリケーション例外(システム例外)のメッセージ概要
                        ｜
                        └ERRDESC    //システム例外のメッセージ詳細

  • 詳細

    利益センタコードを指定して利益センタ責任者を取得します。


ProfitCenterController オブジェクト

概要

利益センタの情報を取得します。

構造図
コンストラクタ(引数１つ)
コンストラクタ(引数２つ)
メソッド
getProfitCenterList() | 利益センタ一覧の取得
getValidTo() | 有効終了日の取得
getPctrName() | 一般名称の取得
getInCharge() | 利益センタ責任者の取得


intra-mart[Server side JavaScript intra-mart Documentation.[Function Container]]

i ntra-mart The Power for Enterprise Web Solution
ページベース開発モデル
ERP連携モジュール API 仕様
(BaseModule Advanced版のみ)

注意事項

このページでは、SAP R/3リアルタイム連携で利用する各ＡＰＩに関して、プログラム・インターフェースの詳細仕様を記載しています。

i ntra-mart で提供されているＡＰＩをオーバーライドした場合、i ntra-mart システム全体が動作しなくなる可能性があるので、無闇にメソッドの再定義をしないようにしてください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


APIリストメニュー

オブジェクト
AccEmployeePayPostController
BankController
BapiController
BusinessAreaController
CompanyController
ControllingAreaController
CostCenterController
GlAccController
ProfitCenterController


intra-mart[intra-mart Documentation.[Portal Module]]

i ntra-mart The Power for Enterprise Web Solution
intra-mart(R) ワークフローモジュール
API 仕様

概要

ワークフローモジュールにて提供されている ページベース開発用API では、 起票（申請）、承認、申請者へ差戻し、承認者へ差戻し、引戻しの処理系のAPIのほか、 各フロー状況に応じた案件の取得、管理者用のためのフロー制御等さまざまなAPIを 提供しております。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


FlowInfo オブジェクト ＡＰＩ

FlowInfo()

  • プロトタイプ

    (Object) FlowInfo()

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    フロー情報オブジェクトを作成します。
    このオブジェクトは、WkfManager.getFlowInfo()を使用したときに返却されるオブジェクトです。

getProcessDefCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String) getProcessDefCd()

  • 概要

    プロセス定義コードを返却します。

  • 入力値

    なし

  • 返却値

    (String)プロセス定義コード

  • 詳細

    このフロー情報オブジェクトが保持するプロセス定義コードを返却します。

getVersionCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getVersionCd()

  • 概要

    バージョンコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)バージョンコード

  • 詳細

    このフロー情報オブジェクトが保持するバージョンコードを返却します。

getActivityCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getActivityCd()

  • 概要

    アクティビティコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)アクティビティコード

  • 詳細

    このフロー情報オブジェクトが保持するアクティビティコードを返却します。

getActivityType()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getActivityType()

  • 概要

    アクティビティ種別を返却します。

  • 入力値

    なし

  • 返却値

    (String)アクティビティ種別

  • 詳細

    このフロー情報オブジェクトが保持するアクティビティ種別を返却します。

    アクティビティ種別のコード値は以下のようになります。
  レシーブ(処理タスク)　　　 :1
  プロセス呼出(サブプロセス) :2
  自動呼出(自動実行タスク)　 :3
  フロー(同期タスク)　　　　 :5
  ターミネート(終了タスク)　 :6
  エンプティ(手動タスク)　　 :7
  スイッチ(分岐タスク)　　　 :8
  イベント(イベント実行)　　 :9
  ルート選択のタスク　　　　 :A

getIsSubProcess()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getIsSubProcess()

  • 概要

    サブプロセスフラグを返却します。

  • 入力値

    なし

  • 返却値

    (boolean)サブプロセスフラグ

  • 詳細

    このフロー情報オブジェクトが保持するサブプロセスフラグを返却します。
    サブプロセスの場合、trueが返却される。

getEndFlg()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getEndFlg()

  • 概要

    同期・分岐終了フラグを返却します。

  • 入力値

    なし

  • 返却値

    (boolean)同期・分岐終了フラグ

  • 詳細

    このフロー情報オブジェクトが保持する同期・分岐終了フラグを返却します。
    「同期・分岐終了フラグ」は分岐と同期の終わる時点を表示するフラグです。
    分岐・同期の終了タスクの場合、trueを返却します。

hasNext()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)hasNext()

  • 概要

    次のタスクが存在するかどうかを返却します。

  • 入力値

    なし

  • 返却値

    (boolean)存在する場合：true/存在しない場合：false

  • 詳細

    このフロー情報オブジェクトが保持するタスク情報の次のタスクが存在するかどうかを返却します。

hasPrev()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)hasPrev()

  • 概要

    前のタスクが存在するかどうかを返却します。

  • 入力値

    なし

  • 返却値

    (boolean)存在する場合：true/存在しない場合：false

  • 詳細

    このフロー情報オブジェクトが保持するタスク情報の前のタスクが存在するかどうかを返却します。

getNext()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getNext()

  • 概要

    自分自身のオブジェクトを、次のタスクに位置している状態に遷移します。

  • 入力値

    なし

  • 返却値

    (FlowInfo)フロー情報オブジェクト

  • 詳細

    自分自身のオブジェクトの次のタスクのフロー情報を返却します。

getPrev()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getPrev()

  • 概要

    自分自身のオブジェクトを、前のタスクに位置している状態に遷移します。

  • 入力値

    なし(必須)

  • 返却値

    (FlowInfo)フロー情報オブジェクト

  • 詳細

    自分自身のオブジェクトの前のタスクのフロー情報を返却します。

getFirst()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getFirst()

  • 概要

    自分自身のオブジェクトを、最初のタスクに位置している状態に遷移します。

  • 入力値

    なし

  • 返却値

    (FlowInfo)フロー情報オブジェクト

  • 詳細

    最初のタスクに位置しているタスクのフロー情報オブジェクトを返却します。

getLast()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getLast()

  • 概要

    自分自身のオブジェクトを、最後のタスクに位置している状態に遷移します。

  • 入力値

    なし

  • 返却値

    (FlowInfo)フロー情報オブジェクト

  • 詳細

    最後のタスクに位置しているタスクのフロー情報オブジェクトを返却します。


FlowInfo オブジェクト

概要

フロー情報オブジェクト

構造図
コンストラクタ
メソッド
getProcessDefCd() | プロセス定義コードの取得
getVersionCd() | バージョンコードの取得
getActivityCd() | アクティビティコードの取得
getActivityType() | アクティビティ種別の取得
getIsSubProcess() | サブプロセスフラグの取得
getEndFlg() | 同期・分岐終了フラグの取得
hasNext() | 次のタスクが存在するかどうかを返却します
hasPrev() | 前のタスクが存在するかどうかを返却します
getNext() | 自分自身のオブジェクトを、次のタスクに位置している状態に遷移します
getPrev() | 自分自身のオブジェクトを、前のタスクに位置している状態に遷移します
getFirst() | 自分自身のオブジェクトを、最初のタスクに位置している状態に遷移します
getLast() | 自分自身のオブジェクトを、最後のタスクに位置している状態に遷移します


GetRootInfoEventObject オブジェクト ＡＰＩ

コンストラクタ

  • プロトタイプ

    (Object) GetRootInfoEventObject()

  • 入力値

    なし

  • 詳細

    アクティビティ情報取得用、オブジェクトを初期化します。

fire()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)fire()

  • 概要

    アクティビティ情報取得処理を行います。

  • 入力値

    なし

  • 返却値

    (String)処理結果
    処理成功：””(空文字)
    処理失敗：BPWErrorCodeIFで定義された定義値

  • 詳細

    設定された条件のアクティビティ情報を取得します。
    アクティビティ情報は、ルートの階層による取得を行います。
    アクティビティ情報取得処理をする為には、最低以下のメソッドを呼び出しておく必要があります。
    【必須】
    ・setProcessDefCd
    ・setVersionCd
    ・setProcessCd
    ・setLoginGroupId
    ・setLoginUserId

setLoginUserId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginUserId((String)loginUserid)

  • 概要

    ログインユーザＩＤを設定します。

  • 入力値

    (String) loginUserid: ログインユーザＩＤ

  • 返却値

    なし。

  • 詳細

    【必須】ログインユーザＩＤを設定します。

setLoginGroupId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginGroupId((String)loginGroupid)

  • 概要

    ログイングループＩＤを設定します。

  • 入力値

    (String) loginGroupid: ログイングループ

  • 返却値

    なし。

  • 詳細

    【必須】ログイングループＩＤを設定します。

setProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessDefCd((String)processdefcd)

  • 概要

    プロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: プロセス定義コード

  • 返却値

    なし。

  • 詳細

    【必須】プロセス定義コードを設定します。

setVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setVersionCd((String)versioncd)

  • 概要

    履歴コードを設定します。

  • 入力値

    (String) versioncd: 履歴コード

  • 返却値

    なし。

  • 詳細

    【必須】履歴コードを設定します。

setProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCd((String)processcd)

  • 概要

    プロセスコードを設定します。

  • 入力値

    (String) processcd: プロセスコード

  • 返却値

    なし。

  • 詳細

    【必須】プロセスコードを設定します。

getResult()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getResult()

  • 概要

    エラーコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)エラーコード

  • 詳細

    エラーコードを返却します。
    エラーコードは、BPWErrorCodeIFで定義された定義値です。
    エラーでない場合は、””(空文字)が返却されます。

getLoginUserId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginUserId()

  • 概要

    ログインユーザＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログインユーザＩＤ

  • 詳細

    現在は使用されていません。
    ログインユーザＩＤを返却します。

getLoginGroupId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginGroupId()

  • 概要

    ログイングループＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログイングループＩＤ

  • 詳細

    現在は使用されていません。
    ログイングループＩＤを返却します。

getProcessInfo()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getUserAppKeysNoCd()

  • 概要

    プロセス情報を返却します。

  • 入力値

    なし

  • 返却値

    プロセス情報オブジェクト

  • 詳細

    設定された条件に対するプロセス情報を取得します。
    プロセス情報オブジェクト
├process_def_cd       // プロセス定義CD(String)
├version_cd           // 履歴CD(String)
├process_cd           // プロセスCD(String)
├process_name         // プロセス名(String)
├draft_date           // 起票日(String)
├draft_user_cd        // 起票者CD(String)
├draft_user_name      // 起票者名(String)
├draft_comment        // 起票時コメント(String)
├process_status       // プロセスステータス(String)
├last_man_activ_cd    // 最終手動アクティビティCD(String)
├last_call_process_def_cd  // 最終呼出しプロセス定義CD(String)
├last_call_version_cd      // 最終呼出し履歴CD(String)
├last_call_process_cd      // 最終呼出しプロセスCD(String)
├call_process_def_cd  // 呼出プロセス定義CD(String)
├call_version_cd      // 呼出履歴CD(String)
├call_process_cd      // 呼出プロセスCD(String)
├call_activity_cd     // 呼出処理CD(String)
├extension_a          // 拡張エリアA(String)
├extension_b          // 拡張エリアB(String)
├extension_c          // 拡張エリアC(String)
├extension_d          // 拡張エリアD(String)
├extension_e          // 拡張エリアE(String)
├extension_f          // 拡張エリアF(String)
├extension_g          // 拡張エリアG(String)
├extension_h          // 拡張エリアH(String)
├create_date          // 作成日時(String)
├create_user_cd       // 作成者CD(String)
├create_user_name     // 作成者名(String)
├record_date          // 最終更新日時(String)
├record_user_cd       // 最終更新者CD(String)
├record_user_name     // 最終更新者名(String)
├record_count         // レコードカウンター(String)

getFirst()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getFirst()

  • 概要

    親アクティビティ情報を返却します。

  • 入力値

    なし

  • 返却値

    (Object)アクティビティ情報

  • 詳細

    設定された条件で取得されたルートの親アクティビティ情報オブジェクトを返却します。

getChildActivityCdList()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getChildActivityCdList()

  • 概要

    カレントターゲットアクティビティ情報に対する
    子アクティビティ情報のアクティビティコード一覧を返却します。

  • 入力値

    なし

  • 返却値

    アクティビティコード一覧(配列型)

  • 詳細

    ルートの現在ターゲットとなっているアクティビティ情報に対する
    子アクティビティ情報のアクティビティコード一覧を返却します。

getTarget()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getTarget(String ActivityCd)

  • 概要

    指定するアクティビティコードに対応する
    アクティビティ情報を返却します。

  • 入力値

    (String) ActivityCd: アクティビティコード

  • 返却値

    (Object)アクティビティ情報

  • 詳細

    指定したアクティビティコードに対応する
    アクティビティ情報オブジェクトを返却します。

アクティビティ情報オブジェクト

    指定されたアクティビティコードに対応するアクティビティ情報オブジェクトを返却します。

    アクティビティ情報オブジェクト
├process_def_cd	// プロセス定義CD(String)
├version_cd		// 履歴CD(String)
├process_cd		// プロセスCD(String)
├activity_cd		// アクティビティCD(String)
├activity_name		// アクティビティ名(String)
├actiity_type_cd	// アクティビティ種別CD(String)
├activity_status	// アクティビティステータス(String)
├status_ended_date	// ステータス完了日付(String)
├call_activity_cd	// 呼出アクティビティCD
├call_activity_type	// 呼出アクティビティ種別
├before_process_def_cd	// 前処理プロセス定義CD(String)
├before_version_cd	// 前処理履歴CD(String)
├before_process_cd	// 前処理プロセスCD(String)
├before_approval_type	// 前処理結果(String)
├before_kind		// 前処理種別(String)
├result_notice_flag	// 結果通知フラグ(String)
├auto_pass_term	// 自動パス期限(String)
├auto_pass_flag	// 自動パス処理フラグ(String)
├attainment_class	// 到達種別(String)
├reception_date	// 受信日付(String)
├process_term_date	// 処理期限日付(String)
├present_process	// 現処理表示文字(String)
├bef_acti_cd		// 前処理アクティビティCD(String)
├bef_acti_name		// 前処理アクティビティ名(String)
├bef_acti_user_cd	// 前処理者CD(String)
├bef_acti_user_name	// 前処理者名(String)
├compulsion_end_flg	// 強制終了可否フラグ(String)
├return_mail_flag	// 引戻し・差戻しメール送信フラグ(String)
├return_flag		// 引戻し・差戻し可否フラグ(String)

// （以下、レシーブ情報。存在しない場合はnullを返却。）
├receive_comment	// コメント(String)
├mail_flag		// メール送信フラグ(String)
├approval_user_cd	// 承認者CD(String)
├approval_user_name	// 承認者名(String)
├approval_type		// 承認結果種別(String)
├transfer_flag		// 代理承認フラグ(String)
├delegate_flag		// 振り替えフラグ(String)

// （以下、自動パス情報。存在しない場合はnullを返却。）
├auto_pass (Object)	// 自動パス情報オブジェクト(配列型)
    ├user_cd	// ユーザCD(String)
    ├user_name	// ユーザ名(String)

// （以下、実行主体ユーザ情報。存在しない場合はnullを返却。）
├run_user (Object)	// 実行主体ユーザオブジェクト(配列型)
    ├user_cd		// ユーザCD(String)
    ├user_name		// ユーザ名(String)
    ├delegate_user_cd	// 振り替え元ユーザCD(String)
    ├delegate_user_name	// 振り替え元ユーザ名(String)


GetRootInfoEventObject オブジェクト

概要

アクティビティ情報の取得を行います。

構造図
コンストラクタ
メソッド
fire() | アクティビティ情報の取得処理を行います。
setLoginUserId() | ログインユーザＩＤを設定します。
setLoginGroupId() | ログイングループＩＤを設定します。
setProcessDefCd() | プロセス定義コードを設定します。
setVersionCd() | 履歴コードを設定します。
setProcessCd() | プロセスコードを設定します。
getResult() | エラーコードを返却します。
getLoginUserId() | ログインユーザＩＤを返却します。
getLoginGroupId() | ログイングループＩＤを返却します。
getProcessInfo() | プロセス情報を返却します。
getFirst() | 親アクティビティ情報を返却します。
getChildActivityCdList() | 現在のターゲットの子階層のアクティビティコードを配列で返却します。
getTarget() | アクティビティ情報のアクティビティコードに対応するアクティビティ情報を返却します。


GetUserApplicationKeyEventObject オブジェクト ＡＰＩ

コンストラクタ

  • プロトタイプ

    (Object) GetUserApplicationKeyEventObject()

  • 入力値

    なし

  • 詳細

    ユーザアプリケーションキー取得用、オブジェクトを初期化します。

fire()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)fire()

  • 概要

    ユーザアプリケーションキー取得処理を行います。

  • 入力値

    なし

  • 返却値

    (String)処理結果
    処理成功：””(空文字)
    処理失敗：BPWErrorCodeIFで定義された定義値

  • 詳細

    設定された条件のユーザアプリケーションキーを取得します。
    ユーザアプリケーションキー取得処理をする為には、最低以下のメソッドを呼び出しておく必要があります。
    【必須】
    ・setProcessDefCd
    ・setVersionCd
    ・setProcessCd
    ・setLoginGroupId
    ・setLoginUserId

setLoginUserId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginUserId((String)loginUserid)

  • 概要

    ログインユーザＩＤを設定します。

  • 入力値

    (String) loginUserid: ログインユーザＩＤ

  • 返却値

    なし。

  • 詳細

    【必須】ログインユーザＩＤを設定します。

setLoginGroupId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginGroupId((String)loginGroupid)

  • 概要

    ログイングループＩＤを設定します。

  • 入力値

    (String) loginGroupid: ログイングループ

  • 返却値

    なし。

  • 詳細

    【必須】ログイングループＩＤを設定します。

setProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessDefCd((String)processdefcd)

  • 概要

    プロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: プロセス定義コード

  • 返却値

    なし。

  • 詳細

    【必須】プロセス定義コードを設定します。

setVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setVersionCd((String)versioncd)

  • 概要

    履歴コードを設定します。

  • 入力値

    (String) versioncd: 履歴コード

  • 返却値

    なし。

  • 詳細

    【必須】履歴コードを設定します。

setProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCd((String)processcd)

  • 概要

    プロセスコードを設定します。

  • 入力値

    (String) processcd: プロセスコード

  • 返却値

    なし。

  • 詳細

    【必須】プロセスコードを設定します。

getResult()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getResult()

  • 概要

    エラーコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)エラーコード

  • 詳細

    エラーコードを返却します。
    エラーコードは、BPWErrorCodeIFで定義された定義値です。
    エラーでない場合は、””(空文字)が返却されます。

getLoginUserId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginUserId()

  • 概要

    ログインユーザＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログインユーザＩＤ

  • 詳細

    現在は使用されていません。
    ログインユーザＩＤを返却します。

getLoginGroupId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginGroupId()

  • 概要

    ログイングループＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログイングループＩＤ

  • 詳細

    現在は使用されていません。
    ログイングループＩＤを返却します。

getUserAppKeysNoCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getUserAppKeysNoCd()

  • 概要

    ユーザアプリケーションキー情報（番号・コード）を返却します。

  • 入力値

    なし

  • 返却値

    (String)ユーザアプリケーションキー情報（番号・コード）

  • 詳細

    ユーザアプリケーションキー情報（番号・コード）を返却します。
    パラメータ番号,パラメータコードをコンマ区切りの文字列で返却します。
    （パラメータ番号1,パラメータコード1,パラメータ番号2,パラメータコード2,・・・・）

getUserAppKeyNo()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getUserAppKeyNo()

  • 概要

    ユーザアプリケーションキー情報（番号）を返却します。

  • 入力値

    なし

  • 返却値

    (String)ユーザアプリケーションキー情報（番号）

  • 詳細

    ユーザアプリケーションキー情報（番号）を返却します。
    パラメータ番号をコンマ区切りの文字列で返却します。
    （パラメータ番号1,パラメータ番号2,パラメータ番号3,・・・・）

getUserAppKeyCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getUserAppKeyCd()

  • 概要

    ユーザアプリケーションキー情報（コード）を返却します。

  • 入力値

    なし

  • 返却値

    (String)ユーザアプリケーションキー情報（コード）

  • 詳細

    ユーザアプリケーションキー情報（コード）を返却します。
    パラメータコードをコンマ区切りの文字列で返却します。
    （パラメータコード1,パラメータコード2,パラメータコード3,・・・・）

getUserAppKeyPrmCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getUserAppKeyPrmCd(String parameterNo)

  • 概要

    ユーザアプリケーションキー情報のパラメータ番号に対応する
    パラメータコードを返却します。

  • 入力値

    (String) parameterNo: パラメータ番号

  • 返却値

    (String)ユーザアプリケーションキー情報：パラメータコード

  • 詳細

    ユーザアプリケーションキー情報のパラメータ番号に対応する
    パラメータコードを返却します。


GetUserApplicationKeyEventObject オブジェクト

概要

ユーザアプリケーションキーの取得を行います。。

構造図
コンストラクタ
メソッド
fire() | ユーザアプリケーションキー取得処理を行います。
setLoginUserId() | ログインユーザＩＤを設定します。
setLoginGroupId() | ログイングループＩＤを設定します。
setProcessDefCd() | プロセス定義コードを設定します。
setVersionCd() | 履歴コードを設定します。
setProcessCd() | プロセスコードを設定します。
getResult() | エラーコードを返却します。
getLoginUserId() | ログインユーザＩＤを返却します。
getLoginGroupId() | ログイングループＩＤを返却します。
getUserAppKeysNoCd() | ユーザアプリケーションキー情報（番号・コード）を返却します。
getUserAppKeyNo() | ユーザアプリケーションキー情報（番号）を返却します。
getUserAppKeyCd() | ユーザアプリケーションキー情報（コード）を返却します。
getUserAppKeyPrmCd() ユーザアプリケーションキー情報のパラメータ番号に対応する
パラメータコードを返却します。


JavaScript API リスト概要

 JavaScript API リスト 概要

ページベース開発モデルで利用可能なJavaScript API の概要です。

オブジェクトの概要
UserTransaction | データベーストランザクションのAPI。
WkfApprover | 承認関連のAPI。
WkfDrafter | 起票関連のAPI。
WkfFlowInfo | フロー情報オブジェクトAPI。
WkfMailSettingBehavior | プログラムサポート/メール送信 リザーブフラグ設定クラス。
WkfManager | マスタ関連のAPI。
WkfProcess | 案件関連のAPI。
WkfReference | 参照関連のAPI。
WkfSearchCondition | プログラムサポート/検索条件設定オブジェクト。
WkfSort | プログラムサポート/ソート指定オブジェクト。
WkfUtil | ユーティリティ関連のAPI。


JavaScript API リスト

 オブジェクト
UserTransaction
WkfApprover
WkfDrafter
WkfFlowInfo
WkfMailSettingBehavior
WkfManager
WkfProcess
WkfReference
WkfSearchCondition
WkfSort
WkfUtil


APIリストメニュー

オブジェクト
PullActivityEventObject
RecognitionEventObject
RegistProcessEventObject
ReturnDraftEventObject
ReturnStartEventObject
GetUserApplicationKeyEventObject
RegistUserApplicationKeyEventObject
GetRootInfoEventObject


PullActivityEventObject オブジェクト ＡＰＩ

コンストラクタ

  • プロトタイプ

    (Object) PullActivityEventObject()

  • 入力値

    なし

  • 詳細

    引戻し用のオブジェクトを、初期化します。

fire()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)fire()

  • 概要

    引戻し処理を行います。

  • 入力値

    なし

  • 返却値

    (String)処理結果
    処理成功：””(空文字)
    処理失敗：BPWErrorCodeIFで定義された定義値

  • 詳細

    設定された内容のアクティビティを引戻します。
    引戻し処理をする為には、最低以下のメソッドを呼び出しておく必要があります。
    【必須】
    ・setProcessDefCd
    ・setVersionCd
    ・setProcessCd
    ・setActivityCd(Completed Activity)
    ・setLoginGroupId
    ・setLoginUserId

setLoginUserId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginUserId((String)loginUserid)

  • 概要

    ログインユーザＩＤを設定します。

  • 入力値

    (String) loginUserid: ログインユーザＩＤ

  • 返却値

    なし。

  • 詳細

    【必須】ログインユーザＩＤを設定します。

setLoginGroupId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginGroupId((String)loginGroupid)

  • 概要

    ログイングループＩＤを設定します。

  • 入力値

    (String) loginGroupid: ログイングループ

  • 返却値

    なし。

  • 詳細

    【必須】ログイングループＩＤを設定します。

setProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessDefCd((String)processdefcd)

  • 概要

    プロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: プロセス定義コード

  • 返却値

    なし。

  • 詳細

    【必須】プロセス定義コードを設定します。

setVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setVersionCd((String)versioncd)

  • 概要

    履歴コードを設定します。

  • 入力値

    (String) versioncd: 履歴コード

  • 返却値

    なし。

  • 詳細

    【必須】履歴コードを設定します。

setProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCd((String)processcd)

  • 概要

    プロセスコードを設定します。

  • 入力値

    (String) processcd: プロセスコード

  • 返却値

    なし。

  • 詳細

    【必須】プロセスコードを設定します。

setActivityCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setActivityCd((String)activitycd)

  • 概要

    アクティビティコードを設定します。

  • 入力値

    (String) activitycd: アクティビティコード

  • 返却値

    なし。

  • 詳細

    【必須】アクティビティコードを設定します。
    設定するアクティビティコードは、引戻し元アクティビティコードです。

setApprovalUserCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalUserCd((String)approvalUsercd)

  • 概要

    承認者コードを設定します。

  • 入力値

    (String) setApprovalUserCd: 承認者コード

  • 返却値

    なし。

  • 詳細

    【必須】
    承認者コードを設定します。
    代理による再申請、代理による承認の場合は本来処理を行うユーザの ユーザコードを設定して下さい。

setApprovalUserName()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalUserName((String)approvalUsername)

  • 概要

    承認者名を設定します。

  • 入力値

    (String) approvalUsername: 承認者名

  • 返却値

    なし。

  • 詳細

    承認者名を設定します。
    ＢＰＷ内部で設定されます。 通常は設定しないで下さい。

setReceiveComment()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setReceiveComment((String)receiveComment)

  • 概要

    承認時コメントを設定します。

  • 入力値

    (String) receiveComment: 承認時コメント

  • 返却値

    なし。

  • 詳細

    承認時コメントを設定します。

getResult()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getResult()

  • 概要

    エラーコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)エラーコード

  • 詳細

    エラーコードを返却します。
    エラーコードは、BPWErrorCodeIFで定義された定義値です。
    エラーでない場合は、””(空文字)が返却されます。

getLoginUserId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginUserId()

  • 概要

    ログインユーザＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログインユーザＩＤ

  • 詳細

    現在は使用されていません。
    ログインユーザＩＤを返却します。

getLoginGroupId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginGroupId()

  • 概要

    ログイングループＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログイングループＩＤ

  • 詳細

    現在は使用されていません。
    ログイングループＩＤを返却します。


PullActivityEventObject オブジェクト

概要

引戻し処理を行います。

構造図
コンストラクタ
メソッド
fire() | 引戻しを行います。
setLoginUserId() | ログインユーザＩＤを設定します。
setLoginGroupId() | ログイングループＩＤを設定します。
setProcessDefCd() | プロセス定義コードを設定します。
setVersionCd() | 履歴コードを設定します。
setProcessCd() | プロセスコードを設定します。
setActivityCd() | アクティビティコードを設定します。
setApprovalUserCd() | 承認者コードを設定します。
setApprovalUserName() | 承認者名を設定します。
setReceiveComment() | 承認時コメントを設定します。
getResult() | エラーコードを返却します。
getLoginUserId() | ログインユーザＩＤを返却します。
getLoginGroupId() | ログイングループＩＤを返却します。


RecognitionEventObject ＡＰＩ

コンストラクタ

  • プロトタイプ

    (Object) RecognitionEventObject ()

  • 入力値

    なし

  • 詳細

    処理(承認、否認、保留)用のオブジェクトを初期化します。

fire()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)fire()

  • 概要

    承認要求を受け付けて、指定されたアクティビティに対して処理を要求します。

  • 入力値

    なし

  • 返却値

    (String)処理結果
    処理成功：””(空文字)
    処理失敗：BPWErrorCodeIFで定義された定義値

  • 詳細

    承認要求を受け付けて、指定されたアクティビティに対して処理を要求します。
    処理をする為には、最低以下のメソッドを呼び出しておく必要があります。
    【必須】
    ・setProcessDefCd
    ・setVersionCd
    ・setProcessCd
    ・setActivityCd(Completed Activity)
    ・setApprovalType ・setTransferFlg ・setLoginGroupId
    ・setLoginUserId

setLoginUserId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginUserId((String)loginUserid)

  • 概要

    ログインユーザＩＤを設定します。

  • 入力値

    (String) loginUserid: ログインユーザＩＤ

  • 返却値

    なし。

  • 詳細

    【必須】ログインユーザＩＤを設定します。

setLoginGroupId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginGroupId((String)loginGroupid)

  • 概要

    ログイングループＩＤを設定します。

  • 入力値

    (String) loginGroupid: ログイングループ

  • 返却値

    なし。

  • 詳細

    【必須】ログイングループＩＤを設定します。

setProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessDefCd((String)processdefcd)

  • 概要

    プロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: プロセス定義コード

  • 返却値

    なし。

  • 詳細

    【必須】プロセス定義コードを設定します。

setVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setVersionCd((String)versioncd)

  • 概要

    履歴コードを設定します。

  • 入力値

    (String) versioncd: 履歴コード

  • 返却値

    なし。

  • 詳細

    【必須】履歴コードを設定します。

setProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCd((String)processcd)

  • 概要

    プロセスコードを設定します。

  • 入力値

    (String) processcd: プロセスコード

  • 返却値

    なし。

  • 詳細

    【必須】プロセスコードを設定します。

setActivityCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setActivityCd((String)activitycd)

  • 概要

    アクティビティコードを設定します。

  • 入力値

    (String) activitycd: アクティビティコード

  • 返却値

    なし。

  • 詳細

    【必須】アクティビティコードを設定します。

setApprovalUserCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalUserCd((String)approvalUsercd)

  • 概要

    承認者コードを設定します。

  • 入力値

    (String) setApprovalUserCd: 承認者コード

  • 返却値

    なし。

  • 詳細

    【必須】
    承認者コードを設定します。
    代理による再申請、代理による承認の場合は本来処理を行うユーザの ユーザコードを設定して下さい。

setApprovalUserName()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalUserName((String)approvalUsername)

  • 概要

    承認者名を設定します。

  • 入力値

    (String) approvalUsername: 承認者名

  • 返却値

    なし。

  • 詳細

    承認者名を設定します。
    ＢＰＷ内部で設定されます。 通常は設定しないで下さい。

setApprovalType()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalType((String)approvalType)

  • 概要

    承認種別を設定します。

  • 入力値

    (String) approvalType: 承認種別

    設定する値は、RecognitionInfoModelで定義されている以下の値です。
      申請　　：　RecognitionInfoModel.APPLY
  承認　　：　RecognitionInfoModel.RECOGNITION
  否認　　：　RecognitionInfoModel.REJECTION
  再申請　：　RecognitionInfoModel.RETRY
  保留　　：　RecognitionInfoModel.SUSPENSION

  • 返却値

    なし。

  • 詳細

    【必須】承認種別を設定します。

setTransferFlg()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setTransferFlg((String)transferFlg)

  • 概要

    代理フラグを設定します。

  • 入力値

    (String) transferFlg: 代理フラグ

    設定する値は、ProcessInfoModelで定義されている以下の値です。
      代理承認　：　ProcessInfoModel.TRANSFER_ON
  承認　　　：　ProcessInfoModel.TRANSFER_OFF

  • 返却値

    なし。

  • 詳細

    【必須】代理フラグを設定します。

setRollSelectFlg()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setRollSelectFlg((String)roleselect)

  • 概要

    ロール絞込み指定フラグを設定します。

  • 入力値

    (String) roleselect: ロール絞込みフラグ

    設定する値は、RecognitionInfoModelで定義されている以下の値です。
      絞込みあり　：　RecognitionInfoModel.ROLL_SELECT_ON
  絞込みなし　：　RecognitionInfoModel.ROLL_SELECT_OFF

  • 返却値

    なし。

  • 詳細

    ロール絞込み指定フラグを設定します。

setRunUserInfoModel()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setRunUserInfoModel((String) processDefCd,(String) versionCd,(String) activityCd,(String) userCd)

  • 概要

    実行時選択時実行主体ユーザマスタ情報を設定します。

  • 入力値

    (String)processDefCd: プロセス定義コード
    (String)versionCd: 履歴コード
    (String)activityCd: アクティビティコード(実行時選択アクティビティコード)
    (String)userCd: ユーザコード

  • 返却値

    なし。

  • 詳細

    実行時選択時実行主体ユーザマスタ情報を設定します。
    実行時選択時に、登録する実行主体ユーザ情報を設定してください。
    次が実行時選択の場合は、
    setRunUserInfoModel() か setRunExecuteInfoModel()
    のどちらか一方が必須項目となります。

setRunExecuteInfoModel()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setRunExecuteInfoModel((String) processDefCd,(String) versionCd,(String) activityCd,(String) postCd,(String) postCdKind)

  • 概要

    実行時選択時実行主体役職マスタテーブルを設定します。

  • 入力値

    (String)processDefCd: プロセス定義コード
    (String)versionCd: 履歴コード
    (String)activityCd: アクティビティコード
    (String)postCd: 組織コード
    (String)postCdKind: コード種別

      設定する値は、RunExecutiveInfoModel で定義されている以下の値です。

    組織(オフィシャルグループ)　：　RunExecutiveInfoModel.POST_TYPE_GROUPING
    ロール　　　　　　　　　　　：　RunExecutiveInfoModel.POST_TYPE_ROLE
    役職　　　　　　　　　　　　：　RunExecutiveInfoModel.POST_TYPE_ORG

  • 返却値

    なし。

  • 詳細

    実行時選択時実行主体役職マスタテーブルを設定します。
    実行時選択時に、登録する実行主体役職情報を設定してください。
    次が実行時選択の場合は、
    setRunUserInfoModel() か setRunExecuteInfoModel()
    のどちらか一方が必須項目となります。

addUserAppliKey()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)addUserAppliKey((Number) i,(String) processDefCd,(String) versionCd,(String) processCd,(String) parameterCd)

  • 概要

    指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。

  • 入力値

    (Number) i：パラメータ番号
    (String) processDefCd：プロセス定義コード
    (String) versionCd：履歴コード
    (String) processCd：プロセスコード
    (String) parameterCd：パラメータコード値

  • 返却値

    なし。

  • 詳細

    指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
    指定されたパラメータ番号でユーザアプリケーションキーテーブル情報リストにマップします。
    また、setApprovalType()に、申請、再申請以外の値を設定した場合、この設定は無視されます。

    以下のパラメータは、現在使用されていません。
    すべて、""を設定してください。
      ・プロセス定義コード
      ・履歴コード
      ・プロセスコード

setReceiveComment()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setReceiveComment((String)receiveComment)

  • 概要

    承認時コメントを設定します。

  • 入力値

    (String) receiveComment: 承認時コメント

  • 返却値

    なし。

  • 詳細

    承認時コメントを設定します。

getResult()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getResult()

  • 概要

    エラーコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)エラーコード

  • 詳細

    エラーコードを返却します。
    エラーコードは、BPWErrorCodeIFで定義された定義値です。
    エラーでない場合は、””(空文字)が返却されます。

getLoginUserId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginUserId()

  • 概要

    ログインユーザＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログインユーザＩＤ

  • 詳細

    現在は使用されていません。
    ログインユーザＩＤを返却します。

getLoginGroupId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginGroupId()

  • 概要

    ログイングループＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログイングループＩＤ

  • 詳細

    現在は使用されていません。
    ログイングループＩＤを返却します。


RecognitionEventObject オブジェクト

概要

画面からの承認要求を受け付けます。

構造図
コンストラクタ
メソッド
fire() | 承認要求を受け付けて、指定されたアクティビティに対して処理を実行します。
setLoginUserId() | ログインユーザＩＤを設定します。
setLoginGroupId() | ログイングループＩＤを設定します。
setProcessDefCd() | プロセス定義コードを設定します。
setVersionCd() | 履歴コードを設定します。
setProcessCd() | プロセスコードを設定します。
setActivityCd() | アクティビティコードを設定します。
setApprovalUserCd() | 承認者コードを設定します。
setApprovalUserName() | 承認者名を設定します。
setApprovalType() | 承認種別を設定します。
setTransferFlg() | 代理フラグを設定します。
setRollSelectFlg() | ロール絞込み指定フラグを設定します。
setRunUserInfoModel() | 実行時選択時実行主体ユーザマスタ情報を設定します。
setRunExecuteInfoModel() | 実行時選択時実行主体役職マスタテーブルを設定します。
setReceiveComment() | 承認時コメントを設定します。
addUserAppliKey() | 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
getResult() | エラーコードを返却します。
getLoginUserId() | ログインユーザＩＤを返却します。
getLoginGroupId() | ログイングループＩＤを返却します。


RegistProcessEventObject オブジェクト ＡＰＩ

コンストラクタ

  • プロトタイプ

    (Object) RegistProcessEventObject()

  • 入力値

    なし

  • 詳細

    申請用のオブジェクトを、初期化します。

fire()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)fire()

  • 概要

    プロセス情報を登録します。

  • 入力値

    なし

  • 返却値

    (String)処理結果
    処理成功：””(空文字)
    処理失敗：BPWErrorCodeIFで定義された定義値

  • 詳細

    プロセス情報を登録します。。
    処理をする為には、最低以下のメソッドを呼び出しておく必要があります。
    【必須】
    ・setProcessDefCd
    ・setVersionCd
    ・setTransferFlg
    ・setProcessName
    ・setDraftUserCd
    ・setLoginGroupId
    ・setLoginUserId

setLoginUserId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginUserId((String)loginUserid)

  • 概要

    ログインユーザＩＤを設定します。

  • 入力値

    (String) loginUserid: ログインユーザＩＤ

  • 返却値

    なし。

  • 詳細

    【必須】ログインユーザＩＤを設定します。

setLoginGroupId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginGroupId((String)loginGroupid)

  • 概要

    ログイングループＩＤを設定します。

  • 入力値

    (String) loginGroupid: ログイングループ

  • 返却値

    なし。

  • 詳細

    【必須】ログイングループＩＤを設定します。

setProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessDefCd((String)processdefcd)

  • 概要

    プロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: プロセス定義コード

  • 返却値

    なし。

  • 詳細

    【必須】プロセス定義コードを設定します。

setVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setVersionCd((String)versioncd)

  • 概要

    履歴コードを設定します。

  • 入力値

    (String) versioncd: 履歴コード

  • 返却値

    なし。

  • 詳細

    【必須】履歴コードを設定します。

setProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCd((String)processcd)

  • 概要

    プロセスコードを設定します。

  • 入力値

    (String) processcd: プロセスコード

  • 返却値

    なし。

  • 詳細

    【必須】プロセスコードを設定します。

setTransferFlg()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setTransferFlg((String)transferFlg)

  • 概要

    代理フラグを設定します。

  • 入力値

    (String) transferFlg: 代理フラグ

    設定する値は、ProcessInfoModelで定義されている以下の値です。
      代理承認　：　ProcessInfoModel.TRANSFER_ON
  承認　　　：　ProcessInfoModel.TRANSFER_OFF

  • 返却値

    なし。

  • 詳細

    【必須】代理フラグを設定します。

setProcessName()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessName((String)processname)

  • 概要

    プロセス名を設定します。

  • 入力値

    (String) processname: プロセス名

  • 返却値

    なし。

  • 詳細

    【必須】プロセス名を設定します。

setDraftUserCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setDraftUserCd((String)draftUsercd)

  • 概要

    起票者コードを設定します。

  • 入力値

    (String) draftUsercd: 起票者コード

  • 返却値

    なし。

  • 詳細

    【必須】
    起票者コードを設定します。
    代理による申請を行うばあい、本来処理するユーザの ユーザコードを設定して下さい。

setDraftUserName()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setDraftUserName((String)draftUsername)

  • 概要

    起票者名を設定します。

  • 入力値

    (String) draftUsername: 起票者名

  • 返却値

    なし。

  • 詳細

    起票者名を設定します。
    ＢＰＷ内部で設定されます。 通常は設定しないで下さい。

setDraftDate()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setDraftDate((String)draftDate)

  • 概要

    起票日を設定します。

  • 入力値

    (String) draftDate: 起票日

  • 返却値

    なし。

  • 詳細

    起票日を設定します。
    ＢＰＷ内部で設定されます。 通常は設定しないで下さい。

setDraftComment()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setDraftComment((String)draftComment)

  • 概要

    起票時コメントを設定します。

  • 入力値

    (String) draftComment: 起票時コメント

  • 返却値

    なし。

  • 詳細

    起票時コメントを設定します。

setCallProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setCallProcessDefCd((String)processdefcd)

  • 概要

    呼び出しプロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: 呼び出しプロセス定義コード

  • 返却値

    なし。

  • 詳細

    呼び出しプロセス定義コードを設定します。

setCallVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setCallVersionCd((String)versioncd)

  • 概要

    呼び出し履歴コードを設定します。

  • 入力値

    (String) versioncd: 呼び出し履歴コード

  • 返却値

    なし。

  • 詳細

    呼び出し履歴コードを設定します。

setCallProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setCallProcessCd((String)processcd)

  • 概要

    呼出プロセスコードを設定します。

  • 入力値

    (String) processcd: 呼出プロセスコード

  • 返却値

    なし。

  • 詳細

    呼出プロセスコードを設定します。

setProcessCallActivityCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCallActivityCd((String)activitycd)

  • 概要

    呼出処理コードを設定します。

  • 入力値

    (String) activitycd: 呼出処理コード

  • 返却値

    なし。

  • 詳細

    呼出処理コードを設定します。

setExtensionA()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setExtensionA((String)value)

  • 概要

    拡張エリアＡを設定します。

  • 入力値

    (String) value: 拡張エリアに設定する値

  • 返却値

    なし。

  • 詳細

    拡張エリアＡを設定します。

setExtensionB()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setExtensionB((String)value)

  • 概要

    拡張エリアＢを設定します。

  • 入力値

    (String) value: 拡張エリアに設定する値

  • 返却値

    なし。

  • 詳細

    拡張エリアＢを設定します。

setExtensionC()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setExtensionC((String)value)

  • 概要

    拡張エリアＣを設定します。

  • 入力値

    (String) value: 拡張エリアに設定する値

  • 返却値

    なし。

  • 詳細

    拡張エリアＣを設定します。

setExtensionD()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setExtensionD((String)value)

  • 概要

    拡張エリアＤを設定します。

  • 入力値

    (String) value: 拡張エリアに設定する値

  • 返却値

    なし。

  • 詳細

    拡張エリアＤを設定します。

setExtensionE()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setExtensionE((String)value)

  • 概要

    拡張エリアＥを設定します。

  • 入力値

    (String) value: 拡張エリアに設定する値

  • 返却値

    なし。

  • 詳細

    拡張エリアＥを設定します。

setExtensionF()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setExtensionF((String)value)

  • 概要

    拡張エリアＦを設定します。

  • 入力値

    (String) value: 拡張エリアに設定する値

  • 返却値

    なし。

  • 詳細

    拡張エリアＦを設定します。

setExtensionG()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setExtensionG((String)value)

  • 概要

    拡張エリアＧを設定します。

  • 入力値

    (String) value: 拡張エリアに設定する値

  • 返却値

    なし。

  • 詳細

    拡張エリアＧを設定します。

setExtensionH()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setExtensionH((String)value)

  • 概要

    拡張エリアＨを設定します。

  • 入力値

    (String) value: 拡張エリアに設定する値

  • 返却値

    なし。

  • 詳細

    拡張エリアＨを設定します。

setRunUserInfoModel()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setRunUserInfoModel((String) processDefCd,(String) versionCd,(String) activityCd,(String) userCd)

  • 概要

    実行時選択時実行主体ユーザマスタ情報を設定します。

  • 入力値

    (String)processDefCd: プロセス定義コード
    (String)versionCd: 履歴コード
    (String)activityCd: アクティビティコード(実行時選択アクティビティコード)
    (String)userCd: ユーザコード

  • 返却値

    なし。

  • 詳細

    実行時選択時実行主体ユーザマスタ情報を設定します。
    実行時選択時に、登録する実行主体ユーザ情報を設定してください。
    次が実行時選択の場合は、
    setRunUserInfoModel() か setRunExecuteInfoModel()
    のどちらか一方が必須項目となります。

setRunExecuteInfoModel()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setRunExecuteInfoModel((String) processDefCd,(String) versionCd,(String) activityCd,(String) postCd,(String) postCdKind)

  • 概要

    実行時選択時実行主体役職マスタテーブルを設定します。

  • 入力値

    (String)processDefCd: プロセス定義コード
    (String)versionCd: 履歴コード
    (String)activityCd: アクティビティコード
    (String)postCd: 組織コード
    (String)postCdKind: コード種別

      設定する値は、RunExecutiveInfoModel で定義されている以下の値です。

    組織(オフィシャルグループ)　：　RunExecutiveInfoModel.POST_TYPE_GROUPING
    ロール　　　　　　　　　　　：　RunExecutiveInfoModel.POST_TYPE_ROLE
    役職　　　　　　　　　　　　：　RunExecutiveInfoModel.POST_TYPE_ORG

  • 返却値

    なし。

  • 詳細

    実行時選択時実行主体役職マスタテーブルを設定します。
    実行時選択時に、登録する実行主体役職情報を設定してください。
    次が実行時選択の場合は、
    setRunUserInfoModel() か setRunExecuteInfoModel()
    のどちらか一方が必須項目となります。

addUserAppliKey()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)addUserAppliKey((Number) i,(String) processDefCd,(String) versionCd,(String) processCd,(String) parameterCd)

  • 概要

    指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。

  • 入力値

    (Number) i：パラメータ番号
    (String) processDefCd：プロセス定義コード
    (String) versionCd：履歴コード
    (String) processCd：プロセスコード
    (String) parameterCd：パラメータコード値

  • 返却値

    なし。

  • 詳細

    指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
    指定されたパラメータ番号でユーザアプリケーションキーテーブル情報リストにマップします。

    以下のパラメータは、現在使用されていません。
    すべて、""を設定してください。
      ・プロセス定義コード
      ・履歴コード
      ・プロセスコード

getResult()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getResult()

  • 概要

    エラーコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)エラーコード

  • 詳細

    エラーコードを返却します。
    エラーコードは、BPWErrorCodeIFで定義された定義値です。
    エラーでない場合は、””(空文字)が返却されます。

getLoginUserId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginUserId()

  • 概要

    ログインユーザＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログインユーザＩＤ

  • 詳細

    現在は使用されていません。
    ログインユーザＩＤを返却します。

getLoginGroupId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginGroupId()

  • 概要

    ログイングループＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログイングループＩＤ

  • 詳細

    現在は使用されていません。
    ログイングループＩＤを返却します。


RegistProcessEventObject オブジェクト

概要

申請処理を行います。

構造図
コンストラクタ
メソッド
fire() | 申請処理を行います。
setLoginUserId() | ログインユーザＩＤを設定します。
setLoginGroupId() | ログイングループＩＤを設定します。
setProcessDefCd() | プロセス定義コードを設定します。
setVersionCd() | 履歴コードを設定します。
setProcessCd() | プロセスコードを設定します。
setTransferFlg() | 代理フラグを設定します。
setProcessName() | プロセス名を設定します。
setDraftUserCd() | 起票者コードを設定します。
setDraftUserName() | 起票者名を設定します。
setDraftDate() | 起票日を設定します。
setDraftComment() | 起票時コメントを設定します。
setCallProcessDefCd() | 呼び出しプロセス定義コードを設定します。
setCallVersionCd() | 呼び出し履歴コードを設定します。
setCallProcessCd() | 呼出プロセスコードを設定します。
setProcessCallActivityCd() | 呼出処理コードを設定します。
setRunUserInfoModel() | 実行時選択時実行主体ユーザマスタ情報を設定します。
setRunExecuteInfoModel() | 実行時選択時実行主体役職マスタテーブルを設定します。
setExtensionA() | 拡張エリアＡに値を設定します。
setExtensionB() | 拡張エリアＢに値を設定します。
setExtensionC() | 拡張エリアＣに値を設定します。
setExtensionD() | 拡張エリアＤに値を設定します。
setExtensionE() | 拡張エリアＥに値を設定します。
setExtensionF() | 拡張エリアＦに値を設定します。
setExtensionG() | 拡張エリアＧに値を設定します。
setExtensionH() | 拡張エリアＨに値を設定します。
addUserAppliKey() | 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
getResult() | エラーコードを返却します。
getLoginUserId() | ログインユーザＩＤを返却します。
getLoginGroupId() | ログイングループＩＤを返却します。


RegistUserApplicationKeyEventObject オブジェクト ＡＰＩ

コンストラクタ

  • プロトタイプ

    (Object) RegistUserApplicationKeyEventObject()

  • 入力値

    なし

  • 詳細

    ユーザアプリケーションキー登録用、オブジェクトを初期化します。

fire()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)fire()

  • 概要

    ユーザアプリケーションキー登録処理を行います。

  • 入力値

    なし

  • 返却値

    (String)処理結果
    処理成功：””(空文字)
    処理失敗：BPWErrorCodeIFで定義された定義値

  • 詳細

    設定された内容のユーザアプリケーションキーを登録します。
    ユーザアプリケーションキー登録処理をする為には、最低以下のメソッドを呼び出しておく必要があります。
    【必須】
    ・setProcessDefCd
    ・setVersionCd
    ・setProcessCd
    ・setLoginGroupId
    ・setLoginUserId

setLoginUserId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginUserId((String)loginUserid)

  • 概要

    ログインユーザＩＤを設定します。

  • 入力値

    (String) loginUserid: ログインユーザＩＤ

  • 返却値

    なし。

  • 詳細

    【必須】ログインユーザＩＤを設定します。

setLoginGroupId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginGroupId((String)loginGroupid)

  • 概要

    ログイングループＩＤを設定します。

  • 入力値

    (String) loginGroupid: ログイングループ

  • 返却値

    なし。

  • 詳細

    【必須】ログイングループＩＤを設定します。

setProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessDefCd((String)processdefcd)

  • 概要

    プロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: プロセス定義コード

  • 返却値

    なし。

  • 詳細

    【必須】プロセス定義コードを設定します。

setVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setVersionCd((String)versioncd)

  • 概要

    履歴コードを設定します。

  • 入力値

    (String) versioncd: 履歴コード

  • 返却値

    なし。

  • 詳細

    【必須】履歴コードを設定します。

setProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCd((String)processcd)

  • 概要

    プロセスコードを設定します。

  • 入力値

    (String) processcd: プロセスコード

  • 返却値

    なし。

  • 詳細

    【必須】プロセスコードを設定します。

addUserAppliKey()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)addUserAppliKey((Number) i,(String) parameterCd)

  • 概要

    指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。

  • 入力値

    (Number) i：パラメータ番号
    (String) parameterCd：パラメータコード値

  • 返却値

    なし。

  • 詳細

    指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
    指定されたパラメータ番号でユーザアプリケーションキーテーブル情報リストにマップします。

setReRegistFlag()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setReRegistFlag((String reRegistFlag))

  • 概要

    再登録フラグを設定します。

  • 入力値

    (boolean) reRegistFlag: 再登録フラグ

  • 返却値

    なし。

  • 詳細

    再登録フラグを設定します。
    既存のユーザアプリケーションキー情報を削除して再登録する場合に、"true"を設定します。

getResult()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getResult()

  • 概要

    エラーコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)エラーコード

  • 詳細

    エラーコードを返却します。
    エラーコードは、BPWErrorCodeIFで定義された定義値です。
    エラーでない場合は、””(空文字)が返却されます。

getLoginUserId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginUserId()

  • 概要

    ログインユーザＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログインユーザＩＤ

  • 詳細

    現在は使用されていません。
    ログインユーザＩＤを返却します。

getLoginGroupId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginGroupId()

  • 概要

    ログイングループＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログイングループＩＤ

  • 詳細

    現在は使用されていません。
    ログイングループＩＤを返却します。


RegistUserApplicationKeyEventObject オブジェクト

概要

ユーザアプリケーションキーの登録を行います。。

構造図
コンストラクタ
メソッド
fire() | ユーザアプリケーションキー登録処理を行います。
setLoginUserId() | ログインユーザＩＤを設定します。
setLoginGroupId() | ログイングループＩＤを設定します。
setProcessDefCd() | プロセス定義コードを設定します。
setVersionCd() | 履歴コードを設定します。
setProcessCd() | プロセスコードを設定します。
addUserAppliKey() | 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
setReRegistFlag() | 再登録フラグを設定します。
getResult() | エラーコードを返却します。
getLoginUserId() | ログインユーザＩＤを返却します。
getLoginGroupId() | ログイングループＩＤを返却します。


ReturnDraftEventObject オブジェクト ＡＰＩ

コンストラクタ

  • プロトタイプ

    (Object) ReturnDraftEventObject()

  • 入力値

    なし

  • 詳細

    前処理者へ差戻し用、オブジェクトを初期化します。

fire()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)fire()

  • 概要

    前処理者へ差戻し処理を行います。

  • 入力値

    なし

  • 返却値

    (String)処理結果
    処理成功：””(空文字)
    処理失敗：BPWErrorCodeIFで定義された定義値

  • 詳細

    設定された内容のアクティビティを差し戻します。
    前処理者へ差戻し処理をする為には、最低以下のメソッドを呼び出しておく必要があります。
    【必須】
    ・setProcessDefCd
    ・setVersionCd
    ・setProcessCd
    ・setActivityCd
    ・setLoginGroupId
    ・setLoginUserId

setLoginUserId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginUserId((String)loginUserid)

  • 概要

    ログインユーザＩＤを設定します。

  • 入力値

    (String) loginUserid: ログインユーザＩＤ

  • 返却値

    なし。

  • 詳細

    【必須】ログインユーザＩＤを設定します。

setLoginGroupId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginGroupId((String)loginGroupid)

  • 概要

    ログイングループＩＤを設定します。

  • 入力値

    (String) loginGroupid: ログイングループ

  • 返却値

    なし。

  • 詳細

    【必須】ログイングループＩＤを設定します。

setProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessDefCd((String)processdefcd)

  • 概要

    プロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: プロセス定義コード

  • 返却値

    なし。

  • 詳細

    【必須】プロセス定義コードを設定します。

setVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setVersionCd((String)versioncd)

  • 概要

    履歴コードを設定します。

  • 入力値

    (String) versioncd: 履歴コード

  • 返却値

    なし。

  • 詳細

    【必須】履歴コードを設定します。

setProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCd((String)processcd)

  • 概要

    プロセスコードを設定します。

  • 入力値

    (String) processcd: プロセスコード

  • 返却値

    なし。

  • 詳細

    【必須】プロセスコードを設定します。

setActivityCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setActivityCd((String)activitycd)

  • 概要

    アクティビティコードを設定します。

  • 入力値

    (String) activitycd: アクティビティコード

  • 返却値

    なし。

  • 詳細

    【必須】アクティビティコードを設定します。
    設定するアクティビティコードは、差戻し元アクティビティコードです。

setApprovalUserCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalUserCd((String)approvalUsercd)

  • 概要

    承認者コードを設定します。

  • 入力値

    (String) setApprovalUserCd: 承認者コード

  • 返却値

    なし。

  • 詳細

    【必須】
    承認者コードを設定します。
    代理による再申請、代理による承認の場合は本来処理を行うユーザの ユーザコードを設定して下さい。

setApprovalUserName()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalUserName((String)approvalUsername)

  • 概要

    承認者名を設定します。

  • 入力値

    (String) approvalUsername: 承認者名

  • 返却値

    なし。

  • 詳細

    承認者名を設定します。
    ＢＰＷ内部で設定されます。 通常は設定しないで下さい。

setApprovalType()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalType((String)approvalType)

  • 概要

    承認種別を設定します。

  • 入力値

    (String) approvalType: 承認種別

    設定する値は、RecognitionInfoModelで定義されている以下の値です。
      承認者へ差戻す　　：　RecognitionInfoModel.RETURN_BEFORE

  • 返却値

    なし。

  • 詳細

    承認種別を設定します。

setReceiveComment()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setReceiveComment((String)receiveComment)

  • 概要

    承認時コメントを設定します。

  • 入力値

    (String) receiveComment: 承認時コメント

  • 返却値

    なし。

  • 詳細

    承認時コメントを設定します。

getResult()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getResult()

  • 概要

    エラーコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)エラーコード

  • 詳細

    エラーコードを返却します。
    エラーコードは、BPWErrorCodeIFで定義された定義値です。
    エラーでない場合は、””(空文字)が返却されます。

getLoginUserId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginUserId()

  • 概要

    ログインユーザＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログインユーザＩＤ

  • 詳細

    現在は使用されていません。
    ログインユーザＩＤを返却します。

getLoginGroupId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginGroupId()

  • 概要

    ログイングループＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログイングループＩＤ

  • 詳細

    現在は使用されていません。
    ログイングループＩＤを返却します。


ReturnDraftEventObject オブジェクト

概要

前処理者へ差戻しを行います。

構造図
コンストラクタ
メソッド
fire() | 前処理者へ差戻しを行います。
setLoginUserId() | ログインユーザＩＤを設定します。
setLoginGroupId() | ログイングループＩＤを設定します。
setProcessDefCd() | プロセス定義コードを設定します。
setVersionCd() | 履歴コードを設定します。
setProcessCd() | プロセスコードを設定します。
setActivityCd() | アクティビティコードを設定します。
setApprovalUserCd() | 承認者コードを設定します。
setApprovalUserName() | 承認者名を設定します。
setApprovalType() | 承認種別を設定します。
setReceiveComment() | 承認時コメントを設定します。
getResult() | エラーコードを返却します。
getLoginUserId() | ログインユーザＩＤを返却します。
getLoginGroupId() | ログイングループＩＤを返却します。


ReturnStartEventObject オブジェクト ＡＰＩ

コンストラクタ

  • プロトタイプ

    (Object) ReturnStartEventObject()

  • 入力値

    なし

  • 詳細

    申請者へ差戻し用、オブジェクトを初期化します。

fire()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)fire()

  • 概要

    申請者へ差戻し処理を行います。

  • 入力値

    なし

  • 返却値

    (String)処理結果
    処理成功：””(空文字)
    処理失敗：BPWErrorCodeIFで定義された定義値

  • 詳細

    設定された内容のアクティビティを差し戻します。
    申請者へ差戻し処理をする為には、最低以下のメソッドを呼び出しておく必要があります。
    【必須】
    ・setProcessDefCd
    ・setVersionCd
    ・setProcessCd
    ・setActivityCd
    ・setLoginGroupId
    ・setLoginUserId

setLoginUserId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginUserId((String)loginUserid)

  • 概要

    ログインユーザＩＤを設定します。

  • 入力値

    (String) loginUserid: ログインユーザＩＤ

  • 返却値

    なし。

  • 詳細

    【必須】ログインユーザＩＤを設定します。

setLoginGroupId()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setLoginGroupId((String)loginGroupid)

  • 概要

    ログイングループＩＤを設定します。

  • 入力値

    (String) loginGroupid: ログイングループ

  • 返却値

    なし。

  • 詳細

    【必須】ログイングループＩＤを設定します。

setProcessDefCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessDefCd((String)processdefcd)

  • 概要

    プロセス定義コードを設定します。

  • 入力値

    (String) processdefcd: プロセス定義コード

  • 返却値

    なし。

  • 詳細

    【必須】プロセス定義コードを設定します。

setVersionCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setVersionCd((String)versioncd)

  • 概要

    履歴コードを設定します。

  • 入力値

    (String) versioncd: 履歴コード

  • 返却値

    なし。

  • 詳細

    【必須】履歴コードを設定します。

setProcessCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setProcessCd((String)processcd)

  • 概要

    プロセスコードを設定します。

  • 入力値

    (String) processcd: プロセスコード

  • 返却値

    なし。

  • 詳細

    【必須】プロセスコードを設定します。

setActivityCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setActivityCd((String)activitycd)

  • 概要

    アクティビティコードを設定します。

  • 入力値

    (String) activitycd: アクティビティコード

  • 返却値

    なし。

  • 詳細

    【必須】アクティビティコードを設定します。
    設定するアクティビティコードは、差戻し元アクティビティコードです。

setApprovalUserCd()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalUserCd((String)approvalUsercd)

  • 概要

    承認者コードを設定します。

  • 入力値

    (String) setApprovalUserCd: 承認者コード

  • 返却値

    なし。

  • 詳細

    【必須】
    承認者コードを設定します。
    代理による再申請、代理による承認の場合は本来処理を行うユーザの ユーザコードを設定して下さい。

setApprovalUserName()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalUserName((String)approvalUsername)

  • 概要

    承認者名を設定します。

  • 入力値

    (String) approvalUsername: 承認者名

  • 返却値

    なし。

  • 詳細

    承認者名を設定します。
    ＢＰＷ内部で設定されます。 通常は設定しないで下さい。

setApprovalType()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setApprovalType((String)approvalType)

  • 概要

    承認種別を設定します。

  • 入力値

    (String) approvalType: 承認種別

    設定する値は、RecognitionInfoModelで定義されている以下の値です。
      承認者へ差戻す　　：　RecognitionInfoModel.RETURN_START

  • 返却値

    なし。

  • 詳細

    承認種別を設定します。

setReceiveComment()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setReceiveComment((String)receiveComment)

  • 概要

    承認時コメントを設定します。

  • 入力値

    (String) receiveComment: 承認時コメント

  • 返却値

    なし。

  • 詳細

    承認時コメントを設定します。

getResult()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getResult()

  • 概要

    エラーコードを返却します。

  • 入力値

    なし

  • 返却値

    (String)エラーコード

  • 詳細

    エラーコードを返却します。
    エラーコードは、BPWErrorCodeIFで定義された定義値です。
    エラーでない場合は、””(空文字)が返却されます。

getLoginUserId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginUserId()

  • 概要

    ログインユーザＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログインユーザＩＤ

  • 詳細

    現在は使用されていません。
    ログインユーザＩＤを返却します。

getLoginGroupId()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLoginGroupId()

  • 概要

    ログイングループＩＤを返却します。

  • 入力値

    なし

  • 返却値

    (String)ログイングループＩＤ

  • 詳細

    現在は使用されていません。
    ログイングループＩＤを返却します。


ReturnStartEventObject オブジェクト

概要

申請者へ差戻しを行います。

構造図
コンストラクタ
メソッド
fire() | 申請者へ差戻しを行います。
setLoginUserId() | ログインユーザＩＤを設定します。
setLoginGroupId() | ログイングループＩＤを設定します。
setProcessDefCd() | プロセス定義コードを設定します。
setVersionCd() | 履歴コードを設定します。
setProcessCd() | プロセスコードを設定します。
setActivityCd() | アクティビティコードを設定します。
setApprovalUserCd() | 承認者コードを設定します。
setApprovalUserName() | 承認者名を設定します。
setApprovalType() | 承認種別を設定します。
setReceiveComment() | 承認時コメントを設定します。
getResult() | エラーコードを返却します。
getLoginUserId() | ログインユーザＩＤを返却します。
getLoginGroupId() | ログイングループＩＤを返却します。


 UserTransaction オブジェクト

データベーストランザクションのAPI。
起票、承認などの関連の処理と併用して
データベースに対するユーザトランザクション制御を行います。

コンストラクタの概要
UserTransaction()
コンストラクタ（ログイングループ未指定）
現在ログインしている”ログイングループID”の
ログイングループ接続先データベースに対して
データベーストランザクション制御を行います。
UserTransaction(String login_group_id)
コンストラクタ(ログイングループ指定)
第１引数として、”ログイングループID”が指定された場合、
指定されたログイングループ接続先データベースに対して
データベーストランザクション制御を行います。
メソッドの概要
Boolean | begin() トランザクションの開始を行います。
Boolean | commit() トランザクションの確定（commit）を行います。
Boolean | rollback() トランザクションの中止（rollback）を行います。
コンストラクタの詳細
UserTransaction

UserTransaction()
コンストラクタ（ログイングループ未指定）
現在ログインしている”ログイングループID”の
ログイングループ接続先データベースに対して
データベーストランザクション制御を行います。
UserTransaction

UserTransaction(String login_group_id)
コンストラクタ(ログイングループ指定)
第１引数として、”ログイングループID”が指定された場合、
指定されたログイングループ接続先データベースに対して
データベーストランザクション制御を行います。
パラメータ
login_group_id String ログイングループID(必須)
メソッドの詳細
begin

Boolean begin()

トランザクションの開始を行います。
返却値
Boolean 処理結果(true:成功/false:失敗)
commit

Boolean commit()

トランザクションの確定（commit）を行います。
返却値
Boolean 処理結果(true:成功/false:失敗)
rollback

Boolean rollback()

トランザクションの中止（rollback）を行います。
返却値
Boolean 処理結果(true:成功/false:失敗)


 WfkSettingReserveFlg オブジェクト

プログラムサポート/メール送信　リザーブフラグ設定クラス。
コンストラクタの概要
WfkSettingReserveFlg()
コンストラクタ
メソッドの概要
String | getResult() エラーコードを返却します。
String | setReserveFlg() リザーブフラグを設定します。
コンストラクタの詳細
WfkSettingReserveFlg

WfkSettingReserveFlg()
コンストラクタ
メソッドの詳細
getResult

String getResult()

エラーコードを返却します。
エラーコードは、BPWErrorCodeIFで定義された定義値です。
エラーでない場合は、””(空文字)が返却されます。
返却値
String エラーコード
setReserveFlg

String setReserveFlg()

リザーブフラグを設定します。
返却値
String エラーコード


WkfApprover オブジェクト ＡＰＩ

WkfApprover()

  • プロトタイプ

    (Object) WkfApprover((String)user_cd, (String)connectID)

  • 入力値

    (String) user_cd: 承認者のユーザID
    (String) connectID: DB接続参照名

  • 返却値

    なし

  • 詳細

    引数２つのコンストラクタ
    承認者オブジェクトを作成します。

WkfApprover()

  • プロトタイプ

    (Object) WkfApprover((String)agent_user_cd, (String)user_cd, (String)connectID)

  • 入力値

    (String) agent_user_cd: 代理承認者のユーザID
    (String) user_cd: 本来の承認者のユーザID
    (String) connectID: DB接続参照名

  • 返却値

    なし

  • 詳細

    引数３つのコンストラクタ
    代理承認者オブジェクトを作成します。
    一覧取得の際に代理人に代理された全てのタスクを表示したい場合は、 本来の承認者のユーザIDに「Approver.AGT_ALL」を指定してください。 ただし、「Approver.AGT_ALL」を指定した場合、承認等の処理は行えません。

approve()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)approve((String)process_def_cd, (String)version_cd, (String)process_cd, (String)activity_cd, (boolean)isFinish, (String)comp_cd, (String)orgn_cd, (String)comment, (Object)nego, (Object)executant, (String)next_actiity_cd)

  • 概要

    指定されたプロセスの承認処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: バージョンコード(必須)
    (String) process_cd: プロセスコード(必須)
    (String) activity_cd: アクティビティコード(必須)
    (boolean) isFinish: 途中終了フラグ(任意。指定なしのときは途中終了しない。)
    (String) comp_cd: ユーザの承認会社コード(任意。指定なしのときは所属なし。)
    (String) orgn_cd: ユーザの承認組織コード(任意。指定なしのときは所属なし。)
    (String) comment: 承認コメント(任意)
    (Object) nego: 根回しメールオブジェクト(任意)
    (Object) executant: 次承認者オブジェクト(次タスクが実行時選択のとき指定します。)
    (String) next_activity_cd: 次アクティビティコード(次タスクがユーザ選択のとき指定します。)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。
    Object  //次承認者オブジェクト
Object
├type    承認者タイプ(必須。ユーザ：user,/組織：orgn)
├comp_cd 会社コード(typeで組織選択時に指定します。)
└cd      承認ユーザ/組織コード(必須)

    Object  //根回しメールオブジェクト
Object
├title       根回しメールタイトル(必須)
├comment     根回しメールコメント(任意)
└user_list[] 根回しメール送信者リスト(必須)
   ├cd       送信先ユーザコード
   ├mail     送信先ユーザメールアドレス
   └name     送信先ユーザ名

denial()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)denial((String)process_def_cd, (String)version_cd, (String)process_cd, (String)activity_cd, (String)comp_cd, (String)orgn_cd, (String)comment, (Object)nego)

  • 概要

    指定されたプロセスの否認処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: バージョンコード(必須)
    (String) process_cd: プロセスコード(必須)
    (String) activity_cd: アクティビティコード(必須)
    (String) comp_cd: ユーザの承認会社コード(任意。指定なしのときは所属なし。)
    (String) orgn_cd: ユーザの承認組織コード(任意。指定なしのときは所属なし。)
    (String) comment: 否認コメント(任意)
    (Object) nego: 根回しメールオブジェクト(任意)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。
    Object  //根回しメールオブジェクト
Object
├title       根回しメールタイトル(必須)
├comment     根回しメールコメント(任意)
└user_list[] 根回しメール送信者リスト(必須)
   ├cd       送信先ユーザコード
   ├mail     送信先ユーザメールアドレス
   └name     送信先ユーザ名

suspend()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)suspend((String)process_def_cd, (String)version_cd, (String)process_cd, (String)activity_cd, (String)comp_cd, (String)orgn_cd, (String)comment, (Object)nego)

  • 概要

    指定されたプロセスの保留処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: バージョンコード(必須)
    (String) process_cd: プロセスコード(必須)
    (String) activity_cd: アクティビティコード(必須)
    (String) comp_cd: ユーザの承認会社コード(任意。指定なしのときは所属なし。)
    (String) orgn_cd: ユーザの承認組織コード(任意。指定なしのときは所属なし。)
    (String) comment: 保留コメント(任意)
    (Object) nego: 根回しメールオブジェクト(任意)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。
    Object  //根回しメールオブジェクト
Object
├title       根回しメールタイトル(必須)
├comment     根回しメールコメント(任意)
└user_list[] 根回しメール送信者リスト(必須)
   ├cd       送信先ユーザコード
   ├mail     送信先ユーザメールアドレス
   └name     送信先ユーザ名

sendBack()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)sendBack((String)process_def_cd, (String)version_cd, (String)process_cd, (String)activity_cd, (String)type, (String)comp_cd, (String)orgn_cd, (String)comment, (Object)nego)

  • 概要

    指定されたプロセスの差し戻し処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: 履歴コード(必須)
    (String) process_cd: プロセスコード(必須)
    (String) activity_cd: アクティビティコード(必須)
    (String) type: 差し戻し先(必須。start:申請者/before:前処理者)
    (String) comp_cd: ユーザの起票会社コード(任意。指定なしのときは所属なし。)
    (String) orgn_cd: ユーザの起票組織コード(任意。指定なしのときは所属なし。)
    (String) comment: 差し戻しコメント(任意)
    (Object) nego: 根回しメールオブジェクト(任意)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。
    Object  //根回しメールオブジェクト
Object
├title       根回しメールタイトル(必須)
├comment     根回しメールコメント(任意)
└user_list[] 根回しメール送信者リスト(必須)
   ├cd       送信先ユーザコード
   ├mail     送信先ユーザメールアドレス
   └name     送信先ユーザ名

pullBack()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)pullBack((String)process_def_cd, (String)version_cd, (String)process_cd, (String)activity_cd)

  • 概要

    指定されたプロセスの引き戻し処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: 履歴コード(必須)
    (String) process_cd: プロセスコード(必須)
    (String) activity_cd: アクティビティコード(必須)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。

getActivityTaskList()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getActivityTaskList((Object)condition, (Object)sort, (Int)start, (Int)amount)

  • 概要

    処理可能案件(未処理案件)一覧を取得します。

  • 入力値

    (Object) condition: 検索条件オブジェクト(必須。必ずフィルターをセットしてください。)
    (Object) sort: ソート指定オブジェクト(任意。指定しないときはnullをセット。)
    (Int) start: フェッチ開始位置(任意。指定しないときは0をセット。)
    (Int) amount: フェッチ件数(任意。指定しないときは0をセット。)

  • 返却値

    Object配列  //処理可能案件(未処理案件)オブジェクトの配列
Object
├category_cd(String)           カテゴリコード
├category_name(String)         カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String)     親プロセスバージョンコード
├parent_process_cd(String)     親プロセスコード
├process_def_cd(String)        プロセス定義コード
├process_def_name(String)      プロセス定義名
├version_cd(String)            バージョンコード
├version_name(String)          バージョン名
├process_cls_cd(String)        プロセス種別コード
├process_cd(String)            プロセスコード
├process_name(String)          プロセス名
├process_status(String)        プロセスステータス
├activity_cd(String)           アクティビティコード
├activity_name(String)         アクティビティ名
├activity_status(String)       アクティビティステータス
├attainment_class(String)      到達種別
├draft_appoint_date(String)    起票指定日
├draft_date(String)            起票日
├draft_user_cd(String)         起票者コード
├draft_user_name(String)       起票者名
├reception_date(String)        受信日付
├process_term_date(String)     処理期限日付
├transfer_flg(Boolean)         代理起票フラグ
├client_auth_flg(Boolean)      代理元承認可否フラグ
├agent_target(String)          代理依頼先対象(起票者でインスタンス作成時)
├agent_cd(String)              代理依頼先ユーザ/組織コード(起票者でインスタンス作成時)
├agent_name(String)            代理依頼先ユーザ/組織名(起票者でインスタンス作成時)
├client_user_cd(String)        代理依頼元ユーザコード(代理起票者でインスタンス作成時)
├client_user_name(String)      代理依頼元ユーザ名(代理起票者でインスタンス作成時)
├next_activity_type(String)    次タスクのタスク種別
└compulsion_end_flg(Boolean)   強制終了可否フラグ
    エラー時 null

  • 詳細

    「検索条件オブジェクト」は、WkfSearchConditionオブジェクトを指定してください。
    このメソッドでは「go_filter」,「at_go_filter」,「clt_agt_go_filter」, 「pullback_filter」,「agt_pullback_filter」,「clt_agt_pullback_filter」, 「sendback_filter」,「agt_sendback_filter」,「clt_agt_sendback_filter」が使用できます。
    いずれかのフィルターを必ずtrueに設定してください。
    代理人用のインスタンス生成時は、「go_filter」,「pullback_filter」,「sendback_filter」は使用できません。
    「ソート指定オブジェクト」は、WkfSortオブジェクト配列を指定してください。
    「ソート指定オブジェクト」では、このメソッドで出力する項目のみソートキーとして指定できるものとする。
    「ソート指定オブジェクト」では、配列の要素１番が第一ソートキーになる。

    プロセス種別コードのコード値は以下のようになります。
  ビジネスプロセスワークフロー :0
  ドキュメントワークフロー　　 :1
  申請者ルート作成ワークフロー :2

プロセスステータスのコード値は以下のようになります。
  アクティブ :1
  完了　　　 :4

アクティビティステータスのコード値は以下のようになります。
  準備中　　 :0
  アクティブ :1
  保留中　　 :2
  取り消し中 :3
  完了　　　 :4

到達種別のコード値は以下のようになります。
  未到達　 :00
  通常到達 :01
  引戻し　 :20
  被引戻し :21
  差戻し　 :30
  被差戻し :31

getEndTaskList()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getEndTaskList((Object)condition, (Object)sort, (Int)start, (Int)amount)

  • 概要

    処理済案件一覧を取得します。

  • 入力値

    (Object) condition: 検索条件オブジェクト(必須。必ずフィルターをセットしてください。)
    (Object) sort: ソート指定オブジェクト(任意。指定しないときはnullをセット。)
    (Int) start: フェッチ開始位置(任意。指定しないときは0をセット。)
    (Int) amount: フェッチ件数(任意。指定しないときは0をセット。)

  • 返却値

    Object配列  //処理済案件オブジェクトの配列
Object
├category_cd(String)              カテゴリコード
├category_name(String)            カテゴリ名
├parent_process_def_cd(String)    親プロセス定義コード
├parent_version_cd(String)        親プロセスバージョンコード
├parent_process_cd(String)        親プロセスコード
├process_def_cd(String)           プロセス定義コード
├process_def_name(String)         プロセス定義名
├version_cd(String)               バージョンコード
├version_name(String)             バージョン名
├process_cls_cd(String)           プロセス種別コード
├process_cd(String)               プロセスコード
├process_name(String)             プロセス名
├process_status(String)           プロセスステータス
├activity_cd(String)              処理時のアクティビティコード
├activity_name(String)            処理時のアクティビティ名
├draft_appoint_date(String)       起票指定日
├draft_date(String)               起票日
├draft_user_cd(String)            起票者コード
├draft_user_name(String)          起票者名
├draft_user_comp_cd(String)       起票者の処理時の会社コード
├draft_user_orgn_cd(String)       起票者の処理時の組織コード
├draft_user_main_flg(String)      主・副所属フラグ
├isJunction(Boolean)              ルートが同期していればtrue
├approval_type(String)            処理結果
├approval_user_cd(String)         処理ユーザコード
├approval_user_name(String)       処理ユーザ名
├approval_date(String)            処理日
├approval_transfer_flg(Boolean)   承認結果履歴代理フラグ
├processing_status(String)        現在の状態
├approval_agent_user_cd(String)   承認代理元ユーザコード(代理承認者でインスタンス作成時)
├approval_agent_user_name(String) 承認代理元ユーザ名(代理承認者でインスタンス作成時)
├transfer_flg(Boolean)            代理依頼フラグ
├client_auth_flg(Boolean)         代理元承認可否フラグ
├agent_target(String)             代理依頼先対象(起票者でインスタンス作成時)
├agent_cd(String)                 代理依頼先ユーザ/組織コード(起票者でインスタンス作成時)
├agent_name(String)              代理依頼先ユーザ/組織名(起票者でインスタンス作成時)
└pull_activity_flg(Boolean)       引き戻し可否フラグ(true:可/false:不可)
    エラー時 null

  • 詳細

    「検索条件オブジェクト」は、WkfSearchConditionオブジェクトを指定してください。
    このメソッドでは「go_filter」,「agt_go_filter」,「clt_agt_go_filter」, 「comp_filter」,「agt_comp_filter」,「clt_agt_comp_filter」が使用できます。
    いずれかのフィルターを必ずtrueに設定してください。
    代理人用のインスタンス生成時は、「go_filter」,「comp_filter」は使用できません。
    「ソート指定オブジェクト」は、WkfSortオブジェクト配列を指定してください。
    「ソート指定オブジェクト」では、このメソッドで出力する項目のみソートキーとして指定できるものとする。
    「ソート指定オブジェクト」では、配列の要素１番が第一ソートキーになる。

    プロセス種別コードのコード値は以下のようになります。
  ビジネスプロセスワークフロー :0
  ドキュメントワークフロー　　 :1
  申請者ルート作成ワークフロー :2

プロセスステータスのコード値は以下のようになります。
  アクティブ :1
  完了　　　 :4

処理結果のコード値は以下のようになります。
  申請　　　　　　 :0
  再申請　　　　　 :1
  承認　　　　　　 :2
  棄却　　　　　　 :3
  申請者へ差戻し　 :4
  前処理者へ差戻し :5
  引き戻し　　　　 :6
  保留　　　　　　 :7
  取り止め　　　　 :8
  対象者自動パス　 :9
  プロセス操作　　 :99

現在の状態のコード値は以下のようになります。
【本人・代理設定なし】
   通常         :000(通常到達にて活性化)
   引戻し       :005(引戻しにて活性化)
   差戻し       :006(差戻しにて活性化)
   通常  (保留) :010(通常到達にて活性化後の保留)
   引戻し(保留) :015(引戻しにて活性化後の保留)
   差戻し(保留) :016(差戻しにて活性化の保留)
【代理設定有り・本人決済可】
   通常         :100(通常到達にて活性化)
   引戻し       :105(引戻しにて活性化)
   差戻し       :106(差戻しにて活性化)
   通常  (保留) :110(通常到達にて活性化後の保留)
   引戻し(保留) :115(引戻しにて活性化後の保留)
   差戻し(保留) :116(差戻しにて活性化の保留)
【代理設定有り・本人決不可】
   通常         :200(通常到達にて活性化)
   引戻し       :205(引戻しにて活性化)
   差戻し       :206(差戻しにて活性化)
   通常  (保留) :210(通常到達にて活性化後の保留)
   引戻し(保留) :215(引戻しにて活性化後の保留)
   差戻し(保留) :216(差戻しにて活性化の保留)
【共通】
   完了　　　　 :999(完了）

noTransaction()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)noTransaction()

  • 概要

    データベーストランザクションを未使用にします。

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    起票等の処理時にトランザクションを張らずにデータベースの更新処理を行なうようになります。


WkfApprover オブジェクト

概要

承認<承認者/代理承認者>

構造図
コンストラクタ(本人用)
コンストラクタ(代理人用)
メソッド
approve() | 承認処理の実行
denial() | 否認処理の実行
suspend() | 保留処理の実行
sendBack() | 差し戻し処理の実行
pullBack() | 引き戻し処理の実行
getActivityTaskList() | 処理可能案件(未処理案件)一覧の取得
getEndTaskList() | 処理済案件一覧の取得
noTransaction() | データベーストランザクションを未使用にします


WkfDrafter オブジェクト ＡＰＩ

WkfDrafter()

  • プロトタイプ

    (Object) WkfDrafter((String)user_cd, (String)connectID)

  • 入力値

    (String) user_cd: 起票者のユーザID
    (String) connectID: DB接続参照名

  • 返却値

    なし

  • 詳細

    引数２つのコンストラクタ
    起票者オブジェクトを作成します。

WkfDrafter()

  • プロトタイプ

    (Object) WkfDrafter((String)agent_user_cd, (String)user_cd, (String)connectID)

  • 入力値

    (String) agent_user_cd: 代理起票者のユーザID
    (String) user_cd: 本来の起票者のユーザID
    (String) connectID: DB接続参照名

  • 返却値

    なし

  • 詳細

    引数３つのコンストラクタ
    代理起票者オブジェクトを作成します。
    一覧取得の際に代理人に代理された全てのタスクを表示したい場合は、 本来の起票者のユーザIDに「Drafter.AGT_ALL」を指定してください。 ただし、「Drafter.AGT_ALL」を指定した場合、起票等の処理は行えません。

getActivityProcessDefList()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getActivityProcessDefList((Object)condition, (Array)sort, (Int)start, (Int)amount, (String)locale)

  • 概要

    起票可能プロセス一覧を取得します。

  • 入力値

    (Object) condition: 検索条件オブジェクト(必須。必ずフィルターをセットしてください。)
    (Array) sort: ソート指定オブジェクトの配列(任意。指定しないときはnullをセット。)
    (Int) start: フェッチ開始位置(任意。指定しないときは0をセット。)
    (Int) amount: フェッチ件数(任意。指定しないときは0をセット。)
    (String) locale: ロケール(任意。指定なしのときはデフォルトロケールを使用します。)

  • 返却値

    Object配列  //起票可能プロセスオブジェクトの配列
Object
├category_cd(String)      カテゴリコード
├category_name(String)    カテゴリ名
├process_def_cd(String)   プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String)       起票可能な最新バージョンコード
├version_name(String)     起票可能な最新バージョン名
├version_note(String)     起票可能な最新バージョンの備考
├effective_date(String)   有効日付
├end_date(String)         終了日付
├process_cls_cd(String)   プロセス種別コード
├activity_cd(String)      開始アクティビティコード
├transfer_flg(Boolean)    代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String)     代理依頼先対象(起票者でインスタンス作成時)
├agent_comp_cd(String)    代理依頼先会社コード(起票者でインスタンス作成時)
├agent_cd(String)         代理依頼先ユーザ/組織コード(起票者でインスタンス作成時)
├agent_name(String)       代理依頼先ユーザ/組織名(起票者でインスタンス作成時)
├client_user_cd(String)   代理依頼元ユーザコード(代理起票者でインスタンス作成時)
└client_user_name(String) 代理依頼元ユーザ名(代理起票者でインスタンス作成時)
    エラー時 null

  • 詳細

    「検索条件オブジェクト」は、WkfSearchConditionオブジェクトを指定してください。
    このメソッドでは「go_filter」,「agt_go_filter」,「clt_agt_go_filter」が使用できます。
    いずれかのフィルターを必ずtrueに設定してください。
    代理人用のインスタンス生成時は、「go_filter」は使用できません。
    起票指定日を指定する場合は検索条件オブジェクトの「draft_appoint_date」に起票指定日を設定してください。
    「ソート指定オブジェクト」は、WkfSortオブジェクト配列を指定してください。
    「ソート指定オブジェクト」では、このメソッドで出力する項目のみソートキーとして指定できるものとする。
    「ソート指定オブジェクト」では、配列の要素１番が第一ソートキーになる。

    プロセス種別コードのコード値は以下のようになります。
  ビジネスプロセスワークフロー :0
  ドキュメントワークフロー　　 :1
  申請者ルート作成ワークフロー :2

draft()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)draft((String)process_def_cd, (String)version_cd, (String)process_temporary_cd, (String)process_name, (Array)app_key, (String)draft_appoint_date, (String)comp_cd, (String)orgn_cd, (String)comment, (Object)nego, (Object)executant, (String)next_actiity_cd, (String)locale)

  • 概要

    新規プロセスの起票処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: バージョンコード(必須)
    (String) process_temporary_cd: 一時プロセスID(任意)
    (String) process_name: プロセス名(必須)
    (Array) app_key: アプリケーションキー配列(任意。0～9要素まで。)
    (String) draft_appoint_date: 起票指定日(任意。指定なしのときは起票日と同日。)
    (String) comp_cd: ユーザの起票会社コード(任意。指定なしのときは所属なし。)
    (String) orgn_cd: ユーザの起票組織コード(任意。指定なしのときは所属なし。)
    (String) comment: 起票コメント(任意)
    (Object) nego: 根回しメールオブジェクト(任意)
    (Object) executant: 次承認者オブジェクト(次タスクが実行時選択のとき指定します。)
    (String) next_activity_cd: 次アクティビティコード(次タスクがユーザ選択のとき指定します。)
    (String) locale: ロケール(任意。指定なしのときはデフォルトロケールを使用します。)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess(Boolean)   処理結果(true:成功/false:失敗)
├getId(String)        エクセプションID
├getMessage(String)   エラーメッセージ
└processInfo(Object)  起票プロセスの情報(処理成功時のみ)
   ├process_def_cd(String)            プロセス定義コード
   ├version_cd(String)                バージョンコード
   ├process_cd(String)                プロセスコード
   ├process_name(String)              プロセス名
   ├draft_date(String)                起票日
   ├draft_user_cd(String)             起票者コード
   ├draft_user_name(String)           起票者名
   ├draft_comment(String)             起票コメント
   ├company_cd(String)                起票者の起票会社コード
   ├code_value(String)                起票者の起票組織コード
   ├group_name(String)                起票者の起票組織名
   ├draft_appoint_date(String)        起票指定日
   ├transactor_cd(String)             処理者コード
   ├transactor_name(String)           処理者名
   ├locale_id(String)                 処理者ロケールID
   ├process_status(String)            プロセスステータス
   ├last_man_activity_cd(String)      最終手動アクティビティコード
   ├last_man_activity_result(String)  最終手動アクティビティ承認結果種別
   ├parent_process_def_cd(String)     親プロセス定義コード
   ├parent_version_cd(String)         親バージョンコード
   ├parent_process_cd(String)         親プロセスコード
   ├parent_activity_cd(String)        親アクティビティコード
   ├processing_status(String)         処理状態識別
   ├process_nest_cnt(String)          サブプロセス呼出カウンタ
   ├parallel_nest_cnt(String)         同期処理階層カウンタ
   ├present_display_info(String)      現処理表示情報
   ├extension_a(String)               拡張エリアＡ
   ├extension_b(String)               拡張エリアＢ
   ├extension_c(String)               拡張エリアＣ
   ├extension_d(String)               拡張エリアＤ
   ├extension_e(String)               拡張エリアＥ
   ├extension_f(String)               拡張エリアＦ
   ├extension_g(String)               拡張エリアＧ
   ├extension_h(String)               拡張エリアＨ
   ├create_date(String)               作成日時
   ├create_user_cd(String)            作成者コード
   ├create_user_name(String)          作成者名
   ├record_date(String)               最終更新日時
   ├record_user_cd(String)            最終更新者コード
   └record_user_name(String)          最終更新者名

  • 詳細

    指定されたプロセス定義の申請処理を行います。
    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。
    一時プロセスIDはドキュメントワークフロー起票時にファイル添付する場合に指定し、storage service上に作成された一時保管フォルダやインデックスファイルの名称と同じIDとします。
    Object  //次承認者オブジェクト
Object
├type    承認者タイプ(必須。ユーザ：user,/組織：orgn)
├comp_cd 会社コード(typeで組織選択時に指定します。)
└cd      承認ユーザ/組織コード(必須)

    Object  //根回しメールオブジェクト
Object
├title       根回しメールタイトル(必須)
├comment     根回しメールコメント(任意)
└user_list[] 根回しメール送信者リスト(必須)
   ├cd       送信先ユーザコード
   ├mail     送信先ユーザメールアドレス
   └name     送信先ユーザ名

retry()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)retry((String)process_def_cd, (String)version_cd, (String)process_cd, (String)process_name, (Array)app_key, (String)draft_appoint_date, (String)comp_cd, (String)orgn_cd, (String)comment, (Object)nego, (Object)executant, (String)next_actiity_cd, (String)locale)

  • 概要

    指定されたプロセスの再起票処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: バージョンコード(必須)
    (String) process_cd: プロセスコード(必須)
    (String) process_name: プロセス名(必須)
    (Array) app_key: アプリケーションキー配列(任意。0～9要素まで。)
    (String) draft_appoint_date: 起票指定日(任意。指定なしのときは起票日と同日。)
    (String) comp_cd: ユーザの起票会社コード(任意。指定なしのときは所属なし。)
    (String) orgn_cd: ユーザの起票組織コード(任意。指定なしのときは所属なし。)
    (String) comment: 再起票コメント(任意)
    (Object) nego: 根回しメールオブジェクト(任意)
    (Object) executant: 次承認者オブジェクト(次タスクが実行時選択のとき指定します。)
    (String) next_activity_cd: 次アクティビティコード(次タスクがユーザ選択のとき指定します。)
    (String) locale: ロケール(任意。指定なしのときはデフォルトロケールを使用します。)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    指定されたプロセスの再起票処理を行います。
    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。
    起票指定日は、引き戻した場合のみ指定可能です。差し戻された場合は起票時と同日になります。
    ユーザの起票会社コードは、引き戻した場合のみ指定可能です。差し戻された場合は起票時と同じになります。
    ユーザの起票組織コードは、引き戻した場合のみ指定可能です。差し戻された場合は起票時と同じになります。
    次承認者オブジェクトは、引き戻した場合のみ指定可能です。差し戻された場合は起票時と同じになります。
    次アクティビティコードは、引き戻した場合のみ指定可能です。差し戻された場合は起票時と同じになります。
    ロケールは、引き戻した場合のみ指定可能です。差し戻された場合は起票時と同じになります。
    Object  //次承認者オブジェクト
Object
├type    承認者タイプ(必須。ユーザ：user,/組織：orgn)
├comp_cd 会社コード(typeで組織選択時に指定します。)
└cd      承認ユーザ/組織コード(必須)

    Object  //根回しメールオブジェクト
Object
├title       根回しメールタイトル(必須)
├comment     根回しメールコメント(任意)
└user_list[] 根回しメール送信者リスト(必須)
   ├cd       送信先ユーザコード
   ├mail     送信先ユーザメールアドレス
   └name     送信先ユーザ名

cancel()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)cancel((String)process_def_cd, (String)version_cd, (String)process_cd, (String)comp_cd, (String)orgn_cd, (String)comment, (Object)nego)

  • 概要

    指定されたプロセスの取り止め処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: バージョンコード(必須)
    (String) process_cd: プロセスコード(必須)
    (String) comp_cd: ユーザの起票会社コード(任意。指定なしのときは所属なし。)
    (String) orgn_cd: ユーザの起票組織コード(任意。指定なしのときは所属なし。)
    (String) comment: 取り止めコメント(任意)
    (Object) nego: 根回しメールオブジェクト(任意)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    指定されたプロセスの取り止め処理を行います。
    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。
    ユーザの起票会社コードは、引き戻した場合のみ指定可能です。差し戻された場合は起票時と同じになります。
    ユーザの起票組織コードは、引き戻した場合のみ指定可能です。差し戻された場合は起票時と同じになります。
    Object  //根回しメールオブジェクト
Object
├title       根回しメールタイトル(必須)
├comment     根回しメールコメント(任意)
└user_list[] 根回しメール送信者リスト(必須)
   ├cd       送信先ユーザコード
   ├mail     送信先ユーザメールアドレス
   └name     送信先ユーザ名

pullBack()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)pullBack((String)process_def_cd, (String)version_cd, (String)process_cd)

  • 概要

    指定されたプロセスの引き戻し処理を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: 履歴コード(必須)
    (String) process_cd: プロセスコード(必須)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。

getEndProcessList()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getEndProcessList((Object)condition, (Array)sort, (Int)start, (Int)amount)

  • 概要

    起票済み案件一覧を取得します。

  • 入力値

    (Object) condition: 検索条件オブジェクト(必須。必ずフィルターをセットしてください。)
    (Array) sort: ソート指定オブジェクトの配列(任意。指定しないときはnullをセット。)
    (Int) start: フェッチ開始位置(任意。指定しないときは0をセット。)
    (Int) amount: フェッチ件数(任意。指定しないときは0をセット。)

  • 返却値

    Object配列  //起票済み案件オブジェクトの配列
Object
├category_cd(String)           カテゴリコード
├category_name(String)         カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String)     親プロセスバージョンコード
├parent_process_cd(String)     親プロセスコード
├process_def_cd(String)        プロセス定義コード
├process_def_name(String)      プロセス定義名
├version_cd(String)            バージョンコード
├version_name(String)          バージョン名
├process_cls_cd(String)        プロセス種別コード
├process_cd(String)            プロセスコード
├process_name(String)          プロセス名
├process_status(String)        プロセスステータス
├activity_cd(String)           アクティビティコード(isJunction=trueのときはnull)
├activity_name(String)         アクティビティ名(isJunction=trueのときはnull)
├activity_status(String)       アクティビティステータス(isJunction=trueのときはnull)
├attainment_class(String)      到達種別(isJunction=trueのときはnull)
├draft_appoint_date(String)    起票指定日
├draft_date(String)            起票日
├draft_user_cd(String)         起票者コード
├draft_user_name(String)       起票者名
├draft_user_comp_cd(String)    起票者の処理時の会社コード
├draft_user_orgn_cd(String)    起票者の処理時の組織コード
├draft_user_main_flg(String)   主・副所属フラグ
├isJunction(Boolean)           ルートが同期していればtrue
├now_approval_name(String)     現処理ユーザ/組織/オフィシャルG/ロール名(isJunction=trueのときはnull)
├reception_date(String)        受信日付
├process_term_date(String)     処理期限日付
├transfer_flg(Boolean)         代理起票フラグ
├client_auth_flg(Boolean)      代理元承認可否フラグ
├agent_target(String)          代理依頼先対象(起票者でインスタンス作成時)
├agent_cd(String)              代理依頼先ユーザ/組織コード(起票者でインスタンス作成時)
├agent_name(String)            代理依頼先ユーザ/組織名(起票者でインスタンス作成時)
├client_user_cd(String)        代理依頼元ユーザコード(代理起票者でインスタンス作成時)
├client_user_name(String)      代理依頼元ユーザ名(代理起票者でインスタンス作成時)
└pull_activity_flg(Boolean)    引き戻し可否フラグ(true:可/false:不可)
    エラー時 null

  • 詳細

    「検索条件オブジェクト」は、WkfSearchConditionオブジェクトを指定してください。
    このメソッドでは「go_filter」,「agt_go_filter」,「clt_agt_go_filter」, 「pullback_filter」,「agt_pullback_filter」,「clt_agt_pullback_filter」, 「sendback_filter」,「agt_sendback_filter」,「clt_agt_sendback_filter」, 「comp_filter」,「agt_comp_filter」,「clt_agt_comp_filter」が使用できます。
    いずれかのフィルターを必ずtrueに設定してください。
    代理人用のインスタンス生成時は、「go_filter」,「pullback_filter」, 「sendback_filter」,「comp_filter」は使用できません。
    「ソート指定オブジェクト」は、WkfSortオブジェクト配列を指定してください。
    「ソート指定オブジェクト」では、このメソッドで出力する項目のみソートキーとして指定できるものとする。
    「ソート指定オブジェクト」では、配列の要素１番が第一ソートキーになる。

    プロセス種別コードのコード値は以下のようになります。
  ビジネスプロセスワークフロー :0
  ドキュメントワークフロー　　 :1
  申請者ルート作成ワークフロー :2

プロセスステータスのコード値は以下のようになります。
  アクティブ :1
  完了　　　 :4

アクティビティステータスのコード値は以下のようになります。
  準備中　　 :0
  アクティブ :1
  保留中　　 :2
  取り消し中 :3
  完了　　　 :4

到達種別のコード値は以下のようになります。
  未到達　 :00
  通常到達 :01
  引戻し　 :20
  被引戻し :21
  差戻し　 :30
  被差戻し :31

noTransaction()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)noTransaction()

  • 概要

    データベーストランザクションを未使用にします。

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    起票等の処理時にトランザクションを張らずにデータベースの更新処理を行なうようになります。


WkfDrafter オブジェクト

概要

起票<起票者/代理起票者>

構造図
コンストラクタ(本人用)
コンストラクタ(代理人用)
メソッド
getActivityProcessDefList() | 起票可能プロセス一覧の取得
draft() | 起票処理の実行
retry() | 再起票処理の実行
cancel() | 取り止め処理の実行
pullBack() | 引き戻し処理の実行
getEndProcessList() | 起票済み案件一覧の取得
noTransaction() | データベーストランザクションを未使用にします


WkfManager オブジェクト ＡＰＩ

WkfManager()

  • プロトタイプ

    (Object) WkfManager((String)user_cd, (String)connectID)

  • 入力値

    (String) user_cd: ユーザID
    (String) connectID: DB接続参照名

  • 返却値

    なし

  • 詳細

    マスタオブジェクトを作成します。

getProcessList()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getProcessList((Object)condition, (Array)sort, (Int)start, (Int)amount)

  • 概要

    プロセス一覧を取得します。

  • 入力値

    (Object) condition: 検索条件オブジェクト(必須。必ずフィルターをセットしてください。)
    (Array) sort: ソート指定オブジェクトの配列(任意。指定しないときはnullをセット。)
    (Int) start: フェッチ開始位置(任意。指定しないときは0をセット。)
    (Int) amount: フェッチ件数(任意。指定しないときは0をセット。)

  • 返却値

    Object配列  //プロセス情報オブジェクトの配列
Object
├category_cd(String)           カテゴリコード
├category_name(String)         カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String)     親プロセスバージョンコード
├parent_process_cd(String)     親プロセスコード
├process_def_cd(String)        プロセス定義コード
├process_def_name(String)      プロセス定義名
├version_cd(String)            バージョンコード
├version_name(String)          バージョン名
├process_cls(String)           プロセス種別コード
├process_cd(String)            プロセスコード
├process_name(String)          プロセス名
├process_status(String)        プロセスステータス
├activity_cd(String)           アクティビティコード
├activity_name(String)         アクティビティ名
├activity_status(String)       アクティビティステータス
├attainment_class(String)      到達種別
├draft_appoint_date(String)    起票指定日
├draft_date(String)            起票日
├draft_user_cd(String)         起票者コード
├draft_user_name(String)       起票者名
├now_approval_name(String)     起票者名
├reception_date(String)        受信日付
└process_term_date(String)     処理期限日付
    エラー時 null

  • 詳細

    「検索条件オブジェクト」は、WkfSearchConditionオブジェクトを指定してください。
    このメソッドでは「go_filter」,「pullback_filter」,「sendback_filter」,「comp_filter」が使用できます。
    いずれかのフィルターを必ずtrueに設定してください。
    「ソート指定オブジェクト」は、WkfSortオブジェクト配列を指定してください。
    「ソート指定オブジェクト」では、このメソッドで出力する項目のみソートキーとして指定できるものとする。
    「ソート指定オブジェクト」では、配列の要素１番が第一ソートキーになる。

    プロセス種別コードのコード値は以下のようになります。
  ビジネスプロセスワークフロー :0
  ドキュメントワークフロー　　 :1
  申請者ルート作成ワークフロー :2

プロセスステータスのコード値は以下のようになります。
  アクティブ :1
  完了　　　 :4

アクティビティステータスのコード値は以下のようになります。
  準備中　　 :0
  アクティブ :1
  保留中　　 :2
  取り消し中 :3
  完了　　　 :4

到達種別のコード値は以下のようになります。
  未到達　 :00
  通常到達 :01
  引戻し　 :20
  被引戻し :21
  差戻し　 :30
  被差戻し :31

removeProcess()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object) removeProcess((String)process_def_cd, (String)version_cd, (String)process_cd, (Boolean)xml_out_flg)

  • 概要

    指定された案件の削除を実行します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: バージョンコード(必須)
    (String) process_cd: プロセスコード(必須)
    (Boolean) xml_out_flg: XML出力フラグ(必須)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    データベーストランザクションは標準で使用することになっており、使用しない場合は先に「noTransaction()」メソッドを使用してください。
    このAPIが実行された場合、案件の状態に関わらず削除を行います。

importProcessDef()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)importProcessDef((String)xls_file)

  • 概要

    プロセス定義のインポートを行います。

  • 入力値

    (String) xls_file: ローカルPCのファイルオブジェクト(必須)

  • 返却値

    Object  //処理結果オブジェクト
Object
├process_def_cd(String)     プロセス定義コード
├version_cd(String)         バージョンコード
├process_def_name(String)   プロセス定義名
├sheet_name(String)         シート名（Excelのシート名)
├status(String)             処理結果ID
└message(String)            処理結果メッセージ

  • 詳細

    入力値の「xls_file」はVirtualFile.load()メソッドを使用し、取得したファイルデータを渡してください。

    処理結果IDのコード値は以下のようになります。
  プロセス定義新規登録 :1
  バージョン追加　　　 :2
  プロセス定義更新　　 :3

exportProcessDef()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)exportProcessDef((array)process_def_cd)

  • 概要

    プロセス定義のエクスポートを行います。

  • 入力値

    (Array) process_def_cd[]: プロセス定義コード配列(必須)

  • 返却値

    エクセルファイルデータのバイト文字列

  • 詳細

    指定されたプロセス定義コードのプロセス定義をエクスポートします。
    返却値はエクセルファイルデータのバイト配列を文字列に変換したものが返却されます。

getCategoryInfo()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getCategoryInfo((String)category_cd)

  • 概要

    カテゴリコードをキーにしてカテゴリ情報を取得します。

  • 入力値

    (String) category_cd: カテゴリコード(必須)

  • 返却値

    Object  //カテゴリ情報オブジェクト
Object
├category_cd(String)            カテゴリコード
├category_name(String)          カテゴリ名
├category_note(String)          備考
├edit_athorities(Array)         編集権限リスト。(各要素はロールIDの文字列)
└processing_authorities(Array)  処理権限リスト。(各要素はロールIDの文字列)
エラー時 null

  • 詳細

    指定されたカテゴリコードをキーにして、カテゴリ情報を取得します。

getCategoryInfoByName()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getCategoryInfoByName((String)category_name)

  • 概要

    カテゴリ名をキーにしてカテゴリ情報を取得します。

  • 入力値

    (String) category_name: カテゴリ名(必須)

  • 返却値

    (Array)カテゴリ情報オブジェクト配列
    エラー時 null

  • 詳細

    カテゴリ情報オブジェクトについては、getCategoryInfo()メソッドを参照してください。

getProcessDefInfo()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getProcessDefInfo((String)process_def_cd)

  • 概要

    プロセス定義コードをキーにしてプロセス定義情報を取得します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)

  • 返却値

    Object  //プロセス定義情報オブジェクト
Object
├category_cd(String)       カテゴリコード
├process_def_cd(String)    プロセス定義コード
├process_def_name(String)  プロセス定義名
├note(String)              備考
├new_version_cd(String)    最新バージョンコード
├process_count(Int)        プロセス数
└active_process_count(Int) アクティブなプロセス数
エラー時 null

  • 詳細

    指定されたプロセス定義コードをキーにして、プロセス定義情報を取得します。

getProcessDefInfoByName()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getProcessDefInfoByName((String)process_def_name)

  • 概要

    プロセス定義コードをキーにしてプロセス定義情報を取得します。

  • 入力値

    (String)process_def_name: プロセス定義名(必須)

  • 返却値

    (Array)プロセス定義情報オブジェクト配列
    エラー時 null

  • 詳細

    プロセス定義情報オブジェクトについては、getProcessDefInfo()メソッドを参照してください。

getVersionInfo()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getVersionInfo((String)process_def_cd, (String)version_cd)

  • 概要

    バージョン(ルート)情報を取得します。

  • 入力値

    (String)process_def_cd: プロセス定義コード(必須)
    (String)version_cd: バージョンコード(必須)

  • 返却値

    Object  //バージョン情報オブジェクトの配列
Object
├process_def_cd(String)          プロセス定義コード
├version_cd(String)              バージョンコード
├version_name(String)            バージョン名
├note(String)                    備考
├start_date(String)              開始日付
├end_date(String)                終了日付
├root_type(String)               ルート種別
├contents_path(Object)           コンテンツパス
   ├page_kind(String)               ページ種別
   ├contents_path(String)           コンテンツパス
   ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
   ├service_id(String)              サービスID(page_kindがframeworkの場合)
   └tab_cd(String)                  タブコード(page_kindがポータルの場合)
├pull_back_contents_path(Object) 引き戻しコンテンツパス
   ├page_kind(String)               ページ種別
   ├contents_path(String)           コンテンツパス
   ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
   ├service_id(String)              サービスID(page_kindがframeworkの場合)
   └tab_cd(String)                  タブコード(page_kindがポータルの場合)
├return_contents_path(Object)    差し戻しコンテンツパス
   ├page_kind(String)               ページ種別
   ├contents_path(String)           コンテンツパス
   ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
   ├service_id(String)              サービスID(page_kindがframeworkの場合)
   └tab_cd(String)                  タブコード(page_kindがポータルの場合)
├refer_contents_path(Object)     参照コンテンツパス
   ├page_kind(String)               ページ種別
   ├contents_path(String)           コンテンツパス
   ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
   ├service_id(String)              サービスID(page_kindがframeworkの場合)
   └tab_cd(String)                  タブコード(page_kindがポータルの場合)
└detail_contents_path(Object)    詳細コンテンツパス
   ├page_kind(String)               ページ種別
   ├contents_path(String)           コンテンツパス
   ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
   ├service_id(String)              サービスID(page_kindがframeworkの場合)
   └tab_cd(String)                  タブコード(page_kindがポータルの場合)
    エラー時 null

  • 詳細

    指定されたプロセス定義コード、バージョンコードをキーにして、バージョン(ルート)情報を取得します。

getActivityInfo()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getActivityInfo((String)process_def_cd, (String)version_cd, (String)activity_cd)

  • 概要

    タスク(アクティビティ)情報を取得します。

  • 入力値

    (String)process_def_cd: プロセス定義コード(必須)
    (String)version_cd: バージョンコード(必須)
    (String)activity_cd: アクティビティコード(必須)

  • 返却値

    Object  //タスク情報オブジェクトの配列
Object
 ├process_def_cd(String)           プロセス定義コード
 ├version_cd(String)               バージョンコード
 ├activity_cd(String)              アクティビティコード
 ├activiyty_name(String)           アクティビティ名
 ├activity_type_cd(String)         アクティビティ種別
(アクティビティ種別がRECEIVEの場合)
 ├copulsion_end_flg(Boolean)       終了可能フラグ
 ├return_flg(Boolean)              差し戻し/引き戻しフラグ
 ├return_mail_flg(Boolean)         差し戻しメールフラグ
 ├client_auth_flg(Boolean)         代理元承認可否フラグ
 ├post_processing__flg(Boolean)    後処理使用フラグ
 ├post_processing_program(String)  後処理プログラム名
 ├run_user(Array)                  対象者情報(Objectの配列)
     ├run_type(String)                対象者種別
     ├run_cd(String)                  対象者コード
     ├run_role_restrict(String)       ロールによる絞込みのロールID(対象者種別が組織の場合)
     └run_post_restrict(String)       役職による絞込みの役職コード(対象者種別が組織の場合)
 ├refer_user(Array)                参照者情報(Objectの配列)
     ├run_type(String)                対象者種別
     ├run_cd(String)                  対象者コード
     ├run_role_restrict(String)       ロールによる絞込みのロールID(対象者種別が組織の場合)
     └run_post_restrict(String)       役職による絞込みの役職コード(対象者種別が組織の場合)
 ├contents_path(Object)            コンテンツパス
     ├page_kind(String)               ページ種別
     ├contents_path(String)           コンテンツパス
     ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
     ├service_id(String)              サービスID(page_kindがframeworkの場合)
     └tab_cd(String)                  タブコード(page_kindがポータルの場合)
 ├pull_back_contents_path(Object)  引き戻しコンテンツパス
     ├page_kind(String)               ページ種別
     ├contents_path(String)           コンテンツパス
     ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
     ├service_id(String)              サービスID(page_kindがframeworkの場合)
     └tab_cd(String)                  タブコード(page_kindがポータルの場合)
 ├return_contents_path(Object)     差し戻しコンテンツパス
     ├page_kind(String)               ページ種別
     ├contents_path(String)           コンテンツパス
     ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
     ├service_id(String)              サービスID(page_kindがframeworkの場合)
     └tab_cd(String)                  タブコード(page_kindがポータルの場合)
 ├auto_pass(Int)                   期日による自動パス設定の日数
 ├auto_pass_executive(Object)      対象者による自動パス設定情報
     ├executive_flg(Boolean)          自動パスフラグ
     └executive_user(Array)           自動パス対象者情報配列(Objectの配列)
         ├executive_type(String)         対象者種別
         └executive_cd(String)           対象者コード
 ├reminder(Object)                 催促メール情報
     ├reminder_flg(Boolean)           催促メール使用フラグ
     └reminder_date(String)           催促猶予日数
(アクティビティ種別がFLOWの場合)

 ├combine_class(String)            条件結合クラス
(アクティビティ種別がINVOKE_AUTOの場合)
 ├run_class(String)                自動実行クラス
(アクティビティ種別がINVOKE_EVENTの場合)
 ├event_id(String)                 イベントID
(アクティビティ種別がINVOKE_PROCESSの場合)
 ├call_process_def_cd(String)      呼出しプロセス定義コード
 ├draft_type_kind(String)          起票タイプ
(アクティビティ種別がINVOKE_PROCESSの場合)
 └switch_info(Array)               実行クラス情報(Objectの配列。配列の順番に評価されます。)
     ├condition_no(Int)               実行比較番号(配列の要素番号と同じ)
     ├run_activity_cd(String)         次に実行されるタスクのアクティビティコード
     └run_class(String)               実行クラス
    エラー時 null

  • 詳細

    プロセス定義コードとバージョンコードとアクティビティコードをキーにして、タスク(アクティビティ)情報を取得します。

getFrowInfo()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getFlowInfo((String)process_def_cd, (String)version_cd, (String)activity_cd)

  • 概要

    特定のタスクの位置情報を保持している、フロー情報を取得します。

  • 入力値

    (String) process_def_cd: プロセス定義コード(必須)
    (String) version_cd: バージョンコード(必須)
    (String) activity_cd: アクティビティコード(必須)

  • 返却値

    (FlowInfo)フロー情報オブジェクトの配列

  • 詳細

    フロー情報オブジェクトについては、FlowInfoクラスを参照してください。

noTransaction()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)noTransaction()

  • 概要

    データベーストランザクションを未使用にします。

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    プロセスの削除時にトランザクションを張らずにデータベースの更新処理を行なうようになります。


WkfManager オブジェクト

概要

マスタ関連

構造図
コンストラクタ
メソッド
getProcessList() | プロセス一覧の取得
removeProcess() | プロセスの削除
importProcessDef() | プロセス定義のインポート
exportProcessDef() | プロセス定義のエクスポート
getCategoryInfo() | カテゴリコードをキーにカテゴリ情報を取得します
getCategoryInfoByName() | カテゴリ名をキーにカテゴリ情報を取得します
getProcessDefInfo() | プロセス定義コードをキーにプロセス定義情報を取得します
getProcessDefInfoByName() | プロセス定義名をキーにプロセス定義情報を取得します
getVersionInfo() | バージョン情報を取得します
getActivityInfo() | タスク(アクティビティ)情報を取得します
getFlowInfo() | 特定のタスクの位置情報を保持した、フローの情報を取得します
noTransaction() | データベーストランザクションを未使用にします


WkfProcess オブジェクト ＡＰＩ

WkfProcess()

  • プロトタイプ

    (Object) WkfProcess((String)process_def_cd, (String)version_cd, (String)process_cd, (String)connectID)

  • 入力値

    (String) process_def_cd: プロセス定義コード
    (String) version_cd: バージョンコード
    (String) process_cd: プロセスコード
    (String) connectID: DB接続参照名

  • 返却値

    なし

  • 詳細

    起票されている案件オブジェクトの作成します。

getFileList()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getFileList()

  • 概要

    添付ファイルの一覧取得

  • 入力値

    なし

  • 返却値

    Object配列  //添付ファイルオブジェクトの配列
Object
├path(String)        ファイルパス(storageからの相対パス)
├file_cd(String)     ファイルID
├file_name(String)   ファイル名（論理ファイル名）
└file_size(Int)      ファイルサイズ(バイト)
    エラー時 null

  • 詳細

    プロセスに添付されたファイルの一覧を「添付ファイルオブジェクト」として返却します。

getProcessHistory()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object) getProcessHistory()

  • 概要

    案件の処理履歴取得

  • 入力値

    なし

  • 返却値

    Object  //プロセス処理履歴オブジェクト
Object
├process_def_cd(String)        プロセス定義コード
├version_cd(String)            バージョンコード
├process_cd(String)            プロセスコード
├activity_cd(String)           アクティビティコード
├activity_name(String)         アクティビティ名
├activity_status(String)       アクティビティステータス
├activity_type(String)         アクティビティ種別
├call_process_cd(String)       親プロセスコード
├status_end_date(String)       ステータス完了日付
├approval_user_cd(String)      承認者コード
├approval_user_name(String)    承認者名
├approval_type(String)         承認種別
├comp_cd(String)               処理者の処理時の会社コード
├orgn_cd(String)               処理者の処理時の組織コード
├orgn_name(String)             処理者の処理時の組織名
├main_flg(Boolean)             主・副所属フラグ（主所属の場合、trueを返す）
├commnet(String)               承認時のコメント
├agent_tran_flg(String)        代理_振替えフラグ
├agent_tran_user_cd(String)    代理_振替元ユーザコード
└agent_tran_user_name(String)  代理_振替元ユーザ名

  • 詳細

    案件の処理履歴が実際にワークフローが遷移した順に出力されます。
    次の処理履歴があるか確認するには「hasNext()」メソッドを使用してください。(詳しくは「hasNext()」を参照してください。)
    次の処理履歴を取得するには「next()」メソッドを使用してください。(詳しくは「next()」を参照してください。)

    アクティビティステータスのコード値は以下のようになります。
  準備中　　 :0
  アクティブ :1
  保留中　　 :2
  取り消し中 :3
  完了　　　 :4

アクティビティ種別は常にレシーブ(処理タスク)となります。

getFlow()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getFlow()

  • 概要

    プロセス上の現在位置取得

  • 入力値

    なし

  • 返却値

    Object配列  //現在位置情報オブジェクト配列
Object
├process_def_cd(String)     プロセス定義コード
├version_cd(String)         バージョンコード
├process_cd(String)         プロセスコード
└activity_cd(String)        アクティビティコード

  • 詳細

    現在承認待ちになっているタスクの位置情報を取得します。

getProcessInfo()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getProcessInfo()

  • 概要

    プロセス情報の取得

  • 入力値

    なし

  • 返却値

    Object  //プロセス情報オブジェクト
Object
├category_cd(String)               カテゴリコード
├category_name(String)             カテゴリ名
├parent_process_def_cd(String)     親プロセス定義コード
├parent_version_cd(String)         親プロセスバージョンコード
├parent_process_cd(String)         親プロセスコード
├parent_activity_cd(String)        親アクティビティコード
├process_def_cd(String)            プロセス定義コード
├process_def_name(String)          プロセス定義名
├version_cd(String)                バージョンコード
├version_name(String)              バージョン名
├process_cd(String)                プロセスコード
├process_name(String)              プロセス名
├process_status(String)            プロセスステータス
├last_man_activity_cd(String)      最終手動アクティビティコード
├last_man_activity_result(String)  最終手動アクティビティ承認結果種別
├draft_appoint_date(String)        起票指定日
├draft_date(String)                起票日
├draft_user_cd(String)             起票者コード
├draft_user_name(String)           起票者名
├draft_comment(String)             起票時コメント
└app_key(Array)                    アプリケーションキー配列(String配列)

  • 詳細

    案件の現在の情報を取得し、整形してプロセス情報オブジェクトとして返却します。

    プロセスステータスのコード値は以下のようになります。
  アクティブ :1
  完了　　　 :4

getTaskResultInfo()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)getTaskResultInfo((String)activity_cd)

  • 概要

    タスク処理結果情報の取得

  • 入力値

    (String) activity_cd: アクティビティコード(必須)

  • 返却値

    Object  //タスク処理結果オブジェクト
Object
├process_def_cd(String)             プロセス定義コード
├version_cd(String)                 バージョンコード
├process_cd(String)                 プロセスコード
├activity_cd(String)                アクティビティコード
├activity_name(String)              アクティビティ名
├activity_type(String)              アクティビティ種別
├activity_status(String)            アクティビティステータス
├attainment_class(String)           到達種別
├activity_status_comp_date(String)  ステータス完了日付
├reception_date(String)             受信日付
├process_term_date(String)          処理期限日付
├approval_type(String)              処理結果
├approval_user_cd(String)           処理ユーザコード
├approval_user_name(String)         処理ユーザ名
├approval_comment(String)           処理時コメント
├approval_date(String)              処理日
├auto_pass_term(String)             自動パス（バッチ）期限
├auto_pass_flag(String)             自動パス（バッチ）処理フラグ
├present_process(String)            現処理表示文字
├transfer_flg(String)               代理依頼フラグ
├delegate_flg(String)               振り替えフラグ
├agent_target(String)               代理依頼先対象(ユーザ/会社組織)
├agent_comp_cd(String)              代理依頼先会社コード（代理に組織を指定時）
├agent_cd(String)                   代理依頼先ユーザ/組織コード
├agent_name(String)                 代理依頼先ユーザ/組織名
├client_user_cd(String)             代理依頼元ユーザコード
└client_user_name(String)           代理依頼元ユーザ名
エラー時 null

  • 詳細

    アクティビティコードをキーとしてタスクの現在の情報を返却します。

    アクティビティ種別は常にレシーブ(処理タスク)となります。

アクティビティステータスのコード値は以下のようになります。
  準備中　　 :0
  アクティブ :1
  保留中　　 :2
  取り消し中 :3
  完了　　　 :4

到達種別のコード値は以下のようになります。
  未到達　 :00
  通常到達 :01
  引戻し　 :20
  被引戻し :21
  差戻し　 :30
  被差戻し :31

処理結果のコード値は以下のようになります。
  申請　　　　　　 :0
  再申請　　　　　 :1
  承認　　　　　　 :2
  棄却　　　　　　 :3
  申請者へ差戻し　 :4
  前処理者へ差戻し :5
  引き戻し　　　　 :6
  保留　　　　　　 :7
  取り止め　　　　 :8
  対象者自動パス　 :9
  プロセス操作　　 :99

hasNext()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)hasNext()

  • 概要

    次のタスクが存在するかどうかを返却します。
    このメソッドは「getProcessHistory()」を使用した後に使用します。

  • 入力値

    なし

  • 返却値

    (boolean)true:存在する/false:存在しない

  • 詳細

    「getProcessHistory()」メソッドで取得した処理結果の次の処理結果があるかどうかを返却します。
    このメソッドは必ず「getProcessHistory()」メソッドを実行した後に使用してください。

next()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)next()

  • 概要

    自分自身のオブジェクトを、次のタスクに遷移させます。
    このメソッドは「getProcessHistory()」を使用した後に使用します。

  • 入力値

    なし

  • 返却値

    (Object)プロセス処理履歴オブジェクト(詳しくは、「getProcessHistory()」を参照してください。)

  • 詳細

    「getProcessHistory()」メソッドで取得した処理結果の次の処理結果を返却します。
    このメソッドは必ず「getProcessHistory()」メソッドを実行した後に使用してください。


WkfProcess オブジェクト

概要

案件

構造図
コンストラクタ
メソッド
getFileList() | 添付ファイル一覧の取得
getProcessHistory() | 案件の処理履歴取得
getFlow() | プロセス上の現在位置取得
getProcessInfo() | プロセス情報の取得
getTaskResultInfo() | タスク処理結果情報の取得
hasNext() | 次のタスクが存在するかどうか返却します
next() | 自分自身のオブジェクトを、次のタスクに遷移させます


WkfReference オブジェクト ＡＰＩ

WkfReference()

  • プロトタイプ

    (Object) WkfReference((String)user_cd, (String)connectID)

  • 入力値

    (String) user_cd: 参照者のユーザID
    (String) connectID: DB接続参照名

  • 返却値

    なし

  • 詳細

    引数２つのコンストラクタ
    参照者オブジェクトを作成します。

getReferTaskList()

  • プロトタイプ

    Array 型インスタンスメソッド
    (Array)getReferTaskList((Object)condition, (Array)sort, (Int)start, (Int)amount)

  • 概要

    参照可能案件一覧を取得します。

  • 入力値

    (Object) condition: 検索条件オブジェクト(必須。必ずフィルターをセットしてください。)
    (Array) sort: ソート指定オブジェクトの配列(任意。指定しないときはnullをセット。)
    (Int) start: フェッチ開始位置(任意。指定しないときは0をセット。)
    (Int) amount: フェッチ件数(任意。指定しないときは0をセット。)

  • 返却値

    Object配列  //参照可能案件オブジェクトの配列
Object
├category_cd           カテゴリコード
├category_name         カテゴリ名
├parent_process_def_cd 親プロセス定義コード
├parent_version_cd     親プロセスバージョンコード
├parent_process_cd     親プロセスコード
├process_def_cd        プロセス定義コード
├process_def_name      プロセス定義名
├version_cd            バージョンコード
├version_name          バージョン名
├process_cls_cd        プロセス種別コード
├process_cd            プロセスコード
├process_name          プロセス名
├process_status        プロセスステータス
├activity_cd           アクティビティコード
├activity_name         アクティビティ名
├draft_appoint_date    起票指定日
├draft_date            起票日
├draft_user_cd         起票者コード
└draft_user_name       起票者名
    エラー時 null

  • 詳細

    「検索条件オブジェクト」は、WkfSearchConditionオブジェクトを指定してください。
    このメソッドでは「go_filter」,「comp_filter」が使用できます。
    いずれかのフィルターを必ずtrueに設定してください。
    「ソート指定オブジェクト」は、WkfSortオブジェクト配列を指定してください。
    「ソート指定オブジェクト」では、このメソッドで出力する項目のみソートキーとして指定できるものとする。
    「ソート指定オブジェクト」では、配列の要素１番が第一ソートキーになる。

    プロセス種別コードのコード値は以下のようになります。
  ビジネスプロセスワークフロー :0
  ドキュメントワークフロー　　 :1
  申請者ルート作成ワークフロー :2

プロセスステータスのコード値は以下のようになります。
  アクティブ :1
  完了　　　 :4


WkfReference オブジェクト

概要

参照者

構造図
コンストラクタ
メソッド
getReferTaskList() 参照可能案件一覧の取得


WkfSearchCondition オブジェクト ＡＰＩ

WkfSearchCondition()

  • プロトタイプ

    (Object) WkfSearchCondition()

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    検索条件設定オブジェクトを作成します。

setCondition()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setCondition((Object)condition)

  • 概要

    検索条件を設定します

  • 入力値

    Object  //検索条件オブジェクト
Object
├go_filter(Boolean)               未処理タスクの表示(本人)
├agt_go_filter(Boolean)           未処理タスクの表示(代理元承認不可)
├clt_agt_go_filter(Boolean)       未処理タスクの表示(代理元承認可)
├pullback_filter(Boolean)         引き戻しタスクの表示(本人)
├agt_pullback_filter(Boolean)     引き戻しタスクの表示(代理元承認不可)
├clt_agt_pullback_filter(Boolean) 引き戻しタスクの表示(代理元承認可)
├sendback_filter(Boolean)         差し戻しタスクの表示(本人)
├agt_sendback_filter(Boolean)     差し戻しタスクの表示(代理元承認不可)
├clt_agt_sendback_filter(Boolean) 差し戻しタスクの表示(代理元承認可)
├comp_filter(Boolean)             完了タスクの表示(本人)
├agt_comp_filter(Boolean)         完了タスクの表示(代理元承認不可)
├clt_agt_comp_filter(Boolean)     完了タスクの表示(代理元承認可)
├category_cd(String)              カテゴリコード
├category_name(String)            カテゴリ名
├process_def_cd(String)           プロセス定義コード
├process_def_name(String)         プロセス定義名
├version_cd(String)               バージョンコード
├process_cd(String)               プロセスコード
├process_name(String)             プロセス名
├activity_cd(String)              アクティビティコード
├activity_name(String)            アクティビティ名
├draft_user_cd(String)            起票者コード
├draft_user_name(String)          起票者名
├draft_comp_cd(String)            起票者の起票会社コード
├draft_orgn_cd(String)            起票者の起票組織コード
├draft_appoint_date(String)       起票指定日
├draft_date_start(String)         起票日(検索範囲開始日)
├draft_date_end(String)           起票日(検索範囲終了日)
├before_user_cd(String)           前処理者ユーザコード
├before_user_name(String)         前処理者ユーザ名
├approval_user_cd(String)         処理者ユーザコード
├approval_user_name(String)       処理者ユーザ名
├approval_comp_cd(String)         処理者の会社コード
├approval_orgn_cd(String)         処理者の会社組織コード
├approval_orgn_name(String)       処理者の会社組織名
├approval_date_start(String)      処理日(検索範囲開始日)
├approval_date_end(String)        処理日(検索範囲終了日)
├agent_user_cd(String)            代理依頼元ユーザコード
├agent_user_name(String)          代理依頼元ユーザ名
├arrive_date_start(String)        到達日(検索範囲開始日)
├arrive_date_end(String)          到達日(検索範囲終了日)
├limit_date_start(String)         処理期限日(検索範囲開始日)
└limit_date_end(String)           処理期限日(検索範囲終了日)

  • 返却値

    なし

  • 詳細

    検索条件を設定します。
    指定できる検索条件は各検索メソッドの戻り値に指定されている項目のみとなります。

    フィルターについて
    フィルターは、未処理タスクの表示(go)、引き戻しタスクの表示(pullback)、差し戻しタスクの表示(sendback)、完了タスクの表示(comp)に分かれています。
    また、それぞれのフィルターに本人、代理元承認不可の代理、代理元承認可の代理の3種類のフィルターがあります。
    <例>未処理タスクの表示の場合
  ・go_filter:未処理タスク(本人処理タスク)を表示します。
  ・agt_go_filter:未処理タスク(代理元承認不可の代理中のタスク)を表示します。
  ・clt_agt_go_filter:未処理タスク(代理元承認可の代理中のタスク)を表示します。
    必ず、いずれかのフィルターをtrueに設定してください。
    go_filterとagt_go_filterを同時に設定することは出来ますが、go_filterとpullback_filterを同時に設定することは出来ません。

getGoFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getGoFilter()

  • 概要

    未処理タスク表示を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 未処理タスク表示(true:表示する/false:表示しない)

  • 詳細

    セットされた、未処理タスク表示を返却します。

getAgtGoFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getAgtGoFilter()

  • 概要

    未処理タスク表示(委譲)を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 未処理タスク表示(委譲)(true:表示する/false:表示しない)

  • 詳細

    セットされた、未処理タスク表示(委譲)を返却します。

getCltAgtGoFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getCltAgtGoFilter()

  • 概要

    未処理タスク表示(代理元処理可委譲)を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 未処理タスク表示(代理元処理可委譲)(true:表示する/false:表示しない)

  • 詳細

    セットされた、未処理タスク表示(代理元処理可委譲)を返却します。

getPullbackFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getPullbackFilter()

  • 概要

    引戻しタスク表示を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 引戻しタスク表示(true:表示する/false:表示しない)

  • 詳細

    セットされた、引戻しタスク表示を返却します。

getAgtPullbackFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getAgtPullbackFilter()

  • 概要

    引戻しタスク表示(委譲)を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 引戻しタスク表示(委譲)(true:表示する/false:表示しない)

  • 詳細

    セットされた、引戻しタスク表示(委譲)を返却します。

getCltAgtPullbackFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getCltAgtPullbackFilter()

  • 概要

    引戻しタスク表示(代理元処理可委譲)を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 引戻しタスク表示(代理元処理可委譲)(true:表示する/false:表示しない)

  • 詳細

    セットされた、引戻しタスク表示(代理元処理可委譲)を返却します。

getSendbackFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getSendbackFilter()

  • 概要

    差し戻しタスク表示を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 差し戻しタスク表示(true:表示する/false:表示しない)

  • 詳細

    セットされた、差し戻しタスク表示を返却します。

getAgtSendbackFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getAgtSendbackFilter()

  • 概要

    差し戻しタスク表示(委譲)を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 差し戻しタスク表示(委譲)(true:表示する/false:表示しない)

  • 詳細

    セットされた、差し戻しタスク表示(委譲)を返却します。

getCltAgtSendbackFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getCltAgtSendbackFilter()

  • 概要

    差し戻しタスク表示(代理元処理可委譲)を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 差し戻しタスク表示(代理元処理可委譲)(true:表示する/false:表示しない)

  • 詳細

    セットされた、差し戻しタスク表示(代理元処理可委譲)を返却します。

getCompFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getCompFilter()

  • 概要

    完了タスク表示を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 完了タスク表示(true:表示する/false:表示しない)

  • 詳細

    セットされた、完了タスク表示を返却します。

getAgtCompFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getAgtCompFilter()

  • 概要

    完了タスク表示(委譲)を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 完了タスク表示(委譲)(true:表示する/false:表示しない)

  • 詳細

    セットされた、完了タスク表示(委譲)を返却します。

getCltAgtCompFilter()

  • プロトタイプ

    boolean 型インスタンスメソッド
    (boolean)getCltAgtCompFilter()

  • 概要

    完了タスク表示(代理元処理可委譲)を返却します

  • 入力値

    なし

  • 返却値

    (boolean) 完了タスク表示(代理元処理可委譲)(true:表示する/false:表示しない)

  • 詳細

    セットされた、完了タスク表示(代理元処理可委譲)を返却します。

getCategoryCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getCategoryCd()

  • 概要

    カテゴリコードを返却します

  • 入力値

    なし

  • 返却値

    (String) カテゴリコード

  • 詳細

    セットされた、カテゴリコードを返却します。

getCategoryName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getCategoryName()

  • 概要

    カテゴリ名を返却します

  • 入力値

    なし

  • 返却値

    (String) カテゴリ名

  • 詳細

    セットされた、カテゴリ名を返却します。

getProcessDefCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getProcessDefCd()

  • 概要

    プロセス定義コードを返却します

  • 入力値

    なし

  • 返却値

    (String) プロセス定義コード

  • 詳細

    セットされた、プロセス定義コードを返却します。

getProcessDefName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getProcessDefName()

  • 概要

    プロセス定義名を返却します

  • 入力値

    なし

  • 返却値

    (String) プロセス定義名

  • 詳細

    セットされた、プロセス定義名を返却します。

getVersionCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getVersionCd()

  • 概要

    バージョンコードを返却します

  • 入力値

    なし

  • 返却値

    (String) バージョンコード

  • 詳細

    セットされた、バージョンコードを返却します。

getProcessCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getProcessCd()

  • 概要

    プロセスコードを返却します

  • 入力値

    なし

  • 返却値

    (String) プロセスコード

  • 詳細

    セットされた、プロセスコードを返却します。

getProcessName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getProcessName()

  • 概要

    プロセス名を返却します

  • 入力値

    なし

  • 返却値

    (String) プロセス名

  • 詳細

    セットされた、プロセス名を返却します。

getActivityCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getActivityCd()

  • 概要

    アクティビティコードを返却します

  • 入力値

    なし

  • 返却値

    (String) アクティビティコード

  • 詳細

    セットされた、アクティビティコードを返却します。

getActivityName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getActivityName()

  • 概要

    アクティビティ名を返却します

  • 入力値

    なし

  • 返却値

    (String) アクティビティ名

  • 詳細

    セットされた、アクティビティ名を返却します。

getDraftUserCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getDraftUserCd()

  • 概要

    起票者ユーザコードを返却します

  • 入力値

    なし

  • 返却値

    (String) 起票者ユーザコード

  • 詳細

    セットされた、起票者ユーザコードを返却します。

getDraftUserName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getDraftUserName()

  • 概要

    起票者ユーザ名を返却します

  • 入力値

    なし

  • 返却値

    (String) 起票者ユーザ名

  • 詳細

    セットされた、起票者ユーザ名を返却します。

getDraftCompCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getDraftCompCd()

  • 概要

    起票者の会社コードを返却します

  • 入力値

    なし

  • 返却値

    (String) 起票者の会社コード

  • 詳細

    セットされた、起票者の会社コードを返却します。

getDraftOrgnCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getDraftOrgnCd()

  • 概要

    起票者の会社組織コードを返却します

  • 入力値

    なし

  • 返却値

    (String) 起票者の会社組織コード

  • 詳細

    セットされた、起票者の会社組織コードを返却します。

getDraftAppointDate()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getDraftAppointDate()

  • 概要

    起票指定日を返却します

  • 入力値

    なし

  • 返却値

    (String) 起票指定日

  • 詳細

    セットされた、起票指定日を返却します。

getDraftDateStart()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getDraftDateStart()

  • 概要

    起票日(検索範囲開始日)を返却します

  • 入力値

    なし

  • 返却値

    (String) 起票日(検索範囲開始日)

  • 詳細

    セットされた、起票日(検索範囲開始日)を返却します。

getDraftDateEnd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getDraftDateEnd()

  • 概要

    起票日(検索範囲終了日)を返却します

  • 入力値

    なし

  • 返却値

    (String) 起票日(検索範囲終了日)

  • 詳細

    セットされた、起票日(検索範囲終了日)を返却します。

getBeforeUserCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getBeforeUserCd()

  • 概要

    前処理者ユーザコードを返却します

  • 入力値

    なし

  • 返却値

    (String) 前処理者ユーザコード

  • 詳細

    セットされた、前処理者ユーザコードを返却します。

getBeforeUserName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getBeforeUserName()

  • 概要

    前処理者ユーザ名を返却します

  • 入力値

    なし

  • 返却値

    (String) 前処理者ユーザ名

  • 詳細

    セットされた、前処理者ユーザ名を返却します。

getApprovalUserCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getApprovalUserCd()

  • 概要

    処理者ユーザコードを返却します

  • 入力値

    なし

  • 返却値

    (String) 処理者ユーザコード

  • 詳細

    セットされた、処理者ユーザコードを返却します。

getApprovalUserName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getApprovalUserName()

  • 概要

    処理者ユーザ名を返却します

  • 入力値

    なし

  • 返却値

    (String) 処理者ユーザ名

  • 詳細

    セットされた、処理者ユーザ名を返却します。

getApprovalCompCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getApprovalCompCd()

  • 概要

    処理者の会社コードを返却します

  • 入力値

    なし

  • 返却値

    (String) 処理者の会社コード

  • 詳細

    セットされた、処理者の会社コードを返却します。

getApprovalOrgnCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getApprovalOrgnCd()

  • 概要

    処理者の会社組織コードを返却します

  • 入力値

    なし

  • 返却値

    (String) 処理者の会社組織コード

  • 詳細

    セットされた、処理者の会社組織コードを返却します。

getApprovalOrgnName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getApprovalOrgnName()

  • 概要

    処理者の会社組織名を返却します

  • 入力値

    なし

  • 返却値

    (String) 処理者の会社組織名

  • 詳細

    セットされた、処理者の会社組織名を返却します。

getApprovalDateStart()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getApprovalDateStart()

  • 概要

    処理日(検索範囲開始日)を返却します

  • 入力値

    なし

  • 返却値

    (String) 処理日(検索範囲開始日)

  • 詳細

    セットされた、処理日(検索範囲開始日)を返却します。

getApprovalDateEnd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getApprovalDateEnd()

  • 概要

    処理日(検索範囲終了日)を返却します

  • 入力値

    なし

  • 返却値

    (String) 処理日(検索範囲終了日)

  • 詳細

    セットされた、処理日(検索範囲終了日)を返却します。

getAgentUserCd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getAgentUserCd()

  • 概要

    代理依頼元ユーザコードを返却します

  • 入力値

    なし

  • 返却値

    (String) 代理依頼元ユーザコード

  • 詳細

    セットされた、代理依頼元ユーザコードを返却します。

getAgentUserName()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getAgentUserName()

  • 概要

    代理依頼元ユーザ名を返却します

  • 入力値

    なし

  • 返却値

    (String) 代理依頼元ユーザ名

  • 詳細

    セットされた、代理依頼元ユーザ名を返却します。

getArriveDateStart()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getArriveDateStart()

  • 概要

    到達日(検索範囲開始日)を返却します

  • 入力値

    なし

  • 返却値

    (String) 到達日(検索範囲開始日)

  • 詳細

    セットされた、到達日(検索範囲開始日)を返却します。

getArriveDateEnd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getArriveDateEnd()

  • 概要

    到達日(検索範囲終了日)を返却します

  • 入力値

    なし

  • 返却値

    (String) 到達日(検索範囲終了日)

  • 詳細

    セットされた、到達日(検索範囲終了日)を返却します。

getLimitDateStart()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLimitDateStart()

  • 概要

    処理期限日(検索範囲開始日)を返却します

  • 入力値

    なし

  • 返却値

    (String) 処理期限日(検索範囲開始日)

  • 詳細

    セットされた、処理期限日(検索範囲開始日)を返却します。

getLimitDateEnd()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getLimitDateEnd()

  • 概要

    処理期限日(検索範囲終了日)を返却します

  • 入力値

    なし

  • 返却値

    (String) 処理期限日(検索範囲終了日)

  • 詳細

    セットされた、処理期限日(検索範囲終了日)を返却します。


WkfSearchCondition オブジェクト

概要

プログラムサポート/検索条件設定

構造図
コンストラクタ
メソッド
setCondition() | 検索条件を設定します
getGoFilter() | 未処理タスク表示を返却します
getAgtGoFilter() | 未処理タスク表示(委譲)を返却します
getCltAgtGoFilter() | 未処理タスク表示(代理元処理可委譲)を返却します
getPullbackFilter() | 引戻しタスク表示を返却します
getAgtPullbackFilter() | 引戻しタスク表示(委譲)を返却します
getCltAgtPullbackFilter() | 引戻しタスク表示(代理元処理可委譲)を返却します
getSendbackFilter() | 差し戻しタスク表示を返却します
getAgtSendbackFilter() | 差し戻しタスク表示(委譲)を返却します
getCltAgtSendbackFilter() | 差し戻しタスク表示(代理元処理可委譲)を返却します
getCompFilter() | 完了タスク表示を返却します
getAgtCompFilter() | 完了タスク表示(委譲)を返却します
getCltAgtCompFilter() | 完了タスク表示(代理元処理可委譲)を返却します
getCategoryCd() | カテゴリコードを返却します
getCategoryName() | カテゴリ名を返却します
getProcessDefCd() | プロセス定義コードを返却します
getProcessDefName() | プロセス定義名を返却します
getVersionCd() | バージョンコードを返却します
getProcessCd() | プロセスコードを返却します
getProcessName() | プロセス名を返却します
getActivityCd() | アクティビティコードを返却します
getActivityName() | アクティビティ名を返却します
getDraftUserCd() | 起票者ユーザコードを返却します
getDraftUserName() | 起票者ユーザ名を返却します
getDraftCompCd() | 起票者の会社コードを返却します
getDraftOrgnCd() | 起票者の会社組織コードを返却します
getDraftAppointDate() | 起票指定日を返却します
getDraftDateStart() | 起票日(検索範囲開始日)を返却します
getDraftDateEnd() | 起票日(検索範囲終了日)を返却します
getBeforeUserCd() | 前処理者ユーザコードを返却します
getBeforeUserName() | 前処理者ユーザ名を返却します
getApprovalUserCd() | 処理者ユーザコードを返却します
getApprovalUserName() | 処理者ユーザ名を返却します
getApprovalCompCd() | 処理者の会社コードを返却します
getApprovalOrgnCd() | 処理者の会社組織コードを返却します
getApprovalOrgnName() | 処理者の会社組織名を返却します
getApprovalDateStart() | 処理日(検索範囲開始日)を返却します
getApprovalDateEnd() | 処理日(検索範囲終了日)を返却します
getAgentUserCd() | 代理依頼元ユーザコードを返却します
getAgentUserName() | 代理依頼元ユーザ名を返却します
getArriveDateStart() | 到達日(検索範囲開始日)を返却します
getArriveDateEnd() | 到達日(検索範囲終了日)を返却します
getLimitDateStart() | 処理期限日(検索範囲開始日)を返却します
getLimitDateEnd() | 処理期限日(検索範囲終了日)を返却します


WkfSort オブジェクト ＡＰＩ

WkfSort()

  • プロトタイプ

    (Object) WkfSort()

  • 入力値

    なし

  • 返却値

    なし

  • 詳細

    ソート指定オブジェクトを作成します。

setAscending()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setAscending((String)sort_key)

  • 概要

    昇順ソートキーセット

  • 入力値

    (String) sort_key: 昇順ソートキー(必須)

  • 返却値

    なし

  • 詳細

    ソート対象は各検索メソッドの戻り値がソート対象となります。
    ソートキーは複数指定可能で、指定した配列の先頭から順に、第１ソートキー・第2ソートキー・・・となります。
    例えば、category_cdを昇順ソートキーとする場合、setAscending(”category_cd”)と記述してください。

setDescending()

  • プロトタイプ

    void 型インスタンスメソッド
    (void)setDescending((String)sort_key)

  • 概要

    降順ソートキーセット

  • 入力値

    (String) sort_key: 降順ソートキー(必須)

  • 返却値

    なし

  • 詳細

    ソート対象は各検索メソッドの戻り値がソート対象となります。
    ソートキーは複数指定可能で、指定した配列の先頭から順に、第１ソートキー・第2ソートキー・・・となります。
    例えば、category_cdを降順ソートキーとする場合、setAscending(”category_cd”)と記述してください。

getAscending()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getAscending()

  • 概要

    昇順ソートキーを返却します

  • 入力値

    なし

  • 返却値

    (String) 昇順ソートキー

  • 詳細

    セットされた、昇順ソートキーを返却します。

getDescending()

  • プロトタイプ

    String 型インスタンスメソッド
    (String)getDescending()

  • 概要

    降順ソートキーを返却します

  • 入力値

    なし

  • 返却値

    (String) 降順ソートキー

  • 詳細

    セットされた、降順ソートキーを返却します。


WkfSort オブジェクト

概要

プログラムサポート/ソート指定

構造図
コンストラクタ
メソッド
setAscending() | 昇順ソートキーセット
setDescending() | 降順ソートキーセット
getAscending() | 昇順ソートキーを返却します
getDescending() | 降順ソートキーを返却します


WkfUtil オブジェクト ＡＰＩ

WkfUtil()

  • プロトタイプ

    (Object) WkfUtil((String)connectID)

  • 入力値

    (String) connectID: DB接続参照名(必須)

  • 返却値

    なし

  • 詳細

    ユーティリティオブジェクトを作成します。

autoPass()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)autoPass((String)category_cd, (String)process_def_cd, (String)version_cd, (Int)date)

  • 概要

    案件の自動パス（バッチ起動）を実行します。

  • 入力値

    (String) category_cd: カテゴリコード（任意。未指定時：全カテゴリ）
    (String) process_def_cd: プロセス定義コード（任意。未指定時：全プロセス）
    (String) version_cd: バージョンコード (任意。未指定時：全バージョン)
    (Int) date: 承認期限の延長日数(任意。未指定のときは０を入力する。)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    案件の自動パス（バッチ起動）を実行します。
    自動パス承認期限を過ぎた案件を自動承認します。

autoPress()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)autoPress((String)category_cd, (String)process_def_cd, (String)version_cd, (Int)date)

  • 概要

    案件の自動催促（バッチ起動）を実行します。

  • 入力値

    (String) category_cd: カテゴリコード（任意。未指定時：全カテゴリ）
    (String) process_def_cd: プロセス定義コード（任意。未指定時：全プロセス）
    (String) version_cd: バージョンコード (任意。未指定時：全バージョン)
    (Int) date: 承認期限の延長日数(任意。未指定のときは０を入力する。)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    案件の自動催促（バッチ起動）を実行します。
    自動催促メールを送ります。

sendMail()

  • プロトタイプ

    Object 型インスタンスメソッド
    (Object)sendMail((String)template_path, (String)process_def_cd, (String)version_cd, (String)process_cd, (String)activity_cd, (Array)to, (Array)cc, (Array)bcc)

  • 概要

    メール送信を行います。

  • 入力値

    (String) template_path: テンプレートパス（必須）
    (String) process_def_cd: プロセス定義コード（必須）
    (String) version_cd: バージョンコード (必須)
    (String) activity_cd: 現在位置アクティビティコード(必須)
    (Array) to: Toメールアドレス配列(必須)
    (Array) cc: Ccメールアドレス配列(任意)
    (Array) bcc: Bccメールアドレス配列(任意)

  • 返却値

    Object  //エラーコードオブジェクト
Object
├isSuccess  処理結果(true:成功/false:失敗)
├getId      エクセプションID
└getMessage エラーメッセージ

  • 詳細

    to,cc,bccに指定されたアドレスのユーザにメールを送信します。


WkfUtil オブジェクト

概要

ユーティリティ

構造図
コンストラクタ
メソッド
autoPass() | 案件の自動パス（バッチ起動）を実行します
autoPress() | 案件の自動催促（バッチ起動）を実行します
sendMail() | メール送信を行います


 WkfApprover オブジェクト

承認関連のAPI。
承認関連の処理に使用されるクラスです。

<サンプル>
コンストラクタの概要
WkfApprover(String user_cd ,String login_group_id)
コンストラクタ(本人用)。
WkfApprover(String agent_user_cd ,String user_cd ,String login_group_id)
コンストラクタ(代理人用)。
メソッドの概要
Object | approve(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Boolean isFinish ,String comp_cd ,String orgn_cd ,String comment ,Object nego ,Object executant ,String route_select_cd) 承認処理を実行します。
Object | denial(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String comp_cd ,String orgn_cd ,String comment ,Object nego) 否認処理を実行します。
Array | getActivityTaskList(Object conditionKey ,Array sortKey ,Number start ,Number amount) 処理可能案件(未処理案件)一覧を取得します。
Array | getEndTaskList(Object conditionKey ,Array sortKey ,Number start ,Number amount) 処理済案件一覧を取得します。
Array | getTargetDepartment(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd) 所属組織を取得します。
void | noTransaction() データベーストランザクションを未使用にする。
Object | pullBack(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd) 引戻し処理を実行します。
Object | sendBack(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String type ,String comp_cd ,String orgn_cd ,String comment ,Object nego) 差し戻し処理を実行します。
Object | suspend(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String comp_cd ,String orgn_cd ,String comment ,Object nego) 保留処理を実行します。
コンストラクタの詳細
WkfApprover

WkfApprover(String user_cd ,String login_group_id)
コンストラクタ(本人用)。
パラメータ
user_cd | String | 承認者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
WkfApprover

WkfApprover(String agent_user_cd ,String user_cd ,String login_group_id)
コンストラクタ(代理人用)。 代理依頼されたもの全てを表示する際は、user_cdに「"AGT_ALL"もしくは"1"」を指定してください。
ただし、"AGT_ALL"を指定すると承認などの一覧検索以外のメソッドは使えません。
パラメータ
agent_user_cd | String | 代理承認者のユーザID(必須)
user_cd | String | 本来の処理者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
approve

Object approve(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Boolean isFinish ,String comp_cd ,String orgn_cd ,String comment ,Object nego ,Object executant ,String route_select_cd)

承認処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
isFinish | Boolean | 途中終了フラグ(任意：未指定=途中終了しない)
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego Object 根回しメールオブジェクト(任意)
 Object //根回しメールオブジェクト
 ├title       根回しメールタイトル(必須)
 ├comment     根回しメールコメント(任意)
 └userList[]  根回しメール送信者リスト(必須)
    └cd       送信先ユーザコード
executant Object 次承認者オブジェクト(次承認者が実行時選択時)
 Object //次承認者オブジェクト
 ├type    承認者タイプ(必須。ユーザ：user,/組織：orgn)
 ├comp_cd 会社コード(typeで組織選択時に指定します。)
 └cd      承認ユーザ/組織コード(必須)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
denial

Object denial(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String comp_cd ,String orgn_cd ,String comment ,Object nego)

否認処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego Object 根回しメールオブジェクト(任意)
 Object //根回しメールオブジェクト
 ├title       根回しメールタイトル(必須)
 ├comment     根回しメールコメント(任意)
 └userList[]  根回しメール送信者リスト(必須)
    └cd       送信先ユーザコード
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
getActivityTaskList

Array getActivityTaskList(Object conditionKey ,Array sortKey ,Number start ,Number amount)

処理可能案件(未処理案件)一覧を取得します。
処理可能案件オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
検索条件オブジェクトについては、WkfSearchConditionを参照してください。
ソート指定オブジェクトについては、WkfSortを参照してください。
パラメータ
conditionKey | Object | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sortKey | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array 処理可能案件情報オブジェクト配列
 Object //処理可能案件情報オブジェクト
 ├category_cd(String)           カテゴリコード
 ├category_name(String)         カテゴリ名
 ├parent_process_def_cd(String) 親プロセス定義コード
 ├parent_version_cd(String)     親プロセスバージョンコード
 ├parent_process_cd(String)     親プロセスコード
 ├process_def_cd(String)        プロセス定義コード
 ├process_def_name(String)      プロセス定義名
 ├version_cd(String)            バージョンコード
 ├version_name(String)          バージョン名
 ├process_cls_cd(String)        プロセス種別コード
 ├process_cd(String)            プロセスコード
 ├process_name(String)          プロセス名
 ├process_status(String)        プロセスステータス
 ├activity_cd(String)           アクティビティコード
 ├activity_name(String)         アクティビティ名
 ├activity_status(String)       アクティビティステータス
 ├attainment_class(String)      到達種別
 ├draft_appoint_date(String)    起票指定日
 ├draft_date(String)            起票日
 ├draft_user_cd(String)         起票者コード
 ├draft_user_name(String)       起票者名
 ├reception_date(String)        受信日付
 ├process_term_date(String)     処理期限日付
 ├transfer_flg(Boolean)         代理起票フラグ
 ├client_auth_flg(Boolean)      代理元承認可否フラグ
 ├agent_target(String)          代理依頼先対象(本人用でインスタンス作成時)
 ├agent_cd(String)              代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
 ├agent_name(String)            代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
 ├client_user_cd(String)        代理依頼元ユーザコード(代理人用でインスタンス作成時)
 ├client_user_name(String)      代理依頼元ユーザ名(代理人用でインスタンス作成時)
 ├next_activity_type(String)    次タスクのタスク種別
 └compulsion_end_flg(Boolean)   強制終了可否フラグ

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getEndTaskList

Array getEndTaskList(Object conditionKey ,Array sortKey ,Number start ,Number amount)

処理済案件一覧を取得します。
処理済案件オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
検索条件オブジェクトについては、WkfSearchConditionを参照してください。
ソート指定オブジェクトについては、WkfSortを参照してください。
パラメータ
conditionKey | Object | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sortKey | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array 処理済案件オブジェクト配列
 Object //処理済案件オブジェクト
 ├category_cd(String)              カテゴリコード
 ├category_name(String)            カテゴリ名
 ├parent_process_def_cd(String)    親プロセス定義コード
 ├parent_version_cd(String)        親プロセスバージョンコード
 ├parent_process_cd(String)        親プロセスコード
 ├process_def_cd(String)           プロセス定義コード
 ├process_def_name(String)         プロセス定義名
 ├version_cd(String)               バージョンコード
 ├version_name(String)             バージョン名
 ├process_cls_cd(String)           プロセス種別コード
 ├process_cd(String)               プロセスコード
 ├process_name(String)             プロセス名
 ├process_status(String)           プロセスステータス
 ├activity_cd(String)              処理時のアクティビティコード
 ├activity_name(String)            処理時のアクティビティ名
 ├draft_appoint_date(String)       起票指定日
 ├draft_date(String)               起票日
 ├draft_user_cd(String)            起票者コード
 ├draft_user_name(String)          起票者名
 ├draft_user_comp_cd(String)       起票者の処理時の会社コード
 ├draft_user_orgn_cd(String)       起票者の処理時の組織コード
 ├draft_user_main_flg(String)      主・副所属フラグ
 ├isJunction(Boolean)              ルートが同期していればtrue
 ├approval_type(String)            処理結果
 ├approval_user_cd(String)         処理ユーザコード
 ├approval_user_name(String)       処理ユーザ名
 ├approval_date(String)            処理日
 ├approval_transfer_flg(Boolean)   承認結果履歴代理フラグ
 ├processing_status(String)        現在の状態
 ├approval_agent_user_cd(String)   承認代理元ユーザコード(代理人用でインスタンス作成時)
 ├approval_agent_user_name(String) 承認代理元ユーザ名(代理人用でインスタンス作成時)
 ├transfer_flg(Boolean)            代理依頼フラグ
 ├client_auth_flg(Boolean)         代理元承認可否フラグ
 ├agent_target(String)             代理依頼先対象(本人用でインスタンス作成時)
 ├agent_cd(String)                 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
 ├agent_name(String)               代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
 └pull_activity_flg(Boolean)       引き戻し可否フラグ(true:可/false:不可)

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getTargetDepartment

Array getTargetDepartment(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd)

所属組織を取得します。
処理時の所属組織として選択できる組織を取得します。
審議時など、既にプロセスコードがふられているに使用します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
返却値
Array 所属組織情報オブジェクト配列
 Object //所属組織情報オブジェクト
   ├company_cd(String)         会社コード
   ├department_cd(String)      組織コード
   └department_name(String)    組織名

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
noTransaction

void noTransaction()

データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。
返却値
void
pullBack

Object pullBack(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd)

引戻し処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
sendBack

Object sendBack(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String type ,String comp_cd ,String orgn_cd ,String comment ,Object nego)

差し戻し処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
type | String | 差戻し先(必須：start=申請者,before=前処理者)
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego Object 根回しメールオブジェクト(任意)
 Object //根回しメールオブジェクト
 ├title       根回しメールタイトル(必須)
 ├comment     根回しメールコメント(任意)
 └userList[]  根回しメール送信者リスト(必須)
    └cd       送信先ユーザコード
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
suspend

Object suspend(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String comp_cd ,String orgn_cd ,String comment ,Object nego)

保留処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード
version_cd | String | バージョンコード
process_cd | String | プロセスコード
activity_cd | String | アクティビティコード
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego Object 根回しメールオブジェクト(任意)
 Object //根回しメールオブジェクト
 ├title       根回しメールタイトル(必須)
 ├comment     根回しメールコメント(任意)
 └userList[]  根回しメール送信者リスト(必須)
    └cd       送信先ユーザコード
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ


 WkfDrafter オブジェクト

起票関連のAPI。
起票関連の処理に使用されるクラスです。

<サンプル>
コンストラクタの概要
WkfDrafter(String user_cd ,String login_group_id)
コンストラクタ１(本人用)。
WkfDrafter(String agent_user_cd ,String user_cd ,String login_group_id)
コンストラクタ２(代理人用)。
メソッドの概要
Object | cancel(String process_def_cd ,String version_cd ,String process_cd ,String comp_cd ,String orgn_cd ,String comment ,Object nego) 取り止め処理を実行します。
Object | draft(String process_def_cd ,String version_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,Object nego ,Object executant ,String route_select_cd ,String locale) 起票処理を実行します。
Array | getActivityProcessDefList(Object conditionKey ,Array sortKey ,Number start ,Number amount ,String locale) 起票可能プロセス一覧を取得します。
Array | getEndProcessList(WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount) 起票済み案件を取得します。
Array | getTargetDepartment(String process_def_cd ,String version_cd ,String activity_cd ,String target_date) 所属組織を取得します。
void | noTransaction() データベーストランザクションを未使用にする。
Object | pullBack(String process_def_cd ,String version_cd ,String process_cd) 引戻し処理を実行します。
Object | retry(String process_def_cd ,String version_cd ,String process_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,Object nego ,Object executant ,String route_select_cd ,String locale) 再起票処理を実行します。
void | subProcessDraft(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String comp_cd ,String orgn_cd ,String comment ,Object nego ,Object executant ,String route_select_cd) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
コンストラクタの詳細
WkfDrafter

WkfDrafter(String user_cd ,String login_group_id)
コンストラクタ１(本人用)。
パラメータ
user_cd | String | 起票者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
WkfDrafter

WkfDrafter(String agent_user_cd ,String user_cd ,String login_group_id)
コンストラクタ２(代理人用)。
代理依頼されたもの全てを表示する際は、user_cdに「"AGT_ALL"もしくは"1")」を指定してください。
ただし、"AGT_ALL"を指定すると承認などの一覧検索以外のメソッドは使えません。
パラメータ
agent_user_cd | String | 代理起票者のユーザID(必須)
user_cd | String | 本来の起票者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
cancel

Object cancel(String process_def_cd ,String version_cd ,String process_cd ,String comp_cd ,String orgn_cd ,String comment ,Object nego)

取り止め処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 取り止めコメント(任意)
nego Object 根回しメールオブジェクト(任意)
 Object //根回しメールオブジェクト
 ├title       根回しメールタイトル(必須)
 ├comment     根回しメールコメント(任意)
 └userList[]  根回しメール送信者リスト(必須)
    └cd       送信先ユーザコード
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
draft

Object draft(String process_def_cd ,String version_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,Object nego ,Object executant ,String route_select_cd ,String locale)

起票処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素０から指定してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_temporary_cd | String | 一時プロセスID(任意：添付ファイル利用時)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーション配列(任意：０〜８要素まで)
draft_appoint_date | String | 起票指定日(任意：未指定時は起票日と同日)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 起票コメント(任意)
nego Object 根回しメールオブジェクト(任意)
 Object //根回しメールオブジェクト
 ├title       根回しメールタイトル(必須)
 ├comment     根回しメールコメント(任意)
 └userList[]  根回しメール送信者リスト(必須)
    └cd       送信先ユーザコード
executant Object 次承認者オブジェクト(次承認者が実行時選択時)
 Object //次承認者オブジェクト
 ├type    承認者タイプ(必須。ユーザ：user,/組織：orgn)
 ├comp_cd 会社コード(typeで組織選択時に指定します。)
 └cd      承認ユーザ/組織コード(必須)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
locale | String | ロケール(任意：なければデフォルトロケールを使用)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)    処理結果(true:成功/false:失敗)
 ├getId(String)        エクセプションID
 ├getMessage(String)   エラーメッセージ
 └processInfo(Object)  起票プロセスの情報(処理成功時のみ)
    ├process_def_cd(String)            プロセス定義コード
    ├version_cd(String)                バージョンコード
    ├process_cd(String)                プロセスコード
    ├process_name(String)              プロセス名
    ├draft_date(String)                起票日
    ├draft_user_cd(String)             起票者コード
    ├draft_user_name(String)           起票者名
    ├draft_comment(String)             起票コメント
    ├company_cd(String)                起票者の起票会社コード
    ├code_value(String)                起票者の起票組織コード
    ├group_name(String)                起票者の起票組織名
    ├draft_appoint_date(String)        起票指定日
    ├transactor_cd(String)             処理者コード
    ├transactor_name(String)           処理者名
    ├locale_id(String)                 処理者ロケールID
    ├process_status(String)            プロセスステータス
    ├last_man_activity_cd(String)      最終手動アクティビティコード
    ├last_man_activity_result(String)  最終手動アクティビティ承認結果種別
    ├parent_process_def_cd(String)     親プロセス定義コード
    ├parent_version_cd(String)         親バージョンコード
    ├parent_process_cd(String)         親プロセスコード
    ├parent_activity_cd(String)        親アクティビティコード
    ├processing_status(String)         処理状態識別
    ├process_nest_cnt(String)          サブプロセス呼出カウンタ
    ├parallel_nest_cnt(String)         同期処理階層カウンタ
    ├present_display_info(String)      現処理表示情報
    ├extension_a(String)               拡張エリアＡ
    ├extension_b(String)               拡張エリアＢ
    ├extension_c(String)               拡張エリアＣ
    ├extension_d(String)               拡張エリアＤ
    ├extension_e(String)               拡張エリアＥ
    ├extension_f(String)               拡張エリアＦ
    ├extension_g(String)               拡張エリアＧ
    ├extension_h(String)               拡張エリアＨ
    ├create_date(String)               作成日時
    ├create_user_cd(String)            作成者コード
    ├create_user_name(String)          作成者名
    ├record_date(String)               最終更新日時
    ├record_user_cd(String)            最終更新者コード
    └record_user_name(String)          最終更新者名
getActivityProcessDefList

Array getActivityProcessDefList(Object conditionKey ,Array sortKey ,Number start ,Number amount ,String locale)

起票可能プロセス一覧を取得します。
起票可能プロセスオブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
検索条件オブジェクトについては、WkfSearchConditionを参照してください。
ソート指定オブジェクトについては、WkfSortを参照してください。
パラメータ
conditionKey | Object | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sortKey | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
locale | String | ロケール
返却値
Array 起票可能プロセスオブジェクト配列
 Object //起票可能プロセスオブジェクト
   ├category_cd(String)      カテゴリコード
   ├category_name(String)    カテゴリ名
   ├process_def_cd(String)   プロセス定義コード
   ├process_def_name(String) プロセス定義名
   ├version_cd(String)       起票可能な最新バージョンコード
   ├version_name(String)     起票可能な最新バージョン名
   ├version_note(String)     起票可能な最新バージョンの備考
   ├effective_date(String)   有効日付
   ├end_date(String)         終了日付
   ├process_cls_cd(String)   プロセス種別コード
   ├activity_cd(String)      開始アクティビティコード
   ├transfer_flg(Boolean)    代理起票フラグ
   ├client_auth_flg(Boolean) 代理元承認可否フラグ
   ├agent_target(String)     代理依頼先対象(本人用でインスタンス作成時)
   ├agent_comp_cd(String)    代理依頼先会社コード(本人用でインスタンス作成時)
   ├agent_cd(String)         代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
   ├agent_name(String)       代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
   ├client_user_cd(String)   代理依頼元ユーザコード(代理人用でインスタンス作成時)
   └client_user_name(String) 代理依頼元ユーザ名(代理人用でインスタンス作成時)

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getEndProcessList

Array getEndProcessList(WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount)

起票済み案件を取得します。
起票済み案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
検索条件オブジェクトについては、WkfSearchConditionを参照してください。
ソート指定オブジェクトについては、WkfSortを参照してください。
パラメータ
conditionKey | WkfSearchCondition | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sortKey | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array 起票済み案件情報オブジェクト配列
 Object //起票済み案件情報オブジェクト
   ├category_cd(String)           カテゴリコード
   ├category_name(String)         カテゴリ名
   ├parent_process_def_cd(String) 親プロセス定義コード
   ├parent_version_cd(String)     親プロセスバージョンコード
   ├parent_process_cd(String)     親プロセスコード
   ├process_def_cd(String)        プロセス定義コード
   ├process_def_name(String)      プロセス定義名
   ├version_cd(String)            バージョンコード
   ├version_name(String)          バージョン名
   ├process_cls_cd(String)        プロセス種別コード
   ├process_cd(String)            プロセスコード
   ├process_name(String)          プロセス名
   ├process_status(String)        プロセスステータス
   ├activity_cd(String)           アクティビティコード(isJunction=trueのときはnull)
   ├activity_name(String)         アクティビティ名(isJunction=trueのときはnull)
   ├activity_status(String)       アクティビティステータス(isJunction=trueのときはnull)
   ├attainment_class(String)      到達種別(isJunction=trueのときはnull)
   ├draft_appoint_date(String)    起票指定日
   ├draft_date(String)            起票日
   ├draft_user_cd(String)         起票者コード
   ├draft_user_name(String)       起票者名
   ├draft_user_comp_cd(String)    起票者の処理時の会社コード
   ├draft_user_orgn_cd(String)    起票者の処理時の組織コード
   ├draft_user_main_flg(String)   主・副所属フラグ
   ├isJunction(Boolean)           ルートが同期していればtrue
   ├now_approval_name(String)     現処理ユーザ/組織/オフィシャルG/ロール名(isJunction=trueのときはnull)
   ├reception_date(String)        受信日付
   ├process_term_date(String)     処理期限日付
   ├transfer_flg(Boolean)         代理起票フラグ
   ├client_auth_flg(Boolean)      代理元承認可否フラグ
   ├agent_target(String)          代理依頼先対象(本人用でインスタンス作成時)
   ├agent_cd(String)              代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
   ├agent_name(String)            代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
   ├client_user_cd(String)        代理依頼元ユーザコード(代理人用でインスタンス作成時)
   ├client_user_name(String)      代理依頼元ユーザ名(代理人用でインスタンス作成時)
   └pull_activity_flg(Boolean)    引き戻し可否フラグ(true:可/false:不可)

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getTargetDepartment

Array getTargetDepartment(String process_def_cd ,String version_cd ,String activity_cd ,String target_date)

所属組織を取得します。
処理時の所属組織として選択できる組織を取得します。
起票時など、プロセスコードがふられていない時に使用します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
activity_cd | String | アクティビティコード(必須)
target_date | String | 起票指定日(任意：指定なしの場合はシステム日付)
返却値
Array 所属組織情報オブジェクト配列
 Object //所属組織情報オブジェクト
   ├company_cd(String)         会社コード
   ├department_cd(String)      組織コード
   └department_name(String)    組織名

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
noTransaction

void noTransaction()

データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。
返却値
void
pullBack

Object pullBack(String process_def_cd ,String version_cd ,String process_cd)

引戻し処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
retry

Object retry(String process_def_cd ,String version_cd ,String process_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,Object nego ,Object executant ,String route_select_cd ,String locale)

再起票処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
アプリケーションキー配列は、必ず要素０から指定してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーションキー配列(任意：０〜８要素まで)
draft_appoint_date | String | 起票指定日(任意：起票日と同日)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 再起票コメント(任意)
nego Object 根回しメールオブジェクト(任意)
 Object //根回しメールオブジェクト
 ├title       根回しメールタイトル(必須)
 ├comment     根回しメールコメント(任意)
 └userList[]  根回しメール送信者リスト(必須)
    └cd       送信先ユーザコード
executant Object 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
 Object //次承認者オブジェクト
 ├type    承認者タイプ(必須。ユーザ：user,/組織：orgn)
 ├comp_cd 会社コード(typeで組織選択時に指定します。)
 └cd      承認ユーザ/組織コード(必須)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
locale | String | ロケール(任意：なければデフォルトロケールを使用)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
subProcessDraft

void subProcessDraft(String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String comp_cd ,String orgn_cd ,String comment ,Object nego ,Object executant ,String route_select_cd)

サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素０から指定してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
process_temporary_cd | String | 一時プロセスID(任意)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーション配列(任意：０〜８要素まで)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 起票コメント(任意)
nego Object 根回しメールオブジェクト(任意)
 Object //根回しメールオブジェクト
 ├title       根回しメールタイトル(必須)
 ├comment     根回しメールコメント(任意)
 └userList[]  根回しメール送信者リスト(必須)
    └cd       送信先ユーザコード
executant Object 次承認者オブジェクト(次承認者が実行時選択時)
 Object //次承認者オブジェクト
 ├type    承認者タイプ(必須。ユーザ：user,/組織：orgn)
 ├comp_cd 会社コード(typeで組織選択時に指定します。)
 └cd      承認ユーザ/組織コード(必須)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
返却値
void


 WkfFlowInfo オブジェクト

フロー情報オブジェクトAPI。
特定のタスクの位置情報を保持した、フロー情報を取得する。
このAPIは、フロー情報オブジェクトを使用する為のAPIです。

<サンプル>
コンストラクタの概要
WkfFlowInfo(Object info)
コンストラクタ。
メソッドの概要
String | getActivityCd() アクティビティコードを取得します。
String | getActivityType() アクティビティ種別を取得します。
Boolean | getEndFlg() 終了フラグを取得します。
Object | getFirst() 最初のタスクのフロー情報を取得します。
Boolean | getIsSubProcess() サブプロセスフラグを取得します。
Object | getLast() 最後のタスクのフロー情報を取得します。
Array | getNext() 次のタスクのフロー情報を取得します。
Array | getPrev() 前のタスクのフロー情報を取得します。
String | getProcessDefCd() プロセス定義コードを取得します。
String | getVersionCd() バージョンコードを取得します。
Boolean | hasNext() 次のタスクが存在するかどうかを返却します。
Boolean | hasPrev() 前のタスクが存在するかどうかを返却します。
コンストラクタの詳細
WkfFlowInfo

WkfFlowInfo(Object info)
コンストラクタ。
パラメータ(info)には、WkfManager#getFlowInfoなどを使用し取得した
フロー情報オブジェクトを指定してください。
パラメータ
info Object フロー情報オブジェクト
メソッドの詳細
getActivityCd

String getActivityCd()

アクティビティコードを取得します。
返却値
String アクティビティコード
getActivityType

String getActivityType()

アクティビティ種別を取得します。
返却値
String アクティビティ種別
getEndFlg

Boolean getEndFlg()

終了フラグを取得します。
現在のタスクが分岐・同期の終了タスクの場合にtrueを取得します。
返却値
Boolean 「終了」の場合:true / 「始点」の場合:false
getFirst

Object getFirst()

最初のタスクのフロー情報を取得します。
ルート上の最初のタスクの情報を取得します。
返却値
Object フロー情報オブジェクト
getIsSubProcess

Boolean getIsSubProcess()

サブプロセスフラグを取得します。
現在のタスクがサブプロセスの場合にtrueを取得します。
返却値
Boolean サブプロセス:true/通常タスク:false
getLast

Object getLast()

最後のタスクのフロー情報を取得します。
ルート上の最後のタスク情報を取得します。
返却値
Object フロー情報オブジェクト
getNext

Array getNext()

次のタスクのフロー情報を取得します。
（同期でルートが複数存在する場合、同期結合まで各ルートが同時に次タスクに状態遷移する）
返却値
Array フロー情報オブジェクト配列
getPrev

Array getPrev()

前のタスクのフロー情報を取得します。
（同期でルートが複数存在する場合、同期結合まで各ルートが同時に前タスクに状態遷移する）
返却値
Array フロー情報オブジェクト配列
getProcessDefCd

String getProcessDefCd()

プロセス定義コードを取得します。
返却値
String プロセス定義コード
getVersionCd

String getVersionCd()

バージョンコードを取得します。
返却値
String バージョンコード
hasNext

Boolean hasNext()

次のタスクが存在するかどうかを返却します。
返却値
Boolean 存在する:true/存在しない:false
hasPrev

Boolean hasPrev()

前のタスクが存在するかどうかを返却します。
返却値
Boolean 存在する:true/存在しない:false


 WkfMailSettingBehavior オブジェクト

プログラムサポート/メール送信　リザーブフラグ設定クラス。
テンプレートメールの予約や停止などを行う場合に使用します。
コンストラクタの概要
WkfMailSettingBehavior()
コンストラクタ
メソッドの概要
String | getResult() エラーコードを返却します。
String | reserveCancel() メール予約機能の使用を取消します。
String | reserveRequest() メール予約機能の使用を依頼します。
String | send() メールの送信を実行します。
void | setTamplateRequest(String templatePath) メールテンプレートの設定を行います。
String | stopCancel() テンプレートメールの送信停止を取り止めます。
String | stopRequest() 同一スレッド内のテンプレートメールの標準送信を停止させます。
コンストラクタの詳細
WkfMailSettingBehavior

WkfMailSettingBehavior()
コンストラクタ
メソッドの詳細
getResult

String getResult()

エラーコードを返却します。
エラーコードは、BPWErrorCodeIFで定義された定義値です。
エラーでない場合は、””(空文字)が返却されます。
返却値
String エラーコード
reserveCancel

String reserveCancel()

メール予約機能の使用を取消します。
reserveRequest()を使用してメール予約の設定をしてある場合、そのメール予約を取り消します。
返却値
String エラーコード
reserveRequest

String reserveRequest()

メール予約機能の使用を依頼します。
処理が正常終了した場合にのみテンプレートメールが送信されるように、メール予約を行います。
返却値
String エラーコード
send

String send()

メールの送信を実行します。
送信予約されているメールがある場合に、そのメールの送信を行います。
返却値
String エラーコード
setTamplateRequest

void setTamplateRequest(String templatePath)

メールテンプレートの設定を行います。
テンプレートメールの送信時に送信されるメールのテンプレートを変更したいときに使用します。
StorageService からのメールテンプレート相対パスを指定してください。
パラメータ
templatePath String テンプレートパス(必須)
返却値
void
stopCancel

String stopCancel()

テンプレートメールの送信停止を取り止めます。
stopRequest()を使用してテンプレートメールの送信停止の設定をしてある場合、
その送信停止の設定を取り止め、解除します。
返却値
String エラーコード
stopRequest

String stopRequest()

同一スレッド内のテンプレートメールの標準送信を停止させます。
テンプレートメールの標準送信機能を停止させたい場合に使用します。
返却値
String エラーコード


 WkfManager オブジェクト

マスタ関連のAPI。
マスタメンテナンス関連処理で使用されるクラスです。
ワークフロー管理者用のロールを持つユーザのみ使用できるクラスです。

<サンプル>
コンストラクタの概要
WkfManager(String user_cd ,String login_group_id)
コンストラクタ。
メソッドの概要
String | exportProcessDef(Array process_def_cd) プロセス定義(Excel形式)エクスポートを実行します。
Object | getActivityInfo(String process_def_cd ,String version_cd ,String activity_cd) プロセス定義コード、バージョンコード、アクティビティコードをキーとして タスク(アクティビティ)情報を取得します。
Object | getCategoryInfo(String category_cd) カテゴリコードをキーとしてカテゴリ情報オブジェクトを取得します。
Array | getCategoryInfoByName(String category_name) カテゴリ名をキーとしてカテゴリ情報オブジェクトを取得します。
Object | getFlowInfo(String process_def_cd ,String version_cd ,String activity_cd) 特定のタスクの位置情報を保持した、フローの情報を取得します。
Object | getProcessDefInfo(String process_def_cd) プロセス定義コードをキーとしてプロセス定義情報オブジェクトを取得します。
Array | getProcessDefInfoByName(String process_def_name) プロセス定義名をキーとしてプロセス定義情報オブジェクトを取得します。
Object | getProcessDefInfoByVersion(String process_def_cd ,String version_cd) プロセス定義コード、バージョンコードをキーとしてプロセス定義情報オブジェクトを取得します。
Array | getProcessList(Object condition_key ,Array sort_key ,Number start ,Number amount) プロセス一覧情報を取得します。
Object | getVersionInfo(String process_def_cd ,String version_cd) プロセス定義コードとバージョンコードをキーとしてバージョン(ルート)情報を取得します。
Object | importProcessDef(String xls_file) プロセス定義(Excel形式)インポートを実行します。
void | noTransaction() データベーストランザクションを未使用にする。
Object | removeProcess(String process_def_cd ,String version_cd ,String process_cd ,Boolean xml_out_flg) 案件の削除処理を実行します。
コンストラクタの詳細
WkfManager

WkfManager(String user_cd ,String login_group_id)
コンストラクタ。
カテゴリの編集権限ロールをもつユーザを指定してください。
パラメータ
user_cd | String | ユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
exportProcessDef

String exportProcessDef(Array process_def_cd)

プロセス定義(Excel形式)エクスポートを実行します。
指定されたプロセス定義コードのプロセス定義をエクスポートします。
返却値はエクセルファイルデータのバイト配列を文字列に変換したものが返却されます。
パラメータ
process_def_cd Array エクスポートプロセス定義コード配列(必須:Stringの配列)
返却値
String エクセルファイルデータ(バイト文字列)
getActivityInfo

Object getActivityInfo(String process_def_cd ,String version_cd ,String activity_cd)

プロセス定義コード、バージョンコード、アクティビティコードをキーとして
タスク(アクティビティ)情報を取得します。
タスク(アクティビティ)情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須：０マスクしないで指定)
activity_cd | String | アクティビティコード(必須)
返却値
Object タスク情報オブジェクト
 Object //タスク情報オブジェクト
   ├process_def_cd(String)           プロセス定義コード
   ├version_cd(String)               バージョンコード
   ├activity_cd(String)              アクティビティコード
   ├activiyty_name(String)           アクティビティ名
   ├activity_type_cd(String)         アクティビティ種別

 (アクティビティ種別がRECEIVEの場合)
   ├compulsion_end_flag(Boolean)     終了可能フラグ
   ├return_flag(Boolean)             差し戻し/引き戻しフラグ
   ├return_mail_flag(Boolean)        差し戻しメールフラグ
   ├post_processing_flg(Boolean)    後処理使用フラグ
   ├post_processing_program(String)  後処理プログラム名
   ├run_user(Array)                  対象者情報(Objectの配列)
        ├run_type(String)                対象者種別
        ├run_cd(String)                  対象者コード
        ├run_group_cd(String)            対象グループコード(対象者種別が組織の場合)
        ├run_role_restrict(String)       ロールによる絞込みのロールID(対象者種別が組織の場合)
        └run_post_restrict(String)       役職による絞込みの役職コード(対象者種別が組織の場合)
   ├refer_user(Array)                参照者情報(Objectの配列)
        ├run_type(String)                対象者種別
        ├run_cd(String)                  対象者コード
        ├run_group_cd(String)            対象グループコード(対象者種別が組織の場合)
        ├run_role_restrict(String)       ロールによる絞込みのロールID(対象者種別が組織の場合)
        └run_post_restrict(String)       役職による絞込みの役職コード(対象者種別が組織の場合)
   ├contents_path(Object)            コンテンツパス
        ├page_kind(String)               ページ種別
        ├contents_path(String)           コンテンツパス
        ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
        ├service_id(String)              サービスID(page_kindがframeworkの場合)
        └tab_cd(String)                  タブコード(page_kindがポータルの場合)
   ├pull_back_contents_path(Object)  引き戻しコンテンツパス
        ├page_kind(String)               ページ種別
        ├contents_path(String)           コンテンツパス
        ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
        ├service_id(String)              サービスID(page_kindがframeworkの場合)
        └tab_cd(String)                  タブコード(page_kindがポータルの場合)
   ├return_contents_path(Object)     差し戻しコンテンツパス
        ├page_kind(String)               ページ種別
        ├contents_path(String)           コンテンツパス
        ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
        ├service_id(String)              サービスID(page_kindがframeworkの場合)
        └tab_cd(String)                  タブコード(page_kindがポータルの場合)
   ├auto_pass(Int)                   期日による自動パス設定の日数
   ├auto_pass_executive(Object)      対象者による自動パス設定情報
        ├executive_flg(Boolean)          自動パスフラグ
        └executive_user(Array)           自動パス対象者情報配列(Objectの配列)
             ├executive_type(String)         対象者種別
             ├executive_cd(String)            対象者コード
             ├executive_group_cd(String)      対象グループコード(対象者種別が組織の場合)
             ├executive_role_restrict(String) ロールによる絞込みのロールID(対象者種別が組織の場合)
             └executive_post_restrict(String) 役職による絞込みの役職コード(対象者種別が組織の場合)
   ├reminder(Obhect)                 催促メール情報
        ├reminder_flg(Boolean)           催促メール使用フラグ
        └reminder_date(String)           催促猶予日数

 (アクティビティ種別がFLOWの場合)
   ├combine_class(String)            条件結合クラス

 (アクティビティ種別がINVOKE_AUTOの場合)
   ├run_class(String)                自動実行クラス

 (アクティビティ種別がINVOKE_EVENTの場合)
   ├event_id(String)                 イベントID

 (アクティビティ種別がINVOKE_PROCESSの場合)
   ├call_process_def_cd(String)      呼出しプロセス定義コード
   ├draft_type_kind(String)          起票タイプ

 (アクティビティ種別がSWITCHの場合)
   ├switch_info(Array)               実行クラス情報(Objectの配列。配列の順番に評価されます。)
        ├condition_no(Int)               実行比較番号(配列の要素番号と同じ)
        ├run_activity_cd(String)         次に実行されるタスクのアクティビティコード
        └run_class(String)               実行クラス

 (アクティビティ種別がMULTIの場合)
   └route_info(Array)                ルート情報(MapObjectの配列。)
        ├select_route_no(String)         ルート選択番号
        ├select_route_name(String)       ルート名
        ├select_route_cd(String)         呼出先のアクティビティコード
        └isCreateRoute(Boolean)          次タスクがルート作成かどうかを取得します。(true:ルート作成/false:その他)

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getCategoryInfo

Object getCategoryInfo(String category_cd)

カテゴリコードをキーとしてカテゴリ情報オブジェクトを取得します。
カテゴリ情報オブジェクトを返却します。
パラメータ
category_cd String カテゴリコード(必須)
返却値
Object カテゴリ情報オブジェクト
 Object //カテゴリ情報オブジェクト
   ├category_cd(String)           カテゴリコード
   ├category_name(String)         カテゴリ名
   ├category_note(String)         備考
   ├edit_athorities(Array)        編集権限リスト。(各要素はロールIDの文字列(String))
   └processing_authorities(Array) 処理権限リスト。(各要素はロールIDの文字列(String))

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getCategoryInfoByName

Array getCategoryInfoByName(String category_name)

カテゴリ名をキーとしてカテゴリ情報オブジェクトを取得します。
カテゴリ情報オブジェクト配列を返却します。
カテゴリ情報オブジェクトについては、getCategoryInfo()メソッドを参照してください。
引数に"" を指定するとカテゴリ情報の一覧が取得できます。
引数にnull を指定することはできません。
パラメータ
category_name String カテゴリ名(任意)
返却値
Array カテゴリ情報オブジェクト配列
 Object //カテゴリ情報オブジェクト
   ├category_cd(String)           カテゴリコード
   ├category_name(String)         カテゴリ名
   ├category_note(String)         備考
   ├edit_athorities(Array)        編集権限リスト。(各要素はロールIDの文字列(String))
   └processing_authorities(Array) 処理権限リスト。(各要素はロールIDの文字列(String))

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getFlowInfo

Object getFlowInfo(String process_def_cd ,String version_cd ,String activity_cd)

特定のタスクの位置情報を保持した、フローの情報を取得します。
フローの情報オブジェクトを返却します。
フロー情報オブジェクトについては、WkfFlowInfoクラスを参照してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
activity_cd | String | アクティビティコード(任意)
返却値
Object フロー情報オブジェクト
 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessDefInfo

Object getProcessDefInfo(String process_def_cd)

プロセス定義コードをキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクトを返却します。
パラメータ
process_def_cd String プロセス定義コード(必須)
返却値
Object プロセス定義オブジェクト
 Object //プロセス定義オブジェクト
   ├category_cd(String)         カテゴリコード
   ├process_def_cd(String)      プロセス定義コード
   ├process_def_name(String)    プロセス定義名
   ├note(String)                備考
   ├new_version_cd(String)      最新バージョンコード
   ├process_count(Int)          プロセス数
   └activity_process_count(Int) アクティブなプロセス数

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessDefInfoByName

Array getProcessDefInfoByName(String process_def_name)

プロセス定義名をキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクト配列を返却します。
引数に"" を指定するとプロセス定義情報の一覧が取得できます。
引数にnull を指定することはできません。
パラメータ
process_def_name String プロセス定義名(任意)
返却値
Array プロセス定義オブジェクト配列
 Object //プロセス定義オブジェクト
   ├category_cd(String)         カテゴリコード
   ├process_def_cd(String)      プロセス定義コード
   ├process_def_name(String)    プロセス定義名
   ├note(String)                備考
   ├new_version_cd(String)      最新バージョンコード
   ├process_count(Int)          プロセス数
   └activity_process_count(Int) アクティブなプロセス数

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessDefInfoByVersion

Object getProcessDefInfoByVersion(String process_def_cd ,String version_cd)

プロセス定義コード、バージョンコードをキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
返却値
Object プロセス定義オブジェクト
 Object //プロセス定義オブジェクト
   ├category_cd(String)         カテゴリコード
   ├process_def_cd(String)      プロセス定義コード
   ├process_def_name(String)    プロセス定義名
   ├note(String)                備考
   ├version_cd(String)          バージョンコード
   ├process_count(Int)          プロセス数
   └activity_process_count(Int) アクティブなプロセス数

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessList

Array getProcessList(Object condition_key ,Array sort_key ,Number start ,Number amount)

プロセス一覧情報を取得します。
プロセス情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
検索条件オブジェクトについては、WkfSearchConditionを参照してください。
ソート指定オブジェクトについては、WkfSortを参照してください。
パラメータ
condition_key | Object | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array プロセス情報オブジェクト配列
 Object //プロセス情報オブジェクト
   ├category_cd(String)           カテゴリコード
   ├category_name(String)         カテゴリ名
   ├parent_process_def_cd(String) 親プロセス定義コード
   ├parent_version_cd(String)     親プロセスバージョンコード
   ├parent_process_cd(String)     親プロセスコード
   ├process_def_cd(String)        プロセス定義コード
   ├process_def_name(String)      プロセス定義名
   ├version_cd(String)            バージョンコード
   ├version_name(String)          バージョン名
   ├process_cls_cd(String)        プロセス種別コード
   ├process_cd(String)            プロセスコード
   ├process_name(String)          プロセス名
   ├process_status(String)        プロセスステータス
   ├activity_cd(String)           アクティビティコード
   ├activity_name(String)         アクティビティ名
   ├activity_status(String)       アクティビティステータス
   ├attainment_class(String)       到達種別
   ├draft_appoint_date(String)    起票指定日
   ├draft_date(String)            起票日
   ├draft_user_cd(String)         起票者コード
   ├draft_user_name(String)       起票者名
   ├now_approval_name(String)     現処理ユーザ/組織名
   ├reception_date(String)        受信日付
   └process_term_date(String)     処理期限日付

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getVersionInfo

Object getVersionInfo(String process_def_cd ,String version_cd)

プロセス定義コードとバージョンコードをキーとしてバージョン(ルート)情報を取得します。
バージョン情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
返却値
Object バージョン情報オブジェクト
 Object //バージョン情報オブジェクト
   ├process_def_cd(String)         プロセス定義コード
   ├version_cd(String)              バージョンコード
   ├version_name(String)            バージョン名
   ├note(String)                    備考
   ├start_date(String)              開始日付
   ├end_date(String)                終了日付
   ├root_type(String)               ルート種別
   ├contents_path(Obect)            コンテンツパス
        ├page_kind(String)            ページ種別
        ├contents_path(String)        コンテンツパス
        ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
        ├service_id(String)           サービスID(page_kindがframeworkの場合)
        └tab_cd(String)               タブコード(page_kindがポータルの場合)
   ├pull_back_contents_path(Object) 引き戻しコンテンツパス
        ├page_kind(String)            ページ種別
        ├contents_path(String)        コンテンツパス
        ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
        ├service_id(String)           サービスID(page_kindがframeworkの場合)
        └tab_cd(String)               タブコード(page_kindがポータルの場合)
   ├return_contents_path(Object)      差し戻しコンテンツパス
        ├page_kind(String)            ページ種別
        ├contents_path(String)        コンテンツパス
        ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
        ├service_id(String)           サービスID(page_kindがframeworkの場合)
        └tab_cd(String)               タブコード(page_kindがポータルの場合)
   ├refer_contents_path(Object)     参照コンテンツパス
        ├page_kind(String)            ページ種別
        ├contents_path(String)        コンテンツパス
        ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
        ├service_id(String)           サービスID(page_kindがframeworkの場合)
        └tab_cd(String)               タブコード(page_kindがポータルの場合)
   └detail_contents_path(Object)    詳細コンテンツパス
        ├page_kind(String)            ページ種別
        ├contents_path(String)        コンテンツパス
        ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
        ├service_id(String)           サービスID(page_kindがframeworkの場合)
        └tab_cd(String)               タブコード(page_kindがポータルの場合)

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
importProcessDef

Object importProcessDef(String xls_file)

プロセス定義(Excel形式)インポートを実行します。
処理ステータスオブジェクトを返却します。
入力値の「xls_file」はVirtualFile.load()メソッドを使用し、取得したファイルデータを渡してください。
パラメータ
xls_file String ローカルPCのファイルオブジェクト(必須)
返却値
Object 処理ステータスオブジェクト
 Object //処理ステータスオブジェクト
   ├process_def_cd(String)     プロセス定義コード
   ├version_cd(String)         バージョンコード
   ├process_def_name(String)   プロセス定義名
   ├sheet_name(String)         シート名（Excelのシート名）
   ├status(String)             処理結果ID
   └message(String)            処理結果メッセージ
noTransaction

void noTransaction()

データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。
返却値
void
removeProcess

Object removeProcess(String process_def_cd ,String version_cd ,String process_cd ,Boolean xml_out_flg)

案件の削除処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
xml_out_flg | Boolean | XML出力フラグ(必須)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ


 WkfProcess オブジェクト

案件関連のAPI。
案件関連の情報取得などに使用されるクラスです。

<サンプル>
コンストラクタの概要
WkfProcess(String process_def_cd ,String version_cd ,String process_cd ,String login_group_id)
コンストラクタ
メソッドの概要
Array | getFileList() 添付ファイル一覧を取得します。
Array | getFlow() プロセス上の現在位置を取得します。
Object | getProcessHistory() 案件の処理履歴取得します。
Object | getProcessInfo() プロセス情報を取得します。
Object | getTaskResultInfo(String activity_cd) タスク処理結果情報を取得します。
Boolean | hasNext() 次のタスクが存在するかを判断します。
Object | next() 自分自身のオブジェクトを、次のタスクに遷移させます。
コンストラクタの詳細
WkfProcess

WkfProcess(String process_def_cd ,String version_cd ,String process_cd ,String login_group_id)
コンストラクタ
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
getFileList

Array getFileList()

添付ファイル一覧を取得します。
添付ファイルオブジェクトを返却します。
返却値
Array 添付ファイルオブジェクト配列
 Object //添付ファイルオブジェクト
   ├path(String)       ファイルパス(storageからの相対パス)
   ├file_cd(String)    ファイルID
   ├file_name(String)  ファイル名（論理ファイル名）
   └file_size(Int)     ファイルサイズ(バイト)

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getFlow

Array getFlow()

プロセス上の現在位置を取得します。
プロセス上の現在承認待ちになっているタスクの情報を取得します。
返却値
Array プロセス上の現在位置情報オブジェクト配列
 Object //現在位置情報オブジェクト
   ├process_def_cd(String)  プロセス定義コード
   ├version_cd(String)      バージョンコード
   ├process_cd(String)      プロセスコード
   └activity_cd(String)     アクティビティコード

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessHistory

Object getProcessHistory()

案件の処理履歴取得します。
案件の処理履歴情報オブジェクトを返却します。

次の処理履歴があるか確認するには「hasNext()」メソッドを使用してください。
(詳しくは「hasNext()」を参照してください。)
次の処理履歴を取得するには「next()」メソッドを使用してください。
(詳しくは「next()」を参照してください。)
返却値
Object 案件の処理履歴オブジェクト
 Object //処理履歴情報オブジェクト
   ├process_def_cd(String)        プロセス定義コード
   ├version_cd(String)            バージョンコード
   ├process_cd(String)            プロセスコード
   ├activity_cd(String)           アクティビティコード
   ├activity_name(String)         アクティビティ名
   ├activity_status(String)       アクティビティステータス
   ├activity_type(String)         アクティビティ種別(常に"処理タスク"(RECEIVE)となります。)
   ├call_process_cd(String)       親プロセスコード
   ├status_ended_date(String)     ステータス完了日付
   ├approval_date(String)         承認日
   ├approval_user_cd(String)      承認者コード
   ├approval_user_name(String)    承認者名
   ├approval_type(String)         承認種別
   ├comp_cd(String)               処理者の処理時の会社コード
   ├orgn_cd(String)               処理者の処理時の組織コード
   ├orgn_name(String)             処理者の処理時の組織名
   ├main_flg(Boolean)             主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）
   ├commnet(String)               承認時のコメント
   ├agent_tran_flg(String)        代理_振替えフラグ
   ├agent_tran_user_cd(String)    代理_振替元ユーザコード
   └agent_tran_user_name(String)  代理_振替元ユーザ名

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessInfo

Object getProcessInfo()

プロセス情報を取得します。
プロセス情報オブジェクトを返却します。
返却値
Object プロセス情報オブジェクト
 Object //プロセス情報オブジェクト
   ├category_cd(String)               カテゴリコード
   ├category_name(String)             カテゴリ名
   ├parent_process_def_cd(String)     親プロセス定義コード
   ├parent_version_cd(String)         親プロセスバージョンコード
   ├parent_process_cd(String)         親プロセスコード
   ├parent_activity_cd(String)        親アクティビティコード
   ├process_def_cd(String)            プロセス定義コード
   ├process_def_name(String)          プロセス定義名
   ├version_cd(String)                バージョンコード
   ├version_name(String)              バージョン名
   ├process_cd(String)                プロセスコード
   ├process_name(String)              プロセス名
   ├process_status(String)            プロセスステータス
   ├last_man_activity(String)         最終手動アクティビティコード
   ├last_man_activity_result(String)  最終手動アクティビティ承認結果種別
   ├draft_appoint_date(String)        起票指定日
   ├draft_date(String)                起票日
   ├draft_user_cd(String)             起票者コード
   ├draft_user_name(String)           起票者名
   ├draft_comment(String)             起票時コメント
   └app_key(Array)                    アプリケーションキー配列(String配列)

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getTaskResultInfo

Object getTaskResultInfo(String activity_cd)

タスク処理結果情報を取得します。
タスク処理結果情報オブジェクトを返却します。
パラメータ
activity_cd String アクティビティコード(必須)
返却値
Object タスク処理結果情報オブジェクト
 Object //タスク処理結果情報オブジェクト
   ├process_def_cd(String)             プロセス定義コード
   ├version_cd(String)                 バージョンコード
   ├process_cd(String)                 プロセスコード
   ├activity_cd(String)                アクティビティコード
   ├activity_name(String)              アクティビティ名
   ├activity_type(String)              アクティビティ種別(常に"処理タスク"(RECEIVE)となります。)
   ├activity_status(String)            アクティビティステータス
   ├attainment_class(String)           到達種別
   ├activity_status_comp_date(String)  ステータス完了日付
   ├reception_date(String)             受信日付
   ├process_term_date(String)          処理期限日付
   ├approval_type(String)              処理結果
   ├approval_user_cd(String)           処理ユーザコード
   ├approval_user_name(String)         処理ユーザ名
   ├approval_comment(String)           処理時コメント
   ├approval_date(String)              処理日
   ├auto_pass_term(String)             自動パス（バッチ）期限
   ├auto_pass_flag(String)             自動パス（バッチ）処理フラグ
   ├present_process(String)            現処理表示文字
   ├transfer_flg(String)               代理依頼フラグ
   ├delegate_flag(String)              振り替えフラグ
   ├agent_target(String)               代理依頼先対象(ユーザ/会社組織)
   ├agent_comp_cd(String)              代理依頼先会社コード（代理に組織を指定時）
   ├agent_cd(String)                   代理依頼先ユーザ/組織コード
   ├agent_name(String)                 代理依頼先ユーザ/組織名
   ├client_user_cd(String)             代理依頼元ユーザコード
   ├client_user_name(String)           代理依頼元ユーザ名
   ├comp_cd(String)                    処理者の処理時の会社コード
   ├orgn_cd(String)                    処理者の処理時の組織コード
   └main_flg(Boolean)                  主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
hasNext

Boolean hasNext()

次のタスクが存在するかを判断します。
「getProcessHistory()」メソッドで取得した処理結果の次の処理結果があるかどうかを返却します。
このメソッドは必ず「getProcessHistory()」メソッドを実行した後に使用してください。
返却値
Boolean 存在する:true/存在しない:false
next

Object next()

自分自身のオブジェクトを、次のタスクに遷移させます。
「getProcessHistory()」メソッドで取得した処理結果の次の処理結果を返却します。
このメソッドは必ず「getProcessHistory()」メソッドを実行した後に使用してください。
案件の処理履歴オブジェクトについては、getProcessHistory()メソッドを参照してください。
返却値
Object 案件の処理履歴オブジェクト


 WkfReference オブジェクト

参照関連のAPI。
参照案件の取得などに使用されるクラスです。

<サンプル>
コンストラクタの概要
WkfReference(String user_cd ,String login_group_id)
コンストラクタ
メソッドの概要
Array getReferTaskList(Object conditionKey ,Array sort_key ,Number start ,Number amount)
参照可能案件一覧を取得します。
コンストラクタの詳細
WkfReference

WkfReference(String user_cd ,String login_group_id)
コンストラクタ
パラメータ
user_cd | String | 参照者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
getReferTaskList

Array getReferTaskList(Object conditionKey ,Array sort_key ,Number start ,Number amount)

参照可能案件一覧を取得します。
参照可能案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
検索条件オブジェクトについては、WkfSearchConditionを参照してください。
ソート指定オブジェクトについては、WkfSortを参照してください。
パラメータ
conditionKey | Object | 検索条件オブジェクト配列(必須。必ずフィルターをセットしてください)
sort_key | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array 参照可能案件情報オブジェクト配列
 Object //参照可能案件情報オブジェクト
   ├category_cd(String)           カテゴリコード
   ├category_name(String)         カテゴリ名
   ├parent_process_def_cd(String) 親プロセス定義コード
   ├parent_version_cd(String)     親プロセスバージョンコード
   ├parent_process_cd(String)     親プロセスコード
   ├process_def_cd(String)        プロセス定義コード
   ├process_def_name(String)      プロセス定義名
   ├version_cd(String)            バージョンコード
   ├version_name(String)          バージョン名
   ├process_cls(String)           プロセス種別コード
   ├process_cd(String)            プロセスコード
   ├process_name(String)          プロセス名
   ├process_status(String)        プロセスステータス
   ├draft_appoint_date(String)    起票指定日
   ├draft_date(String)            起票日
   ├draft_user_cd(String)         起票者コード
   └draft_user_name(String)       起票者名

 返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。


 WkfSearchCondition オブジェクト

プログラムサポート/検索条件設定オブジェクト。
指定できる検索条件は各検索メソッドの戻り値に指定されている項目のみとなります。

検索キーにて日付関連のキーを指定する場合には、intra-mart日付フォーマット（yyyy/MM/dd|HH:mm:ss）にて、
指定するようにしてください。
各検索項目キーは以下のフィールドを参照してください。

※フィルターについて
コンストラクタの概要
WkfSearchCondition()
コンストラクタ
メソッドの概要
void setCondition(Object condition)
検索条件を設定します。
コンストラクタの詳細
WkfSearchCondition

WkfSearchCondition()
コンストラクタ
メソッドの詳細
setCondition

void setCondition(Object condition)

検索条件を設定します。
パラメータ
condition Object 検索条件オブジェクト
 Object 検索条件オブジェクト
   ├go_filter(Boolean)               未処理タスクの表示(本人)
   ├agt_go_filter(Boolean)           未処理タスクの表示(代理元承認不可)
   ├clt_agt_go_filter(Boolean)       未処理タスクの表示(代理元承認可)
   ├pullback_filter(Boolean)         引き戻しタスクの表示(本人)
   ├agt_pullback_filter(Boolean)     引き戻しタスクの表示(代理元承認不可)
   ├clt_agt_pullback_filter(Boolean) 引き戻しタスクの表示(代理元承認可)
   ├sendback_filter(Boolean)         差し戻しタスクの表示(本人)
   ├agt_sendback_filter(Boolean)     差し戻しタスクの表示(代理元承認不可)
   ├clt_agt_sendback_filter(Boolean) 差し戻しタスクの表示(代理元承認可)
   ├complete_filter(Boolean)         完了タスクの表示(本人)
   ├agt_complete_filter(Boolean)     完了タスクの表示(代理元承認不可)
   ├clt_agt_complete_filter(Boolean) 完了タスクの表示(代理元承認可)
   ├category_cd(String)              カテゴリコード
   ├category_name(String)            カテゴリ名
   ├process_def_cd(String)           プロセス定義コード
   ├process_def_name(String)         プロセス定義名
   ├version_cd(String)               バージョンコード
   ├process_cd(String)               プロセスコード
   ├process_name(String)             プロセス名
   ├activity_cd(String)              アクティビティコード
   ├activity_name(String)            アクティビティ名
   ├draft_user_cd(String)            起票者コード
   ├draft_user_name(String)          起票者名
   ├draft_comp_cd(String)            起票者の起票会社コード
   ├draft_orgn_cd(String)            起票者の起票組織コード
   ├draft_appoint_date(String)       起票指定日
   ├draft_date_start(String)         起票日(検索範囲開始日)
   ├draft_date_end(String)           起票日(検索範囲終了日)
   ├before_user_cd(String)           前処理者ユーザコード
   ├before_user_name(String)         前処理者ユーザ名
   ├approval_user_cd(String)         処理者ユーザコード
   ├approval_user_name(String)       処理者ユーザ名
   ├approval_comp_cd(String)         処理者の会社コード
   ├approval_orgn_cd(String)         処理者の会社組織コード
   ├approval_orgn_name(String)       処理者の会社組織名
   ├approval_date_start(String)      処理日(検索範囲開始日)
   ├approval_date_end(String)        処理日(検索範囲終了日)
   ├agent_user_cd(String)            代理依頼元ユーザコード
   ├agent_user_name(String)          代理依頼元ユーザ名
   ├arrive_date_start(String)        到達日(検索範囲開始日)
   ├arrive_date_end(String)          到達日(検索範囲終了日)
   ├limit_date_start(String)         処理期限日(検索範囲開始日)
   └limit_date_end(String)           処理期限日(検索範囲終了日)
返却値
void


 WkfSettingReserveFlg オブジェクト

プログラムサポート/メール送信　リザーブフラグ設定クラス。
コンストラクタの概要
WkfSettingReserveFlg()
コンストラクタ
メソッドの概要
String | getResult() エラーコードを返却します。
String | setReserveFlg() リザーブフラグを設定します。
コンストラクタの詳細
WkfSettingReserveFlg

WkfSettingReserveFlg()
コンストラクタ
メソッドの詳細
getResult

String getResult()

エラーコードを返却します。
エラーコードは、BPWErrorCodeIFで定義された定義値です。
エラーでない場合は、””(空文字)が返却されます。
返却値
String エラーコード
setReserveFlg

String setReserveFlg()

リザーブフラグを設定します。
返却値
String エラーコード


 WkfSort オブジェクト

プログラムサポート/ソート指定オブジェクト。
ソート対象は各検索メソッドの戻り値がソート対象となります。
コンストラクタの概要
WkfSort()
コンストラクタ
メソッドの概要
void | setAscending(String sort_key) 昇順ソートキーを設定します。
void | setDescending(String sort_key) 降順ソートキーを設定します。
コンストラクタの詳細
WkfSort

WkfSort()
コンストラクタ
メソッドの詳細
setAscending

void setAscending(String sort_key)

昇順ソートキーを設定します。 ソート対象は各検索メソッドの戻り値がソート対象となります。
例えば、category_cdを昇順ソートキーとする場合、setAscending(”category_cd”)と記述してください。
パラメータ
sort_key String 昇順ソートキー
返却値
void
setDescending

void setDescending(String sort_key)

降順ソートキーを設定します。 ソート対象は各検索メソッドの戻り値がソート対象となります。
例えば、category_cdを降順ソートキーとする場合、setDescending(”category_cd”)と記述してください。
パラメータ
sort_key String 降順ソートキー
返却値
void


 WkfUtil オブジェクト

ユーティリティ関連のAPI。
バッチ起動などの処理に使用されるクラスです。
コンストラクタの概要
WkfUtil(String login_group_id)
コンストラクタ
メソッドの概要
Object | autoPass(String category_cd ,String process_def_cd ,String version_cd ,Number date) 案件の自動パス(バッチ起動)処理を実行します。
Object | autoPress(String category_cd ,String process_def_cd ,String version_cd ,Number date) 案件の自動催促(バッチ起動)処理を実行します。
Object | sendMail(String template_path ,String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Array to ,Array cc ,Array bcc) メール送信を行います。
コンストラクタの詳細
WkfUtil

WkfUtil(String login_group_id)
コンストラクタ
パラメータ
login_group_id String ログイングループID(必須)
メソッドの詳細
autoPass

Object autoPass(String category_cd ,String process_def_cd ,String version_cd ,Number date)

案件の自動パス(バッチ起動)処理を実行します。
自動パス承認期限を過ぎた案件を自動承認します。
返却値は、処理結果を返却します。
パラメータ
category_cd | String | カテゴリコード(任意：未指定時は全カテゴリ)
process_def_cd | String | プロセス定義コード(任意：未指定時は全プロセス定義)
version_cd | String | バージョンコード(任意：未指定時は全バージョン)
date | Number | 承認期限の延長日数(任意)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
autoPress

Object autoPress(String category_cd ,String process_def_cd ,String version_cd ,Number date)

案件の自動催促(バッチ起動)処理を実行します。
自動催促メールを送ります。
返却値は、処理結果を返却します。
パラメータ
category_cd | String | カテゴリコード(任意：未指定時は全カテゴリ)
process_def_cd | String | プロセス定義コード(任意：未指定時は全プロセス定義)
version_cd | String | バージョンコード(任意：未指定時は全バージョン)
date | Number | 承認期限の延長日数(任意)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ
sendMail

Object sendMail(String template_path ,String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Array to ,Array cc ,Array bcc)

メール送信を行います。
返却値は、メール送信結果を返却します。
パラメータ
template_path | String | テンプレートパス(必須)
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
to | Array | Toメールアドレス配列(String配列)
cc | Array | Ccメールアドレス配列(String配列)
bcc | Array | Bccメールアドレス配列(String配列)
返却値
Object メール送信結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)  処理結果(true:成功/false:失敗)
 ├getId(String)      エクセプションID
 └getMessage(String) エラーメッセージ


intra-mart[Server side JavaScript intra-mart Documentation.[Batch]]

i ntra-mart The Power for Enterprise Web Solution
バッチ管理モジュール

プログラムの作成

Resource Service のインストール・ディレクトリ以下にファンクション・コンテナとしてプログラムファイルを作成します。

バッチ起動されるファンクション・コンテナ内には、必ず init() 関数を定義する必要があります。
(指定時間に該当のファンクション・コンテナをロードすると init() 関数が Application Runtime により自動実行されます。)

バッチ起動されるファンクション・コンテナの init() 関数には、下記のような構造を持つオブジェクト型の引数が渡されます。

引数 | オブジェクト
├ | group | ログイン・グループ名称
├ | name | バッチ設定名称
├ | year | バッチ起動設定年
├ | month | バッチ起動設定月
├ | date | バッチ起動設定日
├ | day | バッチ起動設定曜日
├ | hour | バッチ起動設定時間
├ | minute | バッチ起動設定分
├ | second | バッチ起動設定秒
├ | WWW_HOST | バッチ設定を行った時のＷｅｂサーバホスト名
├ | WWW_PORT | バッチ設定を行った時のＷｅｂサーバポート
├ | WWW_PROTOCOL | バッチ設定を行った時のＷｅｂサーバプロトコル
└ | WWW_LOCATION | バッチ設定を行った時のホームＵＲＬ

バッチ用プログラムに関しては、動作概要【 Batch Program 篇 】 を参照して下さい。

システム構成

バッチ機能を利用するためには、すべてのサービスをそれぞれインストールし、Schdule Service から Application Runtime に対して HTTP 接続できるように環境構築してください。

バッチの登録と設定

バッチプログラムの登録と起動時間の設定は、i ntra-mart 起動後の『システム設定』-『バッチ』メニュー内で行います。

バッチ設定では、バッチ登録と運用可否設定があります。登録したバッチプログラムは、『有効』設定にしておかないと実行されません。
また、バッチサーバの実行状態を『運用中』にしなければバッチプログラムはロードされません。

設定画面の操作に関しては、マニュアルをご参照下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Tree View]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart
カレンダー表示モジュール

機能概要

カレンダーマスメンテナンス画面で設定したデータと連携したカレンダー画面を表示します。 カレンダー画面を利用すると、会社の休日や営業日を考慮した日付の入力が行えます。

ＡＰＩ仕様

この機能は、プレゼンテーションページから利用します。

<IMART type="link"> の page 属性に以下のキーワードをリンクすることで、 カレンダー画面を呼び出すことができます。

@IM_CALENDAR_VIEW | 標準の表示形式のカレンダー
@IM_CALENDAR_VIEW_COMPACT | 動作の軽い表示形式のカレンダー

Presentation Pageのコーディング例
<HTML>
<HEAD>
</HEAD>
<BODY>
<IMART type="link" page="@IM_CALENDAR_VIEW"
year="1999"
month="5">
</IMART>
</BODY>
</HTML>

リンクに対して指定する方法の他にも<IMART type="frame"> のsrc属性 や <IMART type="form"> または <IMART type="submit"> の page 属性に対しても同様に指定することができます。

タグに指定する属性引数には、以下の種類があります。

year | (必須) | カレンダーの表示年
month | (必須) | カレンダーの表示月
past | (任意) | カレンダーの年選択コンボの表示量（過去） （現在表示年から過去past年間をコンボで選択可能）
future | (任意) | カレンダーの年選択コンボの表示量（未来） （現在表示年から未来past年間をコンボで選択可能）
display | (任意) | 日がクリックされたときにページをコールするウィンドウ名 （または、フレーム名）
link | (任意) | 日がクリックされたときにコールされるページパス （ Resource Serviceのプログラムディレクトリ（標準では、%Resource Service%/pages/src）からの相対パス）

カレンダーデータの受け取り方法

表示カレンダーの日がクリックされると自動的に link オプションに指定されているページをコールします。 このページのファンクションコンテナでユーザのクリック（選択）した情報を取得することができます。 ユーザがクリックした日情報は request オブジェクトを介して取得することができます。

Function Containerのコーディング例
        var sGroup = request.group;   // カレンダーID
        var sYear  = request.dtyear;  // 選択年の取得
        var sMonth = request.dtmon;   // 選択月の取得
        var sDate  = request.dtday;   // 選択日の取得

カレンダー拡張タグ

<IMART type="calender"> という拡張タグを使うことでカレンダー画面を自由に作成することができるようになります。

詳細なプログラム・インターフェースに関しては、画面共通モジュール を参照下さい。

カレンダーモジュール

CalendarManagerオブジェクトに 含まれる各メソッドを利用することでプログラムにおいてカレンダー設定情報を呼び出して利用することができるようになります。

詳細なプログラム・インターフェースに関しては、アプリケーション共通モジュール を参照下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript BASE MODULE Documentation.[Mail]]

i ntra-mart The Power for Enterprise Web Solution
メール連携モジュール

準備(前提条件)

Application Runtime からネットワーク接続可能なマシン上にＳＭＴＰサーバ(RFC821 に準拠しているソフトウェア)を立ちあげて下さい。

Application Runtime の初期設定ファイル([install_directory]/conf/imart.xml)において、稼働中のＳＭＴＰサーバのアドレスとポートを指定した後に、i ntra-mart を起動して下さい。
メール連携モジュールを使用するには以下のライブラリが必要です。別途ダウンロードしてください。

  • JavaMail API 1.2
  • JavaBeans Activation Framework 1.0.2

    i ntra-mart BaseModuleの場合はダウンロードしたアーカイブを解凍し、全てのjarファイルを[install_directory]/lib/に配置してください。
    i ntra-mart Frameworkの場合は解凍したjarファイルをウェブアプリケーションサーバのクラスパスに追加してください。

    ＡＰＩ

    MailSender オブジェクト を利用します。

    詳細なプログラム・インターフェースに関しては、アプリケーション共通モジュール を参照下さい。

    例

    ファンクション・コンテナで MailSender ＡＰＩを利用してメール送信プログラムを記述します。

    以下に、aaa@example.com, bbb@example.com, および ccc@example.com に対して「試験メール」という表題の「これはメール送信試験です。\n無事に届きましたか？」という内容のメールを送信する例を示します。
    送信者アドレスは zzz@example.com とします。

    function init(request) {

    var letter = "これはメール送信試験です。\n無事に届きましたか？";

    // 送信メールオブジェクトを生成
    var mail = new MailSender();
    mail.addTo("aaa@example.com");
    mail.addTo("bbb@example.com");
    mail.addTo("ccc@example.com");
    mail.setFrom("zzz@example.com");
    mail.setSubject("試験メール");
    mail.setText(letter);

    // Storage Serviceから取得したファイルを添付
    var file = new VirtualFile("attach.txt");
    mail.addAttachment("attach.txt", file.load());

    // メール送信
    var result = mail.send();

    if(result) {
        Debug.browse("Scucess");
    } else {
        Debug.browse("Failed", mail.getErrorMessage());
    }
}

    • Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2003 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Tree View]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart
ツリー形式表示 API 仕様

機能概要

階層化データをツリー形式でブラウザ上に表示します。

このツリー表示ＡＰＩでは、以下の３種類のツリー表示部品を提供します。

  • フォルダー開閉式(初期表示は全閉)
  • フォルダー開閉式(初期表示は全開)
  • フォルダー開閉動作無し

ＡＰＩ仕様

この機能は、プレゼンテーションページから利用します。

<IMART type="include"> ＡＰＩを利用して、プログラムパスを呼び出して表示します。
呼び出すプログラムパスは以下の中から任意に選択できます。

@TREE_VIEW | 標準
@DYNAMIC_TREE_OPEN_VIEW | フォルダー開閉式(初期表示は全開)
@DYNAMIC_TREE_CLOSE_VIEW | フォルダー開閉式(初期表示は全閉)
@STATIC_TREE_VIEW | フォルダー開閉動作無し
※） 標準インストールにおいては、『標準』はデフォルト動作として『フォルダー開閉式(初期表示は全閉)』が選択されています。

タグに指定する属性引数には、以下の種類があります。

list | (必須) | 表示するツリー構造データ
home_name | (必須) | ホームの表示名
home_detail | (必須) | ホームの説明文 (ポップアップ文字列の表示内容)
click_home | (任意) | ホームイベント時実行関数名 ホームクリック時に実行されます 無指定時はイベント発生なし
click_folder | (任意) | フォルダイベント時実行関数名 フォルダクリック時に引数を伴って実行されます 無指定時はイベント発生時にフォルダの開閉動作
click_item | (任意) | アイテムイベント時実行関数名 アイテムクリック時に引数を伴って実行されます 無指定時はイベント発生時の処理はなし
highlight | (任意) | 選択項目のハイライトカラー 無指定時はデフォルト色を自動選択 (フォルダー開閉式ツリーのみ有効)

ホーム、フォルダーおよびアイテムのイベントとは、該当項目をマウスでクリックする行為をいいます。
マウスクリックイベントに対する各種開閉動作および選択項目のハイライトに関しては、フォルダー開閉式のツリー表示時が対象となり、フォルダー開閉動作無しのツリー表示時には、イベント処理は行われません。

属性 list にしていするツリーデータは、下記のような構造を持つデータオブジェクト配列を指定します。

list[0] ┬ name // この項目の表示名称 ・ ├ detail // この項目の説明 ・ ├ argument // この項目がクリックされた時の引数 ・ └ next[0] // この項目の下階層項目群 ・ ├ name ・ ├ detail ・ ├ argument ・ └ next[0] ・・・ [n] ┬ name ├ detail ├ argument └ next[0]
name | [String] | 項目の表示名称
detail | [String] | マウスポイント時に表示されるポップアップ文字列
argument | [String] | マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列
next | [Array] | 下層のオブジェクト配列。 このプロパティ値を null にした場合アイテムとして扱われます。 また、このプロパティに Array 型のデータを値として与えることで、フォルダとして扱われます(要素を１つも持たない空の配列を値として与えた場合、下層情報を持たないフォルダとして扱われます)。
※）配列データを作成する場合、要素番号は 0 から始まる連続したデータとして作成するようにして下さい。

表示アイコン解説

・・・ | ホーム
・・・ | フォルダ (閉)
・・・ | フォルダ (開)
・・・ | アイテム
・・・ | 全表示

用語および操作解説

ホーム | ( [image] ) | : | マウスでホームアイコン( [image] ) をクリックすると、開かれていたメニュー項目がすべて閉じられます。 ホーム名称をクリックした場合、click_home 属性で指定してある Client Side の JavaScript 関数が実行されます(属性指定を省略した場合には、関数実行は行われません)。
フォルダ | ( [image] ) | : | メニュー項目グループの参照とメニューの開閉を行います。 マウスでフォルダアイコン( [image] または [image] or [image] または [image] or [image] ) をクリックすると、メニュー画面上でフォルダ内の各項目が開閉されます(ツリー開閉式を利用していた場合)。 フォルダ名称をクリックした場合、click_folder 属性で指定してある Client Side の JavaScript 関数が実行されます(属性指定を省略した場合には、関数実行は行われません)。
アイテム | ( [image] ) | : | 閲覧ページ、または作業ページを表示します。 ページアイコン( [image] )またはアイテム名称をクリックすると、click_item 属性で指定してある Client Side の JavaScript 関数が実行されます(属性指定を省略した場合には、関数実行は行われません)。
全表示 | ( [image] ) | : | すべてのメニュー項目を開きます。

プログラミング時の制約事項

引数属性 list には、仕様に準拠したデータを渡して下さい。間違った構造を持つデータを指定した場合、ランタイムエラーが発生する可能性があります。

ツリーの各クリックイベントに対応した Client Side の JavaScript 関数は、必ずツリー呼び出しステートメントよりもファイルの上部に定義(記述)してください。

ツリー開閉式ツリー表示ユニットでは、Dynamic-HTML およびスタイルシート(CSS)技術を利用しています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、これらの技術を無闇に利用すると二重定義などが発生しツリーのイベントが正常に動作しなくなることがあります。

ツリー表示ユニットで利用している Dynamic-HTML(ツリー開閉式のみ) および CSS (ツリー開閉式のみ) の定義名や Client Side JavaScript 関数(ページ内グローバル)および変数(ページ内グローバル) の名称には tree_ というプレフィックスがついています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、Client Side JavaScript の各関数(ページ内グローバル)および各変数(ページ内グローバル)の名称などには、tree_ で開始される名称定義をしないでください。

ツリー表示ユニットでは、Dynamic-HTML(ツリー開閉式のみ) および Client Side JavaScript 技術を利用しています。
これら技術に対応していないブラウザでの利用はしないでください。

開閉式ツリー表示では、Dynamic-HTML 技術を利用して各項目の表示位置を自動的に計算して表示をしています。
ツリー表示呼び出しステートメントを記述してある位置を基準に表示位置を計算しているので、ツリー表示ステートメントはページの最下部に記述するようにしてください。

プログラム例

Presentation Page
<HTML>
<HEAD>
<SCRIPT language="JavaScript">
function onClickHomeFunction(){
window.alert("click home !");
}
function onClickFolderFunction(arg){
window.alert("click folder: " + arg);
}
function onClickItemFunction(arg){
window.alert("click item: " + arg);
}
</SCRIPT>
</HEAD>
<BODY>
<IMART type="include"
page="@TREE_VIEW"
list=datas
click_home="onClickHomeFunction"
click_folder="onClickFolderFunction"
click_item="onClickItemFunction"
home_name="sample"
home_detail="top"
hightlight="blue">
</IMART>
</BODY>
</HTML>
Function Container
var datas = new Array();

function init(request){
datas[0] = new Object();
datas[0].name = "No.1";
datas[0].detail = "item of No.1";
datas[0].argument = "no1";
datas[0].next = new Array();
datas[0][0] = new Object();
datas[0][0].name = "No.1-1";
datas[0][0].detail = "item of No.1-1";
datas[0][0].argument = "no1-1";
datas[0][0].next = null;
datas[1] = new Object();
datas[1].name = "No.2";
datas[1].detail = "item of No.2";
datas[1].argument = "no2";
datas[1].next = null;
}

注意事項

ツリー表示の各ホーム、フォルダおよびアイテムなどの画像ファイルは固定のものが使われます。任意に選択・変更することはできません。

開閉式ツリー表示のマウスイベント処理は、すべてブラウザ上の Client Side JavaScript で制御されていますので、ツリーの表示速度やイベント時の処理速度はクライアントマシンの処理能力に依存します。

ツリーの項目数が多い場合、ツリー表示画面のダウンロードに時間がかかったり、ブラウザ上に表示されるまでに時間がかかることがあります。
また、開閉式ツリー表示において表示項目数が多い時に、マウスクリックに対する反応が鈍くなることがあります。

制約事項

ツリー形式表示を行うためのツリーデータとして渡された情報は、そのまま画面作成に用いられる値として利用されます。
特にツリーデータ内の name プロパティに指定した値は表示系アプリケーション（ブラウザ）の実装に依存します。
また、ツリーデータ内の detail および argument プロパティに指定した値は、Client-Side JavaScript 中で利用されるデータとなりますので、扱える文字に制限がかかる場合があります（制限に関してはブラウザの実装に依存します）。

name データとして使えない文字の一例
< > & "
argument および detail データとして使えない文字の一例
< > " ' \

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Native Call]]

i ntra-mart The Power for Enterprise Web Solution
外部ライブラリコール

概要

intra-mart フレームワーク では、外部ライブラリの呼び出しが可能です。
外部ライブラリの作成から実行までを解説します。

外部ライブラリコールのアーキテクチャ

外部ライブラリの呼び出しは、フレームワークからJavaラッパークラスを経由して、 呼び出しを行います。

外部ライブラリの呼び出しは以下の手順で行います。

  1. ファンクション・コンテナの関数からJavaラッパークラスを生成します。
  2. Javaラッパークラスの関数を呼び出します。
    （Javaラッパークラスの各関数が外部ライブラリの各関数と紐づいています。）
  3. 対応した外部ライブラリの関数が実行されます。

Javaラッパークラスと外部ライブラリの作成

ここでは、C言語で作成される外部ライブラリの作成方法について説明します。

作成に必要なもの

Javaラッパークラスと外部ライブラリを作成するには、以下のものが必要です。
  • JDK （Javaラッパークラスを作成するために必要です）
    • javac.exe (Javaラッパークラスをコンパイルします。)
    • javah.exe (JavaラッパークラスからC言語用のヘッダファイルを作成します。)
    • jni.h （外部ライブラリ作成時に使用する標準ヘッダファイル）
  • Cコンパイラ （外部ライブラリを作成するために必要です）

フレームワークでの制約

フレームワークではJavaScriptから外部ライブラリを呼び出すために使用できる変数の型に制約を受けます。
以下に使用できる変数の型と対応する各言語の型を示します。

JavaScriptの型 | Javaの型 | Cの型
String | String | jstring
Number | double | jdouble
Boolean | boolean | jboolean

作成手順

  1. Javaラッパークラス（.java）を作成します。
  2. javac.exeでJavaラッパークラス(.java)をコンパイルします。（.class の作成）
  3. javah.exeでjavaラッパークラス（.java）から、C言語用のヘッダファイル(.h)を作成します。
  4. 作成されたヘッダファイル(.h)を元に外部ライブラリファイル（.c）を作成します。
  5. 外部ライブラリファイル(.c)をコンパイルし、外部ライブラリ（.dll）を作成します。

Javaラッパークラスの作成

  1. 新規にクラスを作成します｡
    (この時､パッケージ名を必ずつけてください｡)

  2. static エリア（初回CLASSロード時の処理）にロードするライブラリの名称を記述します。

    System.loadLibrary("ライブラリ名");
    ライブラリ名には、拡張子を除いたものを記述します。

  3. publicなメソッドを記述します。

    public native 戻り型 関数名（引数の型 引数名, [.….] ）;
    戻り値 および 引数の型は String , double , boolean のいずれかです。
    ここでは、メソッドの宣言だけで、手続きは書かないことに注意してください。

  4. 作成したファイルをコンパイルします。

    javac.exe ファイル名
    作成したclassファイルを.jarファイルにもまとめます。

[作成例]
package Hellow;
public class Hellow {
       static { // 初回CLASSロード時の処理
        System.loadLibrary("Hellow");  // ロードするライブラリ(Hellow.dll)
    }

    public Hellow( ) { }  // コンストラクタ

    // 引数の文字列を結合する関数
       public native String margeString(String a , String b);
       // 引数の数値を合算する関数
       public native double getPlus(double a , double b);
       // 引数の論理積を求める関数
    public native boolean getAnd(boolean a ,boolean b);
}

外部ライブラリの作成

  1. JavaラッパークラスからC言語用のヘッダファイルを作成します。
    javah.exe ファイル名

    [作成されるヘッダファイルのプロトタイプ]
    JNIEXPORT 戻り型 JNICALL 関数名 ( JavaVMのポインタ,クラスのオブジェクト,各引数の型);

  2. C言語用のヘッダファイルを元に外部ライブラリファイルを作成します。

    各関数の手続きを記述します。

  3. 外部ライブラリファイルをコンパイルして、（.dll）を作成します。

jstring(文字列)の扱い方

文字列はJava上では、UniCodeとして扱われます。
C言語で、利用するためには、UniCode → UTF-8への変換が必要です。
変換方法は以下の通りです。

*env | : JAVA-VMのインスタンス（関数の引数から渡されます）
a | : 変換したい文字列(jstring型) UniCode
*ca | : 変換後の文字列(char * 型) UTF-8

const char *ca = (*env)->GetStringUTFChars(env,a,0);
UTF-8に変換すると、C言語で通常の文字列として扱えます。

Javaへ値を返す時は、UTF-8 → UniCodeへの変換が必要です。
以下の例は、C言語の文字列から、Javaの文字列を作成する方法です
。
*env | : JAVA-VMのインスタンス（関数の引数から渡されます）
jstr | : 作成した文字列（jstring型） UniCode
buf | : 変換元の文字列(char * 型) UTF-8

jstr = (*env)->NewStringUTF(env,buf);

「作成されたヘッダファイルの例」
#include
#ifndef _Included_Hellow_Hellow
#define _Included_Hellow_Hellow
#ifdef __cplusplus
extern "C" {
#endif

JNIEXPORT jstring JNICALL Java_Hellow_Hellow_margeString
  (JNIEnv *, jobject, jstring, jstring);

JNIEXPORT jdouble JNICALL Java_Hellow_Hellow_getPlus
  (JNIEnv *, jobject, jdouble, jdouble);

JNIEXPORT jboolean JNICALL Java_Hellow_Hellow_getAnd
  (JNIEnv *, jobject, jboolean, jboolean);

#ifdef __cplusplus
}
#endif
#endif

「外部ライブラリファイルの例」
#include "Hellow_Hellow.h"
#include
/* 引数の文字列を結合する関数 */
JNIEXPORT jstring JNICALL Java_Hellow_Hellow_margeString
        (JNIEnv *env, jobject jobj, jstring a, jstring b)
{
    char buf[256]; /* テンポラリ文字列 */
    jstring jstr;  /* 戻り値用*/
    /* 引数をユニコードからUTF-8への変換 */
    const char *ca = (*env)->GetStringUTFChars(env,a,0);
    const char *cb = (*env)->GetStringUTFChars(env,b,0);

    strcpy(buf,ca); /* コピー*/
    strcat(buf,cb); /* 結合  */
    /* 戻り値の値をJava用のStringとして作成する。*/
    jstr = (*env)->NewStringUTF(env,buf);
    return jstr;
}
/* 引数の数値を合算する関数 */
JNIEXPORT jdouble JNICALL Java_Hellow_Hellow_getPlus
        (JNIEnv *env, jobject jobj , jdouble a, jdouble b)
{
    jdouble c; /* 戻り値用*/
    c = a + b; /* 合算する */
    return (c);
}
/* 引数の論理積を求める関数 */
JNIEXPORT jboolean JNICALL Java_Hellow_Hellow_getAnd
        (JNIEnv *env, jobject jobj, jboolean a, jboolean b)
{
    jboolean c ; /* 戻り値用*/
    c = a & b ; /* 論理積を求める */
    return (c);
}

外部ライブラリコールの方法

外部ライブラリコールの準備

  1. 作成した外部ライブラリ(DLLファイル)をPATHの通ったディレクトリに保存します。

  2. 作成したJavaラッパークラス(.jarファイル)を Application Runtime 起動時のクラスパスに追加します。
    intra-mart Administrator のJAVA起動オプション画面からjarファイル名（フルパスで）追加します。

  3. Application Runtime を起動します。

JavaScriptからの呼び出し

  1. Javaラッパークラスを生成します。
    objHellow = new Packages.パッケージ名.クラス名();

  2. 生成されたクラスから関数を呼び出します。
    Answer = objHellow.関数名(引数);

  3. これで、外部ライブラリ関数の呼び出しが可能になります。

「JavaScriptの例」
function init(request){
    var a;
    var b;
    var objHellow;

    objHellow = new Packages.Hellow.Hellow(); // クラスのロード

    a = "こんにちは " ;
    b = "イントラマートです"
    sAnswer = objHellow.margeString(a,b);

    // オブジェクト型で帰ってくるので、文字列にする必要があります。
    sAnswer = sAnswer + "";

    a = 10;
    b = 20;
    nAnswer = objHellow.getPlus(a ,b);

    a = true;
    b = false;
    bAnswer = objHellow.getAnd(a ,b);
}

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[call JAVA]]

i ntra-mart The Power for Enterprise Web Solution
JAVA クラスの利用

概要

アプリケーションプログラムでは、ファンクションコンテナにおいて、JAVA プログラムを呼び出して利用する事ができます。
JavaScript から呼び出す事のできる JAVA クラスは、JDK により提供されるクラスの一部と自作のクラスになります。

JAVA 呼び出しによる恩恵

JavaScript から JAVA のプログラムを呼び出せるということは、JAVA により提供される様々な技術を JavaScript から利用可能になるということでもあります。
これにより、単なる JAVA クラスの呼び出しだけにとどまらず、JavaBeans の利用や RMI, IIOP といった通信技術、さらには EJB などの利用も可能となります(この場合、それぞれの技術を提供している他のサーバ製品が別途必要になります)。

注意事項

JAVA のプログラムを呼び出す際に引き渡す引数には、以下の制限がつきます。

・ | 型 | String,Number および Boolean 型のみ、引数として利用可能です。オブジェクトを引数として指定することはできません。
・ | 数値 | JavaScript では、数値型は double として扱っているため、Number 型のデータを double 以外の型として引数指定した場合は、丸め込みなどの現象が起こる事があります。

JavaScript では、例外処理という概念が存在しないため、JavaScript から呼び出された JAVA プログラム内で発生した例外が JAVA プログラム内でキャッチされずにスローされた場合、JavaScript の実行は強制的に中断されます。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[JAVA[EJB Compornent]]]

i ntra-mart The Power for Enterprise Web Solution
EJB コンポーネントの呼び出し方

概要

intra-mart の動作している Java-VM に対して J2EE(Java Enterprise Edition)を追加インストールして適応する事により、他の EJB サーバと連携して、EJB サーバにある EJB コンポーネントを intra-mart のファンクションコンテナから呼び出す事ができるようになります。

準備

以下の手順に従って環境構築を行います。

1 | intra-mart を停止します。
2 | J2EE をインストールします。 J2EE をインストールするのは、Application Runtime の動作しているコンピュータです。 J2EE のインストールに関しては、J2EE のインストール・マニュアルにしたがって下さい。
3 | 環境変数およびクラスパスの追加設定をします。 環境設定に関しては、J2EE のインストールマニュアルを参照して下さい。 例）WindowsNT40 で標準インストールの場合 コンソールにおいて以下のコマンドを実行 SET J2EE_HOME=C:\j2sdkee1.2.1 SET PATH=%J2EE_HOME%\bin;%PATH% %J2EE_HOME%\bin\setenv.bat
4 | intra-mart の各サーバを起動します。

EJB コンポーネントの作成

EJB の規約に準拠してクラス作成をして下さい。
また、JavaScript と連携する部分に関しては、自作クラスの呼び出しに準拠するようにして下さい。

作成した EJB コンポーネントの EJB サーバへの登録およびネーミング設定に関しては、各 EJB サーバ製品のマニュアルを参照して下さい。

JavaScript からの呼び出し

クラスパスを適切に設定して Application Runtime を起動します。

ファンクションコンテナ内で以下のようにして、目的の EJB コンポーネントを呼び出します。

例）XXX という EJB コンポーネントを呼び出す場合

var initial = new Packages.javax.naming.InitialContext();
var objref = initial.lookup("XXX");
var home = Packages.javax.rmi.PortableRemoteObject.narrow(objref, java.lang.Class.forName("XXXHome"));
var interfaceXXX = home.create();
呼び出された EJB コンポーネントは、JavaScript の変数 interfaceXXX に格納されているので、あとは JAVA 呼び出しの要領で EJB コンポーネントの持つ各ＡＰＩを実行できます。

サンプル

SUN の J2EE に同梱されている Converter という EJB コンポーネントを呼び出すための手順を示します。

1 intra-mart を停止します。
2 SUN J2EE のドキュメントにしたがって、J2EE に同梱されているサンプル Converter を設定します。
file://c:/j2sdkee1.2.1/doc/guides/ejb/html/Started.fm.html(J2EE1.2.1 を標準インストールした場合)

各ソースファイルのコンパイルおよび設定が完了したら、ドキュメントにしたがって実行して、正常に動作することを確認して下さい。

3 Converter クラスパスの追加設定をします。
[install_directory]/conf/imart.xml の <java><server><command><option> タグに c:\j2sdkee1.2.1\doc\guides\ejb\examples\converter/\ConverterAppClient.jar(Windows の場合) を追加記述します(intra-mart Administrator を利用する事で簡単に設定ができます)。
4 intra-mart の各サーバを起動します。
5 以下のサンプルコードで Converter を呼び出す事が出来ます。
EJB コンポーネントである Converter の実行に成功すると、コンソールに結果が表示されます。
var initial = new Packages.javax.naming.InitialContext();
var objref = initial.lookup("MyConverter");
var home = Packages.javax.rmi.PortableRemoteObject.narrow(objref, java.lang.Class.forName("ConverterHome"));
var interfaceConverter = home.create();
Debug.print(interfaceConverter.dollarToYen(100.00));
Debug.print(interfaceConverter.yenToEuro(100.00));

注意事項

intra-mart から呼び出す EJB コンポーネントは、intra-mart の動作している Java-VM のバージョンに合わせて作成されたものに限ります。

JAVA および JavaScript で扱う変数型に関する注意事項に関しては、JAVA 標準クラスを呼び出した場合と同様です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


JAVA メニュー

JAVA クラスの利用
標準クラスの呼び出し
自作クラスの呼び出し
EJB コンポーネントの呼び出し


intra-mart[Server side JavaScript intra-mart Documentation.[JAVA[Original class]]]

i ntra-mart The Power for Enterprise Web Solution
自作クラスの呼び出し方

概要

独自に作成した JAVA プログラム(クラス)を呼び出します。

準備

Application Runtime が正しく起動されている事を確認して下さい。
また、バッチプログラムにおいて JAVA を利用する場合には、intra-mart Batch Server が正しく起動していることを確認して下さい。

JAVA クラスの作成

通常の JAVA プログラムを作成する要領でクラスを作成します。

コンストラクタまたはメソッドが引数を必要とする場合、JavaScript から直接受け取る事のできる変数型は String, byte, int, long, short, float, double, および boolean のみとなります。
また、メソッドが返却値を持つ場合で、その返却値を JavaScript でそのまま利用する場合は、String, byte, int, long, short, float, double, boolean のみを利用するようにしてください(JavaScript 側に NaN という数値データを返却する場合 Double.NaN を返却してください)。

独自のクラスを定義してこれを JavaScript から呼び出す場合、呼び出されるクラスでは、必ずパッケージ宣言をしておかなければいけません。

例）指数を司るインスタンスを生成して、メソッド(pow)の引数に指定した様々な数値の累乗を求めるクラス

package myclass;

public class Exponent{
private double exp;

public Exponent(int exp){
this.exp = (double) exp;
}

public double pow(double base){
return java.lang.Math.pow(base, exp);
}
}

環境設定

作成した JAVA プログラム(*.java)を JAVA コンパイラでコンパイルして、生成されたクラスファイル(*.class)をパッケージ宣言どおりのディレクトリ構造をもった場所に保存します(この状態で jar ファイルにする事も可能)。

クラスファイル(または jar ファイル)は、アプリケーションプログラム内で利用する場合には Application Runtime を動作するコンピュータに保存します。また、バッチプログラムで利用する場合には intra-mart Batch Server を動作するコンピュータに保存します。

Application Runtimeのクラスパスに作成したクラスのパスを追加指定します。(intra-mart Administrator で設定する事もできます。なお、クラスパスはクラスの依存関係や目的に応じて、適切に設定してください。

例）クラス myclass.Exponent の場合
コンパイルごのファイル myclass/Exponent.class(ディレクトリ myclass 内に Exponent.class というファイルが存在する状態)を インストールディレクトリ/lib/ に保存します。

root/
└ lib/
└ myclass/
└ Exponent.class
※）root/ は、ページプログラムでクラスを利用する場合は『ApplicationServer インストールディレクトリ』で、バッチプログラムで利用する場合は『BatchServer インストールディレクトリ』となります。

JavaScript からの呼び出し

独自クラスの場合、Packages キーワードにより呼び出しを行います。呼び出し構文は、Packages.パッケージ名.クラス名 となります。

クラスメソッドを利用する場合は、Packages.パッケージ名.クラス名.メソッド名() と記述して呼び出します。
また、コンストラクタを呼び出す場合には、new 演算子を用いて new Packages.パッケージ名.クラス名 と記述して呼び出します。

例）自作の指数クラスを呼び出して 2 の 8 乗を計算し、デバッグ画面に表示します。

var oct = new Packages.myclass.Exponent(8);
Debug.browse(oct.pow(2) - 0);

注意事項

intra-mart から呼び出すクラスは、intra-mart の動作している Java-VM のバージョンに合わせて作成されたものに限ります。

JAVA および JavaScript で扱う変数型に関する注意事項に関しては、JAVA 標準クラスを呼び出した場合と同様です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[JAVA[Standard class]]]

i ntra-mart The Power for Enterprise Web Solution
標準クラスの呼び出し方

概要

JDK により標準で提供されているクラスを呼び出します。
JavaScript から呼び出し可能な JAVA のパッケージは以下の通りです(それ以外のパッケージを利用する場合は、JAVA のクラスを自作して利用するようにしてください)。

java.lang
java.io
java.text
java.util

準備

Application Runtime が正しく起動されている事を確認して下さい。
また、バッチプログラムにおいて JAVA を利用する場合には、intra-mart Batch Server が正しく起動していることを確認して下さい。

プログラムからの呼び出し方

ファンクションコンテナの JavaScript プログラム内において、通常の JAVA のプログラミングの要領で目的のクラスを呼び出して利用して下さい。

インスタンスを生成する必要のあるクラスについては、new 演算子を用いる事でコンストラクタを呼び出す事ができます。また、生成したインスタンスを JavaScript で宣言した変数に格納して利用する事もできます。

プログラミング例

乱数を発生させるクラスを利用して１０回乱数を発生させてコンソール画面上に表示します(サービス化またはデーモン化している場合は、画面の表示されません)。

var ransuu = new java.util.Random();
var cnt = 0;
for(chr = 0; cnt < 10; cnt++){
Debug.print(ransuu.next());
}

注意事項

JavaScript の変数に対して JAVA データを格納した場合、その変数は JavaScript の通常の変数とは異なる扱いとなります。JAVA 変数を通常の JavaScript の変数と同様に扱うためには、変数の変換をする必要があります。JAVA → JavaScript の変換には、以下の方法があります。

String | 文字列連結ロジックを通す事で変換できます。 例）jsString = javaString + "";
Number | 算術演算ロジックを通す事で変換できます。 例）jsNumber = javaNumber - 0;
Boolean | 関係演算ロジックを通す事で変換できます。 例）jsBoolean = javaBoolean == true;

JAVA のＡＰＩを呼び出した結果の返却値を JavaScript の変数に受け取った場合、この値も JAVA として扱われますので、JAVA を利用した結果の値を JavaScript で利用する場合には、変数の型の変換をする必要があります。

JavaScript では import 句を利用する事ができません。JAVA のクラスを呼び出す場合は、必ずパッケージ名を省略せずに完全な形で目的のクラスを指定するようにして下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Presentation Page[extra-IMART tag]]]

i ntra-mart The Power for Enterprise Web Solution
拡張 <IMART> タグ

概要

拡張 <IMART> タグとは、標準で用意されている機能の他に独自の機能をサーバ側で処理されるタグ(<IMART>)としてロジックを登録できる機能です。

タグ関数の作成

実際に実行されるロジックは、FunctionContainer の関数として作成します。

タグ関数
function tagFunction(attr, inner){
return (String) + inner.execute();
}

タグ関数では、実行時に実行エンジンから attr と inner という２つの引数を受け取ります。引数 attr は <IMART> タグのタグ属性として与えられた属性値を持っています。attr はオブジェクト型で、属性名のプロパティを持ち、その値は属性値に等しくなります。

属性値 = attr.属性名

引数 inner の execute() メソッド(Function Container API InnerText を参照)を実行する事により、<IMART> タグおよび </IMART> に挟まれた範囲のスクリプトを実行する事が出来ます。これにより、<IMART> タグのネストされた範囲を画面に表示する事が出来ます(ネストされたタグの実現)。

タグ関数は、必ず文字列を返却値として返す必要があります。タグ関数から返された文字列は、そのタグが定義されていた位置に挿入(画面に表示)されます。

タグ関数の登録

タグとして動作させるロジックを記述した関数を実行エンジンに登録する事により、Presentation Page で拡張 <IMART> タグとして利用できるようになります。
拡張 <IMART> タグは、標準機能として提供されている他の <IMART> タグと同様にして利用できます（記述方法も全く同じです）。

タグ関数を登録するには、Function Container API Imart.defineType() を使います。このＡＰＩにより登録された関数は、Application Server が停止するまで有効に働きます(つまり、タグ関数の登録は１度だけで十分です)。
タグ関数登録時に指定した参照名が、そのままタグの type 名称となります。Presentation Page をプログラムする際、この type 名称は大文字・小文字を厳密に判定しますので、登録時には使いやすい名前になるように十分配慮するようにして下さい。

例

メッセージをキャプションとして表示する拡張タグ

ファンクション・コンテナ
Imart.defineType("caption", viewCaption);

function viewCaption(attr, inner){
if(attr.size == "1"){
return "<H1>" + inner.execute() + "</H1>";
}
else if(attr.size == "2"){
return "<H2>" + inner.execute() + "</H2>";
}
else{
return "<H3>" + inner.execute() + "</H3>";
}
}
プレゼンテーション・ページ
・
・
・
<IMART type="caption" size="1">セクション１</IMART>
<IMART type="caption" size="2">セクション２</IMART>
<IMART type="caption">セクション３</IMART>
・
・
・
実行結果
・
・
・
<H1>セクション１</H1>
<H2>セクション２</H2>
<H3>セクション３</H3>
・
・
・

注意事項

拡張タグのロジックを定義している関数内でページ遷移などのＡＰＩを呼び出さないで下さい。

拡張タグ関数内で利用できないＡＰＩ
  • forward()
  • redirect()
  • transmission()
  • Debug.browse()
  • Module.alert.*
  • Module.download.*
  • Module.mobile.alert()

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Application Common Master Table]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart アプリケーション共通マスタ API 仕様

アプリケーション共通マスタ表は、intra-mart 上で動作するすべてのアプリケーション・プログラムから共通に利用するためのデータベース・アーキテクチャです。
データの参照に関しては、各プログラムから自由に行っても構いませんが、規定の方法以外でのデータ更新を行った場合、他のアプリケーションが正常に動作しなくなることがあります。

詳細はアプリケーション共通マスタ説明資料（PDF）を参照して下さい。

  • ユーザの登録・更新・削除

    • ユーザ（ログインアカウント、ユーザプロファイル）の登録・更新・削除は、 グループ管理者でログインし、メニューの[ログイングループ管理]-[アカウント設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、
    ログインアカウントは    Server Managerルート/specification/dtd/account_5_0.dtd を参照して下さい。
    ユーザプロファイルはServer Managerルート/specification/dtd/profile-data_5_0.dtd を参照して下さい。

    プログラムインターフェースとしては、ログインアカウントに対してはAccountMangerオブジェクトを使用して下さい。

    ユーザプロファイルに対しては、UserManagerオブジェクトを使用して下さい。

  • 会社・組織の登録・更新・削除

    • 会社・組織の登録・更新・削除は、グループ管理者でログインし メニューの[アプリケーション共通マスタ管理用フォルダ]-[組織設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、Server Managerルート/specification/dtd/company-data_5_0.dtd およびcompany-post-data_5_0.dtdを参照して下さい。

    プログラムインターフェースとしては、CompanyManagerオブジェクトを使用して下さい。

  • パブリックグループの登録・更新・削除

    • パブリックグループの登録・更新・削除は、グループ管理者でログインし メニューの[アプリケーション共通マスタ管理用フォルダ]-[パブリックグループ設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、Server Managerルート/specification/dtd/public-group-data_5_0.dtd を参照して下さい。

    プログラムインターフェースとしては、PublicGroupManagerオブジェクトを使用して下さい。

  • プライベートグループの登録・更新・削除

    • プライベートグループの登録・更新・削除は、編集対象のユーザでログインし メニューの[ユーザ設定]-[プライベートグループ設定] から行って下さい。

    プログラムインターフェースとしては、PrivateGroupManagerオブジェクトを使用して下さい。

  • ユーザ検索画面

    • ユーザ検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_user.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

  • 会社・組織検索画面

    • 会社・組織検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_company.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

  • パブリックグループ検索画面

    • パブリックグループ検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_public_group.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

  • プライベートグループ検索画面

    • プライベートグループ検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_private_group.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

  • ロール検索画面

    • ロール検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_role.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Manner for Page-Base Programing Model]]

i ntra-mart The Power for Enterprise Web Solution
コーディングルール
(ページベース開発モデル)

注意事項

このページで記載されている内容は、 i ntra-mart アプリケーション(フレームワークの各画面も含む)をカスタマイズする際の必要事項になりますので、十分に理解した上で、i ntra-mart アプリケーションの開発を行うようにしてください。

J2EE開発モデルに関しては、JAVA、JSP および Servlet 等、関連技術のルールに従ってください。

ルール

1.

i ntra-mart アプリケーション開発において、すべてのプログラム(プレゼンテーション・ページおよびファンクション・コンテナ)内で、JavaScript および i ntra-mart で規定されている予約語をプログラム変数や関数の名称として定義しないでください。

i ntra-mart フレームワークで提供されているＡＰＩの中には、ブラウザ上で動作するものも含まれていますので、ブラウザ上で動作をする Client Side JavaScript 内においても規定されている予約語を使用しないようにしてください。

2.

<IMART> タグは、必ず </IMART> と１対１の関係になるように記述しなければなりません（ </IMART> を未記述時の動作は未定義）。

3.

ファンクション・コンテナ内で、文字列定数値を定義する場合は、必ず " (ダブルクォーテーション)で囲まなければいけません。
(' (シングルクォーテーション)で文字列定数宣言をした場合の動作は保証されません。)

4.

ファンクション・コンテナ内でのスクリプトの記述において、";" (セミコロン)により明示的にステートメント末を宣言しなければいけません。
(JavaScrip の文法においては、改行コードでもステートメント末として認められていますが、この場合、思わぬ誤動作の原因になることがあります。)

5.

ファンクション・コンテナ内で変数を使用する場合には、必ず var キーワードを用いて明示的な変数宣言をしなければいけません。
(JavaScrip の文法においては、未宣言変数の使用も認められていますが、この場合、思わぬ誤動作の原因になることがあります。)

6.

ファンクション・コンテナ内に initという名称の関数を宣言してある場合、そのファンクション・コンテナがロードされた際に、ファンクション・コンテナ内に定義されている init() 関数が i ntra-mart ランタイム・エンジンにより必ず最初に自動実行されます。
(この動作仕様は、すべてのファンクション・コンテナに対して適応されます。)

7.

プログラム(プレゼンテーション・ページおよびファンクション・コンテナ)ファイル名と、プログラムファイルを格納しておくディレクトリに関して、日本語名称を与えてはいけません。

プログラム(プレゼンテーション・ページおよびファンクション・コンテナ)ファイル名と、プログラムファイルを格納しておくディレクトリに関して、以下に示す文字を含む名称を与えてはいけません。

\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab) (全角文字)

(添付ファイル等、データとして扱うファイル名は除く)

8.

i ntra-mart フレームワークで提供している機能において、すべてのＩＤに関して、以下に示す文字を含む名称を与えてはいけません。

\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab) (全角文字)
9.

ファンクション・コンテナ内で [install_directory]/conf/imart.xml を読み込んだり書き込んだりしてはいけません。

設定ファイルをむやみに変更することは、思わぬ誤動作の原因となります。

なお、[install_directory]/conf/imart.xml ファイル内の設定内容を変更した場合には、i ntra-mart システム全体の再起動が必要です。
ただし、i ntra-mart Administrator(サーバ管理ツール)上で設定内容を変更した場合には、i ntra-mart Administrator(サーバ管理ツール)から該当のサーバを再起動するだけで新しい設定内容が反映されます。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Function Container]]]

i ntra-mart The Power for Enterprise Web Solution
Function Containerについて

種類

ファンクションコンテナは、サーバで実行される JavaScript で記述された intra-mart のビジネスロジック・プログラム・ファイルです(Client Side JavaScript は、これに含まれません)。

ファンクションコンテナは、用途により４種に大別されます。

  • 初期起動用
  • Web ページ連携用
  • バッチプログラム用
  • 特殊プログラム
※） 共通関数登録用および独立型関数定義用などは、その性質の類似から『初期起動用』と同義と扱います。

初期起動用

初期起動用ファンクションコンテナは、サーバによりプログラムファイルがロードされると、ファイル内に記述された init() 関数が実行されます。
共通関数登録などの初期化処理は、init() 関数内に記述するようにしてください。

サーバの初期起動時には、ソースのルートディレクトリ（標準では、pages/src または pages/platform/src）にあるinit.js 内に定義された init() 関数が実行されます。

実行シーケンス
  1. init.js のロード
  2. init.js 内の init() 関数の実行

プレゼンテーションページ連携用

プレゼンテーションページと連動するファンクションコンテナは、サーバにより実行される時に、引数を伴って呼び出されます。

HTTP リクエストにより実行された場合、ＵＲＬ引数を持つ request オブジェクトを引数として init() 関数が実行されます。
また、リンクやフォームの action 属性により任意の関数実行が指定されている場合、ＵＲＬ引数を持つ request オブジェクトを引数として指定の関数が実行されます。

HTTP リクエスト以外の方法(ＡＰＩ forward() 等)により実行された場合、ファンクションコンテナ内の init() 関数は、その方法によって定義された引数を伴って実行されます(詳細に関しては、各々のＡＰＩ仕様を参照してください)。

プレゼンテーションページの実行が完了したあと、ファンクションコンテナ内に close() 関数が定義されていた場合、ＵＲＬ引数を持つ request オブジェクトを引数として close() 関数が実行されます。

実行シーケンス
  1. action 属性指定関数の実行
  2. init() 関数の実行
  3. プレゼンテーションページの実行
  4. close() 関数の実行

action 属性関数の実行指定がない場合は、action 属性関数の実行フェーズはスキップされます。
プレゼンテーションページ実行中は、プレゼンテーションページ側の要求に応じて、ファンクションコンテナ内の任意の関数が実行されることがあります。

バッチプログラム用

intra-mart Batch Server により、定められた時刻に実行されるファンクションコンテナが、これに該当します。

バッチ設定メンテナンスにより設定されている時刻になると、設定された任意のファンクションコンテナ内に定義された init() 関数が Application Runtime により実行されます。

特殊プログラム

session.js は、Application Runtime が HTTP リクエストを受け付けた時に実行されるプログラムです。

Application Runtime が HTTP リクエストを受け付けると、session.js 内に定義された init() 関数が実行されます。
また、Application Runtime がプレゼンテーションページの作成を完了した後、HTTP レスポンスを返す前に close() 関数が実行されます。

session.js ファイルを変更した場合は、Application Runtime を再起動するまでシステムには反映されません。

注意事項

ファンクションコンテナ内に定義された init() 関数および close() 関数は、特別な意味を持ちます。
これらの関数を正規の目的以外に定義をすると、思わぬ誤動作の原因となります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Web Page]]]

i ntra-mart The Power for Enterprise Web Solution
Presentation Pageについて
前提

ここでは、ブラウザを使い intra-mart に対してアクセスした場合の、ランタイム・エンジンの動作仕様を説明します。

intra-mart に対して Web アクセスするためには、Schedule Service を除くすべてのサービス および intra-mart Web-Server Connector をインストールして正しく動作していることが必要になります。

動作に必要なプログラム(初期起動)

Application Runtime の初期起動時には、指定のファンクションコンテナを実行します。

初期起動時に実行したいプログラムを記述したファンクションコンテナを適切なディレクトリに保存して、適切に呼び出されるようにしてください。
初期起動時にアプリケーション(共通関数など)の初期化や初期設定などを実行すると有効です。

注意）初期化プログラム内では、データベースアクセスができません。初期起動時にデータベースアクセスをする必要のあるプログラムは、データベースアクセス前に、必ずデータベース接続ＡＰＩを実行し、データベースアクセスＡＰＩに対して、接続参照名を明示的に指定するようにして下さい。

動作に必要なプログラム(Web ページ)

ブラウザから HTTP リクエストにより ページベース開発モデルのプログラムが実行される場合、ページを作成するために必要なプレゼンテーションページおよびファンクションコンテナを実行します。

ページプログラムは、プレゼンテーションページ(HTML)とファンクションコンテナ(JS)の２ファイルで１対となります。

２つのファイルは、ファイルラベル名で関連付けられます。それぞれのファイル(HTML および JS)は、必ず同じファイルラベル名で作成してください。
拡張子は、プレゼンテーションページの場合は .html で、ファンクションコンテナの場合は .js となります。(どちらの拡張子も小文字のみとなります。大文字で記述した場合、正しく動作しなくなります。)

ファンクションコンテナが必要ない場合には、ファンクションコンテナファイルの省略（プレゼンテーションページファイルのみ）は可能ですが、プレゼンテーションページファイルの省略はできません。

ブラウザから直接リンクをする場合は、該当のファイルを Web-Server Connector をインストールしたディレクトリ内に保存して下さい。
(画像ファイルなども、これに該当します。)

実行シーケンス

ブラウザからリクエストがあった場合、以下のように処理が流れます。

  1. ブラウザからのリクエスト受付
  2. session.js 内 init() 関数実行
  3. action 属性関数の実行
  4. page 属性ファンクションコンテナ内 init() 関数の実行
  5. page 属性プレゼンテーションページの実行
  6. session.js 内 close() 関数実行
  7. ページ返却

ブラウザからリクエストを受け付けた場合、必ず session.js 内の init() および close() 関数が実行されます。
この session.js の実行は、ページ処理においてエラーが発生した場合においても、必ず実行されます。

action 属性関数とは、intra-mart 連携用のリンク(<IMART type="link">)またはフォーム(<IMART type="form">)またはサブミット(<IMART type="submit">)からのリクエストであり、action 属性関数の実行指定がされていた場合にのみ処理されます(action 属性関数の実行指定がなかった場合には、この処理フェーズはスキップされます)。
action 属性関数には引数として、ＵＲＬ引数情報を持つオブジェクト(request)が渡されます。引数 request の詳細に関しては、J2EEベース開発モデル アプリケーション共通モジュール を参照して下さい。
action 属性関数指定が複数同時に行われていた場合、以下の順位付けにしたがって実行対象となる関数を決定します。

<IMART> タグの種類と優先順位
link < form < submit

page 属性とは、intra-mart 連携用のリンク(<IMART type="link">)またはフォーム(<IMART type="form">)またはサブミット(<IMART type="submit">)からのリクエストであり、page 属性関数の実行指定がされていた場合にのみ処理されます。
page 属性指定がない場合は、リクエストをしてきたページを再実行します。
また、page 属性指定がない場合でブラウザからの初アクセスの場合は、Resource Service のインストールディレクトリ/pages/ 直下のページ main (main.html および main.js)が実行されます。

page 属性ファンクションコンテナ内 init() 関数には引数として、ＵＲＬ引数情報を持つオブジェクト(request)が渡されます。引数 request の詳細に関しては、J2EEベース開発モデル アプリケーション共通モジュール を参照して下さい。

プレゼンテーションページでは、<IMART> タグ部分が実行されます。
プレゼンテーションページ内のＡＰＩについては、J2EEベース開発モデル 画面共通モジュール を参照して下さい。

各スクリプトの実行フェーズにおいて、何らかの要因でエラーが発生した場合、即座にスクリプト実行を中止して、ブラウザに対してはエラー画面を送信します。
エラーが発生した場合は、エラーの発生した実行フェーズおよび『session.js 内 close() 関数実行』および『ページ返却』を除く残りの実行フェーズはスキップされます。

session.js 内 close() 関数実行フェーズは、ページ処理に関する終了処理を行うことを目的とします。
session.js 内 close() 関数実行フェーズにおいて、Debug.browse() や forward() などのスクリプト実行を強制的に中断して処理を遷移させるＡＰＩを実行した場合、正しく処理されない場合があります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal[light]]]

i ntra-mart The Power for Enterprise Web Solution
ポータルモジュール

概要

会社・組織単位あるいはユーザ単位にフレームワークのログイン後初期画面に今日の予定やお知らせなど、自由にページを配置できるようになります。

あらかじめ作成、登録しておいたポータル表示用画面を、会社・組織単位あるいはユーザ単位に組み合わせ、初期表示画面を作成できます。
詳細はフレームワークのマニュアルをご覧ください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal[light]]]

i ntra-mart The Power for Enterprise Web Solution
ポータルモジュール
注意事項
・ポータル表示用画面登録時メニューの[システム設定]-[ポータル]-[ポートレット登録]画面において、 プログラムのパスが不正なものを一つでも設定されている場合、ポータル表示画面（ログイン後初期画面）で サーブレットエラーになってしまいます。パスの登録は慎重に行ってください。

・各ポータル表示用画面のプレゼンテーションページ内の ClientJavascriptの関数名、変数名、FORMのコントール名に、”IM_”、”_(アンダースコア)” から始まる名前を使うことはできません。システム及び、イントラマートの提供するアプリケーションが 使用します。 また、これらのClientJavaScriptの関数名、変数名、FORMのコントロール名は各ポートレットでバッ ティングしないように、「(アプリケーションに割り当てられるプレフィックス)_」をつけるなどして ください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal[light]]]

i ntra-mart The Power for Enterprise Web Solution
ポータルモジュール

画面開発

ポータル表示用画面は通常のintra-martの画面開発と変わりませんが、以下の点に 注意する必要があります。

・一つの組織に複数のポータル表示用画面を設定した場合、各ページを一つの HTMLファイルにマージして出力するため、プレゼンテーションページ内に<HTML>タグ、 <BODY>タグは記述できません。また、同様の理由により各ポータル表示用画面 プレゼンテーションページ内のClientJavascript、FORMのコントール名等がバッティング しないように注意する必要があります。「(アプリケーションに割り当てられるプレフィックス)_」 をつけるなど、バッティングしないように注意してください。
ClientJavascriptの関数名、変数名、FORMのコントール名に、”IM_”、”_(アンダースコア)” から始まる名前を使うことはできません。
システム及び、イントラマートの提供するアプリケーションが使用します。

・処理に時間のかかるページを複数設定しますと、その分だけログイン時間がかかってしまい ます。できるだけシンプルな画面を作成することをお勧めします。

ページベースの画面

・ページベースの画面では、おおむね通常の画面開発と変わりませんが、以下のような機能を 実現しようとした場合、いくつか制約があります。

ページベースで作成されたポートレット部からサブミット処理を行い、処理終了後に再びポータル画面を表示する場合

ポータル画面のＵＲＬを設定し、ＵＲＬリダイレクトを行なってください。
requestオブジェクトに下記のパラメータが設定されている場合は、クエリー文字列としてＵＲＬに含めてください。

portal_cd ポートレットが配置されているタブコード
actionId ポータル表示切替のアクションＩＤ

ポータル画面に戻りたいときは、Module.alert.*の関数を使用しないで下さい。

・プレゼンテーションページ
<IMART type="form" action="insertData">
<IMART type="hidden" portalCd=portalCd></IMART>
<IMART type="hidden" actionId=actionId></IMART>
<INPUT type="text" name="param">
<INPUT type="submit" value="submit">
</IMART type="form">

・ファンクションコンテナ

    var portalCd;
    var actionId;

    function init(request){
        portalCd = request.portal_cd;
        actionId = request.actionId;
    }

    function insertData(request){
        // 登録処理
        ････････

        // ポータル画面のＵＲＬを取得
        var strPortalUrl = getURL(request);

        // パラメータのセット
        var strPortalUrl += "&param=" + request.param;

        // ポータル画面へリダイレクト
        redirect(strPortalUrl);
    }

    function getURL(request){
        // ＵＲＬの生成
        var url = "portal-portal_display.service";

        // ポータルコードが設定されている場合はURLに設定
        if (!isUndefined(request.portal_cd) && request.portal_cd != '') {
            url += "?portal_cd=" + request.portalCd
                + "&actionId=" + request.actionId;
        }
        return url;
    }

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal Module]]

i ntra-mart The Power for Enterprise Web Solution
企業ポータルソリューション
ポータルモジュール

概要

ポータルモジュールとは、intra-mart を利用したポータルサイトを実現するための機能およびＡＰＩ群のことです。
目的や規模に合わせて２つの構築方法を選択することができます。

im-ポータル

intra-mart intra-mart が標準で装備している機能です。

組織単位あるいはユーザ単位でのポータル画面の設計、および運用が可能になります。
個人認証は、intra-mart が標準で装備しているアクセスセキュリティ機能を利用していて、ログイン後の初期表示画面をポータル化することのできる機能です。

完全な個人ごとのポータルサイト

市販の他のポータルサーバ製品と連携することにより、そのポータル製品の提供する様々な機能を利用したポータルサイトを構築することができます。

市販のポータルサーバ製品と連携するためのＡＰＩ群(APIは、Java クラスとして提供されています。ご利用のポータルサーバ製品が、Javaベースでポータル画面を開発可能かどうか、あらかじめご確認ください。)は、intra-mart intra-mart に標準で搭載されています。これら連携用ＡＰＩを利用して市販のポータルサーバのポータル画面で表示する画面を作成することにより、自由度の高いポータル機能を利用することができます。

連携方法等に関しては、外部アプリケーション連携モジュール を参照してください。また、API 仕様に関しては『J2EEベース開発モデル』の アプリケーション共通モジュール を参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


ポータル メニュー

ポータルモジュール
概要
・im-ポータル
仕様
開発ガイド
注意事項


intra-mart[Server side JavaScript intra-mart Documentation.[About]]

The Power for Enterprise Web Solution

API リスト仕様
 西暦 2008 年 8月 29日現在

注意事項

このＡＰＩリストでは、intra-mart Version 5.0.x におけるモジュール構成、およびプログラム・インターフェースであるＡＰＩ仕様について解説しています。

このＡＰＩリストに記載されている内容は、株式会社ＮＴＴデータイントラマートで定めた intra-mart Version 5.0.x における公式なＡＰＩ仕様になります。

このＡＰＩリスト内に記載されていない内容に関しては保証致しかねますので、予めご了承ください。

推奨されないＡＰＩ

「推奨されません」または「非推奨」、およびこれに類する表現をしているＡＰＩは、他のＡＰＩと比べて以下の条件も併せ持ちます。

  • メーカーの通常サポートの範囲に含まれます。
  • 過去のバージョン（またはリビジョン）のインタフェースを互換するために用意されたものです。
  • 通常は、他に推奨される新しいＡＰＩが提供されています。
  • 他に提供されている推奨される新しいＡＰＩと比較して、パフォーマンス等の性能が劣る場合があります。
  • 将来のバージョン（またはリビジョン）において、削除される可能性があります。

構成

左フレームには全体のメニューが表示されています。

メニューは、このＡＰＩリストを含めた、プロダクト全体の仕様に関して解説している 『 Document 』 と、各ＡＰＩについてプログラム・インターフェースの詳細について解説している 『 Developer's Guide 』 に大きく分類されています。

閲覧方法

左フレームにある各メニューのハイパーリンクをクリックする事で、その内容について詳細に解説されているページへ移動する事ができます。
ページ遷移や情報のビューイングに関しては、通常のウェブブラウジングの方法と同様です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Setup]]

i ntra-mart The Power for Enterprise Web Solution
データのインポート／エクスポート

ResourceService上のセキュリティに関するデータを指定の フォーマット形式のファイルからインポート／エクスポートすることができます。
この操作はシステム設定画面、及びプログラム・インターフェースから行うことができます。
画面から行う方法については、マニュアルを参照して下さい。
プログラム・インターフェースの詳細に関しては、アプリケーション共通モジュール(アクセスセキュリティの各Managerオブジェクト)をご参照下さい。

各インポート・エクスポートデータのフォーマットは、こちらを参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[keyword]]

i ntra-mart The Power for Enterprise Web Solution
予約語

注意事項

ここで記載している予約語は、JavaScript で定義されているもの、および JAVA で定義されているものの他に、i ntra-mart で定義しているものを含みます。

定義されている予約語は、プレゼンテーション・ページ、ファンクション・コンテナのどちらのプログラム内においても守る必要があります。
(ブラウザ上で動作をする Client Side JavaScript のプログラム内においても適用されます。)

予約語適応例

  • JavaScript 変数名
  • JavaScript 関数名
  • JavaScript 共通関数定義名(Procedure)
  • ＵＲＬ引数のキー名称
  • ＨＴＭＬフォームのコントロール名称
  • ＨＴＭＬフォーム名(name 属性)
  • ＨＴＭＬスタイルシート名
  • ＨＴＭＬレイヤー名
  • JAVA パッケージ名
  • intra-mart インストールディレクトリ直下のファイル名称
  • intra-mart インストールディレクトリ/doc/ 直下のファイル名称
  • intra-mart インストールディレクトリ/pages/ 直下のファイル名称
  • intra-mart インストールディレクトリ直下のディレクトリ名称
  • intra-mart インストールディレクトリ/doc/ 直下のディレクトリ名称
  • intra-mart インストールディレクトリ/pages/ 直下のディレクトリ名称
  • データベース表名

これらの名前付けにおいて予約語に違反した命名をした場合、intra-mart の動作が不安定になったり、intra-mart の Version up 時においてスムーズな移行ができない場合があります。

予約語 [ JavaScript ]

abstract boolean break byte case catch char class const continue default do double else extends false final finally float for function goto if implements import in instanceof int interface long native new null package private protected public return short static super switch synchronized this throw throws transient true try typeof var void while with

その他 [ グローバル変数（Client.set()メソッドのキーとして使用している文字列） ]

bx3m52nmcgl00(Identifier.get()で取得した値) USER atr_cfg_mode atr_cfg_gId channel_cfg_mode channel_cfg_gId srh_cfg_gId srh_cfg_notDisplay srh_cfg_style dbs_cfg_mode dbs_cfg_gId grp_conf_userdata usr_cfg_gId lnk_cfg_mode lnk_cfg_gId msg_cfg_mode msg_cfg_gId pag_cfg_gId pag_ndp020 rle_cfg_mode rle_cfg_gId usr_cfg_mode usr_cfg_dbm usr_cfg_gId zon_cfg_mode zon_cfg_gId SYSTEM.MENU.ACTIVE.ID ALERT wkf_sortInf wkf_strDateFrom wkf_strDateTo wkf_request_bk mmt_ndp131 mmtData

その他 [ 共通関数（Procedure.define()メソッドのキーとして使用している文字列） ]

age criteriondate date upload sql RealNumber workflow wkf_isRoute wkf_isItemOnRoute wkf_insertRoute wkf_updateRoute wkf_deleteRoute wkf_getUserNote wkf_getCntAnalyze wkf_getAckDayTermAvg wkf_toNullString wkf_getFullUserName wkf_ackkind_func

予約語 [ JAVA ]

abstract boolean break byte case catch char class const continue default do double else extends final finally float for goto if implements import instanceof int interface long native new null package private protected public return short static super switch synchronized this throw throws transient try void volatile while
JAVA の予約語の大部分は、JavaScript の予約語に含まれています。

その他 [ グローバル変数（jp.co.intra_mart.foundation.service.client.informationパッケージ中の Identifierクラス以外のset()メソッド、entry()メソッドのキーとして使用している文字列） ]

bx3m52nmcgl00(Identifier.get()で取得した値) USER atr_cfg_mode atr_cfg_gId channel_cfg_mode channel_cfg_gId srh_cfg_gId srh_cfg_notDisplay srh_cfg_style dbs_cfg_mode dbs_cfg_gId grp_conf_userdata usr_cfg_gId lnk_cfg_mode lnk_cfg_gId msg_cfg_mode msg_cfg_gId pag_cfg_gId pag_ndp020 rle_cfg_mode rle_cfg_gId usr_cfg_mode usr_cfg_dbm usr_cfg_gId zon_cfg_mode zon_cfg_gId SYSTEM.MENU.ACTIVE.ID ALERT wkf_sortInf wkf_strDateFrom wkf_strDateTo wkf_request_bk mmt_ndp131 mmtData

予約語 [ i ntra-mart ]

以下の文字、または文字列をプレフィックスとする語
_ im Im iM IM

また、ＡＰＩで提供されているクラスおよび関数では大文字を接頭辞として使用しています。

その他 [ StorageServiceルートに使用しているフォルダ名 ]

basemodule system

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Setup]]

i ntra-mart The Power for Enterprise Web Solution
セットアップ

サーバ・マネージャ

システム全体を統括的に管理するためのサーバです。
このサーバは、ライセンス管理も同時に行っています。ライセンス登録は、このサーバの動作しているコンピュータで行ってください。

また、IM-アドミニストレータが接続するサーバにもなりますので、IM-アドミニストレータをご利用の場合は、それぞれのコンピュータがネットワーク接続できるにしてください。

サービス・プラットフォーム

システム内の各機能は、サービスという単位で独立していて、それぞれのサービスが相互に連携をすることによりシステムを構成します。 これらのサービスを動作させるためのサーバプロセスが、このサービスプラットフォームです。

サービス

サービスプラットフォームで実行されて、定められた機能を提供するものです。
サービスには様々な種類があり、個々のサービスはそれぞれ固有の機能を持っています。サービスには、下記の種類があります（各々のサービスに関する詳細については、製品に付属のドキュメントを参照してください）。

  • Application Runtime
  • Resource Service
  • Storage Service
  • Shared Memory Service
  • Permanent Data Service
  • Schedule Service
  • Serialization Service

注意事項

intra-martの各サーバをインストールするコンピュータは全て、時計(コンピュータのシステム時計)を合わせて下さい。
コンピュータごとにシステム時間が大きく違っていると、アプリケーションが正しく動作しない場合があります。

詳細については、フレームワーク・インストールガイドをご参照下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Foundation tools.[JavaScript Compiler]]

i ntra-mart The Power for Enterprise Web Solution
JavaScript コンパイラ
  • 形式
  • 解説
  • オプション
  • 例
  • その他

形式

java -cp ./bin/intramart.jar jp.co.intra_mart.bin.js2class [ options ] [ sourcefiles ] [ sourcedirectories ]

( bin\tools\js2class [ options ] [ sourcefiles ] [ sourcedirectories ] )
options
コマンド行オプション
sourcefiles
コンパイルされる 1 つ以上のソースファイル (my_script.js など)
sourcedirectories
コンパイルされる 1 つ以上のソースファイルのあるディレクトリ

解説
jp.co.intra_mart.bin.js2class ツールは、intramart.jarアーカイブに含まれています。実行時には、intramart.jar からクラスがロードできるようにクラスパスを設定して下さい。(Service-Platform を Windows にインストールしている場合には、bin/tools/ ディレクトリに js2class.bat というバッチファイルがインストールされています。このバッチファイルを利用することでクラスパスの設定等をしなくてもコンパイラを実行することができます。)

jp.co.intra_mart.bin.js2class ツールは、JavaScript プログラミング言語で記述されたファンクションコンテナを読み取り、バイトコードクラスファイル(JAVA のクラスファイル)にコンパイルします(*.js ファイルから *.class ファイルが作られます)。

ソースコードのファイル名を jp.co.intra_mart.bin.js2class に渡すには、ファイル名をコマンド行で直接指定します。ソースコードが複数ある場合は、各ファイル名またはソースコードの親ディレクトリ名をスペースで区切って指定します。

ソースコードのファイル名は .js 拡張子、クラスのファイル名は .class 拡張子を持たなければなりません。また、クラスファイル名はソースファイル名を元にして自動的に生成されます。このクラスファイル名は任意に変更することはできません。

内部関数定義は、追加のクラスファイルを生成します。これらのクラスファイルの名前は、_my_script_js$MyInnerFunction.class のように、内部クラス名と外部クラス名を組み合わせたものになります。

オプション
-d sourcepath
ソースファイルを検索するソースコードパスを指定します。ソースファイルは、ソースコードパス sourcepath とソースファイル名の組合わせで検索します。

-d が指定されていない場合、jp.co.intra_mart.bin.js2class はカレントディレクトリからソースファイルを検索します。

-o directory
クラスファイルの出力先ディレクトリを設定します。クラスがパッケージの一部である場合、jp.co.intra_mart.bin.js2class は、必要に応じてディレクトリを作成し、パッケージ名を反映したサブディレクトリにクラスファイルを置きます。

-o が指定されていない場合、jp.co.intra_mart.bin.js2class はカレントディレクトリにクラスファイルを置きます。

-debug
デバッグ情報を生成します。行番号およびソースファイル情報などが生成されます。-debug オプションを指定することにより、実行時にエラーが発生した場合のデバッグが容易になります。

-opt level
実行時のコードを最適化します。最適化の程度は、0 から 9 までの整数値で指定することができます。数字が大きいほど最適化レベルは高くなりますが、その分コンパイル速度が低下し、デバッグの困難なプログラムが生成されることがあります。0 は最適化をせずにコンパイルします。-opt オプションを指定しなかった場合の標準値は 0 です。また -opt オプションは -debug と併用することはできません。

-charset charset
ソースファイルのエンコーディング名 (Shift_JIS/EUC-JP など) を指定します。-charset が指定されていない場合は、ご利用のシステムにおけるデフォルトの文字エンコーディングが使われます。 このオプションに指定できるエンコーディング名は、JAVA の仕様で定義されているエンコーディング名です。指定可能なエンコーディング名については、JAVA のドキュメントをご覧ください。

-h
ヘルプメッセージを出力します。他のオプション指定があっても、すべて無視されます。また -h オプションが指定された場合、コンパイルは行われません。

例(Windows の場合)

簡単なプログラムのコンパイル
サンプルソースファイル pages/src/sample/example/string/main.js をコンパイルする例を示します。（intra-martのインストール時にサンプルをインストールしてください。）クラスファイルは、標準でクラスパスとなっている doc/imart/WEB-INF/classes/ ディレクトリにコンパイルされるようにします。このため、この例ではスタンドアロン環境の場合に限り、コンパイルした後にクラスファイルを移動したり実行時のクラスパスを設定する必要はありません（ネットワーク環境の場合は、作成されたクラスファイル（_sample/_example/_string/_main_js.classなど） をApplication Runtimeの doc/imart/WEB-INF/classes/ ディレクトリにコピーする必要があります）。
C:> dir
imart\
C:> cd imart\pages\src
C:\imart\pages\src> ..\..\bin\tools\js2class -o C:\imart\doc\imart\WEB-INF\classes sample/example/string/main.js
上記の例では、C:\imart\doc\imart\WEB-INF\classes ディレクトリに _sample/_example/_string ディレクトリが作成され、その中にクラスファイルが保存されます。この状態(ネットワーク構成の場合には、_sample ディレクトリをApplication Runtimeの doc\imart\WEB-INF\classes ディレクトリにコピー)でサーバを再起動すると、pages/src/sample/example/string/main.js は読み込まれなくなり、替わりにクラスファイルがロードされます(以後、ソースコードの変更は自動では反映されません)。

複数のソースファイルのコンパイル
次の例は、ソースファイル init.js とディレクトリ sample 内のすべてのソースファイルをコンパイルします。
C:> dir
imart\
C:> cd imart\pages\src
C:\imart\pages\src> ..\..\bin\tools\js2class -o C:\imart\doc\imart\WEB-INF\classes init.js sample

その他
ソースファイルをコンパイルしておくことにより、システム全体のパフォーマンスを向上させることができます。ただし、ソースファイルを実行した場合とコンパイルされたクラスファイルを実行した場合では、システムにロードされる方式が異なるため実行時のスコープが変わってしまう場合があります。これにより実行時エラーが引き起こされる場合がありますので、ソースファイルをクラスファイル化した場合は、実行に問題がないことを必ず確認する必要があります。

コンパイルしたクラスファイルは、コンパイル時に指定した最適化レベルによりバイトコードの構造が異なります。特に最適化レベルが高い場合には、バイトコードが最適化されていることに起因して実行時エラーが発生する場合があります。その場合は、最適化レベルを低く設定するか、またはエラーとならないソースコードに書き換えて下さい。

コンパイルされたクラスファイルは、そのクラスファイル（ファンクションコンテナ）が実行されるサーバ（Application Runtime）環境においてクラスパスの設定されているディレクトリに保存して実行して下さい。クラスファイルは、ＪＡＶＡの通常のクラスローダーによりロードされてＶＭ上で実行されます。また、クラスファイルは一度実行されるとメモリ内にクラス情報がキャッシュされますので、クラスファイルを変更した場合はサーバの再起動が必要となります。

クラスファイル化したファンクションコンテナを使う場合は、Resource Service にソースファイルは必要ありません（クラスに該当するソースファイル(JavaScript ソースコード)は、削除してしまっても問題ありません）。
Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Foundation tools.[License Editor]]

i ntra-mart The Power for Enterprise Web Solution
ライセンサ
  • 形式
  • 解説
  • オプション
  • 例
  • その他

形式

java -cp ./bin/intramart.jar jp.co.intra_mart.bin.licedit

(bin\tools\licedit )

解説
jp.co.intra_mart.bin.licedit ツールは、intramart.jarアーカイブに含まれています。実行時には、intramart.jar からクラスがロードできるようにクラスパスを設定して下さい。（ServerManager を Windows にインストールしている場合には、bin/tools ディレクトリに licedit.bat というバッチファイルがインストールされています。このバッチファイルを利用することでクラスパスの設定等をしなくてもライセンサを実行することができます。）

jp.co.intra_mart.bin.licedit ツールを利用することで、intra-mart サーバを立ち上げていない状態でもライセンス登録が可能です。また、intra-mart サーバを運用中に jp.co.intra_mart.bin.licedit ツールでライセンス登録をすることもできますが、その場合はライセンス登録後に intra-mart サーバを再起動して下さい。

jp.co.intra_mart.bin.licedit ツールは、ライセンスを登録したり情報を閲覧することができます。また、アプリケーションズのライセンスも観覧、登録することができます。
ライセンスキーの投入モードでライセンスキーを入力することにより、フレームワークまたアプリケーションを自動で判別し、ライセンスを登録できます。

オプション
このコマンドに指定可能なオプションはありません。

例(Windows の場合)
コンソール画面でライセンス登録を行います。
コンソール画面でコマンドを入力してライセンサを起動したら、下記の要領で画面の指示に従いライセンスの登録・閲覧作業を行って下さい。
 Please choose a menu.
            (Please input an enter key after a number key)
  [1] Show the license.
  [2] License Registration.
  [3] Exit.
 ----------------------------------------

 #######################################################
 intra-mart intra-mart
     License ID: TRIAL Version
     Product-type ID: BS
     Product version: 4.0.0
     Serial ID: Trial License
     Install Date: Wed Feb 12 19:06:47 JST 2003
     Trial term: Sun Apr 13 19:06:47 JST 2003
     Max server process: 1.0
     Max user account: 5.0
 #######################################################

 *******************************************************
 イントラネット・スタートパック
     License ID: TRIAL Version
     Product-type ID: II
     Product version: 4.0.0
     Serial ID: Trial License
     Install Date: Sun Feb 16 14:05:26 JST 2003
     Trial term: Thu Apr 17 14:05:26 JST 2003
     Max user account: 5.0
 *******************************************************

 Please choose a menu.
            (Please input an enter key after a number key)
  [1] Show the license.
  [2] License Registration.
  [3] Exit.
 ----------------------------------------
3

C:\imart\bin>

その他
ライセンサでライセンスを登録した場合、intra-mart のすべてのサーバを再起動してください。サーバを再起動しないとライセンサで登録したライセンス情報は反映されません。

jp.co.intra_mart.bin.licedit ツールは、ServerManagerの動作している環境で実行して下さい。その他の環境で jp.co.intra_mart.bin.licedit ツールを利用してライセンス登録を行っても、システムに反映されません。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2005 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.]

TOP

intra-mart Version 5.0

MENU
Document

・セットアップ(インストール)
・予約語一覧
・データのインポート／エクスポート

Developer's Guide

ガイドライン-Programing Guide
  ・Application Runtime
  ・Resource Service
  ・Shared Memory Service
  ・Permanent Data Service
  ・Serialization Service
  ・Storage Service
  ・Schedule Service
基本的なツール
  ・JavaScriptコンパイラ
  ・ライセンサ
J2EEベース開発モデル
  ・コーディングルール
  ・JavaServerPages(Servlet)について
  ・J2EEフレームワーク
  ・J2EEフレームワーク Struts連携
  ・JMS　(BaseModule のみ)

・ユーザ・インタフェース層
    User Interface Layer
    画面共通モジュール１
    画面共通モジュール２
    J2EEフレームワーク（プレゼンテーション）
    J2EEフレームワーク（サービス）
    グラフ描画モジュール

・ビジネス・ロジック層
    Business Logic Layer
    アプリケーション共通モジュール
    メール連携モジュール
    アクセスセキュリティモジュール
    外部ソフトウェア接続モジュール
    ERP連携モジュール(BaseModule Advanced版のみ)
    IM-Curl

・業務基盤ツール
    Business Base Tool
    ワークフローモジュール
    バッチ管理モジュール
    ポータルモジュール

・ユニット
    Unit
    ファイル・アップロード
    ファイル・ダウンロード

    intra-mart 全体のAPIリスト

・アプリケーション共通マスタ
ページベース開発モデル
  ・コーディングルール
  ・Function Containerについて
  ・Presentation Pageについて

・ユーザ・インタフェース層
    User Interface Layer
      画面共通モジュール
      グラフ描画モジュール

・ビジネス・ロジック層
    Business Logic Layer
      アプリケーション共通モジュール
      メール連携モジュール
      ERP連携モジュール(BaseModule Advanced版のみ)
      IM-Curl

・業務基盤ツール
    Business Basic Tool
      ワークフローモジュール
      バッチ管理モジュール
      ポータルモジュール

・ユニット
    Unit
      カレンダー表示モジュール
      ツリー表示モジュール

・アプリケーション共通マスタ

・その他
      JAVAクラスの利用
      外部ライブラリの利用
      拡張 <IMART> タグ
クライアント・サイド API
    実数計算
    クッキー入出力
    ウィンドウ関連
    ＤＡＴＥ情報関連
外部ソフトウェア連携ソリューション
      統合検索ソリューション
その他
  ・カスタマイズ
  ・アクセスセキュリティモジュールを利用しないで
画面を構築する方法
Trouble shooting

・ | データベース
・ | ページベース開発モデルプログラム(Presentation Page)
・ | ページベース開発モデルプログラム(Function Container)


SapRepositoryManager (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapRepositoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
public class SapRepositoryManager
extends Object

JCO.Repository を管理クラス。

SapConnector インスタンスから JCO.Repository を返却するメソッド getJCORepository(SapConnector)を提供します。
接続設定ファイルで設定されたPool用の各ServerTypeごとに JCO.Repository を管理します。

メソッドの概要
static com.sap.mw.jco.JCO.Repository getJCORepository(SapConnector sapConnector)
Repository情報を生成もしくは、取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getJCORepository

public static com.sap.mw.jco.JCO.Repository getJCORepository(SapConnector sapConnector)
                                                      throws SAPAuthSystemException
Repository情報を生成もしくは、取得します。

キャッシュ内にRepository情報がある場合は、キャッシュよりRepository情報を取得します。
キャッシュ内にRepository情報がない場合は、Repository情報を生成します。

パラメータ:
sapConnector - SAPへの接続情報が格納されたオブジェクト
戻り値:
JCO.Repository 生成及び、取得したRepository情報
例外:
SAPAuthSystemException - 認証系システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の使用

jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


AccountRolePermissionSelector (5.0 J2EE-Base Programing Model API Specifications)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.permission
クラス AccountRolePermissionSelector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector
すべての実装インタフェース:
PermissionSelector
public class AccountRolePermissionSelector
extends Object
implements PermissionSelector

ユーザIDから有効なすべてのロールを取得するセレクタ。

選択条件としてのユーザIDからユーザが保有するすべてのロールIDを選択します。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
AccountRolePermissionSelector()
コンストラクタ。
メソッドの概要
Collection | doSelection(String groupId, String[] infos) 選択用情報を利用して選別された情報のリストを返却します。
void | init(Map param) インスタンスの初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountRolePermissionSelector

public AccountRolePermissionSelector()
コンストラクタ。

メソッドの詳細

doSelection

public Collection doSelection(String groupId,
                              String[] infos)
                       throws AccessSecurityException
選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトでなければなりません。

定義:
インタフェース PermissionSelector 内の doSelection
パラメータ:
groupId - ログイングループID
infos - 選択用情報(配列)
この情報を利用して、選別された情報のリストを作成して返却します。
戻り値:
選別された情報のリスト
例外:
AccessSecurityException

init

public void init(Map param)
インスタンスの初期化を行います。
このインスタンスが生成された時に1度だけコールされます。

定義:
インタフェース PermissionSelector 内の init
パラメータ:
param - XMLで定義されたPermissionSelectorに関連付けられたパラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector の使用 (5.0 J2EE-Base Programing Model API Specifications)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector の使用

jp.co.intra_mart.foundation.security.permission.AccountRolePermissionSelector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
5.0
前 次 フレームあり フレームなし


SapRepositoryManager (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapRepositoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
public class SapRepositoryManager
extends Object

JCO.Repository を管理クラス。

SapConnector インスタンスから JCO.Repository を返却するメソッド getJCORepository(SapConnector)を提供します。
接続設定ファイルで設定されたPool用の各ServerTypeごとに JCO.Repository を管理します。

メソッドの概要
static com.sap.mw.jco.JCO.Repository getJCORepository(SapConnector sapConnector)
Repository情報を生成もしくは、取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getJCORepository

public static com.sap.mw.jco.JCO.Repository getJCORepository(SapConnector sapConnector)
                                                      throws SAPAuthSystemException
Repository情報を生成もしくは、取得します。

キャッシュ内にRepository情報がある場合は、キャッシュよりRepository情報を取得します。
キャッシュ内にRepository情報がない場合は、Repository情報を生成します。

パラメータ:
sapConnector - SAPへの接続情報が格納されたオブジェクト
戻り値:
JCO.Repository 生成及び、取得したRepository情報
例外:
SAPAuthSystemException - 認証系システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の使用 (intra-mart ERP連携モジュール)

ERP連携モジュール API 仕様
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の使用

jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart(R)
ERP連携モジュール API 仕様
前 次 フレームあり フレームなし